SMTP 服务器

Windows Server 2008
SMTP 服务器

Windows Server 2008 SMTP 服务器使用 Internet 标准的简单邮件传输协议 (SMTP) 根据征求意见文档 (RFC) 2821 和 RFC 2822 中的规范传输和传递邮件。服务器还包括基于协议基本传递功能构建的增强功能。您可以使用选项控制邮件的路由和传递，以及提供安全通信。

有关具体任务的帮助，请参阅 SMTP 服务器步骤。

有关常规后台信息，请参阅 SMTP 服务器概念。

有关如何监视性能的信息，请参阅 SMTP 服务器维护。

有关问题解决方法的说明，请参阅 SMTP 服务器疑难解答。

有关 SMTP 服务器用户界面中选项卡和属性的信息，请参阅帮助参考。


SMTP 服务器步骤

SMTP 服务器步骤
SMTP 服务器 >

本节包含配置和使用 Windows Server 2008 SMTP 服务器功能的说明：

  • 安装 SMTP 服务器

  • 使用 Microsoft 管理控制台

  • 启动、停止或暂停 SMTP 虚拟服务器

  • 启动、停止或暂停 SMTP 服务

  • 配置 SMTP 虚拟服务器

  • 更改默认启动设置

  • 创建其他 SMTP 虚拟服务器

  • 设置连接

  • 启用协议日志记录

  • 设置群集虚拟服务器

  • 设置安全选项

  • 管理邮件

  • 传递邮件

  • 创建或删除域

  • 配置本地域

  • 配置远程域

  • 配置 LDAP 服务器连接

  • 设置与 ODBC 兼容的数据库


安装 SMTP 服务器
SMTP 服务器 > SMTP 服务器步骤 >

在运行 Windows Server 2008 的计算机上，默认情况下不会安装 SMTP 服务器功能。必须使用服务器管理器来安装 SMTP 服务器功能。

重要信息：
在运行 Windows Server 2008 的计算机上安装了 SMTP 服务器功能以后，在默认 SMTP 虚拟服务器上只启用匿名访问。有关详细信息，请参阅需要对传入连接进行身份验证。

步骤

安装 SMTP 服务器

  1. 在安装了 Windows Server 2008 标准版操作系统和 Windows Server 2008 企业版操作系统以后，将出现"初始配置任务"窗口。可以使用此工具执行此安装过程。但是，如果选择了"登录时不显示此窗口"框，则必须使用服务器管理器执行此过程。

    要手动打开服务器管理器，请单击"开始"，指向"管理工具"，然后单击"服务器管理器"。

  2. 在"服务器管理器"中，单击"服务器管理器"(服务器名)。在结果窗格中，查找"功能摘要"部分，然后单击"添加功能"打开"添加功能向导"。

  3. 在"选择功能"页上，选择"SMTP 服务器"。如果打开了一个对话框，其中显示"是否添加 SMTP 服务器所需的功能?"消息，请单击"添加所需功能"。然后，单击"下一步"。

  4. 在"确认安装选项"页上，单击"安装"。在"添加功能向导"安装 SMTP 服务器期间，将显示"安装进度"页。

  5. 在"安装结果"页上，确认显示了"安装成功"消息，然后单击"关闭"。
注意：
SMTP 服务器功能通过使用 Internet Information Services (IIS) 6.0 Manager 和配置 SMTP 虚拟服务器的属性进行管理。


使用 Microsoft 管理控制台

使用 Microsoft 管理控制台
SMTP 服务器 > SMTP 服务器步骤 >

SMTP 服务器功能的管理工具是 Internet Information Services (IIS) 6.0 管理器。IIS 6.0 管理器以 Microsoft 管理控制台 (MMC) 实现。它可以执行所有操作任务并且需要有本地网络 (LAN) 连接。有关如何启动 Microsoft 管理控制台的说明，请参阅启动 Microsoft 管理控制台。

管理工具默认情况下安装在运行 SMTP 服务器功能的计算机上。

要从远程计算机使用 Microsoft 管理控制台管理 SMTP 服务器，必须正在使用运行 Windows Server 2008 的计算机，必须将 IIS 6.0 管理器单元添加到 MMC 并且连接了需要管理的计算机。

注意：
必须授予操作人员适当的权限以使用 SMTP 服务器功能。有关详细信息，请参阅设置安全选项。


启动 Microsoft 管理控制台

启动 Microsoft 管理控制台
SMTP 服务器 > SMTP 服务器步骤 > 使用 Microsoft 管理控制台 >

要操作 SMTP 服务器功能，您必须从运行该功能的计算机上使用 Microsoft 管理控制台 (MMC) 的 Internet Information Services (IIS) 6.0 管理器管理单元。

重要信息：
在运行 Windows Server 2008 的计算机上，默认情况下不会安装 SMTP 服务器功能。有关如何安装 SMTP 服务器的说明，请参阅安装 SMTP 服务器。
注意：
如果远程计算机与 SMTP 服务器位于同一 LAN 中，您还可以使用 Microsoft 管理控制台通过该远程计算机管理简单邮件传输协议 (SMTP) 虚拟服务器。但是，该远程计算机必须运行 Windows Server 2008，而且您必须将 IIS 6.0 管理器管理单元添加到 MMC 中并连接至要管理的计算机。如果选择远程管理 SMTP，则请确保与正在运行 SMTP 的服务器的连接是安全的且不存在安全风险。

步骤

在运行 SMTP 服务器的计算机上运行 IIS 6.0 管理器

  1. 单击"开始"，指向"控制面板"，再指向"管理工具"，然后单击"Internet Information Services (IIS) 6.0 管理器"。

  2. 在控制台树中，展开 Server name。安装 SMTP 服务器功能时提供的虚拟服务器是 [SMTP 虚拟服务器 #1]。

查看或修改 SMTP 虚拟服务器的属性

  1. 选择要修改的 SMTP 虚拟服务器。

  2. 在"操作"菜单上，单击"属性"。

  3. 单击要查看或修改的选项卡。

  4. 根据需要更改选项。

    有关选项卡选项的详细信息，请参阅访问选项卡。


启动、停止或暂停 SMTP 虚拟服务器

启动、停止或暂停 SMTP 虚拟服务器
SMTP 服务器 > SMTP 服务器步骤 >

默认 SMTP 虚拟服务器在安装 SMTP 服务器功能时启动。您可以从 Microsoft 管理控制台中暂停、停止或重新启动该服务器。

注意：
您还可以启动、停止或暂停整个简单邮件传输协议 (SMTP) 服务。有关说明，请参阅启动、停止或暂停 SMTP 服务。但是，如果您使用了多个虚拟服务器，则停止 SMTP 服务会影响正在您计算机上运行的所有 SMTP 虚拟服务器。SMTP 服务停止后，您不能使用 Microsoft 管理控制台对任何 SMTP 虚拟服务器执行管理功能。

可以手动停止或启动 SMTP 服务。但是，如果该服务正在运行，您在停止、暂停或重新启动该服务时必须谨慎操作，尽可能减少对用户的影响。

重要信息：
请确保您的组织中只有受信任和合格的管理员才具有启动或停止 SMTP 虚拟服务器的必需权限。有关详细信息，请参阅设置安全选项。

本节介绍如何使用 Microsoft 管理控制台启动、停止和暂停 SMTP 虚拟服务器，包含以下主题：

  • 启动 SMTP 虚拟服务器

  • 暂停 SMTP 虚拟服务器

  • 停止 SMTP 虚拟服务器


启动 SMTP 虚拟服务器
SMTP 服务器 > SMTP 服务器步骤 > 启动、停止或暂停 SMTP 虚拟服务器 >

如果默认启动设置是"手动"，则可以使用 Microsoft 管理控制台启动简单邮件传输协议 (SMTP) 虚拟服务器。

步骤

启动 SMTP 虚拟服务器

  1. 在 Microsoft 管理控制台中，展开 SMTP 虚拟服务器的树状结构。

    有关如何启动 Microsoft 管理控制台的说明，请参阅启动 Microsoft 管理控制台。

  2. 单击 SMTP 虚拟服务器以将其选中。

  3. 在"操作"菜单上，单击"启动"。


暂停 SMTP 虚拟服务器
SMTP 服务器 > SMTP 服务器步骤 > 启动、停止或暂停 SMTP 虚拟服务器 >

可以暂停简单邮件传输协议 (SMTP) 虚拟服务器，以便进行配置更改和维护。暂停将阻止新客户端连接服务器。不过，虚拟服务器可以继续保持现有客户端的连接，并传递排队的邮件。

步骤

暂停 SMTP 虚拟服务器

  1. 在 Microsoft 管理控制台中，展开 SMTP 虚拟服务器的树状结构。

    有关如何启动 Microsoft 管理控制台的说明，请参阅启动 Microsoft 管理控制台。

  2. 单击以选择 SMTP 虚拟服务器。

  3. 在"操作"菜单上，单击"暂停"。


停止 SMTP 虚拟服务器
SMTP 服务器 > SMTP 服务器步骤 > 启动、停止或暂停 SMTP 虚拟服务器 >

可以停止简单邮件传输协议 (SMTP) 虚拟服务器，以便进行配置更改和维护。

步骤

停止 SMTP 虚拟服务器

  1. 在 Microsoft 管理控制台中，展开 SMTP 虚拟服务器的树状结构。

    有关如何启动 Microsoft 管理控制台的说明，请参阅启动 Microsoft 管理控制台。

  2. 单击以选择 SMTP 虚拟服务器。

  3. 在"操作"菜单上，单击"停止"。


启动、停止或暂停 SMTP 服务

启动、停止或暂停 SMTP 服务
SMTP 服务器 > SMTP 服务器步骤 >

在正运行 Windows Server 2008 的计算机上，简单邮件传输协议 (SMTP) 作为一项服务来运行。默认情况下，在安装 SMTP 服务器功能时，启动类型设置为自动。有关如何安装 SMTP 服务器功能的说明，请参阅安装 SMTP 服务器。

虽然一台计算机上仅可以使用一个 SMTP 服务，但您可以使用多个 SMTP 虚拟服务器。SMTP 服务运行时，您可以分别启动、停止或暂停各个虚拟服务器。有关详细信息，请参阅启动、停止或暂停 SMTP 虚拟服务器。

如果您使用了多个 SMTP 虚拟服务器，切记暂停或停止整个 SMTP 服务会影响所有的 SMTP 虚拟服务器。

启动 SMTP 服务后，该服务会接受新的传入连接请求。停止 SMTP 服务后，该服务不再接受新连接。暂停 SMTP 服务后，每个正在运行的 SMTP 虚拟服务器都会停止接受新连接，但是会继续为现有连接提供服务。

重要信息：
请确保您的组织中只有受信任和合格的管理员才具有启动或停止 SMTP 服务的必需权限。有关详细信息，请参阅设置安全选项。

步骤

使用管理工具启动、停止或暂停 SMTP 服务

  1. 单击"开始"，指向"管理工具"，然后单击"服务"。

  2. 在控制台树中，选择"服务(本地)"。

  3. 在结果窗格中，右键单击"简单邮件传输协议 (SMTP)"，然后单击"启动"、"停止"或"暂停"。
注意：
重新启动 SMTP 服务时，所有在您关闭该服务时已运行的 SMTP 虚拟服务器都会自动重新启动。但是，对于在服务关闭时已停止的 SMTP 虚拟服务器，即使在 SMTP 服务重新启动后，仍会处于停止状态。


配置 SMTP 虚拟服务器

配置 SMTP 虚拟服务器
SMTP 服务器 > SMTP 服务器步骤 >

简单邮件传输协议 (SMTP) 虚拟服务器具有两种标识功能：

  • 显示名称

  • IP 地址/TCP 端口组合

安装程序会为默认 SMTP 虚拟服务器分配一个 Microsoft 管理控制台显示名称。您可以保留名称 [SMTP 虚拟服务器 #1]，也可以按照以下步骤更改该名称。还可以选择将要与此 SMTP 虚拟服务器相关联的 IP 地址。

步骤

标识 SMTP 虚拟服务器

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后单击"操作"菜单上的"重命名"。

    有关如何启动 Microsoft 管理控制台的说明，请参阅启动 Microsoft 管理控制台。

  2. 如果要更改虚拟服务器的默认名称，请键入一个新名称。

    注意：
    命名 SMTP 虚拟服务器时，请勿使用扩展字符。

  3. 选择 SMTP 虚拟服务器，然后单击"操作"菜单上的"属性"。

  4. 在"IP 地址"中，选择此虚拟服务器的 IP 地址。SMTP 虚拟服务器可响应计算机上配置的所有 IP 地址的连接请求。要标识为虚拟服务器配置的每个 IP 地址的 TCP 端口，请单击"高级"。端口 25 是 SMTP 标准 TCP 端口，建议使用该端口。如果虚拟服务器与不同的 IP 地址相关联，则多个虚拟服务器可以使用端口 25。
注意：
更改 SMTP 虚拟服务器的配置时，可能需要使用"暂停"命令。有关如何暂停 SMTP 虚拟服务器的说明，请参阅暂停 SMTP 虚拟服务器。暂停操作可阻止新客户端连接，但是可使 SMTP 服务继续处理现有的客户端连接并传递队列中的邮件。


更改默认启动设置
SMTP 服务器 > SMTP 服务器步骤 >

您可以使用"管理工具"配置启动时 SMTP 服务的默认状态。

步骤

更改默认启动设置

  1. 单击"开始"，指向"管理工具"，然后单击"服务"。

  2. 在控制台树中，选择"服务(本地)"。

  3. 在结果窗格中，右键单击"简单邮件传输协议(SMTP)"，然后单击"属性"。

  4. 在"常规"选项卡中的"启动类型"下，选择"自动(延迟启动)"、"自动"、"手动"或"禁用"。


创建其他 SMTP 虚拟服务器

创建其他 SMTP 虚拟服务器
SMTP 服务器 > SMTP 服务器步骤 >

大多数情况下，您应只需要一个简单邮件传输协议 (SMTP) 虚拟服务器。但是，举例而言，如果您当前承载多个域并希望有多个默认域，则可创建多个 SMTP 虚拟服务器。对最终用户而言，每个 SMTP 虚拟服务器作为具有唯一 IP 地址/TCP 端口组合的独立服务器出现。

创建 SMTP 虚拟服务器时，会提示您输入根目录的路径。此目录必须是运行 SMTP 服务的计算机的本地目录。

注意：
确保您的组织中只有受信任和合格的管理员才具有创建新的 SMTP 虚拟服务器的必需权限。有关详细信息，请参阅设置安全选项。

步骤

使用 Microsoft 管理控制台创建新的 SMTP 虚拟服务器

  1. 如果 SMTP 虚拟服务器要使用新的 IP 地址，则可以通过在"开始"菜单中选择"控制面板"，然后单击"网络和共享中心"来配置一个 IP 地址。

    有关"网络和共享中心"的详细信息，请参阅 Windows Server 2008 文档。

  2. 配置完 IP 地址后，请在 Microsoft 管理控制台中选择一个现有 SMTP 虚拟服务器。然后，在"操作"菜单上，指向"新建"，再单击"虚拟服务器"。有关如何启动 Microsoft 管理控制台的说明，请参阅启动 Microsoft 管理控制台。

  3. 按照"新建 SMTP 虚拟服务器向导"上的说明进行操作。确保您选择了一个未被其他 SMTP 虚拟服务器占用的 IP 地址/TCP 端口组合。推荐的 TCP 端口为端口 25，它是 SMTP 标准 TCP 端口。只要多个虚拟服务器配置有不同的 IP 地址，它们就可使用同一 TCP 端口。

  4. 如果 SMTP 服务的默认启动设置被设置为"自动"，则新的 SMTP 虚拟服务器可自己启动。如果它不启动，是因为您选择的是已被占用的 IP 地址/TCP 端口组合。

  5. 配置此新的 SMTP 虚拟服务器。


设置连接

设置连接
SMTP 服务器 > SMTP 服务器步骤 >

将邮件发送至远程服务器或从其接收邮件，都会启动连接。

重要信息：
设置连接限制和规定连接超时可以使某些人难于启动拒绝服务攻击 (DoS) 或其他恶意攻击，以保护您的虚拟服务器免受攻击。
注意：
配置传入连接时，应指定在标识简单邮件传输协议 (SMTP) 虚拟服务器时，SMTP 服务用于接收传入邮件的 TCP 端口。有关如何标识 SMTP 虚拟服务器的说明，请参阅配置 SMTP 虚拟服务器。

步骤

配置传入连接

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"常规"选项卡上，选择"限制连接数不超过"复选框，然后设置以下选项。

选项 | 说明
限制连接数不超过 | 选中该复选框时，此选项指定传递传入邮件时的并发连接数。最小连接数为 1。如果未选中该复选框，则没有限制。默认值为无限制。
连接超时(分钟) | 此选项指定关闭非活动连接之前所允许的时间。默认为 10 分钟。

配置出站连接

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"传递"选项卡上，单击"出站连接"打开"出站连接"对话框。

  3. 在"出站连接"下，选中该复选框，然后设置以下选项。

选项 | 说明
限制连接数不超过 | 选中该复选框时，此选项指定可同时存在的、与所有远程域的同时出站连接的总数。默认连接数为 1000。最小值为 1。默认值为无限制。 此设置与"邮件"选项卡上的"限制每个连接的邮件数不超过"选项一起使用，可以提高系统性能。有关如何限制每个连接邮件数的详细信息和说明，请参阅限制每个连接的邮件数。
超时(分钟) | 此选项指定关闭非活动连接之前所允许的时间。默认为 10 分钟。
限制每个域的连接数不超过 | 选中该复选框时，此选项限制与任何单个远程域的连接数。默认连接数为 100。该值应小于或等于"限制连接数不超过"选项的值。
TCP 端口 | 此选项指定用于传出传输的 TCP 端口。默认为端口 25。传出端口设置与传入端口设置可以相同，也可以不同。

有关发送邮件所涉及的过程概述，请参阅SMTP 服务器概念。


启用协议日志记录

启用协议日志记录
SMTP 服务器 > SMTP 服务器步骤 >

协议日志可以跟踪简单邮件传输协议 (SMTP) 虚拟服务器通过网络从 SMTP 客户端接收的命令。您可以选择 SMTP 服务用来记录信息的日志记录格式。

设置日志文件时，请记住日志格式和默认文件名应与 Internet Information Services (IIS) 中的其他服务使用的日志格式和默认文件名相同。如果选择默认文件名，则所有服务的所有事务都记录在同一文件中。如果需要单独维护记录，可以为每个服务单独设置一个文件。如果将文件设置在与默认文件不同的位置，请务必将其存储在本地驱动器上，而不能保存在网络上。此外，由于要与 IIS 共享日志记录，因此某些文件名并不特定于 SMTP。

重要信息：
利用日志文件来审核服务器活动是一个不错的方法，不但可以检测是否有未经授权的外部用户试图访问您的虚拟服务器，还可以检测是否有内部用户尝试访问其无权访问的资源。有关此事件以及其他事件的详细信息，请参阅事件和错误消息中心。

有关事务日志记录和格式的详细信息，请参阅监视邮件事务。

步骤

启用使用了 ASCII 文本格式的日志记录

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"常规"选项卡上，选择"启用日志记录"。

  3. 在"活动日志格式"下拉菜单中，选择一个日志格式。

  4. 单击"属性"，然后在"常规"选项卡上指定"新建日志计划"。

    如果选择"每小时"、"每天"、"每周"或"每月"，将按照这些间隔新建日志文件。

    如果选择"不限制文件大小"，则只创建一个日志文件。

    如果选择"当文件大小达到"，则可以指定日志文件的最大大小，并在当前日志文件达到该大小时新建一个日志文件。

  5. 在"常规"选项卡上，请在日志文件目录下指定日志文件的存储位置。

  6. 如果选择了万维网联合会 (W3C) 扩展日志记录格式，请单击"高级"选项卡，然后选择要跟踪的扩展日志记录选项。

启用使用了 ODBC 格式的日志记录

  1. 设置与 ODBC 兼容的数据库。有关如何设置与 ODBC 兼容的数据库的说明，请参阅设置与 ODBC 兼容的数据库。

  2. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  3. 在"常规"选项卡上，选择"启用日志记录"。

  4. 在"活动日志格式"中，选择"ODBC 日志记录"。

  5. 单击"属性"，然后指定日志文件大小和位置。


设置群集虚拟服务器

设置群集虚拟服务器
SMTP 服务器 > SMTP 服务器步骤 >

故障转移群集是 Windows Server 2008 企业版操作系统的一项功能。有关如何安装故障转移群集的详细信息，请参阅 Windows Server 2008 企业版文档。

服务器群集是将一组协同工作的独立计算机系统（称作节点）作为单个系统使用，以确保关键任务应用程序和资源始终对客户端可用。服务器群集可以提供高可用性。简单邮件传输协议 (SMTP) 服务器群集提供的高可用性意味着如果一个虚拟服务器发生故障，则其工作会分解给群集中剩余的虚拟服务器。这可确保邮件服务不会中断。服务器群集的另一个好处是可以转移服务器资源故障，即在某个虚拟服务器发生故障时，另一个服务器会联机承担其角色。

在群集中，一个节点代表一个正在运行 Windows Server 2008 企业版且具备故障转移群集功能的系统。建议您创建一个新的虚拟服务器作为群集节点，而不是重新配置默认 SMTP 虚拟服务器。

有关故障转移群集和服务器群集的详细信息，请参阅"帮助和支持"。该文档包含有关如何设置和管理服务器群集的详细信息。

步骤

设置群集的 SMTP 虚拟服务器

  1. 如果需要，可将 SMTP 服务的默认启动设置更改为"手动"。有关如何更改默认启动设置的说明，请参阅更改默认启动设置。

  2. 在创建新的虚拟服务器前，请启动 Microsoft 管理控制台，右键单击默认 SMTP 虚拟服务器，然后单击"属性"。有关如何启动 Microsoft 管理控制台的说明，请参阅启动 Microsoft 管理控制台。

  3. 在"常规"选项卡上，单击"高级"。

  4. 在"IP 地址"下，单击"(全部未分配)"，然后单击"编辑"。

  5. 在"标识"对话框中，将 TCP 端口号从默认端口 25 更改为其他端口。所有未分配的端口都可以使用。更改此端口号很重要，这样可避免与您将要为群集创建的新 SMTP 虚拟服务器发生冲突。键入新的端口号（请确保该端口号是唯一的），然后单击"确定"。

  6. 新建 SMTP 虚拟服务器。有关说明，请参阅创建其他 SMTP 虚拟服务器。创建服务器后，您必须手动启动该服务器。请确保您在新虚拟服务器上使用了默认 TCP 端口（端口 25）。

    重要信息：
    进入新建 SMTP 虚拟服务器向导的"选择主目录"屏幕时，请确保键入将用于群集的共享资源的路径。请不要键入本地硬盘的路径。

  7. 运行"IIS 同步"命令可使服务器群集中您的节点与其他节点上的所有 IIS 信息同步。在命令提示符下，打开您节点下的 \Windows\System32\Inetsrv 目录，然后键入 iissync servername，其中 servername 是服务器群集中的另一个节点。有关"IIS 同步"命令的详细信息，请参阅您的 IIS 文档。

  8. 同步服务器群集节点后，可能仍需要检查新建 SMTP 虚拟服务器和默认虚拟服务器上的 TCP 端口号。具体来说，从服务器群集的其他节点查看本地节点时，请确保 TCP 端口设置与您在本地节点上的设置相同。在所有节点上，默认 SMTP 虚拟服务器都不能指向默认端口 25，而应将端口 25 分配给新的 SMTP 虚拟服务器。设置必须与要使用群集上每个节点的设置相同。

  9. 启动故障转移群集管理器。按向导操作并将资源类型与新的 SMTP 虚拟服务器相关联。

    注意：
    在"参数"对话框中，请确保从下拉菜单中选择了新的 SMTP 虚拟服务器，而不是选择了默认的 SMTP 虚拟服务器。有关故障转移群集管理器的详细信息，请参阅"帮助和支持"。


设置安全选项

设置安全选项
SMTP 服务器 > SMTP 服务器步骤 >

本节介绍以下可用的 SMTP 虚拟服务器安全选项：

  • 关于安全设置

  • 设置操作员权限

  • 需要对传入连接进行身份验证

  • 配置出站邮件的身份验证

  • 要求 TLS 加密

  • 设置 IP 对服务器的访问限制

  • 设置或删除虚拟服务器的中继限制


关于安全设置

关于安全设置
SMTP 服务器 > SMTP 服务器步骤 > 设置安全选项 >

您可以决定您所希望的简单邮件传输协议 (SMTP) 虚拟服务器的安全程度，并使用两个安全选项卡上的安全选项获取所需的保护级别。这两个选项卡上的设置适用于虚拟服务器上的所有域。

安全设置

选项卡 | 设置
安全 | 此选项指定具有运行 SMTP 服务的操作员权限的用户帐户。操作员可以配置 SMTP 虚拟服务器属性。
访问 | 此选项所包含的设置可用于要求对所有传入连接进行身份验证并使用传输层安全 (TLS)。您还可以授予或拒绝对特定计算机或网络的访问权限。


设置操作员权限

设置操作员权限
SMTP 服务器 > SMTP 服务器步骤 > 设置安全选项 >

可指定哪些用户帐户可以具有简单邮件传输协议 (SMTP) 虚拟服务器的操作员权限。设置了 Windows 用户帐户后，可通过从列表中选择帐户来授予权限。也可以通过从虚拟服务器操作员列表中删除帐户来撤消这些权限。

步骤

指派操作员权限

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"安全"选项卡上，单击"添加"打开"选择用户或组"对话框。

  3. 在"输入要选择的对象名称(示例)"框中键入一个 Windows 用户帐户名称，单击"检查名称"，然后单击"确定"。选中的帐户将出现在"操作员"中。

还可以从列在"操作员"中的 Windows 用户帐户中删除操作员权限。

删除操作员权限

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"安全"选项卡上，单击要删除的操作员。

  3. 单击"删除"。


需要对传入连接进行身份验证

需要对传入连接进行身份验证
SMTP 服务器 > SMTP 服务器步骤 > 设置安全选项 >

有三种可用的身份验证方法。您可以选择一种、二种方法或三种方法都选用。默认情况下，仅启用匿名访问。默认情况下，仅启用匿名访问以防止他人使用您的简单邮件传输协议 (SMTP) 虚拟服务器中继邮件。有关详细信息，请参阅设置或删除虚拟服务器的中继限制。

SMTP 虚拟服务器的默认邮件中继设置仅允许中继来自通过身份验证的用户的邮件。因此，要允许组织中的用户通过虚拟服务器发送邮件，必须首先对用户进行身份验证。选中"身份验证"对话框中的一种方法后，您的用户将可以发送邮件，同时未通过身份验证的用户将不能使用您的虚拟服务器中继邮件。

身份验证选项 | 说明
匿名访问 | 不需要帐户名或密码。
基本身份验证 | 使用明文形式发送帐户名和密码。指定一个 Windows 域，该域将附加到帐户名以进行身份验证。强烈建议您要求基本身份验证使用传输层安全性 (TLS) 加密，以避免未经授权检测到用户名和密码。
集成 Windows 身份验证 | 使用此选项对 Windows 帐户名和密码进行身份验证。

步骤

禁用传入邮件的身份验证

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"访问"选项卡的"访问控制"下，单击"身份验证"打开"身份验证"对话框。

  3. 选择"匿名访问"，然后单击来清除其他选项的剩余复选框。

设置传入邮件的明文身份验证

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"访问"选项卡的"访问控制"下，单击"身份验证"打开"身份验证"对话框。

  3. 选择"基本身份验证"。

  4. 在"默认域"中，键入 Windows 域名。此默认域与 SMTP 虚拟服务器的默认域不同。

使用集成 Windows 身份验证对传入邮件进行身份验证

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"访问"选项卡的"访问控制"下，单击"身份验证"打开"身份验证"对话框。

  3. 选择"集成 Windows 身份验证"。


配置出站邮件的身份验证

配置出站邮件的身份验证
SMTP 服务器 > SMTP 服务器步骤 > 设置安全选项 >

可以配置简单邮件传输协议 (SMTP) 虚拟服务器，使其提供接收服务器要求的身份验证凭据。可使用三种类型的身份验证：匿名访问、基本身份验证（明文）和集成 Windows 身份验证。匿名访问不要求提供用户名和密码。使用基本身份验证选项时，用来对您所连接的服务器进行身份验证的帐户名称和密码将以明文方式传输。集成 Windows 身份验证选项要求提供 Windows 帐户名称和密码。

可针对特定的远程域改写为 SMTP 虚拟服务器设置的"出站安全"选项。在设置访问单个地址的例外时，您可以设置虚拟服务器身份验证级别来处理大多数传输。下表说明常见的配置方案。

注意：
有关如何加密传出邮件的信息，请参阅要求 TLS 加密。

SMTP 传输 | 身份验证选项
邮件常常被发送到多个地址。 | 禁用 SMTP 虚拟服务器的身份验证。如果由于身份验证要求导致尝试传送邮件到地址空间失败，请为该地址空间创建一个远程域条目。然后，以接收服务器要求的级别启用该远程域的身份验证。
邮件常常被发送到一个地址，需要进行身份验证。 | 确定进行连接时所需的身份验证级别。然后，使用同一级别为 SMTP 虚拟服务器启用身份验证。如果要将邮件发送到其他地址，设置远程域以设置不同的身份验证选项。如果使用此选项，使用的帐户名称可能是标识设置为智能主机的计算机的帐户名称。

步骤

禁用出站邮件的身份验证

  1. 在"传递"选项卡上，单击"出站安全"打开"出站安全"对话框。

  2. 单击"匿名访问"。

  3. 清除所有其他选项。

为出站邮件设置基本身份验证

  1. 在"传递"选项卡上，单击"出站安全"打开"出站安全"对话框。

  2. 单击"基本身份验证"。

  3. 在"用户名"和"密码"下，键入能授予您对要连接的计算机的访问权限的帐户名称和密码。
重要信息：
如果基本身份验证是您的唯一身份验证方法，强烈建议您还要求使用传输层安全性 (TLS) 加密，以避免未经授权检测到用户名和密码。

为传出邮件设置集成 Windows 身份验证

  1. 在"传递"选项卡上，单击"出站安全"打开"出站安全"对话框。

  2. 选择"集成 Windows 身份验证"。

  3. 在"帐户"和"密码"下，键入能授予您对要连接的计算机的访问权限的 Windows 帐户名称和密码。


要求 TLS 加密

要求 TLS 加密
SMTP 服务器 > SMTP 服务器步骤 > 设置安全选项 >

您可以要求所有客户端都使用传输层安全 (TLS) 加密（一种类似于安全套接字层 (SSL) 的通用安全协议）连接到简单邮件传输协议 (SMTP) 虚拟服务器。该选项可确保连接的安全，但并不用于身份验证。

重要信息：
当您要求对虚拟服务器启用基本身份验证时，强烈建议您同时使用 TLS 加密。如果不进行加密，用户名和密码会很容易被截取。

若要为 SMTP 虚拟服务器使用 TLS 加密，在运行 SMTP 服务器功能的 Windows Server 2008 计算机的信任证书存储区中必须已存在一个证书。证书必须颁发给计算机的完全限定域名 (FQDN)。如果将证书颁发给 IP 地址或主机名，则该证书不能用于为 SMTP 服务器通信提供 TLS 加密。默认情况下，Windows 证书颁发机构颁发采用 128 位加密的证书。所连接的客户端也必须能够支持 128 位加密，否则邮件将被退回，同时传递一份未送达报告 (NDR)。

执行下列步骤，可以对 SMTP 虚拟服务器上的所有客户端会话以及远程服务器上的所有会话启用 TLS 加密。

步骤

要求对所有 SMTP 虚拟服务器通信启用 TLS 加密

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"访问"选项卡中的"安全通信"下，选中"要求 TLS 加密"复选框。
注意：
还有其他两个可用的 TLS 选项。若要为所有出站连接使用 TLS，单击"传递"选项卡上的"出站安全"，然后单击"TLS 加密"。同样，如果您经常连接的服务器要求为所有传入连接使用 TLS，您可以创建一个远程域，然后在此远程域属性"常规"选项卡中单击"出站安全"，并选择"TLS 加密"。


安装用于 TLS 加密的服务器证书

安装用于 TLS 加密的服务器证书
SMTP 服务器 > SMTP 服务器步骤 > 设置安全选项 >

本主题说明如何安装服务器证书为 Windows Server 2008 SMTP 服务器功能提供传输层安全性 (TLS) 加密。可以要求所有客户端都使用 TLS 加密来连接简单邮件传输协议 (SMTP) 虚拟服务器。TLS 是一种协议，通过该协议，两个应用程序可通过网络进行隐秘而安全的通信。TLS 对通信进行加密，可以让客户端对服务器进行身份验证，也可以选择让服务器对客户端进行身份验证。TLS 是更安全的安全套接字层 (SSL) 协议版本。

若要为 SMTP 虚拟服务器使用 TLS 加密，运行 SMTP 服务器功能的 Windows Server 2008 计算机的信任证书存储区中必须有一个证书。该证书必须颁发给计算机的完全限定域名 (FQDN)。如果将证书颁发给 IP 地址或主机名，则该证书不能用于为 SMTP 服务器通信提供 TLS 加密。默认情况下，Windows 证书颁发机构 (CA) 将颁发采用 128 位加密的证书。所连接的客户端也必须能够支持 128 位加密，否则邮件将被退回，同时提供一份未送达报告 (NDR)。

请使用下列过程之一来安装服务器证书。如果您具有联机 CA，如 Windows Server 2008 企业 CA，则会立即颁发该证书。如果您具有脱机 CA，如 Windows Server 2008 独立 CA 或第三方 CA，则必须请求证书，然后安装证书文件。如果您正与其进行通信的服务器不要求进行 CA 验证，则可以通过 TLS 事务为 SMTP 创建自签名证书。如果要求进行 CA 验证，则使用自签名证书会导致 TLS 协商失败。

过程

在具有联机 CA 时，请求并安装服务器证书，为所有 SMTP 虚拟服务器通信提供 TLS 加密

  1. 依次单击"开始"、"运行"，在"打开"文本字段中键入 MMC，然后按 Enter。此时将打开 Microsoft 管理控制台 (MMC)。

  2. 单击"文件"菜单，然后单击"添加/删除管理单元"。

  3. 从"可用的管理单元"菜单中选择"证书"，然后单击"添加>"。在"证书管理单元"对话框中，选择"计算机帐户"，然后单击"完成"。单击"确定"。

  4. 展开"证书(本地计算机)"。选择"个人"。单击鼠标右键，然后选择"所有任务"和"请求新证书"。此时将启动证书注册向导。

  5. 在"开始之前"页上，单击"下一步"。

  6. 在"请求证书"页上，选中"算计机"旁边的框。.单击"详细信息"旁边的双 V 形图标，然后选择"属性"。

  7. 在"常规"选项卡上，为证书键入友好的名称和说明。

  8. 在"主题"选项卡的"主题名称"部分，使用"类型"下拉菜单选择"公用名"。在"值"字段中，键入服务器的 FQDN。单击"添加>"。在"备用名称"部分中，使用"类型"下拉菜单选择"DNS"。在"值"字段中，键入服务器的 FQDN。单击"添加>"。

  9. 在"扩展"选项卡中，单击"扩展密钥用法(应用程序策略)"旁边的双 V 形图标。确定"服务器身份验证"选项已选中。

  10. 在"证书颁发机构"选项卡中，选择将颁发证书的 CA。

  11. 单击"确定"保存全部更改并关闭"证书属性"。

  12. 单击"请求证书"对话框中的"注册"。单击"完成"关闭证书注册向导。

在具有脱机 CA 时，请求并安装服务器证书，为所有 SMTP 虚拟服务器通信提供 TLS 加密

  1. 依次单击"开始"、"管理工具"，然后选择"Internet 信息服务 (IIS) 管理器"打开 IIS 7.0 管理器。

  2. 选择服务器节点。

  3. 在"功能"窗格中，选择"服务器证书"。在"操作"窗格中，选择"打开功能"。

  4. 在"操作"窗格中，选择"创建证书请求"。此时将启动证书请求向导。

  5. 在"可分辨名称属性"页中，完成所有字段，然后单击"下一步"。

  6. 在"加密服务提供程序属性"页中，确定"Microsoft RSA SChannel 加密服务提供程序"已选中，"位长度"已设置为 1024。单击"下一步"。

  7. 在"文件名"页中，定位到文件要保存到的位置，并提供文件的名称。文件的扩展名为 .txt。单击"完成"。

  8. 将文件提交给 CA。管理员颁发了证书后，会为您返回一个扩展名为 .cer 的文件。

  9. 在 IIS 管理器中，选择服务器节点。在"功能"窗格中，选择"服务器证书"。在"操作"窗格中，选择"完成证书请求"。

  10. 在"指定证书颁发机构响应"页中，键入路径和 *.cer 文件的名称，或浏览到文件位置，选择文件，然后单击"打开"。单击"确定"安装证书。

创建并安装自签名的服务器证书为所有 SMTP 虚拟服务器通信提供 TLS 加密

  1. 依次单击"开始"、"运行"，在"打开"文本字段中键入 cmd，然后按 Enter。此时将打开一个命令行窗口。

  2. 键入下列命令，然后按 Enter。

    复制代码
    makecert -r -pe -n "CN=ServerName" -sky exchange -ss my -sr LocalMachine
    注意：
    若要获得有关 makecert.exe 程序的详细信息，请在命令提示符下键入 makecert -? 以查看基本选项，或键入 makecert -! 查看扩展选项。

验证证书的安装是否正确以及 SMTP 虚拟服务器是否识别该证书

  1. 依次单击"开始"、"管理工具"，然后选择"Internet 信息服务 (IIS) 6.0 管理器"打开 IIS 6.0 管理器。

  2. 选择一个 SMTP 虚拟服务器，单击鼠标右键，然后选择"属性"。

  3. 在 SMTP 虚拟服务器属性中，选择"访问"选项卡。如果证书安装正确，会在"安全通信"部分中显示消息"找到 TLS 证书，其截止日期为：MM/DD/YYYY"，并且"要求 TLS 加密"复选框是可用的。


设置 IP 对服务器的访问限制

设置 IP 对服务器的访问限制
SMTP 服务器 > SMTP 服务器步骤 > 设置安全选项 >

对于特定的 IP 地址，可以授予或拒绝它对简单邮件传输协议 (SMTP) 虚拟服务器的访问。默认情况下，所有 IP 地址都可访问 SMTP 虚拟服务器。可通过指定单个地址、使用同一子网掩码的一组地址或一个域名来设置限制。

步骤

设置 IP 地址访问限制

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"访问"选项卡中的"连接控制"下，单击"连接"打开"连接"对话框。

  3. 选择"仅以下列表"或"以下列表除外"。

  4. 若要在列表中添加计算机，请单击"添加"。将打开"计算机"对话框。

    要指定单个 IP 地址，单击"单个计算机"并输入一个 IP 地址。

    要指定一组地址，单击"计算机组"并输入一个子网地址和一个子网掩码。

    要指定一个域，单击"域"并输入域名。单击"确定"。

  5. 要从计算机的列表中删除列表项，请选择该项然后单击"删除"。


设置或删除虚拟服务器的中继限制

设置或删除虚拟服务器的中继限制
SMTP 服务器 > SMTP 服务器步骤 > 设置安全选项 >

默认情况下，SMTP 服务器会阻止计算机通过虚拟服务器中继不需要的邮件。要启用通过简单邮件传输协议 (SMTP) 虚拟服务器的中继访问，请单击"访问"选项卡上的"中继"。默认情况下，除满足"身份验证"对话框中指定的身份验证要求的计算机外，会阻止其他所有计算机，可通过单击"访问"选项卡上的"身份验证"查看身份验证要求。

还可以允许将邮件中继至特定的远程域。有关详细信息，请参阅配置远程域。域设置会覆盖 SMTP 虚拟服务器的设置。

注意：
如果虚拟服务器位于 Internet，应禁用中继以避免传播未经请求的电子邮件。

步骤

删除虚拟服务器的中继限制

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"访问"选项卡的"中继限制"下，单击"中继"。此时将打开"中继限制"对话框。

  3. 单击"仅以下列表"或"以下列表除外"。

  4. 单击"添加"打开"计算机"对话框，并向您在步骤 3 中选择的全局访问选项中添加例外。

可以在"中继限制"对话框中指定下列选项。

选项 | 说明
仅以下列表 | 仅列表中的计算机可以通过 SMTP 虚拟服务器中继邮件。默认情况下，此选项会与"不管上表中如何设置，所有通过身份验证的计算机都可以进行中继"一同设置。由于全新安装 Windows Server 2008 时列表为空，因此这意味着默认情况下仅通过身份验证的用户可以中继邮件。
以下列表除外 | 除列表中的计算机外，所有计算机都可以通过 SMTP 虚拟服务器中继邮件。
添加和删除 | 对于已授权或已拒绝中继访问的计算机，此选项可以在其列表中添加或删除条目。
不管上表中如何设置，所有通过身份验证的计算机都可以进行中继 | 此选项允许满足"身份验证"对话框中设置的身份验证要求的计算机将邮件中继到 SMTP 虚拟服务器。默认情况下已设置此选项。


管理邮件

管理邮件
SMTP 服务器 > SMTP 服务器步骤 >

本节介绍如何设置连接限制以使性能最大化，如何设置邮件大小和收件人数的限制，以及如何管理未送达邮件，包含以下主题：

  • 限制每个连接的邮件数

  • 设置邮件大小限制

  • 设置收件人限制

  • 存储 NDR


限制每个连接的邮件数

限制每个连接的邮件数
SMTP 服务器 > SMTP 服务器步骤 > 管理邮件 >

可限制在单个连接中发送的邮件数。限制每个连接的邮件数提供了一种提高系统性能的方法，即使用多个连接向远程域发送邮件。达到设置的限制时，会自动打开一个新连接继续传输，直到所有的邮件都已送达。

例如，如果您通常向某个远程域发送许多邮件，可将"限制每个连接的邮件数不超过"设置为一个相对较小的值，如 20。因此，当在一个会话中发送 100 封邮件时，SMTP 服务会在发送前 20 封邮件后立即打开一个新连接，发送完接下来的 20 封邮件后再打开另一个连接，依此类推。在这种情况下，同时会有多达五个连接向一个目的地传递排队的邮件。邮件传递的速度可能会更快，因为不是在一个连接上传递一个长邮件流，而是同时传递较少的邮件。

要确定该限制的值，请检查系统监视器中 SMTP Server 对象的"发送邮件数/秒"性能计数器。"限制每个连接的邮件数不超过"的值应小于该性能计数器指示的值。如果该计数器指示值 30，而您将最大连接设置为 50，则不会打开同步连接，因为该服务器每秒发送的邮件不会超过 30 封。此时的工作方式就好像这些邮件是以一个长邮件流通过一个连接来发送的。该设置仅影响出站邮件。可用它来增加服务器输出速度。不过，它并不影响其他服务器处理传入邮件的速度。

步骤

限制在一个连接中发送的邮件数

  1. 在 Microsoft 管理控制台中，选择简单邮件传输协议 (SMTP) 虚拟服务器，然后单击"操作"菜单中的"属性"。

  2. 在"邮件"选项卡中，选择"限制每个连接的邮件数不超过"，并在框中键入一个值。默认值是 20。


设置邮件大小限制
SMTP 服务器 > SMTP 服务器步骤 > 管理邮件 >

存在以下两个邮件大小限制设置：

  • 邮件大小限制 这是虚拟服务器的首选邮件限制。它是 SMTP 服务将公布为简单邮件传输协议 (SMTP) 虚拟服务器可接受的最大邮件大小。如果邮件客户端发送一个超过此限制的邮件，该客户端会收到错误。如果远程服务器支持 EHLO，则当它连接到 SMTP 虚拟服务器时将能检测到公布的最大邮件大小值，并且不会尝试传送超过此限制的邮件。相反，它会将一份未送达报告 (NDR) 发送给该邮件的发件人。不支持 EHLO 的远程服务器会尝试发送超过此大小限制的邮件，但如果邮件未通过，则会向发件人发送一份 NDR。

  • 会话大小限制 这是整个连接期间可接受的最大数据量。它是在连接期间发送的所有邮件的总和（仅适用于邮件正文）。

步骤

设置邮件大小限制

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"邮件"选项卡上，选择"邮件大小限制(KB)"，然后键入一个值（以 KB 为单位）用作邮件的最大大小。默认值为 2,048 KB。最小值为 1 KB。

  3. 在"邮件"选项卡上，选择"会话大小限制(KB)"，然后键入一个值指示特定连接中所有邮件的最大总大小（以 KB 为单位）。该数字始终大于最大邮件大小，应谨慎设置，因为连接邮件传输代理 (MTA) 可能会重复地提交邮件。默认大小为 10,240 KB。该值应大于或等于为"邮件大小限制(KB)"输入的值。


设置收件人限制
SMTP 服务器 > SMTP 服务器步骤 > 管理邮件 >

您可以为通过一个连接发送的一封邮件指定最大收件人数。默认值为 100，该值是在征求意见文档 (RFC) 821 中指定的最小值。多数客户端会在收到错误消息后退回邮件，同时传递一份未送达报告 (NDR)。这表示收件人已超过最大收件人数。但是简单邮件传输协议 (SMTP) 服务在此情况下不会退回邮件，而是立即打开一个新连接，为其余收件人处理邮件。例如，如果收件人限制设置为 100，而一封邮件有 105 个收件人，则在一个连接中会将该邮件传递给前 100 个收件人。然后，服务会打开一个新连接，为其余五个收件人处理邮件。

步骤

设置收件人限制

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"邮件"选项卡上的"限制每封邮件的收件人数不超过"中，键入一个表示收件人限制的数字。若不想应用任何限制，可单击以清除该复选框。


存储 NDR

存储 NDR
SMTP 服务器 > SMTP 服务器步骤 > 管理邮件 >

邮件无法传递时，简单邮件传输协议 (SMTP) 服务会将其退回给发件人，同时传递一份未送达报告 (NDR)。您还可以指定将 NDR 的副本发送到您所选择的位置。如果 NDR 无法传递给发件人，则该邮件的副本会存放在死信目录中。

所有 NDR 都会按照与其他邮件相同的传递流程（包括尝试重新发送邮件）进行传递。如果 NDR 达到重试限制而无法传递给发件人，则该邮件的副本会存放在死信目录中。存放在死信目录中的邮件无法传递也无法退回。

步骤

设置 NDR 的存储位置

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"邮件"选项卡的"将未送达报告的副本发送到"中，键入希望用于存储 NDR 副本的邮箱的电子邮件地址。该地址可以是任何有效的 SMTP 电子邮件地址，不过并非必须要键入。要禁用此功能，请清除该文本框。

  3. 在"死信目录"中，键入希望用于存储无法送达的邮件的目录。默认位置为根目录:\inetpub\mailroot\Badmail。单击"浏览"可选择其他文件夹。您还可以指定其他目录，条件是该目录与 SMTP 服务位于同一台计算机上。


传递邮件

传递邮件
SMTP 服务器 > SMTP 服务器步骤 >

打开连接且接收服务器已确认准备好接收数据后，就可以发送邮件进行传递了。本节介绍确定传递方式的设置，这些设置包括路由选项和尝试传递的次数，包含以下主题：

  • 关于邮件传递选项

  • 配置重试次数和间隔

  • 设置最大跃点计数

  • 设置虚拟域

  • 设置完全限定域名

  • 配置智能主机

  • 启用反向 DNS 查找


关于邮件传递选项

关于邮件传递选项
SMTP 服务器 > SMTP 服务器步骤 > 传递邮件 >

使用"传递"选项卡设置所有的传递选项和路由选项。设置可分为下列几类。

路由选项

可以使用下列路由选项：

  • 智能主机 此选项指定路由所有传出邮件的服务器。

  • 最大跃点计数 此选项确定系统在将邮件视为无法传递前，路由邮件所通过的最大服务器数。

  • 完全限定域名 此选项明确指定在邮件交换 (MX) 记录中使用的地址。

传输选项

可以使用下列传输选项：

  • 重试间隔 此选项确定系统在将邮件视为无法传递前，重新发送邮件的次数及间隔。

  • 延迟通知 此选项确定在向邮件发件人发送通知前，邮件重试的时间。

  • 过期超时 此选项确定系统在将邮件视为无法传递前，SMTP 服务继续尝试传递邮件的时间。

安全选项

可以使用下列安全选项：

  • 出站安全 此选项允许您对传出的邮件使用身份验证和传输层安全性 (TLS) 加密。

  • 反向 DNS 查找 此选项可以验证邮件实际上是否来自"发件人"字段中列出的计算机和域。

  • 虚拟域 此选项会使用不同的域名来替换协议中任何邮件"发件人"行所使用的本地域名。该域名是您要标记在传出邮件上的名称。


配置重试次数和间隔

配置重试次数和间隔
SMTP 服务器 > SMTP 服务器步骤 > 传递邮件 >

如果第一次尝试传递邮件时失败，则简单邮件传输协议 (SMTP) 服务会在指定时间后从队列目录中重新发送该邮件。可以设置传递尝试间隔。在达到过期超时之前，将一直以指定的时间间隔尝试传递。达到重试限制后，系统在将邮件返回到发件人的同时会向其发送未送达报告 (NDR)，还会将邮件和 NDR 副本发送到指定位置。该 NDR 将放置在队列目录中并遵循与邮件相同的传递过程。如果 NDR 达到最大重试次数，系统会将 NDR 和邮件发送到死信目录。

步骤

配置重试次数和间隔设置

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 单击"传递"选项卡。

  3. 在"第一次重试间隔(分钟)"中，键入一个值作为重试传递邮件之前的等待时间。默认值为 15 分钟。

  4. 在"第二次重试间隔(分钟)"中，键入一个值作为重试传递邮件之前的等待时间。默认值为 30 分钟，即"第一次重试间隔(分钟)"中的值之后的 30 分钟。

  5. 在"第三次重试间隔(分钟)"中，键入一个值作为重试传递邮件之前的等待时间。默认值为 60 分钟，即"第二次重试间隔(分钟)"中的值之后的 60 分钟。

  6. 在"后续重试间隔(分钟)"中，键入一个值作为后续传递尝试之间的等待时间。默认值为 240 分钟。

延迟通知

考虑到网络延迟，您可以设置一个延迟时间，该时间是系统向邮件发件人发送传递状态通知之前的等待时间。如果在延迟通知超时间隔内没有成功传递邮件，则会向发件人传递一个延迟 DSN。最小值为 1 分钟，默认值为 12 小时，最大值为 9,999 天。使用该值字段旁边的下拉菜单可以选择分钟、小时或天。

过期超时

过期超时用来指定 SMTP 服务可以继续尝试传递邮件的最长时间。如果在过期超时时间间隔内没有成功传递邮件，则会向发件人传递一个 NDR。最小值为 1 分钟。默认值为 2 天。最大值为 9,999 天。使用该值字段旁边的下拉菜单可以选择分钟、小时或天。


设置最大跃点计数
SMTP 服务器 > SMTP 服务器步骤 > 传递邮件 >

邮件在传递时可能要经过多个服务器的中继才能到达其最终目标。可以指定邮件经过的服务器数目，称为跃点计数。

设置好最大跃点计数以后，简单邮件传输协议 (SMTP) 虚拟服务器将对邮件头"接收"行中列出的跃点进行计数。"接收"字段的数目超过最大跃点计数设置时，该邮件将退回发件人，并附带一个未送达报告 (NDR)。

步骤

设置最大跃点计数

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"传递"选项卡上，单击"高级"打开"高级传递"对话框。

  3. 在"最大跃点计数"中，键入源服务器和目标服务器之间邮件可以接受的跃点数。默认值为 15 个跃点。


设置虚拟域
SMTP 服务器 > SMTP 服务器步骤 > 传递邮件 >

虚拟域会替换简单邮件传输协议 (SMTP) 邮件头的收件人字段中使用的本地域名。此类替换仅发生在第一个跃点上。

步骤

设置虚拟域

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"传递"选项卡上，单击"高级"打开"高级传递"对话框。

  3. 在"虚拟域"中，键入要在邮件头中显示的域名而非域的实际名称。

注意：
所有对此类邮件的答复都将通过使用该虚拟域的 SMTP 虚拟服务器来路由。


设置完全限定域名
SMTP 服务器 > SMTP 服务器步骤 > 传递邮件 >

电子邮件域必须可以通过域名系统 (DNS) 进行解析。两种 DNS 记录用于解析电子邮件域。在大多数情况下，邮件交换器 (MX) 记录被设置为将一个电子邮件域与一个或多个服务该域的简单邮件传输协议 (SMTP) 虚拟服务器的完全限定域名 (FQDN) 相关联。MX 记录中引用的每个 SMTP 服务器都必须有一条地址 (A) 记录。A 记录将给定 FQDN 映射到其 IP 地址。

可以只为一个电子邮件域设置一条 A 记录。在这种情况下，A 记录会将域映射到 IP 地址，或者映射到 SMTP 虚拟服务器或服务该域的服务器的地址。但是，建议添加 MX 记录而不是只使用 A 记录，因为使用 MX 记录，SMTP 管理员可以指定客户端向该电子邮件域发送邮件所用的服务器有序列表。SMTP 服务在检查 A 记录之前始终首先查看 MX 记录。因此，在虚拟服务器上设置 MX 记录可以提高性能。在某些情况下，A 记录还用于其他用途（例如 HTTP），而 MX 记录仅用于 SMTP 服务器。MX 记录使服务器可以处理 http://example.com。HTTP 客户端使用 A 记录。MX 记录还可使其他服务器可以处理 someone@example.com。SMTP 客户端使用 MX 记录。

SMTP 服务提供指定 FQDN 的两个选项。可以使用在"控制面板"中"系统属性"的"计算机名称"选项卡上指定的完整计算机名，或者为正在配置的 SMTP 虚拟服务器指定唯一 FQDN。

启动时，在"系统属性"的"计算机名称"选项卡上指定的名称将自动用于 SMTP 虚拟服务器的 FQDN。如果手动或通过加入域更改名称，下次重新启动计算机时该新名称将自动用于 FQDN。不需要执行任何操作来更新虚拟服务器的 FQDN。

要取消自动使用"计算机名称"选项卡上的计算机和域名，可以访问"传递"选项卡更改"高级传递"对话框中的 FQDN。这样，SMTP 服务将使用指定的名称而不是"计算机名称"选项卡上指定的名称。

步骤

设置完全限定域名

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"传递"选项卡上，单击"高级"打开"高级传递"对话框。

  3. 在"完全限定域名"中，输入 FQDN。


配置智能主机

配置智能主机
SMTP 服务器 > SMTP 服务器步骤 > 传递邮件 >

可以通过智能主机来路由目标为远程域的所有传出邮件，而不是使用 DNS 解析将这些邮件直接路由到域。这样，您可使邮件沿着可能比其他路由更直接或更节省费用的连接传送。智能主机与远程域的路由域选项相似。二者的差别是指定了智能主机以后，所有的传出邮件都路由到该服务器。而使用路由域时，只有目标为远程域的邮件才会路由到特定服务器。

重要信息：
确保您指定的智能主机是安全的且由受信任的权威部门管理，尤其是在转发机密信息时。

如果设置了智能主机，仍然可以为远程域指定不同的路由。路由域设置将覆盖智能主机设置。

注意：
您可以通过完全限定域名 (FQDN) 或 IP 地址来标识智能主机。但是，如果更改了 IP 地址，必须更改每台虚拟服务器上的 IP 地址。如果使用 IP 地址，请用方括号 ([ ]) 将地址括起来，以提高系统性能。SMTP 服务首先会检查服务器名，然后再检查 IP 地址。括号可将值标识为 IP 地址，因此不会进行 DNS 查找。

步骤

设置智能主机

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"传递"选项卡上，单击"高级"打开"高级传递"对话框。

  3. 在"智能主机"中，键入智能主机服务器的 FQDN 或 IP 地址。

  4. 如果希望 SMTP 服务在将远程邮件转发到智能主机服务器之前尝试直接传递该远程邮件，请选中"发送到智能主机之前尝试直接传递"复选框。默认设置为将所有远程邮件发送到智能主机而不尝试直接传递。


启用反向 DNS 查找
SMTP 服务器 > SMTP 服务器步骤 > 传递邮件 >

如果选择此选项，简单邮件传输协议 (SMTP) 服务将尝试验证客户端的 IP 地址是否与客户端以 EHLO/HELO 命令提交的主机/域匹配。如果成功执行了反向 DNS 查找，"接收"标头将保持不变。如果验证不成功，将在该邮件的"接收"标头中的 IP 地址之后显示"未验证"。如果反向 DNS 查找失败，将在该邮件的"接收"标头中显示"RDNS 失败"。

注意：
由于此功能将验证所有的传入邮件地址，其使用可能会影响 SMTP 服务性能。清除复选框可禁用此功能。

步骤

启用反向 DNS 查找

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"传递"选项卡上，单击"高级"打开"高级传递"对话框。

  3. 选中"对传入邮件执行反向 DNS 查找"复选框。


创建或删除域

创建或删除域
SMTP 服务器 > SMTP 服务器步骤 >

SMTP 服务器中的域与域名系统 (DNS) 域和 Microsoft Windows 域不同。在简单邮件传输协议 (SMTP) 虚拟服务器上配置的域用于组织邮件以便进行传递。

本节提供了有关域和基本步骤的常规信息。本节包括：

  • 关于域

  • 创建域

  • 删除域

有关详细信息，请参阅下列主题：

  • 有关本地域的信息，请参阅配置本地域。

  • 有关远程域的信息，请参阅配置远程域。


关于域

关于域
SMTP 服务器 > SMTP 服务器步骤 > 创建或删除域 >

简单邮件传输协议 (SMTP) 虚拟服务器至少有一个域：默认本地域。可以添加更多域并其配置为本地域或远程域。除默认域以外，可以删除任何域。

本地域

本地域是由本地 SMTP 服务器提供服务的域名系统 (DNS) 域。任何具有本地域名的邮件都必须本地传递到默认域的投递目录，或者连同未送达报告 (NDR) 退回给发件人。本地域也称为服务域或支持域。具有本地域名的电子邮件地址通常称为本地地址。

如果域是本地的，可以将其指定为默认域或别名域。只有一个默认域。默认域用于标记没有域规范的邮件头。别名域是默认域的别名。如果添加一个域并将其指定为新的默认域，则上一个默认域将变为别名域。

远程域

非本地的域称为远程域或非本地域，具有远程域的电子邮件地址称为非本地地址。SMTP 服务器在 DNS 中查找远程域。

如果希望为特定远程域设置独有的传递要求，可以添加一个远程域并对其进行相应的配置。例如，添加一个远程域并要求 SMTP 服务在有关该域的会话中始终使用传输层安全 (TLS) 加密。或者，更改路由使发送到一个远程域的邮件被路由到其他远程域。可使用"域属性"对话框配置域。


创建域

创建域
SMTP 服务器 > SMTP 服务器步骤 > 创建或删除域 >

可以在 Windows Server 2008 中创建两种类型的域：别名域和远程域。别名域允许您创建指向默认域并使用其设置（包括投递目录）的辅助域。发送到别名域的所有邮件都标记有默认域名。

可以为您经常向其发送邮件的域设置远程域。可以为每个远程域设置一个预定传递路由，并要求在面向该域的所有会话中使用传输层安全性 (TLS) 协议加密。还可以在名称中使用通配符，以便您所创建的域中包含的所有域都使用相同的设置。将星号 (*) 用作首字符，后面跟句点 (.)。例如，您可以按以下格式将星号用作通配符：

复制代码
*.example.com

步骤

在 Microsoft 管理控制台中创建别名域

  1. 在 Microsoft 管理控制台中，展开 SMTP 虚拟服务器。有关如何启动 Microsoft 管理控制台的说明，请参阅启动 Microsoft 管理控制台。

  2. 选择"域"。

  3. 在"操作"菜单上，指向"新建"，然后单击"域"。

  4. 使用新建 SMTP 域向导设置本地（别名）域。

在 Microsoft 管理控制台中创建远程域

  1. 在 Microsoft 管理控制台中，展开 SMTP 虚拟服务器。

  2. 选择"域"。

  3. 在"操作"菜单上，指向"新建"，然后单击"域"。

  4. 使用新建 SMTP 域向导设置远程域。

  5. 若要指定路由域，请设置对传出邮件的身份验证或使用 TLS 加密，选择结果窗格中的域，单击"操作"菜单上的"属性"，然后指定相应选项。


删除域
SMTP 服务器 > SMTP 服务器步骤 > 创建或删除域 >

可以删除已添加的域。不能删除默认域，除非先添加一个别名域，然后将其设置为默认域。

步骤

删除域

  1. 在 Microsoft 管理控制台中，展开简单邮件传输协议 (SMTP) 虚拟服务器。有关如何启动 Microsoft 管理控制台的说明，请参阅启动 Microsoft 管理控制台。

  2. 单击"域"。

  3. 在结果窗格中，选择要删除的域。

  4. 在"操作"菜单上，单击"删除"。


配置本地域

配置本地域
SMTP 服务器 > SMTP 服务器步骤 >

本节介绍如何设置现有本地域的选项，包含以下主题：

  • 指定默认域

  • 配置别名域

  • 指定投递目录


指定默认域

指定默认域
SMTP 服务器 > SMTP 服务器步骤 > 配置本地域 >

默认域用于标记地址中没有域的邮件。简单邮件传输协议 (SMTP) 虚拟服务器可以使用一个默认域。不能删除默认域。

要命名默认域，可以使用分配给计算机的主 DNS 后缀。默认情况下，此名称与 Active Directory 目录服务域的名称相同。如果您的计算机未加入域，则可以在 LAN 连接的"高级 TCP/IP 设置"属性中的 DNS 选项卡下指定 DNS 后缀。该域名还可用于其他所有服务。此外，您可以指定一个唯一域，专门用作 Windows Server 2008 SMTP 服务器的默认域。

启动时，为计算机配置的 DNS 后缀会自动用于默认域。如果您在 DNS 选项卡上更改了 DNS 后缀，则在下次 SMTP 服务启动时，会将新名称自动用于默认域。更新默认 SMTP 虚拟服务器的默认域时不需要执行任何操作。

要覆盖自动使用的网络域，请重命名默认域。这样，SMTP 虚拟服务器就可以使用指定的名称，而非网络域。

步骤

重命名默认域

  1. 展开 SMTP 虚拟服务器，然后单击"域"。

  2. 右键单击结果窗格中的域名，然后单击"重命名"。

  3. 输入默认域的新名称。


配置别名域
SMTP 服务器 > SMTP 服务器步骤 > 配置本地域 >

您可以使用与默认域相同的设置来设置别名域。Windows Server 2008 SMTP 服务器收到的别名域的邮件将存放在为默认域指定的投递目录中。

步骤

配置别名域

  1. 展开简单邮件传输协议 (SMTP) 虚拟服务器，然后右键单击"域"。

  2. 指向"新建"，然后单击"域"。"新建 SMTP 域向导"启动。

  3. 在"新建 SMTP 域向导"中，单击"别名"，然后单击"下一步"。

  4. 键入别名域的名称，然后单击"完成"。


指定投递目录
SMTP 服务器 > SMTP 服务器步骤 > 配置本地域 >

对于默认域，必须指定要存放所有传入邮件的投递目录。SMTP 虚拟服务器将别名域的邮件存放在默认域所使用的投递目录中。只要某一目录是 Windows Server 2008 SMTP 服务器计算机的本地目录，并且该目录已经存在且尚未指定为分拣目录，就可将该目录指定为投递目录。默认情况下，投递目录和分拣目录是为 SMTP 内容配置的根目录的子目录。

重要信息：
确保投递目录位于安全位置且只能由信任的管理员访问。否则，未经授权的用户可能能够访问该目录中的邮件。

步骤

指定投递目录

  1. 在结果窗格中，右键单击默认域，然后单击"属性"。

  2. 在"投递目录"中，键入用于存放所有传入邮件的投递目录。默认位置为根目录:\Inetpub\Mailroot\Drop。或者单击"浏览"，选择该目录。确保您选择的是投递目录而非分拣目录。


配置远程域

配置远程域
SMTP 服务器 > SMTP 服务器步骤 >

您可以通过添加域并对其进行相应的配置来为特定远程域设置特殊的传递要求。例如，您可以设置预定的传递路由、设置身份验证并要求对域的所有连接都使用传输层安全性 (TLS) 加密。如果没有对远程域进行特别配置，则 Windows Server 2008 SMTP 服务器在将邮件传递到该域时不会执行上述任何操作。不过，它将会完成常规的域名系统 (DNS) 查找。

本节包含下列主题：

  • 设置路由域

  • 为远程域启用 TLS 加密

  • 配置远程域的身份验证

  • 配置远程域的 ATRN


设置路由域

设置路由域
SMTP 服务器 > SMTP 服务器步骤 > 配置远程域 >

可以指定一个比直接链接速度更快费用更低的传递路径。键入服务器（您希望通过该服务器为远程域路由邮件）的完全限定域名 (FQDN) 或 IP 地址。如果输入 IP 地址，请用方括号 ([ ]) 将地址括起来，以提高系统性能。该设置将覆盖"传递"选项卡中的智能主机设置。

步骤

指定路由域

  1. 右键单击 SMTP 虚拟服务器，指向"新建"，再单击"域"。

  2. 使用新建 SMTP 域向导创建远程域。在结果窗格中，右键单击新建远程域，再单击"属性"。

  3. 在"常规"选项卡上的"路由域"中，选择将所有邮件转发到智能主机，然后键入服务器（您希望通过该服务器为远程域路由邮件）的 FQDN 或 IP 地址。

    注意：
    可以通过 FQDN 或 IP 地址标识智能主机。（如果更改 IP 地址，则必须更改每台虚拟服务器的 IP 地址）。如果使用 IP 地址，请用方括号 ([ ]) 将地址括起来，以提高系统性能。SMTP 服务首先检查服务器名称，然后再检查 IP 地址。括号可将值标识为 IP 地址，因此不会进行 DNS 查找。


为远程域启用 TLS 加密
SMTP 服务器 > SMTP 服务器步骤 > 配置远程域 >

如果您没有对简单邮件传输协议 (SMTP) 虚拟服务器使用传输层安全性 (TLS) 加密，但为此远程域选中了"TLS 加密"复选框，则 Windows Server 2008 SMTP 服务器将在连接远程域时使用 TLS 加密。域配置将始终覆盖虚拟服务器配置。

步骤

为远程域启用 TLS 加密

  1. 展开 SMTP 虚拟服务器，然后单击"域"。

  2. 在结果窗格中，单击要更改的远程域。在"操作"菜单上，单击"属性"。

  3. 在"常规"选项卡上，单击"出站安全"打开"出站安全"对话框。

  4. 选择"集成 Windows 身份验证"。

  5. 键入 Windows 帐户和密码。

  6. 单击"确定"。

  7. 选中"TLS 加密"复选框，然后单击"确定"。
注意：
如果该远程域不支持 TLS 加密，所有邮件都将被退回，并附带一个未送达报告 (NDR)。


配置远程域的身份验证

配置远程域的身份验证
SMTP 服务器 > SMTP 服务器步骤 > 配置远程域 >

可以配置简单邮件传输协议 (SMTP) 虚拟服务器，使其提供远程域要求的身份验证凭据。可使用两种类型的身份验证：基本身份验证（明文）和集成 Windows 身份验证。使用"基本身份验证"选项，要连接的服务器的帐户名称和密码将以明文方式传输。集成 Windows 身份验证选项要求提供 Windows 帐户名称和密码。默认情况下将配置匿名访问，不使用身份验证。

所选选项将覆盖"访问"选项卡上的 SMTP 虚拟服务器身份验证设置。下表说明两种配置方案。

SMTP 虚拟服务器传输 | 身份验证选项
邮件常常被发送到多个地址。 | 启用对 SMTP 虚拟服务器的匿名访问。如果由于身份验证要求导致将邮件传送到某地址的尝试失败，请为该地址添加一个远程域。然后，以服务器要求的级别启用该域的身份验证。
邮件常常被发送到一个地址，需要进行身份验证。 | 确定进行连接时所需的身份验证级别。然后，使用同一级别为 SMTP 虚拟服务器启用身份验证。如果要将邮件发送到其他地址，设置远程域以设置不同的身份验证选项。如果使用此选项，使用的帐户名称可能是标识设置为智能主机的计算机的帐户名称。

步骤

禁用发送至远程域的传出邮件的身份验证

  1. 展开 SMTP 虚拟服务器，然后单击"域"。

  2. 在结果窗格中，单击要更改的远程域。在"操作"菜单上，单击"属性"。

  3. 在"常规"选项卡上，单击"出站安全"打开"出站安全"对话框。

  4. 选择"匿名访问"，再单击"确定"。

为目标为远程域的传出邮件设置基本身份验证

  1. 展开 SMTP 虚拟服务器，然后单击"域"。

  2. 在结果窗格中，单击要更改的远程域。在"操作"菜单上，单击"属性"。

  3. 在"常规"选项卡上，单击"出站安全"打开"出站安全"对话框。

  4. 单击"基本身份验证"。

  5. 键入要连接的计算机的用户名和密码。

  6. 单击"确定"。
重要信息：
如果基本身份验证是您的唯一身份验证方法，强烈建议您还要求使用传输层安全性 (TLS) 加密，以避免未经授权检测到用户名和密码。

为传出邮件设置集成 Windows 身份验证

  1. 展开 SMTP 虚拟服务器，然后单击"域"。

  2. 在结果窗格中，单击要更改的远程域。在"操作"菜单上，单击"属性"。

  3. 在"常规"选项卡上，单击"出站安全"打开"出站安全"对话框。

  4. 单击"集成 Windows 身份验证"。

  5. 键入 Windows 帐户名称和密码。

  6. 单击"确定"。


配置远程域的 ATRN

配置远程域的 ATRN
SMTP 服务器 > SMTP 服务器步骤 > 配置远程域 >

Windows Server 2008 SMTP 服务器可为定期连接以下载邮件的客户端保存邮件。在此情况下，客户端将发出 ATRN 命令。然后，简单邮件传输协议 (SMTP) 服务将开始向 ATRN 域发送邮件。对于虚拟服务器为其排队邮件的地址，可以创建一个远程域，并为该域启用 ATRN。

步骤

为远程域启用 ATRN 传输

  1. 展开 SMTP 虚拟服务器，然后单击"域"。

  2. 在结果窗格中，单击要更改的远程域。在"操作"菜单上，单击"属性"。

  3. 单击"高级"选项卡，然后选中"排列邮件以便进行远程触发传递"复选框。

  4. 根据需要单击"添加"或"删除"选择将允许在此域中使用 ATRN 命令的 Windows 用户帐户。


配置 LDAP 服务器连接

配置 LDAP 服务器连接
SMTP 服务器 > SMTP 服务器步骤 >

轻型目录访问协议 (LDAP) 是允许您访问 LDAP 服务器上目录信息的 Internet 协议。如果已经授予您使用 LDAP 的权限，您可以在 LDAP 服务器上浏览、读取和搜索目录列表。

使用"LDAP 路由"选项卡，可以配置 Windows Server 2008 SMTP 服务器，使其查询 LDAP 服务器来解析发件人和收件人。例如，可以将 Active Directory 目录服务用做 LDAP 服务器，并使用 Active Directory 用户和计算机创建在简单邮件传输协议 (SMTP) 虚拟服务器上自动扩展的组邮件列表。

本节介绍如何将 SMTP 虚拟服务器配置为 LDAP 客户端，使您可以访问 LDAP 服务器上的目录信息，包含以下主题：

  • 配置 LDAP 连接的预备步骤

  • 选择架构类型

  • 确定身份验证级别

  • 设置 LDAP 路由信息


配置 LDAP 连接的预备步骤

配置 LDAP 连接的预备步骤
SMTP 服务器 > SMTP 服务器步骤 > 配置 LDAP 服务器连接 >

由于"LDAP 路由"选项卡中的某些设置会影响其他设置，因此我们建议您在配置安全轻型目录访问协议 (LDAP) 之前先进行相应的规划。

步骤

配置 LDAP 连接

  1. 确定要使用的架构类型。有关详细信息，请参阅选择架构类型。

  2. 确定绑定到 LDAP 目录所要求的身份验证级别。有关详细信息，请参阅确定身份验证级别。如果您正在连接的 LDAP 服务器不要求进行身份验证，则不需要任何帐户信息。

  3. 确定是否需要指定命名上下文。如果用户帐户位于 LDAP 目录的子容器中，则必须指定命名上下文。指定命名上下文使 LDAP 目录可以更迅速地返回结果，而且在某些情况下，如果 LDAP 服务器上存在多个命名上下文，此操作是必需的。


选择架构类型

选择架构类型
SMTP 服务器 > SMTP 服务器步骤 > 配置 LDAP 服务器连接 >

下表显示"LDAP 路由"选项卡上的"架构"下拉菜单中的架构类型。

架构类型 | 说明
Active Directory | 选择此选项可将 Active Directory 目录服务用于轻型目录访问协议 (LDAP) 服务器。要管理邮箱，请使用 Active Directory 用户和计算机。
站点服务器成员目录 | 如果将 Microsoft LDAP Service 作为 Microsoft Commercial Internet System 2.0 Mail 的一个组件安装，并且使用它管理邮箱，请使用此选项。
Exchange LDAP Service | 选择此选项以使用 Microsoft Site Server 3.0 LDAP 服务器管理邮箱。


确定身份验证级别

确定身份验证级别
SMTP 服务器 > SMTP 服务器步骤 > 配置 LDAP 服务器连接 >

下表显示的四种绑定类型可确定用于连接的身份验证级别。您选择的选项将影响其他选项。

绑定类型 | 说明
匿名 | 无需身份验证。当服务器不要求提供帐户和密码信息时，请选择此选项。
纯文本 | 使用此选项可以明文形式传输帐户信息和密码。选择此选项以后，须提供帐户和密码信息。请注意，建议您不要使用明文形式传输密码，因为未授权的用户或恶意用户可能会读取未加密的信息。
Windows SSPI | 客户端和服务器将协商确定双方都可接受的身份验证级别，并使用可用的最严格的方法。选择此选项以后，须提供帐户和密码信息。
服务帐户 | 此选项使用运行 SMTP 服务的用户帐户信息。这是由使用"管理工具"下的"服务"配置的设置控制的。


设置 LDAP 路由信息
SMTP 服务器 > SMTP 服务器步骤 > 配置 LDAP 服务器连接 >

如果为简单邮件传输协议 (SMTP) 虚拟服务器启用轻型目录访问协议 (LDAP) 路由，可配置此 SMTP 虚拟服务器使其查询 LDAP 目录来解析发件人和收件人。

步骤

设置 LDAP 路由信息

  1. 从 Microsoft 管理控制台中，选择要配置的 SMTP 虚拟服务器的"属性"。有关如何启动 Microsoft 管理控制台的说明，请参阅启动 Microsoft 管理控制台。

  2. 单击"LDAP 路由"选项卡。

  3. 选中"启用 LDAP 路由"复选框。

  4. 按照下表中的说明设置选项。

下表说明了可用的选项。

选项 | 说明
服务器 | 键入运行 LDAP 目录的计算机的名称。如果使用 Exchange LDAP Service 架构类型，则该字段不适用，因为该服务会找到一个附近的服务器并自动使用它。
架构 | 选择架构类型。有关详细信息，请参阅选择架构类型。
绑定 | 选择绑定至 LDAP 服务器时使用的身份验证方法。有关详细信息，请参阅确定身份验证级别。 纯文本以明文方式传输密码。要使用 SMTP 虚拟服务器可用的最严格的身份验证方法，请选择 Windows SSPI。如果不需身份验证，则使用"匿名"，这是默认选项。服务帐户绑定类型使用尝试绑定到 LDAP 服务器的帐户的凭据。
域 | 键入要用于绑定至 LDAP 目录的帐户的域。如果选择纯文本或 Windows SSPI 绑定类型，则此选项适用。
用户名 | 键入要用于绑定至 LDAP 目录的帐户的可分辨名称 (DN)。例如，cn=user1、ou=users、o=company。如果选择纯文本或 Windows SSPI 绑定类型，则此选项适用。
密码 | 键入用于登录至目录服务的密码。如果选择纯文本或 Windows SSPI 绑定类型，则此选项适用。
基准 | 键入正在访问的目录服务中某一容器的可分辨名称。此设置可指定希望 SMTP 服务开始在 LDAP 目录中搜索的位置。搜索将会从指定的容器开始，并可根据需要继续搜索子容器。


设置与 ODBC 兼容的数据库
SMTP 服务器 > SMTP 服务器步骤 >

步骤

本主题介绍如何设置与开放式数据库连接 (ODBC) 兼容的数据库。

设置与 ODBC 兼容的数据库

  1. 使用数据库程序创建与 ODBC 兼容的数据库，例如使用 Microsoft Access 或 Microsoft SQL Server。

  2. 在数据库中创建一个表，该表中包含下表列出的字段。

    字段名 数据类型

    ClientHost

    varchar(255)

    Username

    varchar(255)

    LogTime

    datetime

    Service

    varchar(255)

    Machine

    varchar(255)

    ServerIP

    varchar(50)

    ProcessingTime

    integer

    BytesRecvd

    integer

    BytesSent

    integer

    ServiceStatus

    integer

    Win32Status

    integer

    Operation

    varchar(255)

    Target

    varchar(255)

    Parameters

    varchar(255)


SMTP 服务器概念

SMTP 服务器概念
SMTP 服务器 >

邮件传递是 Internet 站点的常见功能。Internet 邮件通常采用简单邮件传输协议 (SMTP) 进行发送和传递。可以使用 Windows Server 2008 SMTP 服务器配置您的硬件，以便通过 Intranet 或 Internet 传递邮件。

SMTP 服务器支持基本的 SMTP 传递功能。它还提供相应的功能，允许您自定义配置以满足特殊的传递和安全要求。

本节提供有关 SMTP 服务器的常规背景信息，其中包含以下主题：

  • SMTP 服务器概述

  • 重要功能

  • 组件

  • 流程概述


SMTP 服务器概述

SMTP 服务器概述
SMTP 服务器 > SMTP 服务器概念 >

本节提供了有关如何配置 Windows Server 2008 SMTP 服务器和 SMTP 虚拟服务器的常规信息，包含以下主题：

  • 访问选项卡

  • 改进系统性能


访问选项卡

访问选项卡
SMTP 服务器 > SMTP 服务器概念 > SMTP 服务器概述 >

可使用六个选项卡来配置由 Windows Server 2008 SMTP 服务器提供的简单邮件传输协议 (SMTP) 虚拟服务器。下表说明了这六个选项卡。

选项卡 | 说明
常规 | 该选项卡提供决定虚拟服务器如何连接到其他 SMTP 服务器以传输并接收邮件的设置。它还可用来启用日志记录。
访问 | 该选项卡提供要求身份验证和使用传输层安全性 (TLS)（一种面向所有协议和所有入站连接的安全套接字层 (SSL) 加密）的设置。还可以针对特定的计算机或网络批准或拒绝常规访问和延迟访问。
邮件 | 该选项卡配置邮件限制并决定管理无法送达邮件的方式。
传递 | 该选项卡提供决定虚拟服务器如何传递邮件（包括每个连接发送的邮件数、虚拟服务器如何路由邮件，以及尝试重新发送邮件的重试间隔和过期超时）的设置。
LDAP 路由 | 该选项卡提供用于轻型目录访问协议 (LDAP) 的设置，以便允许访问符合 X.500 目录结构的目录。
安全 | 该选项卡指定具有可配置 SMTP 服务的操作员权限的用户帐户。

步骤

在 Microsoft 管理控制台中访问 SMTP 虚拟服务器选项卡

  1. 选择要配置的 SMTP 虚拟服务器。有关如何启动 Microsoft 管理控制台的说明，请参阅启动 Microsoft 管理控制台。

  2. 在"操作"菜单上，单击"属性"。

  3. 单击要显示的选项卡。


改进系统性能

改进系统性能
SMTP 服务器 > SMTP 服务器概念 > SMTP 服务器概述 >

简单邮件传输协议 (SMTP) 虚拟服务器的某些配置设置可能会影响系统性能。要确定如何简化系统以减少处理时间和优化传递连接，请参阅下列主题：

  • 限制每个连接的邮件数

  • 配置智能主机

  • 启用反向 DNS 查找


重要功能

重要功能
SMTP 服务器 > SMTP 服务器概念 >

Windows Server 2008 SMTP 服务器提供下列功能。

标准 Internet 协议支持

SMTP 服务器完全支持简单邮件传输协议 (SMTP) 并与 SMTP 邮件客户端兼容。

可伸缩性

您可以配置 SMTP 虚拟服务器以在单一服务器配置中支持多个域和数百个客户端连接。

便于管理并与 Windows Server 2008 操作系统集成

SMTP 服务器使用 Microsoft 管理控制台进行管理。SMTP 虚拟服务器是使用 Internet Information Services (IIS) 6.0 管理器创建和配置的。管理员可以使用其他 Windows Server 2008 管理功能（包括简单网络管理协议 (SNMP)、事件日志和事务日志）收集使用率统计信息、跟踪邮件和事务或检查使用模式。

高级安全性

SMTP 服务器支持使用传输层安全性 (TLS) 对传输进行加密。

直接投递和分拣邮件

对于默认域，SMTP 服务器支持将所有传入的邮件直接放入投递目录中。这意味着您可以将 SMTP 服务器用作其他应用程序的邮件接收端。

除了连接至 TCP 端口发送邮件外，应用程序还可以使用分拣目录。将格式为文本文件的邮件复制到分拣目录后，SMTP 服务器即完成该邮件的传递。


组件

组件
SMTP 服务器 > SMTP 服务器概念 >

本节介绍 Windows Server 2008 SMTP 服务器的组件、组件功能及其协同工作方式，包含以下主题：

  • 组件和 Microsoft 管理控制台显示设置

  • 组件之间的关系

  • Mailroot 目录和默认目录


组件和 Microsoft 管理控制台显示设置

组件和 Microsoft 管理控制台显示设置
SMTP 服务器 > SMTP 服务器概念 > 组件 >

为计算机设置的所有 Internet Information Services (IIS) 6.0 组件都显示在 Microsoft 管理控制台中。Windows Server 2008 SMTP 服务器在 Microsoft 管理控制台的控制台树中表示为 SMTP 虚拟服务器节点。选择节点时，有关该节点的详细信息显示在结果窗格中。下表提供了计算机和 SMTP 虚拟服务器节点的说明。

节点 | 图标 | 说明
计算机 | 计算机图标 | IIS 的主要管理组件。显示每一项 IIS 服务的信息，包括其运行状态、IP 地址和端口。
SMTP 虚拟服务器 | 电子邮件传递图标 | SMTP 服务器的主要管理组件。提供对配置 SMTP 虚拟服务器的选项卡的访问。
域 | 图标 - 正在传递的两封电子邮件 | SMTP 虚拟服务器的组织组件。节点提供对创建和配置域的"域属性"对话框的访问，并显示有关虚拟服务器上设置的所有域的信息。
当前会话 | 人物头像表明会话状态 | 结果窗格提供有关使用 SMTP 虚拟服务器的状态信息。状态窗格中列出了每个活动会话的用户、源位置和连接时间。


组件之间的关系

组件之间的关系
SMTP 服务器 > SMTP 服务器概念 > 组件 >

可在 Microsoft 管理控制台中使用 SMTP 虚拟服务器管理 Windows Server 2008 SMTP 服务器。每台虚拟服务器包含一个默认域，该域用于标记来自不含域的地址的邮件。无法删除默认域。但是，可以创建别名域。所有别名域使用默认域标记邮件。

有关域的详细信息，请参阅关于域。


Mailroot 目录和默认目录

Mailroot 目录和默认目录
SMTP 服务器 > SMTP 服务器概念 > 组件 >

执行安装过程时会在 Mailroot 目录中创建五个默认子目录，这样 Windows Server 2008 SMTP 服务器就可以处理邮件了。其中四个目录将在下表中逐一介绍。SortTemp 目录也是在安装过程中创建的，用于存储临时文件。Mailroot 目录的默认位置为根目录:\Inetpub\Mailroot。不过，您也可以在安装过程中指定其他位置。下表介绍了 Mailroot 的子目录及其内容。

重要信息：
确保 Mailroot 目录及其子目录只能由受信任的管理员访问。这一安全措施可防止未经授权的用户或恶意用户访问这些目录中的邮件。

目录 | 说明
死信 | 存储无法送达且无法退回给发件人的邮件。
投递 | 接收位于计算机上所有域的所有传入邮件。除了已指定为分拣的目录外，您可以将任一目录指定为投递目录。
分拣 | 处理创建为文本文件并复制到该目录中的传出邮件。格式正确的征求意见文档 (RFC) 2822 邮件复制到分拣目录时，SMTP 服务即会收集该邮件并启动传递过程。
排队 | 存储要传递的邮件。如果邮件因连接忙或中断而无法传递，则该邮件会存储在队列中并按指定间隔再次发送。


流程概述

流程概述
SMTP 服务器 > SMTP 服务器概念 >

Windows Server 2008 SMTP 服务器使用简单邮件传输协议 (SMTP) 根据征求意见文档 (RFC) 2821 和 RFC 2822 中的规范来传输和传送邮件。邮件在远程邮件服务器和为默认域指定的投递目录之间传输。SMTP 服务器旨在提供快速的连接往返以最大化每秒处理的邮件数。

本节介绍如何使用 SMTP 服务器传输和传递邮件，包含以下主题：

  • 处理邮件

  • 本地邮件传递

  • 远程邮件传递


处理邮件

处理邮件
SMTP 服务器 > SMTP 服务器概念 > 流程概述 >

邮件复制到分拣目录或通过指定 TCP 端口传入时，系统会将该邮件放到队列目录中。默认 TCP 端口是端口 25。

如果收件人是本地收件人，则传递邮件。如果收件人不是本地收件人，则会处理邮件以进行远程传递。图 1 显示了邮件流处理。

重要信息：
图 1 中省略了建议在 Internet 和 SMTP 服务器之间配置的一个或多个防火墙。
图 1 邮件流处理

邮件流处理


本地邮件传递

本地邮件传递
SMTP 服务器 > SMTP 服务器概念 > 流程概述 >

如果将邮件传递给本地收件人，则该邮件会从队列目录移到为默认域指定的投递目录中。将邮件存放在投递目录中后，即完成 SMTP 投递周期。可以在"默认域"对话框中指定投递目录。处理流程如图 1 中所示。

重要信息：
图 1 中省略了建议在 Internet 和 SMTP 服务器之间配置的一个或多个防火墙。
图 1 本地邮件流处理

本地邮件流处理


远程邮件传递

远程邮件传递
SMTP 服务器 > SMTP 服务器概念 > 流程概述 >

下表说明了 Windows Server 2008 SMTP 服务器传递远程邮件所涉及的过程。用于配置选项的选项卡包含在说明中。

过程 说明

对邮件进行排序和排队，等待传递。

邮件保留在队列目录中。每封邮件的收件人是按域排序的，因此 SMTP 服务可以将这些邮件按组发送。这样，可以让 SMTP 服务在一个会话中传递多个邮件，从而优化连接。

检查接收服务器是否已准备好接收邮件。

SMTP 服务尝试连接到接收邮件服务器。如果该服务器还没有准备好，邮件将保留在队列中，系统将按指定的间隔尝试重新传递，直到达到最大尝试次数。这些间隔属于重试设置。可以在"传递"选项卡上设置这些间隔。

发送邮件。

收件人通过验证之后，系统将发送邮件。接收服务器确认传输之后，即完成 SMTP 传递。请注意以下传递选项：

  • 如果启用了远程传递的传输层安全性 (TLS)，SMTP 服务将对所有传出邮件进行加密。也可以针对某个特定远程域启用或禁用此功能。通过单击"传递"选项卡上的"出站安全"对话框，可访问"出站安全"对话框，在其中设置 TLS 加密。

  • 远程域的所有邮件均可发送至某个智能主机，该主机再将其发送至收件人。通过单击"传递"选项卡上的"高级"，可访问"高级传递"对话框，在其中指定智能主机。

有关如何使用选项卡来配置 SMTP 虚拟服务器的详细信息，请参阅访问选项卡。


SMTP 服务器维护

SMTP 服务器维护
SMTP 服务器 >

本节介绍如何监视进程以便您可以分析 SMTP 虚拟服务器配置并进行调整，从而使邮件处理更为高效。还介绍如何暂停和停止 SMTP 服务以进行维护，包含以下主题：

  • 监视工具概述

  • 监视系统进程

  • 监视 SMTP 性能和配置

  • 监视邮件事务


监视工具概述

监视工具概述
SMTP 服务器 > SMTP 服务器维护 >

有几种工具可用于跟踪事件和监视性能。可以使用这些工具进行故障排除，确定是否需要更改系统设计。

重要信息：
利用日志文件审核服务器活动是一个不错的方法，不但可检测是否有未经授权的外部用户试图访问您的简单邮件传输协议 (SMTP) 虚拟服务器，还可以检测是否有内部用户试图访问其无权访问的资源。有关如何审核和使用事件查看器的详细信息，请参阅帮助和支持中心。

Windows Server 2008 事件日志

事件日志可用于验证 Windows Server 2008 是否正常运行。事件日志可跟踪信息、警告和错误事件，管理人员须对此予以重视。默认情况下，可使用三种日志：系统、安全和应用程序。

每次启动运行 Windows Server 2008 的计算机时，系统都将自动开始记录预定的事件。对于每种类型的日志，可以指定最大大小、保存条目的时间长度，以及是在日志已满时自动覆盖现有事件还是手动清除条目。

可靠性和性能监视器

可靠性和性能监视器可衡量 SMTP 服务的响应情况，并指示该服务是否按预期效果执行。可以为要审查的任何系统组件记录实际工作负荷统计信息。然后，可以分析数据，确定是否需要调整配置来确保高效处理邮件。要执行此操作，必须启用监视功能并指定要跟踪的内容。

协议日志

协议日志可分别跟踪各 SMTP 事务。必须首先启用日志记录，然后再确定频率和格式。


监视系统进程

监视系统进程
SMTP 服务器 > SMTP 服务器维护 >

SMTP 服务将信息写入两个 Windows Server 2008 事件日志："系统"和"安全性"。在每个日志内，SMTP 服务将记录信息事件、警告事件和错误事件。

请密切监视这些日志，并定期将其存档，以免空间不足。为了避免丢失信息，请不时地清除这些日志以便 SMTP 服务可继续写入新事件。


监视 SMTP 性能和配置

监视 SMTP 性能和配置
SMTP 服务器 > SMTP 服务器维护 >

本节介绍如何使用可靠性和性能监视器来检查系统设计和性能，包含以下主题：

  • 可靠性和性能监视器概述

  • 监视性能

  • 监视系统容量


可靠性和性能监视器概述

可靠性和性能监视器概述
SMTP 服务器 > SMTP 服务器维护 > 监视 SMTP 性能和配置 >

配置系统后，可通过跟踪系统性能检查设计。可使用可靠性和性能监视器记录您希望检查的所有系统对象的实际工作负荷统计信息。然后，可分析日志记录数据，确定是否需要调整配置来确保高效处理邮件。

可以自定义日志记录流程以跟踪不同类型的信息。可选择希望监视的系统对象，然后将计数器设置为跟踪其性能。要微调跟踪并增加管理员对事件的响应时间，可通过设置可靠性和性能监视器，使得每当计数器超过或低于指定的标准时都会生成警告。生成数据后，可将其导出到电子表格或数据库中，用于其他检查和分析。

监视选项包括：

  • 可监视一台计算机，也可同时监视多台计算机。

  • 可在"图表"窗口中实时监视性能，也可将数据存储在日志中以供以后使用。

有关如何使用可靠性和性能监视器的详细信息，请参阅 Windows Server 2008 文档。


监视性能

监视性能
SMTP 服务器 > SMTP 服务器维护 > 监视 SMTP 性能和配置 >

可监视 Windows Server 2008 SMTP 服务器的邮件处理和连接。下表说明了其中的一些性能计数器。

计数器 | 正常读数 | 说明
本地队列长度 | 0 | 此计数器监视本地队列中的邮件数。如果该数字大于 0，则服务器当前接收的邮件超出了它的处理能力。如果该数字持续增长，则应确定导致处理延迟的原因。
远程队列长度 | 0 | 此计数器监视远程队列中的邮件数。如果该数字大于 0，则服务器当前接收的邮件超出了它的处理能力。如果该数字持续增长，则应确定导致处理延迟的原因。
当前入站连接数 | 大于 0 | 此计数器监视当前入站连接数。此值长时间为 0 表示可能存在网络问题。


监视系统容量

监视系统容量
SMTP 服务器 > SMTP 服务器维护 > 监视 SMTP 性能和配置 >

可以将实际使用量与可用资源相比较，以确定是否会发生资源短缺情况。要监视 Windows Server 2008 SMTP 服务器容量，请检查物理资源和 SMTP 服务容量。当物理资源 100% 忙碌时，即达到容量。当服务请求开始延迟时，服务即达到容量。

下表介绍了要监视的对象和要使用的计数器。

对象 | 计数器 | 正常读数 | 说明
逻辑磁盘 | %Disk Time | <70% | 指所选磁盘驱动器忙于为读取或写入请求提供服务所用的时间百分比。如果读数连续超过 70%，则请考虑添加另一台 SMTP 服务器。
系统 | % Total Processor Time | <70% | 指系统上所有处理器忙于执行非空闲线程的平均时间百分比。多处理器系统中的所有处理器都始终处于忙碌状态时，此值是 100%。如果所有处理器都是 50% 忙碌，则此值是 50%。如果四分之一的处理器是 100% 忙碌，则此值是 25%。它是执行有效工作所用时间的分数。在空闲进程中会为每个处理器分配一个空闲线程，该线程会消耗未用于其他任何线程的非生产性处理器循环。
内存 | Available Bytes | > 总内存的 10% | 该值显示当前"零位"、"可用"和"备用"列表中虚拟内存的大小。可以使用"零位"和"可用"内存，"零位"内存可在清零后使用。"备用"内存是从"工作集"进程中删除但仍可用的内存。请注意，这是瞬时计数值，而不是一段时间间隔的平均值。


监视邮件事务

监视邮件事务
SMTP 服务器 > SMTP 服务器维护 >

本节介绍如何使用事务日志跟踪邮件传输，包含以下主题：

  • 协议日志概述

  • 日志格式

  • 日志格式比较

  • 规划协议日志

  • 启用协议日志记录


协议日志概述

协议日志概述
SMTP 服务器 > SMTP 服务器维护 > 监视邮件事务 >

协议日志跟踪简单邮件传输协议 (SMTP) 虚拟服务器从 SMTP 客户端接收的命令。

有四种格式可用于跟踪。通常，它们都跟踪相同的信息。它们的不同之处在于详细程度、显示类型和分析用途。选择格式时，应确定要跟踪的内容、检查数据的方式和从其他 Internet Information Services (IIS) 服务中跟踪事务的方式。有关详细信息，请参阅规划协议日志。

默认格式是万维网联合会 (W3C) 扩展日志文件格式。不过，您也可以选择其他格式。对于这三种格式，事务将被写入到文本文件中。可确定日志记录时段和该文件的最大大小。达到此大小限制后，将创建一个新文件。备份旧文件后将其删除，以免系统在向当前事务日志文件中写入时磁盘空间不足。还有一种格式，可用于收集与 ODBC 兼容的数据库中的数据。

注意：
该日志的格式和默认文件名称与其他 IIS 服务所用的相同。为 SMTP 虚拟服务器选择格式前，计划要为所有服务跟踪的内容、要使用的文件数以及如何设置文件大小。有关详细信息，请参阅规划协议日志。


日志格式

日志格式
SMTP 服务器 > SMTP 服务器维护 > 监视邮件事务 >

有四种格式可用于事务日志。有关每个日志的格式和示例的详细说明，请参阅下列主题：

  • Microsoft IIS 日志文件格式

  • NCSA 通用日志文件格式

  • W3C 扩展日志文件格式

  • ODBC 日志记录

有关不同日志格式的比较，请参阅日志格式比较。


Microsoft IIS 日志文件格式

Microsoft IIS 日志文件格式
SMTP 服务器维护 > 监视邮件事务 > 日志格式 >

以下内容说明了 Microsoft Internet Information Services (IIS) 日志文件格式：

  • 信息将被写入以逗号分隔的 ASCII 文本文件中。

  • 数据是固定的。您无法自定义日志。

  • 对于单个传输有多个记录。

若要查看完整的条目列表，请参阅 Microsoft IIS 日志文件条目。

以下是 Microsoft IIS 日志文件格式的示例：

复制代码
10.123.12.3,   Nwtraders.com,  8/18/06,  13:17:37,  SMTPSVC1, MAIL01,  10.200.200.1,  90, 42,  0,  250,  0,  MAIL FROM,  -,FROM:<someone@Nwtraders.com>,
10.123.12.3, Nwtraders.com, 8/18/06, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 0, 32, 0, 250, 0, RCPT TO, -, TO:<someone@example.com>,
10.123.12.3, Nwtraders.com, 8/18/06, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 270, 480, 101, 250, 0, DATA, -, 0019E3517201287MAIL01,
10.123.12.3, Nwtraders.com, 8/18/06, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 81, 4, 52, 0, 541, QUIT, -, MAIL01,


Microsoft IIS 日志文件条目

Microsoft IIS 日志文件条目
监视邮件事务 > 日志格式 > Microsoft IIS 日志文件格式 >

以下是 Microsoft Internet Information Services (IIS) 日志文件格式的示例：

复制代码
10.123.12.3, Nwtraders.com, 8/18/06, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 90, 42, 0, 250, 0, MAIL FROM, -, FROM:<someone@Nwtraders.com>,

下表显示了 Microsoft IIS 日志文件条目中的字段以及每个字段的示例。

字段 | 示例
客户端 IP 地址 | 10.123.12.3
客户端域名 | Nwtraders.com
连接日期 | 8/18/06
连接时间 | 13:17:37
IIS 服务和站点编号 | SMTPSVC1
服务器计算机名称 | MAIL01
服务器 IP 地址 | 10.200.200.1
处理时间（毫秒） | 90
接收的字节数 | 42
发送的字节数 | 0
SMTP 协议答复代码 | 250
Win32 状态或错误代码 | 0
SMTP 协议命令 | MAIL FROM
可选字段 | -
可变字段，取决于协议命令 | FROM:<someone@Nwtraders.com>


NCSA 通用日志文件格式

NCSA 通用日志文件格式
SMTP 服务器维护 > 监视邮件事务 > 日志格式 >

下面说明了（美国）国家超级计算技术应用中心 (NCSA) 通用日志文件格式：

  • 信息将被写入使用 NCSA 格式的 ASCII 文本文件。

  • 数据是固定的。您无法自定义日志。

  • 对于单个传输有多个记录。

若要查看完整的条目列表，请参阅 NCSA 通用日志格式条目。

以下是 NCSA 通用日志文件格式的示例：

复制代码
10.3.5.1 -  Nwtraders.com  [18/Aug/2006:13:17:37 - 0800] "MAIL FROM -? FROM: someone HTTP/1.0"  250 0
10.3.5.1 - Nwtraders.com[18/Aug/2006:13:17:37 - 0800] "RCPT TO -? TO: someone@example.com HTTP/1.0" 250 0
10.3.5.1 - Nwtraders.com[18/Aug/2006:13:17:37 - 0800] "DATA -?000B72730441764MAIL01 HTTP/1.0" 250 97
10.3.5.1 - Nwtraders.com[18/Aug/2006:13:17:37 - 0800] "QUIT -?someone HTTP/1.0" 0 0


NCSA 通用日志格式条目

NCSA 通用日志格式条目
监视邮件事务 > 日志格式 > NCSA 通用日志文件格式 >

下面为（美国）国家超级计算技术应用中心 (NCSA) 通用日志文件格式的一个示例：

复制代码
10.3.5.1 - Nwtraders.com [18/Aug/2006:13:17:37 - 0800] "MAIL FROM -? FROM: someone HTTP/1.0" 250 0

下表显示了 NCSA 通用日志文件条目中的字段以及每个字段的示例。

字段 | 示例
客户端 IP 地址 | 10.5.3.1
客户端域名 | Nwtraders.com
连接日期和时间 | [18/Aug/2006:13:17:37 - 0800]
SMTP 协议命令和相关信息 | "MAIL FROM -?From:someone HTTP/1.0"
SMTP 协议答复代码 | 250
发送的字节数 | 0


W3C 扩展日志文件格式

W3C 扩展日志文件格式
SMTP 服务器维护 > 监视邮件事务 > 日志格式 >

以下内容说明万维网联合会 (W3C) 扩展日志文件格式：

  • W3C 扩展日志文件格式是 Windows Server 2008 SMTP 服务和其他 Internet Information Services (IIS) 服务的默认日志记录格式。

  • 数据是可变的。您可以选择要跟踪的内容。

  • 此格式是限制日志大小的好方法。

  • 信息将被写入 ASCII 文本文件。

  • 此格式包括一些仅适用于 Web 和 FTP 服务的字段选项。

  • 对于单个传输有多个条目。

下面是 W3C 扩展日志文件格式的示例：

复制代码
2006-08-18  13:17:37  10.3.5.1  Nwtraders.com  MAIL01,   10.200.200.1  MAIL FROM  -  -  250  -  357  0  90  -  -  -  -
2006-08-18 13:17:37 10.3.5.1 Nwtraders.com SMTPSVC1 MAIL01 10.200.200.1 RCPT TO - +TO:+<someone@example.com> 250 0 0 33 0 - - -
2006-08-18 13:17:37 10.3.5.1 Nwtraders.com SMTPSVC1 MAIL01 10.200.200.1 DATA - 001b60731171d87 250 0 101 1209 250 0 - - -
2006-08-18 13:17:37 10.3.5.1 Nwtraders.com SMTPSVC1 MAIL01 10.200.200.1 QUIT - Nwtraders.com 0 3215 52 4 291 0 - - -


W3C 扩展日志文件条目

W3C 扩展日志文件条目
监视邮件事务 > 日志格式 > W3C 扩展日志文件格式 >

万维网联合会 (W3C) 扩展日志文件条目是 Windows Server 2008 SMTP 服务器的默认日志条目。某些 SMTP 日志文件条目与 Web 和 FTP 条目不同。对于需要文本值（不适用于 SMTP 服务器）的字段，在日志文件中以连字符 (-) 或零 (0) 表示。需要数字值的字段在日志文件中以零 (0) 表示。在下表中，以加粗文本列出的字段表示默认的日志文件条目。

字段 | 日志字段 | 说明
日期 | date | 连接日期
时间 | time | 连接时间
客户端 IP 地址 | c-ip | 访问服务器的客户端 IP 地址
客户端域名 | cs-username | 访问服务器的客户端
服务名称 | s-sitename | Internet Information Services (IIS) 服务
服务器名称 | s-computername | 在其上生成日志条目的服务器
服务器 IP | s-ip | 在其上生成日志条目的服务器的 IP 地址
方法 | cs-method | 由客户端发送的简单邮件传输协议 (SMTP) 的协议命令
URI 资源 | cs-uri-stem | 不适用于 Microsoft SMTP 服务
URI 查询 | cs-uri-query | 因 Microsoft SMTP 服务而异；具体取决于 SMTP 协议命令
HTTP 状态 | sc-status | SMTP 协议答复代码
Win32 状态 | sc-win32-status | Windows Server 2008 状态或错误代码；0 表示成功
发送的字节数 | sc-bytes | 服务器发送的字节数
接收的字节数 | cs-bytes | 服务器接收的字节数
所用时间 | time-taken | 执行操作的时间长度（毫秒）
服务器端口 | s-port | 不适用于 SMTP 服务
用户代理 | cs(User-Agent) | 不适用于 SMTP 服务
Cookie | cs(Cookie) | 不适用于 SMTP 服务
引用站点 | cs(Referrer) | 不适用于 SMTP 服务


ODBC 日志记录

ODBC 日志记录
SMTP 服务器维护 > 监视邮件事务 > 日志格式 >

以下列表介绍了开放式数据库连接 (ODBC) 日志记录：

  • 在使用该格式前，您必须设置一个与 ODBC 兼容的数据库。

  • 信息会被写入数据库中。

  • 对于单个传输有多个记录。

下表介绍了 ODBC 事务日志文件的字段和数据类型。

字段名 | 数据类型 | 说明
ClientHost | varchar(255) | 客户端 IP 地址
Username | varchar(255) | 客户端域名
LogTime | datetime | 连接日期和时间
Service | varchar(255) | Internet Information Services (IIS) 服务
Machine | varchar(255) | 计算机名称
ServerIP | varchar(50) | 服务器 IP 地址
ProcessingTime | integer | 处理时间（毫秒）
BytesRecvd | integer | 服务器接收的字节数
BytesSent | integer | 服务器发送的字节数
ServiceStatus | integer | 简单邮件传输协议 (SMTP) 的协议答复代码
Win32Status | integer | Windows Server 2008 状态或错误代码（值为 0 表示成功）。
Operation | varchar(255) | SMTP 协议命令
Target | varchar(255) | 收件人
Parameters | varchar(255) | 无可用说明


日志格式比较

日志格式比较
SMTP 服务器 > SMTP 服务器维护 > 监视邮件事务 >

以下示例说明了如何以下列各种格式记录并显示邮件事务数据：

  • Microsoft Internet Information Services (IIS) 日志文件格式

  • （美国）国家超级计算技术应用中心 (NCSA) 通用日志文件格式

  • 万维网联合会 (W3C) 扩展日志文件格式

  • 打开数据库连接 (ODBC) 日志记录

简单邮件传输协议 (SMTP) 传输的日志条目通常包括多个记录。对于每种日志格式只会显示一个记录，因此可以清楚地发现这些格式之间的区别。

在这些示例中，Nwtraders.com 的 Maria Cameron 在 2006 年 8 月 18 日下午大约 1：17 向一位同事发送电子邮件。

Microsoft IIS 日志文件格式

复制代码
10.3.5.1, Nwtraders.com, 8/18/06, 13:17:37, SMTPSVC1, MAIL01, 10.200.200.1, 90, 42, 0, 250, 0, MAIL FROM, -, FROM:<maria@Nwtraders.com>,

NCSA 通用日志文件格式

复制代码
10.3.5.1 - Nwtraders.com [18/Aug/2006:13:17:37 - 0800] "MAIL FROM -? FROM: maria HTTP/1.0 250 0

W3C 扩展日志文件格式

以下示例只包括默认的设置。您可以添加其他设置。

复制代码
13:17:37 10.3.5.1 MAIL FROM - 250

ODBC 日志记录

数据库包含以下记录：

  • 客户端 IP 地址

  • 客户端域名

  • 连接日期和时间

  • IIS 服务

  • 服务器计算机名称

  • 服务器 IP 地址

  • 处理时间（毫秒）

  • 服务器接收的字节数

  • 服务器发送的字节数

  • SMTP 协议答复代码

  • Win32 状态或错误代码

  • SMTP 协议命令

  • 收件人

  • 参数


规划协议日志

规划协议日志
SMTP 服务器 > SMTP 服务器维护 > 监视邮件事务 >

检查下列信息，确定如何将日志记录用于 Windows Server 2008 SMTP 服务器和其他 Internet Information Services (IIS) 服务。

使用默认设置

如果您为所有 IIS 服务使用默认设置，则每日会为所有服务生成事务日志。不过，日志格式各不相同。Web 和 FTP 服务的默认格式是万维网联合会 (W3C) 扩展日志格式。这些服务的事务组合在一个仅对此格式使用默认选项的文件中。SMTP 虚拟服务器的默认格式是 Microsoft IIS 日志文件格式。事务记录在单独的文件中。

确定要使用的格式

IIS 服务的默认格式不同。如果您要将所有服务的记录组合在一个文件中，则为所有服务选择相同的格式。选择格式时，还应确定数据的检查方式。四种格式中的三种都将记录写入 ASCII 文本文件，有的以空格分隔的格式写入，而有的以逗号分隔的格式写入。选项中的一种格式将记录写入与开放式数据库连接 (ODBC) 兼容的数据库中。

确定设置日志文件的方式

设置事务日志文件时，请考虑下表中的项目。

项目 | 说明
记录频率 | 确定是要每日、每周还是每月记录文件。
日志文件内容 | 确定要在日志文件中包含的内容。如果您为所有 IIS 服务使用默认文件名并使用相同的格式，则事务记录可以合并为一个日志文件。如果您为所有服务使用相同的格式，但为 SMTP 虚拟服务器使用其他文件，请为事务日志单独指定一个文件。
日志文件大小 | 确定是要将文件大小设置为无限制，还是要设置为特定大小。


启用协议日志记录

启用协议日志记录
SMTP 服务器 > SMTP 服务器维护 > 监视邮件事务 >

使用"常规"选项卡启用协议日志记录并选择格式。设置日志文件时，请记住日志格式和默认文件名应与其他 Internet Information Services (IIS) 服务中使用的日志格式和默认文件名相同。如果选择默认文件名，则所有服务的所有事务都记录在同一文件中。如果需要单独维护记录，可以为每个服务单独设置一个文件。

如果将文件设置在与默认文件不同的位置，请务必将其存储在本地驱动器上，而不能保存在网络上。

步骤

启用使用了某一种 ASCII 文本格式的日志记录

  1. 在 Microsoft 管理控制台中，选择 SMTP 虚拟服务器，然后在"操作"菜单上单击"属性"。

  2. 在"常规"选项卡上，选择"启用日志记录"。

  3. 在"活动日志格式"下拉菜单中，选择一个事务日志格式。

  4. 单击"属性"，然后设置日志文件大小和位置。

  5. 如果选择了万维网联合会 (W3C) 扩展日志记录格式，请单击"扩展属性"选项卡，然后单击要跟踪的项目。

启用使用了 ODBC 格式的日志记录

  1. 设置与 ODBC 兼容的数据库。有关如何设置与开放式数据库连接 (ODBC) 兼容的数据库的说明，请参阅设置与 ODBC 兼容的数据库。

  2. 在"常规"选项卡上，单击"启用日志记录"。

  3. 在"活动日志格式"下拉菜单中，选择"ODBC 日志记录"。

  4. 单击"属性"，然后设置日志文件大小和位置。


SMTP 服务器疑难解答

SMTP 服务器疑难解答
SMTP 服务器 >

本节提供有关常见操作问题的信息和解决方案，包括以下疑难解答指导主题：

  • 常规疑难解答提示

  • 传递

  • 系统

  • 排除 SMTP 服务器故障


常规疑难解答提示

常规疑难解答提示
SMTP 服务器 > SMTP 服务器疑难解答 >

为避免发生问题，您可以监视传输并对配置进行调整。如果错误仍然存在，您可以从几个位置启动疑难解答。

常规检查

您可以设置系统，使其定期检查传输并在出现问题前解决瓶颈问题。

设置邮箱以接收 NDR 和无法送达的邮件

不能在 Windows Server 2008 SMTP 服务器中创建邮箱。但是，您可以输入另一台服务器上现有邮箱的名称和路径，以接收未送达报告 (NDR) 和无法送达的邮件的副本。例如，您可以在客户端中创建一个邮箱并将其命名为 Postmaster。设置此选项后，您可以连续检查 NDR 和无法送达的邮件，并尽早解决传输问题。无法送达的邮件使用 .bad 扩展名。

使用性能计数器测量服务器负载并确定瓶颈

可靠性和性能监视器是跟踪进程流信息的极佳工具。定期检查计数器数据。因此，您可以在导致问题前调整配置设置。您可以监视队列中的邮件数、连接数、重试和收件人平均数以及已发送的字节数等项目。可靠性和性能监视器是一种 Windows Server 2008 管理工具。如果特定计数器的值持续增加，请调查原因以便进行调整。

有关如何使用可靠性和性能监视器的详细信息，请参阅监视 SMTP 性能和配置。

解决问题

出现错误后，请通过以下方法解决问题。

检查事件查看器中的事件

系统、应用程序和安全事件日志会记录 SMTP 服务和其他计算机进程的事件。您可以检查日志中的事件，以确定出错的原因。

检查队列目录中的 .rtr 文件，以确定邮件未送达的原因

可能由于远程计算机关闭、队列已满导致邮件未送达，也可能由于各种原因导致所有邮件都无法送达。如果出现此类情况，可以打开队列目录中的远程脚本 (.rtr) 文件，初步确定邮件未送达的原因以及邮件仍在排队等待重新发送的原因。


传递

传递
SMTP 服务器 > SMTP 服务器疑难解答 >

传递问题通常是由于磁盘空间不足或路径条目不对引起的。本节包含下列疑难解答主题：

  • 邮件无法传递到投递目录

  • 无法将邮件送达特定远程域

  • 远程邮件不通过智能主机路由

  • 虚拟域已设置但"发件人"头未变


邮件无法传递到投递目录

邮件无法传递到投递目录
SMTP 服务器 > SMTP 服务器疑难解答 > 传递 >

请考虑以下问题及其相关原因和解决方案。

问号图标 - 获得更详细信息 | 目录或磁盘已满。
工具图标 - 疑难解答提示 | 如有必要，清空投递目录并在磁盘上清理出更多空间。

问号图标 - 获得更详细信息 | 路径无效。
工具图标 - 疑难解答提示 | 检查"域属性"对话框中的"投递目录"路径是否为默认域。目录路径必须位于本地驱动器中。


无法将邮件送达特定远程域

无法将邮件送达特定远程域
SMTP 服务器 > SMTP 服务器疑难解答 > 传递 >

请考虑以下问题及其相关原因和解决方案。

问号图标 - 获得更详细信息 | 路由域路径不正确。这将引发"无法访问主机"错误。
工具图标 - 疑难解答提示 | 请在该远程域的"域属性"中检查"常规"选项卡上的路径。

问号图标 - 获得更详细信息

接收服务器已关闭或因多种原因邮件无法传递。
工具图标 - 疑难解答提示

请考虑下列可能原因：

  • 检查队列目录中的 .rtr 文件以确定原因。

  • 检查可靠性和性能监视器中的重试计数器。

  • 检查接收服务器。

问号图标 - 获得更详细信息 | 名称不正确或地址无效。
工具图标 - 疑难解答提示 | 检查名称和路径。

问号图标 - 获得更详细信息

要求使用传输层安全性 (TLS) 进行连接。密钥证书无效或加密级别不匹配。
工具图标 - 疑难解答提示

请考虑下列可能原因：

  • 检查该远程域的"域属性"中"出站安全"设置上 TLS 的使用是否被改写。

  • 检查 SMTP 服务证书使用的 TLS 加密级别，确保其与接收服务器要求的级别相匹配。


远程邮件不通过智能主机路由

远程邮件不通过智能主机路由
SMTP 服务器 > SMTP 服务器疑难解答 > 传递 >

请考虑以下问题及其相关原因和解决方案。

问号图标 - 获得更详细信息 | 为该远程域指定了路由域，并且覆盖了 SMTP 虚拟服务器的智能主机设置。
工具图标 - 疑难解答提示 | 更改路由域的设置。路由域不能与默认域或任何别名域相同。

问号图标 - 获得更详细信息 | 默认域或别名域被指定为智能主机。不能将本地域用于智能主机。
工具图标 - 疑难解答提示 | 通过单击"传递"选项卡上的"高级"，访问"高级传递"对话框并在其中更改智能主机设置。


虚拟域已设置但"发件人"头未变

虚拟域已设置但"发件人"头未变
SMTP 服务器 > SMTP 服务器疑难解答 > 传递 >

请考虑以下问题及其相关原因和解决方案。

问号图标 - 获得更详细信息 | "发件人"头中没有显示虚拟域。
工具图标 - 疑难解答提示 | 仅对第一个跃点更改了"发件人"头。


系统

系统
SMTP 服务器 > SMTP 服务器疑难解答 >

未解决的传递错误可能造成系统错误。本节包含以下主题：

  • 内存不足


内存不足

内存不足
SMTP 服务器 > SMTP 服务器疑难解答 > 系统 >

请考虑以下问题及其相关原因和解决方案。

问号图标 - 获得更详细信息

无法将已接收的邮件发送出站以进行传递。这表示这些邮件保留在队列中。每个已接收的邮件都被指定为内存中的邮件对象。当邮件保存在投递目录中时，会从内存中将其删除。如果邮件无法传送，并且达到了默认值 100,000 个对象，则系统会生成"内存不足"的错误。
工具图标 - 疑难解答提示

检查下列性能计数器：

  • 本地队列长度

  • 远程队列长度

  • 本地重试队列长度

  • 远程重试队列长度

如果前两个计数器的值为 0，这表示收到邮件后立即将其传送。如果该值大于 0，表示有延迟。

如果重试队列值很高，则表示无法传送该邮件。打开 .rtr 文件并确定导致该问题的原因。

例如，如果远程服务器已关闭，则远程重试队列长度将具有很高的值，并且队列目录中的 .rtr 文件可能会包括错误消息"主机未找到"。


排除 SMTP 服务器故障

排除 SMTP 服务器故障
SMTP 服务器 > SMTP 服务器疑难解答 >

本节介绍在执行 Windows Server 2008 SMTP 服务器操作时经常发生的错误，包含以下主题：

  • SMTP 服务启动，但 SMTP 虚拟服务器未启动

  • SMTP 管理单元未在 MMC 中显示

  • 队列目录包含 .bad 文件

  • 客户端无法连接


SMTP 服务启动，但 SMTP 虚拟服务器未启动

SMTP 服务启动，但 SMTP 虚拟服务器未启动
SMTP 服务器 > SMTP 服务器疑难解答 > 排除 SMTP 服务器故障 >

请考虑以下问题及其相关原因和解决方案。

问号图标 - 获得更详细信息 | SMTP 虚拟服务器在 Microsoft 管理控制台中已停止，并且 SMTP 服务在命令提示符下已停止并启动。
工具图标 - 疑难解答提示 | 在 Microsoft 管理控制台中重新启动 SMTP 虚拟服务器。有关如何在 Microsoft 管理控制台中重新启动 SMTP 虚拟服务器的说明，请参阅在 MMC 中重新启动 SMTP 虚拟服务器。


在 MMC 中重新启动 SMTP 虚拟服务器

在 MMC 中重新启动 SMTP 虚拟服务器
SMTP 服务器疑难解答 > 排除 SMTP 服务器故障 > SMTP 服务启动，但 SMTP 虚拟服务器未启动 >

本主题介绍如何在 Microsoft 管理控制台中重新启动简单邮件传输协议 (SMTP) 虚拟服务器。

步骤

在 Microsoft 管理控制台中重新启动 SMTP 虚拟服务器

  1. 选择 SMTP 虚拟服务器。

  2. 在"操作"菜单上，单击"启动"。


SMTP 管理单元未在 MMC 中显示

SMTP 管理单元未在 MMC 中显示
SMTP 服务器 > SMTP 服务器疑难解答 > 排除 SMTP 服务器故障 >

请考虑以下问题及其相关原因和解决方案。

问号图标 - 获得更详细信息 | Microsoft 管理控制台已在命令提示符下打开。
工具图标 - 疑难解答提示 | 手动添加 Internet Information Services (IIS) 6.0 管理单元以及 SMTP 协议扩展。有关如何手动添加管理单元和扩展的说明，请参阅手动添加 SMTP 管理单元。


手动添加 SMTP 管理单元
SMTP 服务器疑难解答 > 排除 SMTP 服务器故障 > SMTP 管理单元未在 MMC 中显示 >

步骤

本主题介绍如何手动添加 SMTP 管理单元。

手动添加 SMTP 管理单元

  1. 在"控制台"菜单中，单击"添加/删除管理单元"。

  2. 在"可用的管理单元"框中，选择"Internet Information Services (IIS) 6.0"。

  3. 单击"添加"。

  4. 从"所选管理单元"列表中，选择"Internet Information Services (IIS) 6."。

  5. 单击"编辑扩展"。

  6. 选择"SMTP 协议"。单击"确定"。

  7. 单击"确定"关闭"添加或删除管理单元"对话框。


队列目录包含 .bad 文件

队列目录包含 .bad 文件
SMTP 服务器 > SMTP 服务器疑难解答 > 排除 SMTP 服务器故障 >

请考虑以下问题及其相关原因和解决方案。

问号图标 - 获得更详细信息 | 死信目录已满，.bad 文件仍在队列目录中。
工具图标 - 疑难解答提示 | 清除死信目录中的邮件。


客户端无法连接

客户端无法连接
SMTP 服务器 > SMTP 服务器疑难解答 > 排除 SMTP 服务器故障 >

请考虑以下问题及其相关原因和解决方案。

问号图标 - 获得更详细信息 | 客户端访问被拒绝。
工具图标 - 疑难解答提示 | 请检查"安全"选项卡上的计算机访问权限。


帮助参考

帮助参考
SMTP 服务器 >

以下各节提供了有关 SMTP 虚拟服务器用户界面的选项卡和属性的信息：

  • 常规选项卡

  • 访问选项卡

  • 邮件选项卡

  • 传递选项卡

  • LDAP 路由选项卡

  • 安全选项卡

  • 本地域属性

  • 远程域属性


常规选项卡

常规选项卡
SMTP 服务器 > 帮助参考 >

使用"常规"选项卡识别由 SMTP 虚拟服务器使用的 IP 地址、配置 SMTP 虚拟服务器的多个标识、设置连接限制和超时时间并启用日志记录。默认情况下，SMTP 虚拟服务器可响应计算机上配置的所有 IP 地址的连接请求。"常规"选项卡提供以下选项。

完全限定域名

此只读属性指示分配给该 SMTP 虚拟服务器的完全限定域名 (FQDN)。要修改 FQDN，请选择"传递"选项卡，然后单击"高级"。

IP 地址

默认情况下，SMTP 虚拟服务器可响应计算机上配置的所有 IP 地址的连接请求。要为 SMTP 虚拟服务器分配一个特定的 IP 地址，请从该下拉菜单中选择一个 IP 地址。

高级

选择此选项可为此 SMTP 虚拟服务器分配多个 IP 地址，或分配一个与默认 SMTP 端口 25 不同的 TCP 端口。

限制连接数不超过

选中该复选框限制此 SMTP 虚拟服务器的并发传入连接的最大次数，然后键入一个值。最小连接数为 1。如果未选中该复选框，则没有限制。请注意，设置连接限制可使某些人难于启动拒绝服务攻击 (DoS) 或其他恶意攻击，以保护您的虚拟服务器免受攻击。

连接超时(分钟)

此设置可确定在连接超时并结束前，单个传入连接可保持为非活动状态的时间。默认情况下，该值设为 10 分钟。

启用日志记录

可以使用日志记录跟踪 SMTP 虚拟服务器通过网络从 SMTP 客户端接收的命令。利用日志文件来审核服务器活动是一个不错的方法，不但可以检测是否有未经授权的外部用户试图访问您的虚拟服务器，还可以检测是否有内部用户尝试访问其无权访问的资源。选中此复选框可启用日志记录，并配置下列选项：

  • 活动日志格式 使用下拉菜单选择一种日志记录格式：

    • Microsoft Internet Information Services (IIS) 日志文件格式 此日志文件是使用固定的 ASCII 格式记录的。

    • W3C 扩展日志文件格式 此日志文件格式是默认选项。信息以 ASCII 形式记录并且可以自定义。此选项允许您选择要跟踪的项目。

    • （美国）国家超级计算技术应用中心 (NCSA) 通用日志文件格式 此日志文件是使用固定的 ASCII 格式记录的。

    • ODBC 日志记录 此格式使用与开放式数据库连接 (ODBC) 兼容的数据库存储所记录的固定数据字段集的数据。

  • 属性 使用"日志记录属性"对话框配置新日志计划和日志文件目录。


常规选项卡 > 高级

常规选项卡 > 高级
SMTP 服务器 > 帮助参考 > 常规选项卡 >

使用"高级"对话框可以添加、删除或编辑该 SMTP 虚拟服务器的 IP 地址和 TCP 端口号。每个虚拟服务器都通过其 IP 地址和 TCP 端口组合来标识。可以定义该 SMTP 虚拟服务器响应的其他 IP 地址。用户可以使用定义的任一 IP 地址连接到 SMTP 虚拟服务器。通过"高级"对话框中的下列选项，您可以为该虚拟服务器配置多个标识或修改现有标识。

选项 | 说明
地址 | 该选项可列出指定给该 SMTP 虚拟服务器的每个 IP 地址以及每个地址的 TCP 端口。用户可以使用列出的任一 IP 地址连接到 SMTP 虚拟服务器。
添加 | 单击"添加"可打开"标识"对话框，并在该 SMTP 虚拟服务器上为其添加新的 IP 地址和选择 TCP 端口号。
编辑 | 从"地址"表中选择一个条目，然后选择"编辑"打开"标识"对话框，并修改 IP 地址和/或 TCP 端口号。
删除 | 从"地址"表中选择一个条目，然后单击"删除"来删除所选的 IP 地址。


标识

标识
帮助参考 > 常规选项卡 > 常规选项卡 > 高级 >

使用"标识"对话框指定用于与此 SMTP 虚拟服务器通信的 IP 地址和 TCP 端口。端口 25 是简单邮件传输协议 (SMTP) 的标准 TCP 端口。建议使用端口 25。如果虚拟服务器与不同的 IP 地址相关联，则多个虚拟服务器可以使用端口 25。您可以在"标识"对话框中配置下列选项。

IP 地址

使用此选项可指定此 SMTP 虚拟服务器所使用的 IP 地址。可以选择"[全部未分配]"指定 SMTP 虚拟服务器可以使用所有未特别分配给其他 SMTP 虚拟服务器的 IP 地址。要选择特定 IP 地址，请使用下拉框并从列表中选择在运行 Windows Server 2008 SMTP 服务器的计算机上定义的 IP 地址。要为一台服务器配置多个 IP 地址，请单击"启动"，选择"控制面板"，然后单击"网络和共享中心"。

TCP 端口

键入用于连接此 SMTP 虚拟服务器的 TCP 端口号。默认端口是端口 25。SMTP 虚拟服务器是通过其 IP 地址/TCP 端口号组合来识别的。因此，如果为虚拟服务器分配了不同的 IP 地址，则多个 SMTP 虚拟服务器可以使用相同的 TCP 端口。如果您为已在使用的 SMTP 虚拟服务器分配了 IP/TCP 端口号组合，则该虚拟服务器将不会启动。要使新端口号生效，必须重新启动计算机。


访问选项卡

访问选项卡
SMTP 服务器 > 帮助参考 >

使用"访问"选项卡配置对 SMTP 虚拟服务器的客户端访问并创建传输安全性。"访问"选项卡提供以下选项：

访问控制

使用此选项选择 SMTP 虚拟服务器的一种或多种身份验证方法。单击"身份验证"打开"身份验证"对话框并配置身份验证选项。

安全通信

选中"要求 TLS 加密"复选框为此 SMTP 虚拟服务器的所有会话启用传输层安全性 (TLS) 加密。服务器证书已颁发给计算机的完全限定域名 (FQDN) 并已安装时，此选项才可用。

连接控制

使用此选项限制对 SMTP 虚拟服务器的访问。默认情况下，所有 IP 地址都可访问 SMTP 虚拟服务器。不过，您可以在向大型组授予或拒绝访问权限时，授予或拒绝对特定 IP 地址的访问权限。可以通过指定单个 IP 地址、使用同一子网掩码的一组地址或一个域名来设置限制。要查看访问限制选项，请单击"连接"。

中继限制

Windows Server 2008 SMTP 服务器会阻止计算机通过虚拟服务器中继不需要的邮件。默认情况下，除了符合身份验证要求的计算机外，系统会阻止其他所有计算机的中继访问。您可以为特定计算机、使用同一子网掩码的一组地址或一个域启用对虚拟服务器的中继访问。单击"中继"查看中继限制选项。请注意，可以针对特定的远程域改写 SMTP 虚拟服务器中继访问设置。


访问选项卡 > 身份验证

访问选项卡 > 身份验证
SMTP 服务器 > 帮助参考 > 访问选项卡 >

使用"身份验证"对话框可以为 SMTP 虚拟服务器选择一个或多个身份验证方法。Windows Server 2008 SMTP 服务器会使用配置的身份验证机制来验证用户的身份标识，并授予对 SMTP 虚拟服务器的访问权限。默认情况下，仅启用匿名访问。可以使用下列选项。

允许匿名访问

选择此选项可允许对此 SMTP 虚拟服务器进行匿名访问。无需提供用户名或密码。

基本身份验证

选择此选项可以启用基本（明文）身份验证。基本身份验证以明文形式传输密码。我们建议您在使用基本身份验证时要求进行传输层安全 (TLS) 加密，防止在传输过程中危及用户名和密码的安全。如果选择"基本身份验证"，还可以配置下列选项：

  • 要求 TLS 加密 选中该复选框可要求使用 TLS 对凭据进行加密。

  • 默认域 键入用于"基本身份验证"的默认域的域名。域名会附加到帐户名之后。

集成 Windows 身份验证

选择此选项可以让客户端和服务器与 Windows 安全支持提供程序接口进行协商。此安全功能允许公司为客户提供安全登录服务。集成 Windows 身份验证使用加密技术对用户进行身份验证，不要求用户通过网络传输实际密码。

注意：使用集成 Windows 身份验证要求邮件客户端支持此身份验证方法。


访问选项卡 > 连接

访问选项卡 > 连接
SMTP 服务器 > 帮助参考 > 访问选项卡 >

使用"连接"对话框中的选项，可以按客户端 IP 地址或域名限制对 SMTP 虚拟服务器的访问。您可以授予对所有计算机的访问权限，再通过拒绝访问特定计算机来设置此规则的例外情况。此外，如果您拒绝访问所有计算机，仍可以授予对特定计算机的访问权限。"连接"对话框提供以下选项。

选择可以访问此虚拟服务器的计算机

选择下列某一项来控制对此虚拟服务器的访问：

  • 仅以下列表 如果选择此选项，除添加到"计算机"表中的特定 IP 地址和域之外，会拒绝对其他所有连接的访问。

  • 以下列表除外 如果选择此选项，除添加到"计算机"表中的特定 IP 地址和域之外，会授予到其他所有连接的访问权限。

计算机

"计算机"表列出了特别授予或拒绝访问权限的 IP 地址和域。IP 地址或域旁的"访问"列显示了"已授予"或"已拒绝"。"IP 地址(掩码)/域名"列指定了特别授予或拒绝访问权限的 IP 地址和域名。选择以下选项以修改"计算机"表：

  • 添加 单击"添加"打开"计算机"对话框，并授予或拒绝对特定 IP 地址、IP 地址范围或域名的访问。

  • 删除 在"计算机"表中选择一个条目，再单击"删除"可以删除该 IP 地址或域条目。


访问选项卡 > 中继限制

访问选项卡 > 中继限制
SMTP 服务器 > 帮助参考 > 访问选项卡 >

使用"中继限制"对话框中的选项，可以按客户端 IP 地址或域名限制通过 SMTP 虚拟服务器的中继访问。默认情况下，只有通过身份验证的用户可以中继邮件。您可以授予对所有计算机的中继访问权限，再通过拒绝对特定计算机的中继访问来设置此规则的例外情况。此外，如果您拒绝对所有计算机的中继访问，仍可以授予对特定计算机的中继访问权限。

请注意，如果您的虚拟服务器在 Internet 上，建议您不要使用中继。如果启用中继，虚拟服务器可能会用于传播不请自来的商业垃圾邮件或垃圾邮件。

可以使用下列选项。

选择可通过此虚拟服务器中继的计算机

选择下列某一项来控制通过此虚拟服务器的中继访问：

  • 仅以下列表 如果选择此选项，除添加到"计算机"表中的特定 IP 地址和域之外，会拒绝对其他所有连接的中继访问。

  • 以下列表除外 如果选择此选项，除添加到"计算机"表中的特定 IP 地址和域之外，会授予到其他所有连接的中继访问权限。

计算机

"计算机"表列出了已明确允许或拒绝中继访问的 IP 地址和域。IP 地址或域旁的"访问"列显示了"已授予"或"已拒绝"。"IP 地址(掩码)/域名"列指定了特别授予或拒绝访问权限的 IP 地址和域名。

选择以下选项以修改"计算机"表：

  • 添加 单击"添加"打开"计算机"对话框，并授予或拒绝对特定 IP 地址、IP 地址范围或域名的访问。

  • 删除 在"计算机"表中选择一个条目，再单击"删除"可以删除该 IP 地址或域条目。

不管上表中如何设置，所有通过身份验证的计算机都可以进行中继

此复选框在默认情况下处于选中状态。通过此选项，授予其访问此虚拟服务器权限的用户可以使用身份验证凭据进行中继。


计算机对话框

计算机对话框
SMTP 服务器 > 帮助参考 > 访问选项卡 >

可使用"计算机"对话框指定要为其授予或拒绝访问权限的 IP 地址或域名。可以指定单个计算机、计算机组或域名。"计算机"对话框提供以下选项。

单个计算机

选择此选项可以授予或拒绝对单个计算机的访问权限。如果选择了此设置，则以下选项可用：

  • IP 地址 输入单个计算机的 IP 地址。

  • DNS 查找 如果知道要添加到列表中的计算机名称，但不知道其 IP 地址，可单击"DNS 查找"。在出现的对话框中，输入计算机的 DNS 名称，然后单击"确定"。DNS 服务器将计算机名解析为 IP 地址，SMTP 服务器将自动填充"IP 地址"字段。

计算机组

选择此选项可以授予或拒绝对特定子网中所有计算机的访问权限。如果选择此选项，必须输入以下信息：

  • 子网地址 输入一组计算机的基本 IP 地址。

  • 子网掩码 输入指定基本 IP 地址扩展到的 IP 地址范围的子网掩码。

例如，如果输入子网地址 192.168.1.0，子网掩码 255.255.255.0，则 IP 地址处于 192.168.1.1 至 192.168.1.254 范围内的所有计算机都将包括在计算机组中。

域

选择此选项可以授予或拒绝对特定域中所有计算机的访问权限。如果选择此选项，必须在"名称"字段中输入域名。按域名限制访问需要对每个连接执行反向 DNS 查找。这种额外处理开销会影响 SMTP 服务器整体性能。


邮件选项卡

邮件选项卡
SMTP 服务器 > 帮助参考 >

使用"邮件"选项卡上的选项配置应用到邮件大小、会话大小、每个连接的邮件数和每封邮件收件人数的限制。还可配置控制如何处理无法送达邮件的选项。"邮件"选项卡提供以下选项：

邮件大小限制(KB)

选中此复选框可限制此 SMTP 虚拟服务器的邮件大小。要允许使用不受限制的最大邮件大小，请清除此复选框。此 SMTP 虚拟服务器会将该值公布为此 SMTP 虚拟服务器接受的最大邮件大小。如果邮件客户端发送一个超过此限制的邮件，该客户端将收到错误。如果远程服务器支持 EHLO，则当它连接到该 SMTP 虚拟服务器时将能检测到公布的"最大邮件大小"值，并且根本不会尝试传送超过此限制的邮件。相反，会将此邮件连同一份未送达报告 (NDR) 退回给发件人。不支持 EHLO 的远程服务器会尝试发送超过此大小限制的邮件，如果邮件未通过，则会向发件人发送一份 NDR。

对于"邮件大小限制(KB)"，以 KB 为单位，键入一个值用作邮件的最大大小。默认值为 2,048 KB。最小值为 1 KB。

会话大小限制(KB)

选中此复选框可限制在整个连接期间可接受的最大数据量。该值是连接期间发送的所有邮件的总和（仅适用于邮件正文）。

键入一个大于"邮件大小限制(KB)"的值。请谨慎地设置此最大值，因为连接的邮件传输代理 (MTA) 可能会重复地提交邮件。默认大小为 10,240 KB。最小值等于分配给单个邮件大小限制的值。

限制每个连接的邮件数不超过

选中此复选框可限制在单个连接中发送的邮件数。默认值是 20。此功能还提供了一种提高系统性能的方法，即使用多个连接向远程域发送邮件。因此，达到设置的限制后，会自动打开一个新连接继续传输，直到所有的邮件都已送达。要禁用此功能并且不做任何限制，请清除此复选框。

限制每封邮件的收件人数不超过

选中此复选框可限制单封邮件收件人的最大数目。默认值是 100，该值是征求意见文档 (RFC) 2821 中指定的最低要求值。要禁用此功能并且不做任何限制，请清除此复选框。

收到错误消息后，有些客户端会退回邮件并附带一个 NDR，其中指出已超过最大收件人数。在这种情况下，运行 Windows Server 2008 SMTP 服务器的服务器不会将邮件连同 NDR 一起退回。而是立即打开一个新连接，为其余收件人处理邮件。例如，如果收件人限制设置为 100，而正在传输的邮件有 105 个收件人，则收到错误消息后，在一个连接中会将该邮件传递给前 100 个收件人。然后，服务会打开一个新连接，为其余五个收件人处理邮件。

将未送达报告的副本发送到

如果邮件不可送达，则它会连同一份 NDR 一起退回给发件人。可以指定将 NDR 的副本发送到特定的 SMTP 邮箱。键入该邮箱的电子邮件地址。

死信目录

所有 NDR 都会按照与其他邮件相同的传递流程（包括尝试重新发送邮件）进行传递。如果 NDR 达到重试限制而无法传递给发件人，则该邮件的副本会存放在死信目录中。存放在死信目录中的邮件无法传递也无法退回。定期查看此目录并整理这些邮件，因为该目录满了会对 SMTP 服务器的性能产生不利影响。默认情况下，死信目录是 Mailroot 目录的子目录。要选择另一个位置作为死信目录，请单击"浏览"。


传递选项卡

传递选项卡
SMTP 服务器 > 帮助参考 >

打开连接且接收服务器已确认准备好接收数据后，就可以发送邮件进行传递了。可使用 SMTP 虚拟服务器"属性"页的"传递"选项卡来设置所有传递和路由选项，包括设置传递邮件的重试间隔、限制传递期间的服务器跃点数，以及"发件人"行中要显示的标识虚拟域名而不是发件人的原始域名。

"传递"选项卡上包含下列选项。

出站

使用"出站"设置可以配置 SMTP 虚拟服务器处理延迟邮件的方式。可以使用下列设置：

  • 第一次重试间隔(分钟) 该设置确定在第一次传递尝试失败时，SMTP 虚拟服务器在尝试重新发送邮件之前等待的时间。此设置的默认值是 15 分钟。

  • 第二次重试间隔(分钟) 该设置确定在第一次重试失败时，SMTP 虚拟服务器在尝试重新发送邮件之前等待的时间。此设置的默认值是 30 分钟。

  • 第三次重试间隔(分钟) 该设置确定在第二次重试失败时，SMTP 虚拟服务器在尝试重新发送邮件之前等待的时间。此设置的默认值是 60 分钟。

  • 后续重试间隔(分钟) 该设置确定在第三次重试失败时 SMTP 虚拟服务器尝试重新发送邮件的时间间隔。在达到过期超时时间之前，将一直尝试传递邮件。此设置的默认值是 240 分钟。

  • 延迟通知 该设置确定 SMTP 虚拟服务器在最初尝试传递邮件后，在通知邮件发件人传递延迟之前所等待的时间。该设置的默认值是 12 小时。

  • 过期超时 该设置确定在 SMTP 虚拟服务器使邮件过期并向邮件发件人发送未送达报告 (NDR) 之前，服务器可以继续尝试发送邮件的时间。

本地

使用"本地"设置可以为本地邮件传递配置延迟通知和过期超时。可以使用下列选项：

  • 延迟通知 该设置确定 SMTP 虚拟服务器在最初尝试传递邮件后，在通知邮件发件人传递延迟之前所等待的时间。该设置的默认值是 12 小时。最小值是 1 分钟，最大值是 9999 天。使用下拉菜单可以将该值设置为分钟、小时或天。

  • 过期超时 该设置确定在 SMTP 虚拟服务器使邮件过期并向发件人发送 NDR 之前，可以继续尝试发送邮件的时间。该设置的默认值是 2 天。最小值是 1 分钟，最大值是 9999 天。使用下拉菜单可以将该值设置为分钟、小时或天。

出站安全

单击"出站安全"可以访问"出站安全"对话框，以及配置 SMTP 虚拟服务器用来对接收服务器进行身份验证的身份验证方法和凭据。还可以要求使用传输层安全性 (SSL) 加密会话。您可以在"出站安全"对话框中为所有传出邮件设置这些选项，也可以在"域属性"选项卡上针对特定远程域改写这些选项。在设置访问单个地址的例外时，您可以设置 SMTP 虚拟服务器身份验证和加密级别来处理大多数传输。

出站连接

单击"出站连接"可以配置 SMTP 虚拟服务器以限制并发出站连接数。

高级

单击"高级"可以配置高级传递选项，其中包括最大跃点计数、虚拟域、完全限定域名 (FQDN) 和智能主机标识。


出站安全

出站安全
SMTP 服务器 > 帮助参考 > 传递选项卡 >

使用"出站安全"对话框可以配置 SMTP 虚拟服务器用来对接收服务器进行身份验证的身份验证方法和凭据。可使用三种类型的身份验证：

  • 匿名

  • 基本（明文）

  • 集成 Windows 身份验证

匿名访问是默认选项，不需要进行身份验证。还可以要求使用传输层安全性 (TLS) 加密出站会话。您可以在"出站安全"对话框中为所有传出邮件设置这些选项，也可以在"域属性"选项卡上针对特定远程域改写这些选项。在设置访问单个地址的例外时，您可以设置 SMTP 虚拟服务器身份验证和加密级别来处理大多数传输。

"出站安全"对话框提供以下选项。

匿名访问

使用此选项可禁用对出站传输的身份验证。这是默认选项。

基本身份验证

使用"基本身份验证"选项，要连接的服务器的帐户名称和密码将以明文方式传输。此选项应与接收服务器的传入身份验证要求匹配。此选项要求使用用户名和密码。单击"浏览"选择用户。

集成 Windows 身份验证

选择此选项可使用集成 Windows 身份验证来进行身份验证。此选项应与接收服务器的传入身份验证要求匹配。此选项要求使用 Windows 用户帐户名称和密码。单击"浏览"选择帐户。

TLS 加密

选中此复选框可要求所有的传出邮件都使用 TLS 加密。


传递选项卡 > 出站连接

传递选项卡 > 出站连接
SMTP 服务器 > 帮助参考 > 传递选项卡 >

使用"出站连接"对话框以在此 SMTP 虚拟服务器上配置出站连接数的设置。"出站连接"对话框提供以下选项：

限制连接数不超过

配置此设置可为所有远程域指定并发出站连接的最大数目。默认情况下此复选框是选中的，默认限制是 1,000。最小连接数是 1。如果清除此复选框，则不对出站连接数强加任何限制。

超时(分钟)

配置此设置可指定在连接超时前 SMTP 虚拟服务器等待来自接收服务器响应的时间。默认情况下，此设置的值为 10 分钟。如果连接在指定的分钟数内不活动，则 Windows Server 2008 SMTP 服务器会将其关闭。

限制每个域的连接数不超过

配置此设置可为任何单个远程域指定并发出站连接的最大数目。默认情况下，该值设置为 100。该值应小于或等于为"限制连接数不超过"设置的值。

TCP 端口

配置此设置可指定用于出站 SMTP 传输的 TCP 端口。默认设置是端口 25。它是 SMTP 标准 TCP 端口。


传递选项卡 > 高级传递

传递选项卡 > 高级传递
SMTP 服务器 > 帮助参考 > 传递选项卡 >

可使用"高级传递"对话框在 SMTP 虚拟服务器上设置路由选项。"高级传递"对话框提供以下选项：

最大跃点计数

传递一封邮件后，在到达最终目的地之前该邮件可能被路由到多个服务器。可以指定邮件经过的服务器数目，称为跃点计数。

设置了跃点计数以后，SMTP 虚拟服务器将计算在邮件头的"接收"标头行中列出的跃点数目。"接收"字段的数目超过最大跃点计数设置时，该邮件将退回发件人，并附带一个未送达报告 (NDR)。默认情况下，最大跃点计数的值为 15。

虚拟域

虚拟域名将替换在 SMTP 协议的"发件人"行列出的本地域名。

完全限定域名

可以使用以下两种记录来标识和验证 TCP/IP 网络中的计算机：

  • 邮件交换器 (MX) 记录

  • 地址 (A) 记录

MX 记录标识与 SMTP 虚拟服务器相关的主机和域名。MX 记录使用完全限定域名 (FQDN) 作为域名。A 记录标识计算机的 IP 地址。同时使用这两种记录时，名称解析的速度会更快。

对于要处理 MX 记录的 Windows Server 2008 SMTP 服务器，必须指定一个 FQDN。域名系统 (DNS) 使用 FQDN 标识域的主机服务器。其语法是 host.domain。例如，CompanyA.com 可能有多个主机服务器，其中一个名为 Server01。该服务器的 FQDN 是 Server01.CompanyA.com。

默认情况下，FQDN 是为 SMTP 虚拟服务器配置的默认域的名称。要取消自动使用默认域，请在"传递"选项卡上更改 FQDN。

智能主机

可以使用智能主机来路由目标为远程域的所有传出邮件，而不是将这些邮件直接发送到域。这样，您可使邮件沿着可能比其他路由更直接或更节省费用的连接传送。智能主机与远程域的路由域选项相似。二者的差别是指定了智能主机以后，所有的传出邮件都路由到该服务器。而使用路由域时，只有目标为远程域的邮件才会路由到特定服务器。

请确保指定的智能主机经过安全性优化，并且由受信任的权威部门进行管理，尤其是在转发机密信息时。

如果设置了智能主机，仍然可以为远程域指定不同的路由。路由域设置将覆盖智能主机设置。

键入 FQDN 或 IP 地址来标识智能主机。如果使用 IP 地址，请用 [ ] 将其括起，以提高系统性能。SMTP 服务将首先检查名称，然后检查 IP 地址。括号会将值标识为 IP 地址。因此，将不进行 DNS 查找。

在发送到智能主机之前尝试直接传递

选择此选项，尝试在将远程邮件转发到智能主机服务器之前将其直接传递。默认设置为将所有远程邮件发送到智能主机而不尝试直接传递。

对传入邮件执行反向 DNS 查找

如果选择此选项，SMTP 服务器将尝试验证客户端的 IP 地址是否与客户端以 EHLO/HELO 命令提交的主机/域匹配。如果成功执行了反向 DNS 查找，"接收"标头将保持不变。如果验证不成功，将在该邮件的"接收"标头中的 IP 地址之后显示"未验证"。如果 DNS 查找失败，将在该邮件的"接收"标头中显示"RDNS 失败"。由于此功能将验证所有的传入邮件地址，其使用可能会影响 SMTP 服务器性能。


LDAP 路由选项卡

LDAP 路由选项卡
SMTP 服务器 > 帮助参考 >

可以配置 SMTP 虚拟服务器，使其查询轻型目录访问协议 (LDAP) 服务器来解析发件人和收件人。例如，可以将 Active Directory 目录服务用作 LDAP 服务器，并使用 Active Directory 用户和计算机管理工具创建在 SMTP 虚拟服务器中自动展开的组邮件列表。

使用"LDAP 路由"选项卡启用 LDAP 路由并指定此 SMTP 虚拟服务器所使用的目录服务服务器的标识和属性。目录服务存储有关邮件客户端及其邮箱的信息。SMTP 虚拟服务器使用 LDAP 与目录服务通信。

要启动 LDAP 路由，请选择"启用 LDAP 路由"复选框。然后可以配置下列字段：

服务器

键入正在运行 LDAP 目录的计算机名称。如果使用 Microsoft LDAP Servic 架构类型，则该字段不适用，因为该服务会找到一个附近的服务器并自动使用它。

架构

选择要使用的目录服务类型。可用类型如下所示：

  • Active Directory 选择此选项会将 Active Directory 用作 LDAP 服务器。若要管理邮箱，请在 Microsoft 管理控制台中使用 Active Directory 用户和计算机。

  • Site Server 成员目录 选择此选项会使用 Microsoft Site Server 3.0 LDAP 服务器管理邮箱。

  • Exchange LDAP Service 如果将 Exchange LDAP Service 作为 Microsoft Commercial Internet System 2.0 Mail 的一个组件安装，并且使用它管理邮箱，请使用此选项。

绑定

选择绑定类型。绑定类型指定了目录服务如何验证 SMTP 虚拟服务器的身份。可用类型如下所示：

  • 匿名 不向目录服务发送用户名或密码。该选项是您创建的 SMTP 虚拟服务器的默认选项。

  • 纯文本 将"用户名"和"密码"值以不加密的明文形式发送给目录服务。该选项是默认 SMTP 虚拟服务器的默认选项。

  • Windows SSPI 客户端和服务器协商确定双方可接受的身份验证级别，并使用可用的最严格的方法。选中此选项时，需要提供用户名和密码信息。

  • 服务帐户 使用正在运行 SMTP 服务的帐户的凭据。该帐户由"管理工具"下的"服务"控制。

域

键入绑定至 LDAP 目录所使用的帐户的域。如果选择纯文本或 Windows SSPI 绑定类型，则此选项适用。

用户名

键入要用于绑定至 LDAP 目录的帐户的可分辨名称 (DN)。例如： cn=user1,ou=users,o=company.

如果选择纯文本或 Windows SSPI 绑定类型，则此选项适用。

密码

键入用于登录至目录服务的密码。如果选择纯文本或 Windows SSPI 绑定类型，则此选项适用。

基准

键入正在访问的目录服务中某一容器的可分辨名称。此设置可指定希望 SMTP 服务开始在 LDAP 目录中搜索的位置。搜索将会从指定的容器开始，并可根据需要继续搜索子容器。

如果用户帐户位于 LDAP 目录的子容器中，则可能需要使用基准。指定基准可使 LDAP 目录更快地返回结果。在某些情况下必须指定基准，如 LDAP 服务器中存在多个命名上下文时。


安全选项卡

安全选项卡
SMTP 服务器 > 帮助参考 >

使用"安全"选项卡可以指定具有 SMTP 虚拟服务器操作员权限的客户端帐户。通过从列表中选择任何现有 Windows 帐户，可以为该帐户授予虚拟服务器的访问权限，也可以通过从 SMTP 虚拟服务器操作员列表中删除帐户来撤消这些权限。

"安全"选项卡提供以下选项。

操作员

该列表显示具有 SMTP 虚拟服务器操作员权限的用户帐户和安全组。操作员可以访问和配置 SMTP 虚拟服务器。

添加

单击"添加"可以打开"选择用户或组"窗口，您可以在该窗口中选择将作为该 SMTP 虚拟服务器操作员的 Windows 用户帐户或安全组。

删除

选择"操作员"列表中的一个条目，然后单击"删除"从 SMTP 虚拟服务器操作员列表中删除帐户。


本地域属性

本地域属性
SMTP 服务器 > 帮助参考 >

本地域是由本地 SMTP 虚拟服务器提供服务的域名系统 (DNS) 域。任何具有本地域名的传入邮件都必须在本地传递到默认域的投递目录，或者连同未送达报告 (NDR) 退回给发件人。本地域也称为服务域或支持域。具有本地域名的电子邮件地址称为本地地址。

本地域可以配置为默认域也可以配置为别名域。创建 SMTP 虚拟服务器时会配置默认域名。可以创建别名域作为默认域的备用标识。默认域用于标记没有域规范的邮件头。为别名域接收的邮件将标记有默认域并会放置在投递目录下。无法配置别名域的属性。别名域使用默认本地域的配置。

可以在默认本地域的"属性"页中配置以下选项。

投递目录

将所有传入本地邮件传递到为默认域设置的投递目录中。目录中没有邮箱。

创建的所有别名域都使用同一个投递目录。可以将任意目录指定为投递目录，前提是该目录是 Windows Server 2008 SMTP 服务器的驱动器本地目录，并且尚未指定为分拣目录。默认情况下，投递目录是 Mailroot 目录的子目录。要选择其他位置，请单击"浏览"。

启用投递目录配额

选中"启用投递目录配额"时，SMTP 服务器将投递目录的大小限制为"邮件"选项卡中"邮件大小限制(KB)"指定的大小的 10 倍。

超出此配额会在协议日志中生成 452 4.2.2 邮箱已满的条目。


远程域属性

远程域属性
SMTP 服务器 > 帮助参考 >

远程域是您向其发送电子邮件的组织之外的域。您可以通过添加域并对其进行相应的配置来为特定远程域设置特殊的传递要求。例如，可以设置预定的传递路由、要求进行身份验证以及要求对域的所有连接都使用传输层安全性 (TLS) 加密。如果没有对远程域进行特别配置，则 Windows Server 2008 SMTP 服务器在将邮件传递到该域时不会执行上述任何特定操作。不过，它将完成常规的 DNS 查找。

可以在远程域名中使用星号 (*)，前提是星号必须列为首字符且后跟句点 (.)。还可以在名称中使用通配符，以便您所创建的域中包含的所有域都使用相同的设置。

对于远程域，可以在"常规"选项卡中设置以下选项：

允许传入邮件中继到此域

默认情况下，SMTP 服务器会阻止计算机将不需要的邮件中继到远程域。选中"允许传入邮件中继到此域"复选框会覆盖"访问"选项卡上的中继限制设置。

发送 HELO 而不是 EHLO

ESMTP 定义用于扩展 SMTP 的方法，使 SMTP 服务器可以通知 SMTP 客户端其支持的扩展。支持 ESMTP 的 SMTP 客户端通过发出 EHLO 命令而不是 HELO 命令来启动 SMTP 会话。一个成功的响应会发出一系列该服务器支持的 SMTP 扩展。如果该服务器不支持 ESMTP，则会生成错误。选中"发送 HELO 而不是 EHLO"复选框可在向远程域发送通知时仅使用 HELO 进行通信。

出站安全

对于特定的远程域，可以改写"传递"选项卡上设置的身份验证和 TLS 加密选项。这样，在启用由特定远程域处理的单个地址例外时，可以设置 SMTP 虚拟服务器身份验证级别来处理大多数传输。选中"出站安全"选项卡可设置该远程域的身份验证级别。

路由域

可以指定下列选项之一来控制将邮件路由到远程域的方式：

  • 使用 DNS 路由到该域选择该选项可以使用 DNS 名称解析查找远程域中的 SMTP 服务器。

  • 将所有邮件转发到智能主机选择该选项可以指定将发送到远程域的邮件转发到智能主机。远程域的智能主机设置会覆盖"传递"选项卡上虚拟服务器的智能主机设置。键入服务器（希望通过该服务器为远程域路由邮件）的完全限定域名或 IP 地址。


远程域属性 > 高级

远程域属性 > 高级
SMTP 服务器 > 帮助参考 > 远程域属性 >

可使用"远程域属性"页上的"高级"选项卡配置远程域的高级邮件传递选项。

可以在"高级"选项卡上配置以下选项。

排列邮件以便进行远程触发传递

选中此复选框将使 Windows Server 2008 SMTP 服务器能够为定期连接以下载这些邮件的客户端保存邮件。在此情况下，客户端将发出 ATRN 命令。然后，简单邮件传输协议 (SMTP) 服务将开始向 ATRN 域发送邮件。对于虚拟服务器为其排队邮件的地址，可以创建一个远程域，并为该域启用 ATRN。

授权使用 ATRN 的帐户

此选项列出被授权使用此远程域的 ATRN 的用户帐户和组。如果需要，可单击"添加"和"删除"来向用户授予或删除 ATRN 权限。

添加

单击"添加"打开"选择用户或组"窗口。选择被授予 ATRN 权限的 Windows 用户帐户或组。

删除

选择"授权使用 ATRN 的帐户"列表中的一个条目，然后单击"删除"从列表中删除该帐户。