数据源向导屏幕 1

SQL Native Client 帮助
数据源向导屏幕 1

指定数据源的名称和说明和运行该数据源将连接的 SQL Server 的服务器名称。

选项

名称

ODBC 应用程序请求与数据源连接时使用的数据源名称。例如，“Personnel”。该数据源名称显示在“ODBC 数据源管理器”对话框中。

说明

（可选）数据源的说明。例如，“所有雇员的雇佣日期、发薪记录和当前审核”。

选择或输入服务器名称

网络中的 SQL Server 实例的名称。您需要在下一个编辑框中指定一个服务器。

大多数情况下，SQL Server Native Client ODBC 驱动程序可通过使用此框中提供的默认协议顺序和服务器名称进行连接。如果要创建服务器别名或配置客户端网络库，请使用 SQL Server 配置管理器。

当您使用同一台计算机作为 SQL Server 时可以在服务器框中输入“(local)”。即使正在运行非联网版的 SQL Server，用户也可以连接到 SQL Server 的本地实例。SQL Server 2000 及更高版本支持在同一台计算机上运行多个 SQL Server 实例。若要指定 SQL Server 的命名实例，则将服务器名称指定为 ServerName\InstanceName。

有关不同网络类型的服务器名称的详细信息，请参阅 SQL Server 联机丛书中的 SQL Server 安装文档。

完成

如果此屏幕上指定的信息为连接到 SQL Server 所需的全部信息，则您可以单击“完成”。对于在向导的其他屏幕上指定的所有属性都使用默认值。


数据源向导屏幕 2

数据源向导屏幕 2

指定身份验证的方式，并设置 Microsoft SQL Server 高级客户端条目和配置数据源时 SQL Server Native Client ODBC 驱动程序将用于连接到 SQL Server 的登录名和密码。

选项

采用使用网络登录 ID 的集成 Windows 身份验证

指定 SQL Server Native Client ODBC 驱动程序请求建立与 SQL Server 之间的安全（或可信）连接。选中后，SQL Server 将使用集成登录安全性来建立使用此数据源的连接，而不考虑服务器上的当前登录安全模式。提供的任何登录 ID 或密码都将忽略。SQL Server 系统管理员必须将您的 Windows 登录名与 SQL Server 登录 ID 关联起来（例如，通过使用 SQL Server Management Studio）。

您还可以指定该服务器的服务主体名称 (SPN)。

采用使用用户输入的登录 ID 和密码的 SQL Server 身份验证

指定 SQL Server Native Client ODBC 驱动程序不请求建立与 SQL Server 之间的安全（或可信）连接。选中此按钮后，SQL Server 使用标准登录安全性建立使用该数据源的连接。您必须为所有连接请求都指定 SQL Server 登录 ID 和密码。

连接到 SQL Server 以获得其他配置选项的默认设置

选中此复选框后，SQL Server Native Client ODBC 驱动程序将从 SQL Server 中获取后续向导屏幕上选项的初始设置。SQL Server Native Client ODBC 驱动程序连接到在第一个屏幕上“服务器”框中命名的 SQL Server 实例。

清除该复选框后，驱动程序使用标准默认值作为向导中后续屏幕上选项的初始设置。

登录 ID

如果选中“采用使用用户输入的登录 ID 和密码的 SQL Server 身份验证”，则指定 SQL Server Native Client ODBC 驱动程序连接到 SQL Server 时使用的登录 ID。这仅适用于为确定服务器默认设置建立的连接；不适用于创建数据源之后使用该数据源建立的后续连接。

密码

如果选中“采用使用用户输入的登录 ID 和密码的 SQL Server 身份验证”，则指定 SQL Server Native Client ODBC 驱动程序连接到 SQL Server 时使用的密码。这仅适用于为确定服务器默认设置建立的连接；不适用于使用新数据源建立的后续连接。

如果选中“采用使用网络登录 ID 的集成 Windows 身份验证”或清除“连接到 SQL Server 以获得其他配置选项的默认设置”，则将同时禁用“登录 ID”和“密码”框。


数据源向导屏幕 3

数据源向导屏幕 3

指定默认数据库、将由驱动程序使用的各种 ANSI 选项和镜像服务器的名称。

选项

“更改默认的数据库为”框

指定使用该数据源建立的任何连接的默认数据库的名称。清除此框后，连接将使用在服务器上为登录 ID 定义的默认数据库。选择此框后，在框中命名的数据库将覆盖为登录 ID 定义的默认数据库。如果“附加数据库文件名”框中包含主文件的名称，则主文件描述的数据库便附加为使用“更改默认的数据库为”框中指定的数据库名称的数据库。

使用登录 ID 的默认数据库比在 ODBC 数据源中指定默认数据库更有效。

“镜像服务器”复选框

指定要镜像的数据库的故障转移伙伴的名称。如果数据库名称未显示在“更改默认的数据库为”框中，或该名称显示在默认数据库中，则“镜像服务器”将灰显。

您还可以指定镜像服务器的服务器主体名称 (SPN)。镜像服务器的 SPN 用于在客户端和服务器之间相互进行身份验证。

“附加数据库文件名”复选框

指定可附加数据库的主文件的名称。该数据库作为数据源的默认数据库附加和使用。指定主文件的完整路径和文件名。在“更改默认的数据库为”框中指定的数据库名称将用作附加数据库的名称。

“使用 ANSI 引用的标识符”复选框

指定在 SQL Server Native Client ODBC 驱动程序连接时将 QUOTED_IDENTIFIERS 设置为开启。选中此复选框后，SQL Server 将执行与引号有关的 ANSI 规则。双引号只能用于标识符，如列和表名称。字符串必须用单引号引起来：

复制代码
SELECT "LastName"
FROM "Person.Contact"
WHERE "LastName" = 'O''Brien'

清除此复选框后，使用引用标识符的应用程序（如 Microsoft Excel 附带的 Microsoft Query 实用工具）将在生成带有引用标识符的 SQL 语句时出错。

“使用 ANSI Null、填充和警告”复选框

指定在 SQL Server Native Client ODBC 驱动程序连接时将 ANSI_NULLS、ANSI_WARNINGS 和 ANSI_PADDINGS 选项设置为开启。

在 ANSI_NULLS 设置为开启时，服务器将执行与比较列是否为 NULL 有关的 ANSI 规则。在所有 NULL 比较中，必须使用 ANSI 语法“IS NULL”或“IS NOT NULL”。不支持 Transact-SQL 语法“= NULL”。

在 ANSI_WARNINGS 设置为开启时，SQL Server 对违反 ANSI 规则但并不违反 Transact-SQL 规则的情况发出警告消息。此类错误的示例为执行 INSERT 或 UPDATE 语句时数据截断，或在执行聚合函数时遇到 Null 值。

在 ANSI_PADDING 设置为开启时，不自动修改 varchar 值上的尾随空格和 varbinary 值上的尾随零。


数据源向导屏幕 4

数据源向导屏幕 4

指定用于 SQL Server 消息的语言、字符集转换以及 SQL Server Native Client ODBC 驱动程序是否应使用区域设置。还可以控制长时间运行查询的日志记录和驱动程序统计信息设置。

选项

将 SQL Server 系统消息的语言更改为

SQL Server 的每个实例都有多组系统消息，每组消息使用不同的语言（例如，英语、西班牙语、法语等等）。如果对具有多组系统消息的服务器定义一个数据源，您可以指定要为系统消息使用哪种语言。在此列表中，单击该语言。如果 SQL Server 中仅安装了一种语言，则此选项不可用。

对数据使用强加密

选中此选项后，将对通过使用此 DSN 建立的连接传输的数据加密。默认情况下，即使清除此复选框，也将对登录名加密。

执行字符数据翻译

选中此复选框后，SQL Server Native Client ODBC 驱动程序使用 Unicode 对客户端计算机和 SQL Server 之间发送的 ANSI 字符串进行转换。SQL Server Native Client ODBC 驱动程序有时在 SQL Server 代码页和客户端计算机中的 Unicode 之间进行转换。这要求 SQL Server 使用的代码页为客户端计算机中可用的代码页之一。

清除此复选框后，当在客户端应用程序和服务器之间发送 ANSI 字符串时，将不会对 ANSI 字符串中的扩展字符进行翻译。如果客户端计算机使用不同于 SQL Server 代码页的 ANSI 代码页 (ACP)，则可能会错误地解释 ANSI 字符串中的扩展字符。如果客户端计算机对 SQL Server 使用的 ACP 使用同一代码页，则会正确地解释扩展字符。

在输出货币、数字、日期和时间时使用区域设置

指定驱动程序使用客户端计算机的区域设置对字符输出字符串中的货币、数字、日期和时间进行格式设置。驱动程序使用通过数据源连接的用户的 Microsoft Windows 2000 登录帐户的默认区域设置。请对仅显示数据的应用程序选择此选项，而对处理数据的应用程序则不要选择此选项。

将长时间运行的查询保存到日志文件

指定驱动程序记录任何时间超出长查询时间值的查询。长时间运行的查询将记录到指定文件中。若要指定一个日志文件，可以在此框中键入完整的路径和文件名，也可以单击“浏览”在现有文件目录中导航选择一个日志文件。

长查询时间(毫秒)

为长时间运行的查询日志记录指定一个阈值（毫秒）。将记录任何运行时间超过该毫秒数的查询。

将 ODBC 驱动程序统计信息记录到日志文件

指定记录的统计信息。统计信息将记录到指定的文件中。若要指定一个日志文件，可以在此框中键入完整的路径和文件名，也可以单击“浏览”在现有文件目录中导航选择一个日志文件。

统计信息日志是一个制表符分隔文件，可以在 Microsoft Excel 或支持制表符分隔文件的任何其他应用程序中进行分析。


“SQL Server 登录”对话框 (ODBC)

“SQL Server 登录”对话框 (ODBC)

当调用一个 ODBC 连接而不为驱动程序指定足够的信息以便连接到 SQL Server 时，Microsoft SQL Server Native Client ODBC 驱动程序将显示“SQL Server 登录”对话框。

选项

服务器

网络中的 SQL Server 实例的名称。从列表中选择一个服务器\实例名，或在“服务器”框中键入服务器\实例名。您还可以在客户端计算机上使用“SQL Server 配置管理器”创建服务器别名，并在“服务器”框中键入该名称。

当您使用同一台计算机作为 SQL Server 时可以输入“(local)”。即使正在运行非联网版的 SQL Server，您也可以连接到 SQL Server 的本地实例。

有关不同网络类型的服务器名称的详细信息，请参阅 SQL Server 联机丛书中的 SQL Server 安装文档。

使用信任连接

选中此框后，指定 SQL Server Native Client ODBC 驱动程序将请求与在 Microsoft Windows 2000、Windows XP 或 Windows 2003 上运行的 SQL Server 实例之间建立一条安全的（或可信的）连接。SQL Server 使用集成登录安全性建立使用该数据源的连接，而不考虑服务器的当前登录安全模式。提供的任何登录 ID 或密码都将忽略。SQL Server 系统管理员必须将您的 Windows 网络 ID 与 SQL Server 登录 ID 关联起来。

清除此框后，SQL Server 使用标准登录安全性建立使用该数据源的连接。您必须为所有连接请求都指定登录 ID 和密码。

重要提示 使用 Windows 身份验证的可信连接比使用 SQL Server 身份验证进行验证的连接更安全。请尽量使用可信连接。

服务器 SPN

如果您使用受信任连接，则可为服务器指定服务主体名称 (SPN)。

登录 ID

如果清除“使用可信连接”，则指定用于此连接的 SQL Server 登录 ID。如果选中“使用可信连接”，则会禁用“登录 ID”框。

密码

如果清除“使用可信连接”，则指定用于此连接的 SQL Server 登录 ID 的密码。如果选中“使用可信连接”，则会禁用“密码”框。

选项

显示或隐藏“选项”组。如果“服务器”具有值，则启用“选项”按钮。

更改密码

选中此框后，将显示“新密码”和“确认新密码”框。

新密码

指定新密码。

确认新密码

再次指定新密码以便确认。

数据库

指定将用于该连接的默认数据库。此设置将覆盖为该服务器上的登录名指定的默认数据库。如果未指定数据库，连接将使用为该服务器上的登录名指定的默认数据库。

镜像服务器

指定要镜像的数据库的故障转移伙伴的名称。

镜像 SPN

您还可以指定镜像服务器的 SPN。镜像服务器的 SPN 用于在客户端和服务器之间相互进行身份验证。

语言

指定用于 SQL Server 系统消息的国家/地区语言。运行 SQL Server 的计算机必须安装该语言。此设置将覆盖为该服务器上的登录名指定的默认语言。如果未指定语言，连接将使用为该服务器上的登录名指定的默认语言。

应用程序名称

（可选）指定将要存储在 sys.sysprocesses 中该连接所在行的 program_name 列的应用程序名称。

工作站 ID

（可选）指定将要存储在 sys.sysprocesses 中该连接所在行的 hostname 列的工作站 ID。


“SQL Server 登录”对话框 (OLE DB)

“SQL Server 登录”对话框 (OLE DB)

当尝试进行 OLE DB 连接而不为访问接口指定足够信息以便连接到 SQL Server 数据库引擎实例时，SQL Server Native Client OLE DB 访问接口显示“SQL Server 登录”对话框。

选项

服务器

网络上的 SQL Server 数据库引擎实例的名称。从列表中选择一个服务器\实例名，或在“服务器”框中键入服务器\实例名。您还可以在客户端计算机上使用“SQL Server 配置管理器”创建服务器别名，并在“服务器”框中键入该名称。

当您使用同一台计算机作为 SQL Server 时可以输入“(local)”。即使正在运行非联网版的 SQL Server，您也可以连接到 SQL Server 的本地实例。

有关不同网络类型的服务器名称的详细信息，请参阅 SQL Server 联机丛书中的 SQL Server 安装文档。

使用信任连接

选中此框后，指定 SQL Server Native Client OLE DB 访问接口将请求与在 Microsoft Windows 2000、Windows XP 或 Windows 2003 上运行的 SQL Server 实例之间建立一个安全的（或可信的）连接。SQL Server 使用集成登录安全性建立使用此数据源的连接，而不考虑服务器上的当前登录安全模式。提供的任何登录 ID 或密码都将忽略。SQL Server 系统管理员必须将您的 Windows 登录名与 SQL Server 登录 ID 关联起来。

清除此框后，SQL Server 使用标准登录安全性建立使用该数据源的连接。您必须为所有连接请求都指定登录 ID 和密码。

重要提示：
使用 Windows 身份验证的可信连接比使用 SQL Server 身份验证进行验证的连接更安全。请尽量使用可信连接。

服务器 SPN

如果您使用受信任连接，则可为服务器指定服务主体名称 (SPN)。

登录 ID

如果清除“使用可信连接”，则指定用于此连接的 SQL Server 登录 ID。如果选中“使用可信连接”，则会禁用“登录 ID”框。

密码

如果清除“使用可信连接”，则指定用于此连接的 SQL Server 登录 ID 的密码。如果选中“使用可信连接”，则会禁用“密码”框。

选项

显示或隐藏“选项”组。如果“服务器”具有值，则启用“选项”按钮。

更改密码

选中后，将显示“新密码”和“确认新密码”框。

新密码

指定新密码。

确认新密码

再次指定新密码以便确认。

数据库

指定将用于该连接的默认数据库。此设置将覆盖为该服务器上的登录名指定的默认数据库。如果未指定数据库，连接将使用为该服务器上的登录名指定的默认数据库。

镜像服务器

指定要镜像的数据库的故障转移伙伴的名称。

镜像 SPN

您还可以指定镜像服务器的 SPN。镜像服务器的 SPN 用于在客户端和服务器之间相互进行身份验证。

语言

指定用于 SQL Server 系统消息的国家/地区语言。运行 SQL Server 的计算机必须安装该语言。此设置将覆盖为该服务器上的登录名指定的默认语言。如果未指定语言，连接将使用为该服务器上的登录名指定的默认语言。

应用程序名称

（可选）指定将要存储在 sys.sysprocesses 中该连接所在行的 program_name 列的应用程序名称。

工作站 ID

（可选）指定将要存储在 sys.sysprocesses 中该连接所在行的 hostname 列的工作站 ID。


SQL Server 的“连接”选项卡

SQL Server 的“连接”选项卡

使用“连接”选项卡指定连接 Microsoft SQL Server 数据的方式。

该“连接”选项卡特定于访问接口并且只显示 OLE DB Provider for Microsoft SQL Server 需要的连接属性。

选项

选择服务器

从下拉列表中选择服务器名称，或者键入要访问的数据库所在的服务器的位置。在服务器上选择数据库是一项单独的操作。单击“刷新”可刷新列表。

输入登录服务器所需的信息

指定身份验证服务。

“Windows NT 集成安全性”指定 SQL Server 驱动程序请求一个与在支持的 Microsoft 操作系统上运行的 SQL Server 之间的安全的（或可信的）连接。选中后，SQL Server 将使用集成登录安全性来建立使用此数据源的连接，而不考虑服务器上的当前登录安全模式。提供的任何登录 ID 或密码都将忽略。SQL Server 系统管理员必须将您的 Windows 登录名与 SQL Server 登录 ID 关联起来。如果选择了 Windows NT 集成安全性，您还可以选择要用于在客户端和服务器之间相互进行身份验证的服务主体名称 (SPN)。

或者输入“特定用户名和密码”对该数据源验证您的登录信息。SQL Server 驱动程序不会请求到 SQL Server 的安全（或可信）连接。SQL Server 将使用标准登录安全性建立连接。您必须为所有连接请求都指定 SQL Server 登录 ID 和密码。

选中“允许保存密码”可允许将密码与连接字符串保存在一起。是否在连接字符串中包括密码取决于调用应用程序的功能。密码在返回和保存时是未屏蔽和未加密的。

选中“空白密码”可使指定的访问接口在连接字符串中返回空密码。

选择数据库

从下拉列表中选择数据库或键入数据库名称。您还可以指定一个镜像数据库，如果您选择 Windows NT 集成安全性，则还可以为镜像服务器指定一个 SPN。镜像服务器的 SPN 用于在客户端和服务器之间相互进行身份验证。

选中“将数据库文件附加为数据库名称”可指定附加数据库的主文件名。该数据库作为数据源的默认数据库附加和使用。指定主文件的完整路径和文件名。在“更改默认的数据库为”框中指定的数据库名称将用作附加数据库的名称。

更改密码

如果您使用 SQL Server 身份验证，通过此选项可更改 SQL Server 密码。

测试连接

单击“测试连接”可尝试连接到指定的数据源。如果连接失败，请确保设置是正确的。例如，拼写错误和大小写不同均可能导致连接失败。


SQL Server 的“高级”选项卡

SQL Server 的“高级”选项卡

指定访问接口等待初始化完成所用的时间（秒）。

选项

连接超时

指定访问接口等待初始化完成所用的时间（秒）。如果初始化超时，则返回一个错误并且不创建该连接。


文档法律声明

文档法律声明

本文档支持软件程序“SQL Server 2008 R2”的最终商业版本。本文档中的信息是 Microsoft Corporation 的专有信息，属于机密信息。

本文档按“原样”提供。本文档中的信息和表达的观点（包括 URL 和其他 Internet 网站引用）如有更改，恕不另行通知。您应承担使用本文档所带来的风险。本文档中提及的某些示例只是为了便于说明，纯属虚构。不应据此联想或妄加推断。

本文档不向您提供对任何 Microsoft 产品中的任何知识产权的任何法律权利。您可以出于内部参考目的复制和使用本文档。

版权所有 © 2010 Microsoft Corporation。保留所有权利。

Microsoft、Active Directory、ActiveX、Bing Maps、Excel、IntelliSense、MSDN、MS-DOS、PivotChart、PivotTable、PowerPoint、SharePoint、SQL Server、Visual Basic、Visual C#、Visual C++、Visual Studio、Windows、Windows NT、Windows Server 和 Windows Vista 是 Microsoft 集团公司的商标。

SAP NetWeaver 是 SAP AG 在德国和其他几个国家/地区的注册商标。

所有其他商标归其各自拥有者所有。

SQL Server 支持和升级文档策略

文档 - 支持和升级策略

Microsoft SQL Server 2008 R2 软件文档包括 Microsoft 发布的 SQL Server 联机丛书（“BOL”）、自述文件、已知问题文档、示例代码/应用程序、示例数据库和知识库文章，这些文档都包含与 SQL Server 的特征和功能相关的内容（以下统称“文档”）。下面的摘要描述了文档中提到的某些特征和功能的支持及升级策略。

示例。文档中包含的示例主要用于阐释概念以及特定语句或子句的合理用法。大多数示例不包括完整的生产系统通常所包含的全部代码，因为其中删除了某些常用的数据验证和错误处理，以便使示例突出特定的概念或语句。Microsoft 客户支持服务部门不为文档中包含的任何示例提供支持。

占位符。在某些情况下，SQL Server 2008 R2 中的特定功能尚未经过充分测试或开发，不适合使用。此类功能通常作为占位符在 BOL、自述文件或其他文档中列出，仅用作标记以供 Microsoft 内部参考。此类功能不适合使用，且 Microsoft 客户支持服务部门不为这些功能提供支持。尝试使用此类功能可能导致数据丢失。

第三方内容。除非文档另有说明，否则 Microsoft 客户支持服务部门不会对第三方内容（包括将此类第三方内容与 SQL Server 2008 R2 结合使用而导致的问题）提供支持。

未记录的入口点。Microsoft 客户支持服务部门不为利用或使用未记录的入口点（如未记录的 API）的数据库或应用程序提供支持，其中包括但不限于：存储过程、扩展存储过程、函数、视图、表、列、属性或元数据。此类使用可能导致数据丢失。

升级。对于利用或使用未记录的入口点的应用程序和数据库，其服务器和数据库可能无法升级至 SQL Server 2008 R2 的未来版本，且此类服务器和数据库的升级不享有 Microsoft 客户支持服务部门的支持。

有关 Microsoft 支持生命周期策略的详细信息，请访问下面的网站：http://support.microsoft.com/lifecycle。