ASP.NET 的 MMC 管理单元

ASP.NET
ASP.NET 的 MMC 管理单元
DropDown image

本节包含的主题描述如何使用 Microsoft 管理控制台 (MMC) 管理单元配置 ASP.NET 和 ASP.NET 应用程序。

MMC 承载一些管理工具，使用这些管理工具可以管理计算机、服务、其他系统组件和网络。可以将这些管理工具（称作管理单元）中的一个或多个添加到控制台以管理 Web 应用程序。用于 Microsoft 管理控制台 (MMC) 的 ASP.NET 管理单元工具提供了一种一站式用户界面 (UI) 来配置 Web 服务器及其承载的应用程序。该工具包含几个对话框，通过这些对话框可以管理特定的功能（如自定义错误处理或用户身份验证）。

本节内容

“ASP.NET 配置设置”对话框 ->“常规”选项卡
“ASP.NET 配置设置”对话框 ->“自定义错误”选项卡
“ASP.NET 配置设置”对话框 ->“授权”选项卡
“ASP.NET 配置设置”对话框 ->“身份验证”选项卡
“ASP.NET 配置设置”对话框的“应用程序”选项卡
“ASP.NET 配置设置”对话框 ->“状态管理”选项卡
“ASP.NET 配置设置”对话框的“位置”选项卡
“编辑/添加连接字符串”对话框
“编辑/添加应用程序设置”对话框
“编辑/添加自定义错误处理程序”对话框
“编辑规则”对话框
“添加位置”对话框

相关章节

配置 ASP.NET 应用程序

提供有关 ASP.NET 配置模型的信息。其中包括 XML 文件和配置编程 API 的用法。
要提出有关“帮助”或本产品其他功能的建议或错误报告，请转到反馈站点。


“ASP.NET 配置设置”对话框 ->“常规”选项卡

“ASP.NET 配置设置”对话框 ->“常规”选项卡
请参见
DropDown image

通过“ASP.NET 配置设置”对话框的“常规”选项卡可以管理以下两种类型的配置设置：

  • 连接字符串，它定义在与数据存储区（如数据库）建立连接时所使用的信息。

  • 应用程序设置，它是简单的名称/值对，可用于在中心位置创建适用于整个应用程序范围的值。然后就可以从 Web 应用程序的任何位置访问这些应用程序值。通过将应用程序设置作为配置的一部分，可以轻松地更改这些设置。应用程序设置始终存储为字符串。

您在“常规”选项卡上进行的设置应用于您在打开“属性”对话框之前所选择的 Web 应用程序。

Note 注意

配置设置可以被继承。可在 Machine.config 文件中定义设置，此文件充当服务器上所有网站和应用程序的基本配置。通过在 Web 应用程序级别上进行配置设置，可以创建新设置或者重写继承的设置。

打开“常规”对话框

  1. 在 Microsoft Windows 中，打开“管理工具”，然后单击“Internet 信息服务 (IIS) 管理器”。

    出现 IIS 管理器。

  2. 在“Internet 信息服务”下，展开 Servername“(本地计算机)”，展开“网站”，右击 Websitename 或“默认网站”，然后单击“属性”。

    出现“网站属性”对话框。

  3. 单击“ASP.NET”选项卡，然后单击“编辑配置”。

    将出现“ASP.NET 配置设置”对话框。

  4. 单击“常规”选项卡。

任务

使用“常规”选项卡可以执行以下操作：

  • 定义 Web 应用程序的数据库连接字符串。

  • 创建用来存储常用信息的字符串值。然后，可以从应用程序的任何位置访问这些信息，也可以轻松更改这些信息。

用户界面元素

连接字符串管理器

列出为所选 Web 应用程序定义的连接字符串。继承的设置以斜体显示，已经重写的继承设置以粗体显示。

添加

单击它可显示“编辑/添加连接字符串”对话框，在该对话框中可以创建新的连接字符串。

编辑

单击它可显示“编辑/添加连接字符串”对话框，在该对话框中可以编辑现有的连接字符串。

您可以重写继承的设置；在这种情况下，重写的设置仅应用于所选的 Web 应用程序。但您不能通过编辑继承设置，来更改配置层次结构中处于较高级别的该设置的值。

移除

单击它可移除或禁用连接字符串。

您可以永久移除为此 Web 应用程序定义的新设置。如果移除了继承设置，则原始设置将在其层次结构位置上保持不变，但是 IIS 管理器将为该设置创建 <remove> 项，这将禁用该设置。

重置

单击它可将重写或移除的设置还原为其原始值。

IIS 管理器将移除本地被重写的值或删除 <remove> 项，以便允许优先使用继承的设置。

应用程序设置

列出应用程序设置键/值对。

添加

单击可显示“编辑/添加应用程序设置”对话框，在该对话框中可以创建新的键/值对。

编辑

单击可显示“编辑/添加应用程序设置”对话框，在该对话框中可以创建新的键/值对。

您可以重写继承的设置；在这种情况下，重写的设置仅应用于所选的 Web 应用程序。但您不能通过编辑继承设置，来更改配置层次结构中处于较高级别的该设置的值。

移除

单击可移除或禁用键/值对。

您可以永久移除为此 Web 应用程序定义的新应用程序设置。如果移除了继承设置，则原始设置将在其层次结构位置上保持不变，但是 IIS 管理器将为该设置创建 <remove> 项，这将禁用该设置。

重置

单击可将重写或移除的键/值对还原为其原始值。

IIS 管理器将移除本地被重写的值或删除 <remove> 项，以便允许优先使用继承的设置。

请参见

任务

如何：以编程方式访问 ASP.NET 配置设置

参考

“ASP.NET 配置设置”对话框 ->“身份验证”选项卡
“ASP.NET 配置设置”对话框 ->“授权”选项卡
“ASP.NET 配置设置”对话框 ->“自定义错误”选项卡
“ASP.NET 配置设置”对话框的“位置”选项卡
connectionStrings 元素（ASP.NET 设置架构）
appSettings 元素（常规设置架构）

概念

ASP.NET 配置概述


“ASP.NET 配置设置”对话框 ->“自定义错误”选项卡

“ASP.NET 配置设置”对话框 ->“自定义错误”选项卡
请参见
DropDown image

在 ASP.NET 网页或组件中发生错误时，ASP.NET 将引发错误代码。错误可以包括以下类型：

  • 编译时错误。

  • 分析器错误（格式不正确的 ASP.NET 元素）。

  • 配置错误。

  • 运行时错误。

默认情况下，ASP.NET 动态生成错误页，其中包含错误说明、发生错误的页面的名称，以及堆栈跟踪。如果启用了调试模式，则动态生成的页面还包括出现错误的源代码的摘要。通过定义自定义错误，可以指定在发生错误时 Web 应用程序的响应方式。

Note 注意

有关调试模式的详细信息，请参见“ASP.NET 配置设置”对话框的“应用程序”选项卡。

显示“ASP.NET 配置设置”对话框的“自定义错误”选项卡

  1. 在 Microsoft Windows 中，打开“管理工具”，然后单击“Internet 信息服务 (IIS) 管理器”。

    出现 IIS 管理器。

  2. 在“Internet 信息服务”下，展开 Servername“(本地计算机)”，展开“网站”，右击 Websitename 或“默认网站”，然后单击“属性”。

    出现“网站属性”对话框。

  3. 单击“ASP.NET”选项卡，然后单击“编辑配置”。

    将出现“ASP.NET 配置设置”对话框。

  4. 单击“自定义错误”选项卡。

任务

使用“自定义错误”选项卡可以执行以下操作：

  • 指定在 Web 应用程序中的任何地方发生 ASP.NET 错误时显示的默认错误页。

  • 将特定的 HTTP 错误代码映射到相应的错误页。

    Note 注意

    映射只对 ASP.NET 得到通知的错误有效。例如，默认情况下，发生 HTTP 404 错误（找不到页面）时不通知 ASP.NET。如果想让 ASP.NET 接收这些错误，可以将网站属性设置为将 HTTP 错误映射到 .aspx 页。

  • 指定是将自定义错误页显示给所有用户，还是不显示给任何用户，还是显示给远程用户（非管理用户）。

用户界面元素

自定义错误模式

单击一个指定如何显示自定义错误的模式，如下所示：

  • 开

    始终显示自定义错误页。使用此设置可以在开发 Web 应用程序的过程中查看错误。

  • 关

    不显示自定义错误页。而是在发生错误时产生动态生成的 ASP.NET 错误页。

  • 仅限远程

    只对不是源自本地 Web 服务器的请求重定向错误。使用此模式，可以在服务器上操作时查看 ASP.NET 错误，而向 Web 应用程序用户显示自定义错误。

默认重定向 URL

键入在响应 Web 应用程序中的任何地方的未处理错误时显示的页面的名称（.aspx 或 .htm）。

继承的自定义错误

列出从在层次结构中位于更高级别的配置文件继承的自定义错误页。通过添加想要重写的状态代码的本地自定义错误，可以重写继承的错误设置。

本地自定义错误

专门列出当前网站的错误页。

添加

单击可打开“编辑/添加自定义错误处理程序”对话框，在该对话框中可以指定当 ASP.NET 检测到错误时要显示的 HTTP 错误代码和页面。

Note 注意

映射只对 ASP.NET 得到通知的错误有效。例如，默认情况下，发生 HTTP 404 错误（找不到页面）时不通知 ASP.NET。如果想让 ASP.NET 接收这些错误，可以将网站属性设置为将 HTTP 错误映射到 .aspx 页。

必须提供 HTTP 错误代码和它要映射到的页面的 URL。所引用的页不必在当前网站中。

Note 注意

IIS 管理器不验证所输入的 URL。

编辑

单击可打开“编辑/添加自定义错误处理程序”对话框，在该对话框中可以更改在“本地自定义错误”下面选择的页面的名称或错误代码。

移除

单击它可以删除错误页面映射。

请参见

任务

如何：以编程方式访问 ASP.NET 配置设置

参考

“ASP.NET 配置设置”对话框 ->“身份验证”选项卡
“ASP.NET 配置设置”对话框 ->“授权”选项卡
“ASP.NET 配置设置”对话框的“位置”选项卡
connectionStrings 元素（ASP.NET 设置架构）
appSettings 元素（常规设置架构）

概念

ASP.NET 配置概述


“ASP.NET 配置设置”对话框 ->“授权”选项卡

“ASP.NET 配置设置”对话框 ->“授权”选项卡
请参见
DropDown image

使用“ASP.NET 配置设置”对话框的“授权”选项卡，可以根据用户帐户或角色管理当前网站目录的授权规则。可以通过使用 Microsoft Windows 身份验证或 ASP.NET Forms 身份验证（ASP.NET 成员资格）来创建用户帐户和角色。您可以添加、编辑或移除当前网站目录的规则。如果规则不被当前 URL 的下级子目录中的配置文件设置所覆盖，则规则将应用于当前 URL 的当前子目录和所有下级子目录。

在该选项卡中还显示从 Machine.config 配置文件和任何父虚拟目录继承的规则，但无法编辑它们。若要更改继承规则的效果，可以在网站级别创建新的设置。应用程序设置始终存储为字符串。

您在“授权”选项卡上进行的设置应用于显示“属性”对话框之前所选择的网站。

Note 注意

配置设置可以被继承。可在 Machine.config 文件中定义设置，此文件充当服务器上所有网站的基本配置。有关 ASP.NET 配置文件的更多信息，请参见 ASP.NET 配置文件层次结构和继承。

打开“授权”对话框

  1. 在 Windows 中，打开“管理工具”，然后单击“Internet 信息服务 (IIS) 管理器”。

    出现 IIS 管理器。

  2. 在“Internet 信息服务”下，展开 Servername“(本地计算机)”，展开“网站”，右击 Websitename 或“默认网站”，然后单击“属性”。

    出现“网站属性”对话框。

  3. 单击“ASP.NET”选项卡，然后单击“编辑配置”。

  4. 将出现“ASP.NET 配置设置”对话框。

  5. 单击“授权”选项卡。

任务

使用“授权”选项卡可以执行以下操作：

  • 查看在所有继承的配置文件（包括 Machine.config 文件）中定义的授权规则。

  • 添加、编辑和移除当前网站目录的授权规则。

规则优先级

授权规则按从上到下的顺序应用。在某些情况下，为了建立正确的权限，可能需要为同一个文件夹创建多个规则。例如，可能会创建一条规则，该规则拒绝对匿名用户帐户的访问，同时创建第二条规则，该规则拒绝对 Guest 角色中的用户帐户的访问。这样，只有非 Guest 组中的登录用户（即非匿名用户）才能访问该文件夹。

Web.config 设置

通过“安全”选项卡管理的 Web.config 设置为 <authorization>、<roleManager> 和 <authentication> 节。

下列设置摘录自 Web.config 文件，这些设置限制对网站子目录的访问。这些设置允许管理员和名为 John 的用户访问受限制的子目录，拒绝匿名用户访问该目录。

CopyCode image 复制代码
<?xml version="1.0" encoding="utf-8"?>
<configuration>
    <system.web>

                    <authorization>            <allow roles="administrators" />            <allow users="John"/>            <deny users="?" />        </authorization>
    </system.web>
</configuration>

用户界面元素

继承的授权规则

列出在 Machine.config 文件或任何父虚拟目录中所定义的继承授权规则，父虚拟目录在 ASP.NET 配置文件层次结构和继承中定义。继承的设置以斜体显示，已经重写的继承设置以粗体显示。

本地授权规则

列出应用于当前网站目录及其所有子目录的授权规则。

添加

单击可打开“编辑规则”对话框以创建新规则。

编辑

单击可打开“编辑规则”对话框以编辑选定的规则。

移除

单击可从“本地授权规则”中删除选定的行。

请参见

任务

如何：以编程方式访问 ASP.NET 配置设置

参考

“ASP.NET 配置设置”对话框 ->“身份验证”选项卡
“ASP.NET 配置设置”对话框的“位置”选项卡
connectionStrings 元素（ASP.NET 设置架构）
appSettings 元素（常规设置架构）

概念

ASP.NET 配置概述

其他资源

ASP.NET 的 MMC 管理单元


“ASP.NET 配置设置”对话框 ->“身份验证”选项卡

“ASP.NET 配置设置”对话框 ->“身份验证”选项卡
请参见
DropDown image

使用“ASP.NET 配置设置”对话框的“身份验证”选项卡，可以管理当前网站的用户帐户和角色的身份验证。ASP.NET 身份验证是从用户帐户处获取标识凭据（如用户名和密码）并通过某些授权机构验证这些凭据的过程。有关 ASP.NET 如何实现身份验证的完整说明，请参见 ASP.NET 身份验证。

通过“身份验证”选项卡还可以添加、移除和配置当前 Web 应用程序的成员资格提供程序和角色管理。利用 ASP.NET 角色管理可以指定应用程序中的用户帐户可访问的资源。通过角色管理，可以将用户帐户分配到角色，这样可以将用户帐户组作为一个单位来对待。有关 ASP.NET 角色管理的更多信息，请参见了解角色管理。

可以在 Web 应用程序中创建并使用自定义的成员资格提供程序。有关如何实现自定义成员资格提供程序的完整说明，请参见实现成员资格提供程序。

您在“身份验证”选项卡上进行的设置应用于打开“属性”对话框之前所选择的网站。

Note 注意

配置设置可以被继承。可在 Machine.config 文件中定义设置，此文件充当服务器上所有网站的基本配置。有关 ASP.NET 配置文件的更多信息，请参见 ASP.NET 配置文件层次结构和继承。

显示“ASP.NET 配置设置”对话框的“身份验证”选项卡

  1. 在 Microsoft Windows 中，打开“管理工具”，然后单击“Internet 信息服务 (IIS) 管理器”。

    出现 IIS 管理器。

  2. 在“Internet 信息服务”下，展开 Servername“(本地计算机)”，展开“网站”，右击 Websitename 或“默认网站”，然后单击“属性”。

    出现“网站属性”对话框。

  3. 单击“ASP.NET”选项卡，然后单击“编辑配置”。

    将出现“ASP.NET 配置设置”对话框。

  4. 单击“身份验证”选项卡。

任务

使用“身份验证”选项卡可以执行以下操作：

  • 配置当前 Web 应用程序的身份验证类型。

  • 添加、移除和修改当前 Web 应用程序的成员资格提供程序。

  • 添加、移除和修改当前 Web 应用程序的角色成员资格提供程序。

用户界面元素

身份验证模式

单击可为当前网站指定身份验证模式。有关每种身份验证模式的完整说明，请参见 ASP.NET 身份验证。

HTTP Cookie 名称

键入用于当前网站身份验证的 HTTP Cookie 的名称。“HTTP Cookie 名称”仅可用于配置 Forms 身份验证。

登录 URL

键入一个 URL，如果没有找到任何有效的身份验证 Cookie，则将请求重定向到该 URL 以便登录。默认为 login.aspx。“登录 URL”仅可用于配置 Forms 身份验证。

Cookie 保护

单击以指定用于身份验证 Cookie 的加密类型（如果有）。“Cookie 保护”仅可用于配置 Forms 身份验证。

Cookie 超时

输入以整数分钟的时间量，超过此时间量，身份验证 Cookie 将过期。默认值为 30。“Cookie 超时”仅可用于配置 Forms 身份验证。

需要 SSL

选择此复选框，以指定传输身份验证 Cookie 需要 SSL 连接。“需要 SSL”仅可用于配置 Forms 身份验证。

启用可调到期

选择此复选框以在下列条件下重置有效身份验证 Cookie 的过期时间：已发出请求并且已运行时间超过了超时间隔的一半。“启用可调到期”仅可用于配置 Forms 身份验证。

成员资格提供程序类

单击可为当前网站指定配置的成员资格提供程序。

管理提供程序

单击可打开“提供程序设置”对话框，该对话框可以用来添加、移除和配置当前网站的成员资格提供程序。

启用角色管理

选择此复选框可以启用角色管理，以便管理用户帐户组的访问规则。

角色提供程序类

单击可为当前网站指定配置的角色成员资格提供程序。

管理提供程序

单击可打开“提供程序设置”对话框，该对话框可以用来添加、移除和配置当前网站的角色成员资格提供程序。

请参见

概念

实现成员资格提供程序
了解角色管理
ASP.NET 配置文件层次结构和继承

其他资源

ASP.NET 身份验证
ASP.NET 的 MMC 管理单元


“ASP.NET 配置设置”对话框的“应用程序”选项卡

“ASP.NET 配置设置”对话框的“应用程序”选项卡
请参见
DropDown image

通过“ASP.NET 配置设置”对话框的“应用程序”选项卡可以管理三种类型的配置设置：

  • 公共编译、页和运行时设置。

  • 全球化设置。

  • 标识设置。

在 Microsoft Internet 信息服务 (IIS) 管理器中显示“ASP.NET 配置设置”对话框

  1. 打开 Web 应用程序的“属性”对话框。

  2. 依次单击“ASP.NET”、“编辑配置”和“应用程序”。

您在“应用程序”选项卡上进行的设置应用于显示“属性”对话框之前所选择的 Web 应用程序。您在“应用程序”选项卡上应用的设置将显示在 Web 应用程序的 Web.config 文件的 system.web 配置节。

Note 注意

配置设置是可继承的。可在 Machine.config 文件中定义设置，此文件充当服务器上所有网站和 Web 应用程序的基本配置。通过在 Web 应用程序级别上进行配置设置，可以创建新设置或者重写继承的设置。

有关“ASP.NET 配置设置”的信息，请参见 ASP.NET 配置概述。

任务

  • 使用“应用程序”选项卡可以完成以下任务：

  • 设置 Web 应用程序中 ASP.NET 页的默认语言。

  • 设置 Web 应用程序的默认主题和母版页。

  • 对 Web 应用程序启用调试。

  • 指定请求可以运行的最大秒数，超过此时间，ASP.NET 将自动关闭请求。

  • 设置请求、响应和区域性设置的内容编码字符集，这些字符集将确定与区域性相关的函数的结果（如日期、数字和货币格式）。

  • 设置将模拟的 Windows 标识，ASP.NET 页将在该标识下运行。

用户界面元素

“应用程序”选项卡有三种类别，如下所示：

  • 公共编译、页和运行时设置

  • 全球化设置

  • 标识设置

公共编译、页和运行时设置

该类别用于对“页语言默认值”、“页主题默认值”、“页主体默认值”、“启用调试”和“请求执行超时(秒)”进行配置设置。

页语言默认值

用于选择动态编译文件要使用的默认编程语言。可用的语言包括：VB（Microsoft Visual Basic 开发系统）、C#、JS（Microsoft JScript 开发软件）和 VJ#（Microsoft Visual J# 开发工具）。

页主题默认值

用于指定要应用于 Web 应用程序中所有页的默认主题。

页主体默认值

用于指定母版页文件相对于本地配置文件的路径。

启用调试

用于指定是编译发布二进制文件还是调试二进制文件。如果复选框未选中，则该值为 false。

请求执行超时(秒)

用于设置允许执行请求的最大秒数，超过此时间，请求将被 ASP.NET 自动关闭。

全球化设置

用于对“请求编码”、“响应编码”、“区域性”和“UI 区域性”进行配置设置。

请求编码

用于指定每个传入请求的假定编码，包括已发送的数据和查询字符串。默认编码为 UTF-8。

响应编码

用于指定响应的内容编码。默认编码为 UTF-8。

文件编码

用于为 .aspx、.asmx 和 .asax 文件分析指定默认编码。

区域性

用于为处理传入的 Web 请求选择默认的区域性。区域性确定与区域性相关的函数的结果（如日期、数字和货币格式）。

UI 区域性

用于为处理与区域设置相关的资源搜索选择默认区域性。

标识设置

用于对“模拟”、“用户名”和“密码”进行配置设置。

模拟

用于指定是否对每个请求使用客户端模拟。

用户名

用于指定要使用的用户名（在对每个请求都使用客户端模拟的情况下）。

密码

用于指定要使用的密码（在对每个请求都使用客户端模拟的情况下）。

请参见

任务

如何：以编程方式访问 ASP.NET 配置设置
如何：为 ASP.NET 网页全球化设置区域性和 UI 区域性

参考

“ASP.NET 配置设置”对话框 ->“身份验证”选项卡
“ASP.NET 配置设置”对话框 ->“授权”选项卡
“ASP.NET 配置设置”对话框 ->“自定义错误”选项卡
“ASP.NET 配置设置”对话框 ->“常规”选项卡
“ASP.NET 配置设置”对话框的“位置”选项卡

概念

ASP.NET 配置概述
ASP.NET 主题和外观概述
ASP.NET 母版页概述


“ASP.NET 配置设置”对话框 ->“状态管理”选项卡

“ASP.NET 配置设置”对话框 ->“状态管理”选项卡
请参见
DropDown image

使用“ASP.NET 配置设置”对话框的“状态管理”选项卡，可以在对当前网站中的页面进行多次请求时，在多次请求之间管理状态和页信息。当用户在构成 Web 应用程序的不同 ASP.NET 页面之间定位时，ASP.NET 会话状态使您能够为用户帐户存储和检索值。利用“状态管理”选项卡可以配置如何存储值以及在哪里存储值。

您在“状态管理”选项卡上进行的设置应用于打开“属性”对话框之前所选择的网站。

Note 注意

配置设置可以被继承。可在 Machine.config 文件中定义设置，此文件充当服务器上所有网站的基本配置。有关 ASP.NET 配置文件的更多信息，请参见 ASP.NET 配置文件层次结构和继承。

显示“ASP.NET 配置设置”对话框的“状态管理”选项卡

  1. 在 Microsoft Windows 中，单击“开始”，指向“所有程序”，再指向“管理工具”，然后单击“Internet 信息服务 (IIS) 管理器”。

    出现 IIS 管理器。

  2. 在“Internet 信息服务”下，展开 Servername“(本地计算机)”，展开“网站”，右击 Websitename 或“默认网站”，然后单击“属性”。

    出现“网站属性”对话框。

  3. 单击“ASP.NET”选项卡，然后单击“编辑配置”。

    将出现“ASP.NET 配置设置”对话框。

  4. 单击“状态管理”选项卡。

任务

使用“状态管理”选项卡可以执行以下操作：

  • 选择当前 Web 应用程序的会话状态模式。

  • 配置“SQLServer”和“StateServer”会话状态模式。

用户界面元素

会话状态模式

单击会话状态模式。默认会话状态模式是“InProc”，或在 Web 服务器的内存中。有关 ASP.NET 的可用会话状态模式的列表，请参见会话状态模式。

无 Cookie 模式

单击一个 Cookie 模式，定义何时使用用 Cookie 来维护有关用户的信息。有关可用的无 Cookie 模式，请参见 HttpCookieMode。

会话超时

输入在会话终止之前，请求之间所允许间隔的时间量（以分钟为单位）。

连接字符串

输入标识 StateServer 模式下 ASP.NET 状态服务的服务器名称和端口的连接字符串。

网络超时

输入在“StateServer”模式下网络会话终止之前，请求之间所允许间隔的时间量（以秒为单位）。

连接字符串

输入标识“SQLServer”模式下的服务器名称和端口的连接字符串。

请参见

参考

HttpCookieMode

概念

会话状态模式
ASP.NET 配置文件层次结构和继承

其他资源

ASP.NET 的 MMC 管理单元


“ASP.NET 配置设置”对话框的“位置”选项卡

“ASP.NET 配置设置”对话框的“位置”选项卡
请参见
DropDown image

通过将 location 标记与适当的 path 属性组合使用，可以将配置设置应用于特定的 Web 应用程序或目录。path 属性可用于标识特定的文件或子目录，将对其应用唯一的配置设置。使用“ASP.NET 配置设置”对话框的“位置”选项卡可以将配置设置嵌入到配置文件中。

通过“ASP.NET 配置设置”对话框的“位置”选项卡，可以管理下列任务：

  • 位置配置，这些是在配置文件中为节点定义的路径位置配置。

在 Microsoft Internet 信息服务 (IIS) 管理器中显示“ASP.NET 配置设置”对话框

  1. 打开 Web 应用程序的“属性”对话框。

  2. 依次单击“ASP.NET”、“编辑配置”和“应用程序”。

您在“位置”选项卡上进行的设置应用于显示“属性”对话框之前所选择的 Web 应用程序。

注意 配置设置是可继承的。可在 Machine.config 文件中定义设置，此文件充当服务器上所有网站和 Web 应用程序的基本配置。通过在 Web.config 文件中在 Web 应用程序级别上进行配置设置，可以创建新设置或者重写继承的设置。

有关“ASP.NET 配置设置”的信息，请参见 ASP.NET 配置概述。

任务

使用“位置”选项卡可以完成以下任务：

  • 指定路径位置配置，这些配置是在配置文件中为节点定义的。

用户界面元素

位置配置

添加

用于显示“添加位置”对话框，通过该对话框可以指定一个索引和一个位置，以便将新位置添加到“ASP.NET 配置设置”对话框中的“位置配置”对话框。

编辑配置

用于为某个节点显示新的“ASP.NET 配置设置”选项卡，该节点是由包含的配置文件中的路径指定的。

移除

用于将位置项从此节点的配置文件中移除。

请参见

任务

如何：以编程方式访问 ASP.NET 配置设置

参考

“ASP.NET 配置设置”对话框 ->“常规”选项卡
“ASP.NET 配置设置”对话框 ->“身份验证”选项卡
“ASP.NET 配置设置”对话框 ->“授权”选项卡
“ASP.NET 配置设置”对话框 ->“自定义错误”选项卡
“ASP.NET 配置设置”对话框的“应用程序”选项卡

概念

ASP.NET 配置概述
保证 ASP.NET 配置的安全


“编辑/添加连接字符串”对话框

“编辑/添加连接字符串”对话框
请参见
DropDown image

使用“编辑/添加连接字符串”对话框可以创建新的 ConnectionString 属性或者编辑现有的 ConnectionString 属性。在“ASP.NET 配置设置”对话框中的“常规”选项卡上单击“添加”或“编辑”后，将显示“编辑/添加连接字符串对话框。

在 Microsoft Internet 信息服务 (IIS) 管理器中显示“ASP.NET 配置设置”对话框

  1. 打开 Web 应用程序的“属性”对话框。

  2. 依次单击“ASP.NET”、“编辑配置”和“应用程序”。

在“ASP.NET 配置设置”对话框中的“常规”选项卡上单击“添加”，即可显示“编辑/添加连接字符串”对话框。然后，指定 ConnectionString 属性和 Connection 参数的名称或键。

另外，还可以在“ASP.NET 配置设置”对话框中的“常规”选项卡上单击“编辑”来显示“编辑/添加连接字符串”对话框，然后可以通过该对话框编辑现有的 ConnectionString 属性。所选的 ConnectionString 属性将显示在“连接参数”框中。

Note 注意

您可以重写继承的设置；在这种情况下，重写的设置仅应用于所选的 Web 应用程序。不能通过编辑继承的设置来更改其在更高配置层次结构中的值。

有关“ASP.NET 配置设置”的信息，请参见 ASP.NET 配置概述。

任务

使用“编辑/添加连接字符串”对话框可以完成下列任务：

  • 在“常规”选项卡的“连接字符串管理器”对话框中添加新的 ConnectionString 属性。

  • 在“常规”选项卡的“连接字符串管理器”对话框中编辑现有的 ConnectionString 属性。

用户界面元素

编辑/添加连接字符串

名称

用于指定 ConnectionString 属性的名称。

如果通过单击“常规”选项卡上的“编辑”来调用“编辑/添加连接字符串”对话框，则不能为连接字符串指定名称。

连接参数

用于指定 ConnectionString 属性的值。

如果通过单击“常规”选项卡上的“编辑”来调用“编辑/添加连接字符串”对话框，则“连接参数”框包含现有的 ConnectionString 属性的值。

确定

用于应用所创建的新 ConnectionString 属性，或者应用对现有的 ConnectionString 属性所做的更改。

取消

用于关闭“编辑/添加连接字符串”对话框。不会将更改写入连接字符串管理器。

请参见

参考

“ASP.NET 配置设置”对话框 ->“常规”选项卡
connectionStrings 元素（ASP.NET 设置架构）

概念

ASP.NET 配置概述


“编辑/添加应用程序设置”对话框

“编辑/添加应用程序设置”对话框
请参见
DropDown image

应用程序设置是一些简单的键/值对，用于在一个可从 Web 应用程序的任何位置访问的中心位置创建适用于整个应用程序范围的值。通过将应用程序设置作为配置的一部分保存在 Web.config 文件中，这样可以轻松地更改应用程序设置。“常规”选项卡上的“应用程序设置”部分显示应用程序设置键/值对列表。

“编辑/添加应用程序设置”对话框用于创建和编辑 Web 应用程序设置。

在“ASP.NET 配置设置”对话框中“常规”选项卡的“应用程序设置”部分内单击“添加”，即可显示“编辑/添加应用程序设置”对话框。然后，指定 AppSettings 属性的键和值，这些键和值将被添加到“应用程序设置”对话框和 Web 应用程序的 Web.config 文件中。

类似地，可以在“应用程序设置”对话框中选择一个设置，然后单击“编辑”。然后，可以更改所选 AppSettings 属性的值。所做的更改将被添加到“应用程序设置”对话框和 Web 应用程序的 Web.config 文件中。

在 Microsoft Internet 信息服务 (IIS) 管理器中显示“ASP.NET 配置设置”对话框

  1. 打开 Web 应用程序的“属性”对话框。

  2. 依次单击“ASP.NET”、“编辑配置”和“应用程序”。

有关“ASP.NET 配置设置”的信息，请参见 ASP.NET 配置概述。

任务

使用“编辑/添加应用程序设置”对话框可以完成下列任务：

  • 创建新的键/值对，用于在一个中心位置创建适用于整个应用程序范围的值。

  • 编辑 Web 应用程序中当前的键/值对。

用户界面元素

键

用于为键/值对添加新键。如果单击了“编辑”，则不能在文本框中指定新键。

值

用于为键/值对添加新值。如果单击了“编辑”，则可以更改所选键/值对的值。

确定

用于应用所创建的新 AppSettings 属性，或者对现有的应用程序设置应用更改。

取消

用于关闭“编辑/添加应用程序设置”对话框，而不对应用程序设置或 Web 应用程序的 Web.config 文件进行任何更改。

请参见

参考

“ASP.NET 配置设置”对话框 ->“常规”选项卡
appSettings 元素（常规设置架构）

概念

ASP.NET 配置概述


“编辑/添加自定义错误处理程序”对话框

“编辑/添加自定义错误处理程序”对话框
请参见
DropDown image

使用“编辑/添加自定义错误处理程序”对话框可以将错误代码映射到特定错误页。ASP.NET 生成错误代码时，将显示指定的页面。

您在“编辑/添加自定义错误处理程序”对话框中所做的设置应用于打开“属性”对话框之前所选的 Web 应用程序。

Note 注意

配置设置是可继承的。可在 Machine.config 文件中定义设置，此文件充当服务器上所有网站和应用程序的基本配置。通过在 Web 应用程序级别上进行配置设置，可以创建新设置或者重写继承的设置。

注意 ASP.NET 不接收某些错误代码，例如 404。只能映射在 ASP.NET 中内部生成的错误。

打开“编辑/添加自定义错误处理程序”对话框

  1. 在 Microsoft Windows 中，打开“管理工具”，然后单击“Internet 信息服务 (IIS) 管理器”。

    出现 IIS 管理器。

  2. 在“Internet 信息服务”下，展开 Servername“(本地计算机)”，展开 Websitename 或“默认网站”，然后单击“属性”。

    出现“网站属性”对话框。

  3. 单击“ASP.NET”选项卡，然后单击“编辑配置”。

    将出现“ASP.NET 配置设置”对话框。

  4. 单击“自定义错误”。

    • 若要添加自定义错误处理程序，请单击“添加”。

    • 若要编辑自定义错误处理程序，请单击“编辑”。

    出现“编辑/添加自定义错误处理程序”对话框。

用户界面元素

状态代码

键入要映射到错误页的 HTTP 错误代码。

重定向 URL

键入 ASP.NET 为响应错误代码而要显示的页面的 URL。所引用的页不必在当前网站中。

Note 注意

ASP.NET 不验证所输入的 URL。

确定

单击可保存自定义错误处理程序。

取消

单击可取消更改。

请参见

参考

“ASP.NET 配置设置”对话框 ->“自定义错误”选项卡
“ASP.NET 配置设置”对话框 ->“自定义错误”选项卡


“编辑规则”对话框

“编辑规则”对话框
请参见
DropDown image

使用“编辑规则”对话框可以创建新的授权规则或编辑现有的授权规则。可以通过使用 Microsoft Windows 身份验证或 ASP.NET Forms 身份验证（ASP.NET 成员资格）来创建用户帐户和角色。

打开“编辑规则”对话框

  1. 在 Windows 中，打开“管理工具”，然后单击“Internet 信息服务 (IIS) 管理器”。

    出现 IIS 管理器。

  2. 在“Internet 信息服务”下，展开 Servername“(本地计算机)”，展开“网站”，右击 Websitename 或“默认网站”，然后单击“属性”。

    出现“网站属性”对话框。

  3. 单击“ASP.NET”选项卡，然后单击“编辑配置”。

    将出现“ASP.NET 配置设置”对话框。

  4. 单击“授权”选项卡。

    • 若要添加规则，请单击“添加”。

    • 若要编辑规则，请单击一个规则，然后单击“编辑”。

    便会出现“编辑规则”对话框。

任务

使用“编辑规则”对话框，可以执行以下操作：

  • 创建新的授权规则或编辑现有的授权规则。

用户界面元素

规则类型

单击“允许”可以允许所有用户访问。

- 或 -

单击“拒绝”可以拒绝所有用户访问。

有关规则的详细信息，请参见 AuthorizationRuleCollection。

谓词

单击“所有谓词”可以指定允许访问所有 ASP.NET HTTP 传输方法。“所有谓词”是默认值。

单击“特定谓词”，然后键入一个逗号分隔的、被授予访问权限的 HTTP 传输方法的列表。

注册到 ASP.NET 的谓词为 GET、HEAD、POST 和 DEBUG。

用户和角色

必选。

完成下列操作中的一个或多个以应用规则：

  • 单击“所有用户”对所有用户应用规则。

  • 单击“匿名用户”仅对匿名用户帐户应用规则。

  • 单击“用户”，然后键入一个逗号分隔的用户帐户名称列表，对一组特定用户帐户应用规则。

  • 选择“角色”复选框，然后键入一个逗号分隔的角色名称列表，对一组特定角色应用规则。

如果同时指定了“用户”和“角色”，则仅对指定角色的用户帐户应用规则。

使用 Windows 身份验证或 ASP.NET Forms 身份验证（ASP.NET 成员资格）来定义用户帐户和角色。

确定

单击可应用规则。

取消

单击可取消更改。

请参见

任务

如何：实现简单的 Forms 身份验证

参考

“ASP.NET 配置设置”对话框 ->“授权”选项卡
“ASP.NET 配置设置”对话框 ->“授权”选项卡

概念

跨应用程序进行 Forms 身份验证

其他资源

使用 ASP.NET 角色管理授权 (Visual Studio)


“添加位置”对话框

“添加位置”对话框
请参见
DropDown image

使用“添加位置”对话框可以将新的位置配置设置添加到您的网站。通过使用具有适当的 path 属性的 <location> 标记，可以将配置设置应用于特定的资源。path 属性可用于标识特定的文件或子目录，将对其应用唯一的配置设置。

在“ASP.NET 配置设置”对话框中的“位置”选项卡下单击“添加”按钮后，将显示“添加位置”对话框。

在 Microsoft Internet 信息服务 (IIS) 管理器中显示“ASP.NET 配置设置”对话框

  1. 打开 Web 应用程序的“属性”对话框。

  2. 依次单击“ASP.NET”、“编辑配置”和“应用程序”。

使用“添加位置”对话框可以完成以下任务：

  • 指定位置项的索引（键）。

  • 指定要添加到“位置”配置列表中的位置的值。

用户界面元素

索引

指定位置项的索引（键）。

位置

指定要添加到列表中的项的值。（例如，指向特定文件或目录的路径）。

确定

应用在“ASP.NET 配置设置”对话框中的“位置配置”框内输入的新位置值。关闭“添加位置”对话框。

取消

关闭“添加位置”对话框。不会将更改写入“位置配置”框。

请参见

参考

“ASP.NET 配置设置”对话框的“位置”选项卡
“选择位置/打开网站”对话框 ->“本地 IIS”选项卡

概念

ASP.NET 配置概述


dv_aspnetmmchxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

dv_aspnetmmchxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}
DropDown image

dv_aspnetmmchxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

要提出有关“帮助”或本产品其他功能的建议或错误报告，请转到反馈站点。