WinRAR 是什么

WinRAR 是 Windows 版本的 RAR 压缩文件管理器 - 一个允许您创建、管理和控制压缩文件的强大工具。我们提供一系列的 RAR 版本，可用于不同的操作系统：Windows、Linux、FreeBSD 、macOS。

运行于 Windows 下的 RAR 有两个版本:

  • 图形用户界面 版本- WinRAR.exe;

  • 命令行 控制台 (文本模式) 版本 - Rar.exe。

WinRAR 和 WinRAR 自解压模块需要 Windows XP SP3 以上版本。

WinRAR 特性

  • 完全支持 RAR 和 ZIP 2.0 压缩文件;

  • 高度成熟的原创压缩算法;

  • 对于文本、声音、图像和 32-位和 64-位 Intel 可执行程序压缩的特殊优化算法;

  • 外壳界面 包括 拖放 和 向导;

  • 命令行界面;

  • 非 RAR 压缩文件 (7Z、ARJ、BZ2、CAB、GZ、ISO、JAR、LZ、LZH、TAR、UUE、XZ、Z、001 和几种 ZIPX 类型) 管理;

  • 固实 压缩，比常规方法更能够提升压缩率 10% - 50%，尤其是在压缩大量的小文件，类似的文件时;

  • 多卷压缩文件;

  • 使用默认的或是选择的自解压模块创建 自解压 文件 (也可用于分卷);

  • 恢复 物理受损的压缩文件;

  • 恢复卷 允许重建多卷压缩丢失的卷。

  • 支持 Unicode 文件名;

  • 其它服务功能，例如 文件加密、 压缩文件注释、错误日志 等。


WinRAR 的限制

WinRAR 创建的内置的 RAR 格式和 ZIP 压缩文件允许存储任意数量的文件和任意大小的文件。实际可能受文件系统、操作系统、可用内存的限制。某些比较老的文件系统不支持超过 4GB 的文件。

WinRAR 分配内存，以存储每个压缩文件的名称和属性。如果添加了快速打开信息，存储文件名和属性所需的内存会翻倍。 具体数量取决于 UTF-8 编码的文件名的长度，通常我们可以每个文件添加几百字节到压缩字典的内存请求上，来估计压缩时使用的内存。同时也请考虑 32 位 WinRAR 不能使用超过 2GB的内存。如果您需要使用大字典处理大量的文件，最好使用 64 位的 WinRAR。

文件加密的最大密码长度是 127 字符。更长的密码会被截短到此长度。


控制台 RAR 版本

在安装 WinRAR 后您会发现，在相同目录中有个文件 rar.exe 。它也是 RAR 的 Windows 版本，但它只支持命令行，纯文本模式的界面。当从 命令行提示符模式下的 BAT 和 CMD 文件来调用控制 RAR 等时，它特别有用。它支持了比 WinRAR 多得多的命令行参数参数和命令，虽然它有着常规命令行 WinRAR 命令行界面 相似的语法，但却是个真正的 RAR 控制台程序。此帮助文件不包含那一些仅在控制台版本中所支持的参数参数和命令的描述。您可以读取 rar.txt 文件来获取所有控制台 RAR 功能的详细帮助。


致谢

我要感谢 Ron Dwight，他为 RAR 产品和 RAR 的用户做了那么多。很遗憾，Ron 将永远不能看见 WinRAR 的下一个版本了。

WinRAR 包含了 Info-Zip 集团 的代码，用于管理 ZIP 压缩文件。

文本压缩算法基于 Dmitry Shkarin 的 PPMII 和 Dmitry Subbotin carryless rangecoder，您可以在 ftp://ftp.elf.stuba.sk/pub/pc/pack/ 找到它。

WinRAR 加密包含 Szymon Stefanek 和 Brian Gladman 的 AES 实现和 Steve Reid SHA-1 的部分代码。

WinRAR 使用的 CRC32 函数基于 Intel Slicing-by-8 算法。

RAR 压缩文件可以选择包含 BLAKE2sp 哈希, Jean-Philippe Aumasson, Samuel Neves, Zooko Wilcox-O'Hearn 和 Christian Winnerlein 设计。

Alexander Khoroshev 与 Bulat Ziganshin 提供了非常有用的改善 RAR 压缩效率以及压缩速度方面的诀窍。

7z 压缩文件的解压使用了 Igor Pavlov，7-Zip 压缩软件的开发者，版权所有的 7zxa.dll 库。7zxa.dll 在 GNU Lesser General Public License (LGPL) 许可下发布，版本 2.1 或 以后。您可以在 LGPL 协议的许可下修改 7zxa.dll 的部分和为了调试目的执行逆向工程。XZ 压缩文件使用公开的 LZMA SDK 解压。7zxa.dll 库的源代码在 www.7-zip.org 下载。

我们使用 James S. Plank、Kevin M. Greenan 和 Ethan L. Miller 的 “Screaming Fast Galois Field Arithmetic Using Intel SIMD Instructions”论文来改进 Reed-Solomon码性能。也感谢 Artem Drobanov 和 Bulat Ziganshin 提供例子和想法使Reed-Solomon码更有效率。

WinRAR 图像设计由 Aditya Nugraha Putra 提供，来自于 weirdsgn.com。

而 WinRAR 界面集成的主意来自 Ylian Saint-Hilaire 和他的相当优异的“RAR 外壳扩展”程序。

并且特别感谢 Andrey Spasibozhko 在发展 RAR 早期版本时的帮忙。

感谢周明波制作早期的 WinRAR 简体中文版。

关于中文版：

此 WinRAR 简体中文版由 www.winrar.com.cn 制作。


快速开始

图形界面和命令行模式

WinRAR 可以使用下列两种方式中的一种: 标准 Windows 界面的图形界面，或是命令行方式。要开始启用 WinRAR 图形界面只需要简单地在 WinRAR 图标上双击即可，然后您可以使用按钮和菜单来压缩和解压文件。请读取下面的步骤介绍主题

如何使用 WinRAR 的图形模式解压文件

如何使用 WinRAR 的图形模式压缩文件

要在命令行模式使用 WinRAR ，您必须打开“开始”菜单，然后启动“程序/附件/命令提示符”或“运行”对话框的其中一种，然后输入命令文本。您可以在下面的主题中找到压缩和解压的简易示例，但是详尽的命令行模式帮助的获得则位于 命令行模式 帮助主题中。要注意的是如果您是从命令行运行 WinRAR 且没有参数时，界面模式将会启动。

如何使用命令行解压文件

如何使用命令行压缩文件

如果您在安装 WinRAR 时选择了“把 WinRAR 集成到资源管理器中”的选项，它也可以直接从 Windows 界面(资源管理器或是桌面 ) 解压和压缩文件，详细内容在下面可以找到。

如何在资源管理器或桌面解压文件

如何在资源管理器或桌面压缩文件


快速起步: 使用 WinRAR 图形界面模式解压文件

为了使用 WinRAR 图形界面模式解压文件，首先您必须 在 WinRAR 中打开压缩文件。有数种方式可以打开压缩文件:

在 Windows 界面 (资源管理器或是桌面) 的压缩文件名上双击鼠标左键或是按下“Enter”。如果在安装时已经将压缩文件关联到 WinRAR (默认的安装选项)，压缩文件将会在 WinRAR 程序中打开。在安装之后，您也可以使用 综合设置对话框 将压缩文件关联到 WinRAR ;

在 WinRAR 窗口中的压缩文件名上双击鼠标左键或是按下“Enter”

拖动 压缩文件到 WinRAR 图标或窗口。在此之前请先确定在 WinRAR 窗口中没有打开其它的压缩文件。不然的话，拖入的压缩文件将会添加到当前显示的压缩文件之中 ;

从命令行以单个参数 - 压缩文件名，来运行 WinRAR。

当压缩文件在 WinRAR 中打开时，它的内容会显示出来。然后 选择要解压的文件和文件夹 。您也可以使用 Shift + 方向键或 Shift + 鼠标左键多选，就如同 Windows 资源管理器或是其它 Windows 程序一样。也可在 WinRAR 中使用空格键或 Ins 键 选择文件 。在键盘的数字盘部分的“NUM +”和“NUM -”则允许组选择文件时的文件过滤掩码。

当选择了一个或是数个文件后，在 WinRAR 窗口顶端 单击“解压到”按钮，或是按下 Alt+E，在对话框输入目标文件夹并单击“确定”。此对话框也提供一些高级的选项 ( 参阅 解压路径和选项对话框 获得更多信息) 。

解压期间，有个窗口将会出现显示操作的状况。如果您希望中断解压的进行，在命令窗口单击“取消”按钮。您也可以单击“后台”按钮将 WinRAR 最小化放到任务栏区。如果解压完成了，而且没有错误， WinRAR 将会返回到界面模式。在有错误的状况时，则会出现 错误信息诊断窗口。


快速起步: 从命令行解压文件

解压文件并包含完整路径的命令行语法是:

WinRAR X [-参数] <压缩文件> [文件] [@文件列表] [目标文件夹\]

解压文件并忽略路径是:

WinRAR E [-参数] <压缩文件> [文件] [@文件列表] [目标文件夹\]

例如说，您要从压缩文件 LETTERS.RAR 中解压文件 LETTER.TXT 到当前文件夹时，请使用下列命令:

WinRAR X LETTERS.RAR LETTER.TXT

压缩文件扩展名是可选的，并且可以忽略。

下一个命令是从压缩文件 Songs 解压全部的 *.WAV 文件到 Audio 文件夹:

WinRAR X Songs *.WAV Audio\

在文件中列出要解压的文件，然后在命令行逐一列出也是可以的。这种例子下，在命令行必须指定被压缩文件列表文件的文件名。在文件名添加符号 @ 前缀。例如，如果您创建一个文件 Binaries，里面含有字符串 *.exe 和 *.com，然后运行命令 :

WinRAR X TOOLS @Binaries

TOOLS 压缩文件中所有 EXE 和 COM 扩展名的文件，都会被解压到当前文件夹。

解压期间，有个窗口将会出现显示操作的状况。如果您希望中断解压的进行，在命令窗口单击“取消”按钮。您也可以单击“后台”按钮将 WinRAR 最小化放到任务栏。如果解压完成，而且没有错误，WinRAR 将会返回到界面模式。在有错误的状况时，则会出现 错误诊断信息窗口。

参阅 命令行界面 可以获得命令和参数的详细帮助。


快速起步: 在资源管理器或桌面解压文件

如果您在安装 WinRAR 时，没有关闭“把 WinRAR 集成到资源管理器中”选项，您便可以使用 Windows 界面直接解压文件。在压缩文件图标上单击鼠标右键，选择“解压文件”命令，在对话框输入目标文件夹并单击“确定”按钮。此对话框提供了一些高级选项 (请参阅 解压路径和选项对话框 以获得更多信息)。

您也可以选择“解压到 < 文件夹名>”命令来解压文件到指定的文件夹，而不需要其它的附加选项。

注意，如果在 综合设置对话框 选项“层叠关联菜单”是打开的话，您必须打开“ WinRAR”子菜单才能使用上述命令，不然的话，它们是属于上一级菜单的。

另外的方法是，使用鼠标右键拖着一个或是数个压缩文件，并将它们放到目标文件夹，然后在出现的菜单选择“解压到 <文件夹名>”。


快速起步: 从 WinRAR 图形界面压缩文件

首先，您必须运行 WinRAR。在 WinRAR 图标双击或是按下“Enter”。您也可以从 Windows “开始” 菜单启动: 单击“程序”然后“WinRAR”，然后运行“WinRAR”项目。

当 WinRAR 运行时，会显示当前文件夹的文件和文件夹列表。您必须 转到含有要压缩的文件的文件夹。您可以使用 Ctrl+D，在工具栏的驱动器列表或单击位于左下角的驱动器小图标，来更改当前的驱动器。按下退后键 Backspace,Ctrl+PgUp，工具栏下面的小型“向上”按钮或者在文件夹名“...”上面双击都可以转到上级目录。按下 Enter,Ctrl+PgDn 或在任何其它的文件夹上双击都可进入该文件夹。 Ctrl+\ 则将磁盘的根目录文件夹或含有压缩文件的文件夹设置为当前文件夹。

当进入了您需要的文件的文件夹时，选择您要压缩的 文件和文件夹。也可以像 Windows 资源管理器或其它的 Windows 程序一样，使用 + 方向键或是用鼠标来做压缩工作。另外在 WinRAR 中也能使用空格键或 Ins 键来选择文件。在键盘数字盘区的“NUM +”和“NUM -”用来选择组文件时的过滤掩码。

当完成选择了一个或是多个的文件之后，在 WinRAR 窗口顶端 单击“添加”按钮 ，或是按下 Alt+A 或在 命令菜单 选择“添加文件到压缩文件”命令，在出现的对话框输入目标压缩文件名或是直接接受默认名。在对话框您可以选择新建压缩文件的格式 (RAR 或 ZIP)，压缩级别，分卷大小和其它压缩参数。此对话框的详细帮助在 压缩文件名和参数对话框 主题中。当准备好创建压缩文件时，单击“确定”按钮 。

压缩期间，有个窗口将会出现显示操作的状况。如果您希望中断解压的进行，在命令窗口单击“取消”按钮。您也可以单击“后台运行”按钮将 WinRAR 最小化放到任务区。当压缩完成了，命令行窗口将会出现并且以新创建的压缩文件作为当前选定的文件。

使用 拖动 方式，在已存在的 RAR 压缩文件中添加文件也是可以的。在 WinRAR 窗口选择想要的文件并在名称上面按下 Enter (或以鼠标双击)。RAR 将会读取压缩文件并显示它的内容。现在您可以很轻松的从其它程序将要添加的文件拖动到 WinRAR，就可以把文件添加到压缩文件中。


快速起步: 从命令行压缩文件

压缩文件的一般命令行命令语法为:

WinRAR A [-参数] <压缩文件> [文件] [@文件列表]

例如说，您希望添加文件 LETTER.TXT 到压缩文件 LETTERS.RAR ，请输入:

WinRAR A LETTERS.RAR LETTER.TXT

如果未指定压缩文件扩展名，WinRAR 会使用在 压缩配置 选定的默认压缩文件格式。但是您仍可以指定 .RAR 或 .ZIP 扩展名的其中一种来替换上面的默认值。

下一个例子: 添加全部 *.WAV 文件到固实 RAR 压缩文件 Songs:

WinRAR A -S Songs.RAR *.WAV

在文件中列出要压缩的文件，然后在命令行逐一列出也是可以的。这种例子下，在命令行必须指定被压缩文件列表文件的文件名。在文件名前面添加符号 @ 前缀。这样，如果您创建一个文件 Binaries，里面含有字符串 *.exe 和 *.com，并运行命令:

WinRAR A TOOLS.ZIP @Binaries

全部在当前文件夹中有 EXE 和 COM 扩展名的文件，将会被添加到 ZIP 压缩文件 TOOLS 中。

压缩期间，有个窗口将会出现显示操作的状况。如果您希望中断压缩的进行，在命令窗口单击 “取消” 按钮。您也可以单击“后台”按钮将 WinRAR 最小化放到任务栏。如果压缩完成，而且没有错误， WinRAR 将会返回到界面模式。在有错误的状况时，则会出现 错误诊断信息窗口。

参阅 命令行界面 可以获得命令和参数的详细帮助。


快速起步: 在资源管理器或桌面压缩文件

如果您在安装 WinRAR 时，没有关闭“把 WinRAR 集成到资源管理器中”选项，您便可以使用 Windows 界面直接压缩文件。在资源管理器或桌面选择您要压缩的文件，以鼠标右键在选定的文件上单击并选择“添加到压缩文件”。在出现的对话框输入目标压缩文件名或直接接受默认的名称。在对话框您可以选择新建压缩文件的格式 (RAR 或 ZIP )，压缩级别，分卷大小和其它压缩参数。此对话框的详细帮助在 压缩文件名和参数对话框 主题中。当准备好创建压缩文件时，单击“确定”按钮。压缩文件将会在同一个文件夹创建并当成选定的文件。

您也可以选择“添加到 < 压缩文件名>”命令来添加到指定的压缩文件，而没有其它的附加选项，将会引用在 压缩配置 对话框选定的默认压缩设置。

注意，如果在 综合设置对话框 选项“层叠关联菜单”是打开的话，您必须打开“ WinRAR”子菜单才能使用上述的命令，不然的话，它们是属于上一级菜单的。

另一个方法是，使用鼠标左键拖着文件图标并放到已存在的压缩文件图标上，这时文件将会添加到此压缩文件中。


AR 与 ZIP 对比

RAR 与 ZIP 对比

WinRAR 可以创建两种不同的压缩文件格式: RAR 和 ZIP。下面是每一种格式的优点叙述 :

ZIP 压缩文件

在 ZIP 文件的最大优点就是普及率。比如说，大部分在 Internet 的压缩文件都是 ZIP 压缩文件，所以如果您要传送压缩文件给某一个人，但您无法确定您的收件人是否有 WinRAR 来解压压缩文件的内容时，使用 ZIP 格式是个好推荐。要不然您也可以发送 自解压文件。此类的压缩文件稍微大了一点点，但不需要任何的外部程序便可以解压。

另一个 ZIP 的优点便是速度。 ZIP 压缩文件通常在创建时会比 RAR 快一些。

RAR 压缩文件

RAR 格式通常能比 ZIP 提供较好的压缩率，特别是在 固实模式 时。WinRAR 的 RAR 格式分卷 压缩文件提供更多的功能，如自解压分卷。

RAR 格式也有一些在 ZIP 中所缺乏的重要功能，例如 恢复记录，它允许物理受损数据的恢复，还能 锁定 重要的压缩文件，以防止它们被别人意外地更改。

RAR 和 ZIP 格式可以处理几乎无限制的大小(可达 8,589,934,591 GB)。


RAR 5.0 压缩文件格式

WinRAR 5.0 引入了新版本的 RAR 压缩文件格式。

RAR 5.0 格式的新特性包括:

  • 压缩 字典大小 最大可达到 1GB。压缩大文件时，尤其是在 固实 模式中，较大的字典让压缩文件有更高的压缩率。
  • 加密基于 AES-256 算法，理论上比 RAR 4.x 的 AES-128 更强。
  • 恢复记录 使用 Reed-Solomon 纠错码，具有比 RAR 4.x 恢复记录更高的抗多重损害的能力。
  • 更快的 恢复卷 操作。RAR 5.0 中最大的 RAR+REV 卷的数量是 65535，取代 255。
  • 文件时间存储为协调世界时(UTC)，替代 RAR 4.x 的本地时间，这让文件在不同的时区内的交流更直观。
  • 可选的文件数据 BLAKE2sp 校验和。不像 CRC32 校验和，两个不同的文件有相同的 BLAKE2 校验和值几乎是不可能的。所以 BLAKE2 可以被用于文件内容识别。
  • 可以添加可选的 快速打开信息 到压缩文件中，使访问压缩文件的内容更快。
  • 解压缩算法支持多线程。它提升了可压缩效果差数据的大文件和使用BLAKE2校验和时的解压速度。
  • 支持 NTFS 分析点， 符号链接， 硬链接。
  • 可能把 完全相同的文件 的第二份和其他副本存储为第一个文件的引用。
  • 完整的 Unicode 支持。文件名和注释都以 utf-8 格式存储。

某些过时或低效的 RAR 4.x 特性没有包含在 RAR 5.0 格式中:

  • 特殊的算法，包括文本压缩、未处理音频和真彩压缩，不能在 RAR 5.0 中使用。这些被旧 RAR 版本识别的未处理音频和真彩颜色数据格式，变得很少见了。文本压缩的性能在现代多核心 CPU 上比常规压缩要低很多。及时这些算法在 RAR 5.0 中不被支持，最新的 WinRAR 也可以解压任何 4.x RAR 压缩文件，包括那些使用上面提到的算法。RAR 5.0 仍然包括 IA-32 可执行和 delta 压缩算法，这些可有效利用现代数据和硬件。
  • 不再支持创建旧风格 archive.r00, archive.r01 格式的卷名。这些名称的主要目的是为了兼容 MS DOS 文件系统。 但这种命名约定在类似 Windows 文件扩展名是用来定义文件类型和关联的平台上不能很好的工作。

较老的软件，包括 5.0 之前版本的 WinRAR，不能识别 RAR 5.0 压缩文件。所以如果您希望压缩文件能被较老的软件解压缩，最好选择 RAR 4.x 压缩文件格式。可以使用 压缩文件名和参数 对话框或 -ma 命令行参数 设置。如果您需要特殊的文本或多媒体压缩算法或旧风格卷命名方案时 RAR 4.x 可能会更好。


其它支持的压缩文件格式

除了完整的支持 RAR 和 ZIP 之外，WinRAR 提供了一些其它压缩工具所创建的 7Z、ARJ、BZ2、CAB、GZ、ISO、JAR、LZ、LZH、TAR、UUE、XZ、Z 文件的基本功能 : 查看内容、解压文件、显示注释和压缩文件信息，您不需要有任何的外部程序来管理这些格式。支持几种类型的 ZIPX 压缩文件。

而且 WinRAR 还可以将分割成多个部分并以 .001, .002, ...作为扩展名的若干文件合并起来。您可以像常规压缩文件一样打开 .001 文件，然后解压其内容。在开始解压之前，这些文件的所有部分都必须存储于相同的文件夹里。


固实压缩文件

固实压缩文件是一种特殊压缩方式存储的压缩文件，它把压缩文件中的多个或全部文件都当成一个连续数据流来看待。WinRAR 只支持 RAR 格式的压缩文件使用固实模式，ZIP 压缩文件永远是非固实的。使用压缩对话框中的 创建固实压缩文件 选项或命令行的 -s 参数启用固实压缩。

固实压缩可增加压缩性能，特别是在添加大量的小文件的时候，但它也有一些重要的不利因素:

  • 对已存在的固实压缩文件更新时较慢;
  • 要从固实的压缩文件解压单个文件时，它之前的文件都需先经过分析。这造成当从固实的压缩文件内取出文件时会比一般压缩文件取出文件慢一些。但是，当从固实的压缩文件解压全部的文件时，解压速度并没有影响。
  • 如果在固实压缩文件中的任何文件损坏了，要从损坏的范围中解压全部的文件是不可能的。因此，如果固实压缩文件是保存一个潜在的不可靠的媒体时，推荐您在制作时使用 恢复记录。

固实压缩方式适用场合为:

  • 压缩文件很少更新的时候;
  • 不需要经常从压缩文件中解压一个文件或是部分文件的时候;
  • 压缩效率比压缩速度更为重要的时候。

通常文件在固实压缩时是以扩展名做排序的，但也可以使用 -ds 参数禁用排序或使用特殊文件来设置替代的文件顺序。文件名是 rarfiles.lst。

分卷 和 自解压文件 (SFX) 也可以被做成固实格式。

另请参阅: 参数 -s , 参数 -ds, rarfiles.lst


分卷压缩文件(拆分压缩文件)

WinRAR 可以创建包含数个文件的压缩文件。这样的压缩文件被称为 多卷，组成此压缩文件的单个文件被称为 卷。通常分卷压缩是在将大型的压缩文件保存到数个可移动磁盘或通过 Email 传输的好办法。

WinRAR 能够创建 RAR 和 ZIP 多卷。广泛用于 ZIP 多卷的另一个名字是 ZIP 分割文件。

默认 RAR 卷以‘volname.partNNN.rar’格式命名，NNN的位置是卷号。RAR 4.x 压缩格式使用 -vn 参数 可以选择其它的扩展基本命名规则，卷组中第一分卷文件的扩展名是 .rar，以后卷从 .r00 到 .r99 命名。RAR 5.0 压缩文件不支持 -vn 和扩展基本名称。

RAR 卷也可以是 固实 和 自解压格式。第一个自解压卷有不同的(也就是不是 .rar) 文件扩展名，例如对于 Windows 自解压卷是 .exe。

要解压分卷时，您必须从第一个分卷开始解压(有 .rar 扩展名)。如果分卷存在例如硬盘等的非可移动磁盘时，在解压之前，您必须将全部的分卷放在同一个文件夹内。

ZIP 卷有类似于"volname.zip"，"volname.z01"，"volname.z02"的名字。在所有压缩文件中，使用有".ZIP"文件扩展名的卷来处理开始解压或打开一个压缩文件等操作。

和 RAR 卷不一样，ZIP 卷不能自解压。WinRAR 在创建或解压 ZIP 分卷时需要同时访问多卷 ZIP 文件的所有卷，所以不可能在多个移动磁盘上创建或解压 ZIP 卷。您需要在同一文件夹内创建它们然后把它们手动复制的到您的移动磁盘上。类似，在解压前，您需要把所有的 ZIP 卷放到同一个文件夹中。

对已存在的分卷是不可能添加、更新或删除文件的。您可以创新一个新的卷集。

从版本 3.40 开始, WinRAR 在 RAR 卷内存储卷号。如果您对卷应用 显示信息 命令，您可以在“显示信息”对话框的顶端看到此数字。 此数字在原始卷丢失并且您需要手动恢复纠正名称时有用。


恢复卷

恢复卷或 .rev 文件是由 WinRAR 创建的允许重建卷组中丢失的和损坏的文件的特殊文件。它们只能和 多卷压缩文件 一起使用。

这个功能可以用来备份，例如，当您传递一个多卷压缩文件到一个新组，并且部分接收者没有收到一些文件。重新发送恢复卷代替普通卷，可以减少传送文件的数目。

每个恢复卷可以重建一个丢失的 RAR 卷。例如，如果您有30个卷，3个恢复卷，您可以创建任何3个丢失的卷。如果 .rev 文件的数目少于丢失卷的数目，将不可能重建。对于普通和恢复卷的总数，RAR 4.x 不能超过255，RAR 5.0 压缩文件格式不能超过 65535。恢复卷的数目必须少于 RAR 卷的数目。

原来的 RAR 卷在卷被创建后不能被修改。修复算法使用存储在 REV 文件和 RAR 卷中的数据来重建丢失的 RAR 卷。所有如果您修改了 RAR 卷，例如，在创建 REV 文件后锁定它们，修复操作将失败。

除了恢复数据，RAR 5.0 恢复卷文件也存储了类似于文件校验和的服务信息来保护 RAR 文件。所以它们比它们要保护的 RAR 卷要稍大。所以如果您要把 RAR 和 REV 文件单独复制的移动媒介中，您需要把它考虑在内并指定 RAR 卷的大小比媒介的大小少几 K 字节。

当点击 .rev 文件或使用 rc 命令时，或解压时如果不能定位下一卷的位置并且发现可用数量的.rev 文件时，WinRAR 会重建丢失的和损坏的卷。

您可以在 压缩文件名和参数 对话框的选项中使用“恢复卷” 或在 保护压缩文件 命令中类似的选项创建恢复卷。在 命令行模式 中，您可以使用 -rv 参数或 rv 命令。

原来的损坏的分卷的副本在被重建前被重命名为 *.bad。例如，volname.part03.rar 将被重命名为volname.part03.rar.bad。


自解压文件(SFX)

一个 SFX (SelF-eXtracting)自解压文件是压缩文件的一种，它结合了可执行文件模块，一种用以运行从压缩文件解压文件的模块。这样的压缩文件不需要外部程序来解压自解压文件的内容，它自己便可以运行该项操作。然而 WinRAR 仍然可将自解压文件当成是任何其它的压缩文件处理。所以如果您不愿意运行所收到的自解压文件 (比如说，它可能含有病毒时)，您可以使用 WinRAR 来查看或是解压它的内容。

自解压文件通常与其它的可执行文件一样都有 .exe 的扩展名。

自解压文件是很方便的，如果您想要将压缩文件给某一个人时，但却不知道他们是否有该压缩程序可以解压文件的时候。您也可以使用自解压来发布您自己的软件，例如 WinRAR 的安装程序便是使用图形 GUI RAR 自解压模块 Default.sfx 所制作的。

要从命令行创建自解压文件，您可以使用 -sfx 参数来制作新的压缩文件，或是 S 来将已存在的压缩文件转换成自解压文件。 在 WinRAR 图形界面则有两种方式，一个是当要创建新的压缩文件时，从 压缩文件名和参数对话框 选择“创建自解压文件”选项，另一个是输入已存在的压缩文件并单击 “自解压”按钮。

WinRAR 中包含了数个自解压模块，全部的自解压模块都有 .sfx 扩展名并且必须放在 WinRAR 所在的文件夹中。默认的 WinRAR 始终使用 Default.sfx 模块，但是您也可以直接以“-sfx”参数或是“S”命令来直接指定其它的模块名。例如，转换 myarchive.rar 成为自解压格式，使用 WinCon.SFX 模块运行:

WinRAR SWinCon.SFX myarchive.rar

在 WinRAR 图形界面下，您可在菜单中选择您想要用的自解压模块，在当您运行“转换到自解压文件”命令时，它就会出现让您选择。

在这里您可以读取关于自解压模块信息:

  • 图形界面 RAR 和 ZIP 自解压模块 (Default.SFX 和 Zip.SFX)
  • 控制台 RAR 自解压模块 (WinCon.SFX)


加密

在 RAR 和 ZIP 两种格式均支持加密功能。若要加密文件，在压缩之前您必须先指定密码，或直接在 压缩文件名和参数 对话框中指定，在 命令行 模式时使用参数 -p[密码] 。而在 WinRAR 图形界面时，要输入密码您可以按下 Ctrl+P 或者是在 文件菜单 选择“设置默认密码”命令，另一种方式是单击 WinRAR 窗口底部左下角的钥匙图标。在 压缩文件名和参数对话框 里的“高级选项”组中按下“设置密码”按钮输入密码。

和 ZIP 不同，RAR 格式不只允许数据，而且其它的可感知的压缩文件区域：文件名、大小、属性、注释和其它块都可加密。如果您希望这样做，您需要在密码对话框中设置“加密文件名” 选项，或在命令行模式使用 -p[密码] 的参数 -hp[密码]。以这种方式加密的文件，如果没有密码甚至不可能查看文件列表。

固实 RAR 压缩文件和加密文件名的压缩文件对所有压缩包中的文件仅能有一个相同的密码。没有加密文件名的非固实的 RAR 压缩文件和 ZIP 压缩文件可以使用不同的密码。

当不再需要的时候，别忘了将输入的密码删除。不然您或许又加密了别的压缩文件，但却不希望使用同一组密码。要删除密码时，只需要输入空字符串来替换原先的密码，或者先关闭 WinRAR 并重新启动一次。当有密码存在时，钥匙的图标是红色的，否则它是黄色的。而且，当您使用密码开始压缩操作时，标题栏 压缩文件名和参数对话框 也会闪烁两次。

如果您在密码对话框中启用了“用于所有压缩文件”选项并且设置了一个空的字符串作为密码，解压和测试命令会跳过所有加密的文件和压缩文件。在此模式中，WinRAR 状态栏中的钥匙图标不显示。

如果您在 压缩文件名和参数 对话框直接输入它，您不需要删除密码。这不同于其它方式，此类密码仅在单一压缩操作有效，并在完成后它会自动删除。

当解压加密的文件时，开始操作之前您也可以不需要事先输入密码。如果 WinRAR 遇到加密的文件，而解压之前未先输入密码的话，它便会提示用户输入密码。

RAR 压缩文件使用 CBC 模式下的 AES-256 算法为 RAR 5.0 压缩文件加密，以及 CBC 模式下的 AES-128 为 RAR 4.x 压缩文件加密。RAR 5.0 的密钥衍生函数（key derivation function）基于使用 HMAC-SHA256 的 PBKDF2。

默认情况下 ZIP 压缩文件使用 CBC 模式下的 AES-256 算法。但此类压缩文件可能与一些较老的 unzip 工具不兼容。您可以在密码对话框里设置“ZIP 传统加密”选项，来启用传统 ZIP 加密，它不如 AES 健壮，但为较老的软件提供更好的兼容性。

尽管 WinRAR 在 RAR 和 ZIP 格式中都允许使用 AES-256，但 RAR 中选择的密钥衍生函数参数可以使 RAR 加密措施对暴力攻击更有抵抗力。另外，RAR 允许加密文件名和其它文件属性。 如果您需要加密重要的信息，选择 RAR 压缩文件格式会比较好一些。为了确实的安全性，密码长度请最少要 8 个字符。避免在密码中使用普通单词，它们会让密码变弱。密码区分大小写。RAR 压缩文件密码的最大长度是 127 个字符。超长的密码被裁切为此长度。

如果“加密文件名”选项关闭，对于加密 RAR 5.0 文件的文件校验和被修改使用一种特殊的密码依赖算法。这很重要，因为不这样的话就可能在不知道密码的情况下，仅基于校验和就能猜测文件内容。对于短的文件或强 BLAKE2 校验和这样的风险特别高。不要期待这样的加密文件校验和匹配常规和 BLAKE2 和 CRC32 值。如果“加密文件名”选项打开，存储的校验和没有被修改，因为它们只有在提供了有效的密码后才能被访问。

请记住，如果您遗失您的密码，您将无法取出加密的文件，就算是 WinRAR 的作者本身也无法解压加密过的文件。


压缩文件注释

您可以选择性地添加文本信息到 RAR、ZIP 压缩文件中。这些信息叫做 压缩文件注释。要添加时，必须手动在 WinRAR 图形界面模式下使用 添加压缩文件注释 ，在命令行模式要从文件读取注释则使用 - 命令“C” 或是参数 -z<文件> 。

您也可以在 压缩文件名和参数 对话框中直接指定压缩文件的注释。

如果压缩文件含有注释，并且在 常规设置对话框 的选项“显示压缩文件注释”是打开的话，注释窗口将会显示在文件列表的右边。您可以用鼠标拖动左边框，以调整注释窗口的宽度。


防护压缩文件受损

RAR 压缩文件格式 支持一种特殊的附加数据类型，叫做 恢复记录。 中。恢复记录在增大压缩文件大小的同时，它能在磁盘错误或其它数据损坏的情况下帮助恢复存档的文件，只要损坏不是太严重。可以使用命令 "r"(repair) 处理这种损坏。ZIP 压缩文件格式是不支持恢复记录的。

您可以在 压缩文件名和参数设置对话框 设置“添加恢复记录”选项来添加恢复记录到压缩文件中。另一个方法是，在 压缩配置 对话框设置“添加恢复记录”选项。这种情况下，在任何压缩文件修改后均会添加恢复记录到压缩文件中。

如果您需要从 命令行 添加恢复记录，请阅读 rr[N] 命令 和 -rr[N] 参数 的描述，都可以用于此用途。

RAR 5.0 恢复记录使用 Reed-Solomon 纠错码。其修复连续损坏的能力和 RAR 4.x 一样,允许恢复数据略少于恢复记录大小。但它在有多重损坏区域时比 RAR 4.x 记录更有效。

RAR 4.x 恢复区块有 512 字节长，最多包含 524288 个分区，所以其有用的大小和数据恢复能力被限制到 256 MB。这种情况下 RAR 5.0 格式中恢复记录可以和压缩文件本身一样大。

您可以使用“压缩文件名和参数”对话框的 高级选项 设置恢复记录的百分比。也可以在 保护压缩文件 命令中设置。较大的恢复记录允许恢复更严重的损坏，但是会增加压缩文件的大小和处理时间，所以 3 - 10% 是比较理想的选择。由于服务数据开销实际产生的恢复记录大小只是大约匹配用户定义的百分比，对于小压缩文件差距比较大。

要修复一个有恢复记录的损坏压缩文件，请在 WinRAR 图形界面模式应用“修复”命令来完成，在命令行则是使用 命令“r”。修复后的压缩文件将会命名为 fixed.arcname.rar,‘arcname’ 的位置是原来的压缩文件（受损的）名。如果损坏的压缩文件并没有恢复记录，或在主要受损的部分用恢复记录未完全修复时，开始第二阶段。此阶段期间只是重新构建压缩文件的结构，校验和验证失败时是不可能恢复数据的，但如果损坏的压缩文件结构可以访问的话，仍是有希望恢复未受损的数据的，这在非固实的压缩文件上是非常有用的。此阶段对加密文件名的压缩文件不执行，它只有在存在恢复记录时才能修复。

当第二阶段完成时，重新构建的压缩文件将会被保存为 rebuilt.arcname.rar，‘arcname’的位置是原来的压缩文件名。

RAR 5.0 恢复记录比恢复记录本身更耐损坏，可以利用部分损坏的恢复记录数据。但是，请注意，“修复”命令不修复恢复记录的损坏块。只有文件数据可以被更正。压缩文件修复成功后，您可能需要对保存的文件创建一个新的恢复记录。

如果压缩文件数据损坏位置的位置没有偏移，4.x 和 5.0 的记录都很有效。如果您使用某些特殊的软件从损坏的媒介复制一个压缩文件，并有用零填补受损区域或从复制文件中切除受损区域的选择，最好选择用零或任何其他值填充，因为它可以保存原始数据的位置。不过，尽管不是最优的模式，两个版本的恢复记录都能试图修复被删除或插入合理大小,数据位置移动的数据。RAR 5.0 恢复记录处理删除和插入的情况比 RAR 4.x 更有效。


锁定归档

RAR 压缩文件格式 支持压缩文件的锁定。 WinRAR 无法修改锁定的归档，因此锁定重要的归档可以防止 WinRAR 意外修改它们。 如果 WinRAR 命令分组处理归档，这种保护可能特别有用。

在 WinRAR 图形界面模式使用“锁定压缩文件”命令或者在命令行中使用 命令“K” 均可锁定一个压缩文件。


如何选择最优的压缩设置

当创建新压缩文件时，您都面对“压缩文件名称和参数”对话框的 常规选项 页的几个压缩相关参数。您首先需选择压缩文件格式，可以是 RAR, ZIP 或 RAR4。 ZIP 只适用于当您不确定收件者是否有 WinRAR 或其它能解压 RAR 压缩文件的软件时。不然的话，推荐您选择 RAR，因为它支持更多的功能和更高的压缩率。 "RAR5" 是 WinRAR 5.0 引入的最新版本的 RAR 格式。它包含很多重要的修改，如 AES-256 加密、更有效的恢复记录、更大的字典大小，较老的软件，包括老版本的 WinRAR，不能解压 RAR 5.0 压缩文件。所以如果您计划把一个压缩文件发送给其他人，选择 RAR5 需要考虑兼容性问题。 RAR4 是较早版本的 RAR 格式，它缺乏一些重要的更改如 AES-256 加密、更有效的恢复记录、更大的字典大小，这些变化由 WinRAR 5.0 在 2013 年以 RAR5 格式引入。有些较老的工具包括 WinRAR 5.0 之前的 WinRAR 版本，不能解压最新 RAR 格式的压缩文件。如果您希望创建的 RAR 压缩文件与此类软件兼容，您可以选择 RAR4 选项。

姑且不论压缩文件格式的优劣，下一个步骤是选择压缩的方法。您可以选择“存储”、“最快”、“快速”、“常规”、“较好”和“最好”模式。在“最好”方式提供了最高，但速度最慢的压缩，“最快”压缩性能最差，但速度最快，“存储”以尽可能快的速度把文件添加到压缩文件中，而没有任何压缩。“最快”可能适用于每日备份，“最好”用于 Internet 发布，“普通”用于日常使用，如压缩 Email 附件。

如果您是选择 ZIP 压缩文件格式，您的准备工作已到完成阶段。如果选择 RAR 和 RAR5，则有两个重要的选项影响压缩: 字典大小和固实压缩模式。

压缩字典是被压缩算法使用的内存区域，用来查找和压缩重复数据模式。大字典会很大程在度提高大文件，特别是固实模式中，的压缩效果，但它也会导致较慢的压缩速度和更高的内存需求。通常我们建议 RAR 格式使用 4MB 的字典，RAR5(RAR 5.0)压缩文件格式使用 32MB。您可以在 这里读取有关字典大小的更多信息。

“创建固实压缩文件”选项在处理很多小的类似文件时，把要压缩的文件作为一个单独的连续数据流，会导致更高的压缩率。但是它也会导致以后压缩文件修改速度的减慢，增加压缩文件损坏时数据丢失的数量。此模式在 固实压缩文件 主题中有详细解释。

这是所有影响压缩率和速度的主要设置值。实际上，在每次压缩之前，您并不需要每次都设置它们，只需要简单地在默认 压缩配置 选择您喜欢的默认值。它可以在 压缩设置 对话框内创建。


介绍 WinRAR 使用界面

此主题扼要地描述 WinRAR 图形界面的主要组件。

WinRAR 有下列菜单: 文件、命令、 工具, 收藏夹、选项 和 帮助。请选择适当的主题来读取关于各个菜单的命令。

下一个界面项目是工具栏，它被置于菜单下，文件列表上。工具栏按钮是重复的 命令 菜单项目 (请注意，此菜单的所有项目也有键盘快捷键 )。某些按钮只在查看文件夹内容时有效，有些只在查看压缩文件时有效，而某些两种模式均有效。当 WinRAR 显示压缩文件的内容时，如果同等的压缩文件管理功能无法应用在压缩文件时，某些按钮可能会不出现。如果您需要的话，您可以使用 常规设置对话框 来选择要显示的按钮、删除按钮文本或改变按钮的尺寸，或是在工具栏上用鼠标右键单击做设置。

在工具栏按钮下面您将会看见小型“向上”按钮和驱动器列表，“向上”按钮会将当前文件夹转移到上一级，驱动器列表则用以选择当前的磁盘或者，例如，网络，您可以使用鼠标或 F4 键打开它。“向上”按钮和驱动器列表是可以拖动到工具栏的右边的。按下 Ctrl+D 或单击状态栏上的小型“驱动器”图标，也能用来更改当前的驱动器。

文件列表则位于在工具栏的下面。它可以显示未压缩的当前文件夹，或者 WinRAR 进入到压缩文件时，显示压缩过的文件等内容，这些被称为 文件管理和压缩文件管理模式 。每一个文件会显示下列参数: 名称、大小、类型和修改时间。被压缩的文件还有两个附加的参数：压缩包大小和校验和。 校验和是基于文件数据计算出的特殊值，可以用来检测存档的文件是否损坏。WinRAR 可以使用 CRC32 或 BLAKE2 算法计算校验和。

所有的参数都会列入到区域中。通过在区域标题上单击，您可以更改文件的排列顺序 (在标题栏的蓝色的箭头显示排序方向)，也可以通过鼠标拖动标题栏的分隔线来改变标题栏的宽度。有几个附加的列表选项可在 文件列表 对话框中使用。

如果压缩文件被加密过，它的名称后面会跟随着星号。如果文件接续着下一个分卷，它的名称则会跟随着“-->”。如果文件是接续着上一个分卷，它的名称则会跟随着“<--”。以及如果文件是接续在上一个与下一个分卷之间，它的名称则会跟随着“<->”。

在处理文件之前，您必须在列表先选择。在标准的 Windows 选择文件方式外，WinRAR 另外多提供了几个按键给选择操作: 空格键、 Ins 键、NUM +、NUM -。更详尽的内容可以在主题 选择文件 中找到。

下列的按键可用来在列表中浏览。Backspace 或 Ctrl+PgUp 或在文件夹的“..”名称上双击，可以转到磁盘或压缩文件文件夹的上一级。如果您正在查看压缩文件的最上级文件夹，相同的动作将会关闭压缩文件。按下 Enter 或 Ctrl+PgDn 或在任何其它的文件夹上双击则进入里面。同样的动作应用在压缩文件名时，则会打开此压缩文件。 Ctrl+\ 则将磁盘的根目录文件夹或含有压缩文件的文件夹设置为当前文件夹。

Ctrl+PgDn 可以用来尝试将带有非压缩扩展名的文件以压缩文件的方式打开。例如，如果您希望检查 exe 文件是否为自解压压缩文件（SFX ）而不想要运行此文件，您可以在其名称上按下 Ctrl+PgDn。WinRAR 会在 SFX 的情况下显示压缩文件内容。

如果您在文件列表上单击鼠标右键，将会出现包含文件管理和界面命令的菜单。这些命令在普通的 WinRAR 菜单，工具栏和键盘也有，所以您可以选择对您而言最方便的一个。

如果在 选项 的“文件夹树”子菜单中启用文件夹树面板， WinRAR 窗口的左部会包含它。如果您需要在磁盘中或压缩文件中快速导航时目录树很方便。您可以用鼠标拖动它的右边改变文件夹树的宽度。

当 常规设置对话框 属性页“显示压缩文件注释”被选定，而打开的压缩文件存在着注释的时候，文件列表的右边可能会被压缩文件注释窗口所覆盖。您可以通过鼠标拖动注释窗口的左框线，来改变注释窗口的宽度。

状态栏在文件列表下面，WinRAR 窗口的底部。状态栏的左边部分包含二个小图标“驱动器”和“钥匙”。在驱动器图标上单击，您可以更改当前的驱动器。要更改当前的密码，则在 钥匙图标上单击。这些命令在 文件菜单 也有。默认的“钥匙”图标是黄色的，但是如果存在密码，图标将会变成是红的。状态栏的中间部分显示选定的文件总计大小，或有关于当前的操作信息。状态栏右边部分则显示当前文件夹的文件数量和大小。


文件管理和压缩文件管理模式

WinRAR 图形界面可以是二种基本状态中的一种 : 文件管理模式或压缩文件管理模式。

在文件管理模式，将会显示当前工作文件夹的文件和文件夹列表。您可以使用鼠标或键盘等常用的 Windows 方式来 选择 文件和文件夹，以及运行不同文件操作，例如压缩或者删除。这些模式也可以用压缩文件组来运行测试和解压操作。

在压缩文件管理模式，将会显示当前打开的压缩文件的压缩文件和文件夹列表，您也可以选择文件和文件夹，并运行如解压、测试或注释等压缩文件指定操作。

在任一个模式里，您均可以更改当前的文件夹 (实际的或压缩过的)。按下 Backspace 或 Ctrl+PgUp 或在文件夹的 名称上双击，可以转到磁盘或压缩文件文件夹的上一层。如果您正在查看压缩文件的最上层文件夹，相同的动作将会关闭压缩文件，并返回到 WinRAR 文件管理模式。按下 Enter 或 Ctrl+PgDn 或在任何其它的文件夹上双击则进入里面。同样的动作应用在压缩文件名时，则会打开此压缩文件。 Ctrl+\ 则将磁盘的根目录文件夹或含有压缩文件的文件夹设置为当前文件夹。

要进入 WinRAR 的文件管理模式，只需很简单地在 WinRAR 图标上双击，或者从命令行不加参数运行 WinRAR。

要进入 WinRAR 的压缩文件管理模式，先从文件管理模式启动 WinRAR，然后将光标移到想要的压缩文件上，并在压缩文件名上按下 Enter 或从 文件菜单 使用“打开压缩文件”命令。或者在 Windows 界面 (资源管理器或桌面 ) 的压缩文件名上以鼠标双击就可用 WinRAR 将它打开。要有这样的特性，WinRAR 必须在安装期间关联到压缩文件 (它是默认的安装选项 )。您也可在安装后使用 综合设置对话框 将压缩文件关联到 WinRAR。最后，如果在命令行以压缩文件名作为单个参数运行 WinRAR，也可以直接从命令行进入想要的压缩文件。


选择文件

进行任何操作之前，您必须通过 WinRAR 文件列表，在全部的文件和文件夹中选择要操作的文件。

如果您只要选一个文件，只要移动光标到那个文件便可开始操作。文件的选择有数种方式，就像其它的 Windows 应用程序一样，您可以在按方向键或鼠标左键时，按住 Shift 按键来选择文件组。要选择数个分散开的项目则按住 Ctrl 键，然后在每一个想要的项目上单击。按下 Ctrl+A 或者从 文件菜单 使用“全选”命令，可以在当前文件夹选择全部的文件和文件夹。

所有上面涉及非持续性的选择标准方法，如果您移动光标便可以取消选择。虽然标准方法通常就足够使用，但是有时持续性的选择是比较方便的，它允许在当前文件夹浏览，而不会使先前所作的文件选择标记失效。 WinRAR 为此提供一些按键

空格, Ins | 选择光标下的文件，并将光标往下移动。要取消选择文件则使用空格键，在名称上用空格键再按一次或使用“NUM -”命令。
NUM * (数字键盘) | 反选当前文件
NUM + (数字键盘) | 以输入的通配符过滤掩码选择文件
NUM - (数字键盘) | 以输入的通配符过滤掩码取消选择文件

如果在开始解压或测试之前未选择文件，全部压缩的文件将会被解压或是测试，此规则仅在测试及解压操作时有效。


主题

界面主题允许修改通过使用可选的一套图片替换来修改默认的 WinRAR 外观。主题文件以扩展名为“.theme.rar”发布的 RAR 压缩文件。您可以从 WinRAR 主页 的“主题”部分下载它们。要安装一个新的主题，只需要在 WinRAR 像普通 RAR 文件一样打开主题，例如，在它的图标上双击。然后在 WinRAR 显示的对话框中确认来安装。

安装的主题列表在 选项 菜单的“主题”子菜单中。选择任何的列表项目来激活相应的主题。此参考也包含命令“管理主题”提供主题管理功能和“获得更多主题”加载主题网页。

主题文件存储在 %APPDATA%\WinRAR 文件夹 的“Themes”子文件夹内。


向导界面

WinRAR 的向导界面为初学用户设计，允许进行使用一步步的模式执行基本的压缩和解压缩操作。只需点击工具栏上的向导按钮并选择一个您想要执行的操作。

您需要按下 WinRAR 工具栏上的 向导 按钮来显示向导对话框。默认这个按钮在压缩文件内部和外部都是可见的，但是您可以在 常规设置 对话框中的“选择按钮”中，像工具栏中其它按钮一样启用或禁用它。“启动时激活向导”允许在 WinRAR 在启动时自动运行向导。

每个向导对话框顶端有一个简单的用法说明，描述对话框的内容和可能的用户动作。您也可以按下 帮助 按钮得到更多的细节用法说明。


向导: 选择操作

这里您需要选择要进行的操作。

如果您需要解压 RAR、 ZIP 或者其它压缩文件，选择“解压一个压缩文件”。例如，您要解压缩从 Internet 上下载的文件时要选择它。

如果您要创建一个新的压缩文件并把一些文件以压缩格式添加进去，选择“创建新的压缩文件”选项。它可以被用来在您通过 E-mail 发送或复制到外部磁盘前压缩文件，它帮助减小文件大小。

如果您希望向已存在的压缩文件中添加文件而不是创建新的，选择“添加文件到已存在的压缩文件中”选项。

选择好一个操作后，按下对话框下部的“下一步”按钮。如果您选择了“创建新的压缩文件”或“添加文件到已存在的压缩文件中”，您将看到“选择要添加的文件”对话框，这里您需要选择您要压缩的文件。当选择“解压一个压缩文件”的情况时，您会直接到下一个“选择压缩文件”对话框。


向导: 选择压缩文件

这里您需要选择一个压缩文件解压。

按下“浏览”按钮，定位您的文件，选择它的名字并按下“打开”。当然，如果不使用“浏览”，您也可以拖动压缩文件的图标到这个对话框上。

您选择压缩文件名后，按下对话框下部的“下一步”按钮。

注意当激活对话框时 WinRAR 可以猜测压缩文件名，并从您的桌面设置一个已存在的压缩文件名。如果它真的是您要解压的压缩文件，只需按下“ 下一步”，但是如果 WinRAR 猜测错误，只需选择您想要的压缩文件名，和上面描述方法的一样。


向导: 选择压缩文件

这里您需要选择一个压缩文件来创建或更新。

如果您要创建新的压缩文件，通常 WinRAR 将给它建议的某个名字。您既可以接受这个名字，也可以输入其它的。如果 WinRAR 的 设置 选项中的“压缩文件保存的默认文件夹”选项是非空的， WinRAR 将会在这个文件夹中创建文件。如果您希望把它创建到其它的文件夹中，按下“浏览”按钮，找到一个文件夹来添加压缩文件，在“文件名”区域输入文件名并按下“打开”。

如果您希望添加文件到已存在的压缩文件中，您也可以使用“浏览”来定位要更新压缩文件或拖动压缩文件的图标到这个对话框上。

您选择压缩文件名后，按下对话框下部的“下一步” 按钮。


向导: 选择文件夹解压文件

这里您需要选择一个文件夹来放置从压缩文件中解压的文件。

默认情况下 WinRAR 会使用在 WinRAR 路径设置 中指定的“解压缩文件的默认文件夹”中创建它们或者如果没有指定则把它创建在桌面上。您既可以接受这个被建议的名字，也可以按下“ 浏览”按钮并手动选择文件夹。

您选择文件夹名后，按下对话框下部的“完成” 按钮开始解压操作。


向导: 压缩文件选项

在这里您可以选择一些附加的压缩选项。

如果快速的压缩速度比压缩率更重要，则启用“快速，但是压缩率较小”。

如果您希望在成功压缩后删除源文件，设置“压缩后删除源文件”。

如果您需要创建 自解压 压缩文件，启用“创建自解压 (.exe) 压缩文件”选型。这样的压缩文件不需要WinRAR 来解压，它有 exe 的扩展名并能运行(在图标上双击 )来解压里面的内容。

如果您要 加密 压缩的文件您可以按下“设置密码”按钮并指定一个密码。不要忘记您的密码，没有它就不能解压加密的文件。

当然，如果您创建一个新的压缩文件，您可以把它分成几个部分(被称为 卷)。有时数个小尺寸的文件比一个大文件更方便。如果您要这样做，只要在对话框下部的输入区域输入以字节为单位的单个部分的大小。 您可以以字节、KB、MB、GB 来指定大小。只需要在分卷大小右边的下拉列表中选择一个适当的项目。允许十进制小数。

如果您更新一个已经存在的压缩文件，选择创建自解压文件并把它分成几部分是不能的。它只能在新建压缩文件时起作用。

注意这个对话框中的所有设置都是可选的，通常您可以使用它们的默认值。

完成后，按下对话框下部的“完成”按钮开始压缩操作。


查看文件

当您运行“查看文件”命令时，WinRAR 会在 内部查看器 窗口里显示光标下的文件内容，而不管文件的内容或配置设置值。但如果您是在文件名上按下 Enter ，可能会有数种不同的结果。如果光标下的文件是压缩文件， WinRAR 将会打开它并且显示它的内容，不然的话，下一个动作将依据它们在 查看器设置对话框 的设置而定。在此对话框，您可以强制 WinRAR 始终使用内部的查看器。要用外部查看器打开文件时，可调用文件类型关联的 Windows 程序。或者，每次在查看文件之前，询问要运行上述的哪一个动作。

WinRAR 可用来查看一般的文件，而不管是不是压缩文件。如果是调用外部程序来查看压缩文件， WinRAR 会解压此文件到临时文件夹，传送它的名称到外部程序运行并等待外部程序退出。在 WinRAR 测试文件修改时间后，并且如果发现它已被更新，则提供更新信息给压缩文件内的文件，然后删除含有解压文件的文件夹。

注意，当在有 .exe 扩展名的压缩文件上按下 Enter 的时候，在上面述及的方案有些微的修改。在这种情况， WinRAR 不仅解压此文件，而是整个压缩文件内容解压到临时文件夹，然后运行可执行文件。下列的步骤则与上面所述及的类似 : WinRAR 将会等候可执行文件退出，然后测试解压的文件修改时间，并且如果它已被更新，或者创建了新文件时，则提供更新信息给压缩文件，然后删除临时数据以及它的内容。这种处理 .exe 文件的方式，允许程序从压缩文件中被直接运行。举例来说，您可以使用它安装新的程序，而不需自行解压压缩文件来安装。只要进入压缩文件，并在 setup.exe 或 install.exe 程序上按下 Enter 即可。


内部查看器

内部查看器的命令。

菜单/项目 | 快捷键 | 功能
文件/退出 | Alt+F4, Ctrl+W | 从内部查看器退出
编辑/复制 | Ctrl+C | 复制选定的文本到剪贴板
编辑/全选 | Ctrl+A | 选择全部查看的文本
编辑/查找 | Ctrl+F | 在文本中查找字符串
编辑/查找下一个 | F3 | 查找下一个字符串
查看/作为 Windows 文本查看 | Ctrl+I | 使用 Windows 字符表
查看/作为 DOS 文本查看 | Ctrl+D | 使用 DOS 字符表
查看/作为 Unicode (UTF-16LE)查看 |  | 把文本作为小端字节序编码 UTF-16 格式的 Unicode 查看
查看/作为 Unicode (UTF-8)查看 |  | 把文本作为 UTF-8 格式的 Unicode 查看
查看/自动换行 | Ctrl+S | 切换文本自动换行
查看/设置字体... |  | 设置查看器字体
帮助/查看帮助 | F1 | 显示内部查看器帮助

要更改当前的编码，您可以单击查看器状态栏右边，那里会显示当前的编码名称。默认的编码是使用在 查看器设置对话框 所指定的。


“添加到压缩文件”命令

该命令在 文件管理 与 压缩文件管理 模式两者都可以使用。

当 WinRAR 浏览磁盘上的文件时，首先您必须 选择 要压缩的文件和文件夹。然后运行 命令菜单 的 “添加到压缩文件” 命令、在工具栏上的“添加”按钮或键盘快捷键 Alt+A 运行 压缩文件名和参数 对话框，选择压缩文件名和参数，并按下 Enter 开始压缩。

当 WinRAR 显示压缩内容，您必须先运行“添加到压缩文件 命令，然后在出现的对话框内选择文件，并设置上面所述的压缩文件名和参数。

命令行对应的命令: 命令“a”


“解压到指定文件夹”命令

此命令使用于当 WinRAR 是用在 文件管理 和 压缩文件管理 模式时。

在压缩文件管理模式中，当 WinRAR 显示压缩文件内容时，首先，您需要 选择 要被解压的被压缩文件和文件夹。然后使用 命令菜单 、工具栏上的“解压到”按钮或 ALT+E 键盘快捷键运行“解压文件到指定路径中”命令。在 解压路径和选项对话框 中您可以指定解压文件的目标文件夹并且，如果需要的话，设置附加选项。关闭这个对话框后，解压开始。

在文件管理模式可以一次解压几个压缩文件。通常这个操作和前一节中描述的类似，但不是选择压缩文件内部的文件，而是您要 选择 压缩文件和 WinRAR 要搜索压缩文件的文件夹。如果找到任何的压缩文件，将会显示 解压路径和选项对话框。关闭这个对话框后所有找到的压缩文件都将被解压。

命令行等同于: 命令“x”


“测试压缩文件”命令

此命令使用于当 WinRAR 是用在 文件管理 和 压缩文件管理 模式时。

在压缩文件管理模式下，当 WinRAR 显示压缩文件内容，首先，您必须 选择 要测试的压缩文件和文件夹。然后使用 命令菜单、工具栏上的“测试”按钮或键盘快捷键 Alt+T 运行“测试压缩文件”命令。

测试期间所发现的全部错误将会显示在“诊断信息”窗口。如果未检测到错误， WinRAR 将显示一个相应的信息。

在文件管理模式，它能够一次测试数个压缩文件。常规操作与上一段所述相似，但以压缩文件内选定的文件代替。您必须 选择 要 WinRAR 压缩文件和要搜索压缩文件的文件夹。当搜索完成后， WinRAR 将测试所有找到的压缩文件内容。

命令行等同于: 命令“t”


“查看文件”命令

该命令在 文件管理 与 压缩文件管理 模式两者都可使用。它会在 内部查看器 打开光标下面的文件。要运行此命令，可使用 命令菜单、工具栏上的“查看”按钮或是键盘快捷键 Alt+V 的其中一种。

另请查阅: 内部查看器、查看文件


“删除文件”命令

该命令在 文件管理 与 压缩文件管理 模式两者都可使用。在文件管理模式时，它会把选定的文件和文件夹移动到回收站，因此您还有机会恢复意外删除的数据。但在压缩文件管理模式时，选定的文件和文件夹将会从压缩文件中完全的删除，在之后没有任何恢复的可能，因而在此您必须小心。要运行此命令，可使用 命令菜单、工具栏上的“删除”按钮或是键盘快捷键 Alt+D 或键盘上的 Del 按键的其中一种。

在文件管理模式，您也可以永久删除文件。在删除文件时按下 Shift+Del 来替代 Del 键就不会删除到回收站。Shift+Del 命令静默地删除文件即使它们为只读和系统属性，并允许删除非标准名称的文件，例如名称带有后缀空格和小数点。通常基于回收站的删除无法处理这种名称。

命令行对应命令: 命令“d”


“重命名文件”命令

这个命令在 文件管理 和 压缩文件管理 模式下重命名光标下的文件和文件夹。在压缩文件内部重命名文件支持 RAR 和 ZIP 格式。可以使用 命令菜单 或 F2 键盘快捷键来运行这个命令。

重命名命令在使用 多卷压缩文件 时有一些限制。只有那些包含在当前卷中的文件才可以改名。如果您希望重命名卷中的文件，您需要禁用 文件列表 设置对话框中的“合并卷内容”选项，并打开包含所要文件的卷。

当选择一个新的文件名是要小心。如果它包含不被文件系统支持的字符，可能在以后解压重命名后的文件时发生问题。在这样的情况下，只需要把它改为可以使用的名字就可以了。

命令行对应命令: 命令 rn


“打印文件”命令

这个命令允许在 文件管理 和 压缩文件管理 模式里打印光标下的文件。在 命令菜单 或使用 Ctrl+I 快捷键运行。


“不确认直接解压”命令

此命令使用于当 WinRAR 是用在 文件管理 和 压缩文件管理 模式时。 如果 WinRAR 是在压缩文件内部，您需要 选择 要解压的被压缩的文件和文件夹。如果在文件管理模式解压文件，选择要解压的文件和文件夹。 然后使用 命令菜单、工具栏上的“解压”按钮 或 ALT+W 键盘快捷键运行“不确认直接解压”命令。被选择的文件将被解压到当前文件夹或在 路径设置 对话框中指定解压文件的默认文件夹中。如果您要设置不同的解压文件夹或一些附加选项，就要用 解压到指定文件夹 命令。

命令行对应命令: 命令“x”


“添加压缩文件注释”命令

此命令是使用于当 WinRAR 是在 文件管理 和 压缩文件管理 的时候。如果您在压缩文件内部，您不需要选择任何要运行该命令的文件，只要使用 命令菜单、工具栏上的“注释”按钮或键盘快捷键 Alt+M 运行“添加压缩文件注释”命令，然后在出现的对话框中输入 压缩文件注释 。如果您在文件管理模式浏览未被压缩的文件，首先选择要搜索来添加注释的文件和文件夹。

命令行对应命令: 命令“c”,参数 -z<文件 >


“保护压缩文件防止损坏” 命令

此命令使用于当 WinRAR 是用在 文件管理 和 压缩文件管理 模式时。如果您在压缩文件内部，不需要选择任何文件，只需使用 命令菜单 、工具栏上的“保护”按钮或 ALT+P 键盘快捷键运行“保护压缩文件防止损坏”命令。如果您在文件管理模式浏览未压缩文件，首先选择要搜索要保护的文件和文件夹。

添加 恢复记录 到当前被打开或被选择的压缩文件命令。它可以帮助以后万一压缩文件数据有小的物理损坏时 修复 它。这个功能只被 RAR 压缩文件支持。

如果打开的文件是 多卷 系列的第一个文件，您也可以为它创建 恢复卷。只需输入要创建的 .rev 文件的数目。您也可以在这个参数后附加一个百分数，这样创建的 .rev 文件的数目将等于从 RAR 卷总数获得的百分比。

命令行对应命令: 命令“rr”, 命令“rv”


“锁定压缩文件”命令

此命令使用于当 WinRAR 是用在 文件管理 和 压缩文件管理 模式时。如果您在压缩文件内部，您不需要选择任何要运行该命令的文件，只要使用 命令菜单、工具栏上的“锁定”按钮或键盘快捷键 Alt+L 运行“锁定压缩文件”命令。如果您在文件管理模式浏览未压缩文件，首先选择要搜索来锁定的压缩文件和文件夹。

WinRAR 无法修改锁定的归档，因此锁定重要的归档可以防止 WinRAR 意外修改它们。 如果 WinRAR 命令分组处理归档，这种保护可能特别有用。

该命令不旨在或不能阻止其他工具或第三方有意进行修改。它仅针对 WinRAR 引起 的意外数据变更实行安全措施。它仅被 RAR 归档支持。

命令行对应命令: command "k"


“扫描压缩文件内病毒”命令

此命令在 文件管理 和 压缩文件管理 模式都能执行。把一个或多个压缩文件解压到临时文件夹并用安装在用户计算机中的第三方防病毒软件检查其中内容。在压缩文件管理模式，它只处理当前打开的压缩文件，在文件管理模式，在选择的文件和文件夹中的所有压缩文件都会被处理。

此命令显示的对话框包含下列区域。

WinRAR 找到的病毒扫描软件

由 WinRAR 找到的已安装的防病毒软件列表。如果这个列表包含数个病毒扫描软件，您可以选择它们中您想使用的任何一个。如果列表只包含“用户自定义”条目，就意味着 WinRAR 没有找到任何防病毒软件，您需要手动指定一个扫描程序名和参数。

病毒扫描程序名称

病毒扫描软件可执行文件的名字。只有在 WinRAR 不能找到安装在您的计算机上的防病毒软件，并且“由 WinRAR 找到的病毒扫描软件”列表只包含“用户自定义”条目时，您才需要修改它。这时您需要单击“浏览”按钮，定位病毒扫描程序 .exe 文件，它会被 WinRAR 调用检查解压的文件。

病毒扫描程序参数

传递给病毒扫描程序的参数。只有在 WinRAR 不能找到安装在您的计算机上的防病毒软件或它传递给病毒扫描软件的参数不对时，您才需要修改它。例如，这可能发生在防病毒程序的新版本的命令行语法改变时。通常病毒扫描软件需要至少一个参数 - 包含解包文件的文件夹的名字。WinRAR 把这个文件夹表示为%f。如果他的名字包含空格，需要用引号包含它，所以大部分情况下您需要把字符串“%f”放到这里。有些扫描软件需要附件选项，这都可以在它们的文档中找到。

如果您只使用一种防病毒软件并且不需要每次都修改它的参数，您可以通过关闭在 安全设置 中的“提示选择病毒扫描软件”选项来跳过病毒扫描选择对话框。

注意

  1. WinRAR 本身不能查找病毒，它调用已安装到您计算机中的防病毒软件。如果您没有这样的软件，您不能使用此 WinRAR 命令;
  2. 此命令完成后，WinRAR 不会显示任何信息。如果发现病毒，您应该阅读由病毒扫描软件显示的信息。
  3. WinRAR 在调用病毒扫描软件前，先解压所有选择的压缩文件，所以您的磁盘必须由足够的空间来容纳解压的文件。WinRAR 在扫描完成后就删除这些文件;
  4. WinRAR 能自动检测到许多流行的防病毒程序，所以您不需要手动编辑“病毒扫描程序名称”和“病毒扫描程序参数”区域。只要从列表框选择一个扫描软件并单击“确定”。只有在这种方式无效时再使用这两个区域;
  5. WinRAR 保存上次启动病毒扫描程序的参数，在您下次启动此命令时恢复它。


“转换压缩文件格式”命令

运行这个命令把一种压缩格式重新压缩成另一种格式。它在 文件管理模式 和 压缩文件管理模式 中都能使用。在文件管理模式中可以选择数个文件和文件夹来处理，WinRAR 会扫描它们并转换找到的压缩文件。在压缩文件管理模式中默认只转换当前的压缩文件。“转换压缩文件”对话框包含几个控制命令执行的项目。它们的描述如下。

要转换的压缩文件

要用 WinRAR 转换的压缩文件列表。您可以使用添加和移除按钮来添加或移除项目。“移除”按钮不会删除磁盘上的文件，它只是从转换列表中移除它们。

压缩文件列表的内容依靠下一个对话框参数，格式列表。

压缩文件类型

在这里您要选择要转换的压缩文件格式。在这个列表中的压缩文件格式后可能有一个在括号中的数字。它显示了找到多少个这个类型的压缩文件。例如，“zip(12)”意味着 WinRAR 找到了 12个 zip 压缩文件。如果没有这个数字，表示没有找到这种类型的文件。

转换选项/最低允许率

这个选项允许指定可以接受的转换后压缩文件的最低 <新压缩包大小>/< 旧压缩包大小> 百分比。例如， 如果您设为 100，当新的压缩文件大于旧的时，WinRAR 将保存已经存在的压缩文件。如果它被禁用，WinRAR 会忽略压缩文件大小。

转换选项/压缩

“压缩”按钮激活一个对话框，在这里您可以选择转换后文件的不同参数。例如，您可以选择它们是 rar 还是 zip。

转换选项/保存转换后文件的文件夹

在这里您可以输入保存转换后压缩文件的文件夹。如果此文件夹不存在，WinRAR 将尝试创建它。如果此区域是空的，新的压缩文件回被放到旧的被转换文件所在的文件夹中。

转换选项/删除源压缩文件

成功转换后删除选择的文件。

如果原来的和新的压缩文件有相同的格式并且“保存转换后压缩文件的文件夹”是空的，原来的压缩文件就会不管这个选项而被删除。

转换选项/跳过压缩文件

如果启用此选项，加密的压缩文件不会被转换。这可能在您想在无人值守模式下运行转换命令，避免密码提示时有用。当然，如果您知道所有加密的压缩文件使用相同的密码，有另一种办法可以用，调用转换命令前关闭此选项，在 文件 菜单中设置的 默认密码。

"保存" 按钮

这个按钮存储除了“要转换的压缩文件”列表外所有对话框的状态，所以当下次激活对话矿石它会被恢复。您可以使用它来保存您常用的转换设置。

备注

  1. WinRAR 只有文件被成功创建才会保存新的压缩文件，测试和报告的包含文件的总的非压缩大小等于原来压缩文件的未压缩大小。
  2. WinRAR 当可能时尽量保留压缩文件注释。但是如果用户使用“压缩”按钮激活的对话框在指定注释，它将有更高的优先级。文件注释不被转换。其它指定的压缩文件信息，像 NTFS 流和文件安全数据也可以被转换，或者依赖于压缩设置和压缩文件类型。
  3. WinRAR 在转换前把原来的压缩文件解压倒临时文件夹中。在这个文件夹中您需要有足够的可用空间。
  4. WinRAR 在转换包含特殊数据的压缩文件时可能失败，如链接或文件版本。


“修复压缩文件”命令

此命令是使用于当 WinRAR 是用在 文件管理 和 压缩文件管理 模式时。它将认为选择的文件或打开的压缩文件是损坏的压缩文件去尝试修复它们。要使用 工具菜单 或工具栏上的“修复”按钮或 Alt+R 键盘快捷键运行此命令。

WinRAR 只能够修复 RAR 和 ZIP 压缩文件。WinRAR 会试着使用压缩文件数据和扩展名，自动检测压缩文件的类型，但用户也可以自行设置压缩文件类型。

源压缩文件不会被改变，而且操作的结果将会被保存到新的压缩文件。新的压缩文件会命名为 _fixed.arcname.rar 或 rebuilt.arcname.rar。arcname 是原始文件名。

。如果有 恢复记录 ,RAR 压缩文件成功修复的机会比较高一些。注意，没有恢复记录的 固实压缩文件 通常是无法成功修复的。

“修复”操作是否成功，依赖于压缩文件的类型和损坏区域的类型和大小。如果 RAR 压缩文件有恢复记录，则恢复成功的可能性将会很高。如果没有恢复记录，对于固实压缩文件机会就很低，而对于加密文件名的压缩文件则不可能修复。

压缩文件修复的技术详细资料提供于 命令“r” 叙述中(搑”为命令行命令，等同于“修复压缩文件命令” )。

命令行等同于: 命令“r”


“把压缩文件转换成自解压格式”命令

此命令使用于当 WinRAR 是用在 文件管理 和 压缩文件管理 模式时。它将会转换压缩文件成为 自解压。如果您在压缩文件内部，您不需要选择任何要运行该命令的文件，只要使用 工具菜单、工具栏上的“自解压文件”按钮或键盘快捷键 Alt+X 运行“把压缩文件转换成自解压格式”命令，并从列表中选择需要的自解压模块。如果您在文件管理模式浏览未被压缩的文件，首先选择要搜索来转换的文件和文件夹。

如果压缩已经是自解压文件，使用该命令可让您从压缩文件删除已存在的自解压压缩模块。这类例子时， WinRAR 不会改变原有的压缩文件，只创建内容相同，但没有自解压模块的新压缩文件。

如果您选定了 Windows 图形界面自解压模块，会有些推荐的默认值，您也可以单击“高级自解压选项”按钮设置例如默认目标路径、标题和窗口文本等的自解压参数设置。读取 高级自解压选项 主题可获得更多关于它们的信息。

这些主题包含了关于在 WinRAR 中所提供的自解压模块信息:

图形界面 RAR 和 ZIP 模块(Default.SFX 和 Zip.SFX)

控制台 RAR 模块(WinCon.SFX)

命令行对应命令: 命令“s”


“查找文件”命令

这个命令在 文件管理模式 和 压缩文件管理模式 中都能使用。使用“查找文件”对话框即可以在打看的文件中，也可以在选择的文件夹和磁盘中搜索包含指定字符串的文件。对话框描述如下。

要查找的文件名

默认它包含“*”，这意味着检查所有文件。您可以在这里输入其它的掩码，例如，“*.txt”只在 .txt 文件中搜索。它允许输入用空格分隔的几个文件掩码。如果您需要指定包含空格的文件名，使用引号包含它。

要查找的字符串

在这里您可以输入要查找的字符串。如果您保持这个区域空白， WinRAR 将显示匹配其他指定条件的所有文件。

大小写匹配

启用区分大小些字符串比较。

使用所有字符表

当查找字符串时使用 ANSI、Unicode UTF-8、Unicode UTF-16 和 OEM (MS DOS) 字符表。如果这个选项关闭， WinRAR 搜索中只使用默认的 Windows 字符表(ANSI)。

十六进制查找

把输入的字符串作为一系列用空格分隔的十六进制数序列。

搜索区域

此选项限制为当前已打开的压缩文件，如果在压缩文件内部搜索。压缩文件外部使用“当前文件夹”来仅在当前文件夹中搜索，“已选项目”来在 WinRAR 文件列表里选定的文件夹和文件里搜索。选择合适的驱动器名称来在这些驱动器上搜索。

压缩文件类型

要搜索的压缩文件类型。默认包喊“*”，意思是“所有的压缩文件格式”，但是，例如，您可以输入“*.rar”来只在 rar 压缩文件中搜索数据。它允许输入数个用空格分隔的压缩文件掩码。

“在子文件夹中查找”选项

强制 WinRAR 不仅在指定文件夹中搜索，还要在子目录中搜索。仅适用于“当前文件夹”搜索区域。

“在文件中查找”选项

如果启用，WinRAR 将在在匹配指定文件名的非压缩普通文件中搜索。

“在压缩文件中查找”选项

启用在被压缩的文件中查找。您可以设置即“在文件中查找”又“在压缩文件中查找”来在压缩文件和普通文件中搜索希望的字符串。

“忽略已加密的”选项

如果需要密码才能搜索加密的压缩文件内容，则此类压缩文件会被静默地跳过。

"Save" 按钮

这个按钮保存本对话框中的一部分选项，以便在下次激活时自动恢复它们。有些选项可能未被保存，并初始化为更适合于当前搜索的值。

命令行等同于: 命令“i”


“显示信息”命令

此命令是使用于当 WinRAR 是在 文件管理 和 压缩文件管理 的时候。只需使 工具菜单 、工具栏上的“信息”按钮或 ALT+I 键盘快捷键运行“显示信息”命令。

在文件管理模式它允许获得关于被选择的文件和文件夹的信息：总大小、文件和子文件夹数目、压缩文件数。为了提高操作速度，探测压缩文件只是基于文件的扩展名，所以 自解压 压缩文件在这里不被计入。文件扫描可能占用很长时间，但是如果您希望的话，您可以在任何时候关闭这个对话框。

分配个给文件可变大小区块的磁盘空间被称为簇。例如，如果簇的大小是 4096 字节，并且您创建的文件只有1字节大，事实上它将占用 4096 字节。所以，给您一个提示您的文件真实占用的多少和压缩它们后可以节省多少，信息对话框页显示当前磁盘的簇大小。被选择的文件的真实大小包括簇尾部没有填满的空间，被称为“浪费的空间” - 在这些文件尾部浪费的空间总计。

当文件扫描完成时，您可以按下“估计”按钮来获得选择文件估计的压缩大小和时间。此预测是基于 RAR 的“常规”压缩模式，假设磁盘最快并且磁盘交换所花的时间很少。压缩估计运行得很快很粗糙，所以不要期望在这里获得精确的结果。通过它可以显示是否值得化时间来压缩选择的数据。如果设置了“自动开始”选项，当您下一次打开这个对话框时，这个估计操作将被自动初始化，不需要使用“估计”按钮。

当然，完成了扫描操作后，也可以转换到这个对话框的其它页，设置压缩文件的不同选项，象注释、恢复记录、自解压模块等。它允许对所有的被选择的文件和文件夹中的 RAR 和 ZIP 压缩文件应用必要的改变。不象扫描步骤，自解压文件也在这里处理。小心这个操作，它可能立刻改变成百上千的压缩文件的参数。这个功能是强大的，但是如果使用不正确，可能变得更危险

在压缩文件管理模式，不管您在压缩文件内部还是外部，当您激活“显示信息”，但是当只有一个压缩文件被选择时， WinRAR 将显示关于压缩文件的下列信息：

  • 压缩文件名(在对话框标题);
  • 压缩文件类型 (固实、自解压 、 卷) 和格式 (RAR、ZIP、CAB 、ARJ、LZH 等 )。全部的这些参数将会组合成单个字符串，显示于对话框的顶端 ;

由 WinRAR 3.40 或更高版本创建的 RAR 卷此字符也包含一个卷号。此号码可能在原始卷名丢失，而您需要手动纠正文件名时有用;

  • 解压缩时需要的最小压缩程序版本号。对于有些压缩文件格式，例如 ZIPX，此字段可能还包括一个压缩算法的名称;
  • 压缩文件创建时所用的操作系统;
  • 文件夹和文件的总数;
  • 打包和打包后的总计长度;
  • 总压缩率;
  • 自解压 模块的大小，或 0 表示非自解压文件;
  • 压缩文件注释是否存在;
  • 是否为 被加密的 文件;
  • 如果压缩文件被 锁定;
  • 如果有使用 恢复记录，在最优状态下能够修复的最大连续损坏区大小;
  • 压缩文件中任何文件所使用的最大 字典大小 ;

如果有压缩文件注释，将会显示一个包含此注释的附加对话框页。

象在文件管理模式中，可以转换到对话框的其它页，指定当前压缩文件的不同参数。只需按下页面中的“帮助”按钮读取关于它们的更多信息。


“生成报告”命令

此命令在 WinRAR 的文件和压缩文件 管理模式 都可用。

在压缩文件管理模式，此命创建一个包含当前打开的压缩文件中文件的完整列表的报告。文件选择被忽略。

在文件管理模式，只是关于选择条目的报告。根据命令参数，报告可以包含普通文件和选择条目中找到的压缩文件的内容。如果您选择了一个文件夹， WinRAR 会它的和它的子目录的文件。

可以使用下列参数修改报告风格。

把报告保存为文件

这里您可以输入一个报告要保存的文件名。如果您不需要保存报告文件，它允许被保留为空白。

报告输出到打印机

如果您要打印报告，则设置此选项。

复制报告到剪贴板

如果您要复制报告到剪贴板，则设置此选项。这会占用一定数量的内存来在剪贴板上存储数据，所以如果您要产生一个许多兆大小的报告时要注意。它会占用很多的内存而降低操作速度。

输出格式(HTML, Unicode 文本, 文本)

选择输出报告文件的格式。HTML 和 Unicode 文本 格式支持 Unicode所以在文件和压缩文件名中的非英语字符会正确显示。文本 格式是非 Unicode 兼容，可能损坏非英语字符。

文件排序按 (原始顺序、名称、大小、压缩后大小、修改时间、校验和)

这里您可以选择排序的模式或设置为 原始顺序 跳过排序。

压缩文件单独排序

如果启用此选项，每个包含到报告中的压缩文件内容会和其他压缩文件和文件分开，单独排序，所以所有相同的压缩文件的所有文件会被放到同一个组。否则包含到报告中的所有文件会忽略压缩文件的界限，作为一个整体的流来排序。 此操作和原始排序模式没有任何不同。

报告包含/压缩文件

此选项只有在文件管理模式下可用。如果启用它， WinRAR 分析所有文件，如果找到压缩文件，它就会被包含到报告中。如果您要获得您的磁盘上普通文件的列表而不在乎压缩文件的内容，那么就禁用此选项，提高操作速度。

报告包含/普通文件

此选项只在文件管理模式中可用。如果启用， WinRAR 会把普通文件包括到报告中。如果您需要报告只包含压缩文件，您应该禁用此选项。

报告包含/压缩文件名

如果启用，报告会在每一组连续的文件前加上它们所在压缩文件的名字。在某些特定条件下，您也许希望禁用此选项，例如，如果您需要把报告传递给外部程序。

报告包含/报头与总计

如果启用，会将报告列的标题添加到报告的顶部，而有关已处理文件的统计信息将包含在底部。

由于某些报告列的宽度会取决于文件和归档有所不同，因此标题可能未与列对齐。不过它们仍然正确定义了列序。

报告末尾的最终统计信息包含有关文件总数和大小的信息。如果“普通文件”选项被启用，只有普通文件会被加到总计信息中，否则只会有压缩文件在这里出现。不能把普通文件和压缩文件一起计算。对于被卷分开的文件，总计信息只计算它们中从当前卷开始的文件。当处理一组卷时，这样做可以避免分开的文件被计算数次。

报告包含/文件大小

把未压缩的文件大小包含到报告中。

报告包含/压缩后大小

把压缩文件大小包含到报告中。普通文件大小可能不等于未压缩文件的大小，只有在 NTFS 磁盘上，只有在如果文件有“压缩”属性。

报告包含/文件日期

把文件修改日期包含到报告中。日期的格式总是 YYYY-MM-DD hh:mm，它不依赖于系统设置。

报告包含/文件校验和

把文件校验和包含到报告中。此选项在压缩文件和普通文件模式下都可用。用于存档文件的校验和的类型依赖于压缩文件的格式和选项，对于普通文件是 CRC32。对普通文件启用它，会明显减慢操作速度，因为 WinRAR 需要对每个处理的文件读取文件数据计算 CRC32 。所以此选项对已存档的文件不会不引入任何额外的延迟。

“保存”按钮

您可以使用“保存”按钮来存储除了报告文件名外所有对话框选项为默认值。 WinRAR 为此命令保存两套默认值，一个为压缩文件管理模式，另一个为文件管理模式。


“性能测试”命令

使用“性能测试”命令，允许比较在不同的计算机上 RAR 压缩算法的运行表现。

这个命令产生随机数据，包含特定的冗余，不断给处理器和内存加载。然后数据经过 RAR 的压缩和解压缩算法处理，并且对解压的数据和源数据进行比较。如果发现任何的不同， WinRAR 会在命令窗口中报告“发现错误 - 是”。这些错误可能表示类似与不可靠内存的硬件问题。WinRAR 也会显示处理了的数据的大小和压缩速度，当前的和已处理的 KB/s。您可以使用已处理的速度来比较在不同条件下 RAR 的表现。例如，当您需要选择一台新计算机并希望知道哪台计算机将更快地压缩数据时，“基准测试”命令可能会有所帮助。调用具有32 MB字典的“普通”模式下的常规压缩算法，禁用其他过滤器和算法。

使用“多线程”选项，您可以比较常规单线程和多线程（为多处理器系统优化）版本的 RAR 压缩算法的性能。

要花上一断时间来填充压缩字典，它开始的时候是空的。在完成之前，速度值不一致，因此命令窗口在激活后仅几秒钟就开始显示当前速度。当收集的统计数据足以获得准确的结果时，将显示结果速度。设置最终速度后，将不再对其进行更多变更。 虽然源数据是随机的，它们的冗余等级和其他参数总是相同。所以，只要系统负载不变，此命令将报告几乎相同的当前速度，而与执行时间无关。

不能保证不同版本的 WinRAR 会报告相同的压缩速度值，所以您要使用此命令比较不同计算机的性能，首先确认您在所有测试中使用着同样的 WinRAR 版本。同时建议在开始测试前关闭其他应用程序。

“性能测试”命令永远不会自动结束，您需要手动取消它。它不使用硬盘，所有操作都在内存中执行。


文件菜单

命令 | 快捷键 | 功能
打开压缩文件 | Ctrl+O | 打开指定的压缩文件。您也可以读取关于 其它方式 来打开压缩文件
压缩文件另存为.. |  | 保存在 WinRAR 打开的压缩文件的副本到另一文件夹。
更改驱动器 | Ctrl+D | 改变当前的驱动器
设置默认密码 | Ctrl+P | 设置默认 密码。密码会被要求输入两次以确认。此密码将会用于全部的压缩和解压操作
复制文件到剪贴板 | Ctrl+C | 复制选择的被压缩的或普通的文件到剪贴板上。例如，您可以选择压缩文件中的一些文件，按下 Ctrl+C，在资源管理其中打开打开文件夹并按下 Ctrl+V 来解压选择的文件到那个文件夹。您可以在文本编辑器里按下 Ctrl+V 只粘贴文件名，而不是文件内容。
从剪贴板粘帖文件 | Ctrl+V | 粘贴文件到 WinRAR 开始压缩操作，所以您可以在资源管理其中选择文件并把它们粘贴到 WinRAR 中来压缩它们。
全选 | Ctrl+A | 选择 全部的文件和文件夹
选择组 | NUM + | 选择 与输入的过滤掩码匹配的全部的文件和文件夹
取消选择组 | NUM - | 取消选择 与输入的过滤掩码匹配的全部的文件和文件夹
反选 | NUM * | 反选 全部的文件和文件夹
退出 | Alt+F4, Ctrl+W | 退出 WinRAR

根据 常规设置 对话框“保存压缩历史”选项，一些最近打开的压缩文件名会保留在“退出”命令下。您可以在 WinRAR 使用它们快速的打开这些压缩文件。


命令菜单

功能 | 快捷键
添加文件到压缩文件中 | Alt+A
解压到指定文件夹 | Alt+E
测试已压缩文件 | Alt+T
查看文件 | Alt+V
删除文件 | Del, Shift-Del
重命名文件 | F2
打印文件 | Ctrl+I
不确认直接解压 | Alt+W
添加压缩文件注释 | Alt+M
保护压缩文件防止损坏 | Alt+P
锁定压缩文件 | Alt+L


工具菜单

功能 | 快捷方式
向导 |
扫描压缩文件内病毒 | Alt+D
转换压缩文件格式 | Alt+Q
修复压缩文件 | Alt+R
转换为自解压格式 | Alt+X
查找文件 | F3
显示信息 | Alt+I
生成报告 | Alt+G
性能测试 | Alt+B


收藏夹菜单

收藏菜单包含了您最常用的文件夹和压缩文件列表。您可以使用“添加到收藏夹”命令来添加当前打开的压缩文件或文件夹到列表中，也可用 Ctrl+F 的键盘快捷键。描述是可选的，如果这些描述可用， WinRAR 将在“收藏夹”菜单中显示描述，而不是压缩文件名。

如果您从列表中选择了压缩文件或是文件夹，它将会被打开于 WinRAR。注意，您可以快速的打开收藏夹的第一个项目，而不需要打开菜单，您只需按下 Ctrl+1 ... Ctrl+0 按键。Ctrl+1 会打开收藏夹第一个项目标压缩文件，Ctrl+2 - 第二个 ... Ctrl+9 - 第九个， Ctrl+0 - 第十个。

“管理收藏夹”命令则允许您编辑/删除收藏夹的项目，也可以将它们从列表中向上或向下移动。选择希望的项目，并单击这些操作同等的任何一个按钮即可。要删除一个收藏夹除了单击“删除”按钮外，您还可以使用 Del 按键。


选项菜单

在菜单的“设置...”会启动一个对话框，包含了下列的 WinRAR 设置: 常规、 压缩、路径、 文件列表、查看器 、 安全 和 综合。请选择任何的主题来获得详细的内容。而“设置...”命令的键盘快捷键是 Ctrl+S。

您可以导出 WinRAR 设置到一个文件，并在以后使用“导入和导出”子菜单的两个命令导入它们。该文件名为“Settings.reg”，并放在 %APPDATA%\WinRAR 文件夹。如果您重新安装 Windows 或必须移动 WinRAR 到别的计算机时，从文件还原设置值可减少配置 WinRAR 所需的时间。如果 WinRAR 在注册表找不到设置值，且 Settings.reg 文件存在 WinRAR 文件夹或 %APPDATA%\WinRAR 文件夹内，它将被自动导入。为了应用某些导入的设置，可能需要重启 WinRAR。如果 WinRAR.ini 文件 应于保存设置，则这些命令不可用。

在“导入和导出”子菜单里的“创建 WinRAR.ini 文件”命令会创建一个新的 WinRAR.ini 文件 并从注册表复制现有的 WinRAR 设置到此文件。

“文件列表”子菜单包含两组选项。当所有压缩文件和文件加被显示在同一列表下时，“平面文件夹查看”命令 (键盘热键Ctrl+H)参数在经典的树状目录查看和平面查看间切换。它只能用在 压缩文件管理模式 。其它选项组是“列表查看”和“详细资料”项目，它们控制文仅列表的显示。“列表查看” 在多行模式列表和只显示文件名间切换，同时启用“详细资料”可以查看提供的文件大小和更多得其他信息。

“文件夹树”子菜单允许关闭或打开文件夹树面板。您可以为 文件管理(“显示磁盘文件夹”菜单项目)和 压缩文件管理 (“显示压缩文件目录”项目) 模式单独配置它。其它的改变文件夹面板的状态的方法是 Ctrl+T 键盘快捷键。如果您需要在磁盘中或压缩文件中快速导航时目录树很方便。您可以用鼠标拖动它的右边改变文件夹树的宽度。

“主题”子菜单包含可用的 WinRAR 界面主题 列表，“管理主题” 命令提供主题管理功能和“获得更多主题”命令来加载主题网页。

"名称编码" 子菜单 允许指定压缩文件名称的编码。

此菜单的另一个命令是“查看日志”。在 内部查看器 中，它会打开存在于 %APPDATA%\WinRAR 文件夹 下的 rar.log 的内容。请注意，您必须在 常规设置 对话框中将“将错误记录到日志”切换成打开状态，才能强制 WinRAR 写入错误到日志中。使用“清除日志”菜单命令可以清除日志的内容。日志仅对注册版才有效。


帮助菜单

选择“帮助主题”命令可以查看 WinRAR 帮助文件的内容。

使用“WinRAR 主页”项目则连接到 WinRAR 主页，在此您可以下载最新版本的 WinRAR 和在线注册您的共享软件 WinRAR 副本。

“关于 WinRAR...”命令则会显示包含版本和版权信息的对话框。


如何从 Windows 界面打开压缩文件

如果您在安装 WinRAR 时，没有将选项“将压缩文件关联到 WinRAR”关闭的话，要从资源管理器或者桌面打开压缩文件给 WinRAR很容易。只需要在压缩文件图标上双击就可以了。

在安装之后，您也可以使用 综合设置对话框 来将压缩文件关联到 WinRAR。


使用关联菜单

如果您在安装 WinRAR 时，没有将选项“把 WinRAR 集成到资源管理器中中”关闭的话，有数个附加的项目会附加到标准文件和文件夹的关联菜单中，它会在您在资源管理器或者桌面以鼠标右键单击文件图标的时候出现。

对于压缩文件，WinRAR 显示的项目是:“解压文件”和“解压到 <文件夹名>”，而 <文件夹名> 会以文件夹的实际名称替换。这两种命令都会调用 WinRAR 来解压压缩文件内容，但是第一个命令允许您输入目标文件夹以及一些在 解压路径和选项对话框 解压时的选项。而第二个则运行解压到当前文件夹，而没有附加的问题提示。当您解压一组压缩文件时，关联菜单也将会包含“解压压缩文件到单独文件夹”的项目，允许把每个压缩文件的内容放到单独的文件夹中。

WinRAR 也可以修改要显示的压缩文件信息“属性”项目，如果 压缩文件注释 存在的话，通过 显示信息 命令，也可以显示和类似的压缩文件信息。

对于常规的文件和文件夹，WinRAR 添加的项目是: “添加到压缩文件”和“添加到压缩文件 <压缩文件名>”，“压缩并 E-mail_”，“压缩到<压缩文件名 > 并 E-mail”，在此 <压缩文件名> 会以压缩文件的真实名称来替换。这两种命令都会调用 WinRAR 来添加选定的文件到压缩文件，但是第一个命令允许您输入压缩文件名和一些在 压缩文件名和参数 对话框的压缩选项，而第二个则开始添加到现行的压缩文件中，而没有附加的问题提示。类似的，“Email”命令压缩选择的文件并把它附加到一个 E-mail 邮件中，但是第一个允许设置附加的选项。您使用这个参数需要有兼容 MAPI 的 E-mail 客户端 (大部分现代的 E-mail 程序都支持 MAPI 接口)。


拖动文件的支持

WinRAR 支持 Windows 便利的拖动操作。

如果在 文件管理模式 时，拖动单个压缩文件到 WinRAR 中，压缩文件的内容将会被显示，且 WinRAR 将会进入 压缩文件管理模式。

如果，在文件管理模式，一个或是多个的非压缩文件拖动到了 WinRAR 中，WinRAR 将会提示输入压缩文件名，并添加这些文件到压缩文件中。

如果，在压缩文件管理模式，任何的文件被拖动到了 WinRAR 的工具栏或地址栏中，拖动的压缩文件的内容会显示。如果您希望添加一个或更多的文件到当前浏览的压缩文件中，则把它们拖到 WinRAR 的文件列表中。然而，如果此文件不是压缩文件，则把它们拖到工具栏或地址栏和把它们拖到文件列表的效果是一样的。拖动的文件只对于是 RAR 和 ZIP 压缩文件时才有效。

不论当前的 WinRAR 模式和压缩文件格式是怎样，您都可以从 WinRAR 拖动文件到其它的程序。

如果您在安装 WinRAR 时没有关闭“把 WinRAR 集成到资源管理器中”的选项，您可以在桌面拖动文件到 RAR 或 ZIP 图标中，来添加文件到压缩文件中。如果您使用鼠标右键并将之拖动到目标文件夹时也一样，您可选择在菜单出现的“解压到此处”，来从拖动的压缩文件解压全部的文件到目标文件夹。 如果您用鼠标右键拖拽一个未压缩的文件或几个文件并释放到目标文件夹，您可以在上下文菜单里使用“添加到压缩文件”和“添加到<压缩文件名称>”命令，来在目标文件夹里创建包含这些文件的一个压缩文件。


命令行语法

从命令行也可以运行 WinRAR 命令，常规的命令行语法描述如下:

WinRAR <命令> -<参数1> -<参数N> <压缩文件 > <文件...> <@列表文件...> <解压路径\>

命令 | 指定 WinRAR 运行的命令的字符组合。点击 这里 查看 WinRAR 的命令列表。
参数 | 切换操作指定类型，压缩强度，压缩文件类型，等等的定义。点击 这里 查看 WinRAR 的参数列表。
压缩文件 | 要处理的压缩文件名。
文件 | 要处理的文件名。
列表文件 | 列表文件是包含要处理文件名称的纯文本。文件名应该在第一卷启动。可以在列表文件中使用 //字符后添加注释。例如，您可以包含两列字符串创建 backup.lst: c:\work\doc\*.txt //备份文本文档 c:\work\image\*.bmp //备份图片 c:\work\misc 并接着运行: winrar a backup @backup.lst 您可以在命令行中同时指定普通的文件名和列表文件名。
解压路径 | 只与命令 e 和 x ，搭配使用。指出解压文件添加的位置。如果文件夹不存在时，会自动创建。

注意事项

a) 如果未指定 文件 或是 列表文件 时，WinRAR 将会以缺省的 *.* 运行全部的文件;

b) 如果在创建压缩文件时未指定压缩文件扩展名，WinRAR 将会使用在 压缩配置 中选定的默认压缩文件格式。但您可以指定 .RAR 或 .ZIP 扩展名来替换它们。

如果解压时未指定压缩文件扩展名，WinRAR 会认为是 .rar，所以 * 意味着所有 .rar 扩展名的所有文件。如果您需要处理所有没有扩展名的压缩文件，请使 *. 掩码。*.* 掩码选择所有文件。您可以在大部分的操作中在压缩文件名中使用通配符，例如解压、测试和许多其它操作中，但在压缩和删除时不能使用通配符。

c) 在命令行所输入的参数会替换相同的配置设置值 ;

d) 在命令 c 、e、s、t、rr、k 和 x 可在压缩文件名中使用通配符。如此可以用单个的命令来进行超过一个以上的压缩文件，除此之外，如果您指定 -r 参数于这些命令时，它们将会搜索在子文件夹中的压缩文件 ;

e) 某些命令和参数只应用在 RAR 压缩文件，有些则在 RAR 和 ZIP 都可使用，而某些则可应用在全部的压缩文件格式。这一些都得看压缩文件格式所提供的特性而定 ;

f) 命令和参数的大小写是相同意思的，您可以用大写或者小写来下命令均可。

g) 如果命令行的任何部分包含空格，请用引号括起来。

例子

  1. 添加文件夹 "c:\latest data" 到压缩文件 Info.rar 中

WinRAR a Info.rar "c:\latest data"

  2. 解压压缩文件 Info.rar 到文件夹 d:\data

WinRAR x Info.rar d:\data\


字母命令列表

a | 添加文件到压缩文件
c | 添加压缩文件注释
ch | 改变压缩文件参数
cv | 转换压缩文件
cw | 写入一个压缩文件注释到文件
d | 从压缩文件删除文件
e | 从压缩文件解压压缩，忽略路径
f | 刷新压缩文件中的文件
i | 在压缩文件中查找字符串
k | 锁定压缩文件
m | 移动文件和文件夹到压缩文件
r | 修复受损的压缩文件
rc | 重建丢失的卷
rn | 重命名压缩文件
rr[N] | 添加数据恢复记录
rv[N] | 创建恢复卷
s[name] | 转换压缩文件成为自解压文件类型
s- | 删除自解压模块
t | 测试压缩文件
u | 从压缩文件中更新文件
x | 以完整路径名称从压缩文件解压压缩


命令 A - 添加文件到压缩文件

添加指定的文件和文件夹到压缩文件中。此命令行等同于 添加。

注意: 因为分卷压缩文件修改是禁用的，此命令无法应用来更新分卷压缩文件，只用于创建时。

例子:

  1. 从当前文件夹添加全部 *.hlp 文件到压缩文件 help.rar 中

WinRAR a help *.hlp

  2. 从当前文件夹和子文件夹压缩全部文件成为 362000 字节大小、固实的、分卷自解压文件 save.part1.exe,save.part2.rar,save.part3.rar 等，并在每一个分卷中添加恢复记录

WinRAR a -r -v362 -s -sfx -rr save

因为未指定文件名，全部文件 (*) 将会被添加。

  3. 作为一个特别的例外，如果目录名被作为参数指定并且目录名不包含文件掩码和以反斜线结尾，即使没有指定 参数 -r ，目录和子目录的所有内容都会被添加到压缩文件中。

下面的命令将会把文件夹 Bitmaps 中全部的文件添加到 RAR 压缩文件 Pictures 中:

WinRAR a Pictures.rar Bitmaps

  4. 如果文件夹名包含文件掩码或以反斜线结尾，应用普通规则，您需要指定 参数 -r 处理它的子文件夹。

下面的命令将会把文件夹 Bitmaps 中除了子文件夹外全部的文件添加，因为没有指定参数 -r:

WinRAR a Pictures.rar Bitmaps\*


命令 C - 添加压缩文件注释

此命令允许在压缩文件中添加 注释。RAR 压缩文件的最大注释长度是 256 KB，而 ZIP 压缩文件则为 32768 字节。添加压缩文件注释也可以通过使用 压缩文件管理 命令 添加压缩文件注释。

因为分卷压缩文件修改是禁用的，所以注释无法应用在分卷压缩。当创建分卷压缩时，您可以使用参数 -z<文件> 来添加注释到分卷压缩。

例子:

a) 添加注释到压缩文件 distrib.rar

WinRAR c distrib.rar

b) 从文件添加注释可以使用 -z< 文件> 参数。

WinRAR c -zinfo.txt dummy


命令 CH - 改变压缩文件参数

此命令能和大多数压缩文件变量参数一起使用修改压缩文件参数。对于象 -cl, -cu, -tl, 等没有专门命令的参数特别方便。

它不能重新压缩、解密或加密压缩文件数据，它不能整合或创建卷。如果不和其它参数一起使用， 'ch' 命令仅复制压缩文件数据而不修改它。

例子:

设置压缩文件时间为最新的文件

WinRAR ch -tl files.rar


命令 CV - 转换压缩文件

此命令提供命令行界面的 WinRAR 转换压缩文件格式。您可以让它和参数 -y 组合跳过“转换压缩文件”对话框并使用默认参数开始操作。使用在“转换压缩文件”的“保存”按钮来改变默认参数。

例子:

使用默认转换参数转换 c:\files 中所有的 ZIP 压缩文件

WinRAR cv -y c:\files\*.zip


命令 CW - 写压缩文件注释到指定文件

此命令允许保存一个压缩文件的 注释 到文件。输出文件的格式依赖于-sc 参数。

例子:

a) 存储压缩文件 arc 的注释到 ASCII 文件 comment.txt

WinRAR cw arc comment.txt

b) 存储压缩文件 arc 的注释到Unicode文件 unicode.txt

WinRAR cw -scuc arc unicode.txt


命令 D - 从压缩文件删除文件

从压缩文件删除指定的文件和文件夹。此命令行命令相当于 压缩文件管理 命令 删除。

注意:

1) 如果从压缩文件删除全部的文件时，空白的压缩文件将会被删除。

2) 因为分卷压缩文件修改是禁用的，此命令无法应用于分卷压缩。

例子:

从压缩文件 dummy 删除全部的 *.dmy 文件

WinRAR d dummy *.dmy


命令 E - 从压缩文件解压压缩，忽略路径

忽略路径解压压缩的文件到当前或指定的文件夹。此命令行对应的是 压缩文件管理 命令 解压到指定文件夹 并在 解压路径和选项对话框 “不解压路径”的选项是启用时。

例子:

在当前文件夹，从全部的 RAR 压缩文件解压所有的 *.doc 文件到当前文件夹

WinRAR e *.rar *.doc


命令 F - 整理压缩文件内的文件

只有在压缩文件中的文件比添加的还旧时才更新。此命令不会把新文件添加到压缩文件中。命令行等同于 添加到压缩文件 并且在 压缩文件名和参数对话框 选择了“只刷新已存在的文件”的更新模式。

因为分卷压缩文件修改是禁用的，所以此命令无法应用在分卷压缩。

另请参阅: 命令 A - 添加文件到压缩文件


命令 I[i|c|h|t]=<字符串> - 在压缩文件中查找字符串

在压缩文件中查找字符串。支持下列参数:

i 不区分大小写查找(默认);

c 区分大小写查找;

h 十六进制查找;

t 使用 ANSI, UTF-8, UTF-16 和 OEM 字符表;

如果没有指定参数，它可以使用简单的命令行语法 i<字符串> 代替 i=<字符串>

它还允许和其他参数一起指定‘t’变量，例如，ict=字符串，使用上述所有字符表执行区分大小写的查找。

例子:

  1. 在磁盘 C: 中的 *.RAR 压缩文件中的 *.txt 文件中执行区分大小写搜索 "first level" 字符串。

WinRAR "ic=first level" -r c:\*.rar *.txt

  2. 在 e:\text 目录下的 RAR 压缩文件中查找十六进制字符串 f0 e0 ae ae ab 2d 83 e3 a9 。

WinRAR ih=f0e0aeaeab2d83e3a9 -r e:\texts\*.rar


命令 K - 锁定归档

命令 K - 锁定压缩文件

WinRAR 无法修改锁定的归档，因此锁定重要的归档可以防止 WinRAR 意外修改它们。 如果 WinRAR 命令分组处理归档，这种保护可能特别有用。

该命令不旨在或不能阻止其他工具或第三方有意进行修改。它仅针对 WinRAR 引起 的意外数据变更实行安全措施。

在 WinRAR Shell 模式下使用“锁定归档”命令，或在命令行中使用 命令“K”来锁定归档。

示例

WinRAR k release


命令 M - 移动文件和文件夹到压缩文件

类似 命令 a ，但在压缩操作成功完成后，文件和文件夹将会被清除。此命令行等同于 添加到压缩文件 并且在 压缩文件名和参数对话框 中启用“压缩之后删除”选项。

因为分卷压缩文件修改是禁用的，所以此命令无法应用在更新分卷压缩，只能创建。


命令 R - 修复受损的压缩文件

修复压缩文件。压缩文件修复是在两阶段中完成的。首先，在损坏的压缩文件中查找恢复记录(参照 rr 命令)。如果压缩文件包含以前添加的恢复记录，并且如果损坏的数据恢复区域是连续并且小于恢复记录的纠错码大小，则重建压缩文件成功的几率很高。当这个阶段完成，一个名为 fixed.arcname.rar 的新压缩文件会被创建，'arcname' 的位置是原始的(损坏的)压缩文件名。

如果损坏的压缩文件不包含恢复记录，或是如果压缩文件由于严重的损坏，而不能够完全恢复时，第二阶段开始。在此阶段期间，仅有压缩文件结构的重建，而要恢复校验和验证失败的文件是不可能的，但是它尽可能的从损坏的压缩文件架构中，可访问的部位来恢复未损坏的文件。通常这对固实的压缩文件是有用的，在损坏的固实压缩文件，通常仅第一个文件可能在第二个阶段期间被恢复的。此阶段不能修复加密文件名的压缩文件，这样的文件只有存在恢复记录时才能修复。

当此阶段完成，重建结构的压缩文件被保存为 rebuilt.arcname.rar, 'arcname' 的位置是原始压缩文件名。

默认情况下,修复的压缩文件创建到当前目录中，但是您可以添加一个可选的 destpath\ 参数指定其他目标目录。

此命令行等同于 文件管理 命令修复压缩文件。

例子:

修复 buggy.rar 并把结果放到 'c:\fixed' 目录中。

WinRAR r buggy.rar c:\fixed\


命令 RC - 重建丢失的卷

使用 恢复卷(.rev 文件)重建丢失的卷。您需要指定任何存在的卷作为压缩文件名，例如：

WinRAR rc backup.part03.rar

您可以在 这里 读到更多关于恢复卷的信息。


命令 RN - 重命名压缩文件

重命名压缩文件。这个命令只支持 RAR 压缩文件格式。命令语法是:

winrar rn <压缩文件名> <源文件名1> <目标文件名 1> <源文件名N> < 目标文件名N>

例如，下列命令:

WinRAR rn data.rar readme.txt readme.bak info.txt info.bak

在压缩文件 data.rar 中将把 readme.txt 重命名为 readme.bak 并把 info.txt 重命名为 info.bak。

在源文件和目标文件名中可以使用统配符来进行简单像改变文件扩展名的名称转换。例如 :

WinRAR rn data.rar *.txt *.bak

将把所有的 *.txt 文件重命名为 *.bak。

WinRAR 不检查目标文件名是否已经在压缩文件中存在，所以您需要小心，防止重名。尤其是使用统配符时特别重要。这个命令有潜在的危险，因为一个错误的统配符可以损坏所有的压缩文件名。


命令 RR[N] - 添加数据恢复记录

可选，冗余信息 (恢复记录) 可以被添加到压缩文件中。在增大压缩文件大小的同时，它能在磁盘错误或其它数据损坏的情况下帮助恢复存档的文件，只要损坏不是太严重。可以使用命令 "r"(repair) 处理这种损坏。

RAR 4.x 和 RAR 5.0 压缩文件使用不同的恢复记录结构和算法。

RAR 4.x 恢复记录基于 XOR 算法。您可以用恢复区块数或压缩文件大小的百分比来指定 4.x 恢复记录的大小。只是将指定区块数直接添加 “rr”后，如“rr1000”指定 1000 个区块。要使用百分比则可以在百分数后附加“p”或“%”后缀，如“rr5p”或“rr5%”表示 5%。注意，如果您从 Windows 的 .bat 或 .cmd 文件运行这个命令时，您需要使用“rr5%%”代替“rr5%”，因为批处理命令把符号'%'作为批处理文件开始的参数。在这种情况下您可以使用‘p’ 代替‘%’更方便。

RAR 4.x 恢复区块有 512 字节长，如果损坏的区域是连续的，每个分区可以帮助恢复 512 字节的损坏信息。在多重损坏的情况下，此值肯能会 低。最大的恢复区块数是 524288。

4.x 恢复记录的大小可以使用公式<压缩文件大小>/256 + <恢复记录数>*512字节 估计。

RAR 5.0 恢复记录使用 Reed-Solomon 纠错码。其修复连续损坏的能力和 RAR 4.x 一样,允许恢复数据略少于恢复记录大小。但它在有多重损坏区域时比 RAR 4.x 记录更有效。

RAR 5.0 恢复记录不使用 512 字节区块，您仅可以用压缩文件大小的百分比来指定它的大小。不管‘%’或‘p’后缀是否存在，RAR 5.0 格式中，RAR 都会把值作为百分比对待。所以‘rr5’和‘rr5p’都是 5% 的意思。由于服务数据开销实际产生的恢复记录大小只是大约匹配用户定义的百分比，对于小压缩文件差距比较大。

RAR 5.0 恢复记录的大小不能超过被保护的压缩文件的大小，所以您不能使用大约 100% 的值作为参数。越大的恢复记录在创建和修复时的处理都会越慢。

如果压缩文件数据损坏位置的位置没有偏移，4.x 和 5.0 的记录都很有效。如果您使用某些特殊的软件从损坏的媒介复制一个压缩文件，并有用零填补受损区域或从复制文件中切除受损区域的选择，最好选择用零或任何其他值填充，因为它可以保存原始数据的位置。不过，尽管不是最优的模式，两个版本的恢复记录都能试图修复被删除或插入合理大小,数据位置移动的数据。RAR 5.0 恢复记录处理删除和插入的情况比 RAR 4.x 更有效。

如果您不带任何可选参数使用‘rr’命令，WinRAR 默认会把恢复记录的大小设为压缩文件大小的 3%。

此命令行等同于 压缩文件管理 命令 保护压缩文件防止损坏。

例子:

  1. 添加默认大小(3%)的数据恢复记录到该压缩文件 backup

WinRAR rr backup

  2. 添加数据恢复记录到压缩文件 pictures 并设置它的大小为压缩文件总大小的 5%

WinRAR rr5p pictures


命令 RV[N] - 创建恢复卷

创建恢复卷(.rev文件)，以后它可以在卷组中重建丢失的文件。

这个命令只对 RAR 多卷压缩文件有效，您需要在组中指定第一卷的名字作为压缩文件名。例如:

WinRAR rv3 data.part01.rar

选项 <N> 参数指定创建恢复卷的数目，它必须少于 RAR 卷的总数。您也可以附加一个百分号到这个参数上，这样创建的 .rev 文件的数目将等于从 RAR 卷总数获得的这个百分比。 例如:

WinRAR rv15% data.part01.rar

您可以在 这里 读到更多关于恢复卷的信息。


命令 S[名称] - 转换压缩文件成自解压

这个命令会创建一个自解压文件 (SFX) 当运行时会解压包含在里面的文件。

您也可以制作自解压当成多片的分卷压缩第一个序列，但必须注意一点，因为自解压模块的数量而会使文件大小较大些。自解压分卷的创建可使用命令 a 并加上参数 : -v<大小> -sfx，然后您不需要确认分卷的大小 - 第一个分卷会自动的以正确的大小来创建。

这个命令行等同于 压缩文件管理 命令 把压缩文件转换成自解压格式。

例子:

WinRAR s diamant

默认 WinRAR 使用在 RAR 压缩文件的自解压模块文件为 default.sfx，它必须与winrar.exe 存在于相同的文件夹中以及，对于 ZIP 压缩文件则使用 zip.sfx 模块。也可以在“s”命令中，指定交替的自解压模块名。

例如，要添加控制台自解压模块 WinCon.sfx 则运行 :

WinRAR sWinCon.sfx myinst


命令 S- - 删除自解压模块

这个命令会从已存在的 自解压文件 (SFX) 删除自解压模块。

WinRAR 会创建新的不含自解压模块的压缩文件，原有的自解压文件不会删除。

例子:

WinRAR s- rarsetup.exe


命令 T - 测试已压缩文件

为了验证指定的文件，这个命令会运行虚拟文件解压，但不会写入输出数据流。这个命令行等同于 压缩文件管理 命令 测试文件。

例子:

测试全部在磁盘上的 *.rar 压缩文件

WinRAR t -r \*.rar


命令 U - 更新压缩文件内文件

这个命令，就好象 命令 f 一样。仅在如果压缩文件中的文件比被添加的还旧时才更新，但不像“f”的地方是，它只会添加新的文件。

这个命令行等同于 添加到压缩文件 并在 压缩文件名和参数对话框 中选择“添加和更新文件”的更新模式。

因为分卷压缩文件修改是禁用的，所以这个命令无法应用在分卷压缩。

另请参阅: 命令 A - 添加文件到压缩文件中


命令 X - 以完整路径名称从压缩文件解压压缩

以完整路径解压文件和文件夹。保存在压缩文件中的文件夹架构，将会完整的还原恢复。此命令行等同于 压缩文件管理 命令 解压

类似的方法有 命令 e，此命令可以解压文件到当前文件夹或者指定的文件夹。

例如，命令:

WinRAR x Fonts *.ttf

会从压缩文件解压 *.ttf 字体文件到当前文件夹，但下面命令:

WinRAR x Fonts *.ttf NewFonts\

会从压缩文件解压 *.ttf 字体文件到文件夹 NewFonts

在上面的例子，您必须使用附加的倒斜线来表示目标文件夹。


字母参数列表

-- | 停止参数扫描
-@[+] | 禁用 [启用] 文件列表
-ac | 在压缩或解压后清除存档属性
-ad[1,2] | 备选目标路径
-af<类型> | 指定压缩文件格式
-ag[格式] | 以当前日期生成压缩文件名
-ai | 忽略文件属性
-ao | 添加有存档属性设置的
-ap<路径> | 设置内部压缩文件路径
-as | 同步化压缩文件内容
-cfg- | 忽略默认配置和环境变量
-cl | 将文件名转换成为小写
-cp<名称> | 选择一个压缩配置文件
-cu | 将文件名转换成为大写
-df | 压缩后删除压缩文件
-dh | 打开共享的文件
-dr | 删除文件到回收站
-ds | 不排序压缩的文件
-dw | 压缩后清除文件
-ed | 不添加空文件夹
-en | 不添加“压缩文件结束”块
-ep | 从名称中排除路径
-ep1 | 从名称中排除主文件夹
-ep2 | 扩大成完整路径
-ep3 | 扩展包含盘符的完整路径
-e[+]<属性> | 设置文件排除和包含属性
-f | 刷新文件
-hp[密码] | 加密文件数据和头
-ht[b|c] | 选择文件校验和的哈希类型 [BLAKE2,CRC32]
-iadm | 对于自解压压缩文件请求管理员访问权限
-ibck | 在后台运行 WinRAR
-idv | 显示详细输出
-ieml[.][地址] | 使用E-mail发送压缩文件
-iicon<名称> | 指定自解压图标
-iimg<名称> | 指定自解压图片
-ilog[名称] | 记录错误到文件中
-imon<number> | 选择一个显示屏
-inul | 关闭错误信息
-ioff[n] | 关闭 PC 电源
-isnd[-] | 控制通知的声音
-k | 锁定压缩文件
-kb | 保留坏掉的解压文件
-log[格式][=文件名] | 写入名称到日志文件
-m<n> | 设置压缩方式
-ma[4|5] | 指定压缩格式的版本
-mc<参数> | 设置高级压缩参数
-md<n> | 选择字典大小
-me[par] | 设置加密参数
-ms[列表] | 指定文件存储
-mt<参数 > | 设置线程数
-n<文件> | 附加过滤器包含文件
-n@<列表文件> | 从列表文件中读取附加过滤器掩码
-os | 保存 NTFS 数据流
-oc | 设置 NTFS “压缩”属性
-oh | 把硬链接保存为链接而不是文件
-oi[-] | 把完全相同的文件保存为引用
-ol | 把符号链接保存为链接而不是文件
-or | 自动重命名
-ow | 处理文件用户身份校验信息
-o+ | 覆盖已存在的文件
-o- | 不要覆盖已存在的文件
-p[密码] | 设置密码
-qo[-|+] | 添加快速打开信息 [无|强制]
-r | 返回子文件夹
-r- | 禁用递归
-r0 | 只返回与通配符匹配的子文件夹
-ri | 设置优先级和休眠时间
-rr[N] | 添加数据恢复记录
-rv[N] | 创建恢复卷
-s | 创建固实压缩文件
-s<N> | 以文件数量创建固实组
-sc<字符集>[对象] | 指定字符集
-se | 以文件扩展名创建固实组
-sfx[名称] | 创建自解压文件
-sl<大小> | 处理大小小于指定大小的文件
-sm< 大小> | 处理大小超过指定大小的文件
-sv | 创建互不依赖的固实压缩文件
-sv- | 创建互相依赖的固实压缩文件
-s- | 禁用固实算法
-t | 压缩后测试文件
-ta[m,c,a,o]< 日期> | 只处理指定日期之后修改的文件
-tb[m,c,a,o]< 日期> | 只处理指定日期之前修改的文件
-tk | 保持原有压缩文件时间
-tl | 以最新的文件设置压缩文件时间
-tn[m,c,a,o]< 时间> | 处理较新于指定时间的文件
-to[m,c,a,o]< 时间> | 处理较旧于指定时间的文件
-ts[m,c,a,p][+,-,1] | 保存或恢复文件时间(修改,创建,访问,保留)
-u | 更新文件
-v<n>[k|b|m|M|g|G] | 创建分卷压缩
-vd | 创建分卷压缩前清除磁盘内容
-ver[n] | 文件版本控制
-vn | 使用旧风格的卷命名法则
-vp | 每次分卷压缩前暂停
-w<路径> | 设置临时文件的文件夹
-x< 文件> | 排除指定的文件
-x@< 文件列表> | 排除指定的列表文件中列出的文件
-y | 假设全部的询问回应皆为“是”
-z< 文件> | 从文件读取压缩文件注释


参数 -- - 停止扫描参数

此参数会告知 WinRAR 在命令行已没有其它的参数了。它是使用在，如果压缩文件名或文件名是从“-”字符开始的时候。没有“--”参数时，则会将此类名称当成参数来处理。

例子:

从当前文件夹添加全部文件到 固实 压缩文件 -StrangeName

WinRAR a -s -- -StrangeName


Switch -@[+] - disable [enable] file lists

参数 -@[+] - 禁用 [启用] 文件列表

WinRAR 把"@"字符开始的命令行参数作为文件列表对待。因此在默认情况下，WinRAR 在遇到“@文件名"参数时会尝试读取“文件名”文件列表。但如果存在“@文件名”的文件，RAR 将参数作为"@文件名"文件，而不是读取文件列表的文件。

参数 -@[+] 书允许定义如何处理“@"字符开始的参数，以避免这种歧义

如果指定了 -@，所有此参数后的参数都将被视为文件名，而不是文件列表。

如果指定了 -@+，所有此参数后的参数都将被视为文件列表，而不是文件名。

此参数不会影响位于之前的参数。

例子

测试压缩文件 '@home'

WinRAR t -@ notes.rar @home


参数 -AC - 清除存档属性

此参数是设计用于备份目标的。当压缩时使用此参数，在成功压缩的文件的“存档”属性将会被清除。如果解压时使用，WinRAR 会清除解压后文件的“存档”属性。此参数不影响文件夹属性。


参数 -AD[1,2] - 备选目标路径

在解压缩一组压缩文件时，此项可能很有用。

参数 -ad 和 -ad1 为每个压缩文件中解压出的文件创建一个单独的文件夹。 -ad 在目标文件夹中创建这些单独的文件夹，-ad1 在每个归档本身的文件夹中 创建这些单独的文件夹。

参数 -ad2 将解压的文件直接放置到每个归档本身的文件夹中。不创建单独 的文件夹。

为 -ad1 和 -ad2 参数忽略目标目录参数。

示例：

  1. WinRAR 将为每一个未压缩的压缩文件在‘data’下创建子目录。

WinRAR x -ad *.rar data\

  2. WinRAR 将会递归扫描 'arc' 文件夹搜索 *.rar 压缩文件，并在每个压缩文件文件夹里创建子文件夹。

WinRAR x -r -ad1 arc\*.rar


参数 -AF<类型> - 指定压缩文件格式

这个参数在 WinRAR 命令行中允许定义新压缩文件类型 <类型> 参数可以是‘rar’或‘ zip’。

例如，‘winrar a -afzip arc’将创建 arc.zip 压缩文件。

这个参数只被 WinRAR 支持。控制台 RAR 不能创建 ZIP 压缩文件。


参数 -AG[格式] - 以当前日期与时间生成压缩文件名

当创建或处理压缩文件时，以格式“YYYYMMDDHHMMSS”附加当前日期字符串，这对于每日更新是有用的。

附加字符串是由“格式”参数所定义，或者如果不存在时，则使用“ YYYYMMDDHHMMSS”。格式字符串可以包含下列的字符 :

Y | 年
M | 月
MMM | 文本式的月份名 (Jan,Feb，等)
W | 文本星期名 ( 星期以星期一开始)
A | 数字星期名 ( 星期一为 1，星期日为 7)
D | 日(月 )
E | 日(年 )
H | 时
M | 分 (如果接续在时候面，则视为分看待 )
I | 分钟 (不管小时的位置，都做分钟对待)
S | 秒
N | 压缩文件数字(从 1 开始的数字)。WinRAR 搜索要生成的名字的文件是否存在，如果发现它已经存在，将递增一个压缩文件数字，直到生成一个未使用的名字。'N' 格式化字符在创建 卷 时不支持。 在非压缩操作中，如解压，它会在选择已存在的压缩文件向前找第一个未使用的名称或如果这个压缩文件已经存在则把 N 设为 1。

上面列出的每个字符串仅表示添加到压缩文件名中的一个字符。例如，使用 WW 表示 2 数字的星期或 YYYY 定义 4 数字的年。

如果在格式化字符串的第一个字符是‘+’，日期字符串和基本压缩文件名位置交换，所以日期将在压缩文件名之前。

如果格式字符串中的第一个字符为“F”，则字符串的其余部分指定 -ag 参数的默认格式字符串。只有被放置到 rar.ini 文件或 RAR 环境变量时，这种“Such -agf<default_format>”参数才具有实用价值。例如，如果我们将 RAR 环境变量设置为 -agfYYYY-MMM-DD，我们可以使用 -ag，而不使用假定为 YYYY-MMM-DD 格式字符串的参数。

格式字符串可以包含在 '{' 和 '}' 包含的可选字符。此文本插入到压缩文件名中。

所有其它字符都原样添加到压缩文件名。

如果您需要处理已经存在的压缩文件，小心使用 -ag 参数。依赖于以前使用的 -ag 传送的格式字符串和时间，生成的和现有的压缩文件名可能不匹配。在这种情况下 WinRAR 会创建或打开一个新的压缩文件，而不是处理现有文件。您可以使用 -log 参数 写入生成的压缩文件名到一个文件，然后在下一步的处理中从文件读取它。

例子:

  1. 使用默认的 YYYYMMDDHHMMSS 格式

WinRAR a -ag backup

2) 使用 DD-MMM-YY 格式

WinRAR t -agDD-MMM-YY backup

3) 使用 YYYYMMDDHHMM 格式

WinRAR a -ag+YYYYMMDDHHMM backup

4) 使用 YYYY-WW-A 格式，包含区段描述

rar a -agYYYY{year}-WW{week}-A{wday} backup

5) 使用 YYYYMMDD 和压缩文件数字。它允许即使用 YYYYMMDD 格式掩码在同一天使用超过一次时，也产生唯一的文件名

WinRAR a -agYYYYMMDD-NN backup


参数 -AI - 忽略文件属性

当解压时实用此参数，WinRAR 不对解压的文件设置存储在压缩文件中的常规文件属性。此参数保留由操作系统赋予新创建文件的属性。它影响存档、系统、隐藏和只读属性。在 Unix 中，用户、组和其它文件属性。

仅支持 RAR 和 ZIP 格式。


参数 -AO - 添加有存档属性文件设置

此参数是设计用于备份目的的。当压缩时使用此参数，只会添加“存档”属性的文件到压缩文件中。此参数不影响文件夹，因此所有匹配的文件夹都会添加，无论其属性。您还可以指定 -ed 参数，如果您希望忽略所有文件夹记录。

例子:

添加驱动器 C: 具有“存档”属性的全部文件到“ f:backup”并清除文件的“存档”属性

WinRAR a -r -ac -ao f:backup c:\*.*


参数-AP<路径> - 设置压缩文件内的路径

当添加文件到压缩文件时以及当解压时从文件名删除，会将使用此参数定义的路径合并到文件名当中。

例如，如果您希望添加文件 readme.txt 到压缩文件 release 的文件夹 DOCS\ENG 中，您可以运行:

WinRAR a -apDOCS\ENG release readme.txt

或解压 ENG 到当前文件夹 :

WinRAR x -apDOCS release DOCS\ENG\*.*

仅可用于 RAR 和 ZIP 格式。


参数 -AS - 同步压缩文件内容

如果此参数使用于压缩时，在当前添加的文件列表中不存在的被压缩文件，将会从压缩文件中删除。它可以很方便的与 -u 参数结合，用来同步压缩文件和压缩的文件夹的内容。

举例来说，在下面命令之后:

WinRAR a -u -as backup sources\*.cpp

压缩文件 backup.rar 将只会包含源文件夹的 *.cpp 文件，其它的全部文件将会从压缩文件中删除。它看起来就好象创建新压缩文件，但有一个重要的不同 : 如果从上次备份后没有修改过的文件，这项操作会比创建新压缩文件的操作快上许多。


参数 -CFG- - 忽略默认配置和环境变量

此参数让 WinRAR 忽略默认压缩配置 中的设置、RAR 环境变量、, 压缩文件的默认文件夹、 管理密码 对话框中"选择用于压缩文件"的字段，以及其它已保存的配置。


参数 -CL - 将文件名转换成为小写

当使用此参数时，从压缩文件解压、添加到压缩文件、修改或更新压缩文件中的文件的全部文件名都将被转换成为小写。这有时可用于当从一个有区分大小写的操作系统，移动压缩文件到另一个有区分大小写的操作系统。举例来说，从 Unix 下解压，但压缩文件创建在 DOS 下。

例子:

从 port.rar 解压全部的文件并将名称转换成小写

WinRAR x -cl port


参数 -CP<名称> - 选择一个配置文件名

使用此参数，您可以加载存储在 WinRAR 中的压缩配置文件。您需要指定配置名作为参数的参数。如果配置文件保存选择了文件名，WinRAR 会压缩命令行中指定的文件和配置文件中指定的文件。如果配置文件包含压缩文件名，压缩文件会使用它，您不必在命令行中指定压缩文件名。

配置文件名称大小写敏感。请在保存配置文件时使用相同大小写来指定名称。

例子

使用"My Texts"压缩配置文件压缩所有 *.txt 文件

WinRAR a "-cpMy Texts" texts *.txt


参数 -CU - 将文件名转换成为大写

当使用此参数时，从压缩文件解压、添加到压缩文件、修改或更新压缩文件中的文件的全部文件名都将被转换成为大写。

例子:

从 port.rar 解压全部的文件并将名称转换成大写

WinRAR x -cu port


参数 -DF - 压缩后删除文件

移动文件到压缩文件。此参数结合命令 a 运行时的动作等同于命令 m。


参数 -DH - 打开共享的文件

允许处理由其它应用程序打开来写入的文件。

如果应用程序允许度去访问文件时，这个参数有用，但是如果文件的所有访问类型都被禁止，文件打开操作仍然会失败。

此参数是有危险性的，因为它允许添加文件到压缩文件，而文件可能正由其它应用程序进行修改中。使用时请小心。

如果未指定此参数，则依据在 压缩配置 的“打开共享的文件”选项设置而定。

例子:

WinRAR a -dh dbf *.dbf


参数 -DR - 删除文件到回收站

压缩后删除原文件并把它们放到回收站中。


参数 -DS - 不排序压缩的文件

此参数只对 固实 RAR 压缩文件有意义。固实压缩文件的压缩率是依据文件的顺序而定的，默认的 WinRAR 添加到固实压缩文件的文件是按扩展名排序的。您可以使用此参数 -ds 关闭此项排序，并试着设置更为最优化的文件顺序。通常类似的数据是被添加在一起的。

例子:

WinRAR a -s -ds tools *.com *.exe *.doc *.txt *.*

文件将会以: *.com、 *.exe、*.doc、*.txt、全部其它文件类型的顺序来添加。

注意:

文件 rarfiles.lst 也可以用来定义固实压缩文件中的文件顺序


参数 -DW - 压缩后清除文件

压缩后清除文件。删除文件前使用0字节覆盖文件数据，防止删除的文件被恢复，文件被截短并重命名为临时名称。

请注意，这种做法是为普通硬盘设计的，但可能无法覆盖固态磁盘上的原始文件数据，因为 SSD 磨损平衡技术的结果和更复杂的数据地址。


参数 -ED - 不添加空目录

这个参数指出空目录不被存储到被创建的压缩文件中。当解压这样一个压缩文件时, RAR 会基于他们内部的文件路径创建非空的目录。关于空目录的信息丢失。非空目录除了名字外 (访问权限, 流, 等。)其他所有属性全部丢失, 所以只有在您不需要保留这样的信息时使用此参数。

如果 -ed 和 m 命令或 -df 参数一起使用，WinRAR 将不会移除空的文件夹。


参数 -EN - 不添加“压缩文件结束”块

不支持 RAR 5.0 压缩文件。

默认情况下，RAR 在新建或更新压缩文件时，在结束时添加“压缩文件结束”块。它允许跳过象数字安全签名等扩展数据，但是在一些特定条件下禁用这些功能可能有用。例如，如果在一个压缩文件在两个系统之间通过不可靠的连接传递，并且同时发送者在它里面添加新文件时，它可能对确认已经接受的文件部分不会在传送部分之间的另一个结束被修改很重要。

这个参数不能用在分卷上，因为压缩文件结束块包含正确处理卷的重要信息。


参数 -EP - 名称中排除路径

包含此参数时，文件在加入压缩文件时不会包含路径信息。这可能会有在压缩文件中，存在数个相同名称的结果。

如果在解压时使用，解压的文件会忽略压缩的路径，因此所有文件都在同一个目标文件夹里创建。

例子:

从当前磁盘压缩全部的 *.bas 文件而不含路径。

WinRAR a -r -ep bsources \*.bas


参数 -EP1 - 从名称中排除主文件夹

不要存储或解压在命令行所输入的路径。

例子:

  1. 将 'tmp' 文件夹内的全部文件和文件夹添加到压缩文件 'test'，但是从压缩的路径名排除 'tmp\'

WinRAR a -ep1 -r test tmp\*

它等同于命令:

cd tmp

WinRAR a -r ..\test

cd ..

  2. 解压文件并匹配 images\* 掩码到 dest\ 目录， 但从已创建文件的路径里删除 'images\'

WinRAR x -ep1 data images\* dest\


参数 -EP2 - 扩大为完整路径

当压缩时存储完整的文件路径 (除了驱动器号与前缀的反斜线)。


参数 -EP3 - 扩展路径为包含盘符的完全路径

压缩时如果使用此参数则保存和恢复包括盘符的完全的文件路径。磁盘分隔符 (冒号)被下划线字符替换。

如果您解压时使用 -ep3 ，它把下划线改回为冒号并且把文件解压到它们原始的目录和磁盘中。如果用户也指定了目标路径，它会被忽略。

压缩和解压恢复它们原来的状态时提取，会把 UNC 路径从\\server\share 转换为__server\share。

此参数对于把数个磁盘备份到同一个压缩文件有帮助。例如，您可以运行 :

WinRAR a -ep3 -r backup.rar c:\ d:\ e:\

来创建备份并且:

WinRAR x -ep3 backup.rar

来恢复它。

小心使用 -ep3 参数，只有您确认压缩文件不包含任何恶意文件。您可以在 -ep3 参数 的描述中看到更多关于“存储包含盘符的完全路径”模式的可能的好处和危险，它是与此 WinRAR 选项等价的命令行。换句话说，如果是您自己创建的压缩文件或您完全相信它的作者才使用它。此参数允许覆盖在您的计算机上任何地方的任何文件，包括重要的系统文件和通常仅用于备份和恢复的目的。


参数 -e[+]<属性> - 设置文件排除属性

指定文件排除属性掩码。< 属性> 是一个十进制、八进制、(以‘0’开头) 或十六进制 (以‘0x’开头) 格式的数字。如果<属性>和文件属性 AND 逻辑运算后结果非零，文件不被添加到压缩文件中。

默认,在<属性>没有‘+’标记，此参数定义排除掩码。如果对< 属性>和文件属性按位进行 AND 逻辑运算的结果不为 0，则文件将不会被处理。

如果‘+’符号存在，它指定包含掩码。只有具有在掩码中指定的属性中的至少一种的文件会被处理。

在 Windows 版本中也可以使用符号 D, S, H, A 和 R 代替数字掩码来指出带有系统、隐藏、存档和只读属性的文件夹和文件。给出的属性的顺序没有特别的意义。

允许在命令行中把 -e<atr> 和 -e+<atr> 都指定。

例子:

1) 仅有文件夹名字而不包含它们的内容

WinRAR a -r -e+d folders

2) 不压缩系统和隐藏属性的文件:

WinRAR a -esh files


参数 -F - 刷新文件

可使用于压缩文件解压或是创建时。命令字符串“a-f”等同于命令 f。您也可以使用参数“-f”于命令 m。

如果参数“-f”使用于命令 x 或 e，此时仅旧文件会被从压缩文件解压的新版本给替换。压缩后的文件，没有符合的未压缩文件，则不会解压。

界面模式对等的参数是位于 压缩文件名和参数 对话框的“只刷新已存在的文件”选项，以及 解压路径和选项对话框 的“只刷新已存在的文件”选项。

仅支持 RAR 和 ZIP 格式。


参数 -HP[密码] - 加密文件数据和头

这个参数和 -p[p] 类似，但是参数 -p 只加密文件数据，而使文件名等其它信息可见。这个参数加密所有包括文件数据、文件名、大小、属性、注释和其它块等所有可感知压缩文件区域，所以它提供了更高的安全等级。

在压缩文件中使用-hp 加密，没有密码甚至不可能查看文件列表。

例子:

将添加文件 report.txt 到加密的压缩文件 secret.rar 中，使用密码‘fGzq5yKw’

rar a -hpfGzq5yKw secret report.txt


参数 -HT[B|C] - 选择文件校验和的哈希类型 [BLAKE2,CRC32]

参数 -HT[C|S] - 选择文件校验和的哈希类型 [BLAKE2,CRC32]

RAR 压缩文件的文件数据完整性由为每个存档文件计算和存储的校验和保护。

默认情况下，WinRAR 使用 CRC32 函数来计算校验和。RAR 5.0 压缩文件格式还允许选择 BLAKE2 哈希函数代替CRC32。

BLAKE2 哈希使用 -htb 参数，CRC32函数使用 -htc 参数。因为 CRC32 是默认的算法，所以只有在需要覆盖 WinRAR 配置中 -htb 模式时，您才可能需要 -htc。

CRC32 输出是 32 位长。虽然 CRC32 属性适合检测大部分意外的数据错误，它还没有可靠到可以验证文件数据。换句话说，如果两个文件有相同的CRC32，它不保证文件内容是相同的。

BLAKE2 输出是 256 位。作为一个密码学可靠性的强大哈希函数，它几乎可以保证如果两个文件如果有相同的 BLAKE2 值，则它们的内容是相同的。BLAKE2 的错误检测能力也比较短的 CRC32 更可靠。

因为 BLAKE2 输出较长，-htb 参数生成的压缩文件也会略大。

如果压缩文件头没有加密 (无 参数 -hp)，对于加密 RAR 5.0 文件的文件校验和被修改使用一种特殊的密码依赖算法，不可能基于校验和猜测文件内容。不要期待这样的加密文件校验和匹配常规和 BLAKE2 和 CRC32 值。

此参数仅支持 RAR 5.0 压缩文件, 所以您需要和它一起使用 -ma 参数。

命令行 - htb 相当于“压缩文件名和参数”对话框中的 使用 BLAKE2 文件校验和 选项。

例子

使用 BLAKE2 作为文件校验和添加 *.lst 到 lists.rar

WinRAR a -ma -htb lists.rar *.lst


参数 -IADM - 对于自解压压缩文件请求管理员访问权限

如果您创建自解压压缩文件时使用 -IADM, 在 Windows Vista 中启动时会请求管理员访问权限。此参数不改变在旧版本 Windows 中的自解压压缩文件的行为。

此命令行参数等价于 自解压选项: 高级 对话框中的 "请求管理员访问权限" 选项。

例子

WinRAR a -sfx -iadm install.exe c:\data


参数 -IBCK - 在后台运行 WinRAR

当开始压缩或解压操作时，将 WinRAR 最小化放到任务栏指示区。

界面模式对等的参数是位于 压缩文件名和参数 对话框的“后台压缩”选项和 解压对话框的“后台解压”选项。


参数 -IEML [.][地址] - 使用 E-mail 发送压缩文件

附加一个使用添加命令创建或被更新的压缩文件到 E-mail 信息中。您需要有 MAPI 兼容的 E-mail 客户端来使用这个参数(大部分现代的 E-mail 程序支持 MAPI 接口)。

您可以在参数中直接输入详细 E-mail 地址或留为空白。在以后可以由您的 E-mail 程序询问。可以使用用分号或逗号分开的数个地址。

如果您添加一个‘.’字母到 -ieml，成功附加到 E-mail 中后压缩文件会被删除。

如果创建多卷压缩文件使用这个参数，每一卷都附加单独的 E-mail 附件中。


参数 -IICON<名称> - 指定自解压图标

指定要创建或更新的自解压压缩文件的图标。 <名称>参数是 .ico 图标文件的名字。如果您要使用 -iicon，则您不能使用任何第三方可执行文件压缩程序压缩自解压模块。

这个参数等价于 自解压选项: 图标和文本 对话框的“从文件加载图标”的命令行命令。

例子:

  1. 1) 把 c:\myfiles 文件夹的内容添加到 setup.exe 自解压文件中，使用图标c:\myicons\ver1.ico 作为自解压文件的图标

WinRAR a -sfx -iiconc:\myicons\ver1.ico setup.exe c:\myfiles

  2. 使用当前文件夹中的 ver2.ico 文件替换自解压压缩文件 setup.exe 中的图标

WinRAR s -iiconver2.ico setup.exe


参数 -IIMG<名称> - 指定自解压图片

指定一个图像（*.png）文件在创建或更新的自解压压缩文件来显示为图片。 <名称>参数是包含完全路径的 .png 文件的名称。如果您要使用 iimg，则您不能使用任何第三方可执行文件压缩程序压缩自解压模块。

此参数是和在 自解压选项: 文本和图标 对话框的“从文件加载自解压图片”选项等价的命令行。

默认大小的自解压图片是 93x302 像素。推荐使用相同或更小一点的图像。

如果您使用两个 -iimg 参数，则第一个参数将定义默认值，第二个参数将定义高分辨率的 SFX 徽标。如果存在高分辨率徽标，SFX 模块可以调整其大小，并以高 DPI Windows 模式进行显示，与调整标准徽标的大小这项相比，提供更好的可见质量。建议高分辨率徽标的大小为 186x604 像素。

例子:

  1. 将 c:\myfiles 文件夹的内容添加到 setup.exe SFX 压缩文件，将 c:\pictures\logo1.png 用作默认徽标，将 c:\pictures\logo2.png 用作高分辨率的徽标

WinRAR a -sfx -iimgc:\pictures\logo1.png -iimgc:\pictures\logo2.png setup.exe c:\myfiles

  2. 使用保存在当前文件夹中的 logo.png 替换现有 SFX archive setup.exe 中的默认徽标，如果存在高分辨率的徽标，则将其删除

WinRAR s -iimglogo.png setup.exe


参数 -ILOG[文件名] - 记录错误到文件中

把错误信息写到 RAR 目录中的 rar.log 文件中。您可以在 选项菜单 中使用“查看日志”查看这个文件的内容。命令也可以在参数中指定其它的日志文件名代替默认的 rar.log，例如， -ilogc:\log\backup.log。 如果指定的文件名不包含路径，日志文件将在 %APPDATA%\WinRAR 文件夹 中创建。

如果 常规设置 对话框中选项“记录错误到日志中”启用，无论有没有 -ilog 参数，错误信息都会写到 rar.log 中参数。

默认情况下，日志文件使用 UTF-8 小端字节序编码，可以使用 -sc<字符集>g 参数修改，如 -scag 使用原生单字节编码。


参数 -IDV - 显示详细输出

显示更多信息位于命令行模式。现在它仅能与t 命令 配合使用，以便在结果为归档测试成功后发送信息。如果没有此参数，在未找到错误时， 静默完成“t”命令。


参数 -INUL - 禁用错误信息

禁用 WinRAR 错误信息。


参数 -IOFF[n] - 关闭 PC 电源

完成一个操作之后关闭 PC 电源。

使用 -ioff 或 -ioff1 来关闭 PC 电源，-ioff2 来休眠，-ioff3 来睡眠，以及 -ioff4 来重启。操作系统必须支持相应的电源管理功能。

如果启动了多个 WinRAR 副本，则会由最后结束的一份来关闭 PC。


Switch -ISND[-] - 控制通知的声音

使用 -isnd 来启用通知声音，使用 -isnd- 来禁用这些声音。


参数 -K - 锁定压缩文件

WinRAR 无法修改锁定的归档，因此锁定重要的归档可以防止 WinRAR 意外修改它们。 如果 WinRAR 命令分组处理归档，这种保护可能特别有用。

该参数不旨在或不能阻止其他工具或第三方有意进行修改。它仅针对 WinRAR 引起 的意外数据变更实行安全措施。

将 srcfiles 添加到 final.rar 并锁定生成的归档

WinRAR a -k final.rar srcfiles


参数 -KB - 保留解压时损坏的文件

此参数关闭 WinRAR 在解压后删除损坏的文件动作。


参数 -log[格式][=名称] - 写入名称到日志文件

参数 -LOG[格式][=文件名] - 写入名称到日志文件

此参数允许写入在压缩、解压、删除和列表命令中的压缩文件和文件名到指定的文本文件。它的行为被 '格式' 字符串定义，可以包含下面一个或多个字符:

A | 写入压缩文件名到日志文件。如果 RAR 创建或处理了卷，所有的卷名称都被记录。
F | 写入处理的文件名到日志文件。它包含了添加到压缩文件中和从压缩文件中解压、删除的文件或列出的压缩文件内的文件。
P | 如果指定名称的日志文件已经存在，则附加数据到现有文件后，而不是创建一个新的。
U | 以 Unicode 格式写入文件。

如果 'A' 和 'F' 都被指定，则为 'A'。

'名称' 允许指定日志文件的名称。它必须用 '=' 字符和 '格式' 字符串分隔。如果 '名称' 不存在，RAR 会使用默认的 rarinfo.log 文件名。

在同一命令行中允许指定多个 -log 参数。

此参数在您需要用 -ag 或 -v 参数在批处理脚本中处理创建的压缩文件时特别有用。在使用适当的命令创建一个压缩文件，然后从 arcname.txt 读取生成的 RAR 压缩文件名称时，您可以指定 -loga=arcname.txt。例如，在 Windows 批处理文件中它可以是：set /p name=<arcname.txt。

此参数的所有功能仅支持 Rar 格式。ZIP 格式只有在压缩操作时被支持。其它压缩格式不支持此参数。

例子

  1. 写入创建的卷的名字到 vollist.txt:

WinRAR a -v100m -loga=vollist.txt volume.rar c:\data

  2. 以 Unicode 格式写入生成的压缩文件名到 backup.txt:

WinRAR a -ag -logau=backup.txt backup.rar myfiles\*

  3. 写入测试过的卷的名字到 vollist.txt 和测试的卷内的压缩文件名到 filelist.txt:

WinRAR t -log=vollist.txt -logf=filelist.txt volume.part01.rar


参数 -M<n> - 设置压缩方式

选择 <n> 从 0 到 5，您可以 选择一个适当的压缩模式

-m0 | 存储 | 添加文件到压缩文件但是不压缩
-m1 | 最快 | 最快速的方法 ( 最低的压缩比)
-m2 | 快速 | 快速压缩方法
-m3 | 标准 | 标准 (默认 ) 压缩方法
-m4 | 较好 | 较好的压缩方法 (较高的压缩比)
-m5 | 最优 | 最优的压缩方法 (最高压缩比但是速度也最慢)

在 WinRAR 的默认值是使用“-m3”方式 (常规压缩 )。

压缩方式可以使用 压缩文件名和参数对话框 中的“压缩模式”列表来选择。


参数 -MA[4|5] - 指定压缩格式的版本

默认 WinRAR 创建 RAR 5.0 格式的压缩文件。使用 -ma4 来创建 RAR 4.0 压缩文件。在您需要覆盖保存在配置中的 -ma4 时，使用 -ma5 或仅 -ma 来强制 WinRAR 使用 RAR 5.0 格式。

此参数仅在创建新的压缩文件时使用。更新现有压缩文件时它被忽略。

例子

创建 RAR 4.0 固实 压缩文件并使用 2MB 字典 压缩 SrcDir:

WinRAR a -ma4 -md2m data SrcDir


参数 -MC<参数> - 设置高级压缩参数

这个参数主要是试图进行测试和试验，在真实环境中通常最好允许 RAR 去自动选择最佳参数。请注意，不正确地使用这些参数可能导致非常严重的执行和压缩损失，所以只有在您清楚理解您所要做的时使用它。

它的语法:

-mc[参数1][:参数 2][模块][+ or -]

<模块>的位置是指示压缩算法的一个字符，它必须被设置。它可以有下列的值:

A | 音频压缩;
C | 真彩色(RGB) 数据压缩;
D | delta 压缩;
E | x86 Intel 可执行文件压缩;
T | 文本压缩。

RAR 5.0 压缩格式仅支持 'D' 和 'E' 值。

在参数结尾的'+'标记应用选择的算法模块到所处理的数据， '-'完全禁用模块。如果没有指定标记，RAR将基于数据和当前的压缩模式自动选择模块。参数 -mc- 禁止所有的可选模块并只允许常规压缩算法。

<参数1> 和 <参数2> 是下面描述的参数的依靠模块。

音频压缩，增值压缩:

<参数1> 使通道的字节数 (可以是1 - 31)。

RAR 拆分多位声道成单位声道，例如，两个 16位音频声道可以被 RAR 看作每个宽一字节的四个声道。

<参数2> 被忽略。

x86 Intel 可执行文件压缩，真彩(RGB)数据压缩

<参数1> 和 <参数2> 被忽略。

文本压缩:

文本压缩算法对纯文本数据提供了更高的压缩率。但是它不能有效利用多 CPU 核心，导致在多核心和多处理环境中和常规算法相比压缩时间较长。无论 CPU 核心数多少，它的解压速度都比常规算法要慢。这就是为什么默认文本压缩被禁用的原因。您可以使用 -mct 参数来让 WinRAR 在处理合适的数据时自动选择此算法。参数 -mct+ 会对所有数据强制使用文本压缩。

参数 -mct 也可以包括 <参数1> 和 <参数2>, 所以它的完整语法是 -mc[参数1][:参数2]t[+ 或 -]。

<参数1> 是 PPM 算法的规则(可以是 2 - 63)。

<参数2> 对于 PPM 可用的以兆字节位单位的内存 (1-128)。

PPM 压缩和解压使用的内存大小相等，所以创建一个压缩文件时如果分配太多的内存，其它人在安装了比较少内存的机器上解压它时可能出现问题。解压缩也可以使用虚拟内存，但是可能变得非常慢。

例子:

  1. 参数 -mc1a+ 强制使用对所有数据使用 8位单声道诞生到声音压缩。
  2. 参数 -mc10:40t+ 强制使用对所有数据使用文本压缩优化算法,设置压缩次序到 10 并分配 40 MB内存。
  3. 参数 -mc12t 设置压缩次序到 12，设置文本压缩顺序为12 ，当使用文本压缩时，让 RAR 决定何时使用它。
  4. 参数 -mct -mcd- 允许 WinRAR 对合适的数据应用文本压缩，禁用 delta 压缩。


参数 -MD<n> - 选择字典大小

参数 -MD<n>[k,m,g] - 选择字典大小

这个可变大小的字典是被压缩算法使用的专用的内存区域。如果被压缩文件的大小(或在一个固实压缩文件中的总文件大小)比压缩文件大许多，则通常增加字典大小会增加压缩率，减慢压缩速度和增加内存需要。

对于 RAR 4.x 压缩格式，字典大小可以是: 64 KB, 128 KB, 256 KB, 512 KB, 1 MB, 2 MB, 4 MB。

对于 RAR 5.0 压缩格式，字典大小可以是: 128 KB, 256 KB, 512 KB, 1 MB, 2 MB, 4 MB, 8 MB, 16 MB, 32 MB, 64 MB, 128 MB, 256 MB, 512 MB, 1 GB。

您可以附加 'k', 'm' 和 'g' 后缀指定大小单位是 KB，MB 和 GB, 例如，-md64m 指 64MB 字典。如果后缀不存在，默认是 MB，所以 -md64m 等于 -md64。

在压缩时 RAR 需要大约 6 倍于指定字典大小的内存。因此 512 MB 和 1 GB 大小的字典仅在 64 位的 RAR 版本中可用。解压时，分配略多于一个字典大小的内存，所以 32 位和 64 位版本可以解压所有字典大小的压缩文件，包括1 GB。

如果 固实 压缩文件的所有源文件的大小，或者非固实压缩文件的最大源文件的大小至少是字典大小的1/2，则 WinRAR 可以减少字典大小。这对减少内存使用率而不降低压缩率有帮助。

RAR 4.x 的默认可变字典大小是 4 MB。RAR 5.0 压缩格式是 32 MB。

WinRAR 创建的 ZIP 压缩文件始终会使用 32Kb 的字典来创建。

字典大小也可以通过 高级压缩参数 对话框的“字典大小”列表来做选择。

例子:

以 128 MB 字典创建 RAR 5.0 格式固实压缩文件。

WinRAR a -s -ma -md128 lib *.dll


参数 -ME[par] - 设置加密参数

现在仅支持 "ZL" (传统 ZIP) 参数。因此，您可以使用 -mezl 参数连同 -p[pwd] 来使用 ZIP 传统算法创建一个加密的 ZIP 压缩文件。没有 -mezl 的 ZIP 压缩文件以 AES-256 加密，它更安全，但可能跟一些较老版本的 unzip 工具不兼容。

示例

使用 ZIP 传统加密来创建加密的压缩文件

WinRAR a -s -pmypassword -mezl docs.zip *.txt


参数 -MS[列表] - 指定文件类型存储

指定不压缩而直接存储的文件类型。当正确使用时，它将有助于增加压缩速度，而不会显著的减小压缩率。

可选参数 <列表> 参数定义使用分号隔开得文件扩展名列表。例如，-msrar;zip;jpg 将强制 RAR 不压缩直接存储所有的 RAR 和 ZIP 压缩文件和 JPG 图象。它也允许在列表中指定通配符，所以-ms*.rar;*.zip;*.jpg 也可以工作。允许使用多个 -ms 参数，如 -msrar -mszip 替代 -msrar;zip

如果 <列表> 没有被指定， -ms 参数将使用默认的包含下列文件类型的扩展设置:

7z, ace, arj, bz2, cab, gz, jpeg, jpg, lha, lz, lzh, mp3, rar, taz, tgz, xz, z, zip, zipx


参数 -MT<线程> - 设置线程数

<线程> 参数可以是从 1 到 64 的值。它定义推荐压缩算法的最大活动线程数，也用于其它 WinRAR 模块使其以多线程启动。WinRAR 会尝试遵循此建议，但某些时候真实的活动线程数可能超过指定值。

改变 <线程 > 参数轻微影响压缩率，所以如果所有其它压缩参数相等而使用不同的 -mt 参数创建的压缩文件不会解压得一样连贯。

如果没有指定 -mt 参数， RAR 会尝试检测可用的处理器的数量并自动选择优化的线程数。


参数 -N<文件> - 附加过滤器包含文件

应用掩码作为附加过滤器来包含文件列表。通配符在文件掩码的名称和文件部分都可用。关于掩码句法详见 参数 -x 描述。您可以数次指定参数‘ -n’。此关不能替换通常的文件掩码，仍然需要在命令行中输入。它是一个附加的过滤器限制处理的文件那些仅匹配在 杗 参数中指定掩码的文件。某些时候它可以帮助减少命令行的长度。

例如，如果您需要压缩在 Project 和 Info 文件夹内的所有的 *.txt 和 *.lst 文件，您可以输入 :

WinRAR a -r text Project\*.txt Project\*.lst Info\*.txt Info\*.lst

或使用参数 -n:

WinRAR a -r -n*.txt -n*.lst text Project Info


参数 -N@<列表文件> - 从列表文件读取附加过滤器掩码

和 -n<文件> 参数类似，但是从列表文件读取过滤器掩码

此参数不替换通常的列表文件或文件掩码，它们仍需输入到命令行里。它是一个额外的过滤器，用来限制仅处理那些匹配 -n 参数里指定的包含掩码的文件。

例子:

WinRAR a -r -n@inclist.txt text Project Info @listfile.txt


参数 -OC - 设置NTFS“压缩”属性

此参数允许解压文件时恢复 NTFS “压缩”属性。WinRAR 在创建一个压缩文件时保存“压缩”文件属性，但是如果不指定 -oc 参数就不会恢复它们。外壳模式等价此参数的是在解压对话框的“高级”部分的“设置压缩属性”选项。

此参数只被 RAR 压缩文件支持。


参数 -OH - 把硬链接作为链接而不是文件

如果压缩中的文件包含数个 NTFS 硬链接，会把首个硬链接作为普通文件存储，同组中剩下的硬链接作为首文件的链接存储。在解压这些文件的时候，WinARR 会创建硬链接，而不是普通文件。

您一定不要在创建压缩文件后删除或重命名压缩文件中首个硬链接，因为这导致不可能解压下面的链接。如果您修改首个链接，解压后下面链接的内容也会被修改。解压命令要成功创建下面的硬链接必须涉及首硬链接。仅被 RAR 5.0 压缩文件支持。

此命令行参数等价于“压缩文件名和参数”对话框中的把硬链接存储为链接 选项组。


参数 -OI[-][:<最小大小>] - 把相同文件保存为引用

如果指定了此参数，在启动压缩之前 WinRAR 会分析文件的内容。如果找到几个相同的文件，组中的第一个文件作为普通文件保存，所有剩下的文件保存为第一个文件的引用。这可以减少压缩文件的大小，但对生成的压缩文件有一些限制。压缩文件创建后，您一定不要删除或重命名文件压缩文件中的第一个相同文件，因为这会使后面的文件使用它作参考的文件不能解压。如果您修改了第一个文件，后面的文件的内容在解压后也会被修改。解压命令要成功创建后面的文件必须涉及到第一个文件。

如果您要压缩很多相同的文件，并且以后不会修改压缩文件，解压时解压整个压缩文件，没有必要解压缩或跳过单个文件，推荐使用 -oi。如果所有相同的文件小到足以匹配压缩字典，则指定 -md<n> 参数、-s 参数可以提供比 -oi 更灵活的解决方案。

可选的<最小大小>值允许定义最小文件大小的阈值。小于<最小大小>的文件不被分析看作是不同的。如果这个参数不存在，默认值是 64 KB。选择太小<最小大小>可能增加检测相同的文件所需的时间。

仅支持 RAR 5.0 压缩文件。

如果您要禁用在 WinRAR 配置中启用的相同文件处理，使用 -oi-。

此命令行参数相当于“压缩文件名和参数”对话框的 把相同的文件保存为引用 选项。

例子:

把当前目录中的内容保存到 archive.rar。把大于等于 1000000 字节的相同文件保存为引用。

WinRAR a -oi:1000000 -ma archive


参数 -OL[A] - 将符号链接作为链接处理 [绝对路径]

把 NTFS 符号链接和分析点存储为链接，以便文件或文件夹内容不被存档。这些文档项目在解压时被恢复为符号链接或分析点。仅 RAR 5.0 压缩文件支持。

解压时您需要以管理员权限运行 WinRAR 创建符号链接。

WinRAR 使用 -ol 参数压缩时添加所有链接，无论目标是什么。 解压时，WinRAR 默认忽略指向目标文件夹之外的符号链接，在链接目标里带有绝对路径，或多余数量的 ".."，或者其它潜在危险的链接参数。您可以使用 -ola 参数启用解压这种链接。

指向解压目标文件夹之外的文件夹的链接可能导致安全风险。仅当您确认压缩文件内容是安全的（如您自己的备份）时，才启用此解压。

总是解压 WinRAR 视为安全的链接，而无论 -ol 或 -ola 参数。

此命令行参数 -ol 等价于“压缩文件名和参数”对话框中的 把符号链接保存为链接 选项。参数 -ola 等价于解压缩对话框中的 "允许符号链接中的绝对路径" 选项。


参数 -OR - 自动重命名文件

如果相同名字的文件已经存在则自动重命名解压的文件。重命名文件将得到象 'filename(N).txt' 的名字，'filename.txt' 的位置是原始的文件名，如果文件存在 'N' 是从 1 增加数字。


参数 -OS - 储存 NTFS 数据流

此参数只能在 NTFS 文件系统下使用，允许存储与文件相关联的可选数据流。如果压缩时您使用软件在可选流中存储数据并希望保留这些流，您可能需要指定它。

流不保存 NTFS 加密文件。

此参数等同于界面模式 压缩文件名和参数 对话框的“储存文件串流”选项。

此参数仅支持 RAR 压缩文件。


参数 -OW - 处理文件安全信息

当压缩保存文件安全信息以及解压还原时，使用此参数参数。

WinRAR 储存拥有人，组，文件权限和校验信息，但这必须在您先有读取它们的权限前提下。注意，这只支持 Windows 下的 NTFS 文件安全系统。

此参数等同于界面模式 压缩文件名和参数 对话框的“储存文件安全数据”选项。

此参数只支持 RAR 压缩文件。


参数 -O[+|-] - 设置覆盖模式

这个参数可以在解压和更新压缩文件时使用。下列模式可用:

-o | 覆盖前询问(解压文件时默认)
-o+ | 覆盖所有(更新压缩文件时默认);
-o- | 跳过已存在的文件。


参数 -P<密码> - 设置密码

在压缩或解压加密的压缩文件期间，设置密码 <密码> 给 加密 的文件。密码的大小写必须匹配。在命令行时，如果您省略了密码，您将会被提示输入它。

在界面模式，密码也可以经由 输入默认密码 对话框或在 压缩文件名和参数 对话框输入。

例子:

使用密码 ZaBaToAd 来将文件夹“games”的内容添加到压缩文件“secret”。

WinRAR a -pZaBaToAd -r secret games\*.*

注意

1) 如果您希望确保压缩文件的安全性，密码不要使用少于 8 个字符，或是容易被猜测出来的;

2) 不要忘记您的密码，否则您的数据将会完全丢失。


参数 -QO[-|+] - 添加快速打开信息 [无|强制]

RAR 压缩文件在描述的每个文件的数据前存储包含如文件名称、时间、大小和属性的信息的文件头。这种方法比把所有文件头储存在一个连续的块中更能防止损坏，后者如果损坏或丢失会摧毁整个压缩文件的内容。但在更可靠的同时，这些文件头散布于整个压缩文件，如果我们需要在类似 WinRAR 图形界面的外壳中快速打开压缩文件的内容时的访问速度太慢。

要提高压缩文件的打开速度，而且要整个压缩文件不依赖于单一易受损块，RAR 5.0 压缩文件可以包含一个可选的快速打开的记录。这些记录被添加到压缩文件的结尾，包含附加在压缩文件内的普通文件头的文件名和其它文件信息的副本被存储在一个单一的连续块中。因为块是连续的，所以其内容可以被快速读取，而不需要执行大量的磁盘寻道操作。此块中每一个文件头都被校验和保护。如果 WinRAR 检测到快速打开信息被破坏，它会从压缩文件内重新读取这部分的头信息，所以防伤害性能没有被减弱。

快速打开记录包含文件头的完整副本，这可能是数十或数百个字节/文件，会把压缩文件的大小增加相同的量。当文件数据大小与文件头差不多大时，对于许多小文件，大小的增加是很明显的。所以在默认情况下，如果没有指定 -qo 或 -qo 没有使用参数，WinRAR 只对相对大的文件存储头副本，对小文件继续使用本地头。具体的文件大小阈值依赖解 WinRAR 的版本。这种方法提供了一个在打开速度和压缩文件大小之间的合理折衷。如果您想要最大的压缩文件打开速度，而不管大小，您可以使用 -qo+ 存储所有文件头的副本。如果您需要尽可能小的压缩文件，而不关心压缩文件在不同的程序中打开的速度，指定 -qo- 完全排除快速打开信息。

如果您想测试此参数的性能效果，确保压缩文件的内容没有存储在磁盘的缓存中。对于缓存的压缩文件没有进行真正的磁盘搜索，这使访问没有快速打开记录的文件头也很快。

此命令行参数等同于“压缩文件名和参数”对话框中的 快速打开信息 选项组。


参数 -R - 递归子文件夹

启用递归子文件夹，可使用于命令: a、u、 f、m、x、e、t、 k、rr、c 和 s。

当使用于命令 a 、u、f 或 m 时，不但只有当前工作的文件夹，且在全部子文件夹的文件将会一并处理。

当使用于命令 x 、e、t、k、rr、c 或 s 时，不但只有当前工作的文件夹，且在全部子文件夹的压缩文件将会一并处理。

例子:

1) 添加磁盘 C 的内容到压缩文件 Backup

WinRAR a -r Backup c:\*.*

2) 在当前的磁盘测试全部的 *.rar 压缩文件

WinRAR t -r \*.rar


参数 -R- - 禁用递归

禁用子文件夹递归。

在某些情况下，即使没有指定 -r 参数 RAR 也会自动启用递归。参数 -r- 禁止它。

压缩时如果您指定了目录名，目录名不包含通配符，即使 -r 参数没有指定，默认 RAR 添加目录的内容。如果磁盘根目录没有把通配符作为文件掩码指定，RAR 也会自动启用递归。参数 -r- 禁用此行为。

例子:

WinRAR a -r- arc dirname

命令仅会添加空目录 'dirname' 目录并忽略它的内容。下列命令:

WinRAR a -r- arc c:\

会仅压缩 c: 根目录的内容并不会包含子目录。


参数 -R0 - 仅当包含通配符名字时才连同子文件夹

类似于 参数 -r，但是与命令 a、u、 f、m 合用时，将仅对包括通配符'*' 和 '?' 的文件掩码递归子目录。

此参数仅用于文件名。没有文件名部分的目录名，如 'foldername'，不受 -r0 影响，如果没有指定 -r- 参数，它们的内容被完全添加到压缩文件中。

例子

从当前目录和它的子目录添加 *.doc 和仅当前文件夹中的 readme.txt 文件到 docs.rar 压缩文件。在使用 -r 参数的情况下，RAR 会从子目录中搜索 readme.txt。

WinRAR a -r0 docs.rar *.doc readme.txt


参数 -RI<p>[:<s>] - 设置优先级和休眠时间

此参数控制 WinRAR 的系统加载。可用的任务优先级 <p> 的值是 0 - 15。

如果 <p> 是 0,WinRAR 使用默认优先级。<p> 等于 1 设置最低的优先级，15 - 最高的优先级。

休眠时间 <s> 是一个从 0 到 1000 (毫秒)的值。这是一个在压缩或解压的读取或写入操作后 WinRAR 返回系统的时间。如果您需要减少使用 <p> 参数压缩系统加载，可以使用非零的 <s>。

例子:

以默认优先级执行 WinRAR 并休眠 10 毫秒:

WinRAR a -ri0:10 backup *.*


参数 -RR[n] - 添加数据恢复记录

此参数使用于当创建或修改 RAR 压缩文件的时候，添加数据 恢复记录 到压缩文件中。对于 RAR 4.x 格式 'N' 参数可以指定恢复区块数(n = 1，2 .. 524288)，或在 'N' 之后设置 '%' 或 'p' 参数指定压缩文件大小的百分比。对于 RAR 5.0 压缩文件 'N' 总是压缩文件大小的百分比，不管是否存在后缀。

此参数的语法类似于 "RR[N]" 命令。请阅读 RR[N] 命令 的描述和 恢复记录 主题获得详细信息。

此参数等同于界面模式的 压缩文件名和参数 的“添加恢复记录”选项。

例子:

从当前文件夹添加全部的 *.txt 文件到压缩文件 Books，并设置恢复记录大小为压缩文件总大小的 3%

WinRAR a -rr3p Books *.txt


参数 -RV[N] - 创建恢复卷

这个参数在创建 RAR 多卷压缩文件 使用来创建 恢复卷。语法和 rv 命令 相同。


参数 -S - 创建固实压缩文件

固实压缩是一种特殊的压缩方式。固实压缩文件 意味着以牺牲压缩文件更新速度来换取压缩效率。此参数只有在创建新 RAR 压缩文件 时才有意义。

此参数等同于界面模式的 压缩文件名和参数对话框 的“创建固实压缩文件”选项。

例子:

从当前文件夹添加全部的 *.c 和 *.h 文件到固实压缩文件 Sources

WinRAR a -s Sources *.c *.h

请参阅 固实压缩文件 章节来获得帮助信息。


参数 -S<N> - 根据文件计数创建固实组

类似于 -s ，但在压缩 <N> 个文件之后重置 固实 统计数据。通常这样会减低压缩率，但也可以在固实压缩文件损坏时减少数据的丢失。


参数 -SC<字符集>[对象] - 指定字符集

此参数允许指定列表文件、日志文件和压缩包注释文件的字符集。

“字符集”参数是强制的, 可以使用下列值:

U | Unicode UTF-16
F | Unicode UTF-8
A | 原生单字节编码，是 ANSI 用于 Windows
O | OEM (DOS) 编码

源 UTF-16 文件（例如列表文件或注释）的端字节序（Endianness），基于字节序标记来检测。如果丢失字节序标记，假定为小端字节序（little endian）编码。

“对象”参数是可选的, 可以使用下列值:

G | -ilog 参数生成的日志文件
L | 列表文件
C | 注释文件

它允许指定不只一个对象, 例如, -scolc。如果“对象”参数丢失，“字符集”会应用到所有对象。

此参数允许指定在 -z<文件> 参数中的文件的字符集, 列表文件和注释文件在 cw 命令中写入。

例子:

  1. 使用 OEM 编码读取 'list' 中包含的名称:

WinRAR a a -scol data @list

  2. 读取 comment.txt 为 Unicode 文件:

WinRAR c -scuc -zcomment.txt data

  3. 写入 comment.txt 为 Unicode 文件:

WinRAR cw -scuc data comment.txt


参数 -SE - 以文件扩展名创建固实组

类似于 -s，但扩展名更改时重置 固实 统计数据。通常这样会减低压缩率，但也可以在固实压缩文件损坏时减少数据的丢失。


参数 -SL<大小> - 处理大小小于指定大小的文件

仅处理大小小于在此参数的 <大小> 参数中指定的大小的文件。参数 <大小> 必须按字节指定。

仅支持 RAR 和 ZIP 格式。


参数 -SM<大小> - 处理大小超过指定大小的文件

仅处理大小超过在此参数的 <大小> 参数中指定的大小的文件。参数 <大小> 必须按字节指定。

仅支持 RAR 和 ZIP 格式。


参数 -SV -创建互不依赖的固实压缩分卷

当开始一个新的 卷 时，RAR 默认尽可能的尝试重 固实 格式状态，但是只有前一个重置之后有足够的可用数据被打包 (至少几兆字节)。这个参数会强制 RAR 忽略打包的数据大小，并试图对任何大小的分卷重置状态。这会降低压缩率，但在固实卷组中的卷丢失或损坏时可以增加解压部分数据的机会。

注意有时候 RAR 即使使用这个参数也无法重置状态。例如，当压缩一个大文件成许多分割卷时就不能问成。 RAR 只能在分离文件之间重置状态，而不能用在单独文件上。

如果用来创建不带卷的压缩文件时忽略。

您也可以在 WinRAR 图形界面中设置这个选项到RAR 环境变量 中。


参数 -SV- -创建互相依赖的固实压缩分卷

禁止 卷 之间重设 固实 状态。这将稍微提高压缩率，但是意味着如果固实卷丢失或损坏时减少解压部分数据的机会。

如果使用非分卷压缩文件时它将被忽略。

您也可以在 WinRAR 图形界面中设置这个选项到 RAR 环境变量 中。

另请查阅: 参数 -sv


参数 -S- - 禁止固实压缩

即使在 压缩配置 对话框默认启用，也不使用 固实 格式压缩文件。


参数 -SFX[名称] - 创建自解压文件

当创建新压缩文件时使用此参数，将会创建一个 自解压文件 (SFX) 。 RAR 压缩文件默认使用的自解压模块是 Default.SFX 以及 ZIP 压缩文件为 Zip.SFX 。这些模块必须与 winrar.exe 在同一个文件夹中。您也可以指定“-sfx”参数来代替自解压模块。

界面模式下，等同于此参数的是在 压缩文件名和参数 对话框的“创建自解压文件”选项。

例子:

a) 创建自解压的固实分卷压缩文件

WinRAR a -sfx -v360 -s Games

a) 创建压缩文件使用 WinCon.SFX 模块

WinRAR a -sfxWinCon.SFX Gift.rar

另请参阅 s[名称] 命令。


参数 -T - 压缩后测试文件

压缩后测试文件。这个参数在和移动命令组合使用时非常有用，所以只有压缩文件已经被成功测试后，文件才会被删除。


参数 -TA[m,c,a,o]<日期> - 只处理指定日期之后修改的文件

只处理指定日期之后修改的文件。也包括完全匹配指定日期的文件。

日期字符串的格式是 YYYYMMDDHHMMSS。它允许在日期字符串中插入‘-’或‘ :’的分隔符，并忽略后部区域。例如，下列参数是正确的 :-ta2001-11-20。在内部它被转换成 -ta20011120000000 并作为“从2001年11月20日0 时0分0秒后修改的区域”对待。

使用 'm', 'c', 'a' 参数来指定相应的修改、创建和上次访问时间，例如 -tac20011120 表示创建时间。 如果此类参数被忽略，则假定为修改时间。

允许在同一个参数里使用几个修饰参数，例如 -tamc20190215，来为所有指定的时间设置相同的日期。 另外，您可以添加几个时间过滤参数到命令行。 默认情况下，时间过滤器使用 AND 逻辑，因此一个文件必须匹配所有此类过滤器才能被处理。它可以用 'o' 修饰参数来修改为 OR 逻辑，这样一个文件必须至少匹配一个 'o' 过滤器。 例如，使用 -taco20190201 -tamo20190210 来包含创建于 2019-02-01 之后或修改于 2019-02-10 之后的文件。


参数 -TB[m,c,a,o]<日期> - 处理制定日期之前修改的文件

只处理指定日期之前修改的文件。不包括完全匹配指定日期的文件。

日期字符串的格式是 YYYYMMDDHHMMSS。它允许在日期字符串中插入‘-’或‘ :’的分隔符，并忽略后部区域。例如，下列参数是正确的 :-ta2001-11-20。在内部它被转换成 -ta20011120000000 并作为“从2001年11月20日0 时0分0秒后修改的区域”对待。

使用 'm', 'c', 'a' 参数来指定相应的修改、创建和上次访问时间，例如 -tac20011120 表示创建时间。 如果此类参数被忽略，则假定为修改时间。

允许在同一个参数里使用几个修饰参数，例如 -tamc20190215，来为所有指定的时间设置相同的日期。 另外，您可以添加几个时间过滤参数到命令行。 默认情况下，时间过滤器使用 AND 逻辑，因此一个文件必须匹配所有此类过滤器才能被处理。它可以用 'o' 修饰参数来修改为 OR 逻辑，这样一个文件必须至少匹配一个 'o' 过滤器。 例如，使用 -taco20190201 -tamo20190210 来包含创建于 2019-02-01 之后或修改于 2019-02-10 之后的文件。


参数 -TK - 保留原压缩文件时间

当压缩文件发生改变时，防止 WinRAR 修改压缩文件时间。


参数 -TL - 以最新的文件设置压缩文件时间

设置压缩文件的时间为压缩文件中最新的文件时间。强制 WinRAR 以在压缩文件中最新的文件时间修改压缩文件时间。


参数 -TN[m,c,a,o]<时间> - 处理比指定时间新的文件

使用此参数时，只处理比指定时间还新的那些文件。也包括完全匹配指定日期的文件。时间字符串的格式为:

[<n日>d ][<n时>h ][<n分>m ][<n秒>s ]

例如，使用参数 -tn15d 可处理最近 15 天的文件，以及 -tn2h30m 则处理最近 2 时 30 分的文件。

使用 'm', 'c', 'a' 参数来指定相应的修改、创建和上次访问时间，例如 -tac20011120 表示创建时间。 如果此类参数被忽略，则假定为修改时间。

允许在同一个参数里使用几个修饰参数，例如 -tamc20190215，来为所有指定的时间设置相同的日期。 另外，您可以添加几个时间过滤参数到命令行。 默认情况下，时间过滤器使用 AND 逻辑，因此一个文件必须匹配所有此类过滤器才能被处理。它可以用 'o' 修饰参数来修改为 OR 逻辑，这样一个文件必须至少匹配一个 'o' 过滤器。 例如，使用 -taco20190201 -tamo20190210 来包含创建于 2019-02-01 之后或修改于 2019-02-10 之后的文件。


参数 -TO[m,c,a,o]<时间> - 处理比指定时间旧的文件

使用此参数时，只处理比指定时间还旧的那些文件。不包括完全匹配指定日期的文件。

时间字符串的格式为:

[<n日>d ][<n时>h ][<n分>m ][<n秒>s ]

例如，使用参数 -tn15d 可处理文件较旧于 15 天的，以及 -tn2h30m 则处理文件较旧于 2 时 30 分的。

使用 'm', 'c', 'a' 参数来指定相应的修改、创建和上次访问时间，例如 -tac20011120 表示创建时间。 如果此类参数被忽略，则假定为修改时间。

允许在同一个参数里使用几个修饰参数，例如 -tamc20190215，来为所有指定的时间设置相同的日期。 另外，您可以添加几个时间过滤参数到命令行。 默认情况下，时间过滤器使用 AND 逻辑，因此一个文件必须匹配所有此类过滤器才能被处理。它可以用 'o' 修饰参数来修改为 OR 逻辑，这样一个文件必须至少匹配一个 'o' 过滤器。 例如，使用 -taco20190201 -tamo20190210 来包含创建于 2019-02-01 之后或修改于 2019-02-10 之后的文件。


参数-TS[m,c,a,p][+,-,1] - 保存或恢复文件时间 (修改,创建,访问,保留)

使用 -tsm 来保存文件的修改时间，-tsc 用于创建时间，-tsa 用于最近访问时间。允许多个 -ts 参数，例如 -tsc -tsa。如果未指定 'm', 'c' 或 'a'，假定为这三种文件时间。

附加 '+' 来保存文件时间并带有最大的精度。具体值取决于操作系统和文件系统，并且可以在 Windows 里达到 100 纳秒，在 Unix 里达到 1 纳秒。 附加 '1' 来设置 1 秒精确度，或者 '-' 不保存文件时间。如果没有 '+', '-' 或 '1'，则假定为 '+'，因此 -ts+ 和 -ts 都保存三种高精度时间。

同一文件的所有存储时间始终具有相同的精度。如果指定了不同的精度，例如 -tsm1 -tsc+，则选择常用精度。

RAR 4.x 压缩文件总是含有修改时间，并且对于 RAR 4.x 压缩文件 -tsm- 仍然保存修改时间并带有最低的 2 秒精度。另外两个时间可以禁用。RAR RAR 5.0压缩文件允许忽略任何文件时间包括修改，因此解压的文件将会有当前系统时间。 参数 -tsm- -tsc- -tsa- 或 -ts- 会保存低精度修改时间用于 RAR 4.x 并且对于 RAR 5.0 压缩文件没有文件时间。

如果 -ts 参数未指定，RAR 保存最高精度的修改时间并忽略其它时间。

默认时 WinRAR 仅为已解压的文件设置修改时间，即使压缩文件包含其它时间。解压时请使用 -ts- 或 -ts+ 来设置这三个时间，-tsc 和 -tsa 来设置创建和上次访问时间，-tsm- 或 -ts- 来设置当前的系统时间而不是保存在压缩文件里的修改时间。

使用 -tsp 参数可以在归档时保留源文件原始的上次访问文件时间。此参数尝试保留归档文件原始的上次访问时间，但不控制将哪些时间戳存储到归档中。为此，它必须结合其他 -ts 参数一起使用。例如，如果我们希望保存上次访问归档时间，并保留源文件的上次访问时间，我们需要同时使用 -tsa -tsp。-tsp 参数可以防止打开一些没有该参数仍能打开的文件。

允许在同一个参数中组合多个修饰符，例如 -tscap 而不是 -tsc -tsa -tsp。

所有上面描述的模式仅被 RAR 格式支持。在 Zip 压缩文件中，高精度修改时间被存储在类似创建时间和最近访问时间这样的数据结构中。当压缩为 ZIP 文件时，所有的三个时间都用 -ts 或 -tsm 选项控制，而 -tsa 和 -tsc 被忽略。使用 -ts 或 -tsm 把所有时间保存为高精度格式（默认 ZIP 模式），指定 -ts- 或 -tsm- 仅以低精度保存修改时间。当解压 ZIP 压缩文件时，-tsm -tsc -tsa 参数可以单独用于控制相应的时间，如用于 RAR 格式一样。

例子:

  1. 使用最高精确度存储所有文件时间：

WinRAR a -ts backup

  2. 恢复修改和最近访问时间。参数 -tsm 不是必需的，因为 RAR 默认设置修改时间。如果我们希望恢复上次访问时间，我们应该使用 -tsm- -tsa参数：

WinRAR x -tsa backup

  3. 存储低精确度的修改和创建时间。保留源文件的上次访问时间。

WinRAR a -tsm1 -tsc1 -tsp backup


参数 -U - 更新文件

这可与压缩文件解压和创建时合用。命令字符串 a -u 是等同于命令 u 。您也可以使用参数“-u”于命令令 m。

如果参数“-u”使用于命令 x 或 e ，这时从压缩文件解压，有最近使用的文件，只有在旧文件有新版本时才会替换。这不和 -f 一样，如果压缩文件没有符合的未压缩文件，它将会被解压。

界面模时下，相当于此参数的是在 压缩文件名和参数对话框 的“添加并更新文件”选项和在 解压路径和选项对话框 的“解压并更新文件”选项。

仅支持 RAR 和 ZIP 格式。


参数 -V<n>[k|b|m|M|g|G] - 创建分卷

创建 卷 及大小 = <n> *1000

默认此参数使用 <n> 作为一千个 (1000) 字节 (非 1024 x 字节)。您也可以输入符号“k”来表示千字节的大小， 或者符号“b”表示字节，在百万字节为 -‘m’，一百万个字节为 -‘M’ G 字节 - ‘g’十亿个字节 -‘G’。如果省略了大小，将会使用自动检测。

它允许使用十进位小数作为十进制的标记。例如，v1.5g 参数表示 1.5 GB。

您可以指定几个 -v 参数来为不同的卷设置不同的大小。例如 :

rar a -v100k -v200k -v300k arcname

第一卷设为 100 KB 大小, 第二卷设为 200 KB, 剩下的为 300 KB。

如果分卷在可移动磁盘创建，在创建第一个分卷之后，用户将会被提示 :

创建下一个分卷吗 : 是/否/创建全部

在此时间里，您可以抽换磁盘。回答“全部”则会创建全部的分卷而不会暂停。

默认 RAR 卷以‘volname.partNNN.rar’格式命名，NNN 的地方是卷号。RAR 4.x 压缩格式使用 -vn 参数参数可能转换成其它的扩展基本命名规则，卷组中第一卷文件由 .rar 的扩展名，以后卷从 .r00 到 .r99 命名。RAR 5.0 压缩文件不支持 -vn 和扩展基本名称。

当解压或测试多片的分卷压缩文件时，您只能使用第一个分卷的名称。如果下一个分卷不在驱动器时，用户会被提示 :

请插入磁盘 <下一个分卷名>。确定/取消

这时请插入正确的分卷并按下“确定”。

压缩文件分卷是无法修改的。命令 d,f,u 或 s 也不能使用于多片的分卷压缩文件。命令 a 只可以在创建新的多片分卷压缩时使用。

这是可能的，虽然不和在多卷中文件的大小一样，但可以大于未压缩的大小。此事实的缘由是“存储” (如果大小增加时不压缩) 不能在多片的分卷压缩中启用。

压缩文件分卷可以是 固实 以及/或是 自解压 。

此参数等同于界面模式 压缩文件名和参数 对话框的“分割成卷”区域。

例子:

创建 1 GB 大小的实体卷，分卷自解压文件

WinRAR a -s -v1g volume.rar bitmaps


参数 -VD - 创建分卷压缩文件前清除磁盘内容

当使用“-vd”时，在开始压缩操作之前，全部在目标磁盘的文件和文件夹将会先清除。如果您创建 分卷 ，在创建每一个分卷之前，都将先运行清除操作，以让您可以放入非空白的磁盘，但您必须注意在磁盘上不包含任何的有用信息。

此参数只能应用在可移动磁盘，硬盘是无法使用它清除的。


参数 -VER[n] - 文件版本控制

当在已经存在的压缩文件中更新文件时，强制 RAR 保留前一文件版本。旧版本被命名为‘filename;n’处是版本号。仅只吃 RAR 压缩文件。

当时不使用参数 -ver 解压一个压缩文件，rar 默认只解压最近添加地文件版本，它的名字不能包含数字后缀。但是如果您正确指定了文件名，包括版本，它也可以解压。例如，‘ rar x arcname’将只解压组新版本，当使用‘rar x arcname file.txt;5’将解压‘file.txt;5’，如果它在压缩文件中存在的话。

解压时如果您不带参数指定 -ver 参数， RAR 将解压所有和文件掩码匹配的所有文件中的所有版本。这样版本号没有从未压缩文件名中删除。您也可以使用数字作为 -ver 的参数来解压一个具体的文件版本。它将告诉 RAR只解压这个版本并从文件名中删除版本号。例如，‘ rar x -ver5 arcname’将只解压第五版本文件。

如果压缩时您指定了‘n ’参数，它会限制在压缩文件中文件版本的最大数字。超过此限制的旧的文件版本会被移除。

当使用 -ver 参数压缩时，建议在要添加的文件里避免 'filename;n' 格式的名称。此类名称可能导致重复项目，如果在压缩文件里存在较老版本的同名文件或将在之后创建。


参数 -VN - 使用旧风格的卷命名法则

默认 RAR 卷 以‘volname.partNNN.rar’格式命名，NNN的地方是卷号。4.x 压缩格式使用 -vn 参数可能选择其它的扩展基本命名规则，卷组中第一卷文件由 .rar 的扩展名，以后卷从 .r00 到 .r99 命名。

RAR 5.0 压缩文件不支持 -vn 和扩展基本名称。


参数 -VP - 每次分卷压缩前暂停

默认处理下一卷前，RAR 仅在使用可移动驱动器上并且剩余的磁盘空间小于卷大小时询问确认。这个参数强制 RAR 在创建或解压卷前总是进行这样的询问。例如，如果您要在创建后立即把新卷复制到其它媒体时有用。


参数 -W<路径> - 设置临时文件夹

WinRAR 在某些操作中需要创建临时文件和文件夹，如压缩文件修改。默认使用“设置”对话框的路径页面“临时文件的文件夹”区域中指定的目录创建它们。当您在命令行模式下使用 WinRAR，您可以使用 -w<路径> 参数覆盖此参数。

例子:

当添加一个新的注释到 info.rar 文件时使用 d:\tmp 文件夹用于临时文件

WinRAR c -wd:\tmp -zcomment.txt info.rar


参数 -X<文件> - 排除指定的文件

操作中排除指定的文件或文件夹 。通配符可以用在文件名和文件掩码的路径部分。您可以在同一命令行中数次指定参数 -x 来定义数个排除掩码。

如果掩码包含通配符，它应用到当前目录中的文件和它的子目录。没有通配符它不递归，"filename"掩码会在压缩时仅排除当前目录中的 'filename' 文件或解压时排除压缩文件根目录中的 'filename'。

使用 "*\filename" 语法排除所有目录中的所有 "filename"。

如果您知道一个文件的确切路径，您可以是使用"路径\文件名"语法来仅排除"文件名"的此副本。如果您在解压一个压缩文件时使用 -x路径\ 文件名语法，"路径"必须是一个压缩文件内的路径，而不是在解压后的磁盘上的文件路径。

默认，包含通配符的掩码仅应用于文件。如果您需要使用有通配符的掩码排除多个目录，要使用特殊的语法来用于目录排除掩码。这样的掩码必须在后面跟一个斜线的路径分隔符(Windows 是 '\'，Unix 是 '/')。例如，"*tmp*\"掩码会排除所有匹配 "*tmp*" 掩码的目录，"*\tmp\"会排除所有的 'tmp' 目录，由于通配符的存在，掩码会应用于当前目录和它的子目录中的内容。文件夹排除掩码仅支持 RAR 和 ZIP 格式。

如果您要仅排除一个目录，不要使用任何通配符，指定确切的包含相对或绝对路径的目录名。这种情况下您不需要为掩码追加附件的路径分隔符，只有在掩码中包含通配符，需要把它们从文件排除掩码中区分出来时才必须。

例子:

  1. 压缩当前文件夹和它的子文件夹中除了 *.jpg 和 *.avi 外的所有文件

WinRAR a -r -x*.jpg -x*.avi rawfiles

  2. 压缩C:上除了 Temp文件夹外的所有文件

WinRAR a -r -x*\temp\ savec c:\*

  3. 从文件 docs.rar 中解压所有的除了 *.txt 外的所有文件

WinRAR x -x*.txt docs


参数 -X@<列表文件> - 排除指定的列表文件中列出的文件

排除在列表文件 <列表文件> 中列出的文件

例子:

添加全部 *.exe 文件到压缩文件 bin，但是如果名称存在 list.txt 的则排除。

WinRAR a -x@list.txt bin *.exe


参数 -Y - 假设全部的询问回应皆为“是”

如果指定了此参数，“是”为默认值，并自动回应全部的询问。


参数 -Z<文件> - 从文件读取压缩文件注释

如果此参数与任何的压缩文件更新命令合用时，将会从指定的文件读取注释，添加到压缩文件中。 Use 如果您需要指定注释文本的字符集使用参数 -sc。

例子:

从当前文件夹添加全部文件到 固实压缩文件 Receipts，并从 Receipts.diz 添加文件注释

WinRAR a -zReceipts.diz -s Receipts


WinRAR 退出代码

WinRAR 在成功操作的情况下以 0 代码退出。非零退出代码表示下列错误:

代码值 | 描述
0 | 成功操作。
1 | 警告。发生非致命错误。
2 | 发生致命错误。
3 | 无效校验和。数据损坏。
4 | 尝试修改一个 锁定的压缩文件。
5 | 写错误。
6 | 文件打开错误。
7 | 错误命令行选项。
8 | 内存不足。
9 | 文件创建错误。
10 | 没有找到与指定的掩码和选项匹配的文件。
11 | 密码错误。
12 | 读取错误。
255 | 用户中断。


常规设置对话框

要启动此对话框，在 选项菜单 选择“设置...”命令并在“常规”选项卡上单击。对话框的内容描述如下。

系统/低运行优先级

WinRAR 以此参数作为多工环境下的系统占用规则。通常使用常规优先级是最优的选择，但如果您常与其它应用程序合用，并将 WinRAR 放在后台运行时，您可能希望使用较低的优先级。

系统/线程

您可以在此处指定 WinRAR 压缩和其他模块使用的最大 CPU 线程数。当 WinRAR 尝试遵循此选项时，有时活动线程的实际数量可能会超过指定的值。

通常默认值是最佳值，但是如果您希望 WinRAR 占用更少的 CPU 资源，则可能需要减小默认值。减小此参数可能会降低 WinRAR 性能。

历史/保存压缩记录

默认 WinRAR 会在“文件菜单”保存少量最近打开过的压缩文件名，方便您再次快速的访问它们。但如果您需要禁用它，例如基于保密理由时，您可以清除该选项。

如果打开此选项，WinRAR 会把打开过的压缩文件添加到 Windows 最近打开文档列表中。如果关闭“保存压缩记录”，Windows 会自己维护最近打开文档列表，根据 Windows 版本和设置，压缩文件名可能在也可能不添加。

历史/在对话框中显示历史记录

在许多的 WinRAR 对话框中的许多输入区域都支持以前输入字符串的列表，这样可以快速恢复以前输入的值 (压缩文件名、目标路径等) 。它可以保存用户的时间，但是上述选项在多用户环境中这样的功能会有安全问题。所以如果您和其他人共享您的计算机，您可能想要禁止它。

工具栏/按钮大小

选择工具栏按钮大小。仅可用于默认 WinRAR 界面主题。

工具栏/显示按钮文本

控制按钮文本的显示。

工具栏/锁定工具栏

防止被用户移动或改变工具栏的大小。您可以启用此选项来避免在您已经自定义了您需要的工具栏后对工具栏位置或大小的意外修改。

工具栏/工具栏

激活的对话框允许打开或关闭 WinRAR 的主工具栏，附加的小工具栏包含“向上一级”按钮和带有路径或压缩文件信息的地址条。

工具栏/按钮

单击“选择按钮”可打开一个 对话框，在那里您可以指定要显示哪一些工具栏按钮。

工具栏 ( 大型按钮、显示按钮文本)

启动时显示界面/ 显示向导

转换 WinRAR 到 向导 模式，启动就会开始。

界面/启用声音提示功能

在错误及长时间操作完成后，启用 WinRAR 制造声音来提示。

界面/显示压缩文件的注释

如果打开的压缩文件含有注释时，显示 注释 窗口。

界面/重复使用现有窗口

如果意图打开新压缩文件，运行“WinRAR <压缩文件名>”命令或是在压缩文件图标上单击，并且 WinRAR 窗口已存在时，将压缩文件打开于已存在的窗口中，如果未启用此选项，则会创建一个新窗口。

界面/总在最上

将 WinRAR 窗口放在所有程序的上面。如果您经常使用 WinRAR 拖动目标时，您可以做此设置。

界面/标题栏中的完整路径

在 WinRAR 标题栏里显示当前打开文件夹或压缩文件的完整路径。

界面/Windows 进度条

此选项控制在显示解压和压缩进度窗口的进度条的外观。如果启用，WinRAR 会使用标准的 Windows 进度条。如果禁用，会使用 WinRAR 版本的进度条。在较老版本的 Windows 中可以关闭此选项，在 Windows Vista 中启用它，控件会有更好的外观。注意 Windows 进度条仅有两种颜色，所以他们不象 WinRAR 进度条能指示当前的压缩率。但是压缩率也显示在进度窗口的一个单独的行中。

界面/任务栏进度条

如果启用此选项，WinRAR 会在 Windows 任务栏的 WinRAR 图标中显示总的操作进度。任务栏进度条功能仅可用于 Window 7 以上版本，所有“任务栏进度条”选项在较老版本的 Windows 版本中被禁用。

记录/将记录错误到日志

在压缩文件损坏的时候，将错误消息和信息写入到 %APPDATA%\WinRAR 文件夹下的文件 rar.log。此选项只在 注册 之后才能有效。使用 选项菜单 的“查看日志”可以查看日志的内容。

记录/限制日志大小为 <nnn> KB

启用限制 WinRAR 所创建的日志 rar.log 的大小，允许最小的日志值为 50KB。


压缩设置对话框

要启动此对话框，在 选项菜单 选择“设置...”命令并在“压缩”选项卡上单击。对话框的内容描述如下。注意，大多数的压缩选项都可以通过“压缩配置文件 /创建默认值”按钮指定。

要获得不同压缩参数之间差异的详细资料，可在 怎样选择优化的压缩设置 中找到。

压缩配置文件/创建默认值

在单击此按钮后，在显示的对话框您可以指定大部分压缩操作的默认值选项。在线帮助在此对话框的全部部分也可以使用，在任何时候只要单击“帮助”按钮便可以读取详细的选项描述。

在此对话框所输入的选项值会被保存在默认的 压缩配置，名称为“默认配置文件”，并在每一个压缩文件操作之前自动的还原。

某些默认压缩配置的参数不仅用于添加文件到压缩文件中，也用于其它的压缩文件修改操作，如删除或重命名文件。在这些情况下，WinRAR 仅读取适合当前操作匹配的那些参数。解压不使用默认压缩配置的任何选项。

压缩配置文件/管理

打开此对话框可以管理 压缩配置。在此 管理配置 对话框中您可以删除已存在的对话框或者是编辑它们的参数。比如说，您可以重命名配置文件或将它设置为默认值等。请读取此对话框的相关在线帮助可获得更多的信息。

分卷大小列表/定义卷大小

此按钮激活 定义卷大小 对话框。这里您可以自定义预定义的卷大小，和 压缩文件名和参数 对话框中的“分割卷, 大小”关联。

首先作为压缩文件打开的文件类型

定义如何处理回车或双击那些带有存档内容的文件，以及 WinRAR文件列表中的非存档名称扩展名的文件，以文件管理模式。 它不影响对具有像.rar或.zip这样扩展名的常规压缩文件的处理。

指定一个或多个由空格分隔的掩码，以选择作为压缩文件处理的文件。不匹配这些掩码并具有非存档扩展名的所有文件将被执行，或在其关联程序中打开，如果此类程序可用。例如，如果此处 * .exe 掩码不存在，并且您在 WinRAR 文件列表中的自解压 exe 压缩文件上按回车键，则 WinRAR 将运行此 SFX 压缩文件，而不是显示其内容。

如果文件匹配任何掩码，WinRAR 将首先尝试将其作为压缩文件打开，只有当它不是压缩文件时，它将被作为通常的文件来处理。压缩文件内部忽略此选项，因此压缩的文件在点击回车时会在关联程序中打开。

无论这个选项如何，您都可以随时浏览任何压缩文件内容，在压缩文件内部或外部，带有标准或非标准扩展名，通过在 WinRAR 文件列表中在它的名称上按 Ctrl+PgDn。


路径设置对话框

要启动此对话框，在 选项菜单 选择“设置...”命令并在“路径”选项卡上单击。对话框的内容描述如下。

临时文件夹

WinRAR 使用此文件夹创建临时文件，如果此区域留白，根据命令类型，全部的文件和文件夹将创建于当前文件夹或 Window 临时文件夹中。

此参数的初始状态是标准 Windows 临时文件夹。如果您要修改它并且以后想恢复为 Windows 临时文件夹，您可以输入 %temp% 代替文件夹名。 WinRAR 会在创建临时文件前把它替换为 Windows 临时文件夹名。

临时文件夹/仅用于可移动磁盘

在当前文件夹创建临时压缩文件时，硬盘通常是比较快。对于慢的外部磁盘而言，先在硬盘创建好压缩文件之后再复制到外部磁盘上可能会更有效率。当有此类需要时，您需输入临时文件夹，并打开此选项。

启动的文件夹

您可以在此输入每次 WinRAR 启动时所打开的文件夹。注意，此选项仅在“启动”的选项“启动上次使用的文件夹”关闭时才有意义，不然的话，则设置为上次使用的文件夹。

启动的文件夹/启动时恢复上次使用的文件夹

如果启用此选项，当不带参数运行时，WinRAR 将会设置上次查看的文件夹。

压缩文件的默认文件夹

如果此区域不是空白，且压缩文件名不包含完整的路径，压缩文件将会被创建在指定的文件夹。举例来说，如果您输入您桌面的路径，则 WinRAR 创建的文件将会出现在桌面。

如果此区域是空白的，压缩文件将会创建在与压缩的文件相同的文件夹。

命令行模式中 -cfg- 参数禁用大部分 WinRAR 设置，包括压缩的默认文件夹。

解压文件的默认文件夹

您可以在此输入文件夹的名称，这会被用来当成 不确认直接解压 与 解压文件到指定文件夹 命令在建构目标文件夹时的基准。 WinRAR 在这些解压命令时，会创建结合默认文件夹与压缩文件名的目标路径，它可以在此轻松的输入桌面路径，如此您便可在桌面立即看到解压后的数据。

不像压缩默认文件夹，解压文件默认文件夹不在命令行模式中使用。仅 "解压文件..." 命令受到影响，在 上下文菜单里。

附加压缩文件名到路径

它控制当构建解压文件的目标路径时，压缩文件名是否追加到默认的文件夹名后，或到解压对话框里指定的文件夹名称后。

从解压路径移除多余的文件夹

此选项仅可用于 上下文菜单, 仅用于选择了单个根目录包含一个单独文件夹并且没有文件的压缩文件的 "解压到 DestName\" 命令, 'DestName' 的位置是 WinRAR 基于压缩文件名得到的文件夹名。 如果满足这些条件，此选项会从解压路径中移除基于文件名的顶级文件夹。

例如，如果您由一个 Pictures.rar 包含的文件都在 'Samples' 文件夹下，如果您使用右键关联菜单的 "解压到 Pictures\" 命令解压它时， 如果此选项是关闭的，WinRAR 会把文件放到 "Pictures\Samples" 中，打开时为 "Samples"。这样有助于减少一次不必要的点击来打开 'Pictures' 文件夹， 它只包含 'Samples'。

此选项会导致在解压开始有额外的延迟，因为 WinRAR 需要扫描压缩文件并分析文件夹的结构。注意即使解压时将要从路径中移除基于压缩文件的文件夹名，邮件菜单仍然会显示它。 在关联菜单中显示纠正的文件夹会导致在右键点击和显示关联菜单间潜在的烦人延迟。


文件列表设置对话框

要启动此对话框，在 选项菜单 选择“设置...”命令并在“文件列表”选项卡上单击。对话框的内容描述如下。

列表类型 (列表查看或详细资料)

选择列表查看(多域，只显示文件图标) 或详细资料查看 (单域，提供每一个文件大小，日期和类型信息 )其中一种。默认的模式是详细内容查看。

列表样式/显示格线

在文件列表上显示格线。

列表样式/整行选择

使用整行式光标。

列表样式/复选框

使用复选框来选择列表项目。可在 Windows Vista 和更高版本上获得。

文件/将压缩文件优先显示

不管当前的排序模式为何，将压缩文件列于所有文件之前优先显示。

文件/彩色显示加密的或压缩的 NTFS 文件

如果启用，WinRAR 会使用资源管理器一样的颜色来显示 NTFS “压缩的”和“加密的”的属性。默认“压缩的”是蓝色的“加密的”是绿色的。

文件/合并分卷压缩内容

如果该选项启用了，而且您打开了第一个 分卷 ,WinRAR 也会试着读取所有在文件夹内的其它有效的接续分卷压缩文件，并当作第一个分卷压缩文件的内容显示。如此替代结果，所看到的不仅是第一个分卷包含的文件，您将会看到第一个以及随后分卷压缩所包含的文件。

文件/显示秒

在文件列表中显示文件日期的秒。没有此选项 WinRAR 在文件列表中日期显示 1 分钟的精度。

文件/具体大小

如果启用该选项，则文件大小总是以字节来显示。如果禁用该选项， 则大小会使用 KB 或 MB 之类的单位来四舍五入。较小的文件仍然可以 用字节来显示。此选项还会影响 WinRAR 界面的其他部分，例如状态栏 中的总大小和选定大小。

文件/栏目?/I>

选择栏目来以 文件和压缩文件管理模式 显示。

文件/设置字体?/I>

为文件列表和文件夹树型面板选择字体。

选择

在此，您可为列表设置不同的鼠标形式。如果您希望用 Internet 浏览器形式的话，设置“单击打开项目”。在此模式下，如果您希望文件名下加下划线时，您也可以在此选择，而默认的 WinRAR 模式为“双击打开项目”。


查看器设置对话框

要启动此对话框，在 WinRAR 的 选项菜单 选择“设置...”命令并在“查看器”选项卡上单击。对话框的内容叙述如下。

查看类型

选择当用户按下 Enter 时默认的动作，可用的动作为:

内部查看器 | 使用 内部 WinRAR 查看器
外部查看器 | 使用外部查看器，您可在“外部查看器”区域中定义名称
关联的程序 | 使用该类型的 Windows 默认查看器
询问 | 每次按下 Enter 时询问用户想要用的查看器类型

这些设置会被两种文件类型所忽略: (在 文件管理模式 )对于压缩文件和可执行文件它们被忽略。按下 Enter 时，WinRAR 始终会试着打开压缩文件并运行 exe 文件。在 压缩文件管理模式 它们对在查看器设置的“解压所有用于”区域指定的文件类型忽略。如果在这些文件上按下 Enter,WinRAR 会解压整个压缩文件内容到临时文件夹，然后一个文件，等候它中止。如有需要的话更新源压缩文件，并在之后删除临时文件夹和它的全部内容。这提供了从压缩文件直接安装程序的简便方法。

和 Enter 不一样， 查看文件 命令永远使用 WinRAR 内部查看器 打开文件。

内部查看器 /自动检测编码

如果启用此选项，内部查看器尝试自动检测文件内容为 Windows 文本 (ANSI)，DOS 文本 (OEM)，Unicode UTF-8 或 UTF-16 小端字节序。如果检测错误，可以使用内部查看器的 "View" 菜单里的 "View as" 命令，来更改已打开文件的编码。

依赖于这个选项内部查看器将使用 Windows (如果选项没有设置)或 DOS 编码打开文件。也可以使用内部查看器的“查看”菜单中的“作为查看”命令改变当前打开文件的编码页。

内部查看器 /重复使用现有窗口

根据此选项，内部查看器将使用 Windows (如果未设置选项) 或 DOS 页码的一种打开文件。使用在“查看”菜单的“查看方式”命令，也可以改变内部查看器，在当前打开的文件所使用的文本编码。

内部查看器 /自动换行

如果该选项关闭，WinRAR 会为每一个查看的文件创建个别的内部查看器窗口。当选项是打开状态时，则重复使用现有窗口，因此只会有一个打开的查看器。

解压所有用于

在这里您可以定义需要完全解压压缩文件内容的文件掩码，当用户在匹配这些掩码之一的压缩文件上按下 Enter 或双击解压时处理。掩码必需用空格分隔。例如，如果此区域包含 *.exe *.htm *.html，则在打开一个压缩的可执行文件或 HTML 文件时 WinRAR 会解压全部的压缩文件内容。对某些文件类型需要此选项，要正确执行或查看需要访问其它的压缩过的文件。

WinRAR 对在“解压所有用于”区域定义的文件类型忽略“查看类型”设置，并总是使用关联的程序打开它们。

忽略修改

默认情况下，WinRAR 会在查看器修改了打开的文件或创建了新的文件时建议更新压缩文件，但是可以禁用此行为。您可以在“忽略修改”选项中输入以空格分隔的一个或多个文件掩码，如果创建或修改的文件则匹配这些掩码，WinRAR 不会再询问是否要更新压缩文件，也不会将这些文件添加到压缩文件。

例如，如果此字段包含 *.doc *.txt，则所有被扩展或关联的查看器修改或创建的文件都会被忽略，用户查看这些文件时所做的任何修改都会丢失。如果您要对所有查看的文件禁用压缩文件更新，则使用 * 掩码。

此选项的掩码可以有更复杂的语法，可以用双反斜线字符分隔来组合压缩文件和文件掩码: 压缩文件掩码\\文件掩码。掩码可以包含路径，这样可以限制为某些文件夹和它的子文件夹。您可以在路径中使用环境变量。如果您想匹配所有的压缩文件或所有的文件，它允许省略‘压缩文件掩码\\’ 或 ‘文件掩码’ 部分。

例如, *.rar\\*.txt 意味着所有 .rar 压缩文件内的所有 .txt 文件，*\\temp\* 或仅仅 temp\* 匹配压缩文件内所有在‘temp’文件夹下的所有文件，%temp%\*\\* 或 %temp%\*\\ 表示查看器不要更新 Windows 临时文件夹内的所有压缩文件。

外部查看器名

如果您设置了“当按下 Enter 时运行外部查看器”选项时，您可在此输入要当成查看器的程序名。要查看的文件名将会当成单个参数传送给该程序。


安全设置对话框

选择在 选项菜单 的“设置”命令并单击“安全”页激活此对话框。此对话框内容描述如下。

解压时排除的文件类型

如果启用此选项，您可以在输入区指定有潜在危险的列表。它允许输入数个用空格分开的掩码。 WinRAR 在解压或打开压缩文件时会跳过任何匹配这些掩码的文件。

此选项可以帮助包含用户防止被 Email 附件感染。例如，您输入:

*.scr *.pif *.exe

在此区中，它会阻止用户用 WinRAR 解压、查看和允许.scr, .pif 和 .exe 文件。

清除临时文件

此选项组控制 WinRAR 处理压缩文件内已经有文件时生成的临时文件夹内文件的删除模式。它涉及到内部或外部查看器的操作、执行压缩包内文件或拖放解压。

清除临时文件/永不

如果选择了“永不”，会使用普通系统删除函数删除临时文件，有时可以被某些特殊软件恢复。这样处理临时文件样更快，当不很安全。

清除临时文件/总是

在“总是”模式中，在删除临时文件前使用 0 字节文件覆盖它们, 防止被恢复。这是一个导致速度变慢但更安全的方法。

清除临时文件/仅加密文件

如果您选项了“仅加密文件”，它可以让 WinRAR 在认定为加密文件时，使用慢速但安全的方法删除从加密压缩文件解压到临时文件夹中的文件。其它临时文件快速删除。

注意“清除临时文件”选项

  • 清除操作是为普通硬盘设计的，但可能无法覆盖固态磁盘上的原始文件数据，因为 SSD 磨损平衡技术的结果和更复杂的数据地址。
  • 如果临时文件还在使用中，WinRAR 可能不能立即删除它们。但是，当您下一次运行 WinRAR 的，所有超过一小时的临时文件将被删除或清除。如果 WinRAR 不确认临时文件是否仍然在被外部应用程序使用着的情况下做同样的处理。
  • 此选项仅适用于解压操作后创建的临时文件。它在其它不同方式生成的临时文件时不工作，如修改压缩文件时创建的。这些文件总是标准快速删除。

提示选择病毒扫描软件

此选项修改 扫描压缩文件内的病毒 命令的动作。默认它是启动的，所以 WinRAR 当激活病毒扫描命令时每次都提示选择病毒扫描软件名和参数。如果您希望跳过病毒扫描选择对话框则您可以关闭它。如果您只使用一种防病毒软件，您可以通过关闭此选项来跳过病毒扫描选择对话框。


集成设置对话框

要启动此对话框，在 WinRAR 的 选项菜单 选择“设置...”命令并在“集成界面”选项卡上单击。当安装 WinRAR 时也有相同的选项设置，因此在安装期间和安装之后当可以在 WinRAR 设置值中设置下的叙述。

WinRAR 关联到(RAR、ZIP 等)

您可以为选定的文件格式关联 WinRAR 作为默认查看器。保持这些选项的选定是合理的，这样您只要在资源管理器或桌面上双击压缩文件名称或图标，即可在 WinRAR 中打开压缩文件。您可以点击“全部切换”按钮来快速选择所有格式，或者在它们已经全部选择时取消选择它们。

从 Windows 10 开始，Windows 仅将这些关联选项视为推荐。通常，如果没有其他用户应用程序与文件类型相关联，则应用它们。否则，它们将用于构建具有多个条目的“打开方式”列表。因此，可能有必要借助 Windows 自身的设置来更改已经存在的文件关联，例如借助“资源管理器”菜单内“打开方式”中的“始终使用此应用程序来打开文件”选项来“选择其他应用程序”，或 Windows 设置中的“按文件类型选择默认的应用程序”。

用户定义压缩文件扩展名

在这里您可以指定被 WinRAR 支持格式压缩文件的附加的文件扩展名。例如，如果您有扩展名是“.dat”的文件，是 RAR 格式的，您可以在这里输入“dat”来关联到 WinRAR，并且对“dat”文件在 Windows 外壳中的 关联菜单命令 添加解压命令。如果您需要输入数个扩展名，用空格分开它们。

此选项仅在 WinRAR 设置里可用，但在 WinRAR 安装程序里不可用。

界面/添加 WinRAR 到桌面

添加 WinRAR 图标到桌面上。

界面/添加 WinRAR 到开始菜单

添加 WinRAR 图标到“开始”菜单。

此选项添加 WinRAR 图标到 Windows XP 经典风格开始菜单的顶部。从 Windows Vista 开始，程序不能添加自身到开始菜单顶部，所以此选项把 WinRAR 图标添加到“所有程序”列表。如果您要在 Windows Vista 及更新版本系统的开始菜单顶部添加应用程序图标，您可以使用Windows的“附到开始菜单”命令代替。

此选项在 Windows Vista 及以后版本不起作用。从 Windows Vista 开始，程序不能添加自身到开始菜单顶部。您可以使用Windows的“附到开始菜单”命令代替。

界面/创建 WinRAR 程序组

在“开始菜单/程序”中创建 WinRAR 程序组

界面集成/把 WinRAR 集成到资源管理器中

允许使用 关联菜单 和 拖动 来控制 WinRAR 压缩文件。

界面集成/重叠关联菜单

将文件和压缩文件关联菜单全部项目添加到 WinRAR 子菜单中。

集成界面/在关联菜单显示图标

添加小图标到 WinRAR 的文件和压缩文件关联菜单。

外科扩展/右键关联菜单条目

选择在资源管理器的 右键关联菜单 显示的项目。


压缩配置

压缩配置文件是在开始压缩操作之前，用来快速获得不同压缩选项的设置值。它可替代在每一次需要创建新压缩文件时，所必须指定的压缩文件类型、分卷大小、压缩方式和其它的选项等。您可以为您常用的压缩操作典型创建数个配置文件保存选项，并在往后从菜单选择配置文件来还原全部的选项值。

用户定义名称的压缩配置文件显示在配置文件列表中。您可以在 压缩文件名和参数 对话框选择配置文件，只要单击“配置文件”按钮，然后在弹出式列表中选择需求的配置文件名，这时保存在配置文件中的全部选项值均会被还原。WinRAR 提供了少许预先定义的配置文件，例如，创建电子邮件附加文件以及文件备份等，但如果您需要的话，也可以将它们删除。

有两种方法可以创建新配置文件。您可以打开“压缩文件名和参数”对话框，设置所有想要的选项，单击“配置文件”按钮并选择菜单项目中的“保存当前设置值成为新配置文件”。在出现的配置参数 对话框包含了配置文件名区域，让您可在此输入新配置文件的名称，而一些配置文件选项也可在此对话框使用。最重要的选项是“设置为默认配置文件”，如果您设置了它，在每一次压缩和某些压缩文件修改操作之前此配置文件便会被自动的选择。其它的选项则允许保存压缩文件和文件名、在桌面上创建连结以及在选择配置文件之后便立即运行压缩。请读取在 配置参数 对话框的叙述以获得关于这些选项的详细内容。

第二种创建新配置文件的方法是在 压缩设置 对话框单击“创建默认值”按钮。在这种状况下，您只需要在出现的对话框内设置想要的压缩选项，并单击“确定”即可。通过这种方式创建的新配置文件将会变成默认的配置文件，并永远命名为“默认配置文件”。这不像第一种方式，此种方式不提供相关的高级配置文件参数如，保存压缩文件和文件名、在桌面上创建快捷方式，以及它适合用以创建简便不附加任何问题的默认配置文件。但是如果您需要更灵活的应用时，请使用第一种方式。

您无法更改保存在配置文件内的压缩选项，但是可以更改配置文件参数，例如它的名称或是默认状态等。要编辑配置文件参数或是删除已存在的配置文件，请使用 管理配置 命令，您可以从“压缩文件名和参数”对话框内的“配置文件”菜单与“压缩设置”对话框两者之间找到此项目。使用此命令时，您可以配置新配置文件成为默认值或是从配置文件删除默认状态。

可以把密码保存在配置文件中，但是请小心，它以不安全的格式存储在注册表中。所以任何可以访问您的计算机的人可能获取存储的密码。


WinRAR.ini 文件

在默认情况下，WinRAR 将设置保存在注册表中。 在同一台计算机上安装和使用 WinRAR 时，这个方法是合理的。 不过，如果您计划在便携式介质（例如优盘）上安装 WinRAR，而且有时会在不同的计算机上运行它时，您可能更希望避免在这些计算机的注册表中保存任何特定的 WinRAR 数据。

现在可以将 WinRAR 注册表访问重定向到文本文件。 如果您在 WinRAR.exe 所位于的相同文件夹或在 %APPDATA%\WinRAR 文件夹中创建了一个空的 WinRAR.ini 文件，WinRAR 会将对于 HKEY_CURRENT_USER\Software\WinRAR 和 HKEY_LOCAL_MACHINE\Software\WinRAR 注册表项的访问重定向到这个文件。 WinRAR 将先在其自己的文件夹中搜索这个文件，然后再在 %APPDATA%\WinRAR 中进行搜索。

在“导入和导出”子菜单中使用“创建 WinRAR.ini 文件”这个命令来创建一个新的 WinRAR.ini 文件，并将注册表中现有的 WinRAR 设置复制到这个文件。 您需要将使用这个命令创建的文件复制到 WinRAR 自己的文件夹或 %APPDATA%\WinRAR 中来将其激活。

通常只在退出时将当前设置写入 WinRAR.ini，直到在内存中保存完毕为止。 将使用以下格式将它们保存为区分大小写的 UTF-16LE 文本字符串：

<root key>\<key name>=value

其中 <root key> 对于 HKEY_CURRENT_USER 而言可以是 HKCU，对于 HKEY_LOCAL_MACHINE 而言可以是 HKLM，对于由用户手动添加的全局设置而言可以是 Global。 字符串值使用引号括起来，而且字节数组具有"bin:"前缀。

您可以将全局设置更改成控制 WinRAR.ini 行为。 如果未禁用针对 WinRAR.ini 的写入权限，WinRAR 将自动创建下方列出的字符串，而且您需要编辑“=”后的一个参数来更改选项。 将在 WinRAR.ini 的顶部创建这些字符串。如果您要使用只读属性来禁用写入权限，您可以在 WinRAR.ini 中手动添加一个适当的字符串，每行一个命令。 所有这些字符串都使用 UTF-16LE 编码，而且区分大小写，请照此所述正确输入它们。 提供以下全局设置：

Global\AppData=0

阻止 WinRAR 访问 APPDATA%\WinRAR 文件夹。 通常所有文件都保存在这个文件夹中，例如注册表项或界面主题，如果指定了 Global\AppData=0，上述文件都应保存在 WinRAR.exe 所位于的相同文件夹中。 指定 Global\AppData=1 则允许访问 APPDATA%\WinRAR。

Global\Integration=0

虽然 WinRAR 将其 HKEY_CURRENT_USER 和 HKEY_LOCAL_MACHINE 注册表项的分支重定向到 WinRAR.ini，它仍然将数据写入 HKEY_CLASSES_ROOT 和注册表所需的其他部分，以便正确设置外壳（shell）扩展和文件关联。 例如，在使用集成设置对话框时就会发生上述情况。 如果您希望禁用涉及注册表的任何操作，请在 WinRAR.ini 中添加 Global\Integration=0。之后 WinRAR 将无法更改系统集成设置。 该命令还禁止创建或删除桌面和 WinRAR 程序组中的 WinRAR 快捷方式。 指定 Global\Integration=1 则允许系统集成。

Global\SaveSettings=0

禁止在 WinRAR.ini 中写回当前设置，这样在退出时将丢失对当前 WinRAR 副本做出的任何配置变更。 将只读属性设置到 WinRAR.ini 文件可以实现相同的结果。 先按照您的需求配置 WinRAR，关闭 WinRAR 将设置保存到文件，然后再添加 Global\SaveSettings=0 这个命令才是合理的。 这种模式也影响依赖 WinRAR.ini 的其他 WinRAR 组件，例如外壳（shell）扩展看不到上下文菜单项目对话框中的变更。 指定 Global\SaveSettings=1 则允许将设置保存到 WinRAR.ini。

重要注意事项

  • 不同于其他注册表变量，“AppData”变量不会被重定向到 WinRAR.ini，而且能够始终从注册表读取。 该变量定义 %APPDATA%\WinRAR 文件夹的位置，因为可以将 WinRAR.ini 保存在这个文件夹中，在访问 WinRAR.ini 前我们需要知道这个变量的值。
  • 如果 winrar.ini 与 WinRAR 安装程序 .exe 文件位于同一文件夹中，并且较早的版本不可用，则在完成安装后，winrar.ini 将被复制到正确的 WinRAR 文件夹中。


RAR.ini 文件

如果我们希望在默认情况下应用某些命令行参数，可以将它们放置在 rar.ini 文本文件中。 可以在与 WinRAR.exe 相同的文件夹中或在 %APPDATA%\WinRAR 文件夹中创建这些文件。

该文件可以包含以下字符串：

switches=<使用空格分隔任何 RAR 参数>

也可以使用以下语法为各个 WinRAR 命令指定单独的参数集：

switches_<command>=<使用空格分隔任何 RAR 参数>

在 rar.ini 中指定的大多数参数仅在命令行模式下使用。 一些参数适用于外壳模式和命令行模式。

示例

  1. 默认情况下在命令行模式下应用 -m5 -s 参数

switches=-m5 -s

  2. 为 "a" 命令使用 -m5 -s 参数，为 "x" 命令使用 -o+。

switches_a=-m5 -s

switches_x=-o+


RAR 环境变量

使用 SET 命令，默认的参数可以添加到 RAR 的 Windows 环境变量中。 大多数在变量中指定的参数只能适用当 WinRAR 运行于 <命令行模式这种情况。 一些参数可以在 shell 和命令行模式下应用。

例子：

命令

SET RAR=-s -m5 -md64m

当运行于命令行模式时，将会强制 WinRAR 创建 固实压缩文件 并使用最优压缩方式和 64 MB 的字典。


注册表变量

在多用户环境它可以禁止访问WinRAR的配置和菜单并只提供工具栏上的基本功能。如果您需要这样做，创建注册表键 :

HKEY_CURRENT_USER\Software\WinRAR\Policy

或

HKEY_CURRENT_USER\Software\WinRAR\Policy

HKEY_LOCAL_MACHINE 中的这个键比 HKEY_CURRENT_USE 的优先级更高。

这个键可以包含下列值:

键名 | 键值 | 描述
Menu | DWORD | 如果设为 0，禁用 WinRAR 主菜单。
Settings | DWORD | 如果设为 0，禁用“设置”和“选择工具栏按钮”对话框。
Password | DWORD | 如果设为 0，禁用压缩密码改变。这可能对避免加密重要数据有用。
OrgPasswords | DWORD | 如果设为 0，禁用 "管理密码" 对话框。这不禁用已经存储在此对话框中的密码，所以您需要在设置 OrgPasswords 变量前删除它们。
Shutdown | DWORD | 如果设为 0, 禁用 "结束时" 压缩选项, 这样用户不能关机，睡眠，休眠或重启 PC。
Benchmark | DWORD | 如果设置为 0，则禁用 "Benchmark" （基准测试）命令。在多用户环境 "Benchmark" 命令可能滥用共享的计算资源。

Policy 改变后可能需要重启 WinRAR。 Policy 键不影响控制台 RAR (rar.exe 文件)，所以在多用户环境下要更好的安全性， 您可能需要删除 Rar.exe 并仅保留 WinRAR.exe。

WinRAR 使用 HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer 注册表项中 NoDrives DWORD 值的位掩码来隐藏一个或多个驱动器。将其设置为 1 来 隐藏 A：，2 用来隐藏 B：，4用来隐藏 C：，以此类推。允许隐藏多个驱动器。例如， 十进制 12（4 + 8）将隐藏 C：和 D：驱动器。

您也可以在 HKEY_CURRENT_USER\Software\WinRAR\Paths 注册表键值的字符 串值 "AppData" 里指定新的路径到 WinRAR 补充文件，以覆盖 %APPDATA%\WinRAR 文件夹的位置。


RARFILES.LST -设置在固实压缩文件中的文件顺序

固实压缩文件中的文件通常是以扩展名作排序的，也可以使用特别的文件 rarfiles.lst (此文件必须在 Winrar.exe 所在的文件夹或 %APPDATA%\WinRAR 文件夹) 设置代替的文件顺序。它在 WinRAR 中已有提供，但是也可以根据用户的需要自定义。这是个纯文本文件，定义了当固实压缩文件创建时的文件顺序。文件 rarfiles.lst 可包含文件名，通配符和特别的项目 - $default。默认的项目定义了与 rarfiles.lst 中其它项目不符合时，文件在顺序列表中的位置。

提供增进压缩性能和速度操作的秘诀:

  • 可能的话在压缩文件中将类似的文件组在一起;
  • 频繁访问的文件放在起始的位置上。

通常位置越靠顶端的掩码优先级越高，但是这个规则存在一个例外。如果 rarfiles.lst 包含两个掩码，并且所有文件不仅匹配第一个掩码，也匹配第二个掩码，第一个掩码将拥有更高的优先权，即使它被放到第二个后面。例如，存在 *.cpp 和 f*.cpp 掩码的情况下，f*.cpp 拥有更高的优先权，所以“filename.cpp”的位置将根据‘f*.cpp’来选择，而不是‘*.cpp’。

rarfiles.lst 的示例：

file_id.diz
readme.*
*.doc
*.txt
*.hlp
*.inf
*.exe
*.dll
$default
*.rar


图形界面 RAR 和 ZIP 自解压模块(Default.SFX 和 Zip.SFX)

使用这两种模块您可以创建 Windows GUI (图形模式)的 自解压文件。

使用 Default.SFX 模块于 RAR 压缩文件 以及 Zip.SFX 给 ZIP 压缩文件。

WinRAR x64 也包括 Default64.SFX 和 Zip64.SFX，64 位自解压模块。默认 WinRAR x64 使用 32 位版本，但是您可以在 自解压选项: 模块 对话框中选择 64 位模块。64 位自解压压缩文件仅可在 Windows x64 中工作。

这些模块均支持简易的 Setup 命令和命令行选项。使用下面的链接读取相关信息。

  • 自解压安装命令;
  • 自解压命令行选项。

注意

  1. 在自解压模块包含的 Windows 资源是允许修改成您所需要的样子的。例如，您可以在起始对话框中显示您希望的位图。WinRAR 并不提供修改资源的工具或文档。这是个很复杂的过程，如果您要如此做，您必须有资源编辑器，并知道要怎样使用它们。但如果标准的自解压对话框即可满足您的话，您就不需要再修改资源了。 在自解压模块包含的 Windows 资源是允许修改成您所需要的样子的。例如，您可以在起始对话框中显示您希望的位图。WinRAR 并不提供修改资源的工具或文档。这是个很复杂的过程，如果您要如此做，您必须有资源编辑器，并知道要怎样使用它们。但如果标准的自解压对话框即可满足您的话，您就不需要再修改资源了。如果您仅仅要改变自解压的徽标或图标，您可以使用 高级自解压选项 对话框中的“文本和图标”。
  2. 默认情况下，图形界面自解压压缩文件结束时返回的退出码和 WinRAR 退出码 一样。可以通过 SetupCode 命令修改此行为，这样自解压压缩文件也返回安装程序退出码。


图形界面自解压模块: 安装命令

WinRAR 图形界面自解压模块 支持简单的安装命令。您可以把它们输入到自解压的 压缩文件注释 中。下面是 Setup 命令的叙述，在命令上单击可获得详细描述。

Delete | 解压前先删除文件
License | 显示程序的许可协议
Overwrite | 选择文件的覆盖模式
Path | 设置默认目标路径
Presetup | 指定解压前运行的程序
SavePath | 存储目标路径
Setup | 指定解压后运行的程序
SetupCode | 等待安装程序结束并返回它的退出码
Shortcut | 创建解压文件的快捷方式
Silent | 跳过开始时的对话框
TempMode | 解压压缩文件到临时文件夹
Text | 添加文本到自解压对话框文本窗口
Title | 设置自解压对话框标题
Update | 选择更新模式

自解压模块扩展命令参数中的环境变量，因此它被允许使用命令：

Path=%temp%\myapp

Setup=mysetup.exe %sfxpar%

（参见 Setup 的 sfxpar 变量描述）。

这里您可以查看 完整安装脚本的简易示例。


图形界面自解压模块: 命令行选项

WinRAR 图形界面自解压模块 支持下列数个命令行选项。

选项 | 描述
-d<路径> | 设置解压文件的目标路径。
-p<密码> | 指定加密的自解压压缩文件的密码。
-s, -s1, -s2 | 缄默模式。参数 -s 是 -s1 的简明形式。-s 和 -s1 都隐藏 SFX 对话框和解压进程。-s1 也会隐藏 许可 对话框。-s2 隐藏启动对话框，但是显示解压进程。
-sp<参数> | 如果应用程序在Setup自解压命令中没有指定任何参数，您可以使用此参数定义参数传递给此应用。如果Setup命令中已经有了参数，此参数被忽略。安装程序也能从自解压命令行环境变量中读取完全的自解压命令行。sfxpar 环境变量仅包含 SFX 命令行参数，而不带前面的模块名称。

如果您需要在命令行参数中包含引号标记，使用两个连续的引号。


控制台 RAR 自解压模块(WinCon.SFX)

使用此模块，您可以创建 自解压文件，可以在 Windows 命令行模式下运行解压。此模块无法在 MS DOS 下运行。

WinRAR x64 包含了 WinCon64.SFX,这是 64 位版本的自解压模块。默认 WinRAR x64 使用 32 位版本， 但是您可以在 自解压选项: 模块 对话框中选择 64 位模块。结果是 64 位自解压压缩文件仅能在 Windows x64 中运行。

此模块支持了下列的命令行参数参数：

-x 从压缩文件解压 (默认动作 )

-t 测试压缩文件

-v 压缩文件的内容详细列表

-? 显示帮助

控制台自解压压缩文件结束时的退出码和 WinRAR 退出码 一样。


常见问题

常见问题集

常见问题列表

问: 我一直不知道如何使用 WinRAR 来解压文件。

问: RAR 包含了许多种不同的压缩“方法”，什么是使用它们的有利和不利条件，您是否可以推荐哪一个适合于各种情况使用呢？

问: 我常听到许多关于“固实”的压缩文件，到底它们是什么以及我该如何使用它们？

问: 我的站点(E-mail 系统，FTP 服务器等 ) 用户如何在当 RAR 共享软件的 40 天试用期限满之后，从 RAR 压缩文件解压文件呢？

问: 哪里可以获得最新版本的 WinRAR？

问: 当解压时，我收到了“校验和错误”的信息，它代表什么意思？

问: 我从多重固实的分卷压缩 RAR 档中解压时失败，因为其中一压缩分卷损坏了。请帮帮我！

问: 我忘记了我的密码请帮帮我！

问: 为什么 WinRAR 不能删除在 Windows 临时文件夹中的临时文件?

问: 为什么 WinRAR 不能在我的压缩文件中使用 4096 K 字典?

问题和答复

问: 我一直不知道如何使用 WinRAR 来解压文件。

答: 请读取 图形界面和命令行模式 主题。它包含了以数种不同的方式来解压的方法。

问: RAR 包含了许多种不同的压缩“方法”，什么是使用它们的有利和不利条件，您是否可以推荐哪一个适合于各种情况使用呢？

答: 此问题我回答于帮助主题的 怎样优化压缩设置 中。

问: 我常听到许多关于“固实”的压缩文件，到底它们是什么以及我该如何使用它们？

答: 请参阅主题 固实压缩文件

问: 我的站点(E-mail 系统，FTP 服务器等 ) 用户如何在当 RAR 共享软件的 40 天试用期限满之后，从 RAR 压缩文件解压文件呢？

答: 在 RAR 散布的压缩文件中包含了一个免费的 unRAR 公用程序，UNRAR.EXE，可任意使用，而不需要付授权费用，只要任何人有需要从 RAR 所创建的压缩文件解压时。这就像附加的“红利”一般，部分的 UNRAR 原始码可在下列网址获得 www.rarlab.com。请注意，RAR 的运算法是私人资产且您不得以 UNRAR 原始码将它做反向还原工程。

问: 哪里可以获得最新版本的 WinRAR？

答: 请访问 WinRAR 网络主页 www.rarlab.com。

问: 当解压时，我收到了“校验和错误”的信息，它代表什么意思？

答: 因为压缩文件受损或是硬件问题的其中一种让解压的文件损坏，但有 恢复记录 时，您可以试着 修复 它，除此外是不可能恢复受损的数据的。请注意，在 固实压缩文件 的情况下，受损文件之后的全部文件将会失去。

问: 我从多重固实的分卷压缩 RAR 档中解压时失败，因为其中一压缩分卷损坏了 。请帮帮我！

答: 如果您的压缩文件有 恢复卷，把它们放在您的 RAR 分卷所有的目录中并点击第一个恢复卷(REV 文件)开始恢复。
如果没有恢复卷或它们不起作用，尝试对损坏的卷使用 修复 命令。然后重命名恢复卷 fixed.arcname.rar (或rebuilt.arcname.rar，如果恢复记录不存在的话) 为实际的卷名并尝试再次从第一个分卷解压您的压缩文件
如果您希望提高您的有数据损坏多卷 RAR 压缩文件被成功修复的可能性，请在创建它们时使用恢复记录和恢复卷并且最好避免使用 固实压缩 模式，但非固实压缩文件可能导致较低的压缩率。

答: 在最首先，当您保存压缩文件到不可靠的磁盘，如软盘时，您必须使用 RAR 恢复记录。通常，这种例子是不推荐创建成固实压缩文件的，而使用常规 (非固实)模式来替代。

如果您有受损的固实压缩分卷，请尝试 修复 损坏的分卷。当创建压缩文件时使用 RAR 恢复记录，这时会有些帮助。您可以使用 显示信息 命令来检查恢复记录的存在与否。重命名恢复的分卷 _recover.rar 到实际的分卷名，并尝试从第一个分卷来进行新近的修复 (如果无法使用修复，WinRAR 会创建 _reconst.rar)。

问: 我忘记了我的密码请帮帮我！

答: WinRAR 加密并没有任何的后门程序。即使我自己的任何压缩文件，如果我忘记了密码，我也无法将它们恢复。所以在这种状况下请不要要求我帮忙您。

问: 为什么 WinRAR 不能删除在 Windows 临时文件夹中的临时文件?

答: 它是生在您使用拖动来解压文件或用外部查看器打开被压缩的文件时产生的。在某些情况下 WinRAR 关闭后文件可能仍然被使用，没有可靠的方法来探测外部程是否仍然需要这些解压的文件。所以 WinRAR 不会立即删除它们，相反，当您下一次运行 WinRAR 时，所有的超过一小时的临时文件夹会被删除。

如果您解压文件时根本不想使用临时文件夹，也可以在 WinRAR的图形模式用“解压到”命令或用关联菜单的“解压到”项目，而不是用拖动。

问: 为什么 WinRAR 不能在我的压缩文件中使用 4096 K 字典?

答: 即使您在压缩设置中指定 4096 K 字典大小，在创建新的压缩文件时如果总的达到的数据大小少于字典大小的两倍， WinRAR 可以自动减少这个值。它不会损害压缩并会减少内存的需要。


提示

如何从压缩文件安装应用程序

您可以直接从压缩文件中安装或是运行应用程序，只要进入压缩文件后在 setup.exe 或 install.exe 程序上按下 Enter 就行了。当在有 .exe 扩展名的压缩文件按下 Enter 时，WinRAR 会解压压缩文件的整个内容到临时文件夹中，并运行该可执行文件。当可执行文件中止时，WinRAR 会测试解压的文件的修改时间，看是否更新或是新建了任何的文件，然后提供更新文件给压缩文件，之后删除临时文件夹和它的内容。

如果您要以 WinRAR 控制压缩文件，但是压缩文件关联已经被其它程序更改时

有些程序在未经询问下，会自行将它们自己注册为默认的压缩文件查看器。如果有此状况，而您要重新关联 WinRAR，请在菜单 选项 的“设置...”项目，启动 综合设置对话框，选择要关联给 WinRAR 的压缩文件格式，然后按下 Enter。

如何以静默模式安装 WinRAR

如果您必须安装 WinRAR 到比较多的计算机时，屡屡询问安装问题可能令人觉得很烦，在这种状况下您可以运行 WinRAR 安装并加上参数 -s 来跳过全部的问题并使用默认值代替。


WinRAR 许可

END USER LICENSE AGREEMENT OF SIMPLIFIED CHINESE RAR NON-COMMERCIAL PERSONAL EDITION
简体中文RAR非商业个人版最终用户许可协议

The following agreement regarding RAR (and its Windows version - WinRAR) archiver SIMPLIFIED CHINESE NON-COMMERCIAL PERSONAL EDITION - referred to as "software" - is made between win.rar GmbH - referred to as "licensor" - and any natural person referred to as "user" who is installing, accessing or in any other way using the software.
以下关于 RAR（及其 Windows 版本 - WinRAR）压缩文件管理器简体中文非商业个人版（下称“本软件”）的协议在 win.rar GmbH（下称“许可人”）和任何安装、访问或以其它方式使用本软件的自然人（下称“用户”）之间订立。

  1. The author and holder of the copyright of the software is Alexander L. Roshal. The licensor and as such issuer of the license and bearer of the worldwide exclusive usage rights including the rights to reproduce, distribute and make the software available to the public in any form is win.rar GmbH, Berlin, Germany. The simplified Chinese non-commercial personal edition is exclusively distributed in the People's Republic of China at www.winrar.com.cn and its operator is holder of the intellectual property rights of the localization of this SIMPLIFIED CHINESE NON-COMMERCIAL PERSONAL EDITION.
    本软件的作者及版权持有人为 Alexander L. Roshal。Alexander L. Roshal授权德国柏林的win.rar GmbH 公司作为本软件许可证的独家许可人和授权人，在全球向用户授权（包括复制、发布和以任何形式向公众提供本软件）。本软件的简体中文非商业个人版在中华人民共和国境内由www.winrar.com.cn网站独家分发，该网站的运营商在中华人民共和国境内独家享有和行使该软件汉化中文版本的知识产权。
  2. The software is restricted to be used by natural persons and for non-commercial usage. This means that any natural person may use the software within the People's Republic of China at no charge. Any use of the software by any organization, or any usage of the software by natural person for commercial purposes, will infringe the right of the licensor and its affiliated partners, and may result in civil or criminal prosecution.
    本软件只限于自然人及非商业用途的使用。这表示任何自然人均可在中华人民共和国境内以非商业用途免费使用本软件。任何组织使用本软件，或任何自然人基于商业用途使用本软件均构成对许可人及其附属合作伙伴的权利侵害，可能导致民事或刑事追究。
  3. The software will be freely distributed, with exceptions noted below, provided the distribution package is not modified in any way and accessed through legal channels, including official website of www.winrar.com.cn and its authorized third party websites.
    本软件可免费分发（除下列例外），分发前提为分发包未以任何形式被修改并且分发包通过合法渠道获得，获得渠道包括：官方网站www.winrar.com.cn及其运营商授权的第三方网站。
    1. Nobody may distribute separate parts of the package, with the exception of the UnRAR components, without written permission.
      任何人未经书面许可的情况下，不得再分发除了 UnRAR 组件之外的本软件包的任何单独部分。
    2. The software may not be distributed inside of any other software package without written permission. The software must remain in the original unmodified installation file for download without any barrier and conditions to the user such as collecting fees for the download or making the download conditional on the user giving his contact data.
      在未经书面许可的情况下，本软件不得在任何其它软件包中发布。本软件必须保持以未经修改的原始安装文件而供下载，而不得对用户附带任何障碍或条件，例如收取下载费用，或以用户提供联系信息为前提来提供下载。
    3. The unmodified installation file of the software must be provided pure and unpaired. Any bundling is interdicted. In particular the use of any install or download software which is providing any kind of download bundles is prohibited unless granted in written form.
      本软件未经修改的安装文件必须以纯净而独立的形式提供。禁止任何形式的捆绑。尤其禁止使用任何安装或下载软件来提供任何下载捆绑，除非获得书面形式同意。
    4. Hacks/cracks, keys or key generators may not be included, pointed to or referred to by the distributor of the software.
      本软件的分发者不得包含、指向或引用黑客/破解、注册文件及注册文件生成器。
    5. In case of violation of the precedent conditions the allowance lapses immediately and automatically.
      违反上述条件的情况下，许可自动立即失效。
  4. The software will display a dialog window. Depending on the software version and configuration such dialog can contain either a predefined text and links loaded locally or a web page loaded from the internet. Such web page can contain materials according to the licensor's choice, including advertisement. When opening a web page, the software transfers only those parameters which are technically required by HTTP protocol to successfully open a web page in a browser, thus the licensor only provides the media for such content. If the user purchase any service or product based on the advertisement, such transaction only occurs between the user and the provider of such product or service, and has nothing to do with licensor. The licensor shall not be liable to any legal responsibility that arises from between the user and the provider of the product or service. The user shall not remove or mask the advertisement in the software with any technical methods. If the user wishes to use the software in a business environment or without any advertisement in the software; he/she may purchase the commercial version of the software at www.winrar.com.cn
    本软件会显示一个对话框。取决于软件版本和配置，此对话框可能包含预定义文本和本地加载的链接，或者从互联网上加载的网页。按照许可人的意愿，此类网页可能包含不同的内容，包括广告。当打开网页时，本软件仅传输 HTTP 协议在技术上要求的那些参数，以便在浏览器里成功打开一个网页，因此许可人仅提供此类内容的媒介。如果用户基于该广告而购买任何服务或商品，其交易行为仅存于该用户与该商品或服务的提供者之间，与许可人无关。许可人不承担用户与该商品或服务的提供者之间所产生的任何法律责任。用户不得以技术手段去除或屏蔽本软件所附带的广告。如果用户希望在商业环境使用本软件或使用不附带广告的版本，可在www.winrar.com.cn购买本软件的商业版本。
  5. The software is distributed "as is". No warranty of any kind is expressed or implied. You use at your own risk. Neither the author, the licensor nor the distributor of the licensor will be liable for data loss, damages, loss of profits or any other kind of loss while using or misusing this software.
    本软件“按原样”发布。不提供任何明示或暗示的担保。您的使用需要自己承担风险。无论作者、许可人或许可人的经销商，均不对使用或误用本软件时发生的数据丢失、损坏、利润损失或其它任何形式的损失而负责。
    1. No one shall use the software for any illegal purposes, or in violation of any law, regulations or policies of the People's Republic of China.
      任何人均不得违反中国相关法律、法规及政策的规定使用本软件，或将本软件用于任何违法目的。

    2. The user shall use the software with due respect of intellectual property rights of the rights holder, and shall not modify or remove the copyright marks or other intellectual property right marks in the software.
      用户在使用本软件过程中应尊重权利人的知识产权，不得修改或去除本软件所附带的版权及其它知识产权标识。
  6. You may not use, copy, emulate, clone, rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer the software. Neither RAR binary code, WinRAR binary code, UnRAR source code or UnRAR binary code may be used or reverse engineered to re-create the RAR compression algorithm, which is proprietary, without written permission. The software may be using components developed and/or copyrighted by third parties. Please read "Acknowledgments" help file topic for WinRAR or acknow.txt text file for other RAR versions for details.
    您不得使用、复制、仿真、克隆、租借、出租、出售、修改、反编译、反汇编或反向工程本软件。
    未经书面许可，无论 RAR 的二进制代码，WinRAR 的二进制代码，UnRAR 源代码或 UnRAR 的二进制代码均不得被使用或进行反向工程来重新创建专有的 RAR压缩算法。
    本软件可能使用了由第三方开发或持有版权的组件。请阅读 WinRAR 帮助文件的 “感谢”主题，或其它RAR版本 的 acknow.txt 文本文件来了解详情。
  7. This License Agreement is construed solely and exclusively under laws of the People's Republic of China.
    本许可协议仅依据中国法律而订立。
    1. This agreement is made in Chinese and English, both two versions have the same meaning. If any inconsistency exists, the Chinese version shall prevail.
      本协议采用中英文两种版本，两种版本的含义相同。在中国境内使用的情况下，如果有任何不一致的地方，应以中文版本为准。
    2. The licensor shall be responsible for interpretation of the agreement. Anytime the licensor made any modifications to the agreement, the modified version shall be applicable to the user automatically.
      本协议由许可人负责解释。任何时候许可人对本协议做出任何修改，修改版本自动适用于用户。
    3. Installing and using the software signifies acceptance of these terms and conditions of the license. If you do not agree with the terms of this license, you must remove all software files from your storage devices and cease to use the software.
      安装并使用本软件意味着接受本许可的这些条款和条件。如果您不同意本许可的条款，您必须从您的存储设备中删除本软件全部文件并终止使用本软件。


购买信息

您需要购买 WinRAR 许可证，因为成为注册用户后，您可以

  1. 鼓励我们以后对 WinRAR 的开发和改进，制作出新的 WinRAR；
  2. 可在商业或是其它环境下使用 WinRAR；
  3. 全球范围内通过 Email 和 WinRAR 支持站点获得支持和帮助。

购买软件

如果您想要成为 WinRAR 的正式注册用户，请访问 WinRAR 中文网站 www.winrar.com.cn。

注册软件

在您收到注册 key 文件后，请把它复制到 WinRAR 文件夹或 %APPDATA%\WinRAR folder 文件夹中。 如果这个 key 是 RAR 压缩文件，请从压缩文件中解压 key 文件来注册您的 WinRAR。


添加快捷键

添加快捷方式

在这里您可以输入新建快捷方式的参数，它将被自解压程序在解压后创建。这个对话框包含下列区域：

创建到哪里

选择您希望创建快捷方式的位置。

源文件名

被压缩的文件名。

目标文件夹

创建快捷方式的文件夹，如果它不存在，它将被自解压文件创建。

快捷方式描述

描述快捷方式的文本。

快捷方式名

是由自解压程序创建的 .lnk (快捷方式)文件的文件名。

快捷方式图标

快捷方式关联的图标文件名称。如果保留空白，会使用默认图标文件。如果图标文件名没有包含完全路径，自解压压缩文件会在包含解压后文件的文件夹中搜索图标文件。

只有“创建到哪里”和“源文件名”是必需的，所有其它的参数可选。


%APPDATA%\WinRAR 文件夹

旧的 WinRAR 版本辅助文件，象注册 key、导出设置文件 setting.reg 、主题或日志文件，存储在 WinRAR 可执行文件所在的目录中。在 Windows Vista 和以后版本的 Windows 中不推荐在程序文件夹中保存这些数据。软件尝试这么做的时候可能会失败。推荐的应用程序数据的位置是称为 %APPDATA% 文件夹的子文件夹。

%APPDATA% 的真实路径依赖于 Windows 版本。要打开 %APPDATA% 文件夹，如下做：运行 Windows Explorer 或打开“我的电脑”窗口，在地址栏输入 %APPDATA% 并按下 Enter。WinRAR 存储它的文件在 %APPDATA% 的“WinRAR”子目录中。您可以在 Windows 资源管理器地址栏中输入 %APPDATA%\WinRAR 直接打开 WinRAR 数据文件夹。

您需要手动访问 %APPDATA%\WinRAR 的情况是很少的，包括某些情况，例如复制 setting.reg 到其它计算机或使用某些外部查看器浏览错误日志。

注意 WinRAR 会在 %APPDATA%\WinRAR 和 WinRAR 程序文件夹尝试搜索注册 key 和 setting.reg 文件，%APPDATA%\WinRAR 优先。

如果您要覆盖 %APPDATA%\WinRAR 的位置，您可以在注册表键 HKEY_CURRENT_USER\Software\WinRAR\Paths 中设置字符串的值 "AppData" 来包含到 WinRAR 支持文件的新路径。


压缩文件类型

  • RAR 与 ZIP 对比
  • 支持其它压缩文件格式
  • 固实压缩文件
  • 自解压文件 (SFX)
  • 分割压缩文件 (多卷)
  • 恢复卷
  • 加密
  • 压缩文件注释
  • 保护压缩文件防止损坏
  • 锁定压缩文件
  • 怎样选择优化的压缩设置


压缩时添加密码

当您在创建过程时，您可以在这个对话框中输入要应用到压缩文件中的密码。输入的密码只会对单个的当前压缩操作有用，如果您需要改变整体的密码时，您必须使用 文件菜单 的“设置默认密码”命令来输入它。

如果“显示密码”选项是禁用的话，您将被要求输入密码两次，以确认是否正确。

如果您设置了“加密文件名”选项， WinRAR 不只加密数据，而且加密所有包括文件数据、文件名、大小、属性、注释和其它块等所有可感知的压缩文件区域，所以它提供了更高的安全等级。在压缩文件中使用这个命令加密，没有密码甚至不可能查看文件列表。这个操作值可在把数据压缩成 RAR 压缩文件时有用，它不支持 ZIP 格式。

“ZIP 传统加密”选项仅当添加文件到 ZIP 压缩文件时才可用。它允许使用 ZIP 传统加密算法。如果关闭此选项，ZIP 压缩文件将以 AES-256 加密，它更安全，但可能与一些较老版本的 unzip 工具不兼容。

如果您已经保存了一些密码，您可以使用密码对话框中输入密码区域的辅助下拉列表或自动完成功能访问它们。点击“管理密码”按钮打开“管理密码”对话框，在这里您可以保存常用的密码。

如果保存的密码受主密码保护，您需要输入主密码并点击“确认”才能访问它们。如果输入的密码不匹配主密码，此对话框会将其视为普通密码用于压缩文件的各项操作。


清除历史记录

设置“清除最近打开的压缩文件名称”这个选项来删除最近打开的压缩文件名称， 它们在“文件”菜单底部显示。

设置“清除对话框中的下拉列表”这个选项来删除含有之前输入值的这些列表。 这些值的示例包括归档对话框中的压缩文件名称、解压缩对话框中的目标路径、 以及其他对话框中的更多此类列表。


“命令参数”对话框

此对话框允许在运行中切换“结束时”选项而不中断压缩压缩、解压或测试操作，以便您能在操作完成后关闭 PC 电源，休眠，睡眠或重启。

对于压缩操作，在这里可以改变压缩方式，但是 WinRAR 不能在此对话框转换到"存储"模式。


高级压缩参数

通常没有必要改变这个对话框的设置，而且允许 WinRAR 自动选择优化参数是安全的。请注意不正确的使用这个对话框可能导致非常严重的运行和压缩损失，所以只有在您清楚您所作的时候，才能改变它的参数。

下面的这些设置大部分仅被 RAR 4.x 压缩格式支持。这些设置都不可用于 ZIP。只有 delta 压缩和 32 为可执行压缩可用于 RAR 5.0 压缩文件。

这个对话框包含下列选项。

文本压缩/(自动/强迫/禁用)

文本压缩可以提高纯文本文件的压缩率，但是它的压缩和解压缩速度在利用多处理器核心时比常规压缩算法差多了。所以此选项的默认状态是“禁用”。您可以修改它为“自动”来让 WinRAR 对合适的数据自动选择此算法。“强迫”把文本压缩算法应用到所有数据，但是使用此选项会导致压缩和解压更慢。

文本压缩/预测顺序

设置 PPM 算法 ( RAR 文本压缩的核心)的预测顺序。值可以是 2 - 63。通常高的值会略微提高多余数据的压缩率，但是必须有作够的内存来用于 PPM。在缺乏内存的条件下结果可能相反。更高的顺序值会减慢压缩和解压的速度。如果这个区域设为 0 ,WinRAR 会自动选择顺序。

文本压缩/使用内存，MB

PPM 可用的以兆字节位单位的内存 (1-128)。更高的值可以提高压缩率，但是注意 PPM 压缩和解压使用的内存大小相等，所以创建一个压缩文件时如果分配太多的内存，其他人在安装了比较少内存的机器上解压它时可能出现问题。如果这个区域设为 0 ,WinRAR 会自动选择内存大小。

音频压缩/(自动/强制/禁止)

在“自动”模式下，WinRAR 将根据源数据和是否选择“普通”、“最好”或“较好”压缩模式决定什么时候使用音频压缩。“强制”将把音频压缩算法应用到所有压缩数据上。只有当您确认所有的要压缩的文件完全由未加工的音频数据构成时才激活它。“禁止”从根本上阻止音频压缩算法。

音频压缩被设计用来处理未加工的音频数据，象 WAV 文件。它不能增加已经被压缩的音频文件的压缩率，象 MP3。

音频压缩/声道

声道的字节数 (可以是1 - 31)。

RAR 拆分多位声道成单位声道，例如，两个 16位音频声道可以被 RAR 看作每个宽一字节的四个声道。如果这个区域设为 0 ,WinRAR 会自动选择声道数。

真彩压缩:/(自动/强制/禁止)

在“自动”模式下，WinRAR 将根据源数据和是否选择“普通”、“最好”或“较好”压缩模式决定什么时候使用真彩压缩。“强制”将在所有压缩数据上应用真彩压缩算法。只有当您确认所有被压缩文件完全由真彩 (RGB) 数据构成才时激活它。“禁止”从根本上禁止真彩压缩算法。

真彩压缩被设计用来处理未处理的 RGB 基本颜色数据，象 24-位 BMP 文件。它不能增加已经被压缩的文件的压缩率，象 JPG。

启用 x86 可执行文件压缩

允许 WinRAR 使用特别为这种数据类型优化的算法提高 Intel x86 可执行文件的压缩率。它对于 32 位和 64 位的 x86 可执行文件都会有效率。

启用 delta 压缩

允许 WinRAR 使用特别为这种数据类型优化的算法提高结构表数据的压缩率。

默认按钮

重新设置这个对话框的所有值。


关联菜单项目

"选择资源管理器中显示的项目" 选项组让您能选择添加到资源管理器关联菜单中的项目。当您在资源管理器和桌面上的一个文件和压缩文件图标上点击鼠标右键时，这些项目会显示。

“新建子菜单项”选项允许您删除 Windows 关联菜单内“新建”子菜单中的“WinRAR 归档”和“WinRAR ZI P归档”这两个条目。这些选项可能会在关闭“设置”对话框后触发用户账户控制提示，因此，只有在“关联菜单项”及其父“设置”对话框中同时按下“确定”后，才应用其新状态。

"拖放上下文菜单" 选项可以用于从上下文菜单里删除 WinRAR 压缩和解压命令，在使用鼠标右键拖放文件后会显示此上下文菜单。默认启用这些选项，因此 WinRAR 建议在鼠标右键拖放之后使用一个目标文件夹作为目的地来压缩文件并解压文件。

"在哪里检查自解压文件" 选项控制右键关联菜单中自解压模块的进程。当点击右键点击 ".exe" 文件时候，检查可执行文件的内容判断它是否是 自解压(SFX)压缩文件会导致一定的延迟， 因为 WinRAR 需要读取并分析文件数据来判断它是否是自解压文件。对较快的本地硬盘，这个延迟是微不足道的，但是在较慢的网络磁盘上却是很明显的。 此组选项允许单独启用或禁用本地硬盘、网络磁盘和其它像U盘和CD-ROM自解压检查。当右击自解压压缩文件时您不会看到自解压相关的关联菜单。所以当您感受到右击 ".exe" 文件有延迟时可以禁用这些选项。

如果右键单击一个压缩文件，通常上下文菜单里仅包含提取命令。您可以通过在“总是显示压缩项目”里指定一个或多个独立的掩码来修改此现象，以便始终为这些文件类型显示压缩命令，即使文件被识别为压缩文件。如果您希望对于所有压缩文件都同时显示压缩命令和提取命令，请在此处留下 "*" 符号。


“定义卷大小”对话框

此对话框允许自定义预定义的卷大小，和 压缩文件名和参数 中的“分割卷, 大小”关联。

使用“预定义大小”选项来选择在列表中要显示的磁盘大小。如果您需要的值不在“预定义大小”中时，您可以在“用户定义大小”指定四条附加的列表项目。只需要为您的项目输入一个卷标和大小。卷标是任何的短文本字符，大小是单位为字节的数字。按照您的意愿可以忽略卷标。

在“其它项目”中的“‘自动检测’字符串”控制在列表中有“自动检测”项目。如果您在压缩到可移动媒体时永远不会使用自动检测卷大小时，您可以关闭此选项来让列表更短。

“历史条目”选项定义被显示在顶部列表中以前被用户输入的项目的个数。如果您不希望保存手动输入的卷大小，您可以把它设为零。此参数的最大值是 9。


输入默认的密码

在此对话框，您可以输入默认的密码，这可应用在添加、解压、测试和查看选项时。

如果“显示密码”选项被禁用并且压缩文档操作时需要密码，您将会被要求输入密码两次来进行正确性的确认。

如果您设置了“加密文件名选项”，WinRAR 不只加密数据，而且加密所有包括文件数据、文件名、大小、属性、注释和其它块等所有可感知的压缩文件区域，所以它提供了更高的安全等级。在压缩文件中使用这个命令加密，没有密码甚至不可能查看文件列表。这个操作值可在把数据压缩成 RAR 压缩文件时有用，当使用默认密码加密或压缩成 ZIP 格式时，它被忽略。

“ZIP 传统加密”选项仅当添加文件到 ZIP 压缩文件时才可用。它允许使用 ZIP 传统加密算法。如果关闭此选项，ZIP 压缩文件将以 AES-256 加密，它更安全，但可能与一些较老版本的 unzip 工具不兼容。

如果您在密码对话框中启用了“用于所有压缩文件”选项并且设置了一个空的字符串作为密码，解压和测试命令会跳过所有加密的文件和压缩文件。在此选项关闭前，所有尝试打开加密的文件和压缩文件的操作。 这种模式在您需要无人值守的解压一组压缩文件并且希望避免密码提示时很方便。 “用于所有压缩文件”对于非空密码无效，因为非空密码自动应用于所有没有附加选项。

如果您已经保存了一些密码，您可以使用密码对话框中输入密码区域的辅助下拉列表或自动完成功能访问它们。点击"管理密码"按钮打开"管理密码"对话框，在这里您可以保存常用的密码。

如果保存的密码受主密码保护，您需要输入主密码并点击“确认”才能访问它们。如果输入的密码不匹配主密码，此对话框会将其视为普通密码用于压缩文件的各项操作。


执行压缩操作

一个压缩操作被执行，一直等到结束或按下“取消”按钮立即中断它。当压缩或解压时，您也可以按下“后台操作”和“暂停”按钮。“后台操作”把 WinRAR 最小化到任务栏中。当完成当前操作后或您单击任务栏上的小 WinRAR 图标它会自动复原。“暂停”按钮暂停当前操作，您需要按下“继续”来恢复它。

不管在压缩还是解压时，命令窗口上部的进度条都会显示当前文件的处理进度。

当压缩和某些解压操作期间，指示总操作进程的一个附加进度条会在命令窗口的下部显示。它的外观依赖于 常规设置对话框 中的“Windows 进度条”选项。如果此选项关闭并且 WinRAR 正在压缩文件，总的操作进度条会使用 3 色显示。黄色部分指示已经被压缩的数据，而亮灰色表示已读取的数据，所以比较黄色和灰色，您可以估计压缩率。如果“Windows 进度条”打开，仅使用两种颜色，但是在这两种情况下压缩率也显示在此窗口的一个单独的行中。

在压缩、解压和测试操作期间，您可以使用“模式”按钮来即时切换“结束时”的状态，以便您能在操作完成后关闭 PC 电源，休眠，睡眠或重启。对于压缩操作，您也可以在这里改变压缩模式，但是 WinRAR 不能在此对话框中切换“存储”模式。


解压路径和选项对话框: 高级选项

在对话框中您可以指定下列选项:

文件时间

设置修改/创建/最近访问时间

Windows 文件系统为每个文件保存了三个不同的时间区域：最近修改、创建和最近访问。默认 WinRAR 只存储修改时间，但是使用压缩对话框的 时间 部分的文件时间选项您可以存储创建和最近修改的时间。这对于备份可能有用。即使所需要的时间区域在压缩文件中存在，也需要在解压对话框中设置相应的时间选项，在解压时恢复它。 这些选项的可用性取决于具体的压缩文件格式，有些格式不支持它们。

属性

不解压路径名称

如果有此设置，从压缩文件中的最上级文件夹和子文件夹选定的文件，将会解压到目标文件夹，而路径信息则会被忽略。

清除“存档”属性

在已解压的文件清除“存档”属性。此选项是为备份操作而特别设计的。

设置文件安全

这个选项意味着只能用在 NTFS 文件系统上，如果压缩文件中以前保存了文件所有者、租、访问控制和审查信息，则允许恢复它们。这对于在创建压缩文件时指定压缩对话框的 高级 部分的“保存文件安全数据”是必需的。您需要有必需的特权来使用这个功能。安全数据的处理可能降低压缩文件的处理速度，所以，只有在您理解它的含义，并且真的需要他才设置这个选项，在大多数情况下，对于家庭用户，安全处理是不需要的。

这个功能只被 RAR 压缩文件支持。

设置“压缩”属性

此选项允许解压文件时存储 NTFS“压缩”属性。WinRAR 当创建压缩文件是保存“压缩”属性，但如果此选项不被指定就不会恢复它们。

这个功能只被 RAR 压缩文件支持。

文件路径

解压相对路径

默认使用此模式。如果您在 WinRAR 界面中浏览某些压缩文件的子文件夹并启用"解压相对路径"选项，则包括在路径中的当前子目录在解压时候从文件路径中移除。 例如，如果您在压缩文件的文件夹"Backup\MyData"内并解压"Images"文件夹，它会解压为"Images"，而不是"Backup\MyData\Images"。

如果您浏览压缩文件根目录或从关联菜单启动解压，此模式工作为 解压完全路径 选项。

解压完全路径

WinRAR 解压包括路径信息在内的全部压缩文件内容。不像 解压相对路径 模式，不管当前的压缩文件夹的位置，路径信息都被完全解压。

不解压路径名

如果设置此选项，从压缩文件的根目录和从选择的子目录选择的文件都回被解压的目标文件夹中。路径信息被忽略。

解压绝对路径

如果压缩文件使用了在压缩对话框的 文件 部分的“存储包含盘符的完全路径”模式并且您设置了“解压绝对路径”选项， WinRAR 在它们的原始目录和磁盘中创建解压的文件。注意，如果您不是完全确认压缩文件不包含恶意文件则不要设置此选项。您可以在 -ep3 参数 的描述中看到更多关于“存储包含盘符的完全路径”模式的可能的好处和危险，它是与此 WinRAR 选项等价的命令行。此命令只被 RAR 和 ZIP 压缩文件支持。

删除压缩文件

永不

不删除解压过的压缩文件。

询问确认

在删除解压过的压缩文件前询问用户确认。

总是

无确认删除解压过的压缩文件。

移动到回收站

将已删除的压缩文件放入回收站。

WinRAR 仅在无错误解压后并且压缩文件中所有文件都被选择解压时才会删除压缩文件。如果您解压一个 多卷压缩文件, 则所有的卷都会被删除。

注意您可以在解压对话框的 常规 页使用“保存设置”来保存此选项的默认状态，并且它也会在命令行和关联菜单解压命令中生效。要小心使用“询问确认”尤其时“总是”模式。删除解压过的压缩文件使用不当会导致数据丢失。

其它

后台解压

在开始解压缩操作时最小化 WinRAR 到任务栏。

如果其它的 WinRAR 副本正在活动则等待

如果其它 WinRAR 副本正在创建、修改或解压压缩文件时等待，并在其它 WinRAR 任务完成后或暂停时再开始操作。如果您要执行数个压缩或解压缩任务,队列执行能帮助减少磁盘定位的次数并提高整体性能。

您可以通过在命令进度窗口单击"继续"按钮覆盖此选项。当您点击“继续”，WinRAR 会停止等待，忽略其它副本的活动。

该选项不支持 7z 压缩文件。

允许符号链接中的绝对路径

如果关闭该选项，则解压命令忽略指向目标文件夹之外的符号链接，在链接目标里带有绝对路径，多余数量的 ".."，或带有其它潜在危险的链接参数。指向解压目标文件夹之外的文件夹可能导致安全风险。仅当您确认压缩文件内容是安全的（如您自己的备份）时，才启用此选项。

总是解压 WinRAR 视为安全的链接，而无论此选项如何。

允许潜在的不兼容名称

尽管 NTFS 文件系统允许文件名称带有后缀空格和小数点，有很多 Windows 程序无法正确处理此类名称。如果选项禁用，WinRAR 会删除后缀空格和小数点，如果解压时它们存在于文件名中。


解压路径和选项对话框

此对话框启用时，您可以改变解压文件时的目标文件夹。默认的文件夹是与压缩文件所在位置的文件夹相同，但您可以使用 压缩设置对话框 来更改此默认值。您可以输入新的路径 (如果不存在时则自动创建)，在“目标路径”区域，或是从文件夹树窗格中选择一个已存在的文件夹。

对话框将自动选择您输入的文件夹树，但有小的延迟(大约 0.5s) ，如果输入的路径包含驱动器盘符并且如果此类自动选择不会花太多时间。如果文件夹不存在，或者是它的上层，或者是和输入的最相似的会被选择。另外，您也可以通过点击“显示”按钮，强制对话框立即搜索当前输入的文件夹名，这可能在打开对话框时如果您需要定位建议的文件夹时，或当自动选择因为低速而被中止时比较有用。

您可以使用新建文件夹按钮创建一个新的文件夹。它会在树窗当前选择的文件夹中创建一个文件夹或在“目标路径”中指定上次修改的。使用 F2 键重命名树窗格文件夹，Del 删除，F5 刷新树的内容。

解压对话框可以调节大小。您可以使用鼠标拖动它的边来改变大小使文件夹列表窗格有足够的空间。WinRAR 会保存此对话框的新的大小。

此对话框也提供了一些选项:

更新模式

解压和替换文件(默认)

解压全部选定的文件。

解压并更新文件

解压选定的文件，然后复制目标文件夹不存在的，或是比解压文件还要旧的。

仅刷新已存在的文件

只解压选定的文件，已存在目标文件夹和比压缩文件还旧的相同文件，如果文件在磁盘不存在，它将会被跳过。

覆盖模式

覆盖前询问 (默认)

覆盖文件之前先提示。

覆盖但不提示

直接覆盖文件，而没有任何提示。

忽略已存在的文件

这些已存在的文件将不会被覆盖。

自动重命名

如果解压的文件存在同名文件则自动重命名它们。重命名文件会生成类似“filename(N).txt”的名字，“filename.txt”是原始的文件名，“N”是一个数字。

杂项

解压压缩文件到子文件夹中

这个选项只有在一个以上压缩文件被解压时可用。它把解压的每个压缩文件的解压的内容放到单独的文件夹中，名字是基于压缩文件名产生。

保留受损的文件

当解压不正确时，WinRAR 不删除损坏的文件，例如在压缩文件已经损坏时(默认时，WinRAR 会删除此类的文件)。您可以试着从坏掉的文件中保存部分的信息。

在资源管理其中显示

解压完成后，WinRAR 打开资源管理器窗口并显示目标文件夹的内容。

保存设置

如果您希望保存解压对话框两部分(“常规”和“高级”)的当前状态，单击“保存设置”按钮。保存的设置被作为下一次激活这个对话框的默认配置。WinRAR 保存除了目标路径外的所有设置；如果您需要指定默认目标文件夹，使用 压缩设置 对话框。


解压缩路径和选项对话框： 高级选项

解压缩归档到

这些选项仅在选定几个压缩文件时可用。“目标路径”将解压的文件放置到指定的 目标文件夹。“目标路径中的子文件夹”在每个归档的目标文件夹中创建一个单独的 子文件夹。“归档文件夹中的子文件夹”为归档本身文件夹中的每个归档创建一个单独 的子文件夹。“归档文件夹”将解压的文件直接放置到归档本身的文件夹中，而无需 创建单独的子文件夹。

额外的参数

您可以在此处提供一个或多个命令行参数。如果 WinRAR 图形界面中没有与此参数相匹配的选项，则可能会很有用。例如，要忽略保存 的文件属性，并排除 .txt 文件，请将此字符串设置为：

-ai -x*.txt

在此处输入的参数将覆盖类似的图形界面的选项。请您仅在熟悉 WinRAR 的命令行语法 并清楚了解指定参数的用途时，才使用此功能。并非每个参数都在此处适用。错误使用此项 会干扰 WinRAR 的功能，甚至导致数据丢失。


解压的文件输入密码

为解压的文件输入密码

您正尝试解压一个 被加密的 文件或查看加密文件的内容，请输入密码或是取消解压。

在一次解压多个压缩文件时，您可以启用"用于所有压缩文件"选项把输入的密码应用给所有的压缩文件。如果仅处理一个文件则此选项无效。此选项的其它可能的操作是跳过加密的压缩文件。只要输入一个空的字符串作为密码并设置“用于所有压缩文件”您可以使用它对所有压缩文件只输入一次密码。

如果您已经保存了一些密码，您可以使用密码对话框中输入密码区域的辅助下拉列表或自动完成功能访问它们。点击"管理密码"按钮打开"管理密码"对话框，在这里您可以保存常用的密码。

如果保存的密码受主密码保护，您需要输入主密码并点击“确认”才能访问它们。如果输入的密码不匹配主密码，此对话框会将其视为普通密码用于压缩文件的各项操作。


压缩文件名和参数对话框: 高级选项

保存文件安全数据

此参数意味着只能在 NTFS 文件系统下使用，并允许保存文件所有者，组，文件权限和校验信息，但这必须在您先有读取它们的权限前提下。处理安全数据会减低压缩操作的速度，因此仅在如果您了解它的意义并确实需要时才设置此选项，在大多数情况，家庭用户是不需要处理安全数据的。

此参数只支持 RAR 压缩文件。

保存文件数据流

此选项只能在 NTFS 文件系统下使用，并允许保存与文件相关联的可选数据流。如果您要使用可选数据流中存储的数据时您可能需要设置它。NTFS 加密文件流不保存。

此选项仅支持 RAR 压缩文件。

把符号链接存储为链接

把 NTFS 符号链接和分析点存储为链接，以便文件或文件夹内容不被存档。这些文档项目在解压时被恢复为符号链接或分析点。解压时您需要以管理员权限运行 WinRAR 创建符号链接。 指向解压目标文件夹之外的文件夹的符号链接可能导致安全风险，在链接目标里带有绝对路径，多余数量的 ".."，或带有其它潜在危险的链接参数。这种符号链接仅当解压对话框中设置了"允许符号链接中的绝对路径" 选项或指定了-ola 参数时才会解压。 仅支持 RAR 5.0 压缩文件。

把硬链接存储为链接

如果压缩中的文件包含数个 NTFS 硬链接，会把首个硬链接作为普通文件存储，同组中剩下的硬链接作为首文件的链接存储。在解压这些文件的时候，WinARR 会创建硬链接，而不是普通文件。

您一定不要在创建压缩文件后删除或重命名压缩文件中首个硬链接，因为这导致不可能解压下面的链接。如果您修改首个链接，解压后下面链接的内容也会被修改。解压命令要成功创建下面的硬链接必须涉及首硬链接。仅 RAR 5.0 压缩文件支持。

每一卷后暂停

当使用移动磁盘创建或解压下一 卷 前， RAR 默认进行询问。这个总是强制 WinRAR 进行这样的询问。如果磁盘空间有限并且您希望创建后立即复制每一卷到其它磁盘中时，可以使用它。

此操作仅支持 RAR 卷。

使用旧风格的卷命名

默认 RAR 卷 以‘volname.partNNN.rar’格式命名，NNN的地方是卷号。RAR 4.x 压缩格式使用 -vn 参数可能转换成其它的扩展基本命名规则，卷组中第一卷文件由 .rar 的扩展名，以后卷从 .r00 到 .r99 命名。RAR 5.0 压缩文件不支持此选项和扩展基本名称。

恢复卷

这个命令只可用于创建 RAR 多卷 压缩文件时，您只需选择要创建的 恢复卷 的数目。您也可以附加一个百分号到这个参数上，这样创建的 .rev 文件的数目将等于从 RAR 卷总数获得的这个百分比。每个恢复卷可以重建一个丢失的RAR卷。您可以从 这里 获得更多信息。

后台压缩

当开始压缩操作时将 WinRAR 最小化，放在任务栏中。

完成后关闭 PC 电源

如果其它 WinRAR 副本正激活则等待

等待其它 WinRAR 副本正在创建、修改或解压压缩文件，并在其它 WinRAR 任务完成后再开始操作。如果您要执行数个压缩或解压缩任务,队列执行能帮助减少磁盘定位的次数并提高整体性能。

您可以通过在命令进度窗口单击"继续"按钮覆盖此选项。当您点击"继续"，WinRAR 会停止等待，忽略其它副本的活动。

恢复记录

指定 恢复记录 大小为总压缩文件的大小的百分比。较大的恢复记录允许恢复更严重的损坏，但是会增加压缩文件的大小和处理时间，所以 3 - 10% 比较理想。该值只有您在此对话框的 常规 页中启用了“添加恢复记录”选项时才会使用。

设置以压缩文件总大小为准的百分比 恢复记录 大小，最大容许值为 10%。较大的恢复记录允许连续损坏时更多的恢复可能，但同时也增加了压缩文件的大小，因此1 - 3% 应该是最优的数值。该输入区域只在如果您启用 常规选项 对话框的“添加恢复记录”时有效。您无法设置它为0。如果您不需要恢复记录，请关闭“添加恢复记录”选项。

压缩

打开 高级压缩参数 对话框，这里您可以配置不同的 WinRAR 压缩算法模块。这个对话框中的不正确参数甚至可能严重伤害压缩的表现，所以要认真使用。

自解压选项

选择 自解压 模块并设置例如目标路径或窗口标题等的 可选自解压参数 。请注意自解压参数仅能够应用在 Windows 图形界面模块，而不支持控制台或非 Windows 自解压模块。该“自解压选项”按钮仅在如果您启用了 常规选项 对话框的“创建自解压文件”时有效。

您可以把选定的自解压选项保存到 压缩配置 ,WinRAR 会添加命令描述的自解压参数到 压缩文件注释。

结束时

此选项允许您在压缩完成后关闭 PC 电源，休眠，睡眠或重启。操作系统必须支持相应的电源管理功能。


压缩文件名和参数对话框: 备份选项

压缩前清除目标磁盘的内容

在开始压缩操作之前，全部目标磁盘的文件和文件夹将会先被清除。如果您创建了 卷 ，在创建每一个分卷之前均会先运行清除，以避免您意外放入了非空白的可移动磁盘，但您必须确定这些磁盘不包含任何有用的信息。此选项只能应用在可移动磁盘上，硬盘则不能使用清除功能。

只添加有‘压缩’属性设置的文件

仅设置有“存档”属性的文件才被添加。无论属性是什么，这些文件夹都会被添加。此选项主要是设计用于备份操作。

压缩后清除“存档”属性

把成功压缩的文件清除“存档”属性。文件夹属性不改变。此选项主要是为备份操作设计。

打开共享的文件

允许处理已被其它应用程序打开的文件写入。如果一个应用程序允许对文件的读取访问时有帮助，但是如果文件的所有访问类型都被禁止，文件打开操作仍然会失败。

此选项有危险性，因为它允许文件被压缩，但是此文件可能正被其它的应用程序做修改，请小心使用。

按掩码样式生成压缩文件名

当创建压缩文件时，附加当前的日期字符串到压缩文件名，这对于每日的备份相当有用。日期字符串是通过指定的掩码样式格式所指定，请读取 参数 -ag 的叙述来获得掩码样式的描述。

保留以前的版本

当更新已经存在的压缩文件中的文件时，强制 WinRAR 保留以前的文件版本。老版本被改名成‘ filename;n’的位置是版本号。只支持 RAR 压缩文件。

当使用此选项时，建议在要添加的文件里避免 'filename;n' 格式的名称。此类名称可能导致重复项目，如果在压缩文件里存在较老版本的同名文件或将在之后创建。


压缩文件名和参数对话框: 注释

在此您可以指定 压缩文件注释 到新建或者更新压缩文件。您可以选择在 从文件载入注释区域输入包含注释文本文件的名称或在“手动的输入注释”窗口手动输入。


压缩文件名和参数对话框 : 文件

添加的文件

要压缩的文件和文件夹名。此区域会自动填入已选定的文件，但如果需要的话，您也可以编辑它们，或单击“附加”按钮选择更多文件添加列表。在此它允许使用通配符过滤掩码，此例子下 WinRAR 将会在当前文件夹和全部的子文件夹搜索符合过滤掩码的文件。如果您要指定多个掩码，使用空格分割它们。如果掩码包含空格，使用引号括住它。 例如，您可以输入:

*.txt *.doc "set 1.*"

则会压缩全部 .txt 和 .doc 文件以及匹配 "set 1.*" 掩码的文件。

排除的文件

指定文件掩码和文件名从压缩操作的文件中排除。统配符在路径和名称掩码部分都被支持。如果您要指定多个掩码，使用空格分割它们。如果掩码包含空格，使用引号括住它。例如，您可以输入：

c:\temp\info.txt *.bak *.tmp *\temp\

跳过 c:\temp\info.txt 文件、所有 .bak 和 .tmp 文件、所有 temp 文件夹和所有 temp 文件夹中的文件。您可以手动输入文件名或使用“追加”按钮浏览要排除的文件。

在参数 -x的描述中提供关于排除掩码语法的详细信息。此参数和“排除的文件”区域使用同样的排除掩码。

跳过 .bak 和 .tmp 文件和 temp 文件夹中的所有文件。您可以手动输入文件名或使用“追加”按钮浏览要排除的文件。

如果排除掩码包含通配符，它应用到当前文件夹和它的子文件夹。但是它没有通配符则不递归，所以如果您要在子文件夹中排除某些“文件名”，您需要指定“ *\filename”。如果您知道文件的解压路径，您可以使用“路径 \文件名”语法来仅排除此副本的“filename”。

不压缩而直接存储的文件

指定文件掩码和文件名不压缩而直接存储。这个参数被用来存储已经压缩的文件，这将帮助增加压缩速度，而不会显著的减小压缩率。如果您要指定多个掩码，使用空格分割它们。如果掩码包含空格，使用引号括住它。例如，您可以输入：

*.rar *.zip *.jpg

将不压缩直接存储所有的 RAR 和 ZIP 压缩文件和 JPG 图象。

文件路径

选择在压缩文件内保存文件路径的方法。WinRAR 可以存储当前文件夹的相对路径 (默认)，除了驱动器号与前缀的反斜线字符的完整文件路径，或仅存储文件名而不含路径，或存储包含盘符的完整路径。

相对路径模式排除当前的 WinRAR 文件夹。对于在“添加的文件”字段里手动输入的路径，它排除了基本文件夹到最后的路径分隔符，类似 -ep1 参数。

如果不带路径存储名字，可能会创建含有数个相同文件名的压缩文件，因此使用“不存储路径”选项时请小心。

如果您存储包含盘符的完全路径，WinRAR 会使用下划线字符替换磁盘分隔符( 冒号)。如果您在解压对话框的“高级”部分设置了“解压绝对路径”，WinRAR 可以把下划线改回为冒号并且把文件解压到它们原始的目录和磁盘中。您可以在 -ep3 参数 的描述中看到更多关于“存储包含盘符的完全路径”模式的可能的好处和危险，它是与此 WinRAR 选项等价的命令行。

请注意最后一种情况，可能会创建含有数个相同文件名的压缩文件，因此使用“使用不存储路径”选项时请小心。

每个文件均放到独立压缩文件中

把选择的每个文件或文件夹放到单独的压缩文件中。如果您设置了这个选项，一个被输入的压缩文件名仅被当作新的压缩文件的目标路径对待 (如果他不是一个文件夹，它的名字部分被忽略)并且压缩文件名基于文件名产生。

双重扩展名用于压缩文件

该选项修改“每个文件均放到独立压缩文件中”这个动作。 如果启用“双重扩展名用于压缩文件”，则由“每个文件均放到独立压缩文件中”生成的压缩文件将会拥有 filename.ext.rar 样式的名称，压缩文件扩展名附加在文件名之后。如果禁用该选项，我们会有 filename.rar 压缩文件，其文件扩展名被压缩文件扩展名代替。即使禁用该选项，WinRAR 也可以对那些名称相同但只有扩展名不同的文件应用双重扩展名模式。

子文件夹里的压缩文件

该选项修改“每个文件均放到独立压缩文件中”这个动作。 如果启用“子文件夹里的压缩文件”，则“每个文件均放到独立压缩文件中”将会把已选的子文件夹里的每个文件放到另外的压缩文件。如果禁用该选项，则每个已选的文件夹的全部内容将会保存到另外的压缩文件。

使用 E-mail 发送压缩文件到“<地址>”[ 并接着删除]

这个操作附加一个使用添加命令创建或被更新的压缩文件到 E-mail 信息中。您需要有MAPI 兼容的E-mail客户端来使用这个参数(大部分现代的 E-mail 程序支持 MAPI接口)。 如果您不输入目标 E-mail，会被您的 E-mail 程序提问。可以使用用分号或逗号分开的数个地址。如果您设置了“并接着删除”选项，压缩文件会在把它成功附加到 E-mail 附件中后删除。

如果创建 多卷压缩文件 使用了使用 E-mail 发送压缩文件选项，每一卷都附加到单独的 E-mail 附件中。


压缩文件名和参数对话框: 常规选项

对话框包括下列项目:

目标压缩文件名

可以手动输入或是单击“浏览”按钮以浏览压缩文件名的其中一种；您可以输入包含驱动器号的名称或者是完整路径给压缩文件。

配置文件

打开此菜单允许 创建新配置、管理 和选择 压缩配置 。压缩配置文件允许您快速的还原先前保存的压缩选项或是在此对话框指定默认的选项值。WinRAR 提供了少数预先定义的优化配置文件，有创建E-mail 附件，备份文件和其它操作等。“配置文件...”按钮上方显示当前活跃的配置文件名称。更多信息参见 压缩配置 主题。

压缩文件格式 (RAR, RAR4, ZIP)

选择新创建的压缩文件的格式。您可以指定 RAR 使用最新的 RAR 5.0 格式，与 WinRAR 4.x 兼容的 RAR4 格式，或 ZIP 来创建 ZIP 压缩文件。 取决于压缩格式的选择，一些目标格式不支持的高级选项将被禁用。如果您更新一个现有的压缩文件，此选项被忽略，WinRAR 会使用正在更新的压缩文件格式。

压缩模式

在“存储”、“最快”、“快”、“普通”、“好”、“最好” 模式间选择。“存储”以尽可能快的速度把文件写入压缩文件中并不进行压缩。所有其它模式都压缩数据，从“最快”到“最好”，提供了越来越高的压缩率和越来越低的速度。

字典大小

这是处理数据时用于查找和压缩重复数据模式所使用的内存区域的大小。较大的压缩字典有时会提高大文件的压缩率，特别是创建固实 压缩文件时。但是较大的字典也会降低压缩速度并增加内存的需求。

RAR 4.x 压缩文件最大的字典大小是 4MB。RAR 5.0 格式在 64位版本 WinRAR 中允许使用最大 1GB、32位版本 WinRAR 使用最大 256MB (Windows XP x86 最大 128 MB) 的字典创建压缩文件。解压缩相对压缩需要较少的内存，所以在有超过 1GB 可用内存的计算机上 32 和 64位 WinRAR 可以解压所有字典大小的压缩文件，包括 1GB。ZIP 格式的字典大小固定为 32KB。

如果 固实 压缩文件的所有源文件的大小，或者非固实压缩文件的最大源文件的大小至少是字典大小的1/2，则 WinRAR 可以减少字典大小。这对减少内存使用率而不降低压缩率有帮助。

在 分割为卷 区域的 卷 大小

如果您要创建卷，在这里输入单个卷的大小。您可以在大小区域右边的下拉列表中选择大小的单位。此列表中“B”表示字节，"KB" - 千字节，"MB" - 兆字节，"GB" - 吉字节。

它被允许输入在Windows区域设置定义的小数点的小数。

也可以通过在卷大小字符串后追加1个或2个字符来选择单位。小写的"k"被当成是千字节。使用大写的"K"则表示 1,000 字节, 'm' － 兆字节，M -- 为 1,000,000 字节， 'g' - 吉字节，'G' - 十亿字节。 "KB"、"MB" 和 "GB" 代表千字节、兆字节和吉字节，忽略大小写。

卷大小输入区域和下拉列表上次用户输入、预定义和定义的值相关联。您可以使用此列表来快速选择它包含的任何项目。此列表可被 定义分卷大小 对话框自定义。要激活它，点击 压缩设置 对话框中的“定义分卷大小”。

如果您使用 RAR 格式压缩到可移动磁盘，您可以从列表中选择“自动检测”字符串，而 WinRAR 将会自动为新的分卷选择分卷的大小。

更新模式:

  • 添加并替换文件 (默认) 当添加的文件有相同名称时，始终替换已压缩的文件。在压缩文件中不存在时，始终添加这些文件。
  • 添加并更新文件 仅在添加的文件较新时才替换已压缩的文件。在压缩文件中不存在时，总是添加这些文件。
  • 只刷新已存在的文件 仅在添加的文件较新时才替换已压缩的文件。在压缩文件中不存在时，不添加这些文件。
  • 覆盖前询问。 添加的文件和压缩包中的文件同名，覆盖压缩包中的文件前询问。总是添加在压缩文件中不存在的文件。
  • 跳过已存在的文件。 不替换压缩的文件中和要添加文件同名的文件。仅添加在压缩文件中不存在的文件。
  • 同步压缩文件内容 仅在添加的文件较新时才替换已压缩的文件。在压缩文件中不存在时，总是添加这些文件。在添加的文件不存在于压缩文件中时，删除这些文件。这类似创建一个新压缩文件，但有个重要的不同 : 如果在上次备份后，没有文件被修改过，这项操作会比创建新压缩文件来的还要快。

压缩后删除文件

压缩成功后的删除原始文件

创建自解压文件

创建 自解压文件 (exe 文件)，这是一种不使用任何其它程序便能解压的方式。您可以选择自解压模块的类型，并且可以在 高级选项 对话框内设置如目标文件夹等参数。

创建固实压缩文件

创建 固实 压缩文件。通常可获致较高的压缩率，但有一些限制。请读取 固实压缩文件 的描述可获得更多详细资料。

添加恢复记录

添加 恢复记录，这可在压缩文件损坏时帮助还原。您可以在 高级选项 对话框指定恢复记录的大小，默认值是压缩文件总大小的 3%。

测试已压缩文件

压缩后测试。 这个参数在“压缩后删除”时非常有用，所以只有压缩文件已经被成功测试后，文件才会被删除。

锁定压缩文件

WinRAR 无法修改锁定的归档，因此锁定重要的归档可以防止 WinRAR 意外修改它们。 如果 WinRAR 命令分组处理归档，这种保护可能特别有用。该选项不旨在或不能阻止其他 工具或第三方有意进行修改。它仅针对 WinRAR 引起的意外数据变更实行安全措施。

设置密码

给 加密 压缩文件设置密码。它只对单一压缩操作期间有效，且此参数优先于 文件菜单 所输入的默认密码参数。如果默认密码存在时，它会在完成压缩操作之后还原。如果在开始压缩之前默认密码不存在的话，在完成操作之后它也会不存在。


缩文件名和参数对话框

压缩文件名和参数对话框

在添加文件到压缩文件之前运行 添加到压缩文件 命令会显示此对话框。

在此对话框的选项包含了四个分开的选项组，选择下面的任一个项目均可读取组的详细描述 :

  • 常规
  • 高级
  • 选项
  • 文件
  • 备份
  • 时间
  • 注释


压缩文件名和参数对话框: 选项

删除模式

可以从 常规选项中选择下面列出的三种删除模式修改删除文件的行为。 它们只在“压缩后删除原文件”选项打开时才生效。您可以在默认的压缩配置文件中启用任意一个选项来修改“压缩后删除原文件”的行为。

删除文件

普通删除文件。文件被永久删除，但是不安全，有些时候可能被使用特殊软件恢复。

移动文件到回收站

删除文件被放到回收站中。

清除文件

删除文件前使用0字节覆盖文件数据，防止删除的文件被恢复，文件被截短并重命名为临时名称。

请注意，这种做法是为普通硬盘设计的，但可能无法覆盖固态磁盘上的原始文件数据，因为 SSD 磨损平衡技术的结果和更复杂的数据地址。

清除加密文件

如果打开了此选项并且压缩的文件使用了密码，“清除文件”模式会不管“删除模式”组中的其它选项而被启用。

直接在压缩对话框启用它没有太大的意义，因为您可以打开"擦除文件"代替它。所以这个选项目的是在压缩配置文件中使用。如果您更喜欢总是安全删除加密的文件，您可以在默认压缩配置中启用“清除设置密码的文件”。

快速打开信息

RAR 压缩文件在描述的每个文件的数据前存储包含如文件名称、时间、大小和属性的信息的文件头。这种方法比把所有文件头储存在一个连续的块中更能防止损坏，后者如果损坏或丢失会摧毁整个压缩文件的内容。但在更可靠的同时，这些文件头散布于整个压缩文件，如果我们需要在类似 WinRAR 图形界面的外壳中快速打开压缩文件的内容时的访问速度太慢。

要提高压缩文件的打开速度，而且要整个压缩文件不依赖于单一易受损块，RAR 5.0 压缩文件可以包含一个可选的快速打开的记录。这些记录被添加到压缩文件的结尾，包含附加在压缩文件内的普通文件头的文件名和其它文件信息的副本被存储在一个单一的连续块中。因为块是连续的，所以其内容可以被快速读取，而不需要执行大量的磁盘寻道操作。此块中每一个文件头都被校验和保护。如果 WinRAR 检测到快速打开信息被破坏，它会从压缩文件内重新读取这部分的头信息，所以防伤害性能没有被减弱。

快速打开记录包含文件头的完整副本，这可能是数十或数百个字节/文件，会把压缩文件的大小增加相同的量。当文件数据大小与文件头差不多大时，对于许多小文件，大小的增加是很明显的。所以在默认情况下，如果没有指定 -qo 或 -qo 没有使用参数，WinRAR 只对相对大的文件存储头副本，对小文件继续使用本地头。具体的文件大小阈值依赖解 WinRAR 的版本。这种方法提供了一个在打开速度和压缩文件大小之间的合理折衷。如果您想要最大的压缩文件打开速度，而不管大小，您可以使用 -qo+ 存储所有文件头的副本。如果您需要尽可能小的压缩文件，而不关心压缩文件在不同的程序中打开的速度，指定 -qo- 完全排除快速打开信息。

如果您想测试此选项的性能效果，确保压缩文件的内容没有存储在磁盘的缓存中。对于缓存的压缩文件没有进行真正的磁盘搜索，这使访问没有快速打开记录的文件头也很快。

存档功能

使用 BLAKE2 文件校验和

存储 BLAKE2 文件校验和。仅 RAR 5.0 压缩文件格式可用。

RAR 压缩文件的文件数据完整性由为每个存档文件计算和存储的校验和保护。默认情况下，WinRAR 使用 CRC32 函数来计算校验和。RAR 5.0 压缩文件格式还允许选择 BLAKE2 哈希函数的 BLAKE2sp 版本代替 CRC32。

CRC32 输出是 32 位长。虽然 CRC32 属性适合检测大部分意外的数据错误，它还没有可靠到可以验证文件数据。换句话说，如果两个文件有相同的 CRC32，它不保证文件内容是相同的。

BLAKE2 输出是 256 位。作为一个密码学可靠性的强大哈希函数，它几乎可以保证如果两个文件如果有相同的 BLAKE2 值，则它们的内容是相同的。BLAKE2 的错误检测能力也比较短的 CRC32 更可靠。

因为 BLAKE2 输出较长，启用此选项时生成的压缩文件也会略大。

如果压缩文件头没有加密 (加密文件名 选项没有设置)，对于 加密 RAR 5.0 文件的文件校验和被修改使用一种特殊的密码依赖算法，不可能基于校验和猜测文件内容。不要期待这样的加密文件校验和匹配常规和 BLAKE2sp 和 CRC32 值。

把相同文件保存为引用

如果启用此选项，在启动压缩之前 WinRAR 会分析文件的内容。如果找到几个大于 64KB 的相同文件，组中的第一个文件作为普通文件保存，所有剩下的文件保存为第一个文件的引用。这可以减少压缩文件的大小，但对生成的压缩文件有一些限制。压缩文件创建后，您一定不要删除或重命名文件压缩文件中的第一个相同文件，因为这会使后面的文件使用它作参考的文件不能解压。如果您修改了第一个文件，后面的文件的内容在解压后也会被修改。解压命令要成功创建后面的文件必须涉及到第一个文件。

如果您要压缩很多相同的文件，并且以后不会修改压缩文件，解压时解压整个压缩文件，没有必要解压缩或跳过单个文件，推荐使用此选项。如果所有相同的文件小到足以匹配压缩字典，则指定 固实压缩 可以提供比 -oi 更灵活的解决方案。

仅支持 RAR 5.0 压缩文件。

其他参数

您可以在此处提供一个或多个命令行参数。如果 WinRAR 的图形界面中没有与此参数匹配的选项，则可能会很有用。例如，要将文件名转换为小写，并将其放置在“myfiles”文件夹中，请将此字符串设置为：

-cl -apmyfiles

在此处输入的参数将覆盖类似的图形界面选项。仅当您熟悉 WinRAR 命令行语法，并清楚了解指定参数的用途时，才使用此功能。并非每个参数都适用于此。不适当地使用此选项会干扰 WinRAR 的功能，甚至导致数据丢失。


压缩文件名和参数对话框: 时间选项

保存修改时间、创建时间、上次访问时间

在压缩文件里启用保存修改时间、创建时间、上次访问时间。仅支持 RAR 压缩文件。仅 RAR 5.0 压缩文件格式允许禁用保存文件修改时间。如果这些文件时间之一未保存在压缩文件里，它会在解压时被指定为当前的系统时间。

您需要启用“设置创建时间”和“设置上次访问时间”选项 在解压对话框的 高级 部分，以便在解压文件时恢复这些时间。默认启用“设置创建时间”。

高精度时间格式

如果禁用此选项，则文件时间对于 RAR 4.x 和ZIP 压缩文件保存为2秒精度，对于 RAR 5.x 压缩文件保存为1秒精度。启用此选项轻微增加压缩文件的大小，但允许保存文件时间，精度为 0.0000001 秒。

如果此选项为 ZIP 格式启用，则所有三个文件时间（修改、创建、上次访问）都以高精度保存。不像 RAR 格式，我们无法在 ZIP 里以高精度保存单个文件时间。

保留源文件上次访问时间

默认情况下，归档后会更改源文件的上次访问时间。如果我们希望保留这个时间的原始值，我们可以启用此项。此选项保留归档文件原始的上次访问时间，但不控制将哪些时间戳存储在归档中。例如，如果我们希望保存上次访问归档时间，并保留源文件的上次访问时间，我们需要同时使用此选项和“存储上次访问时间”这个选项。此选项可以防止打开一些没有该参数仍能打开的文件。

包含文件: 任何时间 / 旧于 /新于 /之前 / 之后

此选项的默认值为“任何时间”，如此 WinRAR 将压缩全部选定的文件，而不理会它们的时间戳。但是将它更改为“旧于”或“新于”时，您可以强制 WinRAR 只压缩这些修改时间、创建时间或上次访问时间旧于或新于指定日数、时数和分数的文件。例如，如果您希望只压缩最近 3 天被修改过的文件时，这将非常有用。使用“之前”或“之后”您可以只选择比指定修改日期更早或更晚时间修改、创建或上次访问的文件。

“新于”和“之后”选项也包括完全匹配指定日期的文件。“旧于”和“之前”排除此类文件。

设置压缩文件时间为: 当前的系统时间 / 原始压缩文件时间 / 最新的文件时间

此选项的默认值为“当前的系统时间”，如此每一个新建或是修改的压缩文件才能收受当前的系统时间作为修改时间。但是您也可以设置此选项成为“原始的压缩文件时间”以预防压缩文件的时间遭到改变，或是设置为“最新的文件时间”来将被修改文件的修改时间设置为在压缩文件内最新的文件时间。


Brian Gladman 的 AES 实现

WinRAR 加密和解密程序部分来自 Brian Gladman 的 AES 实现，按照下列条件进行许可：

版权所有 (c) 2002, Dr Brian Gladman < >, Worcester, UK.

保留所有权利。

许可条款

本软件源代码及二进制形式（无论是否改变）允许免费分发和使用，但有以下前提：

  1. 此源代码的分发应包含上述版权告示、本条件列表和以下声明；
  2. 二进制形式的分发应在文档及其它相关材料中包含上述版权告示、本条件列表和以下声明；
  3. 未经特别书面许可，版权持有者的名称不得用于背书使用本软件构建的产品。

另外，只要本告示保持完整，本产品可以按照 GNU General Public License (GPL) 的条款来分发，这种情况下适用 GPL 的条款并取代以上条款。

免责声明

本软件按“原样”提供，而在其属性方面无任何明示或暗示的担保，包括但不限于正确性或适用性。

此软件包的源代码和其它有关加密技术和计算机工程的链接在 Brian Gladman 的网站上提供。


压缩选项对话框

此对话框结合了下列命令: 保护压缩文件，创建恢复卷,锁定压缩文件。而这些仅支持 RAR 压缩文件格式。

防护压缩可以在压缩文件有些许物理损坏时，可以帮助 修复 它。如果您希望防止压缩文件损坏，您需要指定占压缩文件总大小的 恢复记录 百分比。允许的最大值为 100%，如果您设为 0，则表示不添加恢复记录。较大的恢复记录在多重连续损坏时允许有较高的修护机率，但也相对增加了压缩文件的大小，因此 3 - 5% 应该是最优的值。

特殊的压缩文件保护方法是产生 恢复卷。只有在被打开的压缩文件是 分卷 系列的第一个文件时才可用，这时您只需选择要创建的 .rev 文件的数目。您也可以附加一个百分号到这个参数上，这样创建的 .rev 文件的数目将等于从 RAR 卷总数获得的这个百分比。每个恢复卷可以重建一个丢失的卷文件。您可以从 这里 获得更多信息。

如果您希望锁定重要的归档，则设置“禁用修改压缩文件”选项，这样 WinRAR 将不能再修改此压缩文件。锁定重要的归档可以防止 WinRAR 引起的意外修改。 该选项不旨在或不能阻止其他工具或第三方有意进行修改。它仅针对 WinRAR 引起的 意外数据变更实行安全措施。


Info-ZIP 源代码

WinRAR 包含了 Info-ZIP group 的源代码用于处理 ZIP 压缩文件。原始的 Info-ZIP 源代码可以从 ftp://ftp.info-zip.org/pub/infozip/ 和 www.info-zip.org 免费获得。

Info-Zip 许可协议

This is version 2009-Jan-02 of the Info-ZIP license. The definitive version of this document should be available at ftp://ftp.info-zip.org/pub/infozip/license.html indefinitely and a copy at http://www.info-zip.org/pub/infozip/license.html.

Copyright (c) 1990-2009 Info-ZIP. All rights reserved.

For the purposes of this copyright and license, "Info-ZIP" is defined as the following set of individuals:

Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter Goatley, Ed Gordon, Ian Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson, Paul Kienitz, David Kirschbaum, Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller, Sergio Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel, Steve Salisbury, Dave Smith, Steven M. Schweda, Christian Spieler, Cosmin Truta, Antoine Verheijen, Paul von Behren, Rich Wales, Mike White.

This software is provided "as is," without warranty of any kind, express or implied. In no event shall Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential damages arising out of the use of or inability to use this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the above disclaimer and the following restrictions:

  1. Redistributions of source code (in whole or in part) must retain the above copyright notice, definition, disclaimer, and this list of conditions.

  2. Redistributions in binary form (compiled executables and libraries) must reproduce the above copyright notice, definition, disclaimer, and this list of conditions in documentation and/or other materials provided with the distribution. Additional documentation is not needed for executables where a command line license option provides these and a note regarding this option is in the executable's startup banner. The sole exception to this condition is redistribution of a standard UnZipSFX binary (including SFXWiz) as part of a self-extracting archive; that is permitted without inclusion of this license, as long as the normal SFX banner has not been removed from the binary or disabled.

  3. Altered versions--including, but not limited to, ports to new operating systems, existing ports with new graphical interfaces, versions with modified or added functionality, and dynamic, shared, or static library versions not from Info-ZIP--must be plainly marked as such and must not be misrepresented as being the original source or, if binaries, compiled from the original source. Such altered versions also must not be misrepresented as being Info-ZIP releases--including, but not limited to, labeling of the altered versions with the names "Info-ZIP" (or any variation thereof, including, but not limited to, different capitalizations), "Pocket UnZip," "WiZ" or "MacZip" without the explicit permission of Info-ZIP. Such altered versions are further prohibited from misrepresentative use of the Zip-Bugs or Info-ZIP e-mail addresses or the Info-ZIP URL(s), such as to imply Info-ZIP will provide support for the altered versions.

  4. Info-ZIP retains the right to use the names "Info-ZIP," "Zip," "UnZip," "UnZipSFX," "WiZ," "Pocket UnZip," "Pocket Zip," and "MacZip" for its own source and binary releases.


Intel Slicing-by-8 CRC32 算法

WinRAR 使用的 CRC32 函数基于 Intel Slicing-by-8 算法。

原始的 Intel Slicing-by-8 算法在 sourceforge.net/projects/slicing-by-8 BSD 许可授权，http://www.opensource.org/licenses/bsd-license.html BSD 协议的文本如下：

Copyright (c) 2004-2006 Intel Corporation.
All Rights Reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


许可和购买信息

请选择下列主题中的一种：

WinRAR 许可

购买信息


输入主密码

Enter master password

请输入主密码来加密保存在注册表里的密码记录，并保护它们免遭未经授权的访问。此后，您会需要在密码提示框里输入主密码来访问这些密码。一旦输入完毕，主密码在关闭 WinRAR 之前始终有效。如果您希望看到它是如何保护的，请在指定主密码后关闭 WinRAR 并重新打开它。输入空密码来从先前保护的密码记录里删除加密。

仅当您在上级“管理密码”对话框里按下“确认”后，实际的加密才执行，而不是在您关闭此主密码提示框以后立即生效。


在压缩配置文件里保存密码

除非设置了主密码，否则压缩配置文件里保存的密码没有安全地加密，并且可以被任何能访问 您电脑的人读取。您可以输入主密码来加密保存在注册表里的密码数据，并保护它免遭未经授权 的访问。此后，您需要在密码提示对话框里输入主密码，才能访问此压缩配置文件。

您可以使用与密码管理器里相同的作为主密码，或者选择不同的密码。您甚至可以为不同的 压缩配置文件指定不同的主密码，尽管这样可能不便于使用。

一旦输入，主密码即对随后的配置文件读取生效，直到关闭 WinRAR 或者选择了使用其它主密码 的压缩配置文件。如果您希望看到它是如何保护的，请在指定主密码后关闭 WinRAR 并重新打开它。


名称编码

"名称编码" 菜单可以从 "选项" 菜单打开，或使用 Ctrl+E 键盘快捷键。它允许选择压缩文件名称的编码。 这个选项影响压缩文件浏览和解压命令。 通常您会偏好 "默认" 项目，以便 WinRAR 可以基于 Windows 语言设置和关于典型压缩文件格式参数的知识来选择编码。但如果您不满意基于 "默认" 的结果，您可以从该菜单提供的代码页列表里选择其它编码。

用户作出的选择保持有效，直到关闭 WinRAR 或选择了此菜单里的另一个选项。如果您希望永久保存当前的菜单选项，请选择 "保存当前" 菜单项。仅当您需要用相同的代码页处理大量压缩文件（这不会被 WinRAR 自动承认）才需这么做，否则 "默认" 是更好的选项。 您总是可以通过在菜单里选择它并选取 "保存当前" 菜单项来恢复 "默认"。

如果压缩文件包含 Unicode 文件名并且 WinRAR 能够可靠地检测到它，WinRAR 会忽略此菜单里一个选定的值，并使用 Unicode 名称。 当没有可用的 Unicode 名称时或无法确切地检测到编码时才使用 "名称编码" 菜单。尽管浏览常规文件和压缩文件时此菜单都可用，选定的代码页仅会影响压缩文件名称并对通常不压缩的文件无效。


“管理配置文件”对话框

在此对话框，您可以编辑一些已存在的 压缩配置 参数或者删除它们。您无法在此创建新配置文件，创建新配置文件的方式在 压缩配置 主题里有描述帮助。

要编辑配置文件参数，您必须将光标先移到配置文件名上，然后单击 “编辑”按钮并在 配置参数 对话框内对要改变的数值做参数设置。必须注意的是，保存在配置文件中的压缩选项是不能更改的，您只能修改少数如名称和默认状态之类的配置文件相关参数。如果您必须修改压缩选项，您必须创建与现有定义相同名称的新配置文件。

要删除配置文件，将光标先移到配置文件名上，然后单击“删除” 按钮。

使用“上移”和“下移”按钮移动列表中当前配置文件。

您可在此对话框内从配置文件列表中轻松的找到默认的配置文件，在它的名称左边会有个小型的 WinRAR 图标(“书本”)。


“管理主题”对话框

此对话框允许管理 WinRAR 界面主题。

按下“选择”来激活当前光标下的主题。使用“添加”按钮来安装新的主题文件。“删除”从列表中移除光标下的主题并从磁盘上删除它的所有文件，所以您以后不能在选择它。

“应用到压缩文件图标”是对所有主题的全局选项。如果它关闭，主题仅修改 WinRAR 的图像，而不会改变 RAR 、ZIP和其它压缩文件图标。如果它是打开的， WinRAR 图像和压缩文件图标都被修改。不像此对话框的其它命令，您需要点击“确定”来应用新的“应用到压缩文件图标”选项。


管理密码

"管理密码" 对话框提供了保存您经常使用的密码和以后快速访问它们的方法。它包含了用户存储的密码记录列表。通常密码标签和压缩文件掩码会被包含在此列表中，但是如果没有定义标签，“标签”列将显示密码文本。

您可以从常规 WinRAR 密码对话框中打开“管理密码”。在您输入默认密码或 WinRAR 询问一个加密的文件、压缩文件的密码时，点击“管理密码...”按钮。

点击“添加” 按钮添加一个新的密码记录到列表当前光标位置下。它会打开密码信息对话框，在这个对话框中，您可以指定密码文本、标签、压缩文件掩码。阅读 密码信息对话框 主题获得这些选项的更多信息。

“删除” 按钮删除所有选择的密码记录。使用 “编辑” 按钮修改管理信息对话框中光标下密码记录的参数。“上移” 和 “下移” 改变列表中所有选择的密码的位置。

按下 "设置主密码" 按钮，设置主密码并在“管理密码”对话框里按下“确认”，如果您希望加密密码记录并保护它们免遭未经授权的访问。随后，您需要在密码提示对话框里输入主密码来访问这些记录。一旦输入完毕，主密码在关闭 WinRAR 之前始终有效。如果您希望看到它是如何保护的，请在指定主密码后关闭 WinRAR 并重新打开它。输入空密码来从先前保护的密码记录里删除加密。

如果未设置主密码，保存在注册表里的密码是以不安全的格式存储的。因此，任何能访问您电脑的人都可以读取它们。尽管这个密码管理器的功能可以让使用密码更方便，但您需要仔细权衡安全风险。如果使用密码保护的信息敏感而机密，应该避免此功能，或仅在您的电脑已保护免遭未经授权的访问时使用它，或者设置主密码。

“启用自动完成” 选项允许密码对话框的自动完成功能。只需要输入密码或标签的第一个字母，并且您要使用的密码或标签存在于保存的密码列表中，WinRAR 会提示完整的文本。自动完成功能仅在密码对话框的“显示密码”选项启用时才工作。如果密码被隐藏，则自动完成功能也被禁用。如果存储的密码定义了标签，自动完成仅用于标签而不能用于密码文本。

当“管理密码”对话框中所有密码列表修改完成，您需要点击“确定”来保存它们。

您将能够在密码对话框中访问保存的密码，或者使用“输入密码”区域的下来列表，或者使用自动完成功能。


确认文件覆盖

文件已经存在，您可以覆盖它 (“是”按钮)，跳过 (“否”按钮)，重命名，全部重命名 ，覆盖全部文件 (“全部皆是” 按钮)，跳过全部已存在的文件 (“全部皆否”按钮) 或 取消 当前的操作。

如果您选择了 全部重命名 模式，重命名文件将得到象 'filename(N).txt' 的名字，'filename.txt' 的位置是原始的文件名， 'N' 是数字。


“配置文件参数”对话框

在此对话框中，您可以描述新建的 压缩配置 或编辑参数，它包含了以下项目:

配置文件名

配置文件名就是配置文件的文本描述。它可以包含空白字符，例如 : 名称“创建 E-mail 附件”是有效的。命名配置文件名时，推荐使用比较明确的名称，如此可简化识别以及对它们的管理，此区域为必填的区域。

您可以在配置文件名称中添加可选的 %arcname% 变量，并将其替换为实际的压缩文件名称。与“添加到上下文菜单”选项一起使用时可能会很方便。例如，您可以创建 ZIP 压缩配置文件，并将其名称设置为“添加到 %arcname%”，以便在上下文菜单中以实际的 ZIP 归档名称显示它。

保存压缩文件名

如果使用此选项，在区域指定的压缩文件名将会被保存在配置文件，并在选择此配置文件时还原。如果未选用此选项，则压缩文件名则由 WinRAR 所推荐，就和平时一样。

保存选定的文件名

如果使用此选项，在区域指定的压缩文件名将会被保存在配置文件，如果您往后选择了配置文件， WinRAR 将会压缩保存在配置文件的文件来替代先前创建的配置文件选定的文件。

此区域在一开始时会包含当前 WinRAR 文件列表的文件名，但您可以在此处编辑它们或者是输入新名称，文件夹名与通配符都是允许的。例如，您可以创建配置文件包含“C:\”做为选定的文件名来备份整个 C: 磁盘。

如果未选用此选项，WinRAR 将会压缩当前选定的文件。

设置为默认配置文件

如果配置文件被标记为默认文件，在每次压缩操作之前打开 压缩文件名和参数 时它便会被自动的选择。如此可以很便利的以您首选的压缩选项的默认配置文件来创建，如此您便不需每次均设置它们。而一次只能设置一个配置文件为默认的。如果没有标记为默认的配置文件，压缩对话框将会以标准的压缩选项设置做为初始化值。

某些默认压缩配置参数不仅用于添加文件到压缩文件，而且也用于其它的压缩文件修改操作，例如删除或重命名文件。在这种情况下 WinRAR 仅读取适用于当前操作的那些参数。解压不使用默认压缩配置的任何选项。

立即运行

如果您选取的配置文件有 立即运行 的参数设置，压缩操作将会立即开始，而无法再修改压缩设置值或压缩文件名等。这对于例行性的压缩操作是非常有用的；因为每次您选择了这类配置文件时，您不需要再单击 “确定”按钮。

在桌面上创建快捷方式

此选项仅在启用了 保存选定的文件名 时有效。如果选择了， WinRAR 会在桌面上以配置文件名创建图标 (快捷方式)，如此您便可在往后在图标上单击，轻松的启用配置文件。例如，您可创建一个备份您数据的配置文件并将它添加在桌面，来简化该项操作。

添加到关联菜单

如果此选项打开，配置文件名会显示在资源管理器的 关联菜单 中，允许从这里激活配置文件。如果您设置了立即执行 配置文件选项，压缩会在关联菜单的配置文件被选择时立即执行。如果 立即执行 关闭，您会首先看到 压缩文件名和参数 对话框。如果 保存压缩文件名 打开，WinRAR 会为新的压缩文件使用保存的文件名。如果 保存选择的文件名 打开，保存在配置文件中的文件和在资源管理器中选择的文件都会被添加到压缩文件中。


密码信息对话框

"密码信息"对话框会在点击“管理密码” 对话框中的“添加”或“编辑”按钮后出现。这样您既可以指定新密码的信息，也可以编辑已有的密码记录。这些信息包括密码文本、标签、"用于压缩文件"区域的压缩文件掩码和"无需询问"选项。

"密码文本" 是唯一一个必填区域。这里必须包含要存储的密码。

如果您不希望真实的密码在密码对话框中显示出来，您可以使用"密码标签"区域。您可以在这里指定密码的标签，以后您需要设置密码时可以使用此标签代替真实的密码。WinRAR 会自动以密码代替此标签。密码对话框会在密码输入区域的上面显示"输入了密码标签"提示您刚输入了一个标签。

例如，您可以定义 Fhtfl34Shu 作为密码文本，home 作为密码标签。以后您可以输入 home 代替 Fhtfl34Shu。此替代只在密码对话框中有效。不影响 命令行模式 和 -p[pwd] 参数。

密码标签必须唯一。他们不能和任何其它标签或密码相同。标签大小写不敏感，所以 home 和 Home 被认为是相同的标签。

如果您把密码文本和标签都定义了，“管理密码”对话框中的“标签”列中会显示标签。如果仅仅定义了密码文本，则密码文本会先知此列中。

"用于压缩文件" 区域可以包含一个或数个压缩文件名或掩码(仅名称，无路径)，用空格分隔。如果压缩文件名中包含空格，则必须用引号。如果解压的压缩文件名匹配这这些掩码中的一个，WinRAR 会自动选择在"密码文本"中定义的密码。如果 "无需确认" 选项关闭，则此密码会被设为密码对话框的默认值，但是用户有机会修改它。如果"无需确认"选项打开，密码会被立刻接受。

例如，如果您指定了 MailDGWT58 作为密码文本，"用于的压缩文件"区域输入了mymail*.rar mymail*.zip，在解压 mymail*.rar 和 mymail*.zip 压缩文件时MailDGWT58 会在密码对话框中自动被选择。此选项仅用于解压操作，压缩时无效。

请注意保存的密码被以未加密格式的纯文本存储在注册表中。这样所有能访问您的计算机的人都可以看到它们。在密码管理功能在处理密码时提供便利的同时，您需要仔细权衡安全风险。如果密码所保护的信息是敏感保密的，或者避免使用此功能，或者保护您的计算机方式非法访问。


“查找结果”对话框

这个对话框包含用 查找文件 命令找到的条目。您可以选择一个或一个以上的文件然后选择“解压缩到”来解压它们。您也可以按下“查看”来查看光标所在处的文件或者是“定位”来在 WinRAR 的主窗口中选定这个文件。

因为技术限制，如果搜索时执行查找到的文件会有一定的延迟。 WinRAR 只有在当前正在处理的压缩文件已经被关闭时才执行这个命令。


“高级自解压选项”对话框

此对话框可通过从 把压缩文件转换成自解压格式 命令，然后单击“高级自解压选项”按钮启动。它允许指定一些 自解压 压缩文件的参数，如默认目标路径，窗口标题和文本。它会使用在 Windows 自解压模块专门主题 所描述的自解压脚本命令，自动生成脚本。因此您不需要学习脚本语言和自己输入命令，只需要设置想要的选项即可。

请注意这些自解压参数仅能够应用在 Windows 图形界面模块，而不支持控制台或非 Windows 自解压程序。

此对话框的自解压参数被结合成一个子对话框，描述如下 :

  • 自解压选项: 常规
  • 自解压选项: 安装
  • 自解压选项: 模式
  • 自解压选项: 高级
  • 自解压选项: 更新
  • 自解压选项: 文本和图标
  • 自解压选项: 许可
  • 自解压选项: 模块


自解压命令: Delete

Delete=<文件名>

在解压到目标文件夹之前删除指定的文件，允许数个 Delete 命令。

如果在此指定的文件被锁定而无法删除，自解压模块在解压前会试着将它临时重命名，并在 Windows 重新启动时删除它，这能不能成功则取决于 Windows 版本的差异。

例子:

Delete=winrar95.exe

Delete=rarlng.dll


自解压命令: License

License=<许可协议对话框标题 >

{

许可协议文本 1

许可协议文本 2

...

}

当运行自解压文件时显示指定的作为软件许可协议文本。用户既可以接受它并继续解压或者拒绝它并退出。

许可可以包含HTML 或者纯文本格式。在以后的处理过程中，为了使字符串和对话框匹配，自解压模块将合并和重新格式化指定的字符串。所以如果您希望重新产生一个新的段落，您需要在它前面放一个空的字符串。

您可以使用 HTML 来控制颜色，字体和显示的格式。HTML 语法的描述可以在 The World Wide Web Consortium 站点找到。也可以使用网页编辑程序来产生 HTML 文本。

如果文本由数个字符串组成，自解压模块把‘}’字符作为文本的结束标记，所以您在您的文本的字符串的首个位置不应该使用此字符。如果您需要在字符串的开头使用‘}’字符，在它前面插入空格。

例子:

License=最终用户许可协议书

{

所有版权于 RAR 均属于作者所专有。

此程序是共享软件，任何人在测试期限内均可以使用此软件。

在测试期限过后，您“必须”注册。

}


自解压选项: 高级

这个对话框是 “高级自解压选项”对话框 的一部分，包含下列设置：

目标文件夹中要删除的文件

解压前，自解压程序会试着删除所指定的文件或在目标文件夹内的文件。您可以在此输入超过一个以上的文件，要如此做时，文件名之间必须以空格分隔。

如果在此指定的文件被锁定而无法删除，自解压模块在解压前会试着将它临时重命名，并在Windows 重新启动时删除它，这能不能成功则取决于 Windows 版本的差异。

相应的 自解压脚本 命令 - Delete

快捷方式

允许解压后为被压缩文件创建快捷方式。按下“添加快捷方式”按钮来定义一个新的快捷方式。您可以在 Shortcut 脚本命令主题里看到快捷键参数描述。“添加快捷方式”按钮下方的区域包含已输入的快捷键，并且在需要时您能在此处编辑它们。

相应的 自解压脚本 命令 - Shortcut

请求管理员访问权限

如果您希望创建 SFX 压缩文件可以设置此选项，将会在 Windows Vista 及以上版本启动时请求管理员权限。此选项在较老 Windows 版本中不改变 SFX 压缩文件的行为。

相应的命令行参数是 -iadm。


自解压选项: 常规

这个对话框是 “高级自解压选项”对话框 的一部分，包含下列设置：

解压路径

设置要解压文件的默认目标路径。您可以选择要将它创建在用户的“Program Files”文件夹，或当前文件夹，或在此指定一个绝对路径。前两种情况不需要包含驱动器号或前缀的“\”反斜线字符，而第三个则必须要有。

相应的 自解压脚本 命令 - Path

解压路径/保存并恢复路径

这个选项允许自解压程序在注册表中存储用户输入的目标路径，并在自解压文件下一次运行时恢复相同的解压路径。原来的 路径值被放在输入目标路径区域的列表下拉菜单中，所以用户可以在以前输入的和原始路径中选择。

当安装新版本或更新一些软件到同样的目录时，这个功能可能很便利。它允许只改变一次目标路径，而不需要每次都输入。

这只可以用在非空的解压路径区域的组合框中。

相应的 SFX 脚本 命令 - SavePath

保存当前设置当成默认值

保存所有在 “高级自解压选项”对话框 内所做的和当前的设置，并在以后每次创建 自解压 压缩文件时，以它们当作默认值。

此按钮仅显示在转换压缩文件到自解压文件调用的“高级自解压选项”对话框中。它保存所有对话框会话中输入的设置。这些保存的设置仅用于转换压缩文件到自解压文件的时候。对于其它压缩文件修改命令使用 压缩配置文件。


自解压选项: 许可

这个对话框是 “高级自解压选项”对话框 的一部分，包含下列设置：

许可窗口标题

设置指定的文本作为许可窗口标题。

相应的 自解压脚本 命令 - License

许可文本

当运行自解压文件时显示指定的作为软件许可协议的文本。用户可以接受它并继续解压或者拒绝它并退出。

许可文本可以包含 HTML 或纯文本格式。在以后的处理过程中，为了使字符串和对话框匹配，自解压模块将合并和重新格式化指定的字符串。所以如果您希望重新生成一个新的段落，您需要在它前面放一个空的字符串。

您可以使用 HTML 标签来控制颜色，字体和显示的格式。 HTML 语法的描述可以在 The World Wide Web Consortium 站点找到。也可以使用网页编辑程序来产生 HTML 文本。

相应的 自解压脚本 命令 - License

从文件加载文本

加载选择文件的内容作为许可文本。


自解压选项: 模式

这个对话框是 “高级自解压选项” 对话框的一部分，包含下列设置：

临时模式/解压文件到临时文件夹

此选项强制自解压程序创建一个临时文件夹，然后将所有文件解压缩到这个文件夹中，开始运行在 安装程序/解压后运行 区域所指定的程序，并在 Setup 程序完成后删除临时文件夹中的所有内容。当运行这些操作时，自解压程序会自动使用“隐藏启动对话框”缄默模式 (下面说明)。但是您可以通过指定“隐藏所有”缄默模式覆盖它。解压的临时文件夹被设置为安装程序的当前文件夹。

您还可以设置两种可选的字符串参数，即定义问题和解压缩前显示问题的标题。此类型的例子下仅在用户选择“是”按钮时才会开始解压缩。

如果设置了 解压到临时文件夹 选项，您就应该指定 Setup 程序。在此模式中，自解压忽略 解压路径 参数。

此选择在安装程序比它的子进程早结束时可能失败。阅读 TempMode 命令描述查看细节。

相应的 自解压脚本 命令 - TempMode

缄默模式

默认自解压在开始解压缩前会先询问确认，并允许用户更改目标文件夹。如果您设置“缄默模式”的“隐藏启动时的对话框”，这时会跳过确认画面。如果您也希望隐藏自解压的许可对话框和解压缩过程的话，请选择“全部隐藏”。

相应的 自解压脚本 命令 - Silent


自解压选项: 模块

这个对话框是 “高级自解压选项”对话框 的一部分，允许选择 自解压 模块。 注意并不是所有的模块都支持高级自解压选项。它只被 图形界面 RAR 和 ZIP 模块( Default.SFX 和 Zip.SFX ) 支持，而不被 控制台 RAR 模块 ( WinCon.SFX ) 支持。


自解压选项：设置

此对话框是 "高级自解压选项" 对话框 的一部分并且包含以下设置：

安装程序/提取后运行

自解压文件（SFX）会在成功提取后尝试执行指定的程序。执行该程序前，包含提取的文件的文件夹已设置为当前文件夹。 如果程序名包含空格，该程序名必须包含在英文双引号里。

允许在此指定几个安装程序，每个程序一行。 如果您不希望同时启动所有的安装程序，请设置“等待并返回退出码”选项。

您可以在程序名前插入 <Max>、<Min> 和 <Hide> 命令来以最大化、最小化或隐藏窗口启动它。< 和 >括号是命令的一部分，必须包含在内。例如，使用 <Hide>setup.exe 来隐藏 setup.exe 窗口。

请阅读 Setup 主题的注释，了解更多的详情。

相应的 SFX script 命令 - Setup

安装程序/提取前运行

自解压文件会在开始提取前尝试执行指定的程序，因此该程序必须已在磁盘上存在。 执行该程序前，目标文件夹已设置为当前文件夹。 如果程序名包含空格，该程序名必须包含在英文双引号里。 您可以将该命令用于，如：将新版本安装到旧版本上时，删除旧版本的程序。

允许在此指定几个程序，每个程序一行。 在开始下一个程序或继续解压缩之前，SFX 会等待每个程序的结束。

您可以在程序名前插入 <Max>、<Min> 和 <Hide> 命令来以最大化、最小化或隐藏窗口启动它。< 和 >括号是命令的一部分，必须包含在内。例如，使用 <Hide>setup.exe 来隐藏 setup.exe 窗口。

相应的 SFX script 命令 - Presetup

安装程序/等待并返回退出码

如果该选项启用，则自解压文件会等待每个指定的安装程序结束，以便在解压后启动并返回此程序的退出码，作为自解压可执行程序的退出码。如果自解压文件由于某种错误而无法作为安装程序运行，它将返回自己的错误代码，与 WinRAR 退出码 相同。返回值按照“退出码调整”参数来调节。

安装程序/退出码调整

因为安装程序和 SFX 模块可以使用相同的退出代码值来定义各种事件，所以“退出码调整”参数允许映射代码到不同的领域。如果它包含正整数，则它会添加到安装程序代码，同时按现状返回 SFX 自己的代码。对于负整数，它的绝对值添加到 SFX 自己的代码，同时按现状返回安装程序代码。使用 0 来按现状返回安装程序和 SFX 两者的代码。

更多详情请参阅 SetupCode 主题。

相应的 SFX script 命令 - SetupCode


自解压选项: 文本和图标

这个对话框是 “高级自解压选项”对话框 的一部分，包含下列设置：

自解压窗口标题

设置指定的文本作为自解压窗口的标题。

相应的 自解压脚本 命令 - Title

自解压窗口显示的文本

添加在自解压模块的文本输出窗口中指定的纯文本或HTML 字符串。

对于纯文本，为了使字符串和对话框匹配，自解压模块将合并和重新格式化指定的字符串。所以如果您希望重新生成一个新的段落，您需要在它前面放一个空的字符串。

您可以使用 HTML 来控制颜色，字体和显示的格式。HTML 语法的描述可以在 The World Wide Web Consortium 站点找到。也可以使用网页编辑程序来产生 HTML 文本。

相应的 自解压脚本 命令 - Text

从文件加载文本

加载选择文件的内容作为子解压窗口文本。

从文件加载自解压图片

指定图像（*.png）文件用于创建或更新自解压压缩文件。

默认自解压图片大小是 93x302 象素。推荐使用同样大小和小一点的图像。

如果您要使用此选项，您不能通过第三方可执行程序压缩器压缩自解压模块。

相应的命令行参数是 -iimg。

高分辨率 SFX 徽标

如果存在此可选的 *.png 图像，则 SFX 模块会调整其大小，并以高 DPI Windows 模式显示它，与调整标准徽标的大小这项相比，提供更好的可见质量。建议此文件的大小为 186x604 像素。

从文件加载自解压文件图标

使用目标 .ico 文件替换默认的自解压文件包含的图标。如果您要使用此选项，您不能使用任何第三方可执行文件压缩程序压缩自解压模块。

相应的命令行参数是 -iicon。


自解压选项: Update

这个对话框是 "高级自解压选项" 对话框dialog 的一部分，包含下列设置:

更新模式/解压和替换文件

不管时间解压所有压缩的文件。

更新模式/解压并更新文件

解压目标文件夹中不存在的或比要解压文件旧的文件。

相应的 自解压脚本 命令 - Update=U

更新模式/仅刷新已存在的文件

仅解压在目标文件夹中存在并较旧的文件。如果文件在目标文件夹中不存在，则会跳过。

相应的 自解压脚本 命令 - Update=F

覆盖模式/覆盖前询问(默认)

覆盖文件前提示。

覆盖模式/覆盖所有文件

无任何提示覆盖文件。

相应的 自解压脚本 命令 - Overwrite=1

覆盖模式/跳过已存在的文件

不覆盖已存在的文件。

相应的 自解压脚本 命令 - Overwrite=2


自解压命令: Overwrite

Overwrite=[n]

如果[n]为 0，在覆盖文件之前用户将会被先询问。这是 覆盖命令的默认动作，可以不需要指定。如果 [n]不存在或是等于[1]，文件将在没有确认的状况下全部覆盖。如果 [n]等于[2]，所有已存在的文件将不会被覆盖。

例子:

Overwrite=1


自解压命令: Path

Path=<路径>

设置默认的目标路径。路径的绝对使用起始点在不更改的情况下为 <驱动器号>:，如果 <路径> 只包含了名称，它将会被附加到“Program Files”文件夹下，如果您希望关闭如此的作用，请从“.\”字符开始定义起始 <路径 >。

例子:

  1. 设置“Calc 3.05 beta”为文件夹名，位置在“Program Files”下，当成默认路径:

Path=Calc 3.05 beta

  2. 设置“C:\Calc”当作默认路径:

Path=C:\Calc

  3. 设置“Calc”在根目录下当作默认路径:

Path=.\Calc

注意

  1. 允许在 Path 里以 %varname% 格式指定系统环境变量。例如："Path=%APPDATA%\MyApp"。SFX 模块会自动扩展它们。动态环境变量例如 %date% 或 %random%，不会被扩展。
  2. SFX 模块设置 sfxstime 环境变量，它包含以 "YYYY-MM-DD-HH-MM-SS-ms" 格式作为开始时间的模块。您可以在 Path 命令里制定它，如果您需要生成一个基于时间的唯一安装路径，例如："Path=MyApp-%sfxstime%"


自解压命令: Presetup

Presetup=[<mode>]<program>

自解压在解压之前将试着运行 <程序>，所以 <程序> 必须在磁盘上已经存在。在运行 <程序> 之前必须先指定目标文件夹。您可以使用此命令，比如说，当安装新版本于旧版本上面时，用以删除先前的程序版本。如果程序名包含空格，它必须包含在引号之内。

程序名前可以使用可选的<mode>字符串，用方括号将其括起来。Mode 字符串可以包含 Max、Min 和 Hide 命令，允许您以最大化、最小化或隐藏窗口来启动安装设置程序。

例子:

  1. 使用默认的窗口可见性和大小来启动“uninstall.exe /clean”：

    Presetup=uninstall.exe /clean

  2. 启动“uninstall.exe /clean”并隐藏其窗口：

    Presetup=<hide>uninstall.exe /clean

注意

  1. 自解压模块对于压缩文件注释中没有Setup或Presetup命令的时候显示"解压"代替"安装"。如果您要设为安装按钮，但是不需要执行任何安装程序，您可以添加一个没有任何参数的"Setup"命令。


自解压命令: 脚本范例

下面脚本设置对话框标题为“Calculator 3.05”，更改对话框的显示文本，设置默认的解压路路径为“Program Files\Calculator”，启用覆盖现有文件并在解压所有文件后运行 Setup.exe。

Title=Calculator 3.05

Text

{

Calculator 是共享软件，任何人都可在 40 天

的评估试用期间内使用此软件。

在超过测试期限之后，如果您希望继续使用

Calculator 的话，您“必须”注册。

}

Path=Calculator

Overwrite=1

Setup=setup.exe


SFX 命令: SavePath

SavePath

这个命令允许自解压程序在注册表中存储用户输入的目标路径，并在自解压文件下一次运行时恢复相同的 Path。原来的 Path 命令内容被放在输入目标路径区域的列表下拉菜单中，所以用户可以在以前输入的和原始路径中选择。

当安装新版本或更新一些软件到同样的目录时，这个功能可能很便利。它允许只改变一次目标路径，而不需要每次都输入。

SavePath 命令只能和 Path 命令一起使用一次。

例子:

Path=Calc 3.05

SavePath


自解压命令: Setup

SFX 命令: 设置

设置=[<mode>]<program>

SFX 将在成功解压后尝试执行<program>。在执行<program>之前，包含被解压出来的文件的文件夹被设置为当前。如果一个程序名包含空格，它必须用引号括起来。

程序名前可以使用可选的<mode>字符串，用方括号将其括起来。Mode 字符串可以包含 Max、Min 和 Hide 命令，允许您以最大化、最小化或隐藏窗口来启动安装设置程序。

示例

  1. 使用默认的窗口可见性和大小来启动 setup.exe：

    Setup=setup.exe

  2. 启动 setup.exe 并隐藏其窗口：

    Setup=<hide>setup.exe

注意

  1. 如果程序没有在 Setup 命令中指定任何参数，您可以使用 -sp<参数> 自解压命令行参数 传递可选的参数到此应用。
  2. 自解压模块在启动安装程序前设置 sfxname，sfxcmd 和 sfxpar 环境变量。sfxname 变量包含自解压模块的名字，sfxcmd 变量包含自解压模块接收的完整命令行。该命令行的第一个参数是 SFX 模块名称。sfxpar 仅包含命令行参数，而不带 SFX 模块名称。安装程序可以在需要这样的信息时读取它。安装程序如果需要这些信息可以读取它们。您也可以指定一个扩展的 %variable% 作为参数，例如 "Setup=setup.exe %sfxpar%"。
  3. 自解压模块对于压缩文件注释中没有Setup或Presetup命令的时候显示"解压"代替"安装"。如果您要设为安装按钮，但是不需要执行任何安装程序，您可以添加Setup=<>命令。 或者您可以通过图形界面的自解压选项 对话框来配置自解压压缩文件，只需要把<>指定为安装程序名。自解压模块不会尝试去运行此名字的程序，但是会改变按钮文本。


自解压命令: SetupCode

SetupCode

如果存在此命令，自解压模块会等待 Setup 或 Presetup 命令中指定的程序结束，并使用它的退出码作为自解压可执行程序的退出码。

如果自解压程序由于某些错误运行 Setup 程序失败，它会返回它自己的错误码，这和 WinRAR 退出码 相同。

因为 Setup 程序和自解压程序模块可以使用相同的退出码值来定义不同的事件，此命令允许映射代码到不同的领域。

如果 Param 是正整数，它会被添加到 Setup 程序代码。SFX 自己的代码按现状返回。

如果 Param 是负整数，它的绝对值会添加到 SFX 自己的代码。Setup 程序代码按现状返回。

如果 Param 为 0，则 SFX 和 setup 代码都按现状返回。

如果 param 被省略，则假定为 1000，因此 "SetupCode" 和 "SetupCode=1000" 相等。

假设我们有 "SetupCode=1000" 命令。如果 SFX 未能运行 setup 程序，则 SFX 会返回其自己的错误代码少于 1000，例如 3 表示校验和错误。如果 SFX 成功启动了一个 setup 程序并且它以 0 代码来结束，则 SFX 会返回 1000。如果 setup 程序返回 10，则 SFX 会返回 1010。

如果我们有负整数 "SetupCode=-1000" 命令，SFX 会在校验和错误的情况下返回 1003，而在 setup 程序返回 0 的情况下返回 0，在 setup 返回 10 的情况下返回 10。

如果使用了数个 Setup 和 Presetup 命令，并且存在 SetupCode，则 SFX 会等待每个 Setup 和 Presetup 命令并返回一个 setup 程序返回的最大代码。

示例

Setup=setup.exe

SetupCode


自解压命令: 快捷方式

自解压命令：快捷方式

快捷方式=<目标类型>,<SrcName>,<目标文件夹>,<描述>,<快捷方式名>,<快捷方式图标>

为解压的文件常见一个快捷方式。

目标类型 是一个一个字符宽的区域，可以有下列值：

D | 在桌面创建快捷方式
P | 在开始菜单/程序中创建快捷方式
T | 在启动菜单中创建快捷方式

源名 是压缩文件名。如果它是可执行文件，您可以在用引号包围的名称之后指定额外的参数。

目标文件夹 是创建快捷方式的文件夹，如果它不存在，它将被自解压文件创建。

描述 是描述快捷方式的字符串。

快捷方式名是由自解压创建的 .lnk (快捷方式 )文件的文件名。

快捷方式图标 是一个和快捷方式关联的图标文件名。如果您忽略此参数，将使用默认图标。如果图标文件名没有包含完全路径，自解压压缩文件会在包含解压后文件的文件夹中搜索图标文件。

所有参数用逗号分隔。如果您需要添加逗号字符在参数内，镶入整个参数引用。如果您需要在字符串中插入一个引用标记，要输入两次引号。只有目标类型和源名是必需的，其它参数可选，并可以忽略或留空白。

例子

1. 在桌面创建在 WinRAR 文件夹中连接到 winrar.exe 的快捷方式，带有“WinRAR 可执行文件”的描述和“WinRAR 压缩文件管理器”的名称和图标 WinRAR.ico：

Shortcut=D, winrar.exe, WinRAR, "WinRAR executable file", "WinRARarchiver", winrar.ico

2. 为 rar.exe 提供额外的参数，忽略 DestFolder 和 ShortcutIcon 参数：

Shortcut=D, "rar.exe" a -ag c:\mydata\backup\daily c:\mydata\files, , Daily backup, Backup


自解压命令: Silent

Silent[=参数]

开始解压时不显示开始对话框。

参数 可以是 1 或 2。

如果 参数 是 1，开始解压对话框会完全隐藏，包含进程指示和文件名。在此模式中自解压程序不显示 许可 对话框。

如果 参数 被忽略或是 2，则跳过开始解压的确认，但用户仍然可以看到压缩文件的解压进程。

例子:

Silent=2


自解压命令: TempMode

TempMode=[问题叙述 ][@窗口标题文本 ]

此命令强制自解压创建一个临时目录，将全部文件解压至此，然后开始运行 Setup 命令所指定的程序，并在完成 Setup 程序之后将临时目录中的内容全部清除。当运行这些操作时，当执行这些操作时，自解压会自动设置 缄默模式 为 2 来跳过启动对话框，但您可以指定带有其它参数的 Silent 命令来覆盖它。解压文件的临时文件夹被设置为安装程序的当前文件夹。

TempMode 命令可以有字符串参数的选项，在解压之前可用以定义问题和问题的标题。这样的例子，仅在当用户选择了“是” 按钮时才会开始解压。

如果 TempMode 命令存在的话，脚本中将有 Setup 命令且不得使用 path 命令。

使用 TempMode 的自解压文件需要检查安装程序是否结束再去删除临时文件。如果安装程序不能在安装完成前终止,这种做法正常工作。但有时安装程序启动一个子进程然后终止，使用子进程来完成安装。在这种情况下，自解压检测到主安装应用程序完成后立即删除临时文件，在子进程故障。所以 TempMode 只对那些不启动其它进程，至少不在子进程结束前退出的安装程序才能正常工作。

例子:

a) TempMode

b) TempMode=您希望继续安装 Calculator 3.05 吗? Calculator 安装程序


自解压命令: Text

此命令支持两种语法版本:

Text=<字符串>

Text

{

字符串 1

字符串 2

...

}

它在自解压模块的输出窗口添加指定纯文本或 HTML字符串。当自解压模块第一次遇到 Text 命令，在添加<字符串 >前，它重设这个窗口默认内容。其后的命令追加 <字符串>到已经存在的文本后。

依赖于使用的语法，这个命令可以一次添加一个或者数个字符串。

对于纯文本的过程中，为了使字符串和对话框匹配，自解压模块将合并和重新格式化指定的字符串。所以如果您希望重新产生一个新的段落，您需要在它前面放一个空的字符串。

您可以使用 HTML 来控制颜色，字体和显示的格式。 HTML 语法的描述可以在 The World Wide Web Consortium 站点找到。也可以使用网页编辑程序来产生 HTML 文本。

如果文本由数个字符串组成，自解压模块把‘}’字符作为文本的结束标记，所以您在您的文本的字符串的首个位置不应该使用此字符。如果您需要在字符串的开头使用‘}’字符，在它前面插入空格。

例子:

  1. 添加单个字符串到对话框窗口

Text=这是我的新程序

  2. 添加指定文本到对话框窗口

Text

{

此程序最有趣的特性是:

- 支持 Windows 剪贴板;

- 每一个处理的文件大小最大为 10KB;

}


自解压命令: Title

Title=<标题>

设置自解压的窗口标题。

例子:

Title==Calculator，版本 3.05


自解压命令: Update

Update=<c>

<c> 参数可以是 U 或 F 字符。

如果<c> 是 U, 自解压模块会解压磁盘上不存在的或比现有文件新的文件。

如果<c> 是 F, 自解压模块会解压比磁盘上文件新的文件。在 F 模式中，如果在目标文件夹不存在要解压文件的副本，则不会解压。

例子

Update=U


参数 -IMON<number> - 选择一个显示屏

选择一个显示屏来显示 WinRAR 的操作进度和对话框。 将在此参数末尾指定显示屏数量，其中 -imon1 表示主显示屏， -imon2 表示辅助显示屏，以此类推。

此参数仅适用于 WinRAR 的命令行模式，而且不影响交互式 的 WinRAR 图形界面或控制台 RAR。

示例

在辅助显示屏上运行解压缩操作

WinRAR x -imon2 files.rar


Switch -ONI - allow potentially incompatible names.

Switch -ONI - 允许潜在的不兼容名称

尽管 NTFS 文件系统允许文件名称带有后缀空格和小数点，有很多 Windows 程序无法正确处理此类名称。如果未指定此参数，RAR 会删除后缀空格和小数点，如果解压时它们存在于文件名中。如果您需要按原样解压此类名称，请指定此参数。

参数 -oni 是与 解压对话框里的 "允许潜在的不兼容名称" 选项相同的命令行参数。


选择工具栏按钮

在此对话框您可以指定当浏览磁盘文件夹 (“在压缩文件外部时显示”选项) 或查看压缩文件内容 (“在压缩文件内部时显示”选项 ) 时，要显示哪一些工具栏按钮。可以改变按钮的顺序，只要选择您希望移动的按钮并按下“上移”或“下移”来改变它们的位置。如果您要恢复默认工具栏配置，按下“默认”按钮。

“分隔符”按钮在选择的当前按钮前插入一个分隔符线。如果您要移除一个分隔符，或者取消它的选择状态，或者再次按下“分隔符”按钮。

注意，您也可以在按下 ALT 键时在工具栏上直接拖动工具栏按钮。