SQL Server 配置管理器帮助
SQL Server 配置管理器帮助 |
 | 请参阅

使用 SQL Server 配置管理器可以配置 SQL Server 服务和网络连接。若要创建或管理数据库对象、配置安全性以及编写 Transact-SQL 查询，请使用 SQL Server Management Studio。对于 SQL Server Express，请使用 Express Manager 工具。有关 SQL Server Management Studio 和 Express Manager 的详细信息，请参阅管理 SQL Server 2000 服务。

本节包含了按 F1 后看到的有关 SQL Server 配置管理器中各对话框的帮助主题。

注意：
SQL Server 配置管理器无法配置 Microsoft SQL Server 2005 之前的 SQL Server 版本。

服务

SQL Server 配置管理器管理与 SQL Server 相关的服务。尽管其中许多任务可以使用 Microsoft Windows 服务对话框来完成，但值得注意的是 SQL Server 配置管理器还可以对其管理的服务执行更多的操作（例如，在服务帐户更改后应用正确的权限）。使用标准的 Windows 服务对话框配置任何 SQL Server 服务都可能会造成服务无法正常工作。

使用 SQL Server 配置管理器可以完成下列服务任务：

  • 启动、停止和暂停服务

  • 将服务配置为自动启动或手动启动，禁用服务，或者更改其他服务设置

  • 更改 SQL Server 服务所使用的帐户的密码

  • 使用跟踪标志（命令行参数）启动 SQL Server

  • 查看服务的属性

SQL Server 网络配置

使用 SQL Server 配置管理器可以完成下列与此计算机上的 SQL Server 服务相关的任务：

  • 启用或禁用 SQL Server 网络协议

  • 配置 SQL Server 网络协议

注意：
有关如何配置协议和连接到 SQL Server 数据库引擎的简短教程，请参阅教程：数据库引擎入门。

SQL Server Native Client 配置

SQL Server 客户端通过使用 SQL Server Native Client 网络库连接到 SQL Server。使用 SQL Server 配置管理器可以完成下列与此计算机上的客户端应用程序相关的任务：

  • 对于此计算机上的 SQL Server 客户端应用程序，指定连接到 SQL Server 实例时的协议顺序。

  • 配置客户端连接协议。

  • 对于 SQL Server 客户端应用程序，创建 SQL Server 实例的别名，使客户端能够使用自定义连接字符串进行连接。

有关这些任务的详细信息，请参阅每个任务的 F1 帮助。

打开 SQL Server 配置管理器

  • 在“开始”菜单上，依次指向“所有程序”、Microsoft SQL Server，再单击“SQL Server 配置管理器”。

请参阅

参考

SQL Server 2008 服务
SQL Server 2008 网络配置
SQL Server Native Client 配置
管理 SQL Server 2000 服务

概念

选择网络协议

© 2010 Microsoft Corporation。保留所有权利。


SQL Server 2008 服务

SQL Server 2008 服务 |
 | 请参阅
SQL Server 配置管理器帮助 >

本节包含按 F1 后看到的有关 Microsoft SQL Server 配置管理器中“SQL Server 服务”对话框的帮助主题。

注意：
如果在未承载资源的群集节点上打开 SQL Server 配置管理器，将显示这些服务已停止。

注意：
如果 SQL Server 服务的节点未用此计算机上可用的 SQL Server 服务进行填充，则您可能会没有足够的权限访问 Windows Management Instrumentation (WMI)。若要配置 WMI 的权限，请在联机丛书中搜索主题“如何在 SQL Server 工具中将 WMI 配置为显示服务器状态”。

请参阅

概念

SQL Server 配置管理器帮助

© 2010 Microsoft Corporation。保留所有权利。


分析服务器 <服务器>（SQL Server 配置管理器）

分析服务器 <服务器>（SQL Server 配置管理器）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

此服务对 Microsoft Analysis Services 提供支持。若要查看服务的属性，请在详细信息窗格中右键单击服务，再单击“属性”。

有关 Analysis Services 的信息，请参阅联机丛书。


分析服务器属性（“登录”选项卡）

分析服务器属性（“登录”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

使用“分析服务器属性”对话框中的“登录”选项卡可以指定 SSAS 服务使用的帐户，还可以启动和停止该服务。

注意：
更改群集实例上的服务使用的“帐户名”时，新帐户必须是安装期间为待更改服务指定的域组的成员，或者您必须有权添加该组的成员。如果您无权修改组成员身份，请与域管理员联系。

选项

本地系统帐户

指定一个不要求输入密码的本地系统帐户。不过，本地系统帐户可能会限制该服务与其他服务器进行交互，具体取决于该帐户所拥有的权限。

本帐户

指定一个使用 Microsoft Windows 身份验证的本地用户帐户或域用户帐户。Microsoft 建议使用具有最低服务权限的域用户帐户。有关选择帐户的信息，请在联机丛书中搜索主题“设置 Windows 服务帐户”。

帐户名

指定本地用户帐户名或域用户帐户名。

密码

键入帐户的密码。

确认密码

再次键入帐户的密码。

启动

启动服务。

停止

停止服务。

暂停

暂停服务。

恢复

恢复暂停的服务。


分析服务器属性（“服务”选项卡）

分析服务器属性（“服务”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

此服务是 Microsoft Analysis Services。若要使 SSAS 正常运行，则必须运行此服务。如果属性值呈浅灰色，则不能使用此应用程序进行更改。

选项

二进制路径

显示此服务所使用的程序文件的位置。

错误控制

1 指示 SERVICE_ERROR_NORMAL。如果在计算机启动过程中无法启动该服务，则启动程序会记录该错误并显示一个弹出消息框，但仍会继续执行启动操作。此值不能更改。

退出代码

当发生错误时，错误号显示在此信息框中。您可以通过在 Microsoft 知识库中搜索该号码获取相关信息来排除故障，或将该错误号提供给技术支持人员以获得帮助。

主机名

显示运行 SSAS 的计算机或群集的名称。

名称

指示该服务的显示名称。

进程 ID

显示由 Microsoft Windows 用来跟踪此程序进程的编号。

SQL 服务类型

显示用于调用进程的服务的类型。Microsoft SQL Server 安装有多种服务。

启动模式

对此服务设置以下选项：

  • 手动：计算机启动时，此服务不自动启动。您必须使用 SQL Server 配置管理器或其他工具来启动该服务。

  • 自动：计算机启动时，此服务将尝试启动。

  • 已禁用：此服务无法启动。

状态

指示此服务是正在运行、已停止还是已禁用。


分析服务器属性（“高级”选项卡）

分析服务器属性（“高级”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

此服务为 Microsoft Analysis Services。如果定义了自定义属性，定义的属性及其属性值将显示在此选项卡上。

选项

群集

指示是否将此服务安装为群集服务器的资源。

客户反馈报告

指示是否已对此服务启用服务质量监视。有关客户反馈报告的详细信息，请在联机丛书中搜索主题“错误和使用报告设置”。

转储目录

显示发生错误时内存转储的存放位置。

错误报告

当设置为“是”时，如果发生错误，Dr. Watson 程序将把相关信息转发给 Microsoft，或转发给错误服务器。有关错误报告的详细信息，请在联机丛书中搜索主题“错误和使用报告设置”。

实例 ID

指示使用此服务的实例。


Notification Services（SQL Server 配置管理器）

Notification Services（SQL Server 配置管理器）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

此服务对 Notification Services 提供支持。若要查看服务的属性，请在详细信息窗格中右键单击服务，再单击“属性”。

有关 Notification Services 的信息，请参阅联机丛书。


NS$<服务名称> 属性（“登录”选项卡）

NS$<服务名称> 属性（“登录”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

使用“Notification Services 属性”对话框中的“登录”选项卡可以指定 Notification Services 服务使用的帐户，还可以启动和停止该服务。

选项

本地系统帐户

指定一个不要求输入密码的本地系统帐户。不过，本地系统帐户可能会限制该服务与其他服务器进行交互，具体取决于该帐户所拥有的权限。

本帐户

指定一个使用 Microsoft Windows 身份验证的本地用户帐户或域用户帐户。Microsoft 建议使用具有最低服务权限的域用户帐户。有关选择帐户的详细信息，请在联机丛书中搜索主题“设置 Windows 服务帐户”。

帐户名

指定本地用户帐户名或域用户帐户名。

密码

键入帐户的密码。

确认密码

再次键入帐户的密码。

启动

启动服务。

停止

停止服务。

暂停

暂停服务。

恢复

恢复暂停的服务。


NS$<服务名称> 属性（“服务”选项卡）

NS$<服务名称> 属性（“服务”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

此服务为 Microsoft Notification Services 服务。如果属性值呈浅灰色，则不能使用此应用程序进行更改。

选项

二进制路径

显示此服务所使用的程序文件的位置。

错误控制

1 指示 SERVICE_ERROR_NORMAL。如果在计算机启动过程中无法启动该服务，则启动程序会记录该错误并显示一个弹出消息框，但仍会继续执行启动操作。此值不能更改。

退出代码

当发生错误时，错误号显示在此信息框中。您可以通过在 Microsoft 知识库中搜索该号码获取相关信息来排除故障，或将该错误号提供给技术支持人员以获得帮助。

主机名

显示运行全文搜索的计算机或群集的名称。

名称

指示该服务的显示名称。

进程 ID

显示 Microsoft Windows 进程 ID。

SQL 服务类型

用于调用进程的服务的类型。SQL Server 安装有多种服务。

启动模式

对此服务设置以下选项：

  • 手动：计算机启动时，此服务不自动启动。您必须使用 SQL Server 配置管理器或其他工具来启动该服务。

  • 自动：计算机启动时，此服务将尝试启动。

  • 已禁用：此服务无法启动。

状态

指示此服务是正在运行、已停止还是已禁用。


NS$<服务名称> 属性（“高级”选项卡）

NS$<服务名称> 属性（“高级”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

Notification Services 实现为名称格式为 NS$<用户配置的名称> 的服务。如果定义了自定义属性，定义的属性及其属性值将显示在此选项卡上。此选项卡有可能不列出任何属性。


报表服务器 <服务器>（SQL Server 配置管理器）

报表服务器 <服务器>（SQL Server 配置管理器）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

此服务对 Microsoft Reporting Services 提供支持。若要查看服务的属性，请在详细信息窗格中右键单击服务，再单击“属性”。

有关 Reporting Services 的信息，请参阅联机丛书。


报表服务器属性（“登录”选项卡）

报表服务器属性（“登录”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

使用“报表服务器属性”对话框中的“登录”选项卡可以指定报表服务器服务使用的帐户，还可以启动和停止该服务。

选项

本地系统帐户

指定一个不要求输入密码的本地系统帐户。不过，本地系统帐户可能会限制该服务与其他服务器进行交互，具体取决于该帐户所拥有的权限。

本帐户

指定一个使用 Microsoft Windows 身份验证的本地用户帐户或域用户帐户。Microsoft 建议使用具有最低服务权限的域用户帐户。有关选择帐户的信息，请在联机丛书中搜索主题“设置 Windows 服务帐户”。

帐户名

指定本地用户帐户名或域用户帐户名。

密码

键入帐户的密码。

确认密码

再次键入帐户的密码。

启动

启动服务。

停止

停止服务。

暂停

暂停服务。

恢复

恢复暂停的服务。


报表服务器属性（“服务”选项卡）

报表服务器属性（“服务”选项卡） |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

此服务为 Microsoft SQL Server 报表服务器服务。如果属性值呈浅灰色，则不能使用此应用程序更改。

选项

二进制路径

显示此服务所使用的程序文件的位置。

错误控制

1 指示“SERVICE_ERROR_NORMAL”。如果在计算机启动过程中无法启动该服务，则启动程序会记录该错误并显示一个弹出消息框，但仍会继续执行启动操作。此值不能更改。

退出代码

当发生错误时，错误号显示在此信息框中。您可以通过在 Microsoft 知识库中搜索该号码获取相关信息来排除故障，或将该错误号提供给技术支持人员以获得帮助。

主机名

显示运行全文搜索的计算机或群集的名称。

名称

指示该服务的显示名称。

进程 ID

显示 Microsoft Windows 进程 ID。

SQL 服务类型

用于调用进程的服务的类型。SQL Server 安装有多种服务。

启动模式

对此服务设置以下选项：

  • 手动：计算机启动时，此服务不自动启动。您必须使用 SQL Server 配置管理器或其他工具来启动该服务。

  • 自动：计算机启动时，此服务将尝试启动。

  • 已禁用：此服务无法启动。

状态

指示此服务是正在运行、已停止还是已禁用。

请参阅

参考

SQL Server 2008 服务

© 2010 Microsoft Corporation。保留所有权利。


报表服务器属性（“高级”选项卡）

报表服务器属性（“高级”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

此服务为 Microsoft Reporting Services。如果定义了自定义属性，定义的属性及其属性值将显示在此选项卡上。

选项

客户反馈报告

指示是否已对此服务启用服务质量监视。有关客户反馈报告的详细信息，请在联机丛书中搜索主题“错误和使用报告设置”。

转储目录

显示发生错误时内存转储的存放位置。

错误报告

当设置为“是”时，如果发生错误，Dr. Watson 程序将把相关信息转发给 Microsoft，或转发给错误服务器。有关错误报告的详细信息，请在联机丛书中搜索主题“错误和使用报告设置”。

实例 ID

指示使用此服务的实例。


SQL Server 代理 <服务器>（SQL Server 配置管理器）

SQL Server 代理 <服务器>（SQL Server 配置管理器）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

此服务对支持 SQL Server 代理。若要查看服务的属性，请在详细信息窗格中右键单击服务，再单击“属性”。

SQL Server 代理是一种 Microsoft Windows 服务，可执行称为“作业”的计划管理任务。有关 SQL Server 代理的详细信息，请参阅 SQL Server 联机丛书中的“关于 SQL Server 代理”。


SQL Server 代理属性（“登录”选项卡）

SQL Server 代理属性（“登录”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

使用“SQL Server 代理属性”对话框中的“登录”选项卡，可以指定 SQL Server 代理服务使用的帐户，还可以启动和停止该服务。对帐户密码的更改立即生效，无需重新启动服务。

注意：
更改群集实例的服务使用的帐户名时，新帐户必须是安装期间为待更改服务指定的域组的成员，或者您必须具有向该组添加成员的权限。如果您无权修改组成员身份，请与域管理员联系。

选项

本地系统帐户

指定一个不要求输入密码的本地系统帐户。不过，本地系统帐户可能会限制该服务与其他服务器进行交互，具体取决于该帐户所拥有的权限。

本帐户

指定一个使用 Windows 身份验证的本地用户帐户或域用户帐户。Microsoft 建议使用具有最低服务权限的域用户帐户。有关选择帐户的信息，请在联机丛书中搜索“设置 Windows 服务帐户”。

帐户名

指定本地用户帐户名或域用户帐户名。

密码

键入帐户的密码。

确认密码

再次键入帐户的密码。

启动

启动服务。

停止

停止服务。

暂停

暂停服务。

恢复

恢复暂停的服务。


SQL Server 代理属性（“高级”选项卡）

SQL Server 代理属性（“高级”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

默认情况下，“高级”选项卡中显示五个属性。如果定义了自定义属性，定义的属性及其属性值将显示在此选项卡上。

选项

群集

指示此服务是否作为群集服务器的资源进行安装。

客户反馈报告

指示是否已对此服务启用服务质量监视。有关客户反馈报告的详细信息，请在联机丛书中搜索主题“错误和使用报告设置”。

转储目录

显示发生错误时内存转储的存放位置。

错误报告

当设置为“是”时，如果发生错误，Dr. Watson 程序将把相关信息转发给 Microsoft，或转发给错误服务器。有关错误报告的详细信息，请在联机丛书中搜索主题“错误和使用报告设置”。

实例 ID

指示使用此服务的实例。


SQL Server 代理属性（“服务”选项卡）

SQL Server 代理属性（“服务”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

此服务为 Microsoft SQL Server 代理服务。如果属性值呈浅灰色，则不能使用此应用程序进行更改。

选项

二进制路径

显示此服务所使用的程序文件的位置。

错误控制

1 指示 SERVICE_ERROR_NORMAL。如果在计算机启动过程中无法启动该服务，则启动程序会记录该错误并显示一个弹出消息框，但仍会继续执行启动操作。此值不能更改。

退出代码

当发生错误时，错误号显示在此信息框中。您可以通过在 Microsoft 知识库中搜索该号码获取相关信息来排除故障，或将该错误号提供给技术支持人员以获得帮助。

主机名

显示运行 SQL Server 代理的计算机或群集的名称。

名称

指示该服务的显示名称。

进程 ID

显示 Microsoft Windows 进程 ID。

SQL 服务类型

显示用于调用进程的服务的类型。SQL Server 安装有多种服务。

启动模式

对此服务设置以下选项：

  • 手动：计算机启动时，此服务不自动启动。您必须使用 SQL Server 配置管理器或其他工具来启动该服务。

  • 自动：计算机启动时，此服务将尝试启动。

  • 已禁用：此服务无法启动。

状态

指示此服务是正在运行、已停止还是已禁用。“…”指示状态更改被挂起。


SQL Server Browser（SQL Server 配置管理器）

SQL Server Browser（SQL Server 配置管理器）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

此服务对 SQL Server 浏览器提供支持。若要查看服务的属性，请在详细信息窗格中右键单击服务，再单击“属性”。

有关 SQL Server Browser 服务的说明及其工作方式，请参阅 SQL Server Browser 服务。


SQL Server 浏览器属性（“登录”选项卡）

SQL Server 浏览器属性（“登录”选项卡） |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

SQL Server 浏览器程序以服务的形式在服务器上运行。SQL Server 浏览器侦听对 Microsoft SQL Server 资源的传入请求，并提供计算机上安装的 SQL Server 实例的有关信息。

SQL Server 浏览器使用 SQL Server 解析协议 (SSRP) 侦听 UDP 端口，并接受未经身份验证的请求。

对帐户密码的更改立即生效，无需重新启动服务。

选项

本地系统帐户

在本地系统帐户的安全上下文中运行 SQL Server Browser 服务。请尽可能使用低权限帐户。

本帐户

指定一个使用 Windows 身份验证的本地用户帐户或域用户帐户。建议使用具有最低服务权限的域用户帐户。有关选择帐户的信息，请参阅 SQL Server 联机丛书中的“设置 Windows 服务帐户”。

浏览

浏览用户或内置安全主体。

重要提示：
使用低权限帐户。有关 SQL Server Browser 服务所需权限的信息，请参阅 SQL Server Browser 服务中的“安全性”部分。

密码

输入安全主体的密码。

确认密码

确认安全主体的密码。

服务状态

指示此服务是正在运行、已停止还是已禁用。“...”指示状态更改被挂起。

启动

启动 SQL Server Browser 服务。

停止

停止 SQL Server Browser 服务。

暂停

暂停 SQL Server Browser 服务。

恢复

恢复暂停的 SQL Server Browser 服务。

请参阅

概念

SQL Server Browser 服务

© 2010 Microsoft Corporation。保留所有权利。


SQL Server 浏览器属性（“服务”选项卡）

SQL Server 浏览器属性（“服务”选项卡） |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

SQL Server 浏览器程序以服务的形式在服务器上运行。SQL Server 浏览器侦听对 Microsoft SQL Server 资源的传入请求，并提供计算机上安装的 SQL Server 实例的有关信息。

使用“SQL Server 浏览器属性”对话框中的“服务”选项卡可以查看下列选项。除了“启动模式”以外，其他所有属性都是只读的。

选项

二进制路径

显示此服务所使用的程序文件的位置。

错误控制

1 指示 SERVICE_ERROR_NORMAL。如果在计算机启动过程中无法启动该服务，则启动程序会记录该错误并显示一个弹出消息框，但仍会继续执行启动操作。此值不能更改。

退出代码

当发生错误时，错误号显示在此信息框中。您可以通过在 Microsoft 知识库中搜索该号码获取相关信息来排除故障，或将该错误号提供给技术支持人员以获得帮助。

主机名

显示运行 SQL Server Browser 服务的计算机或群集的名称。

名称

指示该服务的显示名称。

进程 ID

显示 Windows 进程 ID。

服务类型

显示用于调用进程的服务的类型。SQL Server 安装有多种服务。

启动模式

对此服务设置以下选项：

  • 手动：计算机启动时，此服务不自动启动。您必须使用 SQL Server 配置管理器或其他工具来启动该服务。

  • 自动：计算机启动时，此服务将尝试启动。

  • 已禁用：此服务无法启动。

状态

指示此服务是正在运行、已停止还是已禁用。“...”指示状态更改被挂起。

请参阅

概念

SQL Server Browser 服务

© 2010 Microsoft Corporation。保留所有权利。


SQL Server 浏览器属性（“高级”选项卡）

SQL Server 浏览器属性（“高级”选项卡） |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

SQL Server 浏览器程序以服务的形式在服务器上运行。SQL Server 浏览器侦听对 Microsoft SQL Server 资源的传入请求，并提供计算机上安装的 SQL Server 实例的有关信息。

选项

群集

指示此服务是否作为群集服务器的资源进行安装。

客户反馈报告

指示是否已对此服务启用服务质量监视。有关客户反馈报告的详细信息，请在联机丛书中搜索主题“错误和使用报告设置”。

转储目录

显示发生错误时内存转储的存放位置。

错误报告

当设置为“是”时，如果发生错误，Dr. Watson 程序将把相关信息转发给 Microsoft，或转发给错误服务器。有关错误报告的详细信息，请在联机丛书中搜索主题“错误和使用报告设置”。

实例 ID

指示使用此 SQL Server 代理实例的 SQL Server 实例。默认实例为 MSSQL10_50.MSSQLSERVER。

请参阅

概念

SQL Server Browser 服务

© 2010 Microsoft Corporation。保留所有权利。


SQL Server <服务器>（SQL Server 配置管理器）

SQL Server <服务器>（SQL Server 配置管理器）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

此服务对 Microsoft SQL Server 数据库引擎提供支持。若要查看服务的属性，请在详细信息窗格中右键单击服务，再单击“属性”。

有关 SQL Server 数据库引擎的信息，请参阅联机丛书。


SQL Server 属性（“登录”选项卡）

SQL Server 属性（“登录”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

使用“SQL Server 属性”对话框中的“登录”选项卡，可以指定 SQL Server 服务使用的帐户，更改帐户密码，还可以启动和停止该服务。对帐户密码的更改立即生效。

注意：
更改群集实例的服务使用的帐户名时，新帐户必须是安装期间为待更改服务指定的域组的成员，或者您必须具有向该组添加成员的权限。如果您无权修改组成员身份，请与域管理员联系。

有关选择帐户以运行服务的详细信息，请参阅 SQL Server 联机帮助中的“设置 Windows 服务帐户”。

选项

内置帐户
本地系统
  • 指定本地系统帐户。该帐户不需要密码。但是，本地系统帐户可能会阻止该服务与其他服务器进行交互，具体取决于该帐户所拥有的权限。

本地服务
  • 指定本地服务帐户。该帐户不需要密码。不过，本地服务帐户可能会阻止该服务与其他服务器进行交互，具体取决于该帐户所拥有的权限。

网络服务
  • 建议不要将网络服务帐户用于 SQL Server 或 SQL Server 代理服务。Local User 帐户或 Domain User 帐户更适用于这些服务。

本帐户

指定一个使用 Windows 身份验证的本地用户帐户或域用户帐户。建议使用具有最低服务权限的域用户帐户。

帐户名

指定本地用户帐户名或域用户帐户名。

密码

键入帐户的密码。

确认密码

再次键入帐户的密码。

启动

启动服务。

停止

停止服务。

暂停

暂停服务。

恢复

恢复暂停的服务。

注意：
启动 SQL Server 时，如果出现包含短语“未实现 [0x80004001]”的 WMI 错误，则可能指示目标计算机上未安装 SQL Server。


SQL Server 属性（“服务”选项卡）

SQL Server 属性（“服务”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

使用“MSSQLSERVER 属性”对话框中的“服务”选项卡可以查看或指定下列选项。

选项

二进制路径

列出此服务所使用的程序文件的位置。

错误控制

1 指示 SERVICE_ERROR_NORMAL。如果在计算机启动过程中无法启动该服务，则启动程序会记录该错误并显示一个弹出消息框，但仍会继续执行启动操作。此值不能更改。

退出代码

当发生错误时，错误号显示在此信息框中。您可以通过在 Microsoft 知识库中搜索该号码获取相关信息来排除故障，或将该错误号提供给技术支持人员以获得帮助。

主机名

显示运行 Microsoft SQL Server 服务的计算机或群集的名称。

名称

指示该服务的显示名称。

进程 ID

显示 Windows 进程 ID。

服务类型

显示用于调用进程的服务的类型。SQL Server 安装有多种服务。

启动模式

对此服务设置以下选项：

  • 手动：计算机启动时，此服务不自动启动。您必须使用 SQL Server 配置管理器或其他工具来启动该服务。

  • 自动：计算机启动时，此服务将尝试启动。

  • 已禁用：此服务无法启动。

状态

指示此服务是正在运行、已停止还是已禁用。“...”指示状态更改被挂起。


SQL Server 属性（FILESTREAM 选项卡）

SQL Server 属性（FILESTREAM 选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

使用此页可针对此 SQL Server 2008 安装启用 FILESTREAM。

针对 Transact-SQL 访问启用 FILESTREAM

选中此项可针对 Transact-SQL 访问启用 FILESTREAM。必须选中此控制选项，其他控制选项才可用。

针对文件 I/O 流访问启用 FILESTREAM

选中此项可针对 FILESTREAM 启用 Win32 流访问。

Windows 共享名

使用此控制选项可输入将用来存储 FILESTREAM 数据的 Windows 共享的名称。

允许远程客户端针对 FILESTREAM 数据启用流访问

选中此控制选项可允许远程客户端访问这台服务器上的此 FILESTREAM 数据。


SQL Server 属性（“高级”选项卡）

SQL Server 属性（“高级”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

默认情况下，“高级”选项卡中会显示下列属性。如果定义了自定义属性，定义的属性及其属性值将显示在此选项卡上。

选项

群集

指示此服务是否作为群集服务器的资源进行安装。

客户反馈报告

指示是否已对此服务启用服务质量监视。有关客户反馈报告的详细信息，请在联机丛书中搜索主题“错误和使用报告设置”。

数据路径

显示所安装 SQL Server 的 SQL Server 二进制文件路径。

转储目录

显示发生错误时内存转储的存放位置。

错误报告

当设置为“是”时，如果发生错误，Dr. Watson 程序将把相关信息转发给 Microsoft，或转发给错误服务器。有关错误报告的详细信息，请在联机丛书中搜索主题“错误和使用报告设置”。若要更改此值，请在 SQL Server Management Studio 对象资源管理器中右键单击服务器，再单击“属性”，然后单击“杂项服务器设置”页。这些选项将显示在“信息报告”区域中。

文件版本

显示 SQL Server 可执行文件的版本。

安装路径

显示所安装 SQL Server 的 SQL Server 二进制文件路径。

实例 ID

指示使用此服务的 SQL Server 实例。

语言

显示服务器消息的默认语言。

注册表根目录

显示此应用程序所使用的注册表项的位置。

Service Pack 级别

显示此 SQL Server 实例的 Service Pack 级别。

SKU 名称

显示产品的单品 (SKU)，有时称为产品版本。

启动参数

列出此 SQL Server 实例使用的所有启动参数。这些参数以分号分隔。默认参数包括 master 数据库的数据文件 (master.mdf)、master 数据库的日志文件 (mastlog.ldf) 和错误日志文件的路径。有关启动参数的语法，请在联机丛书中搜索主题“使用 SQL Server 服务启动选项”主题。

单品

显示产品的单品 (SKU) 编号。

版本

显示此 SQL Server 实例的版本号。

虚拟服务器名称

SQL Server 安装到群集服务器之后的虚拟服务器名称。


SQL Server Integration Services（SQL Server 配置管理器）

SQL Server Integration Services（SQL Server 配置管理器）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

此服务对 SSIS 提供支持。若要查看此服务的属性，请在详细信息窗格中右键单击此服务，再单击“属性”。

有关 SSIS 的信息，请参阅联机丛书。


SQL Server Integration Services 属性（“登录”选项卡）

SQL Server Integration Services 属性（“登录”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

使用“Integration Services 属性”对话框中的“登录”选项卡可以指定 Integration Services 服务使用的帐户，还可以启动和停止该服务。

选项

本地系统帐户

指定一个不要求输入密码的本地系统帐户。不过，本地系统帐户可能会限制该服务与其他服务器进行交互，具体取决于该帐户所拥有的权限。

本帐户

指定一个使用 Microsoft Windows 身份验证的本地用户帐户或域用户帐户。Microsoft 建议使用具有最低服务权限的域用户帐户。有关选择帐户的详细信息，请在联机丛书中搜索主题“设置 Windows 服务帐户”。

帐户名

指定本地用户帐户名或域用户帐户名。

密码

键入帐户的密码。

确认密码

再次键入帐户的密码。

启动

启动服务。

停止

停止服务。

暂停

暂停服务。

恢复

恢复暂停的服务。


SQL Server Integration Services 属性（“服务”选项卡）

SQL Server Integration Services 属性（“服务”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

使用“Integration Services 属性”对话框中的“服务”选项卡可以查看或指定下列选项。

选项

二进制路径

显示此服务所使用的程序文件的位置。

错误控制

1 指示 SERVICE_ERROR_NORMAL。如果在计算机启动过程中无法启动该服务，则启动程序会记录该错误并显示一个弹出消息框，但仍会继续执行启动操作。此值不能更改。

退出代码

Microsoft Windows 错误代码，定义了在启动或停止服务时遇到的任何问题。如果错误是此类表示的服务所特有的，并且 ServiceSpecificExitCode 属性中包含该错误的相关信息，则此属性将设置为 ERROR_SERVICE_SPECIFIC_ERROR (1066)。当服务运行时，会将此值设置为 NO_ERROR (0)；而当服务正常终止时，会再次对它进行设置。

主机名

显示运行 SSIS 服务的计算机或群集的名称。

名称

指示该服务的显示名称。

进程 ID

显示 Windows 进程 ID。

SQL 服务类型

显示用于调用进程的服务的类型。Microsoft SQL Server 安装有多种服务。

启动模式

对此服务设置以下选项：

  • 手动：计算机启动时，此服务不自动启动。您必须使用 SQL Server 配置管理器或其他工具来启动该服务。

  • 自动：计算机启动时，此服务将尝试启动。

  • 已禁用：此服务无法启动。

状态

指示此服务是正在运行、已停止还是已禁用。“…”指示状态更改被挂起。


SQL Server Integration Services 属性（“高级”选项卡）

SQL Server Integration Services 属性（“高级”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

Microsoft Integration Services 以 Integration Services服务的形式实现。如果定义了自定义属性，定义的属性及其属性值将显示在此选项卡上。此选项卡有可能不列出任何属性。


SQL 全文筛选器后台程序启动器（SQL Server 配置管理器）

SQL 全文筛选器后台程序启动器（SQL Server 配置管理器）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

从 SQL Server 2008 开始，SQL Server 全文搜索将使用 SQL 全文筛选器后台程序启动器 (FDHOST Launcher) 服务来启动筛选器后台程序主机进程，此进程用于处理全文搜索筛选和断字。必须运行此服务才能使用全文搜索。FDHOST Launcher 服务是可识别实例的服务，它与特定 SQL Server 实例相关联。FDHOST Launcher 服务将服务帐户信息传播到每个已启动的筛选器后台程序主机进程。有关筛选器后台程序主机进程的信息，请参阅 SQL Server 联机丛书中的“全文搜索体系结构”。


SQL 全文筛选器后台程序启动器（“登录”选项卡）

SQL 全文筛选器后台程序启动器（“登录”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

从 SQL Server 2008 开始，SQL Server 全文搜索将使用 SQL 全文筛选器后台程序启动器 (FDHOST Launcher) 服务。如果使用全文搜索，则必须运行此服务。有关筛选器后台程序主机进程的信息，请参阅 SQL Server 联机丛书中的“全文搜索体系结构”。

使用“SQL 全文筛选器后台程序启动器属性”对话框的“登录”选项卡可以指定 SQL Server 全文服务所使用的帐户，还可以更改帐户的密码以及启动和停止此服务。更改帐户的密码将在重新启动此服务后生效。

注意：
更改群集实例的服务所使用的帐户名时，新帐户必须是安装期间为服务指定的域组的成员，或者您必须具有向该组添加成员的权限。如果您无权修改组成员身份，请与域管理员联系。

有关选择帐户以运行服务的详细信息，请参阅 SQL Server 联机帮助中的“设置 Windows 服务帐户”。

选项

内置帐户
Local System

指定 Local System 帐户。该帐户不需要密码。但是，Local System 帐户可能会阻止该服务与其他服务器进行交互，具体取决于该帐户所拥有的权限。

Local Service

指定 Local Service 帐户。该帐户不需要密码。不过，Local Service 帐户可能会阻止该服务与其他服务器进行交互，具体取决于该帐户所拥有的权限。

Network Service

我们建议不要使用 Network Service 帐户运行 SQL Server 服务或 SQL Server 代理服务。Local User 帐户或 Domain User 帐户更适用于这些服务。

本帐户

指定一个使用 Windows 身份验证的本地用户帐户或域用户帐户。建议使用具有最低服务权限的域用户帐户。

帐户名

指定本地用户帐户名或域用户帐户名。

密码

键入帐户的密码。

确认密码

再次键入帐户的密码。

启动

启动服务。

停止

停止服务。

暂停

暂停服务。不可用于此服务。

继续

继续暂停的服务。


SQL 全文筛选器后台程序启动器（“服务”选项卡）

SQL 全文筛选器后台程序启动器（“服务”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

从 SQL Server 2008 开始，SQL Server 全文将使用 SQL 全文筛选器后台程序启动器 (FDHOST Launcher) 服务。如果使用全文搜索，则必须运行此服务。有关筛选器后台程序主机进程的信息，请参阅 SQL Server 联机丛书中的“全文搜索体系结构”。

使用“SQL 全文筛选器后台程序启动器属性”对话框上的“服务”选项卡可以查看或指定以下选项。

选项

二进制路径

列出此服务所使用的程序文件的位置。

错误控制

1 指示 SERVICE_ERROR_NORMAL。如果在计算机启动过程中无法启动该服务，则启动程序会记录该错误并显示一个弹出消息框，但仍会继续执行启动操作。此值不能更改。

退出代码

当发生错误时，错误号显示在此信息框中。您可以通过在 Microsoft 知识库中搜索该号码获取相关信息来排除故障，或将该错误号提供给技术支持人员以获得帮助。

主机名

显示运行 Microsoft SQL Server 服务的计算机或群集的名称。

名称

指示该服务的显示名称。

进程 ID

显示 Windows 进程 ID。

SQL 服务类型

显示用于调用进程的服务的类型。SQL Server 安装有多种服务。

启动模式

对此服务设置以下选项：

  • 手动：计算机启动时，此服务不自动启动。您必须使用 SQL Server 配置管理器或其他工具来启动该服务。

  • 自动：计算机启动时，此服务将尝试启动。

  • 已禁用：此服务无法启动。

状态

指示此服务是正在运行、已停止还是已禁用。“...”指示状态更改被挂起。


SQL 全文筛选器后台程序启动器（高级）

SQL 全文筛选器后台程序启动器（高级）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

从 SQL Server 2008 开始，SQL Server 全文将使用 SQL 全文筛选器后台程序启动器服务。如果使用全文搜索，则必须运行此服务。有关筛选器后台程序主机进程的信息，请参阅 SQL Server 联机丛书中的“全文搜索体系结构”。

默认情况下，“高级”选项卡上不出现任何属性。如果定义了自定义属性，则这些属性及其值将显示在此选项卡上。


未知服务（“登录”选项卡）

未知服务（“登录”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 服务 >

Microsoft SQL Server 配置管理器无法识别此服务。

SQL Server 配置管理器从运行此服务的计算机上的 WMI 提供程序接收服务信息。读取服务属性时出错，或者服务属性不完整。若要解决此问题，请尝试关闭 SQL Server 配置管理器并将其重新打开，或者检查运行此服务的计算机上的 WMI 提供程序。

WMI 提供程序是 Windows 组件。有关如何检查对 WMI 提供程序的权限的信息，请参阅 SQL Server 联机丛书中的“如何在 SQL Server 工具中将 WMI 配置为显示服务器状态”。

如果您认为自己查看的服务是正确的，请使用“未知服务属性”对话框中的“登录”选项卡，指定此服务使用的帐户，以及启动和停止此服务。

选项

本地系统帐户

指定一个不要求输入密码的本地系统帐户。但是，本地系统帐户可能会阻止该服务与其他服务器进行交互，具体取决于该帐户所拥有的权限。

本帐户

指定一个使用 Windows 身份验证的本地用户帐户或域用户帐户。建议使用具有最低服务权限的域用户帐户。有关选择帐户的信息，请参阅 SQL Server 联机丛书中的“设置 Windows 服务帐户”。

帐户名

指定本地用户帐户名或域用户帐户名。

密码

键入帐户的密码。

确认密码

再次键入帐户的密码。

启动

启动服务。

停止

停止服务。

暂停

暂停服务。

恢复

恢复暂停的服务。


SQL Server 2008 网络配置

SQL Server 2008 网络配置 |
 | 请参阅
SQL Server 配置管理器帮助 >

本节包含了按 F1 后看到的有关 SQL Server 配置管理器中“服务器网络配置”对话框的帮助主题。

请参阅

概念

SQL Server 配置管理器帮助

© 2010 Microsoft Corporation。保留所有权利。


适用于 <服务器> 的协议（SQL Server 配置管理器）

适用于 <服务器> 的协议（SQL Server 配置管理器）
SQL Server 配置管理器帮助 > SQL Server 2008 网络配置 >

若要配置数据库引擎使用的协议，可以在控制台窗格中为所需服务器实例选择“协议”，在详细信息窗格中右键单击相应协议，然后单击“属性”。


MSSQLSERVER 的协议属性（“标志”选项卡）

MSSQLSERVER 的协议属性（“标志”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 网络配置 >

当服务器上装有证书时，使用“MSSQLSERVER 的协议属性”对话框中的“标志”选项卡可以查看或指定协议加密以及隐藏实例选项。若要启用或禁用 ForceEncryption 设置，必须重新启动 Microsoft SQL Server。

若要加密连接，应为 SQL Server 数据库引擎提供一个证书。如果未安装证书，则实例启动后，SQL Server 将生成一个自我签署的证书。此自我签署的证书可代替可信证书颁发机构颁发的证书，但它不提供身份验证，也不具有不可否认性。

注意：
使用自我签署的证书加密的安全套接字层 (SSL) 连接不提供强安全性。它们容易在传输中途受到攻击。在生产环境中或在连接到 Internet 的服务器上，不应依赖使用自签名证书的 SSL。

有关加密的详细信息，请参阅 SQL Server 联机丛书中的“加密与 SQL Server 的连接”。

登录过程始终是加密的。如果将 ForceEncryption 设为“是”，则将对所有客户端/服务器通信进行加密，并必须将连接到数据库引擎的客户端配置为信任服务器证书的根颁发机构。有关详细信息，请参阅 SQL Server 联机丛书中的“如何启用数据库引擎的加密连接（SQL Server 配置管理器）”。

集群服务器

若要在故障转移群集中使用加密，必须在故障转移群集中的所有节点上安装具有完全限定的虚拟服务器 DNS 名称的服务器证书。例如，如果有一个包含两个节点的群集，节点名分别为“test1.<您的公司>.com”和“test2.<您的公司>.com”，还有一个名为“virtsql”的虚拟服务器，则需要在两个节点上安装“virtsql.<您的公司>.com”的证书。然后，可以选中 SQL Server 配置管理器中的 ForceEncryption 复选框以将故障转移群集配置为使用加密。

选项

强行加密

强制协议加密。加密是通过将数据更改为不可读的形式来保密敏感信息的方法。即使在传输过程中有人查看了传输数据包，加密也可以确保数据安全。若要使用渠道绑定，请将“强行加密”设置为“打开”，并在“高级”选项卡上配置“扩展保护”。

隐藏实例

防止 SQL Server Browser 服务向尝试通过使用“浏览”按钮来查找实例的客户端计算机公开此数据库引擎实例。在服务器上存在命名实例的情况下，若要连接，则客户端应用程序必须指定协议端点信息。例如，端口号或命名管道名（如 tcp:server,5000）。有关详细信息，请参阅连接到 SQL Server 数据库引擎。

有关详细信息，请参阅联机丛书中的“如何启用数据库引擎的加密连接（SQL Server 配置管理器）”。


MSSQLSERVER 属性的协议（“证书”选项卡）

MSSQLSERVER 属性的协议（“证书”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 网络配置 >

使用“MSSQLSERVER 协议的属性”对话框中的“证书”选项卡可以选择 Microsoft SQL Server 证书，也可以查看证书的属性。在选择证书之前，所有字段均为空。

用户的证书存储在本地计算机上。若要加载供 SQL Server 使用的证书，您必须在与 SQL Server 服务所用的同一用户帐户下运行 SQL Server 配置管理器。

页眉

查看

通过它可以访问有关证书的其他详细信息。只有在“证书”框中选择某个证书后，此选项才可用。有关证书详细信息的其他信息，请参阅 Microsoft Windows 2000 或 Microsoft Windows Server 2003 文档。

清除

从“证书”框中删除所选证书。

证书

由安全提供程序确定的证书名称。选择某个证书可以在属性网格中查看详细信息。

选项

过期日期

证书有效期最后一天的日期。

友好名称

获得证书的个人或证书颁发机构的友好名称或公用名称。

颁发者

有关颁发证书的证书颁发机构的信息。

颁发给

有关证书接收者的信息。


MSSQLSERVER 属性的协议（“高级”选项卡）

MSSQLSERVER 属性的协议（“高级”选项卡）
SQL Server 配置管理器帮助 > SQL Server 2008 网络配置 >

使用“MSSQLSERVER 属性的协议”对话框上的“高级”选项卡为 SQL Server 数据库引擎配置身份验证的扩展保护。扩展保护是操作系统实现的一项网络组件功能。Windows 7 和 Windows Server 2008 R2 提供扩展保护，旧操作系统的 Service Pack 中也包括此功能。使用扩展保护连接时，SQL Server 会更安全。扩展保护功能的一些好处需要选定“标志”选项卡上的“强行加密”后才能获得。

重要提示：
默认情况下，Windows 不启用扩展保护。有关如何在 Windows 中启用扩展保护的信息，请参阅知识库文章身份验证的扩展保护。

有关如何配置其他 SQL Server 服务，以及扩展保护的完整描述，请参阅 Microsoft.com 上的最新信息。

选项

扩展保护

有三种可能的值：

  • 当设置为“关闭”时，禁用扩展保护。SQL Server 的实例将接受来自任何客户端的连接，不管该客户端是否受保护。“关闭”选项虽与旧的和未打补丁的操作系统兼容，但安全性较差。只有在您知道客户端操作系统不支持扩展保护的情况下才使用此设置。

  • 当设置为“允许”时，来自支持扩展保护的操作系统的连接需要扩展保护。来自运行在受保护客户端操作系统上的不受保护客户端应用程序的连接被拒绝。对于来自不受保护操作系统的连接，忽略扩展保护。此设置虽比“关闭”更安全，但仍不是最安全的设置。在混合环境（即有些操作系统支持扩展保护，有些不支持）中使用此设置。

  • 当设置为“必需”时，只接受来自受保护操作系统上受保护应用程序的连接。此设置在三个选项中是最安全的，但来自不支持扩展保护的操作系统的连接将无法连接到 SQL Server。

接受的 NTLM SPN

当多个 NTLM 服务主体名称 (SPN) 标识 SQL Server 的实例时，在此以字符串系列形式列出 SPN，字符串之间用分号分隔。例如，值 MSSQLSvc/HostName1.Contoso.com;MSSQLSvc/HostName2.Contoso.com 指示尝试连接到名为 MSSQLSvc/HOST1 和 MSSQLSvc/HOST2 的客户端得到允许。变量的最大长度为 2048 个字符。


shared memory 属性

shared memory 属性 |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server 2008 网络配置 >

使用“Shared Memory 属性”对话框的“协议”页可以启用或禁用 Shared Memory 协议。Shared Memory 是可供使用的最简单协议，没有可配置的设置。由于使用 Shared Memory 协议的客户端仅可以连接到在同一台计算机运行的 Microsoft SQL Server 实例，因此它对于大多数数据库活动而言是没有用的。如果怀疑其他协议配置有误，请使用 Shared Memory 协议进行故障排除。

必须重新启动 SQL Server 才能启用或禁用该协议。

选项

启用

可能的值为“是”和“否”。默认情况下，Shared Memory 协议是启用的。

请参阅

参考

使用 Shared Memory 协议创建有效的连接字符串

概念

选择网络协议

© 2010 Microsoft Corporation。保留所有权利。


Named Pipes 属性

Named Pipes 属性 |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server 2008 网络配置 >

在使用 Named Pipes 协议时，可以使用“Named Pipes 属性”对话框的“协议”页查看或更改 Microsoft SQL Server 侦听的命名管道。

必须重新启动 SQL Server 才能启用或禁用该协议，或更改命名管道。

选项

启用

可能的值为“是”和“否”。

管道名称

指定 SQL Server 侦听的命名管道。默认情况下，SQL Server 侦听：\\.\pipe\sql\query（对于默认实例）和 \\.\pipe\MSSQL$<instancename>\sql\query（对于命名实例）。此字段最多允许 2047 个字符。

创建备用命名管道

若要更改命名管道，可以在“管道名称”框中键入新的管道名称，然后停止 SQL Server，再将其重新启动。由于 sql\query 是 SQL Server 使用的众所周知的命名管道，更改管道可以有效的降低恶意程序攻击的风险。

示例

键入 \\.\pipe\unit\app 以侦听 unit\app 管道。

键入 \\.\pipe\acct 以侦听 acct 管道。

请参阅

参考

使用 Named Pipes 创建有效的连接字符串

概念

选择网络协议

其他资源

如何启用或禁用服务器网络协议 (SQL Server PowerShell)

© 2010 Microsoft Corporation。保留所有权利。


TCP/IP 属性（“协议”选项卡）

TCP/IP 属性（“协议”选项卡） |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server 2008 网络配置 >

使用“TCP/IP 属性”对话框可以配置 TCP/IP 协议的选项。在左窗格中单击 TCP/IP 在详细信息窗格中显示单个 IP 地址配置。

必须重新启动 Microsoft SQL Server，更改才会生效。

选项

启用

可能的值为“是”和“否”。

保持活动状态

指定传输保持活动状态的数据包的时间间隔（毫秒），以检查位于连接远端的计算机是否仍可用。

全部侦听

指定 SQL Server 是否侦听所有绑定到计算机网卡的 IP 地址。如果设置为“否”，则使用每个 IP 地址各自的属性对话框对各个 IP 地址进行配置。如果设置为“是”，则 IPAll 属性框的设置将应用于所有 IP 地址。默认值为“是”。

无延迟

SQL Server 不会实施对此属性的更改。

请参阅

参考

使用 TCP/IP 创建有效的连接字符串

概念

选择网络协议

其他资源

如何启用或禁用服务器网络协议 (SQL Server PowerShell)

© 2010 Microsoft Corporation。保留所有权利。


TCP/IP 属性（“IP 地址”选项卡）

TCP/IP 属性（“IP 地址”选项卡） |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server 2008 网络配置 >

使用“TCP/IP 属性（‘IP 地址’选项卡）”对话框，可以配置特定 IP 地址的 TCP/IP 协议选项。只有选中“IP All”，才能一次配置所有地址的“TCP 动态端口”和“TCP 端口”。

在重新启动 Microsoft SQL Server 之后，更改才会生效。有关启动和停止 SQL Server Browser 服务的信息，请参阅联机丛书中的“如何启动和停止 SQL Server Browser 服务”。

静态端口与动态端口

SQL Server 的默认实例侦听端口 1433 的传入连接。可以出于安全性原因或根据客户端应用程序的请求来更改该端口。默认情况下，命名实例（包含 SQL Server Express）被配置为侦听动态端口。若要配置静态端口，请将“TCP 动态端口”框保留为空，并在“TCP 端口”框中提供一个可用的端口号。有关打开防火墙中的端口的详细信息，请参阅联机丛书中的“配置 Windows 防火墙以允许 SQL Server 访问”。

动态端口

如果某个 SQL Server 实例已配置为侦听动态端口，则在启动时，该实例将检查操作系统中的可用端口，并为该端口打开一个端点。传入连接必须指定要连接的端口号。由于每次启动 SQL Server 时端口号都可能会改变，因此 SQL Server 提供 SQL Server Browser 服务监视端口，并将传入连接指向该实例的当前端口。使用动态端口会增加通过防火墙连接 SQL Server 的复杂性，因为重新启动 SQL Server 时端口号可能会改变，从而需要更改防火墙设置。若要避免通过防火墙连接的问题，请将 SQL Server 配置为使用静态端口。

选项

活动

指示该 IP 地址在计算机上处于活动状态。不适用于“IPAll”。

启用

如果“TCP/IP 属性(‘协议’选项卡)”上的“全部侦听”属性设为“否”，则该属性指示 SQL Server 是否侦听 IP 地址。如果“TCP/IP 属性(‘协议’选项卡)”上的“全部侦听”属性设为“是”，则表示忽略该属性。不适用于“IPAll”。

IP 地址

查看或更改此连接使用的 IP 地址。列出计算机使用的 IP 地址以及 IP 环回地址 127.0.0.1。不适用于“IPAll”。该 IP 地址可以为 IPv4 格式或 IPv6 格式。

TCP 动态端口

如果未启用动态端口，则为空。若要使用动态端口，请设置为 0。

对于“IPAll”，将显示所用动态端口的端口号。

TCP 端口

查看或更改 SQL Server 侦听的端口。默认情况下，数据库引擎的默认实例侦听端口 1433。

SQL Server 数据库引擎可以侦听同一 IP 地址的多个端口，端口以逗号分隔的格式列出：1433,1500,1501。本字段最多允许 2047 个字符。

若要配置单个 IP 地址以侦听多个端口，还必须将“TCP/IP 属性”对话框的“协议”选项卡上的“全部侦听”参数设置为“否”。有关详细信息，请参阅 SQL Server 联机丛书中的“如何将数据库引擎配置为侦听多个 TCP 端口”。

添加或删除 IP 地址

SQL Server 配置管理器显示安装 SQL Server 时可用的 IP 地址。如果发生以下情况，可用的 IP 地址也会随之改变：添加或删除网卡、动态分配的 IP 地址过期、重新配置网络结构或计算机的物理位置发生改变（例如便携式计算机在另一座大楼连接到网络）。若要更改 IP 地址，可以编辑“IP 地址”框，然后重新启动 SQL Server。

请参阅

参考

使用 TCP/IP 创建有效的连接字符串

概念

选择网络协议
SQL Server Browser 服务

© 2010 Microsoft Corporation。保留所有权利。


VIA 属性

VIA 属性 |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server 2008 网络配置 >

使用“VIA 属性”对话框，可以查看或指定虚拟接口适配器 (VIA) 协议的以下选项。

必须重新启动 Microsoft SQL Server 才能启用或禁用该协议，或更改设置。

选项

默认端口

默认设置为 0:1433，格式为 <network interface card number>:<port number>。

启用

可能的值为“是”和“否”。默认情况下，VIA 协议是禁用的。

重要提示：
不推荐使用 VIA 协议。后续版本的 Microsoft SQL Server 将删除该功能。请避免在新的开发工作中使用该功能，并着手修改当前还在使用该功能的应用程序。

侦听信息

默认设置为 0:1433，格式为 <network interface card number>:<port number>。

如果要列出多个端口，则将它们用英文逗号分开。此字段最多允许 2047 个字符。

注意：
安装了多个 SQL Server 实例后，可以检查端口设置并将每个端口配置为仅可以被一个实例使用。使用 TCP/IP 时，SQL Server 阻止两个实例侦听同一个端口，但使用 VIA 时不阻止。如果两个实例在侦听同一个端口，则传入的 VIA 连接可能无法连接，或连接到意外实例。

请参阅

概念

选择网络协议

© 2010 Microsoft Corporation。保留所有权利。


SQL Server Native Client 配置

SQL Server Native Client 配置
SQL Server 配置管理器帮助 >

本节包含了按 F1 后看到的有关 Microsoft SQL Server 配置管理器中“SQL Server Native Client 配置”对话框的帮助主题。SQL Server Native Client 是客户端计算机用于连接到 SQL Server 的网络库，与 Microsoft SQL Server 一起启动。

SQL Server Native Client 配置中配置的设置将在运行客户端程序的计算机上使用。在运行 SQL Server 的计算机上配置这些设置时，它们仅影响那些运行在服务器上的客户端程序。

这些设置不会影响连接到早期版本的 SQL Server 的客户端，除非它们使用与 SQL Server 一起启动的客户端工具，例如 SQL Server Management Studio。

本节内容

  • 使用 VIA 协议创建有效的连接字符串

  • 客户端协议（SQL Server 配置管理器）

    • 客户端协议属性（“顺序”选项卡）

    • 客户端协议 - Shared Memory 属性（“协议”选项卡）

    • 客户端协议 - TCP/IP 属性（“协议”选项卡）

    • 客户端协议 - Named Pipes 属性（“协议”选项卡）

    • 客户端协议 - VIA 属性（“协议”选项卡）

  • 别名（SQL Server 配置管理器）

    • 新建别名（“别名”选项卡）

    • <别名> 属性（“别名”选项卡）

    • 使用 Shared Memory 协议创建有效的连接字符串

    • 使用 TCP/IP 创建有效的连接字符串

    • 使用 Named Pipes 创建有效的连接字符串

    • 使用 VIA 协议创建有效的连接字符串


SQL Server Native Client 配置属性（“标志”选项卡）

SQL Server Native Client 配置属性（“标志”选项卡）
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 >

此计算机上的 Microsoft SQL Server 客户端使用 SQL Server Native Client 库文件中提供的协议与 SQL Server 服务器进行通信。使用本页可将客户端计算机配置为使用安全套接字层 (SSL) 请求加密的连接。如果无法建立加密的连接，则连接将失败。

登录过程始终是加密的。以下选项仅适用于加密数据。有关 SQL Server 如何加密通信的详细信息，以及如何将客户端配置为信任服务器证书的根颁发机构的说明，请参阅 SQL Server 联机丛书中的“对到 SQL Server 的连接进行加密”和“如何启用数据库引擎的加密连接（SQL Server 配置管理器）”。

选项

强制协议加密

使用 SSL 请求连接。

信任服务器证书

当设置为“否”时，客户端进程将尝试验证服务器证书。客户端和服务器均必须拥有公共证书颁发机构颁发的证书。如果客户端计算机上没有证书，或如果验证证书失败，则连接将终止。

当设置为“是”时，客户端不会验证服务器证书，而是使用自签名证书。

只有在“强制协议加密”设置为“是”时才可使用“信任服务器证书”。


客户端协议（SQL Server 配置管理器）

客户端协议（SQL Server 配置管理器）
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 >

若要配置此计算机上的 Microsoft SQL Server 客户端所使用的协议顺序，请在控制台窗格中右键单击“客户端协议”，再单击“属性”，或者在详细信息窗格中右键单击某个协议，再单击“顺序”。

若要配置此计算机上的 SQL Server 客户端所使用的客户端协议属性，请在控制台窗格中单击“客户端协议”，再在详细信息窗格中右键单击所需的协议，然后单击“属性”。


客户端协议属性（“顺序”选项卡）

客户端协议属性（“顺序”选项卡） |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 > 客户端协议（SQL Server 配置管理器） >

使用“客户端协议属性”对话框中的“顺序”页可以查看和启用客户端协议。

单击某个协议，再单击“启用”或“禁用”，可以将所选协议移到“启用的协议”列表或“禁用的协议”列表中。

协议的使用顺序与其列出的顺序相同，首先尝试使用第一个列出的协议进行连接，然后使用第二个列出的协议，依此类推。通过单击向上键和向下键按钮，可以在“启用的协议”列表中向上或向下移动协议。从该计算机上的客户端连接到 Microsoft SQL Server 时，将始终首先尝试使用“Shared Memory”协议（如果已启用）。

注意：
Microsoft .NET SqlClient 不会使用这些设置。.NET SqlClient 的协议顺序依次为：TCP、命名管道。此顺序不能改变。

选项

禁用的协议

列出已安装但当前未使用的协议。

启用的协议

列出此计算机上的 Microsoft SQL Server 客户端可以使用的协议。

>

启用“禁用的协议”框中当前突出显示的协议，会将其移到“启用的协议”框中。

<

禁用“启用的协议”框中当前突出显示的协议，会将其移到“禁用的协议”框中。

向上键

在列表中向上移动突出显示的协议。这样就可以使网络库尝试使用所选协议进行连接的优先级提高。

向下键

在列表中向下移动突出显示的协议。这样就可以使网络库尝试使用所选协议进行连接的优先级降低。

启用 Shared Memory 协议

从该计算机上的客户端连接到 SQL Server 时，启用 Shared Memory 协议。在启用了该协议的情况下，始终首先尝试使用该协议。

注意：
如果通过前缀或连接字符串的一部分指定了协议，则仅尝试使用指定的协议。

请参阅

概念

选择网络协议

© 2010 Microsoft Corporation。保留所有权利。


客户端协议 - Shared Memory 属性（“协议”选项卡）

客户端协议 - Shared Memory 属性（“协议”选项卡） |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 > 客户端协议（SQL Server 配置管理器） >

在 Microsoft SQL Server 配置管理器中，使用“Shared Memory 属性”对话框中的“协议”选项卡可以查看或修改共享内存。有关使用连接字符串的详细信息，请参阅使用 Shared Memory 协议创建有效的连接字符串。

选项

启用

可能的值为“是”和“否”。

请参阅

概念

选择网络协议

© 2010 Microsoft Corporation。保留所有权利。


客户端协议 - TCP/IP 属性（“协议”选项卡）

客户端协议 - TCP/IP 属性（“协议”选项卡） |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 > 客户端协议（SQL Server 配置管理器） >

在 Microsoft SQL Server 配置管理器中，可以使用“TCP/IP 属性”对话框的“协议”选项卡查看或指定下列选项。若要连接到另一个端口，可以在“默认端口”框中键入端口号。有关使用连接字符串的详细信息，请参阅使用 TCP/IP 创建有效的连接字符串。

选项

默认端口

指定 TCP/IP Net-library 在尝试连接到 SQL Server 的目标实例时将使用的端口。默认值端口为 1433。

连接到数据库引擎的默认实例时，客户端将使用此值。如果已经将默认实例配置为侦听另一个端口，则要将此值更改为该端口号。

连接到数据库引擎的命名实例时，客户端将尝试从在服务器上运行的 SQL Server Browser 服务获取端口号。如果 SQL Server Browser 服务没有运行，则必须通过此设置或作为连接字符串的一部分提供端口号。

启用

可能的值为“是”和“否”。

保持活动状态

此参数（毫秒）控制 TCP 尝试发送 KEEPALIVE 包以检查空闲连接是否仍保持原样的频率。默认值为 30000 毫秒。

保持活动状态的间隔

此参数（毫秒）确定重新传输 KEEPALIVE 直到接收到响应的间隔。默认值为 1000 毫秒。

请参阅

参考

新建别名（“别名”选项卡）
<别名> 属性（“别名”选项卡）

概念

选择网络协议

© 2010 Microsoft Corporation。保留所有权利。


客户端协议 - Named Pipes 属性（“协议”选项卡）

客户端协议 - Named Pipes 属性（“协议”选项卡） |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 > 客户端协议（SQL Server 配置管理器） >

在 Microsoft SQL Server 配置管理器中，使用“Named Pipes 属性”对话框中的“协议”选项卡可以查看或修改默认管道的说明。若要连接到其他管道，请在“默认管道”框中键入该管道。有关使用连接字符串的详细信息，请参阅使用 Named Pipes 创建有效的连接字符串。

选项

默认管道

指定 Named Pipes 网络库用来尝试连接到 SQL Server 目标实例的默认管道。默认情况下，SQL Server 侦听：\\.\pipe\sql\query

若要连接到默认管道，请输入 sql\query

启用

可能的值为“是”和“否”。

请参阅

概念

选择网络协议

© 2010 Microsoft Corporation。保留所有权利。


客户端协议 - VIA 属性（“协议”选项卡）

客户端协议 - VIA 属性（“协议”选项卡） |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 > 客户端协议（SQL Server 配置管理器） >

在 Microsoft SQL Server 配置管理器中，使用“VIA 属性”对话框中的“协议”选项卡可以查看或指定“虚拟接口适配器”的下列选项。有关连接字符串的详细信息，请参阅使用 VIA 协议创建有效的连接字符串。

重要提示：
不推荐使用 VIA 协议。后续版本的 Microsoft SQL Server 将删除该功能。请避免在新的开发工作中使用该功能，并着手修改当前还在使用该功能的应用程序。

选项

默认 NIC

指示 VIA 协议绑定到的网络接口卡 (NIC)。NIC 的编号从零开始。只有一个 NIC 的计算机使用 0 作为 NIC 的编号。

默认服务器

VIA 端口是 VIA 接受来自 VIA 客户端的连接时侦听的端口。

启用

可能的值为“是”和“否”。

请参阅

概念

选择网络协议

© 2010 Microsoft Corporation。保留所有权利。


别名（SQL Server 配置管理器）

别名（SQL Server 配置管理器）
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 >

别名是可用于进行连接的备用名称。别名封装了连接字符串所必需的元素，并使用用户所选择的名称显示这些元素。若要创建此计算机上的 Microsoft SQL Server 客户端的别名，请在控制台窗格中右键单击“别名”，再单击“新建别名”。若要配置此计算机上的 SQL Server 客户端的现有别名，请在控制台窗格中单击“别名”，再在详细信息窗格中右键单击所需的现有别名，然后单击“属性”。


新建别名（“别名”选项卡）

新建别名（“别名”选项卡）
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 > 别名（SQL Server 配置管理器） >

别名是可用于进行连接的备用名称。别名封装了连接字符串所必需的元素，并使用用户所选择的名称显示这些元素。使用“别名 - 新建”对话框中的“别名”页可以指定别名连接字符串的元素。若要更改现有别名的连接字符串，请参阅 <别名> 属性（“别名”选项卡）。

无需在“属性”的所有网格中都填写值。有效组合因所选协议的不同而有所变化。请参阅下面列出的有关有效组合示例的主题。

别名

用于引用此连接的名称（别名）。

管道名称/端口号/VIA 参数

连接字符串的其他元素。此框的名称随所选协议的不同而变化。

重要提示：
不推荐使用 VIA 协议。后续版本的 Microsoft SQL Server 将删除该功能。请避免在新的开发工作中使用该功能，并着手修改当前还在使用该功能的应用程序。

协议

连接所用的协议。

服务器

所连接的 Microsoft SQL Server 实例的名称。

何时使用别名

默认情况下，SQL Server 使用“共享内存”协议连接到 SQL Server 的本地实例，使用“TCP/IP”或“命名管道”连接到其他计算机上的 SQL Server 实例。请在以下情况下创建别名：使用 TCP/IP、命名管道或 VIA 并且希望提供自定义连接字符串时；希望使用服务器名称之外的其他名称进行连接时。

示例

  • SQL Server 不会侦听默认 TCP/IP 端口 1433，因此您希望提供一个包含另一端口号的连接字符串。

  • SQL Server 不会侦听默认命名管道，因此您希望提供一个包含不同管道名称的连接字符串。

  • 希望将应用程序连接到名为 ACCT 的服务器上的数据库，但该数据库已合并为名为 CENTRAL 的服务器上的 ACCT 实例。该应用程序不能轻易更改。创建一个别名 ACCT，其中包含指向 CENTRAL\ACCT 的连接字符串。

创建有效连接字符串

有关别名属性的有效组合的说明和示例，请参阅下列主题：

  • 使用 Shared Memory 协议创建有效的连接字符串

  • 使用 TCP/IP 创建有效的连接字符串

  • 使用 Named Pipes 创建有效的连接字符串

  • 使用 VIA 协议创建有效的连接字符串


<别名> 属性（“别名”选项卡）

<别名> 属性（“别名”选项卡） |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 > 别名（SQL Server 配置管理器） >

别名是可用于进行连接的备用名称。别名封装了连接字符串所必需的元素，并使用用户所选择的名称显示这些元素。使用“<别名> 属性”对话框中的“别名”页可以查看或指定别名连接字符串的元素。

选项

别名

用于引用此连接的名称（别名）。

管道名称/端口号/VIA 参数

连接字符串的其他元素。此框的名称随所选协议的不同而变化。请参阅下列主题中的示例。

重要提示：
不推荐使用 VIA 协议。后续版本的 Microsoft SQL Server 将删除该功能。请避免在新的开发工作中使用该功能，并着手修改当前还在使用该功能的应用程序。

协议

连接所用的协议。

服务器

所连接的 Microsoft SQL Server 实例的名称。

请参阅

参考

使用 Shared Memory 协议创建有效的连接字符串
使用 TCP/IP 创建有效的连接字符串
使用 Named Pipes 创建有效的连接字符串
使用 VIA 协议创建有效的连接字符串

© 2010 Microsoft Corporation。保留所有权利。


使用 Shared Memory 协议创建有效的连接字符串

使用 Shared Memory 协议创建有效的连接字符串 |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 > 别名（SQL Server 配置管理器） >

从运行在同一台计算机上的客户端到 Microsoft SQL Server 的连接使用 shared memory 协议。共享内存没有可配置的属性。始终会先尝试使用共享内存，无法将其从“客户端协议属性”列表中“启用的协议”列表的顶部位置移开。可以禁用 shared memory 协议，在排除其他某个协议的故障时，这样做很有用。

不能使用 shared memory 协议来创建别名，但是如果启用了共享内存，然后通过名称连接到数据库引擎，就可以创建共享内存连接。共享内存连接字符串的格式为 lpc:<servername>[\instancename]。

连接到本地服务器

当连接与客户端运行在同一台计算机上的 SQL Server 时，可以使用“(本地)”作为服务器名称。由于上述方法不明确，因此不建议使用，但是当客户端运行在已知的计算机上时，该方法还是有用的。例如，当为断开连接的移动用户（如销售人员，其 SQL Server 将运行在便携式计算机上并存储相应的项目数据）创建应用程序时，连接到“(本地)”的客户端就可以始终与运行在便携式计算机上的 SQL Server 保持连接。可以使用词语“本地主机”或句点 (.) 来取代“(本地)”。

验证连接协议

以下查询将返回当前连接所使用的协议。

复制代码
SELECT net_transport
FROM sys.dm_exec_connections
WHERE session_id = @@SPID;

示例：

如果已启用 shared memory 协议，下列名称将使用该协议连接到本地计算机：

<servername>

<servername>\<instancename>

(local)

localhost

不能为共享内存连接创建别名。

注意：
在“服务器”框中指定 IP 地址将产生 TCP/IP 连接。

请参阅

参考

使用 TCP/IP 创建有效的连接字符串
使用 Named Pipes 创建有效的连接字符串
使用 VIA 协议创建有效的连接字符串

概念

选择网络协议

© 2010 Microsoft Corporation。保留所有权利。


使用 TCP/IP 创建有效的连接字符串

使用 TCP/IP 创建有效的连接字符串 |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 > 别名（SQL Server 配置管理器） >

若要使用 TCP/IP 来创建有效的连接字符串，必须执行以下操作：

  • 指定“别名”。

  • 在“服务器”框中，输入可以使用 PING 实用工具连接到的服务器名称或 IP 地址。对于命名实例，请追加实例名称。

  • 在“协议”框中指定 TCP/IP。

  • 在“端口号”框中输入端口号（可选）。默认端口号为 1433，这是服务器上默认的数据库引擎实例的端口号。若要连接到命名实例或未侦听端口 1433 的默认实例，则必须提供端口号，或者启动 SQL Server Browser 服务。有关配置 SQL Server Browser 服务的信息，请参阅 SQL Server Browser 服务。

连接时，SQL Server Native Client 组件将从指定别名的注册表中读取服务器、协议和端口的值，然后创建一个格式为 tcp:<servername>[\<instancename>],<port> 或 tcp:<IPAddress>[\<instancename>],<port> 的连接字符串。

注意：
默认情况下，Microsoft Windows XP Service Pack 2 将启用 Windows 防火墙，这将默认关闭端口 1433。因为 Microsoft SQL Server 通过端口 1433 进行通信，因此，如果将 SQL Server 配置为使用 TCP/IP 侦听传入客户端连接，则必须重新打开该端口。有关配置防火墙的信息，请参阅 SQL Server 联机丛书中的“如何将防火墙配置为允许 SQL Server 访问”，或者查阅防火墙文档。

SQL Server 和 SQL Server Native Client 完全支持 Internet 协议版本 4 (IPv4) 和 Internet 协议版本 6 (IPv6)。SQL Server 配置管理器接受 IPv4 和 IPv6 格式的 IP 地址。有关 IPv6 的信息，请参阅 SQL Server 联机丛书中的“使用 IPv6 进行连接”。

连接到本地服务器

当连接与客户端运行在同一台计算机上的 SQL Server 时，可以使用 (local) 作为服务器名称。由于上述方法不明确，因此不建议使用，但是当客户端运行在已知的计算机上时，该方法还是有用的。例如，当为断开连接的移动用户（如销售人员，其 SQL Server 将运行在便携式计算机上并存储相应的项目数据）创建应用程序时，连接到 (local) 的客户端就可以始终与运行在便携式计算机上的 SQL Server 保持连接。可以使用词语 localhost 或句点 (.) 来取代 (local)。

验证连接协议

以下查询将返回当前连接所使用的协议。

复制代码
SELECT net_transport
FROM sys.dm_exec_connections
WHERE session_id = @@SPID;

示例

通过服务器名称进行连接：

复制代码
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             <servername>

通过服务器名称连接到已命名的实例：

复制代码
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             <servername>\<instancename>

通过服务器名称连接到指定的端口：

复制代码
Alias Name         <serveralias>
Port No            <port>
Protocol           TCP/IP
Server             <servername>

通过 IP 地址进行连接：

复制代码
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             <IPAddress>

通过 IP 地址连接到命名实例：

复制代码
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             <IPAddress>\<instancename>

通过 IP 地址连接到指定的端口：

复制代码
Alias Name         <serveralias>
Port No            <port number>
Protocol           TCP/IP
Server             <IPAddress>

使用 (local) 连接到本地计算机：

复制代码
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             (local)

使用 localhost 连接到本地计算机：

复制代码
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             localhost

连接到本地计算机 localhost 上的命名实例：

复制代码
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             localhost\<instancename>

使用句点连接到本地计算机：

复制代码
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             .

使用句点连接到本地计算机上的命名实例：

复制代码
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             .\<instancename>
注意：
有关以 sqlcmd 参数形式指定网络协议的信息，请参阅 SQL Server 联机丛书中的“如何使用 sqlcmd.exe 连接到数据库引擎”。

请参阅

参考

使用 Shared Memory 协议创建有效的连接字符串
使用 Named Pipes 创建有效的连接字符串
使用 VIA 协议创建有效的连接字符串

概念

选择网络协议

© 2010 Microsoft Corporation。保留所有权利。


使用 Named Pipes 创建有效的连接字符串

使用 Named Pipes 创建有效的连接字符串 |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 > 别名（SQL Server 配置管理器） >

默认 Microsoft SQL Server 实例侦听“named pipes”协议时，除非用户进行了更改，否则将使用 \\.\pipe\sql\query 作为管道名称。句点指示该计算机是本地计算机，pipe 指示该连接是命名管道，sql\query 为管道名称。若要连接到默认管道，别名必须使用 \\<computer_name>\pipe\sql\query 作为管道名称。如果已将 SQL Server 配置为侦听其他管道，则管道名称必须使用该管道。例如，如果 SQL Server 使用 \\.\pipe\unit\app 作为管道，则别名必须使用 \\<computer_name>\pipe\unit\app 作为管道名称。

若要创建一个有效的管道名称，必须执行以下操作：

  • 指定“别名”。

  • 选择“命名管道”作为“协议”。

  • 输入“管道名称”。或者，将“管道名称”留空，在您指定了“协议”和“服务器”后，SQL Server 配置管理器将会填入适当的管道名称。

  • 指定“服务器”。对于命名实例，可以提供服务器名称和实例名称。

连接时，SQL Server Native Client 组件将从指定别名的注册表中读取服务器、协议和管道名称的值，然后创建一个格式为 np:\\<computer_name>\pipe\<pipename> 或 np:\\<IPAddress>\pipe\<pipename> 的管道名称。对于命名实例，默认的管道名称为 \\<computer_name>\pipe\MSSQL$<instance_name>\sql\query。

注意：
默认情况下，Microsoft Windows XP Service Pack 2 将启用 Windows 防火墙，这将默认关闭端口 445。因为 Microsoft SQL Server 通过端口 445 进行通信，因此，如果将 SQL Server 配置为使用命名管道侦听传入客户端连接，则必须重新打开该端口。有关配置防火墙的信息，请参阅 SQL Server 联机丛书中的“如何将防火墙配置为允许 SQL Server 访问”，或者查阅防火墙文档。

连接到本地服务器

当连接与客户端运行在同一台计算机上的 SQL Server 时，可以使用 (local)作为服务器名称。由于上述方法不明确，因此不建议使用 (local)，但是当客户端运行在已知的计算机上时，该方法还是有用的。例如，当为断开连接的移动用户（如销售人员，其 SQL Server 将运行在便携式计算机上并存储相应的项目数据）创建应用程序时，连接到 (local) 的客户端就可以始终与运行在便携式计算机上的 SQL Server 保持连接。可以使用词语 localhost 或句点 (.) 来取代 (local)。

验证连接协议

以下查询将返回当前连接所使用的协议。

复制代码
SELECT net_transport
FROM sys.dm_exec_connections
WHERE session_id = @@SPID;

示例

通过服务器名称连接到默认管道：

复制代码
Alias Name         <serveralias>
Pipe Name          <blank>
Protocol           Named Pipes
Server             <servername>

通过 IP 地址连接到默认管道：

复制代码
Alias Name         <serveralias>
Pipe Name          <leave blank>
Protocol           Named Pipes
Server             <IPAddress>

通过服务器名称连接到非默认管道：

复制代码
Alias Name         <serveralias>
Pipe Name          \\<servername>\pipe\unit\app
Protocol           Named Pipes
Server             <servername>

通过服务器名称连接到已命名的实例：

复制代码
Alias Name         <serveralias>
Pipe Name          \\<servername>\pipe\MSSQL$<instancename>\SQL\query
Protocol           Named Pipes
Server             <servername>

使用 localhost 连接到本地计算机：

复制代码
Alias Name         <serveralias>
Pipe Name          <blank>
Protocol           Named Pipes
Server             localhost

使用句点连接到本地计算机：

复制代码
Alias Name         <serveralias>
Pipe Name          <left blank>
Protocol           Named Pipes
Server             .
注意：
若要以 sqlcmd 参数形式指定网络协议，请参阅 SQL Server 联机丛书中的“如何使用 sqlcmd.exe 连接到数据库引擎”。

请参阅

参考

使用 Shared Memory 协议创建有效的连接字符串
使用 TCP/IP 创建有效的连接字符串
使用 VIA 协议创建有效的连接字符串

概念

选择网络协议

© 2010 Microsoft Corporation。保留所有权利。


使用 VIA 协议创建有效的连接字符串

使用 VIA 协议创建有效的连接字符串 |
 | 请参阅
SQL Server 配置管理器帮助 > SQL Server Native Client 配置 > 别名（SQL Server 配置管理器） >

若要使用“虚拟接口适配器”(VIA) 创建有效连接字符串，您必须提供下列所有元素：

  • 指定“别名”。

  • 在“VIA 参数”框中，提供网络接口卡 (NIC) 编号，后跟端口号。如果保留空白，则 VIA 将尝试连接到端口 <NIC#>:1433。

  • 将“VIA”指定为“协议”。

  • 在“服务器”字段中，输入命名实例的服务器名称或“<servername>\<instancename>”。

连接时，SQL Server Native Client 组件将从指定“别名”的注册表中读取“服务器”、“协议”和“VIA 参数”值，然后创建一个格式为 via:<servername> [\instancename],<nic number>:<port> 的连接字符串。

重要提示：
如果同一计算机上安装有两个或多个 Microsoft SQL Server 实例，则 VIA 连接可能会不明确。VIA 协议启用后，将尝试使用 TCP/IP 设置，并侦听端口 0:1433。对于不允许配置端口的 VIA 驱动程序，两个 SQL Server 实例均将侦听同一端口。传入的客户端连接可能是到正确服务器实例的连接，也可能是到不正确服务器实例的连接，还有可能由于端口正在使用而被拒绝连接。

重要提示：
不推荐使用 VIA 协议。后续版本的 Microsoft SQL Server 将删除该功能。请避免在新的开发工作中使用该功能，并着手修改当前还在使用该功能的应用程序。

验证连接协议

以下查询将返回当前连接所使用的协议。

复制代码
SELECT net_transport
FROM sys.dm_exec_connections
WHERE session_id = @@SPID;

示例：

通过服务器名称进行连接：

复制代码
Alias Name         ServerAlias
Via Parameters     0:1433
Protocol           VIA
Server             <servername>

通过服务器名称连接到命名实例：

复制代码
Alias Name         ServerAlias
Via Parameters     0:1433
Protocol           VIA
Server             <servername>\<instancename>
注意：
若要以 sqlcmd 参数形式指定网络协议，请在联机丛书中搜索主题“如何使用 sqlcmd.exe 连接到数据库引擎”。

请参阅

参考

使用 Shared Memory 协议创建有效的连接字符串
使用 TCP/IP 创建有效的连接字符串
使用 Named Pipes 创建有效的连接字符串

概念

选择网络协议

© 2010 Microsoft Corporation。保留所有权利。


SQL Server Browser 服务

SQL Server Browser 服务 |
 | 请参阅
SQL Server 配置管理器帮助 >

SQL Server 浏览器程序以 Windows 服务的形式运行。SQL Server 浏览器侦听对 Microsoft SQL Server 资源的传入请求，并提供计算机上安装的 SQL Server 实例的相关信息。SQL Server 浏览器可用于执行下列操作：

  • 浏览可用服务器列表

  • 连接到正确的服务器实例

  • 连接到专用管理员连接 (DAC) 端点

SQL Server Browser 服务 (sqlbrowser) 为数据库引擎和 SSAS 的每个实例提供实例名称和版本号。SQL Server 浏览器随 SQL Server 一起安装，为该计算机上运行的早期版本的 SQL Server（从 SQL Server 7.0 开始）提供此服务。

SQL Server 浏览器可以在安装过程中进行配置，也可以使用 SQL Server 配置管理器进行配置。默认情况下，SQL Server Browser 服务会自动启动：

  • 升级安装时。

  • 与 SQL Server 2000 实例并行安装时。

  • 在群集上安装时。

  • 安装包括所有 SQL Server Express 实例的SQL Server 数据库引擎的命名实例时。

  • 安装 Analysis Services 的命名实例时。

后台

在 SQL Server 2000 之前，一台计算机上只能安装一个 SQL Server 实例。SQL Server 侦听 1433 端口传入的请求，此端口由官方的 Internet 号码分配机构 (IANA) 分配给 SQL Server。只有一个 SQL Server 实例可以使用端口，因此当 SQL Server 2000 引入对 SQL Server 多个实例的支持时，便开发了 SQL Server 解析协议 (SSRP)，用于侦听 UDP 1434 端口。此侦听器服务用已安装的实例的名称以及实例使用的端口或命名管道来响应客户端请求。为了解决 SSRP 系统的限制，SQL Server 2005 引入了 SQL Server Browser 服务来替换 SSRP。

SQL Server 浏览器工作原理

启动一个 SQL Server 实例后，如果为 SQL Server 启用了 TCP/IP 或 VIA 协议，服务器将被分配一个 TCP/IP 端口。如果启用了 Named Pipes 协议，SQL Server 将侦听特定的命名管道。该特定实例将使用此端口（或“管道”）与客户端应用程序交换数据。在安装过程中，TCP 1433 端口和管道 \sql\query 将分配给默认实例，但服务器管理员可以随后使用 SQL Server 配置管理器进行更改。由于只有一个 SQL Server 实例可以使用端口或管道，因此，会将不同的端口号和管道名称分配给命名实例，包括 SQL Server Express。默认情况下，命名实例和 SQL Server Express 在启用时便配置为使用动态端口，也就是说，当 SQL Server 启动时就分配了可用端口。如果需要，可以为 SQL Server 实例分配特定端口。连接时，客户端可以指定特定端口，但是如果端口是动态分配的，端口号可能会在重新启动 SQL Server 时被更改，因此正确的端口号对于客户端来说是不确定的。

启动后，SQL Server 浏览器将启动并使用 UDP 1434 端口。SQL Server 浏览器将读取注册表，识别计算机上的所有 SQL Server 实例，并注明它们使用的端口和命名管道。当一台服务器具有两个或多个网卡时，SQL Server 浏览器会为 SQL Server 返回其遇到的第一个已启用的端口。SQL Server 浏览器支持 ipv6 和 ipv4。

当 SQL Server 客户端请求 SQL Server 资源时，客户端网络库将使用 1434 端口向服务器发送一条 UDP 消息。SQL Server 浏览器将用请求的实例的 TCP/IP 端口或命名管道做出响应。然后，客户端应用程序中的网络库将使用所需实例的端口或命名管道向服务器发送请求来完成连接。

有关启动和停止 SQL Server Browser 服务的信息，请参阅如何启动和停止 SQL Server Browser 服务。

重要提示：
不推荐使用 VIA 协议。后续版本的 Microsoft SQL Server 将删除该功能。请避免在新的开发工作中使用该功能，并着手修改当前还在使用该功能的应用程序。

使用 SQL Server 浏览器

当 SQL Server Browser 服务不运行时，如果您提供了正确的端口号或命名管道，仍可以连接到 SQL Server。例如，如果 SQL Server 的默认实例在 1433 端口上运行，则可以使用 TCP/IP 连接到此默认实例。

但是，如果 SQL Server Browser 服务未运行，则以下连接无效：

  • 在未完全指定所有参数（例如 TCP/IP 端口或命名管道）的情况下，组件尝试连接到命名实例。

  • 生成或传递其他组件随后要用来进行重新连接的服务器/实例信息的组件。

  • 未提供端口号或管道就连接到命名实例。

  • 在未使用 TCP/IP 1433 端口的情况下，将 DAC 连接到命名实例或默认实例。

  • OLAP 重定向程序服务。

  • 枚举 SQL Server Management Studio、企业管理器或查询分析器中的服务器。

如果在客户端服务器方案中使用 SQL Server（例如，应用程序通过网络访问 SQL Server），那么，若要停止或禁用 SQL Server Browser 服务，必须为每个实例分配一个特定端口号，并编写客户端应用程序代码以便始终使用该端口号。此方法存在如下问题：

  • 必须更新和维护客户端应用程序代码才能确保它连接到正确的端口。

  • 如果服务器上的其他服务或应用程序可以使用您为每个实例选择的端口，则会导致 SQL Server 实例不可用。

并行安装 SQL Server 2000

在 SQL Server 2000 中，通过 SQL Server 服务识别服务器连接端点。在 SQL Server 2005 中，该功能是通过 SQL Server Browser 服务实现的。如果在已运行 SQL Server 2000 或 MSDE 的计算机上安装 SQL Server，则必须确保 SQL Server 2000 或 MSDE 已升级到 Service Pack 3a (SP3a) 或更高版本。SP3a 之前的版本无法正确共享 1434 端口，并且可能会使 SQL Server 实例不能用于请求客户端应用程序。尽管可以更改服务启动顺序，使 SQL Server Browser 服务在 SQL Server 2000 或 MSDE 之前启动，但建议您将所有较早版本的 SQL Server 更新为最新的 Service Pack。

当未更新到最起码的 Service Pack 3a 的 SQL Server 2000 实例安装在计算机上时，如果 SQL Server 浏览器未运行，则将启动 SQL Server 2000 侦听器服务。如果 SQL Server Browser 在侦听器服务启动之后启动，将用 5 秒钟来等待 SQL Server 2000 放弃 1434 端口。如果未放弃该端口，SQL Server Browser 将无法启动。对于 Service Pack 3a 之前的 SQL Server 2000 版本，若要解决此问题，请停止 SQL Server 2000，启动 SQL Server 浏览器，然后重新启动 SQL Server 2000。SQL Server 2000 侦听器服务将继续尝试使用 1434 端口进行启动，因此应尽快将 SQL Server 2000 实例升级到 Service Pack 3a。

SQL Server 7.0 不具备类似功能，因此不会与 SQL Server 浏览器发生冲突。

聚类分析

SQL Server 浏览器不是群集资源，不支持从一个群集节点到其他群集节点的故障转移。因此，在使用群集的情况下，应安装 SQL Server 浏览器，并为群集的每个节点启用该浏览器。在群集中，SQL Server 浏览器侦听 IP_ANY。

注意：
侦听 IP_ANY 时，如果启用侦听特定的 IP，用户必须为每个 IP 配置相同的 TCP 端口，因为 SQL Server 浏览器将返回它遇到的第一个 IP/端口对。

通过命令行进行安装、卸载和运行

默认情况下，SQL Server 浏览器程序安装在 C:\Program Files\Microsoft SQL Server\100\Shared\sqlbrowser.exe 处。如果 SQL Server 2000 已安装在计算机上，但尚未升级到 Service Pack 3，而且 SQL Server 2000 实例也未进行升级，则应在安装 SQL Server 期间停止 SQL Server 2000。如果 SQL Server 2000 正在运行，SQL Server 浏览器将无法启动，也无法使用 1434 端口，而安装可能会因缺少连接而失败。

SQL Server Browser 服务在删除 SQL Server 的最后一个实例后被卸载。SQL Server 2000 的实例将恢复其原始行为。

可以使用 -c 开关，通过命令提示符启动 SQL Server 浏览器来排除故障。

复制代码
<drive>\<path>\sqlbrowser.exe -c

安全性

帐户权限

SQL Server 浏览器使用 SQL Server 解析协议 (SSRP) 侦听 UDP 端口，并接受未经身份验证的请求。SQL Server 浏览器应该在低特权用户的安全上下文中运行，以将受到恶意攻击的几率降到最低。通过使用 SQL Server 配置管理器更改登录帐户。SQL Server 浏览器的最小用户权限如下：

  • 拒绝通过网络访问该计算机

  • 拒绝本地登录

  • 拒绝以批处理作业登录

  • 拒绝通过“终端服务”登录

  • 作为服务登录

  • 读取和写入与网络通信（端口和管道）相关的 SQL Server 注册表项

默认帐户

安装程序将 SQL Server 浏览器配置为使用安装期间为服务选定的帐户。其他可能的帐户包括：

  • 所有“域\本地”帐户

  • 本地服务帐户（不可以在 W2K 平台上使用）

  • 本地系统帐户（不推荐使用，因为其具有不必要的权限）

隐藏 SQL Server

隐藏的实例是仅支持共享内存连接的 SQL Server 实例。对于 SQL Server，设置 HideInstance 标记来指示 SQL Server 浏览器不应对此服务器实例的相关信息做出响应。通过在服务器网络实用工具中设置 HideServer 选项，SQL Server 浏览器还支持 SQL Server 2000 隐藏实例方法。有关配置 HideServer 选项的信息，请参阅 SQL Server 联机丛书中的“如何隐藏 SQL Server 数据库引擎实例”。

使用防火墙

若要与有防火墙保护的服务器上的 SQL Server Browser 服务进行通信，除了打开 SQL Server 使用的 TCP 端口（如 1433）之外，还要打开 UDP 端口 1434。有关如何使用防火墙的信息，请参阅 SQL Server 联机丛书中的“如何将防火墙配置为允许 SQL Server 访问”。

请参阅

其他资源

网络协议和网络库

© 2010 Microsoft Corporation。保留所有权利。


使用 IPv6 进行连接

使用 IPv6 进行连接 |
 | 请参阅
SQL Server 配置管理器帮助 >

SQL Server 和 SQL Server Native Client 完全支持 Internet 协议版本 4 (IPv4) 和 Internet 协议版本 6 (IPv6)。将 Windows 配置为使用 IPv6 SQL Server 时，各组件会自动识别 IPv6 的存在。不必采用特殊的 SQL Server 配置。

支持包括但不限于下列各项：

  • SQL Server 数据库引擎和其他服务器组件可以同时侦听 IPv4 和 IPv6 地址。如果同时存在 IPv4 和 IPv6，则可以使用 SQL Server 配置管理器来配置数据库引擎，以便只侦听 IPv4 地址或只侦听 IPv6 地址。

  • 根据 IPv4 地址对运行于支持 IPv4 和 IPv6 的计算机上的 SQL Server Browser 服务进行查询时，该服务会对 IPv4 地址及其列表中的第一个 IPv4 TCP 端口做出响应。根据 IPv6 地址进行查询时，该服务会对 IPv6 地址及其列表中的第一个 IPv6 TCP 端口做出响应。为了避免出现不一致，建议将 IPv4 和 IPv6 侦听器配置为侦听相同的端口。

  • SQL Server Management Studio 和 SQL Server 配置管理器等工具都接受 IPv4 和 IPv6 格式的 IP 地址。大多数情况下，如果使用服务器主机名或完全限定域名 (FQDN) 指定 <computer_name>\<instance_name>，则无须修改连接字符串。如果服务器安装有 IPv4 和 IPv6，则其主机名或 FQDN 将会解析到多个 IP 地址，其中至少包括一个 IPv4 地址和多个 IPv6 地址。SQL Server Native Client 会按照从 TCP/IP 接收这些 IP 地址时的顺序尝试使用它们来建立连接，并使用第一个成功建立的连接。由于 SQL Server Native Client 无法预测顺序，因此，应将顺序视为随机顺序。如果同时存在 IPv4 地址和 IPv6 地址，则首先尝试使用 IPv4 地址。这一逻辑对于 ODBC、OLE DB 或 ADO.NET 的用户是透明的。

    注意：
    如果数据库引擎未侦听 IPv4，则尝试进行 IPv4 连接之后，必须等待超时期限过后再尝试使用 IPv6 地址。为了避免出现这种情况，请直接连接到 IPv6 IP 地址或使用 IPv6 地址配置客户端的别名。

请参阅

其他资源

SQL Server 配置管理器

© 2010 Microsoft Corporation。保留所有权利。


选择网络协议

选择网络协议
SQL Server 配置管理器帮助 >

若要连接到 SQL Server 数据库引擎，必须启用网络协议。Microsoft SQL Server 可同时通过多种协议处理请求。客户端用单个协议连接到 SQL Server。如果客户端程序不知道 SQL Server 正在侦听哪个协议，可以配置客户端按顺序尝试多个协议。使用 SQL Server 配置管理器启用、禁用以及配置网络协议。

Shared Memory

Shared Memory 是可供使用的最简单协议，没有可配置的设置。由于使用 Shared Memory 协议的客户端仅可以连接到同一台计算机上运行的 SQL Server 实例，因此它对于大多数数据库活动而言是没用的。如果怀疑其他协议配置有误，请使用 Shared Memory 协议进行故障排除。

注意：
使用 MDAC 2.8 或更早版本的客户端不能使用 Shared Memory 协议。如果这些客户端尝试使用，将自动切换为 Named Pipes 协议。

TCP/IP

TCP/IP 是 Internet 上广泛使用的通用协议。它与互连网络中硬件结构和操作系统各异的计算机进行通信。TCP/IP 包括路由网络流量的标准，并能够提供高级安全功能。它是目前在商业中最常用的协议。将计算机配置为使用 TCP/IP 可能会很复杂，但大多数联网的计算机已经配置正确。若要配置未在 SQL Server 配置管理器中出现的 TCP/IP 设置，请参阅 Microsoft Windows 文档。

Named Pipes

Named Pipes 是为局域网而开发的协议。内存的一部分被某个进程用来向另一个进程传递信息，因此一个进程的输出就是另一个进程的输入。第二个进程可以是本地的（与第一个进程位于同一台计算机上），也可以是远程的（位于联网的计算机上）。

VIA

虚拟接口适配器 (VIA) 协议和 VIA 硬件一同使用。有关如何使用 VIA 的信息，请与硬件供应商联系。

重要提示：
不推荐使用 VIA 协议。后续版本的 Microsoft SQL Server 将删除该功能。请避免在新的开发工作中使用该功能，并着手修改当前还在使用该功能的应用程序。

Named Pipes 与 TCP/IP 套接字

在快速局域网 (LAN) 环境中，传输控制协议或 Internet 协议 (TCP/IP) 套接字客户端和 Named Pipes 客户端在性能方面不相上下。但是，网络速度越慢[如在广域网 (WAN) 或拨号网络上]，TCP/IP 套接字客户端与 Named Pipes 客户端的性能差异越明显。这是因为进程间通信 (IPC) 的机制在对等项间的通信方式不同。

对于 Named Pipes，通常网络通信交互性更强。一个对等方直到另一个对等方使用读取命令请求数据时才发送数据。在开始读取数据前，网络读取一般包括一系列窥视 Named Pipes 的信息。这在慢速网络中可能开销非常大，并会导致过多的网络流量，其他的网络客户端反过来也会受到影响。

阐明所讨论的是本地管道还是网络管道也很重要。如果服务器应用程序在运行 SQL Server 实例的计算机的本地运行，则可以选择本地 Named Pipes 协议。本地 Named Pipes 以内核模式运行且速度非常快。

对于 TCP/IP 套接字，数据传输的效率更高，开销也更少。数据传输还可以利用 TCP/IP 套接字性能增强机制的优点，例如窗口化、延迟确认等。这在慢速网络中可能非常有益。对于应用程序的不同类型，这类性能差异可能非常大。

TCP/IP 套接字还支持积压队列。试图连接到 SQL Server 时，与可能导致管道忙错误的 Named Pipes 相比，该队列可以带来有限的平稳效果。

通常，TCP/IP 在慢速 LAN、WAN 或拨号网络中效果较好。而当网络速度不成问题时，Named Pipes 则是更好的选择，因为其功能更强、更易于使用并具有更多的配置选项。

启用协议

该协议必须在客户端和服务器上都启用才能正常工作。服务器可以同时监听所有已启用的协议的请求。客户端计算机可以选取一个协议，或按照 SQL Server 配置管理器中列出的顺序尝试这些协议。

注意：
Microsoft SQL Server 不支持 Banyan VINES 顺序包协议 (SPP)、多协议、AppleTalk 或 NWLink IPX/SPX 网络协议。以前使用这些协议连接的客户端必须选择其他协议才能连接到 SQL Server。

有关如何配置协议和连接到数据库引擎的简短教程，请参阅教程：数据库引擎入门。


管理 SQL Server 2000 服务

管理 SQL Server 2000 服务
SQL Server 配置管理器帮助 >

SQL Server 2000 服务不能由 SQL Server Management Studio 或 SQL Server 配置管理器进行管理。使用 SQL Server 2000 企业管理器可以更改服务帐户；使用服务管理器可以启动或停止服务；使用服务器网络实用工具可以管理服务器协议；使用客户端网络实用工具可以管理客户端协议和别名。


监视错误日志

监视错误日志
SQL Server 配置管理器帮助 >

SQL Server 将某些系统事件和用户定义事件记录到 SQL Server 错误日志和 Microsoft Windows 应用程序日志中。这两种日志都会自动给所有记录事件加上时间戳。使用 SQL Server 错误日志中的信息可以解决 SQL Server 的相关问题。

Windows 应用程序日志完整地记录了 Windows 操作系统上发生的事件，以及 SQL Server 和 SQL Server 代理中的事件。使用 Windows 事件查看器可以查看 Windows 应用程序日志和筛选信息。例如，可以筛选信息、警告、错误、审核成功和审核失败等事件。

比较错误和应用程序日志输出

您可以使用 SQL Server 错误日志和 Windows 应用程序日志来标识产生问题的原因。例如，监视 SQL Server 错误日志时，您可能会遇到不包含原因信息的错误消息。通过比较两个日志中的事件日期和时间，可以缩小可能原因的范围。使用 SQL Server Management Studio 日志文件查看器可以将 SQL Server、SQL Server 代理和 Windows 日志集成到一个列表，这样可以轻松了解相关的服务器事件和 SQL Server 事件。有关详细信息，请参阅 SQL Server 联机丛书中的主题“日志文件查看器”。

本节内容

主题 | 说明
查看 SQL Server 错误日志 | 介绍了 SQL Server 错误日志以及如何查看该日志。
查看 Windows 应用程序日志 | 介绍了 Windows 应用程序日志以及如何查看该日志。


查看 SQL Server 错误日志

查看 SQL Server 错误日志
SQL Server 配置管理器帮助 > 监视错误日志 >

查看 SQL Server 错误日志可以确保进程（例如，备份和还原操作、批处理命令或其他脚本和进程）成功完成。此功能可用于帮助检测任何当前或潜在的问题领域，包括自动恢复消息（尤其是在 SQL Server 实例已停止并重新启动时）、内核消息或其他服务器级错误消息。

使用 SQL Server Management Studio 或任何文本编辑器可以查看 SQL Server 错误日志。默认情况下，错误日志位于 Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\LOG\ERRORLOG 和 ERRORLOG.n 文件中。

每当启动 SQL Server 实例时，将创建新的错误日志，虽然 sp_cycle_errorlog 系统存储过程可用于循环使用错误日志文件，而不必重新启动 SQL Server 实例。通常，SQL Server 保留前六个日志的备份，并指定最近日志备份的扩展名为 .1、下一个最近日志备份的扩展名为 .2，依次类推。当前的错误日志没有扩展名。


查看 Windows 应用程序日志
SQL Server 配置管理器帮助 > 监视错误日志 >

SQL Server 配置为使用 Microsoft Windows 应用程序日志后，每个 SQL Server 会话都将新事件写入该日志中。与 SQL Server 错误日志不同，不是每次启动 SQL Server 实例时都创建新的应用程序日志。

可以通过使用 Windows 事件查看器或 SQL Server Management Studio 中的日志查看器来查看和管理 Windows 应用程序日志。

可以使用事件查看器查看三种日志。

Windows 日志类型 | 说明
系统日志 | 记录由 Windows 操作系统组件记录的事件。例如，如果启动时驱动程序或其他系统组件加载失败，该信息将记录在系统日志中。
安全日志 | 记录安全性事件，例如登录尝试失败。这可以帮助跟踪对安全系统的更改，发现对安全的可能的破坏。例如，对系统的登录尝试可能记录在安全日志中，具体情况取决于用户管理器中的审核设置。 只有 sysadmin 固定服务器角色成员可以查看安全日志。
应用程序日志 | 记录由应用程序记录的事件。例如，数据库应用程序可能会将文件错误记录在应用程序日志中。

有关使用事件查看器、管理应用程序日志及了解其表示的信息的详细信息，请参阅 Windows 文档。
查看 Windows 应用程序日志

如何查看 Windows 应用程序日志 (Windows)


文档法律声明

文档法律声明
SQL Server 配置管理器帮助 >

本文档支持软件程序“SQL Server 2008 R2”的最终商业版本。本文档中的信息是 Microsoft Corporation 的专有信息，属于机密信息。

本文档按“原样”提供。本文档中的信息和表达的观点（包括 URL 和其他 Internet 网站引用）如有更改，恕不另行通知。您应承担使用本文档所带来的风险。本文档中提及的某些示例只是为了便于说明，纯属虚构。不应据此联想或妄加推断。

本文档不向您提供对任何 Microsoft 产品中的任何知识产权的任何法律权利。您可以出于内部参考目的复制和使用本文档。

版权所有 © 2010 Microsoft Corporation。保留所有权利。

Microsoft、Active Directory、ActiveX、Bing Maps、Excel、IntelliSense、MSDN、MS-DOS、PivotChart、PivotTable、PowerPoint、SharePoint、SQL Server、Visual Basic、Visual C#、Visual C++、Visual Studio、Windows、Windows NT、Windows Server 和 Windows Vista 是 Microsoft 集团公司的商标。

SAP NetWeaver 是 SAP AG 在德国和其他几个国家/地区的注册商标。

所有其他商标归其各自拥有者所有。

SQL Server 支持和升级文档策略

文档 - 支持和升级策略

Microsoft SQL Server 2008 R2 软件文档包括 Microsoft 发布的 SQL Server 联机丛书（“BOL”）、自述文件、已知问题文档、示例代码/应用程序、示例数据库和知识库文章，这些文档都包含与 SQL Server 的特征和功能相关的内容（以下统称“文档”）。下面的摘要描述了文档中提到的某些特征和功能的支持及升级策略。

示例。文档中包含的示例主要用于阐释概念以及特定语句或子句的合理用法。大多数示例不包括完整的生产系统通常所包含的全部代码，因为其中删除了某些常用的数据验证和错误处理，以便使示例突出特定的概念或语句。Microsoft 客户支持服务部门不为文档中包含的任何示例提供支持。

占位符。在某些情况下，SQL Server 2008 R2 中的特定功能尚未经过充分测试或开发，不适合使用。此类功能通常作为占位符在 BOL、自述文件或其他文档中列出，仅用作标记以供 Microsoft 内部参考。此类功能不适合使用，且 Microsoft 客户支持服务部门不为这些功能提供支持。尝试使用此类功能可能导致数据丢失。

第三方内容。除非文档另有说明，否则 Microsoft 客户支持服务部门不会对第三方内容（包括将此类第三方内容与 SQL Server 2008 R2 结合使用而导致的问题）提供支持。

未记录的入口点。Microsoft 客户支持服务部门不为利用或使用未记录的入口点（如未记录的 API）的数据库或应用程序提供支持，其中包括但不限于：存储过程、扩展存储过程、函数、视图、表、列、属性或元数据。此类使用可能导致数据丢失。

升级。对于利用或使用未记录的入口点的应用程序和数据库，其服务器和数据库可能无法升级至 SQL Server 2008 R2 的未来版本，且此类服务器和数据库的升级不享有 Microsoft 客户支持服务部门的支持。

有关 Microsoft 支持生命周期策略的详细信息，请访问下面的网站：http://support.microsoft.com/lifecycle。


关于 SQL Server 许可条款

关于 SQL Server 许可条款 |
 | 请参阅
SQL Server 配置管理器帮助 >

安装 SQL Server 时，会将 Microsoft 软件许可条款复制到本地计算机。当在同一台计算机上安装具有相同版本类别和语言的多个 SQL Server 实例时，许可条款的单个副本将适用于该版本类别和语言的所有实例。这些文件将写入到：%ProgramFiles%\Microsoft SQL Server\100\License Terms\ 或 %ProgramFiles(x86)%\Microsoft SQL Server\100\License Terms\。

在同一台计算机上安装相同 SQL Server 版本和语言的多个实例时，许可条款的单个副本将应用于该版本和语言的所有实例。

许可条款文件名指示 SQL Server 的版本以及 SQL Server 语言版本。例如：

  • License_DEV_ENU.txt 表示 SQL Server Developer，英语版本。

  • License_STD_ITA.txt 表示 SQL Server Standard，意大利语版本。

  • License_UA_JPN.txt 表示 SQL Server 升级顾问，日语版本。

  • License_SQLNCLI_ENU.txt 表示 SQL Server Native Client，英语版本。

  • License_SQLXML4_KOR.txt 表示 SQLXML，朝鲜语版本。

以下文件名段用于标识 SQL Server 版本：

  • DC - Datacenter

  • ENT - Enterprise

  • DEV - Developer

  • STD - Standard

  • WKGP - Workgroup

  • WEB - Web

  • EXPR - Express

  • UA - 升级顾问

以下文件名段用于标识 SQL Server 语言：

  • ENU - 英语

  • JPN - 日语

  • FRA - 法语

  • ITA - 意大利语

  • KOR - 朝鲜语

  • DEU - 德语

  • ESN - 西班牙语

  • CHS - 简体中文

  • CHT - 繁体中文

  • NLA - 荷兰语

  • PTB - 葡萄牙语（巴西）

  • SVE - 瑞典语

  • RUS - 俄语

SQL Server 许可选项

有关 SQL Server 定价和许可选项的信息，请参阅 Microsoft SQL Server 2008 R2 网站。

请参阅

概念

文档法律声明

其他资源

SQL Server 2008 R2 隐私声明

© 2010 Microsoft Corporation。保留所有权利。