SQL Server 安装文档概述

SQL Server 2008 R2 安装程序帮助
SQL Server 安装文档概述

SQL Server 安装文档以安装介质和在线两种方式提供。

在安装过程中提供的文档

在 SQL Server 的安装过程中，系统会向您提供完成操作所需的即时信息。

SQL Server 联机丛书

安装介质还包括 SQL Server 联机丛书，提供有关 SQL Server 安装程序的更详细信息。

可以通过选择以下选项之一，查看 SQL Server 联机丛书中的文档：

  • 从安装介质安装 SQL Server 联机丛书。

  • 从下载中心下载 SQL Server 联机丛书。

  • 查看 SQL Server 联机丛书中的最新文档。

SQL Server 安装概述主题

无论您是使用 SQL Server 安装向导还是命令提示符来安装 SQL Server，都最好通过阅读以下部分来做好准备：

  • 计划 SQL Server 安装.

    说明如何准备 SQL Server 安装。

  • 安装或升级 SQL Server 安装。

    说明 SQL Server 的安装或升级选项。

  • 配置 SQL Server 安装.

    说明如何配置 SQL Server 安装。

如果正在安装 SQL Server 故障转移群集，请查看以下内容：

  • SQL Server 故障转移群集入门.

  • 安装故障转移群集前的准备工作.


关于 SQL Server 许可条款

关于 SQL Server 许可条款 |
 | 请参阅
SQL Server 安装文档概述 >

安装 SQL Server 时，会将 Microsoft 软件许可条款复制到本地计算机。当在同一台计算机上安装具有相同版本类别和语言的多个 SQL Server 实例时，许可条款的单个副本将适用于该版本类别和语言的所有实例。这些文件将写入到：%ProgramFiles%\Microsoft SQL Server\100\License Terms\ 或 %ProgramFiles(x86)%\Microsoft SQL Server\100\License Terms\。

在同一台计算机上安装相同 SQL Server 版本和语言的多个实例时，许可条款的单个副本将应用于该版本和语言的所有实例。

许可条款文件名指示 SQL Server 的版本以及 SQL Server 语言版本。例如：

  • License_DEV_ENU.txt 表示 SQL Server Developer，英语版本。

  • License_STD_ITA.txt 表示 SQL Server Standard，意大利语版本。

  • License_UA_JPN.txt 表示 SQL Server 升级顾问，日语版本。

  • License_SQLNCLI_ENU.txt 表示 SQL Server Native Client，英语版本。

  • License_SQLXML4_KOR.txt 表示 SQLXML，朝鲜语版本。

以下文件名段用于标识 SQL Server 版本：

  • DC - Datacenter

  • ENT - Enterprise

  • DEV - Developer

  • STD - Standard

  • WKGP - Workgroup

  • WEB - Web

  • EXPR - Express

  • UA - 升级顾问

以下文件名段用于标识 SQL Server 语言：

  • ENU - 英语

  • JPN - 日语

  • FRA - 法语

  • ITA - 意大利语

  • KOR - 朝鲜语

  • DEU - 德语

  • ESN - 西班牙语

  • CHS - 简体中文

  • CHT - 繁体中文

  • NLA - 荷兰语

  • PTB - 葡萄牙语（巴西）

  • SVE - 瑞典语

  • RUS - 俄语

SQL Server 许可选项

有关 SQL Server 定价和许可选项的信息，请参阅 Microsoft SQL Server 2008 R2 网站。

请参阅

概念

SQL Server 2008 R2 隐私声明
文档法律声明

© 2010 Microsoft Corporation。保留所有权利。


SQL Server 2008 R2 隐私声明

SQL Server 2008 R2 隐私声明
SQL Server 安装文档概述 >

上次更新日期：2010 年 1 月

Microsoft 公司在交付为个人计算提供所需性能、功能以及便利的各种产品的同时，也竭力保护您的隐私。本隐私声明解释了 Microsoft SQL Server 2008 R2（“SQL Server”）的多种数据收集和使用方式。本隐私声明着重于与 Internet 通信所需的一些功能。它不适用于其他联机或脱机的 Microsoft 网站、产品或服务。

个人信息的收集和使用

我们从您那里收集到的信息只会由 Microsoft 及其控制的子公司和关联企业用于实现您正在使用的功能，以及提供服务或执行您要求或授权的交易。这些信息还可能用于分析和改进 Microsoft 产品和服务。

除了本声明中所述的用途外，您提供的个人信息绝不会在未获得您同意的情况下转交给第三方。我们有时会委托其他公司代表我们提供有限的服务，例如包装、寄送与投递所购买的产品，以及其他一些邮寄事务，回答客户有关产品或服务的问题，处理活动注册或执行有关服务的统计分析等。我们只向这些公司提供他们在提供服务时所需的个人信息，并且禁止他们利用这些信息用于任何其他用途。

Microsoft 可能会访问或披露有关您的信息，包括与您的交流内容，以便：(a) 符合法律或者响应合法要求或法律程序；(b) 保护 Microsoft 或我们的客户的权利或财产，包括强制我们实施用于控制您如何使用服务的协议或政策，或 (c) 在确信需要进行此类信息访问或披露以保护 Microsoft 员工、客户或公众的个人安全时采取行动。

Microsoft 通过 SQL Server 收集的信息或通过 SQL Server 发送给 Microsoft 的信息，可能会在美国或者 Microsoft 或其关联企业、子公司或服务提供商维护设施所在的任何其他国家或地区存储和处理，使用 Microsoft 网站或服务即表示您同意将信息转移到您所在国家或地区以外的此类行为。Microsoft 遵守美国商务部针对收集、使用和保存来自欧盟的数据所订立的安全港协议。

计算机相关信息的收集和使用

SQL Server 包含了一些支持 Internet 的功能，可以从您的计算机收集信息（“标准计算机信息”）并且发送到 Microsoft。标准计算机信息通常包含诸如 IP 地址、操作系统版本、浏览器版本以及区域和语言设置等信息。某些情况下，标准计算机信息还可能包括硬件 ID，用于指示设备制造商、设备名称和版本。如果某一特定的功能或服务将信息发送到 Microsoft，则也将发送标准计算机信息。

本隐私声明中列出的每个 SQL Server 功能的隐私详细信息描述将收集哪些附加信息以及如何使用这些信息。

您的信息的安全

Microsoft 承诺保护您信息的安全。我们使用各种安全技术和措施来防止他人未经授权访问、使用或泄露您的信息。例如，我们将您提供的信息存储在受控设施中访问受限的计算机服务器上。

隐私声明更改

我们偶尔会对本隐私声明进行更新，以便反映我们的产品和服务中的变化以及客户反馈。发布更改后，我们会修改本隐私声明顶部的“上次更新日期”。如果对于本隐私声明或者 Microsoft 使用您的个人信息的方式存在实质性更改，我们会通过在实施更改前张贴关于此类更改的通知或者通过直接向您发送通知，就更改事宜通知您。建议您定期查看本隐私声明，以了解 Microsoft 如何保护您的隐私。

详细信息

如果您对本隐私声明有任何问题或者认为我们未遵守本隐私声明，请将电子邮件发送到 sqlpriv@microsoft.com 与我们联系。

您还可以邮寄到：

SQL Server 隐私声明

Microsoft Corporation, One Microsoft Way, Redmond, Washington 98052

特定功能：

客户体验改善计划

此功能的用途：

SQL Server Business Intelligence Development Studio 和 SQL Server Management Studio 的“客户体验改善计划”(CEIP) 功能将收集有关您的硬件配置以及您如何使用软件和服务的信息，以便我们可以判断趋势和使用模式。此信息有助于改进 Microsoft 软件和服务的质量、可靠性及性能。

收集、处理或传送的信息：

CEIP 收集的信息包含您遇到的错误类型及数量、软件和硬件性能及服务速度。我们不会收集您的姓名、地址或其他联系信息。

这项功能会生成一个存储在您的计算机上的全局唯一标识符 (GUID)，用于唯一地标识这台计算机。GUID 是随机生成的数字；它不包含任何个人信息，也不会用于识别您的身份。CEIP 利用 GUID 来区分我们收到的反馈的分布情况，以及应如何确定反馈的优先顺序。例如，Microsoft 使用这个编号可以区分是一位客户遇到 100 次某个错误，还是有 100 位客户各遇到一次相同的错误。GUID 会永久保存。

信息的使用：

收集到的信息有助于改进 Microsoft 的产品。对于因业务需要要使用这些数据的 Microsoft 员工、承包商及供应商，将根据需要授予访问权。

选择/控制

在 SQL Server 安装期间您将有机会参与 CEIP。对于 SQL Server 的预发布版本，默认情况下，CEIP 为启用状态。您可以通过执行以下说明，在以后更改您的安装选择。

更改您的 CEIP 设置：

  1. 启动 SQL Server Management Studio 或 SQL Server Business Intelligence Development Studio，打开一个新的或现有的 Analysis Services 或 Data Transformation Services 项目。

  2. 从 SQL Server Management Studio 的“帮助”菜单，选择“Microsoft SQL Server 客户反馈选项”；或者从 SQL Server Business Intelligence Development Studio 的“帮助”菜单，选择“Microsoft SQL Server 客户反馈设置”。

  3. 要关闭 CEIP，单击“否，我不想参加”。要启用 CEIP，请单击“是，我愿意参加”。

  4. 单击“确定”。

重要信息：

企业客户可以设置基于注册表的策略，利用这种方式构造选择加入或不加入 CEIP 的组策略。相关注册表项和设置如下所示：

注册表项 = HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server\100

注册表项名称 = CustomerFeedback

注册表项类型 DWORD：

  • 0 表示选择不加入

  • 1 表示选择加入

注意：

错误编辑注册表可能会严重损坏您的系统。更改注册表之前，应当备份计算机中的所有重要数据。如果在应用手动更改之后遇到问题，也可以使用“最近一次的正确配置”启动选项。

有关 CEIP 的详细信息，请阅读 CEIP 隐私声明。

各种错误报告

此功能的用途：

利用各种错误报告功能，可以报告使用 SQL Server 及其具有用户界面的所有组件产品时可能遇到的问题。没有用户界面的组件和服务（例如 SQL Server 数据库引擎、SQL 代理、Analysis Services、Reporting Services、Notification Services、SQL 复制、数据库优化顾问组件、SQL Browser 服务和 SQL 编写器）的错误报告是由“SQL Server 错误和使用情况报告”工具处理的，如下所述。

收集、处理或传送的信息：

各种错误报告功能收集标准计算机信息，该信息不用于识别您的身份。这些报告无意收集姓名、地址、电子邮件地址、计算机名称或用于识别用户身份或与用户联系的任何信息。可能会从内存或从已打开文件中收集的数据中捕获此类信息，但 Microsoft 不会使用这些信息来识别用户身份。

在极少数情况下（例如有些问题非常难解决），Microsoft 可能会请求额外数据，包括内存扇区（可能包括发生问题时正在运行的任何或所有应用程序共享的内存）、某些注册表设置以及您的计算机上的一个或多个文件。可能还包括当前文档。请求额外数据后，您可以查看数据并选择是否发送这些信息。

在某些情况下，发送错误报告后，可能要求您回答一个可选的调查。如果发送错误报告但不发送调查信息，则错误报告中的任何信息都不会用来识别您的身份。如果您选择提供电话号码或电子邮件地址，我们就可以与您联系，并要求您提供可以帮助我们解决问题的更多数据。在某些情况下，您可能有机会跟踪您的错误报告。如果选择跟踪错误，您的报告将与您的电子邮件地址关联。

信息的使用：

我们使用数据来诊断和解决客户问题，以及改进此软件和其他 Microsoft 软件和服务。

选择/控制：

每次具有用户界面的 SQL Server 组件发生错误时，将生成报告并询问您是否要将报告发送给 Microsoft。在选择是否发送错误报告之前，您有机会查看报告中包含的信息。

企业客户可以使用组策略来配置“错误报告”功能在计算机上的行为方式。配置选项包括完全关闭“错误报告”功能的功能。有关如何为管理员配置组策略以用于错误报告的详细信息，请参阅 Windows Server 2003 TechNet 网站。有关 Windows Server 2008 的技术细节的详细信息，请参阅 Group Policy Planning and Deployment Guide（组策略计划和部署指南）。

重要信息：

有关收集哪些信息以及如何使用它们的详细信息，请参阅 Privacy Statement for the Microsoft Error Reporting Service（Microsoft 错误报告服务的隐私声明）。

错误和使用情况报告

此功能的用途：

使用错误报告功能可以允许您针对没有用户界面并且在后台运行的 SQL Server 组件和服务器（例如 SQL Server 数据库引擎、SQL 代理、Analysis Services、Reporting Services、Notification Services、SQL 复制、数据库优化顾问组件、SQL Browser 服务和 SQL 编写器［“后台服务”］）自动将错误报告发送到 Microsoft。如果您同意，“错误报告”功能允许您自动向 Microsoft 报告使用后台服务时遇到的问题，并接收可能有助于解决此类问题的信息。

利用“使用情况报告”功能，可以自动向 Microsoft 发送使用情况信息。如果您同意，“使用情况报告”功能将收集有关硬件配置以及该硬件上正在使用哪些 SQL Server 功能的信息，并发送给 Microsoft，以便我们可以确定趋势和使用模式。

收集、处理或传送的信息：

“错误报告”功能与“各种错误报告”功能收集同样的信息。此外，SQL Server 的“错误报告”功能还收集错误发生时特定于使用情况的其他信息，包括：计算机特征（CPU 速度和处理器数量等）、错误线程（或某些错误类型的所有线程）的调用堆栈、执行计划和其他执行数据以及有关已打开文件的信息。该功能还可能收集有关操作系统和 SQL Server 行为、某些错误类型以及数据页内容的历史记录信息。可能会从内存或从已打开文件中收集的数据中捕获个人身份信息，但 Microsoft 不会使用这些信息来识别您的身份。与上述“各种错误报告”不同，在发送“错误报告”功能生成的报告之前，您没有机会查看报告中的信息。

“使用情况报告”功能收集有关硬件配置的信息、该硬件上安装的每个 SQL Server 产品安装和使用哪些功能以及如何执行这些功能。我们不会收集您的姓名、地址或其他联系信息。这项功能还会生成一个存储在您的电脑上的 GUID，用于唯一标识这台电脑。GUID 是随机生成的数字；它不包含任何个人信息，也不会用于识别您的身份。

信息的使用：

“错误和使用情况报告”功能发送的数据用于跟踪和解决用户遇到的问题，并帮助改进 Microsoft 的产品。使用情况报告供“客户体验改善计划”使用，该计划有助于我们开发更好的软件。通过参与此计划，您将直接影响我们设计软件的方式。

选择/控制：

在设置过程中，您将有机会向 Microsoft 自动发送错误和使用情况报告。对于 SQL Server 的预发布版本，默认情况下，错误报告功能为启用状态。要在以后打开或关闭这些功能，请使用“错误和使用情况报告”工具，依次单击“开始”菜单、“程序”、“SQL Server 2005”、“配置工具”以及“SQL Server 错误和使用情况报告”可打开该工具。

企业客户可以使用组策略来配置“错误报告”功能在计算机上的行为方式。配置选项包括完全关闭“错误报告”功能的功能。有关如何为管理员配置组策略以用于错误报告的详细信息，请参阅 Windows Server 2003 TechNet 网站。有关 Windows Server 2008 的技术细节的详细信息，请参阅 Group Policy Planning and Deployment Guide（组策略计划和部署指南）。

重要信息：

即使您在配置 Windows 以使用 Microsoft 错误报告时选择不使用 SQL Server 错误报告功能，某些错误报告仍可能会发送给 Microsoft。

SQL Server 联机丛书：内容反馈功能

此功能的用途：

对于每个 SQL Server 联机丛书帮助主题，您都可以向 SQL Server 文档小组提供有关该内容是否有用的反馈。在每个帮助主题的底部，您都会看到“此信息是否有所帮助？”这一问题。如果单击“是”或“否”按钮，将在您的电子邮件客户端生成一封电子邮件，并将用有关您正在评论的内容的信息自动填充该电子邮件的主题行。您可以在此电子邮件正文中添加关于该内容的具体反馈。

收集、处理或传送的信息：

为了向 SQL Server 文档小组提供有关反馈的必要上下文信息，反馈电子邮件的主题行将包括部分或全部以下信息：主题标题、产品名称、产品版本、文档版本、帮助文件的名称、主题 URL、主题评分（根据您单击“是”还是“否”将有所不同）、帮助文件的类型（.chm 或 .hxs）、您使用的语言（如英语）以及帮助反馈脚本的版本号。请注意，如果帮助主题为 .chm 帮助格式，还可能包含帮助文件在计算机上的安装路径。

信息的使用：

SQL Server 文档小组将使用您提供的信息对 SQL Server 提供的文档进行更正或改进。

选择/控制：

只有您单击“是”或“否”，才会生成反馈电子邮件，并且只有您在电子邮件客户端中单击“发送”，才会向 Microsoft 发送电子邮件。

重要信息：

您的电子邮件地址不会用于营销目的，除非您同意用于此目的。

Microsoft SQL Server 联机丛书：帮助的联机内容设置

此功能的用途：

使用“联机内容”功能可以在执行搜索时自动查询联机网站，包括 Microsoft 的 MSDN Online 网站和第三方社区网站。此外，对代码窗口中的语言关键字按 F1 键，也可以从这些网站获取信息。

收集、处理或传送的信息：

为了返回相关结果，“联机内容”功能会向 MSDN Online（以及您在“联机内容”选项中指定的任何其他第三方网站）传送信息，包括标准计算机信息、您输入的搜索文本字符串或与您对其按 F1 的语言关键字关联的关键字，以及要搜索的源（如 MSDN Online）。

信息的使用：

该信息用于对搜索查询或对按 F1 键进行响应。Microsoft 还使用此信息开发新内容和修改现有内容。

选择/控制：

默认情况下，SQL Server 仅在您的计算机上搜索帮助。如果未选择使用“使用联机内容”设置，将不会向 Microsoft 发送信息。选择搜索设置：

  1. 在联机丛书的屏幕顶部依次选择“帮助”、“工具”、“选项”和“联机”。

  2. 从以下三个选项中选择一项：“仅在本地尝试，而不联机尝试”；“先在本地尝试，然后再联机尝试”或“先联机尝试，然后再在本地尝试”。

  3. 在“搜索提供程序”框中，可以选择或取消选择任何提供程序，使用向上或向下箭头可以设置使用搜索提供程序的顺序。

  4. 单击“确定”。

重要信息：

此内容仅适用于与 MSDN Online 进行的交互；其他指定网站如何收集和使用搜索信息取决于所选的特定网站。有关 MSDN Online 隐私惯例的详细信息，请参阅 Microsoft Online Privacy Notice（Microsoft 联机隐私声明）。

将 Microsoft Bing 地图与 SQL Server Reporting Services 一起使用
此功能的用途：

SQL Server Reporting Services 允许您生成与 Microsoft Bing 地图相集成的报表。为了启用此功能，某些信息将从您的服务器发送到 Bing 地图 Web 服务。

收集、处理或传送的信息：

如果您使用您的 Bing 地图 ID 配置 SQL Server，则在每次运行使用 Bing 地图功能的报表时，该 ID 将连同您的数据请求一起发送到 Bing 地图。

信息的使用：

Microsoft 使用有关的信息来操作和改进 Microsoft Bing 地图和其他 Microsoft 站点和服务。有关详细信息，请参阅 Microsoft Online Privacy Statement（Microsoft Online 隐私声明）。

选择/控制：

默认情况下，唯一标识符将不随对 Microsoft Bing 地图的请求发送。请参阅您的 SQL Server 文档，了解如何将您的 Bing 地图 ID 添加到您的 SQL Server 配置。


文档法律声明

文档法律声明
SQL Server 安装文档概述 >

本文档支持软件程序“SQL Server 2008 R2”的最终商业版本。本文档中的信息是 Microsoft Corporation 的专有信息，属于机密信息。

本文档按“原样”提供。本文档中的信息和表达的观点（包括 URL 和其他 Internet 网站引用）如有更改，恕不另行通知。您应承担使用本文档所带来的风险。本文档中提及的某些示例只是为了便于说明，纯属虚构。不应据此联想或妄加推断。

本文档不向您提供对任何 Microsoft 产品中的任何知识产权的任何法律权利。您可以出于内部参考目的复制和使用本文档。

版权所有 © 2010 Microsoft Corporation。保留所有权利。

Microsoft、Active Directory、ActiveX、Bing Maps、Excel、IntelliSense、MSDN、MS-DOS、PivotChart、PivotTable、PowerPoint、SharePoint、SQL Server、Visual Basic、Visual C#、Visual C++、Visual Studio、Windows、Windows NT、Windows Server 和 Windows Vista 是 Microsoft 集团公司的商标。

SAP NetWeaver 是 SAP AG 在德国和其他几个国家/地区的注册商标。

所有其他商标归其各自拥有者所有。

SQL Server 支持和升级文档策略

文档 - 支持和升级策略

Microsoft SQL Server 2008 R2 软件文档包括 Microsoft 发布的 SQL Server 联机丛书（“BOL”）、自述文件、已知问题文档、示例代码/应用程序、示例数据库和知识库文章，这些文档都包含与 SQL Server 的特征和功能相关的内容（以下统称“文档”）。下面的摘要描述了文档中提到的某些特征和功能的支持及升级策略。

示例。文档中包含的示例主要用于阐释概念以及特定语句或子句的合理用法。大多数示例不包括完整的生产系统通常所包含的全部代码，因为其中删除了某些常用的数据验证和错误处理，以便使示例突出特定的概念或语句。Microsoft 客户支持服务部门不为文档中包含的任何示例提供支持。

占位符。在某些情况下，SQL Server 2008 R2 中的特定功能尚未经过充分测试或开发，不适合使用。此类功能通常作为占位符在 BOL、自述文件或其他文档中列出，仅用作标记以供 Microsoft 内部参考。此类功能不适合使用，且 Microsoft 客户支持服务部门不为这些功能提供支持。尝试使用此类功能可能导致数据丢失。

第三方内容。除非文档另有说明，否则 Microsoft 客户支持服务部门不会对第三方内容（包括将此类第三方内容与 SQL Server 2008 R2 结合使用而导致的问题）提供支持。

未记录的入口点。Microsoft 客户支持服务部门不为利用或使用未记录的入口点（如未记录的 API）的数据库或应用程序提供支持，其中包括但不限于：存储过程、扩展存储过程、函数、视图、表、列、属性或元数据。此类使用可能导致数据丢失。

升级。对于利用或使用未记录的入口点的应用程序和数据库，其服务器和数据库可能无法升级至 SQL Server 2008 R2 的未来版本，且此类服务器和数据库的升级不享有 Microsoft 客户支持服务部门的支持。

有关 Microsoft 支持生命周期策略的详细信息，请访问下面的网站：http://support.microsoft.com/lifecycle。


SQL Server 2008 R2 的许可注意事项

SQL Server 2008 R2 的许可注意事项 |
 | 请参阅
SQL Server 安装文档概述 >

有关 SQL Server 许可选项的详细信息，请参阅该 Microsoft SQL Server 网站。

请参阅

参考

关于 SQL Server 许可条款

概念

SQL Server 2008 R2 隐私声明
文档法律声明

© 2010 Microsoft Corporation。保留所有权利。


SQL Server 的默认实例和命名实例的文件位置

SQL Server 的默认实例和命名实例的文件位置 |
 | 请参阅

安装 SQL Server 将安装一个或多个单独的实例。无论是默认实例还是命名实例都有自己的一组程序文件和数据文件，同时还有在计算机上的所有 SQL Server 实例之间共享的一组公共文件。

对于包含数据库引擎、Analysis Services 和 Reporting Services 的 SQL Server 实例，每个组件都有一套完整的数据文件和可执行文件，以及由所有组件共享的公共文件。

为了隔离每个组件的安装位置，将为给定 SQL Server 实例中的每个组件都生成一个唯一的实例 ID。

重要提示：
程序文件和数据文件不能安装在以下位置：可移动磁盘驱动器、使用压缩的文件系统、系统文件所在的目录以及故障转移群集实例上的共享驱动器。

请勿删除以下任何目录或其内容：Binn、Data、Ftdata、HTML 或 1033。如有必要，可以删除其他目录；但是，如果不卸载并重新安装 SQL Server，则可能无法检索失去的功能或数据。不要删除或修改 HTML 目录中的任何 .htm 文件。它们对于 SQL Server 工具的正常运行是必需的。

所有 SQL Server 实例的共享文件

单个计算机上的所有实例使用的公共文件安装在文件夹 <drive>:\Program Files\Microsoft SQL Server\100\ 中，其中 <drive> 是安装组件的驱动器的编号。默认值通常为驱动器 C。

文件位置和注册表映射

SQL Server 安装过程中，为每个服务器组件生成一个实例 ID。此 SQL Server 版本中的服务器组件分别是数据库引擎、Analysis Services 和 Reporting Services。

使用以下格式构造默认实例 ID：

  • 对于数据库引擎采用的是 MSSQL，后面依次跟有主版本号、下划线和次版本号（如果适用）、一个句点以及实例名。

  • 对于 Analysis Services 采用的是 MSAS，后面依次跟有主版本号、下划线和次版本号（如果适用）、一个句点以及实例名。

  • 对于 Reporting Services 采用的是 MSRS，后面依次跟有主版本号、下划线和次版本号（如果适用）、一个句点以及实例名。

此 SQL Server 2008 R2 版本中的默认实例 ID 的示例如下：

  • 对于默认 SQL Server 2008 R2 实例，为 MSSQL10_50.MSSQLSERVER。

  • 对于默认 Analysis Services 实例，为 MSAS10_50.MSSQLSERVER。

  • 对于名为“MyInstance”的 SQL Server 2008 R2 命名实例，为 MSSQL10_50.MyInstance。

包括数据库引擎和 Analysis Services 的 SQL Server 2008 R2 命名实例（名为“MyInstance”并且按照默认目录安装）的目录结构如下所示：

  • C:\Program Files\Microsoft SQL Server\MSSQL10_50.MyInstance\

  • C:\Program Files\Microsoft SQL Server\MSASSQL10_50.MyInstance\

可为实例 ID 指定任何值，但应避免使用特殊字符和保留关键字。有关详细信息，请参阅保留关键字（安装程序）。

在 SQL Server 安装期间可指定一个非默认实例 ID。如果用户选择更改默认安装目录，则不使用 <Program Files>\Microsoft SQL Server，而使用 <自定义路径>\Microsoft SQL Server。请注意，不支持以下划线 (_) 开头或者包含数字符号 (#) 或美元符号 ($) 的实例 ID。

注意：
Integration Services 和客户端组件是不识别实例的，因此不为它们指定实例 ID。默认情况下，将不识别实例的组件安装在单个目录 <drive>:\Program Files\Microsoft SQL Server\100\ 中。更改一个共享组件的安装路径会同时更改其他共享组件的安装路径。后续安装会将非实例识别组件安装到与原始安装相同的目录。

SQL Server Analysis Services 是唯一的在安装后支持实例重命名的 SQL Server 组件。如果重命名 Analysis Services 实例，实例 ID 不会发生变化。重命名实例后，目录和注册表项将继续使用在安装期间创建的实例 ID。

将在 HKLM\Software\Microsoft\Microsoft SQL Server\<Instance_ID> 下为识别实例的组件创建注册表配置单元。例如，

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL10_50.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSASSQL10_50.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.3

注册表还维护实例 ID 到实例名的映射。实例 ID 到实例名的映射按如下方式维护：

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL10_50"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"="MSASSQL10_50"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="MSRSSQL10_50"

指定文件路径

安装过程中，可以更改下列功能的安装路径：

安装程序中仅显示具有用户可配置目标文件夹的功能的安装路径：

组件 | 默认路径1, 2 | 可配置路径3或固定路径
数据库引擎服务器组件 | \Program Files\Microsoft SQL Server\MSSQL10_50.<实例 ID>\ | 可配置
数据库引擎数据文件 | \Program Files\Microsoft SQL Server\MSSQL10_50.<实例 ID>\ | 可配置
Analysis Services 服务器 | \Program Files\Microsoft SQL Server\MSAS10_50.<实例 ID>\ | 可配置
Analysis Services 数据文件 | \Program Files\Microsoft SQL Server\MSAS10_50.<实例 ID>\ | 可配置
Reporting Services 报表服务器 | \Program Files\Microsoft SQL Server\MSRS10_50.<实例 ID>\Reporting Services\ReportServer\Bin\ | 可配置
Reporting Services 报表管理器 | \Program Files\Microsoft SQL Server\MSRS10_50.<实例 ID>\Reporting Services\ReportManager\ | 固定路径
Integration Services | <安装目录>\100\DTS\ | 可配置4
客户端组件 | <安装目录>\100\Tools\ | 可配置4
复制和服务器端 COM 对象 | <drive>:\Program Files\Microsoft SQL Server\100\COM\5 | 固定路径
用于数据转换运行时引擎、数据转换管道引擎和 dtexec 命令提示实用工具的 Integration Services 组件 DLL | <drive>:\Program Files\Microsoft SQL Server\100\DTS\Binn | 固定路径
为 Integration Services 提供托管连接支持的 DLL | <drive>:\Program Files\Microsoft SQL Server\100\DTS\Connections | 固定路径
Integration Services 支持的每种类型枚举器的 DLL | <drive>:\Program Files\Microsoft SQL Server\100\DTS\ForEachEnumerators | 固定路径
SQL Server 浏览器服务、WMI 提供程序 | <drive>:\Program Files\Microsoft SQL Server\100\Shared\ | 固定路径
所有 SQL Server 实例共享的组件 | <drive>:\Program Files\Microsoft SQL Server\100\Shared\ | 固定路径

1确保使用有限的权限对 \Program Files\Microsoft SQL Server\ 文件夹进行保护。

2这些位置的默认驱动器为 systemdrive，通常为驱动器 C。

3子功能的安装路径由父功能的安装路径决定。

4Integration Services 和客户端组件共享单个安装路径。更改一个组件的安装路径会同时更改其他组件的安装路径。后续安装将组件安装到与原始安装相同的位置。

5此目录由计算机上的所有 SQL Server 实例使用。如果对计算机上的任一实例应用更新，则对此文件夹中的文件所做的任何更改都将影响计算机上的所有实例。向现有安装添加功能时，不能更改以前安装的功能的位置，也不能为新功能指定该位置。必须将其他功能安装到安装程序已建立的目录，或者卸载并重新安装产品。

注意：
对于群集配置，必须选择在该群集的每个节点上都可用的本地驱动器。

当在安装过程中为服务器组件或数据文件指定安装路径时，安装程序除了为程序和数据文件使用指定的位置外，还使用实例 ID。安装程序不会将实例 ID 用于工具和其他共享文件。安装程序也不会将任何实例 ID 用于 Analysis Services 程序和数据文件，尽管它会将实例 ID 用于 Analysis Services 存储库。

如果为数据库引擎功能设置了安装路径，则对于此次安装，SQL Server 安装程序会将该路径用作所有特定于实例的文件夹（包括 SQL 数据文件）的根目录。在这种情况下，如果将根目录设置为“C:\Program Files\Microsoft SQL Server\MSSQL10_50\MSSQL\”，则特定于实例的目录将添加到此路径的末尾。

在 SQL Server 安装向导（安装程序用户界面模式）中选择使用 USESYSDB 升级功能的客户会很容易将产品安装到递归文件夹结构中。例如，<SQLProgramFiles>\MSSQL10_50\MSSQL\MSSQL10_50\MSSQL\Data\。这时，为了使用 USESYSDB 功能，请为 SQL 数据文件功能而非数据库引擎功能设置安装路径。

注意：
数据文件始终应位于名为 Data 的子目录中。例如，当数据文件位于 C:\Program Files\Microsoft SQL Server\MSSQL10_50\MSSQL\Data 下时，应指定 C:\Program Files\Microsoft SQL Server\MSSQL10_50\ 作为升级期间系统数据库的数据目录的根路径。

请参阅

参考

数据库引擎配置 - 数据目录
Analysis Services 配置 - 数据目录

© 2010 Microsoft Corporation。保留所有权利。


如何查看和读取 SQL Server 安装程序日志文件

如何查看和读取 SQL Server 安装程序日志文件 |
 | 请参阅

SQL Server 安装的日志记录在此版本中已经更改。

每次执行安装程序时，都会在一个带有时间戳的新日志文件夹 (%programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\) 中创建日志文件。带有时间戳的日志文件夹的名称格式为 YYYYMMDD_hhmmss。在无人参与模式下运行安装程序时，将在 % temp%\sqlsetup*.log 中创建日志。日志文件夹中的所有文件将归档到各自日志文件夹的 Log*.cab 文件中。

一个典型的安装请求将经历以下三个执行阶段：

  1. 全局规则文本

  2. 组件更新

  3. 用户请求的操作

在每个阶段中，安装程序都生成详细信息日志和摘要日志，并根据需要创建其他日志。在每次执行用户请求的安装操作时安装程序至少会被调用三次。

数据存储文件包含安装过程所跟踪的所有配置对象状态的快照，对于纠正配置错误来说非常有用。XML 文件转储是为每个执行阶段的数据存储对象创建的。它们保存在带有时间戳的日志文件夹下其自己的日志子文件夹中，如下所示：

  • Datastore_GlobalRules

  • Datastore_ComponentUpdated

  • Datastore

以下部分介绍 SQL Server 安装程序日志文件。

摘要文本

概述

此文件显示在安装过程中删除的 SQL Server 组件、操作系统环境、命令行参数值（如果已指定），以及执行的每个 MSI/MSP 的总体状态。

本日志归纳为以下部分：

  • 执行的总体摘要

  • 运行 SQL Server 安装程序的计算机的属性和配置

  • 计算机上先前安装的 SQL Server 产品功能

  • 安装版本和安装包属性的说明

  • 安装过程中提供的运行时输入设置

  • 配置文件的位置

  • 执行结果的详细信息

  • 全局规则

  • 特定于安装方案的规则

  • 失败的规则

  • 规则报表文件的位置

位置

此文件位于 %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\。

若要找到摘要文本文件中的错误，请使用“error”或“failed”关键字搜索该文件。

Summary_engine-base_YYYYMMDD_HHMMss.txt

概述

summary_engine 基本文件类似于摘要文件，是在主工作流中生成的。

位置

此文件位于 %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

Summary_engine-base_YYYYMMDD_HHMMss_ComponentUpdate.txt

概述

组件更新摘要日志文件类似于摘要文件，是在组件更新工作流中生成的。

位置

此文件位于 %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

Summary_engine-base_20080503_040551_GlobalRules.txt

概述

全局规则摘要日志文件类似于摘要文件，是在全局规则工作流中生成的。

位置

此文件位于 %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

Detail.txt

概述

Detail.txt 是针对主工作流（如安装或升级）生成的，它提供有关执行的详细信息。文件中的日志基于调用每个安装操作的时间而生成，并且显示操作的执行顺序以及其依赖项。

位置

此文件位于 %programfiles%\Microsoft SQL Server\100\Setup

Bootstrap\Log\<YYYYMMDD_HHMM>\Detail.txt。

如果在安装过程中发生错误，则将异常或错误记录在该文件的末尾。若要查找该文件中的错误，请首先检查文件末尾，然后在文件中搜索“错误”或“异常”关键字。

Detail_ComponentUpdate.txt

概述

Detail_ComponentUpdate.txt 文件是针对组件更新工作流而生成的，它类似于 Detail.txt。

位置

此文件位于 %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

Detail_GlobalRules.txt

概述

Detail_GlobalRules.txt 是针对全局规则执行而生成的，它类似于 Detail.txt。

位置

此文件位于 %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

MSI 日志文件

概述

MSI 日志文件提供安装包进程的详细信息。它们是在安装指定包的过程中由 MSIEXEC 生成的。

MSI 日志文件的类型：

  • <Feature>_<Architecture>_<Iteration>.log

  • <Feature>_<Architecture>_<Language>_<Iteration>.log

  • <Feature>_<Architecture>_<Iteration>_<workflow>.log

位置

MSI 日志文件位于 %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\<Name>.log。

该文件的末尾是有关执行的摘要，其中包括成功状态或失败状态以及属性。若要找到 MSI 文件中的错误，请搜索“value 3”，通常可找到的错误与此字符串接近。

ConfigurationFile.ini

概述

本配置文件包含安装过程中提供的输入设置。该文件可用于在无需手动输入设置的情况下重新启动安装。但是，帐户的密码、PID 和某些参数不保存在该配置文件中。可以将这些设置添加到该文件中，也可通过使用命令行或安装程序用户界面提供这些设置。有关详细信息，请参阅如何使用配置文件安装 SQL Server 2008 R2。

位置

此文件位于 %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

SystemConfigurationCheck_Report.htm

概述

系统配置检查报表包含有关每个执行规则的简短说明，以及执行状态。

位置

此文件位于 %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<YYYYMMDD_HHMM>\。

请参阅

概念

SQL Server 安装故障排除

© 2010 Microsoft Corporation。保留所有权利。


SQL Server 安装故障排除

SQL Server 安装故障排除 |
 | 请参阅

若要查看有关安装和升级问题的故障排除信息，请参阅 SQL Server 2008 R2 Readme（SQL Server 2008 R2 自述文档）。

请参阅

概念

如何查看和读取 SQL Server 安装程序日志文件

© 2010 Microsoft Corporation。保留所有权利。


SQL Server 安装程序的用户界面参考

SQL Server 安装程序的用户界面参考

本节说明 SQL Server 安装向导提供的安装选项。


接受许可条款

接受许可条款 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“接受许可条款”页可以接受该 SQL Server 版本的许可条款。

您可以打印许可协议或将其复制到剪贴板。若要继续，请接受许可条款，然后单击“下一步”。若要关闭安装过程，请单击“取消”。

功能使用情况报告

如果启用“功能使用情况”报告，SQL Server 将被配置为定期向 Microsoft 发送报告。报告将包含有关硬件配置和用户如何使用 SQL Server 和组件的信息。Microsoft 将使用功能使用情况数据改进 SQL Server。此功能监视的 SQL Server 组件包括以下各项：

  • 数据库引擎

  • Analysis Services

  • Reporting Services

  • Integration Services

  • 复制

  • Business Intelligence Development Studio

  • SQL Server 安装程序

有关功能使用情况的信息将发送到 Microsoft，在那里保存这些信息，且其访问将受到限制。

若要在安装程序完成后禁用功能使用情况报告，请使用 SQL Server“配置工具”菜单上的“SQL Server 错误和使用情况报告”工具。

对于诸如安装、升级、修复等此类安装程序操作，仅在执行安装程序期间才收集和上载信息。

对于所有其他 SQL Server 组件，将每天针对 SQL Server 的所有已启用实例收集一次信息。收集时间默认为在午夜，以便最大程度上减小服务器的负载。如果要更改收集时间，可以手动编辑控制收集时间的注册表项。SQL Server 的各个实例有自己的注册表项：

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL10_50.<INSTANCEID>\CPE\TimeofReporting

该注册表项的值包含运行收集的时间，以从 00:00（午夜）起的分钟数计。例如，值为 60 会在凌晨 1:00 运行收集，而值为 1200 会在晚上 8:00 运行收集，等等。

请参阅

参考

关于 SQL Server 许可条款

© 2010 Microsoft Corporation。保留所有权利。


添加 SQL Server 故障转移群集节点

添加 SQL Server 故障转移群集节点 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会使用以下规则验证您的计算机配置。

检查项 | 说明 | 用户操作
SSMS_IsInternetConnected | 确保计算机已连接到 Internet。如果启动某个 .NET Framework 应用程序（如 Microsoft Management Studio），则在 .NET Framework 安全检查功能验证证书时可能会稍有延迟。 | 请确保计算机已连接到 Internet。
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致。 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级。
BlockMixedArchitectureUpgrade | 检查尝试升级的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 安装或升级时所使用的 SQL Server 安装介质必须与要修改的 SQL Server 实例具有相同的体系结构。
Cluster_IsOnlineIfClustered | 确认计算机未群集化，或者计算机已群集化且群集服务已联机。 | 要么计算机未群集化，要么群集已启动且联机。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 安装在域控制器上。 | 确保此计算机不是域控制器。请参阅 Security Considerations for a SQL Server Installation（安装 SQL Server 的安全注意事项）。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是某些 SQL Server 版本的必备组件。 | 对于 SQL Server 2008 R2 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定此操作系统平台是否支持 SQL Server 安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。有关详细信息，请参阅 Hardware and Software Requirements for Installing SQL Server 2008 R2（安装 SQL Server 2008 R2 的硬件和软件要求）。
FusionRebootCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 在安装 SQL Server 之前，必须重新启动计算机。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 R2 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 R2 安装到其他计算机上。

请参阅

参考

安装程序支持规则

© 2010 Microsoft Corporation。保留所有权利。


Analysis Services 配置 – 帐户设置

Analysis Services 配置 – 帐户设置 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“Analysis Services 配置”页可以向要求对 Analysis Services 进行不受限访问的用户或服务授予管理权限。

如果您正在安装 PowerPivot for SharePoint，请考虑将管理权限授予负责在 SharePoint 2010 场中部署 SQL Server PowerPivot for SharePoint 的 SharePoint 场管理员或服务管理员。

注意：
在 PowerPivot for SharePoint 部署中，PowerPivot 服务应用程序要求对 Analysis Services 服务具有管理权限，以支持服务器通信和协调功能。当您在 SharePoint 管理中心中创建 PowerPivot 服务应用程序时自动授予管理权限。如果您使用“新服务器”选项安装 PowerPivot for SharePoint，安装程序也将授予管理权限。有关安装和服务帐户要求的详细信息，请参阅 How to: Install Analysis Services on a New SharePoint Server（如何在新的 SharePoint 服务器上安装 Analysis Services）。

设置 SQL Server 的注意事项

从 SQL Server 2005 开始，为了帮助确保 SQL Server 比早期版本更为安全，进行了一些重大的更改。这些更改秉承了“设计安全、默认安全、部署安全”的策略，目的在于防止服务器实例及其数据库免遭安全攻击。

SQL Server 2008 通过对服务器和数据库组件引入更多更改，继续实施这一安全强化过程。通过制定一个“最小权限”策略，SQL Server 2008 中引入的更改可进一步减少服务器及其数据库的外围应用和攻击区域，并使 Windows 管理和 SQL Server 管理进一步分离。这意味着内部帐户受到保护，并分成操作系统功能和 SQL Server 功能。这些措施包括：

  • 新的 SQL Server 2008 安装不再将本地 Windows 组 BUILTIN\Administrators 添加到 Analysis Services sysadmin 固定服务器角色。

  • 具有将一个或多个 Windows 主体设置到 SQL Server 内的 sysadmin 服务器角色中的功能。此选项在 SQL Server 安装程序全新安装 SQL Server 2008 期间可用。

  • 已删除外围应用配置器 (SAC) 工具，取而代之的是 SQL Server 配置管理器工具中的基于策略的管理功能和一些相关更改。

这些更改将影响您的 SQL Server 安全规划，并可帮助您为系统创建更加全面的安全配置文件。

在 Windows Vista 和 Windows Server 2008 上运行 SQL Server 2008 时的注意事项

Windows Vista 和 Windows Server 2008 包含一项新功能，即用户帐户控制 (UAC)，该功能有助于管理员对提升的特权的使用进行管理。默认情况下，在 Windows Vista 和 Windows Server 2008 中，管理员不使用其管理权限。相反，他们以标准用户的身份执行大多数操作，仅在必要时临时使用其管理权限。不过，不用提升特权，我们建议您创建具有足够权限的 Windows 用户帐户，以便执行所有必要的管理任务。

UAC 会导致一些已知问题。有关详细信息，请参阅下列网页：

  • 在 Windows Vista 上运行 SQL Server 2005 时的注意事项

  • 用户帐户控制

  • Windows Vista 和 Windows Server 2008 用户帐户控制分步指南

选项

指定 Analysis Services 管理员 - 您必须为 SQL Server 实例指定至少一个系统管理员。

  • 若要添加当前正在运行 SQL Server 安装程序的帐户，请单击“添加当前用户”按钮。

  • 若要添加其他用户或服务，请单击“添加…”按钮，然后为需要管理权限的用户或服务输入 Windows 域用户帐户。

  • 若要从系统管理员列表中删除帐户，请单击“删除”，然后编辑将对 SQL Server 的实例拥有管理员特权的用户、组或计算机的列表。

完成相应列表的编辑后，请单击“确定”，然后在配置对话框中验证管理员列表。完成此列表后，请单击“下一步”。

请参阅

其他资源

设置 Windows 服务帐户
如何在新的独立 SharePoint 服务器上安装 Analysis Services
配置 Analysis Services 服务帐户

© 2010 Microsoft Corporation。保留所有权利。


Analysis Services 配置 - 数据目录

Analysis Services 配置 - 数据目录 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

下表中的默认目录是在 SQL Server 安装过程中可由用户配置的目录。该表指定本机模式安装和 SharePoint 集成模式安装的默认目录。在 SharePoint 集成模式中，Analysis Services 的所有安装都在路径名称中包括 PowerPivot 实例名称。

说明 | 默认目录 | 建议
数据根目录 | C:\Program Files\Microsoft SQL Server\MSAS10.<实例 ID>\OLAP\Data\ - 或 - C:\Program Files\Microsoft SQL Server\MSAS10_50.POWERPIVOT\OLAP\Data\ | 确保通过限制权限对 \Program files\Microsoft SQL Server\ 文件夹进行保护。在许多配置中，Analysis Services 性能取决于数据目录所在的存储区的性能。请将此目录放置在附加到系统上的最高性能存储区中。对于故障转移群集安装，应确保数据目录位于共享磁盘上。
日志文件目录 | C:\Program Files\Microsoft SQL Server\MSAS10.<实例 ID>\OLAP\Log\ - 或 - C:\Program Files\Microsoft SQL Server\MSAS10_50.PowerPivot\OLAP\Log\ | 这是 Analysis Services 日志文件的目录，该目录包含 FlightRecorder 日志。如果要延长网络流量记录器持续时间，请确保该日志目录有足够的空间。
Temp 目录 | C:\Program Files\Microsoft SQL Server\MSAS10.<实例 ID>\OLAP\Temp\ - 或 - C:\Program Files\Microsoft SQL Server\MSAS10_50.PowerPivot\OLAP\Temp\ | 将 Temp 目录放置在高性能存储子系统中。
备份目录 | C:\Program Files\Microsoft SQL Server\MSAS10.<实例 ID>\OLAP\Backup\ - 或 - C:\Program Files\Microsoft SQL Server\MSAS10_50.PowerPivot\OLAP\Backup\ | 这是 Analysis Services 默认备份文件的目录。在 SharePoint 场上，此目录用于缓存 PowerPivot 数据源。确保设置合适的权限以防止数据丢失，并确保 Analysis Services 服务的用户组具有写入备份目录的足够权限。不支持对备份目录使用映射的驱动器。
SharePoint 跟踪日志 | C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Logs | 这是用于 SharePoint 跟踪日志的目录。在服务器场上部署的 Analysis Services 实例将错误和事件消息写入此日志。

说明

  • 在 SharePoint 场上部署的 Analysis Services 实例将应用程序文件、数据文件和属性存储于内容数据库和服务应用程序数据库中。

  • 向现有安装添加功能时，不能更改以前安装的功能的位置，也不能为新功能指定该位置。

  • 如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。

  • 在下列情况下，不能安装程序文件和数据文件：

    • 在可移动磁盘驱动器上

    • 在使用压缩的文件系统上

    • 在系统文件所在的目录上

    • 在故障转移群集实例的共享驱动器上

请参阅

概念

SQL Server 的默认实例和命名实例的文件位置

其他资源

保护程序文件、公共组件和数据文件的安全

© 2010 Microsoft Corporation。保留所有权利。


群集磁盘选择

群集磁盘选择
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“群集磁盘选择”页为 SQL Server 故障转移群集选择共享群集磁盘资源。群集磁盘用于存放 SQL Server 数据。

选项

共享磁盘

从列表中选择一个磁盘。群集磁盘用于存放 SQL Server 数据。

只能指定一个磁盘。如果选择包含群集仲裁资源的组，将显示警告。建议不要安装到群集仲裁资源。

可用共享磁盘

显示可用磁盘的列表，对于列表中的每个磁盘，均会显示是否可用作共享磁盘以及磁盘资源的说明。


群集网络选择

群集网络选择
SQL Server 安装程序的用户界面参考 >

使用“群集网络选择”页可为故障转移群集实例指定网络资源。

选项

SQL Server 故障转移群集网络名称 - 此名称用于在网络上标识您的故障转移群集实例。

网络设置 - 指定故障转移群集实例的 IP 类型和 IP 地址。


群集节点配置

群集节点配置
SQL Server 安装程序的用户界面参考 >

使用“群集节点配置”页可以在故障转移群集实例中添加或删除节点。请注意，SQL Server 故障转移群集的安装操作在此版本中已进行了更改。若要安装或升级 SQL Server 故障转移群集，则必须在故障转移群集的每个节点上运行安装程序。若要向现有的 SQL Server 故障转移群集添加节点，则必须在要添加至 SQL Server 故障转移群集实例的节点上运行 SQL Server 安装程序。不要在活动节点上运行安装程序。

选项

SQL Server 实例名 - 使用该下拉列表可以选择要修改的 SQL Server 故障转移群集实例。

此节点的名称 - 将使用运行 SQL Server 安装程序的计算机名称填充此字段。这就是将在 SQL Server 故障转移群集实例中添加或删除的故障转移群集节点。


群集节点配置(完成)

群集节点配置(完成)
SQL Server 安装程序的用户界面参考 >

使用“群集节点配置(完成)”页可以指定已准备好进行群集的现有 SQL Server 实例。请注意，SQL Server 故障转移群集的安装操作在此版本中已进行了更改。若要安装或升级 SQL Server 故障转移群集，则必须在故障转移群集的每个节点上运行安装程序。若要向现有的 SQL Server 故障转移群集添加节点，则必须在要添加至 SQL Server 故障转移群集实例的节点上运行 SQL Server 安装程序。不要在活动节点上运行安装程序。

选项

下拉框中有以下选项：

  • SQL Server 实例名 - 选择用于 SQL Server 故障转移群集的实例名称。

  • 此节点的名称 - 此字段使用运行 SQL Server 安装程序的计算机名称进行预先填充。

  • SQL Server 故障转移群集网络名称 - 此字段不进行预先填充。为新的 SQL Server 故障转移群集实例指定网络名称，该名称用来在网络上标识故障转移群集实例。


群集资源组

群集资源组 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“群集资源组”页可以指定用于放置 SQL Server 虚拟服务器资源的磁盘。

选项

指定 SQL Server 群集资源组名称。您有以下两种选择：

  • 使用下拉框指定一个要使用的现有组。

  • 键入要创建的新组的名称。请注意，名称“Available storage”不是有效的组名。

请参阅

其他资源

如何创建新的 SQL Server 故障转移群集

© 2010 Microsoft Corporation。保留所有权利。


群集安全策略

群集安全策略
SQL Server 安装程序的用户界面参考 >

使用“群集安全策略”页可以为故障转移群集实例配置安全策略。

选项

为群集服务指定全局或本地域组。所有资源权限都是由包括作为组成员的 SQL Server 服务帐户的域级组控制。有关 Windows Server 2008 上的服务安全 ID (SID) 功能的详细信息，请参阅 Setting Up Windows Service Accounts（设置 Windows 服务帐户）。

如果在 Windows 2000 混合模式域中安装 SQL Server 2008 故障转移群集实例，则必须对 SQL Server 群集服务使用全局域组。

注意：
Windows 2000 域控制器可以在混合模式和本机模式下运行。混合模式允许同一域中存在下级域控制器。


完成 - 完成映像

完成 - 完成映像
SQL Server 安装程序的用户界面参考 >

使用“完成”页可以验证已准备实例的配置是否已完成。

选项

此对话框包含指向此操作的安装日志文件的链接。若要完成安装，请单击“关闭”。


完成映像进度

完成映像进度 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“完成映像进度”页可以监视 SQL Server 映像完成安装程序的状态。在此步骤完成时，此页将列出已配置和已完成的每个 SQL Server 功能的状态。

请参阅

概念

如何查看和读取 SQL Server 安装程序日志文件

© 2010 Microsoft Corporation。保留所有权利。


完成映像规则

完成映像规则
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。下表描述了系统配置检查器的检查参数和妨碍性问题的解决办法。

检查项 | 说明 | 用户操作
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级
MediaPathLength | 检查 SQL Server 安装介质是否过长。 | 确保 SQL Server 安装介质路径不过长。
OsVersionCheck | 检查计算机是否满足最低操作系统版本要求。 | 操作系统必须满足此产品的最低要求。有关详细信息，请参阅 Hardware and Software Requirements for Installing SQL Server 2008 R2（安装 SQL Server 2008 R2 的硬件和软件要求）。
RebootRequiredCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 需要计算机重新启动。安装 SQL Server 之前，必须重新启动计算机。
ThreadHasAdminPrivilegeCheck | 检查运行 SQL Server 安装程序的帐户是否具有计算机的管理权限。 | 请确保运行 SQL Server 安装程序的帐户具有计算机的管理权限。
WmiServiceStateCheck | 检查是否已在计算机上启动并正在运行 WMI 服务。 | 必须正在运行 WMI 服务。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 安装在域控制器上。 | 确保此计算机不是域控制器。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是 SQL Server Express with Advanced Services 的必备组件。 | 对于 SQL Server Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定操作系统平台是否支持该安装程序。 | 这将阻止在 64 位平台上进行任何不受支持的安装。对于 SysPrep，不支持 WOW 安装。
FusionRebootCheck | 检查是否由于断开的合成 ATL 而必须进行计算机重新启动。挂起重新启动会导致 SQL Server 安装程序失败。 | 需要计算机重新启动。在安装 SQL Server 之前，必须重新启动计算机。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 R2 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 R2 安装到其他计算机上。
SSMS_IsInternetConnected | 检查计算机是否已连接到 Internet。基于 .NET Framework 技术的 SQL Server 管理工具必须在启动时检查证书吊销列表。 | 请确保计算机已连接到 Internet。
IsFirewallEnabled | 检查是否启用了 Windows 防火墙。 | 确保已启用防火墙并且相应的端口已打开以启用远程访问。有关对于每个功能要打开的端口的详细信息，请参阅 Configuring Windows Firewall to allow SQL Server Access（配置 Windows 防火墙以允许 SQL Server 访问）。
AS_ValidateEditionUpgrade | 检查是否正在将 SQL Server Analysis Services 升级到正确版本 |
InstanceClashRule | 检查指定的实例名称是否已由 SQL Server 的现有实例使用。 | 使用安装在计算机上的其他实例当前未使用的唯一实例名称。
LibertyASInstallRule | 检查是否安装了 SQL Server 2000（64 位）Analysis Services 的默认实例。 |
Sql2005SsmsExpressFacet | 检查是否安装了 SQL Server 2005 Express Edition 工具。 |
VSShellInstalledRule | 请检查是否存在 Visual Studio 2008 的早期版本或者是否已将其升级至 SP1。 | 在安装 SQL Server 2008 R2 之前，必须先升级至 Visual Studio 2008 SP1。
EditionDownGradeCheck | 检查此方案是否支持所选 SQL Server 实例的版本。 | 对于某些版本，不支持升级。有关详细信息，请参阅 Version and Editions Upgrades（版本升级）。
EditionRequirementCheck | 检查此操作系统是否支持 SQL Server 版本。 | 您必须确认此计算机上的操作系统支持您正在安装的 SQL Server 版本。有关详细信息，请参阅 Hardware and Software Requirements for Installing SQL Server 2008 R2（安装 SQL Server 2008 R2 的硬件和软件要求）。
EditionUpgradeMatrixCheck | 检查所选 SQL Server 实例是否符合升级矩阵要求。 | 对于某些版本，不支持升级。有关详细信息，请参阅 Version and Editions Upgrades（版本升级）。
FAT32FileSystemCheck | 检查指定的驱动器是否为 FAT32 文件系统卷。支持但建议不要在 FAT32 文件系统上进行安装，因为它没有 NTFS 文件系统安全。 | 确保您指定用于安装 SQL Server 的驱动器不是 FAT32 文件系统。


完成 - 安装

完成 - 安装 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

单击“关闭”完成安装。

请参阅

其他资源

验证 SQL Server 安装

© 2010 Microsoft Corporation。保留所有权利。


完成 - 准备映像

完成 - 准备映像
SQL Server 安装程序的用户界面参考 >

使用“完成”页可以验证映像准备是否已完成。

选项

此对话框包含指向此操作的安装日志文件的链接。若要完成映像准备，请单击“关闭”。


完成 - 修复

完成 - 修复
SQL Server 安装程序的用户界面参考 >

使用“完成 - 修复”页可以验证修复是否已完成。

选项

此对话框包含指向此操作的安装日志文件的链接。若要继续，请单击“关闭”。


完成 - 升级

完成 - 升级
SQL Server 安装程序的用户界面参考 >

使用“完成(升级)”页可以验证升级是否已完成。

选项

此对话框包含指向此操作的安装日志文件的链接。若要继续，请单击“关闭”。


远程数据库升级的凭据

远程数据库升级的凭据 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“远程数据库升级的凭据”页可以指定远程报表服务器数据库的数据库登录名。

如果要升级远程数据库引擎实例上的报表服务器数据库，而您运行安装程序所使用的凭据不具有对远程实例的数据库更新权限，则必须输入安装程序可用来连接到此报表服务器数据库并对其进行修改的凭据。

选项

用户名

指定在升级操作期间使用一次以连接到承载报表服务器数据库的数据库引擎实例的 SQL Server 数据库登录名。此帐户必须具有更新报表服务器数据库架构的权限。

如果用于运行安装程序的凭据对报表服务器数据库没有 sysadmin 或数据库所有者权限，则是必需的。

如果要升级一个使用远程报表服务器数据库存储应用程序数据的报表服务器，而用于运行安装程序的凭据对远程服务器没有足够的权限，则必须指定此值。

密码

登录名的密码；如果登录名没有密码，则为空字符串。

请参阅

其他资源

升级 Reporting Services 的注意事项
安装 Reporting Services 的注意事项

© 2010 Microsoft Corporation。保留所有权利。


数据库引擎配置 - 帐户设置

数据库引擎配置 - 帐户设置 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

从 SQL Server 2005 开始，为了帮助确保 SQL Server 比早期版本更为安全，进行了一些重大的更改。这些更改秉承了“设计安全、默认安全、部署安全”的策略，目的在于防止服务器实例及其数据库免遭安全攻击。

SQL Server 2008 通过对服务器和数据库组件引入更多更改，继续实施这一安全强化过程。通过制定一个“最小权限”策略，SQL Server 2008 中引入的更改可进一步减少服务器及其数据库的外围应用和攻击区域，并使 Windows 管理和 SQL Server 管理进一步分离。这意味着内部帐户受到保护，并分成操作系统功能和 SQL Server 功能。这些措施包括：

  • 新的 SQL Server 2008 安装不再将 Windows 组 BUILTIN\Administrators 添加到 SQL Server sysadmin 固定服务器角色。

  • 具有将一个或多个 Windows 主体设置到 SQL Server 内的 sysadmin 服务器角色中的功能。此选项在 SQL Server 安装程序全新安装 SQL Server 2008 期间可用。

  • 已删除外围应用配置器 (SAC) 工具，取而代之的是 SQL Server 配置管理器工具中的基于策略的管理功能和一些相关更改。

这些更改将影响您的 SQL Server 安全规划，并可帮助您为系统创建更加全面的安全配置文件。

在 Windows Vista 和 Windows Server 2008 上运行 SQL Server 2008 时的注意事项

Windows Vista 和 Windows Server 2008 包含一项新功能，即用户帐户控制 (UAC)，该功能有助于管理员对提升的特权的使用进行管理。默认情况下，在 Windows Vista 和 Windows Server 2008 中，管理员不使用其管理权限。相反，他们以标准用户的身份执行大多数操作，仅在必要时临时使用其管理权限。但是，代替提升的特权，我们推荐下列选项之一：

  • 如果您在使用 Windows 身份验证模式，则应创建具有足够权限的 Windows 用户帐户，以便执行所有必要的管理任务。

  • 如果您在使用混合模式（SQL Server 身份验证和 Windows 身份验证），则可以考虑创建一个仅用于管理目的的 SQL Server 登录帐户。

UAC 会导致一些已知问题。有关详细信息，请参阅下列网页：

  • 在 Windows Vista 上运行 SQL Server 2005 时的注意事项

  • 用户帐户控制

选项

安全模式 - 选择“Windows 身份验证”或“混合模式身份验证”用于安装。

Windows 主体设置 - 在 SQL Server 的早期版本中，Windows BUILTIN\Administrators 本地组放入了 SQL Server sysadmin 服务器角色中，有效授予了 Windows 管理员对 SQL Server 实例的访问权限。在 SQL Server 2008 的 sysadmin 服务器角色中未设置 BUILTIN\Administrators 组，而是改为由您在安装过程中为新安装显式设置 SQL Server 管理员。

重要提示：
如果您的组织的进程或代码依赖于 Windows BUILTIN\Administrators 本地组访问权限，则您必须在新的安装过程中显式设置 SQL Server 管理员。直到您完成此步骤之后，安装程序才允许您继续操作。

指定 SQL Server 管理员 - 您必须为 SQL Server 实例至少指定一个 Windows 主体。若要添加用以运行 SQL Server 安装程序的帐户，请单击“当前用户”按钮。若要向系统管理员列表中添加帐户或从中删除帐户，请单击“添加”或“删除”，然后编辑将拥有 SQL Server 实例的管理员权限的用户、组或计算机的列表。

完成列表的编辑后，单击“确定”，然后在配置对话框中验证管理员列表。完成此列表后，请单击“下一步”。

如果选择“混合模式身份验证”，则必须为内置 SQL Server 系统管理员 (sa) 帐户提供登录凭据。

安全说明：
不要使用空密码。请使用强密码。

Windows 身份验证模式

当用户通过 Windows 用户帐户连接时，SQL Server 使用操作系统中的 Windows 主体标记验证帐户名和密码。此为默认身份验证模式，比混合模式更为安全。Windows 身份验证利用 Kerberos 安全协议，通过强密码的复杂性验证提供密码策略强制，提供帐户锁定支持，并且支持密码过期。

安全说明：
请尽可能使用 Windows 身份验证。

重要提示：
不要使用空密码。请使用强密码。切勿设置空密码或弱 sa 密码。

混合模式(Windows 身份验证或 SQL Server 身份验证)

允许用户使用 Windows 身份验证或 SQL Server 身份验证进行连接。通过 Windows 用户帐户进行连接的用户可以使用经过 Windows 验证的可信连接。

如果必须选择“混合模式身份验证”并且要求使用 SQL 登录名以适应早期应用程序，则必须为所有 SQL Server 帐户设置强密码。

注意：
提供 SQL Server 身份验证只是为了向后兼容。请尽可能使用 Windows 身份验证。

输入密码

输入并确认系统管理员 (sa) 登录名。密码是抵御入侵者的第一道防线，因此设置强密码对于系统安全是绝对必要的。切勿设置空密码或弱 sa 密码。

注意：
SQL Server 密码可包含 1 到 128 个字符，包括字母、符号和数字的任意组合。如果选择“混合模式身份验证”，则必须输入强 sa 密码才能进入安装向导的下一页。

强密码指南

强密码不易被人猜出，也不易用计算机程序攻击。强密码不能使用禁止的条件或字词，这些条件或字词包括：

  • 空条件或 NULL 条件

  • “Password”

  • “Admin”

  • “Administrator”

  • “sa”

  • “sysadmin”

强密码不能是与安装计算机相关联的下列字词：

  • 当前登录到计算机的用户的名称。

  • 计算机名称。

强密码的长度必须多于 8 个字符，并且强密码至少要满足下列四个条件中的三个：

  • 它必须包含大写字母。

  • 它必须包含小写字母。

  • 必须包含数字。

  • 必须包含非字母数字字符；例如 #、% 或 ^。

此页上输入的密码必须符合强密码策略要求。如果存在任何使用 SQL Server 身份验证的自动化过程，请确保该密码符合强密码策略要求。

请参阅

其他资源

设置 Windows 服务帐户

© 2010 Microsoft Corporation。保留所有权利。


数据库引擎配置 - 数据目录

数据库引擎配置 - 数据目录 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

下表列出了在 SQL Server 安装过程中用户可配置的默认目录：

说明 | 默认目录 | 建议
数据根目录 | C:\Program Files\Microsoft SQL Server\ | SQL Server 安装程序将为 SQL Server 目录配置 ACL 并在配置过程中中断继承。
用户数据库目录 | C:\Program Files\Microsoft SQL Server\MSSQL10_50.<实例 ID>\Data | 用户数据目录的最佳实践取决于工作量和性能要求。对于故障转移群集安装，应确保数据目录位于共享磁盘上。
用户数据库日志目录 | C:\Program Files\Microsoft SQL Server\MSSQL10_50.<实例 ID>\Data | 确保日志目录有足够的空间。
临时数据库目录 | C:\Program Files\Microsoft SQL Server\MSSQL10_50.<实例 ID>\Data | Temp 目录的最佳实践取决于工作量和性能要求。
临时数据库日志目录 | C:\Program Files\Microsoft SQL Server\MSSQL10_50.<实例 ID>\Data | 确保日志目录有足够的空间。
备份目录 | C:\Program Files\Microsoft SQL Server\MSSQL10_50.<实例 ID>\Backup | 设置合适的权限以防止数据丢失，并确保 SQL Server 服务的用户组具有写入备份目录的足够权限。不支持对备份目录使用映射的驱动器。

注释

  • 向现有安装中添加功能时，不能更改先前安装的功能的位置，也不能为新功能指定该位置。

  • 如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。

  • 在下列情况下，不能安装程序文件和数据文件：

    • 在可移动磁盘驱动器上

    • 在使用压缩的文件系统上

    • 在系统文件所在的目录上

    • 在故障转移群集实例的共享驱动器上

请参阅

概念

SQL Server 的默认实例和命名实例的文件位置

© 2010 Microsoft Corporation。保留所有权利。


数据库引擎配置 - 文件流

数据库引擎配置 - 文件流 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用此页可针对此 SQL Server 2008 安装启用 FILESTREAM。通过将 varbinary(max) 二进制大型对象 (BLOB) 数据以文件形式存储在文件系统上，FILESTREAM 使 SQL Server 数据库引擎和 NTFS 文件系统成为了一个整体。Transact-SQL 语句可以插入、更新、查询、搜索和备份 FILESTREAM 数据。通过 Win32 文件系统接口可以流式方式访问数据。

针对 Transact-SQL 访问启用 FILESTREAM

选中此项可针对 Transact-SQL 访问启用 FILESTREAM。必须选中此控制选项，才能使用其他控制选项。

针对文件 I/O 流访问启用 FILESTREAM

选中此项可针对 FILESTREAM 启用 Win32 流访问。

Windows 共享名

使用此控制选项可输入将用来存储 FILESTREAM 数据的 Windows 共享的名称。

允许远程客户端针对 FILESTREAM 数据启用流访问

选中此控制选项可允许远程客户端访问此服务器上的此 FILESTREAM 数据。

请参阅

其他资源

FILESTREAM 存储入门
sp_configure (Transact-SQL)


数据库引擎配置 - 用户实例

数据库引擎配置 - 用户实例
SQL Server 安装程序的用户界面参考 >

使用“用户实例”页可以为不具有管理员权限的用户生成单独的数据库引擎实例，并可以将用户添加到管理员角色中。

选项

启用用户实例

默认值为“启用”。若要禁用用户实例的功能，请清除此复选框。

用户实例也称为子实例或客户端实例，是由父实例（作为服务运行的主实例，如 SQLExpress）代表用户生成的 SQL Server 实例。用户实例作为用户进程在该用户的安全上下文中运行。用户实例独立于父实例和该计算机上运行的任何其他用户实例。用户实例功能也被称作“以普通用户身份运行” (RANU)。

将用户添加到 SQL Server 管理员角色中

默认情况下不启用此选项。若要将当前安装用户添加到 SQL Server 管理员角色中，请选中此复选框。

作为 BUILTIN\Administrators 成员的 Windows Vista 用户在连接到 SQL Server Express 时，不会自动添加到 sysadmin 固定服务器角色中。只有已显式添加到服务器级管理员角色中的 Windows Vista 用户才能管理 SQL Server Express。Built-In\Users 组的任一成员都可连接到 SQL Server Express 实例，但他们仅拥有执行数据库任务的有限权限。因此，对于从先前 Windows 版本中的 BUILTIN\Administrators 和 Built-In\Users 继承 SQL Server Express 特权的用户，应在运行于 Windows Vista 上的 SQL Server Express 实例中为其显式授予管理特权。

若要在此安装程序完成后对用户角色进行任何更改，请使用 SQL Server 2005 外围应用配置器工具 (SQLSAC.exe)。若要更新 SQL Server 系统管理员角色中的用户列表，请单击“添加新管理员”链接。

确保“要设置的用户”字段中列出了应更新其权限的用户的“域名\用户名”。从“可用权限”窗格的 SQL Server 实例列表中选择要更新的角色，然后单击向右箭头。若要将用户添加到 SQL Server 实例的所有可用实例的所有可用角色中，请单击向右双箭头。

若要在完成选择后实现这些更改，请单击“确定”。若要在不进行更改的情况下结束使用此工具，请单击“取消”。


磁盘空间要求

磁盘空间要求 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“磁盘成本摘要”页可以检查选择安装的 SQL Server 功能的磁盘空间要求。

选项

如果所需的磁盘空间太大，应考虑以下选项：

  • 将安装目录更改为具有更多磁盘空间的驱动器。

  • 更改要安装的 SQL Server 功能。

  • 通过移动其他文件或应用程序在指定驱动器上腾出更多可用空间。

请参阅

其他资源

安装 SQL Server 2008 R2 的硬件和软件要求

© 2010 Microsoft Corporation。保留所有权利。


版本升级规则

版本升级规则 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会采用以下规则验证您的计算机配置。

检查项 | 说明 | 用户操作
Engine_OnlySupportedFeaturesUsedCheckSystem | 检查系统数据库中是否存在要升级到的 SQL Server 版本中不支持的功能。 | 关闭系统数据库中使用的、在要升级到的 SQL Server 版本中不可用的任何功能。
Engine_OnlySupportedFeaturesUsedCheckUser | 检查所有用户数据库中是否存在 SQL Server 版本不支持的功能。 | 关闭系统数据库中使用的、在要升级到的 SQL Server 版本中不可用的任何功能。
Engine_SqlEngineRestartCheck | 检查是否可以重新启动 SQL Server 服务。 | 确定哪个问题在阻止 SQL Server 服务联机并更正它。
Engine_SqlServerServiceDisabled_Id | 检查 SQL Server 服务是否未设置为“已禁用”。 | 将 SQL Server 服务的启动类型设置为“手动”或“自动”。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 R2 安装在域控制器上。 | 确保此计算机不是域控制器。有关详细信息，请参阅 Security Considerations for a SQL Server Installation（安装 SQL Server 的安全注意事项）。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是某些 SQL Server 2008 R2 版本的必备组件。 | 对于 SQL Server 2008 R2 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
EditionUpgradeMatrixCheck | 检查所选 SQL Server 实例是否符合升级矩阵要求。 | 不支持某些版本升级方案。有关详细信息，请参阅 Version and Edition Upgrades（版本升级）。
AS_ValidateEditionUpgrade | 检查 Analysis Services 要升级到的版本是否有效。 | 不支持某些版本升级方案。有关详细信息，请参阅 Version and Edition Upgrades（版本升级）。
Cluster_EditionDownGradeCheck | 检查此方案是否支持所选 SQL Server 实例的版本。 | 不支持某些版本升级方案。有关详细信息，请参阅 Version and Edition Upgrades（版本升级）。
BlockMixedArchitectureUpgrade | 检查尝试升级的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 不支持某些跨平台升级方案。有关详细信息，请参阅 Version and Edition Upgrades（版本升级）。
EditionDownGradeCheck | 检查此方案是否支持所选 SQL Server 实例的版本。 | 不支持某些版本升级方案。有关详细信息，请参阅 Version and Edition Upgrades（版本升级）。

请参阅

参考

安装程序支持规则

© 2010 Microsoft Corporation。保留所有权利。


错误报告

错误报告
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“错误报告”页，可以启用 SQL Server 的功能错误报告功能。

选项

对于 SQL Server 2008 R2 中的 SQL Server 及其组件，错误报告功能在默认情况下已禁用。

错误报告

如果启用错误报告功能，SQL Server 将配置为在下列任意 SQL Server 组件中发生错误时，自动发送报告到 Microsoft：

  • 数据库引擎

  • SQL Server 代理

  • Analysis Services

  • Reporting Services

  • Integration Services

  • 复制

Microsoft 利用错误报告来改进 SQL Server 的功能，并且对所有信息保密。

有关错误的信息将通过安全 (https) 连接发送到 Microsoft，在那里保存这些信息，且对其访问将受到限制。另外，也可以将这些信息发送到您自己的“公司错误报告”服务器。

错误报告包含下列信息：

  • 发生问题时 SQL Server 的状态。

  • 操作系统版本和计算机硬件信息。

  • 用户数字产品 ID（并非用于标识您的许可证）。

  • 计算机或代理服务器的网络 IP 地址。

  • 来自出错进程的内存或文件的信息。

Microsoft 无意收集您的文件、姓名、地址、电子邮件地址或任何其他私人信息。但是，错误报告可能包含来自导致错误的进程的内存或文件中的个人信息。虽然使用这些信息有可能确定您的身份，但 Microsoft 不会将这些信息用于此目的。

有关 SQL Server 隐私保护和数据收集策略的详细信息，请参阅 Microsoft SQL Server Privacy Statement（Microsoft SQL Server 隐私声明）。

如果启用了错误报告功能并出现错误，则 Windows 事件日志中可能会包含来自 Microsoft 的一条响应，该响应指向与特定错误有关的 Microsoft 知识库文章。

若要在安装程序完成后禁用 SQL Server 及其组件的所有实例的错误报告，请转到“错误和使用情况报告”工具并清除“错误报告”的复选框。如果为 SQL Server 的多个组件（SQL Server 数据库引擎、Analysis Services、Reporting Services 和共享组件）启用了“错误报告”，则可以对个别组件以及共享组件（在“其他”中列出）的每个实例禁用“错误报告”。


故障转移群集报告

故障转移群集报告
SQL Server 安装程序的用户界面参考 >

使用“故障转移群集报告”页可以查看安装系统针对此操作所扫描得到的报告结果。

选项

若要查看扫描的详细报告，请单击报告链接。


查看功能

查看功能
SQL Server 安装程序的用户界面参考 >

“查看功能”页是已准备好并且将在完成映像步骤结束时配置并完成的功能的只读列表。该功能列表在准备映像步骤中选择，并且在完成映像步骤中无法修改。除了显示的功能外，已准备实例还包括 SQL Server Browser、SQL Server Writer 和 SQL Server Native Client。

在完成了 SQL Server 的已准备实例的配置后，可以添加在 SQL Server 的已准备实例中未包括的其他功能。

组件组

组件和功能

数据库引擎服务

SQL Server 数据库引擎中包括以下组件：

  • 数据库引擎是用于存储、处理和保护数据的核心服务。

    • 复制：（可选）复制是一组技术，用于将数据和数据库对象从一个数据库复制和分发到另一个数据库，然后在数据库之间进行同步以维护一致性。

    • 全文搜索：（可选）全文搜索提供了针对 SQL Server 表中基于纯字符的数据发出全文查询的功能。

Reporting Services

Reporting Services 包括用于创建、管理和部署表格报表、矩阵报表、图形报表以及自由格式报表的服务器和客户端组件。Reporting Services 还是一个可用于开发报表应用程序的可扩展平台。


安装角色

安装角色 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用此页可以指定是使用“功能选择”页来分别选择各项功能，还是使用安装角色来进行安装。

通过setup role，可以固定选择实现预定义的 SQL Server 配置所需的所有功能和共享组件。

选项

SQL Server 功能安装

选择此选项可分别选择各项功能和共享组件。功能包括数据库引擎服务、Analysis Services（本机模式）、Reporting Services 和 Service Broker。

SQL Server PowerPivot for SharePoint

选择此选项可以在 SharePoint 2010 场中安装 Analysis Services 服务器组件。此选项在场中部署 PowerPivot 系统服务和 Analysis Services 服务，同时支持对包含嵌入式 PowerPivot 数据的已发布 Excel 工作簿进行查询和数据处理。

PowerPivot for SharePoint 有两个配置选项：

  • “现有场”用于将 PowerPivot for SharePoint 添加到已配置的场或独立服务器中。

  • “新服务器”用于通过尽可能少的步骤部署 PowerPivot for SharePoint。此角色要求您已安装但尚未配置 SharePoint 服务器。SQL Server 安装程序将为您配置 SharePoint，并创建 Web 应用程序、网站集和针对 PowerPivot 功能进行优化的服务器配置。

对于此角色，安装程序将执行以下操作：

  • 设置 Analysis Services 服务实例。

  • 在 SharePoint 应用程序服务器上安装程序文件。

  • 部署两个 PowerPivot 解决方案包，它们将应用程序文件添加到 Web 前端服务器。

  • （仅限“新服务器”）将数据库引擎服务添加到安装中，并将其作用场的数据库服务器。

  • （仅限“新服务器”）添加 SQL Server Management Studio、配置工具和性能工具。

  • （仅限“新服务器”）创建一个 PowerPivot 服务应用程序和应用程序数据库。

基于角色的安装不包含 SQL Server PowerPivot for Excel 客户端应用程序。将单独安装此客户端应用程序。

所有功能以及默认值

选择此安装角色将安装此版本提供的所有功能。请注意，从该角色中排除 PowerPivot for SharePoint。您必须使用 PowerPivot for SharePoint 安装角色来安装该功能。

数据库引擎配置为使用 NT AUTHORITY\NETWORK SERVICE 帐户开始。当前用户将设置为 SQL Server sysadmin 角色的成员。此选项设置的值可以通过指定其他命令行参数来覆盖。

在 Windows Vista 或 Windows Server 2008 或更高版本中，当操作系统不是域控制器时，默认情况下，数据库引擎和 Reporting Services 将使用 NTAUTHORITY\NETWORK SERVICE 帐户，Integration Services 将使用 NTAUTHORITY\NETWORK SERVICE 帐户，而 SQL 全文筛选器后台程序启动器将使用 NTAUTHORITY\LOCAL SERVICE 帐户。

请参阅

参考

功能选择
新 SharePoint 场配置

其他资源

安装（Analysis Services SharePoint 集成）
硬件和软件要求
如何在新的独立 SharePoint 服务器上安装 Analysis Services


功能选择

功能选择 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“功能选择”页上的复选框为您的 SQL Server 安装选择组件。

选项

选择各个组件组时，“说明”窗格中会显示相应的说明。您可以选中任意一些复选框。若要继续，必须进行选择。

SQL Server SysPrep：数据库引擎和 Reporting Services 是唯一支持 SQL Server SysPrep 的 SQL Server 2008 R2 功能。您可以在该过程的准备映像步骤中选择这些功能和组件。在完成 SQL Server 的已准备映像时，不能进行选择。有关详细信息，请参阅 How to: Install SQL Server 2008 R2 using SysPrep（如何使用 SysPrep 安装 SQL Server 2008 R2）。

SQL Server 故障转移群集：数据库引擎和 Analysis Services 组件是仅有的两个支持故障转移群集的 SQL Server 2008 R2 功能。可以在故障转移群集节点上安装其他组件，如 Reporting Services 或 Integration Services，但这些组件不能识别群集，因此当该故障转移群集节点脱机时，这些组件的服务不进行故障转移。有关详细信息，请参阅 Getting Started with SQL Server Failover Clustering（SQL Server 故障转移群集入门）。

组件组 组件和功能

数据库引擎服务

SQL Server 数据库引擎中包括以下组件：

  • 数据库引擎是用于存储、处理和保护数据的核心服务。

    • 复制：可选：复制是一组技术，用于将数据和数据库对象从一个数据库复制和分发到另一个数据库，然后在数据库之间进行同步以维护一致性。

SQL Server 故障转移群集：选择“数据库引擎服务”时，复制是必需的，并由 SQL 故障转移群集安装的安装程序自动选择。

  • 全文搜索：可选：全文搜索提供了针对 SQL Server 表中基于纯字符的数据发出全文查询的功能。

SQL Server 故障转移群集：选择“数据库引擎服务”时，全文搜索是必需的，并由 SQL 故障转移群集安装的安装程序自动选择。

  • 用于管理关系数据和 XML 数据的工具。

Analysis Services

Analysis Services 包括用于创建和管理联机分析处理 (OLAP) 以及数据挖掘应用程序的工具。

Reporting Services 2,3

Reporting Services 包括用于创建、管理和部署表格报表、矩阵报表、图形报表以及自由格式报表的服务器和客户端组件。Reporting Services 还是一个可用于开发报表应用程序的可扩展平台。

Integration Services

Integration Services 是一组图形工具和可编程对象，用于移动、复制和转换数据。

共享功能：

  • 客户端工具

  • SQL Server 联机丛书

  • Business Intelligence Development Studio 4,5

  • Integration Services

客户端工具包括用于在客户端和服务器之间进行通信的组件，其中包括用于 DB-Library、OLEDB for OLAP、ODBC、ADODB 和 ADOMD+ 的各种网络库以及以下 SQL Server 管理工具：

  • SQL Server Management Studio (SSMS) 是一个集成环境，用于访问、配置、管理和开发 SQL Server 的所有组件。SSMS 将 SQL Server 早期版本中包含的企业管理器、查询分析器和分析管理器的功能组合到单一环境中，为不同层次的开发人员和管理员提供 SQL Server 访问能力。

  • SQL Server 配置管理器为 SQL Server 服务、服务器协议、客户端协议和客户端别名提供基本配置管理。

  • SQL Server Profiler 提供了图形用户界面，用于监视数据库引擎实例或 Analysis Services 实例。

  • 数据库引擎优化顾问可以协助创建索引、索引视图和分区的最佳组合。

  • 使用复制监视器，可以跨复制拓扑跟踪发布和订阅的状态及性能。

  • SQLXML 客户端功能

  • SQL Server 联机丛书是 SQL Server 的核心文档。

Business Intelligence Development Studio 是用于 Analysis Services、Reporting Services 和 Integration Services 解决方案的集成开发环境。

Integration Services 是一组图形工具和可编程对象，用于移动、复制和转换数据。

客户端工具向后兼容性

客户端工具向后兼容性包括以下组件：

  • SQL 分布式管理对象 (SQL-DMO)。有关详细信息，请参阅 Discontinued SQL Server Features in SQL Server 2008 R2（SQL Server 2008 R2 中不再推荐使用的 SQL Server 功能）。

  • 决策支持对象 (DSO)。有关详细信息，请参阅 Breaking Changes to Analysis Services Features in SQL Server 2008 R2（SQL Server 2008 R2 中 Analysis Services 功能的重大更改）。

  • Data Transformation Services (DTS)。有关详细信息，请参阅 Deprecated Integration Services Features in SQL Server 2008 R2（SQL Server 2008 R2 中不推荐使用的 Integration Services 功能）。

1安装程序不为 Reporting Services 扩展部署中的多个节点配置负载平衡和单 URL 寻址。若要完成扩展部署，必须使用 Windows Server、Microsoft Application Center 或第三方群集管理软件。有关 Web 场部署设置的详细信息，请参阅为扩展部署配置 Reporting Services。

2 Reporting Services 的报表设计器组件需要 Microsoft Internet Explorer 6.0 SP 1。

3 Reporting Services 不支持同时在 64 位平台上和 64 位服务器的 32 位子系统 (WOW64) 上进行并行配置。

4安装 SQL Server Management Studio 需要 Internet Explorer 6.0 SP1。

5安装 Business Intelligence Development Studio 需要 Internet Explorer 6.0 SP1。

共享组件目录

由一台计算机上的所有 SQL Server 实例共享的功能安装在一个目录中。其中包括：

  • 客户端工具

  • SQL Server 联机丛书

  • Business Intelligence Development Studio

  • Integration Services

默认情况下，共享组件安装到 %Program Files%Microsoft SQL Server\ 中。若要更改安装路径，请单击“浏览”按钮。如果更改一个共享组件的安装路径，则要同时更改其他共享组件的安装路径。后续安装会将共享组件安装到与原始安装相同的位置。

在基于 x64 的操作系统上，您可以指定 64 位组件的安装位置，以及 32 位组件在 WOW64 子系统上的安装位置。

安装示例数据库和示例

默认情况下，不会将示例数据库和示例代码作为 SQL Server 安装程序的一部分进行安装。有关安装示例数据库和示例代码的详细信息，请参阅 CodePlex 网站。

安装 SQL Server 2008 R2 后还可以获得有关示例的其他信息。在“开始”菜单中，依次单击“所有程序”、“Microsoft SQL Server 2008 R2”、“文档和教程”，再单击“Microsoft SQL Server 示例概述”。

请参阅

其他资源

SQL Server 2008 R2 的版本和组件

© 2010 Microsoft Corporation。保留所有权利。


功能选择（卸载）

功能选择（卸载）
SQL Server 安装程序的用户界面参考 >

使用“功能选择”-“卸载”页可以选择要从指定的 SQL Server 实例中删除的功能。

选项

可以选择功能的任意组合。


要升级的功能

要升级的功能 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 2008 安装向导的“要升级的功能”页可以指定要升级至 SQL Server 2008 的功能。

选项

  • 在此版本中无法对要升级的功能进行更改。

请参阅

其他资源

版本升级
使用升级顾问来准备升级
使用 SQL Server 的多个版本

© 2010 Microsoft Corporation。保留所有权利。


全文搜索升级选项

全文搜索升级选项 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“全文搜索升级选项”页选择用于此时要升级的数据库的全文搜索升级选项。

在 SQL Server 2005 和早期版本中，每个全文索引都驻留在属于文件组的全文目录中，它们均具有物理路径，并被视为数据库文件。从 SQL Server 2008 开始，全文目录是表示一组全文索引的逻辑概念，即虚拟对象。因此，新的全文目录不会视为带有物理路径的数据库文件。但是，在升级包含数据文件的所有全文目录期间，将在相同磁盘上创建新的文件组。这可以在升级后维护旧磁盘的 I/O 行为。该目录的所有全文索引均被放置到新的文件组中（如果存在根路径）。如果旧的全文目录路径无效，该升级则将全文索引保留在与基表相同的文件组中，或者保留在主文件组中（对于分区表）。

选项

升级到 SQL Server 2008 R2 时，请选择下列全文升级选项之一。

导入

导入全文目录。一般情况下，导入速度比重新生成速度要快很多。例如，当仅使用一个 CPU 时，导入的运行速度比重新生成要快 10 倍左右。不过，导入的全文目录不能使用 SQL Server 2008 中引入的新的和增强的断字符，因此最终可能还是要重新生成全文目录。

注意：
重新生成可以在多线程模式下运行，如果可用的 CPU 在 10 个以上，且您允许重新生成操作使用所有这些 CPU，则重新生成操作的运行速度可能比导入更快。

如果全文目录不可用，则会重新生成关联的全文索引。此选项仅对 SQL Server 2005 数据库可用。

有关导入全文索引的影响的信息，请参阅本主题后面的“有关选择全文升级选项的注意事项”。

重新生成

使用新的和增强的断字符重新生成全文目录。重新生成索引可能需要一些时间，且升级后可能需要占用大量的 CPU 和内存。

重置

重置全文目录。将删除 SQL Server 2005 全文目录文件，但会保留全文目录和全文索引的元数据。在进行升级后，所有全文索引将禁用更改跟踪，并且不会自动启动爬网。在升级完成后，目录将保留为空，直至手动执行完全填充。

所有这些升级选项确保升级后的数据库从 SQL Server 2008 的全文性能增强功能中完全受益。

重要提示：
有关在导入 SQL Server 2005 全文索引后使用新的断字符和将干扰词文件升级到非索引字表的信息，请参阅 Full-Text Search Upgrade（全文搜索升级）。

有关选择全文升级选项的注意事项

为升级选择升级选项时，请考虑以下几点：

  • 如何使用断字符？

    从 SQL Server 2008 开始，全文搜索服务包括新的断字符和词干分析器。这可能更改早期版本中特定文本模式或方案的全文查询结果。因此，在选择适当的升级选项时，如何使用断字符非常重要：

    • 如果使用的全文语言的断字符在 SQL Server 2008 中未发生更改，或者撤回准确性对您来说并不重要，则适合导入。随后，如果遇到任何撤回问题，您只需通过重新生成全文目录即可升级到新的断字符。有关详细信息，请参阅 Full-Text Search Upgrade（全文搜索升级）。

    • 如果您关心撤回准确性，并使用 SQL Server 2008 中经过改进的断字符之一，则适合重新生成。

  • 是否基于整数全文键列生成了任何全文索引？

    重新生成执行内部优化，在某些情况下该优化可提高升级的全文索引的查询性能。具体来说，如果您具有的全文目录包含基表的全文键列为整数数据类型的全文索引，则重新生成将在升级后实现全文查询的理想性能。在这种情况下，我们强烈建议使用“重新生成”选项。

    注意：
    对于 SQL Server 2008 R2 中的全文索引，建议采用整数数据类型作为全文键列。有关详细信息，请参阅 Performance Tuning and Optimization (Full-Text Search)（性能优化（全文搜索））。

  • 使服务器实例处于联机状态的优先级是什么？

    升级期间的导入或重新生成操作会占用很多 CPU 资源，这会延迟其余服务器实例的升级和联机。如果使服务器实例尽快处于联机状态非常重要，并且希望在升级后运行手动填充，则适合“重置”。

其他资源

SQL Server 2008 中全文搜索的重大更改

SQL Server 2008 中全文搜索的行为更改

SQL Server 2008 中不推荐使用的数据库引擎功能

查询全文键列

断字符和词干分析器

请参阅

其他资源

如何安装 SQL Server 2008 R2（安装程序）


安装必备组件

安装必备组件
SQL Server 安装程序的用户界面参考 >

为了成功安装 SQL Server，安装计算机上需要具有下列软件组件。将由 SQL Server 安装程序安装这些软件组件：

  • .NET Framework 2.0 版 SP2，适用于SQL Server Express

  • 适用于 SQL Server Express with Tools 和 SQL Server Express Advanced 的 .NET Framework 3.5 版 SP1

  • 适用于 Windows Server 2003（64 位）IA64 SP1 上的 SQL Server 2008 的 .NET Framework 2.0 版 SP2

  • .NET Framework 3.5 版 SP1，适用于所有其他版本的SQL Server 2008

  • SQL Server 安装程序支持文件

  • SQL Server Native Client

注意：
如果安装失败或被取消，将不会删除这些组件。若要删除它们，请使用“控制面板”中的“添加或删除程序”。

注意：
安装 .NET Framework 2.0 SP2：.NET Framework 2.0 SP2 不作为单独的下载提供。您需要安装其中包括 .NET Framework 2.0 SP2 的 .NET Framework 3.5 SP1。

选项

若要安装必备组件文件，请单击“安装”。若要退出安装过程，请单击“取消”。


安装进度

安装进度 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“安装进度”页可以监视 SQL Server 安装程序的状态。

请参阅

概念

如何查看和读取 SQL Server 安装程序日志文件

© 2010 Microsoft Corporation。保留所有权利。


安装规则

安装规则 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。下表描述了系统配置检查器的检查参数和妨碍性问题的解决办法。

检查项 | 说明 | 用户操作
RebootRequiredCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 需要计算机重新启动。在安装 SQL Server 之前，必须重新启动计算机。
OsVersionCheck | 检查计算机是否满足最低操作系统版本要求。 | 操作系统必须满足此产品的最低要求。有关详细信息，请参阅 Hardware and Software Requirements for Installing SQL Server 2008 R2（安装 SQL Server 2008 R2 的硬件和软件要求）。
ThreadHasAdminPrivilegeCheck | 检查运行 SQL Server 安装程序的帐户是否具有计算机的管理权限。 | 请确保运行 SQL Server 安装程序的帐户具有计算机的管理权限。
WmiServiceStateCheck | 检查是否已在计算机上启动并正在运行 WMI 服务。 | 必须正在运行 WMI 服务。
SSMS_IsInternetConnected | 检查计算机是否已连接到 Internet。基于 .NET Framework 技术的 SQL Server 管理工具必须在启动时检查证书吊销列表。 | 请确保计算机已连接到 Internet。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 安装在域控制器上。 | 确保此计算机不是域控制器。有关详细信息，请参阅 Security Considerations for a SQL Server Installation（安装 SQL Server 的安全注意事项）。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是 SQL Server Express with Advanced Services 的必备组件。 | 对于 SQL Server Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定操作系统平台是否支持该安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。有关详细信息，请参阅 Hardware and Software Requirements for Installing SQL Server 2008 R2（安装 SQL Server 2008 R2 的硬件和软件要求）。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 R2 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 R2 安装到其他计算机上。
BlockCrossLanguageInstall | 检查安装语言是否与现有 SQL Server 功能的语言相同。 | 必须使用与现有 SQL Server 实例相同的语言版本来升级 SQL Server。
BlockMixedArchitectureInstall | 检查要安装的功能是否与指定实例具有相同的 CPU 体系结构。 | 安装或升级时所使用的 SQL Server 安装介质必须与要修改的 SQL Server 实例具有相同的体系结构。
RS_DoesCatalogExist | 检查是否存在目录数据库文件。 | 重命名、移动或删除文件。
RS_DoesCatalogTempDBExist | 检查是否存在目录临时数据库文件。 | 重命名、移动或删除文件。
StandaloneInstall_HasClusteredOrPreparedInstanceCheck | 检查所选实例名称是否已被任意群集节点上的现有已准备就绪的或群集化的实例使用。 | 不能使用所选的实例名称，因为它已被使用。请指定其他 SQL Server 实例名称。
Microsoft Visual Studio 2008 的早期版本 | 请检查是否存在 Visual Studio 2008 的早期版本或者是否已升级至 SP1。 | 在安装 SQL Server 2008 R2 之前，必须先升级至 Visual Studio 2008 SP1。

请参阅

参考

安装程序支持规则

© 2010 Microsoft Corporation。保留所有权利。


安装类型

安装类型
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“安装类型”页可以指定是安装 SQL Server 2008 的新实例还是向现有实例中添加功能。

选项

选择指示您所做选择的单选按钮：

  • 执行 SQL Server 2008 的全新安装

  • 向 SQL Server 2008 的现有实例中添加功能

    如果选择与向现有实例中添加功能相对应的选项，则使用下拉列表选择要更新的 SQL Server 实例。

您只能向 SQL Server 的已准备映像添加 SysPrep 支持的功能（数据库引擎和 Reporting Services）。只有在已准备实例完成后，才能添加 SysPrep 不支持的其他功能。

注意 安装故障转移群集实例之后，不能再向其中添加功能。若要向现有故障转移群集中添加 SQL Server 功能，则必须执行全新安装才能安装单独的 SQL Server 实例。


实例配置

实例配置
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“实例配置”页面可指定是创建 SQL Server 的默认实例还是其命名实例。如果尚未安装 SQL Server 实例，则除非您指定命名实例，否则将创建默认实例。

每个 SQL Server 实例都由一组具有排列规则及其他选项特定设置的非重复的服务组成。目录结构、注册表结构和服务名称都反映在 SQL Server 安装过程中创建的实例名称和特定实例 ID。

实例是默认实例或命名实例。默认实例名为 MSSQLSERVER。不需要客户端指定实例名称便可进行连接。命名实例在安装过程中由用户决定。您可以将 SQL Server 作为命名实例安装，无需先安装默认实例。默认实例可以是 SQL Server 2000、SQL Server 2005、SQL Server 2008 或 SQL Server 2008 R2 安装。不论版本如何，一次均只能安装一个 SQL Server 默认实例。

注意：
使用 SQL Server SysPrep，您可以在“实例配置”页上完成已准备实例时指定实例名称。如果计算机上没有 SQL Server 的现有默认实例，您可以选择将正在完成的已准备实例配置为默认实例。有关详细信息，请参阅如何使用 SysPrep 安装 SQL Server。

多实例

SQL Server 支持单个服务器或处理器上存在多个 SQL Server 实例，但只能有一个实例为默认实例。所有其他实例必须为命名实例。一台计算机可同时运行多个 SQL Server 实例，每个实例独立于其他实例运行。

有关详细信息，请参阅 Maximum Capacity Specifications for SQL Server（SQL Server 最大容量规范）。

选项

仅限故障转移群集实例 - 指定 SQL Server 故障转移群集网络名称。此名称可用来在网络上标识故障转移群集实例。

默认实例或命名实例 - 当您决定是安装 SQL Server 的默认实例还是命名实例时，请考虑以下信息：

  • 如果计划在数据库服务器上安装单个 SQL Server 实例，则该实例应为默认实例。

  • 如果您打算在同一台计算机上安装多个实例，请使用命名实例。一台服务器只能承载一个默认实例。

  • 任何安装 SQL Server Express 的应用程序都应将其作为命名实例安装。当同一台计算机中安装多个应用程序时，这样可以最大程度地减少冲突。

默认实例

选择该选项可安装 SQL Server 的默认实例。一台计算机只能承载一个默认实例；所有其他实例必须是命名实例。但是，如果您已经安装了 SQL Server 的默认实例，则可以向同一台计算机添加 Analysis Services 的默认实例。

命名实例

选择该选项可创建新的命名实例。当对 SQL Server 实例进行命名时，请注意以下几点：

  • 实例名不区分大小写。

  • 实例名称不能包含词语“Default”或其他保留关键字。如果在实例名中使用了保留关键字，将发生安装错误。有关详细信息，请参阅保留关键字（安装程序）。

  • 如果为实例名称指定 MSSQLServer，将创建默认实例。对于 SQL Server Express，如果为实例名称指定 SQLExpress，将创建默认实例。

  • Microsoft SQL Server PowerPivot for SharePoint 安装始终安装为命名实例“PowerPivot”。您不能为此功能角色指定不同的实例名称。

  • 实例名限制为 16 个字符。

  • 实例名中的第一个字符必须是字母。可接受的字母为 Unicode 标准 2.0 定义的那些字母。这些字母包括拉丁字符 a-z、A-Z 和其他语言中的字母字符。

  • 后续字符可以是 Unicode 标准 2.0 定义的字母、源于基本拉丁语或其他国家/地区书写符号的十进制数字、美元符号 ($) 或者下划线 (_)。

  • 实例名称中不允许含有空格或其他特殊字符，也不允许存在反斜杠 (\)、逗号 (,)、冒号 (:)、分号 (;)、单引号 (')、and 符 (&) 和 at 符 (@)。

    注意：
    只有在当前 Windows 代码页中有效的字符才能用在 SQL Server 实例名称中。如果使用了不支持的 Unicode 字符，将会发生安装错误。

检测到的实例和功能

查看正在运行 SQL Server 安装程序的计算机中安装的 SQL Server 实例和组件的列表。

实例 ID - 默认情况下，实例名称用作实例 ID。这用于标识 SQL Server 实例的安装目录和注册表项。默认实例和命名实例的默认方式都是如此。对于默认实例，实例名称和实例 ID 为 MSSQLSERVER。若要使用非默认的实例 ID，请在“实例 ID”字段中指定它。

重要提示：
使用 SQL Server SysPrep，在此页上显示的实例 ID 是在 SQL Server SysPrep 过程的准备映像步骤中指定的实例 ID。在完成映像步骤中，您将无法指定不同的实例 ID。

注意：
不支持以下划线 (_) 开头或者包含数字符号 (#) 或美元符号 ($) 的实例 ID。

有关目录、文件位置和实例 ID 命名的详细信息，请参阅 SQL Server 的默认实例和命名实例的文件位置。

实例根目录 - 默认情况下，实例根目录为 C:\Program Files\Microsoft SQL Server\。若要指定非默认的根目录，请单击“浏览”按钮或提供一个路径名。

SQL Server 的给定实例的所有组件作为一个单元进行管理。所有 SQL Server Service Pack 和升级都将应用于 SQL Server 实例的每个组件。

共用同一实例名称的所有 SQL Server 组件都必须满足以下条件：

  • 版本相同

  • 版本类别相同

  • 语言设置相同

  • 聚集状态相同

    注意：
    Reporting Services 不能识别群集。

  • 操作系统相同


实例选择（卸载）

实例选择（卸载）
SQL Server 安装程序的用户界面参考 >

在“实例选择 – 卸载”页上，使用下拉框指定要卸载的 SQL Server 实例。

选项

可以指定卸载 SQL Server 的整个实例，也可以指定仅卸载共享功能和管理工具。


实例选择(升级)

实例选择(升级)
SQL Server 安装程序的用户界面参考 >

使用“实例选择(升级)”页可以指定要升级的 SQL Server 实例。

选项

必须同时升级实例中的所有组件。不能在升级过程中添加或删除功能。


要升级的实例

要升级的实例 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“要升级的实例”页可以指定要升级到 SQL Server 2008 的 SQL Server 2000 或 SQL Server 2005 实例。

选项

使用单选按钮指定是要升级 SQL Server 实例及其共享组件，还是只升级共享组件。此 SQL Server 版本中的共享组件包括：

  • Integration Services

  • SQL Server 浏览器

  • SQL Server Active Directory Helper

  • SQL 编写器

有关支持的升级方案和已知升级问题的详细信息，请参阅 Version and Edition Upgrades（版本升级）。

请参阅

其他资源

使用升级顾问来准备升级
使用 SQL Server 的多个版本

© 2010 Microsoft Corporation。保留所有权利。


使 SQL Server 2008 外围应用最小化

使 SQL Server 2008 外围应用最小化 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

减少外围应用是一项安全措施，它涉及停止或禁用未使用的组件。外围应用的减少使得对系统潜在攻击的途径更少，从而有助于提高安全性。

对于新 SQL Server 2008 安装，为了减少 SQL Server 外围应用，将禁用或停止某些功能、服务或连接。对于升级安装，所有功能、服务和连接都保持其升级前的状态。

  • 使用 SQL Server 配置管理器可以启用、禁用、启动或停止服务，并可配置数据库引擎的远程连接。

  • 使用基于策略的管理可以启用和禁用可选功能。

使用 SQL Server 配置管理器

SQL Server 配置管理器会随所有 SQL Server 版本一起安装。

打开 SQL Server 配置管理器

  1. 在“开始”菜单中，依次指向“所有程序”、Microsoft SQL Server 2008 R2、“配置工具”，然后单击“SQL Server 配置管理器”。
将服务配置为自动启动

  1. 在 SQL Server 配置管理器中，展开“SQL Server 服务”。

  2. 在详细信息窗格中，右键单击 SQL Server 服务之一，然后单击“属性”。

  3. 在“属性”对话框中，将“启动模式”设置为“自动”。
将数据库引擎配置为接受远程连接

  1. 在 SQL Server 配置管理器中，展开“SQL Server 网络配置”，然后单击 <实例名称> 的协议。

  2. 在详细信息窗格中，右键单击可用的协议之一，然后单击“属性”。

    注意：
    无法对远程连接启用 Shared Memory 协议。

  3. 若要为远程连接启用协议，请将“启用”框设置为“是”。

有关 SQL Server 配置管理器的帮助信息，请查看 SQL Server 配置管理器帮助文件，或参阅 SQL Server 联机丛书。若要配置 SOAP 和 Service Broker 端点，请使用 CREATE ENDPOINT 和 ALTER ENDPOINT。

使用基于策略的管理

使用 SQL Server Management Studio 可以配置基于策略的管理。如果未安装 Management Studio，请运行安装程序并安装客户端工具。安装 SQL Server Express 时并不会安装 Management Studio。请从 Microsoft.com 下载 Management Studio Express。SQL Server 联机丛书中介绍了基于策略的管理功能。

打开 SQL Server Management Studio

  1. 在“开始”菜单上，指向“所有程序”，再指向 Microsoft SQL Server 2008 R2，然后单击 SQL Server Management Studio。
配置基于策略的管理

  1. 在 Management Studio 中，连接到数据库引擎实例，展开“管理”，然后展开“策略管理”。

  2. 从以下三个方面配置基于策略的管理

    • 外围应用配置器

    • Analysis Services 的外围应用配置器

    • Reporting Services 的外围应用配置器

    不应打开默认情况下处于关闭状态的外围应用配置器功能，除非需要它们处理特定业务。

建议的设置：

  • 数据库引擎的建议设置

    将外围应用配置器方面的所有属性都设置为 false。

  • Analysis Services 的建议设置

    将 Analysis Services 方面的外围应用配置器的所有属性都设置为 false。

  • Reporting Services 的建议设置

    使用 Reporting Services 的外围应用配置器禁用所有不需要的 Reporting Services 功能。

请参阅

其他资源

如何启用或禁用服务器网络协议（SQL Server 配置管理器）
如何启用或禁用服务器网络协议 (SQL Server PowerShell)
了解外围应用配置器

© 2010 Microsoft Corporation。保留所有权利。


新 SharePoint 场配置

新 SharePoint 场配置 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

当您在 SQL Server 安装程序中为 SQL Server PowerPivot for SharePoint 安装角色选择“新服务器”选项时，将出现“新场配置”页。

若要配置新服务器场，您必须具有之前安装的但尚未配置的 SharePoint 服务器。服务器必须为 Microsoft SharePoint 2010。

使用此页可以提供安装程序用于初始化 SharePoint 产品和技术配置程序 (psconfig.exe) 的信息。安装程序将在后台运行此配置程序作为安装过程的一部分。SharePoint 服务器将配置如下：

  • 当您选择 SQL Server PowerPivot for SharePoint 安装角色时，将使用随 Analysis Services 安装的数据库引擎的实例创建一个配置数据库。数据库引擎实例将安装为 PowerPivot 命名实例。

  • 将使用默认值创建一个 Web 应用程序和根网站集。

  • 将安装和配置 Analysis Services 服务。将创建和配置默认的 PowerPivot 服务应用程序和数据库，并将其与默认 SharePoint Web 应用程序关联。

  • PowerPivot 解决方案包将部署到服务器场和默认 Web 应用程序中。将为网站集激活 Analysis Services 功能集成，并创建一个 PowerPivot 库。

选项

指定服务器场帐户的凭据。

指定将用于运行 SharePoint 管理中心服务和访问配置数据库的域用户帐户和密码。必须按如下格式指定帐户：域\用户名。

指定场安全设置。

输入管理员在向场添加新的 SharePoint 应用程序服务器或 Web 前端服务器时必须提供的通行短语。

配置 SharePoint 管理中心 Web 应用程序

管理中心是用于管理场的 Web 应用程序。安装程序将在当前计算机上创建此应用程序。对于管理中心的访问是通过您指定的端口号进行的。

请参阅

参考

功能选择
新 SharePoint 场配置
安装角色

其他资源

安装（Analysis Services SharePoint 集成）
硬件和软件要求
如何在新的独立 SharePoint 服务器上安装 Analysis Services


卸载后

卸载后
SQL Server 安装程序的用户界面参考 >

使用“卸载后”页可以验证操作是否已成功完成。

选项

© 2010 Microsoft Corporation。保留所有权利。


准备映像进度

准备映像进度 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“准备映像进度”页可以监视 SQL Server 映像准备安装程序的状态。在此步骤完成时，此页将列出在此过程中准备的每个 SQL Server 功能的状态。

请参阅

概念

如何查看和读取 SQL Server 安装程序日志文件

© 2010 Microsoft Corporation。保留所有权利。


准备映像规则

准备映像规则
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会验证您的计算机配置。下表描述了系统配置检查器的检查参数和妨碍性问题的解决办法。

检查项 | 说明 | 用户操作
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级
MediaPathLength | 检查 SQL Server 安装介质是否过长。 | 确保 SQL Server 安装介质不过长
OsVersionCheck | 检查计算机是否满足最低操作系统版本要求。 | 操作系统必须满足此产品的最低要求。有关详细信息，请参阅 Hardware and Software Requirements for Installing SQL Server 2008 R2（安装 SQL Server 2008 R2 的硬件和软件要求）。
RebootRequiredCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 需要计算机重新启动。安装 SQL Server 之前，必须重新启动计算机。
ThreadHasAdminPrivilegeCheck | 检查运行 SQL Server 安装程序的帐户是否具有计算机的管理权限。 | 请确保运行 SQL Server 安装程序的帐户具有计算机的管理权限。
WmiServiceStateCheck | 检查是否已在计算机上启动并正在运行 WMI 服务。 | 必须正在运行 WMI 服务。
Bids2005InstalledCheck | 检查是否存在 BI Development Studio 的先前版本。 | 在安装 SQL Server 2008 R2 之前，必须先升级至 Visual Studio 2008 SP1。
ConfiguredDownlevelFeaturesCheck | 检查是否安装了不支持 SysPrep 的任何 SQL Server 版本。 |
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 R2 安装在域控制器上。 | 确保此计算机不是域控制器。
FacetWOW64PlatformCheck | 确定此操作系统平台是否支持 SQL Server 安装程序。 | 这将阻止在 64 位平台上进行任何不受支持的安装。对于 SysPrep，不支持 WOW 安装。
FusionRebootCheck | 检查是否由于断开的合成 ATL 而必须进行计算机重新启动。挂起重新启动会导致 SQL Server 安装程序失败。 | 需要计算机重新启动。在安装 SQL Server 之前，必须重新启动计算机。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 R2 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 R2 安装到其他计算机上。
SSMS_IsInternetConnected | 检查计算机是否已连接到 Internet。基于 .NET Framework 技术的 SQL Server 管理工具必须在启动时检查证书吊销列表。 | 请确保计算机已连接到 Internet。
Sql2005SsmsExpressFacet | 检查是否安装了 SQL Server 2005 Express Edition 工具。 |
Unconfigured_AsFeatureStateCheck | 检查 SQL Server SSAS 功能是否处于未配置状态。 |
VSShellInstalledRule | 检查是否存在 Visual Studio 2008 的先前版本。 | 在安装 SQL Server 2008 R2 之前，必须先升级至 Visual Studio 2008 SP1。
BlockCrossLanguageInstall | 检查安装语言是否与现有 SQL Server 功能的语言相同。 | 必须使用与现有 SQL Server 实例相同的语言版本来升级 SQL Server。
BlockMixedArchitectureInstall | 检查要安装的功能是否与指定实例具有相同的 CPU 体系结构。 | 安装或升级时所使用的 SQL Server 安装介质必须与要修改的 SQL Server 实例具有相同的体系结构。
FAT32FileSystemCheck | 检查指定的驱动器是否为 FAT32 文件系统卷。支持但建议不要在 FAT32 文件系统上进行安装，因为它没有 NTFS 文件系统安全。 | 确保您指定用于安装 SQL Server 的驱动器不是 FAT32 文件系统。
Unconfigured_RsFeatureStateCheck | 检查 Reporting Services 功能是否处于未配置状态。 |
Unconfigured_SqlFeatureStateCheck | 检查 SQL Server 数据库引擎 功能是否处于未配置状态。 |


准备映像类型

准备映像类型
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“准备映像类型”页可以指定是安装 SQL Server 2008 R2 的新实例还是向现有实例中添加功能。

选项

选择指示您所做选择的单选按钮：

  • 准备 SQL Server 2008 R2 的新实例

  • 向 SQL Server 2008 R2 的现有已准备实例中添加功能

    如果选择与向现有实例中添加功能相对应的选项，则使用下拉列表选择要更新的 SQL Server 已准备实例。

    注意：
    您可以向 SQL Server 的已准备映像添加 SQL Server SysPrep 支持的功能（数据库引擎和 Reporting Services）。只有在已准备实例完成后，才能添加 SQL Server SysPrep 不支持的其他功能。


产品密钥

产品密钥
SQL Server 安装程序的用户界面参考 >

使用“产品密钥”页可以验证 SQL Server 的实例或者指定安装哪个免费版本的 SQL Server。

选项

若要指定 SQL Server 的免费版本，请选择与免费安装相对应的单选按钮，然后使用下拉框来确定要安装的版本。

若要验证 SQL Server 的付费安装，请选择与“产品密钥”相对应的单选按钮，然后在提供的空间中提供密钥。

对于故障转移群集安装，请对所有故障转移群集节点使用相同的产品密钥。如果产品密钥来自另一个版本的 SQL Server，将发生错误。


进度(卸载)

进度(卸载) |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“进度(卸载)”页可以监视安装进度。

请参阅

概念

如何查看和读取 SQL Server 安装程序日志文件

© 2010 Microsoft Corporation。保留所有权利。


已准备好完成映像

已准备好完成映像
SQL Server 安装程序的用户界面参考 >

“已准备好完成映像”页提供应用于已准备实例配置的配置设置的摘要。

选项

此页上有下列选项：

  • 若要继续安装，请单击“安装”。

  • 若要更改安装设置，请单击“上一步”。

  • 若要退出安装程序，请单击“取消”。


准备安装

准备安装 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

“准备安装”页提供了 SQL Server 安装程序要安装或更改的功能的摘要。

选项

此页上有下列选项：

  • 若要继续安装，请单击“安装”。

  • 若要更改安装设置，请单击“上一步”。

  • 若要退出安装程序，请单击“取消”。

请参阅

概念

如何查看和读取 SQL Server 安装程序日志文件

© 2010 Microsoft Corporation。保留所有权利。


已可以准备映像

已可以准备映像
SQL Server 安装程序的用户界面参考 >

“已可以准备映像”页提供 SQL Server 安装程序准备的功能的摘要。

选项

此页上有下列选项：

  • 若要继续安装，请单击“安装”。

  • 若要更改安装设置，请单击“上一步”。

  • 若要退出安装程序，请单击“取消”。


准备修复

准备修复 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

“准备修复”页提供 SQL Server 安装程序执行的修复过程的摘要。

选项

此页上有下列选项：

  • 若要继续安装，请单击“安装”。

  • 若要更改安装设置，请单击“上一步”。

  • 若要退出安装程序，请单击“取消”。

请参阅

概念

如何查看和读取 SQL Server 安装程序日志文件

© 2010 Microsoft Corporation。保留所有权利。


恢复方法

恢复方法
SQL Server 安装程序的用户界面参考 >

进行选择，然后单击“下一步”继续。


删除 SQL Server 故障转移群集节点

删除 SQL Server 故障转移群集节点
SQL Server 安装程序的用户界面参考 >

使用“故障转移群集节点”页可识别要作为 SQL Server 2008 故障转移群集节点删除的计算机。


修复进度

修复进度 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“修复进度”页可以监视 SQL Server 修复的状态。

请参阅

概念

如何查看和读取 SQL Server 安装程序日志文件

© 2010 Microsoft Corporation。保留所有权利。


报表服务器安装选项

报表服务器安装选项 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 Microsoft SQL Server 安装向导中的“报表服务器安装选项”页来指定确定报表服务器实例安装方式的选项。安装选项的可用性取决于是否在安装报表服务器的同时还安装 SQL Server 数据库引擎的本地实例以及是否其他默认值都可用。

如果安装程序由于一条或多条要求未得到满足而无法执行默认的报表服务器配置，那么安装向导只允许选择最小化安装选项；同时，它会复制所需的文件，但要求在安装结束后，使用 Reporting Services 配置工具来配置报表服务器。

在某些情况下，如果安全套接字层 (SSL) 证书安装在计算机上并绑定到一个强通配符，安装程序将使用 HTTPS 前缀创建 Reporting Services URL。有关如何将证书映射到 Reporting Services URL 的详细信息，请参阅 SQL Server 联机丛书中的配置报表服务器用于安全套接字层 (SSL) 连接。

注意：
如果选择默认安装选项之一，则现有的报表服务器数据库文件可能会导致安装失败。当选择默认安装选项时，安装程序将尝试使用默认名称创建报表服务器数据库。如果使用该名称的数据库已经存在，安装程序将失败，您必须回滚安装。若要避免此问题，可在运行安装程序前重命名现有数据库，或选择“安装但不配置服务器”选项，以便在安装完成后指定自定义数据库设置。

选项

安装本机模式默认配置

用报表服务器数据库、服务帐户和 URL 保留的默认值安装报表服务器实例。如果选择此选项，那么当安装程序完成后，报表服务器实例即可使用。安装程序通过使用本地数据库引擎实例来创建报表服务器数据库，并配置报表服务器，使其使用默认值。

仅当报表服务器安装中使用的默认值对您的系统有效时，此选项才可用。建议希望在本地安装所有组件的开发人员和评估软件的用户使用此选项。

若要查看关于安装程序所用默认设置的信息，或者要找出默认配置无法安装的原因，请单击“详细信息”。有关本机模式报表服务器的默认配置的详细信息，请参阅本机模式安装默认配置 (Reporting Services)。

安装 SharePoint 集成模式默认配置

用报表服务器数据库、服务帐户和 URL 保留的默认值安装报表服务器实例。报表服务器数据库是以支持 SharePoint 站点的内容存储和寻址的格式创建的。有关此安装选项的详细信息，请参阅 SharePoint 集成模式默认配置 (Reporting Services)。

在您在 SharePoint 集成模式中安装报表服务器实例后，还有附加的配置步骤来完成与 SharePoint 环境的集成。有关详细信息，请参阅将 Reporting Services 配置为 SharePoint 2010 集成模式。

安装但不配置服务器

安装报表服务器程序文件，创建报表服务器服务帐户，并注册报表服务器 Windows Management Instrumentation (WMI) 提供程序。此安装选项称为“仅文件”安装。如果不希望使用默认配置，则选择此选项。如果无法安装默认配置，或安装的是包括 Reporting Services 的 SQL Server 故障转移群集，这将是唯一可用的选项。有关“仅文件”安装的详细信息，请参阅“仅文件”安装 (Reporting Services)。

安装程序完成后，必须先创建报表服务器数据库并配置报表服务器，服务器才可以使用。若要配置报表服务器并创建数据库，请使用 Reporting Services 配置工具。有关详细信息，请参阅创建报表服务器数据库和配置报表服务器数据库连接。

请参阅

其他资源

如何启动 Reporting Services 配置
如何创建报表服务器数据库（Reporting Services 配置）
安装 Reporting Services 的注意事项
本机模式安装默认配置 (Reporting Services)


Reporting Services 的配置和安装选项

Reporting Services 的配置和安装选项
SQL Server 安装程序的用户界面参考 >

使用 Microsoft SQL Server 安装向导中的“报表服务器配置”页来指定确定报表服务器实例安装方式的选项。安装选项的可用性取决于是否在安装报表服务器的同时还安装 SQL Server 数据库引擎的本地实例以及是否其他默认值都可用。

如果安装程序由于一条或多条要求未得到满足而无法执行默认的报表服务器配置，那么安装向导只允许选择最小化安装选项；同时，它会复制所需的文件，但要求在安装结束后，使用 Reporting Services 配置工具来配置报表服务器。

在某些情况下，如果安全套接字层 (SSL) 证书安装在计算机上并绑定到一个强通配符，安装程序将使用 HTTPS 前缀创建 Reporting Services URL。有关如何将证书映射到 Reporting Services URL 的详细信息，请参阅 SQL Server 联机丛书中的配置报表服务器用于安全套接字层 (SSL) 连接。

注意：
如果选择默认安装选项之一，则现有的报表服务器数据库文件可能会导致安装失败。当选择默认安装选项时，安装程序将尝试使用默认名称创建报表服务器数据库。如果使用该名称的数据库已经存在，安装程序将失败，您必须回滚安装。若要避免此问题，可在运行安装程序前重命名现有数据库，或选择“安装但不配置服务器”选项，以便在安装完成后指定自定义数据库设置。

选项

安装本机模式默认配置

用报表服务器数据库、服务帐户和 URL 保留的默认值安装报表服务器实例。如果选择此选项，那么当安装程序完成后，报表服务器实例即可使用。安装程序通过使用本地数据库引擎实例来创建报表服务器数据库，并配置报表服务器，使其使用默认值。

仅当报表服务器安装中使用的默认值对您的系统有效时，此选项才可用。建议希望在本地安装所有组件的开发人员和评估软件的用户使用此选项。

若要查看关于安装程序所用默认设置的信息，或者要找出默认配置无法安装的原因，请单击“详细信息”。有关本机模式报表服务器的默认配置的详细信息，请参阅本机模式安装默认配置 (Reporting Services)。

安装 SharePoint 集成模式默认配置

用报表服务器数据库、服务帐户和 URL 保留的默认值安装报表服务器实例。报表服务器数据库是以支持 SharePoint 站点的内容存储和寻址的格式创建的。

有关此安装选项的详细信息，请参阅 SharePoint 集成模式默认配置 (Reporting Services)。

安装但不配置服务器

安装报表服务器程序文件，创建报表服务器服务帐户，并注册报表服务器 Windows Management Instrumentation (WMI) 提供程序。此安装选项称为“仅文件”安装。如果不希望使用默认配置，则选择此选项。如果无法安装默认配置，或安装的是包括 Reporting Services 的 SQL Server 故障转移群集，这将是唯一可用的选项。有关“仅文件”安装的详细信息，请参阅“仅文件”安装 (Reporting Services)。

安装程序完成后，必须先创建报表服务器数据库并配置报表服务器，服务器才可以使用。若要配置报表服务器并创建数据库，请使用 Reporting Services 配置工具。有关详细信息，请参阅创建报表服务器数据库和配置报表服务器数据库连接。

安装用于 SharePoint 技术的 Reporting Services 外接程序

若要安装用于 SharePoint 技术的 Reporting Services 外接程序，请在 SQL Server 安装完成后单击 SQL Server 安装介质上 Setup 文件夹中的 rsSharePoint.msi 文件。也可以下载该外接程序。有关详细信息，请参阅用于 Microsoft SharePoint® 技术 2010 的 SQL Server® 2008 R2 11 月 CTP Reporting Services 外接程序。


保留关键字（安装程序）

保留关键字（安装程序）
SQL Server 安装程序的用户界面参考 >

SQL Server 使用保留关键字来定义、操作和添加数据库。保留关键字是 SQL Server 用于分析和理解 Transact-SQL 语句和批处理的 Transact-SQL 语法的组成部分。

SQL Server 实例名不能与保留关键字匹配。请参照下表以确保在 SQL Server 实例名中未使用保留关键字。

ADD | EXCEPT | PERCENT
ALL | EXEC | PLAN
ALTER | EXECUTE | PRECISION
AND | EXISTS | PRIMARY
ANY | EXIT | PRINT
AS | FETCH | PROC
ASC | FILE | PROCEDURE
AUTHORIZATION | FILLFACTOR | PUBLIC
BACKUP | FOR | RAISERROR
BEGIN | FOREIGN | READ
BETWEEN | FREETEXT | READTEXT
BREAK | FREETEXTTABLE | RECONFIGURE
BROWSE | FROM | REFERENCES
BULK | FULL | REPLICATION
BY | FUNCTION | RESTORE
CASCADE | GOTO | RESTRICT
CASE | GRANT | RETURN
CHECK | GROUP | REVOKE
CHECKPOINT | HAVING | RIGHT
CLOSE | HOLDLOCK | ROLLBACK
CLUSTERED | IDENTITY | ROWCOUNT
COALESCE | IDENTITY_INSERT | ROWGUIDCOL
COLLATE | IDENTITYCOL | RULE
COLUMN | IF | SAVE
COMMIT | IN | SCHEMA
COMPUTE | INDEX | SELECT
CONSTRAINT | INNER | SESSION_USER
CONTAINS | INSERT | SET
CONTAINSTABLE | INTERSECT | SETUSER
CONTINUE | INTO | SHUTDOWN
CONVERT | IS | SOME
CREATE | JOIN | STATISTICS
CROSS | KEY | SYSTEM_USER
CURRENT | KILL | TABLE
CURRENT_DATE | LEFT | TEXTSIZE
CURRENT_TIME | LIKE | THEN
CURRENT_TIMESTAMP | LINENO | TO
CURRENT_USER | LOAD | TOP
CURSOR | NATIONAL | TRAN
DATABASE | NOCHECK | TRANSACTION
DBCC | NONCLUSTERED | TRIGGER
DEALLOCATE | NOT | TRUNCATE
DECLARE | NULL | TSEQUAL
DEFAULT | NULLIF | UNION
DELETE | OF | UNIQUE
DENY | OFF | UPDATE
DESC | OFFSETS | UPDATETEXT
DISK | ON | USE
DISTINCT | OPEN | USER
DISTRIBUTED | OPENDATASOURCE | VALUES
DOUBLE | OPENQUERY | VARYING
DROP | OPENROWSET | VIEW
DUMMY | OPENXML | WAITFOR
DUMP | OPTION | WHEN
ELSE | OR | WHERE
END | ORDER | WHILE
ERRLVL | OUTER | WITH
ESCAPE | OVER | WRITETEXT

此外，ISO 标准定义了保留关键字的列表。不要使用 ISO 保留关键字作为对象名和标识符。ODBC 保留关键字列表（如下表所示）与 ISO 保留关键字列表相同。

注意：
ISO 保留关键字列表有时会比 SQL Server 具有更多的限制，有时则更少。例如，ISO 保留关键字列表包含 INT，而 SQL Server 不将 INT 视为保留关键字。

ODBC 保留关键字

保留了下列关键字用于 ODBC 函数调用。这些单词不限定最小 SQL 语法。但是，为确保与支持核心 SQL 语法的驱动程序兼容，请避免在 SQL Server 实例名中使用这些关键字。

ABSOLUTE | EXEC | OVERLAPS
ACTION | EXECUTE | PAD
ADA | EXISTS | PARTIAL
ADD | EXTERNAL | PASCAL
ALL | EXTRACT | POSITION
ALLOCATE | FALSE | PRECISION
ALTER | FETCH | PREPARE
AND | FIRST | PRESERVE
ANY | FLOAT | PRIMARY
ARE | FOR | PRIOR
AS | FOREIGN | PRIVILEGES
ASC | FORTRAN | PROCEDURE
ASSERTION | FOUND | PUBLIC
AT | FROM | READ
AUTHORIZATION | FULL | REAL
AVG | GET | REFERENCES
BEGIN | GLOBAL | RELATIVE
BETWEEN | GO | RESTRICT
BIT | GOTO | REVOKE
BIT_LENGTH | GRANT | RIGHT
BOTH | GROUP | ROLLBACK
BY | HAVING | ROWS
CASCADE | HOUR | SCHEMA
CASCADED | IDENTITY | SCROLL
CASE | IMMEDIATE | SECOND
CAST | IN | SECTION
CATALOG | INCLUDE | SELECT
CHAR | INDEX | SESSION
CHAR_LENGTH | INDICATOR | SESSION_USER
CHARACTER | INITIALLY | SET
CHARACTER_LENGTH | INNER | SIZE
CHECK | INPUT | SMALLINT
CLOSE | INSENSITIVE | SOME
COALESCE | INSERT | SPACE
COLLATE | INT | SQL
COLLATION | INTEGER | SQLCA
COLUMN | INTERSECT | SQLCODE
COMMIT | INTERVAL | SQLERROR
CONNECT | INTO | SQLSTATE
CONNECTION | IS | SQLWARNING
CONSTRAINT | ISOLATION | SUBSTRING
CONSTRAINTS | JOIN | SUM
CONTINUE | KEY | SYSTEM_USER
CONVERT | LANGUAGE | TABLE
CORRESPONDING | LAST | TEMPORARY
COUNT | LEADING | THEN
CREATE | LEFT | TIME
CROSS | LEVEL | TIMESTAMP
CURRENT | LIKE | TIMEZONE_HOUR
CURRENT_DATE | LOCAL | TIMEZONE_MINUTE
CURRENT_TIME | LOWER | TO
CURRENT_TIMESTAMP | MATCH | TRAILING
CURRENT_USER | MAX | TRANSACTION
CURSOR | MIN | TRANSLATE
DATE | MINUTE | TRANSLATION
DAY | MODULE | TRIM
DEALLOCATE | MONTH | TRUE
DEC | NAMES | UNION
DECIMAL | NATIONAL | UNIQUE
DECLARE | NATURAL | UNKNOWN
DEFAULT | NCHAR | UPDATE
DEFERRABLE | NEXT | UPPER
DEFERRED | NO | USAGE
DELETE | NONE | USER
DESC | NOT | USING
DESCRIBE | NULL | VALUE
DESCRIPTOR | NULLIF | VALUES
DIAGNOSTICS | NUMERIC | VARCHAR
DISCONNECT | OCTET_LENGTH | VARYING
DISTINCT | OF | VIEW
DOMAIN | ON | WHEN
DOUBLE | ONLY | WHENEVER
DROP | OPEN | WHERE
ELSE | OPTION | WITH
END | OR | WORK
END-EXEC | ORDER | WRITE
ESCAPE | OUTER | YEAR
EXCEPT | OUTPUT | ZONE
EXCEPTION |  |


选择已准备实例

选择已准备实例
SQL Server 安装程序的用户界面参考 >

使用“选择已准备实例”页可以指定要完成的已准备实例。

选项

“选择实例 ID”框列出您可以完成的已准备实例。选择要完成的已准备实例。

选择实例 ID

该列表包括在正在运行 SQL Server 安装程序的计算机上您可以完成的所有已准备实例。选择要完成的已准备实例。

已安装的实例

这包括已安装、已准备和已完成实例。


服务器配置 - 排序规则

服务器配置 - 排序规则 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

可以在 SQL Server 安装向导的“服务器配置 – 排序规则”页上修改数据库引擎和 Analysis Services 排序时所用的排序规则设置。选择相应选项以匹配其他 SQL Server 安装或者其他计算机的排序规则设置。

选项

为 SQL Server 和 Analysis Services 进行自定义

SQL Server 提供了两组排序规则：Windows 排序规则和 SQL Server 排序规则。您可以为数据库引擎和 Analysis Services 指定不同的排序规则设置，也可以为它们指定相同的排序规则。

默认情况下，对于美国英语系统区域设置，选择的是 SQL Server 排序规则。SQL Server 本地化版本的默认排序规则由您计算机的 Windows 系统区域设置决定。有关详细信息，请参阅使用 SQL Server 排序规则。

仅当此 SQL Server 安装的排序规则设置必须与另一 SQL Server 实例所用的排序规则设置相匹配，或者必须与另一台计算机的 Windows 系统区域设置相匹配时，才应更改默认设置。

注意：Analysis Services仅使用 Windows 排序规则。如果计划安装 Analysis Services，请在 SQL Server 安装期间，选择 Windows 排序规则，以确保 SQL Server 数据库引擎和 Analysis Services 之间结果的一致性。

有关详细信息，请参阅 Collation Settings in Setup（安装程序中的排序规则设置）。

最佳做法

有关 SQL Server 安装程序使用的 Windows 系统区域设置以及相应的默认排序规则的表的详细信息，请参阅 Collation Settings in Setup（安装程序中的排序规则设置）。

如果可能，请为您的组织使用一个排序规则。这样就不必为每个数据库、列、表达式或标识符显式指定排序规则。如果必须使用多个排序规则和代码页设置，请对查询进行编码，以考虑排序规则优先顺序规则。有关详细信息，请参阅联机丛书主题 Collation Precedence (Transact-SQL)（排序规则优先顺序 (Transact-SQL)）。

为 SQL Server 选择排序规则时，请考虑下列建议：

  • 如果基于二进制码位的排序顺序可接受，请选择 BINARY2 排序规则。

  • 选择 Windows 排序规则以便在各数据类型之间进行一致的比较。

  • 使用新的 100 级排序规则以便获得更好的语言排序支持。有关详细信息，请参阅 Collation and Unicode Support（排序规则和 Unicode 支持）。

  • 如果您计划将数据库迁移到 SQL Server 的升级实例，则选择与您的数据库的现有排序规则匹配的排序规则。

请参阅

其他资源

排序规则选项和 Unicode 支持
安装程序中的排序规则设置

© 2010 Microsoft Corporation。保留所有权利。


服务器配置 - 服务帐户

服务器配置 - 服务帐户 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“服务器配置”页可以为 SQL Server 服务分配登录帐户。此页上配置的实际服务取决于您选择安装的功能。

选项

您可以为所有的 SQL Server 服务分配相同的登录帐户，也可以单独配置各个服务帐户。还可以指定服务是自动启动、手动启动还是禁用。Microsoft 建议对各服务帐户进行单独配置，以便为每项服务提供最低特权，即向 SQL Server 服务授予它们完成各自任务所需的最低权限。有关详细信息，请参阅 Setting Up Windows Service Accounts（设置 Windows 服务帐户）。

单独配置 SQL Server 服务帐户(建议)

使用网格为每项 SQL Server 服务设置一个登录用户名和密码并设置相应服务的启动类型。您可以对 SQL Server 服务使用内置系统帐户、本地帐户、本地组、域组或域用户帐户。

选择下列任一服务以自定义其设置。

选择此服务 为其配置身份验证设置的主体

SQL Server 代理

执行作业、监视 SQL Server 并允许管理任务自动完成的服务。

此服务没有默认登录帐户。

默认的启动类型为“手动”。

SQL Server

SQL Server 数据库引擎。

此服务没有默认登录帐户。

默认的启动类型为“自动”。

SQL Server Browser

SQL Server Browser 是向客户端计算机提供 SQL Server 连接信息的名称解析服务。多个 SQL Server 和 Integration Services 实例共享此服务。

默认的登录帐户为 NT Authority\Local service 且在 SQL Server 安装期间无法更改。可以在安装完成后更改该帐户。

如果未在安装期间指定启动类型，可以根据以下内容来确定：

  • SQL Server Browser 设置为“自动”并在下面描述的安装方案中运行：

    • SQL Server 故障转移群集实例

    • 启用了 TCP 或 NP 的 SQL Server 命名实例

    • 分析服务器的命名实例，未进行群集

    • 进行 SQL Server 2000 升级并且计算机上存在 SQL Server 2000 的现有实例

  • 如果上述方案均不符合并且已经安装 SQL Server Browser，将保持 SQL Server Browser 的当前状态。

  • 如果在安装前没有现有的 SQL Server 2005 或 SQL Server 2008 实例，则启动类型会设置为“已禁用”且被停止。

Analysis Services

Analysis Services。

此服务没有默认登录帐户。

默认的启动类型为“自动”。

对于 SharePoint 集成模式，您必须指定一个 Windows 域用户帐户。您指定的帐户用于 Analysis Services 服务。您为当前实例指定的帐户还必须用于您以后添加到同一场的任何附加 Analysis Services 实例。有关详细信息，请参阅 How to: Install PowerPivot for SharePoint on a New SharePoint Server（如何在新的 SharePoint 服务器上安装 PowerPivot for SharePoint）。

Reporting Services

Reporting Services。服务帐户用于配置报表服务器数据库连接。如果要使用默认的身份验证设置，请选择内置的网络服务。如果指定域用户帐户，并且要在报表服务器上使用 Windows 身份验证，请确保为该帐户注册一个服务主体名称 (SPN)。有关详细信息，请参阅 How to: Configure Windows Authentication in Reporting Services（如何在 Reporting Services 中配置 Windows 身份验证）。

重要提示：
Microsoft 建议，如果有具有较低特权的帐户可供使用，则不要对 SQL Server 或 SQL Server Agent 服务使用 Network Service 帐户，因为 Network Service 是可共享帐户。只有能够确保计算机上未安装使用 Network Service 帐户的其他服务时，该 Network Service 帐户才适合用作 SQL Server 服务帐户。非 Windows 管理员的 Local User 帐户或 Domain User 帐户更适用于 SQL Server 服务。

此服务没有默认登录帐户。

默认的启动类型为“自动”。

Integration Services

Integration Services 是一组图形工具和可编程对象，用于移动、复制和转换数据。

此服务的默认登录帐户为 NT Authority\Network Service。

默认的启动类型为“自动”。

SQL Server 全文筛选器后台程序启动器

创建 fdhost.exe 进程的服务。需要使用此服务来承载为全文索引处理文本数据的断字符和筛选器。

提供运行 FDHOST 启动器服务的帐户。强烈建议您使用低特权帐户。此帐户应该不同于用于 SQL Server 服务的帐户。在 Windows Vista 和 Windows Server 2008 上，FDHOST 启动器服务帐户默认为 LOCAL SERVICE。

出于安全起见，在早于 Windows Vista 和 Windows Server 2008 的 Windows 版本上，建议您使用专门创建的 LOCAL USER 作为 FDHOST 启动器服务帐户。使用 LOCAL SYSTEM、LOCAL SERVICE 或 NETWORK SERVICE 可能会在无意中为服务提供提升的特权，从而降低 SQL Server 安装的安全性。

除非服务帐户无效或您未指定服务帐户（在 Windows Server 2003 或 Windows XP 上），否则 FDHOST 启动器服务会自动启动。

请参阅

其他资源

安装 SQL Server 的安全注意事项

© 2010 Microsoft Corporation。保留所有权利。


SQL Server 故障转移群集向导 - 完成

SQL Server 故障转移群集向导 - 完成 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会使用以下规则验证您的计算机配置。

检查项 | 说明 | 用户操作
SSMS_IsInternetConnected | 确保计算机已连接到 Internet。如果启动某个 .NET Framework 应用程序（如 Microsoft Management Studio），则在 .NET Framework 安全检查功能验证证书时可能会稍有延迟。 | 请确保计算机已连接到 Internet。
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致。 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级。
BlockMixedArchitectureUpgrade | 检查尝试升级的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 安装或升级时所使用的 SQL Server 安装介质必须与要修改的 SQL Server 实例具有相同的体系结构。
Cluster_IsOnlineIfClustered | 确认计算机未群集化，或者计算机已群集化且群集服务已联机。 | 要么计算机未群集化，要么群集已启动且联机。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 R2 安装在域控制器上。 | 确保此计算机不是域控制器。有关详细信息，请参阅 Security Considerations for a SQL Server Installation（安装 SQL Server 的安全注意事项）。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是某些 SQL Server 2008 R2 版本的必备组件。 | 对于 SQL Server 2008 R2 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定此操作系统平台是否支持 SQL Server 安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。有关详细信息，请参阅 Hardware and Software Requirements for Installing SQL Server 2008 R2（安装 SQL Server 2008 R2 的硬件和软件要求）。
FusionRebootCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 在安装 SQL Server 之前，必须重新启动计算机。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 R2 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 R2 安装到其他计算机上。

请参阅

参考

安装程序支持规则

© 2010 Microsoft Corporation。保留所有权利。


SQL Server 故障转移群集向导 - 安装

SQL Server 故障转移群集向导 - 安装 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会使用以下规则验证您的计算机配置。

检查项 | 说明 | 用户操作
SSMS_IsInternetConnected | 确保计算机已连接到 Internet。如果启动某个 .NET Framework 应用程序（如 Microsoft Management Studio），则在 .NET Framework 安全检查功能验证证书时可能会稍有延迟。 | 请确保计算机已连接到 Internet。
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致。 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级。
BlockMixedArchitectureUpgrade | 检查尝试升级的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 安装或升级时所使用的 SQL Server 安装介质必须与要修改的 SQL Server 实例具有相同的体系结构。
Cluster_IsOnlineIfClustered | 确认计算机未群集化，或者计算机已群集化且群集服务已联机。 | 要么计算机未群集化，要么群集已启动且联机。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 R2 安装在域控制器上。 | 确保此计算机不是域控制器。有关详细信息，请参阅 Security Considerations for a SQL Server Installation（安装 SQL Server 的安全注意事项）。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是某些 SQL Server 2008 R2 版本的必备组件。 | 对于 SQL Server 2008 R2 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定此操作系统平台是否支持 SQL Server 安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。有关详细信息，请参阅 Hardware and Software Requirements for Installing SQL Server 2008 R2（安装 SQL Server 2008 R2 的硬件和软件要求）。
FusionRebootCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 在安装 SQL Server 之前，必须重新启动计算机。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 R2 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 R2 安装到其他计算机上。

请参阅

参考

安装程序支持规则

© 2010 Microsoft Corporation。保留所有权利。


SQL Server 故障转移群集向导 – 准备

SQL Server 故障转移群集向导 – 准备 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会使用以下规则验证您的计算机配置。

检查项 | 说明 | 用户操作
SSMS_IsInternetConnected | 确保计算机已连接到 Internet。如果启动某个 .NET Framework 应用程序（如 Microsoft Management Studio），则在 .NET Framework 安全检查功能验证证书时可能会稍有延迟。 | 请确保计算机已连接到 Internet。
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致。 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级。
BlockMixedArchitectureUpgrade | 检查尝试升级的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 安装或升级时所使用的 SQL Server 安装介质必须与要修改的 SQL Server 实例具有相同的体系结构。
Cluster_IsOnlineIfClustered | 确认计算机未群集化，或者计算机已群集化且群集服务已联机。 | 要么计算机未群集化，要么群集已启动且联机。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 R2 安装在域控制器上。 | 确保此计算机不是域控制器。有关详细信息，请参阅 Security Considerations for a SQL Server Installation（安装 SQL Server 的安全注意事项）。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是某些 SQL Server 2008 R2 版本的必备组件。 | 对于 SQL Server 2008 R2 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定此操作系统平台是否支持 SQL Server 安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。有关详细信息，请参阅 Hardware and Software Requirements for Installing SQL Server 2008 R2（安装 SQL Server 2008 R2 的硬件和软件要求）。
FusionRebootCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 在安装 SQL Server 之前，必须重新启动计算机。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 R2 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 安装到其他计算机上。

请参阅

参考

安装程序支持规则

© 2010 Microsoft Corporation。保留所有权利。


摘要（升级）

摘要（升级）
SQL Server 安装程序的用户界面参考 >

使用“摘要”页可以查看为该升级指定的选项。


安装程序支持规则

安装程序支持规则
SQL Server 安装程序的用户界面参考 >

SQL Server 安装向导的“系统配置检查”页显示了系统验证工具的进度。系统配置检查例程会扫描将安装 SQL Server 的计算机，以检查是否存在可能阻止安装程序运行的情况。

选项

仅当所有检查结果都成功，或失败的检查项不会妨碍安装时，“下一步”按钮才可用。

使用“显示详细信息”按钮可显示规则和扫描结果的摘要。扫描结果右侧的“状态”列显示了每一项的状态。单击某个项的状态可查看其详细信息。

下表描述了 SCC 的检查参数、要求和妨碍性问题的解决办法。

检查项 | 说明 | 用户操作
RebootRequiredCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 需要计算机重新启动。在安装 SQL Server 之前，必须重新启动计算机。
OsVersionCheck | 检查计算机是否满足最低操作系统版本要求。 | 确保操作系统版本满足此产品的最低要求。有关详细信息，请参阅 Hardware and Software Requirements for Installing SQL Server 2008 R2（安装 SQL Server 2008 R2 的硬件和软件要求）。
ThreadHasAdminPrivilegeCheck | 检查运行 SQL Server 安装程序的帐户是否具有计算机的管理员权限。 | 请确保运行 SQL Server 安装程序的帐户具有计算机的管理权限。
WmiServiceStateCheck | 检查是否已在计算机上启动并正在运行 WMI 服务。 | 请确保 Windows Management Instrumentation (WMI) 服务正在运行。
SSMS_IsInternetConnected | 检查计算机是否已连接到 Internet。基于 .NET Framework 技术的 SQL Server 管理工具必须在启动时检查证书吊销列表。 | 请确保计算机已连接到 Internet。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 R2 安装在域控制器上。 | 确保此计算机不是域控制器。有关详细信息，请参阅 Security Considerations for a SQL Server Installation（安装 SQL Server 的安全注意事项）。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是 SQL Server 2008 R2 Express with Advanced Services 的必备组件。 | 对于 Microsoft SQL Server 2008 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定操作系统平台是否支持该安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。有关详细信息，请参阅 Hardware and Software Requirements for Installing SQL Server 2008 R2（安装 SQL Server 2008 R2 的硬件和软件要求）。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。 | 删除 SQL Server 7.0 或将 SQL Server 2008 R2 安装到其他计算机上。

其他规则主题

有关方案特定的安装规则，请参阅以下主题：

  • 安装规则

  • 升级规则检查

  • 版本升级规则

  • 卸载规则

  • 准备映像规则

  • 完成映像规则


卸载规则

卸载规则
SQL Server 安装程序的用户界面参考 >

“卸载规则”页将运行一组规则来确保可以成功完成安装操作。

选项

下表描述了系统配置检查器的检查参数、要求和妨碍性问题的解决办法：

检查项 | 说明 | 用户操作
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致。 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级。
OsVersionCheck | 检查计算机是否满足最低操作系统版本要求。 | 确保操作系统版本满足此产品的最低要求。
RebootRequiredCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 需要计算机重新启动。安装 SQL Server 之前，必须重新启动计算机。
ThreadHasAdminPrivilegeCheck | 检查运行 SQL Server 安装程序的帐户是否具有计算机的管理权限。 | 请确保运行 SQL Server 安装程序的帐户具有计算机的管理权限。
WmiServiceStateCheck | 检查是否已在计算机上启动并正在运行 WMI 服务。 | 请确保 WMI 服务正在运行。
BlockMismatchedArchitectureUninstall | 检查尝试删除的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 安装程序必须与要卸载的 SQL Server 实例具有相同的体系结构。

其他规则主题

有关详细信息，请参阅下列主题：

  • 安装程序支持规则.


升级进度

升级进度 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“升级进度”页可以监视 SQL Server 升级的状态。

请参阅

概念

如何查看和读取 SQL Server 安装程序日志文件

© 2010 Microsoft Corporation。保留所有权利。


升级规则检查

升级规则检查 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会使用以下规则验证您的计算机配置。

检查项 | 说明 | 用户操作
SSMS_IsInternetConnected | 确保计算机已连接到 Internet。如果启动某个 .NET Framework 应用程序（如 Microsoft Management Studio），则在 .NET Framework 安全检查功能验证证书时可能会稍有延迟。 | 请确保计算机已连接到 Internet。
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致。 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级。
BlockMixedArchitectureUpgrade | 检查尝试升级的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 安装或升级时所使用的 SQL Server 安装介质必须与要修改的 SQL Server 实例具有相同的体系结构。
Cluster_IsOnlineIfClustered | 确认计算机未群集化，或者计算机已群集化且群集服务已联机。 | 要么计算机未群集化，要么群集已启动且联机。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 R2 安装在域控制器上。 | 确保此计算机不是域控制器。有关详细信息，请参阅 Security Considerations for a SQL Server Installation（安装 SQL Server 的安全注意事项）。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是某些 SQL Server 2008 R2 版本的必备组件。 | 对于 SQL Server 2008 R2 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定此操作系统平台是否支持 SQL Server 安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。有关详细信息，请参阅 Hardware and Software Requirements for Installing SQL Server 2008 R2（安装 SQL Server 2008 R2 的硬件和软件要求）。
FusionRebootCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 需要计算机重新启动。安装 SQL Server 之前，必须重新启动计算机。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 R2 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 R2 安装到其他计算机上。
UCPEditionDowngradeCheck | 确定此版本的 SQL Server 是否支持 SQL Server UCP。 | SQL Server 2008 R2 Datacenter、Enterprise、Developer 或 Enterprise Evaluation 均支持 SQL Server UCP。

请参阅

参考

安装程序支持规则

© 2010 Microsoft Corporation。保留所有权利。


确认卸载选项

确认卸载选项
SQL Server 安装程序的用户界面参考 >

确认您的选择，然后单击“下一步”继续。


在安装程序完成联机丛书的安装之前，您无法搜索所需的主题

在安装程序完成联机丛书的安装之前，您无法搜索所需的主题

安装完成之后，您可以通过以下方式查看 SQL Server 的文档：单击“帮助”；在对话框或界面元素中按 F1 键；或者从“开始”菜单中依次指向“所有程序”、Microsoft SQL Server、“文档和教程”，然后单击“SQL Server 联机丛书”。