SQL Server 安装概述

SQL Server 安装程序帮助
SQL Server 安装概述 |
 | 请参阅

SQL Server 安装向导基于 Windows Installer。 它提供了一个功能树以用来安装所有 SQL Server 组件：

  • 数据库引擎

  • Analysis Services

  • Reporting Services

  • Integration Services

  • 管理工具

  • 文档和示例

注意： SQL Server 有 32 位和 64 位两种版本可用。 有关详细信息，请参阅计划 SQL Server 安装。

无论使用 SQL Server 安装向导还是命令提示符安装 SQL Server，安装过程都包括下列步骤：

本节内容

计划 SQL Server 安装

说明如何为安装 SQL Server 而准备计算机：

  • 查看硬件和软件要求。

  • 查看系统配置检查器的要求和妨碍性问题。

  • 查看 SQL Server 安装的安全注意事项。

安装 SQL Server 2008

说明 SQL Server 的安装选项：

  • 使用安装向导进行安装。

  • 通过命令提示符进行安装。

配置 SQL Server 2008

说明如何使用图形化和命令提示符实用工具配置 SQL Server。

相关章节

安装 SQL Server 数据库引擎的注意事项

说明如何安装和配置 SQL Server 数据库引擎。

安装 Analysis Services 时的注意事项

说明如何安装和配置 SQL Server Analysis Services。

安装 Reporting Services 的注意事项

说明如何安装和配置 SQL Server Reporting Services。

安装 Integration Services 的注意事项

说明如何安装和配置 SQL Server Integration Services。

安装 SQL Server 复制的注意事项

说明如何安装和配置 SQL Server 复制。

安装 SQL Server 管理工具的注意事项

说明如何安装和配置 SQL Server 管理工具。

安装 SQL Server 示例和示例数据库的注意事项

说明如何安装和配置 SQL Server 示例。

请参阅

任务

如何安装 SQL Server 2008（安装程序）

© 2008 Microsoft Corporation。保留所有权利。


SQL Server 安装中的新增功能

SQL Server 安装中的新增功能 |
 | 请参阅
SQL Server 安装概述 >

SQL Server 2008 针对以下方案具有新的安装程序体系结构：安装、升级、维护、故障转移群集和命令提示符安装。

请参阅

任务

如何安装 SQL Server 2008（安装程序）
如何升级到 SQL Server 2008（安装程序）
如何创建新的 SQL Server 故障转移群集（安装程序）

概念

计划 SQL Server 安装
使用升级顾问来准备升级
如何从命令提示符安装 SQL Server 2008


SQL Server 2008 安装快速入门

SQL Server 2008 安装快速入门 |
 | 请参阅
SQL Server 安装概述 >

SQL Server 安装向导提供了一个用于安装以下所有 SQL Server 组件的功能树：

  • 数据库引擎

  • Analysis Services

  • Reporting Services

  • Integration Services

  • 复制

  • 管理工具

  • 连接组件

  • 示例数据库、示例和 SQL Server 联机丛书

以下附加主题介绍了 SQL Server 2008 的其他安装方法：

  • 若要从命令提示符安装 SQL Server，请参阅如何从命令提示符安装 SQL Server 2008。

  • 若要安装故障转移群集，请参阅如何创建新的 SQL Server 故障转移群集（安装程序）。

  • 若要将 SQL Server 的现有实例升级到 SQL Server 2008，请参阅如何升级到 SQL Server 2008（安装程序）。

必备条件

安装 SQL Server 前，请查阅计划 SQL Server 安装中的主题。

注意：
对于本地安装，必须以管理员身份运行安装程序。如果从远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。

过程

安装 SQL Server 2008

  1. 插入 SQL Server 安装媒体，然后双击根文件夹中的 setup.exe。若要从网络共享进行安装，请导航到共享中的根文件夹，然后双击 setup.exe。

  2. 如果出现 Microsoft .NET Framework 2.0 版 安装对话框，则选中相应的复选框以接受 .NET Framework 2.0 许可协议。单击“下一步”。若要退出 SQL Server 2008 安装过程，请单击“取消”。当 .NET Framework 2.0 的安装完成后，请单击“完成”。

  3. Windows Installer 4.5 也是必需的，并且可能由安装向导进行安装。如果系统提示您重新启动计算机，则重新启动计算机，然后再次启动 SQL Server 2008 setup.exe。

  4. 必备组件安装完成后，安装向导会立即启动 SQL Server 安装中心。若要创建 SQL Server 2008 的全新安装，请单击“全新安装或向现有安装添加功能”。

  5. 系统配置检查器将在您的计算机上运行发现操作。若要继续，请单击“确定”。此时，系统已经为您的安装创建了安装日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 安装日志文件。

  6. 在“产品密钥”页上单击相应的单选按钮，以指示您是安装免费版本的 SQL Server，还是您拥有该产品生产版本的 PID 密钥。有关详细信息，请参阅 SQL Server 2008 的版本和组件。

  7. 在“许可条款”页上阅读许可协议，然后选中相应的复选框以接受许可条款和条件。若要继续，请单击“下一步”。若要结束安装程序，请单击“取消”。

  8. 如果计算机上尚未安装 SQL Server 必备组件，则安装向导将安装它们。其中包括：

    • .NET Framework 2.0

    • SQL Server Native Client

    • SQL Server 安装程序支持文件

    若要安装必备组件，请单击“安装”。

  9. 系统配置检查器将在安装继续之前检验计算机的系统状态。检查完成后，请单击“下一步”继续。

  10. 在“功能选择”页上选择要安装的组件。选择功能名称后，右侧窗格中会显示每个组件组的说明。您可以选中任意复选框的组合。有关详细信息，请参阅 SQL Server 2008 的版本和组件。

    您还可以使用此页底部的字段为共享组件指定自定义目录。若要更改共享组件的安装路径，请更新对话框底部字段中所提供的路径名，或单击“浏览”导航到另一个安装目录。默认安装路径为 C:\Program Files\Microsoft SQL Server\。

  11. 在“实例配置”页上指定是安装默认实例还是命名实例。有关详细信息，请参阅实例配置。若要继续，请单击“下一步”。

    实例 ID 后缀 - 默认情况下，使用实例名称作为实例 ID 的后缀。这用于标识 SQL Server 实例的安装目录和注册表项。默认实例和命名实例的默认方式都是如此。对于默认实例，实例名称和实例 ID 后缀均为 MSSQLSERVER。若要使用非默认的实例 ID 后缀，请选中“实例 ID 后缀”复选框，并提供一个值。

    注意：
    典型的 SQL Server 2008 独立实例（无论是默认实例还是命名实例）不会对“实例 ID 后缀”复选框使用非默认值。

    实例根目录 - 默认情况下，实例根目录为 C:\Program Files\Microsoft SQL Server\。若要指定一个非默认的根目录，请使用所提供的字段，或单击“浏览”以找到一个安装文件夹。

    所有 SQL Server Service Pack 和升级都将应用于 SQL Server 实例的每个组件。

    检测到的实例和功能 - 该网格将显示运行安装程序的计算机上的 SQL Server 实例。如果计算机上已经安装了一个默认实例，则必须安装 SQL Server 2008 的命名实例。若要继续，请单击“下一步”。

  12. “磁盘空间要求”页计算指定的功能所需的磁盘空间，然后将要求与可用磁盘空间进行比较。有关详细信息，请参阅磁盘成本摘要。

  13. 本主题中的其余工作流取决于要安装的功能。您可能不会看到所有的页面，具体取决于您进行的选择。

  14. 在“服务器配置 - 服务帐户”页上指定 SQL Server 服务的登录帐户。此页上配置的实际服务取决于您选择安装的功能。

    可以为所有 SQL Server 服务分配相同的登录帐户，也可以分别配置每个服务帐户。还可以指定服务是自动启动、手动启动还是禁用。Microsoft 建议对各服务帐户进行单独配置，以便为每项服务提供最低特权，即向 SQL Server 服务授予它们完成各自任务所需的最低权限。有关详细信息，请参阅SQL Server 配置 - 服务帐户和设置 Windows 服务帐户。

    若要为此 SQL Server 实例中的所有服务帐户指定相同的登录帐户，请在页面底部的字段中提供凭据。

    安全说明 不要使用空密码。请使用强密码。

    为 SQL Server 服务指定登录信息后，请单击“下一步”。

  15. 使用“服务器配置 - 排序规则”选项卡为数据库引擎和 Analysis Services 指定非默认的排序规则。有关详细信息，请参阅 SQL Server 配置 - 排序规则。

  16. 使用“数据库引擎配置 - 帐户设置”页指定以下事项：

    • 安全模式 - 为您的 SQL Server 实例选择 Windows 身份验证或混合模式身份验证。如果选择“混合模式身份验证”，则必须为内置 SQL Server 系统管理员帐户提供一个强密码。

      在设备与 SQL Server 成功建立连接之后，用于 Windows 身份验证和混合模式身份验证的安全机制是相同的。有关详细信息，请参阅数据库引擎配置 - 帐户设置。

    • SQL Server 管理员 - 您必须至少为 SQL Server 实例指定一个系统管理员。若要添加用以运行 SQL Server 安装程序的帐户，请单击“添加当前用户”。若要向系统管理员列表中添加帐户或从中删除帐户，请单击“添加”或“删除”，然后编辑将拥有 SQL Server 实例的管理员权限的用户、组或计算机的列表。有关详细信息，请参阅数据库引擎配置 - 帐户设置。

    完成对该列表的编辑后，请单击“确定”。验证配置对话框中的管理员列表。完成此列表后，请单击“下一步”。

  17. 使用“数据库引擎配置 - 数据目录”页指定非默认的安装目录。若要安装到默认目录，请单击“下一步”。

    重要提示：
    如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。

    有关详细信息，请参阅数据库引擎配置 - 数据目录。

  18. 使用“数据库引擎配置 - FILESTREAM”页对 SQL Server 实例启用 FILESTREAM。有关 FILESTREAM 的详细信息，请参阅数据库引擎配置 - 文件流。若要继续，请单击“下一步”。

  19. 使用“Analysis Services 配置 – 帐户设置”页指定将拥有 Analysis Services 的管理员权限的用户或帐户。您必须为 Analysis Services 至少指定一个系统管理员。若要添加用以运行 SQL Server 安装程序的帐户，请单击“添加当前用户”。若要向系统管理员列表中添加帐户或从中删除帐户，请单击“添加”或“删除”，然后编辑将拥有 Analysis Services 的管理员特权的用户、组或计算机的列表。有关详细信息，请参阅 Analysis Services 配置 – 帐户设置。

    完成对该列表的编辑后，请单击“确定”。验证配置对话框中的管理员列表。完成此列表后，请单击“下一步”。

  20. 使用“Analysis Services 配置 - 数据目录”页指定非默认的安装目录。若要安装到默认目录，请单击“下一步”。

    重要提示：
    如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。

    有关详细信息，请参阅 Analysis Services 配置 - 数据目录。

  21. 使用“Reporting Services 配置”页指定要创建的 Reporting Services 安装的类型。包括以下选项：

    • 本机模式默认配置

    • SharePoint 模式默认配置

    • 未配置的 Reporting Services 安装

    有关 Reporting Services 配置模式的详细信息，请参阅报表服务器安装选项。

  22. 在“错误和使用情况报告”页上指定要发送到 Microsoft 以帮助改善 SQL Server 的信息。默认情况下，用于错误报告和功能使用情况的选项处于启用状态。有关详细信息，请参阅错误和使用情况报告设置。

  23. 系统配置检查器将再运行一组规则来针对您指定的 SQL Server 功能验证您的计算机配置。

  24. “准备安装”页显示您在安装过程中指定的安装选项的树视图。若要继续，请单击“安装”。

  25. 在安装过程中，“安装进度”页会提供相应的状态，因此您可以在安装过程中监视安装进度。

  26. 安装完成后，“完成”页会提供指向安装日志文件摘要以及其他重要说明的链接。若要完成 SQL Server 安装过程，请单击“关闭”。

  27. 如果安装程序指示您重新启动计算机，请立即重新启动。安装完成后，请务必阅读来自安装向导的消息。有关安装日志文件的信息，请参阅如何查看 SQL Server 安装日志文件。

后续步骤

配置新安装的 SQL Server

  • 为了减少系统的可攻击外围应用，SQL Server 将有选择地安装和激活一些密钥服务和功能。有关详细信息，请参阅 MSDN 上的 Understanding Surface Area Configuration（了解外围应用配置器）。

  • 有关使用图形工具和命令提示符实用工具的详细信息，请参阅配置 SQL Server 2008。

请参阅

任务

如何升级到 SQL Server 2008（安装程序）

概念

如何查看 SQL Server 安装日志文件
如何从命令提示符安装 SQL Server 2008


SQL Server 2008 的版本和组件

SQL Server 2008 的版本和组件 |
 | 请参阅
SQL Server 安装概述 >

根据应用程序的需要，安装要求会有所不同。不同版本的 SQL Server 能够满足单位和个人独特的性能、运行时以及价格要求。安装哪些 SQL Server 组件还取决于您的具体需要。下面的部分将帮助您了解如何在 SQL Server 2008 的不同版本和可用组件中做出最佳选择。

SQL Server 2008 的服务器版本

下表介绍 SQL Server 2008 的各个服务器版本：

术语 | 定义
Enterprise（x86、x64 和 IA64）1 | SQL Server Enterprise 是一种综合的数据平台，可以为运行安全的业务关键应用程序提供企业级可扩展性、性能、高可用性和高级商业智能功能。有关详细信息，请参阅 SQL Server 2008 各个版本支持的功能。
Standard（x86 和 x64） | SQL Server Standard 是一个提供易用性和可管理性的完整数据平台。它的内置业务智能功能可用于运行部门应用程序。有关详细信息，请参阅 SQL Server 2008 各个版本支持的功能。 SQL Server Standard for Small Business 包含 SQL Server Standard 的所有技术组件和功能，可以在拥有 75 台或更少计算机的小型企业环境中运行。

1目前可以使用的 Enterprise 是可试用 180 天的 SQL Server 2008 Enterprise Evaluation。有关详细信息，请参阅 SQL Server 网站。

SQL Server 2008 专业版

SQL Server 2008 专业版是针对特定的用户群体而设计的。下表介绍 SQL Server 2008 的各个专业版。

术语 定义

SQL Server 2008 Developer（x86、x64 和 IA64）

SQL Server 2008 Developer 支持开发人员构建基于 SQL Server 的任一种类型的应用程序。它包括 SQL Server 2008 Enterprise 的所有功能，但有许可限制，只能用作开发和测试系统，而不能用作生产服务器。SQL Server 2008 Developer 是构建和测试应用程序的人员的理想之选。可以升级 SQL Server 2008 Developer 以将其用于生产用途。

工作组（x86 和 x64）

SQL Server Workgroup 是运行分支位置数据库的理想选择，它提供一个可靠的数据管理和报告平台，其中包括安全的远程同步和管理功能。

Web（x86、x64）

对于为从小规模至大规模 Web 资产提供可扩展性和可管理性功能的 Web 宿主和网站来说，SQL Server 2008 Web 是一项总拥有成本较低的选择。

SQL Server Express（x86 和 x64）

SQL Server Express with Advanced Services（x86 和 x64）

SQL Server Express 数据库平台基于 SQL Server 2008。它也可用于替换 Microsoft Desktop Engine (MSDE)。SQL Server Express 与 Visual Studio 集成，从而开发人员可以轻松开发功能丰富、存储安全且部署快速的数据驱动应用程序。

SQL Server Express 免费提供，且可以由 ISV 再次分发（视协议而定）。SQL Server Express 是学习和构建桌面及小型服务器应用程序的理想选择，也是独立软件供应商、非专业开发人员和热衷于构建客户端应用程序的人员的最佳选择。如果您需要使用更高级的数据库功能，则可以将 SQL Server Express 无缝升级到更复杂的 SQL Server 版本。

Compact 3.5 SP1 (x86)

Compact 3.1 (x86)

SQL Server Compact 免费提供，是生成用于基于各种 Windows 平台的移动设备、桌面和 Web 客户端的独立和偶尔连接的应用程序的嵌入式数据库理想选择。

有关 SQL Server 2008 各个专业版的详细信息，请参阅 SQL Server 网站。

将 SQL Server 用于 Internet 服务器

在 Internet 服务器（如运行 Internet Information Services (IIS) 的服务器）上通常都会安装 SQL Server 客户端工具。客户端工具包括连接到 SQL Server 实例的应用程序所使用的客户端连接组件。

注意：
尽管可以在运行 IIS 的计算机上安装 SQL Server 实例，但这种做法通常只用于仅包含一台服务器的小型网站。大多数网站都将其中间层 IIS 系统安装在一个服务器上或服务器群集上，将数据库安装在另外一个服务器或服务器联合体上。有关 SSRS 的软件要求的详细信息，请参阅安装 SQL Server 2008 的硬件和软件要求。有关联合的详细信息，请参阅 SQL Server 联机丛书中的联合数据库服务器主题。

将 SQL Server 用于客户端/服务器应用程序

在运行直接连接到 SQL Server 实例的客户端/服务器应用程序的计算机上，只能安装 SQL Server 客户端组件。如果要在数据库服务器上管理 SQL Server 实例，或者打算开发 SQL Server 应用程序，那么客户端组件安装也是一个不错的选择。

客户端组件选项安装以下 SQL Server 功能：命令提示工具、Reporting Services 工具、连接组件、编程模型、管理工具、开发工具以及 SQL Server 联机丛书。有关详细信息，请参阅如何安装 SQL Server 2008（安装程序）。

选择 SQL Server 的组件

使用 SQL Server 安装向导的“功能选择”页面选择安装 SQL Server 时要安装的组件。默认情况下未选中树中的任何功能。

可根据下表中给出的信息确定最能满足需要的功能集合：

服务器组件 | 说明
SQL Server 数据库引擎 | SQL Server 数据库引擎 包括数据库引擎（用于存储、处理和保护数据的核心服务）、复制、全文搜索以及用于管理关系数据和 XML 数据的工具。
Analysis Services | Analysis Services 包括用于创建和管理联机分析处理 (OLAP) 以及数据挖掘应用程序的工具。
Reporting Services | Reporting Services 包括用于创建、管理和部署表格报表、矩阵报表、图形报表以及自由格式报表的服务器和客户端组件。Reporting Services 还是一个可用于开发报表应用程序的可扩展平台。
Integration Services | Integration Services 是一组图形工具和可编程对象，用于移动、复制和转换数据。

管理工具 | 说明
SQL Server Management Studio | SQL Server Management Studio 是一个集成环境，用于访问、配置、管理和开发 SQL Server 的组件。Management Studio 使各种技术水平的开发人员和管理员都能使用 SQL Server。Management Studio 的安装需要 Internet Explorer 6 SP1 或更高版本。
SQL Server 配置管理器 | SQL Server 配置管理器为 SQL Server 服务、服务器协议、客户端协议和客户端别名提供基本配置管理。
SQL Server Profiler | SQL Server Profiler 提供了一个图形用户界面，用于监视数据库引擎实例或 Analysis Services 实例。
数据库引擎优化顾问 | 数据库引擎优化顾问可以协助创建索引、索引视图和分区的最佳组合。
Business Intelligence Development Studio | Business Intelligence Development Studio 是 Analysis Services、Reporting Services 和 Integration Services 解决方案的 IDE。BI Development Studio 的安装需要 Internet Explorer 6 SP1 或更高版本。
连接组件 | 安装用于客户端和服务器之间通信的组件，以及用于 DB-Library、ODBC 和 OLE DB 的网络库。

文档 | 说明
SQL Server 联机丛书 | SQL Server 的核心文档。

请参阅

任务

如何安装 SQL Server 2008（安装程序）

概念

计划 SQL Server 安装


SQL Server 2008 各个版本支持的功能

SQL Server 2008 各个版本支持的功能 |
 | 请参阅
SQL Server 安装概述 >

使用下表可以确定 Microsoft SQL Server 2008 的各个种版本支持哪些功能。

注意：
SQL Server Enterprise 在评估版本中提供，具有 180 天试用期。有关如何获得 SQL Server 2008 的评估版的详细信息，请参阅此 Microsoft 网站 。

可扩展性

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
分区 | 是 |  |  |  |  |
数据压缩 | 是 |  |  |  |  |
资源调控器 | 是 |  |  |  |  |
分区表并行度 | 是 |  |  |  |  |

高可用性

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
多实例支持 | 50 | 16 | 16 | 16 | 16 | 16
联机系统更改 | 是 | 是 | 是 | 是 | 是 | 是
备份日志传送 | 是 | 是 | 是 | 是 |  |
数据库镜像 | 是（完全） | 是（仅完全安全） | 仅见证服务器 | 仅见证服务器 | 仅见证服务器 | 仅见证服务器
故障转移群集 | 操作系统最大值1 | 2 个节点 |  |  |  |
动态 AWE | 是 | 是 |  |  |  |
无需客户端配置的故障转移 | 是 | 是 |  |  |  |
从镜像自动恢复损坏 | 是 | 是 |  |  |  |
数据库快照 | 是 |  |  |  |  |
快速恢复 | 是 |  |  |  |  |
联机索引 | 是 |  |  |  |  |
联机还原 | 是 |  |  |  |  |
镜像备份 | 是 |  |  |  |  |
热添加内存 | 是 |  |  |  |  |
P2P 节点的联机配置 | 是 |  |  |  |  |
热添加 CPU | 是 |  |  |  |  |
备份压缩 | 是 |  |  |  |  |

1Windows Server 2003 最多支持 8 个故障转移群集节点。Windows Server 2008 最多支持 64 个故障转移群集节点。

安全性

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
符合 C2 的跟踪 | 是 | 是 | 是 | 是 | 是 | 是
SQL 审核基础 | 是 | 是 | 是 | 是 | 是 | 是
细粒度审核 | 是 |  |  |  |  |
透明数据库加密 | 是 |  |  |  |  |
ISV 加密（出箱密钥管理） | 是 |  |  |  |  |

复制

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
合并复制 | 是 | 是 | 仅订阅服务器 | 仅订阅服务器 | 仅订阅服务器 | 仅订阅服务器
事务复制 | 是 | 是 | 仅订阅服务器 | 仅订阅服务器 | 仅订阅服务器 | 仅订阅服务器
快照复制 | 是 | 是 | 仅订阅服务器 | 仅订阅服务器 | 仅订阅服务器 | 仅订阅服务器
SQL Server 更改跟踪 | 是 | 是 | 是 | 是 | 是 | 是
异类订阅服务器 | 是 | 是 |  |  |  |
Oracle 发布 | 是 |  |  |  |  |
P2P 事务复制 | 是 |  |  |  |  |

易管理性

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
用户实例 |  |  |  |  | 是 | 是
专用管理员连接 | 是 | 是 | 是 | 是 | 是（在跟踪标志下） | 是（在跟踪标志下）
基于策略的配置 | 是 | 是 | 是 | 是 | 是 | 是
基于策略的管理 | 是 | 是 | 是 | 是 | 是 | 是
性能数据收集和数据仓库 | 是 | 是 | 是 | 是 |  |
标准性能报表 | 是 | 是 |  |  |  |
计划指南 | 是 | 是 |  |  |  |
计划指南的计划冻结 | 是 | 是 |  |  |  |
基于策略的最佳实践 | 是 | 是 |  |  |  |
基于多服务器策略的管理 | 是 | 是 |  |  |  |
分布式分区视图 | 是 |  |  |  |  |
并行索引操作 | 是 |  |  |  |  |
自动的查询到索引视图匹配 | 是 |  |  |  |  |
并行数据库备份校验和检查 | 是 |  |  |  |  |
数据库邮件 | 是 | 是 | 是 | 是 |  |
数据库迁移工具 | 是 | 是 | 是 | 是 | 是 | 是

管理工具

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
SQL 管理对象 (SMO) | 是 | 是 | 是 | 是 | 是 | 是
SQL 配置管理器 | 是 | 是 | 是 | 是 | 是 | 是
SQL CMD（命令提示工具） | 是 | 是 | 是 | 是 | 是 | 是
SQL Server Management Studio | 是 | 是 | 是 | 是（Express 版本） |  | 是（Express 版本）
SQL 事件探查器 | 是 | 是 | 是 | 是 |  |
SQL Server 代理 | 是 | 是 | 是 | 是 |  |
数据库优化顾问 | 是 | 是 | 是 | 是 |  |
Microsoft Operations Manager 包 | 是 | 是 | 是 | 是 |  |

开发工具

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Microsoft Visual Studio Integration | 是 | 是 | 是 | 是 | 是 | 是
SQL 查询、编辑和设计工具 | 是 | 是 | 是 |  |  |
Intellisense（Transact-SQL 和 MDX） | 是 | 是 | 是 |  |  |
版本控制支持 | 是 | 是 | 是 |  |  |
Business Intelligence Development Studio | 是 | 是 |  |  |  |
MDX 编辑、调试和设计工具 | 是 | 是 |  |  |  |

可编程性

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
公共语言运行时 (CLR) 集成 | 是 | 是 | 是 | 是 | 是 | 是
本机 XML 支持 | 是 | 是 | 是 | 是 | 是 | 是
XML 索引 | 是 | 是 | 是 | 是 | 是 | 是
MERGE 和 UPSERT 功能 | 是 | 是 | 是 | 是 | 是 | 是
FILESTREAM 支持 | 是 | 是 | 是 | 是 | 是 | 是
日期和时间数据类型 | 是 | 是 | 是 | 是 | 是 | 是
国际化支持 | 是 | 是 | 是 | 是 | 是 | 是
全文搜索 | 是 | 是 | 是 | 是 |  | 是
查询中的语言规范 | 是 | 是 | 是 | 是 |  | 是
Service Broker（消息） | 是 | 是 | 是 | 仅客户端 | 仅客户端 | 仅客户端
XML/A 支持 | 是 | 是 |  |  |  |
Web 服务（HTTP/SOAP 端点） | 是 | 是 |  |  |  |

空间和位置服务

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
空间索引 | 是 | 是 | 是 | 是 | 是 | 是
大地测量数据类型 | 是 | 是 | 是 | 是 | 是 | 是
高级空间库 | 是 | 是 | 是 | 是 | 是 | 是
基于标准的空间支持 | 是 | 是 | 是 | 是 | 是 | 是

Integration Services

功能 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
使用基本源和目标的 SQL Server 导入和导出向导以及执行 SQL 任务 | 是 | 是 | 是 | 是 | 是 | 是
Integration Services 运行时 | 是 | 是 | 是 | 是 | 是 | 是
Integration Services API 和对象模型 | 是 | 是 | 是 | 是 |  |
包括 VSTA 脚本的 SSIS 设计器 | 是 | 是 |  |  |  |
Integration Services 服务、向导和命令提示实用工具 | 是 | 是 |  |  |  |
基本任务和转换 | 是 | 是 |  |  |  |
日志提供程序和日志记录 | 是 | 是 |  |  |  |
数据事件探查工具 | 是 | 是 |  |  |  |
其他源和目标： 原始文件源 XML 源 DataReader 目标 原始文件目标 记录集目标 SQL Server Compact 目标 SQL Server 目标 | 是 | 是 |  |  |  |
高级源、转换和目标： 数据挖掘查询转换 模糊查找和模糊分组转换 术语提取和术语查找转换 数据挖掘模型定型目标 维度处理目标 分区处理目标 | 是 |  |  |  |  |

数据仓库创建

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
在无需数据库的情况下创建多维数据集 | 是 | 是 |  |  |  |
自动生成临时和数据仓库架构 | 是 | 是 |  |  |  |
属性关系设计器 | 是 | 是 |  |  |  |
有效聚合设计器 | 是 | 是 |  |  |  |

数据仓库规模和性能

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
变更数据捕获 | 是 |  |  |  |  |
星型联接询优化 | 是 |  |  |  |  |
可缩放只读 AS 配置 | 是 |  |  |  |  |
主动缓存 | 是 |  |  |  |  |
自动并行分区处理 | 是 |  |  |  |  |
分区多维数据集 | 是 |  |  |  |  |
分布式分区多维数据集 | 是 |  |  |  |  |

多维分析

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
SQL Server Analysis Services 服务 | 是 | 是 |  |  |  |
SQL Server Analysis Services 备份 | 是 | 是 |  |  |  |
常规性能/规模改进 | 是 | 是 |  |  |  |
维度、属性关系、聚合和多维数据集设计改进 | 是 | 是 |  |  |  |
个性化扩展插件 | 是 | 是 |  |  |  |
财务聚合 | 是 |  |  |  |  |
分区客户 | 是 |  |  |  |  |
自定义汇总 | 是 |  |  |  |  |
半累加性度量值 | 是 |  |  |  |  |
写回维度 | 是 |  |  |  |  |
链接度量值和维度 | 是 |  |  |  |  |
二进制和压缩的 XML 传输 | 是 |  |  |  |  |
帐户智能 | 是 |  |  |  |  |
透视 | 是 |  |  |  |  |
Analysis Services 共享、可缩放数据库 | 是 |  |  |  |  |

数据挖掘

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
标准算法 | 是 | 是 |  |  |  |
数据挖掘工具：向导、编辑器、查询生成器 | 是 | 是 |  |  |  |
交叉验证 | 是 |  |  |  |  |
挖掘结构数据的筛选子集的模型 | 是 |  |  |  |  |
时序：ARTXP 和 ARIMA 模型之间的自定义混和 | 是 |  |  |  |  |
时序：使用新数据的预测 | 是 |  |  |  |  |
无限制并发数据挖掘查询 | 是 |  |  |  |  |
高级配置和算法优化 | 是 |  |  |  |  |
算法插件 API | 是 |  |  |  |  |
并行模型处理 | 是 |  |  |  |  |
时序：跨序列预测 | 是 |  |  |  |  |
关联规则的无限制属性 | 是 |  |  |  |  |
序列预测 | 是 |  |  |  |  |
na?ve Bayes、神经网络和逻辑回归的多个预测目标 | 是 |  |  |  |  |

报表

功能名称 | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
报表服务器 | 是 | 是 | 是 | 是 |  | 是
报表设计器 | 是 | 是 | 是 | 是 |  | 是
报表管理器 | 是 | 是 | 是 | 是（报表管理器） |  | 是（报表管理器）
基于角色的安全性 | 是 | 是 | 是（固定角色） | 是（固定角色） |  | 是（固定角色）
即席报表（报表生成器） | 是 | 是 | 是 |  |  |
Word 导出和增强文本格式设置 | 是 | 是 | 是 | 是 |  | 是
企业规模报表引擎 | 是 | 是 | 是 | 是 |  | 是
IIS 不可知的报表部署 | 是 | 是 | 是 | 是 |  | 是
更新管理工具 | 是 | 是 | 是 | 是 |  | 是
报表定义自定义扩展插件 (RDCE) | 是 | 是 | 是 | 是 |  | 是
SharePoint 集成 | 是 | 是 |  |  |  |
增强的 SSRS 仪表和图表 | 是 | 是 | 是 | 是 |  | 是
自定义身份验证 | 是 | 是 | 是 | 是 |  |
导出到 Excel、PDF 和图像 | 是 | 是 | 是 | 是 |  | 是
远程和非关系数据源支持 | 是 | 是 |  |  |  |
电子邮件和文件共享传递 | 是 | 是 |  |  |  |
报表历史记录、计划、订阅和缓存 | 是 | 是 |  |  |  |
数据源、传递和呈现可扩展性 | 是 | 是 |  |  |  |
扩展（Web 场） | 是 |  |  |  |  |
无限制链接点击 | 是 |  |  |  |  |
数据驱动订阅 | 是 |  |  |  |  |
Reporting Services 内存限制 | 无限制 | 无限制 | 4 GB | 4 GB |  | 4 GB

请参阅

参考

版本升级

概念

SQL Server 安装概述
SQL Server 2008 安装快速入门

其他资源

SQL Server 的产品规格


关于 SQL Server 许可条款

关于 SQL Server 许可条款 |
 | 请参阅
SQL Server 安装概述 >

安装 SQL Server 时，会将 Microsoft 软件许可条款复制到本地计算机。当在同一台计算机上安装具有相同版本类别和语言的多个 SQL Server 实例时，许可条款的单个副本将适用于该版本类别和语言的所有实例。这些文件将写入到：%ProgramFiles%\Microsoft SQL Server\100\EULA\ 或 %ProgramFiles(x86)%\Microsoft SQL Server\100\EULA\。

在同一台计算机上安装相同 SQL Server 版本和语言的多个实例时，许可条款的单个副本将应用于该版本和语言的所有实例。

许可条款文件名指示 SQL Server 的版本以及 SQL Server 语言版本。例如：

  • License_DEV_ENU.txt 表示 SQL Server 2008 Developer，英语版本。

  • License_STD_ITA.txt 表示 SQL Server Standard，意大利语版本。

  • License_UA_JPN.txt 表示 SQL Server 升级顾问，日语版本。

  • License_SQLNCLI_ENU.txt 表示 SQL Native Client，英语版本。

  • License_SQLXML4_KOR.txt 表示 SQLXML，朝鲜语版本。

以下文件名段用于标识 SQL Server 版本：

  • ENT - Enterprise

  • DEV - Developer

  • STD - Standard

  • WKGP - Workgroup

  • WEB - Web

  • EXPR - Express

  • UA - 升级顾问

以下文件名段用于标识 SQL Server 语言：

  • ENU - 英语

  • JPN - 日语

  • FRA - 法语

  • ITA - 意大利语

  • KOR - 朝鲜语

  • DEU - 德语

  • ESN - 西班牙语

  • CHS - 简体中文

  • CHT - 繁体中文

  • NLA - 荷兰语

  • PTB - 葡萄牙语（巴西）

  • SVE - 瑞典语

  • RUS - 俄语

SQL Server 许可选项

有关 SQL Server 定价和许可选项的信息，请参阅 Microsoft SQL Server 网站。

请参阅

概念

SQL Server 隐私声明
文档法律声明


SQL Server 隐私声明

SQL Server 隐私声明
SQL Server 安装概述 >

有关 SQL Server 2008 中用户数据收集组件的信息，请参阅 SQL Server 2008 privacy statement（SQL Server 2008 隐私声明）。


文档法律声明

文档法律声明
SQL Server 安装概述 >

本文档（包括本文档中使用的示例应用程序）仅供参考，Microsoft 及其供应商不对本文档做任何明示或暗示的担保。本文档中的信息（包括 URL 和其他 Internet 网站引用）如有更改，恕不另行通知。由于使用本文档而带来的任何风险或后果均由用户自行承担。

除非另有说明，本文档示例所提及的公司、组织、产品、域名、电子邮件地址、人物、地点和事件纯属虚构。不应据此联想或推断到任何真实的公司、组织、产品、域名、电子邮件地址、人物、地点或事件。用户有责任遵守所有适用的版权法/著作权法。除了版权法/著作权法所规定的权利以外，未经 Microsoft Corporation 的明确书面许可，不得对本文档中的任何部分进行复制、存储或引入检索系统，也不能以任何形式或借助任何手段（电子、机械、影印、录制或其他手段）、出于任何目的进行传播。

Microsoft 可能拥有本文档中内容的专利、专利申请、商标、版权或其他知识产权。除非 Microsoft 提供了明确的书面许可协议，否则提供本文档并不意味着赋予您有关这些专利、商标、版权或其他知识产权的任何许可。

版权所有 © 2008 Microsoft Corporation。保留所有权利。

Microsoft、Active Directory、ActiveX、Excel、IntelliSense、MSDN、MS-DOS、PivotChart、PivotTable、PowerPoint、SharePoint、SQL Server、Visual Basic、Visual C#、Visual C++、Visual Studio、Windows、Windows NT、Windows Server 和 Windows Vista 是 Microsoft Corporation 在美国和/或其他国家/地区的注册商标或商标。

SAP NetWeaver 是 SAP AG 在德国和其他几个国家/地区的注册商标。

所有其他商标归其各自拥有者所有。

SQL Server 支持和升级文档策略

SQL Server 2008 软件文档包括 Microsoft 发布的 SQL Server 联机丛书、自述文件、已知问题文档、示例代码、示例数据库和知识库文章，这些文档都包含与 SQL Server 的特征和功能相关的内容。本支持和升级策略适用于所有 SQL Server 2008 文档，包括 SQL Server 2008 发行版本和 Service Pack 的自述文件；自述文件被视为 SQL Server 2008 联机丛书的扩展。

本文档中包含的示例主要用于说明概念以及特定语句或子句的合理用法。大多数示例不包括完整的生产系统通常所包含的全部代码，因为其中删除了某些常用的数据验证和错误处理，以便使示例突出特定的概念或语句。对这些示例或所包括的源代码，我们不提供技术支持。

在某些情况下，Microsoft SQL Server 2008 的特定功能尚未经过充分测试或开发，不应予以使用。此类功能通常都以占位符的形式出现。因此，未对本软件所包含的某些功能提供文字说明。未说明以及标记用于 Microsoft 内部使用的功能都不应使用，且 Microsoft 客户支持服务部门不为这些功能提供支持。除非 Microsoft SQL Server 2008 文档另有说明，否则 Microsoft 客户支持服务部门不会对第三方内容（包括将此类第三方内容与 Microsoft SQL Server 2008 合并使用而导致的问题）提供支持，并且此类内容还可能导致数据丢失。Microsoft 客户支持部门不为利用或使用未说明的入口点（如未说明的 API）的数据库或应用程序提供支持，其中包括但不限于：存储过程、扩展存储过程、函数、视图、表、列、属性或元数据。

对于利用或使用未说明的入口点的应用程序和数据库，其服务器和数据库可能无法升级至 SQL Server 2008 的未来版本，且此类服务器和数据库的升级不享受相关支持。对于 Microsoft SQL Server 内包含但未在 SQL Server 2008 文档中提供文字说明的 SQL Server 特征和功能，不对其使用提供支持，且此类使用可能导致数据丢失。


SQL Server 2008 的许可注意事项

SQL Server 2008 的许可注意事项 |
 | 请参阅
SQL Server 安装概述 >

有关 SQL Server 2008 许可选项的信息，请参阅该 Microsoft SQL Server 网站。

请参阅

参考

关于 SQL Server 许可条款

概念

SQL Server 隐私声明
文档法律声明


计划 SQL Server 安装

计划 SQL Server 安装 |
 | 请参阅

若要安装 SQL Server 2008，请按下列步骤操作：

  • 查看 SQL Server 2008 安装的安装要求、系统配置检查和安全注意事项。

  • 运行 SQL Server 安装程序以安装或升级到 SQL Server 2008。

  • 使用 SQL Server 实用工具配置 SQL Server。

无论使用 SQL Server 安装向导还是命令提示符安装 SQL Server，下列主题都介绍了 SQL Server 的计划过程。

本节内容

安装 SQL Server 2008 的硬件和软件要求

介绍 SQL Server 的硬件和软件要求、操作系统支持、网络和 Internet 注意事项以及硬盘空间要求。

系统配置检查器的检查参数

介绍 SQL Server 系统配置检查器的要求。

安装 SQL Server 的安全注意事项

介绍 SQL Server 安装的安全注意事项。

SQL Server 2008 的版本和组件

介绍 SQL Server 的版本和组件。

升级到 SQL Server 2008

介绍用于升级到 SQL Server 的选项。

迁移到 SQL Server 2008

介绍用于迁移到 SQL Server 的选项。

配置 SQL Server 2008

介绍 SQL Server 配置工具。

相关章节

安装 SQL Server 数据库引擎的注意事项

本节介绍如何安装和配置 SQL Server 数据库引擎。

安装 Analysis Services 时的注意事项

本节介绍如何安装和配置 SQL Server Analysis Services。

安装 Reporting Services 的注意事项

本节介绍如何安装和配置 SQL Server Reporting Services。

安装 Integration Services 的注意事项

本节介绍如何安装和配置 Integration Services。

安装 SQL Server 复制的注意事项

本节介绍如何安装和配置 SQL Server 复制。

SQL Server 2008 故障转移群集入门

介绍 SQL Server 故障转移群集的方案。

安装 SQL Server 管理工具的注意事项

本节介绍如何安装和配置 SQL Server 管理工具。

安装 SQL Server 示例和示例数据库的注意事项

本节介绍如何安装 AdventureWorks 示例。

请参阅

任务

如何升级到 SQL Server 2008（安装程序）

概念

SQL Server 2008 安装快速入门
如何从命令提示符安装 SQL Server 2008
安装故障转移群集前的准备工作

其他资源

高可用性解决方案概述


安装 SQL Server 2008 的硬件和软件要求

安装 SQL Server 2008 的硬件和软件要求 |
 | 请参阅
计划 SQL Server 安装 >

以下各部分列出了安装和运行 SQL Server 2008 的最低硬件和软件要求。

对于 SQL Server 2008 的 32 位和 64 位版本，适用以下要求：

  • 现在可供使用的 SQL Server 2008 Enterprise 是试用期为 180 天的评估版。有关详细信息，请参阅 SQL Server: How to Buy（SQL Server：如何购买）网站。

  • Microsoft 建议您在使用 NTFS 文件格式的计算机上运行 SQL Server 2008。但针对升级到 SQL Server 2008 的情况，不阻止使用 FAT32 文件系统。

  • SQL Server 安装程序会阻止在只读或压缩驱动器上进行安装。

  • 有关使用 SQL Server 2008 工具为升级到 SQL Server 2008 做准备的信息，请参阅使用升级顾问来准备升级。

  • SQL Server 不安装 .NET Framework 3.5 软件开发工具包 (SDK)。但是，此 SDK 包含在将 .NET Framework 用于 SQL Server 开发时可以使用的工具。您可以从 .NET Framework 网站下载 .NET Framework SDK。

  • 在 SQL Server 安装过程中重新启动计算机的要求：安装 .NET Framework 需要重新启动操作系统。如果安装 Windows Installer 也需要重新启动操作系统，则安装程序将等到 .NET Framework 和 Windows Installer 组件安装完成后，才进行重新启动。

  • 有关 SQL Server 2008 的功能的详细信息，请参阅以下主题：

    • SQL Server 2008 的版本和组件

    • SQL Server 2008 各个版本支持的功能

硬件和软件要求

以下要求适用于所有 SQL Server 2008 安装：

组件 要求

框架2

SQL Server 安装程序安装该产品所需的以下软件组件：

  • .NET Framework 3.51

  • SQL Server Native Client

  • SQL Server 安装程序支持文件

软件2

SQL Server 安装程序需要使用 Microsoft Windows Installer 4.5 或更高版本以及 Microsoft 数据访问组件 (MDAC) 2.8 SP1 或更高版本。您可以从 MDAC 下载网站下载 MDAC 2.8 SP1。

安装所需组件之后，SQL Server 安装程序将验证要安装 SQL Server 2008 的计算机是否也满足成功安装所需的所有其他要求。有关详细信息，请参阅系统配置检查器的检查参数。

网络软件

SQL Server 2008 64 位版本的网络软件要求与 32 位版本的要求相同。

支持的操作系统都具有内置网络软件。独立的命名实例和默认实例支持以下网络协议：

  • Shared memory

  • Named Pipes

  • TCP/IP

  • VIA

注意 故障转移群集不支持 Shared memory 和 VIA。

虚拟化

在以 Windows Server 2008 Standard、Enterprise 和 Data Center 版本中的 Hyper-V 角色运行的虚拟机环境中支持 SQL Server 2008。虚拟机必须运行本主题稍后部分中列出的特定 SQL Server 2008 版本所支持的操作系统。

除了父分区所需的资源以外，还必须为每个虚拟机（子分区）的 SQL Server 2008 实例提供足够的处理器资源、内存和磁盘资源。具体要求在本主题的稍后部分中列出。3

在 Windows Server 2008 上的 Hyper-V 角色中，最多可以为运行 Windows Server 2008 32 位或 64 位版本的虚拟机分配四个虚拟处理器。最多可以为运行 Windows Server 2003 32 位版本的虚拟计算机分配 2 个虚拟处理器。对于承载其他操作系统的虚拟计算机，最多可以为虚拟计算机分配一个虚拟处理器。

注意：

  • 建议在关闭或终止虚拟机之前先关闭 SQL Server 2008。

  • 在 Hyper-V 环境中不支持来宾故障转移群集（在 SQL Server 2008 中配置故障转移群集）。

  • 有关 Windows Server 2008 中 Hyper-V 角色的详细信息，请参阅 Windows Server 2008 网站。

Internet 软件

所有 SQL Server 2008 安装都需要使用 Microsoft Internet Explorer 6 SP1 或更高版本。Microsoft 管理控制台 (MMC)、SQL Server Management Studio、Business Intelligence Development Studio、Reporting Services 的报表设计器组件和 HTML 帮助都需要 Internet Explorer 6 SP1 或更高版本。

硬盘

磁盘空间要求将随所安装的 SQL Server 2008 组件不同而发生变化。有关详细信息，请参阅本主题稍后部分中的硬盘空间要求。

驱动器

从磁盘进行安装时需要相应的 CD 或 DVD 驱动器。

显示器

SQL Server 2008 图形工具需要使用 VGA 或更高分辨率：分辨率至少为 1,024x768 像素。

其他设备

指针设备：需要 Microsoft 鼠标或兼容的指针设备。

1以下 .NET Framework 版本是必需的：

  • Windows Server 2003（64 位）IA64 上的 SQL Server 2008 - .NET Framework 2.0 SP1

  • SQL Server 2008 的所有其他版本 - .NET Framework 3.5

安装 .NET Framework 需要重新启动操作系统。如果安装 Windows Installer 也需要重新启动操作系统，安装程序将等到 .NET Framework 和 Windows Installer 组件完成安装后，才进行重新启动。

2 SQL Server 安装程序将不安装 SQL Server Express 和 SQL Server Express with Advanced Services 所需的以下组件。在运行 SQL Server 安装程序之前，必须手动安装这些组件：

  • SQL Server Express — ..NET Framework 2.0 SP2 和 Windows installer 4.5。在 Windows Vista 上，请使用 .NET Framework 3.5 SP1。

  • SQL Server Express with Advanced Services - .NET Framework 3.5 SP1、Windows Installer 4.5 和 Windows PowerShell 1.0。

3与所有虚拟化技术一样，在 Windows Server 2008 Hyper-V 虚拟计算机上运行的 SQL Server 2008 将比在具有相同物理资源的物理计算机上运行的慢。

处理器、内存和操作系统要求

若要查看系统要求，请选择 SQL Server 2008 的版本：

SQL Server 2008 的服务器版本

  • SQL Server 2008 Enterprise（64 位）IA64

  • SQL Server 2008 Enterprise（64 位）x64

  • SQL Server 2008 Standard（64 位）x64

  • SQL Server 2008 Enterprise（32 位）

  • SQL Server 2008 Standard（32 位）

SQL Server 2008 专业版

  • SQL Server 2008 Developer（64 位）IA64

  • SQL Server 2008 Developer（64 位）x64

  • SQL Server 2008 Workgroup（64 位）x64

  • SQL Server 2008 Web（64 位）x64

  • SQL Server 2008 Express（64 位）x64

  • SQL Server 2008 Express Advanced（64 位）x64

  • SQL Server 2008 Developer（32 位）

  • SQL Server 2008 Workgroup（32 位）

  • SQL Server 2008 Web（32 位）

  • SQL Server 2008 Express 和 Express with Advanced Services（32 位）

本主题中的其他信息

  • 硬盘空间要求

  • 跨语言支持

  • 支持在域控制器上安装 SQL Server 2008

服务器版本（64 位和 32 位）

SQL Server 2008 Enterprise（64 位）IA64

下表列出了 SQL Server 2008 Enterprise（64 位）IA64 的系统要求。请注意，此版本的 SQL Server 2008 在以下本地化版本中不可用：意大利语、西班牙语、葡萄牙语（巴西）或俄语。

组件 要求

处理器

处理器类型：

  • Itanium 处理器或速度更快的处理器

处理器速度：

  • 建议：1.0 GHz 或速度更快的处理器

操作系统

Windows Server 2008 64 位 Itanium1,2

Windows Server 2003 SP2 64 位 Itanium Data Center1,2

Windows Server 2003 SP2 64 位 Itanium Enterprise1

内存

RAM：

  • 最小：512 MB

  • 建议：2.048 GB 或更大的内存

  • 最大：操作系统最大内存

1在 WOW64 中支持管理工具，WOW64 是 Windows 64 位版本中的一项功能，该功能允许以本机方式在 32 位模式下运行 32 位应用程序。尽管基础操作系统在 64 位操作系统上运行，但应用程序以 32 位模式工作。

2 Windows Server 2008 Server Core 安装不支持 SQL Server 2008。

SQL Server 2008 Enterprise（64 位）x64

下表列出了 SQL Server 2008 Enterprise（64 位）x64 的系统要求：

组件 要求

处理器

处理器类型：

  • 最低：AMD Opteron、AMD Athlon 64、支持 Intel EM64T 的 Intel Xeon 和支持 EM64T 的 Intel Pentium IV

处理器速度：

  • 最低：1.4 GHz

  • 建议：2.0 GHz 或速度更快的处理器

操作系统

Windows XP Professional 2003 64 位 x643

Windows Server 2003 SP2 64 位 x64 Standard1

Windows Server 2003 SP2 64 位 x64 Data Center1

Windows Server 2003 SP2 64 位 x64 Enterprise1

Windows Vista 64 位 x64 Ultimate3

Windows Vista 64 位 x64 Home Premium3

Windows Vista 64 位 x64 Home Basic3

Windows Vista 64 位 x64 Enterprise3

Windows Vista 64 位 x64 Business3

Windows Server 2008 64 位 x64 Standard

Windows Server 2008 64 位 x64 Standard（不带 Hyper-V）2,4

Windows Server 2008 64 位 x64 Data Center

Windows Server 2008 64 位 x64 Data Center（不带 Hyper-V）1,2

Windows Server 2008 64 位 x64 Enterprise

Windows Server 2008 64 位 x64 Enterprise（不带 Hyper-V）1,2

内存

RAM：

  • 最小：512 MB

  • 建议：2.048 GB 或更大的内存

  • 最大：操作系统最大内存

1在 WOW64 中支持管理工具，WOW64 是 Windows 64 位版本中的一项功能，该功能允许以本机方式在 32 位模式下运行 32 位应用程序。尽管基础操作系统在 64 位操作系统上运行，但应用程序以 32 位模式工作。

2 Windows Server 2008 Server Core 安装不支持 SQL Server 2008。

3该版本的 Windows 支持 SQL Server 2008 Enterprise Evaluation，不支持 Enterprise。

SQL Server 2008 Standard（64 位）x64

下表列出了 SQL Server 2008 Standard（64 位）x64 的系统要求：

组件 要求

处理器

处理器类型：

  • 最低：AMD Opteron、AMD Athlon 64、支持 Intel EM64T 的 Intel Xeon 和支持 EM64T 的 Intel Pentium IV

处理器速度：

  • 最低：1.4 GHz

  • 建议：2.0 GHz 或速度更快的处理器

操作系统

Windows XP Professional x64

Windows Server 2003 SP2 64 位 x64 Standard1,2

Windows Server 2003 SP2 64 位 x64 Data Center1,2

Windows Server 2003 SP2 64 位 x64 Enterprise1,2

Windows Vista Ultimate x64

Windows Vista Enterprise x64

Windows Vista Business x64

Windows Server 2008 x64 Web1

Windows Server 2008 x64 Standard 和 Windows Server 2008 x64 Standard（不带 Hyper-V）1,2

Windows Server 2008 x64 Data Center 和 Windows Server 2008 x64 Data Center（不带 Hyper-V）1,2

Windows Server 2008 x64 Enterprise 和 Windows Server 2008 x64 Enterprise（不带 Hyper-V）1,2

内存

RAM：

  • 最小：512 MB

  • 建议：2.048 GB 或更大的内存

  • 最大：操作系统最大内存

1在 WOW64 中支持管理工具，WOW64 是 Microsoft Windows 64 位版本中的一项功能，该功能允许以本机方式在 32 位模式下执行 32 位应用程序。尽管基础操作系统在 64 位操作系统上运行，但应用程序以 32 位模式工作。

2 Windows Server 2008 Server Core 安装不支持 SQL Server 2008。

SQL Server 2008 Enterprise（32 位）

下表列出了 SQL Server 2008 Enterprise（32 位）的系统要求：

组件 要求

处理器

处理器类型：

  • Pentium III 兼容处理器或速度更快的处理器

处理器速度：

  • 最低：1.0 GHz

  • 建议：2.0 GHz 或速度更快的处理器

操作系统

Windows XP Professional SP21

Windows XP SP2 Tablet1

Windows XP SP2 Media Center 20021

Windows XP SP2 Media Center 20041

Windows XP Media Center 20051

Windows XP Professional Reduced Media1

Windows Server 2003 Small Business Server R2 Standard

Windows Server 2003 Small Business Server R2 Premium

Windows Server 2003 SP2 Standard

Windows Server 2003 SP2 Enterprise

Windows Server 2003 SP2 Data Center

Windows Server 2003 Small Business Server SP2 Standard

Windows Server 2003 Small Business Server SP2 Premium

Windows Server 2003 SP2 64 位 x64 Standard2

Windows Server 2003 SP2 64 位 x64 Data Center2

Windows Server 2003 SP2 64 位 x64 Enterprise2

Windows Vista Ultimate1

Windows Vista Home Premium1

Windows Vista Home Basic1

Windows Vista Enterprise1

Windows Vista Business1

Windows Vista 64 位 x64 Ultimate1,2

Windows Vista 64 位 x64 Home Premium1,2

Windows Vista 64 位 x64 Home Basic1,2

Windows Vista 64 位 x64 Enterprise1,2

Windows Vista 64 位 x64 Business1,2

Windows Server 2008 Standard（带和不带 Hyper-V）

Windows Server 2008 Web

Windows Server 2008 Data Center

Windows Server 2008 Data Center（不带 Hyper-V）

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise（不带 Hyper-V）

Windows Server 2008 x64 Standard

Windows Server 2008 x64 Standard（不带 Hyper-V）2

Windows Server 2008 x64 Data Center

Windows Server 2008 x64 Data Center（不带 Hyper-V）2

Windows Server 2008 x64 Enterprise

Windows Server 2008 x64 Enterprise（不带 Hyper-V）2

内存

RAM：

  • 最小：512 MB

  • 建议：2.048 GB 或更大的内存

  • 最大：操作系统最大内存

1此版本的 Windows 支持 SQL Server 2008 Enterprise Evaluation，不支持 Enterprise。

2此版本的 SQL Server 可以安装到 64 位服务器的 Windows on Windows (WOW64) 32 位子系统中。

SQL Server 2008 Standard（32 位）

下表列出了 SQL Server 2008 Standard（32 位）的系统要求：

组件 要求

处理器

处理器类型：

  • Pentium III 兼容处理器或速度更快的处理器

处理器速度：

  • 最低：1.0 GHz

  • 建议：2.0 GHz 或速度更快的处理器

操作系统

Windows XP Professional SP2

Windows XP SP2 Tablet

Windows XP x64 Professional 20031

Windows XP SP2 Media Center 2002

Windows XP SP2 Media Center 2004

Windows XP Media Center 2005

Windows XP Professional Reduced Media

Windows Server 2003 Small Business Server R2 Standard

Windows Server 2003 Small Business Server R2 Premium

Windows Server 2003 SP2 Standard

Windows Server 2003 SP2 Enterprise

Windows Server 2003 SP2 Data Center

Windows Server 2003 SP2 Small Business Server Standard

Windows Server 2003 SP2 Small Business Server Premium

Windows Server 2003 SP2 64 位 x64 Standard1

Windows Server 2003 SP2 64 位 x64 Data Center1

Windows Server 2003 SP2 64 位 x64 Enterprise1

Windows Vista Ultimate

Windows Vista Enterprise

Windows Vista Business

Windows Vista Ultimate x641

Windows Vista Enterprise x641

Windows Vista Business x641

Windows Server 2008 Web

Windows Server 2008 Standard Server

Windows Server 2008 Standard Server（不带 Hyper-V）

Windows Server 2008 Data Center

Windows Server 2008 Data Center（不带 Hyper-V）

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise（不带 Hyper-V）

Windows Server 2008 x64 Standard

Windows Server 2008 x64 Standard（不带 Hyper-V）1

Windows Server 2008 x64 Data Center

Windows Server 2008 x64 Data Center（不带 Hyper-V）1

Windows Server 2008 x64 Enterprise

Windows Server 2008 x64 Enterprise（不带 Hyper-V）1

内存

RAM：

  • 最小：512 MB

  • 建议：2.048 GB 或更大的内存

  • 最大：操作系统最大内存

1此版本的 SQL Server 可以安装到 64 位服务器的 Windows on Windows (WOW64) 32 位子系统中。

专业版（64 位和 32 位）

SQL Server 2008 Developer（64 位）IA64

下表列出了 SQL Server 2008 Developer（64 位）IA64 的系统要求。请注意，此版本的 SQL Server 2008 在以下本地化版本中不可用：意大利语、西班牙语、葡萄牙语（巴西）或俄语。

组件 要求

处理器

处理器类型：

  • 最低：Itanium 处理器或速度更快的处理器

处理器速度：

  • 最低：1.0 GHz 或速度更快的处理器

操作系统

Windows Server 2003 SP2 64 位 Itanium Data Center2

Windows Server 2003 SP2 64 位 Itanium Enterprise2

Windows Server 2008 64 位 Itanium Edition2

内存

RAM：

  • 最小：512 MB

  • 建议：2.048 GB 或更大的内存

  • 最大：操作系统最大内存

2在 WOW64 中支持管理工具，WOW64 是 Microsoft Windows 64 位版本中的一项功能，该功能允许以本机方式在 32 位模式下执行 32 位应用程序。尽管基础操作系统在 64 位操作系统上运行，但应用程序以 32 位模式工作。

4 Windows Server 2008 Server Core 安装不支持 SQL Server 2008。

SQL Server 2008 Developer（64 位）x64

下表列出了 SQL Server 2008 Developer（64 位）x64 的系统要求：

组件 要求

处理器

处理器类型：

  • 最低：AMD Opteron、AMD Athlon 64、支持 Intel EM64T 的 Intel Xeon 和支持 EM64T 的 Intel Pentium IV

处理器速度：

  • 最低：1.4 GHz

  • 建议：2.0 GHz 或速度更快的处理器

操作系统

Windows XP x64 Professional 2003

Windows Server 2003 SP2 64 位 x64 Standard2

Windows Server 2003 SP2 64 位 x64 Data Center2

Windows Server 2003 SP2 64 位 x64 Enterprise2

Windows Vista Ultimate x64

Windows Vista Home Premium x64

Windows Vista Home Basic x64

Windows Vista Enterprise x64

Windows Vista Business x64

Windows Server 2008 64 位 x64 Standard 和 Windows Server 2008 64 位 x64 Standard（不带 Hyper-V）2

Windows Server 2008 64 位 x64 Data Center 和 Windows Server 2008 64 位 x64 Data Center（不带 Hyper-V）2

Windows Server 2008 64 位 x64 Enterprise 和 Windows Server 2008 64 位 x64 Enterprise（不带 Hyper-V）2

Windows Server 2008 x64 Web2

内存

RAM：

  • 最小：512 MB

  • 建议：2.048 GB 或更大的内存

  • 最大：操作系统最大内存

2在 WOW64 中支持管理工具，WOW64 是 Microsoft Windows 64 位版本中的一项功能，该功能允许以本机方式在 32 位模式下执行 32 位应用程序。尽管基础操作系统在 64 位操作系统上运行，但应用程序以 32 位模式工作。

4 Windows Server 2008 Server Core 安装不支持 SQL Server 2008。

SQL Server 2008 Workgroup（64 位）x64

下表列出了 SQL Server 2008 Workgroup（64 位）x64 的系统要求：

组件 要求

处理器

处理器类型：

  • 最低：AMD Opteron、AMD Athlon 64、支持 Intel EM64T 的 Intel Xeon 和支持 EM64T 的 Intel Pentium IV

处理器速度：

  • 最低：1.4 GHz

  • 建议：2.0 GHz 或速度更快的处理器

操作系统

Windows XP x64 Professional 2003

Windows Server 2003 SP2 64 位 x64 Standard2

Windows Server 2003 SP2 64 位 x64 Data Center2

Windows Server 2003 SP2 64 位 x64 Enterprise2

Windows Vista Ultimate x64

Windows Vista Home Premium x64

Windows Vista Home Basic x64

Windows Vista Enterprise x64

Windows Vista Business x64

Windows Server 2008 x64 Web2

Windows Server 2008 64 位 x64 Standard 和 Windows Server 2008 64 位 x64 Standard（不带 Hyper-V）2

Windows Server 2008 64 位 x64 Data Center 和 Windows Server 2008 64 位 x64 Data Center（不带 Hyper-V）2

Windows Server 2008 64 位 x64 Enterprise 和 Windows Server 2008 64 位 x64 Enterprise（不带 Hyper-V）2

内存

RAM：

  • 最小：512 MB

  • 建议：2.048 GB 或更大的内存

  • 最大：操作系统最大内存

2在 WOW64 中支持管理工具，WOW64 是 Microsoft Windows 64 位版本中的一项功能，该功能允许以本机方式在 32 位模式下执行 32 位应用程序。尽管基础操作系统在 64 位操作系统上运行，但应用程序以 32 位模式工作。

4 Windows Server 2008 Server Core 安装不支持 SQL Server 2008。

SQL Server 2008 Web（64 位）x64

下表列出了 SQL Server 2008 Web（64 位）x64 的系统要求：

组件 要求

处理器

处理器类型：

  • 最低：AMD Opteron、AMD Athlon 64、支持 Intel EM64T 的 Intel Xeon 和支持 EM64T 的 Intel Pentium IV

处理器速度：

  • 最低：1.4 GHz

  • 建议：2.0 GHz 或速度更快的处理器

操作系统

Windows XP x64 Professional 2003

Windows Server 2003 SP2 64 位 x64 Standard2

Windows Server 2003 SP2 64 位 x64 Data Center2

Windows Server 2003 SP2 64 位 x64 Enterprise2

Windows Vista Ultimate x64

Windows Vista Enterprise x64

Windows Vista Business x64

Windows Server 2008 x64 Web

Windows Server 2008 x64 Standard 和 Windows Server 2008 x64 Standard（不带 Hyper-V）2

Windows Server 2008 x64 Data Center 和 Windows Server 2008 x64 Data Center（不带 Hyper-V）2

Windows Server 2008 x64 Enterprise 和 Windows Server 2008 x64 Enterprise（不带 Hyper-V）2

内存

RAM：

  • 最小：512 MB

  • 建议：2.048 GB 或更大的内存

  • 最大：操作系统最大内存

2在 WOW64 中支持管理工具，WOW64 是 Microsoft Windows 64 位版本中的一项功能，该功能允许以本机方式在 32 位模式下执行 32 位应用程序。尽管基础操作系统在 64 位操作系统上运行，但应用程序以 32 位模式工作。

4 Windows Server 2008 Server Core 安装不支持 SQL Server 2008。

SQL Server 2008 Express Advanced（64 位）x64

下表列出了 SQL Server 2008 Express Advanced（64 位）x64 的系统要求：

组件 要求

处理器

处理器类型：

  • 最低：AMD Opteron、AMD Athlon 64、支持 Intel EM64T 的 Intel Xeon 和支持 EM64T 的 Intel Pentium IV

处理器速度：

  • 最低：1.4 GHz

  • 建议：2.0 GHz 或速度更快的处理器

操作系统

Windows Server 2003 x64

Windows Server 2003 SP2 64 位 x64 Standard1

Windows Server 2003 SP2 64 位 x64 Data Center1

Windows Server 2003 SP2 64 位 x64 Enterprise1

Windows Vista Ultimate x64

Windows Vista Home Premium x64

Windows Vista Home Basic x64

Windows Vista Enterprise x64

Windows Vista Business x64

Windows Server 2008 64 位 x64 Web1

Windows Server 2008 64 位 x64 Standard

Windows Server 2008 64 位 x64 Standard（不带 Hyper-V）1

Windows Server 2008 64 位 x64 Data Center

Windows Server 2008 64 位 x64 Data Center（不带 Hyper-V）1

Windows Server 2008 64 位 x64 Enterprise

Windows Server 2008 64 位 x64 Enterprise（不带 Hyper-V）1

内存

RAM：

  • 最小：512 MB

  • 建议：1 GB 或更大的内存

  • 最大：操作系统最大内存

2在 WOW64 中支持管理工具，WOW64 是 Windows 64 位版本中的一项功能，该功能允许以本机方式在 32 位模式下执行 32 位应用程序。尽管基础操作系统在 64 位操作系统上运行，但应用程序以 32 位模式工作。

SQL Server Developer（32 位）

下表列出了 SQL Server 2008 Developer（32 位）的系统要求：

组件 要求

处理器

处理器类型：

  • Pentium III 兼容处理器或速度更快的处理器

处理器速度：

  • 最低：1.0 GHz

  • 建议：2.0 GHz 或速度更快的处理器

操作系统

Windows XP Home Edition SP2

Windows XP Professional SP2

Windows XP Tablet SP2

Windows XP Professional x64 SP21

Windows XP SP2 Media Center 2002

Windows XP SP2 Media Center 2004

Windows XP Media Center 2005

Windows XP Professional Reduced Media

Windows XP Home Edition Reduced Media

Windows Server 2003 Small Business Server R2 Standard

Windows Server 2003 Small Business Server R2 Premium

Windows Server 2003 SP2 Standard

Windows Server 2003 SP2 Enterprise

Windows Server 2003 SP2 Data Center

Windows Server 2003 SP2 Small Business Server Standard

Windows Server 2003 SP2 Small Business Server Premium

Windows Server 2003 SP2 64 位 x64 Standard2

Windows Server 2003 SP2 64 位 x64 Data Center2

Windows Server 2003 SP2 64 位 x64 Enterprise2

Windows Vista Ultimate

Windows Vista Home Premium

Windows Vista Home Basic

Windows Vista Starter Edition

Windows Vista Enterprise

Windows Vista Business

Windows Vista Ultimate 64 位 x642

Windows Vista Home Premium 64 位 x642

Windows Vista Home Basic 64 位 x642

Windows Vista Enterprise 64 位 x642

Windows Vista Business 64 位 x642

Windows Server 2008 Web

Windows Server 2008 Standard

Windows Server 2008 Standard（不带 Hyper-V）

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise（不带 Hyper-V）

Windows Server 2008 Data Center

Windows Server 2008 Data Center（不带 Hyper-V）

Windows Server 2008 64 位 x64 Standard

Windows Server 2008 64 位 x64 Standard（不带 Hyper-V）2

Windows Server 2008 Data Center

Windows Server 2008 Data Center（不带 Hyper-V）2

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise（不带 Hyper-V）2

内存

RAM：

  • 最小：512 MB

  • 建议：2.048 GB 或更大的内存

  • 最大：操作系统最大内存

1此版本的 SQL Server 2008 可以安装到 64 位服务器的 Windows on Windows (WOW64) 32 位子系统中。

2 Windows Server 2008 Server Core 安装不支持 SQL Server 2008。

SQL Server Workgroup（32 位）

下表列出了 SQL Server 2008 Workgroup（32 位）的系统要求：

组件 要求

处理器

处理器类型：

  • Pentium III 兼容处理器或速度更快的处理器

处理器速度：

  • 最低：1.0 GHz

  • 建议：2.0 GHz 或速度更快的处理器

操作系统

Windows XP Professional SP2

Windows XP SP2 Tablet

Windows XP Professional 64 位 x643

Windows XP SP2 Media Center 2002

Windows XP SP2 Media Center 2004

Windows XP Media Center 2005

Windows XP Professional Reduced Media

Windows Server 2003 Small Business Server R2 Standard

Windows Server 2003 Small Business Server R2 Premium

Windows Server 2003 SP2 Standard

Windows Server 2003 SP2 Enterprise

Windows Server 2003 SP2 Data Center

Windows Server 2003 SP2 Small Business Server Standard

Windows Server 2003 SP2 Small Business Server Premium

Windows Server 2003 64 位 x64 Standard3

Windows Server 2003 64 位 x64 Data Center3

Windows Server 2003 64 位 x64 Enterprise3

Windows Vista Vista Ultimate

Windows Vista Enterprise

Windows Vista Business

Windows Vista 64 位 x64 Ultimate3

Windows Vista 64 位 x64 Enterprise3

Windows Vista 64 位 x64 Business3

Windows Server 2008 2008 Web

Windows Server 2008 Standard

Windows Server 2008 Standard（不带 Hyper-V）

Windows Server 2008 Data Center

Windows Server 2008 Data Center（不带 Hyper-V）

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise（不带 Hyper-V）

Windows Server 2008 64 位 x64 Standard

Windows Server 2008 64 位 x64 Standard（不带 Hyper-V）3

Windows Server 2008 64 位 x64 Data Center

Windows Server 2008 64 位 x64 Data Center（不带 Hyper-V）3

Windows Server 2008 64 位 x64 Enterprise

Windows Server 2008 64 位 x64 Enterprise（不带 Hyper-V）3

内存

RAM：

  • 最小：512 MB

  • 建议：2.048 GB 或更大的内存

  • 最大：操作系统最大内存

3此版本的 SQL Server 2008 可以安装到 64 位服务器的 Windows on Windows (WOW64) 32 位子系统中。

5 Windows Server 2008 Server Core 安装不支持 SQL Server 2008。

SQL Server Web（32 位）

下表列出了 SQL Server 2008 Web（32 位）的系统要求：

组件 要求

处理器

处理器类型：

  • Pentium III 兼容处理器或速度更快的处理器

处理器速度：

  • 最低：1.0 GHz

  • 建议：2.0 GHz 或速度更快的处理器

操作系统

Windows XP Professional SP2

Windows XP SP2 Tablet

Windows XP Professional XP x643

Windows XP SP2 Media Center 2002

Windows XP SP2 Media Center 2004

Windows XP Media Center 2005

Windows XP Professional Reduced Media

Windows Server 2003 Small Business Server R2 Standard

Windows Server 2003 Small Business Server R2 Premium

Windows Server 2003 SP2 Standard

Windows Server 2003 SP2 Enterprise

Windows Server 2003 SP2 Data Center

Windows Server 2003 SP2 Small Business Server Standard

Windows Server 2003 SP2 Small Business Server Premium

Windows Server 2003 SP2 64 位 x64 Standard3

Windows Server 2003 SP2 64 位 x64 Data Center3

Windows Server 2003 SP2 64 位 x64 Enterprise3

Windows Vista Ultimate

Windows Vista Enterprise

Windows Vista Business

Windows Vista Ultimate x643

Windows Vista Enterprise x643

Windows Vista Business x643

Windows Server 2008 Web

Windows Server 2008 Standard Server

Windows Server 2008 Standard Server（不带 Hyper-V）

Windows Server 2008 Data Center

Windows Server 2008 Data Center（不带 Hyper-V）

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise（不带 Hyper-V）

Windows Server 2008 x64 Standard

Windows Server 2008 x64 Standard（不带 Hyper-V）3

Windows Server 2008 x64 Data Center

Windows Server 2008 x64 Data Center（不带 Hyper-V）3

Windows Server 2008 x64 Enterprise

Windows Server 2008 x64 Enterprise（不带 Hyper-V）3

内存

RAM：

  • 最小：512 MB

  • 建议：2.048 GB 或更大的内存

  • 最大：操作系统最大内存

3此版本的 SQL Server 2008 可以安装到 64 位服务器的 Windows on Windows (WOW64) 32 位子系统中。

5 Windows Server 2008 Server Core 安装不支持 SQL Server 2008。

SQL Server Express（32 位）和 Express with Advanced Services（32 位）

下表列出了 SQL Server 2008 Express（32 位）和 Express with Advanced Services（32 位）的系统要求：

组件 要求

处理器

处理器类型：

  • Pentium III 兼容处理器或速度更快的处理器

处理器速度：

  • 最低：1.0 GHz

  • 建议：2.0 GHz 或速度更快的处理器

操作系统

Windows XP SP2 Home

Windows XP SP2 Professional

Windows XP SP2 Tablet

Windows XP SP2 Media Center 2002

Windows XP SP2 Media Center 2004

Windows XP Media Center 2005

Windows Server 2003 Reduced Media

Windows XP Home Edition Reduced Media

Windows Server 2003 Small Business Server R2 Standard

Windows Server 2003 Small Business Server R2 Premium

Windows Server 2003 SP2 Standard

Windows Server 2003 2003 SP2 Enterprise

Windows Server 2003 SP2 Data Center

Windows Server 2003 SP2 Web Edition

Windows Server 2003 SP2 Small Business Server Standard

Windows Server 2003 SP2 Small Business Server Premium

Windows Server 2003 SP2 64 位 x64 Standard3

Windows Server 2003 SP2 64 位 x64 Data Center3

Windows Server 2003 SP2 64 位 x64 Enterprise3

Windows Vista Ultimate

Windows Vista Home Premium

Windows Vista Home Basic

Windows Vista Enterprise

Windows Vista Business

Windows Vista Ultimate 64 位 x648

Windows Vista Home Premium 64 位 x648

Windows Vista Home Basic 64 位 x648

Windows Vista Enterprise 64 位 x648

Windows Vista Business 64 位 x648

Windows Server 2008 Standard Server

Windows Server 2008 Standard Server（不带 Hyper-V）

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise（不带 Hyper-V）

Windows Server 2008 Data Center

Windows Server 2008 Data Center（不带 Hyper-V）

Windows Server 2008 Web Edition

Windows Server 2008 64 位 x64 Web Edition3

Windows Server 2008 64 位 x64 Standard

Windows Server 2008 64 位 x64 Standard（不带 Hyper-V）3

Windows Server 2008 64 位 x64 Data Center

Windows Server 2008 64 位 x64 Data Center（不带 Hyper-V）3

Windows Server 2008 64 位 x64 Enterprise

Windows Server 2008 64 位 x64 Enterprise（不带 Hyper-V）3

Windows XP Embedded SP2 功能包 2007 7

Windows Embedded for Point of Service SP27

内存

RAM：

  • 最小：256 MB

  • 建议：1.024 GB 或更大的内存

  • 最大：操作系统最大内存

3此版本的 SQL Server 2008 可以安装到 64 位服务器的 Windows on Windows (WOW64) 32 位子系统中。

5 Windows Server 2008 Server Core 安装不支持 SQL Server 2008。

6 Windows Server 2003 R2 与 Windows Server 2003 SP2 对 SQL Server 2008 的支持相同。

7支持 SQL Server 2008 Express，不支持 SQL Server 2008 Express with Advanced Services。

8 SQL Server 2008 Express Advanced 可以安装到使用此操作系统的 64 位服务器的 Windows on Windows (WOW64) 32 位子系统中。

SQL Server 2008 Express x64（64 位）

下表列出了 SQL Server 2008 Express x64（64 位）的系统要求：

组件 要求

处理器

处理器类型：

  • 最低：AMD Opteron、AMD Athlon 64、支持 Intel EM64T 的 Intel Xeon 和支持 EM64T 的 Intel Pentium IV

处理器速度：

  • 最低：1.4 GHz

  • 建议：2.0 GHz 或速度更快的处理器

操作系统

Windows Server 2003 x64

Windows Server 2003 SP2 64 位 x64 Standard

Windows Server 2003 SP2 64 位 x64 Data Center

Windows Server 2003 SP2 64 位 x64 Enterprise

Windows Vista Ultimate x64

Windows Vista Home Premium x64

Windows Vista Home Basic x64

Windows Vista Enterprise x64

Windows Vista Business x64

Windows Server 2008 64 位 x64 Web

Windows Server 2008 64 位 x64 Standard

Windows Server 2008 64 位 x64 Standard（不带 Hyper-V）

Windows Server 2008 64 位 x64 Data Center

Windows Server 2008 64 位 x64 Data Center（不带 Hyper-V）

Windows Server 2008 64 位 x64 Enterprise

Windows Server 2008 64 位 x64 Enterprise（不带 Hyper-V）

内存

RAM：

  • 最小：256 MB

  • 建议：1.024 GB 或更大的内存

  • 最大：操作系统最大内存

2在 WOW64 中支持管理工具，WOW64 是 Microsoft Windows 64 位版本中的一项功能，该功能允许以本机方式在 32 位模式下执行 32 位应用程序。尽管基础操作系统在 64 位操作系统上运行，但应用程序以 32 位模式工作。

4 Windows Server 2008 Server Core 安装不支持 SQL Server 2008。

跨语言支持

  • 支持的所有本地化版本的操作系统均支持 SQL Server 2008 英文版。

  • 与 SQL Server 2008 本地化版本使用同一语言的本地化操作系统支持 SQL Server 2008 的本地化版本。

  • SQL Server 的本地化版本可以升级到同一语言的 SQL Server 2008 本地化版本。

  • SQL Server 的本地化版本不能升级到 SQL Server 2008 英文版。

  • SQL Server 的本地化版本不能升级到其他本地化语言的 SQL Server 2008 本地化版本。

  • 通过使用 Windows 多语言用户界面包 (MUI) 设置，在支持的英文版操作系统上还支持 SQL Server 2008 的本地化版本。不过，在运行使用非英文 MUI 设置的英文版操作系统的服务器上安装 SQL Server 2008 的本地化版本之前，必须先检查某些操作系统设置。必须检查以下操作系统设置是否与要安装的 SQL Server 2008 的语言匹配：

    • 操作系统用户界面设置

    • 操作系统用户区域设置

    • 系统区域设置

    如果这些操作系统设置与 SQL Server 本地化版本的语言不匹配，则必须在安装 SQL Server 2008 之前，正确设置这些操作系统设置。

扩展系统支持

SQL Server 2008 64 位版本支持扩展系统，也称作 Windows on Windows (WOW64)。WOW64 是 Windows 64 位版本中的一项功能，该功能允许以本机方式在 32 位模式下执行 32 位应用程序。尽管基础操作系统在 64 位操作系统上运行，但应用程序以 32 位模式工作。

硬盘空间要求（32 位和 64 位）

在安装 SQL Server 2008 的过程中，Windows Installer 会在系统驱动器中创建临时文件。在运行安装程序以安装或升级 SQL Server 之前，请检查系统驱动器中是否有至少 2.0 GB 的可用磁盘空间用来存储这些文件。即使在将 SQL Server 组件安装到非默认驱动器中时，此项要求也适用。

实际硬盘空间需求取决于系统配置和您决定安装的功能。下表提供了 SQL Server 2008 各组件对磁盘空间的要求：

功能 | 磁盘空间要求
数据库引擎和数据文件、复制以及全文搜索 | 280 MB
Analysis Services 和数据文件 | 90 MB
Reporting Services 和报表管理器 | 120 MB
Integration Services | 120 MB
客户端组件 | 850 MB
SQL Server 联机丛书和 SQL Server Compact 联机丛书 | 240 MB

在域控制器上安装 SQL Server

出于安全方面的考虑，Microsoft 建议您不要将 SQL Server 2008 安装在域控制器上。SQL Server 安装程序不会阻止在作为域控制器的计算机上进行安装，但存在以下限制：

  • 在 Windows Server 2003 上，SQL Server 服务可在域帐户或本地系统帐户下运行。

  • 在域控制器上，无法在本地服务帐户或网络服务帐户下运行 SQL Server 服务。

  • 将 SQL Server 安装到计算机上之后，无法将此计算机从域成员更改为域控制器。必须先卸载 SQL Server，然后才能将主机计算机更改为域控制器。

  • 将 SQL Server 安装到计算机上之后，无法将此计算机从域控制器更改为域成员。必须先卸载 SQL Server，然后才能将主机计算机更改为域成员。

  • 在群集节点用作域控制器的情况下，不支持 SQL Server 故障转移群集实例。

  • SQL Server 安装程序不能在只读域控制器上创建安全组或设置 SQL Server 服务帐户。在这种情况下，安装将失败。

支持的客户端（64 位）

在 Windows Server 2003（64 位）上，可以安装 SQL Server 2008 64 位客户端组件。

请参阅

参考

系统配置检查器的检查参数
SQL Server 2008 的版本和组件

概念

计划 SQL Server 安装
安装 SQL Server 的安全注意事项
SQL Server 2008 安装快速入门


系统配置检查器的检查参数

系统配置检查器的检查参数 |
 | 请参阅
计划 SQL Server 安装 >

在 SQL Server 安装过程中，系统配置检查器 (SCC) 会对将要安装 SQL Server 的计算机进行扫描。SCC 将检查会使安装无法成功 SQL Server 的情况。在安装程序启动 SQL Server 安装向导之前，SCC 会检索每个项的状态。然后，将检索结果与所需条件进行比较并提供如何排除妨碍性问题的指导。

其他规则主题

有关方案特定的安装规则，请参阅以下主题：

  • 功能安装规则

  • 升级和修复规则检查

  • 版本升级规则

  • 卸载规则

请参阅

参考

安装 SQL Server 2008 的硬件和软件要求
版本升级

概念

安装 SQL Server 的安全注意事项


安装 SQL Server 的安全注意事项

安装 SQL Server 的安全注意事项
计划 SQL Server 安装 >

安全对于每个产品和每家企业都很重要。遵循简单的最佳做法，可以避免很多安全漏洞。本主题讨论安装 SQL Server 前和安装 SQL Server 之后应考虑采用的一些最佳安全做法。功能的参考主题中包括了特定功能的安全指南。

安装 SQL Server 前的工作

设置服务器环境时，请遵循以下最佳做法：

  • 增强物理安全性

  • 使用防火墙

  • 隔离服务

  • 配置安全的文件系统

  • 禁用 NetBIOS 和服务器消息块

增强物理安全性

物理和逻辑隔离是构成 SQL Server 安全的基础。若要增强 SQL Server 安装的物理安全性，请执行以下任务：

  • 将服务器置于专门的房间，未经授权的人员不得入内。

  • 将数据库的宿主计算机置于受物理保护的场所，最好是上锁的机房，房中配备水灾检测和火灾检测监视系统或灭火系统。

  • 将数据库安装在公司 Intranet 的安全区域中，并且不得将 SQL Server 直接连接到 Internet。

  • 定期备份所有数据，并将备份存储在远离工作现场的安全位置。

使用防火墙

防火墙对于协助确保 SQL Server 安装的安全十分重要。若要使防火墙发挥最佳效用，请遵循以下指南：

  • 在服务器和 Internet 之间放置防火墙。启用防火墙。如果防火墙处于关闭状态，请将其开启。如果防火墙处于开启状态，请不要将其关闭。

  • 将网络分成若干安全区域，区域之间用防火墙分隔。先阻塞所有通信流量，然后有选择地只接受所需的通信。

  • 在多层环境中，使用多个防火墙创建屏蔽子网。

  • 如果在 Windows 域内部安装服务器，请将内部防火墙配置为允许使用 Windows 身份验证。

  • 如果应用程序使用分布式事务处理，可能必须要将防火墙配置为允许 Microsoft 分布式事务处理协调器 (MS DTC) 在不同的 MS DTC 实例之间进行通信。还需要将防火墙配置为允许在 MS DTC 和资源管理器（如 SQL Server）之间进行通信。

有关默认 Windows 防火墙设置的详细信息以及有关影响数据库引擎、Analysis Services、Reporting Services 和 Integration Services 的 TCP 端口的说明，请参阅配置 Windows 防火墙以允许 SQL Server 访问。

隔离服务

隔离服务可以降低风险，防止已受到危害的服务被用于危及其他服务。若要隔离服务，请考虑以下原则：

  • 在不同的 Windows 帐户下运行各自的 SQL Server 服务。对每个 SQL Server 服务，尽可能使用不同的低权限 Windows 或本地用户帐户。有关详细信息，请参阅设置 Windows 服务帐户。

配置安全的文件系统

使用正确的文件系统可提高安全性。对于 SQL Server 安装，应执行以下几项任务：

  • 使用 NTFS 文件系统 (NTFS)。NTFS 是 SQL Server 安装的首选文件系统，因为它比 FAT 文件系统更加稳定和更容易恢复。NTFS 还可以使用安全选项，例如文件和目录访问控制列表 (ACL) 和加密文件系统 (EFS) 文件加密。在安装期间，如果检测到 NTFS，SQL Server 将对注册表项和文件设置相应的 ACL。不应对这些权限做任何更改。SQL Server 的未来版本可能不支持在具有 FAT 文件系统的计算机上进行安装。

    注意：
    如果使用 EFS，则将在运行 SQL Server 的帐户的标识下加密数据库文件。只有此帐户才可解密文件。如果必须更改运行 SQL Server 的帐户，则应先在旧帐户下解密文件，然后在新帐户下将文件重新加密。

  • 对关键数据文件使用独立磁盘冗余阵列 (RAID)。

禁用 NetBIOS 和服务器消息块

外围网络中的服务器应禁用所有不必要的协议，包括 NetBIOS 和服务器消息块 (SMB)。

NetBIOS 使用以下端口：

  • UDP/137（NetBIOS 名称服务）

  • UDP/138（NetBIOS 数据报服务）

  • TCP/139（NetBIOS 会话服务）

SMB 使用以下端口：

  • TCP/139

  • TCP/445

Web 服务器和域名系统 (DNS) 服务器不需要 NetBIOS 或 SMB。在这些服务器上，禁用这两个协议可以减轻由用户枚举带来的威胁。

安装 SQL Server 后的工作

安装完成后，若要增强所安装的 SQL Server 软件的安全性，请遵循以下有关帐户和身份验证模式的最佳做法：

服务帐户

  • 使用尽可能低的权限运行 SQL Server 服务。

  • 将 SQL Server 服务与低特权 Windows 本地用户帐户或域用户帐户相关联。

  • 有关详细信息，请参阅设置 Windows 服务帐户。

身份验证模式

  • 连接 SQL Server 时要求 Windows 身份验证。

强密码

  • 始终为 sa 帐户分配强密码。

  • 始终启用密码策略检查来验证密码强度以及密码是否过期。

  • 始终对所有 SQL Server 登录名使用强密码。有关详细信息，请参阅 SQL Server 2008 Security Overview for Database Administrators（面向数据库管理员的 SQL Server 2008 安全概述）白皮书。


设置 Windows 服务帐户

设置 Windows 服务帐户 |
 | 请参阅
计划 SQL Server 安装 >

SQL Server 中的每个服务表示一个进程或一组进程，用于通过 Windows 管理 SQL Server 操作的身份验证。本主题介绍此 SQL Server 版本中服务的默认配置，以及可以在 SQL Server 安装过程中设置的 SQL Server 服务的配置选项。

安全说明：
始终用尽可能低的用户权限运行 SQL Server 服务。对 SQL Server 服务使用特定用户帐户或域帐户，而不是共享帐户。对不同的 SQL Server 服务使用单独的帐户。请不要向 SQL Server 服务帐户授予其他权限。将通过组成员身份授予权限或直接将权限授予服务 SID。

根据您决定安装的组件，SQL Server 安装程序将安装以下服务：

  • SQL Server Database Services - 用于 SQL Server 关系数据库引擎的服务。

  • SQL Server Agent - 执行作业、监视 SQL Server、激发警报以及允许自动执行某些管理任务。

    注意：
    由于 SQL Server 和 SQL Server Agent 在 Windows 中作为服务来运行，因此必须给 SQL Server 和 SQL Server Agent 指派 Windows 用户帐户。有关如何为每个服务自定义帐户信息的详细信息，请参阅如何安装 SQL Server 2008（安装程序）。

  • Analysis Services - 为商业智能应用程序提供联机分析处理 (OLAP) 和数据挖掘功能。

  • Reporting Services - 管理、执行、创建、计划和传递报表。

  • Integration Services - 为 Integration Services 包的存储和执行提供管理支持。

  • SQL Server Browser - 向客户端计算机提供 SQL Server 连接信息的名称解析服务。

  • 全文搜索 - 对结构化和半结构化数据的内容和属性快速创建全文索引，从而为 SQL Server 提供文档筛选和断字功能。

  • SQL Server Active Directory Helper - 在 Active Directory 中发布和管理 SQL Server 服务。

  • SQL Writer - 允许备份和还原应用程序，以便在 Volume Shadow Copy Service (VSS) 框架中进行操作。

本主题的其余内容分为下列几部分：

  • 配置服务启动类型

  • 对 SQL Server 服务使用启动帐户

  • 对 SQL Server 服务使用服务 SID

  • 辨别识别实例的服务和不识别实例的服务

  • 查看为 SQL Server 服务帐户授予的 NT 权限和特权

  • 查看为 SQL Server 服务帐户创建的访问控制列表

  • 查看 SQL Server 服务的 Windows 权限

  • 查看其他注意事项

  • 本地化的服务名称

配置服务启动类型

在 SQL Server 安装过程中，您可以为某些 SQL Server 服务配置以下启动类型：已禁用、手动或自动。下表列出了可以在安装过程中配置的 SQL Server 服务。对于无人参与的安装，可以在配置文件中或在命令提示符下使用开关。

SQL Server 服务名称 | 是否可在安装向导中配置？ | 无人参与安装的开关1
MSSQLSERVER | 是 | SQLACCOUNT、SQLPASSWORD、SQLAUTOSTART
SQLServerAgent2 | 是 | AGTACCOUNT、AGTPASSWORD、AGTAUTOSTART
MSSQLServerOLAPService | 是 | ASACCOUNT、ASPASSWORD、ASAUTOSTART
ReportServer | 是 | RSACCOUNT、RSPASSWORD、RSAUTOSTART
Integration Services | 是 | ISSVSAccount、ISSVCPassword 和 ISSVCStartupType

1有关无人参与安装的详细信息和示例语法，请参阅如何从命令提示符安装 SQL Server 2008。

2在 SQL Server Express 实例和 SQL Server Express with Advanced Services 实例上 SQL Server Agent 服务已禁用。

对 SQL Server 服务使用启动帐户

若要启动并运行 SQL Server 中的服务，则每个服务都必须有一个在安装过程中配置的用户帐户。用户帐户可以是内置系统帐户、本地用户帐户或域用户帐户。

除具有用户帐户外，每个服务还有用户可控制的三种可能的启动状态：

  • 已禁用 服务已安装但当前未运行。

  • 手动 服务已安装，但仅当另一个服务或应用程序需要该服务的功能时才启动。

  • 自动 服务由操作系统自动启动。

下表显示了每个 SQL Server 服务的可选帐户，以及每个服务的启动状态。

SQL Server 服务名称 | 可选帐户 | 启动类型 | 安装后的默认状态
SQL Server | SQL Server Express：Domain User、Local System、Network Service1 所有其他版本：Domain User、Local System、Network Service1 | 自动2 | 已启动 仅当用户选择不自动启动时才停止
SQL Server Agent | Domain User、Local System、Network Service1 | 手动3 仅当用户选择自动启动时才成为“自动” | 已停止 仅当用户选择自动启动时才启动
Analysis Services | Domain User、Network Service、Local Service 和 Local System | 自动 | 已启动 仅当用户选择不自动启动时才停止
Reporting Services | Domain User、Local System、Network Service、Local Service | 自动 | 已启动 仅当用户选择不自动启动时才停止
Integration Services | Domain User、Local System、Network Service、Local Service | 自动 | 已启动 仅当用户选择不自动启动时才停止。
Full-Text Search | 使用与 SQL Server 服务的帐户不同的帐户。 在 Windows Server 2008 和 Windows Vista 上，该帐户将默认为 Local Service。 | 自动 | 已启动 仅当在 Windows Server 2003 或 Windows XP 上未指定任何帐户时，该服务才停止。
SQL Server Browser | Local Service | 已禁用4 仅当用户选择自动启动时才成为“自动”。 | 已停止 仅当用户选择自动启动时才启动。
SQL Server Active Directory Helper | Local System、Network Service | 已禁用 | 已停止
SQL Writer | Local System | 自动 | 已启动

1 重要提示 建议您不要将 Network Service 帐户用于 SQL Server 服务。Network Service 为可共享帐户，仅当您能够确保计算机上未安装使用该帐户的任何其他服务时，该帐户才适合用作 SQL Server 服务帐户。非 Windows 管理员的 Domain User 帐户更适用于 SQL Server 服务。请注意，SQL Server Agent 不支持 Local Service 帐户。

2在故障转移群集配置中设置为手动。

3在 SQL Server Express 实例和 SQL Server Express with Advanced Services 实例上 SQL Server Agent 服务已禁用。

4默认情况下，对于故障转移群集安装和命名实例，SQL Server Browser 设置为在安装程序完成后自动启动。

使用域用户帐户

如果服务必须与网络服务进行交互，则访问类似文件共享的域资源；如果服务使用到运行 SQL Server 的其他计算机的链接服务器链接，则可以使用具有最低特权的域服务器帐户。许多服务器到服务器的活动只能使用域用户帐户来执行。

使用 Local Service 帐户

Local Service 帐户是一个内置帐户，与 Users 组的成员具有相同级别的资源和对象访问权限。如果有个别服务或进程的安全性受到威胁，则此有限访问权限有助于保护系统的安全性。以 Local Service 帐户身份运行的服务将以一个没有凭据的 Null 会话形式访问网络资源。请注意，SQL Server 或 SQL Server Agent 服务不支持 Local Service 帐户。

使用本地用户帐户

如果计算机不在域中，则建议您使用不具有 Windows 管理员权限的本地用户帐户。

使用 Network Service 帐户

Network Service 帐户是一个内置帐户，比 Users 组的成员拥有更多的对资源和对象的访问权限。以 Network Service 帐户身份运行的服务将使用计算机帐户的凭据访问网络资源。

重要提示：
建议您不对 SQL Server 服务使用 Network Service 帐户。Network Service 为可共享帐户，仅当您能够确保计算机上未安装使用该帐户的任何其他服务时，该帐户才适合用作 SQL Server 服务帐户。

使用 Local System 帐户

将 Local System 权限授予 SQL Server 服务帐户时需谨慎。Local System 是一个具有极高特权的帐户。

对 SQL Server 服务配置使用 Service SID

服务安全 ID (SID) 在基于 Windows Server 2008 和 Windows Vista 操作系统上的 SQL Server 2008 中可用，以允许服务隔离。服务隔离可向服务提供一种访问特定对象的方法，使用这种方法既不用运行高特权帐户也不会削弱对象的安全保护。SQL Server 服务可以使用此标识限制其他服务或应用程序访问其资源。

服务可以通过使用包含服务 SID 的访问控制项对资源进行保护，从而将对象隔离起来，以供自己独占使用。此 per-service SID 派生自服务名称，且对于相应服务是唯一的，例如，SQL Server 服务的服务 SID 名称可能是 NT Service\MSSQL$<实例名>。对某个服务启用 SID 之后，该 SID 会添加到 Windows 的本地安全组中。服务所有者便可修改对象的访问控制列表，以提供访问该 SID 的权限。例如，通常 HKEY_LOCAL_MACHINE\SOFTWARE 中的注册表项仅对具有管理凭据的服务可用。将 per-service SID 添加到该注册表项的访问控制列表后，服务就能够在低特权帐户下运行，同时仍可以访问该注册表项。

在安装期间，SQL Server 安装程序会为 SQL Server 的每个组件创建一个服务组。在 Windows Server 2003 和 Windows XP 上，SQL Server 服务的服务帐户会添加到本地服务组中，它们在这些操作系统上的工作方式与其在 SQL Server 早期版本中的工作方式相同；SQL Server 服务会作为本地组的成员连接到 SQL Server 实例。在 Windows Server 2008 和 Windows Vista 上，添加到本地安全组的是服务 SID，而非 SQL Server 服务帐户。

支持的服务配置

在 Windows Server 2008 或 Windows Vista 域控制器上安装 SQL Server 2008 时需要向 SQL Server 服务提供服务 SID。在故障转移群集节点是域控制器的情况下，不支持 SQL Server 2008。下表显示了 Windows Server 2008 或 Windows Vista 上全新安装和升级安装的服务配置。

全新安装 升级
  • 独立实例 – 具有服务 SID 的服务组

  • 故障转移群集实例 – 服务 SID
  • 独立实例 – 具有服务 SID 的服务组

  • 故障转移群集实例 - 具有服务帐户的服务组

在 Windows Server 2003 或 Windows XP 域控制器上安装 SQL Server 2008 时，需要向 SQL Server 服务的域提供域帐户。如果故障转移群集节点是域控制器，则不支持 SQL Server 2008。下表显示了 Windows Server 2003 或 Windows XP 上的全新安装和升级安装的服务配置。

全新安装 升级
  • 独立实例 - 具有服务帐户的服务组

  • 故障转移群集实例 - 具有服务帐户的域服务组
  • 独立实例 - 具有服务帐户的服务组

  • 故障转移群集实例 - 具有服务帐户的服务组

更改用户帐户

若要更改任何与 SQL Server 相关的服务的服务帐户、密码、服务启动类型或其他属性，请使用 SQL Server 配置管理器。请注意，对 SQL Server 实例进行重命名时不会对 SQL Server 安全组重命名。完成重命名操作之后，安全组将继续使用其旧名称来工作。

辨别识别实例的服务和不识别实例的服务

识别实例的服务与特定 SQL Server 实例相关联，并具有自己的注册表配置单元。通过为每个组件或服务运行 SQL Server 安装程序，可以安装识别实例的服务的多个副本。不识别实例的服务由所有已安装的 SQL Server 实例共享。它们不与特定实例相关联，仅安装一次且不能并行安装。

SQL Server 中识别实例的服务包括：

  • SQL Server

  • SQL Server Agent

    请注意，在 SQL Server Express 实例和 SQL Server Express with Advanced Services 实例上 SQL Server Agent 服务已禁用。

  • Analysis Services

  • Reporting Services

  • Full-text search

SQL Server 中不识别实例的服务包括：

  • Integration Services

  • SQL Server Browser

  • SQL Server Active Directory Helper

  • SQL Writer

查看为 SQL Server 服务帐户授予的 Windows NT 权限和特权

SQL Server 安装程序为不同的 SQL Server 服务创建本地服务组，并根据需要向这些用户组添加服务帐户或服务 SID。这些组可以简化运行 SQL Server 服务和其他可执行文件所需权限的授予过程，并有助于增加 SQL Server 文件的安全性。对于 Windows Vista 和 Windows Server 2008 操作系统上的 SQL Server 独立实例，服务 SID 会自动添加到组。对于 Windows Server 2008 上的故障转移群集实例，安装程序不会创建默认用户组。相反，安装程序会通过服务 SID 将 SQL Server 资源添加到访问控制列表中。用户还可以使用域组和域帐户来运行 SQL Server 服务。请注意，为了利用域组，必须在运行 SQL Server 安装程序之前创建它们。

在域控制器上安装 SQL Server 时，服务组名称必须是唯一的，并且只有域帐户才能用于这些组。

下表显示了 SQL Server 安装程序创建的用户组以及授予它们的特定 Windows NT 用户权限。

SQL Server 服务 | 用户组 | SQL Server 安装程序授予的默认权限
SQL Server | 默认实例：SQLServerMSSQLUser$ComputerName$MSSQLSERVER 命名实例：SQLServerMSSQLUser$ComputerName$InstanceName | 以服务身份登录 (SeServiceLogonRight)1 以批处理作业身份登录 (SeBatchLogonRight) 替换进程级别标记 (SeAssignPrimaryTokenPrivilege) 跳过遍历检查 (SeChangeNotifyPrivilege) 调整进程的内存配额 (SeIncreaseQuotaPrivilege) 启动 SQL Server Active Directory Helper 的权限 启动 SQL Writer 的权限 读取事件日志服务的权限 读取远程过程调用服务的权限
SQL Server Agent3 | 默认实例：SQLServerSQLAgentUser$ComputerName$MSSQLSERVER 命名实例：SQLServerSQLAgentUser$ComputerName$InstanceName | 以服务身份登录 (SeServiceLogonRight) 以批处理作业身份登录 (SeBatchLogonRight) 替换进程级别标记 (SeAssignPrimaryTokenPrivilege) 跳过遍历检查 (SeChangeNotifyPrivilege) 调整进程的内存配额 (SeIncreaseQuotaPrivilege)
Analysis Services | 默认实例：SQLServerMSOLAPUser$ComputerName$MSSQLSERVER 命名实例：SQLServerMSOLAPUser$ComputerName$InstanceName | 以服务身份登录 (SeServiceLogonRight)
SSRS | 默认实例：SQLServerReportServerUser$计算机名$MSRS10.MSSQLSERVER 命名实例：SQLServerReportServerUser$计算机名$MSRS10.实例名 | 以服务身份登录 (SeServiceLogonRight)
Integration Services | 默认实例或命名实例：SQLServerDTSUser$ComputerName | 以服务身份登录 (SeServiceLogonRight) 应用程序事件日志的写入权限。 跳过遍历检查 (SeChangeNotifyPrivilege) 身份验证后模拟客户端 (SeImpersonatePrivilege)
Full-text search | 默认实例：SQLServerFDHostUser$计算机名称$MSSQL10.MSSQLSERVER 命名实例：SQLServerFDHostUser$计算机名称$MSSQL10.实例名 | 以服务身份登录 (SeServiceLogonRight)
SQL Server Browser | 默认实例或命名实例：SQLServerSQLBrowserUser$ComputerName | 以服务身份登录 (SeServiceLogonRight)
SQL Server Active Directory Helper | 默认实例或命名实例：SQLServerMSSQLServerADHelperUser$ComputerName | 无2
SQL Writer | 不适用 | 无2

1此权限默认可授予所有 SQL Server 服务。

2 SQL Server 安装程序不检查此服务或为其授予权限。

3在 SQL Server Express 实例和 SQL Server Express with Advanced Services 实例上 SQL Server Agent 服务已禁用。

查看为 SQL Server 服务帐户创建的访问控制列表

SQL Server 服务帐户必须具有对资源的访问权限。访问控制列表 (ACL) 是在用户组级别设置的。

重要提示：
对于故障转移群集安装，必须为本地帐户的 ACL 设置共享磁盘上的资源。

下表显示了 SQL Server 安装程序设置的 ACL：

服务帐户所属1 | 文件和文件夹 | 访问权限
MSSQLServer | Instid\MSSQL\backup | 完全控制
 | Instid\MSSQL\binn | 读取和执行
 | Instid\MSSQL\data | 完全控制
 | Instid\MSSQL\FTData | 完全控制
 | Instid\MSSQL\Install | 读取和执行
 | Instid\MSSQL\Log | 完全控制
 | Instid\MSSQL\Repldata | 完全控制
 | 100\shared | 读取和执行
 | Instid\MSSQL\Template Data（仅限 SQL Server Express） | 读取
SQLServerAgent2 | Instid\MSSQL\binn | 完全控制
 | Instid\MSSQL\binn | 完全控制
 | Instid\MSSQL\Log | 读取、写入、删除和执行
 | 100\com | 读取和执行
 | 100\shared | 读取和执行
 | 100\shared\Errordumps | 读取和写入
FTS | Instid\MSSQL\FTData | 完全控制
 | Instid\MSSQL\FTRef | 读取和执行
 | 100\shared | 读取和执行
 | 100\shared\Errordumps | 读取和写入
 | Instid\MSSQL\Install | 读取和执行
 | Instid\MSSQL\jobs | 读取和写入
MSSQLServerOLAPservice | 100\shared\ASConfig | 完全控制
 | Instid\OLAP | 读取和执行
 | Instid\Olap\Data | 完全控制
 | Instid\Olap\Log | 读取和写入
 | Instid\OLAP\Backup | 读取和写入
 | Instid\OLAP\Temp | 读取和写入
 | 100\shared\Errordumps | 读取和写入
SQLServerReportServerUser | Instid\Reporting Services\Log Files | 读取、写入、删除
 | Instid\Reporting Services\ReportServer | 读取和执行
 | Instid\Reportingservices\Reportserver\global.asax | 完全控制
 | Instid\Reportingservices\Reportserver\Reportserver.config | 读取
 | Instid\Reporting Services\reportManager | 读取和执行
 | Instid\Reporting Services\RSTempfiles | 读取、写入、执行、删除
 | 100\shared | 读取和执行
 | 100\shared\Errordumps | 读取和写入
MSDTSServer100 | 100\dts\binn\MsDtsSrvr.ini.xml | 读取
 | 100\dts\binn | 读取和执行
 | 100\shared | 读取和执行
 | 100\shared\Errordumps | 读取和写入
SQL Server Browser | 100\shared\ASConfig | 读取
 | 100\shared | 读取和执行
 | 100\shared\Errordumps | 读取和写入
MSADHelper | 不适用（在 Network Service 帐户下运行） |
SQLWriter | 不适用（以 Local System 身份运行） |
User | Instid\MSSQL\binn | 读取和执行
 | Instid\Reporting Services\ReportServer | 读取、执行和列出文件夹内容
 | Instid\Reportingservices\Reportserver\global.asax | 读取
 | Instid\Reporting Services\ReportManager | 读取和执行
 | Instid\Reporting Services\ReportManager\pages | 读取
 | Instid\Reporting Services\ReportManager\Styles | 读取
 | 100\dts | 读取和执行
 | 100\tools | 读取和执行
 | 90\tools | 读取和执行
 | 80\tools | 读取和执行
 | 100\sdk | 读取
 | Microsoft SQL Server\100\Setup Bootstrap | 读取和执行

1在某些情况下，例如执行故障转移群集和在域控制器上安装 SQL Server，将会为 SQL Server 服务 SID 设置 ACL，而不会为 SQL Server 服务设置 ACL。

2在 SQL Server Express 实例和 SQL Server Express with Advanced Services 实例上 SQL Server Agent 服务已禁用。

可能还必须向内置帐户或其他 SQL Server 服务帐户授予某些访问控制权限。下表列出了 SQL Server 安装程序设置的其他 ACL。

请求组件 | 帐户 | 资源 | 权限
MSSQLServer | 性能日志用户 | Instid\MSSQL\binn | 列出文件夹内容
 | 性能监视器用户 | Instid\MSSQL\binn | 列出文件夹内容
 | 性能日志用户、性能监视器用户 | \WINNT\system32\sqlctr100.dll | 读取和执行
 | 仅限于管理员 | \\.\root\Microsoft\SqlServer\ServerEvents\<sql_instance_name>1 | 完全控制
 | 管理员和系统 | \tools\binn\schemas\sqlserver\2003\03\showplan | 完全控制
 | 用户 | \tools\binn\schemas\sqlserver\2003\03\showplan | 读取和执行
Reporting Services | <报表服务器 Web 服务帐户> | <install>\Reporting Services\LogFiles | DELETE READ_CONTROL SYNCHRONIZE FILE_GENERIC_READ FILE_GENERIC_WRITE FILE_READ_DATA FILE_WRITE_DATA FILE_APPEND_DATA FILE_READ_EA FILE_WRITE_EA FILE_READ_ATTRIBUTES FILE_WRITE_ATTRIBUTES
 | 报表管理器应用程序池标识、ASP.NET 帐户、Everyone | <install>\Reporting Services\ReportManager、<install>\Reporting Services\ReportManager\Pages\*.*、<install>\Reporting Services\ReportManager\Styles\*.*、<install>\Reporting Services\ReportManager\webctrl_client\1_0\*.* | 读取
 | 报表管理器应用程序池标识 | <install>\Reporting Services\ReportManager\Pages\*.* | 读取
 | <报表服务器 Web 服务帐户> | <install>\Reporting Services\ReportServer | 读取
 | <报表服务器 Web 服务帐户> | <install>\Reporting Services\ReportServer\global.asax | 完全控制
 | Everyone | <install>\Reporting Services\ReportServer\global.asax | READ_CONTROL FILE_READ_DATA FILE_READ_EA FILE_READ_ATTRIBUTES
 | Network Service | <install>\Reporting Services\ReportServer\ReportService.asmx | 完全控制
 | Everyone | <install>\Reporting Services\ReportServer\ReportService.asmx | READ_CONTROL SYNCHRONIZE FILE_GENERIC_READ FILE_GENERIC_EXECUTE FILE_READ_DATA FILE_READ_EA FILE_EXECUTE FILE_READ_ATTRIBUTES
 | ReportServer Windows 服务帐户 | <install>\Reporting Services\ReportServer\RSReportServer.config | DELETE READ_CONTROL SYNCHRONIZE FILE_GENERIC_READ FILE_GENERIC_WRITE FILE_READ_DATA FILE_WRITE_DATA FILE_APPEND_DATA FILE_READ_EA FILE_WRITE_EA FILE_READ_ATTRIBUTES FILE_WRITE_ATTRIBUTES
 | Everyone | 报表服务器密钥（Instid 配置单元） | 查询值 枚举子项 通知 读取控制
 | 终端服务用户 | 报表服务器密钥（Instid 配置单元） | 查询值 设置值 创建子项 枚举子项 通知 删除 读取控制
 | 超级用户 | 报表服务器密钥（Instid 配置单元） | 查询值 设置值 创建子项 枚举子项 通知 删除 读取控制

1这是 WMI 提供程序命名空间。

查看 SQL Server 服务的 Windows 权限

下表显示了服务名称、用于指代 SQL Server 服务的默认实例和命名实例的术语、服务功能的说明以及所需的最低权限。

显示名称 服务名称 说明 所需权限

SQL Server (实例名)

默认实例：MSSQLSERVER

命名实例：MSSQL$实例名

SQL Server 数据库引擎。

可执行文件的路径为 \MSSQL\Binn\sqlservr.exe。

建议使用本地用户帐户或域用户帐户。

最低权限 功能

MSSQLServer 服务启动帐户

该帐户必须对安装 SQL Server 的根驱动器拥有“列出文件夹”权限。它还必须对存储 SQL Server 文件的任何其他驱动器的根目录也拥有此权限。

注意：
子文件夹不必继承根驱动器的“列出文件夹”权限。

MSSQLServer 服务启动帐户

该帐户必须对数据或日志文件（.mdf、.ndf、.ldf）将驻留的任何文件夹都拥有“完全控制”权限。

SQL Server Agent（实例名）1

默认实例：SQLServerAgent

命名实例：SQLAgent$实例名

执行作业、监视 SQL Server、激发警报以及允许自动执行某些管理任务。

可执行文件的路径为 \MSSQL\Binn\sqlagent.exe。

最低权限 | 功能
该帐户必须是 sysadmin 固定服务器角色的成员。 |
该帐户必须拥有以下 Windows 权限： | 以服务身份登录。 以批处理作业身份登录。 替换进程级别标记。 调整进程的内存配额。 跳过遍历检查。

Analysis Services 服务 (实例名)

默认实例：MSSQLServerOLAPService

命名实例：MSOLAP$InstanceName

为商业智能应用程序提供联机分析处理 (OLAP) 和数据挖掘功能的服务。

可执行文件的路径为 \OLAP\Bin\msmdsrv.exe。

Reporting Services

默认实例：ReportServer

命名实例：ReportServer$InstanceName

管理、执行、创建、计划和传递报表。

可执行文件的路径为 \Reporting Services\ReportServer\Bin\ReportingServicesService.exe。

Integration Services

默认实例或命名实例：MSDTSServer

为 Integration Services 包存储和执行提供管理支持。

可执行文件的路径为 \DTS\Binn\msdtssrvr.exe。

Full-text search

默认实例或命名实例：SQL 全文筛选器后台程序启动器

用于启动全文筛选器后台进程以为 SQL Server 全文搜索执行文档筛选和断字的服务。

SQL Server Browser

默认实例或命名实例：SQLBrowser

向客户端计算机提供 SQL Server 连接信息的名称解析服务。多个 SQL Server 和 SSIS 实例共享此服务。

可执行文件的路径为 <drive>:\Program Files\Microsoft SQL Server\100\Shared\sqlbrowser.exe。

SQL Server Active Directory Helper

默认实例或命名实例：MSSQLServerADHelper。

在 Windows Active Directory 中发布和管理 SQL Server 服务。

可执行文件的路径为 <drive>:\Program Files\Microsoft SQL Server\100\Shared\sqladhelper.exe。

SQL Writer

SQLWriter

允许备份和还原应用程序，以便在 Volume Shadow Copy Service 框架中进行操作。服务器上的所有 SQL Server 实例只有一个 SQL Writer 服务实例。

可执行文件的路径为 <drive>:\Program Files\Microsoft SQL Server\100\Shared\sqlwriter.exe。

1在 SQL Server Express 实例和 SQL Server Express with Advanced Services 实例上 SQL Server Agent 服务已禁用。

查看其他注意事项

下表显示了 SQL Server 服务提供其他功能时所需的权限：

服务/应用程序 | 功能 | 所需权限
SQL Server (MSSQLSERVER) | 使用 xp_sendmail 写入邮件槽。 | 网络写入权限。
SQL Server (MSSQLSERVER) | 运行用户的而不是 SQL Server 管理员的 xp_cmdshell。 | 充当操作系统的一部分以及替换进程级别标记。
SQL Server Agent (MSSQLSERVER) | 使用自动重新启动功能。 | 必须是本地 Administrators 组的成员。
数据库引擎优化顾问 | 优化数据库以获得最佳查询性能。 | 第一次使用时，拥有系统管理员权限的用户必须初始化该应用程序。初始化后，dbo 用户可使用数据库引擎优化顾问仅优化他们拥有的那些表。有关详细信息，请参阅 SQL Server 联机丛书中的“在第一次使用时初始化数据库引擎优化顾问”。
重要提示：
升级到 SQL Server 之前，请先为 SQL Server Agent 启用 Windows 身份验证，并验证所需的默认配置：SQL Server Agent 的服务帐户是否是 SQL Server sysadmin 组的成员。

本地化的服务名称

下表列出了 Windows 的本地化版本所显示的服务名称。

语言 | Local Service 的名称 | Network Service 的名称 | Local System 的名称 | Admin Group 的名称
英语 简体中文 繁体中文 朝鲜语 日语 | NT AUTHORITY\LOCAL SERVICE | NT AUTHORITY\NETWORK SERVICE | NT AUTHORITY\SYSTEM | BUILTIN\Administrators
德语 | NT-AUTORIT?T\LOKALER DIENST | NT-AUTORIT?T\NETZWERKDIENST | NT-AUTORIT?T\SYSTEM | VORDEFINIERT\Administratoren
法语 | AUTORITE NT\SERVICE LOCAL | AUTORITE NT\SERVICE RéSEAU | AUTORITE NT\SYSTEM | BUILTIN\Administrateurs
意大利语 | NT AUTHORITY\SERVIZIO LOCALE | NT AUTHORITY\SERVIZIO DI RETE | NT AUTHORITY\SYSTEM | BUILTIN\Administrators
西班牙语 | NT AUTHORITY\SERVICIO LOC | NT AUTHORITY\SERVICIO DE RED | NT AUTHORITY\SYSTEM | BUILTIN\Administradores
俄语 | NT AUTHORITY\LOCAL SERVICE | NT AUTHORITY\NETWORK SERVICE | NT AUTHORITY\SYSTEM | BUILTIN\Администраторы

请参阅

参考

数据库引擎配置 - 帐户设置
Analysis Services 配置 – 帐户设置

概念

安装 SQL Server 的安全注意事项
SQL Server 的默认实例和命名实例的文件位置


网络协议和网络库

网络协议和网络库 |
 | 请参阅
计划 SQL Server 安装 >

服务器可以同时监听或监视多个网络协议。但必须对每个协议都进行配置。如果没有配置某个协议，则服务器将无法监听该协议。安装完成后，可以使用 SQL Server 配置管理器更改这些协议配置。

默认 SQL Server 网络配置

SQL Server 的默认实例配置为采用 TCP/IP 端口 1433 和命名管道 \\.\pipe\sql\query。SQL Server 命名实例配置为采用 TCP 动态端口，其端口号由操作系统分配。

如果无法使用动态端口地址（例如，当 SQL Server 连接必须通过服务器配置为要通过特定端口地址的防火墙时，或者当某些连接是使用 SQL Server 7.0 或更早版本的客户端组件建立的时），则推荐使用小于 1024 的端口地址。请在此范围内，选择一个未被操作系统或其他应用程序使用的端口。

为了增强安全性，当安装 SQL Server 时不会完全启用网络连接。在安装完成后，若要启用、禁用和配置网络协议，请使用 SQL Server 配置管理器的 SQL Server 网络配置区域。

端点的类型

SQL Server 为 SQL Server 连接引入了一个新概念，在服务器端用“Transact-SQL 端点”来表示该连接。可以对 Transact-SQL 端点授予、撤消和拒绝权限。默认情况下，所有用户都具备访问端点的权限，除非 sysadmin 组的成员或端点所有者拒绝或撤消了此权限。GRANT、REVOKE 和 DENY ENDPOINT 语法使用管理员必须从端点的目录视图中获得的端点 ID。

SQL Server 安装程序将为所有支持的网络协议以及专用管理员连接创建 Transact-SQL 端点。

由 SQL Server 安装程序所创建的 Transact-SQL 端点如下：

  • Transact-SQL 本地计算机

  • Transact-SQL 命名管道

  • Transact-SQL 默认 TCP

  • Transact-SQL 默认 VIA

有关 Transact-SQL 端点的详细信息，请参阅 SQL Server 联机丛书中的“网络协议和 TDS 端点”。

有关 SQL Server 网络配置的详细信息，请参阅 SQL Server 联机丛书中的下列主题：

  • “服务器网络配置”

  • “配置服务器网络协议和网络库”

  • “默认的 SQL Server 网络配置”

  • “网络库和网络协议”

请参阅

概念

计划 SQL Server 安装

其他资源

了解外围应用配置器


SQL Server 的默认实例和命名实例的文件位置

SQL Server 的默认实例和命名实例的文件位置 |
 | 请参阅
计划 SQL Server 安装 >

安装 SQL Server 将安装一个或多个单独的实例。无论是默认实例还是命名实例都有自己的一组程序文件和数据文件，同时还有在计算机上的所有 SQL Server 实例之间共享的一组公共文件。

对于包含数据库引擎、Analysis Services 和 Reporting Services 的 SQL Server 实例，每个组件都有一套完整的数据文件和可执行文件，以及由所有组件共享的公共文件。

为了隔离每个组件的安装位置，将为给定 SQL Server 实例中的每个组件都生成一个唯一的实例 ID。

重要提示：
程序文件和数据文件不能安装在以下位置：可移动磁盘驱动器、使用压缩的文件系统、系统文件所在的目录以及故障转移群集实例上的共享驱动器。

请勿删除以下任何目录或其内容：Binn、Data、Ftdata、HTML 或 2052。如有必要，可以删除其他目录，但您可能无法检索丢失的功能或数据，除非卸载然后重新安装 SQL Server。请勿删除或修改 HTML 目录中的任何 .htm 文件。它们对于 SQL Server 工具的正常运行是必需的。

所有 SQL Server 实例的共享文件

单个计算机上的所有实例使用的公共文件安装在文件夹 <drive>:\Program Files\Microsoft SQL Server\100\ 中，其中 <drive> 是安装组件的驱动器的编号。通常为驱动器 C。

文件位置和注册表映射

SQL Server 安装过程中，为每个服务器组件生成一个实例 ID。此 SQL Server 版本中的服务器组件分别是数据库引擎、Analysis Services 和 Reporting Services。

使用以下格式构造默认实例 ID：

  • 对于数据库引擎采用的是 MSSQL，后跟主版本号和一个句点，然后是实例名。

  • 对于 Analysis Services 采用的是 MSAS，后跟主版本号和一个句点，然后是实例名。

  • 对于 Reporting Services 采用的是 MSRS，后跟主版本号和一个句点，然后是实例名。

此 SQL Server 版本中的默认实例 ID 的示例如下：

  • 对于默认 SQL Server 实例，为 MSSQL10.MSSQLSERVER。

  • 对于默认 Analysis Services 实例，为 MSAS10.MSSQLSERVER。

  • 对于名为“MyInstance”的 SQL Server 命名实例，为 MSSQL10.MyInstance。

包括数据库引擎和 Analysis Services 的 SQL Server 2008 命名实例（名为“MyInstance”并且按照默认目录安装）的目录结构如下所示：

  • C:\Program Files\Microsoft SQL Server\MSSQL10.MyInstance\

  • C:\Program Files\Microsoft SQL Server\ASSQL10.MyInstance\

可为实例 ID 指定任何值，但应避免使用特殊字符和保留关键字。有关详细信息，请参阅保留关键字（安装程序）。

在 SQL Server 安装期间可指定一个非默认实例 ID。如果用户选择更改默认安装目录，则不使用 <Program Files>\Microsoft SQL Server，而使用 <自定义路径>\Microsoft SQL Server。请注意，不支持以下划线 (_) 开头或者包含数字符号 (#) 或美元符号 ($) 的实例 ID。

注意：
Integration Services 和客户端组件是不识别实例的，因此不为它们指定实例 ID。默认情况下，将不识别实例的组件安装在单个目录 <drive>:\Program Files\Microsoft SQL Server\100\ 中。更改一个共享组件的安装路径会同时更改其他共享组件的安装路径。后续安装会将非实例识别组件安装到与原始安装相同的目录。

SQL Server Analysis Services 是支持在安装后重命名实例的唯一 SQL Server 组件。如果重命名 Analysis Services 实例，实例 ID 不会发生变化。重命名实例后，目录和注册表项将继续使用在安装期间创建的实例 ID。

将在 HKLM\Software\Microsoft\Microsoft SQL Server\<Instance_ID> 下为识别实例的组件创建注册表配置单元。例如，

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL10.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\ASSQL10.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.3

注册表还维护实例 ID 到实例名的映射。实例 ID 到实例名的映射按如下方式维护：

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL10"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"="ASSQL10"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="RSSQL10"

指定文件路径

安装过程中，可以更改下列功能的安装路径：

安装程序中仅显示具有用户可配置目标文件夹的功能的安装路径：

组件 | 默认路径1, 2 | 可配置路径3或固定路径
数据库引擎服务器组件 | \Program Files\Microsoft SQL Server\MSSQL10.<实例 ID>\ | 可配置
数据库引擎数据文件 | \Program Files\Microsoft SQL Server\MSSQL10.<实例 ID>\ | 可配置
Analysis Services 服务器 | \Program Files\Microsoft SQL Server\MSAS10.<实例 ID>\ | 可配置
Analysis Services 数据文件 | \Program Files\Microsoft SQL Server\MSAS10.<实例 ID>\ | 可配置
Reporting Services 报表服务器 | \Program Files\Microsoft SQL Server\MSRS10.<实例 ID>\Reporting Services\ReportServer\Bin\ | 可配置
Reporting Services 报表管理器 | \Program Files\Microsoft SQL Server\MSRS10.<实例 ID>\Reporting Services\ReportManager\ | 固定路径
Integration Services | <安装目录>\100\DTS\ | 可配置4
客户端组件 | <安装目录>\100\Tools\ | 可配置4
复制和服务器端 COM 对象 | <drive>:\Program Files\Microsoft SQL Server\100\COM\5 | 固定路径
用于数据转换运行时引擎、数据转换管道引擎和 dtexec 命令提示实用工具的 Integration Services 组件 DLL | <drive>:\Program Files\Microsoft SQL Server\100\DTS\Binn | 固定路径
为 Integration Services 提供托管连接支持的 DLL | <drive>:\Program Files\Microsoft SQL Server\100\DTS\Connections | 固定路径
Integration Services 支持的每种类型枚举器的 DLL | <drive>:\Program Files\Microsoft SQL Server\100\DTS\ForEachEnumerators | 固定路径
SQL Server 浏览器服务、WMI 提供程序 | <drive>:\Program Files\Microsoft SQL Server\100\Shared\ | 固定路径
所有 SQL Server 实例共享的组件 | <drive>:\Program Files\Microsoft SQL Server\100\Shared\ | 固定路径

1确保使用有限的权限对 \Program Files\Microsoft SQL Server\ 文件夹进行保护。

2这些位置的默认驱动器为 systemdrive，通常为驱动器 C。

3子功能的安装路径由父功能的安装路径决定。

4Integration Services 和客户端组件共享单个安装路径。更改一个组件的安装路径会同时更改其他组件的安装路径。后续安装将组件安装到与原始安装相同的位置。

5此目录由计算机上的所有 SQL Server 实例使用。如果对计算机上的任一实例应用更新，则对此文件夹中的文件所做的任何更改都将影响计算机上的所有实例。向现有安装添加功能时，不能更改以前安装的功能的位置，也不能为新功能指定该位置。必须将其他功能安装到安装程序已建立的目录，或者卸载并重新安装产品。

注意：
对于群集配置，必须选择在该群集的每个节点上都可用的本地驱动器。

当在安装过程中为服务器组件或数据文件指定安装路径时，安装程序除了为程序和数据文件使用指定的位置外，还使用实例 ID。安装程序不会将实例 ID 用于工具和其他共享文件。安装程序也不会将任何实例 ID 用于 Analysis Services 程序和数据文件，尽管它会将实例 ID 用于 Analysis Services 存储库。

如果为数据库引擎功能设置了安装路径，则对于此次安装，SQL Server 安装程序会将该路径用作所有特定于实例的文件夹（包括 SQL 数据文件）的根目录。在这种情况下，如果将根目录设置为“C:\Program Files\Microsoft SQL Server\MSSQL10\MSSQL\”，则特定于实例的目录将添加到此路径的末尾。

在 SQL Server 安装向导（安装程序用户界面模式）中选择使用 USESYSDB 升级功能的客户会很容易将产品安装到递归文件夹结构中。例如，<SQLProgramFiles>\MSSQL10\MSSQL\MSSQL10\MSSQL\Data\。这时，为了使用 USESYSDB 功能，请为 SQL 数据文件功能而非数据库引擎功能设置安装路径。

注意：
数据文件始终应位于名为 Data 的子目录中。例如，当数据文件位于 C:\Program Files\Microsoft SQL Server\MSSQL10\MSSQL\Data 下时，应指定 C:\Program Files\Microsoft SQL Server\MSSQL10\ 作为升级期间系统数据库的数据目录的根路径。

请参阅

参考

数据库引擎配置 - 数据目录
Analysis Services 配置 - 数据目录

概念

计划 SQL Server 安装


使用 SQL Server 的多个版本和实例

使用 SQL Server 的多个版本和实例 |
 | 请参阅
计划 SQL Server 安装 >

SQL Server 支持在同一台计算机上存在数据库引擎、Analysis Services 和 Reporting Services 的多个实例。也可以在已安装 SQL Server 早期版本的计算机上升级 SQL Server 的早期版本或安装 SQL Server。有关所支持的升级方案，请参阅版本升级。

并行使用 SQL Server 与早期版本的 SQL Server

可以在已运行 SQL Server 早期版本实例的计算机上安装 SQL Server。如果计算机上已存在默认实例，则 SQL Server 必须作为命名实例安装。

下表显示了对 SQL Server 2008 的并行支持。

现有的 SQL Server 2008 实例 | 并行支持
SQL Server 2008（32 位） | SQL Server 2000（32 位） SQL Server 2000 （64 位）x64 SQL Server 2005（32 位） SQL Server 2005 （64 位）x64
SQL Server 2008（64 位）IA64 | SQL Server 2005（64 位）IA64
SQL Server 2008 （64 位）x64 | SQL Server 2000（32 位） SQL Server 2000 （64 位）x64 SQL Server 2005（32 位） SQL Server 2005 （64 位）x64

请参阅

任务

如何安装 SQL Server 2008（安装程序）

参考

安装 SQL Server 2008 的硬件和软件要求
版本升级

概念

升级到 SQL Server 2008
向后兼容性
使用升级顾问来准备升级


排序规则和 Unicode 支持

排序规则和 Unicode 支持 |
 | 请参阅
计划 SQL Server 安装 >

随着数据库的扩展以满足日益增长的全球市场需求，用户必须能够以多种方式处理字符数据。排序规则允许用户根据其自己的约定对字符串进行排序和比较。排序规则是创建数据库和操作数据的关键部分。

SQL Server 2008 的排序规则完全符合 Windows Server 2008 的排序规则。

SQL Server 2008 排序规则中的新增功能

以下是 SQL Server 2008 中出现的新的排序规则更改：

SQL Server 2008 引入的新排序规则完全符合 Windows Server 2008 提供的排序规则。该 80 个新排序规则通过 *_100 版本引用表示。它们向用户提供语言准确的最新区域性排序约定。该支持包括：

  • 新的东亚政府标准。

  • 语言正确的代理项。

  • 中国少数民族语言。

  • Unicode 5.0 事例表。

  • 对于以前比较结果相等的非加权字符，已向这样的字符添加权重。

已向 SQL Server 2000 至 SQL Server 2005 的现有 Windows 排序规则添加新版本，以反映这些更改。所有当前排序规则在 SQL Server 2005 中均得以维护，以实现向后兼容。未对 SQL_* 排序规则进行更改。

不推荐使用 Korean_Wansung_Unicode、Hindi_CI_AS、Macedonian_CI_AS、Lithuanian_Classic_CI_AS、Cyrillic_90_CI_AS 和 Azeri_Latin_90_CI_AS Windows 排序规则，以及 SQL_ALTDiction_CP1253_CS_AS SQL 排序规则。SQL Server 2005 和 SQL Server 2008 支持这些排序规则。但是，它们不会显示在安装程序排序规则列表中，也不会在将系统函数 ::fn_helpcollations() 用于查询 SQL Server 2008 中支持的排序规则列表时显示。

请参阅

参考

安装程序中的排序规则设置
选择 SQL Server 排序规则

概念

排序规则和国际术语


排序规则和国际术语

排序规则和国际术语 |
 | 请参阅
计划 SQL Server 安装 > 排序规则和 Unicode 支持 >

SQL Server 中的排序规则可为您的数据提供排序规则、区分大小写属性和区分重音属性。用于 char 和 varchar 等字符数据类型的排序规则规定可表示该数据类型的代码页和对应字符。无论是要安装新的 SQL Server 实例、还原数据库备份，还是将服务器连接到客户端数据库，了解要处理的数据的区域设置要求、排序顺序以及区分大小写和重音是很重要的。

在为您的服务器、数据库、列或表达式选择排序规则时，也在向您的数据分配某些特征，这些特征将会影响数据库中许多操作的结果。例如，使用 ORDER BY 构造查询时，结果集的排序顺序可能取决于应用于该数据库的排序规则或 COLLATE 子句中在查询的表达式级别规定的排序规则。

排序规则可以包含任何或所有以下特征：

  • 区分大小写

  • 区分重音

  • 区分假名

  • 区分全半角

为了充分利用 SQL Server 中的排序规则支持，您必须了解本主题中所定义的术语以及这些术语与您的数据的特征之间的关系。

术语

  • 排序规则

  • 区域设置

  • Unicode

  • 代码页

  • 数据类型

  • 排序顺序

排序规则

排序规则指定表示数据集中每个字符的位模式。排序规则还确定了用于数据排序和比较的规则。SQL Server 支持在单个数据库中存储具有不同排序规则的对象。对于非 Unicode 列，排序规则设置指定数据的代码页以及可以表示哪些字符。必须将在非 Unicode 列间移动的数据从源代码页转换到目标代码页。

当 Transact-SQL 语句在具有不同排序规则设置的不同数据库上下文中运行时，其运行结果可能会不同。如果可能，请为您的组织使用标准化排序规则。这样就不必显式指定每个字符或 Unicode 表达式中的排序规则。如果必须使用具有不同排序规则和代码页设置的对象，请对查询进行编码，以考虑排序规则的优先顺序规则。有关详细信息，请参阅排序规则的优先顺序 (Transact-SQL)。

排序规则的特征是区分语言、区分大小写、区分重音、区分假名以及区分全半角。

SQL Server 排序规则包括下列排序规则集：

Windows 排序规则

Windows 排序规则根据关联的 Windows 系统区域设置来定义字符数据的存储规则。在 Windows 排序规则中，使用与 Unicode 数据相同的算法实现非 Unicode 数据的比较。Windows 基本排序规则指定应用字典排序时所用的字母表或语言，以及用于存储非 Unicode 字符数据的代码页。Unicode 排序和非 Unicode 排序都与特定 Windows 版本中的字符串比较相兼容。这保证了 SQL Server 中所有数据类型的一致性，还使开发人员能够使用 SQL Server 所使用的相同规则对应用程序中的字符串排序。有关详细信息，请参阅安装程序中的排序规则设置。

二进制排序规则

二进制排序规则基于区域设置和数据类型定义的编码值顺序来对数据进行排序。它们是区分大小写的。SQL Server 中的二进制排序规则定义了要使用的区域设置和 ANSI 代码页，并强制使用二进制排序顺序。由于它们相对简单，因此二进制排序规则有助于提高应用程序性能。对于非 Unicode 数据类型，数据比较将基于 ANSI 代码页中定义的码位。对于 Unicode 数据类型，数据比较将基于 Unicode 码位。对于 Unicode 数据类型的二进制排序规则，数据排序将不考虑区域设置。例如，对 Unicode 数据应用 Latin_1_General_BIN 和 Japanese_BIN，会得到完全相同的排序结果。

早期版本的 SQL Server 中的二进制排序规则将第一个字符作为 WCHAR 比较，接下来进行逐字节比较。出于向后兼容的原因，现有的二进制排序规则语义保持不变。

此版本的 SQL Server 中的二进制排序规则包含一组纯码位比较排序规则。您可以迁移到二进制排序规则，以利用真正的码位比较。您应该使用二进制排序规则来开发新的应用程序。BIN2 后缀标识了实现新的码位排序规则语义的排序规则名称。另外，新的二进制排序还有一个与 BIN2 对应的比较标志。有关详细信息，请参阅BIN 和 BIN2 排序规则的使用准则。

SQL Server

SQL Server 排序规则 (SQL_*) 提供与 SQL Server 早期版本兼容的排序顺序。非 Unicode 数据的字典排序规则与 Windows 操作系统提供的任何排序例程都不兼容。但是，Unicode 数据的排序与特定版本的 Windows 排序规则兼容。由于 SQL Server 排序规则对非 Unicode 数据和 Unicode 数据使用不同的比较规则，因此对于相同数据的比较将会看到不同的结果，具体取决于基本数据类型。有关详细信息，请参阅使用 SQL Server 排序规则。

注意：
升级 SQL Server 的英文实例时可以指定 SQL Server 排序规则 (SQL_*)，以便与现有 SQL Server 实例兼容。由于 SQL Server 实例的默认排序规则是在安装过程中定义的，因此在以下情况下切记要慎重指定排序规则设置：

  • 应用程序代码依赖早期 SQL Server 排序规则的行为。

  • 将在 SQL Server 6.5 或 SQL Server 7.0 的现有安装中使用 SQL Server 复制。

  • 必须存储反映多种语言的字符数据。

支持在 SQL Server 实例的下列级别设置排序规则：

服务器级排序规则

默认排序规则是在 SQL Server 安装期间设置的，并且会成为系统数据库的默认排序规则。请注意，在 SQL Server 安装期间不能选择仅 Unicode 排序规则，因为不支持将它们用作服务器级排序规则。

将排序规则指派给列或数据库以外的其他对象后，就无法再更改排序规则，除非删除并重新创建对象。可以在创建新的数据库或数据库列时指定排序规则，而不更改 SQL Server 实例的默认排序规则。

若要查询 SQL Server 实例的服务器排序规则，请使用下列 Transact-SQL SERVERPROPERTY 函数：

复制代码
SELECT CONVERT (varchar, SERVERPROPERTY('collation'))

若要查询服务器以找到所有可用的排序规则，请使用以下 fn_helpcollations() 内置函数：

复制代码
SELECT * from ::fn_helpcollations()
数据库级排序规则

创建数据库时，可以使用 CREATE DATABASE 语句的 COLLATE 子句指定默认的数据库排序规则。如果未指定排序规则，则为该数据库分配 model 数据库的默认排序规则。model 数据库的排序规则与 SQL Server 实例的默认排序规则相同。

可使用如下的 ALTER DATABASE 语句更改用户数据库的排序规则：

复制代码
ALTER DATABASE myDB COLLATE Greek_CS_AI

可以使用如下语句检索数据库的当前排序规则：

复制代码
SELECT CONVERT (varchar, DATABASEPROPERTYEX('database_name','collation'))
注意：
更改数据库级排序规则不会影响列级排序规则或表达式级排序规则。

列级排序规则

创建表时，可以使用 CREATE TABLE 语句的 COLLATE 子句指定每个字符串列的排序规则。如果未指定排序规则，则为该列分配数据库的默认排序规则。

可使用如下的 ALTER TABLE 语句更改列的排序规则：

复制代码
ALTER TABLE myTable ALTER COLUMN mycol NVARCHAR(10) COLLATE Greek_CS_AI
表达式级排序规则

表达式级排序规则在语句运行时设置，并且影响结果集的返回方式。这可以使 ORDER BY 排序结果特定于区域设置。使用如下的 COLLATE 子句可以实现表达式级排序规则：

复制代码
SELECT name FROM customer ORDER BY name COLLATE Latin1_General_CS_AI

返回页首

区域设置

区域设置是一组与地点和区域性相关联的信息。它可以包括所用语言的名称和标识符、用于书写该语言的文字以及文化习俗。排序规则可以与一个或多个区域设置相关联。

返回页首

Unicode

如果存储的字符数据反映多种语言，则应始终使用 Unicode 数据类型（nchar、nvarchar 和 ntext），而不要使用非 Unicode 数据类型（char、varchar 和 text）。

非 Unicode 数据类型有明显的局限性，这是因为非 Unicode 计算机只能使用单个代码页。通过使用 Unicode 您可能会体验到性能提升，因为需要较少的代码页转换。必须在数据库级、列级或表达式级单独选择 Unicode 排序规则，因为在服务器级不支持 Unicode 排序规则。

客户端使用的代码页由操作系统的设置来确定。若要在 Windows 2000、Windows XP、Windows Server 2003 或 Windows Server 2008 操作系统上设置客户端代码页，请使用控制面板中的“区域设置”。

在将数据从服务器移到客户端时，服务器排序规则可能无法由旧版本的客户端驱动程序识别。在将数据从 Unicode 服务器移到非 Unicode 客户端时，可能发生这种情况。最好升级客户端操作系统，以使基础系统排序规则得以升级。如果客户端安装有数据库客户端软件，则可以考虑对数据库客户端软件应用服务更新。

还可以尝试针对服务器上的数据使用另一个排序规则。选择一个将映射到客户端上的代码页的排序规则。有关详细信息，请参阅 SQL Server 联机丛书中的“设置和更改排序规则”主题。

若要评估与使用 Unicode 或非 Unicode 数据类型相关的问题，请测试您的具体方案以确定您所在环境下的性能差异大小。最好对整个组织中的系统所使用的排序规则进行标准化，并尽可能部署 Unicode 服务器和客户端。有关 Unicode 的详细信息，请参阅 Unicode Consortium Web site（Unicode Consortium 网站）。

多数情况下，SQL Server 会与其他服务器或客户端进行交互，您的组织可能会在应用程序和服务器实例之间使用多个数据访问标准。SQL Server 客户端是两种主要类型之一：

  • 使用 OLE DB 和开放式数据库连接 (ODBC) 3.7 版或更高版本的 Unicode 客户端。

  • 使用 DB-Library 和 ODBC 3.6 版或更低版本的非 Unicode 客户端。

下表提供有关以 Unicode 和非 Unicode 服务器的各种组合使用多语言数据的信息。

服务器 | 客户端 | 优点或局限性
Unicode | Unicode | 因为 Unicode 数据将在整个系统中使用，所以此方案可提供最佳的性能并可保护检索到的数据免受破坏。ActiveX 数据对象 (ADO)、OLE DB 和 ODBC 3.7 版或更高版本都采用这样的配置。
Unicode | 非 Unicode | 在这种情况下，尤其对于正在运行新操作系统的服务器与正在运行旧版本 SQL Server 或基于旧操作系统的客户端之间的连接，当您向客户端计算机移动数据时，会受到限制或出现错误。服务器上的 Unicode 数据会尝试映射到非 Unicode 客户端的对应代码页，以转换数据。
非 Unicode | Unicode | 该方案对使用多语言数据不是理想配置。在此方案下不能向非 Unicode 服务器写入 Unicode 数据。在向服务器的代码页之外的服务器发送数据时，很可能会发生问题。
非 Unicode | 非 Unicode | 这是对多语言数据有极大局限性的方案。您只可使用一个代码页。

如果在从服务器向客户端（尤其是从 Unicode 服务器向非 Unicode 客户端）移动数据时遇到了错误或困难，旧客户端驱动程序可能无法识别您的服务器排序规则。在这种情况下，您最好升级客户端操作系统，以便更新基础系统排序规则。如果客户端安装有数据库客户端软件，则可以考虑对数据库客户端软件应用服务更新。

还可以尝试针对服务器上的数据使用另一个排序规则。选择一个将映射到客户端上的代码页的排序规则。有关更改排序规则的详细信息，请参阅 SQL Server 联机丛书中的“在 SQL Server 中设置和更改排序规则”主题。有关更改排序规则的详细信息，请参阅“SQL Server 排序规则更改最佳实践”white paper（白皮书）。有关将非 Unicode 数据类型迁移到 Unicode 数据类型的详细信息，请参阅“SQL Server 迁移至 Unicode 的最佳实践”whitepaper（白皮书）。

相关主题： Unicode 基础知识

返回页首

代码页

代码页是给定脚本的有序字符集，其中数值索引（即码位值）与每个字符相关联。Windows 代码页通常称为“字符集”或“charset”。代码页用于支持不同的 Windows 区域设置所使用的字符集和键盘布局。

所有 Windows Server 2008 Unicode 排序规则都基于 Unicode 5.0。

返回页首

数据类型

数据类型为一种定义，用于指定值的范围、可对值执行的操作以及值在内存中的存储方式。定义数据类型可使 SQL Server 以可预测的方式对数据进行操作。非 Unicode 字符数据类型为 char、varchar 和 text。Unicode 数据类型包括 nchar、nvarchar 和 ntext。建议在应用程序中使用 Unicode 数据类型，尤其是在存储反映多种语言的字符数据时。

有关将非 Unicode 数据类型迁移到 Unicode 数据类型的详细信息，请参阅“SQL Server 迁移至 Unicode 的最佳实践”whitepaper（白皮书）。

相关主题：数据类型（数据库引擎）、数据类型 (Transact-SQL) 和 Integration Services 数据类型

返回页首

排序顺序

排序顺序指定数据值的排序方式。它影响数据比较的结果。数据的排序通过使用排序规则而实现，且可使用索引对排序进行优化。

相关主题： Windows 排序规则排序样式、索引

返回页首

请参阅

参考

排序规则和 Unicode 支持


安装程序中的排序规则设置

安装程序中的排序规则设置 |
 | 请参阅
计划 SQL Server 安装 > 排序规则和 Unicode 支持 >

如果服务器之间的排序规则设置不一致，许多服务器对服务器的活动就可能失败或生成不一致的结果。为避免这种情况，请选择与其他 SQL Server 实例中的排序规则设置匹配的 Windows 区域设置或 SQL Server 排序规则 (SQL_*)。

SQL Server 2008 支持在以下级别设置排序规则：

  • 服务器

  • 数据库

  • 列

  • 表达式

有关详细信息，请参阅 排序规则和国际术语和如何从命令提示符安装 SQL Server 2008。

二进制排序规则

二进制排序规则基于每个字符的位模式来排序和比较 SQL Server 中的数据。SQL Server 中的每个二进制排序规则都映射到特定的语言区域设置和 ANSI 代码页，且每个都执行区分大小写和区分重音的数据排序。有关详细信息，请参阅 Windows 排序规则排序样式和BIN 和 BIN2 排序规则的使用准则。

SQL Server 排序规则 (SQL_*)

选择此选项可使设置与 SQL Server 2005 英文版或早期版本的设置匹配。有关详细信息，请参阅使用 SQL Server 排序规则。

Windows 系统区域设置

默认安装设置由 Windows 系统区域设置决定。服务器级排序规则可以在设置期间更改，也可以在安装前通过更改 Windows 系统区域设置进行更改。默认排序规则设置为与每个特定区域设置关联的最早可用版本。这是出于向后兼容的原因。因此，不推荐总是使用这些排序规则。若要利用 SQL Server 2008 功能，请更改 Windows 排序规则的默认安装设置。

若要为 Windows Vista 之前的操作系统设置 Windows 区域设置，请在“控制面板”内“区域和语言选项”中的“高级”选项卡上查找相应的 Windows 系统区域设置名称。在 Windows Vista 中，使用“格式”选项卡。

排序规则指示符

从“排序规则指示符”列表中选择特定的 Windows 排序规则的名称。例如，对于美国英语字符集（代码页 1252），请使用 Latin1_General。

排序顺序

选择用于所选排序规则指示符的排序顺序选项。二进制是最快的排序顺序，并且区分大小写，但是可能会产生意外的排序顺序。如果选择了“二进制”，则“区分大小写”、“区分重音”、“区分假名”和“区分全半角”选项将不可用。有关详细信息，请参阅 Windows 排序规则排序样式。

SQL Server 安装程序中的默认排序规则

在控制面板中，在“区域和语言选项”上的“高级”选项卡中找到 Windows 系统区域设置名称。在 Windows Vista 中，使用“格式”选项卡。下表说明了用于使排序规则设置与现有 Windows 区域设置匹配的对应排序规则指示符和代码页：

Windows 区域设置 | Windows LCID | 默认 | 代码页
南非荷兰语(南非) | 0x0436 | Latin1_General_CI_AS | 1252
阿尔巴尼亚语(阿尔巴尼亚) | 0x041c | Albanian_CI_AS | 1252
阿尔萨斯语(法国) | 0x0484 | Latin1_General_100_CI_AS | 1252
阿姆哈拉语(埃塞俄比亚) | 0x045e | Latin1_General_100_CI_AS | 1252
阿拉伯语(阿尔及利亚) | 0x1401 | Arabic_CI_AS | 1256
阿拉伯语(巴林) | 0x3c01 | Arabic_CI_AS | 1256
阿拉伯语(埃及) | 0x0c01 | Arabic_CI_AS | 1256
阿拉伯语(伊拉克) | 0x0801 | Arabic_CI_AS | 1256
阿拉伯语(约旦) | 0x2c01 | Arabic_CI_AS | 1256
阿拉伯语(科威特) | 0x3401 | Arabic_CI_AS | 1256
阿拉伯语(黎巴嫩) | 0x3001 | Arabic_CI_AS | 1256
阿拉伯语(利比亚) | 0x1001 | Arabic_CI_AS | 1256
阿拉伯语(摩洛哥) | 0x1801 | Arabic_CI_AS | 1256
阿拉伯语(阿曼) | 0x2001 | Arabic_CI_AS | 1256
阿拉伯语(卡塔尔) | 0x4001 | Arabic_CI_AS | 1256
阿拉伯语(沙特阿拉伯) | 0x0401 | Arabic_CI_AS | 1256
阿拉伯语(叙利亚) | 0x2801 | Arabic_CI_AS | 1256
阿拉伯语(突尼斯) | 0x1c01 | Arabic_CI_AS | 1256
阿拉伯语(阿拉伯联合酋长国) | 0x3801 | Arabic_CI_AS | 1256
阿拉伯语(也门) | 0x2401 | Arabic_CI_AS | 1256
亚美尼亚语(亚美尼亚) | 0x042b | Cyrillic_General_100_CI_AS | 1251
阿萨姆语(印度) | 0x044d | 在服务器级别不可用 | Unicode
阿泽里语(阿塞拜疆，西里尔文) | 0x082c | Azeri_Cyrillic_90_CI_AS | 1251
阿泽里语(阿塞拜疆，拉丁语) | 0x042c | Azeri_Latin_90_CI_AS | 1254
巴什基尔语(俄罗斯) | 0x046d | Bashkir_100_CI_AS | 1251
巴斯克语(巴斯克) | 0x042d | Latin1_General_100_CI_AS | 1252
白俄罗斯语(白俄罗斯) | 0x0423 | Cyrillic_General_CI_AS | 1251
孟加拉语(孟加拉) | 0x0845 | 在服务器级别不可用 | Unicode
孟加拉语(印度) | 0x0445 | 在服务器级别不可用 | Unicode
波斯尼亚语(波斯尼亚和黑塞哥维那，西里尔文) | 0x201a | Bosnian_Cyrillic_100_CI_AS | 1251
波斯尼亚语(波斯尼亚和黑塞哥维那，拉丁语) | 0x141a | Bosnian_Latin_100_CI_AS | 1250
布列塔尼语(法国) | 0x047e | Breton_100_CI_AS | 1252
保加利亚语(保加利亚) | 0x0402 | Cyrillic_General_CI_AS | 1251
加泰罗尼亚语(加泰罗尼亚) | 0x0403 | Latin1_General_CI_AS | 1252
中文(中国香港特别行政区) | 0x0c04 | Chinese_Hong_Kong_Stroke_90_CI_AS | 950
中文(中国澳门特别行政区) | 0x1404 | Chinese_Traditional_Pinyin_100_CI_AS | 950
中文(澳门) | 0x21404 | Chinese_Traditional_Stroke_Order_100_CI_AS | 950
中文(中国) | 0x0804 | Chinese_PRC_CI_AS | 936
中文(中国) | 0x20804 | Chinese_PRC_Stroke_CI_AS | 936
中文(新加坡) | 0x1004 | Chinese_PRC_CI_AS | 936
中文(新加坡) | 0x21004 | Chinese_Simplified_Stroke_Order_100_CI_AS | 936
中文(台湾) | 0x30404 | Chinese_Taiwan_Bopomofo_CI_AS | 950
中文(台湾) | 0x0404 | Chinese_Taiwan_Stroke_CI_AS | 950
科西嘉语(法国) | 0x0483 | Corsican_100_CI_AS | 1252
克罗地亚语(波斯尼亚和黑塞哥维那，拉丁语) | 0x101a | Croatian_100_CI_AS | 1250
克罗地亚语(克罗地亚) | 0x041a | Croatian_CI_AS | 1250
捷克语(捷克共和国) | 0x0405 | Czech_CI_AS | 1250
丹麦语(丹麦) | 0x0406 | Danish_Norwegian_CI_AS | 1252
达里语(阿富汗) | 0x048c | Dari_100_CI_AS | 1256
迪维希语(马尔代夫) | 0x0465 | 在服务器级别不可用 | Unicode
荷兰语(比利时) | 0x0813 | Latin1_General_CI_AS | 1252
荷兰语(荷兰) | 0x0413 | Latin1_General_CI_AS | 1252
英语(澳大利亚) | 0x0c09 | Latin1_General_CI_AS | 1252
英语(伯利兹) | 0x2809 | Latin1_General_CI_AS | 1252
英语(加拿大) | 0x1009 | Latin1_General_CI_AS | 1252
英语(加勒比海) | 0x2409 | Latin1_General_CI_AS | 1252
英语(印度) | 0x4009 | Latin1_General_100_CI_AS | 1252
英语(爱尔兰) | 0x1809 | Latin1_General_CI_AS | 1252
英语(牙买加) | 0x2009 | Latin1_General_CI_AS | 1252
英语(马来西亚) | 0x4409 | Latin1_General_100_CI_AS | 1252
英语(新西兰) | 0x1409 | Latin1_General_CI_AS | 1252
英语(菲律宾) | 0x3409 | Latin1_General_CI_AS | 1252
英语(新加坡) | 0x4809 | Latin1_General_100_CI_AS | 1252
英语(南非) | 0x1c09 | Latin1_General_CI_AS | 1252
英语(特立尼达和多巴哥) | 0x2c09 | Latin1_General_CI_AS | 1252
英语(英国) | 0x0809 | Latin1_General_CI_AS | 1252
英语(美国) | 0x0409 | SQL_Latin1_General_CP1_CI_AS | 1252
英语(津巴布韦) | 0x3009 | Latin1_General_CI_AS | 1252
爱沙尼亚语(爱沙尼亚) | 0x0425 | Estonian_CI_AS | 1257
法罗语(法罗群岛) | 0x0438 | Latin1_General_CI_AS | 1252
菲律宾语(菲律宾) | 0x0464 | Latin1_General_100_CI_AS | 1252
芬兰语(芬兰) | 0x040b | Finnish_Swedish_CI_AS | 1252
法语(比利时) | 0x080c | French_CI_AS | 1252
法语(加拿大) | 0x0c0c | French_CI_AS | 1252
法语(法国) | 0x040c | French_CI_AS | 1252
法语(卢森堡) | 0x140c | French_CI_AS | 1252
法语(摩纳哥) | 0x180c | French_CI_AS | 1252
法语(瑞士) | 0x100c | French_CI_AS | 1252
弗里西亚语(荷兰) | 0x0462 | Frisian_100_CI_AS | 1252
加利西亚语(西班牙) | 0x0456 | Latin1_General_CI_AS | 1252
格鲁吉亚语(格鲁吉亚) | 0x0437 | Cyrillic_General_100_CI_AS | 1251
格鲁吉亚语(格鲁吉亚) | 0x10437 | Georgian_Modern_Sort_CI_AS |
德语 - 电话簿排序(DIN) | 0x10407 | German_PhoneBook_CI_AS | 1252
德语(奥地利) | 0x0c07 | Latin1_General_CI_AS | 1252
德语(德国) | 0x0407 | Latin1_General_CI_AS | 1252
德语(列支敦士登) | 0x1407 | Latin1_General_CI_AS | 1252
德语(卢森堡) | 0x1007 | Latin1_General_CI_AS | 1252
德语(瑞士) | 0x0807 | Latin1_General_CI_AS | 1252
希腊语(希腊) | 0x0408 | Greek_CI_AS | 1253
格陵兰语(格陵兰) | 0x046f | Danish_Greenlandic_100_CI_AS | 1252
古吉拉特语(印度) | 0x0447 | 在服务器级别不可用 | Unicode
豪撒语(尼日利亚，拉丁语) | 0x0468 | Latin1_General_100_CI_AS | 1252
希伯来语(以色列) | 0x040d | Hebrew_CI_AS | 1255
印地语(印度) | 0x0439 | 在服务器级别不可用 | Unicode
匈牙利语(匈牙利) | 0x040e | Hungarian_CI_AS | 1250
匈牙利语技术排序 | 0x1040e | Hungarian_Technical_CI_AS | 1250
冰岛语(冰岛) | 0x040f | Icelandic_CI_AS | 1252
伊博语(尼日利亚) | 0x0470 | Latin1_General_100_CI_AS | 1252
印度尼西亚语(印度尼西亚) | 0x0421 | Latin1_General_CI_AS | 1252
因纽特语(加拿大，拉丁语) | 0x085d | Latin1_General_100_CI_AS | 1252
因纽特语(音节，加拿大) | 0x045d | Latin1_General_100_CI_AS | 1252
爱尔兰语(爱尔兰) | 0x083c | Latin1_General_100_CI_AS | 1252
意大利语(意大利) | 0x0410 | Latin1_General_CI_AS | 1252
意大利语(瑞士) | 0x0810 | Latin1_General_CI_AS | 1252
日语(日本 XJIS) | 0x0411 | Japanese_CI_AS | 932
日语(日本) | 0x040411 | Japanese_Bushu_Kakusu_100_CI_AS | 932
卡纳达语(印度) | 0x044b | 在服务器级别不可用 | Unicode
哈萨克语(哈萨克斯坦) | 0x043f | Kazakh_90_CI_AS | 1251
高棉语(柬埔寨) | 0x0453 | 在服务器级别不可用 | Unicode
基切语(危地马拉) | 0x0486 | Modern_Spanish_100_CI_AS | 1252
卢旺达语(卢旺达) | 0x0487 | Latin1_General_100_CI_AS | 1252
孔卡尼语(印度) | 0x0457 | 在服务器级别不可用 | Unicode
朝鲜语(朝鲜语字典排序) | 0x0412 | Korean_Wansung_CI_AS | 949
吉尔吉斯语(吉尔吉斯斯坦) | 0x0440 | Cyrillic_General_CI_AS | 1251
老挝语(老挝人民民主共和国) | 0x0454 | 在服务器级别不可用 | Unicode
拉脱维亚语(拉脱维亚) | 0x0426 | Latvian_CI_AS | 1257
立陶宛语(立陶宛) | 0x0427 | Lithuanian_CI_AS | 1257
下索布语(德国) | 0x082e | Latin1_General_100_CI_AS | 1252
卢森堡语(卢森堡) | 0x046e | Latin1_General_100_CI_AS | 1252
马其顿语(马其顿，FYROM) | 0x042f | Macedonian_FYROM_90_CI_AS | 1251
马来语(文莱达鲁萨兰国) | 0x083e | Latin1_General_CI_AS | 1252
马来语(马来西亚) | 0x043e | Latin1_General_CI_AS | 1252
马拉雅拉姆语(印度) | 0x044c | 在服务器级别不可用 | Unicode
马耳他语(马耳他) | 0x043a | Maltese_100_CI_AS | 1252
毛利语(新西兰) | 0x0481 | Maori_100_CI_AS | 1252
马普丹冈语(智利) | 0x047a | Mapudungan_100_CI_AS | 1252
马拉地语(印度) | 0x044e | 在服务器级别不可用 | Unicode
莫霍克语(加拿大) | 0x047c | Mohawk_100_CI_AS | 1252
蒙古语(蒙古) | 0x0450 | Cyrillic_General_CI_AS | 1251
蒙古语(中国) | 0x0850 | Cyrillic_General_100_CI_AS | 1251
尼泊尔语(尼泊尔) | 0x0461 | 在服务器级别不可用 | Unicode
挪威语(博克马尔语，挪威) | 0x0414 | Norwegian_100_CI_AS | 1252
挪威语(尼诺斯克语，挪威) | 0x0814 | Norwegian_100_CI_AS | 1252
奥克西唐语(法国) | 0x0482 | French_100_CI_AS | 1252
奥里雅语(印度) | 0x0448 | 在服务器级别不可用 | Unicode
普什图语(阿富汗) | 0x0463 | 在服务器级别不可用 | Unicode
波斯语(伊朗) | 0x0429 | Persian_100_CI_AS | 1256
波兰语(波兰) | 0x0415 | Polish_CI_AS | 1250
葡萄牙语(巴西) | 0x0416 | Latin1_General_CI_AS | 1252
葡萄牙语(葡萄牙) | 0x0816 | Latin1_General_CI_AS | 1252
旁遮普语(印度) | 0x0446 | 在服务器级别不可用 | Unicode
克丘亚语(玻利维亚) | 0x046b | Latin1_General_100_CI_AS | 1252
克丘亚语(厄瓜多尔) | 0x086b | Latin1_General_100_CI_AS | 1252
克丘亚语(秘鲁) | 0x0c6b | Latin1_General_100_CI_AS | 1252
罗马尼亚语(罗马尼亚) | 0x0418 | Romanian_CI_AS | 1250
罗曼什语(瑞士) | 0x0417 | Romansh_100_CI_AS | 1252
俄语(俄罗斯) | 0x0419 | Cyrillic_General_CI_AS | 1251
萨米语(伊纳里，芬兰) | 0x243b | Sami_Sweden_Finland_100_CI_AS | 1252
萨米语(律勒欧，挪威) | 0x103b | Sami_Norway_100_CI_AS | 1252
萨米语(律勒欧，瑞典) | 0x143b | Sami_Sweden_Finland_100_CI_AS | 1252
萨米语(北方，芬兰) | 0x0c3b | Sami_Sweden_Finland_100_CI_AS | 1252
萨米语(北方，挪威) | 0x043b | Sami_Norway_100_CI_AS | 1252
萨米语(北方，瑞典) | 0x083b | Sami_Sweden_Finland_100_CI_AS | 1252
萨米语(斯科特，芬兰) | 0x203b | Sami_Sweden_Finland_100_CI_AS | 1252
萨米语(南方，挪威) | 0x183b | Sami_Norway_100_CI_AS | 1252
萨米语(南方，瑞典) | 0x1c3b | Sami_Sweden_Finland_100_CI_AS | 1252
梵语(印度) | 0x044f | 在服务器级别不可用 | Unicode
塞尔维亚语(波斯尼亚和黑塞哥维那，西里尔文) | 0x1c1a | Cyrillic_General_CI_AS | 1251
塞尔维亚语(波斯尼亚和黑塞哥维那，拉丁语) | 0x181a | Latin1_General_CI_AS | 1250
塞尔维亚语(塞尔维亚，西里尔语) | 0x0c1a | Cyrillic_General_CI_AS | 1251
塞尔维亚语(塞尔维亚，拉丁语) | 0x081a | Latin1_General_CI_AS | 1250
巴索托语/北索托语(南非) | 0x046c | Latin1_General_100_CI_AS | 1252
茨瓦纳语(南非) | 0x0432 | Latin1_General_100_CI_AS | 1252
僧伽罗语(斯里兰卡) | 0x045b | 在服务器级别不可用 | Unicode
斯洛伐克语(斯洛伐克) | 0x041b | Slovak_CI_AS | 1250
斯洛文尼亚语(斯洛文尼亚) | 0x0424 | Slovenian_CI_AS | 1250
西班牙语(阿根廷) | 0x2c0a | Modern_Spanish_CI_AS | 1252
西班牙语(玻利维亚) | 0x400a | Modern_Spanish_CI_AS | 1252
西班牙语(智利) | 0x340a | Modern_Spanish_CI_AS | 1252
西班牙语(哥伦比亚) | 0x240a | Modern_Spanish_CI_AS | 1252
西班牙语(哥斯达黎加) | 0x140a | Modern_Spanish_CI_AS | 1252
西班牙语(多米尼加共和国) | 0x1c0a | Modern_Spanish_CI_AS | 1252
西班牙语(厄瓜多尔) | 0x300a | Modern_Spanish_CI_AS | 1252
西班牙语(萨尔瓦多) | 0x440a | Modern_Spanish_CI_AS | 1252
西班牙语(危地马拉) | 0x100a | Modern_Spanish_CI_AS | 1252
西班牙语(洪都拉斯) | 0x480a | Modern_Spanish_CI_AS | 1252
西班牙语(墨西哥) | 0x080a | Modern_Spanish_CI_AS | 1252
西班牙(尼加拉瓜) | 0x4c0a | Modern_Spanish_CI_AS | 1252
西班牙语(巴拿马) | 0x180a | Modern_Spanish_CI_AS | 1252
西班牙语(巴拉圭) | 0x3c0a | Modern_Spanish_CI_AS | 1252
西班牙语(秘鲁) | 0x280a | Modern_Spanish_CI_AS | 1252
西班牙语(波多黎各) | 0x500a | Modern_Spanish_CI_AS | 1252
西班牙语(西班牙) | 0x0c0a | Modern_Spanish_CI_AS | 1252
西班牙语(西班牙，传统风格) | 0x040a | Traditional_Spanish_CI_AS | 1252
西班牙语(美国) | 0x540a | Latin1_General_100_CI_AS | 1252
西班牙语(乌拉圭) | 0x380a | Modern_Spanish_CI_AS | 1252
西班牙语(委内瑞拉) | 0x200a | Modern_Spanish_CI_AS | 1252
斯瓦希里语(肯尼亚) | 0x0441 | Latin1_General_100_CI_AS | 1252
瑞典语(芬兰) | 0x081d | Finnish_Swedish_CI_AS | 1252
瑞典语(瑞典) | 0x041d | Finnish_Swedish_CI_AS | 1252
叙利亚语(叙利亚) | 0x045a | 在服务器级别不可用 | Unicode
塔吉克语(塔吉克斯坦) | 0x0428 | Cyrillic_General_100_CI_AS | 1251
塔马塞特文(阿尔及利亚，拉丁语) | 0x085f | Tamazight_100_CI_AS | 1252
泰米尔语(印度) | 0x0449 | 在服务器级别不可用 | Unicode
鞑靼语(俄罗斯) | 0x0444 | Cyrillic_General_CI_AS | 1251
泰卢固语(印度) | 0x044a | 在服务器级别不可用 | Unicode
泰语(泰国) | 0x041e | Thai_CI_AS | 874
藏语(中国) | 0x0451 | 在服务器级别不可用 | Unicode
土耳其语(土耳其) | 0x041f | Turkish_CI_AS | 1254
土库曼语(土库曼斯坦) | 0x0442 | Turkmen_100_CI_AS | 1250
维吾尔语(中国) | 0x0480 | Uighur_100_CI_AS | 1256
乌克兰语(乌克兰) | 0x0422 | Ukrainian_100_CI_AS | 1251
上索布语(德国) | 0x042e | Upper_Sorbian_100_CI_AS | 1252
乌尔都语(巴基斯坦) | 0x0420 | Urdu_100_CI_AS | 1256
乌兹别克语(乌兹别克斯坦，西里尔文) | 0x0843 | Cyrillic_General_CI_AS | 1251
乌兹别克语(乌兹别克斯坦，拉丁语) | 0x0443 | Uzbek_Latin_90_CI_AS | 1254
越南语(越南) | 0x042a | Vietnamese_CI_AS | 1258
威尔士语(英国) | 0x0452 | Welsh_100_CI_AS | 1252
沃洛夫语(塞内加尔) | 0x0488 | French_100_CI_AS | 1252
班图语/索萨语(南非) | 0x0434 | Latin1_General_100_CI_AS | 1252
雅库特语(俄罗斯) | 0x0485 | Yakut_100_CI_AS | 1251
彝语(中国) | 0x0478 | Latin1_General_100_CI_AS | 1252
约鲁巴语(尼日利亚) | 0x046a | Latin1_General_100_CI_AS | 1252
祖鲁语(南非) | 0x0435 | Latin1_General_100_CI_AS | 1252

请参阅

参考

排序规则和 Unicode 支持
Windows 排序规则排序样式

概念

使用 SQL Server 排序规则


Windows 排序规则排序样式

Windows 排序规则排序样式 |
 | 请参阅
计划 SQL Server 安装 > 排序规则和 Unicode 支持 >

SQL Server 安装过程中将提示选择 Windows 排序规则或二进制排序规则。此选择将影响 Microsoft SQL Server 实例的数据比较和排序顺序行为。本主题提供为您的 SQL Server 实现选择 Microsoft Windows 排序规则或二进制排序规则时的注意事项。

注意：
对于 Windows 排序规则，nchar、nvarchar 和 ntext 这些 Unicode 数据类型与 char、varchar 和 text 这些非 Unicode 数据类型的排序行为相同。

Windows 排序规则根据关联的 Windows 区域设置来定义字符数据的存储规则。Windows 基本排序规则指定应用字典排序时所用的字母表或语言，以及用于存储非 Unicode 字符数据的代码页。二进制排序规则基于区域设置和数据类型所定义的编码值的顺序，对数据进行排序。SQL Server 中的二进制排序规则强制使用二进制排序顺序，定义了要使用的区域设置和 ANSI 代码页。由于二进制排序规则相对简单，因此对改进应用程序的性能非常有用。对于非 Unicode 数据类型，数据比较将基于 ANSI 代码页中定义的码位。对于 Unicode 数据类型，数据比较将基于 Unicode 码位。对于 Unicode 数据类型的二进制排序规则，数据排序将不考虑区域设置。例如，对 Unicode 数据应用 Latin_1_General_BIN 和 Japanese_BIN，会得到完全相同的排序结果。

SQL Server 中早期的二进制排序规则对 Unicode 数据执行的是不完整的逐码位比较，因为更早的 SQL Server 二进制排序规则将首字符作为 WCHAR 比较，然后才进行逐字节比较。为了实现向后兼容，将不更改现有的二进制排序规则语义。

此版本的 SQL Server 中的二进制排序规则还包含一组纯码位比较排序规则。客户可以选择迁移到二进制排序规则，以利用真正的码位比较，并且应该使用二进制排序规则来开发新的应用程序。BIN2 后缀标识了实现码位排序规则语义的排序规则名称。另外，新的二进制排序还有一个与 BIN2 对应的比较标志。有关详细信息，请参阅BIN 和 BIN2 排序规则的使用准则。

下表说明 SQL Server 的 Windows 排序规则排序顺序选项。

排序顺序（后缀） | 排序顺序说明
二进制 (_BIN)1 | 根据为每个字符定义的位模式对 SQL Server 表中的数据进行排序和比较。二进制排序顺序既区分大小写，也区分重音。二进制排序顺序的速度也最快。有关详细信息，请参阅BIN 和 BIN2 排序规则的使用准则。 如果未选择此选项，则 SQL Server 将遵循字典中定义的相关语言或字母表的排序和比较规则。
二进制-码位 (_BIN2)1 | 根据 Unicode 数据的 Unicode 码位对 SQL Server 表中的数据进行排序和比较。对于非 Unicode 数据，二进制-码位将使用与二进制排序相同的比较方式。 使用二进制-码位排序顺序的优点是：对已排序的 SQL Server 数据进行比较的应用程序不必重新对数据进行排序。因此，二进制-码位排序顺序使应用程序开发变得更加简单，从而可以提高性能。有关详细信息，请参阅BIN 和 BIN2 排序规则的使用准则。
区分大小写 (_CS) | 区分大写字母和小写字母。如果选择此项，排序时小写字母将在其对应的大写字母之前。 如果未选择此选项，则 SQL Server 认为字母的大小写形式对于排序目的而言是相同的。
区分重音 (_AS) | 区分重音字符和非重音字符。例如，“a”和“?”视为不同字符。 如果未选择此项，在排序时，SQL Server 将把字母的重音形式和非重音形式视为相同。
区分假名 (_KS) | 区分日语中的两种假名字符类型：平假名和片假名。 如果未选择此选项，则 SQL Server 认为片假名字符和平假名字符对于排序目的而言是相等的。
区分全半角 (_WS) | 区分字符的单字节形式和双字节形式。 如果未选择此项，在排序时，SQL Server 将把同一字符的单字节形式和双字节形式视为相同。

1如果选择此选项，则区分大小写、区分重音、区分假名和区分全半角选项均不可用。

Windows 排序规则示例

每个 Windows 排序规则都由一系列定义大小写、重音、全半角或假名的后缀组合而成。下列示例说明各种后缀组合的排序顺序行为。

Windows 排序规则后缀 | 排序顺序说明
_BIN1 | 二进制排序。
_BIN21 | 二进制-码位排序顺序。
_CI_AI | 不区分大小写、不区分重音、不区分假名、不区分全半角。
_CI_AI_KS | 不区分大小写、不区分重音、区分假名、不区分全半角
_CI_AI_KS_WS | 不区分大小写、不区分重音、区分假名、区分全半角
_CI_AI_WS | 不区分大小写、不区分重音、不区分假名、区分全半角
_CI_AS | 不区分大小写、区分重音、不区分假名、不区分全半角
_CI_AS_KS | 不区分大小写、区分重音、区分假名、不区分全半角
_CI_AS_KS_WS | 不区分大小写、区分重音、区分假名、区分全半角
_CI_AS_WS | 不区分大小写、区分重音、不区分假名、区分全半角
_CS_AI | 区分大小写、不区分重音、不区分假名、不区分全半角
_CS_AI_KS | 区分大小写、不区分重音、区分假名、不区分全半角
_CS_AI_KS_WS | 区分大小写、不区分重音、区分假名、区分全半角
_CS_AI_WS | 区分大小写、不区分重音、不区分假名、区分全半角
_CS_AS | 区分大小写、区分重音、不区分假名、不区分全半角
_CS_AS_KS | 区分大小写、区分重音、区分假名、不区分全半角
_CS_AS_KS_WS | 区分大小写、区分重音、区分假名、区分全半角
_CS_AS_WS | 区分大小写、区分重音、不区分假名、区分全半角

1如果选择 BIN 或二进制-码位，则区分大小写、区分重音、区分假名和区分全半角选项均不可用。

请参阅

参考

安装程序中的排序规则设置

概念

BIN 和 BIN2 排序规则的使用准则


BIN 和 BIN2 排序规则的使用准则

BIN 和 BIN2 排序规则的使用准则 |
 | 请参阅
计划 SQL Server 安装 > 排序规则和 Unicode 支持 >

以下注意事项将帮助您决定是 BIN 还是 BIN2 二进制排序规则适合于 SQL Server 实现。

二进制排序规则基于区域设置和数据类型所定义的编码值的顺序，对数据进行排序。SQL Server 中的二进制排序规则强制使用二进制排序顺序，定义了要使用的区域设置和 ANSI 代码页。由于二进制排序规则相对简单，因此对改进应用程序的性能非常有用。对于非 Unicode 数据类型，数据比较将基于 ANSI 代码页中定义的码位。对于 Unicode 数据类型，数据比较将基于 Unicode 码位。对于 Unicode 数据类型的二进制排序规则，数据排序将不考虑区域设置。例如，对 Unicode 数据应用 Latin_1_General_BIN 和 Japanese_BIN，会得到完全相同的排序结果。

SQL Server 中以“_BIN”结尾的早期二进制排序规则对 Unicode 数据执行的是不完整的逐码位比较。更早的 SQL Server 二进制排序规则将第一个字符作为 WCHAR 比较，接下来是逐字节比较。为了实现向后兼容，将不更改现有的二进制排序规则语义。

使用 BIN 排序规则的准则

如果您的 SQL Server 应用程序与使用二进制排序规则的旧版 SQL Server 交互，那么请继续使用二进制排序规则。二进制排序规则可能更适合混合环境。

使用 BIN2 排序规则的准则

此版本的 SQL Server 中的二进制排序规则包含一组纯码位比较排序规则。您可以迁移到二进制排序规则，以利用真正的码位比较，并且应该使用新的二进制排序规则来开发新的应用程序。BIN2 后缀标识了实现新的码位排序规则语义的排序规则名称。另外，二进制排序还有一个与 BIN2 对应的比较标志。其优点包括更简单的应用程序开发和更清楚的语义。

请参阅

参考

排序规则和 Unicode 支持
安装程序中的排序规则设置


使用 SQL Server 排序规则

使用 SQL Server 排序规则 |
 | 请参阅
计划 SQL Server 安装 > 排序规则和 Unicode 支持 >

SQL Server 2008 排序规则设置取决于安装类型。通常，应当选择能够支持贵组织最常用的 Windows 系统区域设置的 SQL Server 排序规则。若要确定运行 Windows 2000 的计算机上的 Windows 系统区域设置，请在控制面板中单击“区域设置”，然后单击“高级”。在 Windows Vista 中，使用“格式”选项卡。若要确定运行 Windows Server 2003 的计算机上的 Windows 系统区域设置，请在控制面板中单击“区域和语言选项”，然后单击“区域选项”选项卡。在大多数情况下，计算机上运行的 Windows 系统区域设置与用户的语言要求相符。因此，SQL Server 安装程序会自动检测 Windows 系统区域设置并选择相应的 SQL Server 排序规则。为实现向后兼容，默认的英语（美国）排序规则为 SQL_Latin1_General*。

SQL Server 2008 排序规则控制以下内容：

  • 用于存储 SQL Server 中非 Unicode 数据的代码页。

  • 控制 SQL Server 如何对字符进行排序和比较的规则，这些字符以非 Unicode 数据类型存储。SQL Server 安装程序将在装有 SQL Server 的计算机上检测 Windows 排序规则，然后将自动为您的 SQL Server 实例选择排序规则。Unicode 字符和非 Unicode 字符的排序和比较可能不同。

可以使用下表来确定应当选择的排序规则（如果有的话）。

注意：
如果从早期版本的 SQL Server 排序规则设置进行升级，则不需要选择排序规则。

任务 | 排序规则
在不需要与任何现有系统同步的新系统上安装。 | 采用安装程序确定的排序规则，然后选择所需的二进制、大小写或其他选项。 当 SQL Server 安装程序检测到计算机运行的是美国英语系统区域设置时，安装程序会自动选择“字典顺序，不区分大小写，用于 1252 字符集” SQL Server 2008 排序规则。 若要选择等效的 Windows 排序规则，请选择“排序规则指示符”，选择 Latin1_General，然后清除“区分大小写”和“区分重音”。
将已安装的 SQL Server 6.5 或 SQL Server 7.0 升级至 SQL Server，或安装将与已安装的 SQL Server 6.5 进行版本切换的 SQL Server 2008 默认实例。 | 使用安装程序所选的 SQL Server 2008 排序规则。
与 SQL Server 的现有实例同步。 | 针对现有实例在代码编辑器中选择 SERVERPROPERTY(N'Collation')，并指定排序规则。有关详细信息，请参阅 SERVERPROPERTY (Transact-SQL)。如果现有实例的排序规则名称是以“SQL”开头，请在安装程序中选择相同的 SQL Server 排序规则。如果现有实例的排序规则名称不是以“SQL”开头，那么排序规则名称指的是 Windows 排序规则名称。该名称由排序规则指示符名称后加说明组成，说明包括所指定的二进制、区分大小写、区分重音、区分假名以及区分全半角选项。请在 SQL Server 安装程序中选择相同的 Windows 排序规则指示符和排序选项。 有关详细信息，请参阅 Windows 排序规则排序样式。
与 SQL Server 6.5、SQL Server 7.0 或 SQL Server 2000 的现有安装同步。 | 在现有系统上运行 sp_helpsort。随后，使用排序 ID 选择 SQL Server 排序规则，使您的 SQL Server 实例与现有安装兼容。 有关详细信息，请参阅选择 SQL Server 排序规则。
与另一台计算机的 Windows 系统区域设置同步。 | 在控制面板中的“区域选项”（Windows 2000 或 Windows Server 2003）或“区域和语言选项”(Windows XP) 下找到区域设置名称，然后使用安装程序中的排序规则设置主题中提供的表。按照 Windows 排序规则排序样式中的说明设置排序选项。
注意：
在执行取决于排序规则的操作时，被引用对象所用的 SQL Server 排序规则必须使用操作系统所支持的代码页。

请参阅

参考

选择 SQL Server 排序规则

其他资源

Setting Client Code Pages
SQL Server 排序规则名称 (Transact-SQL)


选择 SQL Server 排序规则

选择 SQL Server 排序规则 |
 | 请参阅
计划 SQL Server 安装 > 排序规则和 Unicode 支持 > 使用 SQL Server 排序规则 >

本主题介绍用于需要与不使用排序规则的 SQL Server 版本兼容的 SQL Server 实例的 SQL Server 2008 排序规则选项。

SQL Server 安装向导的“排序规则设置”页列出了以下 SQL 排序规则。

SQL 排序顺序 ID | 排序顺序名称 | 说明 | SQL 排序规则
31 | diction.437 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp437_CS_AS_KI_WI
32 | nocase.437 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp437_CI_AS_KI_WI
33 | nocasepr.437 | 字典顺序，不区分大小写，大写字母优先 | SQL_Latin1_General_Pref_Cp437_CI_AS_KI_WI
34 | noaccent.437 | 字典顺序，不区分大小写，不区分重音 | SQL_Latin1_General_Cp437_CI_AI_KI_WI
40 | cp437bin.437 | 二进制 | SQL_Latin1_General_Cp437_BIN
40 | cp850bin.850 | 二进制 | SQL_Latin1_General_Cp850_BIN
41 | diction.850 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp850_CS_AS_KI_WI
42 | nocase.850 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp850_CI_AS_KI_WI
44 | noaccent.850 | 字典顺序，不区分大小写，不区分重音 | SQL_Latin1_General_Cp850_CI_AI_KI_WI
44 | nocase34.850 | 字典顺序，不区分大小写，大写字母优先 | SQL_Latin1_General_Pref_Cp850_CI_AS_KI_WI
49 | nocase34.850 | 与 1.x 版不区分大小写的数据库严格兼容 | SQL_1xCompat_Cp850_CI_AS_KI_WI
51 | diction.iso | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1_CS_AS_KI_WI
52 | nocase.iso | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1_CI_AS_KI_WI
53 | nocasepr.iso | 字典顺序，不区分大小写，大写字母优先 | SQL_Latin1_General_Pref_Cp1_CI_AS_KI_WI
54 | noaccent.iso | 字典顺序，不区分大小写，不区分重音 | SQL_Latin1_General_Cp1_CI_AI_KI_WI
55 | altdict.850 | 可选字典顺序，区分大小写 | SQL_AltDiction_Cp850_CS_AS_KI_WI
56 | altnocsp.850 | 可选字典顺序，不区分大小写，大写字母优先 | SQL_AltDiction_Pref_Cp850_CI_AS_KI_WI
57 | altnoacc.850 | 可选字典顺序，不区分大小写，不区分重音 | SQL_AltDiction_Cp850_CI_AI_KI_WI
58 | scan.850 | 斯堪的纳维亚文字典顺序，不区分大小写，大写字母优先 | SQL_Scandainavian_Pref_Cp850_CI_AS_KI_WI
59 | scandict.850 | 斯堪的纳维亚文字典顺序，区分大小写 | SQL_Scandainavian_Cp850_CS_AS_KI_WI
60 | scannocase.850 | 不区分大小写的斯堪的纳维亚文字典顺序，无大小写字母优先 | SQL_Scandainavian_Cp850_CI_AS_KI_WI
61 | altnocs.850 | 可选字典顺序，不区分大小写 | SQL_AltDiction_Cp850_CI_AS_KI_WI
80 | binary.250 | 二进制 | SQL_Latin1_General_1250_BIN
81 | diction.250 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1250_CS_AS_KI_WI
82 | nocase.250 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1250_CI_AS_KI_WI
83 | csydic.250 | 捷克文字典顺序，区分大小写 | SQL_Czech_Cp1250_CS_AS_KI_WI
84 | csync.250 | 捷克文字典顺序，不区分大小写 | SQL_Czech_Cp1250_CI_AS_KI_WI
85 | hundic.250 | 匈牙利文字典顺序，区分大小写 | SQL_Hungarian_Cp1250_CS_AS_KI_WI
86 | hunnc.250 | 匈牙利文字典顺序，不区分大小写 | SQL_Hungarian_Cp1250_CI_AS_KI_WI
87 | plkdic.250 | 波兰文字典顺序，区分大小写 | SQL_Polish_Cp1250_CS_AS_KI_WI
88 | plknc.250 | 波兰文字典顺序，不区分大小写 | SQL_Polish_Cp1250_CI_AS_KI_WI
89 | romdic.250 | 罗马尼亚文字典顺序，区分大小写 | SQL_Romanian_Cp1250_CS_AS_KI_WI
90 | romnc.250 | 罗马尼亚文字典顺序，不区分大小写 | SQL_Romanian_Cp1250_CI_AS_KI_WI
91 | shldic.250 | 克罗地亚文字典顺序，区分大小写 | SQL_Croatian_Cp1250_CS_AS_KI_WI
92 | shlnc.250 | 克罗地亚文字典顺序，不区分大小写 | SQL_Croatian_Cp1250_CI_AS_KI_WI
93 | skydic.250 | 斯洛伐克文字典顺序，区分大小写 | SQL_Slovak_Cp1250_CS_AS_KI_WI
94 | skync.250 | 斯洛伐克文字典顺序，不区分大小写 | SQL_Slovak_Cp1250_CI_AS_KI_WI
95 | slvdic.250 | 斯洛文尼亚文字典顺序，区分大小写 | SQL_Slovenian_Cp1250_CS_AS_KI_WI
96 | slvnc.250 | 斯洛文尼亚文字典顺序，不区分大小写 | SQL_Slovenian_Cp1250_CI_AS_KI_WI
104 | binary.250 | 二进制 | SQL_Latin1_General_1251_BIN
105 | diction.251 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1251_CS_AS_KI_WI
106 | nocase.251 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1251_CI_AS_KI_WI
107 | ukrdic.251 | 乌克兰文字典顺序，区分大小写 | SQL_Ukrainian_Cp1251_CS_AS_KI_WI
108 | ukrnc.251 | 乌克兰文字典顺序，不区分大小写 | SQL_Ukrainian_Cp1251_CI_AS_KI_WI
112 | binary.253 | 二进制 | SQL_Latin1_General_1253_BIN
113 | diction.253 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1253_CS_AS_KI_WI
114 | nocase.253 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1253_CI_AS_KI_WI
121 | graltdct.253 | 字典顺序，区分大小写，区分重音 | SQL_Latin1_General_Cp1253_CI_AS_KI_WI
124 | grnoacce.253 | 字典顺序，不区分大小写，不区分重音 | SQL_Latin1_General_Cp1253_CI_AI_KI_WI
128 | binary.254 | 二进制 | SQL_Latin1_General_1254_BIN
129 | diction.254 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1254_CS_AS_KI_WI
130 | nocase.254 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1254_CI_AS_KI_WI
136 | binary.255 | 二进制 | SQL_Latin1_General_1255_BIN
137 | diction.255 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1255_CS_AS_KI_WI
138 | nocase.255 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1255_CI_AS_KI_WI
144 | binary.256 | 二进制 | SQL_Latin1_General_1256_BIN
145 | diction.256 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1256_CS_AS_KI_WI
146 | nocase.256 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1256_CI_AS_KI_WI
152 | binary.257 | 二进制 | SQL_Latin1_General_1257_BIN
153 | diction.257 | 字典顺序，区分大小写 | SQL_Latin1_General_Cp1257_CS_AS_KI_WI
154 | nocase.257 | 字典顺序，不区分大小写 | SQL_Latin1_General_Cp1257_CI_AS_KI_WI
155 | etidic.257 | 爱沙尼亚文字典顺序，区分大小写 | SQL_Estonian_Cp1257_CS_AS_KI_WI
156 | etinc.257 | 爱沙尼亚文字典顺序，不区分大小写 | SQL_Estonian_Cp1257_CI_AS_KI_WI
157 | lvidic.257 | 拉脱维亚文字典顺序，区分大小写 | SQL_Latvian_Cp1257_CS_AS_KI_WI
158 | lvinc.257 | 拉脱维亚文字典顺序，不区分大小写 | SQL_Latvian_Cp1257_CI_AS_KI_WI
159 | lthdic.257 | 立陶宛文字典顺序，区分大小写 | SQL_Lithuanian_Cp1257_CS_AS_KI_WI
160 | lthnc.257 | 立陶宛文字典顺序，不区分大小写 | SQL_Lithuanian_Cp1257_CI_AS_KI_WI
183 | danonocp.iso | 丹麦/挪威文字典顺序，不区分大小写，大写字母优先 | SQL_Danish_Pref_Cp1_CI_AS_KI_WI
184 | islanocp.iso | 瑞典/芬兰文[电话簿]字典顺序，不区分大小写，大写字母优先 | SQL_SwedishPhone_Pref_Cp1_CI_AS_KI_WI
185 | svf2nocp.iso.iso | 瑞典/芬兰文[标准]字典顺序，不区分大小写，大写字母优先 | SQL_SwedishStd_Pref_Cp1_CI_AS_KI_WI
186 | islanocp.iso | 冰岛文字典顺序，不区分大小写，大写字母优先 | SQL_Icelandic_Pref_Cp1_CI_AS_KI_WI
注意：
每个 SQL 排序规则名称在 Transact-SQL 代码中都有一个等效的字符串。有关详细信息，请参阅SQL Server 排序规则名称 (Transact-SQL)。

请参阅

参考

安装程序中的排序规则设置

概念

使用 SQL Server 排序规则


SQL Server 的产品规格

SQL Server 的产品规格
计划 SQL Server 安装 >

下列主题提供了此版本产品规格的详细说明。

SQL Server 2008 的版本和组件

选择要安装的组件和功能。

SQL Server 的最大容量规范

各种 SQL Server 对象的最大容量。

各版本 SQL Server 支持的最大处理器数

SQL Server 的每个版本支持的最大处理器数目。


SQL Server 的最大容量规范

SQL Server 的最大容量规范 |
 | 请参阅
计划 SQL Server 安装 > SQL Server 的产品规格 >

以下各表指定 SQL Server 组件中定义的各种对象的最大大小和最大数量。

数据库引擎对象

下表指定在 SQL Server 数据库中定义的或在 Transact-SQL 语句中引用的各种对象的最大大小和最大数量。

SQL Server 数据库引擎对象 | 最大大小/数量 － SQL Server（32 位） | 最大大小/数量 － SQL Server（64 位）
批大小1 | 65,536 * 网络数据包大小 | 65,536 * 网络数据包大小
每个短字符串列的字节数 | 8,000 | 8,000
每个 GROUP BY、ORDER BY 的字节数 | 8,060 | 8,060
每个索引键的字节数2 | 900 | 900
每个外键的字节数 | 900 | 900
每个主键的字节数 | 900 | 900
每行的字节数8 | 8,060 | 8,060
存储过程源文本中的字节数 | 批处理大小中的较小者或 250 MB | 批处理大小中的较小者或 250 MB
每个 varchar(max)、varbinary(max)、xml、text 或 image 列的字节数 | 2^31-1 | 2^31-1
每个 ntext 或 nvarchar(max) 列的字符数 | 2^30-1 | 2^30-1
每个数据表的聚集索引数 | 1 | 1
GROUP BY、ORDER BY 中的列数 | 仅受字节数限制 | 仅受字节数限制
GROUP BY WITH CUBE 或 WITH ROLLUP 语句中的列数或表达式数目 | 10 | 10
每个索引键的列数7 | 16 | 16
每个外键的列数 | 16 | 16
每个主键的列数 | 16 | 16
每个非宽表的列数 | 1,024 | 1,024
每个宽表的列数 | 30,000 | 30,000
每个 SELECT 语句的列数 | 4,096 | 4,096
每个 INSERT 语句的列数 | 4096 | 4096
每个客户端的连接个数 | 已配置连接的最大值 | 已配置连接的最大值
数据库大小 | 524,272 TB | 524,272 TB
每个 SQL Server 实例的数据库个数 | 32,767 | 32,767
每个数据库的文件组个数 | 32,767 | 32,767
每个数据库的文件个数 | 32,767 | 32,767
文件大小（数据） | 16 TB | 16 TB
文件大小（日志） | 2 TB | 2 TB
每个表的外键表引用数4 | 253 | 253
标识符长度（以字符计） | 128 | 128
每台计算机的实例数 | 所有 SQL Server 版本（Workgroup 除外）的独立服务器上为 50 个实例。Workgroup 支持每台计算机上最多有 16 个实例。 SQL Server 支持故障转移群集上有 25 个实例。 | 独立服务器上为 50 个实例。 故障转移群集上 25 个实例。
包含 SQL 语句的字符串的长度（批大小）1 | 65,536 * 网络数据包大小 | 65,536 * 网络数据包大小
每个连接的锁数 | 每个服务器的最大锁数 | 每个服务器的最大锁数
每个 SQL Server 实例的锁数5 | 最多 2,147,483,647 | 仅受内存限制
嵌套存储过程级别数6 | 32 | 32
嵌套子查询个数 | 32 | 32
嵌套触发器层数 | 32 | 32
每个数据表的非聚集索引个数 | 999 | 999
存在以下任意子句的情况下 GROUP BY 子句中的非重复表达式数目：CUBE、ROLLUP、GROUPING SETS、WITH CUBE、WITH ROLLUP | 32 | 32
GROUP BY 子句中的运算符生成的分组集数目 | 4,096 | 4,096
每个存储过程的参数个数 | 2,100 | 2,100
每个用户定义函数的参数个数 | 2,100 | 2,100
每个数据表的 REFERENCE 个数 | 253 | 253
每个数据表的行数 | 受可用存储空间限制 | 受可用存储空间限制
每个数据库的表数3 | 受数据库中对象数限制 | 受数据库中对象数限制
每个分区表或索引的分区数 | 1,000 | 1,000
非索引列的统计信息条数 | 30,000 | 30,000
每个 SELECT 语句的表个数 | 256 | 256
每个表的触发器个数3 | 受数据库中对象数限制 | 受数据库中对象数限制
每个 UPDATE 语句（宽表）的列数 | 4096 | 4096
用户连接 | 32,767 | 32,767
XML 索引 | 249 | 249

1网络数据包大小指的是用于在应用程序和关系数据库引擎之间进行通信的表格格式数据流 (TDS) 数据包的大小。默认的数据包大小为 4 KB，由“网络数据包大小”配置选项控制。

2在 SQL Server 中，任何索引键的最大字节数不能超过 900。可以使用最大大小合计超过 900 的可变长度列定义键，前提是这些列中所插入行的数据都不超过 900 字节。在 SQL Server 中，可将非键列包含于非聚集索引中以避免最大索引键大小 900 字节的限制。

3数据库对象包括诸如表、视图、存储过程、用户定义函数、触发器、规则、默认值和约束等对象。数据库中所有对象的数量总和不能超过 2,147,483,647。

4尽管表可以包含无限数量的 FOREIGN KEY 约束，但建议最大数量取为 253。根据承载 SQL Server 的硬件配置，指定额外的 FOREIGN KEY 约束对查询优化器的处理而言可能开销很大。

5此值针对静态锁分配。动态锁仅受内存限制。

6如果存储过程访问的数据库多于 8 个，或者交替访问的数据库多于 2 个，将收到错误信息。

7如果表包含一个或多个 XML 索引，由于 XML 列被添加到主 XML 索引的聚集键，用户表的聚集键被限制为 15 列。在 SQL Server 中，可在非聚集索引中包括非键列以避免最多为 16 个键列的限制。有关详细信息，请参阅具有包含列的索引。

8 SQL Server 支持行溢出存储，行溢出存储使长度可变的列可以被推送到行外。只有 24 字节的根存储在推送出行外的可变长度列的主记录中；因此，此版本中的有效行限制高于 SQL Server 早期版本中的有效行限制。有关详细信息，请参阅 SQL Server 联机丛书中的“行溢出数据超过 8 KB”主题。

复制对象

下表指定了 SQL Server 复制中定义的各种对象的最大大小和最大数量。

SQL Server 复制对象 | 最大大小/数量 － SQL Server（32 位） | 最大大小/数量 － SQL Server（64 位）
项目（合并发布） | 256 | 256
项目（快照发布或事务发布） | 32,767 | 32,767
表中的列1（合并发布） | 246 | 246
表中的列数2（SQL Server 快照发布或事务发布） | 1,000 | 1,000
表中的列2（Oracle 快照发布或事务发布） | 995 | 995
行筛选器中使用的列的字节数（合并发布） | 1,024 | 1,024
行筛选器中使用的列的字节数（快照发布或事务发布） | 8,000 | 8,000

1如果将行跟踪用于冲突检测（默认设置），则基表最多可以包含 1,024 列，但必须从项目中对这些列进行筛选，以便最多可发布 246 列。如果使用列跟踪，则基表最多可以包含 246 列。有关跟踪级别的详细信息，请参阅合并复制如何检测和解决冲突的“跟踪级别”部分。

2基表可以包含发布数据库中允许的最大数量的列（在 SQL Server 中为 1024），但如果这些列的数目超过为发布类型指定的最大值，则必须从项目中筛选这些列。

请参阅

参考

安装 SQL Server 2008 的硬件和软件要求
系统配置检查器的检查参数


各版本 SQL Server 支持的最大处理器数

各版本 SQL Server 支持的最大处理器数 |
 | 请参阅
计划 SQL Server 安装 > SQL Server 的产品规格 >

SQL Server 支持将处理器套接字的指定数量与每个套接字中的逻辑 CPU 数量相乘。例如，在下表中，下面的处理器将被视为单处理器：

  • 每个套接字层中有 2 个逻辑 CPU 的单核超线程处理器。

  • 具有 2 个逻辑 CPU 的双核处理器。

  • 具有 4 个逻辑 CPU 的四核处理器。

SQL Server 基于处理器套接字（而非逻辑 CPU）进行授权。

SQL Server 2008 版本 | 支持的处理器数
Enterprise | 操作系统支持的最多处理器
Standard | 4
Web | 4
Workgroup | 2
Express | 1
带高级服务的 Express | 1

请参阅

参考

SQL Server 2008 的各个版本所支持的内存
安装 SQL Server 2008 的硬件和软件要求

其他资源

SQL Server 的产品规格


SQL Server 2008 的各个版本所支持的内存

SQL Server 2008 的各个版本所支持的内存 |
 | 请参阅
计划 SQL Server 安装 > SQL Server 的产品规格 >

下表指示了 SQL Server 2008 的各个版本所支持的最大内存。

SQL Server 版本 | 支持的最大内存
Enterprise | 操作系统最大值
Developer | 操作系统最大值
Standard | 操作系统最大值
Web | 操作系统最大值
Workgroup | 4 GB（64 位），操作系统最大值（32 位）
Express | 1 GB
Express with Advanced Services | 1 GB

请参阅

参考

安装 SQL Server 2008 的硬件和软件要求

其他资源

SQL Server 的产品规格


高可用性解决方案概述

高可用性解决方案概述 |
 | 请参阅
计划 SQL Server 安装 >

本节介绍了几个提高服务器或数据库可用性的 SQL Server 高可用性解决方案。高可用性解决方案可减少硬件或软件故障造成的影响，保持应用程序的可用性，尽可能地减少用户所感受到的停机时间。

SQL Server 提供了几个使服务器或数据库具有高可用性的可选方案。高可用性可选方案包括：

  • 故障转移群集

    故障转移群集可对整个 SQL Server 实例的高可用性提供支持。故障转移群集由具有两个或多个共享磁盘的一个或多个节点或服务器组成。各应用程序将安装到一个称为“资源组”的 Microsoft 群集服务 (MSCS) 群集组中。在任何时候，每个资源组都仅属于群集中的一个节点。该应用程序服务具有一个与节点名称无关的虚拟名称，称为故障转移群集实例名称。应用程序可以通过引用故障转移群集实例名称与故障转移群集实例连接。应用程序不必知道哪一节点承载该故障转移群集实例。

    SQL Server 故障转移群集实例将像单台计算机一样显示在网络中，不过它具有一种功能，即在当前节点不可用时，可以在节点之间进行故障转移。例如，在发生非磁盘硬件故障、操作系统故障或进行计划的操作系统升级时，可以在故障转移群集的一个节点上配置 SQL Server 实例，使其故障转移到磁盘组中的任意其他节点。

    故障转移群集不能防止磁盘故障。您可以使用故障转移群集来减少系统停机时间，提高应用程序可用性。SQL Server Enterprise 和 SQL Server Developer 均支持故障转移群集，SQL Server Standard 也支持故障转移群集，但有一些限制。有关故障转移群集的详细信息，请参阅SQL Server 2008 故障转移群集入门和安装 SQL Server 2008 故障转移群集。

  • 数据库镜像

    数据库镜像实际上是个软件解决方案，可提供几乎是瞬时的故障转移，以提高数据库的可用性。数据库镜像可以用来维护相应生产数据库（称为“主体数据库”）的单个备用数据库（或“镜像数据库”）。

    通过还原但不恢复主体数据库的数据库备份可创建镜像数据库。这使客户端不能访问镜像数据库。但是，为了进行报告，可通过创建镜像数据库的数据库快照间接使用镜像数据库。数据库快照为客户端提供了快照创建时对数据库中数据的只读访问。

    每个数据库镜像配置都涉及包含主体数据库的“主体服务器”，并且还涉及包含镜像数据库的镜像服务器。镜像服务器不断地使镜像数据库随主体数据库一起更新。

    数据库镜像在高安全性模式下以同步操作运行，或在高性能模式下以异步操作运行。在高性能模式下，事务不需要等待镜像服务器将日志写入磁盘便可提交，这样可最大程度地提高性能。在高安全性模式下，已提交的事务将由伙伴双方提交，但会延长事务滞后时间。

    数据库镜像的最简单配置仅涉及主体服务器和镜像服务器。在该配置中，如果主体服务器丢失，则该镜像服务器可以用作备用服务器，但可能会造成数据丢失。高安全性模式支持具有自动故障转移功能的备用配置高安全性模式。这种配置涉及到称为“见证服务器”的第三方服务器实例，它能够使镜像服务器用作热备用服务器。从主体数据库到镜像数据库的故障转移通常需要几秒钟的时间。

    SQL Server 2005 Standard SP1 及更高版本和 SQL Server 2005 Enterprise Edition SP1 及更高版本支持数据库镜像伙伴和见证服务器。前提是各伙伴都必须使用相同的版本，只有 SQL Server 2005 Enterprise Edition SP1 及更高版本支持异步数据库镜像（高性能模式）。SQL Server 2005 Workgroup SP1 及更高版本和 SQL Server 2005 Express Edition SP1 及更高版本也支持见证服务器。有关数据库镜像的详细信息，请参阅数据库镜像。

  • 日志传送

    与数据库镜像一样，日志传送是数据库级操作。可以使用日志传送来维护相应生产数据库（称为“主数据库”）的一个或多个温备用数据库。备用数据库也称为“辅助数据库”。通过还原或使用备份但不恢复主数据库的数据库备份创建每个辅助数据库。使用备份还原可以将生成的辅助数据库用于有限的报表。

    日志传送配置包括一个主服务器（包含主数据库），一个或多个辅助服务器（每个服务器包含一个辅助数据库）和一个监视服务器。每个辅助服务器从主数据库的日志备份按设置的时间间隔更新其辅助数据库。日志传送涉及到主服务器创建主数据库日志备份和辅助服务器还原日志备份之间用户可修改的延迟。发生故障转移之前，必须通过手动应用全部未还原的日志备份来完全更新辅助数据库。

    日志传送具有支持多个备用数据库的灵活性。如果需要多个备用数据库，可以单独使用日志传送或将其作为数据库镜像的补充。当这些解决方案一起使用时，当前数据库镜像配置的主体数据库同时也是当前日志传送配置的主数据库。

    SQL Server Enterprise Edition、Standard Edition 和 Workgroup Edition 均支持日志传送。有关日志传送的详细信息，请参阅日志传送概述和日志传送管理。

  • 复制

    复制使用发布-订阅模式。这样，主服务器（称为发布服务器）便可向一个或多个辅助服务器（即订阅服务器）分发数据。复制可在这些服务器间提供实时的可用性和可伸缩性。它支持筛选，以便为订阅服务器提供数据子集，同时还支持分区更新。订阅服务器处于联机状态，并且可用于报告或其他功能，而无需进行查询恢复。SQL Server 提供三种复制类型：快照复制、事务复制以及合并复制。事务复制的滞后时间最短，常用于要求高可用性的情况。有关详细信息，请参阅改善伸缩性和可用性。

    SQL Server 的所有版本都支持复制。SQL Server Express 或 SQL Server Compact 3.5 不提供复制发布。

    重要提示：
    完善地设计与实施备份和还原策略对任何高可用性解决方案都十分重要。有关详细信息，请参阅在 SQL Server 中备份和还原数据库和备份和还原复制的数据库。

  • 可伸缩共享数据库

    使用可伸缩共享数据库功能可以扩展专门为报表生成的只读数据库。报表数据库必须驻留在一组专用的只读卷上，这些卷主要用于承载数据库。使用商用服务器硬件和商用卷硬件，您可以扩展报表数据库，使之在多台报表服务器上提供相同的报表数据视图。此功能还允许报表数据库使用平稳的更新路径。有关详细信息，请参阅可缩放共享数据库概述。

本节内容

主题 | 说明
选择高可用性解决方案 | 介绍选择高可用性解决方案的注意事项。

请参阅

参考

安装 SQL Server 2008 的硬件和软件要求

其他资源

数据库镜像概述
日志传送概述
SQL Server 复制


选择高可用性解决方案

选择高可用性解决方案
计划 SQL Server 安装 > 高可用性解决方案概述 >

下面列举了选择高可用性解决方案的注意事项：

  • 故障转移群集和数据库镜像都提供以下功能：

    • 自动检测和故障转移

    • 手动故障转移

    • 透明客户端重定向

    故障转移群集具有下列限制：

    • 需要在服务器实例范围内进行操作

    • 需要签名的硬件

    • 备用部分不具有报告功能

    • 利用数据库的单个副本

    • 不能防止磁盘故障

    数据库镜像具有下列优势：

    • 需要在数据库作用范围内操作。

    • 使用数据库单一、重复的副本

      注意：
      如果需要其他副本，则除了数据库镜像之外，还可以使用数据库的日志传送功能。

    • 使用标准服务器

    • 只能使用数据库快照对镜像服务器进行有限的报告。

    • 同步操作时，为了提供零工作丢失，将在主体数据库上延迟提交。

    数据库镜像所带来的可用性等级比以前使用 SQL Server 所能达到的可用性等级有了大幅提升，并提供了一种易于管理的故障转移群集替代方案。

  • 日志传送

    日志传送可以用于补充或替代数据库镜像。虽然异步数据库镜像与日志传送在概念上很相似，但它们仍有很大差异。日志传送具有下列独特的功能：

    • 针对单个主数据库在多个服务器实例上支持多个辅助数据库。

    • 允许用户将延迟时间定义为：从主服务器备份主数据库日志到辅助服务器必须还原日志备份之间的时间。例如，如果主数据库上的数据被意外更改，则较长的延迟会很有用。如果很快发现意外更改，则通过延迟，您可以在辅助数据库反映此更改之前从其中检索仍未更改的数据。

      与日志传送相比，异步数据库镜像具有的潜在优势为：在主数据库中进行指定更改与此更改反映到镜像数据库之间的时间更短。

      数据库镜像相对于日志传送的优势是：它是一种高安全性模式，是作为简单故障转移策略而支持的“无数据丢失”配置。

      注意：
      有关如何将日志传送与数据库镜像结合使用的信息，请参阅数据库镜像和日志传送。

  • 复制

    复制具有下列优势：

    • 因为筛选在数据库范围内进行操作，因此允许在数据库中进行筛选，以便为辅助数据库提供数据子集。

    • 支持多个冗余数据库副本

    • 支持在多个数据库间实现实时的可用性和可伸缩性，支持分区更新

    • 允许辅助数据库完全可用于报告或其他功能，而无需查询恢复。

    注意：
    有关如何将其他高可用性解决方案与复制结合使用的信息，请参阅复制和数据库镜像和复制和日志传送。


SQL Server 2008 故障转移群集入门

SQL Server 2008 故障转移群集入门 |
 | 请参阅
计划 SQL Server 安装 > 高可用性解决方案概述 >

SQL Server 中的故障转移群集为整个 SQL Server 实例提供高可用性支持。例如，您可以将故障转移群集的一个节点上的 SQL Server 实例配置为在发生硬件错误、操作系统错误或计划升级时故障转移到此群集中的任何其他节点。

故障转移群集是一个或多个节点（服务器）与两个或多个共享磁盘的组合，即资源组。资源组（包括其网络名称）和一个 Internet 协议 (IP) 地址组合在一起，构成了称为“故障转移群集或故障转移群集实例”的群集应用程序或群集服务器。SQL Server 故障转移群集出现在网络中时就像是单台计算机一样，但是它具有一种功能，能够在当前节点不可用时从一个节点故障转移到另一个节点。故障转移群集出现在网络中时就像一个普通应用程序或单台计算机一样，但是它具有可提高可用性的其他功能。

对于 SQL Server 2008 中的所有安装方案，故障转移群集都具有一个新的体系结构和新的工作流。两个安装选项是集成安装和高级/企业安装。集成安装将创建并配置一个单节点 SQL Server 故障转移群集实例。其他节点是使用安装程序中的添加节点功能添加的。例如，对于集成安装，您运行安装程序以创建一个单节点故障转移群集。然后，您再次为要添加到群集的每个节点运行安装程序。高级/企业安装包括两个步骤。准备步骤准备要运行的故障转移群集的所有节点。节点是在此初始步骤中定义并进行准备的。准备节点之后，将在活动节点（即具有共享磁盘的节点）上运行完成步骤，以完成故障转移群集实例并使其能够运行。

何时使用故障转移群集

使用故障转移群集可以执行下列操作：

  • 从群集 SQL Server 配置中的任何节点管理故障转移群集。有关详细信息，请参阅安装 SQL Server 2008 故障转移群集。

  • 允许某个故障转移群集节点将故障转移到故障转移群集配置中的任何其他节点。有关详细信息，请参阅安装 SQL Server 2008 故障转移群集。

  • 为故障转移群集配置 Analysis Services。有关详细信息，请参阅How to: install Analysis Services on a failover cluster。

  • 使用 Microsoft Search 服务与故障转移群集执行全文查询。有关详细信息，请参阅在故障转移群集中使用 SQL Server 工具。

安装故障转移群集

必须按照具体的安装步骤进行操作，才能使用故障转移群集。

若要安装、配置和维护 SQL Server 故障转移群集，请使用 SQL Server 安装程序。使用故障转移群集中的 SQL Server 安装程序可以执行下列操作：

  • 安装 SQL Server 来创建故障转移群集。

    在安装故障转移群集之前，必须确保系统满足最低要求并配置 Microsoft 群集服务 (MSCS)。有关故障转移群集的具体要求的详细信息，请参阅安装故障转移群集前的准备工作。

    故障转移群集中的所有节点都必须属于同一平台（可以是 32 位或 64 位平台），并且必须运行相同版本的操作系统。而且，64 位 SQL Server 版本必须安装在运行 64 位版本的 Windows 操作系统的 64 位硬件上。此版本中不对故障转移群集提供 WOW64 支持。

  • 在故障转移群集配置中添加或删除节点而不影响其他群集节点。有关详细信息，请参阅如何在 SQL Server 故障转移群集中添加或删除节点（安装程序）。

  • 为每个故障转移群集实例指定多个 IP 地址。可以为每个服务器指定多个 IP 地址，并可以使用所有可用的网络 IP 子网。SQL Server 使您只能为每个网络指定一个 IP 地址。这可以在一个子网出现故障时提供其他网络连接。

故障转移群集支持

在 SQL Server 中，故障转移群集支持的节点数取决于操作系统以及 SQL Server 的版本。有关 SQL Server 故障转移群集支持的一系列工具、功能和服务，请参阅 Features Supported by the Editions of SQL Server 2005。

请参阅

任务

如何创建新的 SQL Server 故障转移群集（安装程序）

概念

安装故障转移群集前的准备工作
如何从命令提示符安装 SQL Server 2008


安装故障转移群集前的准备工作

安装故障转移群集前的准备工作 |
 | 请参阅
计划 SQL Server 安装 > 高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 >

安装 SQL Server 故障转移群集之前，必须选择运行 SQL Server 的硬件和操作系统。还必须配置 Microsoft 群集服务 (MSCS)，检查网络和安全性并了解将在故障转移群集上运行的其他软件的注意事项。

安装准备一览表

开始安装故障转移群集之前，请检查以下各项。

确认您的硬件解决方案

  • 对于 Windows Server 2003，您的硬件必须是 Windows Catalog and Hardware Compatibility List（Windows 目录和硬件兼容性列表）中列出的硬件。硬件系统必须是显示在群集解决方案类别下的硬件系统。Windows Server 2008 有一个可针对故障转移群集解决方案评估硬件兼容性的实用工具。

    重要提示：
    将各个群集组件添加在一起并不能构成核准的故障转移群集系统。只有作为群集解决方案购买并且在群集组中列出的系统才是核准系统。检查 Windows 目录和 Windows 硬件兼容性列表时，请将类别指定为“群集”。所有其他类别均用于 OEM。有关详细信息，请参阅 The Microsoft support policy for server clusters, the Hardware Compatibility List, and the Windows Server Catalog（针对服务器群集、硬件兼容性列表和 Windows Server 目录的 Microsoft 支持策略）。

  • 在存储区域网络 (SAN) 上实现故障转移服务器群集时，需要进行专门的硬件兼容性测试。整个硬件解决方案都必须包含在 Windows 目录和硬件兼容性列表的“群集/多群集设备”类别中。

  • 如果群集解决方案中包含地理位置分散的群集节点，则还必须验证如网络延迟和共享磁盘支持等附加项。整个方案都必须包含在地理群集硬件兼容性列表中。有关详细信息，请参阅 Microsoft 知识库中的 Windows clustering and geographically separate sites（Windows 群集和地理位置分散的站点）。

  • Windows 2000 Advanced Server 和 Datacenter Server 版还支持 SAN 配置。Windows 目录和硬件兼容性列表中的“群集/多群集设备”类别中列出了一组支持 SAN 的存储设备，这些设备已经过测试，可作为 SAN 存储单元并且附加多个 MSCS 群集。通过将此列表中的设备与 Windows 目录和硬件兼容性列表的“群集”类别中定义的完整群集配置相匹配，您可以以 Microsoft 支持的方式在具有共享存储设备的 SAN 结构上部署一组 Windows 服务器和群集。有关详细信息，请参阅 Microsoft 知识库中的 Datacenter 计划和 Windows 2000 Datacenter Server 产品。

  • 如果您在 iSCSI 技术组件上部署 SQL Server 故障转移群集，建议您多加注意。有关详细信息，请参阅 Microsoft 知识库中的 Support for SQL Server 2000 on iSCSI technology components（对 iSCSI 技术组件上的 SQL Server 2000 的支持）。

  • 有关支持信息，请参阅 Microsoft 知识库中的 SQL Server support policy for Microsoft Clustering（针对 Microsoft 群集的 SQL Server 支持策略）。

  • 考虑仲裁磁盘资源共享问题。在服务器群集中，仲裁磁盘包含服务器群集配置的主控副本，它还在群集节点之间的所有网络通信都失败时用作补救措施。根据实现的服务器群集类型，仲裁磁盘可能是共享群集磁盘阵列上的物理磁盘，也可能不是。尽管最好是将整个群集磁盘用作仲裁磁盘，但也可以允许仲裁资源之外的其他资源访问仲裁磁盘。

    然而，使仲裁资源与其他资源共享同一磁盘会使您处于两难境地。您要么必须配置资源以使组不受其故障的影响，要么必须允许组受其他资源故障的影响。在第一种情况下，资源将不再支持故障转移；在第二种情况下，仲裁资源将随组（包含仲裁资源和出现故障的资源）的其余部分进行故障转移。结果是，在完成组的故障转移之前，整个群集将处于脱机状态。

    有关正确的仲裁驱动器配置的详细信息，请参阅 Microsoft 知识库文章 Quorum Drive Configuration Information（仲裁驱动器配置信息）。

  • 当源安装文件与 SQL Server 故障转移群集位于不同的域中时，若要安装该群集，请将安装文件复制到该群集的主节点上，然后从主节点开始安装。

确认您的操作系统设置

  • 确保您的操作系统已正确安装并且支持故障转移群集。有关详细信息，请参阅安装 SQL Server 2008 的硬件和软件要求。

  • 在 Windows Server 2003 上启用 Windows 加密服务提供程序 (CSP)。如果在任何群集节点上停止或禁用 CSP 服务，SQL Server 安装程序将失败，并显示一个“Windows 徽标要求”对话框。

  • SQL Server 支持装入点；SQL Server 的群集安装数取决于可用驱动器号的数量。如果只对操作系统使用一个驱动器号，而所有其他驱动器号均可用作正常群集驱动器或群集驱动器宿主装入点，则每个故障转移群集最多只能有 25 个 SQL Server 实例。

    通过已装入卷或装入点可以使用单个驱动器号来引用多个磁盘或卷。如果您有一个驱动器号 D: 引用常规磁盘或卷，则您可以在附加磁盘或卷不需要拥有各自的驱动器号的情况下，在驱动器号 D: 下连接或“装入”附加磁盘或卷作为目录。

    SQL Server 故障转移群集的其他装入点注意事项：

    • SQL Server 安装程序要求已装入驱动器的基准驱动器具有关联驱动器号。对于故障转移群集安装，此基准驱动器必须是群集驱动器。在此版本中，不支持卷 GUID。

    • 不能在故障转移群集实例之间共享具有驱动器号的基准驱动器。这是对故障转移群集的正常限制，而不是对独立的多实例服务器的限制。

    • 特别要注意的是，设置故障转移群集时要确保基准驱动器和已装入磁盘或卷都已作为资源列在资源组中。SQL Server 安装程序会在故障转移群集安装过程中验证驱动器配置。

  • SQL Server 安装程序自动设置 SQL Server 群集组与将处于故障转移群集中的磁盘之间的依赖关系。因此不要在运行安装程序之前设置磁盘的依赖关系。

  • 若要对 SQL Server 2008 启用 Kerberos 身份验证，请参阅 Microsoft 知识库中的如何在 SQL Server 中使用 Kerberos 身份验证。

配置 Microsoft 群集服务器

  • 必须至少在服务器群集的一个节点上配置 Microsoft 群集服务器 (MSCS)。只有将 MSCS 安装在通过 MSCS 软件兼容性测试的硬件配置上，才支持 MSCS。您还必须将 SQL Server Enterprise 或 SQL Server Standard 与 MSCS 一起运行。SQL Server Enterprise 支持最多 8 节点的故障转移群集。SQL Server Standard 支持 2 节点的故障转移群集。

    有关在 Windows Server 2003 上安装和配置 MSCS 的详细信息，请参阅 Server clusters（服务器群集）。

  • SQL Server 服务的资源 DLL 导出两个函数，MSCS 群集管理器使用它们来检查 SQL Server 资源的可用性。一个是 LooksAlive，它是一项简单的检查，可以通过 Windows NT 服务控制管理器来查询服务状态。另一个是 IsAlive，它是一项较严格的检查，可以作为用户探测连接到 SQL Server 以执行一个简单查询。默认情况下，LooksAlive 每 5 秒触发一次，IsAlive 每 60 秒触发一次。可以通过 SQL Server 资源的“高级”选项卡中的 MSCS 群集管理器或者使用 Cluster.exe 命令提示实用工具来更改 LooksAlive 和 IsAlive 的轮询间隔。

  • MSCS 必须能够使用 IsAlive 检查来验证故障转移群集实例是否正在运行。这需要使用可信连接来连接到服务器。默认情况下，在群集的节点上未将运行群集服务的帐户配置为管理员，并且 BUILTIN\Administrators 组没有登录到 SQL Server 的权限。只有更改对群集节点的权限时，这些设置才会改变。

    确保运行群集服务的组或帐户可以登录到 SQL Server 以执行 IsAlive 检查。如果不能，IsAlive 检查将失败。MSCS 群集服务帐户必须至少拥有 SQL Server 的 public 权限，才可以定期运行 SELECT @@servername。

  • 安装 MSCS 时，请务必使用不同的服务帐户登录到 MSCS 和 SQL Server。否则，将无法使用群集命令更改群集服务密码。

  • 使用 MSCS 时，在其他节点联机之前，一个节点必须受共享 SCSI 总线的控制。不这样做会导致应用程序故障转移进入联机挂起状态并阻止故障转移到其他节点，或者会导致完全失败。如果您的群集系统具有专有安装进程，则应使用该专有进程。

安装 Microsoft 分布式事务处理协调器

在故障转移群集上安装 SQL Server 之前，请确定是否必须创建 Microsoft 分布式事务处理协调器 (MSDTC) 群集资源。如果只安装数据库引擎，则 MSDTC 群集资源不是必需的。如果要安装数据库引擎和 SSIS、工作站组件或者要使用分布式事务处理，则必须安装 MSDTC。请注意，MSDTC 对于仅 Analysis Services 实例不是必需的。

配置 Microsoft 分布式事务处理协调器

安装操作系统并配置群集后，您还必须使用群集管理器配置 MSDTC 以便在群集中使用。群集 MSDTC 失败不会导致 SQL Server 安装程序停止运行，但如果未能正确配置 MSDTC，则 SQL Server 应用程序功能可能会受影响。

其他软件注意事项

  • 确保所有群集节点配置相同，包括 COM+、磁盘驱动器号和 Administrators 组中的用户。

  • 确认已正确配置群集互连（信号）。有关详细信息，请参阅知识库文章建议在群集服务器上使用的专用“信号”配置。

  • 确认已清除所有节点中的系统日志，并再次查看了系统日志。确保在继续操作之前，日志中没有任何错误消息。

  • 如果采用与早期版本并行的配置来安装 SQL Server，则 SQL Server 服务必须只使用全局域组内的帐户。此外，SQL Server 服务所使用的帐户不得出现在本地 Administrators 组中。不遵守此原则会导致意外的安全行为。

  • 如果在原先不存在 Windows Server 2003 域控制器的环境中部署 Windows Server 2003 群集节点，请参阅将 Windows 2000 和 Windows Server 2003 群集节点用作域控制器。

  • 若要使用加密，请在 SQL Server 故障转移群集中的所有节点上安装带有完全限定的 MSCS 群集 DNS 名称的服务器证书。例如，如果您有一个包含两个节点（节点的名称分别为“Test1.DomainName.com”和“Test2.DomainName.com”）的群集和一个名为“Virtsql”的 SQL Server 故障转移群集实例，则必须获取“Virtsql.DomainName.com”的证书，并在 test1 和 test2 节点上安装该证书。然后，可以选中 SQL Server 配置管理器中的“强制协议加密”复选框，以将故障转移群集配置为使用加密。

    重要提示：
    在将证书安装到故障转移群集实例中的所有参与节点上之前，请勿选中“强制协议加密”复选框。

  • 确认 MSCS 群集上未安装防病毒软件。有关详细信息，请参阅 Microsoft 知识库文章 Antivirus software may cause problems with cluster services（防病毒软件可能会导致群集服务出现问题）。

  • 确认未压缩要安装 SQL Server 的磁盘。如果尝试将 SQL Server 安装到压缩驱动器上，SQL Server 安装程序将失败。

  • 对故障转移群集安装的群集组命名时，群集组名称中不能包含以下任何字符：

    • 小于运算符 (<)

    • 大于运算符 (>)

    • 双引号 (")

    • 单引号 (')

    • “and”符 (&)

    此外还要确认现有的群集组名称不包含不受支持的字符。

网络、端口和防火墙注意事项

  • 确认在开始安装 SQL Server 之前，已对所有专用网卡禁用 NetBIOS。

  • SQL Server 的网络名称和 IP 地址不能用于任何其他目的，如共享文件。如果要创建文件共享资源，请为该资源指定不同的唯一网络名称和 IP 地址。

    重要提示：
    Microsoft 建议您不要在数据驱动器上使用文件共享，因为它们可能影响 SQL Server 的行为和性能。

  • 虽然 SQL Server 在群集中支持 TCP/IP 上的命名管道和 TCP/IP 套接字，但 Microsoft 建议您在群集配置中使用 TCP/IP 套接字。

  • 为了确保故障转移群集功能正确工作，请针对 SQL Server 端口、SQL Browser 端口、文件和打印机共享（TCP 139/445 和 UDP 137/138）以及远程过程调用（TCP 端口 135）在防火墙配置设置中添加例外。

  • 必须启动并正在运行远程注册表服务。

  • 必须启用远程管理。

  • 对于 SQL Server 端口，请使用 SQL Server 配置管理器对您要取消阻止的实例检查 TCP/IP 协议的 SQL Server 网络配置。如果要在安装后使用 TCP 连接到 SQL Server，则必须对 IPALL 启用 TCP 端口。默认情况下，SQL Browser 侦听 UDP 端口 1434。

其他注意事项

  • 若要创建故障转移群集，您必须是本地管理员，有权作为服务登录并有权在故障转移群集实例的所有节点上作为操作系统的一部分工作。

  • 在安装或更新 SQL Server 故障转移群集之前，应禁用在安装过程中可能会使用 SQL Server 组件的所有应用程序和服务，但应使磁盘资源保持联机状态。

  • 在 Windows Server 2008 上，会自动生成用于 SQL Server 2008 服务的服务 SID。对于从 SQL Server 2000 或 SQL Server 2005 升级得到的 SQL Server 2008 故障转移群集实例，将保留现有的域组和 ACL 配置。

  • 在 Windows Server 2003 上，为将要作为 SQL Server 故障转移群集的一部分安装的群集服务创建域组。必须以作为域组成员的域帐户身份运行 SQL Server 服务、SQL Server Agent 服务、Analysis Services 服务以及 iFTS 服务。如果需要，请向域管理员询问现有域组的名称，或者为故障转移群集创建域组。有关详细信息，请参阅Domain Groups for Clustered Services。

  • 群集节点作为域控制器的情况下不支持 SQL Server 故障转移群集。

  • 配置域名服务 (DNS) 或 Windows Internet 名称服务 (WINS)。必须在要安装 SQL Server 故障转移群集的环境中运行 DNS 服务器或 WINS 服务器。SQL Server 安装程序要求 SQL Server IP 接口虚拟引用注册动态域名服务。如果无法完成动态注册，安装程序将失败，安装将回滚。如果没有可用的动态注册，则必须在 DNS 中预注册服务器。

  • 请查阅 安装 SQL Server 的安全注意事项中的内容。

  • 请查阅系统配置检查器的检查参数中的内容。

  • 考虑故障转移群集是否支持您要使用的 SQL Server 工具、功能和组件。有关详细信息，请参阅SQL Server 2008 故障转移群集入门。

  • 考虑您将如何监视和维护故障转移群集以实现高可用性目标。有关详细信息，请参阅维护故障转移群集和在故障转移群集中使用 SQL Server 工具。

  • 若要减少安装 SQL Server 故障转移群集所需的时间，可以在运行 SQL Server 安装程序之前，在所有故障转移群集节点上预安装 .NET Framework 2.0 2.0。

请参阅

参考

安装 SQL Server 2008 的硬件和软件要求
系统配置检查器的检查参数

概念

安装 SQL Server 2008 故障转移群集
安装 SQL Server 的安全注意事项


安装 SQL Server 2008 故障转移群集

安装 SQL Server 2008 故障转移群集 |
 | 请参阅
计划 SQL Server 安装 > 高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 >

若要安装 SQL Server 故障转移群集，您必须通过运行 SQL Server 安装程序来创建并配置一个故障转移群集实例。本主题介绍故障转移群集的元素，以及关于命名故障转移群集实例的重要信息。本主题还介绍了安装故障转移群集的基本步骤。

故障转移群集实例的元素

故障转移群集实例可以在参与故障转移群集节点的一个或多个计算机上运行。故障转移群集实例包括：

  • Microsoft 群集服务 (MSCS) 群集组（也称为“资源组”）中的一个或多个磁盘的组合。各资源组最多可包含一个 SQL Server 实例。

  • 故障转移群集实例的网络名称。

  • 分配给故障转移群集实例的一个或多个 IP 地址。

  • 一个包括 SQL Server、SQL Server 代理、全文搜索 (FTS) 服务以及复制在内的 SQL Server 实例。您可以安装仅包含 SQL Server、仅包含 Analysis Services 或同时包含 SQL Server 和 Analysis Services 的故障转移群集。

命名故障转移群集实例

SQL Server 故障转移群集实例总是象单个计算机那样出现在网络中。必须使用 SQL Server 故障转移群集实例名称来连接到 SQL Server 故障转移群集，而不能使用它碰巧运行的节点的计算机名称。这样做就能确保无论哪个节点运行 SQL Server，您始终能够用相同的名称连接到故障转移群集实例。

您的故障转移群集实例名称对于您的域而言必须是唯一的，SQL Server 不会侦听本地服务器的 IP 地址。相反，SQL Server 只会侦听在安装 SQL Server 故障转移群集实例过程中创建的虚拟 IP 地址。

SQL Server 根据故障转移群集内独特的注册表项和服务名称来确保 SQL Server 功能在故障转移后得以持续。因此，您为 SQL Server 实例（包括默认实例）提供的名称对于故障转移群集中的所有节点都必须是唯一的。使用唯一的实例名称将确保配置为故障转移到单一服务器的 SQL Server 实例拥有独特的注册表项和服务名称。

SQL Server 与故障转移群集合并时的注意事项

  • 如果您计划将多个独立的服务器合并到 SQL Server 故障转移群集实例，我们建议，作为计划过程的一部分，您务必确保群集节点的硬件配置足以支持将要承载的 SQL Server 实例数。

    以下是两个常用方案和可以应用到站点配置的建议解决方案的基础。

    方案 1

    您是托管站，想要提供最多 23 个的 SQL Server 实例，这些实例具有如下资源要求：

    • 23 个 SQL Server 实例中作为单个群集节点的每个实例需要 2 个处理器，共需要 46 个 CPU。

    • 23 个 SQL Server 实例中作为单个群集节点的每个实例需要 2 GB 内存，共需要 48 GB RAM（其中，额外的 2 GB 内存供操作系统使用）。

    • 23 个 SQL Server 实例中每个实例需要 4 个磁盘作为群集磁盘阵列，共需要 92 个磁盘。

    如果将故障转移成员数限制为可用节点的一半，则硬件要求将降为：

    • 23 个处理器、每节点 24 GB 内存和 46 个可用磁盘。

    通过支持装入点进一步减少了磁盘总数。SQL Server 将要求 23 个磁盘每个承载 3 个或更多的装入点，以便提高磁盘空间的可用性。

    潜在的限制是：如果处理器和内存要求提高，现有硬件可能无法在不损失现有 SQL Server 实例性能的情况下为这些要求提供支持。

    方案 2

    从现有 SQL Server 实例迁移到故障转移群集

    首先，必须收集现有服务器的当前基准，注意所有现有瓶颈。假定基准性能统计信息提供以下需求，并且带装入点的单个驱动器能满足驱动器要求，那么就可以采用下列配置：

    • SQL Server 1 - 8 个处理器，16 GB RAM

    • SQL Server 2 - 4 个处理器，8 GB RAM（需要 RAM，计划为 12 GB）

    • SQL Server 3 - 2 个处理器，16 GB RAM（基准表明需要更多处理器）

    • SQL Server 4 - 4 个处理器，8 GB RAM（需要更多网络带宽，为 4 个专用连接添加网络适配器）

    若要替换上述四个服务器，群集节点需要的最小配置如下：

    • 18 个处理器、54 GB 内存和 6 个网络适配器

在计算故障转移群集中的单个节点的最小配置的过程中要考虑下列内容：

  • 所需 CPU 总数

  • 所需总内存和

  • 所需磁盘数

  • 为操作系统添加 2 GB RAM

注意：以前 SQL Server 版本中遇到的磁盘限制不会影响 SQL Server 2008。SQL Server 的每个实例只需要一个群集磁盘来存放数据文件。

安装故障转移群集

若要安装故障转移群集，您必须是本地管理员，具有作为服务登录的权限以及在故障转移群集的所有节点上作为操作系统的一部分进行操作的权限。

若要通过使用 SQL Server 安装程序来安装故障转移群集，请执行以下步骤：

  1. 确定创建故障转移群集实例（如群集磁盘资源、IP 地址和网络名称）和可用于故障转移的节点所需的信息。有关详细信息，请参阅：

    • 安装故障转移群集前的准备工作

    • SQL Server 安装的安全注意事项

    必须在运行 SQL Server 安装程序之前完成这些配置步骤，可使用 Windows 群集管理器来执行操作。必须为要配置的各个故障转移群集实例设置一个 MSCS 组。

  2. 运行 SQL Server 安装程序，开始安装故障转移群集。对于 SQL Server 2008 中的所有安装方案，故障转移群集都具有一个新的体系结构和新的工作流。两个安装选项是集成安装和高级/企业安装。集成安装将创建并配置一个单节点 SQL Server 故障转移群集实例。使用安装程序中的添加节点功能添加其他节点。例如，对于集成安装，您运行安装程序以创建一个单节点故障转移群集。然后，您再次为要添加到群集的每个节点运行安装程序。高级/企业安装包括两个步骤。准备步骤准备要运行的故障转移群集的所有节点。节点是在此初始步骤中定义并进行准备的。准备节点之后，将在活动节点（即具有共享磁盘的节点）上运行完成步骤，以完成故障转移群集实例并使其能够运行。

请参阅

任务

如何创建新的 SQL Server 故障转移群集（安装程序）

概念

安装故障转移群集前的准备工作
如何从命令提示符安装 SQL Server 2008


升级 SQL Server 2008 故障转移群集

升级 SQL Server 2008 故障转移群集 |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 安装 SQL Server 2008 故障转移群集 >

在所有故障转移群集节点上，SQL Server 都支持分别从 SQL Server 2000 和 SQL Server 2005 故障转移群集升级数据库引擎和 Analysis Services。

支持详细信息如下所示：

  • 既支持通过用户界面进行升级，也支持从命令提示符进行升级。有关详细信息，请参阅如何升级 SQL Server 故障转移群集实例（安装程序）和如何从命令提示符安装 SQL Server 2008。

  • 从 SQL Server 2005 升级 – 可以从命令提示符在每个故障转移群集节点上运行升级，也可以使用安装程序用户界面来升级每个群集节点。如果要升级的实例上不存在全文搜索和复制功能，则会自动安装它们，而不能选择忽略它们。

  • 从 SQL Server 2005 升级 – 与从 SQL Server 2005 升级类似：可以从命令提示符在每个故障转移群集节点上运行升级，也可以使用安装程序用户界面来升级每个群集节点。仅支持 32 位方案。不支持从 SQL Server 2000（64 位）进行故障转移群集升级。有关详细信息，请参阅版本升级。

  • Service Pack 安装 – 必须将 SQL Server Service Pack 和修补程序分别应用于所有节点上的 SQL Server 2008 故障转移群集。

  • 以下方案在 SQL Server 2008 中不受支持：

    • 不能从独立的 SQL Server 实例迁移到 SQL Server 2008 故障转移群集。

    • 向 SQL Server 2008 故障转移群集中添加功能。例如，不能向现在仅 Analysis Services 的故障转移群集中添加数据库引擎。

    • 不能将 SQL Server 2008 故障转移群集节点降级为独立的 SQL Server 2008 实例。

  • 有关详细信息，请参阅 SQL Server 2008 故障转移群集入门。

请参阅

任务

如何升级 SQL Server 故障转移群集实例（安装程序）

参考

版本升级

概念

如何从命令提示符安装 SQL Server 2008


维护故障转移群集

维护故障转移群集 |
 | 请参阅
计划 SQL Server 安装 > 高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 >

安装 SQL Server 故障转移群集后，您可以使用 SQL Server 安装程序对其进行更改或修复。例如，您可以向故障转移群集实例添加其他节点、将群集实例作为独立实例运行或从群集实例配置中删除节点。

向现有故障转移群集实例添加节点

SQL Server 安装程序提供了用于维护现有故障转移群集实例的选项。如果选择此选项，则可通过在要添加到群集的计算机上运行 SQL Server 安装程序，向您的故障转移群集配置添加其他节点。有关详细信息，请参阅如何创建新的 SQL Server 故障转移群集（安装程序）和如何在 SQL Server 故障转移群集中添加或删除节点（安装程序）。

从现有故障转移群集实例删除节点

通过在要从群集删除的计算机上运行 SQL Server 安装程序，可以从故障转移群集配置中删除节点。SQL Server 故障转移群集配置中的每个节点都可以看作是一个对等方，不依赖于群集中的其他节点，因此，您可以删除其中的任何节点。已损坏的节点不一定能被删除，并且删除过程将不会从不可用的节点中卸载 SQL Server 二进制文件。可以随时将已删除的节点重新添加到故障转移群集内。有关详细信息，请参阅如何在 SQL Server 故障转移群集中添加或删除节点（安装程序）。

将 SQL Server 群集实例作为独立实例运行

通常情况下，SQL Server 群集实例在 Microsoft 群集服务 (MSCS) 的控制下运行。然而，也可能有必要将 SQL Server 群集实例作为独立实例运行。例如，若要以单用户模式运行 SQL Server 实例，则有必要从命令提示符将 SQL Server 群集实例作为独立实例运行，而不是通过 MSCS 启动 SQL Server。若要使用套接字以独立模式连接到 SQL Server 群集实例，则安装该实例的故障转移群集的 IP 地址和网络名称资源必须处于联机状态。

如果这些资源不能联机，可以使用命名管道进行连接。必须在客户端创建一个别名才能使用 SQL Server 实例正在监听的管道名称通信。可以使用 SQL Server 配置管理器来找出管道名称。

更改服务帐户

在故障转移群集节点关闭或脱机时，不得更改任何 SQL Server 服务帐户的密码。如果一定要这么做，则必须在所有节点都重新联机后再使用 SQL Server 配置管理器重置密码。

如果 SQL Server 的服务帐户不是群集中的管理员，则无法在该群集的任何节点上删除管理共享。管理共享必须在群集中可用，SQL Server 才能运行。

重要提示：
请勿对 SQL Server 服务帐户和 MSCS 帐户使用同一帐户。否则，如果更改了 MSCS 帐户的密码，SQL Server 安装将失败。

在 Windows Server 2008 中，服务 SID 可用于 SQL Server 服务帐户。有关详细信息，请参阅设置 Windows 服务帐户。

请参阅

任务

如何从方案 1 中的故障转移群集故障中恢复
如何从方案 2 中的故障转移群集失败中恢复
如何删除 SQL Server 故障转移群集实例（安装程序）

概念

安装故障转移群集前的准备工作


优化故障转移群集的性能

优化故障转移群集的性能 |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 维护故障转移群集 >

若要在使用故障转移群集时优化其性能，请考虑以下问题。

写缓存

如果磁盘控制器不在群集计算机之外，则必须关闭控制器内的写缓存以防止在故障转移期间发生数据丢失。

在群集中的主机控制器上使用回写高速缓存会影响性能。但是，如果使用外部控制器，则仍然可以提高性能。外部磁盘阵列不受故障转移群集的影响，甚至能通过 SCSI 总线使高速缓存正确地同步。

文件共享

不要将同一个驱动器用于文件共享和群集 SQL Server 数据库。使用这样的驱动器会影响恢复所需的时间，并且会在出现资源故障时引起群集组故障转移。

最大内存大小

分配充足的内存有助于提高故障转移群集的性能。理论上，最大内存是总的可用内存减去操作系统、其他群集和本地到节点所安装资源占用的内存，再除以安装的 Microsoft SQL Server 实例数。请使用此公式确定并设置最大内存大小。我们建议将您的工作最大内存设置为此值的 80% 到 90%，并收集性能基本统计信息，以进一步优化该设置。

最小内存大小

当存在多个 SQL Server 实例并且已设置好最大内存设置时，应设置最小内存。设置最小内存大小可减少故障转移的时间。

群集 CPU 关联

CPU 关联的默认设置在大多数情况下都是首选设置。但是，如果系统超过了最大推荐性能阈值，请使用 N-1 方案设置群集 CPU 关联。

固定 IP 端口和固定内存设置

使用固定 IP 端口和固定内存设置。

请参阅

其他资源

设置服务器配置选项


在故障转移群集中使用 SQL Server 工具

在故障转移群集中使用 SQL Server 工具 |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 维护故障转移群集 >

您可以将大部分 Microsoft SQL Server 工具和服务用于故障转移群集。但是，在使用之前，应当了解下列注意事项。

全文查询

若要在故障转移群集中使用 Microsoft 搜索服务执行全文查询，请遵循下列要求：

  • 为了使全文查询能在故障转移群集中正常工作，SQL Server 实例必须使用同一系统帐户在所有故障转移群集节点上运行。

    注意：
    这是故障转移群集的常规要求，并不仅限于 Microsoft 搜索服务。

  • 若要在故障转移群集中更改 SQL Server 的启动帐户，必须使用 SQL Server 配置管理器。如果使用 Microsoft Windows 中的“控制面板”或“服务”应用程序来更改启动帐户，将破坏 SQL Server 的全文配置。

SQL Server 配置管理器

若要在故障转移群集中使用 SQL Server 配置管理器，请遵循下列要求：

  • 若要在故障转移群集中更改 SQL Server 的启动帐户，必须使用 SQL Server 配置管理器。如果使用 Windows 中的“控制面板”或“服务”应用程序，则可能会破坏服务器配置。

  • 在创建或更改数据库时，只能查看本地故障转移群集实例的群集磁盘。

  • 如果使用 SQL Server 配置管理器重置 SQL Server 服务帐户属性，系统将提示您重新启动 SQL Server。在故障转移群集配置中，这样会使全文资源和 SQL Server 代理资源离线，并且在重新启动 SQL Server 后，不会使全文资源或 SQL Server 代理资源重新在线。必须使用 Windows 群集管理器实用工具，手动重新启动这些资源。

SQL Server Management Studio

  • 如果您正在使用 SQL Server Management Studio 浏览表并且在故障转移时丢失了到 SQL Server 的连接，便会看到错误消息“通信链接失败”。您必须按 Esc 键撤消更改并退出 SQL Server Management Studio 窗口。

    不能运行查询、保存任何更改或编辑网格。

服务控制管理器

使用服务控制管理器启动或停止 SQL Server 群集实例。不能暂停 SQL Server 群集实例。

SQL Server Profiler

可在故障转移群集中使用 SQL Server Profiler。但是，如果在运行 SQL Server Profiler 跟踪时发生故障转移，则必须在服务器重新联机后重新启动跟踪。

SQL Mail

SQL Mail 可通过配置管理器进行远程配置。

请参阅

其他资源

Features Supported by Editions of SQL Server 2005


故障转移群集疑难解答

故障转移群集疑难解答 |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 维护故障转移群集 >

本主题介绍了下列问题：

  • 故障排除的基本步骤。

  • 从故障转移群集故障中恢复。

  • 解决最常见的故障转移群集问题。

  • 使用扩展存储过程和 COM 对象。

故障排除的基本步骤

使用 SQL Server 故障转移群集时，请记住，服务器群集是由运行在 Microsoft 群集服务 (MSCS) 下的故障转移群集实例组成的。SQL Server 的实例可能驻留于提供 Microsoft Server 群集的基于 Microsoft MSCS 的节点中。

如果服务器群集所驻留的节点存在问题，则这些问题可能将自身列为故障转移群集实例的问题。若要调查并解决这些问题，请按以下顺序对 SQL Server 故障转移群集进行故障排除：

  1. 硬件：查看 Microsoft Windows 系统事件日志。

  2. 操作系统：查看 Windows 系统和应用程序事件日志。

  3. 网络：查看 Windows 系统和应用程序事件日志。根据知识库文章 Recommended Private "Heartbeat" Configuration on a Cluster Server 验证当前配置。

  4. 安全性：查看 Windows 应用程序和安全性事件日志。

  5. MSCS：查看 Windows 系统和应用程序事件日志以及群集日志。

  6. SQL Server：验证硬件、操作系统、网络、安全性和 MSCS 基础均没有问题后，像平常一样进行故障排除。

从故障转移群集故障中恢复

通常，故障转移群集故障有以下两个原因：

  • 双节点群集的一个节点出现硬件故障。此硬件故障可能是由 SCSI 卡或操作系统中的故障造成的。

    若要从此故障中恢复，请使用 SQL Server 安装程序将故障节点从故障转移群集中删除，在计算机脱机的情况下解决硬件故障，重新将计算机联机，然后将修复后的节点添加回故障转移群集实例。

    有关详细信息，请参阅如何创建新的 SQL Server 故障转移群集（安装程序）和如何从方案 1 中的故障转移群集故障中恢复。

  • 操作系统故障。在这种情况下，节点处于脱机状态，但并非无法解决该故障。

    若要从操作系统故障中恢复，请恢复节点并测试故障转移。如果 SQL Server 实例未能正确地进行故障转移，必须使用 SQL Server 安装程序从故障转移群集中删除 SQL Server，进行必要的修复，重新将计算机联机，然后将修复后的节点添加回故障转移群集实例。

    使用此方法从操作系统故障中恢复可能要花些时间。如果很容易从操作系统故障中恢复，请不要使用此方法。

    有关详细信息，请参阅如何创建新的 SQL Server 故障转移群集（安装程序）和如何从方案 2 中的故障转移群集失败中恢复。

解决常见问题

以下列表介绍了常见的使用问题并说明如何解决这些问题。

问题：不正确使用命令提示语法以安装 SQL Server

问题 1：在命令提示符下使用 /qn 开关时，很难诊断安装程序问题，因为 /qn 开关取消了所有安装程序对话框和错误消息。如果指定 /qn 开关，则所有安装程序消息（包括错误消息）都将写入安装程序日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 安装日志文件。

解决方法 1：使用 /qb 开关替代 /qn 开关。如果使用 /qb 开关，将显示每个步骤中的基本 UI（包括错误消息）。

问题：在迁移到另一个节点之后，SQL Server 无法登录到网络

问题 1：SQL Server 服务帐户无法与域控制器取得联系。

解决方法 1：检查事件日志以查看是否存在网络连接问题，例如适配器故障或 DNS 问题。验证是否能成功对域控制器运行 ping 命令。

问题 2：所有群集节点上的 SQL Server 服务帐户密码并非全都一致，或者节点没有重新启动从失败的节点迁移过来的 SQL Server 服务。

解决方法 2：使用 SQL Server 配置管理器更改 SQL Server 服务帐户密码。如果不这样做，并且更改了其中一个节点上的 SQL Server 服务帐户密码，也必须更改所有其他节点上的密码。SQL Server 配置管理器会自动执行此操作。

问题：SQL Server 无法访问群集磁盘

问题 1：并未在所有节点上都更新了固件或驱动程序。

解决方法 1：确保所有节点都使用正确的固件版本和相同的驱动程序版本。

问题 2：如果失败的节点位于具有不同驱动器号的共享群集磁盘上，则其他节点无法恢复从该节点迁移过来的群集磁盘。

解决方法 2：两台服务器上的群集磁盘的磁盘驱动器号必须相同。如果不相同，请检查操作系统和 Microsoft 群集服务 (MSCS) 的原始安装。

问题：SQL Server 服务故障导致故障转移

解决方法：若要防止特定服务的故障导致 SQL Server 组进行故障转移，请使用 Windows 中的群集管理器配置这些服务，如下所示：

  • 在“全文属性”对话框的“高级”选项卡中，清除“影响组”复选框。但是，如果 SQL Server 导致故障转移，则全文搜索服务将重新启动。

问题：SQL Server 不自动启动

解决方法：使用 MSCS 中的群集管理器自动启动某个故障转移群集。SQL Server 服务应该设置为手动启动，应该在 MSCS 中配置群集管理器，使其启动 SQL Server 服务。

问题：网络名称离线，无法使用 TCP/IP 连接到 SQL Server

问题 1：DNS 失败，而群集资源设置为需要 DNS。

解决方法 1：更正 DNS 问题。

问题 2：网络上存在重复的名称。

解决方法 2：使用 NBTSTAT 查找重复的名称，然后更正问题。

问题 3：SQL Server 不是使用 Named Pipes 进行连接。

解决方法 3：若要使用 Named Pipes 进行连接，请使用 SQL Server 配置管理器创建一个别名，以连接到适当的计算机。例如，如果有一个群集包含两个节点（Node A 和 Node B）和一个具有默认实例的故障转移群集实例 (Virtsql)，则可以执行下列步骤连接到网络名称资源已离线的服务器：

  1. 使用群集管理器确定包含 SQL Server 实例的组在哪个节点上运行。对于本例，此节点是 Node A。

  2. 使用 net start 在该计算机上启动 SQL Server 服务。有关使用 net start 的详细信息，请参阅手动启动 SQL Server。

  3. 在 Node A 上启动 SQL Server 配置管理器。查看服务器正在侦听的管道名称。它应类似于 \\.\$$\VIRTSQL\pipe\sql\query。

  4. 在客户端计算机上，启动 SQL Server 配置管理器。

  5. 创建别名 SQLTEST1 以通过命名管道连接到此管道名称。为此，请输入 Node A 作为服务器名称并将管道名称编辑为 \\.\pipe\$$\VIRTSQL\sql\query。

  6. 使用别名 SQLTEST1 作为服务器名称连接到此实例。

问题：群集上的 SQL Server 安装程序因发生错误 11001 而失败

问题：[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.X\Cluster] 中存在孤立的注册表项

解决方法：确保当前未使用 MSSQL.X 注册表配置单元，然后删除该群集项。

问题：群集安装错误：“安装程序没有足够的特权来访问目录 <驱动器号>\Microsoft SQL Server。安装无法继续。请以管理员身份登录，或与您的系统管理员联系”

问题：此错误是由于 SCSI 共享驱动器未正确分区而引起的。

解决方法：执行下列步骤以在该共享磁盘上重新创建一个分区：

  1. 从群集中删除磁盘资源。

  2. 删除磁盘上的所有分区。

  3. 在磁盘属性中验证磁盘是否为基本磁盘。

  4. 在共享磁盘上创建一个分区、格式化该磁盘并为磁盘分配一个驱动器号。

  5. 使用群集管理器 (cluadmin) 将磁盘添加到群集中。

  6. 运行 SQL Server 安装程序。

问题：应用程序无法在分布式事务中登记 SQL Server 资源

问题：由于在 Windows 中未完全配置 Microsoft 分布式事务处理协调器 (MS DTC)，因此应用程序可能无法在分布式事务中登记 SQL Server 资源。此问题可能会影响使用分布式事务的链接服务器、分布式查询和远程存储过程。

解决方法：若要避免此类问题，必须在安装 SQL Server 的服务器上完全启用 MS DTC 服务。

若要完全启用 MS DTC，请执行下列步骤：

  1. 在控制面板中打开“管理工具”，然后打开“计算机管理”。

  2. 在“计算机管理”的左侧面板中，展开“服务和应用程序”，然后单击“服务”。

  3. 在“计算机管理”的右侧面板中，右键单击 Distributed Transaction Coordinator，并选择“属性”。

  4. 在“Distributed Transaction Coordinator 的属性”窗口中，单击“常规”选项卡，再单击“停止”来停止此服务。

  5. 在“Distributed Transaction Coordinator 的属性”窗口中，单击“登录”选项卡，将登录帐户设置为 NT AUTHORITY\NetworkService。

  6. 单击“应用”和“确定”以关闭“分布式事务处理协调器”窗口。关闭“计算机管理”窗口。关闭“管理工具”窗口。

注意：
在故障转移群集内的计算机上安装 SQL Server 时，必须在运行安装程序之前完全启用 MS DTC 并为其设置群集。如果 MS DTC 未设置群集，安装程序将失败。在运行安装程序之前，请使用 Microsoft 群集管理器确保 MS DTC 已设置了群集。

使用扩展存储过程和 COM 对象

如果在故障转移群集配置中使用扩展存储过程，所有扩展存储过程都必须安装在与 SQL Server 相关的群集磁盘中。这样做可确保当某节点发生故障转移时，仍能继续使用扩展存储过程。

如果扩展存储过程使用 COM 组件，管理员必须在群集的所有节点中都注册 COM 组件。活动节点的注册表中必须包含加载和执行 COM 组件所需的信息，才能创建这些组件。否则，这些信息将保留在最先注册 COM 组件的计算机的注册表中。

请参阅

概念

如何查看 SQL Server 安装日志文件

其他资源

How Extended Stored Procedures Work
Execution Characteristics of Extended Stored Procedures


故障转移群集操作指南主题

故障转移群集操作指南主题 |
 | 请参阅
计划 SQL Server 安装 > 高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 >

本节中的操作指南主题包含有关创建或维护故障转移群集的信息。在创建 SQL Server 故障转移群集之前，必须使用群集管理器配置 Microsoft 群集服务 (MSCS)。

请参阅

概念

SQL Server 2008 故障转移群集入门
安装故障转移群集前的准备工作


如何创建新的 SQL Server 故障转移群集（安装程序）

如何创建新的 SQL Server 故障转移群集（安装程序） |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 故障转移群集操作指南主题 >

使用 SQL Server 安装向导可以在单个节点上安装 SQL Server 故障转移群集。

使用以下过程创建一个故障转移群集实例。

若要向现有故障转移群集实例添加节点或从中删除节点，请参阅如何在 SQL Server 故障转移群集中添加或删除节点（安装程序）。

有关远程安装，请参阅版本升级。

若要安装独立的 SQL Server 实例，请参阅如何安装 SQL Server 2008（安装程序）。

必备项

在开始之前，请查阅以下 SQL Server 联机丛书主题：

  • 计划 SQL Server 安装

  • 安装故障转移群集前的准备工作

  • 安装 SQL Server 的安全注意事项

  • 您已阅读知识库文章 recommended private "Heartbeat" configuration on a cluster server（建议在群集服务器上使用的专用“检测信号”配置），并显式地按照其中说明进行操作，这一点是很重要的。

    注意：
    在运行 SQL Server 安装程序之前，请记录共享驱动器在群集管理器中的位置。您需要此信息来创建新的故障转移群集。

安装 SQL Server 2008

  1. 插入 SQL Server 安装媒体，然后双击根文件夹中的 setup.exe。若要从网络共享进行安装，请导航到共享中的根文件夹，然后双击 setup.exe。

  2. 如果出现 Microsoft .NET Framework 2.0 版 安装对话框，则选中相应的复选框以接受 .NET Framework 2.0 许可协议。单击“下一步”。若要退出 SQL Server 2008 安装过程，请单击“取消”。当 .NET Framework 2.0 的安装完成后，请单击“完成”。

  3. Windows Installer 4.5 也是必需的，并且可能由安装向导进行安装。如果系统提示您重新启动计算机，则重新启动计算机，然后再次启动 SQL Server 2008 安装程序。

  4. 必备组件安装完成后，安装向导会启动 SQL Server 安装中心。若要创建 SQL Server 2008 的全新安装，请单击“全新安装或向现有安装添加功能”。

  5. 系统配置检查器将在您的计算机上运行发现操作。若要继续，请单击“确定”。系统已经为您的安装创建了安装日志文件。有关详细信息，请参阅如何查看 SQL Server 安装日志文件。

  6. 在“产品密钥”页上单击相应的单选按钮，以指示您是安装免费版本的 SQL Server，还是您拥有该产品生产版本的 PID 密钥。有关详细信息，请参阅 SQL Server 2008 的版本和组件。

  7. 在“许可条款”页上阅读许可协议，然后选中相应的复选框以接受许可条款和条件。若要继续，请单击“下一步”。若要结束安装程序，请单击“取消”。

  8. 如果计算机上尚未安装 SQL Server 必备组件，则安装向导将安装它们。其中包括：

    • .NET Framework 2.0

    • SQL Server Native Client

    • SQL Server 安装程序支持文件

    若要安装必备组件，请单击“安装”。

  9. 系统配置检查器将在安装继续之前检验计算机的系统状态。检查完成后，请单击“下一步”继续。

  10. 在“功能选择”页上选择要安装的组件。选择功能名称后，右侧窗格中会显示每个组件组的说明。您可以选择复选框的任意组合，但仅数据库引擎和 Analysis Services 支持故障转移群集。其他组件将在单个故障转移群集节点上运行。

    您可以使用此页底部的字段为共享组件指定自定义目录。若要更改共享组件的安装路径，请更新对话框底部字段中所提供的路径名，或单击“浏览”导航到另一个安装目录。默认安装路径为 C:\Program Files\Microsoft SQL Server\。

  11. 在“实例配置”页上指定是安装默认实例还是命名实例。有关详细信息，请参阅实例配置。

    实例 ID 后缀 - 默认情况下，使用实例名称作为实例 ID 的后缀。这用于标识 SQL Server 实例的安装目录和注册表项。默认实例和命名实例的默认方式都是如此。对于默认实例，实例名称和实例 ID 后缀均为 MSSQLSERVER。若要使用非默认的实例 ID 后缀，请选中“实例 ID 后缀”复选框，并提供一个值。

    注意：
    典型的 SQL Server 2008 独立实例（无论是默认实例还是命名实例）不会对“实例 ID 后缀”复选框使用非默认值。

    实例根目录 - 默认情况下，实例根目录为 C:\Program Files\Microsoft SQL Server\。若要指定一个非默认的根目录，请使用所提供的字段，或单击“浏览”以找到一个安装文件夹。

    所有 SQL Server Service Pack 和升级都将应用于 SQL Server 实例的每个组件。

    检测到的实例和功能 - 该网格将显示运行安装程序的计算机上的 SQL Server 实例。如果计算机上已经安装了一个默认实例，则必须安装 SQL Server 2008 的命名实例。若要继续，请单击“下一步”。

  12. 使用“群集资源组”页可以指定用于放置 SQL Server 虚拟服务器资源的磁盘。指定 SQL Server 群集资源组名称时，您有以下两种选择：

    • 使用下拉框指定一个要使用的现有组。

    • 键入要创建的新组的名称。请注意，名称“Available storage”不是有效的组名。

  13. 在“群集磁盘选择”页上，为您的 SQL Server 故障转移群集选择共享群集磁盘资源。群集磁盘用于存放 SQL Server 数据。只能指定一个磁盘。如果选择包含群集仲裁资源的组，将显示警告。建议不要安装到群集仲裁资源。“可用共享磁盘”网格显示可用磁盘的列表，对于列表中的每个磁盘资源，均会显示是否可用作共享磁盘以及相关说明。若要继续，请单击“下一步”。

  14. 在“群集网络选择”页上为故障转移群集实例指定网络资源：

    • SQL Server 故障转移群集网络名称 - 此名称用于在网络上标识故障转移群集实例。

    • 网络设置 - 指定故障转移群集实例的 IP 类型和 IP 地址。

    若要继续，请单击“下一步”。

  15. 使用“群集安全策略”页可以为群集服务指定全局或本地域组。所有资源权限都是由包括作为组成员的 SQL Server 服务帐户的域级组控制的。有关 Windows Server 2008 上的服务安全 ID (SID) 功能的信息，请参阅设置 Windows 服务帐户。在 Windows Server 2003 上为 SQL Server 服务指定域组。若要继续，请单击“下一步”。

  16. “磁盘空间要求”页计算指定的功能所需的磁盘空间，并将磁盘空间要求与正在运行安装程序的计算机上的可用磁盘空间进行比较。有关详细信息，请参阅磁盘成本摘要。

  17. 本主题中的其余工作流取决于您指定安装的功能。您可能不会看到所有的页面，具体取决于您进行的选择。

  18. 在“服务器配置 - 服务帐户”页上指定 SQL Server 服务的登录帐户。此页上配置的实际服务取决于您选择安装的功能。

    您可以为所有 SQL Server 服务分配相同的登录帐户，也可以单独配置各个服务帐户。还可以指定服务是自动启动、手动启动还是禁用。Microsoft 建议对各服务帐户进行单独配置，以便为每项服务提供最低特权，即向 SQL Server 服务授予它们完成各自任务所需的最低权限。有关详细信息，请参阅SQL Server 配置 - 服务帐户和设置 Windows 服务帐户。

    若要为此 SQL Server 实例中的所有服务帐户指定相同的登录帐户，请在页面底部的字段中提供凭据。

    安全说明：不要使用空密码。请使用强密码。

    为 SQL Server 服务指定登录信息后，请单击“下一步”。

  19. 使用“服务器配置 - 排序规则”选项卡为数据库引擎和 Analysis Services 指定非默认的排序规则。有关详细信息，请参阅 SQL Server 配置 - 排序规则。

  20. 使用“数据库引擎配置 - 帐户设置”页指定以下各项：

    • 安全模式 - 为您的 SQL Server 实例选择“Windows 身份验证”或“混合模式身份验证”。如果选择“混合模式身份验证”，则必须为内置 SQL Server 系统管理员帐户提供一个强密码。

      在设备与 SQL Server 成功建立连接之后，用于 Windows 身份验证和混合模式身份验证的安全机制是相同的。有关详细信息，请参阅数据库引擎配置 - 帐户设置。

    • SQL Server 管理员 - 您必须为 SQL Server 实例至少指定一个系统管理员。若要添加用以运行 SQL Server 安装程序的帐户，请单击“添加当前用户”。若要向系统管理员列表中添加帐户或从中删除帐户，请单击“添加”或“删除”，然后编辑将拥有 SQL Server 实例的管理员特权的用户、组或计算机列表。有关详细信息，请参阅数据库引擎配置 - 帐户设置。

    完成对该列表的编辑后，请单击“确定”。验证配置对话框中的管理员列表。完成此列表后，请单击“下一步”。

  21. 使用“数据库引擎配置 - 数据目录”页指定非默认的安装目录。若要安装到默认目录，请单击“下一步”。

    重要提示：
    如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。

    有关详细信息，请参阅数据库引擎配置 - 数据目录。

  22. 使用“数据库引擎配置 - FILESTREAM”页对 SQL Server 实例启用 FILESTREAM。有关 FILESTREAM 的详细信息，请参阅数据库引擎配置 - 文件流。若要继续，请单击“下一步”。

  23. 使用“Analysis Services 配置 – 帐户设置”页指定将拥有 Analysis Services 的管理员权限的用户或帐户。您必须为 Analysis Services 至少指定一个系统管理员。若要添加用以运行 SQL Server 安装程序的帐户，请单击“添加当前用户”。若要向系统管理员列表中添加帐户或从中删除帐户，请单击“添加”或“删除”，然后编辑将拥有 Analysis Services 的管理员特权的用户、组或计算机的列表。有关详细信息，请参阅 Analysis Services 配置 – 帐户设置。

    完成对该列表的编辑后，请单击“确定”。验证配置对话框中的管理员列表。完成此列表后，请单击“下一步”。

  24. 使用“Analysis Services 配置 - 数据目录”页指定非默认的安装目录。若要安装到默认目录，请单击“下一步”。

    重要提示：
    如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。

    有关详细信息，请参阅 Analysis Services 配置 - 数据目录。

  25. 使用“Reporting Services 配置”页指定要创建的 Reporting Services 安装的类型。包括以下选项：

    • 本机模式默认配置

    • SharePoint 模式默认配置

    • 未配置的 Reporting Services 安装

    有关 Reporting Services 配置模式的详细信息，请参阅报表服务器安装选项。

  26. 在“错误和使用情况报告”页上指定要发送到 Microsoft 以帮助改善 SQL Server 的信息。默认情况下，用于错误报告和功能使用情况的选项处于启用状态。有关详细信息，请参阅错误和使用情况报告设置。

  27. 系统配置检查器将再运行一组规则来针对您指定的 SQL Server 功能验证您的计算机配置。

  28. “准备安装”页显示安装期间指定的安装选项的树视图。若要继续，请单击“安装”。

  29. 在安装过程中，“安装进度”页会提供相应的状态，因此您可以在安装过程中监视安装进度。

  30. 安装完成后，“完成”页会提供指向安装日志文件摘要以及其他重要说明的链接。若要完成 SQL Server 安装过程，请单击“关闭”。

  31. 如果安装程序指示您重新启动计算机，请立即重新启动。安装完成后，请务必阅读来自安装向导的消息。有关安装日志文件的信息，请参阅如何查看 SQL Server 安装日志文件。

后续步骤

配置新安装的 SQL Server - 为了减少系统的可攻击外围应用，SQL Server 将有选择地安装和激活一些密钥服务和功能。有关详细信息，请参阅 MSDN 上的 Understanding Surface Area Configuration（了解外围应用配置器）。

有关日志文件位置的信息，请参阅如何查看 SQL Server 安装日志文件。

请参阅

概念

如何从命令提示符安装 SQL Server 2008


如何在 SQL Server 故障转移群集中添加或删除节点（安装程序）

如何在 SQL Server 故障转移群集中添加或删除节点（安装程序） |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 故障转移群集操作指南主题 >

使用此过程可以管理现有 SQL Server 故障转移群集实例的节点。

重要提示：
若要更新或删除 SQL Server 故障转移群集，您必须是一名本地管理员，且具有作为服务登录到故障转移群集的所有节点的权限。对于本地安装，必须以管理员身份运行安装程序。如果从远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。

若要查看添加或删除节点的过程步骤，请选择下面的一项操作：

  • 向现有 SQL Server 2008 故障转移群集中添加节点

  • 从现有 SQL Server 2008 故障转移群集中删除节点

添加节点

向现有 SQL Server 2008 故障转移群集中添加节点

  1. 插入 SQL Server 安装媒体，然后双击根文件夹中的 setup.exe。若要从网络共享进行安装，请导航到共享中的根文件夹，然后双击 setup.exe。

  2. 如果出现 Microsoft .NET Framework 2.0 版 安装对话框，则选中相应的复选框以接受 .NET Framework 2.0 许可协议。单击“下一步”。若要退出 SQL Server 2008 安装过程，请单击“取消”。当 .NET Framework 2.0 的安装完成后，请单击“完成”。

  3. Windows Installer 4.5 也是必需的，并且可能由安装向导进行安装。如果系统提示您重新启动计算机，则重新启动计算机，然后再次启动 SQL Server 2008 setup.exe。

  4. 必备组件安装完成后，安装向导会启动 SQL Server 安装中心。若要向现有故障转移群集实例中添加节点，请单击左窗格中的“安装”。然后选择“向 SQL Server 故障转移群集添加节点”。

  5. 系统配置检查器将在您的计算机上运行发现操作。若要继续，请单击“确定”。系统已经为您的安装创建了安装日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 安装日志文件。

  6. 在“产品密钥”页上指定产品的生产版本的 PID 密钥。请注意，您必须针对活动节点上安装的 SQL Server 2008 的版本为此安装输入产品密钥。

  7. 在“许可条款”页上阅读许可协议，然后选中相应的复选框以接受许可条款和条件。若要继续，请单击“下一步”。若要结束安装程序，请单击“取消”。

  8. 如果计算机上尚未安装 SQL Server 必备组件，则安装向导将安装它们。其中包括：

    • .NET Framework 2.0

    • SQL Server Native Client

    • SQL Server 安装程序支持文件

    若要安装必备组件，请单击“安装”。

  9. 系统配置检查器将在安装继续之前检验计算机的系统状态。检查完成后，请单击“下一步”继续。

  10. 在“群集节点配置”页上，使用下拉框指定要在此安装操作期间修改的 SQL Server 2008 故障转移群集实例的名称。

  11. 在“服务器配置 - 服务帐户”页上指定 SQL Server 服务的登录帐户。此页上配置的实际服务取决于您选择安装的功能。对于故障转移群集安装，将基于为活动节点提供的设置，在此页上预填充帐户名和启动类型信息。必须为每个帐户提供密码。有关详细信息，请参阅SQL Server 配置 - 服务帐户和设置 Windows 服务帐户。

    安全说明 不要使用空密码。请使用强密码。

    为 SQL Server 服务指定登录信息后，单击“下一步”。

  12. “磁盘空间要求”页计算指定的功能所需的磁盘空间，并将磁盘空间要求与正在运行安装程序的计算机上的可用磁盘空间进行比较。有关详细信息，请参阅磁盘成本摘要。

  13. 在“错误和使用情况报告”页上指定要发送到 Microsoft 以帮助改善 SQL Server 的信息。默认情况下，用于错误报告和功能使用情况的选项处于启用状态。有关详细信息，请参阅错误和使用情况报告设置。

  14. 系统配置检查器将再运行一组规则来针对您指定的 SQL Server 功能验证您的计算机配置。

  15. “准备安装”页显示安装期间指定的安装选项的树视图。

  16. 在安装过程中，“安装进度”页会提供相应的状态，因此您可以在安装过程中监视安装进度。

  17. 安装完成后，“完成”页会提供指向安装日志文件摘要以及其他重要说明的链接。若要完成 SQL Server 安装过程，请单击“关闭”。

  18. 如果安装程序指示您重新启动计算机，请立即重新启动。安装完成后，请务必阅读来自安装向导的消息。有关安装日志文件的信息，请参阅如何查看 SQL Server 安装日志文件。

删除节点

从现有 SQL Server 2008 故障转移群集中删除节点

  1. 插入 SQL Server 安装媒体。然后双击根文件夹中的 setup.exe。若要从网络共享进行安装，请导航到共享中的根文件夹，然后双击 setup.exe。

  2. 如果出现 Microsoft .NET Framework 2.0 版 安装对话框，则选中相应的复选框以接受 .NET Framework 2.0 许可协议。单击“下一步”。若要退出 SQL Server 2008 安装，请单击“取消”。当 .NET Framework 2.0 的安装完成后，请单击“完成”。

  3. Windows Installer 4.5 也是必需的，并且可能由安装向导进行安装。如果系统提示您重新启动计算机，则重新启动计算机，然后再次启动 SQL Server 2008 setup.exe。

  4. 必备组件安装完成后，安装向导会启动 SQL Server 安装中心。若要向现有故障转移群集实例中添加节点，请单击左窗格中的“安装”，然后选择“向 SQL Server 故障转移群集添加节点”。

  5. 系统配置检查器将在您的计算机上运行发现操作。若要继续，请单击“确定”。系统已经为您的安装创建了安装日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 安装日志文件。

  6. 如果您的计算机上尚未安装 SQL Server 必备组件，安装向导会安装它们。其中包括：

    • .NET Framework 2.0

    • SQL Server Native Client

    • SQL Server 安装程序支持文件

    若要安装必备组件，请单击“安装”。

  7. 系统配置检查器将在安装继续之前检验计算机的系统状态。检查完成后，请单击“下一步”继续。

  8. 在“群集节点配置”页上，使用下拉框指定要在此安装操作期间修改的 SQL Server 2008 故障转移群集实例的名称。“此节点的名称”字段中将列出要删除的节点。

  9. 在“错误和使用情况报告”页上指定要发送到 Microsoft 以帮助改善 SQL Server 的信息。默认情况下，用于错误报告和功能使用情况的选项处于启用状态。有关详细信息，请参阅错误和使用情况报告设置。

  10. 系统配置检查器将再运行一组规则来针对您指定的 SQL Server 功能验证您的计算机配置。

  11. “准备安装”页显示您在安装期间指定的选项的树视图。若要继续，请单击“删除”。

  12. 在删除操作期间，“进度”页会提供删除状态。

  13. “完成”页会提供指向安装日志文件摘要以及其他重要说明的链接。若要完成 SQL Server 安装，请单击“关闭”。有关安装日志文件的信息，请参阅如何查看 SQL Server 安装日志文件。

请参阅

概念

如何查看 SQL Server 安装日志文件


如何修复失败的 SQL Server 2008 安装

如何修复失败的 SQL Server 2008 安装 |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 故障转移群集操作指南主题 >

使用此过程可以修复损坏的 SQL Server 2008 安装。

继续之前，请查阅有关 SQL Server 故障转移群集的以下重要信息：

  • 必须在单个群集节点上运行修复。

  • 若要在“准备”操作失败之后修复故障转移群集节点，请使用“删除节点”，然后再次执行“准备”步骤。请参阅如何在 SQL Server 故障转移群集中添加或删除节点（安装程序）。

过程标题

  1. 从 SQL Server 2008 安装媒体中启动 SQL Server 安装程序 (setup.exe)。

  2. 安装必备组件并进行系统验证之后，安装程序会显示“SQL Server 安装中心”页。

  3. 单击左侧导航区域中的“维护”，然后单击“修复”启动修复操作。

  4. 将运行安装程序支持规则和文件例程，以确保您的系统上安装了必备组件，并且计算机能够通过安装程序验证规则。单击“确定”或“安装”以继续操作。

  5. 在“选择实例”页上选择要修复的实例，然后单击“下一步”继续操作。

  6. 将运行修复规则以验证修复操作。若要继续，请单击“下一步”。

  7. “准备修复”页指示修复操作已准备就绪，可以继续。若要继续，请单击“修复”。

  8. “修复进度”页显示修复操作的状态。“完成”页指示修复操作已完成。

请参阅

概念

SQL Server 安装故障排除
故障转移群集疑难解答
如何查看 SQL Server 安装日志文件


如何删除 SQL Server 故障转移群集实例（安装程序）

如何删除 SQL Server 故障转移群集实例（安装程序） |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 故障转移群集操作指南主题 >

使用此过程可以卸载 SQL Server 故障转移群集实例。

重要提示：
若要更新或删除 SQL Server 故障转移群集，则您必须是本地管理员，且具有以服务登录到故障转移群集的所有节点的权限。

开始之前

请在卸载 SQL Server 故障转移群集之前考虑以下重要事项：

  • 在运行 SQL Server 2008 与 SQL Server 早期版本的计算机上，企业管理器和依赖 SQL-DMO 的其他程序可能会被禁用。 这可发生在以下情况中：

    • 并行安装了 SQL Server 2008、SQL Server 2000 和/或 SQL Server 7.0，又卸载了任一版本。

    • 并行安装了 SQL Server 2000 和 SQL Server 2008，且是在安装 SQL Server 2008 后安装 SQL Server 2000。

    这个问题是由于删除了 SQL Server 2008 SQL-DMO COM 库的注册造成的。 若要重新启用具有 SQL-DMO 依赖关系的 SQL Server 2000 企业管理器和其他程序，请从命令提示符运行“regsvr32.exe sqldmo.dll”来注册 SQL-DMO。

  • 如果在群集环境中并行安装了 SQL Server 2000 和 SQL Server 2008，则卸载 SQL Server 2008 时不应卸载SQL Server Native Client。 SQL Server 2008 的 SQL Server 资源 DLL 始终使用 SQL Server Native Client 连接到 SQL Server。 安装 SQL Server 2008 后，会升级 SQL Server 群集资源 DLL。 卸载 SQL Server 2008 后，SQL Server 资源 DLL 不会替换为 SQL Server 2000 所需的版本。 在群集节点上保留 SQL Server Native Client 可使 SQL Server 资源 DLL 继续连接到 SQL Server 2000 实例。

  • 如果意外卸载了 SQL Server Native Client，则 SQL Server 资源将无法启动。 若要重新安装 SQL Server Native Client，请运行 SQL Server 安装程序来安装 SQL Server 必备组件。

  • 如果卸载具有多个 SQL IP 群集资源的故障转移群集，则必须使用群集管理器删除额外的 SQL IP 资源。

有关命令提示符语法的信息，请参阅如何从命令提示符安装 SQL Server 2008。

卸载 SQL Server 故障转移群集

  1. 若要卸载 SQL Server 故障转移群集，请使用 SQL Server 安装程序提供的删除节点功能分别删除每个节点。 有关详细信息，请参阅如何在 SQL Server 故障转移群集中添加或删除节点（安装程序）。

请参阅

任务

如何阅读 SQL Server 安装日志文件

概念

如何查看 SQL Server 安装日志文件


如何从方案 1 中的故障转移群集故障中恢复

如何从方案 1 中的故障转移群集故障中恢复 |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 故障转移群集操作指南主题 >

在此情况中，失败是由两个节点的群集中节点 1 的硬件故障造成的。例如，该硬件故障可能是由磁盘控制器或操作系统的故障引起的。

从故障转移群集硬盘故障中恢复

  1. 节点 1 失败后，SQL Server 故障转移群集将有关的操作转移到节点 2 上。

  2. 从 Microsoft 群集服务 (MSCS) 中逐出节点 1。若要从 MSCS 中逐出节点，可在节点 2 中打开群集管理器，右键单击要删除的节点，再单击“逐出节点”命令。

  3. 验证节点 1 是否已从群集定义中逐出。

  4. 安装新的硬件，以替换节点 1 中发生故障的硬件。

  5. 使用群集管理器配置 Microsoft 群集服务器 (MSCS) 以便将节点 1 添加到现有群集。有关详细信息，请参阅安装故障转移群集前的准备工作。

  6. 确保所有群集节点上的管理员帐户都相同。有关详细信息，请参阅如何创建新的 SQL Server 故障转移群集（安装程序）。

  7. 运行 SQL Server 安装程序，以便将节点 1 添加到故障转移群集。有关详细信息，请参阅如何在 SQL Server 故障转移群集中添加或删除节点（安装程序）。

请参阅

任务

如何阅读 SQL Server 安装日志文件

概念

如何查看 SQL Server 安装日志文件


如何从方案 2 中的故障转移群集失败中恢复

如何从方案 2 中的故障转移群集失败中恢复 |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 故障转移群集操作指南主题 >

在方案 2 中，失败由节点 1 关闭或离线引起，但不是无法挽回的损坏。这可能是由操作系统故障或硬件故障引起的。

过程

从故障转移群集失败中恢复

  1. 节点 1 失败后，SQL Server 故障转移群集将有关的操作转移到节点 2 上。

  2. 解决节点 1 的问题。

  3. 确保 Microsoft 群集服务 (MSCS) 群集正在工作且所有节点均处于在线状态。

  4. 试图将 SQL Server 故障转移到恢复的节点。如果该操作成功，则不需要执行进一步的操作，但必须进行常规测试。如果 SQL Server 在恢复的节点上无法在线，请参阅故障转移群集疑难解答。

请参阅

任务

如何阅读 SQL Server 安装日志文件

概念

故障转移群集疑难解答
如何查看 SQL Server 安装日志文件

其他资源

How to: Rebuild the Master Database for SQL Server 2005
How to: Rebuild the Registry for SQL Server 2005


如何在 SQL Server 故障转移群集中启用 Kerberos 身份验证

如何在 SQL Server 故障转移群集中启用 Kerberos 身份验证 |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 故障转移群集操作指南主题 >

Kerberos 是一种网络身份验证协议，旨在为客户端/服务器应用程序提供严格的身份验证。Kerberos 为互操作性奠定了基础，同时增强了企业范围的网络身份验证的安全性。

其他资源

可以将 Kerberos 身份验证用于 SQL Server 独立实例或 SQL Server 故障转移群集实例。有关启用 Kerberos 的其他信息，请参阅知识库文章“如何在 SQL Server 中使用 Kerberos 身份验证”。

请参阅

概念

安装 SQL Server 的安全注意事项


如何更改 SQL Server 故障转移群集的 IP 地址

如何更改 SQL Server 故障转移群集的 IP 地址 |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 故障转移群集操作指南主题 >

若要维护或更新 SQL Server 故障转移群集，请使用“控制面板”中的“添加或删除程序”。有关命令提示符语法的信息，请参阅如何从命令提示符安装 SQL Server 2008。

开始之前，请查看下面的 SQL Server 联机丛书主题：安装故障转移群集前的准备工作。

有关更改群集节点中的网络适配器的 IP 地址的其他信息，请参阅此 Microsoft 知识库文章。

重要提示：
若要维护或更新 SQL Server 故障转移群集，您必须是本地管理员，并且在该故障转移群集的所有节点上有权作为服务进行登录。

更改现有 SQL Server 故障转移群集的 IP 地址

  1. 从“开始”菜单中单击“运行”，然后键入 cluadmin 以启动群集管理器并连接到本地实例。

  2. 在左侧窗格中，展开“组”节点，然后选择要更新的组。

  3. 在右侧窗格中，右键单击“SQL IP Address1”（故障转移群集实例名称）并选择“属性”。

  4. 单击“参数”选项卡，然后在“地址”字段中更新 SQL IP Address1（SQL Server 名称）的 IP 地址。

  5. 单击“应用”以实现更改。可能会显示下面的警告对话框：

    “群集管理器标准扩展: 尝试设置属性时出错: 已存储属性，但是只有在下次资源联机时所有更改才会生效。错误 ID: 5024 (000013a0)。”

  6. 单击“确定”清除“群集管理器标准扩展”对话框，此时您将返回到“群集管理器”。若要使资源脱机，然后再使其重新联机，请使用下列步骤。

  7. 在右侧窗格中，右键单击“SQL IP Address1”（故障转移群集实例名称）并选择“脱机”。将会看到 SQL IP Address1（故障转移群集实例名称）、SQL Network Name（故障转移群集实例名称）和 SQL Server 的状态从联机更改为脱机挂起，然后再更改为脱机。

    注意：
    将 IP 更改传播到整个企业网络可能需要 30 分钟或更长的时间。应该尝试将 SQL IP Address 1（故障转移群集实例名称）和 SQL Network Name（故障转移群集实例名称）联机，然后尝试 ping 该故障转移群集实例名称并等待 DNS 将其解析为新的 IP 地址。

  8. 在右侧窗格中，右键单击 SQL Server，然后选择“联机”。将会看到 SQL IP Address1（故障转移群集实例名称）、SQL Network Name（故障转移群集实例名称）和 SQL Server 的状态从脱机更改为联机挂起，然后再更改为联机。

  9. 关闭“群集管理器”。

请参阅

概念

如何查看 SQL Server 安装日志文件


如何升级 SQL Server 故障转移群集实例（安装程序）

如何升级 SQL Server 故障转移群集实例（安装程序） |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 故障转移群集操作指南主题 >

可以使用 SQL Server 安装向导将 SQL Server 故障转移群集升级为 SQL Server 2008 故障转移群集，也可以从命令提示符执行此操作。

有关升级信息，请参阅版本升级和Upgrading to SQL Server 2005。

若要安装独立的 SQL Server 实例，请参阅How to: Install SQL Server 2005 (Setup)。

有关命令提示符安装的语法示例，请参阅如何从命令提示符安装 SQL Server 2008。

必备项

开始之前，请查阅以下重要信息：

  • 安装故障转移群集前的准备工作

  • 查阅使用升级顾问来准备升级。

  • Upgrading the Database Engine

  • Microsoft 知识库中的建议在群集服务器上使用的专用“信号”配置文章。

  • 对于本地安装，必须以管理员身份运行 SQL Server 安装程序。如果从远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。

  • 若要将 SQL Server 的实例升级为 SQL Server 2008 故障转移群集，则要升级的实例必须是故障转移群集。若要将 SQL Server 的独立实例升级为 SQL Server 2008 故障转移群集，请安装新的 SQL Server 2008 故障转移群集，然后使用复制数据库向导从该独立实例中迁移用户数据库。有关详细信息，请参阅使用复制数据库向导。

  • 一次只能升级一个故障转移群集节点。升级操作期间的故障转移有多种选择：

    • 将资源组移到已升级的节点上。

    • 将资源组移到尚未升级的节点上。

    • 在单节点故障转移群集中，SQL Server 安装程序会使 SQL Server 资源组脱机。

  • 不能向现有故障转移群集中添加功能。

  • 仅允许在某些方案中更改故障转移群集的版本。请参阅版本升级。

  • 要控制升级过程中群集节点的故障转移行为，请从命令提示符运行升级操作，并使用 /FAILOVERCLUSTERROLLOWNERSHIP 参数。有关详细信息，请参阅如何从命令提示符安装 SQL Server 2008。

升级 SQL Server 故障转移群集

  1. 插入 SQL Server 安装媒体，然后双击根文件夹中的 setup.exe。若要从网络共享进行安装，请导航到共享中的根文件夹，然后双击 setup.exe。

  2. 如果出现 Microsoft .NET Framework 2.0 版 安装对话框，则选中相应的复选框以接受 .NET Framework 2.0 许可协议。单击“下一步”。若要退出 SQL Server 2008 安装，请单击“取消”。当 .NET Framework 2.0 的安装完成后，请单击“完成”。

  3. Windows Installer 4.5 也是必需的，并且可能由安装向导进行安装。如果系统提示您重新启动计算机，则重新启动计算机，然后再次启动 SQL Server 2008 setup.exe。

  4. 必备组件安装完成后，安装向导会立即启动 SQL Server 安装中心。若要升级 SQL Server 2008 的现有实例，请单击“从 SQL Server 2000 或 SQL Server 2005 升级”。

  5. 如果需要使用安装程序支持文件，SQL Server 安装程序将安装它们。如果安装程序指示您重新启动计算机，请在继续操作之前重新启动。

  6. 系统配置检查器将在您的计算机上运行发现操作。若要继续，请单击“确定”。此时，系统已经为您的安装创建了安装日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 安装日志文件。

  7. 在“产品密钥”页上单击相应的单选按钮，以指示您是升级到免费版本的 SQL Server，还是您拥有该产品生产版本的 PID 密钥。有关详细信息，请参阅 SQL Server 2008 的版本和组件和版本升级。在提供的空间中输入 PID 密钥，然后单击“下一步”继续。请注意，用于故障转移群集升级的 PID 密钥对于所有故障转移群集节点都必须是一致的。同一个 SQL Server 实例中的所有故障转移群集节点都必须是相同的 SQL Server 版本。

  8. 在“许可条款”页上阅读许可协议，然后选中相应的复选框以接受许可条款和条件。若要继续，请单击“下一步”。若要结束安装程序，请单击“取消”。

  9. 在“选择实例”页上指定要升级到 SQL Server 2008 的 SQL Server 实例。若要继续，请单击“下一步”。

  10. 在“功能选择”页上会预先选择要升级的功能。选择功能名称后，右侧窗格中会显示每个组件组的说明。请注意，您不能更改要升级的功能，并且不能在升级操作过程中添加功能。若要在升级操作完成后向已升级的 SQL Server 2008 实例中添加功能，请参阅如何向 SQL Server 2008 的实例添加功能（安装程序）。

  11. 在“实例配置”页上指定是安装默认实例还是命名实例。有关详细信息，请参阅实例配置。若要继续，请单击“下一步”。

    实例 ID 后缀 - 默认情况下，使用实例名称作为实例 ID 的后缀。这用于标识 SQL Server 实例的安装目录和注册表项。默认实例和命名实例的默认方式都是如此。对于默认实例，实例名称和实例 ID 后缀均为 MSSQLSERVER。若要使用非默认的实例 ID 后缀，请选中“实例 ID 后缀”复选框，并提供一个值。

    注意：
    典型的 SQL Server 2008 独立实例（无论是默认实例还是命名实例）不会对“实例 ID 后缀”复选框使用非默认值。

    实例根目录 - 默认情况下，实例根目录为 C:\Program Files\Microsoft SQL Server\。若要指定一个非默认的根目录，请使用所提供的字段，或单击“浏览”以找到一个安装文件夹。

    所有 SQL Server Service Pack 和升级都将应用于 SQL Server 实例的每个组件。

    检测到的实例和功能 - 该网格将显示运行安装程序的计算机上的 SQL Server 实例。如果计算机上已经安装了一个默认实例，则必须安装 SQL Server 2008 的命名实例。若要继续，请单击“下一步”。

  12. “磁盘空间要求”页计算指定的功能所需的磁盘空间，并将磁盘空间要求与正在运行安装程序的计算机上的可用磁盘空间进行比较。有关详细信息，请参阅磁盘成本摘要。

  13. 本主题中的其余工作流取决于要安装的功能。您可能不会看到所有的页面，具体取决于您进行的选择。

  14. 在“服务器配置 - 服务帐户”页上指定 SQL Server 服务的登录帐户。此页上配置的实际服务取决于要升级的功能。

    身份验证和登录信息将继承早期的 SQL Server 实例。您可以为所有 SQL Server 服务分配相同的登录帐户，也可以单独配置各个服务帐户。还可以指定服务是自动启动、手动启动还是禁用。Microsoft 建议对各服务帐户进行单独配置，以便为每项服务提供最低特权，即向 SQL Server 服务授予它们完成各自任务所需的最低权限。有关详细信息，请参阅SQL Server 配置 - 服务帐户和设置 Windows 服务帐户。

    若要为此 SQL Server 实例中的所有服务帐户指定相同的登录帐户，请在页面底部的字段中提供凭据。

    安全说明 不要使用空密码。请使用强密码。

    为 SQL Server 服务指定登录信息后，请单击“下一步”。

  15. 使用“服务器配置 - 排序规则”选项卡为数据库引擎和 Analysis Services 指定非默认的排序规则。有关详细信息，请参阅 SQL Server 配置 - 排序规则。

  16. 在“全文搜索升级选项”页上为所升级的数据库指定升级选项。有关详细信息，请参阅全文搜索升级选项。

  17. 在“错误和使用情况报告”页上指定要发送到 Microsoft 以帮助改善 SQL Server 的信息。默认情况下，用于错误报告和功能使用情况的选项处于启用状态。有关详细信息，请参阅错误和使用情况报告设置。

  18. 在升级操作开始之前，系统配置检查器将再运行一组规则来针对您指定的 SQL Server 功能验证您的计算机配置。

  19. 在“群集升级报告”页上指定升级操作期间节点脱机时的故障转移行为。可以选择故障转移到已升级的节点，也可以选择故障转移到处于早期版本级别的节点。使用“故障转移行为”下拉框进行选择。

  20. “准备升级”页显示您在安装过程中指定的安装选项的树视图。若要继续，请单击“安装”。

  21. 在安装过程中，进度页会提供相应的状态，因此您可以在安装过程中监视安装进度。

  22. 安装完成后，“完成”页会提供指向安装日志文件摘要以及其他重要说明的链接。若要完成 SQL Server 安装过程，请单击“关闭”。

  23. 如果安装程序指示您重新启动计算机，请立即重新启动。安装完成后，请务必阅读来自安装向导的消息。有关安装日志文件的信息，请参阅如何查看 SQL Server 安装日志文件。

后续步骤

升级到 SQL Server 2008 之后，请完成以下任务：

  • 注册服务器 - 升级会删除早期的 SQL Server 实例的注册表设置。升级之后，必须重新注册服务器。

  • 更新统计信息 - 为了帮助优化查询性能，建议您在升级之后更新所有数据库的统计信息。使用 sp_updatestats 存储过程可以更新 SQL Server 数据库中用户定义的表中的统计信息。

  • 更新使用计数器 - 在 SQL Server 的早期版本中，表和索引的行计数与页计数的值可能会不正确。若要更正任何无效的行或页计数，建议在升级完成后对所有数据库运行 DBCC UPDATEUSAGE。

  • 配置新安装的 SQL Server - 为了减少系统的可攻击外围应用，SQL Server 将有选择地安装和激活一些密钥服务和功能。有关外围应用配置器工具的详细信息，请参阅此版本的自述文件。

请参阅

概念

如何从命令提示符安装 SQL Server 2008
如何查看 SQL Server 安装日志文件

其他资源

How to: Verify a Successful Installation of SQL Server 2005 Services


如何重命名 SQL Server 故障转移群集实例

如何重命名 SQL Server 故障转移群集实例 |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 故障转移群集操作指南主题 >

如果 SQL Server 实例包括在故障转移群集中，则重命名虚拟服务器的过程不同于重命名独立实例的过程。有关详细信息，请参阅如何重命名承载 SQL Server 独立实例的计算机。

虚拟服务器的名称始终与 SQL 网络名称（SQL 虚拟服务器的网络名称）相同。尽管您可以更改虚拟服务器的名称，但不能更改实例名。例如，您可以将名为 VS1\instance1 的虚拟服务器更改为其他名称（例如 SQL35\instance1），但是名称的实例部分 (instance1) 将保持不变。

准备工作

开始重命名进程之前，请阅读下列各项：

  • 除了在复制时使用日志传送的情况之外，SQL Server 不支持对复制所涉及的服务器进行重命名。如果主服务器永久丢失连接，则可以重命名日志传送中的辅助服务器。有关详细信息，请参阅复制和日志传送。

  • 当您重命名被配置为使用数据库镜像的虚拟服务器时，必须在进行重命名操作之前先关闭数据库镜像，然后用新的虚拟服务器名称重新建立数据库镜像。数据库镜像的元数据将不会自动更新来反映新的虚拟服务器名称。

重命名虚拟服务器

  1. 使用群集管理器将 SQL 网络名称更改为新名称。

  2. 使网络名称资源脱机。这将使 SQL Server 资源和其他相关资源也脱机。

  3. 使 SQL Server 资源重新联机。

验证重命名操作

虚拟服务器被重命名之后，任何使用旧名称的连接现在都必须使用新名称来连接。

若要验证重命名操作是否完成，请从 @@servername 或 sys.servers 中选择信息。@@servername 函数将返回新的虚拟服务器名称，sys.servers 表将显示新的虚拟服务器名称。若要验证故障转移过程是否能够使用新名称正常工作，用户还应尝试将 SQL Server 资源故障转移到其他节点。

对于从群集中任何节点进行的连接，都可以立即使用新名称。但是，对于从客户端计算机使用新名称进行的连接，则必须在新名称对该客户端计算机可见之后，才能使用新名称连接到服务器。根据网络配置，通过网络传播新名称所需的时间长度可能为几秒钟，也可能长至 3 到 5 分钟；旧的虚拟服务器名称在网络上不再可见也可能会需要一些时间。

若要最小化虚拟服务器重命名操作的网络传播延迟，请使用下列步骤：

最小化网络传播延迟

  1. 在服务器节点上从命令提示符发出下列命令：

    复制代码
    ipconfig /flushdns
ipconfig /registerdns
nbtstat –RR

请参阅

任务

如何重命名承载 SQL Server 独立实例的计算机


如何为 SQL Server 资源添加依赖关系

如何为 SQL Server 资源添加依赖关系 |
 | 请参阅
高可用性解决方案概述 > SQL Server 2008 故障转移群集入门 > 故障转移群集操作指南主题 >

如果将 SQL Server 安装到具有多个磁盘驱动器的 Windows 2000 群集组，并选择将数据置于其中一个驱动器上，则 SQL Server 资源将被设置为只依赖于该驱动器。若要将数据或日志放到另一个磁盘上，必须先为相应磁盘添加与 SQL Server 资源的依赖关系。

需要特别注意的是：如果要将其他任何资源添加到 SQL Server 组中，这些资源必须始终具有自身的唯一 SQL 网络名称资源以及自身的 SQL IP 地址资源。

不要将现有的 SQL 网络名称资源和 SQL IP 地址资源用于 SQL Server 以外的任何资源。如果将 SQL Server 资源与其他资源共享，可能会发生下列问题：

  • 可能会发生意外停用。

  • Service Pack 安装可能会失败。

  • SQL Server 安装程序可能会失败。如果出现此问题，将无法安装更多的 SQL Server 实例，也不能执行例程维护。

还需要考虑下列问题：

  • 使用 FTP 进行 SQL Server 复制：如果 SQL Server 实例使用 FTP 进行 SQL Server 复制，则 FTP 服务必须与设置为使用 FTP 服务的 SQL Server 安装位于同一个物理磁盘。

  • SQL Server 资源依赖关系：如果将某个资源添加到 SQL Server 组中，并且您具有与 SQL Server 资源的依赖关系来确保 SQL Server 可用，则 Microsoft 建议您添加与 SQL Server 代理资源的依赖关系。不要添加与 SQL Server 资源的依赖关系。若要确保运行 SQL Server 的计算机保持高可用性，请对 SQL Server 代理资源进行合理配置以使 SQL Server 代理资源的失败不会对 SQL Server 组带来影响。

  • 文件共享和打印机资源：安装文件共享资源或打印机群集资源时，不应将它们置于运行 SQL Server 的计算机的同一物理磁盘资源上。如果将它们放在相同的物理磁盘资源上，可能导致运行 SQL Server 的计算机的性能降低或该计算机上的服务丢失。

  • MS DTC 注意事项：安装操作系统和配置群集后，必须使用群集管理器将 MS DTC 配置为在群集中使用。群集 MS DTC 失败不会导致 SQL Server 安装程序停止运行，但如果未能正确配置 MS DTC，则 SQL Server 应用程序功能可能会受影响。

    如果在 SQL Server 组中安装 Microsoft 分布式事务处理协调器 (MS DTC)，并且具有依赖于 MS DTC 的其他资源，则在此组脱机时或者处于故障转移期间的情况下，MS DTC 将不可用。默认情况下，在对新的安装运行 SQL Server 故障转移向导时，SQL Server 会要求将 MS DTC 资源放在 SQL Server 组中。Microsoft 建议尽可能将 MS DTC 放在自己的组和自己的物理磁盘资源中。

为 SQL Server 资源添加依赖关系

  1. 打开 Windows 管理工具中的群集管理器。

  2. 查找包含要添加依赖关系的可用 SQL Server 资源的组。

  3. 如果磁盘资源已经位于此组中，请转到步骤 4。否则，请查找包含该磁盘的组。如果该组与包含 SQL Server 的组不属于同一节点，请将包含磁盘资源的组移到包含 SQL Server 组的节点中。

  4. 使 SQL Server 资源脱机。

  5. 选定 SQL Server 资源，打开“属性”对话框，然后使用“依赖项”选项卡将磁盘添加到 SQL Server 依赖项集中。

请参阅

任务

如何阅读 SQL Server 安装日志文件

概念

安装故障转移群集前的准备工作
如何查看 SQL Server 安装日志文件


SQL Server 准备操作指南主题

SQL Server 准备操作指南主题 |
 | 请参阅
计划 SQL Server 安装 >

本节包含有关如何准备 SQL Server 的信息。

本节内容

  • 如何禁用服务器消息块

请参阅

参考

排序规则和 Unicode 支持
设置 Windows 服务帐户


如何禁用服务器消息块

如何禁用服务器消息块 |
 | 请参阅
计划 SQL Server 安装 > SQL Server 准备操作指南主题 >

周边网络中的服务器应该禁用所有不必要的协议，其中包括服务器消息块 (SMB)。Web 服务器和域名系统 (DNS) 服务器不需要 SMB。应该禁用此协议，以防来自用户枚举的威胁。

禁用 SMB

  1. 在“开始”菜单中，指向“设置”，然后单击“网络和拨号连接”。

    右键单击 Internet 连接，然后单击“属性”。

  2. 选中“Microsoft Networks 客户端”复选框，然后单击“卸载”。

  3. 执行卸载步骤。

  4. 选择“Microsoft Networks 文件和打印机共享”，然后单击“卸载”。

  5. 执行卸载步骤。

在可通过 Internet 访问的服务器上禁用 SMB

  • 在本地连接属性中，使用“传播控制协议/Internet 协议 (TCP/IP) 属性”对话框删除“Microsoft Networks 文件和打印共享”和“Microsoft Networks 客户端”。

请参阅

概念

安装 SQL Server 的安全注意事项

其他资源

SQL Server 准备操作指南主题


如何更改操作系统设置以支持本地化版本

如何更改操作系统设置以支持本地化版本 |
 | 请参阅
计划 SQL Server 安装 > SQL Server 准备操作指南主题 >

在支持的操作系统的英文版上，通过使用 Microsoft Windows 多语言用户界面包 (MUI) 设置，支持使用 SQL Server 的本地化版本。

不过，在运行英语版操作系统（具有非英文 MUI 设置）的服务器上安装 SQL Server 的本地化版本之前，必须先验证某些操作系统设置。需要验证下列操作系统设置是否匹配要安装的本地化 SQL Server 的语言：

  • 操作系统用户界面设置

  • 操作系统用户区域设置

  • 系统区域设置

如果这些设置与要安装的本地化 SQL Server 的语言不匹配，请使用下列过程正确设置这些操作系统设置。

注意：
不支持在同一台计算机上安装 SQL Server 实例的不同语言版本。

更改操作系统用户界面设置

  1. 安装与 SQL Server 的本地化版本匹配的操作系统 MUI（如果尚未安装）。

  2. 在 Control Panel 中，打开 Regional and Language Options。

  3. 在 Languages 选项卡上，从列表中为 Language used in menus and dialogs 选择一个值。

    此设置将影响 SQL Server 的用户界面语言，所以它必须与 SQL Server 的本地化版本匹配。

  4. 单击 Apply 确认更改，然后单击 OK 关闭窗口。

更改操作系统用户区域设置

  1. 安装与 SQL Server 的本地化版本匹配的操作系统 MUI（如果尚未安装）。

  2. 在 Control Panel 中，打开 Regional and Language Options。

  3. 在 Regional Options 选项卡上，从列表中为 Select an item to match its preferences 选择一个值。

    此设置将影响特定于区域性的数据格式。

  4. 单击 Apply 确认更改，然后单击 OK 关闭窗口。

更改系统区域设置

  1. 安装与 SQL Server 的本地化版本匹配的操作系统 MUI（如果尚未安装）。

  2. 在 Control Panel 中，打开 Regional and Language Options。

  3. 在 Advanced 选项卡上，从列表中为 Select a language to match the language version of the non-Unicode programs you want to use 选择一个值。

    此设置将使 SQL Server 安装程序可以为 SQL Server 安装选择最佳默认排序规则。

  4. 单击 Apply 确认更改，再单击 OK 关闭窗口。

请参阅

参考

排序规则和 Unicode 支持
安装 SQL Server 2008 的硬件和软件要求

其他资源

SQL Server 准备操作指南主题


安装 SQL Server 2008

安装 SQL Server 2008 |
 | 请参阅

SQL Server 安装向导基于 Windows Installer。它提供了一个功能树以用来安装所有 SQL Server 组件：

  • SQL Server 数据库引擎

  • Analysis Services

  • Reporting Services

  • Integration Services

  • 复制

  • 管理工具

  • 文档

注意 SQL Server 有 32 位和 64 位两种版本可用。SQL Server 的 32 位和 64 位版本可通过安装向导或命令提示符进行安装。有关 SQL Server 组件的详细信息，请参阅 SQL Server 2008 的版本和组件和 SQL Server 2008 各个版本支持的功能。

默认情况下，不会将示例数据库和示例代码作为 SQL Server 安装程序的一部分进行安装。对于 SQL Server 2008 Express Edition 以外的其他 SQL Server 2008 版本，若要安装示例数据库和示例代码，请访问 CodePlex 网站，网址为：http://go.microsoft.com/fwlink/?LinkId=87843。若要了解对 SQL Server Express 的 SQL Server 示例数据库和示例代码的相关支持，请参阅“数据库和示例概述”：http://go.microsoft.com/fwlink/?LinkId=110391。

无论使用 SQL Server 安装向导还是命令提示符安装 SQL Server，安装过程都包括下列步骤：

本节内容

计划 SQL Server 安装

介绍如何为安装 SQL Server 而准备计算机：

  • 查看硬件和软件要求。

  • 查看系统配置检查器的要求和妨碍性问题。

  • 查看 SQL Server 安装的安全注意事项。

配置 SQL Server 2008

安装完成后，可以使用图形化实用工具和命令提示符实用工具配置 SQL Server。

相关章节

安装 SQL Server 数据库引擎的注意事项

介绍如何安装和配置 SQL Server 数据库引擎。

安装 Analysis Services 时的注意事项

介绍如何安装和配置 Analysis Services。

安装 Reporting Services 的注意事项

介绍如何安装和配置 Reporting Services。

安装 Integration Services 的注意事项

介绍如何安装和配置 Integration Services。

安装 SQL Server 复制的注意事项

本节介绍如何安装和配置 SQL Server 复制。

安装 SQL Server 管理工具的注意事项

本节介绍如何安装和配置 SQL Server 管理工具。

安装 SQL Server 示例和示例数据库的注意事项

本节介绍如何安装 SQL Server AdventureWorks 示例。

请参阅

任务

如何安装 SQL Server 2008（安装程序）

其他资源

高可用性解决方案概述


安装 SQL Server 数据库引擎的注意事项

安装 SQL Server 数据库引擎的注意事项 |
 | 请参阅
安装 SQL Server 2008 >

SQL Server 的数据库引擎组件是用于存储、处理数据和保证数据安全的核心服务。数据库引擎提供受控的访问和快速事务处理，以满足企业中要求极高、大量使用数据的应用程序的要求。

SQL Server 支持在同一台计算机上最多存在 50 个数据库引擎实例。若要创建典型的 SQL Server 安装，请参阅如何安装 SQL Server 2008（安装程序）。

重要提示 对于本地安装，必须以管理员身份运行安装程序。如果从远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。

在 SQL Server 安装向导的“要安装的组件”页上选择 SQL Server 数据库引擎时，将安装下列功能：

  • 数据库引擎

  • 复制 - 是一个可选组件

  • 全文搜索 - 是一个可选组件

下列附加功能是许多典型用户应用场景的可选项：

  • Integration Services

  • 连接组件

  • 编程模型

  • 管理工具

  • Management Studio

  • SQL Server 联机丛书

注意：
默认情况下，不会将示例数据库和示例代码作为 SQL Server 安装程序的一部分进行安装。若要安装示例数据库和示例代码，请参阅 CodePlex 网站。

请参阅

任务

如何升级到 SQL Server 2008（安装程序）

参考

SQL Server 2008 的版本和组件

概念

计划 SQL Server 安装

其他资源

高可用性解决方案概述


安装 Analysis Services 时的注意事项

安装 Analysis Services 时的注意事项 |
 | 请参阅
安装 SQL Server 2008 >

SQL Server 提供了一个用于安装其任意组件或所有组件（包括 Analysis Services）的安装程序。通过安装程序，您可以在一台计算机上安装 Analysis Services 或将其与其他 SQL Server 组件一起安装。

本主题着重说明了安装 Analysis Services 前应该了解的重要注意事项。本主题中的信息将帮助您评估安装选项，以便您做出适当选择使安装成功完成。

本主题不包括有关启动安装程序、从命令行运行安装程序或使用安装向导的说明。有关如何启动安装程序以及如何选择要安装的组件的分步说明，请参阅 SQL Server 2008 安装快速入门。有关安装 Analysis Services 的命令行选项的信息，请参阅如何从命令提示符安装 SQL Server 2008。

准备安装 SQL Server Analysis Services

安装 Microsoft SQL Server Analysis Services 之前，请查看下列要求：

  • 安装 SQL Server 2008 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

选择要安装的组件

虽然可单独安装 Analysis Services，但请注意，许多数据仓库解决方案需要安装其他 SQL Server 组件才能开发、部署和管理 Analysis Services 数据库。下表说明了这些附加的 SQL Server 组件。

组件 | 适用于管理员 | 适用于开发人员 | 可选组件
连接组件 用于客户端和服务器之间通信的组件，包括用于 DB-Library、ODBC 和 OLE DB 的网络库。 | X | X |
管理工具 用于管理 SQL Server 的交互工具，包括 SQL Server 配置管理器、SQL Server Management Studio、SQL Server Profiler 和复制监视器。 | X |  |
Business Intelligence Development Studio 商业智能项目的集成开发环境。 |  | X |
软件开发包 可帮助开发人员为 SQL Server 创建自定义解决方案的软件。 |  | X |
SQL Server Database Services SQL Server 数据库引擎和用于管理关系数据和 XML 数据、复制以及全文搜索的工具。 |  |  | X
Reporting Services 报表服务器和报表管理器，前者用于管理、执行、呈现和分发报表，后者是用于访问 SQL Server Reporting Services 组件的基于 Web 的用户界面，包括管理工具和报表。 |  |  | X
Integration Services SQL Server Integration Services，一组用于移动、复制和转换数据的图形化和可编程的对象。 |  |  | X
文档和示例 SQL Server 联机丛书文档、编程参考材料和所有 SQL Server 组件的示例。 | X | X | X

用于安装 Analysis Services 的选项

可以按下列配置安装 Analysis Services：

  • 在没有 SQL Server 先前实例的计算机上安装 Analysis Services。

  • 将 SQL Server 2008 Analysis Services 与 SQL Server 2005 Analysis Services 或 SQL Server 2000 Analysis Services 的现有实例并行安装。

  • 将 SQL Server 2005 Analysis Services 或 SQL Server 2000 Analysis Services 的现有实例升级到 SQL Server 2008 Analysis Services。

安装 SQL Server Analysis Services

在检查了 SQL Server 的安装要求并确保计算机满足这些要求后，就可以安装 SQL Server Analysis Services 了。

如果使用安装向导安装 Analysis Services，您将使用一系列页面来指定组件和选项。下表仅列出了安装向导页面中供选择的选项将对 Analysis Services 安装产生影响的那些页面：

页 建议

要安装的组件

选择 Analysis Services 以安装 Analysis Services 服务。

选择“工作站组件、联机丛书和开发工具”以安装工具和文档。

实例名

在“实例名”页上，只能为所有选定要安装的 SQL Server 组件指定一个实例名。因此，不能同时安装 SQL Server 数据库引擎的默认实例和 Analysis Services 的命名实例。在多个实例的情况下，必须对要使用的每个实例名分别运行安装程序。

与 SQL Server 2000 Analysis Services 并行安装时，必须将 SQL Server 2008 Analysis Services 安装为命名实例。

与 SQL Server 2005 Analysis Services 并行安装时，必须将 SQL Server 2008 Analysis Services 安装为唯一的命名实例。

服务帐户

Analysis Services 作为 Microsoft Windows 服务启动和运行。此服务出现在 SQL Server 配置管理器中已安装服务的列表中，也出现在对 Windows 服务提供管理支持的 Microsoft 管理控制台 (MMC) 管理单元“服务”中。

每个 Analysis Services 实例由自己的服务支持，且每个实例的排序规则和其他服务器选项可以使用不同的设置。每个实例的服务名反映了安装过程中指定的实例名。默认实例的服务名是 MSSQLServerOLAPService。命名实例的服务名为 MSOLAP$实例名称，其中 实例名称 为安装期间为该实例指定的名称。

身份验证模式

该页用于为数据库引擎设置身份验证提供程序。SQL Server Analysis Services 只支持 Windows 身份验证。

排序规则设置

Analysis Services 使用的排序规则指示符和排序顺序设置与 SQL Server 数据库引擎相同。如果在同一个实例名下安装 Analysis Services 和 SQL Server 数据库引擎，则可以选择这两个服务器是使用相同的设置还是使用不同的设置。如果选择使用不同的设置，则必须分别配置 Analysis Services 和 SQL Server 数据库引擎，具体过程如下所述。

在 Analysis Services 和 SQL Server 数据库引擎中使用不同的排序规则设置

  1. 在安装向导的“排序规则设置”页上，选中“为每个服务帐户进行自定义”复选框。

  2. 在“服务”旁边，选择 Analysis Services，然后配置 Analysis Services 的排序规则选项。

    注意：
    “SQL 排序规则”选项不适用于 Analysis Services，且在配置 Analysis Services 排序规则选项时，该选项不可用。

  3. 在“服务”旁边，选择“数据库引擎”，然后配置 SQL Server 数据库引擎的排序规则选项。

有关 SQL Server 排序规则选项的详细信息，请参阅排序规则和 Unicode 支持。

请参阅

任务

如何升级到 SQL Server 2008（安装程序）

其他资源

高可用性解决方案概述


Analysis Services 安装操作指南主题

Analysis Services 安装操作指南主题 |
 | 请参阅
安装 SQL Server 2008 > 安装 Analysis Services 时的注意事项 >

本部分包含安装 Microsoft SQL Server Analysis Services 所用的以下通用步骤。

有关从 Analysis Services 的早期版本进行升级以及迁移 Analysis Services 包的通用步骤，请参阅安装 Analysis Services 时的注意事项。

重要提示：
本部分中的 Analysis Services 安装操作指南主题只将重点放在特定于 Analysis Services 的安装选项上。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

本节内容

  • 如何使用安装程序安装 Analysis Services

  • 如何安装 Analysis Services 的多个实例

  • 如何将 Analysis Services 与早期版本并行安装

  • 如何重命名 Analysis Services 实例

  • 如何添加或删除 Analysis Services 实例的功能

  • 如何卸载 Analysis Services 实例

请参阅

概念

安装 Analysis Services 时的注意事项


如何使用安装程序安装 Analysis Services

如何使用安装程序安装 Analysis Services |
 | 请参阅
安装 SQL Server 2008 > 安装 Analysis Services 时的注意事项 > Analysis Services 安装操作指南主题 >

既可使用 SQL Server 安装向导也可使用命令提示符来安装 Microsoft SQL Server Analysis Services。此安装向导提供了图形用户界面，该界面可以引导您确定每个安装选项，这是推荐大多数用户使用的方法。安装向导为 SQL Server 的初始安装提供指导。其中包括功能选择、实例命名规则、服务帐户配置、强密码指南和排序规则选择。

重要提示：
此主题和此部分中 Analysis Services 安装的其他操作指南主题仅重点介绍 Analysis Services 特有的安装选项。不过，这些主题中提供了关于其他主题的链接，可通过这些链接了解安装 SQL Server 的详细信息。

使用安装程序安装 Analysis Services

  1. 启动 SQL Server 安装向导。

  2. 可以根据需要查看如何安装 SQL Server 2008（安装程序），以查看安装向导的说明，特别是在除 Analysis Services 之外还安装其他 SQL Server 组件时。

  3. 在安装向导的“要安装的组件”页上，选择 Analysis Services。有关要在安装的软件中包括的其他 SQL Server 功能（例如，文档和开发工具）的详细信息，请查看安装 Analysis Services 时的注意事项。

  4. 在“实例名”页上，为安装的软件选择默认实例或命名实例。如果默认的实例已存在，或者如果不希望升级的 SQL Server 2000 Analysis Services 实例已存在于该计算机上，则只能选择命名实例。

  5. 在“服务帐户”页上，为 Analysis Services 服务帐户以及其他 SQL Server 服务帐户指定用户名、密码和域名。您可以将一个帐户用于所有服务。

  6. 在“排序规则设置”页上，指定默认的排序规则。可对 Analysis Services 使用一个排序规则，对 SQL Server 数据库引擎 使用另一个排序规则，或者也可以将一个排序规则指定给所有服务。

  7. 完成安装向导。其余向导页不包含与 Analysis Services 有关的选项设置。

请参阅

概念

安装 Analysis Services 时的注意事项

其他资源

Analysis Services 安装操作指南主题


如何安装 Analysis Services 的多个实例

如何安装 Analysis Services 的多个实例 |
 | 请参阅
安装 SQL Server 2008 > 安装 Analysis Services 时的注意事项 > Analysis Services 安装操作指南主题 >

可以在同一台计算机上运行 Microsoft SQL Server Analysis Services 的多个实例。若要再安装一个实例，请再次运行安装程序并为新实例指定一个唯一的名称。

重要提示：
本部分中的 Analysis Services 安装操作指南主题只将重点放在特定于 Analysis Services 的安装选项上。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

安装 Analysis Services 的另一个实例

  1. 使用 SQL Server 安装向导或在命令提示符下运行安装程序。有关详细信息，请参阅安装 Analysis Services 时的注意事项。

  2. 使用 SQL Server 安装向导时，请在“实例名”页上指定唯一的实例名称。在命令提示符下运行安装程序时，请使用 INSTANCE 选项指定唯一的实例名。

请参阅

其他资源

Analysis Services 安装操作指南主题


如何将 Analysis Services 与早期版本并行安装

如何将 Analysis Services 与早期版本并行安装 |
 | 请参阅
安装 SQL Server 2008 > 安装 Analysis Services 时的注意事项 > Analysis Services 安装操作指南主题 >

可以将 SQL Server 2008 Analysis Services 与 SQL Server 2005 Analysis Services 或 SQL Server 2000 Analysis Services 的现有实例并行安装。

与 SQL Server 2000 Analysis Services 并行安装时，必须将 SQL Server 2008 Analysis Services 安装为命名实例，因为 SQL Server 2000 Analysis Services 不支持命名实例。如果您稍后删除 SQL Server 2000 Analysis Services 的默认实例，则可使用 Analysis Services 实例重命名工具使 SQL Server 2008 Analysis Services 的实例成为默认实例。有关详细信息，请参阅如何重命名 Analysis Services 实例。

与 SQL Server 2005 Analysis Services 并行安装时，必须将 SQL Server 2008 Analysis Services 安装为唯一的命名实例。

重要提示：
本部分中的 Analysis Services 安装操作指南主题只将重点放在特定于 Analysis Services 的安装选项上。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

将 Analysis Services 与早期版本并行安装

  1. 使用 SQL Server 安装向导或在命令提示符下运行安装程序。有关详细信息，请参阅安装 Analysis Services 时的注意事项。

  2. 使用 SQL Server 安装向导时，请在“实例名”页上指定唯一的实例名称。在命令提示符下运行安装程序时，请使用 INSTANCE 选项指定唯一的实例名。

请参阅

其他资源

Analysis Services 安装操作指南主题


如何重命名 Analysis Services 实例

如何重命名 Analysis Services 实例 |
 | 请参阅
安装 SQL Server 2008 > 安装 Analysis Services 时的注意事项 > Analysis Services 安装操作指南主题 >

通过使用“重命名实例”对话框，可以重命名现有的 Microsoft Analysis Services 实例。

重要提示：
本主题和此部分中 Analysis Services 安装的其他帮助主题仅重点介绍 Analysis Services 特有的安装选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

注意：
在 64 位计算机中，必须使用 64 位版本的实例重命名工具。

注意：
群集环境中不支持 Analysis Services 实例重命名工具。

重命名 Analysis Services 的实例

  1. 运行 C:\Program Files\Microsoft SQL Server\10\Tools\Binn\VSShell\Common7\IDE 下的 asinstancerename.exe，启动“实例重命名”工具。

  2. 在“重命名实例”对话框中，从“要重命名的实例”列表中选择要重命名的实例。

  3. 在“新实例名”框中，输入实例的新名称。

  4. 验证用户名和密码是否正确，然后单击“重命名”。

请参阅

其他资源

“重命名实例”对话框（分析服务）
Analysis Services 安装操作指南主题
管理 Analysis Services 实例


如何添加或删除 Analysis Services 实例的功能

如何添加或删除 Analysis Services 实例的功能 |
 | 请参阅
安装 SQL Server 2008 > 安装 Analysis Services 时的注意事项 > Analysis Services 安装操作指南主题 >

在 Microsoft SQL Server 中，只有通过 Microsoft Windows 中“控制面板”的“添加或删除程序”才能支持功能维护。

重要提示：
此主题和此部分中 Analysis Services 安装的其他操作指南主题仅重点介绍 Analysis Services 特有的安装选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

更改 SQL Server Analysis Services 现有实例中的组件

  1. 在 Microsoft Windows 桌面上单击“开始”，单击“控制面板”，再双击“添加或删除程序”。

  2. 在“当前安装的程序”下，选择 Microsoft SQL Server，再单击“更改”。这将启动 Microsoft SQL Server 维护向导。

  3. 在“选择组件”页上的 SQL Server 实例下，选择包含要修改的 Analysis Services 实例的实例。

  4. 在“功能维护”页上，选择 Analysis Services。随后 Microsoft SQL Server 维护向导将启动 Microsoft SQL Server 安装向导。

  5. 在“更改或删除实例”页上，单击“更改已安装的组件”。

  6. 单击“下一步”，然后按照后续向导页中的说明执行操作。

请参阅

其他资源

Analysis Services 安装操作指南主题


如何卸载 Analysis Services 实例

如何卸载 Analysis Services 实例 |
 | 请参阅
安装 SQL Server 2008 > 安装 Analysis Services 时的注意事项 > Analysis Services 安装操作指南主题 >

使用以下步骤卸载 Microsoft SQL Server Analysis Services 的实例。

重要提示：
此主题和此部分中 Analysis Services 安装的其他操作指南主题仅重点介绍 Analysis Services 特有的安装选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

删除 SQL Server Analysis Services 的实例

  1. 在 Microsoft Windows 桌面上单击“开始”，单击“控制面板”，再双击“添加或删除程序”。

  2. 在“当前安装的程序”下，选择 Microsoft SQL Server，再单击“更改”。这将启动 Microsoft SQL Server 维护向导。
注意：
如果单击“删除”，而不是单击“更改”，则在卸载 Analysis Services 的实例的同时，也将卸载同名实例下安装的 SQL Server 数据库引擎和 Reporting Services。

  1. 在“选择组件”页上的 SQL Server 实例下，选择包含要删除的 Analysis Services 实例的实例。

  2. 在“功能维护”页上，选择 Analysis Services。随后 Microsoft SQL Server 维护向导将启动 Microsoft SQL Server 安装向导。

  3. 在“更改或删除实例”页上，单击“删除 Microsoft SQL Server”。

  4. 单击“下一步”，然后按照后续向导页中的说明执行操作。

请参阅

其他资源

Analysis Services 安装操作指南主题


安装 Reporting Services 的注意事项

安装 Reporting Services 的注意事项 |
 | 请参阅
安装 SQL Server 2008 >

SQL Server 提供一个用于安装所有组件（包括 Reporting Services）的安装程序。使用安装程序，可以在单台计算机上安装 Reporting Services 或将其与其他 SQL Server 组件一起安装。如果要单独安装 Reporting Services 客户端和服务器应用程序，则也可以选择 Reporting Services 中的特定功能。

本主题包含以下信息和建议：

  • 选择客户端和服务器应用程序以便包含在 Reporting Services 安装中。

  • 选择附加服务和功能以支持报表服务器操作。

  • 为报表服务器服务选择服务帐户。

  • 选择安装模式，以指示安装程序是最少配置还是完全配置要安装的实例。

  • 在同一台计算机上安装 Reporting Services 的多个实例和版本。

准备安装 Reporting Services

安装 Reporting Services 之前，请查看以下要求和组件说明：

  • 安装 SQL Server 2008 的硬件和软件要求

  • 安装 SQL Server 的安全注意事项

  • 设置 Windows 服务帐户

熟悉安装要求之后，可从命令行或安装向导运行安装程序：

  • 如何安装 SQL Server 2008（安装程序）

  • 如何从命令提示符安装 SQL Server 2008

选择客户端和服务器应用程序

除了 SQL Server 提供的共享工具之外，Reporting Services 还包括一整套用于业务报表的工具和应用程序。下面的列表说明在安装向导或命令行参数中选择特定功能时安装哪些工具和应用程序：

功能选择 | 说明
Reporting Services - 或 - /FEATURES=RS | 安装以下应用程序： 报表服务器服务（它包括报表服务器 Web 服务、后台处理应用程序和报表管理器）、报表生成器、报表设计器、模型设计器、Reporting Services 配置工具和 Reporting Services 命令行实用工具（rsconfig.exe、rskeymgmt.exe 和 rs.exe）。
客户端工具 - 或 - /FEATURES=Tools | 安装用于配置报表服务器、管理作业、管理共享计划和配置角色定义的 SQL Server Management Studio。
Business Intelligence Development Studio - 或 - /FEATURES=BIDS | 安装用于提供报表设计器和模型设计器的 Visual Studio 设计环境。

选择附加服务和功能

添加其他 SQL Server 组件技术和服务可使 Reporting Services 部署受益：

  • 在“功能选择”页中选择“数据库引擎服务”可以承载报表服务器数据库。Reporting Services 需要 SQL Server 2005 或 SQL Server 2008 数据库引擎的本地或远程实例来承载报表服务器数据库。如果同时安装数据库引擎实例和 Reporting Services，则安装默认配置可省去安装后的任务，因为该默认配置会自动创建和配置报表服务器数据库。除了承载报表服务器数据库之外，SQL Server 关系数据库还可以是报表和模型的数据源。

  • 如果要将 Reporting Services 后台处理应用程序用于订阅和计划报表，则需要“SQL Server 代理”。SQL Server 代理应运行在承载报表服务器数据库的数据库引擎实例中。安装数据库引擎时可在“服务器配置”页中指定 SQL Server 代理。

  • 如果安装的数据库引擎实例将用于为不同计算机上的报表服务器实例承载报表服务器数据库，则需要“SQL Server 浏览器”。安装数据库引擎时可在“服务器配置”页中指定“SQL Server 浏览器”。

  • 如果要将 SQL Server Analysis Services 用作报表和模型的数据源，则在“功能选择”页中选择 Analysis Services。

  • 如果要安装 Reporting Services 的产品文档，则在“功能选择”页中选择“SQL Server 联机丛书”。

  • 如果要使用示例 SSIS 包、脚本和报表来查询报表执行日志数据，则在“功能选择”页中选择 Integration Services。必须安装 Integration Services 才能运行包。

选择服务帐户

安装程序在安装向导中提供“服务器配置”页，以便可以配置当前安装中的服务。安装不会选择默认服务帐户，因此必须显式指定要使用的服务帐户。建议您使用拥有网络连接权限的最低特权域用户帐户。如果可能，指定专门供报表服务器使用的帐户，以便能够审核此帐户的登录活动。

以后如果要修改报表服务器服务帐户或更新密码，则使用 Reporting Services 配置工具来进行更改。有关帐户建议或更新服务帐户设置的详细信息，请参阅设置 Windows 服务帐户和配置报表服务器服务帐户。

选择安装选项

安装程序要求您为 Reporting Services 选择安装选项：

  • “安装本机模式默认配置”指示安装程序安装预先配置为使用默认值的 Reporting Services。仅当同时安装本地数据库引擎实例和 Reporting Services 实例时，默认安装选项才可用，否则，不能选择此安装选项。此选项可在本机模式下创建安装完成后可以使用的完全部署的报表服务器，从而节省时间和步骤。有关详细信息，请参阅本机模式安装默认配置 (Reporting Services)。

  • “安装 SharePoint 模式默认配置”指示安装程序安装预先配置为使用报表服务器数据库（与 SharePoint 数据存储配合使用）的 Reporting Services。仅当同时安装本地数据库引擎实例和 Reporting Services 实例时，此默认安装选项才可用。只有在计划将报表服务器集成与 SharePoint 部署一起配置时才应选择此选项。直到您执行此操作时报表服务器才会完全正常运行。有关详细信息，请参阅 SharePoint 集成模式默认配置 (Reporting Services)。

  • “安装但不配置服务器”指示安装程序将程序文件复制到磁盘，配置报表服务器服务并注册报表服务器 Windows Management Instrumentation (WMI) 提供程序。此安装选项称为“仅文件”安装，并作为默认安装选项使用。必须使用 Reporting Services 配置工具进行进一步的配置，才能使用报表服务器。如果要将报表服务器作为安装后任务单独配置，使用自定义设置，使用现有或远程数据库引擎实例来承载报表服务器数据库，或者将 Reporting Services 安装为命名实例，则选择此选项。有关详细信息，请参阅“仅文件”安装 (Reporting Services)。

安装程序不在远程计算机上安装组件。而且，诸如扩展部署、SharePoint 集成模式或在故障转移群集上配置报表服务器数据库之类的部署方案超出了安装程序的范围。有关如何支持和配置这些部署方案的详细信息，请参阅 SQL Server 联机丛书中的规划和体系结构 (Reporting Services)。

比较安装选项

下表将默认配置中使用的设置与“仅文件”安装中使用的设置进行比较。

操作 | 默认配置 | “仅文件”安装
配置实例名。 | 要求同时将数据库引擎和 Reporting Services 安装为同一实例。使用为承载报表服务器数据库的数据库引擎实例指定的 SQL Server 实例名称。 | 使用 SQL Server 实例名。“仅文件”安装可以是默认实例，也可以是命名实例。
创建程序文件夹并复制文件。 | 是 | 是
注册报表服务器 WMI 提供程序。 | 是 | 是
配置服务帐户和启动类型。 | 是。安装期间必须指定此值。 | 是。安装期间必须指定此值。
启动报表服务器服务。 | 是 | 是
向报表服务器服务帐户授予文件夹权限。 | 是 | 是
创建 reportserver 和 reportservertempdb 数据库。创建用于指定数据库权限的 rsexecrole。 | 是。如果默认配置为 SharePoint 集成模式，则报表服务器系统属性 IsSharePointEnabled 将设置为 True。 | 否
配置数据库连接。 | 是。通过 rsexecrole 授予报表服务器服务帐户数据库的权限。 | 否
为报表服务器和报表管理器保留 URL（仅限本机模式）。 | 是 | 否
初始化报表服务器。 | 是 | 否
配置电子邮件传递。 | 否 | 否
配置无人参与的执行帐户。 | 否 | 否
备份加密密钥。 | 否 | 否

配置 Reporting Services

安装 Reporting Services 后，可修改此安装以重新配置服务器或为安装选择自定义设置。如果已执行“仅文件”安装，则必须使用 Reporting Services 配置工具来配置报表服务器，以便其可以使用。

若要运行 Reporting Services 配置工具，请单击“开始”，依次指向“所有程序”、Microsoft SQL Server 2008 和“配置工具”，再单击“Reporting Services 配置”。有关详细信息，请参阅Reporting Services 配置工具和Reporting Services 配置操作指南主题。

验证 Reporting Services 安装

安装和配置后，请验证 Reporting Services 组件是否正常运行。有关详细信息，请参阅如何验证 Reporting Services 安装。

安装 Reporting Services 的多个实例和版本

报表服务器组件是识别实例的组件。如果要在同一台计算机上并行运行 SQL Server 2008、SQL Server 2005 或 SQL Server 2000 版的 Reporting Services，则可安装相同版本或不同版本的 Reporting Services 的多个实例。

SQL Server 2000 Reporting Services 可继续作为默认实例与 SQL Server 2008 Reporting Services 的命名实例并行运行。如果将 SQL Server 2000 Reporting Services 与其他版本一起运行，则 SQL Server 2000 Reporting Services 必须为默认实例，因为它不支持命名实例。因此，在运行 SQL Server 2000 Reporting Services 的计算机上进行并行安装时，SQL Server 安装程序只允许安装 SQL Server 2008 Reporting Services 的命名实例。

安装程序一次安装一个实例。SQL Server 的单个实例可以包含多个组件，其中包括 Reporting Services。通过多次运行安装程序，可在同一台计算机上安装 Reporting Services 的多个实例。

如果安装作为默认实例和命名实例运行的 Reporting Services 的多个实例，将通过实例名标识每个实例。SQL Server 2008 还包括版本信息。例如，如果安装了 SQL Server 2005 和 SQL Server 2008 的默认实例和命名实例，则将看到以下所有四个实例的程序文件和服务：

  • SQL Server 2005 Reporting Services (MSSQLSERVER)

  • SQL Server 2005 Reporting Services (MyInstanceName)

  • SQL Server 2008 Reporting Services (MSRS10.MSSQLSERVER)

  • SQL Server 2008 Reporting Services (MSRS10.MyInstanceName)

默认情况下，如果将 Reporting Services 安装为命名实例，则该实例名将用于定义报表服务器和报表管理器的虚拟目录，并将包括在用于报表服务器和报表管理器的 URL 中，以便每个应用程序相对于运行在同一台计算机上的该应用程序的其他实例具有唯一的名称。有关详细信息，请参阅配置报表服务器 URL。

共享功能

不能安装共享功能的多个实例，但可将其与早期版本并行运行（例如，在同一台计算机上运行 SQL Server 2005 和 SQL Server 2008 Business Intelligence Development Studio）。

不能将一个版本的报表创作工具、服务器配置工具或管理工具用于另一个版本。例如，不能使用 SQL Server 2008 中的 Reporting Services 配置工具来配置早期版本的报表服务器。请确保为安装的每个版本安装所有需要的工具和应用程序。

请参阅

概念

为扩展部署配置 Reporting Services

其他资源

部署 (Reporting Services)
升级 (Reporting Services)
Reporting Services 组件和工具
规划和体系结构 (Reporting Services)


本机模式安装默认配置 (Reporting Services)

本机模式安装默认配置 (Reporting Services) |
 | 请参阅
安装 SQL Server 2008 > 安装 Reporting Services 的注意事项 >

“本机模式默认配置”指安装程序既安装报表服务器实例也对其进行配置的 Reporting Services 安装。安装程序结束后，报表服务器便进入运行状态，可供使用。本机模式报表服务器作为一个独立的应用程序服务器运行。本机模式是默认模式。

当选择本机模式默认配置选项时，安装程序安装以下 Reporting Services 功能：报表服务器服务（包括报表服务器 Web 服务、后台处理应用程序和报表管理器）、报表生成器、报表设计器预览、Reporting Services 配置工具和 Reporting Services 命令行实用工具（rsconfig.exe、rskeymgmt.exe 和 rs.exe）。此选项不适用于诸如 SQL Server Management Studio 或 Business Intelligence Development Studio 之类的共享功能。如果要安装此类功能，就必须将其指定为独立的项。

安装程序为本机模式的报表服务器安装配置以下设置：

  • 报表服务器服务的服务帐户。

  • 报表服务器 Web 服务 URL。

  • 报表管理器 URL。

  • 报表服务器数据库。

  • 服务帐户对报表服务器数据库的访问权限。

  • 与报表服务器数据库的 DSN 连接。

安装程序不会配置无人参与的执行帐户和报表服务器电子邮件，不会备份加密密钥或进行扩展部署。可以使用 Reporting Services 配置工具配置这些属性。有关详细信息，请参阅 Reporting Services 配置工具。

何时安装本机模式默认配置

默认配置在操作状态下安装 Reporting Services，以便在安装程序结束后可以立即使用报表服务器。如果希望通过省掉那些原本要在 Reporting Services 配置工具中执行的必要配置任务从而减少配置步骤，请指定此模式。

安装默认配置不能确保安装程序结束后报表服务器即可工作。服务启动时，默认 URL 可能无法注册。请始终对安装进行测试，以确保服务启动并按预期方式运行。

要求

此安装选项使用默认值来配置使报表服务器正常运转所需的核心配置。安装具有以下要求：

  • Reporting Services 和 SQL Server 数据库引擎必须共同安装在同一实例中。数据库引擎实例承载安装程序所创建和配置的报表服务器数据库。

  • 用于运行安装程序的用户帐户必须是本地 Administrators 组成员，而且拥有针对承载报表服务器数据库的数据库引擎实例创建数据库的权限。

  • 安装程序必须能够使用默认值来保留用于访问报表服务器和报表管理器的 URL。这些值包括端口 80、强通配符和虚拟目录名（格式为 ReportServer_<instance_name> 和 Reports_<instance_name>）。

  • 安装程序必须能够使用默认值来创建报表服务器数据库。这些值包括 ReportServer 和 ReportServerTempDB。如果存在以前安装的现有数据库，安装程序则因无法将报表服务器配置为本机模式的默认配置而被阻止。必须重命名、移动或删除这类数据库以取消阻止安装程序。

如果计算机不满足默认安装的全部要求，则必须在“仅文件”模式下安装 Reporting Services 并在安装程序结束后使用 Reporting Services 配置工具对其进行配置。

请不要仅为了使默认安装继续进行而试图对计算机进行重新配置。这样做可能需要好几个小时的工作量，实际上抵消了该安装选项所带来的省时优势。最佳的解决方案是在“仅文件”模式下安装 Reporting Services，然后将报表服务器配置为使用特定值。

默认 URL 保留项

URL 保留项由前缀、主机名、端口和虚拟目录组成：

组成部分 | 说明
前缀 | 默认的前缀为 HTTP。如果以前安装过安全套接字层 (SSL) 证书，安装程序将尝试创建使用 HTTP 前缀的 URL 保留项。
主机名 | 默认主机名为强通配符 (+)。它指定对于解析为计算机的任何主机名，报表服务器均会接受指定端口上的任何 HTTP 请求，包括 http://<计算机名称>/reportserver、http://localhost/reportserver 或 http://<IP 地址>/reportserver。
端口 | 默认端口为 80。如果将 Reporting Services 安装在 32 位 Windows XP SP2 上，则默认端口为 8080。请注意，如果使用端口 80 以外的其他任何端口，则在浏览器窗口中打开 Reporting Services Web 应用程序时，必须将该端口显式添加至 URL 中。
虚拟目录 | 默认情况下，虚拟目录创建时的格式为 ReportServer_<实例名>（适用于报表服务器 Web 服务）和 Reports_<实例名>（适用于报表管理器）。对于报表服务器 Web 服务，默认的虚拟目录为 reportserver。对于报表管理器，默认的虚拟目录为 reports。

完整的 URL 字符串示例如下所示：

  • http://+:80/reportserver，用于访问报表服务器。

  • http://+:80/reports，用于访问报表管理器。

如何以本机模式默认配置安装报表服务器

可通过命令行或在安装向导中指定本机模式默认配置。以下主题提供分步说明：

  • 如何安装 SQL Server 2008（安装程序）.

  • 如何从命令提示符安装 SQL Server 2008.

命令行脚本示例

以下示例包括数据库引擎服务，因为默认配置需要此服务。

复制代码
setup /q /ACTION=install /FEATURES=SQL,RS,TOOLS /INSTANCENAME=MSSQLSERVER /SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS" /RSSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /SQLSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /AGTSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /RSSVCSTARTUPTYPE="Manual" /RSINSTALLMODE="DefaultNativeMode"

安装向导

在“功能选择”页中选择 Reporting Services 时，安装程序将提供可用于指定安装模式的 Reporting Services 配置页。若要指定默认本机模式安装，请在“Reporting Services 配置”页中选中“安装本机模式默认配置”。

请参阅

任务

如何验证 Reporting Services 安装

参考

设置 Windows 服务帐户

概念

配置报表服务器服务帐户
配置报表服务器 URL
配置报表服务器数据库连接
“仅文件”安装 (Reporting Services)
SharePoint 集成模式默认配置 (Reporting Services)
安装 Reporting Services 的注意事项
初始化报表服务器
配置报表服务器 URL
安装 Reporting Services 的注意事项
SQL Server 2008 安装快速入门

其他资源

配置报表服务器用于安全套接字层 (SSL) 连接
规划部署模式


SharePoint 集成模式默认配置 (Reporting Services)

SharePoint 集成模式默认配置 (Reporting Services) |
 | 请参阅
安装 SQL Server 2008 > 安装 Reporting Services 的注意事项 >

“SharePoint 集成模式默认配置”是指这样的 Reporting Services 安装，即安装程序安装和配置了报表服务器实例并以支持来自 SharePoint 站点的内容存储和寻址的格式创建了报表服务器数据库。

当选择 SharePoint 集成模式默认配置选项时，安装程序将安装以下 Reporting Services 功能：报表服务器服务、报表生成器、报表设计器预览、Reporting Services 配置工具和 Reporting Services 命令行实用工具（rsconfig.exe、rskeymgmt.exe 和 rs.exe）。此选项不适用于诸如 SQL Server Management Studio 或 Business Intelligence Development Studio 之类的共享功能。如果要安装此类功能，就必须将其指定为独立的项。

在安装程序中选择某个默认配置选项时，安装程序将以本机模式或 SharePoint 集成模式配置报表服务器。对于 SharePoint 集成模式的报表服务器，安装程序将配置以下内容：

  • 报表服务器服务的服务帐户。

  • 报表服务器 Web 服务 URL。

  • 报表管理器 URL。

  • 报表服务器数据库。

  • 服务帐户对报表服务器数据库的访问权限。

  • 与报表服务器数据库的 DSN 连接。

安装程序不会配置无人参与的执行帐户和报表服务器电子邮件，不会备份加密密钥或进行扩展部署。可以使用 Reporting Services 配置工具配置这些属性。有关详细信息，请参阅 Reporting Services 配置工具。

安装完成后，报表服务器可能还无法完全正常运行，因为它尚未与 SharePoint 场完全集成。您还必须安装 Reporting Services 外接程序，配置集成设置，并且如果要将报表服务器与跨多个服务器的 SharePoint 场相集成，则可能还要安装其他必备软件。有关详细信息，请参阅将 Reporting Services 配置为 SharePoint 3.0 集成模式。

何时安装 SharePoint 集成模式默认配置

此安装选项用于配置使报表服务器与 Windows SharePoint Services 或 Microsoft Office SharePoint Server 集成的报表服务器核心设置。在下列情况下可以指定此模式：

  • 希望通过省掉那些原本要在 Reporting Services 配置工具中执行的必要配置任务来减少配置步骤。必须有可供使用的 Reporting Services URL、数据库名称和虚拟目录的默认值。这些值必须唯一。如果该计算机上的另一个安装已经使用了这些值，则安装程序将无法使用它们来配置默认安装。

  • 您计划立即安装 Reporting Services 外接程序并在 SharePoint 站点上配置报表服务器集成设置。如果报表服务器为某个 SharePoint 场提供报表处理功能，则还必须在报表服务器计算机上安装 SharePoint Web 前端，以便可以将其联接到该场。有关详细信息，请参阅将 Reporting Services 配置为 SharePoint 3.0 集成模式。

要求

此安装选项的要求如下：

  • Reporting Services 和 SQL Server 数据库引擎必须共同安装在同一实例中。数据库引擎实例承载安装程序所创建和配置的报表服务器数据库。

  • 用于运行安装程序的用户帐户必须是本地计算机上的 Administrators 组成员，而且必须拥有访问和创建使用承载报表服务器数据库的数据库引擎实例的数据库的权限。

  • 安装程序必须能够使用默认值来保留用于访问报表服务器和报表管理器的 URL。这些值包括端口 80、强通配符和虚拟目录名（格式为 ReportServer_<instance_name> 和 Reports_<instance_name>）。

  • 安装程序必须能够使用默认值来创建报表服务器数据库。对于默认实例，这些值为 ReportServer 和 ReportServerTempDB。如果存在来自以前安装的数据库，安装程序将因无法配置报表服务器而被阻止。必须重命名、移动或删除这类数据库以取消阻止安装程序。

安装程序不会检查本地计算机上安装的 SharePoint 产品或技术，也不会安装 Reporting Services 外接程序或在 SharePoint 管理中心配置集成设置。您必须分别安装和配置这些应用程序。有关详细信息，请参阅将 Reporting Services 配置为 SharePoint 3.0 集成模式。

如果计算机未满足默认安装的这些要求，则必须在“仅文件”模式下安装 Reporting Services 并在安装完成后对其进行手动配置。可以使用 Reporting Services 配置工具配置 Reporting Services。

请不要仅为了使默认安装继续进行而试图对计算机进行重新配置。这样做可能需要好几个小时的工作量，实际上抵消了该安装选项所带来的省时优势。最佳的解决方案是在“仅文件”模式下安装 Reporting Services，然后将报表服务器配置为使用特定值。

默认 URL 保留项

URL 保留项由前缀、主机名、端口和虚拟目录组成：

组成部分 | 说明
前缀 | 默认的前缀为 HTTP。如果以前安装过安全套接字层 (SSL) 证书，安装程序将尝试创建使用 HTTP 前缀的 URL 保留项。
主机名 | 默认主机名为强通配符 (+)。它指定对于解析为计算机的任何主机名，报表服务器均会接受指定端口上的任何 HTTP 请求，包括 http://<计算机名称>/reportserver、http://localhost/reportserver 或 http://<IP 地址>/reportserver。
端口 | 默认端口为 80。如果将 Reporting Services 安装在 32 位 Windows XP SP2 上，则默认端口为 8080。请注意，如果使用端口 80 以外的其他任何端口，则在浏览器窗口中打开 Reporting Services Web 应用程序时，必须将该端口显式添加至 URL 中。
虚拟目录 | 默认情况下，虚拟目录创建时的格式为 ReportServer_<实例名>（适用于报表服务器 Web 服务）和 Reports_<实例名>（适用于报表管理器）。对于报表服务器 Web 服务，默认的虚拟目录为 reportserver。对于报表管理器，默认的虚拟目录为 reports。

完整的 URL 字符串示例如下所示：

URL 示例 说明

http://+:80/reportserver

用于访问报表服务器。

http://+:80/reports

用于访问报表管理器。

注意：
在 SharePoint 集成模式下，此 URL 会生成 rsOperationNotSupportedSharePointMode 错误消息，因为这种模式不支持报表管理器。在此模式下，所有内容管理和报表访问都应通过 SharePoint 而不是报表管理器进行处理。

如何以 SharePoint 集成模式默认配置安装报表服务器

您可以通过命令行或在安装向导中指定 SharePoint 模式默认配置。以下主题提供分步说明：

  • 如何安装 SQL Server 2008（安装程序）.

  • 如何从命令提示符安装 SQL Server 2008.

命令行脚本示例

该示例包括数据库引擎服务，这是因为默认配置需要此服务。

复制代码
setup /q /ACTION=install /FEATURES=SQL,RS,TOOLS /INSTANCENAME=MSSQLSERVER /SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS" /RSSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /SQLSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /AGTSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /RSSVCSTARTUPTYPE="Manual" /RSINSTALLMODE="DefaultSharePointMode"

安装向导

在“功能选择”页中选择 Reporting Services 时，安装程序将提供可用于指定安装模式的“Reporting Services 配置”页。若要指定 SharePoint 集成模式安装，请在“Reporting Services 配置”页中选择“安装 SharePoint 集成模式默认配置”。

请参阅

任务

如何验证 Reporting Services 安装

概念

配置报表服务器服务帐户
配置报表服务器 URL
配置报表服务器数据库连接
“仅文件”安装 (Reporting Services)
本机模式安装默认配置 (Reporting Services)
安装 Reporting Services 的注意事项

其他资源

部署 (Reporting Services)
规划部署模式
规划 SharePoint 集成
在 SharePoint 集成模式下运行 Reporting Services 的要求


“仅文件”安装 (Reporting Services)

“仅文件”安装 (Reporting Services) |
 | 请参阅
安装 SQL Server 2008 > 安装 Reporting Services 的注意事项 >

“仅文件”安装是指符合如下条件的 Reporting Services 安装：在该安装中安装程序将为 Reporting Services 程序文件创建文件夹结构、将文件复制到磁盘、在本地计算机上注册报表服务器服务、配置服务帐户、向服务帐户授予文件权限以及注册 Reporting Services WMI 提供程序。

“仅文件”安装包括以下 Reporting Services 功能：报表服务器服务（用来承载报表服务器 Web 服务、后台处理应用程序和报表管理器）、报表生成器、报表设计器预览、Reporting Services 配置工具和 Reporting Services 命令行实用工具（rsconfig.exe、rskeymgmt.exe 和 rs.exe）。它不适用于诸如 SQL Server Management Studio 或 Business Intelligence Development Studio 之类的共享功能。如果要安装此类功能，就必须将其指定为独立的项。

与其他安装模式不同，“仅文件”模式下安装的报表服务器在安装程序完成后不能正常工作。若要通过使用 Reporting Services 配置工具使报表服务器联机，则需要进行其他配置。

何时选择“仅文件”安装模式

在以下情况下必须执行“仅文件”安装：

  • 想要将报表服务器连接到远程报表服务器数据库。

  • 想要将报表服务器作为命名实例安装。

  • 需要部署自定义设置或功能，并且想要完全控制服务器配置的时间和方式。

  • 安装包括 Reporting Services 在内的 SQL Server 故障转移群集。

如何执行“仅文件”安装

“仅文件”安装是 Reporting Services 的默认设置。

可通过命令行或在安装向导中指定“仅文件”安装。以下主题提供分步说明：

  • 如何安装 SQL Server 2008（安装程序）.

  • 如何从命令提示符安装 SQL Server 2008.

命令行脚本示例

为清楚起见，该示例包括了 /RSINSTALLMODE="FilesOnlyMode"。但是，由于“仅文件”模式是默认模式，因此可将其省略且仍可进行“仅文件”模式安装。

复制代码
setup /q /ACTION=install /FEATURES=RS /InstanceName=MSSQLSERVER /RSSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /RSINSTALLMODE="FilesOnlyMode"

安装向导

在“功能选择”页中选择 Reporting Services 时，安装程序将提供可用于指定安装模式的“Reporting Services 配置”页。若要指定“仅文件”安装，请在“Reporting Services 配置”页上选择“安装但不配置报表服务器”。

请参阅

任务

如何验证 Reporting Services 安装

概念

配置报表服务器服务帐户
配置报表服务器 URL
配置报表服务器数据库连接
SharePoint 集成模式默认配置 (Reporting Services)
本机模式安装默认配置 (Reporting Services)
安装 Reporting Services 的注意事项

其他资源

部署 (Reporting Services)
升级 (Reporting Services)
Reporting Services 组件和工具


如何验证 Reporting Services 安装

如何验证 Reporting Services 安装 |
 | 请参阅
安装 SQL Server 2008 > 安装 Reporting Services 的注意事项 >

如果使用默认配置安装报表服务器，安装程序将安装并部署该服务器。可以执行几个简单的测试来验证安装程序是否部署了报表服务器。只有本地管理员才能执行这些步骤。若要让其他用户执行测试，必须为这些用户配置报表服务器访问权限。有关如何配置用户访问的详细信息，请参阅 SQL Server 联机丛书中的教程：在 Reporting Services 中设置权限。

注意：
Reporting Services 教程可帮助您快速学习重要技巧。还提供了介绍每个工具的教程。该教程说明了如何启动工具，并且向您展示第一次打开每个工具时各工具的外观。您可以使用此教程确认所有工具是否正确安装。有关详细信息，请参阅 SQL Server 联机丛书中的教程：如何查找并启动 Reporting Services 工具。

验证报表服务器已安装并正常运行

  • 运行 Reporting Services 配置工具，然后连接到您刚安装的报表服务器实例。“Web 服务 URL”页包括指向报表服务器 Web 服务的链接。单击该链接可验证您是否可以访问该服务器。如果未配置报表服务器数据库，请先进行配置，再单击该链接。

  • 打开“服务”控制台应用程序并验证报表服务器服务是否正在运行。若要查看报表服务器服务的状态，请单击“开始”，指向“控制面板”，双击“管理工具”，再双击“服务”。出现服务列表后，滚动到“报表服务器 (MSSQLSERVER)”。该服务的状态应为“已启动”。

  • 打开浏览器，在地址栏中键入报表服务器的 URL。该地址由安装过程中为报表服务器指定的服务器名称和虚拟目录名组成。默认情况下，报表服务器虚拟目录的名称为 ReportServer。可以使用以下 URL 验证报表服务器安装：http://<计算机名称>/ReportServer<_实例名>。如果将报表服务器安装为命名实例，URL 将有所不同。有关 URL 格式的详细信息，请参阅配置报表服务器 URL。如果您是 Windows Vista 或 Windows Server 2008 的本地管理员，请参阅如何在 Windows Vista 和 Windows Server 2008 上为本地管理配置报表服务器。

  • 运行报表以测试报表服务器的操作。对于此步骤，如果没有任何可用的报表，可以安装和发布示例报表。有关如何安装 Reporting Services 教程中所用的示例数据库、应用程序和数据文件的说明，请参阅 SQL Server 联机丛书中的初始安装 (Reporting Services)。

验证报表管理器已安装并正常运行

  • 打开浏览器，在地址栏中键入报表服务器的 URL。该地址由您在安装过程中或在 Reporting Services 配置工具的“报表管理器 URL”页中为报表管理器指定的服务器名称和虚拟目录名称组成。默认情况下，报表管理器虚拟目录的名称为 Reports。您可以使用以下 URL 验证报表管理器安装：http://<计算机名称>/Reports<_实例名>。

  • 使用报表管理器创建新文件夹或上载文件，以测试定义是否传回报表服务器数据库。如果上述操作成功，则表明连接正常。

验证报表设计器已安装并正常运行

  • 打开 Business Intelligence Development Studio，然后创建基于报表服务器项目类型的新项目。有关使用报表服务器项目向导的详细信息，请参阅 SQL Server 联机丛书中的如何创建报表服务器项目 (Reporting Services)。

  • 如果安装了报表示例，请打开示例报表项目文件并将报表发布到报表服务器。有关详细信息，请参阅 SQL Server 联机丛书中的发布模型。

请参阅

其他资源

HTTP 错误故障排除
配置错误故障排除
服务器和数据库连接故障排除
Reporting Services 错误的原因和解决方法


如何排除 Reporting Services 安装故障

如何排除 Reporting Services 安装故障 |
 | 请参阅
安装 SQL Server 2008 > 安装 Reporting Services 的注意事项 >

如果由于安装期间出现错误而导致无法安装 Reporting Services，请使用本主题中的说明来解决最有可能导致安装错误的情况。有关如何排除在配置用于操作的报表服务器时出现的安装后错误的说明，请参阅配置错误故障排除。

检查安装程序日志

安装程序错误记录在 Microsoft SQL Server\100\Setup Bootstrap\Log 文件夹内的日志文件中。每次运行安装程序时都会创建一个子文件夹。该子文件夹名称为您运行安装程序的时间和日期。该日志文件包括文件集合。打开 *_summary.txt 文件可查看产品、组件和实例信息。打开 *_errorlog.txt 文件可查看安装期间生成的错误信息。打开 *_RS_*_ComponentUpdateSetup.log 以查看 Reporting Services 安装程序信息。有关如何查看安装程序日志文件的说明，请参阅如何查看 SQL Server 安装日志文件。

检查系统必备条件

安装程序会自动检查系统必备条件。不过，如果要排除安装中的问题，则了解安装程序将检查哪些条件非常有用。

  • 运行安装程序的帐户要求包括本地 Administrators 组中的成员身份。安装程序必须具有添加文件的权限、注册表设置权限、创建本地安全组权限和设置权限。如果要在安装时采用默认配置，安装程序必须具有在所安装的 SQL Server 实例上创建报表服务器数据库的权限。

  • 操作系统必须支持 HTTP.SYS 1.1。也就是说您必须使用 Windows XP Service Pack 2 (SP2)、Windows Server 2003、Windows Vista 或 Windows Server 2008。

  • HTTP 服务必须已启用并正在运行。

  • 如果还要安装 SQL Server Agent 服务，则必须运行分布式事务处理协调器 (DTC)。

  • System32 文件夹中必须存在 Authz.dll。

安装程序不再检查 Internet Information Services (IIS) 或 ASP.NET。Reporting Services 需要 MDAC 2.0 和 Microsoft .NET Framework 2.0 版；如果尚未安装这些组件，则安装程序将会安装它们。

解决与默认配置相关的问题

Reporting Services 支持三种安装模式：本机模式默认配置、SharePoint 集成模式默认配置和“仅文件”模式。以默认配置安装 Reporting Services 时，必须满足更多要求才能使安装继续进行。如果无法选择此安装选项，请验证系统是否符合本机模式安装默认配置 (Reporting Services)中说明的所有要求。

如果无法解决有关要求的问题，请执行“仅文件”安装并使用 Reporting Services 配置工具来配置服务器。使用此工具的一个重要优点是：您可以单独配置每个设置并可分隔任何在配置期间出现的错误。有关详细信息，请参阅 Reporting Services 配置工具。

请参阅

概念

安装 Reporting Services 的注意事项

其他资源

故障排除概念 (Reporting Services)


安装 Integration Services 的注意事项

安装 Integration Services 的注意事项 |
 | 请参阅
安装 SQL Server 2008 >

SQL Server 提供了单个安装程序来安装其包括 Integration Services在内的任一组件或所有组件。通过安装程序，可在单台计算机上将 Integration Services 与 SQL Server 组件一起安装，也可以单独安装。

本主题重点介绍在安装 Integration Services 之前应了解的重要注意事项。本主题中的信息将帮助您评估安装选项，以便您做出适当选择使安装成功完成。

本主题不包括有关启动安装程序、使用安装向导或从命令行运行安装程序的说明。有关如何启动安装程序以及如何选择要安装的组件的分步说明，请参阅 SQL Server 2008 安装快速入门。有关用于安装 Integration Services 的命令行选项的信息，请参阅如何从命令提示符安装 SQL Server 2008。

准备安装 Integration Services

安装 Microsoft SQL Server Integration Services 之前，请首先查看以下要求：

  • 安装 SQL Server 2008 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

选择 Integration Services 配置

可按以下配置安装 SQL Server Integration Services：

  • 可以在没有 SQL Server 先前实例的计算机上安装 SQL Server Integration Services。

  • SQL Server 2008 Integration Services 可以与 SQL Server 2005 Integration Services 或 SQL Server 2000 Data Transformation Services (DTS) 或这两者的现有实例并行安装。

  • 可以将 SQL Server 2005 Integration Services 的现有实例升级至 SQL Server 2008 Integration Services。有关详细信息，请参阅升级 Integration Services 时的注意事项。有关与早期版本的 Integration Services 向后兼容的信息，请参阅 Integration Services 的向后兼容性

  • 可以将 SQL Server 2000 Data Transformation Services (DTS) 的现有实例升级至 SQL Server 2008 Integration Services。有关详细信息，请参阅升级 Data Transformation Services 时的注意事项。有关与 DTS 的向后兼容性的信息，请参阅支持 SQL Server 2008 中的 Data Transformation Services (DTS)。

安装 Integration Services

在查看 SQL Server 的安装要求并确保计算机满足这些要求之后，就可以安装 Integration Services 了。

如果使用安装向导安装 Integration Services，则将使用一系列页面来指定组件和选项。下表仅列出了安装向导中包含的选项在选中后会对 Integration Services 安装产生影响的页面：

页 建议

功能选择

选择 Integration Services 可安装 Integration Services 服务并可在设计环境之外运行包。

若要进行 Integration Services 以及用于开发和管理包的工具和文档的完整安装，请同时选择 Integration Services 及以下“共享功能”：

  • Business Intelligence Development Studio，以安装用于设计包的工具。

  • 管理工具 – 完成，以安装用于管理包的 SQL Server Management Studio。

  • “SQL Server 联机丛书”，以安装文档。

  • 客户端工具 SDK，以安装用于 Integration Services 编程的托管程序集。

若要对提取、转换和加载 (ETL) 进程使用专用服务器，建议您在安装 Integration Services 时安装 SQL Server 数据库引擎的本地实例。Integration Services 通常将包存储在数据库引擎实例中，并使用 SQL Server 代理对这些包进行计划。如果 ETL 服务器上没有数据库引擎实例，则必须通过具有数据库引擎实例的服务器计划或运行包。这表示这些包不会在 ETL 服务器上运行，而是在其启动时所在的服务器上运行。因此，专用 ETL 服务器的资源不会按预期方式使用。而且，其他服务器的资源可能会受到 ETL 进程运行的影响。

很多数据仓库解决方案还要求安装其他 SQL Server 组件，例如 SQL Server 数据库引擎、SQL Server Analysis Services 和 SQL Server Reporting Services。

注意：
如果选择了可在安装向导的“功能选择”页上选择进行安装某些 SQL Server 组件，则会安装 Integration Services 组件的部分子集。这些组件对特定任务是有用的，但 Integration Services 功能将受到限制。例如，“数据库引擎服务”选项将安装 SQL Server 导入和导出向导所需的 Integration Services 组件。Business Intelligence Development Tools (BIDS) 选项将安装在设计包时所需的 Integration Services 组件，但不会安装 Integration Services 服务，并且不能在 BI Development Studio 之外运行包。为确保完整安装 Integration Services，必须在“功能选择”页上选择 Integration Services。

实例配置

在“实例配置”页上做出的任何选择都不会影响 Integration Services 或 Integration Services 服务。

在一台计算机上只能安装一个 Integration Services 服务实例。可使用计算机名称连接到该服务。

默认情况下，Integration Services 服务将配置为管理存储在与 Integration Services 同时安装的数据库引擎实例的 msdb 数据库中的包。如果数据库引擎实例未与 Integration Services 同时安装，则 Integration Services 服务将配置为管理存储在本地默认数据库引擎实例的 msdb 数据库中的包。若要管理存储在数据库引擎的某个命名实例或远程实例中的包或存储在数据库引擎的多个实例中的包，必须修改配置文件。有关如何修改该配置文件的详细信息，请参阅配置 Integration Services 服务。

服务器配置

在“服务器配置”页的“服务帐户”选项卡上查看 Integration Services 服务的设置。

默认情况下，Integration Services 服务将注册为在内置 Network Service 帐户下运行，且“启动类型”为“自动”。您不必输入内置 Network Service 帐户的密码。

了解 Integration Services 服务

Integration Services 会安装 Integration Services 服务，这使您能够在 SQL Server Management Studio 中执行以下任务：

  • 在层次结构视图中管理 Integration Services 包和文件夹。包可以存储在数据库引擎实例中或文件系统中。

  • 监视在计算机上运行的 Integration Services 包的执行情况。

重要提示：
Integration Services 服务不是创建、保存和运行 Integration Services 包所必需的。

如果在“功能选择”页上选择 Integration Services 选项，则会安装 Integration Services 服务。如果接受“服务器配置”页上的默认设置，则会启用 Integration Services 服务，且“启动类型”为“自动”。

在一台计算机上只能安装一个 Integration Services 服务实例。该服务并不特定于具体的数据库引擎实例。可使用运行该服务的计算机的名称连接到该服务。

若要管理该服务，可使用 SQL Server 配置管理器，或通过打开“控制面板”中的“管理工具”，使用 Microsoft 管理控制台 (MMC) 的“服务”管理单元。有关详细信息，请参阅管理 Integration Services 服务。

默认情况下，Integration Services 服务将配置为管理存储在与 Integration Services 同时安装的数据库引擎实例的 msdb 数据库中的包。如果数据库引擎实例未与 Integration Services 同时安装，则 Integration Services 服务将配置为管理存储在本地默认数据库引擎实例的 msdb 数据库中的包。若要管理存储在数据库引擎的某个命名实例或远程实例中的包或存储在数据库引擎的多个实例中的包，必须修改配置文件。有关如何修改该配置文件的详细信息，请参阅配置 Integration Services 服务。

默认情况下，在全新安装中，Integration Services 配置为不将与运行包相关的事件记录到应用程序事件日志中。使用 SQL Server 2008 的数据收集器功能时，此设置可防止生成太多事件日志条目。未记录的事件包括 EventID 12288“包已启动”和 EventID 12289“包已成功完成”。若要将这些事件记录到应用程序事件日志中，请打开注册表以进行编辑。然后在注册表中找到 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\100\SSIS 节点，并将 LogPackageExecutionToEventLog 设置的 DWORD 值从 0 改为 1。

在 64 位计算机上安装 Integration Services

安装在 64 位计算机上的 Integration Services 功能

安装程序将根据您选择的安装选项安装各种 Integration Services 功能：

  • 安装 SQL Server 时，如果选择安装 Integration Services，安装程序将安装所有可用的 64 位 Integration Services 功能和工具。

  • 如果需要 Integration Services 设计时功能，还必须安装 Business Intelligence Development Studio。

  • 如果需要 32 位版本的 Integration Services 运行时和工具来以 32 位模式运行某些包，还必须安装 Business Intelligence Development Studio。

64 位功能安装在 Program Files 目录下，而 32 位功能单独安装在 Program Files (x86) 目录下。（这种行为并不特定于 Integration Services 或 SQL Server）。

重要提示：
Itanium 64 位操作系统不支持 Business Intelligence Development Studio（即 Integration Services 包的 32 位开发环境），因此不能将 Business Intelligence Development Studio 安装在 Itanium 服务器上。

有关详细信息，请参阅在 64 位计算机上使用 Integration Services 时的注意事项。

64 位计算机对 Data Transformation Services 的支持

不为 DTS 包提供 64 位设计时或运行时支持。在 64 位计算机上，DTS 包和运行 DTS 包的 Integration Services 包只能以 32 位模式运行。若要安装 32 位版本的 dtexec 实用工具 (dtexec.exe)，请确保在安装过程中选择“客户端工具”或 Business Intelligence Development Studio。

在基于 Itanium 的操作系统上，也不为 DTS 包提供 32 位设计时或运行时支持。因此，不能在基于 Itanium 的操作系统上创建、查看、修改或运行 DTS 包。

安装对 SQL Server 2000 Data Transformation Services 包的支持

SQL Server 2008 不会安装对 DTS 包的运行时支持。您必须先安装此运行时支持，才能运行和管理 DTS 包。有关如何安装 DTS 支持的信息，请参阅如何安装 Data Transformation Services 包的支持组件。

有关 SQL Server 2008 中的 DTS 支持的详细信息，请参阅支持 SQL Server 2008 中的 Data Transformation Services (DTS)。

请参阅

其他资源

在群集环境中配置 Integration Services


Integration Services 安装操作指南主题

Integration Services 安装操作指南主题 |
 | 请参阅
安装 SQL Server 2008 > 安装 Integration Services 的注意事项 >

本部分包含安装 Microsoft SQL Server Integration Services 所用的以下通用步骤。

有关从 Data Transformation Services (DTS) 升级的常用步骤，请参阅升级 Data Transformation Services 操作指南主题。有关迁移 DTS 包的常用步骤，请参阅迁移 Data Transformation Services 包操作指南主题。

重要提示：
本部分中的 Integration Services 安装操作指南主题只将重点放在特定于 Integration Services 的安装选项上，但提供了指向其他主题的链接，这些主题涉及 SQL Server 安装的其他信息。

本节内容

  • 如何安装 Data Transformation Services 包的支持组件

请参阅

概念

安装 Integration Services 的注意事项
如何从命令提示符安装 SQL Server 2008


如何安装 Data Transformation Services 包的支持组件

如何安装 Data Transformation Services 包的支持组件
安装 SQL Server 2008 > 安装 Integration Services 的注意事项 > Integration Services 安装操作指南主题 >

Data Transformation Services (DTS) 包可以继续与同一计算机上的 Integration Services 包一起运行。有关详细信息，请参阅支持 SQL Server 2008 中的 Data Transformation Services (DTS)。

若要与 Integration Services 包一起使用 DTS 包，可以按照以下几节中描述的方法安装运行时和设计时支持组件。

注意：
对于基于 Itanium 的操作系统，不提供对 DTS 包的设计时或运行时支持。因此，不能在基于 Itanium 的操作系统上创建、查看、修改或运行 DTS 包。

安装 DTS 包支持

如主题支持 SQL Server 2008 中的 Data Transformation Services (DTS) 所述，SQL Server 2008 中的 DTS 支持由多个组件组成。虽然安装程序可以安装其中某些组件，但要在安装 DTS 运行时支持之后，那些组件才能正常起作用。要在安装 Integration Services 时包括 DTS 支持所需的全部功能，必须按下述步骤完成多项安装。

安装所有支持 DTS 的功能

  1. 在安装过程中，在“功能选择”页上完成以下选择：

    1. 选择 Integration Services。

      此选项会安装 ActiveX Script 任务以及 DTS 包迁移向导。

    2. 选择“客户端工具向后兼容性”。

      此选项会安装“执行 DTS 2000 包”任务。

  2. 在安装程序运行完毕之后，按本主题后面的“在 32 位计算机上安装对 DTS 包的运行时支持组件”和“在 64 位计算机上安装对 DTS 包的运行时支持组件”等节中所述，安装 DTS 运行时。

  3. （可选）在安装程序运行完毕之后，按本主题后面的“安装 DTS 包设计时支持”一节所述，安装 DTS 设计器。

在 32 位计算机上安装对 DTS 包的运行时支持组件

SQL Server 2008 不会安装对 DTS 包的运行时支持组件。必须先按照以下过程中介绍的方法安装此运行时支持组件，然后才能运行和管理 DTS 包。

在 32 位计算机上安装对 Data Transformation Services (DTS) 包的运行时支持组件

  • 在用于安装 SQL Server 2008 的安装媒体上，找到并运行适用于操作系统的 SQLServer2005_BC*.msi Windows Installer 包。

    - 或者 -

  • 在 Internet 浏览器中打开 Microsoft SQL Server 2008 Feature Pack（Microsoft SQL Server 2008 功能包）页面，然后下载并安装Microsoft SQL Server 2005 向后兼容组件。

在 64 位计算机上安装对 DTS 包的运行时支持组件

不提供对 DTS 包的 64 位运行时支持。在 64 位计算机上，DTS 包和运行 DTS 包的 Integration Services 包只能以 32 位模式运行。若要以 32 位模式在 64 位计算机上的 BI Development Studio 的外部运行包，必须安装 32 位版本的 Integration Services 运行时和命令提示实用工具。

在 64 位计算机上安装 32 位版本的 Integration Services 运行时和命令提示实用工具

  • 在安装过程中，选择 Business Intelligence Development Studio 以安装 32 位版本的 Integration Services 运行时、dtexec 实用工具 (dtexec.exe) 和其他 Integration Services 工具。

安装 DTS 包的设计时支持组件

SQL Server 2008 不会安装对 DTS 包的设计时支持组件。必须先按照以下过程中介绍的方法下载并安装此设计时支持组件，然后才能使用 SQL Server 2008 工具打开并查看 DTS 包。

注意：
可以下载的 DTS 包设计器可与 SQL Server 2008 工具结合使用，但尚未针对 SQL Server 2008 更新设计器的功能。

安装 Data Transformation Services 包的设计时支持组件

  • 在 Internet 浏览器中打开 Feature Pack for Microsoft SQL Server 2005（Microsoft SQL Server 2005 功能包）网页，然后下载并安装 Microsoft SQL Server 2000 DTS 设计器组件。

默认情况下，SQL Server 2000 二进制文件位于 %ProgramFiles%\Microsoft SQL Server\80\Tools\Binn 文件夹中，而 SQL Server 2008 二进制文件位于 %ProgramFiles%\Microsoft SQL Server\100\Tools\Binn 文件夹中。这些默认位置可能会导致 SQL Server 2000 二进制文件路径在 PATH 环境变量中所出现的位置位于 SQL Server 2008 二进制文件路径的前面。如果出现这种情况，则在您尝试使用 DTS 设计器时会显示一条错误消息。若要纠正此错误，请按照以下过程中介绍的方法将设计器所需的文件复制到新的位置。

确保可以在 SQL Server Management Studio 中使用 DTS 设计器

  1. 将 SEMSFC.DLL、SQLGUI.DLL 和 SQLSVC.DLL 文件从 %ProgramFiles%\Microsoft SQL Server\80\Tools\Binn 文件夹复制到 %ProgramFiles%\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE 文件夹中。

  2. 将 SEMSFC.RLL、SQLGUI.RLL 和 SQLSVC.RLL 文件从 %ProgramFiles%\Microsoft SQL Server\80\Tools\Binn\Resources 文件夹复制到 %ProgramFiles%\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\Resources 文件夹中。

确保可以在 Business Intelligence Development Studio 中使用 DTS 设计器

  1. 将 SEMSFC.DLL、SQLGUI.DLL 和 SQLSVC.DLL 文件从 %ProgramFiles%\Microsoft SQL Server\80\Tools\Binn 文件夹复制到 %ProgramFiles%\Microsoft Visual Studio 9.0\Common7\IDE 文件夹中。

  2. 将 SEMSFC.RLL、SQLGUI.RLL 和 SQLSVC.RLL 文件从 %ProgramFiles%\Microsoft SQL Server\80\Tools\Binn\Resources 文件夹复制到 %ProgramFiles%\Microsoft Visual Studio 9.0\Common7\IDE\Resources 文件夹中。


安装 SQL Server 复制的注意事项

安装 SQL Server 复制的注意事项 |
 | 请参阅
安装 SQL Server 2008 >

可以使用 SQL Server 安装向导或通过命令提示符安装复制组件。请在安装 SQL Server 或修改现有实例时安装复制组件。

安装复制组件后，必须配置服务器才可以使用复制。有关详细信息，请参阅 SQL Server 联机丛书中的设计和实现（复制）。

重要提示：
如果在修改 SQL Server 的现有实例时安装复制组件，则在安装完成后必须停止并重新启动 SQL Server 代理。此操作可帮助确保 SQL Server 代理能够识别复制代理子系统，并且可以在作业步骤中调用复制代理。

使用安装程序安装复制

在安装 SQL Server 的新实例时安装复制

  • 若要安装包括复制管理对象 (RMO) 在内的复制组件，请在安装向导的“功能选择”页上选择“SQL Server 复制”。

从命令提示符安装复制

在安装 SQL Server 的新实例时安装复制

  • 请参阅如何从命令提示符安装 SQL Server 2008。

请参阅

概念

安装 SQL Server 2008
如何从命令提示符安装 SQL Server 2008
SQL Server 2008 各个版本支持的功能


安装 SQL Server 管理工具的注意事项

安装 SQL Server 管理工具的注意事项 |
 | 请参阅
安装 SQL Server 2008 >

SQL Server 管理工具包括以下组件：

  • SQL Server Management Studio

  • SQL Server Profiler

  • SQL Server 数据库优化顾问

  • 命令提示符工具，如 sqlcmd.exe 和 osql.exe。

  • Microsoft Visual Studio 的 Business Intelligence Development Studio 外接程序

请注意，Business Intelligence Development Studio 是 SQL Server 安装期间的一个单独选项。

无论计算机上安装了多少 SQL Server、Analysis Services 或 Reporting Services 实例，都只能安装 SQL Server 2008 管理工具的一个副本。

SQL Server 2008 管理工具可与早期版本的 SQL Server 管理工具在同一台计算机上并行运行。

请参阅

任务

如何安装 SQL Server 2008（安装程序）
如何升级到 SQL Server 2008（安装程序）

参考

SQL Server 2008 的版本和组件


安装 SQL Server 示例和示例数据库的注意事项

安装 SQL Server 示例和示例数据库的注意事项 |
 | 请参阅
安装 SQL Server 2008 >

SQL Server 的代码示例和示例数据库不再随产品一起提供。但可以从位于 http://www.codeplex.com/sqlserversamples 的 Microsoft SQL Server Samples and Community Projects（Microsoft SQL Server 示例和社区项目）网站中查找并下载这些示例和示例数据库。在按技术编排的表中，有指向 SQL Server 组件示例和正式 SQL Server 示例数据库的超链接。这些表上还有指向 SQL Server 社区中提供的示例和项目的链接。

安装示例和示例数据库

若要安装整个产品示例集，请在 Microsoft SQL Server Samples and Community Projects（Microsoft SQL Server 示例和社区项目）主页上单击 Releases（版本）选项卡。请注意，每个项目的默认版本都为最新版本。默认版本有可能是 community technology preview 版本。若要选择某个先前版本，请在 Release（版本）窗格中单击该版本名。

在 CodePlex 上，您可以通过单击位于 http://www.codeplex.com/sqlserversamples 的 Microsoft SQL Server Samples and Community Projects（Microsoft SQL Server 示例和社区项目）主页的技术领域表中所需技术的链接，为 SQL Server 技术领域（Analysis Services、数据库引擎、数据可编程性等等）的产品示例查找特定项目。在每个特定项目中，单击 Releases（版本）选项卡，然后单击 Windows Installer 包下载该技术领域的示例集。若要查看该技术领域的示例代码，单击 Source Code（源代码）选项卡，然后单击 Browse（浏览）列中的文件夹图标。

注意：
如果您选择安装示例，则默认情况下，示例文件的安装位置为：C:\Program Files\Microsoft SQL Server\100\Samples\<technology_name>。

若要安装 SQL Server 的正式示例数据库，请访问 http://www.CodePlex.com/MSFTDBProdSamples，或者在 Microsoft SQL Server Samples and Community Projects（Microsoft SQL Server 示例和社区项目）主页的 Sample Databases（示例数据库）部分中，单击 Download（下载）链接并选择所需数据库。

提供反馈

Http://connect.microsoft.com 和 CodePlex 提供了报告与各技术领域示例有关的问题以及进行相关提问的直接途径。若要报告问题并查看已报告问题的状态，请在 Http://connect.microsoft.com 中记录相应的 bug。若要讨论有关示例的各种想法、提供与现有示例有关的反馈或询问与示例有关的问题，请单击 Http://Connect.Microsoft.com/SqlServerSamples 中的 Discussions（讨论）选项卡或其中一个相关项目。请不要使用 CodePlex 上的 Issues（问题）选项卡报告示例缺陷。

更新 .NET Framework CLR 示例的位置

在您编译 SQL Server 的 Microsoft .NET Framework 公共语言进行时 (CLR) 示例之前，请验证 .NET Framework 编译器的版本路径是否为 PATH 环境变量中的第一个 Framework 目录。该 SQL Server 版本附带的编译器的位置为 C:\<Windows 根目录>\Microsoft.NET\Framework\v2.0.x。驱动器 C 为安装驱动器，<Windows 根目录> 为 Windows 或 WINNT，x 为五位数。

请参阅

概念

系统和示例数据库


安装操作指南主题

安装操作指南主题 |
 | 请参阅
安装 SQL Server 2008 >

请按照以下主题中的说明安装 SQL Server 2008。

本节内容

主题 | 说明
如何安装 SQL Server 2008（安装程序） | 介绍如何通过使用安装向导进行 SQL Server 典型安装的过程主题。
如何从命令提示符安装 SQL Server 2008 | 提供运行无人参与安装的示例语法和安装参数的过程主题。
如何向 SQL Server 2008 的实例添加功能（安装程序） | 介绍如何更新现有 SQL Server 2008 实例的过程主题。

请参阅

概念

计划 SQL Server 安装
升级到 SQL Server 2008


如何安装 SQL Server 2008（安装程序）

如何安装 SQL Server 2008（安装程序） |
 | 请参阅
安装 SQL Server 2008 > 安装操作指南主题 >

SQL Server 安装向导基于 Windows Installer。它提供了一个用来安装所有 SQL Server 组件的功能树，因此您不必逐个安装以下组件：

  • 数据库引擎

  • Analysis Services

  • Reporting Services

  • Integration Services

  • 复制

  • 管理工具

  • 连接组件

  • 示例数据库、示例和 SQL Server 联机丛书

以下附加主题介绍了 SQL Server 2008 的其他安装方法：

  • 如何从命令提示符安装 SQL Server 2008.

  • 如何创建新的 SQL Server 故障转移群集（安装程序）.

  • 如何升级到 SQL Server 2008（安装程序）.

必备项

安装 SQL Server 前，请查阅计划 SQL Server 安装中的主题。

注意：
对于本地安装，必须以管理员身份运行安装程序。如果从远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。

安装 SQL Server 2008

  1. 插入 SQL Server 安装媒体。然后双击根文件夹中的 setup.exe。若要从网络共享进行安装，请找到共享中的根文件夹，然后双击 setup.exe。

  2. 如果出现 Microsoft .NET Framework 2.0 版 安装对话框，则选中相应的复选框以接受 .NET Framework 2.0 许可协议。单击“下一步”。若要退出 SQL Server 2008 安装过程，请单击“取消”。当 .NET Framework 2.0 的安装完成后，请单击“完成”。

  3. Windows Installer 4.5 也是必需的，并且可以由安装向导进行安装。如果系统提示您重新启动计算机，则重新启动计算机，然后重新启动 SQL Server 2008 setup.exe。

  4. 必备组件安装完成后，安装向导会运行 SQL Server 安装中心。若要创建 SQL Server 2008 的全新安装，请单击“全新安装或向现有安装添加功能”。

  5. 系统配置检查器将在您的计算机上运行发现操作。若要继续，请单击“确定”。系统已经为您的安装创建了安装日志文件。有关详细信息，请参阅如何查看 SQL Server 安装日志文件。

  6. 在“产品密钥”页上，选择相应的单选按钮，这些按钮指示您是安装免费版本的 SQL Server，还是安装具有 PID 密钥的产品的生产版本。有关详细信息，请参阅 SQL Server 2008 的版本和组件。

  7. 在“许可条款”页上阅读许可协议，然后选中相应的复选框以接受许可条款和条件。

  8. 如果计算机上尚未安装 SQL Server 必备组件，则安装向导将安装它们。其中包括：

    • .NET Framework 2.0

    • SQL Server Native Client

    • SQL Server 安装程序支持文件

    若要安装必备组件，请单击“安装”。

  9. 系统配置检查器将在安装继续之前检验计算机的系统状态。

  10. 在“功能选择”页上选择要安装的组件。选择功能名称后，右侧窗格中会显示每个组件组的说明。您可以选中任意一些复选框。有关详细信息，请参阅 SQL Server 2008 的版本和组件。

    您还可以使用“功能选择”页底部的字段为共享组件指定自定义目录。若要更改共享组件的安装路径，请更新该对话框底部字段中的路径名，或单击“浏览”导航到另一个安装目录。默认安装路径为 C:\Program Files\Microsoft SQL Server\100\。

  11. 在“实例配置”页上指定是安装默认实例还是命名实例。有关详细信息，请参阅实例配置。若要继续，请单击“下一步”。

    实例 ID 后缀 - 默认情况下，使用实例名称作为实例 ID 的后缀。这用于标识 SQL Server 实例的安装目录和注册表项。默认实例和命名实例的默认方式都是如此。对于默认实例，实例名称和实例 ID 后缀均为 MSSQLSERVER。若要使用非默认的实例 ID 后缀，请选中“实例 ID 后缀”复选框，并提供一个值。

    注意：
    典型的 SQL Server 2008 独立实例（无论是默认实例还是命名实例）不会对“实例 ID 后缀”复选框使用非默认值。

    实例根目录 - 默认情况下，实例根目录为 C:\Program Files\Microsoft SQL Server\100\。若要指定一个非默认的根目录，请使用所提供的字段，或单击“浏览”以找到一个安装文件夹。

    所有 SQL Server Service Pack 和升级都将应用于 SQL Server 实例的每个组件。

    检测到的实例和功能 - 该网格将显示运行安装程序的计算机上的 SQL Server 实例。如果计算机上已经安装了一个默认实例，则必须安装 SQL Server 2008 的命名实例。

  12. “磁盘空间要求”页计算指定的功能所需的磁盘空间，然后将所需空间与可用磁盘空间进行比较。有关详细信息，请参阅磁盘成本摘要。

  13. 本主题中的其余工作流取决于要安装的功能。您可能不会看到所有的页面，具体取决于您进行的选择。

  14. 在“服务器配置 - 服务帐户”页上指定 SQL Server 服务的登录帐户。此页上配置的实际服务取决于您选择安装的功能。

    可以为所有 SQL Server 服务分配相同的登录帐户，也可以分别配置每个服务帐户。还可以指定服务是自动启动、手动启动还是禁用。Microsoft 建议对各服务帐户进行单独配置，以便为每项服务提供最低特权，即向 SQL Server 服务授予它们完成各自任务所需的最低权限。有关详细信息，请参阅SQL Server 配置 - 服务帐户和设置 Windows 服务帐户。

    若要为此 SQL Server 实例中的所有服务帐户指定相同的登录帐户，请在页面底部的字段中提供凭据。

    安全说明 不要使用空密码。请使用强密码。

    为 SQL Server 服务指定登录信息后，请单击“下一步”。

  15. 使用“服务器配置 - 排序规则”选项卡为数据库引擎和 Analysis Services 指定非默认的排序规则。有关详细信息，请参阅 SQL Server 配置 - 排序规则。

  16. 使用“数据库引擎配置 - 帐户设置”页指定以下各项：

    • 安全模式 - 为 SQL Server 实例选择 Windows 身份验证或混合模式身份验证。如果选择“混合模式身份验证”，则必须为内置 SQL Server 系统管理员帐户提供一个强密码。

      在设备与 SQL Server 成功建立连接之后，用于 Windows 身份验证和混合模式身份验证的安全机制是相同的。有关详细信息，请参阅数据库引擎配置 - 帐户设置。

    • SQL Server 管理员 - 必须至少为 SQL Server 实例指定一个系统管理员。若要添加用以运行 SQL Server 安装程序的帐户，请单击“添加当前用户”。若要向系统管理员列表中添加帐户或从中删除帐户，请单击“添加”或“删除”，然后编辑将拥有 SQL Server 实例的管理员特权的用户、组或计算机的列表。有关详细信息，请参阅数据库引擎配置 - 帐户设置。

    完成对该列表的编辑后，请单击“确定”。验证配置对话框中的管理员列表。完成此列表后，请单击“下一步”。

  17. 使用“数据库引擎配置 - 数据目录”页指定非默认的安装目录。若要安装到默认目录，请单击“下一步”。

    重要提示：
    如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。

    有关详细信息，请参阅数据库引擎配置 - 数据目录。

  18. 使用“数据库引擎配置 - FILESTREAM”页对 SQL Server 实例启用 FILESTREAM。有关详细信息，请参阅数据库引擎配置 - 文件流。

  19. 使用“Analysis Services 配置 – 帐户设置”页指定将拥有 Analysis Services 的管理员权限的用户或帐户。您必须为 Analysis Services 至少指定一个系统管理员。若要添加用以运行 SQL Server 安装程序的帐户，请单击“添加当前用户”。若要向系统管理员列表中添加帐户或从中删除帐户，请单击“添加”或“删除”，然后编辑将拥有 Analysis Services 的管理员特权的用户、组或计算机的列表。有关详细信息，请参阅 Analysis Services 配置 – 帐户设置。

    完成对该列表的编辑后，请单击“确定”。验证配置对话框中的管理员列表。完成此列表后，请单击“下一步”。

  20. 使用“Analysis Services 配置 - 数据目录”页指定非默认的安装目录。若要安装到默认目录，请单击“下一步”。

    重要提示：
    如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。

    有关详细信息，请参阅 Analysis Services 配置 - 数据目录。

  21. 使用“Reporting Services 配置”页指定要创建的 Reporting Services 安装的类型。包括以下选项：

    • 本机模式默认配置

    • SharePoint 模式默认配置

    • 未配置的 Reporting Services 安装

    有关 Reporting Services 配置模式的详细信息，请参阅报表服务器安装选项。

  22. 在“错误和使用情况报告”页上指定要发送到 Microsoft 以帮助改善 SQL Server 的信息。默认情况下，用于错误报告和功能使用情况的选项处于启用状态。有关详细信息，请参阅错误和使用情况报告设置。

  23. 系统配置检查器将再运行一组规则来针对您指定的 SQL Server 功能验证您的计算机配置。

  24. “准备安装”页显示您在安装过程中指定的安装选项的树视图。若要继续，请单击“安装”。

  25. 在安装过程中，“安装进度”页会提供相应的状态，因此您可以在安装过程中监视安装进度。

  26. 安装完成后，“完成”页会提供指向安装日志文件摘要以及其他重要说明的链接。若要完成 SQL Server 安装过程，请单击“关闭”。

  27. 如果安装程序指示您重新启动计算机，请立即重新启动。安装完成后，请务必阅读来自安装向导的消息。有关详细信息，请参阅如何查看 SQL Server 安装日志文件。

后续步骤

配置新安装的 SQL Server

  • 为了减少系统的可攻击外围应用，SQL Server 将有选择地安装和激活一些密钥服务和功能。有关详细信息，请参阅 MSDN 上的 Understanding Surface Area Configuration（了解外围应用配置器）。

  • 有关使用图形工具和命令提示符实用工具的详细信息，请参阅配置 SQL Server 2008。

请参阅

任务

如何升级到 SQL Server 2008（安装程序）

概念

如何查看 SQL Server 安装日志文件
如何从命令提示符安装 SQL Server 2008


如何从命令提示符安装 SQL Server 2008

如何从命令提示符安装 SQL Server 2008 |
 | 请参阅
安装 SQL Server 2008 > 安装操作指南主题 >

运行 SQL Server 安装程序之前，请先查看计划 SQL Server 安装。

通过从命令提示符安装 SQL Server 的新实例，您可以指定要安装的功能以及如何配置这些功能。还可以指定与安装用户界面是进行静默交互、基本交互还是完全交互。

在以下情况下支持命令提示符安装：

  • 利用在命令提示符下指定的语法和参数，在本地计算机上安装、升级或删除 SQL Server 2008 实例和共享组件。

  • 安装、升级或删除故障转移群集实例。

  • 从 SQL Server 2008 的一个版本升级到 SQL Server 2008 的另一个版本。

  • 利用在配置文件中指定的语法和参数，在本地计算机上安装 SQL Server 2008 的实例。可以使用此方法将安装配置复制到多台计算机，或者安装故障转移群集安装的多个节点。

从命令提示符安装 SQL Server 时，请在命令提示符下指定安装参数，以作为安装语法的一部分。

注意：
对于本地安装，必须以管理员身份运行安装程序。如果从远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。对于故障转移群集安装，您必须是本地管理员，并且有权作为服务登录并有权在所有故障转移群集节点上作为操作系统的一部分工作。

正确使用安装参数

若要编写语法正确的安装命令，请遵循以下准则：

复制代码
/PARAMETER
/PARAMETER=true/false

一个例外是 /FEATURES，它是一个多值参数，但其格式为

  • /FEATURES=AS,RS,IS，无空格，以逗号分隔

请注意转义字符的使用：

  • 支持 /INSTANCEDIR=c:\PathName。

  • 支持 /INSTANCEDIR=c:\PathName\。

  • 支持 /INSTANCEDIR="c:\PathName\\"。

  • 不支持 /INSTANCEDIR="c:\PathName\"。

示例语法

可以使用以下示例脚本在命令提示符处安装 SQL Server 组件。这些脚本提供典型用户方案中安装 SQL Server 的命令提示符语法。请根据您所在单位的需要测试并修改这些示例。

支持的安装参数用法

参数用法

基本安装方案（包括数据库引擎服务和管理工具）

基本安装方案的安装脚本

故障转移群集安装方案

故障转移群集方案的安装脚本

Analysis Services 安装方案

Analysis Services 安装方案的安装脚本

Reporting Services 安装方案

Reporting Services 的安装选项和脚本

Integration Services 安装方案

Analysis Services 安装方案的安装脚本

安装参数的参考文档

安装参数

比较各 SQL Server 版本的安装参数

以前 SQL Server 版本的参数

基本安装方案的安装脚本

请根据您所在单位的需要测试并修改以下安装脚本。

安装新的具有所有 SQL Server 组件的独立实例。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    Setup.exe /q /ACTION=Install /FEATURES=SQL,AS,RS,IS,Tools,BIDS,BOL /INSTANCENAME=MSSQLSERVER /SECURITYMODE=SQL /SQLSYSADMINACCOUNTS="Builtin\Administrators" /SAPWD="StrongPassword" /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="StrongPassword" /AGTSVCACCOUNT="DomainName\UserName" /AGTSVCPASSWORD="StrongPassword" /ASSYSADMINACCOUNTS="Builtin\Administrators" /ASSVCACCOUNT="DomainName\UserName" /ASSVCPASSWORD="StrongPassword" /RSSVCACCOUNT="DomainName\UserName" /RSSVCPASSWORD="StrongPassword" /SQLBROWSERACCOUNT="DomainName\UserName" /SQLBROWSERPASSWORD="StrongPassword" /ISSVCACCOUNT="NT Authority\Network Service"
    重要提示：
    不要使用空密码。请使用强密码。

    注意：
    如果是默认实例，请为 /INSTANCENAME 参数指定“MSSQLSERVER”。如果是命名实例，请指定实例名。

    有关服务帐户配置的详细信息，请参阅设置 Windows 服务帐户。有关日志文件的详细信息，请参阅如何查看 SQL Server 安装日志文件。
安装新的具有 SQL Server 数据库引擎、复制和全文搜索组件的独立实例。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    Setup.exe /q /ACTION=Install /FEATURES=SQL /INSTANCENAME=MSSQLSERVER /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="StrongPassword" /SQLSYSADMINACCOUNTS="DomainName\UserName" /AGTSVCACCOUNT="NT AUTHORITY\Network Service"

重要提示 不要使用空密码。请使用强密码。

注意：
如果是默认实例，请为 /INSTANCENAME 参数指定“MSSQLSERVER”。如果是命名实例，请指定实例名。

 仅安装 SQL Server 管理工具。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    Setup.exe /Action=Install /FEATURES=Tools
安装 SQL Server Express。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    Setup.exe /q /FEATURES=SQL_Tools /INSTANCE=Express /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="StrongPassword" /SQLSYSADMINACCOUNTS="BUILTIN\Administrators"
Use the /ENABLERANU parameter to enable RANU
Use the /ADDCURRENTUSERASSQLADMIN parameter to provision the user in the sysadmin role.
从 SQL Server 2000 或 SQL Server 2005 升级现有实例或故障转移群集节点。

  1. 开始之前，请先查看使用升级顾问来准备升级和向后兼容性中的升级文档。不必指定要升级的功能。

  2. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  3. 在命令提示符下运行以下命令：

    复制代码
    Setup.exe /q /ACTION=upgrade /INSTANCENAME=MSSQLSERVER /SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS" /RSUPGRADEDATABASEACCOUNT="<Provide a SQL Server logon account that can connect to the report server during upgrade>" /RSUPGRADEPASSWORD="<Provide a password for the report server upgrade account>"/ISSVCAccount="NT Authority\Network Service"

    如果要升级故障转移群集实例的某个节点，请使用 /FAILOVERCLUSTERROLLOWNERSHIP 参数控制在升级操作使此节点脱机之前的故障转移行为。此参数的用法如下所示：

    • /FAILOVERCLUSTERROLLOWNERSHIP=0 不会将群集所有权滚动到升级后的节点，并且在升级结束时不会将此节点添加到 SQL Server 群集的可能所有者列表中。

    • /FAILOVERCLUSTERROLLOWNERSHIP=1 将群集所有权滚动到升级后的节点，并且在升级结束时会将此节点添加到 SQL Server 群集的可能所有者列表中。

    • /FAILOVERCLUSTERROLLOWNERSHIP=2 是默认设置。如果未指定此参数，将使用该默认设置。此设置表示 SQL Server 安装程序将根据需要管理群集所有权。

  4. 若要仅升级共享组件，请在命令提示符下运行以下命令：

    复制代码
    Setup.exe /q /ACTION=upgrade

重要提示 不要使用空密码。请使用强密码。

注意：
如果是默认实例，请为 /INSTANCENAME 参数指定“MSSQLSERVER”。如果是命名实例，请指定实例名。

 将 SQL Server 2008 的现有实例升级到另一版本的 SQL Server 2008。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    Setup.exe /q /ACTION=editionupgrade /INSTANCENAME=MSSQLSERVER /PID=<PID key for new edition>"

重要提示 不要使用空密码。请使用强密码。

注意：
如果是默认实例，请为 /INSTANCENAME 参数指定“MSSQLSERVER”。如果是命名实例，请指定实例名。如果未指定实例名称，将仅升级共享组件。

 使用配置文件安装 SQL Server 2008。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    Setup.exe /q /ACTION=Install /Configurationfile=<path to ConfigurationFile.ini file>

    运行 SQL Server 2008 安装程序后，将生成一个配置文件，此配置文件默认保存为 <drive>:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\<YYYYMMDD_HHMMSS\ConfigurationFile.ini。打开此文件可看到安装参数的说明以及已完成的安装的设置。可以使用配置文件复制其他实例，或者安装故障转移群集安装的其他节点。

    有关日志文件的详细信息，请参阅如何查看 SQL Server 安装日志文件。

向现有 SQL Server 实例中添加组件。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    Setup.exe /q /ACTION=Install /INSTANCENAME=MSSQLSERVER /FEATURES=<Feature list>

    注意 若要向命名实例添加功能，请使用实例名称，而不是以上示例中的“MSSQLSERVER”。
卸载现有 SQL Server 实例。

  1. 将 SQL Server 安装媒体插入磁盘驱动器。

  2. 在命令提示符下导航到以下目录：%Program Files%\Microsoft SQL Server\100\Setup Bootstrap，然后在命令提示符下键入以下命令：

    复制代码
    Setup100.exe /Action=Uninstall /FEATURES=SQL,AS,RS,IS,Tools /INSTANCENAME=MSSQLSERVER

    注意 若要删除命名实例，请使用实例名称，而不是以上示例中的“MSSQLSERVER”。

故障转移群集安装方案的安装脚本

SQL Server 故障转移群集安装有以下两个选项：

  • 集成安装，只需一步即可安装并配置一个单节点故障转移群集实例。

  • 高级安装（也称为 Enterprise 安装），包含以下 2 个步骤：准备故障转移群集实例，然后完成安装以创建单节点故障转移群集实例。

安装 SQL Server 故障转移群集实例之前，请先查看以下主题：

  • 安装 SQL Server 2008 的硬件和软件要求

  • 安装 SQL Server 的安全注意事项

  • 安装故障转移群集前的准备工作

    重要提示：
    所有故障转移群集安装命令都需要使用一个基础 Windows 群集。所有将要加入 SQL Server 故障转移群集的节点都必须属于同一 Windows 群集的一部分。

请根据您所在单位的需要测试并修改以下故障转移群集安装脚本。

安装带数据库引擎的集成式单节点 SQL Server 故障转移群集。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=InstallFailoverCluster /FEATURES=SQL /INSTANCENAME="<Insert Instance Name>" [/INSTANCEIDSUFFIX="<Insert InstanceID Suffix>"] /INSTANCEDIR="C:\Program Files\Microsoft SQL Server" /INSTALLSHAREDDIR="C:\Program Files\Microsoft SQL Server" /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="XXXXXX" /AGTSVCACCOUNT="DomainName\UserName" /AGTSVCPASSWORD="XXXXXX" /SQLDOMAINGROUP="DomainName\DomainGroup" /INSTALLSQLDATADIR="<Drive>:\<Path>\MSSQLSERVER" /SQLCOLLATION="CollationName"; default is SQL_Latin1_General_CP1_CS_AS" /FAILOVERCLUSTERGROUP="<Insert new Cluster Group name>" /FAILOVERCLUSTERDISKS="<Cluster Disk Resource Name - for example, 'Disk S:'" /FAILOVERCLUSTERIPADDRESSES="IPv4;XXX.XXX.XXX.XXX;Local Area Connection;xxx.xxx.xxx.x" /FAILOVERCLUSTERNETWORKNAME="<Insert Failover Cluster Instance Name>" /SQLSYSADMINACCOUNTS=" DomainName\UserName " [/SECURITYMODE=SQL /SAPWD="StrongPassword"]
安装带 Analysis Services 的单节点 SQL Server 故障转移群集。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=InstallFailoverCluster /FEATURES=AS /INSTANCENAME="<Insert Instance Name>" [/INSTANCEIDSUFFIX="<Insert InstanceID Suffix>"] /ASSYSADMINACCOUNTS="DomainName\UserName" /ASSVCACCOUNT="DomainName\UserName" /ASSVCPASSWORD="xxxxx" /ASDOMAINGROUP="DomainName\DomainGroup" /ASDATADIR="<Drive>:\Data" /ASLOGDIR="<Drive>:\Log" /ASBACKUPDIR="<Drive>:\Backup" /ASCONFIGDIR="<Drive>:\Config" /ASTEMPDIR="<Drive>:\Temp" /FAILOVERCLUSTERGROUP="<Insert new Cluster Group name>" /FAILOVERCLUSTERDISKS="<Drive>:" /FAILOVERCLUSTERIPADDRESSES="IPv4; xxx.xxx.xxx.xxx;Local Area Connection;xxx.xxx.xxx.x" /FAILOVERCLUSTERNETWORKNAME="<Insert Failover Cluster Instance Name>" /INDICATEPROGRESS
安装带数据库引擎和 Analysis Services 的单节点 SQL Server 故障转移群集实例（默认实例）。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=InstallFailoverCluster /InstanceName=MSSQLSERVER /INDICATEPROGRESS /ASSYSADMINACCOUNTS="DomainName\UserName" /ASDATADIR=<Drive>:\OLAP\Data /ASLOGDIR=<Drive>:\OLAP\Log /ASBACKUPDIR=<Drive>:\OLAP\Backup /ASCONFIGDIR=<Drive>:\OLAP\Config /ASTEMPDIR=<Drive>:\OLAP\Temp /FAILOVERCLUSTERDISKS="<Cluster Disk Resource Name - e.g., 'Disk S:'" /FAILOVERCLUSTERNETWORKNAME="<Insert Network Name>" /FAILOVERCLUSTERIPADDRESSES="IPv4;xx.xxx.xx.xx;Local Area Connection;xxx.xxx.xxx.x" /FAILOVERCLUSTERGROUP="MSSQLSERVER" /Features=AS,SQL /ASSVCACCOUNT="DomainName\UserName" /ASSVCPASSWORD="xxxxxxxxxxx" /ASDOMAINGROUP="DomainName\DomainGroup" /AGTSVCACCOUNT="DomainName\UserName" /AGTSVCPASSWORD="xxxxxxxxxxx" /SQLDOMAINGROUP="DomainName\DomainGroup" /INSTALLSQLDATADIR="<Drive>:\<Path>\MSSQLSERVER" /SQLCOLLATION="SQL_Latin1_General_CP1_CS_AS" /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="xxxxxxxxxxx" /SQLSYSADMINACCOUNTS="DomainName\UserName
安装带数据库引擎和 Analysis Services 的单节点 SQL Server 故障转移群集实例（命名实例）

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=InstallFailoverCluster /InstanceName=INSTANCE NAME /INDICATEPROGRESS /ASSYSADMINACCOUNTS="DomainName\UserName" /ASDATADIR=<Drive>:\OLAP\Data /ASLOGDIR=<Drive>:\OLAP\Log /ASBACKUPDIR=<Drive>:\OLAP\Backup /ASCONFIGDIR=<Drive>:\OLAP\Config /ASTEMPDIR=<Drive>:\OLAP\Temp /FAILOVERCLUSTERDISKS="<Clister Disk Resource Name - e.g., 'Disk S:'" /FAILOVERCLUSTERNETWORKNAME="<Insert Network Name>" /FAILOVERCLUSTERIPADDRESSES="IPv4;xx.xxx.xx.xx;Local Area Connection;xxx.xxx.xxx.x" /FAILOVERCLUSTERGROUP="NAMED_INSTANCE" /Features=AS,SQL /ASSVCACCOUNT="DomainName\UserName" /ASSVCPASSWORD="xxxxxxxxxxx" /ASDOMAINGROUP="DomainName\DomainGroup" /AGTSVCACCOUNT="DomainName\UserName" /AGTSVCPASSWORD="xxxxxxxxxxx" /SQLDOMAINGROUP="DomainName\DomainGroup" /INSTALLSQLDATADIR="<Drive>:\<Path>\<INSTANCE NAME>\" /SQLCOLLATION="SQL_Latin1_General_CP1_CS_AS" /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="xxxxxxxxxxx" /SQLSYSADMINACCOUNTS="DomainName\UserName"

故障转移群集安装的高级方案：

以下两个示例分别使用两个步骤来创建一个数据库引擎故障转移群集实例：一个步骤用于准备故障转移群集实例，另一个步骤用于完成此过程。

请根据您所在单位的需要测试并修改安装脚本。

针对数据库引擎执行故障转移群集高级安装方案的“准备”步骤。这是第 1 步（共 2 步）。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    Setup.exe /q /ACTION=PrepareFailoverCluster /FEATURES=SQL /INSTANCENAME="<Insert Instance Name>" [/INSTANCEIDSUFFIX="<Insert InstanceID Suffix>"] /INSTANCEDIR="<Drive>:\Program Files\Microsoft SQL Server" /INSTALLSHAREDDIR="<Drive>:\Program Files\Microsoft SQL Server" /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="XXXXXX" /AGTSVCACCOUNT="DomainName\UserName" /AGTSVCPASSWORD="XXXXXX" /SQLDOMAINGROUP="DomainName\DomainGroup"
针对数据库引擎执行故障转移群集高级安装方案的“完成”步骤。这是第 2 步（共 2 步）。在将成为故障转移群集中的活动节点的计算机上运行以下命令，以使其可用。必须在 SQL Server 故障转移群集中拥有共享磁盘的节点上运行“CompleteFailoverCluster”操作。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=CompleteFailoverCluster /INSTANCENAME="<Insert Instance Name>" /FAILOVERCLUSTERNETWORKNAME="<Insert FOI Name>" /FAILOVERCLUSTERGROUP="Insert New Cluster Group>" /FAILOVERCLUSTERDISKS="<Cluster Disk Resource Name - e.g., 'Disk S:'>" /FAILOVERCLUSTERIPADDRESSES="IPv4;XXX.XXX.XXX.XXX;Local Area Connection;xxx.xxx.xxx.x" /INSTALLSQLDATADIR="<Drive>:\<Path>\MSSQLSERVER" /SQLCOLLATION="SQL_Latin1_General_CP1_CS_AS" /SQLSYSADMINACCOUNTS="DomainName\UserName" [/SECURITYMODE=SQL /SAPWD="StrongPassword"]

以下两个示例分别使用两个步骤来创建一个 Analysis Services 故障转移群集实例。请根据您所在单位的需要测试并修改安装脚本。

针对 Analysis Services 执行故障转移群集高级安装方案的“准备”步骤。这是第 1 步（共 2 步）。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=PrepareFailoverCluster /FEATURES=AS /InstanceName="<Insert Instance Name>" /ASSVCACCOUNT="DomainName\UserName" /ASSVCPASSWORD="xxxxx" /ASDOMAINGROUP="DomainName\DomainGroup" /INDICATEPROGRESS
针对 Analysis Services 执行故障转移群集高级安装方案的“完成”步骤。这是第 2 步（共 2 步）。在将成为故障转移群集中的活动节点的计算机上运行以下命令，以使其可用。必须在 Analysis Services 故障转移群集中拥有共享磁盘的节点上运行“CompleteFailoverCluster”操作。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=CompleteFailoverCluster /INSTANCENAME="<Insert Instance Name>" /FAILOVERCLUSTERNETWORKNAME="<Insert FOI Name>" /FAILOVERCLUSTERGROUP="<Insert New Cluster Group>" /FAILOVERCLUSTERDISKS="<Cluster Disk Resource Name - for example, 'Disk S:'>" /FAILOVERCLUSTERIPADDRESSES="IPv4;xxx.xxx.xxx.xxx;Local Area Connection;xxx.xxx.xxx.x" /ASSYSADMINACCOUNTS="DomainName\UserName" /ASDATADIR="<Drive>:\NEW_KATMAI\Data" /ASLOGDIR="<Drive>:\NEW_KATMAI\Log" /ASBACKUPDIR="Drive:\NEW_KATMAI\Backup" /ASCONFIGDIR="<Drive>:\NEW_KATMAI\Config" /ASTEMPDIR="<Drive>:\NEW_KATMAI\Temp" /INDICATEPROGRESS

以下两个示例分别使用两个步骤来创建一个带数据库引擎和 Analysis Services 的 SQL Server 故障转移群集实例。请根据您所在单位的需要测试并修改安装脚本。

针对数据库引擎和 Analysis Services 执行故障转移群集高级安装方案的“准备”步骤。这是第 1 步（共 2 步）。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令以准备默认实例：

    复制代码
    setup.exe /q /ACTION=PrepareFailoverCluster /InstanceName=MSSQLSERVER /Features=AS,SQL /INDICATEPROGRESS /ASSVCACCOUNT="DomainName\UserName" /ASSVCPASSWORD="xxxxxxxxxxx" /ASDOMAINGROUP="DomainName\DomainGroup" /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="xxxxxxxxxxx" /SQLDOMAINGROUP="DomainName\DomainGroup" /AGTSVCACCOUNT="DomainName\UserName" /AGTSVCPASSWORD="xxxxxxxxxxx"

在命令提示符下运行以下命令以准备命名实例：

 针对数据库引擎和 Analysis Services 执行故障转移群集高级安装方案的“完成”步骤。这是第 2 步（共 2 步）。在将成为故障转移群集中的活动节点的计算机上运行以下命令，以使其可用。必须在 Analysis Services 故障转移群集中拥有共享磁盘的节点上运行“CompleteFailoverCluster”操作。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令以完成默认实例的故障转移群集安装：

    复制代码
    setup.exe /q /ACTION=CompleteFailoverCluster /InstanceName=MSSQLSERVER /INDICATEPROGRESS /ASSYSADMINACCOUNTS="DomainName\Username" /ASDATADIR=<Drive>:\OLAP\Data /ASLOGDIR=<Drive>:\OLAP\Log /ASBACKUPDIR=<Drive>:\OLAP\Backup /ASCONFIGDIR=<Drive>:\OLAP\Config /ASTEMPDIR=<Drive>:\OLAP\Temp /FAILOVERCLUSTERDISKS="<Cluster Disk Resource Name - for example, 'Disk S:'>:" /FAILOVERCLUSTERNETWORKNAME="<Insert FOI Network Name>" /FAILOVERCLUSTERIPADDRESSES="IPv4;xx.xxx.xx.xx;Local Area Connection;xxx.xxx.xxx.x" /FAILOVERCLUSTERGROUP="MSSQLSERVER" /INSTALLSQLDATADIR="<Drive>:\<Path>\MSSQLSERVER" /SQLCOLLATION="SQL_Latin1_General_CP1_CS_AS" /SQLSYSADMINACCOUNTS="DomainName\UserName"

在命令提示符下运行以下命令以完成命名实例的故障转移群集安装：

添加节点和删除节点方案：

请使用下面的语法向现有 SQL Server 故障转移群集实例中添加节点或从中删除节点。AddNode 操作收集活动节点的功能和设置信息，然后安装必要的组件，再将新节点加入到现有 SQL Server 故障转移群集中。AddNode 既可以用于集成方案，也可以用于高级方案。

请根据您所在单位的需要测试并修改安装脚本。

向具有数据库引擎的现有故障转移群集实例中添加节点。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=AddNode /INSTANCENAME="<Insert Instance Name>" /SQLSVCACCOUNT="<SQL account used on other nodes>" /SQLSVCPASSWORD="<password for SQL account>" /AGTSVCACCOUNT="<SQL Server Agent account used on other nodes>", /AGTSVCPASSWORD="<SQL Server Agent account password>"
向具有 Analysis Services 的现有故障转移群集实例中添加节点。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=AddNode /INSTANCENAME="<Insert Instance Name>" /ASSVCACCOUNT="<AS account used on other nodes>" /ASSVCPASSWORD=”<password for AS account>” /INDICATEPROGRESS
向具有数据库引擎和 Analysis Services 的现有故障转移群集实例中添加节点。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=AddNode /INSTANCENAME="<Insert Instance Name>" /SQLSVCACCOUNT="<SQL account used on other nodes>" /SQLSVCPASSWORD="<password for SQL account>" /AGTSVCACCOUNT="<SQL Server Agent account used on other nodes>", /AGTSVCPASSWORD="<SQL Server Agent account password>" /ASSVCACCOUNT="<AS account used on other nodes>" /ASSVCPASSWORD=”<password for AS account>” /INDICATEPROGRESS

若要完全删除 SQL Server 故障转移群集实例，请在每个故障转移群集节点上使用 REMOVENODE 操作。请根据您所在单位的需要测试并修改这些脚本。

从具有数据库引擎的现有故障转移群集实例中删除节点。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=RemoveNode /INSTANCENAME="<Insert Instance Name>" [/INDICATEPROGRESS]
从具有 Analysis Services 的现有故障转移群集实例中删除节点。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=RemoveNode /INSTANCENAME="<Insert Instance Name>" [/INDICATEPROGRESS]
从具有数据库引擎和 Analysis Services 的现有故障转移群集实例中删除节点。

  1. 将 SQL Server 2008 安装媒体插入磁盘驱动器并打开根文件夹。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=RemoveNode /INSTANCENAME="<Insert Instance Name>" [/INDICATEPROGRESS]

Analysis Services 的安装脚本

若要在命令提示符下安装或升级 Analysis Services，请将“AS”指定为 FEATURES 命令行选项的值之一。例如，若要安装 Analysis Services，可在命令行中指定 /FEATURES=AS。

下表显示了安装 Analysis Services 实例时的可用参数。

参数 | 默认值 | 说明
ASBACKUPDIR | C:\Program Files\Microsoft SQL Server\<实例 ID>\OLAP\Backup 例如，实例 ID 的形式可能如下所示：MSAS10.MSSQLSERVER。 | 指定存储 Analysis Services 备份文件的文件夹。
ASCOLLATION | Latin1_General_CI_AS | 指定 Analysis Services 的排序规则设置。
ASCONFIGDIR | C:\Program Files\Microsoft SQL Server\<实例 ID>\OLAP\Config | 指定用来安装 Analysis Services 配置文件的文件夹。
ASDATADIR | C:\Program Files\Microsoft SQL Server\<实例 ID>\OLAP\Data | 指定用来生成 Analysis Services 多维数据集的文件夹。
ASLANGUAGE | 1033 | 指定区域设置标识符 (LCID)。值 1033 表示美国英语。
ASLOGDIR | C:\Program Files\Microsoft SQL Server\<实例 ID>\OLAP\Log | 指定用于存储 Analysis Services 日志文件的文件夹。
ASPROVIDERMSOLAP | 1 | 指定 MSOLAP 提供程序是否可以在进程中运行。
ASSVCACCOUNT | Local System 帐户 | 指定 MSSQLServerOLAPService 服务帐户域和登录名。使用参数 ASSVCPASSWORD 可以指定与登录名相对应的密码。如果未指定此参数，将使用默认值。
ASSVCPASSWORD | 空 | 指定 MSSQLServerOLAPService 服务帐户密码，该密码与由参数 ASSVCACCOUNT 指定的登录名相对应。指定空密码将导致出错。若要使用空密码，请不要指定此参数。
ASSVCSTARTUPTYPE | Automatic | 指定重新启动 Windows 操作系统后是否自动启动 MSSQLServerOLAPService 服务。该选项可为 Automatic、Disabled 或 Manual。
ASSYSADMINACCOUNTS | 空 | 指定 MSSQLServerOLAPService 管理员帐户密码。
ASTEMPDIR | C:\Program Files\Microsoft SQL Server\<实例 ID>\OLAP\Temp | 指定用于存储 Analysis Services 临时文件的文件夹。
ERRORREPORTING | 0 | 指定是启用还是禁用错误报告。若要启用错误报告，请指定 1。否则，请指定 0。
SQMREPORTING | 0 | 指定是否启用软件质量监视 (SQM)。若要启用 SQM 报告，请指定 1。否则，请指定 0。

请根据您所在单位的需要测试并修改以下 Analysis Services 安装脚本。

安装新的 Analysis Services 默认实例和管理工具

  1. 将安装媒体插入磁盘驱动器并打开 <CD 或 DVD 驱动器>:\SQLDev\Servers\ 文件夹，或导航到网络内部版本文件夹 \\..\SQLDev\Servers\。

  2. 在命令提示符下运行以下命令：

    复制代码
                    setup.exe /ACTION=install /FEATURES=AS,Tools /INSTANCENAME=MSSQLSERVER /ASSVCACCOUNT =<DomainName\UserName> /ASSVCPASSWORD =<StrongPassword>

    重要提示 不要使用空密码。请使用强密码。
升级 SQL Server 2000 Analysis Services 或 SQL Server 2005 Analysis Services 的现有实例

  1. 将安装介质插入磁盘驱动器并打开 <CD 或 DVD 驱动器>:\SQLDev\Servers\ 文件夹，或导航到网络内部版本文件夹 \\..\SQLDev\Servers\。

  2. 在命令提示符下运行以下命令：

    复制代码
                    setup.exe /ACTION=upgrade /FEATURES=AS /INSTANCENAME=<InstanceName>
修复损坏的 SQL Server 2008 Analysis Services 安装

  1. 将安装介质插入磁盘驱动器并打开 <CD 或 DVD 驱动器>:\SQLDev\Servers\ 文件夹，或导航到网络内部版本文件夹 \\..\SQLDev\Servers\。

  2. 在命令提示符下运行以下命令：

    复制代码
                    setup.exe /ACTION=repair /FEATURES=AS /INSTANCENAME=<InstanceName> /ASSVCACCOUNT =<DomainName\UserName> /ASSVCPASSWORD=<StrongPassword>
卸载 Analysis Services 实例

  1. 将安装介质插入磁盘驱动器并打开 <CD 或 DVD 驱动器>:\SQLDev\Servers\ 文件夹，或导航到网络内部版本文件夹 \\..\SQLDev\Servers\。

  2. 在命令提示符下运行以下命令：

    复制代码
                    setup.exe /ACTION=uninstall /FEATURES=AS /INSTANCENAME=<InstanceName>

Reporting Services 的安装选项和脚本

若要从命令提示符安装或升级 Reporting Services，请将“RS”指定为 /FEATURES 命令行选项的值之一。Reporting Services 是识别实例的，所以必须指定 /INSTANCENAME 参数。使用以下选项配置 Reporting Services 安装：

选项 有效值 必需 说明

RSInstallMode

FilesOnlyMode

DefaultNativeMode

DefaultSharePointMode

可选

FilesOnlyMode 安装 Reporting Services 程序文件。FilesOnlyMode 为默认值。如果指定此模式，则必须在安装完成后使用 Reporting Services 配置工具执行所有配置步骤。如果希望 Reporting Services 安装为命名实例，或者如果希望使用远程数据库引擎实例承载报表服务器数据库，则需要此模式。

DefaultNativeMode 使用服务帐户、报表服务器数据库和 URL 的默认值来安装和配置报表服务器。

DefaultSharePointMode 使用默认值安装和配置报表服务器，只有报表服务器系统属性 SharePointIntegratedMode 设置为 True 除外。安装完成后，还必须安装 Windows SharePoint Services (WSS) 3.0 或 Microsoft Office SharePoint Server (MOSS) 2007，否则报表服务器将不能工作。然后，还必须将报表服务器加入到 SharePoint 场并为 SharePoint Web 应用程序配置集成设置。

RSSVCACCOUNT

<域>\<用户>

"NT AUTHORITY\NETWORK SERVICE"

"NT AUTHORITY\LOCAL SYSTEM"

"NT AUTHORITY\LOCAL SERVICE"

是

指定报表服务器服务的服务帐户。如果您指定一个域用户帐户，则域名必须小于 254 个字符而用户帐户名必须小于 20 个字符。

RSSVCPASSWORD

如果指定一个内置帐户，则您可以不指定此值。否则，请指定域用户帐户的密码。

是

为帐户指定强密码。强密码至少包含 8 个字符，并且应由大小写字母数字字符和至少一个符号字符组合而成。

RSSVCSTARTUPTYPE

Manual

Automatic

Disabled

否

指定服务启动类型。默认设置为 Automatic。

RSUPGRADEDATABASEACCOUNT

远程报表服务器数据库的数据库登录名。

如果用于运行安装程序的凭据对报表服务器数据库没有 sysadmin 或数据库所有者权限，则是必需的。

指定在升级期间将使用一次以连接到用于承载报表服务器数据库的数据库引擎实例的 SQL Server 数据库登录名。此帐户必须具有更新报表服务器数据库架构的权限。

如果要升级一个使用远程报表服务器数据库存储应用程序数据的报表服务器，而用于运行安装程序的凭据对远程服务器没有足够的权限，则必须指定此值。

RSUPGRADEPASSWORD

登录名的密码；如果登录名没有密码，则为空字符串。

如果指定了 RSUPGRADEDATABASEACCOUNT，则必须指定此值。

请根据您所在单位的需要测试并修改以下安装脚本。

在“仅文件”模式下使用默认值将 Reporting Services 服务器应用程序安装为默认实例

  1. 将 SQL Server 安装媒体插入磁盘驱动器。

  2. 在命令提示符下运行以下命令：

    复制代码
    Setup /q /ACTION=install /FEATURES=RS /INSTANCENAME=MSSQLSERVER /RSSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE"

如果要使用默认值，命令行可包含最少的参数。此示例在“仅文件”模式下安装未配置的报表服务器，而不安装客户端工具，其中服务帐户作为 Network Service 运行。请注意，未指定 /RSINSTALLMODE。这是因为“仅文件”模式是默认安装模式，如果未指定其他模式则使用该模式。

Reporting Services 需要一个数据库引擎实例来存储应用程序数据。如果希望将数据库引擎现有实例用于报表服务器数据库，则必须在“仅文件”模式下安装 Reporting Services 以便您可以在安装完成后指定要使用的数据库服务器。有关“仅文件”模式的详细信息，请参阅“仅文件”安装 (Reporting Services)。

 在本机模式下以默认配置在一台计算机上安装 Reporting Services、数据库引擎服务和客户端工具

  1. 将 SQL Server 安装媒体插入磁盘驱动器。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup /q /ACTION=install /FEATURES=SQL,RS,TOOLS /INSTANCENAME=MSSQLSERVER /SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS" /RSSVCACCOUNT="Adventure-Works\RSUserAcct" /RSSVCPASSWORD="Som#Pas$w0rd" /SQLSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /AGTSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /RSSVCSTARTUPTYPE="Manual" /RSINSTALLMODE="DefaultNativeMode"

此脚本还会在 Business Intelligence Development Studio 和 SQL Server Management Studio 中安装报表设计器。为了满足默认配置的要求，数据库引擎也将安装在与报表服务器相同的实例中。此脚本包含报表服务器安装的完整的命令行参数，设置为非默认值和虚构凭据。有关默认配置模式的详细信息，请参阅本机模式安装默认配置 (Reporting Services) 和 SharePoint 集成模式默认配置 (Reporting Services)。

 升级使用远程报表服务器数据库的 SQL Server 2005 报表服务器

  1. 将 SQL Server 安装媒体插入磁盘驱动器。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup /q /ACTION=upgrade /INSTANCENAME=MSSQLSERVER /RSUPGRADEDATABASEACCOUNT="Adventure-Works\RSUserAcct" /RSUPGRADEPASSWORD ="Som#Pas$w0rd"

实例中的安装程序组件和功能会升级到新版本；您无法升级同一实例中的特定功能。

此脚本要求您为一次性连接到承载报表服务器数据库的远程数据库引擎实例指定凭据。如果您具有对远程服务器的 sysadmin 或数据库更新权限，则可以省略 RSUPGRADEDATABASEACCOUNT。有关升级报表服务器的详细信息，请参阅升级 Reporting Services 的注意事项。

 卸载 Reporting Services、数据库引擎和客户端工具

  1. 将 SQL Server 安装媒体插入磁盘驱动器。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup /q /ACTION=uninstall /FEATURES=SQL,RS,Tools /INSTANCENAME=MSSQLSERVER

Integration Services 的安装脚本

通常会同时安装或升级 Integration Services 和 SQL Server 数据库引擎实例。虽然可以在没有数据库引擎实例的情况下设计和运行 Integration Services 包，但是您无法将 SQL Server 2008 Integration Services 包存储在 SQL Server 中，除非存在 SQL Server 2008 数据库引擎实例。

若要从命令提示符安装或升级 Integration Services，请将“IS”指定为 FEATURES 命令行选项的值之一。请使用以下选项来配置 Integration Services 服务帐户：

选项 | 必需？ | 说明
ISSVCAccount | 必需 | 用于运行 Integration Services 服务的帐户。建议帐户为 NT AUTHORITY\NETWORK SERVICE。
ISSVCPassword | 必需 | 指定为 ISSVCAccount 的帐户的密码。使用 Network Service 帐户时，请指定空密码。
ISSVCStartupType | 可选 | 服务的启动类型。有效值为 Automatic、Manual 或 Disabled。默认值为 Automatic。
注意：
Integration Services 不是特定于实例的。在一台计算机上仅可安装一个 Integration Services 实例。通过使用运行服务的服务器的名称从管理工具和客户端应用程序连接到该服务。

请根据您所在单位的需要测试并修改以下安装脚本。

使用默认设置安装 Integration Services、SQL Server 数据库引擎实例和客户端工具

  1. 将 SQL Server 安装媒体插入磁盘驱动器。

  2. 在命令提示符下运行以下命令：

    复制代码
    setup.exe /q /ACTION=install /FEATURES=SQL,IS,Tools /ISSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /INSTANCENAME=MSSQLSERVER /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="StrongPassword" /SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS" /AGTACCOUNT="DomainName\UserName" /AGTPASSWORD="StrongPassword"

重要提示 不要使用空密码。请使用强密码。

注意：
对于数据库引擎默认实例，请为 <实例名> 指定“MSSQLSERVER”。如果是命名实例，请指定实例名。在本示例中，已指定默认实例。

SQL Server 安装参数

请使用下表中列出的参数开发命令提示符安装脚本。

SQL Server 组件 | 参数名称 | 说明 | 支持的值
Analysis Services | /ASBACKUPDIR | 指定 Analysis Services 备份文件的目录。 |
Analysis Services | /ASCOLLATION | 指定 Analysis Services 的排序规则设置。 |
Analysis Services | /ASCONFIGDIR | 指定 Analysis Services 配置文件的目录。 |
Analysis Services | /ASDATADIR | 指定 Analysis Services 数据文件的目录。 |
Analysis Services | /ASLANGUAGE | 指定 Analysis Services 的区域设置。 |
Analysis Services | /ASLOGDIR | 指定 Analysis Services 日志文件的目录。 |
Analysis Services | /ASSVCACCOUNT | 指定 Analysis Services 服务的帐户。 |
Analysis Services | /ASSVCPASSWORD | 指定 Analysis Services 服务的密码。 |
Analysis Services | /ASSVCSTARTUPTYPE | 指定 Analysis Services 服务的启动模式。 | 2=自动， 4=禁用， 3=手动
Analysis Services | /ASSYSADMINACCOUNTS | 指定 Analysis Services 的管理员凭据。 |
Analysis Services | /ASTEMPDIR | Analysis Services 临时文件的目录。 |
Analysis Services | /ASPROVIDERMSOLAP | 指定 MSOLAP 提供程序是否可以在进程中运行。 | 1=启用，0=禁用
数据库引擎 | /ENABLERANU | 为 SQL Server Express 安装启用运行身份凭据。 |
数据库引擎 | /INSTALLSQLDATADIR | 指定 SQL Server 数据文件的数据目录。 | 1=启用，0=禁用
数据库引擎 | /REBUILDDATABASES |  |
数据库引擎 | /SAPWD |  |
数据库引擎 | /SECURITYMODE |  | /SECURITYMODE="SQL"
数据库引擎 | /SQLBACKUPDIR |  |
数据库引擎 | /SQLCOLLATION |  |
数据库引擎 | /SQLSVCACCOUNT |  |
数据库引擎 | /SQLSVCPASSWORD |  |
数据库引擎 | /SQLSVCStartuptype | 指定 SQL Server 服务的启动模式。 | 2=自动， 4=禁用， 3=手动
数据库引擎 | /SQLSYSADMINACCOUNTS | 使用此参数可在 SQL Server 中设置用户。 |
数据库引擎 | /SQLTEMPDBDIR |  |
数据库引擎 | /SQLTEMPDBLOGDIR |  |
数据库引擎 | /SQLUSERDBDIR |  |
数据库引擎 | /SQLUSERDBLOGDIR |  |
Integration Services | /ISSVCAccount | 指定 Integration Services 的帐户。 | 域名\用户名或系统帐户
Integration Services | /ISSVCPassword | 指定 Integration Services 密码。 | 只有域帐户才需要。
Integration Services | /ISSVCStartupType | 指定 Integration Services 服务的启动类型。 |
DP 的 NLRegS 扩展插件 | /NPENABLED |  |
DP 的 NLRegS 扩展插件 | /TCPENABLED |  |
Reporting Services | /RSInstallMode |  |
Reporting Services | /RSSVCACCOUNT |  |
Reporting Services | /RSSVCPASSWORD |  |
Reporting Services | /RSSVCStartupType |  |
Reporting Services | /RSUPGRADEDATABASEACCOUNT |  |
Reporting Services | /RSUPGRADEPASSWORD |  |
SQL Server Browser | /BROWSERSVCStartupType | 指定 SQL Server Browser 服务的启动模式。 | 2=自动， 4=禁用， 3=手动
SQL Server 代理 | /AGTSVCACCOUNT | 指定 SQL Server 服务的帐户。 | 域名\用户名或系统帐户
SQL Server 代理 | /AGTSVCPASSWORD | 指定 SQL Server 代理密码 | 只有域帐户才需要。
SQL Server 代理 | /AGTSVCSTARTUPTYPE | 指定 SQL Server Agent 服务的启动模式。 | 2=自动， 4=禁用， 3=手动
SQL Server 安装程序 | /ACTION | 指定一个安装工作流。 | 安装、卸载或升级
SQL Server 安装程序 | /ERRORREPORTING | SQL Server 的错误报告。 | 1=启用；0=禁用
SQL Server 安装程序 | /FEATURES | 指定要安装、卸载或升级的组件。 | SQL、SQLEngine、复制、FullText、AS、RS、IS、TOOLS、BIDS、BOL
SQL Server 安装程序 | /HELP、H、? | 显示安装参数的用法选项。 |
SQL Server 安装程序 | /INDICATEPROGRESS | 指定应将详细的安装程序日志文件传送到控制台。 |
SQL Server 安装程序 | /INSTALLSHAREDDIR | 为 64 位组件指定一个非默认安装目录。 |
SQL Server 安装程序 | /INSTALLSHAREDWOWDIR | 为 32 位组件指定一个非默认安装目录。 |
SQL Server 安装程序 | /INSTANCEDIR | 为共享组件指定一个非默认安装目录。 |
SQL Server 安装程序 | /INSTANCEIDSUFFIX | 为 InstanceID 指定一个非默认值。 |
SQL Server 安装程序 | /INSTANCENAME | 指定非默认 SQL Server 实例名称。 | /InstanceName=MSSQLServer 或 /InstanceName=<命名实例的名称>
SQL Server 安装程序 | /Q | 指定在没有任何用户界面的情况下运行安装程序。 |
SQL Server 安装程序 | /SQMREPORTING | 指定 SQL Server 的功能使用情况报告。 | 1=启用；0=禁用

请参阅

任务

如何安装 SQL Server 2008（安装程序）
如何阅读 SQL Server 安装日志文件


如何向 SQL Server 2008 的实例添加功能（安装程序）

如何向 SQL Server 2008 的实例添加功能（安装程序） |
 | 请参阅
安装 SQL Server 2008 > 安装操作指南主题 >

SQL Server 安装向导提供了一个用于安装所有 SQL Server 组件的树功能。您不必分别安装每个组件。

  • 数据库引擎

  • Analysis Services

  • Reporting Services

  • Integration Services

  • 复制

  • 全文搜索

  • 管理工具

  • 连接组件

  • 示例数据库、示例和 SQL Server 联机丛书

若要从命令提示符向 SQL Server 2008 实例添加功能，请参阅如何从命令提示符安装 SQL Server 2008。

必备条件

继续之前，请查阅计划 SQL Server 安装中的主题。

注意：
对于本地安装，必须以管理员身份运行安装程序。如果从远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。

过程

安装 SQL Server 2008

  1. 插入 SQL Server 安装媒体。然后双击根文件夹中的 setup.exe。若要从网络共享进行安装，请导航到共享中的根文件夹，然后双击 setup.exe。

  2. 如果出现 Microsoft .NET Framework 2.0 版 安装对话框，则选中相应的复选框以接受 .NET Framework 2.0 许可协议。单击“下一步”。若要退出 SQL Server 2008 安装，请单击“取消”。当 .NET Framework 2.0 的安装完成后，请单击“完成”。

  3. Windows Installer 4.5 也是必需的，并且可能由安装向导进行安装。如果系统提示您重新启动计算机，则重新启动计算机，然后重新启动 SQL Server 2008 setup.exe。

  4. 必备组件安装完成后，安装向导会启动 SQL Server 安装中心。若要创建 SQL Server 2008 的全新安装，请单击“全新安装或向现有安装添加功能”。

  5. 系统配置检查器将在您的计算机上运行发现操作。若要继续，请单击“确定”。系统已经为您的安装创建了安装日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 安装日志文件。

  6. 如果您的计算机上尚未安装 SQL Server 必备组件，安装向导会安装它们。其中包括：

    • .NET Framework 2.0

    • SQL Server Native Client

    • SQL Server 安装程序支持文件

    若要安装必备组件，请单击“安装”。

  7. 系统配置检查器将在安装继续之前检验计算机的系统状态。

  8. 在“安装类型”页上指定要更新的实例。

  9. 在“功能选择”页上选择要安装的组件。选择功能名称后，右侧窗格中会显示每个组件组的说明。您可以选择复选框的任意组合。有关详细信息，请参阅 SQL Server 2008 的版本和组件。每个组件都只能在给定的 SQL Server 实例上安装一次。若要安装多个组件，则必须安装其他的 SQL Server 实例。

  10. “磁盘空间要求”页计算指定的功能所需的磁盘空间，并将磁盘空间要求与正在运行安装程序的计算机上的可用磁盘空间进行比较。有关详细信息，请参阅磁盘成本摘要。

  11. 本主题中的其余工作流取决于您指定安装的功能。您可能不会看到所有的页面，具体取决于您进行的选择。

  12. 在“服务器配置 - 服务帐户”页上指定 SQL Server 服务的登录帐户。此页上配置的实际服务取决于您选择安装的功能。

    您可以为所有 SQL Server 服务分配相同的登录帐户，也可以单独配置各个服务帐户。还可以指定服务是自动启动、手动启动还是禁用的。Microsoft 建议您对各个服务帐户进行单独配置，以便为每项服务提供最小特权，即向 SQL Server 服务授予它们完成各自任务所需的最低权限。有关详细信息，请参阅SQL Server 配置 - 服务帐户和设置 Windows 服务帐户。

    若要为此 SQL Server 实例中的所有服务帐户指定相同的登录帐户，请在页面底部的字段中提供凭据。

    安全说明 不要使用空密码。请使用强密码。

    为 SQL Server 服务指定登录信息后，请单击“下一步”。

  13. 使用“服务器配置 - 排序规则”选项卡为数据库引擎和 Analysis Services 指定非默认的排序规则。有关详细信息，请参阅 SQL Server 配置 - 排序规则。

  14. 使用“数据库引擎配置 - 帐户设置”页指定以下各项：

    • 安全模式 - 为您的 SQL Server 实例选择 Windows 身份验证或混合模式身份验证。如果选择“混合模式身份验证”，则必须为内置 SQL Server 系统管理员帐户提供一个强密码。

      在设备与 SQL Server 成功建立连接之后，用于 Windows 身份验证和混合模式身份验证的安全机制是相同的。有关详细信息，请参阅数据库引擎配置 - 帐户设置。

    • SQL Server 管理员 - 您必须为 SQL Server 实例至少指定一个系统管理员。若要添加用以运行 SQL Server 安装程序的帐户，请单击“添加当前用户”。若要向系统管理员列表中添加帐户或从中删除帐户，请单击“添加”或“删除”，然后编辑将拥有 SQL Server 实例的管理员特权的用户、组或计算机的列表。有关详细信息，请参阅数据库引擎配置 - 帐户设置。

    完成对该列表的编辑后，请单击“确定”。验证配置对话框中的管理员列表。完成此列表后，请单击“下一步”。

  15. 使用“数据库引擎配置 - 数据目录”页指定非默认的安装目录。若要安装到默认目录，请单击“下一步”。

    重要提示：
    如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。

    有关详细信息，请参阅数据库引擎配置 - 数据目录。

  16. 使用“数据库引擎配置 - FILESTREAM”页对 SQL Server 实例启用 FILESTREAM。有关 FILESTREAM 的详细信息，请参阅数据库引擎配置 - 文件流。若要继续，请单击“下一步”。

  17. 使用“Analysis Services 配置 – 帐户设置”页指定将拥有 Analysis Services 的管理员权限的用户或帐户。您必须为 Analysis Services 至少指定一个系统管理员。若要添加用以运行 SQL Server 安装程序的帐户，请单击“添加当前用户”。若要向系统管理员列表中添加帐户或从中删除帐户，请单击“添加”或“删除”，然后编辑将拥有 Analysis Services 的管理员特权的用户、组或计算机的列表。有关详细信息，请参阅 Analysis Services 配置 – 帐户设置。

    完成对该列表的编辑后，请单击“确定”。验证配置对话框中的管理员列表。完成此列表后，请单击“下一步”。

  18. 使用“Analysis Services 配置 - 数据目录”页指定非默认的安装目录。若要安装到默认目录，请单击“下一步”。

    重要提示：
    如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。

    有关详细信息，请参阅 Analysis Services 配置 - 数据目录。

  19. 使用“Reporting Services 配置”页指定要创建的 Reporting Services 安装的类型。包括以下选项：

    • 本机模式默认配置

    • SharePoint 模式默认配置

    • 未配置的 Reporting Services 安装

    有关 Reporting Services 配置模式的详细信息，请参阅报表服务器安装选项。

  20. 在“错误和使用情况报告”页上指定要发送到 Microsoft 以帮助改善 SQL Server 的信息。默认情况下，用于错误报告和功能使用情况的选项处于启用状态。有关详细信息，请参阅错误和使用情况报告设置。

  21. 系统配置检查器将运行一组以上的规则，以用您指定的 SQL Server 功能验证您的计算机配置。

  22. “准备安装”页显示您在安装过程中指定的安装选项的树视图。

  23. 在安装过程中，“安装进度”页会提供相应的状态，因此您可以在安装过程中监视安装进度。

  24. 安装完成后，“完成”页会提供指向安装日志文件摘要以及其他重要说明的链接。若要完成 SQL Server 安装过程，请单击“关闭”。

  25. 如果安装程序指示您重新启动计算机，请立即重新启动。安装完成后，请务必阅读来自安装向导的消息。有关安装日志文件的信息，请参阅如何查看 SQL Server 安装日志文件。

后续步骤

配置 SQL Server 安装

  • 为了减少系统的可攻击外围应用，SQL Server 将有选择地安装和激活一些密钥服务和功能。有关详细信息，请参阅 MSDN 上的 Understanding Surface Area Configuration（了解外围应用配置器）。

  • 有关使用图形工具和命令提示符实用工具的详细信息，请参阅配置 SQL Server 2008。

请参阅

任务

如何升级到 SQL Server 2008（安装程序）

概念

如何查看 SQL Server 安装日志文件
如何从命令提示符安装 SQL Server 2008


如何重命名承载 SQL Server 独立实例的计算机

如何重命名承载 SQL Server 独立实例的计算机 |
 | 请参阅
安装 SQL Server 2008 > 安装操作指南主题 >

如果更改了运行 SQL Server 的计算机的名称，则会在 SQL Server 启动期间识别新名称。不必再次运行安装程序以重置计算机名称。只需使用以下步骤对存储在 sys.servers 中并由系统函数 @@SERVERNAME 报告的系统元数据进行更新，使系统元数据反映出使用 @@SERVERNAME 或从 sys.servers 中查询服务器名称的远程连接或应用程序的计算机名称的变化。

不能通过以下步骤重命名 SQL Server 实例。这些步骤只能用于重命名实例名中与计算机名称对应的部分。例如，可以将承载名为 Instance1 的 SQL Server 实例的计算机称（名为 MB1）更改为其他名称，例如 MB2。但是，名称中的实例部分 Instance1 将保持不变。在此示例中，\\计算机名称\实例名 将从 \\MB1\Instance1 更改为 \\MB2\Instance1。

开始之前

开始重命名过程之前，请查看下列信息：

  • 如果 SQL Server 实例是 SQL Server 故障转移群集的一部分，则计算机的重命名过程不同于承载独立实例的计算机的重命名过程。

  • 除了对复制时使用日志传送的情况，SQL Server 不支持对复制所涉及的计算机进行重命名。如果主计算机永久丢失，则可以重命名日志传送中的辅助计算机。有关详细信息，请参阅复制和日志传送。

  • 如果重命名配置为使用 Reporting Services 的计算机，则 Reporting Services 在计算机名称更改后可能不可用。有关详细信息，请参阅重命名报表服务器计算机。

  • 重命名配置为使用数据库镜像的计算机时，必须先关闭数据库镜像，然后才能执行重命名操作。然后，使用新的计算机名称重新建立数据库镜像。数据库镜像的元数据将不会自动更新来反映新计算机名称。使用以下步骤更新系统元数据。

  • 如果用户通过以硬编码方式引用计算机名称的 Windows 组连接到 SQL Server，则用户可能无法再连接到 SQL Server。重命名之后，如果 Windows 组指定的是旧计算机名称，则可能会发生这种情况。若要确保这样的 Windows 组在重命名操作之后可以连接 SQL Server，请更新 Windows 组以指定新计算机名称。

重新启动 SQL Server 后，可使用新计算机名称连接到 SQL Server。为确保 @@SERVERNAME 返回本地服务器实例更新后的名称，应根据您的方案手动运行以下过程：采用的过程取决于所更新的计算机承载的是 SQL Server 的默认实例还是命名实例。

重命名承载 SQL Server 独立实例的计算机

  • 对于承载 SQL Server 默认实例的重命名计算机，请运行以下过程：

    复制代码
    sp_dropserver <old_name>
GO
sp_addserver <new_name>, local
GO

    重新启动 SQL Server 实例。

  • 对于承载 SQL Server 命名实例的重命名计算机，请运行以下过程：

    复制代码
    sp_dropserver <old_name\instancename>
GO
sp_addserver <new_name\instancename>, local
GO

    重新启动 SQL Server 实例。

重命名操作之后

重命名计算机后，所有使用旧计算机名称的连接都必须通过使用新名称进行连接。

验证是否已成功完成重命名操作

  • 通过 @@SERVERNAME 或 sys.servers 选择信息。@@SERVERNAME 函数将返回相应的新名称，sys.servers 表将显示相应的新名称。下例说明了 @@SERVERNAME 的用法。

    复制代码
    SELECT @@SERVERNAME AS 'Server Name'

其他注意事项

远程登录 - 如果计算机具有任何远程登录，运行 sp_dropserver 可能会产生类似如下的错误：

复制代码
Server: Msg 15190, Level 16, State 1, Procedure sp_dropserver, Line 44
There are still remote logins for the server 'SERVER1'.

若要解决此错误，必须删除此服务器的远程登录。

删除远程登录

  • 对于默认实例，请运行以下过程：

    复制代码
    sp_dropremotelogin old_name
GO

  • 对于命名实例，请运行以下过程：

    复制代码
    sp_dropremotelogin old_name\instancename
GO

链接服务器配置 - 链接服务器配置将受到计算机重命名操作的影响。使用 sp_addlinkedserver 或 sp_setnetname 可更新计算机名称引用。有关详细信息，请参阅 MSDN 上的 SQL Server 联机丛书主题 sp_addlinkedserver (Transact-SQL) 或 sp_setnetname (Transact-SQL)。

客户端别名 - 采用 named pipes 的客户端别名将受到计算机重命名操作的影响。例如，如果创建了指向 SRVR1 的别名“PROD_SRVR”，而且该别名采用 Named Pipes 协议，则相应的管道名称将类似于 \\SRVR1\pipe\sql\query。计算机重命名后，named pipe 的路径将不再有效。有关 named pipes 的详细信息，请参阅 MSDN 上的 SQL Server 联机丛书主题 Creating a Valid Connection String Using Named Pipes（使用 Named Pipes 创建有效的连接字符串）。

请参阅

概念

安装 SQL Server 2008


如何查看 SQL Server 安装日志文件

如何查看 SQL Server 安装日志文件 |
 | 请参阅
安装 SQL Server 2008 > 安装操作指南主题 >

SQL Server 安装的日志记录在此版本中已经更改。应查看的主日志为 l<drive>:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\LOG\Summary.txt

每次运行安装程序都会生成一个新的标有时间戳的日志文件夹。例如，如果启动“SQL Server 安装中心”页，则安装程序会获得它自己的标有时间戳的日志文件夹，并且从该页调用的每项安装操作也会获得它自己的标有时间戳的日志文件夹，因此您可能会在此目录中看到多个标有时间戳的日志文件夹。标有时间戳的日志文件夹名称的格式为 YYYMMDD_hhmmss。

详细的安装日志位于以下位置：

<drive>:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\LOG\。

查找详细信息日志中的错误时，请搜索以下短语：

  • Watson bucket

  • Error:

  • Exception has been

一个典型的安装请求将经历以下三个执行阶段：

  1. 全局规则检查

  2. 组件更新

  3. 用户请求的操作

其中每个阶段都会生成详细信息日志和摘要日志，并根据需要生成其他日志文件。在每次执行用户请求的安装操作时安装程序至少会被调用三次。

所生成的典型日志文件为：

  • Detail_GlobalRules.txt

  • Detail_ComponentUpdate.txt

  • Detail.txt

摘要日志文件名称的格式为 Summary_[计算机名称]_timestamp_[执行阶段]

最终的摘要日志复制到 %Program Files%\Microsoft SQL Server\100\setup bootstrap\log 文件夹中，并且命名为 Summary.txt，以便速查。

注意：如果不存在错误，则安装程序不会对日志文件执行 CAB 操作。

在安装过程中所执行的 MSI 操作将以如下格式生成它们自己的日志文件：[产品功能]_[cpu]_[LCID（可选）]_[尝试编号].log。如果 MSI 执行失败，请在关联 MSI 日志中查找仅适用于 ENU 版本的“return value 3”。

数据存储文件包含安装过程所跟踪的所有配置对象状态的快照，对于纠正配置错误来说非常有用。XML 文件转储是为每个执行阶段的数据存储对象创建的。它们保存在标有时间戳的日志文件夹下其自己的日志子文件夹中，如下所示：

  • Datastore_GlobalRules

  • Datastore_ComponentUpdate

  • Datastore

请参阅

概念

SQL Server 安装故障排除


如何阅读 SQL Server 安装日志文件

如何阅读 SQL Server 安装日志文件 |
 | 请参阅
安装 SQL Server 2008 > 安装操作指南主题 >

SQL Server 安装程序在安装过程中会为每个 SQL Server 组件创建日志文件；Setup.exe 启动后会立即开始日志记录。

阅读 SQL Server 安装日志文件

  1. 打开 Windows 资源管理器，然后导航到以下位置：

    <drive>:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\LOG

  2. 打开 Summary.txt 文件。 通查该文件看有无错误消息。

  3. 如果在 Summary.txt 文件中找不到有关失败事项的信息，请打开同一根目录中的 SQLSetup[xxxx].cab 文件。

  4. 如果该 .cab 文件不存在，请在下列路径中打开 CORE 日志文件：

    <drive>:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\LOG\Files

    查看最新修改的核心日志：SQLSetup[xxxx]_[ComputerName]_Core.log。

  5. 如果安装过程中在用户界面中显示了错误，请查找此日志：SQLSetup[xxxx][s]_[ComputerName]_WI.log。

  6. 分析 SQLSetup_[xxxx] 日志文件时，在该文件中搜索“UE 3”。 这是“Return Value 3”的缩写。

  7. 如果安装过程中某个组件失败，请打开日志文件 SQLSetup[xxxx]_[ComputerName]_SQL.log，然后执行“UE 3”搜索以扫描错误。

请参阅

概念

如何查看 SQL Server 安装日志文件


如何卸载 SQL Server 2008 的现有实例（安装程序）

如何卸载 SQL Server 2008 的现有实例（安装程序） |
 | 请参阅
安装 SQL Server 2008 > 安装操作指南主题 >

本文介绍如何手动卸载 SQL Server 的独立实例。使用本主题中提供的步骤，您还可以准备系统以便重新安装 SQL Server。

重要提示：
若要维护或更新 SQL Server 实例，您必须是拥有“作为服务登录”权限的本地管理员。

使用此过程卸载 SQL Server 之前，请注意以下重要信息：

  • 建议使用“控制面板”中的“添加或删除程序”卸载 SQL Server。

  • 在同时运行 SQL Server 和早期 SQL Server 版本的计算机上，企业管理器和其他依赖于 SQL-DMO 的程序可能被禁用。这可能出现在以下情况中：

    • 并行安装了 SQL Server 2008、SQL Server 2000 和 SQL Server 7.0 三者中的任意组合之后，又卸载了其中任何一个或多个实例。

    • 并行安装了 SQL Server 2000 和 SQL Server 2008，且是在安装 SQL Server 2008 后安装 SQL Server 2000。

    这个问题是由于删除了 SQL Server SQL-DMO COM 库的注册造成的。若要重新启用企业管理器和对 SQL-DMO 有依赖关系的其他程序，请在命令提示符处运行 regsvr32.exe sqldmo.dll 以注册 SQL-DMO。有关详细信息，请参阅SQL Server 安装故障排除。

  • 从内存大小为最小必需物理内存量的计算机中删除 SQL Server 组件前，请确保有足够大小的页文件。页文件大小必须等于物理内存量的两倍。虚拟内存不足会导致无法完整删除 SQL Server。

  • 在 SQL Server 2005 中，SQL Server Browser 是与 数据库引擎 或 Analysis Services 一起集成安装的。在 SQL Server 2008 中，SQL Server Browser 是单独安装的，并且随同 数据库引擎 或 Analysis Services 一起自动执行。如果有多个 SQL Server 2008 实例，则 SQL Server Browser 将在删除 SQL Server 2008 的最后一个实例后自动卸载。

    如果 SQL Server 2005 存在于具有一个或多个SQL Server 2008 实例的系统上，SQL Server 2008 Browser 在卸载 SQL Server 2008 的最后一个实例后将不会自动删除。随 SQL Server 2008 一起安装的 SQL Server Browser 将保留在系统中，以方便与 SQL Server 2005 实例的连接。您可以保留随 SQL Server 2005 一起安装的 SQL Server 2008 Browser，它将仍可正常使用。

    若要卸载 SQL Server 2008 的所有组件，则必须从“控制面板”中的“程序和功能”手动卸载 SQL Server Browser 组件。如果在 SQL Server 2005 命名实例存在时删除 SQL Server 2008 Browser，则到 SQL Server 2005 的连接可能中断。在这种情况下，可以通过下面的一种方法重新安装 SQL Server Browser：

    • 使用“控制面板”中的“程序和功能”修复 SQL Server 2005 实例。

    • 安装 SQL Server 2005 数据库引擎实例或 Analysis Services 实例。

删除 SQL Server 之前，请先执行以下步骤：

  • 备份您的数据。您可能希望按照当前的状态保存数据库。可能还希望保存对系统数据库所做的更改。无论哪种情况，请确保先备份数据，再卸载 SQL Server。或者，将所有数据和日志文件的副本保存在 MSSQL 文件夹以外的文件夹中。卸载期间 MSSQL 文件夹将被删除。

    必须保存的文件包括以下数据库文件。以下文件作为 SQL Server 的一部分安装：

    • Distmdl.*

    • Master.*

    • Mastlog.*

    • Model.*

    • Modellog.*

    • Msdbdata.*

    • Msdblog.*

    • Mssqlsystemresource.*

    • Northwind.*（该数据库是可选安装。）

    • Pubs.*

    • Pubs_log.*

    • Tempdb.*

    • Templog.*

    • ReportServer[$InstanceName]（这是 Reporting Services 的默认数据库。）

    • ReportServer[$InstanceName]TempDB（这是 Reporting Services 的默认临时数据库。）

  • 删除本地安全组 。卸载 SQL Server 之前，应先删除用于 SQL Server 组件的本地安全组。

  • 保存或重命名 Reporting Services 文件夹。如果将 Reporting Services 与 SQL Server 安装一起使用，应保存或重命名以下文件夹或子文件夹：

    • <驱动器>\Microsoft SQL Server\Reporting Services

    • <驱动器>\Microsoft SQL Server\MSSQL\Reporting Services

    • <驱动器>\Microsoft SQL Server\<SQL Server instance name>\Reporting Services

    • <驱动器>\Microsoft SQL Server\100\Tools\Report Designer

      注意：
      如果以前是使用 SSRS 配置工具配置的安装，则名称可能会与此列表中的名称有所不同。此外，数据库可能位于运行 SQL Server 的远程计算机上。

  • 删除 Reporting Services 虚拟目录。使用 Internet Information Services (IIS) 管理器删除以下虚拟目录：

    • ReportServer[$InstanceName]

    • Reports[$InstanceName]

  • 删除 ReportServer 应用程序池。使用 IIS 管理器删除 ReportServer 应用程序池。

  • 停止所有 SQL Server 服务。 建议先停止所有 SQL Server 服务，然后再卸载 SQL Server 组件。活动的连接可能会使卸载过程无法成功完成。

  • 使用具有适当权限的帐户。使用 SQL Server 服务帐户或具有同等权限的帐户登录到服务器。例如，可以使用本地 Administrators 组的成员帐户登录到服务器。

卸载 SQL Server 2008 实例

  1. 若要开始卸载过程，请从“开始”菜单，单击“控制面板”，然后双击“添加或删除程序”。

  2. 选择要卸载的 SQL Server 组件，然后单击“更改/删除”。这将启动 SQL Server 安装向导。

  3. 将运行安装程序支持规则以验证您的计算机配置。若要继续，请单击“确定”。

  4. 在“选择实例”页上，使用下拉框指定要删除的 SQL Server 实例，或者指定与仅删除 SQL Server 共享功能和管理工具相对应的选项。若要继续，请单击“下一步”。

  5. 在“选择功能”页上指定要从指定的 SQL Server 实例中删除的功能。继续操作。

  6. 将运行删除规则以验证是否可以成功完成删除操作。

  7. 在“准备卸载”页上查看要卸载的组件和功能的列表。

  8. “安装进度”页将显示安装状态。

  9. 在“完成安装”页上单击“关闭”退出安装向导。

  10. 重复步骤 2-9，直到删除所有 SQL Server 2008 组件。

请参阅

任务

如何阅读 SQL Server 安装日志文件

概念

如何查看 SQL Server 安装日志文件


SQL Server 安装故障排除

SQL Server 安装故障排除 |
 | 请参阅
安装 SQL Server 2008 >

若要查看有关安装和升级问题的故障排除信息，请参阅 SQL Server 2008 Readme（SQL Server 2008 自述文档）。

请参阅

任务

如何阅读 SQL Server 安装日志文件

概念

如何查看 SQL Server 安装日志文件


升级到 SQL Server 2008

升级到 SQL Server 2008 |
 | 请参阅

您可以将 SQL Server 2000 或 SQL Server 2005 实例升级到 SQL Server 2008。在运行 SQL Server 安装程序以升级到 SQL Server 2008 之前，请先查看以下有关升级过程的主题。

本节内容

主题 | 说明
计划 SQL Server 安装 | 介绍安装要求、SQL Server 安装程序运行的系统配置检查以及 SQL Server 安装的安全注意事项。
版本升级 | 介绍 SQL Server 2008 支持的升级途径。
使用升级顾问来准备升级 | 介绍升级顾问，升级顾问是一个对 SQL Server 2000 和 SQL Server 2005 实例进行分析以识别已知升级问题的工具。
升级操作指南主题 | 提供升级到 SQL Server 2008 的步骤主题的链接。
向后兼容性 | 列出在升级到 SQL Server 2008 后可能会影响应用程序的重要更改。

请参阅

概念

升级数据库引擎时的注意事项
升级 Analysis Services 时的注意事项
升级 Reporting Services 的注意事项
升级 Data Transformation Services 时的注意事项
升级复制数据库时的注意事项

其他资源

升级 Integration Services 时的注意事项


版本升级

版本升级 |
 | 请参阅
升级到 SQL Server 2008 >

此 SQL Server 版本支持以下升级方案：

升级前的版本 | 支持的升级途径
SQL Server 2000（32 位）MSDE SP41 | SQL Server 2008 Express
SQL Server 2000（32 位）Standard SP41,4 | SQL Server 2008 Standard SQL Server 2008 Enterprise
SQL Server 2000（32 位）Developer SP41,4 | 不支持升级。
SQL Server 2000（32 位）Enterprise SP41,4 | SQL Server 2008 Enterprise
SQL Server 2000 Enterprise Evaluation（32 位，IA64，X64）4,5 | 不支持升级。
SQL Server 2000（64 位）IA64 Developer SP43,4,5 | SQL Server 2008（64 位）IA64 Developer
SQL Server 2000（64 位）IA64 Enterprise SP43,4,5 | SQL Server 2008（64 位）IA64 Enterprise
SQL Server 2000（32 位）Personal SP42 | 不支持升级。
SQL Server 2005（32 位）Express | SQL Server 2008 Express SQL Server 2008 Express Advanced
SQL Server 2005（32 位）Express Advanced1 | SQL Server 2008 Express Advanced
SQL Server 2005（32 位）Workgroup1 | 不支持升级。
SQL Server 2005（32 位）Standard1 | SQL Server 2008 Standard SQL Server 2008 Enterprise
SQL Server 2005（32 位）Developer1 | 不支持升级。
SQL Server 2005（32 位）Enterprise1 | SQL Server 2008 Enterprise
SQL Server 2005 Enterprise Evaluation（32 位，IA64，X64） | 不支持升级。
SQL Server 2005 IA64（64 位）Developer | 不支持升级。
SQL Server 2005 IA64（64 位）Standard | SQL Server 2008 IA64（64 位）Enterprise
SQL Server 2005 IA64（64 位）Enterprise | SQL Server 2008 IA64（64 位）Enterprise
SQL Server 2005 X64（64 位）Developer | SQL Server 2008 X64（64 位）Developer
SQL Server 2005 X64（64 位）Standard | SQL Server 2008 X64（64 位）Standard SQL Server 2008 X64（64 位）Enterprise
SQL Server 2005 X64（64 位）Enterprise | SQL Server 2008 X64（64 位）Enterprise
SQL Server 2008 Express1 | SQL Server 2008 Express SQL Server 2008 Express Advanced SQL Server 2008 Standard SQL Server 2008 Enterprise
SQL Server 2008 Express Advanced1 | SQL Server 2008 Express Advanced SQL Server 2008 Standard SQL Server 2008 Enterprise
SQL Server 2008 Express x64（64 位） | SQL Server 2008 Express x64（64 位） SQL Server 2008 Express Advanced x64（64 位）
SQL Server 2008 Express Advanced x64（64 位） | SQL Server 2008 Express Advanced x64（64 位） SQL Server 2008 Standard x64（64 位） SQL Server 2008 Enterprise x64（64 位）
SQL Server 2008 Workgroup1 | SQL Server 2008 Workgroup SQL Server 2008 Standard SQL Server 2008 Enterprise
SQL Server 2008 Web1 | SQL Server 2008 Web
SQL Server 2008 Standard1,2 | SQL Server 2008 Standard SQL Server 2008 Enterprise
SQL Server 2008 Developer1,2 | SQL Server 2008 Workgroup SQL Server 2008 Standard SQL Server 2008 Developer SQL Server 2008 Enterprise
SQL Server 2008 Enterprise1,2 | SQL Server 2008 Enterprise
SQL Server 2008 Enterprise Evaluation2 | SQL Server 2008 Standard SQL Server 2008 Enterprise SQL Server 2008 Enterprise Evaluation
SQL Server 2008 IA64（64 位）Enterprise Evaluation2 | SQL Server 2008 IA64（64 位）Enterprise SQL Server 2008 IA64（64 位）Enterprise Evaluation
SQL Server 2008 x64（64 位）Enterprise Evaluation2 | SQL Server 2008 x64（64 位）Standard SQL Server 2008 x64（64 位）Enterprise SQL Server 2008 x64（64 位）Enterprise Evaluation
SQL Server 2008 IA64（64 位）Developer2 | SQL Server 2008 IA64（64 位）Standard SQL Server 2008 IA64（64 位）Developer SQL Server 2008 IA64（64 位）Enterprise
SQL Server 2008 IA64（64 位）Standard2 | SQL Server 2008 IA64（64 位）Enterprise
SQL Server 2008 x64（64 位）Standard2 | SQL Server 2008 IA64（64 位）Standard SQL Server 2008 IA64（64 位）Enterprise
SQL Server 2008 IA64（64 位）Enterprise2 | SQL Server 2008 IA64（64 位）Enterprise
SQL Server 2008 x64（64 位）Enterprise2 | SQL Server 2008 x64（64 位）Enterprise

1可在 64 位服务器的 32 位子系统 (WOW64) 上将此版本的 SQL Server 升级到 SQL Server 2008。

2对 SQL Server 2008 故障转移群集版本的更改受到限制。SQL Server 2008 故障转移群集不支持以下版本降级方案：

  • 从 SQL Server 2008 Enterprise 降级到 SQL Server 2008 Developer、Standard 或 Enterprise Evaluation。

  • 从 SQL Server 2008 Developer 降级到 SQL Server 2008 Standard 或 Enterprise Evaluation。

  • 从 SQL Server 2008 Standard 降级到 SQL Server 2008 Enterprise Evaluation。

  • 从 SQL Server 2008 Enterprise Evaluation 降级到 SQL Server 2008 Standard。

3不支持对 SQL Server 2000（64 位）IA64 故障转移群集进行升级。

4在故障转移群集上不支持从 SQL Server 2000 Analysis Services 升级到 SQL Server 2008。

5升级 SQL Server 2000（64 位）时将不安装 SQL Server 2008 管理工具。若要安装管理工具，则必须在完成升级之后重新运行安装程序。

升级说明

  • 不支持跨版本的 SQL Server 2008 实例。在同一个 SQL Server 2008 实例中，数据库引擎、Analysis Services 和 Reporting Services 组件的版本号必须相同。

  • 升级到 SQL Server 之前，请先为 SQL Server Agent 启用 Windows 身份验证，并验证默认配置：SQL Server Agent 服务帐户是否是 SQL Server sysadmin 组的成员。

  • 在从 SQL Server 2008 的某一版本升级到另一版本之前，请验证要升级到的版本是否支持当前使用的功能。有关详细信息，请参阅 SQL Server 2008 各个版本支持的功能中的相关组件部分。

  • 不支持跨平台升级。不能将 32 位 SQL Server 实例升级到本机 64 位。但是，如上表所示，可将 SQL Server 的 32 位实例升级到 WOW64，这是 64 位服务器上的 32 位子系统。如果数据库未在复制过程中发布，则还可以从 SQL Server 的 32 位实例中备份或分离数据库，并将它们还原或附加到 SQL Server（64 位）实例。在此情况下，还必须在 master、msdb 和 model 系统数据库中重新创建任何登录名和其他用户对象。

  • 若要升级到 SQL Server 2008，您必须运行的是受支持的操作系统。有关详细信息，请参阅安装 SQL Server 2008 的硬件和软件要求。

  • 如果有挂起的重新启动操作，则会阻止升级。

  • 如果未运行 Windows Installer 服务，则会阻止升级。

  • 如果性能计数器已损坏，则会阻止升级。

  • 若要将 SQL Server 的实例升级至 SQL Server 故障转移群集，则要升级的实例必须是故障转移群集。若要将 SQL Server 的独立实例升级至 SQL Server 故障转移群集，请安装新的 SQL Server 故障转移群集，然后使用复制数据库向导迁移独立实例中的用户数据库。有关升级的详细信息，请参阅如何升级 SQL Server 故障转移群集实例（安装程序）。有关数据库迁移的详细信息，请参阅使用复制数据库向导。

  • 若要在运行 Windows Server 2008 的计算机上将 SQL Server 2005 升级到 SQL Server 2008，则必须运行 SQL Server 2005 SP2。SQL Server 2005 SP1 是不受支持的升级方案。

向 SQL Server 的实例添加组件

在升级到 SQL Server 2008 时，不能向 SQL Server 的现有安装添加组件。在将 SQL Server 实例升级到 SQL Server 2008 之后，可以使用 SQL Server 2008 安装向导（即 Setup.exe）添加功能。

跨语言支持

  • 所有支持的操作系统的本地化版本均支持 SQL Server 英文版。

  • 与 SQL Server 本地化版本使用同一语言的本地化操作系统支持 SQL Server 的本地化版本。

  • SQL Server 的本地化版本可以升级到同一语言的 SQL Server 2008 本地化版本。

  • SQL Server 的本地化版本不能升级到 SQL Server 2008 英文版。

  • SQL Server 的本地化版本不能升级到其他本地化语言的 SQL Server 2008 本地化版本。

  • 通过使用 Windows 多语言用户界面包 (MUI) 设置，支持的操作系统的英文版本也支持 SQL Server 的本地化版本。不过，在运行使用非英文 MUI 设置的英文版操作系统的服务器上安装 SQL Server 的本地化版本之前，必须先检查某些操作系统设置。必须检查以下操作系统设置是否与要安装的 SQL Server 的语言匹配：

    • 操作系统用户界面设置

    • 操作系统用户区域设置

    • 系统区域设置

    如果这些操作系统设置与 SQL Server 本地化版本的语言不匹配，则必须在安装 SQL Server 2008 之前正确设置这些操作系统设置。

请参阅

参考

安装 SQL Server 2008 的硬件和软件要求

概念

计划 SQL Server 安装
升级到 SQL Server 2008
使用升级顾问来准备升级


使用升级顾问来准备升级

使用升级顾问来准备升级 |
 | 请参阅
升级到 SQL Server 2008 >

SQL Server 升级顾问可以帮助您做好升级至 SQL Server 2008 的准备。升级顾问分析早期版本的 SQL Server 中已安装的组件，然后生成报告，指出在升级之前或之后应解决的问题。

升级顾问如何工作

运行升级顾问时，将显示“升级顾问”主页。通过该主页，可以运行以下工具：

  • 升级顾问分析向导

  • 升级顾问报表查看器

  • 升级顾问帮助

第一次使用升级顾问时，应运行升级顾问分析向导来分析 SQL Server 组件。该向导完成分析后，请使用升级顾问报表查看器查看生成的报表。每个报表中均有指向升级顾问帮助信息的链接，这些信息可帮助您修复已知问题或减少已知问题的影响。

升级顾问分析

升级顾问会对以下 SQL Server 组件进行分析：

  • 数据库引擎

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Data Transformation Services

    注意：
    升级顾问不扫描 Notification Services，因为它已从 SQL Server 2008 中删除。

该分析会检查可以访问的对象，例如脚本、存储过程、触发器和跟踪文件。升级顾问不能对桌面应用程序或加密的存储过程进行分析。

输出的格式为 XML 报表。通过使用升级顾问报表查看器可查看 XML 报表。

注意：
报表可能包含有“其他升级问题”项。此项链接至一个问题列表，其中列出的问题是升级顾问未检测到但却可能存在于服务器或应用程序中的问题。应查看无法检测的问题的列表，以确定是否由于这些无法检测的问题而必须更改服务器或应用程序。

如何安装和运行升级顾问

安装 SQL Server 升级顾问的位置取决于您将分析的内容。升级顾问支持对除 Reporting Services 之外的所有受支持组件进行远程分析。如果不扫描 Reporting Services 的实例，则可在能够连接到 SQL Server 实例并满足升级顾问必备条件的任何计算机中安装升级顾问。有关详细信息，请参阅版本升级。如果要扫描 Reporting Services 实例，则必须在报表服务器上安装升级顾问。

可在 SQL Server 安装媒体的 Servers\redist\Upgrade Advisor 文件夹下找到升级顾问，也可从 Microsoft 下载中心下载。

安装和运行升级顾问的前提条件如下：

  • Windows XP SP2 或更高版本、Windows Vista、Windows Server 2003 SP1 或更高版本或者 Windows Server 2008。

  • Windows Installer 4.5 或更高版本。

    .NET Framework 2.0 要求使用 Windows Installer 4.5。可以从此 Windows Installer 网站安装 Windows Installer。

  • .NET Framework 2.0 或更高版本。SQL Server 2005 产品介质和 SDK, redistributable, and service pack download Web site（SDK、可再分发文件和 Service Pack 下载网站）提供了 .NET Framework 2.0。

    • 若要从 SQL Server 2005 介质安装 .NET Framework 2.0，请找到磁盘驱动器的根目录。然后，双击 redist 文件夹，再双击 2.0 文件夹，然后根据您使用的操作系统运行 dotnetfx.exe（适用于 32 位）或 dotnetfx64.exe（适用于 64 位）。

  • 扫描 Analysis Services 中的升级问题时需要使用 SQL Server 2000 决策支持对象 (DSO)。若要安装 DSO，请将 SQL Server 2000 介质插入磁盘驱动器。这将启动 SQL Server 2000 安装程序。单击“安装 SQL Server 2000 组件”。单击 Analysis Services 启动 Analysis Services 安装程序。在“选择组件”中，确保选择了“决策支持对象”组件。

  • 扫描 SQL Server 2000 DTS 包时需要使用 SQL Server 2000 客户端组件。请使用 SQL Server 2000 安装盘安装客户端组件。

  • 扫描从 SQL Server 2000 中迁移而来的 SQL Server 2005 DTS 包时需要 SQL Server 2005 向后兼容组件。请使用 SQL Server 2005 安装盘安装向后兼容组件。

若要通过 Web 安装升级顾问，请单击下载页上的下载按钮。随后可以立即运行安装程序，也可以保存 SQLUA.msi 文件并稍后运行它。如果是从产品光盘进行安装，请直接从产品光盘中运行 SQLUA.msi。

安装升级顾问后，可以从“开始”菜单将其打开：

  • 单击“开始”，依次指向“所有程序”和 Microsoft SQL Server 2008，然后单击“SQL Server 2008 升级顾问”。

有关详细信息，请参阅升级顾问文档和随升级顾问一起安装的升级顾问自述文件。

请参阅

参考

版本升级

概念

使用 SQL Server 的多个版本和实例
向后兼容性


升级数据库引擎时的注意事项

升级数据库引擎时的注意事项 |
 | 请参阅
升级到 SQL Server 2008 >

您可以将 SQL Server 数据库引擎升级到 SQL Server 2008。有关受支持的升级路径的信息，请参阅版本升级。

SQL Server 安装程序只需最少的用户干预就可升级 SQL Server 的早期版本。不过，正确的准备工作和熟悉升级过程可以更容易防止或解决出现的任何问题。

此主题提供了为升级过程进行准备和了解升级过程所需的信息，其中包括：

  • 已知升级问题。

  • 升级前的任务和注意事项。

  • 有关升级数据库引擎的过程主题的链接。

  • 将数据库迁移至 SQL Server 的过程主题的链接。

  • 故障转移群集的注意事项。

  • 升级后的任务和注意事项。

已知升级问题

升级数据库引擎之前，请阅读 SQL Server 数据库引擎的向后兼容性。有关支持的升级方案和已知升级问题的信息，请参阅版本升级。有关其他 SQL Server 组件的向后兼容性的内容，请参阅向后兼容性。

重要提示：
在从 SQL Server 的某一版本升级到另一版本之前，请验证要升级到的版本是否支持当前使用的功能。

升级准备一览表

SQL Server 安装程序支持从早期版本的 SQL Server 进行升级。也可以迁移早期 SQL Server 版本中的数据库。可以从一个 SQL Server 实例迁移至同一台计算机上的另一个实例，也可以从另一台计算机上的 SQL Server 实例迁移。迁移选项包括使用复制数据库向导、备份和还原功能、使用 SQL Server Integration Services 导入和导出向导，以及大容量导出/大容量导入方法。

在升级数据库引擎前，请确保执行下列操作：

  • 阅读安装 SQL Server 2008 的硬件和软件要求。

  • 阅读系统配置检查器的检查参数。

  • 阅读安装 SQL Server 的安全注意事项。

  • 阅读 版本升级。

  • 阅读使用升级顾问来准备升级。

  • 阅读 SQL Server 数据库引擎的向后兼容性。

  • 阅读迁移查询计划。

请在升级 SQL Server 之前检查下列问题并做出更改：

  • 从 64 位版本的 SQL Server 升级到 64 位版本的 SQL Server 2008 时，必须在升级数据库引擎之前先升级 Analysis Services。

  • 如有必要，请备份要升级的实例中的所有 SQL Server 数据库文件，以便可以还原这些文件。

  • 在要升级的数据库上运行适当的数据库控制台命令 (DBCC)，以确保这些数据库处于一致状态。

  • 估计升级 SQL Server 组件以及用户数据库所需的磁盘空间。有关 SQL Server 组件所需磁盘空间的信息，请参阅安装 SQL Server 2008 的硬件和软件要求。

  • 确保将现有的 SQL Server 系统数据库（master、model、msdb 和 tempdb）配置为自动增长，并确保它们具有足够的硬盘空间。

  • 确保所有数据库服务器的 master 数据库中都有登录信息。这对还原数据库很重要，因为 master 数据库中有系统登录信息。

  • 禁用所有启动存储过程，因为升级过程在升级 SQL Server 实例时将停止然后再启动服务。在启动时进行处理的存储过程可能会阻塞升级过程。

  • 停止复制并确保复制日志是空的。

  • 升级 SQL Server 2000 数据库引擎实例的操作会保留最大工作线程数的配置值。但是，建议在升级前将最大工作线程数值更改为 0，以允许数据库引擎计算最佳线程数。有关详细信息，请参阅 SQL Server 联机丛书中的max worker threads 选项。

  • 退出所有应用程序，包括所有依赖 SQL Server 的服务。如果有本地应用程序连接到要升级的实例，则升级可能会失败。

  • 如果使用数据库镜像，请参阅 SQL Server 联机丛书中的如何在升级服务器实例时最大限度地减少镜像数据库的停机时间。

升级数据库引擎

可以用升级版本覆盖 SQL Server 2000 或 SQL Server 2005 安装。如果在运行 SQL Server 安装程序时检测到 SQL Server 的早期版本，将升级所有早期 SQL Server 程序文件，并且保留早期 SQL Server 实例中存储的所有数据。此外，计算机上早期版本的 SQL Server 联机丛书将保持不变。

注意：
在升级 SQL Server 后，早期的 SQL Server 实例将被覆盖，在计算机中不再存在。因此在升级前，请备份 SQL Server 数据库以及与早期的 SQL Server 实例相关的其他对象。

可以使用 SQL Server 安装向导升级数据库引擎。

注意：
如果计算机安装了 SQL Server 2000 管理工具和 SQL Server 2008 的默认实例，则 SQL Server 安装程序将允许您安装 SQL Server 2000 默认实例。但这样做将禁用已安装的 SQL Server 2008 实例。因此，当计算机中已存在 SQL Server 2000 管理工具和 SQL Server 2008 的默认实例时，请不要安装 SQL Server 的默认实例。

升级后的数据库兼容级别

升级后，tempdb、model、msdb 和 Resource 数据库的兼容级别将设置为 100。除非升级前 master 系统数据库的兼容级别低于 80，否则该数据库将保持升级前的兼容级别。如果升级前 master 的兼容级别低于 80，升级后该级别将设置为 80。

如果升级前用户数据库的兼容级别为 80 或 90，升级后将保持相应级别。如果升级前兼容级别为 70 或更低，则在升级后的数据库中，兼容级别将设置为 80，该级别为 SQL Server 2008 支持的最低兼容级别。

注意：
新的用户数据库将继承 model 数据库的兼容级别。

迁移数据库

可以使用 SQL Server 中的备份和还原功能或分离和附加功能将用户数据库移动到 SQL Server 实例。

重要提示：
数据库在源服务器和目的服务器上的名称相同时，不能进行移动或复制。在这种情况下，它被标记为“已存在”。

有关详细信息，请参阅使用复制数据库向导或如何使用复制数据库向导升级 SQL Server。

升级数据库引擎后

升级数据库引擎后，请完成以下任务：

  • 重新注册服务器。有关注册服务器的详细信息，请参阅 SQL Server 联机丛书中的注册服务器。

  • 重新填充全文目录。此操作可以提高 SQL Server 安装的性能。有关详细信息，请参阅 SQL Server 联机丛书中的 sp_fulltext_catalog (Transact-SQL) 主题。

  • 在升级完成后更新所有数据库的统计信息。使用 sp_updatestats 存储过程可以更新 SQL Server 数据库中用户定义的表中的统计信息。

  • 对所有数据库运行 DBCC UPDATEUSAGE 来更正任何不正确的行或页计数。

  • 配置 SQL Server 安装。为了减少系统的可攻击表面积，SQL Server 有选择地安装和启用了一些关键服务和功能。

  • 验证或删除 USE PLAN 提示，这些提示由 SQL Server 2005 生成并应用于对已分区表和索引的查询。

    SQL Server 2008 更改了对已分区表和索引的查询方式。如果已分区对象将 USE PLAN 提示用于 SQL Server 2005 生成的计划，针对这些对象的查询可能会包含不可在 SQL Server 2008 中使用的计划。建议升级到 SQL Server 2008 后，执行下列过程。

    如果在查询中直接指定 USE PLAN 提示：

    1. 从查询删除 USE PLAN 提示。

    2. 测试查询。

    3. 如果优化器未选择相应的计划并优化查询，请考虑使用所需的查询计划指定 USE PLAN 提示。

    如果在计划指南中指定 USE PLAN 提示：

    1. 使用 sys.fn_validate_plan_guide 函数来检查计划指南的有效性。或者，可以使用 SQL Server Profiler 中的 Plan Guide Unsuccessful 事件检查是否存在无效计划。

    2. 如果计划指南无效，则删除该计划指南。如果优化器未选择相应的计划并优化查询，则考虑使用所需查询计划指定 USE PLAN 提示。

    当在计划指南中指定 USE PLAN 提示时，无效的计划将不会导致查询失败。相反，仍可在不使用 USE PLAN 提示的情况下对计划进行编译。有关已分区对象的查询处理的详细信息，请参阅关于已分区表和索引的查询处理增强功能。

在升级前标记为启用或禁用全文的数据库，在升级后也将保持该状态。升级后，将为所有启用全文的数据库自动重新生成并填充全文目录。此项操作既耗时又耗费资源。可以通过运行以下语句暂停全文索引操作：

复制代码
EXEC sp_fulltext_service 'pause_indexing', 1

若要恢复全文索引填充，请运行以下语句：

复制代码
EXEC sp_fulltext_service 'pause_indexing', 0

请参阅

概念

使用 SQL Server 的多个版本和实例
向后兼容性
升级复制数据库时的注意事项


如何使用分离和附加来升级数据库 (Transact-SQL)

如何使用分离和附加来升级数据库 (Transact-SQL) |
 | 请参阅
升级到 SQL Server 2008 > 升级数据库引擎时的注意事项 >

安全说明：
建议您不要从未知或不可信源附加或还原数据库。此类数据库可能包含恶意代码，这些代码可能会执行非预期的 Transact-SQL 代码，或者通过修改架构或物理数据库结构导致错误。使用来自未知源或不可信源的数据库前，请在非生产服务器上针对数据库运行 DBCC CHECKDB，然后检查数据库中的代码，例如存储过程或其他用户定义代码。

在 SQL Server 2008 中，可以使用分离和附加操作将用户数据库从 SQL Server 2000 或 SQL Server 2005 升级。将 SQL Server 2005 或 SQL Server 2000 数据库附加到 SQL Server 2008 后，该数据库将立即变为可用，然后会自动进行升级。

但是，存在下列限制：

  • 不能附加使用 SQL Server 2000 或 SQL Server 2005 创建的 master、model 或 msdb 数据库的副本。

  • 附加复制的而不是分离的复制数据库时：

    • 如果将该数据库附加到同一服务器实例的升级版本中，则必须在附加操作完成后执行 sp_vupgrade_replication 来升级复制数据库。有关详细信息，请参阅 sp_vupgrade_replication (Transact-SQL)。

    • 如果将该数据库附加到不同的服务器实例中（不考虑版本），则必须在附加操作完成后执行 sp_removedbreplication 来删除复制数据库。有关详细信息，请参阅 sp_removedbreplication (Transact-SQL)。

  • 当对从 SQL Server 2000 升级到 SQL Server 2008 的数据库使用 APPLY、PIVOT、TABLESAMPLE 或 UNPIVOT 关键字时，必须将数据库的兼容级别设置为 100。若要设置数据库兼容级别，请参阅 sp_dbcmptlevel (Transact-SQL)。

    重要提示：
    在 SQL Server 2000 Service Pack 3 (SP3) 和 SQL Server 的更高版本中，附加和分离操作可以通过将数据库的 cross db ownership chaining 选项设置为 0 来禁用数据库的跨数据库所有权链接。有关启用链接的信息，请参阅cross db ownership chaining 选项。

全文索引升级选项

注意：
将 SQL Server 2005 或 SQL Server 2000 数据库附加到 SQL Server 2008 后，该数据库将立即变为可用，然后会自动进行升级。如果数据库具有全文索引，升级过程将导入、重置或重新生成它们，具体取决于 upgrade_option 服务器属性的设置。如果将升级选项设置为“导入”(upgrade_option = 2) 或“重新生成”(upgrade_option = 0)，在升级过程中将无法使用全文索引。根据编制索引的数据量，导入可能需要数小时，而重新生成最多可能需要十倍的时间。另请注意，如果将升级选项设置为“导入”，并且全文目录不可用，则会重新生成关联的全文索引。若要更改 upgrade_option 服务器属性的设置，请使用 sp_fulltext_service。

过程

使用分离和附加来升级数据库

  1. 使用 sp_detach_db 存储过程从 SQL Server 7.0 或 SQL Server 2000 实例分离数据库。

    有关详细信息，请参阅该版本 SQL Server 的 SQL Server 联机丛书。

    注意：
    在 SQL Server 2005 中，此存储过程具有新的选项。有关详细信息，请参阅 sp_detach_db (Transact-SQL)。

  2. （可选）移动所分离的数据库文件和日志文件。

    即使希望创建新的日志文件，也应该将日志文件与数据文件一起移动。在某些情况下，重新附加数据库需要使用其现有的日志文件。因此，除非在不使用分离日志文件的情况下可以成功附加数据库，否则，请始终保留所有分离的日志文件。

    注意：
    如果尝试在不指定日志文件的情况下附加数据库，则附加操作将会在日志文件的原始位置中查找文件。如果该位置仍存在日志文件的原始副本，则附加该副本。若要避免使用原始日志文件，请指定新日志文件的路径，或在日志文件复制到新位置之后，删除其原始副本。

  3. 使用带有 FOR ATTACH 或 FOR ATTACH_REBUILD_LOG 选项的 CREATE DATABASE 语句，将复制的文件附加到 SQL Server 2005 实例。

    注意：
    有关如何使用对象资源管理器附加 SQL Server 2005 数据库的信息，请参阅如何附加数据库 (SQL Server Management Studio)。

  4. 建议您对已升级的数据库运行 DBCC UPDATEUSAGE。

    在 SQL Server 的早期版本中，用于表和索引行计数以及页计数的值可能不正确。因此，根据 SQL Server 2005 之前的版本创建的数据库可能包含错误的计数。将数据库升级到 SQL Server 2005 之后，建议您运行 DBCC UPDATEUSAGE 以更正所有无效的计数。此 DBCC 语句可更正表或索引中每个分区的行数、已用页数、保留页数、叶级页数以及数据页数。有关详细信息，请参阅 DBCC UPDATEUSAGE (Transact-SQL)。

  5. （可选）如果是复制数据库（而不是移动数据库），则可以使用 sp_attach_db 或 sp_attach_single_file_db 存储过程重新附加 SQL Server 7.0 或 SQL Server 2000 实例上的原始数据库。

    有关详细信息，请参阅该版本 SQL Server 的 SQL Server 联机丛书。

管理已升级服务器实例上的元数据

将数据库附加到其他服务器实例时，为了给用户和应用程序提供一致的体验，您可能需要在其他服务器实例上为数据库重新创建部分或全部元数据（例如登录名、作业和权限）。有关详细信息，请参阅当数据库在其他服务器实例上可用时管理元数据。

示例

下面的示例通过使用 Transact-SQL 语句分离和附加数据库，将 SQL Server 2000 pubs 数据库升级为 SQL Server 2005 数据库。

  1. 将 SQL Server 2000 查询分析器连接到附加了 pubs 的服务器实例，并使用 sp_detach_db 存储过程分离数据库。

    复制代码
    USE master;
GO
EXEC sp_detach_db @dbname = N'pubs';
GO
  2. 此示例的目的在于，使用您选择的方法将 pubs 文件（pubs.mdf 和 pubs_log.ldf）从 C:\Program Files\Microsoft SQL Server\MSSQL\Data\（这是 SQL Server 2000 中 pubs 的默认位置）复制到 C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\Data\（这是 SQL Server 2005 数据目录）。

    重要提示：
    对于生产数据库，请将数据库和事务日志存放在不同的磁盘上。

    注意：
    请使用远程位置的通用命名约定 (UNC) 名称，通过网络将文件复制到远程计算机上的磁盘中。UNC 名称采用以下格式：\\服务器名称\共享名称\路径\文件名。为了向本地硬盘中写入文件，SQL Server 使用的用户帐户必须被授予在远程磁盘上读取或写入文件所需的权限。

  3. 将复制的 pubs 数据库和（可选的）日志文件附加到 SQL Server 2005 实例（此示例使用相同的数据库名称）。在 SQL Server Management Studio 中，打开新的查询编辑器查询并连接到要附加该数据库的服务器实例。

    注意：
    有关详细信息，请参阅 SQL Server Management Studio 数据库引擎查询编辑器窗口。

    执行以下 CREATE DATABASE 语句。

    复制代码
    USE master;
GO
CREATE DATABASE pubs ON PRIMARY
   (FILENAME =
      'C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\Data\pubs.mdf')
   LOG ON (FILENAME =
      'C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\Data\pubs_log.ldf')
   FOR ATTACH;
GO
    注意：
    在 SQL Server Management Studio 中，新附加的数据库在对象资源管理器中不是立即可见的。若要查看数据库，请单击对象资源管理器窗口，并选择“视图”>“刷新”。如果展开“数据库”节点，新附加的数据库现在就会显示在数据库列表中。

  4. （可选）使用 sp_attach_db 存储过程将原始 pubs 数据库重新附加到 SQL Server 2000 实例。在查询分析器中，输入以下语句：

    复制代码
    USE master;
Go
EXEC sp_attach_db @dbname = N'pubs',
   @filename1 =
      N'c:\Program Files\Microsoft SQL Server\MSSQL\Data\pubs.mdf',
   @filename2 =
      N'c:\Program Files\Microsoft SQL Server\MSSQL\Data\pubs_log.ldf';
GO

请参阅

概念

使用升级顾问来准备升级

其他资源

分离数据库和附加数据库
CREATE DATABASE (Transact-SQL)
如何附加数据库 (SQL Server Management Studio)
如何使用复制数据库向导升级 SQL Server
保护数据和日志文件的安全


全文搜索升级

全文搜索升级 |
 | 请参阅
升级到 SQL Server 2008 > 升级数据库引擎时的注意事项 >

将全文搜索升级到 SQL Server 2008 是在安装期间以及附加、还原或使用复制数据库向导复制 SQL Server 早期版本的数据库文件和全文目录期间执行的。

本主题讨论全文升级的以下方面：

  • 升级服务器实例

  • 全文升级选项

  • 有关选择全文升级选项的注意事项

  • 将数据库升级到 SQL Server 2008 时迁移全文索引

  • 有关将 SQL Server 2005 全文目录还原到 SQL Server 2008 的注意事项

  • 将 SQL Server 2005 数据库附加到 SQL Server 2008

升级服务器实例

对于就地升级，SQL Server 2008 实例将与 SQL Server 的旧版本并行安装，且数据将被迁移。如果 SQL Server 的旧版本安装了全文搜索，则将自动安装新版本的全文搜索。并行安装表示 SQL Server 的实例级存在下列每个组件。

断字符、词干分析器和筛选器

每个实例目前均使用自己的一组断字符、词干分析器和筛选器，而不受这些组件的操作系统版本的限制。而且，这些组件在各个实例级也很容易注册和配置。有关详细信息，请参阅断字符和词干分析器和全文搜索筛选器。

筛选器后台程序宿主

全文筛选器后台程序宿主进程可以安全地加载和驱动用于索引和查询的第三方可扩展组件（例如断字符、词干分析器和筛选器），而不会损害全文引擎的完整性。服务器实例对所有多线程筛选器使用多线程进程，并对所有单线程筛选器使用单线程进程。

注意：
SQL Server 2008 引入了 FDHOST Launcher 服务 (MSSQLFDLauncher) 的服务帐户。该服务将服务帐户信息传播到 SQL Server 特定实例的筛选器后台程序宿主进程。有关设置此服务帐户的信息，请参阅如何设置用于全文搜索的 FDHOST 启动器 (MSSQLFDLauncher) 服务帐户（SQL Server 配置管理器）。

在 SQL Server 2005 和早期版本中，每个全文索引都驻留在属于文件组的全文目录中，它们均具有物理路径，并被视为数据库文件。在 SQL Server 2008 中，全文目录是表示一组全文索引的逻辑概念，即虚拟对象。因此，新的全文目录不会视为带有物理路径的数据库文件。但是，在升级包含数据文件的所有全文目录期间，将在相同磁盘上创建新的文件组。这可以在升级后维护旧磁盘的 I/O 行为。该目录的所有全文索引均被放置到新的文件组中（如果存在根路径）。如果旧的全文目录路径无效，该升级则将全文索引保留在与基表相同的文件组中，或者保留在主文件组中（对于分区表）。

有关 SQL Server 2008 中的全文搜索体系结构的详细信息，请参阅全文搜索的体系结构。

注意：
指定全文目录的 SQL Server 2005 Transact-SQL DDL 语句可正常运行。

全文升级选项

将服务器实例升级到 SQL Server 2008 时，您可以通过用户界面选择以下全文升级选项之一。

导入

导入全文目录。一般情况下，导入速度比重新生成速度要快很多。例如，当仅使用一个 CPU 时，导入的运行速度比重新生成要快 10 倍左右。不过，导入的全文目录不能使用 SQL Server 2008 中引入的新的和增强的断字符，因此最终可能还是要重新生成全文目录。

注意：
重新生成可以以多线程模式运行，如果可用的 CPU 在 10 个以上，且您允许重新生成操作使用所有这些 CPU，则重新生成操作的运行速度可能比导入更快。

如果全文目录不可用，则会重新生成关联的全文索引。此选项仅对 SQL Server 2005 数据库可用。

有关导入全文索引的影响的信息，请参阅本主题后面的“有关选择全文升级选项的注意事项”。

重新生成

使用新的和增强的断字符重新生成全文目录。重新生成索引可能需要一定时间，并且升级后可能需要占用大量的 CPU 和内存。

重置

重置全文目录。将删除 SQL Server 2005 全文目录文件，但会保留全文目录和全文索引的元数据。在进行升级后，所有全文索引将禁用更改跟踪，并且不会自动启动爬网。在升级完成后，目录将保留为空，直至手动执行完全填充。

有关选择全文升级选项的注意事项

为升级选择升级选项时，请考虑以下几点：

  • 如何使用断字符？

    SQL Server 2008 全文搜索服务包括新的断字符和词干分析器。这可能更改早期版本中特定文本模式或方案的全文查询结果。因此，在选择适当的升级选项时，如何使用断字符非常重要：

    • 如果使用的全文语言的断字符在 SQL Server 2008 中未发生更改，或者撤回准确性对您来说并不重要，则适合导入。随后，如果遇到任何撤回问题，您只需通过重新生成全文目录即可升级到新的断字符。有关详细信息，请参阅本部分后面的“断字符和导入的全文索引”。

    • 如果您关心撤回准确性，并使用 SQL Server 2008 中经过改进的断字符之一，则适合重新生成。

  • 是否基于整数全文键列生成了任何全文索引？

    重新生成执行内部优化，在某些情况下该优化可提高升级的全文索引的查询性能。具体来说，如果您具有的全文目录包含基表的全文键列为整数数据类型的全文索引，重新生成将在升级后实现全文查询的理想性能。在这种情况下，强烈建议您使用“重新生成”选项。

    注意：
    对于 SQL Server 2008 中的全文索引，建议采用整数数据类型作为全文键列。有关详细信息，请参阅性能优化（全文搜索）。

  • 使服务器实例处于联机状态的优先级是什么？

    升级期间的导入或重新生成操作会占用很多 CPU 资源，这会延迟其余服务器实例的升级和联机。如果使服务器实例尽快处于联机状态非常重要，并且希望在升级后运行手动填充，则适合使用“重置”。

导入 SQL Server 2005 全文索引后使用新的断字符

导入 SQL Server 2005 全文索引时，一定要认识到，SQL Server 2008 包含 SQL Server 2005 中存在的大多数语言的新断字符。只有英语、朝鲜语、泰语和中文（所有形式）的断字符保持不变。对于其他语言，SQL Server 2008 引入了新一代断字符，这些断字符的行为可能与导入的 SQL Server 2005 全文索引中的 SQL Server 2005 断字符行为稍有不同。

如果全文目录是在将 SQL Server 2005 数据库升级到 SQL Server 2008 时导入的，该全文目录中全文索引使用的一种或多种语言现在可能与新断字符关联。对于这些语言，当查询使用新断字符时，由于旧断字符和新断字符的行为略有差异，因此有时可能会出现查询和全文索引内容不匹配。在这种情况下，若要保证查询和全文索引内容之间的完全匹配，请执行下列操作之一：

  • 重新生成包含全文索引的全文目录 (ALTER FULLTEXT CATALOG catalog_name REBUILD)。

  • 对全文索引执行 FULL POPULATION (ALTER FULLTEXT INDEX ON table_name START FULL POPULATION)。

重要提示：
如果全文目录和索引使用的断字符未发生更改（例如英语断字符），则不会出现不匹配。查询时使用的断字符将与以前编制索引时用于创建索引的断字符和将来查询时所使用的断字符相同。

有关断字符的信息，请参阅断字符和词干分析器。

将干扰词文件升级到非索引字表

SQL Server 2005 干扰词已替换为 SQL Server 2008 非索引字。将数据库从早期版本升级到 SQL Server 2008 时，SQL Server 2008 中将不再使用干扰词文件。然而，旧的干扰词文件存储在 FTDATA\ FTNoiseThresaurusBak 文件夹中，您可以稍后在更新或生成相应的 SQL Server 2008 非索引字表时使用它们。

升级之后：

  • 如果您在 SQL Server 2005 安装中从未添加、修改或删除过任何干扰词文件，则该系统非索引字表应该可以满足您的需要。

  • 如果在 SQL Server 2005 中修改过干扰词文件，则这些修改在升级期间将会丢失。若要重新创建这些更新，必须在对应的 SQL Server 2008 非索引字表中手动重新创建这些修改。有关详细信息，请参阅 ALTER FULLTEXT STOPLIST (Transact-SQL)。

  • 如果不希望将任何非索引字应用于全文索引（例如，如果您在 SQL Server 2005 安装中删除或清除过干扰词文件），则必须关闭每个已升级的全文索引的非索引字表。请运行如下 Transact-SQL 语句（将 database 替换为升级的数据库的名称，并将 table 替换为 table 的名称）：

    复制代码
    Use database;
ALTER FULLTEXT INDEX ON table
   SET STOPLIST OFF;
GO
    STOPLIST OFF 子句删除非索引字筛选，并触发对表的填充，而不会筛选任何视为干扰词的词语。

备份和导入全文目录

对于在升级期间重新生成或重置的全文目录（以及对于新的全文目录），全文目录只是一个逻辑概念，并不驻留在文件组中。因此，若要备份 SQL Server 2008 中的全文目录，必须逐个识别包含目录全文索引的每个文件组并将它们备份。有关详细信息，请参阅备份和还原 SQL Server 2008 全文目录。

对于从 SQL Server 2005 导入的全文目录，该全文目录在其自己的文件组中仍然是数据库文件。在 SQL Server 2008 中除不存在 MSFTESQL 服务以外，全文目录的 SQL Server 2005 备份进程仍然适用。有关 SQL Server 2005 进程的详细信息，请参阅 "Backing Up and Restoring Full-Text Catalogs" in SQL Server 2005 Books Online（SQL Server 2005 联机丛书中的“备份和还原全文目录”）。

注意：
有关备份和还原 SQL Server 2008 数据库的信息，请参阅备份和还原 SQL Server 2008 全文目录。

将数据库升级到 SQL Server 2008 时迁移全文索引

使用附加、还原或复制数据库向导可以将 SQL Server 早期版本中的数据库文件和全文目录升级到现有 SQL Server 2008 服务器实例。导入、重置或重新生成 SQL Server 2005 全文索引（如果有）。重新生成或重置 SQL Server 2000 全文索引（如果有）。upgrade_option 服务器属性控制在升级这些数据库期间服务器实例使用哪个全文升级选项。

将所有 SQL Server 2005 或 SQL Server 2000 数据库附加、还原或复制到 SQL Server 2008 后，该数据库将立即变为可用，然后自动进行升级。导入可能需要数小时，而重新生成可能需要最多十倍于此的时间，具体取决于要编制索引的数据量。另请注意，将升级选项设置为“导入”时，如果全文目录不可用，则会重新生成关联的全文索引。

更改服务器实例的全文升级行为

  • Transact-SQL：使用 sp_fulltext_service 的 upgrade_option 操作

  • SQL Server Management Studio ：使用“服务器属性”对话框的“全文升级选项”。有关详细信息，请参阅如何查看或更改全文搜索的服务器属性 (SQL Server Management Studio)。

有关将 SQL Server 2005 全文目录还原到 SQL Server 2008 的注意事项

将全文数据从 SQL Server 2005 数据库升级到 SQL Server 2008 的其中一种方法是将完整数据库备份还原到 SQL Server 2008。

导入目录时，您可以备份和还原数据库和目录文件。其行为与 SQL Server 2005 中相同：

  • 完整数据库备份将包括全文目录。若要引用全文目录，请使用其 SQL Server 2005 文件名，即 sysft_+catalog-name。

  • 如果全文目录处于脱机状态，备份将失败。

有关备份和还原 SQL Server 2005 全文目录的详细信息，请参阅 SQL Server 2005 联机丛书中的 Backing Up and Restoring Full-Text Catalogs（备份和还原全文目录）和 File Backup and Restore and Full-Text Catalogs （文件备份和还原以及全文目录）。

在 SQL Server 2008 上还原数据库时，将为全文目录创建新的数据库文件。该文件的默认名称是 ftrow_catalog-name.ndf。例如，如果 catalog-name 为 cat1，则 SQL Server 2008 数据库文件的默认名称为 ftrow_cat1.ndf。但是，如果目标目录中已使用该默认名称，新数据库文件则命名为 ftrow_catalog-name{GUID}.ndf，其中 GUID 是新文件的全局唯一标识符。

导入目录后，将更新 sys.database_files 和 sys.master_file 以删除目录项，并将 sys.fulltext_catalogs 中的 path 列设置为 NULL。

备份数据库

  • 完整数据库备份

  • 创建事务日志备份（仅限完整恢复模式）

还原数据库备份

  • 执行数据库完整还原（简单恢复模式）

  • 执行数据库完整还原（完整恢复模式）

注意：
有关还原 SQL Server 2008 全文索引的信息，请参阅段落还原和全文索引。

示例

以下示例在 RESTORE 语句中使用 MOVE 子句，还原名为 ftdb1 的 SQL Server 2005 数据库。SQL Server 2005 数据库、日志和目录文件将被移动到 SQL Server 2008 服务器实例上的新位置，如下所示：

  • 数据库文件 ftdb1.mdf 移动到 C:\Program Files\Microsoft SQL Server\MSSQL.1MSSQL10.MSSQLSERVER\MSSQL\DATA\ftdb1.mdf。

  • 日志文件 ftdb1_log.ldf 移动到日志磁盘驱动器上的日志目录 log_drive:\log_directory\ftdb1_log.ldf 中。

  • 与 sysft_cat90 目录对应的目录文件移动到 C:\temp。导入全文索引后，它们将自动放置在数据库文件 C:\ftrow_sysft_cat90.ndf 中，并删除 C:\temp。

复制代码
RESTORE DATABASE [ftdb1] FROM  DISK = N'C:\temp\ftdb1.bak' WITH  FILE = 1,
   MOVE N'ftdb1' TO N'C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\DATA\ftdb1.mdf',
    MOVE N'ftdb1_log' TO N'log_drive:\log_directory\ftdb1_log.ldf',
    MOVE N'sysft_cat90' TO N'C:\temp';

将 SQL Server 2005 数据库附加到 SQL Server 2008

在 SQL Server 2008 中，全文目录是表示一组全文索引的逻辑概念。全文目录是虚拟对象，并不属于任何文件组。但是，将包含全文目录文件的 SQL Server 2005 数据库附加到 SQL Server 2008 服务器实例时，会将目录文件从其先前位置与其他数据库文件一起附加，这与 SQL Server 2005 中相同。

SQL Server 2008 中附加的每个全文目录的状态与从 SQL Server 2005 分离数据库时相同。如果分离操作挂起任意全文索引填充，该填充将在 SQL Server 2008 上恢复，全文索引随后即可用于全文搜索。

如果 SQL Server 2008 找不到全文目录文件，或者在未指定新位置的情况下在附加操作期间移动全文文件，行为则取决于选择的全文升级选项。如果全文升级选项为“导入”或“重新生成”，则重新生成附加的全文目录。如果全文升级选项为“重置”，则重置附加的全文目录。

有关分离和附加数据库的详细信息，请参阅分离数据库和附加数据库、CREATE DATABASE (Transact-SQL)、sp_attach_db 和 sp_detach_db (Transact-SQL)。

请参阅

其他资源

全文搜索入门
全文引擎
断字符和词干分析器
全文搜索筛选器


迁移查询计划

迁移查询计划 |
 | 请参阅
升级到 SQL Server 2008 > 升级数据库引擎时的注意事项 >

大多数情况下，将数据库升级到 SQL Server 2008 会提高查询性能。 但是，如果您具有已针对性能进行过认真优化的任务关键查询，在升级前最好为每个查询创建一个计划指南，以保留这些查询的查询计划。 如果在升级后，查询优化器为一个或多个查询选择了效率较低的计划，则可以启用这些计划指南并强制查询优化器使用升级前的计划。

若要在升级前创建计划指南，请按照以下步骤执行操作：

  1. 通过使用 sp_create_plan_guide 存储过程并在 USE PLAN 查询提示中指定查询计划来记录每个任务关键查询的当前计划。

  2. 验证计划指南是否适用于此查询。

  3. 将数据库升级到 SQL Server 2008。

    计划保留在升级后的数据库中的计划指南中，如果在升级后计划的性能出现退步，则这些计划将用作后备计划。

    建议您在升级后不要启用计划指南，因为由于统计信息进行了更新，您可能会错过新版本中的更好计划或者重新编译所带来的益处。

  4. 如果在升级后选择了效率较低的计划，可以激活所有计划指南或部分计划指南以取代新计划。

示例

下面的示例显示如何通过创建计划指南来为查询记录升级前的计划。

步骤 1：收集计划

计划指南中记录的查询计划必须采用 XML 格式。 可通过以下方式生成 XML 格式的查询计划：

  • SET SHOWPLAN_XML

  • SET STATISTICS XML

  • 查询 sys.dm_exec_query_plan 动态管理函数的 query_plan 列。

  • SQL Server Profiler Showplan XML、Showplan XML Statistics Profile 和 Showplan XML For Query Compile 事件类。

有关生成和分析查询计划的详细信息，请参阅分析查询。

下面的示例通过查询动态管理视图收集语句 SELECT City, StateProvinceID, PostalCode FROM Person.Address ORDER BY PostalCode DESC; 的查询计划。

复制代码
USE AdventureWorks;
GO
SELECT query_plan
    FROM sys.dm_exec_query_stats AS qs
    CROSS APPLY sys.dm_exec_sql_text(qs.sql_handle) AS st
    CROSS APPLY sys.dm_exec_text_query_plan(qs.plan_handle, DEFAULT, DEFAULT) AS qp
    WHERE st.text LIKE N'SELECT City, StateProvinceID, PostalCode FROM Person.Address ORDER BY PostalCode DESC;%';
GO

步骤 2：创建计划指南以强制实施计划

在计划指南中使用 XML 格式的查询计划（通过上述任一方法获取），将该查询计划作为字符串文字复制并粘贴在 sp_create_plan_guide 的 OPTION 子句中指定的 USE PLAN 查询提示中。

在 XML 计划本身中，先将计划中出现的引号 (') 通过第二个引号进行转义，然后再创建计划指南。 例如，对于包含 WHERE A.varchar = 'This is a string' 的计划，必须通过将该代码修改为 WHERE A.varchar = ''This is a string'' 来进行转义。

下面的示例为步骤 1 中收集的查询计划创建计划指南，并在 @hints 参数中插入此查询的 XML 显示计划。 为简洁起见，此示例中仅包括部分显示计划输出。

复制代码
EXECUTE sp_create_plan_guide
@name = N'Guide1',
@stmt = N'SELECT City, StateProvinceID, PostalCode FROM Person.Address ORDER BY PostalCode DESC;',
@type = N'SQL',
@module_or_batch = NULL,
@params = NULL,
@hints = N'OPTION(USE PLAN N''<ShowPlanXML xmlns=''''http://schemas.microsoft.com/sqlserver/2004/07/showplan''''
    Version=''''0.5'''' Build=''''9.00.1116''''>
    <BatchSequence><Batch><Statements><StmtSimple>
    …
    </StmtSimple></Statements></Batch>
    </BatchSequence></ShowPlanXML>'')';
GO

步骤 3：验证计划指南是否适用于查询

再次运行查询，并检查生成的查询计划。 您应看到该计划与您在计划指南中指定的计划相符。

请参阅

其他资源

sp_create_plan_guide (Transact-SQL)
使用 USE PLAN 查询提示
计划强制方案及示例


如何在升级服务器实例时最大限度地减少镜像数据库的停机时间

如何在升级服务器实例时最大限度地减少镜像数据库的停机时间 |
 | 请参阅
升级到 SQL Server 2008 > 升级数据库引擎时的注意事项 >

本主题介绍如何在将服务器实例从 Microsoft SQL Server 2005 更新到 Microsoft SQL Server 2008 时最大限度地减少镜像数据库的停机时间。此过程包括按顺序升级参与数据库镜像的 SQL Server 2005 实例。这种形式的升级称为“滚动升级”，可将停机时间减少为只进行一次故障转移的时间。请注意，对于镜像服务器与主体服务器在地理位置上有一定距离的高性能模式会话而言，滚动升级可能不适合。

注意：
有关执行滚动升级以安装 Service Pack 或修补程序的信息，请参阅如何在系统上安装 Service Pack 并且尽量缩短镜像数据库停机时间。

滚动升级是包含以下阶段的一个多阶段过程：

  • 保护数据。

  • 如果会话包括见证服务器，建议您删除见证服务器。否则，在升级镜像服务器实例时，数据库的可用性将取决于仍然连接至主体服务器实例的见证服务器。删除见证服务器之后，可以在滚动升级过程中随时对其进行升级，而不会有数据库停机的风险。

    注意：
    有关详细信息，请参阅仲裁：见证服务器如何影响数据库可用性。

  • 如果会话在高性能模式下运行，则将运行模式更改为高安全模式。

  • 升级数据库镜像中涉及的每个服务器实例。滚动升级包括升级当前作为镜像服务器的服务器实例，对其每个镜像数据库进行手动故障转移以及升级最初作为主体服务器（现在作为新镜像服务器）的服务器实例。此时，必须继续镜像。

    注意：
    在开始滚动升级之前，建议您至少对一个镜像会话执行实际手动故障转移。

  • 如有必要，恢复为高性能模式。

  • 如有必要，将见证服务器返回镜像会话。

下面将介绍各个阶段的过程。

重要提示：
在并发镜像会话中，一个服务器实例可能扮演不同的镜像角色（主体服务器、镜像服务器或见证服务器）。在这种情况下，必须相应地调整基本滚动升级过程。有关详细信息，请参阅数据库镜像会话。

在升级之前保护数据（最佳做法）

  1. 对每个主体数据库执行完整数据库备份。

    备份数据库

    • 如何备份数据库 (SQL Server Management Studio).

    • 如何创建完整数据库备份 (Transact-SQL)

  2. 对每个主体数据库运行 DBCC CHECKDB 命令。

从会话中删除见证服务器

  1. 如果镜像会话包括见证服务器，则建议您在执行滚动升级之前删除该见证服务器。

    删除见证服务器

    • 如何从数据库镜像会话中删除见证服务器 (SQL Server Management Studio)

    • 如何从数据库镜像会话中删除见证服务器 (Transact-SQL)

将会话从高性能模式更改为高安全模式

  1. 如果镜像会话在高性能模式下运行，则在执行滚动升级之前，将运行模式更改为不带自动故障转移功能的高安全模式。使用下列方法之一：

    • 在 SQL Server Management Studio 中：使用“数据库属性”对话框的“镜像”页将“运行模式”选项更改为“不带自动故障转移功能的高安全(同步)”。有关如何访问此页的信息，请参阅如何启动配置数据库镜像安全向导 (SQL Server Management Studio)。

    • 在 Transact-SQL 中：将事务安全设置为 FULL。有关详细信息，请参阅如何更改数据库镜像会话中的事务安全 (Transact-SQL)。

      注意：
      有关详细信息，请参阅 Transact-SQL 设置和数据库镜像运行模式。

执行滚动升级

  1. 为了最大限度地减少停机时间，我们建议：通过更新任何当前在其所有镜像会话中均为镜像服务器的镜像伙伴开始滚动升级。此时，可能需要更新多个服务器实例。

    注意：
    在滚动升级过程中可以随时升级见证服务器。例如，如果某个服务器实例在会话 1 中为镜像服务器，在会话 2 中为见证服务器，则可以立即升级此服务器实例。

    要首先升级的服务器实例是由镜像会话的当前配置决定的，如下所示：

    • 如果任何服务器实例在其所有镜像会话中均已为镜像服务器，则将此服务器实例升级为新版本。

    • 如果在任何镜像会话中所有服务器实例当前都是主体服务器，则选择一个要首先升级的服务器实例。然后，对其每个主体数据库进行手动故障转移并升级该服务器实例。

    升级完成后，服务器实例将自动重新加入其每个镜像会话。

    执行手动故障转移

    • 如何手动故障转移数据库镜像会话 (SQL Server Management Studio)

    • 如何手动故障转移数据库镜像会话 (Transact-SQL).

    有关手动故障转移工作原理的信息，请参阅手动故障转移。

  2. 对于其镜像服务器实例刚完成升级的每个镜像会话，请等待会话进行同步。然后，连接到主体服务器实例并手动故障转移会话。故障转移后，已升级的服务器实例成为该会话的主体服务器，而以前的主体服务成为镜像服务器。

    此步骤的目的是让其他服务器实例在其作为伙伴的每个镜像会话中成为镜像服务器。

    在出现故障时转移到已升级的服务器实例后的限制。

    在 SQL Server 2005 服务器实例出现故障时转移到 SQL Server 2008 服务器实例后，数据库会话将挂起。直到升级完其他伙伴后，此会话才能继续。但主体服务器仍然接受连接，并允许对主体数据库进行数据访问和修改。

    注意：
    如果建立新镜像会话，则要求所有服务器实例运行相同版本的 SQL Server。

  3. 故障转移后，建议对主体数据库运行 DBCC CHECKDB 命令。

  4. 升级在其作为伙伴的所有镜像会话中目前为镜像服务器的每个服务器实例。此时，可能需要更新多个服务器。

    重要提示：
    在复杂的镜像配置中，某服务器实例在一个或多个镜像会话中可能仍作为原始主体服务器。对这些服务器实例重复步骤 2-4，直至涉及的所有实例均已升级。

  5. 继续镜像会话。

    注意：
    升级完见证服务器后，自动故障转移功能才会起作用。

  6. 升级在其所有镜像会话中为见证服务器的任何剩余服务器实例。在已升级的见证服务器重新加入镜像会话之后，自动故障转移功能将重新变为可用。此时，可能需要更新多个服务器。

将会话恢复为高性能模式

  1. 可以选择使用下列方法之一返回高性能模式：

    • 在 SQL Server Management Studio 中：使用“数据库属性”对话框的“镜像”页将“运行模式”选项更改为“高性能(异步)”。

    • 在 Transact-SQL 中：使用 ALTER DATABASE 将事务安全设置为 OFF。

将见证服务器返回镜像会话

  1. 在高安全模式下，可以选择让见证服务器重新回到每个镜像会话中。

    返回见证服务器

    • 如何添加或替换数据库镜像见证服务器 (SQL Server Management Studio)

    • 如何使用 Windows 身份验证添加数据库镜像见证服务器 (Transact-SQL)

请参阅

其他资源

ALTER DATABASE 数据库镜像 (Transact-SQL)
BACKUP (Transact-SQL)
如何查看镜像数据库的状态 (SQL Server Management Studio)
数据库镜像概述
同步数据库镜像（高安全性模式）
如何在系统上安装 Service Pack 并且尽量缩短镜像数据库停机时间
数据库镜像会话期间的角色切换
数据库镜像会话
强制服务（可能造成数据丢失）
如何启动数据库镜像监视器
异步数据库镜像（高性能模式）


将 SQL Server 2005 日志传送升级到 SQL Server 2008

将 SQL Server 2005 日志传送升级到 SQL Server 2008 |
 | 请参阅
升级到 SQL Server 2008 > 升级数据库引擎时的注意事项 >

从 SQL Server 2005 升级到 SQL Server 2008 时有可能保留日志传送配置。本主题介绍升级日志传送配置的备用方案和最佳实践。

注意：
SQL Server 2008 Enterprise 中引入了备份压缩。升级后的日志传送配置使用备份压缩默认的服务器级配置选项控制是否对事务日志备份文件使用备份压缩。可以为每个日志传送配置指定日志备份的备份压缩行为。有关详细信息，请参阅如何启用日志传送 (SQL Server Management Studio)。

在升级前保护好您的数据

建议您最好在日志传送升级之前保护好您的数据。

保护数据

  1. 对各个主数据库执行完整数据库备份。

    有关详细信息，请参阅：

    • 如何备份数据库 (SQL Server Management Studio).

    • 如何创建完整数据库备份 (Transact-SQL)

    • BACKUP (Transact-SQL)

  2. 对各个主数据库运行 DBCC CHECKDB 命令。

升级监视服务器实例

监视服务器实例（如果存在）可随时升级。

升级监视服务器时，日志传送配置仍将有效，但其状态不会记录在监视器上的表中。监视服务器正在升级期间，已配置的任何警报都不会触发。升级完毕后，可以通过执行 sp_refresh_log_shipping_monitor (Transact-SQL) 系统存储过程来更新监视器表中的信息。

对具有单一辅助服务器的配置进行升级的过程

本节讲述的升级过程适用于由主服务器和唯一一个辅助服务器组成的配置。下图显示了此配置，其中 A 为主服务器实例，B 为单一辅助服务器实例。

有关升级多个辅助服务器的信息，请参阅本主题后面的“升级多个辅助服务器的注意事项”。

升级辅助服务器实例

升级主服务器实例之前的升级过程包括将辅助服务器实例的日志传送配置从 SQL Server 2005 升级到 SQL Server 2008。辅助服务器实例必须总是先于主服务器实例升级。由于在较新版本的 SQL Server 中创建的备份无法在较旧版本的 SQL Server 中还原，所以如果主服务器先于辅助服务器升级，将导致日志传送失败。

由于升级后的辅助服务器继续还原 SQL Server 2005 主服务器的日志备份，因此日志传送在整个升级过程中都不间断。升级辅助服务器实例的过程部分取决于日志传送配置是否具有多个辅助服务器。有关详细信息，请参阅本主题后面的“升级多个辅助服务器实例的注意事项”。

辅助服务器实例正在升级期间，日志传送复制和还原作业不运行，因此未还原的事务日志备份将累积。累积的数量取决于主服务器上进行计划备份的频率。此外，如果还配置了单独的监视服务器，则若未执行还原的时间超过了所配置的时间间隔，就会引发警报。

辅助服务器升级完毕后，日志传送代理作业即开始继续复制和还原主服务器实例（服务器 A）的日志备份。辅助服务器使辅助数据库达到最新所需的时间会有所不同，具体情况取决于升级辅助服务器占用的时间和主服务器上进行备份的频率。

注意：
服务器升级期间，辅助数据库不会升级到 SQL Server 2008 数据库。只有联机时它才会升级。

升级主服务器实例

计划升级时，需要考虑的一个重要事项是数据库将处于不可用状态的时间。最简单的升级方案（下文的方案 1）将使得数据库在主服务器升级期间不可用。

如果能在升级原始主服务器之前将 SQL Server 2005 主服务器故障转移到 SQL Server 2008 辅助服务器（下文的方案 2），则可以最大限度地提高数据库的可用性，但这样做会加大升级过程的复杂程度。故障转移方案有两种不同的形式。一种是切换回原始主服务器并保持原始日志传送配置。另一种是在升级原始主服务器之前删除原始日志传送配置，随后使用新的主服务器创建新配置。上述各个方案在本主题中都有介绍。

重要提示：
一定要先升级辅助服务器实例，然后再升级主服务器实例。有关详细信息，请参阅本主题前面的“升级辅助服务器实例”。

方案 1：不借助故障转移升级主服务器实例

这个方案比较简单，但导致的停机时间要比使用故障转移时间长。主服务器实例进行简单的升级，数据库在升级期间不可用。

服务器升级完毕后，数据库即自动回到联机状态，随即进行升级。数据库升级完毕后，日志传送作业将继续进行。

方案 2：借助故障转移升级主服务器实例

此方案最大限度地提高了可用性，同时使停机时间降低到最短。此方案采取向辅助服务器实例实行受控故障转移的方式，使数据库在原始主服务器实例升级期间保持可用状态。停机时间限于故障转移所需的相对短的时间，而不是升级主服务器实例所需的时间。

借助故障转移升级主服务器实例一般需要三个过程：执行到辅助服务器的受控故障转移，将原始主服务器实例升级到 SQL Server 2008，在 SQL Server 2008 主服务器实例上设置日志传送。本节后面将对这三个过程进行介绍。

重要提示：
如果计划使辅助服务器实例成为新的主服务器实例，则需要删除日志传送配置。原始主服务器实例升级完毕后，需要重新配置从新的主服务器实例到新的辅助服务器实例的日志传送。有关详细信息，请参阅删除日志传送。
过程 1. 执行到辅助服务器的受控故障转移

到辅助服务器的受控故障转移：

  1. 对于指定 WITH NORECOVERY 的主数据库上的事务日志，手动执行结尾日志备份。此日志备份捕获任何尚未备份的日志记录并使数据库脱机。请注意：数据库脱机期间，日志传送备份作业将失败。

    下面的示例在主服务器上创建 AdventureWorks 数据库的一个结尾日志备份。此备份文件名为 Failover_AdventureWorks_20080315.trn：

    复制代码
    BACKUP LOG AdventureWorks
   TO DISK = N'\\FileServer\Log Shipping\AdventureWorks\Failover_AdventureWorks_20080315.trn'
   WITH NORECOVERY;
GO
    建议您使用非重复的文件命名约定区分手动创建的备份文件和日志传送备份作业创建的备份文件。

  2. 在辅助服务器上：

    1. 确保日志传送备份作业自动进行的所有备份都已应用。若要检查哪些备份作业已应用，请使用监视服务器或主服务器和辅助服务器上的 sp_help_log_shipping_monitor (Transact-SQL) 系统存储过程。同一文件应在 last_backup_file、last_copied_file 和 last_restored_file 这三列中列出。如果尚未复制和还原任何备份文件，则请手动调用代理复制和还原作业以进行日志传送配置。有关详细信息，请参阅如何启动作业 (SQL Server Management Studio) 或 sp_start_job (Transact-SQL)。

    2. 将您在第一步中创建的最后一个日志备份文件从文件共享复制到辅助服务器上的日志传送使用的本地位置。

    3. 还原指定 WITH RECOVERY 的最后一个日志备份以使数据库联机。数据库联机的同时将升级到 SQL Server 2008。

      下面的示例还原辅助数据库中的 AdventureWorks 数据库的结尾日志备份。此示例使用 WITH RECOVERY 选项，该选项将使数据库联机：

      复制代码
      RESTORE LOG AdventureWorks
   FROM DISK = N'c:\log shipping\Failover_AdventureWorks_20080315.trn'
   WITH RECOVERY;
GO
      注意：
      对于包含多个辅助服务器的配置，还有额外的注意事项。有关详细信息，请参阅本主题后面的“升级多个辅助服务器实例的注意事项”。

    4. 将客户端从原始主服务器（服务器 A）重定向到联机辅助服务器（服务器 B），以对数据库进行故障转移。

    5. 请注意：辅助数据库在处于联机状态时，它的事务日志并未填满。若要阻止事务日志填满，可能需要备份此日志。如果是这样，建议您将它备份到共享位置，即备份到“备份共享”，以便在其他服务器实例上可以还原这些备份。

过程 2. 将原始主服务器实例升级到 SQL Server 2008

将原始主服务器实例升级到 SQL Server 2008 后，数据库仍将处于脱机状态且仍采用 SQL Server 2005 格式。

过程 3. 在 SQL Server 2008 上设置日志传送

剩余的升级过程取决于是否仍配置日志传送，如下所述：

  • 如果保留了 SQL Server 2005 日志传送配置，则请切换回原始主服务器实例。有关详细信息，请参阅本节后面的“切换回原始主服务器实例”。

  • 如果在进行故障转移之前删除了日志传送配置，则请创建一个新的日志传送配置，其中原始辅助服务器实例是新的主服务器实例。有关详细信息，请参阅本节后面的“将原来的辅助服务器实例作为新的主服务器实例”。
切换回原始主服务器实例
  1. 在临时主服务器（服务器 B）上使用 WITH NORECOVERY 备份日志的尾部，以创建结尾日志备份并使数据库脱机。该结尾日志备份命名为 Switchback_AdventureWorks_20080315.trn。例如：

    复制代码
    BACKUP LOG AdventureWorks
   TO DISK = N'\\FileServer\Log Shipping\AdventureWorks\Switchback_AdventureWorks_20080315.trn'
   WITH NORECOVERY;
GO
  2. 如果任何事务日志备份都是在临时主数据库上进行的，则将那些使用 WITH NORECOVERY 的日志备份（不包括在第一步中创建的结尾备份）还原到原始主服务器（服务器 A）上的脱机数据库。第一个日志备份还原后，数据库即升级到 SQL Server 2008 格式。

  3. 在原始主数据库上（即在服务器 A 上）使用 WITH RECOVERY 还原结尾日志备份 Switchback_AdventureWorks_20080315.trn，从而使数据库联机。

  4. 将客户端从原始主服务器重定向到联机辅助服务器，从而故障转移回原始主数据库（位于服务器 A 上）。

数据库联机后，原始日志传送配置将恢复。

将原来的辅助服务器实例作为新的主服务器实例

按照下面所述建立新的日志传送配置，其中原来的辅助服务器实例 B 用作主服务器，而原来的主服务器实例 A 用作新的辅助服务器：

重要提示：
在此过程开始时且在进行使数据库脱机的手动事务日志备份之前，应该已从原始主服务器上删除原来的日志传送配置。

  1. 若要避免对新的辅助服务器（服务器 A）上的数据库执行完整的备份和还原，请将新的主数据库的日志备份应用到新的辅助数据库。在示例配置中，这包括将在服务器 B 上进行的日志备份还原到服务器 A 上的数据库。

  2. 备份新的主数据库（位于服务器 B 上）的日志。

  3. 使用 WITH NORECOVERY 将日志备份还原到新的辅助服务器实例（服务器 A）。第一个还原操作将数据库升级到 SQL Server 2008。

  4. 配置日志传送，使原来的辅助服务器（服务器 B）作为主服务器实例。

    重要提示：
    如果使用 SQL Server Management Studio，请指定辅助数据库已初始化。

    配置日志传送

    • 如何启用日志传送 (SQL Server Management Studio)

    • 如何启用日志传送 (Transact-SQL)

  5. 将客户端从原始主服务器（服务器 A）重定向到联机辅助服务器（服务器 B），以对数据库进行故障转移。

    重要提示：
    故障转移到新的主数据库时，应确保其元数据与原始主数据库的元数据一致。有关详细信息，请参阅当数据库在其他服务器实例上可用时管理元数据。

升级多个辅助服务器实例的注意事项

下图显示了此配置，其中 A 为主服务器实例，B 和 C 都是辅助服务器实例。

必须先对所有辅助服务器实例进行升级，然后再升级主服务器。

借助故障转移进行升级并切换回原始主服务器

如果有多个辅助服务器实例，则借助故障转移升级主实例的过程将更加复杂。在下面的过程中，所有辅助服务器升级完毕后，主服务器故障转移到其中一个已升级的辅助数据库。原始主服务器得到升级，且日志传送重新故障转移到它。

  1. 升级全部辅助服务器实例（服务器 B 和服务器 C）。

  2. 获取主数据库（位于服务器 A 上）的事务日志的尾部，并使用 WITH NORECOVERY 备份此事务日志，以使该数据库脱机。

  3. 通过使用 WITH RECOVERY 还原日志备份，使您计划故障转移到的辅助服务器（服务器 B）上的辅助数据库联机。

  4. 在所有其他辅助服务器（服务器 C）上，通过使用 WITH NORECOVERY 还原日志备份，使辅助数据库仍处于脱机状态。

    注意：
    日志传送复制和还原作业将在辅助服务器上运行，但由于新的日志备份文件不会放在备份共享中，因此这些作业不执行任何操作。

  5. 将客户端从原始主服务器（服务器 A）重定向到联机辅助服务器（服务器 B），以对数据库进行故障转移。联机数据库将成为临时主服务器，从而保持该数据库在原始主服务器（服务器 A）脱机期间仍可用。

  6. 升级原始主服务器（服务器 A）。

  7. 在已故障转移到的数据库（即服务器 B 上的临时主数据库）上，使用 WITH NORECOVERY 手动备份事务日志。这将使该数据库脱机。

  8. 将使用 WITH NORECOVERY 在临时主数据库（位于服务器 B 上）上创建的所有事务日志备份还原到所有其他辅助数据库（位于服务器 C 上）。从而在原始主数据库升级后，可以继续从其进行日志传送，而无需对每个辅助数据库进行完全的数据库还原。

  9. 使用 WITH RECOVERY 将临时主服务器（服务器 B）上的事务日志还原到的原始主数据库（位于服务器 A 上）。

重新部署日志传送

如果不想使用上述过程之一迁移日志传送配置，可以通过使用主数据库的完整备份和恢复来重新初始化辅助数据库，从而从头开始重新部署日志传送。如果数据库较小，或者在升级过程中高可用性并不是至关重要的，此方法将是个不错的选择。

有关使用 SQL Server Management Studio 启用日志传送的信息，请参阅如何启用日志传送 (SQL Server Management Studio)。

有关使用 Transact-SQL 启用日志传送的信息，请参阅如何启用日志传送 (Transact-SQL)。

请参阅

概念

将 SQL Server 2000 日志传送配置迁移到 SQL Server 2008

其他资源

使用事务日志备份
日志传送管理
日志传送表和存储过程


将 SQL Server 2000 日志传送配置迁移到 SQL Server 2008

将 SQL Server 2000 日志传送配置迁移到 SQL Server 2008 |
 | 请参阅
升级到 SQL Server 2008 > 升级数据库引擎时的注意事项 >

不能将 SQL Server 2000 日志传送配置升级到 SQL Server 2008。数据库维护计划向导是 SQL Server 2000 中日志传送的组成部分，不再用作 SQL Server 2005 及更高版本中日志传送配置的一部分。因此，将服务器升级到 SQL Server 2008 之后，日志传送将无法正常工作。

您可以迁移 SQL Server 2000 日志传送配置。本主题介绍执行此操作的方法：

  • 执行带故障转移的迁移可以在升级日志传送配置中的每个服务器时保持数据库的可用性。辅助数据库不需要重新初始化。

  • 执行不带故障转移的迁移是一个比较简单的过程，在此过程中无需故障转移到辅助服务器。如果执行此过程，则数据库在升级主服务器时不可用。辅助数据库不需要重新初始化。

  • 完全重新部署日志传送，包括从一个完整备份中重新初始化辅助数据库。

将日志传送配置迁移到 SQL Server 2008 后，就可以删除由 SQL Server 2000 日志传送创建的表和 SQL Server 代理作业。

注意：
SQL Server 2008 Enterprise 中引入了备份压缩。升级后的日志传送配置使用备份压缩默认的服务器级配置选项控制是否对事务日志备份文件使用备份压缩。可以为每个日志传送配置指定日志备份的备份压缩行为。有关详细信息，请参阅如何启用日志传送 (SQL Server Management Studio)。

执行带故障转移的迁移

执行带故障转移的迁移将在升级辅助服务器实例期间将主服务器实例暂时保留为 SQL Server 原始版本的实例。升级服务器实例仅会升级联机数据库。脱机数据库（例如日志传送辅助数据库）仍然是 SQL Server 原始版本的数据库。只要数据库保持脱机状态，就可以还原 SQL Server 原始版本的日志备份。

为清晰起见，本过程将 SQL Server 2000 日志传送主服务器实例称为服务器 A，将 SQL Server 2000 日志传送辅助服务器实例称为服务器 B。下图显示了此配置，其中 A 为主服务器实例，B 为单一辅助服务器实例。

  1. 将辅助服务器实例 Server B 升级到 SQL Server 2008。升级 Server B 后，日志传送数据库仍然是 SQL Server 2000 数据库，因为它处于脱机状态。此数据库将在下一步升级。复制和还原日志文件的 SQL Server 2000 日志传送作业将不再起作用。

    注意：
    此时，用户可以继续访问 Server A 上的主数据库。

  2. 从主服务器实例（服务器 A）到辅助服务器实例（服务器 B）的故障转移。

    1. 若要进行故障转移，请将服务器 A 上的主数据库中所有尚未应用的事务日志备份还原到服务器 B。

    2. 对于指定 WITH NORECOVERY 的主数据库上的事务日志，手动执行结尾日志备份。此日志备份捕获任何尚未备份的日志记录并使数据库脱机。

      下面的示例在主服务器上备份 AdventureWorks 数据库的日志结尾。此备份文件名为 Failover_AdventureWorks_20080315.trn：

      复制代码
      BACKUP LOG AdventureWorks
   TO DISK = N'\\FileServer\Log Shipping\AdventureWorks\Failover_AdventureWorks_20080315.trn'
   WITH NORECOVERY;
GO
    3. 通过使用 WITH RECOVERY 还原事务日志结尾，使服务器 B 上的辅助数据库联机。

    故障转移过程使辅助数据库联机，之后将自动升级到 SQL Server 2008 数据库。数据库升级过程将被完整地记录下来。

    注意：
    升级 Server B 上的日志传送数据库后，用户即可使用该数据库。但是，除非已在服务器 B 上配置 SQL Server 2008 日志传送，否则不会采用来自服务器 B 上的数据库的日志备份。

  3. 将 Server A 升级到 SQL Server 2008。日志传送数据库临时保持为 SQL Server 2000 数据库，因为它处于脱机状态。

  4. 在 Server B 上配置 SQL Server 2008 日志传送，将 Server B 作为主服务器，而将 Server A 作为辅助服务器。开始向 Server A 传送事务日志后，当应用了第一个日志备份时，Server A 上的日志传送数据库将升级为 SQL Server 2008 数据库。

    重要提示：
    在 Server B 上配置日志传送时，请确保在“辅助数据库设置”对话框的“初始化辅助数据库”选项卡上指定“否，辅助数据库已初始化”选项。有关详细信息，请参阅如何启用日志传送 (SQL Server Management Studio)。

  5. （可选）若要使 Server A 重新成为主服务器，则故障转移到 Server A。有关详细信息，请参阅交换主服务器和辅助服务器的角色。

执行不带故障转移的迁移

可以将 SQL Server 2000 日志传送配置迁移到 SQL Server 2005，而无需使用故障转移。执行此过程可以轻松地同时升级日志传送配置中的两个服务器实例。但是，在将主服务器实例升级到 SQL Server 2008 时，主数据库不可用。

  1. 将辅助服务器实例升级到 SQL Server 2008。升级辅助服务器实例后，日志传送数据库仍然是 SQL Server 2000 数据库，因为它处于脱机状态。复制和还原日志文件的 SQL Server 2000 日志传送作业将不再起作用。

  2. 将主服务器升级到 SQL Server 2008。在升级过程中，主服务器不可用。

  3. 配置从主服务器实例到辅助服务器实例的日志传送。请确保在“辅助数据库设置”对话框的“初始化辅助数据库”选项卡上指定“否，辅助数据库已初始化”选项。有关详细信息，请参阅如何启用日志传送 (SQL Server Management Studio)。

    重要提示：
    指定 SQL Server 2000 日志传送配置所使用的同一备份共享。这样可确保在 SQL Server 2008 中启用日志传送时，所有日志备份都能正确地应用于辅助数据库。

    由于数据库升级进程是一个完整记录的操作，因此当开始向辅助服务器实例传送日志后，辅助数据库将升级为 SQL Server 2008 数据库。

重新部署日志传送

如果不想迁移日志传送配置，可以通过使用主数据库的完整备份和恢复来重新初始化辅助数据库，从而从头开始重新部署日志传送。如果数据库较小，或者在升级过程中高可用性并不是至关重要的，此方法将是个不错的选择。

启用日志传送

  • 如何启用日志传送 (SQL Server Management Studio).

  • 如何启用日志传送 (Transact-SQL).

删除 SQL Server 2000 日志传送表和作业

SQL Server 2008 不会使用 SQL Server 2000 所使用的任何日志传送表。因此，将服务器升级到 SQL Server 2008 之后，可以删除这些表。这些表包括：

  • log_shipping_databases

  • log_shipping_monitor

  • log_shipping_plan_databases

  • log_shipping_plan_history

  • log_shipping_plans

  • log_shipping_primaries

  • log_shipping_secondaries

还可以删除由 SQL Server 2000 为日志传送配置创建的任何日志传送 SQL Server 代理作业。

请参阅

概念

将 SQL Server 2005 日志传送升级到 SQL Server 2008

其他资源

使用事务日志备份
日志传送管理
日志传送表和存储过程


升级 Analysis Services 时的注意事项

升级 Analysis Services 时的注意事项 |
 | 请参阅
升级到 SQL Server 2008 >

升级通常由 SQL Server 安装程序执行。SQL Server 安装程序可用于升级其任意组件或所有组件（包括 Analysis Services）。

本主题着重说明了升级 Analysis Services 前应该了解的重要注意事项。有关如何启动安装程序以及如何选择要升级的组件的分步说明，请参阅升级到 SQL Server 2008。有关升级 Analysis Services 的命令行选项的信息，请参阅Installing SQL Server from the Command Prompt。

重要提示：
若要了解哪些 Analysis Services 特性和功能已废弃、不推荐使用或已更改，请参阅 SQL Server Analysis Services 的向后兼容性。

已知升级问题

升级到 SQL Server 2008 Analysis Services 之前，请先查看 SQL Server 2008 中 Analysis Services 功能的重大更改。还建议您按使用升级顾问来准备升级中所述运行升级顾问。

升级前的检查表

升级到 SQL Server 2008 Analysis Services 之前，请先检查以下要求：

  • 安装 SQL Server 2008 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

  • 使用升级顾问来准备升级

从 SQL Server 2005 Analysis Services 升级

可以将 SQL Server 2005 Analysis Services 的现有实例升级到 SQL Server 2008 Analysis Services，并且作为升级过程的一部分，还可以将现有数据库从旧实例自动迁移到新实例。因为元数据和二进制数据在两个版本之间兼容，因此升级之后您可以保留该数据而不必手动迁移该数据。若要升级 SQL Server 2005 Analysis Services 的现有实例，请运行安装程序并将现有实例的名称指定为新实例的名称。有关详细信息，请参阅如何升级 Analysis Services 实例。

从 SQL Server 2000 Analysis Services 升级

在从 SQL Server 2000 Analysis Services 升级到 SQL Server 2008 Analysis Services 时，因为对基本体系结构进行了更改，所以最好分两步执行升级。首先，将 SQL Server 2008 Analysis Services 与 SQL Server 2000 Analysis Services 并行安装。接下来，使用 Analysis Services 迁移向导将 SQL Server 2000 Analysis Services 数据库迁移到 SQL Server 2008 Analysis Services 格式。Analysis Services 迁移向导将 SQL Server 2000 Analysis Services 数据库元数据迁移到 SQL Server 2008 Analysis Services 并以 SQL Server 2008 Analysis Services 格式重新创建数据库结构，同时保持原始数据不变。有关详细信息，请参阅如何将 Analysis Services 与早期版本并行安装和迁移现有 Analysis Services 数据库。

如果迁移 SQL Server 2000 Analysis Services 的数据库后，删除其默认实例，则可使用 Analysis Services 实例重命名工具使 SQL Server 2008 Analysis Services 的命名实例成为服务器上的默认实例。有关详细信息，请参阅如何重命名 Analysis Services 实例。

升级 SQL Server 2000 Analysis Services

  1. 使用 SQL Server 安装向导或其他安装方法，安装 SQL Server 2008 Analysis Services 的命名实例。有关详细信息，请参阅Considerations for Installing Analysis Services或Installing SQL Server from the Command Prompt。

  2. 使用 Analysis Services 迁移向导将 SQL Server 2000 Analysis Services 数据库元数据迁移到 SQL Server 2008 Analysis Services。此步骤将以 SQL Server 2008 Analysis Services 数据库格式重新创建数据库结构，同时保持原始数据库不变。有关详细信息，请参阅迁移现有 Analysis Services 数据库。

  3. 处理新的 SQL Server 2008 Analysis Services 数据库。此步骤会在新的数据库结构中填充数据。有关详细信息，请参阅处理 Analysis Services 对象。

  4. 验证数据库升级的处理情况。在 SQL Server Management Studio 中检查已升级的数据库，并且使用客户端应用程序测试这些数据库。

  5. 如果不再需要早期版本的 Analysis Services，则将其卸载。

请参阅

概念

安装 Analysis Services 时的注意事项


迁移现有 Analysis Services 数据库

迁移现有 Analysis Services 数据库 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Analysis Services 时的注意事项 >

您可以使用 Analysis Services 迁移向导将 Microsoft SQL Server 2000 Analysis Services 数据库升级到 Microsoft SQL Server 2008 Analysis Services。在迁移期间，向导复制 SQL Server 2000 Analysis Services 数据库对象，然后在 SQL Server 2008 Analysis Services 实例上重新创建这些对象。源数据库将保持不变且不会被修改。在您验证新的数据库完全可操作后，可以手动删除旧的数据库。

最佳做法是：一次迁移一个数据库或一小批数据库。这样可以验证每个数据库对象是否按要求出现在目标服务器上，然后再迁移其他对象。使用迁移向导时，必须在源服务器和目标服务器上都运行 MSSQLServerOLAPService 服务。（如果迁移命名实例，则必须在源服务器和目标服务器上都运行 MSOLAP$instancename 服务）。

迁移数据库之后，必须从原始数据源处理这些数据库，然后才能对其运行查询。有关详细信息，请参阅处理 Analysis Services 对象。

使用迁移向导

可以从 SQL Server Management Studio 的对象浏览器中的 Analysis Services 服务器节点启动迁移向导。也可以通过在命令提示符处运行程序 MigrationWizard.exe 来启动该向导。

指定源和目标

向导中的初始“欢迎”页之后，显示“指定源和目标”页。在此页上，指定要迁移的数据库的源服务器和目标服务器。Analysis Services 的目标实例可以是本地的，也可以是远程的。如果指定的目标计算机运行 SQL Server 2008 Analysis Services 的多个实例，请使用 computername\instancename 格式。

也可以选择将数据库架构保存到脚本文件中，以后再通过使用 SQL Server 2008 Integration Services 包中的 Analysis Services 执行 DDL 任务来完成迁移。有关 Analysis Services 执行 DDL 任务的详细信息，请参阅 Analysis Services 执行 DDL 任务。

选择要迁移的数据库

向导的下一页是“选择要迁移的数据库”页，它显示所有 SQL Server 2000 Analysis Services 数据库和相应的要创建的 SQL Server 2008 Analysis Services 数据库的列表。默认情况下，所有数据库都是选中的，但是也可以清除不想迁移的任何数据库的名称旁边的复选框。

默认情况下，源数据库的名称与相应的目标数据库的名称是相同的。但是，如果在目标服务器上已经有其他数据库使用同一名称，迁移向导将为新的数据库分配一个唯一的名称。（例如，AdventureWorks 的第二个副本将命名为 AdventureWorks 1。）您可以使用向导中提供的名称，也可以在向导中键入新的名称，或在完成向导之后重命名该数据库。

有关 SQL Server 2000 Analysis Services 对象如何与 SQL Server 2008 Analysis Services 对象相对应的详细信息，请参阅迁移注意事项（Analysis Services - 多维数据）。

注意：
迁移向导不支持 Microsoft SQL Server 7.0 Analysis Services 数据库的迁移。

验证数据库

在“验证数据库”页上，迁移向导验证要迁移的数据库的结构。验证数据库时，向导生成一个日志。若要查看日志或日志项的子集，请单击“查看日志”，然后从以下选项中进行选择：

  • 全部显示

  • 显示错误

  • 显示警告

  • 显示成功

如果发生错误，则验证停止。若要继续进行迁移，请修复导致错误的数据库，然后单击“重新启动”。

任何时候都可以通过单击“停止”来停止验证过程。向导将显示一条消息，在消息中指示尚未验证的数据库的数量。

迁移数据库

在“迁移数据库”页上，向导将 SQL Server 2000 Analysis Services 对象迁移为 SQL Server 2008 Analysis Services 格式。通过单击“停止”，然后单击“取消”，可以停止该过程并回滚整个事务。

迁移完成之后，您可以通过单击“上一步”返回向导中前面的页来更改以前所做的选择。但是，如果更改以前所做的选择，则必须重新运行迁移过程。重新运行迁移过程将会删除已经迁移的数据库。

完成向导

“完成向导”页显示已经创建的 SQL Server 2008 Analysis Services 数据库的摘要。单击“完成”即可完成向导。

迁移数据库之后，必须从原始数据源处理数据库，然后才能查询数据库。有关详细信息，请参阅处理 Analysis Services 对象。

请参阅

概念

升级 Analysis Services 时的注意事项


迁移注意事项（Analysis Services - 多维数据）

迁移注意事项（Analysis Services - 多维数据） |
 | 请参阅
升级到 SQL Server 2008 > 升级 Analysis Services 时的注意事项 >

将 Microsoft SQL Server Analysis Services 的早期版本迁移到 SQL Server 2008 Analysis Services 时，必须注意特性、功能、结构和行为的更改。本概述主题提供与数据挖掘和 Analysis Services 引擎相关的常见迁移注意事项的有关信息。有关迁移注意事项的具体方面的详细信息，请参阅下列主题：

  • SQL Server 2008 中 Analysis Services 功能的重大更改

  • 迁移现有 Analysis Services 数据库

  • SQL Server 2008 中废弃的 Analysis Services 功能

  • SQL Server 2008 中不推荐使用的 Analysis Services 功能

Analysis Services 迁移注意事项

Analysis Services 对象

下表说明了 SQL Server 2000 Analysis Services 对象与 SQL Server 2008 Analysis Services 对象的对应关系。

SQL Server 2000 Analysis Services 对象 | SQL Server 2008 Analysis Services 对象 | 详细信息
聚合 | 聚合 | 仅迁移混合 OLAP (HOLAP) 与多维 OLAP (MOLAP) 分区的聚合。
Analysis Services 数据库 | Analysis Services 数据库 | 无。
命令 | MDX 脚本 | 多维表达式 (MDX) 脚本是为包含命令集合的对象编写的。
多维数据集 | 多维数据集 | 还为共享同一数据源的所有维度、虚拟维度和多维数据集创建一个数据源视图。然后为每个挖掘模型和数据挖掘维度创建一个数据源视图。
多维数据集和数据库角色命令 | 不迁移 | 无。
多维数据集角色 | 多维数据集权限 | 不迁移维度和单元权限。
数据挖掘维度 | 数据挖掘维度 | 还为每个数据挖掘维度创建一个数据源视图。
数据源 | 数据源 | 无。
数据库角色 | 数据库角色和数据库权限 | 无。
维度 | 具有单一层次结构的维度 | 无。
共享同一名称前缀的维度（代表多个层次结构） | 单独的维度，每个维度具有单一层次结构。 | 引用原始层次结构名称的 MDX 表达式不再有效。
层次结构中的级别 | 维度中的属性，以及用户定义层次结构中的某个级别。 | 无。
链接多维数据集 | 不迁移 | 无。
某个级别的成员属性 | 某个级别的成员属性 | 无。
挖掘模型 | 挖掘模型 | 在数据库中为每个挖掘模型创建一个数据源视图。
挖掘模型角色 | 迁移为两个权限：一个用于挖掘结构，另一个用于挖掘模型。 | 无。
一个维度中的多个父子层次结构 | 单一父子层次结构，由父属性中的设置定义。 | 引用原始层次结构的 MDX 表达式不再有效。一个 SQL Server 2008 Analysis Services 维度只能有一个父子层次结构。
远程分区 | 不迁移。 | 在远程分区所在的服务器得到升级之前，或包含远程分区的数据库被迁移之前，远程分区不可用。包含远程分区的数据库可以单独迁移。必须更新远程分区的定义才能识别新服务器实例的名称。
存储库 | XML 格式的对象定义语言 (ODL) 文件 | 无。
虚拟多维数据集 | 链接度量值组 | 无。
虚拟维度 | 源维度的层次结构 | 虚拟父子维度迁移为单独的维度，因为父子维度不能有多个层次结构。

自定义级别公式

在 SQL Server 2005 Analysis Services (SSAS) 中，赋值取代了计算单元和自定义级别公式。计算单元在 SQL Server 2008 Analysis Services 中是受支持的并从 SQL Server 2000 Analysis Services 中按照定义迁移过来，而自定义级别公式则迁移为赋值。

在 SQL Server 2008 Analysis Services 中，计算传递随每次传递自动递增。因此，如果多维数据集包含自定义级别公式，请一定要验证所得结果与预期结果是否相同。

数据源视图

在 SQL Server 2005 Analysis Services (SSAS) 中引入了数据源视图。数据源视图不同于 SQL Server 2000 Analysis Services 中的多维数据集架构，因为数据源视图是源数据的逻辑表示形式，可使用这些源数据定义多个多维数据集，而 SQL Server 2000 Analysis Services 中的多维数据集架构是一种物理表示形式，表示每个多维数据集中各表之间的关系。

迁移多层次结构维度

SQL Server 2005 Analysis Services (SSAS) 与 SQL Server 2000 Analysis Services 相比，多层次结构维度的模型已有了改变。如果可能，此类层次结构将迁移为同一维度，但是也有无法迁移为同一维度的情况。在这种情况下，依赖原始维度层次结构的计算可能会失败。

SQL 语法

SQL Server 2005 Analysis Services (SSAS) 中声明 SQL 查询的方法已发生变化。联机丛书中使用了新语法的巴科斯-诺尔范式 (BNF)。

架构行集更改

SQL Server 2005 Analysis Services (SSAS) 中扩充了许多架构行集，以便提供附加信息。大多数情况下，现有行集和列的位置及含义仍与 SQL Server 2000 Analysis Services 中完全相同。下表说明了在 SQL Server 2005 Analysis Services (SSAS) 中进行的架构行集更改。

架构 | 列 | 更改
DBSCHEMA_TABLES_INFO | 全部 | 不再支持此架构。
MDSCHEMA_CELL_FORMULAS | 全部 | 不再支持此架构。
MDSCHEMA_DIMENSIONS | DIMENSION_CARDINALITY | 此列返回维度键属性成员的数目。
MDSCHEMA_MEMBERS | LEVELS_LIST | 此架构列为 Null。
MDSCHEMA_MEMBERS | MEMBER_ORDINAL | 不推荐使用此列。返回的将是值 0 而不是成员序号。

唯一成员名称

在 SQL Server 2005 Analysis Services (SSAS) 中，唯一成员名称进行了更新，现在这些名称与 SQL Server 2000 Analysis Services 中的那些名称不同。由于对唯一成员名称存在限制，使用原始的唯一名称从成员架构中检索结果时，返回的结果可能与在 SQL Server 2000 Analysis Services 中执行此操作返回的结果不同。

数据挖掘迁移注意事项

迁移向导会将所有挖掘模型从 SQL Server 2000 Analysis Services 数据库传输到目标 SQL Server 2008 Analysis Services 数据库。对于源数据库中的每个挖掘模型，迁移向导会在目标数据库中创建一个新的挖掘结构。挖掘结构只包含一个模型，并且该模型的名称与源数据库中挖掘模型的名称相同。

若要将各个挖掘模型从 SQL Server 2000 Analysis Services 迁移到 SQL Server 2008 Analysis Services 实例，可以使用预测模型标记语言 (PMML) 来完成。下面的示例演示如何以 XML 脚本的形式检索 SQL Server 2000 Analysis Services 挖掘模型的 PMML 表示形式：

SELECT * FROM [Model_Name].PMML

检索 OLE DB 架构 DMSCHEMA_MINING_MODEL_XML，也可以获取这一信息。

通过使用类似于以下内容的语句，您可以用 PMML 脚本在 SQL Server 2008 Analysis Services 实例中创建新的挖掘模型：

CREATE MINING MODEL [Model_Name] FROM PMML '<PMML script>'

如果使用 Analysis Services 迁移向导迁移挖掘模型，请注意该向导仅支持对元数据的迁移。因此，迁移后的挖掘模型是未经处理的。但是，这些模型仍包含原始数据绑定，因此，迁移完成后，可以在 SQL Server 2008 Analysis Services 中处理它们。另一方面，如果使用 PMML 来迁移模型，则原始数据绑定不会被保留。因此，您无法重新处理迁移后的模型。尽管如此，这些模型仍可供使用，因为 PMML 包含源模型所发现的模式和走向。

已知的数据挖掘迁移问题：

  • 无法迁移具有多个事例级别键，且其中的多个键在嵌套表中的挖掘模型。

  • 无法迁移使用聚合数据挖掘访问接口创建的挖掘模型。

请参阅

概念

升级 Analysis Services 时的注意事项


升级或迁移 Analysis Services 的操作指南主题

升级或迁移 Analysis Services 的操作指南主题 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Analysis Services 时的注意事项 >

本部分包含用于将数据库升级和迁移到 Microsoft SQL Server 2008 Analysis Services 的以下常用操作步骤。

有关安装 Analysis Services 的通用步骤的信息，请参阅 Analysis Services 安装操作指南主题。

重要提示：
本部分中的升级和迁移 Analysis Services 的操作指南主题只将重点放在特定于 Analysis Services 的升级和迁移选项上。不过，这些主题中提供了关于其他主题的链接，可通过这些链接了解安装 SQL Server 的详细信息。

本节内容

  • 如何升级 Analysis Services 实例

  • 如何迁移 Analysis Services 数据库

请参阅

概念

升级 Analysis Services 时的注意事项


如何升级 Analysis Services 实例

如何升级 Analysis Services 实例 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Analysis Services 时的注意事项 > 升级或迁移 Analysis Services 的操作指南主题 >

可以将 Microsoft SQL Server 2005 Analysis Services 的现有实例升级到 Microsoft SQL Server 2008 Analysis Services，并且作为升级过程的一部分，还可以将现有数据库从旧实例升级到新实例。若要进行升级，请运行安装程序并将现有实例的名称指定为新实例的名称。

重要提示：
Analysis Services 升级和迁移操作指南主题仅重点介绍 Analysis Services 特有的升级和迁移选项。不过，这些主题中提供的转至其他主题的链接可以帮助您了解安装 SQL Server 的详细信息。

升级 Analysis Services 的实例

  1. 使用 SQL Server 安装向导或在命令提示符下运行安装程序。有关如何使用 SQL Server 安装向导运行安装程序的详细信息，请参阅如何使用安装程序安装 Analysis Services。有关如何在命令提示符下运行安装程序的详细信息，请参阅Installing SQL Server from the Command Prompt。

  2. 使用 SQL Server 安装向导时，请在“实例名”页上选择“默认实例”。若要确认是否存在 SQL Server 2000 Analysis Services 实例，可以单击“已安装的实例”按钮。在命令提示符下运行安装程序时，使用 instancename 选项来指定 SQL Server 2000 Analysis Services 现有实例的名称。由于 SQL Server 2000 Analysis Services 不支持命名实例，因此现有实例的名称通常为服务器名。

请参阅

任务

如何迁移 Analysis Services 数据库

概念

升级 Analysis Services 时的注意事项


如何迁移 Analysis Services 数据库

如何迁移 Analysis Services 数据库 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Analysis Services 时的注意事项 > 升级或迁移 Analysis Services 的操作指南主题 >

您可以在安装过程中通过升级 Analysis Services 的现有实例来迁移现有 Analysis Services 数据库，或者在安装之后通过运行迁移向导进行迁移。

本主题描述使用迁移向导来迁移现有 SQL Server 2000 Analysis Services 数据库的过程。在安装期间，使用 SQL Server 安装向导升级 SQL Server 2000 Analysis Services 实例时，不必指定任何与数据库迁移相关的其他选项。

重要提示：
本主题和同时提供的 Analysis Services 升级和迁移操作指南主题仅重点介绍 Analysis Services 特有的升级和迁移选项。不过，这些主题中提供了关于其他主题的链接，可通过这些链接了解安装 SQL Server 的详细信息。

通过使用迁移向导来迁移现有的 Analysis Services 数据库

  1. 从 SQL Server Management Studio 的对象浏览器中的 Analysis Services 服务器节点启动迁移向导。也可以通过在命令提示符处运行程序 MigrationWizard.exe 来启动该向导。

  2. 向导启动并显示“欢迎使用 Analysis Services 迁移向导”页。阅读介绍性消息，然后单击“下一步”继续。

  3. 在“指定源和目标”页上，标识源 SQL Server 2000 Analysis Services 服务器和实例名，然后标识目标 SQL Server 2008 Analysis Services 服务器和实例名。如果不指定目标服务器，还可以选择将数据库架构保存到一个脚本文件中，并在以后完成迁移。可以使用 SQL Server 2008 Integration Services (SSIS) 包中的 Analysis Services 执行 DDL 任务完成此操作。有关 Analysis Services 执行 DDL 任务的详细信息，请参阅Analysis Services 执行 DDL 任务。

  4. 在“选择要迁移的数据库”页上，选中要迁移的数据库旁边的复选框。如果愿意，可为目标数据库指定与源数据库不同的名称。

  5. 在“验证数据库”页上，向导分析要迁移的数据库并报告所发现的任何问题。

  6. 在“迁移数据库”页上，向导在执行数据库迁移时报告执行的进度。

  7. 在“完成向导”页上，向导报告迁移的结果。单击“完成”即可完成向导。

  8. 迁移数据库之后，必须从原始数据源处理数据库，然后才能查询数据库。有关详细信息，请参阅处理 Analysis Services 对象。

  9. 迁移之后，您可能需要查看迁移注意事项（Analysis Services - 多维数据），以了解 Analysis Services 数据库不同版本间的差异。

请参阅

概念

迁移现有 Analysis Services 数据库
迁移注意事项（Analysis Services - 多维数据）


升级 Reporting Services 的注意事项

升级 Reporting Services 的注意事项 |
 | 请参阅
升级到 SQL Server 2008 >

升级由 SQL Server 安装程序执行。SQL Server 安装程序可用于升级任意或所有 SQL Server 组件，包括 Reporting Services。若要升级早期版本的 SQL Server，请在已安装早期版本的 SQL Server 的计算机上运行 SQL Server 2008 安装程序。安装程序将检测现有实例并提示您进行升级。

运行安装程序时，可以选择从 SQL Server 2000 或 SQL Server 2005 升级的选项，也可以安装并行运行现有安装的 SQL Server 2008 Reporting Services 新实例。

本主题着重说明升级 Reporting Services 前应该了解的重要注意事项。

重要提示：
若要了解哪些 Reporting Services 功能已停止使用、不推荐使用或发生了更改，请参阅 Reporting Services 的向后兼容性。

升级版本类别和版本

SQL Server 2008 安装程序为下列早期版本的 Reporting Services 提供升级支持：

  • SQL Server 2000 Reporting Services 安装，带有 Service Pack 2 (SP2)。

  • SQL Server 2005 Reporting Services。

支持从一个 SQL Server 2008 版本升级或降级到另一个版本。

已知升级问题

在升级到 SQL Server 2008 Reporting Services 之前，请查看升级顾问文档和联机站点中有关升级问题的最新信息。若要获得升级顾问文档，请安装升级顾问。有关详细信息，请参阅使用升级顾问来准备升级。

已知升级问题当前包括以下内容：

  • 对于使用远程 SQL Server 2000 数据库引擎实例承载报表服务器数据库的报表服务器不提供升级支持。

  • 不支持在 SQL Server 2008 中使用 SQL Server 2000 报表服务器 Web 服务。此端点已停用。如果创建或安装了指向 ReportServer2000 端点的自定义功能，则该自定义功能将不再运行。有关新端点的详细信息，请参阅Report Server Web Service Endpoints。

  • 不支持早期版本的 Reporting Services WMI 提供程序。Reporting Services WMI 提供程序并不向后兼容早期的版本。在升级之后，不能将 SQL Server 2008 Reporting Services WMI 提供程序与 Reporting Services 的更早版本一起使用。

有关支持的升级方案的详细信息，请参阅版本升级。如果无法运行安装程序来执行现有安装的就地升级，则可以安装一个新 SQL Server 2008 Reporting Services 实例，然后再将报表服务器数据库和配置文件迁移到该新实例。有关迁移 Reporting Services 的详细信息，请参阅如何迁移 Reporting Services 安装。

升级前的检查表

升级到 SQL Server 2008 Reporting Services 之前，请先检查以下要求：

  • 检查相关要求，以确定硬件和软件是否可以支持 SQL Server 2008 Reporting Services。有关详细信息，请参阅安装 SQL Server 2008 的硬件和软件要求。

  • 使用系统配置检查器 (SCC) 扫描报表服务器计算机中是否有可能妨碍 SQL Server 2008 成功安装的任何情况。有关详细信息，请参阅系统配置检查器的检查参数。

  • 查看 SQL Server 的安全最佳实践和指南。有关详细信息，请参阅 安装 SQL Server 的安全注意事项。

  • 在报表服务器计算机上运行升级顾问工具，以确定可能妨碍成功升级的任何问题。有关详细信息，请参阅使用升级顾问来准备升级。

  • 备份对称密钥。有关详细信息，请参阅备份和还原加密密钥。

  • 备份报表服务器数据库。有关详细信息，请参阅将报表服务器数据库移至其他计算机。

  • 备份以下报表服务器配置文件：Rsreportserver.config、Rswebapplication.config、Rssvrpolicy.config、Rsmgrpolicy.config、Reportingservicesservice.exe.config、Web.config（针对报表服务器和报表管理器 ASP.NET 应用程序）和 Machine.config（如果在报表服务器操作中对其进行了修改，则针对 ASP.NET）。

  • 备份对 IIS 中现有 Reporting Services 虚拟目录的任何自定义。

在升级生产环境之前，务必在与生产环境具有相同配置的生产前环境中运行测试升级。

如何升级早期版本的 Reporting Services

安装程序提供了升级选项，您可以将其作为命令行参数指定或在安装向导中指定。请从下列主题中进行选择以获得有关如何升级您的安装的说明。

如何升级到 SQL Server 2008（安装程序）

说明了如何使用安装向导升级到 SQL Server 2008。

如何从命令提示符安装 SQL Server 2008

说明了如何以命令行操作方式升级到 SQL Server 2008。

删除先前安装中的文件和应用程序

升级不会删除旧日志文件、过时的 RSWebApplication.config 文件或 IIS 中的虚拟目录设置。升级不会删除 SQL Server 2005 报表设计器、Management Studio 或其他客户端工具。如果不再需要它们，请确保在升级完成后删除这些文件和工具。

升级工作流

当选择了一个要升级的现有报表服务器实例时，升级过程即开始。

  1. 如果报表服务器数据库位于远程计算机上，而您没有更新该数据库的权限，则安装程序将提示您提供更新远程报表服务器数据库的凭据。请确保提供具有 sysadmin 或数据库更新权限的凭据。

  2. 安装程序检查阻止升级的条件或设置并读取配置设置。示例包括在报表服务器上部署的自定义扩展插件。如果升级受阻，则必须修改您的安装以便不再阻止升级，或者迁移到新的 SQL Server 2008 实例。有关详细信息，请参阅升级顾问文档。

  3. 如果升级可以继续，则安装程序将提示您继续升级过程。

  4. 安装程序为 SQL Server 2008 程序文件创建新的文件夹。Reporting Services 安装的程序文件夹包括 MSRS10.<实例名>。

  5. 安装程序添加 SQL Server 2008 报表服务器程序文件、配置工具和作为报表服务器功能一部分的命令行实用工具。

    1. 删除先前版本中的程序文件。

    2. 升级到新版本的报表服务器配置工具和实用工具包括 Reporting Services 配置工具、命令行实用工具和报表生成器。随 SQL Server 2008 安装的新工具包括新的报表设计器预览。

    3. 不升级其他客户端工具，例如 Business Intelligence Development Studio、SQL Server Management Studio 和联机丛书。若要获得这些工具的新版本，可以在运行安装程序时添加它们。其早期版本将与 SQL Server 2008 版本并存。如果安装了示例，则会保留早期版本。安装程序不支持升级 SQL Server 示例。

  6. 安装程序重用服务控制管理器中 SQL Server 2008 报表服务器服务的服务条目。此服务条目包括报表服务器 Windows 服务帐户。

  7. 安装程序基于 IIS 中的现有虚拟目录设置保留新的 URL。安装程序可能不会删除 IIS 中的虚拟目录，所以请确保在完成升级之后手动删除它们。

  8. 安装程序将报表服务器数据库升级到新架构并通过为角色添加数据库所有者权限来修改 RSExecRole。仅当正在从 SP1 之前的 SQL Server 2000 Reporting Services 或 SQL Server 2005 Reporting Services 升级时，才会执行此步骤。

  9. 安装程序合并配置文件中的设置。添加新条目时，使用当前安装的配置文件作为基础。不会删除过时的条目，但是在升级完成后，报表服务器不会再读取它们。

请参阅

概念

安装 Reporting Services 的注意事项
升级到 SQL Server 2008


如何检测版本信息 (Reporting Services)

如何检测版本信息 (Reporting Services) |
 | 请参阅
升级到 SQL Server 2008 > 升级 Reporting Services 的注意事项 >

Reporting Services 由多个应用程序、工具和组件组成。如果在单一操作中安装或升级组件，则安装的所有组件将具有相同的版本。但是，如果并行运行多个实例，将服务器组件配置为在不同计算机上运行，或者将项发布到中央服务器，则在尝试将某一版本的客户端工具与不同版本的报表服务器一起使用时，可能会遇到版本兼容性错误。在发布操作中或者在尝试使用 Reporting Services 配置工具连接先前版本的报表服务器时通常会发生这类错误。

本主题可帮助您识别版本或版本类别信息，以便您能够确定是升级组件还是使用其他的客户端或服务器实例安装。有关升级的详细信息，请参阅升级 (Reporting Services)。

报表服务器数据库连接不太可能发生版本兼容性错误。报表服务器可以自动升级它所连接的报表服务器数据库，从而消除了早期版本中有时会发生的数据库版本不匹配错误的主要起因。但是，如果尚未升级所有节点，则可能在扩展部署中遇到错误。

在 Reporting Services 配置工具的“报表服务器状态”页中可以方便地查看报表服务器的版本和版本类别信息。但是，如果由于版本不兼容错误而无法连接到报表服务器数据库，则可以使用本主题后面提供的备用步骤。

注意：
您可以以编程方式检索版本信息。若要检索服务器版本信息，请使用 ServerInfoHeaderValue。若要检索数据库版本，请使用 GetDatabaseVersionDisplayName Method (WMI)。

查找 Reporting Services 配置工具的版本信息

  • 启动 Reporting Services 配置工具。在“报表服务器状态”页上，查看“产品版本”值，并将它与本主题后面的“版本信息”表相比。

查找报表服务器实例的版本和版本类别信息

  1. 在文本编辑器中打开报表服务器服务跟踪日志文件。文件名为 ReportServerService_<时间戳>.log，它位于 \Reporting Services\ReportServer\logfiles 文件夹中。

  2. 报表服务器版本信息位于文件顶部的 <Product> 中。

  3. 在该文件后面的 INFO 语句中可以找到报表服务器的版本类别信息：

    • Reporting Services starting SKU 显示了报表服务器实例的版本类别。

查看报表服务器版本信息的另一种方法是在浏览器窗口的地址栏中键入报表服务器 URL。在页面底部可以找到版本信息，其格式为：<版本>:<内部版本号>。如果版本为 10，则连接的是 SQL Server 2008 报表服务器实例。

查找承载报表服务器数据库的数据库实例的版本类别信息

  1. 在文本编辑器中打开报表服务器服务跟踪日志文件。文件名为 ReportServerService_<时间戳>.log，它位于 \Reporting Services\ReportServer\logfiles 文件夹中。

  2. 在该文件后面的 INFO 语句中可以找到承载报表服务器数据库的数据库服务器的版本类别信息：

    • Catalog SQL Server Edition 显示了承载报表服务器数据库的数据库服务器的版本类别。

日志文件、工具或编程界面中未提供版本信息。请使用本主题结尾处所提供的表获取报表服务器数据库的版本信息。

查找报表设计器和模型设计器的版本

  1. 启动 Business Intelligence Development Studio，单击“帮助”，然后单击“关于 Visual Studio”。

  2. 在已安装产品的列表中，单击 Reporting Services。对话框的产品详细信息部分将显示版本信息。

查找报表管理器或报表生成器的版本

  • 在 SQL Server 2008 中，报表管理器在报表服务器服务中运行。如果知道报表服务器服务的版本，也就会知道报表管理器的版本。但是，如果将报表管理器实例指向不同的 Report Service 实例，则可能会出现报表管理器的版本与报表服务器的版本不同步的情况。若要验证报表管理器的版本，请右键单击报表管理器中的某个网页并使用“查看源”命令查看 HTML。版本信息嵌入在基础 HTML 中。

  • 若要查找报表生成器的版本信息，请启动报表生成器并单击“帮助”菜单中的“关于报表生成器”。

版本信息

下表列出了截至目前发布的报表服务器和报表服务器数据库的版本号：

版本 | 报表服务器 | 报表服务器数据库
SQL Server 2008 | 10.n.nnnn.nn | 无
SQL Server 2005 Reporting Services Service Pack 2 (SP2) | 9.0.3042.00 | C.0.8.45
具有高级服务的 SQL Server 2005 Express Edition | 9.0.3042.00 | C.0.8.45
SQL Server 2005 Reporting Services Service Pack 1 (SP1) | 9.0.2049.00 | C.0.8.43
SQL Server 2005 Reporting Services | 9.0.1399.01 | C.0.8.40
SQL Server 2000 Reporting Services Service Pack 2 (SP2) | 8.00.1038 | C.0.6.54
SQL Server 2000 Reporting Services Service Pack 1 (SP1) | 8.00.0878 | C.0.6.51
SQL Server 2000 Reporting Services | 8.00.0743 | C.0.6.43

请参阅

概念

升级报表服务器数据库

其他资源

教程：如何查找并启动 Reporting Services 工具
升级 (Reporting Services)
Reporting Services 组件和工具


升级报表服务器数据库

升级报表服务器数据库 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Reporting Services 的注意事项 >

报表服务器数据库可以为一个或多个报表服务器实例提供内部存储。因为报表服务器数据库架构可能会因为推出新的 Reporting Services 版本而有所变化，所以要求数据库版本与使用的报表服务器实例的版本相匹配。大多数情况下，报表服务器数据库可以自动升级，您不需要执行任何具体操作。

注意：
您可以升级运行在 SQL Server 2005 数据库引擎实例上的报表服务器数据库，而不必将数据库引擎升级到 SQL Server 2008。还可以使用 SQL Server 2005 数据库引擎实例承载为 SQL Server 2008 Reporting Services 安装新建的报表服务器数据库。

如何升级报表服务器数据库

以下列表指出了升级报表服务器数据库的所有情况：

  • 安装程序升级报表服务器的单个实例。在服务启动并且报表服务器确定数据库架构版本与服务器版本不匹配之后，将自动升级数据库架构。

  • 服务启动时，报表服务器会检查数据库架构版本以验证它是否与服务器版本相匹配。如果数据库架构版本较低，该架构将自动升级到报表服务器所需的架构版本。如果还原或附加一个较低的报表服务器数据库，则自动升级功能特别有用。将在报表服务器跟踪日志文件中输入一条消息，指示已升级数据库架构版本。

  • 当选择旧版本与新报表服务器实例一起使用时，Reporting Services 配置工具将升级本地或远程报表服务器数据库。在这种情况下，必须在发生此操作之前确认升级操作。

    Reporting Services 配置工具不再提供单独的升级按钮或升级脚本。鉴于报表服务器服务的自动升级功能，这些功能在 SQL Server 2008 中已过时。

架构更新后，无法再将升级回滚到以前的版本。请务必备份报表服务器数据库，以备需要重新创建先前安装。

如何更新架构、元数据和报表服务器内容

升级报表服务器数据库需分三个步骤：

  1. 架构将在安装并启动服务之后，或者在 Reporting Services 配置工具中选择 SQL Server 2005 或 2000 报表服务器数据库时进行自动升级。此外，报表服务器服务会在启动时检查数据库版本。如果报表服务器连接到早期版本的数据库，则报表服务器将在启动过程中更新该数据库。

  2. 在更新架构后首次使用报表服务器数据库时升级安全描述符。

  3. 首次使用时，升级已发布报表和已编译报表快照。有关详细信息，请参阅升级报表。

除了报表服务器数据库外，报表服务器还会使用临时数据库。升级报表服务器数据库时，会自动升级临时数据库。

升级报表服务器数据库

如果要升级的 Reporting Services 安装包含报表服务器数据库，则可能会在升级数据库架构时遇到一些问题。默认情况下，安装程序会使用运行安装程序的用户的安全令牌连接到远程 SQL Server 实例并更新架构。如果拥有对承载报表服务器数据库的数据库服务器的 SQL Server sysadmin 权限，将成功升级数据库。同样，如果从命令提示符运行安装程序，并为拥有 sysadmin 权限修改远程计算机上的架构的帐户指定 RSUPGRADEDATABASEACCOUNT 和 RSUPGRADEPASSWORD 参数，也将成功升级数据库。

但是，如果您没有对远程计算机上的数据库的权限，则系统将拒绝连接，并出现以下错误：

“安装程序无法升级报表服务器数据库架构。必须在安装完成后手动更新数据库架构。若要更新架构，请运行 Reporting Services 配置工具，再打开“数据库安装”页，重新选择数据库，然后单击“应用”。数据库将自动升级。”

此时，报表服务器程序文件将被升级，但报表服务器数据库将为早期版本的格式。报表服务器将不可用，直到通过手动升级数据库来完成升级过程为止。

手动升级数据库

如果安装程序没有自动升级报表服务器数据库，则只能升级部分报表服务器安装。若要完全升级，必须在安装完成后运行 Reporting Services 配置工具，手动升级报表服务器数据库。

  1. 运行 Reporting Services 配置工具，并连接到刚升级的报表服务器。有关如何启动该工具和连接到服务器的详细信息，请参阅如何启动 Reporting Services 配置。

  2. 打开“数据库安装”页，然后单击“连接”连接到承载报表服务器数据库的 SQL Server 实例。

  3. 选择要升级的报表服务器数据库。

  4. 单击“应用”以升级数据库架构。

完成上述步骤后，就可使用报表服务器了。

请参阅

任务

如何启动 Reporting Services 配置

概念

创建报表服务器数据库
升级 Reporting Services 的注意事项
如何迁移 Reporting Services 安装


升级报表

升级报表 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Reporting Services 的注意事项 >

SQL Server 2008 引入了对报表定义语言 (RDL)、报表对象模型以及呈现对象模型的更改，这些更改影响在早期版本的软件中创建的报表。将 SQL Server 2005 Reporting Services 安装升级到 SQL Server 2008 Reporting Services 安装时，已上载到报表服务器的现有报表和快照将在第一次进行处理时自动升级为新的架构。如果报表不能自动升级，则将使用向后兼容模式处理报表。

在 Business Intelligence Development Studio 中的报表设计器中打开现有报表定义 (.rdl) 文件时，这些文件将自动升级。

注意：
有关新的 RDL 功能（例如 Tablix 数据区或修订的图表组件）的详细信息，请参阅新增功能 (Reporting Services)。

升级报表后，您可能注意到出现附加的错误、警告和消息。这是对内部报表对象模型和处理组件进行更改的结果，当在报表中检测到根本问题时，将导致出现这些消息。有关详细信息，请参阅 Reporting Services 的向后兼容性。

能够升级的版本

在 Reporting Services 的以前任一版本中创建的报表可以升级。包括下列版本：

  • SQL Server 2000

  • SQL Server 2000 Service Pack 1

  • SQL Server 2000 Service Pack 2

  • SQL Server 2005

  • SQL Server 2005 Service Pack 1

  • SQL Server 2005 Service Pack 2

报表定义 (.rdl) 文件和报表设计器

报表定义文件包括对 RDL 命名空间的引用，该命名空间指定了用于验证 rdl 文件的报表定义架构的版本。

当您在 Business Intelligence Development Studio 的报表设计器中打开某个 .rdl 文件时，如果报表是针对先前命名空间创建的，报表设计器会自动创建一个备份文件，并将该报表升级到当前命名空间。如果保存升级后的报告定义，则同时还会保存转换后的 .rdl 文件。一旦保存，就不能在早期版本的报表设计器中将其打开。这是升级报表定义文件的唯一方法。

可以将在早期版本的 Reporting Services 中创建的 .rdl 文件上载到 SQL Server 2008 报表服务器，该报表将在第一次使用时自动升级。报表服务器将以原始格式存储报表定义文件。报表将在第一次被查看时自动升级，但是存储的报表定义文件仍保持不变。

注意：
不能将具有 SQL Server 2008 报表定义命名空间的报表发布或上载到 SQL Server 2000 报表服务器或 SQL Server 2005 报表服务器。

若要为报表、报表服务器或报表设计器标识当前 RDL 架构，请参阅如何确定报表架构版本。

已发布的报表和报表快照

第一次使用时，报表服务器会尝试将现有的已发布报表和报表快照升级为新的报表定义架构，不需要您执行特定操作。当用户查看报表或报表快照时，或者当报表服务器处理订阅时，将尝试进行升级。报表定义不会被替换，而是继续存储在它在 SQL Server 2008 报表服务器上的原始架构中。如果报表不能升级，则报表将在向后兼容模式下运行。

向后兼容模式

成功升级的报表由 SQL Server 2008 Reporting Services 报表处理器进行处理。不能升级的报表由 SQL Server 2005 Reporting Services 报表处理器在向后兼容模式下进行处理。一个报表不能同时由这两个报表处理器来处理。

第一次使用时，报表将成功升级或标记为向后兼容。

只有 SQL Server 2008 Reporting Services 报表处理器才支持新功能，例如按需分页、Tablix 数据区域、仪表数据区域以及增强的图表数据区域。如果报表不能升级，您仍然可以查看呈现的报表，但不能使用新功能。若要利用新功能，必须成功地升级报表。

使用子报表升级报表

当报表中包含子报表时，升级过程中会出现四种可能的状态之一：

  • 主报表和所有子报表都能成功地升级。它们由 SQL Server 2008 Reporting Services 报表处理器来处理。

  • 主报表和所有子报表都不能升级。它们由 SQL Server 2005 Reporting Services 报表处理器来处理。

  • 主报表可以升级，但一个或多个子报表不能升级。主报表由 SQL Server 2008 Reporting Services 报表处理器处理，但呈现的报表在不能升级的子报表将出现的位置显示消息“错误: 无法处理子报表”。

  • 主报表不能升级，但一个或多个子报表可以升级。主报表由 SQL Server 2008 Reporting Services 报表处理器处理，但呈现的报表在子报表将出现的位置显示消息“错误: 无法处理子报表”。

如果看到错误“错误: 无法处理子报表”，则必须更改主报表或子报表的定义，以便可以由报表处理器的同一版本处理报表。

钻取报表没有此限制，因为它们被作为独立的报表处理。

使用自定义报表项升级报表

SQL Server 2005 Reporting Services 报表可能包含由第三方软件供应商提供并由系统管理员安装在报表创作计算机和报表服务器上的自定义报表项 (CRI)。可以按以下方式升级包含 CRI 的报表：

  • SQL Server 2005 Reporting Services 报表服务器升级到 SQL Server 2008 Reporting Services 报表服务器。在首次使用时自动升级报表服务器上的已发布报表。

  • SQL Server 2005 Reporting Services 报表上载到 SQL Server 2008 Reporting Services 报表服务器。报表将在首次使用时自动升级。

  • 在 Business Intelligence Development Studio 的报表设计器中打开 SQL Server 2005 Reporting Services 报表。将创建原始报表的一个备份副本。发生以下两种情况之一：

    1. 报表中的所有 CRI 没有不受支持的功能。CRI 将转换为新报表定义架构中的报表项，以便升级整个报表。如果保存该文件，则它将保存在当前 RDL 命名空间中。

    2. 报表中的一个或多个 CRI 具有不受支持的功能。出现一个对话框，提示用户是转换这些 CRI 还是将它们保留不变。

    有关详细信息，请参阅本主题后面的在报表设计器中打开报表。

有关为报表服务器、BI Development Studio 或报表标识当前 RDL 命名空间的信息，请参阅如何确定报表架构版本。

升级报表服务器上的报表

当 SQL Server 2005 Reporting Services 报表第一次在已升级到 SQL Server 2008 Reporting Services 报表服务器的报表服务器上运行时，该报表将自动升级到报表服务器支持的当前报表定义命名空间。该报表可能在升级之前已存在于报表服务器上，或该报表可能已通过报表管理器上载，或从 SQL Server 2005 BI Development Studio 中的报表设计器发布到报表服务器。

下表列出由报表服务器为报表中特定类型的 CRI 执行的升级操作。

CRI 类型 | 报表服务器升级操作
第三方 CRI | 不执行升级。 由 SQL Server 2005 Reporting Services 报表处理器来处理。
具有不受支持的功能的 Dundas 2005 图表 CRI | 升级到最新的 RDL 架构。所有的 Dundas 2005 图表 CRI 都将转换为 SQL Server 2008 Reporting Services 图表数据区域。 由 SQL Server 2008 Reporting Services 报表处理器来处理。
不具有不受支持的功能的 Dundas 2005 仪表 CRI | 升级到最新的 RDL 架构。所有的 Dundas 2005 仪表 CRI 都将转换为 SQL Server 2008 Reporting Services 仪表数据区域。 由 SQL Server 2008 Reporting Services 报表处理器来处理。
具有不受支持的功能的 Dundas 2005 图表 CRI | 不执行升级。 由 SQL Server 2005 Reporting Services 报表处理器来处理。
具有不受支持的功能的 Dundas 2005 仪表 CRI | 不执行升级。 由 SQL Server 2005 Reporting Services 报表处理器来处理。

在报表设计器中使用 CRI 打开报表

在 SQL Server 2008 Business Intelligence Development Studio 中使用报表设计器中的 CRI 打开 SQL Server 2005 Reporting Services 报表时，报表将升级到新的报表定义架构。根据报表中包含的 CRI，将执行下列操作之一：

  • 检测到第三方 CRI。如果安装在报表创作计算机上的 CRI 的版本与新的 RDL 架构不兼容，则设计图面将显示带有红色 X 的文本框。您必须与系统管理员联系，以便从与新的 RDL 架构兼容的第三方供应商那里安装新版本的 CRI。

  • 检测到 Dundas 2005 图表或仪表 CRI，所有实例都包含受支持的功能。所有 Dundas 2005 图表和仪表 CRI 都将转换为您在工具箱中看到的 Reporting Services 图表和仪表报表项。这些项称为本机图表和仪表报表项。

  • 检测到 Dundas 2005 图表或仪表 CRI，所有实例都包含不受支持的功能。不受支持的功能将在本节后面的内容中介绍。您可以选择是否将所有 CRI 转换为本机报表项。

    • 如果转换它们，报表将升级到新的 RDL 架构，Dundas 2005 图表和仪表 CRI 将转换为相应的本机图表和仪表报表项，但将删除不受支持的功能。在呈现报表中，您看到的情况可能与 CRI 的显示方式有所不同。

    • 如果选择不转换它们，则报表将升级到新的 RDL 架构，但是 CRI 将被视为第三方 CRI。您必须配合系统管理员和第三方供应商来安装与新报表架构兼容的全新 CRI。如果新的 CRI 不可用，则报表将在报表设计器中显示一个带有红色 X 的文本框。

在报表创作环境中升级报表后将其保存，这是将现有报表升级到新的报表定义架构的唯一方式。

不受支持的 Dundas 2005 图表自定义报表项功能

Dundas 2005 图表 CRI 不受支持的功能包括：

  • 批注。

  • 自定义图例项。

  • 自定义属性具有下列名称：

    • CUSTOM_CODE_CS

    • CUSTOM_CODE_VB

    • CUSTOM_CODE_COMPILED_ASSEMBLY

      例如，如果 .rdl 文件包含以下部分，则需要在升级之前将其删除：

      复制代码
      <CustomProperty>
 <Name>CUSTOM_CODE_CS</Name>
 <Value>dXNpWERwegfdfgiobxxl3bmc… </Value>
</CustomProperty>

不受支持的 Dundas 2005 仪表自定义报表项功能

Dundas 2005 仪表 CRI 不受支持的功能包括：

  • 数字指示器。

  • 状态指示器。

  • 自定义图像。

请参阅

概念

升级 Reporting Services 的注意事项
SQL Server 2008 Reporting Services 中的重大更改
SQL Server Reporting Services 中的行为更改
SQL Server Reporting Services 中停止使用的功能
升级报表服务器数据库

其他资源

转换 CRI 对话框
Custom Report Items
威胁和漏洞缓解 (Reporting Services)


升级 Data Transformation Services 时的注意事项

升级 Data Transformation Services 时的注意事项 |
 | 请参阅
升级到 SQL Server 2008 >

如果计算机中当前安装了 SQL Server 2000 Data Transformation Services (DTS)，可以从 Data Transformation Services 升级到 SQL Server 2008 Integration Services，并且不会遇到任何软件冲突问题。由于 Integration Services 是一个全新的产品，而不是从 Data Transformation Services 升级的版本，所以不会产生软件冲突。

注意：
如果要从 SQL Server 2005 Integration Services 升级到 SQL Server 2008 Integration Services，请参阅升级 Integration Services 时的注意事项。

升级 Data Transformation Services 之前

在将 Data Transformation Services 升级到 Integration Services 之前，建议您阅读支持 SQL Server 2008 中的 Data Transformation Services (DTS)。

我们还建议您在执行升级之前先安装和运行升级顾问。有关详细信息，请参阅使用升级顾问来准备升级。

升级 Data Transformation Services

可以使用下列方法之一升级现有的 SQL Server 2000 实例：

  • 运行 SQL Server 2008 安装程序，然后选择“从 SQL Server 2000 或 SQL Server 2005 升级”选项。

  • 在命令提示符下运行 setup.exe 并指定 /ACTION=upgrade 选项。有关详细信息，请参阅如何从命令提示符安装 SQL Server 2008 中的“Integration Services 的安装脚本”部分。

无法使用 SQL Server 2008 安装程序直接从 SQL Server 6.5 或 7.0 升级到 SQL Server 2008。

升级时，可以同时升级 DTS 和 数据库引擎，也可以只升级 DTS，或只升级数据库引擎。如果只升级 DTS 或只升级数据库引擎，则有一些限制：

  • 如果只升级 DTS，则 SQL Server 2008 Integration Services 完全正常运行。但是，Integration Services 将只能在文件系统中存储包，除非在另一台计算机上有可用的 SQL Server 2008 数据库引擎实例。如果有可用的 SQL Server 2008 数据库引擎 实例，则 Integration Services 将能在该实例中存储包。

  • 如果只升级 数据库引擎，则 DTS 仍正常运行。但您将无法使用 Integration Services 的功能。

将 Data Transformation Services 和数据库引擎同时升级到 SQL Server 2008

本节介绍执行符合以下条件的升级的影响：

  • 将 DTS 和数据库引擎实例同时升级到 SQL Server 2008。

  • 要升级的 DTS 和数据库引擎实例在同一台计算机上。

升级过程执行的操作

升级过程将执行以下任务：

  • 将数据库引擎实例升级到 SQL Server 2008。

  • 安装 SQL Server 2008 Integration Services。

  • 安装 DTS 包的已更新运行时支持组件。该支持组件包括 SQL Server Management Studio 中的 DTS 运行库和 DTS 包枚举。DTS 包可以继续与 Integration Services 包运行在同一台计算机上。有关详细信息，请参阅如何安装 Data Transformation Services 包的支持组件。

  • 保持 msdb 数据库的现有 DTS 系统表中的现有 DTS 包不变。

升级过程不执行的操作

该升级过程不执行以下任务：

  • 不将现有 DTS 包的迁移为 Integration Services 包使用的格式。升级后，还可以选择使用 DTS 包迁移向导将 DTS 包迁移为 Integration Services 格式。在迁移过程中，该向导将复制 DTS 包，然后以 Integration Services 格式重新创建这些包。源包将保持不变且不会被修改。

    安装 Integration Services 时，安装程序还将安装 DTS 包迁移向导。

    注意：
    SQL Server 的 Standard Edition、Enterprise Edition 和 Developer Edition 中提供了 DTS 包迁移向导。

    有关详细信息，请参阅以下主题：

    • 迁移 Data Transformation Services 包

    • 如何将 Data Transformation Services 包迁移到 Integration Services

    • 已知的 DTS 包迁移问题

  • 不安装对 DTS 包的可选的运行时、管理和设计时支持。有关详细信息，请参阅如何安装 Data Transformation Services 包的支持组件。

升级后可执行的操作

升级过程完成后，可以执行下列任务：

  • 安装对 DTS 的可选的运行时和管理支持。有关详细信息，请参阅如何安装 Data Transformation Services 包的支持组件。

安装对 DTS 的可选的运行时支持后，可以执行下列任务：

  • 若要在 SQL Server Management Studio 中的 Management\Legacy\Data Transformation Services 节点下查看 DTS 包，请连接到数据库引擎的已升级实例。（如果连接到 Integration Services 服务，则只能查看 Integration Services 包。）

  • 若要在 Integration Services 包中运行 DTS 包，请使用执行 DTS 2000 包任务。有关详细信息，请参阅执行 DTS 2000 包任务。

  • 若要在命令提示符下运行 DTS 包，请使用 dtsrun.exe 实用工具。

  • 若要从 SQL Server 代理作业运行 DTS 包，请从作业步骤调用 dtsrun.exe 实用工具。

有关如何运行包的详细信息，请参阅运行 Data Transformation Services (DTS) 包。

请参阅

概念

支持 SQL Server 2008 中的 Data Transformation Services (DTS)

其他资源

互操作性和共存 (Integration Services)


升级 Data Transformation Services 操作指南主题

升级 Data Transformation Services 操作指南主题 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Data Transformation Services 时的注意事项 >

本节包含以下说明如何从 Microsoft SQL Server 2000 Data Transformation Services (DTS) 升级到 SQL Server Integration Services 的通用步骤：

  • 如何从 Data Transformation Services 升级到 Integration Services

有关如何安装 Integration Services 的信息，请参阅安装 Integration Services 的注意事项。

有关如何确保在升级到 Integration Services 后支持 DTS 的信息，请参阅如何安装 Data Transformation Services 包的支持组件。

请参阅

概念

支持 SQL Server 2008 中的 Data Transformation Services (DTS)

其他资源

迁移 Data Transformation Services 包


如何从 Data Transformation Services 升级到 Integration Services

如何从 Data Transformation Services 升级到 Integration Services |
 | 请参阅
升级到 SQL Server 2008 > 升级 Data Transformation Services 时的注意事项 > 升级 Data Transformation Services 操作指南主题 >

以下过程说明如何使用安装程序将 SQL Server 2000 Data Transformation Services (DTS) 安装升级到 Integration Services。有关详细信息，请参阅升级 Data Transformation Services 时的注意事项。

SQL Server 2008 不会安装对 DTS 包的运行时支持。您必须先安装此运行时支持，然后才能运行 DTS 包。有关如何安装 DTS 支持的信息，请参阅如何安装 Data Transformation Services 包的支持组件。有关 SQL Server 2008 中的 DTS 支持的详细信息，请参阅支持 SQL Server 2008 中的 Data Transformation Services (DTS)。

升级后，还可以选择使用 DTS 包迁移向导将 DTS 包迁移为 Integration Services 格式。在迁移过程中，该向导将复制 DTS 包，然后以 Integration Services 格式重新创建这些包。源包将保持不变且不会被修改。有关详细信息，请参阅迁移 Data Transformation Services 包。

注意：
以下 SQL Server 版本中提供了 DTS 包迁移向导：Standard Edition、Enterprise Edition 和 Developer Edition。

有关如何升级的详细信息，请参阅如何升级到 SQL Server 2008（安装程序）。

从 Data Transformation Services 升级到 Integration Services

  • 运行 SQL Server 2008 安装程序并选择“从 SQL Server 2000 或 SQL Server 2005 升级”。

    - 或者 -

  • 在命令提示符下，运行 setup.exe 并指定 /ACTION=upgrade 选项。

    有关如何在命令提示符下进行安装的详细信息，请参阅如何从命令提示符安装 SQL Server 2008 中的“Integration Services 的安装脚本”部分。

请参阅

任务

如何安装 Data Transformation Services 包的支持组件

概念

支持 SQL Server 2008 中的 Data Transformation Services (DTS)


迁移 Data Transformation Services 包

迁移 Data Transformation Services 包 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Data Transformation Services 时的注意事项 >

Integration Services 提供了多个选项用于保留使用 SQL Server 2000 Data Transformation Services (DTS) 工具和对象模型创建的解决方案。可以将 DTS 包迁移为 Integration Services 格式，使用 DTS 运行库继续运行 DTS 包，或者使用“执行 DTS 2000 包”任务将 DTS 包并入 Integration Services 解决方案中。

注意：
有关对在早期版本的 Integration Services 中创建的包进行升级的信息，请参阅升级 Integration Services 包。

当将 DTS 包迁移为 Integration Services 格式时，所迁移包的结构以及迁移完整性将取决于原始包的内容。迁移包可能会产生以下结果：

  • 有些包可成功地完全迁移，因为这些包所包含的任务和使用的功能都可映射为 Integration Services 任务和功能。

  • 包中含有不能直接迁移到 Integration Services 任务和功能的 DTS 任务和功能，但是通过使用封装的 DTS 包，包的功能将保留下来。

  • 在某些情况下，例如包名称含有无效字符 (/ \ : [ ] . =) 或包包含未注册的对象时，包迁移向导在这些问题解决前将无法执行迁移。

注意：
包迁移向导将保持 DTS 包不变。

如果包中的所有任务都可映射到 Integration Services 中的新任务，则所迁移包的结构与 DTS 包的结构非常相似。相反，如果任务不能直接映射到 Integration Services 任务，则迁移过程将更改包结构。每个不可迁移的任务将保留其 DTS 格式，并封装在“执行 DTS 2000”任务中。包中的自定义任务也以这种方式进行迁移。有关详细信息，请参阅 迁移任务。

其他包元素（例如，优先约束、连接和变量）迁移为 Integration Services 中的等效元素。有关详细信息，请参阅迁移优先约束、迁移连接和迁移变量。

包的密码将不进行迁移。但是，Integration Services 支持 DTS 包中和“执行 DTS 2000 包”任务中的包密码。Integration Services 包内的“执行 DTS 2000 包”任务可将包密码传递给 DTS 包。有关详细信息，请参阅迁移密码。

Integration Services 中的 ActiveX 脚本任务通常无需额外修订即可运行从 DTS 包中的 ActiveX 脚本迁移的脚本代码。但是，不支持对 DTS 包对象的引用。有关详细信息，请参阅迁移脚本。

在 DTS 设计器中输入的文本批注、包日志记录以及错误处理设置都不会迁移。

迁移包之后，应当打开所迁移的包检查有无问题，包括有无验证失败。例如，某些包依赖于同一包中先前完成的任务才能创建或准备数据源或数据目标，如果找不到这些对象，则验证可能会失败。通过将任务或其他容器对象的 DelayValidation 属性设置为 true，或将受影响的数据流组件的 ValidateExternalMetadata 属性设置为 false，可以解决此类验证失败问题。

注意：
将包从 Management Studio 中迁移后，请在对象资源管理中连接到 Integration Services 的本地实例以查看迁移的包。如果将 SQL Server 选定为目标，则迁移的包将显示在 MSDB 节点下。如果选择文件系统文件夹作为目标，请右键单击“文件系统”节点，并选择“导入包”以显示迁移的包。从 BI Development Studio 内迁移包后，迁移的包将保存到您指定的文件系统文件夹，并添加到“SSIS 包”节点下已打开的项目中。

DTS 包无法在 BI Development Studio 中直接打开或编辑。

有关 Integration Services 中对 DTS 支持的一般信息，请参阅支持 SQL Server 2008 中的 Data Transformation Services (DTS)。

本节内容

使用 DTS 包迁移向导

介绍包迁移向导提供的迁移过程。

已知的 DTS 包迁移问题

列出了包迁移向导或升级顾问可标识的已知包迁移问题。

迁移任务

介绍包迁移向导如何迁移任务，以及迁移后可用于修复任务或增强任务行为的步骤。

迁移优先约束

介绍包迁移向导如何迁移优先约束，以及迁移后可用于增强优先约束行为的步骤。

迁移变量

介绍包迁移向导如何迁移变量，以及迁移后可用于修复或增强变量行为的步骤。

迁移连接

介绍包迁移向导如何迁移连接，以及迁移后可用于编辑连接属性的步骤。

迁移密码

介绍包迁移向导如何迁移密码，以及迁移后可用于提高安全性的其他步骤。

迁移脚本

介绍包迁移向导如何迁移 ActiveX 脚本。

请参阅

任务

如何安装 Data Transformation Services 包的支持组件

概念

Integration Services 的向后兼容性

其他资源

SQL Server Integration Services


使用 DTS 包迁移向导

使用 DTS 包迁移向导 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Data Transformation Services 时的注意事项 > 迁移 Data Transformation Services 包 >

Integration Services 提供的 DTS 包迁移向导可用于迁移通过 DTS 工具和对象模型创建的 SQL Server 2000 Data Transformation Services (DTS) 包。

注意：
SQL Server 的 Standard Edition、Enterprise Edition 和 Developer Edition 提供了包迁移向导。

注意：
有关对在早期版本的 Integration Services 中创建的包进行升级的信息，请参阅升级 Integration Services 包。

注意：
对于保存在 SQL Server 7.0 实例的 msdb 数据库中的 DTS 包，升级顾问无法对其进行分析，并且包迁移向导无法对其进行迁移。但是，对于保存为结构化存储文件或保存在已升级到 SQL Server 2005 的 SQL Server 7.0 实例的 msdb 数据库中的 SQL Server 7.0 DTS 包，升级顾问可以对其进行分析，包迁移向导也可以对其进行迁移。

不是所有的包都可被完全迁移。例如，某些 DTS 任务不映射到 Integration Services 任务，自定义任务无法迁移，ActiveX 脚本任务中或数据转换中的某些脚本无法迁移。有关详细信息，请参阅迁移任务和已知的 DTS 包迁移问题。

以 DTS 包格式留下来的包可在 Integration Services 解决方案中使用，也可作为独立的 DTS 包继续运行。

许多 DTS 包受密码保护。如果您迁移这些包，则包迁移向导将提示您提供这些包的密码。如果不提供正确的密码，则不能迁移受密码保护的包。

SQL Server 不安装 Meta Data Services 的支持组件。仅当在本地计算机上安装了 SQL Server 2000、SQL Server 2000 工具或存储库可再分发文件时，包迁移向导才支持 Meta Data Services（存储库）包。如果存在存储库文件，则包迁移向导可以迁移被保存到 Meta Data Services 的 DTS 包。当存储库文件不存在时，包迁移向导只能迁移保存到 SQL Server 或结构化存储文件中的 DTS 包。

启动包迁移向导

可以从以下三个位置启动包迁移向导。

  • SQL Server Management Studio。连接到 SQL Server 数据库引擎的实例，在对象资源管理器中，右键单击“管理\早期”下的 Data Transformation Services 节点，然后选择“迁移向导”。

  • Business Intelligence Development Studio。创建或打开一个 Integration Services 项目，在解决方案资源管理器中，右键单击“SSIS 包”节点，然后选择“迁移 DTS 2000 包”。

  • 命令提示符。启动 C:\Program Files\Microsoft SQL Server\100\DTS\Binn 文件夹中的 DTSMigrationWizard.exe。

选择包源

包迁移向导可以迁移保存到 SQL Server msdb 数据库、结构化存储文件或 Meta Data Services 中的 DTS 包。不能迁移保存到 Visual Basic 文件中的包。

重要提示：
SQL Server 不安装 Meta Data Services 的支持组件。仅当计算机上有 SQL Server 2000、SQL Server 2000 工具或存储库可再分发文件时，包迁移向导才能够访问保存到 Meta Data Services 的 DTS 包。

如果包位于 msdb 数据库或 Meta Data Services 中，则用户需提供服务器名，然后包迁移向导会使用 Windows 身份验证或 SQL Server 身份验证来验证该用户的身份。

如果包位于结构化存储文件中，请选择要迁移的文件。结构化存储文件可包含多个包的定义，并可包含一个包的多个版本。可迁移该文件中的部分或全部包和包版本。

有关详细信息，请参阅选择源位置（DTS 包升级向导）。

选择包目标

包迁移向导可将包迁移到 SQL Server 实例中的 msdb 数据库，或者迁移到一个 .dtsx 文件。.dtsx 文件是保存到文件系统中的包定义的 XML 表示形式。

如果目标为 SQL Server，则用户需提供服务器名，然后包迁移向导会使用 Windows 身份验证或 SQL Server 身份验证来验证该用户的身份。

有关详细信息，请参阅选择目标位置（DTS 包升级向导）。

注意：
从 Management Studio 内迁移包后，连接到对象资源管理器中的 Integration Services 的本地实例，以查看迁移的包。如果将 SQL Server 选定为目标，则迁移的包将显示在 MSDB 节点下。如果选择文件系统文件夹作为目标，请右键单击“文件系统”节点，并选择“导入包”以显示迁移的包。从 BI Development Studio 内迁移包后，迁移的包将保存到您指定的文件系统文件夹，并添加到“SSIS 包”节点下已打开的项目中。

无法在 BI Development Studio 中打开或编辑 DTS 包。

选择要迁移的包

指定源和目标后，包迁移向导将列出 msdb 数据库、Meta Data Services 或指定的结构化存储文件中可用的包。可以选择要迁移的包，并可更新包迁移向导为该包提供的默认名称。迁移包后，还可以在 Business Intelligence Development Studio 或 SQL Server Management Studio 中更新包名称。

有关详细信息，请参阅列出包（DTS 包迁移向导）。

提供包密码

使用 SQL Server 工具的早期版本开发的包可能受密码保护。必须提供正确的密码，然后向导才能访问这些包的包定义并迁移它们。如果多个包共享一个密码，则只能提供一次该密码。直到您提供了所有受密码保护的包的密码之后，包迁移向导才能继续。如果没有受密码保护的包，则向导将跳过此步骤。

记录迁移错误

可以使包迁移向导记录在迁移过程中出现的错误。

有关详细信息，请参阅Specify a Log File (DTS Package Migration Wizard)。

查看迁移进程

包迁移向导逐一迁移所选包。如果向导无法迁移某个包，它将提供选项以结束所有剩余包的迁移进程，或者跳过该包并继续迁移列表中的下一个包。每个包迁移后，其迁移状态都将更新。

有关详细信息，请参阅Complete the Wizard (DTS Package Migration Wizard)和Migrating the Packages (DTS Package Migration Wizard)。

检查迁移的包

迁移包之后，应当在 Business Intelligence Development Studio 中打开所迁移的包，检查有无问题，包括有无验证失败。例如，某些包依赖于同一包中先前完成的任务才能创建或准备数据源或数据目标，如果找不到这些对象，则验证可能会失败。通过将任务或其他容器对象的 DelayValidation 属性设置为 true，或将受影响的数据流组件的 ValidateExternalMetadata 属性设置为 false，可以解决此类验证失败问题。

注意：
从 Management Studio 内迁移包后，连接到对象资源管理器中的 Integration Services 的本地实例，以查看迁移的包。如果将 SQL Server 选定为目标，则迁移的包将显示在 MSDB 节点下。如果选择文件系统文件夹作为目标，请右键单击“文件系统”节点，并选择“导入包”以显示迁移的包。从 BI Development Studio 内迁移包后，迁移的包将保存到您指定的文件系统文件夹，并添加到“SSIS 包”节点下已打开的项目中。

请参阅

任务

如何安装 Data Transformation Services 包的支持组件

其他资源

迁移 Data Transformation Services 包


已知的 DTS 包迁移问题

已知的 DTS 包迁移问题 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Data Transformation Services 时的注意事项 > 迁移 Data Transformation Services 包 >

这是对使用包迁移向导将 Microsoft SQL Server 2000 Data Transformation Services (DTS) 包迁移为 Integration Services 格式时可能遇到的问题的摘要。

某些 SQL Server 2000 DTS 功能在 Integration Services 中没有直接等效项，包迁移向导通过将这些功能封装在执行 DTS 2000 包任务中来迁移它们。在很多情况下，尽管可以运行这些迁移包而不会出错，但最终必须替换掉封装在执行 DTS 2000 包任务中的功能。

迁移这些包后，应打开所迁移的包以检查是否有问题，包括验证是否失败。例如，某些包依赖于同一包中先前完成的任务才能创建或准备数据源或数据目标，如果找不到这些对象，则验证可能会失败。通过将任务或其他容器对象的 DelayValidation 属性设置为 true，或将受影响的数据流组件的 ValidateExternalMetadata 属性设置为 false，可以解决此类验证失败问题。

有关 Integration Services 中对 DTS 支持的一般信息，请参阅 支持 SQL Server 2008 中的 Data Transformation Services (DTS)。

由升级顾问检测到的已知问题

下表列出了出现在由 SQL Server 升级顾问生成的报表中的各个迁移问题，以及对每个问题的简短说明。包迁移向导和升级顾问识别并报告相同的潜在包迁移问题。

问题标题 问题说明

包迁移之后重新配置事务设置

Integration Services 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的事务设置。迁移之后，必须手动编辑所产生的 SSIS 包，以还原以前的包行为。

纠正操作：迁移后，在 Business Intelligence Development Studio 中对包设置适当的与事务相关的属性及其组件，来重新对包创建所需的事务设置。有关详细信息，请参阅 在包中合并事务。

包迁移之后附加到包步骤上的 ActiveX 脚本的替换功能

Integration Services 包迁移向导不迁移与 SQL Server 2000 Data Transformation Services (DTS) 包中的步骤相关联的 ActiveX 脚本。迁移之后，必须手动编辑所产生的 SSIS 包，以还原以前的包行为。

纠正操作：迁移后，根据相应情况用新的脚本任务或其他 Integration Services 对象替换缺少的脚本。有关详细信息，请参阅脚本任务。

包迁移之后在执行 DTS 2000 包任务中封装的 Analysis Services 任务的替换功能

Integration Services 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的 Analysis Services 任务。已迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。

纠正操作：迁移后，将封装 Analysis Services 任务的执行 DTS 2000 任务转换为 Integration Services Analysis Services 处理任务。有关详细信息，请参阅Analysis Services 处理任务。

包迁移之后在执行 DTS 2000 包任务中封装的复杂数据转换任务的替换功能

Integration Services 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的复杂数据转换任务。已迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。

纠正操作：迁移后，使用 Integration Services 数据流源、转换以及目标来重写复杂数据转换任务。有关详细信息，请参阅创建包数据流和数据流元素。

包迁移之后在执行 DTS 2000 包任务中封装的自定义任务的替换功能

Integration Services 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的自定义任务。已迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。

纠正操作：迁移后，如果所需的功能不在某个内置 Integration Services 组件或组件的组合中，则使用脚本任务、脚本组件或自定义组件来重新创建自定义任务的逻辑。有关编程解决方案的信息，请参阅 Developer's Guide (Integration Services)。

包迁移之后在执行 DTS 2000 包任务中封装的数据驱动的查询任务的替换功能

Integration Services 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的数据驱动的查询任务。已迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。

纠正操作：迁移后，使用 Integration Services 数据流组件重新创建数据驱动的查询任务的功能。替换数据驱动的查询任务的功能时，请考虑使用渐变维度转换、条件性拆分转换或 OLE DB 命令转换。

包迁移之后在执行 DTS 2000 包任务中封装的数据挖掘预测查询任务的替换功能

Integration Services 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的数据挖掘预测查询任务。迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。SQL Server 不安装对 SQL Server 2000 数据挖掘预测查询任务的支持；因此，在没有 SQL Server 2000 Analysis Services 的情况下，迁移的包在升级后将不运行。

纠正操作：迁移后，将封装数据挖掘预测查询任务的执行 DTS 2000 任务转换为 Integration Services 数据挖掘查询任务或数据挖掘查询转换。有关详细信息，请参阅数据挖掘查询任务和数据挖掘查询转换。

包迁移之后动态属性任务的替换功能

Integration Services 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的动态属性任务。迁移之后，必须手动编辑所产生的 SSIS 包，以还原以前的包行为。

纠正操作：迁移后，使用 Integration Services 功能（例如变量、属性表达式和包配置）来重新创建动态属性任务的功能。有关详细信息，请参阅 Integration Services 变量、在包中使用变量、在包中使用属性表达式及包配置。

包迁移之后在执行 DTS 2000 包任务中封装的执行包任务（加载 Meta Data Services 包）的替换功能

Integration Services 包迁移向导不迁移将加载 Meta Data Services 包的执行包任务。迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。SQL Server 不安装对 SQL Server 2000 Meta Data Services 的支持；因此，在没有 SQL Server 2000 客户端工具的情况下，迁移的包在升级后将不运行。

纠正操作：迁移后，将 Meta Data Services 包移到 SQL Server 存储区（位于 msdb 数据库中）或移到结构化存储文件，并且将封装执行包任务（该任务加载 Meta Data Services 包）的执行 DTS 2000 任务转换为从 SQL Server 或结构化存储文件加载包的执行 DTS 2000 任务。有关详细信息，请参阅保存包。

包迁移之后在执行 DTS 2000 包任务中封装的并行数据抽取任务的替换功能

Integration Services 包迁移向导不迁移 SQL Server 2000 Data Transformation Services (DTS) 包中的并行数据抽取任务。已迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。

纠正操作：迁移后，使用 Integration Services 数据流组件重新创建并行数据抽取任务的功能。有关详细信息，请参阅创建包数据流和数据流元素。

包迁移之后在执行 DTS 2000 包任务中封装的 UDL 连接的替换功能

Integration Services 包迁移向导不迁移从 Microsoft 数据链接 (.udl) 文件获得连接信息的任务。已迁移的包将包含封装的 DTS 功能，该功能最终必须被替换。

纠正操作：迁移后，将封装 UDL 文件连接的执行 DTS 2000 任务转换为使用 Integration Services 连接管理器的等效 Integration Services 任务。有关详细信息，请参阅连接管理器和创建连接管理器。

迁移包后重写访问 DTS 对象模型的 ActiveX 脚本代码

Integration Services 包迁移向导不迁移通过 SQL Server 2000 Data Transformation Services (DTS) 包中 GlobalVariables 集合的 Parent 属性访问 DTS 对象模型的 ActiveX 脚本代码。迁移之后，必须手动编辑所产生的 SSIS 包，以还原以前的包行为。

纠正操作：迁移后，修改脚本代码或重写 ActiveX 脚本任务，以便通过其他方式（如使用变量）从包中获取所需的信息。有关详细信息，请参阅 Integration Services 变量和在包中使用变量。

升级顾问未检测到的已知问题

包迁移向导或升级顾问未检测到或未报告的问题如下。

问题标题 | 问题说明
包迁移后，删除和重新创建 ODBC 连接 | 如果迁移后尝试编辑 ODBC 连接，则连接会产生错误。 纠正操作：如果已经将包迁移完毕，则可以删除再重新创建 ODBC 连接。SQL Server Service Pack 1 中已修复此问题。安装 Service Pack 1 或更高版本可避免此问题再次发生。

请参阅

概念

Integration Services 的向后兼容性


迁移任务

迁移任务 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Data Transformation Services 时的注意事项 > 迁移 Data Transformation Services 包 >

许多 SQL Server 2000 Data Transformation Services (DTS) 任务直接映射为 Integration Services 任务，将包迁移到 Integration Services 可以将 SQL Server 2000 版本的任务替换为该任务的 Integration Services 等效任务。

下表列出这两种任务版本间的直接映射。

SQL Server 2000 任务 | SQL Server 2005 任务
ActiveX 脚本任务 | ActiveX 脚本任务
大容量插入任务 | 大容量插入任务
复制 SQL Server 对象任务 | 传输 SQL Server 对象任务
数据挖掘预测任务 | 数据挖掘查询任务
执行包任务 | 执行 DTS 2000 包任务
执行进程任务 | 执行进程任务
执行 SQL 任务 | 执行 SQL 任务
文件传输协议任务 | FTP 任务
消息队列任务 | 消息队列任务
发送邮件任务 | 发送邮件任务
传输数据库任务、传输错误消息任务、传输作业任务、传输登录名任务和传输主存储过程任务 | 传输 SQL Server 对象任务、传输数据库任务、传输错误消息任务、传输作业任务、传输登录名任务和传输主存储过程任务。
注意：
完成包迁移之后，尝试通过使用 GlobalVariables 集合的 Parent 属性来访问包对象模型的 ActiveX 脚本任务将失败。

某些 SQL Server 2000 任务不直接映射为 Integration Services 任务：

  • Analysis Services 任务（因为 Integration Services Analysis Services 任务不能与 Analysis Services 的 SQL Server 2000 实例一起运行）

  • 数据驱动的查询任务

  • 动态属性任务

  • 转换数据任务

在 SQL Server 中，这些任务中的有些任务被替换为非任务功能。下表列出了 SQL Server 2000 任务与其等效的 SQL Server 非任务功能之间的映射。

SQL Server 2000 任务 | SQL Server 2005 功能
动态属性 | 配置和属性表达式。有关详细信息，请参阅创建包配置。
转换数据 | 数据流任务和数据流元素。
数据驱动的查询 | 替换数据驱动的查询任务的功能时，请考虑使用渐变维度转换、条件性拆分转换和 OLE DB 命令转换。

自定义任务

包含自定义任务的包将以特殊方式被迁移到 SQL Server。对于每个自定义任务，都创建一个 SQL Server 2000 包，然后将调用该 SQL Server 2000 包的执行 DTS 2000 包任务添加到所迁移的包中。新的 SQL Server 2000 包（称为中间包）被嵌入到进行迁移的包内，并且不单独保存。例如，具有三项自定义任务的 SQL Server 2000 包将转换成包含三项执行 DTS 2000 包任务的 SQL Server 包，其中每项执行 DTS 2000 包任务指向一个封装一项自定义任务的嵌入的 SQL Server 2000 包。

数据抽取任务

有三项 SQL Server 2000 任务基于 SQL Server 2000 DTS 数据抽取，这三项任务是数据驱动的查询任务、转换数据任务和 ParallelDataPump 任务。除了简单的数据转换任务之外，这些任务都以与自定义任务相同的方式进行迁移。包迁移向导为每项任务创建新的 SQL Server 2000 包，然后将与每项数据抽取任务对应的执行 DTS 2000 包任务添加到新的包。

动态属性任务

动态属性任务不能迁移到 SQL Server。如果尝试迁移具有动态属性任务的包，包迁移向导将发出警告。如果选择迁移这样的包，则在迁移后的包中将由占位符任务替换动态属性任务。占位符任务是一种脚本任务，该脚本任务列出可能要在脚本任务中转换为脚本的动态属性任务中的“属性-值”对。此信息以脚本注释的形式写入脚本任务中。

在 SQL Server 中，配置可以替换和增强动态属性任务中可用的功能。有关详细信息，请参阅创建包配置。

请参阅

其他资源

迁移 Data Transformation Services 包


迁移优先约束

迁移优先约束 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Data Transformation Services 时的注意事项 > 迁移 Data Transformation Services 包 >

将 SQL Server 2000 Data Transformation Services (DTS) 包中的优先约束迁移到新包的 PrecedenceConstraints 集合中。

优先约束的扩展功能

迁移包后，可通过以下方法扩展优先约束：

  • 将表达式与前面可执行文件的执行结果共同使用或替换该执行结果，以指定运行受约束任务的条件。有关详细信息，请参阅将表达式添加到优先约束。

  • 结合多个优先约束以指定运行受约束任务的条件。有关详细信息，请参阅应用多个优先约束。

请参阅

其他资源

迁移 Data Transformation Services 包
优先约束


迁移变量

迁移变量 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Data Transformation Services 时的注意事项 > 迁移 Data Transformation Services 包 >

在 Integration Services 中，所有容器都可使用 Variables 集合，这些容器包括：包、循环结构（例如 Foreach 容器）以及封装每个任务的 TaskHost 容器。迁移包时，全局变量以及来自 SQL Server 2000 DTS 任务的变量都被迁移到该包的 Variables 集合中。例如，SQL Server 2000 执行 SQL 任务使用的变量被添加到已迁移包的 Variables 集合中。

Integration Services 使用命名空间来组织变量。所有 DTS 变量都迁移到 User 命名空间中。

扩展变量的功能

迁移包后，可使用以下方法向变量添加功能：

  • 创建其他命名空间，并按命名空间组织变量。

  • 使用表达式来设置变量值。

  • 指定更新变量值时是否引发事件。

有关详细信息，请参阅 Integration Services 变量和在包中使用变量。

请参阅

其他资源

迁移 Data Transformation Services 包


迁移连接

迁移连接 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Data Transformation Services 时的注意事项 > 迁移 Data Transformation Services 包 >

将 SQL Server 2000 Data Transformation Services (DTS) 包中的连接迁移到 SQL Server，并且转换为适当连接类型的连接管理器。

连接管理器是与数据源所进行的连接的逻辑表示形式。连接管理器指定物理连接的属性，该物理连接在运行包时由运行时引擎所创建。一个迁移的包可有多个连接管理器，这些连接管理器具有相同的连接类型，但各自配置不同。有关详细信息，请参阅连接管理器。

使用连接并可毫无问题地迁移到 SQL Server 的 SQL Server 2000 任务只有执行 SQL 任务。该任务的连接将作为 OLE DB 或 ODBC 连接管理器来迁移。现有连接管理器中以前未设置的所有属性在新连接管理器中被设置为默认值。有关详细信息，请参阅 OLE DB 连接管理器和 ODBC 连接管理器。

注意：
在某些情况下，SQL Server 2000 数据转换任务可与其连接一起成功地进行迁移。数据驱动的查询任务和并行数据抽取任务都被迁移到执行 DTS 2000 包任务中。有关详细信息，请参阅迁移任务和已知的 DTS 包迁移问题。

在 SQL Server 2000 任务中使用但无法迁移到 SQL Server 的所有连接将留在 SQL Server 2000 中间包中，该中间包是作为迁移的组成部分而创建的。例如，SQL Server 2000 转换数据任务中的连接留在封装转换数据任务的 SQL Server 2000 中间包中。

更新连接管理器的属性

连接管理器中包括设置为默认值的属性。

下表列出了这些属性。

属性 | 说明
DelayValidation | 用于指定是否将连接验证延迟到包运行时为止的值。包迁移向导将此属性设置为 False。
Description | 连接管理器的说明。包迁移向导将此属性留空。

请参阅

其他资源

迁移 Data Transformation Services 包


迁移密码

迁移密码 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Data Transformation Services 时的注意事项 > 迁移 Data Transformation Services 包 >

SQL Server 只对与某些包保护级别选项有关的包使用密码。因此，受密码保护的包在从 SQL Server 2000 完全迁移到 SQL Server 后不保留密码，尽管在迁移过程中必须提供密码。有关 SQL Server 中的包保护级别的信息，请参阅设置包的保护级别。

注意：
迁移受密码保护的包时，必须提供这些包的密码，否则无法迁移。

如果安装了 SQL Server 2000 的 DTS 运行时引擎，则可以继续运行 SQL Server 2000 包。还可以将这些包包含在 SQL Server 数据转换解决方案中。在这种情况下，SQL Server 将继续支持包密码。例如，执行 DTS 2000 包任务包含一个密码属性，该属性用于将密码传递给 SQL Server 2000 包。

向包中添加安全功能

迁移包后，可以添加以下安全功能：

  • 对包设置保护级别，即保存包时，是加密所有属性值还是只加密敏感属性值。有关详细信息，请参阅 Integration Services 包。

  • 对包进行数字签名，并设置属性以确保加载包时检查该签名。有关详细信息，请参阅对包进行数字签名。

    重要提示：
    在配置为检查包签名时，Integration Services 仅检查数字签名是否存在、是否有效以及是否来自可信来源。Integration Services 不检查包是否已更改。

  • 对使用检查点的包加密检查点。有关详细信息，请参阅在包中使用检查点。

有关保护 Integration Services 服务和 Integration Services 包的详细信息，请参阅安全性概述 (Integration Services)。

请参阅

其他资源

迁移 Data Transformation Services 包


迁移脚本

迁移脚本 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Data Transformation Services 时的注意事项 > 迁移 Data Transformation Services 包 >

SQL Server 2000 版本的 ActiveX 脚本任务可迁移到 SQL Server ActiveX 脚本任务。但是，提供 SQL Server ActiveX 脚本任务只是为了向后兼容。迁移后，应使用 Integration Services 功能替换 ActiveX 脚本任务。

如果您的脚本包含管理包中控制流的代码，则可以使用 Integration Services 中的新控制流功能（如循环容器和更加灵活的优先约束）替换这些脚本。有关详细信息，请参阅 Integration Services 容器和优先约束。

您可以使用 Integration Services 脚本任务中的托管代码替换脚本中的其他自定义逻辑。有关 Integration Services 脚本任务的详细信息，请参阅脚本任务。

完成包迁移之后，尝试通过使用 GlobalVariables 集合的 Parent 属性来访问包对象模型的 ActiveX 脚本任务将失败。必须使用不同的脚本代码或新的 Integration Services 功能取代原来的功能。

请参阅

其他资源

ActiveX 脚本任务
脚本任务
迁移 Data Transformation Services 包


迁移 Data Transformation Services 包操作指南主题

迁移 Data Transformation Services 包操作指南主题 |
 | 请参阅
升级到 SQL Server 2008 > 升级 Data Transformation Services 时的注意事项 >

本部分包含以下用于将 SQL Server 2000 Data Transformation Services (DTS) 包迁移到 Microsoft Integration Services 的常用步骤：

  • 如何将 Data Transformation Services 包迁移到 Integration Services

有关安装 Integration Services 的常用步骤，请参阅 Integration Services 安装操作指南主题。

请参阅

概念

升级 Data Transformation Services 时的注意事项
Integration Services 的向后兼容性


如何将 Data Transformation Services 包迁移到 Integration Services

如何将 Data Transformation Services 包迁移到 Integration Services |
 | 请参阅
升级到 SQL Server 2008 > 升级 Data Transformation Services 时的注意事项 > 迁移 Data Transformation Services 包操作指南主题 >

您不是必须将 SQL Server 2000 Data Transformation Services (DTS) 包迁移为 Integration Services 包格式。DTS 包可继续与 Integration Services 包一起运行。

注意：
有关对在早期版本的 Integration Services 中创建的包进行升级的信息，请参阅升级 Integration Services 包。

如果要迁移 DTS 包，可以使用 SQL Server 提供的 DTS 包迁移向导来帮助完成此过程。由于该向导不改变原始包，因此如果迁移有困难，您始终可以继续使用原始包。

安装 Integration Services 时，将安装包迁移向导。有关详细信息，请参阅如何安装 Data Transformation Services 包的支持组件。

注意：
SQL Server 的 Standard Edition、Enterprise Edition 和 Developer Edition 提供了包迁移向导。

有关迁移 DTS 包的详细信息，请参阅迁移 Data Transformation Services 包。

有关升级和迁移 Data Transformation Services 用户可用的选项的详细信息，请参阅升级 Data Transformation Services 时的注意事项。

有关 Integration Services 中对 DTS 支持的一般信息，请参阅支持 SQL Server 2008 中的 Data Transformation Services (DTS)。

将 Data Transformation Services 包迁移到 Integration Services

  1. 根据需要，可以运行升级顾问来分析现有的包并获取潜在迁移问题的报表。有关详细信息，请参阅已知的 DTS 包迁移问题。

  2. 运行包迁移向导来迁移包。

  3. 请重新配置升级顾问或向导所报告的必须手动重新配置的包项。

  4. 根据需要对迁移的包进行测试并排除故障。

请参阅

任务

如何安装 Data Transformation Services 包的支持组件

概念

Integration Services 的向后兼容性


升级复制数据库时的注意事项

升级复制数据库时的注意事项 |
 | 请参阅
升级到 SQL Server 2008 >

SQL Server 2008 支持从 SQL Server 的早期版本升级复制数据库；在升级某一节点时，不需要停止其他节点的活动。请务必遵守有关拓扑中支持哪些版本的规则：

  • SQL Server 2000 Service Pack 3 (SP3) 是参与 SQL Server 2008 的复制拓扑必需的最低版本。如果使用的是 SQL Server 2005，则没有必需的最低版本。

  • 分发服务器的版本可以是高于或等于发布服务器版本的任何版本（在许多情况下，分发服务器与发布服务器是同一个实例）。

  • 发布服务器的版本可以是低于或等于分发服务器版本的任何版本。

  • 订阅服务器版本取决于发布的类型：

    • 用于事务发布的订阅服务器版本可以是两个发布服务器版本中的任何一个版本。例如，SQL Server 2000 发布服务器可以对应 SQL Server 2008 订阅服务器，而 SQL Server 2008 发布服务器可以对应 SQL Server 2000 订阅服务器。

    • 合并发布的订阅服务器版本可以是低于或等于发布服务器版本的任何版本。

注意：
在“安装帮助”文档和 SQL Server 联机丛书中可以查看此主题。对于“安装帮助”文档中显示为粗体文本的主题链接来说，所指向的主题仅在联机丛书中提供。

在升级前先运行用于事务复制的日志读取器代理

升级到 SQL Server 2008 之前，必须确保已发布表的所有已提交事务已由日志读取器代理进行了处理。若要确保所有事务均得到处理，请针对包含事务发布的每个数据库执行以下步骤：

  1. 确保针对数据库运行了日志读取器代理。默认情况下，该代理会连续运行。

  2. 停止已发布表上的用户活动。

  3. 日志读取器代理和分发代理支持事务读取和提交操作的批大小。

  4. 执行 sp_replcmds 以验证所有事务是否得到了处理。此过程的结果集应为空。

  5. 执行 sp_replflush 以关闭与 sp_replcmds 的连接。

  6. 将服务器升级到 SQL Server 2008。

  7. 如果在升级后 SQL Server 代理和日志读取器代理没有自动启动，请重新启动它们。

升级后运行用于合并复制的代理

升级后，请为每一个合并发布运行快照代理，并为每一个订阅运行合并代理，以更新复制元数据。因为不必重新初始化订阅，所以不需要应用新快照。升级后首次运行合并代理时，将更新订阅元数据。这表明发布服务器升级时订阅数据库可以保持在线状态和活动状态。

合并复制将发布和订阅元数据存储在发布和订阅数据库中的若干系统表中。运行快照代理将更新发布元数据，而运行合并代理将更新订阅元数据。只需生成发布快照。如果合并发布使用参数化筛选器，则每一个分区也都有快照。不必更新这些分区快照。（在 SQL Server 2000 中，“参数化筛选器”称为“动态筛选器”，“分区快照”称为“动态快照”）。

从 SQL Server Management Studio、复制监视器或命令行运行代理。有关运行快照代理的详细信息，请参阅下列主题：

  • 如何创建和应用初始快照 (SQL Server Management Studio)

  • 如何启动和停止复制代理 (SQL Server Management Studio)

  • 如何创建初始快照（复制 Transact-SQL 编程）

  • Replication Agent Executables Concepts

有关运行合并代理的详细信息，请参阅下列主题：

  • 如何同步请求订阅 (SQL Server Management Studio)

  • 如何同步推送订阅 (SQL Server Management Studio)

  • 如何同步请求订阅（复制编程）

  • 如何同步推送订阅（复制编程）

在使用合并复制的拓扑中升级 SQL Server 之后，如果要使用新功能，请更改所有发布的发布兼容级别。有关详细信息，请参阅在复制拓扑中使用 SQL Server 的多个版本。

升级至 Standard Edition、Workgroup Edition 或 Express Edition

在从 SQL Server 2008 的某一版本升级到另一版本之前，请验证要升级到的版本是否支持当前使用的功能。有关详细信息，请参阅主题 SQL Server 2008 各个版本支持的功能中的“SQL Server 2008 复制功能”部分。

新的复制代理安全模式

在版本低于 SQL Server 2005 的 SQL Server 中，默认情况下，代理在 SQL Server 2005 代理服务帐户的上下文中运行。对于在运行复制代理和建立与数据库及其他资源的 Windows 集成连接时所使用的每个帐户，SQL Server 引入了更细粒度的控制；可为每个代理指定一个不同的帐户。有关详细信息，请参阅安全性和保护（复制）和复制代理安全性模式。

新的安全模式对于在拓扑中升级和运行 SQL Server 2000 具有下列含义：

  • 从 SQL Server 2000 中创建的复制脚本应针对 SQL Server 2008 进行升级，以便利用安全性增强。有关详细信息，请参阅如何升级复制脚本（复制 Transact-SQL 编程）。

  • 从 SQL Server 2000 升级到 SQL Server 2008 的分发服务器或订阅服务器在 SQL Server 代理帐户下可继续运行，并且所拥有的权限很可能比需要的多。建议您在升级后，为具有相应最低权限的代理指定单独的帐户。指定单独的帐户：

    1. 编写发布和订阅脚本。

    2. 对脚本进行更改。有关详细信息，请参阅如何升级复制脚本（复制 Transact-SQL 编程）。

    3. 删除发布和订阅。有关详细信息，请参阅发布数据和数据库对象和订阅发布。

    4. 使用修改后的脚本重新创建发布和订阅。

    有关代理所需权限的信息，请参阅复制代理安全性模式；有关管理登录名和密码的信息，请参阅管理复制中的登录名和密码。升级后创建的新复制配置要求每一个复制代理具有特定的帐户配置。

    注意：
    任何配置为使用 SQL Server 身份验证进行本地数据库连接的代理都改用 Windows 身份验证。本地连接是指代理与它所在的同一台计算机上运行的 SQL Server 实例之间建立的连接。例如，请求订阅的合并代理运行在订阅服务器上，因此它与订阅服务器建立的连接是本地连接。

  • 对于运行 SQL Server 早期版本的复制拓扑的参与者，原复制安全模式保持不变。例如：

    • 因为合并代理或分发是在订阅服务器上创建的，所以对运行 SQL Server 2000 的订阅服务器的请求订阅不使用新的安全模式。

    • 因为合并代理或分发是在分发服务器上创建的，所以从运行 SQL Server 2008 的分发服务器到运行 SQL Server 2000 的订阅服务器的推送订阅使用新的安全模式。

    • 因为代理是在发布数据库的上下文中创建的，所以运行 SQL Server 2000 的发布服务器与运行 SQL Server 2008 的分发服务器不使用新安全模式（对于快照代理、日志读取器代理或队列读取器代理）。

  • SQL Server 2005 和 SQL Server 2008 使用相同的安全模式。

合并复制的 Web 同步

合并复制的 Web 同步选项要求将 SQL Server 复制侦听器 (replisapi.dll) 复制到用于同步的 Internet Information Services (IIS) 服务器上的虚拟目录中。配置 Web 同步时，该文件被配置 Web 同步向导复制到虚拟目录中。若要升级安装在 IIS 服务器上的 SQL Server 组件，必须将 replisapi.dll 从 COM 目录手动复制到 IIS 服务器上的虚拟目录。有关配置 Web 同步的详细信息，请参阅配置 Web 同步。

从早期版本还原复制的数据库

在从早期版本还原复制数据库的备份时，若要确保保留复制设置：请还原到与创建备份的服务器和数据库同名的服务器和数据库。

请参阅

参考

版本升级

概念

复制的向后兼容性
在复制拓扑中使用 SQL Server 的多个版本
升级到 SQL Server 2008

其他资源

管理（复制）
新增功能（复制）


升级 SQL Server 管理工具时的注意事项

升级 SQL Server 管理工具时的注意事项 |
 | 请参阅
升级到 SQL Server 2008 >

SQL Server 2008 支持从 SQL Server 2000 或 SQL Server 2005 进行升级。本主题介绍对升级 SQL Server 管理工具和管理组件（如 SQL Server 代理、数据库邮件、维护计划、XPStar 和 XPWeb）的支持及其行为。

重要提示：
对于本地安装，必须以管理员身份运行 SQL Server 安装程序。如果从远程共享位置运行 SQL Server 安装程序，必须使用对该远程共享位置具有读取和执行权限的域帐户。

已知升级问题

在升级到 SQL Server 2008 之前，请考虑以下问题：

对于所有升级方案：

  • 在升级 MSX 服务器之前，应先对所有 TSX 服务器进行升级。有关 SQL Server 中的 MSX/TSX 的详细信息，请参阅 SQL Server 联机丛书中的企业范围的自动化管理。

  • 必须同时升级 SQL Server 实例中的所有组件。在 SQL Server 2008 实例中，数据库引擎、Analysis Services 和 Reporting Services 组件的版本号必须相同。

  • 在升级到 SQL Server 2008 时可以向 SQL Server 的现有安装添加组件。有关详细信息，请参阅如何升级到 SQL Server 2008（安装程序）。

  • SQL Server 客户端工具（如 SQL Server Management Studio、SQL Server Profiler、数据库引擎优化顾问、sqlcmd、osql 等）不升级到 SQL Server 2008。相反，客户端工具与 SQL Server 早期版本中的工具并行运行。SQL Server 2008 支持从早期版本的 SQL Server 客户端工具导入设置。

  • 在升级期间，从 SQL Server 代理到 SQL Server 的身份验证将从 SQL Server 身份验证更新为 Windows 身份验证。在 SQL Server 2008 中不支持 SQL Server 身份验证。

  • 在升级到 SQL Server 2008 的过程中将保留有关作业和警报的数据。

  • 如果在要升级的实例中正在使用 SQLMail，则在升级之后将支持并启用关联的 XP。否则，将关闭它们。

  • 数据库邮件（也称为 SQLiMail）将与 SQL Server 2008 的数据库引擎组件一起升级。默认情况下，数据库邮件在升级之后将会关闭。升级之后，任何架构更新都应该与更新脚本进行协调。

从 SQL Server 2000 进行升级：

  • 在从 SQL Server 2000 升级到 SQL Server 2008 期间，升级前已有的所有用户代理帐户都将更改为临时的全局代理帐户 UpgradedProxyAccount。仅授予 UpgradedProxyAccount 访问那些显式使用过的子系统的权限，在升级完成后它也并不是对所有子系统都具有访问权限。

  • 尽管 SQL Server 代理警报和作业语法的标记替换已与 SQL Server 2000 不同，但在升级到 SQL Server 2008 的过程中不会自动更新标记。

请参阅

任务

如何升级到 SQL Server 2008（安装程序）

参考

版本升级

其他资源

Backward Compatibility


升级操作指南主题

升级操作指南主题 |
 | 请参阅
升级到 SQL Server 2008 >

本节中的主题说明如何升级 SQL Server 独立实例。

主题 说明

如何升级到 SQL Server 2008（安装程序）

要将 SQL Server 的独立实例升级到 SQL Server 2008 的过程主题。
  • 如何升级 SQL Server 故障转移群集实例（安装程序）

要将 SQL Server 故障转移群集的实例升级到 SQL Server 2008 的过程主题。
  • 如何从命令提示符安装 SQL Server 2008

提供在命令提示符处安装 SQL Server 2008 的示例语法。

请参阅

参考

版本升级

概念

向后兼容性


如何升级到 SQL Server 2008（安装程序）

如何升级到 SQL Server 2008（安装程序） |
 | 请参阅
升级到 SQL Server 2008 > 升级操作指南主题 >

SQL Server 安装向导提供了一个用来升级 SQL Server 组件的功能树。也可以将 SQL Server 2008 与早期版本并行安装，或从早期版本的 SQL Server 迁移已有的数据库和配置设置，然后将它们应用于 SQL Server 2008 的实例。

有关详细信息，请参阅以下主题：

  • 版本升级

  • 有关支持并行配置的详细信息，请参阅使用 SQL Server 的多个版本和实例。

  • 如何升级 SQL Server 故障转移群集实例（安装程序）

  • 如何从命令提示符安装 SQL Server 2008

  • 使用复制数据库向导

  • 如何使用复制数据库向导升级 SQL Server

必备项

对于本地安装，必须以管理员身份运行安装程序。如果从远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。

升级数据库引擎之前，请先查看以下主题：

  • 升级到 SQL Server 2008

  • 安装 SQL Server 2008 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

  • SQL Server 数据库引擎的向后兼容性

过程

升级到 SQL Server 2008

  1. 插入 SQL Server 安装媒体，然后双击根文件夹中的 setup.exe。若要从网络共享进行安装，请导航到共享中的根文件夹，然后双击 setup.exe。

  2. 如果出现 Microsoft .NET Framework 2.0 版 安装对话框，则选中相应的复选框以接受 .NET Framework 2.0 许可协议。单击“下一步”。若要退出 SQL Server 2008 安装，请单击“取消”。当 .NET Framework 2.0 的安装完成后，请单击“完成”。

  3. Windows Installer 4.5 也是必需的，并且可能由安装向导进行安装。如果系统提示您重新启动计算机，则重新启动计算机，然后再次运行 SQL Server 2008 setup.exe。

  4. 必备组件安装完成后，安装向导会启动 SQL Server 安装中心。若要升级 SQL Server 2008 的现有实例，请单击“从 SQL Server 2000 或 SQL Server 2005 升级”。

  5. 如果需要使用安装程序支持文件，SQL Server 安装程序将安装它们。如果安装程序指示您重新启动计算机，请在继续操作之前重新启动。

  6. 系统配置检查器将在您的计算机上运行发现操作。若要继续，请单击“确定”。系统已经为您的安装创建了安装日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 安装日志文件。

  7. 在“产品密钥”页上单击相应的单选按钮，以指示您是升级到免费版本的 SQL Server，还是您拥有该产品生产版本的 PID 密钥。有关详细信息，请参阅 SQL Server 2008 的版本和组件和版本升级。

  8. 在“许可条款”页上阅读许可协议，然后选中相应的复选框以接受许可条款和条件。若要继续，请单击“下一步”。若要结束安装程序，请单击“取消”。

  9. 在“选择实例”页上指定要升级的 SQL Server 实例。

  10. 在“功能选择”页上会预先选择要升级的功能。选择功能名称后，右侧窗格中会显示每个组件组的说明。请注意，您不能更改要升级的功能，并且不能在升级操作过程中添加功能。若要在升级操作完成后向已升级的 SQL Server 2008 实例添加功能，请参阅如何向 SQL Server 2008 的实例添加功能（安装程序）。

  11. 在“实例配置”页上指定是安装默认实例还是命名实例。有关详细信息，请参阅实例配置。

    实例 ID 后缀 - 默认情况下，使用实例名称作为实例 ID 的后缀。这用于标识 SQL Server 实例的安装目录和注册表项。默认实例和命名实例的默认方式都是如此。对于默认实例，实例名称和实例 ID 后缀均为 MSSQLSERVER。若要使用非默认的实例 ID 后缀，请选中“实例 ID 后缀”复选框，并提供一个值。

    注意：
    典型的 SQL Server 2008 独立实例（无论是默认实例还是命名实例）不会对“实例 ID 后缀”复选框使用非默认值。

    实例根目录 - 默认情况下，实例根目录为 C:\Program Files\Microsoft SQL Server\。若要指定一个非默认的根目录，请使用所提供的字段，或单击“浏览”以找到一个安装文件夹。

    所有 SQL Server Service Pack 和升级都将应用于 SQL Server 实例的每个组件。

    检测到的实例和功能 - 该网格将显示运行安装程序的计算机上的 SQL Server 实例。如果计算机上已经安装了一个默认实例，则必须安装 SQL Server 2008 的命名实例。若要继续，请单击“下一步”。

  12. “磁盘空间要求”页计算指定的功能所需的磁盘空间，并将磁盘空间要求与正在运行安装程序的计算机上的可用磁盘空间进行比较。有关详细信息，请参阅磁盘成本摘要。

  13. 本主题中的其余工作流取决于您指定安装的功能。您可能不会看到所有的页面，具体取决于您进行的选择。

  14. 在“服务器配置 - 服务帐户”页上指定 SQL Server 服务的登录帐户。此页上配置的实际服务取决于要升级的功能。

    身份验证和登录信息将继承早期的 SQL Server 实例。您可以为所有 SQL Server 服务分配相同的登录帐户，也可以单独配置各个服务帐户。还可以指定服务是自动启动、手动启动还是禁用的。Microsoft 建议您对各个服务帐户进行单独配置，以确保向 SQL Server 服务授予它们完成各自任务所需的最小权限。有关详细信息，请参阅SQL Server 配置 - 服务帐户和设置 Windows 服务帐户。

    若要为此 SQL Server 实例中的所有服务帐户指定相同的登录帐户，请在页面底部的字段中提供凭据。

    安全说明 不要使用空密码。请使用强密码。

    为 SQL Server 服务指定登录信息后，请单击“下一步”。

  15. 使用“服务器配置 - 排序规则”选项卡为数据库引擎和 Analysis Services 指定非默认的排序规则。有关详细信息，请参阅 SQL Server 配置 - 排序规则。

  16. 在“全文搜索升级选项”页上为所升级的数据库指定升级选项。有关详细信息，请参阅全文搜索升级选项。

  17. 在“错误和使用情况报告”页上指定要发送到 Microsoft 以帮助改善 SQL Server 的信息。默认情况下，用于错误报告和功能使用情况的选项处于启用状态。有关详细信息，请参阅错误和使用情况报告设置。

  18. 在升级操作开始之前，系统配置检查器将运行一组以上的规则来针对您指定的 SQL Server 功能验证您的计算机配置。

  19. “准备升级”页显示您在安装过程中指定的安装选项的树视图。若要继续，请单击“安装”。

  20. 在安装过程中，进度页会提供相应的状态，因此您可以在安装过程中监视安装进度。

  21. 安装完成后，“完成”页会提供指向安装日志文件摘要以及其他重要说明的链接。若要完成 SQL Server 安装过程，请单击“关闭”。

  22. 如果安装程序指示您重新启动计算机，请立即重新启动。安装完成后，请务必阅读来自安装向导的消息。有关安装日志文件的信息，请参阅如何查看 SQL Server 安装日志文件。

后续步骤

升级到 SQL Server 2008 后，请完成以下任务：

  • 注册服务器 - 升级会删除早期的 SQL Server 实例的注册表设置。升级之后，必须重新注册服务器。

  • 更新统计信息 - 为了帮助优化查询性能，建议您在升级之后更新所有数据库的统计信息。使用 sp_updatestats 存储过程更新 SQL Server 数据库中用户定义表中的统计信息。

  • 更新使用情况计数器 - 在 SQL Server 的早期版本中，表和索引的行计数与页计数的值可能会变得不正确。若要更正任何无效的行或页计数，建议您在升级完成后对所有数据库运行 DBCC UPDATEUSAGE。

  • 配置新安装的 SQL Server - 为了减少系统的可攻击外围应用，SQL Server 将有选择地安装和激活一些密钥服务和功能。有关外围应用配置器工具的详细信息，请参阅此版本的自述文件。

请参阅

概念

向后兼容性

其他资源

Upgrading to SQL Server 2005


如何升级到 SQL Server 2008 的另一版本（安装程序）

如何升级到 SQL Server 2008 的另一版本（安装程序） |
 | 请参阅
升级到 SQL Server 2008 > 升级操作指南主题 >

SQL Server 安装向导提供了一个用来升级 SQL Server 组件的功能树。您也可以将 SQL Server 2008 与早期版本并行安装，或从早期版本的 SQL Server 迁移现有数据库和配置设置，然后将它们应用于 SQL Server 2008 实例。

有关详细信息，请参阅以下主题：

  • 版本升级

  • 使用 SQL Server 的多个版本和实例

  • 如何升级 SQL Server 故障转移群集实例（安装程序）

  • 如何从命令提示符安装 SQL Server 2008

  • 如何使用复制数据库向导升级 SQL Server

必备项

对于本地安装，必须以管理员身份运行安装程序。如果从远程共享安装 SQL Server，则必须使用对远程共享具有读取和执行权限的域帐户。

升级数据库引擎之前，请查阅以下主题：

  • 升级到 SQL Server 2008

  • 安装 SQL Server 2008 的硬件和软件要求

  • 系统配置检查器的检查参数

  • 安装 SQL Server 的安全注意事项

  • SQL Server 数据库引擎的向后兼容性

重要提示：
为了激活对 SQL Server 版本进行的更改，必须重新启动 SQL Server 服务。这将导致应用程序在服务脱机时关闭。

过程

升级到 SQL Server 2008

  1. 插入 SQL Server 安装媒体。然后双击根文件夹中的 setup.exe。若要从网络共享进行安装，请找到共享中的根文件夹，然后双击 setup.exe。

  2. 如果出现 Microsoft .NET Framework 2.0 版 安装对话框，则选中相应的复选框以接受 .NET Framework 2.0 许可协议。单击“下一步”。若要退出 SQL Server 2008 安装，请单击“取消”。当 .NET Framework 2.0 的安装完成后，单击“完成”。

  3. Windows Installer 4.5 也是必需的，并且可能由安装向导进行安装。如果系统提示您重新启动计算机，则重新启动计算机，然后再次运行 SQL Server 2008 setup.exe。

  4. 必备组件安装完成后，安装向导会启动 SQL Server 安装中心。若要将 SQL Server 2008 的现有实例升级到另一个版本，请单击“高级”，然后选择“版本升级”。

  5. 如果需要使用安装程序支持文件，SQL Server 安装程序将安装它们。如果安装程序指示您重新启动计算机，请在继续操作之前重新启动。

  6. 系统配置检查器将在您的计算机上运行发现操作。若要继续，请单击“确定”。系统已经为您的安装创建了安装日志文件。有关日志文件的详细信息，请参阅如何查看 SQL Server 安装日志文件。

  7. 在“产品密钥”页上，选择相应的单选按钮，这些按钮指示您是升级到免费版本的 SQL Server，还是您拥有该产品生产版本的 PID 密钥。有关详细信息，请参阅 SQL Server 2008 的版本和组件和版本升级。

  8. 在“许可条款”页上阅读许可协议，然后选中相应的复选框以接受许可条款和条件。若要继续，请单击“下一步”。若要结束安装程序，请单击“取消”。

  9. 在“选择实例”页上指定要升级的 SQL Server 实例。

  10. 在版本升级操作开始之前，系统配置检查器将运行一组以上的规则来验证您的计算机配置。

  11. “准备升级”页显示您在安装过程中指定的安装选项的树视图。若要继续，请单击“安装”。

  12. 在安装过程中，进度页会提供相应的状态，因此您可以在安装过程中监视安装进度。

  13. 安装完成后，“完成”页会提供指向安装日志文件摘要以及其他重要说明的链接。若要完成 SQL Server 安装过程，请单击“关闭”。

  14. 如果安装程序指示您重新启动计算机，请立即重新启动。安装完成后，请务必阅读来自安装向导的消息。有关安装日志文件的信息，请参阅如何查看 SQL Server 安装日志文件。

  15. 如果是从 SQL Server Express 进行的升级，则必须执行以下附加步骤才能使用 SQL Server 的升级实例：

    • 在 Windows SCM 中启用 SQL Server Agent 服务。

    • 使用 SQL Server 配置管理器设置 SQL Server Agent 服务帐户。

    • 升级之后，设置为 Sysadmins 的用户将保持其原有的设置。具体而言，BUILTIN\Users 将保持其原有的设置。可以根据需要禁用、删除或重新设置这些帐户。

    • 升级之后，TempDB 和 ModelDB 的大小和恢复模式将保持不变。可以根据需要重新配置这些设置。

    • 升级之后，模板数据库将保留在计算机上。可以根据需要删除或重新配置这些数据库。

请参阅

概念

升级到 SQL Server 2008
向后兼容性


向后兼容性

向后兼容性 |
 | 请参阅
升级到 SQL Server 2008 >

下列各节包含 SQL Server 组件的向后兼容信息。本内容包括有关不推荐使用的功能、废止的功能、重大更改和行为更改的信息。

本节内容

主题 | 说明
SQL Server 的向后兼容性 | 包含介绍 SQL Server 中的更改的一些主题，这些更改可能会要求您更改应用程序。本主题范围中包含的功能包括数据可编程性、外围应用配置器工具、安装程序、SQL Server 服务，以及其他多种功能更改。
SQL Server 数据库引擎的向后兼容性 | 包含介绍 SQL Server 中的数据库引擎更改的一些主题，这些更改可能会要求您更改应用程序。
SQL Server Analysis Services 的向后兼容性 | 包含介绍 SQL Server 中的 Analysis Services 更改的一些主题，这些更改可能会要求您更改应用程序。
Integration Services 的向后兼容性 | 介绍 SQL Server 中的 Integration Services 更改，这些更改可能会要求您更改现有 Data Transformation Services 应用程序。
Reporting Services 的向后兼容性 | 包含介绍 SQL Server 中的 SSRS 更改的一些主题，这些更改可能会要求您更改现有 Reporting Services 解决方案。
复制的向后兼容性 | 包含介绍 SQL Server 中的数据库引擎更改的一些主题，这些更改可能会要求您更改现有复制解决方案。

请参阅

概念

安装 SQL Server 2008
升级到 SQL Server 2008
迁移到 SQL Server 2008


SQL Server 的向后兼容性

SQL Server 的向后兼容性
升级到 SQL Server 2008 > 向后兼容性 >

向后兼容性部分中的主题介绍了 SQL Server 各版本之间的 SQL Server 行为更改。

本主题范围中包含的功能包括数据可编程性、外围应用配置器工具、SQL Server 安装程序、SQL Server 服务，以及其他多种功能更改。

主题 | 说明
SQL Server 2008 中数据库引擎功能的行为更改 | 此版本中不推荐使用的 SQL Server 功能。本主题的内容涉及数据可编程性功能、外围应用配置器工具及安装功能。
SQL Server 2008 中数据库引擎功能的行为更改 | 此版本中停止使用的 SQL Server 功能。本主题的内容涉及数据可编程性功能、外围应用配置器工具及安装功能。
SQL Server 2008 中数据库引擎功能的行为更改 | 可能需要更改应用程序的更改。本主题的内容涉及数据可编程性功能、外围应用配置器工具及安装功能。
SQL Server 2008 中数据库引擎功能的行为更改 | 此版本中对数据库功能的其他更改。本主题的内容涉及数据可编程性功能、外围应用配置器工具及安装功能。


SQL Server 2008 中不推荐使用的 SQL Server 功能

SQL Server 2008 中不推荐使用的 SQL Server 功能
升级到 SQL Server 2008 > 向后兼容性 > SQL Server 的向后兼容性 >

本主题介绍 SQL Server 2008 中仍然可用但不推荐使用的功能。按照计划，SQL Server 未来版本将不再具有这些功能。在新的应用程序中不应使用这些将不再支持的功能。

SQL Server 的下一版本中不支持的功能

SQL Server 的下一个版本将不再支持以下 SQL Server 数据库引擎 功能。请不要在新的开发工作中使用这些功能，并尽快修改当前还在使用这些功能的应用程序。功能名称列在跟踪事件中显示为 ObjectName，而在性能计数器和 sys.dm_os_performance_counters 中显示为 instance_name。功能 ID 在跟踪事件中显示为 ObjectId。

类别 | 不推荐使用的功能 | 替代功能 | 功能名称 | 功能 ID
SQL Server 服务 | ADHelper 服务 | 无 | ADHelper |
数据可编程性 | 使用 CREATE ENDPOINT (Transact-SQL) 和 ALTER ENDPOINT (Transact-SQL) 的 SOAP/HTTP 端点 | Windows Communications Foundation (WCF) 或 ASP.NET | 本机 XML Web 服务 | 21
数据可编程性 | sys.soap_endpoints (Transact-SQL) | Windows Communications Foundation (WCF) 或 ASP.NET | 本机 XML Web 服务 | 22
数据可编程性 | sys.endpoint_webmethods (Transact-SQL) | Windows Communications Foundation (WCF) 或 ASP.NET | 本机 XML Web 服务 | 23


SQL Server 2008 中不再推荐使用的 SQL Server 功能

SQL Server 2008 中不再推荐使用的 SQL Server 功能
升级到 SQL Server 2008 > 向后兼容性 > SQL Server 的向后兼容性 >

本主题介绍 SQL Server 2008 中不再可用的功能。

外围应用配置器工具

SQL Server 的外围应用配置器工具 (SAC) 已从 SQL Server 2008 中删除。此版本中的替代功能如下所示：

类别 已不再推荐使用的功能 替代功能

工具

外围应用配置器工具

在 SQL Server 2008 中已不再推荐使用外围应用配置器工具。下表显示 2008 年 2 月发布的 CTP 版本中可用于配置设置、选项和组件功能的工具。

设置和组件功能 | 配置方式
协议、连接和启动选项 | 使用 SQL Server 配置管理器。
数据库引擎功能 | 使用基于策略的管理、SQL Server Management Studio 中的属性设置或 sp_Configure。
Analysis Services 功能 | 使用 SQL Server Management Studio 中的属性设置。
Reporting Services - EnableIntegrated Security 属性 | 使用 SQL Server Management Studio 中的属性设置。
Reporting Services -“预定事件和报表传递”以及“Web 服务和 HTTP 访问” | 编辑 RSReportServer.config 配置文件。
命令行选项 | 在此版本中不支持。
SOAP 和 Service Broker 端点 | 使用 CREATE ENDPOINT 和 ALTER ENDPOINT。

已不再推荐使用的 SQL Server 安装程序命令提示符参数

下表显示的是 SQL Server 2008 中不再支持的早期版本 SQL Server 中的安装程序命令提示符参数。

不再推荐使用的参数 | 替换参数
ADDLOCAL | /ACTION=Uninstall 和 /FEATURES
DISABLENETWORKPROTOCOLS | TCP/IP 的 /TCPENABLED1
DISABLENETWORKPROTOCOLS | Named Pipes 的 /NPENABLED1
INSTALLSQLDATADIR | /SQLUSERDBDIR /SQLUSERDBLOGDIR /SQLBACKUPDIR /SQLTEMPDBDIR /SQLTEMPDBLOGDIR
REINSTALL | 在此版本中无等效参数。
REINSTALLMODE | 在此版本中无等效参数。
REMOVE | /ACTION=Uninstall 和 /FEATURES
SAMPLEDATABASE | 在此版本中无等效参数。
SAVESYSDB | 在此版本中无等效参数。
SKUUPGRADE | 在此版本中无等效参数。
UPGRADE | /ACTION=Upgrade 和 /FEATURES
USESYSDB | 在此版本中无等效参数。

1这些参数仅对安装有效。

有关详细信息，请参阅如何从命令提示符安装 SQL Server 2008。


SQL Server 2008 中 SQL Server 功能的重大更改

SQL Server 2008 中 SQL Server 功能的重大更改
升级到 SQL Server 2008 > 向后兼容性 > SQL Server 的向后兼容性 >

本主题介绍 SQL Server 中的重大更改。这些更改可能导致基于 SQL Server 的早期版本的应用程序、脚本或功能无法继续使用。在进行升级时可能会遇到这些问题。有关详细信息，请参阅使用升级顾问来准备升级。

子标题

此处插入章节正文。


SQL Server 2008 中 SQL Server 功能的行为更改

SQL Server 2008 中 SQL Server 功能的行为更改
升级到 SQL Server 2008 > 向后兼容性 > SQL Server 的向后兼容性 >

本主题介绍 SQL Server 2008 中的行为更改。与早期版本的 SQL Server 相比，SQL Server 2008 中的功能的工作或交互方式会受到行为更改的影响。

备注

在此处插入注释。

功能 | 有关详细信息，请参阅：
SQL Server Native Client | Updating an Application to SQL Server 2008 Native Client from SQL Server 2005 Native Client


对 SQL Server 早期版本的支持

对 SQL Server 早期版本的支持
升级到 SQL Server 2008 > 向后兼容性 > SQL Server 的向后兼容性 >

本节中的主题介绍了 SQL Server 对下列早期组件和功能的支持：

请参阅... | 有关详细信息...
分布式管理对象 | 对分布式管理对象的支持。


分布式管理对象

分布式管理对象 |
 | 请参阅
向后兼容性 > SQL Server 的向后兼容性 > 对 SQL Server 早期版本的支持 >

SQL Server 将分布式管理对象功能作为早期组件安装。若要安装“早期组件”功能，请在 SQL Server 安装过程中，在“要安装的组件”页上单击“高级”。展开“客户端组件”功能，然后选择“早期组件”。

请参阅

参考

SQL Server 2008 的版本和组件


Data Transformation Services (DTS)

Data Transformation Services (DTS)
向后兼容性 > SQL Server 的向后兼容性 > 对 SQL Server 早期版本的支持 >

Data Transformation Services (DTS) 已被 SQL Server Integration Services 取代。

SQL Server 2008 不安装 DTS 支持。有关详细信息，请参阅 支持 SQL Server 2008 中的 Data Transformation Services (DTS)。

不推荐使用 Data Transformation Services

不推荐使用 Data Transformation Services (DTS)。考虑到 SQL Server 未来版本的功能，您应制定删除对 DTS 的依赖关系的计划。SQL Server 2000、SQL Server 2005 和 SQL Server 2008 将继续支持 DTS 本身，这出于我们为这些 SQL Server 版本提供支持的一贯承诺。但是，在下一版本中可能会取消对迁移或运行 DTS 包功能的支持。

不推荐使用的 DTS 功能包括 DTS 运行时、DTS API、用于将 DTS 迁移到下一版 Integration Services 的包迁移向导、SQL Server Management Studio 对 DTS 包维护的支持和“执行 DTS 2000 包”任务。

有关如何将 DTS 包迁移为 Integration Services 包格式的信息，请参阅迁移 Data Transformation Services 包。


SQL Server 数据库引擎的向后兼容性

SQL Server 数据库引擎的向后兼容性
升级到 SQL Server 2008 > 向后兼容性 >

向后兼容性部分中的主题说明了 SQL Server 各版本之间的行为更改。

主题 | 说明
SQL Server 2008 中不推荐使用的数据库引擎功能 | 此版本不推荐使用的数据库引擎功能。
SQL Server 2008 中废止的数据库引擎功能 | 此版本废止的数据库引擎功能。
SQL Server 2008 中数据库引擎功能的重大更改 | 可能需要更改应用程序的数据库引擎功能更改。
SQL Server 2008 中数据库引擎功能的行为更改 | 此版本中对数据库功能的其他更改。


SQL Server 2008 中不推荐使用的数据库引擎功能

SQL Server 2008 中不推荐使用的数据库引擎功能 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > SQL Server 数据库引擎的向后兼容性 >

本主题介绍 SQL Server 2008 中仍然可用但不推荐使用的 SQL Server 数据库引擎 功能。按照计划，SQL Server 未来版本将不再具有这些功能。在新的应用程序中不应使用这些不推荐使用的功能。

可以使用 SQL Server Deprecated Features Object 性能计数器监视不推荐使用的功能的使用情况并跟踪事件。有关详细信息，请参阅使用 SQL Server 对象。

SQL Server 的下一版本中不支持的功能

SQL Server 的下一个版本将不再支持以下 SQL Server 数据库引擎 功能。请不要在新的开发工作中使用这些功能，并尽快修改当前还在使用这些功能的应用程序。功能名称值在跟踪事件中作为 ObjectName，而在性能计数器和 sys.dm_os_performance_counter 中作为实例名称。功能 ID 值在跟踪事件中作为 ObjectId。

类别 | 不推荐使用的功能 | 替代功能 | 功能名称 | 功能 ID
备份和还原 | BACKUP { DATABASE | LOG } WITH PASSWORD | 无 | BACKUP DATABASE 或 LOG WITH PASSWORD | 104
备份和还原 | BACKUP { DATABASE | LOG } WITH MEDIAPASSWORD | 无 | BACKUP DATABASE 或 LOG WITH MEDIAPASSWORD | 103
备份和还原 | RESTORE { DATABASE | LOG } … WITH DBO_ONLY | RESTORE { DATABASE | LOG } … … WITH RESTRICTED_USER | RESTORE DATABASE 或 LOG WITH DBO_ONLY | 101
备份和还原 | RESTORE { DATABASE | LOG } WITH PASSWORD | 无 | RESTORE DATABASE 或 LOG WITH PASSWORD | 106
备份和还原 | RESTORE { DATABASE | LOG } WITH MEDIAPASSWORD | 无 | RESTORE DATABASE 或 LOG WITH MEDIAPASSWORD | 105
兼容级别 | 兼容级别为 80，从版本 80 进行升级。 | 只有最后两个版本的兼容级别可用。有关兼容级别的详细信息，请参阅 ALTER DATABASE 兼容级别 (Transact-SQL)。 | 数据库兼容级别 80 | 107
元数据 | DATABASEPROPERTY | DATABASEPROPERTYEX | DATABASEPROPERTY | 38
数据库对象 | 有关触发器的 WITH APPEND 子句 | 重新创建整个触发器。 | CREATE TRIGGER WITH APPEND | 171
实例选项 | disallow results from triggers 选项的默认设置 = 0 | disallow results from triggers 选项的默认设置 = 1 | sp_configure 'disallow results from triggers' | 172
数据库选项 | sp_dboption | ALTER DATABASE | sp_dboption | 77
查询提示 | FASTFIRSTROW 提示 | OPTION (FAST n)。 | FASTFIRSTROW | 177
远程服务器 | sp_addremotelogin sp_addserver sp_dropremotelogin sp_helpremotelogin sp_remoteoption | 用链接服务器替代远程服务器。 | sp_addremotelogin sp_addserver sp_dropremotelogin sp_helpremotelogin sp_remoteoption | 70 69 71 72 73
远程服务器 | @@remserver | 用链接服务器替代远程服务器。 | 无 | 无
远程服务器 | SET REMOTE_PROC_TRANSACTIONS | 用链接服务器替代远程服务器。 | SET REMOTE_PROC_TRANSACTIONS | 110
安全性 | sp_dropalias | 请将别名替换为用户帐户和数据库角色的组合。请使用 sp_dropalias 删除已升级数据库中的别名。 | sp_dropalias | 68
SET 选项 | SET DISABLE_DEF_CNST_CHK | 无。该选项不起任何作用。 | SET DISABLE_DEF_CNST_CHK | 188
SET 选项 | INSERT、UPDATE 和 DELETE 语句的 SET ROWCOUNT | TOP 关键字 | SET ROWCOUNT | 109
Transact-SQL 语法 | *= 和 =* 的用法 | 使用 ANSI 联接语法。有关详细信息，请参阅 FROM (Transact-SQL)。 | 非 ANSI *= 或 =* 外部联接运算符 | 178
Transact-SQL 语法 | COMPUTE / COMPUTE BY | 使用 ROLLUP | COMPUTE [BY] | 180
系统表 | sys.database_principal_aliases | 请使用角色而不是别名。 | database_principal_aliases | 150
Transact-SQL | 不推荐使用 RAISERROR（格式：RAISERROR 整型字符串）语法。 | 请使用当前的 RAISERROR 语法重写语句。 | 旧式 RAISEERROR | 164
其他 | DB-Library 用于 C 语言的嵌入式 SQL | 尽管数据库引擎仍然支持来自使用 DB-Library 和嵌入式 SQL API 的现有应用程序的连接，但它不包括在使用这些 API 的应用程序上进行编程工作所需的文件或文档。SQL Server 数据库引擎 的未来版本将不再支持来自 DB-Library 或嵌入式 SQL 应用程序的连接。请不要使用 DB-Library 或嵌入式 SQL 来开发新的应用程序。修改现有应用程序时，请删除 DB-Library 或嵌入式 SQL 的任何依赖项。请使用 SQLClient 命名空间或诸如 OLE DB 或 ODBC 的 API 来代替这些 API。SQL Server 2008 不包含运行这些应用程序所需的 DB-Library DLL。若要运行 DB-Library 或嵌入式 SQL 应用程序，必须有 SQL Server 6.5 版、SQL Server 7.0 版或 SQL Server 2000 提供的 DB-Library DLL。 | 无 | 无

SQL Server 未来版本中不支持的功能

SQL Server 的下一版本仍支持以下 SQL Server 数据库引擎功能，但以后的版本将删除这些功能。具体是哪一 SQL Server 版本现在还未确定。

类别 不推荐使用的功能 替代功能 功能名称 功能 ID

兼容级别

sp_dbcmptlevel

ALTER DATABASE … SET COMPATIBILITY_LEVEL。有关详细信息，请参阅 ALTER DATABASE 兼容级别 (Transact-SQL)。

sp_dbcmptlevel

80

兼容级别

数据库兼容级别 90

计划为未来版本升级数据库和应用程序。

数据库兼容级别 90

108

XML

内联 XDR 架构生成

不推荐使用 FOR XML 选项的 XMLDATA 指令。如果是 RAW 和 AUTO 模式，请使用 XSD 生成。在 EXPLICT 模式下，没有可以代替 XMLDATA 指令的项。

XMLDATA

181

备份和还原

BACKUP { DATABASE | LOG } TO TAPE

BACKUP { DATABASE | LOG } TO device_that_is_a_tape

BACKUP { DATABASE | LOG } TO DISK

BACKUP { DATABASE | LOG } TO device_that_is_a_disk

BACKUP DATABASE 或 LOG TO TAPE

235

备份和还原

sp_addumpdevice 'tape'

sp_addumpdevice 'disk'

ADDING TAPE DEVICE

236

备份和还原

sp_helpdevice

sys.backup_devices

sp_helpdevice

100

排序规则

Korean_Wansung_Unicode

Lithuanian_Classic

SQL_AltDiction_CP1253_CS_AS

无。SQL Server 2005 中存在这些排序规则，但 fn_helpcollations 并不将它们显示出来。

Korean_Wansung_Unicode

Lithuanian_Classic

SQL_AltDiction_CP1253_CS_AS

191

192

194

排序规则

印地语

马其顿语

SQL Server 2005 及更高版本中存在这些排序规则，但 fn_helpcollations 并不将它们显示出来。请改用 Macedonian_FYROM_90 和 Indic_General_90。

印地语

马其顿语

190

193

排序规则

Azeri_Latin_90

Azeri_Cyrilllic_90

Azeri_Latin_100

Azeri_Cyrilllic_100

Azeri_Latin_90

Azeri_Cyrilllic_90

232

233

配置

SET ANSI_NULLS OFF 和 ANSI_NULLS OFF 数据库选项

SET ANSI_PADDING OFF 和 ANSI_PADDING OFF 数据库选项

SET CONCAT_NULL_YIELDS_NULL OFF 和 CONCAT_NULL_YIELDS_NULL OFF 数据库选项

SET OFFSETS

无。

ANSI_NULLS、ANSI_PADDING 和 CONCAT_NULLS_YIELDS_NULL 这三个选项在任何情况下始终设置为 ON。SET OFFSETS 将不可用。

SET ANSI_NULLS OFF

SET ANSI_PADDING OFF

SET CONCAT_NULL_YIELDS_NULL OFF

SET OFFSETS

ALTER DATABASE SET ANSI_NULLS OFF

ALTER DATABASE SET ANSI_PADDING OFF

ALTER DATABASE SET CONCAT_NULL_YIELDS_NULL OFF

SET 选项

连接

SQLOLEDB 不是受支持的访问接口。

请将 SQL Server Native Client 用于即席连接。

OLEDB 用于即席连接

32

数据类型

sp_addtype

sp_droptype

CREATE TYPE

DROP TYPE

sp_addtype

sp_droptype

62

63

数据类型

rowversion 数据类型的 timestamp 语法

rowversion 数据类型语法

TIMESTAMP

158

数据类型

在 timestamp 列中插入 null 值的功能。

请改用 DEFAULT。

将 NULL 插入 TIMESTAMP 列

179

数据类型

“text in row”表选项

请使用 varchar(max)、nvarchar(max) 和 varbinary(max) 数据类型。有关详细信息，请参阅 sp_tableoption (Transact-SQL)。

Text in row 表选项

9

数据类型

数据类型：

  • text

  • ntext

  • image

请使用 varchar(max)、nvarchar(max) 和 varbinary(max) 数据类型。

数据类型：text、ntext 或 image

4

数据库管理

sp_attach_db

sp_attach_single_file_db

使用 FOR ATTACH 选项的 CREATE DATABASE 语句。若要在一个或多个日志文件有新位置的情况下重新生成这些日志文件，请使用 FOR ATTACH_REBUILD_LOG 选项。

sp_attach_db

sp_attach_single_file_db

81

82

数据库对象

CREATE DEFAULT

DROP DEFAULT

sp_bindefault

sp_unbindefault

CREATE TABLE 和 ALTER TABLE 中的 DEFAULT 关键字

CREATE_DROP_DEFAULT

sp_bindefault

sp_unbindefault

162

64

65

数据库对象

CREATE RULE

DROP RULE

sp_bindrule

sp_unbindrule

CREATE TABLE 和 ALTER TABLE 中的 CHECK 关键字

CREATE_DROP_RULE

sp_bindrule

sp_unbindrule

161

66

67

数据库对象

sp_change_users_login

使用 ALTER USER。

sp_change_users_login

无

数据库对象

sp_depends

sys.dm_sql_referenced_entities 和 sys.dm_sql_referenced_entities

sp_depends

195

数据库对象

sp_renamedb

ALTER DATABASE 中的 MODIFY NAME

sp_renamedb

79

数据库对象

sp_getbindtoken

使用 MARS 或分布式事务。

sp_getbindtoken

98

数据库选项

sp_bindsession

使用 MARS 或分布式事务。

sp_bindsession

97

数据库选项

sp_resetstatus

ALTER DATABASE SET { ONLINE | EMERGENCY }

sp_resetstatus

83

数据库选项

ALTER DATABASE 的 TORN_PAGE_DETECTION 选项

ALTER DATABASE 的 PAGE_VERIFY TORN_PAGE_DETECTION 选项

ALTER DATABASE WITH TORN_PAGE_DETECTION

102

DBCC

DBCC DBREINDEX

ALTER INDEX 的 REBUILD 选项。

DBCC DBREINDEX

11

DBCC

DBCC INDEXDEFRAG

ALTER INDEX 的 REORGANIZE 选项

DBCC INDEXDEFRAG

18

DBCC

DBCC SHOWCONTIG

sys.dm_db_index_physical_stats

DBCC SHOWCONTIG

10

DBCC

DBCC PINTABLE

DBCC UNPINTABLE

无效。

DBCC [UN]PINTABLE

189

扩展属性

用 Level0type = 'type' 和 Level0type = 'USER' 向 1 级或 2 级类型对象添加扩展属性。

用 Level0type = 'USER' 只可直接向用户或角色添加扩展属性。

用 Level0type = 'SCHEMA' 向 1 级类型（如 TABLE 或 VIEW）或 2 级类型（如 COLUMN 或 TRIGGER）添加扩展属性。有关详细信息，请参阅 sp_addextendedproperty (Transact-SQL)。

EXTPROP_LEVEL0TYPE

EXTPROP_LEVEL0USER

13

14

扩展存储过程编程

srv_alloc

srv_convert

srv_describe

srv_getbindtoken

srv_got_attention

srv_message_handler

srv_paramdata

srv_paraminfo

srv_paramlen

srv_parammaxlen

srv_paramname

srv_paramnumber

srv_paramset

srv_paramsetoutput

srv_paramstatus

srv_paramtype

srv_pfield

srv_pfieldex

srv_rpcdb

srv_rpcname

srv_rpcnumber

srv_rpcoptions

srv_rpcowner

srv_rpcparams

srv_senddone

srv_sendmsg

srv_sendrow

srv_setcoldata

srv_setcollen

srv_setutype

srv_willconvert

srv_wsendmsg

请改用 CLR 集成。

XP_API

20

扩展存储过程编程

sp_addextendedproc

sp_dropextendedproc

sp_helpextendedproc

请改用 CLR 集成。

sp_addextendedproc

sp_dropextendedproc

sp_helpextendedproc

94

95

96

扩展存储过程

xp_grantlogin

xp_revokelogin

xp_loginConfig

Use CREATE LOGIN

使用 SERVERPROPERTY 的 DROP LOGIN IsIntegratedSecurityOnly 参数

xp_grantlogin

xp_revokelogin

xp_loginconfig

44

45

59

函数

fn_get_sql

sys.dm_exec_sql_text

fn_get_sql

151

索引选项

sp_indexoption

ALTER INDEX

sp_indexoption

78

索引选项

选项两侧没有括号的 CREATE TABLE、ALTER TABLE 或 CREATE INDEX 语法。

请重写语句以使用当前语法。

INDEX_OPTION

33

数据库对象

从触发器返回结果集的功能

无

从触发器返回结果

12

实例选项

sp_configure option 'allow updates'

系统表不再可更新。其设置不起作用。

sp_configure 'allow updates'

173

实例选项

sp_configure 选项：

  • 'locks'

  • 'open objects'

  • 'set working set size'

这些选项目前为自动配置。其设置不起作用。

sp_configure 'locks'

sp_configure 'open objects'

sp_configure 'set working set size'

174

175

176

实例选项

sp_configure options 'user instances enabled'

不再需要此功能，因为 SQL Server Compact 3.5 提供了必要的功能。其设置不起作用。

无

无

实例选项

sp_configure option 'priority boost'

系统表不再可更新。其设置不起作用。

sp_configure 'priority boost'

199

实例选项
  • sp_configure option 'remote proc trans'

系统表不再可更新。其设置不起作用。

sp_configure 'remote proc trans'

37

链接服务器

链接服务器使用 OLEDB。

对链接服务器使用 OLEDB

19

锁定

sp_lock

查询 sys.dm_tran_locks

sp_lock

99

邮件

SQL 邮件

数据库邮件

SQLMail

邮件

元数据

FILE_ID

INDEXKEY_PROPERTY

FILE_IDEX

sys.index_columns

FILE_ID

INDEXKEY_PROPERTY

15

17

本机 XML Web 服务

带有 FOR SOAP 选项的 CREATE ENDPOINT 或 ALTER ENDPOINT 语句。

EXT_endpoint_webmethods

EXT_soap_endpoints

请改用 Windows Communications Foundation (WCF) 或 ASP.NET。

EXT_CREATE_ALTER_SOAP_ENDPOINT

EXT_endpoint_webmethods

EXT_soap_endpoints

21

22

23

可编程性

SQL Server 数据库管理对象 (SQL-DMO)

SQL Server Management Objects (SMO)

SQL Server 数据库管理对象 (SQL-DMO) 已从 SQL Server 2008 Express 中删除并且还将从其他版本中删除。

建议您尽快修改当前使用此功能的应用程序。如果必须支持用于 SQL Server Express 的 SQL-DMO，请从 Microsoft 下载中心下载 SQL Server 2005 功能包，然后安装其中的向后兼容组件。切勿在新的开发工作中使用 SQL-DMO，请改用 SQL Server 管理对象 (SMO)。《SQL Server 2005 联机丛书》中有相关的 SMO 文档，您可以安装该丛书来获取这些文档。

无

可删除数据库
  • sp_certify_removable

  • sp_create_removable

sp_detach_db

sp_certify_removable

sp_create_removable

74

75

可删除数据库

sp_dbremove

DROP DATABASE

sp_dbremove

76

安全性

ALTER LOGIN WITH SET CREDENTIAL 语法

由新的 ALTER LOGIN ADD 和 DROP CREDENTIAL 语法取代

ALTER LOGIN WITH SET CREDENTIAL

230

安全性

sp_addapprole

sp_dropapprole

CREATE APPLICATION ROLE

DROP APPLICATION ROLE

sp_addapprole

sp_dropapprole

53

54

安全性

sp_addlogin

sp_droplogin

CREATE LOGIN

DROP LOGIN

sp_addlogin

sp_droplogin

39

40

安全性

sp_adduser

sp_dropuser

CREATE USER

DROP USER

sp_adduser

sp_dropuser

49

50

安全性

sp_grantdbaccess

sp_revokedbaccess

CREATE USER

DROP USER

sp_grantdbaccess

sp_revokedbaccess

51

52

安全性

sp_addrole

sp_droprole

CREATE ROLE

DROP ROLE

sp_addrole

sp_droprole

56

57

安全性

sp_approlepassword

sp_password

ALTER APPLICATION ROLE

ALTER LOGIN

sp_approlepassword

sp_password

55

46

安全性

sp_changeobjectowner

ALTER SCHEMA 或 ALTER AUTHORIZATION

sp_changeobjectowner

58

安全性

sp_defaultdb

sp_defaultlanguage

ALTER LOGIN

sp_defaultdb

sp_defaultlanguage

47

48

安全性

sp_denylogin

sp_grantlogin

sp_revokelogin

ALTER LOGIN DISABLE

CREATE LOGIN

DROP LOGIN

sp_denylogin

sp_grantlogin

sp_revokelogin

42

41

43

安全性

USER_ID

DATABASE_PRINCIPAL_ID

USER_ID

16

安全性

sp_srvrolepermission

sp_dbfixedrolepermission

这些存储过程返回在 SQL Server 2000 中是正确的信息。该输出不反映在 SQL Server 2008 中实现的权限层次结构的更改。有关详细信息，请参阅固定服务器角色的权限（数据库引擎）。

sp_srvrolepermission

sp_dbfixedrolepermission

61

60

安全性

GRANT ALL

DENY ALL

REVOKE ALL

GRANT、DENY 和 REVOKE 特定权限。

ALL 权限

35

安全性

PERMISSIONS 内部函数

请改为查询 sys.fn_my_permissions。

PERMISSIONS

170

安全性

SETUSER

EXECUTE AS

SETUSER

165

SMO 类

Microsoft.SQLServer.Management.Smo.Information 类

Microsoft.SQLServer.Management.Smo.Settings 类

Microsoft.SQLServer.Management.Smo.DatabaseOptions 类

Microsoft.SqlServer.Management.Smo.DatabaseDdlTrigger.NotForReplication 属性

Microsoft.SqlServer.Management.Smo.Server 类

Microsoft.SqlServer.Management.Smo.Server 类

Microsoft.SqlServer.Management.Smo.Database 类

无

无

无

SQL Server Agent

net send 通知

寻呼通知

ActiveX 子系统

电子邮件通知

电子邮件通知

命令或 PowerShell 脚本

无

无

SQL Server Management Studio

解决方案资源管理器集成到 SQL Server Management Studio

源代码管理集成到 SQL Server Management Studio

无

无

系统表

sysaltfiles

syscacheobjects

syscolumns

syscomments

sysconfigures

sysconstraints

syscurconfigs

sysdatabases

sysdepends

sysdevices

sysfilegroups

sysfiles

sysforeignkeys

sysfulltextcatalogs

sysindexes

sysindexkeys

syslockinfo

syslogins

sysmembers

sysmessages

sysobjects

sysoledbusers

sysopentapes

sysperfinfo

syspermissions

sysprocesses

sysprotects

sysreferences

sysremotelogins

sysservers

systypes

sysusers

兼容性视图。有关详细信息，请参阅兼容性视图 (Transact-SQL)。

重要提示：
兼容性视图不显示 SQL Server 2005 中新增功能的元数据。建议将应用程序升级为使用目录视图。有关详细信息，请参阅目录视图 (Transact-SQL)。

sysaltfiles

syscacheobjects

syscolumns

syscomments

sysconfigures

sysconstraints

syscurconfigs

sysdatabases

sysdepends

sysdevices

sysfilegroups

sysfiles

sysforeignkeys

sysfulltextcatalogs

sysindexes

sysindexkeys

syslockinfo

syslogins

sysmembers

sysmessages

sysobjects

sysoledbusers

sysopentapes

sysperfinfo

syspermissions

sysprocesses

sysprotects

sysreferences

sysremotelogins

sysservers

systypes

sysusers

141

152

无

133

126

146

131

147

142

123

144

128

127

130

122

132

134

无

143

140

119

137

125

139

145

157

121

153

120

129

138

136

135

124

系统表

sys.numbered_procedures

sys.numbered_procedure_parameters

无

numbered_procedures

numbered_procedure_parameters

148

149

系统函数

fn_virtualservernodes

fn_servershareddrives

SELECT FROM sys.dm_os_cluster_nodes

SELECT FROM sys.dm_io_cluster_shared_drives

fn_virtualservernodes

fn_servershareddrives

155

156

系统视图

sys.sql_dependencies

sys.sql_expression_dependencies

sys.sql_dependencies

196

表压缩

vardecimal 存储格式的使用。

不推荐使用 Vardecimal 存储格式。SQL Server 2008 提供的数据压缩功能可以压缩十进制值和其他数据类型的值。建议您使用数据压缩，而不使用 vardecimal 存储格式。

Vardecimal 存储格式

200

表压缩

sp_db_vardecimal_storage_format 过程的使用。

不推荐使用 Vardecimal 存储格式。SQL Server 2008 提供的数据压缩功能可以压缩十进制值和其他数据类型的值。建议您使用数据压缩，而不使用 vardecimal 存储格式。

sp_db_vardecimal_storage_format

201

表压缩

sp_estimated_rowsize_reduction_for_vardecimal 过程的使用。

请改用数据压缩和 sp_estimate_data_compression_savings 过程。

sp_estimated_rowsize_reduction_for_vardecimal

202

表提示

在 UPDATE 或 DELETE 语句的 FROM 子句中指定 NOLOCK 或 READUNCOMMITTED。

请从 FROM 子句中删除 NOLOCK 或 READUNCOMMITTED 表提示。

UPDATE 或 DELETE 中的 NOLOCK 或 READUNCOMMITTED

无

表提示

不借助 WITH 关键字指定表提示。

使用 WITH。

不带 WITH 的表提示

8

表提示

不带括号的 HOLDLOCK 表提示

167

表提示

INSERT_HINTS

34

Textpointer

WRITETEXT

UPDATETEXT

READTEXT

无

UPDATETEXT 或 WRITETEXT

READTEXT

115

114

Textpointer

TEXTPTR()

TEXTVALID()

无

TEXTPTR

TEXTVALID

5

6

Transact-SQL

:: 函数调用序列

已被 SELECT column_list FROM sys.<function_name>() 取代。

例如，将 SELECT * FROM ::fn_virtualfilestats(2,1) 替换为 SELECT * FROM sys.fn_virtualfilestats(2,1)。

“::”函数调用语法

166

Transact-SQL

SELECT 列表中由三部分和四部分组成的列引用

由两部分组成的名称是符合标准的行为。

两个以上的部分构成的列名称

3

Transact-SQL

用引号引起来的字符串用作 SELECT 列表中表达式的列别名：

'string_alias' = expression

expression [AS]column_alias

expression [AS] [column_alias]

expression [AS] "column_alias"

expression [AS] 'column_alias'

column_alias = expression

字符串文字作为列别名

184

Transact-SQL

编号过程

无。请勿使用。

ProcNums

160

Transact-SQL

在 DROP INDEX 中使用 table_name.index_name 语法

在 DROP INDEX 中使用 index_name ON table_name 语法。

DROP INDEX 具有两部分构成的名称

163

Transact-SQL

不使用分号结束 Transact-SQL 语句。

使用分号 ( ; ) 结束 Transact-SQL 语句。

无

无

Transact-SQL

GROUP BY ALL

将自定义逐案例解决方案与 UNION 或派生表配合使用。

GROUP BY ALL

169

Transact-SQL

ROWGUIDCOL 在 DML 语句中用作列名。

请使用 $rowguid。

ROWGUIDCOL

182

Transact-SQL

IDENTITYCOL 在 DML 语句中用作列名。

请使用 $identity。

IDENTITYCOL

183

Transact-SQL

将 #、## 用作临时表和临时存储过程名称。

请至少使用一个其他字符。

“#”和“##”作为临时表和存储过程的名称

无

Transact-SQL

将 @、@@ 或 @@ 用作 Transact-SQL 标识符。

请勿使用 @ 或 @@ 或以 @@ 开头的名称作为标识符。

“@”和以“@@”开头的名称作为 Transact-SQL 标识符

无。

Transact-SQL

将 DEFAULT 关键字用作默认值。

不要将单词 DEFAULT 用作默认值。

DEFAULT 关键字作为默认值

187

Transact-SQL

将空格用作表提示之间的分隔符。

使用逗号分隔各个表提示。

没有逗号的多个表提示

168

Transact-SQL

聚集索引视图的选择列表在 90 兼容模式下必须包含 COUNT_BIG (*)

请使用 COUNT_BIG (*)。

不包含 COUNT_BIG(*) 的索引视图选择列表

2

Transact-SQL

表提示通过视图间接应用于多语句表值函数 (TVF) 的调用。

无。

间接 TVF 提示

7

Transact-SQL

ALTER DATABASE 语法:

MODIFY FILEGROUP READONLY

MODIFY FILEGROUP READWRITE

MODIFY FILEGROUP READ_ONLY

MODIFY FILEGROUP READ_WRITE

MODIFY FILEGROUP READONLY

MODIFY FILEGROUP READWRITE

195

196

请参阅

参考

SQL Server 2008 中废止的数据库引擎功能


SQL Server 2008 中废止的数据库引擎功能

SQL Server 2008 中废止的数据库引擎功能 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > SQL Server 数据库引擎的向后兼容性 >

本主题介绍 SQL Server 2008 中不再可用的数据库引擎功能。

类别 | 废止的功能 | 替代功能
别名 | sp_addalias | 将别名替换为用户帐户和数据库角色的组合。有关详细信息，请参阅 CREATE USER (Transact-SQL) 和 CREATE ROLE (Transact-SQL)。使用 sp_dropalias 删除已升级数据库中的别名。
API | 已注册服务器的 API | 已经替换为新的支持新 SQL Server 2008 功能的已注册服务器 API。
备份和还原 | DUMP 语句 | BACKUP
备份和还原 | LOAD 语句 | RESTORE
备份和还原 | BACKUP LOG WITH NO_LOG | 无。如果数据库使用的是简单恢复模式，事务日志将被自动截断。如果必须从数据库删除日志备份链，请切换到简单恢复模式。
备份和还原 | BACKUP LOG WITH TRUNCATE_ONLY | 无。如果数据库使用的是简单恢复模式，事务日志将被自动截断。如果必须从数据库删除日志备份链，请切换到简单恢复模式。
备份和还原 | BACKUP TRANSACTION | BACKUP LOG
兼容级别 | 60、65 和 70 兼容级别 | 必须将数据库的兼容级别至少设置为 80。
DBCC | DBCC CONCURRENCYVIOLATION | 无
组 | sp_addgroup | 使用角色。
组 | sp_changegroup | 使用角色。
组 | sp_dropgroup | 使用角色。
组 | sp_helpgroup | 使用角色。
示例数据库 | Northwind 和 pubs | 使用 AdventureWorks。Northwind 和 pubs 可通过下载获取，也可以从以前安装的 SQL Server 中复制。 有关详细信息，请参阅 AdventureWorks 示例数据库。
工具 | 外围应用配置器工具 | 对于 SQL Server 2008，外围应用配置器工具已废止。有关详细信息，请参阅向后兼容性。
Web 助手 | sp_makewebtask sp_dropwebtask sp_runwebtask sp_enumcodepages | 建议您改用 SQL Server Reporting Services。

请参阅

参考

SQL Server 2008 中不推荐使用的数据库引擎功能


SQL Server 2008 中数据库引擎功能的重大更改

SQL Server 2008 中数据库引擎功能的重大更改 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > SQL Server 数据库引擎的向后兼容性 >

本主题介绍数据库引擎中的重大更改。这些更改可能会导致基于 SQL Server 早期版本的应用程序、脚本或功能无法继续使用。在进行升级时可能会遇到这些问题。有关详细信息，请参阅使用升级顾问来准备升级。

排序规则

功能 说明

新排序规则

SQL Server 2008 引入的新排序规则完全符合 Windows Server 2008 提供的排序规则。这 80 个新排序规则以 *_100 版本引用表示，它们的语言准确性得到了改善。如果为服务器或数据库选择新排序规则，请注意，具有旧客户端驱动程序的客户端可能无法识别新排序规则。未被识别的排序规则可能会导致应用程序返回错误并失败。请考虑以下解决方案：

  • 升级客户端操作系统，以更新基础系统排序规则。

  • 如果客户端上安装了数据库客户端软件，则可以考虑对数据库客户端软件应用服务更新。

  • 选择一个现有排序规则，该排序规则会映射到客户端上的一个代码页。

有关详细信息，请参阅设置和更改排序规则。

公共语言运行时 (CLR)

功能 说明

CLR 程序集

当数据库升级到 SQL Server 2008 后，将自动安装 Microsoft.SqlServer.Types 程序集以支持新数据类型。升级顾问规则将检测存在名称冲突的任何用户类型或程序集。升级顾问将建议您重命名所有冲突的程序集，并重命名所有冲突的类型或在代码中使用由两部分组成的名称来引用该预先存在的用户类型。

如果数据库升级检测到某个用户程序集具有冲突名称，它将自动重命名该程序集，并将数据库置于可疑模式下。

如果在升级过程中存在具有冲突名称的用户类型，则不会采取特殊步骤。升级后，旧的用户类型和新的系统类型将同时存在。用户类型将只能按照由两部分组成的名称使用。

CLR 程序集

SQL Server 2008 将安装 .NET Framework 3.5 SP1，以更新全局存取缓存 (GAC) 中的库。如果在 SQL Server 数据库中注册了不支持的库，则在升级到 SQL Server 2008 后，SQL Server 应用程序可能会停止工作。这是因为，在 GAC 中为库提供服务或升级库时并不会更新 SQL Server 中的程序集。如果某个程序集同时存在于 SQL Server 数据库和 GAC 中，则该程序集的两个副本必须完全一致。如果不一致，当 SQL Server CLR 集成功能使用该程序集时，将发生错误。有关详细信息，请参阅Supported .NET Framework Libraries。

升级数据库之后，请使用 ALTER ASSEMBLY 语句对该程序集在 SQL Server 数据库中的副本提供服务或进行升级。有关详细信息，请参阅知识库文章 949080。

若要检测是否在应用程序中使用了任何不支持的 .NET Framework 库，请在数据库中运行以下查询。

复制代码
SELECT name FROM sys.assemblies WHERE clr_name LIKE '%publickeytoken=b03f5f7f11d50a3a,%';

动态管理视图

视图 | 说明
sys.dm_os_sys_info | 删除了 cpu_ticks_in_ms 和 sqlserver_start_time_cpu_ticks 列。
sys.dm_exec_query_resource_semaphores sys.dm_exec_query_memory_grants | resource_semaphore_id 列不是 SQL Server 2008 中的唯一 ID。此更改会对故障排除查询执行造成影响。有关详细信息，请参阅 sys.dm_exec_query_resource_semaphores。

错误和事件

功能 | 说明
登录错误 | 在 SQL Server 2005 中，当使用 SQL 登录名连接到配置为仅使用 Windows 身份验证的服务器时，会返回错误 18452。在 SQL Server 2008 中，则会返回错误 18456。

Showplan

功能 | 说明
显示计划 XML 架构 | 向显示计划 XML 架构中添加了一个新的 SeekPredicateNew 元素，并且将封闭 xsd 序列 (SqlPredicatesType) 转换成了 <xsd:choice> 项。现在，显示计划 XML 架构中可能会显示一个或多个 SeekPredicateNew 元素，而不再显示一个或多个 SeekPredicate 元素。这两种元素是相互排斥的。在显示计划 XML 架构中维护 SeekPredicate 的目的在于实现向后兼容；但是，在 SQL Server 2008 中创建的查询计划中也可以包含 SeekPredicateNew 元素。如果不存在 SeekPredicate 元素，则预计从节点 ShowPlanXML/BatchSequence/Batch/Statements/StmtSimple/QueryPlan/RelOp/IndexScan/SeekPredicates 仅检索 SeekPredicate 子元素的应用程序可能会失败。可以重新编写该应用程序，使此节点中包含 SeekPredicate 或 SeekPredicateNew 元素。有关详细信息，请参阅关于已分区表和索引的查询处理增强功能。
显示计划 XML 架构 | 向显示计划 XML 架构的 ObjectType 复杂类型中添加了一个新的 IndexKind 属性。严格验证根据 SQL Server 2005 架构返回的 SQL Server 计划的应用程序将失败。

Transact-SQL

功能 说明

ALTER_AUTHORIZATION_DATABASE DDL 事件

在 SQL Server 2005 中，如果数据定义语言 (DDL) 操作中安全对象的实体类型为对象，则触发 DDL 事件 ALTER_AUTHORIZATION_DATABASE 后，会在 EVENTDATA xml 的 ObjectType 元素中返回值“object”。在 SQL Server 2008 中，则返回实际类型（例如，“table”或“function”）。

CONVERT

如果传递到 CONVERT 函数的样式无效，则会在二进制转换为字符或字符转换为二进制时，返回一个错误。在早期版本的 SQL Server 中，该无效样式会设置为二进制与字符间相互转换时的默认样式。

对程序集 GRANT/DENY/REVOKE EXECUTE

不能对程序集授予、拒绝或撤消“EXECUTE”权限。此权限不起任何作用，并且现在会导致一个错误。可以对引用程序集方法的存储过程或函数授予、拒绝或撤消“EXECUTE”权限。

对系统类型 GRANT/DENY/REVOKE 权限

不能对系统类型授予、拒绝或撤消权限。在早期版本的 SQL Server 中，这些语句会成功，但是不起任何作用。在 SQL Server 2008 中，则会返回错误。

OUTPUT 子句

为了防止出现不确定的行为，当某个列是通过下列方法之一定义时，OUTPUT 子句不能通过视图或内联表值函数引用该列：

  • 子查询。

  • 执行用户数据访问或系统数据访问（或者被认为执行此类访问）的用户定义函数。

  • 在定义中包含执行用户数据访问或系统数据访问的用户定义函数的计算列。

如果 SQL Server 在 OUTPUT 子句中检测到了此类列，将引发错误 4186。有关详细信息，请参阅 MSSQLSERVER_4186。

OUTPUT INTO 子句

OUTPUT INTO 子句的目标表不能有任何已启用的触发器。

READPAST 表提示

当 READ_COMMITTED_SNAPSHOT 数据库选项设置为 ON 并且满足以下条件之一时，无法指定 READPAST 表提示：

  • 会话的事务隔离级别为 READ COMMITTED。

  • 查询中也指定了 READCOMMITTED 表提示。

若要在上述情况下指定 READPAST 提示，请删除 READCOMMITTED 表提示（如果存在），然后在查询中包括 READCOMMITTEDLOCK 表提示。

sp_helpuser

在 sp_helpuser 存储过程的结果集中返回的以下列名发生了更改。

以前的列名 | 新列名
GroupName | RoleName
Group_name | Role_name
Group_id | Role_id
Users_in_group | Users_in_role

透明数据加密

在 I/O 级别执行透明数据加密 (TDE)：页结构在内存中不加密，而仅在将页写入到磁盘后才对页结构进行加密。数据库文件和日志文件均加密。当数据库使用 TDE 时，那些跳过常规 SQL Server 机制来访问页面（例如，通过直接扫描数据或日志文件）的第三方应用程序将失败，因为文件中的数据已被加密。此类应用程序可以利用 Windows 加密 API 来开发用来在 SQL Server 外部对数据进行解密的解决方案。

XQuery

功能 说明

Datetime 支持

在 SQL Server 2005 中，数据类型 xs:time、xs:date 和 xs:dateTime 不支持时区。时区数据会映射到 UTC 时区。SQL Server 2008 提供了符合标准的行为，从而导致了以下变化：

  • 将验证没有时区的值。

  • 将保留提供的时区或缺少的时区。

  • 修改了内部存储表示形式。

  • 增加了存储值的分辨率。

  • 不允许使用负年份。

可以修改应用程序和 XQuery 表达式来利用新类型值。有关详细信息，请参阅对 time、date、datetime2 和 datetimeoffset 数据类型使用 XML。

请参阅

参考

SQL Server 2008 中数据库引擎功能的行为更改
SQL Server 2008 中不推荐使用的数据库引擎功能
SQL Server 2008 中废止的数据库引擎功能

其他资源

SQL Server 数据库引擎的向后兼容性
ALTER DATABASE 兼容级别 (Transact-SQL)


SQL Server 2008 中数据库引擎功能的行为更改

SQL Server 2008 中数据库引擎功能的行为更改 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > SQL Server 数据库引擎的向后兼容性 >

本主题介绍数据库引擎中的行为更改。行为更改会影响 SQL Server 2008 中的功能与早期版本的 SQL Server 相比的工作或交互方式。

查询处理器体系结构

SQL Server 2008 更改对已分区表和索引的查询的处理方式。当已分区对象的查询将 USE PLAN 提示用于 SQL Server 2005 生成的计划时，它们包含的计划可能无效。有关详细信息，请参阅升级数据库引擎时的注意事项。有关已分区对象的查询处理的详细信息，请参阅关于已分区表和索引的查询处理增强功能。

链接服务器

SQL Server 2008 更改了针对环回链接服务器执行的 INSERT...EXECUTE 语句的事务语义。SQL Server 2005 不支持此方案，此方案会导致错误。在 SQL Server 2008 中，如果没有针对连接启用“多个活动结果集 (MARS)”，则可以针对环回链接服务器执行 INSERT...EXECUTE 语句。如果针对连接启用了 MARS，则此行为与 SQL Server 2005 中相同。

tempdb 数据库

在 SQL Server 的早期版本中，tempdb 数据库的 PAGE_VERIFY 数据库选项设置为 NONE 且不能修改。在 SQL Server 2008 中，对于全新安装的 SQL Server 的 tempdb 数据库，该默认值为 CHECKSUM。如果是升级安装 SQL Server，则默认值仍为 NONE。可以修改该选项。我们建议为 tempdb 数据库使用 CHECKSUM。

计划指南

在 SQL Server 2008 中，如果不能遵守计划指南，则查询将使用不同的计划进行编译，并且不会返回错误。在 SQL Server 2005 中，将引发错误，并且查询将失败。

升级到 SQL Server 2008 之后，在 SQL Server 2005 中创建的计划指南可能无效。无效的计划指南不会导致应用程序失败，但不会使用该计划指南。建议在将应用程序升级到 SQL Server 的新版本时，重新评估和测试计划指南定义。性能优化要求和计划指南匹配行为可能会发生更改。尽管无效的计划指南不会导致查询失败，但仍应在不使用计划指南的情况下对计划进行编译。将数据库升级到 SQL Server 2008 之后，应使用 sys.fn_validate_plan_guide 函数执行下列任务来验证现有的计划指南。或者，可以使用 SQL Server Profiler 中的 Plan Guide Unsuccessful 事件来监视是否有无效的计划指南。

使用 USE PLAN 提示的分区表查询

SQL Server 2008 更改对已分区表和索引的查询的处理方式。使用 USE PLAN 提示的已分区对象查询包含的计划可能无效。建议在升级到 SQL Server 2008 之后使用下列过程。

如果在查询中直接指定 USE PLAN 提示：

  1. 从查询删除 USE PLAN 提示。

  2. 测试查询。

  3. 如果优化器未选择相应的计划、优化查询，则使用所需的查询计划指定 USE PLAN 提示。

如果在计划指南中指定 USE PLAN 提示：

  1. 使用 sys.fn_validate_plan_guide 函数来检查计划指南的有效性。或者，可以使用 SQL Server Profiler 中的 Plan Guide Unsuccessful 事件检查是否存在无效计划。

  2. 如果计划指南无效，则删除该计划指南。如果优化器未选择相应的计划、优化查询，则使用所需的查询计划指定 USE PLAN 提示。

有关已分区对象的查询处理的详细信息，请参阅关于已分区表和索引的查询处理增强功能。

REPLACE 函数

在 SQL Server 2005 中，将修整在 REPLACE 函数的输入参数中指定的尾随空格。在 SQL Server 2008 中，尾随空格将保留。对于依赖函数以前的行为的应用程序，在为函数指定输入参数时，请使用 RTRIM 函数。例如，以下语法将修整 REPLACE 函数中的每个输入参数的尾随空格：REPLACE(RTRIM(input_parameter), RTRIM(input_parameter), RTRIM(input_parameter))。

请参阅

参考

SQL Server 2008 中数据库引擎功能的重大更改
SQL Server 2008 中不推荐使用的数据库引擎功能
SQL Server 2008 中废止的数据库引擎功能

其他资源

SQL Server 数据库引擎的向后兼容性
ALTER DATABASE 兼容级别 (Transact-SQL)


全文搜索向后兼容性

全文搜索向后兼容性 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > SQL Server 数据库引擎的向后兼容性 >

向后兼容性部分的主题介绍 SQL Server 2005 和 SQL Server 2008 中的全文搜索在行为上的更改。

请参阅…… | 有关下面的主题
SQL Server 2008 中不推荐使用的全文搜索功能 | 此版本中不推荐使用的全文搜索功能。
SQL Server 2008 中废弃的全文搜索功能 | 此版本中废弃的全文搜索功能。
SQL Server 2008 中全文搜索的重大更改 | 可能需要更改应用程序的全文搜索更改。
SQL Server 2008 中全文搜索的行为更改 | 全文搜索行为的其他更改。

请参阅

其他资源

SQL Server 数据库引擎的向后兼容性


SQL Server 2008 中不推荐使用的全文搜索功能

SQL Server 2008 中不推荐使用的全文搜索功能 |
 | 请参阅
向后兼容性 > SQL Server 数据库引擎的向后兼容性 > 全文搜索向后兼容性 >

本主题说明 SQL Server 2008 中仍然可用但却不推荐使用的全文搜索功能。按照计划，SQL Server 未来版本将不再具有这些功能。在新的应用程序中不应使用这些不推荐使用的功能。

可以使用 SQL Server:Deprecated Features 对象性能计数器监视不推荐使用的功能的使用情况并跟踪事件。有关详细信息，请参阅使用 SQL Server 对象。

SQL Server 的下一版本中不支持的功能

SQL Server 的下一版本仍将继续支持所有全文搜索功能。

SQL Server 未来版本中不支持的功能

SQL Server 的下一版本支持以下全文搜索功能，但以后的版本将删除这些功能。具体是哪一 SQL Server 版本现在还未确定。

功能名称值在跟踪事件中作为 ObjectName，而在性能计数器和 sys.dm_os_performance_counter 中作为实例名称。功能 ID 值在跟踪事件中作为 ObjectId。

类别 不推荐使用的功能 替代功能 功能名称 功能 ID

全文搜索

CREATE FULLTEXT CATALOG 选项：

IN PATH 'rootpath'

ON FILEGROUP filegroup

无。

CREATE FULLTEXT CATLOG IN PATH

无。*

237

无。*

全文搜索

DATABASEPROPERTYEX 属性：IsFullTextEnabled

无。

DATABASEPROPERTYEX('IsFullTextEnabled')

202

全文搜索

FULLTEXTCATALOGPROPERTY 属性：

  • LogSize

  • PopulateStatus

无。

FULLTEXTCATALOGPROPERTY('LogSize')

FULLTEXTCATALOGPROPERTY('PopulateStatus')

211

201

全文搜索

FULLTEXTSERVICEPROPERTY 属性：

  • ConnectTimeout

  • DataTimeout

  • ResourceUsage

无。

FULLTEXTSERVICEPROPERTY('ConnectTimeout')

FULLTEXTSERVICEPROPERTY('DataTimeout')

FULLTEXTSERVICEPROPERTY('ResourceUsage')

210

209

208

全文搜索

sp_configure 选项：

  • ft crawl bandwidth

  • ft notify bandwidth

无。

sp_configure 'ft crawl bandwidth (max)'

sp_configure 'ft crawl bandwidth (min)'

sp_configure 'ft notify bandwidth (max)'

sp_configure 'ft notify bandwidth (min)'

204

205

206

207

全文搜索

sp_detach_db 选项：

[ @keepfulltextindexfile = ] 'KeepFulltextIndexFile'

无。

sp_detach_db @keepfulltextindexfile

226

全文搜索

sp_fulltext_catalog

CREATE FULL CATALOG

ALTER FULLTEXT CATALOG

DROP FULLTEXT CATALOG

sp_fulltext_catalog

84

全文搜索

sp_fulltext_column

sp_fulltext_database

sp_fulltext_table

CREATE FULL INDEX

ALTER FULLTEXT INDEX

DROP FULLTEXT INDEX

sp_fulltext_column

sp_fulltext_database

sp_fulltext_table

86

87

85

全文搜索

sp_help_fulltext_catalogs

sp_help_fulltext_catalog_components

sp_help_fulltext_catalogs_cursor

sp_help_fulltext_columns

sp_help_fulltext_columns_cursor

sp_help_fulltext_tables

sp_help_fulltext_tables_cursor

sys.fulltext_catalogs

sys.fulltext_index_columns

sys.fulltext_indexes

sp_help_fulltext_catalogs

sp_help_fulltext_catalog_components

sp_help_fulltext_catalogs_cursor

sp_help_fulltext_columns

sp_help_fulltext_columns_cursor

sp_help_fulltext_table

sp_help_fulltext_tables_cursor

88

203

90

92

93

91

89

全文搜索

sp_fulltext_service 操作值：

  • clean_up、connect_timeout 和 data_timeout 返回零

  • resource_usage 没有任何作用。

无
  • sp_fulltext_service @action=clean_up

  • sp_fulltext_service @action=connect_timeout

  • sp_fulltext_service @action=data_timeout

  • sp_fulltext_service @action=resource_usage

116

117

118

200

全文搜索

sys.dm_fts_active_catalogs 列：

  • is_paused

  • previous_status

  • previous_status_description

  • row_count_in_thousands

  • 状态

  • status_description

  • worker_count

无。

dm_fts_active_catalogs.is_paused

dm_fts_active_catalogs.previous_status

dm_fts_active_catalogs.previous_status_description

dm_fts_active_catalogs.row_count_in_thousands

dm_fts_active_catalogs.status

dm_fts_active_catalogs.status_description

dm_fts_active_catalogs.worker_count

218

221

222

224

219

220

223

全文搜索

sys.dm_fts_memory_buffers 列：

  • row_count

无。

dm_fts_memory_buffers.row_count

225

全文搜索

sys.fulltext_catalogs 列：

  • 路径

  • data_space_id

  • file_id 列

无。

fulltext_catalogs.path

fulltext_catalogs.data_space_id

fulltext_catalogs.file_id

215

216

217

* SQL Server:Deprecated Features 对象不监视 CREATE FULLTEXT CATLOG ON FILEGROUP filegroup 的出现情况。

请参阅

参考

SQL Server 2008 中不推荐使用的数据库引擎功能

概念

SQL Server 2008 中全文搜索的重大更改

其他资源

SQL Server，Deprecated Features 对象


SQL Server 2008 中废弃的全文搜索功能

SQL Server 2008 中废弃的全文搜索功能 |
 | 请参阅
向后兼容性 > SQL Server 数据库引擎的向后兼容性 > 全文搜索向后兼容性 >

SQL Server 2008 中仍使用全文搜索功能，尽管部分功能已不再推荐使用。有关详细信息，请参阅 SQL Server 2008 中不推荐使用的全文搜索功能。

请参阅

参考

SQL Server 2008 中废止的数据库引擎功能

概念

SQL Server 2008 中全文搜索的重大更改
SQL Server 2008 中全文搜索的行为更改


SQL Server 2008 中全文搜索的重大更改

SQL Server 2008 中全文搜索的重大更改 |
 | 请参阅
向后兼容性 > SQL Server 数据库引擎的向后兼容性 > 全文搜索向后兼容性 >

本主题介绍全文搜索的重大更改。这些更改可能导致基于 SQL Server 的早期版本的应用程序、脚本或功能无法继续使用。在进行升级时可能会遇到这些问题。有关详细信息，请参阅使用升级顾问来准备升级。

重大更改

下面是 SQL Server 2008 中对全文搜索的重大更改。

功能 方案 SQL Server 2005 SQL Server 2008

具有用户定义类型 (UDT) 的 CONTAINSTABLE

全文键为 SQL Server 用户定义类型，例如，MyType = char(1)。

返回键的类型是为用户定义类型指定的类型。

对于示例，它应是 char(1)。

返回键的类型是用户定义类型。对于示例，它应是 MyType。

CONTAINSTABLE 和 FREETEXTTABLE Transact-SQL 语句的 top_n_by_rank 参数

top_n_by_rank 查询将 0 用作该参数。

失败并显示一个错误消息，说明您必须使用一个大于零的值。

成功，返回零行。

CONTAINSTABLE 和 ItemCount

在它将更改推入 MSSearch 之前从基表中删除行。

CONTAINSTABLE 返回虚影记录。ItemCount 保持不变。

CONTAINSTABLE 不返回任何虚影记录。

ItemCount

表包含 Null 文档或类型列。

除了索引文档之外，Null 文档或类型为 Null 的文档也计算在 ItemCount 值之内。

仅索引文档计算在 ItemCount 值之内。

目录 ItemCount

扩展名为 NULL 的 Blob 列。

它计算在目录的 ItemCount 之内。

它不计算在目录的 ItemCount 之内。

UniqueKeyCount

从目录查询唯一键计数，例如，有两个表均（table1 和 table2），每个表都包含三个单词：word1、word2 和 word3。

UniqueKeyCount = 9。下面介绍了是如何得出此值的：

table1 = 3

table1 全文索引的 EOF = 1

table2 = 3

Table2 全文索引的 EOF = 1

全文目录 = 1

对于每个表，UniqueKeyCount 等于非重复关键字数目加 1 (0xFF)。不会将在多个文档中出现的同一个单词视为新的唯一键。

对于目录，UniqueKeyCount 是此目录下每个表的 UniqueKeyCount 之和。不同表中的相同单词被视为唯一键。在这种情况下唯一键计数是 8。

更新键列时的 sp_fulltext_pendingchanges

对包含两行的表的其中一行更新全文键列，并运行 sp_fulltext_pendingchanges。

两个行均显示。

只显示一行。

内联函数

带全文运算符的内联函数

返回错误消息。

返回相关行。

sp_fulltext_database

通过使用 sp_fulltext_database 启用或禁用全文搜索。

全文查询不返回任何结果。如果对数据库禁用全文功能，则将不允许全文操作。

为全文查询返回结果，并且允许全文操作，即使对数据库禁用全文功能也是如此。

特定于区域设置的非索引字

使用父语言下特定于区域设置的子语言（如比利时法语和加拿大法语）的查询。

使用特定于区域设置的子语言的查询将由其父语言的组件（断字符、词干分析器和非索引字）处理。例如，“法语（法国）”组件用于分析“法语（比利时）”。

必须为每个区域设置标识符 (LCID) 显式添加非索引字。例如，您需要为比利时、加拿大和法国指定一个 LCID。

同义词库词干分析进程

使用同义词库和变形（词干分析）。

同义词库单词在其扩展之后自动进行词干分析。

如果要得到扩展形式中的词干，则需要显式添加词干。

全文目录路径和文件组

使用全文目录。

每个全文目录都有一个物理路径，并且都属于一个文件组。系统将其视为数据库文件。

全文目录是虚拟对象，不属于任何文件组。全文目录是表示一组全文索引的逻辑概念。

注意：
指定全文目录的 SQL Server 2005 Transact-SQL DDL 语句可正常运行。

sys.fulltext_catalogs

使用此目录视图的 path、data_space_id 和 file_id。

这些列都返回一个特定值。

由于全文目录已不再位于文件系统中，因而这些列均返回 NULL。

sys.sysfulltextcatalogs

使用此不推荐使用的系统表的 path 列。

返回全文目录的文件系统路径。

由于全文目录已不再位于文件系统中，因而返回 NULL。

sp_help_fulltext_catalogs

sp_help_fulltext_catalogs_cursor

使用这些不推荐使用的存储过程的 PATH 列。

返回全文目录的文件系统路径。

由于全文目录已不再位于文件系统中，因而返回 NULL。

sp_help_fulltext_catalog_components

使用此存储过程的 sp_help_fulltext_catalog_components。

返回用于当前数据库中所有全文目录的所有组件（筛选器、断字符和协议处理程序）的列表。

返回空行。

DATABASEPROPERTY 和 DATABASEPROPERTYEX

使用 IsFullTextEnabled 属性。

IsFullTextEnabled 设置指示给定数据库中是否启用了全文搜索。

此列的值没有任何效果。用户数据库始终启用全文搜索。

请参阅

概念

SQL Server 2008 中全文搜索的行为更改

其他资源

全文搜索
使用 Transact-SQL 函数获取全文属性值


SQL Server 2008 中全文搜索的行为更改

SQL Server 2008 中全文搜索的行为更改 |
 | 请参阅
向后兼容性 > SQL Server 数据库引擎的向后兼容性 > 全文搜索向后兼容性 >

本主题介绍全文搜索中的行为更改。行为更改会影响 SQL Server 2008 中的功能与早期版本的 SQL Server 相比的工作或交互方式。

在 SQL Server 2008 中，全文引擎作为数据库服务集成到关系数据库中，作为服务器查询和存储引擎基础结构的一部分。新的全文搜索体系结构可实现以下目的：

  • 集成的存储和管理 - 全文搜索现在与 SQL Server 的固有存储和管理功能直接集成，并且 MSFTESQL 服务已不存在。

    • 全文索引存储在数据库文件组内部，而不是在文件系统中。对数据库执行管理操作（如创建备份）会自动影响其全文索引。

    • 现在，全文目录是虚拟对象，并不属于任何文件组；它是表示一组全文索引的逻辑概念。因此，许多目录管理功能已不推荐使用，继而也就引发了某些功能的重大更改。有关详细信息，请参阅 SQL Server 2008 中不推荐使用的数据库引擎功能和 SQL Server 2008 中全文搜索的重大更改。

      注意：
      指定全文目录的 SQL Server 2005 Transact-SQL DDL 语句可正常运行。

  • 集成的查询处理 - 新的全文搜索查询处理器是数据库引擎的一部分，并与 SQL Server 查询处理器完全集成。这表示查询优化器将识别全文查询谓词，并尽可能高效地自动执行它们。

  • 增强的管理和故障排除 - 集成的全文搜索提供的工具可以帮助您分析搜索结构，例如全文索引、给定断字符的输出和非索引字配置等。有关详细信息，请参阅全文搜索故障排除。

  • 非索引字和非索引字表已替代干扰词和干扰词文件。非索引字表是一种数据库对象，有助于简化非索引字的可管理性任务，并提高不同服务器实例和环境之间的完整性的一个数据库对象。有关详细信息，请参阅非索引字和非索引字表。

  • SQL Server 2008 包括 SQL Server 2005 中存在的许多语言的新断字符。只有英语、朝鲜语、泰语和中文（所有形式）的断字符保持不变。对于其他语言，如果全文目录是在将 SQL Server 2005 数据库升级到 SQL Server 2008 时导入的，则该全文目录中全文索引使用的一种或多种语言现在可能与新断字符关联，这些新断字符的行为与导入的断字符的行为稍有不同。有关如何保证查询和全文索引内容之间的完全匹配的详细信息，请参阅全文搜索升级。

  • 已添加一个新的 FDHOST 启动器 (MSSQLFDLauncher) 服务。有关详细信息，请参阅全文搜索入门。

  • 全文索引功能处理 FILESTREAM 列的方式与其处理 varbinary(max) 列的方式相同。FILESTREAM 表必须有一列包含每个 FILESTREAM BLOB 的文件扩展名。有关详细信息，请参阅查询 varbinary(max) 和 xml 列、全文搜索筛选器、全文索引和查询过程和 sys.fulltext_document_types (Transact-SQL)。

    全文引擎会对 FILESTREAM BLOB 的内容进行索引。对诸如图像之类的文件进行索引可能没有用。更新 FILESTREAM BLOB 时，会重新对其进行索引。

重要提示：
有关新的全文搜索体系结构对现有应用程序和脚本的影响的基本信息，我们强烈建议您参阅 SQL Server 2008 中不推荐使用的数据库引擎功能和 SQL Server 2008 中全文搜索的重大更改。

请参阅

概念

全文搜索升级

其他资源

全文搜索的体系结构
全文搜索向后兼容性
全文搜索基础
全文搜索入门


SQL Server Analysis Services 的向后兼容性

SQL Server Analysis Services 的向后兼容性
升级到 SQL Server 2008 > 向后兼容性 >

本节中的各主题介绍 Microsoft SQL Server Analysis Services 的不同版本之间在行为方面的更改

本节内容

主题 | 说明
SQL Server 2008 中废弃的 Analysis Services 功能 | 介绍在 SQL Server Analysis Services 的早期版本中存在但在后来的版本中已删除的功能。
SQL Server 2008 中不推荐使用的 Analysis Services 功能 | 介绍 SQL Server Analysis Services 中出于向后兼容的目的而保留、但在将来版本的 SQL Server 中将会删除的功能。
SQL Server 2008 中 Analysis Services 功能的行为更改 | 介绍在 SQL Server Analysis Services 中已更改的功能。
SQL Server 2008 中 Analysis Services 功能的重大更改 | 介绍升级到 SQL Server Analysis Services 时可能遇到的问题。


SQL Server 2008 中不推荐使用的 Analysis Services 功能

SQL Server 2008 中不推荐使用的 Analysis Services 功能 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > SQL Server Analysis Services 的向后兼容性 >

本主题介绍 SQL Server 2008 中仍然可用但不推荐使用的 Analysis Services 功能。按照计划，SQL Server 未来版本将不再具有这些功能。在新的应用程序中不应使用这些不推荐使用的功能。

不推荐使用的功能

类别 | 不推荐使用的功能 | 注释
连接字符串属性 | InsertInto | 用于填充本地多维数据集的原始连接字符串语法。
连接字符串属性 | CreateCube | 用于填充本地多维数据集的原始连接字符串语法。 在 ADOMD.NET 中不支持。
功能 | SQL Server 2000 PMML | 此功能已由标准预测模型标记语言 (PMML) 替换。
多维表达式 (MDX) | Create Action | 支持扩展语法，但英文语句无法创建新类型的操作。应改用 DDL。
MDX | CalculationPassValue |
MDX | CalculationCurrentPass |
MDX | 默认情况下 NON_EMPTY_BEHAVIOR 查询优化器提示已打开 | 在未来版本中，NON_EMPTY_BEHAVIOR 查询优化器提示将默认为关闭。如果使用不正确，MDX 优化提示可能会产生不正确的结果。
其他 | CELL_EVALUATION_LIST 内部单元属性 | SQL Server Analysis Services 中此属性为空白。
对象 | COM 程序集 | COM 程序集可能会造成安全风险。

请参阅

其他资源

SQL Server Analysis Services 的向后兼容性


SQL Server 2008 中废弃的 Analysis Services 功能

SQL Server 2008 中废弃的 Analysis Services 功能 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > SQL Server Analysis Services 的向后兼容性 >

本主题介绍 SQL Server 2008 中不再可用的 Analysis Services 功能。

废弃的功能

类别 | 废弃的功能 | 注释
连接字符串属性 | Mining Execution Location | 为实现向后兼容性，可接受此属性，但已忽略。始终在服务器上执行。
连接字符串属性 | Mining Location |
连接字符串属性 | Log File | Log File 功能已由 Trace 功能替换。
连接字符串属性 | Execution Location |
连接字符串属性 | Distinct Measures by Key |
连接字符串属性 | Large Level Threshold |
功能 | 聚合提供程序 | 此功能已由插件算法替换。
功能 | 链接多维数据集 | 此功能已由链接度量值组替换。
功能 | 自定义级别公式 | 此功能已由多维表达式 (MDX) 脚本替换。
功能 | 多维数据集和数据库角色命令 | 不再支持。
MDX | CreateVirtualDimension | 不再支持此 MDX 函数。
MDX | CreatePropertySet | 不再支持此 MDX 函数。
MDX | Ignore | 在 SQL Server 2000 Analysis Services 中，此函数保留供将来使用。
其他 | Active Directory 注册 |
其他 | 父子层次结构中的已跳过级别 | SkippedLevelsColumn 属性指示在父子层次结构中的父级下创建成员时要跳过的级别数，该属性不再受支持。
工具 | 外围应用配置器工具 | 对于 SQL Server 2008，外围应用配置器工具已停止使用。有关详细信息，请参阅向后兼容性。

请参阅

其他资源

SQL Server Analysis Services 的向后兼容性


SQL Server 2008 中 Analysis Services 功能的重大更改

SQL Server 2008 中 Analysis Services 功能的重大更改 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > SQL Server Analysis Services 的向后兼容性 >

本主题介绍 Analysis Services 中的重大更改。这些更改可能导致基于 SQL Server 的早期版本的应用程序、脚本或功能无法继续使用。在进行升级时可能会遇到这些问题。有关详细信息，请参阅使用升级顾问来准备升级。

SQL Server 2008 中 Analysis Services 的重大更改

下表列出将 SQL Server 2005 Analysis Services (SSAS) Analysis Services 数据库升级为 SQL Server 2008 时可能遇到的问题。

问题类型 问题说明

shallow exists 函数与包含枚举成员或枚举集叉积的命名集结合使用的方式已更改。

在 SQL Server 2005 Analysis Services (SSAS) 中，shallow exists 函数不可用于包含枚举成员或枚举集叉积的命名集。若要实现与 SQL Server 2005 Analysis Services (SSAS) 的原始发布版本和 SP1 的向后兼容，可将配置属性 ConfigurationSettings\OLAP\Query\NamedSetShallowExistsMode 设置为 1；若要实现与 SQL Server 2005 Analysis Services (SSAS) SP2 的向后兼容，则应将其设置为 2。

VBA 函数对 Null 值和空值的处理方式已与 SQL Server 2005 Analysis Services (SSAS) Analysis Services. 中的方式有所不同。

在 SQL Server 2005 Analysis Services (SSAS) 中，如果将 Null 值或空值用作参数，VBA 函数将返回 0 或空字符串。在 SQL Server 2008 中，它们将返回 Null。

迁移向导将因默认情况下不安装 DSO 而失败。

默认情况下，SQL Server 2008 不会安装 DSO（决策支持对象）向后兼容组件。默认情况下将安装向后兼容包，但将禁用该包的 DSO 组件。由于 SQL Server Analysis Services 迁移向导依赖此组件，因此在未安装该组件的情况下该迁移向导将失败。若要安装 DSO 组件，请执行下列操作：

  1. 打开“控制面板”。

  2. 在 Windows XP 或 Windows Server 2003 中，选择“添加或删除程序”。在 Windows Vista 和 Windows Server 2008 中，选择“程序和功能”。

  3. 右键单击“Microsoft SQL Server 2005 向后兼容”，然后选择“更改”。

  4. 在向后兼容安装向导中，单击“下一步”。

  5. 在“程序维护”页上，选择“修改”，然后单击“下一步”。

  6. 在“功能选择”页上，如果决策支持对象 (DSO) 不可用，请单击向下箭头，然后选择“此功能将安装到本地硬盘上”。单击“下一步”。

  7. 在“准备修改程序”页上，单击“安装”。

  8. 安装完成后，请单击“完成”。

迁移完成后，您可以按照上述步骤删除 DSO，不过需将 DSO 的选项更改为“此功能将不可用”。

如果未安装向后兼容包，则可以从 SQL Server 2008 分发媒体进行安装。请注意，存在针对各目标体系结构的版本 (x86、x64、ia64)。可在以下位置找到这些版本：

x86\Setup\x86\SQLServer2005_BC.msi

x64\Setup\x64\SQLServer2005_BC.msi

ia64\Setup\ia64\SQLServer2005_BC.msi

不建议将分区位置放置在 Data 文件夹中。

服务器管理 Data 文件夹，并将在创建、删除和更改对象时创建或删除相应文件夹。因此，强烈建议不要在 Data 文件夹内指定分区存储位置，尤其是不要在数据库、多维数据集和维度的子文件夹中指定。尽管服务器允许您使用 Create 或 Alter 命令来执行此操作，但它会显示警告。如果您将 Data 文件夹中包含有分区存储位置的数据库从 Analysis Services 2005 升级到 Analysis Services 2008，即可执行此操作。还原或同步操作将需要您将分区存储位置移出 Data 文件夹。

您可能会从在 ProClarity Analytics Server 和 Microsoft Office PerformancePoint Server 2007 中使用“EXISTING”MDX 关键字的查询获得意外结果。

某些情况下，ProClarity Analytics Server 和 Microsoft Office PerformancePoint Server 2007 会在 MDX 中错误地使用 EXISTING 关键字。由于已对 Analysis Services 2008 进行了软件更新，因此这些查询可能会返回意外结果。ProClarity Analytics Server 和 Microsoft Office PerformancePoint Server 2007 将发布一个 Service Release 以解决此问题。

SQL Server 2005 中 Analysis Services 的重大更改

下表列出将 SQL Server 2000 Analysis Services 数据库升级为 SQL Server 2008 时可能遇到的问题。

问题类型 问题说明

不迁移依赖于链接对象的对象

在 Microsoft SQL Server 2008 Analysis Services 中，升级顾问不迁移链接多维数据集和链接维度。因此，无法迁移引用链接多维数据集或链接维度的对象，原因是无法迁移这种对象所基于的链接对象。例如，无法迁移基于链接多维数据集的 OLAP 挖掘模型，这是因为无法迁移挖掘模型所基于的链接多维数据集。

如果将多个层次结构迁移到同一个维度中，则 Autoexist 可以产生不同的查询结果

将多个层次结构或虚拟维度迁移到 Microsoft SQL Server 2008 Analysis Services 的同一维度中时，查询此维度中包含的已迁移层次结构与迁移前查询 SQL Server 2000 Analysis Services 中的该层次结构所产生的结果可能不同，这是因为 Autoexist 功能会自动从包含已迁移层次结构成员的集的任何交叉联接中删除不存在于该维度中的元组。若要解决此问题，应检查在同一维度中涉及多个层次结构的计算。

使用禁用的级别时，浏览体验会不同

从 SQL Server 2005 Analysis Services 开始，不再支持在层次结构中包含隐藏的或禁用的级别。隐藏的或禁用的级别迁移为可见的和启用的级别。计算时如果涉及包含此类级别的层次结构，可能会返回意外结果。升级后，请检查并验证涉及以前包含隐藏或禁用级别的层次结构的计算。

存入桶对于分组级别而言可能不同

从 Microsoft SQL Server 2005 Analysis Services (SSAS) 开始，自动分组可能会返回一组不同的成员组。依赖这些成员组的计算可能会返回意外的结果。升级后，请检查并验证依赖于成员组的计算。

从非特定语言到特定语言的转换可能会产生意外的结果

在 SQL Server 2000 Analysis Services 以及早期版本中，Analysis Services 只使用非特定语言标识符，也称为主要语言标识符，例如 LANG_ENGLISH (0x09) 表示英语，LANG_CHINESE (0x04) 表示中文。

为支持翻译和排序规则选项，Analysis Services 现在使用特定语言标识符，这些标识符是主要语言标识符与用于特定区域性的子语言标识符的组合。例如，主要语言标识符 LANG_ENGLISH (0x09) 和子语言标识符 SUBLANG_ENGLISH_AUS (0x03) 的组合表示澳大利亚英语。

从非特定语言迁移到特定语言的标识符会更改预期的翻译和排序规则行为，从而导致意外的结果。升级后，请检查并验证语言标识符发生了更改的对象，例如维度、层次结构和成员。

不支持多维数据集角色命令

Microsoft SQL Server 2008 Analysis Services 不支持针对多维数据集角色的命令对象，因而不会从早期版本迁移命令。

自定义级别公式以不同方式聚合

如果多维数据集包含带有自定义级别公式的维度，并且还包含前后都带有自定义成员公式和/或一元运算符的维度，那么该多维数据集可能会返回与早期版本的 Analysis Services 不同的结果。这是因为计算优先规则已更改。

自定义成员公式和自定义汇总公式会被迁移到 MDX 脚本中

在 Analysis Services 的早期版本中，支持维度和级别的以下属性：自定义汇总公式、自定义成员公式、所有成员公式和自定义级别公式。在 SQL Server 2005 Analysis Services 中，这些属性已由多维表达式 (MDX) 脚本中支持的功能所取代，因而在迁移期间这些属性会升级到 MDX 脚本。

不迁移自定义聚合

在 Analysis Services 的早期版本中手动生成的聚合，在 Microsoft SQL Server 2008 Analysis Services 中不会迁移。仅迁移由存储设计向导生成的聚合。若要解决此问题，请使用 XMLA 脚本手动创建聚合。

数据成员始终存在于父子维度中

Analysis Services 的早期版本提供了不在父子维度中包括数据成员的选项。在 Analysis Services 的早期版本中，维度的 DataMembers 属性支持三个选项：None、Hidden 或 Visible。None 选项在 Microsoft SQL Server 2008 Analysis Services 中不可用。数据成员始终包含在父属性中。若要在父子维度中隐藏数据成员，可以将维度的 DataMembers 属性设为 Hidden。父特性的 MembersWithData 属性仅支持两个选项：NonLeafDataHidden 或 NonLeafDataVisible。

不支持数据库角色命令

Microsoft SQL Server 2008 Analysis Services 不支持数据库角色的命令对象，因而不会从 Analysis Services 的早期版本迁移命令。

DefaultMember 已迁移到 MDX 脚本中

在 Analysis Services 的早期版本中，维度的默认成员由多维表达式 (MDX)（包含在维度的 DefaultMember 属性中）指定。在 Microsoft SQL Server 2005 Analysis Services (SSAS) 中，此属性已由 MDX 脚本中支持的功能所取代，因而在迁移期间该属性会升级到 MDX 脚本。

迁移时对维度和层次结构的重命名可能会导致不同的查询结果

SQL Server 2000 Analysis Services 中的维度层次结构在内部表示为单独的维度，并使用命名约定标识。迁移到 Microsoft SQL Server 2008 可能会为每个维度层次结构创建一个单独的维度，并用新名称命名，而不是将父维度下的维度层次结构组合在一起，这是因为 auto-exist 会导致安全规则不同于 Analysis Services 的早期版本中应用的安全规则。

不迁移钻取设置

尽管 Microsoft SQL Server 2008 Analysis Services 中存在钻取，但不会迁移 Analysis Services 的早期版本中的钻取设置。

迁移后隐藏的级别是可见的

Analysis Services 不再支持在层次结构中包含隐藏的或禁用的级别。隐藏的或禁用的级别迁移为可见的和启用的级别。计算时如果涉及包含此类级别的层次结构，可能会返回意外结果。

无效对象导致迁移失败

数据库包含无效对象。如果数据库包含无效对象，则迁移无法完成。

不迁移链接多维数据集

Analysis Services 的早期版本支持链接多维数据集。在 Microsoft SQL Server 2005 Analysis Services (SSAS) 中，此功能已由链接维度和链接度量值组所取代。

在迁移期间可能会更改成员的唯一名称

Analysis Services 在迁移期间会尝试保留成员的唯一名称，但是在某些情况下会更改成员的唯一名称。如果更改了成员的唯一名称，则客户端应用程序、多维表达式 (MDX) 表达式和其他依赖于成员唯一名称的属性可能会产生意外的结果。

不支持 ODBC 数据源

尽管 Analysis Services 的早期版本允许使用 ODBC 数据源，但现在已不再支持此功能。

不迁移远程分区

远程分区不会从 Microsoft SQL Server 2000 Analysis Services 迁移到 Microsoft SQL Server 2008 Analysis Services。可将服务器升级到 SQL Server 2008 Analysis Services，然后手动创建远程分区。

不支持某些挖掘模型算法参数

Analysis Services 的早期版本支持在 Microsoft 决策树算法中使用 MINIMUM_LEAF_CASES 参数，以及在 Microsoft 群集算法中使用 MINIMUM_CLUSTER_CASES 参数。从 SQL Server 2005 Analysis Services 开始，这两个参数均重命名为 MINIMUM_SUPPORT。如果在使用早期版本的 Analysis Services 创建的挖掘模型中使用了这些参数，则不会迁移这些参数。

某些 MDX 函数的行为发生了更改

由于 Microsoft SQL Server 2005 Analysis Services (SSAS) 中对多维表达式 (MDX) 语言进行了增强和更改，因此不再支持某些 MDX 函数，或者这些函数的行为与 Analysis Services 的早期版本中相比发生了更改。

CREATE KPI 命令引入了一个新关键字

CREATE KPI 命令引入了一个新关键字 KPI。如果现有对象的名称为 KPI，则该新关键字会与之冲突。

不支持维度安全性的顶级

在 Analysis Services 的早期版本中，您可以指定维度安全性，使用户看到的顶级与层次结构的顶级不同。迁移后，使用顶级设置保护的成员将可见。

不迁移也不注册 UDF 源 .DLL

不迁移在 Analysis Services 的早期版本中注册的用户定义函数 (UDF)。

有限支持非父子层次结构上的一元运算符

从 Microsoft SQL Server 2005 Analysis Services (SSAS) 开始，除非层次结构中以级别为源的属性之间存在属性关系，否则不支持父子层次结构之外的层次结构上的一元运算符。

不支持虚拟多维数据集

Analysis Services 的早期版本支持虚拟多维数据集，即一个或多个常规或链接多维数据集中的度量值和维度子集的组合视图。在 Microsoft SQL Server 2005 Analysis Services (SSAS) 中，此功能已由链接度量值组替换。在升级过程中，虚拟多维数据集将作为链接度量值组进行迁移。

不迁移写回表内容

在 Microsoft SQL Server 2005 Analysis Services (SSAS) 中，已经更新了由 Analysis Services 的早期版本生成的写回表的结构。由 Analysis Services 的早期版本生成的写回表中的数据无法迁移到新的写回表结构中。

请参阅

其他资源

SQL Server Analysis Services 的向后兼容性


SQL Server 2008 中 Analysis Services 功能的行为更改

SQL Server 2008 中 Analysis Services 功能的行为更改 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > SQL Server Analysis Services 的向后兼容性 >

本主题介绍 Analysis Services 中的行为更改。行为更改会影响 SQL Server 2008 中的功能与早期版本的 SQL Server 相比的工作或交互方式。

行为更改

功能 | SQL Server 2000 行为 | SQL Server 行为
浏览 | 支持层次结构中的隐藏或禁用级别。 | 隐藏或禁用级别迁移为可见和启用级别。计算时如果涉及包含此类级别的层次结构，则可能会返回意外结果。
维度 | 支持在父子维度中不包含数据成员的选项。 | 数据成员始终存在于父子维度中；不能再从父子维度中排除数据成员。
多维表达式 (MDX) | 函数：CreateVirtualDimension | 表达式将返回错误。
MDX | 函数：CreatePropertySet | 表达式将返回错误。
MDX | 语句：With Cache | 接受该语法，但不执行任何操作。
MDX | 语句：Create Cache | 接受该语法，但不执行任何操作。
MDX | 计算优先规则。 | 计算优先规则已更改，与 Analysis Services 的早期版本不同。 由于自定义汇总的优先级提前，表达式返回的结果可能与 Analysis Services 的早期版本返回的不同。
安全性 | 支持通过指定维度安全性使用户看到的顶级不同于层次结构的顶级。 | 不支持维度安全性的顶级。在迁移后，使用顶级设置保护的成员将可见。
其他 | 更新中自动提交和自动回滚。 | 尝试提交不存在的事务会失败。在 SQL Server 2000 Analysis Services 中，Update 语句创建它自己的事务。但在 SQL Server Analysis Services 中不会创建。

请参阅

其他资源

SQL Server Analysis Services 的向后兼容性


Reporting Services 的向后兼容性

Reporting Services 的向后兼容性 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 >

本节介绍 SQL Server Reporting Services 的不同版本之间在行为方面的更改它包括不再可用或计划在将来的版本中删除的功能。本节还介绍了对产品所做的根本性更改，已知这些更改会使包含 Reporting Services 功能的自定义应用程序不能正常工作。

本节内容

  • SQL Server Reporting Services 中不推荐使用的功能

  • SQL Server Reporting Services 中停止使用的功能

  • SQL Server 2008 Reporting Services 中的重大更改

  • SQL Server Reporting Services 中的行为更改

关于 SQL Server 2008 中的报表创作和发布

在此版本中，将使用新版本的报表定义语言 (RDL) 架构创作新报表。使用此新架构的报表必须在新的独立报表设计器应用程序内创作，而不能在集成在 SQL Server Business Intelligence Development Studio 中的报表设计器内创作。

新的独立报表设计器应用程序可创作带有新功能的报表，这些新功能包括 Tablix 数据区域和展开的图表数据区域。使用新架构的报表不能发布到以前版本的 Reporting Services 报表服务器。若要查看使用新的 RDL 架构的报表，您必须部署它们（使用报表设计器应用程序）或将其上载（使用报表管理器）到 SQL Server 2008 Reporting Services 报表服务器。

有关 RDL 的详细信息，请参阅Report Definition Language Reference。有关报表创作的详细信息，请参阅报表制作中的新增功能。
关于 SQL Server 2008 中的报表处理和呈现

在此版本中，报表处理引擎已重新设计为仅在查看或导出报表页面才处理和呈现这些页面。有关详细信息，请参阅针对报表处理和呈现的新增功能。

在此版本中，报表呈现对象模型已被替换。有关详细信息，请参阅 SQL Server 2008 Reporting Services 中的重大更改。

请参阅

概念

向后兼容性

其他资源

升级 (Reporting Services)


SQL Server Reporting Services 中不推荐使用的功能

SQL Server Reporting Services 中不推荐使用的功能 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > Reporting Services 的向后兼容性 >

本主题介绍 SQL Server 2008 中仍然可用但不推荐使用的 Reporting Services 功能。按照计划，SQL Server 未来版本将不再具有这些功能。在新的应用程序中不应使用这些不推荐使用的功能。

请参阅

概念

向后兼容性

其他资源

升级 (Reporting Services)
Reporting Services 的向后兼容性


SQL Server Reporting Services 中停止使用的功能

SQL Server Reporting Services 中停止使用的功能 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > Reporting Services 的向后兼容性 >

此主题介绍 SQL Server 2008 中不再可用的 Reporting Services 功能。此处不包括关于停止支持某些版本的操作系统或 Microsoft Internet Information Services (IIS) 的声明。有关系统必备条件的详细信息，请参阅安装 SQL Server 2008 的硬件和软件要求。

报表服务器数据库的手动升级

从 SQL Server 2005 Service Pack 2 (SP2) 开始，报表服务器服务可以自动检测报表服务器数据库的版本并将其升级为与当前报表服务器实例的版本匹配的架构。当检测到较早版本的数据库时，系统会提示您对其进行升级。如果升级此版本，则架构将升级到新格式且无法再将其回滚到之前的格式。

由于增加了自动升级功能，您不再需要创建数据库升级脚本或在 Reporting Services 配置工具中使用自动升级选项。在 SQL Server 2008 Reporting Services (SSRS) 中，用于创建脚本和执行升级操作的按钮已从 Reporting Services 配置工具中的“数据库安装”页删除。有关升级支持的详细信息，请参阅升级报表服务器数据库。

Internet Explorer 5.5 支持

Reporting Services 2005 Service Pack 2 中已声明不推荐使用 Microsoft Internet Explorer 5.5 支持。SQL Server 2008 版本的 Reporting Services 不支持此版本的 Internet Explorer。

SQL Server 2000 报表服务器 Web 服务端点

SQL Server 2000 报表服务器 Web 服务端点已在此版本中停止使用。有关当前端点的详细信息，请参阅 SQL Server 联机丛书中的Report Server Web Service Endpoints。

HTML OWC 呈现扩展插件

在此版本中已停止使用具有 Office Web 组件 (OWC) 的 HTML 呈现扩展插件。

HTML 3.2 呈现扩展插件

此版本中已停止使用 HTML 呈现扩展插件中的 HTML 3.2 格式。Reporting Services 安装中不再包括呈现扩展插件。

报表生成器只在完全信任模式下运行

对于本机模式下的 Reporting Services，此版本中已停止了对于在部分信任模式下运行报表生成器的支持。本地模式和 SharePoint 模式下的 Reporting Services 均只支持在完全信任模式下运行报表生成器。

外围应用配置器工具

对于 SQL Server 2008，外围应用配置器工具已停止使用。有关详细信息，请参阅向后兼容性。

Notification Services

Notification Services 已从 SQL Server 2008 中删除。可以使用现有的 Reporting Services 功能（例如数据驱动订阅）获取由先前版本的 SQL Server 中的 Notification Services 提供的某些功能。

请参阅

概念

向后兼容性

其他资源

升级 (Reporting Services)
Reporting Services 的向后兼容性


SQL Server 2008 Reporting Services 中的重大更改

SQL Server 2008 Reporting Services 中的重大更改 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > Reporting Services 的向后兼容性 >

本主题介绍 Reporting Services 中的重大更改。这些更改可能导致基于早期版本 SQL Server 的应用程序、脚本或功能无法继续使用。您在升级时，或在自定义脚本或报表中可能会遇到这些问题。有关详细信息，请参阅使用升级顾问来准备升级。

报表服务器重大更改

报表生成器重大更改

报表处理重大更改

报表呈现重大更改

有关新功能的详细信息，请参阅新增功能 (Reporting Services)。

报表服务器重大更改

本节介绍报表服务器和管理工具的重大更改。

功能 说明

IIS 和 ASP.NET

Reporting Services 不再依赖 IIS 提供对 SOAP 终结点的访问。URL 不再包括 IIS 中的网站。Reporting Services 直接使用 HTTP.SYS 在您为报表服务器 URL 定义的特定端口上侦听请求。

此增强功能对某些部署而言是重大更改：

  • 如果您具有包括查看 IIS 元数据或属性的脚本、工具或诊断过程，则现在必须开发新的方法以便管理报表服务器部署。

  • 如果您实施 ISAPI 筛选器来保障安全，则必须将 ISAPI 筛选器移至 ISA 服务器中，或创建一个可在 Reporting Services 中执行同一操作的新的 HTTP 模块。

  • 如果使用自定义虚拟目录设置，则可能无法在新的报表服务器实施中配置等效设置或 URL。在某些情况下，升级操作不能为报表服务器或报表管理器创建等效 URL。

升级顾问将通过检查 ISAPI 筛选器和自定义虚拟目录来检测重大更改。升级顾问无法检查所有可能的自定义项。您的安装可能会通过升级顾问检查，但仍可能会中断或产生意外错误。

Windows XP 上的端口冲突

在支持的 32 位 Windows XP SP2 的版本上，IIS 5.1 和 Reporting Services 不能使用相同的端口。不能将 IIS 5.1 和报表服务器都配置为侦听默认 HTTP 端口（端口 80）。

对于在 Web 服务器上承载的 Web 应用程序，IIS 5.1 不使用 HTTP.SYS。这意味着，对于通过同一端口传来的请求，没有公共队列管理，并且没有已注册且已保留 URL 的公共存储库。

该问题会导致在 Windows XP 上升级 SQL Server 2008 Reporting Services 时出现以下行为：

  • 在 Windows XP 的 32 位版本上，如果将现有 SQL Server 2005 Reporting Services 安装升级到 SQL Server 2008 Reporting Services，会将报表服务器配置为侦听端口 8080。

  • 在 Windows XP 的 64 位版本上，如果将现有 SQL Server 2005 Reporting Services 安装升级到 SQL Server 2008 Reporting Services，会将报表服务器配置为侦听端口 80。

  • 如果执行 SQL Server 2008 内部版本到内部版本的升级，则报表服务器将继续侦听升级之前配置的相应端口。

升级完成后，如果希望报表服务器侦听其他端口，则可以使用 Reporting Services 配置工具来更改端口。

有关 SQL Server 2008 支持的 Windows 操作系统的详细信息，请参阅安装 SQL Server 2008 的硬件和软件要求。

注意：
不再支持 IIS 5.0。SQL Server 2008 不支持 Windows 2000 服务器。

Reporting Services Windows Management Instrumentation (WMI) 提供程序

Reporting Services Windows Management Instrumentation (WMI) 提供程序与以前的版本不兼容。新的版本包括其他方法来支持 URL 注册。由于报表服务器安装只能有一个版本的 Reporting Services WMI 提供程序，因此此版本将替代以前的版本。此更改表示针对某些部署而进行的重大更改。如果创建了调用 WMI 提供程序的脚本或工具，则必须修订代码以使用新版本。有关详细信息，请参阅 Reporting Services WMI Provider。

此更改还会阻止用户通过指定要连接的 <server_name>\<instance_name> 格式来与 SQL Server Management Studio 中的 SQL Server 2005 实例建立连接。用户必须改为键入要连接的报表服务器 URL。

服务与应用程序合并

报表服务器 Web 服务、报表管理器和后台处理应用程序都合并到一个服务中。您不能单独启动或停止它们。

Reporting Services 配置文件

Reporting Services 配置文件也进行合并。RSReportServer.config 文件是报表管理器和报表服务器 Web 服务的主配置文件。RSWebApplication.config 文件已过时。以下 RSWebApplication.config 设置已被移到 RSReportServer.config 文件：

  • ReportServerUrl

  • ReportServerExternalUrl

  • ReportBuilderTrustLevel

  • 传递扩展的 DeliveryUI 设置

  • DisplayErrorLink

以下设置已过时，不再使用：

  • ReportServerVirtualDirectory

  • MaxActiveReqForOneUser

如果在以前的安装中修改 RSWebApplication.config 文件，则在升级到 SQL Server 2008 时不会删除该文件。您应手动删除该文件，在本版本中，该文件内的所有设置都将被忽略。

Reporting Services 跟踪日志

ReportServerService_<时间戳>.log 是运行在该服务中的所有应用程序的主跟踪日志。以下文件已过时，在 SQL Server 2008 中不再创建：ReportServerWebApp_<时间戳>.log、ReportServer_<时间戳>.log 和 ReportServerService_main_<时间戳>.log。

Reporting Services 配置工具

Reporting Services 配置工具不再支持“升级数据库”或“授予权限”等功能，这些功能允许通过独立的操作来进行升级或授予权限，或生成用于执行这些任务的脚本模板。在此版本中，升级和数据库权限都作为内部操作来处理。

SQL Server Management Studio

在 Management Studio 中，已将 Home 文件夹从该版本中删除。您不能查看、管理、分发或保护 Management Studio 中的报表服务器内容。

报表管理器

在报表管理器中，已从“站点设置”中删除以下链接：配置项级角色定义、配置系统级角色定义、管理作业。报表管理器不再支持创建、修改或删除角色定义的功能。您必须使用 Management Studio 管理属于特定角色的任务。同样，作业管理已从报表管理器移动到 Management Studio。

电子邮件订阅

报表服务器或远程 SMTP 服务器升级到 Windows Vista 或 Windows Server 2008 时，对于“发件人”、“收件人”、“抄送”、“密件抄送”以及“答复”字段中的电子邮件别名，无法进行电子邮件订阅。

发生此问题的原因在于，Windows Server 2003 包含一个可将别名解析为其完整的电子邮件地址的功能。Reporting Services 依赖该功能允许使用电子邮件别名而不是完整的电子邮件地址。但是，为帮助筛选出错误的电子邮件地址，Windows Vista 和 Windows Server 2008 不包含此功能。若要解决此问题，您必须在配置中配置 DefaultHostName 属性。有关解决此问题的信息，请参阅 Microsoft 知识库文章 945601：“SQL Server 2005 Reporting Services e-mail subscriptions do not work in Windows Vista and in Windows Server 2008 if you use aliases as e-mail addresses”（将别名用作电子邮件地址时 SQL Server 2005 Reporting Services 电子邮件订阅在 Windows Vista 和 Windows Server 2008 中不起作用）。

用于 SharePoint 技术的 SQL Server 2008 Reporting Services 外接程序

在 SharePoint 集成模式下运行 SQL Server 2008 报表服务器实例时，用于 SharePoint 技术的 SQL Server 2008 Reporting Services 外接程序提供了报表呈现、处理和管理功能以及数据驱动订阅。此外接程序下载文件包括报表查看器 Web 部件、Web 应用程序页，同时支持使用 Windows SharePoint Services (WSS) 或 Microsoft Office SharePoint Services (MOSS)。

用于 SharePoint 技术的 SQL Server 2008 Reporting Services 外接程序需要 SQL Server 2008 报表服务器实例，因为早期版本的 SQL Server 不支持此外接程序。如果您使用 SQL Server 2008 之前版本的报表服务器，然后安装或升级到用于 SharePoint 技术的 SQL Server 2008 Reporting Services 外接程序，则该报表服务器将无法按预期方式正常工作。例如，您将无法使用“授予数据库访问权限”页配置数据库访问，也无法使用 SharePoint 产品或技术呈现报表。若要解决此问题，则必须将报表服务器实例升级到 SQL Server 2008，否则必须卸载用于 SharePoint 技术的 SQL Server 2008 Reporting Services 外接程序，然后重新安装用于 SharePoint 技术的 SQL Server 2005 Reporting Services 外接程序。

有关用于 SharePoint 技术的 SQL Server 2008 Reporting Services 外接程序的详细信息，请参阅 Microsoft SQL Server 2008 Reporting Services Add-in Readme（Microsoft SQL Server 2008 Reporting Services 外接程序自述文件）。

基本身份验证

在 SQL Server 2008 Reporting Services 中，基本身份验证仅支持 NETWORK 和 NETWORK_CLEARTEXT 登录类型，而不支持 Interactive 和 BATCH 登录类型。

报表生成器重大更改

本节介绍对报表生成器的重大更改。

报表生成器只在完全信任模式下运行

在以本机模式运行的 Reporting Services 早期版本中，SQL Server 2005 报表生成器可使用以下 URL 来启动：

  • 完全信任 例如，http://<服务器名>/reportserver/reportbuilder/reportbuilder.application

  • 部分信任 例如， http://<服务器名>/reportserver/reportbuilder/reportbuilderlocalintranet.application

对于这两个 URL，<服务器名> 是指定报表服务器的计算机的名称。对于这两个 URL，reportserver 是报表服务器实例的名称。

在此版本中，您必须使用完全信任 URL 来运行报表生成器。当首次使用完全信任 URL 时，系统可能会提示您为应用程序授予更高级别的权限。

注意：
如果未运行报表生成器，或者如果遇到错误，请与系统管理员联系。您可能不具有授予对此应用程序的更高级别信任程度所需的权限。

首次授予这些权限后，不必再次设置这些权限。

在此版本中，如果使用部分信任 URL，则当打开或保存报表或者切换报表服务器时，会出现下列错误消息：

“失败。处理您的请求时出错。保存您的报表，然后重新启动应用程序。”

报表处理重大更改

此版本通过提供按需报表处理，从根本上更改了报表处理体系结构。按需报表处理极大地减少了报表服务器上的内存使用。

RDL 升级重大更改

升级现有报表时，将不支持下列 RDL 元素：

  • RDL 中的对象标识符不能超过 256 个字符

    RDL 中对象的标识符（例如，textboxID）先前不受长度限制。在此版本中，对象标识符的长度最多为 256 个字符。标识符仍然必须符合 CLS。

只为最后一个请求保存交互信息

在 Reporting Services 的早期版本中，快照保存了所有可能的交互选择组合，例如钻取信息和切换选择。您可以查看报表的第五页，但通过跟踪切换的正确 ID，可以通过编程方式切换第一页的项目。

在 SQL Server 2008 中，仅为最后一个呈现请求生成和保存交互信息。您不能先查看某一页，然后以编程方式切换到另一页中的项。只能切换当前报表页上的钻取项目。

报表对象模型命名空间更改

在此版本中，报表对象模型命名空间已发生更改。此命名空间提供从自定义代码到类似 Fields、Parameters 和 ReportItems 的全局集合的只读访问。如果现有自定义代码显式使用对早期命名空间的完全限定引用，则此更改是一项重大更改。

建议不要使用完全限定引用来从代码访问内置集合。通过非显式指定命名空间，自定义代码引用可解析为当前安装的 Reporting Services 版本的报表对象模型版本。

例如，在 SQL Server 2005 Reporting Services 中，以下两个示例将对参数 Microsoft.ReportingServices.ReportProcessing.ReportObjectModel.Parameter 的完全限定引用与对参数 Parameter 的默认引用的使用进行比较，以便将报表参数传递给返回报表参数标签的自定义函数。

不建议使用下面的示例。该示例显示了报表参数的完全限定引用。建议使用第二个示例，它可显示针对某报表参数的默认命名空间引用。

DO NOT USE FULLY QUALIFIED NAMESPACE REFERENCES FOR RUN-TIME COLLECTIONS

Public Function ShowParams(ByVal reportparameter As _

Microsoft.ReportingServices.ReportProcessing.ReportObjectModel.Parameter) _

As String

Return reportparameter.Label

End Function

下面的示例中显示了推荐的访问运行时集合的方法：

Public Function ShowParams(ByVal reportparameter As Parameter) _

As String

Return reportparameter.Label

End Function

报表呈现重大更改

报表呈现体系结构在此版本中发生了根本性的更改，可以为在不同呈现器中的分页和布局提供更一致的呈现效果。

新呈现对象模型和一致分页

对于 SQL Server 2008，呈现对象模型 (ROM) 已更改。不再支持早期版本的呈现对象模型。不支持从多线程呈现扩展插件中访问呈现对象模型（以及从多个线程切换上下文）。

新的 ROM 使呈现页的规则更加一致。有关详细信息，请参阅了解 Reporting Services 中的分页方式。

重新设计的 CSV 数据呈现器

在 Reporting Services 的早期版本中，当将报表导出为 CSV 文件格式时，数据格式保留为报表页上显示的数据格式。对于矩阵数据区域，由此产生的数据格式不便于导入到其他应用程序以继续使用数据。

在此版本中，将报表导出为 CSV 文件时，可以在两种支持的格式之间进行选择：“默认”模式和“兼容”模式。默认模式针对 Excel 进行了优化。兼容模式针对第三方应用程序进行了优化。有关详细信息，请参阅导出到 CSV 文件。

早期格式的 CSV 文件已不再使用。但是，对于不使用矩阵数据区域的报表，可以使用兼容模式获取最接近于早期 CSV 文件格式的文件格式。

在页眉和页脚中与条件可见性聚合

在 Reporting Services 的早期版本中，不同呈现器使用不同的规则来确定应将哪些带有条件可见性的项包含在报表页中。例如，不对打印报表中的隐藏项执行聚合计算，但是对使用浏览器或在 Excel 中查看的报表中的隐藏项执行聚合计算。

在此版本中，所有呈现器均使用相同的规则集来确定应将哪些项包含在报表页中。

Excel 中不支持公式

在 Reporting Services 的早期版本中，对 RDL 格式的表达式转换为 Microsoft Excel 公式的支持是有限的。在此版本中，当将报表导出到 Excel 时，RDL 表达式不会转换为 Excel 公式。

重叠项

在 Reporting Services 的早期版本中，如果报表在报表设计图面上有重叠项，则发布报表时会生成一条警告（“并非所有呈现器都支持重叠的报表项。”），但是报表项仍然保留在设计图面中的原始位置。在 SQL Server 2008 中，当查看报表或将报表导出到不支持重叠项的呈现器中时，报表项将移动到正确的重叠边界。有关详细信息，请参阅了解呈现行为。

请参阅

概念

SQL Server Reporting Services 中的行为更改

其他资源

升级 (Reporting Services)
Reporting Services 的向后兼容性


SQL Server Reporting Services 中的行为更改

SQL Server Reporting Services 中的行为更改 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > Reporting Services 的向后兼容性 >

本主题介绍 Reporting Services 中的行为更改。行为更改会影响 SQL Server 2008 中的功能与早期版本的 SQL Server 相比的工作或交互方式。

报表服务器配置和管理工具

报表创作

报表处理

报表呈现

报表服务器配置和管理工具的行为更改

Reporting Services 包含可用于配置服务器以及管理内容与操作的若干工具。在此版本中，每个工具都针对一个特定用途：配置、管理以及内容管理。为加强工具内部的一致性并删除重叠的功能，这些工具中新增并删除了某些功能和任务。如果您习惯于使用某个工具执行某项给定任务，那么现在可能需要使用不同的工具来完成同一项任务。

功能 | 说明
Reporting Services 配置 | 删除了颜色代码状态图标。新的 URL 配置页取代了用于创建虚拟目录的页。修订了用于创建和配置报表服务器数据库的工作流。现在可以使用向导创建或更新数据库连接。
SQL Server Management Studio | Management Studio 只支持服务器管理任务。您可以连接和配置以本机模式或 SharePoint 集成模式运行的报表服务器。
报表管理器 | 报表管理器用于查看和管理报表服务器内容。此版本引入了管理报表模型的功能。现在可以设置模型项安全性并将点击链接型报表与模型中的实体相关联。 在报表管理器中查看报表时，由于按需报表处理功能所带来的变化，工具栏会显示一个带问号的页数估计值，而不是报表的实际页数。您仍可以单击“最后一页”按钮并导航到报表的最后。

工具支持的任务

任务 | 报表服务器配置 | Management Studio | 报表管理器 | 命令行实用工具
保留 URL | X |  |  | X
设置服务帐户和密码 | X |  |  | X
创建报表服务器数据库或更改连接信息 | X |  |  | X
配置报表服务器扩展 | X |  |  | X
备份、还原、更改密钥或删除加密的数据 | X |  |  | X
配置无人参与的执行帐户 | X |  |  | X
配置报表服务器电子邮件 | X |  |  |
启用“我的报表” |  | X |  |
启用报表执行日志记录 |  | X |  |
启用客户端打印 |  | X |  |
为报表历史记录设置服务器默认值 |  | X |  |
创建或修改角色定义 |  | X |  |
查看正在运行的报表或模型进程的状态并在用时过长时将其停止 |  | X |  |
通过在项和系统级别创建角色分配为报表服务器项和操作授予权限 |  |  | X |
定义和管理报表服务器文件夹层次结构 |  |  | X |
查看报表、报表模型、共享数据源、资源和文件夹 |  |  | X |
上载报表定义 (.rdl)、报表模型 (.smdl) 和资源文件 |  |  | X |
创建和管理共享计划 |  | X | X |
创建和管理链接报表 |  |  | X |
创建和管理报表历史记录 |  |  | X |
创建和管理共享数据源以及单个报表中定义的任何数据源属性 |  |  | X |
制定报表的数据处理计划或将报表配置为作为报表执行快照运行 |  |  | X |
订阅报表传递以及创建和管理数据驱动订阅 |  |  | X |
创建数据驱动订阅 |  |  | X |
使用报表生成器创建、修改和保存报表 |  |  | X |
生成模型，将点击链接型报表与模型中的实体相关联，以及设置模型项安全性 |  |  | X |

报表创作

在早期版本的 Reporting Services 中，四个数据区域（表、矩阵、列表和图表）分属不同的报表项并具有自己的布局行为和属性。在此版本的 Reporting Services 中，表、矩阵和列表数据区域已被一种新的称为 Tablix 数据区域的灵活网格布局所取代，后者使用预定义模板来创建先前的数据区域。Tablix 数据区域允许您将表和矩阵的多个方面组合到灵活的报表布局中。图表数据区域仍作为单独的报表项继续保留，但其中添加了新的图表类型，例如极坐标图、雷达图和漏斗图。有关新图表类型的详细信息，请参阅使用图表数据区域。有关 Tablix 数据区域的详细信息，请参阅使用 Tablix 数据区域。

在表体或矩形容器中保留空格

默认情况下不再删除额外的空格。如果在报表设计图面上查看报表时表体上有额外的空格，则呈现报表时将保留页面上最后一个报表项之后的尾随空格。这可能会导致现有报表具有更多页。若要删除空格，可请将报表属性 ConsumeContainerWhitespace 设为 true。

有关详细信息，请参阅报表制作中的新增功能。

报表处理

SQL Server 2008 中对报表处理进行了重新设计。现在，当报表用户以交互方式阅读报表时将逐页处理和呈现报表。每页上的数据量会影响每页的呈现时间。总页数在呈现报表时确定。对于某些呈现器，在呈现报表中的所有页之前会显示估计页数。

图像

呈现报表时，在初始会话期间不再检索图像，而是在按需处理过程中第一次访问图像时检索图像。

对于历史记录和执行快照，将在创建快照时检索图像。

执行日志：TimeDataRetrieval、TimeProcessing、TimeRendering

TimeDataRetrieval、TimeProcessing 和 TimeRendering 报表日志条目是在向报表处理器发出初始请求时记录的。

导出时的错误检测

在早期版本的 Reporting Services 中，在完成整个报表的处理之前无法查看任何页。此时将先检测 Visibility.Hidden RDL 属性的表达式错误，检查无误后才能导出报表。如果可以查看报表的第一页，则可以导出整个报表而不会出现错误。

在此版本中，报表是逐页处理的。如果 Visibility.Hidden RDL 属性的某个表达式中存在错误，则在呈现存在错误的页以进行导出之前可能不会检测到错误。在这种情况下，整个报表导出将失败。能够成功查看报表中的若干页并不保证可以导出整个报表。您必须尝试导出报表并等待其成功完成，然后才能知道是否成功导出了报表而未发生任何错误。

分组、排序和筛选操作的表达式计算的行为方式与先前的 Reporting Services 版本相同。在呈现报表的第一页之前，报表处理组件将检测这些表达式中的错误，并将检测到的错误报告为严重错误。

报表呈现

重新设计的报表呈现功能在呈现现有报表时引入了以下行为更改。

分页符

在早期版本的 Reporting Services 中，软分页符呈现器按以下方式处理容器（矩形或表体）中的报表项：将最上部和最下部报表项的分页符应用于容器以尽可能减少额外的空白页。在新的呈现对象模型中，为报表项设置的分页符（称为逻辑分页符）始终导致呈现一个新页，而不会尝试消除额外的页。

有关详细信息，请参阅了解 Reporting Services 中的分页方式。

RepeatWith 项

在早期版本的 Reporting Services 中，当 RepeatWith 属性设为 true 时，软分页符呈现器会在页中包含报表项。由于软分页符呈现器的页面大小具有灵活性，因而在计算页面大小时不会计入这些报表项，当设置 InteractiveHeight 以控制页上的数据量时也不会计入这些报表项。在 SQL Server 2008 中，这些项将计入总的页面大小中。因此，页包含的数据可能要少一些，但为 InteractiveHeight 设置值对于页面大小会有更大影响。

有关详细信息，请参阅了解呈现行为。

Excel 中的嵌套子报表和数据区域

在早期版本的 Reporting Services 中，将报表导出到 Microsoft Office Excel 中时不支持表和矩阵单元中的嵌套数据区域和子报表。SQL Server 2008 消除了这一限制。您可以设计在数据区域中使用嵌套数据区域和子报表的报表，将该报表导出到 Excel 呈现器中，并查看嵌套的报表项。

有关详细信息，请参阅导出到 Microsoft Excel。

请参阅

概念

向后兼容性

其他资源

新增功能 (Reporting Services)
升级 (Reporting Services)
Reporting Services 的向后兼容性


Integration Services 的向后兼容性

Integration Services 的向后兼容性
升级到 SQL Server 2008 > 向后兼容性 >

本部分介绍 SQL Server Integration Services 的不同版本之间的更改。它包括不再可用或计划在将来的版本中删除的功能。本部分还介绍对产品所做的更改，已知这些更改会使包含 Integration Services 功能的现有应用程序无法继续工作，或会使其行为发生变化。

本节内容

  • SQL Server 2008 中不推荐使用的 Integration Services 功能

  • SQL Server 2008 中已停止使用的 Integration Services 功能

  • SQL Server 2008 中 Integration Services 功能的重大更改

  • SQL Server 2008 中 Integration Services 功能的行为更改

  • 支持 SQL Server 2008 中的 Data Transformation Services (DTS)


SQL Server 2008 中不推荐使用的 Integration Services 功能

SQL Server 2008 中不推荐使用的 Integration Services 功能 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > Integration Services 的向后兼容性 >

本主题介绍 SQL Server 2008 中仍然可用但不推荐使用的 Integration Services 功能。按照计划，SQL Server 未来版本将不再具有这些功能。在新的应用程序中不应使用这些不推荐使用的功能。

Data Transformation Services (DTS)

不推荐使用 Data Transformation Services (DTS)。考虑到 SQL Server 未来版本的功能，您应制定删除对 DTS 的依赖关系的计划。基于我们目前为以下 SQL Server 版本提供支持的承诺，SQL Server 2000、SQL Server 2005 和 SQL Server 2008 将继续支持 DTS 本身。但是，在下一版本中可能会取消对迁移或运行 DTS 包功能的支持。

不推荐使用的 DTS 功能包括 DTS 运行时、DTS API、用于将 DTS 迁移到下一版 Integration Services 的包迁移向导、SQL Server Management Studio 对 DTS 包维护的支持和“执行 DTS 2000 包”任务。

有关如何将 DTS 包迁移为 Integration Services 包格式的信息，请参阅迁移 Data Transformation Services 包。

ActiveX 脚本任务

在 SQL Server 2008 中提供 ActiveX 脚本任务的目的仅仅是为了实现与 DTS 的向后兼容，在下一版本的 SQL Server 中将删除 ActiveX 脚本任务。不要在新包的开发中使用此功能。应尽快修改当前使用此功能的包。可以使用 Integration Services 中提供的新控制流容器和更灵活的优先约束重新创建 ActiveX 脚本的功能。或者，您也可以使用 Integration Services 脚本任务重新编写这些脚本。

有关如何迁移脚本的信息，请参阅迁移脚本。

请参阅

概念

支持 SQL Server 2008 中的 Data Transformation Services (DTS)


SQL Server 2008 中已停止使用的 Integration Services 功能

SQL Server 2008 中已停止使用的 Integration Services 功能 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > Integration Services 的向后兼容性 >

此主题介绍 SQL Server 2008 中不再可用的 Integration Services 功能。

Microsoft Visual Studio for Applications (VSA)

在 SQL Server 2008 中，脚本任务和脚本转换的脚本环境已由 Visual Studio for Applications (VSA) 替换为 Visual Studio Tools for Applications (VSTA)。虽然这一变更不需要重新编写脚本，但是需要在将现有 Integration Services 包迁移至 SQL Server 2008 时升级包含 VSA 脚本的脚本任务和脚本转换。

在 SQL Server 2008 中，包含在脚本任务或脚本转换中的 VSA 脚本将在 Integration Services 运行它们之间转换为 VSTA。

请参阅

概念

SQL Server 2008 中不推荐使用的 Integration Services 功能


SQL Server 2008 中 Integration Services 功能的重大更改

SQL Server 2008 中 Integration Services 功能的重大更改
升级到 SQL Server 2008 > 向后兼容性 > Integration Services 的向后兼容性 >

本主题介绍 Integration Services 中的重大更改。这些更改可能导致基于 SQL Server 的早期版本的应用程序、脚本或功能无法继续使用。在进行升级时可能会遇到这些问题。有关详细信息，请参阅使用升级顾问来准备升级。

重大更改

下表描述了 SQL Server 2008 附带的 Integration Services 版本与更早版本附带的 Integration Services 版本之间的重大更改。

功能 | 说明
连接字符串中的访问接口名称 | 在 SQL Server 2008 中，SQL Server Native Client 访问接口和 OLE DB Provider for Analysis Services 的名称已经更改，并且其连接字符串使用不同值。若要自动更新使用这些访问接口名称的连接字符串，请使用 SSIS 包升级向导来升级 SQL Server 2005 包。还可以在 BI Development Studio 中自动或手动更新这些连接字符串。
第三方组件和自定义组件 | 在 SQL Server 2008 中，Integration Services 已经更改其应用程序编程接口 (API)。若要与这些新 API 兼容，则必须重新编译所有第三方组件和自定义组件。


SQL Server 2008 中 Integration Services 功能的行为更改

SQL Server 2008 中 Integration Services 功能的行为更改
升级到 SQL Server 2008 > 向后兼容性 > Integration Services 的向后兼容性 >

本主题介绍 Integration Services 的行为更改。与早期版本的 SQL Server 相比，SQL Server 2008 中的功能的工作或交互方式会受到行为更改的影响。

行为更改

下表描述 SQL Server 2008 中包括的 Integration Services 版本与更早版本中包括的 Integration Services 版本之间的行为更改。

问题 | SQL Server 2005 Integration Services 行为 | SQL Server 2008 Integration Services 行为
从执行 SQL 任务在包变量中返回 NULL 值 | 返回该值为 11/30/1999。 | 返回该值为 12/30/1899。
在脚本任务和脚本组件中开发脚本 | 使用 Visual Studio for Applications (VSA) 作为脚本环境。 | 使用 Visual Studio Tools for Applications (VSTA) 作为脚本环境。 若要迁移包含脚本的包，请使用 SSIS 包升级向导。
使用查找转换 | 无法持久化缓存的引用表，或者无法在多个查找转换中共享此表。 | 可以持久化缓存的引用表，也可以在多个查找转换中共享此表。 若要使用查找转换的新功能，请考虑修订您的包。


支持 SQL Server 2008 中的 Data Transformation Services (DTS)

支持 SQL Server 2008 中的 Data Transformation Services (DTS) |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > Integration Services 的向后兼容性 >

SQL Server 2008 为使用 DTS 工具和对象模型创建的 SQL Server 2000 Data Transformation Services (DTS) 包提供可选的 32 位管理支持、运行时支持和设计时支持。

重要提示：
需要手动安装在安装期间未提供的附加、可选组件，才能使用本主题介绍的功能（包括对 DTS 包的运行时支持）。有关详细信息，请参阅本主题后面的“安装对 DTS 包的运行时支持”和“安装对 DTS 包的设计时支持”等部分。

SQL Server 2008 中的 DTS 支持包括以下功能，本主题后面的部分对此进行了更详细的介绍：

  • DTS 运行库、它所公开的对象模型以及 dtsrun.exe 命令提示实用工具。

  • 执行 DTS 2000 包任务，用于在 Integration Services 包内执行 DTS 包。

  • ActiveX 脚本任务，仅用于向后兼容。

  • DTS 包迁移向导，用于将 DTS 包迁移为 Integration Services 包格式。

  • DTS 包的升级顾问规则，用于识别在迁移包时可能遇到的潜在问题。

SQL Server 2008 不支持以下 DTS 功能：

  • 不为 DTS 包提供 64 位设计时或运行时支持。在 64 位计算机上，DTS 包和运行 DTS 包的 Integration Services 包只能以 32 位模式运行。若要以 32 位模式运行 DTS 包，您必须安装和使用 dtexec 实用工具 (dtexec.exe) 的 32 位版本。若要安装 dtexec 实用工具的 32 位版本，请在安装期间选择客户端工具或 Business Intelligence Development Studio。

  • 在基于 Itanium 的操作系统上，也不为 DTS 包提供 32 位设计时或运行时支持。因此，不能在基于 Itanium 的操作系统上创建、查看、修改或运行 DTS 包。

本主题的内容

以下链接可使您转至本主题中的各部分内容：

一般信息
  • DTS 和 SSIS 之间的常规兼容性

  • 管理 DTS 包

设计和运行 DTS 包
  • 安装 DTS 包的运行时支持组件

  • 从命令提示符运行 DTS 包

  • 从 SQL Server 代理作业运行 DTS 包

  • 从 Integration Services 包运行 DTS 包

  • 安装 DTS 包的设计时支持组件

迁移 DTS 包
  • 迁移 DTS 包

  • 将 dtsrun 命令迁移到 dtexec 命令

有限支持
  • 支持 ODBC 数据源

  • 支持存储库包

  • 支持 SQL Server Express 中的 Integration Services

DTS 和 Integration Services 之间的常规兼容性

DTS 与 Integration Services 是完全不同的产品。Integration Services 不是 DTS 的版本升级。因此，DTS 和 Integration Services 之间不存在软件冲突。您可以执行以下过程：

  • 在相同服务器上同时安装 DTS 和 Integration Services。

  • 在同一台服务器上同时运行 DTS 和 Integration Services 包。即使服务器上没有 SQL Server 2000 工具，也可以使用随 Integration Services 一起安装的 DTS 运行时的更新版本运行 DTS 包。

  • 将 DTS 包保存在 SQL Server 2000 实例或运行 SQL Server 2005 或更高版本的实例的 msdb 数据库中。但是，只能将 SQL Server 2008 Integration Services 包保存在运行 SQL Server 2008 的实例上。

  • 即使计算机上没有 SQL Server 2000 工具，也可以选择下载 DTS 设计器来修改 DTS 包。但是，不能在 Business Intelligence Development Studio 中直接打开或修改 DTS 包。

    注意：
    有关如何下载 DTS 设计器的更新版本的信息，请参阅安装 SQL Server 2000 DTS 包的设计时支持组件一节。

将现有 SQL Server 实例升级到 SQL Server 2008 时，DTS 在 msdb 数据库中使用的系统表（如 sysdtspackages）保持不变。DTS 包不会自动迁移。有关如何迁移包的信息，请参阅迁移 DTS 包部分。

用于“返回首页”链接的箭头图标 返回页首

管理 DTS 包

按照“安装对 DTS 包的运行时支持”一节中所述安装对 DTS 的可选运行时支持后，您就可以通过 SQL Server Management Studio 管理 DTS 包了。可以将这些 DTS 包存储在 SQL Server 2000 实例中，也可以将其导入并存储在运行 SQL Server 2005 或更高版本的实例中。

重要提示：
有关如何保护 DTS 包的重要信息，请参阅保护存储在 SQL Server 中的 DTS 包。

若要在 Management Studio 中查看 DTS 包，请首先连接到 SQL Server 实例。（不要连接到 Integration Services 实例。）然后，在对象浏览器的 Management\Legacy\Data Transformation Services 节点下，您将执行以下任务：

  • 如果在 Management Studio 中选择了 Data Transformation Services 节点，则可以查看并打开包，将它们从结构化存储文件导入 SQL Server，或者启动 DTS 包迁移向导。

  • 如果在 Management Studio 中选择了单个 DTS 包，则可打开该包进行修改、迁移，也可将其导出到结构化存储文件或将其删除。

    注意：
    若要打开或修改 DTS 包，必须单独下载 DTS 设计器组件。请参阅安装 SQL Server 2000 DTS 包的设计时支持组件一节。DTS 包无法在 BI Development Studio 中直接打开或修改。

用于“返回首页”链接的箭头图标 返回页首

安装 DTS 包的运行时支持组件

尽管可以在同一计算机上运行 DTS 包和 Integration Services 包，但 SQL Server 2008 不会安装对 DTS 包的运行时支持。您必须先安装此运行时支持，然后才能运行和管理 DTS 包。有关如何安装对 DTS 的运行时支持的信息，请参阅如何安装 Data Transformation Services 包的支持组件。

提供对 DTS 包的运行时支持的向后兼容文件还包括对 SQL Server 2000 Analysis Services 处理任务及其依赖项（即决策支持对象 [DSO]）的运行时支持。但是向后兼容文件不包括用于修改包含 SQL Server 2000 Analysis Services 处理任务的 DTS 包的设计时支持组件。仅当在同一台计算机上安装有 SQL Server 2000 Analysis Services 时，才可以修改包含此任务的包。

提供对 DTS 包的运行时支持的向后兼容文件不包括对 SQL Server 2000 数据挖掘预测查询任务的支持。

用于“返回首页”链接的箭头图标 返回页首

从命令提示符运行 DTS 包

可以从命令提示符运行 DTS 包。安装 DTS 运行时支持组件时，Integration Services 会安装 dtsrun.exe 实用工具。

用于“返回首页”链接的箭头图标 返回页首

从 SQL Server 代理作业运行 DTS 包

若要从 SQL Server 代理作业运行 DTS 包，必须将作业步骤设置为“操作系统(CmdExec)”，并使用 dtsrun 实用工具 (dtsrun.exe) 运行该包。不能将作业步骤设置为“SQL Server Integration Services 包”。有关详细信息，请参阅如何运行包。

用于“返回首页”链接的箭头图标 返回页首

从 Integration Services 包运行 DTS 包

您还可以将 DTS 包作为 Integration Services 包的一部分来运行。Integration Services 提供了执行 DTS 2000 包任务，用于从 Integration Services 包中运行 DTS 包。有关详细信息，请参阅执行 DTS 2000 包任务。

用于“返回首页”链接的箭头图标 返回页首

安装 DTS 包的设计时支持组件

DTS 包无法在 Business Intelligence Development Studio 中直接打开或修改。此外，SQL Server 2008 和 SQL Server 2005 都没有安装用于修改 DTS 包的 DTS 包设计器。但是，可以下载和安装 DTS 包设计器，并使用该设计器修改 DTS 包。有关如何安装对 DTS 包的设计时支持的信息，请参阅如何安装 Data Transformation Services 包的支持组件。安装此下载组件之后，可以从 Management Studio 或 Business Intelligence Development Studio 的执行 DTS 2000 包任务编辑器中查看和修改 DTS 包。

有关如何管理影响 DTS 设计环境的某些 DTS 应用程序属性的信息，请参阅设置 DTS 应用程序属性。

用于“返回首页”链接的箭头图标 返回页首

迁移 DTS 包

SQL Server 提供了用于将 DTS 包迁移到 Integration Services 包格式的 DTS 包迁移向导。如果选择安装 Integration Services，安装程序还将安装 DTS 包迁移向导。还可以选择使用 DTS 包迁移向导将 DTS 包升级为 Integration Services 格式。在迁移过程中，该向导将复制 DTS 包，然后以 Integration Services 格式重新创建这些包。源包将保持不变且不会被修改。

注意：
SQL Server Standard、SQL Server Enterprise 和 SQL Server Developer 中提供了 DTS 包迁移向导。

许多包可以完全迁移到 Integration Services，特别是使用任务和连接的包以及使用在 Integration Services 中具有等效项的其他对象的包。通过封装无法在执行 DTS 2000 包任务内迁移的某些任务或功能，其他包也可以成功迁移。有关详细信息，请参阅迁移 Data Transformation Services 包。

在运行 DTS 包迁移向导之前，您可能希望安装并运行升级顾问，以分析现有包是否存在迁移问题。有关详细信息，请参阅使用升级顾问来准备升级。

注意：
对于保存在 SQL Server 7.0 实例的 msdb 数据库中的 DTS 包，升级顾问无法对其进行分析，并且 DTS 包迁移向导无法对其进行迁移。但是，升级顾问可以分析作为结构化存储文件保存的 SQL Server 7.0 DTS 包，DTS 包迁移向导也可以迁移这些包。此外，对于保存在已升级为 SQL Server 2005 或更高版本的 SQL Server 7.0 实例的 msdb 数据库中的 SQL Server 7.0 DTS 包，升级顾问可以对其进行分析，DTS 包迁移向导也可以对其进行迁移。

用于“返回首页”链接的箭头图标 返回页首

迁移用于执行包的命令行

若要了解用于 SQL Server 2000 DTS dtsrun 实用工具 (dtsrun.exe) 的命令行选项如何映射到用于 Integration Services dtexec 实用工具 (dtexec.exe) 的命令行选项，请参阅 将 dtsrun 选项映射到 dtexec 选项。

用于“返回首页”链接的箭头图标 返回页首

支持 ODBC 数据源

若要将数据加载或保存到 ODBC 数据源，可以使用 ADO.NET 源或目标并选择用于 ODBC 的 .NET Framework 数据访问接口。还可以使用脚本组件创建在单个包内使用的即席 ODBC 源或目标。有关详细信息，请参阅 Creating an ODBC Destination with the Script Component。

用于“返回首页”链接的箭头图标 返回页首

对 Meta Data Services（存储库）包的支持

SQL Server 2000 Meta Data Services（通常称为存储库）是一个不推荐使用的组件。SQL Server 2005 及更高版本不安装也不使用存储库。

DTS 设计器和 dtsrun 实用工具继续支持保存到存储库中的 DTS 包。

Integration Services 仅在升级顾问和 DTS 包迁移向导中支持存储库，且仅限于本地计算机上安装了存储库可再发行文件的情况。（当计算机上安装了 SQL Server 2000 或 SQL Server 2000 工具时，通常会存在这些文件。）当存在存储库可再发行文件时，升级顾问可以扫描保存到存储库的 DTS 包，DTS 包迁移向导也可以迁移这些 DTS 包。当不存在存储库可再发行文件时，只能针对保存到 SQL Server 或结构化存储文件中的 DTS 包使用升级顾问和 DTS 包迁移向导。

Integration Services 执行 DTS 2000 包任务无法运行保存到存储库中的 DTS 包。但是，SQL Server 2000 DTS 运行时可以运行这样的包。因此，若要使 Integration Services 包运行一个存储在存储库中的 DTS 包，请按下列步骤操作：

  1. 确保运行 Integration Services 包的计算机上安装了存储库文件。若要安装存储库文件，请在本地计算机上安装 SQL Server 2000、SQL Server 2000 工具或存储库可再分发文件。

  2. 创建新的 DTS 包，用作存储在存储库中的 DTS 包的包装。在此 DTS 包装包中，使用执行包任务执行存储在存储库中的包。将此包装包保存到 SQL Server 中或保存为结构化存储文件。

  3. 使用 Integration Services 包中的执行 DTS 2000 包任务来运行新的 DTS 包装包。

用于“返回首页”链接的箭头图标 返回页首

SQL Server Express 中对 DTS 包的支持

SQL Server Express 不包含 Integration Services，也不支持 DTS 包。但是，可以通过下列方法之一在运行 SQL Server Express 的服务器上处理 DTS 包：

  • 若要在运行 SQL Server Express 的服务器上运行现有 DTS 包，该服务器上需要安装有 DTS 运行时。尽管 SQL Server Express 不包含 DTS 运行时，但您可以通过安装 SQL Server 2000 客户端工具或 DTS 可再分发文件在服务器上安装 DTS 运行时。

  • 若要在运行 SQL Server Express 的服务器上修改现有 DTS 包，可以使用 SQL Server 2000 工具。您还可以在运行 SQL Server Workgroup Edition、Standard Edition、Enterprise 或 Developer 中任一版本的服务器上的 SQL Server Management Studio 中远程修改包。SQL Server Express 不包括 SQL Server Management Studio。

  • 若要将现有 DTS 包迁移到 Integration Services，需要随 Integration Services 一起安装的 DTS 包迁移向导。SQL Server Express 不包含此向导。您可以使用 SQL Server Standard、Enterprise 或 Developer 中的任一版本运行该向导。

用于“返回首页”链接的箭头图标 返回页首

请参阅

概念

已知的 DTS 包迁移问题

其他资源

将 dtsrun 选项映射到 dtexec 选项
设置 DTS 应用程序属性
在 64 位计算机上使用 Integration Services 时的注意事项


复制的向后兼容性

复制的向后兼容性 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 >

向后兼容性部分中的主题说明 Microsoft SQL Server 复制各版本之间的行为更改。如果要升级或者在复制拓扑中有 SQL Server 的多个版本，则了解向后兼容性是十分重要的。

主题 | 说明
SQL Server 复制中不推荐使用的功能 | Microsoft SQL Server 2008 中为实现向后兼容而保留、但在 SQL Server 未来版本中将删除的复制功能。
SQL Server 复制中停止使用的功能 | 在早期版本中存在但在 SQL Server 2005 中已删除的复制功能。SQL Server 2008 中未删除任何功能。
SQL Server 复制中的行为更改 | SQL Server 2008 中已更改的复制功能。
SQL Server 复制中的重大更改 | 可能需要更改应用程序的复制功能更改。
在复制拓扑中使用 SQL Server 的多个版本 | 在复制拓扑中使用 SQL Server 多个版本时的注意事项。

请参阅

概念

升级复制数据库时的注意事项


SQL Server 复制中不推荐使用的功能

SQL Server 复制中不推荐使用的功能 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > 复制的向后兼容性 >

本主题介绍 SQL Server 2008 中仍然可用但不推荐使用的复制功能。按照计划，SQL Server 未来版本将不再具有这些功能。在新的应用程序中不应使用这些不推荐使用的功能。

影响所有复制类型的不推荐使用的功能

在 SQL Server 2005 或 SQL Server 2008 中不推荐使用以下适用于所有复制类型的功能。

功能 说明

可附加订阅

此功能可在部署大量请求订阅（这在合并复制中很常见）时使用。建议您使用以下方法，而不是使用可附加订阅：

  • 对于使用参数化筛选器分区的合并发布，建议您使用分区快照，这些分区快照可简化对大量订阅的初始化。有关详细信息，请参阅带有参数化筛选器的合并发布的快照。

  • 对于未分区的发布，可以使用备份来初始化订阅。有关详细信息，请参阅初始化合并订阅（不使用快照）和初始化事务订阅（不使用快照）。

在上述两种情况下，您可以通过编写脚本来自动创建大量的订阅：创建一个订阅；将其编写为脚本；对每个订阅服务器修改该脚本；然后在每个订阅服务器上应用该脚本以创建订阅。有关详细信息，请参阅编写复制脚本。

订阅服务器注册

不推荐使用 sp_addsubscriber 存储过程。不再要求在发布服务器上显式注册订阅服务器。

SQL 分布式管理对象 (SQL-DMO)

现有代码将继续起作用，但 SQL-DMO 不支持 SQL Server 2005 和 SQL Server 2008 中的新功能。请改用复制管理对象 (RMO)。有关详细信息，请参阅Replication Management Objects Concepts。

使用 sp_repladdcolumn 和 sp_repldropcolumn 的架构更改

不推荐使用存储过程 sp_repladdcolumn 和 sp_repldropcolumn。请改用架构更改复制。有关详细信息，请参阅对发布数据库进行架构更改。

这些存储过程不能用于添加或删除具有 SQL Server 2005 和更高版本中所引入的数据类型（xml、varchar(max)、nvarchar(max)、varbinary(max)）的列，也不能用于添加或删除具有用户定义类型 (UDT)（datetime2、time、datetimeoffset、hierarchyid、geometry 和 geography 类型）的列。

校验和验证

不应使用校验和验证。请使用二进制校验和验证。也可以为所有 SQL Server 订阅服务器（包括对来自 Oracle 发布服务器的发布的订阅）使用行计数验证。有关详细信息，请参阅验证已复制的数据。

添加发布到 Active Directory

不推荐使用 sp_addpublication 或 sp_addmergepublication 的 @add_to_active_directory 参数向 Active Directory 添加发布。已不再允许通过在 Active Directory 中查找发布来订阅发布。

-UseInprocLoader 参数

不推荐使用分发代理和合并代理的这一参数，因为它与 XML 数据类型不兼容。如果不复制 XML 数据，则可以使用此参数。有关详细信息，请参阅复制分发代理和复制合并代理。

分发和合并代理中的 PublisherAddress、PublisherNetwork、DistributorNetwork 和 DistributorAddress 参数1

这些参数用于指定在连接到发布服务器或分发服务器时所使用的 IP 地址。由于复制子系统使用服务器名称来验证连接，因此建议您在客户端协议上使用别名将 IP 地址映射到服务器名称，并在代理中使用服务器名称。

1 不推荐在 SQL Server 2008 中使用。

不推荐使用的事务复制功能

SQL Server 2005 或 SQL Server 2008 中不推荐使用以下事务复制功能。

功能 | 说明
事务复制的订阅过期 | 不推荐使用 sp_addpublication 的 @retention 属性。如果未在最大分发保持期（sp_adddistributiondb 的 @max_distretention 属性）内同步订阅，则其仍将标记为不活动，且必须重新初始化。有关保持期的详细信息，请参阅订阅过期和停用。
对事务发布的“no sync”订阅 | 如果为 sp_addsubscription 或 sp_addpullsubscription 的 @sync_type 参数指定值 none，则订阅将为“no sync”订阅。如果要指定订阅数据库中已存在必要的架构和数据，则请为此参数指定值 replication support only。有关详细信息，请参阅初始化事务订阅（不使用快照）。
ODBC 订阅服务器 | 对于非 SQL Server 订阅服务器，请改用 OLE-DB。有关所支持的订阅服务器的信息，请参阅非 SQL Server 订阅服务器。
可转换订阅 | 此功能可通过存储过程接口使用，但此功能的支持已从用户界面中删除。使用此功能要求安装 SQL Server 2000 Data Transformation Services (DTS)。有关详细信息，请参阅 Integration Services 的向后兼容性。
适用于快照发布和事务发布的可更新订阅（包括立即更新和排队更新）1 | 建议您改用对等事务复制。有关详细信息，请参阅对等事务复制。
分发 ActiveX 控件 | 此控件使您可以在应用程序中嵌入分发代理。改用 RMO。有关详细信息，请参阅如何同步请求订阅（RMO 编程）和如何同步推送订阅（RMO 编程）。
复制分发服务器接口 | 在 SQL Server 2000 中，复制分发服务器接口提供在分发服务器上的分发数据库中存储复制事务的接口。可用此接口启用从非 SQL Server 数据库发布（需要增加自定义编程以跟踪发布服务器上的更改）。不推荐使用此功能支持，但现有代码在从 SQL Server 2000 升级的服务器上仍可以使用。有关详细信息，请参阅 SQL Server 2000 联机丛书中的“复制分发服务器接口引用”。 SQL Server 2005 和 SQL Server 2008 支持从 Oracle 数据库发布，无需自定义编程。有关详细信息，请参阅 Oracle 发布概述。
复制到 Oracle 8 订阅服务器和从 Oracle 8 发布服务器复制1 | 有关支持的 Oracle 版本的信息，请参阅 Oracle 发布概述和 Oracle 订阅服务器。

1 不推荐在 SQL Server 2008 中使用。

不推荐使用的合并复制功能

SQL Server 2005 或 SQL Server 2008 中不推荐使用以下合并复制功能。

功能 说明

可选同步伙伴

备用同步伙伴功能使您可以指定订阅服务器可与之同步的备用发布服务器。

在 SQL Server 2005 和 SQL Server 2008 中，建议将合并复制与数据库镜像一起使用，而不是与备用同步伙伴一起使用。有关详细信息，请参阅复制和数据库镜像。

对合并发布的“no sync”订阅1

如果为 sp_addmergesubscription 或 sp_addmergepullsubscription 的 @sync_type 参数指定值 none，则订阅将为“no sync”订阅。建议不要将此订阅类型用于合并复制。

合并 ActiveX 控件

此控件使您可以在应用程序中嵌入合并代理。改用 RMO。有关详细信息，请参阅如何同步请求订阅（RMO 编程）或如何同步推送订阅（RMO 编程）。

多列 UPDATE 选项

当合并复制执行更新时，它会更新一个 UPDATE 语句中所有更改的列，并将未更改的列重置为其原始值。另外，它还可以发出多条 UPDATE 语句，每个已更改的列一条。多列 UPDATE 语句的效率通常更高。

在 SQL Server 2005 之前的 SQL Server 版本中，建议为 @fast_multicol_updateproc 项目选项指定 False 值以处理多列更新（一条 UPDATE 语句）效率可能较低的情况：

  • 大部分更新涉及少量的列。

  • 未更改列的索引维护量很大，因为这些列在更新发生时被重置。

由于 SQL Server 中的性能提高，不再需要为这些情况设置此选项。

-ParallelUploadDownload 参数1

合并代理的这一参数用于同时上载和下载在合并复制会话中进行的更改。此参数提供性能提升，但由于必须通过网络传输的元数据量过大，因此有些得不偿失。

sp_addmergepublication 中的 @allow_partition_realignment 属性1

此参数用于控制在行移出订阅服务器的分区时必须发送到订阅服务器的删除操作。

-ExchangeType 参数1

此参数用于控制合并代理是经历上载阶段、下载阶段还是同时经历这两个阶段。此参数的默认值为 3，也就是既执行上载又执行下载。由于仅上载功能不复制架构更改或初始化过程，因此我们不建议您执行仅上载功能。可以通过针对项目使用 @subscriber_upload_options 来实现仅下载功能。有关详细信息，请参阅 sp_addmergearticle (Transact-SQL)。

sp_addmergearticle 中的 @delete_tracking 属性1

此属性用于在应当将删除操作向下发送到发布服务器或订阅服务器时停止跟踪删除操作。可以通过使用 BusinessLogicModule 中的 DeleteHandler 来实现此设置。有关详细信息，请参阅 在合并同步期间执行业务逻辑。

逻辑记录1

此功能用于在单个事务中发送一组相关行。在多数情况下，使用此功能会大幅增加复制性能开销。有关详细信息，请参阅通过逻辑记录对相关行的更改进行分组。

1 不推荐在 SQL Server 2008 中使用。

请参阅

概念

复制的向后兼容性


SQL Server 复制中停止使用的功能

本部分介绍已在 SQL Server 2005 中停止使用的复制功能。

影响所有复制类型的停止使用的功能

以下复制功能已在 SQL Server 中停止使用。

功能 | 说明
在“新建订阅向导”中创建推送订阅而不连接到订阅服务器 | 现在，在“新建订阅向导”中创建推送订阅需要在配置过程中指向订阅服务器的活动连接。有关使用此向导的详细信息，请参阅如何创建推送订阅 (SQL Server Management Studio)。
使用文件传输协议 (FTP) 初始化运行 SQL Server 7.0 版的订阅服务器 | 此功能对运行 SQL Server 2000 或更高版本的订阅服务器可用。有关详细信息，请参阅通过 FTP 传输快照。
在 Windows 同步管理器中创建订阅 | 无法再在同步管理器中创建订阅，但仍然可以同步订阅。有关详细信息，请参阅 Windows 同步管理器。
通过在 Active Directory 中定位发布，来对其订阅 | 不推荐使用 sp_addpublication 或 sp_addmergepublication 的 @add_to_active_directory 参数向 Active Directory 添加发布。已不再允许通过在 Active Directory 中查找发布来订阅发布。
快照 ActiveX 控件 | 利用该控件，可以将快照代理嵌入到应用程序中。请改用新的托管快照代理。有关详细信息，请参阅 SnapshotGenerationAgent 和如何创建初始快照（RMO 编程）。
远程代理激活 | SQL Server 2000 支持在另一台计算机上运行分发代理或合并代理，然后使用 DCOM 远程激活该代理。对于运行 SQL Server 2005 及更高版本的分发服务器，已停止使用此支持；对于运行更早 SQL Server 版本的分发服务器，不推荐使用此支持。有关详细信息，请参阅 SQL Server 2000 联机丛书中的“远程代理激活”。
Microsoft Access (Jet 4.0) 订阅服务器 | Jet 是 Access 使用的基础数据库，在 SQL Server 2000 中，复制支持对 Jet 数据库的订阅。未来版本将不支持这些订阅。 建议改用 SQL Server Express。Access 可以将 SQL Server 数据库用作后端，SQL Server 数据库不受此问题的影响。

已停止使用的事务复制功能

以下事务复制功能已停止使用。

功能 | 说明
排队更新订阅的消息队列选项 | 利用排队更新订阅，将订阅服务器中的更改写入队列；然后，队列读取器代理从该队列中读取更改并将其传递到发布服务器。在 SQL Server 2000 中，订阅可以使用 SQL Server 队列或消息队列对更改进行排队。队列的类型是用 sp_addpublication 的 @queue_type 参数指定的，允许的值为 sql 和 msmq（消息队列）。在 SQL Server 2005 中，只允许使用值 sql。在升级期间，将修改使用消息队列的现有发布从而可以使用 SQL Server 队列。如果某些应用程序依赖于使用消息队列的排队更新，将需要重写这些应用程序以适应 SQL Server 队列。有关排队更新订阅的详细信息，请参阅事务复制的可更新订阅。

已停止使用的合并复制功能

以下合并复制功能已停止使用。

功能 | 说明
从 SQL Server Express 发布 | SQL Server MSDE 可以用作合并发布的发布服务器。SQL Server Express 不能充当发布服务器。它可以订阅合并发布、事务发布和快照发布。具有更新订阅的合并复制和事务复制均允许将更改从订阅服务器传播回发布服务器。
IVBCustomResolver 接口 | 该接口允许使用 Visual Basic 编写基于 COM 的自定义冲突解决程序。在 SQL Server 2005 中，建议使用业务逻辑处理程序，而不使用基于 COM 的冲突解决程序。有关详细信息，请参阅在合并同步期间执行业务逻辑。 还可以使用 C++ 编写基于 COM 的冲突解决程序。有关详细信息，请参阅基于 COM 的自定义冲突解决程序。

请参阅

概念

复制的向后兼容性


SQL Server 复制中的重大更改

SQL Server 复制中的重大更改 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > 复制的向后兼容性 >

本主题介绍 SQL Server 复制中的重大更改。这些更改可能导致基于 SQL Server 的早期版本的应用程序、脚本或功能无法继续使用。在进行升级时可能会遇到这些问题。有关详细信息，请参阅使用升级顾问来准备升级。

SQL Server 2005 中所做的重大更改

本部分介绍 SQL Server 2005 在复制功能方面所做的重大更改。

影响所有复制类型的重大更改

以下重大更改适用于所有复制类型。

功能 说明

复制脚本所需的更改

与 SQL Server 2000 相比，复制代理的安全模式已发生更改。有关安全模式的详细信息，请参阅复制代理安全性模式。如果您是 SQL Server 2005 中的 sysadmin 固定服务器角色的成员，当运行用 SQL Server 2000 或 SQL Server 7.0 创建的复制脚本时，脚本可以正确执行。如果您是 dbo 固定数据库角色或其他角色的成员，则脚本会失败，必须升级。有关升级脚本的信息，请参阅如何升级复制脚本（复制 Transact-SQL 编程）。虽然不需要升级由 sysadmin 角色的成员执行的脚本，但为了利用安全性增强功能，建议对其进行升级。

复制代理的本地连接

升级到 SQL Server 2005 时，所有使用 SQL Server 身份验证的本地连接都改为使用 Windows 身份验证。本地连接是指代理与它所在的同一台计算机上运行的 SQL Server 实例之间建立的连接。例如，请求订阅的合并代理在订阅服务器上运行，因此它与订阅服务器建立的连接是本地连接。

在 SQL Server 的早期版本中，默认情况下代理是在 SQL Server 代理服务帐户的上下文中运行。升级后，在此帐户的上下文中建立本地连接。SQL Server 2005 可以细粒度控制复制代理运行并与数据库及其他资源建立 Windows 集成连接所用的每个帐户；可为每个代理指定不同的帐户。升级后，建议为每个代理指定不同的帐户。有关详细信息，请参阅升级复制数据库时的注意事项和复制代理安全性模式。

ActiveX 控件

所有 ActiveX 控件都标记为对脚本编写和初始化不安全。

SQL Server 2005 中没有快照代理 ActiveX 控件。请改用新的托管快照代理。有关详细信息，请参阅 SnapshotGenerationAgent 和如何创建初始快照（RMO 编程）。

distributor_admin 帐户的密码

不再支持发布服务器和远程分发服务器之间的可信连接，因为这些连接不要求密码（在 SQL Server 2000 Service Pack 3 之前的版本中，默认情况下使用可信连接）。如果使用远程分发服务器，在升级到 SQL Server 2005 之前，请将可信连接转换成不可信连接（此问题不影响使用本地分发服务器的发布服务器）。有关 distributor_admin 帐户的详细信息，请参阅保护分发服务器的安全。

确定所使用的连接类型

  • 在分发服务器上执行 sp_helpdistpublisher。如果受信任列中的值是 1，则必须更改为不可信连接。

更改为不可信连接

  1. 在分发服务器上执行 sp_changedistpublisher，为参数 @property 指定值 'trusted'，为参数 @value 指定值 'False'。

    注意：
    SQL Server 2000 联机丛书的某些版本没有将 'trusted' 列为 @property 的有效值。它对于所有 SQL Server 2000 版本都有效。

  2. 在发布服务器和分发服务器上都执行 sp_changedistributor_password，为参数 @password 指定一个强密码。

SQL Server Express 不包括 SQL Server 代理

如果升级到 SQL Server Express，则必须重新配置复制同步，因为 SQL Server Express 不包括 SQL Server 代理。

如果要使用请求订阅，则必须使用复制管理对象 (RMO)、Windows 同步管理器，或在命令行上运行复制代理，以此来同步这些订阅。有关详细信息，请参阅将数据复制到 SQL Server Express。

如果要继续使用 SQL Server 代理来运行复制代理作业，则必须使用推送订阅或升级到其他版本的 SQL Server（除 SQL Server Express 和 SQL Server Compact 3.5 之外的所有版本都包括 SQL Server 代理）。使用推送订阅的情况下，分发代理或合并代理在分发服务器上运行，因此 SQL Server 代理是可用的（SQL Server Express 不能是分发服务器）。

Microsoft Access (Jet 4.0) 订阅服务器

Jet 是 Access 使用的基础数据库，在 SQL Server 2000 中，复制支持对 Jet 数据库的订阅。未来版本将不支持这些订阅。

建议改用 SQL Server Express。Access 可以将 SQL Server 数据库用作后端，SQL Server 数据库不受此问题的影响。有关详细信息，请参阅将数据复制到 SQL Server Express。

事务复制的重大更改

以下重大更改适用于事务复制。

功能 说明

从备份中初始化事务订阅1

若要在 SQL Server 2008 中从备份初始化订阅，用户必须是 dbcreator 服务器角色的成员之一。在 SQL Server 2005 中，只需具有 db_owner 数据库角色的成员身份。

有关如何从备份初始化订阅的详细信息，请参阅初始化事务订阅（不使用快照）。

排队更新订阅的消息队列选项

利用排队更新订阅，将订阅服务器中的更改写入队列；然后，队列读取器代理从该队列中读取更改并将其传递到发布服务器。在 SQL Server 2000 中，订阅可以使用 SQL Server 队列或消息队列对更改进行排队。队列的类型是用 sp_addpublication 的 @queue_type 参数指定的，允许的值为 sql 和 msmq（消息队列）。在 SQL Server 2005 中，只允许使用 sql 值。在升级期间，将修改使用消息队列的现有发布从而可以使用 SQL Server 队列。如果某些应用程序依赖于使用消息队列的排队更新，将需要重写这些应用程序以适应 SQL Server 队列。有关排队更新订阅的详细信息，请参阅事务复制的可更新订阅。

如果在升级 SQL Server 时消息队列服务处于运行之中，则升级过程将删除现有的消息队列订阅队列。

重要提示：
在 Windows 2000 和 Windows XP 中，还必须运行 Microsoft 分布式事务处理协调器 (MSDTC) 服务，因为在这些平台上消息队列需要使用 MSDTC。

如果未运行消息队列服务，请在升级完成后手动删除这些队列。有关删除队列的详细信息，请参阅 Windows 文档。

更改为调用格式以更新订阅

默认情况下，在事务复制中使用一组存储过程将更改应用到订阅服务器。每个过程都具有一种“调用格式”。此格式确定如何向过程传递参数以及向订阅服务器发送多少数据。在 SQL Server 2000 中，默认格式为 CALL。在 SQL Server 2005 和 SQL Server 2008 中，默认格式为 VCALL。

此更改只影响已自定义的存储过程所在的拓扑。升级后，您必须更改自定义过程的签名，使其包括其他参数。否则，分发代理将失败。

1 此问题只会对 SQL Server 2008 和更高版本带来影响。

合并复制的重大更改

以下重大更改适用于合并复制。

功能 | 说明
从 SQL Server Express 发布 | SQL Server MSDE 可以用作合并发布的发布服务器。SQL Server Express 可替代 MSDE，但不能用作发布服务器。它可以订阅合并发布、事务发布和快照发布。具有更新订阅的合并复制和事务复制均允许将更改从订阅服务器传播回发布服务器。有关复制到 SQL Server Express 的详细信息，请参阅将数据复制到 SQL Server Express。
批处理更改 | 在早期版本的 SQL Server 中，合并代理所做的更改是逐行执行的。在 SQL Server 2005 中，为提高性能，更改是成批执行的；因此，可以在一个语句内插入、更新或删除多行。如果发布数据库或订阅数据库中任何已发布的表都有触发器，请确保这些触发器可以处理插入、更新和删除多行的操作。有关详细信息，请参阅DML 触发器的多行注意事项。
冲突表的重新创建 | 升级到 SQL Server 2005 时重新创建冲突表，将 DBO 作为表的所有者。如果 SQL Server 2000 中的其他用户拥有某些表，则可能需要修改应用程序。 合并复制会以 conflict_PublicationName_ArticleName 命令格式为发布中的每个项目创建一个冲突表。升级时重新创建所有元数据表，并在 DBO 架构中创建所有冲突表。
分配的新标识范围 | 对于使用自动标识范围管理的表，复制可能在升级过程中分配新标识范围。如果某些表分配给订阅服务器的标识范围大于分配给发布服务器的标识范围，则复制会给发布服务器分配与订阅服务器的相等的范围。 若要确定用于每个项目的范围，请在发布数据库中执行 sp_helpmergearticle，并检查 pub_identity_range 列和 identity_range 列。

请参阅

概念

复制的向后兼容性


SQL Server 复制中的行为更改

SQL Server 复制中的行为更改 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > 复制的向后兼容性 >

本主题介绍 SQL Server 复制中的行为更改。行为更改会影响 SQL Server 2008 中的功能与早期版本的 SQL Server 相比的工作或交互方式。

SQL Server 2005 中所做的行为更改

本部分介绍 SQL Server 2005 在复制功能方面所做的一些行为更改。

影响所有复制类型的行为更改

下列更改影响所有复制类型。

功能 | 说明
复制代理安全模式 | 在早期版本的 SQL Server 中，默认情况下，代理在 SQL Server 代理服务帐户的上下文中运行。SQL Server 现在可以更细粒度地控制用于运行复制代理和建立与数据库及其他资源的 Microsoft Windows 集成连接的每个帐户；可为每个代理指定一个不同的帐户。有关详细信息，请参阅安全性和保护（复制）和复制代理安全性模式。有关此更改如何影响升级的信息，请参阅升级复制数据库时的注意事项的“新复制代理安全模式”部分和 SQL Server 复制中的重大更改。
Windows 同步管理器 | 在 SQL Server 2005 之前的 SQL Server 版本中，默认情况下已启用与同步管理器同步订阅的能力。在 SQL Server 2005 中，如果要使用同步管理器，必须显式启用此选项。有关详细信息，请参阅如何使用 Windows 同步管理器同步订阅（Windows 同步管理器）。
复制冲突查看器 | 在 SQL Server 2000 中，复制冲突查看器被打包，以用于再分发。在 SQL Server 2005 中，不对该查看器进行单独打包。若要在应用程序中包含复制冲突查看器，必须在部署了该应用程序的计算机中安装 Microsoft .NET Framework 2.0，还必须将若干文件复制到该计算机。有关详细信息，请参阅升级顾问帮助中的“其他复制升级问题”。有关升级顾问的详细信息，请参阅使用升级顾问来准备升级。
架构选项更改 | 通过架构选项，可以指定复制与表关联的属性和对象（如索引和约束）的方式。在 SQL Server 2005 中，许多架构选项的行为都发生了更改。本主题的下一部分提供详细信息。

架构选项行为更改

下表总结了 SQL Server 2005 中的架构选项更改。

注意：
如果已在 SQL Server 2000 中设置了 0x8000 架构选项，则在升级到 SQL Server 2005 期间该选项将被禁用。对于架构选项 0x10 或 0x40，在 SQL Server 2005 中复制可能要比在 SQL Server 2000 中复制创建的索引多。

选项 | 如果在 SQL Server 2000 中设置该选项，其行为如何 | 如果在 SQL Server 2005 中设置该选项，其行为如何
0x80 | 创建约束或索引。如果还启用了选项 0x8000，则创建的主键将作为包含索引的约束。如果没有启用选项 0x8000，则仅对主键列创建索引。 | 在订阅服务器中创建主键约束。此外还会复制所有与约束有关的索引，即使没有启用选项 0x10 和 0x40（这些选项控制其他情况下的索引创建）。
0x4000 | 创建约束或索引。如果还启用了选项 0x8000，则创建的唯一约束将作为包含索引的约束。如果没有启用选项 0x8000，则仅对该列创建索引。 | 在订阅服务器中创建所有的唯一约束。此外还会复制所有与约束有关的索引，即使没有启用选项 0x10 和 0x40（这些选项控制其他情况下的索引创建）。
0x8000 | 如果还指定了 0x80 或 0x4000，则将同时创建主键约束和唯一约束。如果没有指定其中的任何一个选项，则选项 0x8000 不起任何作用。 | 该选项不起任何作用。

事务复制的行为更改

下列更改会影响事务复制。

功能 说明

订阅服务器对象所有权

使用 SQL Server 2005 新建发布向导创建发布时，订阅服务器上创建的对象的所有者默认为发布服务器上相应对象的所有者的值。在早期版本中，在订阅服务器上创建对象的过程中不指定所有者；它默认为与用以连接到订阅服务器的分发代理帐户相关联的所有者。该行为对存储过程 sp_addarticle (Transact-SQL) 保持不变。

可更新订阅安全模式

sp_link_publication 的 @security_mode 参数控制即时更新订阅的触发器如何在发布服务器上执行调用。在 SQL Server 2005 中，此参数的选项有：

  • 0：使用 SQL Server 身份验证，以存储过程中指定的登录名作为登录名和密码。

  • 1：使用在订阅服务器上进行更改的用户的安全上下文（SQL Server 身份验证或 Windows 集成身份验证）。

  • 2：使用现有的、用户定义的链接服务器登录名。

在 SQL Server 的早期版本中，选项 0 用于指定从订阅服务器到发布服务器（而不是链接服务器）的动态远程过程调用 (RPC)。

合并复制的行为更改

下列更改影响合并复制。

功能 说明

发布兼容级别

在 SQL Server 的早期版本中，如果启用了需要更高兼容级别的功能，则兼容级别会自动增加。在 SQL Server 2005 中，必须先将兼容级别手动设置为 90RTM，然后才能启用要求该兼容级别的功能。有关详细信息，请参阅在复制拓扑中使用 SQL Server 的多个版本中的“合并发布的兼容性级别”部分。

补偿操作

在 SQL Server 的早期版本中，在同步期间遇到错误（如违反约束）时采取补偿操作。此行为在某些情况下很合适，但在某些情况下可能会带来问题；例如，一个未正确配置的订阅服务器发生错误时，可导致撤消对发布服务器和所有其他订阅服务器的更改。

在 SQL Server 2005 中，sp_addmergearticle 的 @compensate_for_errors 参数控制是否采取补偿操作。当设置为 False（默认值）时，禁用补偿操作；但是，仍将错误记录到日志中，且后续合并将继续尝试应用更改。虽然受影响的行中的数据可能表面上不收敛，但只要解决了错误，更改就可以应用，数据亦将收敛。当设置为 True 时，同步期间无法在节点上应用的更改会导致补偿操作，而这些补偿操作会撤消所有其他节点上的更改。

注意：
如果项目的源表已在另一个发布中发布，则两个项目的 @compensate_for_errors 值必须相同。对于运行 SQL Server 2000 8.00.858 版本和更早版本（包括 Service Pack 3）的订阅服务器上的请求订阅，即使将 @compensate_for_errors 设置为 False，仍会发生补偿操作。

冲突表

在 SQL Server 的早期版本中，合并复制为发布中的每一个表项目创建单个冲突表，其名称形式为 conflict_<项目名称>。在 SQL Server 2005 中，该信息包含在两个表中：MSmerge_conflicts_info 和一个名称形式为 MSmerge_conflict_<发布名称>_<项目名称> 的表。

基于保持期的元数据清除

SQL Server 2005 使用基于保持期的元数据清除，这是在 SQL Server 2000 Service Pack 1 中引入的。元数据定期从下列系统表中删除掉：

  • MSmerge_contents

  • MSmerge_tombstone

  • MSmerge_genhistory

  • 任何前映像表（如果存在）。如果发布上启用了 @keep_partition_changes 同步优化选项（有关此选项的详细信息，请参阅下一节），则存在前象表。

@keep_partition_changes 参数

在 SQL Server 的早期版本中，@keep_partition_changes 参数默认情况下设置为 False，因为它导致在发布服务器上存储更多数据。现在，如果发布兼容级别为 90RTM 或更高，且 @use_partition_groups 参数设置为 False，则将它设置为 True。有关这些选项的详细信息，请参阅参数化行筛选器。

请参阅

概念

复制的向后兼容性


在复制拓扑中使用 SQL Server 的多个版本

在复制拓扑中使用 SQL Server 的多个版本 |
 | 请参阅
升级到 SQL Server 2008 > 向后兼容性 > 复制的向后兼容性 >

复制功能支持将数据复制到 SQL Server 的不同版本。本主题提供有关以下方面的信息：

  • 支持的 SQL Server 版本

  • 为早期版本映射 SQL Server 2008 数据类型

  • 从早期版本还原复制的数据库

  • 合并发布的兼容级别

有关如何将数据复制到 SQL Server Express 和 SQL Server Compact 3.5 的信息，请参阅将数据复制到 SQL Server Express和向 SQL Server Compact 复制数据。有关各版本的 SQL Server 所支持功能的信息，请参阅 SQL Server 2008 各个版本支持的功能。

支持的 SQL Server 版本

SQL Server 2000 和 SQL Server 2005 均可以与 SQL Server 2008 一起参与复制拓扑。对于 SQL Server 2000，最低版本为 Service Pack 3 (SP3)。对于 SQL Server 2005，最低版本为 Service Pack 2 (SP2)。

在不同版本的 SQL Server 之间复制时，通常受限于所使用的最早版本的功能。例如，如果将分发服务器升级到 SQL Server 2008 实例，但是您有运行 SQL Server 2005 实例的发布服务器和运行 SQL Server 2000 实例的订阅服务器，则会受限于 SQL Server 2000 的常规功能和复制功能。

注意：
由于 64 位和 32 位环境中的 SQL Server 磁盘存储格式相同，因此复制拓扑可以将运行于 32 位环境中的服务器实例与运行于 64 位环境中的服务器实例结合起来。

对于所有类型的复制，分发服务器版本不得低于发布服务器版本。（分发服务器通常与发布服务器是同一个实例。）

对于事务复制，用于事务发布的订阅服务器版本可以是两个发布服务器版本中的任何一个版本。例如，SQL Server 2000 发布服务器可以对应 SQL Server 2008 订阅服务器，而 SQL Server 2008 发布服务器可以对应 SQL Server 2000 订阅服务器。

对于合并复制，用于合并发布的订阅服务器的版本不能比发布服务器版本高。有关早期版本兼容性的详细信息，请参阅本主题稍后部分中的“合并发布的兼容级别”。有关 SQL Server 的各种版本所支持的复制功能的详细信息，请参阅 SQL Server 2008 各个版本支持的功能。

与运行 SQL Server 2000 的发布服务器一起使用 SQL Server 2005 或 SQL Server 2008 分发服务器

可以使用 SQL Server 2005 和 SQL Server 2008 作为运行 SQL Server 2000 的发布服务器的远程分发服务器。若要更改此方案中的代理属性，请在分发服务器上执行以下存储过程。用这些过程可以更改 SQL Server 2005 中引入的属性：

  • sp_MSchange_snapshot_agent_properties (Transact-SQL)

  • sp_MSchange_logreader_agent_properties (Transact-SQL)

  • sp_MSchange_distribution_agent_properties (Transact-SQL)

  • sp_MSchange_merge_agent_properties (Transact-SQL)

如果您有运行 SQL Server 2000 的发布服务器和分发服务器，则可以使用 sp_changedistpublisher 和 sp_changesubscriber 来更改代理建立连接时所使用的凭据。但是，如果将分发服务器升级到 SQL Server 2008，就不能使用这些过程来更改在现有的代理作业中使用的凭据。这些过程不会影响在调用它们之后创建的代理作业。若要更改现有代理作业的凭据，请调用上面列出的四个过程之一。

为早期版本映射新数据类型

SQL Server 2008 和 SQL Server 2005 支持若干新数据类型。如下表中所示，如果使用来自 SQL Server 2005 或 SQL Server 2008 分发服务器的推送订阅，则会将这些新数据类型映射到订阅服务器上的兼容数据类型。如果将新数据类型复制到运行早期版本 SQL Server 的订阅服务器，则必须验证数据类型的映射是否正确：

  • 默认情况下，将针对合并复制中的项目（而不是快照复制或事务复制中的项目）执行映射。对于合并发布，映射类型的方式由发布兼容级别确定。例如，如果某列类型为 geography 且兼容级别为 90RTM，则类型将映射为 varbinary(max)。如果兼容级别为 80RTM，则类型将映射为 image。

  • 映射行为由 sp_addarticle 和 sp_addmergearticle 的 @schema_option 参数控制。

    有关如何设置架构选项的详细信息，请参阅如何指定架构选项 (SQL Server Management Studio) 和如何指定架构选项（复制 Transact-SQL 编程）。

SQL Server 2008 数据类型 | SQL Server 2005 数据类型 | SQL Server 2000 数据类型
公共语言运行库用户定义类型 (UDT)：8000 个字节或更少 | UDT | image
UDT：大于 8000 个字节1 | varbinary(max) | image
date 2, 3 | nvarchar(10) | nvarchar(10)
datetime2 2, 3 | nvarchar(27) | nvarchar(27)
datetimeoffset 2, 3 | nvarchar(34) | nvarchar(34)
FILESTREAM 属性1, 4 | varbinary(max) | 不支持
geography 和 geometry1, 3 | varbinary(max) | image
hierarchyid 1, 5 | varbinary(max) | image
nvarchar(max) | nvarchar(max) | ntext
time 2, 3 | nvarchar(16) | nvarchar(16)
varchar(max) | varchar(max) | text
varbinary(max) | varbinary(max) | image
xml | xml | ntext

1 对于包含可更新订阅的事务发布，不支持映射 UDT、FILESTREAM、geography、geometry 和 hierarchyid 类型。只有当所有更新订阅服务器运行的都是 SQL Server 2008 或更高版本时，才包括这些类型。

2 复制过程不检查插入到订阅服务器的数据的格式。因此，您的应用程序必须确保所插入数据的格式适用于 date、datetime2、datetimeoffset 和 time 类型的列。这通常是使用约束来完成的。如果数据格式不正确，则在发布服务器上插入时将失败。

3 这些类型在复制到 SQL Server Compact 订阅服务器之后，将由订阅服务器进行转换。有关 SQL Server Compact 数据类型映射的信息，请参阅 SQL Server Compact 文档。

如要将列从类型 geography 或 geometry 映射到 varbinary(max) 或 image，将无法复制这些列的默认约束。此操作会产生以下结果：

  • 如果在发布服务器上已有默认约束，则删除此约束，或者指定不得复制此约束。若要指定不得复制默认约束，请使用默认约束的项目架构选项：

    • 为选项“复制默认值规范”选择值 False。有关详细信息，请参阅如何指定架构选项 (SQL Server Management Studio)。

    • 禁用架构选项 0x800。有关详细信息，请参阅如何指定架构选项（复制 Transact-SQL 编程）。

  • 若要在发布服务器上添加一个默认约束，请首先指定不得复制架构更改。有关详细信息，请参阅如何复制架构更改 (SQL Server Management Studio) 和如何复制架构更改（复制 Transact-SQL 编程）。

4 FILESTREAM 是 varbinary(max) 列的一个属性。有关如何在复制的表中使用 FILESTREAM 列的信息，请参阅 将 FILESTREAM 与其他 SQL Server 功能配合使用中的“复制”一节。具有 FILESTREAM 属性的列不应包含在使用字符模式快照的发布中。

5 是否支持 hierarchyid 类型的列取决于复制类型以及使用的 SQL Server 版本。有关详细信息，请参阅 hierarchyid (Transact-SQL) 的“在复制的表中使用 hierarchyid 列”一节。对于合并复制，当复制兼容级别为 100RTM 且使用字符模式快照时，hierarchyid 将映射为 image。

复制 XML 数据类型

向 SQL Server Compact 3.5 复制 XML 数据类型时，合并复制会将它们映射到 Ntext。SQL Server 2008 中的 XML 数据具有 UTF-16 编码的前缀字节。使用合并复制从 SQL Server 向 SQL Server Compact 3.5 复制时会保留这些字节。查看 SQL Server Compact 3.5 数据库的 Ntext 列时，这些前缀字节不为 SQL Server Management Studio 所理解。因此，这些字节将显示为垃圾字符。

SQL Server 2008 中的 XML 架构集合已经更新。这将对从 SQL Server 2008 向 SQL Server 2005 复制绑定到 XML 架构的 XML 列产生影响。

对于 SQL Server 2008 中的日期、时间和日期时间 XML 架构值，时区不是强制性的。这意味着，如果不对 SQL Server 2008 发布服务器 XML 列指定时区，将不会对 SQL Server 2005 订阅服务器应用该更改，因为 SQL Server 2005 要求指定时区。

有关 SQL Server 2008 发布服务器的日期、时间和日期时间 XML 架构类型化值的时区信息将转换为 SQL Server 2005 中的 UTC-0 时区。这由时区指示符 Z 表示。

SQL Server 2008 XML 架构日期、时间和日期时间类型支持更大的精度。因此，在向 SQL Server 2005 复制这些值时，会进行舍入。

从 SQL Server 2005 向 SQL Server 2008 复制 XML 架构日期或时间日期值时，具有负年份的值将不适用于 SQL Server 2008，因为 SQL Server 2008 不支持此类值。

在这些情况下，复制代理中的 sp_table_validation 和 Validate 方法可能会失败。有关详细信息，请参阅类型化的 XML 与非类型化的 XML 的比较中的“将类型化的 XML 从 SQL Server 2005 升级到 SQL Server 2008”部分。

发布压缩数据

SQL Server 2008 支持表和索引的行压缩和页压缩。有关压缩数据的复制支持的信息，请参阅创建压缩表和索引中的“压缩如何影响复制”。

从早期版本还原复制的数据库

从早期版本还原复制数据库的备份时，可以保留复制设置。如果要将备份还原到与进行备份的服务器和数据库同名的服务器和数据库，或者如果指定了 KEEP_REPLICATION 选项，则将保留复制设置。有关详细信息，请参阅 RESTORE (Transact-SQL)。还原数据库后，请执行 sp_vupgrade_replication 来升级架构和系统数据，以便支持当前产品级别上的复制。

尽管在从早期版本的备份中还原后可以保留复制，但是复制很少用作升级选项。作为产品升级的一部分升级复制的数据库或根据一组脚本重新创建数据库和复制配置较为常见。

合并发布的兼容级别

合并复制使用发布兼容级别来确定给定数据库中的发布可以使用哪些功能。对于 SQL Server 2008 来说，值的范围是从 80RTM（未安装 Service Pack 的 SQL Server 2000）到 100RTM。可以通过下列方法之一来指定兼容级别：

  • 使用 sp_addmergepublication 的 @publication_compatibility_level 参数。有关详细信息，请参阅如何设置合并发布的兼容级别（复制 Transact-SQL 编程）。

  • 在新建发布向导的“订阅服务器类型”页上指定。有关如何运行此向导的详细信息，请参阅如何创建发布和定义项目 (SQL Server Management Studio)。

  • 在“发布属性 - <发布>”对话框的“常规”页上指定。有关详细信息，请参阅如何设置合并发布的兼容级别 (SQL Server Management Studio)。

下列功能要求 90RTM 或更高的兼容级别：

  • 逻辑记录。有关详细信息，请参阅通过逻辑记录对相关行的更改进行分组。

  • 订阅服务器上载选项。有关详细信息，请参阅使用仅下载项目优化合并复制的性能。

  • 不重叠的分区。有关详细信息，请参阅参数化行筛选器。

  • 业务逻辑处理程序。有关详细信息，请参阅在合并同步期间执行业务逻辑。

  • 使用 ALTER <OBJECT> 语句的架构更改。有关详细信息，请参阅对发布数据库进行架构更改。

下列功能不依赖于兼容级别；但是，它们需要使用 SQL Server 2005 及更高版本中随附的合并代理。运行早期版本 SQL Server 的订阅服务器在运行时就好像合并代理功能未启用一样。

  • 预计算分区。有关详细信息，请参阅使用预计算分区优化参数化筛选器的性能。

  • Web 同步。有关详细信息，请参阅合并复制的 Web 同步。

  • 并行阶段代理（为合并代理指定 -ParallelUploadDownload）。有关详细信息，请参阅复制合并代理。

  • 使用参数化筛选器的发布的快照功能。通过这些功能可以执行如下操作：

    • 如果订阅服务器没有分区快照，可以请求快照。

    • 管理员可以预生成快照和计划快照的生成。

    • 使用 FTP 传递参数化快照。

    有关详细信息，请参阅带有参数化筛选器的合并发布的快照和通过 FTP 传输快照。

  • 改进了复制监视器中的历史日志和项目级统计信息。有关详细信息，请参阅如何查看订阅信息和执行其任务（复制监视器）。

SQL Server 2008 中的发布兼容级别行为

下面是需要考虑的发布兼容级别的一些重要行为：

  • 发布兼容级别与数据库兼容级别无关。

  • 如果使用 sp_addmergepublication 或通过复制管理对象 (RMO) 创建发布，则发布兼容级别会在默认情况下设置为 80RTM。如果使用新建发布向导创建发布，则根据在该向导的“订阅服务器类型”页上选择的选项来确定发布兼容级别。

  • 在版本低于 SQL Server 2005 的 SQL Server 中，如果启用了需要更高级别的功能，则发布兼容级别会自动增加。从 SQL Server 2005 开始，必须先将发布兼容级别手动设置为 90RTM 或更高，然后才能启用要求该兼容级别的功能。

  • 仅当快照代理尚未启动且不存在对发布的订阅时，才能降低发布兼容级别。

  • 同一数据库中的所有发布必须具有相同的兼容级别。此要求会产生下列影响：

    • 如果数据库所含发布的兼容级别较低（如 80RTM），而且要在同一数据库中添加另一个级别为 90RTM 或更高的发布，则必须在添加新发布之前手动提高第一个发布的级别。

    • 如果数据库包含两个或多个兼容级别较低的发布，而且要在同一数据库中添加另一个级别为 90RTM 或更高的发布，则必须执行以下操作：只保留一个现有发布，其余全部删除；将其余发布的级别提高到 90RTM 或更高；将已删除的发布重新创建为级别为 90RTM 或更高的发布；创建级别为 90RTM 或更高的新发布。

Web 同步所需的组件和兼容级别

SQL Server 2008 支持针对运行 SQL Server 2005、SQL Server 2008、SQL Server Compact 3.0、3.1 以及 3.5 的订阅服务器进行 Web 同步。下表列出了每种类型的订阅服务器所需的发布兼容级别和服务器组件。

发布服务器版本 | 订阅服务器版本 | 必需的发布兼容级别 | IIS 服务器上必需的组件
SQL Server 2008 | SQL Server 2008 | 100RTM | SQL Server 2008 IIS 组件
SQL Server 2008 | SQL Server Compact 3.0、3.1 和 3.5 | 90RTM | SQL Server Compact 3.5 IIS 组件和 SQL Server 2008 IIS 组件
SQL Server 2008 | SQL Server 2005 | 90RTM | SQL Server 2008 IIS 组件
SQL Server 2005 | SQL Server 2005 | 90RTM | SQL Server 2005 IIS 组件
SQL Server 2005 | SQL Server Compact 3.0、3.1 和 3.5 | 90RTM | SQL Server Compact 3.5 IIS 组件和 SQL Server 2005 IIS 组件
SQL Server 2005 | SQL Server 2008 | 不适用1 | 不适用1

1 因为发布服务器版本不得低于订阅服务器版本，所以不支持该配置。

请参阅

概念

复制的向后兼容性
升级复制数据库时的注意事项


迁移到 SQL Server 2008

迁移到 SQL Server 2008 |
 | 请参阅

如果存在阻止升级的程序、大规模部署或紧急需求，或者要更改安装的硬件或拓扑结构，那么将 SQL Server 安装迁移到 SQL Server 2008 是个不错的办法。迁移过程包括手动步骤和自动步骤。下列主题对迁移过程进行了说明。

本节内容

主题 | 说明
如何迁移 Reporting Services 安装 | 提供有关如何将先前版本的 Reporting Services 迁移到 SQL Server 2008 的信息。
升级 Integration Services 包 | 提供有关如何将 Integration Services 包迁移到 SQL Server 2008 的信息。
迁移 Data Transformation Services 包 | 提供有关如何将 Data Transformation Services 包迁移到 SQL Server 2008 的信息。

请参阅

概念

向后兼容性


升级 Integration Services 包

升级 Integration Services 包 |
 | 请参阅
迁移到 SQL Server 2008 >

在将 SQL Server 2005 实例升级到 SQL Server 2008 时，现有的 SQL Server 2005 Integration Services (SSIS) 包不会自动升级到由 SQL Server 2008 Integration Services (SSIS) 使用的包格式。您将必须选择一种升级方法并手动升级 SQL Server 2005 包。

在升级 SQL Server 2005 包时，Integration Services 会将任何脚本任务和脚本组件中的脚本迁移到 Microsoft Visual Studio Tools for Applications (VSTA)。在 SQL Server 2005 中，脚本任务或脚本组件中的脚本使用的是 Microsoft Visual Studio for Applications (VSA)。有关在迁移之前可能需要进行的脚本更改以及脚本转换失败的详细信息，请参阅将脚本迁移到 VSTA。

选择升级方法

可以使用各种方法来升级 SQL Server 2005 包。对于某些方法，升级只是临时的。对于其他方法，升级将是永久的。下表描述了每种升级方法以及升级是临时的还是永久的。

升级方法 | 升级类型
使用随 SQL Server 2008 安装的 dtexec 实用工具 (dtexec.exe) 来运行 SQL Server 2005 包。 有关详细信息，请参阅 dtexec 实用工具。 | 包升级和脚本迁移是临时的。 无法保存所做的更改。
向现有的项目中添加一个 SQL Server 2005 包，或者在 SQL Server 2008 Integration Services 中打开 SQL Server 2005 包。 | 如果保存该包，则包升级是永久的；否则，如果不保存该包，则包升级是临时的。 如果将该包添加到现有的项目中，则脚本迁移是永久的。如果打开该包并保存转换更改，则脚本迁移也是永久的；否则，如果不保存转换更改，则脚本迁移是临时的。
使用 SSIS 包升级向导创建或打开一个 SQL Server 2005 Integration Services 项目，然后升级该项目中的多个包。 有关详细信息，请参阅如何使用 SSIS 包升级向导升级 Integration Services 包和 SSIS 包升级向导的 F1 帮助。 | 包升级和脚本迁移是永久的。

了解包升级结果

在包升级过程中，SQL Server 2005 包中的大部分组件和功能都无缝地转换为其在 SQL Server 2008 中的对应部分。但是，有一些组件和功能，它们要么无法升级，要么升级的结果值得引起您的注意。下表确定了这些组件和功能。

注意：
若要确定哪些包具有该表中列出的问题，请运行升级顾问。有关详细信息，请参阅使用升级顾问来准备升级。

组件或功能 升级结果

连接字符串

某些提供程序的名称已在 SQL Server 2008 中进行更改，而且需要在连接字符串中使用不同的值。

若要更新连接字符串，请使用下列过程之一：

  • 使用 SSIS 包升级向导升级包，并选择“更新连接字符串以使用新的提供程序名称”选项。

  • 在 Business Intelligence Development Studio 中的“选项”对话框中，选择“更新连接字符串以使用新的提供程序名称”选项。

  • 在 Business Intelligence Development Studio 中，打开该包并手动更改 ConnectionString 属性的文本。

查找转换

包升级过程会将查找转换自动升级为 SQL Server 2008 版本。不过，此组件的 SQL Server 2008 版本有一些您可能想要利用的额外功能。

有关详细信息，请参阅查找转换。

脚本任务和脚本组件

包升级过程会自动将脚本任务和脚本组件中的脚本从 VSA 迁移到 VSTA。

有关在迁移之前可能需要进行的脚本更改以及脚本转换失败的详细信息，请参阅将脚本迁移到 VSTA。

第三方组件和自定义组件

这些组件将不进行升级。您必须手动重新编译这些组件，以便允许它们与 SQL Server 2008 Integration Services 协作。

请参阅

概念

迁移到 SQL Server 2008


将脚本迁移到 VSTA

将脚本迁移到 VSTA |
 | 请参阅
迁移到 SQL Server 2008 > 升级 Integration Services 包 >

在将 SQL Server 2005 包升级到 SQL Server 2008 时，Integration Services 会将任何脚本任务或脚本组件中的脚本迁移到 Microsoft Visual Studio Tools for Applications (VSTA)。VSTA 是 SQL Server 2008 Integration Services (SSIS) 使用的脚本环境。在 SQL Server 2005 中，Integration Services 的脚本环境是 Microsoft Visual Studio for Applications (VSA)。

如果脚本引用接口或者使用由用户定义的类型值，您可能需要在升级包之前修改这些脚本。否则，包将无法升级或者脚本将无法验证，具体情况取决于所使用的升级方法。下表介绍了对代码进行的修改。

任务 | 说明
修改对接口的引用 | 将对 IDTSxxx90 接口的引用替换为对相应 IDTSxxx100 接口的引用。 此任务适用于脚本任务和脚本组件。
修改类型对象 | 如果运行时变量中的用户定义类型值未在 mscorlib.dll 或 Microsoft.SqlServer.VSTAScriptTaskPrx.dll 程序集内定义，请将这些类型更改为从 System.MarshalByRefObject 继承。 此任务仅适用于脚本任务。

有关如何迁移脚本和升级包的详细信息，请参阅升级 Integration Services 包。

了解迁移失败

在迁移脚本时，脚本可能会由于以下原因之一而失败：

  • VSA 脚本的入口点已重命名。

    入口点在 VSTA 项目中的 ScriptMain 类中指定一种方法，Integration Services 运行时会将该方法作为脚本任务代码的入口点来调用。ScriptMain 类是由脚本模板生成的默认类。

  • 在 VSA 脚本中，没有入口点或者有多个入口点。

  • 无法添加程序集引用。

  • 已经将 ScriptMain 类修改为从 ScriptObjectModelSSIS 类以外的其他类中继承。Microsoft .NET Framework 不支持多重继承。

不能将使用 Visual Basic 2005 的 VSA 脚本转换为使用 Microsoft Visual C# 2008 的 VSTA 脚本。但是，可以新建使用 Microsoft Visual C# 2008 的 VSTA 脚本。有关详细信息，请参阅Coding and Debugging the Script Task和Coding and Debugging the Script Component。

请参阅

其他资源

Extending Packages with Scripting


如何使用 SSIS 包升级向导升级 Integration Services 包

如何使用 SSIS 包升级向导升级 Integration Services 包
迁移到 SQL Server 2008 > 升级 Integration Services 包 >

您可以将在早期版本的 Integration Services 中创建的包升级为 SQL Server 2008 使用的 Integration Services 格式。SQL Server 提供了 SSIS 包升级向导来帮助完成此过程。由于可以将该向导配置为备份原始包，因此如果您遇到升级困难，可以继续使用这些原始包。

安装 Integration Services 时，将安装 SSIS 包升级向导。

注意：
SQL Server 的 Standard Edition、Enterprise Edition 和 Developer Edition 提供了 SSIS 包升级向导。

有关如何升级 Integration Services 包的详细信息，请参阅升级 Integration Services 包。

注意：
有关迁移在 SQL Server 2000 Data Transformation Services (DTS) 中创建的包的信息，请参阅迁移 Data Transformation Services 包。

本主题的其余部分介绍了如何运行向导和备份原始包。

运行 SSIS 包升级向导

您可以从 Business Intelligence Development Studio、SQL Server Management Studio 或在命令提示符下运行 SSIS 包升级向导。

从 Business Intelligence Development Studio 运行向导

  1. 在 Business Intelligence Development Studio 中，创建或打开一个 Integration Services 项目。

  2. 在解决方案资源管理器中，右键单击“SSIS 包”节点，然后单击“升级所有包”来升级该节点下的所有包。

    注意：
    打开包含 SQL Server 2005 Integration Services (SSIS) 包的 Integration Services 项目时，Integration Services 将自动打开 SSIS 包升级向导。

从 SQL Server Management Studio 运行向导

  • 在 SQL Server Management Studio 中，连接到 Integration Services，展开“已存储的包”节点，接着右键单击“文件系统”节点或 MSDB 节点，然后单击“升级包”。

在命令提示符下运行向导

  • 在命令提示符下，从 C:\Program Files\Microsoft SQL Server\100\DTS\Binn 文件夹运行 SSISUpgrade.exe 文件。

备份原始包

若要备份原始包，必须将原始包和已升级包存储在文件系统的同一文件夹中。根据向导的运行方式，可以自动选择该存储位置：

  • 从 Business Intelligence Development Studio 运行 SSIS 包升级向导时，该向导会自动将原始包和已升级包存储在文件系统的同一文件夹中。您可以将该向导配置为备份原始包。

  • 从 SQL Server Management Studio 或在命令提示符下运行 SSIS 包升级向导时，可以为原始包和已升级包指定不同的存储位置。若要备份原始包，请确保指定将原始包和已升级包存储在文件系统的同一文件夹中。如果指定任何其他存储选项，则向导将无法备份原始包。

向导备份原始包时，此向导将在 SSISBackupFolder 文件夹中存储该原始包的副本。向导会创建此 SSISBackupFolder 文件夹，将其作为包含原始包和已升级包的文件夹的子文件夹。

在 SQL Server Management Studio 中或在命令提示符下备份原始包

  1. 将原始包保存到文件系统上的某个位置。

    注意：
    向导中的备份选项只能用于已存储到文件系统中的包。

  2. 在 SQL Server Management Studio 中或在命令提示符下，运行 SSIS 包升级向导。

  3. 在向导的“选择源位置”页上，将“包源”属性设置为“文件系统”。

  4. 在向导的“选择目标位置”页上，选择“保存到源位置”，从而将已升级包保存到与原始包相同的位置。

    注意：
    仅当将已升级包存储在与原始包相同的文件夹中时，向导中的备份选项才可用。

  5. 在向导的“选择包管理选项”页上，选择“备份原始包”选项。

在 Business Intelligence Development Studio 中备份原始包

  1. 将原始包保存到文件系统上的某个位置。

    注意：
    向导中的备份选项只能用于已存储到文件系统中的包。

  2. 在 Business Intelligence Development Studio 中，运行 SSIS 包升级向导。

  3. 在向导的“选择包管理选项”页上，选择“备份原始包”选项。


如何迁移 Reporting Services 安装

如何迁移 Reporting Services 安装 |
 | 请参阅
迁移到 SQL Server 2008 >

本主题提供有关将 SQL Server 2000 或 SQL Server 2005 Reporting Services 部署迁移到新 SQL Server 2008 Reporting Services 实例的分步说明。迁移是指将应用程序数据文件移到新的 SQL Server 2008 实例。如果存在阻止升级的程序、大规模部署或运行时间要求，或者要更改安装的硬件或拓扑，则必须迁移安装。

Reporting Services 的迁移过程包括手动步骤和自动步骤。报表服务器迁移包括以下任务：

  • 备份数据库、应用程序和配置文件。

  • 备份加密密钥。

  • 安装 SQL Server 2008 的新实例。如果使用的是相同硬件，则可以将 SQL Server 2008 与现有的 SQL Server 2000 或 2005 安装并行安装。请注意，如果您并行安装，则可能需要将 SQL Server 2008 安装为命名实例。

  • 将报表服务器数据库和其他应用程序文件从 SQL Server 2000 或 2005 安装移到新的 SQL Server 2008 安装中。

  • 将任何自定义应用程序文件移到新安装中。

  • 配置报表服务器。

  • 编辑 RSReportServer.config，使其包括先前安装中的任何自定义设置。

  • 或者，为新的 Reporting Services Windows 服务组配置自定义访问控制列表 (ACL)。

  • 测试安装。

  • 在确认新实例完全正常之后，删除未使用的应用程序和工具。

请注意，如果要重用在以前的安装中创建的现有报表服务器数据库，则用于承载报表服务器数据库的 SQL Server 有版本限制。有关详细信息，请参阅创建报表服务器数据库。

开始之前

即使要迁移（而不是升级）安装，也要考虑针对现有的安装运行升级顾问以帮助确定可能会影响迁移的任何问题。如果要迁移尚未安装或配置的报表服务器，则该步骤尤其有用。通过运行升级顾问，可以查明新 SQL Server 2008 安装可能不支持的自定义设置。

此外，应当注意 SQL Server 2008 中进行了多项将影响安装迁移方式的重要改动：

  • IIS 不再是必备组件。如果要将报表服务器安装迁移到新计算机上，则无需添加 Web 服务器角色。另外，URL 和身份验证的配置步骤不同于以前的版本，用来诊断和解决问题的方法和工具也是如此。

  • 报表服务器 Web 服务、报告管理器和报表服务器 Windows 服务合并到一个报表服务器服务中。所有这三个应用程序都在同一个帐户下运行。所有这三个应用程序都从 RSReportServer.config 文件中读取配置设置，这使得 RSWebApplication.config 被废弃。

  • 为了删除重叠功能而对报表管理器和 SQL Server Management Studio 进行了重新设计。每个工具都支持一组不同的任务；这些工具不再能够互换。

  • SQL Server 2008 Reporting Services 不支持 ISAPI 筛选器。如果使用 ISAPI 筛选器，则必须在迁移之前重新设计报表解决方案。

  • SQL Server 2008 Reporting Services 不支持 IP 地址限制。如果使用 IP 地址限制，则必须在迁移之前重新设计报表解决方案，或使用诸如防火墙、路由器或网络地址转换 (NAT) 等技术来配置被禁止访问报表服务器的地址。

  • SQL Server 2008 Reporting Services 不支持客户端安全套接字层 (SSL) 证书。如果使用客户端 SSL 证书，则必须在迁移之前重新设计报表解决方案。

  • 如果使用 Windows 集成身份验证之外的身份验证类型，则必须将 RSReportServer.config 文件中的 <AuthenticationTypes> 元素更新为支持的身份验证类型。支持的身份验证类型包括 NTLM、Kerberos、Negotiate 和 Basic。SQL Server 2008 Reporting Services 不支持匿名、.NET Passport 和摘要式身份验证。

  • 如果在报表环境中使用自定义级联样式表，则这些样式表不会被迁移。必须在迁移后对它们进行手动移动。

有关 SQL Server 2008 Reporting Services 中更改的详细信息，请参阅升级顾问文档和新增功能 (Reporting Services)。

备份文件和数据

在安装新 Reporting Services 实例之前，请确保对当前安装中的所有文件进行备份。

  1. 备份报表服务器数据库的加密密钥。此步骤对于成功迁移至关重要。而且，在迁移过程中，必须还原加密密钥才能使报表服务器重新获得对加密数据的访问权限。若要备份加密密钥，可以使用 Reporting Services 配置工具（或者，如果要从 SQL Server 2000 迁移的话，可以使用 rskeymgmt 实用工具）。

  2. 使用任一支持的备份 SQL Server 数据库的方法来备份报表服务器数据库。有关详细信息，请参阅将报表服务器数据库移至其他计算机中有关如何备份报表服务器数据库的说明。

  3. 备份报表服务器配置文件。要备份的文件包括：

    1. Rsreportserver.config

    2. Rswebapplication.config

    3. Rssvrpolicy.config

    4. Rsmgrpolicy.config

    5. Reportingservicesservice.exe.config

    6. 报表服务器和报表管理器 ASP.NET 应用程序的 Web.config。

    7. ASP.NET 的 Machine.config（如果您为报表服务器操作修改过它）。

安装 SQL Server 2008 Reporting Services

在仅文件模式下安装新的报表服务器实例，以便可以将它配置为使用非默认值。对于命令行安装，请使用 FilesOnly 参数。在安装向导中，选中“安装但不配置”选项。

单击下面的链接之一以查看有关如何安装新 Reporting Services 实例的说明：

  • 如何安装 SQL Server 2008（安装程序）

  • 如何从命令提示符安装 SQL Server 2008

移动报表服务器数据库

报表服务器数据库包含已发布的报表、模型、共享数据源、计划、资源、订阅和文件夹，还包含系统属性、项属性以及对报表服务器内容的访问权限。

如果您的迁移涉及到使用另一个数据库引擎实例，则必须将报表服务器数据库移到新的数据库引擎实例中。如果要使用同一个数据库引擎实例，请跳至“配置报表服务器”。

若要移动报表服务器数据库，请执行以下操作：

  1. 选择要使用的数据库引擎实例。SQL Server 2008 Reporting Services 要求使用 SQL Server 2005 或 2008 来承载报表服务器数据库。SQL Server 2000 不能再用来为 SQL Server 2008 Reporting Services 承载报表服务器数据库。如果使用的是在 8.0 兼容模式下运行的 SQL Server 2000 或 SQL Server 2005，则必须升级数据库引擎或选择另一个数据库引擎实例。

  2. 启动 SQL Server Management Studio 并连接到数据库引擎。

  3. 如果数据库引擎从未承载过报表服务器数据库，请在系统数据库中创建 RSExecRole。有关详细信息，请参阅如何创建 RSExecRole。

  4. 按照将报表服务器数据库移至其他计算机中的说明操作。

请记住，报表服务器数据库和临时数据库相互依赖而且必须一起移动。请不要复制数据库；复制不会将所有安全设置转移至新安装。请不要移动用于计划报表服务器操作的 SQL Server 代理作业。报表服务器将自动重新创建这些作业。

移动自定义程序集或扩展插件

如果安装中包括自定义的报表项、程序集或扩展插件，则必须重新部署这些自定义组件。如果没有使用自定义组件，请跳至“配置报表服务器”。

若要重新部署自定义组件，请执行以下操作：

  1. 确定是支持程序集还是需要重新编译程序集：

    • 为 SQL Server 2000 版本创建的自定义身份验证扩展插件必须进行重新编译。

    • 必须使用呈现对象模型 (ROM) 重新编写 SQL Server 2008 Reporting Services 的自定义呈现扩展插件。

    • SQL Server 2008 Reporting Services 不支持 HTML 3.2 和 HTML OWC 呈现器。

    • 其他自定义程序集应当不需要重新编译。

  2. 将这些程序集移到新的报表服务器和报表管理器 \bin 文件夹中。在 SQL Server 2008 中，对于默认的 SQL Server 2008 Reporting Services 实例，报表服务器二进制文件位于 \Program files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportServer\bin。

  3. 修改配置文件，以便为自定义组件添加条目。所用程序集的种类不同，这些条目也会有所不同。有关在何处放置文件和添加配置条目的说明，请参阅以下内容：

    1. Deploying a Custom Assembly

    2. How to: Deploy a Custom Report Item

    3. Deploying a Data Processing Extension

    4. Deploying a Delivery Extension

    5. Deploying a Rendering Extension

    6. Implementing a Security Extension

配置报表服务器

为报表服务器 Web 服务和报表管理器配置 URL，并配置与报表服务器数据库的连接。

如果要迁移扩展部署，则应使所有报表服务器节点脱机并按照一次迁移一个服务器的方式迁移各个服务器。一旦迁移了第一个报表服务器并且其成功连接到报表服务器数据库，则该报表服务器数据库版本将自动升级到 SQL Server 2008 数据库版本。

注意：
如果扩展部署中的所有报表服务器均联机并且尚未被迁移，则它们可能会遇到 rsInvalidReportServerDatabase 异常，因为它们在连接到升级的报表服务器数据库之后使用的仍是旧版架构。

  1. 启动 Reporting Services 配置工具，然后连接到刚安装的 Reporting Services 实例。有关详细信息，请参阅如何启动 Reporting Services 配置。

  2. 为报表服务器和报表管理器配置 URL。有关详细信息，请参阅如何配置 URL（Reporting Services 配置）。

  3. 配置报表服务器数据库，并从以前的安装中选择现有的报表服务器数据库。成功配置之后，报表服务器服务将重新启动，并且一旦将其与报表服务器数据库建立了连接，该数据库将自动升级到 SQL Server 2008 Reporting Services。有关如何运行“更改服务器向导”（该向导可用来创建或选择报表服务器数据库）的详细信息，请参阅如何创建报表服务器数据库（Reporting Services 配置）。

  4. 还原加密密钥。在针对报表服务器数据库中预先存在的连接字符串和凭据启用可逆加密时，此步骤是必不可少的。有关详细信息，请参阅备份和还原加密密钥。

  5. 如果报表服务器安装在新计算机上，并且您使用的是 Windows 防火墙，请确保该报表服务器侦听的 TCP 端口处于打开状态。默认情况下，此端口为 80。有关详细信息，请参阅如何将防火墙配置为允许报表服务器访问。

  6. 如果报表服务器安装在 Windows Vista 或 Windows Server 2008 上，请创建角色分配并向“受信任的站点”中添加报表服务器站点以支持本地管理。有关详细信息，请参阅如何在 Windows Vista 和 Windows Server 2008 上为本地管理配置报表服务器。

将自定义配置设置复制到 RSReportServer.config 文件

如果对先前安装中的 RSReportServer.config 文件或 RSWebApplication.config 文件进行过修改，则应当在新的 RSReportServer.config 文件中进行同样的修改。下面的列表概述了修改先前配置文件的某些原因，并提供了一些指向其他信息的链接，这些信息介绍如何在 SQL Server 2008 中配置同样的设置。

自定义 | 信息
具有自定义设置的报表服务器电子邮件传递 | 如何配置报表服务器以进行电子邮件传递（Reporting Services 配置）
数据处理扩展插件 | 在 Reporting Services 中配置数据处理扩展插件
设备信息设置 | 在 RSReportServer.Config 中自定义呈现扩展插件参数
远程实例上的报表管理器 | 如何配置报表管理器

Windows 服务组与安全 ACL

在 SQL Server 2008 Reporting Services 中存在一个服务组，即 Reporting Services Windows 服务组。可使用该组为与 SQL Server 2008 Reporting Services 一起安装的所有注册表项、文件和文件夹创建安全 ACL。此 Windows 组的名称以 SQLServerReportServerUser$<计算机名>$<实例名> 格式显示。此组将取代 SQL Server 2005 Reporting Services 中的两个 Windows 服务组。如果您已将自定义 ACL 与任一 SQL Server 2005 Reporting Services Windows 组相关联，则需要将这些 ACL 应用于SQL Server 2008 Reporting Services 中新报表服务器实例的新组。

验证部署

  1. 打开浏览器，并在 URL 地址中键入报表服务器虚拟目录和报表管理器虚拟目录，对这些目录进行测试。有关详细信息，请参阅如何验证 Reporting Services 安装。

  2. 测试报表，并验证它们是否包含所需的数据。检查数据源信息，查看是否仍指定了数据源连接信息。报表服务器在处理和呈现报表时使用 SQL Server 2008 报表对象模型，但是它不将 SQL Server 2000 或 2005 构造替换为新的报表定义语言元素。若要了解有关如何在 SQL Server 2008 报表服务器上运行现有报表的详细信息，请参阅升级报表。

删除未使用的程序和文件

一旦成功将报表服务器迁移到 SQL Server 2008 Reporting Services 实例，则可能需要执行以下步骤以删除不再需要的程序和文件。

  1. 如果不再需要早期版本的 Reporting Services，则将其卸载。此步骤不会删除下列项，但是，如果不再需要这些项，则可以手动将其删除：

    • 旧的报表服务器数据库

    • RsExec 角色

    • 报表服务器服务帐户

    • 报表服务器 Web 服务的应用程序池

    • 报表管理器和报表服务器的虚拟目录

    • 报表服务器日志文件

  2. 如果此计算机上不再需要 IIS，则将其删除。

  3. 删除 RSActivate.exe（仅限 SQL Server 2000 安装中）。

请参阅

概念

升级 Reporting Services 的注意事项

其他资源

报表服务器数据库
Reporting Services 的向后兼容性
Reporting Services 配置工具


配置 SQL Server 2008

配置 SQL Server 2008 |
 | 请参阅

安装好 SQL Server 后，可以使用图形化实用工具和命令提示符实用工具进一步配置 SQL Server。下表说明了为管理 SQL Server 实例提供的工具支持：

工具或实用工具 | 说明
SQL Server Management Studio | SQL Server Management Studio 用于编辑和执行查询，并用于启动标准向导任务。有关详细信息，请参阅SQL Server Management Studio 简介。
SQL Server Profiler | SQL Server Profiler 提供了用于监视 SQL Server 数据库引擎实例或 Analysis Services 实例的图形用户界面。有关详细信息，请参阅 SQL Server Profiler 简介。
数据库引擎优化顾问 | 数据库引擎优化顾问可协助您创建索引、索引视图和分区的最佳组合。有关详细信息，请参阅使用数据库引擎优化顾问。
Business Intelligence Development Studio | Business Intelligence Development Studio 是用于 Analysis Services 和 Integration Services 解决方案的集成开发环境。有关详细信息，请参阅介绍 Business Intelligence Development Studio。
命令提示实用工具 | 可以通过命令提示符管理 SQL Server 对象。有关详细信息，请参阅命令提示实用工具。
SQL Server 配置管理器 | 可以管理服务器和客户端网络配置设置。有关详细信息，请参阅 SQL Server 配置管理器。
导入和导出数据 | Integration Services 提供了一套用于移动、复制及转换数据的图形化工具和可编程对象。有关详细信息，请参阅 概述 (Integration Services)。
SQL Server 安装程序 | 安装、升级到或更改 SQL Server 实例中的组件。有关详细信息，请参阅安装操作指南主题。

请参阅

概念

配置 Reporting Services

其他资源

管理（数据库引擎）


验证 SQL Server 安装

验证 SQL Server 安装 |
 | 请参阅
配置 SQL Server 2008 >

若要验证 SQL Server 2008 是否安装成功，请确保您选择安装的组件的服务正在计算机上运行。

使用以下服务列表验证正在运行 SQL Server 服务。下表列出服务显示名以及它们所提供的服务。

注意：
实际服务名称与其显示名称略有不同。通过右键单击某一服务并选择“属性”可以查看服务名称。

如果相应服务没有运行，请启动该服务，方法是：右键单击该服务，再单击“启动”。如果某一服务无法启动，则请检查此服务属性中的 .exe 文件的路径。确保指定的路径中存在相应的 .exe 文件。

名称 | 服务
SQL Server (MSSQLSERVER) | SQL Server 数据库引擎的默认实例。
SQL Server (实例名) | SQL Server 数据库引擎的命名实例，其中实例名 是实例的名称。
SQL Server Agent (MSSQLSERVER) | SQL Server 代理的默认实例。SQL Server 代理用于执行作业、监视 SQL Server、激发警报以及允许自动执行某些管理任务。
SQL Server Agent (实例名) | SQL Server 代理的命名实例，其中实例名 是实例的名称。SQL Server 代理用于执行作业、监视 SQL Server、激发警报以及允许自动执行某些管理任务。
Analysis Services (MSSQLSERVER) | Analysis Services 的默认实例。
Analysis Services (实例名) | Analysis Services 的命名实例，其中实例名 是实例的名称。
Reporting Services | Reporting Services 的默认实例。
Reporting Services (实例名) | Reporting Services 的命名实例，其中实例名 是实例的名称。

请参阅

任务

如何阅读 SQL Server 安装日志文件

概念

如何查看 SQL Server 安装日志文件


配置 Reporting Services

配置 Reporting Services |
 | 请参阅
配置 SQL Server 2008 >

使用 Reporting Services 配置工具可对 SQL Server Reporting Services 安装进行配置。如果使用仅安装文件选项安装报表服务器，必须使用此工具来配置服务器，否则服务器将不可用。如果以前安装报表服务器时使用的是默认配置安装选项，则可以使用此工具来验证或修改在安装过程中指定的设置。如果从以前的版本升级，可以使用此工具将报表服务器数据库升级为新格式。

Reporting Services 配置工具可以用来配置本地或远程报表服务器实例。您必须对承载要配置的报表服务器的计算机具有本地系统管理员权限。

本节内容

主题 | 说明
配置报表服务器服务帐户 | 提供有关如何修改服务帐户和密码的建议和步骤。
配置报表服务器 URL | 介绍如何配置用来访问报表服务器 Web 服务和报表管理器的 URL。
创建报表服务器数据库 | 介绍如何创建存储服务器元数据和对象所必需的报表服务器数据库。
配置报表服务器数据库连接 | 介绍如何修改报表服务器用来连接报表服务器数据库的连接字符串。
配置无人参与的执行帐户 | 介绍如何配置用户帐户以便以无人参与的方式处理报表。
配置报表服务器以进行电子邮件传递 | 介绍如何配置报表服务器，以便通过电子邮件来分发报表。
为扩展部署配置 Reporting Services | 提供有关配置多个报表服务器实例以使用共享报表服务器数据库的信息。
将 Reporting Services 配置为 SharePoint 3.0 集成模式 | 概要介绍向 SharePoint 产品或技术的现有部署添加报表服务器的任务及要求
配置和管理加密密钥 | 介绍如何使用和管理存储敏感数据时使用的加密密钥。
Reporting Services 配置操作指南主题 | 提供常见任务的分步说明。
Reporting Services 配置的 F1 帮助主题 | 提供有关 Reporting Services 配置工具页面的帮助主题。

在 SQL Server 联机丛书中

Reporting Services 配置工具的联机帮助只是 SQL Server Reporting Services 产品文档的一部分。您可在 SQL Server 联机丛书中找到完整的产品文档。

当使用 SQL Server 联机丛书时，可以访问此联机帮助系统提供的所有主题，以及关于部署、管理和保护 Reporting Services 安装的其他内容。有关详细信息，请参阅 SQL Server 联机丛书入门。

请参阅

概念

安装 Reporting Services 的注意事项

其他资源

全新安装 (Reporting Services)
升级 (Reporting Services)
配置报表服务器安装


配置报表服务器服务帐户

配置报表服务器服务帐户 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services >

Reporting Services 是作为单个服务实现的，其中包含报表服务器 Web 服务、报表管理器以及用于计划的报告处理和订阅传递的后台处理应用程序。本主题说明最初如何配置服务帐户以及如何使用 Reporting Services 配置工具修改帐户或密码。有关在服务中运行的应用程序的详细信息，请参阅 SQL Server 联机丛书中的服务体系结构 (Reporting Services)。

初始配置

报表服务器服务帐户是在安装过程中定义的。可以在域用户帐户或内置帐户（如 NetworkService 帐户）下运行服务。没有默认帐户；您在安装向导的 SQL Server 配置 - 服务帐户页中指定的任何帐户都将成为报表服务器服务的初始帐户。

重要提示：
尽管报表服务器 Web 服务和报表管理器均为 ASP.NET 应用程序，但它们不在 ASP.NET 帐户下运行。由单个服务体系结构在同一个报表服务器进程标识下运行这两个 ASP.NET 应用程序。与先前版本相比，这是一个重大的更改，在先前版本中，报表服务器 Web 服务和报表管理器均在 IIS 中指定的 ASP.NET 辅助进程标识下运行。

更改服务帐户

若要查看和重新配置服务帐户信息，请始终使用 Reporting Services 配置工具。服务标识信息在内部存储在多个位置上。使用该工具可确保在更改帐户或密码的同时相应地更新所有引用。Reporting Services 配置工具将执行以下附加步骤以确保报表服务器仍然可用：

  • 自动将新帐户添加到本地计算机上创建的报表服务器组中。此组是在用于保护 Reporting Services 文件的访问控制列表 (ACL) 中指定的。

  • 自动更新用于承载报表服务器数据库的 SQL Server 数据库引擎实例的登录权限。新帐户将添加到 RSExecRole。

    旧帐户的数据库登录名不会被自动删除。请务必删除不再使用的帐户。有关详细信息，请参阅管理报表服务器数据库。

    只有在首先将报表服务器数据库连接配置为使用新服务帐户的情况下，才需要将数据库权限授予该服务帐户。如果将报表服务器数据库连接配置为使用域用户帐户或 SQL Server 数据库登录名，连接信息将不受服务帐户更新的影响。

  • 自动更新加密密钥，以包括新帐户的配置文件信息。

    注意：
    如果报表服务器是扩展部署的一部分，则只有正在更新的报表服务器会受到影响。该部署中的其他报表服务器的加密密钥不会受到服务帐户更改的影响。

有关如何设置帐户的说明，请参阅如何为 Reporting Services 配置服务帐户。

选择帐户

可以将报表服务器服务配置为在以下任何帐户类型下运行：

  • 具有最小权限的 Windows 用户帐户

  • NetworkService

  • LocalSystem

  • LocalService

没有用来选择帐户类型的唯一最佳方法。每个帐户都有优点和缺点，选择时必须予以考虑。如果在生产服务器上部署 Reporting Services，则最好将服务配置为在域用户帐户下运行，以避免共享帐户遭恶意用户破坏后造成大范围的损害。这样做还能更轻松地审核该帐户的登录活动。使用 Windows 用户帐户的折中方案为：如果在使用 Kerberos 身份验证的网络中部署 Reporting Services，则必须用该用户帐户来注册服务。有关详细信息，请参阅如何为报表服务器注册服务主体名称 (SPN)。

本部分中的下列指南和链接可以帮助您确定部署的最佳方法。

  • 服务帐户（Reporting Services 配置）。

  • SQL Server 联机丛书中的设置 Windows 服务帐户。

  • 服务和服务帐户安全计划指南（位于 MSDN 上）。

更新过期密码

如果报表服务器服务在域帐户下运行，并且密码还未在 Reporting Services 配置工具中更新就已过期，则指定新密码之前，该服务将无法启动。如果服务无法启动，则不能使用 Reporting Services 配置工具连接到该服务器以更新帐户。在这种情况下，必须使用多种工具来使服务器恢复联机状态。

若要重置密码，请执行下列操作：

  1. 在“开始”菜单上，依次指向“控制面板”和“管理工具”，然后单击“服务”。

  2. 右键单击“SQL Server Reporting Services”，然后选择“属性”。

  3. 单击“登录”，然后键入新密码。

  4. 更新密码后，启动 Reporting Services 配置工具并在“服务帐户”页中更新密码。若要更新由报表服务器存储在内部的帐户信息，必须执行此附加步骤。

如果数据库引擎的服务帐户密码已过期，则尝试连接到报表服务器时，将出现 rsReportServerDatabaseUnavailable 错误。重置密码可以解决此错误。若要查看错误消息的完整文本，请参阅服务器和数据库连接故障排除。

为 SharePoint 集成报表服务器配置报表服务器服务

如果在 SharePoint 集成模式下运行报表服务器，且符合下列条件之一，则必须更新存储在 SharePoint 配置数据库中的服务帐户信息。

  • 修改 Reporting Services 服务帐户（例如，从 NetworkService 帐户切换到域用户帐户）。

  • 扩展 SharePoint 场以包含其他 SharePoint Web 应用程序。如果服务器场是针对报表服务器集成配置的，且配置的用于运行新添加的应用程序的用户帐户与用于运行该场中其他应用程序的用户帐户不同，则必须更新数据库访问信息。

重置数据库访问信息后，应当重新启动 Windows SharePoint Services 服务以确保不再使用旧连接。

  1. 在“管理工具”中，单击“SharePoint 3.0 管理中心”。

  2. 单击“应用程序管理”。

  3. 在“Reporting Services”部分中，单击“授予数据库访问权限”。

  4. 单击“确定”。将出现“输入凭据”对话框。

  5. 输入用户凭据，该用户必须是报表服务器所在的计算机上本地管理员组的成员。这些凭据将用于一次性连接到报表服务器计算机以便检索服务帐户信息。在 SharePoint 数据库中将对为每个服务帐户创建的数据库登录名进行更新。

  6. 若要重新启动服务，请单击“操作”。

  7. 在“拓扑和服务”中，单击服务器上的服务”。

  8. 对于 Windows SharePoint Services Web 应用程序，单击“停止”。

  9. 等待服务停止。

  10. 单击“启动”。

有关详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

请参阅

任务

如何为 Reporting Services 配置服务帐户
如何启动 Reporting Services 配置

参考

服务帐户（Reporting Services 配置）
设置 Windows 服务帐户

概念

配置报表服务器 URL

其他资源

部署 (Reporting Services)
规划服务、帐户和连接
启动和停止报表服务器服务


配置报表服务器 URL

配置报表服务器 URL |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services >

在 Reporting Services 中，URL 用于访问报表服务器 Web 服务和报表管理器。在可以使用任何应用程序之前，必须分别为 Web 服务和报表管理器至少配置一个 URL。Reporting Services 为这两个应用程序 URL 都提供了默认值，它们在大多数部署方案中都能正常使用，包括与其他 Web 服务和应用程序的并行部署。

  • 如果安装了默认配置，则使用默认值自动创建 URL。

  • 如果使用 Reporting Services 配置工具创建或修改 URL，则可以接受 URL 的默认值或指定自定义值。定义 URL 时页面上会出现该 URL 的测试链接，以便可以立即确认指定的设置是否为有效连接。有关如何配置和测试 URL 的分步说明，请参阅如何配置 URL（Reporting Services 配置）。

定义报表服务器 URL

URL 精确标识了网络上报表服务器应用程序实例的位置。创建报表服务器 URL 时，必须指定以下部分。

组成部分 | 说明
主机名 | TCP/IP 网络使用 IP 地址来唯一标识网络上的设备。计算机中安装的每个网络适配器都有一个物理 IP 地址。如果 IP 地址解析为主机标头，则可以指定主机标头。如果要将报表服务器部署到企业网络上，则可以使用计算机的网络名称。
端口 | TCP 端口是设备上的端点。报表服务器将侦听指定端口上的请求。
虚拟目录 | 端口通常由多个 Web 服务或应用程序共享。为此，报表服务器 URL 始终包括与获取请求的应用程序对应的虚拟目录。您必须为侦听同一 IP 地址和端口的每个 Reporting Services 应用程序都指定唯一的虚拟目录名称。
SSL 设置 | 可以将 Reporting Services 中的 URL 配置为使用计算机中先前安装的现有 SSL 证书。有关详细信息，请参阅配置报表服务器用于安全套接字层 (SSL) 连接。

默认 URL

通过 URL 访问报表服务器或报表管理器时，该 URL 应包括主机名称而不是 IP 地址。在 TCP/IP 网络上，IP 地址将解析为主机名称（或计算机的网络名称）。如果使用了默认值配置 URL，则应可以使用将计算机名称或 localhost 指定为主机名的 URL 来访问报表服务器 Web 服务：

  • http://<计算机名称>/reportserver

  • http://localhost/reportserver

下表中显示了使这些 URL 可用的设置。该表显示了通过包含主机名的 URL 来启用报表服务器连接的默认值：

组成部分 | 值 | 说明
IP 地址 | 所有已分配的值 | 网络上的域名服务将 URL 上的主机名解析为计算机的 IP 地址。只要定义的 URL 中指定了 IP 地址，发送到特定主机的请求便将到达其预期目标。
端口 | 80 | 端口 80 是计算机上进行 TCP/IP 连接的默认端口。因为报表服务器侦听的是端口 80，所以可以忽略 URL 中的端口号。如果指定另一个端口，则必须在 URL 中指定该端口。
虚拟目录 | ReportServer | 请注意，这两个示例 URL 都包括虚拟目录名称。除非自定义 URL 定义，否则必须始终在 URL 中指定该应用程序的虚拟目录名称。
注意：
基本 URL 保留项可启用将在 URL 中使用的任何有效主机名。Reporting Services 配置工具可使用允许将主机名变体解析为特殊报表服务器实例的语法在 HTTP.SYS 中创建一个 URL 保留项。有关 URL 保留项的详细信息，请参阅关于 URL 保留和注册 (Reporting Services)。

对报表服务器 URL 的服务器端权限

每个 URL 端点的权限都以独占方式授予报表服务器服务帐户。只有此帐户有权接受定向到 Reporting Services URL 的请求。通过安装程序或 Reporting Services 配置工具配置服务标识时，创建并维护该帐户的随机访问控制列表 (DACL)。如果更改服务帐户，Reporting Services 配置工具将更新您创建的所有 URL 保留项以拾取新的帐户信息。有关详细信息，请参阅 URL 保留语法 (Reporting Services)。

对发送到报表服务器 URL 的客户端请求进行身份验证

默认情况下，URL 端点上支持的身份验证类型为 Windows 身份验证。这是默认的安全扩展插件。如果要实现自定义或窗体身份验证提供程序，则必须修改报表服务器上的身份验证设置。还可以选择更改 Windows 身份验证设置以匹配网络中使用的身份验证子系统。有关详细信息，请参阅在 Reporting Services 中配置身份验证。

本节内容

如何配置 URL（Reporting Services 配置）

本主题提供了在 Reporting Services 配置工具中设置和修改 URL 保留项的说明。

关于 URL 保留和注册 (Reporting Services)

URL 用于访问应用程序和报表。本主题说明了 Reporting Services 中的应用程序 URL、默认 URL 以及 URL 保留和注册的工作方式。

URL 保留语法 (Reporting Services)

Reporting Services 使用的默认 URL 保留项对于大多数情况都是有效的。但是，如果要限制访问权限或扩展部署以启用 Internet 或 Extranet 访问，则可能要自定义设置以适合您的要求。本主题说明了 URL 保留项的语法并为如何创建针对特定部署的自定义保留项提供了建议。

配置文件中的 URL (Reporting Services)

RSReportServer.config 文件包含了 URL 保留项的多个条目以及由报表管理器和报表服务器电子邮件传递使用的 URL。本主题概述了 URL 配置设置以便您可以了解它们之间如何进行比较。

多实例报表服务器部署的 URL 保留项

当在一台计算机中安装多个 Reporting Services 实例时，如果已注册某个 URL，便会增加 URL 重复的可能性。若要避免这些错误，请遵循本主题中针对创建特定于实例的 URL 保留项的建议。

请参阅

任务

如何配置 URL（Reporting Services 配置）

概念

Web 服务 URL（Reporting Services 配置）

其他资源

RSReportServer 配置文件
使用 SharePoint 2.0 Web 部件查看报表
配置报表服务器用于安全套接字层 (SSL) 连接
配置报表服务器安装


关于 URL 保留和注册 (Reporting Services)

关于 URL 保留和注册 (Reporting Services) |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > 配置报表服务器 URL >

Reporting Services 应用程序的 URL 在 HTTP.SYS 中定义为 URL 保留项。URL 保留项定义了指向 Web 应用程序的 URL 端点的语法。在报表服务器上配置应用程序时，将定义报表服务器 Web 服务和报表管理器的 URL 保留项。通过安装程序或 Reporting Services 配置工具配置 URL 时，会自动为您创建 URL 保留项：

  • 安装程序将使用默认值创建 URL 保留项。如果安装程序安装默认配置，它将保留两个 URL；一个是报表服务器 Web 服务的 URL，另一个是为报表管理器保留的 URL。您可以使用 Reporting Services 配置工具添加更多 URL 或修改安装程序创建的默认 URL。

  • Reporting Services 配置工具将根据您在此工具的“Web 服务 URL”或“报表管理器 URL”页中指定的 URL 创建 URL 保留项。

安装程序和此工具都还会为报表服务器服务分配对 URL 的权限、检查有无重复实例并向 HTTP.SYS 添加 URL 保留项。切勿使用 HttpCfg.exe 或其他工具直接创建或修改 Reporting Services URL 保留项。如果您跳过了某一步骤或设置了无效的值，您将会遇到可能难以诊断或修复的问题。

注意：
HTTP.SYS 是一个操作系统组件，用于侦听网络请求并将它们路由至请求队列。在此版本的 Reporting Services 中，HTTP.SYS 为报表服务器 Web 服务和报表管理器建立和维护请求队列。Internet Information Services (IIS) 不再用于承载或访问 Reporting Services 应用程序。有关 HTTP.SYS 功能的详细信息，请参阅 MSDN 上的 HTTP Server API（HTTP 服务器 API）。

主题内容

本主题介绍 URL、URL 保留和注册、默认值，以及在为不同的服务器配置创建或修改 URL 时应遵循的一些特定于部署的建议。本主题包含以下部分：

  • Reporting Services 中的 URL

  • URL 保留和注册

  • 默认 URL

  • Reporting Services URL 的身份验证和服务标识

  • 用于本地管理的 URL

  • 用于扩展部署的 URL

  • 用于 SharePoint 集成模式的 URL

有关 Reporting Services 安装中的 URL 构造和使用或者对保留或注册错误进行故障排除的详细信息，请参阅配置报表服务器 URL 和配置错误故障排除。

Reporting Services 中的 URL

在 Reporting Services 安装中，可以通过 URL 访问以下工具、应用程序和项：

  • 报表服务器 Web 服务

  • 报表管理器

  • 报表生成器

  • 已发布到报表服务器的报表

不应通过 URL 将其他已发布的、可通过 URL 寻址的项（如模型和共享数据源）作为独立项进行访问。当在浏览器窗口中查看这些项时，报表服务器不会以有意义的格式显示这些项。

注意：
本主题不讨论对报表生成器或存储在报表服务器上的特定报表的 URL 访问。有关通过 URL 对这些项进行访问的详细信息，请参阅 SQL Server 联机丛书中的启动报表生成器和Using a URL to Access Report Server Items。

URL 保留和注册

URL 保留项定义了可用于访问 Reporting Services 应用程序的 URL。Reporting Services 将在 HTTP.SYS 中为报表服务器 Web 服务和报表管理器保留一个或多个 URL，然后在服务启动时注册它们。指向报表生成器和报表的 URL 基于报表服务器 Web 服务 URL 保留项。通过向 URL 追加参数，可以通过 Web 服务打开报表生成器或报表。保留和注册由 HTTP.SYS 实现。有关详细信息，请参阅 MSDN 上的 Namespace Reservations, Registration, and Routing（命名空间保留、注册和路由）。

URL 保留是指创建指向 Web 应用程序的 URL 端点并将其存储在 HTTP.SYS 中的过程。HTTP.SYS 是计算机上定义的所有 URL 保留项的公共存储库，它定义了一组保证 URL 保留项唯一的公共规则。

URL 注册在服务启动时进行。此时会创建请求队列，并且 HTTP.SYS 开始将请求路由到该队列。必须先注册 URL 端点，然后再将定向至该端点的请求添加到该队列。当报表服务器服务启动时，它将注册已为所有启用的应用程序保留的所有 URL。也就是说，必须启用 Web 服务，才能进行注册。如果在外围应用配置器中，对于基于策略的管理的 Reporting Services 方面将 WebServiceAndHTTPAccessEnabled 属性设置为 False，则 Web 服务的 URL 在该服务启动时将不会注册。

如果停止服务或回收 Web 服务或报表管理器应用程序域，则会撤消注册 URL。如果在服务正在运行时修改 URL 保留项，报表服务器将会立即回收应用程序域，以便可以撤消注册旧的 URL，开始注册新的 URL。

下面几个简单的示例说明了 URL 保留项的概念以其与用于 Reporting Services 应用程序的 URL 地址之间的关联。需要注意一个关键点，即 URL 保留项与用于访问应用程序的 URL 具有不同的语法：

HTTP.SYS 中的 URL 保留项 | URL | 说明
http://+:80/reportserver | http://<计算机名称>/reportserver http://<IP 地址>/reportserver http://localhost/reportserver | 此 URL 保留项针对端口 80 指定了一个通配符 (+)。这会将指定主机（在端口 80 上解析为报表服务器计算机）的任何传入请求放入报表服务器队列中。请注意，借助此 URL 保留项，可以使用任意数目的 URL 访问报表服务器。 对于大多数操作系统而言，这是 Reporting Services 报表服务器的默认 URL 保留项。
http://123.45.67.0:80/reportserver | http://123.45.67.0/reportserver | 此 URL 保留项指定了一个 IP 地址，与通配符 URL 保留项相比，其限制性要强很多。只能使用包含此 IP 地址的 URL 连接到报表服务器。如果给定此 URL 保留项，则以 http://<计算机名称>/reportserver 或 http://localhost/reportserver 对报表服务器的请求将失败。

默认 URL

如果在默认配置中安装 Reporting Services，安装程序将为报表服务器 Web 服务和报表管理器保留 URL。在 Reporting Services 配置工具中定义 URL 保留项时，也可以接受这些默认值。如果安装 SQL Server Express 或安装 Reporting Services 作为命名实例，则默认 URL 将包含实例名称。

重要提示：
实例字符为下划线字符 (_)。

URL 保留项包含一个端口号。以下操作系统将允许多个 Web 应用程序共享一个端口：Windows Server 2003、Windows Vista 和 Windows Server 2008。如果您使用的是 Windows XP，请确保使用唯一的端口。

实例类型 | 应用程序 | 默认 URL | HTTP.SYS 中的实际 URL 保留项
默认实例 | 报表服务器 Web 服务 | http://<服务器名称>/reportserver | http://<服务器名称>:80/reportserver
默认实例 | 报表管理器 | http://<服务器名称>/reportserver | http://<服务器名称>:80/reportserver
命名实例 | 报表服务器 Web 服务 | http://<服务器名称>/reportserver_<实例名称> | http://<服务器名称>:80/reportserver_<实例名称>
命名实例 | 报表管理器 | http://<服务器名称>/reports_<实例名称> | http://<服务器名称>:80/reports_<实例名称>
SQL Server Express | 报表服务器 Web 服务 | http://<服务器名称>/reportserver_SQLExpress | http://<服务器名称>:80/reportserver_SQLExpress
SQL Server Express | 报表管理器 | http://<服务器名称>/reports_SQLExpress | http://<服务器名称>:80/reports_SQLExpress

Reporting Services URL 的身份验证和服务标识

Reporting Services URL 保留项指定了报表服务器服务的服务帐户。运行服务的帐户用于为运行在同一实例上的 Reporting Services 应用程序创建的所有 URL。报表服务器实例的服务标识存储在 RSReportServer.config 文件中。

服务帐户没有默认值。但是，在安装过程中需要指定服务帐户，即使以“仅文件”模式安装服务器，也会在 RSReportServer.config 中的 URLReservation 中指定服务帐户。服务帐户的有效值包括域用户帐户、LocalSystem 或 NetworkService。

因为默认安全性为 RSWindowsNegotiate，所以匿名访问已禁用。对于 Intranet 访问，报表服务器 URL 使用网络计算机名称。如果要为 Internet 连接配置 Reporting Services，必须使用其他设置。有关详细信息，请参阅规划 Extranet 或 Internet 部署。有关身份验证的详细信息，请参阅在 Reporting Services 中配置身份验证。

用于本地管理的 URL

如果您为 URL 保留项指定了强通配符或弱通配符，则可以分别使用 http://localhost/reportserver 或 http://localhost/reports。

http://localhost URL 将解释为 http://127.0.0.1。如果您将 URL 保留项限定为计算机名称或单个 IP 地址，则除非在本地计算机上为 127.0.0.1 创建附加保留项，否则将无法使用 localhost。同样，如果您的计算机上禁用 localhost 或 127.0.0.1，也无法使用该 URL。

Windows Vista 和 Windows Server“Longhorn”新增了一些安全功能，以便最大程度地降低无意中以提升的特权运行程序的风险。还需要执行一些其他步骤，才能在这些操作系统上启用本地管理。有关详细信息，请参阅如何在 Windows Vista 和 Windows Server 2008 上为本地管理配置报表服务器。

用于扩展部署的 URL

此版本中没有这一部分的相关信息。

SharePoint 集成模式下的报表服务器的 URL

如果独立报表服务器配置为在较大的 SharePoint 产品或技术部署中运行，则 URL 和虚拟目录构造将在以下几个方面受到影响：

  • 报表及其他项的 URL 通过 SharePoint Web 应用程序 URL 进行寻址。如果通过 URL 访问特定报表，请始终使用包含站点路径、文档库、项名称和文件扩展名（例如，报表的扩展名为 .rdl）的完全限定的 URL。在报表中引用共享数据源和模型以及在为对报表服务器的发布操作指定目标服务器和文件夹时，必须指定完全限定的 URL。

  • 文件扩展名用来区分不同类型的报表服务器项。有效的扩展名包括用于报表定义的 .rdl、用于报表模型的 .smdl 以及用于为 SharePoint 站点创建的共享数据源的 .rsds。

  • 尽管 SharePoint 产品和技术具有为自身定义的 URL 保留项，但在发布到服务器时您可以忽略这种保留。对于 SharePoint Web 应用程序，URL 保留是内部操作。

  • 对于将集成的报表服务器和 SharePoint 技术实例安装在同一台计算机上的单服务器部署，不能使用 http://localhost/reportserver。如果使用 http://localhost 访问 SharePoint Web 应用程序，则必须使用非默认网站或唯一端口分配来访问报表服务器。此外，如果报表服务器与 SharePoint 场集成在一起，则对于部署中安装在远程计算机上的节点，对报表服务器的 localhost 访问将无法解析。

  • 不能为在 SharePoint 集成模式下运行的报表服务器配置报表管理器的 URL 保留项和端点。如果配置了这些项，则在 SharePoint 集成模式下部署报表服务器后，报表管理器将不再工作。此模式不支持报表管理器。

如果您集成了某个报表服务器扩展部署以便在较大的 SharePoint 产品或技术部署中运行，请对各报表服务器节点进行负载平衡，并定义指向该扩展部署的单个虚拟服务器 URL。报表服务器集成设置只允许您指定单个报表服务器 URL。如果是扩展部署，则此 URL 必须是该扩展部署中各服务器节点的访问点。

有关部署模式和发布项的 URL 要求的详细信息，请参阅 规划部署模式和将模型和共享数据源部署到 SharePoint 站点。

请参阅

任务

如何配置 URL（Reporting Services 配置）

概念

URL 保留语法 (Reporting Services)
本机模式安装默认配置 (Reporting Services)

其他资源

RSReportServer 配置文件
并行部署 Reporting Services 和 Internet Information Services


URL 保留语法 (Reporting Services)

URL 保留语法 (Reporting Services) |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > 配置报表服务器 URL >

本主题介绍报表服务器 Web 服务和报表管理器的 URL 字符串的各部分。该内部存储的 URL 字符串的结构不同于在浏览器窗口的地址栏中键入的 URL 的结构。URL 保留项字符串会在您配置 URL 时显示在 Reporting Services 配置工具的“结果”窗口中，也会出现在 RSReportServer.config 文件中。如果要解决 URL 保留项中存在的问题，或者要查询 HTTP.SYS 以查看服务器上定义的内部 URL 保留项，则了解该 URL 字符串的定义方式会很有用。

URL 语法

报表服务器 URL 存储在 UrlString 元素和 VirtualDirectory 元素中。将 UrlString 和 VirtualDirectory 区分为不同元素的原因是您可以具有多个 URL 字符串，但每个 Reporting Services 应用程序只有一个虚拟目录名。

在 HTTP.SYS 中，URL 保留项包括 UrlString 和 VirtualDirectory。URL 保留项的语法包含以下部分：

<scheme>://<hostname>:<port>/<virtualdirectory>

下表说明了每个属性及其有效值。

属性 有效值 说明

Scheme

http 或 https

针对非 SSL 连接和 SSL 连接的前缀。

Hostname

(+) 强通配符，相当于 IP 地址的值为“(所有已分配的)”。

(*) 弱通配符，相当于 IP 地址为“(所有未分配的)”。

完全限定域名

计算机名称

IP 地址 (IPV4)

IP 地址 (IPV6)

标识网络上的服务器。

(+) 强通配符是默认值。HTTP.SYS 将接受给定端口和虚拟目录组合的所有网络适配器上的所有请求。报表服务器将接受该端口上的任何请求。

(*) 弱通配符。HTTP.SYS 接受给定端口和虚拟目录组合的所有网络适配器上未由其他 URL 保留项处理的所有请求。

计算机名称是网络上计算机的 NETBIOS 名称。

完全限定域名包含域地址和服务器名，如域控制器或公共域名服务器中所注册的那样。

IP 地址 (IPV4) 是采用 IPV4 格式的、计算机网络适配器的 IP 地址：nnn.nnn.nnn.nnn。

IP 地址 (IPV6) 是采用 IPV6 格式的、计算机网络适配器的 IP 地址：<标头>:<标头>:nnn.nnn.nnn.nnn。

Port

80

443

<自定义>

端口 80 是与服务器之间的 HTTP 请求的标准端口。

端口 443 是用于 SSL 连接的标准端口。

您可以使用任何未被其他应用程序保留的端口。

Virtualdirectory

ReportServer[_InstanceName]

Reports[_InstanceName]

<自定义>

指定应用程序的名称。该值是一个字符串。默认情况下，Reporting Services 使用 ReportServer 和 Reports 作为报表服务器 Web 服务和报表管理器应用程序的应用程序名称。您可以根据需要使用不同的名称。

此值是必需的。它用于标识应用程序。

为每个应用程序实例仅指定一个虚拟目录。若要为同一实例中的同一应用程序创建多个 URL，可以创建 UrlString 的多个版本。若要为多个应用程序实例创建唯一的虚拟目录名，可以考虑将实例名称包含在虚拟目录名中，即使用下划线字符 (_) 追加实例名称。InstanceName 是可选的，但是如果同一台计算机上有多个实例，则建议使用此选项。有关如何为命名实例设置 URL 保留项的详细信息，请参阅多实例报表服务器部署的 URL 保留项。

虚拟目录的值不区分大小写。您可以使用任意字符串，只要它不包含 URL 分隔符或 URL 编码即可。

请参阅

任务

如何配置 URL（Reporting Services 配置）

概念

配置报表服务器 URL

其他资源

RSReportServer 配置文件


配置文件中的 URL (Reporting Services)

配置文件中的 URL (Reporting Services) |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > 配置报表服务器 URL >

Reporting Services 在 RSReportServer.config 文件中存储应用程序设置。在此文件内，有一些既用于 URL 又用于 URL 保留的配置设置。这些配置设置的用途和修改规则大不相同。如果您习惯于通过修改配置文件来优化部署，则本主题可帮助您了解每项 URL 设置的用法。

RSReportServer.config 文件中的 URL 设置

Reporting Services 存储用于进行应用程序和报表访问的 URL，以及将 Web 前端组件连接到后端报表服务器的 URL。

用于进行应用程序访问的 URL

URL 用于访问报表服务器 Web 服务和报表管理器。若要配置 URL，必须使用 Reporting Services 配置工具。该工具用于为 HTTP.SYS 中的每个应用程序创建 URL 保留，并为 RSReportServer.config 的 URLReservations 部分中的 URL 添加条目。

  • 若要查看 URLReservations 部分的每个元素的说明，请参阅 RSReportServer 配置文件。

  • 若要仅了解有关 UrlString 元素的语法的详细信息，请参阅 URL 保留语法 (Reporting Services)。

  • 有关如何配置用于应用程序访问的 URL 的说明，请参阅如何配置 URL（Reporting Services 配置）。

用于进行报表访问的 URL

Reporting Services 包括可用于发送报表链接或附件的报表服务器电子邮件传递扩展插件。传递报表时将构造报表链接。报表服务器电子邮件传递扩展插件使用配置文件中的 UrlRoot 设置来创建链接。UrlRoot 还用于解析通过无人参与的报表处理生成的呈现报表中的链接。

当您配置用于应用程序访问的 URL 时，将在 RSReportServer.config 文件中自动指定 UrlRoot。如果在配置文件中修改该值，则必须指定连接到报表服务器数据库（包含要传递的报表）的报表服务器 Web 服务的有效 URL 地址。您只可以为一个报表服务器实例指定一个 UrlRoot；对于任何给定的报表服务器实例，RSReportServer.config 文件中只能存在一个 UrlRoot 条目。如果您为报表服务器 Web 服务保留了多个 URL，则必须为 UrlRoot 选择其中一个可用值。

在大多数情况下，您无需修改 UrlRoot。然而，如果将通过完全限定的 URL 访问报表服务器，并且您未将使用主机标头的 URL 配置为完全限定的站点名称，则必须手动编辑 RSReportServer.config 以将 UrlRoot 设置为将用于呈现报表的完全限定的报表服务器 URL（例如，https://www.adventure-works.com/mywebapp/reportserver）。

用于将报表管理器和 Web 部件连接到报表服务器 Web 服务的 URL

报表管理器和 Reporting Services 的 SharePoint 2.0 Web 部件是连接到报表服务器的 Web 前端组件。用于连接到后端报表服务器的 URL 包括：

  • ReportServerUrl（由报表管理器使用）

  • ReportServerExternalUrl（由 Web 部件使用）

注意：
Reporting Services 的早期版本包括 ReportServerVirtualDirectory 元素。该值在 SQL Server 2008 中已过时。如果您已升级现有安装并正在使用包含此设置的配置文件，则报表服务器不再读取该值。

下表简要概括了所有可以在 Reporting Services 配置文件中指定的 URL。

设置 用法 说明

ReportServerUrl

可选。除非您自己添加此元素，否则此元素不包含在 RSReportServer.config 文件中。

仅当您配置以下方案之一时才应设置此元素：

  • 报表管理器提供对在另一台计算机上运行或在同一台计算机上的另一实例上运行的报表服务器 Web 服务的 Web 前端访问。

  • 当您有指向一个报表服务器的多个 URL，并且您希望报表服务器使用特定的 URL 时。

  • 您有特定的报表服务器 URL，您希望所有报表管理器连接均使用此 URL。

    例如，您可能为网络中的所有计算机都启用报表管理器访问，但需要报表管理器通过一个本地连接连接到报表服务器。在这种情况下，您可以将 ReportServerUrl 配置为“http://localhost/reportserver”。

有关如何实施这些方案的说明，请参阅如何配置报表管理器。

该值指定一个指向报表服务器 Web 服务的 URL。此值由报表管理器在启动时读取。如果已设置该值，则报表管理器将连接到此 URL 中指定的报表服务器。

默认情况下，报表管理器提供对与报表管理器运行在同一报表服务器实例中的报表服务器 Web 服务的 Web 前端访问。然而，如果希望将报表管理器与作为另一实例一部分或在另一台计算机的实例上运行的报表服务器 Web 服务一起使用，则可以将此 URL 设置为定向报表管理器使之连接到外部报表服务器 Web 服务。

如果安全套接字层 (SSL) 证书安装在您要连接的报表服务器上，则 ReportServerUrl 值必须是为获得此证书而注册的服务器的名称。如果出现“基础连接已经关闭: 未能为 SSL/TLS 安全通道建立信任关系”错误，请将 ReportServerUrl 设置成为其颁发 SSL 证书的服务器的完全限定域名。例如，如果向 https://adventure-works.com.onlinesales 注册了此证书，则报表服务器 URL 将为 https://adventure-works.com.onlinesales/reportserver。

ReportServerExternalUrl

可选。除非您自己添加此元素，否则此元素不包含在 RSReportServer.config 文件中。

仅当您使用的是 SharePoint 2.0 Web 部件且希望用户能够检索报表并在新的浏览器窗口中打开该报表时，才应设置此元素。

将 <ReportServerExternalUrl> 添加在 <ReportServerUrl> 元素下方，然后将其设置为在单独的浏览器窗口中被访问时解析为报表服务器实例的完全限定报表服务器名称。不要删除 <ReportServerUrl>。

下面的示例说明了相应的语法：

<ReportServerExternalUrl>http://myserver/reportserver</ReportServerExternalUrl>

该值由 SharePoint 2.0 Web 部件使用。

在早期版本中，建议您设置该值以在面向 Internet 的报表服务器上部署报表生成器。这是未经测试的部署方案。如果您在过去使用此设置支持对报表生成器的 Internet 访问，那么现在您应考虑使用替代策略。

请参阅

任务

如何配置 URL（Reporting Services 配置）

概念

配置报表服务器 URL

其他资源

RSReportServer 配置文件
如何修改 Reporting Services 配置文件
使用 SharePoint 2.0 Web 部件查看报表


多实例报表服务器部署的 URL 保留项

多实例报表服务器部署的 URL 保留项 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > 配置报表服务器 URL >

如果将多个 Reporting Services 实例安装在同一台计算机上，则必须考虑如何为每个实例定义 URL 保留项。在每个实例中，报表服务器 Web 服务和报表管理器都必须至少有一个 URL 保留项。整组保留项在 HTTP.SYS 中必须保持唯一。

在 URL 注册（发生在服务启动时）过程中会检测 URL 是否重复。如果您创建的 URL 保留项不唯一，那么，直到启动服务时，才会检测到名称冲突。因此，请确保遵循命名约定或规则以确保所有的值保持唯一。

默认的命名约定

可以将 Reporting Services 安装到 SQL Server 命名实例中。当您在命名实例中安装或配置报表服务器时，实例名称会自动包括在 Reporting Services 提供的默认 URL 保留项中的虚拟目录中。下表显示了默认实例和命名实例的 URL 保留项。

SQL Server 实例 | 默认 URL 保留项
默认实例 (MSSQLServer) | http://+:80/reportserver
命名实例 (MynamedInstance) | http://+:80/reportserver_MyNamedInstance

对于命名实例，虚拟目录中包括实例名称。默认实例和命名实例在同一个端口上侦听，但是唯一的虚拟目录名称确定了请求将由哪个报表服务器获取。

建议的最佳实践是使用虚拟目录名称来区分报表服务器实例，这样可在 URL 和目标实例之间提供清楚的对应关系，并确保应用程序名称在整个系统中保持唯一。

自定义命名约定

尽管建议使用实例名称，但是您可以使用 URL 语法和自己的命名约定来满足 URL 保留项的唯一名称约束。下面的示例说明了用来为每个实例创建唯一 URL 的不同方法。

报表服务器的默认实例 (MSSQLSERVER) | ReportServer_MyNamedInstance | 唯一性
http://+:80/reportserver | http://+:8888/reportserver | 每个实例都在一个不同的端口上侦听。
http://www.contoso.com/reportserver | http://SRVR-46/reportserver | 每个实例都对应不同的服务器名称（完全限定域名和计算机名称）。

唯一性要求

Reporting Services 使用的基础技术对于唯一名称施加了一定的要求。HTTP.SYS 要求其存储库中的所有 URL 保持唯一。您可以通过改变端口、主机名或虚拟目录名称来创建唯一的 URL。ASP.NET 要求同一个进程内的应用程序标识保持唯一。此要求会影响虚拟目录名称。它规定您不能在同一个报表服务器实例中复制虚拟目录名称。

请参阅

任务

如何配置 URL（Reporting Services 配置）

概念

配置报表服务器 URL
使用 SQL Server 的多个版本和实例


创建报表服务器数据库

创建报表服务器数据库 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services >

Reporting Services 使用两个 SQL Server 关系数据库存储报表服务器元数据和对象。一个数据库用于主存储，另一个数据库用于存储临时数据。这两个数据库一起创建，并按名称绑定。通过默认 SQL Server 实例，将这两个数据库命名为 reportserver 和 reportservertempdb。这两个数据库统称为“报表服务器数据库”或“报表服务器目录”。

重要提示：
请不要编写对报表服务器数据库运行查询的应用程序。报表服务器数据库不是公用架构。从一个版本升级到下一个版本时可能会更改表结构。如果编写一个需要访问报表服务器数据库的应用程序，则始终使用 Reporting Services API 来访问报表服务器数据库。

创建报表服务器数据库的方式

您可以通过以下方式创建报表服务器数据库：

  • 如果选择默认配置安装选项，则可通过安装程序自动创建。在 SQL Server 安装向导中，这是“报表服务器安装选项”页中的“安装本机模式默认配置”选项或“安装 SharePoint 集成模式默认配置”。如果选择“安装但不配置”选项，则必须使用 Reporting Services 配置工具来创建数据库。

  • 通过 Reporting Services 配置工具手动创建。如果使用远程 SQL Server 数据库引擎来承载该数据库，则必须手动创建报表服务器数据库。有关详细信息，请参阅如何创建报表服务器数据库（Reporting Services 配置）。

数据库服务器版本要求

SQL Server 用来承载报表服务器数据库：

  • SQL Server 2005 或 SQL Server 2008 可用来承载数据库。不要使用 SQL Server 2000 或更早版本的 SQL Server。

  • SQL Server 数据库引擎实例可以是本地或远程实例。

若要在远程计算机上创建报表服务器数据库，则需要将连接配置为使用域用户帐户或具有网络访问权限的服务帐户。如果决定使用远程 SQL Server 实例，请仔细考虑报表服务器应使用哪些凭据来连接 SQL Server 实例。有关详细信息，请参阅配置报表服务器数据库连接。

重要提示：
报表服务器和用于承载报表服务器数据库的 SQL Server 实例可位于不同的域中。对于 Internet 部署，通常的做法是使用防火墙后的服务器。如果要配置用于 Internet 访问的报表服务器，请使用 SQL Server 凭据连接到位于防火墙后的 SQL Server 实例并使用 IPSEC 保护连接的安全。

数据库服务器版本类别要求

创建报表服务器数据库时，请注意并非所有版本的 SQL Server 均可用来承载数据库。下表显示了可用于特定 Reporting Services 版本的数据库引擎版本。

对于此 SQL Server Reporting Services 版本 | 使用此版本的数据库引擎实例来承载数据库
具有高级服务的 SQL Server Express | 具有高级服务的 SQL Server Express（仅用于本地）
Web | Web Edition（仅用于本地）
Workgroup | Workgroup Edition（仅用于本地）
Evaluation | Standard Edition、Evaluation Edition、Enterprise Edition（本地或远程）
Developer | Standard Edition、Developer Edition、Enterprise Edition（本地或远程）
Standard | Standard Edition、Enterprise Edition（本地或远程）
Enterprise | Standard Edition、Enterprise Edition（本地或远程）

请参阅

任务

如何创建报表服务器数据库（Reporting Services 配置）

其他资源

报表服务器数据库
管理报表服务器数据库
Developer's Guide (Reporting Services)


配置报表服务器数据库连接

配置报表服务器数据库连接 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services >

每个报表服务器实例都需要连接到存储由服务器管理的报表、报表模型、共享数据源、资源和元数据的报表服务器数据库。如果要安装默认配置，则可以在报表服务器安装过程中创建初始连接。多数情况下，可以在安装程序完成之后使用 Reporting Services 配置工具配置连接。您可以随时修改连接，以更改帐户类型或重置凭据。有关如何创建数据库并配置连接的分步说明，请参阅如何创建报表服务器数据库（Reporting Services 配置）。

如果出现下列情况，则必须配置报表服务器数据库连接：

  • 为首次使用配置报表服务器。

  • 配置报表服务器以使用不同的报表服务器数据库。

  • 更改数据库连接所使用的用户帐户或密码。当帐户信息存储在 RSReportServer.config 文件中时，您只需要更新数据库连接。如果使用服务帐户进行连接（该帐户使用 Windows 集成安全性作为凭据类型），则不会存储密码，从而无需更新连接信息。有关更改帐户的详细信息，请参阅配置报表服务器服务帐户。

  • 配置报表服务器扩展部署。配置扩展部署时，您需要创建多个到报表服务器数据库的连接。有关如何执行此多步操作的详细信息，请参阅如何配置报表服务器扩展部署（Reporting Services 配置）。

Reporting Services 如何连接到数据库引擎

报表服务器根据凭据和连接信息以及对使用该数据库的报表服务器实例有效的加密密钥来访问报表服务器数据库。拥有有效的加密密钥对于存储和检索敏感数据是必要的。首次配置数据库时，会自动创建加密密钥。创建密钥之后，如果更改报表服务器服务标识，则必须更新这些密钥。有关使用加密密钥的详细信息，请参阅配置和管理加密密钥。

报表服务器数据库为内部组件，只有报表服务器可以访问。为报表服务器数据库指定的凭据和连接信息专门由报表服务器使用。请求报表的用户不需要拥有报表服务器数据库的数据库权限或数据库登录名。

Reporting Services 使用 System.Data.SqlClient 连接到承载报表服务器数据库的数据库引擎。如果使用的是数据库引擎的本地实例，报表服务器将使用共享内存建立连接。如果使用的是报表服务器数据库的远程数据库服务器，则可能必须根据所使用的版本启用远程连接。如果使用的是 Developer Edition，则默认情况下会关闭远程连接。如果使用的是 Enterprise Edition，则默认情况下会启用 TCP/IP 远程连接。

若要验证实例是否接受远程连接，请依次单击“开始”、“所有程序”、Microsoft SQL Server 2008、“配置工具”、“SQL Server 配置管理器”，然后确认为每个服务启用了 TCP/IP 协议。

启用远程连接时，也会启用客户端协议和服务器协议。若要确认协议已启用，请依次单击“开始”、“所有程序”、Microsoft SQL Server 2008、“配置工具”、“SQL Server 配置管理器”、“SQL Server 网络配置”，再单击“MSSQLSERVER 协议”。有关详细信息，请参阅如何启用或禁用服务器网络协议（SQL Server 配置管理器）。

定义报表服务器数据库连接

若要配置连接，必须使用 Reporting Services 配置工具或 rsconfig 命令行实用工具。报表服务器需要以下连接信息：

  • 承载报表服务器数据库的数据库引擎实例的名称。可以使用本地或远程 SQL Server 2005 或 SQL Server 2008 实例。

  • 报表服务器数据库的名称。首次创建连接时，可以创建新的报表服务器数据库，也可以选择现有的数据库。有关详细信息，请参阅创建报表服务器数据库。

  • 凭据类型。可以使用服务帐户、Windows 域帐户或 SQL Server 数据库登录名。

  • 用户名和密码（仅在使用 Windows 域帐户或 SQL Server 登录名时需要）。

必须为所提供的凭据授予访问报表服务器数据库的权限。如果使用 Reporting Services 配置工具，则此步骤会自动执行。有关访问数据库所需权限的详细信息，请参阅本主题中的“数据库权限”一节。

存储数据库连接信息

Reporting Services 在下列 RSreportserver.config 设置中存储和加密连接信息。必须使用 Reporting Services 配置工具或 rsconfig 实用工具为这些设置创建加密值。

并非所有的值都针对每一种连接类型进行了设置。如果使用默认值配置连接（即使用服务帐户建立连接），则 <LogonUser>、<LogonDomain> 和 <LogonCred> 将为空，如下所示：

复制代码
<Dsn></Dsn>
<ConnectionType></ConnectionType>
<LogonUser></LogonUser>
<LogonDomain></LogonDomain>
<LogonCred></LogonCred>

如果将连接配置为使用特定的 Windows 帐户或数据库登录名，则在随后更改帐户或登录名时必须更新已存储的值。

选择凭据类型

可以在报表服务器数据库连接中使用三种类型的凭据：

  • 使用报表服务器服务帐户的 Windows 集成安全性。由于报表服务器作为单个服务实现，因此只有运行服务的帐户需要数据库访问。

  • Windows 用户帐户。如果报表服务器和报表服务器数据库安装在同一台计算机上，则可以使用本地帐户。否则，必须使用域帐户。

  • SQL Server 登录名。

注意：
不能使用自定义身份验证扩展插件来连接到报表服务器数据库。自定义身份验证扩展插件只能用来对报表服务器的主体进行身份验证。它们不会影响报表服务器数据库的连接，也不会影响为报表提供内容的外部数据源的连接。

如果数据库引擎实例配置为使用 Windows 身份验证且与报表服务器计算机位于同一个域或可信域中，则可将连接配置为使用通过 Reporting Services 配置工具作为连接属性进行管理的服务帐户或域用户帐户。如果数据库服务器位于另一个域中，或者您使用的是工作组安全性，则必须将连接配置为使用 SQL Server 数据库登录名。在这种情况下，一定要对连接进行加密。有关详细信息，请参阅加密与 SQL Server 的连接。
使用服务帐户和集成安全性

可以使用 Windows 集成安全性通过报表服务器服务帐户进行连接。已为此帐户授予了登录报表服务器数据库的权限。如果以默认配置安装 Reporting Services，这将是安装程序选择的默认凭据类型。

此服务帐户为可信帐户，此帐户提供一种低维护方法来管理报表服务器数据库连接。由于此服务帐户使用 Windows 集成安全性来建立连接，因此无需存储凭据。但是，如果以后要更改服务帐户密码或标识（例如从内置帐户切换到域帐户），请确保使用 Reporting Services 配置工具进行更改。该工具会将数据库权限自动更新为使用修改后的帐户信息。有关详细信息，请参阅配置报表服务器服务帐户。

将数据库连接配置为使用服务帐户时，如果报表服务器数据库位于远程计算机上，则帐户必须拥有网络权限。如果报表服务器数据库位于不同的域中，并且位于防火墙之后，或者您使用的是工作组安全性而非域安全性，则不要使用服务帐户。请改用 SQL Server 数据库用户帐户。

使用域用户帐户

可以为报表服务器到报表服务器数据库的连接指定一个 Windows 用户帐户。如果使用本地帐户或域帐户，则每次更改密码或帐户时，必须更新报表服务器数据库连接。请始终使用 Reporting Services 配置工具来更新连接。

使用 SQL Server 登录名

可以指定使用一个 SQL Server 登录名连接到报表服务器数据库。如果使用 SQL Server 身份验证并且报表服务器数据库位于远程计算机上，则可以使用 IPSec 来协助保护服务器之间数据传输。如果使用数据库登录名，则每次更改密码或帐户时，必须更新报表服务器数据库连接。

数据库权限

用来连接到报表服务器数据库的帐户被授予了以下角色：

  • ReportServer 数据库的 public 和 RSExecRole 角色。

  • master、msdb 和 ReportServerTempDB 数据库的 RSExecRole 角色。

使用 Reporting Services 配置工具创建或修改连接时，将自动授予这些权限。如果使用 rsconfig 实用工具并且要为该连接指定不同的帐户，则必须为该新帐户更新 SQL Server 登录名。可以在 Reporting Services 配置工具中创建用来更新报表服务器的 SQL Server 登录名的脚本文件。

验证数据库名称

使用 Reporting Services 配置工具可以确定特定报表服务器实例所使用的报表服务器数据库。若要查找该名称，请连接到该报表服务器实例并打开“数据库安装”页。

使用不同的报表服务器数据库或移动报表服务器数据库

可以通过更改连接信息将报表服务器实例配置为使用不同的报表服务器数据库。切换数据库的一个常见示例是部署生产报表服务器。通常，生产服务器是通过从测试报表服务器数据库切换到生产报表服务器数据库来实现的。您还可以将报表服务器数据库移动到另一台计算机上。有关详细信息，请参阅将报表服务器数据库移至其他计算机和迁移 (Reporting Services)。

将多个报表服务器配置为使用同一个报表服务器数据库

可以将多个报表服务器配置为使用同一个报表服务器数据库。此部署配置称为扩展部署。如果要在服务器群集中运行多个报表服务器，则此配置为必备条件。但是，如果要将服务应用程序分段，或者要测试新的报表服务器实例的安装和设置以将其与现有报表服务器安装进行比较，则也以可使用此配置。有关详细信息，请参阅为扩展部署配置 Reporting Services。

请参阅

概念

创建报表服务器数据库
Reporting Services 配置操作指南主题
配置报表服务器服务帐户

其他资源

连接数据源 (Reporting Services)
配置报表服务器安装
RSReportServer 配置文件
rsconfig 配置工具


配置报表服务器以进行电子邮件传递

配置报表服务器以进行电子邮件传递 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services >

Reporting Services 包括电子邮件传递扩展插件，以便可以通过电子邮件分发报表。根据定义电子邮件订阅的方式，传递可能由通知、链接、附件或嵌入报表组成。电子邮件传递扩展插件可与现有的邮件服务器技术一起使用。邮件服务器必须是 SMTP 服务器或转发器。报表服务器通过操作系统提供的协作数据对象 (CDO) 库 (cdosys.dll) 连接到 SMTP 服务器。

默认情况下，未配置报表服务器电子邮件传递扩展插件。必须使用 Reporting Services 配置工具对此扩展插件进行最低配置。若要设置高级属性，必须编辑 RSReportServer.config 文件。如果无法将报表服务器配置为使用此扩展插件，则可以将报表传递到共享文件夹。有关详细信息，请参阅 Reporting Services 中的文件共享传递。

配置要求

  • 报表服务器电子邮件传递在协作数据对象 (CDO) 上实现，且需要本地或远程的简单邮件传输协议 (SMTP) 服务器或 SMTP 转发器。所有 Windows 操作系统都不支持 SMTP。如果使用的是基于 Itanium 的 Windows Server 2008 版本，则也不支持 SMTP。有关通过 CDO 提供的配置选项的详细信息，请参阅 MSDN 上的 Configuration（配置）。

  • 报表服务器服务帐户必须对 SMTP 服务器拥有权限才能发送邮件。

  • 电子邮件传递扩展插件在电子邮件附件中使用 UTF-8 编码。您无法修改此编码；HTML 呈现扩展插件仅支持 UTF-8。

注意：
默认电子邮件传递扩展插件不支持给待发邮件进行数字签名或加密。

为本地或远程的 SMTP 服务配置报表服务器

可以使用本地 SMTP 服务或远程 SMTP 服务器或转发器来支持电子邮件传递。如果具有现有远程 SMTP 服务器的访问权限，则应该考虑使用该服务器。若没有可用的 SMTP 服务器或随后由于计算机连接失败而遇到报表传递错误，则应该进行切换以使用本地 SMTP 服务。有关如何为本地或远程服务配置报表服务器的详细信息，将稍后在本主题中进一步说明。

为电子邮件传递设置配置选项

必须先设置确定使用哪一个 SMTP 服务器的配置值，才能使用报表服务器电子邮件传递。

若要针对电子邮件传递配置报表服务器，请执行下列操作：

  • 如果要仅指定一个 SMTP 服务器和一个具有发送电子邮件权限的用户帐户，则使用 Reporting Services 配置工具。以下是配置报表服务器电子邮件传递扩展插件所需的最低设置。有关详细信息，请参阅如何配置报表服务器以进行电子邮件传递（Reporting Services 配置）。

  • （可选）使用文本编辑器在 RSreportserver.config 文件中指定其他设置。此文件包含报表服务器电子邮件传递的所有配置设置。如果要使用本地 SMTP 服务器或将电子邮件限定传递到特定主机，则需要在这些文件中指定其他设置。有关查找和修改配置文件的详细信息，请参阅 SQL Server 联机丛书中的如何修改 Reporting Services 配置文件。

注意：
报表服务器电子邮件设置都是基于 CDO。若要了解有关特定设置的更多详细信息，可以参考 CDO 产品文档。

报表服务器电子邮件配置示例

下面的示例说明了远程 SMTP 服务器的 RSreportserver.config 文件中的设置：若要了解设置说明及有效值，请参阅 RSReportServer 配置文件或 CDO 产品文档。

复制代码
<RSEmailDPConfiguration>
     <SMTPServer>mySMTPServer.Adventure-Works.com</SMTPServer>
     <SMTPServerPort></SMTPServerPort>
     <SMTPAccountName></SMTPAccountName>
     <SMTPConnectionTimeout></SMTPConnectionTimeout>
     <SMTPServerPickupDirectory></SMTPServerPickupDirectory>
     <SMTPUseSSL></SMTPUseSSL>
     <SendUsing>2</SendUsing>
     <SMTPAuthenticate></SMTPAuthenticate>
     <From>my-rs-email-account@Adventure-Works.com</From>
     <EmbeddedRenderFormats>
          <RenderingExtension>MHTML</RenderingExtension>
     </EmbeddedRenderFormats>
     <PrivilegedUserRenderFormats></PrivilegedUserRenderFormats>
     <ExcludedRenderFormats>
          <RenderingExtension>HTMLOWC</RenderingExtension>
          <RenderingExtension>NULL</RenderingExtension>
     </ExcludedRenderFormats>
     <SendEmailToUserAlias>True</SendEmailToUserAlias>
     <DefaultHostName></DefaultHostName>
     <PermittedHosts>
          <HostName>Adventure-Works.com</HostName>
          <HostName>hotmail.com</HostName>
     </PermittedHosts>
</RSEmailDPConfiguration>

用于在邮件中设置“收件人:”字段的配置选项

根据“管理单独的订阅”任务授予的权限而创建的用户定义订阅包含基于域用户帐户的预设用户名。用户创建订阅时，“收件人:”字段中的收件人姓名会使用创建该订阅的人员的域用户帐户自行转换为地址。

如果您所用的 SMTP 服务器或转发器使用了不同于域用户帐户的电子邮件帐户，则 SMTP 服务器尝试将报表传递给该用户时，报表传递会失败。

若要解决该问题，可以修改允许用户在“收件人:”字段中输入名称的配置设置：

  1. 使用文本编辑器打开 RSReportServer.config。

  2. 将 SendEmailToUserAlias 设置为 False。

  3. 将 DefaultHostName 设置为 SMTP 服务器或转发器的域名系统 (DNS) 名称或 IP 地址。

  4. 保存该文件。

远程 SMTP 服务的配置选项

报表服务器与 SMTP 服务器或转发器之间的连接是由下列配置设置决定的：

  • SendUsing 指定发送邮件的方法。您可以选择网络 SMTP 服务或本地 SMTP 服务拾取目录。若要使用远程 SMTP 服务，必须在 RSReportServer.config 文件中将此值设置为 2。

  • SMTPServer 指定远程 SMTP 服务器或转发器。如果使用远程 SMTP 服务器或转发器，则必须指定此值。

  • “发件人”用于设置显示在电子邮件的“发件人:”行中的值。如果使用远程 SMTP 服务器或转发器，则必须指定此值。

其他用于远程 SMTP 服务的值包括以下值（请注意，除非您要覆盖默认值，否则无需指定这些值）：

  • SMTPServerPort 配置为端口 25。

  • SMTPAuthenticate 指定如何将报表服务器连接到远程 SMTP 服务器。默认值为 0（或不进行身份验证）。这种情况下，将通过匿名访问创建连接。报表服务器和 SMTP 服务器可能需要成为同一域的成员，这取决于域配置。

    若要向受限制的通讯组列表发送电子邮件（例如，只接受经过身份验证的帐户发来的邮件的通讯组列表），则将 SMTPAuthenticate 设置为 2。

本地 SMTP 服务的配置选项

若要测试报表服务器电子邮件传递或解决所遇到的疑难问题，则配置本地 SMTP 服务会很有用。默认情况下，不启用本地 SMTP 服务。有关如何启用该服务的说明，请参阅如何配置报表服务器以进行电子邮件传递（Reporting Services 配置）。

报表服务器与本地 SMTP 服务器或转发器之间的连接是由下列配置设置决定的：

  • 将 SendUsing 设置为 1。

  • 将 SMTPServerPickupDirectory 设置为本地驱动器中的文件夹。

    注意：
    如果正在使用本地 SMTP 服务器，请确保不要设置 SMTPServer。

  • “发件人”用于设置显示在电子邮件的“发件人:”行中的值。此值是必需的。

请参阅

任务

如何启动 Reporting Services 配置
如何配置报表服务器以进行电子邮件传递（Reporting Services 配置）

其他资源

订阅和传递 (Reporting Services)
Reporting Services 中的电子邮件传递
配置文件 (Reporting Services)


配置无人参与的执行帐户

配置无人参与的执行帐户 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services >

Reporting Services 提供一个特殊帐户，用于进行无人参与的报表处理和通过网络发送连接请求。可以通过下列方式使用该帐户：

  • 通过网络为使用数据库身份验证的报表发送连接请求，或连接到不需要或不使用身份验证的外部报表数据源。有关详细信息，请参阅 SQL Server 联机丛书中的为报表数据源指定凭据和连接信息。

  • 检索在报表中使用的外部图像文件。如果您要使用图像文件并且无法通过匿名访问来访问该文件，则可以配置无人参与的报表处理帐户并授予该帐户访问该文件的权限。有关如何使用无人参与的执行帐户检索图像的详细信息，请参阅 SQL Server 联机丛书中的向报表添加图像。

无人参与的报表处理是指任何由事件（计划驱动事件或数据刷新事件）而不是用户请求触发的报表执行过程。报表服务器使用无人参与的报表处理帐户来登录承载外部数据源的计算机。由于报表服务器服务帐户从不用于连接到其他计算机，因此该帐户是必需的。

重要提示：
配置该帐户的过程为可选操作。但是，如果不配置该帐户，用于连接到某些数据源的选项会受到限制，并且可能无法从远程计算机检索图像文件。如果配置了该帐户，则必须对其进行不断更新。具体来说，如果允许密码过期或在 Active Directory 中更改了帐户信息，则在下次处理报表时将遇到以下错误：“登录失败 (rsLogonFailed) 登录失败: 未知的用户名或密码不正确。”即使您从不检索外部图像也不向外部计算机发送连接请求，正确维护无人参与的报表处理帐户也是必要的。如果配置了该帐户但后来发现不需要使用它，则可以将其删除以避免日常的帐户维护任务。

如何配置帐户

必须使用域用户帐户。若要发挥该帐户应有的作用，它应不同于用于运行报表服务器服务的帐户。请确保使用具有如下特征的帐户：对为报表服务器提供数据源和资源的那些计算机只拥有最小权限（具有网络连接权限的只读访问权限就已足够）和有限访问权限。有关详细信息，请参阅如何启动 Reporting Services 配置。

若要指定帐户，可使用 Reporting Services 配置工具或 rsconfig 实用工具。配置无人参与的执行帐户的最简便方法是运行 Reporting Services 配置工具，然后在“执行帐户”页中指定凭据。

  1. 启动 Reporting Services 配置工具，然后连接到要配置的报表服务器实例。有关说明，请参阅如何启动 Reporting Services 配置。

  2. 在“执行帐户”页上，选择“指定执行帐户”。

  3. 键入帐户和密码，再次键入密码，然后单击“应用”。

使用 RSCONFIG 实用工具

设置帐户的另一种方法是使用 rsconfig 实用工具。若要指定该帐户，请使用 rsconfig 的 -e 参数。为 rsconfig 指定 -e 参数可强制该实用工具将帐户信息写入到配置文件中。您无需指定 RSreportserver.config 的路径。请按照以下步骤来配置该帐户。

  1. 创建或选择一个有权访问为报表服务器提供数据或服务的计算机和服务器的域帐户。您应使用权限受到限制（如只读权限）的帐户。

  2. 打开命令提示符窗口：在“开始”菜单上，单击“运行”，键入 cmd，再单击“确定”。

  3. 键入以下命令，为本地报表服务器实例配置该帐户：

    rsconfig -e -u< 域 / 用户名 > -p< 密码 >

rsconfig -e 支持其他参数。若要获取有关语法的详细信息和查看命令示例，请参阅 SQL Server 联机丛书中的 rsconfig 配置工具。

帐户信息的存储方式

设置帐户后，将在本地或远程报表服务器实例上的 RSreportserver.config 文件中以加密值的形式指定以下设置：

复制代码
<UnattendedExecutionAccount>
     <UserName></UserName>
     <Password></Password>
     <Domain></Domain>
</UnattendedExecutionAccount>

设置值后，将无法通过解密以纯文本的形式查看这些值。如果输错了值或忘记了指定的值，则必须使用 Reporting Services 配置工具或运行 rsconfig -e 重新设置。

无人参与的报表处理帐户的使用方法

若要检索图像文件，报表服务器将自动使用该帐户，您不需要执行任何具体操作。若要使用此帐户连接到为报表提供数据的外部数据源，则必须在报表数据源或共享数据源的“数据源属性”页中指定“凭据类型”选项：

  • 在报表管理器或 Management Studio 中，选择“不需要凭据”选项。

  • 在以 SharePoint 集成模式运行的报表服务器的 SharePoint 站点上，选择“无人参与的报表处理帐户”选项。

无人参与的报表处理帐户主要用于连接到外部服务器，而不是用作数据库服务器的登录名。如果要使用此帐户凭据登录到数据库，则必须在连接字符串中指定凭据。如果数据库服务器支持 Windows 集成安全性，并且用于无人参与报表处理的帐户拥有数据库读取权限，则可以指定 Integrated Security=SSPI。否则，必须在连接字符串中输入用户名和密码，该字符串对拥有数据源连接属性编辑权限的任何用户均以明文形式显示。

虽然系统不会阻止您使用无人参与的报表处理帐户在建立连接后检索数据，但是不建议这样做。该帐户应该用于特定的目的。如果使用该帐户检索数据，则有违本意。

无人参与的报表处理帐户的维护方法

定义此帐户后，必须确保不断更新此帐户和密码。可以使用 Reporting Services 配置工具来更新用于存储此帐户相关信息的配置设置。

  1. 启动 Reporting Services 配置工具，然后连接到要配置的报表服务器实例。

  2. 在“执行帐户”页上，确认已选中“指定执行帐户”。

  3. 键入新帐户或密码，再次键入密码，然后单击“应用”。

无人参与的报表处理帐户的删除方法

如果您不需要使用该帐户，则可以将其删除以避免日常的帐户维护任务。

  1. 启动 Reporting Services 配置工具，然后连接到要配置的报表服务器实例。

  2. 在“执行帐户”页上，清除“指定执行帐户”。

  3. 单击“应用”。

将从 RSReportServer.config 文件中删除此帐户的信息。

请参阅

其他资源

规划服务、帐户和连接
配置报表服务器安装
“数据源”属性页（报表管理器）
RSReportServer 配置文件
rsconfig 配置工具
为报表数据源指定凭据和连接信息


配置和管理加密密钥

配置和管理加密密钥 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services >

Reporting Services 使用加密密钥来保护存储在报表服务器数据库中的凭据和连接信息。在 Reporting Services 中，通过一组用于保护敏感数据的公钥、私钥和对称密钥支持加密。安装或配置报表服务器时，在报表服务器初始化期间会创建对称密钥，报表服务器使用此对称密钥对存储在报表服务器中的敏感数据进行加密。公钥和私钥由操作系统创建，用于保护对称密钥。对于在报表服务器数据库中存储敏感数据的每个报表服务器实例，都要创建一个公钥私钥对。

管理加密密钥包括创建对称密钥的备份副本以及了解密钥的还原、删除或更改的时间和方式。如果迁移报表服务器安装或配置扩展部署，则必须拥有对称密钥的备份副本，以便可以将其应用于新的安装。

若要管理对称密钥，可以使用 Reporting Services 配置工具或 rskeymgmt 实用工具。Reporting Services 中包括的工具仅用于管理对称密钥（公钥和私钥由操作系统管理）。Reporting Services 配置工具和 rskeymgmt 实用工具都支持以下任务：

  • 备份对称密钥的副本，以便可以使用该副本来恢复报表服务器安装或作为计划迁移的一部分。

  • 将以前保存的对称密钥还原到报表服务器数据库，以允许新的报表服务器实例访问最初不是由其进行加密的现有数据。

  • 在无法访问加密数据时删除报表服务器数据库中的加密数据，这种情况极少出现。

  • 当对称密钥遭到破坏时重新创建对称密钥并重新加密数据，这种情况极少出现。作为安全性方面的最佳做法，您应定期（例如，每隔几个月）重新创建对称密钥，以保护报表服务器数据库，使其能够抵御试图解开密钥的网络攻击。

  • 在报表服务器扩展部署（多个报表服务器同时共享单个报表服务器数据库以及为该数据库提供可逆加密的对称密钥）中添加或删除报表服务器实例。

本节内容

主题 | 说明
初始化报表服务器 | 介绍如何创建加密密钥。
备份和还原加密密钥 | 介绍如何备份加密密钥以及如何还原备份以恢复或迁移报表服务器安装。
删除和重新创建加密密钥 | 介绍如何用新版本替换对称密钥以及在无法验证对称密钥时如何重新开始。
添加和删除扩展部署的加密密钥 | 介绍如何添加和删除加密密钥以控制在扩展部署中包括哪些报表服务器。

请参阅

概念

存储加密的报表服务器数据

其他资源

Reporting Services 配置工具
rskeymgmt 实用工具
管理报表服务器数据库


初始化报表服务器

初始化报表服务器 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > 配置和管理加密密钥 >

在 Reporting Services 中，已初始化的服务器是指可以在报表服务器数据库中加密和解密数据的服务器。初始化是一项必需的报表服务器操作。初始化在报表服务器服务第一次启动时发生。在将报表服务器联接到现有部署，或在恢复进程中手动重新创建密钥时也需要进行初始化。有关如何使用加密密钥以及为什么使用加密密钥的详细信息，请参阅配置和管理加密密钥和存储加密的报表服务器数据。

加密密钥部分基于报表服务器服务的配置文件信息。如果更改用于运行报表服务器服务的用户标识，则必须相应地更新密钥。如果使用 Reporting Services 配置工具更改标识，将自动处理此步骤。

如果由于某些原因导致初始化失败，则报表服务器在响应用户和服务请求时将返回 RSReportServerNotActivated 错误。这种情况下，可能需要排除系统或服务器配置故障。有关详细信息，请参阅初始化和加密密钥错误故障排除。

初始化过程概述

初始化过程将创建并存储一个用于加密的对称密钥。对称密钥由 Microsoft Windows 加密服务创建，随后由报表服务器服务用来加密和解密数据。对称密钥本身通过非对称密钥进行加密。

以下步骤描述了初始化过程：

  1. 在初始启动时，报表服务器服务读取 RSReportServer.config 文件以获取安装标识符和数据库连接信息。

  2. 报表服务器服务从加密服务请求公钥。Windows 创建私钥和公钥并将公钥发送到报表服务器服务。

  3. 报表服务器服务连接到报表服务器数据库并存储安装标识符和公钥值。

  4. 报表服务器服务再次调入加密服务，这次是请求对称密钥。Windows 创建对称密钥。

  5. 报表服务器服务再次连接到报表服务器数据库，并将对称密钥添加到步骤 3 中存储的公钥和安装标识符值中。在存储对称密钥之前，报表服务器服务使用其公钥对对称密钥进行加密。存储对称密钥后，即可将报表服务器视为已初始化，并且可供使用。

针对扩展部署初始化报表服务器

Reporting Services 支持在多个报表服务器实例中共享单个报表服务器数据库的扩展部署模型。若要联接扩展部署，报表服务器必须在共享数据库中创建并存储其对称密钥副本。尽管使用该数据库的服务器都使用同一个对称密钥，但是每个报表服务器都有自己的密钥副本。每个副本各不相同，因为这些副本都使用其各自拥有的公钥进行了唯一加密。

针对扩展部署初始化报表服务器的开始步骤与描述初始化单个服务器和数据库组合的前三个步骤相同。

扩展部署初始化过程的不同之处在于报表服务器获取对称密钥的方式。在初始化第一个服务器时，它从 Windows 获取对称密钥。在配置扩展部署的过程中，在初始化第二个服务器时，它将从已初始化的报表服务器服务中获取对称密钥。第一个报表服务器实例使用第二个实例的公钥来为第二个报表服务器实例创建对称密钥的加密副本。在此过程中的任何一点，对称密钥永远不会作为纯文本公开。

如何初始化报表服务器

  • 若要初始化报表服务器，请使用 Reporting Services 配置工具。在创建和配置报表服务器数据库时，将自动进行初始化。有关详细信息，请参阅配置报表服务器数据库连接。

  • 若要针对扩展部署初始化报表服务器，可以使用 Reporting Services 配置工具中的“初始化”页或使用 RSKeymgmt 实用工具。若要按照逐步说明操作，请参阅如何配置报表服务器扩展部署（Reporting Services 配置）。

注意：
RSKeymgmt 是一种控制台应用程序，需要在已作为扩展部署的一部分的报表服务器实例所驻留的计算机上从命令行运行。运行该实用工具时，需要指定相关参数，以选择要初始化的远程报表服务器实例。

只有当安装标识符与公钥相匹配时，才会初始化报表服务器。如果匹配成功，则创建允许可逆加密的对称密钥。如果匹配失败，则将禁用报表服务器，在这种情况下，可能需要应用备份密钥；如果备份密钥不可用或无效，则可能需要删除加密数据。有关报表服务器所使用的加密密钥的详细信息，请参阅配置和管理加密密钥。

注意：
还可以使用 Reporting Services Windows Management Instrumentation (WMI) 提供程序以编程的方式初始化报表服务器。有关详细信息，请参阅 Reporting Services WMI Provider。

如何确认报表服务器初始化

若要确认报表服务器初始化，请通过在命令窗口中键入 http://<服务器名>/reportserver 来 ping 报表服务器 Web 服务。如果发生 RSReportServerNotActivated 错误，则表示初始化失败。

请参阅

概念

存储加密的报表服务器数据

其他资源

Reporting Services 安装的备份和还原操作
初始化和加密密钥错误故障排除
部署 (Reporting Services)
管理 (Reporting Services)


备份和还原加密密钥

备份和还原加密密钥 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > 配置和管理加密密钥 >

报表服务器配置的一个重要部分是为用于加密敏感信息的对称密钥创建备份副本。该密钥的备份副本对许多例程操作来说是必需的，通过使用备份副本，您可以在新的安装中重用现有报表服务器数据库。在发生以下任何事件时，必须还原加密密钥的备份副本：

  • 更改报表服务器 Windows 服务帐户名或重置密码。使用 Reporting Services 配置工具时，对该密钥进行备份是服务帐户名称更改操作的一部分。

    注意：
    重置密码不同于更改密码。密码重置需要相应的权限以覆盖域控制器上的帐户信息。密码重置在您忘记或不知道特定密码时由系统管理员执行。只有密码重置才需要还原对称密钥。定期更改帐户密码不需要重置对称密钥。

  • 重命名承载报表服务器的计算机或实例（报表服务器实例基于 SQL Server 实例名）。

  • 迁移报表服务器安装或配置报表服务器以使用其他报表服务器数据库。

  • 由于硬件故障而恢复报表服务器安装。

只需要备份对称密钥的一个副本。报表服务器数据库和对称密钥之间存在一对一的对应关系。尽管只需要备份一个副本，但如果在扩展部署模型中运行多个报表服务器，则可能需要多次还原密钥。每个报表服务器实例都需要具有自己的对称密钥副本，才能对报表服务器数据库中的数据进行锁定和解锁。

将加密密钥备份到磁盘

备份对称密钥是将密钥写入所指定的文件，然后使用所提供的密码对密钥进行加密的过程。对称密钥绝对不能在未加密状态下存储，所以在将它保存到磁盘时，必须提供密码对密钥进行加密。创建文件后，必须将其存储在安全的位置，并记住用于对文件进行解锁的密码。若要备份对称密钥，可以使用 Reporting Services 配置工具或 rskeymgmt 实用工具。

如何备份加密密钥（Reporting Services 配置工具）

  1. 启动 Reporting Services 配置工具，再连接到要配置的报表服务器实例。

  2. 单击“加密密钥”，再单击“备份”。

  3. 键入强密码。

  4. 指定用来包含所存储密钥的文件。Reporting Services 将向该文件追加 .snk 文件扩展名。请考虑将文件存储在软盘上，以使其与报表服务器隔开。

  5. 单击“确定”。

如何备份加密密钥 (rskeymgmt)

  1. 如果希望将密码保护的文件与报表服务器分开存储，请将软盘插入软盘驱动器中。

  2. 在承载报表服务器的计算机上本地运行 rskeymgmt.exe。必须使用 -e 提取参数复制密钥，提供文件名并指定密码。下面的示例阐释了必须指定的参数：

    复制代码
    rskeymgmt -e -f a:\rsdbkey.snk -p<password>
  3. 将软盘存放在安全的位置。

还原加密密钥

还原对称密钥将覆盖存储在报表服务器数据库中的现有对称密钥。还原加密密钥将用以前保存到磁盘上的副本来替换无法使用的密钥。还原加密密钥将导致以下操作：

  • 从密码保护的备份文件中打开对称密钥。

  • 使用报表服务器 Windows 服务的公钥加密对称密钥。

  • 将加密的对称密钥存储到报表服务器数据库中。

  • 删除以前存储的对称密钥数据（例如，在以前部署的报表服务器数据库中已存在的密钥信息）。

若要还原加密密钥，必须具有保存在文件中的加密密钥副本。还必须知道用来对存储的副本进行解锁的密码。如果有了密钥和密码，则可以运行 Reporting Services 配置工具或 rskeymgmt 实用工具来还原密钥。该对称密钥必须与用来对报表服务器数据库中当前存储的加密数据进行锁定和解锁的密钥相同。如果还原的副本无效，则报表服务器将无法访问报表服务器数据库中当前存储的加密数据。在这种情况下，如果无法恢复有效的密钥，则最好删除所有加密值。如果由于某些原因（例如，如果没有备份副本）而无法还原加密密钥，则必须删除现有密钥和加密内容。有关详细信息，请参阅删除和重新创建加密密钥。有关创建对称密钥的详细信息，请参阅初始化报表服务器。

如何还原加密密钥（Reporting Services 配置工具）

  1. 启动 Reporting Services 配置工具，再连接到要配置的报表服务器实例。

  2. 在“加密密钥”页上，单击“还原”。

  3. 选择包含备份副本的 .snk 文件。

  4. 键入用于解锁该文件的密码。

  5. 单击“确定”。

如何还原加密密钥 (rskeymgmt)

  1. 插入包含加密密钥备份副本的软盘。

  2. 在承载报表服务器的计算机上本地运行 rskeymgmt.exe。使用 -a 参数还原密钥。必须提供完全限定的文件名，并指定密码。下面的示例阐释了必须指定的参数：

    复制代码
    rskeymgmt -a -f a:\rsdbkey.snk -p<password>

请参阅

概念

配置和管理加密密钥

其他资源

Reporting Services 配置工具
rskeymgmt 实用工具
Reporting Services 安装的备份和还原操作


删除和重新创建加密密钥

删除和重新创建加密密钥 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > 配置和管理加密密钥 >

删除和重新创建加密密钥不属于加密密钥例行维护活动。您可以为了响应对报表服务器的特定威胁来执行这些任务，或者当无法访问报表服务器数据库时作为最后一种解决手段来执行这些任务。

  • 当确信现有对称密钥的安全受到威胁时，应重新创建对称密钥。作为安全性方面的最佳做法，您还可以定期重新创建密钥。

  • 当无法还原对称密钥时，应删除现有加密密钥和不可用的加密内容。

重新创建加密密钥

如果确认对称密钥已泄露给未经授权的用户，或者报表服务器遭到攻击，作为一种防范措施，您想要重置对称密钥，那么可以重新创建对称密钥。当重新创建对称密钥时，将使用新值对所有加密值重新进行加密。如果在扩展部署中运行了多个报表服务器，则对称密钥的所有副本都将更新为新值。报表服务器使用可用的公钥更新部署中每一台服务器的对称密钥。

只有在报表服务器处于工作状态时，才能重新创建对称密钥。重新创建加密密钥以及重新对内容进行加密将会中断服务器的操作。在进行重新加密时，必须将服务器脱机。在重新加密过程中，不应该向报表服务器发送请求。

可以使用 Reporting Services 配置工具或 rskeymgmt 实用工具重置对称密钥和加密的数据。有关如何创建对称密钥的详细信息，请参阅初始化报表服务器。

如何重新创建加密密钥（Reporting Services 配置工具）

  1. 通过修改 rsreportserver.config 文件中的 IsWebServiceEnabled 属性禁用报表服务器 Web 服务和 HTTP 访问。此步骤可暂时停止将身份验证请求发送到报表服务器而不会完全关闭服务器。您必须具有最低限度的服务，以便可以重新创建密钥。

    如果要为报表服务器扩展部署重新创建加密密钥，请对该部署中的所有实例禁用此属性。

    1. 打开 Windows 资源管理器，导航到 drive:\Program Files\Microsoft SQL Server\report_server_instance\Reporting Services。将 drive 替换为您的驱动器号，并将 report_server_instance 替换为与要禁用其 Web 服务和 HTTP 访问的报表服务器实例对应的文件夹名称。例如，C:\Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services。

    2. 打开 rsreportserver.config 文件。

    3. 对于 IsWebServiceEnabled 属性，指定为 False，然后保存所做的更改。

  2. 启动 Reporting Services 配置工具，再连接到要配置的报表服务器实例。

  3. 在“加密密钥”页上，单击“更改”。单击“确定”。

  4. 重新启动报表服务器 Windows 服务。如果要为扩展部署重新创建加密密钥，请在所有实例上重新启动该服务。

  5. 通过修改 rsreportserver.config 文件中的 IsWebServiceEnabled 属性，重新启用 Web 服务和 HTTP 访问。如果使用的是扩展部署，请对所有实例执行此操作。

如何重新创建加密密钥 (rskeymgmt)

  1. 禁用报表服务器 Web 服务和 HTTP 访问。使用以上过程中的说明停止 Web 服务操作。

  2. 在承载报表服务器的计算机上本地运行 rskeymgmt.exe。使用 -s 参数重置对称密钥。不需要其他参数：

    复制代码
    rskeymgmt -s
  3. 重新启动 Windows 服务，并启用 Web 服务操作。

删除无用的加密内容

如果由于某些原因无法还原加密密钥，报表服务器将永远无法解密和使用由该密钥加密的所有数据。若要将报表服务器还原到工作状态，必须删除当前存储在报表服务器数据库中的加密值，然后手动重新指定需要的值。

删除加密密钥会将所有对称密钥信息从报表服务器数据库中删除，并会删除所有加密内容。所有未加密的数据都将保持不变；只有加密内容被删除。删除加密密钥时，报表服务器通过添加新的对称密钥自动对自身进行重新初始化。删除加密内容时，会出现以下情况：

  • 共享数据源中的连接字符串被删除。运行报表的用户得到错误消息“ConnectionString 属性尚未初始化”。

  • 存储的凭据被删除。报表和共享数据源重新配置为使用所提示的凭据。

  • 基于模型（且需要共享数据源配置为使用存储的凭据或不使用凭据）的报表将不会运行。

  • 订阅被停用。

加密内容一旦被删除，便无法恢复。必须重新指定连接字符串和存储的凭据，并且必须激活订阅。

可以使用 Reporting Services 配置工具或 rskeymgmt 实用工具删除值。

如何删除加密密钥（Reporting Services 配置工具）

  1. 启动 Reporting Services 配置工具，再连接到要配置的报表服务器实例。

  2. 单击“加密密钥”，再单击“删除”。单击“确定”。

  3. 重新启动报表服务器 Windows 服务。对于扩展部署，应对所有报表服务器实例执行此操作。

如何删除加密密钥 (rskeymmgt)

  1. 在承载报表服务器的计算机上本地运行 rskeymgmt.exe。必须使用 -d 应用参数。下面的示例说明了必须指定的参数：

    复制代码
    rskeymgmt -d
  2. 重新启动报表服务器 Windows 服务。对于扩展部署，应对所有报表服务器实例执行此操作。

如何重新指定加密值

  1. 对于每个共享数据源，必须重新键入连接字符串。

  2. 对于每个使用存储的凭据的报表和共享数据源，必须重新键入用户名和密码，然后再保存。有关详细信息，请参阅为报表数据源指定凭据和连接信息。

  3. 对于每个数据驱动订阅，打开每个订阅，再重新键入订阅数据库的凭据。

  4. 对于使用加密数据的订阅（其中包括文件共享传递扩展插件和使用加密的任何第三方传递扩展插件），打开每个订阅，再重新键入凭据。使用报表服务器电子邮件传递的订阅不使用加密数据，因而不受密钥更改的影响。

请参阅

概念

配置和管理加密密钥
存储加密的报表服务器数据

其他资源

Reporting Services 配置工具
rskeymgmt 实用工具


添加和删除扩展部署的加密密钥

添加和删除扩展部署的加密密钥 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > 配置和管理加密密钥 >

通过将多个报表服务器配置为使用一个共享的报表服务器数据库，可以在扩展部署模型中运行 Reporting Services。扩展部署中的成员身份是基于报表服务器是否将加密密钥存储在报表服务器数据库中。通过为特定的报表服务器实例添加和删除加密密钥，可以控制扩展部署成员身份。如果要从部署中删除节点，则可以按任意顺序进行删除。如果要向部署中添加节点，则必须联接已作为部署的一部分的报表服务器中的所有新实例。

使用 Reporting Services 配置工具配置扩展部署

配置扩展部署的最简单方法是使用 Reporting Services 配置工具。有关详细信息和分步说明，请参阅为扩展部署配置 Reporting Services和如何配置报表服务器扩展部署（Reporting Services 配置）。

使用 Rskeymgmt 配置扩展部署

使用 rskeymgmt 实用工具，可以将报表服务器实例初始化为使用共享的报表服务器数据库。要向扩展部署中添加报表服务器，需要初始化报表服务器。要进行初始化，需要有管理员权限。对于承载要加入部署的报表服务器的远程计算机，您必须拥有管理员凭据。

如何将报表服务器加入扩展部署 (rskeymgmt)

  1. 在特定计算机的本地运行 rskeymgmt.exe，该计算机承载已经是报表服务器扩展部署成员的报表服务器。

  2. 使用 -j 参数将报表服务器加入报表服务器数据库。使用 -m 和 -n 参数指定要添加到部署中的远程报表服务器实例。使用 -u 和 -v 参数指定远程计算机上的管理员帐户。如果要使用同一台计算机中的多个报表服务器实例创建扩展部署，则使用的语法会稍有不同。有关应使用的语法的详细信息，请参阅 rskeymgmt 实用工具。

    下面的示例说明了将远程报表服务器加入扩展部署时必须指定的参数（如果您对远程计算机拥有管理员权限，则可以忽略凭据）：

    复制代码
    rskeymgmt -j -m <remotecomputer> -n <namedreportserverinstance> -u <administratoraccount> -v <administratorpassword>

如何从扩展部署 (rskeymgmt) 中删除报表服务器

  1. 打开要删除的报表服务器的 rsreportserver.config 文件并找到安装 ID。默认情况下，该文件位于 Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportServer 中。

    如果安装了单个实例，则计算机中只有一个 rsreportserver.config 文件。如果安装了多个 Reporting Services 实例，则请使用 Reporting Services 配置工具中的“服务器状态”页来查找要删除的报表服务器的实例标识符（例如，MSSQL.2）。为报表服务器实例存储程序文件的文件夹名称将基于实例标识符来命名（例如，Program Files\Microsoft SQL Server\MSSQL.2）。

  2. 运行 rskeymgmt.exe。可以在属于报表服务器扩展部署一部分的任何报表服务器上运行该文件。

  3. 使用 -r 参数从扩展部署中释放该报表服务器实例。下面的示例说明了必须指定的参数：

    复制代码
    rskeymgmt -r <installation ID>

这些步骤从扩展部署中删除报表服务器，但不会卸载报表服务器上的 Reporting Services 实例。从扩展部署中删除报表服务器之后，如果不再需要服务器上的 Reporting Services，则可以卸载该服务器上的 Reporting Services。有关信息，请参阅如何卸载 SQL Server 2008 的现有实例（安装程序）。

请参阅

概念

配置和管理加密密钥
初始化报表服务器

其他资源

Reporting Services 配置工具
rskeymgmt 实用工具


存储加密的报表服务器数据

存储加密的报表服务器数据 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > 配置和管理加密密钥 >

Reporting Services 将加密值存储在报表服务器数据库和配置文件中。大多数加密值都是用于访问向报表提供数据的外部数据源的凭据。本主题介绍对哪些值进行了加密、Reporting Services 中使用的加密功能以及您应当了解的其他类型的已存储机密数据。

加密值

下面列出了 Reporting Services 安装中所存储的值。

  • 报表服务器用于连接到报表服务器数据库（存储内部服务器数据）的连接信息和凭据。

    这些值是在安装过程中或报表服务器配置期间指定和加密的。您可以在任何时候使用 Reporting Services 配置工具或 rsconfig 配置工具更新连接信息。对配置设置的加密则是使用对所有用户都可用的本地计算机的计算机级密钥来执行的。加密的报表服务器连接信息存储在 rsreportserver.config 文件中（其他任何配置文件都不会包含加密设置）。有关详细信息，请参阅 配置报表服务器数据库连接。

  • 报表服务器用于连接到向报表提供数据的外部数据源的存储凭据。

    这些值是在您为报表配置数据源信息时定义的，随后会以加密值的形式存储在报表服务器数据库中。报表服务器使用对称密钥对这些数据进行加密和解密。有关存储的凭据的详细信息，请参阅 规划服务、帐户和连接和为报表数据源指定凭据和连接信息。

  • 报表服务器用于连接到其他计算机以检索报表中使用的外部图像文件或外部数据的无人参与用户帐户。

    当需要连接到远程计算机且没有其他可用于连接的凭据时，可使用此帐户。此帐户主要用于支持对不使用凭据即可访问数据源的报表进行无人参与处理。如果创建报表所依据的数据源在访问数据时不要求或使用凭据，则必须配置此帐户才能使用报表服务器。

    此帐户在某些环境下是必需的，并且只能通过 Reporting Services 配置工具或 rsconfig 进行创建。此值还会存储在 rsreportserver.config 文件中。您必须手动创建此帐户。有关此帐户及其用法的详细信息，请参阅配置无人参与的执行帐户。

  • 用于加密的对称密钥。

    此值是在安装过程中或服务器配置期间创建的，随后会以加密值的形式存储在报表服务器数据库中。报表服务器 Windows 服务使用此密钥对存储在报表服务器数据库中的数据进行加密和解密。

Reporting Services 中的加密功能

Reporting Services 使用 Windows 操作系统提供的加密功能。包括对称加密和非对称加密。

报表服务器数据库中的数据使用对称密钥进行加密。每个报表服务器数据库只有一个对称密钥。此对称密钥使用 Windows 生成的非对称密钥对的公钥进行自加密。私钥由 Report Server Windows 服务帐户持有。

在多个报表服务器实例共享同一个报表服务器数据库的报表服务器扩展部署中，所有报表服务器节点都使用一个对称密钥。每个节点必须具有一个共享对称密钥的副本。配置扩展部署时，将为每个节点自动创建一个对称密钥副本。每个节点都使用 Windows 服务帐户专有密钥对的公钥来加密对称密钥的副本。若要详细了解如何为单个实例和扩展部署创建对称密钥，请参阅初始化报表服务器。

注意：
如果更改 Report Server Windows 服务帐户，则非对称密钥将变为无效，从而中断服务器操作。为了避免此类故障，请始终使用 Reporting Services 配置工具来修改服务帐户设置。使用配置工具时，密钥会自动更新。有关详细信息，请参阅配置报表服务器服务帐户。

其他机密数据源

报表服务器中还存储有其他可能包含需保护的敏感信息的未加密数据。具体来说，报表历史记录快照和报表执行快照包含的查询结果可能包括仅供授权用户使用的数据。因此，对包含机密数据的报表使用快照功能时，需要注意，有权打开报表服务器数据库中的表的用户也能通过检查表的内容来查看所存储报表的部分内容。

注意：
对于所用参数基于用户安全标识的报表，Reporting Services 不支持缓存或报表历史记录。

请参阅

概念

配置和管理加密密钥

其他资源

管理报表服务器数据库
配置文件 (Reporting Services)


为扩展部署配置 Reporting Services

为扩展部署配置 Reporting Services |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services >

扩展部署用来增加报表服务器的可扩展性，以处理更多的并发用户和更大的报表执行负载，还可用来在特定服务器上专门处理交互式报表或计划报表。扩展部署中包括：

  • 两个或多个共享单个报表服务器数据库的报表服务器实例。

  • （可选）一个用来将交互式用户负载分布到多个报表服务器实例上的网络负载平衡 (NLB) 群集。

如果将 Reporting Services 部署到 NLB 群集上，则需要确保在报表服务器 URL 的配置中使用 NLB 虚拟服务器名称，并将这些服务器配置为共享同一个视图状态。

Reporting Services 不参与 Microsoft Cluster Services 群集。但是，可以在属于故障转移群集的数据库引擎实例上创建报表服务器数据库。

若要计划、安装和配置扩展部署，请按照下列步骤操作：

  • 请查阅规划扩展部署以了解有关何时使用扩展部署的指南。

  • 请查阅如何安装 SQL Server 2008（安装程序）以了解如何安装报表服务器实例的说明。

  • 请查阅如何配置报表服务器扩展部署（Reporting Services 配置）以了解有关如何共享报表服务器数据库并将报表服务器实例加入扩展部署的说明。

  • （可选）如果要将扩展部署配置为在网络负载平衡群集上运行，请查阅如何在网络负载平衡群集上配置报表服务器以了解有关如何配置视图状态验证的说明。

请参阅

概念

配置文件中的 URL (Reporting Services)
安装 Reporting Services 的注意事项

其他资源

规划部署拓扑
在 SQL Server 故障转移群集中承载报表服务器数据库
配置文件 (Reporting Services)
Reporting Services 组件和工具


将 Reporting Services 配置为 SharePoint 3.0 集成模式

将 Reporting Services 配置为 SharePoint 3.0 集成模式 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services >

可以将 SQL Server Reporting Services 的部署配置为与 Microsoft Windows SharePoint Services 3.0 或 Microsoft Office SharePoint Server 2007 的部署配合使用。必须对报表服务器和所部署的 SharePoint 产品或技术执行配置步骤，用户才能将报表文档发布到 SharePoint 库并在 SharePoint 站点上获取报表查看和管理服务。该配置过程将建立服务器连接信息；因此按顺序执行这些步骤是非常重要的。

本主题概述每个服务器的配置步骤，其中包含以下各节：

  • 报表服务器上的配置步骤概述

  • SharePoint Server 上的配置步骤概述

  • 服务帐户配置

  • 如何配置服务器集成

有关不同服务器拓扑的详细信息，请参阅 SharePoint 集成模式下的 Reporting Services 的部署拓扑。有关联机丛书中 SharePoint 集成相关主题的完整列表，请参阅如何了解 SharePoint 集成模式。

报表服务器上的配置步骤概述

若要将报表服务器配置为 SharePoint 集成模式，您必须具有现有的独立报表服务器或扩展部署。必须对报表服务器执行以下任务：

  1. 在 SharePoint 集成模式下创建报表服务器数据库。

    这会在报表服务器上设置服务器属性，并激活新的用于集成操作的 SOAP 报表服务器管理端点。使用 Reporting Services 配置工具创建数据库。

  2. 对于包括 SharePoint 服务器场的部署，在报表服务器计算机上安装一个 Windows SharePoint Services Web 前端。该 Web 前端会将报表服务器计算机加入 SharePoint 场中。只有在将报表服务器和 SharePoint 技术实例部署到不同的计算机上时，才需要在报表服务器计算机上安装 Web 前端。

  3. 如果在部署时涉及到将 SharePoint 数据库放在与报表服务器相同的计算机上，请将报表服务器服务配置为在域帐户下运行。只有当报表服务器和应用程序数据库在同一台计算机上，而 SharePoint Web 应用程序在另一台计算机上时，才需要执行此步骤。

关于报表服务器数据库

报表服务器数据库可以为一个或多个报表服务器实例提供内部存储。报表服务器数据库可以支持本机模式操作，也可以支持 SharePoint 集成模式，但不能同时支持这两种模式。数据库中的内容是特定于模式的，在不同的服务器模式之间不可互换。如果创建支持 SharePoint 集成模式的报表服务器数据库，则以后无法将该数据库自动转换或迁移为使用本机模式报表服务器实例运行。通过以下方式使用报表服务器数据库，具体情况取决于服务器模式：

  • 为本机模式操作创建报表服务器数据库时，报表服务器数据库是报表服务器所使用的持久性数据的唯一存储库。

  • 创建 SharePoint 集成模式的报表服务器数据库时，报表服务器数据库会存储服务器属性、报表执行快照、报表历史记录、订阅定义和计划。同时还存储报表、报表模型、共享数据源和资源的第二副本以提高服务器的处理性能。报表文档的主存储位于 SharePoint 内容数据库。有关详细信息，请参阅存储报表服务器内容并将报表服务器内容和 SharePoint 数据库同步。

创建 SharePoint 集成模式的报表服务器数据库是将该报表服务器配置为 SharePoint 集成模式的重要的第一步。可以使用 Reporting Services 配置工具来创建报表服务器数据库并配置与报表服务器的连接。只有报表服务器才连接到报表服务器数据库。Windows SharePoint Services 或 Office SharePoint Server 实例始终都不会连接到报表服务器数据库，也不会从报表服务器数据库中检索数据。

关于报表服务器扩展部署和 SharePoint 集成模式

如果要将报表服务器扩展部署与 SharePoint 服务器场集成，则所有属于该部署的报表服务器实例都必须在 SharePoint 集成模式下运行。在同一扩展部署中不能使用几种服务器模式的组合。而且，您必须为扩展部署创建一个入口点（即，解析为报表服务器实例所安装到的 NLB 群集的虚拟 IP 的 URL）。

关于多个报表服务器实例和 SharePoint 集成模式

如果要在一台计算机上安装多个 Reporting Services 实例，但是仅将其中的一个实例配置为 SharePoint 集成模式，请确保执行以下操作：

  • 确保所有的 Reporting Services 实例具有相同的版本。SQL Server 2008 Reporting Services (SSRS) 引入了一个更新版本的 Reporting Services Windows Management Instrumentation (WMI) 提供程序。同一台计算机上不能同时装有 SQL Server 2008 Reporting Services (SSRS) 和较低版本的 SQL Server 2008 Reporting Services (SSRS)。因此，即使您不需要针对所有实例实现 SQL Server 2008 Reporting Services (SSRS) 功能，也有必要让所有报表服务器实例都运行 SQL Server 2008 Reporting Services (SSRS) 或更高版本。

  • 如果您在不同的时间针对不同的报表服务器实例运行 SQL Server 2008 安装程序，请在安装第二个 SQL Server 2008 Reporting Services (SSRS) 实例之后重新启动 WMI 服务。

SharePoint Server 上的配置步骤概述

若要在运行 SharePoint 产品或技术的服务器上配置集成，必须执行以下操作：

  1. 下载并安装用于 SharePoint 技术的 Reporting Services 外接程序。

    该外接程序将会安装程序文件和应用程序页，包括您在管理中心打开用来设置报表服务器 URL 和其他集成设置的页。您可以为 SharePoint 场或独立的 SharePoint Web 应用程序指定报表服务器集成设置。

  2. 如果您未在根网站集上安装该外接程序，请激活报表服务器功能。

  3. 使用 SharePoint 管理中心配置报表服务器集成。配置设置包括指定单个报表服务器 URL、针对发往报表服务器的请求设置身份验证类型、向报表服务器服务帐户授予数据库访问权限。

  4. （可选）在 SharePoint 管理中心中，可以设置报表服务器默认值，以便启用日志记录、即席生成报表以及对报表历史记录和超时值的限制。

可以将 SharePoint 产品和技术部署为场或独立的服务器。场包含一个或多个虚拟服务器，在该场中每个虚拟服务器都是一个 SharePoint Web 应用程序。报表服务器在场级集成。从存储集成方面来看，一个场只能有一个报表服务器数据库。可以使用 SharePoint 管理中心管理场中所有服务器的集成设置。

可以将场中每个 SharePoint Web 应用程序都配置为使用不同的身份验证提供程序。这不会给报表服务器集成带来任何影响。无论使用何种身份验证提供程序，报表服务器部署都将处理该场中每个服务器的请求。

每个 Web 应用程序都具有默认的顶级站点。可以在每个顶级站点上设置不同的权限，以使报表服务器项和操作在场中所有服务器之间具有不同的可用性。

服务帐户配置

将报表服务器作为在内置帐户或者本地/域 Windows 用户帐户下运行的单个 Windows 服务实现。在 SharePoint 集成模式下，该服务必须连接到具有写权限和执行权限的 SharePoint 内容数据库。由于该服务连接到 SharePoint 内容数据库，因此用来运行该服务的帐户将具有不同的要求，具体情况取决于是否使用远程连接，以及报表服务器 URL 代理端点连接使用的是 Windows 集成安全模式还是可信帐户模式。

下表提供了建议不同部署方案使用的服务帐户。

部署方案 | 服务 | SharePoint 数据库 | 建议报表服务器服务使用的帐户
单台服务器 | 所有服务都安装在同一台计算机上 | 同一台计算机上 | 任何（NetworkService、域用户、本地用户和 LocalSystem)。 由于应用程序使用本地数据库连接进行连接，因此您可以将该服务配置为在任何类型的帐户下运行。
将部署分布到多台计算机上 | SharePoint Web 应用程序和报表服务器安装在不同的计算机上 | 第三台计算机上 - 或 - SharePoint 服务器计算机 | 域用户帐户 - 或 - NetworkService，但是只有当您将 NT_AUTHORITY\NetworkService 添加到报表服务器计算机上的 WSS_WPG Windows 组中时才使用。有关详细信息，请参阅配置错误故障排除。
将部署分布到多台计算机上 | SharePoint Web 应用程序和报表服务器安装在不同的计算机上 | 在报表服务器计算机上 | 无论报表服务器 URL 代理端点是如何配置的，都需要使用域用户帐户。 SharePoint 数据库在远程计算机上运行时，SharePoint Web 应用程序会显式拒绝远程计算机的计算机帐户访问数据库。如果报表服务器和 SharePoint 数据库在同一台计算机上，而且其中的任一服务在内置帐户下运行，则将相应地拒绝该服务的访问。将该服务配置为在域用户帐户下运行，可确保不会因为该服务运行在被禁止的帐户下而拒绝报表服务器访问数据库。
注意：
在讨论数据库连接的服务帐户要求时，因为只有报表服务器连接到报表服务器数据库，所以将不包括报表服务器数据库。

关于 SharePoint 服务帐户配置

针对 Windows SharePoint Services 和 Office SharePoint Server 的服务帐户建议声明：对于服务器场部署，应当在域用户帐户（而不是 Network Service）下运行应用程序池进程。尽管建议使用域用户帐户，但它不是必需的。但是，一定要认识到，如果您将 SharePoint Web 应用程序配置为在 Network Service 下运行，报表服务器位于远程计算机上，而且报表服务器 URL 代理端口在可信帐户模式下进行连接，那么，在从 SharePoint 站点访问报表和报表服务器功能时将遇到错误。有关在部署此配置时所发生的服务器错误的详细信息，请参阅配置错误故障排除。

有关服务帐户连接到 SharePoint 技术实例的详细信息，请参阅 SharePoint 集成模式下的 Reporting Services 安全性概述。若要了解 SharePoint 部署的服务帐户建议，请参阅 Windows SharePoint Services 产品文档中的 Plan for administrative and service accounts（规划管理和服务帐户）。

如何配置服务器集成

将服务器配置为集成操作需要使用多个工具和步骤。单击下面的链接可阅读有关在特定的部署方案中配置服务器集成的说明：

  • 如何在独立服务器上配置 SharePoint 集成

  • 如何在多台服务器上配置 SharePoint 集成

请参阅

任务

如何在 SharePoint 管理中心中配置报表服务器集成
如何切换服务器模式（Reporting Services 配置）

参考

设置 Windows 服务帐户

概念

备份和还原加密密钥
如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）

其他资源

RSReportDesigner 配置文件
规划部署模式
SharePoint 集成模式下的 Reporting Services 的部署拓扑
在 SharePoint 站点上为报表服务器项授予权限
SharePoint 集成模式下的 Reporting Services 安全性概述
将模型和共享数据源部署到 SharePoint 站点


Reporting Services 配置操作指南主题

Reporting Services 配置操作指南主题 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services >

本部分包含使用 Reporting Services 配置工具配置报表服务器实例的过程。

本节内容

本节中的主题进行了适当分类，以便于您轻松找到所需说明。第一部分包含有关本机模式的报表服务器的基本配置任务主题。第二部分包含高级配置主题。第三部分包含有关将报表服务器配置为以 SharePoint 集成模式运行的主题。

基本配置

主题 | 说明
如何启动 Reporting Services 配置 | 提供启动 Reporting Services 配置工具的步骤。
如何为 Reporting Services 配置服务帐户 | 说明如何为报表服务器服务指定帐户和密码信息。
如何为报表服务器注册服务主体名称 (SPN) | 说明如何为在使用 Kerberos 身份验证的网络上的域用户帐户下运行的报表服务器手动注册 SPN。
如何配置 URL（Reporting Services 配置） | 说明如何建立一个或多个用于访问报表服务器 Web 服务和报表管理器的 URL。
如何创建报表服务器数据库（Reporting Services 配置） | 提供创建报表服务器数据库的步骤。此步骤是部署 Reporting Services 安装所必需的步骤。

高级或可选配置

主题 | 说明
如何配置报表服务器扩展部署（Reporting Services 配置） | 提供配置多个报表服务器以共享报表服务器数据库的步骤。
如何配置报表服务器以进行电子邮件传递（Reporting Services 配置） | 提供有关配置报表服务器以进行电子邮件分发的步骤。
如何将防火墙配置为允许报表服务器访问 | 说明如何打开用于报表服务器的入站请求和出站响应的端口。
如何在 Windows Vista 和 Windows Server 2008 上为本地管理配置报表服务器 | 描述使用 http://localhost 连接到报表管理器或报表服务器所需的其他步骤。
如何配置报表服务器以进行远程管理 | 说明如何配置远程报表服务器实例以便可以从其他计算机上连接和配置它。
如何打开或关闭 Reporting Services 功能 | 说明如何删除 Reporting Services 安装中不使用的功能。
如何启用远程错误（Reporting Services 配置） | 说明如何将报表服务器上的服务器属性设置为返回有关出现在远程服务器上的错误条件的其他信息。

SharePoint 集成

主题 | 说明
如何在报表服务器计算机中安装 SharePoint Web 前端 | 说明如何添加用于将报表服务器计算机联接到 SharePoint 服务器场的 SharePoint 程序文件。
如何安装或卸载 Reporting Services 外接程序 | 说明如何在 SharePoint 服务器上安装报表服务器应用程序页、配置页和 URL。
如何在 SharePoint 管理中心中激活报表服务器功能 | 说明如何在未启用根网站集时手动激活某个网站集的报表服务器功能。
如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置） | 说明如何为在 SharePoint 集成模式下运行的报表服务器创建报表服务器数据库。
如何在 SharePoint 管理中心中配置报表服务器集成 | 提供在 SharePoint 管理中心中配置集成的说明。
如何在独立服务器上配置 SharePoint 集成 | 提供在一台计算机上安装所有服务器组件和应用程序数据库的分步指导。
如何在多台服务器上配置 SharePoint 集成 | 提供在分布式服务器部署中的多台计算机上安装服务器组件的分步指导。
如何切换服务器模式（Reporting Services 配置） | 说明如何从 SharePoint 技术或实例部署中删除报表服务器实例，以便您可以将该实例作为本机模式报表服务器运行。
如何了解 SharePoint 集成模式 | 提供特定于 SharePoint 技术的 Reporting Services 外接程序的主题列表。

请参阅

任务

如何检测版本信息 (Reporting Services)

概念

如何迁移 Reporting Services 安装

其他资源

设计即席报表操作指南主题
配置报表服务器安装
Reporting Services 配置工具


如何启动 Reporting Services 配置

如何启动 Reporting Services 配置 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

Reporting Services 配置工具用于对 Reporting Services 的安装进行配置。只要您是报表服务器计算机上本地管理员组的成员，就可以配置本地或远程报表服务器实例。在可以连接到远程报表服务器实例并对其进行配置之前，必须使远程 Windows Management Instrumentation (WMI) 调用能够通过 Windows 防火墙。有关详细信息，请参阅 SQL Server 联机丛书中的如何配置报表服务器以进行远程管理。

Reporting Services 配置工具是特定于版本的。随 SQL Server 2008 一起安装的 Reporting Services 配置工具不能用于配置早期版本的 Reporting Services。如果在同一计算机上并行运行新版本和旧版本的 Reporting Services，则必须使用随每个版本安装的 Reporting Service 配置工具来配置每个实例。

启动 Reporting Services 配置

  1. 单击“开始”，依次指向“所有程序”、Microsoft SQL Server 2008 和“配置工具”。

    如果要从先前版本的 SQL Server 中配置报表服务器实例，请打开此版本的程序文件夹。例如，指向 Microsoft SQL Server 2005 而非 Microsoft SQL Server 2008 可打开 SQL Server 2005 服务器组件的配置工具。

  2. 单击“Reporting Services 配置”。将显示“连接到报表服务器实例”对话框，供您选择要配置的报表服务器实例。

  3. 在“服务器名称”中，指定安装报表服务器实例的计算机的名称。默认情况下，将显示本地计算机的名称，但如果要连接到安装在远程计算机上的报表服务器，则可以键入远程 SQL Server 实例的名称。

  4. 如果指定远程计算机，请单击“查找”以建立一个连接。

  5. 在“报表服务器实例”中，选择要配置的 SQL Server Reporting Services 实例。在列表中只显示 SQL Server 2008 报表服务器实例。不能配置较早版本的 Reporting Services。

  6. 单击“连接”。

请参阅

概念

Reporting Services 配置操作指南主题

其他资源

配置报表服务器安装
Reporting Services 配置工具


如何在 SharePoint 管理中心中激活报表服务器功能

如何在 SharePoint 管理中心中激活报表服务器功能 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

在安装了用于 SharePoint 技术的 Microsoft SQL Server 2008 Reporting Services 外接程序之后，应在 SharePoint 管理中心中配置报表服务器集成设置。若要配置报表服务器集成，请使用管理中心的“应用程序管理”选项卡中的 Reporting Services 页。

如果在“应用程序管理”中看不到 Reporting Services 部分，则要么尚未安装 Reporting Services 外接程序，要么尚未激活报表服务器集成设置。

若要验证是否已安装，请在“添加或删除程序”中查看已安装应用程序的列表。如果 Reporting Services 外接程序已安装，请按照本主题中的说明激活此功能。

默认情况下，为本地 SharePoint Web 应用程序的根网站集激活 Reporting Services 外接程序。如果未启用根站点或在安装 Reporting Services 外接程序时未定义网站集，则必须手动激活报表服务器集成设置。

激活网站集的 Reporting Services 集成

  1. 依次单击“开始”、“管理工具”和“SharePoint 3.0 管理中心”。

  2. 单击“站点操作”。

  3. 单击“站点设置”。

  4. 单击“网站集功能”。

  5. 在列表中找到“报表服务器集成功能”。

  6. 单击“激活”。

后续步骤

激活此功能后，可以继续进行服务器集成。有关说明，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

请参阅

概念

如何安装或卸载 Reporting Services 外接程序
如何安装或卸载 Reporting Services 外接程序
将 Reporting Services 配置为 SharePoint 3.0 集成模式

其他资源

在 SharePoint 集成模式下运行 Reporting Services 的要求
规划部署模式


如何将防火墙配置为允许报表服务器访问

如何将防火墙配置为允许报表服务器访问 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

可以通过指定 IP 地址、端口和虚拟目录的 URL 访问报表服务器应用程序和已发布的报表。如果 Windows 防火墙已开启，配置为报表服务器使用的端口很可能已关闭。表明端口可能已关闭的迹象包括请求报表后出现空白网页，或尝试从远程客户端计算机打开报表管理器时出现空白页。

若要打开端口，必须在报表服务器计算机上使用 Windows 防火墙实用工具。Reporting Services 不会帮您打开端口，您必须手动执行该步骤。

默认情况下，报表服务器侦听端口 80 的 HTTP 请求。因此，以下操作说明包括用来指定该端口的步骤。如果将报表服务器 URL 配置为使用其他端口，则在按照以下说明进行操作时必须指定相应的端口号。

如果要访问外部计算机上的 SQL Server 关系数据库，或者如果报表服务器数据库在外部 SQL Server 实例上，则必须打开外部计算机上的端口 1433 和 1434。有关详细信息，请参阅如何为数据库引擎访问配置 Windows 防火墙。有关默认 Windows 防火墙设置的详细信息以及有关影响数据库引擎、Analysis Services、Reporting Services 和 Integration Services 的 TCP 端口的说明，请参阅配置 Windows 防火墙以允许 SQL Server 访问。

必备项

这些操作说明假定您已经配置了服务帐户，创建了报表服务器数据库，并为报表服务器 Web 服务和报表管理器配置了 URL。有关详细信息，请参阅Reporting Services 配置操作指南主题。

您还应验证是否可以通过将本地 Web 浏览器连接到本地报表服务器实例来访问报表服务器。此步骤可确保您拥有有效的安装。开始打开端口之前，应验证是否已对安装进行了正确的配置。若要在 Windows Vista 或 Windows Server 2008 中完成该步骤，还必须将报表服务器站点添加到“受信任的站点”中。有关详细信息，请参阅如何在 Windows Vista 和 Windows Server 2008 上为本地管理配置报表服务器。

在 Windows 防火墙中打开端口

针对不同版本的 Windows 防火墙分别有不同的说明。如果使用 Windows Vista 或 Windows Server 2008，请参考本主题末尾的说明。

在 Windows Server 2003 SP 2 或 Windows XP SP2 中打开端口 80

  1. 在“开始”菜单上单击“控制面板”，然后单击“Windows 防火墙”。

  2. 在“例外”选项卡上，单击“添加端口”。

  3. 在“名称”中键入 ReportServer (TCP on port 80)。

  4. 在“端口号”中键入 80。

  5. 确保选中了 TCP。

  6. 单击“更改范围”。

  7. 单击“仅我的网络(子网)”，然后单击“确定”。

  8. 单击“确定”关闭对话框。

  9. 重新启动计算机。

在 Windows Vista 中打开端口 80

  1. 在“开始”菜单上单击“控制面板”，单击“安全”，然后单击“Windows 防火墙”。

  2. 单击“允许程序通过 Windows 防火墙”。

  3. 单击“继续”。

  4. 在“例外”选项卡上，单击“添加端口”。

  5. 在“名称”中键入 ReportServer (TCP on port 80)。

  6. 在“端口号”中键入 80。

  7. 确保选中了 TCP。

  8. 单击“更改范围”。

  9. 单击“仅我的网络(子网)”，然后单击“确定”。

  10. 单击“确定”关闭对话框。

  11. 重新启动计算机。

后续步骤

打开端口后，必须在确认远程用户是否可以通过所打开的端口访问报表服务器之前，通过主文件夹或站点级别的角色分配授予用户访问报表服务器的权限。如果用户不具有足够的权限，那么虽然可以正确地打开端口，但报表服务器连接仍会失败。有关详细信息，请参阅如何授予用户对报表服务器的访问权限（报表管理器）。

您还可以通过在其他计算机上启动报表管理器来验证是否正确打开了端口。有关详细信息，请参阅如何启动报表管理器。

请参阅

任务

如何验证 Reporting Services 安装

概念

配置报表服务器服务帐户
配置报表服务器 URL
创建报表服务器数据库
配置报表服务器服务帐户
Reporting Services 配置操作指南主题


如何配置报表服务器以进行电子邮件传递（Reporting Services 配置）

如何配置报表服务器以进行电子邮件传递（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

Reporting Services 提供了一个电子邮件传递扩展插件，供用户订阅报表；报表随后将传递到电子邮箱中。若要使用报表服务器电子邮件传递扩展插件，必须先对其进行配置。配置报表服务器的电子邮件传递需要以下各项：

  • 一个简单邮件传输协议 (SMTP) 服务器或网关。

  • 一个拥有从 SMTP 服务器发送电子邮件的权限的帐户。根据您单位的安全策略，您可能需要在通过公司的 SMTP 服务器发送电子邮件之前先请求权限。有关详细信息，请询问您的系统管理员或网络管理员。

  • 报表服务器服务必须对 SMTP 服务器具有 Send As 权限。

若要配置报表服务器电子邮件，可以使用 Reporting Services 配置工具，也可以编辑配置文件。Reporting Services 配置工具提供了报表服务器所要求的最低设置。如果要使用本地 SMTP 服务或指定高级设置，则请修改此配置文件。

如果要评估报表服务器电子邮件功能或解决订阅或传递问题，可以将报表服务器电子邮件配置为使用本地 SMTP 服务，该服务用于将报表传递到本地文件夹。有关详细信息，请参阅配置报表服务器以进行电子邮件传递。

如果您未配置报表服务器来进行电子邮件传递，或者您无权访问 SMTP 服务器，则可以使用文件共享传递扩展插件，将报表分发到可通过网络连接进行访问的共享文件夹。

使用 Reporting Services 配置工具配置报表服务器电子邮件

  1. 请验证报表服务器 Windows 服务是否对 SMTP 服务器拥有 Send As 权限。

  2. 启动 Reporting Services 配置工具，然后连接到报表服务器实例。

  3. 在“电子邮件设置”页上，输入 SMTP 服务器的名称。此值可以是 IP 地址、企业 Intranet 上计算机的 UNC 名称或者完全限定域名。

  4. 在“发件人地址”中，输入有权从 SMTP 服务器发送电子邮件的帐户的名称。

  5. 单击“应用”。

配置报表服务器的远程 SMTP 服务

  1. 请验证报表服务器 Windows 服务是否对 SMTP 服务器拥有 Send As 权限。

  2. 在文本编辑器中打开 RSReportServer.config 文件。

  3. 请验证是否将 <UrlRoot> 设置为报表服务器 URL 地址。此值是在您配置报表服务器时设置的，应该已经填写。如果未设置此值，则请键入报表服务器 URL 地址。

  4. 在“传递”部分中，查找 <ReportServerEmail>。

  5. 在 <SMTPServer> 中，键入 SMTP 服务器的名称。此值可以是 IP 地址、企业 Intranet 上计算机的 UNC 名称或者完全限定域名。

  6. 请验证是否将 <SendUsing> 设置为 2。如果将其设置为其他值，则报表服务器无法配置为使用远程 SMTP 服务。

  7. 在 <From> 中，键入有权从 SMTP 服务器发送电子邮件的帐户的名称。

  8. 保存该文件。

    报表服务器将自动使用新的设置；不需要重新启动该服务。您可以指定其他 SMTP 设置，以进一步配置如何将 SMTP 服务器用于报表服务器电子邮件传递。有关详细信息，请参阅配置报表服务器以进行电子邮件传递和 RSReportServer 配置文件。

配置报表服务器的本地 SMTP 服务

  1. 在“控制面板”中，单击“添加或删除程序”。

  2. 单击“添加/删除 Windows 组件”启动 Windows 组件向导。

  3. 选择“应用程序服务器”，然后单击“详细信息”。

  4. 选择“Internet 信息服务 (IIS)”，然后单击“详细信息”。

  5. 选中“SMTP 服务”复选框，然后单击“确定”。

  6. 在 Windows 组件向导中，单击“下一步”。单击“完成”。

  7. 验证服务是否正在“服务”控制台上运行。

  8. 在文本编辑器中打开 RSReportServer.config 文件。

  9. 请验证是否将 <UrlRoot> 设置为报表服务器 URL 地址。此值是在您配置报表服务器时设置的，应该已经填写。如果未设置此值，则请键入报表服务器 URL 地址。

  10. 在“传递”部分中，查找 <ReportServerEmail>。

  11. 在 <SMTPServer> 中，清除此设置的所有值，但不要删除标记。

  12. 将 <SendUsing> 设置为 1。如果将其设置为其他值，则未将报表服务器配置为使用本地 SMTP 服务。

  13. 将 <SMTPServerPickupDirectory> 设置为本地驱动器中的文件夹。

  14. 将 <From> 设置为有权从 SMTP 服务器发送电子邮件的帐户。

  15. 保存该文件。

请参阅

概念

配置报表服务器以进行电子邮件传递

其他资源

如何为报表管理器设置默认传递扩展插件
Reporting Services 中的文件共享传递
Reporting Services 中的电子邮件传递
Reporting Services 配置工具
订阅和传递 (Reporting Services)


如何在 Windows Vista 和 Windows Server 2008 上为本地管理配置报表服务器

如何在 Windows Vista 和 Windows Server 2008 上为本地管理配置报表服务器 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

如果希望对报表服务器实例进行本地管理，则在 Windows Vista 和 Windows Server 2008 上部署 Reporting Services 需要执行额外的配置步骤。通过在访问应用程序时删除管理员权限，Windows Vista 和 Windows Server 2008 均可限制过度使用提升权限。因为操作系统删除了权限，所以本地 Administrators 组的成员运行大多数应用程序时就像使用标准用户帐户时一样。

虽然该方法可提高系统的整体安全性，但会阻止用户使用 Reporting Services 为本地管理员创建的预定义内置角色分配。但通过在用户方执行额外配置，在执行下列操作后可以使用标准用户权限有效地管理报表服务器内容和操作：

  • 将 Reporting Services URL 添加到受信任站点。默认情况下，Internet Explorer 7.0 在 Windows Vista 和 Windows Server 2008 上是以保护模式运行的，此功能可阻止浏览器请求到达运行在同一计算机上的高级别进程。通过将报表服务器应用程序添加为受信任站点，可以禁用这些应用程序的保护模式。

  • 创建角色分配，授予您（报表服务器管理员）管理内容和操作的权限而无需使用 Internet Explorer 中的“以管理员的身份运行”功能。通过为您的 Windows 用户帐户创建角色分配，并通过显式角色分配替换 Reporting Services 为本地管理员创建的预定义的内置角色分配，您将获得对报表服务器的访问权限（包括内容管理员和系统管理员权限）。

本主题说明在完成安装并且配置了报表服务器组件之后如何配置报表服务器以便进行本地管理。如果您尚未安装或配置报表服务器，请参阅如何安装 SQL Server 2008（安装程序）和 Reporting Services 配置操作指南主题。有关用户帐户控制 (UAC) 功能以及如何利用管理员权限连接到数据库引擎的详细信息，请参阅如何从 Windows Vista 连接到 SQL Server。

注意：
如果正在 Windows Vista 或 Windows Server 2008 上部署 Reporting Services，请确保打开 Windows 防火墙的 80 端口，以允许访问报表服务器计算机。有关说明，请参阅如何将防火墙配置为允许报表服务器访问。

在 Windows Vista 和 Windows Server 2008 上配置本地报表服务器管理

  1. 使用“以管理员的身份运行”权限打开一个浏览器窗口。从“开始”菜单上，单击“所有程序”，右键单击 Internet Explorer，然后选择“以管理员的身份运行”。

  2. 单击“允许”以继续。

  3. 在 URL 地址中，输入报表管理器 URL。有关说明，请参阅如何启动报表管理器。

  4. 单击“工具”。

  5. 单击“Internet 选项”。

  6. 单击“安全”。

  7. 单击“受信任的站点”。

  8. 单击“站点”。

  9. 添加 http://<服务器名称>。

  10. 如果不将 HTTPS 用于默认站点，请清除“对该区域中的所有站点要求服务器验证(https:)”复选框。

  11. 单击“添加”。

  12. 单击“确定”。

  13. 在报表管理器的主页上，单击“属性”。

  14. 单击“新建角色分配”。

  15. 按以下格式键入 Windows 用户帐户：<域>\<用户>。

  16. 选择“内容管理员”。

  17. 单击“确定”。

  18. 单击主页上角的“站点设置”。

  19. 单击“配置站点范围的安全性”。

  20. 单击“新建角色分配”。

  21. 按以下格式键入 Windows 用户帐户：<域>\<用户>。

  22. 选择“系统管理员”。

  23. 单击“确定”。

  24. 关闭报表管理器。

  25. 重新在 Internet Explorer 中打开报表管理器，但不使用“以管理员的身份运行”。

使用 Windows Vista 和 Windows Server 2008 上的 Business Intelligence Development Studio

如果您在 Windows Vista 或 Windows Server 2008 上安装了 Business Intelligence Development Studio，则在使用设计工具时会遇到与 Visual Studio 环境的兼容问题。如果希望打开现有项目或解决方案，或者希望将项目从报表设计器或模型设计器发布到报表服务器，则必须以提升的权限打开 Business Intelligence Development Studio：

  1. 从“开始”菜单上，依次单击“所有程序”和 SQL Server 2008，右键单击 Business Intelligence Development Studio，然后单击“以管理员的身份运行”。

  2. 单击“继续”。

  3. 单击“运行程序”。

现在，您应该能够将报表和其他项目部署到报表服务器上了。如果没有足够的权限，您将遇到如下的问题：

  • 尝试打开现有项目时遇到拒绝访问错误。

  • 配置与共享数据源的数据源连接时遇到登录失败错误。

  • 当使用报表服务器向导创建报表时，如果向导尝试连接到为报表提供数据的外部数据源，您将会遇到登录失败错误。

SQL Server Management Studio 用户必须使用“以管理员的身份运行”权限为管理服务器上的数据库的用户创建登录名。有关 Management Studio 的提升权限要求的详细信息，请参阅如何从 Windows Vista 连接到 SQL Server。

请参阅

任务

如何启动 Reporting Services 配置

参考

安装 SQL Server 2008 的硬件和软件要求

概念

Reporting Services 配置操作指南主题


如何配置报表服务器扩展部署（Reporting Services 配置）

如何配置报表服务器扩展部署（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

Reporting Services 支持扩展部署模式。该模式允许运行共享单个报表服务器数据库的多个报表服务器实例。

若要创建扩展部署，请使用安装程序和 Reporting Services 配置工具：

  • 使用安装程序安装将与扩展部署联接的每个报表服务器实例。

  • 使用 Reporting Services 配置工具将每个报表服务器连接到共享数据库。您一次只能连接并配置一台报表服务器。

  • 使用 Reporting Services 配置工具将新的报表服务器实例联接到已经与报表服务器数据库连接的第一个报表服务器实例来完成扩展。

为避免在将服务器实例连接到共享数据库时出现数据库兼容错误，应确保所有实例都为同一版本。例如，如果使用 SQL Server 2008 报表服务器实例创建报表服务器数据，则同一部署中的其他所有实例也必须为 SQL Server 2008 实例。有关详细信息，请参阅为扩展部署配置 Reporting Services。

下面的说明阐述如何配置双节点报表服务器扩展部署。重复本主题中所述的步骤可向部署中添加其他报表服务器节点。

如果打算在网络负载平衡 (NLB) 群集上承载扩展部署，则应当在配置扩展部署之前配置 NLB 群集。有关详细信息，请参阅如何在网络负载平衡群集上配置报表服务器。

安装 SQL Server 实例以承载报表服务器数据库

  1. 在将承载报表服务器数据库的计算机上安装 SQL Server 实例。至少需要安装 SQL Server 数据库引擎和 Reporting Services。

  2. 如有必要，请针对报表服务器启用远程连接。SQL Server 的某些版本在默认情况下不允许进行远程 TCP/IP 和 Named Pipes 连接。若要确认是否允许进行远程连接，请使用 SQL Server 配置管理器，然后查看目标实例的网络配置设置。如果远程实例还是一个命名实例，请验证目标服务器上的 SQL Server Browser 服务是否已启用且正在运行。SQL Server Browser 可提供用于连接到命名实例的端口号。

安装第一个报表服务器实例

  1. 安装属于部署内容的第一个报表服务器实例。安装 Reporting Services 时，请在“报表服务器安装选项”页上选择“安装但不配置服务器”选项。

  2. 启动 Reporting Services 配置工具。

  3. 配置报表服务器 Web 服务 URL、报表管理器 URL 和报表服务器数据库。有关详细信息，请参阅如何配置报表服务器。

  4. 验证报表服务器是否正常运行。有关详细信息，请参阅如何验证 Reporting Services 安装。

安装并配置第二个报表服务器实例

  1. 运行安装程序以在另一台计算机上安装第二个 Reporting Services 实例，或在同一台计算机上将其安装为命名实例。在安装 Reporting Services 时，请在“报表服务器安装选项”页上选择“安装但不配置服务器”选项。

  2. 启动 Reporting Services 配置工具，然后连接到刚安装的新实例。

  3. 将报表服务器连接到用于第一个报表服务器实例的数据库：

    1. 单击“数据库”打开“数据库”页。

    2. 单击“更改数据库”。

    3. 单击“选择现有报表服务器数据库”。

    4. 键入承载您要使用的报表服务器数据库的 SQL Server SQL Server 数据库引擎实例的服务器名称。此服务器必须是上述说明中连接到的服务器。

    5. 单击“测试连接”，再单击“下一步”。

    6. 在“报表服务器数据库”中，选择您为第一个报表服务器创建的数据库，然后单击“下一步”。默认名称为 ReportServer。请勿选择 ReportServerTempDB；它仅用于在处理报表时存储临时数据。如果数据库列表为空，请重复前四个步骤以建立服务器连接。

    7. 在“凭据”页中，选择报表服务器将用于连接到报表服务器数据库的帐户类型和凭据。可以使用与第一个报表服务器实例相同的凭据，也可以使用其他凭据。单击“下一步”。

    8. 单击“摘要”，再单击“完成”。

  4. 配置报表服务器 Web 服务 URL。先不要测试该 URL。在报表服务器联接到扩展部署后，该 URL 才会解析。

  5. 配置报表管理器 URL。先不要测试 URL，也不要试图验证部署。报表服务器在联接到扩展部署后才可用。

将第二个报表服务器实例联接到扩展部署

  1. 打开 Reporting Services 配置工具，然后连接到第一个报表服务器实例。由于已将第一个报表服务器初始化为执行可逆加密操作，因此它可用于将其他报表服务器实例联接到扩展部署。

  2. 单击“扩展部署”打开“扩展部署”页。您会看到两个条目，分别对应于连接到报表服务器数据库的两个报表服务器实例。第一个报表服务器实例应已联接。第二个报表服务器应在“等待联接”。如果您在自己的部署中没有看到类似的条目，请确认您已连接到已配置和初始化为使用报表服务器数据库的第一个报表服务器。

  3. 在“扩展部署”页上，选择等待联接部署的报表服务器实例，然后单击“添加服务器”。

  4. 现在应能验证两个报表服务器实例是否都正常运行。若要验证第二个实例，可以使用 Reporting Services 配置工具连接到报表服务器，然后单击“Web 服务 URL”或“报表管理器 URL”。

如果计划在负载平衡服务器群集中运行报表服务器，则需要进行额外配置。有关详细信息，请参阅如何在网络负载平衡群集上配置报表服务器。

请参阅

任务

如何为 Reporting Services 配置服务帐户
如何配置 URL（Reporting Services 配置）
如何创建报表服务器数据库（Reporting Services 配置）
如何启动 Reporting Services 配置

概念

配置报表服务器 URL
配置报表服务器数据库连接
添加和删除扩展部署的加密密钥
Reporting Services 配置操作指南主题

其他资源

规划扩展部署


如何在网络负载平衡群集上配置报表服务器

如何在网络负载平衡群集上配置报表服务器 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

如果要将报表服务器扩展配置为在网络负载平衡 (NLB) 群集上运行，必须执行以下操作：

  • 确保可通过映射到虚拟服务器 IP 地址的虚拟服务器名称来访问 NLB 群集。必须提供虚拟服务器名称，才能配置 NLB 群集的单入口点。在为每个报表服务器实例配置 URL 时，会将虚拟服务器名称指定为主机。

  • 配置视图状态验证以支持查看交互式报表。交互式报表通常会在单个用户会话期间多次呈现，以便为了响应用户操作而对新数据或不同数据进行可视化。通过配置视图状态验证，可以在用户会话期间保持连续性，而与实际请求由哪个报表服务器提供服务无关。

Reporting Services 不支持对扩展部署进行负载平衡，也不支持定义通过共享 URL 进行单点访问。您必须实现单独的软件或硬件 NLB 群集解决方案以支持 Reporting Services 扩展部署。

可以将 Reporting Services 安装在已经是 NLB 群集一部分的节点上，也可以先配置扩展部署，然后再安装群集软件。

报表服务器在 NLB 群集上的部署步骤

可以使用下面的指南来安装和配置部署：

步骤 | 说明 | 详细信息
1 | 在将 Reporting Services 安装在 NLB 群集内的服务器节点上之前，请检查扩展部署的要求。 | 规划扩展部署
2 | 配置 NLB 群集并验证它是否正常工作。 确保将主机标头名称映射到 NLB 群集的虚拟服务器 IP。主机标头名称用在报表服务器 URL 中，它比 IP 地址便于记忆和键入。 | 有关详细信息，请参阅您运行的 Windows 操作系统版本的 Windows Server 产品文档。
4 | 在已是 NLB 群集一部分的节点上以“仅文件”模式安装 Reporting Services，并为扩展部署配置报表服务器实例。 所配置的扩展部署将不响应那些定向到虚拟服务器 IP 的请求。在配置视图状态验证之后，会在以后的步骤中将扩展部署配置为使用虚拟服务器 IP。 | 如何配置报表服务器扩展部署（Reporting Services 配置）
5 | 配置视图状态验证。 为了达到最佳效果，请在配置扩展部署之后、配置报表服务器实例以使用虚拟服务器 IP 之前执行此步骤。通过先配置视图状态验证，可以避免在用户试图访问交互式报表时出现有关状态验证失败的异常。 | 本主题中的如何配置视图状态验证。
6 | 将 HostName 和 UrlRoot 配置为使用 NLB 群集的虚拟服务器 IP。 | 本主题中的如何配置 HostName 和 UrlRoot。
7 | 验证能否通过指定的主机名来访问服务器。 | 本主题中的验证报表服务器访问权限。

如何配置视图状态验证

若要在 NLB 群集上运行扩展部署，必须配置视图状态验证，以便用户可以查看交互式 HTML 报表。您必须针对报表服务器和报表管理器执行此操作。

视图状态验证由 ASP.NET 控制。默认情况下，将启用视图状态验证并使用 Web 服务的标识来执行验证。但是，在 NLB 群集方案中，存在运行于不同计算机上的多个服务实例和 Web 服务标识。因为每个节点的服务标识都各不相同，所以您无法依赖单个进程标识来执行验证。

若要解决此问题，可以生成一个任意验证密钥来支持视图状态验证功能，然后将每个报表服务器节点手动配置为使用同一密钥。可以使用随机生成的十六进制序列。十六进制序列的长度由验证算法（如 SHA1）确定。

  1. 通过使用由 .NET Framework 提供的 autogenerate 功能，生成一个验证密钥和解密密钥。最后，您必须具有单个 <machineKey> 条目，您可以将该条目粘贴到扩展部署中每个报表管理器实例的 Web.config 文件中。

    下面的示例说明了您必须获得的值。请不要将该示例复制到配置文件中，其中的密钥值是无效的。

    复制代码
    <machineKey validationKey="123455555" decryptionKey="678999999" validation="SHA1" decryption="AES"/>
  2. 打开报表管理器的 Web.config 文件，并在 <system.web> 部分粘贴所生成的 <machineKey> 元素。默认情况下，报表管理器的 Web.config 文件位于 \Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportManager\Web.config 中。

  3. 保存该文件。

  4. 对扩展部署中的每个报表服务器重复上述步骤。

  5. 确保 \Reporting Services\Report Manager 文件夹中所有 Web.Config 文件的 <system.web> 部分都包含相同的 <machineKey> 元素。

如何配置 HostName 和 UrlRoot

若要在 NLB 群集上配置报表服务器扩展部署，必须定义单个虚拟服务器名称，以提供服务器群集的单访问点。然后向您的环境中的域名服务器 (DNS) 注册此虚拟服务器名称。

在定义虚拟服务器名称之后，可以在 RSReportServer.config 文件中配置 HostName 和 UrlRoot 属性，以在报表服务器 URL 中包括虚拟服务器名称。

在报表环境中使用通配符 URL 保留项时，配置 HostName 属性。将 HostName 属性指定为 NLB 服务器的虚拟服务器名称时，报表环境的网络流量将定向到 NLB 服务器。然后，NLB 将在报表服务器节点之间分发请求。

此外，配置 UrlRoot 属性，以便报表链接处理的是已导出为静态报表的报表（例如 Excel 或 PDF 格式）或由订阅（例如电子邮件订阅）生成的报表。

如果将 Reporting Services 与 Windows SharePoint Services 3.0 或 Office SharePoint Server 2007 集成到一起，或者在自定义 Web 应用程序中承载报表，您可能需要仅配置 UrlRoot 属性。在这种情况下，将 UrlRoot 属性配置为 SharePoint 站点或 Web 应用程序的 URL。这会将报表环境的网络流量定位到处理报表的应用程序，而不是报表服务器或 NLB 群集。

请不要修改 ReportServerUrl。如果修改了此 URL，那么，在每次处理内部请求时，都将额外引入一个通过虚拟服务器的往返过程。有关详细信息，请参阅配置文件中的 URL (Reporting Services)。有关编辑配置文件的详细信息，请参阅如何修改 Reporting Services 配置文件。

  1. 在文本编辑器中打开 RSReportServer.config。

  2. 查找 <services> 部分，并将以下信息添加到配置文件，将 HostName 值替换为 NLB 服务器的虚拟服务器名：

    复制代码
    <HostName>virtual_server</HostName>
  3. 查找 UrlRoot。此元素未在该配置文件中指定，但是所使用的默认值是采用 http:// 或 https://<计算机名称>/<报表服务器> 格式的 URL，其中 <报表服务器> 是报表服务器 Web 服务的虚拟目录名称。

  4. 为 UrlRoot 键入一个包括群集虚拟名称的值，其格式为：http:// 或 https://<虚拟服务器>/<报表服务器>。

  5. 保存该文件。

  6. 对于扩展部署中的每个报表服务器，在其相应的 RSReportServer.config 文件中重复上述步骤。

验证报表服务器访问权限

验证是否可通过虚拟服务器名称（例如，https://MyVirtualServerName/reportserver 和 https://MyVirtualServerName/reports）访问扩展部署。

通过查看报表服务器日志文件或检查 RS 执行日志（该执行日志表包含的 InstanceName 列可以显示处理特定请求的实例名称），可以检查哪个节点实际处理报表。有关详细信息，请参阅 Reporting Services 日志文件。

如果不能连接到报表服务器上，请检查 NLB 以确保请求发送到报表服务器，并查看报表服务器 HTTP 日志，以确保服务器接收请求。

对失败的请求进行疑难解答

如果请求未到达报表服务器实例，请检查 RSReportServer.config 文件，验证虚拟服务器名称是否指定为报表服务器 URL 的主机名：

  1. 在文本编辑器中打开 RSReportServer.config 文件。

  2. 查找 <HostName>、<ReportServerUrl> 和 <UrlRoot>，并检查每个设置的主机名。如果该值不是预期的主机名，请将其替换为正确的主机名。

如果在做出以下更改后启动 Reporting Services 配置工具，则该工具可能会将 <ReportServerUrl> 设置更改为默认值。请始终保留一份配置文件的备份副本，以备需要用包含要使用的设置的版本替换该配置文件时使用。

请参阅

任务

如何启动 Reporting Services 配置
如何配置 URL（Reporting Services 配置）
如何配置报表服务器扩展部署（Reporting Services 配置）

概念

Reporting Services 配置操作指南主题

其他资源

规划扩展部署
RSReportServer 配置文件


如何配置报表服务器以进行远程管理

如何配置报表服务器以进行远程管理 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

在 Reporting Services 中，您可以通过本地或远程方式配置报表服务器实例。若要配置远程报表服务器实例，可以使用 Reporting Services 配置工具或编写使用 Reporting Services Windows Management Instrumentation (WMI) 提供程序的自定义代码。Reporting Services 配置工具为 WMI 提供程序提供了一个图形界面，这样您便可以直接配置报表服务器，而不必编写代码。启动该工具时，可以指定要连接的远程服务器。

在可以使用该工具配置远程报表服务器之前，必须按照本主题中的说明在 Windows 防火墙中启用端口、启用远程连接并启用远程 WMI 请求。

正确的配置可帮助您避免出现以下错误：

The machine could not be found.

"The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)".

必备项

若要修改防火墙设置，必须从本地登录，并且您必须是本地 Administrators 组的成员。不能通过远程连接来修改远程计算机的 Windows 防火墙设置。

如果要为非管理员用户启用远程管理，则必须为该帐户授予对分布式组件对象模型 (DCOM) 的远程激活权限。本主题提供了有关配置服务器以供非管理员访问的说明。

某些组织的组策略阻止某些操作系统或用户进行远程服务器管理。开始修改防火墙设置之前，请与网络管理员进行核实，以确认是否存在对远程管理的限制。

有关详细信息，请参阅 MSDN 上 Platform SDK 文档中的 Connecting Through Windows Firewall（通过 Windows 防火墙连接）。

任务

启用远程报表服务器配置的任务包括：

  • 在 Windows 防火墙中启用端口以允许报表服务器和 SQL Server 数据库引擎实例所使用的端口的请求。

  • 启用与承载报表服务器数据库的数据库引擎实例之间的远程连接。远程连接是配置报表服务器数据库连接和管理加密密钥所必需的。

  • 启用远程 WMI 请求以通过 Microsoft Windows 防火墙。

  • 如果要配置远程报表服务器以便由非管理用户进行管理，则必须设置 DCOM 权限以启用对标准 Windows 用户帐户的远程 WMI 访问。由于 WMI 使用 DCOM 作为远程调用传输方式，因此必须设置 DCOM 权限，以使不是以本地管理员身份登录的用户可以配置服务器。

  • 如果要配置远程报表服务器以便由非管理用户进行管理，则还必须设置对报表服务器 WMI 命名空间的 WMI 权限。默认情况下，本地管理员组的所有成员都有权访问报表服务器 WMI 命名空间。如果要对非管理员授予访问权限，则必须设置权限。

本主题中提供了有关如何执行这些任务的说明。

在 Windows 防火墙中打开端口

  1. 如何为数据库引擎访问配置 Windows 防火墙.

  2. 如何将防火墙配置为允许报表服务器访问.

配置与报表服务器数据库的远程连接

  1. 单击“开始”，依次指向“程序”、Microsoft SQL Server 2008、“配置工具”，然后单击“SQL Server 配置管理器”。

  2. 在左窗格中，展开“SQL Server 网络配置”，然后针对 SQL Server 实例单击“协议”。

  3. 在详细信息窗格中，启用“TCP/IP”和“命名管道”协议，然后重新启动 SQL Server 服务。

在 Windows 防火墙中启用远程管理

  1. 以本地管理员身份登录要启用远程管理功能的计算机。

  2. 如果报表服务器是在 Windows Vista 中运行，则右键单击“命令提示符”并选择“以管理员身份运行”。对于其他操作系统，请打开一个命令提示符窗口。

  3. 运行以下命令：

    复制代码
    netsh.exe firewall set service type=REMOTEADMIN mode=ENABLE scope=ALL

    可以指定不同的作用域选项。有关详细信息，请参阅 Windows 防火墙产品文档。

  4. 验证是否已启用远程管理。可以运行以下命令以显示状态：

    复制代码
    netsh.exe firewall show state

  5. 重新启动计算机。

设置 DCOM 权限为非管理员启用远程 WMI 访问

  1. 在“开始”菜单中，指向“管理工具”，单击“组件服务”。

    对于 Windows Vista，在“开始”菜单上依次单击“所有程序”、“运行”，然后输入 mmc comexp.msc。

  2. 打开“组件服务”文件夹。

  3. 打开“计算机”文件夹。

  4. 选择“我的电脑”。

  5. 在“操作”菜单中，选择“属性”。

  6. 单击“COM 安全”。

  7. 在“启动和激活权限”中单击“编辑限制”。

  8. 如果在“启动权限”中没有看到您的名称，请单击“添加”。

  9. 键入您的用户帐户名，然后单击“确定”。

  10. 在“<用户或组> 权限”的“允许”列中，选择“远程启动”和“远程激活”，然后单击“确定”。

为非管理员设置报表服务器 WMI 命名空间的权限

  1. 在“开始”菜单中，指向“管理工具”，单击“计算机管理”。

  2. 打开“服务和应用程序”文件夹。

  3. 右键单击“WMI 控件”，然后选择“属性”。

  4. 单击“安全性”。

  5. 打开 Root 文件夹。

  6. 打开 Microsoft 文件夹。

  7. 打开 SQLServer 文件夹。

  8. 打开 ReportServer 文件夹。

  9. 打开实例文件夹。如果安装了默认实例，则文件夹为 MSSQLSERVER。

  10. 打开 v10 文件夹。

  11. 选中 Admin 文件夹，然后单击“安全”。

  12. 单击“添加”，然后键入将用于管理服务器的用户帐户。

  13. 在“允许”列中，选择“启用帐户”、“远程启用”和“读取安全”，然后单击“确定”。

请参阅

任务

如何启动 Reporting Services 配置

其他资源

Reporting Services 配置工具
Reporting Services WMI Provider
配置报表服务器安装


如何为 Reporting Services 配置服务帐户

如何为 Reporting Services 配置服务帐户 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

在 Reporting Services 安装中，报表服务器 Web 服务、报表管理器和后台处理应用程序在一个服务内运行。运行该服务的帐户是在安装过程中定义的，即在“服务标识”页中指定的帐户；但是，如果希望使用不同的帐户或更改密码，可以使用 Reporting Services 配置工具。

如果您将报表服务器配置为使用 SharePoint 集成模式并使用 Reporting Services 配置工具更改了服务帐户，则您还必须打开 SharePoint 管理中心并使用 Reporting Services“授予数据库访问权限”页来重新应用报表服务器和实例设置。此步骤将授予新服务帐户访问 SharePoint 数据库的权限，将 Reporting Services 与 Windows SharePoint Services (WSS) 或 Microsoft Office SharePoint Server (MOSS) 集成在一起时需要执行此操作。有关如何在 SharePoint 管理中心授予数据库访问权限的详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

请始终使用 Reporting Services 配置工具来更新服务帐户，以便可以同时更新与该服务标识相关的其他设置。

配置报表服务器服务帐户

  1. 启动 Reporting Services 配置工具，再连接到报表服务器。

  2. 在“服务帐户”页上，根据您要使用的帐户类型选择相应选项。有关指定何种帐户类型的建议，请参阅配置报表服务器服务帐户。

  3. 如果选择了一个 Windows 用户帐户，请指定新的帐户名和密码。帐户名不能超过 20 个字符。

    如果报表服务器部署在支持 Kerberos 身份验证的网络中，则必须使用刚刚指定的域用户帐户注册报表服务器服务主体名称 (SPN)。有关详细信息，请参阅如何为报表服务器注册服务主体名称 (SPN)。

  4. 单击“应用”。

  5. 当系统提示您备份对称密钥时，请键入对称密钥备份的文件名和位置，并键入用于锁定和解锁该文件的密码，然后单击“确定”。

  6. 如果报表服务器使用该服务帐户连接到报表服务器数据库，则连接信息将更新为使用新的帐户或密码。更新连接信息要求连接到数据库。如果出现“SQL Server 数据库连接”对话框，请输入拥有连接到数据库的权限的凭据，然后单击“确定”。

  7. 当系统提示您还原对称密钥时，请键入在步骤 5 中指定的密码，并单击“确定”。

  8. 查看“结果”窗格中的状态消息以验证所有任务是否均已成功完成。

服务标识更新错误故障排除

更改服务标识将启动一系列事件，其中包括重新启动服务、更新受密码保护的加密密钥、更新 URL 保留项以及更新报表服务器数据库连接信息（如果使用该服务帐户来连接报表服务器数据库）。您可以通过查看页面底部“结果”窗格中的通知来监视这些事件的状态。如果在此过程中出现错误，可以尝试使用以下方法进行解决：

  • 如果无法还原对称密钥，可以尝试使用“加密密钥”页中的“还原”手动还原它。如果这不起作用，可以考虑删除加密的内容。您必须重新创建数据源连接信息和订阅，但其余内容仍然可用。有关详细信息，请参阅备份和还原加密密钥。

  • 如果服务未启动，请使用管理工具中的“服务”控制台应用程序手动重新启动它。

  • 更新服务帐户时可能会发生 URL 保留项错误。每个 URL 保留项都包含一个安全描述符，其中包含授权该服务帐户接受该 URL 上的请求的自由访问控制列表 (DACL)。更新帐户时，必须重新创建该 URL，以便用新帐户信息更新 DACL。如果无法重新创建 URL 保留项，并且您知道该帐户是有效的，请尝试重新启动计算机。如果错误仍然存在，请尝试使用不同的帐户。

请参阅

任务

如何启动 Reporting Services 配置

参考

服务帐户（Reporting Services 配置）

概念

配置报表服务器服务帐户
配置报表服务器数据库连接
配置和管理加密密钥

其他资源

服务体系结构 (Reporting Services)


如何配置 URL（Reporting Services 配置）

如何配置 URL（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

您必须为每个应用程序至少配置一个 URL 才能使用报表管理器或报表服务器 Web 服务。如果 Reporting Services 是在“仅文件”模式下安装的（即通过在安装向导的“报表服务器安装选项”页上选择“安装但不配置服务器”选项），则必须配置 URL。如果 Reporting Services 是采用默认配置安装的，则已经为每个应用程序配置了 URL。如果您将报表服务器配置为使用 SharePoint 集成模式，并使用 Reporting Services 配置工具更新了报表服务器 Web 服务 URL，则您还必须更新 SharePoint 管理中心中的 URL。

可以使用 Reporting Services 配置工具来配置 URL。URL 的所有部分均在此工具中定义。与早期版本不同，Internet Information Services (IIS) 网站不再提供对 SQL Server 2008 中的 Reporting Services 应用程序的访问。

Reporting Services 提供了在多数部署方案下均能发挥良好作用的默认值，这些部署方案包括与其他 Web 服务和应用程序的并行部署。默认 URL 包含实例名称，如果您在同一台计算机上运行多个报表服务器实例，则这可以最大限度地降低 URL 冲突的风险。

本主题提供有关以下任务的说明：

  • 为报表服务器 Web 服务创建 URL。

  • 为报表管理器创建 URL。

  • 设置高级 URL 属性以定义其他 URL。

有关如何存储和维护 URL 以及互操作性问题的详细信息，请参阅 关于 URL 保留和注册 (Reporting Services)和并行部署 Reporting Services 和 Internet Information Services。若要查看 Reporting Services 安装中经常使用的 URL 示例，请参阅本主题中的 URL 示例。

必备项

在创建或修改 URL 之前，请注意以下几点：

  • 您必须是报表服务器计算机上本地 Administrators 组的成员。

  • 如果同一台计算机上安装了 IIS 6.0 或 7.0，请检查使用端口 80 的任何网站上的虚拟目录的名称。如果发现任何虚拟目录使用默认 Reporting Services 虚拟目录名称（即“Reports”和“ReportServer”），请为您要配置的 Reporting Services URL 选择不同的虚拟目录名称。

  • 必须使用 Reporting Services 配置工具来配置 URL，而不要使用系统实用工具。切勿直接在 RSReportServer.config 文件的 URLReservations 部分中修改 URL 保留项。若要同时更新内部存储的基础 URL 保留项并同步存储在 RSReportServer.config 文件中的 URL 设置，则有必要使用 Reporting Services 配置工具。

  • 选择一个报表活动较少的时间。每次 URL 保留项发生更改时，都可能会回收报表服务器 Web 服务和报表管理器的应用程序域。

  • 有关 Reporting Services 中 URL 的结构和用法的概述，请参阅配置报表服务器 URL。

为报表服务器 Web 服务配置 URL

  1. 启动 Reporting Services 配置工具，然后连接到某个本地报表服务器实例。

  2. 单击“Web 服务 URL”。

  3. 指定虚拟目录。虚拟目录名称用于标识接收请求的应用程序。由于 IP 地址和端口可由多个应用程序共享，因而使用虚拟目录名称来指定接收请求的应用程序。

    此值必须唯一，以确保请求到达预期目标。此值是必需的，且区分大小写。虚拟目录名称和 Reporting Services 应用程序实例之间是一一对应的。如果创建多个指向同一应用程序实例的 URL，则必须在为此应用程序实例定义的所有 URL 中使用相同的虚拟目录名称。

    对于报表服务器 Web 服务，默认虚拟目录名称为 ReportServer。

  4. 指定用于在网络中唯一地标识该报表服务器计算机的 IP 地址。如果希望指定主机标头或者为同一应用程序实例定义其他 URL，则必须单击“高级”。有关如何设置 URL 的高级属性的说明，请参阅本主题后面的说明。否则，请使用“Web 服务 URL”页从下列值中进行选择：

    • “所有已分配的”指定分配给计算机的任何 IP 地址均可用在指向报表服务器应用程序的 URL 中。此值还包含友好主机名（如计算机名），域名服务器可将该主机名解析为分配给该计算机的 IP 地址。此为 Reporting Services URL 的默认值。

    • “所有未分配的”指定报表服务器将接收任何尚未由其他应用程序处理的请求。建议避免使用此选项。如果选择此选项，则具有更强 URL 保留项的另一个应用程序可能会截获发往该报表服务器的请求。

    • 127.0.0.1 是用于访问 localhost 的 IPv4 地址。它支持对报表服务器计算机进行本地管理。如果仅选择此值，则只有在本地登录到报表服务器计算机的用户可以访问应用程序。

    • ::1 是 IPv6 格式的环回地址。

    • 此列表中还显示特定 IP 地址。IP 地址可以采用 IPv4 和 IPv6 格式。Nnn.nnn.nnn.nnn 是计算机网络适配器的 32 位 IPv4 地址。IPv6 地址为 128 位，包含八个由冒号分隔的 4 字节字段：<前缀>:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn

      如果有多个网络适配器，或者如果网络同时支持 IPv4 和 IPv6 地址，则会看到多个 IP 地址。如果只选择一个 IP 地址，则会将应用程序限制为只能访问该 IP 地址（以及域名服务器映射到该地址的任何主机名）。您不能使用 localhost 访问报表服务器，也不能使用安装在报表服务器计算机上的其他网络适配器的 IP 地址。如果选择此值，则通常是因为您要配置多个还指定显式 IP 地址或主机名的 URL 保留项（例如，一个针对用于 Intranet 连接的网络适配器，另一个用于 Extranet 连接）。

  5. 指定端口。端口 80 是 Windows Server 2003、Windows Vista 和 Windows Server 2008 上的 Reporting Services 的默认端口，这是因为它可以与其他应用程序共享。如果使用 32 位 Windows XP SP2，则默认端口为 8080。如果希望使用自定义端口号，请记住必须始终在用于访问报表服务器的 URL 中指定它。可以使用以下方法来查找可用端口：

    • 在命令提示符下键入以下命令以返回正在使用的 TCP 端口的列表：

      netstat –a –n -p tcp

    • 查阅 Microsoft 支持文章 Information about TCP/IP port assignments（关于 TCP/IP 端口分配的信息），了解 TCP 端口分配以及已知端口（0 到 1023）、注册端口（1024 到 49151）和动态或专用端口（49152 到 65535）之间的区别。

    • 如果您正在使用 Windows 防火墙，则必须打开该端口。有关说明，请参阅如何将防火墙配置为允许报表服务器访问。

  6. 如果尚未进行验证，请验证 IIS（如果已安装）的虚拟目录名称是否与您要使用的名称不同。

  7. 如果安装了 SSL 证书，则现在可以选择它以将 URL 绑定到计算机上安装的 SSL 证书。

  8. （可选）如果选择了 SSL 证书，则可以指定一个自定义端口。默认端口为 443，但您可以使用任何可用端口。

  9. 单击“应用”创建 URL。

  10. 通过单击页面 URL 部分中的链接来测试该 URL。请注意，必须先创建并配置报表服务器数据库，然后才能测试 URL。有关说明，请参阅如何创建报表服务器数据库（Reporting Services 配置）。

  11. 此外，如果将报表服务器配置为使用 SharePoint 集成模式，则在 SharePoint 管理中心中配置报表服务器 Web 服务 URL。有关如何在 SharePoint 管理中心中更新报表服务器 Web 服务 URL 的详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

为报表管理器创建 URL 保留项

  1. 启动 Reporting Services 配置工具并连接到报表服务器实例。

  2. 单击“报表管理器 URL”。

  3. 指定虚拟目录。报表管理器与报表服务器 Web 服务将侦听相同的 IP 地址和端口。如果将报表管理器配置为指向不同的报表服务器 Web 服务，则必须在 RSReportServer.config 文件中修改报表管理器 URL 设置。有关说明，请参阅如何配置报表管理器。

  4. 如果安装了 SSL 证书，则可以选择它以要求通过 HTTPS 路由针对报表管理器的所有请求。

    （可选）如果选择了 SSL 证书，则可以指定一个自定义端口。默认端口为 443，但您可以使用任何可用端口。

  5. 单击“应用”创建 URL。

  6. 通过单击页面 URL 部分中的链接来测试该 URL。

设置高级属性以指定其他 URL

您可以通过指定不同的端口或主机名（域名服务器可以解析为分配给计算机的 IP 地址的 IP 地址或主机标头名称）为报表服务器 Web 服务或报表管理器保留多个 URL。通过创建多个 URL，可以为同一个报表服务器实例设置不同的访问路径。例如，若要启用报表服务器的 Intranet 和 Extranet 访问，可以为 Intranet 访问使用默认 URL，并为 Extranet 访问使用另一个完全限定的主机名：

  • http://myserver01/reportserver

  • http://www.adventure-works.com/reportserver

不能为同一个应用程序实例设置多个虚拟目录名称。每个 Reporting Services 应用程序实例只能映射到一个虚拟目录名称。如果同一台计算机上有多个 Reporting Services 实例，则应用程序的虚拟目录名称应包含实例名称以确保每个请求都能到达其预期目标。

设置 URL 的高级属性

  1. 在“Web 服务 URL”或“报表管理器 URL”页上，单击“高级”。

  2. 单击“添加”。

  3. 单击“IP 地址”或“主机标头名称”。如果指定主机标头，请确保指定一个 DNS 服务可以解析的名称。如果指定可以公共使用的域名，请包含整个 URL，包括 http://www。

  4. 指定端口。如果指定自定义端口，则应用程序的 URL 必须始终包含该端口号。

  5. 单击“确定”。

  6. 通过打开浏览器窗口并输入 URL 来测试 URL。

同一台计算机上多个报表服务器实例的 URL

如果为多个 Reporting Services 实例保留 URL，则应遵循下列命名约定以避免命名冲突。有关详细信息，请参阅多实例报表服务器部署的 URL 保留项。

URL 配置示例

下面列出了报表服务器 URL 的某些可能样式示例：

  • http://localhost/reportserver

  • http://localhost/reportserver_SQLEXPRESS

  • http://sales01/reportserver

  • http://sales01:8080/reportserver

  • https://sales.adventure-works.com/reportserver

  • https://www.adventure-works.com:8080/reportserver01

用来访问报表管理器的 URL 也具有类似的格式，并通常创建在承载报表服务器的同一网站下。唯一的不同是虚拟目录名称（这里是 reports，不过您可以将其配置为需要的任意名称）：

  • http://localhost/reports

  • http://localhost/reports_SQLEXPRESS

  • http://sales01/reports

  • http://sales01:8080/reports

  • https://sales.adventure-works.com/reports

  • https://www.adventure-works.com:8080/reports

请参阅

任务

如何启动 Reporting Services 配置

概念

配置报表服务器 URL

其他资源

在 Reporting Services 中配置身份验证


如何在 SharePoint 管理中心中配置报表服务器集成

如何在 SharePoint 管理中心中配置报表服务器集成 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

如果要将报表服务器配置为在所部署的 SharePoint 产品或技术中运行，则必须指定用来确定 SharePoint 技术实例和 Reporting Services 报表服务器之间连接的集成设置。

  • 您必须是 SharePoint 站点或场的管理员才能配置报表服务器集成：

  • 必须已经安装了提供配置页的 Reporting Services 外接程序。

  • 还必须有一个目标报表服务器，该服务器已连接到为 SharePoint 集成运作模式创建的报表服务器数据库。

  • 如果要将 Reporting Services 配置为在 SharePoint 服务器场中运行，则报表服务器计算机上还必须安装 SharePoint Web 前端。

您指定的设置已存储在配置数据库中。如果您在为一个包含多个虚拟服务器的场配置集成，则这些设置将供所有已在 SharePoint 场中启用而且装有 Reporting Services 外接程序的 Web 前端使用。

如果您以后修改报表服务器服务帐户或者将 SharePoint 场扩展为包括其他应用程序，则必须重新运行“授予数据库访问权限”命令才能更新 SharePoint 配置数据库中的访问权限。有关详细信息，请参阅配置报表服务器服务帐户。

有关整套任务的详细信息，请参阅将 Reporting Services 配置为 SharePoint 3.0 集成模式。

注意：
定义报表服务器 URL 之后，稍后进行修改时一定要谨慎。修改报表服务器 URL 将会中断服务器之间的连接，这会使当前处理的报表和模型受到影响。如果更改生产服务器上的报表服务器 URL，请确保按照为您的单位预先确定的停机步骤来进行操作。

在管理中心中指定报表服务器集成设置

  1. 在“管理工具”中，单击 SharePoint 3.0 管理中心。

  2. 单击“应用程序管理”选项卡。

    在 Reporting Services 部分中，应当能够看到下列链接：管理集成设置、授予数据库访问权限和设置服务器默认值。如果您没有看到该部分或者这些链接，则说明您的计算机上没有安装 Reporting Services 外接程序或者该功能尚未激活。有关详细信息，请参阅如何在 SharePoint 管理中心中激活报表服务器功能。

  3. 单击“管理集成设置”。

  4. 在“报表服务器 Web 服务 URL”中，指定要与当前的 SharePoint 站点或场一起使用的报表服务器站点。该 URL 可以指向单个报表服务器实例，也可以是一组负载平衡报表服务器（在扩展部署中运行）的虚拟服务器名称。

    若要获取 URL，请打开 Reporting Services 配置工具，连接到报表服务器，然后单击“Web 服务 URL”。单击该 URL，验证其是否有效。复制该 URL 并将其粘贴到“报表服务器 Web 服务 URL”中。

    报表服务器 URL 中包括在 Reporting Services 配置工具中指定的服务器名称和虚拟目录。下面的示例说明了如何构造报表服务器 URL：

    • http://your-server-name/reportserver（如果报表服务器位于不同的计算机，则可使用此示例）。

    • http://your-server-name:8080/reportserver（如果报表服务器在 Microsoft Windows XP SP2 上运行，则可以使用此示例）。

    • https://your-server-name:443/reportserver。

    请不要为用于整个 SharePoint 场的报表服务器 URL 指定 http://localhost。对于安装在远程服务器上的 SharePoint Web 前端，指定了 http://localhost 的 URL 地址将无效。

    如果将报表服务器与 SharePoint 技术实例并行安装，请检查虚拟目录名称是否存在冲突。有关互操作性问题的详细信息，请参阅并行部署 Reporting Services 和 Internet Information Services。

  5. 在“身份验证模式”中，选择“Windows 身份验证”或“可信身份验证”，以便指定安装在 SharePoint 服务器上的报表服务器端点是否为报表服务器上的模拟连接发送带有安全令牌的标头。

    Reporting Services 应用程序页上的用户操作发出的所有请求都将由 SharePoint Web 应用程序上的报表服务器端点转发到报表服务器进行处理。根据身份验证模式，这些请求的标头中可以包括也可以不包括 SharePoint 用户标识令牌。

    如果将 SharePoint Web 应用程序配置为进行 Windows 身份验证配置并启用了 Kerberos 协议，则可以选择“Windows 身份验证”来通过 Windows 集成安全性进行连接。在这种情况下，将不发送用户标识令牌。（可选）可以选择“可信身份验证”来模拟可信帐户并将请求标头中的 SharePoint 用户信息发送到报表服务器。

    如果将 SharePoint Web 应用程序配置为进行窗体身份验证，则该请求标头将始终包含 SharePoint 用户标识，并且将忽略您为身份验证模式指定的任何值。有关服务器连接的详细信息，请参阅 SharePoint 集成模式下的 Reporting Services 安全性概述。

  6. 单击“确定”。

  7. 在“Reporting Services”部分中，单击“授予数据库访问权限”。在此步骤中，将从报表服务器实例检索服务帐户信息。将为报表服务器服务帐户创建数据库登录名和权限。若要集成 Reporting Services 报表服务器和 SharePoint Web 应用程序，报表服务器应能够访问 SharePoint 配置和内容数据库。报表服务器服务必须能够以具有读写权限的可信用户身份进行连接。

  8. 指定报表服务器的名称。默认情况下，此名称即为计算机的名称。

  9. 指定该实例是默认实例还是命名实例。如果您不确信，请启动 Reporting Services 配置工具，然后连接到报表服务器。在“连接到报表服务器实例”对话框中，展开“实例名称”来查看服务器上所安装实例的列表。MSSQLSERVER 是默认实例的名称。所有其他实例都是命名实例。

  10. 单击“确定”。

    将打开“输入凭据”对话框。

  11. 在“输入凭据”对话框中，指定用户名和密码以连接到报表服务器检索服务帐户信息。请确保为其输入凭据的帐户为报表服务器计算机的本地 Administrators 的成员。

  12. 在“Reporting Services”部分中，单击“设置服务器默认值”。

  13. 在“报表历史记录默认值”中，为要保留的报表历史记录副本数设置站点范围内的默认值。默认值提供了一个初始设置，可用其确定可以为每个报表存储的快照数。可以在特定报表的属性页中指定其他限制。

  14. 在“报表处理超时”中，指定在一定时间段（以秒为单位）之后报表服务器上的报表处理是否超时。此值应用于报表服务器上的报表处理。它不会影响为报表提供数据的数据库服务器上的数据处理。报表处理计时器时钟在您选择报表时开始运行，而在报表打开时结束运行。所指定的值必须足以完成数据处理和报表处理。

  15. 在“报表处理日志”中，指定报表服务器是否会生成跟踪日志及日志的保留天数。您可以指定报表服务器是否会生成跟踪日志及指定日志保留的天数。这些日志存储在报表服务器计算机上的 \Microsoft SQL Server\MSSQL.n\ReportServer\Log 文件夹中。每次重新启动该服务时都要启动新的日志文件。有关日志文件的详细信息，请参阅 报表服务器服务跟踪日志。

  16. 在“启用 Windows 集成安全性”中，指定与报表数据源的连接是否可以使用请求报表的用户的 Windows 安全令牌。

  17. 在“启用即席生成报表”中，指定用户是否可以从报表生成器报表执行即席查询。设置此选项会设置报表服务器的 EnableLoadReportDefinition 属性。如果清除此选项，则报表服务器将不会为使用报表模型作为数据源的报表生成点击链接型报表。

  18. 单击“确定”。

请参阅

任务

如何在独立服务器上配置 SharePoint 集成
如何在多台服务器上配置 SharePoint 集成
如何在报表服务器计算机中安装 SharePoint Web 前端

概念

如何安装或卸载 Reporting Services 外接程序
如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）

其他资源

Reporting Services 和 SharePoint 技术的集成
管理报表历史记录
从 SharePoint 站点查看和管理报表服务器项
设置报表处理超时值


如何在独立服务器上配置 SharePoint 集成

如何在独立服务器上配置 SharePoint 集成 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

在 SharePoint 集成模式下运行 Reporting Services 的部署方案之一就是将所有服务器组件和应用程序数据库安装在一台独立服务器上。如果您希望了解这些技术如何协作，或者要开发自定义应用程序并希望只需一台计算机即可运行所有服务，则该配置非常有用。下图说明了必须安装的组件。

位于一台计算机上的 Reporting Services 和 SharePoint

必备项

安装组件之前，请确保执行以下操作：

  • 查阅部署配置的介绍，熟悉将要安装的组件。有关详细信息，请参阅 SharePoint 集成模式下的 Reporting Services 的部署拓扑。

  • 查阅配置概述主题，获取有关服务帐户配置的最佳实践建议，并了解有关配置步骤的更多信息。有关详细信息，请参阅将 Reporting Services 配置为 SharePoint 3.0 集成模式。

  • 查阅适用于在 SharePoint 集成模式下包括 Reporting Services 的所有部署方案的硬件和软件要求。有关详细信息，请参阅在 SharePoint 集成模式下运行 Reporting Services 的要求。

  • 查阅本主题中的其余章节，了解适用于独立服务器配置的其他要求。

独立服务器配置的数据库注意事项

Reporting Services 和 SharePoint 产品和技术均使用 SQL Server 关系数据库来存储应用程序数据。Reporting Services 需要使用兼容版本的数据库引擎的一个实例。如果您提供了数据库服务器，则 SharePoint 产品和技术可以使用现有的数据库服务器。如果您未提供数据库服务器，安装程序将会将 SQL Server Embedded Edition 安装为内部组件并将它用于应用程序数据库。由于您已经为 Reporting Services 安装了数据库引擎，所以可以考虑将该实例同时用于 SharePoint 应用程序数据库。

但是，如果您允许安装程序安装和使用 SQL Server Embedded Edition，则可以显著减少安装和配置步骤。如果您拥有足够的磁盘空间，则应当使用 SharePoint 提供的 Embedded Edition。

如果您不希望计算机上有多个 SQL Server 实例，则可以将数据库引擎用于 SharePoint 配置和内容数据库。为此，在安装 SharePoint 产品或技术时，必须选择“高级”安装选项。

注意：
报表服务器实例不能将 Embedded Edition 用于其数据库。但是，由 SharePoint 产品或技术安装的 Embedded Edition 实例可以与您可能同时安装的其他数据库引擎版本并存。有关报表服务器数据库版本要求的详细信息，请参阅创建报表服务器数据库。

安装顺序

可以按任意顺序安装组件技术，但是，为了获得最佳效果，应当先安装 Reporting Services，并在确认安装有效后再安装 SharePoint 产品或技术。

为了节省步骤，应当同时安装 Reporting Services 和数据库引擎。由于要一起安装数据库引擎和 Reporting Services，因此您将很可能有机会以默认配置安装 Reporting Services，在默认配置中，虚拟目录、服务帐户和报表服务器数据库均在安装过程中自动配置。

以下列表概述了必须执行的部署任务：

  1. 安装 Reporting Services 和数据库引擎。如有可能，请在安装 Reporting Services 时选择“安装 SharePoint 模式默认配置”选项。否则，可以选择“安装但不配置”选项，在执行安装后任务的过程中配置服务器。

  2. 配置报表服务器（如果尚未对其配置），并确认您拥有有效的安装。

  3. 下载并安装 Microsoft .NET Framework 3.0 可再分发包。

  4. 安装 Windows SharePoint Services 或 Office SharePoint Server 2007。选择“基本”安装选项。

  5. 运行 SharePoint 产品和技术配置向导，然后打开 SharePoint 站点以确认您拥有有效的安装。

  6. 下载并安装用于 SharePoint 技术的 Reporting Services 外接程序。

  7. 在管理中心中配置报表服务器集成功能。

安装 Reporting Services 和数据库引擎

  • 将 Reporting Services 和数据库引擎安装到同一台计算机上。有关详细信息，请参阅如何安装 SQL Server 2008（安装程序）。

  • 配置报表服务器，但是在创建报表服务器数据库时，选择与 SharePoint 集成模式相对应的选项。有关详细信息，请参阅如何配置报表服务器。

在完成安装之后，可以通过连接到报表服务器验证该安装是否成功。可以通过在浏览器窗口的 URL 地址中输入 http://localhost/reportserver 来测试连接。

下载并安装 .NET Framework 3.0 可再分发包

  1. 从 Microsoft 下载中心下载 .NET Framework 3.0 redistributable package（.NET Framework 3.0 可再分发包）。

  2. 运行安装程序。安装程序将在后台运行，而且可能需要一些时间才能完成。若要检查安装进度，请在任务栏的通知区域中单击 Microsoft .NET Framework 3.0 安装图标。

安装并配置 Windows SharePoint Services 或 Office SharePoint Server

  1. 从安装媒体中运行 Setup.exe。

  2. 输入由 25 个字符组成的产品密钥。

  3. 接受软件许可协议。

  4. 单击“基本”。

    此选项提供的安装步骤最少。它会立即使用所有默认值来安装软件。它还自动执行用于设置管理中心和默认 SharePoint 站点的配置步骤。

    如果要使用现有的数据库引擎实例，必须改为单击“高级”。如果选择该选项，安装程序会提供“完全”安装选项，供您指定要使用的数据库服务器。请记住，选择“高级”安装选项会增加以后必须执行的配置步骤的复杂程度。有关如何指定和配置“高级”安装的详细信息，请按照如何在多台服务器上配置 SharePoint 集成中的“安装 SharePoint 产品或技术”过程操作。在完成多服务器部署主题中的“高级”安装和配置步骤时，请返回到本主题，更改端口分配情况并继续执行其余任务。

  5. 在“已完成”页中，验证与“运行 SharePoint 产品和技术配置向导”相对应的复选框是否处于选中状态。

  6. 单击“关闭”。

    在安装程序关闭之后，SharePoint 产品和技术配置向导将运行。如果选择的是“基本”安装选项，配置任务将在后台运行，您可以在配置任务完成后单击“完成”。

  7. 验证安装是否成功。默认情况下，在完成配置任务之后，SharePoint 站点将在浏览器窗口中打开。此步骤将验证安装和配置过程。

默认情况下，SharePoint 产品和技术配置向导会为 SharePoint Web 应用程序分配端口 80，这将导致报表服务器变得不可用。因此，您现在必须将报表服务器配置设置修改为使用另一个端口，而且必须启动默认网站。

验证是否已针对 SharePoint 集成模式配置了报表服务器数据库

  1. 启动 Reporting Services 配置工具并连接到报表服务器实例。有关说明，请参阅如何启动 Reporting Services 配置。

  2. 在“报表服务器状态”页中，验证“报表服务器模式”是否设置为“SharePoint 集成”。

  3. 如果没有针对 SharePoint 集成模式配置报表服务器，请单击“数据库”，并针对 SharePoint 集成模式创建报表服务器数据库。有关说明，请参阅如何创建报表服务器数据库（Reporting Services 配置）和如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）。

如果您使用的是新安装的 Reporting Services 并且希望支持无人参与的报表执行，则还应配置无人参与的报表处理帐户。或者，配置报表服务器，以通过电子邮件进行传递。有关详细信息，请参阅配置无人参与的执行帐户和配置报表服务器以进行电子邮件传递。

下载并安装用于 SharePoint 技术的 Reporting Services 外接程序

  1. 单击 Microsoft SQL Server 打开 Microsoft 网站的下载页面。

    重要提示：
    若要安装 Reporting Services 外接程序，您必须是 SharePoint Web 场管理员和网站集管理员。

  2. 选择要安装的语言。

  3. 在“此下载中包括的文件”中，单击“下载”以安装 32 位或 64 位版本的 Reporting Services 外接程序。

  4. 单击“保存”将该文件保存到您的计算机上的某个位置。

  5. 打开 Windows 资源管理器并浏览到该文件所在的文件夹。

  6. 双击 SharePointRS.msi 开始安装。有关详细信息，请参阅如何安装或卸载 Reporting Services 外接程序。

  7. 获取 Reporting Services 外接程序的最新版本的自述文件以了解最新的更改和已知问题。在 Microsoft 网站的下载页中，在“此下载中包括的文件”中单击“下载”以打开 readme_rsaddin.htm 文件，然后将该文件保存到您的计算机上。

配置报表服务器集成

  1. 依次单击“开始”、“管理工具”和“SharePoint 3.0 管理中心”。

    重要提示：
    若要完成以下步骤，您必须是 SharePoint 场管理员组的成员和网站集管理员。

  2. 单击“应用程序管理”。应该会看到一个名称为 Reporting Services 的新的部分。该部分包含一些链接，这些链接所指向的页面可用来指定集成设置。如果您没有看到该部分，则必须激活报表服务器集成功能。有关详细信息，请参阅如何在 SharePoint 管理中心中激活报表服务器功能。

    您必须至少设置报表服务器 URL、选择身份验证模式并授予报表服务器访问 SharePoint 数据库的权限。有关详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

  3. 关闭管理中心。

后续步骤

通过启动 Reporting Services 配置工具并打开“SharePoint 集成”页查看服务器状态来验证集成。您应该会看到可以单击以启动 SharePoint 管理中心的链接。

也可以通过打开报表服务器的浏览器窗口来验证安装。URL 应当类似于 http://example-server-name:8080/reportserver。该 URL 指向代理端点。在 SharePoint 库中添加报表服务器项后，您可以将浏览器窗口打开到该 URL 以查看该站点上的各项。

最后，您应能够打开 SharePoint Web 应用程序并能够将报表和其他文档上载到 SharePoint 库。

在安装了所有组件并配置了用来连接服务器组件的设置之后，必须分配相应的权限、添加内容类型并在 SharePoint 库中添加报表服务器项。
完成服务器集成部署任务
  1. 打开 SharePoint Web 应用程序。默认情况下，该 URL 为 http://<服务器名称>。

  2. 设置权限以授予用户访问 SharePoint 站点的权限。安全性是必需的，但如果要继承现有的权限，则不必设置对特定项的权限。有关详细信息，请参阅在 SharePoint 站点上为报表服务器项授予权限或如何在 SharePoint 站点上为报表服务器项设置权限（SharePoint 集成模式下的 Reporting Services）。

  3. 如果要创建新的共享数据源、报表模型和报表生成器报表，请添加 Reporting Services 内容类型。有关详细信息，请参阅如何将报表服务器内容类型添加到库中（SharePoint 集成模式下的 Reporting Services）。

  4. 创建共享数据源以与报表和模型配合使用。有关详细信息，请参阅如何创建和管理共享数据源（SharePoint 集成模式下的 Reporting Services）。

  5. 创建共享计划以与订阅或无人参与的报表处理配合使用。有关详细信息，请参阅如何创建和管理共享计划（SharePoint 集成模式下的 Reporting Services）。

  6. 将报表定义文件 (.rdl)、数据源文件 (.rds) 和报表模型文件 (.smdl) 发布到 SharePoint 库。您还可以在 SharePoint 库中使用上载命令以上载 .rdl 和 .smdl 文件，但不能上载 .rds 文件。根据您拥有的权限，还可以在报表生成器中创建报表，并将报表保存到库中。如果这些报表包含对共享数据源或外部文件的引用，则必须更新这些引用。有关详细信息，请参阅将模型和共享数据源部署到 SharePoint 站点和如何将文档上载到 SharePoint 库（SharePoint 集成模式下的 Reporting Services）。

上载报表时，请确保报表的数据源属性正确。数据源必须具有有效的外部数据源连接字符串。凭据类型必须对您的网络拓扑有效。特别要注意的是，如果您的域未启用 Kerberos 身份验证，则不能使用 Windows 集成安全性凭据类型。相反，应指定存储的凭据。验证数据源属性正确之后，可以单击报表名称来打开报表。该报表将在报表查看器 Web 部件中自动打开。

如果报表未打开，请检查您对该报表拥有的权限，并检查用来定义与外部数据源连接的数据源属性。在站点或场上，SharePoint 权限用于控制对报表、报表模型、共享数据源以及报表生成器工具（用来创建即席报表）的访问权限。如果用户看不到这些项，则应验证权限是否设置正确。

无法通过报表管理器或 SQL Server Management Studio 管理运行在 SharePoint 集成模式下的报表服务器。关于支持的功能和不支持的功能的完整列表，请参阅 Reporting Services 在 SharePoint 集成模式下支持的功能。

请参阅

任务

如何在多台服务器上配置 SharePoint 集成

概念

将 Reporting Services 配置为 SharePoint 3.0 集成模式

其他资源

在 SharePoint 集成模式下运行 Reporting Services 的要求
SharePoint 集成模式下的 Reporting Services 的部署拓扑
规划部署模式
Reporting Services 和 SharePoint 技术的集成


如何在多台服务器上配置 SharePoint 集成

如何在多台服务器上配置 SharePoint 集成 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

本主题提供以 SharePoint 集成模式在多服务器部署拓扑中安装和配置 Reporting Services 的分步说明。如果有大量用户从 SharePoint 站点访问报表，建议采用此配置。下图说明了必须安装的组件。

分离的 Reporting Services 和 SharePoint

必备项

在开始安装组件之前，请确保执行以下操作：

  • 查阅部署配置的介绍，熟悉将要安装的组件。有关详细信息，请单击 SharePoint 集成模式下的 Reporting Services 的部署拓扑。

  • 查阅有关为服务帐户配置建议的最佳实践的配置概述主题，并了解有关配置步骤的更多信息。有关详细信息，请单击将 Reporting Services 配置为 SharePoint 3.0 集成模式。

  • 查阅适用于在 SharePoint 集成模式下包括 Reporting Services 的所有部署方案的硬件和软件要求。有关详细信息，请单击在 SharePoint 集成模式下运行 Reporting Services 的要求。

  • 查阅本节中的其余各项，了解适用于独立服务器配置的其他要求。
多服务器部署的服务器要求

必须至少有两台或三台服务器。如果预计用户相当多，则通常将应用程序数据承载到由数据库引擎以独占方式使用的第三台服务器上以改进性能。

如果使用两台服务器，则每台服务器都应当具有以下组件：

  • 在一台服务器上安装 SQL Server 2008 Reporting Services (SSRS) 和数据库引擎。此服务器将用来承载报表服务器、报表服务器数据库和 SharePoint 应用程序数据库。

  • 在第二台服务器上，安装 Microsoft .NET Framework 3.0 可再分发包（SharePoint 产品或技术的实例）和 Reporting Services 外接程序。此服务器将成为场中的主服务器。管理中心将安装在此服务器上。用户将从该计算机上的网站集访问报表服务器内容。

多服务器部署的帐户要求

必须有一个域用户帐户才能将 SharePoint 产品或技术的实例连接到 SharePoint_config 数据库。服务器场要求使用域帐户建立服务和数据库连接。如有可能，请创建一个只能用于该应用程序的新帐户。请避免使用您自己的凭据或者将以普通用户身份访问 SharePoint 站点的任何用户的凭据（您将遇到“访问被拒绝”错误）。

必须为域帐户创建一个 SQL Server 数据库登录名。此登录名需要对服务器具有 DBCreator 权限。

必须将 SharePoint 应用程序池进程帐户配置为作为域用户运行。

必须将报表服务器服务配置为作为域用户帐户运行。

重要提示：
对于分布式服务器部署（其中报表服务器、SharePoint Web 应用程序和服务器数据库位于三台不同的计算机上），可以使用包含默认网站和端口分配的默认设置。如果将 SharePoint Web 应用程序和报表服务器安装在不同的计算机上，但将 SharePoint 数据库放在报表服务器计算机上，那么，除非遵循上节所述的有关服务帐户配置的准则，否则将遇到连接错误。有关详细信息，请参阅如何为 Reporting Services 配置服务帐户。

管理员凭据是执行如下操作所必需的：运行所有的安装程序；授予权限以成为网站集主管理员；在配置报表服务器集成时授予数据库访问权限。

安装顺序

可以按任意顺序安装组件技术。为了获得最佳结果，请确认在集成每个服务器产品或技术之前已正确安装它们。

下面列出了部署任务的摘要：

  1. 安装 Reporting Services 和数据库引擎。如果要在生产服务器上安装服务器软件，或者使用的是三服务器部署配置，请计划选择“安装但不配置服务器”选项，以便可以控制报表服务器的配置时间和方式。

  2. 配置报表服务器并验证安装是否有效。

  3. 下载并安装 .NET Framework 3.0 可再分发包。

  4. 安装 Windows SharePoint Services 或 Office SharePoint Server 2007。计划选择“高级”安装选项，以便可以在配置过程中指定远程数据库服务器。

  5. 运行 SharePoint 产品和技术配置向导并选择数据库服务器。

  6. 在管理中心中配置网站集功能，并打开 SharePoint 站点以确认安装有效。

  7. 下载并安装用于 SharePoint 技术的 Reporting Services 外接程序。

  8. 在管理中心中配置报表服务器集成功能。

安装 Reporting Services 和数据库引擎

  • 将 Reporting Services 和数据库引擎安装在相同或不同计算机上。有关详细信息，请参阅安装 Reporting Services 的注意事项。

在完成安装之后，将报表服务器配置为执行本机模式操作以验证安装是否成功。这样做之后，将可以使用报表管理器来验证安装。

有关如何启动 Reporting Services 配置工具以及如何将报表服务器配置为执行本机模式操作的说明，请参阅 Reporting Services 配置操作指南主题。

下载并安装 .NET Framework 3.0 可再分发包

  1. 在另一台将用于 SharePoint 产品或技术实例的服务器上，从 Microsoft 下载中心下载 .NET Framework 3.0 redistributable package（.NET Framework 3.0 可再分发包）。

  2. 运行安装程序。安装程序将在后台运行，而且可能需要一些时间才能完成。若要检查安装进度，请在任务栏的通知区域中单击 Microsoft .NET Framework 3.0 安装图标。

安装 SharePoint 产品或技术

  1. 从 Windows SharePoint Services 3.0 或 Microsoft Office SharePoint Server 的安装媒体中运行 Setup.exe。

  2. 输入由 25 个字符组成的产品密钥。

  3. 接受软件许可协议。

  4. 单击“高级”。

    1. 在“服务器类型”中，单击“Web 前端”。

    2. “数据位置”选项卡用于指定搜索索引文件的位置。在“数据位置”中，使用默认值或选择具有多余磁盘空间的计算机。

    3. 单击“立即安装”。

  5. 配置 SharePoint 产品或技术。SharePoint 产品和技术配置向导应在安装完成后启动。如果未启动，请从“管理工具”中启动它。

    1. 在欢迎屏幕上，单击“下一步”。

    2. 如有必要，单击“是”以重新启动此服务。

    3. 在“连接到服务器场”页上，单击“否，我希望创建新的服务器场”，然后单击“下一步”。

    4. 在“指定配置数据库设置”页上，输入数据库服务器的名称。如果将数据库引擎安装为默认实例，则数据库服务器与计算机同名。

    5. 在“用户名”和“密码”中，键入有权登录该计算机、具有 SQL Server 数据库登录名并对该服务器具有 DBCreator 权限的域用户帐户的凭据。如有可能，请指定一个仅用来运行该应用程序的帐户。请不要键入将在以后访问 SharePoint 站点的用户的凭据；否则，该用户可能会在以后访问该站点上的内容时收到“访问被拒绝”错误。单击“下一步”。

    6. 在“配置 SharePoint 管理中心”页上，单击“下一步”接受所有默认值。如果已知在域中针对 Windows 身份验证启用了模拟和委托功能，则可以改为选择“协商(Kerberos)”。否则，请选择默认值并单击“下一步”。

    7. 在“正在完成 SharePoint 产品和技术配置向导”上，单击“下一步”开始使用指定的设置进行配置。

    8. 单击“完成”。

配置 SharePoint Web 应用程序

  1. 依次单击“开始”、“管理工具”和“SharePoint 3.0 管理中心”。按照管理员任务中的检查表操作。有关每个任务的详细信息，请单击“阅读部署步骤”链接，然后打开“快速入门指南”。需要执行以下步骤中的任务。

  2. 创建 Web 应用程序：

    1. 单击“创建 SharePoint 网站”。

    2. 单击“新建 Web 应用程序”。

    3. 选择使用默认值“新建 IIS 网站(SharePoint - 80)”。这包括使用端口 80、不使用主机标头、使用默认路径、使用 NTLM 和不使用匿名访问。请确保指定应用程序池进程帐户。选择一个域用户帐户。

    4. 单击“确定”。

  3. 在“已创建应用程序”页上单击“创建网站集”。

    1. 输入一个标题。

    2. 对于所有选项均使用默认值。在指定网站集主管理员时，指定具有本地管理员权限的帐户。

    3. 单击“确定”。

  4. 打开命令提示符窗口并键入 iisrest /noforce。

  5. 单击此 URL 以验证网站。

  6. （可选）在管理中心中，启用诊断日志记录。

将报表服务器配置为 SharePoint 集成模式

  1. 在报表服务器计算机上安装和配置 SharePoint Web 前端。有关说明，请参阅如何在报表服务器计算机中安装 SharePoint Web 前端。

    1. 浏览器窗口将打开至主服务器上的管理中心，可以在这里验证服务器场的配置是否成功。

  2. 配置报表服务器集成：

    1. 启动 Reporting Services 配置工具并连接到报表服务器实例。有关说明，请参阅如何启动 Reporting Services 配置。

    2. 在左导航窗格内，单击“服务帐户”。验证它使用的是否为域用户帐户。如果不是，请将它配置为使用域用户帐户。

    3. 在导航窗格内，单击“数据库”。

      注意：
      如果使用的是远程数据库引擎实例，请参阅如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）了解详细信息。

    4. 单击“更改数据库”。

    5. 选择“新建数据库”。

    6. 单击“下一步”。

    7. 指定将承载该数据库的数据库引擎实例。

    8. 单击“测试连接”，确认可以连接到它。

    9. 单击“下一步”。

    10. 在“数据库名称”中，键入新数据库的名称（例如，reportserverSharepointMode）。

    11. 选择“SharePoint 集成模式”。

    12. 单击“下一步”。

    13. 指定报表服务器用于连接到报表服务器数据库的凭据。

    14. 单击“下一步”。

    15. 单击“下一步”。

    16. 单击“完成”。

    17. 配置无人参与的执行帐户和其他要更改的任何设置。报表服务器虚拟目录的值应当仍有效。但是，在将报表服务器配置为使用 SharePoint 集成模式数据库之后，报表管理器将不再可用（报表管理器虚拟目录的选项卡应当显示为灰色）。

下载并安装 Reporting Services 外接程序

  1. 单击 Microsoft SQL Server 200 打开 Microsoft 网站的下载页面。

    重要提示：
    若要安装 Reporting Services 外接程序，您必须是 SharePoint Web 场管理员和网站集管理员。

  2. 选择要安装的语言。

  3. 在“此下载中包括的文件”中，单击“下载”以安装 32 位或 64 位版本的 Reporting Services 外接程序。

  4. 单击“保存”将该文件保存到计算机上的某个位置。

  5. 打开 Windows 资源管理器并浏览到该文件所在的文件夹。

  6. 双击 SharePointRS.msi 开始安装。有关说明，请参阅如何安装或卸载 Reporting Services 外接程序。

  7. 获取 Reporting Services 外接程序的最新版本的自述文件以了解最新的更改和已知问题。在 Microsoft 网站的下载页中，在“此下载中包括的文件”中单击“下载”以打开 readme_rsaddin.htm 文件，然后将该文件保存到计算机上。

在管理中心中配置服务器集成

  1. 依次单击“开始”、“管理工具”和“SharePoint 3.0 管理中心”。

    重要提示：
    若要完成以下步骤，您必须是 SharePoint 场管理员组的成员和网站集管理员。

  2. 单击“应用程序管理”。应该会看到一个名称为 Reporting Services 的新的部分。该部分包含一些链接，这些链接所指向的页面可用来指定集成设置。如果没有看到该部分，则必须激活报表服务器集成功能。有关详细信息，请参阅如何在 SharePoint 管理中心中激活报表服务器功能。

    您必须至少设置报表服务器 URL、选择身份验证模式并授予报表服务器访问 SharePoint 数据库的权限。有关详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

  3. 关闭管理中心。

如果 Reporting Services 服务是用内置帐户运行的，您将遇到一个错误。如果已经将服务配置为使用域用户帐户，请重新启动服务以清除旧连接信息（假定已经在当前会话中建立了连接）。有关服务帐户配置的详细信息，请参阅配置报表服务器服务帐户。

后续步骤

在安装了所有组件并配置了用来连接服务器组件的设置之后，必须分配相应的权限、添加内容类型并在 SharePoint 库中添加报表服务器项。

完成服务器集成部署任务

  1. 打开 SharePoint Web 应用程序。默认情况下，该 URL 为 http://<服务器名称>。

  2. 设置权限以授予用户访问 SharePoint 站点的权限。安全性是必需的，但如果要继承现有的权限，则不必设置对特定项的权限。有关详细信息，请参阅在 SharePoint 站点上为报表服务器项授予权限或如何在 SharePoint 站点上为报表服务器项设置权限（SharePoint 集成模式下的 Reporting Services）。

  3. 如果要创建新的共享数据源、报表模型和报表生成器报表，请添加 Reporting Services 内容类型。有关详细信息，请参阅如何将报表服务器内容类型添加到库中（SharePoint 集成模式下的 Reporting Services）。

  4. 创建共享数据源以与报表和模型配合使用。有关详细信息，请参阅如何创建和管理共享数据源（SharePoint 集成模式下的 Reporting Services）。

  5. 创建共享计划以与订阅或无人参与的报表处理配合使用。有关详细信息，请参阅如何创建和管理共享计划（SharePoint 集成模式下的 Reporting Services）。

  6. 将报表定义文件 (.rdl)、数据源文件 (.rds) 和报表模型文件 (.smdl) 发布到 SharePoint 库。您还可以在 SharePoint 库中使用上载命令以上载 .rdl 和 .smdl 文件，但不能上载 .rds 文件。根据您拥有的权限，还可以在报表生成器中创建报表，并将报表保存到库中。如果这些报表包含对共享数据源或外部文件的引用，则必须更新这些引用。有关详细信息，请参阅将模型和共享数据源部署到 SharePoint 站点和如何将文档上载到 SharePoint 库（SharePoint 集成模式下的 Reporting Services）。

上载报表时，请确保报表的数据源属性正确。数据源必须具有有效的外部数据源连接字符串。凭据类型必须对您的网络拓扑有效。特别要注意的是，如果您的域未启用 Kerberos 身份验证，则不能使用 Windows 集成安全性凭据类型。相反，应指定存储的凭据。验证数据源属性正确之后，可以单击报表名称来打开报表。该报表将在报表查看器 Web 部件中自动打开。

如果报表未打开，请检查您对该报表拥有的权限，并检查用来定义与外部数据源连接的数据源属性。在站点或场上，SharePoint 权限用于控制对报表、报表模型、共享数据源以及报表生成器工具（用来创建即席报表）的访问权限。如果用户看不到这些项，则应验证权限是否设置正确。

不能通过报表管理器来管理在 SharePoint 集成模式下运行的报表服务器。关于支持的功能和不支持的功能的完整列表，请参阅 Reporting Services 在 SharePoint 集成模式下支持的功能。

请参阅

任务

如何在独立服务器上配置 SharePoint 集成

概念

将 Reporting Services 配置为 SharePoint 3.0 集成模式
安装 Reporting Services 的注意事项
配置无人参与的执行帐户
配置报表服务器以进行电子邮件传递

其他资源

在 SharePoint 集成模式下运行 Reporting Services 的要求
SharePoint 集成模式下的 Reporting Services 的部署拓扑
规划部署模式
Reporting Services 和 SharePoint 技术的集成


如何创建报表服务器数据库（Reporting Services 配置）

如何创建报表服务器数据库（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

Reporting Services 将 SQL Server 数据库用于内部存储。该数据库是必需组件，用于存储发布的报表、模型、共享数据源、会话数据、资源和服务器元数据。

若要创建报表服务器数据库或更改连接字符串或凭据，请使用 Reporting Services 配置工具“数据库”页中的选项。

何时创建或配置报表服务器数据库

如果在“仅文件”模式下安装报表服务器，则必须创建和配置报表服务器数据库。

如果在本机模式的默认配置下或 SharePoint 集成模式下安装 Reporting Services，则安装报表服务器实例时会自动创建和配置报表服务器数据库。可以使用 Reporting Services 配置工具查看或修改安装程序为您配置的设置。

开始之前

创建或配置报表服务器数据库是一个多步骤过程。创建报表服务器数据库之前，请考虑要如何指定下列各项：

选择数据库服务器

Reporting Services 需要一个 SQL Server 2005 或 2008 数据库引擎实例来承载报表服务器数据库。可以使用本地或远程服务器。

检查版本要求

验证数据库引擎的版本是否与您所使用的报表服务器版本兼容。有关版本兼容性的详细信息，请参阅创建报表服务器数据库。

启用 TCP/IP 连接

启用数据库引擎的 TCP/IP 连接。默认情况下，某些数据库引擎版本不启用 TCP/IP。本主题中提供了相关说明。

打开 SQL Server 的端口

对于远程服务器，如果使用的是防火墙软件，则必须打开数据库引擎侦听的端口。

确定一种模式

报表服务器数据库支持本机模式或 SharePoint 集成模式。“本机模式”为默认设置。要将 Reporting Services 部署为独立的应用程序服务器时，使用此模式。

计划将报表服务器与 SharePoint 产品或技术的实例一起部署时，使用“SharePoint 集成模式”。运行该向导时将创建此数据库，但直到您将报表服务器添加到 SharePoint 场时才能添加内容或查看项。有关详细信息，请参阅规划部署模式。

确定报表服务器凭据

确定报表服务器与报表服务器数据库的连接方式。凭据类型包括域用户帐户、SQL Server 数据库用户帐户或报表服务器服务帐户。

这些凭据经过加密并存储在 RSReportServer.config 文件中。报表服务器将这些凭据用于与报表服务器数据库进行的连接。如果您要使用 Windows 用户帐户或数据库用户帐户，请确保指定已经存在的帐户。尽管 Reporting Services 配置工具将创建登录名并设置必要的权限，但不会为您创建帐户。有关详细信息，请参阅配置报表服务器数据库连接。

确定报表服务器语言

选择要为报表服务器指定的语言。当用户使用不同语言版本的浏览器连接到服务器时，预定义的角色名称、说明和“我的报表”文件夹不会以不同的语言显示。有关在报表服务器部署中如何使用语言资源的详细信息，请参阅多语言或全局部署的解决方案设计注意事项 (Reporting Services).

检查凭据以创建和设置数据库

确保您拥有的帐户凭据具有在数据库引擎实例上创建数据库的权限。这些凭据用于一次性连接以创建报表服务器数据库和 RSExecRole。如果登录名尚不存在，将为报表服务器所用的帐户创建一个数据库用户登录名以连接到该数据库。您可以用您登录时所用的 Microsoft Windows 帐户进行连接，也可以输入 SQL Server 数据库登录名。

启用对远程报表服务器数据库的访问

  1. 如果您使用的是远程数据库引擎实例，请登录到此数据库服务器以验证或启用 TCP/IP 连接。

  2. 依次指向“开始”、“所有程序”、Microsoft SQL Server、“配置工具”，再单击“SQL Server 配置管理器”。

  3. 打开“SQL Server 网络配置”。

  4. 选择实例。

  5. 右键单击 TCP/IP，再单击“启用”。

  6. 重新启动服务。

  7. 打开防火墙软件并打开 SQL Server 侦听的端口。对于默认实例，此端口通常为 TCP/IP 连接的 1433 端口。有关详细信息，请参阅如何为数据库引擎访问配置 Windows 防火墙。

创建本地报表服务器数据库

  1. 启动 Reporting Services 配置工具并连接到要为其创建数据库的报表服务器实例。有关详细信息，请参阅如何启动 Reporting Services 配置。

  2. 在“数据库”页上，单击“更改数据库”。

  3. 单击“新建数据库”，然后单击“下一步”。

  4. 连接到您将用于创建和承载报表服务器数据库的数据库引擎实例：

    1. 键入要使用的 SQL Server 数据库引擎实例。向导将显示作为默认实例（如果可用）运行的本地数据库引擎。否则，您必须键入要使用的服务器和实例。命名实例以此格式指定：<服务器名称>\<实例名>。

    2. 输入用于一次性连接到数据库引擎的凭据以创建报表服务器数据库。有关如何使用这些凭据的详细信息，请参阅本主题中的开始之前。

    3. 单击“测试连接”以验证与服务器的连接。

    4. 单击“下一步”。

  5. 指定用于创建数据库的属性。有关如何使用这些属性的详细信息，请参阅本主题中的开始之前：

    1. 键入报表服务器数据库的名称。创建主数据库时，会同时为其创建一个临时数据库。请考虑使用一个说明性名称来帮助记忆数据库的使用方式。请注意，您指定的名称将在数据库的生存期内使用。在创建报表服务器数据库之后，不能对其进行重命名。

    2. 选择要显示角色定义和“我的报表”所用的语言。

    3. 选择服务器模式。除非计划在 SharePoint 产品或技术中部署报表服务器，否则请始终选择“本机模式”。

    4. 单击“下一步”。

  6. 指定报表服务器用来连接到报表服务器数据库的凭据。

    1. 指定身份验证类型：

      选择“数据库凭据”以使用已定义的 SQL Server 数据库登录名进行连接。如果报表服务器位于不同域、不可信域或装有防火墙的计算机中，则建议使用数据库凭据。

      如果您拥有的最低特权域用户帐户具有登录到该计算机和数据库服务器的权限，则选择“Windows 凭据”。

      如果希望报表服务器使用其自身的服务帐户进行连接，则选择“服务凭据”。使用此选项，该服务器将使用集成安全性进行连接；凭据不进行加密或存储。

    2. 单击“下一步”。

  7. 检查“摘要”页上的信息以确保设置正确，然后单击“下一步”。

  8. 单击“报表服务器 URL”页或“报表管理器 URL”页上的 URL，验证连接。必须定义这些 URL 才能进行此测试。如果报表服务器数据库连接有效，您将在浏览器窗口中看到报表服务器文件夹层次结构或报表管理器。有关详细信息，请参阅如何验证 Reporting Services 安装。

请参阅

任务

如何启动 Reporting Services 配置

参考

设置 Windows 服务帐户
数据库（Reporting Services 配置）

概念

配置报表服务器数据库连接
Reporting Services 配置操作指南主题

其他资源

管理报表服务器数据库
报表服务器数据库
配置报表服务器安装
Reporting Services 配置工具


如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）

如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

使用 Reporting Services 配置工具创建 SharePoint 集成模式下的报表服务器数据库，并配置从报表服务器到报表服务器数据库的连接。只有报表服务器才连接到报表服务器数据库。与报表服务器集成的 Windows SharePoint Services 或 Office SharePoint Server 实例从不会连接到报表服务器数据库，也不会直接从报表服务器数据库中检索数据。

报表服务器数据库可以支持本机模式操作，也可以支持 SharePoint 集成模式，但不能同时支持这两种模式。如果创建支持 SharePoint 集成模式的报表服务器数据库，则以后无法转换或迁移该数据库，以便使用本机模式报表服务器实例运行。报表服务器数据库包含特定于模式的元数据（具体而言，是项位置和权限信息），此元数据在另一模式下不兼容。

创建 SharePoint 集成模式的报表服务器数据库时，报表服务器数据库会存储服务器属性、报表执行快照、报表历史记录、订阅定义和计划。同时还存储报表、报表模型、共享数据源和资源的第二副本以提高服务器的处理性能。报表文档的主存储位于 SharePoint 内容数据库。有关详细信息，请参阅存储报表服务器内容并将报表服务器内容和 SharePoint 数据库同步。

关于支持 SharePoint 集成的报表服务器数据库，需要注意以下几个要点：

  • 使用 Reporting Services 配置工具“数据库”页中的更改数据库向导创建 SharePoint 集成模式下的报表服务器数据库。有关说明，请参阅如何创建报表服务器数据库（Reporting Services 配置）。

  • 使用 Reporting Services 配置工具维护或更新报表服务器数据库的连接信息。

  • 使用 SQL Server Management Studio 和 SQL Server 工具来备份和管理报表服务器数据库。SharePoint 3.0 管理中心中的数据库备份功能不适用于报表服务器数据库。

  • 创建报表服务器数据库只是配置用于集成操作的报表服务器的多步骤过程中的一个步骤。创建数据库之后，通过启动 SharePoint 3.0 管理中心并指定报表服务器集成设置来完成集成步骤。有关详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

请参阅

任务

如何切换服务器模式（Reporting Services 配置）

概念

将 Reporting Services 配置为 SharePoint 3.0 集成模式
配置报表服务器数据库连接

其他资源

规划部署模式
管理报表服务器数据库


如何启用远程错误（Reporting Services 配置）

如何启用远程错误（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

可以将报表服务器上的服务器属性设置为返回有关出现在远程服务器上的错误条件的其他信息。如果错误消息中包含文本“有关此错误的详细信息，请导航到本地服务器上的报表服务器或启用远程错误”，则可以将 EnableRemoteErrors 属性设置为访问可帮助您解决问题的其他信息。

注意：
您可以通过编辑报表服务器数据库中的 ConfigurationInfo 表将 EnableRemoteErrors 设置为 True，但是如果报表服务器正在使用中，则应使用 SQL Server Management Studio 或脚本来修改此设置。

通过 SQL Server Management Studio 启用远程错误

  1. 启动 Management Studio 并连接到报表服务器实例。

  2. 右键单击报表服务器节点，然后选择“属性”。

  3. 单击“高级”以打开属性页。

  4. 在 EnableRemoteErrors 中，选择 True。

  5. 单击“确定”。

通过脚本启用远程错误

  1. 创建文本文件并将以下脚本复制到该文件中。

    复制代码
    Public Sub Main()
  Dim P As New [Property]()
  P.Name = "EnableRemoteErrors"
  P.Value = True
  Dim Properties(0) As [Property]
  Properties(0) = P
  Try
    rs.SetSystemProperties(Properties)
    Console.WriteLine("Remote errors enabled.")
  Catch SE As SoapException
    Console.WriteLine(SE.Detail.OuterXml)
  End Try
End Sub

  2. 将文件另存为 EnableRemoteErrors.rss。

  3. 单击“开始”，指向“运行”，键入 cmd，再单击“确定”打开命令提示符窗口。

  4. 导航到包含您刚刚创建的 .rss 文件的目录。

  5. 键入以下命令行，并将 servername 替换为服务器的实际名称：

    复制代码
    rs -i EnableRemoteErrors.rss -s http://servername/ReportServer

请参阅

其他资源

Report Server System Properties
如何连接到 Management Studio 中的报表服务器
Report Server System Properties
服务器属性（“高级”页）- Reporting Services


如何在报表服务器计算机中安装 SharePoint Web 前端

如何在报表服务器计算机中安装 SharePoint Web 前端 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

如果将报表服务器配置为在由多个服务器组成的 SharePoint 场中以 SharePoint 集成模式运行，则必须在报表服务器计算机上安装 SharePoint 产品或技术的 Web 前端应用程序，这样便可以将报表服务器计算机与场进行联接。

SharePoint 场由均使用同一版本 SharePoint 产品或技术的多个服务器组成。如果服务器场使用 Windows SharePoint Services 3.0，则必须在报表服务器计算机上安装 Windows SharePoint Services 3.0。如果服务器场使用 Microsoft Office SharePoint Portal Server 场，则必须安装 Office SharePoint Portal Server。

若要安装 Web 前端，您必须是 SharePoint 场管理员。还必须知道数据库服务器的名称以及该服务器场使用的配置数据库的名称。

以下步骤仅当在 SharePoint 服务器场中部署报表服务器时才需要。如果所有服务器应用程序都在一台计算机中运行，则无需在报表服务器上安装 Web 前端。

在安装 Web 前端并将报表服务器计算机联接到场之后，可以使用 SharePoint 3.0 管理中心关闭不需要的任何 Web 前端功能。

安装 Web 前端

  1. 在运行 Reporting Services 的服务器中，运行用于该场的 SharePoint 产品或技术的安装程序。

  2. 在“安装类型”中，单击“高级”。

  3. 在“服务器类型”中，选择“Web 前端”。

  4. “数据位置”选项卡用于指定搜索索引文件的位置。在“数据位置”中，使用默认值或选择具有多余的磁盘空间的计算机。

  5. 单击“立即安装”。

安装完成之后，必须配置 Web 前端以将其联接到服务器场。

配置 Web 前端

  1. 运行 SharePoint 产品和技术配置向导以将 Web 前端加入到远程 SharePoint 场中。SharePoint 产品和技术配置向导应在安装完成后启动。如果未启动，请从“管理工具”中启动它。

  2. 在欢迎屏幕上，单击“下一步”。

  3. 如有必要，单击“是”以重新启动此服务。

  4. 在“连接到服务器场”页上，选择“是”以连接到现有服务器场。单击“下一步”。

  5. 在“指定配置数据库设置”页上，指定承载配置数据库的 SQL Server 数据库引擎实例。如果您不知道配置数据库的名称，请单击“检索数据库名称”，然后选择配置数据库。

  6. 输入 Web 前端将用来连接到配置数据库的用户名和密码。单击“下一步”。

  7. 在“完成 SharePoint 产品和技术向导”页中，单击“高级设置”。

  8. 在“高级设置”中，请确认是否选择了“请勿使用此计算机承载网站”。

  9. 单击“确定”，单击“下一步”，然后完成向导。

安装 Web 前端只是整个配置过程中的一步。有关完整步骤的详细信息，请参阅将 Reporting Services 配置为 SharePoint 3.0 集成模式。

有关配置集成了 Reporting Services 及 SharePoint 产品和技术的多服务器部署的详细信息，请参阅如何在多台服务器上配置 SharePoint 集成。

请参阅

任务

如何在多台服务器上配置 SharePoint 集成

概念

如何安装或卸载 Reporting Services 外接程序
将 Reporting Services 配置为 SharePoint 3.0 集成模式

其他资源

Reporting Services 和 SharePoint 技术的集成
规划部署模式
在 SharePoint 集成模式下运行 Reporting Services 的要求


如何安装或卸载 Reporting Services 外接程序

如何安装或卸载 Reporting Services 外接程序 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

用于 SharePoint 技术的 Microsoft SQL Server 2008 Reporting Services 外接程序可通过 Web 下载，您可以将其安装在具有 SharePoint 产品或技术实例的服务器上。它提供了一套功能，使您能够在较大型的 Microsoft Windows SharePoint Services 3.0 或 Microsoft Office SharePoint Server 2007 部署中运行报表服务器。这些功能包括报表查看器 Web 部件、URL 代理端点和应用程序页，以便您能够在 SharePoint 站点上创建、查看和管理报表、报表模型以及其他报表服务器内容。用于 SharePoint 技术的 Reporting Services 外接程序是在 SharePoint 集成模式下运行的报表服务器的必需组件。

Reporting Services 部署在场级与 SharePoint 产品或技术实现集成。如果在场配置中具有多个 SharePoint Web 应用程序，则必须在具有 Web 前端的每台计算机上都安装 Reporting Services 外接程序。在所有计算上都安装了此外接程序后，启动 Central Administration 对场中的所有服务器配置报表服务器集成。

准备安装

将报表服务器与 SharePoint 产品或技术的实例集成需要很多步骤，安装 Reporting Services 外接程序是其中的一步。有关完整步骤的详细信息，请参阅将 Reporting Services 配置为 SharePoint 3.0 集成模式。服务器配置步骤的顺序非常重要。为获得最佳结果，应确保按顺序执行。

准备安装 Reporting Services 外接程序：

  1. 作为 SharePoint 场管理员登录以安装 Reporting Services 外接程序。

  2. 验证您是否具有两个服务器安装：一个报表服务器和一个 SharePoint 服务器，这样才满足集成操作的要求。有关详细信息，请参阅在 SharePoint 集成模式下运行 Reporting Services 的要求。

  3. 将 Reporting Services 外接程序下载到安装了 SharePoint 产品或技术实例的服务器上。

    1. 转到 Microsoft 下载中心上的用于 SharePoint 技术的 SQL Server 2008 Reporting Services 外接程序页面。

    2. 选择要安装的语言版本。报表查看器 Web 部件 (ReportViewer.dwp) 只可用于所选的语言。不管您在下载页上选择何种语言，应用程序页和消息均可用于所有支持的语言。有关所支持语言的详细信息，请参阅多语言或全局部署的解决方案设计注意事项 (Reporting Services)。

    3. 在“此下载中包括的文件”部分，单击“下载”安装 SharepointRS.msi。

  4. 如果将 Reporting Services 与具有多个 Web 前端应用程序的 SharePoint 场集成，请将 SharepointRS.msi 复制或下载到场中具有 Web 服务器前端的每台计算机上。仅对用于访问报表服务器内容的 Web 前端执行此操作。

如何使用安装向导安装 Reporting Services 外接程序

对于要为报表服务器集成配置 SharePoint 产品或技术的部署，请在具有针对该部署的 Web 前端的计算机上运行 SharepointRS.msi。可使用安装向导来安装 Reporting Services 外接程序，或从命令行运行安装程序并为“仅文件”模式安装指定命令行参数。

安装程序并不对服务器与 Reporting Services 的集成进行配置。必须在安装程序完成后配置集成。安装程序使用当前部署的现有文件夹结构，并为 Reporting Services 外接程序应用程序文件创建一个新的文件夹。

  1. 导航到包含 SharePointRS.msi 的文件夹。

  2. 双击 SharePointRS.msi 运行安装向导。该向导将显示“欢迎”页、许可协议和注册信息页。

  3. 单击“安装”运行安装程序。

  4. 安装程序结束后，请转至“管理工具”，然后单击“SharePoint 3.0 管理中心”。

  5. 单击“应用程序管理”。应该会看到一个名称为 Reporting Services 的新的部分。该部分包含指向用于指定集成设置的页面的链接。有关如何指定设置的说明，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

如何在“仅文件”模式下安装 Reporting Services 外接程序

如果在正常安装期间遇到错误，则可在“仅文件”模式下安装 Reporting Services 外接程序。在“仅文件”模式下，安装程序将运行安装向导以将应用程序文件复制到计算机。文件复制后，必须运行自定义操作才能完成安装。

  1. 运行 SharePointRS.msi SKIPCA=1.

  2. 在文件系统中找到 rsCustomAction.exe 文件。该文件是由安装程序复制到计算机中的。该文件将位于 %Temp% 目录中。

    若要获取该文件的路径信息，请依次单击“开始”、“运行”，然后键入 %temp%。该文件应位于\Documents and Settings\<用户名称>\LOCALS~1\Temp。

  3. 打开命令提示符窗口。为此，请依次单击“开始”、“运行”，然后键入 cmd。

  4. 导航到包含 rsCustomAction 可执行文件的文件夹。

  5. 输入以下命令：

    复制代码
    rsCustomAction.exe /i
    该配置步骤的完成需要几分钟的时间。在此过程中将重新启动 W3SVC 服务。

  6. 安装程序结束后，请转至“管理工具”，然后单击“SharePoint 3.0 管理中心”。

  7. 单击“应用程序管理”。应该会看到一个名为 Reporting Services 的新的部分。该部分包含指向用于指定集成设置的页面的链接。有关如何指定设置的说明，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

如何删除 Reporting Services 外接程序

可通过在卸载模式下运行安装程序 (SharepointRS.msi)) 来卸载用于 SharePoint 技术的 Reporting Services 外接程序。卸载外接程序时将删除用于在报表服务器上处理报表和模型的服务器集成功能。

若要卸载 Reporting Services 外接程序，必须使 Windows SharePoint Services 或 Office SharePoint Server 2007 安装仍处于运行状态。如果首先卸载了 SharePoint 产品或技术，则必须重新安装该产品或技术才能卸载 Reporting Services 外接程序。

  1. 在 SharePoint 站点上，删除所有报表和不再使用的其他报表服务器项。在删除 Reporting Services 外接程序后，它们将不运行。

  2. 在控制面板的“添加和删除程序”中，选择“用于 Microsoft SharePoint 技术的 Microsoft SQL Server 2005 Reporting Services 外接程序”。

单击“删除”。

卸载外接程序的步骤与卸载独立服务器和服务器场的步骤相同。安装程序将删除在安装过程中添加的程序文件和所有配置设置。

安装程序将不删除以下内容：

  • 为用于访问 SharePoint 配置和内容数据库的报表服务器服务帐户创建的登录名。必须从用于承载 SharePoint 数据库的 SQL Server 数据库引擎实例中删除报表服务器服务帐户的所有登录名。

  • 为报表用户创建的权限或组。如果创建了自定义权限级别或 SharePoint 组来授予访问报表服务器功能的权限，则应撤销不再需要的任何权限。

  • 上载到 SharePoint 库的数据文件，包括报表定义 (.rdl)、报表模型 (.smdl) 和共享数据源 (.rsds) 文件。不会删除这些文件，但它们将不再运行。必须手动删除这些文件。

  • 安装程序将不删除报表服务器数据库，也不修改用于集成操作的报表服务器实例。卸载外接程序后，如果要将该实例用作独立的报告应用程序，可考虑将报表服务器切换为在本机模式下运行。

如何从命令行运行 SharePointRS.msi

可从命令行运行安装程序来修复或卸载 Reporting Services 外接程序。

  • 运行 SharePointRS.msi -r 可修复现有安装。

  • 运行 SharePointRS.msi -u 可卸载外接程序的现有安装。

安装日志文件

安装程序在运行期间，将会为安装 Reporting Services 外接程序的用户把相应信息记录到 %temp% 文件夹下的一个日志文件中。文件名为 RS_SP_<number>.log。日志文件中记录的每个错误均以字符串“SSRSCustomActionError”开头。

请参阅

任务

如何切换服务器模式（Reporting Services 配置）
如何在报表服务器计算机中安装 SharePoint Web 前端

概念

将 Reporting Services 配置为 SharePoint 3.0 集成模式

其他资源

从 SharePoint 站点查看和管理报表服务器项
规划部署模式
在 SharePoint 集成模式下运行 Reporting Services 的要求
SharePoint 集成模式下的 Reporting Services 安全性概述
在 SharePoint 站点上为报表服务器项授予权限


如何为报表服务器注册服务主体名称 (SPN)

如何为报表服务器注册服务主体名称 (SPN) |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

如果要在使用 Kerberos 协议进行相互身份验证的网络中部署 Reporting Services，并且将报表服务器服务配置为以域用户帐户身份运行，则必须为报表服务器服务创建服务主体名称 (SPN)。此外，如果将域用户配置为服务帐户，则必须将报表服务器配置为使用 NTLM 身份验证。

关于 SPN

SPN 是服务在使用 Kerberos 身份验证的网络上的唯一标识符。它由服务类、主机名和端口组成。在使用 Kerberos 身份验证的网络中，必须在内置计算机帐户（如 NetworkService 或 LocalSystem）或用户帐户下为服务器注册 SPN。对于内置帐户，SPN 将自动进行注册。但是，如果在域用户帐户下运行服务，则必须为要使用的帐户手动注册 SPN。

若要创建 SPN，可使用 SetSPN 命令行实用工具。有关详细信息，请参阅 Microsoft Windows Server TechCenter 上的 Setspn。

您必须具有域管理员身份，才能在域控制器上运行该实用工具。

语法

使用 SetSPN 实用工具为报表服务器创建 SPN 的命令语法类似如下所示：

复制代码
Setspn -a http/<computername>.<domainname>:<port> <domain-user-account>

SetSPN 随 Windows Server 2003 Service Pack 1 支持工具包提供，该工具包必须单独下载。-a 参数用于使用特定帐户注册服务主体名称。

HTTP 为服务类。报表服务器 Web 服务在 HTTP.SYS 中运行。在为 HTTP 创建 SPN 时，将同时对在 HTTP.SYS（包括承载在 IIS 中的应用程序）中运行的位于同一台计算机上的所有 Web 应用程序授予基于该域用户帐户的票证。如果这些服务在其他帐户下运行，则身份验证请求将失败。为避免此问题，请务必将所有 HTTP 应用程序配置为在同一帐户下运行，或考虑为每个应用程序创建主机头，然后为每个主机头单独创建一个 SPN。配置主机标头时，无论 Reporting Services 配置如何都必须更改 DNS。

您为 <计算机名称>、<域名> 和 <端口> 指定的值将标识承载报表服务器的计算机的唯一网络地址。此地址可以是本地主机名，或者完全限定的域名 (FQDN)。如果只有一个域且使用的是端口 80，则可以省略命令行中的 <域名> 和 <端口>。<域用户帐户> 是报表服务器服务运行时使用的用户帐户，也是必须注册 SPN 的用户帐户。

为域用户帐户注册 SPN

为以域用户身份运行的报表服务器服务注册 SPN

  1. 安装 Reporting Services 并将报表服务器服务配置为以域用户帐户身份运行。请注意，直到完成以下步骤之后，用户才能连接到报表服务器。

  2. 从下载中心下载并安装 Windows Server 2003 Service Pack 1 Support Tools（Windows Server 2003 Service Pack 1 支持工具）。

  3. 以域管理员的身份登录到域控制器。

  4. 打开命令提示符窗口。

  5. 复制以下命令，并用适用于您的网络的实际值替换占位符值。

    复制代码
    Setspn -a http/<computer-name>.<domain-name>:<port> <domain-user-account>

  6. 运行命令。

  7. 打开 RsReportServer.config 文件，找到 <AuthenticationTypes> 部分。添加 <RSWindowsNegotiate/> 作为该部分的第一个项，以启用 NTLM。

请参阅

任务

如何为 Reporting Services 配置服务帐户

概念

配置报表服务器服务帐户
Reporting Services 配置操作指南主题
安装 Reporting Services 的注意事项

其他资源

规划服务、帐户和连接


如何切换服务器模式（Reporting Services 配置）

如何切换服务器模式（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

如果已将报表服务器配置为在 SharePoint 集成模式下运行，则通过将此报表服务器切换为本机模式可以从部署的 SharePoint 技术实例中分离此服务器。

若要切换模式，请将报表服务器指向本机模式报表服务器数据库。切换模式时，不必重新安装报表服务器。

尽管您可以切换报表服务器的模式，但您不能切换报表服务器数据库的模式。报表服务器数据库中包含在其他上下文中无法使用的模式特定数据。如果创建了 SharePoint 集成模式下的报表服务器数据库，则无法在本机模式报表服务器上使用此数据库。

有三种方式可从 SharePoint 集成模式切换到本机模式。在 Reporting Services 配置工具的“数据库安装”页中执行下列操作之一：

  • 单击“更改”并创建新数据库。

  • 从现有数据库列表中，选择一个已在本机模式下运行的现有报表服务器数据库，指定凭据，然后单击“应用”。

  • 单击“新建”并创建新数据库。确保清除“使用支持 SharePoint 集成模式的架构”复选框。

本主题将介绍第一种方法的各个步骤。有关如何将本机模式报表服务器配置为在 SharePoint 集成模式下运行的详细信息，请参阅将 Reporting Services 配置为 SharePoint 3.0 集成模式。

切换到本机模式

  1. 单击“开始”，依次指向“程序”、Microsoft SQL Server 2008 和“配置工具”。

  2. 单击“Reporting Services 配置”。此时将出现“选择报表服务器安装实例”对话框，以便可以选择要配置的报表服务器实例。

  3. 在“计算机名称”中，指定安装报表服务器实例的计算机名称。指定的默认值是本地计算机名称，但也可以键入远程 SQL Server 实例的名称。

  4. 在“实例名”中，选择要配置的 SQL Server Reporting Services 实例。

  5. 单击“连接”。

  6. 单击“数据库安装”将“数据库安装”页打开。此页面包含有关当前使用的数据库的信息。应将“服务器模式”设置为“SharePoint 集成”。

  7. 单击“更改”。

  8. 单击“确定”确认要创建新数据库。

  9. 在“SQL Server 连接”对话框中，输入新数据库的名称。

  10. 确保未选中“创建 SharePoint 集成模式的报表服务器数据库”复选框。

  11. 单击“确定”。

  12. 在“数据库安装”页上，指定用于连接到报表服务器数据库的凭据。

    1. 选择“服务凭据”，以使用 Windows 服务帐户和 Web 服务帐户通过集成安全性进行连接。

    2. 选择“Windows 凭据”可以指定域用户帐户。必须将域用户帐户指定为 <域>\<用户>。

    3. 选择“SQL Server 凭据”可以指定 SQL Server 登录名。

  13. 单击“应用”。

在将 SharePoint 集成报表服务器切换为本机模式时，将重新定义内容的位置和用于控制对内容进行访问的权限。必须向报表服务器重新发布内容，您必须在报表服务器上指定可以访问项和操作的角色，并且需要重新定义订阅和预定操作。在以 SharePoint 集成模式运行的报表服务器上创建的报表历史记录无法在本机模式报表服务器上重新创建。

请参阅

任务

如何在 SharePoint 管理中心中配置报表服务器集成

概念

将 Reporting Services 配置为 SharePoint 3.0 集成模式
如何安装或卸载 Reporting Services 外接程序
配置报表服务器数据库连接
如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）

其他资源

规划部署模式


如何打开或关闭 Reporting Services 功能

如何打开或关闭 Reporting Services 功能 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置操作指南主题 >

您可以关闭不用作锁定策略一部分的报表服务器功能，以减小生产报表服务器的攻击面。在大多数情况下，需要同时运行各种 Reporting Services 功能才能使用 Reporting Services 中提供的所有功能。但是根据所用的部署模型，您可以禁用不需要的功能。例如，如果所有报表处理均已配置为预定操作，则可以只启用后台处理。同样，如果您只需要交互式的按需报表，则可以只运行报表服务器 Web 服务。

本主题中的过程将为您演示如何关闭 Reporting Services 功能。可以不同的方式配置这些功能，如直接编辑 RsReportServer.config 文件或使用 SQL Server Management Studio 中基于策略的管理的 Reporting Services 的外围应用配置器方面。使用以下链接可以找到说明如何打开或关闭相应功能的步骤：

  • 报表服务器 Web 服务

  • 预定的事件和处理

  • 报表管理器

  • 报表生成器

  • 报表数据源的 Windows 集成安全性

报表服务器 Web 服务

通过编辑配置打开或关闭报表服务器 Web 服务

  1. 在文本编辑器中打开 RsReportServer.config 文件。有关详细信息，请参阅如何修改 Reporting Services 配置文件。

  2. 若要打开报表服务器 Web 服务，请将 IsWebServiceEnabled 设置为 true：

    复制代码
    <IsWebServiceEnabled>true</IsWebServiceEnabled>

  3. 若要关闭报表服务器 Web 服务，请将 IsWebServiceEnabled 设置为 false：

    复制代码
    <IsWebServiceEnabled>false</IsWebServiceEnabled>

  4. 保存所做的更改，然后关闭该文件。

使用 SQL Server Management Studio 打开或关闭报表服务器 Web 服务

  1. 打开 SQL Server Management Studio，然后连接到要配置的 Reporting Services 实例。

  2. 在对象资源管理器中右键单击 Reporting Services 节点，指向“策略”，然后单击“方面”。

  3. 在“方面”列表中，选择 Reporting Services 的外围应用配置器。

  4. 在“方面属性”下：

    • 若要打开报表服务器 Web 服务，请将 WebServiceAndHTTPAccessEnabled 设置为 True。

    • 若要关闭报表服务器 Web 服务，请将 WebServiceAndHTTPAccessEnabled 设置为 False。

  5. 单击“确定”。

预定的事件和传递

通过编辑配置打开或关闭预定的事件和传递

  1. 在文本编辑器中打开 RsReportServer.config 文件。有关详细信息，请参阅如何修改 Reporting Services 配置文件。

  2. 若要打开预定的报表处理和传递，请将 IsSchedulingService、IsNotificationService 和 IsEventService 设置为 true：

    复制代码
    <IsSchedulingService>true<\IsSchedulingService>
<IsNotificationService>true<\IsNotificationService>
<IsEventService>true<\IsEventService>

  3. 若要关闭预定的报表处理和传递，请将 IsSchedulingService、IsNotificationService 和 IsEventService 设置为 false：

    复制代码
    <IsSchedulingService>false<\IsSchedulingService>
<IsNotificationService>false<\IsNotificationService>
<IsEventService>false<\IsEventService>

  4. 保存所做的更改，然后关闭该文件。
注意：
无法完全关闭后台处理，因为它提供执行服务器操作所需的数据库维护功能。

使用 SQL Server Management Studio 打开或关闭预定的事件和传递

  1. 打开 SQL Server Management Studio，然后连接到要配置的 Reporting Services 实例。

  2. 在对象资源管理器中右键单击 Reporting Services 节点，指向“策略”，然后单击“方面”。

  3. 在“方面”列表中，选择 Reporting Services 的外围应用配置器。

  4. 在“方面属性”下：

    • 若要打开预定的事件和传递，请将 ScheduleEventsAndReportDeliveryEnabled 设置为 True。

    • 若要关闭预定的事件和传递，请将 ScheduleEventsAndReportDeliveryEnabled 设置为 False。

  5. 单击“确定”。

注意：
不能完全关闭后台处理，因为它提供执行服务器操作所需的数据库维护功能。

报表管理器

通过编辑配置打开或关闭报表管理器

  1. 在文本编辑器中打开 RsReportServer.config 文件。有关说明，请参阅如何修改 Reporting Services 配置文件。

  2. 若要打开报表管理器，请将 IsReportManagerEnabled 设置为 true：

    复制代码
    <IsReportManagerEnabled>true<\IsReportManagerEnabled>

  3. 若要关闭报表管理器，请将 IsReportManagerEnabled 设置为 false：

    复制代码
    <IsReportManagerEnabled>false<\IsReportManagerEnabled>

  4. 保存所做的更改，然后关闭该文件。

使用 SQL Server Management Studio 打开或关闭报表管理器

  1. 打开 SQL Server Management Studio，然后连接到要配置的 Reporting Services 实例。

  2. 在对象资源管理器中右键单击 Reporting Services 节点，指向“策略”，然后单击“方面”。

  3. 在“方面”列表中，选择 Reporting Services 的外围应用配置器。

  4. 在“方面属性”下：

    • 若要打开报表管理器，请将 ReportManagerEnabled 设置为 True。

    • 若要关闭报表管理器，请将 ReportManagerEnabled 设置为 False。

  5. 单击“确定”。

报表生成器

使用 SQL Server Management Studio 打开或关闭报表生成器

  1. 打开 SQL Server Management Studio，然后连接到要配置的 Reporting Services 实例。

  2. 在对象资源管理器中右键单击 Reporting Services 节点，然后单击“属性”。

  3. 在“服务器属性”对话框中，单击“选择页”下的“安全性”。

    • 若要打开报表生成器，请选择“启用即席报表执行”选项。

    • 若要关闭报表生成器，请取消选择“启用即席报表执行”选项。

  4. 单击“确定”。

Windows 集成安全性

使用 SQL Server Management Studio 打开或关闭 Windows 集成安全性

  1. 打开 SQL Server Management Studio，然后连接到要配置的 Reporting Services 实例。

  2. 在对象资源管理器中右键单击 Reporting Services 节点，然后单击“属性”。

  3. 在“服务器属性”对话框中，单击“选择页”下的“安全性”。

    • 若要打开 Windows 集成安全性，请选择“对报表数据源启用 Windows 集成安全性”选项。

    • 若要关闭 Windows 集成安全性，请取消选择“对报表数据源启用 Windows 集成安全性”选项。

  4. 单击“确定”。

请参阅

任务

如何启动 Reporting Services 配置

其他资源

RSReportServer 配置文件
组件体系结构
Reporting Services 组件和工具
服务体系结构 (Reporting Services)
SQL Server Management Studio 简介
使用基于策略的管理来管理服务器


Reporting Services 配置的 F1 帮助主题

Reporting Services 配置的 F1 帮助主题 |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services >

本部分介绍 Reporting Services 配置工具的 F1 帮助。

本节内容

  • 连接到报表服务器

  • 报表服务器状态

  • 服务帐户

  • Web 服务 URL

  • 高级多网站配置

  • 数据库

  • 更改数据库向导

  • 更改凭据向导

  • 报表管理器 URL

  • 电子邮件设置

  • 执行帐户

  • 加密密钥

  • 备份加密密钥

  • 还原加密密钥

  • 扩展部署

请参阅

任务

如何启动 Reporting Services 配置

其他资源

Reporting Services 配置工具
配置报表服务器安装


连接到报表服务器（Reporting Services 配置）

连接到报表服务器（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 >

使用此对话框连接到本地或远程 SQL Server 2008 Reporting Services 报表服务器实例。您不能使用此工具连接到早期版本的 Reporting Services 报表服务器。一次仅能连接到一个实例。

  • 若要连接到本地报表服务器实例，请使用默认值并单击“连接”。Reporting Services 配置工具提供了本地服务器名称并可检测到默认实例。在大多数情况下，您可以单击“连接”而不必更改值。如果安装了多个实例，则必须选择要使用的实例。

  • 若要连接到远程报表服务器实例，请键入服务器名称，单击“查找”，再选择该实例，然后单击“连接”。

若要打开此对话框，请启动 Reporting Services 配置工具。启动此工具后，该对话框会立即显示出来。有关详细信息，请参阅如何启动 Reporting Services 配置。

选项

服务器名称

输入安装 SQL Server 2008 Reporting Services 的计算机的网络名称。只键入计算机名称；不包括前缀或斜杠。

查找

查找“服务器名称”中指定的计算机。

报表服务器实例

如果安装了多个报表服务器实例，则选择哪个实例进行连接。只有有效的实例可供选择。如果将旧版本的 Reporting Services 与 SQL Server 实例并行运行，则那些实例将不会显示在此列表中。

连接

连接到指定的服务器和实例。

请参阅

任务

如何启动 Reporting Services 配置

概念

使用 SQL Server 的多个版本和实例

其他资源

Reporting Services 配置工具


报表服务器状态（Reporting Services 配置）

报表服务器状态（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 >

使用此页可以查看当前连接的报表服务器实例的有关信息。此页是报表服务器配置的起始页。此外还提供了用于配置 URL、服务帐户、报表服务器数据库、报表服务器电子邮件传递、扩展部署和加密密钥的其他页。

若要打开此页，请启动 Reporting Services 配置工具并连接到报表服务器实例。有关详细信息，请参阅如何启动 Reporting Services 配置。

如果连接到报表服务器，但所有页面链接均显示为灰色，请验证是否已启动报表服务器服务。可以使用“管理工具”中的“服务”控制台应用程序检查服务状态。

选项

SQL Server 实例

显示当前连接的报表服务器实例的有关信息。报表服务器实例的名称基于 SQL Server 命名实例。默认实例为 MSSQLSERVER。命名实例将是您在安装过程中指定的值。有关实例的详细信息，请参阅使用 SQL Server 的多个版本和实例。

注意：
在具有高级服务的 SQL Server 中，默认实例为 SQLExpress。

实例 ID

与文件系统中的某一文件夹对应，该文件夹用于存储您所连接到的 SQL Server 实例的程序文件。“实例 ID”值是由安装程序分配的，格式为 component.instance，其中 component 为一个表示 SQL Server 组件的值，instance 为实例名称。默认实例名为 MSSQLSERVER。例如，如果安装数据库引擎、Analysis Services 和 Reporting Services 组件的默认实例，则对应的文件夹名称分别为 MSSQL10.MSSQLSERVER、MSAS10.MSSQLSERVER 和 MSRS10.MSSQLSERVER。如果安装已安装组件（例如数据库引擎）的第二个实例，并且将该实例命名为 Contoso，则“实例 ID”为 MSSQL10.Contoso。

版本类别

显示版本信息。具有高级服务的 SQL Server Express Edition、Workgroup Edition、Developer Edition、Evaluation Edition、Standard Edition 和 Enterprise Edition 中均提供了 Reporting Services。

产品版本

显示所安装的 Reporting Services 的版本。

报表服务器数据库

显示用于存储当前报表服务器实例的应用程序数据的报表服务器数据库的名称。

报表服务器模式

显示是以本机模式还是以 SharePoint 集成模式部署报表服务器。如果报表服务器数据库是使用支持 SharePoint 集成操作模式的架构创建的，则此值将设置为该模式。有关部署模式的详细信息，请参阅规划部署模式。有关设置集成操作所需的所有步骤的详细信息，请参阅将 Reporting Services 配置为 SharePoint 3.0 集成模式。

服务器状态

显示报表服务器服务是否正在运行。

启动

启动报表服务器服务。在更改某些配置之后（例如，在更改计算机名称之后重新配置报表服务器时），需要重新启动该服务。如果重新配置 URL 保留项，该服务将自动重新启动。要使更改生效，必须重新启动服务。

停止

停止报表服务器服务。停止服务会导致报表服务器停止工作。有关详细信息，请参阅启动和停止报表服务器服务。

请参阅

任务

如何启动 Reporting Services 配置

概念

Reporting Services 配置的 F1 帮助主题
初始化报表服务器

其他资源

服务体系结构 (Reporting Services)
配置报表服务器安装
启动和停止报表服务器服务


服务帐户（Reporting Services 配置）

服务帐户（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 >

使用“服务帐户”页可以指定运行报表服务器服务的帐户。此帐户最初在安装过程中进行配置。如果要更改此帐户或密码，则可以对其进行修改。报表服务器 Web 服务、报表管理器和后台处理应用程序都使用此页上指定的服务标识运行。

为报表服务器服务指定的帐户需要拥有访问注册表、报表服务器程序文件和报表服务器数据库的权限。在您使用 Reporting Services 配置工具设置此帐户时，所有权限都会自动配置给此帐户。如果您使用此服务帐户连接到报表服务器数据库，该工具会将此帐户分配给承载报表服务器数据库的 SQL Server 实例上的 RSExecRole，这样，就会为此帐户创建一个数据库登录名并配置数据库权限。报表服务器数据库是报表服务器可以写入的唯一数据存储区。此服务帐户不需要其他任何数据存储区的权限。

若要打开此页，请启动 Reporting Services 配置工具，然后在导航窗格中选择相应链接。有关详细信息，请参阅如何启动 Reporting Services 配置。

重要提示：
我们极力建议您在每次更新帐户或密码时都使用 Reporting Services 配置工具。使用此工具更新帐户可确保其他基于此服务标识的内部设置都能同时自动更新。

选项

使用内置帐户

从此列表中选择 Network Service、Local System 或 Local Service。建议只选择 Network Service；不过，可以将帐户配置为使用任何可用的帐户。

使用其他帐户

选择此选项可以指定 Windows 用户帐户。可以输入本地 Windows 用户帐户或域用户帐户。按下面的格式指定域帐户：<域>\<用户>。按下面的格式指定本地 Windows 用户帐户：<计算机名称>\<用户>。您只能选择现有的帐户；不能在 Reporting Services 配置中创建新帐户。

帐户的最大字符数限制为 20 个字符。

如果网络使用 Kerberos 身份验证，且您将报表服务器配置为使用域用户帐户运行，则必须使用此用户帐户注册服务。有关详细信息，请参阅如何为报表服务器注册服务主体名称 (SPN)。

如果您要切换帐户类型（例如，将一个 Windows 帐户替换为另一个 Windows 帐户，或者将内置帐户替换为 Windows 域帐户），系统将提示您创建加密密钥的备份副本。在选择新帐户时此备份副本将自动还原。

注意：
每次修改服务帐户时，Reporting Services 配置工具都会提示您备份和还原加密密钥。必须执行这些步骤，才能确保加密数据在报表服务器上可用。有关这些操作的详细信息，请参阅加密密钥（Reporting Services 配置）。

此外，如果您有一台配置为在 SharePoint 集成模式下运行的报表服务器，且通过使用 Reporting Services 配置工具更改服务帐户，则您还必须打开 SharePoint 管理中心并使用 Reporting Services“授予数据库访问权限”页重新应用该报表服务器和实例设置。此步骤将授予新服务帐户访问 SharePoint 数据库的权限，将 Reporting Services 与 Windows SharePoint Services (WSS) 或 Microsoft Office SharePoint Server (MOSS) 集成在一起时需要执行此操作。有关如何在 SharePoint 管理中心授予数据库访问权限的详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

选择帐户

为了实现最佳的结果，请指定一个拥有网络连接权限、可以访问网络域控制器和公司 SMTP 服务器或网关的帐户。下表汇总了各个帐户，并为使用这些帐户提供了建议。

帐户 说明

域用户帐户

如果您有一个拥有报表服务器操作所需的最小权限的 Windows 域用户帐户，则应使用此帐户。

之所以建议使用域帐户，是因为这种帐户可以将报表服务器服务与其他应用程序隔离开。使用共享帐户（如 Network Service）运行多个应用程序会增加恶意用户控制报表服务器的风险，因为在这种情况下，任何一个应用程序的安全漏洞会很容易扩散到使用同一帐户运行的所有其他应用程序。

在为约束委托或为 SharePoint 集成模式（在此模式下，报表服务器、报表服务器数据库、SharePoint 配置和内容数据库位于一台计算机上，而 SharePoint Web 应用程序位于另一台计算机上）下的特定配置来配置报表服务器时，要求使用域用户帐户。

请注意，如果您使用域用户帐户，则在您的组织强制密码过期策略时，您必须定期更改密码。您可能还需要使用此用户帐户注册服务。有关详细信息，请参阅如何为报表服务器注册服务主体名称 (SPN)。

避免使用本地 Windows 用户帐户。本地帐户通常没有足够的权限访问其他计算机上的资源。有关如何使用本地帐户限制报表服务器功能的详细信息，请参阅本主题中的使用本地帐户的注意事项。

Network Service

Network Service 是一个拥有网络登录权限的内置最低特权帐户。如果没有可用的域用户帐户，或者要避免因密码过期策略而可能导致的任何服务中断，建议使用此帐户。

如果您选择 Network Service，请尝试将使用同一帐户运行的其他服务的数量降到最低。对于使用同一帐户运行的多个应用程序，如果一个应用程序出现安全漏洞，则所有其他应用程序的安全都会受到影响。

Local Service

Local Service 是一个与经过身份验证的本地 Windows 用户帐户类似的内置帐户。以“Local Service”帐户运行的服务将以一个没有凭据的 Null 会话形式访问网络资源。此帐户不适合于 Intranet 部署方案。因为在此部署方案下，报表服务器必须连接至远程报表服务器数据库或网络域控制器，以在打开报表或处理订阅之前对用户进行身份验证。

Local System

Local System 是一个高特权帐户，运行报表服务器时不需要此帐户。请勿将此帐户用于报表服务器的安装。此时应选择域帐户或 Network Service。

使用本地帐户的注意事项

使用本地帐户的主要注意事项是报表服务器是否需要访问远程数据库服务器、邮件服务器和域控制器。如果将报表服务器配置为作为本地 Windows 用户帐户、Local Service 或 Local System 运行，则必须考虑如何设置其他配置设置以及订阅创建和传递方面的注意事项：

  • 如果使用本地帐户运行服务，则以后在配置远程报表服务器数据库的连接时，选项将受到限制。具体来说，如果您使用的是远程报表服务器数据库，则必须将连接配置为使用有权登录到远程 SQL Server 实例的域用户帐户或 SQL Server 数据库用户。

  • 在本地帐户下运行服务将对订阅的创建具有新的要求。报表服务器存储创建订阅的用户的信息。如果用户在使用域帐户登录时创建订阅，则在处理订阅时，报表服务器服务将尝试连接到域控制器以对用户进行身份验证。如果此服务使用本地帐户运行，则在报表服务器尝试将身份验证请求发送到远程域控制器时，此请求将失败。若要消除此限制，可以使用基于窗体的自定义身份验证扩展插件或让所有用户使用本地用户帐户连接到报表服务器。

  • 在本地帐户下运行服务将对订阅的传递具有新的要求。某些传递扩展插件在订阅定义中包含有用户帐户信息。如果要将报表发送到基于域用户帐户的电子邮件地址，并且使用本地帐户运行报表服务器服务，则此服务将无法访问远程域控制器以解析目标电子邮件帐户。

请参阅

任务

如何为 Reporting Services 配置服务帐户

概念

配置报表服务器服务帐户
Reporting Services 配置的 F1 帮助主题

其他资源

报表服务器
启动和停止报表服务器服务


Web 服务 URL（Reporting Services 配置）

Web 服务 URL（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 >

使用“Web 服务 URL”页可配置或修改用于访问报表服务器的 URL。将基于指定的 URL 创建“URL 保留项”。URL 保留项定义适用于所有 URL 的语法和规则，随后可使用这些 URL 来访问报表服务器 Web 服务。它指定报表服务器 Web 服务的前缀、主机、端口和虚拟目录。根据指定主机的方式不同，一个保留可能会对应多个 URL。主机的默认值指定强通配符。使用强通配符，可在 URL 中指定可解析为承载报表服务器的计算机的任何主机名。有关 URL 配置和保留的详细信息，请参阅如何配置 URL（Reporting Services 配置）和配置报表服务器 URL。

若要打开此页，请启动 Reporting Services 配置工具，并在导航窗格中单击“Web 服务 URL”。有关详细信息，请参阅如何启动 Reporting Services 配置。

此页提供报表服务器 URL 中常用的值。如果要创建其他 URL，请使用主机标头，或指定特殊格式的 IP 地址，然后单击“高级”。

单击“应用”后，此页上将显示一个指向 Web 服务的链接。如果在创建报表服务器数据库之前单击此链接，则可能会看到“Page Not Found”（找不到页）错误。配置数据库后，就不会再显示此错误。有关详细信息，请参阅如何创建报表服务器数据库（Reporting Services 配置）。

如果重新安装了 Reporting Services，但在试图使用“所有已分配的”的默认 IP 地址值和端口 80 时收到错误，则通常情况下，重新启动服务后重新创建该 URL 即可纠正此错误。有关说明，请参阅配置错误故障排除。

选项

虚拟目录

指定报表服务器 Web 服务的虚拟目录名称。在同一台计算机上，每个报表服务器 Web 服务实例只能有一个虚拟名称。

IP 地址

标识 TCP/IP 网络上的报表服务器计算机。有效值包括：

  • “所有已分配的”指定分配给计算机的任何 IP 地址均可用在指向报表服务器应用程序的 URL 中。此值还包含友好主机名（如计算机名），域名服务器可将该主机名解析为分配给该计算机的 IP 地址。此为 Reporting Services URL 的默认值。

  • “所有未分配的”指定报表服务器将接受任何未完全匹配 IP 地址或主机名的请求。如果其他 Web 应用程序已在使用此值，请不要再使用它。如果仍使用此值，将中断其他应用程序的服务。

  • 127.0.0.1 用于访问本地主机。它支持对报表服务器计算机进行本地管理。如果仅选择此值，则只有在本地登录到报表服务器计算机的用户可以访问应用程序。

  • Nnn.nnn.nnn.nnn 是计算机网络适配器的 IPv4 地址。如果您的网络使用 Ipv6 寻址，IP 地址将为 8 个 4 字节字段组成的 128 位值，其格式大致如下：<标头>:nnnn:nnnn:nnnn:nnnn

    如果有多个网络适配器，您将看到每个网络适配器都有一个 IP 地址。如果仅选择此值，它将限制对该 IP 地址（以及域名服务器映射到该地址的任何主机名）的应用程序访问。您不能使用 localhost 访问报表服务器，也不能使用安装在报表服务器计算机上的其他网络适配器的 IP 地址。

TCP 端口

指定报表服务器为包含报表服务器虚拟目录名称的 URL 监视 HTTP 请求的端口。

SSL 证书

将证书绑定到指定的 IP 地址。必须在计算机上安装和配置此证书。Reporting Services 不提供管理证书的功能。证书必须颁发给解析为 IP 地址的主机名或计算机名。例如，若要使用已颁发给 http://salesreports 的证书，则指定的 IP 地址必须解析为名为 salesreports 的服务器。

如果使用证书，则必须修改 RSReportServer.config 文件中的 UrlRoot 配置设置，以便指定要为其注册证书的计算机的完全限定名称。有关详细信息，请参阅 SQL Server 联机丛书中的配置报表服务器用于安全套接字层 (SSL) 连接。

SSL 端口

为 SSL 连接指定端口。

URL

显示为当前报表服务器实例定义的 URL。

高级

单击此选项可为当前应用程序实例创建其他 URL。

请参阅

概念

Reporting Services 配置的 F1 帮助主题
配置报表服务器 URL

其他资源

并行部署 Reporting Services 和 Internet Information Services
规划 Extranet 或 Internet 部署


高级多网站配置（Reporting Services 配置）

高级多网站配置（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 > Web 服务 URL（Reporting Services 配置） >

使用此对话框可创建和管理用于访问报表服务器或报表管理器的 URL。“高级多网站配置”对话框用于创建附加 URL 和包含主机标头名称的自定义 URL，或者用于指定 IPv4 或 IPv6 格式的 IP 地址。

如果要配置多种不同的方式来访问报表服务器，则创建多个 URL 非常有用。例如，通过 Intranet 和 Extranet 连接访问报表服务器通常对于每种类型的连接需要具有不同的 URL。

若要打开“高级多网站配置”对话框，请单击 Reporting Services 配置工具中的“Web 服务 URL”页或“报表管理器 URL”页上的“高级”。“高级多网站配置”对话框打开后，可以单击“添加”或“编辑”来定义新的 URL，或者修改或删除现有的 URL。

单击“确定”保存所做的更改。如果添加或删除 URL 后，没有先单击“确定”就关闭了对话框，所做的更改将丢失。

选项

IP 地址

标识 TCP/IP 网络上的报表服务器计算机。有效值包括：

  • “所有已分配的”指定分配给计算机的任何 IP 地址均可用在指向报表服务器应用程序的 URL 中。此值还包含友好主机名（如计算机名），域名服务器可将该主机名解析为分配给该计算机的 IP 地址。此为 Reporting Services URL 的默认值。

  • “所有未分配的”指定报表服务器将接受任何未完全匹配 IP 地址或主机名的请求。如果其他 Web 应用程序已在使用此值，请不要再使用它。如果仍使用此值，将中断其他应用程序的服务。

  • 127.0.0.1 用于访问本地主机。它支持对报表服务器计算机进行本地管理。如果仅选择此值，则只有在本地登录到报表服务器计算机的用户可以访问应用程序。

  • Nnn.nnn.nnn.nnn 是计算机网络适配器的 IPv4 地址。如果您的网络使用 Ipv6 寻址，IP 地址将为 8 个 4 字节字段组成的 128 位值，其格式大致如下：<标头>:nnnn:nnnn:nnnn:nnnn。

    如果有多个网络适配器，您将看到每个网络适配器都有一个 IP 地址。如果仅选择此值，它将限制对该 IP 地址（以及域名服务器映射到该地址的任何主机名）的应用程序访问。您不能使用 localhost 访问报表服务器，也不能使用安装在报表服务器计算机上的其他网络适配器的 IP 地址。

端口

指定报表服务器监视请求的端口。端口 80 为默认端口。如果使用端口 80，则不必将其包含在 URL 中。如果使用其他任何端口号，则必须始终将其包含在 URL 中（例如，http://localhost:8181/reports）。

主机标头

如果已有一个在域名服务器上定义的主机标头解析为您的计算机，则可以在为报表服务器访问配置的 URL 中指定该主机标头。

主机标头是允许多个网站共享一个 IP 地址和端口的唯一名称。主机标头名称比 IP 地址和端口号更容易记住和键入。这里有一个主机标头名称的示例：www.adventure-works.com。

SSL 端口

为 SSL 连接指定端口。SSL 的默认端口为 443。

SSL 证书

指定安装在此计算机上的 SSL 证书的证书名称。如果证书映射到某个通配符，则可以将其用于报表服务器连接。

指定为其注册证书的完全限定的计算机名称。指定的名称必须与为其注册证书的名称相同。

必须先安装证书，才能使用此选项。还必须修改 RSReportServer.config 文件中的 UrlRoot 配置设置，以便指定要为其注册证书的计算机的完全限定名称。有关详细信息，请参阅 SQL Server 联机丛书中的配置报表服务器用于安全套接字层 (SSL) 连接。

颁发给

显示为其创建证书的计算机的名称。

添加

定义附加 URL。

编辑

修改 URL 语法的任何部分。

删除

从列表中清除 URL 项。

请参阅

任务

如何启动 Reporting Services 配置
如何配置 URL（Reporting Services 配置）

概念

配置报表服务器 URL


数据库（Reporting Services 配置）

数据库（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 >

使用“数据库”页创建和配置为一个或多个报表服务器实例提供内部存储的报表服务器数据库。如果要配置报表服务器以使用远程报表服务器数据库，则必须使用 Reporting Services 配置工具来创建该数据库。

创建报表服务器数据库和配置连接是一个多步骤过程。为了指导您完成各个步骤，此页为每种类型的任务都提供了向导。还将为您创建或更新权限和登录名。您可以在“进度”页中监视每个步骤的状态。如果出现错误，您可以单击该错误以获取如何解决该错误的相关信息。

报表服务器数据库必须支持特定服务器模式。默认模式为本机模式，但如果是在较大的 SharePoint 产品或技术部署中运行报表服务器，则也可以创建 SharePoint 集成模式下的报表服务器。有关详细信息，请参阅如何创建报表服务器数据库（Reporting Services 配置）和如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）。

若要打开此页，请启动 Reporting Services 配置工具，然后单击导航窗格中的“数据库”。有关详细信息，请参阅如何启动 Reporting Services 配置。

选项

SQL Server 名称

在当前报表服务器数据库中，“SQL Server 名称”指定了运行报表服务器数据库的 SQL Server 2005 或 SQL Server 2008 数据库引擎的名称。可以在本地或远程计算机上使用默认或命名实例。

数据库名称

指定存储服务器数据的报表服务器数据库的名称。

报表服务器模式

指示报表服务器数据库是支持本机模式还是支持 SharePoint 集成模式。有关详细信息，请参阅规划部署模式。

更改数据库

启动一个向导以指导您完成创建或选择报表服务器数据库所需的所有步骤。

凭据类型

指定报表服务器用来连接报表服务器数据库的凭据。可以指定的凭据类型包括服务帐户、Windows 域用户、Windows 本地用户或 SQL Server 数据库登录名。有关选择凭据的详细信息，请参阅配置报表服务器数据库连接。

用户名

如果使用的是 Windows 凭据，请指定域用户帐户；如果使用的是 SQL Server 凭据，则指定 SQL Server 登录名。如果使用的是 Windows 凭据，请以如下格式指定它们：<域>\<帐户>。

密码

指定帐户的密码。

更改凭据

启动可指导您完成以下操作所需的所有步骤的向导，这些操作包括选择不同的帐户或更新用于连接到报表服务器数据库的帐户的密码。

请参阅

任务

如何创建报表服务器数据库（Reporting Services 配置）

概念

Reporting Services 配置的 F1 帮助主题
创建报表服务器数据库
升级报表服务器数据库
配置报表服务器数据库连接
为扩展部署配置 Reporting Services

其他资源

报表服务器数据库
管理报表服务器数据库


更改数据库向导（Reporting Services 配置）

更改数据库向导（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 > 数据库（Reporting Services 配置） >

Reporting Services 配置工具提供了更改数据库向导，可引导您完成创建新的报表服务器数据库或选择现有报表服务器数据库用于当前报表服务器实例的步骤。

如果您选择来自早期版本的报表服务器数据库，所选数据库将进行升级，以便与其连接的报表服务器实例的版本匹配。服务启动时，它会检查数据库版本并自动将其升级到当前架构。

若要启动此向导，请在 Reporting Services 配置工具中的“数据库”页上单击“更改数据库”。有关如何启动 Reporting Services 配置工具的说明，请参阅如何启动 Reporting Services 配置。

选项

操作

选择您要执行的任务。您可以在本机模式或 SharePoint 集成模式下创建新的数据库。或者，您也可以选择现有的报表服务器数据库以将其与当前报表服务器实例一起使用。

数据库服务器

指定承载报表服务器数据库的 SQL Server 数据库引擎实例的名称。可以使用 SQL Server 2005 或 SQL Server 2008 实例。可以使用本地或远程计算机上的默认或命名实例。如果要连接到命名实例，请按如下格式输入服务器名称：<服务器>\<实例>。

若要连接到数据库引擎实例，必须使用有权登录到服务器并更新数据库信息的凭据。Reporting Services 配置工具使用您的当前 Windows 凭据，但如果您没有登录名或数据库权限，您必须指定一个 SQL Server 数据库登录名。您不能指定其他 Windows 凭据。如果您希望以其他 Windows 用户身份连接，请以该用户身份登录，然后启动 Reporting Services 配置工具。

如果要连接到远程实例，您需要先为该实例启用远程连接。SQL Server 的某些版本和版本类别在默认情况下不启用远程连接。若要确认是否允许建立远程连接，请使用 SQL Server 配置管理器工具并确认 TCP/IP 和命名管道协议处于启用状态。如果远程实例也是一个命名实例，应检查在目标服务器上 SQL Server Browser 服务是否已启用并正在运行。SQL Server Browser 为 Reporting Services 配置工具提供命名实例使用的端口号。

数据库

指定存储服务器数据的报表服务器数据库的名称。可以指定现有的数据库或创建新的数据库。

当您在“操作”页面中选择“创建新数据库”时，用于创建新数据库的属性将显示在向导中。Reporting Services 配置工具将创建按名称绑定的两个数据库：一个数据库用于包含静态数据，还有一个临时数据库用于存储会话和工作数据。有关详细信息，请参阅报表服务器数据库。

您也可以选择现有的报表服务器数据库。Reporting Services 配置工具不会将无效的数据库筛选出来。有效的数据库是基于报表服务器数据库架构的（您不能选择缺少必要的表、视图或存储过程的数据库）。如果您选择为 Reporting Services 的早期版本创建的数据库，则所选数据库将升级成当前格式。

语言

只有在创建新的报表服务器数据库时，才需设置此值。

利用此值，您可以指定以何种语言创建角色定义和说明。Reporting Services 提供了一个基于角色的授权模型，此模型包含一组预定义的角色。这些角色仅会以您指定的语言创建一次。角色名称和说明绝不会以其他语言显示，即使您连接到报表服务器所用的浏览器的区域性或语言设置受此服务器支持，也不例外。您指定的语言也决定了使用何种语言创建作为“我的报表”功能一部分的“我的报表”文件夹和“用户”文件夹的名称。有关 Reporting Services 中所支持语言的详细信息，请参阅多语言或全局部署的解决方案设计注意事项 (Reporting Services)。

服务器模式

报表服务器数据库支持本机模式或 SharePoint 集成模式。这两种模式是互斥的。

如果您要创建新的报表服务器数据库，必须指定一种模式。您选择的模式决定了报表服务器数据库的结构并将报表服务器系统属性 SharePointIntegrated 设置为 true 或 false。

如果您要选择其他报表服务器数据库，则会显示当前数据库的模式，以便让您知道当前数据库的使用方式。您可以选择为其他模式创建的数据库。这样做将会切换当前报表服务器实例的服务器模式。有关模式的详细信息，请参阅 规划部署模式。

凭据

指定用于将报表服务器连接到报表服务器数据库的帐户。有效值包括报表服务器 Web 服务的服务帐户、在您要用来承载报表服务器的数据库引擎实例上定义的 SQL Server 数据库登录名，或 Windows 帐户。如果您要使用 Windows 帐户，则在报表服务器和数据库位于同一台计算机上时可以指定本地帐户（<计算机名>\<用户名>），或者，在报表服务器和数据库位于同一域内的不同计算机上时可以指定域用户帐户（<域>\<用户名>）。

报表服务器将创建一个数据库登录名，并为您指定的帐户分配数据库权限。

报表服务器自身不创建帐户。您指定的帐户必须已经存在，并且对于部署配置而言必须是有效的。具体来说，如果数据库位于远程计算机上并且您希望使用 Windows 帐户，则您必须指定对该计算机拥有登录权限的帐户。

如果计算机位于其他域或不可信域中，请考虑使用 SQL Server 数据库登录名。有关选择帐户的详细信息，请参阅配置报表服务器数据库连接。

摘要

在安装程序配置连接前验证设置。

进度和完成

监视每个任务的进度。

请参阅

任务

如何创建报表服务器数据库（Reporting Services 配置）

参考

数据库（Reporting Services 配置）
更改凭据向导（Reporting Services 配置）

概念

Reporting Services 配置的 F1 帮助主题
配置报表服务器数据库连接
为扩展部署配置 Reporting Services

其他资源

规划部署模式
报表服务器数据库
管理报表服务器数据库


更改凭据向导（Reporting Services 配置）

更改凭据向导（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 > 数据库（Reporting Services 配置） >

Reporting Services 配置工具提供了更改凭据向导，用以引导您完成重新配置报表服务器用于连接到报表服务器数据库的帐户的步骤。更改凭据时，此工具将为报表服务器当前使用的报表服务器数据库更新数据库服务器的所有权限和数据库登录信息。

若要启动此向导，请在 Reporting Services 配置工具中的“数据库”页上单击“更改凭据”。有关如何启动 Reporting Services 配置工具的说明，请参阅如何启动 Reporting Services 配置。

选项

数据库服务器

指定运行报表服务器数据库的 SQL Server 数据库引擎实例的名称。

若要连接到数据库引擎实例，必须使用有权登录到服务器并更新数据库信息的凭据。Reporting Services 配置工具使用您当前的 Windows 凭据，但如果您没有登录名或数据库权限，则可以指定一个 SQL Server 数据库登录名。

您不能指定其他 Windows 凭据。如果您希望以其他 Windows 用户身份连接，请以该用户身份登录，然后启动 Reporting Services 配置工具。

凭据

指定用于将报表服务器连接到报表服务器数据库的帐户。有效值包括报表服务器 Web 服务的服务帐户、在您要用来承载报表服务器的数据库引擎实例上定义的 SQL Server 数据库登录名，或 Windows 帐户。如果您要使用 Windows 帐户，则在报表服务器和数据库位于同一台计算机上时可以指定本地帐户（<计算机名>\<用户名>），或者，在报表服务器和数据库位于同一域内的不同计算机上时可以指定域用户帐户（<域>\<用户名>）。

报表服务器将创建一个数据库登录名，并为您指定的帐户分配数据库权限。

报表服务器自身不创建帐户。您指定的帐户必须已经存在，并且对于部署配置而言必须是有效的。具体来说，如果数据库位于远程计算机上并且您希望使用 Windows 帐户，则您必须指定对该计算机拥有登录权限的帐户。

如果计算机位于其他域或不可信域中，请考虑使用 SQL Server 数据库登录名。有关选择帐户的详细信息，请参阅配置报表服务器数据库连接。

摘要

在向导运行之前验证设置。

进度和完成

监视每个任务的进度。

请参阅

任务

如何创建报表服务器数据库（Reporting Services 配置）

参考

数据库（Reporting Services 配置）
更改数据库向导（Reporting Services 配置）

概念

Reporting Services 配置的 F1 帮助主题
配置报表服务器数据库连接
为扩展部署配置 Reporting Services

其他资源

报表服务器数据库
管理报表服务器数据库


报表管理器 URL（Reporting Services 配置）

报表管理器 URL（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 >

使用报表管理器 URL 页可配置或修改用于访问报表管理器的 URL。默认情况下，报表管理器 URL 继承报表服务器 Web 服务 URL 的前缀、IP 地址和端口。这是因为报表管理器提供了对于运行在相同报表服务器服务中的 Web 服务的前端访问。如果您正在隔离服务应用程序并使用报表管理器访问其他计算机上的报表服务器 Web 服务，则必须编辑 RSReportServer.config 文件以将报表管理器指向不同的实例。有关配置报表管理器与远程报表服务器的连接的详细信息，请参阅如何配置报表管理器。

如果您打算将报表服务器配置为在 SharePoint 集成模式下运行，请不要创建报表管理器 URL。在 SharePoint 集成模式下运行的报表服务器不支持报表管理器。如果报表管理器已存在一个 URL，则将报表服务器配置为在 SharePoint 集成模式下运行后，该 URL 将不可用。

若要打开该页，请启动 Reporting Services 配置工具，并在导航窗格中单击“报表管理器 URL”。有关如何启动此工具的详细信息，请参阅如何启动 Reporting Services 配置。

注意：
如果报表管理器未启用，则将无法设置此页上的选项。有关启用报表管理器的详细信息，请参阅如何打开或关闭 Reporting Services 功能。

选项

虚拟目录

指定报表管理器的虚拟目录名称。在同一台计算机上，每个报表管理器实例只能有一个虚拟目录名称。

URL

显示为当前报表管理器实例定义的 URL。

高级

为当前报表管理器实例添加附加 URL。

请参阅

任务

如何配置 URL（Reporting Services 配置）

概念

配置文件中的 URL (Reporting Services)
Reporting Services 配置的 F1 帮助主题
配置报表服务器 URL

其他资源

服务体系结构 (Reporting Services)
RSReportServer 配置文件
规划部署模式
报表管理器


电子邮件设置（Reporting Services 配置）

电子邮件设置（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 >

使用此页可指定简单邮件传输协议 (SMTP) 设置，这些设置用于启用报表服务器的报表服务器电子邮件传递功能。可使用报表服务器电子邮件传递扩展插件通过电子邮件订阅来分发报表或报表处理通知。报表服务器电子邮件传递扩展插件需要使用 SMTP 服务器并在“发件人:”字段中使用电子邮件地址。

其他的配置设置（包括限制邮件服务器主机和呈现扩展插件可用性的设置）可用于进一步自定义电子邮件订阅。不能在 Reporting Services 配置工具中指定这些设置。若要配置其他设置，必须手动编辑 RSReportServer.config 文件。有关详细信息，请参阅配置报表服务器以进行电子邮件传递和 配置文件 (Reporting Services)。

若要打开此页，请启动 Reporting Services 配置工具，然后在导航窗格中单击“电子邮件设置”。有关详细信息，请参阅如何启动 Reporting Services 配置。

选项

发件人地址

指定要在所生成电子邮件的“发件人:”字段中使用的电子邮件地址。您必须指定一个有权从 SMTP 服务器中发送邮件的用户帐户。

当前 SMTP 传递方法

指定报表服务器电子邮件通过 SMTP 服务器进行路由。这是可以在 Reporting Services 配置工具中指定的唯一传递方法。

另一种传递方法是使用本地 SMTP 服务拾取目录。如果网络 SMTP 服务不可用，则可以使用此传递方法。若要指定本地 SMTP 服务拾取目录，必须编辑 RSReportServer.config 文件。如果您编辑配置文件以使用本地 SMTP 服务拾取目录，Reporting Services 配置工具会将“传递方法”选项设置为“自定义”，以指示传递方法在配置文件中指定。

在配置文件中，可以通过 SendUsing 配置设置来设置传递方法。有关指定 SendUsing 设置的详细信息，请参阅配置报表服务器以进行电子邮件传递。

SMTP 服务器

指定要使用的 SMTP 服务器或网关。可以使用网络中的本地服务器或 SMTP 服务器。

请参阅

概念

配置报表服务器以进行电子邮件传递
Reporting Services 配置的 F1 帮助主题


执行帐户（Reporting Services 配置）

执行帐户（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 >

使用此页可以配置用于无人参与处理的帐户。只有在其他凭据源不可用的以下特殊情况时，才使用此帐户：

  • 当报表服务器连接到不需要凭据的数据源时。可能不需要凭据的数据源示例包括 XML 文档和一些客户端数据库应用程序。

  • 当报表服务器连接到其他服务器以检索报表中所引用的外部图像文件或其他资源时。

设置此帐户是可选的，但如果不设置此帐户，则将限制您使用外部图像以及与一些数据源的连接。在检索外部图像文件时，报表服务器将检查是否可以建立匿名连接。如果连接受密码保护，报表服务器将使用无人参与的报表处理帐户来连接到远程服务器。在为报表检索数据时，报表服务器或者模拟当前用户、提示用户提供凭据或使用存储的凭据，或者（如果数据源连接指定“无”作为凭证类型）使用无人参与的处理帐户。在连接到其他计算机时，报表服务器不允许对其服务帐户凭据进行委托或模拟，因此，如果不能使用其他凭据，报表服务器就必须使用无人参与的处理帐户。

您指定的帐户不能是用于运行服务帐户的帐户。如果配置了该帐户，它将作为加密值存储在 RSReportServer.config 文件中。如果将在扩展部署中运行该报表服务器，则必须在每个报表服务器上以相同的方式配置此帐户。

您可以使用任何一个 Windows 用户帐户。为获得最佳结果，请选择拥有读取权限和网络登录权限的帐户，以支持与其他计算机的连接。对于您希望在报表中使用的任何外部图像或数据文件，它必须拥有对这些文件的读取权限。切勿指定本地帐户，除非所有报表数据源和外部图像均存储在报表服务器计算机中。只可将该帐户用于无人参与报表处理。

注意：
如果使用的是带高级服务的 SQL Server 2008 Express，则仅当在报表中引用外部图像并且访问该图像文件需要相应权限时才需要配置此帐户。SQL Server Express 不支持到远程服务器的数据源连接。

若要打开该页，请启动 Reporting Services 配置工具，并在导航窗格中选择“执行帐户”。有关详细信息，请参阅如何启动 Reporting Services 配置。

选项

指定执行帐户

选择此选项可指定一个帐户。

帐户

输入一个 Windows 域用户帐户。使用如下格式：<域>\<用户帐户>。

密码

键入密码。

确认密码

重新键入密码。

请参阅

概念

Reporting Services 配置的 F1 帮助主题
存储加密的报表服务器数据
配置无人参与的执行帐户

其他资源

RSReportServer 配置文件


加密密钥（Reporting Services 配置）

加密密钥（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 >

使用“加密密钥”页可以管理用于对报表服务器中数据进行加密和解密的对称密钥。管理加密密钥是报表服务器配置的一个重要方面。虽然在您创建报表服务器数据库时将自动创建并应用对称密钥，但是您必须创建对称密钥的备份副本，以便执行日常的维护操作。您需要具有对称密钥的有效副本，才可执行以下维护任务：

  • 更改报表服务器服务的服务帐户。

  • 将 Reporting Services 安装迁移到其他计算机。

  • 配置新的报表服务器实例以共享或使用现有报表服务器数据库。

如果更新了报表服务器服务的用户帐户（并且是使用 Reporting Services 配置工具以外的工具更改了此帐户），或者要将报表服务器安装迁移到新服务器，则必须还原对称密钥。

为了保护对称密钥免受未经授权的访问，对称密钥使用报表服务器服务的私钥进行了加密。只有报表服务器服务可以解锁并使用对称密钥以在报表服务器数据库中存储敏感数据。如果更改了报表服务器服务的标识，或者将报表服务器迁移到新计算机，则报表服务器服务的私钥将不再能够解开对称密钥的锁定。若要恢复对对称密钥的访问，则必须使用新报表服务器服务标识的私钥重新加密对称密钥。还原对称密钥就是对对称密钥重新加密的过程。

只应还原当前用于加密和解密报表服务器数据库中数据的对称密钥。如果还原无效的对称密钥，您将不再能够访问敏感数据。在这种情况下，必须删除并重新创建密钥。

重要提示：
删除并重新创建对称密钥是不可逆转的操作，它会对当前安装产生重要的影响。如果删除对称密钥，则使用此对称密钥加密的所有现有数据将随此对称密钥一起被删除。删除的数据包括指向外部报表数据源的连接字符串、存储的连接字符串和某些订阅信息。

若要打开此页，请启动 Reporting Services 配置工具，然后在导航窗格中选择相应链接。有关详细信息，请参阅如何启动 Reporting Services 配置。

选项

备份

将对称密钥复制到您指定的文件。对称密钥决不能以纯文本形式存储。您必须键入密码来保护该文件。

还原

将以前保存的对称密钥的副本应用于报表服务器数据库。您必须提供密码对文件进行解锁。

还原后的对称密钥副本将覆盖当前连接的报表服务器实例还原前的对称密钥副本。还原对称密钥后，必须初始化使用该报表服务器数据库的所有报表服务器。有关初始化报表服务器的详细信息，请参阅初始化报表服务器。

更改

重新创建对称密钥并对报表服务器数据库中的所有加密值重新进行加密。请确保在重新创建对称密钥前停止报表服务器服务。

在扩展部署中，对称密钥的所有副本都将替换为新的版本。在更改对称密钥前，请务必检查加入扩展部署的服务器的列表，以确认仅对有效的报表服务器实例授予了对新密钥的访问权限。“扩展部署”页列出了扩展部署中包含的服务器。在重新创建密钥前，请停止部署中包含的各个报表服务器上的报表服务器服务。

请注意，如果您具有许多数据源和订阅，则重新生成对称密钥的过程可能需要耗费较长的时间。

删除

删除对称密钥和所有加密内容（包括连接字符串和存储的凭据）。如果您无法还原对称密钥，则只能删除该密钥。

一旦删除了对称密钥，您必须在报表和共享数据源中重新输入缺少的连接字符串和存储的凭据，因为其中已不再具有这些值。另外，对于使用存储加密数据的传递扩展插件的所有订阅，还必须进行更新。这包括使用加密值的文件共享传递扩展插件和任何第三方传递扩展插件。

此信息无法自动更新。一次只能更新一个使用存储的凭据和连接字符串的报表、订阅和共享数据源。

请参阅

概念

Reporting Services 配置的 F1 帮助主题
备份和还原加密密钥
删除和重新创建加密密钥
初始化报表服务器
存储加密的报表服务器数据

其他资源

初始化和加密密钥错误故障排除


备份加密密钥（Reporting Services 配置）

备份加密密钥（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 > 加密密钥（Reporting Services 配置） >

Reporting Services 使用加密密钥来保护存储在报表服务器数据库中的敏感数据。备份该密钥对于确保可继续访问连接字符串和凭据至关重要。

如果将报表服务器数据库移动到其他计算机，或者更改报表服务器服务帐户的用户名或密码，则必须备份该密钥。这两个操作均要求您从先前创建的备份副本还原密钥。

若要打开“备份加密密钥”对话框，请单击 Reporting Services 配置工具导航窗格中的“加密密钥”，然后单击“备份”。当使用 Reporting Services 配置工具中的“服务帐户”页更新服务帐户时，也会显示此对话框。

选项

文件位置

为 Reporting Services 指定对称密钥的文件名和位置。对称密钥决不能以纯文本形式存储。您必须键入密码来保护该文件。

密码

键入密码以防止对该文件进行未经授权的访问。只有知道密码的用户才能还原封存在该文件中的密钥。Reporting Services 会强制采用强密码策略。密码必须至少包含 8 个字符，并且应由大小写字母数字字符和至少一个符号字符组合而成。

确认密码

重新键入刚才输入的密码。

请参阅

任务

如何启动 Reporting Services 配置

参考

加密密钥（Reporting Services 配置）

概念

Reporting Services 配置的 F1 帮助主题
备份和还原加密密钥
删除和重新创建加密密钥
初始化报表服务器
存储加密的报表服务器数据

其他资源

初始化和加密密钥错误故障排除


还原加密密钥（Reporting Services 配置）

还原加密密钥（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 > 加密密钥（Reporting Services 配置） >

Reporting Services 使用加密密钥来保护存储在报表服务器数据库中的敏感数据。为确保您可以继续访问加密数据，请务必创建加密密钥的备份，以备以后因服务帐户发生变化而需要还原它或需要将它作为计划迁移的一部分还原时使用。

若要还原此密钥，事先必须将此密钥的备份副本保存到受密码保护的文件中。在密钥还原过程中，报表服务器将用在受密码保护的文件中找到的密钥替换现有密钥。该文件中的密钥必须与用于加密和解密数据的密钥相同。

若要验证是否还原了有效的密钥，请使用报表管理器来查看订阅或具有使用存储凭据的数据源的任何报表。如果在试图打开订阅定义页时出现“报表服务器无法访问加密数据”错误，或在打开此前将存储凭据用于报表数据源的报表时系统提示您输入凭据，则表明您还原的是无效密钥。

如果还原的是与用于加密数据的密钥不同的无效密钥，则无法解密当前存储在报表服务器数据库中的数据。如果还原的是无效密钥，则应立即还原正确密钥的备份副本（如果有的话）。如果没有用于加密数据的密钥的备份副本，则必须删除所有加密数据。请单击加密密钥页上的“删除”按钮以执行此步骤。在删除加密内容之后，必须手动更新所有订阅并重新指定为报表定义的所有存储凭据以及报表服务器上的所有数据驱动订阅。

若要打开“还原加密密钥”对话框，请单击 Reporting Services 配置工具导航窗格中的“加密密钥”，然后单击“还原”。当使用 Reporting Services 配置工具中的“服务帐户”页更新服务帐户时，也会显示此对话框。

选项

文件位置

选择包含对称密钥副本的受密码保护的文件。默认的文件扩展名为 .snk。

密码

输入用于解锁该文件的密码。只有知道密码的用户才可还原密钥。Reporting Services 强制实施强密码策略。密码必须至少包含 8 个字符，并且应由大小写字母数字字符和至少一个符号字符组合而成。

请参阅

任务

如何启动 Reporting Services 配置

参考

加密密钥（Reporting Services 配置）

概念

Reporting Services 配置的 F1 帮助主题
备份和还原加密密钥
删除和重新创建加密密钥
初始化报表服务器
存储加密的报表服务器数据

其他资源

初始化和加密密钥错误故障排除


扩展部署（Reporting Services 配置）

扩展部署（Reporting Services 配置） |
 | 请参阅
配置 SQL Server 2008 > 配置 Reporting Services > Reporting Services 配置的 F1 帮助主题 >

使用此页可以查看扩展部署的初始化状态或将报表服务器联接到扩展部署。

“已初始化的报表服务器”是指可以对报表服务器数据库中存储的敏感数据进行加密和解密的服务器（已存储凭据和连接字符串是存储在此数据库中的加密数据示例）。报表服务器初始化是一项必需的报表服务器操作。

“扩展部署”是指两个或多个报表服务器实例共享单个报表服务器数据库。在以下情况中使用此配置：

  • 作为对服务器群集中的多个报表服务器进行负载平衡的必备条件。在可以对多个报表服务器进行负载平衡之前，必须首先将它们配置为共享同一报表服务器数据库。

  • 通过使用一个服务器处理交互式报表同时使用另一个服务器处理计划的报表，将报表服务器应用程序分段置于不同的计算机上。在此情况下，每个服务器实例均按照共享报表服务器数据库中存储的同一报表服务器内容来处理不同类型的请求。

若要配置扩展部署，则首先应有两个或多个与同一报表服务器数据库连接的报表服务器实例。安装所有实例后，连接到第一个报表服务器，然后使用“扩展部署”页联接每个附加实例。只有已初始化为使用数据库的报表服务器才能初始化其他节点。

若要打开该页，请启动 Reporting Services 配置工具，然后在导航窗格中选择“扩展部署”。有关详细信息，请参阅如何启动 Reporting Services 配置。

选项

SQL Server 名称

指定承载报表服务器数据库的 SQL Server 数据库引擎实例的名称。

数据库名称

指定报表服务器实例当前连接到的数据库的名称。

服务器模式

显示服务器和数据库的模式。服务器模式为“本机”或“SharePoint 集成”。这两种模式均支持扩展部署。

服务器

显示报表服务器名称。在大多数情况下，此为安装报表服务器的计算机的名称。

实例

显示报表服务器实例名称。报表服务器实例基于 SQL Server 实例。

状态

指示报表服务器是已初始化还是正在等待联接扩展部署：

  • 对于不属于扩展部署的独立报表服务器，此页说明此报表服务器实例已根据其专用报表服务器数据库进行初始化。“状态”设置为“已联接”。

  • 对于正在等待联接扩展部署的报表服务器，此页的“服务器”、“实例”和“状态”均为空值。如果选择的现有报表服务器数据库已由其他报表服务器实例使用，则报表服务器将处于等待联接扩展部署状态。此页上的消息将指示您连接到已与场联接的报表服务器。若要完成该请求，请单击“连接”，选择已初始化为使用报表服务器数据库的报表服务器，接着单击“扩展部署”，选择状态为“正在等待联接”的报表服务器实例，然后单击“初始化”。

  • 对于当前作为扩展部署一部分的报表服务器，此页显示共享同一个报表服务器数据库的所有报表服务器实例的初始化状态。查看扩展部署的状态时，连接到哪个服务器无关紧要。对扩展部署中的所有节点均以相同的方式报告它们的状态信息。

    对于属于扩展部署的报表服务器，可使用此页来添加或删除节点。

初始化

单击“初始化”可将报表服务器添加到扩展部署中。该步骤用于将报表服务器配置为使用共享报表服务器数据库中的对称密钥。可以使用“初始化”将报表服务器实例添加到扩展部署中，或者排除迁移或安装故障。

除非您事先配置了与共享报表服务器数据库的连接，否则报表服务器实例将不可用。此外，还必须从已初始化为使用报表服务器数据库的报表服务器执行初始化操作。

删除

单击“删除”可以从报表服务器数据库中删除选定报表服务器实例的加密密钥。您可以通过删除密钥将报表服务器从扩展部署中删除，或者排除迁移或安装故障。使用此选项，将仅删除指定报表服务器实例的加密密钥。报表服务器数据库中的加密数据不受影响。

请确保在删除密钥之前创建了该密钥的备份副本，作为一种防范措施。一旦删除列表中最后一个报表服务器的加密密钥，将对该数据库的任何后续报表服务器初始化提出新的要求。新的要求是初始化报表服务器之后，必须还原对称密钥的备份副本。如果希望访问报表服务器数据库中当前存在的加密数据，还原对称密钥是必需的。

如果不再需要加密数据或者没有密钥的备份副本，则必须删除该加密数据。有关详细信息，请参阅加密密钥（Reporting Services 配置）。

请参阅

任务

如何配置报表服务器扩展部署（Reporting Services 配置）

概念

为扩展部署配置 Reporting Services
初始化报表服务器
配置和管理加密密钥

其他资源

规划部署模式
rskeymgmt 实用工具


配置 Windows 防火墙以允许 SQL Server 访问

配置 Windows 防火墙以允许 SQL Server 访问 |
 | 请参阅
配置 SQL Server 2008 >

防火墙系统有助于阻止对计算机资源进行未经授权的访问。如果防火墙已打开但却未正确配置，则可能会阻止连接 SQL Server。

若要通过防火墙访问 SQL Server 实例，必须在运行 SQL Server 的计算机上配置防火墙以允许访问。防火墙是 Microsoft Windows 的一个组件。也可以安装其他公司的防火墙。本主题讨论如何配置 Windows 防火墙，不过所述基本原理也适用于其他防火墙程序。

注意：
本主题概述了防火墙配置并汇总了 SQL Server 管理员所需的信息。有关防火墙的详细信息以及权威信息，请参阅防火墙文档，例如 Windows Firewall with Advanced Security and IPsec（高级安全 Windows 防火墙和 IPsec）和 Windows Firewall with Advanced Security - Content Roadmap（高级安全 Windows 防火墙 - 内容概览）。

用户如果熟悉“控制面板”中的“Windows 防火墙”项，熟悉高级安全 Windows 防火墙的 Microsoft 管理控制台 (MMC) 管理单元，以及知道要配置哪些防火墙设置，可以直接转至以下列表中的主题：

  • 如何为数据库引擎访问配置 Windows 防火墙

  • 如何为 Analysis Services 访问配置 Windows 防火墙

  • 如何将防火墙配置为允许报表服务器访问

  • 如何为 Integration Services 配置 Windows 防火墙

主题内容

本主题包含以下部分：

基本防火墙信息

默认防火墙设置

用于配置防火墙的程序

数据库引擎使用的端口

Analysis Services 使用的端口

Reporting Services 使用的端口

Integration Services 使用的端口

其他端口和服务

与其他防火墙规则的交互

防火墙配置文件概述

其他防火墙设置

使用高级安全 Windows 防火墙管理单元

解决防火墙设置问题

基本防火墙信息

防火墙的工作原理是检查传入的数据包并将其与一组规则进行比较。如果规则允许数据包通过，则防火墙将把该数据包传递给 TCP/IP 协议以进行其他处理。如果规则不允许数据包通过，则防火墙将丢弃该数据包，此外，如果已启用日志记录，防火墙还将在防火墙日志文件中创建一个条目。

允许的通信的列表采用以下某种方式进行填充：

  • 当启用了防火墙的计算机开始通信时，防火墙会在列表中创建一个条目以便允许响应。传入响应将被视为请求的通信，并且您不必对此进行配置。

  • 管理员可配置防火墙例外。这样将允许访问计算机上运行的指定程序，或访问计算机上的指定连接端口。在此情况下，当计算机充当服务器、侦听器或对等方时，将会接受未经请求的传入通信。必须完成此类配置才能连接到 SQL Server。

选择防火墙策略远较只是确定应打开还是关闭给定端口复杂。当为企业设计防火墙策略时，请确保考虑所有可供使用的规则和配置选项。本主题不讨论所有可能的防火墙选项。建议您查看以下文档：

Getting Started with Windows Firewall with Advanced Security in Windows Vista and Windows Server 2008

Windows Firewall with Advanced Security Design Guide

Introduction to Server and Domain

默认防火墙设置

规划防火墙配置的第一步是确定操作系统的防火墙的当前状态。如果操作系统是从早期版本升级而来，则可能已保留以前的防火墙设置。此外，防火墙设置可能已由其他管理员或域中的组策略更改。不过，默认设置如下所示：

  • Windows Server 2008

    防火墙打开并禁止远程连接。

  • Windows Server 2003

    防火墙关闭。管理员应考虑打开防火墙。

  • Windows Vista

    防火墙打开并禁止远程连接。

  • Windows XP Service Pack 2 或更高版本

    防火墙打开并禁止远程连接。

  • Windows XP Service Pack 1 或更低版本

    防火墙关闭，应打开防火墙。

注意：
打开防火墙将影响访问此计算机的其他程序，例如文件和打印共享以及远程桌面连接。在调整防火墙设置之前，管理员应对计算机上运行的所有应用程序加以考虑。

用于配置防火墙的程序

有三种配置 Windows 防火墙设置的方式。

  • “控制面板”中的“Windows 防火墙”项

    可以从“控制面板”打开“Windows 防火墙”项。

    重要提示：
    在“控制面板”中的“Windows 防火墙”项中所做的更改只会影响当前配置文件。诸如便携式计算机之类的移动设备不应使用“控制面板”中的“Windows 防火墙”项，因为当以其他配置连接设备时配置文件可能会更改。这样以前配置的配置文件将失效。有关配置文件的详细信息，请参阅 Getting Started with Windows Firewall with Advanced Security in Windows Vista and Windows Server 2008（Windows Vista 和 Windows Server 2008 中的高级安全 Windows 防火墙入门）。

    使用“控制面板”中的“Windows 防火墙”项可配置基本选项。其中包括：

    • 打开或关闭“控制面板”中的“Windows 防火墙”项

    • 启用和禁用规则

    • 配置例外的端口和程序

    • 设置一些范围限制

    “控制面板”中的“Windows 防火墙”项最适合于防火墙配置经验不足的用户以及要为非移动的计算机配置基本防火墙选项的用户。也可以采用以下步骤通过 run 命令打开“控制面板”中的“Windows 防火墙”项：

    打开“Windows 防火墙”项

    1. 在“开始”菜单上，单击“运行”，然后输入 firewall.cpl。

    2. 单击“确定”。

  • Microsoft 管理控制台 (MMC)

    使用高级安全 Windows 防火墙 MMC 管理单元可以配置更高级的防火墙设置。此管理单元仅可供 Microsoft Vista 和 Windows Server 2008 使用；不过，它以一种易于使用的方式呈现大多数防火墙选项，并且会显示所有防火墙配置文件。有关详细信息，请参阅本主题后面的使用高级安全 Windows 防火墙管理单元。

  • netsh

    管理员可以在命令提示符下使用 netsh.exe 工具配置和监视基于 Windows 的计算机。通过使用 netsh 工具，可以将输入的上下文命令定向到相应帮助器，然后由帮助器执行此命令。帮助器是一个动态链接库 (.dll) 文件，它通过对一种或多种服务、实用工具或协议提供配置、监视和支持来扩展 netsh 工具的功能。所有支持 SQL Server 的操作系统都具有防火墙帮助器。Microsoft Windows Vista 和 Windows Server 2008 也具有称作 advfirewall 的高级防火墙帮助器。本主题不讨论如何使用 netsh。不过，所述配置选项中的许多选项都可以通过使用 netsh 加以配置。有关使用 netsh 配置 SQL Server 的脚本，请参阅如何在运行 Windows XP Service Pack 2 的系统上使用脚本以编程方式打开端口供 SQL Server 使用。有关 netsh 的详细信息，请参阅以下链接：

    • 如何使用 Netsh.exe 工具和命令行开关

    • 如何使用“netsh advfirewall firewall”上下文而非“netsh firewall”上下文控制 Windows Server 2008 和 Windows Vista 中的 Windows 防火墙行为

    • “netsh firewall”命令及“profile=all”参数不配置基于 Windows Vista 的计算机上的公共配置文件

    • 解决 Windows XP Service Pack 2 中 Windows 防火墙的设置问题（高级用户）

SQL Server 使用的端口

下面几个表可有助于您确定 SQL Server 所使用的端口。

数据库引擎使用的端口

下表列出了数据库引擎经常使用的端口。

方案 | 端口 | 注释
通过 TCP 运行的 SQL Server 默认实例 | TCP 端口 1433 | 这是允许通过防火墙的最常用端口。它适用于与默认数据库引擎安装或作为计算机上唯一运行实例的命名实例之间的例行连接。（命名实例具有特殊的注意事项。请参阅本主题后面的动态端口）。
采用默认配置的 SQL Server 命名实例 | 此 TCP 端口是在启动数据库引擎时确定的动态端口。 | 请参阅下面动态端口部分中的描述。当使用命名实例时，SQL Server Browser 服务可能需要 UDP 端口 1434。
配置为使用固定端口的 SQL Server 命名实例 | 由管理员配置的端口号。 | 请参阅下面动态端口部分中的描述。
专用管理员连接 | TCP 端口 1434 | 默认情况下，不会启用与专用管理员连接 (DAC) 的远程连接。若要启用远程 DAC，请使用外围应用配置器方面。有关详细信息，请参阅了解外围应用配置器。
SQL Server Browser 服务 | UDP 端口 1434 | SQL Server Browser 服务用于侦听指向命名实例的传入连接，并为客户端提供与此命名实例对应的 TCP 端口号。通常，只要使用数据库引擎的命名实例，就会启动 SQL Server Browser 服务。如果客户端配置为连接到命名实例的特定端口，则不必启动 SQL Server Browser 服务。
通过 HTTP 端点运行的 SQL Server 默认实例。 | TCP 端口 80 | 用于通过 URL 实现的 HTTP 连接。
通过 HTTPS 端点运行的 SQL Server 默认实例。 | TCP 端口 443 | 用于通过 URL 实现的 HTTPS 连接。HTTPS 是使用安全套接字层 (SSL) 的 HTTP 连接。
Service Broker | TCP 端口 4022 | 对于 SQL Server Service Broker，没有默认端口，这只是常规配置。
数据库镜像 | 管理员选择的端口。若要确定此端口，请执行以下查询： SELECT name, protocol_desc, port, state_desc FROM sys.tcp_endpoints WHERE type_desc = 'DATABASE_MIRRORING' | 对于数据库镜像，没有默认端口，这只是常规配置。务必避免中断正在使用的镜像端点，尤其是处于带有自动故障转移功能的高安全模式下时。防火墙配置必须避免破坏仲裁。有关详细信息，请参阅指定服务器网络地址（数据库镜像）。
复制 | 与 SQL Server 的复制连接使用典型的常规数据库引擎端口（TCP 端口 1433 等） 复制快照的 Web 同步和 FTP/UNC 访问要求在防火墙上打开其他端口。为了将初始数据和架构从一个位置传输到另一个位置，复制可以使用 FTP（TCP 端口 21）或者通过 HTTP（TCP 端口 80）或文件和打印共享（TCP 端口 137、138 或 139）进行的同步。 | 对于通过 HTTP 进行的同步，复制使用 IIS 端点（其端口可配置，但默认情况下为端口 80），不过 IIS 进程通过标准端口（对于默认实例为 1433）连接到后端 SQL Server。 在使用 FTP 进行 Web 同步期间，FTP 传输是在 IIS 和 SQL Server 发布服务器之间进行，而非在订阅服务器和 IIS 之间进行。 有关详细信息，请参阅Configuring Microsoft Internet Security and Acceleration Server for Microsoft SQL Server 2000 Replication over the Internet（为通过 Internet 进行的 Microsoft SQL Server 2000 复制配置 Microsoft Internet Security and Acceleration Server）。
Transact-SQL 调试器 | TCP 端口 135 请参阅端口 135 的特殊注意事项 可能还需要 IPsec 例外。 | 如果使用 Visual Studio，则在 Visual Studio 主机计算机上，还必须将 Devenv.exe 添加到“例外”列表中并打开 TCP 端口 135。 如果使用 Management Studio，则在 Management Studio 主机计算机上，还必须将 ssms.exe 添加到“例外”列表中并打开 TCP 端口 135。有关详细信息，请参阅配置和启动 Transact-SQL 调试器。

有关为数据库引擎配置 Windows 防火墙的分步说明，请参阅如何为数据库引擎访问配置 Windows 防火墙。

动态端口

命名实例（包括 SQL Server Express）使用动态端口。也就是说，每次启动数据库引擎时，它都将确定一个可用端口并使用此端口号。如果命名实例是安装的唯一数据库引擎实例，则它可能使用 TCP 端口 1433。如果还安装了其他数据库引擎实例，则它可能会使用其他 TCP 端口。由于所选端口可能会在每次启动数据库引擎时更改，因而很难配置防火墙以启用对正确端口号的访问。因此，如果启动防火墙，则建议重新配置数据库引擎以每次都使用同一端口号。这称为固定端口或静态端口。有关详细信息，请参阅配置固定端口。

另一种配置命名实例以侦听固定端口的方法是在防火墙中为诸如 sqlservr.exe 之类的 SQL Server 程序创建例外（针对数据库引擎）。这会非常方便，但当使用高级安全 Windows 防火墙 MMC 管理单元时，端口号将不会显示在“入站规则”页的“本地端口”列中。这会使审核哪些端口处于打开状态变得更为困难。另一注意事项是 Service Pack 或累积的更新可能会更改 SQL Server 可执行文件的路径，这将使防火墙规则作废。

注意：
下面的过程将使用“控制面板”中的“Windows 防火墙”项。高级安全 Windows 防火墙 MMC 管理单元可以配置更复杂的规则。其中包括配置服务例外，这对于提供深度防御会非常有用。请参阅下面的使用高级安全 Windows 防火墙管理单元。

使用“控制面板”中的“Windows 防火墙”项向防火墙添加程序例外。

  1. 在“控制面板”中的“Windows 防火墙”项的“例外”选项卡上，单击“添加程序”。

  2. 浏览到要允许其通过防火墙的 SQL Server 实例的所在位置，例如 C:\Program Files\Microsoft SQL Server\MSSQL10.<实例名称>\MSSQL\Binn，选择 sqlservr.exe，然后单击“打开”。

  3. 单击“确定”。

有关端点的详细信息，请参阅网络协议和 TDS 端点和端点目录视图 (Transact-SQL)。

Analysis Services 使用的端口

下表列出了 Analysis Services 经常使用的端口。

功能 | 端口 | 注释
Analysis Services | 对于默认实例，为 TCP 端口 2383。 | 默认 Analysis Services 实例的标准端口。
SQL Server Browser 服务 | 仅 Analysis Services 命名实例需要的 TCP 端口 2382 | 客户端向 Analysis Services 命名实例发出不指定端口号的连接请求时，该连接请求将被转到端口 2382，即 SQL Server Browser 侦听的端口。然后，SQL Server Browser 将此请求重定向到该命名实例所使用的端口。
配置为通过 IIS/HTTP 使用的 Analysis Services （PivotTable® Service 使用 HTTP 或 HTTPS） | TCP 端口 80 | 用于通过 URL 实现的 HTTP 连接。
配置为通过 IIS/HTTPS 使用的 Analysis Services （PivotTable® Service 使用 HTTP 或 HTTPS） | TCP 端口 443 | 用于通过 URL 实现的 HTTPS 连接。HTTPS 是使用安全套接字层 (SSL) 的 HTTP 连接。

如果用户通过 IIS 和 Internet 访问 Analysis Services，则必须打开 IIS 侦听的端口，并在客户端连接字符串中指定该端口。在这种情况下，不需要打开任何端口就能直接访问 Analysis Services。默认端口 2389 和端口 2382 应当与所有其他并非必需的端口一起受到限制。

有关为 Analysis Services 配置 Windows 防火墙的分步说明，请参阅如何为 Analysis Services 访问配置 Windows 防火墙。

Reporting Services 使用的端口

下表列出了 Reporting Services 经常使用的端口。

功能 | 端口 | 注释
Reporting Services Web 服务 | TCP 端口 80 | 用于通过 URL 实现的与 Reporting Services 之间的 HTTP 连接。建议不要使用预配置规则“万维网服务(HTTP)”。有关详细信息，请参阅下面的与其他防火墙规则的交互部分。
配置为通过 HTTPS 使用的 Reporting Services | TCP 端口 443 | 用于通过 URL 实现的 HTTPS 连接。HTTPS 是使用安全套接字层 (SSL) 的 HTTP 连接。建议不要使用预配置规则“安全万维网服务(HTTPS)”。有关详细信息，请参阅下面的与其他防火墙规则的交互部分。

当 Reporting Services 连接到数据库引擎或 Analysis Services 实例时，还必须为这些服务打开相应的端口。有关为 Reporting Services 配置 Windows 防火墙的分步说明，请参阅如何将防火墙配置为允许报表服务器访问。

Integration Services 使用的端口

下表列出了 Integration Services 服务经常使用的端口。

功能 | 端口 | 注释
Microsoft 远程过程调用 (MS RPC) 由 Integration Services 运行时使用。 | TCP 端口 135 请参阅端口 135 的特殊注意事项 | Integration Services 服务在端口 135 上使用 DCOM。服务控制管理器使用端口 135 执行诸如启动和停止 Integration Services 服务以及将控制请求传送到正在运行的服务等任务。此端口号无法更改。 仅当从 Management Studio 或自定义应用程序连接到远程 Integration Services 服务实例时，才需要打开此端口。

有关为 Integration Services 配置 Windows 防火墙的分步说明，请参阅为 Integration Services 访问配置 Windows 防火墙和如何为 Integration Services 配置 Windows 防火墙。

其他端口和服务

下表列出了 SQL Server 可能依赖的一些端口和服务。

方案 端口 注释

Windows Management Instrumentation

有关 WMI 的详细信息，请参阅WMI Provider for Configuration Management Concepts。

WMI 作为共享服务主机的一部分使用通过 DCOM 分配的端口运行。WMI 可能使用 TCP 端口 135。

请参阅端口 135 的特殊注意事项

SQL Server 配置管理器使用 WMI 列出和管理各个服务。建议使用预配置规则组 Windows Management Instrumentation (WMI)。有关详细信息，请参阅下面的与其他防火墙规则的交互部分。

Microsoft 分布式事务处理协调器 (MS DTC)

TCP 端口 135

请参阅端口 135 的特殊注意事项

如果应用程序使用分布式事务处理，可能必须要将防火墙配置为允许 Microsoft 分布式事务处理协调器 (MS DTC) 在不同的 MS DTC 实例之间以及在 MS DTC 和资源管理器（如 SQL Server）之间进行通信。建议使用预配置的“分布式事务处理协调器”规则组。

Management Studio 中的浏览按钮使用 UDP 连接到 SQL Server Browser 服务。有关详细信息，请参阅 SQL Server Browser 服务。

UDP 端口 1434

UDP 是一种无连接协议。

防火墙具有一个名为 UnicastResponsesToMulticastBroadcastDisabled Property of the INetFwProfile Interface（INetFwProfile 接口的 UnicastResponsesToMulticastBroadcastDisabled 属性）的设置，用于控制防火墙在对广播（或多播）UDP 请求的单播响应方面的行为。 它有以下两种行为：

  • 如果此设置为 TRUE，则根本不允许对广播进行任何单播响应。枚举服务将失败。

  • 如果此设置为 FALSE（默认值），则允许单播响应 3 秒钟。此时间长度不可配置。在堵塞或长时间滞后的网络中，或者对于负载很重的服务器，尝试枚举 SQL Server 实例可能会返回部分列表，这可能会误导用户。

IPsec 通信

UDP 端口 500 和 UDP 端口 4500

如果域策略要求通过 IPSec 进行网络通信，则还必须将 UDP 端口 4500 和 UDP 端口 500 添加到例外列表中。使用 Windows 防火墙管理单元中的“新建入站规则向导”可以选择 IPsec。有关详细信息，请参阅下面的使用高级安全 Windows 防火墙管理单元。

将 Windows 身份验证用于可信域

必须将防火墙配置为允许身份验证请求。

有关详细信息，请参阅如何为域和信任关系配置防火墙。

SQL Server 和 Windows 群集

群集需要与 SQL Server 不直接相关的其他端口。

有关详细信息，请参阅 Enable a network for cluster use（启用网络以供群集使用）。

HTTP 服务器 API (HTTP.SYS) 中保留的 URL 命名空间

很可能为 TCP 端口 80，但可以配置为其他端口。有关常规信息，请参阅配置 HTTP 和 HTTPS。

有关使用 HttpCfg.exe 保留 HTTP.SYS 端点的 SQL Server 特定信息，请参阅Reserving URL Namespaces by Using Http.sys。

端口 135 的特殊注意事项

将 RPC 与 TCP/IP 或 UDP/IP 一起用作传输方式时，通常会根据需要为系统服务动态分配入站端口。将使用端口号大于 1024 的 TCP/IP 和 UDP/IP 端口。这些端口通常被不正式地称为“随机 RPC 端口”。在这些情况下，RPC 客户端依赖 RPC 端点映射器来通知它们为服务器分配了哪些动态端口。对于一些基于 RPC 的服务，可以配置特定端口，而非让 RPC 动态分配一个端口。此外，还可以将 RPC 动态分配的端口范围限制为一个较小的范围，不管何种服务均可如此。有关本主题的详细信息，请参阅以下参考内容：

  • Windows 服务器系统的服务概述和网络端口要求

  • 如何从产品 CD 使用 Windows Server 2003 支持工具排除 RPC 端点映射器的错误

  • Using Distributed COM with Firewalls

  • Remote Procedure Call (RPC)

  • 如何配置与防火墙一起使用的 RPC 动态端口分配

  • Windows 2000 Startup and Logon Traffic Analysis

与其他防火墙规则的交互

Windows 防火墙使用规则和规则组建立其配置。每个规则或规则组通常与特定程序或服务相关，并且该程序和服务可以在您不知道的情况下修改或删除相应规则。例如，规则组“万维网服务(HTTP)”和“安全万维网服务(HTTPS)”与 IIS 相关。启用这些规则将打开端口 80 和 443，并且如果启用这些规则，则依赖端口 80 和 443 的 SQL Server 功能将能正常工作。不过，配置 IIS 的管理员可能会修改或禁用这些规则。因此，如果您为 SQL Server 使用端口 80 或端口 443，则应创建您自己的规则或规则组，这样可以独立于其他 IIS 规则之外维护您的所需端口配置。

高级安全 Windows 防火墙 MMC 管理单元允许符合任何适用允许规则的所有通信。因此，如果有两个均应用于端口 80 的规则（具有不同的参数），则符合任一规则的通信都将得到允许。因此，如果一个规则允许来自本地子网的通过端口 80 的通信而另一个规则允许来自任意地址的通信，则实际结果是不管通信来源是什么，所有通向端口 80 的通信都将得到允许。若要有效地管理对 SQL Server 的访问，管理员应定期查看服务器上启用的所有防火墙规则。

防火墙配置文件概述

Getting Started with Windows Firewall with Advanced Security in Windows Vista and Windows Server 2008（Windows Vista 和 Windows Server 2008 中的高级安全 Windows 防火墙入门）中的 Network location-aware host firewall（识别网络位置的主机防火墙）部分介绍了防火墙配置文件。为了进行汇总，Windows Vista 和 Windows Server 2008 可按照连接性、连接数和类别来识别并记住与它们连接的每个网络。

在高级安全 Windows 防火墙中有三种网络位置类型：

  • 域。Windows 可以验证对计算机所联接域的域控制器的访问。

  • 公共。除域网络之外，其他所有网络最初都归为公共网络一类。直接连到 Internet 的网络或者位于公共场所（如机场和咖啡店）的网络应保留为公共网络。

  • 专用。由用户或应用程序标识为专用的网络。只应将可信网络标识为专用网络。用户很可能希望将家庭网络或小型企业网络标识为专用网络。

管理员可以为每种网络位置类型创建一个配置文件，每个配置文件均包含不同的防火墙策略。在任何时候只能应用一个配置文件。应用配置文件的顺序如下：

  1. 如果要向计算机所属域的域控制器验证所有接口，则应用域配置文件。

  2. 如果要向域控制器验证所有接口或者所有接口均连接到归为专用网络位置一类的网络，则应用专用配置文件。

  3. 否则，应用公共配置文件。

使用高级安全 Windows 防火墙 MMC 管理单元查看和配置所有防火墙配置文件。“控制面板”中的“Windows 防火墙”项仅可配置当前配置文件。

使用“控制面板”中的“Windows 防火墙”项进行其他防火墙设置

添加到防火墙的例外可以限制端口仅对来自特定计算机或本地子网的传入连接打开。这种对端口打开范围的限制可以大大减少计算机对恶意用户的暴露程度，因此建议采用此类限制。

注意：
使用“控制面板”中的“Windows 防火墙”项仅可配置当前防火墙配置文件。

使用“控制面板”中的“Windows 防火墙”项更改防火墙例外的范围

  1. 在“控制面板”中的“Windows 防火墙”项的“例外”选项卡上，选择一个程序或端口，然后单击“属性”或“编辑”。

  2. 在“编辑程序”或“编辑端口”对话框中，单击“更改范围”。

  3. 选择以下选项之一：

    • 任何计算机(包括 Internet 上的计算机)

      建议不要使用。这将使任何可寻址到您计算机的计算机都可以连接到指定程序或端口。如果要允许向 Internet 上的匿名用户呈现信息，则此设置可能是必需的，不过这会增加您对于恶意用户的暴露程度。如果启用此设置，同时还允许网络地址转换 (NAT) 遍历（例如“允许边缘遍历”选项），则会进一步增加您的暴露程度。

    • 仅我的网络(子网)

      这是比“任何计算机”更安全的设置。只有网络的本地子网中的计算机可以连接到相应程序或端口。

    • 自定义列表：

    只有具有列表中的 IP 地址的计算机可以连接。这是比“仅我的网络(子网)”更安全的设置，不过，使用 DHCP 的客户端计算机有时候会更改它们的 IP 地址。这样的话，目标计算机将无法连接。另一台您未打算授权的计算机可能接受这一列出的 IP 地址，从而能够连接。如果希望列出其他配置为使用固定 IP 地址的服务器，则可能最好选择“自定义列表”选项；不过，入侵者可能会假冒 IP 地址。限制防火墙规则的作用大小取决于网络基础结构的优劣。

使用高级安全 Windows 防火墙管理单元

在运行 Vista 或 Windows Server 2008 的计算机上，可以通过使用高级安全 Windows 防火墙 MMC 管理单元来配置其他高级防火墙设置。此管理单元包括规则向导，并提供“控制面板”中的“Windows 防火墙”项中未提供的附加设置。这些设置包括：

  • 加密设置

  • 服务限制

  • 按名称限制计算机的连接

  • 限制连接到特定用户或配置文件

  • 边缘遍历允许通信绕过网络地址转换 (NAT) 路由器

  • 配置出站规则

  • 配置安全规则

  • 传入连接需要 IPsec

使用新建规则向导创建新防火墙规则

  1. 在“开始”菜单上，单击“运行”，键入 WF.msc，然后单击“确定”。

  2. 在“高级安全 Windows 防火墙”的左窗格中，右键单击“入站规则”，然后单击“新建规则”。

  3. 使用所需设置完成“新建入站规则向导”。

解决防火墙设置问题

以下工具和方法对于解决防火墙问题会非常有用：

  • 有效端口状态是与端口相关的所有规则的总体作用结果。当试图禁止通过某一端口访问时，查看引用该端口号的所有规则将会非常有用。为此，请使用高级安全 Windows 防火墙 MMC 管理单元，并按端口号对入站和出站规则进行排序。

  • 查看在运行 SQL Server 的计算机上处于活动状态的端口。此检查过程包括确认正在侦听的 TCP/IP 端口，同时确认这些端口的状态。

    若要验证哪些端口正在侦听，请使用 netstat 命令行实用工具。除了显示活动 TCP 连接以外，netstat 实用工具还将显示多种 IP 统计信息和其他信息。

    列出正在侦听的 TCP/IP 端口

    1. 打开命令提示符窗口。

    2. 在命令提示符下，键入 netstat -n -a。

      -n 开关指示 netstat 以数字方式显示活动 TCP 连接的地址和端口号。-a 开关指示 netstat 显示计算机正在侦听的 TCP 和 UPD 端口。
  • PortQry 实用工具可用于报告 TCP/IP 端口的状态（正在侦听、未在侦听或已筛选）。（对于已筛选状态，端口可能正在侦听，也可能未在侦听；此状态指示实用工具没有收到端口的响应。）PortQry 实用工具可以从 Microsoft 下载中心下载。

有关故障排除的其他主题，请参阅：

  • Troubleshooting Windows Firewall with Advanced Security in Windows Vista and Windows Server 2008 - Diagnostics and Tools

  • 故障排除（数据库引擎）

  • 故障排除（Analysis Services - 数据挖掘）

  • 故障排除 (Reporting Services)

  • 故障排除 (Integration Services)

请参阅

概念

安装故障转移群集前的准备工作

其他资源

Windows 服务器系统的服务概述和网络端口要求


系统和示例数据库

系统和示例数据库 |
 | 请参阅
配置 SQL Server 2008 >

安装 SQL Server 时，安装程序会创建下表中显示的数据库和日志文件。

数据库 | 数据库文件 | 日志文件
master | Master.mdf | Mastlog.ldf
model | Model.mdf | Modellog.ldf
msdb | Msdbdata.mdf | Msdblog.ldf
tempdb | Tempdb.mdf | Templog.ldf
mssqlsystemresource | Mssqlsystemresource.mdf | Mssqlsystemresource.ldf

系统数据库包括 master、model、msdb、mssqlsystemresource 和 tempdb。

注意：
数据库和日志文件的默认位置为 Program Files\Microsoft SQL Server\MSQL10.<实例名>\MSSQL\。如果安装 SQL Server 时更改了默认目录，则此位置将会发生变化。

AdventureWorks 示例数据库

默认情况下，此 SQL Server 版本中不会安装示例数据库。有关安装示例数据库和示例代码的详细信息，请参阅 CodePlex 网站。

安装 SQL Server 2008 后还可以获得有关示例的其他信息。在“开始”菜单中，依次单击“所有程序”、Microsoft SQL Server 2008、“文档和教程”，再单击“Microsoft SQL Server 示例概述”。

请参阅

任务

安装 SQL Server 示例和示例数据库的注意事项

概念

安装 SQL Server 2008
升级到 SQL Server 2008

其他资源

Getting Started with SQL Server Projects and Administration


SQL Server 安装程序的用户界面参考

SQL Server 安装程序的用户界面参考 |
 | 请参阅

本节说明 SQL Server 安装向导提供的安装选项。

请参阅

任务

如何安装 SQL Server 2008（安装程序）


接受许可条款

接受许可条款 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“接受许可条款”页可以接受该 SQL Server 版本的许可条款。

选项

您可以打印许可协议或将其复制到剪贴板。若要继续，请接受许可条款，然后单击“下一步”。若要退出安装过程，请单击“取消”。

请参阅

任务

如何安装 SQL Server 2008（安装程序）

参考

关于 SQL Server 许可条款


添加 SQL Server 故障转移群集节点

添加 SQL Server 故障转移群集节点 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会使用以下规则验证您的计算机配置。

检查项 | 说明 | 用户操作
SSMS_IsInternetConnected | 确保计算机已连接到 Internet。如果启动某个 .NET Framework 应用程序（如 Microsoft Management Studio），则在 .NET Framework 安全检查功能验证证书时可能会稍有延迟。 | 请确保计算机已连接到 Internet。
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致。 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级。
BlockMixedArchitectureUpgrade | 检查尝试升级的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 安装或升级时所使用的 SQL Server 安装媒体必须与要修改的 SQL Server 实例具有相同的体系结构。
Cluster_IsOnlineIfClustered | 确认计算机未群集化，或者计算机已群集化且群集服务已联机。 | 要么计算机未群集化，要么群集已启动且联机。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 安装在域控制器上。 | 确保此计算机不是域控制器。请参阅安装 SQL Server 的安全注意事项。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是某些 SQL Server 2008 版本的必备组件。 | 对于 SQL Server 2008 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定此操作系统平台是否支持 SQL Server 安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。请参阅安装 SQL Server 2008 的硬件和软件要求。
FusionRebootCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 在安装 SQL Server 之前，必须重新启动计算机。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 安装到其他计算机上。

请参阅

任务

如何安装 SQL Server 2008（安装程序）

参考

系统配置检查器的检查参数


Analysis Services 配置 – 帐户设置

Analysis Services 配置 – 帐户设置 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

从 SQL Server 2005 开始，为了确保 SQL Server 比其早期版本更为安全，就进行了一些重大的更改。这些更改秉承了“设计安全、默认安全、部署安全”的策略，目的在于帮助保护服务器及其数据库免遭安全攻击。

SQL Server 2008 通过对服务器和数据库组件引入更多更改，继续实施这一安全强化过程。SQL Server 2008 利用了 Windows Vista 和 Windows Server 2008 具备的一些功能，如用户帐户控制 (UAC)。

通过制定一个“最低特权权限”策略，SQL Server 2008 中引入的更改有助于减少服务器及其数据库的外围应用和攻击区域。也就是说内部帐户可得到保护并已按照操作系统功能和 SQL Server 功能进行划分。这些措施包括：

  • 具有将一个或多个 Windows 主体设置到 SQL Server 内的 Sysadmin 服务器角色中的功能。在 SQL Server 安装过程中会提供此选项。

  • 删除了外围应用配置器 (SAC) 工具。取而代之的是配置管理器工具中的基于策略的管理功能以及相关的一些更改。

这些更改将影响您的 SQL Server 安全规划，并可帮助您为系统创建更加全面的安全配置文件。

在 Windows Vista 上运行 SQL Server 2008 时的注意事项

在 Windows Vista 之前的 Windows 早期版本中，本地 Administrators 组的成员不需要有自己的 SQL Server 登录名，并且在 SQL Server 内部无需向他们授予管理权限。他们以内置服务器主体 BUILTIN\Administrators 的身份连接到 SQL Server，并且在 SQL Server 内部拥有管理权限，因为 BUILTIN\Administrators 是 sysadmin 固定服务器角色的成员。

在 Windows Vista 中，这些机制仅可用于使用提升的 Windows 权限运行的管理用户，而并不推荐使用提升的 Windows 权限。默认情况下，在 Windows Vista 和 Windows Server 2008 操作系统中，管理员是以标准用户的身份执行大多数操作的。因此，您应为每个管理用户创建一个 SQL Server 登录名，并将该登录名添加到 sysadmin 固定服务器角色中。对于用来运行 SQL Server 代理作业的 Windows 帐户，您也应该执行这些操作。这些作业包括复制代理作业。

在 Windows Vista 中安装和运行 SQL Server 2008 时，需要考虑下列注意事项。

Issues Caused by User Account Control in Windows Vista（由 Windows Vista 中用户帐户控制导致的问题）

Windows Vista 包含一个新功能，即用户帐户控制 (UAC)，该功能有助于管理员对提升权限的使用进行管理。默认情况下，在 Windows Vista 中，管理员不使用其管理权限。相反，他们以标准（非管理）用户的身份执行大多数操作，仅在必要时临时运用其管理权限。

UAC 会导致一些已知问题。有关详细信息，请参阅 TechNet 上的下列网页：

Windows Vista: User Account Control（Windows Vista：用户帐户控制）

选项

指定 SQL Server 管理员- 您必须为 SQL Server 实例指定至少一个系统管理员。若要添加用以运行 SQL Server 安装程序的帐户，请单击“当前用户”按钮。若要向系统管理员列表中添加帐户或从中删除帐户，请单击“添加”或“删除”，然后编辑将对其分配 SQL Server 实例的管理员特权的用户、组或计算机的列表。

完成相应列表的编辑后，请单击“确定”，然后在配置对话框中验证管理员列表。完成此列表后，请单击“下一步”。

请参阅

参考

设置 Windows 服务帐户


Analysis Services 配置 - 数据目录

Analysis Services 配置 - 数据目录 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

下表中的默认目录是在 SQL Server 安装过程中可由用户配置的目录。

说明 | 默认目录 | 建议
数据根目录 | C:\Program Files\Microsoft SQL Server\MSAS10.<InstanceID>\OLAP\Data\ | 确保用有限的权限对 \Program files\Microsoft SQL Server\ 文件夹进行了保护。在许多配置中，Analysis Services 性能取决于数据目录所在的存储区的性能。请将此目录放置在附加到系统上的最高性能存储区中。对于故障转移群集安装，应确保数据目录位于共享磁盘上。
日志文件目录 | C:\Program Files\Microsoft SQL Server\MSAS10.<InstanceID>\OLAP\Log\ | 这是 Analysis Services 日志文件的目录，该目录包含 FlightRecorder 日志。如果要延长网络流量记录器持续时间，请确保该日志目录有足够的空间。
Temp 目录 | C:\Program Files\Microsoft SQL Server\MSAS10.<InstanceID>\OLAP\Temp\ | 将 Temp 目录放置在高性能存储子系统中。
备份目录 | C:\Program Files\Microsoft SQL Server\MSAS10.<InstanceID>\OLAP\Backup\ | 这是 Analysis Services 默认备份文件的目录。确保设置合适的权限以防止数据丢失，并确保 Analysis Services 服务的用户组具有写入备份目录的足够权限。不支持对备份目录使用映射的驱动器。

注释

  • 向现有安装添加功能时，不能更改以前安装的功能的位置，也不能为新功能指定该位置。

  • 如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。

  • 在下列情况下，不能安装程序文件和数据文件：

    • 在可移动磁盘驱动器上

    • 在使用压缩的文件系统上

    • 在系统文件所在的目录上

    • 在故障转移群集实例的共享驱动器上

请参阅

概念

SQL Server 的默认实例和命名实例的文件位置


群集磁盘选择

群集磁盘选择
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“群集磁盘选择”页为 SQL Server 故障转移群集选择共享群集磁盘资源。群集磁盘用于存放 SQL Server 数据。

选项

共享磁盘

从列表中选择一个磁盘。群集磁盘用于存放 SQL Server 数据。

只能指定一个磁盘。如果选择包含群集仲裁资源的组，将显示警告。建议不要安装到群集仲裁资源。

可用共享磁盘

显示可用磁盘的列表，对于列表中的每个磁盘，均会显示是否可用作共享磁盘以及磁盘资源的说明。


群集网络选择

群集网络选择
SQL Server 安装程序的用户界面参考 >

使用“群集网络选择”页可为故障转移群集实例指定网络资源。

选项

SQL Server 故障转移群集网络名称 - 此名称用于在网络上标识您的故障转移群集实例。

网络设置 - 指定故障转移群集实例的 IP 类型和 IP 地址。


群集节点配置

群集节点配置
SQL Server 安装程序的用户界面参考 >

使用“群集节点配置”页可以在故障转移群集实例中添加或删除节点。

选项

SQL Server 实例名 - 使用该下拉列表可以选择要修改的 SQL Server 故障转移群集实例。

此节点的名称 - 将使用运行 SQL Server 安装程序的计算机名称填充此字段。这就是将在 SQL Server 故障转移群集实例中添加或删除的故障转移群集节点。


群集节点配置(完成)

群集节点配置(完成) |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“群集节点配置(完成)”页可以指定已准备好进行群集的现有 SQL Server 实例。

选项

下拉框中有以下选项：

  • SQL Server 实例名 - 选择用于 SQL Server 故障转移群集的实例名称。

  • 此节点的名称 - 此字段将使用运行 SQL Server 安装程序的计算机名称进行预先填充。

  • SQL Server 故障转移群集网络名称 - 此字段不进行预先填充。为新的 SQL Server 故障转移群集实例指定网络名称，该名称用来在网络上标识故障转移群集实例。

请参阅

任务

如何创建新的 SQL Server 故障转移群集（安装程序）


群集资源组

群集资源组 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“群集资源组”页可以指定用于放置 SQL Server 虚拟服务器资源的磁盘。

选项

指定 SQL Server 群集资源组名称。您有以下两种选择：

  • 使用下拉框指定一个要使用的现有组。

  • 键入要创建的新组的名称。请注意，名称“Available storage”不是有效的组名。

请参阅

任务

如何创建新的 SQL Server 故障转移群集（安装程序）


群集安全策略

群集安全策略
SQL Server 安装程序的用户界面参考 >

使用“群集安全策略”页可以为故障转移群集实例配置安全策略。

选项

为群集服务指定全局或本地域组。所有资源权限都是由包括作为组成员的 SQL Server 服务帐户的域级组控制的。有关 Windows Server 2008 上的服务安全 ID (SID) 功能的信息，请参阅设置 Windows 服务帐户。


完成(升级)

完成(升级) |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“完成(升级)”页可以验证升级是否已完成。

选项

此对话框包含指向此操作的安装日志文件的链接。若要继续，请单击“关闭”。

请参阅

任务

如何安装 SQL Server 2008（安装程序）


远程数据库升级的凭据

远程数据库升级的凭据 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 Microsoft SQL Server 安装向导的“远程数据库升级的凭据”页可以指定远程报表服务器数据库的数据库登录名。

如果要升级远程 SQL Server 数据库引擎实例上的报表服务器数据库，而您运行安装程序所使用的凭据不具有对远程实例的数据库更新权限，则必须输入安装程序可用来连接到此报表服务器数据库并对其进行修改的凭据。

选项

用户名

指定在升级操作期间使用一次以连接到承载报表服务器数据库的数据库引擎实例的 SQL Server 数据库登录名。此帐户必须具有更新报表服务器数据库架构的权限。

如果用于运行安装程序的凭据对报表服务器数据库没有 sysadmin 或数据库所有者权限，则是必需的。

如果要升级一个使用远程报表服务器数据库存储应用程序数据的报表服务器，而用于运行安装程序的凭据对远程服务器没有足够的权限，则必须指定此值。

密码

登录名的密码；如果登录名没有密码，则为空字符串。

请参阅

概念

升级 Reporting Services 的注意事项
安装 Reporting Services 的注意事项


数据库引擎配置 - 帐户设置

数据库引擎配置 - 帐户设置 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

从 SQL Server 2005 开始，为了帮助确保 SQL Server 比早期版本更为安全，进行了一些重大的更改。这些更改秉承了“设计安全、默认安全、部署安全”的策略，目的在于防止服务器实例及其数据库免遭安全攻击。

SQL Server 2008 通过对服务器和数据库组件引入更多更改，继续实施这一安全强化过程。SQL Server 2008 利用了 Windows Vista 和 Windows Server 2008 中的用户帐户控制 (UAC)。

通过制定一个“最低特权权限”策略，SQL Server 2008 中引入的更改进一步减少了服务器及其数据库的外围应用和攻击区域。也就是说，内部帐户受到保护并分成操作系统功能和 SQL Server 功能。这些措施包括：

  • 具有将一个或多个 Windows 主体设置到 SQL Server 内的 Sysadmin 服务器角色中的功能。在 SQL Server 安装过程中会提供此选项。

  • 已删除外围应用配置器 (SAC) 工具，取而代之的是配置管理器工具中的基于策略的管理和更改。

这些更改将影响您的 SQL Server 安全规划，并可帮助您为系统创建更加全面的安全配置文件。

在 Windows Vista 上运行 SQL Server 2008 时的注意事项

在 Windows Vista 之前的 Windows 早期版本中，本地 Administrators 组的成员不需要有自己的 SQL Server 登录名，并且在 SQL Server 内部无需向他们授予管理权限。他们以内置服务器主体 BUILTIN\Administrators 的身份连接到 SQL Server，并且在 SQL Server 内部拥有管理权限，因为 BUILTIN\Administrators 是 sysadmin 固定服务器角色的成员。

在 Windows Vista 中，这些机制仅可用于使用提升的 Windows 权限运行的管理用户，而并不推荐使用提升的 Windows 权限。默认情况下，在 Windows Vista 和 Windows Server 2008 操作系统中，管理员是以标准用户的身份执行大多数操作的。因此，您应为每个管理用户创建一个 SQL Server 登录名，并将该登录名添加到 sysadmin 固定服务器角色中。对于用来运行 SQL Server 代理作业的 Windows 帐户，您也应该执行这些操作。这些作业包括复制代理作业。

在 Windows Vista 中安装和运行 SQL Server 2008 时，需要考虑下列注意事项。

Issues Caused by User Account Control in Windows Vista（由 Windows Vista 中用户帐户控制导致的问题）

Windows Vista 包含一个新功能，即用户帐户控制 (UAC)，该功能有助于管理员对提升权限的使用进行管理。默认情况下，在 Windows Vista 中，管理员不使用其管理权限。相反，他们以标准用户的身份执行大多数操作，仅在必要时临时使用其管理权限。

UAC 会导致一些已知问题。有关详细信息，请参阅 TechNet 上的下列网页：

Windows Vista: User Account Control（Windows Vista：用户帐户控制）

选项

安全模式 - 选择“Windows 身份验证”或“混合模式身份验证”用于安装。

Windows 主体设置 - 在 SQL Server 的早期版本中，Windows Builtin\Administrator 本地组放入了 SQL Server sysadmin 服务器角色中，有效授予了 Windows 管理员对 SQL Server 实例的访问权限。

重要提示：
如果您的单位的进程或代码取决于 Windows Builtin\Administrator 本地组访问权限，则必须显式授权以登录到 SQL Server。直到您完成此步骤之后，安装程序才允许您继续操作。

指定 SQL Server 管理员 - 您必须为 SQL Server 实例至少指定一个 Windows 主体。若要添加用以运行 SQL Server 安装程序的帐户，请单击“当前用户”按钮。若要向系统管理员列表中添加帐户或从中删除帐户，请单击“添加”或“删除”，然后编辑将拥有 SQL Server 实例的管理员特权的用户、组或计算机列表。

完成列表的编辑后，单击“确定”，然后在配置对话框中验证管理员列表。完成此列表后，请单击“下一步”。

如果选择“混合模式身份验证”，则必须为内置 SQL Server 系统管理员 (SA) 帐户提供登录凭据。

安全说明：
不要使用空密码。请使用强密码。

Windows 身份验证模式

当用户通过 Windows 用户帐户连接时，SQL Server 使用操作系统中的 Windows 主体标记验证帐户名和密码。此为默认身份验证模式，比混合模式更为安全。Windows 身份验证利用 Kerberos 安全协议，通过强密码的复杂性验证提供密码策略强制，提供帐户锁定支持，并且支持密码过期。

安全说明：
请尽可能使用 Windows 身份验证。

重要提示：
不要使用空密码。请使用强密码。切勿设置空密码或弱 sa 密码。

混合模式(Windows 身份验证或 SQL Server 身份验证)

允许用户使用 Windows 身份验证或 SQL Server 身份验证进行连接。通过 Windows 用户帐户进行连接的用户可以使用经过 Windows 验证的可信连接。

如果必须选择“混合模式身份验证”并且要求使用 SQL 登录名以适应早期应用程序，则必须为所有 SQL Server 帐户设置强密码。

注意：
提供 SQL Server 身份验证只是为了向后兼容。请尽可能使用 Windows 身份验证。

输入密码

输入并确认系统管理员 (sa) 登录名。密码是抵御入侵者的第一道防线，因此设置强密码对于系统安全是绝对必要的。切勿设置空密码或弱 sa 密码。

注意：
SQL Server 密码可包含 1 到 128 个字符，包括字母、符号和数字的任意组合。如果选择“混合模式身份验证”，则必须输入强 sa 密码才能进入安装向导的下一页。

强密码指南

强密码不易被人猜出，也不易用计算机程序攻击。强密码不能使用禁止的条件或字词，这些条件或字词包括：

  • 空条件或 NULL 条件

  • “Password”

  • “Admin”

  • “Administrator”

  • “sa”

  • “sysadmin”

强密码不能是与安装计算机相关联的下列字词：

  • 当前登录到计算机的用户的名称。

  • 计算机名称。

强密码的长度必须多于 8 个字符，并且强密码至少要满足下列四个条件中的三个：

  • 它必须包含大写字母。

  • 它必须包含小写字母。

  • 必须包含数字。

  • 必须包含非字母数字字符；例如 #、% 或 ^。

此页上输入的密码必须符合强密码策略要求。如果存在任何使用 SQL Server 身份验证的自动化过程，请确保该密码符合强密码策略要求。

请参阅

参考

设置 Windows 服务帐户


数据库引擎配置 - 数据目录

数据库引擎配置 - 数据目录 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

下表列出了在 SQL Server 安装过程中用户可配置的默认目录：

说明 | 默认目录 | 建议
数据根目录 | C:\Program Files\Microsoft SQL Server\ | SQL Server 安装程序将为 SQL Server 目录配置 ACL 并在配置过程中中断继承。
用户数据库目录 | C:\Program Files\Microsoft SQL Server\MSSQL10.<实例 ID>\Data | 用户数据目录的最佳实践取决于工作量和性能要求。对于故障转移群集安装，应确保数据目录位于共享磁盘上。
用户数据库日志目录 | C:\Program Files\Microsoft SQL Server\MSSQL10.<实例 ID>\Data | 确保日志目录有足够的空间。
临时数据库目录 | C:\Program Files\Microsoft SQL Server\MSSQL10.<实例 ID>\Data | Temp 目录的最佳实践取决于工作量和性能要求。
临时数据库日志目录 | C:\Program Files\Microsoft SQL Server\MSSQL10.<实例 ID>\Data | 确保日志目录有足够的空间。
备份目录 | C:\Program Files\Microsoft SQL Server\MSSQL10.<实例 ID>\Backup | 设置合适的权限以防止数据丢失，并确保 SQL Server 服务的用户组具有写入备份目录的足够权限。不支持对备份目录使用映射的驱动器。

注释

  • 向现有安装中添加功能时，不能更改先前安装的功能的位置，也不能为新功能指定该位置。

  • 如果指定非默认的安装目录，请确保安装文件夹对于此 SQL Server 实例是唯一的。此对话框中的任何目录都不应与其他 SQL Server 实例的目录共享。

  • 在下列情况下，不能安装程序文件和数据文件：

    • 在可移动磁盘驱动器上

    • 在使用压缩的文件系统上

    • 在系统文件所在的目录上

    • 在故障转移群集实例的共享驱动器上

请参阅

概念

SQL Server 的默认实例和命名实例的文件位置


数据库引擎配置 - 文件流

数据库引擎配置 - 文件流 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用此页可针对此 SQL Server 2008 安装启用 FILESTREAM。

针对 Transact-SQL 访问启用 FILESTREAM

选中此选项可针对 Transact-SQL 访问启用 FILESTREAM。必须选中此控制选项，其他控制选项才可用。

针对文件 I/O 流访问启用 FILESTREAM

选中此选项可针对 FILESTREAM 启用 Win32 流访问。

Windows 共享名

使用此控制选项可输入将用来存储 FILESTREAM 数据的 Windows 共享的名称。

允许远程客户端针对 FILESTREAM 数据启用流访问

选中此控制选项可允许远程客户端访问这台服务器上的此 FILESTREAM 数据。

请参阅

其他资源

FILESTREAM 存储入门
sp_configure (Transact-SQL)


数据库引擎配置 - 用户实例

数据库引擎配置 - 用户实例
SQL Server 安装程序的用户界面参考 >

使用“用户实例”页可以为不具有管理员权限的用户生成单独的数据库引擎实例，并可以将用户添加到管理员角色中。

选项

启用用户实例

默认值为“启用”。若要禁用用户实例的功能，请清除此复选框。

用户实例也称为子实例或客户端实例，是由父实例（作为服务运行的主实例，如 SQLExpress）代表用户生成的 SQL Server 实例。用户实例作为用户进程在该用户的安全上下文中运行。用户实例独立于父实例和该计算机上运行的任何其他用户实例。用户实例功能也被称作“以普通用户身份运行” (RANU)。

将用户添加到 SQL Server 管理员角色中

默认情况下不启用此选项。若要将当前安装用户添加到 SQL Server 管理员角色中，请选中此复选框。

作为 BUILTIN\Administrators 成员的 Windows Vista 用户在连接到 SQL Server Express 时，不会自动添加到 sysadmin 固定服务器角色中。只有已显式添加到服务器级管理员角色中的 Windows Vista 用户才能管理 SQL Server Express。Built-In\Users 组的任一成员都可连接到 SQL Server Express 实例，但他们仅拥有执行数据库任务的有限权限。因此，对于从先前 Windows 版本中的 BUILTIN\Administrators 和 Built-In\Users 继承 SQL Server Express 特权的用户，应在运行于 Windows Vista 上的 SQL Server Express 实例中为其显式授予管理特权。

若要在此安装程序完成后对用户角色进行任何更改，请使用 SQL Server 2005 外围应用配置器工具 (SQLSAC.exe)。若要更新 SQL Server 系统管理员角色中的用户列表，请单击“添加新管理员”链接。

确保“要设置的用户”字段中列出了应更新其权限的用户的“域名\用户名”。从“可用权限”窗格的 SQL Server 实例列表中选择要更新的角色，然后单击向右箭头。若要将用户添加到 SQL Server 实例的所有可用实例的所有可用角色中，请单击向右双箭头。

若要在完成选择后实现这些更改，请单击“确定”。若要在不进行更改的情况下结束使用此工具，请单击“取消”。


磁盘成本摘要

磁盘成本摘要 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“磁盘成本摘要”页可以检查选择安装的 SQL Server 2008 功能的磁盘空间要求。

选项

如果所需的磁盘空间太大，应考虑以下选项：

  • 将安装目录更改为具有更多磁盘空间的驱动器。

  • 更改要安装的 SQL Server 功能。

  • 通过移动其他文件或应用程序在指定驱动器上腾出更多可用空间。

请参阅

参考

安装 SQL Server 2008 的硬件和软件要求


版本升级规则

版本升级规则 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会使用以下规则验证您的计算机配置。

检查项 | 说明 | 用户操作
Engine_OnlySupportedFeaturesUsedCheckSystem | 检查系统数据库中是否存在要升级到的 SQL Server 版本中不支持的功能。 | 关闭系统数据库中使用的、在要升级到的 SQL Server 版本中不可用的任何功能。
Engine_OnlySupportedFeaturesUsedCheckUser | 检查所有用户数据库中是否存在 SQL Server 版本不支持的功能。 | 关闭系统数据库中使用的、在要升级到的 SQL Server 版本中不可用的任何功能。
Engine_SqlEngineRestartCheck | 检查是否可以重新启动 SQL Server 服务。 | 确定哪个问题在阻止 SQL Server 服务联机并更正它。
Engine_SqlServerServiceDisabled_Id | 检查 SQL Server 服务是否未设置为“已禁用”。 | 将 SQL Server 服务的启动类型设置为“手动”或“自动”。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 安装在域控制器上。 | 确保此计算机不是域控制器。请参阅安装 SQL Server 的安全注意事项。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是某些 SQL Server 2008 版本的必备组件。 | 对于 SQL Server 2008 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
EditionUpgradeMatrixCheck | 检查所选 SQL Server 实例是否符合升级矩阵要求。 | 不支持某些版本升级方案。请参阅版本升级。
AS_ValidateEditionUpgrade | 检查 Analysis Services 要升级到版本是否有效。 | 不支持某些版本升级方案。请参阅版本升级。
Cluster_EditionDownGradeCheck | 检查此方案是否支持所选 SQL Server 实例的版本。 | 不支持某些版本升级方案。请参阅版本升级。
BlockMixedArchitectureUpgrade | 检查尝试升级的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 不支持某些跨平台升级方案。请参阅版本升级。
EditionDownGradeCheck | 检查此方案是否支持所选 SQL Server 实例的版本。 | 不支持某些版本升级方案。请参阅版本升级。

请参阅

参考

系统配置检查器的检查参数


错误和使用情况报告设置

错误和使用情况报告设置 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“错误和使用情况报告设置”页，可以启用 SQL Server 的功能错误和使用情况报告功能。

选项

对于 SQL Server 2008 预发行版本中的 SQL Server 及其组件，功能使用情况数据收集和错误报告功能在默认情况下已启用。不过，可以通过清除复选框禁用其中一个选项或将两个选项都禁用。

错误报告

如果启用错误报告功能，SQL Server 将配置为在下列任意 SQL Server 组件中发生错误时，自动发送报告到 Microsoft：

  • 数据库引擎

  • SQL Server 代理

  • Analysis Services

  • Reporting Services

  • Integration Services

  • 复制

Microsoft 利用错误报告来改进 SQL Server 的功能，并且对所有信息保密。

有关错误的信息将通过安全 (https) 连接发送到 Microsoft，在那里保存这些信息，且对其访问将受到限制。另外，也可以将这些信息发送到您自己的“公司错误报告”服务器。

错误报告包含下列信息：

  • 发生问题时 SQL Server 的状态。

  • 操作系统版本和计算机硬件信息。

  • 用户数字产品 ID（并非用于标识您的许可证）。

  • 计算机或代理服务器的网络 IP 地址。

  • 来自出错进程的内存或文件的信息。

Microsoft 无意收集您的文件、姓名、地址、电子邮件地址或任何其他私人信息。但是，错误报告可能包含来自导致错误的进程的内存或文件中的个人信息。虽然使用这些信息有可能确定您的身份，但 Microsoft 不会将这些信息用于此目的。

有关 Microsoft SQL Server 隐私保护和数据收集策略的信息，请访问此 Microsoft SQL Server 隐私声明。

如果启用了错误报告功能并出现致命错误，则 Windows 事件日志中可能会包含来自 Microsoft 的一条响应，该响应指向与特定错误有关的 Microsoft 知识库文章。

若要在安装程序完成后禁用 SQL Server 及其组件的所有实例的错误或功能使用情况报告，请转到“错误和使用情况报告设置”对话框并清除“功能使用情况”的复选框。如果为 SQL Server 的多个组件（SQL Server 数据库引擎、Analysis Services、Reporting Services 和共享组件）启用了“错误报告”，则可以对个别组件以及共享组件（在“其他”中列出）的每个实例禁用“错误报告”。

功能使用情况

如果启用“功能使用情况”报告，SQL Server 将被配置为定期向 Microsoft 发送报告。报告将包括有关硬件配置以及如何使用 SQL Server 软件和服务的信息。Microsoft 将使用功能使用情况数据来改进 SQL Server。由此功能监视的 SQL Server 组件包括：

  • 数据库引擎

  • Analysis Services

  • Reporting Services

  • Integration Services

  • 复制

  • Business Intelligence Development Studio

有关功能使用情况的信息将发送到 Microsoft，在那里保存这些信息，且其访问将受到限制。

若要在安装程序完成后禁用功能使用情况报告，请使用 SQL Server“配置工具”菜单上的“SQL Server 错误和使用情况报告”工具。

对所有已启用的 SQL Server 实例会每天收集一次信息。收集时间默认为在午夜，以便最大程度上减小服务器的负载。如果要更改收集时间，可以手动编辑控制收集时间的注册表项。每个 SQL Server 实例都有自己的注册表项：

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL10\CPE\TimeofReporting

该注册表项的值包含运行收集的时间，以从 00:00（午夜）起的分钟数计。例如，值为 60 会在凌晨 1:00 运行收集，而值为 1200 会在晚上 8:00 运行收集，等等。

请参阅

其他资源

Configuring a SQL Server Installation


故障转移群集报告

故障转移群集报告 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“故障转移群集报告”页可以查看安装系统针对此操作所扫描得到的报告结果。

选项

若要查看扫描的详细报告，请单击报告链接。

请参阅

任务

如何安装 SQL Server 2008（安装程序）


功能安装规则

功能安装规则 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 2008 安装程序会验证您的计算机配置。下表描述了系统配置检查器的检查参数和妨碍性问题的解决办法。

检查项 | 说明 | 用户操作
RebootRequiredCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 需要计算机重新启动。在安装 SQL Server 之前，必须重新启动计算机。
OsVersionCheck | 检查计算机是否满足最低操作系统版本要求。 | 操作系统必须满足此产品的最低要求。请参阅安装 SQL Server 2008 的硬件和软件要求。
ThreadHasAdminPrivilegeCheck | 检查运行 SQL Server 安装程序的帐户是否具有计算机的管理权限。 | 请确保运行 SQL Server 安装程序的帐户具有计算机的管理权限。
WmiServiceStateCheck | 检查是否已在计算机上启动并正在运行 WMI 服务。 | 必须正在运行 WMI 服务。
SSMS_IsInternetConnected | 检查计算机是否已连接到 Internet。基于 .NET Framework 技术的 SQL Server 管理工具必须在启动时检查证书吊销列表。 | 请确保计算机已连接到 Internet。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 安装在域控制器上。 | 确保此计算机不是域控制器。请参阅安装 SQL Server 的安全注意事项。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是 SQL Server 2008 Express with Advanced Services 的必备组件。 | 对于 SQL Server 2008 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定操作系统平台是否支持该安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。请参阅安装 SQL Server 2008 的硬件和软件要求。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 安装到其他计算机上。
BlockCrossLanguageInstall | 检查安装语言是否与现有 SQL Server 功能的语言相同。 | 必须使用与现有 SQL Server 实例相同的语言版本来升级 SQL Server。
BlockMixedArchitectureInstall | 检查要安装的功能是否与指定实例具有相同的 CPU 体系结构。 | 安装或升级时使用的 SQL Server 安装媒体必须与要修改的 SQL Server 实例具有相同的体系结构。
RS_DoesCatalogExist | 检查是否存在目录数据库文件。 | 重命名、移动或删除文件。
RS_DoesCatalogTempDBExist | 检查是否存在目录临时数据库文件。 | 重命名、移动或删除文件。
StandaloneInstall_HasClusteredOrPreparedInstanceCheck | 检查所选实例名称是否已被任意群集节点上的现有已准备就绪的或群集化的实例使用。 | 不能使用所选实例名称，因为它已被使用。请指定其他 SQL Server 实例名称。

请参阅

参考

系统配置检查器的检查参数


功能选择

功能选择 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“功能选择”页上的复选框为您的 SQL Server 安装选择组件。

选项

选择各个组件组时，“说明”窗格中会显示相应的说明。您可以选中任意一些复选框。若要继续，必须进行选择。

数据库引擎和 Analysis Services 组件是唯一支持故障转移群集的 SQL Server 2008 功能。可以在故障转移群集节点上安装其他组件，如 Reporting Services 或 Integration Services，但这些组件不能识别群集，因此当该故障转移群集节点脱机时，这些组件的服务不进行故障转移。有关详细信息，请参阅 SQL Server 2008 故障转移群集入门。

选择此组件组 安装这些组件和功能

数据库引擎服务

SQL Server 数据库引擎中包括以下组件：

  • 数据库引擎是用于存储、处理和保护数据的核心服务。

  • 可选：复制是一组技术，用于将数据和数据库对象从一个数据库复制和分发到另一个数据库，然后在数据库之间进行同步以维护一致性。

  • 可选：全文搜索提供了针对 SQL Server 表中基于纯字符的数据发出全文查询的功能。

  • 用于管理关系数据和 XML 数据的工具。

Analysis Services

Analysis Services 包括用于创建和管理联机分析处理 (OLAP) 以及数据挖掘应用程序的工具。

Reporting Services 2,3

Reporting Services 包括用于创建、管理和部署表格报表、矩阵报表、图形报表以及自由格式报表的服务器和客户端组件。Reporting Services 还是一个可用于开发报表应用程序的可扩展平台。

Integration Services

Integration Services 是一组图形工具和可编程对象，用于移动、复制和转换数据。

共享功能：

  • 客户端工具

  • SQL Server 联机丛书

  • Business Intelligence Development Studio 4,5

  • Integration Services

客户端工具包括用于在客户端和服务器之间进行通信的组件，其中包括用于 DB-Library、OLEDB for OLAP、ODBC、ADODB 和 ADOMD+ 的各种网络库以及以下 SQL Server 管理工具：

  • SQL Server Management Studio (SSMS) 是一个集成环境，用于访问、配置、管理和开发 SQL Server 的所有组件。SSMS 将 SQL Server 早期版本中包含的企业管理器、查询分析器和分析管理器的功能组合到单一环境中，为不同层次的开发人员和管理员提供 SQL Server 访问能力。

  • SQL Server 配置管理器为 SQL Server 服务、服务器协议、客户端协议和客户端别名提供基本配置管理。

  • SQL Server Profiler 提供了图形用户界面，用于监视数据库引擎实例或 Analysis Services 实例。

  • 数据库引擎优化顾问可以协助创建索引、索引视图和分区的最佳组合。

  • 使用复制监视器，可以跨复制拓扑跟踪发布和订阅的状态及性能。

  • SQLXML 客户端功能

  • SQL Server 联机丛书是 SQL Server 的核心文档。

Business Intelligence Development Studio 是用于 Analysis Services、Reporting Services 和 Integration Services 解决方案的集成开发环境。

Integration Services 是一组图形工具和可编程对象，用于移动、复制和转换数据。

1安装程序不为 Reporting Services 扩展部署中的多个节点配置负载平衡和单 URL 寻址。若要完成扩展部署，必须使用 Windows Server、Microsoft Application Center 或第三方群集管理软件。有关 Web 场部署设置的详细信息，请参阅为扩展部署配置 Reporting Services。

2 Reporting Services 的报表设计器组件需要 Microsoft Internet Explorer 6.0 SP 1。

3 Reporting Services 不支持同时在 64 位平台上和 64 位服务器的 32 位子系统 (WOW64) 上进行并行配置。

4安装 SQL Server Management Studio 需要 Internet Explorer 6.0 SP1。

5安装 Business Intelligence Development Studio 需要 Internet Explorer 6.0 SP1。

共享组件目录

由一台计算机上的所有 SQL Server 实例共享的功能安装在一个目录中。其中包括：

  • 客户端工具

  • SQL Server 联机丛书

  • Business Intelligence Development Studio

  • Integration Services

默认情况下，共享组件安装到 %Program Files%Microsoft SQL Server\ 中。若要更改安装路径，请单击“浏览”按钮。如果更改一个共享组件的安装路径，则要同时更改其他共享组件的安装路径。后续安装会将共享组件安装到与原始安装相同的位置。

在基于 x64 的操作系统上，您可以指定 64 位组件的安装位置，以及 32 位组件在 WOW64 子系统上的安装位置。

安装 AdventureWorks 示例数据库

默认情况下，不会将示例数据库和示例代码作为 SQL Server 安装程序的一部分进行安装。若要安装示例数据库和示例代码，请参阅 CodePlex 网站。

安装 SQL Server 2008 后还可以获得有关示例的其他信息。在“开始”菜单中，依次单击“所有程序”、Microsoft SQL Server 2008、“文档和教程”，再单击“Microsoft SQL Server 示例概述”。

请参阅

参考

SQL Server 2008 的版本和组件


功能选择（卸载）

功能选择（卸载） |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“功能选择 - 卸载”页可以选择要从指定的 SQL Server 实例中删除的功能。

选项

可以选择功能的任意组合。

请参阅

任务

如何安装 SQL Server 2008（安装程序）


要升级的功能

要升级的功能 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 2008 安装向导的“要升级的功能”页可以指定要升级至 SQL Server 2008 的功能。

选项

  • 在此版本中无法对要升级的功能进行更改。

请参阅

参考

版本升级

概念

使用升级顾问来准备升级
使用 SQL Server 的多个版本和实例


全文搜索升级选项

全文搜索升级选项 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“全文搜索升级选项”页选择用于此时要升级的数据库的全文搜索升级选项。

在 SQL Server 2005 和早期版本中，每个全文索引都驻留在属于文件组的全文目录中，它们均具有物理路径，并被视为数据库文件。在 SQL Server 2008 中，全文目录是表示一组全文索引的逻辑概念，即虚拟对象。因此，新的全文目录不会被视为带有物理路径的数据库文件。但是，在升级包含数据文件的所有全文目录期间，将在相同磁盘上创建新的文件组。这可以在升级后维护旧磁盘的 I/O 行为。该目录的所有全文索引均被放置到新的文件组中（如果存在根路径）。如果旧的全文目录路径无效，该升级则将全文索引保留在与基表相同的文件组中，或者保留在主文件组中（对于分区表）。

选项

升级到 SQL Server 2008 时，请选择下列全文升级选项之一。

导入

导入全文目录。一般情况下，导入速度比重新生成速度要快很多。例如，当仅使用一个 CPU 时，导入的运行速度比重新生成要快 10 倍左右。不过，导入的全文目录不能使用 SQL Server 2008 中引入的新的和增强的断字符，因此最终可能还是要重新生成全文目录。

注意：
重新生成操作能够以多线程模式运行，如果可用的 CPU 在 10 个以上，且您允许重新生成操作使用所有这些 CPU，则重新生成操作的运行速度可能会比导入更快。

如果全文目录不可用，则会重新生成关联的全文索引。此选项仅对 SQL Server 2005 数据库可用。

有关导入全文索引的影响的信息，请参阅本主题后面的“有关选择全文升级选项的注意事项”。

重新生成

使用新的和增强的断字符重新生成全文目录。重新生成索引可能需要一些时间，且升级后可能需要占用大量的 CPU 和内存。

重置

重置全文目录。将删除 SQL Server 2005 全文目录文件，但会保留全文目录和全文索引的元数据。在进行升级后，所有全文索引将禁用更改跟踪，并且不会自动启动爬网。在升级完成后，目录将保留为空，直至手动执行完全填充。

所有这些升级选项确保升级后的数据库从 SQL Server 2008 的全文性能增强功能中完全受益。

重要提示：
有关在导入 SQL Server 2005 全文索引后使用新的断字符和将干扰词文件升级到非索引字表的信息，请参阅 Full-Text Search Upgrade（全文搜索升级）。

有关选择全文升级选项的注意事项

为升级选择升级选项时，请考虑以下几点：

  • 如何使用断字符？

    SQL Server 2008 全文搜索服务包括新的断字符和词干分析器。这可能更改早期版本中特定文本模式或方案的全文查询结果。因此，在选择适当的升级选项时，如何使用断字符非常重要：

    • 如果使用的全文语言的断字符在 SQL Server 2008 中未发生更改，或者撤回准确性对您来说并不重要，则适合导入。随后，如果遇到任何撤回问题，您只需通过重新生成全文目录即可升级到新的断字符。有关详细信息，请参阅 Full-Text Search Upgrade（全文搜索升级）。

    • 如果您关心撤回准确性，并使用 SQL Server 2008 中经过改进的断字符之一，则适合重新生成。

  • 是否有任何全文索引是基于整数全文键列生成的？

    重新生成执行内部优化，在某些情况下该优化可提高升级的全文索引的查询性能。具体来说，如果您具有的全文目录包含基表的全文键列为整数数据类型的全文索引，则重新生成将在升级后实现全文查询的理想性能。在这种情况下，我们强烈建议使用“重新生成”选项。

    注意：
    对于 SQL Server 2008 中的全文索引，建议采用整数数据类型作为全文键列。有关详细信息，请参阅 Performance Tuning and Optimization (Full-Text Search)（性能优化（全文搜索））。

  • 使服务器实例处于联机状态的优先级是什么？

    升级期间的导入或重新生成操作会占用很多 CPU 资源，这会延迟其余服务器实例的升级和联机。如果使服务器实例尽快处于联机状态非常重要，并且希望在升级后运行手动填充，则适合“重置”。

其他资源

SQL Server 2008 中全文搜索的重大更改

SQL Server 2008 中全文搜索的行为更改

SQL Server 2008 中不推荐使用的数据库引擎功能

查询全文键列

断字符和词干分析器

请参阅

任务

如何安装 SQL Server 2008（安装程序）


安装完成

安装完成 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

单击“关闭”完成安装。

请参阅

参考

SQL Server 2008 的版本和组件

概念

验证 SQL Server 安装
配置 SQL Server 2008


安装必备组件

安装必备组件 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

为了成功安装 SQL Server，安装计算机上需要具有下列软件组件。将由 SQL Server 安装程序安装这些软件组件：

  • 用于 SQL Server Express 和高级 SQL Server Express 的 .NET Framework 3.5 版

  • 适用于 Windows Server 2003（64 位）IA64 SP1 上的 SQL Server 2008 的 .NET Framework 2.0 SP1 版

  • .NET Framework 3.5 版（适用于所有其他版本的 SQL Server 2008）

  • SQL Server 安装程序支持文件

  • SQL Server Native Client

注意：
如果安装失败或被取消，将不会删除这些组件。若要删除它们，请使用“控制面板”中的“添加或删除程序”。

选项

若要安装必备组件文件，请单击“安装”。若要退出安装过程，请单击“取消”。

请参阅

参考

安装 SQL Server 2008 的硬件和软件要求


安装进度

安装进度 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“安装进度”页可以监视 SQL Server 安装程序的状态。

请参阅

概念

如何查看 SQL Server 安装日志文件


安装类型

安装类型 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“安装类型”页可以指定是安装 SQL Server 2008 的新实例还是向现有实例中添加功能。

选项

选择指示您所做选择的单选按钮：

  • 执行 SQL Server 2008 的全新安装

  • 向 SQL Server 2008 的现有实例中添加功能

    如果选择与向现有实例中添加功能相对应的选项，则使用下拉列表选择要升级的 SQL Server 实例。

    注意：
    安装故障转移群集实例之后，不能再向其中添加功能。若要向现有故障转移群集中添加 SQL Server 功能，则必须执行全新安装才能安装单独的 SQL Server 实例。

请参阅

任务

如何安装 SQL Server 2008（安装程序）


实例配置

实例配置 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“实例配置”页面可指定是创建 SQL Server 的默认实例还是其命名实例。如果尚未安装 SQL Server 实例，则除非您指定命名实例，否则将创建默认实例。

每个 SQL Server 实例都由一组在排序规则及其他选项方面具有特定设置的非重复服务组成。目录结构、注册表结构和服务名称均反映了在 SQL Server 安装期间创建的实例名称和特定实例 ID。

实例是默认实例或命名实例。默认实例名称是 MSSQLSERVER；SQL Server Express 的默认实例名称为 SQLExpress。不需要客户端指定实例名称便可进行连接。命名实例在安装过程中由用户决定。您可以将 SQL Server 作为命名实例安装，无需先安装默认实例。默认实例可以是 SQL Server 2000、SQL Server 2005 或 SQL Server 2008 安装。不论版本如何，一次均只能安装一个 SQL Server 默认实例。

多实例

SQL Server 支持在单个服务器或处理器上存在多个 SQL Server 实例，但只能有一个实例为默认实例。所有其他实例必须为命名实例。一台计算机可同时运行多个 SQL Server 实例，每个实例独立于其他实例运行。

有关详细信息，请参阅 SQL Server 的最大容量规范。

选项

仅限故障转移群集实例 - 指定 SQL Server 故障转移群集网络名称。此名称在网络上标识故障转移群集实例。

默认实例或命名实例 - 当决定是安装 SQL Server 的默认实例还是命名实例时，请考虑以下信息：

  • 如果计划在数据库服务器上安装单个 SQL Server 实例，则该实例应为默认实例。

  • 如果计划在同一台计算机上安装多个实例，请使用命名实例。一台服务器只能承载一个默认实例。

  • 任何安装 SQL Server Express 的应用程序都应将其作为命名实例安装。当同一台计算机中安装多个应用程序时，这样可以最大程度地减少冲突。

默认实例

选择该选项可安装 SQL Server 的默认实例。一台计算机只能承载一个默认实例；所有其他实例必须是命名实例。但是，如果您已经安装了 SQL Server 的默认实例，则可以向同一台计算机添加 Analysis Services 的默认实例。

命名实例

选择该选项可创建新的命名实例。当对 SQL Server 实例进行命名时，请注意以下几点：

  • 实例名不区分大小写。

  • 实例名称不能包含词语“Default”或其他保留关键字。如果在实例名中使用了保留关键字，将发生安装错误。有关详细信息，请参阅保留关键字（安装程序）。

  • 如果为实例名称指定 MSSQLServer，将创建默认实例。对于 SQL Server Express，如果为实例名称指定 SQLExpress，将创建默认实例。

  • 实例名限制为 16 个字符。

  • 实例名中的第一个字符必须是字母。可接受的字母为 Unicode 标准 2.0 定义的那些字母。这些字母包括拉丁字符 a-z、A-Z 和其他语言中的字母字符。

  • 后续字符可以是 Unicode 标准 2.0 定义的字母、源于基本拉丁语或其他国家/地区书写符号的十进制数字、美元符号 ($) 或者下划线 (_)。

  • 实例名称中不允许含有空格或其他特殊字符，也不允许存在反斜杠 (\)、逗号 (,)、冒号 (:)、分号 (;)、单引号 (')、and 符 (&) 和 at 符 (@)。

    注意：
    只有在当前 Windows 代码页中有效的字符才能用在 SQL Server 实例名称中。如果使用了不支持的 Unicode 字符，将会发生安装错误。

检测到的实例和功能

查看正在运行 SQL Server 安装程序的计算机中安装的 SQL Server 实例和组件的列表。

实例 ID - 默认情况下，实例名称用作实例 ID。这用于标识 SQL Server 实例的安装目录和注册表项。默认实例和命名实例的默认方式都是如此。对于默认实例，实例名称和实例 ID 为 MSSQLSERVER。若要使用非默认的实例 ID，请在“实例 ID”字段中指定它。

注意：
不支持以下划线 (_) 开头或者包含数字符号 (#) 或美元符号 ($) 的实例 ID。

有关目录、文件位置和实例 ID 命名的详细信息，请参阅 SQL Server 的默认实例和命名实例的文件位置。

实例根目录 - 默认情况下，实例根目录为 C:\Program Files\Microsoft SQL Server\。若要指定非默认的根目录，请单击“浏览”按钮或提供一个路径名。

SQL Server 的给定实例的所有组件作为一个单元进行管理。所有 SQL Server Service Pack 和升级都将应用于 SQL Server 实例的每个组件。

共用同一实例名称的所有 SQL Server 组件都必须满足以下条件：

  • 版本相同

  • 版本类别相同

  • 语言设置相同

  • 聚集状态相同

    注意：
    Reporting Services 不能识别群集。

  • 操作系统相同

请参阅

其他资源

How to: Install SQL Server 2005


实例选择（卸载）

实例选择（卸载） |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在“实例选择 – 卸载”页上，使用下拉框指定要卸载的 SQL Server 实例。

选项

可以指定卸载 SQL Server 的整个实例，也可以指定仅卸载共享功能和管理工具。

请参阅

任务

如何安装 SQL Server 2008（安装程序）


实例选择(升级)

实例选择(升级) |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“实例选择(升级)”页可以指定要升级的 SQL Server 实例。

选项

必须同时升级实例中的所有组件。不能在升级过程中添加或删除功能。

请参阅

任务

如何安装 SQL Server 2008（安装程序）


使 SQL Server 2008 外围应用最小化

使 SQL Server 2008 外围应用最小化 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

减少外围应用是一项安全措施，它涉及停止或禁用未使用的组件。外围应用的减少使得对系统潜在攻击的途径更少，从而有助于提高安全性。

对于新 SQL Server 2008 安装，为了减少 SQL Server 外围应用，将禁用或停止某些功能、服务或连接。对于升级安装，所有功能、服务和连接都保持其升级前的状态。

  • 使用 SQL Server 配置管理器可以启用、禁用、启动或停止服务，并可配置数据库引擎的远程连接。

  • 使用基于策略的管理可以启用和禁用可选功能。

使用 SQL Server 配置管理器

SQL Server 配置管理器会随所有 SQL Server 版本一起安装。

打开 SQL Server 配置管理器

  1. 在“开始”菜单中，依次指向“所有程序”、Microsoft SQL Server 2008、“配置工具”，然后单击“SQL Server 配置管理器”。
将服务配置为自动启动

  1. 在 SQL Server 配置管理器中，展开“SQL Server 服务”。

  2. 在详细信息窗格中，右键单击 SQL Server 服务之一，然后单击“属性”。

  3. 在“属性”对话框中，将“启动模式”设置为“自动”。
将数据库引擎配置为接受远程连接

  1. 在 SQL Server 配置管理器中，展开“SQL Server 网络配置”，然后单击 <实例名称> 的协议。

  2. 在详细信息窗格中，右键单击可用的协议之一，然后单击“属性”。

    注意：
    无法对远程连接启用 Shared Memory 协议。

  3. 若要为远程连接启用协议，请将“启用”框设置为“是”。

有关 SQL Server 配置管理器的帮助信息，请查看 SQL Server 配置管理器帮助文件，或参阅 SQL Server 联机丛书。若要配置 SOAP 和 Service Broker 端点，请使用 CREATE ENDPOINT 和 ALTER ENDPOINT。

使用基于策略的管理

使用 SQL Server Management Studio 可以配置基于策略的管理。如果未安装 Management Studio，请运行安装程序并安装客户端工具。安装 SQL Server Express 时并不会安装 Management Studio。请从 Microsoft.com 下载 Management Studio Express。SQL Server 联机丛书中介绍了基于策略的管理功能。

打开 SQL Server Management Studio

  1. 在“开始”菜单上，指向“所有程序”，再指向 Microsoft SQL Server 2008，然后单击 SQL Server Management Studio。
配置基于策略的管理

  1. 在 Management Studio 中，连接到数据库引擎实例，展开“管理”，然后展开“策略管理”。

  2. 从以下三个方面配置基于策略的管理

    • 外围应用配置器

    • Analysis Services 的外围应用配置器

    • Reporting Services 的外围应用配置器

    不应打开默认情况下处于关闭状态的外围应用配置器功能，除非需要它们处理特定业务。

建议的设置：

  • 数据库引擎的建议设置

    将外围应用配置器方面的所有属性都设置为 false。

  • Analysis Services 的建议设置

    将 Analysis Services 方面的外围应用配置器的所有属性都设置为 false。

  • Reporting Services 的建议设置

    使用 Reporting Services 的外围应用配置器禁用所有不需要的 Reporting Services 功能。

请参阅

其他资源

了解外围应用配置器


卸载后

卸载后 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“卸载后”页可以验证操作是否已成功完成。

选项

请参阅

任务

如何安装 SQL Server 2008（安装程序）


产品密钥

产品密钥 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“产品密钥”页可以验证 SQL Server 2008 的实例或者指定安装哪个免费版本的 SQL Server 2008。

选项

若要指定 SQL Server 2008 的免费版本，请选择与免费安装相对应的单选按钮，然后使用下拉框来确定要安装的版本。

若要验证 SQL Server 2008 的付费安装，请选择与“产品密钥”相对应的单选按钮，然后在提供的空间中提供密钥。

对于故障转移群集安装，请对所有故障转移群集节点使用相同的产品密钥。如果产品密钥来自另一个版本的 SQL Server，将发生错误。

请参阅

任务

如何安装 SQL Server 2008（安装程序）


进度(卸载)

进度(卸载) |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“进度(卸载)”页可以监视安装进度。

请参阅

任务

如何安装 SQL Server 2008（安装程序）

概念

如何查看 SQL Server 安装日志文件


准备安装

准备安装 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

“准备安装”页上有通过 SQL Server 安装程序要安装或更改的功能的摘要。

选项

此页上有下列选项：

  • 若要继续安装，请单击“安装”。

  • 若要更改安装设置，请单击“上一步”。

  • 若要退出安装程序，请单击“取消”。

请参阅

任务

如何阅读 SQL Server 安装日志文件

概念

如何查看 SQL Server 安装日志文件


恢复方法

恢复方法
SQL Server 安装程序的用户界面参考 >

进行选择，然后单击“下一步”继续。


删除 SQL Server 故障转移群集节点

删除 SQL Server 故障转移群集节点 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“故障转移群集节点”页可识别要作为 SQL Server 2008 故障转移群集节点删除的计算机。

请参阅

任务

如何安装 SQL Server 2008（安装程序）


报表服务器安装选项

报表服务器安装选项 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 Microsoft SQL Server 安装向导中的“报表服务器安装选项”页来指定确定报表服务器实例安装方式的选项。安装选项的可用性取决于是否在安装报表服务器的同时还安装 SQL Server 数据库引擎的本地实例以及是否其他默认值都可用。

如果安装程序由于一条或多条要求未得到满足而无法执行默认的报表服务器配置，那么安装向导只允许选择最小化安装选项；同时，它会复制所需的文件，但要求在安装结束后，使用 Reporting Services 配置工具来配置报表服务器。

在某些情况下，如果安全套接字层 (SSL) 证书安装在计算机上并绑定到一个强通配符，安装程序将使用 HTTPS 前缀创建 Reporting Services URL。有关如何将证书映射到 Reporting Services URL 的详细信息，请参阅 SQL Server 联机丛书中的配置报表服务器用于安全套接字层 (SSL) 连接。

注意：
如果选择默认安装选项之一，则现有的报表服务器数据库文件可能会导致安装失败。当选择默认安装选项时，安装程序将尝试使用默认名称创建报表服务器数据库。如果使用该名称的数据库已经存在，安装程序将失败，您必须回滚安装。若要避免此问题，可在运行安装程序前重命名现有数据库，或选择“安装但不配置服务器”选项，以便在安装完成后指定自定义数据库设置。

选项

安装本机模式默认配置

用报表服务器数据库、服务帐户和 URL 保留的默认值安装报表服务器实例。如果选择此选项，那么当安装程序完成后，报表服务器实例即可使用。安装程序通过使用本地数据库引擎实例来创建报表服务器数据库，并配置报表服务器，使其使用默认值。

仅当报表服务器安装中使用的默认值对您的系统有效时，此选项才可用。建议希望在本地安装所有组件的开发人员和评估软件的用户使用此选项。

若要查看关于安装程序所用默认设置的信息，或者要找出默认配置无法安装的原因，请单击“详细信息”。有关本机模式报表服务器的默认配置的详细信息，请参阅本机模式安装默认配置 (Reporting Services)。

安装 SharePoint 集成模式默认配置

用报表服务器数据库、服务帐户和 URL 保留的默认值安装报表服务器实例。报表服务器数据库是以支持 SharePoint 站点的内容存储和寻址的格式创建的。

有关此安装选项的详细信息，请参阅 SharePoint 集成模式默认配置 (Reporting Services)。

安装但不配置服务器

安装报表服务器程序文件，创建报表服务器服务帐户，并注册报表服务器 Windows Management Instrumentation (WMI) 提供程序。此安装选项称为“仅文件”安装。如果不希望使用默认配置，则选择此选项。如果无法安装默认配置，或安装的是包括 Reporting Services 的 SQL Server 故障转移群集，这将是唯一可用的选项。有关“仅文件”安装的详细信息，请参阅“仅文件”安装 (Reporting Services)。

安装程序完成后，必须先创建报表服务器数据库并配置报表服务器，服务器才可以使用。若要配置报表服务器并创建数据库，请使用 Reporting Services 配置工具。有关详细信息，请参阅创建报表服务器数据库和配置报表服务器数据库连接。

安装用于 SharePoint 技术的 Reporting Services 外接程序

若要安装用于 SharePoint 技术的 Reporting Services 外接程序，请在 SQL Server 安装完成后单击 SQL Server 2008 安装媒体上 Setup 文件夹中的 rsSharePoint.msi 文件。

请参阅

任务

如何启动 Reporting Services 配置
如何创建报表服务器数据库（Reporting Services 配置）

概念

安装 Reporting Services 的注意事项
本机模式安装默认配置 (Reporting Services)


保留关键字（安装程序）

保留关键字（安装程序） |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

SQL Server 使用保留关键字来定义、操作和添加数据库。保留关键字是 SQL Server 用于分析和理解 Transact-SQL 语句和批处理的 Transact-SQL 语法的组成部分。

SQL Server 实例名不能与保留关键字匹配。请参照下表以确保在 SQL Server 实例名中未使用保留关键字。

ADD | EXCEPT | PERCENT
ALL | EXEC | PLAN
ALTER | EXECUTE | PRECISION
AND | EXISTS | PRIMARY
ANY | EXIT | PRINT
AS | FETCH | PROC
ASC | FILE | PROCEDURE
AUTHORIZATION | FILLFACTOR | PUBLIC
BACKUP | FOR | RAISERROR
BEGIN | FOREIGN | READ
BETWEEN | FREETEXT | READTEXT
BREAK | FREETEXTTABLE | RECONFIGURE
BROWSE | FROM | REFERENCES
BULK | FULL | REPLICATION
BY | FUNCTION | RESTORE
CASCADE | GOTO | RESTRICT
CASE | GRANT | RETURN
CHECK | GROUP | REVOKE
CHECKPOINT | HAVING | RIGHT
CLOSE | HOLDLOCK | ROLLBACK
CLUSTERED | IDENTITY | ROWCOUNT
COALESCE | IDENTITY_INSERT | ROWGUIDCOL
COLLATE | IDENTITYCOL | RULE
COLUMN | IF | SAVE
COMMIT | IN | SCHEMA
COMPUTE | INDEX | SELECT
CONSTRAINT | INNER | SESSION_USER
CONTAINS | INSERT | SET
CONTAINSTABLE | INTERSECT | SETUSER
CONTINUE | INTO | SHUTDOWN
CONVERT | IS | SOME
CREATE | JOIN | STATISTICS
CROSS | KEY | SYSTEM_USER
CURRENT | KILL | TABLE
CURRENT_DATE | LEFT | TEXTSIZE
CURRENT_TIME | LIKE | THEN
CURRENT_TIMESTAMP | LINENO | TO
CURRENT_USER | LOAD | TOP
CURSOR | NATIONAL | TRAN
DATABASE | NOCHECK | TRANSACTION
DBCC | NONCLUSTERED | TRIGGER
DEALLOCATE | NOT | TRUNCATE
DECLARE | NULL | TSEQUAL
DEFAULT | NULLIF | UNION
DELETE | OF | UNIQUE
DENY | OFF | UPDATE
DESC | OFFSETS | UPDATETEXT
DISK | ON | USE
DISTINCT | OPEN | USER
DISTRIBUTED | OPENDATASOURCE | VALUES
DOUBLE | OPENQUERY | VARYING
DROP | OPENROWSET | VIEW
DUMMY | OPENXML | WAITFOR
DUMP | OPTION | WHEN
ELSE | OR | WHERE
END | ORDER | WHILE
ERRLVL | OUTER | WITH
ESCAPE | OVER | WRITETEXT

此外，ISO 标准定义了保留关键字的列表。不要使用 ISO 保留关键字作为对象名和标识符。ODBC 保留关键字列表（如下表所示）与 ISO 保留关键字列表相同。

注意：
ISO 保留关键字列表有时会比 SQL Server 具有更多的限制，有时则更少。例如，ISO 保留关键字列表包含 INT。SQL Server 不将 INT 视为保留关键字。

ODBC 保留关键字

保留了下列关键字用于 ODBC 函数调用。这些单词不限定最小 SQL 语法。但是，为确保与支持核心 SQL 语法的驱动程序兼容，请避免在 SQL Server 实例名中使用这些关键字。

ABSOLUTE | EXEC | OVERLAPS
ACTION | EXECUTE | PAD
ADA | EXISTS | PARTIAL
ADD | EXTERNAL | PASCAL
ALL | EXTRACT | POSITION
ALLOCATE | FALSE | PRECISION
ALTER | FETCH | PREPARE
AND | FIRST | PRESERVE
ANY | FLOAT | PRIMARY
ARE | FOR | PRIOR
AS | FOREIGN | PRIVILEGES
ASC | FORTRAN | PROCEDURE
ASSERTION | FOUND | PUBLIC
AT | FROM | READ
AUTHORIZATION | FULL | REAL
AVG | GET | REFERENCES
BEGIN | GLOBAL | RELATIVE
BETWEEN | GO | RESTRICT
BIT | GOTO | REVOKE
BIT_LENGTH | GRANT | RIGHT
BOTH | GROUP | ROLLBACK
BY | HAVING | ROWS
CASCADE | HOUR | SCHEMA
CASCADED | IDENTITY | SCROLL
CASE | IMMEDIATE | SECOND
CAST | IN | SECTION
CATALOG | INCLUDE | SELECT
CHAR | INDEX | SESSION
CHAR_LENGTH | INDICATOR | SESSION_USER
CHARACTER | INITIALLY | SET
CHARACTER_LENGTH | INNER | SIZE
CHECK | INPUT | SMALLINT
CLOSE | INSENSITIVE | SOME
COALESCE | INSERT | SPACE
COLLATE | INT | SQL
COLLATION | INTEGER | SQLCA
COLUMN | INTERSECT | SQLCODE
COMMIT | INTERVAL | SQLERROR
CONNECT | INTO | SQLSTATE
CONNECTION | IS | SQLWARNING
CONSTRAINT | ISOLATION | SUBSTRING
CONSTRAINTS | JOIN | SUM
CONTINUE | KEY | SYSTEM_USER
CONVERT | LANGUAGE | TABLE
CORRESPONDING | LAST | TEMPORARY
COUNT | LEADING | THEN
CREATE | LEFT | TIME
CROSS | LEVEL | TIMESTAMP
CURRENT | LIKE | TIMEZONE_HOUR
CURRENT_DATE | LOCAL | TIMEZONE_MINUTE
CURRENT_TIME | LOWER | TO
CURRENT_TIMESTAMP | MATCH | TRAILING
CURRENT_USER | MAX | TRANSACTION
CURSOR | MIN | TRANSLATE
DATE | MINUTE | TRANSLATION
DAY | MODULE | TRIM
DEALLOCATE | MONTH | TRUE
DEC | NAMES | UNION
DECIMAL | NATIONAL | UNIQUE
DECLARE | NATURAL | UNKNOWN
DEFAULT | NCHAR | UPDATE
DEFERRABLE | NEXT | UPPER
DEFERRED | NO | USAGE
DELETE | NONE | USER
DESC | NOT | USING
DESCRIBE | NULL | VALUE
DESCRIPTOR | NULLIF | VALUES
DIAGNOSTICS | NUMERIC | VARCHAR
DISCONNECT | OCTET_LENGTH | VARYING
DISTINCT | OF | VIEW
DOMAIN | ON | WHEN
DOUBLE | ONLY | WHENEVER
DROP | OPEN | WHERE
ELSE | OPTION | WITH
END | OR | WORK
END-EXEC | ORDER | WRITE
ESCAPE | OUTER | YEAR
EXCEPT | OUTPUT | ZONE
EXCEPTION |  |

请参阅

任务

如何安装 SQL Server 2008（安装程序）


选择实例

选择实例 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“选择实例”页可以为该操作指定 SQL Server 实例。

选项

使用单选按钮指定是要升级 SQL Server 实例及其共享组件，还是只升级共享组件。此 SQL Server 版本中的共享组件包括：

  • Integration Services

  • SQL Server Browser

  • SQL Server Active Directory Helper

  • SQL 编写器

有关支持的升级方案和已知升级问题的信息，请参阅版本升级。

请参阅

概念

使用升级顾问来准备升级
使用 SQL Server 的多个版本和实例


SQL Server 配置 - 排序规则

SQL Server 配置 - 排序规则 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

可以在 SQL Server 安装向导的“服务器配置 – 排序规则”页上修改数据库引擎和 Analysis Services 排序时所用的排序规则设置。选择相应选项以匹配其他 SQL Server 安装或者其他计算机的排序规则设置。

选项

为 SQL Server 和 Analysis Services 进行自定义

SQL Server 提供了两组排序规则：Windows 排序规则和 SQL Server 排序规则。您可以为数据库引擎和 Analysis Services 指定不同的排序规则设置，也可以为它们指定相同的排序规则。

默认情况下，对于美国英语系统区域设置，选择的是 SQL Server 排序规则。SQL Server 本地化版本的默认排序规则由您计算机的 Windows 系统区域设置决定。有关详细信息，请参阅使用 SQL Server 排序规则。

仅当此 SQL Server 安装的排序规则设置必须与另一 SQL Server 实例所用的排序规则设置相匹配，或者必须与另一台计算机的 Windows 系统区域设置相匹配时，才应更改默认设置。

注意：Analysis Services仅使用 Windows 排序规则。如果计划安装 Analysis Services，请在 SQL Server 安装期间，选择 Windows 排序规则，以确保 SQL Server 数据库引擎和 Analysis Services 之间结果的一致性。

有关详细信息，请参阅安装程序中的排序规则设置。

最佳实践

有关 SQL Server 安装程序使用的 Windows 系统区域设置以及相应的默认排序规则的表，请参阅安装程序中的排序规则设置。

如果可能，请为您的组织使用一个排序规则。这样就不必为每个数据库、列、表达式或标识符显式指定排序规则。如果必须使用多个排序规则和代码页设置，请对查询进行编码，以考虑排序规则优先顺序规则。有关详细信息，请参阅联机丛书主题 Collation Precedence (Transact-SQL)（排序规则优先顺序 (Transact-SQL)）。

为 SQL Server 选择排序规则时，请考虑下列建议：

  • 如果二进制顺序可接受，请选择二进制排序规则。

  • 如果应用程序同时使用 nchar/nvarchar 和 char/varchar 数据类型并且会在比较中混合使用它们，请选择 Windows 排序规则以便在各数据类型之间进行一致的比较。

  • 如果应用程序只使用 char/varchar 数据类型，并且您使用 Analysis Services，请选择 Windows 排序规则。

  • 如果应用程序只使用 char/varchar 数据类型，且下列情况属实，请选择 SQL Server 排序规则：

    • 您关心字符串比较/LIKE 的性能。

    • 您不关心 Windows 排序规则中的语言比较语义。

    • 您需要 SQL Server 排序规则中的字典排序顺序。

    • 您不关心与操作系统或其他应用程序的排序一致性。

请参阅

参考

排序规则和 Unicode 支持
安装程序中的排序规则设置


SQL Server 配置 - 服务帐户

SQL Server 配置 - 服务帐户 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用 SQL Server 安装向导的“服务器配置”页可以为 SQL Server 服务分配登录帐户。此页上配置的实际服务取决于您选择安装的功能。

选项

可以为所有的 SQL Server 服务分配相同的登录帐户，也可以分别配置各个服务帐户。还可以指定服务是自动启动、手动启动还是禁用的。Microsoft 建议您对各个服务帐户进行单独配置，以确保向 SQL Server 服务授予它们完成各自任务所需的最小权限。有关详细信息，请参阅设置 Windows 服务帐户。

单独配置 SQL Server 服务帐户(建议)

使用网格为每项 SQL Server 服务设置一个登录用户名和密码并设置相应服务的启动类型。您可以对 SQL Server 服务使用内置系统帐户、本地帐户、本地组、域组或域用户帐户。

对于故障转移群集安装，将基于为活动节点提供的设置，在此页上预填充帐户名和启动类型信息。必须为每个帐户提供密码。

选择下列任一服务以自定义其设置。

选择此服务 为其配置身份验证设置的主体

SQL Server Agent

运行作业、监视 SQL Server 并可自动处理管理任务的服务。

此服务没有默认登录帐户。

默认的启动类型为“手动”。

SQL Server

SQL Server 数据库引擎。

此服务没有默认登录帐户。

默认的启动类型为“自动”。

SQL Server Browser

SQL Server Browser 是向客户端计算机提供 SQL Server 连接信息的名称解析服务。多个 SQL Server 和 Integration Services 实例共享此服务。

默认登录帐户为 NT Authority\Local service 且无法更改。

默认的启动类型为“自动”。

Analysis Services

Analysis Services。

此服务没有默认登录帐户。

默认的启动类型为“自动”。

Reporting Services

Reporting Services。

服务帐户用于配置报表服务器数据库连接。如果要使用默认的身份验证设置，请选择内置的网络服务。如果指定域用户帐户，并且要在报表服务器上使用 Windows 身份验证，请确保为该帐户注册一个服务主体名称 (SPN)。有关详细信息，请参阅如何在 Reporting Services 中配置 Windows 身份验证。

重要提示：
Microsoft 建议，如果有具有较低特权的帐户可供使用，则不要对 SQL Server 或 SQL Server Agent 服务使用 Network Service 帐户，因为 Network Service 是可共享帐户。只有能够确保计算机上未安装使用 Network Service 帐户的其他服务时，该 Network Service 帐户才适合用作 SQL Server 服务帐户。非 Windows 管理员的 Local User 帐户或 Domain User 帐户更适用于 SQL Server 服务。

此服务没有默认登录帐户。

默认的启动类型为“自动”。

Integration Services

Integration Services 是一组图形工具和可编程对象，用于移动、复制和转换数据。

此服务的默认登录帐户为 NT Authority\Network Service。

默认的启动类型为“自动”。

SQL 全文筛选器后台程序启动器

创建 fdhost.exe 进程的服务。需要使用此服务来承载为全文索引处理文本数据的断字符和筛选器。

提供运行 FDHOST 启动器服务的帐户。强烈建议您使用低特权帐户。此帐户应该不同于用于 SQL Server 服务的帐户。在 Windows Vista 和 Windows Server 2008 上，FDHOST 启动器服务帐户默认为 LOCAL SERVICE。

出于安全起见，在早于 Windows Vista 和 Windows Server 2008 的 Windows 版本上，建议您使用专门创建的 LOCAL USER 作为 FDHOST 启动器服务帐户。使用 LOCAL SYSTEM、LOCAL SERVICE 或 NETWORK SERVICE 可能会在无意中为服务提供提升的特权，从而降低 SQL Server 安装的安全性。

除非服务帐户无效或您未指定服务帐户（在 Windows Server 2003 或 Windows XP 上），否则 FDHOST 启动器服务会自动启动。

请参阅

参考

设置 Windows 服务帐户

概念

安装 SQL Server 的安全注意事项


SQL Server 故障转移群集向导 - 完成

SQL Server 故障转移群集向导 - 完成 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会使用以下规则验证您的计算机配置。

检查项 | 说明 | 用户操作
SSMS_IsInternetConnected | 确保计算机已连接到 Internet。如果启动某个 .NET Framework 应用程序（如 Microsoft Management Studio），则在 .NET Framework 安全检查功能验证证书时可能会稍有延迟。 | 请确保计算机已连接到 Internet。
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致。 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级。
BlockMixedArchitectureUpgrade | 检查尝试升级的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 安装或升级时所使用的 SQL Server 安装媒体必须与要修改的 SQL Server 实例具有相同的体系结构。
Cluster_IsOnlineIfClustered | 确认计算机未群集化，或者计算机已群集化且群集服务联机。 | 要么计算机未群集化，要么群集已启动且联机。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 安装在域控制器上。 | 确保此计算机不是域控制器。请参阅安装 SQL Server 的安全注意事项。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是某些 SQL Server 2008 版本的必备组件。 | 对于 SQL Server 2008 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定此操作系统平台是否支持 SQL Server 安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。请参阅安装 SQL Server 2008 的硬件和软件要求。
FusionRebootCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 在安装 SQL Server 之前，必须重新启动计算机。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 安装在其他计算机上。

请参阅

任务

如何安装 SQL Server 2008（安装程序）

参考

系统配置检查器的检查参数


SQL Server 故障转移群集向导 - 安装

SQL Server 故障转移群集向导 - 安装 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会使用以下规则验证您的计算机配置。

检查项 | 说明 | 用户操作
SSMS_IsInternetConnected | 确保计算机已连接到 Internet。如果启动某个 .NET Framework 应用程序（如 Microsoft Management Studio），则在 .NET Framework 安全检查功能验证证书时可能会稍有延迟。 | 请确保计算机已连接到 Internet。
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致。 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级。
BlockMixedArchitectureUpgrade | 检查尝试升级的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 安装或升级时所使用的 SQL Server 安装媒体必须与要修改的 SQL Server 实例具有相同的体系结构。
Cluster_IsOnlineIfClustered | 确认计算机未群集化，或者计算机已群集化且群集服务联机。 | 要么计算机未群集化，要么群集已启动且已联机。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 安装在域控制器上。 | 确保此计算机不是域控制器。请参阅安装 SQL Server 的安全注意事项。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是某些 SQL Server 2008 版本的必备组件。 | 对于 SQL Server 2008 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定此操作系统平台是否支持 SQL Server 安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。请参阅安装 SQL Server 2008 的硬件和软件要求。
FusionRebootCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 在安装 SQL Server 之前，必须重新启动计算机。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 安装到其他计算机上。

请参阅

任务

如何安装 SQL Server 2008（安装程序）

参考

系统配置检查器的检查参数


SQL Server 故障转移群集向导 – 准备

SQL Server 故障转移群集向导 – 准备 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会使用以下规则验证您的计算机配置。

检查项 | 说明 | 用户操作
SSMS_IsInternetConnected | 确认计算机已连接到 Internet。如果启动某个 .NET Framework 应用程序（如 Microsoft Management Studio），则在 .NET Framework 安全检查功能验证证书时可能会稍有延迟。 | 请确保计算机已连接到 Internet。
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致。 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级。
BlockMixedArchitectureUpgrade | 检查尝试升级的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 安装或升级时所使用的 SQL Server 安装媒体必须与要修改的 SQL Server 实例具有相同的体系结构。
Cluster_IsOnlineIfClustered | 确认计算机未群集化，或者计算机已群集化且群集服务已联机。 | 要么计算机未群集化，要么群集已启动且联机。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 安装在域控制器上。 | 确保此计算机不是域控制器。请参阅安装 SQL Server 的安全注意事项。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是某些 SQL Server 2008 版本的必备组件。 | 对于 SQL Server 2008 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定此操作系统平台是否支持 SQL Server 安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。请参阅安装 SQL Server 2008 的硬件和软件要求。
FusionRebootCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 在安装 SQL Server 之前，必须重新启动计算机。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 安装到其他计算机上。

请参阅

任务

如何安装 SQL Server 2008（安装程序）

参考

系统配置检查器的检查参数


摘要（升级）

摘要（升级） |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

使用“摘要”页可以查看为该升级指定的选项。

请参阅

任务

如何安装 SQL Server 2008（安装程序）


系统配置检查 (SCC)

系统配置检查 (SCC) |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

SQL Server 安装向导的“系统配置检查”页显示了系统验证工具的进度。系统配置检查例程会扫描将安装 SQL Server 的计算机，以检查是否存在可能阻止安装程序运行的情况。

选项

仅当所有检查结果都成功，或失败的检查项不会妨碍安装时，“下一步”按钮才可用。

使用“显示详细信息”按钮可显示规则和扫描结果的摘要。扫描结果右侧的“状态”列显示了每一项的状态。单击某个项的状态可查看其详细信息。

下表描述了 SCC 的检查参数、要求和妨碍性问题的解决办法。

检查项 | 说明 | 用户操作
RebootRequiredCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 需要计算机重新启动。安装 SQL Server 之前，必须重新启动计算机。
OsVersionCheck | 检查计算机是否满足最低操作系统版本要求。 | 确保操作系统版本满足此产品的最低要求。请参阅安装 SQL Server 2008 的硬件和软件要求。
ThreadHasAdminPrivilegeCheck | 检查运行 SQL Server 安装程序的帐户是否具有计算机的管理员权限。 | 请确保运行 SQL Server 安装程序的帐户具有计算机的管理权限。
WmiServiceStateCheck | 检查是否已在计算机上启动并正在运行 WMI 服务。 | 请确保 Windows Management Instrumentation (WMI) 服务正在运行。
SSMS_IsInternetConnected | 检查计算机是否已连接到 Internet。基于 .NET Framework 技术的 SQL Server 管理工具必须在启动时检查证书吊销列表。 | 请确保计算机已连接到 Internet。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 安装在域控制器上。 | 确保此计算机不是域控制器。请参阅安装 SQL Server 的安全注意事项。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是 SQL Server 2008 Express with Advanced Services 的必备组件。 | 对于 Microsoft SQL Server 2008 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定操作系统平台是否支持该安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。请参阅安装 SQL Server 2008 的硬件和软件要求。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。 | 删除 SQL Server 7.0 或将 SQL Server 2008 安装在其他计算机上。

其他规则主题

有关应用场景特定的安装规则，请参阅以下主题：

  • 功能安装规则

  • 升级和修复规则检查

  • 版本升级规则

  • 卸载规则

请参阅

任务

如何安装 SQL Server 2008（安装程序）

参考

系统配置检查器的检查参数
安装 SQL Server 2008 的硬件和软件要求


卸载规则

卸载规则 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

“卸载规则”页将运行一组规则来确保可以成功完成安装操作。

选项

下表描述了系统配置检查器的检查参数、要求和妨碍性问题的解决办法：

检查项 | 说明 | 用户操作
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致。 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级。
OsVersionCheck | 检查计算机是否满足最低操作系统版本要求。 | 确保操作系统版本满足此产品的最低要求。
RebootRequiredCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 需要计算机重新启动。安装 SQL Server 之前，必须重新启动计算机。
ThreadHasAdminPrivilegeCheck | 检查运行 SQL Server 安装程序的帐户是否具有计算机的管理权限。 | 请确保运行 SQL Server 安装程序的帐户具有计算机的管理权限。
WmiServiceStateCheck | 检查是否已在计算机上启动并正在运行 WMI 服务。 | 请确保 WMI 服务正在运行。
BlockMismatchedArchitectureUninstall | 检查尝试删除的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 安装程序必须与要卸载的 SQL Server 实例具有相同的体系结构。

其他规则主题

有关应用场景特定的安装规则，请参阅以下主题：

  • 功能安装规则

  • 升级和修复规则检查

  • 版本升级规则

  • 卸载规则

请参阅

任务

如何安装 SQL Server 2008（安装程序）

参考

系统配置检查器的检查参数
安装 SQL Server 2008 的硬件和软件要求


升级和修复规则检查

升级和修复规则检查 |
 | 请参阅
SQL Server 安装程序的用户界面参考 >

在安装操作完成之前，SQL Server 安装程序会使用以下规则验证您的计算机配置。

检查项 | 说明 | 用户操作
SSMS_IsInternetConnected | 确保计算机已连接到 Internet。如果启动某个 .NET Framework 应用程序（如 Microsoft Management Studio），则在 .NET Framework 安全检查功能验证证书时可能会稍有延迟。 | 请确保计算机已连接到 Internet。
AclPermissionsFacet | 检查 SQL Server 注册表项是否一致。 | SQL Server 注册表项必须保持一致，才能支持 SQL Server 安装或升级。
BlockMixedArchitectureUpgrade | 检查尝试升级的功能的 CPU 体系结构是否与此安装程序的 CPU 体系结构不同。 | 安装或升级时所使用的 SQL Server 安装媒体必须与要修改的 SQL Server 实例具有相同的体系结构。
Cluster_IsOnlineIfClustered | 确认计算机未群集化，或者计算机已群集化且群集服务联机。 | 要么计算机未群集化，要么群集已启动且联机。
FacetDomainControllerCheck | 检查计算机是否为域控制器。建议不要将 SQL Server 2008 安装在域控制器上。 | 确保此计算机不是域控制器。请参阅安装 SQL Server 的安全注意事项。
FacetPowerShellCheck | 检查是否安装了 Windows PowerShell。Windows PowerShell 是某些 SQL Server 2008 版本的必备组件。 | 对于 SQL Server 2008 Express with Advanced Services 安装，请确保已经安装了 Windows PowerShell。
FacetWOW64PlatformCheck | 确定此操作系统平台是否支持 SQL Server 安装程序。 | 此规则将阻止在 64 位平台上进行不受支持的安装。请参阅安装 SQL Server 2008 的硬件和软件要求。
FusionRebootCheck | 检查是否需要挂起计算机重新启动。挂起重新启动会导致安装程序失败。 | 需要计算机重新启动。安装 SQL Server 之前，必须重新启动计算机。
PerfMonCounterNotCorruptedCheck | 检查现有性能计数器注册表配置单元是否一致。 | 请确保该性能计数器注册表配置单元一致。
SqlUnsupportedProductBlocker | 检查是否安装了 SQL Server 7.0 或 SQL Server 7.0 OLAP 服务。SQL Server 2008 不支持与 SQL Server 7.0 并行安装。 | 删除 SQL Server 7.0 或将 SQL Server 2008 安装在其他计算机上。

请参阅

参考

系统配置检查器的检查参数


确认卸载选项

确认卸载选项
SQL Server 安装程序的用户界面参考 >

确认您的选择，然后单击“下一步”继续。


在安装程序完成联机丛书的安装之前，您无法搜索所需的主题

在安装程序完成联机丛书的安装之前，您无法搜索所需的主题

安装程序完成之后，您可以通过以下方法查看 SQL Server 的文档：单击“帮助”；在对话框或界面元素中按 F1 键；或者从“开始”菜单中依次指向“所有程序”、Microsoft SQL Server、“文档和教程”，然后单击“SQL Server 联机丛书”。