配置 Reporting Services

SQL Server 2008 R2 Reporting Services 配置管理器帮助
配置 Reporting Services

使用 Reporting Services 配置工具可对 SQL Server Reporting Services 安装进行配置。如果使用仅安装文件选项安装报表服务器，必须使用此工具来配置服务器，否则服务器将不可用。如果以前安装报表服务器时使用的是默认配置安装选项，则可以使用此工具来验证或修改在安装过程中指定的设置。如果从以前的版本升级，可以使用此工具将报表服务器数据库升级为新格式。有关配置 Reporting Services 时的部署注意事项和选项的详细信息，请参阅 SQL Server 联机丛书中的部署（本机模式下的 Reporting Services）和部署（SharePoint 集成模式下的 Reporting Services）部分。

Reporting Services 配置工具可以用来配置本地或远程报表服务器实例。您必须对承载要配置的报表服务器的计算机具有本地系统管理员权限。

本节涉及的主题

配置报表服务器服务帐户

提供有关如何修改服务帐户和密码的建议和步骤。

配置报表服务器 URL

介绍如何配置用来访问报表服务器 Web 服务和报表管理器的 URL。

创建报表服务器数据库

介绍如何创建存储服务器元数据和对象所必需的报表服务器数据库。

配置报表服务器数据库连接

介绍如何修改报表服务器用来连接报表服务器数据库的连接字符串。

配置无人参与的执行帐户

介绍如何配置用户帐户以便以无人参与的方式处理报表。

配置报表服务器以进行电子邮件传递

介绍如何配置报表服务器，以便通过电子邮件来分发报表。

为扩展部署配置 Reporting Services

提供有关配置多个报表服务器实例以使用共享报表服务器数据库的信息。

将 Reporting Services 配置为 SharePoint 2010 集成模式

概要介绍向 SharePoint 产品或技术的现有部署添加报表服务器的任务及要求

配置和管理加密密钥

介绍如何使用和管理存储敏感数据时使用的加密密钥。

Reporting Services 配置操作指南主题

提供常见任务的分步说明。

Reporting Services 配置 F1 帮助主题

提供有关 Reporting Services 配置工具页面的帮助主题。

在 SQL Server 联机丛书中

Reporting Services 配置工具的联机帮助只是 SQL Server Reporting Services 产品文档的一部分。您可在 SQL Server 联机丛书中找到完整的产品文档。

当使用 SQL Server 联机丛书时，可以访问此联机帮助系统提供的所有主题，以及关于部署、管理和保护 Reporting Services 安装的其他内容。有关详细信息，请参阅 SQL Server 联机丛书中的 SQL Server 联机丛书入门。


配置报表服务器服务帐户

配置报表服务器服务帐户 |
 | 请参阅
配置 Reporting Services >

Reporting Services 是作为单个服务实现的，其中包含报表服务器 Web 服务、报表管理器以及用于计划的报告处理和订阅传递的后台处理应用程序。本主题说明最初如何配置服务帐户以及如何使用 Reporting Services 配置工具修改帐户或密码。有关在服务中运行的应用程序的详细信息，请参阅 SQL Server 联机丛书中的服务体系结构 (Reporting Services)。

初始配置

报表服务器服务帐户是在安装过程中定义的。可以在域用户帐户或内置帐户（如 NetworkService 帐户）下运行服务。没有默认帐户；您在安装向导的 服务器配置 - 服务帐户页中指定的任何帐户都将成为报表服务器服务的初始帐户。

重要提示：
尽管报表服务器 Web 服务和报表管理器均为 ASP.NET 应用程序，但它们不在 ASP.NET 帐户下运行。由单个服务体系结构在同一个报表服务器进程标识下运行这两个 ASP.NET 应用程序。与先前版本相比，这是一个重大的更改，在先前版本中，报表服务器 Web 服务和报表管理器均在 IIS 中指定的 ASP.NET 辅助进程标识下运行。

更改服务帐户

若要查看和重新配置服务帐户信息，请始终使用 Reporting Services 配置工具。服务标识信息在内部存储在多个位置上。使用该工具可确保在更改帐户或密码的同时相应地更新所有引用。Reporting Services 配置工具将执行以下附加步骤以确保报表服务器仍然可用：

  • 自动将新帐户添加到本地计算机上创建的报表服务器组中。此组是在用于保护 Reporting Services 文件的访问控制列表 (ACL) 中指定的。

  • 自动更新用于承载报表服务器数据库的 SQL Server 数据库引擎实例的登录权限。新帐户将添加到 RSExecRole。

    旧帐户的数据库登录名不会被自动删除。请务必删除不再使用的帐户。有关详细信息，请参阅 SQL Server 联机丛书中的管理报表服务器数据库。

    只有在首先将报表服务器数据库连接配置为使用新服务帐户的情况下，才需要将数据库权限授予该服务帐户。如果将报表服务器数据库连接配置为使用域用户帐户或 SQL Server 数据库登录名，连接信息将不受服务帐户更新的影响。

  • 自动更新加密密钥，以包括新帐户的配置文件信息。

    注意：
    如果报表服务器是扩展部署的一部分，则只有正在更新的报表服务器会受到影响。该部署中的其他报表服务器的加密密钥不会受到服务帐户更改的影响。

有关如何设置帐户的说明，请参阅如何为 Reporting Services 配置服务帐户。

选择帐户

可以将报表服务器服务配置为在以下任何帐户类型下运行：

  • 具有最小权限的 Windows 用户帐户

  • NetworkService

  • LocalSystem

  • LocalService

没有用来选择帐户类型的唯一最佳方法。每个帐户都有优点和缺点，选择时必须予以考虑。如果在生产服务器上部署 Reporting Services，则最好将服务配置为在域用户帐户下运行，以避免共享帐户遭恶意用户破坏后造成大范围的损害。这样做还能更轻松地审核该帐户的登录活动。使用 Windows 用户帐户的折中方案为：如果在使用 Kerberos 身份验证的网络中部署 Reporting Services，则必须用该用户帐户来注册服务。有关详细信息，请参阅如何为报表服务器注册服务主体名称 (SPN)。

本部分中的下列指南和链接可以帮助您确定部署的最佳方法。

  • 服务帐户（Reporting Services 配置）.

  • SQL Server 联机丛书中的设置 Windows 服务帐户。

  • 服务和服务帐户安全计划指南（位于 MSDN 上）。

更新过期密码

如果报表服务器服务在域帐户下运行，并且密码还未在 Reporting Services 配置工具中更新就已过期，则指定新密码之前，该服务将无法启动。如果服务无法启动，则不能使用 Reporting Services 配置工具连接到该服务器以更新帐户。在这种情况下，必须使用多种工具来使服务器恢复联机状态。

若要重置密码，请执行下列操作：

  1. 在“开始”菜单上，依次指向“控制面板”和“管理工具”，然后单击“服务”。

  2. 右键单击“SQL Server Reporting Services”，然后选择“属性”。

  3. 单击“登录”，然后键入新密码。

  4. 更新密码后，启动 Reporting Services 配置工具并在“服务帐户”页中更新密码。若要更新由报表服务器存储在内部的帐户信息，必须执行此附加步骤。

如果数据库引擎的服务帐户密码已过期，则尝试连接到报表服务器时，将出现 rsReportServerDatabaseUnavailable 错误。重置密码可以解决此错误。若要查看错误消息的完整文本，请参阅 SQL Server 联机丛书中的服务器和数据库连接故障排除。

为 SharePoint 集成报表服务器配置报表服务器服务

如果在 SharePoint 集成模式下运行报表服务器，且符合下列条件之一，则必须更新存储在 SharePoint 配置数据库中的服务帐户信息。

  • 修改 Reporting Services 服务帐户（例如，从 NetworkService 帐户切换到域用户帐户）。

  • 扩展 SharePoint 场以包含其他 SharePoint Web 应用程序。如果服务器场是针对报表服务器集成配置的，且配置的用于运行新添加的应用程序的用户帐户与用于运行该场中其他应用程序的用户帐户不同，则必须更新数据库访问信息。

重置数据库访问信息后，应当重新启动 Windows SharePoint Services 服务以确保不再使用旧连接。

  1. 在“管理工具”中，单击“SharePoint 2010 管理中心”。

  2. 单击“应用程序管理”。

  3. 在“Reporting Services”部分中，单击“授予数据库访问权限”。

  4. 单击“确定”。将出现“输入凭据”对话框。

  5. 输入用户凭据，该用户必须是报表服务器所在的计算机上本地管理员组的成员。这些凭据将用于一次性连接到报表服务器计算机以便检索服务帐户信息。在 SharePoint 数据库中将对为每个服务帐户创建的数据库登录名进行更新。

  6. 若要重新启动服务，请单击“操作”。

  7. 在“拓扑和服务”中，单击“服务器上的服务”。

  8. 对于 Windows SharePoint Services Web 应用程序，单击“停止”。

  9. 等待服务停止。

  10. 单击“启动”。

注意：
SharePoint 2010 产品和技术需要域帐户来完成服务配置，如报表服务 SharePoint 集成。

有关详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

请参阅

任务

如何为 Reporting Services 配置服务帐户
如何启动 Reporting Services 配置

参考

服务帐户（Reporting Services 配置）

概念

配置报表服务器 URL

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


配置报表服务器 URL

配置报表服务器 URL |
 | 请参阅
配置 Reporting Services >

在 Reporting Services 中，URL 用于访问报表服务器 Web 服务和报表管理器。在可以使用任何应用程序之前，必须分别为 Web 服务和报表管理器至少配置一个 URL。Reporting Services 为这两个应用程序 URL 都提供了默认值，它们在大多数部署方案中都能正常使用，包括与其他 Web 服务和应用程序的并行部署。

  • 如果安装了默认配置，则使用默认值自动创建 URL。

  • 如果使用 Reporting Services 配置工具创建或修改 URL，则可以接受 URL 的默认值或指定自定义值。定义 URL 时页面上会出现该 URL 的测试链接，以便可以立即确认指定的设置是否为有效连接。有关如何配置和测试 URL 的分步说明，请参阅如何配置 URL（Reporting Services 配置）。

定义报表服务器 URL

URL 精确标识了网络上报表服务器应用程序实例的位置。创建报表服务器 URL 时，必须指定以下部分。

组成部分 | 说明
主机名 | TCP/IP 网络使用 IP 地址来唯一标识网络上的设备。计算机中安装的每个网络适配器都有一个物理 IP 地址。如果 IP 地址解析为主机标头，则可以指定主机标头。如果要将报表服务器部署到企业网络上，则可以使用计算机的网络名称。
端口 | TCP 端口是设备上的端点。报表服务器将侦听指定端口上的请求。
虚拟目录 | 端口通常由多个 Web 服务或应用程序共享。为此，报表服务器 URL 始终包括与获取请求的应用程序对应的虚拟目录。您必须为侦听同一 IP 地址和端口的每个 Reporting Services 应用程序都指定唯一的虚拟目录名称。
SSL 设置 | 可以将 Reporting Services 中的 URL 配置为使用计算机中先前安装的现有 SSL 证书。有关详细信息，请参阅 SQL Server 联机丛书中的配置报表服务器用于安全套接字层 (SSL) 连接。

默认 URL

通过 URL 访问报表服务器或报表管理器时，该 URL 应包括主机名称而不是 IP 地址。在 TCP/IP 网络上，IP 地址将解析为主机名称（或计算机的网络名称）。如果使用了默认值配置 URL，则应可以使用将计算机名称或 localhost 指定为主机名的 URL 来访问报表服务器 Web 服务：

  • http://<计算机名称>/reportserver

  • http://localhost/reportserver

下表中显示了使这些 URL 可用的设置。该表显示了通过包含主机名的 URL 来启用报表服务器连接的默认值：

组成部分 | 值 | 说明
IP 地址 | 所有已分配的值 | 网络上的域名服务将 URL 上的主机名解析为计算机的 IP 地址。只要定义的 URL 中指定了 IP 地址，发送到特定主机的请求便将到达其预期目标。
端口 | 80 | 端口 80 是计算机上进行 TCP/IP 连接的默认端口。因为报表服务器侦听的是端口 80，所以可以忽略 URL 中的端口号。如果指定另一个端口，则必须在 URL 中指定该端口。
虚拟目录 | ReportServer | 请注意，这两个示例 URL 都包括虚拟目录名称。除非自定义 URL 定义，否则必须始终在 URL 中指定该应用程序的虚拟目录名称。
注意：
基本 URL 保留项可启用将在 URL 中使用的任何有效主机名。Reporting Services 配置工具可使用允许将主机名变体解析为特殊报表服务器实例的语法在 HTTP.SYS 中创建一个 URL 保留项。有关 URL 保留项的详细信息，请参阅关于 URL 保留和注册 (Reporting Services)。

对报表服务器 URL 的服务器端权限

每个 URL 端点的权限都以独占方式授予报表服务器服务帐户。只有此帐户有权接受定向到 Reporting Services URL 的请求。通过安装程序或 Reporting Services 配置工具配置服务标识时，创建并维护该帐户的随机访问控制列表 (DACL)。如果更改服务帐户，Reporting Services 配置工具将更新您创建的所有 URL 保留项以拾取新的帐户信息。有关详细信息，请参阅 URL 保留项语法 (Reporting Services)。

对发送到报表服务器 URL 的客户端请求进行身份验证

默认情况下，URL 端点支持的身份验证类型为 Windows 身份验证。这是默认的安全扩展插件。如果要实现自定义或窗体身份验证提供程序，则必须修改报表服务器上的身份验证设置。还可以选择更改 Windows 身份验证设置，使其与网络中使用的身份验证子系统匹配。有关详细信息，请参阅 SQL Server 联机丛书中的在 Reporting Services 中配置身份验证。

本节涉及的主题

如何配置 URL（Reporting Services 配置）

本主题提供了在 Reporting Services 配置工具中设置和修改 URL 保留项的说明。

关于 URL 保留和注册 (Reporting Services)

URL 用于访问应用程序和报表。本主题说明了 Reporting Services 中的应用程序 URL、默认 URL 以及 URL 保留和注册的工作方式。

URL 保留项语法 (Reporting Services)

Reporting Services 使用的默认 URL 保留项对于大多数情况都是有效的。但是，如果要限制访问权限或扩展部署以启用 Internet 或 Extranet 访问，则可能要自定义设置以适合您的要求。本主题说明了 URL 保留项的语法并为如何创建针对特定部署的自定义保留项提供了建议。

配置文件中的 URL (Reporting Services)

RSReportServer.config 文件包含了 URL 保留项的多个条目以及由报表管理器和报表服务器电子邮件传递使用的 URL。本主题概述了 URL 配置设置以便您可以了解它们之间如何进行比较。

多实例报表服务器部署的 URL 保留项

当在一台计算机中安装多个 Reporting Services 实例时，如果已注册某个 URL，便会增加 URL 重复的可能性。若要避免这些错误，请遵循本主题中针对创建特定于实例的 URL 保留项的建议。

请参阅

任务

如何配置 URL（Reporting Services 配置）

概念

Web 服务 URL（Reporting Services 配置）

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


关于 URL 保留和注册 (Reporting Services)

关于 URL 保留和注册 (Reporting Services) |
 | 请参阅
配置 Reporting Services > 配置报表服务器 URL >

Reporting Services 应用程序的 URL 在 HTTP.SYS 中定义为 URL 保留项。URL 保留项定义了指向 Web 应用程序的 URL 端点的语法。在报表服务器上配置应用程序时，将定义报表服务器 Web 服务和报表管理器的 URL 保留项。通过安装程序或 Reporting Services 配置工具配置 URL 时，会自动为您创建 URL 保留项：

  • 安装程序将使用默认值创建 URL 保留项。如果安装程序安装默认配置，它将保留两个 URL；一个是报表服务器 Web 服务的 URL，另一个是为报表管理器保留的 URL。您可以使用 Reporting Services 配置工具添加更多 URL 或修改安装程序创建的默认 URL。

  • Reporting Services 配置工具将根据您在此工具的“Web 服务 URL”或“报表管理器 URL”页中指定的 URL 创建 URL 保留项。

安装程序和此工具都还会为报表服务器服务分配对 URL 的权限、检查有无重复实例并向 HTTP.SYS 添加 URL 保留项。切勿使用 HttpCfg.exe 或其他工具直接创建或修改 Reporting Services URL 保留项。如果您跳过了某一步骤或设置了无效的值，您将会遇到可能难以诊断或修复的问题。

注意：
HTTP.SYS 是一个操作系统组件，用于侦听网络请求并将它们路由至请求队列。在此版本的 Reporting Services 中，HTTP.SYS 为报表服务器 Web 服务和报表管理器建立和维护请求队列。Internet Information Services (IIS) 不再用于承载或访问 Reporting Services 应用程序。有关 HTTP.SYS 功能的详细信息，请参阅 MSDN 上的 HTTP Server API（HTTP 服务器 API）。

主题内容

本主题介绍 URL、URL 保留和注册、默认值，以及在为不同的服务器配置创建或修改 URL 时应遵循的一些特定于部署的建议。本主题包含以下部分：

  • Reporting Services 中的 URL

  • URL 保留和注册

  • 默认 URL

  • Reporting Services URL 的身份验证和服务标识

  • 用于本地管理的 URL

  • 用于扩展部署的 URL

  • 用于 SharePoint 集成模式的 URL

有关 Reporting Services 安装中的 URL 构造和使用或者对保留或注册错误进行故障排除的详细信息，请参阅 SQL Server 联机丛书中的配置报表服务器 URL 和解决配置问题。

Reporting Services 中的 URL

在 Reporting Services 安装中，可以通过 URL 访问以下工具、应用程序和项：

  • 报表服务器 Web 服务

  • 报表管理器

  • 报表生成器

  • 已发布到报表服务器的报表

不应通过 URL 将其他已发布的、可通过 URL 寻址的项（如模型和共享数据源）作为独立项进行访问。当在浏览器窗口中查看这些项时，报表服务器不会以有意义的格式显示这些项。

注意：
本主题不讨论对报表生成器或存储在报表服务器上的特定报表的 URL 访问。有关通过 URL 对这些项进行访问的详细信息，请参阅 SQL Server 联机丛书中的使用 URL 访问报表服务器项。

URL 保留和注册

URL 保留项定义了可用于访问 Reporting Services 应用程序的 URL。Reporting Services 将在 HTTP.SYS 中为报表服务器 Web 服务和报表管理器保留一个或多个 URL，然后在服务启动时注册它们。指向报表生成器和报表的 URL 基于报表服务器 Web 服务 URL 保留项。通过向 URL 追加参数，可以通过 Web 服务打开报表生成器或报表。保留和注册由 HTTP.SYS 实现。有关详细信息，请参阅 MSDN 上的 Namespace Reservations, Registration, and Routing（命名空间保留、注册和路由）。

URL 保留是指创建指向 Web 应用程序的 URL 端点并将其存储在 HTTP.SYS 中的过程。HTTP.SYS 是计算机上定义的所有 URL 保留项的公共存储库，它定义了一组保证 URL 保留项唯一的公共规则。

URL 注册在服务启动时进行。此时会创建请求队列，并且 HTTP.SYS 开始将请求路由到该队列。必须先注册 URL 端点，然后再将定向至该端点的请求添加到该队列。当报表服务器服务启动时，它将注册已为所有启用的应用程序保留的所有 URL。也就是说，必须启用 Web 服务，才能进行注册。如果在外围应用配置器中，对于基于策略的管理的 Reporting Services 方面将 WebServiceAndHTTPAccessEnabled 属性设置为 False，则 Web 服务的 URL 在该服务启动时将不会注册。

如果停止服务或回收 Web 服务或报表管理器应用程序域，则会撤消注册 URL。如果在服务正在运行时修改 URL 保留项，报表服务器将会立即回收应用程序域，以便可以撤消注册旧的 URL，开始注册新的 URL。

下面几个简单的示例说明了 URL 保留项的概念以及它与用于 Reporting Services 应用程序的 URL 地址之间的关联。需要注意一个关键点，即 URL 保留项与用于访问应用程序的 URL 具有不同的语法：

HTTP.SYS 中的 URL 保留项 | URL | 说明
http://+:80/reportserver | http://<计算机名称>/reportserver http://<IP 地址>/reportserver http://localhost/reportserver | 此 URL 保留项针对端口 80 指定了一个通配符 (+)。这会将指定主机（在端口 80 上解析为报表服务器计算机）的任何传入请求放入报表服务器队列中。请注意，借助此 URL 保留项，可以使用任意数目的 URL 访问报表服务器。 对于大多数操作系统而言，这是 Reporting Services 报表服务器的默认 URL 保留项。
http://123.45.67.0:80/reportserver | http://123.45.67.0/reportserver | 此 URL 保留项指定了一个 IP 地址，与通配符 URL 保留项相比，其限制性要强很多。只能使用包含此 IP 地址的 URL 连接到报表服务器。如果给定此 URL 保留项，则以 http://<计算机名称>/reportserver 或 http://localhost/reportserver 对报表服务器的请求将失败。

默认 URL

如果在默认配置中安装 Reporting Services，安装程序将为报表服务器 Web 服务和报表管理器保留 URL。在 Reporting Services 配置工具中定义 URL 保留项时，也可以接受这些默认值。如果安装 SQL Server Express 或安装 Reporting Services 作为命名实例，则默认 URL 将包含实例名称。

重要提示：
实例字符为下划线字符 (_)。

URL 保留项包含一个端口号。以下操作系统将允许多个 Web 应用程序共享一个端口：Windows Server 2003、Windows Vista 和 Windows Server 2008。如果您使用的是 Windows XP，请确保使用唯一的端口。

实例类型 | 应用程序 | 默认 URL | HTTP.SYS 中的实际 URL 保留项
默认实例 | 报表服务器 Web 服务 | http://<服务器名称>/reportserver | http://<服务器名称>:80/reportserver
默认实例 | 报表管理器 | http://<服务器名称>/reportserver | http://<服务器名称>:80/reportserver
命名实例 | 报表服务器 Web 服务 | http://<服务器名称>/reportserver_<实例名称> | http://<服务器名称>:80/reportserver_<实例名称>
命名实例 | 报表管理器 | http://<服务器名称>/reports_<实例名称> | http://<服务器名称>:80/reports_<实例名称>
SQL Server Express | 报表服务器 Web 服务 | http://<服务器名称>/reportserver_SQLExpress | http://<服务器名称>:80/reportserver_SQLExpress
SQL Server Express | 报表管理器 | http://<服务器名称>/reports_SQLExpress | http://<服务器名称>:80/reports_SQLExpress

Reporting Services URL 的身份验证和服务标识

Reporting Services URL 保留项指定了报表服务器服务的服务帐户。运行服务的帐户用于为运行在同一实例上的 Reporting Services 应用程序创建的所有 URL。报表服务器实例的服务标识存储在 RSReportServer.config 文件中。

服务帐户没有默认值。但是，在安装过程中需要指定服务帐户，即使以“仅文件”模式安装服务器，也会在 RSReportServer.config 中的 URLReservation 中指定服务帐户。服务帐户的有效值包括域用户帐户、LocalSystem 或 NetworkService。

因为默认安全性为 RSWindowsNegotiate，所以匿名访问已禁用。对于 Intranet 访问，报表服务器 URL 使用网络计算机名称。如果要为 Internet 连接配置 Reporting Services，必须使用其他设置。有关详细信息，请参阅 SQL Server 联机丛书中的规划 Extranet 或 Internet 部署。有关身份验证的详细信息，请参阅 SQL Server 联机丛书中的在 Reporting Services 中配置身份验证。

用于本地管理的 URL

如果您为 URL 保留项指定了强通配符或弱通配符，则可以分别使用 http://localhost/reportserver 或 http://localhost/reports。

http://localhost URL 将解释为 http://127.0.0.1。如果您将 URL 保留项限定为计算机名称或单个 IP 地址，则除非在本地计算机上为 127.0.0.1 创建附加保留项，否则将无法使用 localhost。同样，如果您的计算机上禁用 localhost 或 127.0.0.1，也无法使用该 URL。

Windows Vista 和 Windows Server“Longhorn”新增了一些安全功能，以便最大程度地降低无意中以提升的特权运行程序的风险。还需要执行一些其他步骤，才能在这些操作系统上启用本地管理。有关详细信息，请参阅如何在 Windows Vista 和 Windows Server 2008 上为本地管理配置报表服务器。

用于扩展部署的 URL

此版本中没有这一部分的相关信息。

SharePoint 集成模式下的报表服务器的 URL

如果独立报表服务器配置为在较大的 SharePoint 产品或技术部署中运行，则 URL 和虚拟目录构造将在以下几个方面受到影响：

  • 报表及其他项的 URL 通过 SharePoint Web 应用程序 URL 进行寻址。如果通过 URL 访问特定报表，请始终使用包含站点路径、文档库、项名称和文件扩展名（例如，报表的扩展名为 .rdl）的完全限定的 URL。在报表中引用共享数据源和模型以及在为对报表服务器的发布操作指定目标服务器和文件夹时，必须指定完全限定的 URL。

  • 文件扩展名用来区分不同类型的报表服务器项。有效的扩展名包括用于报表定义的 .rdl、用于报表模型的 .smdl 以及用于为 SharePoint 站点创建的共享数据源的 .rsds。

  • 尽管 SharePoint 产品和技术具有为自身定义的 URL 保留项，但在发布到服务器时您可以忽略这种保留。对于 SharePoint Web 应用程序，URL 保留是内部操作。

  • 对于将集成的报表服务器和 SharePoint 技术实例安装在同一台计算机上的单服务器部署，不能使用 http://localhost/reportserver。如果使用 http://localhost 访问 SharePoint Web 应用程序，则必须使用非默认网站或唯一端口分配来访问报表服务器。此外，如果报表服务器与 SharePoint 场集成在一起，则对于部署中安装在远程计算机上的节点，对报表服务器的 localhost 访问将无法解析。

  • 不能为在 SharePoint 集成模式下运行的报表服务器配置报表管理器的 URL 保留项和端点。如果配置了这些项，则在 SharePoint 集成模式下部署报表服务器后，报表管理器将不再工作。此模式不支持报表管理器。

如果您集成了某个报表服务器扩展部署以便在较大的 SharePoint 产品或技术部署中运行，请对各报表服务器节点进行负载平衡，并定义指向该扩展部署的单个虚拟服务器 URL。报表服务器集成设置只允许您指定单个报表服务器 URL。如果是扩展部署，则此 URL 必须是该扩展部署中各服务器节点的访问点。

有关部署模式和发布项的 URL 要求的详细信息，请参阅 SQL Server 联机丛书中的 规划部署模式和将模型和共享数据源部署到 SharePoint 站点。

请参阅

任务

如何配置 URL（Reporting Services 配置）

概念

URL 保留项语法 (Reporting Services)

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


URL 保留项语法 (Reporting Services)

URL 保留项语法 (Reporting Services) |
 | 请参阅
配置 Reporting Services > 配置报表服务器 URL >

本主题介绍报表服务器 Web 服务和报表管理器的 URL 字符串的各部分。该内部存储的 URL 字符串的结构不同于在浏览器窗口的地址栏中键入的 URL 的结构。URL 保留项字符串会在您配置 URL 时显示在 Reporting Services 配置工具的“结果”窗口中，也会出现在 RSReportServer.config 文件中。如果要解决 URL 保留项中存在的问题，或者要查询 HTTP.SYS 以查看服务器上定义的内部 URL 保留项，则了解该 URL 字符串的定义方式会很有用。

URL 语法

报表服务器 URL 存储在 UrlString 元素和 VirtualDirectory 元素中。将 UrlString 和 VirtualDirectory 区分为不同元素的原因是您可以具有多个 URL 字符串，但每个 Reporting Services 应用程序只有一个虚拟目录名。

在 HTTP.SYS 中，URL 保留项包括 UrlString 和 VirtualDirectory。URL 保留项的语法包含以下部分：

<scheme>://<hostname>:<port>/<virtualdirectory>

下表说明了每个属性及其有效值。

属性 有效值 说明

Scheme

http 或 https

针对非 SSL 连接和 SSL 连接的前缀。

Hostname

(+) 强通配符，相当于 IP 地址的值为“(所有已分配的)”。

(*) 弱通配符，相当于 IP 地址为“(所有未分配的)”。

完全限定域名

计算机名称

IP 地址 (IPV4)

IP 地址 (IPV6)

标识网络上的服务器。

(+) 强通配符是默认值。HTTP.SYS 将接受给定端口和虚拟目录组合的所有网络适配器上的所有请求。报表服务器将接受该端口上的任何请求。

(*) 弱通配符。HTTP.SYS 接受给定端口和虚拟目录组合的所有网络适配器上未由其他 URL 保留项处理的所有请求。

计算机名称是网络上计算机的 NETBIOS 名称。

完全限定域名包含域地址和服务器名，如域控制器或公共域名服务器中所注册的那样。

IP 地址 (IPV4) 是采用 IPV4 格式的、计算机网络适配器的 IP 地址：nnn.nnn.nnn.nnn。

IP 地址 (IPV6) 是采用 IPV6 格式的、计算机网络适配器的 IP 地址：<标头>:<标头>:nnn.nnn.nnn.nnn。

Port

80

443

<自定义>

端口 80 是与服务器之间的 HTTP 请求的标准端口。

端口 443 是用于 SSL 连接的标准端口。

您可以使用任何未被其他应用程序保留的端口。

Virtualdirectory

ReportServer[_InstanceName]

Reports[_InstanceName]

<自定义>

指定应用程序的名称。该值是一个字符串。默认情况下，Reporting Services 使用 ReportServer 和 Reports 作为报表服务器 Web 服务和报表管理器应用程序的应用程序名称。您可以根据需要使用不同的名称。

此值是必需的。它用于标识应用程序。

为每个应用程序实例仅指定一个虚拟目录。若要为同一实例中的同一应用程序创建多个 URL，可以创建 UrlString 的多个版本。若要为多个应用程序实例创建唯一的虚拟目录名，可以考虑将实例名称包含在虚拟目录名中，即使用下划线字符 (_) 追加实例名称。InstanceName 是可选的，但是如果同一台计算机上有多个实例，则建议使用此选项。有关如何为命名实例设置 URL 保留项的详细信息，请参阅多实例报表服务器部署的 URL 保留项。

虚拟目录的值不区分大小写。您可以使用任意字符串，只要它不包含 URL 分隔符或 URL 编码即可。

请参阅

任务

如何配置 URL（Reporting Services 配置）

概念

配置报表服务器 URL

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


配置文件中的 URL (Reporting Services)

配置文件中的 URL (Reporting Services) |
 | 请参阅
配置 Reporting Services > 配置报表服务器 URL >

Reporting Services 在 RSReportServer.config 文件中存储应用程序设置。在此文件内，有一些既用于 URL 又用于 URL 保留的配置设置。这些配置设置的用途和修改规则大不相同。如果您习惯于通过修改配置文件来优化部署，则本主题可帮助您了解每项 URL 设置的用法。

RSReportServer.config 文件中的 URL 设置

Reporting Services 存储用于进行应用程序和报表访问的 URL，以及将 Web 前端组件连接到后端报表服务器的 URL。

用于进行应用程序访问的 URL

URL 用于访问报表服务器 Web 服务和报表管理器。若要配置 URL，必须使用 Reporting Services 配置工具。该工具用于为 HTTP.SYS 中的每个应用程序创建 URL 保留，并为 RSReportServer.config 的 URLReservations 部分中的 URL 添加条目。

  • 若要查看 URLReservations 部分的每个元素的说明，请参阅 SQL Server 联机丛书中的 RSReportServer 配置文件。

  • 若要仅了解有关 UrlString 元素的语法的详细信息，请参阅 URL 保留项语法 (Reporting Services)。

  • 有关如何配置用于应用程序访问的 URL 的说明，请参阅如何配置 URL（Reporting Services 配置）。

用于进行报表访问的 URL

Reporting Services 包括可用于发送报表链接或附件的报表服务器电子邮件传递扩展插件。传递报表时将构造报表链接。报表服务器电子邮件传递扩展插件使用配置文件中的 UrlRoot 设置来创建链接。UrlRoot 还用于解析通过无人参与的报表处理生成的呈现报表中的链接。

当您配置用于应用程序访问的 URL 时，将在 RSReportServer.config 文件中自动指定 UrlRoot。如果在配置文件中修改该值，则必须指定连接到报表服务器数据库（包含要传递的报表）的报表服务器 Web 服务的有效 URL 地址。您只可以为一个报表服务器实例指定一个 UrlRoot；对于任何给定的报表服务器实例，RSReportServer.config 文件中只能存在一个 UrlRoot 条目。如果您为报表服务器 Web 服务保留了多个 URL，则必须为 UrlRoot 选择其中一个可用值。

在大多数情况下，您无需修改 UrlRoot。然而，如果将通过完全限定的 URL 访问报表服务器，并且您未将使用主机标头的 URL 配置为完全限定的站点名称，则必须手动编辑 RSReportServer.config 以将 UrlRoot 设置为将用于呈现报表的完全限定的报表服务器 URL（例如，https://www.adventure-works.com/mywebapp/reportserver）。

用于将报表管理器和 Web 部件连接到报表服务器 Web 服务的 URL

报表管理器和 Reporting Services 的 SharePoint 2.0 Web 部件是连接到报表服务器的 Web 前端组件。用于连接到后端报表服务器的 URL 包括：

  • ReportServerUrl（由报表管理器使用）

  • ReportServerExternalUrl（由 Web 部件使用）

注意：
Reporting Services 的早期版本包括 ReportServerVirtualDirectory 元素。该值在 SQL Server 2008 中已过时。如果您已升级现有安装并正在使用包含此设置的配置文件，则报表服务器不再读取该值。

下表简要概括了所有可以在 Reporting Services 配置文件中指定的 URL。

设置 用法 说明

ReportServerUrl

可选。除非您自己添加此元素，否则此元素不包含在 RSReportServer.config 文件中。

仅当您配置以下方案之一时才应设置此元素：

  • 报表管理器提供对在另一台计算机上运行或在同一台计算机上的另一实例上运行的报表服务器 Web 服务的 Web 前端访问。

  • 当您有指向一个报表服务器的多个 URL，并且您希望报表服务器使用特定的 URL 时。

  • 您有特定的报表服务器 URL，您希望所有报表管理器连接均使用此 URL。

    例如，您可能为网络中的所有计算机都启用报表管理器访问，但需要报表管理器通过一个本地连接连接到报表服务器。在这种情况下，您可以将 ReportServerUrl 配置为“http://localhost/reportserver”。

有关如何实施这些方案的说明，请参阅 SQL Server 联机丛书中的 如何配置报表管理器。

该值指定一个指向报表服务器 Web 服务的 URL。此值由报表管理器在启动时读取。如果已设置该值，则报表管理器将连接到此 URL 中指定的报表服务器。

默认情况下，报表管理器提供对与报表管理器运行在同一报表服务器实例中的报表服务器 Web 服务的 Web 前端访问。然而，如果希望将报表管理器与作为另一实例一部分或在另一台计算机的实例上运行的报表服务器 Web 服务一起使用，则可以将此 URL 设置为定向报表管理器使之连接到外部报表服务器 Web 服务。

如果安全套接字层 (SSL) 证书安装在您要连接的报表服务器上，则 ReportServerUrl 值必须是为获得此证书而注册的服务器的名称。如果出现“基础连接已经关闭: 未能为 SSL/TLS 安全通道建立信任关系”错误，请将 ReportServerUrl 设置成为其颁发 SSL 证书的服务器的完全限定域名。例如，如果向 https://adventure-works.com.onlinesales 注册了此证书，则报表服务器 URL 将为 https://adventure-works.com.onlinesales/reportserver。

ReportServerExternalUrl

可选。除非您自己添加此元素，否则此元素不包含在 RSReportServer.config 文件中。

仅当您使用的是 SharePoint 2.0 Web 部件且希望用户能够检索报表并在新的浏览器窗口中打开该报表时，才应设置此元素。

将 <ReportServerExternalUrl> 添加在 <ReportServerUrl> 元素下方，然后将其设置为在单独的浏览器窗口中被访问时解析为报表服务器实例的完全限定报表服务器名称。不要删除 <ReportServerUrl>。

下面的示例说明了相应的语法：

<ReportServerExternalUrl>http://myserver/reportserver</ReportServerExternalUrl>

该值由 SharePoint 2.0 Web 部件使用。

在早期版本中，建议您设置该值以在面向 Internet 的报表服务器上部署报表生成器。这是未经测试的部署方案。如果您在过去使用此设置支持对报表生成器的 Internet 访问，那么现在您应考虑使用替代策略。

请参阅

任务

如何配置 URL（Reporting Services 配置）

概念

配置报表服务器 URL

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


多实例报表服务器部署的 URL 保留项

多实例报表服务器部署的 URL 保留项 |
 | 请参阅
配置 Reporting Services > 配置报表服务器 URL >

如果将多个 Reporting Services 实例安装在同一台计算机上，则必须考虑如何为每个实例定义 URL 保留项。在每个实例中，报表服务器 Web 服务和报表管理器都必须至少有一个 URL 保留项。整组保留项在 HTTP.SYS 中必须保持唯一。

在 URL 注册（发生在服务启动时）过程中会检测 URL 是否重复。如果您创建的 URL 保留项不唯一，那么，直到启动服务时，才会检测到名称冲突。因此，请确保遵循命名约定或规则以确保所有的值保持唯一。

默认的命名约定

可以将 Reporting Services 安装到 SQL Server 命名实例中。当您在命名实例中安装或配置报表服务器时，实例名称会自动包括在 Reporting Services 提供的默认 URL 保留项中的虚拟目录中。下表显示了默认实例和命名实例的 URL 保留项。

SQL Server 实例 | 默认 URL 保留项
默认实例 (MSSQLServer) | http://+:80/reportserver
命名实例 (MynamedInstance) | http://+:80/reportserver_MyNamedInstance

对于命名实例，虚拟目录中包括实例名称。默认实例和命名实例在同一个端口上侦听，但是唯一的虚拟目录名称确定了请求将由哪个报表服务器获取。

建议的最佳实践是使用虚拟目录名称来区分报表服务器实例，这样可在 URL 和目标实例之间提供清楚的对应关系，并确保应用程序名称在整个系统中保持唯一。

自定义命名约定

尽管建议使用实例名称，但是您可以使用 URL 语法和自己的命名约定来满足 URL 保留项的唯一名称约束。下面的示例说明了用来为每个实例创建唯一 URL 的不同方法。

报表服务器的默认实例 (MSSQLSERVER) | ReportServer_MyNamedInstance | 唯一性
http://+:80/reportserver | http://+:8888/reportserver | 每个实例都在一个不同的端口上侦听。
http://www.contoso.com/reportserver | http://SRVR-46/reportserver | 每个实例都对应不同的服务器名称（完全限定域名和计算机名称）。

唯一性要求

Reporting Services 使用的基础技术对于唯一名称施加了一定的要求。HTTP.SYS 要求其存储库中的所有 URL 保持唯一。您可以通过改变端口、主机名或虚拟目录名称来创建唯一的 URL。ASP.NET 要求同一个进程内的应用程序标识保持唯一。此要求会影响虚拟目录名称。它规定您不能在同一个报表服务器实例中复制虚拟目录名称。

请参阅

任务

如何配置 URL（Reporting Services 配置）

概念

配置报表服务器 URL

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


创建报表服务器数据库

创建报表服务器数据库 |
 | 请参阅
配置 Reporting Services >

注意：
对于 SQL Server 2008 R2，没有对本主题中所列的内容进行任何更改。

Reporting Services 使用两个 SQL Server 关系数据库存储报表服务器元数据和对象。一个数据库用于主存储，另一个数据库用于存储临时数据。这两个数据库一起创建，并按名称绑定。通过默认 SQL Server 实例，将这两个数据库命名为 reportserver 和 reportservertempdb。这两个数据库统称为“报表服务器数据库”或“报表服务器目录”。

重要提示：
请不要编写对报表服务器数据库运行查询的应用程序。报表服务器数据库不是公用架构。从一个版本升级到下一个版本时可能会更改表结构。如果编写一个需要访问报表服务器数据库的应用程序，则始终使用 Reporting Services API 来访问报表服务器数据库。

创建报表服务器数据库的方式

您可以通过以下方式创建报表服务器数据库：

  • 如果选择默认配置安装选项，则可通过安装程序自动创建。在 SQL Server 安装向导中，这是“报表服务器安装选项”页中的“安装本机模式默认配置”选项或“安装 SharePoint 集成模式默认配置”。如果选择“安装但不配置”选项，则必须使用 Reporting Services 配置工具来创建数据库。

  • 通过 Reporting Services 配置工具手动创建。如果使用远程 SQL Server 数据库引擎来承载该数据库，则必须手动创建报表服务器数据库。有关详细信息，请参阅如何创建报表服务器数据库（Reporting Services 配置）。

数据库服务器版本要求

SQL Server 用来承载报表服务器数据库：

  • SQL Server 2005 或 SQL Server 2008 可用来承载数据库。不要使用 SQL Server 2000 或更早版本的 SQL Server。

  • SQL Server 数据库引擎实例可以是本地或远程实例。

若要在远程计算机上创建报表服务器数据库，则需要将连接配置为使用域用户帐户或具有网络访问权限的服务帐户。如果决定使用远程 SQL Server 实例，请仔细考虑报表服务器应使用哪些凭据来连接 SQL Server 实例。有关详细信息，请参阅配置报表服务器数据库连接。

重要提示：
报表服务器和用于承载报表服务器数据库的 SQL Server 实例可位于不同的域中。对于 Internet 部署，通常的做法是使用防火墙后的服务器。如果要配置用于 Internet 访问的报表服务器，请使用 SQL Server 凭据连接到位于防火墙后的 SQL Server 实例并使用 IPSEC 保护连接的安全。

数据库服务器版本类别要求

创建报表服务器数据库时，请注意并非所有版本的 SQL Server 均可用来承载数据库。下表显示了可用于特定 Reporting Services 版本的数据库引擎版本。

对于此 SQL Server Reporting Services 版本 | 使用此版本的数据库引擎实例来承载数据库
具有高级服务的 SQL Server Express | 具有高级服务的 SQL Server Express（仅用于本地）
Web | Web Edition（仅用于本地）
Workgroup | Workgroup Edition（仅用于本地）
评估版 | 评估版
Developer | Standard Edition、Developer Edition、Enterprise Edition（本地或远程）
Standard | Standard Edition、Enterprise Edition（本地或远程）
Enterprise | Standard Edition、Enterprise Edition（本地或远程）

请参阅

概念

配置 Reporting Services

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


配置报表服务器数据库连接

配置报表服务器数据库连接 |
 | 请参阅
配置 Reporting Services >

每个报表服务器实例都需要连接到存储由服务器管理的报表、报表模型、共享数据源、资源和元数据的报表服务器数据库。如果要安装默认配置，则可以在报表服务器安装过程中创建初始连接。多数情况下，可以在安装程序完成之后使用 Reporting Services 配置工具配置连接。您可以随时修改连接，以更改帐户类型或重置凭据。有关如何创建数据库并配置连接的分步说明，请参阅如何创建报表服务器数据库（Reporting Services 配置）。

如果出现下列情况，则必须配置报表服务器数据库连接：

  • 为首次使用配置报表服务器。

  • 配置报表服务器以使用不同的报表服务器数据库。

  • 更改数据库连接所使用的用户帐户或密码。当帐户信息存储在 RSReportServer.config 文件中时，您只需要更新数据库连接。如果使用服务帐户进行连接（该帐户使用 Windows 集成安全性作为凭据类型），则不会存储密码，从而无需更新连接信息。有关更改帐户的详细信息，请参阅配置报表服务器服务帐户。

  • 配置报表服务器扩展部署。配置扩展部署时，您需要创建多个到报表服务器数据库的连接。有关如何执行此多步操作的详细信息，请参阅如何配置报表服务器扩展部署（Reporting Services 配置）。

Reporting Services 如何连接到数据库引擎

报表服务器根据凭据和连接信息以及对使用该数据库的报表服务器实例有效的加密密钥来访问报表服务器数据库。拥有有效的加密密钥对于存储和检索敏感数据是必要的。首次配置数据库时，会自动创建加密密钥。创建密钥之后，如果更改报表服务器服务标识，则必须更新这些密钥。有关使用加密密钥的详细信息，请参阅配置和管理加密密钥。

报表服务器数据库为内部组件，只有报表服务器可以访问。为报表服务器数据库指定的凭据和连接信息专门由报表服务器使用。请求报表的用户不需要拥有报表服务器数据库的数据库权限或数据库登录名。

Reporting Services 使用 System.Data.SqlClient 连接到承载报表服务器数据库的数据库引擎。如果使用的是数据库引擎的本地实例，报表服务器将使用共享内存建立连接。如果使用的是报表服务器数据库的远程数据库服务器，则可能必须根据所使用的版本启用远程连接。如果使用的是 Developer Edition，则默认情况下会关闭远程连接。如果使用的是 Enterprise Edition，则默认情况下会启用 TCP/IP 远程连接。

若要验证实例是否接受远程连接，请依次单击“开始”、“所有程序”、Microsoft SQL Server 2008 R2、“配置工具”、“SQL Server 配置管理器”，然后确认为每个服务启用了 TCP/IP 协议。

启用远程连接时，也会启用客户端协议和服务器协议。若要确认协议已启用，请依次单击“开始”、“所有程序”、Microsoft SQL Server 2008 R2、“配置工具”、“SQL Server 配置管理器”、“SQL Server 网络配置”，再单击“MSSQLSERVER 协议”。有关详细信息，请参阅 SQL Server 联机丛书中的如何启用或禁用服务器网络协议（SQL Server 配置管理器）。

定义报表服务器数据库连接

若要配置连接，您必须使用 Reporting Services 配置管理器工具或 rsconfig 命令行实用工具。报表服务器需要以下连接信息：

  • 承载报表服务器数据库的数据库引擎实例的名称。

  • 报表服务器数据库的名称。首次创建连接时，可以创建新的报表服务器数据库，或选择现有数据库。有关详细信息，请参阅创建报表服务器数据库。

  • 凭据类型。可以使用服务帐户、Windows 域帐户或 SQL Server 数据库登录名。

  • 用户名和密码（仅在使用 Windows 域帐户或 SQL Server 登录名时需要）。

必须为所提供的凭据授予访问报表服务器数据库的权限。如果使用 Reporting Services 配置工具，则此步骤会自动执行。有关访问数据库所需权限的详细信息，请参阅本主题中的“数据库权限”一节。

存储数据库连接信息

Reporting Services 在下列 RSreportserver.config 设置中存储和加密连接信息。必须使用 Reporting Services 配置工具或 rsconfig 实用工具为这些设置创建加密值。

并非所有的值都针对每一种连接类型进行了设置。如果使用默认值配置连接（即使用服务帐户建立连接），则 <LogonUser>、<LogonDomain> 和 <LogonCred> 将为空，如下所示：

复制代码
<Dsn></Dsn>
<ConnectionType></ConnectionType>
<LogonUser></LogonUser>
<LogonDomain></LogonDomain>
<LogonCred></LogonCred>

如果将连接配置为使用特定的 Windows 帐户或数据库登录名，则在随后更改帐户或登录名时必须更新已存储的值。

选择凭据类型

可以在报表服务器数据库连接中使用三种类型的凭据：

  • 使用报表服务器服务帐户的 Windows 集成安全性。由于报表服务器作为单个服务实现，因此只有运行服务的帐户需要数据库访问。

  • Windows 用户帐户。如果报表服务器和报表服务器数据库安装在同一台计算机上，则可以使用本地帐户。否则，必须使用域帐户。

  • SQL Server 登录名。

注意：
不能使用自定义身份验证扩展插件来连接到报表服务器数据库。自定义身份验证扩展插件只能用来对报表服务器的主体进行身份验证。它们不会影响报表服务器数据库的连接，也不会影响为报表提供内容的外部数据源的连接。

如果数据库引擎实例配置为使用 Windows 身份验证且与报表服务器计算机位于同一个域或可信域中，则可将连接配置为使用通过 Reporting Services 配置工具作为连接属性进行管理的服务帐户或域用户帐户。如果数据库服务器位于另一个域中，或者您使用的是工作组安全性，则必须将连接配置为使用 SQL Server 数据库登录名。在这种情况下，一定要对连接进行加密。有关详细信息，请参阅 SQL Server 联机丛书中的加密与 SQL Server 的连接。
使用服务帐户和集成安全性

可以使用 Windows 集成安全性通过报表服务器服务帐户进行连接。已为此帐户授予了登录报表服务器数据库的权限。如果以默认配置安装 Reporting Services，这将是安装程序选择的默认凭据类型。

此服务帐户为可信帐户，此帐户提供一种低维护方法来管理报表服务器数据库连接。由于此服务帐户使用 Windows 集成安全性来建立连接，因此无需存储凭据。但是，如果以后要更改服务帐户密码或标识（例如从内置帐户切换到域帐户），请确保使用 Reporting Services 配置工具进行更改。该工具会将数据库权限自动更新为使用修改后的帐户信息。有关详细信息，请参阅配置报表服务器服务帐户。

将数据库连接配置为使用服务帐户时，如果报表服务器数据库位于远程计算机上，则帐户必须拥有网络权限。如果报表服务器数据库位于不同的域中，并且位于防火墙之后，或者您使用的是工作组安全性而非域安全性，则不要使用服务帐户。请改用 SQL Server 数据库用户帐户。

使用域用户帐户

可以为报表服务器到报表服务器数据库的连接指定一个 Windows 用户帐户。如果使用本地帐户或域帐户，则每次更改密码或帐户时，必须更新报表服务器数据库连接。请始终使用 Reporting Services 配置工具来更新连接。

使用 SQL Server 登录名

可以指定使用一个 SQL Server 登录名连接到报表服务器数据库。如果使用 SQL Server 身份验证并且报表服务器数据库位于远程计算机上，则可以使用 IPSec 来协助保护服务器之间的数据传输。如果使用数据库登录名，则每次更改密码或帐户时，必须更新报表服务器数据库连接。

数据库权限

用来连接到报表服务器数据库的帐户被授予了以下角色：

  • ReportServer 数据库的 public 和 RSExecRole 角色。

  • master、msdb 和 ReportServerTempDB 数据库的 RSExecRole 角色。

使用 Reporting Services 配置工具创建或修改连接时，将自动授予这些权限。如果使用 rsconfig 实用工具并且要为该连接指定不同的帐户，则必须为该新帐户更新 SQL Server 登录名。可以在 Reporting Services 配置工具中创建用来更新报表服务器的 SQL Server 登录名的脚本文件。

验证数据库名称

使用 Reporting Services 配置工具可以确定特定报表服务器实例所使用的报表服务器数据库。若要查找该名称，请连接到该报表服务器实例并打开“数据库安装”页。

使用不同的报表服务器数据库或移动报表服务器数据库

可以通过更改连接信息将报表服务器实例配置为使用不同的报表服务器数据库。切换数据库的一个常见示例是部署生产报表服务器。通常，生产服务器是通过从测试报表服务器数据库切换到生产报表服务器数据库来实现的。您还可以将报表服务器数据库移动到另一台计算机上。有关详细信息，请参阅 SQL Server 联机丛书中的将报表服务器数据库移至其他计算机和迁移 (Reporting Services)。

将多个报表服务器配置为使用同一个报表服务器数据库

可以将多个报表服务器配置为使用同一个报表服务器数据库。此部署配置称为扩展部署。如果要在服务器群集中运行多个报表服务器，则此配置为必备条件。但是，如果要将服务应用程序分段，或者要测试新的报表服务器实例的安装和设置以将其与现有报表服务器安装进行比较，则也以可使用此配置。有关详细信息，请参阅为扩展部署配置 Reporting Services。

请参阅

概念

创建报表服务器数据库
Reporting Services 配置操作指南主题
配置报表服务器服务帐户

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


配置报表服务器以进行电子邮件传递

配置报表服务器以进行电子邮件传递 |
 | 请参阅
配置 Reporting Services >

Reporting Services 包括电子邮件传递扩展插件，以便可以通过电子邮件分发报表。根据定义电子邮件订阅的方式，传递可能由通知、链接、附件或嵌入报表组成。电子邮件传递扩展插件可与现有的邮件服务器技术一起使用。邮件服务器必须是 SMTP 服务器或转发器。报表服务器通过操作系统提供的协作数据对象 (CDO) 库 (cdosys.dll) 连接到 SMTP 服务器。

默认情况下，未配置报表服务器电子邮件传递扩展插件。必须使用 Reporting Services 配置工具对此扩展插件进行最低配置。若要设置高级属性，必须编辑 RSReportServer.config 文件。如果无法将报表服务器配置为使用此扩展插件，则可以将报表传递到共享文件夹。有关详细信息，请参阅 SQL Server 联机丛书中的Reporting Services 中的文件共享传递。

配置要求

  • 报表服务器电子邮件传递在协作数据对象 (CDO) 上实现，且需要本地或远程的简单邮件传输协议 (SMTP) 服务器或 SMTP 转发器。所有 Windows 操作系统都不支持 SMTP。如果使用的是基于 Itanium 的 Windows Server 2008 版本，则也不支持 SMTP。有关通过 CDO 提供的配置选项的详细信息，请参阅 MSDN 上的 Configuration（配置）。

  • 报表服务器服务帐户必须对 SMTP 服务器拥有权限才能发送邮件。

  • 电子邮件传递扩展插件在电子邮件附件中使用 UTF-8 编码。您无法修改此编码；HTML 呈现扩展插件仅支持 UTF-8。

注意：
默认电子邮件传递扩展插件不支持给待发邮件进行数字签名或加密。

为本地或远程的 SMTP 服务配置报表服务器

可以使用本地 SMTP 服务或远程 SMTP 服务器或转发器来支持电子邮件传递。如果具有现有远程 SMTP 服务器的访问权限，则应该考虑使用该服务器。若没有可用的 SMTP 服务器或随后由于计算机连接失败而遇到报表传递错误，则应该进行切换以使用本地 SMTP 服务。有关如何为本地或远程服务配置报表服务器的详细信息，将稍后在本主题中进一步说明。

为电子邮件传递设置配置选项

必须先设置确定使用哪一个 SMTP 服务器的配置值，才能使用报表服务器电子邮件传递。

若要针对电子邮件传递配置报表服务器，请执行下列操作：

  • 如果要仅指定一个 SMTP 服务器和一个具有发送电子邮件权限的用户帐户，则使用 Reporting Services 配置工具。以下是配置报表服务器电子邮件传递扩展插件所需的最低设置。有关详细信息，请参阅如何配置报表服务器以进行电子邮件传递（Reporting Services 配置）。

  • （可选）使用文本编辑器在 RSreportserver.config 文件中指定其他设置。此文件包含报表服务器电子邮件传递的所有配置设置。如果要使用本地 SMTP 服务器或将电子邮件限定传递到特定主机，则需要在这些文件中指定其他设置。有关查找和修改配置文件的详细信息，请参阅 SQL Server 联机丛书中的如何修改 Reporting Services 配置文件。

注意：
报表服务器电子邮件设置都是基于 CDO。若要了解有关特定设置的更多详细信息，可以参考 CDO 产品文档。

报表服务器电子邮件配置示例

下面的示例说明了远程 SMTP 服务器的 RSreportserver.config 文件中的设置：若要了解设置说明及有效值，请参阅 SQL Server 联机丛书中的 RSReportServer 配置文件或 CDO 产品文档。

复制代码
<RSEmailDPConfiguration>
     <SMTPServer>mySMTPServer.Adventure-Works.com</SMTPServer>
     <SMTPServerPort></SMTPServerPort>
     <SMTPAccountName></SMTPAccountName>
     <SMTPConnectionTimeout></SMTPConnectionTimeout>
     <SMTPServerPickupDirectory></SMTPServerPickupDirectory>
     <SMTPUseSSL></SMTPUseSSL>
     <SendUsing>2</SendUsing>
     <SMTPAuthenticate></SMTPAuthenticate>
     <From>my-rs-email-account@Adventure-Works.com</From>
     <EmbeddedRenderFormats>
          <RenderingExtension>MHTML</RenderingExtension>
     </EmbeddedRenderFormats>
     <PrivilegedUserRenderFormats></PrivilegedUserRenderFormats>
     <ExcludedRenderFormats>
          <RenderingExtension>HTMLOWC</RenderingExtension>
          <RenderingExtension>NULL</RenderingExtension>
     </ExcludedRenderFormats>
     <SendEmailToUserAlias>True</SendEmailToUserAlias>
     <DefaultHostName></DefaultHostName>
     <PermittedHosts>
          <HostName>Adventure-Works.com</HostName>
          <HostName>hotmail.com</HostName>
     </PermittedHosts>
</RSEmailDPConfiguration>

用于在邮件中设置“收件人:”字段的配置选项

根据“管理单独的订阅”任务授予的权限而创建的用户定义订阅包含基于域用户帐户的预设用户名。用户创建订阅时，“收件人:”字段中的收件人姓名会使用创建该订阅的人员的域用户帐户自行转换为地址。

如果您所用的 SMTP 服务器或转发器使用了不同于域用户帐户的电子邮件帐户，则 SMTP 服务器尝试将报表传递给该用户时，报表传递会失败。

若要解决该问题，可以修改允许用户在“收件人:”字段中输入名称的配置设置：

  1. 使用文本编辑器打开 RSReportServer.config。

  2. 将 SendEmailToUserAlias 设置为 False。

  3. 将 DefaultHostName 设置为 SMTP 服务器或转发器的域名系统 (DNS) 名称或 IP 地址。

  4. 保存该文件。

远程 SMTP 服务的配置选项

报表服务器与 SMTP 服务器或转发器之间的连接是由下列配置设置决定的：

  • SendUsing 指定发送邮件的方法。您可以选择网络 SMTP 服务或本地 SMTP 服务拾取目录。若要使用远程 SMTP 服务，必须在 RSReportServer.config 文件中将此值设置为 2。

  • SMTPServer 指定远程 SMTP 服务器或转发器。如果使用远程 SMTP 服务器或转发器，则必须指定此值。

  • “发件人”用于设置显示在电子邮件的“发件人:”行中的值。如果使用远程 SMTP 服务器或转发器，则必须指定此值。

其他用于远程 SMTP 服务的值包括以下值（请注意，除非您要覆盖默认值，否则无需指定这些值）：

  • SMTPServerPort 配置为端口 25。

  • SMTPAuthenticate 指定如何将报表服务器连接到远程 SMTP 服务器。默认值为 0（或不进行身份验证）。这种情况下，将通过匿名访问创建连接。报表服务器和 SMTP 服务器可能需要成为同一域的成员，这取决于域配置。

    若要向受限制的通讯组列表发送电子邮件（例如，只接受经过身份验证的帐户发来的邮件的通讯组列表），则将 SMTPAuthenticate 设置为 2。

本地 SMTP 服务的配置选项

若要测试报表服务器电子邮件传递或解决所遇到的疑难问题，则配置本地 SMTP 服务会很有用。默认情况下，不启用本地 SMTP 服务。有关如何启用该服务的说明，请参阅如何配置报表服务器以进行电子邮件传递（Reporting Services 配置）。

报表服务器与本地 SMTP 服务器或转发器之间的连接是由下列配置设置决定的：

  • 将 SendUsing 设置为 1。

  • 将 SMTPServerPickupDirectory 设置为本地驱动器中的文件夹。

    注意：
    如果正在使用本地 SMTP 服务器，请确保不要设置 SMTPServer。

  • “发件人”用于设置显示在电子邮件的“发件人:”行中的值。此值是必需的。

请参阅

任务

如何启动 Reporting Services 配置
如何配置报表服务器以进行电子邮件传递（Reporting Services 配置）

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


配置无人参与的执行帐户

配置无人参与的执行帐户 |
 | 请参阅
配置 Reporting Services >

Reporting Services 提供一个特殊帐户，用于进行无人参与的报表处理和通过网络发送连接请求。可以通过下列方式使用该帐户：

  • 通过网络为使用数据库身份验证的报表发送连接请求，或连接到不需要或不使用身份验证的外部报表数据源。有关详细信息，请参阅 SQL Server 联机丛书中的为报表的数据源指定凭据和连接信息。

  • 检索在报表中使用的外部图像文件。如果您要使用图像文件并且无法通过匿名访问来访问该文件，则可以配置无人参与的报表处理帐户并授予该帐户访问该文件的权限。有关如何使用无人参与的执行帐户检索图像的详细信息，请参阅 SQL Server 联机丛书中的向报表添加图像。

无人参与的报表处理是指任何由事件（计划驱动事件或数据刷新事件）而不是用户请求触发的报表执行过程。报表服务器使用无人参与的报表处理帐户来登录承载外部数据源的计算机。由于报表服务器服务帐户从不用于连接到其他计算机，因此该帐户是必需的。

重要提示：
配置该帐户的过程为可选操作。但是，如果不配置该帐户，用于连接到某些数据源的选项会受到限制，并且可能无法从远程计算机检索图像文件。如果配置了该帐户，则必须对其进行不断更新。具体来说，如果允许密码过期或在 Active Directory 中更改了帐户信息，则在下次处理报表时将遇到以下错误：“登录失败 (rsLogonFailed) 登录失败: 未知的用户名或密码不正确。”即使您从不检索外部图像也不向外部计算机发送连接请求，正确维护无人参与的报表处理帐户也是必要的。如果配置了该帐户但后来发现不需要使用它，则可以将其删除以避免日常的帐户维护任务。

如何配置帐户

必须使用域用户帐户。若要发挥该帐户应有的作用，它应不同于用于运行报表服务器服务的帐户。请确保使用具有如下特征的帐户：对为报表服务器提供数据源和资源的那些计算机只拥有最小权限（具有网络连接权限的只读访问权限就已足够）和有限访问权限。有关详细信息，请参阅如何启动 Reporting Services 配置。

若要指定帐户，可使用 Reporting Services 配置工具或 rsconfig 实用工具。配置无人参与的执行帐户的最简便方法是运行 Reporting Services 配置工具，然后在“执行帐户”页中指定凭据。

  1. 启动 Reporting Services 配置工具，然后连接到要配置的报表服务器实例。有关说明，请参阅如何启动 Reporting Services 配置。

  2. 在“执行帐户”页上，选择“指定执行帐户”。

  3. 键入帐户和密码，再次键入密码，然后单击“应用”。

使用 RSCONFIG 实用工具

设置帐户的另一种方法是使用 rsconfig 实用工具。若要指定该帐户，请使用 rsconfig 的 -e 参数。为 rsconfig 指定 -e 参数可强制该实用工具将帐户信息写入到配置文件中。您无需指定 RSreportserver.config 的路径。请按照以下步骤来配置该帐户。

  1. 创建或选择一个有权访问为报表服务器提供数据或服务的计算机和服务器的域帐户。您应使用权限受到限制（如只读权限）的帐户。

  2. 打开命令提示符窗口：在“开始”菜单上，单击“运行”，键入 cmd，再单击“确定”。

  3. 键入以下命令，为本地报表服务器实例配置该帐户：

    rsconfig -e -u< 域 / 用户名 > -p< 密码 >

rsconfig -e 支持其他参数。若要获取有关语法的详细信息和查看命令示例，请参阅 SQL Server 联机丛书中的 rsconfig 配置工具。

帐户信息的存储方式

设置帐户后，将在本地或远程报表服务器实例上的 RSreportserver.config 文件中以加密值的形式指定以下设置：

复制代码
<UnattendedExecutionAccount>
     <UserName></UserName>
     <Password></Password>
     <Domain></Domain>
</UnattendedExecutionAccount>

设置值后，将无法通过解密以纯文本的形式查看这些值。如果输错了值或忘记了指定的值，则必须使用 Reporting Services 配置工具或运行 rsconfig -e 重新设置。

无人参与的报表处理帐户的使用方法

若要检索图像文件，报表服务器将自动使用该帐户，您不需要执行任何具体操作。若要使用此帐户连接到为报表提供数据的外部数据源，则必须在报表数据源或共享数据源的“数据源属性”页中指定“凭据类型”选项：

  • 在报表管理器或 SharePoint 站点中，选择“不需要凭据”选项。

无人参与的报表处理帐户主要用于连接到外部服务器，而不是用作数据库服务器的登录名。如果要使用此帐户凭据登录到数据库，则必须在连接字符串中指定凭据。如果数据库服务器支持 Windows 集成安全性，并且用于无人参与报表处理的帐户拥有数据库读取权限，则可以指定 Integrated Security=SSPI。否则，必须在连接字符串中输入用户名和密码，该字符串对拥有数据源连接属性编辑权限的任何用户均显示为明文形式。

虽然系统不会阻止您使用无人参与的报表处理帐户在建立连接后检索数据，但是不建议这样做。该帐户应该用于非常具体的功能。如果使用该帐户检索数据，则有违本意。

无人参与的报表处理帐户的维护方法

定义此帐户后，必须确保不断更新此帐户和密码。可以使用 Reporting Services 配置工具来更新用于存储此帐户相关信息的配置设置。

  1. 启动 Reporting Services 配置工具，然后连接到要配置的报表服务器实例。

  2. 在“执行帐户”页上，确认已选中“指定执行帐户”。

  3. 键入新帐户或密码，再次键入密码，然后单击“应用”。

无人参与的报表处理帐户的删除方法

如果您不需要使用该帐户，则可以将其删除以避免日常的帐户维护任务。

  1. 启动 Reporting Services 配置工具，然后连接到要配置的报表服务器实例。

  2. 在“执行帐户”页上，清除“指定执行帐户”。

  3. 单击“应用”。

将从 RSReportServer.config 文件中删除此帐户的信息。

请参阅

概念

配置 Reporting Services

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


配置和管理加密密钥

配置和管理加密密钥 |
 | 请参阅
配置 Reporting Services >

Reporting Services 使用加密密钥来保护存储在报表服务器数据库中的凭据和连接信息。在 Reporting Services 中，通过一组用于保护敏感数据的公钥、私钥和对称密钥支持加密。安装或配置报表服务器时，在报表服务器初始化期间会创建对称密钥，报表服务器使用此对称密钥对存储在报表服务器中的敏感数据进行加密。公钥和私钥由操作系统创建，用于保护对称密钥。对于在报表服务器数据库中存储敏感数据的每个报表服务器实例，都要创建一个公钥私钥对。

管理加密密钥包括创建对称密钥的备份副本以及了解密钥的还原、删除或更改的时间和方式。如果迁移报表服务器安装或配置扩展部署，则必须拥有对称密钥的备份副本，以便可以将其应用于新的安装。

若要管理对称密钥，可以使用 Reporting Services 配置工具或 rskeymgmt 实用工具。Reporting Services 中包括的工具仅用于管理对称密钥（公钥和私钥由操作系统管理）。Reporting Services 配置工具和 rskeymgmt 实用工具都支持以下任务：

  • 备份对称密钥的副本，以便可以使用该副本来恢复报表服务器安装或作为计划迁移的一部分。

  • 将以前保存的对称密钥还原到报表服务器数据库，以允许新的报表服务器实例访问最初不是由其进行加密的现有数据。

  • 在无法再访问加密数据时删除报表服务器数据库中的加密数据，这种情况极少出现。

  • 当对称密钥遭到破坏时重新创建对称密钥并重新加密数据，这种情况极少出现。作为安全性方面的最佳做法，您应定期（例如，每隔几个月）重新创建对称密钥，以保护报表服务器数据库，使其能够抵御试图解开密钥的网络攻击。

  • 在报表服务器扩展部署（多个报表服务器同时共享一个报表服务器数据库以及为该数据库提供可逆加密的对称密钥）中添加或删除报表服务器实例。

本节内容

初始化报表服务器

介绍如何创建加密密钥。

备份和还原加密密钥

介绍如何备份加密密钥以及如何还原备份以恢复或迁移报表服务器安装。

存储加密的报表服务器数据

介绍报表服务器的加密。

删除和重新创建加密密钥

介绍如何用新版本替换对称密钥以及在无法验证对称密钥时如何重新开始。

添加和删除扩展部署的加密密钥

介绍如何添加和删除加密密钥以控制在扩展部署中包括哪些报表服务器。

请参阅

概念

存储加密的报表服务器数据

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


初始化报表服务器

初始化报表服务器 |
 | 请参阅
配置 Reporting Services > 配置和管理加密密钥 >

在 Reporting Services 中，已初始化的服务器是指可以在报表服务器数据库中加密和解密数据的服务器。初始化是一项必需的报表服务器操作。初始化在报表服务器服务第一次启动时发生。在将报表服务器联接到现有部署，或在恢复进程中手动重新创建密钥时也需要进行初始化。有关如何使用加密密钥以及为什么使用加密密钥的详细信息，请参阅配置和管理加密密钥和存储加密的报表服务器数据。

加密密钥部分基于报表服务器服务的配置文件信息。如果更改用于运行报表服务器服务的用户标识，则必须相应地更新密钥。如果使用 Reporting Services 配置工具更改标识，将自动处理此步骤。

如果由于某些原因导致初始化失败，则报表服务器在响应用户和服务请求时将返回 RSReportServerNotActivated 错误。这种情况下，可能需要排除系统或服务器配置故障。有关详细信息，请参阅 SQL Server 联机丛书中的初始化和加密密钥错误故障排除。

初始化过程概述

初始化过程将创建并存储一个用于加密的对称密钥。对称密钥由 Microsoft Windows 加密服务创建，随后由报表服务器服务用来加密和解密数据。对称密钥本身通过非对称密钥进行加密。

以下步骤描述了初始化过程：

  1. 在初始启动时，报表服务器服务读取 RSReportServer.config 文件以获取安装标识符和数据库连接信息。

  2. 报表服务器服务从加密服务请求公钥。Windows 创建私钥和公钥并将公钥发送到报表服务器服务。

  3. 报表服务器服务连接到报表服务器数据库并存储安装标识符和公钥值。

  4. 报表服务器服务再次调入加密服务，这次是请求对称密钥。Windows 创建对称密钥。

  5. 报表服务器服务再次连接到报表服务器数据库，并将对称密钥添加到步骤 3 中存储的公钥和安装标识符值中。在存储对称密钥之前，报表服务器服务使用其公钥对对称密钥进行加密。存储对称密钥后，即可将报表服务器视为已初始化，并且可供使用。

针对扩展部署初始化报表服务器

Reporting Services 支持在多个报表服务器实例中共享单个报表服务器数据库的扩展部署模型。若要联接扩展部署，报表服务器必须在共享数据库中创建并存储其对称密钥副本。尽管使用该数据库的服务器都使用同一个对称密钥，但是每个报表服务器都有自己的密钥副本。每个副本各不相同，因为这些副本都使用其各自拥有的公钥进行了唯一加密。

针对扩展部署初始化报表服务器的开始步骤与描述初始化单个服务器和数据库组合的前三个步骤相同。

扩展部署初始化过程的不同之处在于报表服务器获取对称密钥的方式。在初始化第一个服务器时，它从 Windows 获取对称密钥。在配置扩展部署的过程中，在初始化第二个服务器时，它将从已初始化的报表服务器服务中获取对称密钥。第一个报表服务器实例使用第二个实例的公钥来为第二个报表服务器实例创建对称密钥的加密副本。在此过程中的任何一点，对称密钥永远不会作为纯文本公开。

如何初始化报表服务器

  • 若要初始化报表服务器，请使用 Reporting Services 配置工具。在创建和配置报表服务器数据库时，将自动进行初始化。有关详细信息，请参阅配置报表服务器数据库连接。

  • 若要针对扩展部署初始化报表服务器，可以使用 Reporting Services 配置工具中的“初始化”页或使用 RSKeymgmt 实用工具。若要按照逐步说明操作，请参阅如何配置报表服务器扩展部署（Reporting Services 配置）。

注意：
RSKeymgmt 是一种控制台应用程序，需要在已作为扩展部署的一部分的报表服务器实例所驻留的计算机上从命令行运行。运行该实用工具时，需要指定相关参数，以选择要初始化的远程报表服务器实例。

只有当安装标识符与公钥相匹配时，才会初始化报表服务器。如果匹配成功，则创建允许可逆加密的对称密钥。如果匹配失败，则将禁用报表服务器，在这种情况下，可能需要应用备份密钥；如果备份密钥不可用或无效，则可能需要删除加密数据。有关报表服务器所使用的加密密钥的详细信息，请参阅配置和管理加密密钥。

注意：
还可以使用 Reporting Services Windows Management Instrumentation (WMI) 提供程序以编程的方式初始化报表服务器。有关详细信息，请参阅 SQL Server 联机丛书中的Reporting Services WMI 提供程序。

如何确认报表服务器初始化

若要确认报表服务器初始化，请通过在命令窗口中键入 http://<服务器名>/reportserver 来对报表服务器 Web 服务运行 ping 命令。如果发生 RSReportServerNotActivated 错误，则表示初始化失败。

请参阅

概念

存储加密的报表服务器数据

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


存储加密的报表服务器数据

存储加密的报表服务器数据 |
 | 请参阅
配置 Reporting Services > 配置和管理加密密钥 >

注意 对于 SQL Server 2008 R2，没有对本主题中所列的内容进行任何更改。

Reporting Services 将加密值存储在报表服务器数据库和配置文件中。大多数加密值都是用于访问向报表提供数据的外部数据源的凭据。本主题介绍对哪些值进行了加密、Reporting Services 中使用的加密功能以及您应当了解的其他类型的已存储机密数据。

加密值

下面列出了 Reporting Services 安装中所存储的值。

  • 报表服务器用于连接到报表服务器数据库（存储内部服务器数据）的连接信息和凭据。

    这些值是在安装过程中或报表服务器配置期间指定和加密的。您可以在任何时候使用 Reporting Services 配置工具或 rsconfig 配置工具更新连接信息。对配置设置的加密则是使用对所有用户都可用的本地计算机的计算机级密钥来执行的。加密的报表服务器连接信息存储在 rsreportserver.config 文件中（其他任何配置文件都不会包含加密设置）。有关详细信息，请参阅 配置报表服务器数据库连接。

  • 报表服务器用于连接到向报表提供数据的外部数据源的存储凭据。

    这些值是在您为报表配置数据源信息时定义的，随后会以加密值的形式存储在报表服务器数据库中。报表服务器使用对称密钥对这些数据进行加密和解密。有关存储的凭据的详细信息，请参阅 SQL Server 联机丛书中的 规划服务、帐户和连接和为报表的数据源指定凭据和连接信息。

  • 报表服务器用于连接到其他计算机以检索报表中使用的外部图像文件或外部数据的无人参与用户帐户。

    当需要连接到远程计算机且没有其他可用于连接的凭据时，可使用此帐户。此帐户主要用于支持对不使用凭据即可访问数据源的报表进行无人参与处理。如果创建报表所依据的数据源在访问数据时不要求或使用凭据，则必须配置此帐户才能使用报表服务器。

    此帐户在某些环境下是必需的，并且只能通过 Reporting Services 配置工具或 rsconfig 进行创建。此值还会存储在 rsreportserver.config 文件中。您必须手动创建此帐户。有关此帐户及其用法的详细信息，请参阅配置无人参与的执行帐户。

  • 用于加密的对称密钥。

    此值是在安装过程中或服务器配置期间创建的，随后会以加密值的形式存储在报表服务器数据库中。报表服务器 Windows 服务使用此密钥对存储在报表服务器数据库中的数据进行加密和解密。

Reporting Services 中的加密功能

Reporting Services 使用 Windows 操作系统提供的加密功能。包括对称加密和非对称加密。

报表服务器数据库中的数据使用对称密钥进行加密。每个报表服务器数据库只有一个对称密钥。此对称密钥使用 Windows 生成的非对称密钥对的公钥进行自加密。私钥由 Report Server Windows 服务帐户持有。

在多个报表服务器实例共享同一个报表服务器数据库的报表服务器扩展部署中，所有报表服务器节点都使用一个对称密钥。每个节点必须具有一个共享对称密钥的副本。配置扩展部署时，将为每个节点自动创建一个对称密钥副本。每个节点都使用 Windows 服务帐户专有密钥对的公钥来加密对称密钥的副本。若要详细了解如何为单个实例和扩展部署创建对称密钥，请参阅初始化报表服务器。

注意：
如果更改 Report Server Windows 服务帐户，则非对称密钥将变为无效，从而中断服务器操作。为了避免此类故障，请始终使用 Reporting Services 配置工具来修改服务帐户设置。使用配置工具时，密钥会自动更新。有关详细信息，请参阅配置报表服务器服务帐户。

其他机密数据源

报表服务器中还存储有其他可能包含需保护的敏感信息的未加密数据。具体来说，报表历史记录快照和报表执行快照包含的查询结果可能包括仅供授权用户使用的数据。因此，对包含机密数据的报表使用快照功能时，需要注意，有权打开报表服务器数据库中的表的用户也能通过检查表的内容来查看所存储报表的部分内容。

注意：
对于所用参数基于用户安全标识的报表，Reporting Services 不支持缓存或报表历史记录。

请参阅

概念

配置和管理加密密钥

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


备份和还原加密密钥

备份和还原加密密钥 |
 | 请参阅
配置 Reporting Services > 配置和管理加密密钥 >

报表服务器配置的一个重要部分是为用于加密敏感信息的对称密钥创建备份副本。该密钥的备份副本对许多例程操作来说是必需的，通过使用备份副本，您可以在新的安装中重用现有报表服务器数据库。在发生以下任何事件时，必须还原加密密钥的备份副本：

  • 更改报表服务器 Windows 服务帐户名或重置密码。使用 Reporting Services 配置工具时，对该密钥进行备份是服务帐户名称更改操作的一部分。

    注意：
    重置密码不同于更改密码。密码重置需要相应的权限以覆盖域控制器上的帐户信息。密码重置在您忘记或不知道特定密码时由系统管理员执行。只有密码重置才需要还原对称密钥。定期更改帐户密码不需要重置对称密钥。

  • 重命名承载报表服务器的计算机或实例（报表服务器实例基于 SQL Server 实例名）。

  • 迁移报表服务器安装或配置报表服务器以使用其他报表服务器数据库。

  • 由于硬件故障而恢复报表服务器安装。

只需要备份对称密钥的一个副本。报表服务器数据库和对称密钥之间存在一对一的对应关系。尽管只需要备份一个副本，但如果在扩展部署模型中运行多个报表服务器，则可能需要多次还原密钥。每个报表服务器实例都需要具有自己的对称密钥副本，才能对报表服务器数据库中的数据进行锁定和解锁。

将加密密钥备份到磁盘

备份对称密钥是将密钥写入所指定的文件，然后使用所提供的密码对密钥进行加密的过程。对称密钥绝对不能在未加密状态下存储，所以在将它保存到磁盘时，必须提供密码对密钥进行加密。创建文件后，必须将其存储在安全的位置，并记住用于对文件进行解锁的密码。若要备份对称密钥，可以使用 Reporting Services 配置工具或 rskeymgmt 实用工具。

如何备份加密密钥（Reporting Services 配置工具）

  1. 启动 Reporting Services 配置工具，再连接到要配置的报表服务器实例。

  2. 单击“加密密钥”，再单击“备份”。

  3. 键入强密码。

  4. 指定用来包含所存储密钥的文件。Reporting Services 将向该文件追加 .snk 文件扩展名。请考虑将文件存储在软盘上，以使其与报表服务器隔开。

  5. 单击“确定”。

如何备份加密密钥 (rskeymgmt)

  1. 如果希望将密码保护的文件与报表服务器分开存储，请将软盘插入软盘驱动器中。

  2. 在承载报表服务器的计算机上本地运行 rskeymgmt.exe。必须使用 -e 提取参数复制密钥，提供文件名并指定密码。下面的示例阐释了必须指定的参数：

    复制代码
    rskeymgmt -e -f a:\rsdbkey.snk -p<password>
  3. 将软盘存放在安全的位置。

还原加密密钥

还原对称密钥将覆盖存储在报表服务器数据库中的现有对称密钥。还原加密密钥将用以前保存到磁盘上的副本来替换无法使用的密钥。还原加密密钥将导致以下操作：

  • 从密码保护的备份文件中打开对称密钥。

  • 使用报表服务器 Windows 服务的公钥加密对称密钥。

  • 将加密的对称密钥存储到报表服务器数据库中。

  • 删除以前存储的对称密钥数据（例如，在以前部署的报表服务器数据库中已存在的密钥信息）。

若要还原加密密钥，必须具有保存在文件中的加密密钥副本。还必须知道用来对存储的副本进行解锁的密码。如果有了密钥和密码，则可以运行 Reporting Services 配置工具或 rskeymgmt 实用工具来还原密钥。该对称密钥必须与用来对报表服务器数据库中当前存储的加密数据进行锁定和解锁的密钥相同。如果还原的副本无效，则报表服务器将无法访问报表服务器数据库中当前存储的加密数据。在这种情况下，如果无法恢复有效的密钥，则最好删除所有加密值。如果由于某些原因（例如，如果没有备份副本）而无法还原加密密钥，则必须删除现有密钥和加密内容。有关详细信息，请参阅 删除和重新创建加密密钥。有关创建对称密钥的详细信息，请参阅初始化报表服务器。

如何还原加密密钥（Reporting Services 配置工具）

  1. 启动 Reporting Services 配置工具，再连接到要配置的报表服务器实例。

  2. 在“加密密钥”页上，单击“还原”。

  3. 选择包含备份副本的 .snk 文件。

  4. 键入用于解锁该文件的密码。

  5. 单击“确定”。

如何还原加密密钥 (rskeymgmt)

  1. 插入包含加密密钥备份副本的软盘。

  2. 在承载报表服务器的计算机上本地运行 rskeymgmt.exe。使用 -a 参数还原密钥。必须提供完全限定的文件名，并指定密码。下面的示例阐释了必须指定的参数：

    复制代码
    rskeymgmt -a -f a:\rsdbkey.snk -p<password>

请参阅

概念

配置和管理加密密钥

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


删除和重新创建加密密钥

删除和重新创建加密密钥 |
 | 请参阅
配置 Reporting Services > 配置和管理加密密钥 >

删除和重新创建加密密钥不属于加密密钥例行维护活动。您可以为了响应对报表服务器的特定威胁来执行这些任务，或者当无法访问报表服务器数据库时作为最后一种解决手段来执行这些任务。

  • 当确信现有对称密钥的安全受到威胁时，应重新创建对称密钥。作为安全性方面的最佳做法，您还可以定期重新创建密钥。

  • 当无法还原对称密钥时，应删除现有加密密钥和不可用的加密内容。

重新创建加密密钥

如果确认对称密钥已泄露给未经授权的用户，或者报表服务器遭到攻击，作为一种防范措施，您想要重置对称密钥，那么可以重新创建对称密钥。当重新创建对称密钥时，将使用新值对所有加密值重新进行加密。如果在扩展部署中运行了多个报表服务器，则对称密钥的所有副本都将更新为新值。报表服务器使用可用的公钥更新部署中每一台服务器的对称密钥。

只有在报表服务器处于工作状态时，才能重新创建对称密钥。重新创建加密密钥以及重新对内容进行加密将会中断服务器的操作。在进行重新加密时，必须将服务器脱机。在重新加密过程中，不应该向报表服务器发送请求。

可以使用 Reporting Services 配置工具或 rskeymgmt 实用工具重置对称密钥和加密的数据。有关如何创建对称密钥的详细信息，请参阅初始化报表服务器。

如何重新创建加密密钥（Reporting Services 配置工具）

  1. 通过修改 rsreportserver.config 文件中的 IsWebServiceEnabled 属性禁用报表服务器 Web 服务和 HTTP 访问。此步骤可暂时停止将身份验证请求发送到报表服务器而不会完全关闭服务器。您必须具有最低限度的服务，以便可以重新创建密钥。

    如果要为报表服务器扩展部署重新创建加密密钥，请对该部署中的所有实例禁用此属性。

    1. 打开 Windows 资源管理器，导航到 drive:\Program Files\Microsoft SQL Server\report_server_instance\Reporting Services。将 drive 替换为您的驱动器号，并将 report_server_instance 替换为与要禁用其 Web 服务和 HTTP 访问的报表服务器实例对应的文件夹名称。例如，C:\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services。

    2. 打开 rsreportserver.config 文件。

    3. 对于 IsWebServiceEnabled 属性，指定为 False，然后保存所做的更改。

  2. 启动 Reporting Services 配置工具，再连接到要配置的报表服务器实例。

  3. 在“加密密钥”页上，单击“更改”。单击“确定”。

  4. 重新启动报表服务器 Windows 服务。如果要为扩展部署重新创建加密密钥，请在所有实例上重新启动该服务。

  5. 通过修改 rsreportserver.config 文件中的 IsWebServiceEnabled 属性，重新启用 Web 服务和 HTTP 访问。如果使用的是扩展部署，请对所有实例执行此操作。

如何重新创建加密密钥 (rskeymgmt)

  1. 禁用报表服务器 Web 服务和 HTTP 访问。使用以上过程中的说明停止 Web 服务操作。

  2. 在承载报表服务器的计算机上本地运行 rskeymgmt.exe。使用 -s 参数重置对称密钥。不需要其他参数：

    复制代码
    rskeymgmt -s
  3. 重新启动 Windows 服务，并启用 Web 服务操作。

删除无用的加密内容

如果由于某些原因无法还原加密密钥，报表服务器将永远无法解密和使用由该密钥加密的所有数据。若要将报表服务器还原到工作状态，必须删除当前存储在报表服务器数据库中的加密值，然后手动重新指定需要的值。

删除加密密钥会将所有对称密钥信息从报表服务器数据库中删除，并会删除所有加密内容。所有未加密的数据都将保持不变；只有加密内容被删除。删除加密密钥时，报表服务器通过添加新的对称密钥自动对自身进行重新初始化。删除加密内容时，会出现以下情况：

  • 共享数据源中的连接字符串被删除。运行报表的用户得到错误消息“ConnectionString 属性尚未初始化”。

  • 存储的凭据被删除。报表和共享数据源重新配置为使用所提示的凭据。

  • 基于模型（且需要共享数据源配置为使用存储的凭据或不使用凭据）的报表将不会运行。

  • 订阅被停用。

加密内容一旦被删除，便无法恢复。必须重新指定连接字符串和存储的凭据，并且必须激活订阅。

可以使用 Reporting Services 配置工具或 rskeymgmt 实用工具删除值。

如何删除加密密钥（Reporting Services 配置工具）

  1. 启动 Reporting Services 配置工具，再连接到要配置的报表服务器实例。

  2. 单击“加密密钥”，再单击“删除”。单击“确定”。

  3. 重新启动报表服务器 Windows 服务。对于扩展部署，应对所有报表服务器实例执行此操作。

如何删除加密密钥 (rskeymmgt)

  1. 在承载报表服务器的计算机上本地运行 rskeymgmt.exe。必须使用 -d 应用参数。下面的示例说明了必须指定的参数：

    复制代码
    rskeymgmt -d
  2. 重新启动报表服务器 Windows 服务。对于扩展部署，应对所有报表服务器实例执行此操作。

如何重新指定加密值

  1. 对于每个共享数据源，必须重新键入连接字符串。

  2. 对于每个使用存储的凭据的报表和共享数据源，必须重新键入用户名和密码，然后再保存。有关详细信息，请参阅 SQL Server 联机丛书中的为报表的数据源指定凭据和连接信息。

  3. 对于每个数据驱动订阅，打开每个订阅，再重新键入订阅数据库的凭据。

  4. 对于使用加密数据的订阅（其中包括文件共享传递扩展插件和使用加密的任何第三方传递扩展插件），打开每个订阅，再重新键入凭据。使用报表服务器电子邮件传递的订阅不使用加密数据，因而不受密钥更改的影响。

请参阅

概念

配置和管理加密密钥
存储加密的报表服务器数据

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


添加和删除扩展部署的加密密钥

添加和删除扩展部署的加密密钥 |
 | 请参阅
配置 Reporting Services > 配置和管理加密密钥 >

通过将多个报表服务器配置为使用一个共享的报表服务器数据库，可以在扩展部署模型中运行 Reporting Services。扩展部署中的成员身份是基于报表服务器是否将加密密钥存储在报表服务器数据库中。通过为特定的报表服务器实例添加和删除加密密钥，可以控制扩展部署成员身份。如果要从部署中删除节点，则可以按任意顺序进行删除。如果要向部署中添加节点，则必须联接已作为部署的一部分的报表服务器中的所有新实例。

使用 Reporting Services 配置工具配置扩展部署

配置扩展部署的最简单方法是使用 Reporting Services 配置工具。有关详细信息和分步说明，请参阅为扩展部署配置 Reporting Services和如何配置报表服务器扩展部署（Reporting Services 配置）。

使用 Rskeymgmt 配置扩展部署

使用 rskeymgmt 实用工具，可以将报表服务器实例初始化为使用共享的报表服务器数据库。要向扩展部署中添加报表服务器，需要初始化报表服务器。要进行初始化，需要有管理员权限。对于承载要加入部署的报表服务器的远程计算机，您必须拥有管理员凭据。

如何将报表服务器加入扩展部署 (rskeymgmt)

  1. 在特定计算机的本地运行 rskeymgmt.exe，该计算机承载已经是报表服务器扩展部署成员的报表服务器。

  2. 使用 -j 参数将报表服务器加入报表服务器数据库。使用 -m 和 -n 参数指定要添加到部署中的远程报表服务器实例。使用 -u 和 -v 参数指定远程计算机上的管理员帐户。如果要使用同一台计算机中的多个报表服务器实例创建扩展部署，则使用的语法会稍有不同。有关应使用的语法的详细信息，请参阅 rskeymgmt 实用工具。

    下面的示例说明了将远程报表服务器加入扩展部署时必须指定的参数（如果您对远程计算机拥有管理员权限，则可以忽略凭据）：

    复制代码
    rskeymgmt -j -m <remotecomputer> -n <namedreportserverinstance> -u <administratoraccount> -v <administratorpassword>

如何从扩展部署 (rskeymgmt) 中删除报表服务器

  1. 打开要删除的报表服务器的 rsreportserver.config 文件，找到安装 ID。默认情况下，此文件位于 Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportServer。

    如果安装了单个实例，则计算机中只有一个 rsreportserver.config 文件。如果安装了多个 Reporting Services 实例，则请使用 Reporting Services 配置工具中的“服务器状态”页来查找要删除的报表服务器的实例标识符（例如，MSSQL.2）。为报表服务器实例存储程序文件的文件夹名称将基于实例标识符来命名（例如，Program Files\Microsoft SQL Server\MSSQL.2）。

  2. 运行 rskeymgmt.exe。可以在属于报表服务器扩展部署一部分的任何报表服务器上运行该文件。

  3. 使用 -r 参数从扩展部署中释放该报表服务器实例。下面的示例说明了必须指定的参数：

    复制代码
    rskeymgmt -r <installation ID>

这些步骤从扩展部署中删除报表服务器，但不会卸载报表服务器上的 Reporting Services 实例。从扩展部署中删除报表服务器之后，如果不再需要服务器上的 Reporting Services，则可以卸载该服务器上的 Reporting Services。有关信息，请参阅 SQL Server 联机丛书中的如何卸载现有的 SQL Server 实例（安装程序）。

请参阅

概念

配置和管理加密密钥
初始化报表服务器

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


为扩展部署配置 Reporting Services

为扩展部署配置 Reporting Services |
 | 请参阅
配置 Reporting Services >

扩展部署用来增加报表服务器的可扩展性，以处理更多的并发用户和更大的报表执行负载，还可用来在特定服务器上专门处理交互式报表或计划报表。扩展部署中包括：

  • 两个或多个共享单个报表服务器数据库的报表服务器实例。

  • （可选）一个用来将交互式用户负载分布到多个报表服务器实例上的网络负载平衡 (NLB) 群集。

如果将 Reporting Services 部署到 NLB 群集上，则需要确保在报表服务器 URL 的配置中使用 NLB 虚拟服务器名称，并将这些服务器配置为共享同一个视图状态。

Reporting Services 不参与 Microsoft Cluster Services 群集。但是，可以在属于故障转移群集的数据库引擎实例上创建报表服务器数据库。

若要计划、安装和配置扩展部署，请按照下列步骤操作：

  • 请查阅 SQL Server 联机丛书中的规划扩展部署以了解有关何时使用扩展部署的指南。

  • 请查阅 SQL Server 联机丛书中的如何安装 SQL Server 2008 R2（安装程序）以了解如何安装报表服务器实例的说明。

  • 请查阅如何配置报表服务器扩展部署（Reporting Services 配置）以了解有关如何共享报表服务器数据库并将报表服务器实例加入扩展部署的说明。

  • （可选）如果要将扩展部署配置为在网络负载平衡群集上运行，请查阅如何在网络负载平衡群集上配置报表服务器以了解有关如何配置视图状态验证的说明。

请参阅

概念

配置文件中的 URL (Reporting Services)

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


将 Reporting Services 配置为 SharePoint 2010 集成模式

将 Reporting Services 配置为 SharePoint 2010 集成模式 |
 | 请参阅
配置 Reporting Services >

可以将 SQL Server Reporting Services 的部署配置为与 Microsoft SharePoint Foundation 2010 或 Microsoft SharePoint Server 2010 的部署配合使用。必须对报表服务器和所部署的 SharePoint 产品执行配置步骤后，用户才能将报表文档发布到 SharePoint 库并在 SharePoint 站点上获取报表查看和管理服务。该配置过程将建立服务器连接信息；因此按顺序执行这些步骤是非常重要的。

本主题概述每个服务器的配置步骤，其中包含以下各节：

  • 报表服务器上的配置步骤概述

  • SharePoint Server 上的配置步骤概述

  • 服务帐户配置

  • 如何配置服务器集成

有关不同服务器拓扑的详细信息，请参阅 SQL Server 联机丛书中的 SharePoint 集成模式下的 Reporting Services 的部署拓扑。有关 SQL Server 联机丛书中 SharePoint 集成相关主题的完整列表，请参阅如何了解 SharePoint 集成模式。

报表服务器上的配置步骤概述

若要将报表服务器配置为 SharePoint 集成模式，您必须具有现有的独立报表服务器或扩展部署。必须对报表服务器执行以下任务：

  1. 在 SharePoint 集成模式下创建报表服务器数据库。

    这会在报表服务器上设置服务器属性，并激活新的用于集成操作的 SOAP 报表服务器管理端点。使用 Reporting Services 配置工具创建数据库。

  2. 对于包括 SharePoint 服务器场的部署，在报表服务器计算机上安装一个 SharePoint Web 前端。该 Web 前端会将报表服务器计算机加入 SharePoint 场中。只有在将报表服务器和 SharePoint 技术实例部署到不同的计算机上时，才需要在报表服务器计算机上安装 Web 前端。

  3. 如果在部署时涉及到将 SharePoint 数据库放在与报表服务器相同的计算机上，请将报表服务器服务配置为在域帐户下运行。只有当报表服务器和应用程序数据库在一台计算机上，而 SharePoint Web 应用程序在另一台计算机上时，才需要执行此步骤。

注意：
在服务器场配置中，SharePoint 2010 产品和技术需要域帐户来完成服务配置，如报表服务 SharePoint 集成等。

关于报表服务器数据库

报表服务器数据库可以为一个或多个报表服务器实例提供内部存储。报表服务器数据库可以支持本机模式操作，也可以支持 SharePoint 集成模式，但不能同时支持这两种模式。数据库中的内容是特定于模式的，在不同的服务器模式之间不可互换。如果创建支持 SharePoint 集成模式的报表服务器数据库，则以后无法将该数据库自动转换或迁移为使用本机模式报表服务器实例运行。通过以下方式使用报表服务器数据库，具体情况取决于服务器模式：

  • 为本机模式操作创建报表服务器数据库时，报表服务器数据库是报表服务器所使用的持久性数据的唯一存储库。

  • 创建 SharePoint 集成模式的报表服务器数据库时，报表服务器数据库会存储服务器属性、报表执行快照、报表历史记录、订阅定义和计划。同时还存储报表、报表模型、共享数据源和资源的第二副本以提高服务器的处理性能。报表文档的主存储位于 SharePoint 内容数据库。有关详细信息，请参阅 SQL Server 联机丛书中的存储报表服务器内容并将报表服务器内容和 SharePoint 数据库同步。

创建 SharePoint 集成模式的报表服务器数据库是将该报表服务器配置为 SharePoint 集成模式的重要的第一步。可以使用 Reporting Services 配置工具来创建报表服务器数据库并配置与报表服务器的连接。只有报表服务器才连接到报表服务器数据库。SharePoint Foundation 2010 或 SharePoint Server 2010 实例始终都不会连接到报表服务器数据库，也不会从报表服务器数据库中检索数据。

关于报表服务器扩展部署和 SharePoint 集成模式

如果要将报表服务器扩展部署与 SharePoint 服务器场集成，则所有属于该部署的报表服务器实例都必须在 SharePoint 集成模式下运行。在同一扩展部署中不能使用几种服务器模式的组合。而且，您必须为扩展部署创建一个入口点（即，解析为报表服务器实例所安装到的 NLB 群集的虚拟 IP 的 URL）。

关于多个报表服务器实例和 SharePoint 集成模式

如果要在一台计算机上安装多个 Reporting Services 实例，但是仅将其中的一个实例配置为 SharePoint 集成模式，请确保执行以下操作：

  • 确保所有的 Reporting Services 实例具有相同的版本。SQL Server 2008 Reporting Services 引入了一个更新版本的 Reporting Services Windows Management Instrumentation (WMI) 提供程序。同一台计算机上不能同时装有 SQL Server 2008 Reporting Services 和较低版本的 SQL Server 2008 Reporting Services。因此，即使您不需要针对所有实例实现 SQL Server 2008 Reporting Services 功能，也有必要让所有报表服务器实例都运行 SQL Server 2008 Reporting Services 或更高版本。

  • 如果您在不同的时间针对各报表服务器实例运行 SQL Server 2008 R2 安装程序，请在安装第二个 SQL Server 2008 Reporting Services 实例之后重新启动 WMI 服务。

SharePoint Server 上的配置步骤概述

若要在运行 SharePoint 产品或技术的服务器上配置集成，必须执行以下操作：

  1. 下载并安装用于 SharePoint 技术的 Reporting Services 外接程序。

    该外接程序将会安装程序文件和应用程序页，包括您在管理中心打开用来设置报表服务器 URL 和其他集成设置的页。您可以为 SharePoint 场或独立的 SharePoint Web 应用程序指定报表服务器集成设置。

  2. 如果您未在根网站集上安装该外接程序，请激活报表服务器功能。

  3. 使用 SharePoint 管理中心配置报表服务器集成。配置设置包括指定单个报表服务器 URL、针对发往报表服务器的请求设置身份验证类型、向报表服务器服务帐户授予数据库访问权限。

  4. （可选）在 SharePoint 管理中心中，可以设置报表服务器默认值，以便启用日志记录、即席生成报表以及对报表历史记录和超时值的限制。

可以将 SharePoint 产品部署为场或独立的服务器。场包含一个或多个虚拟服务器，在该场中每个虚拟服务器都是一个 SharePoint Web 应用程序。报表服务器在场级集成。从存储集成方面来看，一个场只能有一个报表服务器数据库。可以使用 SharePoint 管理中心管理场中所有服务器的集成设置。

可以将场中每个 SharePoint Web 应用程序都配置为使用不同的身份验证提供程序。这不会给报表服务器集成带来任何影响。无论使用何种身份验证提供程序，报表服务器部署都将处理该场中每个服务器的请求。

每个 Web 应用程序都具有默认的顶级站点。可以在每个顶级站点上设置不同的权限，以使报表服务器项和操作在场中所有服务器之间具有不同的可用性。

服务帐户配置

将报表服务器作为在内置帐户或者本地/域 Windows 用户帐户下运行的单个 Windows 服务实现。在 SharePoint 集成模式下，该服务必须连接到具有写权限和执行权限的 SharePoint 内容数据库。由于该服务连接到 SharePoint 内容数据库，因此用来运行该服务的帐户将具有不同的要求，具体情况取决于是否使用远程连接，以及报表服务器 URL 代理端点连接使用的是 Windows 集成安全模式还是可信帐户模式。

下表提供了建议不同部署方案使用的服务帐户。

部署方案 | 服务 | SharePoint 数据库 | 建议报表服务器服务使用的帐户
单台服务器 | 所有服务都安装在同一台计算机上 | 同一台计算机上 | 任何（NetworkService、域用户、本地用户和 LocalSystem)。 由于应用程序使用本地数据库连接进行连接，因此您可以将该服务配置为在任何类型的帐户下运行。
将部署分布到多台计算机上 | SharePoint Web 应用程序和报表服务器安装在不同的计算机上 | 第三台计算机上 - 或 - SharePoint 服务器计算机 | 域用户帐户 - 或 - NetworkService，但是只有当您将 NT_AUTHORITY\NetworkService 添加到报表服务器计算机上的 WSS_WPG Windows 组中时才使用。有关详细信息，请参阅 SQL Server 联机丛书中的解决配置问题。
将部署分布到多台计算机上 | SharePoint Web 应用程序和报表服务器安装在不同的计算机上 | 在报表服务器计算机上 | 无论报表服务器 URL 代理端点是如何配置的，都需要使用域用户帐户。 SharePoint 数据库在远程计算机上运行时，SharePoint Web 应用程序会显式拒绝远程计算机的计算机帐户访问数据库。如果报表服务器和 SharePoint 数据库在同一台计算机上，而且其中的任一服务在内置帐户下运行，则将相应地拒绝该服务的访问。将该服务配置为在域用户帐户下运行，可确保不会因为该服务运行在被禁止的帐户下而拒绝报表服务器访问数据库。
注意：
在讨论数据库连接的服务帐户要求时，因为只有报表服务器连接到报表服务器数据库，所以将不包括报表服务器数据库。

关于 SharePoint 服务帐户配置

针对 SharePoint Foundation 2010 和 SharePoint Server 2010 的服务帐户建议声明：对于服务器场部署，应当在域用户帐户（而不是 Network Service）下运行应用程序池进程。尽管建议使用域用户帐户，但它不是必需的。但是，一定要认识到，如果您将 SharePoint Web 应用程序配置为在 Network Service 下运行，报表服务器位于远程计算机上，而且报表服务器 URL 代理端口在可信帐户模式下进行连接，那么，在从 SharePoint 站点访问报表和报表服务器功能时将遇到错误。有关在部署此配置时所发生的服务器错误的详细信息，请参阅 SQL Server 联机丛书中的解决配置问题。

有关服务帐户连接到 SharePoint 技术实例的详细信息，请参阅 SQL Server 联机丛书中的 SharePoint 集成模式下的 Reporting Services 安全性概述。若要了解 SharePoint 部署的服务帐户建议，请参阅 SharePoint 产品文档中的 Plan for administrative and service accounts（规划管理和服务帐户）。

如何配置服务器集成

将服务器配置为集成操作需要使用多个工具和步骤。单击下面的链接可阅读有关在特定的部署方案中配置服务器集成的说明：

  • 如何在独立服务器上配置 SharePoint 集成

  • 如何在多台服务器上配置 SharePoint 集成

请参阅

概念

备份和还原加密密钥
如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


Reporting Services 配置操作指南主题

Reporting Services 配置操作指南主题
配置 Reporting Services >

本节包含使用 Reporting Services 配置工具配置报表服务器实例的过程。

本节内容

本节中的主题进行了适当分类，以便于您轻松找到所需说明。第一部分包含有关本机模式的报表服务器的基本配置任务主题。第二部分包含高级配置主题。第三部分包含有关将报表服务器配置为以 SharePoint 集成模式运行的主题。

基本配置

如何启动 Reporting Services 配置

提供启动 Reporting Services 配置工具的步骤。

如何为 Reporting Services 配置服务帐户

说明如何为报表服务器服务指定帐户和密码信息。

如何为报表服务器注册服务主体名称 (SPN)

说明如何为在使用 Kerberos 身份验证的网络上的域用户帐户下运行的报表服务器手动注册 SPN。

如何配置 URL（Reporting Services 配置）

说明如何建立一个或多个用于访问报表服务器 Web 服务和报表管理器的 URL。

如何创建报表服务器数据库（Reporting Services 配置）

提供创建报表服务器数据库的步骤。此步骤是部署 Reporting Services 安装所必需的步骤。

高级或可选配置

如何配置报表服务器扩展部署（Reporting Services 配置）

提供配置多个报表服务器以共享报表服务器数据库的步骤。

如何配置报表服务器以进行电子邮件传递（Reporting Services 配置）

提供有关配置报表服务器以进行电子邮件分发的步骤。

如何将防火墙配置为允许报表服务器访问

说明如何打开用于报表服务器的入站请求和出站响应的端口。

如何在 Windows Vista 和 Windows Server 2008 上为本地管理配置报表服务器

描述使用 http://localhost 连接到报表管理器或报表服务器所需的其他步骤。

如何配置报表服务器以进行远程管理

说明如何配置远程报表服务器实例以便可以从其他计算机上连接和配置它。

如何打开或关闭 Reporting Services 功能

说明如何删除 Reporting Services 安装中不使用的功能。

如何启用远程错误（Reporting Services 配置）

说明如何将报表服务器上的服务器属性设置为返回有关出现在远程服务器上的错误条件的其他信息。

SharePoint 集成

如何在报表服务器计算机中安装 SharePoint Web 前端

说明如何添加用于将报表服务器计算机联接到 SharePoint 服务器场的 SharePoint 程序文件。

如何安装或卸载 Reporting Services 外接程序

说明如何在 SharePoint 服务器上安装报表服务器应用程序页、配置页和 URL。

如何在 SharePoint 管理中心中激活报表服务器功能

说明如何在未启用根网站集时手动激活某个网站集的报表服务器功能。

如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）

说明如何为在 SharePoint 集成模式下运行的报表服务器创建报表服务器数据库。

如何在 SharePoint 管理中心中配置报表服务器集成

提供在 SharePoint 管理中心中配置集成的说明。

如何在独立服务器上配置 SharePoint 集成

提供在一台计算机上安装所有服务器组件和应用程序数据库的分步指导。

如何在多台服务器上配置 SharePoint 集成

提供在分布式服务器部署中的多台计算机上安装服务器组件的分步指导。

如何切换服务器模式（Reporting Services 配置）

说明如何从 SharePoint 技术或实例部署中删除报表服务器实例，以便您可以将该实例作为本机模式报表服务器运行。

SQL Server 联机丛书中的如何了解 SharePoint 集成模式

提供特定于 SharePoint 技术的 Reporting Services 外接程序的主题列表。


如何启动 Reporting Services 配置

如何启动 Reporting Services 配置 |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

Reporting Services 配置管理器用于配置 Reporting Services 安装。只要您是报表服务器计算机上本地管理员组的成员，就可以配置本地或远程报表服务器实例。在可以连接到远程报表服务器实例并对其进行配置之前，必须使远程 Windows Management Instrumentation (WMI) 调用能够通过 Windows 防火墙。有关详细信息，请参阅 SQL Server 联机丛书中的如何配置报表服务器以进行远程管理。

Reporting Services 配置管理器是版本特定的。随此版本的 SQL Server 一起安装的 Reporting Services 配置工具不能用于配置早期版本的 Reporting Services。如果在同一计算机上并行运行新版本和旧版本的 Reporting Services，则必须使用随每个版本安装的 Reporting Service 配置工具来配置每个实例。

启动 Reporting Services 配置

  1. 单击“开始”，依次指向“所有程序”、Microsoft SQL Server 2008 R2 和“配置工具”。

    如果要从先前版本的 SQL Server 中配置报表服务器实例，请打开此版本的程序文件夹。例如，在打开 SQL Server 2005 服务器组件的配置工具时，应指向 Microsoft SQL Server 2005 而非 Microsoft SQL Server 2008 R2。

  2. 单击“Reporting Services 配置管理器”。出现“连接到报表服务器实例”对话框，您可以从中选择要配置的报表服务器实例。

  3. 在“服务器名称”中，指定安装报表服务器实例的计算机的名称。默认情况下，将显示本地计算机的名称，但如果要连接到安装在远程计算机上的报表服务器，则可以键入远程 SQL Server 实例的名称。

  4. 如果指定远程计算机，请单击“查找”以建立一个连接。

  5. 在“报表服务器实例”中，选择要配置的 SQL Server Reporting Services 实例。在列表中只显示此 SQL Server 版本的报表服务器实例。不能配置较早版本的 Reporting Services。

  6. 单击“连接”。

请参阅

概念

Reporting Services 配置操作指南主题

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何在 SharePoint 管理中心中激活报表服务器功能

如何在 SharePoint 管理中心中激活报表服务器功能 |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

在安装了用于 SharePoint 产品的 Microsoft SQL Server 2008 R2 Reporting Services 外接程序之后，应在 SharePoint 管理中心中激活报表服务器集成功能。若要激活报表服务器功能，请在 SharePoint 管理中心的“站点设置”页中使用 Reporting Services 页。

如果 Reporting Services 功能在网站集功能列表中未显示，则没有安装 Reporting Services 外接程序。

若要验证是否已安装，请在 Microsoft Windows“控制面板”中查看已安装应用程序的列表。如果 Reporting Services 外接程序已安装，请按照本主题中的说明激活此功能。

默认情况下，为本地 SharePoint Web 应用程序的根网站集激活 Reporting Services 外接程序。如果未启用根站点或在安装 Reporting Services 外接程序时未定义网站集，则必须手动激活报表服务器集成设置。

注意：
用于 SharePoint 产品的外接程序的 SQL Server 2008 R2 Reporting Services 版本和更高版本将在安装外接程序时为所有现有的网站集激活报表服务器集成功能。此外，对于新的网站集，此功能将自动激活。

注意：
用于 SharePoint 产品的外接程序的 SQL Server 2008 R2 Reporting Services 版本和更高版本将安装在网站集功能列表中将显示的两个功能。对于报表以及与 Reporting Services 集成相关的管理中心页的其他功能，存在一般性的集成。

激活或停用网站集的 Reporting Services 集成

  1. 依次单击“开始”、“管理工具”和“SharePoint 2010 管理中心”。

  2. 单击“网站操作”。

  3. 单击“站点设置”。

  4. 在网站集管理组中单击“网站集功能”

  5. 在列表中找到“报表服务器集成功能”和“报表服务器管理中心功能”。

  6. 单击“激活”。
注意：
若要停用这些功能，您可以使用相同的过程，但单击“停用”，而非“激活”。

后续步骤

激活此功能后，可以继续进行服务器集成。有关说明，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

请参阅

概念

如何安装或卸载 Reporting Services 外接程序
如何安装或卸载 Reporting Services 外接程序

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何将防火墙配置为允许报表服务器访问

如何将防火墙配置为允许报表服务器访问 |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

可以通过指定 IP 地址、端口和虚拟目录的 URL 访问报表服务器应用程序和已发布的报表。如果 Windows 防火墙已开启，配置为报表服务器使用的端口很可能已关闭。表明端口可能已关闭的迹象包括请求报表后出现空白网页，或尝试从远程客户端计算机打开报表管理器时出现空白页。

若要打开端口，必须在报表服务器计算机上使用 Windows 防火墙实用工具。Reporting Services 不会帮您打开端口，您必须手动执行该步骤。

默认情况下，报表服务器侦听端口 80 的 HTTP 请求。因此，以下操作说明包括用来指定该端口的步骤。如果将报表服务器 URL 配置为使用其他端口，则在按照以下说明进行操作时必须指定相应的端口号。

如果要访问外部计算机上的 SQL Server 关系数据库，或者如果报表服务器数据库在外部 SQL Server 实例上，则必须在外部计算机上打开端口 1433 和 1434。有关详细信息，请参阅 SQL Server 联机丛书中的如何为数据库引擎访问配置 Windows 防火墙。有关默认 Windows 防火墙设置的详细信息以及有关影响数据库引擎、Analysis Services、Reporting Services 和 Integration Services 的 TCP 端口的说明，请参阅 SQL Server 联机丛书中的配置 Windows 防火墙以允许 SQL Server 访问。

必备项

这些操作说明假定您已经配置了服务帐户，创建了报表服务器数据库，并为报表服务器 Web 服务和报表管理器配置了 URL。有关详细信息，请参阅Reporting Services 配置操作指南主题。

您还应验证是否可以通过将本地 Web 浏览器连接到本地报表服务器实例来访问报表服务器。此步骤可确保您拥有有效的安装。开始打开端口之前，应验证是否已对安装进行了正确的配置。若要在 Windows Vista 或 Windows Server 2008 中完成该步骤，还必须将报表服务器站点添加到“受信任的站点”中。有关详细信息，请参阅如何在 Windows Vista 和 Windows Server 2008 上为本地管理配置报表服务器。

在 Windows 防火墙中打开端口

针对不同版本的 Windows 防火墙分别有不同的说明。如果使用 Windows Vista 或 Windows Server 2008，请参考本主题末尾的说明。

在 Windows Server 2003 SP 2 或 Windows XP SP2 中打开端口 80

  1. 在“开始”菜单上单击“控制面板”，然后单击“Windows 防火墙”。

  2. 在“例外”选项卡上，单击“添加端口”。

  3. 在“名称”中键入 ReportServer (TCP on port 80)。

  4. 在“端口号”中键入 80。

  5. 确保选中了 TCP。

  6. 单击“更改范围”。

  7. 单击“仅我的网络(子网)”，然后单击“确定”。

  8. 单击“确定”关闭对话框。

  9. 重新启动计算机。

在 Windows Vista 中打开端口 80

  1. 在“开始”菜单上单击“控制面板”，单击“安全”，然后单击“Windows 防火墙”。

  2. 单击“允许程序通过 Windows 防火墙”。

  3. 单击“继续”。

  4. 在“例外”选项卡上，单击“添加端口”。

  5. 在“名称”中键入 ReportServer (TCP on port 80)。

  6. 在“端口号”中键入 80。

  7. 确保选中了 TCP。

  8. 单击“更改范围”。

  9. 单击“仅我的网络(子网)”，然后单击“确定”。

  10. 单击“确定”关闭对话框。

  11. 重新启动计算机。

后续步骤

打开端口后，必须在确认远程用户是否可以通过所打开的端口访问报表服务器之前，通过主文件夹或站点级别的角色分配授予用户访问报表服务器的权限。如果用户不具有足够的权限，那么虽然可以正确地打开端口，但报表服务器连接仍会失败。有关详细信息，请参阅 SQL Server 联机丛书中的如何授予用户对报表服务器的访问权限（报表管理器）。

您还可以通过在其他计算机上启动报表管理器来验证是否正确打开了端口。有关详细信息，请参阅 SQL Server 联机丛书中的如何启动报表管理器。

请参阅

概念

配置报表服务器服务帐户
配置报表服务器 URL
创建报表服务器数据库
配置报表服务器服务帐户
Reporting Services 配置操作指南主题

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何配置报表服务器以进行电子邮件传递（Reporting Services 配置）

如何配置报表服务器以进行电子邮件传递（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

Reporting Services 提供了一个电子邮件传递扩展插件，供用户订阅报表；报表随后将传递到电子邮箱中。若要使用报表服务器电子邮件传递扩展插件，必须先对其进行配置。配置报表服务器的电子邮件传递需要以下各项：

  • 一个简单邮件传输协议 (SMTP) 服务器或网关。

  • 一个拥有从 SMTP 服务器发送电子邮件的权限的帐户。根据您单位的安全策略，您可能需要在通过公司的 SMTP 服务器发送电子邮件之前先请求权限。有关详细信息，请询问您的系统管理员或网络管理员。

  • 报表服务器服务必须对 SMTP 服务器具有 Send As 权限。

若要配置报表服务器电子邮件，可以使用 Reporting Services 配置工具，也可以编辑配置文件。Reporting Services 配置工具提供了报表服务器所要求的最低设置。如果要使用本地 SMTP 服务或指定高级设置，则请修改此配置文件。

如果要评估报表服务器电子邮件功能或解决订阅或传递问题，可以将报表服务器电子邮件配置为使用本地 SMTP 服务，该服务用于将报表传递到本地文件夹。有关详细信息，请参阅配置报表服务器以进行电子邮件传递。

如果您未配置报表服务器来进行电子邮件传递，或者您无权访问 SMTP 服务器，则可以使用文件共享传递扩展插件，将报表分发到可通过网络连接进行访问的共享文件夹。

使用 Reporting Services 配置工具配置报表服务器电子邮件

  1. 请验证报表服务器 Windows 服务是否对 SMTP 服务器拥有 Send As 权限。

  2. 启动 Reporting Services 配置工具，然后连接到报表服务器实例。

  3. 在“电子邮件设置”页上，输入 SMTP 服务器的名称。此值可以是 IP 地址、企业 Intranet 上计算机的 UNC 名称或者完全限定域名。

  4. 在“发件人地址”中，输入有权从 SMTP 服务器发送电子邮件的帐户的名称。

  5. 单击“应用”。

配置报表服务器的远程 SMTP 服务

  1. 请验证报表服务器 Windows 服务是否对 SMTP 服务器拥有 Send As 权限。

  2. 在文本编辑器中打开 RSReportServer.config 文件。

  3. 请验证是否将 <UrlRoot> 设置为报表服务器 URL 地址。此值是在您配置报表服务器时设置的，应该已经填写。如果未设置此值，则请键入报表服务器 URL 地址。

  4. 在“传递”部分中，查找 <ReportServerEmail>。

  5. 在 <SMTPServer> 中，键入 SMTP 服务器的名称。此值可以是 IP 地址、企业 Intranet 上计算机的 UNC 名称或者完全限定域名。

  6. 请验证 <SendUsing> 设置为 2。如果将其设置为其他值，则报表服务器无法配置为使用远程 SMTP 服务。

  7. 在 <From> 中，键入有权从 SMTP 服务器发送电子邮件的帐户的名称。

  8. 保存该文件。

    报表服务器将自动使用新的设置；不需要重新启动该服务。您可以指定其他 SMTP 设置，以进一步配置如何将 SMTP 服务器用于报表服务器电子邮件传递。有关详细信息，请参阅 SQL Server 联机丛书中的配置报表服务器以进行电子邮件传递和 RSReportServer 配置文件。

配置报表服务器的本地 SMTP 服务

  1. 在“控制面板”中，单击“添加或删除程序”。

  2. 单击“添加/删除 Windows 组件”启动 Windows 组件向导。

  3. 选择“应用程序服务器”，然后单击“详细信息”。

  4. 选择“Internet 信息服务 (IIS)”，然后单击“详细信息”。

  5. 选中“SMTP 服务”复选框，然后单击“确定”。

  6. 在 Windows 组件向导中，单击“下一步”。单击“完成”。

  7. 验证服务是否正在“服务”控制台上运行。

  8. 在文本编辑器中打开 RSReportServer.config 文件。

  9. 请验证是否将 <UrlRoot> 设置为报表服务器 URL 地址。此值是在您配置报表服务器时设置的，应该已经填写。如果未设置此值，则请键入报表服务器 URL 地址。

  10. 在“传递”部分中，查找 <ReportServerEmail>。

  11. 在 <SMTPServer> 中，清除此设置的所有值，但不要删除标记。

  12. 将 <SendUsing> 设置为 1。如果将其设置为其他值，则无法将报表服务器配置为使用本地 SMTP 服务。

  13. 将 <SMTPServerPickupDirectory> 设置为本地驱动器中的文件夹。

  14. 将 <From> 设置为有权从 SMTP 服务器发送电子邮件的帐户。

  15. 保存该文件。

请参阅

概念

配置报表服务器以进行电子邮件传递
配置 Reporting Services

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何在 Windows Vista 和 Windows Server 2008 上为本地管理配置报表服务器

如何在 Windows Vista 和 Windows Server 2008 上为本地管理配置报表服务器 |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

如果希望对报表服务器实例进行本地管理，则在 Windows Vista 和 Windows Server 2008 上部署 Reporting Services 需要执行额外的配置步骤。通过在访问应用程序时删除管理员权限，Windows Vista 和 Windows Server 2008 均可限制过度使用提升权限。因为操作系统删除了权限，所以本地 Administrators 组的成员运行大多数应用程序时就像使用标准用户帐户时一样。

虽然该方法可提高系统的整体安全性，但会阻止用户使用 Reporting Services 为本地管理员创建的预定义内置角色分配。但通过在用户方执行额外配置，在执行下列操作后可以使用标准用户权限有效地管理报表服务器内容和操作：

  • 将 Reporting Services URL 添加到受信任站点。默认情况下，Internet Explorer 7.0 在 Windows Vista 和 Windows Server 2008 上是以保护模式运行的，此功能可阻止浏览器请求到达运行在同一计算机上的高级别进程。通过将报表服务器应用程序添加为受信任站点，可以禁用这些应用程序的保护模式。

  • 创建角色分配，授予您（报表服务器管理员）管理内容和操作的权限而无需使用 Internet Explorer 中的“以管理员的身份运行”功能。通过为您的 Windows 用户帐户创建角色分配，并通过显式角色分配替换 Reporting Services 为本地管理员创建的预定义的内置角色分配，您将获得对报表服务器的访问权限（包括内容管理员和系统管理员权限）。

本主题说明在完成安装并且配置了报表服务器组件之后如何配置报表服务器以便进行本地管理。如果您尚未安装或配置报表服务器，请参阅 SQL Server 联机丛书中的如何安装 SQL Server 2008 R2（安装程序）和 Reporting Services 配置操作指南主题。有关用户帐户控制 (UAC) 功能以及如何利用管理员权限连接到数据库引擎的详细信息，请参阅 SQL Server 联机丛书中的如何从 Windows Vista 连接到 SQL Server。

注意：
如果正在 Windows Vista 或 Windows Server 2008 上部署 Reporting Services，请确保打开 Windows 防火墙的 80 端口，以允许访问报表服务器计算机。有关说明，请参阅如何将防火墙配置为允许报表服务器访问。

在 Windows Vista 和 Windows Server 2008 上配置本地报表服务器管理

  1. 使用“以管理员的身份运行”权限打开一个浏览器窗口。从“开始”菜单上，单击“所有程序”，右键单击 Internet Explorer，然后选择“以管理员的身份运行”。

  2. 单击“允许”以继续。

  3. 在 URL 地址中，输入报表管理器 URL。有关说明，请参阅 SQL Server 联机丛书中的如何启动报表管理器。

  4. 单击“工具”。

  5. 单击“Internet 选项”。

  6. 单击“安全性”。

  7. 单击“受信任的站点”。

  8. 单击“站点”。

  9. 添加 http://<服务器名称>。

  10. 如果不将 HTTPS 用于默认站点，请清除“对该区域中的所有站点要求服务器验证(https:)”复选框。

  11. 单击“添加”。

  12. 单击“确定”。

  13. 在报表管理器的主页上，单击“属性”。

  14. 单击“新建角色分配”。

  15. 按以下格式键入 Windows 用户帐户：<域>\<用户>。

  16. 选择“内容管理员”。

  17. 单击“确定”。

  18. 单击主页上角的“站点设置”。

  19. 单击“配置站点范围的安全性”。

  20. 单击“新建角色分配”。

  21. 按以下格式键入 Windows 用户帐户：<域>\<用户>。

  22. 选择“系统管理员”。

  23. 单击“确定”。

  24. 关闭报表管理器。

  25. 重新在 Internet Explorer 中打开报表管理器，但不使用“以管理员的身份运行”。

使用 Windows Vista 和 Windows Server 2008 上的 Business Intelligence Development Studio

如果您在 Windows Vista 或 Windows Server 2008 上安装了 Business Intelligence Development Studio，则在使用设计工具时会遇到与 Visual Studio 环境的兼容问题。如果希望打开现有项目或解决方案，或者希望将项目从报表设计器或模型设计器发布到报表服务器，则必须以提升的权限打开 Business Intelligence Development Studio：

  1. 从“开始”菜单上，依次单击“所有程序”和 SQL Server 2008，右键单击 Business Intelligence Development Studio，然后单击“以管理员的身份运行”。

  2. 单击“继续”。

  3. 单击“运行程序”。

现在，您应该能够将报表和其他项目部署到报表服务器上了。如果没有足够的权限，您将遇到如下的问题：

  • 尝试打开现有项目时遇到拒绝访问错误。

  • 配置与共享数据源的数据源连接时遇到登录失败错误。

  • 当使用报表服务器向导创建报表时，如果向导尝试连接到为报表提供数据的外部数据源，您将会遇到登录失败错误。

SQL Server Management Studio 用户必须使用“以管理员的身份运行”权限为管理服务器上的数据库的用户创建登录名。有关 Management Studio 的提升权限要求的详细信息，请参阅 SQL Server 联机丛书中的如何从 Windows Vista 连接到 SQL Server。

请参阅

任务

如何启动 Reporting Services 配置

概念

Reporting Services 配置操作指南主题

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何配置报表服务器以进行远程管理

如何配置报表服务器以进行远程管理 |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

在 Reporting Services 中，您可以通过本地或远程方式配置报表服务器实例。若要配置远程报表服务器实例，可以使用 Reporting Services 配置工具或编写使用 Reporting Services Windows Management Instrumentation (WMI) 提供程序的自定义代码。Reporting Services 配置工具为 WMI 提供程序提供了一个图形界面，这样您便可以直接配置报表服务器，而不必编写代码。启动该工具时，可以指定要连接的远程服务器。

在可以使用该工具配置远程报表服务器之前，必须按照本主题中的说明在 Windows 防火墙中启用端口、启用远程连接并启用远程 WMI 请求。

正确的配置可帮助您避免出现以下错误：

The machine could not be found.

"The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)".

必备项

若要修改防火墙设置，必须从本地登录，并且您必须是本地 Administrators 组的成员。不能通过远程连接来修改远程计算机的 Windows 防火墙设置。

如果要为非管理员用户启用远程管理，则必须为该帐户授予对分布式组件对象模型 (DCOM) 的远程激活权限。本主题提供了有关配置服务器以供非管理员访问的说明。

某些组织的组策略阻止某些操作系统或用户进行远程服务器管理。开始修改防火墙设置之前，请与网络管理员进行核实，以确认是否存在对远程管理的限制。

有关详细信息，请参阅 MSDN 上 Platform SDK 文档中的 Connecting Through Windows Firewall（通过 Windows 防火墙连接）。

任务

启用远程报表服务器配置的任务包括：

  • 在 Windows 防火墙中启用端口以允许报表服务器和 SQL Server 数据库引擎实例所使用的端口的请求。

  • 启用与承载报表服务器数据库的数据库引擎实例之间的远程连接。远程连接是配置报表服务器数据库连接和管理加密密钥所必需的。

  • 启用远程 WMI 请求以通过 Microsoft Windows 防火墙。

  • 如果要配置远程报表服务器以便由非管理用户进行管理，则必须设置 DCOM 权限以启用对标准 Windows 用户帐户的远程 WMI 访问。由于 WMI 使用 DCOM 作为远程调用传输方式，因此必须设置 DCOM 权限，以使不是以本地管理员身份登录的用户可以配置服务器。

  • 如果要配置远程报表服务器以便由非管理用户进行管理，则还必须设置对报表服务器 WMI 命名空间的 WMI 权限。默认情况下，本地管理员组的所有成员都有权访问报表服务器 WMI 命名空间。如果要对非管理员授予访问权限，则必须设置权限。

本主题中提供了有关如何执行这些任务的说明。

在 Windows 防火墙中打开端口

  1. 如何为数据库引擎访问配置 Windows 防火墙.

  2. 如何将防火墙配置为允许报表服务器访问.

配置与报表服务器数据库的远程连接

  1. 单击“开始”，依次指向“程序”、Microsoft SQL Server 2008 R2、“配置工具”，然后单击“SQL Server 配置管理器”。

  2. 在左窗格中，展开“SQL Server 网络配置”，然后针对 SQL Server 实例单击“协议”。

  3. 在详细信息窗格中，启用“TCP/IP”和“命名管道”协议，然后重新启动 SQL Server 服务。

在 Windows 防火墙中启用远程管理

  1. 以本地管理员身份登录要启用远程管理功能的计算机。

  2. 如果报表服务器是在 Windows Vista 中运行，则右键单击“命令提示符”并选择“以管理员身份运行”。对于其他操作系统，请打开一个命令提示符窗口。

  3. 运行以下命令：

    复制代码
    netsh.exe firewall set service type=REMOTEADMIN mode=ENABLE scope=ALL

    可以指定不同的作用域选项。有关详细信息，请参阅 Windows 防火墙产品文档。

  4. 验证是否已启用远程管理。可以运行以下命令以显示状态：

    复制代码
    netsh.exe firewall show state

  5. 重新启动计算机。

设置 DCOM 权限为非管理员启用远程 WMI 访问

  1. 在“开始”菜单中，指向“管理工具”，单击“组件服务”。

    对于 Windows Vista，在“开始”菜单上依次单击“所有程序”、“运行”，然后输入 mmc comexp.msc。

  2. 打开“组件服务”文件夹。

  3. 打开“计算机”文件夹。

  4. 选择“我的电脑”。

  5. 在“操作”菜单中，选择“属性”。

  6. 单击“COM 安全”。

  7. 在“启动和激活权限”中单击“编辑限制”。

  8. 如果在“启动权限”中没有看到您的名称，请单击“添加”。

  9. 键入您的用户帐户名，然后单击“确定”。

  10. 在“<用户或组> 权限”的“允许”列中，选择“远程启动”和“远程激活”，然后单击“确定”。

为非管理员设置报表服务器 WMI 命名空间的权限

  1. 在“开始”菜单中，指向“管理工具”，单击“计算机管理”。

  2. 打开“服务和应用程序”文件夹。

  3. 右键单击“WMI 控件”，然后选择“属性”。

  4. 单击“安全性”。

  5. 打开 Root 文件夹。

  6. 打开 Microsoft 文件夹。

  7. 打开 SQLServer 文件夹。

  8. 打开 ReportServer 文件夹。

  9. 打开实例文件夹。如果安装了默认实例，则文件夹为 MSSQLSERVER。

  10. 打开 v10 文件夹。

  11. 选中 Admin 文件夹，然后单击“安全”。

  12. 单击“添加”，然后键入将用于管理服务器的用户帐户。

  13. 在“允许”列中，选择“启用帐户”、“远程启用”和“读取安全”，然后单击“确定”。

请参阅

任务

如何启动 Reporting Services 配置

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何配置报表服务器扩展部署（Reporting Services 配置）

如何配置报表服务器扩展部署（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

Reporting Services 支持扩展部署模式。该模式允许运行共享单个报表服务器数据库的多个报表服务器实例。

若要创建扩展部署，请使用安装程序和 Reporting Services 配置工具：

  • 使用安装程序安装将与扩展部署联接的每个报表服务器实例。

  • 使用 Reporting Services 配置工具将每个报表服务器连接到共享数据库。您一次只能连接并配置一台报表服务器。

  • 使用 Reporting Services 配置工具将新的报表服务器实例联接到已经与报表服务器数据库连接的第一个报表服务器实例来完成扩展。

为避免在将服务器实例连接到共享数据库时出现数据库兼容错误，应确保所有实例都为同一版本。例如，如果使用 SQL Server 2008 报表服务器实例创建报表服务器数据，则同一部署中的其他所有实例也必须为 SQL Server 2008 实例。有关详细信息，请参阅为扩展部署配置 Reporting Services。

下面的说明阐述如何配置双节点报表服务器扩展部署。重复本主题中所述的步骤可向部署中添加其他报表服务器节点。

如果打算在网络负载平衡 (NLB) 群集上承载扩展部署，则应当在配置扩展部署之前配置 NLB 群集。有关详细信息，请参阅如何在网络负载平衡群集上配置报表服务器。

安装 SQL Server 实例以承载报表服务器数据库

  1. 在将承载报表服务器数据库的计算机上安装 SQL Server 实例。至少需要安装 SQL Server 数据库引擎和 Reporting Services。

  2. 如有必要，请针对报表服务器启用远程连接。SQL Server 的某些版本在默认情况下不允许进行远程 TCP/IP 和 Named Pipes 连接。若要确认是否允许进行远程连接，请使用 SQL Server 配置管理器，然后查看目标实例的网络配置设置。如果远程实例还是一个命名实例，请验证目标服务器上的 SQL Server Browser 服务是否已启用且正在运行。SQL Server Browser 可提供用于连接到命名实例的端口号。

安装第一个报表服务器实例

  1. 安装属于部署内容的第一个报表服务器实例。安装 Reporting Services 时，请在“报表服务器安装选项”页上选择“安装但不配置服务器”选项。

  2. 启动 Reporting Services 配置工具。

  3. 配置报表服务器 Web 服务 URL、报表管理器 URL 和报表服务器数据库。有关详细信息，请参阅 SQL Server 联机丛书中的如何配置报表服务器。

  4. 验证报表服务器是否正常运行。有关详细信息，请参阅 SQL Server 联机丛书中的如何验证 Reporting Services 安装。

安装并配置第二个报表服务器实例

  1. 运行安装程序以在另一台计算机上安装第二个 Reporting Services 实例，或在同一台计算机上将其安装为命名实例。在安装 Reporting Services 时，请在“报表服务器安装选项”页上选择“安装但不配置服务器”选项。

  2. 启动 Reporting Services 配置工具，然后连接到刚安装的新实例。

  3. 将报表服务器连接到用于第一个报表服务器实例的数据库：

    1. 单击“数据库”打开“数据库”页。

    2. 单击“更改数据库”。

    3. 单击“选择现有报表服务器数据库”。

    4. 键入承载您要使用的报表服务器数据库的 SQL Server SQL Server 数据库引擎实例的服务器名称。此服务器必须是上述说明中连接到的服务器。

    5. 单击“测试连接”，再单击“下一步”。

    6. 在“报表服务器数据库”中，选择您为第一个报表服务器创建的数据库，然后单击“下一步”。默认名称为 ReportServer。请勿选择 ReportServerTempDB；它仅用于在处理报表时存储临时数据。如果数据库列表为空，请重复前四个步骤以建立服务器连接。

    7. 在“凭据”页中，选择报表服务器将用于连接到报表服务器数据库的帐户类型和凭据。可以使用与第一个报表服务器实例相同的凭据，也可以使用其他凭据。单击“下一步”。

    8. 单击“摘要”，再单击“完成”。

  4. 配置报表服务器 Web 服务 URL。先不要测试该 URL。在报表服务器联接到扩展部署后，该 URL 才会解析。

  5. 配置报表管理器 URL。先不要测试 URL，也不要试图验证部署。报表服务器在联接到扩展部署后才可用。

将第二个报表服务器实例联接到扩展部署

  1. 打开 Reporting Services 配置工具，然后连接到第一个报表服务器实例。由于已将第一个报表服务器初始化为执行可逆加密操作，因此它可用于将其他报表服务器实例联接到扩展部署。

  2. 单击“扩展部署”打开“扩展部署”页。您会看到两个条目，分别对应于连接到报表服务器数据库的两个报表服务器实例。第一个报表服务器实例应已联接。第二个报表服务器应在“等待联接”。如果您在自己的部署中没有看到类似的条目，请确认您已连接到已配置和初始化为使用报表服务器数据库的第一个报表服务器。

  3. 在“扩展部署”页上，选择等待联接部署的报表服务器实例，然后单击“添加服务器”。

  4. 现在应能验证两个报表服务器实例是否都正常运行。若要验证第二个实例，可以使用 Reporting Services 配置工具连接到报表服务器，然后单击“Web 服务 URL”或“报表管理器 URL”。

如果计划在负载平衡服务器群集中运行报表服务器，则需要进行额外配置。有关详细信息，请参阅如何在网络负载平衡群集上配置报表服务器。

请参阅

任务

如何为 Reporting Services 配置服务帐户
如何配置 URL（Reporting Services 配置）
如何创建报表服务器数据库（Reporting Services 配置）
如何启动 Reporting Services 配置

概念

配置报表服务器 URL
配置报表服务器数据库连接
添加和删除扩展部署的加密密钥
Reporting Services 配置操作指南主题

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何在网络负载平衡群集上配置报表服务器

如何在网络负载平衡群集上配置报表服务器 |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

如果要将报表服务器扩展配置为在网络负载平衡 (NLB) 群集上运行，必须执行以下操作：

  • 确保可通过映射到虚拟服务器 IP 地址的虚拟服务器名称来访问 NLB 群集。必须提供虚拟服务器名称，才能配置 NLB 群集的单入口点。在为每个报表服务器实例配置 URL 时，会将虚拟服务器名称指定为主机。

  • 配置视图状态验证以支持查看交互式报表。交互式报表通常会在单个用户会话期间多次呈现，以便为了响应用户操作而对新数据或不同数据进行可视化。通过配置视图状态验证，可以在用户会话期间保持连续性，而与实际请求由哪个报表服务器提供服务无关。

Reporting Services 不支持对扩展部署进行负载平衡，也不支持定义通过共享 URL 进行单点访问。您必须实现单独的软件或硬件 NLB 群集解决方案以支持 Reporting Services 扩展部署。

可以将 Reporting Services 安装在已经是 NLB 群集一部分的节点上，也可以先配置扩展部署，然后再安装群集软件。

报表服务器在 NLB 群集上的部署步骤

可以使用下面的指南来安装和配置部署：

步骤 | 说明 | 详细信息
1 | 在将 Reporting Services 安装在 NLB 群集内的服务器节点上之前，请检查扩展部署的要求。 | SQL Server 联机丛书中的规划扩展部署
2 | 配置 NLB 群集并验证它是否正常工作。 确保将主机标头名称映射到 NLB 群集的虚拟服务器 IP。主机标头名称用在报表服务器 URL 中，它比 IP 地址便于记忆和键入。 | 有关详细信息，请参阅您运行的 Windows 操作系统版本的 Windows Server 产品文档。
4 | 在已是 NLB 群集一部分的节点上以“仅文件”模式安装 Reporting Services，并为扩展部署配置报表服务器实例。 所配置的扩展部署将不响应那些定向到虚拟服务器 IP 的请求。在配置视图状态验证之后，会在以后的步骤中将扩展部署配置为使用虚拟服务器 IP。 | 如何配置报表服务器扩展部署（Reporting Services 配置）
5 | 配置视图状态验证。 为了达到最佳效果，请在配置扩展部署之后、配置报表服务器实例以使用虚拟服务器 IP 之前执行此步骤。通过先配置视图状态验证，可以避免在用户试图访问交互式报表时出现有关状态验证失败的异常。 | 本主题中的如何配置视图状态验证。
6 | 将 Hostname 和 UrlRoot 配置为使用 NLB 群集的虚拟服务器 IP。 | 本主题中的如何配置 Hostname 和 UrlRoot。
7 | 验证能否通过指定的主机名来访问服务器。 | 本主题中的验证报表服务器访问权限。

如何配置视图状态验证

若要在 NLB 群集上运行扩展部署，必须配置视图状态验证，以便用户可以查看交互式 HTML 报表。您必须针对报表服务器和报表管理器执行此操作。

视图状态验证由 ASP.NET 控制。默认情况下，将启用视图状态验证并使用 Web 服务的标识来执行验证。但是，在 NLB 群集方案中，存在运行于不同计算机上的多个服务实例和 Web 服务标识。因为每个节点的服务标识都各不相同，所以您无法依赖单个进程标识来执行验证。

若要解决此问题，可以生成一个任意验证密钥来支持视图状态验证功能，然后将每个报表服务器节点手动配置为使用同一密钥。可以使用随机生成的十六进制序列。十六进制序列的长度由验证算法（如 SHA1）确定。

  1. 通过使用由 .NET Framework 提供的 autogenerate 功能，生成一个验证密钥和解密密钥。最后，您必须具有单个 <machineKey> 条目，您可以将该条目粘贴到扩展部署中每个报表管理器实例的 Web.config 文件中。

    下面的示例说明了您必须获得的值。请不要将该示例复制到配置文件中，其中的密钥值是无效的。

    复制代码
    <machineKey validationKey="123455555" decryptionKey="678999999" validation="SHA1" decryption="AES"/>
  2. 打开报表管理器的 Web.config 文件，并在 <system.web> 部分粘贴所生成的 <machineKey> 元素。默认情况下，报表管理器的 Web.config 文件位于 \Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportManager\Web.config 中。

  3. 保存该文件。

  4. 对扩展部署中的每个报表服务器重复上述步骤。

  5. 确保 \Reporting Services\Report Manager 文件夹中所有 Web.Config 文件的 <system.web> 部分都包含相同的 <machineKey> 元素。

如何配置 Hostname 和 UrlRoot

若要在 NLB 群集上配置报表服务器扩展部署，必须定义单个虚拟服务器名称，以提供服务器群集的单访问点。然后向您的环境中的域名服务器 (DNS) 注册此虚拟服务器名称。

在定义虚拟服务器名称之后，可以在 RSReportServer.config 文件中配置 Hostname 和 UrlRoot 属性，以在报表服务器 URL 中包括虚拟服务器名称。

在报表环境中使用通配符 URL 保留项时，配置 Hostname 属性。将 Hostname 属性指定为 NLB 服务器的虚拟服务器名称时，报表环境的网络流量将定向到 NLB 服务器。然后，NLB 将在报表服务器节点之间分发请求。

此外，配置 UrlRoot 属性，以便报表链接处理的是已导出为静态报表的报表（例如 Excel 或 PDF 格式）或由订阅（例如电子邮件订阅）生成的报表。

如果将 Reporting Services 与 Windows SharePoint Services 3.0 或 Office SharePoint Server 2007 集成到一起，或者在自定义 Web 应用程序中承载报表，您可能需要仅配置 UrlRoot 属性。在这种情况下，将 UrlRoot 属性配置为 SharePoint 站点或 Web 应用程序的 URL。这会将报表环境的网络流量定位到处理报表的应用程序，而不是报表服务器或 NLB 群集。

请不要修改 ReportServerUrl。如果修改了此 URL，那么，在每次处理内部请求时，都将额外引入一个通过虚拟服务器的往返过程。有关详细信息，请参阅配置文件中的 URL (Reporting Services)。有关编辑配置文件的详细信息，请参阅 SQL Server 联机丛书中的如何修改 Reporting Services 配置文件。

  1. 在文本编辑器中打开 RSReportServer.config。

  2. 查找 <Service> 部分，并将以下信息添加到配置文件，将 Hostname 值替换为 NLB 服务器的虚拟服务器名：

    复制代码
    <Hostname>virtual_server</Hostname>
  3. 查找 UrlRoot。此元素未在该配置文件中指定，但是所使用的默认值是采用 http:// 或 https://<计算机名称>/<报表服务器> 格式的 URL，其中 <报表服务器> 是报表服务器 Web 服务的虚拟目录名称。

  4. 为 UrlRoot 键入一个包括群集虚拟名称的值，其格式为：http:// 或 https://<虚拟服务器>/<报表服务器>。

  5. 保存该文件。

  6. 对于扩展部署中的每个报表服务器，在其相应的 RSReportServer.config 文件中重复上述步骤。

验证报表服务器访问权限

验证是否可通过虚拟服务器名称（例如，https://MyVirtualServerName/reportserver 和 https://MyVirtualServerName/reports）访问扩展部署。

通过查看报表服务器日志文件或检查 RS 执行日志（该执行日志表包含的 InstanceName 列可以显示处理特定请求的实例名称），可以检查哪个节点实际处理报表。有关详细信息，请参阅 SQL Server 联机丛书中的Reporting Services 日志文件。

如果不能连接到报表服务器上，请检查 NLB 以确保请求发送到报表服务器，并查看报表服务器 HTTP 日志，以确保服务器接收请求。

对失败的请求进行疑难解答

如果请求未到达报表服务器实例，请检查 RSReportServer.config 文件，验证虚拟服务器名称是否指定为报表服务器 URL 的主机名：

  1. 在文本编辑器中打开 RSReportServer.config 文件。

  2. 查找 <Hostname>、<ReportServerUrl> 和 <UrlRoot>，并检查每个设置的主机名。如果该值不是预期的主机名，请将其替换为正确的主机名。

如果在做出以下更改后启动 Reporting Services 配置工具，则该工具可能会将 <ReportServerUrl> 设置更改为默认值。请始终保留一份配置文件的备份副本，以备需要用包含要使用的设置的版本替换该配置文件时使用。

请参阅

任务

如何启动 Reporting Services 配置
如何配置 URL（Reporting Services 配置）
如何配置报表服务器扩展部署（Reporting Services 配置）

概念

Reporting Services 配置操作指南主题

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何为 Reporting Services 配置服务帐户

如何为 Reporting Services 配置服务帐户 |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

在 Reporting Services 安装中，报表服务器 Web 服务、报表管理器和后台处理应用程序在一个服务内运行。运行该服务的帐户是在安装过程中定义的，即在“服务标识”页中指定的帐户；但是，如果希望使用不同的帐户或更改密码，可以使用 Reporting Services 配置工具。

如果您将报表服务器配置为使用 SharePoint 集成模式并使用 Reporting Services 配置工具更改了服务帐户，则您还必须打开 SharePoint 管理中心并使用 Reporting Services“授予数据库访问权限”页来重新应用报表服务器和实例设置。此步骤向新服务帐户授予对 SharePoint 数据库的访问权限，这是将 Reporting Services 与 SharePoint Foundation 2010 或 SharePoint Server 2010 集成所必需的。有关如何在 SharePoint 管理中心授予数据库访问权限的详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

请始终使用 Reporting Services 配置工具来更新服务帐户，以便可以同时更新依赖服务标识的其他设置。

不能将内置 Windows 服务帐户（Local Service 或 Network Service）用作域控制器上的报表服务器服务帐户。

配置报表服务器服务帐户

  1. 启动 Reporting Services 配置管理器并连接到报表服务器。

  2. 在“服务帐户”页上，选择描述您要使用的帐户类型的选项。有关指定何种帐户类型的建议，请参阅配置报表服务器服务帐户。

  3. 如果选择了一个 Windows 用户帐户，请指定新的帐户名和密码。帐户名不能超过 20 个字符。

    如果报表服务器部署在支持 Kerberos 身份验证的网络中，则必须使用刚刚指定的域用户帐户注册报表服务器服务主体名称 (SPN)。有关详细信息，请参阅如何为报表服务器注册服务主体名称 (SPN)。

  4. 单击“应用”。

  5. 当系统提示您备份对称密钥时，请键入对称密钥备份的文件名和位置，并键入用于锁定和解锁该文件的密码，然后单击“确定”。

  6. 如果报表服务器使用该服务帐户连接到报表服务器数据库，则连接信息将更新为使用新的帐户或密码。更新连接信息要求连接到数据库。如果出现“SQL Server 数据库连接”对话框，请输入拥有连接到数据库的权限的凭据，然后单击“确定”。

  7. 当系统提示您还原对称密钥时，请键入在步骤 5 中指定的密码，并单击“确定”。

  8. 查看“结果”窗格中的状态消息以验证所有任务是否均已成功完成。

服务标识更新错误故障排除

更改服务标识将启动一系列事件，其中包括重新启动服务、更新受密码保护的加密密钥、更新 URL 保留项以及更新报表服务器数据库连接信息（如果使用该服务帐户来连接报表服务器数据库）。您可以通过查看页面底部“结果”窗格中的通知来监视这些事件的状态。如果在此过程中出现错误，可以尝试使用以下方法进行解决：

  • 如果无法还原对称密钥，可以尝试使用“加密密钥”页中的“还原”手动还原它。如果这不起作用，可以考虑删除加密的内容。您必须重新创建数据源连接信息和订阅，但其余内容仍然可用。有关详细信息，请参阅备份和还原加密密钥。

  • 如果服务未启动，请使用管理工具中的“服务”控制台应用程序手动重新启动它。

  • 更新服务帐户时可能会发生 URL 保留项错误。每个 URL 保留项都包含一个安全描述符，其中包含授权该服务帐户接受该 URL 上的请求的自由访问控制列表 (DACL)。更新帐户时，必须重新创建该 URL，以便用新帐户信息更新 DACL。如果无法重新创建 URL 保留项，并且您知道该帐户是有效的，请尝试重新启动计算机。如果错误仍然存在，请尝试使用不同的帐户。

请参阅

任务

如何启动 Reporting Services 配置

参考

服务帐户（Reporting Services 配置）

概念

配置报表服务器服务帐户
配置报表服务器数据库连接
配置和管理加密密钥

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何配置 URL（Reporting Services 配置）

如何配置 URL（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

您必须为每个应用程序至少配置一个 URL 才能使用报表管理器或报表服务器 Web 服务。如果 Reporting Services 是在“仅文件”模式下安装的（即通过在安装向导的“报表服务器安装选项”页上选择“安装但不配置服务器”选项），则必须配置 URL。如果 Reporting Services 是采用默认配置安装的，则已经为每个应用程序配置了 URL。如果您将报表服务器配置为使用 SharePoint 集成模式，并使用 Reporting Services 配置工具更新了报表服务器 Web 服务 URL，则您还必须更新 SharePoint 管理中心中的 URL。

可以使用 Reporting Services 配置工具来配置 URL。URL 的所有部分均在此工具中定义。与早期版本不同，Internet Information Services (IIS) 网站不再提供对 SQL Server 2008 中的 Reporting Services 应用程序的访问。

Reporting Services 提供了在多数部署方案下均能发挥良好作用的默认值，这些部署方案包括与其他 Web 服务和应用程序的并行部署。默认 URL 包含实例名称，如果您在同一台计算机上运行多个报表服务器实例，则这可以最大限度地降低 URL 冲突的风险。

本主题提供有关以下任务的说明：

  • 为报表服务器 Web 服务创建 URL。

  • 为报表管理器创建 URL。

  • 设置高级 URL 属性以定义其他 URL。

有关如何存储和维护 URL 以及互操作性问题的详细信息，请参阅 SQL Server 联机丛书中的 关于 URL 保留和注册 (Reporting Services)和Deploying Reporting Services and Internet Information Services Side-by-Side。若要查看 Reporting Services 安装中经常使用的 URL 示例，请参阅本主题中的 URL 示例。

必备项

在创建或修改 URL 之前，请注意以下几点：

  • 您必须是报表服务器计算机上本地 Administrators 组的成员。

  • 如果同一台计算机上安装了 IIS 6.0 或 7.0，请检查使用端口 80 的任何网站上的虚拟目录的名称。如果发现任何虚拟目录使用默认 Reporting Services 虚拟目录名称（即“Reports”和“ReportServer”），请为您要配置的 Reporting Services URL 选择不同的虚拟目录名称。

  • 必须使用 Reporting Services 配置工具来配置 URL，而不要使用系统实用工具。切勿直接在 RSReportServer.config 文件的 URLReservations 部分中修改 URL 保留项。若要同时更新内部存储的基础 URL 保留项并同步存储在 RSReportServer.config 文件中的 URL 设置，则有必要使用 Reporting Services 配置工具。

  • 选择一个报表活动较少的时间。每次 URL 保留项发生更改时，都可能会回收报表服务器 Web 服务和报表管理器的应用程序域。

  • 有关 Reporting Services 中 URL 的结构和用法的概述，请参阅配置报表服务器 URL。

为报表服务器 Web 服务配置 URL

  1. 启动 Reporting Services 配置工具，然后连接到某个本地报表服务器实例。

  2. 单击“Web 服务 URL”。

  3. 指定虚拟目录。虚拟目录名称用于标识接收请求的应用程序。由于 IP 地址和端口可由多个应用程序共享，因而使用虚拟目录名称来指定接收请求的应用程序。

    此值必须唯一，以确保请求到达预期目标。此值是必需的，且区分大小写。虚拟目录名称和 Reporting Services 应用程序实例之间是一一对应的。如果创建多个指向同一应用程序实例的 URL，则必须在为此应用程序实例定义的所有 URL 中使用相同的虚拟目录名称。

    对于报表服务器 Web 服务，默认虚拟目录名称为 ReportServer。

  4. 指定用于在网络中唯一地标识该报表服务器计算机的 IP 地址。如果希望指定主机标头或者为同一应用程序实例定义其他 URL，则必须单击“高级”。有关如何设置 URL 的高级属性的说明，请参阅本主题后面的说明。否则，请使用“Web 服务 URL”页从下列值中进行选择：

    • “所有已分配的”指定分配给计算机的任何 IP 地址均可用在指向报表服务器应用程序的 URL 中。此值还包含友好主机名（如计算机名），域名服务器可将该主机名解析为分配给该计算机的 IP 地址。此为 Reporting Services URL 的默认值。

    • “所有未分配的”指定报表服务器将接收任何尚未由其他应用程序处理的请求。建议避免使用此选项。如果选择此选项，则具有更强 URL 保留项的另一个应用程序可能会截获发往该报表服务器的请求。

    • 127.0.0.1 是用于访问 localhost 的 IPv4 地址。它支持对报表服务器计算机进行本地管理。如果仅选择此值，则只有在本地登录到报表服务器计算机的用户可以访问应用程序。

    • ::1 是 IPv6 格式的环回地址。

    • 此列表中还显示特定 IP 地址。IP 地址可以采用 IPv4 和 IPv6 格式。Nnn.nnn.nnn.nnn 是计算机网络适配器的 32 位 IPv4 地址。IPv6 地址为 128 位，包含八个由冒号分隔的 4 字节字段：<前缀>:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn

      如果有多个网络适配器，或者如果网络同时支持 IPv4 和 IPv6 地址，则会看到多个 IP 地址。如果只选择一个 IP 地址，则会将应用程序限制为只能访问该 IP 地址（以及域名服务器映射到该地址的任何主机名）。您不能使用 localhost 访问报表服务器，也不能使用安装在报表服务器计算机上的其他网络适配器的 IP 地址。如果选择此值，则通常是因为您要配置多个还指定显式 IP 地址或主机名的 URL 保留项（例如，一个针对用于 Intranet 连接的网络适配器，另一个用于 Extranet 连接）。

  5. 指定端口。端口 80 是 Windows Server 2003、Windows Vista 和 Windows Server 2008 上的 Reporting Services 的默认端口，这是因为它可以与其他应用程序共享。如果使用 32 位 Windows XP SP2，则默认端口为 8080。如果希望使用自定义端口号，请记住必须始终在用于访问报表服务器的 URL 中指定它。可以使用以下方法来查找可用端口：

    • 在命令提示符下键入以下命令以返回正在使用的 TCP 端口的列表：

      netstat –a –n -p tcp

    • 查阅 Microsoft 支持文章 Information about TCP/IP port assignments（关于 TCP/IP 端口分配的信息），了解 TCP 端口分配以及已知端口（0 到 1023）、注册端口（1024 到 49151）和动态或专用端口（49152 到 65535）之间的区别。

    • 如果您正在使用 Windows 防火墙，则必须打开该端口。有关说明，请参阅如何将防火墙配置为允许报表服务器访问。

  6. 如果尚未进行验证，请验证 IIS（如果已安装）的虚拟目录名称是否与您要使用的名称不同。

  7. 如果安装了 SSL 证书，则现在可以选择它以将 URL 绑定到计算机上安装的 SSL 证书。

  8. （可选）如果选择了 SSL 证书，则可以指定一个自定义端口。默认端口为 443，但您可以使用任何可用端口。

  9. 单击“应用”创建 URL。

  10. 通过单击页面 URL 部分中的链接来测试该 URL。请注意，必须先创建并配置报表服务器数据库，然后才能测试 URL。有关说明，请参阅如何创建报表服务器数据库（Reporting Services 配置）。

  11. 此外，如果将报表服务器配置为使用 SharePoint 集成模式，则在 SharePoint 管理中心中配置报表服务器 Web 服务 URL。有关如何在 SharePoint 管理中心中更新报表服务器 Web 服务 URL 的详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

为报表管理器创建 URL 保留项

  1. 启动 Reporting Services 配置工具并连接到报表服务器实例。

  2. 单击“报表管理器 URL”。

  3. 指定虚拟目录。报表管理器与报表服务器 Web 服务将侦听相同的 IP 地址和端口。如果将报表管理器配置为指向不同的报表服务器 Web 服务，则必须在 RSReportServer.config 文件中修改报表管理器 URL 设置。有关说明，请参阅 SQL Server 联机丛书中的如何配置报表管理器。

  4. 如果安装了 SSL 证书，则可以选择它以要求通过 HTTPS 路由针对报表管理器的所有请求。

    （可选）如果选择了 SSL 证书，则可以指定一个自定义端口。默认端口为 443，但您可以使用任何可用端口。

  5. 单击“应用”创建 URL。

  6. 通过单击页面 URL 部分中的链接来测试该 URL。

设置高级属性以指定其他 URL

您可以通过指定不同的端口或主机名（域名服务器可以解析为分配给计算机的 IP 地址的 IP 地址或主机标头名称）为报表服务器 Web 服务或报表管理器保留多个 URL。通过创建多个 URL，可以为同一个报表服务器实例设置不同的访问路径。例如，若要启用报表服务器的 Intranet 和 Extranet 访问，可以为 Intranet 访问使用默认 URL，并为 Extranet 访问使用另一个完全限定的主机名：

  • http://myserver01/reportserver

  • http://www.adventure-works.com/reportserver

不能为同一个应用程序实例设置多个虚拟目录名称。每个 Reporting Services 应用程序实例只能映射到一个虚拟目录名称。如果同一台计算机上有多个 Reporting Services 实例，则应用程序的虚拟目录名称应包含实例名称以确保每个请求都能到达其预期目标。

设置 URL 的高级属性

  1. 在“Web 服务 URL”或“报表管理器 URL”页上，单击“高级”。

  2. 单击“添加”。

  3. 单击“IP 地址”或“主机标头名称”。如果指定主机标头，请确保指定一个 DNS 服务可以解析的名称。如果指定可以公共使用的域名，请包含整个 URL，包括 http://www。

  4. 指定端口。如果指定自定义端口，则应用程序的 URL 必须始终包含该端口号。

  5. 单击“确定”。

  6. 通过打开浏览器窗口并输入 URL 来测试 URL。

同一台计算机上多个报表服务器实例的 URL

如果为多个 Reporting Services 实例保留 URL，则应遵循下列命名约定以避免命名冲突。有关详细信息，请参阅多实例报表服务器部署的 URL 保留项。

URL 配置示例

下面列出了报表服务器 URL 的某些可能样式示例：

  • http://localhost/reportserver

  • http://localhost/reportserver_SQLEXPRESS

  • http://sales01/reportserver

  • http://sales01:8080/reportserver

  • https://sales.adventure-works.com/reportserver

  • https://www.adventure-works.com:8080/reportserver01

用来访问报表管理器的 URL 也具有类似的格式，并通常创建在承载报表服务器的同一网站下。唯一的不同是虚拟目录名称（这里是 reports，不过您可以将其配置为需要的任意名称）：

  • http://localhost/reports

  • http://localhost/reports_SQLEXPRESS

  • http://sales01/reports

  • http://sales01:8080/reports

  • https://sales.adventure-works.com/reports

  • https://www.adventure-works.com:8080/reports

请参阅

任务

如何启动 Reporting Services 配置

概念

配置报表服务器 URL

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何在 SharePoint 管理中心中配置报表服务器集成

如何在 SharePoint 管理中心中配置报表服务器集成 |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

如果要将报表服务器配置为在所部署的 SharePoint 产品中运行，则必须指定用来确定 SharePoint 技术实例和 Reporting Services 报表服务器之间连接的集成设置。

  • 您必须是 SharePoint 场的管理员才能配置报表服务器集成：

  • 您必须已安装用于 SharePoint 产品的 Reporting Services 外接程序，它提供配置页和一般的集成。

  • 还必须还有一个目标报表服务器，该服务器已连接到为 SharePoint 集成模式创建的报表服务器数据库。

  • 如果要将 Reporting Services 配置为在 SharePoint 服务器场中运行，则报表服务器计算机上还必须安装 SharePoint Web 前端。

您指定的设置已存储在配置数据库中。如果您在为一个包含多个虚拟服务器的场配置集成，则这些设置将供所有已在 SharePoint 场中启用而且装有 Reporting Services 外接程序的 Web 前端使用。

如果您以后修改报表服务器服务帐户或者将 SharePoint 场扩展为包括其他应用程序，则必须重新运行“授予数据库访问权限”命令才能更新 SharePoint 配置数据库中的访问权限。有关详细信息，请参阅配置报表服务器服务帐户。

有关整套任务的详细信息，请参阅将 Reporting Services 配置为 SharePoint 2010 集成模式。

注意：
定义报表服务器 URL 之后，稍后进行修改时一定要谨慎。修改报表服务器 URL 将会中断服务器之间的连接，这会使当前处理的报表和模型受到影响。如果更改生产服务器上的报表服务器 URL，请确保按照为您的单位预先确定的停机步骤来进行操作。

在管理中心中指定报表服务器集成设置

  1. 在“管理工具”中，单击“SharePoint 2010 管理中心”。

  2. 单击“常规应用程序设置”选项卡。

    在 Reporting Services 部分中，应该看到下列链接：“Reporting Services 集成”、“将报表服务器添加到集成”、“设置服务器默认值”。如果您没有看到该部分或者这些链接，则说明您的计算机上没有安装 Reporting Services 外接程序或者该功能尚未激活。有关详细信息，请参阅如何在 SharePoint 管理中心中激活报表服务器功能。

  3. 单击“Reporting Services 集成”。

  4. 在“报表服务器 Web 服务 URL”中，指定要与当前的 SharePoint 站点或场一起使用的报表服务器站点。该 URL 可以指向单个报表服务器实例，也可以是一组负载平衡报表服务器（在扩展部署中运行）的虚拟服务器名称。

    若要获取 URL，请打开 Reporting Services 配置工具，连接到报表服务器，然后单击“Web 服务 URL”。单击该 URL，验证其是否有效。复制该 URL 并将其粘贴到“报表服务器 Web 服务 URL”中。

    报表服务器 URL 中包括在 Reporting Services 配置工具中指定的服务器名称和虚拟目录。下面的示例说明了如何构造报表服务器 URL：

    • http://your-server-name/reportserver（如果报表服务器位于不同的计算机，则可使用此示例）。

    • https://your-server-name:443/reportserver。

    请不要为用于整个 SharePoint 场的报表服务器 URL 指定 http://localhost。对于安装在远程服务器上的 SharePoint Web 前端，指定为 http://localhost 的 URL 地址将无效。

    如果将报表服务器与 SharePoint 技术实例并行安装，请检查虚拟目录名称是否存在冲突。有关互操作性问题的详细信息，请参阅 SQL Server 联机丛书中的Deploying Reporting Services and Internet Information Services Side-by-Side。

  5. 在“身份验证模式”中，选择“Windows 身份验证”或“可信帐户”，以便指定安装在 SharePoint 服务器上的报表服务器端点是否为报表服务器上的模拟连接发送带有安全令牌的标头。

    Reporting Services 应用程序页上的用户操作发出的所有请求都将由 SharePoint Web 应用程序上的报表服务器端点转发到报表服务器进行处理。根据身份验证模式，这些请求的标头中可以包括也可以不包括 SharePoint 用户标识令牌。

    如果将 SharePoint Web 应用程序配置为进行 Windows 身份验证配置并启用了 Kerberos 协议，则可以选择“Windows 身份验证”来通过 Windows 集成安全性进行连接。在这种情况下，将不发送用户标识令牌。（可选）可以选择“可信帐户”来模拟可信帐户并将请求标头中的 SharePoint 用户信息发送到报表服务器。

    有关服务器连接的详细信息，请参阅 SQL Server 联机丛书中的 SharePoint 集成模式下的 Reporting Services 安全性概述。

  6. 在“凭据”中，指定表示报表服务器所在计算机上管理员组的成员的凭据。

  7. 在“激活 Reporting Services 功能”中，选择要为其激活 Reporting Services 集成功能的范围，该范围可以是所有网站集，也可以是您选择的那些网站集。

  8. 单击“确定”。

  9. 在“Reporting Services”部分中，单击“设置服务器默认值”。

  10. 在“报表历史记录快照”中，为要保留的报表历史记录副本数设置站点范围内的默认值。默认值是初始设置，用于确定可以为每个报表存储的快照数。可以在特定报表的属性页中指定其他限制。

  11. 在“报表处理超时”中，指定在一定时间段（以秒为单位）之后报表服务器上的报表处理是否超时。此值应用于报表服务器上的报表处理。它不会影响为报表提供数据的数据库服务器上的数据处理。报表处理计时器时钟在您选择报表时开始运行，而在报表打开时结束运行。所指定的值必须足以完成数据处理和报表处理。

  12. 在“报表处理日志”中，指定报表服务器是否会生成跟踪日志及日志的保留天数。这些日志存储在报表服务器计算机上的 \Microsoft SQL Server\MSSQL.n\ReportServer\Log 文件夹中。每次重新启动该服务时都要启动新的日志文件。有关日志文件的详细信息，请参阅 报表服务器服务跟踪日志。

  13. 在“启用 Windows 集成安全性”中，指定与报表数据源的连接是否可以使用请求报表的用户的 Windows 安全令牌。

  14. 在“允许运行即席报表”中，指定用户是否可以从报表生成器报表执行即席查询。设置此选项会设置报表服务器的 EnableLoadReportDefinition 属性。如果清除此选项，则报表服务器将不会为使用报表模型作为数据源的报表生成点击链接型报表。

  15. 在“启用 RSClientPrint ActiveX 控件下载”中，指定用户是否可以下载提供打印选项的客户端控件。

  16. 在“启用报表生成器下载”中，指定客户端是否能够看到可用于下载报告生成器应用程序的按钮。

  17. 在“自定义报表生成器启动 URL”中，在报表服务器未使用默认报表生成器 URL 时指定自定义 URL。此设置是可选的。如果不指定值，将使用默认 URL，它将启动 Report Builder 3.0。若要将 Report Builder 1.0 作为 Click-Once 应用程序启动，请输入以下值：http://<计算机名称>/ReportServer/ReportBuilder/ReportBuilder_1_0_0_0.application。

  18. 单击“确定”。.

请参阅

任务

如何在独立服务器上配置 SharePoint 集成
如何在多台服务器上配置 SharePoint 集成
如何在报表服务器计算机中安装 SharePoint Web 前端

概念

如何安装或卸载 Reporting Services 外接程序
如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何在独立服务器上配置 SharePoint 集成

如何在独立服务器上配置 SharePoint 集成 |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

在 SharePoint 集成模式下运行 Reporting Services 的部署方案之一就是将所有服务器组件和应用程序数据库安装在一台独立服务器上。如果您希望了解这些技术如何协作，或者要开发自定义应用程序并希望只需一台计算机即可运行所有服务，则该配置非常有用。

必备项

安装组件之前，请确保执行以下操作：

  • 查阅部署配置的介绍，熟悉将要安装的组件。有关详细信息，请参阅 SQL Server 联机丛书中的SharePoint 集成模式下的 Reporting Services 的部署拓扑。

  • 查阅配置概述主题，获取有关服务帐户配置的最佳实践建议，并了解有关配置步骤的更多信息。有关详细信息，请参阅将 Reporting Services 配置为 SharePoint 2010 集成模式。

  • 查阅适用于在 SharePoint 集成模式下包括 Reporting Services 的所有部署方案的硬件和软件要求。有关详细信息，请参阅 SQL Server 联机丛书中的在 SharePoint 集成模式下运行 Reporting Services 的要求。

  • 查阅本主题中的其余章节，了解适用于独立服务器配置的其他要求。

独立服务器配置的数据库注意事项

Reporting Services 和 SharePoint 产品和技术均使用 SQL Server 关系数据库来存储应用程序数据。Reporting Services 需要使用兼容版本的数据库引擎的一个实例。如果您提供了数据库服务器，则 SharePoint 产品和技术可以使用现有的数据库服务器。如果您未提供数据库服务器，安装程序将会将 SQL Server Embedded Edition 安装为内部组件并将它用于应用程序数据库。由于您已经为 Reporting Services 安装了数据库引擎，所以可以考虑将该实例同时用于 SharePoint 应用程序数据库。

但是，如果您允许安装程序安装和使用 SQL Server Embedded Edition，则可以显著减少安装和配置步骤。如果您拥有足够的磁盘空间，则应当使用 SharePoint 提供的 Embedded Edition。

如果您不希望计算机上有多个 SQL Server 实例，则可以将数据库引擎用于 SharePoint 配置和内容数据库。为此，在安装 SharePoint 产品或技术时，必须选择“高级”安装选项。

注意：
报表服务器实例不能将 Embedded Edition 用于其数据库。但是，由 SharePoint 产品或技术安装的 Embedded Edition 实例可以与您可能同时安装的其他数据库引擎版本并存。有关报表服务器数据库版本要求的详细信息，请参阅创建报表服务器数据库。

安装顺序

可以按任意顺序安装组件技术，但是，为了获得最佳效果，应当先安装 Reporting Services，并在确认安装有效后再安装 SharePoint 产品或技术。

为了节省步骤，应当同时安装 Reporting Services 和数据库引擎。由于要一起安装数据库引擎和 Reporting Services，因此您将很可能有机会以默认配置安装 Reporting Services，在默认配置中，虚拟目录、服务帐户和报表服务器数据库均在安装过程中自动配置。

以下列表概述了必须执行的部署任务：

  1. 安装 Reporting Services 和数据库引擎。如有可能，请在安装 Reporting Services 时选择“安装 SharePoint 模式默认配置”选项。否则，可以选择“安装但不配置”选项，在执行安装后任务的过程中配置服务器。

  2. 配置报表服务器（如果尚未对其配置），并确认您拥有有效的安装。

  3. 下载并安装 Microsoft .NET Framework 3.0 可再发行包。

  4. 安装 SharePoint Server 2010 或 SharePoint Foundation 2010。选择“基本”安装选项。

  5. 运行 SharePoint 产品和技术配置向导，然后打开 SharePoint 站点以确认您拥有有效的安装。

  6. 下载并安装用于 SharePoint 技术的 Reporting Services 外接程序。

  7. 在管理中心中配置报表服务器集成功能。

安装 Reporting Services 和数据库引擎

  • 将 Reporting Services 和数据库引擎安装到同一台计算机上。有关详细信息，请参阅 SQL Server 联机丛书中的如何安装 SQL Server 2008 R2（安装程序）。

  • 配置报表服务器，但是在创建报表服务器数据库时，选择与 SharePoint 集成模式相对应的选项。有关详细信息，请参阅 SQL Server 联机丛书中的如何配置报表服务器。

在完成安装之后，可以通过连接到报表服务器验证该安装是否成功。可以通过在浏览器窗口的 URL 地址中输入 http://localhost/reportserver 来测试连接。

下载并安装 .NET Framework 3.0 可再分发包

  1. 从 Microsoft 下载中心下载 .NET Framework 3.0 redistributable package（.NET Framework 3.0 可再分发包）。

  2. 运行安装程序。安装程序将在后台运行，而且可能需要一些时间才能完成。若要检查安装进度，请在任务栏的通知区域中单击 Microsoft .NET Framework 3.0 安装图标。

安装 SharePoint 产品或技术

  1. 从安装介质中运行 Setup.exe。

  2. 输入由 25 个字符组成的产品密钥。

  3. 接受软件许可协议。

  4. 单击“基本”。

    此选项提供的安装步骤最少。它会立即使用所有默认值来安装软件。它还自动执行用于设置管理中心和默认 SharePoint 站点的配置步骤。

    如果要使用现有的数据库引擎实例，必须改为单击“高级”。如果选择该选项，安装程序会提供“完全”安装选项，供您指定要使用的数据库服务器。请记住，选择“高级”安装选项会增加以后必须执行的配置步骤的复杂程度。有关如何指定和配置“高级”安装的详细信息，请按照如何在多台服务器上配置 SharePoint 集成中的“安装 SharePoint 产品或技术”过程操作。在完成多服务器部署主题中的“高级”安装和配置步骤时，请返回到本主题，更改端口分配情况并继续执行其余任务。

  5. 在“已完成”页中，验证与“运行 SharePoint 产品和技术配置向导”相对应的复选框是否处于选中状态。

  6. 单击“关闭”。

    在安装程序关闭之后，SharePoint 产品和技术配置向导将运行。如果选择的是“基本”安装选项，配置任务将在后台运行，您可以在配置任务完成后单击“完成”。

  7. 验证安装是否成功。默认情况下，在完成配置任务之后，SharePoint 站点将在浏览器窗口中打开。此步骤将验证安装和配置过程。

默认情况下，SharePoint 产品和技术配置向导会为 SharePoint Web 应用程序分配端口 80，这将导致报表服务器变得不可用。因此，您现在必须将报表服务器配置设置修改为使用另一个端口，而且必须启动默认网站。

验证是否已针对 SharePoint 集成模式配置了报表服务器数据库

  1. 启动 Reporting Services 配置工具并连接到报表服务器实例。有关说明，请参阅如何启动 Reporting Services 配置。

  2. 在“报表服务器状态”页中，验证“报表服务器模式”是否设置为“SharePoint 集成”。

  3. 如果没有针对 SharePoint 集成模式配置报表服务器，请单击“数据库”，并针对 SharePoint 集成模式创建报表服务器数据库。有关说明，请参阅如何创建报表服务器数据库（Reporting Services 配置）和如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）。

如果您使用的是新安装的 Reporting Services 并且希望支持无人参与的报表执行，则还应配置无人参与的报表处理帐户。或者，配置报表服务器，以通过电子邮件进行传递。有关详细信息，请参阅配置无人参与的执行帐户和配置报表服务器以进行电子邮件传递。

下载并安装用于 SharePoint 技术的 Reporting Services 外接程序

  1. 单击用于 SharePoint 技术的 Microsoft SQL Server 2008 Reporting Services 外接程序打开 Microsoft 网站的下载页面。

    重要提示：
    若要安装 Reporting Services 外接程序，您必须是 SharePoint Web 场管理员和网站集管理员。

  2. 选择要安装的语言。

  3. 在“此下载中包括的文件”中，单击“下载”以安装 32 位或 64 位版本的 Reporting Services 外接程序。

  4. 单击“保存”将该文件保存到您的计算机上的某个位置。

  5. 打开 Windows 资源管理器并浏览到该文件所在的文件夹。

  6. 双击 SharePointRS.msi 开始安装。有关详细信息，请参阅如何安装或卸载 Reporting Services 外接程序。

  7. 获取 Reporting Services 外接程序的最新版本的自述文件以了解最新的更改和已知问题。在 Microsoft 网站的下载页中，在“此下载中包括的文件”中单击“下载”以打开 readme_rsaddin.htm 文件，然后将该文件保存到计算机上。

配置报表服务器集成

  1. 依次单击“开始”、“管理工具”和“SharePoint 2010 管理中心”。

    重要提示：
    若要完成以下步骤，您必须是 SharePoint 场管理员组的成员和网站集管理员。

  2. 单击“应用程序管理”。应该会看到一个名为 Reporting Services 的新部分。该部分包含一些链接，这些链接所指向的页面可用来指定集成设置。如果您没有看到该部分，则必须激活报表服务器集成功能。有关详细信息，请参阅如何在 SharePoint 管理中心中激活报表服务器功能。

    您必须至少设置报表服务器 URL、选择身份验证模式并授予报表服务器访问 SharePoint 数据库的权限。有关详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

  3. 关闭管理中心。

后续步骤

通过启动 Reporting Services 配置工具并打开“SharePoint 集成”页查看服务器状态来验证集成。应当能看到一个链接，单击它可以启动 SharePoint 管理中心。

也可以通过打开报表服务器的浏览器窗口来验证安装。URL 应当类似于 http://example-server-name:8080/reportserver。该 URL 指向代理端点。在 SharePoint 库中添加报表服务器项后，您可以将浏览器窗口打开到该 URL 以查看该站点上的各项。

最后，您应能够打开 SharePoint Web 应用程序并能够将报表和其他文档上载到 SharePoint 库。

在安装了所有组件并配置了用来连接服务器组件的设置之后，必须分配相应的权限、添加内容类型并在 SharePoint 库中添加报表服务器项。
完成服务器集成部署任务
  1. 打开 SharePoint Web 应用程序。默认情况下，该 URL 为 http://<服务器名称>。

  2. 设置权限以授予用户访问 SharePoint 站点的权限。安全性是必需的，但如果要继承现有的权限，则不必设置对特定项的权限。有关详细信息，请参阅 SQL Server 联机丛书中的在 SharePoint 站点上授予对报表服务器项的权限或如何在 SharePoint 站点上为报表服务器项设置权限（SharePoint 集成模式下的 Reporting Services）。

  3. 如果要创建新的共享数据源、报表模型和报表生成器报表，请添加 Reporting Services 内容类型。有关详细信息，请参阅 SQL Server 联机丛书中的如何将报表服务器内容类型添加到库中（SharePoint 集成模式下的 Reporting Services）。

  4. 创建共享数据源以与报表和模型配合使用。有关详细信息，请参阅 SQL Server 联机丛书中的如何创建和管理共享数据源（SharePoint 集成模式下的 Reporting Services）。

  5. 创建共享计划以与订阅或无人参与的报表处理配合使用。有关详细信息，请参阅 SQL Server 联机丛书中的如何创建和管理共享计划（SharePoint 集成模式下的 Reporting Services）。

  6. 将报表定义文件 (.rdl)、数据源文件 (.rds) 和报表模型文件 (.smdl) 发布到 SharePoint 库。您还可以在 SharePoint 库中使用上载命令以上载 .rdl 和 .smdl 文件，但不能上载 .rds 文件。根据您拥有的权限，还可以在报表生成器中创建报表，并将报表保存到库中。如果这些报表包含对共享数据源或外部文件的引用，则必须更新这些引用。有关详细信息，请参阅 SQL Server 联机丛书中的将模型和共享数据源部署到 SharePoint 站点和如何将文档上载到 SharePoint 库（SharePoint 集成模式下的 Reporting Services）。

上载报表时，请确保报表的数据源属性正确。数据源必须具有有效的外部数据源连接字符串。凭据类型必须对您的网络拓扑有效。特别要注意的是，如果您的域未启用 Kerberos 身份验证，则不能使用 Windows 集成安全性凭据类型。您应当转而指定存储凭据。验证数据源属性正确之后，可以单击报表名称来打开报表。报表将在报表查看器 Web 部件中自动打开。

如果报表未打开，请检查您对该报表拥有的权限，并检查用来定义与外部数据源连接的数据源属性。在站点或场上，SharePoint 权限用于控制对报表、报表模型、共享数据源以及报表生成器工具（用来创建即席报表）的访问权限。如果用户看不到这些项，则应验证权限是否设置正确。

无法通过报表管理器或 SQL Server Management Studio 管理运行在 SharePoint 集成模式下的报表服务器。关于支持的功能和不支持的功能的完整列表，请参阅 SQL Server 联机丛书中的 Reporting Services 在 SharePoint 集成模式下支持的功能。

请参阅

任务

如何在多台服务器上配置 SharePoint 集成

概念

将 Reporting Services 配置为 SharePoint 2010 集成模式

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何在多台服务器上配置 SharePoint 集成

如何在多台服务器上配置 SharePoint 集成 |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

本主题提供以 SharePoint 集成模式在多服务器部署拓扑中安装和配置 Reporting Services 的分步说明。如果有大量用户从 SharePoint 站点访问报表，建议采用此配置。

必备项

安装组件之前，请确保执行以下操作：

  • 查阅部署配置的介绍，熟悉将要安装的组件。有关详细信息，请单击 SQL Server 联机丛书中的SharePoint 集成模式下的 Reporting Services 的部署拓扑。

  • 查阅有关为服务帐户配置建议的最佳实践的配置概述主题，并了解有关配置步骤的更多信息。有关详细信息，请单击将 Reporting Services 配置为 SharePoint 2010 集成模式。

  • 查阅适用于在 SharePoint 集成模式下包括 Reporting Services 的所有部署方案的硬件和软件要求。有关详细信息，请单击 SQL Server 联机丛书中的在 SharePoint 集成模式下运行 Reporting Services 的要求。

  • 查阅本节中的其余各项，了解适用于独立服务器配置的其他要求。
多服务器部署的服务器要求

必须至少有两台或三台服务器。如果预计用户相当多，则通常将应用程序数据承载到由数据库引擎以独占方式使用的第三台服务器上以改进性能。

如果使用两台服务器，则每台服务器都应当具有以下组件：

  • 在一台服务器上安装 SQL Server 2008 Reporting Services 和数据库引擎。此服务器将用来承载报表服务器、报表服务器数据库和 SharePoint 应用程序数据库。

  • 在第二台服务器上，安装 Microsoft .NET Framework 3.0 可再发行包（SharePoint 产品或技术的实例）和 Reporting Services 外接程序。此服务器将成为场中的主服务器。管理中心将安装在此服务器上。用户将从该计算机上的网站集访问报表服务器内容。

多服务器部署的帐户要求

必须有一个域用户帐户才能将 SharePoint 产品或技术的实例连接到 SharePoint_config 数据库。服务器场要求使用域帐户建立服务和数据库连接。如有可能，请创建一个只能用于该应用程序的新帐户。请避免使用您自己的凭据或者将以普通用户身份访问 SharePoint 站点的任何用户的凭据（您将遇到“访问被拒绝”错误）。

必须为域帐户创建一个 SQL Server 数据库登录名。此登录名需要对服务器具有 DBCreator 权限。

必须将 SharePoint 应用程序池进程帐户配置为作为域用户运行。

必须将报表服务器服务配置为作为域用户帐户运行。

重要提示：
对于分布式服务器部署（其中报表服务器、SharePoint Web 应用程序和服务器数据库位于三台不同的计算机上），可以使用包含默认网站和端口分配的默认设置。如果将 SharePoint Web 应用程序和报表服务器安装在不同的计算机上，但将 SharePoint 数据库放在报表服务器计算机上，那么，除非遵循上节所述的有关服务帐户配置的准则，否则将遇到连接错误。有关详细信息，请参阅如何为 Reporting Services 配置服务帐户。

管理员凭据是执行如下操作所必需的：运行所有的安装程序；授予权限以成为网站集主管理员；在配置报表服务器集成时授予数据库访问权限。

安装顺序

可以按任意顺序安装组件技术。为了获得最佳结果，请确认在集成每个服务器产品或技术之前已正确安装它们。

下面列出了部署任务的摘要：

  1. 安装 Reporting Services 和数据库引擎。如果要在生产服务器上安装服务器软件，或者使用的是三服务器部署配置，请计划选择“安装但不配置服务器”选项，以便可以控制报表服务器的配置时间和方式。

  2. 配置报表服务器并验证安装是否有效。

  3. 下载并安装 .NET Framework 3.0 可再发行包。

  4. 安装 SharePoint Server 2010 或 SharePoint Foundation 2010。计划选择“高级”安装选项，以便可以在配置过程中指定远程数据库服务器。

  5. 运行 SharePoint 产品和技术配置向导并选择数据库服务器。

  6. 在管理中心中配置网站集功能，并打开 SharePoint 站点以确认安装有效。

  7. 下载并安装用于 SharePoint 技术的 Reporting Services 外接程序。

  8. 在管理中心中配置报表服务器集成功能。

安装 Reporting Services 和数据库引擎

  • 将 Reporting Services 和数据库引擎安装在相同或不同计算机上。有关详细信息，请参阅 SQL Server 联机丛书中的安装 Reporting Services 的注意事项。

在完成安装之后，将报表服务器配置为执行本机模式操作以验证安装是否成功。这样做之后，将可以使用报表管理器来验证安装。

有关如何启动 Reporting Services 配置工具以及如何将报表服务器配置为执行本机模式操作的说明，请参阅 Reporting Services 配置操作指南主题。

下载并安装 .NET Framework 3.0 可再发行包

  1. 在另一台将用于 SharePoint 产品或技术实例的服务器上，从 Microsoft 下载中心下载 .NET Framework 3.0 redistributable package（.NET Framework 3.0 可再发行包）。

  2. 运行安装程序。安装程序将在后台运行，而且可能需要一些时间才能完成。若要检查安装进度，请在任务栏的通知区域中单击 Microsoft .NET Framework 3.0 安装图标。

安装 SharePoint 产品或技术

  1. 从安装介质中运行 Setup.exe。

  2. 输入由 25 个字符组成的产品密钥。

  3. 接受软件许可协议。

  4. 单击“高级”。

    1. 在“服务器类型”中，单击“Web 前端”。

    2. “数据位置”选项卡用于指定搜索索引文件的位置。在“数据位置”中，使用默认值或选择具有多余磁盘空间的计算机。

    3. 单击“立即安装”。

  5. 配置 SharePoint 产品或技术。SharePoint 产品和技术配置向导应在安装完成后启动。如果未启动，请从“管理工具”中启动它。

    1. 在欢迎屏幕上，单击“下一步”。

    2. 如有必要，单击“是”以重新启动此服务。

    3. 在“连接到服务器场”页上，单击“否，我希望创建新的服务器场”，然后单击“下一步”。

    4. 在“指定配置数据库设置”页上，输入数据库服务器的名称。如果将数据库引擎安装为默认实例，则数据库服务器与计算机同名。

    5. 在“用户名”和“密码”中，键入有权登录该计算机、具有 SQL Server 数据库登录名并对该服务器具有 DBCreator 权限的域用户帐户的凭据。如有可能，请指定一个仅用来运行该应用程序的帐户。请不要键入将在以后访问 SharePoint 站点的用户的凭据；否则，该用户可能会在以后访问该站点上的内容时收到“访问被拒绝”错误。单击“下一步”。

    6. 在“配置 SharePoint 管理中心”页上，单击“下一步”接受所有默认值。如果已知在域中针对 Windows 身份验证启用了模拟和委托功能，则可以改为选择“协商(Kerberos)”。否则，请选择默认值并单击“下一步”。

    7. 在“正在完成 SharePoint 产品和技术配置向导”上，单击“下一步”开始使用指定的设置进行配置。

    8. 单击“完成”。

配置 SharePoint Web 应用程序

  1. 依次单击“开始”、“管理工具”和“SharePoint 2010 管理中心”。按照管理员任务中的检查表操作。有关每个任务的详细信息，请单击“阅读部署步骤”链接，然后打开“快速入门指南”。需要执行以下步骤中的任务。

  2. 创建 Web 应用程序：

    1. 单击“创建 SharePoint 网站”。

    2. 单击“新建 Web 应用程序”。

    3. 选择使用默认值“新建 IIS 网站(SharePoint - 80)”。这包括使用端口 80、不使用主机标头、使用默认路径、使用 NTLM 和不使用匿名访问。请确保指定应用程序池进程帐户。选择一个域用户帐户。

    4. 单击“确定”。

  3. 在“已创建应用程序”页上单击“创建网站集”。

    1. 输入一个标题。

    2. 对于所有选项均使用默认值。在指定网站集主管理员时，指定具有本地管理员权限的帐户。

    3. 单击“确定”。

  4. 打开命令提示符窗口并键入 iisrest /noforce。

  5. 单击此 URL 以验证网站。

  6. （可选）在管理中心中，启用诊断日志记录。

将报表服务器配置为 SharePoint 集成模式

  1. 在报表服务器计算机上安装和配置 SharePoint Web 前端。有关说明，请参阅如何在报表服务器计算机中安装 SharePoint Web 前端。

    1. 浏览器窗口将打开至主服务器上的管理中心，可以在这里验证服务器场的配置是否成功。

  2. 配置报表服务器集成：

    1. 启动 Reporting Services 配置工具并连接到报表服务器实例。有关说明，请参阅如何启动 Reporting Services 配置。

    2. 在左导航窗格内，单击“服务帐户”。验证它使用的是否为域用户帐户。如果不是，请将它配置为使用域用户帐户。

    3. 在导航窗格内，单击“数据库”。

      注意：
      如果使用的是远程数据库引擎实例，请参阅如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）了解详细信息。

    4. 单击“更改数据库”。

    5. 选择“新建数据库”。

    6. 单击“下一步”。

    7. 指定将承载该数据库的数据库引擎实例。

    8. 单击“测试连接”，确认可以连接到它。

    9. 单击“下一步”。

    10. 在“数据库名称”中，键入新数据库的名称（例如，reportserverSharepointMode）。

    11. 选择“SharePoint 集成模式”。

    12. 单击“下一步”。

    13. 指定报表服务器用于连接到报表服务器数据库的凭据。

    14. 单击“下一步”。

    15. 单击“下一步”。

    16. 单击“完成”。

    17. 配置无人参与的执行帐户和其他要更改的任何设置。报表服务器虚拟目录的值应当仍有效。但是，在将报表服务器配置为使用 SharePoint 集成模式数据库之后，报表管理器将不再可用（报表管理器虚拟目录的选项卡应当显示为灰色）。

下载并安装 Reporting Services 外接程序

  1. 单击 Microsoft SQL Server 2008 打开 Microsoft 网站的下载页面。

    重要提示：
    若要安装 Reporting Services 外接程序，您必须是 SharePoint Web 场管理员和网站集管理员。

  2. 选择要安装的语言。

  3. 在“此下载中包括的文件”中，单击“下载”以安装 32 位或 64 位版本的 Reporting Services 外接程序。

  4. 单击“保存”将该文件保存到您的计算机上的某个位置。

  5. 打开 Windows 资源管理器并浏览到该文件所在的文件夹。

  6. 双击 rsSharePoint.msi 开始安装。有关说明，请参阅如何安装或卸载 Reporting Services 外接程序。

  7. 获取 Reporting Services 外接程序的最新版本的自述文件以了解最新的更改和已知问题。在 Microsoft 网站的下载页中，在“此下载中包括的文件”中单击“下载”以打开 readme_rsaddin.htm 文件，然后将该文件保存到计算机上。

在管理中心中配置服务器集成

  1. 依次单击“开始”、“管理工具”和“SharePoint 2010 管理中心”。

    重要提示：
    若要完成以下步骤，您必须是 SharePoint 场管理员组的成员和网站集管理员。

  2. 单击“应用程序管理”。应该会看到一个名为 Reporting Services 的新部分。该部分包含一些链接，这些链接所指向的页面可用来指定集成设置。如果您没有看到该部分，则必须激活报表服务器集成功能。有关详细信息，请参阅如何在 SharePoint 管理中心中激活报表服务器功能。

    您必须至少设置报表服务器 URL、选择身份验证模式并授予报表服务器访问 SharePoint 数据库的权限。有关详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

  3. 关闭管理中心。

如果 Reporting Services 服务是用内置帐户运行的，您将遇到一个错误。如果已经将服务配置为使用域用户帐户，请重新启动服务以清除旧连接信息（假定已经在当前会话中建立了连接）。有关服务帐户配置的详细信息，请参阅配置报表服务器服务帐户。

后续步骤

在安装了所有组件并配置了用来连接服务器组件的设置之后，必须分配相应的权限、添加内容类型并在 SharePoint 库中添加报表服务器项。

完成服务器集成部署任务

  1. 打开 SharePoint Web 应用程序。默认情况下，该 URL 为 http://<服务器名称>。

  2. 设置权限以授予用户访问 SharePoint 站点的权限。安全性是必需的，但如果要继承现有的权限，则不必设置对特定项的权限。有关详细信息，请参阅 SQL Server 联机丛书中的在 SharePoint 站点上授予对报表服务器项的权限或如何在 SharePoint 站点上为报表服务器项设置权限（SharePoint 集成模式下的 Reporting Services）。

  3. 如果要创建新的共享数据源、报表模型和报表生成器报表，请添加 Reporting Services 内容类型。有关详细信息，请参阅 SQL Server 联机丛书中的如何将报表服务器内容类型添加到库中（SharePoint 集成模式下的 Reporting Services）。

  4. 创建共享数据源以与报表和模型配合使用。有关详细信息，请参阅 SQL Server 联机丛书中的如何创建和管理共享数据源（SharePoint 集成模式下的 Reporting Services）。

  5. 创建共享计划以与订阅或无人参与的报表处理配合使用。有关详细信息，请参阅 SQL Server 联机丛书中的如何创建和管理共享计划（SharePoint 集成模式下的 Reporting Services）。

  6. 将报表定义文件 (.rdl)、数据源文件 (.rds) 和报表模型文件 (.smdl) 发布到 SharePoint 库。您还可以在 SharePoint 库中使用上载命令以上载 .rdl 和 .smdl 文件，但不能上载 .rds 文件。根据您拥有的权限，还可以在报表生成器中创建报表，并将报表保存到库中。如果这些报表包含对共享数据源或外部文件的引用，则必须更新这些引用。有关详细信息，请参阅 SQL Server 联机丛书中的将模型和共享数据源部署到 SharePoint 站点和如何将文档上载到 SharePoint 库（SharePoint 集成模式下的 Reporting Services）。

上载报表时，请确保报表的数据源属性正确。数据源必须具有有效的外部数据源连接字符串。凭据类型必须对您的网络拓扑有效。特别要注意的是，如果您的域未启用 Kerberos 身份验证，则不能使用 Windows 集成安全性凭据类型。您应当转而指定存储凭据。验证数据源属性正确之后，可以单击报表名称来打开报表。报表将在报表查看器 Web 部件中自动打开。

如果报表未打开，请检查您对该报表拥有的权限，并检查用来定义与外部数据源连接的数据源属性。在站点或场上，SharePoint 权限用于控制对报表、报表模型、共享数据源以及报表生成器工具（用来创建即席报表）的访问权限。如果用户看不到这些项，则应验证权限是否设置正确。

不能通过报表管理器来管理在 SharePoint 集成模式下运行的报表服务器。关于支持的功能和不支持的功能的完整列表，请参阅 SQL Server 联机丛书中的 Reporting Services 在 SharePoint 集成模式下支持的功能。

请参阅

任务

如何在独立服务器上配置 SharePoint 集成

概念

将 Reporting Services 配置为 SharePoint 2010 集成模式
配置无人参与的执行帐户
配置报表服务器以进行电子邮件传递

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何创建报表服务器数据库（Reporting Services 配置）

如何创建报表服务器数据库（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

Reporting Services 将 SQL Server 数据库用于内部存储。该数据库是必需组件，用于存储发布的报表、模型、共享数据源、会话数据、资源和服务器元数据。

若要创建报表服务器数据库或更改连接字符串或凭据，请使用 Reporting Services 配置工具“数据库”页中的选项。

何时创建或配置报表服务器数据库

如果在“仅文件”模式下安装报表服务器，则必须创建和配置报表服务器数据库。

如果在本机模式的默认配置下或 SharePoint 集成模式下安装 Reporting Services，则安装报表服务器实例时会自动创建和配置报表服务器数据库。可以使用 Reporting Services 配置工具查看或修改安装程序为您配置的设置。

开始之前

创建或配置报表服务器数据库是一个多步骤过程。创建报表服务器数据库之前，请考虑要如何指定下列各项：

选择数据库服务器

Reporting Services 需要一个 SQL Server 2005 或 2008 数据库引擎实例来承载报表服务器数据库。可以使用本地或远程服务器。

检查版本要求

验证数据库引擎的版本是否与您所使用的报表服务器版本兼容。有关版本兼容性的详细信息，请参阅创建报表服务器数据库。

启用 TCP/IP 连接

启用数据库引擎的 TCP/IP 连接。默认情况下，某些数据库引擎版本不启用 TCP/IP。本主题中提供了相关说明。

打开 SQL Server 的端口

对于远程服务器，如果使用的是防火墙软件，则必须打开数据库引擎侦听的端口。

确定一种模式

报表服务器数据库支持本机模式或 SharePoint 集成模式。“本机模式”为默认设置。要将 Reporting Services 部署为独立的应用程序服务器时，使用此模式。

计划将报表服务器与 SharePoint 产品或技术的实例一起部署时，使用“SharePoint 集成模式”。运行向导时将创建数据库，但在将报表服务器添加到 SharePoint 场之前，您将无法添加内容或查看项目。有关详细信息，请参阅 SQL Server 联机丛书中的规划部署模式。

确定报表服务器凭据

确定报表服务器与报表服务器数据库的连接方式。凭据类型包括域用户帐户、SQL Server 数据库用户帐户或报表服务器服务帐户。

这些凭据经过加密并存储在 RSReportServer.config 文件中。报表服务器将这些凭据用于与报表服务器数据库进行的连接。如果您要使用 Windows 用户帐户或数据库用户帐户，请确保指定已经存在的帐户。尽管 Reporting Services 配置工具将创建登录名并设置必要的权限，但不会为您创建帐户。有关详细信息，请参阅配置报表服务器数据库连接。

确定报表服务器语言

选择要为报表服务器指定的语言。当用户使用不同语言版本的浏览器连接到服务器时，预定义的角色名称、说明和“我的报表”文件夹不会以不同的语言显示。有关在报表服务器部署中如何使用语言资源的详细信息，请参阅 SQL Server 联机丛书中的多语言或全局部署的解决方案设计注意事项 (Reporting Services)。

检查凭据以创建和设置数据库

确保您拥有的帐户凭据具有在数据库引擎实例上创建数据库的权限。这些凭据用于一次性连接以创建报表服务器数据库和 RSExecRole。如果登录名尚不存在，将为报表服务器所用的帐户创建一个数据库用户登录名以连接到该数据库。您可以用您登录时所用的 Microsoft Windows 帐户进行连接，也可以输入 SQL Server 数据库登录名。

启用对远程报表服务器数据库的访问

  1. 如果您使用的是远程数据库引擎实例，请登录到此数据库服务器以验证或启用 TCP/IP 连接。

  2. 依次指向“开始”、“所有程序”、Microsoft SQL Server、“配置工具”，再单击“SQL Server 配置管理器”。

  3. 打开“SQL Server 网络配置”。

  4. 选择实例。

  5. 右键单击 TCP/IP，再单击“启用”。

  6. 重新启动服务。

  7. 打开防火墙软件并打开 SQL Server 侦听的端口。对于默认实例，此端口通常为用于 TCP/IP 连接的 1433 端口。有关详细信息，请参阅 SQL Server 联机丛书中的如何为数据库引擎访问配置 Windows 防火墙。

创建本地报表服务器数据库

  1. 启动 Reporting Services 配置工具并连接到要为其创建数据库的报表服务器实例。有关详细信息，请参阅如何启动 Reporting Services 配置。

  2. 在“数据库”页上，单击“更改数据库”。

  3. 单击“新建数据库”，然后单击“下一步”。

  4. 连接到您将用于创建和承载报表服务器数据库的数据库引擎实例：

    1. 键入要使用的 SQL Server 数据库引擎实例。向导将显示作为默认实例（如果可用）运行的本地数据库引擎。否则，您必须键入要使用的服务器和实例。命名实例以此格式指定：<服务器名称>\<实例名>。

    2. 输入用于一次性连接到数据库引擎的凭据以创建报表服务器数据库。有关如何使用这些凭据的详细信息，请参阅本主题中的开始之前。

    3. 单击“测试连接”以验证与服务器的连接。

    4. 单击“下一步”。

  5. 指定用于创建数据库的属性。有关如何使用这些属性的详细信息，请参阅本主题中的开始之前：

    1. 键入报表服务器数据库的名称。创建主数据库时，会同时为其创建一个临时数据库。请考虑使用一个说明性名称来帮助记忆数据库的使用方式。请注意，您指定的名称将在数据库的生存期内使用。在创建报表服务器数据库之后，不能对其进行重命名。

    2. 选择要显示角色定义和“我的报表”所用的语言。

    3. 选择服务器模式。除非计划在 SharePoint 产品或技术中部署报表服务器，否则请始终选择“本机模式”。

    4. 单击“下一步”。

  6. 指定报表服务器用来连接到报表服务器数据库的凭据。

    1. 指定身份验证类型：

      选择“数据库凭据”以使用已定义的 SQL Server 数据库登录名进行连接。如果报表服务器位于不同域、不可信域或装有防火墙的计算机中，则建议使用数据库凭据。

      如果您拥有的最低特权域用户帐户具有登录到该计算机和数据库服务器的权限，则选择“Windows 凭据”。

      如果希望报表服务器使用其自身的服务帐户进行连接，则选择“服务凭据”。使用此选项，该服务器将使用集成安全性进行连接；凭据不进行加密或存储。

    2. 单击“下一步”。

  7. 检查“摘要”页上的信息以确保设置正确，然后单击“下一步”。

  8. 单击“报表服务器 URL”页或“报表管理器 URL”页上的 URL，验证连接。必须定义这些 URL 才能进行此测试。如果报表服务器数据库连接有效，您会在浏览器窗口中看到报表服务器文件夹层次结构或报表管理器。有关详细信息，请参阅 SQL Server 联机丛书中的如何验证 Reporting Services 安装。

请参阅

任务

如何启动 Reporting Services 配置

参考

数据库（Reporting Services 配置）

概念

配置报表服务器数据库连接
Reporting Services 配置操作指南主题

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）

如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

使用 Reporting Services 配置工具创建 SharePoint 集成模式下的报表服务器数据库，并配置从报表服务器到报表服务器数据库的连接。只有报表服务器才连接到报表服务器数据库。与报表服务器集成的 Windows SharePoint Services 或 Office SharePoint Server 实例从不会连接到报表服务器数据库，也不会直接从报表服务器数据库中检索数据。

报表服务器数据库可以支持本机模式操作，也可以支持 SharePoint 集成模式，但不能同时支持这两种模式。如果创建支持 SharePoint 集成模式的报表服务器数据库，则以后无法转换或迁移该数据库，以便使用本机模式报表服务器实例运行。报表服务器数据库包含特定于模式的元数据（具体而言，是项位置和权限信息），此元数据在另一模式下不兼容。

创建 SharePoint 集成模式的报表服务器数据库时，报表服务器数据库会存储服务器属性、报表执行快照、报表历史记录、订阅定义和计划。同时还存储报表、报表模型、共享数据源和资源的第二副本以提高服务器的处理性能。报表文档的主存储位于 SharePoint 内容数据库。有关详细信息，请参阅 SQL Server 联机丛书中的存储报表服务器内容并将报表服务器内容和 SharePoint 数据库同步。

关于支持 SharePoint 集成的报表服务器数据库，需要注意以下几个要点：

  • 使用 Reporting Services 配置工具“数据库”页中的更改数据库向导创建 SharePoint 集成模式下的报表服务器数据库。有关说明，请参阅 SQL Server 联机丛书中的如何创建报表服务器数据库（Reporting Services 配置）。

  • 使用 Reporting Services 配置工具维护或更新报表服务器数据库的连接信息。

  • 使用 SQL Server Management Studio 和 SQL Server 工具来备份和管理报表服务器数据库。SharePoint 3.0 管理中心中的数据库备份功能不适用于报表服务器数据库。

  • 创建报表服务器数据库只是配置用于集成操作的报表服务器的多步骤过程中的一个步骤。创建数据库之后，通过启动 SharePoint 3.0 管理中心并指定报表服务器集成设置来完成集成步骤。有关详细信息，请参阅 SQL Server 联机丛书中的如何在 SharePoint 管理中心中配置报表服务器集成。

请参阅

任务

如何切换服务器模式（Reporting Services 配置）

概念

将 Reporting Services 配置为 SharePoint 2010 集成模式
配置报表服务器数据库连接

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何启用远程错误（Reporting Services 配置）

如何启用远程错误（Reporting Services 配置）
配置 Reporting Services > Reporting Services 配置操作指南主题 >

注意 对于 SQL Server 2008 R2，没有对本主题中所列的内容进行任何更改。

可以将报表服务器上的服务器属性设置为返回远程服务器上所发生的错误情形的其他信息。如果错误消息中包含文本“有关此错误的详细信息，请导航到本地服务器上的报表服务器或启用远程错误”，则可以将 EnableRemoteErrors 属性设置为访问可帮助您解决问题的其他信息。有关详细信息，请参阅 SQL Server 联机丛书中的报表服务器系统属性。

注意：
您可以通过编辑报表服务器数据库中的 ConfigurationInfo 表将 EnableRemoteErrors 设置为 True，但是如果报表服务器正在使用中，则应使用 SQL Server Management Studio 或脚本来修改此设置。

通过 SQL Server Management Studio 启用远程错误

  1. 启动 Management Studio 并连接到报表服务器实例。有关详细信息，请参阅 SQL Server 联机丛书中的如何在 Management Studio 中连接到报表服务器。

  2. 右键单击报表服务器节点，然后选择“属性”。

  3. 单击“高级”以打开属性页。有关详细信息，请参阅 SQL Server 联机丛书中的Server Properties (Advanced Page) - Reporting Services。

  4. 在 EnableRemoteErrors 中，选择 True。

  5. 单击“确定”。

通过脚本启用远程错误

  1. 创建文本文件并将以下脚本复制到该文件中。

    复制代码
    Public Sub Main()
  Dim P As New [Property]()
  P.Name = "EnableRemoteErrors"
  P.Value = True
  Dim Properties(0) As [Property]
  Properties(0) = P
  Try
    rs.SetSystemProperties(Properties)
    Console.WriteLine("Remote errors enabled.")
  Catch SE As SoapException
    Console.WriteLine(SE.Detail.OuterXml)
  End Try
End Sub

  2. 将文件另存为 EnableRemoteErrors.rss。

  3. 单击“开始”，指向“运行”，键入 cmd，再单击“确定”打开命令提示符窗口。

  4. 导航到包含您刚刚创建的 .rss 文件的目录。

  5. 键入以下命令行，并将 servername 替换为服务器的实际名称：

    复制代码
    rs -i EnableRemoteErrors.rss -s http://servername/ReportServer


如何在报表服务器计算机中安装 SharePoint Web 前端

如何在报表服务器计算机中安装 SharePoint Web 前端 |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

如果将报表服务器配置为在由多个服务器组成的 SharePoint 场中以 SharePoint 集成模式运行，则必须在报表服务器计算机上安装 SharePoint 产品的 Web 前端应用程序，这样便可以将报表服务器计算机与场进行联接。

SharePoint 场由均使用同一版本 SharePoint 产品的多个服务器组成。例如，如果服务器场使用 SharePoint Foundation 2010，则必须在报表服务器计算机上安装 SharePoint Foundation 2010。

若要安装 Web 前端，您必须是 SharePoint 场管理员。还必须知道数据库服务器的名称以及该服务器场使用的配置数据库的名称。

以下步骤仅当在 SharePoint 服务器场中部署报表服务器时才需要。如果所有服务器应用程序都在一台计算机中运行，则无需在报表服务器上安装 Web 前端。

在安装 Web 前端并将报表服务器计算机联接到场之后，可以使用 SharePoint 管理中心关闭不需要的任何 Web 前端功能。

安装 Web 前端

  1. 在运行 Reporting Services 的服务器中，运行用于该场的 SharePoint 产品的安装程序。

  2. 在“安装类型”中，单击“高级”。

  3. 在“服务器类型”中，选择“Web 前端”。

  4. “数据位置”选项卡用于指定搜索索引文件的位置。在“数据位置”中，使用默认值或选择具有多余的磁盘空间的计算机。

  5. 单击“立即安装”。

安装完成之后，必须配置 Web 前端以将其联接到服务器场。

配置 Web 前端

  1. 运行 SharePoint 产品和技术配置向导以将 Web 前端加入到远程 SharePoint 场中。SharePoint 产品和技术配置向导应在安装完成后启动。如果未启动，请从“管理工具”中启动它。

  2. 在欢迎屏幕上，单击“下一步”。

  3. 如有必要，单击“是”以重新启动此服务。

  4. 在“连接到服务器场”页上，选择“是”以连接到现有服务器场。单击“下一步”。

  5. 在“指定配置数据库设置”页上，指定承载配置数据库的 SQL Server 数据库引擎实例。如果您不知道配置数据库的名称，请单击“检索数据库名称”，然后选择配置数据库。

  6. 输入 Web 前端将用来连接到配置数据库的用户名和密码。单击“下一步”。

  7. 在“完成 SharePoint 产品和技术向导”页中，单击“高级设置”。

  8. 在“高级设置”中，请确认是否选择了“请勿使用此计算机承载网站”。

  9. 单击“确定”，单击“下一步”，然后完成向导。

安装 Web 前端只是整个配置过程中的一步。有关完整步骤的详细信息，请参阅将 Reporting Services 配置为 SharePoint 2010 集成模式。

有关配置集成了 Reporting Services 及 SharePoint 产品和技术的多服务器部署的详细信息，请参阅如何在多台服务器上配置 SharePoint 集成。

请参阅

概念

如何安装或卸载 Reporting Services 外接程序

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何安装或卸载 Reporting Services 外接程序

如何安装或卸载 Reporting Services 外接程序 |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

用于 SharePoint 2010 产品的 Microsoft SQL Server Reporting Services 外接程序可通过 Web 下载，您可以将其安装在具有 SharePoint 产品或技术实例的服务器上。它提供了一套功能，使您能够在较大型的 Microsoft SharePoint Foundation 2010 或 Microsoft SharePoint Server 2010 部署中运行报表服务器。这些功能包括报表查看器 Web 部件、URL 代理端点和应用程序页，以便您能够在 SharePoint 站点上创建、查看和管理报表、报表模型、数据源以及其他报表服务器内容。用于 SharePoint 2010 产品的 Reporting Services 外接程序是在 SharePoint 集成模式下运行的报表服务器的必需组件。

重要提示：
Reporting Services 部署在场级与 SharePoint 2010 产品的部署实现集成。如果在场配置中具有多个 SharePoint Web 应用程序，则必须在具有 Web 前端的每台计算机上都安装 Reporting Services 外接程序。推荐先使用安装向导将 Reporting Services 外接程序安装到某一台 Web 前端计算机上。然后使用“仅文件”模式安装将外接程序依次安装到场中的其他 Web 前端计算机上。在成功完成一次“仅文件”模式安装后，在下一台 Web 前端计算机上开始该安装，以此类推，直到在 SharePoint 场中的所有 Web 前端计算机上都完成该安装。然后，启动 SharePoint 管理中心对 SharePoint 场中的所有 Web 前端服务器配置报表服务器集成。

准备安装

将报表服务器与 SharePoint 产品或技术的实例集成需要很多步骤，安装 Reporting Services 外接程序是其中的一步。有关完整步骤的详细信息，请参阅将 Reporting Services 配置为 SharePoint 2010 集成模式。服务器配置步骤的顺序非常重要。为获得最佳结果，应确保按顺序执行。

准备安装 Reporting Services 外接程序：

  1. 以 SharePoint 场管理员的身份登录以便安装 Reporting Services 外接程序。

  2. 验证您是否具有两个服务器安装：一个报表服务器和一个 SharePoint 服务器，这样才满足集成操作的要求。有关详细信息，请参阅 SQL Server 联机丛书中的在 SharePoint 集成模式下运行 Reporting Services 的要求。

  3. 将 Reporting Services 外接程序下载到安装了 SharePoint 产品实例的服务器上。

    1. 转到 Microsoft 下载中心 上用于 SharePoint 2010 产品的 Microsoft SQL Server Reporting Services 外接程序页。

    2. 选择并下载要安装的语言版本。只提供您选择的语言版本的报表查看器 Web 部件 (ReportViewer.dwp)。不管您在下载页上选择何种语言，应用程序页和消息均可用于所有支持的语言。有关所支持的语言的详细信息，请参阅 SQL Server 联机丛书中的多语言或全局部署的解决方案设计注意事项 (Reporting Services)。

  4. 如果将 Reporting Services 与具有多个 Web 前端应用程序的 SharePoint 场集成，则将 rsSharepoint.msi 复制或下载到场中每台具有 Web 服务器前端的计算机上。仅对将要用于访问报表服务器内容的 Web 前端执行此操作。

外接程序的安装

若要安装 Reporting Services 外接程序，您必须是计算机上的管理员。

您必须是网站集管理员才能激活 Reporting Services 集成功能。

在此版本中，外接程序可在安装 SharePoint 之前安装，也可在安装 SharePoint 之后安装。此外接程序遵循 SharePoint 预部署标准，将文件安装到 SharePoint 安装所用的位置中。

注意：
在安装 SharePoint 产品或技术之前安装外接程序的好处是：当新的服务器添加到场后，SharePoint 场会配置并激活 Reporting Services 外接程序。

在安装 SharePoint 产品或技术之前安装外接程序

在您希望与 Reporting Services 集成并作为 SharePoint Web 前端运行的所有服务器上，必须安装该外接程序。如果尚未安装 SharePoint 产品或技术，则可以在所有服务器上运行外接程序安装向导。

  1. 下载 Reporting Services 外接程序的安装程序 (rsSharepoint.msi)。

  2. 以管理员身份运行 rsSharepoint.msi 以启动安装向导。向导将显示“欢迎”页、软件许可条款和注册信息页。安装程序将在 %program files%\common files\Microsoft Shared\ 下创建 SharePoint 2010 文件夹，并将文件复制到该文件夹中。您必须以管理员身份来运行 .msi，方法是首先打开提升的命令提示符窗口，然后从命令行运行 rsSharepoint.msi。

  3. 在 SharePoint 管理中心配置报表服务器集成设置和功能激活。

在安装 SharePoint 产品或技术之后安装外接程序

如果在安装 SharePoint 产品或技术之后在服务器上安装外接程序，则只能在其中一台 SharePoint 服务器上运行外接程序的“完全”安装。对于场中的其他 SharePoint 服务器，必须从命令行运行外接程序的“仅文件”安装。“仅文件”安装会安装文件，但会跳过安装过程的自定义操作部分。

在所有服务器上安装外接程序之后，启动 SharePoint 管理中心来配置报表服务器集成。

“仅文件”安装

若要安装文件但跳过自定义操作步骤，则可以从命令行中使用 SKIPCA 选项来运行 .msi：

  1. 使用管理员权限打开命令提示符。

  2. 运行 msiexec -i rsSharePoint.msi SKIPCA=1。

外接程序完全安装的两个步骤

如果安装期间出现错误，可以从命令行分两个步骤运行安装程序。首先，运行安装程序来安装文件并跳过自定义操作，然后运行自定义操作可执行文件。若要在“仅文件”模式下安装 Reporting Services 外接程序，请执行以下操作：

  1. 使用管理员权限打开命令提示符。

  2. 运行 msiexec -i rsSharePoint.msi SKIPCA=1。

  3. 在文件系统中找到 rsCustomAction.exe 文件。该文件由安装程序复制到您的计算机上。该文件将位于 %Temp% 目录。

    若要获取该文件的路径信息，请依次单击“开始”、“运行”，然后键入 %temp%。该文件应位于\Documents and Settings\<用户名称>\LOCALS~1\Temp。

    打开命令提示符窗口。为此，请依次单击“开始”、“运行”，然后键入 cmd。在更高版本的操作系统上，可能需要提升权限，并使用管理员权限运行此命令。

  4. 导航到包含 rsCustomAction 可执行文件的文件夹。

  5. 输入下面的命令。完成该配置步骤需要几分钟时间。在此过程中将重新启动 W3SVC 服务。

    复制代码
    rsCustomAction.exe /i

如何删除 Reporting Services 外接程序

可通过在卸载模式下运行安装程序 (rsSharepoint.msi) 来卸载用于 SharePoint 2010 产品的 Reporting Services 外接程序。卸载外接程序会删除用于在报表服务器上处理报表和模型的服务器集成功能。

若要卸载 Reporting Services 外接程序，必须使 SharePoint Foundation 2010 或 SharePoint Server 2010 安装仍处于运行状态。如果先卸载 SharePoint 2010，则必须重新安装该产品才能卸载 Reporting Services 外接程序。

注意：
从场中的一台活动服务器上删除外接程序时，将会从场中的所有服务器上删除该外接程序。如果只需要从一台服务器上删除外接程序，应先将此服务器从 SharePoint 场中删除，然后再卸载外接程序。

  • 在 SharePoint 网站上，删除不再使用的所有报表和其他报表服务器项。在删除 Reporting Services 外接程序后，它们不会再运行。

  • 在控制面板的“程序”中，选择“卸载程序”，然后选择“Microsoft SQL Server 2008 R2 Reporting Services SharePoint 外接程序”。

  • 单击“删除”。

卸载外接程序的步骤与卸载独立服务器和服务器场的步骤相同。安装程序将删除在安装过程中添加的程序文件和所有配置设置。

安装程序将不删除以下内容：

  • 为用于访问 SharePoint 配置和内容数据库的报表服务器服务帐户创建的登录名。必须从用于承载 SharePoint 数据库的 SQL Server 数据库引擎实例中删除报表服务器服务帐户的所有登录名。

  • 为报表用户创建的权限或组。如果创建了自定义权限级别或 SharePoint 组来授予访问报表服务器功能的权限，则应撤销不再需要的任何权限。

  • 上载到 SharePoint 库的数据文件，包括报表定义 (.rdl)、报表模型 (.smdl)、共享数据源 (.rsds) 和已发布报表项 (.rsc) 文件。不会删除这些文件，但它们将不再运行。必须手动删除这些文件。

  • 安装程序将不删除报表服务器数据库，也不修改用于集成操作的报表服务器实例。卸载外接程序后，如果要将该实例用作独立的报告应用程序，可考虑将报表服务器切换为在本机模式下运行。

如何从命令行运行 rsSharePoint.msi

可从命令行运行安装程序来修复或卸载 Reporting Services 外接程序。

  • 运行 rsSharePoint.msi -r 可修复现有安装。

  • 运行 rsSharePoint.msi -u 可卸载外接程序的现有安装。

安装日志文件

安装程序在运行期间，将会为安装 Reporting Services 外接程序的用户把相应信息记录到 %temp% 文件夹下的一个日志文件中。文件名为 RS_SP_<number>.log。日志中的每个错误都以字符串“SSRSCustomActionError”开头。

配置和激活

安装外接程序后，需要从 SharePoint 管理中心配置和查看功能激活。有关详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成和如何在 SharePoint 管理中心中激活报表服务器功能。

升级

如果具有 Reporting Services 外接程序的现有安装，则可以升级到最新版本。安装程序将检测现有版本并提示您确认是否更新。如果确认更新，则旧版本的外接程序将被删除，然后安装新版本。

请注意，Reporting Services 外接程序不能识别实例。一台计算机上只能有一个外接程序实例。不能同时运行早期版本和当前版本。

请参阅

任务

如何切换服务器模式（Reporting Services 配置）
如何在报表服务器计算机中安装 SharePoint Web 前端

概念

将 Reporting Services 配置为 SharePoint 2010 集成模式

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何为报表服务器注册服务主体名称 (SPN)

如何为报表服务器注册服务主体名称 (SPN) |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

如果要在使用 Kerberos 协议进行相互身份验证的网络中部署 Reporting Services，并且将报表服务器服务配置为以域用户帐户身份运行，则必须为报表服务器服务创建服务主体名称 (SPN)。此外，如果将域用户配置为服务帐户，则必须将报表服务器配置为使用 NTLM 身份验证。

关于 SPN

SPN 是服务在使用 Kerberos 身份验证的网络上的唯一标识符。它由服务类、主机名和端口组成。在使用 Kerberos 身份验证的网络中，必须在内置计算机帐户（如 NetworkService 或 LocalSystem）或用户帐户下为服务器注册 SPN。对于内置帐户，SPN 将自动进行注册。但是，如果在域用户帐户下运行服务，则必须为要使用的帐户手动注册 SPN。

若要创建 SPN，可使用 SetSPN 命令行实用工具。有关详细信息，请参阅 Microsoft Windows Server TechCenter 上的 Setspn。

您必须具有域管理员身份，才能在域控制器上运行该实用工具。

语法

使用 SetSPN 实用工具为报表服务器创建 SPN 的命令语法类似如下所示：

复制代码
Setspn -a http/<computername>.<domainname>:<port> <domain-user-account>

SetSPN 随 Windows Server 2003 Service Pack 1 支持工具包提供，该工具包必须单独下载。-a 参数用于使用特定帐户注册服务主体名称。

HTTP 为服务类。报表服务器 Web 服务在 HTTP.SYS 中运行。在为 HTTP 创建 SPN 时，将同时对在 HTTP.SYS（包括承载在 IIS 中的应用程序）中运行的位于同一台计算机上的所有 Web 应用程序授予基于该域用户帐户的票证。如果这些服务在其他帐户下运行，则身份验证请求将失败。为避免此问题，请务必将所有 HTTP 应用程序配置为在同一帐户下运行，或考虑为每个应用程序创建主机头，然后为每个主机头单独创建一个 SPN。配置主机标头时，无论 Reporting Services 配置如何都必须更改 DNS。

您为 <计算机名称>、<域名> 和 <端口> 指定的值将标识承载报表服务器的计算机的唯一网络地址。此地址可以是本地主机名，或者完全限定的域名 (FQDN)。如果只有一个域且使用的是端口 80，则可以省略命令行中的 <域名> 和 <端口>。<域用户帐户> 是报表服务器服务运行时使用的用户帐户，也是必须注册 SPN 的用户帐户。

为域用户帐户注册 SPN

为以域用户身份运行的报表服务器服务注册 SPN

  1. 安装 Reporting Services 并将报表服务器服务配置为以域用户帐户身份运行。请注意，直到完成以下步骤之后，用户才能连接到报表服务器。

  2. 从下载中心下载并安装 Windows Server 2003 Service Pack 1 Support Tools（Windows Server 2003 Service Pack 1 支持工具）。

  3. 以域管理员的身份登录到域控制器。

  4. 打开命令提示符窗口。

  5. 复制以下命令，并用适用于您的网络的实际值替换占位符值。

    复制代码
    Setspn -a http/<computer-name>.<domain-name>:<port> <domain-user-account>

  6. 运行命令。

  7. 打开 RsReportServer.config 文件，找到 <AuthenticationTypes> 部分。添加 <RSWindowsNegotiate/> 作为该部分的第一个项，以启用 NTLM。

请参阅

任务

如何为 Reporting Services 配置服务帐户

概念

配置报表服务器服务帐户
Reporting Services 配置操作指南主题

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何切换服务器模式（Reporting Services 配置）

如何切换服务器模式（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

如果已将报表服务器配置为在 SharePoint 集成模式下运行，则通过将此报表服务器切换为本机模式可以从部署的 SharePoint 技术实例中分离此服务器。

若要切换模式，请将报表服务器指向本机模式报表服务器数据库。切换模式时，不必重新安装报表服务器。

尽管您可以切换报表服务器的模式，但您不能切换报表服务器数据库的模式。报表服务器数据库中包含在其他上下文中无法使用的模式特定数据。如果创建了 SharePoint 集成模式下的报表服务器数据库，则无法在本机模式报表服务器上使用此数据库。

有三种方式可从 SharePoint 集成模式切换到本机模式。在 Reporting Services 配置工具的“数据库安装”页中执行下列操作之一：

  • 单击“更改”并创建新数据库。

  • 从现有数据库列表中，选择一个已在本机模式下运行的现有报表服务器数据库，指定凭据，然后单击“应用”。

  • 单击“新建”并创建新数据库。确保清除“使用支持 SharePoint 集成模式的架构”复选框。

本主题将介绍第一种方法的各个步骤。有关如何将本机模式报表服务器配置为在 SharePoint 集成模式下运行的详细信息，请参阅将 Reporting Services 配置为 SharePoint 2010 集成模式。

切换到本机模式

  1. 单击“开始”，依次指向“程序”、Microsoft SQL Server 2008 R2 和“配置工具”。

  2. 单击“Reporting Services 配置”。此时将出现“选择报表服务器安装实例”对话框，以便可以选择要配置的报表服务器实例。

  3. 在“计算机名称”中，指定安装报表服务器实例的计算机名称。指定的默认值是本地计算机名称，但也可以键入远程 SQL Server 实例的名称。

  4. 在“实例名”中，选择要配置的 SQL Server Reporting Services 实例。

  5. 单击“连接”。

  6. 单击“数据库安装”将“数据库安装”页打开。此页面包含有关当前使用的数据库的信息。应将“服务器模式”设置为“SharePoint 集成”。

  7. 单击“更改”。

  8. 单击“确定”确认要创建新数据库。

  9. 在“SQL Server 连接”对话框中，输入新数据库的名称。

  10. 确保未选中“创建 SharePoint 集成模式的报表服务器数据库”复选框。

  11. 单击“确定”。

  12. 在“数据库安装”页上，指定用于连接到报表服务器数据库的凭据。

    1. 选择“服务凭据”，以使用 Windows 服务帐户和 Web 服务帐户通过集成安全性进行连接。

    2. 选择“Windows 凭据”可以指定域用户帐户。必须将域用户帐户指定为 <域>\<用户>。

    3. 选择“SQL Server 凭据”可以指定 SQL Server 登录名。

  13. 单击“应用”。

在将 SharePoint 集成报表服务器切换为本机模式时，将重新定义内容的位置和用于控制对内容进行访问的权限。必须向报表服务器重新发布内容，您必须在报表服务器上指定可以访问项和操作的角色，并且需要重新定义订阅和预定操作。在以 SharePoint 集成模式运行的报表服务器上创建的报表历史记录无法在本机模式报表服务器上重新创建。

请参阅

任务

如何在 SharePoint 管理中心中配置报表服务器集成

概念

将 Reporting Services 配置为 SharePoint 2010 集成模式
如何安装或卸载 Reporting Services 外接程序
配置报表服务器数据库连接
如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


如何打开或关闭 Reporting Services 功能

如何打开或关闭 Reporting Services 功能 |
 | 请参阅
配置 Reporting Services > Reporting Services 配置操作指南主题 >

您可以关闭不用作锁定策略一部分的报表服务器功能，以减小生产报表服务器的攻击面。在大多数情况下，需要同时运行各种 Reporting Services 功能才能使用 Reporting Services 中提供的所有功能。但是根据所用的部署模型，您可以禁用不需要的功能。例如，如果所有报表处理均已配置为预定操作，则可以只启用后台处理。同样，如果您只需要交互式的按需报表，则可以只运行报表服务器 Web 服务。

本主题中的过程将为您演示如何关闭 Reporting Services 功能。可以不同的方式配置这些功能，如直接编辑 RsReportServer.config 文件或使用 SQL Server Management Studio 中基于策略的管理的 Reporting Services 的外围应用配置器方面。使用以下链接可以找到说明如何打开或关闭相应功能的步骤：

  • 报表服务器 Web 服务

  • 预定的事件和处理

  • 报表管理器

  • 报表生成器

  • 报表数据源的 Windows 集成安全性

报表服务器 Web 服务

通过编辑配置打开或关闭报表服务器 Web 服务

  1. 在文本编辑器中打开 RsReportServer.config 文件。有关详细信息，请参阅 SQL Server 联机丛书中的如何修改 Reporting Services 配置文件。

  2. 若要打开报表服务器 Web 服务，请将 IsWebServiceEnabled 设置为 true：

    复制代码
    <IsWebServiceEnabled>true</IsWebServiceEnabled>

  3. 若要关闭报表服务器 Web 服务，请将 IsWebServiceEnabled 设置为 false：

    复制代码
    <IsWebServiceEnabled>false</IsWebServiceEnabled>

  4. 保存所做的更改，然后关闭该文件。

使用 SQL Server Management Studio 打开或关闭报表服务器 Web 服务

  1. 打开 SQL Server Management Studio，然后连接到要配置的 Reporting Services 实例。

  2. 在对象资源管理器中右键单击 Reporting Services 节点，指向“策略”，然后单击“方面”。

  3. 在“方面”列表中，选择 Reporting Services 的外围应用配置器。

  4. 在“方面属性”下：

    • 若要打开报表服务器 Web 服务，请将 WebServiceAndHTTPAccessEnabled 设置为 True。

    • 若要关闭报表服务器 Web 服务，请将 WebServiceAndHTTPAccessEnabled 设置为 False。

  5. 单击“确定”。

预定的事件和传递

通过编辑配置打开或关闭预定的事件和传递

  1. 在文本编辑器中打开 RsReportServer.config 文件。有关详细信息，请参阅 SQL Server 联机丛书中的如何修改 Reporting Services 配置文件。

  2. 若要打开预定的报表处理和传递，请将 IsSchedulingService、IsNotificationService 和 IsEventService 设置为 true：

    复制代码
    <IsSchedulingService>true<\IsSchedulingService>
<IsNotificationService>true<\IsNotificationService>
<IsEventService>true<\IsEventService>

  3. 若要关闭预定的报表处理和传递，请将 IsSchedulingService、IsNotificationService 和 IsEventService 设置为 false：

    复制代码
    <IsSchedulingService>false<\IsSchedulingService>
<IsNotificationService>false<\IsNotificationService>
<IsEventService>false<\IsEventService>

  4. 保存所做的更改，然后关闭该文件。
注意：
不能完全关闭后台处理，因为它提供执行服务器操作所需的数据库维护功能。

使用 SQL Server Management Studio 打开或关闭预定的事件和传递

  1. 打开 SQL Server Management Studio，然后连接到要配置的 Reporting Services 实例。

  2. 在对象资源管理器中右键单击 Reporting Services 节点，指向“策略”，然后单击“方面”。

  3. 在“方面”列表中，选择 Reporting Services 的外围应用配置器。

  4. 在“方面属性”下：

    • 若要打开预定的事件和传递，请将 ScheduleEventsAndReportDeliveryEnabled 设置为 True。

    • 若要关闭预定的事件和传递，请将 ScheduleEventsAndReportDeliveryEnabled 设置为 False。

  5. 单击“确定”。

注意：
不能完全关闭后台处理，因为它提供执行服务器操作所需的数据库维护功能。

报表管理器

通过编辑配置打开或关闭报表管理器

  1. 在文本编辑器中打开 RsReportServer.config 文件。有关说明，请参阅 SQL Server 联机丛书中的如何修改 Reporting Services 配置文件。

  2. 若要打开报表管理器，请将 IsReportManagerEnabled 设置为 true：

    复制代码
    <IsReportManagerEnabled>true<\IsReportManagerEnabled>

  3. 若要关闭报表管理器，请将 IsReportManagerEnabled 设置为 false：

    复制代码
    <IsReportManagerEnabled>false<\IsReportManagerEnabled>

  4. 保存所做的更改，然后关闭该文件。

使用 SQL Server Management Studio 打开或关闭报表管理器

  1. 打开 SQL Server Management Studio，然后连接到要配置的 Reporting Services 实例。

  2. 在对象资源管理器中右键单击 Reporting Services 节点，指向“策略”，然后单击“方面”。

  3. 在“方面”列表中，选择 Reporting Services 的外围应用配置器。

  4. 在“方面属性”下：

    • 若要打开报表管理器，请将 ReportManagerEnabled 设置为 True。

    • 若要关闭报表管理器，请将 ReportManagerEnabled 设置为 False。

  5. 单击“确定”。

报表生成器

使用 SQL Server Management Studio 打开或关闭报表生成器

  1. 打开 SQL Server Management Studio，然后连接到要配置的 Reporting Services 实例。

  2. 在对象资源管理器中右键单击 Reporting Services 节点，然后单击“属性”。

  3. 在“服务器属性”对话框中，单击“选择页”下的“安全性”。

    • 若要打开报表生成器，请选择“启用即席报表执行”选项。

    • 若要关闭报表生成器，请取消选择“启用即席报表执行”选项。

  4. 单击“确定”。

Windows 集成安全性

使用 SQL Server Management Studio 打开或关闭 Windows 集成安全性

  1. 打开 SQL Server Management Studio，然后连接到要配置的 Reporting Services 实例。

  2. 在对象资源管理器中右键单击 Reporting Services 节点，然后单击“属性”。

  3. 在“服务器属性”对话框中，单击“选择页”下的“安全性”。

    • 若要打开 Windows 集成安全性，请选择“对报表数据源启用 Windows 集成安全性”选项。

    • 若要关闭 Windows 集成安全性，请取消选择“对报表数据源启用 Windows 集成安全性”选项。

  4. 单击“确定”。

请参阅

任务

如何启动 Reporting Services 配置

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


Reporting Services 配置 F1 帮助主题

Reporting Services 配置 F1 帮助主题 |
 | 请参阅
配置 Reporting Services >

本部分介绍 Reporting Services 配置工具的 F1 帮助。

本节内容

  • 连接到报表服务器

  • 报表服务器状态

  • 服务帐户

  • Web 服务 URL

  • 高级多网站配置

  • 数据库

  • 更改数据库向导

  • 更改凭据向导

  • 报表管理器 URL

  • 电子邮件设置

  • 执行帐户

  • 加密密钥

  • 备份加密密钥

  • 还原加密密钥

  • 扩展部署

请参阅

任务

如何启动 Reporting Services 配置

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


连接到报表服务器（Reporting Services 配置）

连接到报表服务器（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 >

使用此对话框连接到本地或远程 SQL Server 2008 或更高版本的 Reporting Services 报表服务器实例。不能使用此工具连接到早期版本的 Reporting Services 报表服务器。一次仅能连接到一个实例。

  • 若要连接到本地报表服务器实例，请使用默认值并单击“连接”。Reporting Services 配置工具提供了本地服务器名称并可检测到默认实例。在大多数情况下，您可以单击“连接”而不必更改值。如果安装了多个实例，则必须选择要使用的实例。

  • 若要连接到远程报表服务器实例，请键入服务器名称，单击“查找”，再选择该实例，然后单击“连接”。

若要打开此对话框，请启动 Reporting Services 配置工具。启动此工具后，该对话框会立即显示出来。有关详细信息，请参阅如何启动 Reporting Services 配置。

选项

服务器名称

输入安装了 SQL Server 2008 或更高版本的 Reporting Services 的计算机的网络名称。只键入计算机名称；不包括前缀或斜杠。

查找

查找“服务器名称”中指定的计算机。

报表服务器实例

如果安装了多个报表服务器实例，则选择哪个实例进行连接。只有有效的实例可供选择。如果将旧版本的 Reporting Services 与 SQL Server 实例并行运行，则那些实例将不会显示在此列表中。

连接

连接到指定的服务器和实例。

请参阅

任务

如何启动 Reporting Services 配置

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


报表服务器状态（Reporting Services 配置）

报表服务器状态（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 >

使用此页可以查看当前连接的报表服务器实例的有关信息。此页是报表服务器配置的起始页。此外还提供了用于配置 URL、服务帐户、报表服务器数据库、报表服务器电子邮件传递、扩展部署和加密密钥的其他页。

若要打开此页，请启动 Reporting Services 配置工具并连接到报表服务器实例。有关详细信息，请参阅如何启动 Reporting Services 配置。

如果连接到报表服务器，但所有页面链接均显示为灰色，请验证是否已启动报表服务器服务。可以使用“管理工具”中的“服务”控制台应用程序检查服务状态。

选项

SQL Server 实例

显示当前连接的报表服务器实例的有关信息。报表服务器实例的名称基于 SQL Server 命名实例。默认实例为 MSSQLSERVER。命名实例将是您在安装过程中指定的值。有关实例的详细信息，请参阅 SQL Server 联机丛书中的使用 SQL Server 的多个版本和实例。

注意：
在具有高级服务的 SQL Server 中，默认实例为 SQLExpress。

实例 ID

与文件系统中的某一文件夹对应，该文件夹用于存储您所连接到的 SQL Server 实例的程序文件。“实例 ID”值是由安装程序分配的，格式为 component.instance，其中 component 为一个表示 SQL Server 组件的值，instance 为实例名称。默认实例名为 MSSQLSERVER。例如，如果安装数据库引擎、Analysis Services 和 Reporting Services 组件的默认实例，则对应的文件夹名称分别为 MSSQL10_50.MSSQLSERVER、MSAS10_50.MSSQLSERVER 和 MSRS10_50.MSSQLSERVER。如果安装已安装组件（例如数据库引擎）的第二个实例，并且将该实例命名为 Contoso，则“实例 ID”为 MSSQL10_50.Contoso。

Edition

显示版本信息。具有高级服务的 SQL Server Express Edition、Workgroup Edition、Developer Edition、Evaluation Edition、Standard Edition 和 Enterprise Edition 中均提供了 Reporting Services。

产品版本

显示所安装的 Reporting Services 的版本。

报表服务器数据库

显示用于存储当前报表服务器实例的应用程序数据的报表服务器数据库的名称。

报表服务器模式

显示是以本机模式还是以 SharePoint 集成模式部署报表服务器。如果报表服务器数据库是使用支持 SharePoint 集成操作模式的架构创建的，则此值将设置为该模式。有关部署模式的详细信息，请参阅 SQL Server 联机丛书中的规划部署模式。有关设置集成操作所需的所有步骤的详细信息，请参阅将 Reporting Services 配置为 SharePoint 2010 集成模式。

服务器状态

显示报表服务器服务是否正在运行。

启动

启动报表服务器服务。在更改某些配置之后（例如，在更改计算机名称之后重新配置报表服务器时），需要重新启动该服务。如果重新配置 URL 保留项，该服务将自动重新启动。要使更改生效，必须重新启动服务。

停止

停止报表服务器服务。停止服务会导致报表服务器停止工作。有关详细信息，请参阅 SQL Server 联机丛书中的启动和停止报表服务器服务。

请参阅

任务

如何启动 Reporting Services 配置

概念

Reporting Services 配置 F1 帮助主题
初始化报表服务器

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


服务帐户（Reporting Services 配置）

服务帐户（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 >

使用“服务帐户”页可以指定运行报表服务器服务的帐户。此帐户最初在安装过程中进行配置。如果要更改此帐户或密码，则可以对其进行修改。报表服务器 Web 服务、报表管理器和后台处理应用程序都使用此页上指定的服务标识运行。

为报表服务器服务指定的帐户需要拥有访问注册表、报表服务器程序文件和报表服务器数据库的权限。在您使用 Reporting Services 配置工具设置此帐户时，所有权限都会自动配置给此帐户。如果您使用此服务帐户连接到报表服务器数据库，该工具会将此帐户分配给承载报表服务器数据库的 SQL Server 实例上的 RSExecRole，这样，就会为此帐户创建一个数据库登录名并配置数据库权限。报表服务器数据库是报表服务器可以写入的唯一数据存储区。此服务帐户不需要其他任何数据存储区的权限。

若要打开此页，请启动 Reporting Services 配置工具，然后在导航窗格中选择相应链接。有关详细信息，请参阅如何启动 Reporting Services 配置。

重要提示：
我们极力建议您在每次更新帐户或密码时都使用 Reporting Services 配置工具。使用此工具更新帐户可确保其他基于此服务标识的内部设置都能同时自动更新。

选项

使用内置帐户

从此列表中选择 Network Service、Local System 或 Local Service。建议只选择 Network Service；不过，可以将帐户配置为使用任何可用的帐户。

使用其他帐户

选择此选项可以指定 Windows 用户帐户。可以输入本地 Windows 用户帐户或域用户帐户。按下面的格式指定域帐户：<域>\<用户>。按下面的格式指定本地 Windows 用户帐户：<计算机名称>\<用户>。您只能选择现有的帐户；不能在 Reporting Services 配置中创建新帐户。

帐户的最大字符数限制为 20 个字符。

如果网络使用 Kerberos 身份验证，且您将报表服务器配置为使用域用户帐户运行，则必须使用此用户帐户注册服务。有关详细信息，请参阅如何为报表服务器注册服务主体名称 (SPN)。

如果您要切换帐户类型（例如，将一个 Windows 帐户替换为另一个 Windows 帐户，或者将内置帐户替换为 Windows 域帐户），系统将提示您创建加密密钥的备份副本。在选择新帐户时将自动还原备份副本。

注意：
每次修改服务帐户时，Reporting Services 配置管理器都会提示您备份和还原加密密钥。必须执行这些步骤，才能确保加密数据在报表服务器上可用。有关这些操作的详细信息，请参阅加密密钥（Reporting Services 配置）。

此外，如果您有一台配置为在 SharePoint 集成模式下运行的报表服务器，且通过使用 Reporting Services 配置工具更改服务帐户，则您还必须打开 SharePoint 管理中心并使用 Reporting Services“授予数据库访问权限”页重新应用该报表服务器和实例设置。此步骤将授予新服务帐户访问 SharePoint 数据库的权限，将 Reporting Services 与 SharePoint 产品或技术集成在一起时需要此权限。有关如何在 SharePoint 管理中心授予数据库访问权限的详细信息，请参阅如何在 SharePoint 管理中心中配置报表服务器集成。

选择帐户

为了实现最佳的结果，请指定一个拥有网络连接权限、可以访问网络域控制器和公司 SMTP 服务器或网关的帐户。下表汇总了各个帐户，并为使用这些帐户提供了建议。

帐户 | 说明
域用户帐户 | 如果您有一个拥有报表服务器操作所需的最小权限的 Windows 域用户帐户，则应使用此帐户。 之所以建议使用域帐户，是因为这种帐户可以将报表服务器服务与其他应用程序隔离开。使用共享帐户（如 Network Service）运行多个应用程序会增加恶意用户控制报表服务器的风险，因为在这种情况下，任何一个应用程序的安全漏洞会很容易扩散到使用同一帐户运行的所有其他应用程序。 如果是为受约束委托或 SharePoint 集成模式（包含的 SharePoint 2010 产品要求使用域用户帐户而非内置的计算机帐户）配置报表服务器，则必须使用域用户帐户。 请注意，如果您使用域用户帐户，并且您的组织实施了密码过期策略，则您必须定期更改密码。您可能还需要使用此用户帐户注册服务。有关详细信息，请参阅如何为报表服务器注册服务主体名称 (SPN)。 避免使用本地 Windows 用户帐户。本地帐户通常没有足够的权限访问其他计算机上的资源。有关如何使用本地帐户限制报表服务器功能的详细信息，请参阅本主题中的使用本地帐户的注意事项。
Network Service | Network Service 是一个拥有网络登录权限的内置最低特权帐户。如果没有可用的域用户帐户，或者要避免因密码过期策略而可能导致的任何服务中断，建议使用此帐户。 如果您选择 Network Service，请尝试将使用同一帐户运行的其他服务的数量降到最低。对于使用同一帐户运行的多个应用程序，如果一个应用程序出现安全漏洞，则所有其他应用程序的安全都会受到影响。
Local Service | Local Service 是一个与经过身份验证的本地 Windows 用户帐户类似的内置帐户。以“Local Service”帐户运行的服务将以一个没有凭据的 Null 会话形式访问网络资源。此帐户不适合于 Intranet 部署方案。因为在此部署方案下，报表服务器必须连接至远程报表服务器数据库或网络域控制器，以在打开报表或处理订阅之前对用户进行身份验证。
Local System | Local System 是一个高特权帐户，运行报表服务器时不需要此帐户。请勿将此帐户用于报表服务器的安装。此时应选择域帐户或 Network Service。

使用本地帐户的注意事项

使用本地帐户的主要注意事项是报表服务器是否需要访问远程数据库服务器、邮件服务器和域控制器。如果将报表服务器配置为作为本地 Windows 用户帐户、Local Service 或 Local System 运行，则必须考虑如何设置其他配置设置以及订阅创建和传递方面的注意事项：

  • 如果使用本地帐户运行服务，则以后在配置远程报表服务器数据库的连接时，选项将受到限制。具体来说，如果您使用的是远程报表服务器数据库，则必须将连接配置为使用有权登录到远程 SQL Server 实例的域用户帐户或 SQL Server 数据库用户。

  • 在本地帐户下运行服务将对订阅的创建具有新的要求。报表服务器存储创建订阅的用户的信息。如果用户在使用域帐户登录时创建订阅，则在处理订阅时，报表服务器服务将尝试连接到域控制器以对用户进行身份验证。如果此服务使用本地帐户运行，则在报表服务器尝试将身份验证请求发送到远程域控制器时，此请求将失败。若要消除此限制，可以使用基于窗体的自定义身份验证扩展插件或让所有用户使用本地用户帐户连接到报表服务器。

  • 在本地帐户下运行服务将对订阅的传递具有新的要求。某些传递扩展插件在订阅定义中包含有用户帐户信息。如果要将报表发送到基于域用户帐户的电子邮件地址，并且使用本地帐户运行报表服务器服务，则此服务将无法访问远程域控制器以解析目标电子邮件帐户。

请参阅

任务

如何为 Reporting Services 配置服务帐户

概念

配置报表服务器服务帐户
Reporting Services 配置 F1 帮助主题

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


Web 服务 URL（Reporting Services 配置）

Web 服务 URL（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 >

使用“Web 服务 URL”页可配置或修改用于访问报表服务器的 URL。将基于指定的 URL 创建“URL 保留项”。URL 保留项定义适用于所有 URL 的语法和规则，随后可使用这些 URL 来访问报表服务器 Web 服务。它指定报表服务器 Web 服务的前缀、主机、端口和虚拟目录。根据指定主机的方式不同，一个保留可能会对应多个 URL。主机的默认值指定强通配符。使用强通配符，可在 URL 中指定可解析为承载报表服务器的计算机的任何主机名。有关 URL 配置和保留的详细信息，请参阅如何配置 URL（Reporting Services 配置）和配置报表服务器 URL。

若要打开此页，请启动 Reporting Services 配置工具，并在导航窗格中单击“Web 服务 URL”。有关详细信息，请参阅如何启动 Reporting Services 配置。

此页提供报表服务器 URL 中常用的值。如果要创建其他 URL，请使用主机标头，或指定特殊格式的 IP 地址，然后单击“高级”。

单击“应用”后，此页上将显示一个指向 Web 服务的链接。如果在创建报表服务器数据库之前单击此链接，则可能会看到“Page Not Found”（找不到页）错误。配置数据库后，就不会再显示此错误。有关详细信息，请参阅如何创建报表服务器数据库（Reporting Services 配置）。

如果重新安装了 Reporting Services，但在试图使用“所有已分配的”的默认 IP 地址值和端口 80 时收到错误，则通常情况下，重新启动服务后重新创建该 URL 即可纠正此错误。有关说明，请参阅 SQL Server 联机丛书中的解决配置问题。

选项

虚拟目录

指定报表服务器 Web 服务的虚拟目录名称。在同一台计算机上，每个报表服务器 Web 服务实例只能有一个虚拟名称。

IP 地址

标识 TCP/IP 网络上的报表服务器计算机。有效值包括：

  • “所有已分配的”指定分配给计算机的任何 IP 地址均可用在指向报表服务器应用程序的 URL 中。此值还包含友好主机名（如计算机名），域名服务器可将该主机名解析为分配给该计算机的 IP 地址。此为 Reporting Services URL 的默认值。

  • “所有未分配的”指定报表服务器将接受任何未完全匹配 IP 地址或主机名的请求。如果其他 Web 应用程序已在使用此值，请不要再使用它。如果仍使用此值，将中断其他应用程序的服务。

  • 127.0.0.1 用于访问本地主机。它支持对报表服务器计算机进行本地管理。如果仅选择此值，则只有在本地登录到报表服务器计算机的用户可以访问应用程序。

  • Nnn.nnn.nnn.nnn 是计算机网络适配器的 IPv4 地址。如果您的网络使用 Ipv6 寻址，IP 地址将为 8 个 4 字节字段组成的 128 位值，其格式大致如下：<标头>:nnnn:nnnn:nnnn:nnnn

    如果有多个网络适配器，您将看到每个网络适配器都有一个 IP 地址。如果仅选择此值，它将限制对该 IP 地址（以及域名服务器映射到该地址的任何主机名）的应用程序访问。您不能使用 localhost 访问报表服务器，也不能使用安装在报表服务器计算机上的其他网络适配器的 IP 地址。

TCP 端口

指定报表服务器为包含报表服务器虚拟目录名称的 URL 监视 HTTP 请求的端口。

SSL 证书

将证书绑定到指定的 IP 地址。必须在计算机上安装和配置此证书。Reporting Services 不提供管理证书的功能。证书必须颁发给解析为 IP 地址的主机名或计算机名。例如，若要使用已颁发给 http://salesreports 的证书，则指定的 IP 地址必须解析为名为“salesreports”的服务器。

如果使用证书，则必须修改 RSReportServer.config 文件中的 UrlRoot 配置设置，以便指定要为其注册证书的计算机的完全限定名称。有关详细信息，请参阅 SQL Server 联机丛书中的配置报表服务器用于安全套接字层 (SSL) 连接。

SSL 端口

为 SSL 连接指定端口。

URL

显示为当前报表服务器实例定义的 URL。

高级

单击此选项可为当前应用程序实例创建其他 URL。

请参阅

概念

Reporting Services 配置 F1 帮助主题
配置报表服务器 URL

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


高级多网站配置（Reporting Services 配置）

高级多网站配置（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 > Web 服务 URL（Reporting Services 配置） >

使用此对话框可创建和管理用于访问报表服务器或报表管理器的 URL。“高级多网站配置”对话框用于创建附加 URL 和包含主机标头名称的自定义 URL，或者用于指定 IPv4 或 IPv6 格式的 IP 地址。

如果要配置多种不同的方式来访问报表服务器，则创建多个 URL 非常有用。例如，通过 Intranet 和 Extranet 连接访问报表服务器通常对于每种类型的连接需要具有不同的 URL。

若要打开“高级多网站配置”对话框，请单击 Reporting Services 配置工具中的“Web 服务 URL”页或“报表管理器 URL”页上的“高级”。“高级多网站配置”对话框打开后，可以单击“添加”或“编辑”来定义新的 URL，或者修改或删除现有的 URL。

单击“确定”保存所做的更改。如果添加或删除 URL 后，没有先单击“确定”就关闭了对话框，所做的更改将丢失。

选项

IP 地址

标识 TCP/IP 网络上的报表服务器计算机。有效值包括：

  • “所有已分配的”指定分配给计算机的任何 IP 地址均可用在指向报表服务器应用程序的 URL 中。此值还包含友好主机名（如计算机名），域名服务器可将该主机名解析为分配给该计算机的 IP 地址。此为 Reporting Services URL 的默认值。

  • “所有未分配的”指定报表服务器将接受任何未完全匹配 IP 地址或主机名的请求。如果其他 Web 应用程序已在使用此值，请不要再使用它。如果仍使用此值，将中断其他应用程序的服务。

  • 127.0.0.1 用于访问本地主机。它支持对报表服务器计算机进行本地管理。如果仅选择此值，则只有在本地登录到报表服务器计算机的用户可以访问应用程序。

  • Nnn.nnn.nnn.nnn 是计算机网络适配器的 IPv4 地址。如果您的网络使用 Ipv6 寻址，IP 地址将为 8 个 4 字节字段组成的 128 位值，其格式大致如下：<标头>:nnnn:nnnn:nnnn:nnnn。

    如果有多个网络适配器，您将看到每个网络适配器都有一个 IP 地址。如果仅选择此值，它将限制对该 IP 地址（以及域名服务器映射到该地址的任何主机名）的应用程序访问。您不能使用 localhost 访问报表服务器，也不能使用安装在报表服务器计算机上的其他网络适配器的 IP 地址。

端口

指定报表服务器监视请求的端口。端口 80 为默认端口。如果使用端口 80，则不必将其包含在 URL 中。如果使用其他任何端口号，则必须始终将其包含在 URL 中（例如，http://localhost:8181/reports）。

主机标头

如果已有一个在域名服务器上定义的主机标头解析为您的计算机，则可以在为报表服务器访问配置的 URL 中指定该主机标头。

主机标头是允许多个网站共享一个 IP 地址和端口的唯一名称。主机标头名称比 IP 地址和端口号更容易记住和键入。这里有一个主机标头名称的示例：www.adventure-works.com。

SSL 端口

为 SSL 连接指定端口。SSL 的默认端口为 443。

SSL 证书

指定安装在此计算机上的 SSL 证书的证书名称。如果证书映射到某个通配符，则可以将其用于报表服务器连接。

指定为其注册证书的完全限定的计算机名称。指定的名称必须与为其注册证书的名称相同。

必须先安装证书，才能使用此选项。还必须修改 RSReportServer.config 文件中的 UrlRoot 配置设置，以便指定要为其注册证书的计算机的完全限定名称。有关详细信息，请参阅 SQL Server 联机丛书中的配置报表服务器用于安全套接字层 (SSL) 连接。

颁发给

显示为其创建证书的计算机的名称。

添加

定义附加 URL。

编辑

修改 URL 语法的任何部分。

删除

从列表中清除 URL 项。

请参阅

任务

如何启动 Reporting Services 配置
如何配置 URL（Reporting Services 配置）

概念

配置报表服务器 URL

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


数据库（Reporting Services 配置）

数据库（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 >

使用“数据库”页创建和配置为一个或多个报表服务器实例提供内部存储的报表服务器数据库。如果要配置报表服务器以使用远程报表服务器数据库，则必须使用 Reporting Services 配置工具来创建该数据库。

创建报表服务器数据库和配置连接是一个多步骤过程。为了指导您完成各个步骤，此页为每种类型的任务都提供了向导。还将为您创建或更新权限和登录名。您可以在“进度”页中监视每个步骤的状态。如果出现错误，您可以单击该错误以获取如何解决该错误的相关信息。

报表服务器数据库必须支持特定服务器模式。默认模式为本机模式，但如果是在较大的 SharePoint 产品或技术部署中运行报表服务器，则也可以创建 SharePoint 集成模式下的报表服务器。有关详细信息，请参阅如何创建报表服务器数据库（Reporting Services 配置）和如何创建 SharePoint 集成模式的报表服务器数据库（Reporting Services 配置）。

若要打开此页，请启动 Reporting Services 配置工具，然后单击导航窗格中的“数据库”。有关详细信息，请参阅如何启动 Reporting Services 配置。

选项

SQL Server 名称

在“当前报表服务器数据库”中，“SQL Server 名称”指定运行报表服务器数据库的 SQL Server 2008 数据库引擎的名称。可以使用本地或远程计算机上的默认或命名实例。

数据库名称

指定存储服务器数据的报表服务器数据库的名称。

报表服务器模式

指示报表服务器数据库是支持本机模式还是支持 SharePoint 集成模式。有关详细信息，请参阅规划部署模式。

更改数据库

启动一个向导以指导您完成创建或选择报表服务器数据库所需的所有步骤。

凭据类型

指定报表服务器用来连接报表服务器数据库的凭据。可以指定的凭据类型包括服务帐户、Windows 域用户、Windows 本地用户或 SQL Server 数据库登录名。有关选择凭据的详细信息，请参阅配置报表服务器数据库连接。

用户名

如果使用的是 Windows 凭据，请指定域用户帐户；如果使用的是 SQL Server 凭据，则指定 SQL Server 登录名。如果使用的是 Windows 凭据，请以如下格式指定它们：<域>\<帐户>。

密码

指定帐户的密码。

更改凭据

启动可指导您完成以下操作所需的所有步骤的向导，这些操作包括选择不同的帐户或更新用于连接到报表服务器数据库的帐户的密码。

请参阅

任务

如何创建报表服务器数据库（Reporting Services 配置）

概念

Reporting Services 配置 F1 帮助主题
配置报表服务器数据库连接
为扩展部署配置 Reporting Services

其他资源

报表服务器数据库

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


更改数据库向导（Reporting Services 配置）

更改数据库向导（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 > 数据库（Reporting Services 配置） >

Reporting Services 配置工具提供了更改数据库向导，可引导您完成创建新的报表服务器数据库或选择现有报表服务器数据库用于当前报表服务器实例的步骤。

如果您选择来自早期版本的报表服务器数据库，所选数据库将进行升级，以便与其连接的报表服务器实例的版本匹配。服务启动时，它会检查数据库版本并自动将其升级到当前架构。

若要启动此向导，请在 Reporting Services 配置工具中的“数据库”页上单击“更改数据库”。有关如何启动 Reporting Services 配置工具的说明，请参阅如何启动 Reporting Services 配置。

选项

操作

选择您要执行的任务。您可以在本机模式或 SharePoint 集成模式下创建新的数据库。或者，您也可以选择现有的报表服务器数据库以将其与当前报表服务器实例一起使用。

数据库服务器

指定承载报表服务器数据库的 SQL Server 数据库引擎实例的名称。可以使用 SQL Server 2005 或 SQL Server 2008 实例。可以使用本地或远程计算机上的默认或命名实例。如果要连接到命名实例，请按如下格式输入服务器名称：<服务器>\<实例>。

若要连接到数据库引擎实例，必须使用有权登录到服务器并更新数据库信息的凭据。Reporting Services 配置工具使用您的当前 Windows 凭据，但如果您没有登录名或数据库权限，您必须指定一个 SQL Server 数据库登录名。您不能指定其他 Windows 凭据。如果您希望以其他 Windows 用户身份连接，请以该用户身份登录，然后启动 Reporting Services 配置工具。

如果要连接到远程实例，您需要先为该实例启用远程连接。SQL Server 的某些版本和版本类别在默认情况下不启用远程连接。若要确认是否允许建立远程连接，请使用 SQL Server 配置管理器工具并确认 TCP/IP 和命名管道协议处于启用状态。如果远程实例也是一个命名实例，应检查在目标服务器上 SQL Server Browser 服务是否已启用并正在运行。SQL Server Browser 为 Reporting Services 配置工具提供命名实例使用的端口号。

数据库

指定存储服务器数据的报表服务器数据库的名称。可以指定现有的数据库或创建新的数据库。

当您在“操作”页面中选择“创建新数据库”时，用于创建新数据库的属性将显示在向导中。Reporting Services 配置工具将创建按名称绑定的两个数据库：一个数据库用于包含静态数据，还有一个临时数据库用于存储会话和工作数据。有关详细信息，请参阅 SQL Server 联机丛书中的报表服务器数据库。

您也可以选择现有的报表服务器数据库。Reporting Services 配置工具不会将无效的数据库筛选出来。有效的数据库是基于报表服务器数据库架构的（您不能选择缺少必要的表、视图或存储过程的数据库）。如果您选择为 Reporting Services 的早期版本创建的数据库，则所选数据库将升级成当前格式。

语言

只有在创建新的报表服务器数据库时，才需设置此值。

利用此值，您可以指定以何种语言创建角色定义和说明。Reporting Services 提供了一个基于角色的授权模型，此模型包含一组预定义的角色。这些角色仅会以您指定的语言创建一次。角色名称和说明绝不会以其他语言显示，即使您连接到报表服务器所用的浏览器的区域性或语言设置受此服务器支持，也不例外。您指定的语言也决定了使用何种语言创建作为“我的报表”功能一部分的“我的报表”文件夹和“用户”文件夹的名称。有关 Reporting Services 中所支持语言的详细信息，请参阅 SQL Server 联机丛书中的多语言或全局部署的解决方案设计注意事项 (Reporting Services)。

服务器模式

报表服务器数据库支持本机模式或 SharePoint 集成模式。这两种模式是互斥的。

如果您要创建新的报表服务器数据库，必须指定一种模式。您选择的模式决定了报表服务器数据库的结构并将报表服务器系统属性 SharePointIntegrated 设置为 true 或 false。

如果您要选择其他报表服务器数据库，则会显示当前数据库的模式，以便让您知道当前数据库的使用方式。您可以选择为其他模式创建的数据库。这样做将会切换当前报表服务器实例的服务器模式。有关模式的详细信息，请参阅 SQL Server 联机丛书中的 规划部署模式。

凭据

指定用于将报表服务器连接到报表服务器数据库的帐户。有效值包括报表服务器 Web 服务的服务帐户、在您要用来承载报表服务器的数据库引擎实例上定义的 SQL Server 数据库登录名，或 Windows 帐户。如果您要使用 Windows 帐户，则在报表服务器和数据库位于同一台计算机上时可以指定本地帐户（<计算机名>\<用户名>），或者，在报表服务器和数据库位于同一域内的不同计算机上时可以指定域用户帐户（<域>\<用户名>）。

报表服务器将创建一个数据库登录名，并为您指定的帐户分配数据库权限。

报表服务器自身不创建帐户。您指定的帐户必须已经存在，并且对于部署配置而言必须是有效的。具体来说，如果数据库位于远程计算机上并且您希望使用 Windows 帐户，则您必须指定对该计算机拥有登录权限的帐户。

如果计算机位于其他域或不可信域中，请考虑使用 SQL Server 数据库登录名。有关选择帐户的详细信息，请参阅配置报表服务器数据库连接。

摘要

在安装程序配置连接前验证设置。

进度和完成

监视每个任务的进度。

请参阅

任务

如何创建报表服务器数据库（Reporting Services 配置）

参考

数据库（Reporting Services 配置）
更改凭据向导（Reporting Services 配置）

概念

Reporting Services 配置 F1 帮助主题
配置报表服务器数据库连接
为扩展部署配置 Reporting Services

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


更改凭据向导（Reporting Services 配置）

更改凭据向导（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 > 数据库（Reporting Services 配置） >

Reporting Services 配置管理器提供了更改凭据向导，可引导您完成重新配置报表服务器用于连接到报表服务器数据库的帐户的步骤。更改凭据时，此工具将为报表服务器当前使用的报表服务器数据库更新数据库服务器的所有权限和数据库登录信息。

若要启动此向导，请在 Reporting Services 配置管理器中的“数据库”页上单击“更改凭据”。有关如何启动 Reporting Services 配置管理器的说明，请参阅如何启动 Reporting Services 配置。

选项

数据库服务器

指定运行报表服务器数据库的 SQL Server 数据库引擎实例的名称。

若要连接到数据库引擎实例，必须使用有权登录到服务器并更新数据库信息的凭据。Reporting Services 配置工具使用您当前的 Windows 凭据，但如果您没有登录名或数据库权限，则可以指定一个 SQL Server 数据库登录名。

您不能指定其他 Windows 凭据。如果您希望以其他 Windows 用户身份连接，请以该用户身份登录，然后启动 Reporting Services 配置工具。

凭据

指定用于将报表服务器连接到报表服务器数据库的帐户。有效值包括报表服务器 Web 服务的服务帐户、在您要用来承载报表服务器的数据库引擎实例上定义的 SQL Server 数据库登录名，或 Windows 帐户。如果您要使用 Windows 帐户，则在报表服务器和数据库位于同一台计算机上时可以指定本地帐户（<计算机名>\<用户名>），或者，在报表服务器和数据库位于同一域内的不同计算机上时可以指定域用户帐户（<域>\<用户名>）。

报表服务器将创建一个数据库登录名，并为您指定的帐户分配数据库权限。

报表服务器自身不创建帐户。您指定的帐户必须已经存在，并且对于部署配置而言必须是有效的。具体来说，如果数据库位于远程计算机上并且您希望使用 Windows 帐户，则您必须指定对该计算机拥有登录权限的帐户。

如果计算机位于其他域或不可信域中，请考虑使用 SQL Server 数据库登录名。有关选择帐户的详细信息，请参阅配置报表服务器数据库连接。

摘要

在向导运行之前验证设置。

进度和完成

监视每个任务的进度。

请参阅

任务

如何创建报表服务器数据库（Reporting Services 配置）

参考

数据库（Reporting Services 配置）
更改数据库向导（Reporting Services 配置）

概念

Reporting Services 配置 F1 帮助主题
配置报表服务器数据库连接
为扩展部署配置 Reporting Services

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


报表管理器 URL（Reporting Services 配置）

报表管理器 URL（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 >

使用报表管理器 URL 页可配置或修改用于访问报表管理器的 URL。默认情况下，报表管理器 URL 继承报表服务器 Web 服务 URL 的前缀、IP 地址和端口。这是因为报表管理器提供了对于运行在相同报表服务器服务中的 Web 服务的前端访问。如果您正在隔离服务应用程序并使用报表管理器访问其他计算机上的报表服务器 Web 服务，则必须编辑 RSReportServer.config 文件以将报表管理器指向不同的实例。有关配置报表管理器与远程报表服务器的连接的详细信息，请参阅 SQL Server 联机丛书中的如何配置报表管理器。

如果您打算将报表服务器配置为在 SharePoint 集成模式下运行，请不要创建报表管理器 URL。在 SharePoint 集成模式下运行的报表服务器不支持报表管理器。如果报表管理器已存在一个 URL，则将报表服务器配置为在 SharePoint 集成模式下运行后，该 URL 将不可用。

若要打开该页，请启动 Reporting Services 配置工具，并在导航窗格中单击“报表管理器 URL”。有关如何启动此工具的详细信息，请参阅如何启动 Reporting Services 配置。

注意：
如果报表管理器未启用，则将无法设置此页上的选项。有关启用报表管理器的详细信息，请参阅如何打开或关闭 Reporting Services 功能。

选项

虚拟目录

指定报表管理器的虚拟目录名称。在同一台计算机上，每个报表管理器实例只能有一个虚拟目录名称。

URL

显示为当前报表管理器实例定义的 URL。

高级

为当前报表管理器实例添加附加 URL。

请参阅

任务

如何配置 URL（Reporting Services 配置）

概念

配置文件中的 URL (Reporting Services)
配置报表服务器 URL

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


电子邮件设置（Reporting Services 配置）

电子邮件设置（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 >

使用此页可指定简单邮件传输协议 (SMTP) 设置，这些设置用于启用报表服务器的报表服务器电子邮件传递功能。可使用报表服务器电子邮件传递扩展插件通过电子邮件订阅来分发报表或报表处理通知。报表服务器电子邮件传递扩展插件需要使用 SMTP 服务器并在“发件人:”字段中使用电子邮件地址。

其他的配置设置（包括限制邮件服务器主机和呈现扩展插件可用性的设置）可用于进一步自定义电子邮件订阅。不能在 Reporting Services 配置工具中指定这些设置。若要配置其他设置，必须手动编辑 RSReportServer.config 文件。有关详细信息，请参阅 SQL Server 联机丛书中的配置报表服务器以进行电子邮件传递和配置文件 (Reporting Services)。

若要打开此页，请启动 Reporting Services 配置工具，然后在导航窗格中单击“电子邮件设置”。有关详细信息，请参阅如何启动 Reporting Services 配置。

选项

发件人地址

指定要在所生成电子邮件的“发件人:”字段中使用的电子邮件地址。您必须指定一个有权从 SMTP 服务器中发送邮件的用户帐户。

当前 SMTP 传递方法

指定报表服务器电子邮件通过 SMTP 服务器进行路由。这是可以在 Reporting Services 配置工具中指定的唯一传递方法。

另一种传递方法是使用本地 SMTP 服务拾取目录。如果网络 SMTP 服务不可用，则可以使用此传递方法。若要指定本地 SMTP 服务拾取目录，必须编辑 RSReportServer.config 文件。如果您编辑配置文件以使用本地 SMTP 服务拾取目录，Reporting Services 配置工具会将“传递方法”选项设置为“自定义”，以指示传递方法在配置文件中指定。

在配置文件中，可以通过 SendUsing 配置设置来设置传递方法。有关指定 SendUsing 设置的详细信息，请参阅配置报表服务器以进行电子邮件传递。

SMTP 服务器

指定要使用的 SMTP 服务器或网关。可以使用网络中的本地服务器或 SMTP 服务器。

请参阅

概念

配置报表服务器以进行电子邮件传递
Reporting Services 配置 F1 帮助主题

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


执行帐户（Reporting Services 配置）

执行帐户（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 >

使用此页可以配置用于无人参与处理的帐户。只有在其他凭据源不可用的以下特殊情况时，才使用此帐户：

  • 当报表服务器连接到不需要凭据的数据源时。可能不需要凭据的数据源示例包括 XML 文档和一些客户端数据库应用程序。

  • 当报表服务器连接到其他服务器以检索报表中所引用的外部图像文件或其他资源时。

设置此帐户是可选的，但如果不设置此帐户，则将限制您使用外部图像以及与一些数据源的连接。在检索外部图像文件时，报表服务器将检查是否可以建立匿名连接。如果连接受密码保护，报表服务器将使用无人参与的报表处理帐户来连接到远程服务器。在为报表检索数据时，报表服务器或者模拟当前用户、提示用户提供凭据或使用存储的凭据，或者（如果数据源连接指定“无”作为凭证类型）使用无人参与的处理帐户。在连接到其他计算机时，报表服务器不允许对其服务帐户凭据进行委托或模拟，因此，如果不能使用其他凭据，报表服务器就必须使用无人参与的处理帐户。

您指定的帐户不能是用于运行服务帐户的帐户。如果配置了该帐户，它将作为加密值存储在 RSReportServer.config 文件中。如果将在扩展部署中运行该报表服务器，则必须在每个报表服务器上以相同的方式配置此帐户。

您可以使用任何一个 Windows 用户帐户。为获得最佳结果，请选择拥有读取权限和网络登录权限的帐户，以支持与其他计算机的连接。对于您希望在报表中使用的任何外部图像或数据文件，它必须拥有对这些文件的读取权限。切勿指定本地帐户，除非所有报表数据源和外部图像均存储在报表服务器计算机中。只可将该帐户用于无人参与报表处理。

注意：
如果使用的是带高级服务的 SQL Server 2008 Express，则仅当在报表中引用外部图像并且访问该图像文件需要相应权限时才需要配置此帐户。SQL Server Express 不支持到远程服务器的数据源连接。

若要打开该页，请启动 Reporting Services 配置工具，并在导航窗格中选择“执行帐户”。有关详细信息，请参阅如何启动 Reporting Services 配置。

选项

指定执行帐户

选择此选项可指定一个帐户。

帐户

输入一个 Windows 域用户帐户。使用如下格式：<域>\<用户帐户>。

密码

键入密码。

确认密码

重新键入密码。

请参阅

概念

Reporting Services 配置 F1 帮助主题
存储加密的报表服务器数据
配置无人参与的执行帐户

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


加密密钥（Reporting Services 配置）

加密密钥（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 >

使用“加密密钥”页可以管理用于对报表服务器中数据进行加密和解密的对称密钥。管理加密密钥是报表服务器配置的一个重要方面。虽然在您创建报表服务器数据库时将自动创建并应用对称密钥，但是您必须创建对称密钥的备份副本，以便执行日常的维护操作。您需要具有对称密钥的有效副本，才可执行以下维护任务：

  • 更改报表服务器服务的服务帐户。

  • 将 Reporting Services 安装迁移到其他计算机。

  • 配置新的报表服务器实例以共享或使用现有报表服务器数据库。

如果更新了报表服务器服务的用户帐户（并且是使用 Reporting Services 配置工具以外的工具更改了此帐户），或者要将报表服务器安装迁移到新服务器，则必须还原对称密钥。

为了保护对称密钥免受未经授权的访问，对称密钥使用报表服务器服务的私钥进行了加密。只有报表服务器服务可以解锁并使用对称密钥以在报表服务器数据库中存储敏感数据。如果更改了报表服务器服务的标识，或者将报表服务器迁移到新计算机，则报表服务器服务的私钥将不再能够解开对称密钥的锁定。若要恢复对对称密钥的访问，则必须使用新报表服务器服务标识的私钥重新加密对称密钥。还原对称密钥就是对对称密钥重新加密的过程。

只应还原当前用于加密和解密报表服务器数据库中数据的对称密钥。如果还原无效的对称密钥，您将不再能够访问敏感数据。在这种情况下，必须删除并重新创建密钥。

重要提示：
删除并重新创建对称密钥是不可逆转的操作，它会对当前安装产生重要的影响。如果删除对称密钥，则使用此对称密钥加密的所有现有数据将随此对称密钥一起被删除。删除的数据包括指向外部报表数据源的连接字符串、存储的连接字符串和某些订阅信息。

若要打开此页，请启动 Reporting Services 配置工具，然后在导航窗格中选择相应链接。有关详细信息，请参阅如何启动 Reporting Services 配置。

选项

备份

将对称密钥复制到您指定的文件。对称密钥决不能以纯文本形式存储。您必须键入密码来保护该文件。

还原

将以前保存的对称密钥的副本应用于报表服务器数据库。您必须提供密码对文件进行解锁。

还原后的对称密钥副本将覆盖当前连接的报表服务器实例还原前的对称密钥副本。还原对称密钥后，必须初始化使用该报表服务器数据库的所有报表服务器。有关初始化报表服务器的详细信息，请参阅初始化报表服务器。

更改

重新创建对称密钥并对报表服务器数据库中的所有加密值重新进行加密。请确保在重新创建对称密钥前停止报表服务器服务。

在扩展部署中，对称密钥的所有副本都将替换为新的版本。在更改对称密钥前，请务必检查加入扩展部署的服务器的列表，以确认仅对有效的报表服务器实例授予了对新密钥的访问权限。“扩展部署”页列出了扩展部署中包含的服务器。在重新创建密钥前，请停止部署中包含的各个报表服务器上的报表服务器服务。

请注意，如果您具有许多数据源和订阅，则重新生成对称密钥的过程可能需要耗费较长的时间。

删除

删除对称密钥和所有加密内容（包括连接字符串和存储的凭据）。如果您无法还原对称密钥，则只能删除该密钥。

一旦删除了对称密钥，您必须在报表和共享数据源中重新输入缺少的连接字符串和存储的凭据，因为其中已不再具有这些值。另外，对于使用存储加密数据的传递扩展插件的所有订阅，还必须进行更新。这包括使用加密值的文件共享传递扩展插件和任何第三方传递扩展插件。

此信息无法自动更新。一次只能更新一个使用存储的凭据和连接字符串的报表、订阅和共享数据源。

请参阅

概念

Reporting Services 配置 F1 帮助主题
备份和还原加密密钥
删除和重新创建加密密钥
初始化报表服务器
存储加密的报表服务器数据

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


备份加密密钥（Reporting Services 配置）

备份加密密钥（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 > 加密密钥（Reporting Services 配置） >

Reporting Services 使用加密密钥来保护存储在报表服务器数据库中的敏感数据。备份该密钥对于确保可继续访问连接字符串和凭据至关重要。

如果将报表服务器数据库移动到其他计算机，或者更改报表服务器服务帐户的用户名或密码，则必须备份该密钥。这两个操作均要求您从先前创建的备份副本还原密钥。

若要打开“备份加密密钥”对话框，请单击 Reporting Services 配置工具导航窗格中的“加密密钥”，然后单击“备份”。当使用 Reporting Services 配置工具中的“服务帐户”页更新服务帐户时，也会显示此对话框。

选项

文件位置

为 Reporting Services 指定对称密钥的文件名和位置。对称密钥决不能以纯文本形式存储。您必须键入密码来保护该文件。

密码

键入密码以防止对该文件进行未经授权的访问。只有知道密码的用户才能还原封存在该文件中的密钥。Reporting Services 会强制采用强密码策略。密码必须至少包含 8 个字符，并且应由大小写字母数字字符和至少一个符号字符组合而成。

确认密码

重新键入刚才输入的密码。

请参阅

任务

如何启动 Reporting Services 配置

参考

加密密钥（Reporting Services 配置）

概念

Reporting Services 配置 F1 帮助主题
备份和还原加密密钥
删除和重新创建加密密钥
初始化报表服务器
存储加密的报表服务器数据

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


还原加密密钥（Reporting Services 配置）

还原加密密钥（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 > 加密密钥（Reporting Services 配置） >

Reporting Services 使用加密密钥来保护存储在报表服务器数据库中的敏感数据。为确保您可以继续访问加密数据，请务必创建加密密钥的备份，以备以后因服务帐户发生变化而需要还原它或需要将它作为计划迁移的一部分还原时使用。

若要还原此密钥，事先必须将此密钥的备份副本保存到受密码保护的文件中。在密钥还原过程中，报表服务器将用在受密码保护的文件中找到的密钥替换现有密钥。该文件中的密钥必须与用于加密和解密数据的密钥相同。

若要验证是否还原了有效的密钥，请使用报表管理器来查看订阅或具有使用存储凭据的数据源的任何报表。如果在试图打开订阅定义页时出现“报表服务器无法访问加密数据”错误，或者在打开此前将存储凭据用于报表数据源的报表时，系统提示您输入凭据，则表明您还原的是无效密钥。

如果还原的是无效密钥，而不是用于加密数据的密钥，则无法解密当前存储在报表服务器数据库中的数据。如果还原的是无效密钥，则应立即还原正确密钥的备份副本（如果有的话）。如果没有用于加密数据的密钥的备份副本，则必须删除所有加密数据。请单击加密密钥页上的“删除”按钮以执行此步骤。在删除加密内容之后，必须手动更新所有订阅并重新指定为报表定义的所有存储凭据以及报表服务器上的所有数据驱动订阅。

若要打开“还原加密密钥”对话框，请单击 Reporting Services 配置工具导航窗格中的“加密密钥”，然后单击“还原”。当使用 Reporting Services 配置工具中的“服务帐户”页更新服务帐户时，也会显示此对话框。

选项

文件位置

选择包含对称密钥副本的受密码保护的文件。默认的文件扩展名为 .snk。

密码

输入用于解锁该文件的密码。只有知道密码的用户才可还原密钥。Reporting Services 强制实施强密码策略。密码必须至少包含 8 个字符，并且应由大小写字母数字字符和至少一个符号字符组合而成。

请参阅

任务

如何启动 Reporting Services 配置

参考

加密密钥（Reporting Services 配置）

概念

Reporting Services 配置 F1 帮助主题
备份和还原加密密钥
删除和重新创建加密密钥
初始化报表服务器
存储加密的报表服务器数据

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


扩展部署（Reporting Services 配置）

扩展部署（Reporting Services 配置） |
 | 请参阅
配置 Reporting Services > Reporting Services 配置 F1 帮助主题 >

使用此页可以查看扩展部署的初始化状态或将报表服务器联接到扩展部署。

“已初始化的报表服务器”是指可以对报表服务器数据库中存储的敏感数据进行加密和解密的服务器（已存储凭据和连接字符串是存储在此数据库中的加密数据示例）。报表服务器初始化是一项必需的报表服务器操作。

“扩展部署”是指两个或多个报表服务器实例共享单个报表服务器数据库。在以下情况中使用此配置：

  • 作为对服务器群集中的多个报表服务器进行负载平衡的必备条件。在可以对多个报表服务器进行负载平衡之前，必须首先将它们配置为共享同一报表服务器数据库。

  • 通过使用一个服务器处理交互式报表同时使用另一个服务器处理计划的报表，将报表服务器应用程序分段置于不同的计算机上。在此情况下，每个服务器实例均按照共享报表服务器数据库中存储的同一报表服务器内容来处理不同类型的请求。

若要配置扩展部署，则首先应有两个或多个与同一报表服务器数据库连接的报表服务器实例。安装所有实例后，连接到第一个报表服务器，然后使用“扩展部署”页联接每个附加实例。只有已初始化为使用数据库的报表服务器才能初始化其他节点。

若要打开该页，请启动 Reporting Services 配置工具，然后在导航窗格中选择“扩展部署”。有关详细信息，请参阅如何启动 Reporting Services 配置。

选项

SQL Server 名称

指定承载报表服务器数据库的 SQL Server 数据库引擎实例的名称。

数据库名称

指定报表服务器实例当前连接到的数据库的名称。

服务器模式

显示服务器和数据库的模式。服务器模式为“本机”或“SharePoint 集成”。这两种模式均支持扩展部署。

服务器

显示报表服务器名称。在大多数情况下，此为安装报表服务器的计算机的名称。

实例

显示报表服务器实例名称。报表服务器实例基于 SQL Server 实例。

状态

指示报表服务器是已初始化还是正在等待联接扩展部署：

  • 对于不属于扩展部署的独立报表服务器，此页说明此报表服务器实例已根据其专用报表服务器数据库进行初始化。“状态”设置为“已联接”。

  • 对于正在等待联接扩展部署的报表服务器，此页的“服务器”、“实例”和“状态”均为空值。如果选择的现有报表服务器数据库已由其他报表服务器实例使用，则报表服务器将处于等待联接扩展部署状态。此页上的消息将指示您连接到已与场联接的报表服务器。若要完成该请求，请单击“连接”，选择已初始化为使用报表服务器数据库的报表服务器，接着单击“扩展部署”，选择状态为“正在等待联接”的报表服务器实例，然后单击“初始化”。

  • 对于当前作为扩展部署一部分的报表服务器，此页显示共享同一个报表服务器数据库的所有报表服务器实例的初始化状态。查看扩展部署的状态时，连接到哪个服务器无关紧要。对扩展部署中的所有节点均以相同的方式报告它们的状态信息。

    对于属于扩展部署的报表服务器，可使用此页来添加或删除节点。

初始化

单击“初始化”可将报表服务器添加到扩展部署中。该步骤用于将报表服务器配置为使用共享报表服务器数据库中的对称密钥。可以使用“初始化”将报表服务器实例添加到扩展部署中，或者排除迁移或安装故障。

除非您事先配置了与共享报表服务器数据库的连接，否则报表服务器实例将不可用。此外，还必须从已初始化为使用报表服务器数据库的报表服务器执行初始化操作。

删除

单击“删除”可以从报表服务器数据库中删除选定报表服务器实例的加密密钥。您可以通过删除密钥将报表服务器从扩展部署中删除，或者排除迁移或安装故障。使用此选项，将仅删除指定报表服务器实例的加密密钥。报表服务器数据库中的加密数据不受影响。

请确保在删除密钥之前创建了该密钥的备份副本，作为一种防范措施。一旦删除列表中最后一个报表服务器的加密密钥，将对该数据库的任何后续报表服务器初始化提出新的要求。新的要求是初始化报表服务器之后，必须还原对称密钥的备份副本。如果希望访问报表服务器数据库中当前存在的加密数据，还原对称密钥是必需的。

如果不再需要加密数据或者没有密钥的备份副本，则必须删除该加密数据。有关详细信息，请参阅加密密钥（Reporting Services 配置）。

请参阅

任务

如何配置报表服务器扩展部署（Reporting Services 配置）

概念

为扩展部署配置 Reporting Services
初始化报表服务器
配置和管理加密密钥

帮助和信息

获取 SQL Server 2008 帮助
© 2010 Microsoft Corporation。保留所有权利。


文档法律声明

文档法律声明

本文档支持软件程序“SQL Server 2008 R2”的最终商业版本。本文档中的信息是 Microsoft Corporation 的专有信息，属于机密信息。

本文档按“原样”提供。本文档中的信息和表达的观点（包括 URL 和其他 Internet 网站引用）如有更改，恕不另行通知。您应承担使用本文档所带来的风险。本文档中提及的某些示例只是为了便于说明，纯属虚构。不应据此联想或妄加推断。

本文档不向您提供对任何 Microsoft 产品中的任何知识产权的任何法律权利。您可以出于内部参考目的复制和使用本文档。

版权所有 © 2010 Microsoft Corporation。保留所有权利。

Microsoft、Active Directory、ActiveX、Bing Maps、Excel、IntelliSense、MSDN、MS-DOS、PivotChart、PivotTable、PowerPoint、SharePoint、SQL Server、Visual Basic、Visual C#、Visual C++、Visual Studio、Windows、Windows NT、Windows Server 和 Windows Vista 是 Microsoft 集团公司的商标。

SAP NetWeaver 是 SAP AG 在德国和其他几个国家/地区的注册商标。

所有其他商标归其各自拥有者所有。

SQL Server 支持和升级文档策略

文档 - 支持和升级策略

Microsoft SQL Server 2008 R2 软件文档包括 Microsoft 发布的 SQL Server 联机丛书（“BOL”）、自述文件、已知问题文档、示例代码/应用程序、示例数据库和知识库文章，这些文档都包含与 SQL Server 的特征和功能相关的内容（以下统称“文档”）。下面的摘要描述了文档中提到的某些特征和功能的支持及升级策略。

示例。文档中包含的示例主要用于阐释概念以及特定语句或子句的合理用法。大多数示例不包括完整的生产系统通常所包含的全部代码，因为其中删除了某些常用的数据验证和错误处理，以便使示例突出特定的概念或语句。Microsoft 客户支持服务部门不为文档中包含的任何示例提供支持。

占位符。在某些情况下，SQL Server 2008 R2 中的特定功能尚未经过充分测试或开发，不适合使用。此类功能通常作为占位符在 BOL、自述文件或其他文档中列出，仅用作标记以供 Microsoft 内部参考。此类功能不适合使用，且 Microsoft 客户支持服务部门不为这些功能提供支持。尝试使用此类功能可能导致数据丢失。

第三方内容。除非文档另有说明，否则 Microsoft 客户支持服务部门不会对第三方内容（包括将此类第三方内容与 SQL Server 2008 R2 结合使用而导致的问题）提供支持。

未记录的入口点。Microsoft 客户支持服务部门不为利用或使用未记录的入口点（如未记录的 API）的数据库或应用程序提供支持，其中包括但不限于：存储过程、扩展存储过程、函数、视图、表、列、属性或元数据。此类使用可能导致数据丢失。

升级。对于利用或使用未记录的入口点的应用程序和数据库，其服务器和数据库可能无法升级至 SQL Server 2008 R2 的未来版本，且此类服务器和数据库的升级不享有 Microsoft 客户支持服务部门的支持。

有关 Microsoft 支持生命周期策略的详细信息，请访问下面的网站：http://support.microsoft.com/lifecycle。