新增对象

访问 Microsoft Developer Network (MSDN) 网站上的“Office 开发人员中心”，获取有关使用 Microsoft Office 2003 Web 组件进行编程的最新信息，包括产品新闻、技术文章、下载内容以及示例。

下表列出了添加到 Microsoft Office 2003 Web 组件对象模型中的对象。

对象 | 说明
ChScrollView | 使用 ChScrollView 对象的属性和方法可返回有关图表视图的信息，也可以滚动并缩放图表视图。
ChSelectionCollection | 使用 ChSelectionCollection 集合可对图表中当前选定的所有对象进行操作。
ListObject | ListObject 对象代表工作表中的一个 XML 列表。
ListObjects | 使用 ListObjects 集合的属性和方法可对工作表中的所有 XML 列表进行操作。
ListRow | ListRow 对象代表 XML 列表中的一行。
ListRows | 使用 ListRows 集合可对 XML 列表中的所有行进行操作。
XmlDataBinding | XmlDataBinding 对象代表 XML 列表的 XML 数据绑定以及电子表格组件中已映射的数据。
XmlDataBindings | 使用 XmlDataBindings 集合可对电子表格组件中的所有 XML 数据绑定进行操作。
XmlMap | XmlMap 对象代表一个 XML 架构映射，它将 XML 数据映射到电子表格组件中的工作表。
XmlMaps | 使用 XmlMaps 集合可对电子表格组件中的所有 XML 架构映射进行操作。


新增属性（按字母顺序列表）

访问 Microsoft Developer Network (MSDN) 网站上的“Office 开发人员中心”，获取有关使用 Microsoft Office 2003 Web 组件进行编程的最新信息，包括产品新闻、技术文章、下载内容以及示例。

下表列出了添加到 Microsoft Office 2003 Web 组件对象模型中的属性（按字母顺序排序）。

新增属性 | 对象
Active | ListRow
AllowUISelection | ChartSpace
Async | XmlDataBinding
BarWidth | ChChart
BindingData | XmlDataBinding
BindingInProgress | XmlDataBinding, XmlDataBindings
CanQuery | XmlDataBinding
CanUpdate | XmlDataBinding
DataBodyRange | ListObject
DefaultQueryOnLoad | Spreadsheet
HeaderRowRange | ListObject
HorizontalExtent | ChScrollView
HorizontalExtentMax | ChScrollView
HorizontalPosition | ChScrollView
InsertRowRange | ListObject
ListObject | Range, Workbook
ListObjects | Worksheet
ListRows | ListObject
LoadMode | XmlDataBinding
MapData | XmlMap
PropNames | ListObject
ScrollView | ChChart
SelectionCollection | ChartSpace
VerticalExtent | ChScrollView
VerticalExtentMax | ChScrollView
VerticalPosition | ChScrollView
XmlDataBindings | Workbook
XmlMap | XmlDataBinding
XmlMaps | Workbook


新增属性（按对象排序）

访问 Microsoft Developer Network (MSDN) 网站上的“Office 开发人员中心”，获取有关使用 Microsoft Office 2003 Web 组件进行编程的最新信息，包括产品新闻、技术文章、下载内容以及示例。

下表列出了添加到 Microsoft Office 2003 Web 组件对象模型中的属性（按对象名称排序）。

对象 | 新增属性
ChartSpace | AllowUISelection, SelectionCollection
ChChart | BarWidth, ScrollView
ChScrollView | HorizontalExtent, HorizontalExtentMax, HorizontalPosition, VerticalExtent, VerticalExtentMax, VerticalPosition
ListObject | DataBodyRange, HeaderRowRange, InsertRowRange, ListRows, PropNames
ListRow | Active
PivotField | SubtotalLabelBackColor, SubtotalLabelFont, SubtotalLabelForeColor, SubtotalLabelHAlignment
Range | ListObject
Spreadsheet | DefaultQueryOnLoad
Workbook | ListObject, XmlDataBindings, XmlMaps
Worksheet | ListObjects
XmlDataBinding | Async, BindingData, BindingInProgress, CanQuery, CanUpdate, LoadMode, XmlMap
XmlDataBindings | BindingInProgress
XmlMap | MapData


新增方法（按字母顺序列表）

访问 Microsoft Developer Network (MSDN) 网站上的“Office 开发人员中心”，获取有关使用 Microsoft Office 2003 Web 组件进行编程的最新信息，包括产品新闻、技术文章、下载内容以及示例。

下表列出了添加到 Microsoft Office 2003 Web 组件对象模型中的方法（按字母顺序排序）。

新增方法 | 对象
Add | XmlDataBindings, XmlMaps
Delete | XmlDataBinding, XmlMap
ExportMetaData | XmlMap
FireParametersOut | Spreadsheet
GetDataPointVisible | ChSeries
ExportXML | XmlMap
ImportXml | XmlMap
OverrideDefaultElementFormatting | ChChartDraw
Refresh | XmlDataBinding
Select2 | ChPoint
SetExtent | ChScrollView
SetPosition | ChScrollView
Update | XmlDataBinding
Validate | Range


新增方法（按对象排序）

访问 Microsoft Developer Network (MSDN) 网站上的“Office 开发人员中心”，获取有关使用 Microsoft Office 2003 Web 组件进行编程的最新信息，包括产品新闻、技术文章、下载内容以及示例。

下表列出了添加到 Microsoft Office 2003 Web 组件对象模型中的方法（按对象名称排序）。

对象 | 新增方法
ChChartDraw | OverrideDefaultElementFormatting
ChPoint | Select2
ChScrollView | SetExtent, SetPosition
ChSeries | GetDataPointVisible
Range | Validate
Spreadsheet | FireParametersOut
XmlDataBinding | Delete , Refresh, Update
XmlDataBindings | Add
XmlMap | Delete , ExportMetaData, ExportXML, ImportXml
XmlMaps | Add


新增事件

访问 Microsoft Developer Network (MSDN) 网站上的“Office 开发人员中心”，获取有关使用 Microsoft Office 2003 Web 组件进行编程的最新信息，包括产品新闻、技术文章、下载内容以及示例。

下表列出了添加到 Microsoft Office 2003 Web 组件对象模型中的事件。

新增事件 | 对象
BindingAdded | Spreadsheet
BindingCompleted | Spreadsheet
BindingDeleted | Spreadsheet
BindingError | Spreadsheet
BindingUpdated | Spreadsheet
ParametersOutReady | Spreadsheet
RowReady | Spreadsheet


Microsoft Office 图表工作区示例

创建数据绑定图表

创建使用数组指定的数据的图表

创建使用 ADO 记录集数据的图表

创建使用 Microsoft Office 电子表格数据的图表

使用图表

创建包含多个图表类型的图表

图表集合

创建易于访问的图表


在 VBScript 中声明和使用事件过程

使用 Private 和 ByVal 关键字和参数以显式声明方式在 Visual Basic 中声明事件过程，如下面示例所示。

Private Sub Spreadsheet1_MouseOver(ByVal Button As Long, ByVal Shift As Long, ByVal Target As Range)

由于 VBScript 不使用这些关键字而所有参数通过 Variant 传递，因此该过程声明在 VBScript 中无效。取而代之，只是使用事件名称和参数名称即可在 VBScript 中声明事件过程，如下面示例所示。

Sub Spreadsheet1_MouseOver(Button, Shift, Target)

参数名称本身只是任何容器中的惯例（可以使用任何参数名称）。

注意 某些脚本编辑器（包括 Microsoft 脚本编辑器）在创建事件过程时并不填写参数列表。为了确保事件过程正确运行，请查询“对象浏览器”或帮助中相应的主题，并自行填写参数列表。


在 VBScript 中使用命名常量

在 VBScript 代码中不能使用命名常量。本示例在 Visual Basic 中有效而在 VBScript 中无效。

Set valueAxis = ChartSpace1.Charts(0).Axes(chAxisPositionLeft)

VBScript 只是将命名常量 chAxisPositionLeft 视为另一个未初始化的变量，因此其值为 0（零）。由于 chAxisPositionLeft 的实际值为 –3，因此该代码在 VBScript 中不会按预期工作。

Constants 属性返回一个允许 VBScript 编程人员用作常量的对象。该属性应用于每个顶层容器对象（ChartSpace、DataSourceControl、PivotTable 和 Spreadsheet）。它返回一个包含 Microsoft Office Web Components 类型库中所有命名常量的（无论 Constants 属性应用于任何对象，总是返回命名常量的完整集合）。

要在 VBScript 中使用命名常量，可以设置指向由 Constants 属性返回的对象的对象变量，然后使用该对象在代码中指定命名常量，如下面示例所示。

Set chConstants = ChartSpace1.Constants
Set valueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionLeft)

还可以在表达式中直接使用 Constants 属性，如下面示例所示。

Spreadsheet1.ActiveSheet.Export "sstest.xls", Spreadsheet1.Constants.ssExportActionNone

注释 可以在 Visual Basic 中使用 Constants 属性，但是既不必需也不建议。在不需要如此的容器中使用 Constants 属性将明显导致代码运行缓慢。


安全连接外部数据源

在为网页上的 Office Web 组件定义到外部数据源的连接时，此信息将以非加密（纯文本）的连接字符串形式存储在 HTML 源中。因此，在浏览器中打开该页的用户可以很方便地查看该页的 HTML 源，并阅读连接字符串，根据您定义连接的方式，此字符串可能会包含用户名和密码。

如果数据源支持这种验证模式，则若要阻止用户使用连接字符串的信息进行未授权的访问，请使用 Windows 验证（也称作“可信连接”和“集成的安全”），这种验证方式使用当前用户的 Microsoft Windows 帐户连接外部数据源。使用 Windows 验证连接外部数据源有以下优点：

  • 编程人员或网页设计人员不必输入用户名或密码即可连接到数据源，因此信息不会暴露在网页的 HTML 源中。
  • 网页的用户在打开该网页时不必输入用户名或密码即可连接到数据源，因此在发送到服务器的过程中，信息不会遭到损坏。
  • 仅允许在安全系统中为数据源配置的 Windows 用户帐户连接到该数据源。

要点 若要使用 Windows 验证，您希望其能连接到外部数据源的用户必须具有 Windows 域的用户帐户。Windows 工作组的成员用户无法使用 Windows 验证。

在 Office Web 组件的用户接口中定义连接

例如，若要使用 Windows 验证从电子表格组件的用户接口中连接到 Microsoft SQL Server，请使用以下过程定义连接。

要点 在使用 Windows 验证连接 Microsoft SQL Server 数据库之前，服务器管理员必须对服务器进行配置以使用此验证模式，并且必须为 Windows 用户帐户（或用户帐户所属的组）以及任何您希望能够访问解决方案的用户帐户授予登录访问权。另外，服务器管理员将为用户帐户授予解决方案所要求的对表格或存储过程的最低级别权限。

  1. 在设计窗口中，确保电子表格处于激活状态。有关说明，请参阅设计程序的“帮助”。
  2. 单击工具栏上的“命令和选项”，然后单击“数据源”选项卡。
  3. 单击“编辑”，然后双击“新 SQL Server 连接”。
  4. 在“服务器名称”中，指定服务器的名称。
  5. 在“登录凭据”下，单击“使用 Windows 验证”。
  6. 单击“下一步”，然后按照“数据连接向导”剩余屏幕中的指示指定要检索的数据。

注释

  • 某些设计程序在默认状态下不支持电子表格的设计阶段用户接口。如果正在使用此类程序，则第二步不会显示“数据源”选项卡。若要激活设计阶段用户接口，必须将 DisplayDesignTimeUI 属性设置为 True。
  • 其他支持 Windows 验证的数据源可能会在“数据连接向导”中提供不同的选项。例如，若要用 Windows 验证连接到 Oracle 数据库，必须仅在“用户名”框中输入一个正斜杠 (/)。有关使用 Windows 验证连接数据源的详细信息，请参阅所使用的数据源提供程序的文档。
  • 如果使用“Microsoft SQL Server 的数据检索服务”（或者使用已定义为可使用该数据检索服务的“数据检索服务连接(.uxdc)”文件）连接到外部数据源，并且不使用 Windows 验证，则用于连接到数据源的用户名和密码不会保存在该网页中。当使用此方法连接外部数据源时，宿主电子表格的网页的用户会收到输入其登录信息的提示。若要使用数据检索服务，必须有访问已安装了该数据检索服务的 Windows SharePoint Services 服务器的权限。默认情况下，Windows SharePoint Services 安装用于连接到 SharePoint 列表中的数据的数据检索服务。SharePoint 网站管理员可以安装 Office 2003 Web 部件和组件以添加用于 Microsoft SQL Server 和 Microsoft 企业解决方案的数据检索服务。Office 2003 Web 部件和组件可从 Microsoft Office 联机下载中获得。若要使用数据检索服务定义连接，请在上述过程的第二步中单击“编辑”，单击“新建源”，然后单击“Microsoft 企业解决方案”（以连接到 Microsoft 企业解决方案数据）或单击“数据检索服务”（以连接到 Windows SharePoint Services 列表或 Microsoft SQL Server 数据）。

以编程方式定义到外部数据的连接

当使用 ConnectionString 属性定义到外部数据源的连接（或定义 ADO Connection 对象的连接字符串以使其传递到 PivotTable 对象的 Connection 属性）时，如果可能，应使用 Windows 验证。若要对 SQL Server 使用 Windows 验证，您的连接字符串应使用以下包含 Integrated Security=SSPI 的格式：

Provider=SQLOLEDB;Data Source=NameOfServer;Initial Catalog=NameOfDatabase;
   Integrated Security=SSPI

其他数据源的连接字符串可能需要不同的格式，例如，若要使用 Windows 验证连接到 Oracle 数据库，您需要传递用户 ID 值的正斜杠 (/)：

Provider=MSDAORA.1;User ID=/;Data Source=NameOfServer;
   Initial Catalog=NameOfDatabase

使用不支持 Windows 验证的数据源

如果 Windows 验证对要使用的数据源不可用，则必须在以编程方式或在 Office Web 组件的用户接口中定义连接时传递用户名和密码来连接数据源。由于当网页上存在电子表格、图表或数据透视表组件时，其他用户可能会获得此用户名和密码，所以应避免使用此验证模式从网页上某个组件中连接敏感数据。即使您并不介意未授权用户查看您的数据，也应仅用一个对数据源具有有限权限的用户帐户进行连接。例如当使用用户名和密码连接 SQL Server 数据库时，不要使用系统管理员帐户或其他任何具有较高权限的帐户，这是因为未授权用户可能使用此帐户和密码来访问服务器上的其他数据。


创建易于访问的图表

当您新建图表时，默认情况下，HasSelectionMarks 和 AllowPropertyToolBox 属性将设置为 False。因此，仅使用键盘操作图表的用户无法看到图表中的项目何时被选中 (HasSelectionMarks)，并且无法显示“命令和选项”对话框以设置所选项目的属性 (AllowPropertyToolBox)。若要启用这些功能以便使用键盘的用户访问图表更容易，您可在设计时按如下步骤手动设置这些属性。

启用选定标记和“命令和选项”对话框

  1. 右键单击图表控件，再单击“命令和选项”。
  2. 在“显示/隐藏”选项卡上的“允许用户查看”下，单击“选定标记”和“命令和选项对话框”。

另外，您也可通过编程方式来设置这些属性，如下面的示例所示。

Sub Make_Accessible()

   'Show selection marks for individual chart elements.
   Chartspace1.HasSelectionMarks = True

   'Allow the user to display the Commands and Options dialog box.
   Chartspace1.AllowPropertyToolbox = True

End Sub


AllGroupingDefs 集合对象

多个对象
AllGroupingDefs
GroupingDef
PageFields

包含数据源控件的所有 GroupingDef 对象。

使用 AllGroupingDefs 集合

DataSourceControl 对象的 AllGroupingDefs 属性返回一个 AllGroupingDefs 集合。


AllPageFields 集合对象

多个对象
AllPageFields
PageField
多个对象

包含数据源控件的所有 PageField 对象。

使用 AllPageFields 集合

DataSourceControl 对象的 AllPageFields 属性返回一个 AllPageFields 集合。


Borders 集合对象

Range
Borders
多个对象

由表示工作表区域的四个边框的四个 Border 对象组成的集合。

使用 Borders 集合

Range 对象的 Borders 属性返回一个 Borders 集合。


ChAxes 集合

ChChart
ChAxes
多个对象

表示单张图表上坐标轴的 ChAxis 对象集合。每张图表最多可有十六条坐标轴。

使用 ChAxes 集合

ChChart 对象的 Axes 属性返回 ChAxes 集合。


ChCategoryLabels 集合对象

ChAxis
ChCategoryLabels
多个对象

表示指定分类坐标轴上所有 ChCategoryLabel 对象的集合。

使用 ChCategoryLabels 集合对象

使用 ChAxis 对象的 CategoryLabels 属性返回一个 ChCategoryLabels 集合。本示例显示 Chartspace1 中第一个图表上分类坐标轴的标志数。

Sub DisplayItemCount

   Dim chtChart1
   Dim chConstants

   Set chConstants = Chartspace1.Constants

   Set chtChart1 = Chartspace1.Charts(0)

   MsgBox chChart1.Axes(chConstants.chAxisPositionCategory) _
          .CategoryLabels.ItemCount

End Sub


ChChartFields 对象

ChDropZone
ChChartFields
多个对象

表示已经添加到放置区的字段。包含一个 ChChartField 对象集合。

使用 ChChartFields 对象

ChDropZone 对象的 ChartFields 属性返回 ChChartFields 对象。


ChCharts 集合

多个对象
ChCharts
ChChart
多个对象

图表工作区中的 ChChart 对象集合。每个 ChChart 对象表示一个图表。图表工作区最多可以包含 64 个图表。

使用 ChCharts 集合

ChartSpace 对象的 Charts 属性返回 ChCharts 集合。


ChDataLabelsCollection 集合

ChSeries
ChDataLabelsCollection
多个对象

表示数据系列的 ChDataLabels 对象集合。每个 ChDataLabels 对象表示数据系列的一组数据标签。

使用 ChDataLabelsCollection 集合

使用 ChSeries 对象的 DataLabelsCollection 属性返回 DataLabelsCollection 集合。

使用 ChDataLabelsCollection 集合的 Add 方法为数据系列添加一组数据标签。

下面示例为 Chartspace1 中第一张图表的第一个系列添加数据标签，然后设置数据标签格式。

Sub AddDataLabels()

    Dim serSeries1
    Dim dlSeries1Labels

    ' Set a variable to the first series of the first chart
    ' in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a set of data labels to the first series and return
    ' a DataLabels object.
    Set dlSeries1Labels = serSeries1.DataLabelsCollection.Add

    ' Set the number format of the data labels.
    dlSeries1Labels.NumberFormat = "0.00"

    ' Set the data labels to display the category
    ' name for the data point.
    dlSeries1Labels.HasCategoryName = True

    ' Set the data labels to display the value
    ' for the data point.
    dlSeries1Labels.HasValue = True

End Sub


ChErrorBarsCollection 对象

ChSeries
ChErrorBarsCollection
多个对象

单个系列的 ChErrorBars 对象集合。

使用 ChErrorBarsCollection 对象

ChSeries 对象的 ErrorBarsCollection 属性返回 ChErrorBarsCollection 对象。

下面示例为 ChartSpace1 中第一张图表的第一个系列添加误差线，然后设置误差线属性。

Sub AddErrorBars()

    Dim chConstants
    Dim ebCollection
    Dim ebSeries1

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the collection of error bars for
    ' the first series in the first chart of Chartspace1.
    Set ebCollection = ChartSpace1.Charts(0).SeriesCollection(0).ErrorBarsCollection

    ' Add error bars to the chart.
    ebCollection.Add

    ' Set a variable to the error bars for the data series.
    Set ebSeries1 = ebCollection.Item(0)

    ' Set the error bars so that they represent a certain
    ' percentage of the value of a data point.
    ebSeries1.Type = chConstants.chErrorBarTypePercent

    ' The error bars represent 5% of a data point.
    ebSeries1.Amount = 0.05

End Sub


ChLegendEntries 集合

ChLegend
ChLegendEntries
多个对象

指定图例的 ChLegendEntry 对象集合。

使用 ChLegendEntries 集合

ChLegend 对象的 LegendEntries 属性返回 ChLegendEntries 集合。

使用 LegendEntries(index) 返回单个 LegendEntry 对象，其中 index 为图例项索引号。不能按名称返回图例项。

索引号表示图例项在图例中的位置。LegendEntries(0) 位于图例的顶部，而 LegendEntries(LegendEntries.Count - 1) 位于图例的底部。下面示例更改 Chartspace1 中图表工作区图例顶部图例项（通常为第一系列的图例）的文本字体。

Chartspace1.ChartSpaceLegend.LegendEntries(0) _
    .Font.Bold = True


ChPoints 集合

ChSeries
ChPoints
多个对象

数据系列中所有 ChPoint 对象的集合。系列中数据点的数量仅受所用计算机中系统内存的限制。

使用 ChPoints 集合

ChSeries 对象的 Points 属性返回 ChPoints 集合。

使用 Points(index) 返回单个 ChPoint 对象，其中 index 为点索引号。点在系列中从左向右编号。Points(0) 为最左侧的点，Points(Points.Count - 1) 为最右侧的点。下面示例将 Chartspace1 第一张图表中第一个系列的第三个点存储在一个变量中。

Sub GetPointValue()

Dim ptSeries1Points
Dim dblPointValue

' Set a variable to the collection of points for the first
' data serties in the first chart in Chartspace1.
Set ptSeries1Points = ChartSpace1.Charts(0).SeriesCollection(0).Points

' Store the underlying value of the third data point in a variable.
dblPointValue = ptSeries1Points(2).GetValue(chDimValues)

End Sub


ChSelectionCollection 集合

多个对象
ChSelectionCollection

使用 ChSelectionCollection 集合

可使用 SelectionCollection 属性检索选择列表。ChartSpace 对象的 SelectionCollection 属性（例如 ChartSpace.SelectionCollection）返回 ChSelectionCollection 集合，其中包含图表中所有选中的对象，包括主要选择和次要选择。主要选择是此集合中的第一项。任何其他项都是次要选择，它们只能是 ChPoint 对象。此集合总是至少包含一项，即主要选择。由 ChartSpace.SelectionCollection(0) 返回的对象与 ChartSpace 对象的 Selection 属性返回的对象相同（例如 ChartSpace.Selection）。ChSelectionCollection 集合只能使用 Select2 方法进行填充，例如 Chartspace.Charts(0).Seriescollection(x),Points(y).Select2()。

不能在图表组件的用户界面中选择多项。必须以编程方式向某个选择中添加项或从中将其删除。若要在用户单击图表时能捕捉到多个选择，必须监视鼠标移动和鼠标按钮事件，并标识使用 ChartSpace 对象的 RangeFromPoint 方法选中的项。若要防止图表组件的内置选择处理操作干扰多项选择的编程跟踪，必须确保将 ChartSpace 对象的 AllowUISelection 属性设置为 False。

可使用 Item 属性返回从 ChSelectionCollection 集合中选中的单个对象。对 ChSelectionCollection 集合中各对象编制的索引是从 0 开始，0 表示第一个对象，1 表示第二个对象，依此类推。可使用 Count 属性返回 ChSelectionCollection 集合中的项目数。Parent 属性返回父对象，此处为 ChartSpace 对象。

ChSelectionCollection 集合没有方法。


ChSeriesCollection 集合对象

ChChart
ChSeriesCollection
多个对象

图表上所有 ChSeries 对象的集合。图表最多可以包含 256 个系列。

使用 ChSeriesCollection 集合对象

ChChart 对象的 SeriesCollection 属性返回 ChSeriesCollection 集合。

使用 Add 方法新建系列并添加到图表中。

使用 SeriesCollection(index) 返回单个 ChSeries 对象，其中 index 为索引号或名称。本示例设置 ChartSpace1 的第一个图表中第一个系列的内部颜色。

ChartSpace1.Charts(0).SeriesCollection(1).Interior.Color = "Red"


ChTrendlines 集合

ChSeries
ChTrendlines
多个对象

系列的 ChTrendline 对象集合。

使用 ChTrendlines 集合

ChSeries 对象的 Trendlines 属性返回 ChTrendlines 集合。

使用 ChTrendline 对象的 Add 方法在图表中添加趋势线。

下面示例为 Chartspace1 中第一张图表的第一个系列添加一条趋势线，并设置趋势线格式。

Sub AddPolyTrendline()

    Dim serSeries1
    Dim chConstants
    Dim tlSeries1Trend

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the first series of the first chart
    ' in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a trendline to the first series and return
    ' a Trendline object.
    Set tlSeries1Trend = serSeries1.Trendlines.Add

    ' Display the equation used to calculate the trendline.
    tlSeries1Trend.IsDisplayingEquation = True

    ' Set the trendline to be a polynomial trendline.
    tlSeries1Trend.Type = chConstants.chTrendlineTypePolynomial

End Sub


DataPages 集合对象

多个对象
DataPages
DataPage
多个对象

包含数据源控件的所有 DataPage 对象。

使用 DataPages 集合

DataSourceControl 对象的 DataPages 属性返回一个 DataPages 集合。


ElementExtensions 集合对象

多个对象
ElementExtensions
ElementExtension

包含指定数据源控件的 ElementExtension 对象。

使用 ElementExtensions 集合

DataSourceControl 对象的 ElementExtensions 属性返回一个 ElementExtensions 集合。


Filters 集合对象

AutoFilter
Filters
多个对象

表示“自动筛选”使用的筛选集合。每个筛选以一个 Filter 对象表示。AutoFilter 对象包含一个 Filters 集合，Filters 集合包含筛选区域中每列的 Filter 对象，每个 Filter 对象包含一个 Criteria 对象。

使用 Filters 对象

AutoFilter 对象的 Filters 属性返回一个 Filters 集合。


GroupingDefs 集合对象

RecordsetDef
GroupingDefs
GroupingDef
PageFields

表示在记录集定义中创建明细记录的分组父层的 GroupingDef 对象集合。顺序非常重要，索引号越低，分组层次越高。索引 0（零）为最低一级分组。

使用 GroupingDefs 集合

RecordsetDef 对象的 GroupingDefs 属性返回一个 GroupingDefs 集合。


GroupLevels 集合对象

多个对象
GroupLevels
GroupLevel

表示指定数据源控件的 GroupLevel 对象集合。每个 GroupLevel 对象表示数据访问页层次中指定级别所有记录的集合。

使用 GroupLevels 集合

DataSourceControl 对象的 GroupLevels 属性返回一个 GroupLevels 集合。


Headings 对象

Window
Headings
多个对象

Window 对象的行和列标题的集合。

使用 Headings 对象

下列属性返回 Headings 集合。

Window 对象的 RowHeadings 属性。

Window 对象的 ColumnHeadings 属性。

下面示例自定义 Spreadsheet1 中活动工作表上 D 列的标题。

Spreadsheet1.ActiveWindow.ColumnHeadings(4).Caption = "1999 Sales"


ListObjects 集合

Worksheet
ListObjects
多个对象

使用 ListObjects 集合

ListObjects 集合为工作表中所有 ListObject 对象的集合。ListObject 对象表示电子表格组件中的 XML 列表。ListObject 对象为 ListObjects 集合的成员。

对 ListObjects 集合中的各 ListObject 对象编制的索引是从 1 开始，1 表示第一个对象，2 表示第二个对象，依此类推。可使用 Item 属性从 ListObjects 集合中返回单个 ListObject 对象。Item 属性的参数为 ListObjects 集合中 ListObject 对象的名称或索引号。名称为 XML 电子表格文件中 MapInfo/Map/Entry 的 ID 属性值。在 XML 电子表格文件中显示这些详细信息的 XML 段落类似于：

<x2:MapInfo xmlns:x2="http://schemas.microsoft.com/office/excel/2003/xml">
   <x2:Map x2:ID="Cust_MapId">
      <x2:Entry x2:ID="example_id" x2:Type="table">
         ...
      </x2:Entry>
   </x2:Map>
</x2:MapInfo>

上面的示例中，ID 值为 example_id。也可使用 ListObject 对象的 Name 属性获得该名称。可使用 Microsoft Excel 创建 XML 电子表格文件，方法是：先创建数据绑定的电子表格，然后再将该工作簿另存为 XML 电子表格。

可使用只读 Count 属性返回 ListObjects 集合中的对象数。使用 Application 和 Parent 属性可返回指定的 ListObjects 集合的电子表格组件和父对象（即 Worksheet 对象）。


ListRows 集合

ListObject
ListRows
多个对象

使用 ListRows 集合

ListRows 集合为 ListObject 对象中所有 ListRow 对象的集合。ListObject 对象表示电子表格组件中的 XML 列表。ListRow 对象为 ListRows 集合的成员。

对 ListRows 集合中的各 ListRow 对象编制的索引是从 1 开始，1 表示第一个对象，2 表示第二个对象，依此类推。可使用 Item 属性返回 ListRows 集合中的单个 ListRow 对象。Item 属性的参数为 ListRows 集合中 ListRow 对象的索引号。

假设要在 ListRows 集合中通过将插入行中的单元格提升到“official”行创建新行。若要完成此操作，请使用 Add 方法，它将返回表示新建行的 ListRow 对象。新行将添加到 XML 列表的底部。

可使用只读 Count 属性返回 ListRows 集合中的对象数。Application 和 Parent 属性返回指定的 ListRows 对象的电子表格组件和父对象（即 ListObject 对象）。


LookupRelationships 集合对象

PageRowsource
LookupRelationships
PageRelationship
多个对象

表示 PageRelationship 对象集合，这些对象定义与页面行来源的查询连接关系。在本主题显示的对象图示中，第一个 PageRowsource 对象（在 LookupRelationships 集合之上）为一对多关系中的“多”侧的对象，而 PageRelationship 对象（在集合下）为“一”侧的对象。

使用 LookupRelationships 集合

PageRowsource 对象的 LookupRelationships 属性返回一个 LookupRelationships 集合。


LookupSchemaRelationships 集合对象

SchemaRowsource
LookupSchemaRelationships
SchemaRelationship
SchemaRelatedFields

表示 SchemaRelationship 对象集合，其中单个方案行来源作为一对多关系中的“多”侧。

使用 LookupSchemaRelationships 集合

SchemaRowsource 对象的 LookupSchemaRelationships 属性返回一个 LookupSchemaRelationships 集合。


Names 集合

多个对象
Names
Name
Range

工作簿中所有 Name 对象的集合。每个 Name 对象可表示一个单元格区域、公式或常量值的定义名称。

使用 Names 集合

使用 Names 属性返回 Names 集合。下面示例创建活动工作簿中所有名称的列表，包括引用的地址。

Sub List_All_Names()
   Dim nmCurrentName
   Dim rngCurrent

   Set rngCurrent = Spreadsheet1.ActiveSheet.Range("A1")

   ' Loop through all of the names in the active workbook.
   For Each nmCurrentName In Spreadsheet1.ActiveWorkbook.Names

      ' Write the current name to the worksheet.
      rngCurrent.Value = nmCurrentName.Name

      ' Write the definition of the current name to the worksheet.
      rngCurrent.Offset(0, 1).Value = "'" & nmCurrentName.RefersTo

      Set rngCurrent = rngCurrent.Offset(1, 0)
   Next
End Sub

使用 Add 方法创建名称并将其添加到集合。以下示例新建一个名称，引用工作表“Sheet1”中 A1:C20 范围内的单元格。

Spreadsheet1.Names.Add "CurrentMonth", "=Sheet1!$A$1:$C$20"

RefersTo 参数必须在 A1 的样式批注中指定，并在适当位置包含美元符号 ($)。例如，如果在 Sheet1 上选定单元格 A10 并且通过将 RefersTo 参数设为“=Sheet1!A1:B1”定义了一个名称，则新名称实际引用 A10:B10（因为您指定了一个相对引用）。若要指定绝对引用，请使用“=Sheet1!$A$1:$B$1”。


OCCommands 对象

多个对象
OCCommands
OCCommand

包含一个 OCCommand 对象集合，表示指定 Microsoft Office Web Component 中所有可用的用户界面和键盘命令的集合。

使用 OCCommands 对象

下列属性返回一个 OCCommands 集合：

  • ChartSpace 对象的 Commands 属性。
  • PivotTable 对象的 Commands 属性。
  • Spreadsheet 对象的 Commands 属性。

OCCommandId、ChartCommandIdEnum、PivotCommandId 和 SpreadsheetCommandId 常量中包含每个 Web 组件支持的命令列表。

使用 Item 属性返回单个 OCCommand 对象。


PageFields 集合对象

多个对象
PageFields
PageField
多个对象

PageField 对象集合，这些对象描述将在由指定记录集定义产生的记录集中出现的字段。这些字段由组成该记录集定义的页面行来源的输出字段与添加到该集合中的其他字段组合而成。集合中的顺序并不重要，因为所有控件均按名称绑定而不是按与输出记录集中字段的顺序关系绑定。

使用 PageFields 集合对象

RecordsetDef、PageRowSource 和 GroupingDef 对象的 PageFields 属性返回一个 PageFields 集合。


PageRelatedFields 集合对象

PageRelationship
PageRelatedFields
PageRelatedField
PageField

属于指定记录集定义的 PageRelatedField 对象集合。该集合在创建基于 SchemaRelatedFields 集合的记录集定义时自动填充。

使用 PageRelatedFields 集合

PageRelationship 对象的 PageRelatedFields 属性返回一个 PageRelatedFields 集合。


PageRowsources 集合对象

RecordsetDef
PageRowsources
PageRowsource
多个对象

数据模型中的 PageRowsource 对象集合。

使用 PageRowsources 集合对象

RecordsetDef 对象的 PageRowsources 属性返回一个 PageRowsources 集合。


Panes 集合对象

Window
Panes
多个对象

工作表的 Pane 对象集合。

使用 Panes 集合

Window 对象的 Panes 属性返回一个 Panes 集合。


ParameterValues 集合对象

RecordsetDef
ParameterValues
ParameterValue

记录集定义的 ParameterValue 对象集合。

使用 ParameterValues 集合

RecordsetDef 对象的 ParameterValues 属性返回一个 ParameterValues 集合。


PivotAggregates 集合对象

PivotCell
PivotAggregates
PivotAggregate
多个对象

指定单元格的 PivotAggregate 对象集合。

使用 PivotAggregates 集合

PivotCell 对象的 Aggregates 属性返回一个 PivotAggregates 集合中的对象。


PivotAxisMembers 集合

多个对象
PivotAxisMembers
PivotAxisMember
多个对象

PivotAxisMember 对象的集合。

使用 PivotAxisMembers 集合

使用 PivotAxisMembers 集合的 Item 属性返回 PivotAxisMember 对象。


PivotColumnMembers 集合

多个对象
PivotColumnMembers
PivotColumnMember
多个对象

PivotColumnMember 对象的集合。

使用 PivotColumnMembers 集合

使用 PivotColumnMembers 集合的 Item 属性返回 PivotColumnMember 对象。


PivotFields 集合对象

多个对象
PivotFields
PivotField
多个对象

指定字段集的 PivotField 对象集合。

使用 PivotFields 集合

使用下列对象的 Fields 属性返回一个 PivotFields 集合：PivotDetailRange、PivotFieldSet、PivotResultColumnAxis、PivotResultDataAxis、PivotResultGroupAxis、PivotResultPageAxis 或 PivotResultRowAxis。


PivotFieldSets 集合对象

多个对象
PivotFieldSets
PivotFieldSet
多个对象

指定坐标轴上或指定视图中的 PivotFieldSet 对象集合。

使用 PivotFieldSets 集合

下列属性返回一个 PivotFieldSets 集合中的对象：

  • PivotAxis 对象的 FieldSets 属性

  • PivotDataAxis 对象的 FieldSets 属性

  • PivotFilterAxis 对象的 FieldSets 属性

  • PivotGroupAxis 对象的 FieldSets 属性

  • PivotResultFilterAxis 对象的 FieldSets 属性

  • PivotView 对象的 FieldSets 属性


PivotMemberProperties 集合

PivotField
PivotMemberProperties
PivotMemberProperty

PivotMemberProperty 对象的集合。

使用 PivotMemberProperties 集合

使用 PivotMemberProperties 集合的 Item 属性返回 PivotMemberProperty 对象。


PivotMembers 集合对象

多个对象
PivotMembers
PivotMember
多个对象

PivotMember 对象集合。

使用 PivotMembers 集合

下列属性返回一个 PivotMembers 集合中的对象：

  • 下列对象的 ChildMembers 属性：PivotAxisMember、PivotColumnMember、PivotMember、PivotPageMember 或 PivotRowMember

  • PivotField 对象的 CustomGroup Members 属性


PivotPageMembers 集合

PivotPageMember
PivotPageMembers
PivotPageMember
多个对象

PivotPageMember 对象的集合。

使用 PivotPageMembers 集合

使用 PivotPageMembers 集合的 Item 属性返回 PivotPageMember 对象。


PivotResultGroupFields 集合

多个对象
PivotResultGroupFields
PivotResultGroupField
多个对象

PivotResultGroupField 对象的集合。

使用 PivotResultGroupFields 集合

下列属性返回一个 PivotResultGroupFields 集合：

PivotResultColumnAxis 对象的 GroupFields 属性。

PivotResultGroupAxis 对象的 GroupFields 属性。

PivotResultPageAxis 对象的 GroupFields 属性。

PivotResultRowAxis 对象的 GroupFields 属性。


PivotResultMemberProperties 集合

多个对象
PivotResultMemberProperties
PivotResultMemberProperty
PivotMemberProperty

结果成员的成员属性集合。

使用 PivotResultMemberProperties 集合

下列属性返回一个 PivotResultMemberProperties 集合：

PivotAxisMember 对象的 MemberProperties 属性。

PivotColumnMember 对象的 MemberProperties 属性。

PivotPageMember 对象的 MemberProperties 属性。

PivotRowMember 对象的 MemberProperties 属性。


PivotRowMembers 集合

多个对象
PivotRowMembers
PivotRowMember
多个对象

PivotRowMember 对象的集合。

使用 PivotRowMembers 集合

使用 PivotRowMembers 集合的 Item 属性返回 PivotRowMember 对象。


PivotTotals 集合对象

多个对象
PivotTotals
PivotTotal
多个对象

指定数值轴上或指定视图中的 PivotTotal 对象集合。

使用 PivotTotals 集合

PivotDataAxis、PivotResultDataAxis 和 PivotView 对象的 Totals 属性返回一个 PivotTotals 集合。


RecordsetDefs 集合对象

多个对象
RecordsetDefs
RecordsetDef
多个对象

指定数据源控件的 RecordsetDef 对象集合。

使用 RecordsetDefs 集合

DataSourceControl 对象的 RecordsetDefs 属性返回一个 RecordsetDefs 集合。


SchemaFields 集合对象

SchemaRowsource
SchemaFields
SchemaField
SchemaProperties

方案行来源中所有可用 SchemaField 对象的集合。

使用 SchemaFields 集合

SchemaRowsource 对象的 SchemaFields 属性返回一个 SchemaFields 集合。


SchemaParameters 集合对象

SchemaRowsource
SchemaParameters
SchemaParameter
SchemaProperties

指定方案行来源的 SchemaParameter 对象集合。

使用 SchemaParameters 集合

SchemaRowsource 对象的 SchemaParameters 属性返回一个 SchemaParameters 集合。


SchemaRelationships 集合对象

多个对象
SchemaRelationships
SchemaRelationship
SchemaRelatedFields

数据源控件的 SchemaRelationship 对象集合。

使用 SchemaRelationships 集合

DataSourceControl 对象的 SchemaRelationships 属性返回一个 SchemaRelationships 集合。


SchemaRowsources 集合对象

多个对象
SchemaRowsources
SchemaRowsource
多个对象

指定数据源控件的 SchemaRowsource 对象集合。在打开数据库时，该集合将以数据库中的对象自动重填。

使用 SchemaRowsources 集合

DataSourceControl 对象的 SchemaRowsources 属性返回一个 SchemaRowsources 集合。


Sheets 集合

多个对象
Sheets
Workbook

工作簿中所有 Worksheet 对象的集合。每个 Worksheet 对象表示一个工作表。

使用 Sheets 集合

下列属性返回 Sheets 集合。

Spreadsheet 对象的 Sheets 属性。

Window 对象的 SelectedSheets 属性。

Workbook 对象的 Sheets 属性。


SublistRelationships 集合对象

RecordsetDef
SublistRelationships
PageRelationship
多个对象

dscSublist 类型的 PageRelationship 对象集合，这些对象全部具有与一对多关系中“一”（父）侧相同的记录集定义。子列表关系的子对象中的记录只在需要时检索。

使用 SublistRelationships 集合

RecordsetDef 对象的 SublistRelationships 属性返回一个 SublistRelationships 集合。


SublistSchemaRelationships 集合对象

SchemaRowsource
SublistSchemaRelationships
SchemaRelationship
SchemaRelatedFields

SchemaRelationship 对象集合，这些对象具有与（一对多关系中）“一”侧相同的方案行来源。

使用 SublistSchemaRelationships 集合

SchemaRowsource 对象的 SublistSchemaRelationships 属性返回一个 SublistSchemaRelationships 集合。


Windows 集合对象

多个对象
Windows
Window
多个对象

Spreadsheet 控件中所有 Window 对象的集合。Spreadsheet 对象的 Windows 集合包含应用程序中的所有窗口，而 Workbook 对象的 Windows 集合只包含指定工作簿的窗口。在这两种情况下，Spreadsheet 对象均只包含一个 Window 对象。该对象表示工作簿中活动工作表的窗口。

每个工作表具有唯一相关联的 Window 对象。Application.ActiveWindow 或 Application.Workbooks(1).Windows(1) 通常返回指向活动工作表窗口的指针。没有 ActiveSheet.Window 或 Sheets(i).Window。

使用 Windows 集合对象

下列属性返回 Windows 集合。

Spreadsheet 对象的 Windows 属性。

Workbook 对象的 Windows 属性。


Workbooks 集合

多个对象
Workbooks
多个对象

包含电子表格控件中打开的 Workbook 对象的集合。电子表格控件只支持一个打开的工作簿。

使用 Workbooks 集合

使用 ActiveWorkbook 属性引用电子表格控件中当前打开的工作簿。


Worksheets 集合对象

多个对象
Worksheets
Workbook

工作簿中所有 Worksheet 对象的集合。每个 Worksheet 对象表示一个工作表。

使用 Worksheets 集合对象

使用 Spreadsheet 或 Workbook 对象的 Worksheets 属性返回 Worksheets 集合。

使用 Add 方法新建工作表并添加到集合中。本示例在 Spreadsheet1 的第一个工作表之前添加两个工作表。

Spreadsheet1.Worksheets.Add _
        Spreadsheet1.Worksheets(1), ,2

使用 Worksheets(index) 返回单个 Worksheet 对象，其中 index 为工作表索引号或名称。本示例隐藏 Spreadsheet1 中的第一个工作表。

Spreadsheet1.Worksheets(1).Visible = False

Worksheet 对象也是 Sheets 集合中的成员。


XmlDataBindings 集合

Workbook
XmlDataBindings
Workbook

XmlDataBindings 集合包含与电子表格组件相关联的所有 XmlDataBinding 对象。每个 XmlDataBinding 对象都包含配置数据，以将电子表格组件绑定到数据检索服务、SOAP Web 服务、XML 文件或 Web 部件。

使用 XmlDataBindings 集合

XMLDataBinding 对象为 XmlDataBindings 集合的成员，是电子表格组件中所有 XmlDataBinding 对象的集合。对集合中的各 XmlDataBinding 对象编制的索引是从 1 开始，1 表示第一个对象，2 表示第二个对象，依此类推。通过使用 XmlDataBindings 集合的 Item 属性可从该集合返回 XmlDataBinding 对象。Item 属性的参数是该集合中要返回对象的索引号，或是该对象的绑定 ID。绑定 ID 是表示绑定的 XML 中的 ID 属性值。可在电子表格组件（或电子表格 Web 部件）的 XML 电子表格文件中找到该值，或通过检查 XmlDataBinding 对象的 BindingData 属性找到该值。通过使用 Microsoft Excel 创建数据绑定的电子表格，然后再将该工作簿另存为 XML 电子表格可创建 XML 电子表格文件。

使用 XmlDataBindings 集合中的 Add 方法可新建 XmlDataBinding 对象。创建 XmlDataBinding 对象后，即可使用其 BindingData 属性以指定绑定配置信息，并可使用 XmlMap 属性以指定与绑定相关联的架构映射。

下面示例使用 Workbook 对象的 XmlDataBindings 属性创建 XmlDataBindings 对象并显示如何处理绑定信息：

Dim objBindings
Dim objBinding
Dim strBindingInfo

Set objBindings = Spreadsheet1.ActiveWorkbook.XmlDataBindings

For Each objBinding in objBindings
     ' Save the XML binding information to a variable.
     strBindingInfo = objBinding.BindingData
     ' Work with the binding information here.
Next


XmlMaps 集合

Workbook
XmlMaps
Workbook

XmlMaps 集合是所有与电子表格组件相关联的 XmlMap 对象的集合。XmlMap 对象是 XML 架构映射，指定如何将数据源中的数据映射到电子表格组件。

使用 XmlMaps 集合

对 XmlMaps 集合中各 XmlMap 对象编制的索引是从 1 开始，1 表示第一个对象，2 表示第二个对象，依此类推。可使用 Item 属性从 XmlMaps 集合中返回 XmlMap 对象。Item 属性的参数是集合中要返回对象的索引号，或是该对象映射 ID。映射 ID 是表示映射的 XML 中的 ID 属性值。可在部件的 XML 电子表格文件中找到该值，或通过检查 XmlMap 对象的 MapData 属性找到该值。使用 Microsoft Excel 创建数据绑定的电子表格，然后再将该工作簿另存为 XML 电子表格可创建 XML 电子表格文件。通过使用 XmlMaps 集合的 Add 方法可新建 XmlMap 对象。

下面示例使用 XmlMaps 属性返回 XmlMaps 集合对象：

Dim objMaps
Dim objMap
Dim strMapInfo

Set objMaps = Spreadsheet1.ActiveWorkbook.XmlMaps

For Each objMap in objMaps
     ' Save the XML map information to a variable.
     strMapInfo = objMap.MapData
     ' Work with the map information here.
Next


AutoFilter 对象

多个对象
AutoFilter
多个对象

表示“自动筛选”容器。AutoFilter 对象包含一个 Range 集合和一个 Filters 集合。

使用 AutoFilter 对象

Worksheet 对象的 AutoFilter 属性返回指定工作表的 AutoFilter 对象。


Border 对象

Range
Borders
Border
Range

表示对象的边框。

Border 对象为 Borders 集合的成员。

使用 Border 对象

Borders 集合的 Item 属性返回一个 Border 对象。


ByRef 对象

ByRef

包含事件参数的值。

使用 ByRef 对象

某些事件通过 ByRef 对象类型的参数返回或设置数值。如果事件参数为 ByRef 对象类型，请使用参数的 Value 属性返回或设置参数。

下面事件参数通过 ByRef 对象返回或设置数值：

  • BeforeContextMenu 事件的 Menu 和 Cancel 参数
  • BeforeKeyDown 事件的 Cancel 参数
  • BeforeKeyPress 事件的 Cancel 参数
  • BeforeKeyUp 事件的 Cancel 参数
  • BeforeRender 事件的 Cancel 参数
  • CommandBeforeExecute 事件的 Cancel 参数
  • CommandChecked 事件的 Checked 参数
  • CommandEnabled 事件的 Enabled 参数
  • CommandTipText 事件的 Caption 参数
  • EndEdit 事件的 FinalValue、Cancel 和 ErrorDescription 参数
  • StartEdit 事件的 InitialValue、Cancel 和 ErrorDescription 参数（Spreadsheet 对象）
  • StartEdit 事件的 InitialValue、ArrowMode、CaretPosition、Cancel 和 ErrorDescription 参数（PivotTable 对象）


ChartSpace 对象

ChartSpace
多个对象

表示图表工作区。图表工作区为图表容器的顶层，可以包含多个图表，每个图表以 ChChart 对象表示。在新建图表工作区时，工作区为空（不包含任何图表）。请使用 ChCharts 对象的 Add 方法新建图表。

使用 ChartSpace 对象

可以使用 CreateObject 方法或 New 关键字新建 ChartSpace 对象。

HTML 页或 Visual Basic 窗体上的图表控件对象 ID 返回 ChartSpace 对象。

ChartSpace 对象的编程标识符为 CLSID:0002E55D-0000-0000-C000-000000000046。下例将在 HTML 页上创建名为“ChartSpace1”的图表工作区。

<object id=ChartSpace1 classid=CLSID:0002E55D-0000-0000-C000-000000000046 style="width:100%;height:350"></object>


ChAxis 对象

多个对象
ChAxis
多个对象

表示图表上的单个坐标轴。一张图表最多可有十六条坐标轴。ChAxis 对象为 ChAxes 集合的成员。

使用 ChAxis 对象

使用 ChAxes 对象的 Add 方法向图表添加一条坐标轴。

下列属性和方法返回 ChAxis 对象。

ChAxes 对象的 Add 方法

ChAxes 对象的 Item 属性

ChAxis 对象的 CrossingAxis 属性

ChGridlines 对象的 Parent 属性


ChBorder 对象

多个对象
ChBorder

表示图表上对象的边框。

使用 ChBorder 对象

下列属性返回 ChBorder 对象：

ChChart 对象的 Border 属性

ChChartDraw 对象的 Border 属性

ChDataLabel 对象的 Border 属性

ChDataLabels 对象的 Border 属性

ChDropZone 对象的 ButtonBorder 属性

ChDropZone 对象的 WatermarkBorder 属性

ChLegend 对象的 Border 属性

ChPlotArea 对象的 Border 属性

ChPoint 对象的 Border 属性

ChSegmentBoundary 对象的 Border 属性

ChSeries 对象的 Border 属性

ChSurface 对象的 Border 属性

ChTitle 对象的 Border 属性

使用 Color、DashStyle 和 Weight 属性设置边框属性。下面示例设置 ChartSpace1 图例的边框属性。

Sub Format_Chartspace_Legend()

    Dim ChartLegend
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the legend for the chartspace.
    Set ChartLegend = ChartSpace1.ChartSpaceLegend

    ' Set the legend color.
    ChartLegend.Border.Color = "Blue"

    ' Set the line weight for the legend.
    ChartLegend.Border.Weight = chConstants.owcLineWeightThick

    ' Set the line style for the legend.
    ChartLegend.Border.DashStyle = chLineRoundDot

End Sub


ChCategoryLabel 对象

多个对象
ChCategoryLabel
多个对象

表示 ChCategoryLabels 集合中的单个标志。

使用 ChCategoryLabel 对象

可以使用下列属性返回 ChCategoryLabel 对象：

ChCategoryLabels 集合的 Item 属性

ChCategoryLabel 对象的 ParentLabel 属性


ChChart 对象

多个对象
ChChart
多个对象

表示图表工作区中的单个图表。图表工作区最多可以包含 16 个图表。ChChart 对象为 ChCharts 集合的成员。

使用 ChChart 对象

使用 ChCharts 集合对象的 Add 方法在图表工作区中添加一个图表：

下列属性和方法返回 ChChart 对象。

ChAxes 对象的 Parent 属性

ChAxis 对象的 Parent 属性

ChCharts 对象的 Add 方法

ChCharts 对象的 Item 属性

ChPlotArea 对象的 Parent 属性

ChSeries 对象的 Parent 属性

ChSeriesCollection 对象的 Parent 属性


ChChartDraw 对象

ChChartDraw
多个对象

可用于在图表上绘制诸如线条、矩形或椭圆等项。

使用 ChChartDraw 对象

DrawEllipse、DrawLine、DrawPolyLine、DrawPolygon 和 DrawLine 方法可用于在图表上添加图形对象。DrawText 方法可用于向图表添加文本。Border、Font、Interior 和 Line 属性可用于在向图表添加图形对象之前设置其格式。

必须利用下列一个或多个事件向图表添加图形对象：BeforeRender、AfterRender 或 AfterFinalRender。


ChChartField 对象

ChDropZone
ChChartFields
ChChartField
ChDropZone

表示放置区中的字段。

使用 ChChartField 对象

ChChartFields 对象的 Item 属性返回 ChChartField 对象。

如果图表绑定到文字类型数据，访问该对象将导致运行时出错。


不支持的语言元素

您请求了不支持的语言元素的帮助。


ChDataLabel 对象

多个对象
ChDataLabel
多个对象

表示系列或趋势线上的单个数据标志。

使用 ChDataLabel 对象

下列属性可用于返回 ChDataLabel 对象：

ChDataLabels 对象的 Item 属性

ChTrendline 对象的 DataLabel 属性

本示例在 Chartspace1 第一个图表的第一个系列中添加数据标志，然后设置第三个数据标志。

Sub FormatSeriesLabel()

    Dim serSeries1
    Dim dlSeries1Labels

    ' Set a variable to the first series of the first chart
    ' in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a set of data labels to the first series and return
    ' a DataLabels object.
    Set dlSeries1Labels = serSeries1.DataLabelsCollection.Add

    dlSeries1Labels.Item(2).Font.Bold = True
    dlSeries1Labels.Item(2).Font.Color = "Red"

End Sub


ChDataLabels 对象

多个对象
ChDataLabels
多个对象

包含一个 ChDataLabel 对象集合，表示系列中指定数据标志集合中的所有数据标志。请注意系列中可以包含多个数据标志集合。

使用 ChDataLabels 对象

下列属性和方法可用于返回 ChDataLabels 对象：

ChDataLabelsCollection 集合对象的 Add 方法。

ChDataLabelsCollection 集合对象的 Item 属性。

本示例在 Chartspace1 第一个图表的第一个系列中添加数据标志，并设置数据标志的格式。

Sub AddDataLabels()

    Dim serSeries1
    Dim dlSeries1Labels

    ' Set a variable to the first series of the first chart
    ' in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a set of data labels to the first series and return
    ' a DataLabels object.
    Set dlSeries1Labels = serSeries1.DataLabelsCollection.Add

    ' Set the number format of the data labels.
    dlSeries1Labels.NumberFormat = "0.00"

    ' Set the data labels to display the category
    ' name for the data point.
    dlSeries1Labels.HasCategoryName = True

    ' Set the data labels to display the value
    ' for the data point.
    dlSeries1Labels.HasValue = True

End Sub


ChDropZone 对象

多个对象
ChDropZone
多个对象

表示绑定到关系数据源的图表上的放置区。

使用 ChDropZone 对象

ChartSpace 对象的 DropZones 方法返回 ChDropZone 对象。

本示例将设置 Chartspace1 中系列放置区的按钮和水印格式。

Sub Setup_DropZone()

    Dim dzSeriesDropZone
    Dim ChConstants

    Set chConstants = Chartspace1.Constants

    ' Set a variable to the series drop zone in Chartspace1.
    Set dzSeriesDropZone = ChartSpace1.DropZones(chConstants.chDropZoneSeries)

    ' The next three lines of code format the button of the drop zone.
    dzSeriesDropZone.ButtonBorder.Weight = chConstants.owcLineWeightMedium
    dzSeriesDropZone.ButtonInterior.SetSolid "Red"
    dzSeriesDropZone.ButtonFont.Size = 14

    ' The next three lines of code format the watermark of the drop zone.
    dzSeriesDropZone.WatermarkBorder.Color = "Red"
    dzSeriesDropZone.WatermarkFont.Color = "Red"
    dzSeriesDropZone.WatermarkInterior.SetSolid "Green"

End Sub


ChErrorBars 对象

ChSeries
ChErrorBarsCollection
ChErrorBars
多个对象

表示系列的误差线。误差线指定图表数据的不确定度。只有雷达图、极坐标图、面积图、条形图、柱形图、折线图和 XY 散点图具有误差线。只有散点图中的系列具有 x 和 y 误差线。ChErrorBars 对象不是集合。没有表示单个误差线的对象，可以为系列中的所有点打开 x 误差线或 y 误差线，或者将它们关闭。

使用 ChErrorBars 对象

使用 ChErrorBarsCollection 对象的 Add 方法向系列添加误差线。

下列方法返回 ChErrorBars 对象。有关详细信息，请参阅下列方法的帮助主题：

ChErrorBarsCollection 对象的 Add 方法

ChErrorBarsCollection 对象的 Item 属性

下面示例为 ChartSpace1 中第一张图表的第一个系列添加误差线，然后设置误差线属性。

Sub AddErrorBars()

    Dim chConstants
    Dim ebCollection
    Dim ebSeries1

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the collection of error bars for
    ' the first series in the first chart of Chartspace1.
    Set ebCollection = ChartSpace1.Charts(0).SeriesCollection(0).ErrorBarsCollection

    ' Add error bars to the chart.
    ebCollection.Add

    ' Set a variable to the error bars for the data series.
    Set ebSeries1 = ebCollection.Item(0)

    ' Set the error bars so that they represent a certain
    ' percentage of the value of a data point.
    ebSeries1.Type = chConstants.chErrorBarTypePercent

    ' The error bars represent 5% of a data point.
    ebSeries1.Amount = 0.05

End Sub


ChFont 对象

多个对象
ChFont

包含图表上对象的字体属性（字体名称、字体大小、颜色等等）。

使用 ChFont 对象

下列属性可用于返回 ChFont 对象：

ChAxis 对象的 Font 属性

ChChartDraw 对象的 Font 属性

ChDataLabel 对象的 Font 属性

ChDataLabels 对象的 Font 属性

ChDropZone 对象的 ButtonFont 属性

ChDropZone 对象的 WatermarkFont 属性

ChLegend 对象的 Font 属性

ChLegendEntry 对象的 Font 属性

ChTitle 对象的 Font 属性

使用 Name 属性设置指定对象的字体。Bold、Italic、Color、Underline 和 Size 属性可用于进一步设置指定对象的字体格式。


ChFormatMap 对象

多个对象
ChFormatMap
ChSegments

ChFormatMap 对象允许通过设置格式来显示数值区域。ChFormatMap 对象可用于提供可视提示，以突出显示数据的指定部分。

使用 ChFormatMap 对象

ChSeries 对象的 FormatMap 属性返回 ChFormatMap 对象。

格式映射可以包含一个或多个 ChSegment 对象，每个对象可以单独设置格式。

本示例将 Chartspace1 绑定到 SQL Server 罗斯文数据库中的 Order Details 表，然后创建一个格式映射。较小的值以白色显示，较大的值以蓝色阴影显示，图表中的最大值以深蓝色显示。

Sub Window_Onload()

    Dim serSeries1
    Dim segSegment1
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' The following two lines of code bind Chartspace1 to the Order Details table in the
    ' Northwind SQL Server database.
    ChartSpace1.ConnectionString = "Provider=SQLOLEDB.1;Persist Security Info=TRUE;" & _
                                   "Integrated Security=SSPI;Initial Catalog=Northwind;" & _
                                   "Data Source=ServerName;"
    ChartSpace1.DataMember = "Order Details"

    ' The following two lines of code bind Chartspace1 to the Quantity and ProductID fields
    ' in the Order details table.
    ChartSpace1.SetData chConstants.chDimCategories, chConstants.chDataBound, "ProductID"
    ChartSpace1.SetData chConstants.chDimValues, chConstants.chDataBound, "Quantity"

    ' Create a format map.
    ChartSpace1.SetData chConstants.chDimFormatValues, chConstants.chDataBound, "Quantity"

    ' Set a variable to the first series in the first chart in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a segment to the format map.
    Set segSegment1 = serSeries1.FormatMap.Segments.Add

    ' Specify that the divisions in formatting be created automatically.
    segSegment1.HasAutoDivisions = True

    ' Measure the segment boundaries based upon a percentage.
    segSegment1.Begin.ValueType = chConstants.chBoundaryValuePercent
    segSegment1.End.ValueType = chConstants.chBoundaryValuePercent

    ' Set the beginning value to 0%, and the ending value to 100%.
    segSegment1.Begin.Value = 0
    segSegment1.End.Value = 1

    ' Format the interior of the matching values.
    segSegment1.Begin.Interior.Color = "White"
    segSegment1.End.Interior.Color = "Blue"

End Sub

本示例将 Chartspace1 绑定到罗斯文数据库中的 Order Details 表，然后创建两个段。第一段突出显示图表第一个系列中最低的 10% 的数值。第二段突出显示图表第一个系列的最高的 20% 的数值。

Sub Window_Onload()

    Dim serseries1
    Dim segBottom10Pct
    Dim segTop20Pct
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

   ' The following two lines of code bind Chartspace1 to the Order Details table in the
   ' Northwind SQL Server database.
   ChartSpace1.ConnectionString = "Provider=SQLOLEDB.1;Persist Security Info=TRUE;" & _
                                  "Integrated Security=SSPI;Initial Catalog=Northwind;" & _
                                  "Data Source=ServerName;"
   ChartSpace1.DataMember = "Order Details"

   ' The following two lines of code bind Chartspace1 to the Quantity and ProductID fields
   ' in the Order details table.
   ChartSpace1.SetData chConstants.chDimCategories, chConstants.chDataBound, "ProductID"
   ChartSpace1.SetData chConstants.chDimValues, chConstants.chDataBound, "Quantity"

   ' Create a format map.
   ChartSpace1.SetData chConstants.chDimFormatValues, chConstants.chDataBound, "Quantity"

   ' Set a variable to the first series in the first chart in Chartspace1.
   Set serseries1 = ChartSpace1.Charts(0).SeriesCollection(0)

   ' Add a segment to the format map. This segment will
   ' represent the bottom 10% of values in the chart.
   Set segBottom10Pct = serseries1.FormatMap.Segments.Add

   ' Measure the segment boundaries based upon a percentage.
   segBottom10Pct.Begin.ValueType = chConstants.chBoundaryValuePercent
   segBottom10Pct.End.ValueType = chConstants.chBoundaryValuePercent

   ' Set the beginning value to 0%, and the ending value to 10%.

   segBottom10Pct.Begin.Value = 0

   segBottom10Pct.End.Value = 0.1

   ' Format the interior of the matching values.
   segBottom10Pct.Begin.Interior.Color = "red"
   segBottom10Pct.End.Interior.Color = "red"

   ' Add a segment to the format map. This segment will
   ' represent the top 20% of values in the chart.
    Set segTop20Pct = serseries1.FormatMap.Segments.Add

    ' Measure the segment boundaries based upon a percentage.
    segTop20Pct.Begin.ValueType = chConstants.chBoundaryValuePercent
    segTop20Pct.End.ValueType = chConstants.chBoundaryValuePercent

    ' Set the beginning value to 80%, and the ending value to 100%.
    segTop20Pct.Begin.Value = 0.8
    segTop20Pct.End.Value = 1

    ' Format the interior of the matching values.
    segTop20Pct.Begin.Interior.Color = "green"
    segTop20Pct.End.Interior.Color = "green"

End Sub


ChGridlines 对象

ChAxis
ChGridlines
多个对象

表示图表坐标轴的主要和次要网格线。网格线依赖于坐标轴。网格线延伸了图表坐标轴上的刻度线，便于查看数据标志相关的数值。该对象不是集合。没有表示单个网格线的对象，可以打开坐标轴的所有网格线，或者全部关闭。

使用 ChGridlines 对象

下列属性返回 ChGridlines 对象。

ChAxis 对象的 MajorGridlines 属性

ChAxis 对象的 MinorGridlines 属性

下面示例启用 Chartspace1 中第一张图表数值轴的主要和次要网格线，然后设置网格线的宽度。

Sub EnableGridlines()

    Dim chConstants
    Dim axValueAxis

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the value axis in the first chart in Chartspace1.
    Set axValueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue)

    ' The following two lines of code turn on the major and
    ' minor gridlines for the value axis.
    axValueAxis.HasMajorGridlines = True
    axValueAxis.HasMinorGridlines = True

    ' The following two lines of code set the line weight of the
    ' major and minor gridlines for the value axis.
    axValueAxis.MajorGridlines.Line.Weight = chConstants.owcLineWeightMedium
    axValueAxis.MinorGridlines.Line.Weight = chConstants.owcLineWeightHairline

End Sub


ChInterior 对象

多个对象
ChInterior

表示对象的内部格式。

使用 ChInterior 对象

下列属性返回 ChInterior 对象：

ChChart 对象的 Interior 属性

ChChartDraw 对象的 Interior 属性

ChartSpace 对象的 Interior 属性

ChDataLabel 对象的 Interior 属性

ChDataLabels 对象的 Interior 属性

ChDropZone 对象的 ButtonInterior 属性

ChDropZone 对象的 WatermarkInterior 属性

ChLegend 对象的 Interior 属性

ChPlotArea 对象的 Interior 属性

ChPoint 对象的 Interior 属性

ChSegmentBoundary 对象的 Interior 属性

ChSeries 对象的 Interior 属性

ChSurface 对象的 Interior 属性

ChTitle 对象的 Interior 属性

本示例设置 ChartSpace1 中第一张图表的前两个系列和绘图区的内部填充。

Sub FormatInteriorFills()

    Dim chConstants
    Dim serSeries1
    Dim serSeries2

    Set chConstants = ChartSpace1.Constants

    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)
    Set serSeries2 = ChartSpace1.Charts(0).SeriesCollection(1)

    ' Set the interior fill of the first series to a two-color gradient.
    serSeries1.Interior.SetTwoColorGradient chConstants.chGradientDiagonalDown, _
               chConstants.chGradientVariantCenter, "Blue", "Silver"

    ' Set the interior fill of the second series to a solid color.
    serSeries2.Interior.SetSolid "Purple"

    ' Set the interior fill of the plot area to a preset texture.
    ChartSpace1.Charts(0).PlotArea.Interior.SetTextured _
               chConstants.chTextureParchment, chConstants.chTile

End Sub


ChLegend 对象

多个对象
ChLegend
多个对象

表示图表工作区或图表的图例。图表或图表工作区只能包含一个图例。ChLegend 对象包含一个 ChLegendEntries 集合，其中包含一个或多个 ChLegendEntry 对象。

使用 ChLegend 对象

使用 HasLegend 属性或 HasChartSpaceLegend 属性启用图例。

下列属性返回一个 ChLegend 对象。

ChartSpace 对象的 ChartSpaceLegend 属性

ChChart 对象的 Legend 属性

ChLegendEntries 对象的 Parent 属性

ChLegendEntry 对象的 Parent 属性


ChLegendEntry 对象

ChLegend
ChLegendEntries
ChLegendEntry
多个对象

表示单个图例项。ChLegendEntry 对象为 ChLegendEntries 集合的成员。

使用 ChLegendEntry 对象

ChLegendEntries 集合的 Item 属性返回 ChLegendEntry 对象。

使用 LegendEntries(index) 返回单个 LegendEntry 对象，其中 index 为图例项索引号。不能按名称返回图例项。

索引号表示图例项在图例中的位置。LegendEntries(0) 位于图例的顶部，而 LegendEntries(LegendEntries.Count - 1) 位于图例的底部。下面示例更改 Chartspace1 中图表工作区图例顶部图例项（通常为第一系列的图例）的文本字体。

Chartspace1.ChartSpaceLegend.LegendEntries(0) _
    .Font.Bold = True


ChLine 对象

多个对象
ChLine

表示图表上线条的格式。

使用 ChLine 对象

可以使用下列属性返回 ChLine 对象：

ChAxis 对象的 Line 属性

ChChartDraw 对象的 Line 属性

ChErrorBars 对象的 Line 属性

ChGridlines 对象的 Line 属性

ChPoint 对象的 Line 属性

ChSegmentBoundary 对象的 Line 属性

ChSeries 对象的 Line 属性

ChTrendline 对象的 Line 属性


ChMarker 对象

ChSeries
ChMarker

表示折线图、XY 散点图、雷达图或极坐标图上的数据标志。

使用 ChMarker 对象

ChSeries 对象的 Marker 属性返回 ChMarker 对象。

使用 Size 和 Style 属性设置 ChMarker 对象的格式。

下面示例将 Chartspace1 中第一张图表的第一个系列转换为折线图，然后设置折线上数据标志的格式。

Sub FormatMarkers()

    Dim serSeries1
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the first series of the first chart
    ' in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Change the type of the first data series to a line chart.
    serSeries1.Type = chConstants.chChartTypeLineMarkers

    ' Set the marker style.
    serSeries1.Marker.Style = chConstants.chMarkerStyleDiamond

    ' Set the size of the markers.
    serSeries1.Marker.Size = 7

End Sub


ChPlotArea 对象

多个对象
ChPlotArea
多个对象

表示图表的绘图区（绘制图表数据的区域）。饼图、圆环图、雷达图和极坐标图没有绘图区，这些图表直接在图表区上进行绘制。

使用 ChPlotArea 对象

ChChart 对象的 PlotArea 属性返回 ChPlotArea 对象。

下面示例以预定义的纹理填充 Chartspace1 中第一张图表的绘图区。

Sub FormatPlotArea()
   Dim chConstants

   Set chConstants = ChartSpace1.Constants

   ' Set the interior fill of the plot area to a preset texture.
   ChartSpace1.Charts(0).PlotArea.Interior.SetTextured _

   chConstants.chTextureParchment, chConstants.chTile

End Sub


ChPoint 对象

ChSeries
ChPoints
ChPoint
多个对象

表示图表系列中的单个数据点。ChPoint 对象为 ChPoints 集合的成员，该集合包含指定系列中的所有点。

使用 ChPoint 对象

使用该对象设置系列中单个数据点的格式，或使用 GetValue 方法返回点的数值。

ChPoints 对象的 Item 属性返回 ChPoint 对象。


ChScaling 对象

多个对象
ChScaling

表示数据系列、坐标轴或图表的刻度。

使用 ChScaling 对象

下列属性返回一个 ChScaling 对象：

ChAxis 对象的 Scaling 属性

ChChart 对象的 Scalings 属性

ChSeries 对象的 Scalings 属性


ChScrollView 对象

ChChart
ChScrollView

使用 ChScrollView 对象

可使用 ChScrollView 对象的方法和属性检索信息和控制图表视图滚动。

可使用 ChChart 对象的 ScrollView 属性检索图表的 ChScrollView 对象（每个图表一个）。此对象是允许应用程序检索信息和控制视图滚动的主要接口。ChScrollView 对象有若干个属性，可用于指定和确定图表视图的滚动。

可使用 ChScrollView 对象的方法和属性检索有关图表视图的信息及控制图表视图。显示图表本身的图表组件部分是可见的绘图区域，可在此显示整个图表或部分图表。当可见绘图区域中仅显示部分图表时，这种效果就好像是对图表的这部分进行放大，而其余部分则包含在超出可见绘图区域边界的虚拟绘图区域中。

VerticalPosition 和 HorizontalPosition 属性可在垂直方向和水平方向滚动视图。这些属性的初始值一般为位置 (0, 0)，并相对于实际绘图区域（ChPlotArea 对象）的 Left 和 Top 属性值。滚动视图的位移增量与 VerticalExtent 和 VerticalExtentMax 属性的比值，以及 HorizontalExtent 和 HorizontalExtentMax 属性的比值有关。

VerticalExtent 和 VerticalExtentMax 属性的比值指出了滚动视图区域垂直尺寸相对于实际绘图区域垂直尺寸的位置。HorizontalExtent 和 HorizontalExtentMax 属性的比值指出了滚动视图区域水平尺寸相对于实际绘图区域水平尺寸的位置。

通过将 VerticalExtentMax 和 HorizontalExtentMax 属性值分别设置为大于或小于 VerticalExtent 和 HorizontalExtent 属性值，可将图表的显示进行放大或缩小。例如，若要将图表放大 200%，可将 VerticalExtentMax 和 HorizontalExtentMax 属性值设置为 VerticalExtent 和 HorizontalExtent 属性值的两倍。

不论是否放大图表，都可通过使用 ChScrollView 对象的 Top、Left、Right 和 Bottom 属性访问滚动视图的尺寸。而且还可使用 ChPlotArea 对象的 Top、Left、Right 和 Bottom 属性访问实际绘图区域的尺寸。

如果 HorizontalExtent 或 HorizontalExtentMax 属性的值小于或等于零 (0)，将禁用滚动视图，图表不能水平滚动。同样，如果 VerticalExtentMax 或 VerticalExtent 属性的值小于或等于零，则图表不能垂直滚动。

还可使用图表组件的 SetPosition 和 SetExtent 方法更改滚动位置和滚动范围。使用 SetPosition 和 SetExtent 方法与设置各个 HorizontalExtent、VerticalExtent、HorizontalPosition 和 VerticalPosition 属性相同，但这些方法使您能同时设置多个属性，因而减少重新绘制图形的次数。


ChSegment 对象

ChFormatMap
ChSegments
ChSegment
ChSegmentBoundary

表示格式映射中的一段。格式映射中的每一段可以独立于其他段设置格式。

使用 ChSegment 对象

下列方法或属性返回 ChSegment 对象。

ChSegments 对象的 Add 方法

ChSegments 对象的 Item 属性

使用 ChSegments 对象的 Add 方法新建一段。使用由 Begin 属性返回的 ChSegmentBoundary 对象的属性设置段的开始格式。使用由 End 属性返回的 ChSegmentBoundary 对象的属性设置段的结束格式。

示例

本示例将 Chartspace1 绑定到罗斯文数据库中的 Order Details 表，然后创建两个段。第一段突出显示图表第一个系列的低 10% 数值。第二段突出显示图表第一个系列的高 20% 数值。

Sub Window_Onload()

    Dim serseries1
    Dim segBottom10Pct
    Dim segTop20Pct
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' The following two lines of code bind Chartspace1 to the Order Details table in the
    ' Northwind SQL Server database.

    ChartSpace1.ConnectionString = "Provider=SQLOLEDB.1;persist Security Info=TRUE;" & _
                                   "Integrated Security=SSPI;Initial Catalog=Northwind;Data Source=" & _
                                   "ServerName;"

    ChartSpace1.DataMember = "Order Details"

    ' The following two lines of code bind Chartspace1 to the Quantity and ProductID fields
    ' in the Order details table.
    ChartSpace1.SetData chConstants.chDimCategories, chConstants.chDataBound, "ProductID"
    ChartSpace1.SetData chConstants.chDimValues, chConstants.chDataBound, "Quantity"

    ' Create a format map.
    ChartSpace1.SetData chConstants.chDimFormatValues, chConstants.chDataBound, "Quantity"

    ' Set a variable to the first series in the first chart in Chartspace1.
    Set serseries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a segment to the format map. This segment will
    ' represent the bottom 10% of values in the chart.
    Set segBottom10Pct = serseries1.FormatMap.Segments.Add

    ' Measure the segment boundaries based upon a percentage.

    segBottom10Pct.Begin.ValueType = chConstants.chBoundaryValuePercent
    segBottom10Pct.End.ValueType = chConstants.chBoundaryValuePercent

    ' Set the beginning value to 0%, and the ending value to 10%
    segBottom10Pct.Begin.Value = 0
    segBottom10Pct.End.Value = 0.1

    ' Format the interior of the matching values.
    segBottom10Pct.Begin.Interior.Color = "red"
    segBottom10Pct.End.Interior.Color = "red"

    ' Add a segment to the format map. This segment will
    ' represent the top 20% of values in the chart.

    Set segTop20Pct = serseries1.FormatMap.Segments.Add

    ' Measure the segment boundaries based upon a percentage.
    segTop20Pct.Begin.ValueType = chConstants.chBoundaryValuePercent
    segTop20Pct.End.ValueType = chConstants.chBoundaryValuePercent

    ' Set the beginning value to 80%, and the ending value to 100%.
    segTop20Pct.Begin.Value = 0.8
    segTop20Pct.End.Value = 1

    ' Format the interior of the matching values.
    segTop20Pct.Begin.Interior.Color = "green"
    segTop20Pct.End.Interior.Color = "green"

End Sub


ChSegmentBoundary 对象

ChSegment
ChSegmentBoundary
多个对象

返回 ChSegment 对象的边界。

使用 ChSegmentBoundary 对象

下列属性返回一个 ChSegmentBoundary 对象。

ChSegment 对象的 Begin 属性

ChSegment 对象的 End 属性

使用 Value 属性设置 ChSegmentBoundary 对象的开始和结束值。使用 ValueType 属性指定数值表示百分比还是绝对数值。

使用下列属性返回的对象设置 ChSegmentBoundary 对象格式：Border、Interior 和 Line。


ChSegments 对象

ChFormatMap
ChSegments
多个对象

表示 ChFormatMap 对象的段集合。

使用 ChSegments 对象

ChFormatMap 对象的 Segments 属性可用于返回 ChSegments 对象。

使用 ChSegments 对象的 Add 方法在格式映射中添加段。

使用 ChSegments 对象的 Item 属性返回单个 ChSegment 对象。


ChSeries 对象

多个对象
ChSeries
多个对象

表示图表上的系列。ChSeries 对象为 ChSeriesCollection 集合的成员。

使用 ChSeries 对象

使用 ChSeriesCollection 集合的 Add 方法向图表中添加系列。

下列属性和方法返回 ChSeries 对象：

ChDataLabels 对象的 Parent 属性

ChDataLabelsCollection 对象的 Parent 属性

ChErrorBars 对象的 Parent 属性

ChErrorBarsCollection 对象的 Parent 属性

ChPoint 对象的 Parent 属性

ChPoints 对象的 Parent 属性

ChSeriesCollection 对象的 Add 方法

ChSeriesCollection 对象的 Item 属性

ChTrendline 对象的 Parent 属性

ChTrendlines 对象的 Parent 属性


ChSurface 对象

ChPlotArea
ChSurface
多个对象

表示图表的墙或基底表面。

使用 ChSurface 对象

下列属性可用于返回 ChSurface 对象：

ChChart 对象的 BackWall 属性

ChChart 对象的 SideWall 属性

ChChart 对象的 Floor 属性

可以使用 Border、Interior 和 Thickness 属性设置 ChSurface 对象格式。


ChTitle 对象

多个对象
ChTitle
多个对象

表示图表工作区、坐标轴或图表的标题。

使用 ChTitle 对象

使用 HasTitle 或 HasChartspaceTitle 属性启用标题。

下列属性返回 ChTitle 对象：

ChartSpace 对象的 ChartSpaceTitle 属性

ChAxis 对象的 Title 属性

ChChart 对象的 Title 属性

下面示例为 Chartpsace1 的第一张图表添加标题，并设置新建标题的格式。

Sub AddChartTitle()

    Dim Chart1Title
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Enable the title for the first chart in the
    ' chartspace.
    ChartSpace1.Charts(0).HasTitle = True

    ' Set a variable to the chart title.
    Set Chart1Title = ChartSpace1.Charts(0).Title

    ' Set the caoption for the title.
    Chart1Title.Caption = "2000 Sales by Department"

    ' Set the title to display at the bottom of the chart.
    Chart1Title.Position = chConstants.chTitlePositionBottom

    ' Format the font used for the title.
    Chart1Title.Font.Bold = True
    Chart1Title.Font.Name = "Tahoma"
    Chart1Title.Font.Size = 16

End Sub


ChTrendline 对象

ChSeries
ChTrendlines
ChTrendline
多个对象

表示图表上的趋势线。趋势线显示系列中数据的趋势或方向。ChTrendline 对象为 ChTrendlines 集合的成员。

使用 ChTrendline 对象

使用 ChTrendlines 对象的 Add 方法为系列添加趋势线。

下列方法和属性返回 ChTrendline 对象。

ChTrendlines 集合的 Add 方法

ChTrendlines 集合的 Item 属性

下面示例为 Chartspace1 中第一张图表的第一个系列添加一条趋势线，并设置趋势线格式。

Sub AddPolyTrendline()

    Dim serSeries1
    Dim chConstants
    Dim tlSeries1Trend

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the first series of the first chart
    ' in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a trendline to the first series and return
    ' a Trendline object.
    Set tlSeries1Trend = serSeries1.Trendlines.Add

    ' Display the equation used to calculate the trendline.
    tlSeries1Trend.IsDisplayingEquation = True

    ' Set the trendline to be a polynomial trendline.
    tlSeries1Trend.Type = chConstants.chTrendlineTypePolynomial

End Sub


ChUserDefinedSelection 对象

ChUserDefinedSelection

表示在 BeginObject 和 EndObject 方法调用之间在图表上绘制的对象。

使用 ChUserDefinedSelection 对象

如果选择了自定义图形对象，ChartSpace 对象的 Selection 属性将返回 ChUserDefinedSelection 对象。


Coordinate 对象

Coordinate

存储下次检索的数据点的 X 和 Y 坐标。

使用 Coordinate 对象

使用 ChAxis 或 ChSeries 对象的 ValueToPoint 方法返回 Coordinate 对象。

使用 Coordinate 对象的 x 和 y 属性返回 Coordinate 对象当前存储的数据点的 X 和 Y 坐标。

本示例将 Chartspace1 中第一个图表的标题更改为图表第一个系列中数据点的像素坐标。

Sub GetPixelCoordinates()

    Dim chChart1
    Dim lXPos
    Dim lYPos
    Dim coPointCoordinates

    ' Set a variable to the first chart in Chartspace1.
    Set chChart1 = ChartSpace1.Charts(0)

    ' Enable the title for the chart.
    chChart1.HasTitle = True

    ' Set a Coordinate object to the coordinates of a data point.
    Set coPointCoordinates = chChart1.SeriesCollection(0).ValueToPoint("Pears", 10)

    ' Set a variable to the X-coordinate.
    lXPos = coPointCoordinates.x

    ' Set a variable to the Y-coordinate.
    lYPos = coPointCoordinates.y

    ' Set the chart's titles to the pixel coordinates of the specified
    ' data point.
    chChart1.Title.Caption = "X(" & lXPos & ") Y(" & lYPos & ")"

End Sub


Criteria 对象

Filter
Criteria
Filter

包含整个“自动筛选”条件数组。每个条件为一个 String 类型值。AutoFilter 对象包含一个 Filters 集合，Filters 集合包含筛选区域中每列的 Filter 对象，每个 Filter 对象包含一个 Criteria 对象。

使用 Criteria 对象

Filter 对象的 Criteria 属性返回指定筛选的 Criteria 对象。


DataPage 对象

多个对象
DataPage
多个对象

表示单击展开按钮时数据访问页上显示的组合节。这些节包括对应于单个父记录的记录集中可见记录的标题节、每条记录的组页眉和组页脚及导航节。

DataPage 对象为 DataPages 集合的成员。

使用 DataPage 对象

下列属性返回一个 DataPage 对象：

  • DataPages 对象的 Item 属性

  • Section 对象的 DataPage 属性

  • DSCEventInfo 对象的 DataPage 属性


DataSourceControl 对象

DataSourceControl
多个对象

表示数据源控件。数据源控件为数据模型的顶层。

使用 DataSourceControl 对象

可以使用 CreateObject 方法或 New 关键字创建 DataSourceControl 对象。

HTML 页上数据源控件的对象 ID 返回 DataSourceControl 对象。DataSourceControl 对象的编程标识符为 CLSID:CLSID:0002E55B-0000-0000-C000-000000000046。下面示例在 HTML 页上创建名为“MSODSC”的数据源控件。

<object id=MSODSC classid=CLSID:0002E55B-0000-0000-C000-000000000046></object>


DSCEventInfo 对象

DSCEventInfo
多个对象

包含指定数据源控件事件的信息。

使用 DSCEventInfo 对象

下列数据源控件事件使用 DSCEventInfo 对象作为唯一参数：

  • AfterDelete 事件

  • AfterInsert 事件

  • AfterUpdate 事件

  • BeforeCollapse 事件

  • BeforeDelete 事件

  • BeforeExpand 事件

  • BeforeFirstPage 事件

  • BeforeInitialBind 事件

  • BeforeInsert 事件

  • BeforeLastPage 事件

  • BeforeNextPage 事件

  • BeforeOverwrite 事件

  • BeforePreviousPage 事件

  • BeforeUpdate 事件

  • Current 事件

  • DataError 事件

  • DataPageComplete 事件

  • Dirty 事件

  • Focus 事件

  • RecordExit 事件

  • RecordsetSaveProgress 事件

  • Undo 事件

当事件触发时，可以使用 DSCEventInfo 对象的属性返回有关数据访问页的信息。Section 属性可用于确定数据访问页上发生事件的节。可以使用 ReturnValue 属性取消某些事件的完成。

上面列出的事件所支持的 DSCEventInfo 属性有所不同。某些事件支持 DSCEventInfo 属性的子集，而某些事件不支持任何 DSCEventInfo 属性。使用不支持的属性将导致运行时出错。

如果 Discontinued 字端设置为 No，本示例将取消记录删除。DSCEventInfo 对象的 Section 属性将检索 Discontinued 字段的值。如果该字段包含 No，则 DSCEventInfo 对象的 ReturnValue 将设置为 False，取消记录删除。

Sub MSODSC_BeforeDelete(DSCEventInfo)

   Dim txtDiscontinued

   ' Set a variable to the text box that contains the value
   ' of the Discontinued field for the record that is to be deleted.
   Set txtDiscontinued = DSCEventInfo.Section.HTMLContainer _
                        .Children("Discontinued")

   ' Check the value of the control.
   If txtDiscontinued.Value = "No" Then

      ' Display a message to the user.
      Msgbox "Do not delete products that have not " & _
             "been discontinued."

      Cancel the deletion of the record.
      DSCEventInfo.ReturnValue = False
   End If

End Sub


ElementExtension 对象

多个对象
ElementExtensions
ElementExtension

为 HTML 元素（如文本框和下拉列表框）添加数据相关的属性。元素扩展将记录集和分组定义对象（诸如页面字段）绑定到 HTML 页面上的元素，该页面可以绑定其结果数据。

ElementExtension 对象为 ElementExtensions 集合的成员。

使用 ElementExtension 对象

下列方法和属性返回一个 ElementExtension 对象：

  • ElementExtensions 集合的 Add 方法

  • ElementExtensions 集合的 Item 属性


Filter 对象

多个对象
Filter
多个对象

表示“自动筛选”使用的单个筛选。Filter 对象为 Filters 集合的成员。AutoFilter 对象包含一个 Filters 集合，Filters 集合包含筛选区域中每列的 Filter 对象，每个 Filter 对象包含一个 Criteria 对象。

使用 Filter 对象

Filters 对象的 Item 属性返回一个 Filter 对象。


Font 对象

多个对象
Font

包含对象的字体属性（字体名称、字体大小、颜色等等）。

使用 Font 对象

使用 Font 属性返回 Font 对象。

下面示例将单元格 A1:C5 的格式设置为加粗。

Spreadsheet1.ActiveSheet.Range("A1:A5").Font.Bold = True


GroupingDef 对象

多个对象
GroupingDef
PageFields

表示分组定义。分组定义为一种特殊类型的记录集定义。利用 RecordsetDef 对象，可以在分组层次或元素扩展的 Execute 方法和 RecordSource 属性中使用分组定义的名称。

分组定义定义一个 ADO 分组记录集，该记录集显示为层次中的包含记录集或页面产生的记录集的父层次。在运行时，包含记录集定义的所有数据在分组记录集创建之前提取。

使用 GroupingDef 对象

下列方法和属性返回一个 GroupingDef 对象：

  • GroupingDefs 集合的 Add 方法

  • GroupingDefs 集合的 AddTotal 方法

  • GroupingDefs 或 AllGroupingDefs 集合的 Item 属性


GroupLevel 对象

多个对象
GroupLevel

表示数据访问页层次中指定级别所有记录的集合。GroupLevel 对象为 GroupLevels 集合的成员。

使用 GroupLevel 对象

下列方法和属性返回一个 GroupLevel 对象：

  • GroupLevels 集合的 Add 方法

  • GroupLevels 集合的 Item 属性

  • DataPage 对象的 GroupLevel 属性


Heading 对象

Window
Headings
Heading
Window

表示指定窗口 Headings 集合中的单个行或列标题。

使用 Heading 对象

使用 Headings 集合的 Item 属性返回单个 Heading 对象。可以表示为 Headings(Index) 或 Headings.Item(Index)，其中 Index 为单个 Heading 对象的索引号。

使用 Caption 属性自定义窗口中的行和列标题。下面示例演示如何使用 Caption 属性更改窗口中的行和列标题：

Sub Change_Headings()

    Dim hdrColHeadings
    Dim hdrRowHeadings

    ' Set a variable to the column headings in the active window.
    Set hdrColHeadings = Spreadsheet1.ActiveWindow.ColumnHeadings

    ' Set a variable to the row headings in the active window.
    Set hdrRowHeadings = Spreadsheet1.ActiveWindow.RowHeadings

    ' Set the headings of columns A through D.
    hdrColHeadings(1).Caption = "Qtr 1"
    hdrColHeadings(2).Caption = "Qtr 2"
    hdrColHeadings(3).Caption = "Qtr 3"
    hdrColHeadings(4).Caption = "Qtr 4"

    ' Set the headings of rows 1 though 5.
    hdrRowHeadings(1).Caption = "Sedan"
    hdrRowHeadings(2).Caption = "Convertible"
    hdrRowHeadings(3).Caption = "Truck"
    hdrRowHeadings(4).Caption = "Sport-Utility"
    hdrRowHeadings(5).Caption = "Minivan"

End Sub

The Caption 属性 of the Heading 对象 is limited to 256 characters, and the text cannot be wrapped to a second line.

Use the ResetHeadings 方法 to set the row and column headings back to their default values.


Hyperlink 对象

Range
Hyperlink
Range

表示一个超链接。

使用 Hyperlink 对象

Range 对象的 Hyperlink 属性返回一个 Hyperlink 对象。


Interior 对象

多个对象
Interior

表示一个对象的内部。

使用 Interior 对象

下列属性返回一个 Interior 对象：

  • Range 对象的 Interior 属性

  • TitleBar 对象的 Interior 属性


ListObject 对象

多个对象
ListObject
多个对象

使用 ListObject 对象

ListObject 对象表示工作表中的 XML 列表。ListObject 对象为 ListObjects 集合的成员。对 ListObjects 集合中的各 ListObject 对象编制的索引是从 1 开始，1 表示第一个对象，2 表示第二个对象，依此类推。可使用 Item 属性从 ListObjects 集合中返回单个 ListObject 对象。Item 属性的参数为 ListObjects 集合中 ListObject 对象的名称或索引号。名称为 XML 电子表格文件中 Entry 元素 (MapInfo/Map/Entry) 的 ID 属性值。在 XML 电子表格文件中显示这些详细信息的 XML 段落类似于：

<x2:MapInfo xmlns:x2="http://schemas.microsoft.com/office/excel/2003/xml">
   <x2:Map x2:ID="Cust_MapId">
      <x2:Entry x2:ID="example_id" x2:Type="table">
         ...
      </x2:Entry>
   </x2:Map>
</x2:MapInfo>

也可使用 ListObject 对象的 Name 属性获得名称。可使用 Microsoft Excel 创建 XML 电子表格文件，方法是：先创建数据绑定的电子表格，然后再将该工作簿另存为 XML 电子表格。

本示例设置电子表格组件中指定列表区域的边框线宽。

Sub SetListBorder()
    Dim ssConstants
    Dim rngList

    Set ssConstants = Spreadsheet1.Constants

    ' Set a variable to the range that contains the list.
    Set rngList = Spreadsheet1.ActiveSheet.ListObjects(1).Range

    ' Set the range border weight.
    rngList.Borders.Weight = ssConstants.owcLineWeightMedium
End Sub


ListRow 对象

ListObject
ListRows
ListRow
多个对象

使用 ListRow 对象

ListRow 对象表示电子表格组件的 ListObject 对象中的行。ListRow 对象为 ListRows 集合的成员。ListRows 集合包含 ListObject 对象中的所有行。ListRow 对象没有默认属性。

对 ListRows 集合中的 ListRow 对象编制的索引是从 1 开始，1 表示第一个对象，2 表示第二个对象，依此类推。可使用 Item 属性从 ListRows 集合中返回单个 ListRow 对象。Item 属性的参数为 ListRows 集合中 ListRow 对象的索引号。

可使用 Delete 方法删除列表中一行的单元格。删除该行将使位于删除行下方的其他单元格上移。ListRow 对象的读/写 Active 属性允许查找是否已选中行，或选择行。可使用 Range 属性返回表示指定的列表行应用的区域的 Range 对象。

可使用 Index 属性查找 ListRows 集合中 ListRow 对象的当前序号位置。Application 和 Parent 属性返回指定的 ListRows 对象的电子表格组件和父对象（即 ListObject 对象）。


Name 对象

多个对象
Names
Name
Range

表示单元格区域、公式或常量的定义名称。Name 对象为 Names 集合的成员。

使用 Name 对象

使用 Names(index) 返回单个 Name 对象，其中 index 为名称、索引号或定义名称。

索引号表示名称在集合中的位置。本示例显示应用程序集合中第一个名称的单元格引用。

MsgBox Names(1).RefersTo

本示例从活动工作簿中删除名称 "mySortRange"。

ActiveWorkbook.Names("mySortRange").Delete

使用 Name 属性返回或设置名称本身的文本。本示例更改活动工作簿中第一个 Name 对象的名称。

Names(1).Name = "stock_values"

使用 Add 方法创建名称并添加到集合中。本示例新建引用工作表 "Sheet1" 上单元格 A1:C20 的名称。

Spreadsheet1.Names.Add "CurrentMonth", "=Sheet1!$A$1:$C$20"

RefersTo 参数必须以 A1-样式符指定，包括相应的美圆符号 ($)。例如，如果选定了 Sheet1 上的单元格 A10，并使用 RefersTo 参数定义了名称 "=Sheet1!A1:B1"，新名称实际上引用单元格 A10:B10（因为指定了相对引用）要指定绝对引用，请使用 "=Sheet1!$A$1:$B$1"。


OCCommand 对象

多个对象
OCCommands
OCCommand

表示指定 Microsoft Office Web Component 中的单个命令。

使用 OCCommand 对象

使用 OCCommands 集合的 Item 属性返回单个 OCCommand 对象。

OCCommandId、ChartCommandIdEnum、PivotCommandId 和 SpreadsheetCommandId 常量中包含每个 Microsoft Office Web Component 支持的命令列表。

使用 OCCommand 对象的 Execute 方法执行特定命令。本示例使用 Execute 方法选定 Spreadsheet1 中活动工作表中的左上角单元格。

Sub SelectUpperLeft()

    Dim ssConstants

    Set ssConstants = Spreadsheet1.Constants

    ' Select the upper-left cell in the active worksheet.
    Spreadsheet1.Commands(ssConstants.ssCommandMoveToOrigin).Execute

End Sub

使用 CommandBeforeExecute 事件在执行命令之前加以指定限制，或取消命令。本示例在调用 Export 命令时刷新 PivotTable1 以便将最新数据导出到 Microsoft Excel。

Sub PivotTable1_CommandBeforeExecute(Command, Cancel)

   Dim ptConstants

   Set ptConstants = PivotTable1.Constants

   ' Check to see if the Export command
   ' has been invoked.
   If Command = ptConstants.plCommandExport Then

       ' Refresh the PivotTable list.
       PivotTable1.Refresh

   End If

End Sub

本示例防止用户将 Spreadsheet1 中的内容剪切、复制或导出到 Microsoft Excel。

Sub Spreadsheet1_CommandBeforeExecute(Command, Cancel)

    Dim ssConstants

    Set ssConstants = Spreadsheet1.Constants

    Select Case Command

        ' Check to see if the Export command has
        ' been invoked.
        Case ssConstants.ssCommandExport

            ' Cancel the command.
            Cancel.Value = True

            ' Display a message to the user.
            MsgBox "Export of the data is prohibited."

        ' Check to see if the Cut or Copy commands
        ' have been invoked.
        Case ssConstants.ssCommandCopy, ssConstants.ssCommandCut

            ' Cancel the command.
            Cancel.Value = True

            ' Display a message to the user.
            MsgBox "Cutting or Copying the data is prohibited."
    End Select

End Sub

如果要在执行指定命令时执行一系列命令，请使用 CommandExecute 事件。本示例在每次刷新 PivotTable1 时将当前日期和时间写入 HTML 文本框控件。

Sub PivotTable1_CommandExecute(Command)

   Dim ptConstants

   Set ptConstants = PivotTable1.Constants

   ' Check to see if the PivotTable list has been refreshed.
   If Command = ptConstants.plCommandRefresh Then

      ' Write the current data and time to the text box.
      TextBox.Value = "PivotTable last refeshed on " & _
                      Date & " at " & Time

   End If

End Sub


隐藏语言元素

您请求了隐藏的语言元素的帮助，因此程序不能访问。


OWCLanguageSettings 对象

多个对象
OWCLanguageSettings

返回有关 Microsoft Office Web Components 的语言设置信息。

使用 OWCLanguageSettings 对象

使用 Application.LanguageSettings.LanguageID(MsoAppLanguageID)，其中 MsoAppLanguageID 为下列返回指定应用程序地区标识符 (LCID) 信息的常量之一：msoLanguageIDHelp、msoLanguageIDInstall、msoLanguageIDUI 或 msoLanguageIDUIPrevious。本示例以消息框返回名为 Spreadsheet1 的电子表格控件的安装语言、用户界面语言和帮助语言的地区标识符。

MsgBox "The following locale IDs are registered " & _
    "for this application: Install Language - " & _
    Spreadsheet1.LanguageSettings.LanguageID(msoLanguageIDInstall) & _
    " User Interface Language - " & _

Spreadsheet1.LanguageSettings.LanguageID(msoLanguageIDUI) & _
    " Help Language - " & _

Spreadsheet1.LanguageSettings.LanguageID(msoLanguageIDHelp)

本示例测试美国英语是否注册为首选编辑语言。

If Spreadsheet1.LanguageSettings. _
    LanguagePreferredForEditing(msoLanguageIDEnglishUS) Then
    MsgBox "U.S. English is one of the chosen editing languages."
End If


PageField 对象

多个对象
PageField
多个对象

表示记录集或分组定义中的字段。数据访问页上的控件使用页字段名称绑定到记录集数据。

PageField 对象有三种类型：

  • 输出类型。该类型直接来自方案行来源中的方案字段。对于表类型或视图类型的方案行来源，这意味着字段在数据模型生成的 SQL 语句的 SELECT 列表中列出。对于文本类型或存储过程类型的方案行来源，所有方案字段的显示均与输出的结果相同，并且页字段名称必须与方案字段名称相同。
  • 计算类型。这是一种添加到记录集中的本地计算列。该类型支持 Visual Basic for Applications 表达式语法。表达式可以引用同一记录集定义或分组定义中的 dscOutput 或 dscGrouping 类型的页字段。表达式还可以通过文档对象模型引用 HTML 元素（例如，=Quantity*UnitPrice*Document.All("Text0").Value）。每当保存更新记录、刷新页面或调用记录集的 Resync 方法后，计算字段将重新计算。
  • 分组类型。该类型为附属于 GroupingDef 或 RecordsetDef 对象的分组字段或合计字段。

PageField 对象可以为 AllPageFields、GroupingFields、OutputFields 或 PageFields 集合的成员。

使用 PageField 对象

下列属性和方法返回一个 PageField 对象：

  • AllPageFields 集合的 Item 属性

  • PageFields 集合的 Add 方法

  • PageFields 集合的 Item 属性

  • PageRelatedField 对象的 ManySide 属性

  • PageRelatedField 对象的 OneSide 属性


PageRelatedField 对象

PageRelationship
PageRelatedFields
PageRelatedField
PageField

表示组成页面关系的列对的页面实例。这些字段名称用于生成 SQL 中的连接子句，以及将父记录集定义与子记录集定义相关联。

PageRelatedField 对象为 PageRelatedFields 集合的成员。

使用 PageRelatedField 对象

PageRelatedFields 集合的 Item 属性返回一个 PageRelatedField 对象。


PageRelationship 对象

多个对象
PageRelationship
多个对象

PageRelationship 对象将两个页面行来源联系在一起，可以在一个记录集定义中（一个 LookupRelationships 集合），也可以在不同的记录集定义间（一个 SublistRelationships 集合）。页面关系根据 SchemaRelationship 对象中的信息创建。

PageRelationship 对象为 LookupRelationships 或 SublistRelationships 集合的成员。

使用 PageRelationship 对象

下列方法和属性返回一个 PageRelationship 对象：

  • LookupRelationships 集合的 Add 方法

  • LookupRelationships 集合的 Item 属性

  • SublistRelationships 集合的 Add 方法

  • SublistRelationships 集合的 Item 属性


PageRowsource 对象

多个对象
PageRowsource
多个对象

PageRowsource 对象指当前用于数据访问页的 SchemaRowsource 对象实例。在作为页面行来源进行添加之前，在数据模型中必须有作为方案行来源的表、视图或存储过程；然后页面行来源再用作页面的数据源。

PageRowsource 对象为 PageRowsources 集合的成员。

使用 PageRowsource 对象

下列属性返回一个 PageRowsource 对象：

  • PageField 对象的 PageRowsource 属性

  • PageRelationship 对象的 ManySide 属性

  • PageRelationship 对象的 OneSide 属性

  • PageRowsources 集合的 Item 属性

  • RecordsetDef 对象的 PrimaryPageRowsource 属性


Pane 对象

多个对象
Pane
多个对象

表示窗口中的窗格。Pane 对象为 Panes 集合和 Window 对象共同的成员。

使用 Pane 对象

下列属性返回一个 Pane 对象：

  • Panes 集合的 Item 属性

  • Window 对象的 ActivePane 属性


ParameterValue 对象

RecordsetDef
ParameterValues
ParameterValue

表示一个输入参数值表达式。该表达式在执行时计算，为 dscProcedure 或 dscCommandText 类型的行来源提供运行时参数。

使用 ParameterValue 对象

下列方法和属性返回一个 ParameterValue 对象：

  • ParameterValues 集合的 Add 方法

  • ParameterValues 集合的 Item 属性


PivotAggregate 对象

PivotCell
PivotAggregates
PivotAggregate
多个对象

表示与数据透视表列表中总计相关的数据。总计定义用户要查看的内容，但是总计的结果数据称作聚合或聚合值。PivotAggregate 对象为 PivotAggregates 集合的成员。

使用 PivotAggregate 对象

PivotAggregates 集合的 Item 属性返回一个 PivotAggregate 对象。


PivotAxis 对象

多个对象
PivotAxis
多个对象

作为 PivotResultAxis、PivotResultColumnAxis、PivotResultDataAxis、PivotResultFilterAxis、PivotResultGroupAxis、PivotResultPageAxis 和 PivotResultRowAxis 对象的基类。使用这些对象之一的 SourceAxis 属性返回一个 PivotAxis 对象。


PivotAxisMember 对象

多个对象
PivotAxisMember
多个对象

表示分组字段的显示值。PivotAxisMember 对象为 PivotAxisMembers 集合的成员。

使用 PivotAxisMember 对象

下列属性返回一个 PivotAxisMember 对象：

PivotAxisMember、PivotColumnMember、PivotPageMember 和 PivotRowMember 对象的 FindAxisMember 属性

PivotAxisMember、PivotColumnMember、PivotPageMember 和 PivotRowMember 对象的 ParentAxisMember 属性

PivotAxisMember、PivotColumnMember、PivotPageMember 和 PivotRowMember 对象的 TotalMember 属性

PivotResultColumnAxis、PivotResultGroupAxisPivotResultPageAxis 和 PivotResultRowAxis 对象的 Member 属性

PivotAxisMembers 集合的 Item 属性。

PivotAxisMember 与 PivotMember 对象具有许多共同属性，但是 PivotAxisMember 对象包含一些 PivotMember 对象没有的属性。使用 GroupField 和 CustomGroupType 属性访问成员的分组设置。可以使用 Hyperlink 属性访问成员的超链接设置。MemberProperties 属性可用于访问成员的任何成员属性。Height、Left 和 Width 属性可用于设置成员的大小和位置。


PivotCell 对象

多个对象
PivotCell
多个对象

表示数据透视表列表中的单元格（数据分组）。单元格显示聚合，如果底层有可用的明细记录，可以使单元格显示明细网格。行列坐标轴上的分组字段决定指定单元格表示的数据量。甚至一个没有分组字段的简单列表也的确是一个显示明细网格的单个单元格。

使用 PivotCell 对象

下列属性返回一个 PivotCell 对象：

  • PivotAggregate、PivotDetailCell 和 PivotDetailRange 对象的 Cell 属性

  • PivotData 对象的 Cells、CellsEx 和 CurrentCell 属性

  • PivotRange 对象的 BottomRight、Cells 和 TopLeft 属性


PivotColumnMember 对象

多个对象
PivotColumnMember
多个对象

表示数据透视表列表列区域中分组字段的显示值。PivotColumnMember 对象为 PivotColumnMembers 集合的成员。

使用 PivotColumnMember 对象

下列属性返回一个 PivotColumnMember 对象：

PivotCell 对象的 ColumnMember 属性

PivotResultColumnAxis 对象的 ColumnMember 属性

PivotColumnMember 对象的 FindColumnMember 属性

PivotColumnMember 对象的 ParentColumnMember 属性

PivotColumnMember 对象的 TotalColumnMember 属性

PivotColumnMembers 集合的 Item 属性

PivotData 对象的 Left 属性

PivotColumnMember 对象与 PivotAxisMember 对象具有许多共同属性。使用 DetailLeft、DetailLeftOffset、DetailsExpanded 属性或 MoveDetailLeft 方法自定义明细记录的显示方式。


PivotData 对象

多个对象
PivotData
多个对象

表示数据透视表列表中的数据。

使用 PivotData 对象

下列属性返回一个 PivotData 对象：

  • 下列对象的 Data 属性：PivotCell、PivotResultAxis、PivotResultColumnAxis、PivotResultDataAxis、PivotResultFilterAxis、PivotResultGroupAxis、PivotResultPageAxis 和 PivotResultRowAxis。

  • PivotTable 对象的 ActiveData 属性。


PivotDataAxis 对象

多个对象
PivotDataAxis
多个对象

表示数据透视表的数值轴。数值轴包含字段集和总计。

使用 PivotDataAxis 对象

下列属性返回一个 PivotDataAxis 对象：

  • PivotView 对象的 DataAxis 属性

  • PivotResultDataAxis 对象 SourceDataAxis 属性


PivotDetailCell 对象

多个对象
PivotDetailCell
多个对象

表示数据透视表列表明细网格中的单元格。

使用 PivotDetailCell 对象

下列属性返回一个 PivotDetailCell 对象：

  • PivotCell 对象的 DetailCells 属性

  • PivotDetailRange 对象的 BottomRight 属性

  • PivotDetailRange 对象的 TopLeft 属性


PivotDetailRange 对象

PivotCell
PivotDetailRange
多个对象

表示数据透视表列表明细网格中的单元格区域。

使用 PivotDetailRange 对象

PivotCell 对象的 DetailRange 属性返回一个 PivotDetailRange 对象。


PivotField 对象

多个对象
PivotField
多个对象

表示数据透视表列表中的单个字段。

使用 PivotField 对象

下列属性和方法返回 PivotField 对象：

  • 下列对象的 Field 属性：PivotAxisMember、PivotColumnMember、PivotDetailCell、PivotMember、PivotPageMember、PivotRowMember 和 PivotTotal。

  • PivotField 对象的 FilterContext 属性。

  • PivotFields 对象的 Item 属性。

  • PivotFieldSet 对象的 AddCalculatedField 和 AddCustomGroupField 方法，以及 BoundField 属性。

  • PivotResultField 和 PivotResultGroupField 对象的 SourceField 属性。


PivotFieldSet 对象

多个对象
PivotFieldSet
多个对象

表示锁定在一起组成层次结构的字段集。例如，在地理字段集中，按次序可能包括“洲”、“国家/地区”、“州”和“城市”字段。典型情况下，如果数据源为记录集，则字段集将只包含单个字段。

使用 PivotFieldSet 对象

下面属性和方法返回一个 PivotFieldSet 对象：

  • PivotField 对象的 FieldSet 属性。

  • PivotFieldSets 对象的 Item 属性。

  • PivotView 对象的 AddFieldSet 方法。


PivotFilterAxis 对象

多个对象
PivotFilterAxis
多个对象

表示数据透视表列表中的筛选坐标轴。

使用 PivotFilterAxis 对象

下列属性返回一个 PivotFilterAxis 对象：

  • PivotView 对象的 FilterAxis 属性

  • PivotResultFilterAxis 对象的 SourceFilterAxis 属性


PivotFont 对象

多个对象
PivotFont

包含指定对象的字体属性（字体名称、字体大小、颜色等）。

使用 PivotFont 对象

下列属性返回一个 PivotFont 对象：

  • PivotField 对象的 DetailFont、GroupedFont 和 SubtotalFont 属性

  • PivotLabel 对象的 Font 属性

  • PivotView 对象的 FieldLabelFont、HeaderFont、PropertyCaptionFont、PropertyValueFont 和 TotalFont 属性


PivotGroupAxis 对象

多个对象
PivotGroupAxis
多个对象

表示数据透视表列表中的分组坐标轴。

使用 PivotGroupAxis 对象

下列属性返回一个 PivotGroupAxis 对象：

  • PivotResultColumnAxis 对象的 SourceColumnAxis 属性

  • PivotResultPageAxis 对象的 SourcePageAxis 属性

  • PivotResultRowAxis 对象的 SourceRowAxis 属性

  • PivotView 对象的 ColumnAxis、PageAxis 和 RowAxis 属性


PivotHyperlink 对象

多个对象
PivotHyperlink

表示数据透视表列表中的超链接。

使用 PivotHyperlink 对象

使用 PivotDetailCell、PivotAxisMember、PivotColumnMember、PivotRowMember 或 PivotPageMember 对象的 Hyperlink 属性返回 PivotHyperlink 对象。

如果字段的 IsHyperlink 属性设置为 True，PivotTable 控件将字段成员作为超链接处理。

使用 Address 属性可返回 PivotHyperlink 对象的地址。PivotHyperlink 对象的 Address 属性为只读。您必须更新数据库本身才能更改数据透视表列表中超链接的地址。使用 Follow 方法可解析、下载和显示目标文档。


PivotLabel 对象

多个对象
PivotLabel
PivotFont

表示指定对象的标签。包含格式属性（前景色、背景色、字体等）。

使用 PivotLabel 对象

下列属性返回一个 PivotLabel 对象：

  • PivotAxis 对象的 Label 属性

  • PivotDataAxis 对象的 Label 属性

  • PivotFilterAxis 对象的 Label 属性

  • PivotGroupAxis 对象的 Label 属性

  • PivotResultLabel 对象的 SourceLabel 属性

  • PivotView 对象的 Label 属性

  • PivotView 对象的 TitleBar 属性


PivotMember 对象

多个对象
PivotMember
多个对象

表示分组字段的显示值。

使用 PivotMember 对象

下列属性和方法返回一个 PivotMember 对象：

  • 下列对象的 FindMember 属性：PivotAxisMember、PivotColumnMember、PivotFieldSet、PivotPageMember 或 PivotRowMember

  • 下列对象的 ParentMember 属性：PivotAxisMember、PivotColumnMember、PivotMember、PivotPageMember 或 PivotRowMember

  • 下列对象的 SourceMember 属性：PivotAxisMember、PivotColumnMember、PivotPageMember 或 PivotRowMember

  • PivotField 对象的 AddCustomGroupMember 方法

  • PivotFieldSet 对象的 AllMember 或 Member 属性

  • PivotMembers 对象的 Item 属性


PivotMemberProperty 对象

多个对象
PivotMemberProperty

表示数据透视表成员的成员属性。成员属性为 OLAP 多维数据集成员定义的自定义属性。

使用 PivotMemberProperty 对象

下列属性返回一个 PivotMemberProperty 对象：

PivotMemberProperties 集合的 Item 属性

PivotResultMemberProperty 对象的 MemberProperty 属性

使用 DisplayIn 属性控制指定成员属性是否在数据透视表列表、屏幕提示、数据透视表列表且屏幕提示中显示，或不显示。使用 Caption 属性设置成员属性的标题。

本示例设置并显示 Store Name 字段的成员标题。

Sub DisplayMemberProperties()

    Dim ptView
    Dim ptConstants
    Dim fldStoreName

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable.
    Set ptView = PivotTable1.ActiveView

    ' Set a variable to the Store Name field.
    Set fldStoreName = ptView.FieldSets("Store").Fields("Store Name")

    ' The following three lines of code specify that the member properties are
    ' displayed in the PivotTable list.
    fldStoreName.MemberProperties("Store Manager").DisplayIn = ptConstants.plDisplayPropertyInReport
    fldStoreName.MemberProperties("Store Type").DisplayIn = ptConstants.plDisplayPropertyInReport
    fldStoreName.MemberProperties("Store Sqft").DisplayIn = ptConstants.plDisplayPropertyInReport

    ' The following three lines of code set the caption for the member properties.
    fldStoreName.MemberProperties("Store Manager").Caption = "Manager Name"
    fldStoreName.MemberProperties("Store Type").Caption = "Store Type"
    fldStoreName.MemberProperties("Store Sqft").Caption = "Size in SQFT"

End Sub


PivotPageMember 对象

多个对象
PivotPageMember
多个对象

表示数据透视表列表页面区域中分组字段的显示值。PivotPageMember 对象为 PivotPageMembers 集合的成员。

使用 PivotPageMember 对象

下列属性返回一个 PivotRowMember 对象：

PivotCell 对象的 PageMember 属性

PivotResultPageAxis 对象的 PageMember 属性

PivotPageMember 对象的 FindPageMember 属性

PivotPageMember 对象的 ParentPageMember 属性

PivotPageMember 对象的 TotalPageMember 属性

PivotPageMember 集合的 Item 属性

PivotPageMember 对象与 PivotAxisMember 对象具有许多共同属性。


PivotRange 对象

PivotData
PivotRange
多个对象

表示数据透视表列表中的单元格区域。

使用 PivotRange 对象

PivotData 对象的 Range 属性返回一个 PivotRange 对象。


PivotResultAxis 对象

多个对象
PivotResultAxis
多个对象

包含指向数据透视表列表中结果坐标轴数据的指针。

使用 PivotResultAxis 对象

下列属性返回一个 PivotResultAxis 对象：

PivotResultField 对象的 Axis 属性。

PivotResultGroupField 对象的 Axis 属性。

使用 Data 属性引用数据。使用 SourceAxis 属性引用来源坐标轴。


PivotResultColumnAxis 对象

PivotData
PivotResultColumnAxis
多个对象

表示数据透视表列表中列坐标轴的数据。

使用 PivotResultColumnAxis 对象

PivotData 对象的 ColumnAxis 属性返回 PivotResultColumnAxis 对象。

使用 Data 属性返回数据指针。

使用 SourceColumnAxis 属性返回坐标轴指针。


PivotResultDataAxis 对象

PivotData
PivotResultDataAxis
多个对象

表示数据透视表列表的数值坐标轴。

使用 PivotResultDataAxis 对象

PivotData 对象的 DataAxis 属性返回 PivotResultDataAxis 对象。

使用 Data 属性返回数据指针。

使用 SourceDataAxis 属性返回坐标轴指针。


PivotResultField 对象

PivotResultField
多个对象

指向结果字段的来源字段和坐标轴。

使用 PivotResultField 对象

使用 Axis 属性所返回对象的 SourceAxis 属性引用结果字段的来源坐标轴。

使用 SourceField 属性引用结果字段的来源字段。


PivotResultFilterAxis 对象

PivotData
PivotResultFilterAxis
多个对象

表示数据透视表列表中筛选坐标轴的数据。

使用 PivotResultFilterAxis 对象

PivotData 对象的 FilterAxis 属性返回 PivotResultFilterAxis 对象。

使用 Data 属性返回数据指针。

使用 SourceFilterAxis 属性返回坐标轴指针。


PivotResultGroupAxis 对象

多个对象
PivotResultGroupAxis
多个对象

表示数据透视表列表中分组坐标轴的数据。

使用 PivotResultGroupAxis 对象

下列属性返回一个 PivotResultGroupAxis 对象：

ChCategoryLabels 对象的 PivotAxis 属性

ChSeriesCollection 对象的 PivotAxis 属性

PivotAxisMember 对象的 Axis 属性

PivotColumnMember 对象的 Axis 属性

PivotRowMember 对象的 Axis 属性

PivotPageMember 对象的 Axis 属性

使用 Data 属性返回数据指针。

使用 SourceAxis 属性返回坐标轴指针。


PivotResultGroupField 对象

多个对象
PivotResultGroupField
多个对象

表示结果成员的分组字段。

使用 PivotResultGroupField 对象

下列属性返回一个 PivotResultGroupField 对象：

PivotResultGroupFields 集合的 Item 属性。

PivotAxisMember 对象的 GroupField 属性。

PivotColumnMember 对象的 GroupField 属性。

PivotPageMember 对象的 GroupField 属性。

PivotRowMember 对象的 GroupField 属性。

使用 Axis 属性返回的 PivotResultAxis 对象配置来源坐标轴。

使用 SourceField 属性返回的 PivotField 对象配置来源字段。


PivotResultLabel 对象

多个对象
PivotResultLabel
PivotLabel

表示结果坐标轴的标志。

使用 PivotResultLabel 对象

下列属性返回一个 PivotResultLabel 对象：

PivotData 对象的 Label 属性

PivotResultAxis 对象的 Label 属性

PivotResultColumnAxis 对象的 Label 属性

PivotResultDataAxis 对象的 Label 属性

PivotResultFilterAxis 对象的 Label 属性

PivotResultGroupAxis 对象的 Label 属性

PivotResultPageAxis 对象的 Label 属性

PivotResultRowAxis 对象的 Label 属性

使用 SourceLabel 属性返回的 PivotLabel 对象设置结果标志格式。


PivotResultMemberProperty 对象

多个对象
PivotResultMemberProperties
PivotResultMemberProperty
PivotMemberProperty

表示结果成员的成员属性。

使用 PivotResultMemberProperty 对象

PivotResultMemberProperties 集合的 Item 属性返回 PivotResultMemberProperty 对象。

使用 MemberProperty 属性返回的 PivotMemberProperty 对象访问成员属性的设置。


PivotResultPageAxis 对象

PivotData
PivotResultPageAxis
多个对象

表示数据透视表列表中页坐标轴的数据。

使用 PivotResultPageAxis 对象

PivotData 对象的 PageAxis 属性返回 PivotResultPageAxis 对象。

使用 Data 属性返回数据指针。

使用 SourcePageAxis 属性返回坐标轴指针。


PivotResultRowAxis 对象

PivotData
PivotResultRowAxis
多个对象

表示数据透视表列表中行坐标轴的数据。

使用 PivotResultRowAxis 对象

PivotData 对象的 RowAxis 属性返回 PivotResultRowAxis 对象。

使用 Data 属性返回数据指针。

使用 SourceRowAxis 属性返回坐标轴指针。


PivotRowMember 对象

多个对象
PivotRowMember
多个对象

表示数据透视表列表行区域中分组字段的显示值。PivotRowMember 对象为 PivotRowMembers 集合的成员。

使用 PivotRowMember 对象

下列属性返回一个 PivotRowMember 对象：

PivotCell 对象的 RowMember 属性。

PivotResultRowAxis 对象的 RowMember 属性。

PivotRowMember 对象的 FindRowMember 属性。

PivotRowMember 对象的 ParentRowMember 属性。

PivotRowMember 对象的 TotalRowMember 属性。

PivotRowMember 集合的 Item 属性。

PivotData 对象的 Top 属性。

PivotRowMember 对象与 PivotAxisMember 对象具有许多共同属性。使用 TotalRowHeight 和 TotalRowMember 属性自定义总计的显示方式。


PivotTable 对象

PivotTable
多个对象

表示数据透视表列表的容器。

使用 PivotTable 对象

可以使用 CreateObject 方法或 New 关键字创建 PivotTable 对象。

HTML 页上的数据透视表列表控件 ID 返回一个 PivotTable 对象。PivotTable 对象的编程标识符为 CLSID:0002E55A-0000-0000-C000-000000000046。下面示例在 HTML 页上创建名为“PivotTable1”的数据透视表列表。

<object id=PivotTable1 classid=CLSID:0002E55A-0000-0000-C000-000000000046></object>


PivotTotal 对象

多个对象
PivotTotal
多个对象

表示数据透视表列表中的总计。总计是为指定单元格内容显示的聚合值。

使用 PivotTotal 对象

下列属性和方法返回一个 PivotTotal 对象：

  • PivotAggregate 对象的 Total 属性

  • PivotField 对象的 FilterOn 和 SortOn 属性

  • PivotTotals 对象的 Item 属性

  • PivotView 对象的 AddCalculatedTotal 和 AddTotal 方法


PivotView 对象

多个对象
PivotView
多个对象

表示数据透视表列表的指定视图。

使用 PivotView 对象

  • 下列对象的 View 属性返回一个 PivotView 对象：PivotAxis、PivotAxisMember、PivotColumnMember、PivotData、PivotDataAxis、PivotFieldSet、PivotFilterAxis、PivotGroupAxis、PivotMember、PivotPageMember、PivotRowMember 和 PivotTotal。

  • PivotTable 对象的 ActiveView 属性也返回一个 PivotView 对象。


Protection 对象

Worksheet
Protection
Worksheet

包含工作表的保护属性。

使用 Protection 对象

Worksheet 对象的 Protection 属性返回一个 Protection 对象。


Range 对象

多个对象
Range
多个对象

表示单元格、单元格区域、行或列。

使用 Range 对象

下列属性和方法返回一个 Range 对象。

对象 | 属性/方法
AutoFilter | Range
ListObject | DataBodyRange
 | HeaderRowRange
 | InsertRowRange
 | Range
ListRow | Range
Name | RefersToRange
Pane | VisibleRange
Range | Cells
 | Columns
 | CurrentArray
 | CurrentRegion
 | End
 | EntireColumn
 | EntireRow
 | Find
 | FindNext
 | FindPrevious
 | Item
 | MergeArea
 | Next
 | Offset
 | Previous
 | Range
 | Rows
Spreadsheet | ActiveCell
 | Cells
 | Columns
 | Range
 | RectIntersect
 | RectUnion
 | Rows
 | Selection
Window | ActiveCell
 | RangeFromPoint
 | RangeSelection
 | Selection
 | VisibleRange
Worksheet | Cells
 | Columns
 | Range
 | Rows
 | UsedRange


RecordNavigationControl 对象

RecordNavigationControl

表示记录导航控件。

使用 RecordNavigationControl 对象

可以使用 CreateObject 方法或 New 关键字创建 RecordNavigationControl 对象。

HTML 页上记录导航控件的对象 ID 返回一个 RecordNavigationControl 对象。RecordNavigationControl 对象的编程标识符为 CLSID:0002E55C-0000-0000-C000-000000000046。下面示例在 HTML 页上创建名称为“RNC1”的记录导航控件。

<object id=RNC1 classid=CLSID:0002E55C-0000-0000-C000-000000000046></object>


RecordsetDef 对象

多个对象
RecordsetDef
多个对象

表示记录集定义。

使用 RecordsetDef 对象

下列属性返回一个 RecordsetDef 对象：

  • PageField 对象的 RecordsetDef 属性

  • PageRowsource 对象的 RecordsetDef 属性

  • RecordsetDef 对象的 ParentRecordsetDef 属性

  • RecordsetDefs 对象的 Item 属性及其 Add 和 AddNew 方法


SchemaField 对象

SchemaRowsource
SchemaFields
SchemaField
SchemaProperties

表示方案行来源中的字段。这些字段的名称用于生成 dscTable 或 dscView 类型行来源的 SELECT 语句。SchemaField 对象为 SchemaFields 集合的成员。

使用 SchemaField 对象

下列方法和属性返回一个 SchemaField 对象：

  • SchemaFields 集合的 Add 方法

  • SchemaFields 集合的 Item 属性


SchemaParameter 对象

SchemaRowsource
SchemaParameters
SchemaParameter
SchemaProperties

表示方案行来源的单个参数。SchemaParameter 对象为 SchemaParameters 集合的成员。

使用 SchemaParameter 对象

下列方法和属性返回一个 SchemaParameter 对象：

  • SchemaParameters 集合的 Add 方法

  • SchemaParameters 集合的 Item 属性


SchemaProperties 对象

多个对象
SchemaProperties
SchemaProperty

此对象没有说明文档。


SchemaProperty 对象

多个对象
SchemaProperties
SchemaProperty

此对象没有说明文档。


SchemaRelatedField 对象

SchemaRelationship
SchemaRelatedFields
SchemaRelatedField

描述组成方案关系的列对。这些字段的名称用于产生 SQL 中的连接子句，以及将父记录集定义与子列表的子记录集定义相关联。SchemaRelatedField 对象为 SchemaRelatedFields 集合的成员。

使用 SchemaRelatedField

下列方法和属性返回一个 SchemaRelatedField 对象：

  • SchemaRelatedFields 集合的 Add 方法

  • SchemaRelatedFields 集合的 Item 属性


SchemaRelatedFields 集合对象

SchemaRelationship
SchemaRelatedFields
SchemaRelatedField

方案关系的 SchemaRelatedField 对象集合。

使用 SchemaRelatedFields 集合

SchemaRelationship 对象的 SchemaRelatedFields 属性返回一个 SchemaRelatedFields 集合。


SchemaRelationship 对象

多个对象
SchemaRelationship
SchemaRelatedFields

表示方案关系。方案关系说明方案行来源的连接方式，并且通常具有一个“一”侧和一个“多”侧（一对多关系）。SchemaRelationship 对象为 SchemaRelationships 集合的成员。

使用 SchemaRelationship 对象

下列属性和方法返回一个 SchemaRelationship 对象：

  • LookupSchemaRelationships 集合的 Item 属性

  • SchemaRelationships 集合的 Add 和 AddNew 方法，以及 Item 属性

  • SublistSchemaRelationships 集合的 Item 属性


SchemaRowsource 对象

多个对象
SchemaRowsources
SchemaRowsource
多个对象

表示方案的行来源。数据库中的每个表、视图或存储过程都是潜在的方案行来源，这与为数据源控件明确定义的命令一样。

SchemaRowsource 对象为 SchemaRowsources 集合的成员。

使用 SchemaRowsource 对象

下列方法和属性返回一个 SchemaRowsource 对象：

  • SchemaRowsources 集合的 Add 和 AddNew 方法

  • SchemaRowsources 集合的 Item 属性。


Section 对象

多个对象
Section
多个对象

单个组页眉、页脚、标题或导航节的实例。

使用 Section 对象

下列属性和方法返回一个 Section 对象：

对象 | 属性/方法
DataPage | FirstSection
DataSourceControl | CurrentSection
 | GetContainingSection
DSCEventInfo | Section
Section | ChildSection
 | NextSection
 | NextSibling
 | ParentSection
 | PreviousSection
 | PreviousSibling


Spreadsheet 对象

Spreadsheet
多个对象

表示电子表格的容器。

使用 Spreadsheet 对象

可以使用 CreateObject 方法或 New 关键字创建 Spreadsheet 对象。

HTML 页或 Visual Basic 窗体上电子表格控件的对象 ID 返回一个 Spreadsheet 对象。

Spreadsheet 对象的编程标识符为 CLSID:0002E559-0000-0000-C000-000000000046。下面示例在 HTML 页上创建名为“Spreadsheet1”的电子表格。

<object id=Spreadsheet1 classid=CLSID:0002E559-0000-0000-C000-000000000046 style="width:49%;height:350"></object>


TitleBar 对象

多个对象
TitleBar
多个对象

表示工作表上的标题栏。

使用 TitleBar 对象

Spreadsheet 对象的 TitleBar 属性返回一个 TitleBar 对象。


Window 对象

多个对象
Window
多个对象

表示一个窗口。许多工作表特性，诸如滚动条和网格线，实际上是窗口的属性。Window 对象为 Windows 集合的成员。每个工作表具有唯一的 Window 对象。代码只能访问工作簿活动工作表的窗口。也就是说，尽管 Windows 集合表现为只有一个 Window 对象，但实际上有多个 Window 对象，不过只能访问活动工作表的 Window 对象。

使用 Window 对象

下列属性返回 Window 对象。

Spreadsheet 对象的 ActiveWindow 属性。

Windows 集合的 Item 属性。

下面示例隐藏 Spreadsheet1 活动窗口中的行和列标题。

Sub HideHeadings()

   Spreadsheet1.ActiveWindow.DisplayColumnHeadings = False
   Spreadsheet1.ActiveWindow.DisplayRowHeadings = False

End Sub

下面示例移动 C 列使其成为窗口最左边的列。

Spreadsheet1.ActiveWindow.ScrollColumn = 3


Workbook 对象

多个对象
Workbook
多个对象

表示一个工作簿。Workbook 对象为 Workbooks 集合的成员。

使用 Workbook 对象

使用 Spreadsheet 对象的 ActiveWorkbook 属性返回对打开的工作簿的引用。

工作簿包含一个 Worksheets 集合。


Worksheet 对象

多个对象
Worksheet
多个对象

表示工作簿中的单个工作表。

使用 Worksheet 对象

下列属性返回一个 Worksheet 对象：

  • Range 对象的 Worksheet 属性

  • Spreadsheet、Window 和 Workbook 对象的 ActiveSheet 属性

  • Worksheet 对象的 Next 和 Previous 属性

  • Worksheets 集合的 Add 方法和 Item 属性


XmlDataBinding 对象

XmlDataBindings
XmlDataBinding
多个对象

XmlDataBinding 对象表示绑定在电子表格组件中的 XML 数据。可将电子表格组件绑定或连接到数据检索服务、SOAP Web 服务、XML 文件或 Web 部件，其中的绑定由 XmlDataBinding 对象表示。

使用 XmlDataBinding 对象

XMLDataBinding 对象为 XmlDataBindings 集合的成员，是电子表格组件中所有 XmlDataBinding 对象的集合。对集合中各 XmlDataBinding 对象编制的索引是从 1 开始，1 表示第一个对象，2 表示第二个对象，依此类推。通过使用 XmlDataBindings 集合的 Item 属性可从该集合返回 XmlDataBinding 对象。Item 属性的参数为该集合中要返回的对象的索引号，或是该对象的绑定 ID。绑定 ID 是表示绑定的 XML 中的 ID 属性值。可在电子表格组件（或电子表格 Web 部件）的 XML 电子表格文件中找到该值，或通过检查 XmlDataBinding 对象的 BindingData 属性找到该值。通过使用 Microsoft Excel 创建数据绑定的电子表格，然后再将该工作簿另存为 XML 电子表格可创建 XML 电子表格文件。

可使用 XmlDataBindings 集合的 Add 方法新建 XmlDataBinding 对象。创建 XmlDataBinding 对象后，即可使用其 BindingData 属性以指定绑定配置信息。

下面示例显示如何处理与电子表格组件相关的各 XmlDataBinding 对象。

Dim objBindings
Dim objBinding
Dim strBindingInfo

Set objBindings = Spreadsheet1.ActiveWorkbook.XmlDataBindings

For Each objBinding in objBindings
     ' Save the XML binding information to a variable.
     strBindingInfo = objBinding.BindingData
     ' Work with the binding information here.
Next


XmlMap 对象

Workbook
XmlMaps
XmlMap
Workbook

XmlMap 对象表示电子表格组件的 XML 架构映射。XmlMap 对象为 XmlMaps 集合的成员。

使用 XmlMap 对象

对 XmlMaps 集合中的各 XmlMap 对象编制的索引是从 1 开始，1 表示第一个对象，2 表示第二个对象，依此类推。可使用 Item 属性从 XmlMaps 集合中返回 XmlMap 对象。Item 属性的参数是集合中要返回对象的索引号，或是该对象的映射 ID。映射 ID 是表示映射的 XML 中的 ID 属性值。可在部件的 XML 电子表格文件中找到该值，或通过检查 XmlMap 对象的 MapData 属性找到该值。使用 Microsoft Excel 创建数据绑定的电子表格，然后再将该工作簿另存为 XML 电子表格可创建 XML 电子表格文件。通过使用 XmlMaps 集合的 Add 方法可新建 XmlMap 对象。

下面示例显示如何处理每个与电子表格组件相关的 XmlMap 对象。其中使用 ActiveWorkbook 对象的 XmlMaps 属性返回 XmlMaps 集合对象：

Dim objMaps
Dim objMap
Dim strMapInfo

Set objMaps = Spreadsheet1.ActiveWorkbook.XmlMaps

For Each objMap in objMaps
     ' Save the XML map information to a variable.
     strMapInfo = objMap.MapData
     ' Work with the map information XML here.
Next


Activate 方法

显示 Activate 方法应用于 Range 对象的情形。

激活单个单元格。要选择单元格区域，请使用 Select 方法。

expression.Activate

expression 必需。该表达式返回一个 Range 对象。

显示 Activate 方法应用于 Worksheet 对象的情形。

激活指定工作表。

expression.Activate

expression 必需。该表达式返回一个 Worksheet 对象。

示例

显示 应用于 Range 对象的情形。

本示例选定活动工作表上的单元格 A1:C3，然后使选定区域中的单元格 B2 成为活动单元格。

Sub Activate_Range()

   ' Select cells A1:C3 in the active worksheet.
   Spreadsheet1.ActiveSheet.Range("A1:C3").Select

   ' Select cell B2. The following line of code uses the Cells
   ' method to index the current selection. Cell B2 is in the
   ' second row and the second column of the current selection.
   Spreadsheet1.Selection.Cells(2, 2).Activate
End Sub

显示 应用于 Worksheet 对象的情形。

本示例激活 Spreadsheet1 中的 Sheet2。

Spreadsheet1.Worksheets("Sheet2").Activate


Add 方法

显示 Add 方法应用于 ChAxes 对象的情形。

在图表中添加坐标轴。新建一个 ChAxis 对象。

expression.Add(Scaling)

expression 必需。该表达式返回一个 ChAxes 对象。

Scaling ChScaling 对象，必需。来自于其他坐标轴或系列的刻度对象。

显示 Add 方法应用于 ChCharts 对象的情形。

新建一个空图表。返回一个 ChChart 对象。

expression.Add(Index)

expression 必需。该表达式返回一个 ChCharts 对象。

Index Long 类型，可选。指定新图表的位置。指定零 (0) 将图表插入到集合的开始。默认值为 -1，表示如果不指定该参数，新图表将插入到集合的末尾。

显示 Add 方法应用于 ChDataLabelsCollection 对象的情形。

在指定系列中添加数据标志。新建一个未初始化的 ChDataLabels 对象，并添加到指定的 ChDataLabelsCollection 集合。一个系列只能具有一套数据标志，这意味着如果 ChDataLabelsCollection 集合已经包含一个 ChDataLabels 对象，则该方法无效。

expression.Add()

expression 必需。该表达式返回一个 ChDataLabelsCollection 对象。

显示 Add 方法应用于 ChErrorBarsCollection 对象的情形。

在系列中添加误差线。新建一个未初始化的 ChErrorBars 对象，并添加到指定的 ChErrorBarsCollection 集合。一张图表只能具有一套误差线，这意味着 XY 散点图只能包含 X 或 Y 误差线，而不能同时包含二者。

expression.Add()

expression 必需。该表达式返回一个 ChErrorBarsCollection 对象。

显示 Add 方法应用于 ChSegments 对象的情形。

在格式映射中添加一段。返回一个 ChSegment 对象。

expression.Add()

expression 必需。该表达式返回一个 ChSegments 对象。

显示 Add 方法应用于 ChSeriesCollection 对象的情形。

在图表中添加一个系列。在 ChSeriesCollection 集合的指定位置新建一个空的 ChSeries 对象。

expression.Add(Index)

expression 必需。该表达式返回一个 ChSeriesCollection 对象。

Index Long 类型，可选。指定新系列在集合中的位置。指定零 (0) 将系列置于集合的开始。默认值为 -1，表示如果不指定该参数，新系列将置于集合的末尾。

显示 Add 方法应用于 ChTrendlines 对象的情形。

在系列中添加趋势线。新建一个未初始化的 ChTrendline 对象，并添加到指定 ChTrendlines 集合的末尾。每个系列只能包含一个趋势线。

expression.Add()

expression 必需。该表达式返回一个 ChTrendlines 对象。

显示 Add 方法应用于 ElementExtensions 对象的情形。

新建一个 ElementExtension 对象。

expression.Add(ElementID, FailIfThere)

expression 必需。该表达式返回一个 ElementExtensions 对象。

ElementID String 类型，必需。指定将由新 ElementExtension 对象扩展的 HTML 元素的 ID 标记。

FailIfThere Boolean 类型，可选。如果该参数设置为 True，并且由 ElementID 指定的对象已经具有元素扩展名，则 Add 方法无效。如果该参数设置为 False（或不指定），将替换已有的元素扩展名。

显示 Add 方法应用于 GroupingDefs 对象的情形。

新建分组定义。返回一个 GroupingDef 对象。

expression.Add(GroupingDefName, GroupingFieldName, PageFieldName, Index)

expression 必需。该表达式返回一个 GroupingDefs 对象。

GroupingDefName String 类型，必需。指定新分组定义的名称。

GroupingFieldName String 类型，必需。指定用于创建新分组定义的分组字段名称。

PageFieldName String 类型，必需。指定用于创建新分组定义的页字段名称。

Index Variant 类型，可选。指定分组定义的序号位置、名称或实际对象引用，新分组定义将添加到该分组定义之前。如果不指定该参数，新分组定义添加到集合的末尾。

说明

表示组级别的记录集定义具有 GroupingDef 对象类型，该类型由表示记录集定义的 RecordsetDef 对象派生。如果涉及控件绑定，GroupingDef 对象定义的记录集行为与 RecordsetDef 对象定义的记录集相似。

显示 Add 方法应用于 GroupLevels 对象的情形。

新建组级别。返回一个 GroupLevel 对象。

expression.Add(RecordSource, FailIfThere)

expression 必需。该表达式返回一个 GroupLevels 对象。

RecordSource String 类型，必需。指定新组级别的记录源名称。

FailIfThere Boolean 类型，可选。如果该参数设置为 True，并且新组级别已经存在，则 Add 方法无效。默认值为 False。

显示 Add 方法应用于 Sheets 和 Worksheets 对象的情形。

新建一个工作表。新工作表将成为活动工作表。

expression.Add(Before, After, Count, Type)

expression 必需。该表达式返回上面对象之一。

Before Variant 类型，可选。指定在其之前添加新工作表的工作表对象。

After Variant 类型，可选。指定在其之后添加新工作表的工作表对象。

Count Variant 类型，可选。添加的工作表数。默认值为 1。

Type Variant 类型，可选。指定工作表类型。可以为下列 XlSheetType 常量之一：xlWorksheet。

说明

如果同时省略 Before 和 After，则新工作表插入到活动工作表之前。

显示 Add 方法应用于 PageFields 对象的情形。

新建一个页字段。返回一个 PageField 对象。

expression.Add(Source, FieldType, Name, TotalType, Index)

expression 必需。该表达式返回一个 PageFields 对象。

Source Variant 类型，必需。指定新页字段的来源。对于 dscOutput 类型的新页字段，该参数指定一个 SchemaField 对象或方案字段名称。对于 dscCalculated 类型的新页字段，该参数指定计算字段的表达式。对于 dscGrouping 类型的新页字段，该参数指定一个 PageField 对象或分组所基于的页字段名称。

FieldType Variant 类型，可选。指定新字段类型。默认值和允许值取决于使用该方法的父对象。有关详细信息，请参阅本主题的“说明”部分。

Name Variant 类型，可选。指定新页字段的名称。如果不指定该参数，输出字段名称与所基于的方案字段名称相同，分组字段名称为 "By<pagefieldname>" 或 "<agg function>of<pagefieldname>"，计算字段名称为 "Expr"。如果必要，在所有情况下均在新名称的末尾自动追加序数，以确保唯一性。

TotalType DscTotalTypeEnum 类型，可选。总计类型。

DscTotalTypeEnum 可以为下列 DscTotalTypeEnum 常量之一。
dscAny
dscAvg
dscCount
dscMax
dscMin
dscNone 默认值
dscStdev
dscSum

Index Variant 类型，可选。指定页字段的序号位置、名称或实际对象引用，新页字段将添加到该页字段之前。如果不指定该参数，新页字段将添加到集合的末尾。该参数仅适用于 GroupingDef 对象的 PageFields 集合。有关详细信息，请参阅本段后面的“说明”部分。

说明

PageFields 集合具有三个不同的父对象：RecordsetDef、PageRowsource 和 GroupingDef。所有这些父对象使用相同的 Add 方法。但是，根据所用于的父对象不同，默认值和允许值有所不同。

  • 对于 RecordsetDef.PageFields.Add，FieldType 的默认值为 dscOutput。FieldType 的其他允许值为 dscCalculated 和 dscGrouping。如果 FieldType 为 dscOutput，指定来源字段将添加到记录集定义中的主页行来源，这样，在相应的方案行来源中必须存在该来源字段。如果 FieldType 为 dscGrouping，TotalType 必须为 dscNone 以外的值（非聚合分组字段只能存在于分组定义，而不是记录集定义中）。这种情况下不能使用 Index 参数。
  • 对于 PageRowsource.PageFields.Add，FieldType 的默认且唯一的允许值为 dscOutput。TotalType 的唯一允许值为 dscNone。这种情况下不能使用 Index 参数。使用 Add 方法，可以在查询行来源中添加输出字段。
  • 对于 GroupingDef.PageFields.Add，FieldType 的默认值为 dscGrouping。FieldType 的其他允许值为 dscCalculated。这种情况下可以使用 Index 参数（次序在分组定义中很重要）。

显示 Add 方法应用于 LookupRelationships 和 SublistRelationships 对象的情形。

新建一个查找联接关系或子列表关系。返回一个 PageRelationship 对象。

expression.Add(PageRowsource, SchemaRelationship)

expression 必需。该表达式返回上面对象之一。

PageRowsource PageRowsource 对象，必需。指定一对多页面关系中“一”侧的页面行来源。

SchemaRelationship SchemaRelationship 对象，必需。表示一对多关系中“多”侧的父页面行来源与本方法中指定的页面行来源之间的连接字段。

说明

SublistRelationships 集合包含 dscSublist 类型的 PageRelationship 对象，其 RecordsetDef 对象是一对多关系中的“一”侧（父对象）。

显示 Add 方法应用于 ParameterValues 对象的情形。

新建一个参数值。返回一个 ParameterValue 对象。

expression.Add(ParameterName, Value)

expression 必需。该表达式返回一个 ParameterValues 对象。

ParameterName String 类型，必需。指定参数名称。

Value Variant 类型，可选。指定参数值。

显示 Add 方法应用于 RecordsetDefs 对象的情形。

新建一个记录集定义。返回一个 RecordsetDef 对象。

expression.Add(SchemaRowsource, Name)

expression 必需。该表达式返回一个 RecordsetDefs 对象。

SchemaRowsource Variant 类型，必需。指定将用于新建记录集定义的方案行来源。该参数可以为 SchemaRowsource 对象或已有方案行来源的名称。

Name Variant 类型，可选。指定新记录集定义的名称。如果不指定该参数，新记录集定义的名称与 SchemaRowsource 参数指定的方案行来源名称相同，如果必要，新名称的末尾将自动追加序数，以确保唯一性。

说明

使用单个 AddNew 方法调用，可以创建记录集定义、页面行来源和方案行来源。

显示 Add 方法应用于 SchemaFields 对象的情形。

新建一个方案字段。返回一个 SchemaField 对象。

expression.Add(Name, DataType, Length)

expression 必需。该表达式返回一个 SchemaFields 对象。

Name String 类型，必需。指定新方案字段的名称。

DataType ADO DataTypeEnum 类型，必需。指定新方案字段的数据类型。

Length Variant 类型，可选。指定新方案字段的长度。

说明

在 Microsoft Access 的设计模式中，将自动以可用的方案字段填充 SchemaFields 集合。

显示 Add 方法应用于 SchemaParameters 对象的情形。

新建一个方案参数。返回一个 SchemaParameter 对象。

expression.Add(Name, DataType, Size, Scale, Precision, Direction)

expression 必需。该表达式返回一个 SchemaParameters 对象。

Name String 类型，必需。指定新方案参数的名称。

DataType Variant 类型，可选。指定新方案参数的数据类型。可以为下列 ADO DataTypeEnum 常量之一。

Size Variant 类型，可选。指定新方案参数的最大长度。

Scale Variant 类型，可选。指定小数点右侧的最大位数。

Precision Variant 类型，可选。指定参数的最大位数。

Direction Variant 类型，可选。指定参数是否为输入参数、输出参数、输入输出参数或过程返回值。由于只支持输入参数，因此不应该指定该参数。

说明

在 Microsoft Access 的设计模式中，将以可用的方案参数自动填充 SchemaParameters 集合。

显示 Add 方法应用于 SchemaRelatedFields 对象的情形。

新建一个相关字段。返回一个 SchemaRelatedField 对象。

expression.Add(ManySchemaField, OneSchemaField)

expression 必需。该表达式返回一个 SchemaRelatedFields 对象。

ManySchemaField String 类型，必需。指定一对多关系中“一”侧的方案字段名称。

OneSchemaField String 类型，必需。指定一对多关系中“多”侧的方案字段名称。

说明

SchemaRelatedField 对象描述组成 SchemaRelationship 对象的列对。这些字段名称用于生成 SQL 中的联接语句和层次中的父子关系。

在 Microsoft Access 的设计模式中，将以可用的方案字段自动填充 SchemaFields 集合。

显示 Add 方法应用于 SchemaRelationships 对象的情形。

新建一个方案关系。返回一个 SchemaRelationship 对象。

expression.Add(Name, ManySchemaRowsource, OneSchemaRowsource, ManySchemaField, OneSchemaField)

expression 必需。该表达式返回一个 SchemaRelationships 对象。

Name String 类型，必需。指定新方案关系的名称。

ManySchemaRowsource String 类型，必需。指定一对多关系中“多”侧的行来源名称。

OneSchemaRowsource String 类型，必需。指定一对多关系中“一”侧的行来源名称。

ManySchemaField String 类型，必需。指定一对多关系中“多”侧的方案字段名称。

OneSchemaField String 类型，必需。指定一对多关系中“一”侧的方案字段名称。

说明

在 Microsoft Access 的设计模式中，将以可用的方案关系自动填充 SchemaRelationships 集合。

显示 Add 方法应用于 SchemaRowsources 对象的情形。

新建一个方案行来源。返回一个 SchemaRowSource 对象。

expression.Add(Name, RowsourceType, CommandText)

expression 必需。该表达式返回一个 SchemaRowsources 对象。

Name String 类型，必需。指定新行来源的名称。

RowsourceType DscRowsourceTypeEnum 类型，必需。指定新行来源的类型。

DscRowsourceTypeEnum 可为以下 DscRowsourceTypeEnum 常量之一。
dscCommandFile
dscCommandText
dscProcedure
dscTable
dscView

CommandText Variant 类型，可选。方案行来源命令文本。有关详细信息，请参阅 CommandText 属性的帮助主题。

说明

在 Microsoft Access 的设计模式中，将以可用的方案行来源自动填充 SchemaRowsources 集合。

显示 Add 方法应用于 Criteria 对象的情形。

添加“自动筛选”条件。

expression.Add(Criterion)

expression 必需。该表达式返回一个 Criteria 对象。

Criterion String 类型，必需。指定新条件。

显示 Add 方法应用于 Names 对象的情形。

定义新名称。返回一个 Name 对象。

expressionAdd(Name, RefersTo, Visible, MacroType, ShortcutKey, Category, NameLocal, RefersToLocal, CategoryLocal, RefersToR1C1, RefersToR1C1Local)

expression 必需。该表达式返回一个 Names 对象。

Name Variant 类型，可选。如果没有指定 NameLocal，则该参数为必需。用作名称的文本（以宏语言表示）。名称不能包括空格，不能与单元格引用类似。

RefersTo Variant 类型，可选。必需，除非指定其他 RefersTo 参数，否则为必需。描述引用的名称（使用 A1-样式符以宏语言表示）。

Visible Variant 类型，可选。不支持该参数。

MacroType Variant 类型，可选。不支持该参数。

ShortcutKey Variant 类型，可选。不支持该参数。

Category Variant 类型，可选。不支持该参数。

NameLocal Variant 类型，可选。如果没有指定 Name，则该参数为必需。用作名称的文本（以用户语言表示）。名称不能包括空格，不能与单元格引用类似。

RefersToLocal Variant 类型，可选。除非指定其他 RefersTo 参数，否则为必需。描述引用的名称（使用 A1-样式符以宏语言表示）。

CategoryLocal Variant 类型，可选。不支持该参数。

RefersToR1C1 Variant 类型，可选。除非指定其他 RefersTo 参数，否则为必需。描述引用的名称（使用 R1C1-样式符以宏语言表示）。

RefersToR1C1Local Variant 类型，可选。除非指定其他 RefersTo 参数，否则为必需。描述引用的名称（使用 R1C1-样式符以宏语言表示）。

显示 Add 方法应用于 ListRows 集合的情形。

通过将插入行中的单元格提升至添加行来向当前 XML 列表的 ListRows 集合添加新行。返回包含新创建行的值的 ListRow 对象。

expression.Add()

expression 必需。返回一个 ListRows 集合的表达式。

显示 Add 方法应用于 XmlDataBindings 集合的情形。

向当前 Workbook 的 XmlDataBindings 集合添加新数据绑定。

expression.Add(bstrBindingData)

expression 必需。返回一个 XmlDataBindings 集合的表达式。

bstrBindingData String 类型，必需。为新数据绑定定义配置数据的 XML 片段。您可以使用 BindingData 属性返回现有绑定的配置数据。有关电子表格组件的数据绑定 XML 架构的信息，请在 Microsoft Developer Network (MSDN) 网站上搜索。

说明

由 XmlDataBinding 对象定义的数据绑定可从数据检索服务、SOAP Web 服务、XML 文件或其他电子表格组件中查询或更新数据。

事先不添加相关映射就调用 Add 方法添加绑定会生成运行时错误。若要避免这种错误，必须先对 XmlMaps 集合调用 Add 方法以添加相关映射。

显示 Add 方法应用于 XmlMaps 集合的情形。

向当前 Workbook 的 XmlMaps 集合添加新 XML 映射。

expression.Add(bstrMapData)

expression 必需。返回一个 XmlMaps 集合的表达式。

bstrMapData String 类型，必需。为新 XML 映射定义配置数据的 XML 片段。您可以使用 MapData 属性返回现有 XML 映射的配置数据。有关电子表格组件 XML 映射的 XML 架构的信息，请在 Microsoft Developer Network (MSDN) 网站上搜索。

示例

显示 应用于 ChCharts 对象的情形。

本示例向图表工作区中添加图表。

Set cht = ChartSpace1.Charts.Add

显示 应用于 ChDataLabelsCollection 对象的情形。

本示例向图表工作区中指定系列添加数据标志。

Set ch = ChartSpace1.Charts(0)
ch.SeriesCollection(0).DataLabelsCollection.Add

显示 应用于 ChErrorBarsCollection 对象的情形。

本示例向图表工作区中指定系列添加误差线。

Set eb = ChartSpace1.Charts(0).SeriesCollection(0).ErrorBarsCollection.Add

显示 应用于 ChSeriesCollection 对象的情形。

本示例向图表工作区中指定图表新添一个系列，然后设置新系列的值。

Dim values(7)

values(0) = 0
values(1) = 1
values(2) = 10
values(3) = 25
values(4) = 30
values(5) = 40
values(6) = 60

Set s2 = ChartSpace1.Charts(0).SeriesCollection.Add
Set c = ChartSpace1.Constants
s2.SetData c.chDimValues, c.chDataLiteral, values

显示 应用于 ChTrendlines 对象的情形。

本示例向图表工作区中指定系列添加趋势线。

Set trndline = ChartSpace1.Charts(0).SeriesCollection(0).Trendlines.Add

显示 应用于 Criteria 对象的情形。

本示例打开 A1:J22 的“自动筛选”，然后为第一列和第三列设置并应用筛选。

Spreadsheet1.Range("a1:j22").AutoFilter
Set af = Spreadsheet1.ActiveSheet.AutoFilter
Set filterColumnOne = af.Filters(1)
Set filterColumnThree = af.Filters(3)
filterColumnOne.Criteria.Add "blue" ' Don't show blue in column 1.
filterColumnOne.Criteria.Add "green" ' Don't show green in column 1.
filterColumnThree.Criteria.Add "yellow" ' Don't show yellow in column 3.
af.Apply


AddCalculatedField 方法

在数据透视表中添加一个计算字段。计算字段可如同其他字段一样用于排序、筛选或分组。在添加计算字段之前必须使用 AddFieldSet 方法创建自定义字段集。返回一个 PivotField 对象。

expression.AddCalculatedField(Name, Caption, DataField, Expression)

expression 必需。该表达式返回一个由 AddFieldSet 方法创建的 PivotFieldSet 对象。

Name String 类型，必需。计算字段的名称。名称在字段集中必须唯一。

Caption String 类型，必需。数据透视表用户界面上计算字段显示的标题。尽管该参数为必需，但标题可以赋予空字符串。

DataField String 类型，必需。在数据透视表基础记录集中创建的新字段名称。

Expression String 类型，必需。该表达式用于计算新字段中的项。该表达式必须与 Jet 表达式服务兼容。

说明

自定义字段集只能包含一个计算字段。在自定义字段集中添加第二个计算字段将导致运行时出错。

示例

本示例在 PivotTable1 中新添名为“Variance”的字段集。在新字段集中创建标题为“Budget Variance”的计算字段，然后将该计算字段插入到 PivotTable 视图中。

Sub TestAddFieldSet()

    Dim vwView
    Dim fsNewFieldSet

    Set vwView = PivotTable1.ActiveView

    ' Add a custom field set to the PivotTable.
    Set fsNewFieldSet = vwView.AddFieldSet("Variance")

    ' Add a calculated total to the newly created field set.
    fsNewFieldSet.AddCalculatedField "Variance", _

    "Budget Variance", "fldVariance", _

    "Budget / Actual"

    ' Insert the calculated field into the data axis.
    vwView.DataAxis.InsertFieldSet fsNewFieldSet

End Sub


AddCalculatedTotal 方法

在数据透视表中添加计算总计。使用 AddCalculatedTotal 方法创建基于数据透视表中定义的总计的自定义总计。计算总计返回一个 PivotTotal 对象。

expression.AddCalculatedTotal(Name, Caption, Expression, SolveOrder)

expression 必需。该表达式返回一个 PivotView 对象。

Name String 类型，必需。用于在 PivotTotals 集合中标识新计算总计。该参数在 PivotTotals 集合中必须唯一。长度必须在 1 到 50 个字符之间。

Caption String 类型，必需。用于在数据透视表用户界面中标识新计算总计。

Expression String 类型，必需。该表达式用于计算新计算总计。必须为访问数据所用的 OLE DB 提供者的有效多维表达式 (MDX) 语句。

SolveOrder Long 类型，可选。表示在刷新数据透视表时新计算总计的求解次序。如果创建的计算总计取决于前面创建的计算总计，则 SolveOrder 参数非常有用。

示例

下面示例在名为“PivotTable1”的数据透视表中添加名为 “Sales in Last Period”的计算总计。新计算总计显示前一时间段的销售额。本示例使用随 Microsoft SQL Server 7.0 OLAP Services 安装的 FoodMart OLAP 多维数据集。

Sub TestAddCalculatedTotal()

   Dim strExp
   Dim totCalcTotal
   Dim vwView

   Set vwView = PivotTable1.ActiveView

   ' The MDX expression used for the new calculated total.
   strExp = "([Measures].[Store Sales], Time.PrevMember)"

   ' Create the new calculated total.
   Set totCalcTotal = vwView.AddCalculatedTotal  _
                   ("Sales in Last Period", "Sales in Last Period", strExp)

   ' Insert the calculated total in the data area of the PivotTable.
   vwView.DataAxis.InsertTotal totCalcTotal

End Sub


AddCustomGroupField 方法

向字段集中添加自定义分组字段。返回一个 PivotField 对象。

expression.AddCustomGroupField(Name, Caption, Before)

expression 必需。该表达式返回一个 PivotFieldSet 对象。

Name String 类型，可选。新字段的名称。

Caption String 类型，可选。新字段显示的标题。

Before Variant 类型，可选。字段的索引、名称或引用。

说明

使用该方法创建了自定义分组字段后，请使用 AddCustomGroupMember 方法向组中添加成员。

请注意自定义分组字段及其成员均在客户端创建，而不是在数据源创建。

示例

本示例在 Time 字段集中添加一个自定义分组字段，然后在字段中添加两个成员。

Sub CreateCustomGroup()

   Dim fsTime
   Dim fsHalfYear

   ' Set a variable to the Time field set.
   Set fsTime = PivotTable1.ActiveView.FieldSets("Time")

   ' Add a custom group field named "Group1" to the Time field set.
   Set fsHalfYear = fsTime.AddCustomGroupField("Group1", "Group1", _
                    "Quarter")

   ' Add a member to the custom field set. This member includes all "Q1"
   ' and "Q2" members under 1997.
   fsHalfYear.AddCustomGroupMember fsTime.Member.Childmembers("1997").Name, _
                                   Array("Q1","Q2"), "1stHalf"

   ' Add a member to the custom field set. This member includes all "Q3"
   ' and "Q4" members under 1997.
   fsHalfYear.AddCustomGroupMember fsTime.Member.ChildMembers("1997").Name, _
                                   Array("Q3","Q4"), "2ndHalf"

End Sub


AddCustomGroupMember 方法

向自定义分组字段中添加成员。返回一个 PivotMember 对象。

expression.AddCustomGroupMember(Parent, varChildMembers, bstrCaption)

expression 必需。该表达式返回一个 PivotField 对象。

Parent Variant 类型，必需。新成员的父成员的名称、唯一名称或引用。

varChildMembers Variant 类型，必需。添加到新自定义分组成员的成员名称、唯一名称或成员引用。

bstrCaption String 类型，可选。新成员显示的标题。

说明

使用该方法填充由 AddCustomGroupField 方法创建的字段。

示例

本示例在 Time 字段集中添加一个自定义分组字段，然后在字段中添加两个成员。

Sub CreateCustomGroup()

   Dim fsTime
   Dim fsHalfYear

   ' Set a variable to the Time field set.
   Set fsTime = PivotTable1.ActiveView.FieldSets("Time")

   ' Add a custom group field named "Group1" to the Time field set.
   Set fsHalfYear = fsTime.AddCustomGroupField("Group1", "Group1", _
                    "Quarter")

   ' Add a member to the custom field set. This member includes all "Q1"
   ' and "Q2" members under 1997.
   fsHalfYear.AddCustomGroupMember fsTime.Member.Childmembers("1997").Name, _
                                   Array("Q1","Q2"), "1stHalf"

   ' Add a member to the custom field set. This member includes all "Q3"
   ' and "Q4" under 1997.
   fsHalfYear.AddCustomGroupMember fsTime.Member.ChildMembers("1997").Name, _
                                   Array("Q3","Q4"), "2ndHalf"

End Sub


AddFieldSet 方法

在数据透视表中添加自定义字段集。创建了自定义字段集后，可使用 AddCalculatedField 方法定义自定义字段。返回一个 PivotFieldSet 对象。

expression.AddFieldSet(Name)

expression 必需。该表达式返回一个 PivotView 对象。

Name String 类型，必需。指定新字段集的名称。名称在 PivotFieldSets 集合中必须唯一。长度必须在 1 到 24 之间。

说明

在将新字段集添加到当前数据透视表视图之前，必须在其中添加一个计算字段。自定义字段集只能包含一个计算字段。在自定义字段集中添加第二个计算字段将导致运行时出错。

注释 如果数据透视表已连接到联机分析处理 (OLAP) 数据源，则可向数据透视表添加自定义字段集，但不能在数据源中使用该字段集。

示例

本示例在 PivotTable1 的新字段集中添加名为“Variance”的计算字段，然后将该计算字段插入到数据透视表视图中。

Sub TestAddFieldSet()
    Dim vwView
    Dim fsNewFieldSet

    Set vwView = PivotTable1.ActiveView

    ' Add a custom field set to the PivotTable.
    Set fsNewFieldSet = vwView.AddFieldSet("Variance")

    ' Add a calculated total to the newly created field set.
    fsNewFieldSet.AddCalculatedField "Variance", _
                "Budget Variance", "fldVariance", _
                "Budget / Actual"

    ' Insert the calculated field into the data axis.
    vwView.DataAxis.InsertFieldSet fsNewFieldSet

End Sub


AddIn 方法

在指定的电子表格中添加加载项。

expression.AddIn(AddIn)

expression 该表达式返回一个 Spreadsheet 对象。

AddIn 必需。Object 类型。指定加载项。


AddNew 方法

新建一个方案行来源和记录集定义。返回一个 RecordsetDef 对象。

expression.AddNew(Source, RowsourceType, Name)

expression 该表达式返回一个 RecordsetDefs 对象。

Source String 类型，必需。指定 dscCommandText 或 dscCommandFile 类型的新方案行来源的名称命令文本，或指定以方案行来源添加的表、视图或存储过程的名称命令文本。有关详细信息，请参阅 CommandText 属性的帮助主题。

RowsourceType Variant 类型，可选。指定新方案行来源的类型。可以为下列 dscRowsourceTypeEnum 常量之一。默认常量为 dscCommandText。

Name Variant 类型，可选。指定使用 AddNew 方法创建的记录集定义、页面行来源和方案行来源的名称。如果不指定该参数并且 RowsourceType 参数为 dscTable、dscView 或 dscProcedure，新名称与 Source 参数中指定的名称相同（如果必要，将自动在末尾追加序数以确保唯一性）。如果不指定该参数并且 RowsourceType 为 dscCommandText 或 dscCommandFile。新名称为“commandN”，其中 N 为一个或多个追加序数。

说明

页字段通常以页数据定义中唯一的名称定义。但是，将页字段添加到主页行来源为 dscProcedure、dscCommandText 或 dscCommandFile 类型的记录集定义中时，页字段名称必须与方案字段名称相同。这将导致 AllPageFields 集合中有多个相同名称的页字段。要区分相同名称的对象，可以使用表达式 AllPageFields("RecordsetdefName.PagefieldName")，其中 RecordsetdefName 为记录集定义的名称，PagefieldName 为页字段的名称。请注意页字段名称本身不能包含句号。


AddTotal 方法

显示 AddTotal 方法应用于 GroupingDefs 对象的情形。

新建总计。

expression.AddTotal(GroupingDefName, GroupingFieldName, PageFieldName, TotalType, Index)

expression 该表达式返回一个 GroupingDefs 对象。

GroupingDefName String 类型，必需。指定用于创建总计的 GroupingDef 对象。

GroupingFieldName String 类型，必需。指定用于创建总计的分组字段。

PageFieldName String 类型，必需。指定用于创建总计的 PageField 对象。

TotalType DscTotalTypeEnum 类型，必需。指定用于创建总计的函数。

DscTotalTypeEnum 可为以下 DscTotalTypeEnum 常量之一：
dscAny
dscAvg
dscCount
dscMax
dscMin
dscNone
dscStdev
dscSum

Index Variant 类型，可选。指定新总计在集合中的位置。

显示 AddTotal 方法应用于 PivotView 对象的情形。

在“数据透视表”视图中添加总计。

expression.AddTotal(Name, Field, Function)

expression 该表达式返回一个 PivotView 对象。

Name String 类型，必需。指定总计名称。

Field PivotField 类型，必需。指定用于创建总计的字段。

Function PivotTotalFunctionEnum 类型，必需。指定用于创建总计的函数。

PivotTotalFunctionEnum 可为以下 PivotTotalFunctionEnum 常量之一：
plFunctionAverage
plFunctionCount
plFunctionMax
plFunctionMin
plFunctionStdDev
plFunctionStdDevP
plFunctionSum
plFunctionVar
plFunctionVarP

示例

显示 应用于 PivotView 对象的情形。

本示例在活动视图的“数据透视表”列表中添加合计总计。
Sub Add_Total()
    Dim vwView
    Dim ptConstants
    Dim totNewTotal

    Set vwView = PivotTable1.ActiveView
    Set ptConstants = PivotTable1.Constants

    ' Add a new total named "Total Budget" to the current view.
    Set totNewTotal = vwView.AddTotal("Total Budget", vwView.Fieldsets("budget").Fields(0), _
             ptConstants.plFunctionSum)

    ' Insert the newly created total into the detail area of the PivotTable.
    vwView.DataAxis.InsertTotal totNewTotal

End Sub


Apply 方法

应用指定的“自动筛选”。通常使用 AutoFilter 方法打开“自动筛选”并添加一个或多个条件；然后使用 Apply 方法应用新的筛选。

expression.Apply

expression 该表达式返回一个 AutoFilter 对象。

示例

本示例打开 A1:C20 区域内的“自动筛选”，为 A 列和 C 列设置筛选，然后应用这些筛选。

Private Sub EnableAutoFilter()
Dim afFilters
Dim afCol1
Dim afCol3

' Turn on AutoFilter.
Spreadsheet1.Worksheets("Sheet1").Range("A1:C20").AutoFilter

' Set a variable to the AutoFilter object.
Set afFilters = Spreadsheet1.Worksheets("sheet1").AutoFilter

Set afCol1 = afFilters.Filters(1)
Set afCol3 = afFilters.Filters(3)

' Add a criteria that excludes blue from column A.
afCol1.Criteria.Add "blue"

' Add a criteria that excludes green from column A.
afCol1.Criteria.Add "green"

' Add a criteria that excludes yellow from column c.
afCol3.Criteria.Add "yellow"

' Apply the criteria.
afFilters.Apply
End Sub


ApplyFilter 方法

根据当前选定的字段筛选数据访问页上的记录。在功能上等效于记录导航控件上的“按选定内容筛选”按钮。

expression.ApplyFilter

expression 必需。该表达式返回一个 DataPage 对象。

说明

该方法根据数据访问页上的当前选定内容确定筛选字段。因此，当数据访问页上的控件（例如命令按钮）调用包含该方法的过程时，必须将焦点设置在排序字段。

示例

本示例根据 CategoryID 字段中当前显示的内容筛选数据访问页。

Sub Command0_onclick()

   MSODSC.Datapages(0).FirstSection.HTMLContainer.Children("CategoryID").Focus

   MSODSC.Datapages(0).ApplyFilter

End Sub


AutoFilter 方法

显示或隐藏“自动筛选”下拉箭头。通常使用该方法打开“自动筛选”并添加一个或多个条件；然后使用 Apply 方法应用新的筛选。

expression.AutoFilter(Field, Criteria1, Operator, Criteria2, VisibleDropDown)

expression 该表达式返回一个 Range 对象。

Field Variant 类型，可选。不支持该参数。

Criteria1 Variant 类型，可选。不支持该参数。

Operator Variant 类型，可选。不支持该参数。

Criteria2 Variant 类型，可选。不支持该参数。

VisibleDropDown Variant 类型，可选。不支持该参数。

说明

请不要将该方法与 AutoFilter 属性相混淆。该方法应用于 Range 对象并打开“自动筛选”，而 AutoFilter 属性则为指定工作表返回 AutoFilter 对象。

示例

本示例打开 A1:C20 区域内的“自动筛选”，为 A 列和 C 列设置筛选，然后应用这些筛选。

Sub Apply_AutoFilter()
    Dim afFilters
    Dim afCol1
    Dim afCol3

    ' Turn on AutoFilter.
    Spreadsheet1.Worksheets("Sheet1").Range("A1:C20").AutoFilter

    ' Set a variable to the AutoFilter object.
    Set afFilters = Spreadsheet1.Worksheets("sheet1").AutoFilter

    Set afCol1 = afFilters.Filters(1)
    Set afCol3 = afFilters.Filters(3)

    ' Add a criteria that excludes blue from column A.
    afCol1.Criteria.Add "blue"

    ' Add a criteria that excludes green from column A.
    afCol1.Criteria.Add "green"

    ' Add a criteria that excludes yellow from column c.
    afCol3.Criteria.Add "yellow"

    ' Apply the criteria.
    afFilters.Apply
End Sub


AutoFit 方法

更改区域中的列宽或行高以达到最佳匹配。

expression.AutoFit

expression 必需。该表达式返回一个 Range 对象。必须为行或行区域，或者列或列区域。否则，该方法将产生错误。

示例

本示例调整选定行列为最佳匹配。

Sub AutoFitSelection()

   Dim rngSelected

   Set rngSelected = Spreadsheet1.Selection

   rngSelected.Rows.AutoFit
   rngSelected.Columns.AutoFit

End Sub


AutoLayout 方法

将指定的“数据透视表”列表恢复为默认视图配置。如果“数据透视表”绑定到记录集，则将在数据轴为记录集中的每个字段添加一个字段集。如果“数据透视表”绑定到多维数据源，例如 OLAP 多维数据集，所有字段集均将从坐标轴删除，清除当前视图。

expression.AutoLayout(MaxDataFields)

expression 该表达式返回一个 PivotView 对象。

MaxDataFields Long 类型，可选。如果数据成员为记录集，则指定可以添加到坐标轴的最大字段数。如果没有指定该参数或指定为零 (0)，则可添加的字段数没有限制。

示例

本示例重新设置 PivotTable1 的活动视图。

PivotTable1.ActiveView.AutoLayout


BeginObject 方法

开始指定 ChChartDraw 对象的绘制顺序。

expression.BeginObject(id)

expression 必需。该表达式返回一个 ChChartDraw 对象。

id Long 类型，必需。将该参数设置为唯一的标识符，该标识符将用于确定绘制的对象。设置为 -1 标识符传递给事件过程的 ChChartDraw 对象。

说明

可以将多个绘图元素合并为一个用户可选择的项，方法是将它们置于对 BeginObject 和 EndObject 方法的调用之间。

示例

本示例使用 BeforeRender 事件取消 Chartspace1 中第一张图表绘图区和网格线的绘制，然后在图表着色后 AfterRenderEvent 事件在绘图区绘制一个椭圆。

Private Sub ChartSpace1_BeforeRender(chartObject, Cancel)

    Select Case TypeName(chartObject)

        Case "ChGridlines"

            ' Cancel the drawing of the gridlines.
            Cancel.Value = True

        Case "ChPlotArea"

            ' Cancel the drawing of the plot area.
            Cancel.Value = True

    End Select

End Sub

Private Sub ChartSpace1_AfterRender(drawObject, chartObject)

    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Check to see if the chart has been rendered.
    If TypeName(chartObject) = "ChChart" Then

        ' The next three lines of code set the interior
        ' and border properties of the ellipse.
        drawObject.Interior.SetPresetGradient _
               chConstants.chGradientHorizontal, _
               chConstants.chGradientVariantStart, _
               Int((24 - 1 + 1) * Rnd + 1)
        drawObject.Border.Weight = 1
        drawObject.Border.Color = "black"

        ' Begin the drawing object.
        drawObject.BeginObject 1

        ' Draw the ellipse.
        drawObject.DrawEllipse chartObject.PlotArea.Left, chartObject.PlotArea.Bottom, _
                               chartObject.PlotArea.Right, chartObject.PlotArea.Top

        drawObject.EndObject

  End If

End Sub


BeginUndo 方法

指定撤消块的开始。这意味着从该调用到与其相对应的 EndUndo 方法调用之间的所有语句均可在对 Undo 方法的一次调用中撤消。这样可以将整个宏合并为一个语句，以便于撤消。撤消块可以嵌套。

expression.BeginUndo

expression 该表达式返回一个 ChartSpace 或 Spreadsheet 对象。

示例

本示例创建包含设置单元格 D10 数字格式和字体代码的撤消块。可以单击 Spreadsheet1 工具栏上的“撤消”按钮撤消所有格式设置。

Sub UndoBlock()
    Dim rngCurrent

    ' Enable undo.
    Spreadsheet1.EnableUndo = True

    ' Start an undo block.
    Spreadsheet1.BeginUndo

        Set rngCurrent = Spreadsheet1.Worksheets("sheet1").Range("D10")

        ' The following three lines of code apply
        ' various formatting to cell D10.
        rngCurrent.NumberFormat = "0.###"
        rngCurrent.Font.Color = "Blue"
        rngCurrent.Font.Name = "Times New Roman"

    ' End the undo block.
    Spreadsheet1.EndUndo
End Sub


BorderAround 方法

为区域添加边框，并设置新边框的 Color、LineStyle 和 Weight 属性。

expression.BorderAround(LineStyle, Weight, ColorIndex, Color)

expression 必需。该表达式返回一个 Range 对象。

LineStyle Variant 类型，可选。边框的线型。可为下列 XlLineStyle 常量之一。

XlLineStyle 可以为下列 XlLineStyle 常量之一。
xlContinuous 默认
xlDash
xlDashDot
xlDashDotDot
xlDot

Weight XlBorderWeight 类型，可选。边框宽度。

XlBorderWeight 可以为下列 XlBorderWeight 常量之一。
xlHairline
xlMedium
xlThick
xlThin 默认

ColorIndex XlColorIndex 类型，可选。边框颜色，以当前调色板索引表示，或以 XlColorIndex 常量表示。

XlColorIndex 可以为下列 XlColorIndex 常量之一。
xlColorIndexAutomatic 默认
xlColorIndexNone

Color Variant 类型，可选。边框颜色，以 RGB 值表示。

说明

必须指定 ColorIndex 或 Color，但不能同时指定。

可以指定 LineStyle 或 Weight，但不能同时指定。如果没有指定任何参数，则使用默认线型和宽度。

示例

本示例在 Sheet1 的区域 A1:D4 周围添加红色粗边框。

Sub Add_Border()

   Dim ssConstants

   Set ssConstants = Spreadsheet1.Constants

   Spreadsheet1.Worksheets("Sheet1").Range("A1:D4") _
             .BorderAround , ssConstants.xlThick, 3

Enb Sub


Calculate 方法

计算打开的工作簿、工作簿中的指定工作表或工作表上的指定单元格区域。

expression.Calculate

expression 该表达式返回一个 Range、Spreadsheet 或 Worksheet 对象。

示例

本示例重新计算电子表格上的活动工作表。

Spreadsheet1.ActiveSheet.Calculate

本示例重新计算 Sheet1 中的区域 A1:G5。

Spreadsheet1.Worksheets("Sheet1").Range("A1:G5").Calculate


CalculateFull 方法

强制打开的工作簿上的公式重新计算。

expression.CalculateFull

expression 必需。该表达式返回一个 Spreadsheet 对象。

示例

本示例强制 Spreadsheet1 中的所有数据进行完全计算。

Spreadsheet1.CalculateFull


Clear 方法

显示 Clear 方法应用于 ChartSpace 对象的情形。

删除图表工作区的所有图表，并将所有格式恢复为默认值。

expression.Clear

expression 该表达式返回一个 ChartSpace 对象。

显示 Clear 方法应用于 Range 对象的情形。

删除指定区域的所有格式和数据。

expression.Clear

expression 该表达式返回一个 Range 对象。

示例

显示 应用于 ChartSpace 对象的情形。

本示例删除指定图表工作区的所有图表。

ChartSpace1.Clear

显示 应用于 Range 对象的情形。

本示例清除 Spreadsheet1 中活动工作表上的 B2:C4 区域。

Spreadsheet1.ActiveSheet.Range("B2:C4").Clear


ClearContents 方法

删除指定区域的所有数据。

expression.ClearContents

expression 该表达式返回一个 Range 对象。

示例

本示例删除 Spreadhseet1 中活动工作表上 A4:B10 区域中的所有数据。

Spreadsheet1.ActiveSheet.Range("A4:B10").ClearContents


ClearFormats 方法

删除指定区域的所有格式。

expression.ClearFormats

expression 该表达式返回一个 Range 对象。

示例

本示例清除活动工作表上所有单元格的格式。

Spreadsheet1.ActiveSheet.Cells.ClearFormats


Collapse 方法

折叠指定节。

expression.Collapse

expression 该表达式返回一个 Section 对象。


Copy 方法

显示 Copy 方法应用于 Sheets、Worksheet 和 Worksheets 对象的情形。

将指定工作表复制到工作簿中的其他位置。

expression.Copy(Before, After)

expression 必需。该表达式返回上面对象之一。

Before Variant 类型，可选。在其之前放置复制工作表的工作表。如果指定了 After 则不能指定 Before。

After Variant 类型，可选。在其之后放置复制工作表的工作表。如果指定了 Before 则不能指定 After。

显示 Copy 方法应用于 Range 对象的情形。

将区域复制到 Destination 参数指定的单元格位置。如果省略 Destination 参数，区域将复制到“剪贴板”。

expression.Copy(Destination)

expression 必需。该表达式返回上面对象之一。

Destination Variant 类型，可选。指定将指定区域复制到的新区域。

显示 Copy 方法应用于 PivotTable 对象的情形。

将 PivotTable 对象复制到 Windows“剪贴板”。

expression.Copy(Selection)

expression 必需。该表达式返回一个 PivotTable 对象。

Selection Object 类型，可选。指定的选定内容。

示例

显示 应用于 Sheets、Worksheet 和 Sheets 对象的情形。

本示例复制 Sheet1 使其显示在工作表列表的末尾。

Sub CopySheet()

   ' Copy Sheet1.
   Spreadsheet1.Sheets("Sheet1").Copy  , _
      Spreadsheet1.Sheets(Spreadsheet1.Sheets.Count)

   ' Rename the new copy of Sheet1.
   Spreadsheet1.ActiveSheet.Name = "Copy of Sheet1"

End Sub

显示 应用于 Range 对象的情形。

本示例将 Sheet1 中的单元格 A1:B10 复制到以 Sheet2 中 A 列第一个空单元格开始的区域。

Sub CopyCells()

   Dim ssConstants
   Dim rngDest

   Set ssConstants = Spreadsheet1.Constants

   ' Set a variable to the first blank cell in column A of Sheet2.
   Set rngDest = Spreadsheet1.Sheets("Sheet2").Range("A262144").End(ssConstants.xlUp).Offset(1, 0)

   ' Copy cell2 A1:B10 of Sheet1 to the first blank cell in column A of Sheet2.
   Spreadsheet1.Sheets("Sheet1").Range("A1:B10").Copy rngDest

End Sub

应用于 PivotTable 对象的情形。

下例将 PivotTable1 的活动视图复制到一个新的 Microsoft Excel 工作表，打印该工作表，然后关闭 Excel。

Sub Copy_To_XL()
Dim xlApp
Dim XlBook

' Create a new instance of Excel.
Set xlApp = CreateObject("Excel.Application.11")

' Create a new workbook.
Set xlBook = xlApp.Workbooks.Add

' Copy the current view of the PivotTable.
PivotTable1.Copy PivotTable1.ActiveView

' Paste the PivotTable.
xlApp.ActiveSheet.Paste
' Format the columns.
xlApp.Selection.Columns.AutoFit
' Print the PivotTable.
xlApp.ActiveWindow.SelectedSheets.PrintOut 1

' Close the workbook.
xlBook.Close False

' Exit Excel.
xlApp.Quit

' Clean up variables.
Set xlBook = Nothing
Set xlApp = Nothing
End Sub


CopyFromRecordset 方法

将 ADO 或 DAO Recordset 对象中的内容复制到工作表，从指定区域的左上角开始。如果 Recordset 对象包含具有 OLE 对象的字段，则该方法无效。

expression.CopyFromRecordset(Data, MaxRows, MaxColumns)

expression 必需。该表达式返回一个 Range 对象。

Data Variant 类型，必需。要复制到指定区域的 Recordset 对象名称。

MaxRows Variant 类型，可选。复制到工作表上的最大记录数。如果忽略该参数，将复制 Recordset 对象中的所有记录。

MaxColumns Variant 类型，可选。复制到工作表上的最大字段数。如果忽略该参数，将复制 Recordset 对象中的所有字段。

说明

复制从 Recordset 对象的当前行开始。复制完成后，Recordset 对象的 EOF 属性为 True。

当该方法向工作表复制记录集时，如果指定的区域不足以容纳记录集的内容，则结果将截短。

示例

本示例将名为 rstAuthors 的记录集复制到 Spreadsheet1 中活动工作表上以单元格 A1 开始的区域。

Spreadsheet1.ActiveSheet.Cells.CopyFromRecordset rstAuthors


Cut 方法

剪切指定区域，并将其移动到“剪贴板”或粘贴到指定目标区域。

expression.Cut(Destination)

expression 该表达式返回一个 Range 对象。

Destination Variant 类型，可选。如果不指定该参数，则将指定区域放置到“剪贴板”。如果该参数为 Range 对象，则将源区域移动到指定区域。

示例

本示例将活动工作表上单元格 A3 中的公式、数据和格式移动到单元格 G7。

Sub MoveCell()
    Dim shtSource

    Set shtSource = Spreadsheet1.ActiveSheet

    ' Move the contents of cell A3 to cell G7.
    shtSource.Range("A3").Cut shtSource.Range("G7")
End Sub


Delete 方法

显示 Delete 方法应用于 Hyperlink、ListRow、Name、PivotHyperlink、Sheets、Worksheet、Worksheets、XmlDataBinding 和 XmlMap 对象的情形。

删除指定对象。

expression.Delete()

expression 该表达式返回上面列出的对象之一。

说明

如果在异步绑定进行过程中对 XmlDataBinding 或 XmlMap 对象调用 Delete 方法，则会发生运行时错误。您可以用 XmlDataBinding 对象的 Async 属性确定数据绑定是否为异步。可以用 XmlDataBinding 对象的 BindingInProgress 属性确定绑定是否正在进行。

在不删除相关绑定的情况下对 XmlMap 对象调用 Delete 方法会生成运行时错误。若要避免此错误，您必须先对代表相关绑定的 XmlDataBinding 对象调用 Delete 方法。

显示 Delete 方法应用于 ChAxes、ChCharts、ChSeriesCollection、ElementExtensions、GroupingDefs、GroupLevels、LookupRelationships、PageFields、ParameterValues、RecordsetDefs、SchemaFields、SchemaRelationships、SchemaRowsources 和 SublistRelationships 对象的情形。

从指定集合中删除单个对象。

expression.Delete(Index)

expression 该表达式返回上面列出的对象之一。

Index Variant 类型，必需。指定要删除的对象名称或编号。

显示 Delete 方法应用于 ChDataLabelsCollection、ChErrorBarsCollection、ChSegments 和 ChTrendlines 对象的情形。

从指定集合中删除单个对象。

expression.Delete(Index)

expression 该表达式返回上面列出的对象之一。

Index Long 类型，必需。指定要删除的对象名称或编号。

显示 Delete 方法应用于 Range 对象的情形。

从工作表中删除指定单元格。

expression.Delete(Shift)

expression 该表达式返回上面列出的对象之一。

Shift Variant 类型，可选。指定如何调整单元格以替换删除的单元格。可以为下列 XlDeleteShiftDirection 常量之一：xlShiftToLeft 或 xlShiftUp。如果省略该参数，Microsoft Excel 将根据区域的形状确定调整方式。

示例

显示 应用于 ChDataLabelsCollection 集合的情形。

本示例从图表工作区中的指定系列删除数据标志。

ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection.Delete 0


DeleteCustomGroupMember 方法

从自定义分组字段中删除一个成员。

expression.DeleteCustomGroupMember(CustomGroupMember)

expression 必需。该表达式返回一个 PivotField 对象。

CustomGroupMember Variant 类型，必需。要删除的成员名称、唯一名称或引用。

说明

如果 CustomGroupMember 参数引用的成员不是自定义分组字段中的成员，该方法将返回一个运行时出错。


DeleteField 方法

从指定字段集中删除由 AddCalculatedField 或 AddCustomGroupField 方法创建的计算字段。

expression.DeleteField(Field)

expression 必需。该表达式返回一个 PivotFieldSet 对象。

Field Variant 类型，必需。字段集中计算字段的名称、唯一名称或引用。


DeleteFieldSet 方法

删除使用 AddFieldSet 方法创建的字段集。该字段集将从数据透视表视图和 PivotFieldSets 集合中删除。

expression.DeleteFieldSet(FieldSet)

expression 必需。该表达式返回一个 PivotView 对象。

FieldSet Variant 类型，必需。自定义字段集的名称或引用。

示例

下列代码行从 PivotTable1 中删除名为“Variance”的自定义字段集。

PivotTable1.ActiveView.DeleteFieldSet "Variance"


DeleteRecord 方法

从指定的数据访问页删除一条记录。

expression.DeleteRecord

expression 该表达式返回一个 DataPage 对象。


DeleteTotal 方法

从 PivotTotals 集合中删除一个 PivotTotal 对象。只能删除用户定义的总计。

expression.DeleteTotal(Total)

expression 该表达式返回一个 PivotView 对象。

Total Variant 类型，必需。指定总计的名称或数值。

示例

本示例从 PivotTable1 中删除名为“Total Budget”的总计。

Sub Delete_Total()
    Dim vwView

    Set vwView = PivotTable1.ActiveView

    ' Delete the total named "Total Budget."
    vwView.DeleteTotal vwView.Totals("Total Budget")
End Sub


DrawEllipse 方法

在指定图表上绘制一个椭圆。使用 Border 和 Interior 属性的当前设置确定新椭圆的这些属性。

expression.DrawEllipse(Left, Top, Right, Bottom)

expression 必需。该表达式返回一个 ChChartDraw 对象。

Left Long 类型，必需。椭圆左边界的像素坐标。

Top Long 类型，必需。椭圆上边界的像素坐标。

Right Long 类型，必需。椭圆右边界的像素坐标。

Bottom Long 类型，必需。椭圆下边界的像素坐标。

示例

本示例使用 BeforeRender 事件取消 Chartspace1 中第一张图表绘图区和网格线的绘制，然后在图表着色后 AfterRender 事件在绘图区绘制一个椭圆。

Private Sub ChartSpace1_BeforeRender(chartObject, Cancel)

    Select Case TypeName(chartObject)

        Case "ChGridlines"

            ' Cancel the drawing of the gridlines.
            Cancel.Value = True

        Case "ChPlotArea"

            ' Cancel the drawing of the plot area.
            Cancel.Value = True

    End Select

End Sub

Private Sub ChartSpace1_AfterRender(drawObject, chartObject)

    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Check to see if the chart has been rendered.
    If TypeName(chartObject) = "ChChart" Then

        ' The next three lines of code set the interior
        ' and border properties of the ellipse.
        drawObject.Interior.SetPresetGradient _
               chConstants.chGradientHorizontal, _
               chConstants.chGradientVariantStart, _
               Int((24 - 1 + 1) * Rnd + 1)
        drawObject.Border.Weight = 1
        drawObject.Border.Color = "black"

        ' Begin the drawing object.
        drawObject.BeginObject 1

        ' Draw the ellipse.
        drawObject.DrawEllipse chartObject.Left, chartObject.Bottom, _
                               chartObject.Right, chartObject.Top

        drawObject.EndObject

    End If

End Sub


DrawLine 方法

在指定图表上绘制线条。使用 Line 属性的当前设置确定新线条的属性。

expression.DrawLine(x0, y0, x1, y1)

expression 必需。该表达式返回一个 ChChartDraw 对象。

x0 Long 类型，必需。X 平面的起始像素坐标。

y0 Long 类型，必需。Y 平面的起始像素坐标。

x1 Long 类型，必需。X 平面的终止像素坐标。

y1 Long 类型，必需。Y 平面的终止像素坐标。

示例

本示例演示如何联合使用 BeforeRender 和 AfterRender 事件创建自定义网格线。BeforeRender 事件取消网格线着色，AfterRender 事件绘制自定义网格线。

Sub ChartSpace1_BeforeRender(chartObject, Cancel)

    ' Check to see if the next object to be rendered
    ' is a gridline.
    If TypeName(chartObject) = "ChGridlines" Then

        ' Cancel the rendering of gridlines.
        Cancel.Value = True

    End If

End Sub

Sub ChartSpace1_AfterRender(drawObject, chartObject)

    Dim chChart1
    Dim plPlotArea
    Dim lLeft
    Dim lRight
    Dim lHeight
    Dim lTop
    Dim lIncrement
    Dim chConstants
    Dim iCtr

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the first chart in Chartspace1.
    Set chChart1 = ChartSpace1.Charts(0)

    ' Set a variable to the plot area of the chart.
    Set plPlotArea = chChart1.PlotArea

    ' Check to see if the rendered object is a gridline.
    If TypeName(chartObject) = "ChGridlines" Then

        ' The next four lines of code use the extents of
        ' the plot area to calculate the dimensions of the line.
        ' to be drawn.
        lLeft = plPlotArea.Left
        lTop = plPlotArea.Top
        lRight = plPlotArea.Right
        lHeight = plPlotArea.Bottom - lTop

        ' Determine the increment to use between gridlines.
        ' Change the divisor to adjust the increment.
        lIncrement = lHeight / 10

        ' The next three lines of code set the properties of the
        ' line to be drawn.
        drawObject.Line.DashStyle = chConstants.chLineRoundDot
        drawObject.Line.Color = "Green"
        drawObject.Line.Weight = chConstants.owcLineWeightMedium

        For iCtr = 1 To 9

            ' Draw the line.
            drawObject.DrawLine lLeft, lTop + iCtr * lIncrement, _
                                lRight, lTop + iCtr * lIncrement

        Next

    End If

End Sub


DrawPolygon 方法

在图表上绘制多边形。多边形的点由描述多边形线段的 X 和 Y 值数组指定。使用 Border 和 Interior 属性的当前设置确定新多边形的属性。

expression.DrawPolygon(xValues, yValues)

expression 必需。该表达式返回一个 ChChartDraw 对象。

xValues Variant 类型，必需。该数组包含用于计算多边形的 X 值。

yValues Variant 类型，必需。该数组包含用于计算多边形的 Y 值。

示例

本示例使用 BeforeRender 事件取消图表标题着色，并使用 AfterRender 事件以多边形替换图表标题。

Private Sub ChartSpace1_BeforeRender(chartObject,Cancel)

    If TypeName(chartObject) = "ChTitle" Then
            Cancel.Value = True
    End If

End Sub

Sub ChartSpace1_AfterRender(drawObject, chartObject)

    Dim alXValues(9)
    Dim alYValues(9)
    Dim chConstants
    Dim iCutoff

    iCutoff = 20

    Set chConstants = ChartSpace1.Constants

    If TypeName(chartObject) = "ChTitle" Then

        ' Set the array containing the x values for
        ' the line.
        alXValues(0) = chartObject.Left + iCutoff
        alXValues(1) = chartObject.Right - iCutoff
        alXValues(2) = chartObject.Right
        alXValues(3) = chartObject.Right
        alXValues(4) = chartObject.Right - iCutoff
        alXValues(5) = chartObject.Left + iCutoff
        alXValues(6) = chartObject.Left
        alXValues(7) = chartObject.Left
        alXValues(8) = chartObject.Left + iCutoff

        ' Set the array containing the y values for
        ' the line.
        alYValues(0) = chartObject.Top
        alYValues(1) = chartObject.Top
        alYValues(2) = chartObject.Top + iCutoff
        alYValues(3) = chartObject.Bottom - iCutoff
        alYValues(4) = chartObject.Bottom
        alYValues(5) = chartObject.Bottom
        alYValues(6) = chartObject.Bottom - iCutoff
        alYValues(7) = chartObject.Top + iCutoff
        alYValues(8) = chartObject.Top

        ' Set the properties for the polygon.
        drawObject.Interior.SetTwoColorGradient chConstants.chGradientFromCenter, _
                                  chConstants.chGradientVariantStart, "Red", "Green"

        ' Draw the polygon.
        drawObject.DrawPolygon alXValues, alYValues

    End If

End Sub


DrawPolyLine 方法

绘制包含多个线段的线条。线条的点由描述线条线段的 X 和 Y 值数组指定。使用 Line 属性的当前设置确定新线条的属性。

expression.DrawPolyLine(xValues, yValues)

expression 必需。该表达式返回一个 ChChartDraw 对象。

xValues Variant 类型，必需。该数组包含用于计算线条的 X 值。

yValues Variant 类型，必需。该数组包含用于计算线条的 Y 值。

示例

本示例使用 AfterRender 事件在 Chartspace1 周围绘制自定义边框。

Sub ChartSpace1_AfterRender(drawObject, chartObject)

    Dim alXValues(9)
    Dim alYValues(9)
    Dim iCutOff
    Dim chConstants

    iCutOff = 10

    Set chConstants = ChartSpace1.Constants

    If TypeName(chartObject) = "ChChart" Then

        ' Set the array containing the x values for
        ' the line.
        alXValues(0) = chartObject.Left + iCutOff
        alXValues(1) = chartObject.Right - iCutOff
        alXValues(2) = chartObject.Right
        alXValues(3) = chartObject.Right
        alXValues(4) = chartObject.Right - iCutOff
        alXValues(5) = chartObject.Left + iCutOff
        alXValues(6) = chartObject.Left
        alXValues(7) = chartObject.Left
        alXValues(8) = chartObject.Left + iCutOff

        ' Set the array containing the y values for
        ' the line.
        alYValues(0) = chartObject.Top
        alYValues(1) = chartObject.Top
        alYValues(2) = chartObject.Top + iCutOff
        alYValues(3) = chartObject.Bottom - iCutOff
        alYValues(4) = chartObject.Bottom
        alYValues(5) = chartObject.Bottom
        alYValues(6) = chartObject.Bottom - iCutOff
        alYValues(7) = chartObject.Top + iCutOff
        alYValues(8) = chartObject.Top

        ' Set the properties for the line.
        drawObject.Line.Color = "blue"
        drawObject.Line.Weight = chConstants.owcLineWeightThick
        drawObject.Line.DashStyle = chConstants.chLineLongDashDot

        ' Draw the line.
        drawObject.DrawPolyLine alXValues, alYValues

    End If

End Sub


DrawRectangle 方法

在图表上绘制矩形。使用 Border 和 Interior 属性的当前设置确定新矩形的属性。

expression.DrawRectangle(Left, Top, Right, Bottom)

expression 必需。该表达式返回一个 ChChartDraw 对象。

Left Long 类型，必需。矩形左边的像素坐标。

Top Long 类型，必需。矩形上边的像素坐标。

Right Long 类型，必需。矩形右边的像素坐标。

Bottom Long 类型，必需。矩形下边的像素坐标。

示例

本示例使用 AfterRender 事件绘制矩形，替换 Chartspace1 中第一张图表的图例项。

Sub ChartSpace1_AfterRender(drawObject, chartObject)

    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    If TypeName(chartObject) = "ChLegendEntry" Then

        ' Set the interior of the rectangle to a preset texture.
        ' You could substitute a URL to a custom graphic
        ' for the texture.
        drawObject.Interior.SetTextured chConstants.chTextureSand

        ' Begin drawing the rectangle.
        drawObject.BeginObject 1

        ' Draw the rectangle.
        drawObject.DrawRectangle chartObject.Left, chartObject.Top, _
                                 chartObject.Right, chartObject.Bottom

        drawObject.EndObject

    End If

End Sub


DrawText 方法

在图表上绘制文本字符串。

expression.DrawText(bstrText, Left, Top)

expression 必需。该表达式返回一个 ChChartDraw 对象。

bstrText String 类型，必需。要在图表上绘制的文本。

Left Long 类型，必需。文本左边的像素坐标。

Top Long 类型，必需。文本上边的像素坐标。

示例

本示例在每次重绘图表时在绘图区左上角添加一个文本字符串。

Sub ChartSpace1_AfterRender(drawObject, chartObject)

    Dim chChart1

    Set chChart1 = ChartSpace1.Charts(0)

    ' After the legend has been rendered, then add the text
    ' to the chart.
    If TypeName(chartObject) = "ChLegend" Then
        drawObject.DrawText "2000 Sales", chChart1.PlotArea.Left + 5, _
                            chChart1.PlotArea.Top
    End If

End Sub


DropZones 方法

返回一个 ChDropZone 对象。使用返回对象的属性设置放置区的格式。

expression.DropZones(dz)

expression 必需。该表达式返回一个 Chartspace 对象。

dz ChartDropZonesEnum 类型，必需。表示要设置格式的放置区。

ChartDropZonesEnum 可以为下列 ChartDropZonesEnum 常量之一。
chDropZoneCategories
chDropZoneCharts
chDropZoneData
chDropZoneFilter
chDropZoneSeries

示例

本示例将设置 Chartspace1 中系列放置区的按钮和水印格式。

Sub SetupDropZone()

    Dim dzSeriesDropZone
    Dim chConstants

    Set chConstants = Chartspace1.Constants

    ' Set a variable to the series drop zone in Chartspace1.
    Set dzSeriesDropZone = ChartSpace1.DropZones(chConstants.chDropZoneSeries)

    ' The next three lines of code format the button of the drop zone.
    dzSeriesDropZone.ButtonBorder.Weight = chConstants.owcLineWeightMedium
    dzSeriesDropZone.ButtonInterior.SetSolid "Red"
    dzSeriesDropZone.ButtonFont.Size = 14

    ' The next three lines of code format the watermark of the drop zone.
    dzSeriesDropZone.WatermarkBorder.Color = "Red"
    dzSeriesDropZone.WatermarkFont.Color = "Red"
    dzSeriesDropZone.WatermarkInterior.SetSolid "Green"

End Sub


DuplicateFormat 方法

将指定图表的格式和类型复制到工作区中绑定到同一数据源的其他图表。该方法只适用于绑定到关系数据源列表的图表控件。

expression.DuplicateFormat

expression 必需。该表达式返回一个 ChChart 对象。

说明

在使用该方法之前，必须将图表控件的 HasMultipleCharts 属性设置为 True。

示例

本示例将 Chartspace1 中第一张图表的格式复制到 Chartspace1 中所有绑定到同一数据透视表列表的其他图表。

Chartspace1.Charts(0).DuplicateFormat


EndEdit 方法

将活动单元格脱离编辑模式。

expression.EndEdit(Accept)

expression 必需。该表达式返回一个 PivotTable 对象。

Accept Boolean 类型，可选。指定是否接受当前值。将该参数设置为 False 将放弃明细单元格中的任何更改，并还原为原值。默认值为 True。


EndObject 方法

结束指定 ChChartDraw 对象的绘制序列。

expression.EndObject

expression 必需。该表达式返回一个 ChChartDraw 对象。

示例

本示例使用 BeforeRender 事件取消 Chartspace1 中第一张图表绘图区和网格线的绘制，然后在图表着色后 AfterRenderEvent 事件在绘图区绘制一个椭圆。

Private Sub ChartSpace1_BeforeRender(chartObject, Cancel)

    Select Case TypeName(chartObject)

        Case "ChGridlines"

            ' Cancel the drawing of the gridlines.
            Cancel.Value = True

        Case "ChPlotArea"

            ' Cancel the drawing of the plot area.
            Cancel.Value = True

    End Select

End Sub

Private Sub ChartSpace1_AfterRender(drawObject, chartObject)

    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Check to see if the chart has been rendered.
    If TypeName(chartObject) = "ChChart" Then

        ' The next three lines of code set the interior
        ' and border properties of the ellipse.
        drawObject.Interior.SetPresetGradient _
               chConstants.chGradientHorizontal, _
               chConstants.chGradientVariantStart, _
               Int((24 - 1 + 1) * Rnd + 1)
        drawObject.Border.Weight = 1
        drawObject.Border.Color = "black"

        ' Begin the drawing object.
        drawObject.BeginObject 1

        ' Draw the ellipse.
        drawObject.DrawEllipse chartObject.Left, chartObject.Bottom, _
                               chartObject.Right, chartObject.Top

        drawObject.EndObject

  End If

End Sub


EndUndo 方法

指定撤消块的结束。这意味着从该调用到与其相对应的 BeginUndo 方法调用之间的所有语句均可在对 Undo 方法的一次调用中撤消。这样可以将整个宏合并为一个语句，以便于撤消。撤消块可以嵌套。

expression.EndUndo

expression 该表达式返回一个 ChartSpace 或 Spreadsheet 对象。

示例

本示例创建包含设置单元格 D10 数字格式和字体代码的撤消块。单击 Spreadsheet1 工具栏上的“撤消”按钮可撤消所有格式设置。

Sub UndoBlock()
    Dim rngCurrent

    ' Enable undo.
    Spreadsheet1.EnableUndo = True

    ' Start an undo block.
    Spreadsheet1.BeginUndo

        Set rngCurrent = Spreadsheet1.Worksheets("sheet1").Range("D10")

        ' The following three lines of code apply
        ' various formatting to cell D10.
        rngCurrent.NumberFormat = "0.###"
        rngCurrent.Font.Color = "Blue"
        rngCurrent.Font.Name = "Times New Roman"

    ' End the undo block.
    Spreadsheet1.EndUndo
End Sub


EuroConvert 方法

可以使用 EuroConvert 方法将数字转换为欧元或将欧元转换为参与货币。还可将欧元作为中间量，使用该方法将数字从一种参与货币转换为另一种参与货币。EuroConvert 方法使用欧盟委员会制定的固定兑换汇率。返回一个 Double 类型值。

expression.euro Convert(Number, SourceCurrency, TargetCurrency, FullPrecision, TriangulationPrecision)

expression 必需。该表达式返回“应用于”列表中的对象之一。

Number Double 类型，必需。要转换的数字。

SourceCurrency String 类型，必需。字符串表达式或对包含字符串的字段的引用，对应于国际标准化组织 (ISO) 为要转换的货币指定的缩写。可以为下表列出的 ISO 代码之一。

货币 | ISO 代码 | 计算精度 | 显示精度
比利时法郎 | BEF | 0 | 0
卢森堡法郎 | LUF | 0 | 0
德国马克 | DEM | 2 | 2
西班牙比塞塔 | ESP | 0 | 0
法国法郎 | FRF | 2 | 2
爱尔兰镑 | IEP | 2 | 2
意大利里拉 | ITL | 0 | 0
荷兰盾 | NLG | 2 | 2
奥地利先令 | ATS | 2 | 2
葡萄牙埃斯库多 | PTE | 1 | 2
芬兰马克 | FIM | 2 | 2
欧元 | EUR | 2 | 2
在前表中，计算精度确定对转换货币结果进行四舍五入的货币单位。例如，在转换德国马克时计算精度为 2，结果将向最接近的芬尼四舍五入，100 芬尼为 1 马克。显示精度确定结果字段中显示的小数位数。

EuroConvert 方法的更新版本可支持其他货币。

货币 | ISO 代码
丹麦克朗 | DKK
德拉克马 | GRD
瑞典克朗 | SEK
英镑 | GBP

TargetCurrency String 类型，必需。三字符的字符串，对应于要转换的数字的 ISO 货币代码。请参阅前表中的 ISO 代码。要获取 ISO 代码列表，请参阅 SourceCurrency 参数说明。

FullPrecision Variant 类型，可选。逻辑值（True 或 False）或者将计算出 True 或 False 值的表达式，指定结果的显示方式。

请使用 | 如果要
False | 以货币专用四舍五入规则显示结果。（请参阅 SourceCurrency 参数说明中的表格）计算精度值用于计算结果，显示精度值用于显示结果。如果省略 FullPrecision 参数，则默认值为 False。
True | 以计算返回的所有有效位数显示结果。

TriangulationPrecision Variant 类型，可选。大于等于 3 的值，指定在两国货币转换中欧元中间量的计算精度有效位数。

说明

尾部零将截短，无效参数将返回 #Error。

如果源 ISO 代码与目标 ISO 代码相同，则返回数字的原值。

该方法不应用格式。

EuroConvert 方法使用欧盟委员会制定的当前汇率。如果汇率发生更改，Microsoft 将更新该方法。要获得当前生效的规则和汇率信息，请参阅欧盟委员会关于欧元的公告。

示例

本示例将 UnitPrice 字段的值从法国法郎转换为欧元。

Dub ConvertToEuros()

   Dim dblSourceNum
   Dim dblConvertedNum

   ' Set a variable to the UnitPrice field.
   dblSourceNum = Document.All("unitprice").Value

   ' Convert the UnitPrice from French francs to euros.
   dblConvertedNum = MSODSC.EuroConvert(dblsourcenum,"FRF","EUR",False,3)

   ' Place the converted value in the EuroValue field.
   Document.All("EuroValue").Value = dblConvertedNum

End Sub


Evaluate 方法

计算文本形式的表达式并返回结果。表达式可以包括函数、关键词或 Spreadsheet Component 可以解析的其他语法的任意组合。

expression.Evaluate(Expression)

expression 必需。该表达式返回“应用于”列表中的对象之一。

Expression Variant 类型，必需。要计算的表达式。

说明

该方法可使用下列 Microsoft Excel 名称类型：

  • A1-样式的引用。可以通过 A1-样式符号引用单个单元格。所有引用均视为绝对引用。
  • 区域。在引用中可以使用区域、交集和并集运算符（分别为冒号、空格和逗号）。
  • 定义的名称。在宏语言中可以指定任何名称。

示例

本示例使用 Evaluate 方法计算一个角度的余切。

Function CalcCotangent(sngAngleInDegrees)

    Dim strExpression

    ' Put together the expression to calculate the cotangent
    ' of the angle.
    strExpression = "1/TAN(" & sngAngleInDegrees & "*PI()/180)"

    ' Evaluate the string and return the result.
    CalcCotangent = Spreadsheet1.ActiveSheet.Evaluate(strExpression)

End Function


Execute 方法

显示 Execute 方法应用于 DataSourceControl 对象的情形。

返回一个 Recordset 对象，表示记录集定义或分组定义的结果记录集。如果记录集为章节记录集层次结构的一部分，则数据源控件创建整个层次结构并从中返回请求的记录集。

expression.Execute(RecordsetName, ExecuteOption, FetchType)

expression 该表达式返回一个 DataSourceControl 对象。

RecordsetName String 类型，必需。记录集定义或分组定义的名称。

ExecuteOption ADO ExecuteOptionEnum 类型，可选。指定查询的执行方式。默认值为 adOptionUnspecified。

FetchType dscFetchTypeEnum 类型，可选。如果指定记录集定义包含子列表的子记录集定义，将该参数设置为 dscFull 将导致在调用 Execute 方法时提取所有记录。如果不指定该参数或设置为 dscParameterized，仅在打开指定父记录集的子记录集时提取子记录集中的记录。例如，如果 Customers 父记录集具有 Orders 子记录集，并且该参数设置为 dscFull，在运行时将返回全部客户的所有记录。如果将该参数设置为 dscParameterized，Customer ID 为 'ANTAR' 的客户记录集仅在 Customers 记录集定位于该 Customer ID 并且打开 Orders 子记录集时提取。

显示 Execute 方法应用于 OCCommand 对象的情形。

执行指定命令。

expression.Execute( )

expression 该表达式返回一个 OCCommand 对象。


Expand 方法

展开指定节。

expression.Expand

expression 该表达式返回一个 Section 对象。


Export 方法

显示 Export 方法应用于 PivotTable 对象的情形。

将指定数据透视表列表保存为文件，并可选择在 Microsoft Excel 中打开。

expression.Export(Filename, Action)

expression 该表达式返回一个 PivotTable 对象。

Filename String 类型，可选。指定保存文件的文件名。如果不指定该参数，将在用户临时文件夹中创建临时文件（临时文件夹的位置因操作系统而异）。

Action PivotExportActionEnum 类型。指定将数据透视表列表保存为文件后进行的操作。如果不指定该参数，将在 Excel 中打开数据透视表列表。如果用户计算机上没有安装 Excel，则显示警告。

PivotExportActionEnum 可以为下列 PivotExportActionEnum 常量之一。
plExportActionNone
plExportActionOpenInExcel 默认值

显示 Export 方法应用于 Spreadsheet 对象的情形。

expression.Export(Filename, Action, Format)

expression 该表达式返回一个 Spreadsheet 对象。

Filename String 类型，可选。指定保存文件的文件名。如果不指定该参数，将在用户临时文件夹中创建临时文件（临时文件夹的位置因操作系统而异）。如果 Action 参数设置为 ssExportActionNone，则必须指定该参数。

Action SheetExportActionEnum 类型，可选。指定是否将工作表保存为文件。如果不指定该参数，则在 Microsoft Excel 中打开工作表。如果用户计算机上没有安装 Excel，则显示警告。

SheetExportActionEnum 可以为下列 SheetExportActionEnum 常量之一。
ssExportActionNone
ssExportActionOpenInExcel 默认值

Format SheetExportFormat 类型，可选。指定导出电子表格时所用的格式。

SheetExportActionEnum 可以为下列 SheetExportActionEnum 常量之一。
ssExportAsAppropriate 默认值
ssExportHTML

ssExportXMLSpreadsheet

示例

显示 应用于 Spreadsheet 对象的情形。

本示例将活动工作表导出为指定文件。

Sub ExportSpreadsheet()

    Dim ssConstants

    Set ssConstants = Spreadsheet1.Constants

    Spreadsheet1.Export "ssheet1.htm", ssConstants.ssExportActionNone, _
        ssConstants.ssExportXMLSpreadsheet

End Sub


ExportMetaData 方法

使用此方法可返回一个包含 <pagingInfo> 标记的 Variant (String) 变量，此标记来自数据检索服务对最近绑定刷新操作的查询响应。

expression.ExportMetaData(ShowDialogs)

expression 必需。返回“应用于”列表中的一个对象的表达式。

ShowDialogs Boolean 类型，可选。指定在 ExportMetaData 方法遇到电子表格组件自身返回的错误时，是否显示对话框。当 ShowDialogs 设为 True 时，如果 ExportMetaData 方法遇到电子表格组件返回的错误，将显示对话框。当 ShowDialogs 设为 False 时，则不会为电子表格组件错误显示对话框。默认值为 False。

注释 ShowDialogs 参数并不控制是否为电子表格组件之外的错误（例如脚本创作组件返回的错误）显示对话框。若要阻止为电子表格组件之外的错误显示对话框，您必须在脚本中捕获这些错误。

说明

<pagingInfo> 标记并不始终显示在查询响应中。如果没有显示此标记，则 ExportMetaData 方法将返回一个空 String。


ExportPicture 方法

以图像文件保存指定图表工作区或数据透视表列表。

expression.ExportPicture(FileName, FilterName, Width, Height)

expression 该表达式返回一个 ChartSpace 或 PivotTable 对象。

FileName String 类型，可选。指定保存的文件名。如果不指定该参数，对于图表工作区默认文件名为“Chart.gif”，对于数据透视表列表为“Pivot.gif”。

FilterName String 类型，可选。指定所用的图形过滤器名称。支持的文件名为 GIF、JPG 和 PNG。默认值为 GIF。

Width Long 类型可选。以像素为单位指定图像的宽度。必须为服务器侧的图表指定该参数。

Height Long 类型可选。以像素为单位指定图像的高度。必须为服务器侧的图表指定该参数。

示例

本示例将图表工作区保存为图像文件。

ChartSpace1.ExportPicture "sales.gif", "gif", 320, 240


ExportXML 方法

显示 应用于 DataSourceControl 对象的情形。

将当前记录集保存为 XML 文件。

expression.ExportXML(eEncoding)

expression 必需。返回一个 DataSourceControl 对象的表达式。

eEncoding DscEncodingEnum 类型，可选。架构信息的导出格式。如果省略该参数，则架构信息将嵌入到数据文档中。

DscEncodingEnum 可以为下列 DscEncodingEnum 常量之一。
dscUTF16
dscUTF8 默认值

说明

使用 XMLLocation 属性可设置数据是导出为 XML 数据岛还是独立的 XML 数据文件。使用 XMLDataTarget 属性可指定导出数据所用的路径或 ID。

显示 应用于 XmlMap 对象的情形。

将指定架构映射中的数据保存为 XML 数据流。

expression.ExportXML(ShowDialogs)

expression 必需。返回一个 XmlMap 对象的表达式。

ShowDialogs Boolean 类型，可选。指定在 ExportXML 方法遇到电子表格组件自身返回的错误时，是否显示对话框。当 ShowDialogs 设为 True 时，如果 ExportXML 方法遇到电子表格组件返回的错误，则显示对话框。当 ShowDialogs 设为 False 时，则不会为电子表格组件错误显示对话框。默认值为 False。

注释 ShowDialogs 参数并不控制是否为电子表格组件之外的错误（例如脚本创作组件返回的错误）显示对话框。若要阻止为电子表格组件之外的错误显示对话框，您必须在脚本中捕获这些错误。

说明

如果在异步绑定进行过程中对 XmlMap 对象调用 ExportXml 方法，则会发生运行时错误。您可以用 XmlDataBinding 对象的 Async 属性确定数据绑定是否为异步。可以用 XmlDataBinding 对象的 BindingInProgress 属性确定绑定是否正在进行。

示例

显示 应用于 DataSourceControl 对象的情形。

本示例将名为 MSODSC 的数据源控件中的当前数据导出为 XML 数据文件。

Sub ExportData()

   Dim dscConstants

   Set dscConstants = MSODSC.Constants

   ' Set the location of the XML data to a data file.
   MSODSC.XMLLocation = dscConstants.dscXMLDataFile

   ' Set the specific target to export to.
   MSODSC.XMLDataTarget = "Q1 Sales Analysis.xml"

   ' Export the current data.
   MSODSC.ExportXML

End Sub


FillDown 方法

从顶部单元格开始向下填充指定区域。第一行单元格的内容和格式将复制到区域中的其他行。

expression.FillDown

expression 必需。该表达式返回一个 Range 对象。

示例

本示例以单元格 A1 中的内容填充活动工作表上的区域 A1:A10。

Spreadsheet1.ActiveSheet.Range("A1:A10").FillDown


FillRight 方法

从最左侧开始向右填充指定区域。最左侧列中单元格的内容和格式将复制到区域中的其他列。

expression.FillRight

expression 必需。该表达式返回一个 Range 对象。

示例

本示例将以单元格 A1 中的内容填充活动工作表上的区域 A1:M1。

Spreadsheet1.ActiveSheet.Range("A1:M1").FillRight


Find 方法

在指定区域中查找指定信息，并返回表示第一个找到该信息的单元格的 Range 对象。如果没有找到匹配项，则返回 Nothing。该操作不影响选定内容活动单元格。

expression.Find(What, After, LookIn, LookAt, SearchOrder, SearchDirection, MatchCase, MatchByte)

expression 该表达式返回一个 Range 对象。

What Variant 类型，必需。要搜索的数据。

After Variant 类型，可选。指定从其后开始搜索的单个单元格。对应于搜索完成后用户界面的活动单元格位置。请记住搜索从该单元格之后 开始，指定单元格直到该方法返回该单元格才进行搜索。如果不指定该参数，则搜索从区域的左上角单元格后面开始。

LookIn XlFindLookIn 类型，可选。指定搜索公式还是显示的值。

XlFindLookIn 可以为下列 XlFindLookIn 常量之一。
xlFormulas
xlValues

LookAt XlLookAt 类型，可选。将该参数设置为 xlWhole 会强制单元格的整个内容完全与 What 参数的内容相匹配。

XlLookAt 可以为下列 XlFindLookAt 常量之一。
xlPart
xlWhole

SearchOrder XlSearchOrder 类型，可选。指定按列还是按行搜索。

XlSearchOrder 可以为下列 XlSearchOrder 常量之一。
xlByColumns
xlByRows

SearchDirection XlSearchDirection 类型，可选。指定搜索方向。

XlSearchDirection 可以为下列 XlSearchDirection 常量之一。
xlNext
xlPrevious

MatchCase Boolean 类型，可选。设置为 True，则使搜索区分大小写。默认值为 False。

MatchByte Variant 类型，可选。只适用于已经选择或安装了双字节语言支持的场合。设置为 True 可使双字节只与双字节匹配。设置为 False 可使双字节可与等效单字节匹配。

示例

本示例查找区域 A1:F10 中所有出现“Mike”的单元格，并加粗这些单元格。

Sub Find_Mike()
    Dim ssConstants
    Dim rngFindRange
    Dim rngFoundCell
    Dim rngFirstFound

    Set ssConstants = Spreadsheet1.Constants

    ' Set a variable to the range to search.
    Set rngFindRange = Spreadsheet1.Sheets("Sheet1").Range("A1:F10")

    ' Find the first occurrence of Mike.
    Set rngFoundCell = rngFindRange.Find("Mike", rngFindRange.Cells(1, 1), _
                    ssConstants.xlValues, ssConstants.xlPart)

    ' If Mike was found...
    If Not rngFoundCell Is Nothing Then

        ' Set a variable to the first found instance.
        Set rngFirstFound = rngFoundCell

        Do
            ' Set the font to bold.
            rngFoundCell.Font.Bold = True

            'Find the next occurrence of Mike.
            Set rngFoundCell = rngFindRange.FindNext(rngFoundCell)

        ' Loop until you return to the first occurrence of Mike.
        Loop Until rngFoundCell.Address = rngFirstFound.Address
    End If
End Sub


FindNext 方法

继续由 Find 方法开始的搜索。查找匹配相同条件的下一个单元格，并返回表示该单元格的 Range 对象。该操作不影响选定内容和活动单元格。

expression.FindNext(After)

expression 必需。该表达式返回一个 Range 对象。

After Variant 类型，可选。从单元格之后开始搜索。对应于用户界面中活动单元格的位置。请注意 After 必须为区域中的单个单元格。请记住搜索从该单元格之后 开始，活动单元格本身直到 FindNext 方法返回该单元格才进行搜索。如果不指定该参数，则搜索从区域的左上角单元格后面开始。

示例

本示例查找 Sheet1 中所有出现“Mike”的单元格，并加粗这些单元格。

Sub FindMike()

    Dim ssConstants
    Dim rngFindRange
    Dim rngFoundCell
    Dim rngFirstFound

    Set ssConstants = Spreadsheet1.Constants

    ' Set a variable to the range to search.
    Set rngFindRange = Spreadsheet1.Sheets("Sheet1").UsedRange

    ' Find the first ocurence of Mike.
    Set rngFoundCell = rngFindRange.Find("Mike", rngFindRange.Cells(1, 1), _
                       ssConstants.xlValues, ssConstants.xlPart)

    ' If Mike was found...
    If Not rngFoundCell Is Nothing Then

        ' Set a variable to the first found instance.
        Set rngFirstFound = rngFoundCell

        Do
            ' Set the font to bold.
            rngFoundCell.Font.Bold = True

            'Find the next occurrence of Mike.
            Set rngFoundCell = rngFindRange.FindNext(rngFoundCell)

        ' Loop until you return to the first occurrence of Mike.
        Loop Until rngFoundCell.Address = rngFirstFound.Address

    End If

End Sub


FindPrevious 方法

继续由 Find 方法开始的搜索。查找匹配相同条件的上一个单元格，并返回表示该单元格的 Range 对象。该操作不影响选定内容和活动单元格。

expression.FindPrevious(After)

expression 必需。该表达式返回“应用于”列表中的对象之一。

After Variant 类型，可选。从其之前开始搜索的单元格。对应于用户界面中活动单元格的位置。请注意 After 必须为区域中的单个单元格。请记住搜索从该单元格之前 开始，活动单元格本身只有在 FindPrevious 方法返回该单元格时才进行搜索。如果不指定该参数，则搜索从区域的左上角单元格之前开始。

示例

本示例展示 FindPrevious 方法如何与 Find 和 FindNext 方法一起使用。在运行本示例之前，请确保 Sheet1 在 B 列中至少包含两处“Redmond”。

Sub Find_Methods()

    Dim rngFoundCell
    Dim rngFindRange

    ' Set a variable to the range to search.
    Set rngFindRange = Spreadsheet1.ActiveSheet.Columns("B")

    ' Find the first occurence of Redmond in column B.
    Set rngFoundCell = rngFindRange.Find("Redmond")

    ' Display the location of the first occurence of Redmond.
    MsgBox "The first occurrence is in cell " & rngFoundCell.Address

    ' Find the next occurence of Redmond in column B.
    Set rngFoundCell = rngFindRange.FindNext(after:=rngFoundCell)

    ' Display the location of the next occurence of Redmond.
    MsgBox "The next occurrence is in cell " & rngFoundCell.Address

    ' Find the previous occurence of Redmond in column B.
    Set rngFoundCell = rngFindRange.FindPrevious(after:=rngFoundCell)

    ' Display the location of the previous occurence of Redmond.
    MsgBox "The previous occurrence is in cell " & rngFoundCell.Address

End Sub


FireParametersOut 方法

使用此方法可触发 ParametersOutReady 事件。返回 Nothing。

expression.FireParametersOut(InterfaceName, ParamArray)

expression 必需。返回一个 Spreadsheet 对象的表达式。

InterfaceName 必需。ParametersOutProvider 接口的名称，在解决方案规范文件中指定。

ParamArray 可选。字符串的一维数组，其中每个字符串都是一个参数值。如果没有指定参数，则会使用 /ParametersOutProvider/SendParameters/Parameter/DefaultValue 中的值。如果这两个参数都没有，则会返回错误。

说明

注意，仅当电子表格组件正在 SharePoint 网站的 Web 部件页上的电子表格 Web 部件环境中运行时才可应用此方法。

电子表格 Web 部件可以实现 IParametersOutProvider 接口。当实现 IParametersOutProvider 接口的独立 Web 部件调用其 FireParametersOut 方法时，就会触发 ParametersOutReady 事件。ParametersOutReady 事件将一组开发人员定义的参数传递给其他实现 IParametersOutConsumer 接口的 Web 部件。

有关解决方案规范文件架构的详细信息，请在 Microsoft Developer Network (MSDN) 网站中搜索“解决方案规范文件”。有关解决方案规范文件的摘要信息以及一些示例，请在 Microsoft Office Excel 2003 帮助中搜索“电子表格部件”。


FlipHorizontal 方法

水平翻转指定图表中的所有系列。

expression.FlipHorizontal

expression 该表达式返回一个 ChPlotArea 对象。

示例

本示例水平翻转指定图表中的所有系列。

ChartSpace1.Charts(0).PlotArea.FlipHorizontal


FlipVertical 方法

垂直翻转指定图表中的所有系列。

expression.FlipVertical

expression 该表达式返回一个 ChPlotArea 对象。

示例

本示例垂直翻转指定图表中的所有系列。

ChartSpace1.Charts(0).PlotArea.FlipVertical


Follow 方法

显示 Follow 方法应用于 Hyperlink 对象的情形。

如果已经下载，则显示缓存文档。否则，该方法将解析超链接，下载目标文件，然后显示文档。

expression.Follow(NewWindow, AddHistory, ExtraInfo, Method, HeaderInfo)

expression 必需。该表达式返回一个 Hyperlink 对象。

NewWindow Variant 类型，可选。设置为 True 将在新窗口中显示目标文档。默认值为 False。

AddHistory Variant 类型，可选。不支持该参数。

ExtraInfo Variant 类型，可选。不支持该参数。

Method Variant 类型，可选。不支持该参数。

HeaderInfo Variant 类型，可选。不支持该参数。

显示 Follow 方法应用于 PivotHyperlink 对象的情形。

如果已经下载，则显示缓存文档。否则，该方法将解析超链接，下载目标文件，然后显示文档。

expression.Follow(NewWindow)

expression 该表达式返回一个 PivotHyperlink 对象。

NewWindow Boolean 类型，可选。设置为 True 将在新窗口中显示目标文档。默认值为 False。

示例

本示例解析活动工作表上单元格 B15 中的超链接，下载目标文件，然后显示文档。

Spreadsheet1.ActiveSheet.Range("b15").Hyperlink.Follow


GetContainingSection 方法

返回指定 HTML 元素的包含节。

expression.GetContainingSection(Element)

expression 该表达式返回一个 DataSourceControl 对象。

Element Object 类型，必需。代表指定 HTML 元素。


GetDataPointVisible 方法

返回滚动视图中可见的数据点索引。Long 类型。

expression.GetDataPointVisible(datapoint)

expression 必需。返回一个 ChSeries 对象的表达式。

datapoint Required ChartDataPointEnum.

ChartDataPointEnum 可为下列 ChartDataPointEnum 常量之一。
chDataPointFirst 索引值最低的可见数据点。
chDataPointLast 索引值最高的可见数据点。

说明

只有当相关类别在滚动视图范围内才认为数据点是可见的。此方法仅对栏和列图表有效。对于其他图表类型，没有对返回的值进行定义。

示例

下例说明如何获得滚动视图中可见的数据点索引。

Dim objSeries
Dim chChart
Dim lngPointFirst
Dim lngPointLast

Set chChart = ChartSpace.Constants

' Save the lowest and highest visible data point index values to variables.
lngPointFirst = _
    objSeries.GetDataPointVisible(chChart.chDataPointFirst)
lngPointLast = _
    objSeries.GetDataPointVisible(chChart.chDataPointLast)


GetPicture 方法

从二进制数据流返回图表图片。

expression.GetPicture(FilterName, Width, Height)

expression 必需。该表达式返回一个 ChartSpace 对象。

FilterName String 类型，可选。所用的图形过滤器名称。默认值为 "GIF"。

Width Long 类型，可选。以像素为单位的图表宽度。

Height Long 类型，可选。以像素为单位的图表高度。

说明

可以使用 BinaryWrite 方法将该方法返回的图片写入当前 HTTP 会话。

示例

本示例使用 ASP 脚本根据 SQL Server 数据库中的数据创建图表。创建图表后，将在浏览器窗口中显示图表的图片。

  <%
   Dim PictType
   Dim NewChart
   Dim chConstants

   Set NewChart = CreateObject("OWC11.ChartSpace")

   Response.Expires = 0
   Response.Buffer = True
   Response.Clear

   PictType = "jpg"
   Response.ContentType = "image/" & PictType

   Set chConstants = NewChart.Constants

   NewChart.ConnectionString = "Provider=SQLOLEDB.1;Persist Security Info=TRUE;" & _
                               "Integrated Security=SSPI;Initial Catalog=Northwind;" & _
                               "Data Source=servername;"
   NewChart.DataMember = "Order Details"

   NewChart.SetData chConstants.chDimCategories, chConstants.chDataBound, "ProductID"
   NewChart.SetData chConstants.chDimValues, chConstants.chDataBound, "Quantity"

   NewChart.Charts(0).Type = chConstants.chChartTypeColumn3D
   NewChart.Charts(0).HasTitle = True
   NewChart.Charts(0).Title.Caption = "Server-Rendered Chart"

   Response.BinaryWrite NewChart.GetPicture(PictType, 500, 400)
   %>


GetValue 方法

返回自定义数据维中指定点的数值。

expression.GetValue(Dimension, scaled)

expression 该表达式返回一个 ChPoint 对象。

Dimension ChartDimensionsEnum 类型，必需。从中检索数据的数据维。

ChartDimensionsEnum 可以为下列 ChartDimensionsEnum 常量之一。
chDimBubbleValues
chDimCategories
chDimCharts
chDimCloseValues
chDimFilter
chDimFormatValues
chDimHighValues
chDimLowValues
chDimOpenValues
chDimRValues
chDimSeriesNames
chDimThetaValues
chDimValues
chDimXValues
chDimYValues

Scaled Variant 类型，可选。指定是否返回点的实际值，或相对于其他相关点的百分比。将该参数设置为 True 将返回百分比。该参数仅适用于使用饼图、圆环图或堆积柱形图的情况。

说明

另外，可为 Dimension 参数指定 ChartErrorBarCustomValuesEnum 常量以返回误差线的值。

ChartErrorBarCustomValuesEnum 可以为下列 ChartErrorBarCustomValuesEnum 常量之一。
chErrorBarMinusValues
chErrorBarPlusValues


Group 方法

按照 Series 参数指定的系列分组指定系列。

expression.Group(Series)

expression 必需。该表达式返回一个 ChSeries 对象。

Series ChSeries 对象，必需。指定系列要按其分组的系列。


HideDetails 方法

隐藏指定对象的明细单元格。如果指定对象为 PivotData 对象，将隐藏所有明细单元格。如果指定对象为 PivotRowMember 对象，将隐藏该行的所有明细单元格。如果指定对象为 PivotColumnMember 对象，将隐藏该列的所有明细单元格。

expression.HideDetails

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例隐藏 PivotTable1 中的所有明细单元格。

PivotTable1.ActiveData.HideDetails


ImportXml 方法

当调用此方法时，指定电子表格组件映射会用 XML 数据流进行更新。返回 Nothing。

expression.ImportXml(XMLData, ShowDialogs, UseIDXPath)

expression 返回一个 XmlMap 对象的表达式。

XMLData Variant 类型，必需。包含要导出的 XML 数据的 String 或 IStream 对象。

ShowDialogs Boolean 类型，可选。指定在 ImportXml 方法遇到电子表格组件自身返回的错误时，是否显示对话框。当 ShowDialogs 设为 True 时，如果 ImportXml 方法遇到电子表格组件返回的错误，则显示对话框。当 ShowDialogs 设为 False 时，则不为电子表格组件错误显示对话框。默认值为 False。

UseIDXPath Boolean 类型，可选。指定将 XML 数据导入电子表格 Web 部件（该电子表格 Web 部件用于实现 XML 数据解决方案规范文件的 RowConsumer 元素中的 IRowConsumer 连接接口）的方式。设置为 False 时，电子表格 Web 部件将根据 XPath 语句导入 XML 数据，其中 XPath 语句在与该 Web 部件相关的 XML 电子表格文件的 Map 元素中的 XPath 元素中指定。设置为 True 时，电子表格 Web 部件将使用根/行架构（如下所示）导入 XML 数据，并将行元素映射到与该 Web 部件相关 XML 电子表格文件的 Map 元素中的 Field 元素。默认值为 False。

根/行架构

<Root>
    <Row>
        <Field1>Field1Value</Field1>
        <Field2>Field2Value</Field2>
    </Row>
</Root>

电子表格 Web 部件会尝试将每个字段标记名（如上面架构示例中的 Field1 和 Field2）与 XML 电子表格文件的 Map 元素中的 Field 元素的 ID 属性相匹配。例如，以下 XML 电子表格文件的 XML 片段显示一个其 ID 属性值为“Field1”的 Field 元素。

<Map x2:ID="Products_Map" x2:SchemaID="Schema1" x2:RootElement="Products">
    <Entry x2:Type="table" x2:ID="2" x2:ShowTotals="false" x2:NoInserts="true">
    <Range>Products!R2C1:R4C8</Range>
    <HeaderRange>R1C1</HeaderRange>
    <x:FilterOn>True</x:FilterOn>
    <XPath>/Products/Products_Row</XPath>
    <Field x2:ID="Field1">
        <Range>RC</Range>
        <XPath>ProductID</XPath>
        <XSDType>int</XSDType>
    </Field>
    . . .

注释 ShowDialogs 参数并不控制是否为电子表格组件之外的错误（例如脚本创作组件返回的错误）显示对话框。若要阻止为电子表格组件之外的错误显示对话框，您必须在脚本中捕获这些错误。

说明

使用 ImportXml 方法可将 XML 数据文件的内容导入到单元格中或导入到映射为指定架构映射的 XML 列表中。如果导入的 XML 数据文件内容与指定架构映射不匹配，则 ImportXml 操作就会失败，当可选 ShowDialogs 参数设为 True 时，将显示错误对话框。

所导入的 XML 数据需要与导入的 XmlMap 相匹配，即 XmlMap 条目和字段包含的 XPaths 应该与所导入数据中的某些元素或属性相对应。

在异步绑定过程中，调用所有包含 XmlMap.ImportXml 的数据绑定对象模型都会返回一条错误消息，提示用户由于异步绑定正在进行，所以无法完成所要求的操作。当异步绑定完成后，对象模型的调用才会成功。

示例

下例表示如何先使用 CanQuery 属性检查绑定是否可以查询。如果可以查询，该代码将刷新绑定。一个事件处理程序会捕获 BindingCompleted 事件，再调用 ExportXmlInfo 函数，并将其他电子表格组件示例作为参数传递给该函数。ExportXmlInfo 函数将调用 ExportXML 方法，然后将 XML 数据流返回到正在调用的函数，并作为 ImportXml 方法的输入值。

Dim objBinding
Dim objBindings
Dim objXmlStringIn
Dim objXmlMap

Set objXmlMap = Spreadsheet1.ActiveWorkbook.XmlMaps.Item(1)
Set objBindings = Spreadsheet1.ActiveWorkbook.XmlDataBindings

For Each objBinding In objBindings
    If objBinding.CanQuery = True
        objBinding.Refresh
    End If
Next

Sub Spreadsheet1_BindingCompleted(bindingID, Action)

Dim objXmlStringIn
Dim objXmlMap

    ' Write out the data in the specified map to an XML data stream.
    objXmlStringIn = ExportXmlInfo(Spreadsheet2)

    ' Use the XML data stream by passing it as the argument to the ImportXml method.
    objXmlMap.ImportXml objXmlStringIn

End Sub

Function ExportXmlInfo(Spreadsheet2)
    Dim objXmlMap

    Set objXmlMap = Spreadsheet2.ActiveWorkbook.XmlMaps.Item(1)
    ' Return the map to the calling function.
    ExportXmlInfo = objXmlMap.ExportXml()
End Function

注释 有关从网页中运行的脚本中捕获 BindingCompleted 事件的信息，请参阅 BindingCompleted 事件主题。


Insert 方法

在工作表中插入单元格或单元格区域，并调整其他单元格以留出空间。

expression.Insert(Shift)

expression 必需。该表达式返回一个 Range 对象。

Shift Variant 类型，可选。指定单元格的调整方式。可以为下列 XlInsertShiftDirection 常量之一：xlShiftToRight 或 xlShiftDown。如果省略该参数，Microsoft Excel 将根据区域形状确定调整方式。


InsertFieldSet 方法

在指定坐标轴插入一个字段集。

expression.InsertFieldSet(FieldSet, Before, Remove)

expression 该表达式返回一个 PivotAxis、PivotDataAxis、PivotFilterAxis 或 PivotGroupAxis 对象。

FieldSet PivotFieldSet 对象，必需。指定要插入的字段集。

Before Variant 类型，可选。指定插入的字段集前面的字段集索引。

Remove Boolean 类型，可选。该参数为将来的应用而保留，其值总是为 True。将字段集添加到指定坐标轴后，它将从其他坐标轴删除。

示例

本示例在 PivotTable1 的行轴、数据轴和筛选轴添加字段集。

Sub Add_Fields_To_PivotTable()
    Dim vwView
    Dim ptConstants
    Dim totOrderCount

    Set ptConstants = PivotTable1.Constants
    Set vwView = PivotTable1.ActiveView

    ' Add the ShipCountry field to the row axis.
    vwView.RowAxis.InsertFieldSet vwView.FieldSets("ShipCountry")

    ' Add the OrderId field to the data axis.
    vwView.DataAxis.InsertFieldSet vwView.FieldSets("OrderID")

    ' Add the ShipVia field to the filter axis
    vwView.FilterAxis.InsertFieldSet vwView.FieldSets("ShipVia")

    ' Create a total named "Order Count" that counts the OrderID field.
    Set totOrderCount = vwView.AddTotal("Order Count", vwView.FieldSets("OrderId").Fields("OrderId"), _
                        ptConstants.plFunctionCount)

    ' Add the Order Count total to the data axis.
    vwView.DataAxis.InsertTotal totOrderCount
End Sub


InsertTotal 方法

在 PivotTotals 集合中添加 PivotTotal 对象。

expression.InsertTotal(Total, Before)

expression 该表达式返回一个 PivotDataAxis 对象。

Total PivotTotal 对象，必需。指定要插入的总计。

Before Variant 类型，可选。指定要在其之前插入总计的总计索引。如果不指定该参数，则总计插入到集合的末尾。

说明

如果 PivotTotal 对象当前属于 PivotTotals 集合，则首先从集合中删除相应的对象然后再重新插入。由于总计按其在集合中的顺序显示，因此显示顺序将发生更改。

示例

本示例在 PivotTable1 中插入名为“Total Budget”的总计，该总计对 Budget 字段求和，然后将总计插入到 PivotTable 视图。

Sub Add_Total()
    Dim vwView
    Dim ptConstants
    Dim totNewTotal

    Set vwView = PivotTable1.ActiveView
    Set ptConstants = PivotTable1.Constants

    ' Add a new total named "Total Budget" to the current view.
    Set totNewTotal = vwView.AddTotal("Total Budget", vwView.Fieldsets("budget").Fields(0), _
             ptConstants.plFunctionSum)

    ' Insert the newly created total into the detail area of the PivotTable.
    vwView.DataAxis.InsertTotal totNewTotal

End Sub


IsButtonEnabled 方法

显示 IsButtonEnabled 方法应用于 DataPage 对象的情形。

如果启用了指定导航按钮，则返回 True。

expression.IsButtonEnabled(Button)

expression 必需。该表达式返回一个 DataPage 对象。

Button NavButtonEnum 类型，必需。指定导航按钮。

NavButtonEnum 可为以下 NavButtonEnum 常量之一：
navbtnApplyFilter
navbtnDelete
navbtnHelp
navbtnMoveFirst
navbtnMoveLast
navbtnMoveNext
navbtnMovePrev
navbtnNew
navbtnSave
navbtnSaveAll
navbtnSortAscending
navbtnSortDescending
navbtnToggleFilter
navbtnUndo
navbtnUndoAll

显示 IsButtonEnabled 方法应用于 RecordNavigationControl 对象的情形。

如果启用了指定导航按钮，则返回 True。

expression.IsButtonEnabled(navbtn)

expression 必需。该表达式返回一个 RecordNavigationControl 对象。

navbtn NavButtonEnum 类型，必需。指定导航按钮。

NavButtonEnum 可为以下 NavButtonEnum 常量之一：
navbtnApplyFilter
navbtnDelete
navbtnHelp
navbtnMoveFirst
navbtnMoveLast
navbtnMoveNext
navbtnMovePrev
navbtnNew
navbtnSave
navbtnSaveAll
navbtnSortAscending
navbtnSortDescending
navbtnToggleFilter
navbtnUndo
navbtnUndoAll


Item 方法

返回 Names 集合中的 Name 对象。

expression.Item(Index, IndexLocal, RefersTo)

expression 必需。该表达式返回一个 Names 对象。

Index Variant 类型，可选。定义名称要返回的名称或编号。

IndexLocal Variant 类型，可选。以用户语言表示的定义名称的名称。如果使用该参数，将不翻译名称。

RefersTo Variant 类型，可选。不支持该参数。

说明

必须只指定这三个参数中的一个。

示例

本示例从工作簿中删除名称 "SortRange"。

Spreadsheet1.ActiveWorkbook.Names("SortRange").Delete


LargeScroll 方法

按页滚动窗口内容。页的大小取决于活动窗口中可见的行和列。

expression.LargeScroll(Down, Up, ToRight, ToLeft)

expression 必需。该表达式返回一个 Window 对象。

Down Variant 类型，可选。向下滚动内容的页数。

Up Variant 类型，可选。向上滚动内容的页数。

ToRight Variant 类型，可选。向右滚动内容的页数。

ToLeft Variant 类型，可选。向左滚动内容的页数。

说明

如果同时指定 Down 和 Up 或 ToRight 和 ToLeft，则窗口内容滚动的页数为参数之差。例如，如果 Down 为 3 而 Up 为 6，则内容向上滚动三页。

以上任何参数均可为负数。

示例

本示例将 Spreadsheet1 活动窗口中的内容向下滚动三页、向右滚动两页。

Spreadsheet1.ActiveWindow.LargeScroll 3, ,2


Load 方法

从 URL 或本地文件加载 XML 图表。文件必须只由图表 XML 组成，不能包含任何前导 HTML。字符串必须以 <script language="XML"> 开始，以 </script> 结束。

expression.Load(FileName As String)

expression 该表达式返回一个 ChartSpace 对象。

FileName String 类型，必需。指定包含 XML 图表数据的文件。

示例

本示例加载指定的 XML 数据文件。

ChartSpace1.Load "chart.xml"


LoadText 方法

将指定文本文件加载并分列到工作表中。文本文件的内容从指定的单元格开始加载到工作表中，并覆盖单元格原有内容。

expression.LoadText(File, Delimiters, ConsecutiveDelimAsOne, TextQualifier)

expression 该表达式返回一个 Range 对象。

File String 类型，必需。指定文本文件名称。

Delimiters String 类型，可选。指定字段分隔符。默认值为无分隔符。

ConsecutiveDelimAsOne Boolean 类型，可选。设置为 True 可将连续分隔符视为一个分隔符。默认值为 False。

TextQualifier String 类型，可选。指定文本识别符。默认值为双引号。

示例

本示例在 Spreadsheet1 的活动工作表中插入一个制表符分隔的文本文件。文本文件的内容将从单元格 B10 开始。

Spreadsheet1.ActiveSheet.Range("B10").LoadText "tabfile.txt", Chr$(9)


MakeCurrent 方法

使指定节成为当前节。

expression.MakeCurrent(ScrollIntoView)

expression 该表达式返回一个 Section 对象。

ScrollIntoView Boolean 类型，可选。将此参数设置为 True 可将节滚动到视图中。默认值为 False。


Merge 方法

由指定区域创建合并单元格。创建合并单元格后，指定区域中左上角单元格的值将用作合并单元格的值。合并单元格中的所有其他单元格的值均将忽略。

expression.Merge(Across)

expression 该表达式返回一个 Range 对象。如果区域中部分包含以前的合并单元格，则该方法无效。

Across Variant 类型，可选。设置为 True 可指定区域中每一行的单元格合并为一个单独的合并单元格。默认值为 False。

示例

本示例由区域 B2:C5 创建一个合并单元格，并在合并单元格周围设置红色粗边框。

Sub Merge_Cells()
Dim ssConstants
Dim rngMerged

Set ssConstants = Spreadsheet1.Constants

' Merge cells B2:C5.
Spreadsheet1.ActiveSheet.Range("B2:C5").Merge

' Set a variable to the merged range.
Set rngMerged = Spreadsheet1.ActiveSheet.Range("B2").MergeArea

' Format the merged cell.
rngMerged.Borders.Color = "Red"
rngMerged.Borders.Weight = ssConstants.owcLineWeightThick
rngMerged.HorizontalAlignment = ssConstants.xlHAlignCenter
rngMerged.VerticalAlignment = ssConstants.xlVAlignCenter
End Sub


Move 方法

将工作表移动到工作簿中的其他位置。

expression.Move(Before, After)

expression 必需。该表达式返回“应用于”列表中的对象之一。

Before Variant 类型，可选。在其之前放置移动工作表的工作表。如果指定了 After 则不能指定 Before。

After Variant 类型，可选。在其之后放置移动工作表的工作表。如果指定了 Before 则不能指定 After。


MoveDetailLeft 方法

以指定的列成员开始向作滚动明细区域。

expression.MoveDetailLeft(DetailLeft, DetailLeftOffset, Update)

expression 必需。该表达式返回一个 PivotColumnMember 对象。

DetailLeft Long 类型，必需。表示作为滚动基点的单元格索引号。例如，使用数值 2 将从明细区域中的第三列开始滚动。

DetailLeftOffset Long 类型，必需。滚动的像素数。

Update Boolean 类型，可选。确定是否更新显示。默认值为 True。

示例

本示例从第二列开始将明细区域向左滚动 10 像素。

Sub ScrollDetailColumns()

    Dim ptData
    Dim pmColumnMember

    Set ptData = PivotTable1.ActiveData

    Set pmColumnMember = ptData.ColumnAxis.Member

    ' Scroll the first column in the detail area
    ' the left by 10 pixels.
    pmColumnMember.MoveDetailLeft 1, 10

End Sub


MoveDetailTop 方法

以指定单元格开始向下滚动明细区域。

expression.MoveDetailTop(DetailTop, DetailTopOffset, Update)

expression 必需。该表达式返回一个 PivotCell 对象。

DetailTop Long 类型，必需。表示作为滚动基点的单元格索引号。例如，使用数值 5 将从明细区域中的第六行开始滚动。

DetailTopOffset Long 类型，必需。滚动的像素数。使用 0 将 DetailTop 参数指定的记录滚动到明细区域的顶部。

Update Boolean 类型，可选。确定是否更新显示。默认值为 True。

说明

使用 MoveDetailLeft 方法向左滚动明细区域。

示例

本示例将第十五行滚动为明细区域中显示的第一行。

Sub ScrollDetailArea()

    Dim ptData
    Dim pmColumnMember
    Dim pmRowMember

    Set ptData = PivotTable1.ActiveData

    Set pmRowMember = ptData.RowAxis.Member
    Set pmColumnMember = ptData.ColumnAxis.Member

    ' Starting at the 15th row of the detail area, scroll 100 pixels.
    ptData.Cells(pmRowMember, pmColumnMember).MoveDetailTop 15, 0

End Sub


MoveFirst 方法

移动到数据访问页记录集中的第一条记录。如果当前记录为记录集中的第一条记录，则该方法无效。

expression.MoveFirst

expression 该表达式返回一个 DataPage 对象。


MoveLast 方法

移动到数据访问页记录集中的最后一条记录。如果当前记录为记录集中的最后一条记录，则该方法无效。

expression.MoveLast

expression 该表达式返回一个 DataPage 对象。


MoveLeft 方法

将列字段成员向左滚动指定像素数，或直到下一列成员滚动到显示的左侧。

expression.MoveLeft(Left, LeftOffset, Update)

expression 必需。该表达式返回一个 PivotData 对象。

Left PivotColumnMember 对象，必需。滚动的列成员。

LeftOffset Long 类型，必需。成员滚动的像素数。

Update Boolean 类型，可选。确定是否更新显示。默认值为 True。

说明

使用 MoveTop 属性滚动行字段成员。

示例

本示例将数据透视表视图滚动到下一列成员。

Sub ScrolltoNextColumnMember()

    Dim ptData

    Set ptConstants = PivotTable1.Constants

    Set ptData = PivotTable1.ActiveData

    ' Scroll to the next column member.
    ptData.MoveLeft ptData.Left, 1000

End Sub


MoveNext 方法

移动到数据访问页记录集中的下一条记录。如果当前记录为记录集中的最后一条记录，则该方法无效。

expression.MoveNext

expression 该表达式返回一个 DataPage 对象。


MovePrevious 方法

移动到数据访问页记录集中的上一条记录。如果当前记录为记录集中的第一条记录，则该方法无效。

expression.MovePrevious

expression 该表达式返回一个 DataPage 对象。


MoveTop 方法

将列字段成员向上滚动指定像素数，或直到下一行成员滚动到显示的顶部。

expression.MoveTop(Top, TopOffset, Update)

expression 必需。该表达式返回一个 PivotData 对象。

Top PivotRowMember 对象，必需。滚动的行成员。

TopOffset Long 类型，必需。成员滚动的像素数。

Update Boolean 类型，可选。确定是否更新显示。默认值为 True。

说明

使用 MoveLeft 属性滚动列字段成员。

示例

本示例将数据透视表视图滚动到下一行成员。

Sub ScrolltoNextRowMember()

    Dim ptData

    Set ptConstants = PivotTable1.Constants

    Set ptData = PivotTable1.ActiveData

    ' Scroll to the next row member.
    ptData.MoveTop ptData.Top, 1000

End Sub


NewRecord 方法

在数据访问页记录集中添加一条新记录。如果记录集不能更新，则该方法无效。

expression.NewRecord

expression 该表达式返回一个 DataPage 对象。


Nz 方法

使用该方法在值为 Null 时返回零、空字符串 (" ") 或其他指定值。例如，可以使用该函数将 Null 值转换为其他值，并防止其通过表达式传播。返回一个 Variant。

expression.Nz(Value, ValueIfNull)

expression 必需。该表达式返回一个 DataSourceControl 对象。

Value Variant 类型，必需。转换的值。

ValueIfNull Variant 类型，可选。如果 Value 参数为 Null 时返回的值。该参数使得可以返回非零或非空字符串的值。

说明

该方法对可能包括 Null 值的表达式非常有用。要强制表达式在即使包含 Null 值时也能计算出非 Null 值，请使用该方法返回零、空字符串或自定义返回值。

例如，表达式 2 + varX 在变量 varX 为 Null 时将总是返回 Null 值。但是，2 + MSODSC.Nz(varX) 返回 2。

在下一示例中，赋予 Nz 方法的可选参数在 varFreight 为 Null 时提供可返回的字符串。

varResult = MSODSC.Nz(varFreight, "No Freight Charge")


OverrideDefaultElementFormatting 方法

通过 OverrideDefaultElementFormatting 方法可使用当前 ChChartDraw 对象的绘图格式来绘制图表。返回 Nothing。

expression.OverrideDefaultElementFormatting()

expression 必需。返回一个 ChChartDraw 对象的表达式。

说明

大多数生成一个 BeforeRender 事件的图表元素都会用图表组件的默认格式初始化绘图界面。可以使用 BeforeRender 事件过程中的 OverrideDefaultElementFormatting 方法来更改作为其 drawObject 参数传递到 BeforeRender 事件的当前 ChChartDraw 对象的默认属性。

示例

下例使用 OverrideDefaultElementFormatting 方法更改 ChChartDraw 对象的属性：

Sub Chartspace_BeforeRender(drawObject As ChChartDraw, chartObject As Object, Cancel As ByRef)
    On Error Resume Next

    ' This format will be applied only to all legends.
    If TypeName(chartObject)="ChLegend" Then
        drawObject.border.weight = 5
        drawObject.border.color = "green"
        drawObject.OverrideDefaultElementFormatting
    End If

    ' This format will only be applied to all titles.
    If TypeName(chartObject)="ChTitle" Then
        drawObject.border.weight = 10
        drawObject.border.color = "violet"
        drawObject.OverrideDefaultElementFormatting
    End If
End Sub

Sub Chartspace_AfterRender(drawObject As ChChartDraw, chartObject As Object)
    Select Case TypeName(chartObject)
        Case "ChLegend", "ChTitle"
            ' Chartspace will apply the overrided drawObject format to the Title and Legend objects.
            drawObject.DrawRectangle chartObject.Left, _
                            chartObject.Top, chartObject.right, chartObject.bottom
    End Select
End Sub


ParseText 方法

将指定文本字符串分列并将结果置于指定区域。

expression.ParseText(Text, Delimiters, ConsecutiveDelimAsOne, TextQualifier)

expression 该表达式返回一个 Range 对象。

Text String 类型，必需。指定要分列的字符串。

Delimiters String 类型，可选。指定字段分隔符。

ConsecutiveDelimAsOne Boolean 类型，可选。如果为 True 则将连续分隔符视为一个分隔符。默认值为 False。

TextQualifier String 类型，可选。指定文本识别符。默认值为双引号。

示例

本示例将指定字符串在从单元格 A1 开始的区域内分列。

Spreadsheet1.ActiveSheet.Range("A1").ParseText "name, address, city, state", ","


Paste 方法

显示 Paste 方法应用于 Worksheet 对象的情形。

将“剪贴板”中的内容粘贴到工作表上。如果不指定 Destination 参数，则在使用该方法之前必须选择目标区域。

expression.Paste(Destination, Link)

expression 必需。该表达式返回一个 Worksheet 对象。

Destination Variant 类型，可选。指定要粘贴“剪贴板”中内容的位置的 Range 对象。如果忽略该参数，则使用当前选定区域。只有“剪贴板”中的内容可以粘贴到区域中时才能指定该参数。

Link Variant 类型，可选。该 Spreadsheet 组件版本中不支持。

显示 Paste 方法应用于 Range 对象的情形。

将“剪贴板”中的内容粘贴到指定区域。

expression.Paste

expression 该表达式返回一个 Range 对象。

示例

显示 应用于 Worksheet 对象的情形。

本示例复制 Sheet1 上单元格 A1:D10 中的内容，并粘贴到 Sheet2 中以 A1 开始的区域。

Sub PasteData()

    ' Copy cell A1:D10 in Sheet1.
    Spreadsheet1.Sheets("Sheet1").Range("A1:D10").Copy

    ' Paste starting at cell A1 of Sheet2.
    Spreadsheet1.ActiveSheet.Paste
    Spreadsheet1.Sheets("Sheet2").Range("A1")

End Sub

显示 应用于 Range 对象的情形。

本示例将单元格 A1 中的内容粘贴到单元格 A3、A5 和 A7 中。

Sub PasteRange()

    Dim iRowNum

    ' Copy cell A1 on the active worksheet.
    Spreadsheet1.ActiveSheet.Range("A1").Copy

    ' Loop through the odd numbers from 3 to 7.
    For iRowNum = 3 To 7 Step 2
        ' Paste the copied cell.
        Spreadsheet1.ActiveSheet.Cells(iRowNum, 1).Paste
    Next

End Sub


PointsToScreenPixelsX 方法

返回一个 Long 类型，表示从电子表格窗口左边到电子表格第一列左边之间的像素数，其中包括 Points 参数指定的值。

expression.PointsToScreenPixelsX(Points)

expression 必需。该表达式返回一个 Window 对象。

Points Long 类型，必需。加到该方法的结果中的像素数。

说明

虽然此方法名称暗示该方法将把点值转换为屏幕像素值，但实际上该方法仅使用像素值执行上述操作。对于 PointsToScreenPixelsX 方法，该值将根据行标题是打开还是关闭，有一个固定数量（24 像素）的变化。

示例

此示例在行标题打开时返回 25，在行标题关闭时返回 1。

Sub Window_OnLoad()

     MsgBox Spreadsheet1.ActiveWindow.PointsToScreenPixelsX(0)

End Sub


PointsToScreenPixelsY 方法

返回一个 Long 类型值，表示从电子表格窗口顶部到电子表格第一行顶部之间的像素数，其中包括 Points 参数指定的值。

expression.PointsToScreenPixelsY(Points)

expression 必需。该表达式返回一个 Window 对象。

Points Long 类型，必需。加到该方法的结果中的像素数。

说明

虽然方法名称暗示该方法将把点值转换为屏幕像素值，但实际上该方法仅使用像素值执行上述操作。对于 PointsToScreenPixelsY 方法，该值将根据工具栏（22 像素）和列标题（17 像素）是打开还是关闭而有所变化。

示例

此示例在工具栏和列标题都打开时返回 40，在工具栏和列标题都关闭时返回 1。

Sub Window_OnLoad()

     MsgBox Spreadsheet1.ActiveWindow.PointsToScreenPixelsY(0)

End Sub


Protect 方法

显示 Protect 方法应用于 Worksheet 对象的情形。

保护工作表不被修改。该方法在功能上等效于使用 Protection 对象的属性保护工作表。

expression.Protect(Password, DrawingObjects, Contents, Scenarios, UserInterfaceOnly, AllowFormattingCells, AllowFormattingColumns, AllowFormattingRows, AllowInsertingColumns, AllowInsertingRows, AllowInsertingHyperlinks, AllowDeletingColumns, AllowDeletingRows, AllowSorting, AllowFiltering, AllowUsingPivotTableReports)

expression 必需。该表达式返回一个 Worksheet 对象。

Password Variant 类型，可选。不支持该参数。

DrawingObjects Variant 类型，可选。不支持该参数。

Contents Variant 类型，可选。设置为 True 将保护工作表上锁定单元格的内容。默认值为 True。

Scenarios Variant 类型，可选。不支持该参数。

UserInterfaceOnly Variant 类型，可选。不支持该参数。

AllowFormattingCells Variant 类型，可选。不支持该参数。

AllowFormattingColumns Variant 类型，可选。设置为 True 将允许调整列的宽度。默认值为 False。等效于 Protection 对象的 AllowSizingAllColumns 属性。

AllowFormattingRows Variant 类型，可选。设置为 True 将允许调整行的高度。默认值为 False。等效于 Protection 对象的 AllowSizingAllRows 属性。

AllowInsertingColumns Variant 类型，可选。如果可以插入工作表列，则设置为 True。默认值为 False。等效于 Protection 对象的 AllowInsertingColumns 属性。

AllowInsertingRows Variant 类型，可选。如果可以插入工作表行，则设置为 True。默认值为 False。等效于 Protection 对象的 AllowInsertingRows 属性。

AllowInsertingHyperlinks Variant 类型，可选。不支持该参数。

AllowDeletingColumns Variant 类型，可选。如果可以删除工作表列，则设置为 True。默认值为 False。等效于 Protection 对象的 AllowDeletingColumns 属性。

AllowDeletingRows Variant 类型，可选。如果可以删除工作表行，则设置为 True。默认值为 False。等效于 Protection 对象的 AllowDeletingRows 属性。

AllowSorting Variant 类型，可选。如果指定工作表可以排序，则设置为 True。默认值为 False。等效于 Protection 对象的 AllowSorting 属性。

AllowFiltering Variant 类型，可选。如果指定工作表可以筛选，则设置为 True。默认值为 False。等效于 Protection 对象的 EnableAutoFilter 属性。

AllowUsingPivotTableReports Variant 类型，可选。不支持该参数。

显示 Protect 方法应用于 Workbook 对象的情形。

保护工作簿使其不被修改。

expression.Protect(Password, Structure, Windows)

expression 必需。该表达式返回一个 Workbook 对象。

Password Variant 类型，可选。不支持该参数。

Structure Variant 类型，可选。设置为 True 将保护工作簿结构。保护工作簿结构可防止移动、插入、删除、隐藏、显示和重新命名工作表。默认值为 False。

Windows Variant 类型，可选。不支持该参数。

说明

设置不支持的参数为 True 将导致运行时出错。

示例

显示 应用于 Worksheet 对象的情形。

本示例保护 Spreadsheet1 中 Sheet1 上锁定单元格的内容，但允许用户插入或删除列和行。

Spreadsheet1.Worksheets("Sheet1").Protect , , True, , , , , , True, True, , True, True


RangeFromPoint 方法

显示 RangeFromPoint 方法应用于 ChartSpace 对象的情形。

返回图表工作区中指定位置上最详细的对象。例如如果指定点的 x 和 y 坐标，则返回相应的 ChPoint 对象，尽管在该坐标上还存在一个系列。

expression.RangeFromPoint(X, Y)

expression 必需。该表达式返回一个 ChartSpace 对象。

X Long 类型，必需。

Y Long 类型，必需。

显示 RangeFromPoint 方法应用于 Window 对象的情形。

返回位于指定屏幕坐标对中的 Range 对象。如果在指定坐标中没有区域，该方法返回 Nothing。

expression.RangeFromPoint(X, Y)

expression 必需。该表达式返回一个 Window 对象。

X Long 类型，必需。

Y Long 类型，必需。

示例

显示 应用于 ChartSpace 对象的情形。

本示例在鼠标指针经过 ChartSpace1 中的对象时更改 HTML 文本框“Textbox”的值。文本框中的值反映鼠标指针经过的对象类型。

Sub ChartSpace1_MouseMove(ByVal Button, ByVal Shift, ByVal x, ByVal y)

    ' Set the value of Textbox to the type of object .
    Textbox.Value = TypeName(ChartSpace1.RangeFromPoint(x,y))
End Sub


RectIntersect 方法

返回表示指定区域之间矩形交集的 Range 对象。如果指定区域之间没有重叠，则返回 Nothing 。

expression.RectIntersect(Range1, Range2)

expression 必需。该表达式返回一个 Spreadsheet 对象。

Range1 Range 类型，必需。

Range2 Range 类型，必需。

示例

本示例将 Spreadsheet1 活动工作表中命名区域“Range1”与命名区域“Range2”重叠的单元格加粗。

Sub BoldIntersection()

    Dim rngIntersect
    Dim rngFirstRange
    Dim rngSecondRange

    ' Set a variable to the first named range.
    Set rngFirstRange = Spreadsheet1.ActiveSheet.Range("Range1")

    ' Set a variable to the second named range.
    Set rngSecondRange = Spreadsheet1.ActiveSheet.Range("Range2")

    ' Set a variable to the intersection of the two named ranges.
    Set rngIntersect = Spreadsheet1.RectIntersect(rngFirstRange, rngSecondRange)

    ' Check whether the named ranges overlap.
    If Not rngIntersect Is Nothing Then

        ' Bold the font in the overlapping portion
        ' of the two ranges.
        rngIntersect.Font.Bold = True

    End If

End Sub


RectUnion 方法

返回一个 Range 对象，表示指定区域联合中的最小单元格区域。

expression.RectUnion(Range1, Range2)

expression 必需。该表达式返回一个 Spreadsheet 对象。

Range1 Range 类型，必需。

Range2 Range 类型，必需。

说明

该方法通常返回矩形区域。例如，如果指定 A1:A5 和 F1:F10，返回值为矩形区域 A1:F10。另外，不能使用该方法创建包含不连续区域的区域。


Refresh 方法

显示 Refresh 方法应用于 XmlDataBinding 对象的情形

从由给定绑定 <ConnectionInfo Purpose="Query"> 部分指定的连接中刷新数据，并更新为相应架构映射显示的数据。如果指定数据绑定没有包含有效连接或查询定义，则返回一个错误。

expression.Refresh(ShowDialogs, varParamNameValList)

expression 返回一个 XmlDataBinding 对象的表达式。

ShowDialogs Boolean 类型，可选。指定在 Refresh 方法遇到电子表格组件自身返回的错误时，是否显示对话框。当 ShowDialogs 设为 True 时，如果 Refresh 方法遇到电子表格组件返回的错误，则显示对话框。当 ShowDialogs 设为 False 时，则不会为电子表格组件错误显示对话框。默认值为 False。

注释 ShowDialogs 参数并不控制是否为电子表格组件之外的错误（例如脚本创作组件返回的错误）显示对话框。若要阻止为电子表格组件之外的错误显示对话框，您必须在脚本中捕获这些错误。

varParamNameValList 可选。如果绑定查询包含客户端参数，则用名称/值对数组传递这些参数。例如：XmlDataBindings("Binding1").Refresh(True, Array(Array(Param1, Value1), Array(Param2, Value2))。如果没有指定参数，则将采用绑定定义 /ClientParameterBindings/ClientParameterBinding/@DefaultValue 属性中指定的值。

说明

如果 Refresh 方法调用成功，则会触发 BindingCompleted 事件。

如果 Refresh 方法调用失败，则会触发 BindingError 事件，并且如果 ShowDialogs 参数设为 True，就会显示一个对话框。若要在脚本中捕获该错误，必须为 BindingError 事件创建一个事件过程。Refresh 方法或浏览器不会返回该错误。

当在异步绑定过程中调用 Refresh 方法时，将立即返回该错误。可以使用 XmlDataBinding 对象的 Async 属性来确定绑定是否支持异步绑定。可以为 BindingCompleted 和 BindingError 事件编写事件过程以确定绑定的完成时间。当在同步绑定过程中调用 Refresh 方法时，如果同步绑定正在进行，则会阻止任何试图调用 Refresh 方法或 XmlDataBinding 对象的任何其他成员的操作。

可以使用 XmlDataBinding 对象的 BindingInProgress 属性来确定异步绑定是否正在进行。但是，由于同步绑定进行期间将阻止调用 XmlDataBinding 成员，所以您可以有效地使用 BindingInProgress 属性来检查同步绑定和异步绑定的状态。例如，此循环：

Do
' Loop until binding operation is complete.
Loop While objBinding.BindingInProgress = True

用于确定上述绑定类型中的一种是否正在进行。由于同步绑定期间将阻止所有 XmlDataBinding 对象的调用，所以只要同步绑定正在进行，该循环就返回 False。如果异步绑定正在进行，它也会返回 False，因为这正是 BindingInProgress 属性的目的。

显示 Refresh 方法应用于“应用于”列表中所有其他对象的情形。

刷新指定对象（重载源数据或重绘对象）。

expression.Refresh()

expression 该表达式返回“应用于”列表中的对象之一。

示例

显示 应用于 XmlDataBinding 对象的情形。

下例使用 Refresh 方法刷新数据绑定，这会使 BindingCompleted 事件的事件处理程序捕获该事件并运行代码。

Sub RefreshBinding(Spreadsheet1)
    Spreadsheet1.ActiveWorkbook.XmlDataBindings.Item(1).Refresh
End Sub

Sub Spreadsheet1_BindingCompleted(bindingID, Action)

    If Spreadsheet1.ActiveWorkbook.XmlDataBindings.Item(bindingID).CanQuery = True Then
        ' Write code here to perform any additional actions on this query binding.
    End If

End Sub

注释 有关从网页中运行的脚本中捕获 BindingCompleted 事件的信息，请参阅 BindingCompleted 事件主题。

显示 应用于 ChartSpace 对象的情形

本示例重绘图表工作区本身。

ChartSpace1.Refresh


RefreshJetCache 方法

刷新数据访问页与 Microsoft Access 数据库的连接。

expression.RefreshJetCache( )

expression 必需。该表达式返回一个 DataSourceControl 对象。


RemoveFieldSet 方法

从指定坐标轴删除字段集。

expression.RemoveFieldSet(FieldSet)

expression 该表达式返回一个 PivotDataAxis、PivotFilterAxis 或 PivotGroupAxis 对象。

FieldSet Variant 类型，必需。指定要删除的字段集。可以为 PivotFieldSet 对象、字段集名称或字段集索引号。

示例

本示例从 PivotTable1 中的筛选轴删除 ShipVia 字段。

PivotTable1.ActiveView.FilterAxis.RemoveFieldSet "ShipVia"


RemoveTotal 方法

从指定数据轴删除总计。

expression.RemoveTotal(Total)

expression 该表达式返回一个 PivotDataAxis 对象。

Total Variant 类型，必需。指定要删除的总计。可以为 PivotTotal 对象、总计名称或总计索引号。

示例

本示例从 PivotTable1 的当前视图中删除 Order Count 总计。

PivotTable1.ActiveView.DataAxis.RemoveTotal "Order Count"


Repaint 方法

强制重绘指定对象。

expression.Repaint

expression 必需。该表达式返回一个 ChartSpace 或 Spreadsheet 对象。


Requery 方法

执行返回指定对象的记录集和所有相关记录集的查询。

expression.Requery

expression 该表达式返回一个 DataPage 对象。


Reset 方法

重置指定 Heading 对象。使用该方法重置指定行或列的标题。如果要将窗口中所有行列标题重置为默认值，请使用 ResetHeadings 方法。

expression.Reset

expression 必需。该表达式返回一个 Heading 对象。

示例

本示例将 Spreadsheet1 的活动工作表中 D 列标题重置为默认值。

Spreadsheet1.ActiveWindow.ColumnHeadings(4).Reset


ResetColors 方法

将指定工作簿的调色板重置为默认颜色。

expression.ResetColors

expression 必需。该表达式返回一个 Workbook 对象。

示例

下面示例将 Spreadsheet1 中打开工作簿的调色板重置为默认设置。

Spreadsheet1.ActiveWorkbook.ResetColors


ResetHeadings 方法

将指定窗口的行列标题重置为默认值。如果要重置指定行和列的标题，请使用 Reset 方法。

expression.ResetHeadings

expression 必需。该表达式返回一个 Window 对象。

示例

本示例将 Spreadsheet1 的活动窗口中的行列标题重置为默认值。

Spreadsheet1.ActiveWindow.ResetHeadings


RotateClockwise 方法

将指定图表的所有系列顺时针旋转 90 度。

expression.RotateClockwise

expression 该表达式返回一个 ChPlotArea 对象。

示例

本示例将指定图表的所有系列顺时针旋转 90 度。

ChartSpace1.Charts(0).PlotArea.RotateClockwise


RotateCounterClockwise 方法

将指定图表的所有系列逆时针旋转 90 度。

expression.RotateCounterClockwise

expression 该表达式返回一个 ChPlotArea 对象。

示例

本示例将指定图表的所有系列逆时针旋转 90 度。

ChartSpace1.Charts(0).PlotArea.RotateCounterClockwise


Save 方法

将当前记录保存到与指定数据访问页相关联的数据库中。

expression.Save

expression 该表达式返回一个 DataPage 对象。


ScrollIntoView 方法

滚动文档窗口，使指定矩形区域中的内容显示在文档窗口或窗格的左上角或右下角（取决于 Start 参数值）。

expression.ScrollIntoView(Left, Top, Width, Height, Start)

expression 必需。该表达式返回一个 Window 对象。

Left Long 类型，必需。矩形距离文档窗口或窗格左边的水平位置（点数）。

Top Long 类型，必需。矩形距离文档窗口或窗格上边的垂直位置（点数）。

Width Long 类型，必需。矩形的宽度（点数）。

Height Long 类型，必需。矩形的高度（点数）。

Start Variant 类型，可选。设置为 True 使矩形的左上角位于文档窗口或窗格的左上角。设置为 False 使矩形的右下角位于文档窗口或窗格的右下角。默认值为 True。

说明

Start 参数在矩形大于文档窗口时确定屏幕显示方向非常有用。

示例

本示例在活动文档窗口中定义 100X200 像素的矩形，位于距离窗口上边 20 像素、左边 50 像素，然后向上和向左滚动文档，使矩形的左上角与窗口的左上角对齐。

Spreadsheet1.ActiveWindow.ScrollIntoView 50, 20, 100, 200


Select 方法

显示 Select 方法应用于 ChartSpace、ChAxis、ChCategoryLabel、ChChart、ChChartField、ChDataLabel、ChDataLabels、ChErrorBars、ChGridlines、ChLegend、ChLegendEntry、ChPlotArea、ChPoint、ChSeries、ChSurface、ChTitle、ChTrendline、Range、Sheets、Worksheet 和 Worksheets 对象的情形。

选定指定对象。

expression.Select

expression 必需。该表达式返回上面对象之一。

显示 Select 方法应用于 PivotTable 对象的情形。

选定数据透视表列表中的对象。

expression.Select(Selection, ActiveObject, ScrollType, Update, Notify)

expression 必需。该表达式返回上面对象之一。

Selection Object 类型，必需。选定的对象。

ActiveObject Object 类型，必需。新的选定内容中的活动对象。

ScrollType PivotScrollTypeEnum 类型，可选。指定滚动新的选定内容以显示此内容的方法。

PivotScrollTypeEnum 可以为下列 PivotScrollTypeEnum 常量之一。
plScrollTypeAll
plScrollTypeBottom
plScrollTypeLeft
plScrollTypeNone 默认值
plScrollTypeRight
plScrollTypeTop

Update Boolean 类型，可选。确定是否更新显示。默认值为 True。

Notify Boolean 类型，可选。不支持该参数。

示例

本示例选定与活动单元格在同一行且右边隔一列的单元格。

Spreadsheet1.ActiveCell.Offset(0, 1).Select


Select2 方法

使用 ChPoint 对象的 Select2 方法可对当前选定对象集合中的对象进行操作。返回 Nothing。

expression.Select2(selmode)

expression 必需。返回一个 ChPoint 对象的表达式。

selmode ChartSelectMode 类型，可选。

值 | 说明
chSelectModeReplace (0) | （默认状态下）使此对象成为当前选定对象，并且成为主要选择。取消选择任何其他选定对象。
chSelectModeAdd (1) | 将此对象添加到当前选定对象集中。如果当前没有选定对象，则使用此方法与使用 Select 方法具有相同的效果。如果已选择了一个或多个对象，则此对象将成为次要选择。
chSelectModeRemove (2) | 从当前选定对象集中删除此对象。如果对象不是当前选定对象，则此设置无效。如果当前选定对象为主要对象，则将删除该对象，集合中的下一项将成为主要对象。如果集合中没有其他项，则 ChartSpace 对象将成为主要对象。
chSelectModeToggle (3) | 如果对象不在当前选定对象集中，则此设置与 chSelectModeAdd 具有相同效果。如果该对象在当前选定对象集中，则此设置与 chSelectModeRemove 具有相同效果。

说明

除 Select2 方法具有一个可选的 selmode 参数之外，Select2 方法与 ChPoint 对象的 Select 方法相似。主要选择一般是第一个选定对象。其他选定对象都是次要选择。使用当前选择的图表组件方法和属性仅识别主要选择。


SetData 方法

设置指定图表对象的数据。

expression.SetData(Dimension, DataSourceIndex, DataReference)

expression 该表达式返回一个 ChChart、ChErrorBars ChSeries 或 ChartSpace 对象。

Dimension ChartDimensionsEnum 常量，必需。指定设置的数据维。

ChartDimensionsEnum 可以为下列 ChartDimensionsEnum 常量之一。
chDimBubbleValues 设置气泡图上的标志值。
chDimCategories 设置用作分类的值。
chDimCharts 在 HasMultipleCharts 属性设置为 True 时设置新图表的来源字段。
chDimCloseValues 设置股票图的收盘值。
chDimFilter 设置放置于筛选坐标轴的字段。
chDimFormatValues 设置格式映射中的值。
chDimHighValues 设置股票图的盘高值。
chDimLowValues 设置股票图的盘低值。
chDimOpenValues 设置股票图的开盘值。
chDimRValues 设置极坐标图的 R 值。
chDimSeriesNames 设置作为系列名称的值。
chDimThetaValues 设置极坐标图的极角值。
chDimValues 设置绘制图表的值。
chDimXValues 设置 XY 散点图或气泡图的 X 值。
chDimYValues 设置 XY 散点图或气泡图的 Y 值。

DataSourceIndex Long 类型，必需。可以为 ChartSpecialDataSourcesEnum 常量。

ChartSpecialDataSourcesEnum 可以为下列 ChartSpecialDataSourcesEnum 常量之一。
chDataBound 将指定对象绑定到 DataReference 参数指定的外部数据源。
chDataLinked 将指定对象绑定到其他维。在 Dimension 参数中指定 chDimFormatValues 创建格式映射时使用该值。
chDataLiteral 将指定对象绑定到 DataReference 参数指定的文字类型数据。
chDataNone 清除指定对象。

DataReference Variant 类型，可选。对于 ChChart 和 ChSeries 对象，该参数以 Microsoft Excel 样式的区域引用（例如，“A1:D4”）或行集的列名指定数据引用。如果 DataSourceIndex 参数设置为 chDataLiteral，可以将 DataReference 设置为一维数组或逗号分隔列表。对于 ChErrorBars 对象，该参数指定可用作误差线数值的 Double 或 String 数组。请注意该参数仅适用于自定义误差线（误差线的 Type 属性必须设置为 chErrorBarTypeCustom）。

说明

另外，还可为 Dimension 参数指定 ChartErrorBarCustomValuesEnum 常量以指定用于误差线的值。

ChartErrorBarCustomValuesEnum 可以为下列 ChartErrorBarCustomValuesEnum 常量之一。
chErrorBarMinusValues
chErrorBarPlusValues

只能将图表绑定到一个数据源。例如，如果在图表工作区中有两个图表，不能将其绑定到不同的数据源。但是，可以将图表或数据系列绑定到文字类型数据，而图表或图表工作区绑定到外部数据源。

如果绑定到 OLAP 数据源，DataReference 参数可以绑定到字段集而不是字段。连接到 OLAP 数据源时，可以向 DataReference 参数传递字段数组以绑定到指定字段。

示例

本示例创建使用文字类型数据数组的图表。

Sub BindChartToArrays()

    Dim asSeriesNames(1)
    Dim asCategories(7)
    Dim aiValues(7)
    Dim chConstants
    Dim chtNewChart

    asSeriesNames(0) = "Satisfaction Data"

    asCategories(0) = "Very Good"
    asCategories(1) = "Good"
    asCategories(2) = "N/A"
    asCategories(3) = "Average"
    asCategories(4) = "No Response"
    asCategories(5) = "Poor"
    asCategories(6) = "Very Poor"

    aiValues(0) = 10
    aiValues(1) = 22
    aiValues(2) = 6
    aiValues(3) = 31
    aiValues(4) = 5
    aiValues(5) = 14
    aiValues(6) = 12

    Set chConstants = ChartSpace1.Constants

    ' Add a new chart to Chartspace1.
    Set chtNewChart = ChartSpace1.Charts.Add

    ' Specify that the chart is a column chart.
    chtNewChart.Type = chConstants.chChartTypeColumnClustered

    ' Bind the chart to the arrays.
    chtNewChart.SetData chConstants.chDimSeriesNames, chConstants.chDataLiteral, asSeriesNames
    chtNewChart.SetData chConstants.chDimCategories, chConstants.chDataLiteral, asCategories
    chtNewChart.SeriesCollection(0).SetData chConstants.chDimValues, chConstants.chDataLiteral, aiValues

End Sub

本示例创建绑定到电子表格的图表。系列名称在单元格 B1 中，分类名称在 A2:A28 中，数值在单元格 B2:B28 中。

Sub BindToSpreadsheet()
    Dim chConstants
    Dim chtChart1

    Set chConstants = ChartSpace1.Constants

    ' Set the data source of ChartSpace1 to Spreadsheet1.
    Set ChartSpace1.DataSource = Spreadsheet1

    ' Set a variable to a new chart in Chartspace1.
    Set chtChart1 = ChartSpace1.Charts.Add

    ' Set the chart type.
    chtChart1.Type = chConstants.chChartTypeLineMarkers

    ' Bind the series name to cell B1 in the first sheet of Spreadsheet1.
    chtChart1.SetData chConstants.chDimSeriesNames, chConstants.chDataBound, "B1"

    ' Bind the category axis to cell A2:A28 in the first sheet of Spreadsheet1.
    chtChart1.SetData chConstants.chDimCategories, chConstants.chDataBound, "A2:A28"

    ' Bind the values of the data series to cells B2:B28 in the first sheet of Spreadsheet1.
    chtChart1.SeriesCollection(0).SetData chConstants.chDimValues, chConstants.chDataBound, "B2:B28"

End Sub

本示例将 Chartspace1 绑定到 SQL Server 罗斯文数据库中的 Order Details 表，然后创建一个格式映射。较小的值以白色显示，较大的值以蓝色阴影显示，图表中的最大值以深蓝色显示。

Sub Window_Onload()

    Dim serSeries1
    Dim segSegment1
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' The following two lines of code bind Chartspace1 to the Order Details table in the
    ' Northwind SQL Server database.
    ChartSpace1.ConnectionString = "Provider=SQLOLEDB.1;Persist Security Info=TRUE;" & _
                                   "Integrated Security=SSPI;Initial Catalog=Northwind;" & _
                                   "Data Source=ServerName;"
    ChartSpace1.DataMember = "Order Details"

    ' The following two lines of code bind Chartspace1 to the Quantity and ProductID fields
    ' in the Order details table.
    ChartSpace1.SetData chConstants.chDimCategories, chConstants.chDataBound, "ProductID"
    ChartSpace1.SetData chConstants.chDimValues, chConstants.chDataBound, "Quantity"

    ' Create a format map.
    ChartSpace1.SetData chConstants.chDimFormatValues, chConstants.chDataBound, "Quantity"

    ' Set a variable to the first series in the first chart in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a segment to the format map.
    Set segSegment1 = serSeries1.FormatMap.Segments.Add

    ' Specify that the divisions in formatting be created automatically.
    segSegment1.HasAutoDivisions = True

    ' Measure the segment boundaries based upon a percentage.
    segSegment1.Begin.ValueType = chConstants.chBoundaryValuePercent
    segSegment1.End.ValueType = chConstants.chBoundaryValuePercent

    ' Set the beginning value to 0%, and the ending value to 100%.
    segSegment1.Begin.Value = 0
    segSegment1.End.Value = 1

    ' Format the interior of the matching values.
    segSegment1.Begin.Interior.Color = "White"
    segSegment1.End.Interior.Color = "Blue"

End Sub


SetExtent 方法

使用 SetExtent 方法可指定图表组件的 ChScrollView 对象的视图范围。返回 Nothing。

expression.SetExtent(HorizontalExtent, VerticalExtent)

expression 必需。返回一个 ChScrollView 对象的表达式。

HorizontalExtent Long 类型，必需。

VerticalExtent Long 类型，必需。

说明

使用此方法指定当前滚动视图位置与分别设置 HorizontalExtent 和 VerticalExtent 属性具有同样的效果。但使用 SetExtent 方法比分别设置 HorizontalExtent 和 VerticalExtent 属性需要更少的重新绘制操作。

使用 ChScrollView 对象的方法和属性可检索有关图表视图的信息，并对图表视图进行控制。显示图表自身的图表组件部分是可见绘图区，它可以显示整个图表或图表中的某一部分。如果仅图表的一部分显示在可见绘图区中，则其效果与放大图表的该部分，其他剩余部分包含在超出可见绘图区边界的可见绘图区中相似。有关 ChScrollView 对象的属性值彼此如何相关的信息，请参阅 ChScrollView 对象主题。

VerticalPosition 和 HorizontalPosition 属性描述可见绘图区的左上角位置。VerticalExtent 和 HorizontalExtent 属性描述可见绘图区右下角位置。由于经常需要集中处理这些属性，所以可以使用 SetPosition 方法指定可见绘图区的左上角位置，并使用 SetExtent 方法指定右下角位置。

示例

下例使用 SetExtent 方法将图表的滚动视图垂直和水平范围设置为 200% 的显示比例。

Dim lngHMax
Dim lngVMax

lngHMax = ChartSpace1.Charts(0).ScrollView.HorizontalExtentMax * 2
lngVMax = ChartSpace1.Charts(0).ScrollView.VerticalExtentMax * 2

ChartSpace1.Charts(0).ScrollView.SetExtent lngHMax, lngVMax


SetOneColorGradient 方法

以单色渐变填充指定 ChInterior 对象。

expression.SetOneColorGradient(GradientStyle, GradientVariant, GradientDegree, Color)

expression 必需。该表达式返回一个 ChInterior 对象。

GradientStyle ChartGradientStyleEnum 类型，必需。渐变样式。

ChartGradientStyleEnum 可以为下列 ChartGradientStyleEnum 常量之一。
chGradientDiagonalDown
chGradientDiagonalUp
chGradientFromCenter 如果将该参数设置为 chGradientFromCenter，则 GradientVariant 选项只有 chGradientVariantEnd 和 chGradientVariantStart。
chGradientFromCorner
chGradientHorizontal
chGradientVertical

GradientVariant ChartGradientVariantEnum 类型，必需。渐变变量。

ChartGradientVariantEnum 可以为下列 ChartGradientVariantEnum 常量之一。
chGradientVariantCenter
chGradientVariantEdges
chGradientVariantEnd
chGradientVariantStart

GradientDegree Double 类型，必需。渐变角度。可以为 0.0（暗）到 1.0（亮）之间的值。

Color Variant 类型，可选。渐变的前景色。可使用 Long 类型值代表红绿蓝颜色值或 String 类型值命名一种有效的 HTML 颜色值。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝颜色值（例如，红色为 RGB(255,0,0)）。如果忽略该参数，则使用 Color 属性。

示例

本示例设置 ChartSpace1 中第一张图表的前两个系列和绘图区的内部填充。

Sub FormatInteriorColors()

    Dim chConstants
    Dim serSeries1
    Dim serSeries2

    Set chConstants = ChartSpace1.Constants

    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)
    Set serSeries2 = ChartSpace1.Charts(0).SeriesCollection(1)

    ' Set the interior fill of the first series to a one-color gradient.
    serSeries1.Interior.SetOneColorGradient chConstants.chGradientDiagonalDown, _
              chConstants.chGradientVariantCenter, 0.2, "Blue"

    ' Set the interior fill of the second series to a preset gradient.
    serSeries2.Interior.SetPresetGradient chConstants.chGradientFromCenter, _
               chConstants.chGradientVariantEnd, chConstants.chGradientDaybreak

    ' Set the interior fill of the plot area to a pattern.
    ChartSpace1.Charts(0).PlotArea.Interior.SetPatterned chConstants.chPattern10Percent, _
               "Yellow", "Blue"

End Sub


SetPatterned 方法

使用预设图案填充指定的 ChInterior 对象。

expression.SetPatterned(patternType, Color, BackColor)

expression 必需。该表达式返回一个 ChInterior 对象。

patternType ChartPatternTypeEnum 类型，必需。图案样式。

ChartPatternTypeEnum 可以为下列 ChartPatternTypeEnum 常量之一。
chPattern10Percent
chPattern20Percent
chPattern25Percent
chPattern30Percent
chPattern40Percent
chPattern50Percent
chPattern5Percent
chPattern60Percent
chPattern70Percent
chPattern75Percent
chPattern80Percent
chPattern90Percent
chPatternDarkDownwardDiagonal
chPatternDarkHorizontal
chPatternDarkUpwardDiagonal
chPatternDarkVertical
chPatternDashedDownwardDiagonal
chPatternDashedHorizontal
chPatternDashedUpwardDiagonal
chPatternDashedVertical
chPatternDiagonalBrick
chPatternDivot
chPatternDottedDiamond
chPatternDottedGrid
chPatternHorizontalBrick
chPatternLargeCheckerBoard
chPatternLargeConfetti
chPatternLargeGrid
chPatternLightDownwardDiagonal
chPatternLightHorizontal
chPatternLightUpwardDiagonal
chPatternLightVertical
chPatternNarrowHorizontal
chPatternNarrowVertical
chPatternOutlinedDiamond
chPatternPlaid
chPatternShingle
chPatternSmallCheckerBoard
chPatternSmallConfetti
chPatternSmallGrid
chPatternSolidDiamond
chPatternSphere
chPatternTrellis
chPatternWave
chPatternWeave
chPatternWideDownwardDiagonal
chPatternWideUpwardDiagonal
chPatternZigZag

Color Variant 类型，可选。图案的前景色。可使用 Long 类型值代表红绿蓝颜色值或 String 类型值命名一种有效的 HTML 颜色值。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝颜色值（例如，红色为 RGB(255,0,0)）。如果忽略该参数，则使用 Color 属性。

BackColor Variant 类型，可选。图案的背景色。可使用 Long 类型值代表红绿蓝颜色值或 String 类型值命名一种有效的 HTML 颜色值。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝颜色值（例如，红色为 RGB(255,0,0)）。如果忽略该参数，则使用 BackColor 属性。

示例

本示例设置 ChartSpace1 中第一张图表的前两个系列和绘图区的内部填充。

Sub Format_Interior_Colors()

    Dim chConstants
    Dim serSeries1
    Dim serSeries2

    Set chConstants = ChartSpace1.Constants

    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)
    Set serSeries2 = ChartSpace1.Charts(0).SeriesCollection(1)

    ' Set the interior fill of the first series to a one-color gradient.
    serSeries1.Interior.SetOneColorGradient chConstants.chGradientDiagonalDown, _
              chConstants.chGradientVariantCenter, 0.2, "Blue"

    ' Set the interior fill of the second series to a preset gradient.
    serSeries2.Interior.SetPresetGradient chConstants.chGradientFromCenter, _
              chConstants.chGradientVariantEnd, chConstants.chGradientDaybreak

    ' Set the interior fill of the plot area to a pattern.
    ChartSpace1.Charts(0).PlotArea.Interior.SetPatterned chConstants.chPattern10Percent, _
              "Yellow", "Blue"

End Sub


SetPosition 方法

使用 SetPosition 方法可指定图表组件的 ChScrollView 对象的当前视图位置。返回 Nothing。

expression.SetPosition(HorizontalPosition, VerticalPosition)

expression 必需。返回一个 ChScrollView 对象的表达式。

HorizontalPosition Long 类型，必需。

VerticalPosition Long 类型，必需。

说明

使用此方法指定当前滚动视图位置与分别设置 HorizontalPosition 和 VerticalPosition 属性具有相同的效果。但是使用 SetPosition 方法比分别设置 HorizontalPosition 和 VerticalPosition 属性需要更少的重新绘制操作。

使用 ChScrollView 对象的方法和属性可检索有关图表视图的信息，并可对图表视图进行控制。显示图表自身的图表组件部分是可见绘图区，它可以显示整个图表或图表中的某一部分。如果仅图表的一部分显示在可见绘图区中，则其效果与将图表的该部分放大，其他剩余部分包含在超出可见绘图区边界的可见绘图区内相似。有关 ChScrollView 对象的属性值彼此如何相关的信息，请参阅 ChScrollView 对象主题。

VerticalPosition 和 HorizontalPosition 属性描述可见绘图区的左上角位置。VerticalExtent 和 HorizontalExtent 属性描述可见绘图区右下角位置。由于经常需要集中处理这些属性，所以可以使用 SetPosition 方法指定可见绘图区的左上角位置，并使用 SetExtent 方法指定右下角位置。

示例

下例表示可见绘图区左下角中已缩放的图表的左下角位置。

Dim lngVE
Dim lngHE
Dim lngVEM
Dim lngHEM
Dim objScrollView

Set objScrollView = ChartSpace1.Charts(0).ScrollView
lngVE = objScrollView.VerticalExtent
lngHE = objScrollView.HorizontalExtent
lngVEM = objScrollView.VerticalExtentMax
lngHEM = objScrollView.HorizontalExtentMax

' For zoomed chart, display lower left corner of virtual plot area in
' the lower left corner of the visible plot area.
If (lngVE <> lngVEM) Or (lngHE <> lngHEM) Then
 objScrollView.SetPosition 0, objScrollView.VerticalPosition + (lngVEM - lngVE)
End If


SetPresetGradient 方法

以预设渐变样式填充 ChInterior 对象。

expression.SetPresetGradient(GradientStyle, gradientVarient, gradientPreset)

expression 必需。该表达式返回“应用于”列表中的对象之一。

GradientStyle ChartGradientStyleEnum 类型，必需。渐变样式。

ChartGradientStyleEnum 可以为下列 ChartGradientStyleEnum 常量之一。
chGradientDiagonalDown
chGradientDiagonalUp
chGradientFromCenter
chGradientFromCorner
chGradientHorizontal
chGradientVertical

gradientVarient ChartGradientVariantEnum 类型，必需。渐变变量。

ChartGradientVariantEnum 可以为下列 ChartGradientVariantEnum 常量之一。
chGradientVariantCenter
chGradientVariantEdges
chGradientVariantEnd
chGradientVariantStart

gradientPreset ChartPresetGradientTypeEnum 类型，必需。用于填充指定对象的渐变样式。

ChartPresetGradientTypeEnum 可以为下列 ChartPresetGradientTypeEnum 常量之一。
chGradientBrass
chGradientCalmWater
chGradientChrome
chGradientChromeII
chGradientDaybreak
chGradientDesert
chGradientEarlySunset
chGradientFire
chGradientFog
chGradientGold
chGradientGoldII
chGradientHorizon
chGradientLateSunset
chGradientMahogany
chGradientMoss
chGradientNightfall
chGradientOcean
chGradientParchment
chGradientPeacock
chGradientRainbow
chGradientRainbowII
chGradientSapphire
chGradientSilver
chGradientWheat

示例

本示例设置 ChartSpace1 中第一张图表的前两个系列和绘图区的内部填充。

Sub Format_Interior_Colors()

    Dim chConstants
    Dim serSeries1
    Dim serSeries2

    Set chConstants = ChartSpace1.Constants

    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)
    Set serSeries2 = ChartSpace1.Charts(0).SeriesCollection(1)

    ' Set the interior fill of the first series to a one-color gradient.
    serSeries1.Interior.SetOneColorGradient chConstants.chGradientDiagonalDown, _
               chConstants.chGradientVariantCenter, 0.2, "Blue"

    ' Set the interior fill of the second series to a preset gradient.
    serSeries2.Interior.SetPresetGradient chConstants.chGradientFromCenter, _
               chConstants.chGradientVariantEnd, chConstants.chGradientDaybreak

    ' Set the interior fill of the plot area to a pattern.
    ChartSpace1.Charts(0).PlotArea.Interior.SetPatterned chConstants.chPattern10Percent, _
               "Yellow", "Blue"

End Sub


SetRootRecordset 方法

设置指定 DataSourceControl 对象的根记录集。使用该方法更改数据访问页绑定的记录集。

expression.SetRootRecordset(RecordsetName, Recordset)

expression 必需。该表达式返回一个 DataSourceControl 对象。

RecordsetName String 类型，必需。新记录集的名称。如果 DataSource 控件包含该名称的记录集，将替换该记录集。

Recordset Recordset 对象，必需。ADO 记录集。

说明

该方法支持连接任何 ADO 记录集。

示例

本示例更改数据源控件使用的根记录集。

Sub ChangeRootRecordset()
   Dim rstCategories
   Dim strShapeText
   Dim strConnectionString

   strShapeText = MSODSC.RootRecordsetDefs(0).ShapeText

   strConnectionString = "Provider=MSDataShape.1;Persist Security Info=True;Data Source" &
                        "=sqlsvr;Integrated Security=SSPI;Initial Catalog=Northwind;" &
                        "Data Provider=SQLOLEDB.1"

   Set rstCategories = CreateObject("ADODB.Recordset")

   rstCategories.Open strShapeText, strConnectionString, 1, 3

   MSODSC.SetRootRecordset "Categories", rstCategories

End Sub


SetSolid 方法

以纯色填充指定 ChInterior 对象。使用该方法将渐变、纹理、图案或背景填充转换为纯色填充。

expression.SetSolid(Color)

expression 必需。该表达式返回一个 ChInterior 对象。

Color Variant 类型，可选。指定 ChInterior 对象的颜色。可使用 Long 类型值代表红绿蓝颜色值或 String 类型值命名一种有效的 HTML 颜色值。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝颜色值（例如，红色为 RGB(255,0,0)）。

示例

本示例设置 ChartSpace1 中第一张图表的前两个系列和绘图区的内部填充。

Sub Format_Interior_Fills()

    Dim chConstants
    Dim serSeries1
    Dim serSeries2

    Set chConstants = ChartSpace1.Constants

    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)
    Set serSeries2 = ChartSpace1.Charts(0).SeriesCollection(1)

    ' Set the interior fill of the first series to a two-color gradient.
    serSeries1.Interior.SetTwoColorGradient chConstants.chGradientDiagonalDown, _
               chConstants.chGradientVariantCenter, "Blue", "Silver"

    ' Set the interior fill of the second series to a solid color.
               serSeries2.Interior.SetSolid "Purple"

    ' Set the interior fill of the plot area to a preset texture.
    ChartSpace1.Charts(0).PlotArea.Interior.SetTextured _
               chConstants.chTextureParchment, chConstants.chTile

End Sub


SetSpreadsheetData 方法

将指定图表或图表工作区绑定到 Spreadsheet 组件中工作表上的单元格区域。在调用该方法之前，图表必须已经绑定到 Spreadsheet 组件中的单元格区域。

expression.SetSpreadsheetData(DataReference, SeriesByRows)

expression 必需。该表达式返回一个 ChartSpace 或 ChChart 对象。

DataReference String 类型，必需。对绑定单元格区域的引用。可表示为单元格引用 (A1:D5) 或定义名称的形式。

SeriesByRows Boolean 类型，可选。指定是否每一行表示一个数据系列。如果每一列表示一个数据系列，则设置该属性为 False。

示例

本示例将 ChartSpace1 绑定到 Spreadsheet1 中第一个工作表的单元格 A1:F25。

ChartSpace1.SetSpreadsheetData "Sheet1!A1:F25", False


SetTextured 方法

以图像或预设纹理填充指定 ChInterior 对象。

expression.SetTextured(textureFile, TextureFormat, stackUnit, TexturePlacement)

expression 必需。该表达式返回一个 ChInterior 对象。

textureFile Variant 类型，必需。用于填充对象内部的图像。可指定指向图像文件的 URL 或 ChartPresetTextureEnum 常量。

ChartPresetTextureEnum 可以为下列 ChartPresetTextureEnum 常量之一。
chTextureBlueTissuePaper
chTextureBouquet
chTextureBrownMarble
chTextureCanvas
chTextureCork
chTextureDenim
chTextureFishFossil
chTextureGranite
chTextureGreenMarble
chTextureMediumWood
chTextureNewsprint
chTextureOak
chTexturePaperBag
chTexturePapyrus
chTextureParchment
chTexturePinkTissuePaper
chTexturePurpleMesh
chTextureRecycledPaper
chTextureSand
chTextureStationery
chTextureWalnut
chTextureWaterDroplets
chTextureWhiteMarble
chTextureWovenMat

TextureFormat ChartTextureFormatEnum 类型，可选。确定图片在指定 ChInterior 对象中的显示方式。

ChartTextureFormatEnum 可以为下列 ChartTextureFormatEnum 常量之一。
chStack
chStackScale
chStretch
chStretchPlot
chTile 默认值

stackUnit Double 类型，可选。指定当 TextureFormat 参数设置为 chStackScale 时图片如何层叠和缩放。

TexturePlacement ChartTexturePlacementEnum 类型，可选。影响图片在指定 ChInterior 对象中显示的位置。该设置只影响三维图表。

ChartTexturePlacementEnum 可以为下列 ChartTexturePlacementEnum 常量之一。
chAllFaces 默认值
chEnd
chEndSides
chFront
chFrontEnd
chFrontSides
chProjectFront
chSides

示例

本示例设置 ChartSpace1 中第一张图表的前两个系列和绘图区的内部填充。

Sub Format_Interior_Fills()

    Dim chConstants
    Dim serSeries1
    Dim serSeries2

    Set chConstants = ChartSpace1.Constants

    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)
    Set serSeries2 = ChartSpace1.Charts(0).SeriesCollection(1)

    ' Set the interior fill of the first series to a two-color gradient.
    serSeries1.Interior.SetTwoColorGradient chConstants.chGradientDiagonalDown, _
               chConstants.chGradientVariantCenter, "Blue", "Silver"

    ' Set the interior fill of the second series to a solid color.
    serSeries2.Interior.SetSolid "Purple"

    ' Set the interior fill of the plot area to a preset texture.
    ChartSpace1.Charts(0).PlotArea.Interior.SetTextured _
              chConstants.chTextureParchment, chConstants.chTile

End Sub


SetTwoColorGradient 方法

以双色渐变填充指定 ChInterior 对象。

expression.SetTwoColorGradient(GradientStyle, GradientVariant, Color, BackColor)

expression 必需。该表达式返回一个 ChInterior 对象。

GradientStyle ChartGradientStyleEnum 类型，必需。渐变样式。

ChartGradientStyleEnum 可以为下列 ChartGradientStyleEnum 常量之一。
chGradientDiagonalDown
chGradientDiagonalUp
chGradientFromCenter
chGradientFromCorner
chGradientHorizontal
chGradientVertical

GradientVariant ChartGradientVariantEnum 类型，必需。渐变变量。如果 GradientStyle 为 chGradientFromCenter，则 GradientVariant 参数只能为 chGradientVariantStart 或 chGradientVariantEnd。

ChartGradientVariantEnum 可以为下列 ChartGradientVariantEnum 常量之一。
chGradientVariantCenter
chGradientVariantEdges
chGradientVariantEnd
chGradientVariantStart

Color Variant 类型，可选。渐变的前景色。可使用 Long 类型值代表红绿蓝颜色值或 String 类型值命名一种有效的 HTML 颜色值。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝颜色值（例如，红色为 RGB(255,0,0)）。如果忽略该参数，则使用 Color 属性决定前景色。

BackColor Variant 类型，可选。渐变的背景色。可使用 Long 类型值代表红绿蓝颜色值或 String 类型值命名一种有效的 HTML 颜色值。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝颜色值（例如，红色为 RGB(255,0,0)）。如果忽略该参数，则使用 BackColor 属性。

示例

本示例设置 ChartSpace1 中第一张图表的前两个系列和绘图区的内部填充。

Sub Format_Interior_Fills()

    Dim chConstants
    Dim serSeries1
    Dim serSeries2

    Set chConstants = ChartSpace1.Constants

    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)
    Set serSeries2 = ChartSpace1.Charts(0).SeriesCollection(1)

    ' Set the interior fill of the first series to a two-color gradient.
    serSeries1.Interior.SetTwoColorGradient chConstants.chGradientDiagonalDown, _
              chConstants.chGradientVariantCenter, "Blue", "Silver"

    ' Set the interior fill of the second series to a solid color.
    serSeries2.Interior.SetSolid "Purple"

    ' Set the interior fill of the plot area to a preset texture.
    ChartSpace1.Charts(0).PlotArea.Interior.SetTextured _
              chConstants.chTextureParchment, chConstants.chTile

End Sub


Show 方法

滚动电子表格窗口，将指定区域移入视图。

expression.Show

expression 该表达式返回一个 Range 对象。

说明

如果指定的区域不在活动工作表上，该方法并不会激活该工作表。但是，当激活该工作表时将显示指定区域。例如，如果 Sheet1 当前处于活动状态而对 Sheet2 上的单元格 A500 应用该方法，则 Sheet1 将保持活动状态。如果立即手动或使用 Worksheet 对象的 Activate 方法激活 Sheet2，则将激活单元格 A500。

示例

本示例将滚动电子表格，直到显示单元格 P75。

Spreadsheet1.ActiveSheet.Range("p75").Show


ShowAbout 方法

显示“关于 Microsoft Office Web Components”对话框。

expression.ShowAbout

expression 必需。该表达式返回一个 Spreadsheet 或 PivotTable 对象。


ShowAllData 方法

在指定工作表上显示所有筛选的行，并设置所有筛选为“全部显示”。

expression.ShowAllData

expression 该表达式返回一个 Worksheet 对象。

示例

本示例在指定工作表上显示所有筛选的行，并设置所有筛选为“全部显示”。

Spreadsheet1.ActiveSheet.ShowAllData


ShowContextMenu 方法

在指定屏幕坐标显示自定义上下文菜单。

expression.ShowContextMenu(x, y, Menu)

expression 必需。该表达式返回“应用于”列表中的对象之一。

x Long 类型，必需。表示显示上下文菜单的 X 坐标。

y Long 类型，必需。表示显示上下文菜单的 Y 坐标。

Menu Variant 类型，必需。包含要显示的菜单项的数组。

示例

本示例显示一个上下文菜单。

Sub ShowMenu()

    Dim cmContextMenu(4)
    Dim cmClearSubMenu(2)

    cmClearSubMenu(0) = Array("&All", "ClearAll")
    cmClearSubMenu(1) = Array("&Formats", "ClearFormats")
    cmClearSubMenu(2) = Array("&Values", "ClearValues")

    cmContextMenu(0) = Array("Cu&t", "owc2")
    cmContextMenu(1) = Array("&Copy", "owc3")
    cmContextMenu(2) = Array("&Paste", "owc4")
    cmContextMenu(3) = Empty
    cmContextMenu(4) = Array("Clea&r", cmClearSubMenu)

    Spreadsheet1.ShowContextMenu 10, 40, cmContextMenu

End Sub


ShowDetails 方法

展开指定对象的明细单元格。如果指定对象为 PivotData 对象，则展开所有明细单元格。如果指定对象为 PivotRowMember 对象，则展开该行所有明细单元格。如果指定对象为 PivotColumnMember 对象，则展开该列所有明细单元格。

expression.ShowDetails

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例展开 PivotTable1 中的所有明细单元格。

PivotTable1.ActiveData.ShowDetails


ShowHelp 方法

显示 ShowHelp 方法应用于 ChartSpace 对象的情形。

显示 Chart 控件的主帮助主题。

expression.ShowHelp(iTopic)

expression 必需。该表达式返回一个 ChartSpace 对象。

iTopic Long 类型，必需。指定为 0 则显示 Spreadsheet 控件的主帮助主题。

显示 ShowHelp 方法应用于 PivotTable 和 Spreadsheet 对象的情形。

显示 PivotTable 或 Spreadsheet 控件的主帮助主题。

expression.ShowHelp(Topic)

expression 必需。该表达式返回上面对象之一。

Topic Long 类型，必需。指定为 0 则显示控件的主帮助主题。


SmallScroll 方法

按行或按列滚动窗口内容。

expression.SmallScroll(Down, Up, ToRight, ToLeft)

expression 必需。该表达式返回一个 Window 对象。

Down Variant 类型，可选。将内容向下滚动的行数。

Up Variant 类型，可选。将内容向上滚动的行数。

ToRight Variant 类型，可选。将内容向右滚动的列数。

ToLeft Variant 类型，可选。将内容向左滚动的列数。

说明

如果同时指定 Down 和 Up 或 ToLeft 和 ToRight，则窗口内容的滚动为参数之差。例如，如果 Down 为 3 而 Up 为 6，则内容向上滚动三行。

任何参数均可为负数。

示例

本示例将 Spreadsheet1 活动窗口的内容向下滚动三行。

Spreadsheet1.ActiveWindow.SmallScroll 3


Sort 方法

排序区域，或者如果指定区域只包含一个单元格，则返回当前区域。

expression.Sort(ColumnKey, Order, Header)

expression 该表达式返回一个 Range 对象。

ColumnKey Long 类型，必需。第一个排序列的列号。默认值为 1。

Order XlSortOrder 类型，可选。排序次序。

XlSortOrder 可以为下列 XlSortOrder 常量之一。
xlAscending 默认值
xlDescending

Header XlYesNoGuess 类型，可选。确定第一行是否包含标题。

XlYesNoGuess 可以为下列 XlYesNoGuess 常量之一。
xlGuess 让该方法确定第一行是否包含标题。
xlNo 默认值 第一行不包含标题。
xlYes 第一行包含标题。

示例

本示例在 B 列上按降序排序区域 A1:F10。

Sub SortData()
Dim ssConstants

Set ssConstants = Spreadsheet1.Constants

' Sort Range A1:F10 on column B in descending order and specify that
' row 1 contains headings.
Spreadsheet1.ActiveSheetRange("A1:F10").Sort 2, _
ssConstants.xlDescending, ssConstants.xlYes
End Sub


SortAscending 方法

以升序排序数据访问页上的字段。

expression.SortAscending

expression 必需。该表达式返回一个 DataPage 对象。

说明

该方法根据数据访问页上的当前选定内容确定排序字段。因此，当数据访问页上的控件（例如命令按钮）调用包含该方法的过程时，必须将焦点设置在排序字段。

示例

本示例以升序排序 ProductName 字段。

Sub SortProductNameAscending()

   ' Set focus to the control for the ProductName field.
   MSODSC.Datapages(0).FirstSection.HTMLContainer.Children("ProductName").Focus

   ' Sort the field in descending order.
   MSODSC.DataPages(0).SortAscending

End Sub


SortDescending 方法

以降序排序数据访问页上的字段。

expression.SortDescending

expression 必需。该表达式返回一个 DataPage 对象。

说明

该方法根据数据访问页上的当前选定内容确定排序字段。因此，当数据访问页上的控件（例如命令按钮）调用包含该方法的过程时，必须将焦点设置在排序字段。

示例

本示例以降序排序 ProductName 字段。

Sub SortProductNameDescending()

   ' Set focus to the control for the ProductName field.
   MSODSC.Datapages(0).FirstSection.HTMLContainer.Children("ProductName").Focus

   ' Sort the field in descending order.
   MSODSC.DataPages(0).SortDescending

End Sub


StartEdit 方法

使活动明细单元格进入编辑模式。

expression.StartEdit(InitialValue, ArrowMode, CaretPosition)

expression 必需。该表达式返回 PivotTable 对象之一。

InitialValue Variant 类型，可选。指定编辑单元格时的初始值。如果不指定该参数，则使用当前值。

ArrowMode PivotArrowModeEnum 类型，可选。指定用户在编辑模式下向左键和向右键的功能。

PivotArrowModeEnum 可以为下列 PivotArrowModeEnum 常量之一。
plArrowModeAccept 默认值 接受编辑并移向下一个单元格。
plArrowModeEdit 将插入点在单元格中左移或右移一个位置。

CaretPosition PivotCaretPositionEnum 类型，可选。指定单元格中插入点的位置。

PivotCaretPositionEnum 可以为下列 PivotCaretPositionEnum 常量之一。
plCaretPositionAtEnd 默认值
plCaretPositionAtMouse

说明

如果当前选定内容不是明细单元格或当前数据不可编辑，该方法将导致运行时出错。


TextHeight 方法

计算并返回一个 Variant 类型，根据当前字体设置以像素表示指定文本的高度。

expression.TextHeight(Text)

expression 必需。该表达式返回一个 ChChartDraw 对象。

Text String 类型，必需。要计算大小的文本。


TextWidth 方法

计算并返回一个 Variant 类型，根据当前字体设置以像素表示指定文本的宽度。

expression.TextWidth(Text)

expression 必需。该表达式返回一个 ChChartDraw 对象。

Text String 类型，必需。要计算大小的文本。


ToggleFilter 方法

切换已经应用于数据访问页的当前筛选状态。如果筛选为活动状态，调用该方法将去活筛选。再次调用该方法将重新应用筛选。

expression.ToggleFilter

expression 必需。该表达式返回一个 DataPage 对象。

示例

本示例切换名为 MSODSC 的数据源控件中第一个数据访问页上的筛选。

MSODSC.DataPages(0).ToggleFilter


Undo 方法

对于 ChartSpace 和 Spreadsheet 对象，撤消上一次操作或上一个位于 BeginUndo 和 EndUndo 方法调用之间的宏块。

对于 DataPage 对象，如果所做的编辑还没有保存，则将数据访问页还原到编辑前的状态。

expression.Undo

expression 该表达式返回一个 ChartSpace、DataPage 或 Spreadsheet 对象。

示例

本示例撤消上一次操作，如果操作不能撤消则显示一个消息框。

If Spreadsheet1.CanUndo Then
    Spreadsheet1.Undo
Else
    MsgBox "can't undo last action"
End If


Ungroup 方法

将指定系列移动到新层次。

expression.Ungroup(UseNewScaling)

expression 必需。该表达式返回一个 ChSeries 对象。

UseNewScaling Boolean 类型，可选。将该参数设置为 True 可指定系列使用与前一层次不同的刻度。默认值为 False。

说明

如果将系列移动到新层次，可以将系列赋予基于不同数值刻度的坐标轴。

示例

本示例基于文字类型数据创建组合图表。第一个数据系列绘制为折线图。第二个数据系列绘制为柱形图，位于自己的数值轴上。

Sub Window_Onload()

    Dim asSeriesNames(1)
    Dim asCategories(3)
    Dim aiSeries1(3)
    Dim alSeries2(3)
    Dim chConstants
    Dim chtNewChart
    Dim serUnitSales
    Dim serDispInc
    Dim axIncomeAxis

    asSeriesNames(0) = "UnitSales"
    asSeriesNames(1) = "Disposable Income"

    asCategories(0) = "Item 1"
    asCategories(1) = "Item 2"
    asCategories(2) = "Item 3"
    asCategories(3) = "Item 4"

    aiSeries1(0) = 75
    aiSeries1(1) = 84
    aiSeries1(2) = 30
    aiSeries1(3) = 94

    alSeries2(0) = 14522
    alSeries2(1) = 17321
    alSeries2(2) = 9424
    alSeries2(3) = 41782

    Set chConstants = ChartSpace1.Constants

    ' Enagble the display of the legend.
    ChartSpace1.HasChartSpaceLegend = True

    ' Add a new chart to Chartspace1.
    Set chtNewChart = ChartSpace1.Charts.Add

    ' Specify that the chart is a column chart.
    chtNewChart.Type = chConstants.chChartTypeLineMarkers

    ' Bind the chart to the arrays.
    chtNewChart.SetData chConstants.chDimSeriesNames, chConstants.chDataLiteral, asSeriesNames
    chtNewChart.SetData chConstants.chDimCategories, chConstants.chDataLiteral, asCategories

    Set serUnitSales = chtNewChart.SeriesCollection(0)

    serUnitSales.SetData chConstants.chDimValues, chConstants.chDataLiteral, aiSeries1

    Set serDispInc = chtNewChart.SeriesCollection(1)

    serDispInc.SetData chConstants.chDimValues, chConstants.chDataLiteral, alSeries2

    ' Ungroup the series.
    serDispInc.Ungroup True

    ' Add a new value axis to the chart based on the values in the series.
    Set axIncomeAxis = chtNewChart.Axes.Add(serDispInc.Scalings(chConstants.chDimValues))

    ' Place the axis on the right side of the chart.
    axIncomeAxis.Position = chConstants.chAxisPositionRight

    ' Display the series as columns.
    serDispInc.Type = chConstants.chChartTypeColumnClustered

End Sub


UnMerge 方法

将指定合并区域拆分为单个单元格。合并区域拆分后，合并区域中的值将置于区域左上角的单元格。所有其他单元格将被清除。

expression.UnMerge

expression 该表达式返回一个 Range 对象。

示例

本示例拆分包含单元格 A1 的合并区域。

Spreadsheet1.ActiveSheet.Range("A1").UnMerge


Unprotect 方法

从工作表或工作簿删除保护。如果工作表或工作簿未处于保护状态，该方法无效。该方法等效于将 Protection 对象的 Enabled 属性设置为 False。

expression.Unprotect(Password)

expression 必需。该表达式返回“应用于”列表中的对象之一。

Password 该参数在此版本的 Microsoft Office Spreadsheet 组件中不支持。


Update 方法

使用 Update 方法可将包含在 XML 映射中的数据编写成绑定到 SOAP Web 服务的数据源。返回 Nothing。

expression.Update(ShowDialogs)

expression 必需。返回一个 XmlDataBinding 对象的表达式。

ShowDialogs Boolean 类型，可选。指定当 Update 方法遇到电子表格组件自身返回的错误时，是否显示对话框。当 ShowDialogs 设为 True 时，如果 Update 方法遇到电子表格组件返回的错误，则显示对话框。当 ShowDialogs 设为 False 时，不会显示电子表格组件错误的对话框。默认值为 False。

注释 ShowDialogs 参数并不控制是否为电子表格组件之外的错误（例如脚本创作组件返回的错误）显示对话框。若要阻止为电子表格组件之外的错误显示对话框，您必须在脚本中捕获这些错误。

说明

如果 Update 方法失败，就会触发电子表格组件的 BindingError 事件，并返回所有的脚本创作错误。若要捕获更新错误，您必须向 BindingError 事件添加代码，或在脚本中捕获这些错误。在异步绑定期间，任何试图以编程方式使用 XmlDataBinding 对象的操作都会失败。可以使用 XmlDataBinding 对象的 Async 属性确定绑定是否支持异步绑定。使用 XmlDataBinding 对象的 BindingInProgress 属性可确定异步绑定是否正在进行中。

示例

可以向电子表格组件的 BindingCompleted 事件添加调用 Update 方法的代码，也可以使用 BindingInProgress 属性确定数据绑定是否正在进行中。下例使用 Update 方法为电子表格组件中的所有 XmlDataBinding 对象将数据重新编写成 SOAP Web 服务的数据源：

Sub UpdateBinding (Spreadsheet1)

    Spreadsheet1.ActiveWorkbook.XmlDataBindings.Item(2).Update

End Sub

Sub Spreadsheet1_BindingCompleted(bindingID, Action)

    If Spreadsheet1.ActiveWorkbook.XmlDataBindings.Item(bindingID).CanUpdate = True Then
        ' Write code here to perform any additional actions on this update binding.
    End If

End Sub

注释 有关从网页中运行的脚本中捕获 BindingCompleted 事件的信息，请参阅 BindingCompleted 事件主题。


UpdatePropertyToolbox 方法

以当前选定对象更新“命令 和选项”窗口。

expression.UpdatePropertyToolbox

expression 该表达式返回一个 Spreadsheet 对象。


Validate 方法

使用 Validate 方法可使电子表格组件的一个单元格或一组单元格中的数据生效。返回 Nothing。

expression.Validate()

expression 必需。返回一个 Range 对象的表达式。

说明

为电子表格组件中的单元格创建一个或多个数据有效性规则的最简单的方法是使用 Microsoft Excel。可以使用 Excel 新建一个电子表格，也可以打开一个现有的电子表格，然后使用 Excel 数据有效性功能创建数据有效性规则。将电子表格保存为 XML 电子表格文件，然后将电子表格组件的 XmlUrl 属性设置为已保存的文件。在 XML 电子表格文件中创建的有效性规则仅在通过用户接口输入数据时，才会触发有效性规则错误。例如，当用户在单元格中输入有悖于有效性规则的数据时，他会收到一条有效性规则错误消息。但是，如果以编程方式将数据输入到单元格中，或者使用 ImportXml 方法将包含无效数据的新 XML 数据文件导入到电子表格组件中，则不会触发错误消息。在这种情况下，可以使用 Validate 方法确定此类数据是否有效。

Validate 方法不会返回表示一个单元格或一组单元格包含无效数据的值。如果使用 Microsoft Visual Basic Scripting Edition (VBScript) 来使数据生效，则必须在调用 Validate 方法之前使用 On Error Resume Next 语句。在调用 Validate 方法后，应立即使用 VBScript Err 对象的 Number 属性来测试数据的生效是否成功。

示例

下列表明如果单元格中的数据有效，则函数返回 True，如果无效，则返回 False。

Dim objRange
Spreadsheet1.xmlurl = "MyXmlSpreadsheetFile.xml"
Set objRange = Spreadsheet1.Workbooks(1).ListObject("EntryID").DataBodyRange

If ValidateRange(objRange) = True Then
     ' Validation succeeded.
Else
     ' Validation failed.
End If

Function ValidateRange(objRange)
    Dim lngError
    On Error Resume Next
    objRange.Validate()
    lngError = Err.Number
    If lngError <> 0  Then
         ValidateRange = True
         Exit Function
    End If
    ValidateRange = False
End Function

下一个示例将向单元格添加数据，然后使用 Validate 方法确定数据是否满足单元格的有效性规则：

Dim objRange

Set objRange = Spreadsheet1.ActiveCell

objRange.Value = 100
On Error Resume Next

objRange.Validate()

If Err.Number <> 0 then
    objRange.Value = ""
End If


ValueToPoint 方法

显示 ValueToPoint 方法应用于 ChAxis 对象的情形。

返回一个 Coordinate 对象，包含指定坐标轴上数据点的像素坐标信息。

expression.ValueToPoint(Value)

expression 必需。该表达式返回一个 ChAxis 对象。

Value Variant 类型，必需。要返回像素坐标轴的数值。

显示 ValueToPoint 方法应用于 ChSeries 对象的情形。

返回一个 Coordinate 对象，包含指定数据点的像素坐标信息。

expression.ValueToPoint(xvalue, yvalue, zvalue)

expression 必需。该表达式返回一个 ChSeries 对象。

xvalue Variant 类型，必需。分类轴上的数值或分类标志。

yvalue Variant 类型，必需。数值轴上的值。

zvalue Variant 类型，可选。三维图表上系列坐标轴上的数值或系列标志。

说明

使用返回的 Coordinate 对象的 x 和 y 属性返回指定数据点的 X 和 Y 坐标。

示例

显示 应用于 ChSeries 对象的情形。

本示例将 Chartspace1 中第一个图表的标题更改为图表第一个系列中数据点的像素坐标。

Sub GetPixelCoordinates()

    Dim chChart1
    Dim lXPos
    Dim lYPos
    Dim coPointCoordinates

    ' Set a variable to the first chart in Chartspace1.
    Set chChart1 = ChartSpace1.Charts(0)

    ' Enable the title for the chart.
    chChart1.HasTitle = True

    ' Set a Coordinate object to the coordinates of a data point.
    Set coPointCoordinates = chChart1.SeriesCollection(0).ValueToPoint("Pears", 10)

    ' Set a variable to the X-coordinate.
    lXPos = coPointCoordinates.x

    ' Set a variable to the Y-coordinate.
    lYPos = coPointCoordinates.y

    ' Set the chart's title to the pixel coordinates of the specified
    ' data point.
    chChart1.Title.Caption = "X(" & lXPos & ") Y(" & lYPos & ")"

End Sub


Active 属性

如果选中 ListRow 对象所代表的行，则返回 True。Boolean 类型，可读写。

expression.Active

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

将 ListRow 对象的 Active 属性设置为 True 不会反映在 Selection 属性所返回的 Range 对象中。若要将行添加到选定区域，必须使用 Select 方法代替。

示例

本示例检查是否已选定 XML 列表中指定的行。

Sub IsRowActive()

      Dim objLists
      Dim objLRows
      Dim objLRow

      Set objLists = Spreadsheet1.ActiveSheet.ListObjects
      Set objLRows = objLists.Item(1).ListRows

     ' Save list row information for the third row to a variable.
      Set objLRow = objLRows.Item(3)

     ' Display whether the current row is selected.
      If objLRow.Active Then
            MsgBox ("Row is selected.")
      Else
            MsgBox ("Row is not selected.")
      End If

End Sub


ActiveCell 属性

返回代表活动单元格的 Range 对象。只读。

expression.ActiveCell

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

请仔细区分活动单元格和选定区域。活动单元格为选定区域内部的一个单元格。而选定区域可以包含多个单元格，但只有一个单元格为活动单元格。

示例

本示例设置工作表上活动单元格中的数字格式。

Spreadsheet1.ActiveCell.NumberFormat = "0.##"


ActiveData 属性

返回一个表示活动数据透视表列表中的数据的 PivotData 对象。

expression.ActiveData

expression 必需。该表达式返回一个 PivotTable 对象。


ActiveObject 属性

返回或设置一个 Object 类型，表示数据透视表列表上明细区域中的选定单元格。使用所返回对象的 Value 属性更改选定单元格的值。

expression.ActiveObject

expression 必需。该表达式返回一个 PivotTable 对象。

说明

如果没有选定明细单元格，则该属性返回 Nothing。

示例

本示例启用 PivotTable1 中明细记录的编辑，然后在选定明细单元格中写入当前日期。如果选定单元格中已经插入了日期，则不允许编辑明细记录。

Sub EditSelectedCell()

    Dim objActiveCell

    ' Allow editing of detail records.
    PivotTable1.ActiveView.AllowEdits = True

    ' Set a variable to the currently selected cell.
    Set objActiveCell = PivotTable1.ActiveObject

    ' Check whether a detail cell is selected.
    If Not objActiveCell Is Nothing Then

        ' Set the value of the detail cell
        ' to the current date.
        ' Note: This will result in a run-time
        ' error if the data type of the selected
        ' cell does not support date values.
        objActiveCell.Value = Date

    End If

    ' Disallow editing of detail records.
    PivotTable1.ActiveView.AllowEdits = False

End Sub


ActivePane 属性

返回代表活动电子表格窗格的 Pane 对象。只读。

expression.ActivePane

expression 必需。该表达式返回一个 Window 对象。

示例

本示例将设置电子表格活动窗格中可见区域左上角单元格的值。

Spreadsheet1.ActivePane.VisibleRange.Cells(1, 1).Value = "top left"


ActiveSheet 属性

返回代表活动工作表的 Worksheet 对象。只读。

expression.ActiveSheet

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例更改活动工作表的名称。

Spreadsheet1.ActiveSheet.Name = "Budget Sheet"


ActiveView 属性

返回代表活动“数据透视表”列表布局的 PivotView 对象。为“数据透视表”活动视图设置变量为更改活动视图提供了一种方便的方法。只读。

expression.Case

expression 必需。该表达式返回一个 PivotTable 对象。

示例

本示例在 PivotTable1 的活动视图中插入两个字段集。

Sub Insert_Fieldsets()
    Dim vwView

    Set vwView = PivotTable1.ActiveView

    ' Add the Store Type field to the column axis.
    vwView.ColumnAxis.InsertFieldSet vwView.FieldSets("Store Type")

    ' Add the Promotions field to the row axis.
    vwView.RowAxis.InsertFieldSet vwView.FieldSets("Promotions")
End Sub


ActiveWindow 属性

返回表示当前窗口的 Window 对象。

expression.ActiveWindow

expression 必需。该表达式返回一个 Spreadsheet 对象。

示例

本示例隐藏 Spreadsheet1 中活动窗口中的行列标题。

Sub HideHeadings()
   Spreadsheet1.ActiveWindow.DisplayColumnHeadings = False
   Spreadsheet1.ActiveWindow.DisplayRowHeadings = False
End Sub


ActiveWorkbook 属性

返回表示打开工作簿的 Workbook 对象。

expression.ActiveWorkbook

expression 必需。该表达式返回一个 Spreadsheet 对象。

示例

本示例保护 Spreadsheet1 中打开工作簿的结构。

Speadsheet1.ActiveWorkbook.Protect , True


Address 属性

显示 Address 属性应用于 Hyperlink 和 PivotHyperlink 对象的情形。

返回或设置一个 String 类型，表示目标文档的地址。可读写。

expression.Address

expression 必需。该表达式返回一个 Hyperlink 或 PivotHyperlink 对象。

显示 Address 属性应用于 Range 对象的情形。

返回一个 String 类型，表示指定区域的地址（例如，A1）。只读。

expression.Address(RowAbsolute, ColumnAbsolute, ReferenceStyle, External, RelativeTo)

expression 必需。该表达式返回一个 Range 对象。

RowAbsolute Variant 类型，可选。设置为 True 将以绝对引用返回引用的行部分。默认值为 True。

ColumnAbsolute Variant 类型，可选。设置为 True 将以绝对引用返回引用的列部分。默认值为 True。

ReferenceStyle xlReferenceStyle 类型，可选。引用样式。

ReferenceStyle 可以为下列 XlReferenceStyle 常量之一。
xlA1
xlR1C1

External Variant 类型，可选。设置为 True 将返回外部引用。外部引用包括工作表的名称。设置为 False 将返回本地引用。默认值为 False。

RelativeTo Variant 类型，可选。如果 RowAbsolute 和 ColumnAbsolute 为 False，并且 ReferenceStyle 为 xlR1C1，则必须包括相对引用的起始点。该参数为定义起始点的 Range 对象。

示例

显示 应用于 Hyperlink 对象的情形。

本示例在 Spreadsheet1 中 Sheet1 的单元格 C10 插入超链接。
Sub Insert_Hyperlink()
    Dim rngNewHyperlink

    Set rngNewHyperlink = Spreadsheet1.Worksheets("sheet1").Range("c10")

    rngNewHyperlink.Value = "Click to read about the latest Office updates"
    rngNewHyperlink.Hyperlink.Address = "http://officeupdate.microsoft.com"
End Sub

应用于 Range 对象的情形。

本示例返回可见区域的地址。

MsgBox Spreadsheet1.ActiveSheet.VisibleRange.Address


Aggregates 属性

返回指定单元格的 PivotAggregates 集合。

expression.Aggregates

expression 必需。该表达式返回一个 PivotCell 对象。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


AllGroupingDefs 属性

返回指定数据源控件的 AllGroupingDefs 对象。只读。

expression.AllGroupingDefs

expression 必需。该表达式返回一个 DataSourceControl 对象。


AllIncludeExclude 属性

返回或设置一个 PivotFieldSetAllIncludeExcludeEnum 类型，表示指定字段集的 IncludedMembers 或 ExcludedMembers 列表中未列出的所有成员的包含状态。可读写。

PivotFieldSetAllIncludeExcludeEnum 可以为下列 PivotFieldSetAllIncludeExcludeEnum 常量之一。
plAllDefault 默认值 当字段集在数据透视表的行或列坐标轴上时包括所有成员。
plAllExclude
plAllInclude

expression.AllIncludeExclude

expression 必需。该表达式返回一个 PivotFieldSet 对象。

示例

本示例设置 PivotTable1 中 Store State 和 Store City 字段的包括和排除成员。包括和排除中未列出的成员将排除在外。

Sub MemberFiltering()

    Dim fldStoreCity
    Dim fldStoreState
    Dim ptView
    Dim ptConstants

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the current PivotTable view.
    Set ptView = PivotTable1.ActiveView

    ' Set a variable to the Store State field.
    Set fldStoreState = ptView.FieldSets("Store").Fields("Store State")

    ' Set a variable to the Store City field.
    Set fldStoreCity = ptView.FieldSets("Store").Fields("Store City")

    ' Exclude California and Washington from the Store State field.
    fldStoreState.ExcludedMembers = Array("CA", "WA")

    ' Include members of the Store City field. Note that the cities are
    ' in states that have been excluded by the previous line. Since
    ' Store State is a parent to Store City, then the excluded states
    ' are displayed in the PivotTable.
    fldStoreCity.IncludedMembers = Array("Los Angeles", "San Diego", _
                                         "Seattle", "Spokane")

    ' Exclude all members that are not in the list for the IncludedMembers and
    ' ExcludedMembers properties.
    ptView.FieldSets("Store").AllIncludeExclude = ptConstants.plAllExclude

End Sub


AllMember 属性

返回一个 PivotMember 对象，表示指定字段集中的顶层成员。

expression.AllMember

expression 必需。该表达式返回一个 PivotFieldSet 对象。


AllowAdditions 属性

对于 GroupLevel 对象：返回或设置一个 Boolean 类型，表示用户是否可以在指定组中添加记录。将该属性设置为 False 可禁止用户在组中添加记录。默认值为 True。可读写。

对于 PivotView 对象：返回或设置一个 Boolean 类型，表示用户是否可以在数据透视表列表的明细区域中新添记录。将该属性设置为 True 将允许用户插入新记录。默认值为 False。可读写。

expression.AllowAdditions

expression 必需。该表达式返回一个 GroupLevel 或 PivotView 对象。

说明

如果该属性设置为 True，则明细区域的空行中将显示星号 (*)。新添到数据透视表列表的明细区域中的记录也将添加到数据源。

如果数据源不允许插入，则不能在数据透视表列表中添加记录。

示例

本示例允许用户在 PivotTable1 的明细区域中新添记录。

PivotTable1.ActiveView.AllowAdditions = True


AllowCustomOrdering 属性

返回或设置用户是否可以重排行坐标轴或列坐标轴的成员。将该属性设置为 False 可禁止用户重排行坐标轴或列坐标轴的成员。默认值为 True。Boolean 类型，可读写。

expression.AllowCustomOrdering

expression 必需。该表达式返回一个 PivotTable 对象。

示例

本示例禁止用户重排 PivotTable1 中行坐标轴或列坐标轴的成员。

PivotTable1.AllowCustomOrdering = False


AllowDeletingColumns 属性

指定在工作表处于保护状态下时，是否可以删除工作表的列。默认值为 False，但当 Protection 对象的 Enabled 属性设置为 False 时无效。Boolean 类型，可读写。

expression.AllowDeletingColumns

expression 必需。该表达式返回一个 Protection 对象。

示例

本示例将锁定 Sheet1 上的所有单元格、启用对列的插入和删除操作，然后保护 Sheet1。

Sub Protect_Worksheet()
    Dim ptProtSheet1

    'Lock all cells on the worksheet.
    Spreadsheet1.Worksheets("Sheet1").Cells.Locked = True

    Set ptProtSheet1 = Spreadsheet1.Worksheets("Sheet1").Protection

    ' Allows user to delete columns while Sheet1 is protected.
    ptProtSheet1.AllowDeletingColumns = True

    ' Allows user to insert columns while Sheet1 is protected.
    ptProtSheet1.AllowInsertingColumns = True

    ' Protect Sheet1.
    ptProtSheet1.Enabled = True
End Sub


AllowDeletingRows 属性

指定在工作表处于保护状态下时，是否可以删除工作表的行。默认值为 False，但当 Protection 对象的 Enabled 属性设置为 False 时无效。Boolean 类型，可读写。

expression.AllowDeletingRows

expression 必需。该表达式返回一个 Protection 对象。

示例

本示例将锁定 Sheet1 上的所有单元格、启用对行的插入和删除操作，然后保护 Sheet1。

Sub Protect_Worksheet()
    Dim ptProtSheet1

    'Lock all cells on the worksheet.
    Spreadsheet1.Worksheets("Sheet1").Cells.Locked = True

    Set ptProtSheet1 = Spreadsheet1.Worksheets("Sheet1").Protection

    ' Allows user to delete rows while Sheet1 is protected.
    ptProtSheet1.AllowDeletingRows = True

    ' Allows user to insert rows while Sheet1 is protected.
    ptProtSheet1.AllowInsertingRows = True

    ' Protect Sheet1.
    ptProtSheet1.Enabled = True
End Sub


AllowDeletions 属性

对于 GroupLevel 对象：返回或设置一个 Boolean 类型，表示用户是否可以从指定组中删除记录。将该属性设置为 False 可禁止用户删除组中记录。默认值为 True。可读写。

对于 PivotView 对象：返回或设置一个 Boolean 类型，表示用户是否可以从指定数据透视表列表的明细区域中删除记录。将该属性设置为 True 可允许用户删除组中记录。默认值为 False。可读写。

expression.AllowDeletions

expression 必需。该表达式返回一个 GroupLevel 或 PivotView 对象。

说明

从数据透视表列表明细区域中删除的记录也将从源数据库中删除。如果源记录集不允许删除，则用户不能从数据透视表列表明细区域中删除记录。

示例

本示例允许用户从 PivotTable1 的明细区域删除记录。

PivotTable1.ActiveView.AllowDeletions = True


AllowDetails 属性

指定用户是否可以展开指定“数据透视表”列表的内部成员以显示详细记录。默认值为 True。Boolean 类型，可读写。

expression.AllowDetails

expression 必需。该表达式返回一个 PivotTable 对象。

说明

如果该属性为 False，内部成员将不显示展开指示器，禁用大部分聚合项的 Expand 命令，双击聚合项不会显示详细数据。如果该属性为 False，用户仍然可以通过编程手段查看详细信息。

示例

本示例禁用对“数据透视表”列表详细信息的查看。

PivotTable1.AllowDetails = False


AllowEdits 属性

对于 GroupLevel 对象：返回或设置一个 Boolean 类型，表示用户是否可以编辑指定组中的记录。将该属性设置为 False 可禁止用户编辑组中记录。默认值为 True。可读写。

对于 PivotView 对象：返回或设置一个 Boolean 类型，表示用户是否可以编辑数据透视表列表明细区域中的单元格。将该属性设置为 True 将允许用户编辑明细区域中的单元格。默认值为 False。可读写。

expression.AllowEdits

expression 必需。该表达式返回一个 GroupLevel 或 PivotView 对象。

说明

更改单元格数值将对源数据库进行相应的更改。源数据库中标记为只读的字段不能在数据透视表列表中编辑。

示例

本示例启用 PivotTable1 中明细区域的编辑。

PivotTable1.ActiveView.AllowEdits = True


AllowFiltering 属性

显示 AllowFiltering 属性应用于 Protection 对象的情形。

确定在工作表处于保护状态时，是否可启用或禁用“自动筛选”。如果 Protection 对象的 Enabled 属性设置为 False，则该属性无效。设置该属性为 True 将禁用工具栏上的命令。如果在该属性设置为 False 之前“自动筛选”处于启用状态，用户仍然可以筛选数据。Boolean 类型，可读写。

expression.AllowFiltering

expression 必需。该表达式返回一个 Protection 对象。

显示 AllowFiltering 属性应用于 PivotTable 对象的情形。

确定是否可以在“数据透视表”列表的筛选区添加或删除字段，以及是否启用工具栏上的“自动筛选”命令。默认值为 True。Boolean 类型，可读写。

expression.AllowFiltering

expression 必需。该表达式返回一个 PivotTable 对象。

示例

显示 应用于 Protection 对象的情形。

本示例锁定 Sheet1 上的所有单元格，启用对列的插入和删除操作，禁用工具栏上的“自动筛选”命令，然后保护 Sheet1。

Sub Protect_Worksheet()
Dim ptProtSheet1

'Lock all cells on the worksheet.
Spreadsheet1.Worksheets("Sheet1").Cells.Locked = True

Set ptProtSheet1 = Spreadsheet1.Worksheets("Sheet1").Protection

' Allows user to delete columns while Sheet1 is protected.
ptProtSheet1.AllowDeletingColumns = True

' Allows user to insert columns while Sheet1 is protected.
ptProtSheet1.AllowInsertingColumns = True

' Disable the AutoFilter command on the toolbar.
ptProtSheet1.AllowFiltering = False

' Protect Sheet1.
ptProtSheet1.Enabled = True
End Sub

显示 应用于 PivotTable 对象的情形。

本示例禁用对“数据透视表”列表的筛选。

PivotTable1.AllowFiltering = False


AllowFormattingColumns 属性

返回或设置是否可以调整保护工作表上的列宽。将该属性设置为 True 将启用工作表处于保护状态下的列宽调整。默认值为 False。Boolean 类型，可读写。

expression.AllowFormattingColumns

expression 必需。该表达式返回一个 Protection 对象。

示例

本示例锁定 Sheet1 上的所有单元格，然后启用用户对行列的调整，再保护 Sheet1。

Sub Protect_Worksheet()
    Dim ptProtSheet1

    ' Lock all cells on the worksheet.
    Spreadsheet1.Worksheets("Sheet1").Cells.Locked = True

    Set ptProtSheet1 = Spreadsheet1.Worksheets("Sheet1").Protection

    ' Allows user to resize rows while Sheet1 is protected.
    ptProtSheet1.AllowFormattingRows = True

    ' Allows user to resize columns while Sheet1 is protected.
    ptProtSheet1.AllowFormattingColumns = True

    ' Protect Sheet1.
    ptProtSheet1.Enabled = True
End Sub


AllowFormattingRows 属性

返回或设置是否可以调整保护工作表上的行高。将该属性设置为 True 将启用工作表处于保护状态下的行高调整。默认值为 False。Boolean 类型，可读写。

expression.AllowFormattingRows

expression 必需。该表达式返回一个 Protection 对象。

示例

本示例锁定 Sheet1 上的所有单元格，然后启用用户对行列的调整，再保护 Sheet1。

Sub Protect_Worksheet()

    Dim ptProtSheet1

    ' Lock all cells on the worksheet.
    Spreadsheet1.Worksheets("Sheet1").Cells.Locked = True

    Set ptProtSheet1 = Spreadsheet1.Worksheets("Sheet1").Protection

    ' Allows user to resize rows while Sheet1 is protected.
    ptProtSheet1.AllowFormattingRows = True

    ' Allows user to resize columns while Sheet1 is protected.
    ptProtSheet1.AllowFormattingColumns = True

    ' Protect Sheet1.
    ptProtSheet1.Enabled = True

End Sub


AllowGrouping 属性

如果用户可以对指定数据透视表列表中的行坐标轴或列坐标轴上的字段分组，则返回 True。如果该属性设置为 False，将禁用分组按钮，但是用户仍然可以通过编程进行字段分组。默认值为 True。Boolean 类型，可读写。

expression.AllowGrouping

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

如果该属性设置为 False，将禁用透视。这意味着行和列区域中的成员是固定的，不能将字段拖入或拖出这些区域。所有与分组相关的命令都将禁用，包括下列命令：

  • 移动到列区域
  • 移动到明细区域（如果选定内容为行或列区域中的字段）
  • 移动到筛选区域
  • 移动到行区域

如果为 False，将冻结报表版式，但是用户仍然可以筛选数据。

示例

本示例将禁用数据透视表列表的字段分组。

PivotTable1.AllowGrouping = False


AllowHeadingRename 属性

指定是否可以自定义保护工作表中的行和列标题。设置该属性为 True 可自定义保护工作表中的列标题。默认值为 False。Boolean 类型，可读写。

expression.AllowHeadingRename

expression 必需。该表达式返回一个 Protection 对象。

说明

将该属性设置为 False 之后，设置行或列标题的 Caption 属性将导致运行时出错。必须将 Protection 对象的 Enabled 属性设置为 True 使该属性生效。

示例

本示例锁定 Sheet1 上的所有单元格，启用列的插入和删除，禁用行列标题的自定义，然后保护 Sheet1。

Sub Protect_Worksheet()

    Dim ptProtSheet1

    'Lock all cells on the worksheet.
    Spreadsheet1.Worksheets("Sheet1").Cells.Locked = True

    Set ptProtSheet1 = Spreadsheet1.Worksheets("Sheet1").Protection

    ' Allows user to delete columns while Sheet1 is protected.
    ptProtSheet1.AllowDeletingColumns = True

    ' Allows user to insert columns while Sheet1 is protected.
    ptProtSheet1.AllowInsertingColumns = True

    ' prevent row and column headings from being customized.
    ptProtectSheet1.AllowHeadingRename = False

    ' Protect Sheet1.
    ptProtectSheet1.Enabled = True

End Sub


AllowInsertingColumns 属性

指定在工作表处于保护状态下时，是否可以插入工作表列。默认值为 False，但当 Protection 对象的 Enabled 属性设置为 False 时无效。Boolean 类型，可读写。

expression.AllowInsertingColumns

expression 必需。该表达式返回一个 Protection 对象。

示例

本示例锁定 Sheet1 上的所有单元格，然后启用对列的插入和删除操作，然后保护 Sheet1。

Sub Protect_Worksheet()
    Dim ptProtSheet1

    'Lock all cells on the worksheet.
    Spreadsheet1.Worksheets("Sheet1").Cells.Locked = True

    Set ptProtSheet1 = Spreadsheet1.Worksheets("Sheet1").Protection

    ' Allows user to delete columns while Sheet1 is protected.
    ptProtSheet1.AllowDeletingColumns = True

    ' Allows user to insert columns while Sheet1 is protected.
    ptProtSheet1.AllowInsertingColumns = True

    ' Protect Sheet1.
    ptProtSheet1.Enabled = True
End Sub


AllowInsertingRows 属性

指定在工作表处于保护状态下时，是否可以插入工作表行。默认值为 False，但当 Protection 对象的 Enabled 属性设置为 False 时无效。Boolean 类型，可读写。

expression.AllowInsertingRows

expression 必需。该表达式返回一个 Protection 对象。

示例

本示例锁定 Sheet1 上的所有单元格，然后启用对行的插入和删除操作，然后保护 Sheet1。

Sub Protect_Worksheet()
    Dim ptProtSheet1

    'Lock all cells on the worksheet.
    Spreadsheet1.Worksheets("Sheet1").Cells.Locked = True

    Set ptProtSheet1 = Spreadsheet1.Worksheets("Sheet1").Protection

    ' Allows user to delete rows while Sheet1 is protected.
    ptProtSheet1.AllowDeletingRows = True

    ' Allows user to insert rows while Sheet1 is protected.
    ptProtSheet1.AllowInsertingRows = True

    ' Protect Sheet1.
    ptProtSheet1.Enabled = True
End Sub


AllowLayoutEvents 属性

设置该属性为 True 将启用 AfterLayout 事件。默认值为 False。Boolean 类型，可读写。

expression.AllowLayoutEvents

expression 必需。该表达式返回一个 ChartSpace 对象。

示例

本示例启用 ChartSpace1 的所有事件。

Sub Window_Onload()

    ' Allow the AfterLayout event to fire.
    ChartSpace1.AllowLayoutEvents = True

    ' Allow BeforeRender and AfterRender events
    ' to fire as each data point is rendered.
    ChartSpace1.AllowPointRenderEvents = True

    ' Allow BeforeRender and AfterRender events
    ' to fire as each chart element is rendered.
    ' The AfterFinalRender event will fire after
    ' all chart elements have been rendered.
    ChartSpace1.AllowRenderEvents = True

    ' Allow the BeforeScreenTip event to fire.
    ChartSpace1.AllowScreenTipEvents = True

End Sub


AllowMultiFilter 属性

返回或设置在指定字段集处于数据透视表列表筛选区域时用户是否可以选择多项。默认值为 True。Boolean 类型，可读写。

expression.AllowMultiFilter

expression 必需。该表达式返回一个 PivotFieldSet 对象。

说明

将该属性设置为 False 将仿效字段集在 Microsoft Office 2000 PivotTable 组件筛选区域中的行为。

示例

本示例禁用 Merchant 字段在 PivotTable1 的筛选区域时的多项选择。

PivotTable1.ActiveView.FieldSets("Merchant").AllowMultiFilter = False


AllowPointRenderEvents 属性

设置该属性为 True 将启用在着色每个数据点时调用 BeforeRender 和 AfterRender 事件。默认值为 False。Boolean 类型，可读写。

expression.AllowPointRenderEvents

expression 必需。该表达式返回一个 ChartSpace 对象。

示例

本示例启用 ChartSpace1 的所有事件。

Sub Window_Onload()

    ' Allow the AfterLayout event to be called.
    ChartSpace1.AllowLayoutEvents = True

    ' Allow BeforeRender and AfterRender events
    ' to be called as each data point is rendered.
    ChartSpace1.AllowPointRenderEvents = True

    ' Allow BeforeRender and AfterRender events
    ' to be called as each chart element is rendered.
    ' The AfterFinalRender event will fire after
    ' all chart elements have been rendered.
    ChartSpace1.AllowRenderEvents = True

    ' Allow the BeforeScreenTip event to be called.
    ChartSpace1.AllowScreenTipEvents = True

End Sub


AllowPropertyToolbox 属性

确定用户是否可以在运行时显示“命令和选项”对话框。设置 AllowPropertyToolbox 属性为 False 将禁用工具栏上的“命令和选项”按钮。默认值为 True。Boolean 类型，可读写。

expression.AllowPropertyToolbox

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例在运行时禁用 Spreadsheeet1 工具栏上的“命令和选项”按钮。

Spreadsheet1.AllowPropertyToolbox = False


AllowRenderEvents 属性

设置该属性为 True 将启用 BeforeRender、AfterRender 和 AfterFinalRender 事件。默认值为 False。Boolean 类型，可读写。

expression.AllowRenderEvents

expression 必需。该表达式返回一个 ChartSpace 对象。

示例

本示例启用 ChartSpace1 的所有事件。

Sub Window_Onload()

    ' Allow the AfterLayout event to fire.
    ChartSpace1.AllowLayoutEvents = True

    ' Allow BeforeRender and AfterRender events
    ' to fire as each data point is rendered.
    ChartSpace1.AllowPointRenderEvents = True

    ' Allow BeforeRender and AfterRender events
    ' to fire as each chart element is rendered.
    ' The AfterFinalRender event will fire after
    ' all chart elements have been rendered.
    ChartSpace1.AllowRenderEvents = True

    ' Allow the BeforeScreenTip event to fire.
    ChartSpace1.AllowScreenTipEvents = True

End Sub


AllowScreenTipEvents 属性

设置该属性为 True 将启用 BeforeScreenTip 事件。默认值为 False。Boolean 类型，可读写。

expression.AllowScreenTipEvents

expression 必需。该表达式返回一个 ChartSpace 对象。

说明

BeforeScreenTip 事件使得可以在显示之前修改屏幕提示。

示例

本示例启用 ChartSpace1 的所有事件。

Sub Window_Onload()

    ' Allow the AfterLayout event to be called.
    ChartSpace1.AllowLayoutEvents = True

    ' Allow BeforeRender and AfterRender events
    ' to fire as each data point is rendered.
    ChartSpace1.AllowPointRenderEvents = True

    ' Allow BeforeRender and AfterRender events
    ' to be called as each chart element is rendered.
    ' The AfterFinalRender event will be called after
    ' all chart elements have been rendered.
    ChartSpace1.AllowRenderEvents = True

    ' Allow the BeforeScreenTip event to be called.
    ChartSpace1.AllowScreenTipEvents = True

End Sub


AllowSorting 属性

指定在工作表处于保护状态下时，是否可以进行排序。默认值为 False，但当 Protection 对象的 Enabled 属性设置为 False 时无效。Boolean 类型，可读写。

expression.AllowSorting

expression 必需。该表达式返回一个 Protection 对象。

示例

本示例锁定 Sheet1 上的所有单元格，启用行列筛选和排序，然后保护工作表。

Sub Protect_Worksheet()
    Dim ptProtSheet1

    'Lock all cells on the worksheet.
    Spreadsheet1.Worksheets("Sheet1").Cells.Locked = True

    Set ptProtSheet1 = Spreadsheet1.Worksheets("Sheet1").Protection

    ' Allows user to filter rows while Sheet1 is protected.
    ptProtSheet1.AllowFiltering = True

    ' Allows user to sort rows and columns while Sheet1 is protected.
    ptProtSheet1.AllowSorting = True

    ' Protect Sheet1.
    ptProtSheet1.Enabled = True
End Sub


AllowUISelection 属性

返回或设置当用户用鼠标单击元素时是否选择图表中的元素。Boolean 类型，可读写。

expression.AllowUISelection

expression 必需。该表达式返回一个 ChartSpace 对象。

说明

如果该属性设置为 True，则当用户用鼠标单击图表元素时，当前的所选区域列表将被清空，而变为只包含用户单击的元素。如果该属性设置为 False，则当用户用鼠标单击元素时，将保留当前的所选区域列表，并忽略鼠标单击事件。默认值为 True。

示例

以下示例禁用 AllowUISelection 属性。

ChartSpace1.AllowUISelection = False


AllPageFields 属性

返回数据源控件的 AllPageFields 集合。只读。

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


AlternateDataSource 属性

返回或设置备用数据源（将用作数据源的其他复杂数据绑定控件）ID。String 类型，可读写。

expression.AlternateDataSource

expression 必需。该表达式返回一个 ElementExtension 对象。


AlternateRowColor 属性

返回或设置一个 String 类型，表示指定组中每隔一行的颜色。可读写。

expression.AlternateRowColor

expression 必需。该表达式返回一个 GroupLevel 对象。


AlwaysIncludeInCube 属性

返回或设置指定字段集是否总是包含在数据透视表列表的本地缓存中。将该属性设置为 True 可确保指定字段集包含在本地缓存中。默认值为 False。Boolean 类型，可读写。

expression.AlwaysIncludeInCube

expression 必需。该表达式返回一个 PivotFieldSet 对象。

说明

将字段的该属性设置为 True，可确保正确计算基于字段集的计算总计。


AmbientLightIntensity 属性

返回或设置一个 Double 类型，指定照亮三维图表的环境照明百分比。有效设置范围为 0 到 1。可读写。

expression.AmbientLightIntensity

expression 必需。该表达式返回一个 ChChart 对象。

示例

本示例将 Chartspace1 中的单元格图表转换为三维条形图，并设置图表的照明角度选项。

Sub Format3DLightSources()

    Dim cht3DBar

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DBar = ChartSpace1.Charts(0)

    ' Change the chart to a 3D Bar chart.
    cht3DBar.Type = chChartTypeBar3D

    ' Set the intensity of the ambient light.
    cht3DBar.AmbientLightIntensity = 0.7

    ' Set the inclination of the directional light source.
    cht3DBar.DirectionalLightInclination = 35

    ' Set the intensity of the directional light source.
    cht3DBar.DirectionalLightIntensity = 0.8

    ' Set the rotation of the directional light source.
    cht3DBar.DirectionalLightRotation = 120

End Sub


Amount 属性

返回或设置固定数值和百分比误差线的误差量。使用 SetData 方法指定数据绑定误差线的误差量。Double 类型，可读写。

expression.Amount

expression 必需。该表达式返回一个 ChErrorBars 对象。

说明

该数值将进行算术纠正，这意味着 5% 以 0.05 表示而不是以 5 表示。固定值为 5 的误差线在转换为百分比时将为 500%。

示例

本示例为 ChartSpace1 中第一张图表的所有系列添加误差线，并设置误差量。

Sub Add_Error_Bars()
    Dim ebErrorBars
    Dim serChartSeries
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Loop through all of the series in the first chart
    ' of ChartSpace1.
    For Each serChartSeries in ChartSpace1.Charts(0).SeriesCollection

        ' Add error bars to the current series.
        Set ebErrorBars = serChartSeries.ErrorBarsCollection.Add

        ' Set the error bars to be a percentage of the value.
        ebErrorBars.Type = chConstants.chErrorBarTypePercent

        ' Set the percentage amount.
        ebErrorBars.Amount = 0.05
    Next
End Sub


Application 属性

显示 Application 属性应用于“应用于”列表中除 OWCLanguageSettings 对象之外的所有对象的情形。

返回表示电子表格控件的 Spreadsheet 对象。

expression.Application

expression 必需。该表达式返回上面对象之一。

显示 Application 属性应用于 OWCLanguageSettings 对象的情形。

返回表示指定 Microsoft Office Web Component 的 Object 对象。

expression.Application

expression 必需。该表达式返回一个 OWCLanguageSettings 对象。


AspectRatio 属性

返回或设置一个 Long 类型，指定特定三维图表的高度与宽度之比。将该属性设置为大于 100 将得到高大于宽的图表，而设置为小于 100 将得到宽大于高的图表。有效设置范围为 0 到 500。可读写。

expression.AspectRatio

expression 必需。该表达式返回一个 ChChart 对象。

说明

该属性对三维饼图无效，请使用 Thickness 属性增加三维饼图的厚度。

示例

本示例将 Chartspace1 中的第一张图表转换为三维柱形图，然后增加图表的宽度和深度。

Sub Format3DDepthWidth()

    Dim cht3DColumn

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DColumn = ChartSpace1.Charts(0)

    ' Change the chart to a 3-D Column chart.
    cht3DColumn.Type = chChartTypeColumnClustered3D

    ' Increase the depth of the chart in relation
    ' to it's width.
    cht3DColumn.ChartDepth = 125

    ' Increase the width of the chart in relation
    ' to it's height.
    cht3DColumn.AspectRatio = 80

End Sub


Async 属性

指定 XMLDataBinding 对象的绑定是否为异步绑定。只读。

expression.Async

expression 必需。该表达式返回一个 XmlDataBinding 对象。

说明

可使用 XmlDataBinding 对象的 Async 属性确定绑定是否支持异步绑定。如果绑定为异步绑定，则返回 True，否则，返回 False。默认值为 False。

该属性仅影响 Query 绑定的行为。当该值为 True 时，在页面加载过程中，在 LoadMode=Normal 绑定实际发生之前，Spreadsheet 组件将与所有静态数据一起呈现。当进行异步绑定时，Spreadsheet 组件将处于非交互模式（类似于“仅查看”模式）。绑定结束且该事件发生后，用户界面将变为交互模式。

当该值为 False 时，只有在 LoadMode=Normal 绑定加载完成后，页面才会呈现。在绑定操作完成之前，不会对用户界面命令或 Refresh 方法调用所引发的刷新操作做出响应。

当进行异步绑定时，任何以编程方式处理 XmlDataBinding 对象的操作都将失败。

示例

以下 VBScript 示例检查 XMLDataBindings 集合中的第一个 XMLDataBinding 对象是否为异步绑定状态。如果为异步状态，则显示一个消息框。

Sub Async()

    Dim objBinding
    Set objBinding = Spreadsheet1.ActiveWorkbook.XmlDataBindings.Item(1)

    ' Check to see if the binding is asynchronous.
    If objBinding.Async = True Then

        ' Alert the user if the binding state is asynchronous.
        MsgBox ("The binding is asynchronous.")

    End If

End Sub


AutoFilter 属性

返回指定工作表的 AutoFilter 对象。

expression.AutoFilter

expression 该表达式返回 Worksheet 对象。

说明

请不要将该属性与 AutoFilter 方法相混淆。该属性返回指定工作表的 AutoFilter 对象，而 AutoFilter 方法应用于 Range 对象并打开“自动筛选”。

示例

本示例打开 A1:C20 区域内的“自动筛选”，为 A 列和 C 列设置筛选，然后应用这些筛选。

Sub Apply_AutoFilter()
    Dim afFilters
    Dim afCol1
    Dim afCol3

    ' Turn on AutoFilter.
    Spreadsheet1.Worksheets("Sheet1").Range("A1:C20").AutoFilter

    ' Set a variable to the AutoFilter object.
    Set afFilters = Spreadsheet1.Worksheets("sheet1").AutoFilter

    Set afCol1 = afFilters.Filters(1)
    Set afCol3 = afFilters.Filters(3)

    ' Add a criteria that excludes blue from column A.
    afCol1.Criteria.Add "blue"

    ' Add a criteria that excludes green from column A.
    afCol1.Criteria.Add "green"

    ' Add a criteria that excludes yellow from column C.
    afCol3.Criteria.Add "yellow"

    ' Apply the criteria.
    afFilters.Apply
End Sub


AutoFilterMode 属性

如果当前显示了“自动筛选”下拉箭头，则返回 True。可以将该属性设置为 False 来隐藏箭头，但不能将其设置为 True。使用 AutoFilter 方法筛选列表并显示下拉箭头。Boolean 类型，可读写。

expression.AutoFilterMode

expression 必需。该表达式返回 Worksheet 对象。

说明

如果显示了“自动筛选”下拉箭头，但当前没有筛选行（即所有行均可见），则 AutoFilterMode 属性为 True 并且 FilterMode 属性为 False。

示例

本示例关闭活动工作表的“自动筛选”。

Spreadsheet1.ActiveSheet.AutoFilterMode = False


AutoFit 属性

对于 Spreadsheet 或 PivotTable 对象：如果由可见的行列数确定电子表格或数据透视表列表的总体大小，则设置为 True。行高和列宽不能超过电子表格或数据透视表列表的 MaxHeight 和 MaxWidth 属性值。默认值为 True。如果将 AutoFit 属性设置为 False，则电子表格或数据透视表列表的总体大小由 Width 和 Height 属性设置。Boolean 类型，可读写。

对于 PivotAxisMember 或 PivotTotal 对象：如果自动设置总计宽度，则设置为 True。默认值为 True。如果该属性设置为 True，任何布局更改均更新 Width 和 Height 属性值。如果通过编程更改了 Width 和 Height 值，则 AutoFit 属性值将设置为 False。Boolean 类型，可读写。

expression.AutoFit

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例禁用数据透视表列表的自动调整大小，然后设置其宽度。

注释 可使用 OBJECT HTML 元素的 object 属性访问 PivotTable 对象的 Width 属性 (PivotTable1.Object.Width)，因为 HTML 页上的 OBJECT 元素也有其自己的 Width 属性。当 PivotTable 控件是在用户窗体或其他 ActiveX 容器中时则无此必要。

Sub DisableAutoFit()

   PivotTable1.AutoFit = False
   PivotTable1.Object.Width = 8000

End Sub


Axes 属性

返回指定图表的 ChAxes 集合。使用 Axes 属性设置图表坐标轴的属性。只读。

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。

expression.Axes

expression 必需。该表达式返回一个 ChChart 对象。

示例

本示例在 ChartSpace1 中第一个图表的数值轴和分类轴上添加标题，并更改字体。

Sub Format_Chart_Axes()

    Dim axCategoryAxis
    Dim axValueAxis

    ' Set a variable to the Category (X) axis.
    Set axCategoryAxis = ChartSpace1.Charts(0).Axes(0)

    ' Set a variable to the Value (Y) axis.
    Set axValueAxis = ChartSpace1.Charts(0).Axes(1)

    ' The following two lines of code enable, and then
    ' set the title for the category axis.
    axCategoryAxis.HasTitle = True
    axCategoryAxis.Title.Caption = "Sales by Quarter"

    ' The following three lines of code set the font
    ' for the values displayed on the category axis.
    axCategoryAxis.Font = "Tahoma"
    axCategoryAxis.Font.Size = 8
    axCategoryAxis.Font.Bold = True

    ' The following two lines of code enable, and then
    ' set the title for the value axis.
    axValueAxis.HasTitle = True
    axValueAxis.Title.Caption = "Dollars ($)"

    ' The following three lines of code set the font
    ' for the values displayed on the value axis.
    axValueAxis.Font = "Tahoma"
    axValueAxis.Font.Size = 8
    axValueAxis.Font.Bold = True
end sub


Axis 属性

显示 Axis 属性应用于 PivotResultField 和 PivotResultGroupField 对象的情形。

返回一个 PivotResultAxis 对象表示指定 PivotResultField 或 PivotResultGroupField 的父坐标轴。

expression.Axis

expression 必需。该表达式返回上面对象之一。

显示 Axis 属性应用于 PivotAxisMember、PivotColumnMember、PivotPageMember 和 PivotRowMember 对象的情形。

返回一个 PivotResultGroupAxis 对象，表示指定对象的父坐标轴。

expression.Axis

expression 必需。该表达式返回上面对象之一。


BackColor 属性

返回或设置指定对象或区域的背景色。当设置该属性时，可以使用 Long 类型值表示红绿蓝 (RGB) 体系的颜色值或使用 String 类型值表示一种有效的 HTML 颜色值。例如，如果要将对象设置为红色，可使用十六进制值 &HFF，十进制值 255 或字符串值“red”。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝体系的颜色值（例如，红色为 RGB(255,0,0)）。Variant 类型，可读写。

expression.BackColor

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

该属性总是返回 Long 类型值，该值代表一种红绿蓝体系的颜色值。

示例

本示例设置 PivotTable1 中标题栏的字号、前景色和背景色。

Sub Format_Titlebar()
    Dim vwView

    Set vwView = PivotTable1.ActiveView

    ' Set the background color of the title bar.
    vwView.Label.BackColor = "DarkSalmon"

    ' Set the font size of the title bar.
    vwView.Label.Font.Size = 16

    ' Set the foreground color of the title bar.
    vwView.Label.ForeColor = "Sienna"
End Sub


BackWall 属性

返回表示三维图表背景墙纸的 ChSurface 对象。使用返回的 ChSurface 对象的属性和方法设置指定图表背景墙纸的格式。

expression.BackWall

expression 必需。该表达式返回一个 ChPlotArea 对象。

示例

本示例将 Chartspace1 中的第一个图表转换为三维柱形图，并设置图表背景墙纸、侧面墙纸和基底的格式。

Sub FormatWallsFloor()

    Dim cht3DColumn
    Dim chConstants
    Dim paPlotArea

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DColumn = ChartSpace1.Charts(0)

    ' Set a variable to the plot area.
    Set paPlotArea = cht3DColumn.PlotArea

    ' Change the chart to a 3D Column chart.
    cht3DColumn.Type = chConstants.chChartTypeColumnClustered3D

    ' Format the back wall of the chart.
    paPlotArea.BackWall.Interior.SetSolid "Yellow"
    paPlotArea.BackWall.Thickness = 5

    ' Format the side wall of the chart.
    paPlotArea.SideWall.Interior.SetSolid "Yellow"
    paPlotArea.SideWall.Thickness = 5

    ' Format the floor of the chart.
    paPlotArea.Floor.Interior.SetSolid "Blue"
    paPlotArea.Floor.Thickness = 5

End Sub


BarWidth 属性

用于在条形图或柱形图中设置或指定数据标志的特定宽度。返回 Long 值。Long 类型，可读写。

expression.BarWidth

expression 必需。该表达式返回一个 ChChart 对象。

说明

BarWidth 属性以百分比指定（一英寸的 1/7200）。默认值零 (0) 表示“自动”。

设置该属性可更改图表控件 ChScrollView 对象的滚动视图的宽度。该属性仅对条形图和柱形图有效。对其他图表类型没有任何影响。该属性仅在柱形图的 HorizontalExtentMax 属性和条形图的 VerticalExtentMax 属性非零时有效。

设置 BarWidth 属性后，用户将不能更改 HorizontalExtent 或 VerticalExtent 属性。由于在禁用 BarWidth 属性之前，BarWidth 属性值将覆盖任何 HorizontalExtent 或 VerticalExtent 值，因此，更改 HorizontalExtent 或 VerticalExtent 属性将没有任何影响。通过将 BarWidth 属性设置为零 (0) 可禁用该属性。

示例

以下示例通过将该值设置为 7200 来将图表的条宽设置为一英寸。若要将条宽设置为半英寸，则应将该值指定为 3600。

Chartspace1.Charts(0).BarWidth = 7200


BaseName 属性

返回指定字段在源数据库中的名称。String 类型，只读。

expression.BaseName

expression 必需。该表达式返回一个 PivotField 对象。

说明

字段可以有多个名称，如下表所示。

名称 | 说明
Caption | 用户所见的名称。
Name | 用于在代码中标识字段的名称。
DataField | 底层记录集中的字段名称。（该名称不需要与基本名称一致，如果出现命名冲突或为了简化名称的使用和记忆，则可以使用不同的名称。）
BaseName | 原始源数据库中的字段名称。


Begin 属性

返回一个 ChSegmentBoundary 对象，表示格式映射的段边界的起始值。

expression.Begin

expression 必需。该表达式返回一个 ChSegment 对象。

说明

使用返回的 ChSegmentBoundary 对象的 Value 属性设置格式映射中指定段的起始值。使用 Interior、Line 和 Border 属性设置段边界格式。

示例

本示例将 Chartspace1 绑定到 SQL Server 罗斯文数据库中的 Order Details 表，然后创建格式映射，以红色突出显示低 10% 数值，以绿色突出显示高 20% 数值。

Sub Window_Onload()

    Dim serseries1
    Dim segBottom10Pct
    Dim segTop20Pct
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' The following two lines of code bind Chartspace1 to the Order Details table in the
    ' Northwind SQL Server database.
    ChartSpace1.ConnectionString = "Provider=SQLOLEDB.1;Persist Security Info=TRUE;" & _
                                   "Integrated Security=SSPI;Initial Catalog=Northwind;" & _
                                   "Data Source=SeverName;"
    ChartSpace1.DataMember = "Order Details"

    ' The following two lines of code bind Chartspace1 to the Quantity and ProductID fields
    ' in the Order details table.
    ChartSpace1.SetData chConstants.chDimCategories, chConstants.chDataBound, "ProductID"
    ChartSpace1.SetData chConstants.chDimValues, chConstants.chDataBound, "Quantity"

    ' Create a format map.
    ChartSpace1.SetData chConstants.chDimFormatValues, chConstants.chDataBound, "Quantity"

    ' Set a variable to the first series in the first chart in Chartspace1.
    Set serseries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a segment to the format map. This segment will
    ' represent the bottom 10% of values in the chart.
    Set segBottom10Pct = serseries1.FormatMap.Segments.Add

    ' Measure the segment boundaries based upon a percentage.
    segBottom10Pct.Begin.ValueType = chConstants.chBoundaryValuePercent
    segBottom10Pct.End.ValueType = chConstants.chBoundaryValuePercent

    ' Set the beginning value to 0%, and the ending value to 10%.
    segBottom10Pct.Begin.Value = 0
    segBottom10Pct.End.Value = 0.1

    ' Format the interior of the matching values.
    segBottom10Pct.Begin.Interior.Color = "red"
    segBottom10Pct.End.Interior.Color = "red"

    ' Add a segment to the format map. This segment will
    ' represent the top 20% of values in the chart.
    Set segTop20Pct = serseries1.FormatMap.Segments.Add

    ' Measure the segment boundaries based upon a percentage.
    segTop20Pct.Begin.ValueType = chConstants.chBoundaryValuePercent
    segTop20Pct.End.ValueType = chConstants.chBoundaryValuePercent

    ' Set the beginning value to 80%, and the ending value to 100%.
    segTop20Pct.Begin.Value = 0.8
    segTop20Pct.End.Value = 1

    ' Format the interior of the matching values.
    segTop20Pct.Begin.Interior.Color = "Green"
    segTop20Pct.End.Interior.Color = "Green"

End Sub


BindingData 属性

返回或设置给定 XmlDataBinding 对象的配置数据。String 类型，可读写。

expression.BindingData

expression 必需。该表达式返回一个 XmlDataBinding 对象。

说明

XmlDataBinding 对象包含以 XML 形式表示的配置数据。配置数据的格式必须遵守 XML 电子表格文件中所定义的 Spreadsheet 组件 XML 架构。BindingId 是一个新的 XML 片段，必须与当前值相同，否则将产生运行时错误。BindingID 为 XmlDataBinding 对象的 ID 属性，必须在工作簿的所有工作表中保持唯一。

示例

以下示例首先从 Workbook 对象的 XmlDataBindings 集合中获取 XMLDataBinding 对象编号。然后重复每一个 XMLDataBinding 对象以获取 BindingData 属性。

Sub ViewBindings()

    Dim strXml
    Dim intBinding
    Dim intCounter

    ' Get the number of XmlDataBinding objects in the XmlDataBindings collection.
    intBinding = Spreadsheet1.ActiveWorkbook.XmlDataBindings.Count

    ' Display a message box.
       MsgBox ("There are " & intBinding & " XmlDataBinding objects in the collection")

    ' Loop through each XmlDataBinding object in the collection.
    intCounter =1
    For intCounter = 1 to intBinding

            ' Get the configuration data for a given XmlDataBinding object from a XmlDataBindings collection.
                 strXml = Spreadsheet1.ActiveWorkbook.XmlDataBindings.Item(intCounter).BindingData
                 MsgBox ("Binding item #"  &  intCounter  & " returned XML:" & chr(10) & strXml)

          Next

End Sub


BindingInProgress 属性

显示 应用于 XmlDataBinding 对象的情形。

返回 True 或 False 值以指示特定数据检索服务连接绑定的状态。

expression.BindingInProgress

expression 必需。该表达式返回一个 XmlDataBinding 对象。

说明

BindingInProgress 属性仅应用于异步查询绑定，因为在进行同步绑定时无法调用对象模型。True 值表示指定的绑定正在执行异步绑定。False 表示没有执行任何绑定。

可使用 XmlDataBinding 对象的 Async 属性确定绑定是否为异步绑定。

显示 应用于 XmlDataBindings 集合的情形。

返回 True 或 False 值以指示工作簿中数据检索服务连接绑定的状态。

expression.BindingInProgress

expression 必需。该表达式返回一个 XmlDataBindings 集合。

说明

BindingInProgress 属性仅应用于异步查询绑定，因为在进行同步绑定时无法调用对象模型。True 值表示绑定正在执行异步绑定。False 表示没有执行任何绑定。

可使用 XmlDataBinding 对象的 Async 属性确定绑定是否为异步绑定。

示例

显示 应用于 XmlDataBindings 集合的情形。

以下代码示例检查每一个 XmlDataBindings 对象是否正在进行绑定。此处 Spreadsheet 组件的名称为 Spreadsheet1。

Dim objBinding
Dim strBindingInProgress

For Each objBinding In Spreadsheet1.ActiveWorkbook.XmlDataBindings
    If objBinding.Async = True Then
        ' Save the binding-in-progress information to a variable.
        strBindingInProgress =  objBinding.BindingInProgress

        ' Work with the information here.
    End If
Next


Bold 属性

对于 Font 对象：如果指定字体为加粗，则返回 True。Variant 类型，可读写（如果区域中的某些单元格为加粗而其他不是，则返回 Null）。请使用 IsNull 函数判断返回值是否为 Null。

对于 PivotFont 和 ChFont 对象：返回或设置一个 Boolean 类型，判断指定对象的字体是否为加粗。可读写。

expression.Bold

expression 必需。该表达式返回上面对象之一。

示例

本示例设置图表工作区中指定坐标轴的字体属性。

Sub SetAxisFont()

Dim axs

Set axs = ChartSpace1.Charts(0).Axes(1)

axs.Font.Name = "Arial"
axs.Font.Size = 8
axs.Font.Bold = True

End Sub


Bookmark 属性

返回一个 Variant 类型，表示当前 ADO 记录集的书签。只读。

expression.Bookmark

expression 必需。该表达式返回一个 PivotDetailCell 对象。


Border 属性

返回一个表示指定对象边框的 ChBorder 对象。

expression.Border

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

图表系列的边框表示柱形图、条形图、饼图、圆环图、面积图和盘高-盘低-收盘图的外边框颜色。在具有标志的图表（诸如具有标志的折线图）上，边框表示标志的外边框颜色。

示例

本示例设置图表工作区中指定系列的边框线粗。

Sub SetBorder()

   Dim chConstants

   Set chConstants = ChartSpace1.Constants

   ChartSpace1.Charts(0).SeriesCollection(0).Border _
                        .Weight = chConstants.owcLineWeightMedium

End Sub


Borders 属性

返回代表单元格区域四个边框的 Borders 集合。只读。

expression.Borders

expression 必需。该表达式返回 Range 对象。

示例

本示例为 Sheet1 上区域 B5:C10 的单元格添加中等粗细的绿色边框。

Sub SetBorders()
    Dim ssConstants
    Dim rngBorder

    Set ssConstants = Spreadsheet1.Constants

    ' Set a variable to the range to add the borders to.
    Set rngBorder = Spreadsheet1.Worksheets("Sheet1").Range("b5:c10")

    ' Set the border weight.
    rngBorder.Borders.Weight = ssConstants.owcLineWeightMedium

    ' Set the border color.
    rngBorder.Borders.Color = "green"
End Sub


Bottom 属性

显示 Bottom 属性应用于 ChPlotArea 对象的情形。

返回或设置一个 Long 类型，表示指定绘图区的底层。可读写。

expression.Bottom

expression 必需。该表达式返回上面对象之一。

显示 Bottom 属性应用于 ChartSpace、ChAxis、ChCategoryLabel、ChChart、ChChartField、ChDataLabel、ChDataLabels、ChDropZone、ChErrorBars、ChLegend、ChLegendEntry、ChPoint、ChSeries、 ChScrollView、ChTitle 和 ChTrendline 对象的情形。

返回一个 Long 值，表示指定对象的底层。只读。

expression.Bottom

expression 必需。该表达式返回上面对象之一。


BottomRight 属性

显示 BottomRight 属性应用于 PivotRange 对象的情形。

返回一个表示指定区域右下角单元格的 PivotCell 对象。

expression.BottomRight

expression 必需。该表达式返回一个 PivotRange 对象。

显示 BottomRight 属性应用于 PivotDetailRange 对象的情形。

返回一个表示指定明细区域右下角单元格的 PivotDetailCell 对象。

expression.BottomRight

expression 必需。该表达式返回一个 PivotDetailRange 对象。


BoundField 属性

返回来源为记录集时作为数据绑定信息的 PivotField 对象。如果来源为多维，则该属性返回 Nothing。

expression.BoundField

expression 必需。该表达式返回一个 PivotFieldSet 对象。


BubbleScale 属性

返回或设置指定图表上所有气泡系列的缩放因子。默认值为 100，有效范围为 0–300。该属性值表示相对于默认设置的气泡大小。设置 BubbleScale 属性为 300（大于默认值两倍）将生成其气泡外观为三倍于默认值的图表。Double 类型，可读写。

expression.BubbleScale

expression 必需。该表达式返回一个 ChChart 对象。

示例

本示例设置图表工作区中指定图表的气泡缩放因子。注意 Charts(0) 必须为气泡图。

ChartSpace1.Charts(0).BubbleScale = 200


Build 属性

返回一个 Long 类型，表示 Microsoft Office Web Components 的编译号。只读。

expression.Build

expression 必需。该表达式返回一个 Spreadsheet 对象。

说明

该属性返回与 BuildNumber 属性相同的信息，但是为 Long 类型而不是 String 类型。


BuildNumber 属性

返回 Microsoft Office Web Components 的内部版本号。String 类型，只读。

expression.BuildNumber

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例在 Spreadsheet1 活动单元格中显示 Microsoft Office Web Components 的内部版本号。

Spreadsheet1.ActiveCell.Value = "MSOWC Build " & Spreadsheet1.BuildNumber


ButtonBorder 属性

返回表示指定放置区中每个按钮边框的 ChBorder 对象。使用返回的 ChBorder 对象的属性设置放置区每个按钮的边框格式。

expression.ButtonBorder

expression 必需。该表达式返回一个 ChDropZone 对象。

示例

本示例将设置 Chartspace1 中系列放置区的按钮和水印格式。

Sub SetupDropZone()

    Dim dzSeriesDropZone
    Dim ChConstants

    Set chConstants = Chartspace1.Constants

    ' Set a variable to the series drop zone in Chartspace1.
    Set dzSeriesDropZone = ChartSpace1.DropZones(chConstants.chDropZoneSeries)

    ' The next three lines of code format the button of the drop zone.
    dzSeriesDropZone.ButtonBorder.Weight = chConstants.owcLineWeightMedium
    dzSeriesDropZone.ButtonInterior.SetSolid "Red"
    dzSeriesDropZone.ButtonFont.Size = 14

    ' The next three lines of code format the watermark of the drop zone.
    dzSeriesDropZone.WatermarkBorder.Color = "Red"
    dzSeriesDropZone.WatermarkFont.Color = "Red"
    dzSeriesDropZone.WatermarkInterior.SetSolid "Green"

End Sub


ButtonFont 属性

返回表示指定放置区中每个按钮字体的 ChFont 对象。使用返回的 ChFont 对象的属性设置放置区中每个按钮的字体格式。

expression.ButtonFont

expression 必需。该表达式返回一个 ChDropZone 对象。

示例

本示例将设置 Chartspace1 中系列放置区的按钮和水印格式。

Sub SetupDropZone()

    Dim dzSeriesDropZone
    Dim ChConstants

    Set chConstants = Chartspace1.Constants

    ' Set a variable to the series drop zone in Chartspace1.
    Set dzSeriesDropZone = ChartSpace1.DropZones(chConstants.chDropZoneSeries)

    ' The next three lines of code format the button of the drop zone.
    dzSeriesDropZone.ButtonBorder.Weight = chConstants.owcLineWeightMedium
    dzSeriesDropZone.ButtonInterior.SetSolid "Red"
    dzSeriesDropZone.ButtonFont.Size = 14

    ' The next three lines of code format the watermark of the drop zone.
    dzSeriesDropZone.WatermarkBorder.Color = "Red"
    dzSeriesDropZone.WatermarkFont.Color = "Red"
    dzSeriesDropZone.WatermarkInterior.SetSolid "Green"

End Sub


ButtonInterior 属性

返回表示指定放置区中每个按钮内部的 ChInterior 对象。使用返回的 ChInterior 对象的属性设置放置区中每个按钮内部的格式。

expression.ButtonInterior

expression 必需。该表达式返回一个 ChDropZone 属性。

说明

在默认情况下，图表控件使用三维对象的颜色设置作为放置区按钮的内部颜色,该颜色在“显示控制面板”的“外观”选项卡上指定。

示例

本示例将设置 Chartspace1 中系列放置区的按钮和水印格式。

Sub SetupDropZone()

    Dim dzSeriesDropZone
    Dim ChConstants

    Set chConstants = Chartspace1.Constants

    ' Set a variable to the series drop zone in Chartspace1.
    Set dzSeriesDropZone = ChartSpace1.DropZones(chConstants.chDropZoneSeries)

    ' The next three lines of code format the button of the drop zone.
    dzSeriesDropZone.ButtonBorder.Weight = chConstants.owcLineWeightMedium
    dzSeriesDropZone.ButtonInterior.SetSolid "Red"
    dzSeriesDropZone.ButtonFont.Size = 14

    ' The next three lines of code format the watermark of the drop zone.
    dzSeriesDropZone.WatermarkBorder.Color = "Red"
    dzSeriesDropZone.WatermarkFont.Color = "Red"
    dzSeriesDropZone.WatermarkInterior.SetSolid "Green"

End Sub


Calculation 属性

返回或设置指定计算模式的 XlCalculation 常量。可读写。

XlCalculation 可以为下列 XlCalculation 常量之一。
xlCalculationAutomatic 如果更改引用的单元格，公式将重新计算。
xlCalculationManual 直到用户启动一次重新计算，公式才重新计算。

expression.Calculation

expression 必需。该表达式返回一个 Spreadsheet 对象。

示例

本示例将 Spreadsheet1 置为手动计算模式。

Sub ManualCalculationMode()

   Dim ssConstants

   Set ssConstants = Spreadsheet1.Constants

   ' Set Spreadsheet1 to manual calculation mode.
   Spreadsheet1.Calculation = ssConstants.xlCalculationManual

End Sub


CalculationVersion 属性

返回一个数字，其最右侧两位表示计算引擎的次要版本号，而左侧的其他位表示 Microsoft Office Spreadsheet 组件的主要版本号。Long 类型，只读。

expression.CalculationVersion

expression 必需。该表达式返回一个 Spreadsheet 或 Workbook 对象。


CanQuery 属性

如果 XmlDataBinding 对象（在 XML 电子表格文件的 <Binding> 元素中指定）包含 <DataSource> 子元素，并且 Purpose 属性 (/Binding/DataSource/ConnectionInfo@Purpose) 的值为“Query”，则返回 True。否则返回 False。只读。

expression.CanQuery

expression 必需。该表达式返回一个 XmlDataBinding 对象。

说明

如果返回 True，则 <DataSource> 元素的 Purpose 属性值为“Query”。这意味着可调用 XmlDataBinding 对象的 Refresh 方法重新查询数据源。注意：XMLDataBinding 对象可包含多个 <DataSource> 元素标记：其中一个元素的 Purpose 值为“Query”；另一个元素的 Purpose 值为“Update”。有关更新绑定的信息，请参阅 CanUpdate 属性。

XMLDataBinding 对象表示到 XML 文件、SOAP 服务、其他 Web 部件（仅当从“电子表格 Web 部件”中进行绑定时）或数据检索服务连接的绑定。

在 XML 电子表格文件中显示 <DataSource> 元素明细数据的 XML 片段如下所示：

<x2:Binding x2:ID="Cust_bind_id" x2:LoadMode="Normal" x2:Async="False">
<x2:MapID>Cust_MapId</x2:MapID>
<udc:DataSource MajorVersion="1" MinorVersion="0">
<udc:Type Type="XMLFile" MajorVersion="1" MinorVersion="0"/>
<udc:Name>sample_name</udc:Name>
   <udc:ConnectionInfo Purpose="Query">
      ...
   </udc:ConnectionInfo>
</udc:DataSource>

示例

以下示例将刷新绑定。这将运行 BindingCompleted 事件的事件处理程序，确定是否可查询绑定（即，其 Purpose 属性值是否为“Query”）。您可编写该事件处理程序中的代码以执行任何其他绑定操作。

Sub RefreshBinding(Spreadsheet1)
    Dim objBinding

    Set objBinding = Spreadsheet1.ActiveWorkbook.XmlDataBindings("Cust_bind_id")
    objBinding.Refresh

End Sub

Sub Spreadsheet1_BindingCompleted(bindingID, Action)

    If Spreadsheet1.ActiveWorkbook.XmlDataBindings.Item(bindingID).CanQuery = True Then
        ' Write code here to perform any additional actions on this query binding.
    End If

End Sub

注释 有关从网页中运行的脚本中捕获 BindingCompleted 事件的信息，请参阅 BindingCompleted 事件主题。


CanUndo 属性

如果有可以撤消的前一操作，则返回 True。Boolean 类型，只读。

expression.CanUndo

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例撤消上次执行的操作，如果没有可以撤消的操作则显示消息框。

Sub Undo_Action()
    If Spreadsheet1.CanUndo Then
        Spreadsheet1.Undo
    Else
        MsgBox "Can't undo last action."
    End If
End Sub


CanUpdate 属性

如果 XmlDataBinding 对象（由 XML 电子表格文件中的 <Binding> 元素指定）包含 <DataSource> 元素，并且 Purpose 属性 (/Binding/DataSource/ConnectionInfo@Purpose) 的值为“Update”，则返回 True。否则返回 False。只读。

expression.CanUpdate

expression 必需。该表达式返回一个 XmlDataBinding 对象。

说明

注意：XMLDataBinding 对象可包含多个 <DataSource> 元素标记：其中一个元素的 Purpose 值为“Query”；另一个元素的 Purpose 值为“Update”。有关更新绑定的信息，请参阅 CanUpdate 属性。

XMLDataBinding 对象表示到 XML 文件、SOAP 服务、其他 Web 部件（仅当从“电子表格 Web 部件”中进行绑定时）或数据检索服务连接的绑定。

在 XML 电子表格文件中显示明细数据的 XML 片段如下所示：

<udc:DataSource MajorVersion="1" MinorVersion="0" xmlns:udc="http://schemas.microsoft.com/data/udc">
   <udc:Type Type="XMLFile" MajorVersion="1" MinorVersion="0"/>
   <udc:Name>Example_Filename<udc:Name/>
   <udc:ConnectionInfo Purpose="Update">
      ...
   </udc:ConnectionInfo>
</udc:DataSource>

示例

以下示例首先确定是否可更新数据检索服务连接绑定（即，其 Purpose 属性值是否为“Update”）。如果可更新，则代码调用 UpdateBinding 函数，传递 BindingId 属性值作为参数。因为更新绑定始终同步执行，所以无需检查绑定是否为异步绑定，该函数将直接调用 Update 方法。

Dim objBinding

Set objBinding = Spreadsheet1.ActiveWorkbook.XmlDataBindings("Cust_bind_id")
    If objBinding.CanUpdate = True Then
        ' Fetch the data and update the corresponding map.
        UpdateBinding("Cust_bind_id")
    End If

Next

Function UpdateBinding(strBindingID)
    Dim objBinding

    Set objBinding = Spreadsheet1.ActiveWorkbook.XmlDataBindings(strBindingID)

    objBinding.Update
End Function


Caption 属性

显示 Caption 属性应用于 ChSeries、ChTitle、 ChTrendline、Heading、Spreadsheet、PivotField、PivotFieldSet、PivotLabel、PivotMemberProperty、PivotTotal 和 TitleBar 对象的情形。

返回或设置指定对象的标题。String 类型，可读写。

expression.Caption

expression 必需。该表达式返回上面所列对象之一。

显示 Caption 属性应用于 ChCategoryLabel、PivotAxisMember、PivotColumnMember、PivotMember、PivotPageMember、PivotResultMemberProperty 和 PivotRowMember 对象的情形。

返回指定对象的标题。String 类型，只读。

expression.Caption

expression 必需。该表达式返回上面所列对象之一。

示例

应用于 Spreadsheet 对象的情形。

本示例在 Spreadsheet1 标题栏中显示当前日期和时间。

Sub SetTitleBar_Caption()
    Dim ssTitle

    Set ssTitle = Spreadhseet1.TitleBar

    ' Set the title bar's caption to the
    ' current date and time.
    ssTitle.Caption = Date & " " & Time

    ' Enable the title bar.
    ssTitle.Visible = True
End Sub


CaptionHAlignment 属性

返回或设置指定的数据透视表列表中明细页脚标签的水平对齐方式。PivotHAlignmentEnum 类型，可读写。

PivotHAlignmentEnum 可为以下 PivotHAlignmentEnum 常量之一：
plHAlignAutomatic
plHAlignCenter
plHAlignLeft
plHAlignRight

expression.CaptionHAlignment

expression 必需。该表达式返回一个 PivotTotal 对象。

说明

标题只能在详细页脚中聚合项的左侧显示。使用 CaptionHAlignment 属性将标题靠近聚合项显示 (plHAlignRight) 或靠近页脚的左边界显示 (plHAlignLeft)。如果在左侧有其他聚合项显示，则标题显示在其他聚合项的右侧。如果没有足够的空间显示标题，则不显示标题。

示例

本示例设置 PivotTable1 中总计及其标题的格式。

Sub Set_Total_Alignment()
    Dim ptConstants
    Dim vwView
    Dim totTotal

    Set ptConstants = PivotTable1.Constants
    Set vwView = PivotTable1.ActiveView

    ' Loop through all totals in the view.
    For Each totTotal in vwView.DataAxis.Totals

        ' Set the horizontal alignment of the total to center.
        totTotal.HAlignment = ptConstants.plHAlignCenter

        ' Set the horizontal alignment of the caption to center.
        totTotal.CaptionHAlignment = ptConstants.plHAlignCenter
    Next
End Sub


CaptionSection 属性

如果指定组级显示有标题节，则返回 True。Boolean 类型，可读写。

expression.CaptionSection

expression 必需。该表达式返回一个 GroupLevel 对象。

说明

标题节仅在数据访问页上显示一次，并且显示在给定组级别的所有可见记录之上。在浏览记录时标题节始终可见。


CategoryLabels 属性

返回指定坐标轴的 ChCategoryLabels 集合。仅对分类坐标轴和时间刻度轴有效。

expression.CategoryLabels

expression 必需。该表达式返回一个 ChAxis 对象。


Cell 属性

返回表示聚合单元格或明细单元格位置的 PivotCell 对象。使用该属性返回数据透视表列表中选定区域的详细信息。

expression.Cell

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例利用 PivotTable1 的 DoubleClick 事件显示数据透视表明细区域中单元格的详细信息。本示例假定 PivotTable1 使用罗斯文数据库中的“客户”表。

Sub PivotTable1_DblClick()
    Dim ptSelection
    Dim nRow
    Dim rs

    Set ptSelection = PivotTable1.Selection

    ' If the current selection is in the
    ' detail area of the PivotTable list.
    If TypeName(ptSelection) = "PivotDetailRange" then

        nRow = ptSelection.TopLeft.Row

        ' Set a variable to the recordset of the top-left
        ' cell in the selection.
        Set rs = ptSelection.TopLeft.Cell.Recordset

        ' Move the cursor the the correct record in the recordset.
        rs.Move nRow

        MsgBox "The row that was double-clicked was..." & String(2, vbCrLf) & _
            "Customer ID = " & rs("CustomerID") & vbCrLf & _
            "Company Name = " & rs("CompanyName") & vbCrLf & _
            "Contact Name = " & rs("ContactName")
    Else
        MsgBox "Double-click on a row!", vbExclamation
    End If

End Sub


Cells 属性

显示 Cells 属性应用于 Range、Spreadsheet 和 Worksheet 对象的情形。

返回一个表示对象中单元格的 Range 对象。

expression.Cells

expression 必需。该表达式返回以上对象之一。

显示 Cells 属性应用于 PivotData 和 PivotRange 对象的情形。

返回一个基于行和列成员的 PivotCell 对象。

expression.Cells(Row, Column)

expression 必需。该表达式返回以上对象之一。

Row 必需，PivotRowMember 对象。表示指定行。

Column 必需，PivotColumnMember 对象。表示指定列。

示例

显示 应用于 Range、Spreadsheet 和 Worksheet 对象的情形。

本示例设置单元格 B3 的值为 5。

Spreadsheet1.Range("A2:C4").Cells(4).Value = 5

本示例清除 Sheet1 上的所有单元格。

Spreadsheet1.Worksheets("Sheet1").Cells.Clear


CellsEx 属性

返回一个 PivotCell 对象，表示指定行、列和页成员的交点。

expression.CellsEx(Row, Column, Page)

expression 必需。该表达式返回一个 PivotData 对象。

Row PivotRowMember 对象，必需。指定包含返回单元格的行。

Column PivotColumnMember 对象，必需。指定包含返回单元格的列。

Page PivotPageMember 对象，必需。指定包含返回单元格的页。

示例

本示例设置一个变量指向通过 2-Day 运送到北卡罗莱纳州邮政编码为 28016 的总计数量。

Sub Get2DayShippingToNC()

    Dim ptData
    Dim pmRowMember
    Dim pmColMember
    Dim pmPageMember
    Dim pmIntersection
    Dim dblShipTotal

    Set ptData = PivotTable1.ActiveData

    ' Set a variable to a row field member.
    Set pmRowMember = ptData.RowAxis.Member.ChildAxisMembers("North Carolina")

    ' Set a variable to a column field member.
    Set pmColMember = ptData.ColumnAxis.Member.ChildAxisMembers("2-Day")

    ' Set a variable to a page field member.
    Set pmPageMember = ptData.PageAxis.Member.ChildAxisMembers("28016")

    ' Set a variable to the intersection of the row, column, and page field members.
    Set pmIntersection = ptData.CellsEx(pmRowMember, pmColMember, pmPageMember)

    ' Set a variable to the total shipping amount for the item.
    dblShipTotal = pmIntersection.Aggregates("Shipping").Value

End Sub


ChartDepth 属性

返回或设置一个 Long 类型，指定三维图表相对于宽度的深度。设置该属性为大于 100 的值将得到深大于宽的图表，而设置小于 100 的值将得到宽大于深的图表。有效设置范围为 0 到 500。可读写。

expression.ChartDepth

expression 必需。该表达式返回一个 ChChart 对象。

说明

该属性对三维饼图无效。

示例

本示例将 Chartspace1 中的第一个图表转换为三维柱形图，然后增加图表的宽度和深度。

Sub Format_3D_Depth_Width()

    Dim cht3DColumn

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DColumn = ChartSpace1.Charts(0)

    ' Change the chart to a 3D Column chart.
    cht3DColumn.Type = chChartTypeColumnClustered3D

    ' Increase the depth of the chart in relation
    ' to it's width.
    cht3DColumn.ChartDepth = 125

    ' Increase the width of the chart in relation
    ' to it's height.
    cht3DColumn.AspectRatio = 80

End Sub


ChartFields 属性

返回表示添加到指定放置区的字段集合的 ChChartFields 对象。

expression.ChartFields

expression 必需。该表达式返回一个 ChDropZone 对象。

示例

本示例显示添加到 Chartspace1 系列放置区的字段数。

Sub SetupDropZone()

    Dim dzSeriesDropZone
    Dim ChConstants

    Set chConstants = Chartspace1.Constants

    ' Set a variable to the series drop zone in Chartspace1.
    Set dzSeriesDropZone = ChartSpace1.DropZones(chConstants.chDropZoneSeries)

    ' Display the number of fields that have been added to the
    ' series drop zone.
    MsgBox dzSeriesDropZone.ChartFields.Count

End Sub


ChartLayout 属性

返回或设置指定图表工作区中所有图表的布局。ChartChartLayoutEnum 类型，可读写。

ChartChartLayoutEnum 可为以下 ChartChartLayoutEnum 常量之一：
chChartLayoutAutomatic
chChartLayoutHorizontal
chChartLayoutVertical

expression.ChartLayout

expression 必需。该表达式返回一个 ChartSpace 对象。

由于图表工作区可以包含一个或多个图表，因此可以同时使用 ChartLayout 和 ChartWrapCount 属性指定要定位的图表数量。ChartLayout 属性可以创建自定义图表排列方式，例如在一行上水平排列三个图表。

有两种不同的图表布局类型：

ChChartLayoutHorizontal 图表从左到右水平排列，直到图表个数达到 ChartWrapCount 属性所指定的值。达到该数量后，将在活动行下方另起一行，从左侧重新开始排列。该方法将持续（每到 ChartWrapCount 数量后换行）到所有图表排列完毕。

ChChartLayoutVertical 图表从上到下垂直排列，直到图表个数达到 ChartWrapCount 属性所指定的值。达到该数量后，将在活动列右侧另起一列，从上方重新开始排列。该方法将持续（每到图表数量到达 ChartWrapCount 值后换列）到所有图表排列完毕。

示例

本示例设置 ChartWrapCount 和 ChartLayout 属性然后在指定图表工作区添加六个附加图表。

Sub AddCharts()
    Dim chtChart
    Dim chConstants
    Dim iCtr

    Set chConstants = ChartSpace1.Constants

    ' Set the chart workspace so that a row or column
    ' of charts is created for every two charts
    ' in the chart workspace.
    ChartSpace1.ChartWrapCount = 2

    ' Set the chart workspace so that the charts are laid our horizontally.
    ' Since this code adds six charts to the chart workspace and the
    ' ChrtWrapCount property has been set to wrap every two charts,
    ' then the code results in three rows of two charts.
    ChartSpace1.ChartLayout = chConstants.chChartLayoutHorizontal

    For iCtr = 1 To 6
        ' Add a chart to the chart workspace.
        Set chtChart = ChartSpace1.Charts.Add

        ' Enable the chart title.
        chtChart.HasTitle = True

        ' Add a title to the chart that indicates the order
        ' in which the chart was created.
        chtChart.Title.Caption = "Chart # " & iCtr

        ' Specify that the chart is to be a line chart.
        chtChart.Type = chConstants.chChartTypeLine
    Next
End Sub


Charts 属性

返回指定图表工作区的 ChCharts 集合。

expression.Charts

expression 必需。该表达式返回一个 ChartSpace 对象。

说明

在默认情况下，新图表工作区不包含图表。新建图表工作区后，在创建图表之前必须添加 Chart 对象。使用 Add 方法新建图表。

示例

本示例在指定图表工作区添加图表。

Set cht = ChartSpace1.Charts.Add


ChartSpaceLegend 属性

返回代表图表工作区图例的 ChLegend 对象。使用该属性设置图表工作区的图例属性。请注意 ChartSpaceLegend 属性代表整个图表工作区的图例。请使用 ChChart 对象的 Legend 属性设置图表工作区中个别图表的图例。如果图表工作区没有图例，则返回 Nothing。只读。

expression.ChartSpaceLegend

expression 必需。该表达式返回一个 ChartSpace 对象。

示例

本示例将设置图表工作区标题，并将图表工作区图例置于工作区的左侧。

Sub SetLegend()
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Enable the title for the chart workspace.
    ChartSpace1.HasChartSpaceTitle = True

    ' Set the title for the chart workspace.
    ChartSpace1.ChartSpaceTitle.Caption = "Monthly Sales Data"

    ' Enable the legend for the chart workspace.
    ChartSpace1.HasChartSpaceLegend = True

    ' Position the legend for the chart workspace.
    ChartSpace1.ChartSpaceLegend.Position = chConstants.chLegendPositionLeft
End Sub


ChartSpaceTitle 属性

返回代表图表工作区标题的 ChTitle 对象。使用该属性设置图表工作区的标题属性。请注意 ChartSpaceTitle 属性代表整个图表工作区的标题。请使用 ChChart 对象的 Title 属性设置图表工作区中个别图表的标题。如果图表工作区没有标题，则返回 Nothing。只读。

expression.ChartSpaceTitle

expression 必需。该表达式返回一个 ChartSpace 对象。

示例

本示例将设置图表工作区标题，并将图表工作区图例置于工作区的左侧。

Sub SetLegend()
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Enable the title for the chart workspace.
    ChartSpace1.HasChartSpaceTitle = True

    ' Set the title for the chart workspace.
    ChartSpace1.ChartSpaceTitle.Caption = "Monthly Sales Data"

    ' Enable the legend for the chart workspace.
    ChartSpace1.HasChartSpaceLegend = True

    ' Position the legend for the chart workspace.
    ChartSpace1.ChartSpaceLegend.Position = chConstants.chLegendPositionLeft
End Sub


ChartWrapCount 属性

返回或设置水平或垂直排列图表时换行或换列的图表数量。有关布局和换行的详细完整论述，请参阅 ChartLayout 属性的帮助主题。Long 类型，可读写。

expression.ChartWrapCount

expression 必需。该表达式返回一个 ChartSpace 对象。

示例

本示例设置 ChartWrapCount 和 ChartLayout 属性，然后在指定图表工作区添加六个附加图表。

Sub AddCharts()
    Dim chtChart
    Dim chConstants
    Dim iCtr

    Set chConstants = ChartSpace1.Constants

    ' Set the chart workspace so that a row or column
    ' of charts is created for every two charts
    ' in the chart workspace.
    ChartSpace1.ChartWrapCount = 2

    ' Set the chart workspace so that the charts are laid our horizontally.
    ' Since this code adds six charts to the chart workspace and the
    ' ChrtWrapCount property has been set to wrap every two charts,
    ' then the code results in three rows of two charts.
    ChartSpace1.ChartLayout = chConstants.chChartLayoutHorizontal

    For iCtr = 1 To 6
        ' Add a chart to the chart workspace.
        Set chtChart = ChartSpace1.Charts.Add

        ' Enable the chart title.
        chtChart.HasTitle = True

        ' Add a title to the chart that indicates the order
        ' in which the chart was created.
        chtChart.Title.Caption = "Chart # " & iCtr

        ' Specify that the chart is to be a line chart.
        chtChart.Type = chConstants.chChartTypeLine
    Next
End Sub


Checked 属性

返回是否启用指定命令。Boolean 类型，只读。

expression.Checked

expression 必需。该表达式返回一个 OCCommand 对象。

说明

OCCommandId、ChartCommandIdEnum、PivotCommandId 和 SpreadsheetCommandId 常量中包含每个 Web 组件支持的命令列表。


ChildAxisMembers 属性

返回一个 PivotAxisMembers 集合，表示指定 PivotAxisMember 对象的子对象。

expression.ChildAxisMembers

expression 必需。该表达式返回一个 PivotAxisMember 对象。

示例

本示例设置一个变量指向通过 2-Day 运送到北卡罗莱纳州邮政编码为 28016 的总计数量。

Sub Get2DayShippingToNC()

    Dim ptData
    Dim pmRowMember
    Dim pmColMember
    Dim pmPageMember
    Dim pmIntersection
    Dim dblShipTotal

    Set ptData = PivotTable1.ActiveData

    ' Set a variable to a row field member.
    Set pmRowMember = ptData.RowAxis.Member.ChildAxisMembers("North Carolina")

    ' Set a variable to a column field member.
    Set pmColMember = ptData.ColumnAxis.Member.ChildAxisMembers("2-Day")

    ' Set a variable to a page field member.
    Set pmPageMember = ptData.PageAxis.Member.ChildAxisMembers("28016")

    ' Set a variable to the intersection of the row, column, and page field members.
    Set pmIntersection = ptData.CellsEx(pmRowMember, pmColMember, pmPageMember)

    ' Set a variable to the total shipping amount for the item.
    dblShipTotal = pmIntersection.Aggregates("Shipping").Value

End Sub


ChildColumnMembers 属性

返回一个 PivotColumnMembers 集合，表示指定 PivotColumnMember 对象的子对象。

expression.ChildColumnMembers

expression 必需。该表达式返回一个 PivotColumnMember 对象。

示例

本示例设置一个变量指向通过 2-Day 运送到北卡罗莱纳州邮政编码为 28016 的总计数量。

Sub Get2DayShippingToNC()

    Dim ptData
    Dim pmRowMember
    Dim pmColMember
    Dim pmPageMember
    Dim pmIntersection
    Dim dblShipTotal

    Set ptData = PivotTable1.ActiveData

    ' Set a variable to a row field member.
    Set pmRowMember = ptData.RowAxis.RowMember.ChildRowMembers("North Carolina")

    ' Set a variable to a column field member.
    Set pmColMember = ptData.ColumnAxis.ColumnMember.ChildColumnMembers("2-Day")

    ' Set a variable to a page field member.
    Set pmPageMember = ptData.PageAxis.PageMember.ChildPageMembers("28016")

    ' Set a variable to the intersection of the row, column, and page field members.
    Set pmIntersection = ptData.CellsEx(pmRowMember, pmColMember, pmPageMember)

    ' Set a variable to the total shipping amount for the item.
    dblShipTotal = pmIntersection.Aggregates("Shipping").Value

End Sub


ChildLabel 属性

获取或设置与控件相关联的标签的 ID 属性值。String 类型，可读写。

expression.ChildLabel

expression 必需。该表达式返回一个 ElementExtension 对象。


ChildMembers 属性

返回一个表示指定成员的子成员的 PivotMembers 集合。

expression.ChildMembers

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


ChildPageMembers 属性

返回一个 PivotPageMembers 集合，表示指定 PivotPageMember 对象的子对象。

expression.ChildPageMembers

expression 必需。该表达式返回一个 PivotPageMember 对象。

示例

本示例设置一个变量指向通过 2-Day 运送到北卡罗莱纳州邮政编码为 28016 的总计数量。

Sub Get2DayShippingToNC()

    Dim ptData
    Dim pmRowMember
    Dim pmColMember
    Dim pmPageMember
    Dim pmIntersection
    Dim dblShipTotal

    Set ptData = PivotTable1.ActiveData

    ' Set a variable to a row field member.
    Set pmRowMember = ptData.RowAxis.RowMember.ChildRowMembers("North Carolina")

    ' Set a variable to a column field member.
    Set pmColMember = ptData.ColumnAxis.ColumnMember.ChildColumnMembers("2-Day")

    ' Set a variable to a page field member.
    Set pmPageMember = ptData.PageAxis.PageMember.ChildPageMembers("28016")

    ' Set a variable to the intersection of the row, column, and page field members.
    Set pmIntersection = ptData.CellsEx(pmRowMember, pmColMember, pmPageMember)

    ' Set a variable to the total shipping amount for the item.
    dblShipTotal = pmIntersection.Aggregates("Shipping").Value

End Sub


ChildRowMembers 属性

返回一个 PivotRowMembers 集合，表示指定 PivotRowMember 对象的子对象。

expression.ChildRowMembers

expression 必需。该表达式返回一个 PivotRowMember 对象.

示例

本示例设置一个变量指向通过 2-Day 运送到北卡罗莱纳州邮政编码为 28016 的总计数量。

Sub Get2DayShippingToNC()

    Dim ptData
    Dim pmRowMember
    Dim pmColMember
    Dim pmPageMember
    Dim pmIntersection
    Dim dblShipTotal

    Set ptData = PivotTable1.ActiveData

    ' Set a variable to a row field member.
    Set pmRowMember = ptData.RowAxis.RowMember.ChildRowMembers("North Carolina")

    ' Set a variable to a column field member.
    Set pmColMember = ptData.ColumnAxis.ColumnMember.ChildColumnMembers("2-Day")

    ' Set a variable to a page field member.
    Set pmPageMember = ptData.PageAxis.PageMember.ChildPageMembers("28016")

    ' Set a variable to the intersection of the row, column, and page field members.
    Set pmIntersection = ptData.CellsEx(pmRowMember, pmColMember, pmPageMember)

    ' Set a variable to the total shipping amount for the item.
    dblShipTotal = pmIntersection.Aggregates("Shipping").Value

End Sub


ChildSection 属性

返回一个表示指定节的子节的 Section 对象。如果指定节没有展开，则该属性无效。

expression.ChildSection

expression 必需。该表达式返回一个 Section 对象。


Color 属性

返回或设置指定对象的主颜色。Variant 类型，可读写。

说明

当设置该属性时，可使用 Long 类型值代表红绿蓝体系的颜色值或用 String 类型值命名的一种有效的 HTML 颜色。 例如，如果要将对象设置为红色，可使用十六进制值 &HFF，十进制值 255 或字符串值“red”。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝体系的颜色值（红色为 RGB(255,0,0)）。

该属性总是返回 Long 类型值，该值代表一种红绿蓝体系的颜色值。

在图表上还可以使用下面两种特殊常量之一：chColorAutomatic（恢复为默认颜色）或 chColorNone（表示无色或透明）。但是，不能将字体颜色设置为 chColorNone。

示例

本示例将为电子表格上区域 B5:C10 中的所有单元格添加中等粗细的绿色边框。

Sub SetBorder()

Set ssConstants = Spreadsheet1.Constants

    Spreadsheet1.ActiveSheet.Range("b5:c10").Borders.Weight = ssConstants.owcLineWeightMedium
    Spreadsheet1.ActiveSheet.Range("b5:c10").Borders.Color = "green"
End Sub


ColorIndex 属性

显示 ColorIndex 属性应用于 Border 对象的情形。

返回或设置边框的颜色。颜色以当前调色板中的索引值或 XlColorIndex 常量指定。Variant 类型，可读写。

XlColorIndex 可以为下列 XlColorIndex 常量之一。
xlColorIndexAutomatic
xlColorIndexNone

expression.ColorIndex

expression 必需。该表达式返回一个 Border 对象。

显示 ColorIndex 属性应用于 Borders 对象的情形。

返回或设置所有四个边框的颜色。颜色以当前调色板中的索引值或 XlColorIndex 常量指定。如果四个边框的颜色不同，则返回 Null。Variant 类型，可读写。

XlColorIndex 可以为下列 XlColorIndex 常量之一。
xlColorIndexAutomatic
xlColorIndexNone

expression.ColorIndex

expression 必需。该表达式返回一个 Borders 对象。

显示 ColorIndex 属性应用于 Font 对象的情形。

返回或设置字体的颜色。颜色以当前调色板中的索引值或 XlColorIndex 常量指定。Variant 类型，可读写。

XlColorIndex 可以为下列 XlColorIndex 常量之一。
xlColorIndexAutomatic
xlColorIndexNone

expression.ColorIndex

expression 必需。该表达式返回一个 Font 对象。

显示 ColorIndex 属性应用于 Interior 对象的情形。

返回或设置内部填充的颜色。颜色以当前调色板中的索引值或 XlColorIndex 常量指定。Variant 类型，可读写。

XlColorIndex 可以为下列 XlColorIndex 常量之一。
xlColorIndexAutomatic
xlColorIndexNone

expression.ColorIndex

expression 必需。该表达式返回一个 Interior 对象。

说明

该属性以工作簿调色板中的索引指定颜色。可以使用 Colors 方法返回当前调色板。

下面示例显示默认调色板中的颜色索引值。

示例

显示 应用于 Font 对象的情形。

本示例将 Sheet1 上 A1 单元格的字体颜色更改为红色。

Spreadsheet1.ActiveSheet.Range("A1").Font.ColorIndex = 3


Colors 属性

返回或设置工作簿调色板中的颜色。调色板有 56 项，每项以一个 RGB 值表示。Variant 类型，可读写。

expression.Colors(Index)

expression 必需。该表达式返回一个 Workbook 对象。

Index Variant 类型，可选。颜色索引号（1 到 56）。如果不指定该参数，该方法返回一个包含调色板中所有 56 种颜色的数组。

示例

本示例设置活动工作簿调色板中的第五种颜色。

Spreadsheet1.ActiveWorkbook.Colors(5) = RGB(255, 0, 0)

本示例在 Spreadsheet1 的活动工作表上创建显示可用调色板的表格。

Sub Create_Color_Table()
    Dim avarColorArray()
    Dim iCtr
    Dim rngCurrent

    ' Set an array variable to the colors in the color palette.
    avarColorArray = Spreadsheet1.ActiveWorkbook.Colors

    Set rngCurrent = Spreadsheet1.ActiveSheet.Range("A1")

    ' Loop through all of the colors in the array.
    For iCtr = 1 To UBound(avarColorArray)
        rngCurrent.Value = "Color " & iCtr

        ' Set the color of a cell in column B to
        ' the appropriate color.
        rngCurrent.Offset(0, 1).Interior.Color _
                        = avarColorArray(iCtr)

        Set rngCurrent = rngCurrent.Offset(1, 0)
    Next
End Sub


Column 属性

返回指定区域中第一列的列号。Long 类型，只读。

expression.Column

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例在活动工作表上的可见区域中，隔列将字体设置为加粗。

Sub BoldColumns()
    Dim col

    For Each col In Spreadsheet1.ActiveSheet.VisibleRange.Columns
        If col.Column Mod 2 = 0 Then col.Font.Bold = True
    Next
End Sub


ColumnAxis 属性

对于 PivotData 对象：返回一个 PivotResultColumnAxis 对象，表示指定数据透视表列表中的列坐标轴。

对于 PivotView 对象：返回一个 PivotGroupAxis 对象，表示指定数据透视表列表中的列坐标轴。

expression.ColumnAxis

expression 必需。该表达式返回一个 PivotData 或 PivotView 对象。

示例

本示例在活动视图的数据透视表列表中插入两个字段集。

Sub AddFieldsToPT()

   Dim ptView

   Set ptView= PivotTable1.ActiveView

   ptView.ColumnAxis.InsertFieldSet ptView.FieldSets("Store Type")

   ptView.RowAxis.InsertFieldSet ptView.FieldSets("Promotions")

End Sub


ColumnHeadings 属性

返回表示指定窗口中列标题的 Headings 集合。使用 Caption 属性自定义列标题。

expression.ColumnHeadings

expression 必需。该表达式返回一个 Window 对象。

示例

本示例通过禁用某些用户界面元素、限制活动窗口的可查看区域和自定义行列标题，设置并创建一个自定义数据输入工作表。

Sub Create_Datasheet()
    Dim hdrColHeadings
    Dim hdrRowHeadings
    Dim wndActive

    Set wndActive = Spreadsheet1.ActiveWindow

    ' Hide various UI elements.
    wndActive.DisplayWorkbookTabs = False
    Spreadsheet1.DisplayToolbar = False

    ' Display the title bar and set it's caption.
    Spreadsheet1.DisplayTitleBar = True
    Spreadsheet1.TitleBar.Caption = "Revenue Worksheet"

    ' Resize the spreadsheet component.
    Spreadsheet1.AutoFit = True

    ' Limit the viewable range of the active sheet.
    wndActive.ViewableRange = "A1:D5"

    ' Set a variable to the column headings in the active window.
    Set hdrColHeadings = wndActive.ColumnHeadings

    ' Set a variable to the row headings in the active window.
    Set hdrRowHeadings = wndActive.RowHeadings

    ' Set the headings of columns A through D.
    hdrColHeadings(1).Caption = "Qtr 1"
    hdrColHeadings(2).Caption = "Qtr 2"
    hdrColHeadings(3).Caption = "Qtr 3"
    hdrColHeadings(4).Caption = "Qtr 4"

    ' Set the headings of rows 1 though 5.
    hdrRowHeadings(1).Caption = "1996"
    hdrRowHeadings(2).Caption = "1997"
    hdrRowHeadings(3).Caption = "1998"
    hdrRowHeadings(4).Caption = "1999"
    hdrRowHeadings(5).Caption = "2000"
End Sub


ColumnMember 属性

返回一个表示与指定单元格相交的列坐标轴上最内侧成员的 PivotColumnMember 对象。

expression.ColumnMember

expression 必需。该表达式返回“应用于”列表中的对象之一。


ColumnMembers 属性

返回一个 PivotColumnMembers 集合，表示指定列的所有成员。

expression.ColumnMembers

expression 必需。该表达式返回一个 PivotRange 对象。

说明

列成员集合中不包含通过将 IsFiltered 属性设置为 True 筛选掉的成员。


Columns 属性

显示 Column 属性应用于 Range 对象的情形。

返回代表指定区域中列的 Range 对象。只读。

expression.Columns

expression 必需。该表达式返回一个 Range 对象。

显示 Column 属性应用于 Spreadsheet 和 Worksheet 对象的情形。

返回代表指定工作表上所有列的 Range 对象。

expression.Columns

expression 必需。该表达式返回以上对象之一。只读。

示例

显示 应用于 Range 对象的情形。

本示例在活动工作表上的可见区域中，隔行将字体设置为加粗。

Sub BoldColumns()
    Dim col

    For Each col In Spreadsheet1.ActiveSheet.VisibleRange.Columns

        If col.Column Mod 2 = 0 Then col.Font.Bold = True

    Next
End Sub

显示 应用于 Worksheet 对象的情形。

本示例删除活动工作表上 B 列中的所有数据。

Spreadsheet1.ActiveSheet.Columns(2).ClearContents


ColumnWidth 属性

返回或设置指定区域中所有列的列宽。如果区域中的列宽不一致，则返回 Null。请使用 IsNull 函数判断返回值是否为 Null。Variant 类型，可读写。

expression.ColumnWidth

expression 必需。该表达式返回一个 Range 对象。

示例

本示例设置活动工作表上区域 A1:F10 中所有单元格的公式、列宽和数字格式。

Sub Format_Sheet1()
    Dim rngCurrent

    Set rngCurrent = Spreadsheet1.ActiveSheet.Range("A1:F10")

    rngCurrent.Formula = "=rand()"

    rngCurrent.ColumnWidth = 10

    rngCurrent.NumberFormat = "#.###"
End Sub


Commands 属性

返回一个 OCCommands 对象，表示可用命令集合。

expression.Commands

expression 必需。该表达式返回“应用于”列表中的对象之一。


CommandText 属性

返回或设置指定对象的命令字符串。对于 RecordsetDef 和 SchemaRowsource 对象为 String 类型，只读；对于“应用于”列表中的其他对象为 String 类型，可读写。

expression.CommandText

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

对于类型 dscCommandText，该属性返回或设置从提供者返回单个结果集的文本字符串（通常为 SQL）。

对于类型 dscCommandFile，该属性返回或设置 XML 文件的 URL，其中包含指定 SchemaRowsource 对象的数据。


CompareMemberCaptionsBy 属性

返回或设置一个 PivotMembersCompareByEnum 常量，确定数据透视表控件成员标题与 MemberCaptions 属性设置的自定义标题列表的比较方式。与 MemberCaptions 属性建立的自定义列表相符的标题将使用自定义标题重命名。可读写。

PivotMembersCompareByEnum 可以为下列 PivotMembersCompareByEnum 常量之一。
plMembersCompareByName 按名称比较标题。如果希望根据 MemberCaptions 属性建立的相应设置重新命名特定标题的每个出处，请使用该设置。这对日期和时间最有用。例如，可能希望以 Feb 替换每个 February 实例。
plMembersCompareByUniqueName 按唯一名称比较标题。如果数据集包含互不相关的标题的多个实例，请使用该设置。例如，数据集可能在 Maine 和 Oregon 下包含名为的 Portland 的项，但是不希望这些实例共用相同的标题。

expression.CompareMemberCaptionsBy

expression 必需。该表达式返回一个 PivotFieldSet 对象。

说明

如果指定字段为基于时间的字段，则默认值为 plMembersCompareByName。否则，默认值为 plMembersCompareByUniqueName。


CompareOrderedMembersBy 属性

返回或设置一个 PivotMembersCompareByEnum 常量，确定在通过 OrderedMembers 属性建立自定义排序次序后，数据透视表控件对指定字段集的成员进行排序的方式。可读写。

PivotMembersCompareByEnum 可以为下列 PivotMembersCompareByEnum 常量之一。
plMembersCompareByName 按名称比较标题。如果希望根据 MemberCaptions 属性建立的相应设置重新命名特定标题的每个出处，请使用该设置。这对日期和时间最有用。例如，可能希望以 Feb 替换每个 February 实例。
plMembersCompareByUniqueName 按唯一名称比较标题。如果数据集包含互不相关的标题的多个实例，请使用该设置。例如，数据集可能在 Maine 和 Oregon 下包含名为的 Portland 的项，但是不希望这些实例共用相同的标题。

expression.CompareOrderedMembersBy

expression 必需。该表达式返回一个 PivotFieldSet 对象。

说明

如果指定字段为基于时间的字段，则默认值为 plMembersCompareByName。否则，默认值为 plMembersCompareByUniqueName。


Connection 属性

返回或设置指定对象所用的 ADO Connection 对象。对于 PivotTable 对象，可读写；对于 DataSourceControl 和 DSCEventInfo 对象，只读。

expression.Connection

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

调用由该属性返回的 Connection 对象的方法或设置其属性时应当小心。例如，不应该调用 Connection 对象的 Close 方法。

要点 有关安全数据连接的有关信息，请参阅安全连接外部数据源。


ConnectionFile 属性

返回或设置一个 String 类型，指定用于将数据访问页连接到数据源的 Office Database Connection (.odc) 或 Microsoft Data Link (.udl) 文件名称。可读写。

expression.ConnectionFile

expression 必需。该表达式返回一个 DataSourceControl 对象。

示例

本示例将数据访问页连接到名为 "SQL Northwind.odc" 的 Office Database Connection 文件。

MSODSC.ConnectionFile = "SQL Northwind.odc"


ConnectionString 属性

返回或设置两层数据库连接的 ADO 连接。String 类型，可读写。

expression.ConnectionString

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

使用数据源控件，该属性等效于 Microsoft Access 中的 CurrentProject.BaseConnectionString。当数据源控件创建连接时，数据源控件的 ConnectionString 属性值可能与 Connection 对象返回的 ConnectionString 属性值不同，因为数据源控件使用了其他 OLE DB 提供者提供附加服务。例如，在 ID 为“MSODSC”的数据源控件所在的 HTML 页面上，下列表达式可能不等效。

要点 有关安全数据连接的有关信息，请参阅安全连接外部数据源。

MSODSC.ConnectionString
MSODSC.Connection.ConnectionString

示例

本示例建立一个到数据库的连接，查询数据，然后当加载包含 PivotTable1 的网页时，向 PivotTable1 添加字段。

Sub Window_OnLoad()

    Dim sConnStr
    Dim ptView

    ' Set a variable to the connection string.
    sConnStr = "Provider=sqloledb;Data Source=DataServer;Initial Catalog=Testing;Integrated Security=SSPI;"

    ' Set the connection string
    PivotTable1.ConnectionString = sConnStr

    ' Return all data from the Spending table.
    PivotTable1.CommandText = "Select * from Spending"

    Set ptView = PivotTable1.ActiveView

    ' The following four lines of code add fields to the row area and data
    ' areas of the PivotTable list.
    ptView.RowAxis.InsertFieldSet ptView.FieldSets("Project")
    ptView.RowAxis.InsertFieldSet ptView.FieldSets("Year")
    ptView.DataAxis.InsertFieldSet ptView.FieldSets("Budget")
    ptView.DataAxis.InsertFieldSet ptView.FieldSets("Actual")

End Sub


Constants 属性

返回允许脚本用户使用命名常量的对象。只读。

有关详细信息，请参阅在 VBScript 中使用命名常量。

该属性仅在 HTML 页上必需。在其他容器（例如 Visual Basic）中，可以直接使用对象模块中定义的常量，而不必使用 Constants 属性。在其他容器中使用 Constants 属性将有效，但由于它将明显导致代码运行延缓，因此不建议使用。

expression.Constants

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例为电子表格上区域 B5:C10 中的所有单元格添加中等粗细的绿色边框。由于在 VBScript 中不能使用命名常量，因此本示例为 Constants 属性返回的对象设置了一个变量。

Sub SetBorder()
    Dim ssConstants

    ' Set a variable to the constants of the Spreadsheet component.
    Set ssConstants = Spreadsheet1.Constants

    ' Set the border weight.
    Spreadsheet1.Range("b5:c10").Borders.Weight = ssConstants.owcLineWeightMedium

    ' Set the border color.
    Spreadsheet1.Range("b5:c10").Borders.Color = "green"
End Sub


ConsumesRecordset 属性

对于复杂控件，如果数据由数据源控件提供，则返回 True。任何数据绑定控件均具有 ControlSource 属性（用于简单 HTML 控件）或 ConsumesRecordset 属性（用于诸如数据透视表列表或图表工作区的复杂控件）。Boolean 类型，可读写。

expression.ConsumesRecordset

expression 必需。该表达式返回一个 ElementExtension 对象。


Control 属性

返回一个 PivotTable 对象，表示指定 PivotData 或 PivotView 对象的数据透视表列表。

expression.Control

expression 必需。该表达式返回一个 PivotData 或 PivotView 对象。


ControlSource 属性

返回或设置指定控件所绑定的控件名称。String 类型，可读写。

expression.ControlSource

expression 必需。该表达式返回一个 ElementExtension 对象。

说明

该属性返回或设置指定控件所绑定字段的 Name 和 Source 属性值。该属性值以下列格式的字符串返回：“PageField.Name:PageField.Source”，其中斜体字符串将替换为实际的 Name 和 Source 属性值。如果 Name 和 Source 属性值一致，则返回一个值。

如果将该属性设置为方案行来源中的方案字段名称，并且包含指定控件的节使用该行来源，则方案字段自动添加为页字段。


Count 属性

返回指定集合中的对象数目。Long 类型，只读。

expression.Count

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例设置用于表示活动工作表上可见区域中列数和行数的变量，然后隔行设置单元格颜色。

Sub Format_Odd_Rows()
    Dim rngUsed
    Dim iUsedRows
    Dim iUsedColumns
    Dim shtActive
    Dim iCtr

    Set shtActive = Spreadsheet1.ActiveSheet

    ' Set a variable ot the used range of the active sheet.
    Set rngUsed = shtActive.UsedRange

    ' Get the count of used rows in the active sheet.
    iUsedRows = rngUsed.Rows.Count

    ' Get the count of used columns in the active sheet.
    iUsedColumns = rngUsed.Columns.Count

    ' Loop through every odd row in the used range.
    For iCtr = 1 To iUsedRows Step 2

        ' Color the background of the cells green.
        shtActive.Range(shtActive.Cells(iCtr, 1), shtActive. _
            Cells(iCtr, iUsedColumns)).Interior.ColorIndex = 43
    Next
End Sub


Criteria 属性

返回指定筛选的 Criteria 对象。请使用 Criteria 对象的 Add 方法为 Filter 对象添加条件，其中 Criteria 对象为此属性所返回。只读。

expression.Criteria

expression 必需。该表达式返回一个 Filter 对象。

示例

本示例打开 A1:C20 区域内的“自动筛选”，为 A 列和 C 列设置筛选，然后应用这些筛选。

Sub Apply_AutoFilter()
Dim afFilters
Dim afCol1
Dim afCol3

' Turn on AutoFilter.
Spreadsheet1.Worksheets("Sheet1").Range("A1:C20").AutoFilter

' Set a variable to the AutoFilter object
Set afFilters = Spreadsheet1.Worksheets("sheet1").AutoFilter

Set afCol1 = afFilters.Filters(1)
Set afCol3 = afFilters.Filters(3)

' Add a criteria that excludes blue from column A.
afCol1.Criteria.Add "blue"

' Add a criteria that excludes green from column A.
afCol1.Criteria.Add "green"

' Add a criteria that excludes yellow from column c.
afCol3.Criteria.Add "yellow"

'Apply the criteria
afFilters.Apply
End Sub


Crosses 属性

返回或设置表示指定的坐标轴与其他坐标轴相交方式的值。ChartAxisCrossesEnum 类型，可读写。

ChartAxisCrossesEnum 可为以下 ChartAxisCrossesEnum 常量之一：
chAxisCrossesAutomatic 自动设置两个坐标轴的交点。
chAxisCrossesCustom 由 CrossesAtValue 和 CrossingAxis 属性指定交点。

expression.Crosses

expression 必需。该表达式返回一个 ChAxis 对象。

示例

如果分类轴没有设置自定义交点，本示例设置图表工作区中分类轴与数值轴在数值零 (0) 处相交。

Sub Format_Axis()
    Dim chConstants
    Dim axValueAxis
    Dim axCategoryAxis

    Set chConstants = ChartSpace1.Constants

    Set axValueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue)
    Set axCategoryAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionCategory)

    If axCategoryAxis.Crosses = chConstants.chAxisCrossesAutomatic Then
        axValueAxis.CrossingAxis = axCategoryAxis
        axCategoryAxis.CrossesAtValue = 0
    End If

End Sub


CrossesAtValue 属性

返回或设置指定坐标轴的交点。当设置某坐标轴的该值时，实际上是设置该坐标轴与其他坐标轴相交时其他坐标轴上的值。例如，设置数值 (y) 轴的该属性将设置数值轴与分类 (x) 轴相交时分类轴上的值。Double 类型，可读写。

expression.CrossesAtValue

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例设置图表工作区中的分类轴与数值轴在数值零 (0) 处相交。

Sub SetCrossingValue()
    Dim chConstants
    Dim axValueAxis
    Dim axCategoryAxis

    Set chContants = ChartSpace1.Constants

    Set axValueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue)
    Set axCategoryAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionCategory)

    axValueAxis.CrossingAxis = axCategoryAxis

    axCategoryAxis.CrossesAtValue = 0
End Sub

以下示例使数值轴与分类轴在第三分类点处相交。

Sub SetCrossingCategory()
    Dim chConstants

    Set chConstants = ChartSpace1.Constants
    ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionLeft).CrossesAtValue = 3
End Sub


CrossingAxis 属性

返回或设置相交坐标轴。如果指定坐标轴已删除，则该属性设置为 Null，并且 Crosses 属性恢复为 chAxisCrossesAutomatic。ChAxis 类型，可读写。

expression.CrossingAxis

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例设置图表工作区中的分类轴与数值轴在数值零 (0) 处相交。

Sub SetCrossingValue()
    Dim chConstants
    Dim axValueAxis
    Dim axCategoryAxis

    Set chtContants = ChartSpace1.Constants

    Set axValueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue)
    Set axCategoryAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionCategory)

    axValueAxis.CrossingAxis = axCategoryAxis

    axCategoryAxis.CrossesAtValue = 0
End Sub


CSVData 属性

以逗号分隔列表返回或设置电子表格数据。String 类型，可读写。

expression.CSVData

expression 必需。该表达式返回一个 Spreadsheet 对象。

示例

本示例设置单元格区域 A1:G1 的值。

Spreadsheet1.CSVData = "1,1,2,3,5,8,13"


CSVURL 属性

返回或设置以逗号分隔的电子表格数据文件的 URL（Internet 地址）。String 类型，可读写。

expression.CSVURL

expression 必需。该表达式返回一个 Spreadsheet 对象。

示例

本示例设置电子表格数据，数据来自用户计算机上的文件。

Spreadsheet1.CSVURL = "file:\test.csv"


CurrentArray 属性

如果指定单元格属于数组，则返回表示整个数组的 Range 对象。如果指定单元格不属于数组，将导致运行时出错。只读。

expression.CurrentArray

expression 必需。该表达式返回一个 Range 对象。

说明

使用 HasArray 属性判断单元格是否属于数组。

示例

假定活动单元格属于数组，本示例选定该数组。

Spreadsheet1.ActiveCell.CurrentArray.Select


CurrentCell 属性

返回一个 PivotCell 对象，包含当前编辑的明细单元格。

expression.CurrentCell

expression 必需。该表达式返回一个 PivotData 对象。

说明

该属性仅在数据透视表列表连接到关系数据源时有效。


CurrentRegion 属性

返回代表当前区域的 Range 对象。当前区域是以空行与空列的组合为边界的区域。只读。

expression.CurrentRegion

expression 必需。该表达式返回一个 Range 对象。

示例

如果活动工作表上单元格 A1 的当前区域处于可见状态，则本示例中的函数返回 True（如果当前区域在可见区域之外，则函数返回 False）。

Function IsCurrentRegionVisible()
    Dim rngCurrent
    Dim rngVisible
    Dim rngIntersect

    ' Set the varible to the current region of cell A1.
    Set rngCurrent = Spreadsheet1.ActiveSheet.Cells(1, 1).CurrentRegion

    ' Set a variable to the currently visible range.
    Set rngVisible = Spreadsheet1.ActiveWindow.VisibleRange

    ' Set a variable to the overlapping portion of the current region
    ' and the visible range.
    Set rngIntersect = Spreadsheet1.RectIntersect(rngCurrent, rngVisible)

    ' If the overlapping region is the same as the current region, then
    ' return true.
    IsCurrentRegionVisible = (rngIntersect.Address = rngCurrent.Address)
End Function


CurrentSection 属性

返回一个表示当前节（包含焦点当前所在的控件的节）的 Section 对象。

expression.CurrentSection

expression 必需。该表达式返回一个 DataSourceControl 对象。


CustomGroupMembers 属性

返回一个 PivotMembers 集合，表示自定义分组字段的成员。

expression.CustomGroupMembers

expression 必需。该表达式返回一个 PivotField 对象。


CustomGroupType 属性

返回一个 PivotMemberCustomGroupTypeEnum 常量，表示指定成员所在组的类型。只读。

PivotMemberCustomGroupTypeEnum 可以为下列 PivotMemberCustomGroupTypeEnum 常量之一。
plGroupTypeCustomGroup 指定成员为自定义组。
plGroupTypeDynamicOther
plGroupTypeFallThrough
plGroupTypePlaceHolder
plGroupTypeRegular 指定成员不是自定义组。
plGroupTypeStaticOther

expression.CustomGroupType

expression 必需。该表达式返回一个 PivotAxisMember 对象。


DashStyle 属性

返回或设置表示指定线条或边框虚线线型的 ChartLineDashStyleEnum 常量。可读写。

ChartLineDashStyleEnum 可以为下列 ChartLineDashStyleEnum 常量之一。
chLineDash
chLineDashDot
chLineDashDotDot
chLineLongDash
chLineLongDashDot
chLineRoundDot
chLineSolid
chLineSquareDot

expression.DashStyle

expression 必需。该表达式返回一个 ChLine 或 ChBorder 对象。

说明

该属性只对系列线条有效。

示例

本示例将 Chartspace1 中的第一个图表更改为折线图，然后设置图表中第一个数据系列的线条格式。

Sub Set_Series_LineStyle()

    Dim chConstants
    Dim serSeries1

    Set chConstants = ChartSpace1.Constants

    ' Change the chart to a line chart.
    ChartSpace1.Charts(0).Type = chChartTypeLine

    ' Set a variable to refer to the first data series in the chart.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Set the miter of the line of the first series.
    serSeries1.Line.Miter = chConstants.chLineMiterBevel

    ' Set the line weight of the first series.
    serSeries1.Line.Weight = chConstants.owcLineWeightThick

    ' Set the line style of the first series.
    serSeries1.Line.DashStyle = chConstants.chLineRoundDot

End Sub


Data 属性

返回一个 PivotData 对象，表示数据透视表列表的数据源。

expression.Data

expression 必需。该表达式返回“应用于”列表中的对象之一。


DataAxis 属性

返回代表数据轴的 PivotDataAxis 对象。使用该属性返回的 PivotDataAxis 对象在“数据透视表”列表的数据轴插入字段和总计。只读。

示例

本示例为活动视图的“数据透视表”列表添加总计，并在数据轴插入字段集。

Sub InsertTotal()
    Dim ptView
    Dim ptConstants
    Dim totNewtotal

    Set ptView = PivotTable1.ActiveView
    Set ptConstants = PivotTable1.Constants

    Set totNewTotal = view.AddTotal("myTotal", view.FieldSets("Freight").Fields(0), _
                                    ptConstants.plFunctionSum)

    ptView.DataAxis.InsertTotal totNewTotal
    ptView.DataAxis.InsertFieldSet ptView.FieldSets("OrderDate")
End Sub


DataBodyRange 属性

从指定 ListObject 对象中返回数据绑定行作为 Range 对象。Range 对象，只读。

expression.DataBodyRange

expression 必需。该表达式返回一个 ListObject 对象。

说明

不支持某些 Range 属性和方法。不支持的属性包括 Locked、MergeArea 和 MergeCells。不支持的方法包括 Delete、Insert、Merge 和 UnMerge。DataBodyRange 不包括 HeaderRowRange 属性（数据绑定行上面的标题行）或 InsertRowRange 属性（数据绑定行下面的插入行）。

注意：若要设置行的颜色，仅可对 XML 列表中的所有行设置颜色。无法设置插入行的颜色。

示例

本示例将 ListObject 对象的 DataBodyRange 的内部颜色设置为黄色，边框颜色设置为红色。

Dim rngDataBody

' Set a variable to the data body range.
Set rngDataBody = Spreadsheet1.ActiveSheet.ListObjects(1).DataBodyRange

' Set the interior color and the border color of the data body range.
With rngDataBody
    .Interior.ColorIndex = 6
    .Borders.ColorIndex = 3
End With


DataEntry 属性

如果指定页只用于数据输入，则返回 True（如果页面还包括填充记录集，则返回 False）。默认值为 False。Boolean 类型，可读写。

expression.DataEntry

expression 必需。该表达式返回一个 DataSourceControl 对象。


DataField 属性

如果数据来自记录集，则返回 PivotField 对象所绑定的字段名称。String 类型，只读。

expression.DataField

expression 必需。该表达式返回一个 PivotField 对象。


DataLabel 属性

返回代表指定趋势线相关联的数据标志的 ChDataLabel 对象。只读。

expression.DataLabel

expression 必需。该表达式返回一个 ChTrendline 对象。

示例

本示例在图表工作区的指定系列中添加趋势线，设置数据标志字体为加粗，并使趋势线只显示公式（而不显示 R 平方值）。

Sub AddTrendLine()
Dim trndline

' Add a trendline to the first series in the first chart in ChartSpace1.
Set trndline = ChartSpace1.Charts(0).SeriesCollection(0).Trendlines.Add

' Set the font of the trendline to bold.
trndline.DataLabel.Font.Bold = True

' Do not display the R-Squared value with the trendline.
trndline.IsDisplayingRSquared = False

' Display the equation for the trendline.
trndline.IsDisplayingEquation = True
End Sub


DataLabelsCollection 属性

返回包含指定系列数据标志的 ChDataLabelsCollection 对象。每个系列中只能包含一套数据标志。只读。

有关返回集合中的单个成员的详细信息，请参阅返回集合中的对象。

expression.DataLabelsCollection

expression 必需。该表达式返回一个 ChSeries 对象。

示例

本示例在图表工作区中的指定系列添加数据标志。

ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection.Add

本示例设置指定系列的数据标志字体。

ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection(0).Font.Bold = True


DataMember 属性

返回或设置数据成员名称（指定控件将从数据源请求获取的记录集名称）。DataMember 类型，可读写。

expression.DataMember

expression 必需。该表达式返回“应用于”列表中的对象之一。


DataPage 属性

返回一个 DataPage 对象，表示指定节的数据访问页。

expression.DataPage

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

数据页为共享通用记录导航控件的一组节。


DataPages 属性

返回数据源控件的 DataPages 集合。

expression.DataPages

expression 必需。该表达式返回一个 DataSourceControl 对象。


DataPageSize 属性

返回或设置数据访问页上指定联合级别所显示的记录数。联合页的默认值为 5，非联合页为 1。Long 类型，可读写。

expression.DataPageSize

expression 必需。该表达式返回一个 GroupLevel 对象。


DataSource 属性

返回或设置表示指定控件数据源的 ADO DataSource 对象。

expression.DataSource

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例创建绑定到电子表格的图表。系列名称在单元格 B1 中，分类名称在单元格 A2:A28 中，值在单元格 B2:B28 中。

Set c = ChartSpace1.Constants
Set ChartSpace1.DataSource = Spreadsheet1.Object
ChartSpace1.Charts.Add
ChartSpace1.Charts(0).Type = c.chChartTypeLineMarkers
ChartSpace1.Charts(0).SetData c.chDimCategories, 0, "a2:a28"
ChartSpace1.Charts(0).SetData c.chDimSeriesNames, 0, "b1"
ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimValues, 0, "b2:b28"


DataSourceName 属性

返回或设置一个 String 类型，指定作为图表控件数据源的 ActiveX 控件名称。该属性可用于支持 Microsoft Internet Explorer 文档对象模型的容器中。可读写。

expression.DataSourceName

expression 必需。该表达式返回一个 ChartSpace 对象。

示例

本示例将 PivotTable1 作为 Chartspace1 的数据源，然后显示字段列表使用户可以向图表添加数据。

Sub ConnectChart()

   ' Bind ChartSpace1 to PivotTable1.
   Chartspace1.DataSourceName = "PivotTable1"

   ' Display the field list.
   Chartspace1.DisplayFieldList = True

End Sub


DataSourceType 属性

返回或设置指定图表工作区的数据源类型。ChartDataSourceTypeEnum 类型，只读。

ChartDataSourceTypeEnum 可为以下 ChartDataSourceTypeEnum 常量之一：
chDataSourceTypeDSC
chDataSourceTypePivotTable
chDataSourceTypeQuery
chDataSourceTypeSpreadsheet
chDataSourceTypeUnknown

expression.DataSourceType

expression 必需。该表达式返回一个 ChartSpace 对象。


DataType 属性

显示 DataType 属性应用于 SchemaField 和 SchemaParameter 对象的情形。

返回或设置指定字段的数据类型。ADO DataTypeEnum 类型，可读写。

expression.DataType

expression 必需。该表达式返回上述对象之一。

显示 DataType 属性应用于 PivotField 对象的情形。

返回或设置指定字段的数据类型。ADO DataTypeEnum 类型，只读。

expression.DataType

expression 必需。该表达式返回一个 PivotField 对象。

显示 DataType 属性应用于 Spreadsheet 对象的情形。

指定电子表格的数据格式和来源，如下表所示。String 类型，可读写。

值 | 含义
HTMLURL | 数据源为 HTMLURL 属性指定的 URL。
HTMLData | 数据源为 HTMLData 属性指定的字符串。
CSVURL | 数据源为 CSVURL 属性指定的 URL。
CSVData | 数据源为 CSVData 属性指定的字符串。

expression.DataType

expression 必需。该表达式返回一个 Spreadsheet 对象。


DefaultColor 属性

如果 Color 属性为 chColorAutomatic，则返回表示指定填充色以 RGB 封装的整数。Variant 类型，只读。

expression.DefaultColor

expression 必需。该表达式返回一个 ChInterior 对象。


DefaultControlType 属性

返回或设置指定数据源控件的默认控件类型。DefaultControlTypeEnum 类型，可读写。

DefaultControlTypeEnum 可为以下 DefaultControlTypeEnum 常量之一：
ctlTypeBoundHTML
ctlTypeBoundSpan
ctlTypeTextBox

expression.DefaultControlType

expression 必需。该表达式返回一个 DataSourceControl 对象。


DefaultMember 属性

返回一个 PivotMember 对象，表示指定字段集的默认成员。

expression.DefaultMember

expression 必需。该表达式返回一个 PivotFieldSet 对象。

说明

该属性仅在数据透视表列表连接到 OLAP 数据源时有效。

默认成员通常为“全部”或数据维中的顶层成员之一。


DefaultQueryOnLoad 属性

该属性设置为 True 时，加载页面时将刷新 Purpose 属性值为“Query”并且 LoadMode 属性值为“Normal”的绑定。设置为 False 时，加载页面时不刷新任何绑定。可读写。

expression.DefaultQueryOnLoad

expression 必需。该表达式返回一个 Spreadsheet 对象。

说明

XmlDataBinding 对象可为到 XML 文件、SOAP 服务、其他 Web 部件（仅当从“电子表格 Web 部件”中进行绑定时）或数据检索服务的绑定。

DefaultQueryOnLoad 属性的默认值为 True。Purpose 属性位于 XML 电子表格文件的 <DataSource> 元素所包含的数据检索服务连接绑定明细数据中 (Binding/DataSource/ConnectionInfo@Purpose)。LoadMode 属性位于 <Binding> 元素中。在 XML 电子表格文件中显示这些明细数据的 XML 片段如下所示：

<x2:Binding x2:ID="Cust_bind_id" x2:LoadMode="Normal" x2:Async="False">
<x2:MapID>Cust_MapId</x2:MapID>
   <udc:DataSource MajorVersion="1" MinorVersion="0">
   <udc:Type Type="XMLFile" MajorVersion="1" MinorVersion="0"/>
   <udc:Name>sample_name</udc:Name>
   <udc:ConnectionInfo Purpose="Query">


DefaultRecordset 属性

返回指定控件的默认 ADO Recordset 对象。只读。

expression.DefaultRecordset

expression 必需。该表达式返回一个 DataSourceControl 对象。

说明

不应对绑定到记录集的节使用该属性，而应使用 DataPage 对象的 Recordset 属性。


DefaultSort 属性

返回或设置用于指定联合级别排序的字段。字段必须为联合级别的一部分。如果使用该属性指定多个字段，请使用逗号分隔字段。String 类型，可读写。

expression.DefaultSort

expression 必需。该表达式返回一个 GroupLevel 对象。


DefaultValue 属性

返回或设置指定控件在用户新建记录时的值。应用于任何绑定控件、具有 Value 属性的控件或同时满足这些条件的任何控件。对于 ElementExtension 对象为 String 类型，可读写；对于 PivotField 对象为 Variant 类型，可读写。

expression.DefaultValue

expression 必需。该表达式返回“应用于”列表中的对象之一。


DesignMode 属性

如果电子表格控件当前处于设计模式，则返回 True。Boolean 类型，只读。

expression.DesignMode

expression 必需。该表达式返回一个 Spreadsheet 对象。


DetailAutoFit 属性

显示 DetailAutoFit 属性应用于 PivotField 对象的情形。

如果指定字段在用于数据轴时列宽设置为自动，则返回 True。Boolean 类型，可读写。

expression.DetailAutoFit

expression 必需。该表达式返回一个 PivotField 对象。

显示 DetailAutoFit 属性应用于 PivotView 对象的情形。

如果明细网格的宽度由明细字段的宽度确定，则返回 True。明细网格的宽度不能超过 DetailMaxWidth 属性值。如果 DetailAutoFit 属性设置为 False，则明细网格的宽度基于 DetailWidth 属性值设置。如果 DetailAutoFit 属性设置为 True，任何布局更改将自动更新 DetailWidth 属性。Boolean 类型，可读写。

expression.DetailAutoFit

expression 必需。该表达式返回一个 PivotView 对象。


DetailBackColor 属性

返回或设置指定字段在明细网格中显示时的背景色。默认背景色为白色。Variant 类型，可读写。

expression.DetailBackColor

expression 必需。该表达式返回一个 PivotField 对象。

说明

当设置该属性时，可使用 Long 类型值代表红绿蓝体系的颜色值或 String 类型值命名一种有效的 HTML 颜色。例如，如果要将对象设置为红色，可使用十六进制值 &HFF，十进制值 255 或字符串值“red”。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝体系的颜色值（红色为 RGB(255,0,0)）。

该属性总是返回 Long 类型值，该值代表一种红绿蓝体系的颜色值。


DetailCells 属性

返回基于行列索引的 PivotDetailCell 对象。使用该属性访问“数据透视表”列表明细区域中单个单元格的属性。

expression.Cell(Row, Column)

expression 该表达式返回一个 PivotCell 对象。

Row Long 类型，必需。指定包含指定单元格的行。

Column Long 类型，必需。指定包含指定单元格的列。


DetailColumnCount 属性

返回一个 Long 类型，表示指定单元格中明细单元格的列数。只读。

expression.DetailColumnCount

expression 必需。该表达式返回一个 PivotCell 对象。

说明

如果在数据透视表列表连接到 OLAP 数据源时，使用该属性将导致运行时出错。


DetailFont 属性

返回 PivotFont 对象，代表指定字段在明细网格中的显示字体。只读。

expression.DetailFont

expression 必需。该表达式返回一个 PivotField 对象。


DetailForeColor 属性

返回或设置指定字段在明细网格中显示时的前景色。Variant 类型，可读写。

expression.DetailForeColor

expression 必需。该表达式返回一个 PivotField 对象。

说明

当设置该属性时，可使用 Long 类型值代表红绿蓝体系的颜色值或 String 类型值命名一种有效的 HTML 颜色。 例如，如果要将对象设置为红色，可使用十六进制值 &HFF，十进制值 255 或字符串值“red”。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝体系的颜色值（红色为 RGB(255,0,0)）。

该属性总是返回 Long 类型值，该值代表一种红绿蓝体系的颜色值。

示例

本示例在 PivotTable1 中添加插入字段，添加总计，然后设置“数据透视表”列表明细区域中的字段格式。

Sub Layout_PivotTable1()
    Dim vwView
    Dim ptConstants
    Dim totOrderCount

    Set ptConstants = PivotTable1.Constants
    Set vwView = PivotTable1.ActiveView

    ' Add the ShipCountry field to the row axis.
    vwView.RowAxis.InsertFieldSet vwView.FieldSets("ShipCountry")

    ' Add the OrderId field to the data axis.
    vwView.DataAxis.InsertFieldSet vwView.FieldSets("OrderID")

    ' Add the ShipVia field to the filter axis.
    vwView.FilterAxis.InsertFieldSet vwView.FieldSets("ShipVia")

    ' Create a total named "Order Count" that counts the OrderID field.
    Set totOrderCount = vwView.AddTotal("Order Count", vwView.FieldSets("OrderId").Fields("OrderId"), _
                        ptConstants.plFunctionCount)

    ' Add the Order Count total to the data axis.
    vwView.DataAxis.InsertTotal totOrderCount

    ' Set the horizontal alignment of the OrderID field.
    vwView.FieldSets("OrderId").Fields("OrderId").DetailHAlignment = plHAlignCenter

    ' Set the foreground color of the OrderId field.
    vwView.FieldSets("OrderId").Fields("OrderId").DetailForeColor = RGB(100, 100, 200)

End Sub


DetailHAlignment 属性

返回或设置指定字段在明细网格中显示时字段值的水平排列方式。默认情况下，数值为左对齐。PivotHAlignmentEnum 类型，可读写。

PivotHAlignmentEnum 可为以下 PivotHAlignmentEnum 常量之一：
plHAlignAutomatic
plHAlignCenter
plHAlignLeft
plHAlignRight

expression.DetailHAlignment

expression 必需。该表达式返回一个 PivotField 对象。

示例

本示例在 PivotTable1 中添加插入字段，添加总计，然后设置“数据透视表”列表明细区域中的字段格式。

Sub Layout_PivotTable1()
    Dim vwView
    Dim ptConstants
    Dim totOrderCount

    Set ptConstants = PivotTable1.Constants
    Set vwView = PivotTable1.ActiveView

    ' Add the ShipCountry field to the row axis.
    vwView.RowAxis.InsertFieldSet
    vwView.FieldSets("ShipCountry")

    ' Add the OrderId field to the data axis.
    vwView.DataAxis.InsertFieldSet vwView.FieldSets("OrderID")

    ' Add the ShipVia field to the filter axis.
    vwView.FilterAxis.InsertFieldSet
    vwView.FieldSets("ShipVia")

    ' Create a total named "Order Count" that counts
    ' the OrderID field.
    Set totOrderCount = vwView.AddTotal("Order Count",
    vwView.FieldSets("OrderId").Fields("OrderId"), _
    ptConstants.plFunctionCount)

    ' Add the Order Count total to the data axis.
    vwView.DataAxis.InsertTotal totOrderCount

    ' Set the horizontal alignment of the OrderID field.
    vwView.FieldSets("OrderId").Fields("OrderId").DetailHAlignment = plHAlignCenter

    ' Set the foreground color of the OrderId field.
    vwView.FieldSets("OrderId").Fields("OrderId").DetailForeColor = RGB(100, 100, 200)

End Sub


DetailLeft 属性

返回或设置一个 Long 类型，表示明细网格中最左侧的列。可读写。

expression.DetailLeft(Column)

expression 该表达式返回“应用于”列表中的对象之一。

Column PivotMember 对象，必需。指定明细网格中最左侧的列。


DetailLeftOffset 属性

返回或设置一个 Long 类型，表示明细区域中的数据距离左边偏移的像素数。使用该属性向左移动明细区域中的数据。可读写。

expression.DetailLeftOffset

expression 必需。该表达式返回一个 PivotColumnMember 对象。

说明

将该属性设置为负值将导致运行时出错。

示例

本示例将 PivotTable1 明细区域中的数据向左移动 10 个像素。

PivotTable1.ActiveData.ColumnAxis.ColumnMember.DetailLeftOffset = 10


DetailMaxHeight 属性

返回或设置当 DetailAutoFit 属性值为 True 时明细网格可以达到的最大高度（像素）。如果明细网格的高度超过最大高度时将显示滚动条。默认值为 250 像素。如果 DetailAutoFit 属性值为 False 则忽略该属性。Long 类型，可读写。

expression.DetailMaxHeight

expression 必需。该表达式返回一个 PivotView 对象。


DetailMaxWidth 属性

返回或设置当 DetailAutoFit 属性值为 True 时明细网格可以达到的最大宽度（像素）。如果明细网格的宽度超过最大宽度时将显示滚动条。默认值为 1024 像素。如果 DetailAutoFit 属性值为 False 则忽略该属性。Long 类型，可读写。

expression.DetailMaxWidth

expression 必需。该表达式返回一个 PivotView 对象。


DetailRange 属性

返回指定区域的一个 PivotDetailRange 对象。

expression.DetailRange(TopLeft, BottomRight)

expression 该表达式返回一个 PivotCell 对象。

TopLeft 必需，PivotDetailCell 对象。指定明细区域左上角的单元格。

BottomRight 必需，PivotDetailCell 对象。指定明细区域右下角的单元格。


DetailRowCount 属性

返回一个 Long 类型，表示包含指定单元格的明细区域的行数。只读。

expression.DetailRowCount

expression 必需。该表达式返回一个 PivotCell 对象。

说明

如果在数据透视表列表连接到 OLAP 数据源时，使用该属性将导致运行时出错。


DetailRowHeight 属性

返回或设置明细网格的行高（像素）。Long 类型，可读写。

expression.DetailRowHeight

expression 必需。该表达式返回一个 PivotView 对象。


DetailsExpanded 属性

返回数据透视表列表的明细区域中是否展开明细数据。Boolean 类型，只读。

expression.DetailsExpanded

expression 必需。该表达式返回一个 PivotColumnMember 对象。

说明

如果在数据透视表列表连接到 OLAP 数据源时，使用该属性将导致运行时出错。


DetailSortOrder 属性

返回或设置汇总轴上字段的排序方式。Variant 类型，可读写。

expression.DetailSortOrder

expression 必需。该表达式返回一个 PivotView 对象。

说明

字段按数组次序排序。如果在排序数组中某字段的 SortDirection 属性设置为 plSortDirectionDefault，则忽略该字段。


DetailTop 属性

返回或设置明细网格中最上面可见行的索引。Long 类型，可读写。

expression.DetailTop

expression 必需。该表达式返回一个 PivotCell 对象。


DetailTopOffset 属性

返回或设置一个 Long 类型，表示明细区域中指定单元格距离顶部偏移的像素数。使用该属性向上移动明细区域中的单元格。可读写。

expression.DetailTopOffset

expression 必需。该表达式返回一个 PivotCell 对象。

说明

将该属性设置为负值将导致运行时出错。

示例

本示例将数据透视表明细区域中的当前选定单元格向上滚动 15 个像素。

PivotTable1.ActiveData.CurrentCell.DetailTopOffset = 15


DetailWidth 属性

返回或设置指定字段在明细网格中显示的宽度（像素）。Long 类型，可读写。

expression.DetailWidth

expression 必需。该表达式返回一个 PivotField 对象。


Direction 属性

显示 Direction 属性应用于 ChErrorBars 对象的情形。

返回或设置指定误差线的误差线方向。ChartErrorBarDirectionEnum 类型，可读写。

ChartErrorBarDirectionEnum 可为以下 ChartErrorBarDirectionEnum 常量之一：
chErrorBarDirectionX
chErrorBarDirectionY

expression.Direction

expression 必需。该表达式返回上述对象之一。

说明

chErrorBarDirectionX 常量只能用于 XY 散点图、极坐标图、条形图或气泡图。

显示 Direction 属性应用于 SchemaParameter 对象的情形。

返回 SchemaRowSource 对象的 Direction 参数。ParameterDirectionEnum (ADO) 类型，只读。

expression.Direction

expression 必需。该表达式返回上述对象之一。

示例

显示 应用于 ChErrorBars 对象的情形。

本示例在指定图表添加误差线并设置误差线方向。Charts(0) 必须为 XY 散点图、极坐标图、条形图或气泡图。

Sub AddErrorBars()

   Dim ebErrorBars
   Dim chConstants

   Set chConstants = Chartspace1.Constants

   ' Add error bars to the first series in the chart.
   Set ebErrorBars = ChartSpace1.Charts(0).SeriesCollection(0).ErrorBarsCollection.Add

   ' Set the direction of the error bars.
   ebErrorBars.Direction = chConstants.chErrorBarDirectionX

End Sub


DirectionalLightInclination 属性

返回或设置一个 Double 类型，指定方向性光源相对于指定图表 X-Z 平面的旋转角度。有效设置范围为 -90 到 90。设置该属性为 -90 将光源置于图表正下方。设置该属性为 90 将光源置于图表的正上方。可读写。

expression.DirectionalLightInclination

expression 必需。该表达式返回一个 ChChart 对象。

示例

本示例将 Chartspace1 中的第一个图表转换为三维条形图，并设置图表的照明选项。

Sub Format3DLightSources()

    Dim cht3DBar

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DBar = ChartSpace1.Charts(0)

    ' Change the chart to a 3-D Bar chart.
    cht3DBar.Type = chChartTypeBar3D

    ' Set the intensity of the ambient light.
    cht3DBar.AmbientLightIntensity = 0.7

    ' Set the inclination of the directional light source.
    cht3DBar.DirectionalLightInclination = 35

    ' Set the intensity of the directional light source.
    cht3DBar.DirectionalLightIntensity = 0.8

    ' Set the rotation of the directional light source.
    cht3DBar.DirectionalLightRotation = 120

End Sub


DirectionalLightIntensity 属性

返回或设置一个 Double 类型，指定三维图表方向性光源的亮度。有效设置范围为 0 到 1。可读写。

expression.DirectionalLightIntensity

expression 必需。该表达式返回一个 ChChart 对象。

示例

本示例将 Chartspace1 中的第一个图表转换为三维条形图，并设置图表的照明选项。

Sub Format_3D_LightSources()

    Dim cht3DBar

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DBar = ChartSpace1.Charts(0)

    ' Change the chart to a 3D Bar chart.
    cht3DBar.Type = chChartTypeBar3D

    ' Set the intensity of the ambient light.
    cht3DBar.AmbientLightIntensity = 0.7

    ' Set the inclination of the directional light source.
    cht3DBar.DirectionalLightInclination = 35

    ' Set the intensity of the directional light source.
    cht3DBar.DirectionalLightIntensity = 0.8

    ' Set the rotation of the directional light source.
    cht3DBar.DirectionalLightRotation = 120
End Sub


DirectionalLightRotation 属性

返回或设置一个 Double 类型，指定三维图表的方向性光源的旋转角度。有效设置范围为 0 到 360。可读写。

expression.DirectionalLightRotation

expression 必需。该表达式返回一个 ChChart 对象。

说明

方向性光源围绕图表的 Y-轴旋转。

示例

本示例将 Chartspace1 中的第一个图表转换为三维条形图，并设置图表的照明选项。

Sub Format3DLightSources()

    Dim cht3DBar

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DBar = ChartSpace1.Charts(0)

    ' Change the chart to a 3D Bar chart.
    cht3DBar.Type = chChartTypeBar3D

    ' Set the intensity of the ambient light.
    cht3DBar.AmbientLightIntensity = 0.7

    ' Set the inclination of the directional light source.
    cht3DBar.DirectionalLightInclination = 35

    ' Set the intensity of the directional light source.
    cht3DBar.DirectionalLightIntensity = 0.8

    ' Set the rotation of the directional light source.
    cht3DBar.DirectionalLightRotation = 120

End Sub


Dirty 属性

如果自上次保存后对电子表格进行了更改，则返回 True。Boolean 类型，可读写。

expression.Dirty

expression 必需。该表达式返回一个 Spreadsheet 对象。

示例

如果自上次保存后对电子表格进行了更改，则本示例将电子表格导出到某个文件。

If Spreadsheet1.Dirty Then
    Spreadsheet1.Export "sstest.xls", Spreadsheet1.Constants.ssExportActionNone
End If


DisplayAlert 属性

返回或设置一个 DscDisplayAlert 常量，指出在调用 BeforeDelete 和 BeforeOverwrite 事件时是否显示警告。可读写。

DscDisplayAlert 可以为下列 DscDisplayAlert 常量之一。
dscDataAlertContinue 不显示警告。
dscDataAlertDisplay 显示警告要求用户确认操作。

expression.DisplayAlert

expression 必需。该表达式返回一个 DSCEventInfo 对象。

示例

本示例在 BeforeOverwrite 事件中使用 DisplayAlert 属性禁止在调用 ExportXML 方法时提示用户覆盖已有文件。

Sub MSODSC_BeforeOverwrite(DSCEventInfo)

   Dim dscConstants
   Set dscConstants = MSODSC.Constants

   ' Don't alert the user when overwriting an existing file.
   DSCEventInfo.DisplayAlert = dscConstants.dscDataAlertContinue

End Sub


DisplayAlerts 属性

如果在代码运行时要显示指定警告和消息，则返回 True。默认值为 True。如果不希望被提示和警告信息所打扰，请将该属性设置为 False；当消息需要响应时，将选择默认响应。

如果将该属性设置为 False，则不能自动设置为 True，要显示消息和警告必须将其设置为 True。Boolean 类型，可读写。

expression.DisplayAlerts

expression 必需。该表达式返回“应用于”列表中的对象之一。


DisplayCalculatedMembers 属性

返回或设置一个 Boolean 类型，确定是否显示计算成员。将该属性设置为 False 可隐藏成员。默认值为 True。可读写。

expression.DisplayCalculatedMembers

expression 必需。该表达式返回一个 PivotView 对象。


DisplayColumnHeadings 属性

返回或设置指定窗口是否显示列标题。设置该属性为 False 将隐藏列标题。默认值为 True。Boolean 类型，可读写。

expression.DisplayColumnHeadings

expression 必需。该表达式返回一个 Window 对象。

示例

本示例隐藏 Spreadsheet1 的活动窗口中的行列标题。

Sub HideHeadings()
   Spreadsheet1.ActiveWindow.DisplayColumnHeadings = False
   Spreadsheet1.ActiveWindow.DisplayRowHeadings = False
End Sub


DisplayCustomHeadings 属性

确定指定窗口是否显示自定义的行列标题（如果存在）。默认值为 True。Boolean 类型，可读写。

expression.DisplayCustomHeadings

expression 必需。该表达式返回一个 Window 对象。

说明

尽管将该属性设置为 False 可隐藏自定义的行列标题，但并不将它们重置为默认值。请使用该属性代替使用 ResetHeadings 方法暂时隐藏自定义的行列标题。

示例

本示例不显示 Spreadsheet1 的活动窗口中的自定义行列标题。

Spreadsheet1.ActiveWindow.DisplayCustomHeadings = False


DisplayDesignTimeUI 属性

设置为 True 在运行时显示“命令和选项”窗口的设计阶段版本。默认值为 False。Boolean 类型，可读写。

expression.DisplayDesignTimeUI

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例设置 Spreadsheet1 使其在运行时显示“命令和选项”窗口的设计阶段版本。

Spreadsheet1.DisplayDesignTimeUI = True


DisplayEmptyMembers 属性

如果显示了空成员（即使没有聚合项），则返回 True。默认值为 False。Boolean 类型，可读写。

expression.DisplayEmptyMembers

expression 必需。该表达式返回一个 PivotGroupAxis 对象。


DisplayExpandIndicator 属性

如果具有可用子成员或明细记录的成员显示了展开指示器，则返回 True。当隐藏展开指示器时，则在此位置成员显示名称。默认值为 True。 Boolean 类型，可读写。

expression.DisplayExpandIndicator

expression 必需。该表达式返回一个 PivotTable 对象。


DisplayFieldButtons 属性

返回或设置图表上是否显示字段按钮和放置区。设置该属性为 False 将隐藏字段按钮和放置区。默认值为 True。Boolean 类型，可读写。

expression.DisplayFieldButtons

expression 必需。该表达式返回一个 ChartSpace 对象。

说明

如果图表控件绑定到文本型数据源，则该属性无效。

示例

本示例隐藏 Chartspace1 上的放置区和字段按钮。

Chartspace1.DisplayFieldButtons = False


DisplayFieldList 属性

设置该属性为 True 可显示“字段列表”。默认值为 False。Boolean 类型，可读写。

expression.DisplayFieldList

expression 必需。该表达式返回“应用于”列表中的对象之一。


DisplayGridlines 属性

如果指定电子表格显示了网格线，则返回 True。默认值为 True。Boolean 类型，可读写。

expression.DisplayGridlines

expression 必需。该表达式返回一个 Window 对象。

示例

本示例隐藏电子表格上的网格线。

Spreadsheet1.ActiveWindow.DisplayGridlines = False


DisplayHeadings 属性

如果同时显示行列标题，则返回 True；如果都不显示或行列标题不完全显示，则返回 False。Boolean 类型，可读写。

expression.DisplayHeadings

expression 必需。该表达式返回一个 Window 对象。

说明

可以使用 DisplayColumnHeadings 和 DisplayRowHeadings 属性独立控制行列标题的显示。

示例

本示例隐藏 Spreadsheet1 活动窗口中的行列标题。

Spreadsheet1.ActiveWindow.DisplayHeadings = False


DisplayHorizontalScrollBar 属性

如果指定电子表格显示了水平滚动条，则返回 True。默认值为 True。Boolean 类型，可读写。

expression.DisplayHorizontalScrollBar

expression 必需。该表达式返回一个 Window 对象。

示例

本示例隐藏电子表格的水平滚动条。

Spreadsheet1.ActiveWindow.DisplayHorizontalScrollBar = False


DisplayIn 属性

返回或设置一个 PivotMemberPropertyDisplayEnum 常量，确定指定成员属性是显示在数据透视表列表上还是屏幕提示上，或两者都显示，或都不显示。可读写。

PivotMemberPropertyDisplayEnum 可以为下列 PivotMemberPropertyDisplayEnum 常量之一。
plDisplayPropertyInAll
plDisplayPropertyInReport
plDisplayPropertyInScreenTip
plDisplayPropertyNone

expression.DisplayIn

expression 必需。该表达式返回一个 PivotMemberProperty 对象。

示例

本示例设置并显示 Store Name 字段成员的标题。

Sub Display_MemberProperties()
    Dim ptView
    Dim ptConstants
    Dim fldStoreName

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable.
    Set ptView = PivotTable1.ActiveView

    ' Set a variable to the Store Name field.
    Set fldStoreName = ptView.FieldSets("Store").Fields("Store Name")

    ' The following three lines of code specify that the member properties are
    ' displayed in the PivotTable list.
    fldStoreName.MemberProperties("Store Manager").DisplayIn = ptConstants.plDisplayPropertyInReport
    fldStoreName.MemberProperties("Store Type").DisplayIn = ptConstants.plDisplayPropertyInReport
    fldStoreName.MemberProperties("Store Sqft").DisplayIn = ptConstants.plDisplayPropertyInReport

    ' The following three lines of code set the caption for the member properties.
    fldStoreName.MemberProperties("Store Manager").Caption = "Manager Name"
    fldStoreName.MemberProperties("Store Type").Caption = "Store Type"
    fldStoreName.MemberProperties("Store Sqft").Caption = "Size in SQFT"
End Sub


DisplayInFieldList 属性

返回或设置是否在“数据透视表字段列表”对话框中显示指定字段集或总计。将该属性设置为 False 可禁止在“数据透视表字段列表”对话框中显示指定字段集或总计。默认值为 True。Boolean 类型，可读写。

expression.DisplayInFieldList

expression 必需。该表达式返回一个 PivotFieldSet 或 PivotTotal 对象。

示例

本示例在 PivotTable1 中新添一个总计。新总计设置为显示父行字段的百分比，并且将不显示在“数据透视表字段列表”对话框中。

Sub Add_Total()

    Dim vwView
    Dim ptConstants
    Dim totNewTotal

    Set vwView = PivotTable1.ActiveView
    Set ptConstants = PivotTable1.Constants

    ' Add a new total named "Total Budget" to the current view.
    Set totNewTotal = vwView.AddTotal("Total Budget", vwView.FieldSets("Budget").Fields(0), _
             ptConstants.plFunctionSum)

    ' Insert the newly created total into the detail area of the PivotTable.
    vwView.DataAxis.InsertTotal totNewTotal

    ' Show the totals as a percentage of the parent row field.
    totNewTotal.ShowAs = ptConstants.plShowAsPercentOfRowParent

    ' Do not display the new total in the PivotTable Field List dialog box.
    totNewTotal.DisplayInFieldList = False

End Sub


DisplayOfficeLogo 属性

设置为 True 可在工具栏上显示 Microsoft Office 徽标。Boolean 类型，可读写。

expression.DisplayOfficeLogo

expression 必需。该表达式返回一个 ChartSpace、PivotTable 或 Spreadsheet 对象。

示例

本示例隐藏 PivotTable1 工具栏上的 Microsoft Office 徽标。

PivotTable1.DisplayOfficeLogo = False


DisplayPropertyToolbox 属性

设置该属性为 True 可显示“命令和选项”窗口。Boolean 类型，可读写。

expression.DisplayPropertyToolbox

expression 必需。该表达式返回“应用于”列表中的对象之一。


DisplayRowHeadings 属性

确定指定窗口是否显示行标题。设置该属性为 False 将隐藏行标题。默认值为 True。Boolean 类型，可读写。

expression.DisplayRowHeadings

expression 必需。该表达式返回一个 Window 对象。

示例

本示例隐藏 Spreadsheet1 活动窗口中的行列标题。

Sub HideHeadings()
   Spreadsheet1.ActiveWindow.DisplayColumnHeadings = False
   Spreadsheet1.ActiveWindow.DisplayRowHeadings = False
End Sub


DisplayScreenTips 属性

返回或设置是否显示屏幕提示。设置该属性为 False 将不显示屏幕提示。默认值为 True。Boolean 类型，可读写。

expression.DisplayScreenTips

expression 必需。该表达式返回一个 PivotTable 或 ChartSpace 对象。

示例

本示例禁用 PivotTable1 的屏幕提示。

PivotTable1.DisplayScreenTips = False


DisplayTitleBar 属性

如果指定的电子表格显示了标题栏，则返回 True。默认值为 True。Boolean 类型，可读写。

expression.DisplayTitleBar

expression 必需。该表达式返回一个 Spreadsheet 对象。

示例

本示例隐藏电子表格的标题栏。

Spreadsheet1.DisplayTitleBar = False


DisplayToolbar 属性

如果指定电子表格、图表区或“数据透视表”列表显示了工具栏，则返回 True。默认值为 True。Boolean 类型，可读写。

expression.DisplayToolbar

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

隐藏工具栏并不更改“数据透视表”列表的高度，但是将引起布局的更改。只有在 AutoFit 属性为 True 并且“数据透视表”列表的宽度调整为大于容纳工具栏所需的宽度时，宽度才发生更改。

示例

本示例隐藏电子表格的工具栏。

Spreadsheet1.DisplayToolbar = False


DisplayTotal 属性

返回是否显示指定 PivotResultGroupField 对象的总计。Boolean 类型，只读。

expression.DisplayTotal

expression 必需。该表达式返回一个 PivotResultGroupField 对象。


DisplayVerticalScrollBar 属性

如果指定电子表格显示了垂直滚动条，则返回 True。默认值为 True。Boolean 类型，可读写。

expression.DisplayVerticalScrollBar

expression 必需。该表达式返回一个 Window 对象。

示例

本示例隐藏电子表格的垂直滚动条。

Spreadsheet1.ActiveWindow.DisplayVerticalScrollBar = False


DisplayWorkbookTabs 属性

如果显示工作簿标签，则返回 True。如果设置单个 Window 对象的该属性为 False，则工作簿所有窗口的该属性均设置为 False。默认值为 True。Boolean 类型，可读写。

expression.DisplayWorkbookTabs

expression 必需。该表达式返回一个 Window 对象。


DisplayZeros 属性

如果显示零值，则返回 True。如果要隐藏指定窗口中的所有零值，则将该属性为 False。Boolean 类型，可读写。

expression.DisplayZeros

expression 必需。该表达式返回一个 Window 对象。


Divisions 属性

返回或设置一个 Long 类型，表示指定图表的图例中显示的科目数。可读写。

expression.Divisions

expression 必需。该表达式返回一个 ChSegment 对象。

示例

本示例将 Chartspace1 绑定到 SQL Server 罗斯文数据库中的 Order Details 表。然后，创建格式映射，在图表中以深蓝色阴影显示较大数值。

Sub Window_Onload()

    Dim serSeries1
    Dim segSegment1
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' The following two lines of code bind Chartspace1 to the Order Details table in the
    ' Northwind SQL Server database.
    ChartSpace1.ConnectionString = "Provider=SQLOLEDB.1;Persist Security Info=TRUE;" & _
                                   "Integrated Security=SSPI;Initial Catalog=Northwind;" & _
                                   "Data Source=ServerName;"
    ChartSpace1.DataMember = "Order Details"

    ' The following two lines of code bind Chartspace1 to the Quantity and ProductID fields
    ' int he Order details table.
    ChartSpace1.SetData chConstants.chDimCategories, chConstants.chDataBound, "ProductID"
    ChartSpace1.SetData chConstants.chDimValues, chConstants.chDataBound, "Quantity"

    ' Create a format map.
    ChartSpace1.SetData chConstants.chDimFormatValues, chConstants.chDataBound, "Quantity"

    ' Set a variable to the first series in the first chart in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a segment to the format map.
    Set segSegment1 = serSeries1.FormatMap.Segments.Add

    ' Measure the segment boundaries based upon a percentage.
    segSegment1.Begin.ValueType = chConstants.chBoundaryValuePercent
    segSegment1.End.ValueType = chConstants.chBoundaryValuePercent

    ' Set the beginning value to 0%, and the ending value to 100%.
    segSegment1.Begin.Value = 0
    segSegment1.End.Value = 1

    ' Format the interior of the matching values.
    segSegment1.Begin.Interior.Color = "White"
    segSegment1.End.Interior.Color = "Blue"

    segSegment1.HasDiscreteDivisions = True

    segSegment1.Divisions = 3

End Sub


DrawType 属性

返回一个 ChartDrawModesEnum 常量，指定执行绘图的途径。只读。

ChartDrawModesEnum 可以为下列 ChartDrawModesEnum 常量之一。
chDrawModeHitTest
chDrawModePaint
chDrawModeScale 不支持该属性。
chDrawModeSelection

expression.DrawType

expression 必需。该表达式返回一个 ChChartDraw 对象。


EditMode 属性

返回一个 PivotEditModeEnum 常量，指定数据透视表列表当前是否处于编辑模式。只读。

PivotEditModeEnum 可以为下列 PivotEditModeEnum 常量之一。
plEditInProgress
plEditNone

expression.EditMode

expression 必需。该表达式返回一个 PivotTable 对象。


ElementExtensions 属性

返回数据源控件的 ElementExtensions 对象。

expression.ElementExtensions

expression 必需。该表达式 返回一个 DataSourceControl 对象。


ElementID 属性

指定用于指定扩展的 HTML 元素 ID 标签。String 类型，只读。

expression.ElementID

expression 必需。该表达式 返回一个 ElementExtension 对象。


EnableAutoFilter 属性

如果指定工作表可以筛选，则返回 True。如果 Protection 的 Enabled 属性设置为 False 则该属性无效。Boolean 类型，可读写。

expression.EnableAutoFilter

expression 必需。该表达式返回一个 Worksheet 对象。

示例

本示例启用活动工作表的“自动筛选”，然后保护 Spreadsheet1 中的工作表。

Sub ProtectWorksheet_EnableAutoFilter
    Spreadsheet1.ActiveSheet.EnableAutoFilter = True
    Spreadsheet1.ActiveSheet.Protection.Enabled = True
End Sub


Enabled 属性

对于 OCCommand 对象：返回一个 Boolean 类型，表示是否启用指定命令。只读。

对于 Protection 对象：返回或设置一个 Boolean 类型，确定是否启用指定工作表的保护。将该属性设置为 True 可保护工作表。如果将该属性设置为 False，则忽略其他 Protection 对象属性设置。可读写。

expression.Enabled

expression 必需。该表达式返回一个 OCCommand 或 Protection 对象。

示例

本示例禁止用户在活动工作表中插入行。

Sub PreventInsertingRows()

   Dim pt

   Set pt = Spreadsheet1.ActiveSheet.Protection

   pt.AllowInsertingRows = False

   pt.Enabled = True

End Sub


EnableEvents 属性

如果启用了电子表格或图表工作区的事件，则返回 True。Boolean 类型，可读写。

expression.EnableEvents

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例禁止运行电子表格处理事件。

Spreadsheet1.EnableEvents = False


EnableResize 属性

如果用户可以调整电子表格控件大小，则返回 True。设置该属性为 False 可防止用户调整电子表格控件大小。默认值为 True。Boolean 类型，可读写。

expression.EnableResize

expression 必需。该表达式返回一个 Window 对象。

示例

本示例设置电子表格控件的高度和宽度，然后防止用户调整控件大小。

Sub Size_Spreadsheet()
   ' Set the height of the spreadsheet control.
   Spreadsheet1.Height = 4000

   ' Set the width of the spreadsheet control.
   Spreadsheet1.Width = 6000

   ' Prevent the user from resizing the spreadsheet control.
   Spreadsheet1.ActiveWindow.EnableResize = False
End Sub


EnableUndo 属性

如果启用了指定电子表格的撤消功能，则返回 True。将 EnableUndo 属性设置为 False 将禁用电子表格组件的撤消功能。Boolean 类型，可读写。

expression.EnableUndo

expression 必需。该表达式返回一个 Spreadsheet 对象。

示例

本示例创建一个撤消块，内含设置单元格 D10 数字格式和字体的代码。

Sub Undo_Block()
    Dim rngCurrent

    ' Enable undo.
    Spreadsheet1.EnableUndo = True

    ' Start an undo block.
    Spreadsheet1.BeginUndo

        Set rngCurrent = Spreadsheet1.Worksheets("sheet1").Range("D10")

        ' The following three lines of code apply
        ' various formatting to cell D10.
        rngCurrent.NumberFormat = "0.###"
        rngCurrent.Font.Color = "Blue"
        rngCurrent.Font.Name = "Times New Roman"

    ' End the undo block.
    Spreadsheet1.EndUndo
End Sub


End 属性

显示 End 属性应用于 Range 对象的情形。

返回一个 Range 对象，表示包含指定来源区域的区域结束单元格。使用该属性等效于按下 Ctrl+向上键、Ctrl+向下键、Ctrl+向左键或 Ctrl+向右键的组合键。

expression.End(Direction)

expression 必需。该表达式返回一个 Range 对象。

Direction XlDirection 类型，必需。移动的方向。

XlDirection 可以为下列 XlDirection 常量之一。
xlDown
xlToLeft
xlToRight
xlUp

显示 End 属性应用于 ChSegment 对象的情形。

返回一个 ChSegmentBoundary 对象，表示格式映射的段边界的结束值。

expression.End

expression 必需。该表达式返回一个 ChSegment 对象。

说明

使用返回的 ChSegmentBoundary 对象的 Value 属性设置格式映射中指定段的结束值。使用 Interior、Line 和 Border 属性设置段边界的格式。

示例

显示 应用于 Range 对象的情形。

本示例选定一个单元格区域：从活动单元格开始，向下延伸直到一个单元格为止。

Sub SelectContiguousCells()

    Dim ssConstants
    Dim rngStartCell

    Set ssConstants = Spreadsheet1.Constants

    Set rngStartCell = Spreadsheet1.ActiveCell

    Spreadsheet1.ActiveSheet.Range(rngStartCell, _
     rngStartCell.End(ssConstants.xlDown)).Select

End Sub

显示 应用于 ChSegment 对象的情形。

本示例将 Chartspace1 绑定到 SQL Server 罗斯文数据库中的 Order Details 表，然后创建格式映射，以红色突出显示低 10% 数值，以绿色突出显示高 20% 数值。

Sub Window_Onload()

    Dim serseries1
    Dim segBottom10Pct
    Dim segTop20Pct
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' The following two lines of code bind Chartspace1 to the Order Details table in the
    ' Northwind SQL Server database.
    ChartSpace1.ConnectionString = "Provider=SQLOLEDB.1;Persist Security Info=TRUE;" & _
                     "Integrated Security=SSPI;Initial Catalog=Northwind;" & _
                     "Data Source=DataServer;"
    ChartSpace1.DataMember = "Order Details"

    ' The following two lines of code bind Chartspace1 to the Quantity and ProductID fields
    ' in the Order details table.
    ChartSpace1.SetData chConstants.chDimCategories, chConstants.chDataBound, "ProductID"
    ChartSpace1.SetData chConstants.chDimValues, chConstants.chDataBound, "Quantity"

    ' Create a format map.
    ChartSpace1.SetData chConstants.chDimFormatValues, chConstants.chDataBound, "Quantity"

    ' Set a variable to the first series in the first chart in Chartspace1.
    Set serseries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a segment to the format map. This segment will
    ' represent the bottom 10% of values in the chart.
    Set segBottom10Pct = serseries1.FormatMap.Segments.Add

    ' Measure the segment boundaries based upon a percentage.
    segBottom10Pct.Begin.ValueType = chConstants.chBoundaryValuePercent
    segBottom10Pct.End.ValueType = chConstants.chBoundaryValuePercent

    ' Set the beginning value to 0%, and the ending value to 10%.
    segBottom10Pct.Begin.Value = 0
    segBottom10Pct.End.Value = 0.1

    ' Format the interior of the matching values.
    segBottom10Pct.Begin.Interior.Color = "red"
    segBottom10Pct.End.Interior.Color = "red"

    ' Add a segment to the format map. This segment will
    ' represent the top 20% of values in the chart.
    Set segTop20Pct = serseries1.FormatMap.Segments.Add

    ' Measure the segment boundaries based upon a percentage.
    segTop20Pct.Begin.ValueType = chConstants.chBoundaryValuePercent
    segTop20Pct.End.ValueType = chConstants.chBoundaryValuePercent

    ' Set the beginning value to 80%, and the ending value to 100%.
    segTop20Pct.Begin.Value = 0.8
    segTop20Pct.End.Value = 1

    ' Format the interior of the matching values.
    segTop20Pct.Begin.Interior.Color = "green"
    segTop20Pct.End.Interior.Color = "green"

End Sub


EndStyle 属性

返回或设置误差线的结束样式。ChartEndStyleEnum 类型，可读写。

ChartEndStyleEnum 可为以下 ChartEndStyleEnum 常量之一：
chEndStyleCap 默认
chEndStyleNone

expression.EndStyle

expression 必需。该表达式返回一个 ChErrorBars 对象。

示例

本示例在 ChartSpace1 中第一个图表的所有系列中添加误差线，然后设置误差量和结束样式。

Sub Add_Error_Bars()
    Dim ebErrorBars
    Dim serChartSeries
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Loop through all of the series in the first chart
    ' in ChartSpace1.
    For Each serChartSeries in ChartSpace1.Charts(0).SeriesCollection

        ' Add error bars to the current series.
        Set ebErrorBars = serChartSeries.ErrorBarsCollection.Add

        ' Set the error bars to be a percentage of the value.
        eberrorBars.Type = chConstants.chErrorBarTypePercent

        ' Set the percentage amount.
        ebErrorBars.Amount = 0.05

        ' Set the end style of the error bars.
        ebErrorBars.EndStyle = chConstants.chEndStyleNone
    Next
End Sub


EntireColumn 属性

返回代表包含指定区域的整列的 Range 对象。只读。

expression.EntireColumn

expression 必需。该表达式返回一个 Range 对象。

示例

本示例为包含活动单元格的整列内容设置字体颜色。

Spreadsheet1.ActiveCell.EntireColumn.Font.Color = "green"


EntireRow 属性

返回代表包含指定区域的整行（或多行）的 Range 对象。只读。

expression.EntireRow

expression 必需。该表达式返回一个 Range 对象。

示例

本示例为包含活动单元格的整行内容设置字体颜色。

Spreadsheet1.ActiveCell.EntireRow.Font.Color = "red"


Error 属性

返回包含有关指定事件错误信息的 ADO Error 对象。只读。

expression.Error

expression 必需。该表达式返回一个 DSCEventInfo 对象。


ErrorBarsCollection 属性

返回 ChErrorBarsCollection 集合，其中包含的一个 ChErrorBars 对象对应于指定系列中的每组误差线 。一个系列只能有一组误差线，因此 ChErrorBarsCollection 集合从来不会包含多个对象。只读。

expression.ErrorBarsCollection

expression 必需。该表达式返回一个 ChSeries 对象。

示例

本示例在 ChartSpace1 中第一个图表的所有系列中添加误差线，然后设置误差量和结束样式。

Sub Add_Error_Bars()
    Dim ebErrorBars
    Dim serChartSeries
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Loop through all of the series in the first chart
    ' in ChartSpace1.
    For Each serChartSeries in ChartSpace1.Charts(0).SeriesCollection

        ' Add error bars to the current series.
        Set ebErrorBars = serChartSeries.ErrorBarsCollection.Add

        ' Set the error bars to be a percentage of the value.
        eberrorBars.Type = chConstants.chErrorBarTypePercent

        ' Set the percentage amount.
        ebErrorBars.Amount = 0.05

        ' Set the end style of the error bars.
        ebErrorBars.EndStyle = chConstants.chEndStyleNone
    Next
End Sub


ExcludedMembers 属性

返回或设置指定字段中不希望显示的成员。该属性可以设置为单个成员或成员的 Variant 数组。成员可以一个或多个 PivotMember 对象、成员名称或唯一名称传递。

expression.ExcludedMembers

expression 必需。该表达式返回一个 PivotField 对象。

说明

如果包括了显式排除的成员的一个或多个子成员，则该成员仍将显示在数据透视表列表中。设置该属性可清除以前对指定字段的所有设置。可以将 ExcludedMembers 属性设置为 Empty (ExcludedMembers = Empty) 或空 Variant 数组 (ExcludedMembers = Array()) 以清除指定字段包含的成员列表。

示例

本示例设置 PivotTable1 中 Store State 和 Store City 字段的包括和排除成员。

Sub Member_Filtering()

    Dim fldStoreCity
    Dim fldStoreState
    Dim ptView

    ' Set a variable to the current PivotTable view.
    Set ptView = PivotTable1.ActiveView

    ' Set a variable to the Store State field.
    Set fldStoreState = ptView.FieldSets("Store").Fields("Store State")

    ' Set a variable to the Store City field.
    Set fldStoreCity = ptView.FieldSets("Store").Fields("Store City")

    ' Exclude California and Washington from the Store State field.
    fldStoreState.ExcludedMembers = Array("CA", "WA")

    ' Include members of the Store City field. Note that the cities are
    ' in states that have been excluded by the previous line. Since
    ' Store State is a parent to Store City, then the excluded states
    ' are displayed in the PivotTable.
    fldStoreCity.IncludedMembers = Array("Los Angeles", "San Diego", _
                                         "Seattle", "Spokane")

End Sub


ExpandDetails 属性

返回或设置一个 PivotTableExpandEnum 常量，表示将字段添加到数据透视表列表的明细区域中时是否展开。可读写。

PivotTableExpandEnum 可以为下列 PivotTableExpandEnum 常量之一。
plExpandAlways 将字段添加到数据透视表列表的明细区域中时总是展开。该设置并不禁止用户在字段添加到数据透视表列表后折叠字段。
plExpandAutomatic 默认值 对于关系数据源，字段及其成员展开。对于多维数据源，字段及其成员不展开。
plExpandNever 字段添加到数据透视表列表的明细区域中从不展开。该设置并不禁止用户在将字段添加到数据透视表列表后展开字段。

expression.ExpandDetails

expression 必需。该表达式返回一个 PivotView 对象。

示例

本示例设置 PivotTable1 使字段添加到数据透视表列表后从不展开。

Sub NeverExpand()
    Dim pvtView
    Dim ptConstants

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view.
    Set pvtView = PivotTable1.ActiveView

    ' Always expand fields when they are added
    ' to a PivotTable list.
    pvtView.ExpandMembers = ptConstants.plExpandNever

    ' Always expand fields when they are added
    ' to the detail area PivotTable list.
    pvtView.ExpandDetails = ptConstants.plExpandNever
End Sub


Expanded 属性

对于 PivotCell 对象：如果显示了指定单元格的明细网格，则返回 True。如果将该属性设置为 False，将不显示明细网格而显示聚合（如果可用）。Boolean 类型，可读写。

对于 PivotAxisMember 对象：如果显示指定成员的子成员，则返回 True；如果折叠子成员，则返回 False。Boolean 类型，可读写。

对于 PivotField 对象：同时返回或设置指定字段的所有成员的展开状态。设置字段的 Expanded 属性将立即设置该字段相关成员的 Expanded 属性。设置字段单个成员的 Expanded 属性不影响字段本身的 Expanded 属性。Boolean 类型，可读写。

expression.Expanded

expression 必需。该表达式返回“应用于”列表中的对象之一。


ExpandedByDefault 属性

如果指定组级别在默认情况下为展开状态，则返回 True。默认值为 False。Boolean 类型，可读写。

expression.ExpandedByDefault

expression 必需。该表达式返回一个 GroupLevel 对象。


ExpandMembers 属性

返回或设置一个 PivotTableExpandEnum 常量，表示将字段添加到数据透视表列表时是否展开字段及其成员。可读写。

PivotTableExpandEnum 可以为下列 PivotTableExpandEnum 常量之一。
plExpandAlways 字段及其成员在添加到数据透视表列表中时总是展开。该设置并不禁止用户在字段添加到数据透视表列表后折叠字段。
plExpandAutomatic 默认值 对于关系数据源，字段及其成员展开。对于多维数据源，字段及其成员不展开。
plExpandNever 字段及其成员在添加到数据透视表列表中时从不展开。该设置并不禁止用户在将字段添加到数据透视表列表后展开字段。

expression.ExpandMembers

expression 必需。该表达式返回一个 PivotView 对象。

示例

本示例设置 PivotTable1 使字段添加到数据透视表列表后从不展开。

Sub NeverExpand()
    Dim pvtView
    Dim ptConstants

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view.
    Set pvtView = PivotTable1.ActiveView

    ' Always expand fields when they are added
    ' to a PivotTable list.
    pvtView.ExpandMembers = ptConstants.plExpandNever

    ' Always expand fields when they are added
    ' to the detail area PivotTable list.
    pvtView.ExpandDetails = ptConstants.plExpandNever
End Sub


Explosion 属性

显示 Explosion 属性应用于 ChPoint 对象的情形。

返回或设置指定饼图或圆环图扇面的分离程度值。有效范围为 0 到 1000。分离程度值等于图表半径的百分比。请注意设置该属性为 100 将使扇面尖端移至距离图表中心等于图表半径的位置。使用该属性可突出特定扇面。Long 类型，可读写。

expression.Explosion

expression 必需。该表达式返回一个 ChPoint 对象。

显示 Explosion 属性应用于 ChSeries 对象的情形。

返回或设置指定饼图或圆环图系列的分离程度值。有效范围为 0 到 1000。分离程度值等于图表半径的百分比。请注意设置该属性为 100 将使扇面尖端移至距离图表中心等于图表半径的位置。Long 类型，可读写。

expression.Explosion

expression 必需。该表达式返回一个 ChSeries 对象。

示例

显示 应用于 ChPoint 对象的情形。

本示例将指定系列的第三点的尖端移动十分之一图表半径的距离。

ChartSpace1.Charts(0).SeriesCollection(0).Points(2).Explosion = 10

显示 应用于 ChSeries 对象的情形。

本示例将指定系列中饼图或圆环图的扇面尖端移动十分之一图表半径的距离。

ChartSpace1.Charts(0).SeriesCollection(0).Explosion = 10


Expression 属性

返回或设置一个 String 类型，表示用于计算指定计算字段或计算总计的表达式。该表达式必须与 Jet 表达式服务兼容。可读写。

expression.Expression

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

如果不用于计算字段或计算总计，Expression 属性将返回空字符串。

示例

下面示例显示 PivotTable1 中计算字段 Variance 当前使用的表达式。在编辑了表达式并单击“确定”后，新的表达式将赋予 Variance 字段。

Sub Change_Expression()

    Dim vwView
    Dim cfCalcField
    Dim strCurrentExpression
    Dim strNewExpression

    Set vwView = PivotTable1.ActiveView

    ' Set a varible to the calculated field.
    Set cfCalcField = _
        vwView.Fieldsets("Variance").Fields("Variance")

    ' Set a variable to the current expression used in the
    ' Variance field.
    strCurrentExpression = cfCalcField.Expression

    ' Display an input box that contains the current expression for the
    ' Variance field. Edit the expression and then click OK.
    strNewExpression = InputBox("Edit the expression used for the calculated" & _
        "field and then click OK.", , strCurrentExpression)

    ' Set the expression used to calculate the Variance field to the
    ' expression entered in the input box.
    cfCalcField.Expression  = strNewExpression

End Sub


ExtrudeAngle 属性

返回或设置一个 Double 类型，指定三维图表的延伸方向。该属性仅在图表的 ProjectionMode 属性设置为 chProjectionModeOrthographic 时有效。有效值范围为 0 到 360。默认值为 45。可读写。

expression.ExtrudeAngle

expression 必需。该表达式返回一个 ChChart 对象。

示例

本示例将 Chartspace1 中的第一个图表转换为三维柱形图，然后设置图表的投影模式。

Sub SetExtrudeAngle()

    Dim cht3DColumn
    Dim chConstants

    Set chConstants = Chartspace1.Constants

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DColumn = ChartSpace1.Charts(0)

    ' Change the chart to a 3-D Column chart.
    cht3DColumn.Type = chChartTypeColumnClustered3D

    ' Set the projection mode to orthographic.
    cht3DColumn.ProjectionMode = chConstants.chProjectionModeOrthographic

    ' Set the extrusion angle.
    cht3DColumn.ExtrudeAngle = 75

End Sub


Field 属性

返回一个 PivotField 对象，表示与指定成员或总计相关的字段。

expression.Field

expression 必需。该表达式返回“应用于”列表中的对象之一。


FieldLabelBackColor 属性

返回或设置背景色，该背景色用于行、列和筛选的字段标志。默认值为 25% 灰色。Variant 类型，可读写。

expression.FieldLabelBackColor

expression 必需。该表达式返回一个 PivotView 对象。

说明

当设置该属性时，可使用 Long 类型值代表红绿蓝体系的颜色值或 String 类型值命名一种有效的 HTML 颜色。例如，如果要将对象设置为红色，可使用十六进制值 &HFF，十进制值 255 或字符串值“red”。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝体系的颜色值。（红色为 RGB(255,0,0)）。

该属性总是返回 Long 类型值，该值代表一种红绿蓝体系的颜色值。


FieldLabelFont 属性

返回 PivotFont 对象，该对象代表行、列和筛选的字段标志。只读。

expression.FieldLabelFont

expression 必需。该表达式返回一个 PivotView 对象。


FieldLabelForeColor 属性

返回或设置前景色，该前景色用于行、列和筛选的字段标志。默认值为 25% 灰色。Variant 类型，可读写。

expression.FieldLabelForeColor

expression 必需。该表达式返回一个 PivotView 对象。

说明

当设置该属性时，可使用 Long 类型值代表红绿蓝体系的颜色值或 String 类型值命名一种有效的 HTML 颜色。例如，如果要将对象设置为红色，可使用十六进制值 &HFF，十进制值 255 或字符串值“red”。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝体系的颜色值。（红色为 RGB(255,0,0)）。

该属性总是返回 Long 类型值，该值代表一种红绿蓝体系的颜色值。


FieldLabelHeight 属性

返回行、列和筛选的字段标志的高度。Long 类型，只读。

expression.FieldLabelHeight

expression 必需。该表达式返回一个 PivotView 对象。


Fields 属性

返回指定字段集的 PivotFields 集合。

expression.Fields

expression 必需。该表达式返回“应用于”列表中的对象之一。


FieldSet 属性

返回表示指定字段所属字段集的一个 PivotFieldSet 对象。

expression.FieldSet

expression 必需。该表达式 返回一个 PivotField 对象。


FieldSets 属性

返回一个 PivotFieldSets 对象，其中包含与指定坐标轴或视图相关的字段集。

expression.FieldSets

expression 必需。该表达式返回“应用于”列表中的对象之一。


FieldType 属性

返回指定字段的字段类型。DscFieldTypeEnum 类型，只读。

DscFieldTypeEnum 可为以下 DscFieldTypeEnum 常量之一：
dscCalculated
dscGrouping
dscOutput
dscParameter

expression.FieldType

expression 必需。该表达式 返回一个 PageField 属性。


FillType 属性

返回表示用于指定 ChInterior 对象的填充类型的 ChartFillTypeEnum 常量。只读。

ChartFillTypeEnum 可以为下列 ChartFillTypeEnum 常量之一。
chFillGradientOneColor
chFillGradientPresetColors
chFillGradientTwoColors
chFillPatterned
chFillSolid
chFillTexturePreset
chFillTextureUserDefined

expression.FillType

expression 必需。该表达式返回一个 ChInterior 对象。

说明

可以使用下列方法设置 ChInterior 对象的填充类型：SetOneColorGradient、SetPatterned、SetPresetGradient、SetSolid、SetTextured 和 SetTwoColorGradient。


Filter 属性

返回数据访问页所对应记录集的 ADO 筛选字符串。Variant 类型，可读写。

expression.Filter

expression 必需。该表达式 返回一个 DataPage 对象。


FilterAxis 属性

对于 PivotData 对象：返回一个表示筛选坐标轴的 PivotResultFilterAxis 对象。

对于 PivotView 对象：返回一个表示筛选坐标轴的 PivotFilterAxis 对象。

expression.FilterAxis

expression 必需。该表达式返回一个 PivotData 或 PivotView 对象。


FilterCaption 属性

返回一个 String 类型，表示筛选坐标轴上字段集下面显示的标题。只读。

expression.FilterCaption

expression 必需。该表达式返回一个 PivotFieldSet 对象。

说明

如果用户只选定了指定字段中的一项，则该属性返回该项。如果用户选定了字段中的多项，则该属性很可能返回 "(Multiple Items)"。


FilterContext 属性

返回一个 PivotField 对象，表示条件筛选评估的上下文。

expression.FilterContext

expression 必需。该表达式返回一个 PivotField 对象。

说明

将条件筛选应用于字段时，筛选可应用于字段或该字段在字段集中的父字段之一。例如，假定数据透视表列表中包含名为 Store 的字段集。Store 字段集包含下列字段：Country、Region、City 和 Store Number。Country 字段为 Region 字段的父字段，Region 字段为 City 字段的父字段，而 City field 字段为 Store Number 字段的父字段。

现在要查找前五名经济发展良好的城市。如果设置 City 字段的该属性，将在数据透视表列表上显示前五名经济发展良好的城市。如果设置 Region 字段的该属性，将返回每个地区的前五名城市。

为应用条件筛选的字段的子字段设置该属性将导致运行时出错。例如，在 City 字段应用条件筛选时，不能设置 Store Number 的该属性。

示例

本示例显示每个州经济发展最差的城市。

Sub LeastProfitableByState()

    Dim ptView
    Dim ptConstants
    Dim fldFilterField

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable list.
    Set ptView = PivotTable1.ActiveView

    ' Set a variable to the field that is to be filtered.
    Set fldFilterField = PivotTable1.ActiveData.RowAxis.Fields("Store City")

    ' Filter the stores based on profit.
    Set fldFilterField.FilterOn = ptView.Totals("Profit")

    ' Set the function used to filter the stores.
    fldFilterField.FilterFunction = ptConstants.plFilterFunctionBottomCount

    ' Display the least profitable store.
    fldFilterField.FilterFunctionValue = 1

    ' Set the context of the filter. Although we are filtering based on
    ' the Store City field, setting the filter context to the Store State
    ' field means that the least profitable store from each state will be
    ' displayed.
    Set ptView.FieldSets("Store").Fields("Store City").FilterContext = _
               ptView.FieldSets("Store").Fields("Store State")

End Sub


FilterCrossJoins 属性

返回或设置一个 Boolean 类型，确定数据透视表控件在为当前视图检索数据时如何处理空成员。默认值为 True。可读写。

expression.FilterCrossJoins

expression 必需。该表达式返回一个 PivotView 对象。

说明

大部分情况下，不希望将该属性设置为 False。但是，如果 OLAP 多维数据集包含顶层成员为空的字段集，则可能希望将该属性设置为 False。


FilterFunction 属性

显示 FilterFunction 属性应用于 PivotField 对象的情形。

返回或设置指定字段的筛选函数。PivotFieldFilterFunctionEnum 类型，可读写。

PivotFieldFilterFunctionEnum 可为以下 PivotFieldFilterFunctionEnum 常量之一：
plFilterFunctionBottomCount
plFilterFunctionBottomPercent
plFilterFunctionBottomSum
plFilterFunctionExpression
plFilterFunctionMemberSet
plFilterFunctionNone
plFilterFunctionTopCount
plFilterFunctionTopPercent
plFilterFunctionTopSum

expression.FilterFunction

expression 必需。该表达式返回一个 PivotField 对象。

显示 FilterFunction 属性应用于 Criteria 对象的情形。

返回或设置“自动筛选”使用指定条件的方式。如果该属性设置为 ssFilterFunctionInclude，则指定项将显示在筛选列表中，并且删除其他所有项。如果该属性设置为 ssFilterFunctionExclude，则将从筛选列表中删除指定项并显示所有其他项。SheetFilterFunction 类型，可读写。

SheetFilterFunction 可为以下 SheetFilterFunction 常量之一：
ssFilterFunctionExclude
ssFilterFunctionInclude

expression.FilterFunction

expression 必需。该表达式返回一个 Criteria 对象。


FilterFunctionValue 属性

返回或设置一个 Variant 类型，表示用于筛选字段的值。数值的类型将根据 FilterFunction 属性的当前设置而变。请使用下表为该属性确定相应的数值。可读写。

FilterFunction 设置 | 相应的数值范围
plFilterFunctionBottomCount | Integer 类型，表示要显示底层成员数量。
plFilterFunctionBottomPercent | Double 类型，范围为 0 到 1，表示要显示的底层成员百分比。
plFilterFunctionBottomSum |
plFIlterFunctionNone |
plFilterFunctionTopCount | Integer 类型，表示要显示的顶层成员数量。
plFilterFunctionTopPercent | Double 类型，范围为 0 到 1，表示要显示的顶层成员百分比。
plFilterFunctionTopSum |

expression.FilterFunctionValue

expression 必需。该表达式返回一个 PivotField 对象。

示例

本示例在基于 Profit 总计的 Store City 字段上应用条件筛选，并显示经济发展最好的前三名商店。

Sub TopThreeStores()

    Dim ptView
    Dim ptConstants
    Dim fldFilterField

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable list.
    Set ptView = PivotTable1.ActiveView

    ' Set a variable to the field that is to be filtered.
    Set fldFilterField = PivotTable1.ActiveData.RowAxis.Fields("Store City")

    ' Filter the stores based on profit.
    Set fldFilterField.FilterOn = ptView.Totals("Profit")

    ' Set the function used to filter the stores.
    fldFilterField.FilterFunction = ptConstants.plFilterFunctionTopCount

    ' Display the three most profitable stores.
    fldFilterField.FilterFunctionValue = 3

End Sub


FilterMode 属性

如果“自动筛选”条件当前隐藏了工作表行，则返回 True。默认值为 False。Boolean 类型，只读。

expression.FilterMode

expression 必需。该表达式返回 Worksheet 对象。

说明

如果显示了“自动筛选”下拉箭头，但当前没有筛选任何行（即所有行均可见），则 AutoFilterMode 属性为 True 并且 FilterMode 属性为 False。

示例

本示例打开区域 A1:C20 的“自动筛选”，设置列 A 和 C 的筛选，然后应用筛选。FilterMode 属性将返回 False，直到“自动筛选”条件应用于列表。

Sub Apply_AutoFilter()
    Dim afFilters
    Dim afCol1
    Dim afCol3

    ' Turn on AutoFilter.
    Spreadsheet1.Worksheets("Sheet1").Range("A1:C20").AutoFilter

    ' Set a variable to the AutoFilter object.
    Set afFilters = Spreadsheet1.Worksheets("sheet1").AutoFilter

    Set afCol1 = afFilters.Filters(1)
    Set afCol3 = afFilters.Filters(3)

    ' Add a criteria that excludes blue from column A.
    afCol1.Criteria.Add "blue"

    ' Add a criteria that excludes green from column A.
    afCol1.Criteria.Add "green"

    ' Add a criteria that excludes yellow from column c.
    afCol3.Criteria.Add "yellow"

    ' At this point, the FilterMode property is False
    ' because the AutoFilter criteria has not been applied.
    MsgBox Spreadsheet1.Worksheets("Sheet1").FilterMode

    ' Apply the criteria.
    afFilters.Apply

    ' The FilterMode property is now True since you
    ' have hidden several rows in the list.
    MsgBox Spreadsheet1.Worksheets("Sheet1").FilterMode
End Sub


FilterOn 属性

返回一个 PivotTotal 对象，表示对字段进行条件筛选时所用的总计。

expression.FilterOn

expression 必需。该表达式返回一个 PivotField 对象。

示例

本示例在基于 Profit 总计的 Store City 字段上应用条件筛选，并显示经济发展最好的前三名商店。

Sub TopThreeStores()

    Dim ptView
    Dim ptConstants
    Dim fldFilterField

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable list.
    Set ptView = PivotTable1.ActiveView

    ' Set a variable to the field that is to be filtered.
    Set fldFilterField = PivotTable1.ActiveData.RowAxis.Fields("Store City")

    ' Filter the stores based on profit.
    Set fldFilterField.FilterOn = ptView.Totals("Profit")

    ' Set the function used to filter the stores.
    fldFilterField.FilterFunction = ptConstants.plFilterFunctionTopCount

    ' Display the three most profitable stores.
    fldFilterField.FilterFunctionValue = 3

End Sub


FilterOnScope 属性

该属性建立对字段进行条件筛选时的范围。可以传递包含成员唯一名称或数组的 String 类型。返回一个包含 PivotMember 对象的 Variant 数组。可读写。

expression.FilterOnScope

expression 必需。该表达式返回一个 PivotField 对象。

说明

该范围基于筛选字段之外的其他字段的一个或多个成员。例如，可能要对添加到数据透视表列表行坐标轴的 Customer 字段应用筛选，显示购买额最多的前三名客户。要完成上述操作，将 FilterFunction 属性设置为 plFilterFunctionTopCount，FilterFunctionValue 属性设置为 3，FilterOn 属性设置为 Total Sales 总计。数据透视表列表将显示三名最好的客户。

如果需要将查询范围缩小为更特定的客户集合，则需要使用 FilterOnScope 属性。如果要查看 Southeast 地区的前面客户，则需要将 FilterOnScope 属性设置为表示 Region 字段中 Southeast 成员的表达式。

示例

本示例显示在加拿大销售业绩最好的两种产品。

Sub DisplayTopTwoCanadianSellers()

    Dim objPivotView
    Dim objPivotData
    Dim fldProductName

    ' Set a variable to the active view of the PivotTable.
    Set objPivotView = PivotTable1.ActiveView

    ' Set a variable to the active data of the PivotTable.
    Set objPivotData = PivotTable1.ActiveData

    ' Set a variable to the Product Name field, which has been
    ' added to the row axis of the PivotTable list.
    Set fldProductName = objPivotData.RowAxis.Fields("Product Name")

    ' The following two lines of code set the PivotTable list to filter for the
    ' top 2 items.
    fldProductName.FilterFunction = PivotTable1.Constants.plFilterFunctionTopCount
    fldProductName.FilterFunctionValue = 2

    ' Filter based on the Unit Sales total.
    Set fldProductName.FilterOn = objPivotView.Totals("Unit Sales")

    ' Set the filter scope to include only sales in Canada.
    fldProductName.FilterOnScope = objPivotView.FieldSets("Store").Member.ChildMembers("Canada").UniqueName

End Sub


Filters 属性

返回指定“自动筛选”的 Filters 集合。筛选区域的每一列均在 Filters 集合中包含一个 Filter 对象。只读。

expression.Filters

expression 必需。该表达式返回一个 AutoFilter 对象。

示例

本示例打开 A1:C20 区域内的“自动筛选”，为 A 列和 C 列设置筛选，然后应用这些筛选。

Sub Apply_AutoFilter()
    Dim afFilters
    Dim afCol1
    Dim afCol3

    ' Turn on AutoFilter.
    Spreadsheet1.Worksheets("Sheet1").Range("A1:C20").AutoFilter

    ' Set a variable to the AutoFilter object.
    Set afFilters = Spreadsheet1.Worksheets("sheet1").AutoFilter

    Set afCol1 = afFilters.Filters(1)
    Set afCol3 = afFilters.Filters(3)

    ' Add a criteria that excludes blue from column A.
    afCol1.Criteria.Add "blue"

    ' Add a criteria that excludes green from column A.
    afCol1.Criteria.Add "green"

    ' Add a criteria that excludes yellow from column c.
    afCol3.Criteria.Add "yellow"

    ' Apply the criteria.
    afFilters.Apply
End Sub


FindAxisMember 属性

根据给定的成员引用查找坐标轴成员。返回一个 PivotAxisMember 对象。

expression.FindAxisMember(Path, Format)

expression 必需。该表达式返回一个 PivotAxisMember 对象。

Path String 类型，必需。变量或字符串，包含要查找的成员的引用。

Format PivotMemberFindFormatEnum 类型，必需。指定 Path 参数使用的格式。

PivotMemberFindFormatEnum 可以为下列 PivotMemberFindFormatEnum 常量之一。
plFindFormatMember 不支持该属性。
plFindFormatPathHex 不支持该属性。
plFindFormatPathInt 成员引用为索引路径。例如，"1\0\5\1"。
plFindFormatPathName 成员引用为唯一名称或名称（如果确定）。例如，"[USA].[Oregon].[Portland]"。

说明

如果没有找到请求的成员，将返回 IsValid 属性设置为 False 的 PivotAxisMember 对象。这使得可以引用稍后添加到方案的成员。

该属性可用于从指定坐标轴的顶层成员中查找成员。使用 Member 属性 (PivotAxisMember.Axis.Member) 可返回坐标轴的顶层成员。


FindColumnMember 属性

根据给定的成员引用查找列成员。返回一个 PivotColumnMember 对象。

expression.FindColumnMember(Path, Format)

expression 必需。该表达式返回一个 PivotColumnMember 对象。

Path String 类型，必需。变量或字符串，包含要查找的成员的引用。

Format PivotMemberFindFormatEnum 类型，必需。指定 Path 参数使用的格式。

PivotMemberFindFormatEnum 可以为下列 PivotMemberFindFormatEnum 常量之一。
plFindFormatMember 不支持该属性。
plFindFormatPathHex 不支持该属性。
plFindFormatPathInt 成员引用为索引路径。例如，"1\0\5\1"。
plFindFormatPathName 成员引用为唯一名称或名称（如果确定）。例如，"[USA].[Oregon].[Portland]"。

说明

如果没有找到请求的成员，将返回 IsValid 属性设置为 False 的 PivotColumnMember 对象。这使得可以引用稍后添加到方案的成员。

该属性可用于从列坐标轴的顶层成员中查找成员。使用 Member 属性返回列坐标轴的顶层成员。


FindMember 属性

显示 FindMember 属性应用于 PivotFieldSet 对象的情形。

根据给定的成员引用查找成员。返回一个 PivotMember 对象。

expression.FindMember(NameOrPath, Format)

expression 必需。该表达式返回一个 PivotFieldSet 对象。

NameOrPath Variant 类型，必需。变量或字符串，包含要查找的成员的引用。

Format PivotMemberFindFormatEnum 类型，可选。指定 Path 参数使用的格式。

PivotMemberFindFormatEnum 可以为下列 PivotMemberFindFormatEnum 常量之一。
plFindFormatMember 不支持该属性。
plFindFormatPathHex 不支持该属性。
plFindFormatPathInt 不支持该属性。
plFindFormatPathName 成员引用为唯一名称或名称（如果确定）。例如，"[USA].[Oregon].[Portland]"。

显示 FindMember 属性应用于 PivotAxisMember、PivotColumnMember、PivotMember、PivotPageMember 和 PivotRowMember 对象的情形。

根据给定的成员引用查找成员。返回一个 PivotMember 对象。

expression.FindMember(Path, Format)

expression 必需。该表达式返回上面对象之一。

Path String 类型，必需。变量或字符串，包含要查找的成员的引用。

Format PivotMemberFindFormatEnum 类型，必需。指定 Path 参数使用的格式。

PivotMemberFindFormatEnum 可以为下列 PivotMemberFindFormatEnum 常量之一。
plFindFormatMember 不支持该属性。
plFindFormatPathHex 不支持该属性。
plFindFormatPathInt 成员引用为路径索引。例如，"1\0\5\1"。
plFindFormatPathName 成员引用为唯一名称或名称（如果确定）。例如，"[USA].[Oregon].[Portland]"。

说明

如果没有找到请求的成员，将返回 IsValid 属性设置为 False 的 PivotMember 对象。这使得可以引用稍后添加到方案的成员。

示例

本示例试图在 Warehouse 字段集中查找指定仓库。如果没有找到指定仓库，将警告用户。

Sub FindWarehouse()

    Dim ptView
    Dim ptConstants
    Dim fsWarehouse
    Dim pmFound

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view.
    Set ptView = PivotTable1.ActiveView

    ' Set a variable to the Warehouse field set.
    Set fsWarehouse = ptView.FieldSets("Warehouse")

    ' Set a variable to the results of the FindMember property.
    Set pmFound = fsWarehouse.FindMember("Quality Distribution, Inc.", ptConstants.plFindFormatMember)

    ' Check to see if the member was found.
    If pmFound.IsValid = False Then

        ' Alert the user if the member was not found.
        MsgBox "The specified member does not exist."

    End If

End Sub


FindPageMember 属性

根据给定的成员引用查找页成员。返回一个 PivotPageMember 对象。

expression.FindPageMember(Path, Format)

expression 必需。该表达式返回一个 PivotPageMember 对象。

Path String 类型，必需。变量或字符串，包含要查找的成员的引用。

Format PivotMemberFindFormatEnum 类型，必需。指定 Path 参数使用的格式。

PivotMemberFindFormatEnum 可以为下列 PivotMemberFindFormatEnum 常量之一。
plFindFormatMember 不支持该属性。
plFindFormatPathHex 不支持该属性。
plFindFormatPathInt 成员引用为索引路径。例如，"1\0\5\1"。
plFindFormatPathName 成员引用为唯一名称或名称（如果确定）。例如，"[USA].[Oregon].[Portland]"。

说明

如果没有找到请求的成员，将返回 IsValid 属性设置为 False 的 PivotPageMember 对象。这使得可以引用稍后添加到方案的成员。

该属性可用于从指定页坐标轴的顶层成员中查找成员。使用 Member 属性返回页坐标轴的顶层成员。


FindRowMember 属性

根据给定的成员引用查找行成员。返回一个 PivotRowMember 对象。

expression.FindRowMember(Path, Format)

expression 必需。该表达式返回一个 PivotRowMember 对象。

Path String 类型，必需。变量或字符串，包含要查找的成员的引用。

Format PivotMemberFindFormatEnum 类型，必需。指定 Path 参数使用的格式。

PivotMemberFindFormatEnum 可以为下列 PivotMemberFindFormatEnum 常量之一。
plFindFormatMember 成员引用为命名的路径。例如，"USA\Oregon\Portland"。
plFindFormatPathHex 成员引用为十六进制索引的路径。
plFindFormatPathInt 成员引用为索引路径。例如，"1\0\5\1"。
plFindFormatPathName 成员引用为唯一名称或名称（如果确定）。例如，"[USA].[Oregon].[Portland]"。

说明

如果没有找到请求的成员，将返回 IsValid 属性设置为 False 的 PivotRowMember 对象。这使得可以引用稍后添加到方案的成员。


FirstSection 属性

返回表示指定数据访问页上第一节的 Section 对象。只读。

expression.FirstSection

expression 必需。该表达式返回一个 DataPage 对象。


FirstSliceAngle 属性

以度为单位（从垂直轴开始，沿顺时针方向）返回或设置饼图或圆环图的第一扇区起始角度。只应用于饼图或圆环图。Long 类型，可读写。

expression.FirstSliceAngle

expression 必需。该表达式返回一个 ChChart 对象。

示例

本示例将饼图或圆环图的第一扇区起始角度设置为 45 度。Charts(0) 必须为饼图或圆环图。

ChartSpace1.Charts(0).FirstSliceAngle = 45


Floor 属性

返回表示三维图表基底的 ChSurface 对象。使用返回的 ChSurface 对象的属性和方法设置指定图表的基底格式。

expression.Floor

expression 必需。该表达式返回一个 ChPlotArea 对象。

示例

本示例将 Chartspace1 中的第一个图表转换为三维柱形图，然后设置图表的背景墙纸、侧面墙纸和基底格式。

Sub FormatWallsFloor()

    Dim cht3DColumn
    Dim chConstants
    Dim paPlotArea

    Set chConstants = Chartspace1.Constants

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DColumn = ChartSpace1.Charts(0)

    ' Change the chart to a 3D Column chart.
    cht3DColumn.Type = chConstants.chChartTypeColumnClustered3D

    ' Set a variable to the plot area.
    Set paPlotArea = cht3DColumn.PlotArea

    ' Format the back wall of the chart.
    paPlotArea.BackWall.Interior.SetSolid "Yellow"
    paPlotArea.BackWall.Thickness = 5

    ' Format the side wall of the chart.
    paPlotArea.SideWall.Interior.SetSolid "Yellow"
    paPlotArea.SideWall.Thickness = 5

    ' Format the floor of the chart.
    paPlotArea.Floor.Interior.SetSolid "Blue"
    paPlotArea.Floor.Thickness = 5

End Sub


Font 属性

返回表示指定对象字体的一个 ChFont、Font 或 PivotFont 对象（返回的对象类型取决于应用该属性的对象）。

expression.Font

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例设置活动单元格的数字格式。

Sub SetFont()

   Dim rngCurrentCell

   Set rngCurrentCell = Spreadsheet1.ActiveCell

   rngCurrentCell.NumberFormat = "0.###"

   rngCurrentCell.Font.Color = "Blue"

   rngCurrentCell.Font.Name = "Times New Roman"

End Sub


FontName 属性

返回或设置指定 RecordNavigationControl 对象的字体名称。String 类型，可读写。

expression.FontName

expression 必需。该表达式返回一个 RecordNavigationControl 对象。

示例

本示例设置控件 RNC1 的字体名称为“Courier New”。

RNC1.FontName = "Courier New"


ForeColor 属性

返回或设置指定对象或区域的前景色。当设置该属性时，可使用 Long 类型值代表红绿蓝体系的颜色值或 String 类型值命名一种有效的 HTML 颜色。例如，如果要将对象设置为红色，可使用十六进制值 &HFF，十进制值 255 或字符串值“red”。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建 RGB 颜色值。（红色为 RGB(255,0,0)）。Variant 类型，可读写。

expression.ForeColor

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

该属性总是返回 Long 类型值，该值代表一种 RGB 颜色值。

示例

本示例设置 PivotTable1 的字体大小、前景色和背景色。

Sub Format_Titlebar()
    Dim vwView

    Set vwView = PivotTable1.ActiveView

    ' Set the background color of the title bar.
    vwView.Label.BackColor = "DarkSalmon"

    ' Set the font size of the title bar.
    vwView.Label.Font.Size = 16

    ' Set the foreground color of the title bar.
    vwView.Label.ForeColor = "Sienna"
End Sub


Format 属性

返回或设置一个 String 类型，表示指定元素的数字格式。可读写。

expression.Format

expression 必需。该表达式返回一个 ElementExtension 对象。


FormatMap 属性

返回一个 ChFormatMap 对象，表示指定系列的格式映射。

expression.FormatMap

expression 必需。该表达式返回一个 ChSeries 对象。


Formula 属性

以 A1-样式符和脚本语言返回或设置对象的公式。如果单元格包含常量，则该属性返回常量。如果单元格为空，则返回空字符串。如果单元格包含公式，则 Formula 属性以字符串返回公式，其格式与公式进行激活编辑时显示的相同（包括等号）。

如果将单元格的值或公式设置为日期，Spreadsheet 组件将查看单元格是否已经设置为某种日期或时间数字格式。如果没有，Spreadsheet 组件将数字格式更改为默认的短日期数字格式。

如果区域为一维或二维区域，可以将公式设置为相同维数的数组。与此类似，也可以将公式放入数组。

在多单元格区域设置公式将以公式填充区域中的所有单元格。Variant 类型，可读写。

expression.Formula

expression 必需。该表达式返回一个 Range 对象。

示例

本示例设置 Spreadsheet1 中 Sheet1 上单元格 B5 的公式、列宽和数字格式。

Sub SetFormula()
Dim rngRandomNum

' Set a variable to cell B5 on Sheet1.
Set rngRandomNum = Spreadsheet1.Worksheets("Sheet1").Range("B5")

' Insert a formula into cell B5.
rngRandomNum.Formula = "=5*RAND()"

' Set the number format for cell B5.
rngRandomNum.NumberFormat = "#.###"

' Autofit column B.
rngRandomNum.Columns.AutoFit

End Sub


FormulaArray 属性

返回或设置一个 Variant 类型，表示区域的数组公式。返回（或设置为）单个公式或 Visual Basic 数组。如果指定区域不包含数组公式，该属性将返回空字符串 ("")。可读写。

expression.FormulaArray

expression 必需。该表达式返回一个 Range 对象。

示例

本示例在活动工作表上的单元格 E1:E3 中输入公式 =SUM(A1:A3)。

Spreadsheet1.ActiveSheet.Range("E1:E3").FormulaArray = _
         "=SUM(A1:A3)"


FormulaLocal 属性

以用户正在使用的语言返回或设置区域公式。如果单元格包含常量，则该属性返回常量。如果单元格为空，则返回空字符串。如果单元格包含公式，则 Formula 属性以字符串返回公式，其格式与公式进行激活编辑时显示的相同（包括等号）。

如果将单元格的值或公式设置为日期，Spreadsheet 组件将查看单元格是否已经设置为某种日期或时间数字格式。如果没有，Spreadsheet 组件将数字格式更改为默认的短日期数字格式。

如果区域为一维或二维区域，可以将公式设置为相同维数的数组。与此类似，也可以将公式放入数组。

在多单元格区域设置公式将以公式填充区域中的所有单元格。Variant 类型，可读写。

expression.FormulaLocal

expression 必需。该表达式返回一个 Range 对象。

示例

本示例以用户语言显示 Spreadsheet1 活动单元格中的公式。

MsgBox Spreadsheet1.ActiveCell.FormulaLocal


FreezePanes 属性

将该属性设置为 True 可在活动工作表中创建窗格。窗格将在活动单元格的左上方创建。例如，当单元格 D5 为活动单元格时，设置该属性为 True 将在第四行和第五行之间产生一个水平窗格、在 C 列和 D 列之间产生一个垂直窗格。设置该属性为 False 将从工作表中删除所有窗格。Boolean 类型，可读写。

expression.FreezePanes

expression 必需。该表达式返回一个 Window 对象。

示例

本示例在活动工作表中创建窗格。

Spreadsheet1.ActiveWindow.FreezePanes = True


Function 属性

返回或设置用于生成聚合值的函数。PivotTotalFunctionEnum 类型，可读写。

PivotTotalFunctionEnum 可为以下 PivotTotalFunctionEnum 常量之一：
plFunctionAverage
plFunctionCalculated
plFunctionCount
plFunctionMax
plFunctionMin
plFunctionStdDev
plFunctionStdDevP
plFunctionSum
plFunctionUnknown
plFunctionVar
plFunctionVarP

expression.Function

expression 必需。该表达式 返回一个 PivotTotal 对象。

说明

Sum 运算符为数字数据类型的默认值。Count 运算符为其他数据类型的默认值。


GapDepth 属性

返回或设置一个 Long 类型，指定三维图表中 Z 轴上相邻数据系列之间的间距量。有效范围为 0 到 500。可读写。

expression.GapDepth

expression 必需。该表达式返回一个 ChChart 对象。

说明

设置该属性为 100 将使间距与数据系列的间隔程度相同。

示例

本示例将 Chartspace1 中的第一个图表转换为三维柱形图，然后设置图表的间距深度。

Sub SetGapDepth()

    Dim cht3DColumn As ChChart

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DColumn = ChartSpace1.Charts(0)

    ' Change the chart to a 3-D Column chart.
    cht3DColumn.Type = chChartTypeColumn3D

    ' Set the gap depth.
    cht3DColumn.GapDepth = 75

End Sub


GapWidth 属性

以列宽百分比返回或设置相邻分类标志之间的间距。零值表示在相邻分类标志之间没有间距，而正值将创建间距。Long 类型，可读写。

expression.GapWidth

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例设置相邻分类标志之间的间距为 250 点。

ChartSpace1.Charts(0).GapWidth = 250


GradientDegree 属性

返回一个 Double 类型，以 0.0（暗）到 1.0（亮）之间的值表示指定底纹填充的渐变程度。只读。

expression.GradientDegree

expression 必需。该表达式返回一个 ChInterior 对象。

说明

使用 SetOneColorGradient 方法设置 ChInterior 对象的渐变程度。


GradientStyle 属性

返回表示指定 ChInterior 对象渐变样式的 ChartGradientStyleEnum 常量。只读。

ChartGradientStyleEnum 可以为下列 ChartGradientStyleEnum 常量之一。
chGradientDiagonalDown
chGradientDiagonalUp
chGradientFromCenter
chGradientFromCorner
chGradientHorizontal
chGradientVertical

expression.GradientStyle

expression 必需。该表达式返回一个 ChInterior 对象。

说明

使用 SetPresetGradient、SetOneColorGradient 或 SetTwoColorGradient 方法设置 ChInterior 对象的渐变样式。


GradientVariant 属性

返回表示指定 ChInterior 对象底纹变量的 ChartGradientVariantEnum 常量。只读。

ChartGradientVariantEnum 可以为下列 ChartGradientVariantEnum 常量之一。
chGradientVariantCenter
chGradientVariantEdges
chGradientVariantEnd
chGradientVariantStart

expression.GradientVariant

expression 必需。该表达式返回一个 ChInterior 对象。

说明

使用 OneColorGradient 或 TwoColorGradient 方法设置 ChInterior 对象的渐变变量。


GridlineColor 属性

以 RGB 值返回或设置网格线颜色。Long 类型，可读写。

expression.GridlineColor

expression 必需。该表达式返回一个 Window 对象。

示例

下面示例设置 Spreadsheet1 中活动窗口的网格线颜色为红色。

Spreadsheet1.ActiveWindow.GridlineColor = RGB(255,0,0)


GridlineColorIndex 属性

以当前调色板中的索引或 XlColorIndex 常量返回或设置网格线颜色。可读写。

XlColorIndex 可以为下列 XlColorIndex 常量之一。
xlColorIndexAutomatic
xlColorIndexNone

expression.GridlineColorIndex

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

将该属性设置为 xlColorIndexAutomatic 可指定颜色为自动。

下面示例显示默认调色板中的颜色索引值。

示例

下面示例设置 Spreadsheet1 中活动窗口的网格线颜色为蓝色。

Spreadsheet1.ActiveWindow.GridlineColorIndex = 5


GridX 属性

在指定数据访问页设计器的默认节的 X 轴上，返回或设置每英寸的虚线网格线数。Long 类型，可读写。

expression.GridX

expression 必需。该表达式 返回一个 DataSourceControl 对象。


GridY 属性

在指定数据访问页设计器的默认节的 Y 轴上，返回或设置每英寸的虚线网格线数。Long 类型，可读写。

expression.GridY

expression 必需。该表达式 返回一个 DataSourceControl 对象。


GroupedAutoFit 属性

如果指定字段在用于行轴或列轴时列宽设置为自动，则返回 True。如果要设置字段的列宽，请将该属性设置为 False。然后将字段的 GroupedWidth 属性设置为所需的宽度。默认值为 True。Boolean 类型，可读写。

expression.GroupedAutoFit

expression 必需。该表达式返回一个 PivotField 对象。

示例

本示例禁用 PivotTable1 中“ProductName”字段的 GroupedAutoFit 属性，并设置字段宽度为 150 像素。

Sub Set_ColumnWidth()
    Dim fldProducts

    ' Set a variable to the ProductName field.
    Set fldProducts = PivotTable1.ActiveView.FieldSets("ProductName").Fields(0)

    ' Set the GroupedAutoFit for the ProductName field.
    fldProducts.GroupedAutoFit = False

    ' Set the width of the ProductName field to 150 pixels.
    fldProducts.GroupedWidth = 150
End Sub


GroupedBackColor 属性

返回或设置一个 Variant 类型，表示字段分组时的背景色。可读写。

expression.GroupedBackColor

expression 必需。该表达式返回一个 PivotField 对象。

说明

在设置该属性时，既可以使用表示红绿蓝颜色的 Long 类型值，也可以使用命名有效 HTML 颜色值的 String 类型值。例如，要将对象颜色设置为红色，可以使用十六进制值 &HFF、十进制值 255 或字符串值 "red"。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝颜色值（红色为 RGB(255,0,0)）。

示例

本示例对 PivotTable1 的 Age 字段进行分组。年龄从 15 开始到 80,每隔 5 年新建一组，然后设置所得分组的字体、前景、背景、高度和对齐方式。

Sub AddGrouping()

    Dim vwView
    Dim ptConstants
    Dim pfGroupedField

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable.
    Set vwView = PivotTable1.ActiveView

    ' Set a variable to the Age field.
    Set pfGroupedField = vwView.FieldSets("Age").Fields("Age")

    ' Set the GroupOn property so that the Age field will be
    ' grouped by the GroupInterval setting.
    pfGroupedField.GroupOn = ptConstants.plGroupOnInterval

    ' Create a new grouping for every five years.
    pfGroupedField.GroupInterval = 5

   ' Start the grouping at age 15.
    pfGroupedField.GroupStart = 15

    ' End the grouping at age 80.
    pfGroupedField.GroupEnd = 80

    ' Set the font for the field when it is grouped.
    pfGroupedField.GroupedFont.Bold = True

    ' Set the foreground color for the field when it is grouped.
    pfGroupedField.GroupedForeColor = "Black"

    ' Set the Background color for the field when it is grouped.
    pfGroupedField.GroupedBackColor = "Blue"

    ' Set the height for the field when it is grouped.
    pfGroupedField.GroupedHeight = 15

    ' Set the horizontal alignment for the field when it is grouped.
    pfGroupedField.GroupedHAlignment = ptConstants.plHAlignRight

End Sub


GroupedFont 属性

返回或设置一个 PivotFont 对象，表示分组指定字段时的字体。

expression.GroupedFont

expression 必需。该表达式返回一个 PivotField 对象。

示例

本示例对 PivotTable1 的 Age 字段进行分组。年龄从 15 开始到 80,每隔 5 年新建一组，然后设置所得分组的字体、前景、背景、高度和对齐方式。

Sub AddGrouping()

    Dim vwView
    Dim ptConstants
    Dim pfGroupedField

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable.
    Set vwView = PivotTable1.ActiveView

    ' Set a variable to the Age field.
    Set pfGroupedField = vwView.FieldSets("Age").Fields("Age")

    ' Set the GroupOn property so that the Age field will be
    ' grouped by the GroupInterval setting.
    pfGroupedField.GroupOn = ptConstants.plGroupOnInterval

    ' Create a new grouping for every five years.
    pfGroupedField.GroupInterval = 5

   ' Start the grouping at age 15.
    pfGroupedField.GroupStart = 15

    ' End the grouping at age 80.
    pfGroupedField.GroupEnd = 80

    ' Set the font for the field when it is grouped.
    pfGroupedField.GroupedFont.Bold = True

    ' Set the foreground color for the field when it is grouped.
    pfGroupedField.GroupedForeColor = "Black"

    ' Set the Background color for the field when it is grouped.
    pfGroupedField.GroupedBackColor = "Blue"

    ' Set the height for the field when it is grouped.
    pfGroupedField.GroupedHeight = 15

    ' Set the horizontal alignment for the field when it is grouped.
    pfGroupedField.GroupedHAlignment = ptConstants.plHAlignRight

End Sub


GroupedForeColor 属性

返回或设置一个 Variant 类型，表示字段分组时的前景色。使用该属性设置分组项的颜色。可读写。

expression.GroupedForeColor

expression 必需。该表达式返回一个 PivotField 对象。

说明

在设置该属性时，既可以使用表示红绿蓝颜色的 Long 类型值，也可以使用命名有效 HTML 颜色值的 String 类型值。例如，要将对象颜色设置为红色，可以使用十六进制值 &HFF、十进制值 255 或字符串值 "red"。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝颜色值（红色为 RGB(255,0,0)）。

示例

本示例对 PivotTable1 的 Age 字段进行分组。年龄从 15 开始到 80,每隔 5 年新建一组，然后设置所得分组的字体、前景、背景、高度和对齐方式。

Sub AddGrouping()

    Dim vwView
    Dim ptConstants
    Dim pfGroupedField

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable.
    Set vwView = PivotTable1.ActiveView

    ' Set a variable to the Age field.
    Set pfGroupedField = vwView.FieldSets("Age").Fields("Age")

    ' Set the GroupOn property so that the Age field will be
    ' grouped by the GroupInterval setting.
    pfGroupedField.GroupOn = ptConstants.plGroupOnInterval

    ' Create a new grouping for every five years.
    pfGroupedField.GroupInterval = 5

   ' Start the grouping at age 15.
    pfGroupedField.GroupStart = 15

    ' End the grouping at age 80.
    pfGroupedField.GroupEnd = 80

    ' Set the font for the field when it is grouped.
    pfGroupedField.GroupedFont.Bold = True

    ' Set the foreground color for the field when it is grouped.
    pfGroupedField.GroupedForeColor = "Black"

    ' Set the Background color for the field when it is grouped.
    pfGroupedField.GroupedBackColor = "Blue"

    ' Set the height for the field when it is grouped.
    pfGroupedField.GroupedHeight = 15

    ' Set the horizontal alignment for the field when it is grouped.
    pfGroupedField.GroupedHAlignment = ptConstants.plHAlignRight

End Sub


GroupedHAlignment 属性

返回或设置一个 PivotHAlignmentEnum 常量，表示分组指定字段时的水平对齐方式。可读写。

PivotHAlignmentEnum 可以为下列 PivotHAlignmentEnum 常量之一。
plHAlignAutomatic
plHAlignCenter
plHAlignLeft
plHAlignRight

expression.GroupedHAlignment

expression 必需。该表达式返回一个 PivotField 对象。

示例

本示例对 PivotTable1 的 Age 字段进行分组。年龄从 15 开始到 80,每隔 5 年新建一组，然后设置所得分组的字体、前景、背景、高度和对齐方式。

Sub AddGrouping()

    Dim vwView
    Dim ptConstants
    Dim pfGroupedField

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable.
    Set vwView = PivotTable1.ActiveView

    ' Set a variable to the Age field.
    Set pfGroupedField = vwView.FieldSets("Age").Fields("Age")

    ' Set the GroupOn property so that the Age field will be
    ' grouped by the GroupInterval setting.
    pfGroupedField.GroupOn = ptConstants.plGroupOnInterval

    ' Create a new grouping for every five years.
    pfGroupedField.GroupInterval = 5

   ' Start the grouping at age 15.
    pfGroupedField.GroupStart = 15

    ' End the grouping at age 80.
    pfGroupedField.GroupEnd = 80

    ' Set the font for the field when it is grouped.
    pfGroupedField.GroupedFont.Bold = True

    ' Set the foreground color for the field when it is grouped.
    pfGroupedField.GroupedForeColor = "Black"

    ' Set the Background color for the field when it is grouped.
    pfGroupedField.GroupedBackColor = "Blue"

    ' Set the height for the field when it is grouped.
    pfGroupedField.GroupedHeight = 15

    ' Set the horizontal alignment for the field when it is grouped.
    pfGroupedField.GroupedHAlignment = ptConstants.plHAlignRight

End Sub


GroupedHeight 属性

返回或设置一个 Long 类型，表示字段分组时的高度。可读写。

expression.GroupedHeight

expression 必需。该表达式返回一个 PivotField 对象。

示例

本示例对 PivotTable1 的 Age 字段进行分组。年龄从 15 开始到 80,每隔 5 年新建一组，然后设置所得分组的字体、前景、背景、高度和对齐方式。

Sub AddGrouping()

    Dim vwView
    Dim ptConstants
    Dim pfGroupedField

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable.
    Set vwView = PivotTable1.ActiveView

    ' Set a variable to the Age field.
    Set pfGroupedField = vwView.FieldSets("Age").Fields("Age")

    ' Set the GroupOn property so that the Age field will be
    ' grouped by the GroupInterval setting.
    pfGroupedField.GroupOn = ptConstants.plGroupOnInterval

    ' Create a new grouping for every five years.
    pfGroupedField.GroupInterval = 5

   ' Start the grouping at age 15.
    pfGroupedField.GroupStart = 15

    ' End the grouping at age 80.
    pfGroupedField.GroupEnd = 80

    ' Set the font for the field when it is grouped.
    pfGroupedField.GroupedFont.Bold = True

    ' Set the foreground color for the field when it is grouped.
    pfGroupedField.GroupedForeColor = "Black"

    ' Set the Background color for the field when it is grouped.
    pfGroupedField.GroupedBackColor = "Blue"

    ' Set the height for the field when it is grouped.
    pfGroupedField.GroupedHeight = 15

    ' Set the horizontal alignment for the field when it is grouped.
    pfGroupedField.GroupedHAlignment = ptConstants.plHAlignRight

End Sub


GroupedWidth 属性

返回或设置指定字段在行轴或列轴上显示时的宽度（像素）。默认值为 50 像素。如果指定字段的 GroupedAutoFit 属性设置为 True，则忽略该属性。Long 类型，可读写。

expression.GroupedWidth

expression 必需。该表达式返回一个 PivotField 对象。

示例

本示例禁用 PivotTable1 中“ProductName”字段的 GroupedAutoFit 属性，并设置字段宽度为 150 像素。

Sub Set_ColumnWidth()
    Dim fldProducts

    ' Set a variable to the ProductName field.
    Set fldProducts = PivotTable1.ActiveView.FieldSets("ProductName").Fields(0)

    ' Set the GroupedAutoFit for the ProductName field.
    fldProducts.GroupedAutoFit = False

    ' Set the width of the ProductName field to 150 pixels.
    fldProducts.GroupedWidth = 150
End Sub


GroupEnd 属性

返回或设置一个 Variant 类型，表示指定字段分组间隔的结束值。可读写。

expression.GroupEnd

expression 必需。该表达式返回一个 PivotField 对象。

说明

如果指定字段包含大于该属性设置值的数值，将创建名为 ">=(GroupEnd +1)" 的分组，其中 GroupEnd 为该属性的指定值。该组将包含所有大于该属性设置值的数值。

如果没有设置该属性或设置为 Empty，则字段中的最大值将用作结束值。

如果 GroupOn 属性的当前设置为 plGroupOnPrefixChars，则设置该属性将导致运行时出错。

示例

本示例对 PivotTable1 的 Age 字段进行分组。年龄从 15 开始到 80,每隔 5 年新建一组，然后设置所得分组的字体、前景、背景、高度和对齐方式。

Sub AddGrouping()

    Dim vwView
    Dim ptConstants
    Dim pfGroupedField

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable.
    Set vwView = PivotTable1.ActiveView

    ' Set a variable to the Age field.
    Set pfGroupedField = vwView.FieldSets("Age").Fields("Age")

    ' Set the GroupOn property so that the Age field will be
    ' grouped by the GroupInterval setting.
    pfGroupedField.GroupOn = ptConstants.plGroupOnInterval

    ' Create a new grouping for every five years.
    pfGroupedField.GroupInterval = 5

   ' Start the grouping at age 15.
    pfGroupedField.GroupStart = 15

    ' End the grouping at age 80.
    pfGroupedField.GroupEnd = 80

    ' Set the font for the field when it is grouped.
    pfGroupedField.GroupedFont.Bold = True

    ' Set the foreground color for the field when it is grouped.
    pfGroupedField.GroupedForeColor = "Black"

    ' Set the Background color for the field when it is grouped.
    pfGroupedField.GroupedBackColor = "Blue"

    ' Set the height for the field when it is grouped.
    pfGroupedField.GroupedHeight = 15

    ' Set the horizontal alignment for the field when it is grouped.
    pfGroupedField.GroupedHAlignment = ptConstants.plHAlignRight

End Sub


GroupField 属性

返回一个 PivotResultGroupField 对象。使用所返回对象的该属性访问指定坐标轴成员的来源字段和坐标轴属性。

expression.GroupField

expression 必需。该表达式返回一个 PivotAxisMember 对象。


GroupFields 属性

返回指定分组坐标轴的 PivotResultGroupFields 集合。

expression.GroupFields

expression 必需。该表达式返回一个 PivotResultGroupAxis 对象。


GroupFilterControl 属性

返回或设置用于设置货币的列表框或组合框的 ID。String 类型，可读写。

expression.GroupFilterControl

expression 必需。该表达式返回一个 GroupLevel 对象。


GroupFilterField 属性

返回或设置组筛选控件使用的筛选字符串（控件将设置货币的字段）。该字符串必须为组级别记录源中的页字段名称。String 类型，可读写。

expression.GroupFilterField

expression 必需。该表达式返回一个 GroupLevel 对象。


GroupFooter 属性

如果指定的节具有页脚，则返回 True。除最内层的级别外，可以设置任何捆绑级别的该属性。默认值为 False。Boolean 类型，可读写。

expression.GroupFooter

expression 必需。该表达式返回 GroupLevel 对象。


GroupHeader 属性

如果指定的节具有页眉，则返回 True。默认值为 True。Boolean 类型，可读写。

expression.GroupHeader

expression 必需。该表达式返回一个 GroupLevel 对象。


GroupingDefs 属性

返回指定记录集定义的 GroupingDefs 集合。该集合包含为明细记录创建组级别的 GroupingDef 对象。

expression.GroupingDefs

expression 必需。该表达式 返回一个 RecordsetDef 对象。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


GroupingTotalFunction 属性

返回或设置一个 ChartGroupingTotalFunctionEnum 常量，表示用于显示组中数值的函数。可读写。

ChartGroupingTotalFunctionEnum 可以为下列 ChartGroupingTotalFunctionEnum 常量之一。
chFunctionAvg
chFunctionCount
chFunctionDefault
chFunctionMax
chFunctionMin
chFunctionSum

expression.GroupingTotalFunction

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例将 Chartspace1 中的第一个图表转换为折线图，然后设置分类轴格式，使数据按月分组。图表上显示每个月的平均值。

Sub FormatTimeScaling()

    Dim chConstants
    Dim axCategory

    Set chConstants = ChartSpace1.Constants

    ' Change the chart to a Line chart.
    ChartSpace1.Charts(0).Type = chConstants.chChartTypeLine

    ' Set a variable to the category axis.
    Set axCategory = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionCategory)

    ' Specify that you will determine the grouping settings of the
    ' axis. Note that this line of code is necessary only if the
    ' GroupingType property for the axis has been previously set to
    ' chAxisGroupingNone.
    axCategory.GroupingType = chConstants.chAxisGroupingManual

    ' Group the category axis by month.
    axCategory.GroupingUnitType = chConstants.chAxisUnitMonth

    ' Create a new grouping for every month.
    axCategory.GroupingUnit = 1

    ' Display the average of the items in each group.
    axCategory.GroupingTotalFunction = chConstants.chFunctionAvg

    ' A tick label is displayed for every month.
    axCategory.TickLabelUnitType = chConstants.chAxisUnitMonth

    ' A tick mark is displayed for every three months.
    axCategory.TickMarkUnitType = chConstants.chAxisUnitQuarter

End Sub


GroupingType 属性

返回或设置一个 ChartAxisGroupingEnum 常量，表示是否对图表坐标轴上的项进行分组，如果进行分组，是否自动进行。可读写。

ChartAxisGroupingEnum 可以为下列 ChartAxisGroupingEnum 常量之一。
chAxisGroupingAuto Chart 控件选择分组单位和类型。
chAxisGroupingManual 将使用 GroupingUnitType 和 GroupingUnit 属性执行分组。
chAxisGroupingNone 不对坐标轴进行分组。

expression.GroupingType

expression 必需。该表达式返回一个 ChAxis 对象。

说明

如果满足下列条件，Chart 控件将自动创建时间刻度并在分类轴上进行分组：

  • Chart 控件检测到分类信息为日期。
  • Chart 控件绑定到数据透视表列表，并且数据透视表列表没有绑定到 OLAP 数据源。

示例

本示例禁用 Chartspace1 中第一个图表的分类轴的时间刻度。

Sub DisableTimeScaling()

    Dim chConstants
    Dim axCategory

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the category axis.
    Set axCategory = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionTimescale)

    ' Disable time scaling on the category axis.
    axCategory.GroupingType = chConstants.chAxisGroupingNone

End Sub


GroupingUnit 属性

返回或设置一个 Long 类型，表示组中的项数。可读写。

expression.GroupingUnit

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例将 Chartspace1 中的第一个图表转换为折线图，然后设置分类轴格式，使数据按月分组。图表上显示每个月的平均值。

Sub FormatTimeScaling()

    Dim chConstants
    Dim axCategory

    Set chConstants = ChartSpace1.Constants

    ' Change the chart to a Line chart.
    ChartSpace1.Charts(0).Type = chConstants.chChartTypeLine

    ' Set a variable to the category axis.
    Set axCategory = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionCategory)

    ' Specify that you will determine the grouping settings of the
    ' axis. Note that this line of code is necessary only if the
    ' GroupingType property for the axis has been previously set to
    ' chAxisGroupingNone.
    axCategory.GroupingType = chConstants.chAxisGroupingManual

    ' Group the category axis by month.
    axCategory.GroupingUnitType = chConstants.chAxisUnitMonth

    ' Create a new grouping for every month.
    axCategory.GroupingUnit = 1

    ' Display the average of the items in each group.
    axCategory.GroupingTotalFunction = chConstants.chFunctionAvg

    ' A tick label is displayed for every month.
    axCategory.TickLabelUnitType = chConstants.chAxisUnitMonth

    ' A tick mark is displayed for every three months.
    axCategory.TickMarkUnitType = chConstants.chAxisUnitQuarter

End Sub


GroupingUnitType 属性

返回或设置一个 ChartAxisUnitTypeEnum 常量，表示坐标轴上的项如何分组。

ChartAxisUnitTypeEnum 可以为下列 ChartAxisUnitTypeEnum 常量之一。
chAxisUnitDay
chAxisUnitMonth
chAxisUnitQuarter
chAxisUnitWeek
chAxisUnitYear

expression.GroupingUnitType

expression 必需。该表达式返回一个 ChAxis 对象。

说明

设置该属性将设置 GroupingType 属性为 chAxisGroupingManual。

如果满足下列条件，Chart 控件将自动创建时间刻度并在分类轴上进行分组：

  • Chart 控件检测到分类信息为日期。
  • Chart 控件绑定到数据透视表列表，并且数据透视表列表没有绑定到 OLAP 数据源。

示例

本示例将 Chartspace1 中的第一个图表转换为折线图，然后设置分类轴格式，使数据按月分组。图表上显示每个月的平均值。

Sub FormatTimeScaling()

    Dim chConstants
    Dim axCategory

    Set chConstants = ChartSpace1.Constants

    ' Change the chart to a Line chart.
    ChartSpace1.Charts(0).Type = chConstants.chChartTypeLine

    ' Set a variable to the category axis.
    Set axCategory = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionCategory)

    ' Specify that you will determine the grouping settings of the
    ' axis. Note that this line of code is necessary only if the
    ' GroupingType property for the axis has been previously set to
    ' chAxisGroupingNone.
    axCategory.GroupingType = chConstants.chAxisGroupingManual

    ' Group the category axis by month.
    axCategory.GroupingUnitType = chConstants.chAxisUnitMonth

    ' Create a new grouping for every month.
    axCategory.GroupingUnit = 1

    ' Display the average of the items in each group.
    axCategory.GroupingTotalFunction = chConstants.chFunctionAvg

    ' A tick label is displayed for every month.
    axCategory.TickLabelUnitType = chConstants.chAxisUnitMonth

    ' A tick mark is displayed for every three months.
    axCategory.TickMarkUnitType = chConstants.chAxisUnitQuarter

End Sub


GroupInterval 属性

显示 GroupInterval 属性应用于 PivotField 对象的情形。

返回或设置一个 Double 类型，表示字段的分组间隔。该属性将依据 GroupOn 属性的当前设置进行解释。下表说明了该属性如何依据 GroupOn 属性的当前设置进行解释。可读写。

GroupOn 设置 | GroupInterval 的含义
plGroupOnEachValue | 忽略。
plGroupOnPrefixChars | 每个数值所用的初始字符数。
plGroupOnYears | 每组中的年数。
plGroupOnQtrs | 每组中的季度数。
plGroupOnMonths | 每组中的月数。
plGroupOnWeeks | 每组中的星期数。
plGroupOnDays | 每组中的天数。
plGroupOnHours | 每组中的小时数。
plGroupOnMinutes | 每组中的分钟数。
plGroupOnSeconds | 每组中的秒数。
plGroupOnInterval | 每组的数字大小。

expression.GroupInterval

expression 必需。该表达式返回一个 PivotField 对象。

显示 GroupInterval 属性应用于 GroupLevel 和 PageField 对象的情形。

返回或设置一个 Double 类型，表示组间距。可读写。

expression.GroupInterval

expression 必需。该表达式返回上面对象之一。

示例

显示 应用于 PivotField 对象的情形。

本示例对 PivotTable1 的 Age 字段进行分组。年龄从 15 开始到 80,每隔 5 年新建一组，然后设置所得分组的字体、前景、背景、高度和对齐方式。

Sub AddGrouping()

    Dim vwView
    Dim ptConstants
    Dim pfGroupedField

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable.
    Set vwView = PivotTable1.ActiveView

    ' Set a variable to the Age field.
    Set pfGroupedField = vwView.FieldSets("Age").Fields("Age")

    ' Set the GroupOn property so that the Age field will be
    ' grouped by the GroupInterval setting.
    pfGroupedField.GroupOn = ptConstants.plGroupOnInterval

    ' Create a new grouping for every five years.
    pfGroupedField.GroupInterval = 5

   ' Start the grouping at age 15.
    pfGroupedField.GroupStart = 15

    ' End the grouping at age 80.
    pfGroupedField.GroupEnd = 80

    ' Set the font for the field when it is grouped.
    pfGroupedField.GroupedFont.Bold = True

    ' Set the foreground color for the field when it is grouped.
    pfGroupedField.GroupedForeColor = "Black"

    ' Set the Background color for the field when it is grouped.
    pfGroupedField.GroupedBackColor = "Blue"

    ' Set the height for the field when it is grouped.
    pfGroupedField.GroupedHeight = 15

    ' Set the horizontal alignment for the field when it is grouped.
    pfGroupedField.GroupedHAlignment = ptConstants.plHAlignRight

End Sub


GroupLevel 属性

返回指定数据访问页的 GroupLevel 对象。GroupLevel 对象与由记录集定义或分组定义所产生的记录集相对应。只读。

expression.GroupLevel

expression 必需。该表达式返回一个 DataPage 对象。


GroupLevels 属性

返回指定数据源控件的 GroupLevels 对象。只读。

expression.GroupLevels

expression 必需。该表达式返回一个 DataSourceControl 对象。

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


GroupOn 属性

显示 GroupOn 属性应用于 PivotField 对象的情形。

返回或设置一个 PivotFieldGroupOnEnum 常量，表示字段的分组设置。使用该属性确定如何分组数据透视表字段中的项。可读写。

PivotFieldGroupOnEnum 可以为下列 PivotFieldGroupOnEnum 常量之一。
plGroupOnEachValue 指定不分组。默认设置。
plGroupOnPrefixChars 按照每个值的前 N 个字符分组文本数值，其中 N 为 GroupInterval 属性属性值。该设置仅对文本字段有效。
plGroupOnYears 按年分组日期或时间值。
plGroupOnQtrs 按季度分组日期和时间值。
plGroupOnMonths 按月分组日期和时间值。
plGroupOnWeeks 按星期分组日期和时间值。
plGroupOnDays 按各自的日分组日期和时间值。
plGroupOnHours 按各自的小时分组日期和时间值。
plGroupOnMinutes 按各自的分钟分组日期和时间值。
plGroupOnSeconds 按各自的秒分组日期和时间值。
plGroupOnInterval 按 GroupInterval 属性指定的间距分组数字值。

expression.GroupOn

expression 必需。该表达式返回一个 PivotField 对象。

说明

设置了 GroupOn 属性后，可以使用 GroupInterval、GroupStart 和 GroupEnd 属性进一步定义如何分组字段中的项。

设置该属性将影响数据透视表列表中行、列和筛选区域上每个字段值的显示方式。设置该属性不影响数据透视表列表明细区域中的数值显示方式。但是，筛选将反映数据透视表列表明细区域中字段的 GroupOn 设置。

设置数据透视表字段的该属性将清除已经设置的 IncludedMembers 和 ExcludedMembers 属性。

显示 GroupOn 属性应用于 GroupLevel 和 PageField 对象的情形。

返回或设置一个 DscGroupOnEnum 常量，表示 GroupLevel 对象或 PageField 对象的分组方式。可读写。

expression.GroupOn

expression 必需。该表达式返回上面所列的对象之一。

DscGroupOnEnum 可以为下列 DscGroupOnEnum 常量之一。
dscDay
dscEachValue
dscHour
dscInterval
dscMinute
dscMonth
dscPrefix
dscQuarter
dscWeek
dscYear

示例

显示 应用于 PivotField 对象的情形。

本示例对 PivotTable1 的 Age 字段进行分组。年龄从 15 开始到 80,每隔 5 年新建一组，然后设置所得分组的字体、前景、背景、高度和对齐方式。

Sub AddGrouping()

    Dim vwView
    Dim ptConstants
    Dim pfGroupedField

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable.
    Set vwView = PivotTable1.ActiveView

    ' Set a variable to the Age field.
    Set pfGroupedField = vwView.FieldSets("Age").Fields("Age")

    ' Set the GroupOn property so that the Age field will be
    ' grouped by the GroupInterval setting.
    pfGroupedField.GroupOn = ptConstants.plGroupOnInterval

    ' Create a new grouping for every five years.
    pfGroupedField.GroupInterval = 5

   ' Start the grouping at age 15.
    pfGroupedField.GroupStart = 15

    ' End the grouping at age 80.
    pfGroupedField.GroupEnd = 80

    ' Set the font for the field when it is grouped.
    pfGroupedField.GroupedFont.Bold = True

    ' Set the foreground color for the field when it is grouped.
    pfGroupedField.GroupedForeColor = "Black"

    ' Set the Background color for the field when it is grouped.
    pfGroupedField.GroupedBackColor = "Blue"

    ' Set the height for the field when it is grouped.
    pfGroupedField.GroupedHeight = 15

    ' Set the horizontal alignment for the field when it is grouped.
    pfGroupedField.GroupedHAlignment = ptConstants.plHAlignRight

End Sub


GroupStart 属性

返回或设置一个 Variant 类型，表示指定字段分组间隔的起始值。可读写。

expression.GroupStart

expression 必需。该表达式返回一个 PivotField 对象。

说明

如果指定字段包含小于该属性设置值的数值，将创建名为 "<GroupStart " 的分组，其中 GroupStart 为该属性的指定值。该组将包含所有小于该属性设置值的数值。

如果没有设置该属性或设置为 Empty，则字段中的最小值将用作起始值。

如果 GroupOn 属性的当前设置为 plGroupOnPrefixChars，则设置该属性将导致运行时出错。

示例

本示例对 PivotTable1 的 Age 字段进行分组。年龄从 15 开始到 80,每隔 5 年新建一组，然后设置所得分组的字体、前景、背景、高度和对齐方式。

Sub AddGrouping()

    Dim vwView
    Dim ptConstants
    Dim pfGroupedField

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable.
    Set vwView = PivotTable1.ActiveView

    ' Set a variable to the Age field.
    Set pfGroupedField = vwView.FieldSets("Age").Fields("Age")

    ' Set the GroupOn property so that the Age field will be
    ' grouped by the GroupInterval setting.
    pfGroupedField.GroupOn = ptConstants.plGroupOnInterval

    ' Create a new grouping for every five years.
    pfGroupedField.GroupInterval = 5

   ' Start the grouping at age 15.
    pfGroupedField.GroupStart = 15

    ' End the grouping at age 80.
    pfGroupedField.GroupEnd = 80

    ' Set the font for the field when it is grouped.
    pfGroupedField.GroupedFont.Bold = True

    ' Set the foreground color for the field when it is grouped.
    pfGroupedField.GroupedForeColor = "Black"

    ' Set the Background color for the field when it is grouped.
    pfGroupedField.GroupedBackColor = "Blue"

    ' Set the height for the field when it is grouped.
    pfGroupedField.GroupedHeight = 15

    ' Set the horizontal alignment for the field when it is grouped.
    pfGroupedField.GroupedHAlignment = ptConstants.plHAlignRight

End Sub


HAlignment 属性

返回或设置指定标签或总计的数据对齐方式。PivotHAlignmentEnum 类型，可读写。

PivotHAlignmentEnum 可为以下 PivotHAlignmentEnum 常量之一：
plHAlignAutomatic
plHAlignCenter
plHAlignLeft
plHAlignRight

expression.HAlignment

expression 必需。该表达式返回“应用于”列表中的对象之一。


HasAbsoluteLabels 属性

返回或设置百分比计算段的图例项在图例中是否显示为绝对数值。设置为 True 以显示百分比计算段的实际起始值和结束值。默认值为 False。Boolean 类型，可读写。

expression.HasAbsoluteLabels

expression 必需。该表达式返回一个 ChSegment 对象。

示例

本示例将 Chartspace1 绑定到 SQL Server 罗斯文数据库中的 Order Details 表。然后，创建格式映射，在图表中以深蓝色阴影显示较大数值。

Sub Window_Onload()

    Dim serSeries1
    Dim segSegment1 As ChSegment
    Dim chconstants

    Set chconstants = ChartSpace1.Constants

    ' The following two lines of code bind Chartspace1 to the Order Details table in the
    ' Northwind SQL Server database.
    ChartSpace1.ConnectionString = "Provider=SQLOLEDB.1;persist Security Info=TRUE;" & _
                                   "Integrated Security=SSPI;Initial Catalog=Northwind;" & _
                                   "Data Source=DataServer;"
    ChartSpace1.DataMember = "Order Details"

    ' The following two lines of code bind Chartspace1 to the Quantity and ProductID fields
    ' in the Order Details table.
    ChartSpace1.SetData chconstants.chDimCategories, chconstants.chDataBound, "ProductID"
    ChartSpace1.SetData chconstants.chDimValues, chconstants.chDataBound, "Quantity"

    ' Create a format map.
    ChartSpace1.SetData chconstants.chDimFormatValues, chconstants.chDataBound, "Quantity"

    ' Set a variable to the first series in the first chart in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a segment to the format map.
    Set segSegment1 = serSeries1.FormatMap.Segments.Add

    ' Measure the segment boundaries based upon a percentage.
    segSegment1.Begin.ValueType = chconstants.chBoundaryValuePercent
    segSegment1.End.ValueType = chconstants.chBoundaryValuePercent

    ' Set the beginning value to 0%, and the ending value to 100%.
    segSegment1.Begin.Value = 0
    segSegment1.End.Value = 1

    ' Format the interior of the matching values.
    segSegment1.Begin.Interior.Color = "White"
    segSegment1.End.Interior.Color = "Blue"
    segSegment1.HasAutoDivisions = False
    segSegment1.HasAbsoluteLabels = True
    segSegment1.HasDiscreteDivisions = False

End Sub


HasArray 属性

如果指定单元格属于数组公式，则返回 True。Variant 类型，只读。

expression.HasArray

expression 必需。该表达式返回一个 Range 对象。

说明

使用 CurrentArray 属性确定属于当前数组的单元格。

示例

本示例判断 Spreadsheet1 中的活动单元格是否属于某个数组。如果是，则选定该数组。

If Spreadsheet1.ActiveCell.HasArray Then _
     Spreadsheet1.ActiveCell.CurrentArray.Select


HasAutoAspectRatio 属性

如果修改了指定图表的纵横比，则返回 False。将该属性设置为 True 可将指定图表还原为默认纵横比。Boolean 类型，可读写。

expression.HasAutoAspectRatio

expression 必需。该表达式返回一个 ChChart 对象。

示例

本示例将 Chartspace1 中的第一个图表重置为默认纵横比。

Chartspace1.Charts(0).HasAutoAspectRatio = True


HasAutoCaption 属性

如果指定趋势线的名称由趋势线类型和系列索引自动生成（例如 “Poly. (Series 1)”），则返回 True。设置趋势线的 Caption 将设置该属性为 False。Boolean 类型，可读写。

expression.HasAutoCaption

expression 必需。该表达式返回一个 ChTrendline 对象。

示例

如果指定趋势线标题的当前设置为自动生成，本示例将设置趋势线的标题。请注意 SeriesCollection(0) 必须为已经具有趋势线的系列。

Sub SetCaption()
    Dim serZero
    Dim trndline

    Set serZero = ChartSpace1.Charts(0).SeriesCollection(0)
    serZero.Line.Color = "red"
    Set trndline = serZero.Trendlines(0)
    If trndline.HasAutoCaption Then trndline.Caption = "data trend"
End Sub


HasAutoChartDepth 属性

如果修改了指定图表的深度，则返回 False。将该属性设置为 True 可将指定图表还原为默认深度。Boolean 类型，可读写。

expression.HasAutoChartDepth

expression 必需。该表达式返回一个 ChChart 对象。

示例

本示例将 Chartspace1 中的第一个图表重置为默认深度。

Chartspace1.Charts(0).HasAutoChartDepth = True


HasAutoDivisions 属性

返回或设置是否为指定段自动创建分段。默认值为 True。Boolean 类型，可读写。

expression.HasAutoDivisions

expression 必需。该表达式返回一个 ChSegment 对象。

示例

本示例将 Chartspace1 绑定到 SQL Server 罗斯文数据库中的 Order Details 表。然后，创建格式映射，在图表中以深蓝色阴影显示较大数值。

Sub Window_Onload()

    Dim serSeries1
    Dim segSegment1 As ChSegment
    Dim chconstants

    Set chconstants = ChartSpace1.Constants

    ' The following two lines of code bind Chartspace1 to the Order Details table in the
    ' Northwind SQL Server database.
    ChartSpace1.ConnectionString = "Provider=SQLOLEDB.1;persist Security Info=TRUE;" & _
                                   "Integrated Security=SSPI;Initial Catalog=Northwind;" & _
                                   "Data Source=DataServer;"
    ChartSpace1.DataMember = "Order Details"

    ' The following two lines of code bind Chartspace1 to the Quantity and ProductID fields
    ' in the Order Details table.
    ChartSpace1.SetData chconstants.chDimCategories, chconstants.chDataBound, "ProductID"
    ChartSpace1.SetData chconstants.chDimValues, chconstants.chDataBound, "Quantity"

    ' Create a format map.
    ChartSpace1.SetData chconstants.chDimFormatValues, chconstants.chDataBound, "Quantity"

    ' Set a variable to the first series in the first chart in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a segment to the format map.
    Set segSegment1 = serSeries1.FormatMap.Segments.Add

    ' Measure the segment boundaries based upon a percentage.
    segSegment1.Begin.ValueType = chconstants.chBoundaryValuePercent
    segSegment1.End.ValueType = chconstants.chBoundaryValuePercent

    ' Set the beginning value to 0%, and the ending value to 100%
    segSegment1.Begin.Value = 0
    segSegment1.End.Value = 1

    ' Format the interior of the matching values.
    segSegment1.Begin.Interior.Color = "White"
    segSegment1.End.Interior.Color = "Blue"

    segSegment1.HasAutoDivisions = False

    segSegment1.HasAbsoluteLabels = True

    segSegment1.HasDiscreteDivisions = False

End Sub


HasAutoMajorUnit 属性

如果指定坐标轴的主要单位自动确定，则返回 True。默认值为 True。该属性应只用于数值轴。Boolean 类型，可读写。

expression.HasAutoMajorUnit

expression 必需。该表达式返回一个 ChAxis 对象。

示例

如果当前指定坐标轴的主要单位已设置为自动确定，本示例将设置坐标轴的主要单位。

Sub SetMajorUnit()
    Dim chtConstants
    dim axs

    Set chtConstants = ChartSpace1.Constants
    Set axs = ChartSpace1.Charts(0).Axes(chtConstants.chAxisPositionValue)
    If axs.HasAutoMajorUnit Then axs.MajorUnit = 5000
End Sub


HasAutoMaximum 属性

如果指定坐标轴的最大刻度值已设置为自动确定，则返回 True。默认值为 True。Boolean 类型，可读写。

expression.HasAutoMaximum

expression 必需。该表达式返回一个 ChScaling 对象。

示例

如果指定坐标轴的最大刻度值当前已设置为自动确定，本示例将设置坐标轴的最大刻度值。

Sub SetScale()
    Dim chConstants
    dim axisScale

    Set chConstants = ChartSpace1.Constants
    Set axisScale = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue).Scaling
    If axisScale.HasAutoMaximum Then axisScale.Maximum = 50000
End Sub


HasAutoMinimum 属性

如果指定坐标轴的最小刻度值已设置为自动确定，则返回 True。默认值为 True。Boolean 类型，可读写。

expression.HasAutoMinimum

expression 必需。该表达式返回一个 ChScaling 对象。

示例

如果指定坐标轴的最小刻度值当前设置为自动确定，本示例将设置坐标轴的最小刻度值。

Sub SetScaling()
    Dim chConstants
    Dim axisScale

    Set chConstants = ChartSpace1.Constants
    Set axisScale = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue).Scaling
    If axisScale.HasAutoMinimum Then axisScale.Minimum = 10
End Sub


HasAutoMinorUnit 属性

如果指定坐标轴的次要刻度单位设置为自动确定，则返回 True。默认值为 True。该属性应只用于数值轴。Boolean 类型，可读写。

expression.HasAutoMinorUnit

expression 必需。该表达式返回一个 ChAxis 对象。

示例

如果指定坐标轴的次要刻度单位当前已设置为自动确定，本示例将设置坐标轴的次要刻度单位。

Sub SetMinorUnit()
    Dim chConstants
    Dim axs

    Set chConstants = ChartSpace1.Constants
    Set axs = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue)
    If axs.HasAutoMinorUnit Then axs.MinorUnit = 500
End Sub


HasBubbleSize 属性

如果指定系列或图表的每个数据标志当前显示其气泡大小，则返回 True。默认值为 False。请注意该属性只适用于气泡图。Boolean 类型，可读写。

expression.HasBubbleSize

expression 必需。该表达式返回一个 ChDataLabels 对象。

说明

数据标志组件总是按照以下顺序显示：[SeriesName] [CategoryName] [Value] [BubbleSize] [Percentage]。

示例

本示例使指定系列的数据标志显示其气泡大小。请注意 Charts(0) 必须为气泡图。

Sub DisplayLabels()
    Dim dlBubbleLabels

    Set dlBubbleLabels = ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection.Add

    dlBubbleLabels.HasBubbleSize = True
End Sub


HasCategoryName 属性

如果指定系列或图表的每个数据标志当前显示其类别名称或标志，则返回 True。默认值为 False。Boolean 类型，可读写。

expression.HasCategoryName

expression 必需。该表达式返回一个 ChDataLabels 对象。

说明

数据标志组件总是按照以下顺序显示：[SeriesName] [CategoryName] [Value] [BubbleSize] [Percentage]。

示例

本示例使指定系列的数据标志显示其类别和系列名称。

Sub ShowLabels()
    Dim dl

    Set dl = ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection(0)

    ' Display the category names.
    dl.HasCategoryName = True

    ' Display the series names.
    dl.HasSeriesName = True
End Sub


HasChartSpaceLegend 属性

如果指定的图表工作区具有图例，则返回 True。Boolean 类型，可读写。

expression.HasChartSpaceLegend

expression 必需。该表达式返回一个 ChartSpace 对象。

说明

设置该属性为 False 将从图表工作区删除图例。如此操作后，如果随后再将该属性设置为 True，将丢失所有自定义格式并且必须重新设置。

示例

本示例将设置图表工作区标题，并将图表工作区图例置于工作区的左侧。

Sub Format_ChartSpace()
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Enable the title for the chartspace.
    ChartSpace1.HasChartSpaceTitle = True

    ' Set the chartspace title.
    ChartSpace1.ChartSpaceTitle.Caption = "Monthly Sales Data"

    ' Enable the legend for the chartspace.
    ChartSpace1.HasChartSpaceLegend = True

    ' Specify the position of the chartspace legend.
    ChartSpace1.ChartSpaceLegend.Position = chConstants.chLegendPositionLeft
End Sub


HasChartSpaceTitle 属性

如果指定图表工作区具有标题，则返回 True。Boolean 类型，可读写。

expression.HasChartSpaceTitle

expression 必需。该表达式返回一个 ChartSpace 对象。

说明

设置该属性为 False 将从图表工作区删除标题。如此操作后，如果随后再将该属性设置为 True，将丢失所有自定义格式并且必须重新设置。

示例

本示例将设置图表工作区标题，并将图表工作区图例置于工作区的左侧。

Sub Format_ChartSpace()
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Enable the title for the chartspace.
    ChartSpace1.HasChartSpaceTitle = True

    ' Set the chartspace title.
    ChartSpace1.ChartSpaceTitle.Caption = "Monthly Sales Data"

    ' Enable the legend for the chartspace.
    ChartSpace1.HasChartSpaceLegend = True

    ' Specify the position of the chartspace legend.
    ChartSpace1.ChartSpaceLegend.Position = chConstants.chLegendPositionLeft
End Sub


HasDetails 属性

如果指定单元格可以显示明细记录，则返回 True；如果没有明细记录可显示，则返回 False。重新查询数据时将重新设置该属性。如果该属性设置为 False，则内部成员不显示展开标记。如果提供者为多维数据源，该属性通常设置为 False。Boolean 类型，只读。

expression.HasDetails

expression 必需。该表达式 返回一个 PivotTable 对象。


HasDiscreteDivisions 属性

返回或设置指定段的起始值和结束值之间的格式插值方法。将该属性设置为 True 将使 Chart 控件指定段的分段数。将该属性设置为 False 将使 Chart 控件在段的起始值和结束值之间进行插值，而不创建离散格式分段。默认值为 False。Boolean 类型，可读写。

expression.HasDiscreteDivisions

expression 必需。该表达式返回一个 ChSegment 对象。

说明

为了演示将该属性设置为 True 或 False 之间的区别，假定设置了段的下列属性：

  • .Begin.Value = 10
  • .Begin.Interior.Color = "White"
  • .End.Value = 50
  • .End.Interior.Color = "Green"

如果该属性设置为 True，Chart 控件将创建许多分段，包含上面颜色设置的不同插值。但是，由于每个点在不同的分段，因此如果点在数值上彼此非常接近将很难设置格式。值为 24 的点可能为白色，值为 25 的点可能为相当深的绿色阴影，因为是在 24 与 25 之间创建的分段。将该属性设置为 False 将得到由白到绿的过渡插值。

示例

本示例将 Chartspace1 绑定到 SQL Server 罗斯文数据库中的 Order Details 表。然后，创建格式映射，在图表中以深蓝色阴影显示较大数值。

Sub Window_Onload()

    Dim serSeries1
    Dim segSegment1 As ChSegment
    Dim chconstants

    Set chconstants = ChartSpace1.Constants

    ' The following two lines of code bind Chartspace1 to the Order Details table in the
    ' Northwind SQL Server database.
    ChartSpace1.ConnectionString = "Provider=SQLOLEDB.1;persist Security Info=TRUE;" & _
                                   "Integrated Security=SSPI;Initial Catalog=Northwind;" & _
                                   "Data Source=DataServer;"
    ChartSpace1.DataMember = "Order Details"

    ' The following two lines of code bind Chartspace1 to the Quantity and ProductID fields
    ' in the Order Details table.
    ChartSpace1.SetData chconstants.chDimCategories, chconstants.chDataBound, "ProductID"
    ChartSpace1.SetData chconstants.chDimValues, chconstants.chDataBound, "Quantity"

    ' Create a format map.
    ChartSpace1.SetData chconstants.chDimFormatValues, chconstants.chDataBound, "Quantity"

    ' Set a variable to the first series in the first chart in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a segment to the format map.
    Set segSegment1 = serSeries1.FormatMap.Segments.Add

    ' Measure the segment boundaries based upon a percentage.
    segSegment1.Begin.ValueType = chconstants.chBoundaryValuePercent
    segSegment1.End.ValueType = chconstants.chBoundaryValuePercent

    ' Set the beginning value to 0%, and the ending value to 100%.
    segSegment1.Begin.Value = 0
    segSegment1.End.Value = 1

    ' Format the interior of the matching values.
    segSegment1.Begin.Interior.Color = "White"
    segSegment1.End.Interior.Color = "Blue"

    segSegment1.HasAutoDivisions = False

    segSegment1.HasAbsoluteLabels = True

    segSegment1.HasDiscreteDivisions = False

End Sub


HasFormula 属性

如果区域中的所有单元格均包含公式，则返回 True；如果没有单元格包含公式，则返回 False；如果某些单元格包含公式而其他不包含，则返回 Null。Variant 类型，只读。请使用 IsNull 函数判断返回值是否为 Null。

expression.HasFormula

expression 必需。该表达式返回一个 Range 对象。

示例

如果当前选定区域中的单元格包含公式，本示例将重新计算活动工作表。

Sub CalcIfSelectionHasFormulas()
    Dim vntHasFormula
    Dim rngCurrent

    Set rngCurrent = Spreadsheet1.Selection

    ' Set a variable to the HasFormula property
    ' for the current selection.
    vntHasFormula = rngCurrent.HasFormula

    If IsNull(vntHasFormula) Then

        ' Calculate the active worksheet if the
        ' selection contains one or more formulas.
        Spreadsheet1.ActiveSheet.Calculate

    ElseIf vntHasFormula Then

        ' Calculate the active worksheet if all
        ' selected cells contain a formula.
        Spreadsheet1.ActiveSheet.Calculate
    End If
End Sub


HasLegend 属性

如果指定图表具有图例，则返回 True。Boolean 类型，可读写。

expression.HasLegend

expression 必需。该表达式返回一个 ChChart 对象。

示例

本示例将指定图表设置为包含图例。

ChartSpace1.Charts(0).HasLegend = True


HasMajorGridlines 属性

如果指定坐标轴具有主要网格线，则返回 True。请注意任何坐标轴均可具有网格线。Boolean 类型，可读写。

expression.HasMajorGridlines

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例启用 ChartSpace1 中第一个图表的主要和次要网格线。

Sub EnableGridlines()
    Dim chConstants
    Dim axValueAxis

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to refer to the value axis.
    Set axValueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue)

    ' Enable the major gridlines on the value axis.
    axValueAxis.HasMajorGridlines = True

    ' Enable the major gridlines on the value axis.
    axValueAxis.HasMinorGridlines = True
End Sub


HasMinorGridlines 属性

如果指定坐标轴具有次要网格线，则返回 True。请注意任何坐标轴均可具有网格线。Boolean 类型，可读写。

expression.HasMinorGridlines

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例启用 ChartSpace1 中第一个图表的主要和次要网格线。

Sub EnableGridlines()
    Dim chConstants
    Dim axValueAxis

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to refer to the value axis.
    Set axValueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue)

    ' Enable the major gridlines on the value axis.
    axValueAxis.HasMajorGridlines = True

    ' Enable the major gridlines on the value axis.
    axValueAxis.HasMinorGridlines = True
End Sub


HasMultipleCharts 属性

返回或设置一个 Boolean 类型，表示指定 ChartSpace 是否包含多个图表。默认值为 False。可读写。

expression.HasMultipleCharts

expression 必需。该表达式返回一个 ChartSpace 对象。


HasPassiveAlerts 属性

返回或设置当发生非严重错误时是否使用被动警告。默认值为 True。Boolean 类型，可读写。

expression.HasPassiveAlerts

expression 必需。该表达式返回一个 Chartspace 对象。

说明

被动警告以图表控件左下角的小感叹号表示。单击该符号可显示有关发生的非严重错误的详细信息。该功能与 Microsoft Internet Explorer 的一项功能类似，该功能在发生脚本错误时状态栏将显示警告符号。


HasPercentage 属性

如果指定系列或图表的所有数据标志当前显示其百分比值，则返回 True。默认值为 False。该属性只适用于饼图、圆环图和堆积图。Boolean 类型，可读写。

expression.HasPercentage

expression 必需。该表达式返回一个 ChDataLabels 对象。

说明

数据标志组件总是按照以下顺序显示：[SeriesName] [CategoryName] [Value] [BubbleSize] [Percentage]。

示例

本示例在系列中添加显示百分比值的数据标志。请注意 Charts(0) 必须为饼图、圆环图或堆积图。

Sub AddPercentabeLabels()
    Dim dl

    Set dl = ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection.Add

    ' Display percentage labels.
    dl.HasPercentage = True
End Sub


HasPlotDetails 属性

如果图表中不包含分类字段将绘制明细字段，则返回 True。默认值为 False。Boolean 类型，可读写。

expression.HasPlotDetails

expression 必需。该表达式返回一个 ChartSpace 对象。

示例

本示例启用当图表中不包含分类字段时在 ChartSpace1 绘制明细字段。

ChartSpace1.HasPlotDetails = True


HasRuntimeSelection 属性

返回或设置指定图表控件的图表选定模式。如果该属性为 True，则第一次单击将选定内部对象，而第二次单击将选定外部对象。例如，如果该属性为 True 并且用户单击了数据系列中的第三个数据点，则只选定该点。当用户第二次单击数据点时，将选定整个数据系列。设置该属性为 False，将强制在用户第一次单击第三个数据点时即选定整个数据系列。用户必须再次单击第三个数据点以只选定数据点。默认值为 True。Boolean 类型，可读写。

expression.HasRuntimeSelection

expression 必需。该表达式返回一个 ChartSpace 对象。


HasSelectionMarks 属性

设置该属性为 True 将在用户选定图表项时显示选定标记。默认值为 False。Boolean 类型，可读写。

expression.HasSelectionMarks

expression 必需。该表达式返回一个 ChartSpace 对象。

说明

除了将该属性设置为 True 以外，还必须将 AllowPropertyToolbox 属性设置为 True 以允许用户设置单个图表元素的格式。

示例

本示例使用户可以选择并设置 Chartspace1 中的单个图表元素。

Sub Allow_Formatting()

   'Allow the user to display the Commands and Options dialog box.
   Chartspace1.AllowPropertyToolbox = True

   ' Display selection marks for chart elements.
   Chartspace1.HasSelectionMarks = True

End Sub


HasSeriesByRows 属性

返回或设置指定图表控件中图表的系列和分类与数据源的行和列的映射方式。在默认情况下，如果图表绑定到关系数据源，则图表系列与基础数据透视表列表中的列相对应。默认值为 False。Boolean 类型，可读写。

expression.HasSeriesByRows

expression 必需。该表达式返回一个 ChartSpace 控件。


HasSeriesName 属性

如果指定系列或图表的所有数据标志当前显示其系列名称，则返回 True。默认值为 False。该属性只适用于饼图、圆环图和堆积图。Boolean 类型，可读写。

expression.HasSeriesName

expression 必需。该表达式返回一个 ChDataLabels 对象。

说明

数据标志组件总是按照以下顺序显示：[SeriesName] [CategoryName] [Value] [BubbleSize] [Percentage]。

示例

本示例使指定系列的数据标志显示其类别和系列名称。

Sub ShowLabels()
    Dim dl

    Set dl = ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection(0)

    ' Display the category names.
    dl.HasCategoryName = True

    ' Display the series names.
    dl.HasSeriesName = True
End Sub


HasSplit 属性

如果指定坐标轴的刻度在其 SplitMinimum 属性值和 SplitMaximum 属性值之间具有拆分顶点，则返回 True。默认值为 False。Boolean 类型，可读写。

expression.HasSplit

expression 必需。该表达式返回一个 ChScaling 对象。

示例

本示例拆分 ChartSpace1 中第一个图表的数值轴，并设置最小拆分值和最大拆分值。数值轴经过拆分并且 1000 到 5000 之间的值将不显示。

Sub Split_Value_Axis()
    Dim chConstants
    Dim scValueAxis

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the scaling object of the value axis.
    Set scValueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue).Scaling

    ' Add a split to the value axis.
    scValueAxis.HasSplit = True

    ' Specify the minnimum value of the split.
    scValueAxis.SplitMinimum = 1000

    '  Specify the maximum value for the split.
    scValueAxis.SplitMaximum = 5000
End Sub


HasTickLabels 属性

如果指定坐标轴在每个主要刻度线处均具有标签，则返回 True。默认值为 True。Boolean 类型，可读写。

expression.HasTickLabels

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例关闭 ChartSpace1 中第一个图表上分类轴的刻度线标签。

Sub DisableTickLabels()
    Dim chConstants

    Set chConstants = ChartSpace1.Constants

    ' Turn off the tick mark labels on the category axis.
    ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionCategory).HasTickLabels = False
End Sub


HasTitle 属性

如果指定图表或坐标轴具有标题，则返回 True。默认值为 False。Boolean 类型，可读写。

expression.HasTitle

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例使指定图表显示标题并设置标题字体。

Sub SetChartTitle()

    ' Enable the chart title for the first chart in ChartSpace1.
    ChartSpace1.Charts(0).HasTitle = True

    ' Set the title caption.
    ChartSpace1.Charts(0).Title.Caption = "Monthly Sales"

    ' Set the title font.
    ChartSpace1.Charts(0).Title.Font.Name = "times new roman"
End Sub


HasUnifiedScales 属性

如果指定图表控件中所有图表的坐标轴使用相同的刻度，则返回 True。默认值为 False。Boolean 类型，可读写。

expression.HasUnifiedScales

expression 必需。该表达式返回一个 ChartSpace 对象。

说明

如果图表控件包含多个具有不兼容的坐标轴的图表，则该属性将返回运行时出错。例如，如果图表控件包含 XY 散点图和柱形图将返回错误。不能设置该属性是因为柱形图包含分类轴，而 XY 散点图没有。

如果在将该属性设置为 True 后，使用 Add 方法在图表控件中新添图表，则新图表的坐标轴不会自动与已有图表的相一致。必须将该属性设置为 False，然后再设置为 True 才能使新图表的坐标轴与已有图表的相一致。


HasValue 属性

如果指定系列或图表的所有数据标志当前显示其 y 轴数值，则返回 True。默认值为 False。Boolean 类型，可读写。

expression.HasValue

expression 必需。该表达式返回一个 ChDataLabels 对象。

说明

数据标志组件总是按照以下顺序显示：[SeriesName] [CategoryName] [Value] [BubbleSize] [Percentage]。

设置散点图或极坐标图的该属性为 True 将同时显示 x 轴和 y 轴数值。

示例

本示例设置指定系列的数据标志显示其 y 轴数值。

ChartSpace1.Charts(0).SeriesCollection(0).DataLabelsCollection(0)HasValue = True


HeaderBackColor 属性

返回或设置一个 Variant 类型，指定数据区域标题或筛选区域项的背景色。可读写。

expression.HeaderBackColor

expression 必需。该表达式返回一个 PivotView 对象。

说明

在设置该属性时，既可以使用表示红绿蓝颜色的 Long 类型值，也可以使用命名有效 HTML 颜色值的 String 类型值。例如，要将对象颜色设置为红色，可以使用十六进制值 &HFF、十进制值 255 或字符串值 "red"。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝颜色值（红色为 RGB(255,0,0)）。

除该属性外，请使用 HeaderFont、HeaderForeColor 和 HeaderHAlignment 属性设置数据透视表列表中数据区域标题或筛选区域项的格式。

示例

本示例设置 PivotTable1 当前视图中数据区域和筛选区域的标题格式。

Sub SetHeaderProperties()

    Dim ptView
    Dim ptConstants

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the current PivotTable view.
    Set ptView = PivotTable1.ActiveView

    ' Set the background color.
    ptView.HeaderBackColor = "Gray"

    ' Set the foreground color.
    ptView.HeaderForeColor = "Blue"

    ' Set the font.
    ptView.HeaderFont = "Tahoma"

    ' Set the alignment.
    ptView.HeaderHAlignment = ptConstants.plHAlignLeft

End Sub


HeaderFont 属性

返回一个 PivotFont 对象，表示指定视图数据区域标题或筛选区域项的字体。可读写。

expression.HeaderFont

expression 必需。该表达式返回一个 PivotView 对象。

说明

除该属性外，请使用 HeaderBackColor、HeaderForeColor 和 HeaderHAlignment 属性设置数据透视表列表中数据区域标题或筛选区域项的格式。

示例

本示例设置 PivotTable1 当前视图中数据区域和筛选区域的标题格式。

Sub SetHeaderProperties()

    Dim ptView
    Dim ptConstants

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the current PivotTable view.
    Set ptView = PivotTable1.ActiveView

    ' Set the background color.
    ptView.HeaderBackColor = "Gray"

    ' Set the foreground color.
    ptView.HeaderForeColor = "Blue"

    ' Set the font.
    ptView.HeaderFont = "Tahoma"

    ' Set the alignment.
    ptView.HeaderHAlignment = ptConstants.plHAlignLeft

End Sub


HeaderForeColor 属性

返回或设置一个 Variant 类型，指定数据区域标题或筛选区域项的前景色。可读写。

expression.HeaderForeColor

expression 必需。该表达式返回一个 PivotView 对象。

说明

在设置该属性时，既可以使用表示红绿蓝颜色的 Long 类型值，也可以使用命名有效 HTML 颜色值的 String 类型值。例如，要将对象颜色设置为红色，可以使用十六进制值 &HFF、十进制值 255 或字符串值 "red"。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝颜色值（红色为 RGB(255,0,0)）。

除该属性外，请使用 HeaderBackColor、HeaderFont 和 HeaderHAlignment 属性设置数据透视表列表中数据区域标题或筛选区域项的格式。

示例

本示例设置 PivotTable1 当前视图中数据区域和筛选区域的标题格式。

Sub SetHeaderProperties()

    Dim ptView
    Dim ptConstants

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the current PivotTable view.
    Set ptView = PivotTable1.ActiveView

    ' Set the background color.
    ptView.HeaderBackColor = "Gray"

    ' Set the foreground color.
    ptView.HeaderForeColor = "Blue"

    ' Set the font.
    ptView.HeaderFont = "Tahoma"

    ' Set the alignment.
    ptView.HeaderHAlignment = ptConstants.plHAlignLeft

End Sub


HeaderHAlignment 属性

返回或设置一个 PivotHAlignmentEnum 常量，表示指定视图数据区域标题或筛选区域项的水平对齐方式。可读写。

PivotHAlignmentEnum 可以为下列 PivotHAlignmentEnum 常量之一。
plHAlignAutomatic
plHAlignCenter
plHAlignLeft
plHAlignRight

expression.HeaderHAlignment

expression 必需。该表达式返回一个 PivotView 对象。

说明

除该属性外，请使用 HeaderBackColor、HeaderForeColor 和 HeaderFont 属性设置数据透视表列表中数据区域标题或筛选区域项的格式。

示例

本示例设置 PivotTable1 当前视图中数据区域和筛选区域的标题格式。

Sub SetHeaderProperties()

    Dim ptView
    Dim ptConstants

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the current PivotTable view.
    Set ptView = PivotTable1.ActiveView

    ' Set the background color.
    ptView.HeaderBackColor = "Gray"

    ' Set the foreground color.
    ptView.HeaderForeColor = "Blue"

    ' Set the font.
    ptView.HeaderFont = "Tahoma"

    ' Set the alignment.
    ptView.HeaderHAlignment = ptConstants.plHAlignLeft

End Sub


HeaderHeight 属性

返回一个 Long 类型，表示指定视图数据轴上的字段标题或筛选字段中的项的高度。只读。

expression.HeaderHeight

expression 必需。该表达式返回一个 PivotView 对象。


HeaderRowRange 属性

返回一个 Range 对象，代表指定 ListObject 对象的标题行。只读。

expression.HeaderRowRange

expression 必需。该表达式返回一个 ListObject 对象。

说明

如果显示了标题行，则返回代表指定 ListObject 对象标题行的 Range 对象。如果未显示标题行，则返回 Nothing 对象。

示例

以下示例将标题行区域信息保存到一个变量中。

Dim rngHeaderRowRange
Dim objList

Set  objList = Spreadsheet1.ActiveSheet.ListObjects(1)
Set rngHeaderRowRange = objList.HeaderRowRange


Height 属性

以磅值返回或设置指定对象的高度。

  • 对于 Window 对象为 Double 类型，只读。

  • 对于 Range 对象为 Variant 类型，只读。

  • PivotAxisMember、PivotColumnMember、PivotPageMember、PivotRowMember 和 PivotTable 对象的 Long 类型，可读写。

  • 对于“应用于”列表中的所有其他对象为 Long 类型，只读。

expression.Height

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

数据透视表列表的 AutoFit 属性在更改 Height 属性时设置为 False。

示例

本示例设置数据透视表列表的高度为 36 磅。

PivotTable1.Object.Height = 36


HeightRatio 属性

返回或设置图表工作区中指定图表相对于其他图表的高度比率。默认值为 100。 Long 类型，可读写。

expression.HeightRatio

expression 必需。该表达式返回一个 ChChart 对象。

说明

该属性设置图表工作区中指定图表相对于其他图表的高度。要使该属性生效，图表工作区中必须有多个图表。当显示多个图表时，这些图表在一个网格中显示（有关详细信息，请参阅 ChartLayout 和 ChartWrapCount 属性的帮助主题）。初始情况下，网格中所有图表的 HeightRatio 和 WidthRatio 属性均设置为 100，即所有图表具有同样大小。

要更改网格中图表的高度，请调整 HeightRatio 属性设置。例如，如果各个图表以三行显示，并且所有图表的初始 HeightRatio 属性设置为 100。如果希望第 3 行图表只有一半可用高度，可设置其 HeightRatio 属性为 200；剩下的一半图表高度分配给第 1 行和第 2 行。由于 HeightRatio 属性指定的高度是相对的，因此可以将三行属性设置为 1,1,2、100,100,200 或 20,20,40，它们具有相同效果。

如果图表工作区中包含显示超过一行的图表，则每行的最大 HeightRatio 设置用于设置整行的相对高度。

该属性对于创建价格和成交量图表非常有用，其中成交量图表为价格图表一半大小。


Hidden 属性

如果指定区域当前处于隐藏状态，则返回 True。区域必须跨越整列或整行。可以使用 EntireRow 和 EntireColumn 属性返回对整行或整列的引用。Boolean 类型，可读写。

expression.Hidden

expression 必需。该表达式返回一个 Range 对象。

示例

本示例在包含数值的一行中循环。如果单元格中的月份不是当前月份，则隐藏该列。如果月份为当前月份，而该列处于隐藏状态，则显示该列。

Sub Hide_Dates()
    Dim rngLoopRange
    Dim rngCurrCell
    Dim ssConstants

    Set ssConstants = Spreadsheet1.Constants

    ' Set range to loop through the range of contiguous
    ' cells in row 1 starting in column A.
    Set rngLoopRange = Spreadsheet1.ActiveSheet.Range("A1", _
            Spreadsheet1.ActiveSheet.Range("A1").End(ssConstants.xlToRight))

    ' Loop through the cells.
    For Each rngCurrCell In rngLoopRange

        ' Hide the column if the month in the current cell does
        ' not match the current month.
        If Month(rngCurrCell.Value) <> Month(Date) Then
            rngCurrCell.EntireColumn.Hidden = True

        ' If the month in the current cell matches the current month
        ' and the column is hidden, then unhide the column.
        ElseIf rngCurrCell.EntireColumn.Hidden Then
            rngCurrCell.EntireColumn.Hidden = False
        End If
    Next
End Sub


HoleSize 属性

返回或设置指定圆环图的内径大小。内径大小必须为 0 到 90（默认值为 50）之间的值。Long 类型，可读写。

expression.HoleSize

expression 必需。该表达式返回一个 ChChart 对象。

说明

将该属性设置为零 (0) 可使圆环图变为饼图（ChChart 对象的 Type 属性将返回 chChartTypePieStacked）。

示例

本示例设置指定图表的内径大小。请注意 Charts(0) 必须为圆环图。

ChartSpace1.Charts(0).HoleSize = 25


HorizontalAlignment 属性

返回或设置一个 Variant 类型，表示指定区域的水平对齐方式。可为 XlHAlign 常量。

XlHAlign 可以为下列 XlHAlign 常量之一。
xlHAlignGeneral
xlHAlignCenter
xlHAlignLeft
xlHAlignRight

expression.HorizontalAlignment

expression 必需。该表达式返回一个 Range 对象。

示例

本示例将 Sheet1 的区域 A1:A5 设置为左对齐。

Sub AlignRange()

   Dim ssConstants
   Set ssConstants = Spreadsheet1.Constants

   Worksheets("Sheet1").Range("A1:A5").HorizontalAlignment = ssConstants.xlHAlignLeft

End Sub


HorizontalExtent 属性

使用 HorizontalExtent 属性可指定或确定 ChScrollView 对象水平视图的宽度。返回一个 Long 值。Long 类型，可读写。

expression.HorizontalExtent

expression 必需。该表达式返回一个 ChScrollView 对象。

说明

使用 ChScrollView 对象的方法和属性可检索图表视图的有关信息和控制图表视图。Chart 组件显示图表本身的部分为可见绘图区，可显示整个图表或部分图表。仅在可见绘图区显示部分图表时，与放大该图表部分时的效果相同，剩余图表部分包含在扩展可见绘图区边界所得的虚拟绘图区中。有关 ChScrollView 对象的属性值是如何彼此关联的信息，请参阅 ChScrollView 对象主题。

示例

以下示例使用 HorizontalExtent 和 HorizontalExtentMax 属性在缩放和未缩放（水平）之间切换图表视图。在本示例中，Chart 组件的名称为 ChartSpace1。

Sub ZoomView()
    Dim lngHEM

    lngHEM = Chartspace1.Charts(0).ScrollView.HorizontalExtentMax

    If Chartspace1.Charts(0).ScrollView.HorizontalExtent = lngHEM Then
          ' Zoom the chart.
          Chartspace1.Charts(0).ScrollView.HorizontalExtent = (lngHEM / 3)
    Else
          ' Zoom out on the chart.
          Chartspace1.Charts(0).ScrollView.HorizontalExtent = lngHEM
    End If
End Sub


HorizontalExtentMax 属性

使用该属性可指定或确定 ChScrollView 对象水平视图的最大宽度。返回一个 Long 值。Long 类型，可读写。

expression.HorizontalExtentMax

expression 必需。该表达式返回一个 ChScrollView 对象。

说明

使用 ChScrollView 对象的方法和属性可检索图表视图的有关信息和控制图表视图。Chart 组件显示图表本身的部分为可见绘图区，可显示整个图表或部分图表。仅在可见绘图区显示部分图表时，与放大该图表部分时的效果相同，剩余图表部分包含在扩展可见绘图区边界所得的虚拟绘图区中。HorizontalExtentMax 属性表示图表的总高度，而不管图表缩放与否。有关 ChScrollView 对象的属性值是如何彼此关联的信息，请参阅 ChScrollView 对象主题。

示例

以下示例使用 HorizontalExtent 和 HorizontalExtentMax 属性在缩放和未缩放（水平）之间切换图表视图。在本示例中，Chart 组件的名称为 ChartSpace1。

Sub ZoomView()
    Dim lngHEM

    lngHEM = Chartspace1.Charts(0).ScrollView.HorizontalExtentMax

    If Chartspace1.Charts(0).ScrollView.HorizontalExtent = lngHEM Then
          ' Zoom the chart.
          Chartspace1.Charts(0).ScrollView.HorizontalExtent = (lngHEM / 3)
    Else
          ' Zoom out on the chart.
          Chartspace1.Charts(0).ScrollView.HorizontalExtent = lngHEM
    End If
End Sub


HorizontalPosition 属性

使用 HorizontalPosition 属性可指定或确定 ChScrollView 对象水平视图的当前位置。返回一个 Long 值。Long 类型，可读写。

expression.HorizontalPosition

expression 必需。该表达式返回一个 ChScrollView 对象。

说明

使用 ChScrollView 对象的方法和属性可检索图表视图的有关信息和控制图表视图。Chart 组件显示图表本身的部分为可见绘图区，可显示整个图表或部分图表。仅在可见绘图区显示部分图表时，与放大该图表部分时的效果相同，剩余图表部分包含在扩展可见绘图区边界所得的虚拟绘图区中。有关 ChScrollView 对象的属性值是如何彼此关联的信息，请参阅 ChScrollView 对象主题。

HorizontalPosition 属性提供图表水平位置的有关信息。Chart 组件可见区域的最左端为 0，可见区域的最右端为 HorizontalPosition 属性值等于 HorizontalExtentMax 属性的位置（尽管可将 HorizontalPosition 属性值设置为大于 HorizontalExtentMax 属性值，甚至设置为负值）。只要 HorizontalExtent 属性值大于 HorizontalExtentMax 属性值，则整个视图都可见。

当 HorizontalPosition 属性等于零时，绘图区的最左端将位于滚动视图窗口的最左端。当 HorizontalPosition 等于 HorizontalExtentMax 时，绘图区将左移以在滚动视图窗口的左侧显示绘图区的右侧部分。HorizontalPosition 属性可为负数。例如，如果 HorizontalPosition = (-0.25 * HorizontalExtentMax)，则绘图区将按绘图区虚拟宽度的 25% 右移。

示例

以下示例更改 Chart 组件（在本示例中名为 ChartSpace1）滚动视图的水平和垂直位置。

Dim lngHorizontal
Dim lngVertical

lngHorizontal = ChartSpace1.Charts(0)ScrollView.HorizontalPosition
lngVertical = ChartSpace1.Charts(0)ScrollView.VerticalPosition

ChartSpace1.Charts(0)ScrollView.SetPosition lngHorizontal + 300, lngVertical + 200


HTMLContainer 属性

返回包含指定节的 HTML DIV 元素。只读。

expression.HTMLContainer

expression 必需。该表达式 返回一个 Section 对象。


HTMLData 属性

对于 PivotTable 和 Range 对象：返回一个 String 类型，以正确格式的 HTML 字符串表示指定数据透视表列表或区域。只读。

对于 Spreadsheet 对象：返回或设置一个 String 类型，以正确格式的 HTML 字符串表示电子表格数据。可读写。

expression.HTMLData

expression 必需。该表达式返回“应用于”列表中的对象之一。


HTMLURL 属性

返回或设置电子表格 HTML 数据文件的 URL（Internet 地址）。String 类型，可读写。

expression.HTMLURL

expression 必需。该表达式 返回一个 Spreadsheet 对象。


Hwnd 属性

返回一个 Long 类型，表示数据透视表控件窗口的顶层窗口句柄。只读。

expression.Hwnd

expression 必需。该表达式返回一个 PivotTable 对象。


Hyperlink 属性

对于 PivotAxisMember、PivotColumnMember、PivotDetailCell、PivotPageMember 和 PivotRowMember 对象：返回一个 PivotHyperlink 对象，表示指定对象的超链接。

对于 Range 对象：返回一个 Hyperlink 对象，表示指定区域的超链接。

expression.Hyperlink

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例解析活动工作表上单元格 B15 中的超链接，下载目标文件，然后显示文档。

Spreadsheet1.ActiveSheet.Range("b15").Hyperlink.Follow


id 属性

返回一个 Long 类型，表示自定义图形对象的标识符。只读。

expression.id

expression 必需。该表达式返回一个 ChUserDefinedSelection 对象。


Inclination 属性

返回或设置一个 Double 类型，表示指定三维图表的视图斜率。有效范围为 -90 到 90。可读写。

expression.Inclination

expression 必需。该表达式返回一个 ChChart 对象。

说明

设置该属性为 90 将得到指定图表的顶视图。

示例

本示例将 Chartspace1 中的第一个图表转换为三维柱形图，然后设置视图的斜率。

Sub SetGapDepth()

    Dim cht3DColumn As ChChart

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DColumn = ChartSpace1.Charts(0)

    ' Change the chart to a 3-D Column chart.
    cht3DColumn.Type = chChartTypeColumn3D

    ' Set the inclination.
    cht3DColumn.Inclination = 45

End Sub


Include 属性

返回或设置将包含于指定图表的误差线元素。默认值为 chErrorBarIncludeBoth。ChartErrorBarIncludeEnum 类型，可读写。

ChartErrorBarIncludeEnum 可为以下 ChartErrorBarIncludeEnum 常量之一：
chErrorBarIncludeBoth
chErrorBarIncludeMinusValues
chErrorBarIncludePlusValues

expression.Include

expression 必需。该表达式返回一个 ChErrorBars 对象。

示例

本示例在指定图表上添加误差线，并设置误差线只显示正值。

Sub Format_ErrorBars()
    Dim chConstants
    Dim ebErrorBars

    Set chConstants = ChartSpace1.Constants

    ' Add error bars to the first series in the first chart.
    Set ebErrorBars = ChartSpace1.Charts(0).SeriesCollection(0).ErrorBarsCollection.Add

    ' Include positive values.
    ebErrorBars.Include = chConstants.chErrorBarIncludePlusValues
End Sub


IncludedMembers 属性

返回或设置指定字段中显示的成员。该属性可以设置为单个成员或成员的 Variant 数组。成员可以一个或多个 PivotMember 对象、成员名称或唯一名称传递。可读写。

expression.IncludedMembers

expression 必需。该表达式返回一个 PivotField 对象。

说明

如果包括了在设置该属性时未包括的成员的父成员，则该成员仍将显示在数据透视表列表中。设置该属性可清除以前对指定字段的所有设置。可以将该属性设置为 Empty (IncludedMembers = Empty) 或空 Variant 数组 (IncludedMembers = Array()) 以清除指定字段包含的成员列表。

示例

本示例设置 PivotTable1 中 Store State 和 Store City 字段的包括和排除成员。

Sub Member_Filtering()

    Dim fldStoreCity
    Dim fldStoreState
    Dim ptView

    ' Set a variable to the current PivotTable view.
    Set ptView = PivotTable1.ActiveView

    ' Set a variable to the Store State field.
    Set fldStoreState = ptView.FieldSets("Store").Fields("Store State")

    ' Set a variable to the Store City field.
    Set fldStoreCity = ptView.FieldSets("Store").Fields("Store City")

    ' Exclude California and Washington from the Store State field.
    fldStoreState.ExcludedMembers = Array("CA", "WA")

    ' Include members of the Store City field. Note that the cities are
    ' in states that have been excluded by the previous line. Since
    ' Store State is a parent to Store City, then the excluded states
    ' are displayed in the PivotTable.
    fldStoreCity.IncludedMembers = Array("Los Angeles", "San Diego", _
                                         "Seattle", "Spokane")

End Sub


Index 属性

返回相似对象集合中指定对象的索引号码。对于 ChSeries 对象为 Long 类型，可读写；对于“应用于”列表中的所有其他对象为 Long 类型，只读。

expression.Index

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

可设置 ChSeries 对象的索引号码。指定的系列移动到指定位置，其他系列进行必要的重新排序。

ListRow 对象的索引值与其在 XML 列表中的当前位置相对应。排序或者添加或删除行后，根据其新位置，给定的行可能具有新的索引值。

示例

本示例将包含 6 个系列的 XY 散点图中的系列 1 移动到第四个索引位置。在移动过程中，系列 2 到 4 重新排序为系列 1 到 3。系列 0 和系列 5 保持在原来位置。

ChartSpace1.Charts(0).SeriesCollection(1).Index = 4


InsertRowRange 属性

从指定的 ListObject 对象中返回插入行（如果存在）的 Range 对象。只读。

expression.InsertRowRange

expression 必需。该表达式返回一个 ListObject 对象。

说明

不支持某些 Range 属性和方法。不支持的属性包括 Locked、MergeArea 和 MergeCells。不支持的方法包括 Delete、Insert、Merge 和 UnMerge。如果插入行当前不可见，则将返回 Nothing 对象。

可使用 InsertRowRange 属性引用插入行中的任何单元格。只有在为 XML 列表添加了新行后，才会保存 InsertRowRange 属性所返回的 Range 边框属性。

示例

以下示例获取插入行范围信息并显示该信息。

Dim rngInsertRow
Dim objList

Set objList = Spreadsheet1.Worksheets(1).ListObjects(1)

' Save the insert range information to a variable.
Set rngInsertRow = objList.InsertRowRange

MsgBox ("The insert row range is: " & Chr(10) & rngInsertRow.Address)


Interior 属性

显示 Interior 属性应用于 ChartSpace、ChChart、ChChartDraw、ChDataLabel、ChDataLabels、ChLegend、ChPlotArea、ChPoint、ChSegmentBoundary、ChSeries、ChSurface 和 ChTitle 对象的情形。

返回一个 ChInterior 对象，表示指定对象的内部。

expression.Interior

expression 必需。该表达式返回上面对象之一。

显示 Interior 属性应用于 Range 和 TitleBar 对象的情形。

返回一个 Interior 对象，表示指定对象的内部。

expression.Interior

expression 必需。该表达式返回上面对象之一。

示例

本示例设置指定系列的内部颜色。

ChartSpace1.Charts(0).SeriesCollection(0).Interior.Color = "red"


InternalPivotTable 属性

返回图表控件内部用于绑定外部数据源的 PivotTable 对象。

expression.InternalPivotTable

expression 必需。该表达式返回一个 ChartSpace 对象。


International 属性

返回当前的国家/地区和国际设置信息。Variant 类型，只读。

expression.International(Index)

expression 必需。该表达式返回一个 Spreadsheet 或 ChartSpace 对象。

Index Long 类型，必需。要返回的设置。可以为下表所列的 XlApplicationInternational 常量之一。

索引 | 类型 | 含义
xlCountryCode | Long | Microsoft Office Web Components 的国家/地区版本。
xlCountrySetting | Long | “控制面板”中的当前地区设置。
xlDecimalSeparator | String | 小数分隔符。
xlThousandsSeparator | String | 零或千位分隔符。
xlListSeparator | String | 列表分隔符。
xlUpperCaseRowLetter | String | 大写行字母（对于 R1C1-样式引用）。
xlUpperCaseColumnLetter | String | 大写列字母。
xlLowerCaseRowLetter | String | 小写行字母。
xlLowerCaseColumnLetter | String | 小写列字母。
xlLeftBracket | String | 在 R1C1-样式相对引用中左方括号 ([) 的替代字符。
xlRightBracket | String | 在 R1C1-样式相对引用中右方括号 (]) 的替代字符。
xlLeftBrace | String | 在 R1C1-样式相对引用中左大括号 ({) 的替代字符。
xlRightBrace | String | 在 R1C1-样式相对引用中右大括号 (}) 的替代字符。
xlColumnSeparator | String | 数组文字类型的列分隔符。
xlRowSeparator | String | 数组文字类型的行分隔符。
xlAlternateArraySeparator | String | 如果当前数组分隔符与小数分隔符相同时替代的数组项分隔符。
xlDateSeparator | String | 日期分隔符 (/)。
xlTimeSeparator | String | 时间分隔符 (:)。
xlYearCode | String | 数字格式中的年符号 (y)。
xlMonthCode | String | 月符号 (m)。
xlDayCode | String | 日符号 (d)。
xlHourCode | String | 小时符号 (h)。
xlMinuteCode | String | 分钟符号 (m)。
xlSecondCode | String | 秒符号 (s)。
xlCurrencyCode | String | 货币符号。
xlGeneralFormatName | String | “常规”数字格式名称。
xlCurrencyDigits | Long | 货币格式中的小数位数。
xlCurrencyNegative | Long | 负数货币值的货币格式： 0 = (symbolx) 或 (xsymbol) 1 = -symbolx 或 -xsymbol 2 = symbol-x 或 x-symbol 3 = symbolx- 或 xsymbol- 其中 symbol 为国家/地区的货币符号。请注意货币符号的位置由 xlCurrencyBefore 决定。
xlNoncurrencyDigits | Long | 非货币格式的小数位数。
xlMonthNameChars | Long | 为了向后兼容总是返回三个字符。月份名称的缩写从 Microsoft Windows 中读取并且可以为任意长度。
xlWeekdayNameChars | Long | 为了向后兼容总是返回三个字符。星期名称的缩写从 Microsoft Windows 中读取并且可以为任意长度。
xlDateOrder | Long | 日期元素的次序： 0 = 月-日-年 1 = 日-月-年 2 = 年-月-日
xl24HourClock | Boolean | 如果使用 24 小时制时间，则返回 True；如果使用 12 小时时间，则返回 False。
xlNonEnglishFunctions | Boolean | 如果不以英文显示函数，则返回 True。
xlMetric | Boolean | 如果使用米制度量系统，则返回 True；如果使用英制度量系统，则返回 False。
xlCurrencySpaceBefore | Boolean | 如果在货币符号前面添加空格，则返回 True。
xlCurrencyBefore | Boolean | 如果货币符号在货币值之前，则返回 True；如果货币符号在货币值之后，则返回 False。
xlCurrencyMinusSign | Boolean | 如果对负数使用负号，则返回 True；如果使用括号，则返回 False。
xlCurrencyTrailingZeros | Boolean | 如果显示零货币值的尾部零，则返回 True。
xlCurrencyLeadingZeros | Boolean | 如果显示零货币值的前导零，则返回 True。
xlMonthLeadingZero | Boolean | 如果以数字显示月份时显示月份中的前导零，则返回 True。
xlDayLeadingZero | Boolean | 如果在日期中显示前导零，则返回 True。
xl4DigitYears | Boolean | 如果使用四位年，则返回 True；如果使用两位年，则返回 False。
xlMDY | Boolean | 如果长日期显示中日期次序为月-日-年，则返回 True；如果次序为日-月-年，则返回 False。
xlTimeLeadingZero | Boolean | 如果日期中显示前导零，则返回 True。

说明

上表显示的符号、分隔符和货币格式可能因所用语言和地理位置而异，而且可能不可用，这取决于选择或安装的语言支持（例如，美国英语）。


IsConsistent 属性

返回一个 Boolean 类型，表示源数据集是否与指定 PivotData 对象一致。只读。

expression.IsConsistent

expression 必需。该表达式返回一个 PivotData 对象。

说明

如果已经提交对数据集的更改但未更新总计，则该属性返回 False。发生上述情况时，请使用 PivotTable 对象的 Refresh 方法更新总计。


IsDataBound 属性

返回或设置一个 Boolean 类型，确定指定工作表是否绑定到外部数据源。可读写。

expression.IsDataBound

expression 必需。该表达式返回一个 Worksheet 对象。


IsDirty 属性

返回或设置一个 Boolean 类型，表示数据透视表列表从上次保存后是否发生更改。可读写。

expression.IsDirty

expression 必需。该表达式返回一个 PivotTable 对象。


IsDisplayingEquation 属性

如果图表上显示了指定系列的趋势线公式，则返回 True（与 R 平方值在同一数据标志内）。默认值为 True。Boolean 类型，可读写。

expression.IsDisplayingEquation

expression 必需。该表达式返回一个 ChTrendline 对象。

示例

本示例在指定系列添加趋势线。只显示趋势线公式。

Sub AddTrendLine()
    Dim trndline

    ' Add a trendline to the first series in the first chart in ChartSpace1.
    Set trndline = ChartSpace1.Charts(0).SeriesCollection(0).Trendlines.Add

    ' Set the font of the trendline to bold.
    trndline.DataLabel.Font.Bold = True

    ' Do not display the R-Squared value with the trendline.
    trndline.IsDisplayingRSquared = False

    ' Display the equation for the trendline.
    trndline.IsDisplayingEquation = True
End Sub


IsDisplayingRSquared 属性

如果图表上显示了指定系列的 R 平方值，则返回 True（与公式在同一数据标志）。将该属性设置为 True 将自动启用数据标志。默认值为 True。Boolean 类型，可读写。

expression.IsDisplayingRSquared

expression 必需。该表达式返回一个 ChTrendline 对象。

示例

本示例在指定系列添加趋势线。只显示趋势线公式。

Sub AddTrendLine()
    Dim trndline

    ' Add a trendline to the first series in the first chart in ChartSpace1.
    Set trndline = ChartSpace1.Charts(0).SeriesCollection(0).Trendlines.Add

    ' Set the font of the trendline to bold.
    trndline.DataLabel.Font.Bold = True

    ' Do not display the R-Squared value with the trendline.
    trndline.IsDisplayingRSquared = False

    ' Display the equation for the trendline.
    trndline.IsDisplayingEquation = True
End Sub


IsExpanded 属性

如果指定节处于展开状态，则返回 True。Boolean 类型，只读。

expression.IsExpanded

expression 必需。该表达式返回一个 Section 对象。


IsFiltered 属性

如果应用了当前筛选，则返回 True。默认值为 True。Boolean 类型，可读写。

expression.IsFiltered

expression 必需。该表达式返回一个 PivotView 对象。


IsFilterOn 属性

如果应用了数据访问页筛选，则返回 True。Boolean 类型，可读写。

expression.IsFilterOn

expression 必需。该表达式返回一个 DataPage 对象。


IsHyperlink 属性

显示 IsHyperlink 属性应用于 PivotField 对象的情形。

返回或设置是否将指定字段中的项作为超链接处理。将该属性设置为 True 以将指定字段中的项作为超链接处理。默认值为 False。Boolean 类型，可读写。

expression.IsHyperlink

expression 必需。该表达式返回一个 PivotField 对象。

显示 IsHyperlink 属性应用于 SchemaField 和 SchemaParameter 对象的情形。

返回指定字段是否包含超链接。Boolean 类型，只读。

expression.IsHyperlink

expression 必需。该表达式返回上面对象之一。

示例

显示 应用于 PivotField 对象的情形。

本示例将 PivotTable1 中 Merchant 字段的项转换为超链接。

PivotTable1.ActiveView.FieldSets("Merchant") _
    .Fields(0).IsHyperlink = True


IsIncluded 属性

如果字段包含于指定字段集并处于活动状态，则返回 True。Boolean 类型，可读写。

expression.IsIncluded

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

“数据透视表”列表中不显示非活动字段。字段集必须至少有一个字段的 IsIncluded 属性设置为 True。如果试图将该属性为 True 的唯一字段设置为 False，将产生运行错误。字段集用于筛选轴时将忽略该属性。如果用户隐藏了用户界面上最后一个字段，则字段集将从坐标轴被删除。


IsTotal 属性

如果指定成员用于显示一个分类汇总，则返回 True。Boolean 类型，只读。

expression.IsTotal

expression 必需。该表达式返回“应用于”列表中的对象之一。


IsValid 属性

返回一个 Boolean 类型，表示指定成员是否为指定上下文的有效成员。只读。

expression.IsValid

expression 必需。该表达式返回一个 PivotMember 对象。

示例

本示例试图在 Warehouse 字段集中查找指定仓库。如果没有找到指定仓库，将警告用户。

Sub FindWarehouse()

    Dim ptView
    Dim ptConstants
    Dim fsWarehouse
    Dim pmFound

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view.
    Set ptView = PivotTable1.ActiveView

    ' Set a variable to the Warehouse field set.
    Set fsWarehouse = ptView.FieldSets("Warehouse")

    ' Set a variable to the results of the FindMember property.
    Set pmFound = fsWarehouse.FindMember("Quality Distribution, Inc.", ptConstants.plFindFormatPathName)

    ' Check to see if the member was found.
    If pmFound.IsValid = False Then

        ' Alert the user if the member was not found.
        MsgBox "The specified member does not exist."

    End If

End Sub


Italic 属性

如果字体样式为斜体，则返回 True。对于 ChFont 和 PivotFont 对象为 Boolean 类型，可读写；对于 Font 对象为 Variant 类型，可读写（如果某些文字为斜体而其他不是，则返回 Null）。请使用 IsNull 函数判断返回值是否为 Null。

expression.Italic

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例将 B 列内容的字体设置为斜体。

Spreadsheet1.Columns(2).Font.Italic = True


Item 属性

显示 Item 属性应用于 Borders 对象的情形。

返回一个 Border 对象，表示指定边框。

expression.Item(Index)

expression 必需。该表达式返回一个 Border 对象。

Index XlBordersIndex 类型，必需。要返回的边框。

XlBordersIndex 可为下列 XlBordersIndex 常量之一。
xlEdgeBottom
xlEdgeLeft
xlEdgeRight
xlEdgeTop
xlInsideHorizontal
xlInsideVertical

显示 Item 属性应用于 ChCategoryLabels 对象的情形。

返回一个 ChCategoryLabel 对象，表示指定的分类标志。

expression.Item(Level, Index)

expression 必需。该表达式返回上面对象之一。

Level Long 类型，可选。要索引的分类标志级别。

Index Variant 类型，必需。要返回的分类标志名称或索引号。

显示 Item 属性应用于 PivotMemberProperties 和 PivotResultMemberProperties 对象的情形。

返回一个 PivotMemberProperty 对象，表示指定的成员属性。

expression.Item(varIndex)

expression 必需。该表达式返回上面对象之一。

varIndex Variant 类型，必需。要返回的成员属性的名称或索引号。

显示 Item 属性应用于 Range 对象的情形。

返回一个 Range 对象，表示指定单元格区域中的指定单元格。

expression.Item(RowIndex, ColumnIndex)

expression 必需。该表达式返回一个 Range 对象。

RowIndex Variant 类型，必需。要返回的单元格的行索引。

ColumnIndex Variant 类型，可选。要返回的单元格的列索引。

显示 Item 属性应用于 XmlDataBindings 集合的情形。

从 XmlDataBindings 集合中返回一个 XmlDataBinding 对象。

expression.Item(Index)

expression 必需。该表达式返回一个 XmlDataBindings 集合。

Index Variant 类型，必需。要返回绑定的绑定 ID 或从 1 开始的索引号。绑定 ID 为 Spreadsheet 组件的 XML 电子表格文件中 <Binding> 标记的 ID 属性值。绑定 ID 值可作为 XmlDataBinding 对象的 BindingData 属性所返回的 XML 片段的一部分进行访问。

显示 Item 属性应用于 XmlMaps 对象的情形。

从 XmlMaps 集合中返回一个 XmlMap 对象。

expression.Item((Index)

expression 必需。该表达式返回一个 XmlMaps 集合。

Index Variant 类型，必需。要返回架构映射的映射 ID 或从 1 开始的索引号。映射 ID 由 Spreadsheet 组件的 XML 电子表格文件的 <Binding> 标记中所包含的 <MapID> 标记指定。映射 ID 值可作为 XmlDataBinding 对象的 BindingData 属性所返回的 XML 片段的一部分进行访问。

显示 Item 属性应用于 ListObjects 集合的情形。

从 ListObjects 集合中返回一个 ListObject 对象。

expression.Item(Index)

expression 必需。该表达式返回一个 ListObjects 集合。

Index Variant 类型，必需。要返回 XML 列表的名称或从 1 开始的索引号。名称由 Spreadsheet 组件的 XML 电子表格文件的 <MapInfo> 标记中所包含的 <Entry> 标记的 ID 属性指定。还可使用 ListObject 对象的 Name 属性访问名称。

显示 Item 属性应用于“应用于”列表中所有其他对象的情形。

返回指定集合中的单个对象。Item 属性为大部分集合的默认属性，因此通常无须显式使用该属性。有关返回集合中的单个成员的详细信息，请参阅返回集合中的单个对象。

expression.Item(Index)

expression 该表达式返回“应用于”列表中的对象之一。

Index Long 或 Variant 类型，必需。取决于 expression 中指定的对象（有关对象允许的参数类型列表，请参阅“对象浏览器”）。要返回对象的名称或索引号。


ItemCount 属性

返回一个 Long 类型，指定特定图表坐标轴的分类标志数。只读。

expression.ItemCount(Level)

expression 必需。该表达式返回一个 ChCategoryLabels 对象。

Level Long 类型，可选。要返回数量的分类标志级别。在默认情况下，返回最内部级别的标志数。


JoinType 属性

返回或设置形成查询的方式。DscJoinTypeEnum 类型，可读写。

DscJoinTypeEnum 可为以下 DscJoinTypeEnum 常量之一：
dscInnerJoin
dscLeftOuterJoin
dscRightOuterJoin

expression.JoinType

expression 必需。该表达式返回一个 PageRelationship 对象。

说明

只有 PageRelationship 对象的 Type 属性设置为 dscLookup 时才能使用该属性。


Label 属性

显示 Label 属性应用于 PivotAxis、PivotDataAxis、PivotFilterAxis、PivotGroupAxis 和 PivotView 对象的情形。

返回一个 PivotLabel 对象，表示视图标志或坐标轴标志。

expression.Label

expression 必需。该表达式返回上面对象之一。

显示 Label 属性应用于 PivotData、PivotResultAxis、PivotResultColumnAxis、PivotResultDataAxis、PivotResultFilterAxis、PivotResultGroupAxis、PivotResultPageAxis 和 PivotResultRowAxis 对象的情形。

返回一个 PivotResultLabel 对象，表示坐标轴标志。

expression.Label

expression 必需。该表达式返回上面对象之一。


LanguageID 属性

返回一个 Long 类型，表示安装语言、用户界面语言和帮助语言的地区标识符 (LCID)。只读。

expression.LanguageID(id)

expression 必需。该表达式返回“应用于”列表中的对象之一。

id MsoAppLanguageID 类型，必需。

MsoAppLanguageID 可以为下列 MsoAppLanguageID 常量之一。
msoLanguageIDExeMode | 组件使用的语言模式。该设置影响可以显示和编辑的语言、可用的语言专用功能、数字样式、货币设置等等。 如果没有使用支持的语言，主机应用程序将不配置为支持从右到左和东亚语言。支持的语言如下所示： 阿拉伯语 波斯语 西伯来语 日语 朝鲜语 简体中文 繁体中文 乌尔都语 意第绪语
msoLanguageIDHelp | 联机帮助使用的语言。
msoLanguageIDInstall | Microsoft Office Web Components 用于创建默认值的语言设置。
msoLanguageIDUI | 主机应用程序用户界面使用的语言。
msoLanguageIDUIPrevious | 指定计算机上次重启时使用的用户界面语言设置。程序或加载项可用其判断用户界面语言是否更改。


LanguagePreferredForEditing 属性

如果 msoLanguageID 常量值在注册表中标识为首选编辑语言，则返回 True。Boolean 类型，只读。

expression.LanguagePreferredForEditing(lid)

expression 必需。该表达式返回“应用于”列表中的对象之一。

lid MsoLanguageID 类型，必需。在注册表中检查的语言。

MsoLanguageID 可以为下列 MsoLanguageID 常量之一。
msoLanguageIDAfrikaans
msoLanguageIDAlbanian
msoLanguageIDAmharic
msoLanguageIDArabic
msoLanguageIDArabicAlgeria
msoLanguageIDArabicBahrain
msoLanguageIDArabicEgypt
msoLanguageIDArabicIraq
msoLanguageIDArabicJordan
msoLanguageIDArabicKuwait
msoLanguageIDArabicLebanon
msoLanguageIDArabicLibya
msoLanguageIDArabicMorocco
msoLanguageIDArabicOman
msoLanguageIDArabicQatar
msoLanguageIDArabicSyria
msoLanguageIDArabicTunisia
msoLanguageIDArabicUAE
msoLanguageIDArabicYemen
msoLanguageIDArmenian
msoLanguageIDAssamese
msoLanguageIDAzeriCyrillic
msoLanguageIDAzeriLatin
msoLanguageIDBasque
msoLanguageIDBelgianDutch
msoLanguageIDBelgianFrench
msoLanguageIDBengali
msoLanguageIDBrazilianPortuguese
msoLanguageIDBulgarian
msoLanguageIDBurmese
msoLanguageIDByelorussian
msoLanguageIDCatalan
msoLanguageIDCherokee
msoLanguageIDChineseHongKong
msoLanguageIDChineseMacao
msoLanguageIDChineseSingapore
msoLanguageIDCroatian
msoLanguageIDCzech
msoLanguageIDDanish
msoLanguageIDDutch
msoLanguageIDEnglishAUS
msoLanguageIDEnglishBelize
msoLanguageIDEnglishCanadian
msoLanguageIDEnglishCaribbean
msoLanguageIDEnglishIreland
msoLanguageIDEnglishJamaica
msoLanguageIDEnglishNewZealand
msoLanguageIDEnglishPhilippines
msoLanguageIDEnglishSouthAfrica
msoLanguageIDEnglishTrinidad
msoLanguageIDEnglishUK
msoLanguageIDEnglishUS
msoLanguageIDEnglishZimbabwe
msoLanguageIDEstonian
msoLanguageIDFaeroese
msoLanguageIDFarsi
msoLanguageIDFinnish
msoLanguageIDFrench
msoLanguageIDFrenchCameroon
msoLanguageIDFrenchCanadian
msoLanguageIDFrenchCotedIvoire
msoLanguageIDFrenchLuxembourg
msoLanguageIDFrenchMali
msoLanguageIDFrenchMonaco
msoLanguageIDFrenchReunion
msoLanguageIDFrenchSenegal
msoLanguageIDFrenchWestIndies
msoLanguageIDFrenchZaire
msoLanguageIDFrisianNetherlands
msoLanguageIDGaelicIreland
msoLanguageIDGaelicScotland
msoLanguageIDGalician
msoLanguageIDGeorgian
msoLanguageIDGerman
msoLanguageIDGermanAustria
msoLanguageIDGermanLiechtenstein
msoLanguageIDGermanLuxembourg
msoLanguageIDGreek
msoLanguageIDGujarati
msoLanguageIDHebrew
msoLanguageIDHindi
msoLanguageIDHungarian
msoLanguageIDIcelandic
msoLanguageIDIndonesian
msoLanguageIDInuktitut
msoLanguageIDItalian
msoLanguageIDJapanese
msoLanguageIDKannada
msoLanguageIDKashmiri
msoLanguageIDKazakh
msoLanguageIDKhmer
msoLanguageIDKirghiz
msoLanguageIDKonkani
msoLanguageIDKorean
msoLanguageIDLao
msoLanguageIDLatvian
msoLanguageIDLithuanian
msoLanguageIDMacedonian
msoLanguageIDMalayalam
msoLanguageIDMalayBruneiDarussalam
msoLanguageIDMalaysian
msoLanguageIDMaltese
msoLanguageIDManipuri
msoLanguageIDMarathi
msoLanguageIDMexicanSpanish
msoLanguageIDMixed
msoLanguageIDMongolian
msoLanguageIDNepali
msoLanguageIDNone
msoLanguageIDNoProofing
msoLanguageIDNorwegianBokmol
msoLanguageIDNorwegianNynorsk
msoLanguageIDOriya
msoLanguageIDOromo
msoLanguageIDPolish
msoLanguageIDPortuguese
msoLanguageIDPunjabi
msoLanguageIDRhaetoRomanic
msoLanguageIDRomanian
msoLanguageIDRomanianMoldova
msoLanguageIDRussian
msoLanguageIDRussianMoldova
msoLanguageIDSamiLappish
msoLanguageIDSanskrit
msoLanguageIDSerbianCyrillic
msoLanguageIDSerbianLatin
msoLanguageIDSesotho
msoLanguageIDSimplifiedChinese
msoLanguageIDSindhi
msoLanguageIDSlovak
msoLanguageIDSlovenian
msoLanguageIDSorbian
msoLanguageIDSpanish
msoLanguageIDSpanishArgentina
msoLanguageIDSpanishBolivia
msoLanguageIDSpanishChile
msoLanguageIDSpanishColombia
msoLanguageIDSpanishCostaRica
msoLanguageIDSpanishDominicanRepublic
msoLanguageIDSpanishEcuador
msoLanguageIDSpanishElSalvador
msoLanguageIDSpanishGuatemala
msoLanguageIDSpanishHonduras
msoLanguageIDSpanishModernSort
msoLanguageIDSpanishNicaragua
msoLanguageIDSpanishPanama
msoLanguageIDSpanishParaguay
msoLanguageIDSpanishPeru
msoLanguageIDSpanishPuertoRico
msoLanguageIDSpanishUruguay
msoLanguageIDSpanishVenezuela
msoLanguageIDSutu
msoLanguageIDSwahili
msoLanguageIDSwedish
msoLanguageIDSwedishFinland
msoLanguageIDSwissFrench
msoLanguageIDSwissGerman
msoLanguageIDSwissItalian
msoLanguageIDTajik
msoLanguageIDTamil
msoLanguageIDTatar
msoLanguageIDTelugu
msoLanguageIDThai
msoLanguageIDTibetan
msoLanguageIDTigrignaEritrea
msoLanguageIDTigrignaEthiopic
msoLanguageIDTraditionalChinese
msoLanguageIDTsonga
msoLanguageIDTswana
msoLanguageIDTurkish
msoLanguageIDTurkmen
msoLanguageIDUkrainian
msoLanguageIDUrdu
msoLanguageIDUzbekCyrillic
msoLanguageIDUzbekLatin
msoLanguageIDVenda
msoLanguageIDVietnamese
msoLanguageIDWelsh
msoLanguageIDXhosa
msoLanguageIDZulu

说明

必须测试所有有效的 msoLanguageID 值以列举首选语言的集合。

示例

本示例测试美国英语是否注册为首选编辑语言。

If Spreadsheet1.LanguageSettings. _
    LanguagePreferredForEditing(msoLanguageIDEnglishUS) Then

   MsgBox "U.S. English is one of the chosen editing languages."

End If


LanguageSettings 属性

返回一个 OWCLanguageSettings 对象，包含指定 Spreadsheet 或 Chart Workspace 控件中的语言设置信息。

expression.LanguageSettings

expression 必需。该表达式返回一个 ChartSpace 或 Spreadsheet 对象。

示例

本示例显示 Spreadsheet1 的用户界面当前语言的地区标识符 (LCID)。

MsgBox Spreadsheet1.LanguageSettings.LanguageID(msoLanguageIDUI)


Left 属性

显示 Left 属性应用于 ChartSpace、ChCategoryLabel、ChChartField、ChDataLabel、ChDataLabels、ChErrorBars、ChLegendEntry、ChPoint、ChSeries、ChTrendline、PivotAggregate、PivotAxisMember、PivotColumnMember、PivotDetailCell、PivotPageMember、PivotResultAxis、PivotResultColumnAxis、PivotResultDataAxis、PivotResultFilterAxis、PivotResultGroupAxis、PivotResultLabel、PivotResultPageAxis、PivotResultRowAxis、PivotRowMember 和 PivotTable 对象的情形。

返回（或设置，取决于对象）一个 Long 类型，表示指定对象的左边。可读写。

expression.Left

expression 必需。该表达式返回上面对象之一。

显示 Left 属性应用于 ChScrollView 对象的情形。

返回一个 Long 值，表示 ChScrollView 对象的左边。只读。

expression.Left

expression 必需。该表达式返回一个 ChScrollView 对象。

显示 Left 属性应用于 PivotData 对象的情形。

返回或设置一个 PivotColumnMember 对象，表示最左侧可见列上的成员。可读写。

expression.Left

expression 必需。该表达式返回一个 PivotData 对象。

显示 Left 属性应用于 Range 对象的情形。

返回一个 Variant 类型，表示从电子表格左边到指定区域左边之间的距离。如果区域在可见区域之外，该数值可以为负数。只读。

expression.Left

expression 必需。该表达式返回一个 Range 对象。

显示 Left 属性应用于 Window 对象的情形。

返回一个 Double 类型，表示指定窗口的左边。只读。

expression.Left

expression 必需。该表达式返回一个 Window 对象。

示例

如果单元格 F1 当前在可见区域的左侧，本示例将向左滚动窗口显示该单元格。

Sub ScrollSheet

   Dim rngScroll

   Set rngScroll = Spreadsheet1.Range("f1")

   If rngScroll.Left < 0 Then Spreadsheet1.ActiveSheet.Scroll rngScroll

End Sub


Left2 属性

返回一个 Long 类型，表示数据透视表列表左边到数据区域之间的距离。该属性通常返回 1。只读。

expression.Left2

expression 必需。该表达式返回一个 PivotData 对象。


LeftOffset 属性

返回或设置一个 Long 类型，表示向左滚动数据区域的像素数。可读写。

expression.LeftOffset

expression 必需。该表达式返回一个 PivotData 对象。

说明

使用 TopOffset 向下滚动数据区域。

示例

本示例将 PivotTable1 的数据区域分别向下和向左滚动 45 像素。

Sub ScrollDataArea()

    Dim ptData

    Set ptData = PivotTable1.ActiveData

    ' Scroll 45 pixels down.
    ptData.TopOffset = 45

    ' Scroll the data area to the left.
    ptData.LeftOffset = 45

End Sub


Legend 属性

返回 ChLegend 对象，表示指定图表的图例。

expression.Legend

expression 必需。该表达式 返回一个 ChChart 对象。

示例

本示例使指定图表显示图例，然后设置图例字体。

Sub AddLegend()

   ' Enable the legend for the first chart in Chartspace1.
   ChartSpace1.Charts(0).HasLegend = True

   ' Set the font for the legend.
   ChartSpace1.Charts(0).Legend.Font.Name = "Times New Roman"

End Sub


LegendEntries 属性

返回指定图例的 ChLegendEntries 集合。

expression.LegendEntries

expression 必需。该表达式 返回一个 ChLegend 对象。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。

示例

本示例隐藏指定图例项。

ChartSpace1.Charts(0).Legend.LegendEntries(1).Visible = False


Length 属性

返回或设置最大字段或参数长度。Long 类型，可读写。

expression.Length

expression 必需。该表达式返回“应用于”列表中的对象之一。


Level 属性

返回一个 Long 类型，指定特定分类标志在分层分类坐标轴上显示的级别。最外部级别为零 (0)。只读。

expression.Level

expression 必需。该表达式返回一个 ChCategoryLabel 对象。


LevelCount 属性

返回一个 Long 类型，指定分层图表坐标轴的级别数。只读。

expression.LevelCount

expression 必需。该表达式返回一个 ChCategoryLabels 对象。


LightNormal 属性

返回或设置一个 Double 类型，指定三维图表中从 90 度射出的光照量。有效范围为 0 到 1。可读写。

expression.LightNormal

expression 必需。该表达式返回一个 ChChart 对象。

说明

设置该属性为 0 将得到图表的平面效果，而设置该属性为 0.5 将得到更强的三维效果。

示例

本示例将 Chartspace1 中的第一个图表转换为三维柱形图，然后设置图表的 LightNormal 属性。

Sub SetGapDepth()

    Dim cht3DColumn As ChChart

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DColumn = ChartSpace1.Charts(0)

    ' Change the chart to a 3-D Column chart.
    cht3DColumn.Type = chChartTypeColumn3D

    cht3DColumn.LightNormal = 0.8

End Sub


Line 属性

返回可用于更改指定图表元素外观的一个 ChLine 对象。

expression.Line

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

与其他属性结合使用，Line 属性可以设置坐标轴、趋势线、折线图或股票图上的折线、误差线和网格线的格式。

示例

本示例设置指定系列的线条颜色。

ChartSpace1.Charts(0).SeriesCollection(0).Line.Color = "red"


LineStyle 属性

返回或设置指定区域的边框的线条样式。可为 LineStyleEnum 常量之一；如果边框样式不统一，则返回 Null。请使用 IsNull 函数判断返回值是否为 Null。Variant 类型，可读写。

expression.LineStyle

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

如果 ChBorder 对象表示图表元素，则不能设置该属性。

示例

本示例将区域 A1:E5 中每个单元格的边框设置为绿色点划线。

Sub SetBorder()

   Dim rngCurrent
   Dim ssConstants

   Set ssConstants = Spreadsheet1.Constants

   Set rngCurrent = Spreadsheet1.Range("a1:e5")

   rngCurrent.Borders.LineStyle = ssConstants.ssConstants.xlDashDot

   rngCurrent.Borders.Color = "Green"

End Sub


ListBoundField 属性

返回或设置绑定到指定列表框或组合框的字段（与显示字段相对）。只应用于列表框和组合框。String 类型，可读写。

expression.ListBoundField

expression 必需。该表达式返回一个 ElementExtension 对象。

说明

使用 ListDisplayField 属性返回或设置显示的字段。

该属性与 ListRowSource 和 ListDisplayField 属性结合使用，用于控制列表框或组合框中的数据显示方式。例如，考虑显示 Order Details 节产品名称的列表框。Order Details 节后面的记录集包括名为 ProductID 的字段，表示指定 Order Detail 记录的产品。但是页面作者希望在下拉列表框中显示产品名称，而不是在文本框中显示 ProductID。列表框可以由名为 Products 的记录集定义填充，该记录集定义包含 Product 表中的 ProdID 和 ProductName 字段。该列表框元素的属性可以如下表所示的方式进行设置。

属性 | 值
ListRowSource | Products
ListBoundField | ProdID
ListDisplayField | ProductName
ControlSource | ProductID


ListDisplayField 属性

返回或设置列表框或组合框中显示的字段（与绑定字段相对）。只能有一个显示字段。该属性只能应用于列表框和组合框。String 类型，可读写。

expression.ListDisplayField

expression 必需。该表达式返回一个 ElementExtension 对象。

说明

使用 ListBoundField 属性返回或设置绑定字段。

该属性与 ListRowSource 和 ListBoundField 属性结合使用，用于控制列表框或组合框中的数据显示方式。例如，考虑显示 Order Details 节产品名称的列表框。Order Details 节后面的记录集包括名为 ProductID 的字段，表示指定 Order Detail 记录的产品。但是页面作者希望在下拉列表框中显示产品名称，而不是在文本框中显示 ProductID。列表框可以由名为 Products 的记录集定义填充，该记录集定义包含 Product 表中的 ProdID 和 ProductName 字段。该列表框元素的属性可以如下表所示的方式进行设置。

属性 | 值
ListRowSource | Products
ListBoundField | Prod ID
ListDisplayField | Product Name
ControlSource | Product ID


ListObject 属性

显示 应用于 Range 对象的情形。

如果存在与指定区域相交的任何列表对象，则为返回 ListObject 对象的 Range 对象属性。只读。

expression.ListObject

expression 必需。该表达式返回一个 Range 对象。

说明

可使用 ListObject 属性查找区域中是否存在 XML 列表。该属性与 Microsoft Excel 中 Range 对象的 PivotTable 和 QueryTable 属性类似。如果存在多个 ListObject 对象与指定区域相交，则 Spreadsheet 组件将选择一个返回。

显示 应用于 Workbook 对象的情形。

返回一个 ListObject 对象。

expression.ListObject(EntryID)

expression 必需。该表达式返回一个 Workbook 对象。

EntryID String 类型，必需。XML 电子表格中 MapInfo/Map/Entry 的 ID 属性值。

说明

从在 MapInfo/Map/Entry 的 <MapInfo> 元素中映射的 XML 电子表格中返回特定 EntryID 的 ListObject 对象。

在 XML 电子表格文件中显示明细数据的 XML 片段如下所示：

<x2:MapInfo xmlns:x2="http://schemas.microsoft.com/office/excel/2003/xml">
   <x2:Map x2:ID="Cust_MapId">
      <x2:Entry x2:ID="example_id" x2:Type="table">
         ...
      </x2:Entry>
   </x2:Map>
</x2:MapInfo>

示例

显示 应用于 Range 对象的情形。

以下示例返回指定区域中的 XML 列表。

ActiveSheet.Range("A1:G9").ListObject

显示 应用于 Workbook 对象的情形。

以下示例在活动文档中查找特定的 ListObject 对象。

Dim objList

Set objList = Spreadsheet1.ActiveWorkbook.ListObject("example_id")


ListObjects 属性

返回 Worksheet 对象的 ListObjects 集合。只读。

expression.ListObjects

expression 必需。该表达式返回一个 Worksheet 对象。

说明

使用 ListObjects 属性返回指定 Worksheet 对象的 ListObjects 集合。然后在 ListObjects 集合中重复获取该工作表中的每一个 ListObject 对象。

示例

以下示例处理与 Spreadsheet 组件（名为 Spreadsheet1）有关的每一个 ListObjects 对象。该代码使用第二个 Worksheet 对象的 ListObjects 属性返回 ListObjects 集合。然后获取 ListObject 对象的名称。该名称与 XML 电子表格文件的架构映射语法中 MapInfo/Map/Entry 的 ID 属性值相对应。

在 XML 电子表格文件中显示明细数据的 XML 片段如下所示。在本示例中，ListObject 对象的名称为 Cust_MapId：

<x2:MapInfo xmlns:x2="http://schemas.microsoft.com/office/excel/2003/xml">
   <x2:Map x2:ID="Cust_MapId">
      <x2:Entry x2:ID="example_id" x2:Type="table">
         ...
      </x2:Entry>
   </x2:Map>
</x2:MapInfo>

Dim objLists
Dim objList
Dim strName

Set objLists = Spreadsheet1.Worksheets(2).ListObjects

For Each objList in objLists
    ' Save the ListObject name to a variable.
    strName = objList.Name

    ' Work with that particular list object here.

Next

本示例设置 Spreadsheet 组件（名为 Spreadsheet1）中指定 ListObject 边框的线条粗细。

Dim ssConstants

Set ssConstants = Spreadsheet1.Constants

' Set a variable to the range to add the borders to.
rngList = Spreadsheet1.ActiveSheet.ListObjects(1).Range

' Set whole range border weight.
rngList.Weight = ssConstants.owcLineWeightMedium


ListRows 属性

返回一个 ListRows 集合，表示 ListObject 对象中的所有数据行。不包括标题行或插入行。只读。

expression.ListRows

expression 必需。该表达式返回一个 ListObject 对象。

说明

使用 ListRows 属性返回指定 ListObject 对象的 ListRows 集合。然后在 ListRows 集合中重复获取该工作表中的每一个 ListRow 对象。

示例

以下示例显示如何检索指定列表行（此处为第八行）的列表行信息。

Dim objLists
Dim objLRows
Dim objLRow

Set objLists = Spreadsheet1.ActiveSheet.ListObjects
Set objLRows = objLists.Item(1).ListRows

' Save the list row information of list row number 8 to a variable.
Set objRow = objLRows.Item(8)

' Work with the list row information here.


ListRowSource 属性

指定列表框或组合框的数据源。该属性只能应用于列表框和组合框，但是必须在设置 ListBoundField 或 ListDisplayField 属性前设置。String 类型，可读写。

expression.ListRowSource

expression 必需。该表达式返回一个 ElementExtension 对象。

说明

该属性与 ListBoundField 和 ListDisplayField 属性结合使用，用于控制列表框或组合框中的数据显示方式。例如，考虑显示 Order Details 节产品名称的列表框。Order Details 节后面的记录集包括名为 ProductID 的字段，表示指定 Order Detail 记录的产品。但是页面作者希望在下拉列表框中显示产品名称，而不是在文本框中显示 ProductID。列表框可以由名为 Products 的记录集定义填充，该记录集定义包含 Product 表中的 ProdID 和 ProductName 字段。该列表框元素的属性可以如下表所示的方式进行设置。

属性 | 值
ListRowSource | Products
ListBoundField | Prod ID
ListDisplayField | Product Name
ControlSource | Product ID


LoadMode 属性

返回一个枚举常量，表示特定数据绑定的 <Binding> 元素中 LoadMode 属性值的等价数字值。BindingLoadMode 常量，只读。

expression.LoadMode

expression 必需。该表达式返回一个 XMLDataBinding 对象。

说明

XMLDataBinding 对象可为到 XML 文件、任意 SOAP 服务、其他 Web 部件（对于“电子表格 Web 部件”）或数据检索服务的绑定。LoadMode 属性描述绑定加载行为。可能的 LoadMode 属性设置及其等价数字值如下所示。如果未提供属性设置，则使用默认值“normal”：

BindingLoadMode 说明
Normal (0 )

对于查询绑定，在首次加载、用户单击“全部刷新”工具栏按钮、在电子表格 Web 部件中单击工具条上的“刷新”命令或在 Spreadsheet 组件中单击上下文菜单中的“刷新数据”命令时进行绑定。绑定也可通过编程手段完成。

对于更新绑定，每当用户在电子表格 Web 部件中单击工具条上的“更新数据”命令或使用上下文菜单中的“保存数据”命令时即开始绑定。绑定也可通过编程手段实现。

OM (1)

对于查询绑定，绑定不会在首次加载、用户单击“全部刷新”工具栏按钮、在电子表格 Web 部件中单击工具条上的“刷新”命令或在 Spreadsheet 组件中单击上下文菜单中的“刷新数据”命令时进行。也不会在 Spreadsheet 对象中调用 Refresh 方法时进行。仅在调用 XmlDataBinding 对象的 Refresh 方法时进行绑定。

对于更新绑定，绑定不会在首次加载、用户在电子表格 Web 部件中单击工具条上的“更新数据”命令或使用上下文菜单中的“保存数据”命令时进行。仅在调用 XmlDataBinding 对象的 Update 方法时进行绑定。

Delay (2)

对于查询绑定，当用户单击“全部刷新”工具栏按钮、在电子表格 Web 部件中单击工具条上的“刷新”命令或单击上下文菜单中的“刷新数据”命令时进行绑定。绑定也可通过编程手段完成。

对于更新绑定，绑定行为与 Normal 枚举值的说明相同。


Location 属性

返回或设置计算字段的计算位置。DscLocationEnum 类型，可读写。

DscLocationEnum 可为以下 DscLocationEnum 常量之一：
dscClient
dscServer
dscSystem

expression.Location

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

该属性控制计算字段的计算位置。如果该属性设置为 dscServer，表达式包括在发送给数据库的 SQL 字符串中，并且必须使用数据库的正确 SQL 语法。如果该属性设置为 dscClient，则表达式在客户端计算机上使用 Visual Basic for Applications 表达式计算。


Locked 属性

如果锁定了指定区域的所有单元格，则返回 True；如果没有锁定任何单元格，则返回 False；如果某些单元格处于锁定状态而其他没有，则返回 Null。默认值为 True。请使用 IsNull 函数判断返回值是否为 Null。Variant 类型，可读写。

expression.Locked

expression 必需。该表达式返回一个 Range 对象。

示例

本示例只锁定 Spreadsheet1 中活动工作表上 B 列的单元格，然后保护工作表。

Sub LockColumnB()
    Dim shtCurrent

    Set shtCurrent = Spreadsheet1.ActiveSheet

    ' Clear the locked attribute for all cells on the active sheet.
    shtCurrent.Cells.Locked = False

    ' Lock all of the cells in Column B.
    shtCurrent.Columns(2).Locked = True

    ' Enable protection on the active sheet.
    shtCurrent.Protection.Enabled = True
End Sub


LogBase 属性

在使用对数刻度时设置对数的底。试图将属性设置为小于零 (0) 的值将导致错误。Double 类型，可读写。

expression.LogBase

expression 必需。该表达式 返回一个 ChScaling 对象。

示例

本示例使指定坐标轴使用底为 2 的对数刻度。

Sub SetScaling()

   Dim chConstants
   Dim scValueAxisScaling

   Set chConstants = ChartSpace1.Constants

   ' Set a variable to the scaling object of the value axis.
   Set scValueAxisScaling = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue).Scaling

   ' Set the scaling type.
   scValueAxisScaling.Type = chConstants.chScaleTypeLogarithmic

   ' Set the base value.
   scValueAxisScaling.LogBase = 2

End Sub


LookupRelationships 属性

返回指定页行来源的 LookupRelationships 集合。只读。

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。

expression.LookupRelationships

expression 必需。该表达式返回一个 PageRowsource 对象。

说明

LookupRelationship 对象引用与指定页行来源具有一对多关系的行来源。这些行来源的字段可以与指定行来源的字段显示在同一节或“数据透视表”列表中。


LookupSchemaRelationships 属性

返回指定方案行来源的 LookupSchemaRelationships 集合。只读。

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。

expression.LookupSchemaRelationships

expression 必需。该表达式返回一个 SchemaRowSource 对象。


MajorGridlines 属性

返回一个表示指定坐标轴主要网格线的 ChGridlines 对象。请注意可以在任何坐标轴上使用网格线。只读。

expression.MajorGridlines

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例设置 ChartSpace1 中第一个图表数值轴上网格线的颜色和线条粗细。

Sub Format_Gridlines()
    Dim chConstants
    Dim glMajorGridlines
    Dim glMinorGridlines

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the major gridlines on the value axis.
    Set glMajorGridlines = ChartSpace1.Charts(0).Axes( _
           chConstants.chAxisPositionValue).MajorGridlines

    ' Set a variable to the minor gridlines on the value axis.
    Set glMinorGridlines = ChartSpace1.Charts(0).Axes( _
           chConstants.chAxisPositionValue).MinorGridlines

    ' Set the color and weight of the major gridlines.
    glMajorGridlines.Line.Color = "white"
    glMajorGridlines.Line.Weight = 5

    ' Set the color and weight of the minor gridlines.
    glMinorGridlines.Line.Color = "yellow"
    glMajorGridlines.Line.Weight = 2
End Sub


MajorTickMarks 属性

返回或设置指定坐标轴的主要刻度线类型。ChartTickMarkEnum 类型，可读写。

ChartTickMarkEnum 可为以下 ChartTickMarkEnum 常量之一：
chTickMarkAutomatic
chTickMarkCross
chTickMarkInside
chTickMarkNone
chTickMarkOutside

expression.MajorTickMarks

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例关闭指定坐标轴上的刻度线。

Sub DisableMajorTickMarks()
   Dim chConstants

   Set chConstants = ChartSpace1.Constants

   ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionLeft).MajorTickMarks _
             = chConstants.chTickMarkNone
End Sub


MajorUnit 属性

返回或设置指定坐标轴的主要单位。该属性只能用于数值轴。Double 类型，可读写。

expression.MajorUnit

expression 必需。该表达式返回一个 ChAxis 对象。

说明

设置该属性将导致 HasAutoMajorUnit 属性设置为 False。

示例

本示例设置数值轴的主要和次要单位。

Sub SetValueAxis()
   Dim chConstants
   Dim axValueAxis

   Set chConstants = ChartSpace1.Constants

   Set axValueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue)

   axValueAxis.MajorUnit = 7
   axValueAxis.MinorUnit = 2.5
End Sub


MajorVersion 属性

返回 Microsoft Office Web Components 对象库的主要版本。Long 类型，只读。

expression.MajorVersion

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例显示 Spreadsheet1 的主版本。

Msgbox Spreadsheet1.MajorVersion


ManySide 属性

显示 ManySide 属性应用于 PageRelatedField 对象的情形。

返回一个表示一对多关系中多侧页面行来源所对应字段的 PageField 对象。

expression.ManySide

expression 必需。该表达式返回一个 PageRelatedField 对象。

显示 ManySide 属性应用于 PageRelationship 对象的情形。

返回一个表示指定一对多关系中多侧页面行来源的 PageRowsource 对象。

expression.ManySide

expression 必需。该表达式返回一个 PageRelationship 对象。

显示 ManySide 属性应用于 SchemaRelatedField 和 SchemaRelationship 对象的情形。

返回指定一对多关系中多侧方案字段或方案行来源的名称。String 类型，只读。

expression.ManySide

expression 必需。该表达式返回上述对象之一。


MapData 属性

使用 MapData 属性可指定或确定 XmlMap 对象的架构映射。String 类型，可读写。

expression.MapData

expression 必需。该表达式返回一个 XmlMap 对象。

说明

XmlMap 对象在通过设置 XMLURL 或 XMLData 属性将包含绑定和映射信息的 XML 电子表格文件加载到 Spreadsheet 组件中时创建。可通过以下方式创建 XML 电子表格文件：使用 Microsoft Office Excel 2003 将数据导入并映射到工作表，再将工作簿另存为 XML 电子表格文件。设置 MapData 属性将使用所指定的新架构映射替换现有的所有架构映射。

示例

以下示例使用 XmlMap 对象的 MapData 属性返回架构映射：

Dim objMap
Dim strMapData

For Each objMap in Spreadsheet1.ActiveWorkbook.XmlMaps
     ' Save the xml map information to a variable.
     strMapData = objMap.MapData
     ' Work with map info xml here.
Next

下一示例为设置 MapData 属性的函数：

Function ChangeMapSchema(objMap, strMapData)
On Error Resume Next
objMap.MapData = strMapData

    If Err.Number <> 0 Then
        ChangeMapSchema = True
    Else
        ChangeMapSchema = False
    End If
End Function


Marker 属性

返回一个 ChMarker 对象，表示指定系列中每个点的标志。只读。

expression.Marker

expression 必需。该表达式返回一个 ChSeries 对象。

示例

本示例设置图表类型，然后设置指定系列的标志类型和内部颜色。

Sub SetMarkerStyle()
   Dim chConstants
   Dim serSeries1

   Set chConstants = ChartSpace1.Constants

   Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

   ChartSpace1.Charts(0).Type = chConstants.chChartTypeLineMarkers

   serSeries1.Marker.Style = chConstants.chMarkerStyleSquare

   serSeries1.Interior.Color = "blue"
End Sub


MaxHeight 属性

显示 MaxHeight 属性应用于 PivotTable 对象的情形。

返回或设置指定数据透视表列表在 AutoFit 属性值为 True 时能够达到的最大高度（像素）。如果在最大高度内不能显示所有数据，将显示垂直滚动条。默认值为 32,000 像素。Long 类型，可读写。

expression.MaxHeight

expression 必需。该表达式返回一个 PivotTable 对象。

显示 MaxHeight 属性应用于 Spreadsheet 对象的情形。

返回或设置指定工作表在 AutoFit 属性值为 True 时能够达到的最大高度。如果在最大高度内不能显示所有数据，将显示垂直滚动条。数值可以像素表示，也可以容器窗口的百分比表示（表示为诸如“50%”的字符串）。默认值为 80%。Variant 类型，可读写。

expression.MaxHeight

expression 必需。该表达式返回一个 Spreadsheet 对象。


Maximum 属性

返回或设置指定刻度的最大值。Double 类型，可读写。

expression.Maximum

expression 必需。该表达式返回一个 ChScaling 对象。

示例

本示例设置指定坐标轴刻度的最大值和最小值。

Sub SetScalingLimits()
   Dim chConstants
   Dim axisScale

   Set chConstants = ChartSpace1.Constants

   Set axisScale = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue).Scaling

   axisScale.Maximum = 70
   axisScale.Minimum = -10
End Sub0


MaxRecords 属性

返回或设置连接将返回到本地计算机的最大记录数。Long 类型，可读写。

expression.MaxRecords

expression 必需。该表达式返回一个 DataSourceControl 对象。


MaxWidth 属性

显示 MaxWidth 属性应用于 PivotTable 对象的情形。

返回或设置指定数据透视表列表在 AutoFit 属性值为 True 时能够达到的最大宽度（像素）。如果在最大宽度内不能显示所有数据，将显示水平滚动条。默认值为 32,000 像素。Long 类型，可读写。

expression.MaxWidth

expression 必需。该表达式返回一个 PivotTable 对象。

显示 MaxWidth 属性应用于 Spreadsheet 对象的情形。

返回或设置指定工作表在 AutoFit 属性值为 True 时能够达到的最大宽度。如果在最大宽度内不能显示所有数据，将显示水平滚动条。数值可以像素表示，也可以容器窗口的百分比表示（表示为诸如“50%”的字符串）。默认值为 80%。Variant 类型，可读写。

expression.MaxWidth

expression 必需。该表达式返回一个 Spreadsheet 对象。


Member 属性

显示 Member 属性应用于 PivotResultColumnAxis、PivotResultGroupAxis、PivotResultPageAxis 和 PivotResultRowAxis 对象的情形。

返回一个 PivotAxisMember 对象，表示指定结果坐标轴的父成员。

expression.Member

expression 必需。该表达式返回上面对象之一。

显示 Member 属性应用于 PivotFieldSet 对象的情形。

返回一个 PivotMember 对象，表示指定字段集的顶层成员对象。

expression.Member

expression 必需。该表达式返回一个 PivotFieldSet 对象。


MemberCaptions 属性

返回或设置一个 Variant 类型数组，包含指定字段中的成员标题。使用该属性自定义字段中的成员标题。可读写。

expression.MemberCaptions

expression 必需。该表达式返回一个 PivotField 对象。

说明

传递给该属性的数组中包含要修改的每个标题的数组。数组中的第一个成员可以包含成员名称、唯一名称或对 PivotMember 对象的引用。数组中的第二个元素为成员使用的新标题。

数组中未指定的成员将使用数据源提供的默认标题。

注释 该属性仅用于“联机分析处理 (OLAP)”数据源。

示例

本示例以更可读的标题替换 Customers 字段集中 State Province 字段的标题。

Sub NewMemberCaptions()

    Dim fldStateCaptions
    Dim avarNewCaptions(2)

    Set fldStateCaptions = PivotTable1.ActiveView.FieldSets("Customers") _
                          .Fields("State Province")

    ' The following three lines of code specify the new captions to
    ' be displayed for the states in the State Province field.
    avarNewCaptions(0) = Array("[State Province].[CA]", "California")
    avarNewCaptions(1) = Array("[State Province].[WA]", "Washington")
    avarNewCaptions(2) = Array("[State Province].[OR]", "Oregon")

    ' Apply the new captions to the State Province field.
    fldStateCaptions.MemberCaptions = avarNewCaptions

End Sub


MemberProperties 属性

显示 MemberProperties 属性应用于 PivotField 对象的情形。

返回一个 PivotMemberProperties 对象，表示指定数据透视表字段的 OLAP 成员属性。

expression.MemberProperties

expression 必需。该表达式返回一个 PivotField 对象。

显示 MemberProperties 属性应用于 PivotAxisMember、PivotColumnMember、PivotPageMember 和 PivotRowMember 对象的情形。

返回一个 PivotResultMemberProperties 对象，表示指定数据透视表字段的 OLAP 成员属性。

expression.MemberProperties

expression 必需。该表达式返回上面对象之一。

示例

显示 应用于 PivotField 对象的情形。

本示例显示 Store Name 字段集的成员属性。

Sub Display_MemberProperties()

 Dim ptView
 Dim ptConstants
 Dim fldStoreName

 Set ptConstants = PivotTable1.Constants

 ' Set a variable to the active view of the PivotTable.
 Set ptView = PivotTable1.ActiveView

 ' Set a variable to the Store Name field.
 Set fldStoreName = ptView.FieldSets("Store").Fields("Store Name")

 ' The following three lines of code specify that the member properties are
 ' displayed in the PivotTable list.
 fldStoreName.MemberProperties("Store Manager").DisplayIn = ptConstants.plDisplayPropertyInReport
 fldStoreName.MemberProperties("Store Type").DisplayIn = ptConstants.plDisplayPropertyInReport
 fldStoreName.MemberProperties("Store Sqft").DisplayIn = ptConstants.plDisplayPropertyInReport

 ' The following three lines of code set the caption for the member properties.
 fldStoreName.MemberProperties("Store Manager").Caption = "Manager Name"
 fldStoreName.MemberProperties("Store Type").Caption = "Store Type"
 fldStoreName.MemberProperties("Store Sqft").Caption = "Size in SQFT"

End Sub


MemberPropertiesOrder 属性

返回或设置一个 Variant 类型数组，表示指定字段中成员属性的显示次序。使用该属性重排成员属性的显示次序。可读写。

expression.MemberPropertiesOrder

expression 必需。该表达式返回一个 PivotField 对象。

说明

传递给该属性的数组可以包含 PivotMemberProperty 对象列表或成员标题的 String 列表。

示例

本示例启用 PivotTable1 中 Store Name 字段的成员标题，然后重排并自定义标题。

Sub Format_MemberProperties()
    Dim ptView
    Dim ptConstants
    Dim fldStoreName

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the active view of the PivotTable.
    Set ptView = PivotTable1.ActiveView

    ' Set a variable to the Store Name field.
    Set fldStoreName = ptView.FieldSets("Store").Fields("Store Name")

    ' The following three lines of code specify that the member properties are
    ' displayed in the PivotTable list.
    fldStoreName.MemberProperties("Store Manager").DisplayIn = ptConstants.plDisplayPropertyInReport
    fldStoreName.MemberProperties("Store Type").DisplayIn = ptConstants.plDisplayPropertyInReport
    fldStoreName.MemberProperties("Store Sqft").DisplayIn = ptConstants.plDisplayPropertyInReport

    fldStoreName.MemberPropertiesOrder = Array("Store Type", "Store Sqft", "Store Manager")

    ' The following three lines of code set the caption for the member properties.
    fldStoreName.MemberProperties("Store Manager").Caption = "Manager Name"
    fldStoreName.MemberProperties("Store Type").Caption = "Store Type"
    fldStoreName.MemberProperties("Store Sqft").Caption = "Size in SQFT"
End Sub


MemberProperty 属性

返回一个 PivotMemberProperty 对象，表示指定结果成员的成员属性。

expression.MemberProperty

expression 必需。该表达式返回一个 PivotResultMemberProperty 对象。


MergeArea 属性

返回 Range 对象，该对象代表包含指定区域任何部分的合并区域。指定区域可以包含多个单元格，如果区域中不包含合并单元格，则被返回而不做更改。只读。

expression.MergeArea

expression 必需。该表达式返回一个 Range 对象。

示例

本示例在 Sheet1 中由区域 B2:C5 创建合并单元格，并在合并单元格周围设置红色粗边框。

Sub Merge_Cells()
    Dim ssConstants
    Dim shtCurrent

    Set ssConstants = Spreadsheet1.Constants
    Set shtCurrent = Spreadsheet1.Worksheets("Sheet1")

    ' Merge cells B2:C5.
    shtCurrent.Range("B2:C5").Merge

    ' Set the border color of the merged cell.
    shtCurrent.Range("B2").MergeArea.Borders.Color = "Red"

    ' Set the border weight of the merged cell.
    shtCurrent.Range("B2").MergeArea.Borders.Weight = ssConstants.owcLineWeightThick
End Sub


MergeCells 属性

如果指定区域在合并单元格中，则为 True。如果指定区域不包含合并单元格，则为 False。如果指定区域包含全部或部分合并单元格，以及合并单元格以外的其他单元格，则为 Null。Variant 类型，可读写。

expression.MergeCells

expression 必需。该表达式返回一个 Range 对象。

说明

如果选择了包含合并单元格的区域，得到的选定内容可能不同于预想的选定内容。

使用 Address 属性查看选定区域的地址。

使用 UnMerge 方法取消指定区域的合并。


Minimum 属性

返回或设置指定刻度的最小值。Double 类型，可读写。

expression.Minimum

expression 必需。该表达式返回一个 ChScaling 对象。

示例

本示例设置指定坐标轴刻度的最大值和最小值。

Sub SetScalingLimits()
   Dim chConstants
   Dim axisScale

   Set chConstants = ChartSpace1.Constants

   Set axisScale = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue).Scaling

   axisScale.Maximum = 70
   axisScale.Minimum = -10
End Sub


MinorGridlines 属性

返回表示指定坐标轴次要网格线的 ChGridlines 对象。请注意您可以在任何坐标轴上使用网格线。只读。

expression.MinorGridlines

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例设置 ChartSpace1 中第一个图表数值轴上网格线的颜色和线条粗细。

Sub Format_Gridlines()
    Dim chConstants
    Dim glMajorGridlines
    Dim glMinorGridlines

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the major gridlines on the value axis.
    Set glMajorGridlines = ChartSpace1.Charts(0).Axes( _
           chConstants.chAxisPositionValue).MajorGridlines

    ' Set a variable to the minor gridlines on the value axis.
    Set glMinorGridlines = ChartSpace1.Charts(0).Axes( _
           chConstants.chAxisPositionValue).MinorGridlines

    ' Set the color and weight of the major gridlines.
    glMajorGridlines.Line.Color = "white"
    glMajorGridlines.Line.Weight = 5

    ' Set the color and weight of the minor gridlines.
    glMinorGridlines.Line.Color = "yellow"
    glMajorGridlines.Line.Weight = 2
End Sub


MinorTickMarks 属性

返回或设置指定坐标轴的次要刻度线类型。ChartTickMarkEnum 类型，可读写。

ChartTickMarkEnum 可为以下 ChartTickMarkEnum 常量之一：
chTickMarkAutomatic
chTickMarkCross
chTickMarkInside
chTickMarkNone
chTickMarkOutside

expression.MinorTickMarks

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例打开指定坐标轴的次要网格线和次要刻度线，并设置网格线颜色和刻度线样式。

Sub FormatValueAxis()
   Dim chConstants
   Dim axValueAxis

   Set chConstants = ChartSpace1.Constants

   Set axValueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionLeft)

   axValueAxis.HasMinorGridlines = True

   axValueAxis.MinorGridlines.Line.Color = "green"

   axValueAxis.MinorTickMarks = chConstants.chTickMarkOutside
End Sub


MinorUnit 属性

返回或设置指定坐标轴的次要单位。该属性只能用于数值轴。Double 类型，可读写。

expression.MinorUnit

expression 必需。该表达式返回一个 ChAxis 对象。

说明

设置该属性将导致 HasAutoMinorUnit 属性设置为 False。

示例

本示例设置数值轴的主要和次要单位。

Sub SetValueAxis()
   Dim chConstants
   Dim axValueAxis

   Set chConstants = ChartSpace1.Constants

   Set axValueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue)

   axValueAxis.MajorUnit = 7
   axValueAxis.MinorUnit = 2.5
End Sub


MinorVersion 属性

返回 Microsoft Office Web Components 对象库的次要版本。String 类型，只读。

expression.MinorVersion

expression 必需。该表达式返回“应用于”列表中的对象之一。


Miter 属性

返回或设置指定线条外边缘连接方式的 ChartLineMiterEnum 常量。可读写。

ChartLineMiterEnum 可以为下列 ChartLineMiterEnum 常量之一。
chLineMiterBevel 默认值
chLineMiterMiter
chLineMiterRound

expression.Miter

expression 必需。该表达式返回一个 ChLine 对象。

示例

本示例将 Chartspace1 中的第一个图表更改为折线图，然后设置图表中第一个系列的线条格式。

Sub Set_Series_LineStyle()

    Dim chConstants
    Dim serSeries1

    Set chConstants = ChartSpace1.Constants

    ' Change the chart to a line chart.
    ChartSpace1.Charts(0).Type = chChartTypeLine

    ' Set a variable to refer to the first data series in the chart.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Set the miter of the line of the first series.
    serSeries1.Line.Miter = chConstants.chLineMiterBevel

    ' Set the line weight of the first series.
    serSeries1.Line.Weight = chConstants.owcLineWeightThick

    ' Set the line style of the first series.
    serSeries1.Line.DashStyle = chConstants.chLineRoundDot

End Sub


MoveAfterReturn 属性

确定用户按 Enter 后是否移动活动单元格。默认值为 True。请使用 MoveAfterReturnDirection 属性确定用户按 Enter 后活动单元格的移动方向。Boolean 类型，可读写。

expression.MoveAfterReturn

expression 必需。该表达式返回一个 Spreadsheet 对象。

示例

本示例将导致用户按 Enter 后活动单元格保持选中状态。

Spreadsheet1.MoveAfterReturn = False


MoveAfterReturnDirection 属性

返回或设置当用户按 Enter 且 MoveAfterReturn 属性设置为 True 时焦点的移动方向。XlDirection 类型，可读写。

XlDirection 可为以下 XlDirection 常量之一：
xlDown
xlToLeft
xlToRight
xlUp

expression.MoveAfterReturnDirection

expression 必需。该表达式返回一个 Spreadsheet 对象。

示例

本示例在用户按 Enter 后选定活动单元格右侧的单元格。

Sub MoveAfterEnter()
    Dim ssConstants

    Set ssConstants = Spreadsheet1.Constants

    ' Enable the MoveAfterReturn property.
    Spreadsheet1.MoveAfterReturn = True

    ' Move the cursor one cell to the right when
    ' the user presses ENTER.
    Spreadsheet1.MoveAfterReturnDirection = xlToRight
End Sub


Name 属性

返回或设置指定对象的名称。

  • 对于 Font 对象为 Variant 类型，可读写。

  • 对于 Range 对象可读写。返回 Name 对象。使用 String 进行设置。

  • 对于 ChAxis、ChChart、ChFont、ChSeries、GroupingDef、Name、PageField、PivotFont、PivotHyperlink、PivotTotal、RecordsetDef、SchemaField、SchemaRowsource 和 Worksheet 对象为 String 类型，可读写。

  • 对于“应用于”列表中的所有其他对象为 String 类型，只读。

expression.Name

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例设置指定图表的名称。

ChartSpace1.Charts(0).Name = "Line Chart"

设置了图表名称后，可以通过名称引用图表，如下面示例所示。

ChartSpace1.Charts("Line Chart").HasLegend = True


Names 属性

显示 Names 属性应用于 Spreadsheet 和 Workbook 对象的情形。

返回表示活动工作簿中所有名称的 Names 集合。只读。

expression.Names

expression 必需。该表达式返回一个 Spreadsheet 或 Workbook 对象。

显示 Names 属性应用于 Worksheet 对象的情形。

返回表示指定工作表中定义的所有工作表级名称的 Names 集合。只读。

expression.Names

expression 必需。该表达式返回一个 Worksheet 对象。

示例

显示 应用于 Spreadsheet 和 Workbook 对象的情形。

下面示例创建活动工作簿中所有名称的列表，包括它们引用的地址。

Sub List_All_Names()
   Dim nmCurrentName
   Dim rngCurrent

   Set rngCurrent = Spreadsheet1.ActiveSheet.Range("A1")

   ' Loop through all of the names in the active workbook.
   For Each nmCurrentName In Spreadsheet1.ActiveWorkbook.Names

      ' Write the current name to the worksheet.
      rngCurrent.Value = nmCurrentName.Name

      ' Write the definition of the current name to the worksheet.
      rngCurrent.Offset(0, 1).Value = "'" & nmCurrentName.RefersTo

      Set rngCurrent = rngCurrent.Offset(1, 0)
   Next
End Sub


Next 属性

显示 Next 属性应用于 Range 对象的情形。

返回表示下一个单元格的 Range 对象。该属性类似于按 Tab 键，但与键击不同，该属性返回下一个单元格而并不选定。在保护工作表上，该属性返回下一个未锁定的单元格。

在未保护的工作表上，该属性通常返回指定单元格右侧相邻的单元格。

expression.Next

expression 必需。该表达式返回一个 Range 对象。

显示 Next 属性应用于 Worksheet 对象的情形。

返回表示下一个工作表的 Worksheet 对象。

expression.Next

expression 必需。该表达式返回一个 Worksheet 对象。

示例

显示 应用于 Range 对象的情形。

本示例选定活动工作表中的下一个非锁定单元格。如果活动工作表没有处于保护状态，该单元格即为活动单元格右侧相邻的单元格。

Spreadsheet1.ActiveCell.Next.Select


NextSection 属性

返回代表指定页上的下一物理节（无论是同一层还是上一层）的 Section 对象。该属性对于页面上的最后一节无效。只读。

expression.NextSection

expression 必需。该表达式返回一个 Section 对象。


NextSibling 属性

返回表示当前数据访问页中下一个同级项的 Section 对象。这可能导致下一页记录进行自填充。该属性不能跨越父层，并对当前数据访问页的最后一个同级项无效。

expression.NextSibling

expression 必需。该表达式 返回一个 Section 对象。


NumberFormat 属性

返回或设置指定对象的数字格式。对于 Range 对象为 Variant 类型，可读写。对于“应用于”列表中的所有其他对象为 String 类型，可读写。

expression.NumberFormat

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

您可通过使用与 Microsoft Excel 相同的格式代码来定义数字格式。有关数字格式代码的信息，请参阅 Microsoft Excel 帮助中的“创建或删除自定义数字格式”主题。

示例

本示例设置活动工作表上区域 A1:E10 和 F1:F10 的数字格式。

Sub FormatCells()

   Spreadsheet1.ActiveSheet.Range("A1:E10").NumberFormat = "0.###"
   Spreadsheet1.ActiveSheet.Range("F1:F10").NumberFormat = "Currency"

End Sub


NumericScale 属性

返回数字类型在小数点右边可以带有的最大小数位数。Long 类型，只读。

expression.NumericScale

expression 必需。该表达式 返回一个 SchemaParameter 对象。


ObjectType 属性

返回一个 ChartSelectionsEnum 常量，表示当前选定的对象类型。

ChartSelectionsEnum 可以为下列 ChartSelectionsEnum 常量之一。
chSelectionAxis
chSelectionCategoryLabel
chSelectionChart
chSelectionChartSpace
chSelectionDataLabel
chSelectionDataLabels
chSelectionDropZone
chSelectionErrorbars
chSelectionField
chSelectionGridlines
chSelectionLegend
chSelectionLegendEntry
chSelectionNone
chSelectionPlotArea
chSelectionPoint
chSelectionSeries
chSelectionSurface
chSelectionTitle
chSelectionTrendline
chSelectionUserDefined

expression.ObjectType

expression 必需。该表达式返回“应用于”列表中的对象之一。


Offline 属性

返回一个 Boolean 类型，表示 Microsoft Internet Explorer 是否处于脱机状态。只读。

expression.Offline

expression 必需。该表达式返回一个 DataSourceControl 对象。

示例

本示例更改标志控件的文本，指出在数据访问页绑定到数据源之前为脱机状态。

Sub MSODSC_BeforeInitialBind(DSCEventInfo)

   If MSODSC.Offline = True then
      Label.innerText = "Offline"
   Else
      Label.innerText = "Online"
   End If

End Sub


OfflinePublication 属性

返回或设置一个 String 类型，表示数据访问页脱机时使用的发布内容。可读写。

expression.OfflinePublication

expression 必需。该表达式返回一个 DataSourceControl 对象。

说明

该属性仅在 OfflineType 属性设置为 dscOfflineMerge 时有效。


OfflineSource 属性

返回或设置一个 String 类型，表示数据访问页脱机时使用的数据源。可读写。

expression.OfflineSource

expression 必需。该表达式返回一个 DataSourceControl 对象。

说明

该属性的设置值因 OfflineType 和 XMLLocation 属性的当前设置而异。如果 OfflineType 属性设置为 dscOfflineMerge，则该属性应设置为到本地 MSDE 数据库的连接字符串。如果 OfflineType 属性设置为 dscOfflineXMLDataFile 并且 XMLLocation 属性设置为 dscXMLDataFile，则该属性应设置为包含 XML 数据文件路径的字符串。

示例

本示例根据名为 MSODSC 的数据源控件设置脱机设置。

Sub SetOfflineSettings()

   Dim dscConstants

   Set dscConstants = MSODSC.Constants

   ' Set the offline type.
   MSODSC.OfflineType = dscConstants.dscOfflineXMLDataFile

   ' Set the location of the XML data to a data file.
   MSODSC.XMLLocation = dscconstants.dscXMLDataFile

   ' Set the XML data file to use when the page is offline.
   MSODSC.OfflineSource = "Q1 Sales Analysis.xml"

End Sub


OfflineType 属性

返回或设置一个 DscOfflineTypeEnum 常量，表示数据访问页脱机时用于持续提供数据的连接类型。可读写。

DscOfflineTypeEnum 可以为下列 DscOfflineTypeEnum 常量之一。
dscOfflineMerge 数据存储在本地 MSDE 数据库中。
dscOfflineNone 数据访问页脱机时数据不可用。
dscOfflineWorkflow 不支持该属性。
dscOfflineXMLDataFile 数据存储在 XML 数据文件中。

expression.OfflineType

expression 必需。该表达式返回一个 DataSourceControl 对象。

示例

本示例根据名为 MSODSC 的数据源控件设置脱机设置。

Sub SetOfflineSettings()

   Dim dscConstants

   Set dscConstants = MSODSC.Constants

   ' Set the offline type.
   MSODSC.OfflineType = dscConstants.dscOfflineXMLDataFile

   ' Set the location of the XML data to a data file.
   MSODSC.XMLLocation = dscconstants.dscXMLDataFile

   ' Set the XML data file to use when the page is offline.
   MSODSC.OfflineSource = "Q1 Sales Analysis.xml"

End Sub


Offset 属性

返回表示与指定区域具有一定偏移的区域的 Range 对象。

expression.Offset(RowOffset, ColumnOffset)

expression 必需。该表达式返回一个 Range 对象。

RowOffset Variant 类型，可选。区域偏移的行数（正数、负数或 0（零））。正数表示向下偏移，负数表示向上偏移。默认值为 0。

ColumnOffset Variant 类型，可选。区域偏移的列数（正数、负数或 0（零））。正数表示向右偏移，负数表示向左偏移。默认值为 0。

示例

本示例设置活动单元格右侧隔一列的单元格内容的字体。

Spreadsheet1.ActiveCell.Offset(0, 1).Font.Bold = True

本示例对 Spreadsheet1 活动工作表的 A 列中的相邻数值进行循环，并删除包含奇数值的行。

Sub Delete_Odd_Values()

    Spreadsheet1.ActiveSheet.Range("A1").Select

    ' Loop until an empty cell is selected.
    Do Until IsEmpty(Spreadsheet1.ActiveCell)

        ' If the active cell contains an odd number.
        If Spreadsheet1.ActiveCell.Value Mod 2 = 1 Then
            ' Delete the row.
            Spreadsheet1.ActiveCell.EntireRow.Delete
        Else
            ' Select the next cell.
            Spreadsheet1.ActiveCell.Offset(1, 0).Select
        End If
    Loop
End Sub


OneSide 属性

显示 OneSide 属性应用于 PageRelatedField 对象的情形。

返回一个 PageField 对象，表示一对多关系中“一”侧页面行来源所对应字段。

expression.OneSide

expression 必需。该表达式返回一个 PageRelatedField 对象。

显示 OneSide 属性应用于 PageRelationship 对象的情形。

返回一个 PageRowsource 对象，表示一对多关系中“一”侧的页面行来源。

expression.OneSide

expression 必需。该表达式返回一个 PageRelationship 对象。

显示 OneSide 属性应用于 SchemaRelatedField 和 SchemaRelationship 对象的情形。

返回指定一对多关系中“一”侧方案字段或方案行来源的名称。String 类型，只读。

expression.OneSide

expression 必需。该表达式返回上述对象之一。


Order 属性

返回或设置指定趋势线的多项式顺序（大于 1 的整数）。如果为线性趋势线设置该属性，将使其成为多项式趋势线。Long 类型，可读写。

expression.Order

expression 必需。该表达式返回一个 ChTrendline 对象。

示例

本示例设置指定趋势线的顺序。

ChartSpace1.Charts(0).SeriesCollection(0).Trendlines(0).Order = 2


OrderedMembers 属性

返回或设置一个 Variant 类型，确定当 SortDirection 属性设置为 plSortDirectionCustom、plSortDirectionCustomAscending 或 plSortDirectionCustomDescending 时字段成员的排序方式。将该属性设置为成员数组，成员按希望在数据透视表列表显示的次序排序。在设置该属性时，可以传递成员名称、成员唯一名称或成员对象引用的数组。在检索该属性时，数组通常包含 PivotMember 对象引用。可读写。

expression.OrderedMembers

expression 必需。该表达式返回一个 PivotField 对象。

说明

字段中未列在该数组中的任何成员将显示在数组中最后一个成员之下。

设置该属性将替换当前列表。要在已有列表中添加项，必须检索列表并添加成员，或使用变量保持当前列表、追加成员，然后重置该属性。

允许传递当前不在数据结果中的成员名称或唯一名称。如果传递了不能解析为结果成员的名称或唯一名称，将转换为 IsValid 属性设置为 False 的 PivotMember 对象。

要清除该列表，请将该属性设置为 Empty 或零元素数组。

示例

本示例在 Title 字段中创建自定义排序次序。

Sub CustomSort()

   Dim ptConstants
   Dim ptView
   Dim pfTitle

   Set ptConstants = PivotTable1.Constants

   Set ptView = PivotTable1.ActiveView

   ' Set a variable to the Title field.
   Set pfTitle = ptView.FieldSets("Title").Fields("Title")

   ' Specify the ordering for some of the items in the Title field.
   pfTitle.OrderedMembers = Array("Sales Representative", _
                                  "Sales Manager", "Vice President, Sales")

   ' Set the sort direction.
   pfTitle.SortDirection = ptConstants.plSortDirectionCustom

End Sub


Orientation 属性

对于 PivotFieldSet 对象：返回一个 PivotFieldSetOrientationEnum 常量，表示字段集方向。字段集可同时位于汇总坐标轴和列、行或筛选坐标轴。只读。

PivotFieldSetOrientationEnum 可以为下列 PivotFieldSetOrientationEnum 常量之一。
plOrientationColumnAxis
plOrientationDataAxis
plOrientationFilterAxis
plOrientationNone
plOrientationPageAxis
plOrientationRowAxis

对于 ChAxis 对象：返回或设置一个 Long 类型，表示指定坐标轴上的标志方向。可为 ChartLabelOrientationEnum 常量。可读写。

ChartLabelOrientationEnum 可以为下列 ChartLabelOrientationEnum 常量之一。
chLabelOrientationAutomatic
chLabelOrientationDownward
chLabelOrientationHorizontal
chLabelOrientationUpward

对于 ChScaling 对象：返回或设置一个 ChartScaleOrientationEnum 常量，表示刻度方向。更改该属性的值可翻转图表。可读写。

ChartScaleOrientationEnum 可以为下列 ChartScaleOrientationEnum 常量之一。
chScaleOrientationMaxMin
chScaleOrientationMinMax

expression.Orientation

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例设置指定坐标轴的刻度方向。

Sub SetAxisOrientation()

   Dim chConstants

   Set chConstants = ChartSpace1.Constants

   ChartSpace1.Charts(0).Axes(1).Scaling.Orientation = chConstants.chScaleOrientationMaxMin

End Sub


Overlap 属性

返回或设置单个类别中标志之间的重叠量。正数导致标志重叠，负数导致标志分离。默认值为零 (0)，有效范围从 –100 到 100。Long 类型，可读写。

expression.Overlap

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例设置指定图表的重叠值。

ChartSpace1.Charts(0).Overlap = 25


PageAxis 属性

对于 PivotView 对象：返回一个 PivotGroupAxis 对象，表示页坐标轴。

对于 PivotData 对象：返回一个 PivotResultGroupAxis 对象，表示页坐标轴。

expression.PageAxis

expression 必需。该表达式返回一个 PivotView 或 PivotData 对象。


PageFields 属性

返回指定记录集定义的 PageFields 集合。

expression.PageFields

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


PageMember 属性

对于 PivotCell 对象：返回一个 PivotPageMember 对象。表示指定单元格的页成员。

对于 PivotResultPageAxis 对象：返回一个 PivotPageMember 对象，表示指定结果坐标轴的页成员。

expression.PageMember

expression 必需。该表达式返回一个 PivotCell 或 PivotResultPageAxis 对象。


PageRelatedFields 属性

返回指定的页面关系的 PageRelatedFields 集合。只读。

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。

expression.PageRelatedFields

expression 必需。该表达式返回一个 PageRelationship 对象。


PageRowsource 属性

返回指定的页字段的 PageRowsource 对象。只读。

expression.PageRowsource

expression 必需。该表达式返回一个 PageField 对象。


PageRowsources 属性

返回指定的记录集定义的 PageRowsources 集合。

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。

expression.PageRowsources

expression 必需。该表达式返回一个 RecordsetDef 对象。


Panes 属性

返回指定工作表的 Panes 集合。

expression.Panes

expression 必需。该表达式 返回一个 Window 对象。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。

示例

本示例为指定窗格中的可见区域设置变量，并显示区域的位置。

Sub SetVisibleRange()

   Dim rngVisible

   Set rngVisible = Spreadsheet1.ActiveSheet.Panes(1).VisibleRange

   MsgBox "rngVisible.Address " & vr.Address

End Sub


ParameterValues 属性

返回指定记录集定义的 ParameterValues 集合。

expression.ParameterValues

expression 必需。该表达式 返回一个 RecordsetDef 对象。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


Parent 属性

返回指定对象的父对象。

expression.Parent

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例的事件过程将在用户单击图表工作区时运行。

Sub ChartSpace1_Click()

   Dim chConstants
   Dim iSeriesNum
   Dim iPointNum

   Set chConstants = ChartSpace1.Constants

   If ChartSpace1.SelectionType = chConstants.chSelectionPoint Then
      ' Point parent is series.
      iSeriesNum = ChartSpace1.Selection.Parent.Index

      iPointNum = ChartSpace1.Selection.Index

      MsgBox "Series: " & iSeriesNum & " Point: " & iPointNum
   End If

End Sub


ParentAxisMember 属性

返回一个 PivotAxisMember 对象，表示指定坐标轴成员的父成员。

expression.ParentAxisMember

expression 必需。该表达式返回一个 PivotAxisMember 对象。

说明

如果将该属性应用于顶层坐标轴成员，该属性返回 Nothing。


ParentColumnMember 属性

返回一个 PivotColumnMember 对象，表示指定列成员的父成员。

expression.ParentColumnMember

expression 必需。该表达式返回一个 PivotColumnMember 对象。

说明

如果该属性应用于顶层列成员，该属性返回 Nothing。


ParentLabel 属性

返回一个 ChCategoryLabel 对象，表示指定标志的父标志。

expression.ParentLabel

expression 必需。该表达式返回一个 ChCategoryLabel 对象。

说明

将该属性应用于没有父标志的标志将导致运行时出错。


ParentMember 属性

返回一个表示指定成员的父成员的 PivotMember 对象。

expression.ParentMember

expression 必需。该表达式返回“应用于”列表中的对象之一。


ParentPageMember 属性

返回一个 PivotPageMember 对象，表示指定页成员的父成员。

expression.ParentPageMember

expression 必需。该表达式返回一个 PivotPageMember 对象。


ParentRecordsetDef 属性

返回一个表示指定记录集定义的父对象的 RecordsetDef 对象。

expression.ParentRecordsetDef

expression 必需。该表达式 返回一个 RecordsetDef 对象。


ParentRowMember 属性

返回一个 PivotRowMember 对象，表示指定行成员的父成员。

expression.ParentRowMember

expression 必需。该表达式返回一个 PivotRowMember 对象。

说明

如果该属性应用于顶层行成员，该属性返回 Nothing。


ParentSection 属性

返回一个表示指定节的父对象的 Section 对象。

expression.ParentSection

expression 必需。该表达式 返回一个 Section 对象。


Path 属性

返回一个 String 类型，表示指定成员的路径。只读。

expression.Path(Format)

expression 必需。该表达式返回一个 PivotMember 对象。

Format PivotMemberFindFormatEnum 类型，必需。

PivotMemberFindFormatEnum 可以为下列 PivotMemberFindFormatEnum 常量之一。
plFindFormatMember 对该属性无效。
plFindFormatPathHex
plFindFormatPathInt
plFindFormatPathName


Pattern 属性

返回 ChartPatternTypeEnum 常量，表示指定 ChInterior 对象的填充图案。只读。

ChartPatternTypeEnum 可以为下列 ChartPatternTypeEnum 常量之一。
chPattern10Percent
chPattern20Percent
chPattern25Percent
chPattern30Percent
chPattern40Percent
chPattern50Percent
chPattern5Percent
chPattern60Percent
chPattern70Percent
chPattern75Percent
chPattern80Percent
chPattern90Percent
chPatternDarkDownwardDiagonal
chPatternDarkHorizontal
chPatternDarkUpwardDiagonal
chPatternDarkVertical
chPatternDashedDownwardDiagonal
chPatternDashedHorizontal
chPatternDashedUpwardDiagonal
chPatternDashedVertical
chPatternDiagonalBrick
chPatternDivot
chPatternDottedDiamond
chPatternDottedGrid
chPatternHorizontalBrick
chPatternLargeCheckerBoard
chPatternLargeConfetti
chPatternLargeGrid
chPatternLightDownwardDiagonal
chPatternLightHorizontal
chPatternLightUpwardDiagonal
chPatternLightVertical
chPatternNarrowHorizontal
chPatternNarrowVertical
chPatternOutlinedDiamond
chPatternPlaid
chPatternShingle
chPatternSmallCheckerBoard
chPatternSmallConfetti
chPatternSmallGrid
chPatternSolidDiamond
chPatternSphere
chPatternTrellis
chPatternWave
chPatternWeave
chPatternWideDownwardDiagonal
chPatternWideUpwardDiagonal
chPatternZigZag

expression.Pattern

expression 必需。该表达式返回一个 ChInterior 对象。

说明

使用 SetPatterned 方法设置 ChInterior 对象的图案。


PercentComplete 属性

返回一个 Long 类型，表示当前操作的已完成部分。只有 RecordsetSaveProgress 事件支持该属性。只读。

expression.PercentComplete

expression 必需。该表达式返回一个 DSCEventInfo 对象。

说明

在 RecordsetSaveProgress 事件中使用该属性更新容器中的控件，例如状态栏。

在不支持的事件中使用该属性将导致运行时出错。

示例

本示例在保存 DataSourceControl 对象中的记录集时使用 RecordsetSaveProgess 事件更新 Microsoft Internet Explorer 的状态栏。

Sub MSODSC_RecordsetSaveProgress(DSCEventInfo)

    ' Update the status bar with the current
    ' completion percentage.
    Window.Status = DSCEventInfo.PercentComplete

    ' Check to see if the save has been completed.
    If DSCEventInfo.PercentComplete = 100 then

        ' Clear the status bar when the save is complete.
        Window.Status = ""
    End If

End Sub


Period 属性

返回或设置一个 Long 类型，表示移动平均趋势线的周期。可读写。

expression.Period

expression 必需。该表达式返回一个 ChTrendline 对象。


Perspective 属性

返回或设置一个 Long 类型，指定三维图表的透视系数值。如果图表的 ProjectionMode 属性设置为 chProjectionModeOrthographic，该属性无效。有效范围为 0 到 80。可读写。

expression.Perspective

expression 必需。该表达式返回一个 ChChart 对象

示例

本示例将 Chartspace1 中的第一个图表转换为三维柱形图，然后设置图表的透视系数值。

Sub SetPerspective()

    Dim cht3DColumn

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DColumn = ChartSpace1.Charts(0)

    ' Change the chart to a 3-D Column chart.
    cht3DColumn.Type = chChartTypeColumnClustered3D

    ' Set the perspective.
    cht3DColumn.Perspective = 35

End Sub


PivotAxis 属性

返回指定分类标志或数据系列的 PivotResultGroupAxis 对象。

expression.PivotAxis

expression 必需。该表达式返回一个 ChCategoryLabels 或 ChSeriesCollection 对象。


PivotObject 属性

显示 PivotObject 属性应用于 ChPoint 对象的情形。

返回一个 Object 类型，表示指定点对应的数据透视表对象。

expression.PivotObject(Dimension)

expression 必需。该表达式返回上面对象之一。

Dimension ChartDimensionsEnum 类型，必需。

ChartDimensionsEnum 可以为下列 ChartDimensionsEnum 常量之一。
chDimBubbleValues
chDimCategories
chDimCharts
chDimCloseValues
chDimFilter
chDimFormatValues
chDimHighValues
chDimLowValues
chDimOpenValues
chDimRValues
chDimSeriesNames
chDimThetaValues
chDimValues
chDimXValues
chDimYValues

显示 PivotObject 属性应用于 ChCategoryLabel、ChChartField、ChLegendEntry 和 ChSeries 对象的情形。

返回一个 Object 类型，表示指定对象对应的数据透视表对象。

expression.PivotObject

expression 必需。该表达式返回上面对象之一。

说明

如果图表没有绑定到关系数据源，该属性返回 Null。


PlotAllAggregates 属性

返回或设置一个 ChartPlotAggregatesEnum 常量，确定当图表控件绑定到关系数据源时绘制的字段。可读写。

ChartPlotAggregatesEnum 可以为下列 ChartPlotAggregatesEnum 常量之一。
chPlotAggregatesCategories 绘制数据透视表列表中的所有数据字段。
chPlotAggregatesCharts
chPlotAggregatesFromTotalOrientation
chPlotAggregatesNone 只绘制数据透视表列表中的第一个数据字段。
chPlotAggregatesSeries 以内嵌于最内层的系列绘制多个数据字段。

expression.PlotAllAggregates

expression 必需。该表达式返回一个 ChartSpace 对象。

说明

该属性仅在图表数据区域添加了多个字段时有效。


PlotArea 属性

返回一个表示指定图表上绘图区的 ChPlotArea 对象。请注意饼图、圆环图、雷达图和极坐标图没有绘图区。

expression.PlotArea

expression 必需。该表达式 返回一个 ChChart 对象。

示例

本示例设置指定图表上绘图区的内部颜色。

ChartSpace1.Charts(0).PlotArea.Interior.Color = "Green"


Points 属性

返回指定系列的 ChPoints 集合。

expression.Points

expression 必需。该表达式 返回一个 ChSeries 对象。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。

示例

本示例设置指定系列第二点的内部颜色。

ChartSpace1.Charts(0).SeriesCollection(0).Points(2).Interior.Color = "green"


Position 属性

返回或设置对象的位置。

  • ChAxis 对象的 ChartAxisPositionEnum 类型，可读写。

ChartAxisPositionEnum 可为以下 ChartAxisPositionEnum 常量之一：
chAxisPositionBottom
chAxisPositionCategory
chAxisPositionCircular
chAxisPositionLeft
chAxisPositionPrimary
chAxisPositionRadial
chAxisPositionRight
chAxisPositionSecondary
chAxisPositionSeries
chAxisPositionTimescale
chAxisPositionTop
chAxisPositionValue
  • ChDataLabels 对象的 ChartDataLabelPositionEnum 类型，可读写。
ChartDataLabelPositionEnum 可为以下 ChartDataLabelPositionEnum 常量之一：
chLabelPositionAutomatic
chLabelPositionBottom
chLabelPositionCenter
chLabelPositionInsideBase
chLabelPositionInsideEnd
chLabelPositionLeft
chLabelPositionOutsideBase
chLabelPositionOutsideEnd
chLabelPositionRight
chLabelPositionTop
  • ChLegend 对象的 ChartLegendPositionEnum 类型，可读写。
ChartLegendPositionEnum 可为以下 ChartLegendPositionEnum 常量之一：
chLegendPositionAutomatic
chLegendPositionBottom
chLegendPositionLeft
chLegendPositionRight
chLegendPositionTop
  • ChTitle 对象的 ChartTitlePositionEnum 类型，可读写。
ChartTitlePositionEnum 可为以下 ChartTitlePositionEnum 常量之一：
chTitlePositionAutomatic
chTitlePositionBottom
chTitlePositionLeft
chTitlePositionRight
chTitlePositionTop

expression.Position

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例在指定图表绘图区的左侧放置图例。

Sub AddLegend()

   Dim chConstants

   Set chConstants = ChartSpace1.Constants

   ' Enbable the legend for the first chart in Chartspace1.
   ChartSpace1.Charts(0).HasLegend = True

   ' Set the position of the legend.
   ChartSpace1.Charts(0).Legend.Position = chConstants.chLegendPositionLeft

End Sub


Precision 属性

返回数字类型可以使用的最大位数。Long 类型，只读。

expression.Precision

expression 必需。该表达式 返回一个 SchemaParameter 对象。


PrefixCharacter 属性

返回指定区域的前缀字符。如果指定区域包含在输入工作表时以单引号开始的值，则返回单引号 (')。如果指定区域不包含前缀字符，则返回空字符串。Variant 类型，只读。

expression.PrefixCharacter

expression 必需。该表达式返回一个 Range 对象。

示例

本示例删除 Spreadsheet1 中活动工作表的所有前缀字符。

Sub Delete_PrefixCharacters()
    Dim rngCell

    ' Loop through all used cells in the active worksheet.
    For Each rngCell In Spreadsheet1.ActiveSheet.UsedRange

        ' If a prefix character exists, delete it.
        If rngCell.PrefixCharacter <> "" Then
            rngCell.Value = rngCell.Value
        End If
    Next
End Sub


PresetGradientType 属性

返回 ChartPresetGradientTypeEnum 常量，表示指定 ChInterior 对象的预设渐变类型。只读。

ChartPresetGradientTypeEnum 可以为下列 ChartPresetGradientTypeEnum 常量之一。
chGradientBrass
chGradientCalmWater
chGradientChrome
chGradientChromeII
chGradientDaybreak
chGradientDesert
chGradientEarlySunset
chGradientFire
chGradientFog
chGradientGold
chGradientGoldII
chGradientHorizon
chGradientLateSunset
chGradientMahogany
chGradientMoss
chGradientNightfall
chGradientOcean
chGradientParchment
chGradientPeacock
chGradientRainbow
chGradientRainbowII
chGradientSapphire
chGradientSilver
chGradientWheat

expression.PresetGradientType

expression 必需。该表达式返回一个 ChInterior 对象。

说明

使用 SetPresetGradient 方法设置填充的预设渐变类型。


PresetTexture 属性

返回 ChartPresetTextureEnum 常量，表示指定 ChInterior 对象的预设纹理。只读。

ChartPresetTextureEnum 可以为下列 ChartPresetTextureEnum 常量之一。
chTextureBlueTissuePaper
chTextureBouquet
chTextureBrownMarble
chTextureCanvas
chTextureCork
chTextureDenim
chTextureFishFossil
chTextureGranite
chTextureGreenMarble
chTextureMediumWood
chTextureNewsprint
chTextureOak
chTexturePaperBag
chTexturePapyrus
chTextureParchment
chTexturePinkTissuePaper
chTexturePurpleMesh
chTextureRecycledPaper
chTextureSand
chTextureStationery
chTextureWalnut
chTextureWaterDroplets
chTextureWhiteMarble
chTextureWovenMat

expression.PresetTexture

expression 必需。该表达式返回一个 ChInterior 对象。

说明

使用 SetTextured 方法设置 ChInterior 对象的预设纹理。


Previous 属性

显示 Previous 属性应用于 Range 对象的情形。

返回表示上一个单元格的 Range 对象。该属性类似于按 Shift+Tab 键，但与键击组合不同，该属性返回上一个单元格而并不选定。

在保护工作表上，该属性返回上一个未锁定的单元格。在未保护的工作表上，该属性通常返回指定单元格左侧相邻的单元格。

如果指定区域中的活动单元格在 A 列，使用该属性将导致运行时出错。

expression.Previous

expression 必需。该表达式返回一个 Range 对象。

显示 Previous 属性应用于 Worksheet 对象的情形。

返回表示上一个工作表的 Worksheet 对象。

expression.Previous

expression 必需。该表达式返回一个 Worksheet 对象。

示例

显示 应用于 Range 对象的情形。

本示例选定活动工作表中上一个非锁定单元格。

Spreadsheet1.ActiveCell.Previous.Select


PreviousSection 属性

返回一个 Section 对象，表示指定页上的前一节。无论是同级项还是父类。对于页面上的第一节，该属性无效。

expression.PreviousSection

expression 必需。该表达式 返回一个 Section 对象。


PreviousSibling 属性

返回一个表示当前数据访问页中前一同级项的 Section 对象。对于当前数据访问页上的第一个同级项，该属性无效。

expression.PreviousSibling

expression 必需。该表达式 返回一个 Section 对象。


PrimaryPageRowsource 属性

返回一个 PageRowsource 对象，表示指定记录集定义的主页面行来源。在创建记录集定义时，在 Add 或 AddNew 方法中命名的行来源将成为主页面行来源。

expression.PrimaryPageRowsource

expression 必需。该表达式 返回一个 RecordsetDef 对象。


PrintQuality3D 属性

返回或设置一个 Double 类型，表示三维图表打印分辨率与打印机分辨率的比值。有效范围为 0 到 1。默认值为 0.25。可读写。

expression.PrintQuality3D

expression 必需。该表达式返回一个 ChartSpace 对象。

说明

该属性值越低，三维图表的打印速度越快。但是，该属性设置得太低得不到满意的打印效果。

示例

本示例设置 Chartspace1 中的三维图表以 75% 的打印机分辨率进行打印。

Chartspace1.PrintQuality3D = 0.75


ProjectionMode 属性

返回或设置指定三维图表透视视图的 ChartProjectionModeEnum 常量。可读写。

ChartProjectionModeEnum 可以为下列 ChartProjectionModeEnum 常量之一。
chProjectionModeOrthograph 该视图不应用透视。使用这种投影的优点是垂直线条保持垂直，使某些图表易于阅读。
chProjectionModePerspective 提供最逼真的三维效果。对象向远处会聚于消失点。这是默认投影。

expression.ProjectionMode

expression 必需。该表达式返回一个 ChChart 对象。

示例

本示例将 Chartspace1 中的第一个图表转换为三维柱形图，然后设置图表的投影模式。

Sub SetExtrudeAngle()

    Dim cht3DColumn
    Dim chConstants

    Set chConstants = Chartspace1.Constants

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DColumn = ChartSpace1.Charts(0)

    ' Change the chart to a 3D Column chart.
    cht3DColumn.Type = chChartTypeColumnClustered3D

    ' Sets the projection mode to orthographic.
    cht3DColumn.ProjectionMode = chConstants.chProjectionModeOrthographic

    ' Sets the extrusion angle.
    cht3DColumn.ExtrudeAngle = 75

End Sub


PropertyCaptionFont 属性

返回一个 PivotFont 对象，表示指定视图中用于显示 OLAP 成员属性标题的字体设置。使用返回的对象设置成员属性标题的字体格式。

expression.PropertyCaptionFont

expression 必需。该表达式返回一个 PivotView 对象。

示例

本示例设置 PivotTable1 活动视图中成员属性的标题和数值的对齐方式和字体格式。

Sub Format_MemberProperties()

    Dim ptView
    Dim ptConstants

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the current PivotTable view.
    Set ptView = PivotTable1.ActiveView

    ' The following three lines of code format the
    ' font for member property captions.
    ptView.PropertyCaptionFont.Name = "Tahoma"
    ptView.PropertyCaptionFont.Size = 8
    ptview.PropertyCaptionFont.Bold = True

    ' Left-align the member property captions.
    ptview.PropertyCaptionHAlignment = ptConstants.plHAlignLeft

    ' The following two lines of code format the
    ' font for member property values.
    ptview.PropertyValueFont.Name = "Tahoma"
    ptview.PropertyValueFont.Size = 8

    ' Right-align the member property values.
    ptview.PropertyValueHAlignment = ptConstants.plHAlignRight

End Sub


PropertyCaptionHAlignment 属性

返回或设置一个 PivotHAlignmentEnum 常量，表示指定视图中 OLAP 成员属性标题的水平对齐方式。使用该属性可设置成员属性标题的水平对齐方式。可读写。

PivotHAlignmentEnum 可以为下列 PivotHAlignmentEnum 常量之一。
plHAlignAutomatic
plHAlignCenter
plHAlignLeft
plHAlignRight

expression.PropertyCaptionHAlignment

expression 必需。该表达式返回一个 PivotView 对象。

示例

本示例设置 PivotTable1 活动视图中成员属性的标题和数值的对齐方式和字体格式。

Sub Format_MemberProperties()

    Dim ptView
    Dim ptConstants

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the current PivotTable view.
    Set ptView = PivotTable1.ActiveView

    ' The following three lines of code format the
    ' font for member property captions.
    ptView.PropertyCaptionFont.Name = "Tahoma"
    ptView.PropertyCaptionFont.Size = 8
    ptview.PropertyCaptionFont.Bold = True

    ' Left-align the member property captions.
    ptview.PropertyCaptionHAlignment = ptConstants.plHAlignLeft

    ' The following two lines of code format the
    ' font for member property values.
    ptview.PropertyValueFont.Name = "Tahoma"
    ptview.PropertyValueFont.Size = 8

    ' Right-align the member property values.
    ptview.PropertyValueHAlignment = ptConstants.plHAlignRight

End Sub


PropertyCaptionWidth 属性

返回或设置一个 Long 类型，表示指定字段中显示的成员属性标题宽度。可读写。

expression.PropertyCaptionWidth

expression 必需。该表达式返回一个 PivotField 对象。


PropertyHeight 属性

返回或设置一个 Long 类型，表示指定字段中显示的成员属性高度。可读写。

expression.PropertyHeight

expression 必需。该表达式返回一个 PivotField 对象。


PropertyValueFont 属性

返回一个 PivotFont 对象，表示指定视图中用于显示 OLAP 成员属性值的字体设置。使用返回的对象设置成员属性值的字体格式。

expression.PropertyValueFont

expression 必需。该表达式返回一个 PivotView 对象。

示例

本示例设置 PivotTable1 活动视图中成员属性的标题和数值的对齐方式和字体格式。

Sub Format_MemberProperties()

    Dim ptView
    Dim ptConstants

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the current PivotTable view.
    Set ptView = PivotTable1.ActiveView

    ' The following three lines of code format the
    ' font for member property captions.
    ptView.PropertyCaptionFont.Name = "Tahoma"
    ptView.PropertyCaptionFont.Size = 8
    ptview.PropertyCaptionFont.Bold = True

    ' Left-align the member property captions.
    ptview.PropertyCaptionHAlignment = ptConstants.plHAlignLeft

    ' The following two lines of code format the
    ' font for member property values.
    ptview.PropertyValueFont.Name = "Tahoma"
    ptview.PropertyValueFont.Size = 8

    ' Right-align the member property values.
    ptview.PropertyValueHAlignment = ptConstants.plHAlignRight

End Sub


PropertyValueHAlignment 属性

返回或设置一个 PivotHAlignmentEnum 常量，表示指定视图中 OLAP 成员属性值的水平对齐方式。使用该属性可设置成员属性值的水平对齐方式。可读写。

PivotHAlignmentEnum 可以为下列 PivotHAlignmentEnum 常量之一。
plHAlignAutomatic
plHAlignCenter
plHAlignLeft
plHAlignRight

expression.PropertyValueHAlignment

expression 必需。该表达式返回一个 PivotView 对象。

示例

本示例设置 PivotTable1 活动视图中成员属性的标题和数值的对齐方式和字体格式。

Sub Format_MemberProperties()

    Dim ptView
    Dim ptConstants

    Set ptConstants = PivotTable1.Constants

    ' Set a variable to the current PivotTable view.
    Set ptView = PivotTable1.ActiveView

    ' The following three lines of code format the
    ' font for member property captions.
    ptView.PropertyCaptionFont.Name = "Tahoma"
    ptView.PropertyCaptionFont.Size = 8
    ptview.PropertyCaptionFont.Bold = True

    ' Left-align the member property captions.
    ptview.PropertyCaptionHAlignment = ptConstants.plHAlignLeft

    ' The following two lines of code format the
    ' font for member property values.
    ptview.PropertyValueFont.Name = "Tahoma"
    ptview.PropertyValueFont.Size = 8

    ' Right-align the member property values.
    ptview.PropertyValueHAlignment = ptConstants.plHAlignRight

End Sub


PropertyValueWidth 属性

返回或设置一个 Long 类型，表示指定字段中显示的成员属性值的宽度。可读写。

expression.PropertyValueWidth

expression 必需。该表达式返回一个 PivotField 对象。


PropNames 属性

返回一个字符串数组，包含 XML 列表 (/Map/Entry/Field@ID) 的架构映射中每一 Field 元素的 ID 属性值（按从左到右的次序），该次序与映射中 /Field/Range 元素的次序相对应。Variant 类型，只读。

expression.PropNames

expression 必需。该表达式返回一个 ListObject 对象。

说明

对于通过在 Microsoft Office Excel 2003 中将文件另存为 XML 电子表格文件所创建的 XML 列表，PropName 属性所返回的 ID 值与 ListObject 对象所代表的 XML 列表标题行中的列名称相对应。返回值在数组中的排列次序取决于 RightToLeft 属性设置。

示例

以下示例显示当活动单元格位于列表中时如何在列表中获取列名称：

Dim strFieldName
Dim objListObject

Set objListObject = Spreadsheet1.ActiveCell.ListObject
For Each strFieldName in objListObject.PropNames
  ' strFieldName now contains element (field) name for a column in the list.
Next


ProtectContents 属性

如果工作表内容处于保护状态，则返回 True。Boolean 类型，只读。

expression.ProtectContents

expression 必需。该表达式返回一个 Worksheet 对象。


Protection 属性

返回一个包含指定工作表保护信息的 Protection 对象。如果 Enabled 属性设置为 False，则忽略保护属性。

expression.Protection

expression 必需。该表达式 返回一个 Worksheet 对象。

示例

本示例锁定 B 列中的单元格并启用工作表保护。

Sub ProtectColumnB()

   ' Unlock all of the cells in the active sheet.
   Spreadsheet1.ActiveSheet.Cells.Locked = False

   ' Lock the cells in column B.
   Spreadsheet1.Columns(2).Locked = True

   ' Protect the locked cells.
   Spreadsheet1.ActiveSheet.Protection.Enabled = True

End Sub


ProtectionMode 属性

如果启用了用户界面专用保护，则返回 True。通常返回 True。Boolean类型，只读。

expression.ProtectionMode

expression 必需。该表达式返回一个 Worksheet 对象。


ProtectStructure 属性

如果工作簿中的工作表次序处于保护状态，则返回 True。Boolean 类型，只读。

expression.ProtectStructure

expression 必需。该表达式返回一个 Workbook 对象。


ProviderFormattedValue 属性

返回一个 Variant 类型，表示指定聚合按数据源格式的值。只读。

expression.ProviderFormattedValue

expression 必需。该表达式返回一个 PivotAggregate 对象。


ProviderType 属性

返回一个 ProviderType 常量，表示指定数据透视表列表的数据提供者类型。只读。

expression.ProviderType

expression 必需。该表达式返回一个 PivotTable 对象。


Range 属性

显示 应用于 AutoFilter 对象的情形。

返回一个 Range 对象，表示应用指定 AutoFilter 对象的单元格区域。

expression.Range

expression 必需。该表达式返回一个 AutoFilter 对象

显示 应用于 PivotData 对象的情形。

返回一个 PivotRange 对象，表示单元格或单元格区域。

expression.Range(TopLeft, BottomRight)

expression 该表达式返回一个 PivotData 对象。

TopLeft PivotCell 对象，必需。指定特定区域的左上角单元格。

BottomRight PivotCell 对象，必需。指定特定区域的右下角单元格。

显示 应用于 Range、Spreadsheet 和 Worksheet 对象的情形。

返回一个 Range 对象，表示单元格或矩形单元格区域。不能创建非矩形区域或包含不连续区域的区域。

expression.Range(Cell1, Cell2)

expression 该表达式返回一个 Range、Spreadsheet 或 Worksheet 对象。

Cell1 Variant 类型，必需。以 A1-样式引用（例如，“A1:C3”）指定整个区域。引用中可以包括区域运算符（冒号）、交集运算符（空格）或联合运算符（逗号）。还可以包括美圆符号，但是已经忽略。引用还可以通过包含单个单元格、整列或整行的 Range 对象或单个单元格的名称字符串指定区域的左上角单元格。如果 Cell1 指定区域中左上角的单元格，则 Cell2 为必需。

Cell2 Variant 类型，可选。（如果 Cell1 指定特定区域的左上角单元格，则该参数为必需。）指定区域右下角的单元格。可以为包含单个单元格、整列或整行的 Range 对象或单个单元格的名称字符串。

说明

该属性应用于 Range 对象时，参数指定相对于区域的单元格。本示例设置变量指向表示单元格 B5 的 Range 对象。

Set tempRange = Spreadsheet1.Range("b5:b10").range("a1")

显示 应用于 ListObject 对象的情形。

返回一个 Range 对象，表示指定 XML 列表所在区域。包括标题行（如存在）和插入行。只读。

expression.Range

expression 必需。该表达式返回一个 ListObject 对象。

说明

从 ListObject 对象返回的区域不支持 Range 对象的某些属性和方法。此时，将产生运行时错误。

不支持的属性包括 Locked、MergeArea 和 MergeCells。不支持的方法包括 Delete、Insert、Merge 和 UnMerge。

支持 AutoFilter 和 Sort 方法，但始终应用于整个列表。

显示 应用于 ListRow 对象的情形。

返回一个 Range 对象，表示指定 XML 列表行的应用区域。只读。

expression.Range

expression 必需。该表达式返回一个 ListRow 对象。

说明

从 ListRow 对象返回的区域不支持 Range 对象的某些属性和方法。此时，将产生运行时错误。

不支持的属性包括 Locked、MergeArea 和 MergeCells。不支持的方法包括 Delete、Insert、Merge 和 UnMerge。

示例

显示 应用于 Range、Spreadsheet 和 Worksheet 对象的情形。

本示例设置行 1 到行 10 的行高为 15 点。

Spreadsheet1.Range("a1:a10").RowHeight = 15

本示例设置变量指向一个区域，包括当前单元格区域 A1 中从第三列和第四列的第二个单元格到最后一行单元格。

Sub GetRange()

   Dim rngCurRegion
   Dim rngTempRange

   Set rngCurRegion = Spreadsheet1.Range("a1").CurrentRegion

   Set rngTempRange = rngCurRegion.Range(rngCurRegion.Cells(2, 3), _
       curRegion.Cells(rngCurRegion.Rows.Count, 4))

End Sub


RangeSelection 属性

返回表示指定窗口中工作表上选定单元格的 Range 对象。只读。

expression.RangeSelection

expression 必需。该表达式返回一个 Window 对象。

说明

该属性与 Selection 属性的功能相同。

示例

本示例设置选定单元格的字体为加粗。

Spreadsheet1.ActiveWindow.RangeSelection.Font.Bold = True


ReadingOrder 属性

返回或设置一个 Long 类型，表示指定对象的阅读次序。可为 XlReadingOrder 常量。可读写。

XlReadingOrder 可为下列 XlReadingOrder 常量之一。
xlRTL 从右到左
xlLTR 从左到右
xlContext

expression.ReadingOrder

expression 必需。该表达式返回一个 Range 对象。

说明

某些常量可能不可用，这取决于所选择或安装的语言支持（例如，美国英语）。


RecordNavigationSection 属性

如果指定联合节具有导航节，则返回 True。默认值为 True。Boolean 类型，可读写。

expression.RecordNavigationSection

expression 必需。该表达式返回一个 GroupLevel 对象。


RecordSelector 属性

返回或设置一个 Boolean 类型，表示是否显示指定分组的记录选择器。可读写。

expression.RecordSelector

expression 必需。该表达式返回一个 GroupLevel 对象。


Recordset 属性

对于 PivotCell 对象：返回一个 ADO Recordset 对象，包含单元格的明细记录（如果可用）。

对于 PivotData 对象：返回一个 ADO Recordset 对象，包含指定 PivotData 对象的明细记录（如果可用）。

对于 DataPage 对象：返回指定数据访问页的 ADO Recordset 对象。

expression.Recordset

expression 必需。该表达式返回“应用于”列表中的对象之一。


RecordsetDef 属性

返回指定页字段或页面行来源的容器 RecordsetDef 对象。

expression.RecordsetDef

expression 必需。该表达式返回“应用于”列表中的对象之一。


RecordsetDefs 属性

返回数据源控件的 RecordsetDefs 集合。

expression.RecordsetDefs

expression 必需。该表达式 返回一个 DataSourceControl 对象。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


RecordsetLabel 属性

当页面没有联合并显示一个记录时，以及页面已经联合并显示多个记录时，返回或设置记录导航控件的记录集标签。String 类型，可读写。

expression.RecordsetLabel

expression 必需。该表达式 返回一个 RecordNavigationControl 对象。

说明

标签由以分号分隔的两个字符串组成。第一个字符串表示页面上显示一个记录时显示的标签，第二个字符串表示页面上显示多个记录时显示的标签。标签可以包含下列占位符，用于在页面上显示记录集信息。

占位符 | 说明
|0 | 组中当前记录或第一个可见记录的号码。
|1 | 组中最后一个可见记录的号码。
|2 | 记录集中的记录数。

示例

本示例设置记录集的标签。如果页面已经联合并显示 8 个记录中的第 1 个到 5 个，则标签显示“Categories 1-5 of 8”。如果页面没有联合并显示第一个记录，则标签显示“Category 1 of 8”。

ProductNavigation.RecordsetLabel = _
    "Category |1 of |2;Categories |0-|1 of |2"


RecordsetType 属性

返回或设置数据源控件的记录集类型。DscRecordsetTypeEnum 类型，可读写。

DscRecordsetTypeEnum 可为以下 DscRecordsetTypeEnum 常量之一：
dscSnapshot
dscUpdatableSnapshot

expression.RecordsetType

expression 必需。该表达式 返回一个 DataSourceControl 对象。


RecordSource 属性

对于 ElementExtension 和 GroupLevel 对象：返回或设置一个 String 类型，表示节的记录源（记录集定义或分组定义的名称）。仅应用于 DIV 节。可读写。

对于 RecordNavigationControl 对象：返回或设置一个 DataMember 对象，表示节的记录源。可读写。

expression.RecordSource

expression 必需。该表达式返回“应用于”列表中的对象之一。


RefersTo 属性

以脚本语言或 A1-样式符返回或设置名称由引用定义的公式，并以等号开始。Variant 类型，可读写。

expression.RefersTo

expression 必需。该表达式返回一个 Name 对象。

示例

下面示例创建活动工作簿中所有名称的列表，包括所引用的公式。

Sub List_All_Names()
   Dim nmCurrentName
   Dim rngCurrent

   Set rngCurrent = Spreadsheet1.ActiveSheet.Range("A1")

   ' Loop through all of the names in the active workbook.
   For Each nmCurrentName In Spreadsheet1.ActiveWorkbook.Names

      ' Write the current name to the worksheet.
      rngCurrent.Value = nmCurrentName.Name

      ' Write the definition of the current name to the worksheet.
      rngCurrent.Offset(0, 1).Value = "'" & nmCurrentName.RefersTo

      Set rngCurrent = rngCurrent.Offset(1, 0)
   Next
End Sub


RefersToLocal 属性

返回或设置一个 Variant 类型，表示名称所引用的公式。公式以用户语言和 A1-样式符表示，并以等号开始。可读写。

expression.RefersToLocal

expression 必需。该表达式返回一个 Name 对象。

示例

下面示例创建活动工作簿中所有名称的列表，包括所引用的公式（以用户语言表示）。

Sub List_All_Names()
   Dim nmCurrentName
   Dim rngCurrent

   Set rngCurrent = Spreadsheet1.ActiveSheet.Range("A1")

   ' Loop through all of the names in the active workbook.
   For Each nmCurrentName In Spreadsheet1.ActiveWorkbook.Names

      ' Write the current name to the worksheet.
      rngCurrent.Value = nmCurrentName.Name

      ' Write the definition of the current name to the worksheet.
      rngCurrent.Offset(0, 1).Value = "'" & nmCurrentName.RefersToLocal

      Set rngCurrent = rngCurrent.Offset(1, 0)
   Next
End Sub


RefersToRange 属性

返回由 Name 对象引用的 Range 对象。如果 Name 对象没有引用区域（例如，引用常量或公式），该属性将产生运行时出错。只读。

expression.RefersToRange

expression 必需。该表达式返回一个 Name 对象。


ResyncCommand 属性

指定 SQL 命令，该命令以指定记录集唯一的表的主键为参数，以便该命令只返回一条记录。在更新或插入操作后，执行重新同步命令“整理”行。String 类型，可读写。

expression.ResyncCommand

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

对于任何表单，只要其基于包含连接或表达式列的存储过程，就必须设置该属性。在所有其他情况，Microsoft Access 可以自动整理表。如果没有设置该属性，用户在更新或插入操作后将看不到整理后的字段值，但是更新和插入仍将正确执行。


ReturnValue 属性

返回或设置指定事件的返回值。可以通过设置该属性为 False 来取消某些事件的默认操作。Boolean 类型，可读写。

expression.ReturnValue

expression 必需。该表达式返回一个 DSCEventInfo 对象。

示例

本示例使用 BeforeInsert 事件防止用户在记录集中记录达到 75 个时，再添加其他记录。

Sub MSODSC_BeforeInsert(DSCEventInfo)
   Dim rstCurrentData

   ' Set a variable to the recordset.
   Set rstCurrentData = DSCEventInfo.DataPage.Recordset

   ' Check to see if the recordset has reached its limit.
   If rstCurrentData.RecordCount >= 75 then

      ' Display a message to the user.
      MsgBox "Cannot add any more records."

      ' Cancel the insertion of the record.
      DSCEventInfo.ReturnValue = False
   End If
End Sub


RevisionNumber 属性

返回 Microsoft Office Web Components 的修订号。String 类型，只读。

expression.RevisionNumber

expression 必需。该表达式返回“应用于”列表中的对象之一。


Right 属性

显示 Right 属性应用于 ChPlotArea 对象的情形。

返回或设置一个 Long 类型，表示指定对象的右边。可读写。

expression.Right

expression 必需。该表达式返回一个 ChPlotArea 对象。

显示 Right 属性应用于 ChartSpace、ChAxis、ChCategoryLabel、ChChart、ChChartField、ChDataLabel、ChDataLabels、ChDropZone、ChErrorBars、ChLegend、ChLegendEntry、ChPoint、ChSeries、 ChScrollView、ChTitle 和 ChTrendline 对象的情形。

返回一个 Long 类型，表示指定对象的右边。只读。

expression.Right

expression 必需。该表达式返回上面对象之一。


RightToLeft 属性

如果启用从右到左语言支持，则返回 True。例如，该属性设置为 True，将使滚动条显示在左侧。Boolean 类型，可读写。

expression.RightToLeft

expression 必需。该表达式返回“应用于”列表中的对象之一。


Rotation 属性

返回或设置一个 Double 类型，表示指定三维图表的旋转角度。有效范围为 0 到 360。可读写。

expression.Rotation

expression 必需。该表达式返回一个 ChChart 对象。

示例

本示例将 Chartspace1 中的第一个图表转换为三维柱形图，然后将图表旋转 145 度。

Sub SetGapDepth()

    Dim cht3DColumn As ChChart

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DColumn = ChartSpace1.Charts(0)

    ' Change the chart to a 3-D Column chart.
    cht3DColumn.Type = chChartTypeColumn3D

    ' Rotate the chart.
    cht3DColumn.Rotation = 145

End Sub


Row 属性

返回指定区域中第一行的行号。Long 类型，只读。

expression.Row

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例在单元格 A1 的当前区域中，将颜色隔行设置为绿色。

Sub FormatRows()

   Dim rngCurrentRow

   ' Loop through all of the rows int he current region.
   For Each rngCurrentRow In Spreadsheet1.Cells(1, 1).CurrentRegion.Rows

      ' Check to see if the row number is an even number.
      If rngCurrentRow.Row Mod 2 = 0 Then

         ' Set the interior color of the row.
         rngCurrentRow.Interior.Color = "LightGreen"
      End If
   Next
End Sub


RowAxis 属性

对于 PivotData 对象：返回一个 PivotResultRowAxis 对象，表示行坐标轴。

对于 PivotView 对象：返回一个 PivotGroupAxis 对象，表示行坐标轴。

expression.RowAxis

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例在活动视图中向数据透视表列表插入两个字段。

Sub AddFieldsToPT()

   Dim ptView

   Set ptView = PivotTable1.ActiveView

   ptView.ColumnAxis.InsertFieldSet ptView.FieldSets("Store Type")

   ptView.RowAxis.InsertFieldSet ptView.FieldSets("Promotions")

End Sub


RowHeadings 属性

返回表示指定窗口中行标题的 Headings 集合。使用 Caption 属性自定义行标题。

expression.RowHeadings

expression 必需。该表达式返回一个 Window 对象。

示例

本示例通过禁用某些用户界面元素、限制活动窗口的可查看区域和自定义行列标题，设置并创建一个自定义数据输入工作表。

Sub Create_Datasheet()
    Dim hdrColHeadings
    Dim hdrRowHeadings
    Dim wndActive

    Set wndActive = Spreadsheet1.ActiveWindow

    ' Hide various UI elements.
    wndActive.DisplayWorkbookTabs = False
    Spreadsheet1.DisplayToolbar = False

    ' Display the title bar and set it's caption.
    Spreadsheet1.DisplayTitleBar = True
    Spreadsheet1.TitleBar.Caption = "Revenue Worksheet"

    ' Resize the spreadsheet component.
    Spreadsheet1.AutoFit = True

    ' Limit the viewable range of the active sheet.
    wndActive.ViewableRange = "A1:D5"

    ' Set a variable to the column headings in the active window.
    Set hdrColHeadings = wndActive.ColumnHeadings

    ' Set a variable to the row headings in the active window.
    Set hdrRowHeadings = wndActive.RowHeadings

    ' Set the headings of columns A through D.
    hdrColHeadings(1).Caption = "Qtr 1"
    hdrColHeadings(2).Caption = "Qtr 2"
    hdrColHeadings(3).Caption = "Qtr 3"
    hdrColHeadings(4).Caption = "Qtr 4"

    ' Set the headings of rows 1 though 5.
    hdrRowHeadings(1).Caption = "1996"
    hdrRowHeadings(2).Caption = "1997"
    hdrRowHeadings(3).Caption = "1998"
    hdrRowHeadings(4).Caption = "1999"
    hdrRowHeadings(5).Caption = "2000"
End Sub


RowHeight 属性

返回或设置指定区域中所有行的行高（磅）。如果行高不统一，则返回 Null。请使用 IsNull 函数判断返回值是否为 Null。Variant 类型，可读写。

expression.RowHeight

expression 必需。该表达式 返回一个 Range 对象。

示例

本示例将行 1 到行 10 的行高设置为 15 点。

Spreadsheet1.Range("a1:a10").RowHeight = 15


RowMember 属性

返回一个 PivotRowMember 对象，表示与指定单元格相交的行坐标轴上的内部成员。

expression.RowMember

expression 必需。该表达式返回“应用于”列表中的对象之一。


RowMembers 属性

返回一个包含行坐标轴上成员的 PivotRowMembers 集合。

expression.RowMembers

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


Rows 属性

Range 对象：返回一个表示指定区域中所有行的 Range 对象。

Spreadsheet 对象：返回一个表示活动工作表中所有行的 Range 对象。

Worksheet 对象：返回一个表示指定工作表上所有行的 Range 对象。

expression.Rows

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例在单元格 A1 的当前区域中，将文字隔行设置为加粗。

Sub BoldEvenRows()

   Dim rngCurrentRow

   ' Loop through the rows in the current region.
   For Each rngCurrentRow In Spreadsheet1.Cells(1, 1).CurrentRegion.Rows

      ' Check whenther the current row number is an even number.
      If rngCurrentRow.Row Mod 2 = 0 Then

         ' Bold the font in the current row.
         rngCurrentRow.Font.Bold = True
      End If
   Next
End Sub

本示例设置行 2 为加粗。

Spreadsheet1.Rows(2).Font.Bold = True


Scaling 属性

返回指定坐标轴的 ChScaling 对象。

expression.Scaling

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例在指定图表的右边添加第二个数值 (y) 坐标轴。第二个坐标轴使用与主数值坐标轴相同的刻度。

Sub AddAxis()

   Dim chConstants
   Dim axisScale

   Set chConstants = ChartSpace1.Constants

   Set axisScale = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionLeft).Scaling

   ChartSpace1.Charts(0).Axes.Add axisScale

End Sub


Scalings 属性

为指定图表或系列返回一个 ChScaling 对象。

expression.Scalings(Dimension)

expression 必需。该表达式返回“应用于”列表中的对象之一。

Dimension ChartDimensionsEnum 常量，必需。指定返回的维。

ChartDimensionsEnum 可为以下 ChartDimensionsEnum 常量之一：
chDimBubbleValues
chDimCategories
chDimCharts
chDimCloseValues
chDimFilter
chDimFormatValues
chDimHighValues
chDimLowValues
chDimOpenValues
chDimRValues
chDimSeriesNames
chDimThetaValues
chDimValues
chDimXValues
chDimYValues

示例

本示例设置指定 ChScaling 对象的最小值。

Sub SetScaling()

   Dim chConstants

   Set chConstants = ChartSpace1.Constants

   ChartSpace1.Charts(0).SeriesCollection(0).Scalings _
                 (chConstants.chDimCategories).Minimum = -10
End Sub


SchemaFields 属性

返回指定方案行来源的 SchemaFields 集合。

expression.SchemaFields

expression 必需。该表达式 返回一个 SchemaRowsource 对象。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


SchemaParameters 属性

返回指定方案行来源的 SchemaParameters 集合。

expression.SchemaParameters

expression 必需。该表达式 返回一个 SchemaRowsource 对象。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


SchemaRelatedFields 属性

返回指定方案关系的 SchemaRelatedFields 集合。

expression.SchemaRelatedFields

expression 必需。该表达式返回 SchemaRelationship 对象。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


SchemaRelationships 属性

返回数据源控件的 SchemaRelationships 集合。

expression.SchemaRelationships

expression 必需。该表达式返回 DataSourceControl 对象。


SchemaRowsources 属性

返回数据源控件的 SchemaRowsources 集合。

expression.SchemaRowsources

expression 必需。该表达式返回 DataSourceControl 对象。

说明

在设计模式，该集合自动以数据库信息填充。在浏览模式中，该集合包含指定页面所用的方案对象和用户明确添加的对象。

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


ScreenUpdating 属性

如果屏幕更新处于打开状态，则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ScreenUpdating

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

将该属性设置为 False 将使图表工作区或电子表格停止重绘。若要防止屏幕闪烁或不允许用户看见个别更新，可将该属性设置为 False，执行更新操作，然后将该属性重新设置为 True。将 ScreenUpdating 属性设置为 False 后，如果用户刷新了页面，并且对控件调用 Repaint 方法，则仍可重绘图表工作区或电子表格。

示例

本示例关闭屏幕更新。

Spreadsheet1.ScreenUpdating = False


ScrollColumn 属性

返回或设置窗格或窗口中最左侧的列号。如果窗格处于冻结状态，则该属性排除冻结区域。Long 类型，可读写。

expression.ScrollColumn

expression 必需。该表达式返回一个 Window 对象。

示例

本示例移动 C 列使其成为窗口中最左侧的列。

Spreadsheet1.ActiveWindow.ScrollColumn = 3


ScrollRow 属性

返回或设置窗格或窗口中顶部的行号。如果窗格处于冻结状态，则该属性排除冻结区域。Long 类型，可读写。

expression.ScrollRow

expression 必需。该表达式返回一个 Window 对象。

示例

本示例将第十行移动到窗口顶部。

Spreadsheet1.ActiveWindow.ScrollRow = 10


ScrollView 属性

使用 ScrollView 属性可返回图表的 ChScrollView 对象。ChScrollView 对象，只读。

expression.ScrollView

expression 必需。该表达式返回一个 ChChart 对象。

说明

ChartSpace 对象支持多个图表，各个图表可独立滚动。每个图表对应于一个 ChScrollView 对象。使用 ChScrollView 对象的属性和方法可检索图表滚动视图的有关信息和控制图表滚动视图。

示例

以下示例使用 ScrollView 属性执行 ChScrollView 对象的 SetPosition 方法：

Chartspace1.Charts(1).ScrollView.SetPosition (HorizontalPosition.Value + 200, VerticalPosition.Value + 200)


Section 属性

返回一个 Section 对象，表示发生指定事件的节。

expression.Section

expression 必需。该表达式返回 DSCEventInfo 对象。


Segments 属性

返回一个 ChSegments 对象，表示指定格式映射中的段集合。

expression.Segments

expression 必需。该表达式返回一个 ChFormatMap 对象。

示例

本示例将 Chartspace1 绑定到 SQL Server 罗斯文数据库中的 Order Details 表，然后创建一个格式映射。较小的值以白色显示，较大的值以蓝色阴影显示，图表中的最大值以深蓝色显示。

Sub Window_Onload()

    Dim serSeries1
    Dim segSegment1
    Dim chconstants

    Set chconstants = ChartSpace1.Constants

    ' The following two lines of code bind Chartspace1 to the Order Details table in the
    ' Northwind SQL Server database.
    ChartSpace1.ConnectionString = "Provider=SQLOLEDB.1;persist Security Info=TRUE;" & _
                                   "Integrated Security=SSPI;Initial Catalog=Northwind;" & _
                                   "Data Source=DataServer;"
    ChartSpace1.DataMember = "Order Details"

    ' The following two lines of code bind Chartspace1 to the Quantity and ProductID fields
    ' in the Order Details table.
    ChartSpace1.SetData chconstants.chDimCategories, chconstants.chDataBound, "ProductID"
    ChartSpace1.SetData chconstants.chDimValues, chconstants.chDataBound, "Quantity"

    ' Create a format map.
    ChartSpace1.SetData chconstants.chDimFormatValues, chconstants.chDataBound, "Quantity"

    ' Set a variable to the first series in the first chart in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a segment to the format map.
    Set segSegment1 = serSeries1.FormatMap.Segments.Add

    ' Specify that the divisions in formatting be created automatically.
    segSegment1.HasAutoDivisions = True

    ' Measure the segment boundaries based upon a percentage.
    segSegment1.Begin.ValueType = chconstants.chBoundaryValuePercent
    segSegment1.End.ValueType = chconstants.chBoundaryValuePercent

    ' Set the beginning value to 0%, and the ending value to 100%.
    segSegment1.Begin.Value = 0
    segSegment1.End.Value = 1

    ' Format the interior of the matching values.
    segSegment1.Begin.Interior.Color = "White"
    segSegment1.End.Interior.Color = "Blue"

End Sub


SelectedSheets 属性

返回指定窗口中所有选定工作表的 Sheets 集合。该集合将只包含一个工作表，即活动工作表。

expression.SelectedSheets

expression 必需。该表达式返回一个 Window 对象。


Selection 属性

对于 ChartSpace 对象：返回一个 Object 类型，表示选定对象。使用 TypeName 函数判断选定对象的类型。

对于 PivotTable 对象：返回或设置一个 Object 类型，表示选定对象。

对于 Spreadsheet 和 Window 对象：返回一个 Range 对象，表示选定单元格。

expression.Selection

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例中的过程在更改图表工作区中的选定内容时运行。如果用户选定坐标轴，过程显示坐标轴的最小值和最大值。

Sub ChartSpace1_SelectionChange()

   Dim chConstants
   Dim minval
   Dim maxval

   Set chConstants = ChartSpace1.Constants

   If ChartSpace1.SelectionType = chConstants.chSelectionAxis Then

      minval = ChartSpace1.Selection.Scaling.Minimum

      maxval = ChartSpace1.Selection.Scaling.Maximum

      MsgBox "minimum = " & minval & " maximum = " & maxval
   End If

End Sub


SelectionCollection 属性

SelectionCollection 属性返回 ChartSpace 对象的 ChSelectionCollection 集合。

expression.SelectionCollection

expression 必需。该表达式返回一个 ChartSpace 对象。

说明

ChSelectionCollection 对象包含图表中当前选择的所有对象。集合中的第一项为主要选项。其他项为辅助选项。由于 ChartSpace.SelectionCollection(0) 所返回的对象与 ChartSpace 对象的 Selection 属性所返回的对象相同，因此，该集合中的项数永不为零。集合中的第一个对象可为任何图表对象选项，但所有并发对象必须为数据点。如果 Selection 属性为空，并且没有辅助选项，则 SelectionCollection 将等于 0。

在 Chart 组件的用户界面中无法选择多项。必须通过编程手段向选项中添加项或从中删除项。若要在用户单击图表时捕获多个选项，必须监控鼠标移动和鼠标按钮事件，并使用 ChartSpace 对象的 RangeFromPoint 方法识别所选项。为了防止 Chart 组件的内置选项处理行为妨碍多选项的编程跟踪，必须确保将 ChartSpace 对象的 AllowUISelection 属性设置为 False。

示例

以下示例显示如何在图表中使用 SelectionCollection 属性迭代所选的一组数据点。

Dim intCount
Dim intIndex
With ChartSpace.Charts(0).SeriesCollection(0)
    .Points(0).Select2 1
    .Points(1).Select2 1
    .Points(2).Select2 1
    .Points(3).Select2 1
    .Points(4).Select2 1
End With
intCount = ChartSpace.SelectionCollection.Count

For intIndex = 0 To intCount - 1
  MsgBox "Item(" & iIndex & ") = " & TypeName(ChartSpace.SelectionCollection.Item(intIndex))
Next


SelectionType 属性

对于 ChartSpace 对象：返回一个 ChartSelectionsEnum 常量，表示图表工作区中当前选定的对象类型。只读。

ChartSelectionsEnum 可以为下列 ChartSelectionsEnum 常量之一。
chSelectionAxis
chSelectionCategoryLabel
chSelectionChart
chSelectionChartSpace
chSelectionDataLabel
chSelectionDataLabels
chSelectionDropZone
chSelectionErrorbars
chSelectionField
chSelectionGridlines
chSelectionLegend
chSelectionLegendEntry
chSelectionNone
chSelectionPlotArea
chSelectionPoint
chSelectionSeries
chSelectionSurface
chSelectionTitle
chSelectionTrendline
chSelectionUserDefined

对于 PivotTable 对象：返回一个 String 类型，表示数据透视表列表中当前选定的对象类型。只读。

expression.SelectionType

expression 必需。该表达式返回一个 ChartSpace 或 PivotTable 对象。

示例

本示例中的过程在更改图表工作区中的选定内容时运行。如果用户选定坐标轴，过程显示坐标轴的最小值和最大值。

Sub ChartSpace1_SelectionChange()

   Dim chConstants
   Dim minval
   Dim maxval

   Set chConstants = ChartSpace1.Constants

   If ChartSpace1.SelectionType = chConstants.chSelectionAxis Then

      minval = ChartSpace1.Selection.Scaling.Minimum

      maxval = ChartSpace1.Selection.Scaling.Maximum

      MsgBox "minimum = " & minval & " maximum = " & maxval
   End If

End Sub


Separator 属性

返回或设置指定系列或图表中分隔数据标签组件的字符串。String 类型，可读写。

expression.Separator

expression 必需。该表达式返回 ChDataLabels 对象。

示例

本示例更改指定系列的数据标签分隔符。

Sub FormatDataLabels()

   Dim dlDataLabels

   ' Add data labels to the first series.
   Set dlDataLabels = ChartSpace1.Charts(0).SeriesCollection(0) _
                      .DataLabelsCollection.Add

   ' Display the category name in the data labels.
   dlDataLabels.HasCategoryName = True

   ' Set the data label seperator.
   dlDataLabels.Separator = ":"

End Sub


SeriesCollection 属性

返回指定图表的 ChSeriesCollection 集合。

expression.SeriesCollection

expression 必需。该表达式返回 ChChart 对象。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。

示例

本示例将指定系列的线条颜色设置为红色。

ChartSpace1.Charts(0).SeriesCollection(0).Line.Color = "red"


ServerFilter 属性

返回或设置指定对象的服务器筛选。String 类型，可读写。

expression.ServerFilter

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

服务器筛选为一种条件，该条件指定从服务器提取记录的类型（一种或多种）。数据模型在其生成的 SQL 语句的 WHERE 子句中添加服务器筛选字符串。只能在具有 dscTable 或 dscView 类型主行来源的记录集上设置服务器筛选。


Sheets 属性

显示 Sheets 属性应用于 Spreadsheet 对象的情形。

返回表示活动工作簿中所有工作表的 Sheets 集合。

expression.Sheets

expression 必需。该表达式返回一个 Spreadsheet 对象。

显示 Sheets 属性应用于 Workbook 对象的情形。

返回表示指定工作簿中所有工作簿的 Sheets 集合。

expression.Sheets

expression 必需。该表达式返回一个 Workbook 对象。

示例

显示 应用于 Workbook 对象的情形。

本示例以升序对 Spreadsheet1 活动工作簿中的工作表进行排序。

Sub Sort_Sheets()
   Dim i
   Dim j
   Dim iSheetCount

   iSheetCount = Spreadsheet1.ActiveWorkbook.Sheets.Count

   For i = 1 To iSheetCount
      For j = 1 To iSheetCount - 1
         If UCase(Spreadsheet1.ActiveWorkbook.Sheets(j).Name) > _
            UCase(Spreadsheet1.ActiveWorkbook.Sheets(j + 1).Name) Then

             Spreadsheet1.ActiveWorkbook.Sheets(j).Move , _
                Spreadsheet1.ActiveWorkbook.Sheets(j + 1)
         End If
      Next
   Next
End Sub


ShowAll 属性

设置为 True，将清除“自动筛选”条件。添加条件将设置该属性为 False。如果没有筛选条件并且将该属性设置为 False，将不显示数据。Boolean 类型，可读写。

expression.ShowAll

expression 必需。该表达式返回 Criteria 对象。

示例

本示例清除活动工作表上列 1 的“自动筛选”条件，并对工作表重新应用“自动筛选”。

Sub ReapplyAutoFilter()

   Dim afAutoFilter

   ' Set a variable to the current filter settings.
   Set afAutoFilter = Spreadsheet1.ActiveSheet.AutoFilter

   ' Show all records.
   afAutoFilter.Filters(1).Criteria.ShowAll = True

   ' Reapply the filters.
   afAutoFilter.Apply

End Sub


ShowAs 属性

返回或设置一个 PivotShowAsEnum 常量，表示 PivotTotal 对象的显示方式。可读写。

PivotShowAsEnum 可以为下列 PivotShowAsEnum 常量之一。
plShowAsNormal 默认值
plShowAsPercentOfColumnParent 以相对于每项的父列总计的百分比显示总计。
plShowAsPercentOfColumnTotal 以相对于每项的列总计的百分比显示总计。
plShowAsPercentOfGrandTotal 以相对于所有数据总计的百分比显示总计。
plShowAsPercentOfRowParent 以相对于每项的父行总计的百分比显示总计。
plShowAsPercentOfRowTotal 以相对于每项的行总计的百分比显示总计。

expression.ShowAs

expression 必需。该表达式返回一个 PivotTotal 对象。

示例

本示例在 PivotTable1 中新添一个总计。新总计设置为显示父行字段的百分比，并且将不显示在“数据透视表字段列表”对话框中。

Sub Add_Total()

    Dim vwView
    Dim ptConstants
    Dim totNewTotal

    Set vwView = PivotTable1.ActiveView
    Set ptConstants = PivotTable1.Constants

    ' Add a new total named "Total Budget" to the current view.
    Set totNewTotal = vwView.AddTotal("Total Budget", vwView.FieldSets("Budget").Fields(0), _
             ptConstants.plFunctionSum)

    ' Insert the newly created total into the detail area of the PivotTable.
    vwView.DataAxis.InsertTotal totNewTotal

    ' Show the totals as a percentage of the parent row field.
    totNewTotal.ShowAs = ptConstants.plShowAsPercentOfRowParent

    ' Do not display the new total in the PivotTable Field List dialog box.
    totNewTotal.DisplayInFieldList = False

End Sub


ShowAsValue 属性

返回一个 Variant 类型，以非百分比格式表示指定 PivotAggregate 对象的值。在 ShowAs 属性设置为下列值之一时，使用该属性返回单元格聚合的值：plShowAsPercentOfColumnParent、plShowAsPercentOfColumnTotal、plShowAsPercentOfGrandTotal、plShowAsPercentOfRowParent、plShowAsPercentOfRowTotal。只读。

expression.ShowAsValue

expression 必需。该表达式返回一个 PivotAggregate 对象。

示例

本示例在消息框中显示行字段中第三个成员的聚合。

Sub GetTotal()

    Dim ptData
    Dim pmRowMem
    Dim pmColMem

    ' Set a variable to the PivotTable data.
    Set ptData = PivotTable1.ActiveData

    ' Set a variable to the third item contained in the field
    ' that has been added to the row axis.
    Set pmRowMem = ptData.RowAxis.Member.ChildMembers(2)

    ' In this example, there are no fields on the column axis.
    Set pmColMem = ptData.ColumnAxis.Member

    ' Display the value of the aggregate.
    MsgBox ptData.Cells(pmRowMem, pmColMem).Aggregates(0).ShowAsValue

End Sub


ShowDelButton 属性

如果显示了 Delete 按钮（记录导航控件），则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowDelButton

expression 必需。该表达式返回“应用于”列表中的对象之一。


ShowFilterBySelectionButton 属性

如果显示了“按选定内容筛选”按钮（记录导航控件），则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowFilterBySelectionButton

expression 必需。该表达式返回 RecordNavigationControl 对象。


ShowFirstButton 属性

如果显示了“第一项”按钮（记录导航控件），则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowFirstButton

expression 必需。该表达式返回 RecordNavigationControl 对象。


ShowHelpButton 属性

如果显示了“帮助”按钮（记录导航控件），则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowHelpButton

expression 必需。该表达式返回 RecordNavigationControl 对象。


ShowLabel 属性

如果显示了记录导航控件标签，则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowLabel

expression 必需。该表达式 返回 RecordNavigationControl 对象。


ShowLastButton 属性

如果显示了“最后一项”按钮（记录导航控件），则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowLastButton

expression 必需。该表达式返回 RecordNavigationControl 对象。


ShowNewButton 属性

如果显示了“新建”按钮（记录导航控件），则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowNewButton

expression 必需。该表达式返回 RecordNavigationControl 对象。


ShowNextButton 属性

如果显示了“下一个”按钮（记录导航控件），则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowNextButton

expression 必需。该表达式返回 RecordNavigationControl 对象。


ShowPrevButton 属性

如果显示了“上一个”按钮（记录导航控件），则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowPrevButton

expression 必需。该表达式 返回 RecordNavigationControl 对象。


ShowSaveButton 属性

如果显示了“保存”按钮（记录导航控件），则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowSaveButton

expression 必需。该表达式返回 RecordNavigationControl 对象。


ShowSortAscendingButton 属性

如果显示了“升序排列”按钮（记录导航控件），则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowSortAscendingButton

expression 必需。该表达式返回 RecordNavigationControl 对象。


ShowSortDescendingButton 属性

如果显示了“降序排序”按钮（记录导航控件），则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowSortDescendingButton

expression 必需。该表达式返回 RecordNavigationControl 对象。


ShowToggleFilterButton 属性

如果显示了“切换筛选”按钮（记录导航控件），则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowToggleFilterButton

expression 必需。该表达式返回 RecordNavigationControl 对象。


ShowUndoButton 属性

如果显示了“撤消”按钮（记录导航控件），则返回 True。默认值为 True。Boolean 类型，可读写。

expression.ShowUndoButton

expression 必需。该表达式返回 RecordNavigationControl 对象。


SideWall 属性

返回表示三维图表侧面墙纸的 ChSurface 对象。使用返回的 ChSurface 对象的属性和方法设置指定图表侧面墙纸的格式。

expression.SideWall

expression 必需。该表达式返回一个 ChPlotArea 对象。

示例

本示例将 Chartspace1 中的第一个图表转换为三维柱形图，并设置图表背景墙纸、侧面墙纸和基底的格式。

Sub FormatWallsFloor()

    Dim cht3DColumn
    Dim chConstants
    Dim paPlotArea

    Set chConstants = Chartspace1.Constants

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DColumn = ChartSpace1.Charts(0)

    ' Set a variable to the plot area.
    Set paPlotArea = cht3DColumn.PlotArea

    ' Change the chart to a 3D Column chart.
    cht3DColumn.Type = chConstants.chChartTypeColumnClustered3D

    ' Format the back wall of the chart.
    paPlotArea.BackWall.Interior.SetSolid "Yellow"
    paPlotArea.BackWall.Thickness = 5

    ' Format the side wall of the chart.
    paPlotArea.SideWall.Interior.SetSolid "Yellow"
    paPlotArea.SideWall.Thickness = 5

    ' Format the floor of the chart.
    paPlotArea.Floor.Interior.SetSolid "Blue"
    paPlotArea.Floor.Thickness = 5

End Sub


Size 属性

返回或设置字体或标志大小（磅）。如果用于字符大小不统一的区域，则返回 Null。请使用 IsNull 函数判断返回值是否为 Null。 对于 Font 对象为 Variant 类型，可读写；对于“应用于”列表中的所有其他对象为 Long 类型，可读写。

expression.Size

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例设置指定坐标轴的字体为 6 磅。

Set c = ChartSpace1.Constants
ChartSpace1.Charts(0).Axes(c.chAxisPositionLeft).Font.Size = 6


SizeRepresents 属性

返回或设置气泡图上气泡大小所表示的含义。ChartSizeRepresentsEnum 类型，可读写。

ChartSizeRepresentsEnum 可为以下 ChartSizeRepresentsEnum 常量之一：
chSizeIsArea
chSizeIsWidth

expression.SizeRepresents

expression 必需。该表达式返回 ChChart 对象。

示例

本示例设置气泡图的 SizeRepresents 属性。

Sub SetSizeParameter()

   Dim chConstants

   Set chConstants = Chartspace1.Constants

   ChartSpace1.Charts(0).SizeRepresents = chConstants.chSizeIsArea

End Sub


SolveOrder 属性

返回或设置一个 Long 类型，表示指定总计的求解次序。可读写。

expression.SolveOrder

expression 必需。该表达式返回一个 PivotTotal 对象。


SortDirection 属性

返回或设置指定字段的排序方向。PivotFieldSortDirectionEnum 类型，可读写。

PivotFieldSortDirectionEnum 可为以下 PivotFieldSortDirectionEnum 常量之一：
plSortDirectionAscending
plSortDirectionCustom
plSortDirectionCustomAscending
plSortDirectionCustomDescending
plSortDirectionDefault
plSortDirectionDescending

expression.SortDirection

expression 必需。该表达式返回 PivotField 对象。

说明

字段按照底层数据提供者的排序规则排序。例如，数据提供者可按照字母顺序（February、January 等）或月份顺序（January、February 等）排序日期。


SortOn 属性

返回或设置用于排序指定字段的总计。PivotTotal 类型，可读写。

expression.SortOn

expression 必需。该表达式返回 PivotField 对象。.


SortOnScope 属性

返回或设置用于缩小指定字段排序范围的字符串数组。Variant 类型，可读写。

expression.SortOnScope

expression 必需。该表达式返回 PivotField 对象。


Source 属性

返回或设置指定页字段或页面行来源的来源。String 类型，可读写。

expression.Source

expression 必需。该表达式返回“应用于”列表中的对象之一。


SourceAxis 属性

返回一个 PivotAxis 对象，表示指定结果坐标轴的来源坐标轴。

expression.SourceAxis

expression 必需。该表达式返回一个 PivotResultAxis 对象。


SourceColumnAxis 属性

返回一个 PivotGroupAxis 对象，表示指定结果坐标轴的来源坐标轴。

expression.SourceColumnAxis

expression 必需。该表达式返回一个 PivotResultColumnAxis 对象。


SourceDataAxis 属性

返回一个 PivotDataAxis 对象，表示指定结果坐标轴的来源坐标轴。

expression.SourceDataAxis

expression 必需。该表达式返回一个 PivotResultDataAxis 对象。


SourceField 属性

返回一个 PivotField 对象，表示指定结果字段的来源字段。

expression.SourceField

expression 必需。该表达式返回一个 PivotResultField 对象。


SourceFilterAxis 属性

返回一个 PivotFilterAxis 对象，表示指定结果坐标轴的来源坐标轴。

expression.SourceFilterAxis

expression 必需。该表达式返回一个 PivotResultFilterAxis 对象。


SourceLabel 属性

返回一个 PivotLabel 对象，表示指定结果标志的来源标志。

expression.SourceLabel

expression 必需。该表达式返回一个 PivotResultLabel 对象。


SourceMember 属性

返回一个 PivotMember 对象，表示指定坐标轴成员的来源成员。

expression.SourceMember

expression 必需。该表达式返回一个 PivotAxisMember 对象。


SourcePageAxis 属性

返回一个 PivotGroupAxis 对象，表示指定结果坐标轴的来源坐标轴。

expression.SourcePageAxis

expression 必需。该表达式返回一个 PivotResultPageAxis 对象。


SourceRowAxis 属性

返回一个 PivotGroupAxis 对象，表示指定结果坐标轴的来源坐标轴。

expression.SourceRowAxis

expression 必需。该表达式返回一个 PivotResultRowAxis 属性。


SplitMaximum 属性

如果指定 ChScaling 对象具有拆分，则该属性返回或设置拆分的最大值。该属性应大于 SplitMinimum 属性值。Double 类型，可读写。

expression.SplitMaximum

expression 必需。该表达式返回一个 ChScaling 对象。

示例

本示例拆分 ChartSpace1 中第一个图表的数值轴，并设置最小拆分值和最大拆分值。数值轴经过拆分并且 1000 到 5000 之间的值将不显示。

Sub Split_Value_Axis()
    Dim chConstants
    Dim scValueAxis

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the scaling object of the value axis.
    Set scValueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue).Scaling

    ' Add a split to the value axis.
    scValueAxis.HasSplit = True

    ' Specify the minnimum value of the split.
    scValueAxis.SplitMinimum = 1000

    ' Specify the maximum value for the split.
    scValueAxis.SplitMaximum = 5000
End Sub


SplitMinimum 属性

如果指定 ChScaling 对象具有拆分，该属性返回或设置拆分的最小时值，该属性应小于 SplitMaximum 属性值。Double 类型，可读写。

expression.SplitMinimum

expression 必需。该表达式返回一个 ChScaling 对象。

示例

本示例拆分 ChartSpace1 中第一个图表的数值轴，并设置最小拆分值和最大拆分值。数值轴经过拆分并且 1000 到 5000 之间的值将不显示。

Sub Split_Value_Axis()
    Dim chConstants
    Dim scValueAxis

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the scaling object of the value axis.
    Set scValueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue).Scaling

    ' Add a split to the value axis.
    scValueAxis.HasSplit = True

    ' Specify the minnimum value of the split.
    scValueAxis.SplitMinimum = 1000

    '  Specify the maximum value for the split.
    scValueAxis.SplitMaximum = 5000
End Sub


StandardHeight 属性

以点数返回工作簿中所有行的标准（默认）高度。Double 类型，只读。

expression.StandardHeight

expression 必需。该表达式返回一个 Worksheet 对象。

示例

本示例将 Spreadsheet1 的活动工作簿中的行列重置为默认尺寸。

Sub Reset_Height_Width()
     Dim shtActive
     Set shtActive = Spreadsheet1.ActiveSheet

     shtActive.Rows.RowHeight = shtActive.StandardHeight
     shtActive.Columns.ColumnWidth = shtActive.StandardWidth
End Sub


StandardWidth 属性

返回工作表中所有列的标准（默认）宽度。以“普通”样式的一个字符宽度作为度量单位。Double 类型，可读写。

expression.StandardWidth

expression 必需。该表达式返回一个 Worksheet 对象。

示例

本示例将 Spreadsheet1 的活动工作簿中的行列重置为默认尺寸。

Sub Reset_Height_Width()
   Dim shtActive
   Set shtActive = Spreadsheet1.ActiveSheet

   shtActive.Rows.RowHeight = shtActive.StandardHeight
   shtActive.Columns.ColumnWidth = shtActive.StandardWidth
End Sub


Status 属性

返回一个 DscStatusEnum 常量，表示当前事件的状态。只有 AfterDelete 事件支持该属性。只读。

DscStatusEnum 可以为下列 DscStatusEnum 常量之一。
dscDeleteCancel 删除操作成功。
dscDeleteOK 删除操作被代码取消。
dscDeleteUserCancel 删除操作被用户取消。

expression.Status

expression 必需。该表达式返回一个 DSCEventInfo 对象。

说明

在不支持的事件中使用该属性将导致运行时出错。


Style 属性

返回或设置指定系列或图表的标志样式。ChartMarkerStyleEnum 类型，可读写。

ChartMarkerStyleEnum 可为以下 ChartMarkerStyleEnum 常量之一：
chMarkerStyleCircle
chMarkerStyleDash
chMarkerStyleDiamond
chMarkerStyleDot
chMarkerStyleNone
chMarkerStylePlus
chMarkerStyleSquare
chMarkerStyleStar
chMarkerStyleTriangle
chMarkerStyleX

expression.Style

expression 必需。该表达式返回 ChMarker 对象。

示例

本示例设置指定系列的标志样式。

Sub SetMarkerStyle()

   Dim chConstants

   Set chConstants = ChartSpace1.Constants

   ChartSpace1.Charts(0).SeriesCollection(0).Marker _
               .Style = chConstants.chMarkerStyleStar

End Sub


Subaddress 属性

返回或设置与超链接（超链接地址 # 符号右面的字符串）相关联的位置（文档内）。String 类型，可读写。

expression.SubAddress

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例设置指定超链接的地址和子地址。

Sub SetHyperlink()

   Dim hypHyperlink

   Set hypHyperlink = Spreadsheet1.Range("A12").Hyperlink

   hypHyperlink.Address = "http://example.microsoft.com/ExcelDev/e-tips.htm"

   hypHyperlink.Subaddress = "top"

End Sub


SublistRelationships 属性

返回指定记录集定义的 SublistRelationships 集合。

expression.SublistRelationships

expression 必需。该表达式返回 RecordsetDef 对象。

说明

子列表关系指其他记录集定义中的行来源，它与指定记录集定义的主页面行来源具有多对一的关系。

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


SublistSchemaRelationships 属性

返回指定方案行来源的 SublistSchemaRelationships 集合。

expression.SublistSchemaRelationships

expression 必需。该表达式返回 SchemaRowsource 对象。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。


SubtotalBackColor 属性

返回或设置指定字段中分类汇总的背景色。对于分类汇总，该属性设置将覆盖 TotalBackColor 属性设置。Variant 类型，可读写。

expression.SubtotalBackColor

expression 必需。该表达式返回 PivotField 对象。

说明

当设置该属性时，可使用 Long 类型值表示红绿蓝体系的颜色值或 String 类型值命名一种有效的 HTML 颜色。例如，如果要将对象设置为红色，可使用十六进制值 &HFF，十进制值 255 或字符串值“red”。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝体系的颜色值。（红色为 RGB(255,0,0)）。

该属性总是返回 Long 类型值，该值表示一种红绿蓝体系的颜色值。


SubtotalFont 属性

返回表示分类汇总字体的 PivotFont 对象。

expression.SubtotalFont

expression 必需。该表达式返回 PivotField 对象。


SubtotalForeColor 属性

返回或设置指定字段的前景色。该属性将覆盖 TotalForeColor 属性。Variant 类型，可读写。

expression.SubtotalForeColor

expression 必需。该表达式返回 PivotField 对象。

说明

当设置该属性时，可使用 Long 类型值表示红绿蓝体系的颜色值或 String 类型值命名一种有效的 HTML 颜色。例如，如果要将对象设置为红色，可使用十六进制值 &HFF，十进制值 255 或字符串值“red”。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝体系的颜色值。（红色为 RGB(255,0,0)）。

该属性总是返回 Long 类型值，该值表示一种红绿蓝体系的颜色值。


SubtotalLabelBackColor 属性

返回或设置指定字段的分类汇总背景色。Variant 类型，可读写。

expression.SubtotalLabelBackColor

expression 必需。该表达式返回一个 PivotField 对象。

说明

在设置该属性时，既可以使用表示红绿蓝颜色的 Long 类型值，也可以使用命名有效 HTML 颜色值的 String 类型值。例如，要将对象颜色设置为红色，可以使用十六进制值 &HFF、十进制值 255 或字符串值 "red"。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝颜色值（红色为 RGB(255,0,0)）。

该属性总是以表示红绿蓝颜色值的 Long 类型值返回颜色。


SubtotalLabelFont 属性

返回一个 PivotFont 对象，表示指定字段中分类汇总标志中的字体。

expression.SubtotalLabelFont

expression 必需。该表达式返回一个 PivotField 对象。


SubtotalLabelForeColor 属性

返回或设置指定字段的分类汇总前景色。Variant 类型，可读写。

expression.SubtotalLabelForeColor

expression 必需。该表达式返回一个 PivotField 对象。

说明

在设置该属性时，既可以使用表示红绿蓝颜色的 Long 类型值，也可以使用命名有效 HTML 颜色值的 String 类型值。例如，要将对象颜色设置为红色，可以使用十六进制值 &HFF、十进制值 255 或字符串值 "red"。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝颜色值（红色为 RGB(255,0,0)）。

该属性总是以表示红绿蓝颜色值的 Long 类型值返回颜色。


SubtotalLabelHAlignment 属性

返回或设置一个 PivotHAlignmentEnum 常量，表示指定字段的分类汇总标志的水平对齐方式。可读写。

PivotHAlignmentEnum 可以为下列 PivotHAlignmentEnum 常量之一。
plHAlignAutomatic
plHAlignCenter
plHAlignLeft
plHAlignRight

expression.SubtotalLabelHAlignment

expression 必需。该表达式返回一个 PivotField 对象。


Subtotals 属性

如果指定字段显示分类汇总，则返回 True。Boolean 类型，可读写。

expression.Subtotals(Subtotals)

expression 该表达式返回 PivotField 对象。该字段必须在行或列坐标轴上。

Subtotals 必需，Long 类型。指定分类汇总。


TabRatio 属性

返回或设置工作簿的标签区域宽度与窗口的水平滚动条宽度的比率（以 0（零）到 1 之间的数字表示，默认值为 0.6）。更改该属性与窗口的水平滚动条长度具有反比关系。从默认值开始增大该属性将减小滚动条的长度，而从默认值开始减小该属性将增大滚动条的长度。Double 类型，可读写。

expression.TabRatio

expression 必需。该表达式返回一个 Window 对象。

示例

本示例使工作簿的标签为水平滚动条的一半宽度。

Spreadsheet1.ActiveWindow.TabRatio = 0.5


Text 属性

显示 Text 属性应用于 PivotAggregate 和 PivotDetailCell 对象的情形。

根据当前 NumberFormat 属性设置以字符串类型返回指定值。String 类型，只读。

expression.Text

expression 必需。该表达式返回上述对象之一。

显示 Text 属性应用于 Range 对象的情形。

返回指定单元格中显示的带格式的值。如果区域中包含多个单元格并且单元格中包含不同的值，则返回 Null。请使用 IsNull 函数判断返回值是否为 Null。Variant 类型，只读。

expression.Text

expression 必需。该表达式返回 Range 对象。

示例

本示例为单元格 A1 中的带格式值设置变量。

txt = Spreadsheet1.Range("a1").Text


TextureFormat 属性

返回一个 ChartTextureFormatEnum 常量，指出用于显示指定 ChInterior 对象纹理的格式。如果指定的内部没有填充纹理或图片，则该属性将返回一个运行时错误。只读。

ChartTextureFormatEnum 可以为下 ChartTextureFormatEnum 常量之一。
chStack
chStackScale
chStretch
chStretchPlot
chTile

expression.TextureFormat

expression 必需。该表达式返回一个 ChInterior 对象。


TextureName 属性

返回一个 String 类型，指出用于填充指定 ChInterior 对象的图片文件名称和路径。如果指定对象的内部已设置为一个预设纹理，该属性将返回一个运行时错误。只读。

expression.TextureName

expression 必需。该表达式返回一个 ChInterior 对象。

说明

使用 SetTextured 方法设置填充的纹理文件。


TexturePlacement 属性

返回一个 ChartTexturePlacementEnum 常量，指出纹理应用于指定 ChInterior 对象的方法。只读。

ChartTexturePlacementEnum 可以为下列 ChartTexturePlacementEnum 常量之一。
chAllFaces
chEnd
chEndSides
chFront
chFrontEnd
chFrontSides
chProjectFront
chSides

expression.TexturePlacement

expression 必需。该表达式返回一个 ChInterior 对象。

说明

该属性只影响三维图表。


TextureStackUnit 属性

返回一个 Double 类型，指出指定 ChInterior 对象的纹理堆积单位。除非 SetTexture 方法用于填充对象的内部，并且该方法的 TextureFormat 参数设置为一个 chStackScale 值，否则该属性将返回一个运行时错误。只读。

expression.TextureStackUnit

expression 必需。该表达式返回一个 ChInterior 对象。


Thickness 属性

返回或设置一个 Long 类型，指定三维图表中指定数据系列或曲面的厚度。

expression.Thickness

expression 必需。该表达式返回一个 ChSeries 或 ChSurface 对象。

说明

使用该属性将设置三维折线图中线条的粗细或三维饼图中饼的厚度。

示例

本示例将 Chartspace1 中的第一个图表转换为三维折线图，并设置该图表每条线条的粗细。

Sub SetLineThickness()

    Dim cht3DLine
    Dim serSeries

    ' Set a variable to the first chart in Chartspace1.
    Set cht3DLine = ChartSpace1.Charts(0)

    ' Change the chart to a 3D Line chart.
    cht3DLine.Type = chChartTypeLine3D

    ' Set the thickness of each line in the chart.
    For Each serSeries In cht3DLine.SeriesCollection
        serSeries.Thickness = 4
    Next
End Sub


TickLabelSpacing 属性

返回或设置指定坐标轴上刻度线标签之间的分类数。只能应用于分类轴。Long 类型，可读写。

expression.TickLabelSpacing

expression 必需。该表达式返回 ChAxis 对象。

示例

本示例设置指定坐标轴上刻度线标签之间的分类数为 2。

ChartSpace1.Charts(0).Axes(1).TickLabelSpacing = 2


TickLabelUnitType 属性

返回或设置一个 ChartAxisUnitTypeEnum 常量，表示时间刻度分类轴上刻度线标志的显示间隔。可读写。

ChartAxisUnitTypeEnum 可以为下列 ChartAxisUnitTypeEnum 常量之一。
chAxisUnitDay
chAxisUnitMonth
chAxisUnitQuarter
chAxisUnitWeek
chAxisUnitYear

expression.TickLabelUnitType

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例将 Chartspace1 中的第一个图表转换为折线图，然后设置分类轴格式，使数据按月分组。图表上显示每个月的平均值。

Sub FormatTimeScaling()

    Dim chConstants
    Dim axCategory

    Set chConstants = ChartSpace1.Constants

    ' Change the chart to a Line chart.
    ChartSpace1.Charts(0).Type = chConstants.chChartTypeLine

    ' Set a variable to the category axis.
    Set axCategory = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionCategory)

    ' Specify that you will determine the grouping settings of the
    ' axis. Note that this line of code is necessary only if the
    ' GroupingType property for the axis has been previously set to
    ' chAxisGroupingNone.
    axCategory.GroupingType = chConstants.chAxisGroupingManual

    ' Group the category axis by month.
    axCategory.GroupingUnitType = chConstants.chAxisUnitMonth

    ' Create a new grouping for every month.
    axCategory.GroupingUnit = 1

    ' Display the average of the items in each group.
    axCategory.GroupingTotalFunction = chConstants.chFunctionAvg

    ' A tick label is displayed for every month.
    axCategory.TickLabelUnitType = chConstants.chAxisUnitMonth

    ' A tick mark is displayed for every three months.
    axCategory.TickMarkUnitType = chConstants.chAxisUnitQuarter

End Sub


TickMarkSpacing 属性

返回或设置指定坐标轴上刻度线之间的分类数。只能应用于分类轴。使用 MajorUnit 和 MinorUnit 属性设置数值轴上的刻度线间距。Long 类型，可读写。

expression.TickMarkSpacing

expression 必需。该表达式返回 ChAxis 对象。

示例

本示例设置指定坐标轴上刻度线之间的分类数为 2。

ChartSpace1.Charts(0).Axes(1).TickMarkSpacing = 2


TickMarkUnitType 属性

返回或设置一个 ChartAxisUnitTypeEnum 常量，表示时间刻度分类轴上的刻度线显示间隔。可读写。

ChartAxisUnitTypeEnum 可以为下列 ChartAxisUnitTypeEnum 常量之一。
chAxisUnitDay
chAxisUnitMonth
chAxisUnitQuarter
chAxisUnitWeek
chAxisUnitYear

expression.TickMarkUnitType

expression 必需。该表达式返回一个 ChAxis 对象。

示例

本示例将 Chartspace1 中的第一个图表转换为折线图，然后设置分类轴格式，使数据按月分组。图表上显示每个月的平均值。

Sub FormatTimeScaling()

    Dim chConstants
    Dim axCategory

    Set chConstants = ChartSpace1.Constants

    ' Change the chart to a Line chart.
    ChartSpace1.Charts(0).Type = chConstants.chChartTypeLine

    ' Set a variable to the category axis.
    Set axCategory = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionCategory)

    ' Specify that you will determine the grouping settings of the
    ' axis. Note that this line of code is necessary only if the
    ' GroupingType property for the axis has been previously set to
    ' chAxisGroupingNone.
    axCategory.GroupingType = chConstants.chAxisGroupingManual

    ' Group the category axis by month.
    axCategory.GroupingUnitType = chConstants.chAxisUnitMonth

    ' Create a new grouping for every month.
    axCategory.GroupingUnit = 1

    ' Display the average of the items in each group.
    axCategory.GroupingTotalFunction = chConstants.chFunctionAvg

    ' A tick label is displayed for every month.
    axCategory.TickLabelUnitType = chConstants.chAxisUnitMonth

    ' A tick mark is displayed for every three months.
    axCategory.TickMarkUnitType = chConstants.chAxisUnitQuarter

End Sub


TimeValue 属性

返回一个 Variant 类型，表示具有适当日期和时间格式的指定成员值。只读。

expression.TimeValue

expression 必需。该表达式返回一个 PivotMember 对象。


TipText 属性

显示 TipText 属性应用于 ChSeries 对象的情形。

返回或设置一个 String 类型，表示指定数据系列的图表屏幕提示文本。图表屏幕提示文本以标记设置，该标记表示图表屏幕提示相关联的值。下表说明了可用于设置屏幕提示的标记。可读写。

标记 | 说明
<N> | 其中 N 为维数，返回维的名称。
<value> | 对于绑定到数据透视表列表的数据系列，返回透视聚合的名称。对于不是绑定到数据透视表列表的数据系列，返回 "Value"。
<ls> | 表示列表分隔符。
<br> | 插入换行符。
<< | 返回 "<" 符号。

expression.TipText

expression 必需。该表达式返回一个 ChSeries 对象。

显示 TipText 属性应用于 OCCommand 对象的情形。

返回一个 String 类型，表示指定命令的屏幕提示文本。只读。

expression.TipText

expression 必需。该表达式返回一个 OCCommand 对象。

说明

OCCommandId、ChartCommandIdEnum、PivotCommandId 和 SpreadsheetCommandId 常量中包含每个 Web 组件支持的命令。

示例

显示 应用于 ChSeries 对象的情形。

本示例设置 Chartspace1 中第一个图表的第一个系列的屏幕提示文本。
Sub SetChartTips()

 ' Set the tiptext for Series1.
 Chartspace1.Charts(0).SeriesCollection(0) _
      .TipText = "<1>:<value>:<2>"

End Sub


Title 属性

返回表示指定坐标轴或图表标题的 ChTitle 对象。

expression.Title

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例使指定图表包含标题，并设置标题文字。

Sub SetChartTitle()

   ' Enable the chart title.
   ChartSpace1.Charts(0).HasTitle = True

   ' Set the chart title.
   ChartSpace1.Charts(0).Title.Caption = "Satisfaction Data"

End Sub


TitleBar 属性

显示 TitleBar 属性应用于 PivotView 对象的情形。

返回表示指定视图标题的 PivotLabel 对象。

expression.TitleBar

expression 必需。该表达式返回 PivotView 对象。

显示 TitleBar 属性应用于 Spreadsheet 对象的情形。

返回表示指定电子表格标题的 TitleBar 对象。

expression.TitleBar

expression 必需。该表达式返回 Spreadsheet 对象。

示例

本示例设置电子表格的标题。

Spreadsheet1.TitleBar.Caption = "Monthly Sales"


Toolbar 属性

返回一个 MSComctlLib.Toolbar 对象，表示工具栏。

expression.Toolbar

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

使用返回的 MSComctlLib.Toolbar 对象自定义 Microsoft Office Web Components 中的工具栏。可以如同自定义按钮一样添加或删除内置按钮。


Top 属性

显示 Top 属性应用于 ChartSpace、ChCategoryLabel、ChChartField、ChDataLabel、ChDataLabels、ChErrorBars、ChLegendEntry、ChPoint、ChSeries、ChTrendline、PivotAggregate、PivotAxisMember、PivotColumnMember、PivotDetailCell、PivotPageMember、PivotResultAxis、PivotResultColumnAxis、PivotResultDataAxis、PivotResultFilterAxis、PivotResultGroupAxis、PivotResultLabel、PivotResultPageAxis、PivotResultRowAxis、PivotRowMember 和 PivotTable 对象的情形。

返回（或设置，取决于对象）一个 Long 类型，表示指定对象的顶边。可读写。

expression.Top

expression 必需。该表达式返回上面对象之一。

显示 Top 属性应用于 ChScrollView 对象的情形。

返回一个 Long 值，表示 ChScrollView 对象的顶边。只读。

expression.Top

expression 必需。该表达式返回一个 ChScrollView 对象。

显示 Top 属性应用于 PivotData 对象的情形。

返回或设置一个 PivotRowMember 对象，表示最上面可见汇总行上的成员。可读写。

expression.Top

expression 必需。该表达式返回一个 PivotData 对象。

显示 Top 属性应用于 Range 对象的情形。

返回一个 Variant 类型，表示从电子表格窗口顶边到指定区域顶边之间的距离。如果区域在可见区域之外，该数值可以为负数。只读。

expression.Top

expression 必需。该表达式返回一个 Range 对象。

显示 Top 属性应用于 Window 对象的情形。

返回一个 Double 类型，表示指定窗口的顶边。只读。

expression.Top

expression 必需。该表达式返回一个 Window 对象。

示例

本示例设置变量表示电子表格窗口顶边到单元格 A35 的距离。

t2 = Spreadsheet1.Range("A35").Top


Top2 属性

返回一个 Long 类型，表示数据透视表列表顶边到数据区域之间的距离。只读。

expression.Top2

expression 必需。该表达式返回一个 PivotData 对象。

说明

如果没有显示指定工具栏，则该属性返回 1。


TopLeft 属性

显示 TopLeft 属性应用于 PivotRange 对象的情形。

返回表示指定区域左上角单元格的 PivotCell 对象。

expression.TopLeft

expression 必需。该表达式返回 PivotRange 对象。

显示 TopLeft 属性应用于 PivotDetailRange 对象的情形。

返回表示明细区域左上角单元格的 PivotDetailCell 对象。

expression.TopLeft

expression 必需。该表达式返回 PivotDetailRange 对象。


TopOffset 属性

返回或设置一个 Long 类型，表示向下滚动数据区域的像素数。可读写。

expression.TopOffset

expression 必需。该表达式返回一个 PivotData 对象。

说明

使用 LeftOffset 向左滚动数据区域。

示例

本示例将 PivotTable1 的数据区域分别向下和向左滚动 45 像素。

Sub ScrollDataArea()

    Dim ptData

    Set ptData = PivotTable1.ActiveData

    ' Scroll 45 pixels down.
    ptData.TopOffset = 45

    ' Scroll the data area to the left.
    ptData.LeftOffset = 45

End Sub


Total 属性

返回表示指定聚合总计的 PivotTotal 对象。

expression.Total

expression 必需。该表达式返回 PivotAggregate 对象。


TotalAllMembers 属性

如果分类汇总中包括筛选成员，则设置为 True。如果将该属性设置为 False，分类汇总中将不包括筛选出视图的成员。默认值为 False。Boolean 类型，可读写。

expression.TotalAllMembers

expression 必需。该表达式返回一个 PivotView 对象。


TotalBackColor 属性

返回或设置所有汇总的背景色。Variant 类型，可读写。

expression.TotalBackColor

expression 必需。该表达式返回 PivotView 对象。

说明

当设置该属性时，可使用 Long 类型值表示红绿蓝体系的颜色值或 String 类型值命名一种有效的 HTML 颜色。例如，如果要将对象设置为红色，可使用十六进制值 &HFF，十进制值 255 或字符串值“red”。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝体系的颜色值。（红色为 RGB(255,0,0)）。

该属性总是返回 Long 类型值，该值表示一种红绿蓝体系的颜色值。


TotalColumnMember 属性

返回一个 PivotColumnMember 对象，表示用于显示总计的成员。

expression.TotalColumnMember

expression 必需。该表达式返回一个 PivotColumnMember 对象。


TotalFont 属性

返回一个 PivotFont 对象，表示单元格或明细网格页脚中显示的聚合字体。

expression.TotalFont

expression 必需。该表达式返回 PivotView 对象。


TotalForeColor 属性

返回或设置所有汇总的前景色。Variant 类型，可读写。

expression.TotalForeColor

expression 必需。该表达式返回 PivotView 对象。

说明

当设置该属性时，可使用 Long 类型值表示红绿蓝体系的颜色值或 String 类型值命名一种有效的 HTML 颜色。例如，如果要将对象设置为红色，可使用十六进制值 &HFF，十进制值 255 或字符串值“red”。在 Microsoft Visual Basic 中，可以使用 RGB 函数创建红绿蓝体系的颜色值。（红色为 RGB(255,0,0)）。

该属性总是返回 Long 类型值，该值表示一种红绿蓝体系的颜色值。


TotalMember 属性

返回一个 PivotAxisMember 对象，表示用于显示分类汇总的成员。

expression.TotalMember

expression 必需。该表达式返回“应用于”列表中的对象之一。


TotalOrientation 属性

返回或设置在有多个总计时，汇总总计的显示方向。PivotViewTotalOrientationEnum 类型，可读写。

PivotViewTotalOrientationEnum 可为以下 PivotViewTotalOrientationEnum 常量之一：
plTotalOrientationColumn
plTotalOrientationRow

expression.TotalOrientation

expression 必需。该表达式返回 PivotView 对象。


TotalPageMember 属性

返回一个 PivotPageMember 对象，表示用于显示总计的成员。

expression.TotalPageMember

expression 必需。该表达式返回一个 PivotPageMember 对象。


TotalRowHeight 属性

返回或设置一个 Long 类型，表示包含指定成员分类汇总的行的高度。可读写。

expression.TotalRowHeight

expression 必需。该表达式返回一个 PivotRowMember 对象。


TotalRowMember 属性

返回一个 PivotRowMember 对象，表示用于显示总计的成员。

expression.TotalRowMember

expression 必需。该表达式返回一个 PivotRowMember 对象。


Totals 属性

对于 PivotDataAxis 和 PivotResultDataAxis 对象：返回一个 PivotTotals 集合，包含汇总坐标轴上的所有 PivotTotal 对象。汇总区域显示每个单元格的总计。

对于 PivotView 对象：返回一个 PivotTotals 集合集合，包含当前视图的所有总计。

expression.Totals

expression 必需。该表达式返回“应用于”列表中的对象之一。


TotalType 属性

返回或设置总计类型。DscTotalTypeEnum 类型，可读写。

DscTotalTypeEnum 可为以下 DscTotalTypeEnum 常量之一：
dscAny
dscAvg
dscCount
dscMax
dscMin
dscNone
dscStdev
dscSum

expression.TotalType

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

非 dscNone 的值仅对 dscGrouping 类型的页字段有效。


Type 属性

显示 Type 属性应用于 ChAxis 对象的情形。

返回 ChartAxisTypeEnum 对象类型，只读。

ChartAxisTypeEnum 可为以下 ChartAxisTypeEnum 常量之一：
chCategoryAxis
chSeriesAxis
chTimescaleAxis
chValueAxis

expression.Type

expression 必需。该表达式返回上述对象之一。

显示 Type 属性应用于 ChChart 和 ChSeries 对象的情形。

返回或设置 ChartChartTypeEnum 对象类型，可读写。

ChartChartTypeEnum 可为以下 ChartChartTypeEnum 常量之一：
chChartTypeArea
chChartTypeArea3D
chChartTypeAreaOverlapped3D
chChartTypeAreaStacked
chChartTypeAreaStacked100
chChartTypeAreaStacked1003D
chChartTypeAreaStacked3D
chChartTypeBar3D
chChartTypeBarClustered
chChartTypeBarClustered3D
chChartTypeBarStacked
chChartTypeBarStacked100
chChartTypeBarStacked1003D
chChartTypeBarStacked3D
chChartTypeBubble
chChartTypeBubbleLine
chChartTypeColumn3D
chChartTypeColumnClustered
chChartTypeColumnClustered3D
chChartTypeColumnStacked
chChartTypeColumnStacked100
chChartTypeColumnStacked1003D
chChartTypeColumnStacked3D
chChartTypeCombo
chChartTypeCombo3D
chChartTypeDoughnut
chChartTypeDoughnutExploded
chChartTypeLine
chChartTypeLine3D
chChartTypeLineMarkers
chChartTypeLineOverlapped3D
chChartTypeLineStacked
chChartTypeLineStacked100
chChartTypeLineStacked1003D
chChartTypeLineStacked100Markers
chChartTypeLineStacked3D
chChartTypeLineStackedMarkers
chChartTypePie
chChartTypePie3D
chChartTypePieExploded
chChartTypePieExploded3D
chChartTypePieStacked
chChartTypePolarLine
chChartTypePolarLineMarkers
chChartTypePolarMarkers
chChartTypePolarSmoothLine
chChartTypePolarSmoothLineMarkers
chChartTypeRadarLine
chChartTypeRadarLineFilled
chChartTypeRadarLineMarkers
chChartTypeRadarSmoothLine
chChartTypeRadarSmoothLineMarkers
chChartTypeScatterLine
chChartTypeScatterLineFilled
chChartTypeScatterLineMarkers
chChartTypeScatterMarkers
chChartTypeScatterSmoothLine
chChartTypeScatterSmoothLineMarkers
chChartTypeSmoothLine
chChartTypeSmoothLineMarkers
chChartTypeSmoothLineStacked
chChartTypeSmoothLineStacked100
chChartTypeSmoothLineStacked100Markers
chChartTypeSmoothLineStackedMarkers
chChartTypeStockHLC
chChartTypeStockOHLC

expression.Type

expression 必需。该表达式返回上述对象之一。

显示 Type 属性应用于 ChErrorBars 对象的情形。

返回或设置 ChartErrorBarTypeEnum 对象类型，可读写。

ChartErrorBarTypeEnum 可为以下 ChartErrorBarTypeEnum 常量之一：
chErrorBarTypeCustom
chErrorBarTypeFixedValue
chErrorBarTypePercent

expression.Type

expression 必需。该表达式返回上述对象之一。

显示 Type 属性应用于 ChScaling 对象的情形。

返回或设置 ChartScaleTypeEnum 对象类型，可读写。

ChartScaleTypeEnum 可为以下 ChartScaleTypeEnum 常量之一：
chScaleTypeLinear
chScaleTypeLogarithmic

expression.Type

expression 必需。该表达式返回上述对象之一。

显示 Type 属性应用于 ChTrendline 对象的情形。

返回或设置 ChartTrendlineTypeEnum 对象类型，可读写。

ChartTrendlineTypeEnum 可为以下 ChartTrendlineTypeEnum 常量之一：
chTrendlineTypeExponential
chTrendlineTypeLinear
chTrendlineTypeLogarithmic
chTrendlineTypeMovingAverage
chTrendlineTypePolynomial
chTrendlineTypePower

expression.Type

expression 必需。该表达式返回上述对象之一。

显示 Type 属性应用于 PageRelationship 对象的情形。

返回 DscPageRelTypeEnum 对象类型，只读。

DscPageRelTypeEnum 可为以下 DscPageRelTypeEnum 常量之一：
dscLookup
dscSublist

expression.Type

expression 必需。该表达式返回上述对象之一。

显示 Type 属性应用于 PivotField 对象的情形。

返回 PivotFieldTypeEnum 对象类型，只读。

PivotFieldTypeEnum 可为以下 PivotFieldTypeEnum 常量之一：
plTypeCalculated
plTypeCustomGroup
plTypeRegular
plTypeTimeDays
plTypeTimeHalfYears
plTypeTimeHours
plTypeTimeMinutes
plTypeTimeMonths
plTypeTimeQuarters
plTypeTimeSeconds
plTypeTimeUndefined
plTypeTimeWeekdays
plTypeTimeWeeks
plTypeTimeYears
plTypeUnknown
plTypeUserDefined

expression.Type

expression 必需。该表达式返回上述对象之一。

显示 Type 属性应用于 PivotFieldSet 对象的情形。

返回 PivotFieldSetTypeEnum 对象类型，只读。

PivotFieldSetTypeEnum 可为以下 PivotFieldSetTypeEnum 常量之一：
plFieldSetTypeOther
plFieldSetTypeTime
plFieldSetTypeUnknown
plFieldSetTypeUserDefined

expression.Type

expression 必需。该表达式返回上述对象之一。

显示 Type 属性应用于 PivotTotal 对象的情形。

返回 PivotTotalTypeEnum 对象类型，只读。

PivotTotalTypeEnum 可为以下 PivotTotalTypeEnum 常量之一：
plTotalTypeCalculated
plTotalTypeIntrinsic
plTotalTypeUserDefined

expression.Type

expression 必需。该表达式返回上述对象之一。

显示 Type 属性应用于 SchemaRowsource 对象的情形。

返回或设置 DscRowsourceTypeEnum 对象类型，可读写。

DscRowsourceTypeEnum 可为以下 DscRowsourceTypeEnum 常量之一：
dscCommandFile
dscCommandText
dscProcedure
dscTable
dscView

expression.Type

expression 必需。该表达式返回上述对象之一。

显示 Type 属性应用于 Section 对象的情形。

返回 SectTypeEnum 对象类型，只读。

SectTypeEnum 可为以下 SectTypeEnum 常量之一：
sectTypeCaption
sectTypeFooter
sectTypeHeader
sectTypeNone
sectTypeRecNav

expression.Type

expression 必需。该表达式返回上述对象之一。

显示 Type 属性应用于 Worksheet 对象的情形。

返回 XlSheetType 对象类型，只读。

XlSheetType 可为以下 XlSheetType 常量之一：
xlWorksheet

expression.Type

expression 必需。该表达式返回上述对象之一。

显示 Type 属性应用于 Window 对象的情形。

返回 XlWindowType 对象类型，只读。

XlWindowType 可为以下 XlWindowType 常量之一：
xlWorkbook

expression.Type

expression 必需。该表达式返回上述对象之一。

示例

本示例设置指定图表的图表类型。

Sub SetChartType()

   Dim chConstants

   Set chConstants = ChartSpace1.Constants

   ChartSpace1.Charts(0).Type = chConstants.chChartTypeLineMarkers

End Sub


Underline 属性

返回或设置指定区域的字体下划线样式。ChFont 和 PivotFont 对象的 UnderlineStyleEnum 类型，可读写。Font 对象的 Variant 类型（如果字体中的字符具有不同的下划线样式，则返回 Null，否则返回 UnderlineStyleEnum 常量之一），可读写。使用 IsNull 函数可确定返回的值是否为 Null。

UnderlineStyleEnum 可为以下 UnderlineStyleEnum 常量之一：
owcUnderlineStyleDouble
owcUnderlineStyleDoubleAccounting
owcUnderlineStyleNone
owcUnderlineStyleSingle
owcUnderlineStyleSingleAccounting

expression.Underline

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例为行 1 中所有单元格的数值添加单下划线。

Sub FormatFont()

   Dim ssConstants

   Set ssConstants = Spreadsheet1.Constants

   Spreadsheet1.Rows(1).Font.Underline = ssConstants.owcUnderlineStyleSingle

End Sub


UniqueName 属性

返回指定对象的唯一名称（由提供者返回的唯一成员引用）。如果成员来源为 RecordsetDef 对象，则返回 Null。String 类型，只读。

expression.UniqueName

expression 必需。该表达式返回“应用于”列表中的对象之一。


UniqueTable 属性

指定当窗体绑定到多表视图或存储过程时可更新表的名称。String 类型，可读写。

expression.UniqueTable

expression 必需。该表达式返回“应用于”列表中的对象之一。


UsableHeight 属性

以像素为单位返回一个窗口可占用应用程序窗口区的最大高度。返回与 Height 属性相同的值。Double 类型，只读。

expression.UsableHeight

expression 必需。该表达式返回一个 Window 对象。

说明

使用 UsableWidth 属性返回一个窗口可能的最大宽度。


UsableWidth 属性

以像素为单位返回一个窗口可占用应用程序窗口区的最大宽度。返回与 Width 属性相同的值。Double 类型，只读。

expression.UsableWidth

expression 必需。该表达式返回一个 Window 对象。

说明

使用 UsableHeight 属性返回一个窗口可能的最大高度。


UsedRange 属性

返回表示指定工作表上所用区域的 Range 对象。

expression.UsedRange

expression 必需。该表达式返回 Worksheet 对象。

示例

本示例调整活动工作表上已使用区域的行高和列宽，使其适应区域中所包含的数据。

Sub AutoFitSpreadsheet()

   Dim rngUsedRange

   ' Set a variable tot he used range in the active sheet.
   Set rngUsedRange = Spreadsheet1.ActiveSheet.UsedRange

   ' Autofit the rows.
   rngUsedRange.AutoFitRows

   ' Autofit the columns.
   rngUsedRange.AutoFitColumns

End Sub


UseRemoteProvider 属性

如果数据源控件使用远程提供者，则返回 True。Boolean 类型，可读写。

expression.UseRemoteProvider

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

如果该属性设置为 True，数据源控件使用 Microsoft Remote Data Services 提供者进行数据连接。该属性只适用于使用 HTTP 或 HTTPS 地址从 Microsoft Internet Information Server 上读取的页面。Microsoft Remote Data Services 提供者通过向 IIS 传递 HTTP 或 HTTPS 请求（IIS 再与数据库建立 OLE DB 连接）提取数据。


UserMode 属性

返回一个 Boolean 类型，指定数据透视表列表是否处于只读模式。只读。

expression.UserMode

expression 必需。该表达式返回一个 PivotTable 对象。


UseStandardHeight 属性

如果 Range 对象的行高等于工作表的标准高度，则返回 True。如果区域包含多行，并且某些行是标准高度，则返回 Null。如果没有任何行为标准高度，则返回 False。Variant 类型，可读写。

expression.UseStandardHeight

expression 必需。该表达式返回一个 Range 对象。

示例

本示例将 Spreadsheet1 中 Sheet1 的第四行高度设置为标准行高。

Spreadsheet1.Worksheets("Sheet1").Rows(4).UseStandardHeight = True


UseStandardWidth 属性

如果 Range 对象列宽等于工作表的标准宽度，则返回 True。如果区域包含多列，并且某些列是标准宽度，则返回 Null。如果没有任何列是标准宽度，则返回 False。Variant 类型，可读写。

expression.UseStandardWidth

expression 必需。该表达式返回一个 Range 对象。

示例

本示例将 Spreadsheet1 中 Sheet1 的 B 列宽设置为标准宽度。

Spreadsheet1.Worksheets("Sheet1").Columns("B").UseStandardWidth = True


UseXMLData 属性

返回或设置数据访问页是否将绑定到 XML 数据。Boolean 类型，可读写。

expression.UseXMLData

expression 必需。该表达式返回一个 DataSourceControl 对象。

说明

使用 XMLLocation 属性设置数据位于 XML 数据岛或单独的 XML 数据文件。使用 XMLDataTarget 属性指定用于绑定数据的路径或 ID。

示例

本示例将数据访问页绑定到 XML 数据文件。

Sub MSODSC_BeforeInitialBind(DSCEventInfo)

   Dim dscConstants

   Set dscConstants = MSODSC.Constants

   ' Set the offline type.
   MSODSC.XMLLocation = dscConstants.dscXMLDataFile

   ' Set the location of the XML data to a data file.
   MSODSC.XMLDataTarget = "Q1 Sales Analysis.xml"

   ' Bind to the XML data.
   MSODSC.UseXMLData = True

End Sub


Value 属性

显示 Value 属性应用于 ChSegmentBoundary 对象的情形。

返回或设置一个 Double 类型，表示指定段边界的值。可读写。

expression.Value

expression 必需。该表达式返回一个 ChSegmentBoundary 对象。

显示 Value 属性应用于 Name 和 Spreadsheet 对象的情形。

返回一个 String 类型，表示指定对象的名称。只读。

expression.Value

expression 必需。该表达式返回上面对象之一。

显示 Value 属性应用于 Borders、ByRef、ParameterValue 和 PivotDetailCell 对象的情形。

返回或设置一个 Variant 类型，表示指定对象的值。可读写。

expression.Value

expression 必需。该表达式返回上面对象之一。

显示 Value 属性应用于 Range 对象的情形。

返回或设置一个 Variant 类型，表示指定单元格的值。可读写。

expression.Value(RangeValueDataType)

expression 必需。该表达式返回一个 Range 对象。

RangeValueDataType Variant 类型，可选。区域数值的数据类型。

说明

如果指定区域中包含多个单元格，该属性返回区域中活动单元格的值。

显示 Value 属性应用于 PivotAggregate、PivotAxisMember、PivotColumnMember、PivotMember、PivotPageMember、PivotResultMemberProperty、PivotRowMember 和 SchemaProperty 对象的情形。

返回一个 Variant 类型，表示指定对象的值。只读。

expression.Value

expression 必需。该表达式返回上面对象之一。

示例

本示例从指定区域创建合并单元格，然后在合并单元格中赋值。

Sub MergeCells()

   Spreadsheet1.Range("A1:C3").Merge

   Spreadsheet1.Range("A1").Value = "Monday"

End Sub


Value2 属性

返回或设置一个 Variant 类型，表示单元格的值。可读写。

expression.Value2

expression 必需。该表达式返回一个 Range 对象。

说明

该属性与 Value 属性的唯一区别是：Value2 属性不使用 Currency 和 Date 数据类型。可以通过使用 Double 数据类型，以浮点数形式返回这些数据类型格式的数值。

示例

本示例将举例说明 Value 和 Value2 属性的差别。

Sub Value_vs_Value2()
   Dim rngCell1
   Dim rngCell2

   ' Set a variable to the cells used in this example.
   Set rngCell1 = Spreadsheet1.ActiveSheet.Range("A1")
   Set rngCell2 = Spreadsheet1.ActiveSheet.Range("A2")

   ' Set the number formats used by the cells in this example.
   rngCell1.NumberFormat = "Currency"
   rngCell2.NumberFormat = "Short Date"

   ' Set the value of cell A1 to a currency value.
   rngCell1.Value = "$123.456789"

   ' Set the value of cell A2 to a date.
   rngCell2.Value = "9/7/1970"

    ' Use the Value property to return the value of cell A1.
   MsgBox "Currency returned by the Value Property = " & _
          rngCell1.Value

   ' Use the Value2 property to return the value of cell A1.
   MsgBox "Currency returned by the Value2 Property = " & _
          rngCell1.Value2

   ' Use the Value property to return the value of cell A2.
   MsgBox "Date returned by the Value Property = " & _
          rngCell2.Value

   ' Use the Value2 property to return the value of cell A2.
   MsgBox "Date returned by the Value2 Property = " & _
          rngCell2.Value2
End Sub


ValueType 属性

返回或设置一个 ChartBoundaryValueTypeEnum 常量，表示如何解释指定段边界的 Value 属性。可读写。

ChartBoundaryValueTypeEnum 可以为下列 ChartBoundaryValueTypeEnum 常量之一。
chBoundaryValueAbsolute Value 属性指定的值为固定边界。
chBoundaryValuePercent Value 属性指定的值为百分比。

expression.ValueType

expression 必需。该表达式返回一个 ChSegmentBoundary 对象。

说明

如果该属性设置为 chBoundaryValuePercent，则指定段边界的 Value 属性必须为 0 到 1 之间。

示例

本示例将 Chartspace1 绑定到 SQL Server 罗斯文数据库中的 Order Details 表。然后，创建格式映射，在图表中以深蓝色阴影显示较大数值。

Sub Window_Onload()

    Dim serSeries1
    Dim segSegment1 As ChSegment
    Dim chconstants

    Set chconstants = ChartSpace1.Constants

    ' The following two lines of code bind Chartspace1 to the Order Details table in the
    ' Northwind SQL Server database.
    ChartSpace1.ConnectionString = "Provider=SQLOLEDB.1;Persist Security Info=TRUE;" & _
                                   "Integrated Security=SSPI;Initial Catalog=Northwind;" & _
                                   "Data Source=DataServer;"
    ChartSpace1.DataMember = "Order Details"

    ' The following two lines of code bind Chartspace1 to the Quantity and ProductID fields
    ' in  the Order Details table.
    ChartSpace1.SetData chconstants.chDimCategories, chconstants.chDataBound, "ProductID"
    ChartSpace1.SetData chconstants.chDimValues, chconstants.chDataBound, "Quantity"

    ' Create a format map.
    ChartSpace1.SetData chconstants.chDimFormatValues, chconstants.chDataBound, "Quantity"

    ' Set a variable to the first series in the first chart in Chartspace1.
    Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

    ' Add a segment to the format map.
    Set segSegment1 = serSeries1.FormatMap.Segments.Add

    ' Measure the segment boundaries based upon a percentage.
    segSegment1.Begin.ValueType = chconstants.chBoundaryValuePercent
    segSegment1.End.ValueType = chconstants.chBoundaryValuePercent

    ' Set the beginning value to 0%, and the ending value to 100%.
    segSegment1.Begin.Value = 0
    segSegment1.End.Value = 1

    ' Format the interior of the matching values.
    segSegment1.Begin.Interior.Color = "White"
    segSegment1.End.Interior.Color = "Blue"

End Sub


Version 属性

返回 Microsoft Office Web Components 的版本。String 类型，只读。

expression.Version

expression 必需。该表达式返回“应用于”列表中的对象之一。


VerticalAlignment 属性

返回或设置指定对象的垂直对齐方式。可为 XlVAlign 常量。Variant 类型，可读写。

XlVAlign 可以为下列 XlVAlign 常量之一。
xlVAlignCenter
xlVAlignLeft
xlVAlignRight

expression.VerticalAlignment

expression 必需。该表达式返回一个 Range 对象。

示例

本示例将 Spreadsheet1 中 Sheet1 上单元格 C7:G10 的内容向上对齐。

Sub SetAlignment()
   Dim rngAlign
   Dim ssConstants

   Set ssConstants = Spreadsheet1.Constants

   Set rngAlign = Spreadsheet1.Worksheets("Sheet1").Range("C7:G10")

   ' Center the contents of the range horizontally.
   rngAlign.HorizontalAlignment = ssConstants.xlHAlignCenter

   ' Vertically align the contents of the range at the top of the cells.
   rngAlign.VerticalAlignment = ssConstants.xlVAlignTop
End Sub


VerticalExtent 属性

使用 VerticalExtent 属性可指定或确定 ChScrollView 对象垂直视图的宽度。返回一个 Long 值。Long 类型，可读写。

expression.VerticalExtent

expression 必需。该表达式返回一个 ChScrollView 对象。

说明

使用 ChScrollView 对象的方法和属性可检索图表视图的有关信息和控制图表视图。Chart 组件显示图表本身的部分为可见绘图区，可显示整个图表或部分图表。仅在可见绘图区显示部分图表时，与放大该图表部分时的效果相同，剩余图表部分包含在扩展可见绘图区边界所得的虚拟绘图区中。有关 ChScrollView 对象的属性值是如何彼此关联的信息，请参阅 ChScrollView 对象主题。

示例

以下示例使用 VerticalExtentMax 属性在缩放和未缩放之间切换图表视图。

Sub ToggleZoom()
     If objChart.ChScrollView.VerticalExtent = objChart.ChScrollView.VerticalExtentMax Then
          ' Zoom chart and make it scrollable.
          objChart.ChScrollView.VerticalExtent = (objChart.ChScrollView.VerticalExtentMax / 2)
          objChart.ChScrollView.HorizontalExtent = (objChart.ChScrollView.HorizontalExtentMax / 2)
     Else
          ' Unzoom chart and remove scrolling.
          objChart.ChScrollView.VerticalExtent = objChart.ChScrollView.VerticalExtentMax
          objChart.ChScrollView.HorizontalExtent = objChart.ChScrollView.HorizontalExtentMax
     End If
End Sub


VerticalExtentMax 属性

使用 VerticalExtentMax 属性可指定或确定 ChScrollView 对象垂直视图的最大宽度。返回一个 Long 值。Long 类型，可读写。

expression.VerticalExtentMax

expression 必需。该表达式返回一个 ChScrollView 对象。

说明

使用 ChScrollView 对象的方法和属性可检索图表视图的有关信息和控制图表视图。Chart 组件显示图表本身的部分为可见绘图区，可显示整个图表或部分图表。仅在可见绘图区显示部分图表时，与放大该图表部分时的效果相同，剩余图表部分包含在扩展可见绘图区边界所得的虚拟绘图区中。VerticalExtentMax 属性表示图表的总高度，而不管图表缩放与否。有关 ChScrollView 对象的属性值是如何彼此关联的信息，请参阅 ChScrollView 对象主题。

示例

以下示例使用 VerticalExtentMax 属性在缩放和未缩放之间切换图表视图：

Sub ToggleZoom()
     If objChart.ChScrollView.VerticalExtent = objChart.ChScrollView.VerticalExtentMax Then
          ' Zoom chart.
          objChart.ChScrollView.VerticalExtent = (objChart.ChScrollView.VerticalExtentMax / 2)
          objChart.ChScrollView.HorizontalExtent = (objChart.ChScrollView.HorizontalExtentMax / 2)
     Else
          ' Unzoom chart.
          objChart.ChScrollView.VerticalExtent = objChart.ChScrollView.VerticalExtentMax
          objChart.ChScrollView.HorizontalExtent = objChart.ChScrollView.HorizontalExtentMax
     End If
End Sub


VerticalPosition 属性

使用 VerticalPosition 属性可指定或确定 ChScrollView 对象垂直视图的当前位置。返回一个 Long 值。Long 类型，可读写。

expression.VerticalPosition

expression 必需。该表达式返回一个 ChScrollView 对象。

说明

使用 ChScrollView 对象的方法和属性可检索图表视图的有关信息和控制图表视图。Chart 组件显示图表本身的部分为可见绘图区，可显示整个图表或部分图表。仅在可见绘图区显示部分图表时，与放大该图表部分时的效果相同，剩余图表部分包含在扩展可见绘图区边界所得的虚拟绘图区中。有关 ChScrollView 对象的属性值是如何彼此关联的信息，请参阅 ChScrollView 对象主题。

当 VerticalPosition 属性等于零时，绘图区的顶端将位于滚动视图窗口的顶端。VerticalPosition 属性可为负数。例如，如果 VerticalPosition = (-0.25 * VerticalExtentMax)，则绘图区将按绘图区虚拟高度的 25% 下移。

示例

以下代码显示使用 ChScrollView 对象的属性和方法的不同方式。

Dim lngVP
Dim lngHP
Dim lngVE
Dim lngHE
Dim lngVEM
Dim lngHEM
Dim objScrollView

Set objScrollView = ChartSpace1.Charts(0).ScrollView
lngVP = objScrollView.VerticalPosition
lngHP = objScrollView.HorizontalPosition
lngVE = objScrollView.VerticalExtent
lngHE = objScrollView.HorizontalExtent
lngVEM = objScrollView.VerticalExtentMax
lngHEM = objScrollView.HorizontalExtentMax

' Toggle the scroll view between unzoomed and 200% zoomed:
If lngVE = lngVEM And lngHE = lngHEM Then
        ' Chart is not zoomed so zoom to 200%.
        objScrollView.VerticalExtentMax = objScrollView.VerticalExtentMax * 2
  objScrollView.HorizontalExtentMax = objScrollView.HorizontalExtentMax * 2
Else
  ' Chart is zoomed, return it to unzoomed state.
  objScrollView.VerticalExtentMax = objScrollView.VerticalExtent
  objScrollView.HorizontalExtentMax = objScrollView.HorizontalExtent
End If

' For zoomed chart, display lower left corner of virtual plot area in
' the lower left corner of the visible plot area.
If lngVE <> lngVEM Or lngHE <> lngHEM Then
' Move bottom edge of virtual plot area to bottom of visible plot area.
 objScrollView.VerticalPosition = objScrollView.VerticalPosition + (lngVEM - lngVM)
' Move left edge of virtual plot area to left edge of visilble plot area.
objScrollView.HorizontalPosition = 0
End If

' This example does the same thing as the previous example using the SetPosition method.
If lngVE <> lngVEM Or lngHE <> lngHEM Then
 objScrollView.SetPosition 0, objScrollView.VerticalPosition + (lngVEM - lngVE)
End If


View 属性

返回一个 PivotView 对象，表示指定对象的当前视图。

expression.View

expression 必需。该表达式返回“应用于”列表中的对象之一。


ViewableRange 属性

返回或设置用户可以查看的单元格区域。设置该属性可以隐藏工作表单元格（例如，包含中间计算值的单元格）。String 类型，可读写。

expression.ViewableRange

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

请不要将该属性与 VisibleRange 属性相混淆，此属性返回代表所有当前可见单元格的 Range 对象。

示例

本示例设置电子表格上的可查看区域。

Sub Shrink_Viewable_Range()

    ' Set the viewable range of the window to cells A1:D10.
    Spreadsheet1.ActiveWindow.ViewableRange = "A1:D10"

    ' Resize the spreadsheet to eliminate the gray area.
    Spreadsheet1.Autofit = True
End Sub


ViewOnlyMode 属性

如果 Microsoft Office Web Components 处于只读模式，则返回 True。如果用户没有在计算机上安装相应的许可，则 Web 组件将处于只读模式。Boolean 类型，只读。

expression.ViewOnlyMode

expression 必需。该表达式返回“应用于”列表中的对象之一。


ViewportLeft 属性

返回或设置一个 Long 类型，表示可见数据区域的左边。使用该属性将数据区域向左滚动指定像素数。可读写。

expression.ViewportLeft

expression 必需。该表达式返回一个 PivotData 对象。

说明

使用 ViewportTop 属性返回或设置可见数据区域的顶边。

将该属性设置为无效值将导致运行时出错。例如，将该属性设置为 5000 而数据区域不能滚动如此多的像素，将导致运行时出错。


ViewportTop 属性

返回或设置一个 Long 类型，表示可见数据区域的顶边。使用该属性将数据区域向下滚动指定像素数。可读写。

expression.ViewportTop

expression 必需。该表达式返回一个 PivotData 对象。

说明

使用 ViewportLeft 属性返回或设置可见数据区域的左边。

将该属性设置为无效值将导致运行时出错。例如，将该属性设置为 5000 而数据区域不能滚动如此多的像素，将导致运行时出错。


Visible 属性

对于 ChDataLabel、ChLegendEntry、PivotLabel 和 TitleBar 对象：返回或设置一个 Boolean 类型，确定指定对象是否可见。将该属性设置为 False 可隐藏指定对象。可读写。

对于 Sheets 和 Worksheets 对象：返回或设置一个 Variant 类型，确定指定对象是否可见。将该属性设置为 False 可隐藏指定对象。可读写。

对于 Window 对象。返回一个 Boolean 类型，表示指定窗口是否可见。只读。

Worksheet 对象。返回或设置一个 XlSheetVisibility 常量，确定指定工作表的可见性。可读写。

XlSheetVisibility 可以为下列 XlSheetVisibility 常量之一。
xlSheetHidden
xlSheetVeryHidden
xlSheetVisible

expression.Visible

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例显示指定图表的图例，并隐藏指定图例项。

Sub ShowLegend()

   ChartSpace1.Charts(0).HasLegend = True
   ChartSpace1.Charts(0).Legend.LegendEntries(1).Visible = False

End Sub


VisibleRange 属性

返回代表当前所有可见单元格的 Range 对象。只读。

expression.VisibleRange

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

请不要将该属性与 ViewableRange 属性相混淆，ViewableRange 属性返回指定用户可查看的区域（该区域的一部分当前可能不可见）的 String 对象。

示例

本示例在活动工作表上的可见区域中，隔列将字体设置为加粗。

Sub Bold_Odd_Columns()
    Dim rngColumn

    'Loop through the visible columns.
    For Each rngColumn In Spreadsheet1.ActiveWindow.VisibleRange.Columns

        'Set the font to bold if the column is odd-numbered.
        If rngColumn.Column Mod 2 = 0 Then
            rngColumn.Font.Bold = True
        End If
    Next
End Sub

如果单元格 A1 的整个当前区域处于可见状态，则本示例中的函数返回 True（如果当前区域延伸到可见区域以外，则函数返回 False）。

Function IsCurrentRegionVisible()
    Dim rngCurrent
    Dim rngVisible
    Dim rngIntersect

    ' Set the varible to the current region of cell A1.
    Set rngCurrent = Spreadsheet1.ActiveSheet.Cells(1, 1).CurrentRegion

    ' Set a variable to the currently visible range.
    Set rngVisible = Spreadsheet1.ActiveWindow.VisibleRange

    ' Set a variable to the overlapping portion of the current region
    ' and the visible range.
    Set rngIntersect = Spreadsheet1.RectIntersect(rngCurrent, rngVisible)

    ' If the overlapping region is the same as the current ragion, then
    ' return true.
    IsCurrentRegionVisible = (rngIntersect.Address = rngCurrent.Address)
End Function


WatermarkBorder 属性

返回一个表示指定放置区中水印边框的 ChBorder 对象。使用返回的 ChBorder 对象的属性设置放置区的水印边框格式。

expression.WatermarkBorder

expression 必需。该表达式返回一个 ChDropZone 对象。

示例

本示例将设置 Chartspace1 中系列放置区的按钮和水印格式。

Sub SetupDropZone()

    Dim dzSeriesDropZone
    Dim ChConstants

    Set chConstants = Chartspace1.Constants

    ' Set a variable to the series drop zone in Chartspace1.
    Set dzSeriesDropZone = ChartSpace1.DropZones(chConstants.chDropZoneSeries)

    ' The next three lines of code format the button of the drop zone.
    dzSeriesDropZone.ButtonBorder.Weight = chConstants.owcLineWeightMedium
    dzSeriesDropZone.ButtonInterior.SetSolid "Red"
    dzSeriesDropZone.ButtonFont.Size = 14

    ' The next three lines of code format the watermark of the drop zone.
    dzSeriesDropZone.WatermarkBorder.Color = "Red"
    dzSeriesDropZone.WatermarkFont.Color = "Red"
    dzSeriesDropZone.WatermarkInterior.SetSolid "Green"

End Sub


WatermarkFont 属性

返回一个表示指定放置区中水印字体的 ChFont 对象。使用返回的 ChFont 对象的属性设置放置区中水印的字体格式。

expression.WatermarkFont

expression 必需。该表达式返回一个 ChDropZone 对象。

示例

本示例将设置 Chartspace1 中系列放置区的按钮和水印格式。

Sub SetupDropZone()

    Dim dzSeriesDropZone
    Dim ChConstants

    Set chConstants = Chartspace1.Constants

    ' Set a variable to the series drop zone in Chartspace1.
    Set dzSeriesDropZone = ChartSpace1.DropZones(chConstants.chDropZoneSeries)

    ' The next three lines of code format the button of the drop zone.
    dzSeriesDropZone.ButtonBorder.Weight = chConstants.owcLineWeightMedium
    dzSeriesDropZone.ButtonInterior.SetSolid "Red"
    dzSeriesDropZone.ButtonFont.Size = 14

    ' The next three lines of code format the watermark of the drop zone.
    dzSeriesDropZone.WatermarkBorder.Color = "Red"
    dzSeriesDropZone.WatermarkFont.Color = "Red"
    dzSeriesDropZone.WatermarkInterior.SetSolid "Green"

End Sub


WatermarkInterior 属性

返回一个表示指定放置区中水印内部的 ChInterior 对象。使用返回的 ChInterior 对象的属性设置放置区中水印内部的格式。

expression.WatermarkInterior

expression 必需。该表达式返回一个 ChDropZone 对象。

示例

本示例将设置 Chartspace1 中系列放置区的按钮和水印格式。

Sub SetupDropZone()

    Dim dzSeriesDropZone
    Dim ChConstants

    Set chConstants = Chartspace1.Constants

    ' Set a variable to the series drop zone in Chartspace1.
    Set dzSeriesDropZone = ChartSpace1.DropZones(chConstants.chDropZoneSeries)

    ' The next three lines of code format the button of the drop zone.
    dzSeriesDropZone.ButtonBorder.Weight = chConstants.owcLineWeightMedium
    dzSeriesDropZone.ButtonInterior.SetSolid "Red"
    dzSeriesDropZone.ButtonFont.Size = 14

    ' The next three lines of code format the watermark of the drop zone.
    dzSeriesDropZone.WatermarkBorder.Color = "Red"
    dzSeriesDropZone.WatermarkFont.Color = "Red"
    dzSeriesDropZone.WatermarkInterior.SetSolid "Green"

End Sub


Weight 属性

返回或设置指定边框或线条的粗细。可以为 LineWeightEnum 常量之一，如果边框粗细不统一，则返回 Null。Variant 类型，可读写。

expression.Weight

expression 必需。该表达式返回“应用于”列表中的对象之一。

示例

本示例设置图表坐标轴线条和边框为粗线。

Sub FormatChart()

   Dim chConstants

   Set chConstants = ChartSpace1.Constants

   ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionValue).Line _
                       .Weight = chConstants.owcLineWeightThick

   ChartSpace1.Border.Weight = chConstants.owcLineWeightThick

End Sub


Width 属性

显示 Width 属性应用于 Window 对象的情形。

返回一个 Double 类型，表示指定窗口的宽度。只读。

expression.Width

expression 必需。该表达式返回一个 Window 对象。

显示 Width 属性应用于 PivotAxisMember、PivotColumnMember、PivotFieldSet、PivotPageMember、PivotRowMember、PivotTable 和 PivotTotal 对象的情形。

返回或设置一个 Long 类型，表示指定对象的宽度。可读写。

expression.Width

expression 必需。该表达式返回上面对象之一。

显示 Width 属性应用于 PivotAggregate、PivotDetailCell、PivotResultAxis、PivotResultColumnAxis、PivotResultDataAxis、PivotResultFilterAxis、PivotResultGroupAxis、PivotResultLabel、PivotResultPageAxis 和 PivotResultRowAxis 对象的情形。

返回一个 Long 类型，表示指定对象的宽度。只读。

expression.Width

expression 必需。该表达式返回上面对象之一。

显示 Width 属性应用于 Range 对象的情形。

返回一个 Variant 类型，表示指定对象的宽度。只读。

expression.Width

expression 必需。该表达式返回一个 Range 对象。

说明

如果更改 Width 属性的值，数据透视表列表的 AutoFit 属性将设置为 False。

示例

本示例设置数据透视表列表的宽度为 150 点。

PivotTable1.Object.Width = 150


WidthRatio 属性

返回或设置指定图表相对于图表工作区中其他图表的宽度比例。默认值为 100。Long 类型，可读写。

expression.WidthRatio

expression 必需。该表达式返回 ChChart 对象。

说明

若要使该属性生效，图表工作区中必须有多个图表。当显示多个图表时，这些图表在一个网格中显示（有关详细信息，请参阅 ChartLayout 和 ChartWrapCount 属性的帮助主题）。在初始情况下，网格中所有图表的 HeightRatio 和 WidthRatio 属性均设置为 100，即所有图表具有同样的大小。

若要更改网格中图表的宽度，请调整 WidthRatio 属性设置。例如，如果以三列显示每个图表，所有图表初始 WidthRatio 设置为 100。如果希望列 3 占用可用宽度的一半，可将其 WidthRatio 设置为 200；图表宽度的另一半将由列 1 和列 2 平分。由于 WidthRatio 属性指定的宽度是相对的，因此可以将三个列的该属性分别设置为 1、1、2，100、100、200 或 20、20、40，它们具有相同的效果。

如果图表工作区包含由多列显示的图表，则每列最大的 WidthRatio 设置将用于设置整个列的相对宽度。

该属性对于创建价格和成交量股票图表非常有用，其中成交量图表为价格图表一半大小。


WindowNumber 属性

返回窗口数。在该 Microsoft Office Spreadsheet Component 版本中通常返回 1。Long 类型，只读。

expression.WindowNumber

expression 必需。该表达式返回一个 Window 对象。


Windows 属性

返回一个 Windows 集合，表示打开工作簿中的窗口。

expression.Windows

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

尽管打开工作簿中的每个工作表均具有自己的窗口，该属性总是返回对活动工作表窗口的引用。


Workbooks 属性

返回一个表示打开工作簿的 Workbooks 集合。

expression.Workbooks

expression 必需。该表示返回一个 Spreadsheet 对象。


Worksheet 属性

返回一个表示包含指定区域的工作表的 Worksheet 对象。只读。

expression.Worksheet

expression 必需。该表达式返回一个 Range 对象。

示例

本示例激活 Spreadsheet1 中包含区域 "Revenue" 的工作表。

Spreadsheet1.Range("Revenue").Worksheet.Activate


Worksheets 属性

返回一个 Worksheets 集合，表示打开工作簿中的工作表。

expression.Worksheets

expression 必需。该表达式返回“应用于”列表中的对象之一。


X 属性

返回一个 Long 类型，表示 Coordinate 对象中当前存储的数据点的 X 坐标。只读。

expression.x

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

使用 ValueToPoint 方法将数据点的坐标返回到 Coordinate 对象。

使用 y 属性返回 Coordinate 对象中当前存储的数据点的 Y 坐标。

示例

本示例将 Chartspace1 中第一个图表的标题更改为图表第一个系列中数据点的像素坐标。

Sub GetPixelCoordinates()

    Dim chChart1
    Dim lXPos
    Dim lYPos
    Dim coPointCoordinates

    ' Set a variable to the first chart in Chartspace1.
    Set chChart1 = ChartSpace1.Charts(0)

    ' Enable the title for the chart.
    chChart1.HasTitle = True

    ' Set a Coordinate object to the coordinates of a data point.
    Set coPointCoordinates = chChart1.SeriesCollection(0).ValueToPoint("Pears", 10)

    ' Set a variable to the X-coordinate.
    lXPos = coPointCoordinates.x

    ' Set a variable to the Y-coordinate.
    lYPos = coPointCoordinates.y

    ' Set the chart's titles to the pixel coordinates of the specified
    ' data point.
    chChart1.Title.Caption = "X(" & lXPos & ") Y(" & lYPos & ")"

End Sub


XMLData 属性

返回或设置指定组件的 XML 数据。String 类型，可读写。

expression.XMLData

expression 必需。该表达式返回“应用于”列表中的对象之一。


XmlDataBindings 属性

使用 XmlDataBindings 属性可返回一个 XmlDataBindings 集合。XmlDataBindings 集合，只读。

expression.XmlDataBindings

expression 必需。该表达式返回一个 Workbook 对象。

说明

XmlDataBindings 集合包含一个或多个 XmlDataBinding 对象。每个 XmlDataBinding 对象包含将 Spreadsheet 组件绑定到数据检索服务、SOAP Web 服务、XML 文件或其他 Spreadsheet 组件的配置数据。

示例

以下示例使用 Workbook 对象的 XmlDataBindings 属性返回 XmlDataBindings 集合的成员，然后处理表示绑定信息的 XML：

Dim objBindings
Dim objBinding
Dim strBindingInfo

Set objBindings = Spreadsheet1.ActiveWorkbook.XmlDataBindings

For Each objBinding in objBindings
     ' Save the XML binding information to a variable.
     strBindingInfo = objBinding.BindingData
     ' Work with binding information here.
Next


XMLDataTarget 属性

返回或设置一个 String 类型，表示要加载或保存 XML 数据的位置。可读写。

expression.XMLDataTarget

expression 必需。该表达式返回一个 DataSourceControl 对象。

示例

本示例将名为 MSODSC 的数据源控件中的当前数据导出到 XML 数据文件。

Sub ExportData()

   Dim dscConstants

   Set dscConstants = MSODSC.Constants

   ' Set the location of the XML data to a data file.
   MSODSC.XMLLocation = dscConstants.dscXMLDataFile

   ' Set the specific target to export to.
   MSODSC.XMLDataTarget = "Q1 Sales Analysis.xml"

   ' Export the current data.
   MSODSC.ExportXML
End Sub


XMLLocation 属性

返回或设置一个 DscXMLLocationEnum 常量，指定是从 XML 数据文件还是从当前数据访问页中的 XML 数据岛加载或保存 XML 数据。可读写。

DscXMLLocationEnum 可以为下列 DscXMLLocationEnum 常量之一。
dscXMLDataFile XML 数据存储在单独的文件中。
dscXMLEmbedded XML 数据存储在当前数据访问页中的 XML 数据岛。

expression.XMLLocation

expression 必需。该表达式返回一个 DataSourceControl 对象。

示例

本示例将名为 MSODSC 的数据源控件中的当前数据导出到 XML 数据文件。

Sub ExportData()

   Dim dscConstants

   Set dscConstants = MSODSC.Constants

   ' Set the location of the XML data to a data file.
   MSODSC.XMLLocation = dscConstants.dscXMLDataFile

   ' Set the specific target to export to.
   MSODSC.XMLDataTarget = "Q1 Sales Analysis.xml"

   ' Export the current data.
   MSODSC.ExportXML

End Sub


XmlMap 属性

使用 XmlMap 属性可返回一个 XmlMap 对象，表示与 XmlDataBinding 对象相关联的 XML 架构映射。返回一个 XmlMap 对象。只读。

expression.XmlMap

expression 必需。该表达式返回一个 XmlDataBinding 对象。

说明

使用 XmlMap 对象的 MapData 属性可指定或确定在 XmlDataBinding 对象中指定的数据源映射信息。

示例

以下示例使用 XmlMap 属性返回与绑定相关联的架构映射。

Dim objBindings
Dim objBinding
Dim strMapInfo

Set objBindings = Spreadsheet1.ActiveWorkbook.XmlDataBindings

For Each objBinding in objBindings
     ' Save the XML binding information to a variable.
     Set strMapInfo = objBinding.XmlMap
     ' Work with binding information here.
Next


XmlMaps 属性

使用 Workbook 对象的 XmlMaps 属性可返回一个 XmlMaps 集合。返回一个 XmlMaps 集合。只读。

expression.XmlMaps

expression 必需。该表达式返回一个 Workbook 对象。

说明

XmlMaps 对象是与 Spreadsheet 组件相关联的所有 XmlMap 对象的集合。XmlMap 是一个 XML 架构映射，指定如何在 Spreadsheet 组件中从数据源映射数据。

通过使用 XmlMaps 集合的 Add 方法可创建新的 XmlMap 对象。在将 Spreadsheet 组件的 XmlUrl 属性设置为 XML 电子表格文件名称或包含有正确的 XML 配置数据（包含 Spreadsheet 组件的绑定和映射配置）的字符串时也可使用 XmlMap 对象。可通过以下方法创建 XML 电子表格文件：使用 Microsoft Excel 创建数据绑定电子表格，再将工作簿另存为 XML 电子表格。

示例

以下示例举例说明如何使用 WorkBook 对象的 XmlMaps 属性返回 XmlMaps 集合。

Dim objMaps
Dim objMap
Dim strMapInfo

Set objMaps = Spreadsheet1.ActiveWorkbook.XmlMaps

For Each objMap in objMaps
     ' Save the XML map information to a variable.
     strMapInfo = objMap.MapData
     ' Work with map information here.
Next


XMLURL 属性

返回或设置一个 String 类型，表示可扩展标记语言 (XML) 文件的 URL。设置该属性将放弃当前打开的工作簿，并将指定 XML 文件加载到新的工作簿。可读写。

expression.XMLURL

expression 必需。该表达式返回一个 Spreadsheet 对象。

示例

本示例将指定 XML 文件的内容加载到 Spreadsheet1 的 Sheet1 中。

Spreadsheet1.XMLURL = "http://example.microsoft.com/Test.xml"


Y 属性

返回一个 Long 类型，表示 Coordinate 对象中当前存储的数据点的 Y 坐标。只读。

expression.y

expression 必需。该表达式返回“应用于”列表中的对象之一。

说明

使用 ValueToPoint 方法将数据点的坐标返回到 Coordinate 对象。

使用 x 属性返回 Coordinate 对象中当前存储的数据点的 X 坐标。

示例

本示例将 Chartspace1 中第一个图表的标题更改为图表第一个系列中数据点的像素坐标。

Sub GetPixelCoordinates()

    Dim chChart1
    Dim lXPos
    Dim lYPos
    Dim coPointCoordinates

    ' Set a variable to the first chart in Chartspace1.
    Set chChart1 = ChartSpace1.Charts(0)

    ' Enable the title for the chart.
    chChart1.HasTitle = True

    ' Set a Coordinate object to the coordinates of a data point.
    Set coPointCoordinates = chChart1.SeriesCollection(0).ValueToPoint("Pears", 10)

    ' Set a variable to the X-coordinate.
    lXPos = coPointCoordinates.x

    ' Set a variable to the Y-coordinate.
    lYPos = coPointCoordinates.y

    ' Set the chart's titles to the pixel coordinates of the specified
    ' data point.
    chChart1.Title.Caption = "X(" & lXPos & ") Y(" & lYPos & ")"

End Sub


ZOrder 属性

返回或设置一个 Long 类型，指定系列从前到后的着色次序。可读写。

expression.ZOrder

expression 必需。该表达式返回一个 ChSeries 对象。

说明

将该属性设置为 0 使系列在图表前着色。

该属性仅影响簇状或重叠三维面积图、条形图、柱形图和折线图。


AfterDelete 事件

在删除记录后或取消记录删除后发生。如果要在删除记录后执行一系列操作，请使用该事件。

Private Sub Object_AfterDelete(ByVal DSCEventInfo As DSCEventInfo)

Object DataSourceControl 对象。

DSCEventInfo 包含事件有关信息的 DSCEventInfo 对象。

说明

使用 DSCEventInfo 对象的 Status 属性判断是否取消了记录删除。

使用 DSCEventInfo 对象的 DataPage 和 Section 属性判断更新的数据访问页、节和记录集。

示例

本示例显示消息框指出触发事件的记录删除状态。

Sub MSODSC_AfterDelete(DSCEventInfo)

   Dim dscConstants

   Set dscConstants = MSODSC.Constants

   ' Check the status of the record deletion.
   Select Case DSCEventInfo.Status

      ' The record was deleted.
      Case dscConstants.dscDeleteOK

         MsgBox "Record deleted successfully."

      ' The deletion was canceled via code.
      Case dscConstants.dscDeleteCancel

         MsgBox "Record deletion canceled by code."

      ' The delection was canceled by the user.
      Case dscConstants.dscDeleteUserCancel
         MsgBox "Record deletion canceled by user."

   End Select

End Sub


AfterFinalRender 事件

在所有图表元素均已着色后发生。

Private Sub ChartSpace_AfterFinalRender(ByVal drawObject As ChChartDraw)

drawObject ChChartDraw 对象。使用该对象的方法和属性在图表上绘制对象。

说明

要使用该事件，必须将 AllowRenderEvents 属性设置为 True。


AfterInsert 事件

在插入记录后发生。如果要在插入记录后执行一系列操作，请使用该事件。

Private Sub Object_AfterInsert(ByVal DSCEventInfo As DSCEventInfo)

Object DataSourceControl 对象。

DSCEventInfo 包含事件有关信息的 DSCEventInfo 对象。

说明

使用 DSCEventInfo 对象的 DataPage 和 Section 属性判断更新的数据访问页、节和记录。


AfterLayout 事件

在指定图表控件中的所有图表完成排列之后、着色之前发生。在该事件中，可以通过更改每张图表的 Left 和 Top 属性重新定位它们的 ChTitle、ChLegend、ChChart 和 ChAxis 对象。可以通过更改 Left、Top、Right 和 Bottom 属性重新定位 ChPlotArea 对象。这些属性不能在该事件之外更改。

Private Sub ChartSpace_AfterLayout( ByVal drawObject As ChChartDraw)

drawObject ChChartDraw 对象。在图表上使用此对象的方法和属性操作绘图对象。

说明

为了捕捉该事件，必须将 AllowLayoutEvents 属性设置为 True。

示例

本示例使用 AfterLayout 事件将 Chartspace1 中第一张图表的标题移动到图表的左侧，然后将图例移动到图表的顶部。

Private Sub ChartSpace1_AfterLayout(drawObject)

    ' Move the title to the left side of the chart.
    ChartSpace1.Charts(0).Title.Left = 1

    ' Move the legend towards the top of the chart.
    ChartSpace1.Charts(0).Legend.Top = 20

End Sub


AfterRender 事件

在 chartObject 参数表示的对象着色后发生。

Private Sub ChartSpace_AfterRender(ByVal drawObject As ChChartDraw, ByVal chartObject As Object)

drawObject ChChartDraw 对象。使用该对象的方法和属性修改图表上的绘图对象。

chartObject 已着色的对象。使用 TypeName 函数判断着色的对象类型。

说明

要在所有图表对象上使用该事件，必须将 AllowRenderEvents 和 AllowPointsRenderEvents 属性设置为 True。

示例

本示例在每次重绘图表时在绘图区的左上角添加文本字符串。

Sub ChartSpace1_AfterRender(drawObject, chartObject)

    Dim chChart1

    Set chChart1 = ChartSpace1.Charts(0)

    ' After the legend has been rendered, then add the text
    ' to the chart.
    If TypeName(chartObject) = "ChLegend" Then
        drawObject.DrawText "2000 Sales", chChart1.PlotArea.Left + 5, _
                            chChart1.PlotArea.Top

    End If

End Sub

本示例演示如何结合使用 BeforeRender 和 AfterRender 事件创建自定义网格线。BeforeRender 事件取消网格线的着色，AfterRender 事件绘制自定义网格线。

Sub ChartSpace1_BeforeRender(drawObject, chartObject, Cancel)

    ' Check to see if the next object to be rendered
    ' is a gridline.
    If TypeName(chartObject) = "ChGridlines" Then

        ' Cancel the rendering of gridlines.
        Cancel.Value = True

    End If

End Sub

Sub ChartSpace1_AfterRender(drawObject, chartObject)

    Dim chChart1
    Dim plPlotArea
    Dim lLeft
    Dim lRight
    Dim lHeight
    Dim lTop
    Dim lIncrement
    Dim chConstants
    Dim iCtr

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the first chart in Chartspace1.
    Set chChart1 = ChartSpace1.Charts(0)

    ' Set a variable to the plot area of the chart.
    Set plPlotArea = chChart1.PlotArea

    ' Check to see if the rendered object is a gridline.
    If TypeName(chartObject) = "ChGridlines" Then

        ' The next four lines of code use the extents of
        ' the plot area to calculate the dimensions of the line
        ' to be drawn.
        lLeft = plPlotArea.Left
        lTop = plPlotArea.Top
        lRight = plPlotArea.Right
        lHeight = plPlotArea.Bottom - lTop

        ' Determine the increment to use between gridlines.
        ' Change the divisor to adjust the increment.
        lIncrement = lHeight / 10

        ' The next three lines of code set the properties of the
        ' line to be drawn.
        drawObject.Line.DashStyle = chConstants.chLineRoundDot
        drawObject.Line.Color = "Green"
        drawObject.Line.Weight = chConstants.owcLineWeightMedium

        For iCtr = 1 To 9

            ' Draw the line.
            drawObject.DrawLine lLeft, lTop + iCtr * lIncrement, _
                                lRight, lTop + iCtr * lIncrement

        Next
    End If

End Sub


AfterUpdate 事件

在以新数据更新记录或记录失去焦点后发生。

Private Sub Object_AfterUpdate(ByVal DSCEventInfo As DSCEventInfo)

Object DataSourceControl 对象。

DSCEventInfo 包含事件有关信息的 DSCEventInfo 对象。

说明

使用 DSCEventInfo 对象的 DataPage 和 Section 属性判断更新的数据访问页、节和记录。

示例

本示例显示包含更新记录的节的有关信息。

Sub MSODSC_AfterUpdate(DSCInfo)

    MsgBox DSCInfo.Section.HTMLContainer.All(1).InnerText

End Sub


BeforeCollapse 事件

当单击数据访问页上的折叠按钮时发生。

Private Sub Object_BeforeCollapse(DSCEventInfo As DSCEVENTINFO)

Object 应用该事件的 DataSourceControl 对象名称。

DSCEventInfo 包含事件相关信息的 DSCEventInfo 对象。


BeforeContextMenu 事件

在显示上下文菜单之前发生。用户单击鼠标右键或按下应用键将显示上下文菜单。

Private Sub Object_BeforeContextMenu(ByVal x As Long, ByVal y As Long, ByVal Menu As Byref, ByVal Cancel As ByRef)

x 表示显示上下文菜单的 X 坐标。

y 表示显示上下文菜单的 Y 坐标。

Menu 将该对象的 Value 属性设置为包含要显示的菜单项数组。

Cancel 将该对象的 Value 属性设置为 True 将取消键击。

说明

使用该事件自定义 Microsoft Office Web Components 的上下文菜单。

示例

本示例显示一个自定义上下文菜单。菜单中包含四个选项，最后一个选项显示子菜单。

Sub Spreadsheet1_BeforeContextMenu(x, y, Menu, Cancel)

    Dim cmContextMenu(4)
    Dim cmClearSubMenu(2)

    cmClearSubMenu(0) = Array("&All", "ClearAll")
    cmClearSubMenu(1) = Array("&Formats", "ClearFormats")
    cmClearSubMenu(2) = Array("&Values", "ClearValues")

    cmContextMenu(0) = Array("Cu&t", "owc2")
    cmContextMenu(1) = Array("&Copy", "owc3")
    cmContextMenu(2) = Array("&Paste", "owc4")
    cmContextMenu(3) = Empty
    cmContextMenu(4) = Array("Clea&r", cmClearSubMenu)

    Menu.Value = cmContextMenu

End Sub


BeforeDelete 事件

在删除记录之前发生。如果要在删除记录之前应用一系列条件，请使用该事件。

Private Sub Object_BeforeDelete(ByVal DSCEventInfo As DSCEventInfo)

Object DataSourceControl 对象。

DSCEventInfo 包含事件有关信息的 DSCEventInfo 对象。

说明

将 DSCEventInfo 对象的 ReturnValue 属性设置为 False 可取消记录删除。取消记录删除后，仍将发生 AfterDelete 事件。

使用 DSCEventInfo 对象的 DataPage 和 Section 属性判断更新的数据访问页、节和记录。

使用 DisplayAlert 属性决定在调用该事件时是否提示用户。

示例

如果 "Discontinued" 字段设置为 No，本示例取消记录删除。

Sub MSODSC_BeforeDelete(DSCEventInfo)

   Dim txtDiscontinued

   ' Set a variable to the text box that contains the value
   ' of the Discontinued field for the record that is to be deleted.
   Set txtDiscontinued = DSCEventInfo.Section.HTMLContainer _
                        .Children("Discontinued")

   ' Check the value of the control.
   If txtDiscontinued.Value = "No" Then

      ' Display a message to the user.
      Msgbox "Do not delete products that have not " & _
             "been discontinued."

      Cancel the deletion of the record.
      DSCEventInfo.ReturnValue = False
   End If

End Sub


BeforeExpand 事件

当单击数据访问页上的展开按钮时发生。

Private Sub Object_BeforeExpand(DSCEventInfo As DSCEVENTINFO)

Object 应用该事件的 DataSourceControl 对象名称。

DSCEventInfo 包含事件相关信息的 DSCEventInfo 对象。


BeforeFirstPage 事件

在显示联合数据访问页上第一组记录集之前发生。

Private SubObject_BeforeFirstPage(DSCEventInfo As DSCEVENTINFO)

Object 应用该事件的 DataSourceControl 对象名称。

DSCEventInfo 包含事件相关信息的 DSCEventInfo 对象。


BeforeInitialBind 事件

在指定数据访问页上的控件首次绑定到记录集之前发生。使用该事件在控件应用数据之前设置数据访问页的属性。

Private Sub Object_BeforeInitialBind(ByVal DSCEventInfo As DSCEventInfo)

Object DataSourceControl 对象。

DSCEventInfo 包含事件有关信息的 DSCEventInfo 对象。

说明

本事件不支持任何 DSCEventInfo 属性。


BeforeInsert 事件

在新记录中输入第一个字符之后，将记录添加到记录集之前发生。

Private Sub Object_BeforeInsert(ByVal DSCEventInfo As DSCEventInfo)

Object DataSourceControl 对象。

DSCEventInfo 包含事件有关信息的 DSCEventInfo 对象。

说明

将 DSCEventInfo 对象的 ReturnValue 属性设置为 False 可取消插入新记录。

可以使用 DSCEventInfo 对象的 DataPage 属性获取有关数据访问页的详细信息。

示例

本示例使用 BeforeInsert 事件防止用户在记录集达到 75 条记录时添加其他记录。

Sub MSODSC_BeforeInsert(DSCEventInfo)
   Dim rstCurrentData

   ' Set a variable to the recordset.
   Set rstCurrentData = DSCEventInfo.DataPage.Recordset

   ' Check to see if the recordset has reached its limit.
   If rstCurrentData.RecordCount >= 75 then

      ' Display a message to the user.
      MsgBox "Cannot add any more records."

      ' Cancel the insertion of the record.
      DSCEventInfo.ReturnValue = False
   End If
End Sub


BeforeKeyDown 事件

在用户按下键盘上的键之后、控件处理键击之前发生。如果用户将键按住，该事件将按照用户计算机上设置的键击重复间隔重复发生。

Private Sub Object_BeforeKeyDown(ByVal KeyCode As Long, ByVal Shift As Long, ByVal Cancel As ByRef)

Object ChartSpace、PivotTable 或 Spreadsheet 对象。

KeyCode 表示按下或释放的键代码的整数。

Shift Shift、Ctrl 和 Alt 的状态。如果按下 Shift 则返回 1，按下 Ctrl 则返回 2，按下 Alt 则返回 4。如果 Shift、Ctrl 和 Alt 均没有按下，则返回 0。

Cancel 将该对象的 Value 属性设置完 True 可取消键击。

说明

取消该事件还将取消 BeforeKeyPress 和 KeyPress 事件，但是不能阻止 KeyDown 或 KeyUp 事件发生。

键击相关事件的顺序为：

  1. BeforeKeyDown
  2. KeyDown
  3. BeforeKeyPress
  4. KeyPress
  5. BeforeKeyUp
  6. KeyUp


BeforeKeyPress 事件

在用户按下并释放键盘上的键之后、控件处理键击之前发生。如果用户将键按住，该事件将按照用户计算机上设置的键击重复间隔重复发生。

Private Sub Object_BeforeKeyPress(ByVal KeyAscii As Long, ByVal Cancel As ByRef)

Object ChartSpace、PivotTable 或 Spreadsheet 对象。

KeyAscii 表示按下或释放的键代码的整数。

Cancel 将该对象的 Value 属性设置为 True 可取消键击。

说明

取消该事件并不阻止 KeyPress 或 KeyUp 事件发生。

键击相关事件的顺序为：

  1. BeforeKeyDown
  2. KeyDown
  3. BeforeKeyPress
  4. KeyPress
  5. BeforeKeyUp
  6. KeyUp


BeforeKeyUp 事件

在用户释放键盘上某个键之后、控件处理该键击之前发生。

Private Sub Object_BeforeKeyUp(ByVal KeyCode As Long, ByVal Shift As Long, ByVal Cancel As ByRef)

Object 应用该事件的 ChartSpace、PivotTable 或 Spreadsheet 对象名称。

KeyCode 表示按下或释放的键代码的整数。

Shift Shift、Ctrl 和 Alt 键的状态。如果按下 Shift 键则返回 1，如果按下 Ctrl 键则返回 2 ，如果按下 Alt 键则返回 4。如果没有按下 Shift、Ctrl 或 Alt 中的任何键则返回 0。

Cancel 将该对象的 Value 属性设置为 True 可取消键击。

说明

取消该事件并不能阻止发生 KeyUp 事件。

键盘相关事件的顺序为：

  1. BeforeKeyDown
  2. KeyDown
  3. BeforeKeyPress
  4. KeyPress
  5. BeforeKeyUp
  6. KeyUp


BeforeLastPage 事件

在显示联合数据访问页上最后一组记录集之前发生。

Private Sub Object_BeforeLastPage(DSCEventInfo As DSCEVENTINFO)

Object 应用该事件的 DataSourceControl 对象名称。

DSCEventInfo 包含事件相关信息的 DSCEventInfo 对象。


BeforeNextPage 事件

在显示联合数据访问页上下一组记录集之前发生。

Private Sub Object_BeforeNextPage(DSCEventInfo As DSCEVENTINFO)

Object 应用该事件的 DataSourceControl 对象名称。

DSCEventInfo 包含事件相关信息的 DSCEventInfo 对象。


BeforeOverwrite 事件

在将要覆盖已有文件之前发生。

Private Sub Object_BeforeOverwrite(ByVal DSCEventInfo As DSCEventInfo)

Object DataSourceControl 对象。

DSCEventInfo 包含事件有关信息的 DSCEventInfo 对象。

说明

该事件可以在使用 ExportXML 方法导出当前记录集时发生。将 DSCEventInfo 对象的 ReturnValue 属性设置为 False 可阻止覆盖已有文件。将 DSCEventInfo 对象的 DisplayAlert 属性设置为 dscDataAlertContinue 可在不提示用户的情况下覆盖文件。

注释：不能覆盖不是由数据源控件创建的文件。

示例

本示例允许在不提示用户的情况下覆盖由 ExportXML 方法创建的文件。

Sub MSODSC_BeforeOverwrite(DSCEventInfo)

   Dim dscConstants
   Set dscConstants = MSODSC.Constants

   'Don't alert the user when overwriting an existing file.
   DSCEventInfo.DisplayAlert = dscConstants.dscDataAlertContinue

End Sub


BeforePreviousPage 事件

在显示联合数据访问页上前一组记录集之前发生。

Private Sub Object_BeforePreviousPage(DSCEventInfo As DSCEVENTINFO)

Object 应用该事件的 DataSourceControl 对象名称。

DSCEventInfo 包含事件相关信息的 DSCEventInfo 对象。


BeforeRender 事件

在由 chartObject 参数传递的对象着色之前发生。

Private Sub Object_BeforeRender(ByVal drawObject As ChChartDraw, ByVal chartObject As Object, Cancel As ByRef)

Object 要触发该事件的 ChartSpace 对象名称。

drawObject 对 ChChartDraw 对象的引用。使用返回的对象的 DrawType 属性判断要发生的着色类型。

chartObject 要着色的对象。使用 TypeName 函数判断对象的类型。

Cancel 将该对象的 Value 属性设置为 True 可取消对 chartObject 表示的对象的着色。

说明

要在所有图表对象上使用该事件，必须将 AllowRenderEvents 和 AllowPointsRenderEvents 属性设置为 True。

示例

本示例演示如何结合使用 BeforeRender 和 AfterRender 事件创建自定义网格线。BeforeRender 事件取消网格线的着色，AfterRender 事件绘制自定义网格线。

Sub ChartSpace1_BeforeRender(drawObject, chartObject, Cancel)

    ' Check to see if the next object to be rendered
    ' is a gridline.
    If TypeName(chartObject) = "ChGridlines" Then

        ' Cancel the rendering of gridlines.
        Cancel.Value = True
    End If
End Sub

Sub ChartSpace1_AfterRender(drawObject, chartObject)
    Dim chChart1
    Dim plPlotArea
    Dim lLeft
    Dim lRight
    Dim lHeight
    Dim lTop
    Dim lIncrement
    Dim chConstants
    Dim iCtr

    Set chConstants = ChartSpace1.Constants

    ' Set a variable to the first chart in Chartspace1.
    Set chChart1 = ChartSpace1.Charts(0)

    ' Set a variable to the plot area of the chart.
    Set plPlotArea = chChart1.PlotArea

    ' Check to see if the rendered object is a gridline.
    If TypeName(chartObject) = "ChGridlines" Then

        ' The next four lines of code use the extents of
        ' the plot area to calculate the dimensions of the line
        ' to be drawn.
        lLeft = plPlotArea.Left
        lTop = plPlotArea.Top
        lRight = plPlotArea.Right
        lHeight = plPlotArea.Bottom - lTop

        ' Determine the increment to use between gridlines.
        ' Change the divisor to adjust the increment.
        lIncrement = lHeight / 10

        ' The next three lines of code set the properties of the
        ' line to be drawn.
        drawObject.Line.DashStyle = chConstants.chLineRoundDot
        drawObject.Line.Color = "Green"
        drawObject.Line.Weight = chConstants.owcLineWeightMedium

        For iCtr = 1 To 9

            ' Draw the line.
            drawObject.DrawLine lLeft, lTop + iCtr * lIncrement, _
                                lRight, lTop + iCtr * lIncrement
        Next
    End If
End Sub


BeforeScreenTip 事件

显示 BeforeScreenTip 事件应用于 ChartSpace 对象的情形。

在显示屏幕提示之前发生。

Private Sub Object_BeforeScreenTip(ByVal TipText As ByRef, ByVal ContextObject As Object)

Object 要触发该事件的 ChartSpace 对象名称。

TipText 将该对象的 Value 属性设置为要显示的屏幕提示。将 Value 属性设置为 "" 可禁用屏幕提示。

ContextObject 图表中触发屏幕提示的对象。

显示 BeforeScreenTip 事件应用于 PivotTable 对象的情形。

在显示屏幕提示之前发生。

Private Sub Object_BeforeScreenTip(ByVal ScreenTipText As ByRef, ByVal SourceObject As Object)

Object 要触发该事件的 PivotTable 对象名称。

ScreenTip Text 将该对象的 Value 属性设置为要显示的屏幕提示。将 Value 属性设置为 "" 可禁用屏幕提示。

SourceObject 图表中触发屏幕提示的对象。

说明

使用该事件自定义图表或数据透视表列表中显示的屏幕提示。


BeforeUpdate 事件

在数据更改之后、记录集更新之前发生。在将数据提交数据库之前使用该事件验证数据的有效性。

Private Sub Object_BeforeUpdate(ByVal DSCEventInfo As DSCEventInfo)

Object A DataSourceControl 对象。

DSCEventInfo 包含事件有关信息的 DSCEventInfo 对象。

说明

使用 DSCEventInfo 对象的 DataPage 和 Section 属性判断更新的数据访问页、节和记录。

将 DSCEventInfo 对象的 ReturnValue 属性设置为 False 可取消更新。

示例

如果用户在 UnitsInStock 字段大于 100 时在 UnitsOnOrder 字段输入了大于 0 的值，本示例将取消记录集的更新。

Sub MSODSC_BeforeUpdate(DSCEventInfo)

   Dim txtUnitsOnOrder
   Dim txtUnitsInStock

   ' Set a variable to the text box that contains the value
   ' for the UnitsOnOrder field.
   Set txtUnitsOnOrder = DSCEventInfo.Section.HTMLContainer _
                         .Children("UnitsOnOrder")

   ' Set a variable to the text box that contains the value
   ' for the UnitsInStock field.
   Set txtUnitsInStock = DSCEventInfo.Section.HTMLContainer _
                         .Children("UnitsInStock")

   ' Check the value of the UnitsOnOrder Field.
   If CLng(txtUnitsOnOrder.Value) > 0 then

      ' Check the value of the UnitsInStock Field.
      If CLng(txtUnitsInStock.Value) > 100 then

         ' Display a message to the user.
         MsgBox "Don't reorder the part until fewer than 100 are in stock."

         ' Cancel the update.
         DSCEventInfo.ReturnValue = False

      End If
   End If

End Sub


BindingAdded 事件

在通过 Edit Query 命令添加新的或修改现有的 XmlDataBinding 对象时发生。

Private Sub Spreadsheet1_BindingAdded(BindingId)

BindingId XmlDataBinding 对象的唯一 ID。

说明

当绑定到数据检索服务连接 (.uxdc) 文件时，由电子表格组件自动生成 BindingId。当您使用 Excel 创建数据绑定电子表格，随后又将其保存为 XML 电子表格文件时，Microsoft Excel 也会自动生成 BindingId。在 XML 电子表格文件中，包含 BindingId 的 XML 片段与以下段落相似：

<x2:Binding x2:ID="Bind_id89929" x2:LoadMode="Normal" x2:Async="False">

您还可以通过将包含数据绑定详细信息的相关 XML 片段添加到 XML 电子表格文件中来手动指定 BindingId 值。

示例

以下 Microsoft Visual Basic Scripting Edition (VBScript) 中的示例将跟踪 XmlDataBinding 对象事件的数目，并显示所发生事件的 BindingId。

'global XmlDataBinding object BindingAdded event counter.
Dim gintCounterBindingAdded
gintCounterBindingAdded = 0

Sub Spreadsheet1_BindingAdded(BindingId)

    gintCounterBindingAdded = gintCounterBindingAdded + 1
    MsgBox ("BindingAdded and BindingID is: " & BindingId)

End Sub


BindingCompleted 事件

在通过 Refresh 或 Update 方法将数据成功地加载到映射中或从映射中导出时发生。

Private Sub Spreadsheet_BindingCompleted(BindingId, Action)

BindingId String 类型，必需。XmlDataBinding 对象的唯一 ID。您还可以通过将包含数据绑定详细信息的相关 XML 片段添加到 XML 电子表格文件中来手动指定 BindingId 值。

Action 引用已完成的绑定操作类型。可能的值为“Refresh”和“Update”。

说明

当绑定到数据检索服务连接 (.uxdc) 文件时，由电子表格组件自动生成唯一的 BindingId。当使用 Excel 创建数据绑定电子表格，随后又将其保存为 XML 电子表格文件时，Microsoft Excel 也会自动生成 BindingId。在 XML 电子表格文件中，包含 BindingId 的 XML 片段与以下段落相似：

<x2:Binding x2:ID="bind_id0" x2:Async="True"
 xmlns:x2="urn:schemas-microsoft-com:office:excel2"
 xmlns:dsp="http://schemas.microsoft.com/sharepoint/dsp"
 xmlns:udc="http://schemas.microsoft.com/data/udc"
 xmlns:soap-env="http://schemas.xmlsoap.org/soap/envelope/"
 xmlns:udcs="http://schemas.microsoft.com/data/udc/soap">
   <x2:MapID>map_id0</x2:MapID>
   <udc:DataSource MajorVersion="1" MinorVersion="0">
     <udc:Name/>
     <udc:Type Type="SOAP" MajorVersion="1" MinorVersion="0">
    <udc:SubType Type="DSP" MajorVersion="1" MinorVersion="0"/>
     </udc:Type>
    <udc:ConnectionInfo Purpose="Query">
      <udcs:SOAPAction>http://schemas.microsoft.com/sharepoint/dsp/queryRequest</udcs:SOAPAction>
      <udcs:Location href="Data_Retrieval_Services_URL">SQLDataAdapter</udcs:Location>
      <soap-env:Body>
       <dsp:queryRequest>
        <dsp:dsQuery select="/database[@id='Database_Name']/table[@id='Table_Name']" resultContent="dataOnly">
         <dsp:Query RowLimit="10" QueryType="DSPQ">
          <dsp:Fields>
                     <dsp:Field Name="Column_Name"/>
             </dsp:Fields>
         </dsp:Query>
        </dsp:dsQuery>
       </dsp:queryRequest>
      </soap-env:Body>
      <soap-env:Header>
       <dsp:versions>
        <dsp:version>1.0</dsp:version>
       </dsp:versions>
       <dsp:dataRoot>
        <dsp:root>SQL_Server</dsp:root>
       </dsp:dataRoot>
       <dsp:request service="DspSql" document="content" method="query"/>
        <dsp:authentication>
        <dsp:basic>
         <dsp:useExplicit>
          <dsp:userId>user_name</dsp:userId>
          <dsp:password>password</dsp:password>
         </dsp:useExplicit>
        </dsp:basic>
       </dsp:authentication>
      </soap-env:Header>
     </udc:ConnectionInfo>
    </udc:DataSource>
</x2:Binding>

当通过 Refresh 或 Update 方法将数据成功地加载到映射中或从映射中导出后，就会触发 BindingCompleted 事件。当首次提交其 Binding 元素的 LoadMode 属性设为“normal”的查询绑定页时也会触发此事件。

在异步绑定期间，某些与数据绑定相关的方法会生成运行时错误，这些错误提示用户由于异步绑定正在进行，所以无法完成所要求的操作。在异步绑定完成后，对这些方法的调用就会获得成功。有关详细信息，请参阅 XMLDataBinding 对象文档。

解决方案开发人员可以使用 BindingCompleted 和 BindingError 事件来获得绑定的完成时间。注意，使用 BindingCompleted 事件选择 XML 行不会在加载页时将该行发送到部件到部件的绑定客户。Window.Onload 事件可用来执行该操作。

以下 XML 示例片段表示了 LoadMode = "normal"：

<x2:Binding x2:ID="Bind_id89929" x2:LoadMode="normal" x2:Async="true" xmlns:x2="http://schemas.microsoft.com/office/excel/2003/xml">
    ...
</x2:Binding>

下例显示在网页首次加载后，用户刷新绑定数据（LoadMode 属性设为“normal”时的行为）时，如何从网页中运行的脚本中捕获 BindingCompleted 事件。必须将 BindingCompleted 事件的事件处理程序放置在 Spreadsheet 组件的 <OBJECT> 标记之前的 <SCRIPT> 标记中，才可正常运行。

<SCRIPT language=vbscript for="Spreadsheet1" event="BindingCompleted(bindingID, Action)">

    If Spreadsheet1.ActiveWorkbook.XmlDataBindings.Item(bindingID).CanQuery = True Then

        MsgBox "Binding Completed."

    End If

</SCRIPT>

<OBJECT id=Spreadsheet1 classid=CLSID:0002E559-0000-0000-C000-000000000046>
    ...
</OBJECT>


BindingDeleted 事件

在删除新 XmlDataBinding 对象时发生。

Private Sub Spreadsheet_BindingDeleted(BindingId)

BindingId String 类型，必需。XmlDataBinding 对象的唯一 ID。当绑定到数据检索服务连接 (.uxdc) 文件时，由电子表格组件自动生成唯一的 BindingId 。当您使用 Excel 创建数据绑定电子表格，随后又将其保存为 XML 电子表格文件时，Microsoft Excel 也会自动生成 BindingId。在 XML 电子表格文件中，包含 BindingId 的 XML 片段与以下段落相似：
<x2:Binding x2:ID="Bind_id89929" x2:LoadMode="normal" x2:Async="False">。
您还可以通过将包含数据绑定详细信息的相关 XML 片段添加到 XML 电子表格文件中来手动指定 BindingId 值。

示例

以下示例将跟踪 BindingDeleted 事件的数目，并显示所发生事件的 BindingId。

'global XmlDataBinding object BindingDeleted event counter.
Dim gintCounterBindingDeleted
gintCounterBindingDeleted = 0

Sub Spreadsheet1_BindingDeleted(BindingId)
    gintCounterBindingDeleted = gintCounterBindingDeleted + 1
    MsgBox "BindingDeleted and BindingId is: " & BindingId
End Sub


BindingError 事件

在由于调用 Refresh 或 Update 方法而从数据源处收到错误时发生。

Private Sub Spreadsheet1_BindingError(BindingId, Action, DialogText, FaultCode, FaultString, FaultDetail)

BindingId String 类型，必需。XmlDataBinding 对象的唯一 ID。当绑定到数据检索服务连接 (.uxdc) 文件时，由电子表格组件自动生成唯一的 BindingId 。当您使用 Excel 创建数据绑定电子表格，随后又将其保存为 XML 电子表格文件时，Microsoft Excel 也会自动生成 BindingId。在 XML 电子表格文件中，包含 BindingId 的 XML 片段与以下段落相似：
<x2:Binding x2:ID="Bind_id89929" x2:LoadMode="normal" x2:Async="False">。
您还可以通过将包含数据绑定详细信息的相关 XML 片段添加到 XML 电子表格文件中来手动指定 BindingId 值。

Action String 类型，必需。引用已完成的绑定操作类型。可能的值为“Refresh”和“Update”。

DialogText String 类型，必需。引用映射为所收到的错误代码的错误字符串。

FaultCode String 类型，必需。对应于错误消息中的 <FaultCode> 元素，例如，"Client.Dsp.Authentication"。

FaultString String 类型，必需。对应于错误消息中的 <FaultString> 元素，例如，"Can't logon user <username>"。

FaultDetail String 类型，必需。对应于错误消息中的 <Detail> 元素，例如，<dsp:queryResponse status="failure" xmlns:dsp="http://schemas.microsoft.com/sharepoint/dsp"> </dsp:queryResponse> <dsp:author>authorName</dsp:author>。这些字符串与数据检索服务连接 SOAP 错误消息的结构相匹配。

说明

对于 XML 电子表格文件和部件到部件绑定，DialogText 错误字符串将显示在错误消息中，而不显示在 FaultCode、FaultString 和 FaultDetail 参数中。对于任意 SOAP 绑定，所有 XML Web 服务错误消息都会返回 FaultCode 和 FaultString，但是大多数 XML Web 服务不会返回可选元素 FaultDetail，包括数据检索服务。

当 Refresh 或 Update 方法失败时，就会发生 BindingError 事件，并显示错误对话框。为了俘获脚本中的错误，解决方案开发人员使用 BindingError 事件。Refresh 或 Update 方法或 Internet Explorer 不会返回该错误。当在异步绑定过程中调用 Refresh 或 Update 时，这些方法将立即返回一个错误。

解决方案开发人员可以使用 BindingCompleted 和 BindingError 事件来获得绑定的完成时间。注意，使用 BindingCompleted 事件选择 XML 行不会在加载页时将该行发送到部件到部件的绑定客户。可使用 Window.Onload 事件可用来执行该操作。


BindingUpdated 事件

在现有 XmlDataBinding 对象的 BindingData 属性发生更改时发生。

Private Sub Spreadsheet1_BindingUpdated(BindingId)

BindingId String 类型，必需。XmlDataBinding 对象的唯一 ID。

BindingId String 类型，必需。XmlDataBinding 对象的唯一 ID。当绑定到数据检索服务连接 (.uxdc) 文件时，由电子表格组件自动生成唯一的 BindingId 。当您使用 Excel 创建数据绑定电子表格，随后又将其保存为 XML 电子表格文件时，Microsoft Excel 也会自动生成 BindingId。在 XML 电子表格文件中，包含 BindingId 的 XML 片段与以下段落相似：
<x2:Binding x2:ID="Bind_id89929" x2:LoadMode="normal" x2:Async="False">。
您还可以通过将包含数据绑定详细信息的相关 XML 片段添加到 XML 电子表格文件中来手动指定 BindingId 值。

说明

XmlDataBinding 对象包含 XML 形式的配置数据。可以使用 BindingData 属性返回或设置给定 XmlDataBinding 对象的配置数据。


ButtonClick 事件

当用户单击导航按钮时发生。

Private Sub RecordNavigationControl_ButtonClick(NavButton As NavButtonEnum)

NavButton 指定单击后触发 ButtonClick 事件的按钮。可以为下列 NavButtonEnum 常量之一。

navbtnMoveFirst
navbtnMovePrev
navbtnMoveNext
navbtnMoveLast
navbtnNew
navbtnDelete
navbtnSave
navbtnUndo
navbtnSortAscending
navbtnSortdescending
navbtnApplyFilter
navbtnToggleFilter
navbtnHelp

说明

有关在 VBScript 中使用事件的详细信息，请参阅在 VBScript 中声明和使用事件过程。


Change 事件

在更改一个或多个单元格中的数据时发生。编辑和复制粘贴操作均触发该事件发生。

Private Sub Range_Change( )

说明

本事件在 EndEdit 事件后发生，此时数据已经更改，并且不能取消。

该事件需要 WithEvents 关键字，因此不能用于 VBScript 或 JScript。

示例

本示例在更改 Spreadsheet1 中 Sheet1 的 A1 单元格中的数据时更新 Visual Basic 窗体上的标签控件。

Dim WithEvents rngRange1 As Range

Private Sub Form_Load()

    ' Set a variable to the range for which you want to capture
    ' the Change event.
    Set rngRange1 = Spreadsheet1.Worksheets("Sheet1").Range("A1")

End Sub

Private Sub rngRange1_Change()
    ' Change the caption of Label1 to the current value
    ' of cell A1.
    Label1.Caption = rngRange1.Value
End Sub


Click 事件

在用户单击指定控件时发生。

Private Sub object_Click( )

object ChartSpace、PivotTable 或 Spreadsheet 对象。

说明

有关在 VBScript 中使用事件的详细信息，请参阅在 VBScript 中声明和使用事件过程。


CommandBeforeExecute 事件

在执行命令之前发生。如果要在执行命令之前加以指定限制，请使用该事件。

Private Sub object_CommandBeforeExecute (ByVal Command As Variant, ByVal Cancel As ByRef)

object ChartSpace、PivotTable 或 Spreadsheet 对象。

Command 必需。执行的命令。

Cancel 必需。将该对象的 Value 属性设置为 True 可取消命令。

说明

OCCommandId、ChartCommandIdEnum、PivotCommandId 和 SpreadsheetCommandId 常量包含了每个 Microsoft Office Web Components 支持的命令列表。

示例

本示例在调用导出命令时刷新数据透视表列表，以使最新数据导出到 Microsoft Excel。

Sub PivotTable1_CommandBeforeExecute(Command, Cancel)

   Dim ptConstants

   Set ptConstants = PivotTable1.Constants

   ' Check to see if the Export command
   ' has been invoked.
   If Command = ptConstants.plCommandExport Then

       ' Refresh the PivotTable list.
       PivotTable1.Refresh

   End If

End Sub


CommandChecked 事件

在指定 Microsoft Office Web Component 确定命令是否选中时发生。

Private Sub object_CommandChecked (ByVal Command As Variant, ByVal Checked As ByRef)

object ChartSpace、PivotTable 或 Spreadsheet 对象。

Command 必需。执行的命令。

Checked 必需。将该对象的 Value 属性设置为 True 可取消选中命令。

说明

OCCommandId、ChartCommandIdEnum、PivotCommandId 和 SpreadsheetCommandId 常量包含了每个 Web 组件支持的命令列表。


CommandEnabled 事件

在启用指定 Microsoft Office Web Component 命令时发生。

Private Sub object_CommandEnabled (ByVal Command As Variant, ByVal Enabled As ByRef)

object ChartSpace、PivotTable 或 Spreadsheet 对象。

Command 必需。执行的命令。

Enabled 必需。将该对象的 Value 属性设置为 True 可禁用命令。

说明

OCCommandId、ChartCommandIdEnum、PivotCommandId 和 SpreadsheetCommandId 常量包含了每个 Web 组件支持的命令列表。


CommandExecute 事件

在执行命令之后发生。如果要在执行特定命令之后执行一系列命令，请使用该事件。

Private Sub object_CommandExecute (ByVal Command As Variant, ByVal Succeeded As Boolean)

object ChartSpace、PivotTable 或 Spreadsheet 对象。

Command 执行的命令。

Succeeded 如果命令成功执行，则返回 True。

说明

OCCommandId、ChartCommandIdEnum、PivotCommandId 和 SpreadsheetCommandId 常量包含了每个 Office Web 组件支持的命令列表。

示例

本示例在每次刷新数据透视表列表时将当前日期和时间写入一个 HTML 文本框。

Sub PivotTable1_CommandExecute(Command, Succeeded)

   Dim ptConstants

   Set ptConstants = PivotTable1.Constants

   ' Check to see if the PivotTable list has been refreshed.
   If Command = ptConstants.plCommandRefresh Then

      ' Write the current data and time to the text box.
      TextBox.Value = "PivotTable Last Refeshed on " & _
                      Date & " at " & Time

   End If

End Sub


CommandTipText 事件

在指定 Microsoft Office Web Component 查询命令的屏幕提示文本时发生。

Private Sub object_CommandTipText (ByVal Command As Variant, ByVal Caption As ByRef)

object ChartSpace、PivotTable 或 Spreadsheet 对象。

Command 执行的命令。

注意 该对象的 Value 属性包含命令的屏幕提示文本。

说明

OCCommandId、ChartCommandIdEnum、PivotCommandId 和 SpreadsheetCommandId 常量包含了每个 Web 组件支持的命令列表。


Current 事件

在记录成为当前记录时发生。

Private Sub Object_Current(DSCEventInfo As DSCEVENTINFO)

Object 应用该事件的 DataSourceControl 对象名称。

DSCEventInfo 包含事件相关信息的 DSCEventInfo 对象。


DataChange 事件

在更改特定属性或执行特定方法时发生。请参阅 PivotDataReasonEnum 常量获取可触发此事件的属性和方法的有关详细信息。

PivotDataReasonEnum 可以为下列 PivotDataReasonEnum 常量之一。
plDataReasonAdhocFieldAdded
plDataReasonAdhocFieldDeleted
plDataReasonAdhocMemberChanged
plDataReasonAllIncludeExcludeChange
plDataReasonAllowDetailsChange
plDataReasonAllowMultiFilterChange
plDataReasonAlwaysIncludeInCubeChange
plDataReasonCommandTextChange
plDataReasonConnectionStringChange
plDataReasonDataMemberChange
plDataReasonDataSourceChange
plDataReasonDisplayCalculatedMembersChange
plDataReasonDisplayCellColorChange
plDataReasonDisplayEmptyMembersChange
plDataReasonExcludedMembersChange
plDataReasonExpressionChange
plDataReasonFieldNameChange
plDataReasonFieldSetDeleted
plDataReasonFieldSetNameChange
plDataReasonFilterContextChange
plDataReasonFilterCrossJoinsChange
plDataReasonFilterFunctionChange
plDataReasonFilterFunctionValueChange
plDataReasonFilterOnChange
plDataReasonFilterOnScopeChange
plDataReasonGroupEndChange
plDataReasonGroupIntervalChange
plDataReasonGroupOnChange
plDataReasonGroupStartChange
plDataReasonIncludedMembersChange
plDataReasonInsertFieldSet
plDataReasonInsertTotal
plDataReasonIsFilteredChange
plDataReasonIsIncludedChange
plDataReasonMemberPropertyDisplayInChange
plDataReasonMemberPropertyIsIncludedChange
plDataReasonOrderedMembersChange
plDataReasonRecordChanged
plDataReasonRefreshDataSource
plDataReasonRemoveFieldSet
plDataReasonRemoveTotal
plDataReasonSortDirectionChange
plDataReasonSortOnChange
plDataReasonSortOnScopeChange
plDataReasonSubtotalsChange
plDataReasonTotalAllMembersChange
plDataReasonTotalDeleted
plDataReasonTotalExpressionChange
plDataReasonTotalFunctionChange
plDataReasonTotalNameChange
plDataReasonTotalSolveOrderChange
plDataReasonUnknown
plDataReasonUser

Private Sub Object_DataChange(ByVal Reason As PivotDataReasonEnum)

Object 要触发该事件的 PivotTable 对象名称。

Reason 使用 PivotDataReasonEnum 常量的值确定此事件的触发原因。

PivotDataReasonEnum 可以为下列 PivotDataReasonEnum 常量之一。
plDataReasonAdhocFieldAdded
plDataReasonAdhocFieldDeleted
plDataReasonAdhocMemberChanged
plDataReasonAllIncludeExcludeChange
plDataReasonAllowDetailsChange
plDataReasonAllowMultiFilterChange
plDataReasonAlwaysIncludeInCubeChange
plDataReasonCommandTextChange
plDataReasonConnectionStringChange
plDataReasonDataMemberChange
plDataReasonDataSourceChange
plDataReasonDisplayCalculatedMembersChange
plDataReasonDisplayCellColorChange
plDataReasonDisplayEmptyMembersChange
plDataReasonExcludedMembersChange
plDataReasonExpressionChange
plDataReasonFieldNameChange
plDataReasonFieldSetDeleted
plDataReasonFieldSetNameChange
plDataReasonFilterContextChange
plDataReasonFilterCrossJoinsChange
plDataReasonFilterFunctionChange
plDataReasonFilterFunctionValueChange
plDataReasonFilterOnChange
plDataReasonFilterOnScopeChange
plDataReasonGroupEndChange
plDataReasonGroupIntervalChange
plDataReasonGroupOnChange
plDataReasonGroupStartChange
plDataReasonIncludedMembersChange
plDataReasonInsertFieldSet
plDataReasonInsertTotal
plDataReasonIsFilteredChange
plDataReasonIsIncludedChange
plDataReasonMemberPropertyDisplayInChange
plDataReasonMemberPropertyIsIncludedChange
plDataReasonOrderedMembersChange
plDataReasonRecordChanged
plDataReasonRefreshDataSource
plDataReasonRemoveFieldSet
plDataReasonRemoveTotal
plDataReasonSortDirectionChange
plDataReasonSortOnChange
plDataReasonSortOnScopeChange
plDataReasonSubtotalsChange
plDataReasonTotalAllMembersChange
plDataReasonTotalDeleted
plDataReasonTotalExpressionChange
plDataReasonTotalFunctionChange
plDataReasonTotalNameChange
plDataReasonTotalSolverOrderChange
plDataReasonUnknown
plDataReasonUser


DataError 事件

当发生数据错误时发生。

Private Sub Object_DataError(DSCEventInfo As DSCEVENTINFO)

Object 应用该事件的 DataSourceControl 对象名称。

DSCEventInfo 包含事件相关信息的 DSCEventInfo 对象。


DataPageComplete 事件

在指定数据访问页完成加载后发生。

Private Sub Object_DataPageComplete(DSCEventInfo As DSCEVENTINFO)

Object 应用该事件的 DataSourceControl 对象名称。

DSCEventInfo 包含事件相关信息的 DSCEventInfo 对象。


DataSetChange 事件

当图表工作区为数据绑定并且数据集发生变化（例如进行筛选操作）时发生。当数据源具备初始数据时也发生该事件。

Private Sub Object_DataSetChange( )

Object 应用该事件的 ChartSpace 对象名称。

说明

有关在 VBScript 中使用事件的详细信息，请参阅在 VBScript 中声明和使用事件过程。


DblClick 事件

在用户双击指定控件时发生。

Private Sub object_DblClick( )

object ChartSpace、PivotTable 或 Spreadsheet 对象。


Dirty 事件

在用户更改了数据访问页上的内容时发生。

Private Sub Object_Dirty(ByVal DSCEventInfo As DSCEventInfo)

Object DataSourceControl 对象。

DSCEventInfo 包含事件有关信息的 DSCEventInfo 对象。

说明

将 DSCEventInfo 对象的 ReturnValue 属性设置为 False 可还原为原值。

使用 DSCEventInfo 对象的 DataPage 和 Section 属性判断更新的数据访问页、节和记录。

该事件在 BeforeUpdate 事件之前触发。


EndEdit 事件

当用户从编辑模式切换到指定 Spreadsheet 控件或数据透视表列表时发生。使用该事件可以对工作表或数据透视表列表明细区域中的数据项进行有效性验证。

Private Sub Object_EndEdit(ByVal Accept As Boolean, ByVal FinalValue As ByRef, ByVal Cancel As ByRef, ByVal ErrorDescription As ByRef)

Object PivotTable 或 Spreadsheet 对象。

Accept 指定特定控件是否接受编辑。如果参数为 False，控件将脱离编辑模式，因为用户取消了编辑。如果参数为 True，则可以取消编辑。

FinalValue 该参数的 Value 属性返回要输入到工作表或数据透视表列表中的数值。

Cancel 将该参数的 Value 属性设置为 True 可取消编辑并使用户处于编辑模式。

ErrorDescription 将该参数的 Value 属性设置为要向用户显示的文本。默认文本为 "The new value was not accepted."。


Focus 事件

在数据访问页中的节获得焦点时发生。

Private Sub Object_Focus(ByVal DSCEventInfo As DSCEventInfo)

Object DataSourceControl 对象。

DSCEventInfo 包含事件有关信息的 DSCEventInfo 对象。

说明

使用 DSCEventInfo 对象的 DataPage 和 Section 属性判断更新的数据访问页、节和记录。


Initialize 事件

在 Spreadsheet 组件正在加载、加载完成之前发生。

Private Sub Object_Initialize()

Object 要触发该事件的 Spreadsheet 对象名称。

说明

使用该事件初始化电子表格的设置。

示例

本示例使用 Initialize 事件利用用户计算机上的文件设置电子表格数据。

Sub Spreadsheet1_Initialize()

   ' Load a CSV file into the spreadsheet.
   Spreadsheet1.CSVURL = "Data.csv"

End Sub


KeyDown 事件

在用户按下键盘上的键之后发生。如果用户将键按住，该事件将按照用户计算机上设置的键击重复间隔重复发生。

Private Sub Object_KeyDown(ByVal KeyCode As Long, ByVal Shift As Long)

Object 要触发该事件的 ChartSpace、PivotTable 或 Spreadsheet 对象名称。

KeyCode Long 类型，表示按下或释放的键代码。

Shift Shift、Ctrl 和 Alt 的状态。如果按下 Shift 则返回 1，按下 Ctrl 则返回 2，按下 Alt 则返回 4。如果 Shift、Ctrl 和 Alt 均没有按下，则返回 0。

说明

有关在 VBScript 中使用事件的信息，请参阅在 VBScript 中声明和使用事件过程。

键击相关事件的顺序为：

  1. BeforeKeyDown
  2. KeyDown
  3. BeforeKeyPress
  4. KeyPress
  5. BeforeKeyUp
  6. KeyUp


KeyPress 事件

在用户按下并释放键盘上的键后发生。

Private Sub Object_KeyPress(ByVal KeyAscii As Long)

Object 要触发该事件的 ChartSpace、PivotTable 或 Spreadsheet 对象名称。

KeyAscii Long 类型，表示按下或释放的键代码。

说明

如果取消 BeforeKeyDown 事件则该事件不会发生。

有关在 VBScript 中使用事件的信息，请参阅在 VBScript 中声明和使用事件过程。

键击相关事件的顺序为：

  1. BeforeKeyDown
  2. KeyDown
  3. BeforeKeyPress
  4. KeyPress
  5. BeforeKeyUp
  6. KeyUp


KeyUp 事件

在用户释放键盘上的键之后发生。

Private Sub Object_KeyUp(ByVal KeyCode As Long, ByVal Shift As Long)

Object 要触发该事件的 ChartSpace、PivotTable 或 Spreadsheet 对象名称。

KeyCode Long 类型，表示按下或释放的键代码。

Shift Shift、Ctrl 和 Alt 的状态。如果按下 Shift 则返回 1，按下 Ctrl 则返回 2，按下 Alt 则返回 4。如果 Shift、Ctrl 和 Alt 均没有按下，则返回 0。

说明

有关在 VBScript 中使用事件的信息，请参阅在 VBScript 中声明和使用事件过程。

键击相关事件的顺序为：

  1. BeforeKeyDown
  2. KeyDown
  3. BeforeKeyPress
  4. KeyPress
  5. BeforeKeyUp
  6. KeyUp


LoadCompleted 事件

在 Spreadsheet 组件完成加载之后发生。

Private Sub Object_LoadCompleted()

Object 要触发该事件的 Spreadsheet 对象名称。


MouseDown 事件

当用户在指针位于电子表格、数据透视表列表或图表工作区上按下鼠标键时发生。

Private Sub Object_MouseDown(ByVal Button As Long, ByVal Shift As Long, ByVal x As Long, ByVal y As Long)

Object 要触发该事件的 ChartSpace、PivotTable 或 Spreadsheet 对象名称。

Button 释放的鼠标键。如果释放的是鼠标左键，则返回 1，如果释放的是鼠标右键，则返回 2，如果释放的是鼠标中键，则返回 4。

Shift 发生事件时 Shift、Ctrl 和 Alt 的状态。如果按下 Shift 则返回 1，按下 Ctrl 则返回 2，按下 Alt 则返回 4。如果 Shift、Ctrl 和 Alt 均没有按下，则返回 0。

x 鼠标指针的 X 坐标。

y 鼠标指针的 Y 坐标。

说明

有关在 VBScript 中使用事件的信息，请参阅在 VBScript 中声明和使用事件过程。


MouseMove 事件

当用户在数据透视表列表或图表工作区上移动鼠标指针时发生。

Private Sub Object_MouseMove(ByVal Button As Long, ByVal Shift As Long, ByVal x As Long, ByVal y As Long)

Object 要触发该事件的 ChartSpace 或 PivotTable 对象名称。

Button 释放的鼠标键。如果释放的是鼠标左键，则返回 1，如果释放的是鼠标右键，则返回 2，如果释放的是鼠标中键，则返回 4。

Shift 发生事件时 Shift、Ctrl 和 Alt 的状态。如果按下 Shift 则返回 1，按下 Ctrl 则返回 2，按下 Alt 则返回 4。如果 Shift、Ctrl 和 Alt 均没有按下，则返回 0。

x 鼠标指针的 X 坐标。

y 鼠标指针的 Y 坐标。

说明

有关在 VBScript 中使用事件的信息，请参阅在 VBScript 中声明和使用事件过程。


MouseOut 事件

当用户将鼠标指针移出电子表格上的单元格时发生。

Private Sub Object_MouseOut(ByVal Button As Long, ByVal Shift As Long, ByVal Target As Range)

Object 要触发该事件的 Spreadsheet 对象名称。

Button 释放的鼠标键。如果释放的是鼠标左键，则返回 1，如果释放的是鼠标右键，则返回 2，如果释放的是鼠标中键，则返回 4。

Shift 发生事件时 Shift、Ctrl 和 Alt 的状态。如果按下 Shift 则返回 1，按下 Ctrl 则返回 2，按下 Alt 则返回 4。如果 Shift、Ctrl 和 Alt 均没有按下，则返回 0。

Target 表示鼠标指针移出的单元格的 Range 对象。

说明

有关在 VBScript 中使用事件的信息，请参阅在 VBScript 中声明和使用事件过程。


MouseOver 事件

当用户将鼠标指针停留在指定电子表格上的单元格时发生。

Private Sub Object_MouseOut(ByVal Button As Long, ByVal Shift As Long, ByVal Target As Range)

Object 要触发该事件的 Spreadsheet 对象名称。

Button 释放的鼠标键。如果释放的是鼠标左键，则返回 1，如果释放的是鼠标右键，则返回 2，如果释放的是鼠标中键，则返回 4。

Shift 发生事件时 Shift、Ctrl 和 Alt 的状态。如果按下 Shift 则返回 1，按下 Ctrl 则返回 2，按下 Alt 则返回 4。如果 Shift、Ctrl 和 Alt 均没有按下，则返回 0。

Target 表示鼠标指针移过的单元格的 Range 对象。

说明

有关在 VBScript 中使用事件的信息，请参阅在 VBScript 中声明和使用事件过程。


MouseUp 事件

当用户在指针位于电子表格、数据透视表列表或图表工作区上释放鼠标键时发生。

Private Sub Object_MouseUp(ByVal Button As Long, ByVal Shift As Long, ByVal x As Long, ByVal y As Long)

Object 要触发该事件的 ChartSpace、PivotTable 或 Spreadsheet 对象名称。

Button 释放的鼠标键。如果释放的是鼠标主键，则返回 1，如果释放的是鼠标次键，则返回 2，如果释放的是鼠标中键，则返回 4。

Shift 发生事件时 Shift、Ctrl 和 Alt 的状态。如果按下 Shift 则返回 1，按下 Ctrl 则返回 2，按下 Alt 则返回 4。如果 Shift、Ctrl 和 Alt 均没有按下，则返回 0。

x 鼠标指针的 X 坐标。

y 鼠标指针的 Y 坐标。

说明

有关在 VBScript 中使用事件的信息，请参阅在 VBScript 中声明和使用事件过程。


MouseWheel 事件

当用户旋转具有滑轮的鼠标设备上的滑轮时发生。

Private Sub Object_MouseWheel (ByVal Page As Boolean, ByVal Count As Long)

Object 要触发该事件的 ChartSpace、PivotTable 或 Spreadsheet 对象名称。

Page 如果更改了页面，则返回 True。

Count 滚动的行数。


ParametersOutReady 事件

在一组参数从所连接的实现 IParametersOutProvider 接口的 Web 部件传递到实现 IParametersOutConsumer 接口的电子表格 Web 部件时，就会发生该 ParametersOutReady 事件。

expression.ParametersOutReady(InterfaceName As String, ParamValues As Variant)

expression 必需。该表达式返回一个 Spreadsheet 对象。

InterfaceName 接收事件的 IParametersOutConsumer 接口的名称（解决方案规范文件中定义的名称：InterfaceConnections/ParametersOutConsumer@Name）。

ParamValues 字符串数组，其中包含由实现 IParametersOutProvider 接口的 Web 部件提供的参数。

说明

此事件仅适用于 SharePoint 网站的 Web 部件页上的电子表格 Web 部件。有关电子表格 Web 部件的详细信息，请搜索 Excel 帮助以及 Microsoft Developer Network (MSDN) 网站。

当实现 IParametersOutProvider 接口的单个 Web 部件调用 FireParametersOut 方法时，就会触发 ParametersOutReady 事件。ParamValues 参数是一个字符串数组，其中每个字符串都包含一个参数的值。ParamValues 参数必须与 IParametersOutProvider 接口声明中列出的项具有相同的长度和顺序。当此事件发生时，您可以查询 Web 部件数据源来获取由实现 IParametersOutProvider 接口的 Web 部件发送到数据源的更新数据。


PivotTableChange 事件

当添加或删除数据透视表列表字段、字段集或总计时发生。

Private Sub PivotTable_PivotTableChange(Reason As PivotTableReasonEnum)

Reason 指定数据透视表列表的更改方式。可为下列 PivotTableReasonEnum 常量之一。

plPivotTableReasonTotalAdded
plPivotTableReasonFieldSetAdded
plPivotTableReasonFieldAdded

说明

有关在 VBScript 中使用事件的详细信息，请参阅在 VBScript 中声明和使用事件过程。


Query 事件

在需要数据透视表列表查询时发生。查询可能不立即进行，而推迟到显示新数据时执行。

Private Sub PivotTable_Query( )


RecordExit 事件

当用户导航到其他记录、刷新数据访问页或关闭数据访问页时发生。

Private Sub Object_RecordExit(DSCEventInfo As DSCEventInfo)

Object 要触发该事件的 DataSourceControl 对象名称。

DSCEventInfo 包含事件有关信息的 DSCEventInfo 对象。

说明

该事件在 BeforeUpdate 事件之后、记录更改之前发生。

在联合数据访问页中，在同一父记录的子记录中移动不触发该事件。

将 DSCEventInfo 对象的 ReturnValue 属性设置为 False 可取消该事件，并阻止记录更改。

可以使用 DSCEventInfo 对象的 DataPage 属性获取有关数据访问页的详细信息。


RecordsetSaveProgress 事件

在调用 ExportXML 方法时重复发生。在导出记录集时使用该事件向用户提供反馈。

Private Sub Object_RecordsetSaveProgress(ByVal DSCEventInfo As DSCEventInfo)

Object DataSourceControl 对象。

DSCEventInfo 包含事件有关信息的 DSCEventInfo 对象。

说明

使用 PercentComplete 属性确定导出操作的当前进度。

不能使用该事件更新当前 HTML 文档的内容。

示例

本示例在保存 DataSourceControl 中的记录集时使用 RecordsetSaveProgess 事件更新 Microsoft Internet Explorer 的状态栏。

Sub MSODSC_RecordsetSaveProgress(DSCEventInfo)

    ' Update the status bar with the current
    ' completion percentage.
    Window.Status = DSCEventInfo.PercentComplete

    ' Check to see if the save has been completed.
    If DSCEventInfo.PercentComplete = 100 then

        ' Clear the status bar when the save is complete.
        Window.Status = ""
    End If

End Sub


RowReady 事件

在将 ListObject 对象加载到电子表格组件中，选中 ListObject 对象中的单行，调用 XmlDataBinding 对象的 Refresh 方法时，不管该方法成功与否，都会调用该组件的 RowReady 事件过程。

Private Sub Spreadsheet1_RowReady(XDTName As String, RowDataArray As Variant, SelectionStatus As String)

XDTName 包含 ListObject 对象的 Name 属性值。

RowDataArray 当 SelectionStatus 返回“标准”时，此参数包含一个数组，其中的值为所选行中每一单元格的值。当 SelectionStatus 返回“新”或“无”时，该数组为空。

SelectionStatus 包含下表中列出的一个值：

值 | 说明
新 | 表示选中了新行或插入行。RowDataArray 中的值数组为空。
无 | 表示没有行被选中。RowDataArray 中的值数组为空。
标准 | 表示选中了现有行。RowDataArray 中的值数组包含所选行中的每一单元格的值。

说明

如果由于将新 XML 电子表格文件或 XML 数据加载到控件中而触发了此事件，则 SelectionStatus 参数的值将为“无”。只要将活动单元格移到列表中的其他行，电子表格组件就会触发 RowReady 事件。如果用户单击所选行内的某个位置，或单击列表外的某个位置，然后选中列表中的多行，则不会触发 RowReady 事件。

示例

下例使用 RowReady 事件过程来处理事件过程参数所包含的信息。

Sub Spreadsheet1_RowReady(XDTName, RowDataArray, SelectionStatus)
Dim strCellData
Dim intItem

    Select Case SelectionStatus
        Case "None"
        Case "New"
        Case "Standard"
                For intItem = 0 to UBound(RowDataArray) - 1
                        strCellData = RowDataArray(intItem)
      ' Work with data in cells of selected row here.
                Next
  Case Else
    End Select
End Sub


SelectionChange 事件

当用户进行一项新的选择时发生。用户不能取消该事件。

Private Sub Object_SelectionChange( )

Object 应用该事件的 ChartSpace、PivotTable 或 Spreadsheet 对象名称。

说明

有关在 VBScript 中使用事件的详细信息，请参阅在 VBScript 中声明和使用事件过程。

可以使用 Selection 属性判断当前选定内容的对象类型，如下面示例所示：

Private Sub PivotTable_SelectionChange()
    If TypeName(PivotTable.Selection) = "PivotTotal" Then
        'Handle selection of a total here
    End If
End Sub


SelectionChanging 事件

当用户在选择区域时移动鼠标指针时发生。当用户使用键盘选择时不发生该事件。用户不能取消该事件。

Private Sub Object _SelectionChanging(ByVal Range As Range)

Object 要触发该事件的 Spreadsheet 对象名称。

Range 表示用户选定的单元格区域的 Range 对象。

说明

有关在 VBScript 中使用事件的信息，请参阅在 VBScript 中声明和使用事件过程。


SheetActivate 事件

当激活工作表时发生。

Private Sub Object_SheetActivate(ByVal Sh As Worksheet)

Object 要捕获该事件的 Spreadsheet 对象名称。

Sh Worksheet 类型，必需。激活的工作表。

说明

当用户更改工作表时，SheetDeactivate 事件将在 SheetActivate 事件之前调用。

示例

本示例在每次激活 Spreadsheet1 中的工作表时显示激活工作表的名称。

Sub Spreadsheet1_SheetActivate(Sh)

   MsgBox Sh.Name

End Sub


SheetCalculate 事件

在计算工作表后发生。

Private Sub Object_SheetCalculate(ByVal Sh As Worksheet)

Object 要捕捉该事件的 Spreadsheet 对象名称。

Sh 表示计算工作表的 Worksheet 对象。

示例

本示例使用 SheetCalculate 事件监视 Spreadsheet1 中 Sheet1 上单元格 A5 的数值状态。

Sub Spreadsheet1_SheetCalculate(Sh)

    Dim rngRangeToWatch

    ' Set a variable to the cell that you want to watch.
    Set rngRangeToWatch = Spreadsheet1.Worksheets("Sheet1").Range("A5")

    ' If the calculated sheet is Sheet1...
    If Sh.Name = "Sheet1" Then

        ' ...and the value of the cell to watch is less thant 10...
        If rngRangeToWatch.Value < 10 Then

            ' ... alert the user of the status.
            MsgBox "Inventory is less than 10. Reorder the part."
        End If

    End If

End Sub


SheetChange 事件

当用户或外部链接更改了任何工作表中的单元格时发生。

Private Sub Object_SheetChange(ByVal Sh As Object, ByVal Target As Range)

Object 要捕捉该事件的 Spreadsheet 对象名称。

Sh 表示工作表的 Worksheet 对象。

Target 表示更改区域的 Range 对象。

示例

本示例演示如何使用 SheetChange 事件对 Spreadsheet1 中 Sheet1 的单元格 A1:A10 进行有条件的格式设置。

Sub Spreadsheet1_SheetChange(Sh, Target)
    Dim rngIntersect
    Dim rngCondFormat

    ' Set a variable to the range to be conditionally formatted. In this
    ' case, the range is cells A1:A10 on Sheet1.
    Set rngCondFormat = Spreadsheet1.Worksheets("Sheet1").Range("A1:A10")

    ' Check to see if the change was made on Sheet1.
    If Sh.Name = "Sheet1" Then

        ' Set a variable to the intersection of the changed cell
        ' and the conditional formatting range.
        Set rngIntersect = Spreadsheet1.RectIntersect(Target, rngCondFormat)

        ' Check to see if the changed cell intersects with the
        ' conditional formatting range.
        If Not rngIntersect Is Nothing Then

            ' Format the target cell based on its value.
            Select Case Target.Value

                Case Is >= 25
                    Target.Font.Color = "Green"
                    Target.Font.Bold = True
                    Target.Font.Italic = False
                Case Is >= 10
                    Target.Font.Color = "Blue"
                    Target.Font.Bold = False
                    Target.Font.Italic = True
                Case Is < 10
                    Target.Font.Color = "Red"
                    Target.Font.Bold = True
                    Target.Font.Italic = False
            End Select
        End If
    End If
End Sub


SheetDeactivate 事件

当去活工作表时发生。

Private Sub Object _SheetDeactivate(ByVal Sh As Worksheet)

Object 要捕捉该事件的 Spreadsheet 对象名称。

Sh Worksheet 类型，必需。去活的工作表。

说明

用户在更换工作表时，该事件在 SheetActivate 事件之前调用。

示例

本示例在每次去活 Spreadsheet1 中的工作表时显示去活工作表的名称。

Sub Spreadsheet1_SheetDeactivate(Sh)

   MsgBox Sh.Name & " was just deactivated."

End Sub


SheetFollowHyperlink 事件

在单击超链接时发生。

Private Sub object_SheetFollowHyperlink(ByVal Sh As Worksheet, Target As Hyperlink)

Object 要触发该事件的 Spreadsheet 对象名称。

Sh 必需。已经去活的工作表。

Target 必需。单击的超链接。

示例

本示例保存在 Spreadsheet1 中单击超链接的记录。在每次单击超链接时将包含超链接的工作表名称和目标地址写入 Sheet3。

Sub Spreadsheet1_SheetFollowHyperlink(Sh, Target)

    Dim ssConstants
    Dim rngNewItem
    Dim shtListSheet

    Set ssConstants = Spreadsheet1.Constants

    ' Set a variable to Sheet3.
    Set shtListSheet = Spreadsheet1.ActiveWorkbook.Worksheets("Sheet3")

    ' Set a variable to the first available cell in column A of Sheet3.
    Set rngNewItem = shtListSheet.Range("A262144").End(ssConstants.xlUp).Offset(1, 0)

    ' Write the name of the sheet to Column A of Sheet3.
    rngNewItem.Value = Sh.Name

    ' Write the target address of the hyperlink to Column B of Sheet3.
    rngNewItem.Offset(0, 1).Value = Target.Address

End Sub


StartEdit 事件

显示 StartEdit 事件应用于 Spreadsheet 对象的情形。

当用户在指针位于单元格中进入编辑模式时发生。

Private Sub Object_StartEdit (ByVal Selection As Object, ByVal InitialValue As ByRef, ByVal Cancel As ByRef, ByVal ErrorDescription As ByRef)

Object 要触发该事件的 Spreadsheet 对象名称。

Selection 当前选定的单元格区域。

InitialValue 使用该对象的 Value 属性返回或设置用于编辑单元格的初始值。

Cancel 将该对象的 Value 属性设置为 True 禁止用户进入编辑模式。

ErrorDescription 将该对象的 Value 属性设置为要向用户显示的消息。

显示 StartEdit 事件应用于 PivotTable 对象的情形。

当用户在明细单元格中进入编辑模式时发生。

Private Sub Object _StartEdit (ByVal Selection As Object, ByVal ActiveObject As Object, ByVal InitialValue As ByRef, ByVal ArrowMode As ByRef, ByVal CaretPosition As ByRef, ByVal Cancel As ByRef, ByVal ErrorDescription As ByRef)

Object 要触发该事件的 PivotTable 对象名称。

Selection 当前选定的单元格区域。

ActiveObject 活动对象。

InitialValue 使用该对象的 Value 属性返回或设置用于编辑单元格的初始值。

ArrowMode 指定向左键和向右键在编辑模式下的功能。将此对象的 Value 属性设置为 PivotArrowModeEnum 常量。

PivotArrowModeEnum 可以为下列 PivotArrowModeEnum 常量之一。
plArrowModeAccept 接受编辑并移向下一个单元格。
plArrowModeEdit 在单元格中将插入点左移或右移一个位置。

CaretPosition 指定单元格中插入点的位置，将该对象的 Value 属性设置为 PivotCaretPositionEnum 常量。

PivotCaretPositionEnum 可以为下列 PivotCaretPositionEnum 常量之一。
plCaretPositionAtEnd
plCaretPositionAtMouse

Cancel 将该对象的 Value 属性设置为 True 可禁止用户进入编辑模式。

ErrorDescription 将该对象的 Value 属性设置为要向用户显示的消息。

说明

有关在 VBScript 中使用事件的信息，请参阅在 VBScript 中声明和使用事件过程。


Undo 事件

当用户单击导航控件上的“撤消”按钮或取消 Dirty 事件时发生。该事件在数据还原为原始值之前发生。使用该事件设置允许用户撤消更改的条件。

Private Sub Object_Undo(ByVal DSCEventInfo As DSCEventInfo)

Object DataSourceControl 对象。

DSCEventInfo 包含事件有关信息的 DSCEventInfo 对象。

说明

将 DSCEventInfo 对象的 ReturnValue 属性设置为 False 可取消操作。

使用 DSCEventInfo 对象的 DataPage 和 Section 属性获取有关页的详细信息。


ViewChange 事件

显示 ViewChange 事件应用于 ChartSpace 对象的情形。

在重绘图表时发生。

Private Sub Object _ViewChange( )

Object 要触发该事件的 ChartSpace 对象名称。

显示 ViewChange 事件应用于 PivotTable 对象的情形。

在重绘数据透视表列表时发生。

Private Sub Object _ViewChange(ByVal Reason As PivotViewReasonEnum)

Object 要触发该事件的 PivotTable 对象名称。

Reason 表示视图如何更改的 PivotViewReasonEnum 常量

显示 ViewChange 事件应用于 Spreadsheet 对象的情形。

在重绘电子表格时发生。

Private Sub Object _ViewChange(ByVal Target As Range)

Object 要触发该事件的 Spreadsheet 对象名称。

Target 当前可见区域。

说明

有关在 VBScript 中使用事件的信息，请参阅在 VBScript 中声明和使用事件过程。


Office Web 组件常量

此主题提供了 Office Web 组件对象模型中所有常量的列表。有关如何使用这些常量的信息，请参阅在 VBScript 中使用命名常量。

显示 AddinClientTypeEnum

常量 | 值
ssCoerceBool | 4
ssCoerceErr | 16
ssCoerceFlow | 32
ssCoerceFLStr | 4096
ssCoerceFSRef | 1024
ssCoerceInt | 2048
ssCoerceMissing | 128
ssCoerceMulti | 64
ssCoerceNil | 256
ssCoerceNum | 1
ssCoerceParse | 16384
ssCoerceRef | 8
ssCoerceRef3d | 512
ssCoerceSemiCalced | 8192
ssCoerceStr | 2
ssCoerceUncalced | 32768

显示 BindingLoadMode

常量 | 值
Delay | 2
Normal | 0
OM | 1

显示 Chart3DSurfaceEnum

常量 | 值
chSurfaceBackWall | 0
chSurfaceFloor | 2
chSurfaceSideWall | 1

显示 ChartAxisCrossesEnum

常量 | 值
chAxisCrossesAutomatic | 0
chAxisCrossesCustom | 3

显示 ChartAxisGroupingEnum

常量 | 值
chAxisGroupingAuto | 1
chAxisGroupingManual | 2
chAxisGroupingNone | 0

显示 ChartAxisPositionEnum

常量 | 值
chAxisPositionBottom | -2
chAxisPositionCategory | -7
chAxisPositionCircular | -6
chAxisPositionLeft | -3
chAxisPositionPrimary | -10
chAxisPositionRadial | -5
chAxisPositionRight | -4
chAxisPositionSecondary | -11
chAxisPositionSeries | -9
chAxisPositionTimescale | -7
chAxisPositionTop | -1
chAxisPositionValue | -8

显示 ChartAxisTypeEnum

常量 | 值
chCategoryAxis | 0
chSeriesAxis | 3
chTimescaleAxis | 2
chValueAxis | 1

显示 ChartAxisUnitTypeEnum

常量 | 值
chAxisUnitDay | 0
chAxisUnitMonth | 2
chAxisUnitQuarter | 3
chAxisUnitWeek | 1
chAxisUnitYear | 4

显示 ChartBoundaryValueTypeEnum

常量 | 值
chBoundaryValueAbsolute | 1
chBoundaryValuePercent | 0

显示 ChartChartLayoutEnum

常量 | 值
chChartLayoutAutomatic | 0
chChartLayoutHorizontal | 1
chChartLayoutVertical | 2

显示 ChartChartTypeEnum

常量 | 值
chChartTypeArea | 29
chChartTypeArea3D | 60
chChartTypeAreaOverlapped3D | 61
chChartTypeAreaStacked | 30
chChartTypeAreaStacked100 | 31
chChartTypeAreaStacked1003D | 63
chChartTypeAreaStacked3D | 62
chChartTypeBar3D | 50
chChartTypeBarClustered | 3
chChartTypeBarClustered3D | 51
chChartTypeBarStacked | 4
chChartTypeBarStacked100 | 5
chChartTypeBarStacked1003D | 53
chChartTypeBarStacked3D | 52
chChartTypeBubble | 27
chChartTypeBubbleLine | 28
chChartTypeColumn3D | 46
chChartTypeColumnClustered | 0
chChartTypeColumnClustered3D | 47
chChartTypeColumnStacked | 1
chChartTypeColumnStacked100 | 2
chChartTypeColumnStacked1003D | 49
chChartTypeColumnStacked3D | 48
chChartTypeCombo | -1
chChartTypeCombo3D | -2
chChartTypeDoughnut | 32
chChartTypeDoughnutExploded | 33
chChartTypeLine | 6
chChartTypeLine3D | 54
chChartTypeLineMarkers | 7
chChartTypeLineOverlapped3D | 55
chChartTypeLineStacked | 8
chChartTypeLineStacked100 | 10
chChartTypeLineStacked1003D | 57
chChartTypeLineStacked100Markers | 11
chChartTypeLineStacked3D | 56
chChartTypeLineStackedMarkers | 9
chChartTypePie | 18
chChartTypePie3D | 58
chChartTypePieExploded | 19
chChartTypePieExploded3D | 59
chChartTypePieStacked | 20
chChartTypePolarLine | 42
chChartTypePolarLineMarkers | 43
chChartTypePolarMarkers | 41
chChartTypePolarSmoothLine | 44
chChartTypePolarSmoothLineMarkers | 45
chChartTypeRadarLine | 34
chChartTypeRadarLineFilled | 36
chChartTypeRadarLineMarkers | 35
chChartTypeRadarSmoothLine | 37
chChartTypeRadarSmoothLineMarkers | 38
chChartTypeScatterLine | 25
chChartTypeScatterLineFilled | 26
chChartTypeScatterLineMarkers | 24
chChartTypeScatterMarkers | 21
chChartTypeScatterSmoothLine | 23
chChartTypeScatterSmoothLineMarkers | 22
chChartTypeSmoothLine | 12
chChartTypeSmoothLineMarkers | 13
chChartTypeSmoothLineStacked | 14
chChartTypeSmoothLineStacked100 | 16
chChartTypeSmoothLineStacked100Markers | 17
chChartTypeSmoothLineStackedMarkers | 15
chChartTypeStockHLC | 39
chChartTypeStockOHLC | 40

显示 ChartColorIndexEnum

常量 | 值
chColorAutomatic | -1
chColorNone | -2

显示 ChartCommandIdEnum

常量 | 值
chCommandAutoCalc | 1016
chCommandAutoFilter | 1017
chCommandAverage | 6045
chCommandBold | 1052
chCommandByRowCol | 6032
chCommandChartType | 6039
chCommandCollapse | 1013
chCommandConditionalFilter | 1125
chCommandCount | 6042
chCommandCut | 1001
chCommandDeleteSelection | 1011
chCommandDrill | 6034
chCommandDrillOut | 6037
chCommandExpand | 1012
chCommandFieldList | 1010
chCommandFilterByMenu | 1015
chCommandFontColor | 1057
chCommandFontName | 1050
chCommandFontSize | 1051
chCommandInteriorColor | 1056
chCommandItalic | 1053
chCommandLaunchDataFinder | 6027
chCommandLineColor | 1055
chCommandMax | 6044
chCommandMin | 6043
chCommandMoveToCategoryArea | 6056
chCommandMoveToChartArea | 6057
chCommandMoveToFilterArea | 6054
chCommandMoveToSeriesArea | 6055
chCommandMultiChart | 6050
chCommandPassiveAlert | 6026
chCommandRefresh | 1014
chCommandSelectNextMajor | 6005
chCommandSelectNextMinor | 6003
chCommandSelectPrevMajor | 6004
chCommandSelectPrevMinor | 6002
chCommandShowAbout | 1007
chCommandShowAll | 1121
chCommandShowBottom1 | 1110
chCommandShowBottom10 | 1113
chCommandShowBottom10Percent | 1118
chCommandShowBottom1Percent | 1115
chCommandShowBottom2 | 1111
chCommandShowBottom25 | 1114
chCommandShowBottom25Percent | 1119
chCommandShowBottom2Percent | 1116
chCommandShowBottom5 | 1112
chCommandShowBottom5Percent | 1117
chCommandShowBottomNMenu | 1124
chCommandShowContextMenu | 6001
chCommandShowDropZones | 6052
chCommandShowHelp | 1006
chCommandShowLegend | 6028
chCommandShowOther | 1120
chCommandShowPropertyToolbox | 1005
chCommandShowToolbar | 6053
chCommandShowTop1 | 1100
chCommandShowTop10 | 1103
chCommandShowTop10Percent | 1108
chCommandShowTop1Percent | 1105
chCommandShowTop2 | 1101
chCommandShowTop25 | 1104
chCommandShowTop25Percent | 1109
chCommandShowTop2Percent | 1106
chCommandShowTop5 | 1102
chCommandShowTop5Percent | 1107
chCommandShowTopNMenu | 1123
chCommandShowWizard | 6040
chCommandSortAscending | 2000
chCommandSortAscendingByTotal | 6035
chCommandSortDescending | 2031
chCommandSortDescendingByTotal | 6036
chCommandStdDev | 6046
chCommandStdDevP | 6048
chCommandSum | 6041
chCommandTogglePropertiesInScreenTip | 6038
chCommandUnderline | 1054
chCommandUndo | 1000
chCommandUnifiedScales | 6051
chCommandVar | 6047
chCommandVarP | 6049

显示 ChartDataGroupingFunctionEnum

常量 | 值
chDataGroupingFunctionAverage | 3
chDataGroupingFunctionMaximum | 1
chDataGroupingFunctionMinimum | 0
chDataGroupingFunctionSum | 2

显示 ChartDataLabelPositionEnum

常量 | 值
chLabelPositionAutomatic | 0
chLabelPositionBottom | 9
chLabelPositionCenter | 1
chLabelPositionInsideBase | 3
chLabelPositionInsideEnd | 2
chLabelPositionLeft | 6
chLabelPositionOutsideBase | 5
chLabelPositionOutsideEnd | 4
chLabelPositionRight | 7
chLabelPositionTop | 8

显示 ChartDataPointEnum

常量 | 值
chDataPointFirst | 0
chDataPointLast | 1

显示 ChartDataSourceTypeEnum

常量 | 值
chDataSourceTypeDSC | 5
chDataSourceTypePivotTable | 3
chDataSourceTypeQuery | 4
chDataSourceTypeSpreadsheet | 1
chDataSourceTypeUnknown | 0

显示 ChartDimensionsEnum

常量 | 值
chDimBubbleValues | 9
chDimCategories | 1
chDimCharts | 15
chDimCloseValues | 6
chDimFilter | 14
chDimFormatValues | 16
chDimHighValues | 7
chDimLowValues | 8
chDimOpenValues | 5
chDimRValues | 10
chDimSeriesNames | 0
chDimThetaValues | 11
chDimValues | 2
chDimXValues | 4
chDimYValues | 3

显示 ChartDrawModesEnum

常量 | 值
chDrawModeHitTest | 3
chDrawModePaint | 1
chDrawModeScale | 4
chDrawModeSelection | 2

显示 ChartDropZonesEnum

常量 | 值
chDropZoneCategories | 2
chDropZoneCharts | 4
chDropZoneData | 3
chDropZoneFilter | 0
chDropZoneSeries | 1

显示 ChartEndStyleEnum

常量 | 值
chEndStyleCap | 2
chEndStyleNone | 1

显示 ChartErrorBarCustomValuesEnum

常量 | 值
chErrorBarMinusValues | 13
chErrorBarPlusValues | 12

显示 ChartErrorBarDirectionEnum

常量 | 值
chErrorBarDirectionX | 1
chErrorBarDirectionY | 0

显示 ChartErrorBarIncludeEnum

常量 | 值
chErrorBarIncludeBoth | 2
chErrorBarIncludeMinusValues | 1
chErrorBarIncludePlusValues | 0

显示 ChartErrorBarTypeEnum

常量 | 值
chErrorBarTypeCustom | 2
chErrorBarTypeFixedValue | 0
chErrorBarTypePercent | 1

显示 ChartFillStyleEnum

常量 | 值
chNone | -1
chSolid | 0

显示 ChartFillTypeEnum

常量 | 值
chFillGradientOneColor | 3
chFillGradientPresetColors | 5
chFillGradientTwoColors | 4
chFillPatterned | 2
chFillSolid | 1
chFillTexturePreset | 6
chFillTextureUserDefined | 7

显示 ChartGradientStyleEnum

常量 | 值
chGradientDiagonalDown | 4
chGradientDiagonalUp | 3
chGradientFromCenter | 7
chGradientFromCorner | 5
chGradientHorizontal | 1
chGradientVertical | 2

显示 ChartGradientVariantEnum

常量 | 值
chGradientVariantCenter | 3
chGradientVariantEdges | 4
chGradientVariantEnd | 2
chGradientVariantStart | 1

显示 ChartGroupingTotalFunctionEnum

常量 | 值
chFunctionAvg | 5
chFunctionCount | 2
chFunctionDefault | 6
chFunctionMax | 4
chFunctionMin | 3
chFunctionSum | 1

显示 ChartLabelOrientationEnum

常量 | 值
chLabelOrientationAutomatic | 1000
chLabelOrientationDownward | -90
chLabelOrientationHorizontal | 0
chLabelOrientationUpward | 90

显示 ChartLegendPositionEnum

常量 | 值
chLegendPositionAutomatic | 0
chLegendPositionBottom | 2
chLegendPositionLeft | 3
chLegendPositionRight | 4
chLegendPositionTop | 1

显示 ChartLineDashStyleEnum

常量 | 值
chLineDash | 0
chLineDashDot | 1
chLineDashDotDot | 2
chLineLongDash | 4
chLineLongDashDot | 5
chLineRoundDot | 6
chLineSolid | 7
chLineSquareDot | 8

显示 ChartLineMiterEnum

常量 | 值
chLineMiterBevel | 0
chLineMiterMiter | 1
chLineMiterRound | 2

显示 ChartMarkerStyleEnum

常量 | 值
chMarkerStyleCircle | 8
chMarkerStyleDash | 7
chMarkerStyleDiamond | 2
chMarkerStyleDot | 6
chMarkerStyleNone | 0
chMarkerStylePlus | 9
chMarkerStyleSquare | 1
chMarkerStyleStar | 5
chMarkerStyleTriangle | 3
chMarkerStyleX | 4

显示 ChartPatternTypeEnum

常量 | 值
chPattern10Percent | 2
chPattern20Percent | 3
chPattern25Percent | 4
chPattern30Percent | 5
chPattern40Percent | 6
chPattern50Percent | 7
chPattern5Percent | 1
chPattern60Percent | 8
chPattern70Percent | 9
chPattern75Percent | 10
chPattern80Percent | 11
chPattern90Percent | 12
chPatternDarkDownwardDiagonal | 15
chPatternDarkHorizontal | 13
chPatternDarkUpwardDiagonal | 16
chPatternDarkVertical | 14
chPatternDashedDownwardDiagonal | 28
chPatternDashedHorizontal | 32
chPatternDashedUpwardDiagonal | 27
chPatternDashedVertical | 31
chPatternDiagonalBrick | 40
chPatternDivot | 46
chPatternDottedDiamond | 24
chPatternDottedGrid | 45
chPatternHorizontalBrick | 35
chPatternLargeCheckerBoard | 36
chPatternLargeConfetti | 33
chPatternLargeGrid | 34
chPatternLightDownwardDiagonal | 21
chPatternLightHorizontal | 19
chPatternLightUpwardDiagonal | 22
chPatternLightVertical | 20
chPatternNarrowHorizontal | 30
chPatternNarrowVertical | 29
chPatternOutlinedDiamond | 41
chPatternPlaid | 42
chPatternShingle | 47
chPatternSmallCheckerBoard | 17
chPatternSmallConfetti | 37
chPatternSmallGrid | 23
chPatternSolidDiamond | 39
chPatternSphere | 43
chPatternTrellis | 18
chPatternWave | 48
chPatternWeave | 44
chPatternWideDownwardDiagonal | 25
chPatternWideUpwardDiagonal | 26
chPatternZigZag | 38

显示 ChartPivotDataReferenceEnum

常量 | 值
chPivotColAggregates | -3
chPivotColumns | -1
chPivotRowAggregates | -4
chPivotRows | -2

显示 ChartPlotAggregatesEnum

常量 | 值
chPlotAggregatesCategories | 2
chPlotAggregatesCharts | 3
chPlotAggregatesFromTotalOrientation | 4
chPlotAggregatesNone | 0
chPlotAggregatesSeries | 1

显示 ChartPresetGradientTypeEnum

常量 | 值
chGradientBrass | 20
chGradientCalmWater | 8
chGradientChrome | 21
chGradientChromeII | 22
chGradientDaybreak | 4
chGradientDesert | 6
chGradientEarlySunset | 1
chGradientFire | 9
chGradientFog | 10
chGradientGold | 18
chGradientGoldII | 19
chGradientHorizon | 5
chGradientLateSunset | 2
chGradientMahogany | 15
chGradientMoss | 11
chGradientNightfall | 3
chGradientOcean | 7
chGradientParchment | 14
chGradientPeacock | 12
chGradientRainbow | 16
chGradientRainbowII | 17
chGradientSapphire | 24
chGradientSilver | 23
chGradientWheat | 13

显示 ChartPresetTextureEnum

常量 | 值
chTextureBlueTissuePaper | 17
chTextureBouquet | 20
chTextureBrownMarble | 11
chTextureCanvas | 2
chTextureCork | 21
chTextureDenim | 3
chTextureFishFossil | 7
chTextureGranite | 12
chTextureGreenMarble | 9
chTextureMediumWood | 24
chTextureNewsprint | 13
chTextureOak | 23
chTexturePaperBag | 6
chTexturePapyrus | 1
chTextureParchment | 15
chTexturePinkTissuePaper | 18
chTexturePurpleMesh | 19
chTextureRecycledPaper | 14
chTextureSand | 8
chTextureStationery | 16
chTextureWalnut | 22
chTextureWaterDroplets | 5
chTextureWhiteMarble | 10
chTextureWovenMat | 4

显示 ChartProjectionModeEnum

常量 | 值
chProjectionModeOrthographic | 1
chProjectionModePerspective | 0

显示 ChartScaleOrientationEnum

常量 | 值
chScaleOrientationMaxMin | 1
chScaleOrientationMinMax | 0

显示 ChartScaleTypeEnum

常量 | 值
chScaleTypeLinear | 0
chScaleTypeLogarithmic | 1

显示 ChartSelectionMarksEnum

常量 | 值
chSelectionMarksAll | 1
chSelectionMarksNone | 0
chSelectionMarksPivot | 2

显示 ChartSelectionsEnum

常量 | 值
chSelectionAxis | 0
chSelectionCategoryLabel | 16
chSelectionChart | 1
chSelectionChartSpace | 12
chSelectionDataLabel | 18
chSelectionDataLabels | 3
chSelectionDropZone | 17
chSelectionErrorbars | 4
chSelectionField | 14
chSelectionGridlines | 5
chSelectionLegend | 6
chSelectionLegendEntry | 7
chSelectionNone | -1
chSelectionPlotArea | 2
chSelectionPoint | 8
chSelectionSeries | 9
chSelectionSurface | 13
chSelectionTitle | 10
chSelectionTrendline | 11
chSelectionUserDefined | -2

显示 ChartSelectMode

常量 | 值
chSelectModeAdd | 1
chSelectModeRemove | 2
chSelectModeReplace | 0
chSelectModeToggle | 3

显示 ChartSeriesByEnum

常量 | 值
chSeriesByColumns | 1
chSeriesByRows | 0

显示 ChartSizeRepresentsEnum

常量 | 值
chSizeIsArea | 1
chSizeIsWidth | 0

显示 ChartSpecialDataSourcesEnum

常量 | 值
chDataBound | 0
chDataLinked | -3
chDataLiteral | -1
chDataNone | -2

显示 ChartTextureFormatEnum

常量 | 值
chStack | 1
chStackScale | 2
chStretch | 3
chStretchPlot | 5
chTile | 4

显示 ChartTexturePlacementEnum

常量 | 值
chAllFaces | 7
chEnd | 2
chEndSides | 6
chFront | 1
chFrontEnd | 3
chFrontSides | 5
chProjectFront | 8
chSides | 4

显示 ChartTickMarkEnum

常量 | 值
chTickMarkAutomatic | 0
chTickMarkCross | 4
chTickMarkInside | 2
chTickMarkNone | 1
chTickMarkOutside | 3

显示 ChartTitlePositionEnum

常量 | 值
chTitlePositionAutomatic | 0
chTitlePositionBottom | 2
chTitlePositionLeft | 3
chTitlePositionRight | 4
chTitlePositionTop | 1

显示 ChartTrendlineTypeEnum

常量 | 值
chTrendlineTypeExponential | 0
chTrendlineTypeLinear | 1
chTrendlineTypeLogarithmic | 2
chTrendlineTypeMovingAverage | 5
chTrendlineTypePolynomial | 3
chTrendlineTypePower | 4

显示 DefaultControlTypeEnum

常量 | 值
ctlTypeBoundSpan | 1
ctlTypeTextBox | 0

显示 DscAdviseTypeEnum

常量 | 值
dscAdd | 1
dscChange | 5
dscDelete | 2
dscDeleteComplete | 6
dscLoad | 4
dscMove | 3
dscRename | 7

显示 DscDisplayAlert

常量 | 值
dscDataAlertContinue | 0
dscDataAlertDisplay | 1

显示 DscDropLocationEnum

常量 | 值
dscAbove | 1
dscBelow | 3
dscWithin | 2

显示 DscDropTypeEnum

常量 | 值
dscDefault | 0
dscFields | 2
dscGrid | 1

显示 DscEncodingEnum

常量 | 值
dscEUCJ | 4
dscUCS2 | 2
dscUCS4 | 3
dscUTF16 | 1
dscUTF8 | 0
dscWindows | 5

显示 DscFetchTypeEnum

常量 | 值
dscFull | 1
dscParameterized | 2

显示 DscFieldTypeEnum

常量 | 值
dscCalculated | 2
dscGrouping | 3
dscOutput | 1
dscParameter | -1

显示 DscGroupOnEnum

常量 | 值
dscDay | 6
dscEachValue | 0
dscHour | 7
dscInterval | 9
dscMinute | 8
dscMonth | 4
dscPrefix | 1
dscQuarter | 3
dscWeek | 5
dscYear | 2

显示 DscHyperlinkPartEnum

常量 | 值
dschlAddress | 2
dschlDisplayedValue | 0
dschlDisplayText | 1
dschlFullAddress | 5
dschlScreenTip | 4
dschlSubAddress | 3

显示 DscJoinTypeEnum

常量 | 值
dscInnerJoin | 1
dscLeftOuterJoin | 2
dscRightOuterJoin | 3

显示 DscLocationEnum

常量 | 值
dscClient | 0
dscServer | 1
dscSystem | -1

显示 DscObjectTypeEnum

常量 | 值
dscobjDatamodel | 512
dscobjGroupingDef | 256
dscobjLookupRelationship | 128
dscobjPageField | 32
dscobjPageRelatedField | 1024
dscobjPageRowsource | 16
dscobjParameterValue | 2048
dscobjRecordsetDef | 8
dscobjSchemaField | 2
dscobjSchemaParameter | 8192
dscobjSchemaProperty | 16384
dscobjSchemaRelatedField | 4096
dscobjSchemaRelationship | 4
dscobjSchemaRowsource | 1
dscobjSublistRelationship | 64
dscobjUnknown | -1

显示 DscOfflineTypeEnum

常量 | 值
dscOfflineMerge | 1
dscOfflineNone | 0
dscOfflineWorkflow | 3
dscOfflineXMLDataFile | 2

显示 DscPageRelTypeEnum

常量 | 值
dscLookup | 2
dscSublist | 1

显示 DscRecordsetTypeEnum

常量 | 值
dscSnapshot | 1
dscUpdatableSnapshot | 2

显示 DscRowsourceTypeEnum

常量 | 值
dscCommandDSP | 6
dscCommandFile | 5
dscCommandText | 3
dscFunction | 5
dscInlineFunction | 6
dscProcedure | 4
dscTable | 1
dscTableFunction | 7
dscView | 2

显示 DscSaveAsEnum

常量 | 值
dscSaveAsEmbeddedXML | 0
dscSaveAsXMLDataFile | 1

显示 DscStatusEnum

常量 | 值
dscDeleteCancel | 1
dscDeleteOK | 0
dscDeleteUserCancel | 2

显示 DscTotalTypeEnum

常量 | 值
dscAny | 6
dscAvg | 2
dscCount | 5
dscMax | 4
dscMin | 3
dscNone | 0
dscStdev | 7
dscSum | 1

显示 DscXMLLocationEnum

常量 | 值
dscXMLDataFile | 1
dscXMLEmbedded | 0

显示 ExpandBitmapTypeEnum

常量 | 值
ecBitmapOpenCloseFolder | 2
ecBitmapPlusMinus | 0
ecBitmapUpDownArrow | 1

显示 LineStyleEnum

常量 | 值
owcLineStyleAutomatic | 1
owcLineStyleDash | 3
owcLineStyleDashDot | 5
owcLineStyleDashDotDot | 6
owcLineStyleDot | 4
owcLineStyleNone | 0
owcLineStyleSolid | 2

显示 LineWeightEnum

常量 | 值
owcLineWeightHairline | 0
owcLineWeightMedium | 2
owcLineWeightThick | 3
owcLineWeightThin | 1

显示 MsoAppLanguageID

常量 | 值
msoLanguageIDExeMode | 4
msoLanguageIDHelp | 3
msoLanguageIDInstall | 1
msoLanguageIDUI | 2
msoLanguageIDUIPrevious | 5

显示 MsoLanguageID

常量 | 值
msoLanguageIDAfrikaans | 1078
msoLanguageIDAlbanian | 1052
msoLanguageIDAmharic | 1118
msoLanguageIDArabic | 1025
msoLanguageIDArabicAlgeria | 5121
msoLanguageIDArabicBahrain | 15361
msoLanguageIDArabicEgypt | 3073
msoLanguageIDArabicIraq | 2049
msoLanguageIDArabicJordan | 11265
msoLanguageIDArabicKuwait | 13313
msoLanguageIDArabicLebanon | 12289
msoLanguageIDArabicLibya | 4097
msoLanguageIDArabicMorocco | 6145
msoLanguageIDArabicOman | 8193
msoLanguageIDArabicQatar | 16385
msoLanguageIDArabicSyria | 10241
msoLanguageIDArabicTunisia | 7169
msoLanguageIDArabicUAE | 14337
msoLanguageIDArabicYemen | 9217
msoLanguageIDArmenian | 1067
msoLanguageIDAssamese | 1101
msoLanguageIDAzeriCyrillic | 2092
msoLanguageIDAzeriLatin | 1068
msoLanguageIDBasque | 1069
msoLanguageIDBelgianDutch | 2067
msoLanguageIDBelgianFrench | 2060
msoLanguageIDBengali | 1093
msoLanguageIDBosnian | 4122
msoLanguageIDBrazilianPortuguese | 1046
msoLanguageIDBulgarian | 1026
msoLanguageIDBurmese | 1109
msoLanguageIDByelorussian | 1059
msoLanguageIDCatalan | 1027
msoLanguageIDCherokee | 1116
msoLanguageIDChineseHongKong | 3076
msoLanguageIDChineseHongKongSAR | 3076
msoLanguageIDChineseMacao | 5124
msoLanguageIDChineseMacaoSAR | 5124
msoLanguageIDChineseSingapore | 4100
msoLanguageIDCroatian | 1050
msoLanguageIDCzech | 1029
msoLanguageIDDanish | 1030
msoLanguageIDDivehi | 1125
msoLanguageIDDutch | 1043
msoLanguageIDDzongkhaBhutan | 2129
msoLanguageIDEdo | 1126
msoLanguageIDEnglishAUS | 3081
msoLanguageIDEnglishBelize | 10249
msoLanguageIDEnglishCanadian | 4105
msoLanguageIDEnglishCaribbean | 9225
msoLanguageIDEnglishIndonesia | 14345
msoLanguageIDEnglishIreland | 6153
msoLanguageIDEnglishJamaica | 8201
msoLanguageIDEnglishNewZealand | 5129
msoLanguageIDEnglishPhilippines | 13321
msoLanguageIDEnglishSouthAfrica | 7177
msoLanguageIDEnglishTrinidad | 11273
msoLanguageIDEnglishTrinidadTobago | 11273
msoLanguageIDEnglishUK | 2057
msoLanguageIDEnglishUS | 1033
msoLanguageIDEnglishZimbabwe | 12297
msoLanguageIDEstonian | 1061
msoLanguageIDFaeroese | 1080
msoLanguageIDFarsi | 1065
msoLanguageIDFilipino | 1124
msoLanguageIDFinnish | 1035
msoLanguageIDFrench | 1036
msoLanguageIDFrenchCameroon | 11276
msoLanguageIDFrenchCanadian | 3084
msoLanguageIDFrenchCotedIvoire | 12300
msoLanguageIDFrenchHaiti | 15372
msoLanguageIDFrenchLuxembourg | 5132
msoLanguageIDFrenchMali | 13324
msoLanguageIDFrenchMonaco | 6156
msoLanguageIDFrenchMorocco | 14348
msoLanguageIDFrenchReunion | 8204
msoLanguageIDFrenchSenegal | 10252
msoLanguageIDFrenchWestIndies | 7180
msoLanguageIDFrenchZaire | 9228
msoLanguageIDFrisianNetherlands | 1122
msoLanguageIDFulfulde | 1127
msoLanguageIDGaelicIreland | 2108
msoLanguageIDGaelicScotland | 1084
msoLanguageIDGalician | 1110
msoLanguageIDGeorgian | 1079
msoLanguageIDGerman | 1031
msoLanguageIDGermanAustria | 3079
msoLanguageIDGermanLiechtenstein | 5127
msoLanguageIDGermanLuxembourg | 4103
msoLanguageIDGreek | 1032
msoLanguageIDGuarani | 1140
msoLanguageIDGujarati | 1095
msoLanguageIDHausa | 1128
msoLanguageIDHawaiian | 1141
msoLanguageIDHebrew | 1037
msoLanguageIDHindi | 1081
msoLanguageIDHungarian | 1038
msoLanguageIDIbibio | 1129
msoLanguageIDIcelandic | 1039
msoLanguageIDIgbo | 1136
msoLanguageIDIndonesian | 1057
msoLanguageIDInuktitut | 1117
msoLanguageIDItalian | 1040
msoLanguageIDJapanese | 1041
msoLanguageIDKannada | 1099
msoLanguageIDKanuri | 1137
msoLanguageIDKashmiri | 1120
msoLanguageIDKashmiriDevanagari | 2144
msoLanguageIDKashmiriIndia | 2144
msoLanguageIDKazakh | 1087
msoLanguageIDKhmer | 1107
msoLanguageIDKirghiz | 1088
msoLanguageIDKonkani | 1111
msoLanguageIDKorean | 1042
msoLanguageIDKyrgyz | 1088
msoLanguageIDLao | 1108
msoLanguageIDLatin | 1142
msoLanguageIDLatvian | 1062
msoLanguageIDLithuanian | 1063
msoLanguageIDMacedonian | 1071
msoLanguageIDMalayalam | 1100
msoLanguageIDMalayBruneiDarussalam | 2110
msoLanguageIDMalaysian | 1086
msoLanguageIDMaltese | 1082
msoLanguageIDManipuri | 1112
msoLanguageIDMaori | 1153
msoLanguageIDMarathi | 1102
msoLanguageIDMexicanSpanish | 2058
msoLanguageIDMixed | -2
msoLanguageIDMongolian | 1104
msoLanguageIDNepali | 1121
msoLanguageIDNone | 0
msoLanguageIDNoProofing | 1024
msoLanguageIDNorwegianBokmol | 1044
msoLanguageIDNorwegianNynorsk | 2068
msoLanguageIDOriya | 1096
msoLanguageIDOromo | 1138
msoLanguageIDPashto | 1123
msoLanguageIDPolish | 1045
msoLanguageIDPortuguese | 2070
msoLanguageIDPunjabi | 1094
msoLanguageIDRhaetoRomanic | 1047
msoLanguageIDRomanian | 1048
msoLanguageIDRomanianMoldova | 2072
msoLanguageIDRussian | 1049
msoLanguageIDRussianMoldova | 2073
msoLanguageIDSamiLappish | 1083
msoLanguageIDSanskrit | 1103
msoLanguageIDSerbianCyrillic | 3098
msoLanguageIDSerbianLatin | 2074
msoLanguageIDSesotho | 1072
msoLanguageIDSimplifiedChinese | 2052
msoLanguageIDSindhi | 1113
msoLanguageIDSindhiPakistan | 2137
msoLanguageIDSinhalese | 1115
msoLanguageIDSlovak | 1051
msoLanguageIDSlovenian | 1060
msoLanguageIDSomali | 1143
msoLanguageIDSorbian | 1070
msoLanguageIDSpanish | 1034
msoLanguageIDSpanishArgentina | 11274
msoLanguageIDSpanishBolivia | 16394
msoLanguageIDSpanishChile | 13322
msoLanguageIDSpanishColombia | 9226
msoLanguageIDSpanishCostaRica | 5130
msoLanguageIDSpanishDominicanRepublic | 7178
msoLanguageIDSpanishEcuador | 12298
msoLanguageIDSpanishElSalvador | 17418
msoLanguageIDSpanishGuatemala | 4106
msoLanguageIDSpanishHonduras | 18442
msoLanguageIDSpanishModernSort | 3082
msoLanguageIDSpanishNicaragua | 19466
msoLanguageIDSpanishPanama | 6154
msoLanguageIDSpanishParaguay | 15370
msoLanguageIDSpanishPeru | 10250
msoLanguageIDSpanishPuertoRico | 20490
msoLanguageIDSpanishUruguay | 14346
msoLanguageIDSpanishVenezuela | 8202
msoLanguageIDSutu | 1072
msoLanguageIDSwahili | 1089
msoLanguageIDSwedish | 1053
msoLanguageIDSwedishFinland | 2077
msoLanguageIDSwissFrench | 4108
msoLanguageIDSwissGerman | 2055
msoLanguageIDSwissItalian | 2064
msoLanguageIDSyriac | 1114
msoLanguageIDTajik | 1064
msoLanguageIDTamazight | 1119
msoLanguageIDTamazightLatin | 2143
msoLanguageIDTamil | 1097
msoLanguageIDTatar | 1092
msoLanguageIDTelugu | 1098
msoLanguageIDThai | 1054
msoLanguageIDTibetan | 1105
msoLanguageIDTigrignaEritrea | 2163
msoLanguageIDTigrignaEthiopic | 1139
msoLanguageIDTraditionalChinese | 1028
msoLanguageIDTsonga | 1073
msoLanguageIDTswana | 1074
msoLanguageIDTurkish | 1055
msoLanguageIDTurkmen | 1090
msoLanguageIDUkrainian | 1058
msoLanguageIDUrdu | 1056
msoLanguageIDUzbekCyrillic | 2115
msoLanguageIDUzbekLatin | 1091
msoLanguageIDVenda | 1075
msoLanguageIDVietnamese | 1066
msoLanguageIDWelsh | 1106
msoLanguageIDXhosa | 1076
msoLanguageIDYi | 1144
msoLanguageIDYiddish | 1085
msoLanguageIDYoruba | 1130
msoLanguageIDZulu | 1077

显示 NavButtonEnum

常量 | 值
navbtnApplyFilter | 10
navbtnDelete | 5
navbtnHelp | 12
navbtnMoveFirst | 0
navbtnMoveLast | 3
navbtnMoveNext | 2
navbtnMovePrev | 1
navbtnNew | 4
navbtnSave | 6
navbtnSortAscending | 8
navbtnSortDescending | 9
navbtnToggleFilter | 11
navbtnUndo | 7

显示 NotificationType

常量 | 值
dscConnectionReset | 0
dscDataReset | 1

显示 OCCommandId

常量 | 值
ocCommandAbout | 1007
ocCommandAutoCalc | 1016
ocCommandAutoFilter | 1017
ocCommandChooser | 1010
ocCommandCollapse | 1013
ocCommandCopy | 1002
ocCommandCut | 1001
ocCommandExpand | 1012
ocCommandExport | 1004
ocCommandHelp | 1006
ocCommandPaste | 1003
ocCommandProperties | 1005
ocCommandRefresh | 1014
ocCommandSortAsc | 2000
ocCommandSortDesc | 2031
ocCommandUndo | 1000

显示 PivotArrowModeEnum

常量 | 值
plArrowModeAccept | 0
plArrowModeEdit | 1

显示 PivotCaretPositionEnum

常量 | 值
plCaretPositionAtEnd | 0
plCaretPositionAtMouse | 1

显示 PivotCommandId

常量 | 值
plCommandAbout | 1007
plCommandAutoAverage | 12089
plCommandAutoCalc | 1016
plCommandAutoCount | 12006
plCommandAutoFilter | 1017
plCommandAutoMax | 12008
plCommandAutoMin | 12007
plCommandAutoStdDev | 12090
plCommandAutoStdDevP | 12092
plCommandAutoSum | 12005
plCommandAutoVar | 12091
plCommandAutoVarP | 12093
plCommandBottomRightEdge | 12017
plCommandCalculated | 12110
plCommandChooser | 1010
plCommandClearCustomOrdering | 12154
plCommandCollapse | 1013
plCommandConditionalFilter | 1125
plCommandContextMenu | 12066
plCommandCopy | 1002
plCommandCreateCalculatedTotal | 12102
plCommandCut | 12157
plCommandDelete | 1011
plCommandDeleteRow | 12101
plCommandDemote | 12039
plCommandDown | 12029
plCommandDropzones | 12009
plCommandEndEdit | 12100
plCommandEnterDetails | 12024
plCommandExitDetails | 12025
plCommandExpand | 1012
plCommandExpandIndicator | 12051
plCommandExport | 1004
plCommandExtendBottomRightEdge | 12108
plCommandExtendDown | 12075
plCommandExtendLeft | 12072
plCommandExtendPageDown | 12079
plCommandExtendPageLeft | 12076
plCommandExtendPageRight | 12077
plCommandExtendPageUp | 12078
plCommandExtendRight | 12073
plCommandExtendTopLeftEdge | 12107
plCommandExtendUp | 12074
plCommandFilter | 12037
plCommandFilterByMenu | 12065
plCommandFilterBySel | 12001
plCommandFormatAlignAutomatic | 12158
plCommandFormatAlignCenter | 12142
plCommandFormatAlignLeft | 12141
plCommandFormatAlignRight | 12143
plCommandFormatBackColor | 12148
plCommandFormatBold | 12062
plCommandFormatComma | 12061
plCommandFormatCurrency | 12056
plCommandFormatDate | 12059
plCommandFormatExponent | 12058
plCommandFormatForeColor | 12147
plCommandFormatGeneral | 12055
plCommandFormatItalic | 12063
plCommandFormatName | 12144
plCommandFormatPercent | 12057
plCommandFormatSize | 12145
plCommandFormatTime | 12060
plCommandFormatUnderline | 12064
plCommandFormatUnderline2 | 12146
plCommandGroupByColumn | 12035
plCommandGroupByRow | 12034
plCommandGroupMembers | 12155
plCommandHelp | 1006
plCommandHideAllPropertiesInReport | 12150
plCommandHideAllPropertiesInScreenTip | 12152
plCommandHideDetails | 12096
plCommandHyperlink | 12082
plCommandInsertField | 12004
plCommandLastDown | 12023
plCommandLastLeft | 12020
plCommandLastRight | 12021
plCommandLastUp | 12022
plCommandLeft | 12026
plCommandLeftEdge | 12014
plCommandMoveMemDown | 12086
plCommandMoveMemLeft | 12087
plCommandMoveMemRight | 12088
plCommandMoveMemUp | 12085
plCommandNextHorz | 12012
plCommandNextHorzCell | 12018
plCommandNextVert | 12013
plCommandNextVertCell | 12069
plCommandOpenHyperlinkInPlace | 12083
plCommandOpenHyperlinkInWindow | 12084
plCommandPageDown | 12031
plCommandPageLeft | 12032
plCommandPageRight | 12033
plCommandPageUp | 12030
plCommandPaste | 1003
plCommandPrevHorz | 12067
plCommandPrevHorzCell | 12019
plCommandPrevVert | 12068
plCommandPrevVertCell | 12070
plCommandProfile | 12153
plCommandPromote | 12038
plCommandProperties | 1005
plCommandRefresh | 1014
plCommandRemove | 12010
plCommandRight | 12027
plCommandRightEdge | 12015
plCommandSelectAll | 12054
plCommandSelectField | 12052
plCommandSelectRow | 12053
plCommandShowAll | 1121
plCommandShowAllPropertiesInReport | 12149
plCommandShowAllPropertiesInScreenTip | 12151
plCommandShowAs | 12134
plCommandShowAsNormal | 12135
plCommandShowAsPercentOfColumnParent | 12139
plCommandShowAsPercentOfColumnTotal | 12137
plCommandShowAsPercentOfGrandTotal | 12140
plCommandShowAsPercentOfRowParent | 12138
plCommandShowAsPercentOfRowTotal | 12136
plCommandShowBottom1 | 1110
plCommandShowBottom10 | 1113
plCommandShowBottom10Percent | 1118
plCommandShowBottom1Percent | 1115
plCommandShowBottom2 | 1111
plCommandShowBottom25 | 1114
plCommandShowBottom25Percent | 1119
plCommandShowBottom2Percent | 1116
plCommandShowBottom5 | 1112
plCommandShowBottom5Percent | 1117
plCommandShowBottomNMenu | 1124
plCommandShowDetails | 12095
plCommandShowOther | 1120
plCommandShowTop1 | 1100
plCommandShowTop10 | 1103
plCommandShowTop10Percent | 1108
plCommandShowTop1Percent | 1105
plCommandShowTop2 | 1101
plCommandShowTop25 | 1104
plCommandShowTop25Percent | 1109
plCommandShowTop2Percent | 1106
plCommandShowTop5 | 1102
plCommandShowTop5Percent | 1107
plCommandShowTopNMenu | 1123
plCommandSortAsc | 2000
plCommandSortDesc | 2031
plCommandStartEdit | 12099
plCommandSubtotal | 12042
plCommandTogglePropertiesInReport | 12097
plCommandTogglePropertiesInScreenTip | 12098
plCommandTogglePropertyInReport | 12900
plCommandTogglePropertyInScreenTip | 12950
plCommandToolbar | 12044
plCommandTopLeftEdge | 12016
plCommandUngroup | 12036
plCommandUngroupMembers | 12156
plCommandUp | 12028

显示 PivotDataReasonEnum

常量 | 值
plDataReasonAdhocFieldAdded | 43
plDataReasonAdhocFieldDeleted | 44
plDataReasonAdhocMemberChanged | 45
plDataReasonAllIncludeExcludeChange | 42
plDataReasonAllowDetailsChange | 4
plDataReasonAllowMultiFilterChange | 41
plDataReasonAlwaysIncludeInCubeChange | 46
plDataReasonCommandTextChange | 31
plDataReasonConnectionStringChange | 32
plDataReasonDataMemberChange | 23
plDataReasonDataSourceChange | 22
plDataReasonDisplayCalculatedMembersChange | 10
plDataReasonDisplayCellColorChange | 49
plDataReasonDisplayEmptyMembersChange | 19
plDataReasonExcludedMembersChange | 16
plDataReasonExpressionChange | 47
plDataReasonFieldNameChange | 53
plDataReasonFieldSetDeleted | 39
plDataReasonFieldSetNameChange | 52
plDataReasonFilterContextChange | 9
plDataReasonFilterCrossJoinsChange | 50
plDataReasonFilterFunctionChange | 8
plDataReasonFilterFunctionValueChange | 13
plDataReasonFilterOnChange | 11
plDataReasonFilterOnScopeChange | 12
plDataReasonGroupEndChange | 30
plDataReasonGroupIntervalChange | 27
plDataReasonGroupOnChange | 24
plDataReasonGroupStartChange | 26
plDataReasonIncludedMembersChange | 15
plDataReasonInsertFieldSet | 0
plDataReasonInsertTotal | 2
plDataReasonIsFilteredChange | 28
plDataReasonIsIncludedChange | 17
plDataReasonMemberPropertyDisplayInChange | 34
plDataReasonMemberPropertyIsIncludedChange | 33
plDataReasonOrderedMembersChange | 29
plDataReasonRecordChanged | 40
plDataReasonRefreshDataSource | 51
plDataReasonRemoveFieldSet | 1
plDataReasonRemoveTotal | 3
plDataReasonSortDirectionChange | 5
plDataReasonSortOnChange | 6
plDataReasonSortOnScopeChange | 7
plDataReasonSubtotalsChange | 35
plDataReasonTotalAllMembersChange | 48
plDataReasonTotalDeleted | 38
plDataReasonTotalExpressionChange | 36
plDataReasonTotalFunctionChange | 20
plDataReasonTotalNameChange | 14
plDataReasonTotalSolveOrderChange | 37
plDataReasonUnknown | 25
plDataReasonUser | 21

显示 PivotEditModeEnum

常量 | 值
plEditInProgress | 1
plEditNone | 0

显示 PivotExportActionEnum

常量 | 值
plExportActionNone | 0
plExportActionOpenInExcel | 1

显示 PivotFieldFilterFunctionEnum

常量 | 值
plFilterFunctionBottomCount | 4
plFilterFunctionBottomPercent | 6
plFilterFunctionBottomSum | 8
plFilterFunctionNone | 0
plFilterFunctionTopCount | 3
plFilterFunctionTopPercent | 5
plFilterFunctionTopSum | 7

显示 PivotFieldGroupOnEnum

常量 | 值
plGroupOnDays | 6
plGroupOnEachValue | 0
plGroupOnHours | 7
plGroupOnInterval | 10
plGroupOnMinutes | 8
plGroupOnMonths | 4
plGroupOnPrefixChars | 1
plGroupOnQtrs | 3
plGroupOnSeconds | 9
plGroupOnWeeks | 5
plGroupOnYears | 2

显示 PivotFieldSetAllIncludeExcludeEnum

常量 | 值
plAllDefault | 0
plAllExclude | 2
plAllInclude | 1

显示 PivotFieldSetOrientationEnum

常量 | 值
plOrientationColumnAxis | 1
plOrientationDataAxis | 8
plOrientationFilterAxis | 4
plOrientationNone | 0
plOrientationPageAxis | 16
plOrientationRowAxis | 2

显示 PivotFieldSetTypeEnum

常量 | 值
plFieldSetTypeOther | 2
plFieldSetTypeTime | 1
plFieldSetTypeUnknown | 3
plFieldSetTypeUserDefined | 4

显示 PivotFieldSortDirectionEnum

常量 | 值
plSortDirectionAscending | 1
plSortDirectionCustom | 4
plSortDirectionCustomAscending | 5
plSortDirectionCustomDescending | 6
plSortDirectionDefault | 0
plSortDirectionDescending | 2

显示 PivotFieldTypeEnum

常量 | 值
plTypeCalculated | 2
plTypeCustomGroup | 17
plTypeRegular | 1
plTypeTimeDays | 9
plTypeTimeHalfYears | 5
plTypeTimeHours | 10
plTypeTimeMinutes | 11
plTypeTimeMonths | 7
plTypeTimeQuarters | 6
plTypeTimeSeconds | 12
plTypeTimeUndefined | 13
plTypeTimeWeekdays | 16
plTypeTimeWeeks | 8
plTypeTimeYears | 4
plTypeUnknown | 14
plTypeUserDefined | 15

显示 PivotFilterUpdateMemberStateEnum

常量 | 值
plMemberStateChecked | 2
plMemberStateClear | 1
plMemberStateGray | 3

显示 PivotHAlignmentEnum

常量 | 值
plHAlignAutomatic | 0
plHAlignCenter | 2
plHAlignLeft | 1
plHAlignRight | 3

显示 PivotMemberCustomGroupTypeEnum

常量 | 值
plGroupTypeCustomGroup | 2
plGroupTypeDynamicOther | 6
plGroupTypeFallThrough | 3
plGroupTypePlaceHolder | 4
plGroupTypeRegular | 1
plGroupTypeStaticOther | 5

显示 PivotMemberFindFormatEnum

常量 | 值
plFindFormatMember | 0
plFindFormatPathHex | 3
plFindFormatPathInt | 2
plFindFormatPathName | 1

显示 PivotMemberPropertyDisplayEnum

常量 | 值
plDisplayPropertyInAll | 3
plDisplayPropertyInReport | 1
plDisplayPropertyInScreenTip | 2
plDisplayPropertyNone | 0

显示 PivotMembersCompareByEnum

常量 | 值
plMembersCompareByName | 1
plMembersCompareByUniqueName | 0

显示 PivotScrollTypeEnum

常量 | 值
plScrollTypeAll | 15
plScrollTypeBottom | 4
plScrollTypeLeft | 2
plScrollTypeNone | 0
plScrollTypeRight | 8
plScrollTypeTop | 1

显示 PivotShowAsEnum

常量 | 值
plShowAsNormal | 0
plShowAsPercentOfColumnParent | 4
plShowAsPercentOfColumnTotal | 2
plShowAsPercentOfGrandTotal | 5
plShowAsPercentOfRowParent | 3
plShowAsPercentOfRowTotal | 1

显示 PivotTableExpandEnum

常量 | 值
plExpandAlways | 1
plExpandAutomatic | 0
plExpandNever | 2

显示 PivotTableReasonEnum

常量 | 值
plPivotTableReasonFieldAdded | 3
plPivotTableReasonFieldSetAdded | 2
plPivotTableReasonTotalAdded | 0
plPivotTableReasonTotalDeleted | 1

显示 PivotTotalFunctionEnum

常量 | 值
plFunctionAverage | 5
plFunctionCalculated | 127
plFunctionCount | 2
plFunctionMax | 4
plFunctionMin | 3
plFunctionStdDev | 6
plFunctionStdDevP | 10
plFunctionSum | 1
plFunctionUnknown | 0
plFunctionVar | 7
plFunctionVarP | 11

显示 PivotTotalTypeEnum

常量 | 值
plTotalTypeCalculated | 3
plTotalTypeIntrinsic | 1
plTotalTypeUserDefined | 2

显示 PivotViewReasonEnum

常量 | 值
plViewReasonAlignmentChange | 18
plViewReasonAllowAdditionsChange | 64
plViewReasonAllowCustomOrderingChange | 60
plViewReasonAllowDeletionsChange | 65
plViewReasonAllowEditsChange | 63
plViewReasonAllowFilteringChange | 32
plViewReasonAllowGroupingChange | 33
plViewReasonAllowPropertyToolbox | 61
plViewReasonAutoFitChange | 40
plViewReasonBackColorChange | 17
plViewReasonCellExpandedChange | 9
plViewReasonDataChange | 2
plViewReasonDataMemberCaptionChange | 72
plViewReasonDetailLeftChange | 21
plViewReasonDetailLeftOffsetChange | 48
plViewReasonDetailMaxHeightChange | 44
plViewReasonDetailMaxWidthChange | 43
plViewReasonDetailRowHeightChange | 10
plViewReasonDetailTopChange | 20
plViewReasonDetailTopOffsetChange | 47
plViewReasonDisplayInFieldListChange | 73
plViewReasonDisplayOutlineChange | 26
plViewReasonDisplayScreenTipsChange | 68
plViewReasonDisplayToolbarChange | 37
plViewReasonExpandDetailsChange | 42
plViewReasonExpandMembersChange | 62
plViewReasonFieldCaptionChange | 27
plViewReasonFieldDetailWidthChange | 11
plViewReasonFieldExpandedChange | 41
plViewReasonFieldGroupedHeightChange | 53
plViewReasonFieldGroupedWidthChange | 12
plViewReasonFieldSetCaptionChange | 28
plViewReasonFieldSetWidthChange | 14
plViewReasonFontBoldChange | 5
plViewReasonFontItalicChange | 6
plViewReasonFontNameChange | 3
plViewReasonFontSizeChange | 4
plViewReasonFontUnderlineChange | 7
plViewReasonForeColorChange | 16
plViewReasonHeightChange | 35
plViewReasonHideDetails | 59
plViewReasonIsHyperlinkChange | 49
plViewReasonKillFocus | 67
plViewReasonLabelCaptionChange | 29
plViewReasonLabelVisibleChange | 36
plViewReasonLeftChange | 23
plViewReasonLeftOffsetChange | 46
plViewReasonMaxHeightChange | 38
plViewReasonMaxWidthChange | 39
plViewReasonMemberCaptionChange | 30
plViewReasonMemberCaptionsChange | 70
plViewReasonMemberExpandedChange | 8
plViewReasonMemberHeightChange | 54
plViewReasonMemberPropertiesOrderChange | 52
plViewReasonMemberPropertyCaptionChange | 51
plViewReasonMemberPropertyDisplayInChange | 50
plViewReasonMemberWidthChange | 55
plViewReasonNumberFormatChange | 19
plViewReasonPropertyCaptionWidthChange | 71
plViewReasonPropertyHeightChange | 57
plViewReasonPropertyValueWidthChange | 56
plViewReasonRightToLeftChange | 24
plViewReasonSelectionChange | 0
plViewReasonSetFocus | 66
plViewReasonShowAsChange | 69
plViewReasonShowDetails | 58
plViewReasonSystemColorChange | 1
plViewReasonToolbarChange | 74
plViewReasonTopChange | 22
plViewReasonTopOffsetChange | 45
plViewReasonTotalCaptionChange | 31
plViewReasonTotalOrientationChange | 25
plViewReasonTotalWidthChange | 15
plViewReasonUseProviderFormattingChange | 75
plViewReasonViewDetailWidthChange | 13
plViewReasonWidthChange | 34
plViewReasonXMLApplied | 76

显示 PivotViewTotalOrientationEnum

常量 | 值
plTotalOrientationColumn | 2
plTotalOrientationRow | 1

显示 ProviderType

常量 | 值
providerTypeMultidimensional | 3
providerTypeRelational | 2
providerTypeUnknown | 1

显示 SectTypeEnum

常量 | 值
sectTypeCaption | 1
sectTypeFooter | 3
sectTypeHeader | 2
sectTypeNone | 0
sectTypeRecNav | 4

显示 SheetCommandEnum

常量 | 值
ssAutoFilter | 15
ssCalculate | 0
ssClear | 14
ssCopy | 7
ssCut | 6
ssDeleteColumns | 5
ssDeleteRows | 4
ssExport | 9
ssFind | 13
ssHelp | 17
ssInsertColumns | 3
ssInsertRows | 2
ssPaste | 8
ssProperties | 16
ssSortAscending | 11
ssSortDescending | 12
ssUndo | 10

显示 SheetExportActionEnum

常量 | 值
ssExportActionNone | 0
ssExportActionOpenInExcel | 1

显示 SheetExportFormat

常量 | 值
ssExportAsAppropriate | 0
ssExportHTML | 2
ssExportXMLSpreadsheet | 1

显示 SheetFilterFunction

常量 | 值
ssFilterFunctionExclude | 2
ssFilterFunctionInclude | 1

显示 SpreadSheetCommandId

常量 | 值
ssCommandAbout | 1007
ssCommandAutoFilter | 10001
ssCommandAutosum | 10000
ssCommandBold | 1052
ssCommandClear | 10002
ssCommandCopy | 1002
ssCommandCut | 1001
ssCommandDeleteCols | 10007
ssCommandDeleteQuery | 10071
ssCommandDeleteRows | 10006
ssCommandEat | 10054
ssCommandEditQuery | 10070
ssCommandEnterEditMode | 10038
ssCommandEscape | 10041
ssCommandExpandDown | 10033
ssCommandExpandLeft | 10030
ssCommandExpandMenu | 10053
ssCommandExpandPageDown | 10046
ssCommandExpandPageLeft | 10065
ssCommandExpandPageRight | 10063
ssCommandExpandPageUp | 10048
ssCommandExpandRight | 10032
ssCommandExpandToEndDown | 10037
ssCommandExpandToEndLeft | 10034
ssCommandExpandToEndRight | 10036
ssCommandExpandToEndUp | 10035
ssCommandExpandToHome | 10052
ssCommandExpandToLast | 10043
ssCommandExpandToOrigin | 10050
ssCommandExpandUp | 10031
ssCommandExport | 1004
ssCommandHelp | 1006
ssCommandInsertCols | 10009
ssCommandInsertRows | 10008
ssCommandItalic | 1053
ssCommandMakeActiveCellVisible | 10066
ssCommandMoveDown | 10017
ssCommandMoveLeft | 10014
ssCommandMoveNext | 10022
ssCommandMovePageDown | 10045
ssCommandMovePageLeft | 10064
ssCommandMovePageRight | 10062
ssCommandMovePageUp | 10047
ssCommandMovePrevious | 10023
ssCommandMoveRight | 10016
ssCommandMoveToEndDown | 10029
ssCommandMoveToEndLeft | 10026
ssCommandMoveToEndRight | 10028
ssCommandMoveToEndUp | 10027
ssCommandMoveToHome | 10051
ssCommandMoveToLast | 10042
ssCommandMoveToLastInRow | 10044
ssCommandMoveToOrigin | 10049
ssCommandMoveUp | 10015
ssCommandNewSheet | 10057
ssCommandNextSheet | 10055
ssCommandOpenHyperlink | 10073
ssCommandPaste | 1003
ssCommandPrevSheet | 10056
ssCommandProperties | 1005
ssCommandRecalc | 10059
ssCommandRecalcForce | 10010
ssCommandRefresh | 10060
ssCommandRefreshAll | 10061
ssCommandRefreshData | 10068
ssCommandSaveData | 10069
ssCommandScrollDown | 10021
ssCommandScrollLeft | 10018
ssCommandScrollRight | 10020
ssCommandScrollUp | 10019
ssCommandSelectAll | 10013
ssCommandSelectArray | 10058
ssCommandSelectArraySilent | 10067
ssCommandSelectCol | 10012
ssCommandSelectRow | 10011
ssCommandSetChartRange | 10072
ssCommandShowContextMenu | 10039
ssCommandSortAsc | 2000
ssCommandSortAscLast | 2030
ssCommandSortDesc | 2031
ssCommandSortDescLast | 2061
ssCommandTabNext | 10024
ssCommandTabPrevious | 10025
ssCommandToggleToolbar | 10040
ssCommandUnderline | 1054
ssCommandUndo | 1000

显示 SynchronizationStatus

常量 | 值
dscSynchronizationDone | 1
dscSynchronizing | 0

显示 TipTypeEnum

常量 | 值
eTipTypeAuto | 2
eTipTypeHTML | 1
eTipTypeNone | -1
eTipTypeText | 0

显示 UnderlineStyleEnum

常量 | 值
owcUnderlineStyleDouble | 2
owcUnderlineStyleDoubleAccounting | 4
owcUnderlineStyleNone | 0
owcUnderlineStyleSingle | 1
owcUnderlineStyleSingleAccounting | 3

显示 XlApplicationInternational

常量 | 值
xl24HourClock | 33
xl4DigitYears | 43
xlAlternateArraySeparator | 16
xlColumnSeparator | 14
xlCountryCode | 1
xlCountrySetting | 2
xlCurrencyBefore | 37
xlCurrencyCode | 25
xlCurrencyDigits | 27
xlCurrencyLeadingZeros | 40
xlCurrencyMinusSign | 38
xlCurrencyNegative | 28
xlCurrencySpaceBefore | 36
xlCurrencyTrailingZeros | 39
xlDateOrder | 32
xlDateSeparator | 17
xlDayCode | 21
xlDayLeadingZero | 42
xlDecimalSeparator | 3
xlGeneralFormatName | 26
xlHourCode | 22
xlLeftBrace | 12
xlLeftBracket | 10
xlListSeparator | 5
xlLowerCaseColumnLetter | 9
xlLowerCaseRowLetter | 8
xlMDY | 44
xlMetric | 35
xlMinuteCode | 23
xlMonthCode | 20
xlMonthLeadingZero | 41
xlMonthNameChars | 30
xlNoncurrencyDigits | 29
xlNonEnglishFunctions | 34
xlRightBrace | 13
xlRightBracket | 11
xlRowSeparator | 15
xlSecondCode | 24
xlThousandsSeparator | 4
xlTimeLeadingZero | 45
xlTimeSeparator | 18
xlUpperCaseColumnLetter | 7
xlUpperCaseRowLetter | 6
xlWeekdayNameChars | 31
xlYearCode | 19

显示 XlBordersIndex

常量 | 值
xlDiagonalDown | 5
xlDiagonalUp | 6
xlEdgeBottom | 9
xlEdgeLeft | 7
xlEdgeRight | 10
xlEdgeTop | 8
xlInsideHorizontal | 12
xlInsideVertical | 11

显示 XlBorderWeight

常量 | 值
xlHairline | 1
xlMedium | -4138
xlThick | 4
xlThin | 2

显示 XlCalculation

常量 | 值
xlCalculationAutomatic | -4105
xlCalculationManual | -4135
xlCalculationSemiautomatic | 2

显示 XlColorIndex

常量 | 值
xlColorIndexAutomatic | -4105
xlColorIndexNone | -4142

显示 XlConstants

常量 | 值
xlAutomatic | -4105
xlNone | -4142

显示 XlDeleteShiftDirection

常量 | 值
xlShiftToLeft | -4159
xlShiftUp | -4162

显示 XlDirection

常量 | 值
xlDown | -4121
xlToLeft | -4159
xlToRight | -4161
xlUp | -4162

显示 XlFindLookIn

常量 | 值
xlComments | -4144
xlFormulas | -4123
xlValues | -4163

显示 XlHAlign

常量 | 值
xlHAlignCenter | -4108
xlHAlignCenterAcrossSelection | 7
xlHAlignDistributed | -4117
xlHAlignFill | 5
xlHAlignGeneral | 1
xlHAlignJustify | -4130
xlHAlignLeft | -4131
xlHAlignRight | -4152

显示 XlInsertShiftDirection

常量 | 值
xlShiftDown | -4121
xlShiftToRight | -4161

显示 XlLineStyle

常量 | 值
xlContinuous | 1
xlDash | -4115
xlDashDot | 4
xlDashDotDot | 5
xlDot | -4118
xlDouble | -4119
xlLineStyleNone | -4142
xlSlantDashDot | 13

显示 XlLookAt

常量 | 值
xlPart | 2
xlWhole | 1

显示 XlOrientation

常量 | 值
xlDownward | -4170
xlHorizontal | -4128
xlUpward | -4171
xlVertical | -4166

显示 XlRangeValueType

常量 | 值
xlRangeValueCSV | 1001
xlRangeValueDefault | 10
xlRangeValueHTML | 1000
xlRangeValueXMLSpreadsheet | 11

显示 XlReadingOrder

常量 | 值
xlContext | -5002
xlLTR | -5003
xlRTL | -5004

显示 XlReferenceStyle

常量 | 值
xlA1 | 1
xlR1C1 | -4150

显示 XlSearchDirection

常量 | 值
xlNext | 1
xlPrevious | 2

显示 XlSearchOrder

常量 | 值
xlByColumns | 2
xlByRows | 1

显示 XlSheetType

常量 | 值
xlChart | -4109
xlDialogSheet | -4116
xlExcel4IntlMacroSheet | 4
xlExcel4MacroSheet | 3
xlWorksheet | -4167

显示 XlSheetVisibility

常量 | 值
xlSheetHidden | 0
xlSheetVeryHidden | 2
xlSheetVisible | -1

显示 XlSortOrder

常量 | 值
xlAscending | 1
xlDescending | 2

显示 XlUnderlineStyle

常量 | 值
xlUnderlineStyleDouble | -4119
xlUnderlineStyleDoubleAccounting | 5
xlUnderlineStyleNone | -4142
xlUnderlineStyleSingle | 2
xlUnderlineStyleSingleAccounting | 4

显示 XlVAlign

常量 | 值
xlVAlignBottom | -4107
xlVAlignCenter | -4108
xlVAlignDistributed | -4117
xlVAlignJustify | -4130
xlVAlignTop | -4160

显示 XlWindowType

常量 | 值
xlChartAsWindow | 5
xlChartInPlace | 4
xlClipboard | 3
xlInfo | -4129
xlWorkbook | 1

显示 XlYesNoGuess

常量 | 值
xlGuess | 0
xlNo | 2
xlYes | 1


BeforeQuery 事件

在数据透视表列表查询其数据源时发生。

Private Sub Object_BeforeQuery()

Object 要触发该事件的 PivotTable 对象名称。

说明

该事件的发生相当频繁。触发该事件的一些示例包括在数据透视表列表中添加字段、移动字段、排序或筛选数据。


OnConnect 事件

当数据透视表列表连接到数据源时发生。

Private Sub Object_OnConnect()

Object 要触发该事件的 PivotTable 对象名称。


OnDisconnect 事件

当数据透视表列表断开数据源或连接到其他数据源时发生。

Private Sub Object_OnDisconnect()

Object 要触发该事件的 PivotTable 对象名称。


创建使用数组指定的数据的图表

本示例创建使用数组指定的数据的图表。数组设置为分类和数值数据，然后使用 SetData 方法利用这些数组设置图表数据。

要运行本示例，请将本主题中的其余文本复制到 HTML 页。

<object id=ChartSpace1 classid=CLSID:0002E55D-0000-0000-C000-000000000046 style="width:100%;height:350"></object>

<script language=vbs>
Sub Window_OnLoad()

    Dim categories(3)
    Dim values(3)
    Dim chConstants

    ' Create an array of strings representing the categories.
    ' The categories will be the same for all three series.
    categories(0) = "Car"
    categories(1) = "Sport-Utility"
    categories(2) = "Truck"
    categories(3) = "Minivan"

    ' Clear the contents of the chart workspace. This removes
    ' any old charts that may already exist and leaves the chart workspace
    ' completely empty. One chart object is then added.
    ChartSpace1.Clear
    ChartSpace1.Charts.Add
    Set chConstants = ChartSpace1.Constants

    ' Add three series to the chart.
    ChartSpace1.Charts(0).SeriesCollection.Add
    ChartSpace1.Charts(0).SeriesCollection.Add
    ChartSpace1.Charts(0).SeriesCollection.Add

    ' Series one contains sales growth data for 1998.
    ' Set the series caption (the text that appears in the legend).
    ChartSpace1.Charts(0).SeriesCollection(0).Caption = "1998"

    ' Set the categories for the first series (this collection is zero-based)
    ChartSpace1.Charts(0).SeriesCollection(0).SetData chConstants.chDimCategories, chConstants.chDataLiteral, categories

    values(0) = 0.2
    values(1) = 0.06
    values(2) = 0.17
    values(3) = 0.13

    ChartSpace1.Charts(0).SeriesCollection(0).Caption = "1998"
    ChartSpace1.Charts(0).SeriesCollection(0).SetData chConstants.chDimCategories, chConstants.chDataLiteral, categories
    ChartSpace1.Charts(0).SeriesCollection(0).SetData chConstants.chDimValues, chConstants.chDataLiteral, values

    ' Series two contains sales growth data for 1999.
    ' Update the values array, then set the chart data.
    values(0) = 0.38
    values(1) = 0.82
    values(2) = 0.28
    values(3) = 0.62

    ChartSpace1.Charts(0).SeriesCollection(1).Caption = "1999"
    ChartSpace1.Charts(0).SeriesCollection(1).SetData chConstants.chDimCategories, chConstants.chDataLiteral, categories
    ChartSpace1.Charts(0).SeriesCollection(1).SetData chConstants.chDimValues, chConstants.chDataLiteral, values

    ' Series two contains sales growth data for 2000.
    ' Update the values array, and then set the chart data.
    values(0) = 0.42
    values(1) = 0.12
    values(2) = 0.55
    values(3) = 0.25

    ChartSpace1.Charts(0).SeriesCollection(2).Caption = "2000"
    ChartSpace1.Charts(0).SeriesCollection(2).SetData chConstants.chDimCategories, chConstants.chDataLiteral, categories
    ChartSpace1.Charts(0).SeriesCollection(2).SetData chConstants.chDimValues, chConstants.chDataLiteral, values

    ' Make the chart legend visible, format the left value axis as percentage,
    ' and specify that value gridlines are at 10% intervals.
    ChartSpace1.Charts(0).HasLegend = True
    ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionLeft).NumberFormat = "0%"
    ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionLeft).MajorUnit = 0.1
End Sub
</script>


创建使用 ADO 记录集数据的图表

本示例使用 ADO 记录集数据创建图表。利用返回的记录集数据创建制表符分隔的字符串，然后使用 SetData 方法利用该字符串设置图表数据。

要运行本示例，请将本主题中的其余文本复制到 HTML 页。

<object id=ChartSpace1 classid=CLSID:0002E55D-0000-0000-C000-000000000046 style="width:100%;height:350"></object>
<object id=ADOConnection1 classid=CLSID:00000514-0000-0010-8000-00AA006D2EA4></object>

<script language=vbs>
Sub Window_OnLoad()
    Dim rs, categories, values, c

    ' This example connects to the Northwind sample database
    ' and charts the Query "Category Sales for 1995". ADO is used to open a
    ' connection to the database and return the entire recordset. The query
    ' contains two columns: Category Name and Category Sales.
    ' The records are then extracted into strings.

    categories = ""
    values = ""

    ' Open the connection and execute the query.
    ADOConnection1.Open "DRIVER={Microsoft Access Driver (*.mdb)};DBQ=c:\nwind.mdb"
    Set rs = ADOConnection1.Execute("SELECT * FROM [Category Sales for 1995]")

    ' Start at the first record and move through the entire recordset.
    ' Field 0 is the category name, Field 1 is the sales value.
    ' Create a tab-delimited string for the names and one for the values.
    rs.MoveFirst
    Do While Not rs.EOF
        categories = categories & rs.Fields(0).Value & Chr(9)
        values = values & rs.Fields(1).Value & Chr(9)
        rs.MoveNext
    Loop
    rs.Close
    ADOConnection1.Close

    ' Remove the leftover tab character at the end of the strings.
    categories = Left(categories, Len(categories) - 1)
    values = Left(values, Len(values) - 1)

    ' Create a chart with one series (called "Sales").
    ChartSpace1.Clear
    ChartSpace1.Charts.Add
    ChartSpace1.Charts(0).SeriesCollection.Add
    ChartSpace1.Charts(0).SeriesCollection(0).Caption = "Sales"

    'Set the series categories and values using the strings created from the recordset.
    Set c = ChartSpace1.Constants
    ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimCategories, c.chDataLiteral, categories
    ChartSpace1.Charts(0).SeriesCollection(0).SetData c.chDimValues, c.chDataLiteral, values

    ' Set the chart type and format the axis as U.S. dollars.
    ChartSpace1.Charts(0).Type = c.chChartTypeBarClustered
    ChartSpace1.Charts(0).Axes(c.chAxisPositionBottom).NumberFormat = "$#,##0"
End Sub
</script>


创建使用 Microsoft Office 电子表格数据的图表

本示例创建使用 Microsoft Office 电子表格数据的图表。图表通过 DataSource 属性绑定到电子表格，然后使用 SetData 方法利用电子表格上的区域设置图表数据。

要运行本示例，请将本主题中的其余文本复制到 HTML 页。

<object id=ChartSpace1 classid=CLSID:0002E55D-0000-0000-C000-000000000046 style="width:49%;height:350"></object>
<object id=Spreadsheet1 classid=CLSID:0002E559-0000-0000-C000-000000000046 style="width:49%;height:350"></object>

<b>Source: </b>Industry Data
<p>

<script language=vbscript>
Sub Window_OnLoad()

    Dim chConstants

    Spreadsheet1.ActiveSheet.Cells.Clear
    Spreadsheet1.ActiveSheet.Cells(2, 1).Value = "Car"
    Spreadsheet1.ActiveSheet.Cells(3, 1).Value = "Sport-Utility"
    Spreadsheet1.ActiveSheet.Cells(4, 1).Value = "Truck"
    Spreadsheet1.ActiveSheet.Cells(5, 1).Value = "Minivan"

    Spreadsheet1.ActiveSheet.Cells(1, 2).Value = "1998"
    Spreadsheet1.ActiveSheet.Cells(2, 2).Value = 0.2
    Spreadsheet1.ActiveSheet.Cells(3, 2).Value = 0.06
    Spreadsheet1.ActiveSheet.Cells(4, 2).Value = 0.17
    Spreadsheet1.ActiveSheet.Cells(5, 2).Value = 0.13

    Spreadsheet1.ActiveSheet.Cells(1, 3).Value = "1999"
    Spreadsheet1.ActiveSheet.Cells(2, 3).Value = 0.38
    Spreadsheet1.ActiveSheet.Cells(3, 3).Value = 0.82
    Spreadsheet1.ActiveSheet.Cells(4, 3).Value = 0.28
    Spreadsheet1.ActiveSheet.Cells(5, 3).Value = 0.62

    Spreadsheet1.ActiveSheet.Cells(1, 4).Value = "2000"
    Spreadsheet1.ActiveSheet.Cells(2, 4).Value = 0.42
    Spreadsheet1.ActiveSheet.Cells(3, 4).Value = 0.12
    Spreadsheet1.ActiveSheet.Cells(4, 4).Value = 0.55
    Spreadsheet1.ActiveSheet.Cells(5, 4).Value = 0.25

    ' Clear the contents of the chart workspace. This removes
    ' any old charts that may already exist and leaves the chart workspace
    ' completely empty. One chart object is then added.
    ChartSpace1.Clear
    ChartSpace1.Charts.Add
    Set chConstants = ChartSpace1.Constants

    ' Set the chart DataSource property to the spreadsheet.
    ' It is possible to specify multiple data sources, but this example uses only one.
    ChartSpace1.DataSource = Spreadsheet1

    ' Add three series to the chart.
    ChartSpace1.Charts(0).SeriesCollection.Add
    ChartSpace1.Charts(0).SeriesCollection.Add
    ChartSpace1.Charts(0).SeriesCollection.Add

    ' Connect the chart to data by specifying spreadsheet cell references
    ' for the different data dimensions.
    ' Notice that the series name is also bound to a spreadsheet cell. Changing
    ' the contents of the cell "B1" will also change the name that appears in the legend.
    ' If you don't want this behavior, set SeriesCollection(0).Caption instead of
    ' using the SetData method to bind the series name to the spreadsheet.

    ' Series one contains sales growth data for 1998.
    ' Bind the series name, the category names, and the values.
    ChartSpace1.Charts(0).SeriesCollection(0).SetData chConstants.chDimSeriesNames, chConstants.chDataBound, "B1"
    ChartSpace1.Charts(0).SeriesCollection(0).SetData chConstants.chDimCategories, chConstants.chDataBound, "A2:A5"
    ChartSpace1.Charts(0).SeriesCollection(0).SetData chConstants.chDimValues, chConstants.chDataBound, "B2:B5"

    ' Series two contains sales growth data for 1999.
    ChartSpace1.Charts(0).SeriesCollection(1).SetData chConstants.chDimSeriesNames, chConstants.chDataBound, "C1"
    ChartSpace1.Charts(0).SeriesCollection(1).SetData chConstants.chDimCategories, chConstants.chDataBound, "A2:A5"
    ChartSpace1.Charts(0).SeriesCollection(1).SetData chConstants.chDimValues, chConstants.chDataBound, "C2:C5"

    ' Series two contains sales growth data for 2000.
    ChartSpace1.Charts(0).SeriesCollection(2).SetData chConstants.chDimSeriesNames, chConstants.chDataBound, "D1"
    ChartSpace1.Charts(0).SeriesCollection(2).SetData chConstants.chDimCategories, chConstants.chDataBound, "A2:A5"
    ChartSpace1.Charts(0).SeriesCollection(2).SetData chConstants.chDimValues, chConstants.chDataBound, "D2:D5"

    ' Make the chart legend visible, format the left value axis as percentage,
    ' and specify that value gridlines are at 10% intervals.
    ChartSpace1.Charts(0).HasLegend = True
    ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionLeft).NumberFormat = "0%"
    ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionLeft).MajorUnit = 0.1
End Sub
</script>


创建包含多个图表类型的图表

可以创建包含列、行和区域的组合图表。请注意组合的图表类型必须具有兼容的堆积（即，不能将堆积柱形图与折线图组合，只能将堆积柱形图与堆积折线图组合）。

图表和系列均具有 Type 属性。设置 ChChart 对象的 Type 属性将更改每个系列的图表类型。如果新系列的类型必须与图表中的其他系列兼容，则设置 ChSeries 对象的 Type 属性只更改该系列。如果新系列的类型不兼容，整个图表将更改类型以满足更改的系列。这意味着如果将簇状柱形图上的一个系列更改为折线系列，将创建一个组合的柱形-折线图。相反，如果试图将簇状柱形图上的一个系列更改为饼系列，则整个图表将成为饼图。


返回集合中的对象

Item 属性从集合中返回单个对象。本示例将变量 thisChart 设置为表示第一个图表的 ChChart 对象。

Set thisChart = ChartWorkspace1.Charts.Item(1)

Item 属性为大部分集合的默认属性，因此可以省略 Item 关键字更精简地编写同一语句。

Set thisChart = ChartWorkspace1.Charts(1)

某些集合使用枚举类型的 Item 属性返回集合的指定成员。例如，ChAxes 集合使用 ChartAxisPositionEnum 枚举类型，如下面示例所示。

Set chConstants = ChartSpace1.Constants
Set valueAxis = ChartSpace1.Charts(0).Axes.Item(chConstants.chAxisPositionLeft)
Set categoryAxis = ChartSpace1.Charts(0).Axes.Item(chConstants.chAxisPositionBottom)

可以再次省略 Item 关键字，如下面示例所示。

Set chConstants = ChartSpace1.Constants
Set valueAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionLeft)
Set categoryAxis = ChartSpace1.Charts(0).Axes(chConstants.chAxisPositionBottom)

有关指定集合的详细信息，请参阅该集合的帮助主题。


图表集合

为什么需要多个图表？

在许多情况下，可能在一个图表工作区中使用多个图表。如下是一些典型情形：

  • 需要具有多个饼图。
  • 需要显示价格和成交量的股票图。
  • 希望以一个在图表间切换的变量比较相似信息。按地区显示学校智商测验 (SAT) 的图表就是一个示例。这可能涉及四个图表：北部、南部、东部和西部，每个图表按平均分数比较地区内的学校管区。


RemoveFileProperties 属性

该属性确定是否随数据访问页保存个人信息。将该属性设置为 True 可从数据访问页删除个人信息。

将该属性设置为 True 将从数据访问页删除下列信息：

  • 作者

  • 上次保存者

  • 公司名称


Trendlines 属性

返回指定系列的 ChTrendlines 集合。请注意一个系列只能有一个趋势线。

expression.Trendlines

expression 必需。该表达式返回 ChSeries 对象。

说明

有关返回单个集合成员的详细信息，请参阅返回集合中的对象。

示例

本示例为指定系列添加趋势线，并隐藏趋势线的 R 平方值。

Sub AddTrendline()

   Dim serSeries1

   ' Set a variable to the first series in the first chart of Chartspace1.
   Set serSeries1 = ChartSpace1.Charts(0).SeriesCollection(0)

   ' Add a trendline to the series.
   serSeries1.Trendlines.Add

   ' Hide the R Squared value for the trendline.
   serSeries1.Trendlines(0).IsDisplayingRSquared = False

End Sub


图表工作区对象模型

ChartSpace
ChBorder
ChCharts
ChChart
ChAxes
ChAxis
ChCategoryLabels
ChCategoryLabel
PivotResultGroupAxis
PivotAxis
PivotAxisMember
PivotData
PivotFields
PivotResultGroupFields
PivotResultLabel
ChFont
ChGridlines
ChLine
Coordinate
ChPlotArea
ChSurface
ChScaling
ChScrollView
ChSeriesCollection
ChSeries
ChDataLabelsCollection
ChDataLabels
ChErrorBarsCollection
ChErrorBars
ChFormatMap
ChSegments
ChLine
ChMarker
ChPoints
ChPoint
ChTrendlines
ChTrendline
PivotResultGroupAxis
ChInterior
ChLegend
ChFont
ChLegendEntries
ChLegendEntry
ChSelectionCollection
ChTitle
ChFont
OCCommands
OCCommand
OWCLanguageSettings

图例

对象和集合
仅对象


DataSourceControl 对象模型

DataSourceControl
AllGroupingDefs
GroupingDef
PageFields
PageField
PageRowsource
LookupRelationships
RecordsetDef
GroupingDefs
PageRowsources
ParameterValues
ParameterValue
SublistRelationships
AllPageFields
PageField
PageRowsource
LookupRelationships
PageFields
RecordsetDef
GroupingDefs
GroupingDef
PageFields
PageRowsources
ParameterValues
SublistRelationships
DataPages
DataPage
GroupLevel
ElementExtensions
ElementExtension
GroupLevels
GroupLevel
RecordsetDefs
RecordsetDef
GroupingDefs
GroupingDef
PageFields
PageRowsource
LookupRelationships
PageRelationship
PageRelatedFields
PageRowsources
ParameterValues
SublistRelationships
PageRelationship
SchemaRelationships
SchemaRelationship
SchemaRelatedFields
SchemaRowsources
SchemaRowsource
LookupSchemaRelationships
SchemaRelationship
SchemaRelatedFields
SchemaFields
SchemaField
SchemaParameters
SchemaParameter
SchemaProperties
SchemaProperty
SublistSchemaRelationships
SchemaRelationship
SchemaRelatedFields
Section
DataPage
GroupLevel

图例

对象和集合
仅对象


Microsoft Office Web Components 对象模型

请从下面列表中选择对象模型。

图表工作区对象模型

数据源控件对象模型

数据透视表列表对象模型

电子表格对象模型


PivotTable 对象模型

PivotTable
OCCommands
OCCommand
PivotData
PivotCell
PivotAggregates
PivotAggregate
PivotTotal
PivotField
PivotFieldSet
PivotFont
PivotMember
PivotMemberProperties
PivotMembers
PivotDetailCell
PivotField
PivotFieldSet
PivotFont
PivotMember
PivotMemberProperties
PivotMemberProperty
PivotMembers
PivotTotal
PivotHyperlink
PivotDetailRange
PivotFields
PivotField
PivotFieldSet
PivotFont
PivotMember
PivotMemberProperties
PivotMembers
PivotTotal
PivotPageMember
PivotAxisMember
PivotAxisMembers
PivotField
PivotFieldSet
PivotFont
PivotMemberProperties
PivotTotal
PivotHyperlink
PivotMember
PivotMembers
PivotPageMembers
PivotResultGroupAxis
PivotAxis
PivotFieldSets
PivotLabel
PivotFields
PivotResultGroupFields
PivotResultGroupField
PivotResultAxis
PivotAxis
PivotResultMemberProperties
PivotResultMemberProperty
PivotMemberProperty
PivotColumnMember
PivotAxisMember
PivotAxisMembers
PivotField
PivotFieldSet
PivotFont
PivotMemberProperties
PivotTotal
PivotHyperlink
PivotMember
PivotMembers
PivotResultGroupAxis
PivotAxis
PivotFields
PivotResultGroupFields
PivotResultGroupField
PivotResultAxis
PivotAxis
PivotFieldSets
PivotLabel
PivotResultMemberProperties
PivotResultMemberProperty
PivotColumnMembers
PivotRange
PivotResultColumnAxis
PivotAxis
PivotAxisMember
PivotFields
PivotGroupAxis
PivotResultGroupFields
PivotResultDataAxis
PivotAxis
PivotDataAxis
PivotFields
PivotTotals
PivotResultFilterAxis
PivotAxis
PivotFieldSets
PivotFilterAxis
PivotResultLabel
PivotLabel
PivotResultPageAxis
PivotAxis
PivotAxisMember
PivotFields
PivotGroupAxis
PivotPageMember
PivotResultGroupFields
PivotResultRowAxis
PivotAxis
PivotAxisMember
PivotFields
PivotGroupAxis
PivotResultGroupFields
PivotRowMember
PivotAxisMember
PivotAxisMembers
PivotField
PivotHyperlink
PivotMember
PivotMembers
PivotResultGroupAxis
PivotResultGroupField
PivotResultMemberProperties
PivotRowMembers
PivotView
PivotDataAxis
PivotFieldSet
PivotField
PivotMemberProperties
PivotMembers
PivotFields
PivotMember
PivotMembers
PivotFieldSets
PivotFilterAxis
PivotFont
PivotGroupAxis
PivotLabel
PivotTotal
PivotField
PivotMember
PivotMemberProperties
PivotMembers
PivotTotals

图例

对象和集合
仅对象


电子表格对象模型

Spreadsheet
Names
OCCommands
OCCommand
OWCLanguageSettings
Range
Borders
Border
Font
Hyperlink
Interior
Name
Sheets
TitleBar
Font
Interior
Windows
Window
Headings
Heading
Panes
Pane
Workbooks
Workbook
XmlDataBindings
XmlDataBinding
XmlMaps
XmlMap
Worksheets
Worksheet
AutoFilter
Filters
Filter
ListObjects
ListObject
ListRows
ListRow
Protection

图例

对象和集合
仅对象


DataSourceControl 对象


ChartSpace 对象


ChartSpace 对象

AllowLayoutEvents 属性


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

BeforeKeyPress 事件

BeforeKeyUp 事件

KeyDown 事件

KeyPress 事件

KeyUp 事件


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

BeforeKeyDown 事件

BeforeKeyUp 事件

KeyDown 事件

KeyPress 事件

KeyUp 事件


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

BeforeKeyDown 事件

BeforeKeyPress 事件

KeyDown 事件

KeyPress 事件

KeyUp 事件


PivotTable 对象


ChartSpace 对象

PivotTable 对象


Spreadsheet 对象


RecordNavigationControl 对象


Range 对象


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

ButtonClick 事件

DblClick 事件

File Not Found

File Not Found

MouseDown 事件

MouseMove 事件

MouseUp 事件


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

CommandChecked 事件

CommandEnabled 事件

CommandExecute 事件


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

CommandBeforeExecute 事件

CommandEnabled 事件

CommandExecute 事件


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

CommandBeforeExecute 事件

CommandChecked 事件

CommandExecute 事件


DataSourceControl 对象

DSCEventInfo 对象


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

ButtonClick 事件

Click 事件

File Not Found

File Not Found

MouseDown 事件

MouseMove 事件

MouseUp 事件


PivotTable 对象

Spreadsheet 对象


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

BeforeKeyDown 事件

BeforeKeyPress 事件

BeforeKeyUp 事件

KeyPress 事件

KeyUp 事件


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

BeforeKeyDown 事件

BeforeKeyPress 事件

BeforeKeyUp 事件

KeyDown 事件

KeyUp 事件


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

BeforeKeyDown 事件

BeforeKeyPress 事件

BeforeKeyUp 事件

KeyDown 事件

KeyPress 事件


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

ButtonClick 事件

Click 事件

DblClick 事件

File Not Found

File Not Found

MouseMove 事件

MouseUp 事件


ChartSpace 对象

PivotTable 对象

ButtonClick 事件

Click 事件

DblClick 事件

File Not Found

File Not Found

MouseDown 事件

MouseUp 事件


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

ButtonClick 事件

Click 事件

DblClick 事件

File Not Found

File Not Found

MouseDown 事件

MouseMove 事件


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

File Not Found

File Not Found

MouseDown 事件

MouseMove 事件

MouseUp 事件


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

File Not Found

Select 方法

Selection 属性

SelectionType 属性


在 VBScript 中使用命名常量


创建使用 Microsoft Office 电子表格数据的图表

创建使用 ADO 记录集数据的图表


创建使用 Microsoft Office 电子表格数据的图表

创建使用数组指定的数据的图表


创建使用 ADO 记录集数据的图表

创建使用数组指定的数据的图表


Add 方法

Delete 方法

ExportMetaData 方法

ExportXML 方法

FireParametersOut 方法

GetDataPointVisible 方法

ImportXml 方法

OverrideDefaultElementFormatting 方法

Refresh 方法

Select2 方法

SetExtent 方法

SetPosition 方法

TextHeight 方法

TextWidth 方法

Update 方法

Validate 方法


Add 方法

Delete 方法

ExportMetaData 方法

ExportXML 方法

FireParametersOut 方法

GetDataPointVisible 方法

ImportXml 方法

OverrideDefaultElementFormatting 方法

Refresh 方法

Select2 方法

SetExtent 方法

SetPosition 方法

Update 方法

Validate 方法


ChScrollView 对象

ChSelectionCollection 集合

ListObject 对象

ListObjects 集合

ListRow 对象

ListRows 集合

XmlDataBinding 对象

XmlDataBindings 集合

XmlMap 对象

XmlMaps 集合


Active 属性

AllowUISelection 属性

Async 属性

BarWidth 属性

BindingData 属性

BindingInProgress 属性

CanQuery 属性

CanUpdate 属性

DataBodyRange 属性

DefaultQueryOnLoad 属性

HeaderRowRange 属性

HorizontalExtent 属性

HorizontalExtentMax 属性

HorizontalPosition 属性

InsertRowRange 属性

ListObject 属性

ListObjects 属性

ListRows 属性

LoadMode 属性

MapData 属性

PropNames 属性

ScrollView 属性

SelectionCollection 属性

VerticalExtent 属性

VerticalExtentMax 属性

VerticalPosition 属性

XmlDataBindings 属性

XmlMap 属性

XmlMaps 属性


Active 属性

AllowUISelection 属性

Async 属性

BarWidth 属性

BindingData 属性

BindingInProgress 属性

CanQuery 属性

CanUpdate 属性

DataBodyRange 属性

DefaultQueryOnLoad 属性

HeaderRowRange 属性

HorizontalExtent 属性

HorizontalExtentMax 属性

HorizontalPosition 属性

InsertRowRange 属性

ListObject 属性

ListRows 属性

LoadMode 属性

MapData 属性

PropNames 属性

ScrollView 属性

SelectionCollection 属性

SubtotalBackColor 属性

SubtotalFont 属性

SubtotalLabelBackColor 属性

SubtotalLabelFont 属性

SubtotalLabelForeColor 属性

SubtotalLabelHAlignment 属性

VerticalExtent 属性

VerticalExtentMax 属性

VerticalPosition 属性

XmlDataBindings 属性

XmlMap 属性

XmlMaps 属性


Select 方法


ChAxes 集合

ChCharts 集合

ChDataLabelsCollection 集合

ChErrorBarsCollection 对象

ChSegments 对象

ChSeriesCollection 集合对象

ChTrendlines 集合

Criteria 对象

ElementExtensions 集合对象

GroupingDefs 集合对象

GroupLevels 集合对象

ListRows 集合

LookupRelationships 集合对象

Names 集合

PageFields 集合对象

ParameterValues 集合对象

RecordsetDefs 集合对象

SchemaFields 集合对象

SchemaParameters 集合对象

SchemaRelatedFields 集合对象

SchemaRelationships 集合对象

SchemaRowsources 集合对象

Sheets 集合

SublistRelationships 集合对象

Worksheets 集合对象

XmlDataBindings 集合

XmlMaps 集合


PivotFieldSet 对象


PivotView 对象


PivotField 对象


Spreadsheet 对象

HasAutoMajorUnit 属性


RecordsetDefs 集合对象

RecordsetDef 对象


RemoveTotal 方法


AutoFilter 对象

AutoFilter 方法


DataPage 对象

DataPage 对象


PivotView 对象

ActiveView 属性


ChChartDraw 对象


ChartSpace 对象

Spreadsheet 对象

EnableUndo 属性

EndUndo 方法

Undo 方法


Range 对象

Range 对象


Range 对象

Spreadsheet 对象

Worksheet 对象

CalculateFull 方法

Calculation 属性


ChartSpace 对象

Range 对象

ClearContents 方法

ClearFormats 方法

Delete 方法


Section 对象


PivotTable 对象

Range 对象

Sheets 集合

Worksheet 对象

Worksheets 集合对象

Cut 方法

Paste 方法


Range 对象

Spreadsheet 对象


ChAxes 集合

ChCharts 集合

ChDataLabelsCollection 集合

ChErrorBarsCollection 对象

ChSegments 对象

ChSeriesCollection 集合对象

ChTrendlines 集合

ElementExtensions 集合对象

GroupingDefs 集合对象

GroupLevels 集合对象

Hyperlink 对象

ListRow 对象

LookupRelationships 集合对象

Name 对象

PageFields 集合对象

ParameterValues 集合对象

PivotHyperlink 对象

Range 对象

RecordsetDefs 集合对象

SchemaFields 集合对象

SchemaRelationships 集合对象

SchemaRowsources 集合对象

Sheets 集合

SublistRelationships 集合对象

Worksheet 对象

Worksheets 集合对象

XmlDataBinding 对象

XmlMap 对象

Clear 方法


PivotField 对象

AddCustomGroupMember 方法


PivotView 对象

AddFieldSet 方法


DataPage 对象

NewRecord 方法


PivotView 对象

AddCalculatedTotal 方法


ChartSpace 对象

ChDropZone 对象


ChChart 对象


ChChartDraw 对象

BeginObject 方法


ChartSpace 对象

Spreadsheet 对象

BeginUndo 方法

EnableUndo 属性

Undo 方法


Spreadsheet 对象

Worksheet 对象


DataSourceControl 对象

OCCommand 对象


PivotTable 对象

Spreadsheet 对象

ExportPicture 方法

ExportXML 方法


XmlMap 对象


ChartSpace 对象

PivotTable 对象

Export 方法

ExportXML 方法


DataSourceControl 对象

XmlMap 对象

Export 方法

ExportPicture 方法


Range 对象

FillRight 方法


Range 对象

FillDown 方法


ChPlotArea 对象

FlipVertical 方法


ChPlotArea 对象

FlipHorizontal 方法


Hyperlink 对象

PivotHyperlink 对象

Hyperlink 属性

Subaddress 属性


ChSeries 对象


ChartSpace 对象

ExportPicture 方法


ChPoint 对象


ChSeries 对象

Ungroup 方法


ShowDetails 方法


Range 对象

Delete 方法


RemoveFieldSet 方法


PivotDataAxis 对象

RemoveTotal 方法


DataPage 对象

RecordNavigationControl 对象


Names 集合


Window 对象

SmallScroll 方法


ChartSpace 对象

LoadText 方法


Range 对象

Load 方法


Range 对象

UnMerge 方法


ButtonClick 事件

Click 事件

DblClick 事件

File Not Found

MouseDown 事件

MouseMove 事件

MouseUp 事件


Sheets 集合

Worksheet 对象

Worksheets 集合对象

MoveDetailLeft 方法

MoveDetailTop 方法

MoveFirst 方法

MoveLast 方法

MoveLeft 方法

MoveNext 方法

MovePrevious 方法

MoveTop 方法


PivotColumnMember 对象


PivotCell 对象


DataPage 对象


PivotData 对象


DataPage 对象

DeleteRecord 方法


Range 对象

Worksheet 对象

Copy 方法

Cut 方法


Window 对象

PointsToScreenPixelsY 方法


Window 对象

PointsToScreenPixelsX 方法


Unprotect 方法


ChartSpace 对象

Window 对象


Spreadsheet 对象

RectUnion 方法


Spreadsheet 对象

RectIntersect 方法


Repaint 方法


AddFieldSet 方法


PivotDataAxis 对象

AddTotal 方法


Refresh 方法


Heading 对象

ResetHeadings 方法


Workbook 对象


Window 对象

Reset 方法


ChPlotArea 对象


Window 对象

Show 方法


ChartSpace 对象

ChAxis 对象

ChCategoryLabel 对象

ChChart 对象

ChChartField 对象

ChDataLabel 对象

ChDataLabels 对象

ChErrorBars 对象

ChGridlines 对象

ChLegend 对象

ChLegendEntry 对象

ChPlotArea 对象

ChPoint 对象

ChSeries 对象

ChSurface 对象

ChTitle 对象

ChTrendline 对象

PivotTable 对象

Range 对象

Sheets 集合

Worksheet 对象

Worksheets 集合对象


Select 方法

Selection 属性

SelectionChange 事件

SelectionType 属性


ChartSpace 对象

ChChart 对象

ChErrorBars 对象

ChSeries 对象

ConnectionString 属性

DataSource 属性

DataSourceName 属性


ChScrollView 对象


ChInterior 对象


SetData 方法


Range 对象

ScrollIntoView 方法


Worksheet 对象


BeforeContextMenu 事件


HideDetails 方法


Window 对象

LargeScroll 方法


Range 对象

AllowSorting 属性


DataPage 对象

SortDescending 方法


DataPage 对象

SortAscending 方法


ChartSpace 对象

DataPage 对象

Spreadsheet 对象

BeginUndo 方法

DataPage 属性

DSCEventInfo 对象

EnableUndo 属性

EndUndo 方法

ReturnValue 属性

Section 属性


ChSeries 对象

Group 方法


Workbook 对象

Worksheet 对象

Enabled 属性

Protect 方法

Protection 对象


XmlDataBinding 对象


ChAxis 对象

ChSeries 对象

Coordinate 对象

X 属性

Y 属性


PageFields 集合对象


Count 属性

Item 属性

DataSourceControl 对象

不支持的语言元素

PageRowsource 对象

RecordsetDef 对象


Apply 方法

Filter 对象

Filters 集合对象

Worksheet 对象

Filters 集合对象

Range 对象

Worksheet 对象

Worksheet 对象


Value 属性


AllowFiltering 属性

AllowGrouping 属性

AllowLayoutEvents 属性

AllowPointRenderEvents 属性

AllowPropertyToolbox 属性

AllowRenderEvents 属性

AllowScreenTipEvents 属性

AllowUISelection 属性

Border 属性

Bottom 属性

BuildNumber 属性

CanUndo 属性

ChartLayout 属性

Charts 属性

ChartSpaceLegend 属性

ChartSpaceTitle 属性

ChartWrapCount 属性

Commands 属性

CommandText 属性

ConnectionString 属性

Constants 属性

DataMember 属性

DataSource 属性

DataSourceName 属性

DataSourceType 属性

DisplayFieldButtons 属性

DisplayFieldList 属性

DisplayOfficeLogo 属性

DisplayPropertyToolbox 属性

DisplayScreenTips 属性

DisplayToolbar 属性

EnableEvents 属性

HasChartSpaceLegend 属性

HasChartSpaceTitle 属性

HasMultipleCharts 属性

HasPassiveAlerts 属性

HasPlotDetails 属性

HasRuntimeSelection 属性

HasSelectionMarks 属性

HasSeriesByRows 属性

HasUnifiedScales 属性

Interior 属性

InternalPivotTable 属性

International 属性

LanguageSettings 属性

Left 属性

MajorVersion 属性

MinorVersion 属性

ObjectType 属性

Parent 属性

PlotAllAggregates 属性

PrintQuality3D 属性

RevisionNumber 属性

Right 属性

ScreenUpdating 属性

Selection 属性

SelectionCollection 属性

SelectionType 属性

Toolbar 属性

Top 属性

Version 属性

ViewOnlyMode 属性

XMLData 属性

BeginUndo 方法

Clear 方法

DropZones 方法

EndUndo 方法

ExportPicture 方法

GetPicture 方法

Load 方法

RangeFromPoint 方法

Refresh 方法

Repaint 方法

Select 方法

SetData 方法

SetSpreadsheetData 方法

ShowContextMenu 方法

ShowHelp 方法

Undo 方法

AfterFinalRender 事件

AfterLayout 事件

AfterRender 事件

BeforeContextMenu 事件

BeforeKeyDown 事件

BeforeKeyPress 事件

BeforeKeyUp 事件

BeforeRender 事件

BeforeScreenTip 事件

Click 事件

CommandBeforeExecute 事件

CommandChecked 事件

CommandEnabled 事件

CommandExecute 事件

CommandTipText 事件

DataSetChange 事件

DblClick 事件

KeyDown 事件

KeyPress 事件

KeyUp 事件

MouseDown 事件

MouseMove 事件

MouseUp 事件

MouseWheel 事件

SelectionChange 事件

ViewChange 事件


Bottom 属性

CategoryLabels 属性

Crosses 属性

CrossesAtValue 属性

CrossingAxis 属性

Font 属性

GroupingTotalFunction 属性

GroupingType 属性

GroupingUnit 属性

GroupingUnitType 属性

HasAutoMajorUnit 属性

HasAutoMinorUnit 属性

HasMajorGridlines 属性

HasMinorGridlines 属性

HasTickLabels 属性

HasTitle 属性

Index 属性

Left 属性

Line 属性

MajorGridlines 属性

MajorTickMarks 属性

MajorUnit 属性

MinorGridlines 属性

MinorTickMarks 属性

MinorUnit 属性

Name 属性

NumberFormat 属性

ObjectType 属性

Orientation 属性

Parent 属性

Position 属性

Right 属性

Scaling 属性

TickLabelSpacing 属性

TickLabelUnitType 属性

TickMarkSpacing 属性

TickMarkUnitType 属性

Title 属性

Top 属性

Type 属性


ChartSpace 对象

ChChart 对象

ChChartDraw 对象

不支持的语言元素

ChDataLabel 对象

ChDataLabels 对象

ChDropZone 对象

ChLegend 对象

ChPlotArea 对象

ChPoint 对象

ChSegmentBoundary 对象

ChSeries 对象

ChSurface 对象

ChTitle 对象


ChAxis 对象


AmbientLightIntensity 属性

AspectRatio 属性

Axes 属性

BarWidth 属性

Border 属性

Bottom 属性

BubbleScale 属性

ChartDepth 属性

DirectionalLightInclination 属性

DirectionalLightIntensity 属性

DirectionalLightRotation 属性

ExtrudeAngle 属性

FirstSliceAngle 属性

GapDepth 属性

GapWidth 属性

HasAutoAspectRatio 属性

HasAutoChartDepth 属性

HasLegend 属性

HasTitle 属性

HeightRatio 属性

HoleSize 属性

Inclination 属性

Index 属性

Interior 属性

Left 属性

Legend 属性

LightNormal 属性

Name 属性

ObjectType 属性

Overlap 属性

Parent 属性

Perspective 属性

PlotArea 属性

ProjectionMode 属性

Right 属性

Rotation 属性

Scalings 属性

ScrollView 属性

SeriesCollection 属性

SizeRepresents 属性

Title 属性

Top 属性

Type 属性

WidthRatio 属性


BeginObject 方法

DrawEllipse 方法

DrawLine 方法

DrawPolygon 方法

DrawPolyLine 方法

DrawRectangle 方法

DrawText 方法

EndObject 方法

OverrideDefaultElementFormatting 方法

TextHeight 方法

TextWidth 方法


Select 方法

ChDropZone 对象

ChDropZone 对象


ChDropZone 对象


Count 属性

Item 属性

Parent 属性

Add 方法

Delete 方法

ChartSpace 对象

不支持的语言元素

ChAxes 集合

ChBorder 对象

ChInterior 对象

ChLegend 对象

ChPlotArea 对象

ChScaling 对象

ChScrollView 对象

ChSeriesCollection 集合对象

ChTitle 对象


Border 属性

Bottom 属性

Count 属性

Font 属性

HasBubbleSize 属性

HasCategoryName 属性

HasPercentage 属性

HasSeriesName 属性

HasValue 属性

Index 属性

Interior 属性

Item 属性

Left 属性

NumberFormat 属性

ObjectType 属性

Parent 属性

Position 属性

Right 属性

Separator 属性

Top 属性

Select 方法


Bottom 属性

ButtonBorder 属性

ButtonFont 属性

ButtonInterior 属性

ChartFields 属性

Index 属性

Left 属性

ObjectType 属性

Parent 属性

Right 属性

Top 属性

WatermarkBorder 属性

WatermarkFont 属性

WatermarkInterior 属性


Bold 属性

Color 属性

Italic 属性

Name 属性

Size 属性

Underline 属性

ChAxis 对象

ChChartDraw 对象

ChDataLabel 对象

ChDataLabels 对象

ChDropZone 对象

ChLegend 对象

ChLegendEntry 对象

ChTitle 对象


Segments 属性

ChSegments 对象

ChSeries 对象

ChSegments 对象


Select 方法

ChAxis 对象


BackColor 属性

Color 属性

DefaultColor 属性

FillType 属性

GradientDegree 属性

GradientStyle 属性

GradientVariant 属性

Pattern 属性

PresetGradientType 属性

PresetTexture 属性

TextureFormat 属性

TextureName 属性

TexturePlacement 属性

TextureStackUnit 属性

SetOneColorGradient 方法

SetPatterned 方法

SetPresetGradient 方法

SetSolid 方法

SetTextured 方法

SetTwoColorGradient 方法

ChartSpace 对象

ChChart 对象

ChChartDraw 对象

不支持的语言元素

ChDataLabel 对象

ChDataLabels 对象

ChDropZone 对象

ChLegend 对象

ChPlotArea 对象

ChPoint 对象

ChSegmentBoundary 对象

ChSeries 对象

ChSurface 对象

ChTitle 对象


ChLegend 对象


Select 方法

ChLegend 对象


Color 属性

DashStyle 属性

Miter 属性

Weight 属性

ChAxis 对象

ChChartDraw 对象

ChErrorBars 对象

ChGridlines 对象

ChPoint 对象

ChSegmentBoundary 对象

ChSeries 对象

ChTrendline 对象


BackWall 属性

Border 属性

Bottom 属性

Floor 属性

Interior 属性

Left 属性

ObjectType 属性

Parent 属性

Right 属性

SideWall 属性

Top 属性

FlipHorizontal 方法

FlipVertical 方法

RotateClockwise 方法

RotateCounterClockwise 方法

Select 方法

ChChart 对象

ChSurface 对象

ChBorder 对象

ChChart 对象

ChInterior 对象

ChSurface 对象


HasAutoMaximum 属性

HasAutoMinimum 属性

HasSplit 属性

LogBase 属性

Maximum 属性

Minimum 属性

Orientation 属性

SplitMaximum 属性

SplitMinimum 属性

Type 属性

ChAxis 对象

ChChart 对象

ChSeries 对象


Bottom 属性

HorizontalExtent 属性

HorizontalExtentMax 属性

HorizontalPosition 属性

Left 属性

Right 属性

Top 属性

VerticalExtent 属性

VerticalExtentMax 属性

VerticalPosition 属性

SetExtent 方法

SetPosition 方法

ChChart 对象


ChFormatMap 对象

ChSegmentBoundary 对象


ChSegment 对象


ChFormatMap 对象


Count 属性

Item 属性

Parent 属性

ChartSpace 对象

不支持的语言元素


Border 属性

Bottom 属性

Caption 属性

DataLabelsCollection 属性

ErrorBarsCollection 属性

Explosion 属性

FormatMap 属性

GapWidth 属性

Index 属性

Interior 属性

Left 属性

Line 属性

Marker 属性

Name 属性

ObjectType 属性

Overlap 属性

Parent 属性

PivotObject 属性

Points 属性

Right 属性

Scalings 属性

Thickness 属性

TipText 属性

Top 属性

Trendlines 属性

Type 属性

ZOrder 属性

GetDataPointVisible 方法

Group 方法

Select 方法

SetData 方法

Ungroup 方法

ValueToPoint 方法

ChDataLabels 对象

ChDataLabelsCollection 集合

ChErrorBars 对象

ChErrorBarsCollection 对象

ChPoint 对象

ChPoints 集合

ChSeriesCollection 集合对象

ChTrendline 对象

ChTrendlines 集合

ChBorder 对象

ChChart 对象

ChDataLabelsCollection 集合

ChErrorBarsCollection 对象

ChFormatMap 对象

ChInterior 对象

ChLine 对象

ChMarker 对象

ChPoints 集合

ChScaling 对象

ChTrendlines 集合


Select 方法

ChPlotArea 对象


Bottom 属性

Caption 属性

DataLabel 属性

HasAutoCaption 属性

Index 属性

IsDisplayingEquation 属性

IsDisplayingRSquared 属性

Left 属性

Line 属性

ObjectType 属性

Order 属性

Parent 属性

Period 属性

Right 属性

Top 属性

Type 属性

Select 方法

ChSeries 对象


id 属性

Parent 属性


X 属性

Y 属性


Add 方法

Filter 对象

Filter 对象


ApplyFilter 方法

DeleteRecord 方法

IsButtonEnabled 方法

MoveFirst 方法

MoveLast 方法

MoveNext 方法

MovePrevious 方法

NewRecord 方法

Requery 方法

Save 方法

SortAscending 方法

SortDescending 方法

ToggleFilter 方法

Undo 方法


Count 属性

Item 属性

DataSourceControl 对象

不支持的语言元素

GroupLevel 对象

Section 对象


AllGroupingDefs 属性

AllPageFields 属性

BuildNumber 属性

Connection 属性

ConnectionFile 属性

ConnectionString 属性

Constants 属性

CurrentSection 属性

DataEntry 属性

DataPages 属性

DefaultControlType 属性

DefaultRecordset 属性

DisplayAlerts 属性

ElementExtensions 属性

GridX 属性

GridY 属性

GroupLevels 属性

MajorVersion 属性

MaxRecords 属性

MinorVersion 属性

Offline 属性

OfflinePublication 属性

OfflineSource 属性

OfflineType 属性

RecordsetDefs 属性

RecordsetType 属性

RevisionNumber 属性

SchemaRelationships 属性

SchemaRowsources 属性

UseRemoteProvider 属性

UseXMLData 属性

Version 属性

XMLDataTarget 属性

XMLLocation 属性

EuroConvert 方法

Execute 方法

ExportXML 方法

GetContainingSection 方法

Nz 方法

RefreshJetCache 方法

SetRootRecordset 方法

AfterDelete 事件

AfterInsert 事件

AfterUpdate 事件

BeforeCollapse 事件

BeforeDelete 事件

BeforeExpand 事件

BeforeFirstPage 事件

BeforeInitialBind 事件

BeforeInsert 事件

BeforeLastPage 事件

BeforeNextPage 事件

BeforeOverwrite 事件

BeforePreviousPage 事件

BeforeUpdate 事件

Current 事件

DataError 事件

DataPageComplete 事件

Dirty 事件

Focus 事件

RecordExit 事件

RecordsetSaveProgress 事件

Undo 事件

AllGroupingDefs 集合对象

AllPageFields 集合对象

DataPages 集合对象

ElementExtensions 集合对象

GroupLevels 集合对象

RecordsetDefs 集合对象

SchemaRelationships 集合对象

SchemaRowsources 集合对象

Section 对象


Connection 属性

DataPage 属性

DisplayAlert 属性

Error 属性

PercentComplete 属性

ReturnValue 属性

Section 属性

Status 属性

DataPage 对象

Section 对象


AlternateDataSource 属性

ChildLabel 属性

ConsumesRecordset 属性

ControlSource 属性

DefaultValue 属性

ElementID 属性

Format 属性

ListBoundField 属性

ListDisplayField 属性

ListRowSource 属性

RecordsetLabel 属性

RecordSource 属性

ResyncCommand 属性

ServerFilter 属性

TotalType 属性

UniqueTable 属性


ElementExtension 对象


Application 属性

Criteria 属性

Parent 属性

Criteria 对象

Filters 集合对象

AutoFilter 对象

Criteria 对象


AutoFilter 对象


Application 属性

Bold 属性

Color 属性

ColorIndex 属性

Italic 属性

Name 属性

Parent 属性

Size 属性

Underline 属性

Range 对象

TitleBar 对象


RecordsetDef 对象

PageFields 集合对象


AllowAdditions 属性

AllowDeletions 属性

AllowEdits 属性

AlternateRowColor 属性

CaptionSection 属性

DataPageSize 属性

DefaultSort 属性

ExpandedByDefault 属性

GroupFilterControl 属性

GroupFilterField 属性

GroupFooter 属性

GroupHeader 属性

GroupInterval 属性

GroupOn 属性

RecordNavigationSection 属性

RecordSelector 属性

RecordSource 属性


GroupLevel 对象


Reset 方法

Window 对象

Window 对象


Window 对象


Application 属性

Color 属性

ColorIndex 属性

Parent 属性

Range 对象

TitleBar 对象


Application 属性

DataBodyRange 属性

HeaderRowRange 属性

InsertRowRange 属性

ListRows 属性

Name 属性

Parent 属性

PropNames 属性

Range 属性

ListObjects 集合

ListRow 对象

ListRows 集合

Range 对象

Workbook 对象

ListRows 集合

Range 对象

Worksheet 对象


Delete 方法

ListObject 对象


Add 方法

ListObject 对象


PageRowsource 对象


SchemaRowsource 对象

SchemaRelatedFields 集合对象


Delete 方法

不支持的语言元素

Spreadsheet 对象

Workbook 对象

Worksheet 对象

Range 对象


Execute 方法


Item 属性

ChartSpace 对象

不支持的语言元素

不支持的语言元素

不支持的语言元素

PivotTable 对象

Spreadsheet 对象

OCCommand 对象


Application 属性

LanguageID 属性

LanguagePreferredForEditing 属性

ChartSpace 对象

不支持的语言元素

不支持的语言元素

Spreadsheet 对象


FieldType 属性

GroupInterval 属性

GroupOn 属性

Location 属性

Name 属性

PageRowsource 属性

RecordsetDef 属性

Source 属性

TotalType 属性

AllPageFields 集合对象

PageFields 集合对象

PageRelatedField 对象

PageRowsource 对象

RecordsetDef 对象


Count 属性

Item 属性

Add 方法

Delete 方法

GroupingDef 对象

PageRowsource 对象

RecordsetDef 对象

PageRowsource 对象

RecordsetDef 对象


PageRelationship 对象

PageField 对象


JoinType 属性

ManySide 属性

Name 属性

OneSide 属性

PageRelatedFields 属性

Type 属性

LookupRelationships 集合对象

SublistRelationships 集合对象

PageRelatedFields 集合对象

PageRowsource 对象


LookupRelationships 属性

Name 属性

PageFields 属性

RecordsetDef 属性

Source 属性

PageField 对象

PageRelationship 对象

PageRowsources 集合对象

RecordsetDef 对象

LookupRelationships 集合对象

PageFields 集合对象

RecordsetDef 对象


RecordsetDef 对象


Application 属性

Index 属性

Parent 属性

VisibleRange 属性

Panes 集合对象

Window 对象

Range 对象

Window 对象


RecordsetDef 对象

ParameterValue 对象


PivotResultAxis 对象

PivotResultColumnAxis 对象

PivotResultDataAxis 对象

PivotResultFilterAxis 对象

PivotResultGroupAxis 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象


AutoFit 属性

Axis 属性

Caption 属性

ChildAxisMembers 属性

ChildMembers 属性

CustomGroupType 属性

Expanded 属性

Field 属性

FindAxisMember 属性

FindMember 属性

GroupField 属性

Height 属性

Hyperlink 属性

IsTotal 属性

IsValid 属性

Left 属性

MemberProperties 属性

Name 属性

ParentAxisMember 属性

ParentMember 属性

Path 属性

SourceMember 属性

TimeValue 属性

Top 属性

TotalMember 属性

UniqueName 属性

Value 属性

View 属性

Width 属性

HideDetails 方法

ShowDetails 方法

PivotAxisMember 对象

PivotAxisMembers 集合

PivotColumnMember 对象

PivotPageMember 对象

PivotResultColumnAxis 对象

PivotResultGroupAxis 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotRowMember 对象

PivotAxisMember 对象

PivotAxisMembers 集合

PivotField 对象

PivotHyperlink 对象

PivotMember 对象

PivotMembers 集合对象

PivotResultGroupAxis 对象

PivotResultGroupField 对象

PivotResultMemberProperties 集合

PivotView 对象


PivotAxisMember 对象

PivotAxisMembers 集合

PivotField 对象

PivotHyperlink 对象

PivotMember 对象

PivotMembers 集合对象

PivotResultGroupAxis 对象

PivotResultGroupField 对象

PivotResultMemberProperties 集合

PivotView 对象


Aggregates 属性

ColumnMember 属性

Data 属性

DetailCells 属性

DetailColumnCount 属性

DetailRange 属性

DetailRowCount 属性

DetailTop 属性

DetailTopOffset 属性

Expanded 属性

PageMember 属性

Recordset 属性

RowMember 属性

MoveDetailTop 方法


AutoFit 属性

Axis 属性

Caption 属性

ChildAxisMembers 属性

ChildColumnMembers 属性

ChildMembers 属性

CustomGroupType 属性

DetailLeft 属性

DetailLeftOffset 属性

DetailsExpanded 属性

Expanded 属性

Field 属性

FindAxisMember 属性

FindColumnMember 属性

FindMember 属性

GroupField 属性

Height 属性

Hyperlink 属性

IsTotal 属性

IsValid 属性

Left 属性

MemberProperties 属性

Name 属性

ParentAxisMember 属性

ParentColumnMember 属性

ParentMember 属性

Path 属性

SourceMember 属性

TimeValue 属性

Top 属性

TotalColumnMember 属性

TotalMember 属性

UniqueName 属性

Value 属性

View 属性

Width 属性

HideDetails 方法

MoveDetailLeft 方法

ShowDetails 方法

PivotCell 对象

PivotColumnMember 对象

PivotColumnMembers 集合

PivotData 对象

PivotResultColumnAxis 对象

PivotAxisMember 对象

PivotAxisMembers 集合

PivotColumnMember 对象

PivotColumnMembers 集合

PivotField 对象

PivotHyperlink 对象

PivotMember 对象

PivotMembers 集合对象

PivotResultGroupAxis 对象

PivotResultGroupField 对象

PivotResultMemberProperties 集合

PivotView 对象


PivotAxisMember 对象

PivotAxisMembers 集合

PivotColumnMember 对象

PivotColumnMembers 集合

PivotField 对象

PivotHyperlink 对象

PivotMember 对象

PivotMembers 集合对象

PivotResultGroupAxis 对象

PivotResultGroupField 对象

PivotResultMemberProperties 集合

PivotView 对象


Cells 属性

CellsEx 属性

ColumnAxis 属性

Control 属性

CurrentCell 属性

DataAxis 属性

DetailLeft 属性

FilterAxis 属性

IsConsistent 属性

Label 属性

Left 属性

Left2 属性

LeftOffset 属性

PageAxis 属性

Range 属性

Recordset 属性

RowAxis 属性

Top 属性

Top2 属性

TopOffset 属性

View 属性

ViewportLeft 属性

ViewportTop 属性

HideDetails 方法

MoveLeft 方法

MoveTop 方法

ShowDetails 方法

不支持的语言元素

PivotCell 对象

PivotResultAxis 对象

PivotResultColumnAxis 对象

PivotResultDataAxis 对象

PivotResultFilterAxis 对象

PivotResultGroupAxis 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotTable 对象

不支持的语言元素

PivotCell 对象

PivotColumnMember 对象

PivotRange 对象

PivotResultColumnAxis 对象

PivotResultDataAxis 对象

PivotResultFilterAxis 对象

PivotResultLabel 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotRowMember 对象

PivotView 对象

ActiveData 属性


FieldSets 属性

Label 属性

Totals 属性

View 属性

InsertFieldSet 方法

InsertTotal 方法

RemoveFieldSet 方法

RemoveTotal 方法

PivotResultDataAxis 对象

PivotView 对象

PivotFieldSets 集合对象

PivotLabel 对象

PivotTotals 集合对象

PivotView 对象


Bookmark 属性

Cell 属性

Column 属性

Field 属性

Height 属性

Hyperlink 属性

Left 属性

Row 属性

Text 属性

Top 属性

Value 属性

Width 属性

PivotCell 对象

PivotDetailRange 对象

PivotCell 对象

PivotField 对象

PivotHyperlink 对象


BaseName 属性

Caption 属性

CustomGroupMembers 属性

DataField 属性

DataType 属性

DefaultValue 属性

DetailAutoFit 属性

DetailBackColor 属性

DetailFont 属性

DetailForeColor 属性

DetailHAlignment 属性

DetailWidth 属性

ExcludedMembers 属性

Expanded 属性

Expression 属性

FieldSet 属性

FilterContext 属性

FilterFunction 属性

FilterFunctionValue 属性

FilterOn 属性

FilterOnScope 属性

GroupedAutoFit 属性

GroupedBackColor 属性

GroupedFont 属性

GroupedForeColor 属性

GroupedHAlignment 属性

GroupedHeight 属性

GroupedWidth 属性

GroupEnd 属性

GroupInterval 属性

GroupOn 属性

GroupStart 属性

IncludedMembers 属性

IsHyperlink 属性

IsIncluded 属性

MemberCaptions 属性

MemberProperties 属性

MemberPropertiesOrder 属性

Name 属性

NumberFormat 属性

OrderedMembers 属性

PropertyCaptionWidth 属性

PropertyHeight 属性

PropertyValueWidth 属性

SortDirection 属性

SortOn 属性

SortOnScope 属性

SubtotalBackColor 属性

SubtotalFont 属性

SubtotalForeColor 属性

SubtotalLabelBackColor 属性

SubtotalLabelFont 属性

SubtotalLabelForeColor 属性

SubtotalLabelHAlignment 属性

Subtotals 属性

Type 属性

UniqueName 属性

AddCustomGroupMember 方法

DeleteCustomGroupMember 方法

PivotAxisMember 对象

PivotColumnMember 对象

PivotDetailCell 对象

PivotField 对象

PivotFields 集合对象

PivotFieldSet 对象

PivotMember 对象

PivotPageMember 对象

PivotResultField 对象

PivotResultGroupField 对象

PivotRowMember 对象

PivotTotal 对象


Count 属性

Item 属性

PivotFieldSet 对象

PivotResultColumnAxis 对象

PivotResultDataAxis 对象

PivotResultGroupAxis 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotField 对象

PivotFieldSet 对象

PivotFont 对象

PivotMemberProperties 集合

PivotMembers 集合对象

PivotTotal 对象


AllIncludeExclude 属性

AllMember 属性

AllowMultiFilter 属性

AlwaysIncludeInCube 属性

BoundField 属性

Caption 属性

CompareMemberCaptionsBy 属性

CompareOrderedMembersBy 属性

DefaultMember 属性

DisplayInFieldList 属性

Fields 属性

FilterCaption 属性

FindMember 属性

Member 属性

Name 属性

Orientation 属性

Type 属性

UniqueName 属性

View 属性

Width 属性


Count 属性

Item 属性

PivotAxis 对象

PivotDataAxis 对象

PivotFilterAxis 对象

PivotGroupAxis 对象

PivotResultFilterAxis 对象

PivotView 对象

PivotField 对象

PivotFields 集合对象

PivotMember 对象

PivotView 对象


FieldSets 属性

Label 属性

View 属性

InsertFieldSet 方法

RemoveFieldSet 方法

PivotResultFilterAxis 对象

PivotView 对象

PivotFieldSets 集合对象

PivotLabel 对象

PivotView 对象


Bold 属性

Color 属性

Italic 属性

Name 属性

Size 属性

Underline 属性

PivotField 对象

PivotLabel 对象

PivotView 对象


DisplayEmptyMembers 属性

FieldSets 属性

Label 属性

View 属性

InsertFieldSet 方法

RemoveFieldSet 方法

PivotResultColumnAxis 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotView 对象

PivotFieldSets 集合对象

PivotLabel 对象

PivotView 对象


Address 属性

Name 属性

Parent 属性

Subaddress 属性

Delete 方法

Follow 方法

PivotAxisMember 对象

PivotColumnMember 对象

PivotDetailCell 对象

PivotPageMember 对象

PivotRowMember 对象


PivotFont 对象


Caption 属性

ChildMembers 属性

CustomGroupType 属性

Field 属性

FindMember 属性

IsValid 属性

Name 属性

ParentMember 属性

Path 属性

TimeValue 属性

UniqueName 属性

Value 属性

View 属性


PivotField 对象

PivotMemberProperty 对象


Caption 属性

DisplayIn 属性

IsIncluded 属性

Name 属性

NumberFormat 属性

PivotMemberProperties 集合

PivotResultMemberProperty 对象


Count 属性

Item 属性

PivotAxisMember 对象

PivotColumnMember 对象

PivotField 对象

PivotMember 对象

PivotPageMember 对象

PivotRowMember 对象

PivotField 对象

PivotMember 对象

PivotMembers 集合对象

PivotView 对象


AutoFit 属性

Axis 属性

Caption 属性

ChildAxisMembers 属性

ChildMembers 属性

ChildPageMembers 属性

CustomGroupType 属性

Expanded 属性

Field 属性

FindAxisMember 属性

FindMember 属性

FindPageMember 属性

GroupField 属性

Height 属性

Hyperlink 属性

IsTotal 属性

IsValid 属性

Left 属性

MemberProperties 属性

Name 属性

ParentAxisMember 属性

ParentMember 属性

ParentPageMember 属性

Path 属性

SourceMember 属性

TimeValue 属性

Top 属性

TotalMember 属性

TotalPageMember 属性

UniqueName 属性

Value 属性

View 属性

Width 属性

HideDetails 方法

ShowDetails 方法

PivotCell 对象

PivotPageMember 对象

PivotPageMembers 集合

PivotResultPageAxis 对象

PivotAxisMember 对象

PivotAxisMembers 集合

PivotField 对象

PivotHyperlink 对象

PivotMember 对象

PivotMembers 集合对象

PivotPageMember 对象

PivotPageMembers 集合

PivotResultGroupAxis 对象

PivotResultGroupField 对象

PivotResultMemberProperties 集合

PivotView 对象


PivotPageMember 对象

PivotAxisMember 对象

PivotAxisMembers 集合

PivotField 对象

PivotHyperlink 对象

PivotMember 对象

PivotMembers 集合对象

PivotPageMember 对象

PivotPageMembers 集合

PivotResultGroupAxis 对象

PivotResultGroupField 对象

PivotResultMemberProperties 集合

PivotView 对象


Data 属性

Height 属性

Label 属性

Left 属性

SourceAxis 属性

Top 属性

Width 属性

PivotResultField 对象

PivotResultGroupField 对象

PivotAxis 对象

PivotData 对象

PivotResultLabel 对象


Axis 属性

SourceField 属性

PivotField 对象

PivotResultAxis 对象


Data 属性

Fields 属性

GroupFields 属性

Height 属性

Label 属性

Left 属性

Member 属性

SourceAxis 属性

Top 属性

Width 属性

ChCategoryLabels 集合对象

ChSeriesCollection 集合对象

PivotAxisMember 对象

PivotColumnMember 对象

PivotPageMember 对象

PivotRowMember 对象

PivotAxis 对象

PivotAxisMember 对象

PivotData 对象

PivotFields 集合对象

PivotResultGroupFields 集合

PivotResultLabel 对象


Axis 属性

DisplayTotal 属性

SourceField 属性

PivotAxisMember 对象

PivotColumnMember 对象

PivotPageMember 对象

PivotResultGroupFields 集合

PivotRowMember 对象

PivotField 对象

PivotResultAxis 对象


Count 属性

Item 属性

PivotResultColumnAxis 对象

PivotResultGroupAxis 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotField 对象

PivotResultAxis 对象


PivotData 对象

PivotResultAxis 对象

PivotResultColumnAxis 对象

PivotResultDataAxis 对象

PivotResultFilterAxis 对象

PivotResultGroupAxis 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotLabel 对象


PivotMemberProperty 对象


AutoFit 属性

Axis 属性

Caption 属性

ChildAxisMembers 属性

ChildMembers 属性

ChildRowMembers 属性

CustomGroupType 属性

Expanded 属性

Field 属性

FindAxisMember 属性

FindMember 属性

FindRowMember 属性

GroupField 属性

Height 属性

Hyperlink 属性

IsTotal 属性

IsValid 属性

Left 属性

MemberProperties 属性

Name 属性

ParentAxisMember 属性

ParentMember 属性

ParentRowMember 属性

Path 属性

SourceMember 属性

TimeValue 属性

Top 属性

TotalMember 属性

TotalRowHeight 属性

TotalRowMember 属性

UniqueName 属性

Value 属性

View 属性

Width 属性

HideDetails 方法

ShowDetails 方法

PivotCell 对象

PivotData 对象

PivotResultRowAxis 对象

PivotRowMember 对象

PivotRowMembers 集合

PivotAxisMember 对象

PivotAxisMembers 集合

PivotField 对象

PivotHyperlink 对象

PivotMember 对象

PivotMembers 集合对象

PivotResultGroupAxis 对象

PivotResultGroupField 对象

PivotResultMemberProperties 集合

PivotRowMember 对象

PivotRowMembers 集合

PivotView 对象


PivotAxisMember 对象

PivotAxisMembers 集合

PivotField 对象

PivotHyperlink 对象

PivotMember 对象

PivotMembers 集合对象

PivotResultGroupAxis 对象

PivotResultGroupField 对象

PivotResultMemberProperties 集合

PivotRowMember 对象

PivotRowMembers 集合

PivotView 对象


ActiveData 属性

ActiveObject 属性

ActiveView 属性

AllowCustomOrdering 属性

AllowDetails 属性

AllowFiltering 属性

AllowGrouping 属性

AllowPropertyToolbox 属性

AutoFit 属性

BackColor 属性

BuildNumber 属性

Commands 属性

CommandText 属性

Connection 属性

ConnectionString 属性

Constants 属性

DataMember 属性

DataSource 属性

DataSourceName 属性

DisplayAlerts 属性

DisplayDesignTimeUI 属性

DisplayExpandIndicator 属性

DisplayFieldList 属性

DisplayOfficeLogo 属性

DisplayPropertyToolbox 属性

DisplayScreenTips 属性

DisplayToolbar 属性

EditMode 属性

HasDetails 属性

Height 属性

HTMLData 属性

Hwnd 属性

IsDirty 属性

Left 属性

MajorVersion 属性

MaxHeight 属性

MaxWidth 属性

MinorVersion 属性

Parent 属性

ProviderType 属性

RevisionNumber 属性

RightToLeft 属性

Selection 属性

SelectionType 属性

Toolbar 属性

Top 属性

UserMode 属性

Version 属性

ViewOnlyMode 属性

Width 属性

XMLData 属性

Copy 方法

EndEdit 方法

Export 方法

ExportPicture 方法

Refresh 方法

Select 方法

ShowAbout 方法

ShowContextMenu 方法

ShowHelp 方法

StartEdit 方法

BeforeContextMenu 事件

BeforeKeyDown 事件

BeforeKeyPress 事件

BeforeKeyUp 事件

BeforeQuery 事件

BeforeScreenTip 事件

Click 事件

CommandBeforeExecute 事件

CommandChecked 事件

CommandEnabled 事件

CommandExecute 事件

CommandTipText 事件

DataChange 事件

DblClick 事件

EndEdit 事件

KeyDown 事件

KeyPress 事件

KeyUp 事件

MouseDown 事件

MouseMove 事件

MouseUp 事件

MouseWheel 事件

OnConnect 事件

OnDisconnect 事件

PivotTableChange 事件

Query 事件

SelectionChange 事件

StartEdit 事件

ViewChange 事件


AutoFit 属性

Caption 属性

CaptionHAlignment 属性

DisplayInFieldList 属性

Expression 属性

Field 属性

Function 属性

HAlignment 属性

Name 属性

NumberFormat 属性

ShowAs 属性

SolveOrder 属性

Type 属性

UniqueName 属性

View 属性

Width 属性


Count 属性

Item 属性

PivotDataAxis 对象

PivotResultDataAxis 对象

PivotView 对象

PivotField 对象

PivotView 对象


AllowAdditions 属性

AllowDeletions 属性

AllowEdits 属性

ColumnAxis 属性

Control 属性

DataAxis 属性

DetailAutoFit 属性

DetailMaxHeight 属性

DetailMaxWidth 属性

DetailRowHeight 属性

DetailSortOrder 属性

DisplayCalculatedMembers 属性

ExpandDetails 属性

ExpandMembers 属性

FieldLabelBackColor 属性

FieldLabelFont 属性

FieldLabelForeColor 属性

FieldLabelHeight 属性

FieldSets 属性

FilterAxis 属性

FilterCrossJoins 属性

HeaderBackColor 属性

HeaderFont 属性

HeaderForeColor 属性

HeaderHAlignment 属性

HeaderHeight 属性

IsFiltered 属性

Label 属性

PageAxis 属性

PropertyCaptionFont 属性

PropertyCaptionHAlignment 属性

PropertyValueFont 属性

PropertyValueHAlignment 属性

RowAxis 属性

TitleBar 属性

TotalAllMembers 属性

TotalBackColor 属性

TotalFont 属性

TotalForeColor 属性

TotalOrientation 属性

Totals 属性

AddCalculatedTotal 方法

AddFieldSet 方法

AddTotal 方法

AutoLayout 方法

DeleteFieldSet 方法

DeleteTotal 方法

不支持的语言元素

PivotAxis 对象

PivotAxisMember 对象

PivotColumnMember 对象

PivotData 对象

PivotDataAxis 对象

PivotFieldSet 对象

PivotFilterAxis 对象

PivotGroupAxis 对象

PivotMember 对象

PivotPageMember 对象

PivotRowMember 对象

PivotTable 对象

PivotTotal 对象

不支持的语言元素

PivotDataAxis 对象

PivotFieldSets 集合对象

PivotFilterAxis 对象

PivotFont 对象

PivotGroupAxis 对象

PivotLabel 对象

PivotTotals 集合对象

ActiveData 属性


AllowDeletingColumns 属性

AllowDeletingRows 属性

AllowFiltering 属性

AllowFormattingColumns 属性

AllowFormattingRows 属性

AllowHeadingRename 属性

AllowInsertingColumns 属性

AllowInsertingRows 属性

AllowSorting 属性

Application 属性

Enabled 属性

Parent 属性

Worksheet 对象

Worksheet 对象


Address 属性

Application 属性

Borders 属性

Cells 属性

Column 属性

Columns 属性

ColumnWidth 属性

Count 属性

CurrentArray 属性

CurrentRegion 属性

End 属性

EntireColumn 属性

EntireRow 属性

Font 属性

Formula 属性

FormulaArray 属性

FormulaLocal 属性

HasArray 属性

HasFormula 属性

Height 属性

Hidden 属性

HorizontalAlignment 属性

HTMLData 属性

Hyperlink 属性

Interior 属性

Item 属性

Left 属性

ListObject 属性

Locked 属性

MergeArea 属性

MergeCells 属性

Name 属性

Next 属性

NumberFormat 属性

Offset 属性

Parent 属性

PrefixCharacter 属性

Previous 属性

Range 属性

ReadingOrder 属性

Row 属性

RowHeight 属性

Rows 属性

Text 属性

Top 属性

UseStandardHeight 属性

UseStandardWidth 属性

Value 属性

Value2 属性

VerticalAlignment 属性

Width 属性

Worksheet 属性

Activate 方法

AutoFilter 方法

AutoFit 方法

BorderAround 方法

Calculate 方法

Clear 方法

ClearContents 方法

ClearFormats 方法

Copy 方法

CopyFromRecordset 方法

Cut 方法

Delete 方法

FillDown 方法

FillRight 方法

Find 方法

FindNext 方法

FindPrevious 方法

Insert 方法

LoadText 方法

Merge 方法

ParseText 方法

Paste 方法

Select 方法

Show 方法

Sort 方法

UnMerge 方法

Validate 方法

Change 事件


DataSource 属性

FontName 属性

RecordsetLabel 属性

RecordSource 属性

ShowDelButton 属性

ShowFilterBySelectionButton 属性

ShowFirstButton 属性

ShowHelpButton 属性

ShowLabel 属性

ShowLastButton 属性

ShowNewButton 属性

ShowNextButton 属性

ShowPrevButton 属性

ShowSaveButton 属性

ShowSortAscendingButton 属性

ShowSortDescendingButton 属性

ShowToggleFilterButton 属性

ShowUndoButton 属性

IsButtonEnabled 方法

ButtonClick 事件


CommandText 属性

GroupingDefs 属性

Name 属性

PageFields 属性

PageRowsources 属性

ParameterValues 属性

ParentRecordsetDef 属性

PrimaryPageRowsource 属性

ResyncCommand 属性

ServerFilter 属性

SublistRelationships 属性

UniqueTable 属性


Count 属性

Item 属性

Add 方法

AddNew 方法

Delete 方法

DataSourceControl 对象

不支持的语言元素

GroupingDefs 集合对象

PageFields 集合对象

PageRowsource 对象

PageRowsources 集合对象

ParameterValues 集合对象

RecordsetDef 对象

SublistRelationships 集合对象


SchemaRowsource 对象

SchemaProperties 对象


Add 方法

SchemaRowsource 对象

SchemaProperties 对象


SchemaProperty 对象


Name 属性

Value 属性

SchemaField 对象

SchemaParameter 对象

SchemaRowsource 对象


SchemaRelationship 对象


Add 方法

SchemaRelationship 对象

SchemaRelatedField 对象


SchemaRelatedFields 集合对象


CommandText 属性

LookupSchemaRelationships 属性

Name 属性

SchemaFields 属性

SchemaParameters 属性

SublistSchemaRelationships 属性

Type 属性

DataSourceControl 对象

不支持的语言元素

LookupSchemaRelationships 集合对象

SchemaFields 集合对象

SchemaParameters 集合对象

SchemaProperties 对象

SublistSchemaRelationships 集合对象


Count 属性

Item 属性

Add 方法

Delete 方法

DataSourceControl 对象

不支持的语言元素

LookupSchemaRelationships 集合对象

SchemaFields 集合对象

SchemaParameters 集合对象

SchemaProperties 对象

SublistSchemaRelationships 集合对象


ChildSection 属性

DataPage 属性

HTMLContainer 属性

IsExpanded 属性

NextSection 属性

NextSibling 属性

ParentSection 属性

PreviousSection 属性

PreviousSibling 属性

Type 属性


ActiveCell 属性

ActiveSheet 属性

ActiveWindow 属性

ActiveWorkbook 属性

AllowPropertyToolbox 属性

Application 属性

AutoFit 属性

Build 属性

BuildNumber 属性

Calculation 属性

CalculationVersion 属性

CanUndo 属性

Caption 属性

Cells 属性

Columns 属性

Commands 属性

Constants 属性

CSVData 属性

CSVURL 属性

DataMember 属性

DataSource 属性

DataType 属性

DefaultQueryOnLoad 属性

DesignMode 属性

Dirty 属性

DisplayDesignTimeUI 属性

DisplayOfficeLogo 属性

DisplayPropertyToolbox 属性

DisplayTitleBar 属性

DisplayToolbar 属性

EnableEvents 属性

EnableUndo 属性

HTMLData 属性

HTMLURL 属性

International 属性

LanguageSettings 属性

MajorVersion 属性

MaxHeight 属性

MaxWidth 属性

MinorVersion 属性

MoveAfterReturn 属性

MoveAfterReturnDirection 属性

Name 属性

Names 属性

Range 属性

RevisionNumber 属性

RightToLeft 属性

Rows 属性

ScreenUpdating 属性

Selection 属性

Sheets 属性

TitleBar 属性

Toolbar 属性

Value 属性

Version 属性

ViewOnlyMode 属性

Windows 属性

Workbooks 属性

Worksheets 属性

XMLData 属性

XMLURL 属性

AddIn 方法

BeginUndo 方法

Calculate 方法

CalculateFull 方法

EndUndo 方法

Evaluate 方法

Export 方法

FireParametersOut 方法

RectIntersect 方法

RectUnion 方法

Refresh 方法

Repaint 方法

ShowAbout 方法

ShowContextMenu 方法

ShowHelp 方法

Undo 方法

UpdatePropertyToolbox 方法

BeforeContextMenu 事件

BeforeKeyDown 事件

BeforeKeyPress 事件

BeforeKeyUp 事件

BindingAdded 事件

BindingCompleted 事件

BindingDeleted 事件

BindingError 事件

BindingUpdated 事件

Click 事件

CommandBeforeExecute 事件

CommandChecked 事件

CommandEnabled 事件

CommandExecute 事件

CommandTipText 事件

DblClick 事件

EndEdit 事件

Initialize 事件

KeyDown 事件

KeyPress 事件

KeyUp 事件

LoadCompleted 事件

MouseDown 事件

MouseOut 事件

MouseOver 事件

MouseUp 事件

MouseWheel 事件

ParametersOutReady 事件

RowReady 事件

SelectionChange 事件

SelectionChanging 事件

SheetActivate 事件

SheetCalculate 事件

SheetChange 事件

SheetDeactivate 事件

SheetFollowHyperlink 事件

StartEdit 事件

ViewChange 事件

Names 集合

OCCommands 对象

OWCLanguageSettings 对象

Range 对象

Sheets 集合

TitleBar 对象

Window 对象

Windows 集合对象

Workbook 对象

Workbooks 集合

Worksheet 对象

Worksheets 集合对象


Application 属性

Caption 属性

Font 属性

Interior 属性

Parent 属性

Visible 属性

不支持的语言元素

Spreadsheet 对象

Font 对象

Interior 对象

不支持的语言元素


ActiveCell 属性

ActivePane 属性

ActiveSheet 属性

Application 属性

ColumnHeadings 属性

DisplayColumnHeadings 属性

DisplayCustomHeadings 属性

DisplayGridlines 属性

DisplayHeadings 属性

DisplayHorizontalScrollBar 属性

DisplayRowHeadings 属性

DisplayVerticalScrollBar 属性

DisplayWorkbookTabs 属性

DisplayZeros 属性

EnableResize 属性

FreezePanes 属性

GridlineColor 属性

GridlineColorIndex 属性

Height 属性

Index 属性

Left 属性

Panes 属性

Parent 属性

RangeSelection 属性

RowHeadings 属性

ScrollColumn 属性

ScrollRow 属性

SelectedSheets 属性

Selection 属性

TabRatio 属性

Top 属性

Type 属性

UsableHeight 属性

UsableWidth 属性

ViewableRange 属性

Visible 属性

VisibleRange 属性

Width 属性

WindowNumber 属性


Application 属性

Count 属性

Item 属性

Parent 属性

不支持的语言元素

Spreadsheet 对象

Workbook 对象

Headings 对象

Pane 对象

Panes 集合对象

Range 对象

Sheets 集合

Workbook 对象

Worksheet 对象


ActiveSheet 属性

Application 属性

CalculationVersion 属性

Colors 属性

ListObject 属性

Name 属性

Names 属性

Parent 属性

ProtectStructure 属性

Sheets 属性

Windows 属性

Worksheets 属性

XmlDataBindings 属性

XmlMaps 属性


Application 属性

Count 属性

Item 属性

Parent 属性

不支持的语言元素

Spreadsheet 对象

不支持的语言元素

Workbook 对象


Application 属性

AutoFilter 属性

AutoFilterMode 属性

Cells 属性

Columns 属性

CommandText 属性

ConnectionString 属性

DataMember 属性

EnableAutoFilter 属性

FilterMode 属性

Index 属性

IsDataBound 属性

ListObjects 属性

Name 属性

Names 属性

Next 属性

Parent 属性

Previous 属性

ProtectContents 属性

Protection 属性

ProtectionMode 属性

Range 属性

Rows 属性

StandardHeight 属性

StandardWidth 属性

Type 属性

UsedRange 属性

Visible 属性


Application 属性

Async 属性

BindingData 属性

BindingInProgress 属性

CanQuery 属性

CanUpdate 属性

LoadMode 属性

Parent 属性

XmlMap 属性

Delete 方法

Refresh 方法

Update 方法

Workbook 对象

XmlMap 对象


Add 方法

Workbook 对象

Workbook 对象


Workbook 对象

Workbook 对象


ListRow 对象


Spreadsheet 对象

Window 对象

ActivePane 属性

ActiveSheet 属性

AddTotal 方法

AllGroupingDefs 集合对象

Cells 属性

Range 属性


PivotTable 对象

PivotCell 对象


Window 对象

ActiveCell 属性


ActiveCell 属性


PivotTable 对象

ActiveData 属性


Spreadsheet 对象

Window 对象


Spreadsheet 对象

Workbook 对象


Hyperlink 对象

PivotHyperlink 对象

Range 对象

HasAutoMajorUnit 属性

Subaddress 属性


PivotFieldSet 对象

PivotMember 对象


AllowDeletions 属性


Protection 对象

AllowDeletingRows 属性

AllowDetails 属性

AllowFiltering 属性

AllowGrouping 属性

AllowInsertingColumns 属性

AllowInsertingRows 属性

AllowPropertyToolbox 属性

AllowSorting 属性

Locked 属性

Protection 属性


Protection 对象

AllowDeletingColumns 属性

AllowDetails 属性

AllowFiltering 属性

AllowGrouping 属性

AllowInsertingColumns 属性

AllowInsertingRows 属性

AllowPropertyToolbox 属性

AllowSorting 属性

Locked 属性

Protection 属性


AllowAdditions 属性


PivotTable 对象

AllowDeletingColumns 属性

AllowDeletingRows 属性

AllowFiltering 属性

AllowGrouping 属性

AllowInsertingColumns 属性

AllowInsertingRows 属性

AllowPropertyToolbox 属性

AllowSorting 属性


GroupLevel 对象

PivotView 对象

AllowAdditions 属性

AllowDeletions 属性

AllowDetails 属性


AllowDeletingColumns 属性

AllowDeletingRows 属性

AllowDetails 属性

AllowGrouping 属性

AllowInsertingColumns 属性

AllowInsertingRows 属性

AllowPropertyToolbox 属性

AllowSorting 属性

Locked 属性

Protection 属性


Protection 对象

AllowFormattingRows 属性


Protection 对象

AllowFormattingColumns 属性


AllowDeletingColumns 属性

AllowDeletingRows 属性

AllowDetails 属性

AllowFiltering 属性

AllowInsertingColumns 属性

AllowInsertingRows 属性

AllowPropertyToolbox 属性

AllowSorting 属性


Protection 对象

Heading 对象


Protection 对象

AllowDeletingColumns 属性

AllowDeletingRows 属性

AllowDetails 属性

AllowFiltering 属性

AllowGrouping 属性

AllowInsertingRows 属性

AllowPropertyToolbox 属性

AllowSorting 属性

Locked 属性

Protection 属性


Protection 对象

AllowDeletingColumns 属性

AllowDeletingRows 属性

AllowDetails 属性

AllowFiltering 属性

AllowGrouping 属性

AllowInsertingColumns 属性

AllowPropertyToolbox 属性

AllowSorting 属性

Locked 属性

Protection 属性


ChartSpace 对象

AfterLayout 事件


AllowDeletingColumns Property

 AllowDeletingRows Property

 AllowDetails Property

 AllowFiltering Property

 AllowGrouping Property

 AllowInsertingColumns Property

 AllowInsertingRows Property

 AllowSorting Property

 Creating an Accessible Chart

 DisplayPropertyToolbox Property


ChartSpace 对象

BeforeScreenTip 事件


Protection 对象

AllowDeletingColumns 属性

AllowDeletingRows 属性

AllowDetails 属性

AllowFiltering 属性

AllowGrouping 属性

AllowInsertingColumns 属性

AllowInsertingRows 属性

AllowPropertyToolbox 属性

Locked 属性

Protection 属性

Sort 方法


ChErrorBars 对象


AutoFilter 对象

Border 对象

Borders 集合对象

Criteria 对象

Filter 对象

Filters 集合对象

Font 对象

Heading 对象

Headings 对象

Hyperlink 对象

Interior 对象

ListObject 对象

ListObjects 集合

ListRow 对象

ListRows 集合

Name 对象

Names 集合

OWCLanguageSettings 对象

Pane 对象

Panes 集合对象

Protection 对象

Range 对象

Sheets 集合

Spreadsheet 对象

TitleBar 对象

Window 对象

Windows 集合对象

Workbook 对象

Workbooks 集合

Worksheet 对象

Worksheets 集合对象

XmlDataBinding 对象

XmlDataBindings 集合

XmlMap 对象

XmlMaps 集合


ChChart 对象

ChartDepth 属性


Worksheet 对象

FilterMode 属性


PivotAxisMember 对象

PivotColumnMember 对象

PivotPageMember 对象

PivotRowMember 对象

PivotTable 对象

PivotTotal 对象

Spreadsheet 对象


PivotAxisMember 对象

PivotColumnMember 对象

PivotPageMember 对象

PivotResultField 对象

PivotResultGroupField 对象

PivotRowMember 对象

PivotResultAxis 对象

PivotResultGroupAxis 对象


ChInterior 对象

PivotLabel 对象

PivotTable 对象

Color 属性

DetailBackColor 属性

DetailForeColor 属性

ForeColor 属性

TotalBackColor 属性

TotalForeColor 属性


XmlDataBinding 对象

XmlDataBindings 集合


ChFont 对象

Font 对象

PivotFont 对象

Font 属性

Italic 属性

TotalFont 属性

Underline 属性


PivotDetailCell 对象


ChartSpace 对象

ChChart 对象

ChChartDraw 对象

ChDataLabel 对象

ChDataLabels 对象

ChLegend 对象

ChPlotArea 对象

ChPoint 对象

ChSegmentBoundary 对象

ChSeries 对象

ChSurface 对象

ChTitle 对象

Borders 属性


Range 对象

Border 属性


ChartSpace 对象

ChAxis 对象

ChCategoryLabel 对象

ChChart 对象

ChChartField 对象

ChDataLabel 对象

ChDataLabels 对象

ChDropZone 对象

ChErrorBars 对象

ChLegend 对象

ChLegendEntry 对象

ChPlotArea 对象

ChPoint 对象

ChScrollView 对象

ChSeries 对象

ChTitle 对象

ChTrendline 对象


PivotDetailRange 对象

PivotRange 对象

Bottom 属性

TopLeft 属性


ChChart 对象

SizeRepresents 属性


Spreadsheet 对象

BuildNumber 属性


ChartSpace 对象

DataSourceControl 对象

PivotTable 对象

Spreadsheet 对象

Build 属性

MajorVersion 属性

MinorVersion 属性

RevisionNumber 属性

Version 属性


Spreadsheet 对象

Workbook 对象

MajorVersion 属性

MinorVersion 属性


Undo 方法


ChCategoryLabel 对象

ChSeries 对象

ChTitle 对象

ChTrendline 对象

Heading 对象

PivotAxisMember 对象

PivotColumnMember 对象

PivotField 对象

PivotFieldSet 对象

PivotLabel 对象

PivotMember 对象

PivotMemberProperty 对象

PivotPageMember 对象

PivotResultMemberProperty 对象

PivotRowMember 对象

PivotTotal 对象

Spreadsheet 对象

TitleBar 对象

BaseName 属性


PivotTotal 对象

HAlignment 属性


ChAxis 对象

ChCategoryLabels 集合对象


PivotAggregate 对象

PivotDetailCell 对象

PivotDetailRange 对象

Cells 属性

CellsEx 属性

DblClick 事件


PivotData 对象

PivotRange 对象

Range 对象

Spreadsheet 对象

Worksheet 对象

ActiveCell 属性

Cell 属性

CellsEx 属性


ChChart 对象

AspectRatio 属性


ChDropZone 对象

ChChartFields 对象


ChartSpace 对象

ChartWrapCount 属性


ChartSpace 对象

ChartLayout 属性


OCCommand 对象

Enabled 属性


PivotAxisMembers 集合


PivotAxisMember 对象

PivotColumnMember 对象

PivotMember 对象

PivotPageMember 对象

PivotRowMember 对象

ChildAxisMembers 属性

ChildColumnMembers 属性

ChildPageMembers 属性

ChildRowMembers 属性


PivotPageMember 对象


PivotRowMember 对象


Section 对象

ParentSection 属性


Border 对象

Borders 集合对象

ChBorder 对象

ChFont 对象

ChInterior 对象

ChLine 对象

Font 对象

Interior 对象

PivotFont 对象

BackColor 属性

DetailBackColor 属性

DetailForeColor 属性

ForeColor 属性


Border 对象

Borders 集合对象

Font 对象

Interior 对象

Color 属性

Colors 属性


Row 属性


RowAxis 属性


Window 对象

RowHeadings 属性


PivotCell 对象

PivotResultColumnAxis 对象

ColumnMembers 属性

RowMember 属性

RowMembers 属性


PivotRange 对象


Rows 属性


Range 对象

RowHeight 属性


Enabled 属性


ChartSpace 对象

PivotTable 对象

RecordsetDef 对象

SchemaRowsource 对象

Worksheet 对象

Connection 属性

ConnectionString 属性


PivotFieldSet 对象

MemberCaptions 属性


PivotFieldSet 对象

OrderedMembers 属性


DataSourceControl 对象

DSCEventInfo 对象

PivotTable 对象

CommandText 属性

ConnectionString 属性


DataSourceControl 对象

Connection 属性


ChartSpace 对象

DataSourceControl 对象

PivotTable 对象

Worksheet 对象

CommandText 属性

Connection 属性


ChartSpace 对象

DataSourceControl 对象

PivotTable 对象

Spreadsheet 对象


ElementExtension 对象

ControlSource 属性


PivotData 对象

PivotView 对象


ElementExtension 对象

ConsumesRecordset 属性


AllGroupingDefs 集合对象

AllPageFields 集合对象

Borders 集合对象

ChAxes 集合

ChChartFields 对象

ChCharts 集合

ChDataLabels 对象

ChDataLabelsCollection 集合

ChErrorBarsCollection 对象

ChLegendEntries 集合

ChPoints 集合

ChSegments 对象

ChSelectionCollection 集合

ChSeriesCollection 集合对象

ChTrendlines 集合

Criteria 对象

DataPages 集合对象

ElementExtensions 集合对象

Filters 集合对象

GroupingDefs 集合对象

GroupLevels 集合对象

Headings 对象

ListObjects 集合

ListRows 集合

LookupRelationships 集合对象

LookupSchemaRelationships 集合对象

Names 集合

PageFields 集合对象

PageRelatedFields 集合对象

PageRowsources 集合对象

Panes 集合对象

ParameterValues 集合对象

PivotAggregates 集合对象

PivotAxisMembers 集合

PivotColumnMembers 集合

PivotFields 集合对象

PivotFieldSets 集合对象

PivotMemberProperties 集合

PivotMembers 集合对象

PivotPageMembers 集合

PivotResultGroupFields 集合

PivotResultMemberProperties 集合

PivotRowMembers 集合

PivotTotals 集合对象

Range 对象

RecordsetDefs 集合对象

SchemaFields 集合对象

SchemaParameters 集合对象

SchemaProperties 对象

SchemaRelatedFields 集合对象

SchemaRelationships 集合对象

SchemaRowsources 集合对象

Sheets 集合

SublistRelationships 集合对象

SublistSchemaRelationships 集合对象

Windows 集合对象

Workbooks 集合

Worksheets 集合对象

XmlDataBindings 集合

XmlMaps 集合

Item 属性


Filter 对象


PivotData 对象

PivotCell 对象


Range 对象

UsedRange 属性


DataSourceControl 对象

MakeCurrent 方法


PivotAxisMember 对象

PivotColumnMember 对象

PivotMember 对象

PivotPageMember 对象

PivotRowMember 对象

AddCustomGroupMember 方法

CustomGroupMembers 属性


ChBorder 对象

ChLine 对象

Line 属性

LineStyle 属性

Miter 属性

Weight 属性


PivotCell 对象

PivotResultAxis 对象

PivotResultColumnAxis 对象

PivotResultDataAxis 对象

PivotResultFilterAxis 对象

PivotResultGroupAxis 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotData 对象


ListObject 对象


PivotField 对象

BaseName 属性


ChTrendline 对象

ChDataLabel 对象


ChSeries 对象

ChDataLabelsCollection 集合


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

Worksheet 对象


DSCEventInfo 对象

Section 对象


ChartSpace 对象

PivotTable 对象

RecordNavigationControl 对象

Spreadsheet 对象

DataSourceName 属性

SetData 方法


ChartSpace 对象

PivotTable 对象

DataSource 属性

SetData 方法


PivotField 对象

SchemaField 对象

SchemaParameter 对象

Spreadsheet 对象


ChInterior 对象

Color 属性


DataSourceControl 对象

Recordset 属性


ElementExtension 对象

PivotField 对象


PivotField 对象

PivotView 对象

DetailMaxWidth 属性

DetailWidth 属性


PivotCell 对象

PivotDetailCell 对象


PivotCell 对象

DetailRowCount 属性


PivotField 对象

HAlignment 属性


PivotColumnMember 对象

PivotData 对象

DetailTop 属性

Left 属性


PivotCell 对象

DetailColumnCount 属性


PivotView 对象

SortDirection 属性


PivotCell 对象

DetailLeft 属性


ChErrorBars 对象

SchemaParameter 对象


DSCEventInfo 对象

DisplayAlerts 属性


DisplayAlert 属性


Window 对象

DisplayRowHeadings 属性


Window 对象

ResetHeadings 方法


DisplayToolbar 属性


PivotGroupAxis 对象


Window 对象

DisplayVerticalScrollBar 属性


PivotFieldSet 对象

PivotTotal 对象


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

DisplayTitleBar 属性

DisplayToolbar 属性


AllowPropertyToolbox 属性


Window 对象

DisplayColumnHeadings 属性


DisplayTitleBar 属性


PivotResultGroupField 对象


Window 对象

DisplayHorizontalScrollBar 属性


Worksheet 对象

AutoFilter 方法


AllowDeletingColumns 属性

AllowDeletingRows 属性

AllowDetails 属性

AllowFiltering 属性

AllowGrouping 属性

AllowInsertingColumns 属性

AllowInsertingRows 属性

AllowSorting 属性

Locked 属性


EnableUndo 属性


Window 对象

EnableUndo 属性


ChSegment 对象

Range 对象

Border 属性

Interior 对象

Line 属性


Range 对象

EntireRow 属性


Range 对象

EntireColumn 属性


DSCEventInfo 对象


PivotField 对象

IncludedMembers 属性


PivotAxisMember 对象

PivotCell 对象

PivotColumnMember 对象

PivotField 对象

PivotPageMember 对象

PivotRowMember 对象

BeforeCollapse 事件

BeforeExpand 事件

Collapse 方法

Expand 方法


PivotView 对象

ExpandDetails 属性


ChPoint 对象

ChSeries 对象

FirstSliceAngle 属性

HoleSize 属性


Formula 属性


ChChart 对象

ProjectionMode 属性


Fields 属性


Field 属性


PivotField 对象

FieldSets 属性


FieldSet 属性


PageField 对象


DataPage 对象

FilterFunction 属性


PivotData 对象

PivotView 对象

PivotFilterAxis 对象

PivotResultFilterAxis 对象


Filter 属性


Worksheet 对象

AutoFilterMode 属性


PivotField 对象

FilterOn 属性


AutoFilter 对象

Filter 属性


PivotAxisMember 对象

PivotColumnMember 对象

PivotPageMember 对象

PivotRowMember 对象

Find 方法

FindColumnMember 属性

FindMember 属性

FindNext 方法

FindPageMember 属性

FindRowMember 属性


PivotAxisMember 对象

PivotColumnMember 对象

PivotFieldSet 对象

PivotMember 对象

PivotPageMember 对象

PivotRowMember 对象

Find 方法

FindAxisMember 属性

FindColumnMember 属性

FindPageMember 属性

FindRowMember 属性


DataPage 对象

NextSection 属性


ChAxis 对象

ChChartDraw 对象

ChDataLabel 对象

ChDataLabels 对象

ChLegend 对象

ChLegendEntry 对象

ChTitle 对象

PivotLabel 对象

Range 对象

TitleBar 对象

Bold 属性

Italic 属性

TotalFont 属性


RecordNavigationControl 对象

Font 对象


PivotLabel 对象


Range 对象

Formula 属性


PivotTotal 对象


ChChart 对象

GapWidth 属性


ChChart 对象

ChSeries 对象

GapDepth 属性

Overlap 属性


Window 对象

GridlineColorIndex 属性


Window 对象

GridlineColor 属性


DataSourceControl 对象

GridY 属性


DataSourceControl 对象

GridX 属性


PivotAxisMember 对象

PivotColumnMember 对象

PivotPageMember 对象

PivotRowMember 对象

GroupFields 属性

PivotResultGroupField 对象


PivotResultColumnAxis 对象

PivotResultGroupAxis 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

GroupField 属性

PivotResultGroupFields 集合


GroupLevel 对象

GroupFilterField 属性


GroupLevel 对象

GroupFilterControl 属性


GroupLevel 对象

GroupHeader 属性


GroupLevel 对象

GroupFooter 属性


GroupLevel 对象

PageField 对象

PivotField 对象

GroupEnd 属性

GroupOn 属性

GroupStart 属性


DataPage 对象

GroupLevels 集合对象


DataSourceControl 对象

GroupLevel 对象


GroupLevel 对象

PageField 对象

PivotField 对象

GroupEnd 属性

GroupInterval 属性

GroupStart 属性


CaptionHAlignment 属性


ChTrendline 对象


ChScaling 对象

HasAutoMinimum 属性


ChScaling 对象

HasAutoMaximum 属性


ChAxis 对象

HasAutoMajorUnit 属性


ChDataLabels 对象


ChartSpace Object

Creating an Accessible Chart


ChScaling 对象


ChAxis 对象

ChChart 对象

ChartSpaceTitle 属性

HasChartSpaceLegend 属性

HasChartSpaceTitle 属性

HasLegend 属性

Title 属性


PivotAxisMember 对象

PivotColumnMember 对象

PivotDetailCell 对象

PivotPageMember 对象

PivotResultAxis 对象

PivotResultColumnAxis 对象

PivotResultDataAxis 对象

PivotResultFilterAxis 对象

PivotResultGroupAxis 对象

PivotResultLabel 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotRowMember 对象

PivotTable 对象

Range 对象

Window 对象

Width 属性


ChChart 对象

WidthRatio 属性


ChChart 对象

Explosion 属性


PivotTable 对象

Range 对象

Spreadsheet 对象

CSVData 属性

CSVURL 属性

HTMLURL 属性

XMLData 属性


Follow 方法


ChUserDefinedSelection 对象


PivotField 对象

ExcludedMembers 属性


ChAxis 对象

ChCategoryLabel 对象

ChChart 对象

ChDataLabel 对象

ChDataLabels 对象

ChDropZone 对象

ChErrorBars 对象

ChLegendEntry 对象

ChPoint 对象

ChSeries 对象

ChTrendline 对象

Heading 对象

ListRow 对象

Name 对象

Pane 对象

Window 对象

Worksheet 对象


ChartSpace 对象

ChChart 对象

ChChartDraw 对象

ChDataLabel 对象

ChDataLabels 对象

ChLegend 对象

ChPlotArea 对象

ChPoint 对象

ChSegmentBoundary 对象

ChSeries 对象

ChSurface 对象

ChTitle 对象

Range 对象

TitleBar 对象


ChartSpace 对象

Spreadsheet 对象


PivotData 对象

Refresh 方法


PivotTable 对象

Dirty 事件


ChTrendline 对象

IsDisplayingRSquared 属性


ChTrendline 对象

IsDisplayingEquation 属性


Section 对象

Expand 方法


PivotView 对象

IsFilterOn 属性


DataPage 对象

IsFiltered 属性


Hyperlink 属性


PivotField 对象

PivotMemberProperty 对象

ExcludedMembers 属性

IncludedMembers 属性


PivotAxisMember 对象

PivotColumnMember 对象

PivotPageMember 对象

PivotRowMember 对象


PivotAxisMember 对象

PivotColumnMember 对象

PivotMember 对象

PivotPageMember 对象

PivotRowMember 对象


ChFont 对象

Font 对象

PivotFont 对象

Bold 属性

Font 属性

TotalFont 属性

Underline 属性


AllGroupingDefs 集合对象

AllPageFields 集合对象

Borders 集合对象

ChAxes 集合

ChCategoryLabels 集合对象

ChChartFields 对象

ChCharts 集合

ChDataLabels 对象

ChDataLabelsCollection 集合

ChErrorBarsCollection 对象

ChLegendEntries 集合

ChPoints 集合

ChSegments 对象

ChSelectionCollection 集合

ChSeriesCollection 集合对象

ChTrendlines 集合

Criteria 对象

DataPages 集合对象

ElementExtensions 集合对象

Filters 集合对象

GroupingDefs 集合对象

GroupLevels 集合对象

Headings 对象

ListObjects 集合

ListRows 集合

LookupRelationships 集合对象

LookupSchemaRelationships 集合对象

OCCommands 对象

PageFields 集合对象

PageRelatedFields 集合对象

PageRowsources 集合对象

Panes 集合对象

ParameterValues 集合对象

PivotAggregates 集合对象

PivotAxisMembers 集合

PivotColumnMembers 集合

PivotFields 集合对象

PivotFieldSets 集合对象

PivotMemberProperties 集合

PivotMembers 集合对象

PivotPageMembers 集合

PivotResultGroupFields 集合

PivotResultMemberProperties 集合

PivotRowMembers 集合

PivotTotals 集合对象

Range 对象

RecordsetDefs 集合对象

SchemaFields 集合对象

SchemaParameters 集合对象

SchemaProperties 对象

SchemaRelatedFields 集合对象

SchemaRelationships 集合对象

SchemaRowsources 集合对象

Sheets 集合

SublistRelationships 集合对象

SublistSchemaRelationships 集合对象

Windows 集合对象

Workbooks 集合

Worksheets 集合对象

XmlDataBindings 集合

XmlMaps 集合

Item 属性


ChCategoryLabels 集合对象

Count 属性


PageRelationship 对象


PivotAxis 对象

PivotData 对象

PivotDataAxis 对象

PivotFilterAxis 对象

PivotGroupAxis 对象

PivotResultAxis 对象

PivotResultColumnAxis 对象

PivotResultDataAxis 对象

PivotResultFilterAxis 对象

PivotResultGroupAxis 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotView 对象


OWCLanguageSettings 对象


PivotData 对象

Left 属性


ChartSpace 对象

ChAxis 对象

ChCategoryLabel 对象

ChChart 对象

ChChartField 对象

ChDataLabel 对象

ChDataLabels 对象

ChDropZone 对象

ChErrorBars 对象

ChLegend 对象

ChLegendEntry 对象

ChPlotArea 对象

ChPoint 对象

ChScrollView 对象

ChSeries 对象

ChTitle 对象

ChTrendline 对象

PivotAxisMember 对象

PivotColumnMember 对象

PivotData 对象

PivotDetailCell 对象

PivotPageMember 对象

PivotResultAxis 对象

PivotResultColumnAxis 对象

PivotResultDataAxis 对象

PivotResultFilterAxis 对象

PivotResultGroupAxis 对象

PivotResultLabel 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotRowMember 对象

PivotTable 对象

Range 对象

Window 对象

Top 属性


SchemaField 对象

SchemaParameter 对象


ChCategoryLabel 对象

LevelCount 属性


ChCategoryLabels 集合对象

Level 属性


ChAxis 对象

ChChartDraw 对象

ChErrorBars 对象

ChGridlines 对象

ChPoint 对象

ChSegmentBoundary 对象

ChSeries 对象

ChTrendline 对象

Border 属性

Interior 属性


Line 属性


Range 对象

Workbook 对象


SchemaRowsource 对象


ChAxis 对象

MinorTickMarks 属性


ChAxis 对象

MinorUnit 属性


ChartSpace 对象

DataSourceControl 对象

PivotTable 对象

Spreadsheet 对象

BuildNumber 属性

MinorVersion 属性

RevisionNumber 属性

Version 属性


OneSide 属性


MaxWidth 属性


MaxHeight 属性


PivotFieldSet 对象

PivotResultColumnAxis 对象

PivotResultGroupAxis 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotAxisMember 对象

PivotMember 对象


PivotField 对象

PivotMember 对象


PivotAxisMember 对象

PivotColumnMember 对象

PivotField 对象

PivotPageMember 对象

PivotRowMember 对象

MemberPropertiesOrder 属性

MemberProperty 属性

PivotMemberProperties 集合

PivotResultMemberProperties 集合


PivotResultMemberProperty 对象


ChAxis 对象

MajorTickMarks 属性


ChAxis 对象

MajorUnit 属性


ChartSpace 对象

DataSourceControl 对象

PivotTable 对象

Spreadsheet 对象

BuildNumber 属性

MajorVersion 属性

RevisionNumber 属性

Version 属性


ChLine 对象


Spreadsheet 对象

MoveAfterReturnDirection 属性


Spreadsheet 对象

MoveAfterReturn 属性


ChAxis 对象

ChChart 对象

ChFont 对象

ChSeries 对象

Font 对象

GroupingDef 对象

Hyperlink 对象

ListObject 对象

Name 对象

PageField 对象

PageRelationship 对象

PageRowsource 对象

ParameterValue 对象

PivotAggregate 对象

PivotAxisMember 对象

PivotColumnMember 对象

PivotField 对象

PivotFieldSet 对象

PivotFont 对象

PivotHyperlink 对象

PivotMember 对象

PivotMemberProperty 对象

PivotPageMember 对象

PivotResultMemberProperty 对象

PivotRowMember 对象

PivotTotal 对象

Range 对象

RecordsetDef 对象

SchemaField 对象

SchemaParameter 对象

SchemaProperty 对象

SchemaRelatedField 对象

SchemaRelationship 对象

SchemaRowsource 对象

Spreadsheet 对象

Workbook 对象

Worksheet 对象

BaseName 属性


Spreadsheet 对象

Workbook 对象

Worksheet 对象

Name 属性

Names 集合


Previous 属性


Section 对象

PreviousSibling 属性


ChAxis 对象

ChDataLabels 对象

PivotField 对象

PivotMemberProperty 对象

PivotTotal 对象

Range 对象


SchemaParameter 对象


ChartSpace 对象

ChAxis 对象

ChCategoryLabel 对象

ChChart 对象

ChChartField 对象

ChDataLabel 对象

ChDataLabels 对象

ChDropZone 对象

ChErrorBars 对象

ChGridlines 对象

ChLegend 对象

ChLegendEntry 对象

ChPlotArea 对象

ChPoint 对象

ChSeries 对象

ChTitle 对象

ChTrendline 对象


DataSourceControl 对象

OfflineType 属性


ManySide 属性


PivotField 对象

IsValid 属性


ChAxis 对象

ChScaling 对象

PivotFieldSet 对象


GapWidth 属性


PivotData 对象

PivotView 对象

PivotGroupAxis 对象

PivotResultGroupAxis 对象


GroupingDef 对象

PageRowsource 对象

RecordsetDef 对象


PageField 对象

PageRowsources 属性


RecordsetDef 对象

PageRowsource 属性


AutoFilter 对象

Border 对象

Borders 集合对象

ChartSpace 对象

ChAxes 集合

ChAxis 对象

ChBorder 对象

ChCategoryLabel 对象

ChCategoryLabels 集合对象

ChChart 对象

ChChartField 对象

ChChartFields 对象

ChCharts 集合

ChDataLabel 对象

ChDataLabels 对象

ChDataLabelsCollection 集合

ChDropZone 对象

ChErrorBars 对象

ChErrorBarsCollection 对象

ChGridlines 对象

ChLegend 对象

ChLegendEntries 集合

ChLegendEntry 对象

ChPlotArea 对象

ChPoint 对象

ChPoints 集合

ChSegments 对象

ChSelectionCollection 集合

ChSeries 对象

ChSeriesCollection 集合对象

ChSurface 对象

ChTitle 对象

ChTrendline 对象

ChTrendlines 集合

ChUserDefinedSelection 对象

Criteria 对象

Filter 对象

Filters 集合对象

Font 对象

Heading 对象

Headings 对象

Hyperlink 对象

Interior 对象

ListObject 对象

ListObjects 集合

ListRow 对象

ListRows 集合

Name 对象

Names 集合

Pane 对象

Panes 集合对象

PivotHyperlink 对象

PivotTable 对象

Protection 对象

Range 对象

Sheets 集合

TitleBar 对象

Window 对象

Windows 集合对象

Workbook 对象

Workbooks 集合

Worksheet 对象

Worksheets 集合对象

XmlDataBinding 对象

XmlDataBindings 集合

XmlMap 对象

XmlMaps 集合


PivotAxisMember 对象

PivotColumnMember 对象

PivotPageMember 对象

PivotRowMember 对象

ChildAxisMembers 属性

ParentColumnMember 属性

ParentMember 属性

ParentPageMember 属性

ParentRowMember 属性

PivotAxisMember 对象


ChCategoryLabel 对象


ChildMembers 属性


Section 对象

ChildSection 属性


ChInterior 对象

SetPatterned 方法


DSCEventInfo 对象

RecordsetSaveProgress 事件


PivotResultGroupAxis 对象


ChCategoryLabel 对象

ChChartField 对象

ChLegendEntry 对象

ChPoint 对象

ChSeries 对象


ChAxis 对象

ChDataLabels 对象

ChLegend 对象

ChTitle 对象


ChInterior 对象

SetPresetGradient 方法


ChInterior 对象

SetTextured 方法


Next 属性


Section 对象

NextSection 属性


Section 对象

NextSibling 属性


ChChart 对象

ExtrudeAngle 属性


SchemaField 对象

SchemaParameter 对象

SchemaRowsource 对象


PivotAggregate 对象


Window 对象

Range 属性


DataPage 对象

PivotCell 对象

PivotData 对象


PageField 对象

PageRowsource 对象


ElementExtension 对象

RecordNavigationControl 对象


ElementExtension 对象

GroupLevel 对象

RecordNavigationControl 对象


Name 对象


ElementExtension 对象

RecordsetDef 对象


DSCEventInfo 对象

DSCEventInfo 对象


ChartSpace 对象

DataSourceControl 对象

PivotTable 对象

Spreadsheet 对象

BuildNumber 属性

MajorVersion 属性

MinorVersion 属性

Version 属性


Column 属性


ColumnAxis 属性


Window 对象

ColumnHeadings 属性


Range 对象

ColumnWidth 属性


PivotCell 对象

PivotResultRowAxis 对象

ColumnMember 属性

ColumnMembers 属性

RowMembers 属性


Columns 属性


ChAxis 对象

Scalings 属性


Scaling 属性


Window 对象

ScrollRow 属性


Window 对象

ScrollColumn 属性


ChFormatMap 对象

ChSegments 对象


Window 对象

ActiveSheet 属性


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

Window 对象

File Not Found

Select 方法

SelectionChange 事件

SelectionType 属性


ChartSpace 对象

PivotTable 对象

File Not Found

Select 方法

Selection 属性

SelectionChange 事件


Spreadsheet 对象

Workbook 对象

Sheets 集合

Worksheets 属性


Criteria 对象

AutoFilter 方法


PivotTotal 对象

ShowAsValue 属性


PivotAggregate 对象

ShowAs 属性


RecordNavigationControl 对象

ShowFilterBySelectionButton 属性

ShowFirstButton 属性

ShowHelpButton 属性

ShowLabel 属性

ShowLastButton 属性

ShowNewButton 属性

ShowNextButton 属性

ShowPrevButton 属性

ShowSaveButton 属性

ShowSortAscendingButton 属性

ShowSortDescendingButton 属性

ShowToggleFilterButton 属性

ShowUndoButton 属性


RecordNavigationControl 对象

ShowDelButton 属性

ShowFirstButton 属性

ShowHelpButton 属性

ShowLabel 属性

ShowLastButton 属性

ShowNewButton 属性

ShowNextButton 属性

ShowPrevButton 属性

ShowSaveButton 属性

ShowSortAscendingButton 属性

ShowSortDescendingButton 属性

ShowToggleFilterButton 属性

ShowUndoButton 属性


RecordNavigationControl 对象

ShowDelButton 属性

ShowFilterBySelectionButton 属性

ShowHelpButton 属性

ShowLabel 属性

ShowLastButton 属性

ShowNewButton 属性

ShowNextButton 属性

ShowPrevButton 属性

ShowSaveButton 属性

ShowSortAscendingButton 属性

ShowSortDescendingButton 属性

ShowToggleFilterButton 属性

ShowUndoButton 属性


RecordNavigationControl 对象

ShowDelButton 属性

ShowFilterBySelectionButton 属性

ShowFirstButton 属性

ShowLabel 属性

ShowLastButton 属性

ShowNewButton 属性

ShowNextButton 属性

ShowPrevButton 属性

ShowSaveButton 属性

ShowSortAscendingButton 属性

ShowSortDescendingButton 属性

ShowToggleFilterButton 属性

ShowUndoButton 属性


RecordNavigationControl 对象

ShowDelButton 属性

ShowFilterBySelectionButton 属性

ShowFirstButton 属性

ShowHelpButton 属性

ShowLastButton 属性

ShowNewButton 属性

ShowNextButton 属性

ShowPrevButton 属性

ShowSaveButton 属性

ShowSortAscendingButton 属性

ShowSortDescendingButton 属性

ShowToggleFilterButton 属性

ShowUndoButton 属性


RecordNavigationControl 对象

ShowDelButton 属性

ShowFilterBySelectionButton 属性

ShowFirstButton 属性

ShowHelpButton 属性

ShowLabel 属性

ShowNewButton 属性

ShowNextButton 属性

ShowPrevButton 属性

ShowSaveButton 属性

ShowSortAscendingButton 属性

ShowSortDescendingButton 属性

ShowToggleFilterButton 属性

ShowUndoButton 属性


RecordNavigationControl 对象

ShowDelButton 属性

ShowFilterBySelectionButton 属性

ShowFirstButton 属性

ShowHelpButton 属性

ShowLabel 属性

ShowLastButton 属性

ShowNextButton 属性

ShowPrevButton 属性

ShowSaveButton 属性

ShowSortAscendingButton 属性

ShowSortDescendingButton 属性

ShowToggleFilterButton 属性

ShowUndoButton 属性


RecordNavigationControl 对象

ShowDelButton 属性

ShowFilterBySelectionButton 属性

ShowFirstButton 属性

ShowHelpButton 属性

ShowLabel 属性

ShowLastButton 属性

ShowNewButton 属性

ShowPrevButton 属性

ShowSaveButton 属性

ShowSortAscendingButton 属性

ShowSortDescendingButton 属性

ShowToggleFilterButton 属性

ShowUndoButton 属性


RecordNavigationControl 对象

ShowDelButton 属性

ShowFilterBySelectionButton 属性

ShowFirstButton 属性

ShowHelpButton 属性

ShowLabel 属性

ShowLastButton 属性

ShowNewButton 属性

ShowNextButton 属性

ShowSaveButton 属性

ShowSortAscendingButton 属性

ShowSortDescendingButton 属性

ShowToggleFilterButton 属性

ShowUndoButton 属性


RecordNavigationControl 对象

ShowDelButton 属性

ShowFilterBySelectionButton 属性

ShowFirstButton 属性

ShowHelpButton 属性

ShowLabel 属性

ShowLastButton 属性

ShowNewButton 属性

ShowNextButton 属性

ShowPrevButton 属性

ShowSortAscendingButton 属性

ShowSortDescendingButton 属性

ShowToggleFilterButton 属性

ShowUndoButton 属性


RecordNavigationControl 对象

ShowDelButton 属性

ShowFilterBySelectionButton 属性

ShowFirstButton 属性

ShowHelpButton 属性

ShowLabel 属性

ShowLastButton 属性

ShowNewButton 属性

ShowNextButton 属性

ShowPrevButton 属性

ShowSaveButton 属性

ShowSortDescendingButton 属性

ShowToggleFilterButton 属性

ShowUndoButton 属性


RecordNavigationControl 对象

ShowDelButton 属性

ShowFilterBySelectionButton 属性

ShowFirstButton 属性

ShowHelpButton 属性

ShowLabel 属性

ShowLastButton 属性

ShowNewButton 属性

ShowNextButton 属性

ShowPrevButton 属性

ShowSaveButton 属性

ShowSortAscendingButton 属性

ShowToggleFilterButton 属性

ShowUndoButton 属性


RecordNavigationControl 对象

ShowDelButton 属性

ShowFilterBySelectionButton 属性

ShowFirstButton 属性

ShowHelpButton 属性

ShowLabel 属性

ShowLastButton 属性

ShowNewButton 属性

ShowNextButton 属性

ShowPrevButton 属性

ShowSaveButton 属性

ShowSortAscendingButton 属性

ShowSortDescendingButton 属性

ShowUndoButton 属性


RecordNavigationControl 对象

ShowDelButton 属性

ShowFilterBySelectionButton 属性

ShowFirstButton 属性

ShowHelpButton 属性

ShowLabel 属性

ShowLastButton 属性

ShowNewButton 属性

ShowNextButton 属性

ShowPrevButton 属性

ShowSaveButton 属性

ShowSortAscendingButton 属性

ShowSortDescendingButton 属性

ShowToggleFilterButton 属性


Style 属性


ChChart 对象

BubbleScale 属性


PivotResultAxis 对象

PivotResultColumnAxis 对象

PivotResultDataAxis 对象

PivotResultFilterAxis 对象

PivotResultGroupAxis 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotAxis 对象


PivotResultColumnAxis 对象

PivotGroupAxis 对象


PivotResultDataAxis 对象

PivotDataAxis 对象


PivotResultFilterAxis 对象

PivotFilterAxis 对象


PivotResultLabel 对象

PivotLabel 对象


PivotMember 对象


PivotResultPageAxis 对象

PivotGroupAxis 对象


PivotResultRowAxis 对象

PivotGroupAxis 对象


Worksheet 对象

StandardWidth 属性


Worksheet 对象

StandardHeight 属性


ChMarker 对象

Size 属性


Hyperlink 对象

PivotHyperlink 对象

Address 属性

Follow 方法


NumberFormat 属性


ChSeries 对象

ChSurface 对象


ChAxis 对象

TickMarkSpacing 属性


ChAxis 对象

TickMarkUnitType 属性


ChAxis 对象

TickLabelSpacing 属性


ChAxis 对象

TickLabelUnitType 属性


ChSeries 对象

OCCommand 对象


ChAxis 对象

ChChart 对象

ChartSpaceTitle 属性

HasChartSpaceTitle 属性

HasTitle 属性


PivotData 对象

Top 属性


ChartSpace 对象

ChAxis 对象

ChCategoryLabel 对象

ChChart 对象

ChChartField 对象

ChDataLabel 对象

ChDataLabels 对象

ChDropZone 对象

ChErrorBars 对象

ChLegend 对象

ChLegendEntry 对象

ChPlotArea 对象

ChPoint 对象

ChScrollView 对象

ChSeries 对象

ChTitle 对象

ChTrendline 对象

PivotAxisMember 对象

PivotColumnMember 对象

PivotData 对象

PivotDetailCell 对象

PivotPageMember 对象

PivotResultAxis 对象

PivotResultColumnAxis 对象

PivotResultDataAxis 对象

PivotResultFilterAxis 对象

PivotResultGroupAxis 对象

PivotResultLabel 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotRowMember 对象

PivotTable 对象

Range 对象

Window 对象

Left 属性


BottomRight 属性


PivotColumnMember 对象

TotalRowMember 属性


PivotAxisMember 对象

PivotColumnMember 对象

PivotPageMember 对象

PivotRowMember 对象

TotalColumnMember 属性

TotalPageMember 属性

TotalRowMember 属性


PivotPageMember 对象

TotalMember 属性


PivotRowMember 对象

TotalMember 属性


PivotTotals 集合对象


ElementExtension 对象

PageField 对象


ChAxis 对象

ChChart 对象

ChErrorBars 对象

ChScaling 对象

ChSeries 对象

ChTrendline 对象

PageRelationship 对象

PivotField 对象

PivotFieldSet 对象

PivotTotal 对象

SchemaRowsource 对象

Section 对象

Window 对象

Worksheet 对象


ChFont 对象

Font 对象

PivotFont 对象

Bold 属性

Italic 属性


PivotAxisMember 对象

PivotColumnMember 对象

PivotField 对象

PivotFieldSet 对象

PivotMember 对象

PivotPageMember 对象

PivotRowMember 对象

PivotTotal 对象


Window 对象

UsableWidth 属性


Window 对象

UsableHeight 属性


Worksheet 对象

CurrentRegion 属性


PivotTable 对象

ViewOnlyMode 属性


Range 对象

UseStandardWidth 属性


Range 对象

UseStandardHeight 属性


DataSourceControl 对象

XMLLocation 属性


Range 对象

Value 属性


Borders 集合对象

ByRef 对象

ChSegmentBoundary 对象

Name 对象

ParameterValue 对象

PivotAggregate 对象

PivotAxisMember 对象

PivotColumnMember 对象

PivotDetailCell 对象

PivotMember 对象

PivotPageMember 对象

PivotResultMemberProperty 对象

PivotRowMember 对象

Range 对象

SchemaProperty 对象

Spreadsheet 对象

Formula 属性


ChSegmentBoundary 对象


ChartSpace 对象

DataSourceControl 对象

PivotTable 对象

Spreadsheet 对象

BuildNumber 属性

MajorVersion 属性

MinorVersion 属性

RevisionNumber 属性


Range 对象

HorizontalAlignment 属性


PivotAxis 对象

PivotAxisMember 对象

PivotColumnMember 对象

PivotData 对象

PivotDataAxis 对象

PivotFieldSet 对象

PivotFilterAxis 对象

PivotGroupAxis 对象

PivotMember 对象

PivotPageMember 对象

PivotRowMember 对象

PivotTotal 对象

ActiveView 属性


Window 对象

VisibleRange 属性


UserMode 属性


PivotData 对象

ViewportTop 属性


PivotData 对象

ViewportLeft 属性


ChDataLabel 对象

ChLegendEntry 对象

PivotLabel 对象

Sheets 集合

TitleBar 对象

Window 对象

Worksheet 对象

Worksheets 集合对象


ViewableRange 属性


Border 对象

Borders 集合对象

ChBorder 对象

ChLine 对象


PivotAxisMember 对象

PivotColumnMember 对象

PivotDetailCell 对象

PivotFieldSet 对象

PivotPageMember 对象

PivotResultAxis 对象

PivotResultColumnAxis 对象

PivotResultDataAxis 对象

PivotResultFilterAxis 对象

PivotResultGroupAxis 对象

PivotResultLabel 对象

PivotResultPageAxis 对象

PivotResultRowAxis 对象

PivotRowMember 对象

PivotTable 对象

PivotTotal 对象

Range 对象

Window 对象

Height 属性


ChChart 对象

HeightRatio 属性


Windows 集合对象


Spreadsheet 对象

Workbooks 集合


Range 对象

Worksheet 对象


Worksheets 集合对象


Coordinate 对象


ChartSpace 对象

PivotTable 对象

Spreadsheet 对象

CSVData 属性

CSVURL 属性

HTMLData 属性

HTMLURL 属性


DataSourceControl 对象模型

Microsoft Office Web Components 对象模型

PivotTable 对象模型

电子表格对象模型


图表工作区对象模型

Microsoft Office Web Components 对象模型

PivotTable 对象模型

电子表格对象模型


图表工作区对象模型

DataSourceControl 对象模型

Microsoft Office Web Components 对象模型

电子表格对象模型


图表工作区对象模型

DataSourceControl 对象模型

Microsoft Office Web Components 对象模型

PivotTable 对象模型


INDEX~TEXT
seealso~"参阅"
appliesto~"应用于"
elements~"元素"
properties~"属性"
methods~"方法"
events~"事件"
example~"示例"
specifics~"特性"
show~"显示说明"
hide~"隐藏说明"
parentelements~"父元素"
childelements~"子元素"
attributeslinks~"特性"
section~"节"
rows~"行"
cells~"单元格"