关于电子表格

可以使用电子表格输入和计算数据。电子表格由单元格的行和列组成。可以直接在电子表格的单元格中输入数据，并使用公式对这些数据进行计算。用户可以更改数据，并看到自动计算出的结果。也可以对单元格中的数据进行排序、筛选和查找。下例显示了在网页上用作购房贷款计算器的电子表格。当用户在浏览器中更改了带边框的输入单元格中的值时，电子表格将计算购房贷款的支付金额。

显示 浏览器及许可要求

若要在浏览器中查看并使用交互式的电子表格，则必须安装 Microsoft Office Web Components，具有有效的 Microsoft Office 2003 许可，以及 Microsoft Internet Explorer 5.01 (Service Pack 2) 或更高版本。如果没有适当的许可，您可以查看组件但不能与其进行交互。请联系网络或计算机的管理员以查看您的系统是否符合与电子表格进行交互所必需的条件。

显示 保存更改

在电子表格中进行的更改只对当前的浏览器会话有效。如果要保存对电子表格中数据所做的更改，请将数据导出到一张 Microsoft Excel 工作表上，并在该工作表中保存数据。

显示 禁用的功能

电子表格中的一些项目可能已由网页的设计者保护起来。例如，设计者可能已锁定某些单元格、禁止排序和筛选、禁止显示工具栏或“命令和选项”对话框。如果在访问这些功能时遇到问题，而您的计算机符合浏览器和许可的要求，那么请与网页的设计者联系。

显示 关于电子表格 Web 部件

除在标准网页上使用电子表格组件外，如果您有访问运行 Microsoft Windows SharePoint Services 的服务器的权限，就可以将电子表格用作 Web 部件页面上的电子表格 Web 部件。在 Windows SharePoint Services 网站可以支持电子表格 Web 部件之前，网站管理员必须先在该网站上安装 Office 2003 Web 部件和组件。Office 2003 Web 部件和组件可从 Microsoft Office Online 上的下载内容中获得。该安装只需要执行一次就可以在该网站上支持任何数量的电子表格 Web 部件。

电子表格 Web 部件

电子表格 Web 部件支持电子表格组件的所有功能，还可支持 Web 部件的其他特殊功能，比如，创建 Web 部件连接以允许 Web 部件向其他 Web 部件发送数据或从选定行接收数据。

注释 电子表格 Web 部件与电子表格组件具有相同的许可要求，需要 Microsoft Internet Explorer 5.01 (Service Pack 2) 或更高版本。

有关电子表格 Web 部件的详细信息，请参阅 Microsoft Office Excel 2003 帮助中的以下帮助主题：“关于电子表格 Web 部件”、“创建数据绑定电子表格 Web 部件”和“创建可连接的电子表格 Web 部件”。请在“目录”中，单击“Excel 和 Web”，然后单击“使用电子表格 Web 部件”。


关于 XML 列表

当电子表格组件的用户或设计者使用数据检索服务或“数据检索服务连接”文件 (.uxdc) 从数据源中查询和导入数据时，数据会以名为 XML 列表的表结构显示出来。XML 列表的行为与数据库程序中的数据表很类似：当在列表中添加、删除、筛选和排序项目时，列表中的每行都会作为单个记录处理。XML 列表与可以刷新以显示数据源当前信息的查询相关联。另外，您还可以编辑该查询以提供不同的查询参数值、选择不同的域、筛选数据和排序数据，因此，您可有效地检索所需的数据子集。

XML 列表具有如下的视觉功能，可将它与电子表格中的其他区域区分开。

  • 框架清晰地概述了 XML 列表中的数据。框架内的数据是从数据源中返回的；框架外的数据不属于从数据源返回的数据。
  • XML 列表可以显示不属于从数据源检索到的数据的列标题，因此，您的标题永远不会在该数据被筛选时和数据一起排序或被排除。
  • XML 列表在列表底部显示被称为插入行的行，以便简化新记录的添加：只要在插入行中单击并进行键入即可。

如果设计者还未锁定整个 XML 列表以及禁用 XML 列表的其他功能，则处理 XML 列表中的数据就会如以下章节所描述的那样。

显示 添加记录

默认情况下，当您单击 XML 列表内的任何单元格时，在最左侧的单元格中带有蓝色星号字符的空行显示在列表尾部。该行称为插入行。您使用插入行向 XML 列表中添加新行。下面的规则和行为适用于使用插入行添加记录。

  • 您可以在插入行中的任何未锁定列中键入值，从而自动在您当前键入的行下面显示新的插入行。
  • 当右键单击 XML 列表中除第一行以外的任何行时，指向“插入”，然后单击“行”，不能插入新行。相反，选定内容会移动到插入行。如果右键单击第一行，指向“插入”，然后单击“行”，就会有一个新行插入到 XML 列表上。
  • 如果页面设计者已经对 XML 列表中的某个列应用了格式，当向 XML 列表中添加新记录时，同样的格式会应用到该列中的所有值。
  • 在向 XML 列表中添加行时，列表下的电子表格中的所有值都向下移动一行。

显示 粘贴记录

下面的规则在向插入行中粘贴单元格时适用。

  • 可以粘贴多行数据。
  • 如果粘贴的列数大于 XML 列表中的数字，多余的行就会粘贴到 XML 列表的右侧，但不成为列表的一部分。
  • 如果为任何列定义了验证，而对于任何粘贴值的验证失败了，则整个粘贴操作就会失败。错误消息会显示验证失败的第一个值。

显示 删除记录

下面的规则和行为在 XML 列表中删除行时适用。

  • 当您在 XML 列表中选中除插入行以外的一行或多行时，右键单击，指向“删除”，然后单击“行”时，选定的行就会被删除，它下面的所有行，以及列表下的所有值都会上移。
  • 插入行不能删除。

显示 排序记录

排序 XML 列表使用与排序电子表格中的其他数据所使用的相同的命令和工具栏按钮，此时下面的规则适用。

  • 无法对 XML 列表的子集进行排序，无论在列表中如何选择单元格。在排序时，列表内的整个行（记录）都会进行排序，列表内的所有行都会进行排序。
  • 工具栏上的“升序排序”和“降序排序”按钮的下拉列表中的列名来自 XML 列表中与第一行相邻的上面一行单元格中的值。如果与列表相邻的上面一行单元格没有值，则会使用标签“列 1 (列标)”、“列 2 (列标)”，等等。
  • 如果选定内容扩展到 XML 列表之外，就会禁用排序。

显示 筛选记录

通过使用工具栏上的“自动筛选”按钮对 XML 列表中的值进行筛选，其工作方式与在电子表格中筛选任何其他数据一样，只是对 XML 列表的筛选所筛选的是整个列表行，而且始终应用到列表中的所有行。“自动筛选”箭头显示在紧挨 XML 列表上的行中，除非列表从第 1 行开始，在这种情况下，筛选箭头显示在 XML 列表数据的第一行中。因此，在 XML 列表没有标题行的情况下，如果在 XML 列表上面插入行并添加列标题，筛选数据就更容易了。

显示 插入和删除列

不能在 XML 列表中插入或删除列。不过，如果选定内容位于 XML 列表的第一（最左侧）列，可以在列表的左边（外部）插入列。

显示 计算列

包含 XML 列表的电子表格组件的设计者，可在列表内创建不属于与 XML 列表绑定的数据源的计算列。例如，如果数据源有两个包含项目的单价和项目数量的列，设计者就可向 XML 列表中添加计算列以计算扩展价格。计算列中的公式被应用到使用插入行添加的所有新行。

在使用 XML 列表时，可以向插入行中的单元格添加公式，但添加的公式不应用到每个新行，而且在使用“保存”命令时或者刷新来自外部数据源的数据后不会进行保存。

显示 使用相关的查询

右键单击列表，然后使用“外部数据”子菜单上的命令来使用与 XML 列表相关的查询。下表对这些命令进行说明。

命令 | 说明
刷新数据 | 通过使用与 XML 列表相关的查询显示来自数据源的当前信息再次查询数据。
保存数据 | 如果查询和数据源的定义支持对数据源的更新，该命令就会用 XML 列表中的信息来更新数据源中的数据。如果查询不支持更新，就会禁用该命令。 注释 “数据连接向导”不支持创建更新查询。
编辑查询 | 显示“数据连接向导”，其中包含“选择字段”对话框，以便选择要显示的不同的字段。单击“后退”可更改查询定义中的不同设置，比如选择要使用的数据对象，以及指定查询参数值。单击“下一步”可对数据进行排序、指定筛选标准以及限制返回的行数。“数据连接向导”中的可用设置将根据使用的数据源的不同而改变。当完成对查询的编辑时，请单击“完成”。
删除查询 | 从电子表格中删除 XML 列表及其相关查询。 要点 使用该命令会显示一条消息，要求确认是否删除查询。如果回答“是”，就无法撤消该命令。如果电子表格的布局和格式中包含 XML 列表的定义，可刷新页面再次显示 XML 列表。


电子表格的浏览器支持

若要使用交互式电子表格，用户必须有 Microsoft Internet Explorer 5.01 (Service Pack 2) 或更高版本，安装 Microsoft Office Web Components，并拥有适当的 Microsoft Office 2003 许可。如果没有 Office 2003 许可，也可安装该组件，并在网页中对其进行查看，但是不能与其进行交互。

注释 电子表格 Web 部件与电子表格组件具有相同的许可要求。有关电子表格 Web 部件的详细信息，请参阅关于电子表格中的“关于电子表格 Web 部件”部分。


关于 Microsoft Office Web Components

Microsoft Office Web Components 是 Microsoft Office 2003 中安装的一组 ActiveX 控件。计算机上安装了 Office Web 组件之后，您就可以在 Internet Explorer 5.01 (Service Pack 2) 或更高版本中对电子表格、数据透视表列表和图表进行交互访问。

如果计算机上未安装 Office Web 组件，但您有允许 Intranet 发布的 Office 2003 站点许可证，则可对组件进行配置，以提示用户从公司的 Intranet 下载 Office Web 组件。这样，您网站上的用户无需在计算机上安装 Office 2003 软件就可使用数据访问页。

有关如何配置 Office Web 组件的信息，请参阅 Microsoft Office Resource Kit 网站。


关于 Office Web 组件的“仅供查看”模式

如果您的计算机未安装 Microsoft Office 2003 软件许可，或不能通过 Microsoft Office 2003 应用程序获取该许可，那么只能在网页上查看某个 Microsoft Office Web Component（电子表格组件、图表组件或数据透视表组件），而不能与其进行交互。

若要与正在查看的组件进行交互并使用其完整的功能，则必须安装 Microsoft Office 2003 或获取 Office 2003 许可。如果您是在公司或组织中，请与网络管理员咨询以获取帮助。

在“仅供查看”模式中，可以执行下列操作：

  • 查看数据。
  • 打印。
  • 选择和滚动数据。
  • 使用超链接。
  • 调整组件大小。
  • 在“电子表格组件”中选取工作表。
  • 展开或折叠数据透视表列表中的成员。
  • 刷新数据透视表列表中的数据。
  • 可使用“关于”、“帮助”和“刷新”命令。但有关交互（例如设置单元格格式、拖动字段、排序、筛选等）的帮助主题不可用。

在“仅供查看”模式中，只可使用“关于”、“帮助”、和“刷新”命令，其他命令都不可用。


关于访问不同域上的数据源

电子表格试图访问另一个域上的数据，但由于以下一个原因失败了：

  • 控件正在访问的网站不包括在可信网站的列表内。
  • 在 Internet Explorer 中的“安全设置”对话框上，在“其他”下面的“通过域访问数据资源”设置被设为“禁用”，或被设为“提示”，而当您被提示时，却单击了“取消”。

若要启用跨域访问，请执行下列操作：

显示 启用提示

  1. 在 Internet Explorer 中的 “工具”菜单上，单击“Internet 选项”。在“安全”选项卡上选择相应的 Web 内容区域，然后单击“自定义级别”。在“其他”下面，将“通过域访问数据资源”设置为“提示”。
  2. 当被提示时，如果您信任数据提供商，请单击“确定”以便允许数据透视表列表从指定域访问数据。

显示 将网站添加到可信网站列表中

如果正在访问的网站总是可靠的，则可将网站添加到可信网站列表中。

  1. 在 Internet Explorer 中的“工具”菜单上，单击“Internet 选项”。在“安全”选项卡上选择“受信任的站点”作为 Web 内容区域，然后单击“站点”。
  2. 在“可信站点”对话框中，输入网站详细信息，然后单击“确定”。


关于获取电子表格的设计“帮助”

本主题中的部分内容可能不适用于某些语言。

在 Web 浏览器中查看电子表格并与其进行交互时，实际上是使用由其他程序（称为设计程序）所创建的组件。在设计程序中，例如 Microsoft FrontPage 或 Microsoft Access 的数据访问页，用户可向电子表格添加所需数据，也可以将电子表格添加到正在设计的网页中，以及将网页发布到 Web 服务器上。设计程序提供了有关设计电子表格的“帮助”。

要了解如何设计电子表格，请首先选择将要使用的设计程序。可以使用任何支持的设计程序，如果需要其他的设计功能，则可以稍后在其他设计程序中对此电子表格进行处理。

显示 在设计程序中获取帮助

如果您具有 Microsoft Office 2003 许可，并已安装 Microsoft Office Web Components，则可在几个程序中创建和修改电子表格。可以在一个程序中创建电子表格，然后使用另一个程序修改电子表格或该电子表格所在的网页。

选择使用何种设计程序取决于要在网页上进行设计和管理的工作量、要使用的数据类型和对不同设计程序的熟悉程度等。

Microsoft Excel 如果要尝试使用不同的公式、调整引用、从其他源导入数据或设计交互式图表以反映电子表格中的数据，则 Excel 是创建电子表格的最佳设计环境。

Microsoft FrontPage 如果希望创建网页或修改通过 Excel 发布的电子表格，则建议使用 FrontPage 设计程序。在 FrontPage 中，除了可以创建网页上的电子表格，还可修改用其他程序设计的电子表格。使用 FrontPage 的扩展网页编辑和管理功能向网页中添加控件、图形、主题以及其他内容，然后将页面变成网站的一部分。FrontPage 可在 Office 2003 中获得。

Microsoft Access 如果要创建对数据库中的数据进行操作和显示的网页，并且用户使用 Internet Explorer 5.01 SP2 或更高版本，则应使用 Access 的数据访问页“设计”视图来创建电子表格。可以使用 Access 建立从 Access 数据库到网页之间的连接，然后还可以使用电子表格中的公式将数据库的值返回到电子表格中。Access 可在 Office 2003 中获得。

Microsoft Visual Basic 如果需要比 Excel、FrontPage 和 Access 所提供的脚本功能更全面的编程环境，则可在 Visual Basic 中设计电子表格。如果自定义解决方案中需要包含电子表格或计算引擎，则可使用 Visual Basic。用户可在该程序中对 Visual Basic 窗体上的电子表格进行交互和查看。窗体将代替浏览器而成为运行环境，该程序可使许多电子表格或计算功能自动执行。

在设计程序中工作时，可按以下方法获取帮助：

  • 设计程序的“帮助” 有关在设计程序中可用于处理电子表格的命令与功能的详细信息，请参阅设计程序的“帮助”。例如，在 Microsoft FrontPage 中，可以单击“Microsoft FrontPage 帮助” 按钮图像 。

    Microsoft Excel 提供了有关保存 Excel 数据以便用于网页的一般性帮助，也提供了有关保存电子表格以便用于网页的特定信息。若要在 Excel 中访问该“帮助”，请单击“Microsoft Excel 帮助” 按钮图像 。

  • 电子表格的设计时“帮助” 如果在其他设计程序中可以访问“命令和选项”对话框，则可以访问设计时的“帮助”主题。在用设计程序创建或激活的电子表格中，请单击“命令和选项”对话框中的“帮助” 按钮图像 ，或单击电子表格工具栏上的“帮助”。

显示 获取编写使用电子表格的脚本和程序的“帮助”

可以使用脚本和程序使电子表格具有自动化功能，还可将电子表格包含在非 Web 浏览器的运行时程序中，运行时程序是用编程环境（例如 Microsoft Visual Basic）开发的程序。

编写脚本 Microsoft Office 程序提供了“Microsoft 脚本编辑器”以帮助编写脚本。例如，可以在 FrontPage 中使用“脚本编辑器”来自定义电子表格。有关运行“脚本编辑器”的详细信息，请参阅 Office 设计程序中的“帮助”。在“脚本编辑器”中，可以显示有关使用其功能和编写脚本的其他“帮助”。

对象模型的“帮助” 有关开发程序或脚本以处理电子表格的“帮助”可以显示与电子表格相关的对象模型、属性和方法的信息。在安装 Microsoft Office Web Components（“电子表格组件”就是其中之一）的同时也将安装对象模型“帮助”。根据所用设计程序的不同，可以按下列两种方法之一访问此“帮助”：

  • Visual Basic 中的“帮助” 在 Visual Basic 或 Microsoft Visual Basic for Applications 中，可以创建对 Microsoft Office Web Components 库的引用，然后，就可以通过对象浏览器或通过选择关键字并按 F1 来访问“帮助”。有关创建引用和使用对象模型“帮助”的详细信息，请参阅 Visual Basic 或 VBA 中的“帮助”。
  • 其他环境中的“帮助” 如果使用的是其他开发环境，则请定位并双击帮助文件“owcvba11.chm”。

显示 获取关于电子表格 Web 部件的帮助

电子表格 Web 部件中组合了多种技术的使用，包括 Microsoft Windows SharePoint Services、Microsoft Office 2003、Microsoft Office Excel 2003 和 Microsoft Office Web Components。电子表格 Web 部件其实就是 Web 部件中的电子表格组件。在使用该 Web 部件时可能需要使用的帮助信息可以从多个不同位置获得。

显示 获得电子表格 Web 部件帮助

电子表格 Web 部件帮助主题是上下文相关的帮助主题，可解答与 Web 部件有关的特定问题，比如，它有哪些用途、如何使用它、有哪些常用属性和自定义属性、如何与其他 Web 部件连接，以及如何进行故障诊断。

当您在 Windows SharePoint Services 服务器上安装 Microsoft Office Web 部件和组件产品时，即可获得该帮助信息。

若要显示电子表格“Web 部件”帮助信息，请在 Web 部件菜单上，单击“帮助”。

显示 获得 Microsoft Office 电子表格组件帮助

电子表格组件是独立的，可以合并到其他 Microsoft Office 产品和用户指定的应用程序中。Microsoft Office Web Components 中包含单独的帮助系统，专门用于说明如何使用它们。

这是您正在阅读的帮助信息，当您在计算机上安装 Microsoft Office Web Components 时可获得它。

若要获得 Office 电子表格组件帮助信息，请在“电子表格组件”工具栏上，单击“帮助”。

显示 获取 Microsoft Windows SharePoint Services 帮助

Windows SharePoint Services 帮助系统提供您可能需要的一些信息，这些信息是关于与电子表格 Web 部件相关的功能的，特别是创建、使用和管理 Web 部件页。

当管理员在服务器上安装 Windows SharePoint Services 时，您即可获得该帮助信息。

若要显示该帮助信息，请单击顶部链接栏上的“帮助”。

显示 获得数据连接向导帮助

数据连接向导是在多个 Microsoft Office 应用程序中使用的，包括电子表格组件和电子表格 Web 部件。

当一个或多个 Microsoft Office 产品安装到您的计算机上时，即可获得该帮助信息。

若要显示该帮助信息，请在任何 Microsoft Office 产品中参阅以下帮助主题：“有关 Office 数据连接文件的详细信息”和“有关数据源的详细信息”。

显示 获得自定义的电子表格 Web 部件帮助

有关创建自定义的电子表格 Web 部件的帮助信息可在 Microsoft Office Excel 2003 中找到。

当 Office Excel 2003 安装到您的计算机上时，即可获得该帮助信息。

若要显示该帮助信息，请参阅 Office Excel 2003 帮助中的如下帮助主题：“关于电子表格 Web 部件”、“创建数据绑定的电子表格 Web 部件”和“创建可连接的电子表格 Web 部件”。在“目录”中，请单击“Excel 和 Web”，然后单击“使用电子表格 Web 部件”

显示 从其他 Microsoft 网站获得帮助

以下的 Microsoft 网站中有关于使用和自定义电子表格 Web 部件的其他最新信息：

Microsoft Developer Network
Microsoft Office 帮助中心
Microsoft SharePoint 产品和技术帮助中心


电子表格中的键盘快捷键

有关用按键激活和停用页面上的“Microsoft Office 电子表格组件”的信息，请参阅设计程序中的“帮助”。

显示 显示快捷菜单的快捷键

Shift+F10
显示快捷菜单

显示 用于在电子表格中移动和滚动的键

箭头键
向上、下、左或右移动一个单元格
Ctrl+ 箭头键
移动到当前数据区域的边缘
Home
移动到行首
Ctrl+Home
移动到工作表的开头
Ctrl+End
移动到工作表的最后一个单元格，这个单元格位于数据区的最右列和最底行的交叉处（右下角）；或是与首单元格（一般为 A1）相对的单元格
Page Down
向下移动一屏
Page Up
向上移动一屏
Alt+Page Down
向右移动一屏
Alt+Page Up
向左移动一屏
Ctrl+Page Down
移动到下一张工作表
Ctrl+Page Up
移动到上一张工作表
Tab
在保护工作表上的非锁定单元格之间向前移动
Shift+Tab
在保护工作表上的非锁定单元格之间向后移动

显示 在 Scroll Lock 打开的状态下，用于移动的键

Scroll Lock
打开或关闭 Scroll Lock
向上键或向下键
向上或向下滚动一行
向左键或向右键
向左或向右滚动一列

显示 在工作表中使用的键

Shift+F11
插入新工作表
Ctrl+Page Down
移动到下一张工作表
Ctrl+Page Up
移动到上一张工作表
CTRL+E
将所有工作表导出到 Microsoft Excel

显示 在工作表上输入数据时使用的键

Enter
完成单元格输入并在选定区域中向下移动
Ctrl+Enter
用当前输入项填充选定的单元格区域
Shift+Enter
完成单元格输入并在选定区域中向上移动
Tab
完成单元格输入并在选定区域中向右移动
Ctrl+Shift+Enter
输入数组公式
Shift+Tab
完成单元格输入并在选定区域中向左移动
Esc
取消单元格输入
箭头键
向上、下、左或右移动一个字符
Home
移到行首
End
移到行尾
Alt+0128 （在数字小键盘上，且打开 Num Lock）
输入欧洲货币字符 欧元货币符号

显示 在单元格中使用的键

F2
编辑活动单元格，并将插入点放置到行尾
F9
计算活动电子表格中的所有工作表
=（等号）
键入公式
Alt+=（等号）
使用自动求和命令插入一个 SUM 函数
Backspace
删除插入点左边的字符或删除选定区域
Delete
删除插入点右边的字符或删除选定区域
Ctrl+Shift+Enter
将公式作为数组公式输入

显示 用于设置数据格式的键

Ctrl+B
应用或取消字体加粗格式
Ctrl+I
应用或取消字体倾斜格式
Ctrl+U
应用或取消下划线格式

显示 用于编辑数据的键

F2
编辑活动单元格，并将插入点放置到行尾
F4
在当前选定的引用的绝对和相对模式间切换
Esc
取消单元格中的输入
Backspace
清除活动单元格并保留编辑模式，或者在编辑单元格内容时删除活动单元格中的前一个字符
Enter
完成单元格输入

显示 用于插入、删除和复制选中区域的键

Ctrl+C
复制选定区域
Ctrl+X
剪切选定区域
Ctrl+V
粘贴选定区域
Delete
清除选定区域的内容
Ctrl+Z
撤消上一次操作

显示 用于在选中区域内移动的键

Enter
在选定区域内由上往下移动，或者按在“命令和选项”对话框中选定的方向移动
Shift+Enter
在选定区域内由下往上移动，或者按与“命令和选项”对话框中选定的方向相反的方向移动
Tab
在选定区域内由左往右移动。如果选定区域只有一列，则向下移动一个单元格
Shift+Tab
在选定区域内由右往左移动。如果选定区域只有一列，则向上移动一个单元格

显示 选择单元格、列或行时使用的键

Shift+ 箭头键
将选定区域扩展一个单元格
CTRL+/
选择包含活动单元格的数组
Ctrl+Shift+ 箭头键
将选定区域扩展到与活动单元格同一行或同一列的最后一个非空白单元格
Shift+Home
将选定区域扩展到行首
Ctrl+Shift+Home
将选定区域扩展到工作表的开始位置
Ctrl+Shift+End
将选定区域扩展到工作表的最后一个使用的单元格（右下角）
Ctrl+ 空格键
选定整列
Shift+ 空格键
选定整行
Ctrl+A
选定整张工作表
Shift+Page Up
将选定区域向上扩展一屏

显示 用于操作“自动筛选”下拉列表的快捷键

Ctrl+T
在选定区域上启用“自动筛选”
Alt+ 向下键
打开选定单元格的“自动筛选”下拉列表
Tab
在“自动筛选”下拉列表中最近选定的项、“确定”按钮和“取消”按钮之间循环切换
箭头键
移动到“自动筛选”下拉列表的下一项或上一项上
字母或数字键
在“自动筛选”下拉列表中，移动到以该字母或数字开头的第一项
Shift+ 箭头键
在“自动筛选”下拉列表中扩展选中区域
空格键
在“自动筛选”下拉列表中选中或清除选定项的复选框
Enter
关闭“自动筛选”下拉列表并应用所做的一切更改
Esc
关闭“自动筛选”下拉列表，但并不应用所做的更改

显示 在“帮助”中使用的快捷键

显示 在“帮助”窗口中使用的快捷键

F6
在导航窗格和主题窗格之间进行切换
Alt+O
显示“选项”菜单以访问任何“帮助”工具栏命令
Alt+空格键
显示程序的“控制”菜单
Alt+F4
关闭“帮助”窗口

显示 在导航窗格中使用的快捷键

Ctrl+Tab
切换到另外一个选项卡
Enter
打开或关闭选定的书，或打开选定的“帮助”主题
向下键
选择下一本书或下一个“帮助”主题
向上键
选择上一本书或上一个“帮助”主题
Shift+F10
显示快捷菜单

显示 在主题窗格中使用的快捷键

Alt+向右键
前往以前查看的“帮助”主题
Alt+向左键
返回以前查看的“帮助”主题
Tab
选取下一个隐藏的文本或超链接，或主题顶部的“全部显示”或“全部隐藏”
Shift+Tab
选取以前隐藏的文本或超链接
Enter
执行选定的“全部显示”、“全部隐藏”、隐藏文本或超链接中的操作
向上键或向下键
向“帮助”主题的开始或结束方向滚动
Page Up 或 Page Down
以较大的步长向“帮助”主题的开始或结束方向滚动
Home 或 End
前往“帮助”主题的开始或结束部分
Ctrl+P
打印当前“帮助”主题
Ctrl+A
选定整个“帮助”主题
Ctrl+C
将选定内容复制到剪贴板
SHIFT+F10
显示快捷菜单


关于电子表格工具、命令和选项

显示 工具栏

电子表格顶部的工具栏为处理电子表格数据提供了一组命令。若要查看每个按钮的命令名称，请将鼠标指针停留在按钮上。如果没有看见工具栏，或没有显示工具栏，可能是网页的设计者已将其禁用。如果您正在查看电子表格 Web 部件中的电子表格，且设计者未禁用工具栏，则可单击工具条上的“工具栏”命令，以显示和隐藏工具栏。

显示 “命令和选项”对话框

“命令和选项”对话框包括可用于查找电子表格中数据的命令（如“查找下一个”）和可以设置的属性（如单元格的背景色和列宽）。对话框还包括某些工具栏或快捷菜单上没有的命令。若要显示对话框，请单击工具栏上的“命令和选项” 按钮图像 。

“命令和选项”对话框中的命令和属性位于多个选项卡中，例如，“公式”选项卡和“格式”选项卡。在“公式”选项卡中，可查看选中的单元格的公式，或者定义公式中可使用的名称；在“格式”选项卡中，可设置数字的格式、更改文字的颜色和选择边框样式等。

如果无法显示“命令和选项”对话框，可能是网页设计者已将其禁用。


显示或隐藏电子表格工具栏

  1. 右键单击电子表格中的单元格，再在快捷菜单上单击“命令与选项”，然后单击“工作簿”选项卡。
  2. 在“显示/隐藏”下，选中或清除“工具栏”复选框。


显示或隐藏“命令和选项”对话框

请执行下列操作之一：

  • 若要显示“命令和选项”对话框，请单击电子表格工具栏上的“命令和选项” 按钮图像 。
  • 若要隐藏“命令和选项”对话框，请单击该对话框右上角的“关闭” 按钮图像 。


添加或删除工作表

  1. 单击电子表格工具栏上的“命令和选项” 按钮图像 ，再单击“工作簿”选项卡。
  2. 在“工作表”下，执行下列操作之一：
    • 若要添加工作表，请单击“插入”。重复该操作可添加多张工作表。

      可通过以下方法更改插入工作表的名称：在“工作表名称”列表中选择名称，再在“工作表名称”框中键入新的名称，然后按 Enter。

    • 若要删除工作表，请在“工作表名称”列表中单击该工作表的名称，再单击“删除”。

      该工作表及其数据将被永久删除。


更改工作表的名称

  1. 在电子表格工具栏上，单击“命令和选项” 按钮图像 ，再单击“工作簿”选项卡。
  2. 在“工作表”下的“工作表名称”列表中，单击要更改的工作表名称。
  3. 在“工作表名称”框中，键入新的名称。
  4. 按 Enter。


更改工作表的排列顺序

  1. 在电子表格工具栏上，单击“命令和选项” 按钮图像 ，再单击“工作簿”选项卡。
  2. 在“工作表”下的“工作表名称”列表中，单击要移动的工作表的名称。
  3. 在“次序”旁，单击“向上箭头” 向上箭头 可将工作表在工作簿中的位置向前移动，单击“向下箭头” 向下箭头 可将工作表在工作簿中的位置向后移动。


显示或隐藏行号或列标

列标是位于电子表格顶部的灰色单元格（或其他颜色的单元格，这取决于 Microsoft Windows 的显示设置）中的字母，行号是位于电子表格一侧的灰色单元格中的数字。

  1. 在电子表格的工具栏上，单击“命令和选项” 按钮图像 ，再单击“工作表”标签。
  2. 在“显示/隐藏”下，选中或清除“列标”或“行号”复选框。


显示或隐藏电子表格中的网格线

  1. 在电子表格的工具栏上，单击“命令和选项” 按钮图像 ，再单击“工作表”标签。
  2. 在“显示/隐藏”下，选中或清除“网格线”复选框。


显示或隐藏工作表选择器

工作表选择器由“工作表名称”选项卡和“工作表”列表组成，当单击选项卡上的箭头时，将显示另一个“工作表”列表。

  1. 在电子表格工具栏上，单击“命令和选项” 按钮图像 ，再单击“工作簿”选项卡。
  2. 在“显示/隐藏”下，选中或清除“工作表选择器”复选框。


保存更改

在浏览器中对电子表格所做的更改只在当前的浏览器会话中有效。若要保存对数据的更改，请执行下列操作之一：

  • 在电子表格的工具栏上，单击“导出到 Microsoft Excel” 导出到 Microsoft Excel ，然后将电子表格副本保存为 Microsoft Excel 工作表。
  • 将电子表格中的数据复制到 Excel 或计算机上的其他程序中，然后在该程序中保存数据。


撤消更改

  • 若要撤消上一次对电子表格所做的更改，请在工具栏上，单击“撤消” 按钮图像 。多次单击“撤消” 按钮图像 可撤消多次更改（最多为 16 次）。
  • 不保存浏览器中所做的更改。若要撤消在当前会话中所做的所有更改，请关闭该网页，然后再重新打开它。


打印电子表格

若要通过浏览器打印电子表格，则必须打印整个网页。

  • 在 Microsoft Internet Explorer 中，单击“文件”菜单上的“打印”。

注释 如果电子表格比打印页面宽或长，则将不打印超出页面的部分。为了更好地控制打印方式（包括打印长列表和设置分页符的功能），请通过单击工具栏上的“导出到 Microsoft Excel” 导出到 Microsoft Excel 将电子表格导出到 Microsoft Excel。有关通过 Excel 打印的信息，请参阅 Excel 的“帮助”。


关于在电子表格中输入文本、数字、日期和时间

本主题中的部分内容可能不适用于某些语言。

显示 输入文本

将字符作为文本处理 在电子表格中，文本被看作是任何数字、空格和非数字字符的组合。例如，电子表格将下列输入项看作文本：

10AA109、127AXY、12-976 和 208 4675。

将数字和日期作为文本输入 如果希望输入的数字和日期存储为文本形式，那么请在文本的开始处键入撇号 (')。例如，如果要将编号 02-01-23 作为文本形式（而不是以日期形式）输入，那么请键入“'02-01-23”。

对齐文本 默认情况下，单元格中的所有文本都是左对齐的。也可将对齐方式更改为居中或右对齐。

单元格中的文本不能换行 无法在单个单元格中显示多行文本。

重复文本 若要在多个单元格中输入相同的文本字符串，请选定单元格，再键入文本，然后按 Ctrl+Enter。

欧元符号 若要输入欧元符号 ( 欧元 )，请先确保已打开 Num Lock，然后在数字键盘上键入 ALT+0128。以下列出了可显示欧元符号的字体：

操作系统 | 字体
Microsoft Windows XP | 大多数字体都支持欧元符号
Microsoft Windows 2000 | Arial、Courier New、Tahoma（常规并加粗）、Times New Roman

显示 输入数字

可以用作数字的字符 在电子表格中，数字只能包含下列字符：

0 1 2 3 4 5 6 7 8 9 + – ( ) , / $ % . E e 欧元

电子表格将忽略前导加号 (+)，并将数字串内的单个句点作为小数点处理。所有其他由非数字字符与数字组合而成的字符串都将作为文本处理。

输入分数 若要避免将输入的分数当作日期，则可在分数前加上 0（零）和一个空格。例如，键入“0 1/2”。

输入负数 在负数前加上负号 (-)，或将数字用括号 () 括起来。

对齐数字 默认情况下，单元格中的所有数字都是右对齐的。也可将对齐方式更改为居中或左对齐。

数字的显示方式 对单元格应用的数字格式决定了数字的显示方式。如果在单元格中按“常规”数字格式键入数字，则电子表格可能会应用其他数字格式。例如，如果键入“$14.73”，则电子表格会对其应用货币格式。数字格式可以更改。

“常规”数字格式 在具有默认“常规”数字格式的单元格中，电子表格将数字显示为整数 (789)、小数 (7.89)，或者如果数字的长度超过单元格的宽度，则以科学记数法 (7.89E+08) 来显示数字。“常规”数字格式至多显示 11 位数字，其中包括小数点和“E”、“+”等字符。如果所用数字多于 11 位，则可应用科学记数法格式（使用指数符）。

15 位数限制 无论所显示的数字有多少位，电子表格的存储精度都至多为 15 位。如果数字超过 15 位数，则电子表格会将多余位转换为零 (0)。

区域设置 可作为数字使用的字符取决于 Microsoft Windows“控制面板”中“区域设置”内的选项。这些选项也决定了数字的默认格式，例如：在基于美国英语的系统中，句号 (.) 将作为小数点使用。

重复数据 若要在多个单元格中输入相同数据，那么请选定单元格，再键入数据，然后按 Ctrl+Enter。

显示 输入日期和时间

日期和时间均为数字 电子表格将日期和时间视为数字。时间或日期在单元格中的显示方式取决于单元格所应用的数字格式。当键入电子表格所能识别的日期或时间时，单元格的格式将由“常规”数字格式更改为日期或时间格式。在默认情况下，时间和日期在单元格中为右对齐。如果电子表格不能识别日期或时间格式，则日期或时间将作为文本输入，并在单元格中为左对齐。

控制面板 在“控制面板”的“区域设置”中的选项将决定当前日期和时间的默认格式，以及作为日期和时间分隔符的字符。例如，对于美国英语的时间系统，连字符 (-) 用作日期分隔符，冒号 (:) 用作时间分隔符。

使用以四位数表示的年份 当解释不确定的日期时，电子表格将进行某些假设。例如，如果输入只包含月份和一到两位数字的日期，则电子表格将假设从 1 到 31 是天数，而年份是当前年份。例如，December 01 将假设为今年的 12 月 1 日，而不是 2001 年的 12 月。December 32 则假设为 1932 年的 12 月 1 日。30-12-1 是 1930 年 12 月 1 日，但 29-12-1 则是 2029 年 12 月 1 日，除非系统管理员更改了默认的截止日期。

为确保电子表格按所需方式解释日期，请输入用四位数表示的年份。

同时输入日期和时间 若要在同一个单元格中输入日期和时间，请在日期和时间之间键入空格。例如，1976-7-10 23:12。

时间后加上 AM 或 PM 若要输入 12 小时制时间，请在时间后面键入一个空格，然后加上 AM 或 PM。例如，先键入 9:00，再接着键入 AM 或 PM。

查看日期或时间后的序列号 不论用何种格式显示日期或时间，电子表格都会将所有日期存储为序列号，而将所有时间存储为小数。若要将日期显示为序列号或将时间显示为小数，则请选定包含日期或时间的单元格，然后将数字格式更改为“常规”数字格式。在“常规”格式中，数字的日期部分位于小数点左边，而时间部分位于小数点右边。在电子表格中，日期序列号 1 与日期 1899 年 12 月 31 日，星期日相对应。

用日期和时间进行计算 可以对日期和时间进行加减运算，也可将其包括在其他计算中。若要在公式中使用日期或时间，请将日期或时间作为文本输入，并用引号围住。例如，以下公式的差为 68：

="2004-5-12"-"2004-3-5"


在电子表格中输入文本、数字、日期和时间

  1. 单击要向其中输入数据的单元格。
  2. 键入数据，再按 Enter 或 Tab。

注释

  • 若要分隔日期的各个部分，请使用连字符。例如，键入“2002-9-5”或“5-Sep-02”。

  • 若要按 12 小时制输入时间，请在时间后空一格，再键入“AM”或“PM”，例如，键入“9:00 PM”。否则，将按 AM 处理。

  • 公式之前要有一个等号 (=)。

  • 若要输入超链接，请键入以“http://”或“ftp://”协议开头的 URL 地址，然后再按 Enter。

  • 若要在多个单元格中键入相同的数据，请先选定单元格，再键入数据，然后按 Ctrl+Enter。


电子表格如何处理 2000 年及其以后的日期

因为计算程序解释日期的规则比较复杂，所以应尽可能输入明确的日期。这样在计算日期时就具有最高的准确性。

电子表格如何解释不确定日期 在解释不确定日期时，电子表格将作出某些假设。例如，如果输入了只包含月份和一或两位数字的日期，则电子表格将假设 1 到 31 是天，而年份是当前年份。例如，电子表格假设 December 01 为今年的 12 月 1 日，而不是 2001 年的 12 月。电子表格还假设 December 32 是 1932 年的 12 月 1 日。

电子表格如何解释用两位数表示的年份 在默认情况下，当输入用两位数表示的年份时，电子表格将按下列方法解释年份：

  • 00 到 29 电子表格将用两位数表示的从 00 到 29 的年份值解释为从 2000 到 2029 年。例如，如果键入日期“19-5-28”，则电子表格将假设日期为 May 28, 2019（2019 年 5 月 28 日）。
  • 30 到 99 电子表格将用两位数表示的从 30 到 99 的年份值解释为从 1930 到 1999 年。例如，如果键入日期为“98-5-28”，则电子表格将假设日期为 May 28, 1998（1998 年 5 月 28 日）。

使用四位数表示年份 若要确保电子表格按所需方式解释年份值，请键入用四位数表示的年份值（例如，键入“2001”而不是“01”）。

更改年份的解释方法 系统管理员可以自定义 Microsoft Office 以使用不同规则来解释日期。例如，管理员可以将解释为二十世纪某一日期的最早两位数年份值从 30 更改为其他数值。而且，管理员还可以更改默认的日期格式，以显示用四位数表示的年份，而不显示用两位数表示的年份。

如果要查明系统是否使用了自定义的日期解释方法，请向管理员询问。有关如何自定义日期解释方式的详细信息，请参阅《Office 2003 资源工具包》。


更改单元格中的数据

  1. 单击要更改的单元格。
  2. 请执行下列操作之一：

    • 若要在单元格中输入新的数字或文本，以替换单元格中的当前内容，则请键入新值。

    • 若要更改单元格内容的一部分，请双击该单元格，然后进行所需更改。

  3. 若要接受对单元格的更改，请按 Enter。

注释 一个单元格只能有一种字体和文本格式。


关于移动和复制数据

在复制单元格时，将复制整个单元格，包括公式及其计算结果和单元格格式。复制或移动的单元格将替换要粘贴这些单元格的区域中的任何数据。粘贴单元格可能影响 XML 列表的方式有多种。有关的详细信息，请参阅关于 XML 列表中的“粘贴记录”。

显示 复制和移动对公式的影响

在移动公式时，公式内的单元格引用不会更改。在复制公式时，绝对单元格引用不会更改；但是，相对单元格引用将随被粘贴单元格的位置而更改。例如，如果将公式：

=A1+B1

从单元格 C1 复制到单元格 D2，即向右移一列并向下移一行，则公式中的引用将更新以反映新的位置：

=B2+C2

显示 筛选对复制和移动的影响

如果选定的复制区域包含由筛选所隐藏的单元格，则只会复制可见单元格。如果用于粘贴数据的区域中包括由筛选所隐藏的行，则可能需要先关闭筛选，以便能看到所有复制的单元格。不能将数据移动（或剪切）到包含筛选行的区域以外。如果要移动这些数据，则必须先关闭筛选。

显示 复制到其他程序中

将从电子表格中复制的单元格以 XML 电子表格、HTML 和纯文本的格式放置在 Office 的剪贴板上。可为粘贴内容的目标应用程序选择最适合的格式。例如，在将单元格粘贴到 Microsoft Office Excel 2003 工作表时，通过以 XML 电子表格的格式粘贴可在工作表上重新生成公式、值和单元格格式。当将单元格粘贴到 Microsoft Word 文档时，可用 HTML 格式将单元格作为表格粘贴。单元格的格式设置和值将保留，但不保留公式。当将单元格粘贴到“记事本”时，单元格将作为不包括格式或公式的纯文本进行粘贴。

显示 在“电子表格组件”中复制与在 Microsoft Excel 中复制的区别

在电子表格中复制和移动单元格与在 Excel 中复制和移动单元格有以下不同：

没有复制指示器 在电子表格中复制的单元格不具有在 Excel 中用于指示复制内容的移动虚线边框。

没有“选择性粘贴”命令 在电子表格中复制单元格时，将同时复制值、格式和公式。用户不能分别粘贴这些元素，不能在粘贴时将行变为列，也不能应用加、减、乘或除运算，而这些操作在 Excel 中是可以进行的。

粘贴时不能插入单元格 在电子表格中，粘贴的单元格总会替换已有的单元格。但在 Excel 中，则可以插入复制的单元格。如果要在电子表格中添加空白区域以放置复制或移动的数据，则可以在粘贴被复制的单元格之前，先插入行和列。

复制的数据仍然在剪贴板中 在电子表格中复制数据时，数据将保留在剪贴板中，直至又复制了其他数据或清空了剪贴板。复制数据后，可以在电子表格中执行其他操作，然后再粘贴数据。在 Excel 中，如果在粘贴数据之前执行了其他操作或按了 Esc，则将删除剪贴板中的内容。

立即剪切数据 在电子表格中移动数据时，如果剪切了数据，则数据将立即消失，并且剪切的数据只能粘贴一次。当在 Excel 中移动数据时，剪切的数据在粘贴前并不从其原位置删除，并且可以多次粘贴该数据。


移动和复制数据

显示 移动或复制整个单元格

如果在复制或剪切单元格之后又粘贴了该单元格，则会复制或移动整个单元格，不仅包括公式和公式的计算结果，也包括单元格格式。

如果要复制的选定区域中包含由筛选所隐藏的单元格，则只会复制可见单元格。无法将将数据从包含筛选行的区域中移走。若要移动数据，则必须先关闭筛选。

  1. 选定要移动或复制的单元格。
  2. 请执行下列操作之一：

    • 若要移动单元格，请单击“剪切” 按钮图像 。

    • 若要复制单元格，请单击“复制” 按钮图像 。

    注释 剪切数据时，只能粘贴一次。但复制数据时，则可以粘贴多次。如果需要在多个位置上粘贴数据，那么请用“复制”按钮复制数据。

  3. 单击要粘贴单元格的区域左上角的单元格。
  4. 单击“粘贴” 按钮图像 。

注释

  • 复制或移动的单元格将替换要粘贴单元格区域中的任何数据。
  • 在移动公式时，公式内的单元格引用不会更改。在复制公式时，绝对单元格引用也不会更改；但是，相对单元格引用将会更改。

显示 移动或复制单元格内的字符

  1. 双击包含要移动或复制字符的单元格。
  2. 在单元格中，选择要移动或复制的字符。
  3. 请执行下列操作之一：

    • 若要移动字符，请单击“剪切” 按钮图像 。

    • 若要复制单元格，请单击“复制” 按钮图像 。

  4. 在单元格中，单击要粘贴字符的位置。
  5. 单击“粘贴” 按钮图像 。
  6. 按 Enter。

注释 当将某个单元格中的字符移动或复制到另一个单元格中时，该字符将应用目标单元格中的格式。


插入或删除行或列

显示 插入行或列

  1. 单击要插入新列的右边一列中的单元格，或单击要插入新行的下面一行中的单元格。

    如果要插入多行或多列，则请选定多个单元格。例如，如果要插入三行，则请选定某一列中的三个单元格。

  2. 右键单击单元格或选定区域，再将指针指向快捷菜单上的“插入”，然后单击“行”或“列”。

显示 删除行或列

  1. 单击要删除的列或行中的单元格。

    如果要插入多行或多列，则请选定多个单元格。例如，如果要插入三行，则请选定某一列中的三个单元格。

  2. 右键单击单元格或选定区域，再将指针指向快捷菜单上的“删除”，然后单击“行”或“列”。


插入、更改或删除超链接

显示 插入超链接

  1. 单击要插入超链接的单元格。
  2. 键入以有效的协议（例如：“http://”）开头的地址，然后按 Enter 来输入作为超链接的地址。例如，键入“http://example.microsoft.com”。

注释 地址在单元格中将显示为蓝色带下划线的文本。如果需要显示超链接的文本而不是地址本身，可使用 HYPERLINK 电子表格函数。

显示 更改超链接

  1. 单击超链接旁边的单元格，然后使用箭头键移动到该单元格中。
  2. 按 F2 开始在单元格中进行编辑。
  3. 键入对超链接地址的更改或键入对使用 HYPERLINK 电子表格函数的公式的更改。

注释 如果正在修改通过 Microsoft Excel 工作表发布的超链接，并且该超链接最初是使用 Excel 中的“插入超链接”对话框创建的，则可以更改该超链接所显示的文本，但不能更改该超链接的跳转地址。

显示 删除超链接

  1. 单击超链接旁边的单元格，然后使用箭头键移动到该单元格中。
  2. 按 Delete。


清除单元格中的内容

  1. 选定要清除的单元格。
  2. 按 Delete。

显示 提示

清除单元格内容将删除值和公式，但不会删除格式。若要同时删除值、公式和格式，请选定该单元格，再单击“剪切” 按钮图像 。


关于公式

显示 公式定义

公式是对电子表格数据或其他数据执行操作的方程式。公式可以执行数学运算，例如加法和乘法；还可以连接文本或比较电子表格的值。以下公式将电子表格上单元格 A1 中的值与单元格 A2 中的值相加：

=A1+A2

公式可使用常量（如：数字或文本值），也可引用电子表格中的单元格，还可以使用相同网页上的数据的值。

公式的元素

电子表格中的公式总是以等号开始 (=)。等号后为要计算的元素（操作数），这些元素由运算符分隔。运算符为一些符号，用于指定公式中元素所执行的运算类型，例如加法 (+)、乘法 (*) 和减法 (-)。

显示 计算

公式由等号开始，并根据公式中运算符的特定顺序从左到右进行计算。例如，先计算乘法，然后再计算加法。

=5+2*3*4

在上面的示例中，首先执行最左边的乘法 (2*3)，得到的结果为 6；然后从左向右执行乘法运算 (6*4)，得到的结果为 24；最后执行加法运算 (5+24)，得到的结果为 29。

通过更改公式的语法可以控制运算的次序。例如，可以在下例中使用括号更改上例中的语法，使得先执行 (5+2)，得到结果 (7)，然后将其乘以 3 得到结果 21，再将 21 乘以 4 得到结果 84。

=(5+2)*3*4

默认情况下，计算会自动执行，这意味着当公式引用的单元格发生更改时，公式将重新进行计算。但是，也可将计算设置为手动控制，以便只在您需要时，才进行重新计算。

显示 常量与单元格引用

公式可以引用常量和其他单元格。如果包含公式的单元格的值依赖于其他单元格中的值，则此单元格就是从属单元格。例如，如果单元格 B2 中包含公式 =C2，则它就是从属单元格。

如果公式所引用的单元格发生了更改，则默认情况下，从属单元格也将随之更改。例如，如果下列单元格中的某个值发生了更改，则公式 =B2+C2+D2 的结果也将随之更改。

如果在公式中使用常量而不是对单元格的引用（例如，=30+70+110），则只有在自己更改公式时其结果才会更改。

显示 函数

Microsoft Office“电子表格组件”提供了许多预定义或内置的公式，称作函数。函数可用于执行简单或复杂的计算。例如，下面的公式使用 SUM 函数对单元格区域进行求和计算：

=SUM(A1:A5)


常用公式示例

显示 基于单个条件求和

使用 SUMIF 电子表格函数可对基于另一区域中某一值的区域进行求和。例如，对于包含值“Northwind”的区域 B5:B25 中的每个单元格，下列公式将计算区域 F5:F25 中相应单元格的和。

=SUMIF(B5:B25,"Northwind",F5:F25)

显示 统计某个值或条件的出现次数

COUNTIF 电子表格函数统计单元格区域中数值的出现次数，例如，在区域 B5:B25 中包含文本“Northwind”的单元格个数。

=COUNTIF(B5:B25,"Northwind")

显示 计算即时余额

可在电子表格中创建一个支票“登记簿”来跟踪银行交易。作为电子表格的一部分，可以建立公式来计算即时余额。在本示例中，假设单元格 F6 中包含以前的余额，单元格 D7 中包含第一笔交易的存款分类汇总，而单元格 E7 中包含任何收到的现金数量。

若要计算第一笔交易的当前余额，则请在单元格 F7 中输入下列公式：

=SUM(F6,D7,–E7)

当输入新的交易时，此公式就会被复制到每笔存款所对应的当前余额单元格中。

显示 合并姓和名

通过使用和号 (&) 文本运算符，可以使用公式合并或连接某列中姓的列表和另一列中名的列表。在这些示例中，假设单元格 D5 中包含名，而单元格 E5 中包含姓。

若要按“名 姓”格式显示全名（例如“John Smith”），可按如下方式：

=D5&" "&E5

若要按“姓, 名”格式显示全名（例如“Smith, John”），可按如下方式：

=E5&", "&D5

显示 合并日期与文本

若要合并或连接两个值以产生一个连续的文本值，则请使用和号 (&) 文本运算符。若要将单元格中存储的数字、日期或时间值与文本字符串连接，则请使用 TEXT 电子表格函数。例如，如果单元格 G5 中包含记帐日期 5-Jun-2000，则可以使用本公式显示文本“成交日：5-Jun-2000”。

="成交日："&TEXT(G5, "d-mmm-yyyy")

显示 按百分比增加数字

可按百分比增加存储在单元格中的数值。本例中，假定单元格 G5 中包含要按 5% 增加的值。将单元格 G5 中的值与 1 相乘以返回初始值，然后添加所需百分比，这样公式将返回增加后的结果值。

=G5*(1+5%)

如果百分比数量存储在单元格 G2 中，请使用本公式：

=G5*(1+$G$2)

对单元格 G2 的引用是绝对单元格引用，所以不需要更改对 G2 的引用就可以将公式复制到其他单元格中。


创建公式

  1. 单击要添加公式的单元格。
  2. 键入等号 (=)。
  3. 键入公式。
  4. 按 Enter。

显示 提示

若要自动插入对单元格区域的求和公式，请先选中要求和的数据旁的第一个空白单元格（它位于数据列之下或数据右侧的一行中），再在电子表格的工具栏上，单击“自动求和” 按钮图像 ，再按 Enter。


更改公式

  1. 双击包含要更改的公式的单元格，以使公式显示在单元格中。

    如果单元格中包含超链接，请单击要更改的单元格旁边的单元格，再使用箭头键移动到具有要更改的公式的单元格上。然后按 F2。

  2. 更改单元格中的公式。
  3. 按 Enter。


同时查看公式及其结果

  1. 单击包含要查看的公式的单元格。
  2. 在电子表格工具栏上，单击“命令和选项” 按钮图像 ，再单击“公式”选项卡。
  3. 在“活动单元格中的公式(引用)”框中查看公式。公式的结果将显示在“单元格值”框中。


插入区域的汇总

通过使用“自动求和”可以自动插入单元格区域的总和。

  1. 请单击要求和数据后的第一个空白单元格，该单元格既可在数据列的下方，也可以在数据行的右边，或者选定一个列区域求和。
  2. 在电子表格工具栏上，单击“自动求和” 按钮图像 。

    在选定的单元格或选定的列区域下方的单元格中将显示推荐使用的公式。

  3. 请执行下列操作之一：

    • 若要接受推荐的公式，请按 Enter。

    • 若要更改推荐的公式，请选择要进行求和的区域，然后按 Enter。


更改电子表格的计算时间

如果电子表格中包含许多公式，则可能需要很长时间进行计算。若要加速工作进程，则可以将计算模式由自动更改为手动，以便可以决定何时重新计算电子表格。

  1. 在电子表格工具栏上，单击“命令和选项” 按钮图像 ，再单击“工作簿”选项卡。
  2. 在“计算”下，执行下列操作之一：

    • 若只要在数值发生更改时就重新计算电子表格，请选中“自动”。

    • 若只在按 F9 或单击“计算”的情况下重新计算电子表格，请选中“手动”。


关于在公式中使用名称

显示 概述

公式中的定义名称使人们更容易理解公式的含义。例如，公式 =SUM(一季度销售额) 要比公式 =SUM(C20:C30) 更容易理解。

名称可用于所有的工作表。例如，如果名称“预计销售”引用了第一张工作表中的区域 A20:A30，则其他工作表都可使用名称“预计销售”来引用第一张工作表中的 A20:A30。

名称也可以用来代表不会更改的（常量）公式和数值。例如，可使用名称“销售税”代表销售额的税率（如 6.2%）。

注释 默认情况下，名称使用单元格绝对引用。

显示 命名规则

允许使用的字符 名称的第一个字符必须是字母或下划线。名称中的其他字符可以是字母、数字、句号和下划线。

名称是否可为单元格引用 名称不能与单元格引用相同，例如 Z$100 或 R1C1。

是否可使用多个单词 可以，但名称中不能有空格。可以用下划线和句号作单词分隔符，例如，Sales_Tax 或 First.Quarter。

名称的长度 名称最多可以包含 255 个字符。

名称是否区分大小写 名称可以包含大、小写字符。“电子表格组件”在名称中不区分大小写。例如，如果已经创建了名称 Sales，然后又在同一个电子表格中创建了名称 SALES，则第二个名称将替换第一个名称。


为单元格、公式或常量定义名称

  1. 在电子表格工具栏上，单击“命令和选项” 按钮图像 ，再单击“公式”选项卡。
  2. 在“名称”下，键入要在“名称”框中使用的名称。

    如果要定义仅对一张电子表格可用的名称（本地名称），请在要使用的名称之前加上该电子表格的名称以及一个感叹号。例如，如果要命名单元格 Budget，并且使它仅对 Sheet2 可用，则可在“名称”框中键入：

    Sheet2!Budget

  3. 在“引用”框中，键入 =（等号），后接要命名的公式、常量值或者单元格或单元格区域引用。例如，若要命名 Sheet1 上的单元格区域 A1 到 A5，可键入：

    =Sheet1!$A$1:$A$5

  4. 单击“定义”。


更改或删除定义名称

  1. 在电子表格工具栏上，单击“命令和选项” 按钮图像 ，再单击“公式”选项卡。
  2. 在“名称”下的“所有名称”框中，单击要更改或删除的名称。
  3. 请执行下列操作之一：
    • 若要更改名称，请在“名称”框中键入新名称，并单击“定义”。然后在“所有名称”框中单击原始名称，再单击“删除”。
    • 若要更改名称代表的单元格、公式或常量，请在“引用”框中进行更改，然后单击“定义”。
    • 若要删除该名称，请单击“删除”。


关于单元格和区域引用

显示 概述

引用可标识电子表格中的单元格或单元格区域，并指示电子表格将在何处查找要在公式中使用的值或数据。通过使用引用，可以在一个公式中使用包含在电子表格不同部分中的数据，或在多个公式中使用一个单元格中的值。

电子表格使用 A1 引用样式，此样式用字母标识列（从 A 到 ZZZ，共 18,278 列），用数字标识行（从 1 到 262,144）。

若要引用某个单元格，请输入列标和行号。例如，D50 引用列 D 和行 50 交叉处的单元格。

若要引用某个单元格区域，请先输入对区域左上角单元格的引用，接着键入冒号 (:)，然后输入对区域右下角单元格的引用。以下为一些引用示例。

若要引用 | 请使用
列 A 和行 10 交叉处的单元格 | A10
列 A 和行 10 到行 20 之间的单元格区域 | A10:A20
行 15 和列 B 到列 E 之间的单元格区域 | B15:E15
行 5 中的全部单元格 | 5:5
行 5 到行 10 之间的全部单元格 | 5:10
列 H 中的全部单元格 | H:H
列 H 到列 J 之间的全部单元格 | H:J
列 A 到列 E 和行 10 到行 20 之间的单元格区域 | A10:E20

显示 相对引用与绝对引用

相对引用 当创建的公式中包含对单元格或区域的引用时，这些引用通常是相对于包含该公式的单元格的相对引用。在下例中，单元格 B6 中包含公式 =A5。而该值位于 B6 单元格向上一个再向左一个单元格中。这就称为相对引用。

当复制和粘贴使用相对引用的公式时，粘贴公式中的引用将自动调整以引用相对于该公式位置的其他单元格。在下例中，单元格 B2 中的公式 =A1 引用了 B2 左上方的单元格。如果将公式粘贴到单元格 B3 中，则公式将调整为 =A2，它引用 B3 左上方的单元格。

绝对引用 如果在将公式复制到其他单元格中时不希望调整引用，请使用绝对引用。若要创建绝对引用，请在不希望更改的引用之前键入美元符号 ($)。例如，若要在公式 =A5*C1 中创建对单元格 C1 的绝对引用，请在公式中按如下方式添加美元符号：

=A5*$C$1

混合引用 也可以仅使一行或一列成为绝对引用，这就称为混合引用。例如，如果希望在复制某个公式时只更新列引用，而不更新行引用，则可将美元符号放置在行号之前：

=C$1

显示 提示

若要快速地将相对引用更改为绝对引用，请在公式中选择引用，并按 F4。每按一次 F4，引用将按下列顺序进行循环：绝对引用列和相对引用行、相对引用列和绝对引用行、相对引用列和相对引用行，再恢复绝对引用列和绝对引用行。


关于计算

计算是电子表格用于计算单元格中的公式并将其结果显示为值的过程。默认情况下，当公式所引用的单元格发生更改时，公式将自动进行计算。但是，可以更改电子表格的计算方式。

存储的值与显示的值 数值的显示和存储有时并不相同。例如，日期和时间是以序列号存储的，但通常按几种日期或时间格式之一进行显示和打印。电子表格在计算中使用存储的序列号，这样可以计算两个日期之间的天数。

存储值所显示的格式有时也取决于用户为其选择的格式。例如，可以对包含数字 123456789 的单元格设置格式，使其使用科学记数法格式，这样显示结果将为 1.23E+08。或者可以对包含日期序列号 36699 的单元格设置格式，使其显示为“2000-6-22”或“22-Jun-00”。更改数值的显示方式不会影响存储的值。

Microsoft Windows“控制面板”中的区域设置也会决定数字、货币、日期和时间格式的显示方式。例如，这些设置将决定年份是按两位数还是四位数显示。请参阅 Windows 的“帮助”以获取有关这些格式的信息。


关于运算符

运算符对公式中的元素进行特定类型的运算。“电子表格组件”中包括四类运算符：算术、比较、文本连接和引用。运算符按一定的顺序计算。

显示 运算符的类型

显示 算术

使用下列算术运算符可执行基本数学运算（如加法、减法或乘法）、合并数字和产生数字结果。

算术 运算符 | 含义 | 示例
+（加号） | 加法 | 3+3
-（减号） | 减法 负数 | 3-1 -1
*（星号） | 乘法 | 3*3
/（斜线） | 除法 | 3/3
%（百分号） | 百分比 | 20%
^（插入符号） | 乘幂 | 3^2（即 3*3）

显示 比较

若要比较两个值，可使用下列比较运算符。如果使用这些运算符比较两个值，则其结果将是一个逻辑值，即 TRUE 或 FALSE。

比较 运算符 | 含义 | 示例
=（等号） | 等于 | A1=B1
>（大于号） | 大于 | A1>B1
<（小于号） | 小于 | A1<B1
>=（大于等于号） | 大于或等于 | A1>=B1
<=（小于等于号） | 小于或等于 | A1<=B1
<>（不等号） | 不相等 | A1<>B1

显示 文本连接

若要合并或连接一个或多个文本字符串以产生一行文本，则可使用和号 (&)。

文本 运算符 | 含义 | 示例
&（和号） | 连接 | "北" & "风" 连接在一起得到“北风”

显示 引用

若要在计算中合并单元格区域，可使用下列引用运算符。

引用 运算符 | 含义 | 示例
:（冒号） | 区域运算符，产生对包括在两个引用之间（包含两个引用）的所有单元格的引用 | B5:B15
,（逗号） | 联合运算符，将多个引用合并为一个引用 | SUM(B5:B15,D5:D15)
（单个空格） | 交叉运算符，产生对两个引用的交集单元格的引用 | SUM(B5:B15 A7:D7) 在本示例中，单元格 B7 为两个区域的交集。

显示 运算符的运算顺序

如果一个公式中具有多个运算符，则“电子表格组件”将按下表所示顺序执行运算。如果公式中包含优先级相同的运算符，例如公式中包含乘法和除法运算符，则“电子表格组件”将按从左到右的顺序对运算符进行计算。若要更改求值的顺序，则请将公式中要先计算的部分用括号括起来。

运算符 | 说明
:（冒号） （单个空格） ,（逗号） | 引用运算符
– | 负号（例如 -1）
% | 百分比
^ | 乘幂
* 和 / | 乘和除
+ 和 – | 加和减
& | 连接符（连接两个文本字符串）
= < > <= >= <> | 比较运算符


关于数组公式和数组常量

数组公式可以进行多个计算并返回一个或多个结果。数组公式对两组或多组被称为数组参数的值进行运算。每个数组参数必须有相同数量的行和列。除了不能用 Ctrl+Shift+Enter 生成公式外，创建数组公式的方法与创建其他公式的方法相同。编辑数组公式时，公式为倾斜格式。

如果不想在工作表的单个单元格中输入每个常量值，则可用数组常量来代替引用。

一些内置函数就是数组公式，因此必须将其作为数组输入才可得到正确结果。

显示 数组公式的用法

计算单个结果 此类数组公式通过用一个数组公式代替多个公式的方式来简化工作表模式。

例如，下面的数组公式用一组股票的价格和股份计算出了股票的总价格，而没有用一行单元格来计算和显示每支股票的单个价格。

将公式 =SUM(B2:C2*B3:C3) 作为数组公式输入时，它将每支股票的股份（在单元格 B2 和 C2 中）与股票的价格（在单元格 B3 和 C3 中）相乘，然后将这些计算结果相加。

计算多个结果 一些电子表格函数返回数值数组，或需要将某个数值数组作为参数。若要使用数组公式计算多个结果，则必须将数组输入到与数组参数具有相同的列数和行数的单元格区域中。

例如，给出了相应于三个月（列 A 的 1、2、3 ）的三个销售量（列 B 的 20234、21003 和 10000），TREND 函数返回销售量的直线拟合值。若要显示该公式的所有结果，可将公式输入列 C (C1:C3) 的三个单元格中。

将公式 =TREND(B1:B3,A1:A3) 作为数组公式输入时，它会根据三个月的三个销售量得到三个不同的结果（22196、17079 和 11962，分别显示于单元格 C1、C2 和 C3 中）。

显示 数组常量的用法

在普通公式中，可输入对包含某个数值的单元格的引用，或数值本身，其中该值与单元格引用被称为常量。同样，在数组公式中也可输入对数组的引用，或输入包含在单元格中的数值数组，其中该数值数组和数组引用被称为数组常量。数组公式可以按与非数组公式相同的方式使用常量，但是必须按特定格式输入数组常量。

数组常量可包含数字、文本、逻辑值（如 TRUE 或 FALSE）或错误值（如 #N/A）。数组常量中可包含不同类型的数值。例如，{1，3，4；TRUE，FALSE，TRUE}。数组常量中的数字可以使用整数、小数或科学记数格式。文本必须包含在半角的双引号内，例如 "Tuesday"。

数组常量无法包含单元格引用、长度不等的行或列、公式、特殊字符 $（美元符号）、圆括号或 %（百分号）。

数组常量的格式

数组常量置于大括号 ( { } ) 中。

不同列的数值用逗号 (,) 分开。例如，若要表示数值 10、20、30 和 40，必须输入 {10,20,30,40}。这个数组常量是一个 1 行 4 列数组，相当于一个 1 行 4 列的引用。

不同行中的值用分号 (;) 隔开。例如，若要表示一行中的 10、20、30、40 和下一行中的 50、60、70、80，应该输入一个 2 行 4 列的数组常量：{10,20,30,40;50,60,70,80}。


创建数组公式

显示 计算单个结果

可用数组公式执行多个计算而生成单个结果。通过用单个数组公式代替多个不同的公式，可简化工作表模型。

  1. 请单击要输入数组公式的单元格。
  2. 键入数组公式。

    例如，下例计算一组股票价格和股份的总价值，而不是使用一行单元格来计算并显示出每支股票的单个价值。

    将公式 =SUM(B2:C2*B3:C3) 作为数组公式输入时，它将每支股票的股份（在单元格 B2 和 C2 中）与股票的价格（在单元格 B3 和 C3 中）相乘，然后将这些计算结果相加。

  3. 按 Ctrl+Shift+Enter。

显示 计算多个结果

一些电子表格函数返回数值数组，或需要将某个数值数组作为参数。若要用数组公式计算出多个结果，必须将数组输入到与数组参数具有相同列数和行数的单元格区域中。

  1. 选中要输入数组公式的单元格区域。
  2. 键入数组公式。

    例如，给出了相应于三个月（列 A 中的 1、2 和 3）的三个销售量（列 B 中的 20234、21003 和 10000），TREND 函数返回销售量的直线拟合值。若要显示该公式的所有结果，请将其输入到列 C (C1:C3) 中的三个单元格。

    将公式 =TREND(B1:B3,A1:A3) 作为数组公式输入时，它会根据三个月的三个销售量得到三个不同的结果（22196、17079 和 11962，分别显示于单元格 C1、C2 和 C3 中）。

  3. 按 Ctrl+Shift+Enter。


编辑数组公式

如果数组公式占用了多个单元格，则必须编辑整个区域，就好似单个单元格一样。您不能只更改数组公式中的一个元素。

  1. 选择包含数组公式的单元格，或者如果数组公式占用了多个单元格，选择包含数组公式的区域。

    显示 操作方法

    1. 选择数组中的某个单元格。
    2. 按 Ctrl+/（正斜线）。
  2. 按“F2”键。
  3. 对数组公式进行更改。
  4. 按 Ctrl+Shift+Enter。


选择数组公式的区域

  1. 选择数组中的某个单元格。
  2. 按 Ctrl+/（正斜线）。


移动或复制数组公式

  1. 选择整个数组区域。

    显示 操作方法

    1. 选择数组中的某个单元格。
    2. 按 Ctrl+/（正斜线）。

    单击电子表格工具栏上的“剪切” 按钮图像 或“复制” 按钮图像 。

  2. 选择整个目标区域，否则，该数组将被粘贴到单个单元格中。
  3. 单击“粘贴” 按钮图像 。


关于使用函数

电子表格函数

函数是一些预定义的公式，通过使用一些称为参数的特定数值来按特定的顺序或结构执行计算。例如，SUM 函数对单元格或单元格区域进行求和，PMT 函数在给定的利率、贷款期限和本金数额基础上计算偿还额。

参数 参数可以是数字、文本、逻辑值（例如 TRUE 或 FALSE）、错误值（例如 #N/A）、单元格引用、常量、公式或其他函数。每个指定的参数都必须有效参数值。

结构 函数的结构是：以函数名称开始，后面紧跟左括号、然后是以逗号分隔的函数参数，最后是右括号。如果函数以公式为开始，请在函数名称前键入等号 (=)。

嵌套函数

在某些情况下，可能需要将函数用作其他函数的参数。例如，下列公式使用了嵌套的 AVERAGE 函数，并将结果与 50 进行比较。

有效返回值 如果将嵌套函数用作参数，则其必须返回与参数相同类型的值。例如，如果参数返回 TRUE 或 FALSE 值，则嵌套函数也必须返回 TRUE 或 FALSE 值。否则，电子表格将显示 #VALUE! 错误值。


在电子表格中设置单元格的格式

  1. 选择要设置格式的单元格。
  2. 在电子表格工具栏上，单击“命令和选项” 按钮图像 ，再单击“格式”选项卡。
  3. 请执行下列一项或多项操作：

    显示 更改文本的字体或大小

    • 若要更改文本的外观，请单击“文本格式”组中的某个按钮。

    • 若要更改文本的字体或大小，请在“字体”列表中单击其他字体，或在“字体”列表旁的列表中选取其他字号。

    显示 更改数字格式

    当在单元格中更改数字的格式时，数字的显示值将发生更改，但不会更改存储值。例如，日期 2000-6-22 的存储值是序列号：36699。序列号将保持不变，即使单元格的数字格式更改为：星期四 2000 年 6 月 22 日。
    • 在“文本格式”下，在“数字格式”列表中单击所需格式。

    显示 在单元格周围添加边框

    • 在“文本格式”下的“边框”旁，选择所需的边框颜色、样式、宽度和放置选项。

    显示 更改单元格的背景色

    1. 在“文本格式”下的“单元格”旁，单击“填充颜色” 按钮图像 旁的箭头。
    2. 在调色板上，单击所需颜色。

    显示 对齐单元格中的数据

    • 若要水平对齐文本，请单击“文本格式”下的“左对齐” 按钮图像 、“居中” 按钮图像 或“右对齐” 按钮图像 。
    • 若要垂直对齐文本，请单击“文本格式”下的“顶端对齐” 按钮图像 、“水平居中” 按钮图像 或“底端对齐” 按钮图像 。

    注释 默认情况下，单元格中的文本是左对齐的，而数字、日期和时间为右对齐。


数字格式

本主题中的部分内容可能不适用于某些语言。

可以在设计程序和运行时的浏览器中使用“命令和选项”对话框更改电子表格中数字的格式。Microsoft Windows“控制面板”中的设置也会决定数字、货币、日期和时间格式的显示方式。例如，这些设置将决定是按两位数还是四位数显示年份。请参阅 Windows 的“帮助”以获取有关这些格式的信息。

在 Microsoft Visual Basic 或脚本中，可以为数据指定自定义的数字格式。还可以在“数字格式”框的电子表格对象模式中键入可用的自定义格式。若要了解更多信息，请参阅如何获取设计电子表格程序的“帮助”。

下列数字格式位于“命令和选项”对话框的“格式”选项卡的“数字格式”列表中。

格式 | 效果
常规日期 | 将数字显示为日期和可选时间。例如，99-8-31 05:54 AM。 数字的小数部分是时间。如果数字没有小数部分，则只显示日期。如果数字只含有小数部分而无整数部分，则只显示时间。
长日期 | 按 Windows 区域设置的长日期格式显示日期。例如，星期四 2001 年 1 月 25 日。
中等日期 | 根据 Windows 的区域设置显示带月和日分隔符的日期，年份则显示为两位数，例如，25-Jan-01。
短日期 | 按 Windows 区域设置的短日期格式显示日期。例如，01-1-25。
长时间 | 按 Windows 区域设置的长时间格式显示时间。例如，8:45:36 PM。
中等时间 | 按 12 小时格式显示时间，使用 AM 或 PM 标志符，但不包含秒。例如，8:45 PM。
短时间 | 按 24 小时格式显示时间，省略秒。例如，20:45。
常规 | 按右对齐方式显示数字，没有千位分隔符，如果为负数，则前面要加负号。最多可显示 11 位数字，如果有小数点，则显示 10 位数字，并对小数点后的额外数字取整。如果小数点左边的数字多于 11 位，则使用科学记数法。按左对齐方式显示文本。
货币 | 按 Windows 区域设置的货币格式显示数字，如果需要则还会显示千位分隔符和两位小数位。例如，如果是默认的英语（美国）区域设置，则会显示为 $2,532.75。
欧洲货币 | 将数字显示为欧洲货币的形式，同时具有千位分隔符和两位小数位。根据 Windows 中货币的区域设置，欧元符号可以位于数字之前或之后。例如，对于默认的英语（美国）区域设置，显示为 欧元 12.35。
固定 | 显示具有两位小数位的数字。例如，68.30。
标准 | 显示具有千位分隔符和两位小数位的数字。Windows 区域设置的数字格式决定了千位分隔符使用的字符。例如，如果以逗号作为千位分隔符，则显示为 1,800.00。
百分比 | 显示数字的方法为：数字乘以 100，具有两位小数位和百分比符号。例如，数值 0.8914 将显示为 89.14%。
科学记数 | 按指数方法显示数字。例如，1.25E+10。
是/否 | 如果数字为 0，则显示“No”，其他情况下显示“Yes”。
真/假 | 如果数字为 0，则显示“False”，其他情况下显示“True”。
打开/关闭 | 如果数字为 0，则显示“Off”，其他情况下显示“On”。


合并单元格或取消合并单元格

  1. 选定要合并的单元格。请记住：在合并单元格时，只保留选定区域左上角单元格中的数据。而所有其他合并单元格中的数据都将被删除。
  2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“格式”选项卡。
  3. 在“单元格格式”下，单击“合并单元格” 按钮图像 或“取消合并单元格” 按钮图像 。


更改列宽

  1. 请确保已显示列标。

    显示 操作方法

    列标是位于电子表格顶部的灰色单元格（或其他颜色的单元格，这取决于 Microsoft Windows 的显示设置）中的字母，行号是位于电子表格一侧的灰色单元格中的数字。

    1. 在电子表格的工具栏上，单击“命令和选项” 按钮图像 ，再单击“工作表”标签。
    2. 在“显示/隐藏”下，选中或清除“列标”或“行号”复选框。
  2. 选择要更改的列。
  3. 将鼠标指向列或选定区域的列标的右边界上，直至指针变为 Pointer with perpendicular double-headed arrow 。

  4. 拖动边界直至得到合适的宽度，或者，若要使列宽适应内容，请双击正确的列边界。


更改行高

  1. 确保在电子表格上已显示行号。

    显示 操作方法

    列标是位于电子表格顶部的灰色单元格（或其他颜色的单元格，这取决于 Microsoft Windows 的显示设置）中的字母，行号是位于电子表格一侧的灰色单元格中的数字。

    1. 在电子表格的工具栏上，单击“命令和选项” 按钮图像 ，再单击“工作表”标签。
    2. 在“显示/隐藏”下，选中或清除“列标”或“行号”复选框。
  2. 选择要更改的行。
  3. 将鼠标指向行或选定区域的行号的下边界，直至指针变为 Pointer with perpendicular double-headed arrow 。

  4. 拖动边界直至得到合适的行高，或者，若要使行高适应内容，请双击行边界的底部。


显示文本或电子表格，以便从右到左或从左到右读取

当使用从右到左进行阅读的语言查看电子表格时，请使用从右到左的文本方向或显示。

显示 从右到左或从左到右显示整个电子表格

  1. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“工作表”标签。

  2. 在“显示/隐藏”下，选中或清除“从右到左显示”复选框。

如果选择了从右到左显示方式，则电子表格的元素将显示为对默认的从左到右显示方式的一种镜像图像：行号将显示在电子表格的右边，垂直滚动栏将显示在左边。

显示 从右到左或从左到右显示文本

文本方向默认设置为“上下文”，这表示文本方向根据所用语言按从右到左或从左到右自动显示。可对指定单元格进行设置使其按从右到左或从左到右的方向显示文本，这样在使用不同单元格中的多种语言时，每个单元格具有不同的文本方向。

  1. 选定要为其设置文本方向的单元格。

  2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“格式”选项卡。

  3. 在“文本格式”下，单击“文字方向”框旁边的箭头，再从列表中选取选项。


关于查找数据

可用“查找内容”功能（“命令和选项”对话框上的“工作表”标签中）定位已直接输入到单元格中的文字、数字、日期和时间，或定位公式的计算结果。

使用“查找内容”选项时，请牢记以下规则：

  • 区分大小写 默认情况下，“查找内容”不区分大小写。若仅查找其值与所输入内容大小写相匹配的单元格，请选中“区分大小写”复选框。
  • 单元格匹配 默认情况下，“查找内容”搜索那些包含“查找内容”框中的值的单元格。例如，如果输入“John”，则将搜索到包含如下字符串的单元格：“Johnson”或“Little John”。若要查找仅包含您所输入的值的单元格，请选中“单元格匹配”复选框。
  • 格式化的值 “查找内容”功能搜索显示的值，而不搜索格式。例如，假定某一单元格的格式为“是/否”数字格式。如果该单元格包含一个零 (0)，则显示为“No”，可用“查找内容”定位“No”。但无法用“查找内容”找到具有特定颜色或字体格式的所有单元格。
  • 搜索方向 “查找内容”功能按从左到右的顺序搜索第一行的所有列，然后按从左到右的顺序搜索第二行的所有列，依此类推。
  • 通配符 “查找内容”功能不允许使用通配符，如：问号 (?) 和星号 (*)。
  • 隐藏数据 “查找内容”功能不查找隐藏单元格或通过筛选隐藏的单元格中的数据。


查找数据

  1. 若要在整个电子表格中搜索数据，请单击单个单元格，或者，若要在特定单元格区域中搜索数据，请选中该区域。

  2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“工作表”标签。
  3. 在“查找内容”框中，键入要查找的文本或值。

    注释

    • 默认情况下，“查找内容”搜索包含“查找内容”框中的值的单元格。例如，如果输入“John”，则将找到包含“Johnson”或“Little John.”字符串的单元格。如果查找只包含“查找内容”框中的值的单元格，请选中“单元格匹配”复选框。
    • 默认情况下，“查找内容”不区分大小写。若仅查找其值与所输入内容大小写相匹配的单元格，请选中“区分大小写”复选框。
  4. 单击“查找下一个”。


数据排序

需要排序的数据应建立为数据清单。清单在各列中具有相似的项，且在顶行中具有列标志，并且不包含任何空行或空列。

显示 按单列排序

  1. 若要对整个数据清单进行排序，请单击清单中的某个单元格（列标志不包含在排序中）。

    如果要对数据清单的某一部分进行排序，则请选定要排序的区域（如果不希望对列标志以及区域的其他部分进行排序，那么请不要将列标志选定为区域的一部分）。

  2. 在电子表格工具栏上，单击“升序” 按钮图像 或“降序” 按钮图像 旁边的箭头，再单击作为排序依据的列。

注释

  • 由筛选隐藏的行或行高为零的行不能进行排序。
  • 只能对行进行排序，而不能对列的次序进行排序。
  • 排序不区分大小写。例如，如果进行升序排序，则“ALL”和“all”将排列在“BLUE”和“blue”之前。

显示 按多列进行排序

若要按多列进行排序，应对数据清单进行多次排序，每次按不同的列排序。例如，下面的数据清单是按销售人员组织的。该清单先按“产品”列（该列也被称为内部列或较低级分类列）排序以使产品按字母顺序排列。然后，清单按“销售人员”列（该列被称为外部列或较高级分类列）排序。

  1. 请先决定所需分类次序。例如，如果正按两列排序，应先决定较高级分类列和较低级分类列。

  2. 在较低级分类（内部）列中选择一个单元格。

  3. 在电子表格工具栏上，单击“升序” 按钮图像 或“降序” 按钮图像 旁边的箭头，再单击作为排序依据的列。

  4. 在较高级分类（外部）列中选取一个单元格，然后重复以上步骤。

  5. 对每个较高级分类（外部）列重复以上步骤。

注释

  • 由筛选隐藏的行或行高为零的行不能进行筛选。
  • 只能对行进行排序，而不能对列的次序进行排序。
  • 排序不区分大小写。例如，如果进行升序排序，则“ALL”和“all”将排列在“BLUE”和“blue”之前。

注释 排序影响 XML 列表可有多种方式。有关这些区别的详细信息，请参阅关于 XML 列表中的“排序记录”。


应用或取消筛选

显示 应用筛选

  1. 在要应用筛选的清单中，单击某一单元格。或者，选中要应用筛选的特定单元格区域。
  2. 在工具栏上，单击“自动筛选” 按钮图像 ，以将其选中。
  3. 单击包含要显示数据的列中的箭头。

  4. 若要只显示要查看的项，请清除“全部显示”复选框，再选中要显示的每个项所对应的复选框。

显示 取消筛选

  • 在工具栏上，单击“自动筛选” 按钮图像 ，以使其不再处于选中状态。


对筛选数据求和

  1. 筛选数据以显示要求和的行。

    显示 操作方法

    显示 应用筛选

    1. 在要应用筛选的清单中，单击某一单元格。或者，选中要应用筛选的特定单元格区域。
    2. 在工具栏上，单击“自动筛选” 按钮图像 ，以将其选中。
    3. 单击包含要显示数据的列中的箭头。

    4. 若要只显示要查看的项，请清除“全部显示”复选框，再选中要显示的每个项所对应的复选框。

    显示 取消筛选

    • 在工具栏上，单击“自动筛选” 按钮图像 ，以使其不再处于选中状态。

  2. 单击要求和数据下的单元格。
  3. 在电子表格工具栏上，单击“自动求和” 按钮图像 ，再按 Enter。

注释 “自动求和”按钮只对可见行中的数据求和。如果要计算所有行的和，请先显示所有行，然后再进行求和。


关于通过 Excel 发布的电子表格

当通过 Microsoft Excel 发布电子表格后，大部分 Excel 功能将保留，并与在 Excel 中使用的方法一样。当发布或保存为网页上的电子表格时，下表中的 Excel 功能将会更改或不予保留。

Excel 公式、函数和计算功能 | 当发布或保存为网页时发生的情况
公式中的标志 | 标志将转换为单元格引用。
对其他工作表中数据的引用 | 只要您发布整个工作簿，对其他工作表的引用就会正确发布。如果您只发布引用工作表，则对其他工作表的引用就转换为值。
分类汇总 | 数字和计算将正确显示。分组和分级显示功能将不予保留。
1904 年日期系统 | 显示的日期将保持不变，但日期的序列号将转换为 1900 年日期系统。
显示精度 | 单元格的值被发布。
R1C1 引用样式 | R1C1 引用样式将转换为 A1 引用样式。
Excel 格式、图形和显示功能 | 当发布或保存为网页时发生的情况
旋转或竖排文字 | 旋转或竖排文字将转换为横排文字。
分散对齐 | 不保留。
Thai 对齐 | 不保留。
缩进文本 | 不保留。
单元格中的自动换行文本 | 不保留。
图形 | 不保留。
图案填充 | 不保留。
点划线边框 | 点划线边框将转换为实线边框。
单个单元格中的多种字体 | 不保留。将使用单元格中第一个字符的字体。
条件格式 | 不保留。
单元格批注 | 不保留。
数据有效性限制和消息 | 除“自定义”和“列表”外的所有有效类型都得以保留。另外，有效性规则中的单元格引用、自定义输入消息和自定义错误消息都不被支持。
审核追踪箭头 | 不保留。
分级显示 | 折叠的行将按隐藏状态发布，展开的行则正常发布。
打印或页面设置功能。 | 不保留。
Excel 文件、共享和导入功能 | 当发布或保存为网页时发生的情况
共享工作簿信息 | 不保留。
Lotus 兼容性 | R1C1 引用样式将转换为 A1 引用样式。
外部数据区域 | 值将被发布。根据源数据进行刷新的功能将不保留。
Web 查询 | 值将被发布。根据源数据进行刷新的功能将不保留。
密码 | 不保留。
Excel 列表和 XML 列表功能 | 当发布或保存为网页时发生的情况
Excel 列表 | 不保留。
XML 列表 | XML 列表得以保留，但如果列表有一个总计行，总计行不保留。


将电子表格导出到 Excel 工作簿中

  • 在电子表格的工具栏上，单击“导出到 Microsoft Excel” 导出到 Microsoft Excel 以运行或切换到 Microsoft Excel，并在工作簿中显示数据。

注释

  • 因为 Excel 支持 256 列和 65,536 行，所以不能将电子表格中的数据导出到 IW 列至 ZZZ 列，以及 65,537 行到 262,144 行。但是，可以将数据复制到多个 Excel 工作表中。
  • 将电子表格中的数据导出到 Excel 时，只会导出值和公式。与网页中的其他数据或与其他网页相连的链接无法在 Excel 中保留。
  • 如果导出某些电子表格数字格式，则 Excel 中的数据将按自定义数字格式显示。例如，“是/否”、“真/假”和“打开/关闭”电子表格格式都将在 Excel 中按自定义数字格式显示。有关 Excel 中自定义数字格式的详细信息，请参阅 Excel 的“帮助”。


电子表格中错误值的疑难解答

如果公式不能正确计算结果，则电子表格将显示错误值。例如，当公式需要数字值时却得到文本，或删除了公式引用的单元格，以及单元格宽度不足以显示结果时，都将导致错误值。

错误值可能不是由公式本身造成的。例如，如果公式显示 #N/A 或 #VALUE!，则说明公式引用的单元格中可能包含错误。

以下是每个错误值的可能原因和解决方案。

显示 #####

如果单元格中包含的数字、日期或时间的长度超出了单元格的宽度，则会导致 ##### 错误值。可以通过拖动列标之间的边界调整列的大小。

显示 #CIRC!

如果公式引用自身，则不论是直接还是间接引用，都将导致 #CIRC! 错误值。

可能原因 | 建议解决方案
单元格中的公式直接引用了自身。例如，单元格 B10 包含公式 =SUM(B5:B10)。 | 检查公式中的引用，并确保该引用没有引用到单元格自身。
单元格中的公式间接引用了自身。例如，单元格 B10 中包含公式 =SUM(B5:B9)，而单元格 B5 中包含公式 =B10*0.5。 | 检查公式引用的所有单元格，并确保这些单元格都不包含对含有 #CIRC! 错误的单元格的引用。 如果公式引用的任意单元格中包含公式自身，则请确保这些公式引用的单元格中不包含对含有 #CIRC! 错误的单元格的引用。

显示 #DIV/0!

如果公式除以 0（零），则会导致 #DIV/0! 错误值。

可能原因 | 建议解决方案
除数引用了空白单元格或包含 0 的单元格（如果操作数引用了空白单元格，则将解释为 0）。 | 更改单元格引用，或在用作除数的单元格中输入非 0 值。可以在作为除数引用的单元格中输入值 #N/A，这样就会将公式的结果更改为 #N/A，表示除数不可用。 为了防止显示错误值，请使用 IF 电子表格函数。如果除数引用了空白单元格或包含 0 的单元格，则 IF 函数将不显示任何内容，而不是错误值。例如，可使用 =IF(B5=0,"",A5/B5)。其中，两个引号代表了一个空文本串。
将 0 用作除数，例如 =5/0。 | 将除数更改为非 0 的数字。

显示 #N/A

如果函数或公式无法使用某个值，则会导致 #N/A 错误值。

如果电子表格中的某些单元格包含还不能使用的数据，则可以在这些单元格中输入“#N/A”，这样引用这些单元格的公式将返回 #N/A，而不会试图进行计算。

如果必需的值都可用，但却在不希望出现此错误值的位置出现了 #N/A 错误值，则可能是由于该函数中某些参数的特定要求未被满足，或者也可能是由于在公式或函数参数中没有正确地引用值。

可能原因 | 建议解决方案
为 HLOOKUP、LOOKUP、MATCH 或 VLOOKUP 电子表格函数的 lookup_value 参数赋予了不适当的值。 | 请确保 lookup_value 参数的值类型正确。例如，应该引用值或单元格，而不应引用区域。
使用 MATCH 电子表格函数时，match_type 参数不正确。 | MATCH 电子表格函数中包含 match_type 参数，此参数指定了函数将如何对 lookup_value 参数和 lookup_array 参数中的值进行匹配。例如，match_type 参数可以设置为在按升序或降序排序的 lookup_array 参数中查找最相近匹配的值或完全匹配的值，或在没有排序的 lookup_array 参数中进行查找。 如果函数找不到匹配的值，请确保 lookup_array 参数是根据所使用的 match_type 参数进行排序的，并（或）试着更改 match_type 参数。
将 range_lookup 参数设置为 FALSE，并使用 HLOOKUP 或 VLOOKUP 电子表格函数查找不可用的值。 | VLOOKUP 和 HLOOKUP 电子表格函数中包含 range_lookup 参数，该参数决定了函数是查找完全匹配还是模糊匹配的数据。如果此参数为 TRUE 或省略此参数，则返回模糊匹配的值。也就是说，如果没有找到完全匹配值，将返回比 lookup_value 参数小的下一个最大值。如果参数为 FALSE，则 VLOOKUP 将查找完全匹配值。如果一个也找不到，则会返回 #N/A 错误值。请确保要查找的值位于 lookup_array 参数中。
在电子表格函数中漏掉了一个或多个参数。 | 请在函数中包含所有必需的参数。

显示 #NAME?

如果公式中的文本无法识别，将导致 #NAME? 错误值。

可能原因 | 建议解决方案
函数名称拼写错误。 | 更正拼写。
在公式中输入文本时没有用双引号将文本括起，因而不能正确解释为文本。 | 将公式中的文本用双引号括起来。例如，下列公式将文本“The total amount is”与单元格 B50 中的值连接起来： ="The total amount is "&B50
漏掉了区域引用中的冒号 (:)。 | 请确保公式中的所有区域引用都使用了冒号 (:)。例如，SUM(A1:C10)。

显示 #NULL!

如果指定了两个实际上并不交叉的区域的交集，将导致 #NULL! 错误值。

可能原因 | 建议解决方案
使用了不正确的区域运算符。 | 如果要引用不相交的两个区域，则请使用联合运算符，即逗号 (,)。例如，公式 =SUM(A1:A10,C1:C10) 将不相交的两个区域相加，并用逗号分隔两个区域。 如果要引用相交的两个区域，则请使用交集运算符，即单个空格。例如 =SUM(B5:C15 A10:D10)，这样就会计算两个区域的公共单元格（即交集）B10 及 C10 的和。
使用了不正确的单元格引用。 | 检查区域引用中是否有键入错误。

显示 #NUM!

如果公式或函数中的数字有误，将导致 #NUM! 错误值。

可能原因 | 建议解决方案
在必须使用数字参数的函数中使用了不合适的参数。 | 请确保函数所用参数的类型是正确的。
使用了反复迭代的电子表格函数，例如 IRR 或 RATE，则经过一定次数的尝试之后，函数仍不能得到一定精度的结果。 | 对估计参数使用其他值。
公式计算出的结果太大或太小，以致于该数字无法在电子表格中表示。 | 电子表格中的值必须在 -1E307 和 1E307 之间。

显示 #REF!

如果单元格引用无效，则会导致 #REF! 错误值。

可能原因 | 建议解决方案
删除了其他公式引用的单元格，或将已移动的单元格粘贴到其他公式引用的单元格上。 | 更正公式，或在删除或粘贴单元格之后单击“撤消” 按钮图像 以恢复电子表格上的单元格。

显示 #VALUE!

如果使用了错误类型的参数或操作数，将导致 #VALUE! 错误值。

可能原因 | 建议解决方案
当公式需要数字或逻辑值（例如 TRUE 或 FALSE）时，却输入了文本。文本不能转换为正确的数据类型。 | 请确保操作数或参数的值符合公式或函数所需的数据类型，且公式所引用的单元格中包含有效的值。例如，如果单元格 A5 中包含数字且单元格 A6 中包含文本“不可用”，则公式 =A5+A6 将返回错误值 #VALUE!。如下所示使用 SUM 电子表格函数将两个值相加（SUM 函数将忽略文本）： =SUM(A5:A6)
为需要单个值的运算符或函数提供了区域。 | 将区域更改为单个值。
当函数需要区域时却省略了区域。 | 某些函数，例如 COUNTIF 和 SUMIF，需要使用区域。请确保包含所有必需的区域参数。
为 ADDRESS 电子表格函数的 A1 参数提供了非 1 的值。 | ADDRESS 函数只能返回 A1 样式的引用。请将参数更改为 1。
为数据库函数（D 函数）使用了计算条件（将公式作为条件使用）。 | “电子表格组件”中的数据库函数不支持计算条件（例如，“=Field1<Field2”）。请将条件更改为简单条件，例如“Field1”。
用 AREAS 电子表格函数引用多个区域。 | AREAS 电子表格函数不支持多个区域。只能引用一个单元格区域。


电子表格疑难解答

查找帮助信息

显示 无法找到所需的帮助信息

根据您使用电子表格组件的方式，将会在不同位置找到帮助信息。有关详细信息，请参阅关于获取电子表格的帮助信息。

输入和编辑数据和公式

显示 不能更改电子表格中的单元格

单元格可能已锁定或受保护。有关详细信息，请参阅网页设计程序。

显示 不能对电子表格单元格中的文本进行自动换行

Microsoft Office“电子表格组件”不支持单元格中文本的自动换行。如果要正确显示文本，请缩短文本或对文本使用多个单元格，或者还可以增加列宽以显示所有文本。

显示 电子表格中没有编辑栏

与 Microsoft Excel 不同，Microsoft Office“电子表格组件”不提供编辑单元格内容的编辑栏。但是，通过双击单元格或者在选定单元格后按 F2 可以编辑单元格中的内容。

显示 不能更改超链接

如果正在修改通过 Microsoft Excel 工作表发布的超链接，且该超链接最初是用 Excel 中的“插入超链接”对话框创建的，则可以更改该超链接显示的文本，但不能更改该超链接跳转的地址。若要更改地址，请先删除该超链接，再插入新的超链接。

显示 不能控制电子表格的大小

电子表格可能已设置为自动调整大小。有关详细信息，请参阅网页设计程序。

显示 不能控制是否在电子表格中显示或隐藏滚动条

网页设计程序可能已将电子表格设置为自动调整大小。如果是这样，那么在电子表格达到最高和最宽设置时将显示滚动条，而不管滚动条被设置为显示还是隐藏。有关详细信息，请参阅网页设计程序。

筛选、排序和查找数据

显示 电子表格中的数据不能正确排序

如果对电子表格进行排序没有产生希望的结果，则请按下列步骤进行检查：

在排序前检查选定区域 如果选定了要排序的单元格区域，则电子表格将对该区域中且只对该区域中的所有数据进行排序。这意味着，如果标题行位于选定区域中，则标题行也将排序。另外，如果选定了必须排序的列表中的一列数据，则只对该列进行排序，而不对整个列表进行排序。请选定要排序区域中的单个单元格，注意不能是标题行中的单元格。电子表格将自动检测数据进行排序，并且排除标题行。如果这样做仍然无效，则请选定要排序的整个区域，但不要选定标题行。

检查数字所使用的格式是否为数字格式 如果值的排序不正确，可能是由于单元格的格式设置为文本格式而非数字格式。例如，某些会计系统中的负数在导入电子表格后将转换为文本格式。如果要应用正确的格式，则请单击该单元格，然后更改数字的格式。

检查日期和时间的格式是否正确 日期和时间将按数字进行处理。将日期或时间输入到单元格中之后，单元格的格式将从“常规”数字格式更改为内置日期或时间格式。为确保日期和时间能正确排序，列中所有日期和时间的格式都必须相同。如果要应用正确的格式，请单击单元格，然后更改数字的格式。

删除前导空格 请确保数据前没有插入前导空格。在对数据排序前请先删除前导空格。

检查区域设置 排序次序将随区域设置的不同而变化。请确保“控制面板”的“区域设置”或“区域选项”中的区域设置正确。有关更改区域设置的详细信息，请参阅 Windows 的“帮助”。

确保按正确次序对多个列进行了排序 在对多个列进行排序时，排序的次序决定了数据的组织方式。首先排序较低级别（内部）的分类，然后排序较高级别（外部）的分类。

显示 电子表格清单没有显示所有数据

列表可能用“自动筛选”命令进行了筛选而仅显示特定行。如果在每列顶部单元格的右边出现箭头，请执行下列操作之一：

  • 单击该箭头，然后单击“（全部显示）”。
  • 请确保未选中工具栏上的“自动筛选”按钮 按钮图像 。

显示 合并单元格后，不能筛选电子表格

Microsoft Office“电子表格组件”不支持对包含合并单元格的列表进行筛选的功能。如果电子表格中包含合并单元格，那么请拆分该合并单元格，然后再使用“自动筛选”命令。

显示 “查找下一个”命令并不查找电子表格中的数据。

如果选定了数据区域，则“查找下一个”命令将只在选定区域内搜索指定值。如果要查找电子表格中任意位置的数据，请在单击“查找下一个”命令之前选定单个单元格。

显示 通过 Excel 发布电子表格后，“自动筛选”下拉列表出现错误

在 Microsoft Excel 中，可以创建无法显示在电子表格的“自动筛选”下拉列表中的“自动筛选”条件。例如，在电子表格中没有与“前 10 个...”或“始于”等价的条件。

如果在 Excel 中发布了“自动筛选”区域，但该区域使用的条件无法显示在电子表格的“自动筛选”列表中，则被筛选的项将正确地显示在网页上，但“自动筛选”列表并不反映所选择的条件。

通过单击电子表格工具栏上的“自动筛选” 按钮图像 关闭筛选功能可重新设置下拉列表，而再次单击“自动筛选” 按钮图像 将再次打开筛选功能。这也将重新设置所显示的列表。

导入和导出

显示 不能通过 Microsoft Excel 发布有密码保护的电子表格

通过 Microsoft Excel，只能发布密码为空的受保护电子表格。请在 Excel 中打开原始工作簿并删除密码，然后再重新发布工作表。

显示 电子表格筛选未正确导出到 Excel 中

在电子表格中，可以创建某些“自动筛选”条件，但不能显示在 Microsoft Excel 的“自动筛选”下拉列表或“自定义自动筛选方式”对话框中。例如，在 Excel 中，没有与包含三个未选定项的电子表格筛选等价的筛选条件。将电子表格导出到 Excel 中时，如果电子表格中包含 Excel 不支持的筛选条件，则将在 Excel 中显示整个“自动筛选”区域。

如果要导出筛选数据，并像在电子表格中一样进行显示，则建议不要为每个筛选设置两个以上的条件，也就是说，不应该有两个以上的复选框设置（选中或清除）与其他复选框不同。

显示 试图将电子表格导出到 Excel 时，有消息显示行或列过多

电子表格可以包含从列 A 到列 ZZZ 以及从行 1 到行 262,144 的数据。另一方面，Microsoft Excel 工作表只包含从列 A 到列 IV 和从行 1 到行 65,536 的数据。如果要将电子表格导出到 Excel，则必须将 IV 以后的列和 65,536 以后的行中的数据删除或移动。如果需要，可将这些数据复制到另一张 Excel 工作表中。

在浏览器中处理电子表格

显示 不能与电子表格进行交互

如果可以查看电子表格而不能与电子表格进行交互，可能是因为不能访问 Microsoft Office 2003 许可。有关详细信息，请与系统管理员联系。

显示 在浏览器中打开包含电子表格的网页时，显示错误消息“无法打开 URL”

源数据网页不可用 如果电子表格中的某些数据来自其他网页，则检查该网页是否可用，以及用户是否可访问该网页。

网页不在本地 如果电子表格包含链接其他网页上的数据的公式，请检查是否可以访问该网页以及该网页是否在本地计算机或 Intranet 上。有关详细信息，请与系统管理员联系。

显示 在 Web 浏览器中单击“编辑”按钮时在不正确的程序打开了网页。

Web 浏览器中的“编辑”按钮所调用的程序取决于该页面是如何发布的。

如果单击 Web 浏览器中的“编辑”按钮时却打开了不希望使用的程序，那么请退出该程序，接着启动要使用的程序，然后在新启动的程序中打开该网页。

错误值

显示 出现了错误值而不是公式的结果

如果部分公式不能计算或公式中出现问题，则公式将返回错误值，例如 #NAME? 或 #DIV/0!。如果要查明原因，请阅读错误值的疑难解答。

访问其他域上的数据源

显示 电子表格未能成功访问其他域上的数据。

Microsoft Internet Explorer 中的配置设置可控制是否允许 ActiveX 控件访问不是网页所在的服务器的域上的数据源。有关如何配置 Internet Explorer 以允许电子表格访问其他域上的数据的信息，请参阅关于访问不同域上的数据源。