关于数据透视表列表

数据透视表列表是一种交互式的表格，可以对来自 Web 浏览器中的数据动态的进行分析。可以使用数据透视表列表查看和组织列表或数据库中的数据，也可以查找信息或明细数据，并且可以创建个性化的汇总和报表。

数据透视表列表可以显示来自网络其他位置的数据源中的已有数据。数据透视表列表的创建者决定要使用的源数据，也就是说，设计者决定要使用什么样的源数据库以及要使哪些数据子集可用。子集决定了查看者可以汇总的内容。例如，如果要汇总产品销售额和库存级别，则源数据需要提供产品的销售数据和库存数量。不能在列表的计算单元格中键入新值，也不能重新定义列表所显示的源数据，但是可以更改数据的显示和组织方式。同样，还可以刷新数据透视表列表以反映源数据中的任何更改。

数据透视表列表的设计者可以包含相关联的图表，它们以图形的方式显示相同数据。如果您查看的网页包含这样的图表，当刷新或对数据透视表列表做某些更改时，您会看到反映在图表中的更改。同样，对图表所做的某些更改也会反映在数据透视表列表中。

显示 分析数据

数据透视表列表的设计者通过设置列表来显示多种可能的数据视图之一。可以使用数据透视表列表工具栏和“命令和选项”对话框来更改数据的显示方式。可以查找特定的数据、显示更多或更少的明细数据量或者将行和列移至不同的区域以计算数据的不同汇总。

在其最简单的窗体中，数据透视表列表在行和列中显示数据，相同列中具有相似的情况。每一列称为一个字段。下例中包含名为“运动”、“季度”和“销售”的字段。

简单的数据透视表列表类似于数据库中的记录表，或电子表格数据清单中的一组行。若要进一步分析数据，可执行以下操作：

  • 筛选字段以查找数据。例如，仅显示关于第三季度网球销售额的数据。
  • 通过对项进行排序以重新排列行。例如，对“销售”字段进行排序以查看哪种运动和哪个季度的销售额最高。
  • 在行和列区域中对字段进行分组。例如，可以对前两个季度分组以比较前半年和单个季度的销售额。
  • 向列表中添加分类汇总或其他计算。例如，显示每种运动最大的销售量。

数据透视表列表中包含不同的区域，可以将字段移至这些区域以进行汇总或查看字段项的明细数据。可以将所有字段移至明细数据区域，以便像上例一样显示数据透视表列表（如果源数据设置为允许这样操作）。

显示 汇总数据

通过创建汇总字段并将字段移到其他区域，可以快速的汇总数据。通过创建一个“销售总额”汇总字段，将“运动”字段移至行区域，并将“季度”字段移至列区域，则可容易地看到第三季度高尔夫销售额与其他运动或其他季度情况的比较，也可以查看总计销售额。

显示 关于源数据

数据透视表列表可以显示来自网络数据库中的数据，包括联机分析处理 (OLAP) 数据库和关系数据库，例如 Microsoft Access 或 Microsoft SQL Server。数据透视表列表也可以显示来自网络中其他类型数据库的数据，或显示来自电子表格数据库（例如 Microsoft Excel 数据清单）的数据。源数据库的类型以及所查看的数据透视表列表中所包含的数据的类型将决定用户可以在 Web 浏览器中创建的视图和汇总种类。

OLAP 是一种数据库服务器处理方法，它按一定的方法组织大量的数据，使需要分析商务趋势和结果的用户能够更方便地访问和理解数据。这些数据库按明细数据的字段集（也称作维）和级别来组织数据分类。

例如，“地理”字段集可能包含“国家/地区”、“地区”和“市/县”级别，“时间”字段集可能包含“年”、“季度”、“月”和“日”级别。 这些级别会转化为数据透视表列表中的行、列或筛选字段。

如果使用基于 OLAP 数据库（例如：由 Microsoft SQL Server OLAP Services 创建的数据库）的数据透视表列表，将发现不能将字段移至明细数据区域中，而且某些字段只能用于数据区域。

显示 保存更改

如果使用 Microsoft Internet Explorer 5.01 (Service Pack 2) 或更高版本，则对数据透视表列表所做的更改将在浏览器会话期间保留，即使在查看其他网页后返回数据透视表列表，该更改仍然保留。但是，如果重新打开网页（例如，通过单击 Internet Explorer 地址栏然后按 Enter 打开网页），则所做的更改将消失。

不管使用何种 Web 浏览器，所做的更改均不会影响原始数据透视表列表。因此，正在查看相同数据透视表列表的其他用户均不会看到所做的更改。

显示 使用其他程序

您可以将数据从数据透视表列表复制到其他程序（例如 Microsoft Word）中，或者，如果要进一步分析数据或打印自定义版本的数据，可以将数据透视表列表导出到 Microsoft Excel 数据透视表中。如果要创建自己的数据透视表列表，或更改已有数据透视表列表的设计，则可以使用 Microsoft Access 或 Microsoft FrontPage 打开网页，并使用数据透视表列表的高级功能。有关详细信息，请查看 Access 或 FrontPage 的“帮助”。

显示 浏览器及许可要求

若要在浏览器中使用交互式的数据透视表列表，则必须安装 Microsoft Office Web Components 和 Microsoft Internet Explorer 5.01 (Service Pack 2) 或更高版本，并具有有效的 Microsoft Office 2003 许可。没有适当的许可，您可以查看组件但是不能与它们进行交互。请与网络管理员或计算机管理员联系以查看您的系统是否符合与数据透视表列表进行交互所必需的条件。

显示 禁用的功能

数据透视表列表中的某些元素可能被网页的设计者保护起来。例如，设计者可能禁止添加或移动字段，禁止排序和筛选，禁止显示工具栏或“命令和选项”对话框。如果访问这些功能有问题，而您的计算机符合浏览器和许可的要求，请与网页的设计者联系。


关于在不同的浏览器中使用数据透视表列表

若要与数据透视表列表交互，用户必须安装 Microsoft Office Web Components，并拥有适当的 Microsoft Office 2003 许可以及 Microsoft Internet Explorer 5.01 (Service Pack 2) 或更高版本。如果没有 Office 2003 许可，也可安装该组件，并在网页中对其进行查看，但是不能与其进行交互。

如果安装了 Office Web 组件并且具有 Office 2003 许可，则可支持的浏览器如下：

显示 Microsoft Internet Explorer 5.01 (Service Pack 2) 或更高版本

在该浏览器中，用户可以访问通过浏览器所能访问的所有数据透视表列表功能。当用户离开数据透视表列表，又在相同浏览器会话中重新回到该数据透视表列表时，用户所做的更改（如格式和版式的更改）将保留。

显示 其他浏览器

在 Microsoft Internet Explorer 的早期版本和其他浏览器中，将不能查看数据透视表列表。如果使用这些浏览器，则数据透视表列表可能只在网页上显示为带外边框的框或根本不显示。


关于 Microsoft Office Web Components

Microsoft Office Web Components 是 Microsoft Office 2003 中安装的一组 ActiveX 控件。计算机上安装了 Office Web 组件之后，您就可以在 Internet Explorer 5.01 (Service Pack 2) 或更高版本中对电子表格、数据透视表列表和图表进行交互访问。

如果计算机上未安装 Office Web 组件，但您有允许 Intranet 发布的 Office 2003 站点许可证，则可对组件进行配置，以提示用户从公司的 Intranet 下载 Office Web 组件。这样，您网站上的用户无须在计算机上安装 Office 2003 软件就可使用数据访问页。

有关如何配置 Office Web 组件的信息，请参阅《Microsoft Office 2003 资源工具包》。


关于 Office Web 组件的“仅供查看”模式

如果您的计算机未安装 Microsoft Office 2003 软件许可，或不能通过 Microsoft Office 2003 的应用程序获取该许可，则只能在网页上查看 Microsoft Office Web Component（电子表格组件、图表组件或数据透视表组件），而不能与其进行交互。

若要与正在查看的组件进行交互并使用其完整的功能，则必须安装 Microsoft Office 2003 或获取 Office 2003 许可。如果您是在公司或组织中，请向网络管理员咨询以获取帮助。

在“仅供查看”模式中时，可以：

  • 查看数据。
  • 打印。
  • 选择并进行滚动。
  • 使用超链接。
  • 调整组件大小。
  • 在“电子表格组件”中选择工作表。
  • 在数据透视表列表中展开或折叠成员。
  • 在数据透视表列表中刷新数据。
  • 使用“关于”、“帮助”和“刷新”命令。不会应用处理交互操作（设置单元格格式、拖动字段、排序、筛选等等）的“帮助”主题。

除“关于”、“帮助”和“刷新”命令外的所有其他命令在“仅供查看”模式中不能使用。


关于设计数据透视表列表

本主题中的部分内容可能不适用于某些语言。

在 Web 浏览器中查看数据透视表列表并与其进行交互时，处理的是由其他程序（称为设计程序）创建的控件。在设计程序中，可以选择希望数据透视表列表显示的源数据，可以将数据透视表列表添加到所设计的网页中，还可以将网页发布到 Web 服务器上。在设计程序中可获得有关设计数据透视表列表的“帮助”。

显示 设计自己的数据透视表列表

如果要进一步了解设计数据透视表列表的详细信息，请首先选择要使用的设计程序。可以使用任何支持的设计程序，如果需要其他的设计功能，则可以稍后在其他设计程序中处理该数据透视表列表。例如，如果是在 Microsoft Excel 中设计数据透视表，则可以用 Excel 将此报表保存或发布到网页上的数据透视表列表中。如果需要自定义生成的数据透视表列表以更改其默认设置，或需要将其他控件添加到页上，则可以在 Microsoft FrontPage 中打开和修改网页。

可以使用下列设计程序来创建数据透视表列表。

显示 Microsoft FrontPage

建议使用 FrontPage 修改通过 Microsoft Excel 保存或发布的数据透视表列表。在 FrontPage 中，可创建网页上的数据透视表列表、修改在其他程序中设计的数据透视表列表，然后使用 FrontPage 的功能构建和管理网站。

显示 Microsoft Access

Access 为用户提供了一些特殊化功能，包括创建可在上面操作和显示来自 Microsoft Access 和 Microsoft SQL Server 数据库中的数据的网页等。例如，可以使用字段列表定位数据，并将其拖到数据透视表列表中。可以在数据透视表列表和其他用于在网页上显示和操作数据库中数据的控件之间建立链接。

显示 Microsoft Excel

如果要尝试不同布局并调整可用于数据透视表列表的源数据，则 Excel 是优秀的设计环境。在 Excel 中可以访问外部数据并创建 Excel 数据透视表。通过 Excel，还可以将数据透视表保存或发布到网页的数据透视表列表上（数据透视表是 Excel 版本的数据透视表列表）。在 Excel 中指定的源数据将自动连接到数据透视表列表，并且在发布数据透视表列表时大多数 Excel 数据透视表功能都包括在里面。

您可能希望在其他设计程序中设置数据透视表列表的格式，并调整其大小和外观。

显示 Microsoft Visual Basic 或脚本语言

如果是程序员，则可以编写程序或脚本来创建数据透视表列表。Microsoft FrontPage 和 Microsoft Access 都可用于编写脚本。如果要设计在自定义解决方案中使用而不在 Web 浏览器中使用的数据透视表列表，则可以使用其他编程环境，例如 Microsoft Visual Basic。

Microsoft Word 则不是适合于数据透视表列表的设计程序。

显示 获取设计帮助

在设计程序（例如 Microsoft FrontPage 或 Microsoft Access）中创建或激活数据透视表列表时，“命令和选项”对话框将提供用于自定义数据透视表列表在浏览器中的使用方式的其他属性和命令。设计程序也可能提供自己的命令和功能，用于准备源数据并将其附加到数据透视表列表中。

使用设计程序时，可以通过以下两种方法获得有关设计数据透视表列表的帮助：

显示 设计程序的“帮助”

有关设计程序中可用于处理数据透视表列表的命令和功能的详细信息，请参阅设计程序中的“帮助”。例如，在 Microsoft Access 中，可单击“Office 助手”或单击“Microsoft Office Access 帮助” 按钮图像 。

Microsoft Excel 提供了关于保存和发布 Excel 数据在网页上使用的常规“帮助”，也提供了有关为数据透视表准备数据并将数据透视表作为数据透视表列表发布到网页上的特定信息。若要在 Excel 中访问该“帮助”，请单击“Office 助手”或单击“Microsoft Office Excel 帮助” 按钮图像 。

显示 数据透视表列表的设计“帮助”

在设计程序中所创建或激活的数据透视表列表中，可以单击数据透视表列表工具栏上的“帮助” 按钮图像 。这样，将会显示关于在设计程序中的数据透视表列表中能够使用的命令和属性的设计“帮助”主题。该设计“帮助”与浏览器中的“帮助”（即：当前正在查看的“帮助”主题）不同。

显示 为数据透视表列表编写脚本和程序

可以使用脚本和程序自动操作数据透视表列表，或者，也可以不在 Web 浏览器中而在运行时程序中使用数据透视表列表，运行时程序是在编程环境（如 Microsoft Visual Basic）中开发的程序。

编写脚本

Microsoft Office 2003 程序提供了“Microsoft 脚本编辑器”用于编写脚本。例如，在处理 Microsoft Access 的数据访问页时，可以使用“设计”视图中的“脚本编辑器”来自定义数据透视表列表。有关运行“脚本编辑器”的详细信息，请参阅 Microsoft Office 设计程序中的“帮助”。在“脚本编辑器”中，可以显示有关使用其功能和编写脚本的附加“帮助”。

对象模型“帮助”

若要获取有关开发程序或脚本以处理数据透视表列表的帮助，请使用 Microsoft Office Web Components 的“Visual Basic 参考”以显示与数据透视表列表相关的对象模型、属性和方法的信息。此对象模型“帮助”在安装 Microsoft Office Web Components（“数据透视表组件”就是其中之一）时将安装。根据所使用的设计程序的不同，可以按下列两种方法之一获取该“帮助”：

  • Microsoft Visual Basic 中的“帮助” 在 Visual Basic 或 Visual Basic for Applications (VBA) 中，可以创建对 Microsoft Office Web Components 库的引用，然后可以在对象浏览器中获得“帮助”，或通过选择关键字并按 F1 获得“帮助”。有关创建引用和使用对象模型“帮助”的详细信息，请参阅 Visual Basic 或 VBA 中的“帮助”。

  • 其他环境中的“帮助” 如果使用其他开发环境，则请找到并双击“帮助”文件“Owcvba10.chm”。


关于访问不同域上的数据源

当数据透视表列表试图访问其他域中的数据，但是由于以下原因失败了：

  • 控件正在访问的网站不包括在可信网站的列表内。
  • 在 Internet Explorer 中的“安全设置”对话框上，在“其他”下面的“通过域访问数据资源”设置被设为“禁用”，或被设为“提示”，而当您被提示时，却单击了“取消”。

若要启用跨域访问，请执行下列操作：

显示 启用提示

  1. 在 Internet Explorer 中的“工具”菜单上，单击“Internet 选项”。在“安全”选项卡上选择相应的 Web 内容区域，然后单击“自定义级别”。在“其他”下面，将“通过域访问数据资源”设置为“提示”。
  2. 当被提示时，如果您信任数据提供商，请单击“确定”以便允许数据透视表列表从指定域访问数据。

显示 将网站添加到可信网站列表中

如果正在访问的网站总是可靠的，则可将网站添加到可信网站列表中。

  1. 在 Internet Explorer 中的“工具”菜单上，单击“Internet 选项”。在“安全”选项卡上选择“受信任的站点”作为 Web 内容区域，然后单击“站点”。
  2. 在“可信站点”对话框中，输入网站详细信息，然后单击“确定”。


保存对数据透视表列表的更改

如果使用 Microsoft Internet Explorer 5.01 (Service Pack 2) 或更高版本，则对数据透视表列表所做的更改将在浏览器会话期间保留，即使在查看其他网页后返回数据透视表列表时，该更改仍然保留。但是，如果重新打开网页（例如，通过单击 Internet Explorer 地址栏然后按 Enter 打开网页），则所做的更改将消失。

若要对数据透视表列表进行更改并将这些更改保存到文件中，请在设计程序（如 Microsoft FrontPage 或 Microsoft Access）中打开数据透视表列表。

还可以将数据透视表列表导出到 Microsoft Excel 数据透视表中，然后保存该 Excel 报表。有关详细信息，请参阅 Excel 中的“帮助”。


撤销对数据透视表列表的更改

  • 若要将数据透视表列表恢复为在 Microsoft Internet Explorer 中首次查看时的初始状态，请关闭 Internet Explorer，然后再次启动 Internet Explorer。

注释 不能撤消对数据透视表列表的单个更改。


打印数据透视表列表

  • 在 Microsoft Internet Explorer 的“文件”菜单上，单击“打印”。

注释

  • 如果数据透视表列表比打印纸张宽或长，则超出页面的部分将不打印。
  • Web 浏览器只打印数据透视表列表中没有隐藏且在浏览器会话期间滚动过的部分。例如，如果仅显示较高级别的明细数据或隐藏明细数据，则不会打印隐藏的明细数据。如果从头到尾滚动了数据透视表列表中的所有数据，则会打印整个数据透视表列表。
  • 如果要更灵活地控制数据的打印方式（包括打印较长清单以及设置自动分页符），则可以将数据透视表列表导出到 Microsoft Excel 中。有关从 Excel 中打印的详细信息，请参阅 Excel 中的“帮助”。


数据透视表列表的元素

标注 1 筛选字段

标注 2 行字段

标注 3 列字段

标注 4 字段下拉箭头

标注 5 数据字段

标注 6 展开指示器

显示 字段

每个字段都对应一列数据，并且可以汇总多行信息。字段类型包括行字段、列字段、数据字段、明细数据字段和筛选字段。

显示 项

字段中数据的唯一元素。行和列字段中的数据项跨列和沿行显示。行和列相交处的单元格显示该行上部和该列左边各项的汇总数据。当可显示较低级别的项时，则展开指示器 加号框 将显示在项的旁边。最低级别的项将不显示展开指示器。项右侧的展开指示器（ 加号框 和 减号框 框）表示明细数据可用于该项。

显示 行字段

行区域中的字段。在上面的数据透视表列表中，“产品”和“销售人员”是行字段。行字段中的项都列在数据透视表列表的左边。最靠近数据区域的行字段（例如“销售人员”）为内部行字段；内部行字段左边的行字段（例如“产品”）为外部行字段。

显示 列字段

列区域中的字段。列字段中的项都横向排列在数据透视表列表的顶部，位于数据字段之上。在上面的数据透视表中，“年份”是具有两个数据项的列字段，这两个数据项分别为“1996”与“1997”。最靠近数据区域的列字段为内部列字段；内部列字段上面的列字段为外部列字段。

显示 筛选字段

在筛选区域（可用于筛选整个数据透视表列表）中的字段可显示特定项的汇总数据。在上面的数据透视表中，“地区”为筛选字段，可用于显示所有地区或只是选定地区的数据。筛选字段具有与 Microsoft Excel 数据透视表中的页字段相同的功能。

显示 数据字段

包含源数据汇总值的字段。在上面的数据透视表列表中，“销售额”是包含汇总销售量的数据字段，数据字段中的每个值都是源数据中“销售额”字段或列中数据项的总和。

数据字段通常使用“求和”汇总函数来汇总数字型数据，例如统计或销售量。在上面的数据透视表列表中，包含 30,984 的单元格显示了 Davolio 在 1996 年的奶制品销售总额。本单元格合并了源数据中包含以下内容的所有记录的销售量：产品为“奶制品”、销售人员为 Davolio 以及年份为“1996”。

基本数据也可以是文本，默认情况下，将用“计数”汇总函数进行汇总，该函数将得到数据项的数量。例如，包含销售产品类型的数据字段可用来统计 Davolio 在 1996 年的奶制品销售数量。数据透视表列表还可以使用“最小值”和“最大值”汇总函数来汇总数据，它们可分别得到最小值和最大值。

显示 数据区域

数据透视表列表中包含数据字段的部分。

显示 明细数据字段

显示源数据中所有行或记录的字段

显示 明细数据区域

数据透视表列表中包含数据字段的部分。

显示 字段下拉箭头

每个字段右边的箭头 字段箭头 。单击该箭头可显示列表，从此列表中可以选择要显示和隐藏的项。

在基于 OLAP 源数据的数据透视表列表中，可以选择维字段中不同级别的项。“日期”和“时间”字段以及具有自定义分组的字段在所有类型的源数据中都提供了不同的级别。例如，单击“年份”字段旁的箭头可能显示如下内容：

在本例中，“1998”旁清除的复选框表明“1998”年已隐藏。“1999”旁灰色的复选框表明“1999”年当前已选定来进行显示，但“1999”下的某些项没有选定来进行显示。在“1999”内，“一季度”就是隐藏的。“2000”旁选中的复选框则表明“2000”年已选定来进行显示。选择“（全部）”将选择所有级别的所有项，以便进行显示。


选取数据透视表列表或其中的元素

显示 选取整个数据透视表列表

  • 如果显示了标题栏，则请单击该标题栏。否则，按 Ctrl+A。

注释 如果数据透视表列表没有绑定到数据源上，则无法显示标题栏。

显示 选取一个或多个数据单元格

  • 若要选取单个单元格，请单击该单元格。若要选取一组单元格，请单击并拖动鼠标指针，直至选取了所有要选取的单元格。

显示 选取行、列或筛选字段

  • 单击字段标志。

注释 选中行或列字段的同时也将选中该字段中的所有数据项。

显示 选取明细数据字段

  • 单击字段标志。如果显示了多个项的明细数据，则字段标志将显示多次，单击字段标志的一个实例将选中所有实例。

显示 选取汇总字段

  • 单击汇总字段的任意字段标志。

显示 选取一个或多个项

  • 若要选取单个数据项，请单击该数据项的标志。
  • 若要将更多数据项添加到选定区域中，请在单击数据项标志时按住 Ctrl。
  • 若要选取一组连续的数据项，请单击第一个数据项的标志，按住 Shift 并单击最后一个数据项的标志。

注释 选定某个数据项时也将选定其中的所有数据。

显示 选取分类汇总或总计

  • 单击分类汇总或总计。

注释 选定某个分类汇总或总计的同时也将选定分类汇总或总计中的所有数据。

显示 选取标题栏或拖放区域

  1. 单击标题栏。

  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“特性”选项卡。

  3. 在“选择标题”列表中，选取所需的项。

显示 选取行或列字段的自定义属性

  1. 单击行或列字段，或其中一个项目。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“项目属性”选项卡。
  3. 在“项目属性”列表中，选取所需的属性。

    注释 如果选中的字段没有自定义属性，则“项目属性”列表为空。

    可以设置选定属性的标题、数字格式和显示位置。所选格式只影响选定的属性。

  4. 若要设置属性的字体和样式，请选取“格式”列表中的“属性标题”或“属性值”。

注释 应用于自定义属性的字体和文本样式设置将影响数据透视表列表中的所有自定义属性，但是只有当这些属性显示在报表中时，设置才起作用。当自定义属性显示在屏幕提示中时，该格式将被忽略。


关于查看基于数据透视表列表的图表

网页的设计者可能创建了图表，该图表以图形的方式显示了数据透视表列表中的信息。本主题提供了有关图表如何工作以及在更改数据透视表列表后图表将如何变化的信息。

显示 自动更新

如果更改了图表所基于的数据透视表列表，则图表将自动更新以反映数据透视表列表中的变化。例如，如果将字段移至行或列区域，则图表将自动更新，并将该字段作为分类或系列数据显示。如果隐藏了信息（例如，筛选数据或从数据透视表列表中删除字段时）而使得数据不再包含于列表的视图中，则相应的信息也将从图表中删除。同样，如果对图表进行了更改，则数据透视表列表将自动更新，以反映图表中的变化。

显示 基于数据透视表列表的图表示例

下面的示例显示了基于数据透视表列表的图表。“求和项：销售额”字段显示了每个销售人员每类产品的总销售额。“销售人员”字段标志的蓝箭头表明该字段经过筛选后只显示四个销售人员的汇总。

标注 1 数据透视表列表的列字段“类型”在图表中显示为分类数据（“饮料”和“奶制品”等）。

标注 2 “销售人员”行字段在图表中显示为系列数据。

标注 3 系列名称显示在图例中（“Buchanan”和“Davolio”等）。

在数据透视表列表中添加或移动字段时，图表会自动进行更新以反映更改。

在前面的示例中，“销售人员”字段移动到了数据透视表列表的列区域中，“类型”字段移动到了数据透视表列表的行区域中。“地区”字段添加到了列区域中，并进行了筛选，而只显示“东部”和“北部”。而图表会自动进行更新，这样“类型”字段中的数据在图例中显示为系列，而“销售人员”和“地区”字段中的数据则提供了分类数据。

可以在图表内排序、筛选和移动字段。


更改标题和标志

可以更改数据透视表列表的标题、字段名、字段内项的名称和汇总字段的名称。所做的更改不会影响源数据。

  1. 单击数据透视表列表工具栏上的“命令和选项” 按钮图像 。
  2. 请执行下列一项或多项操作：

    显示 更改标题栏上的文字或拖放区域的标题

    1. 单击数据透视表列表的标题栏。
    2. 单击“命令和选项”对话框的“标题”选项卡。
    3. 在“选择标题”列表中，选取要更改其标题的元素。
    4. 在“标题”文本框中，键入新标题。

    显示 更改字段、字段集或自定义分组字段的标题

    1. 请执行下列操作之一：
      • 若更改字段的标题，请单击该字段。
      • 若要更改字段集的标题，请单击该字段集中的字段。
    2. 单击“命令和选项”对话框的“标题”选项卡。
    3. 在“选择标题”列表中，选取要更改其标题的元素。
    4. 在“标题”文本框中，键入新标题。

    显示 更改项目属性的标题

    1. 单击项目属性所在的字段。
    2. 单击“命令和选项”对话框的“项目属性”选项卡。
    3. 在“项目属性”列表中，单击要更改其标题的属性。
    4. 在“标题”文本框中，键入新标题。

    显示 更改项目或自定义分组的标题

    1. 单击要更改其标题的项目或自定义分组。
    2. 单击“命令和选项”对话框的“标题”选项卡。
    3. 在“标题”文本框中，键入新标题。

注释 如果选定的项目不需要标题，则请清除“标题”文本框。


查看有关字段或项目的信息

  1. 请执行下列操作之一：
    • 有关字段的信息，请单击该字段的标志。
    • 有关字段中数据项的信息，请单击该数据项。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“标题”选项卡。


关于将数据透视表列表导出到 Excel 或其他应用程序中

如果很熟悉 Microsoft Excel 数据透视表并希望在 Excel 中处理数据，则可以有多种实现方法。但是，如果直接在 Excel 中打开包含数据透视表列表的网页，则不能查看或修改数据透视表列表。

显示 导出到交互式的 Excel 数据透视表中

若要使用 Excel 查看和修改网页上的数据透视表列表，则可以将数据透视表列表导出到 Excel 中。Excel 数据透视表将连接到与原始数据透视表列表相同的源数据上，这样，所有原始数据透视表列表中的字段和数据就可用于 Excel 中，并且如果源数据有更改，还可以更新报表。

准备导出到 Excel 中 Excel 数据透视表不能显示明细数据字段。当导出到 Excel 中时，就可以通过 Excel 的“数据透视表”工具栏使用明细数据字段，但字段不会显示在报表中。如果希望 Excel 数据透视表反映 Web 上数据透视表列表的外观，则在导出到 Excel 数据透视表之前，请将所有字段移出明细数据区域，或者隐藏数据项和单元格的明细数据，以便明细数据区域不再显示。

导出后 在将数据透视表列表导出到 Excel 之后，可能会注意到其中的一些变化。这是因为 Excel 数据透视表不支持某些数据透视表列表的功能，或者是以不同的方式执行一些功能。有关数据透视表列表和 Excel 数据透视表之间差异的详细信息，请参阅 Excel 的“帮助”。

显示 将数据复制到其他程序中用于非交互使用

复制到 Microsoft Word 或 Excel 中 如果希望使用当前显示在数据透视表列表中的数据的快照，则可以将数据复制并粘贴到 Excel 或 Word 中。在向其他程序中复制整个数据透视表列表，或复制数据的选定区域时，数据透视表列表中的文本或数值将成为 Word 文档或 Excel 工作簿的一部分。而在数据透视表列表的原始源数据与文档或工作簿的复制内容之间并没有创建任何连接，因此不能刷新或更新复制的数据。

复制到其他程序中 还可以将显示在数据透视表列表中的数据复制到其他程序中，例如 Microsoft FrontPage 或 Microsoft Access 中。在将数据复制到 Excel 或 Word 以外的其他不支持 HTML 格式（数据透视表列表使用此格式）的程序中时，数据将被复制为无格式的文本。


关于获取帮助

在浏览器中，用户可以使用数据透视表列表的“帮助”。这种运行时“帮助”解释了如何在浏览器中使用数据透视表列表的特性和功能。

对于使用 Microsoft Internet Explorer 5.01 (Service Pack 2) 或更高版本和 Microsoft Office Web Components 的用户，与数据透视表列表特定相关的“帮助”是自动可用的。运行时“帮助”与浏览器“帮助”菜单上的“帮助”是相互独立的。

数据透视表列表帮助主题为所有用户提供了有关在浏览器中使用数据透视表列表的常规信息。对于其他 Microsoft Office Web Components（如电子表格组件），用户可在浏览器中使用其“帮助”。

若要了解浏览器所提供的“帮助”，请在网页上创建数据透视表列表，并在 Internet Explorer 中打开该网页，再单击数据透视表列表，然后单击数据透视表列表工具栏上的“帮助” 按钮图像 。在“帮助”窗口中，就可以查看目录并搜索主题文本。在浏览器中不能使用“Office 助手”回答问题。

没有 Office Web 组件和 Internet Explorer 5.01 (Service Pack 2) 或更高版本的用户将不能访问运行时“帮助”。


数据透视表列表中的键盘快捷键

显示 用于激活、使用和停用数据透视表列表的快捷键

Tab
依次选择或激活网页中的控件。激活数据透视表列表后，按 Tab 可选择数据透视表列表中的元素
Ctrl+Tab
停用（或退出）数据透视表列表，将焦点移动到浏览器上的“地址”框

显示 用于选择数据透视表列表中元素的快捷键

Tab
将选定的内容由左至右，然后再向下移动
Enter
将选定的内容由上至下，然后再向右移动
Shift+Tab
选中左边的单元格。如果当前的单元格在最左端，则按 Shift+Tab 将选中上一行的最后一个单元格
Shift+Enter
选中当前单元格之上的单元格。如果当前单元格在最顶端，则按 Shift+Enter 将选中前一列的最后一个单元格
Ctrl+Tab
在列区域中，选定下一项的明细数据单元格
Ctrl+Enter
在行区域中，选定下一项的明细数据单元格
Shift+Ctrl+Tab
在列区域中，选定上一项的明细数据单元格
Shift+Ctrl+Enter
在行区域中，选定上一项的明细数据单元格
箭头键
按箭头键的方向切换选定内容。如果选定行字段或列字段，则按向下键将移动到字段中数据的第一项，然后按某个箭头键可移动到下一项、上一项或回到字段。如果选定了明细数据字段或数据项，则可按向下键或向右键移动到明细数据区域或数据区域的第一个单元格中
Shift+箭头键
按箭头键的方向扩展或缩小选定区域
Ctrl+箭头键
按箭头键的方向，将选定区域移动到最后一个单元格
Shift+Alt+箭头键
按箭头键方向移动选定项
Home
选中当前行最左端的单元格
End
选中当前行最右端的单元格
Ctrl+Home
选中第一行最左端的单元格
Ctrl+End
选中最后一行的最后一个单元格
Shift+Ctrl+Home
将选定区域扩展到第一行最左端的单元格
Shift+Ctrl+End
将选定区域扩展到最后一行的最后一个单元格
Ctrl+空格键
为当前选定的数据项、汇总或明细数据选取字段
Shift+空格键
选取包含当前选定单元格的整行
Ctrl+A
选定整个数据透视表列表
Page Down
显示下一屏
Page Up
显示上一屏
Shift+Page Down
将选定区域向下扩展一屏
Shift+Page Up
将选定区域向上减少一屏

显示 用于执行命令的快捷键

Shift+F10
显示数据透视表列表中选定元素的快捷菜单。使用快捷菜单可执行数据透视表列表中的命令
带下划线的字母
执行快捷菜单上的命令
Esc
关闭快捷菜单，不执行任何命令
Ctrl+7
显示或隐藏数据透视表列表工具栏
Alt+Enter
显示“命令和选项”对话框
Alt+F4
关闭“命令和选项”对话框
F9
使用源数据刷新数据透视表列表
Esc
取消进行中的刷新操作
Ctrl+C
将选定数据从数据透视表列表复制到剪贴板中
Ctrl+V
粘贴剪贴板中的内容
Ctrl+X
将选定的数据移入剪贴板
Ctrl+E
将数据透视表列表导出到 Microsoft Excel 中

显示 用于显示、隐藏、筛选和排序数据的快捷键

Ctrl+8
显示或隐藏项旁边的展开指示器（ 加号框 和 减号框 框）
Ctrl+加号（数字键盘）
展开当前选定的项
Ctrl+减号（数字键盘）
隐藏当前选定的项
Alt+向下键
打开当前选定字段的列表
Tab
在字段下拉列表中最近选定的项、“确定”按钮和“取消”按钮之间切换
箭头键
移动到字段下拉列表中的下一项
空格键
选中或清除字段下拉列表中当前项的复选框。
CTRL+>
如果明细数据可用于当前的项，则显示明细数据
CTRL+<
隐藏当前项的明细数据
Enter
关闭字段下拉列表，并应用所做的更改
Esc
关闭字段下拉列表，但不应用所做的更改
Ctrl+T
打开或关闭“自动筛选”
Ctrl+Shift+A
按升序对选中字段或汇总中的数据进行排序 (A - Z 0 - 9)
Ctrl+Shift+Z
按降序对选中字段或汇总中的数据进行排序 (Z - A 9 - 0)
Alt+Shift+向上键或 Alt+Shift+向左键
将选定部分向上或向左移动
Alt+Shift+向下键或 Alt+Shift+向右键
将选定部分向下或向右移动

显示 用于添加字段和汇总，以及更改数据透视表列表的布局的快捷键

显示 处理字段列表的快捷键

Ctrl+L
显示字段列表，或者，如果已经显示了字段列表，则激活字段列表
箭头键
移动到字段列表的下一项
Shift+向上键
移动到上一项并将其包括在选定区域中
Shift+向下键
移动到下一项并将其包括在选定区域中
Ctrl+向上键
移动到上一项，但不将其包括在选定区域中
Ctrl+ 向下键
移动到下一项，但并不将其包括在选定区域中
Ctrl+空格键
如果选定区域中的项有焦点，则将其从选定区域中删除，反之亦然
加号（数字键盘）
展开字段列表中的当前项以显示其内容。或者，展开“汇总”以显示可用的汇总字段
减号（数字键盘）
折叠字段列表中的当前项以隐藏其内容。或者，折叠“汇总”以隐藏可用的汇总字段
Tab
在字段列表中最近选定的项、“添加到”按钮及其旁边的列表之间切换。
Alt+向下键
打开字段列表中“添加到”按钮旁的下拉列表。使用箭头键可移动到列表中的下一项，然后按 Enter 可选定该项
Enter
将字段列表中突出显示的字段添加到“添加到”列表中显示的数据透视表列表内的区域中
Alt+F4
关闭字段列表

显示 添加字段和汇总的快捷键

Ctrl+Shift+S
使用“求和”汇总函数为数据透视表列表中选定的字段添加新的汇总字段
Ctrl+Shift+C
使用“计数”汇总函数为数据透视表列表中选定的字段添加新的汇总字段
Ctrl+Shift+M
使用“最小值”汇总函数为数据透视表列表中选定的字段添加新的汇总字段
Ctrl+Shift+X
使用“最大值”汇总函数为数据透视表列表中选定的字段添加新的汇总字段
CTRL+Shift+E
使用“平均值”汇总函数为数据透视表列表中选定的字段添加新的汇总字段
CTRL+Shift+D
使用“标准偏差”汇总函数为数据透视表列表中选定的字段添加新的汇总字段
CTRL+Shift+T
使用“总体标准偏差”汇总函数为数据透视表列表中选定的字段添加新的汇总字段
CTRL+Shift+V
使用“方差”汇总函数为数据透视表列表中选定的字段添加新的汇总字段
CTRL+Shift+R
使用“总体方差”汇总函数为数据透视表列表中选定的字段添加新的汇总字段
Ctrl+Shift+B
打开或关闭数据透视表列表中选定字段的分类汇总和总计
Ctrl+F
添加计算明细数据字段

显示 更改布局的快捷键

注释 以下四个快捷键当按下键盘的数字键盘上的 1、2、3 或 4 键时不起作用

Ctrl+1
将数据透视表列表中的选定字段移动到行区域中
Ctrl+2
将数据透视表列表中的选定字段移动到列区域中
Ctrl+3
将数据透视表列表中的选定字段移动到筛选区域中
Ctrl+4
将数据透视表列表中的选定字段移动到明细数据区域中
Ctrl+向左键
将数据透视表列表中选定的行或列字段移动到较高级别
Ctrl+向右键
将数据透视表列表中选定的行或列字段移动到较低级别

显示 用于设置数据透视表列表格式的快捷键

若要使用以下快捷键，首先请选定汇总字段的明细数据字段或数据单元格

下面的前七个键盘快捷键可用于更改选中字段的数字格式

Ctrl+Shift+~（波形符）
将常规数字格式应用于选定的汇总字段或明细数据字段中的值
Ctrl+Shift+$
将货币格式（两位小数位，负数用圆括号括起）应用于选定的汇总字段或明细数据字段中的值
Ctrl+Shift+%
将百分比格式（没有小数位）应用于选定的汇总字段或明细数据字段中的值
Ctrl+Shift+^
将指数格式（两位小数位）应用于选定的汇总字段或明细数据字段中的值
Ctrl+Shift+#
将日期格式（日、月和年）应用于选定的汇总字段或明细数据字段中的值
Ctrl+Shift+@
将时间格式（小时、分钟以及 AM 或 PM）应用于选定的汇总字段或明细数据字段中的值
Ctrl+Shift+!
将数字格式（两位小数位，千位分隔符，用减号表示负值）应用于选定的汇总字段或明细数据字段中的值
Ctrl+B
加粗数据透视表列表中选中字段的文本
Ctrl+U
为数据透视表列表中选中字段的文本添加下划线
Ctrl+I
将数据透视表列表中选中字段的文本设置为倾斜

显示 用于下列超链接的快捷键

若要使用快捷键，首先应选定有超链接的单元格或数据项。

Enter
跟随超链接
Shift+Enter
在新窗口中打开链接

显示 用于添加、编辑或删除数据的快捷键

F2
输入编辑模式
Tab
接受编辑，向右移动焦点，然后再将其向下移动
Enter
接受编辑，向下移动焦点，然后再将其向右移动
Shift+Tab
接受编辑、向左移动焦点，然后再将其向上移动
Shift+Enter
接受编辑、向上移动焦点，然后再将其向左移动
Esc
放弃编辑
Delete
删除所有选定的行

显示 “帮助”中使用的快捷键

显示 “帮助”窗口中使用的快捷键

F6
在导航窗格和主题窗格之间切换
Alt+O
显示“选项”菜单以访问任意“帮助”工具栏命令
Alt+空格键
显示程序的“控制”菜单
Alt+F4
关闭“帮助”窗口

显示 导航窗格中使用的快捷键

Ctrl+Tab
切换到其他选项卡
Enter
打开或关闭选定的书，或打开选定的“帮助”主题
向下键
选择下一本书或下一个“帮助”主题
向上键
选择上一本书或上一个“帮助”主题
Shift+F10
显示快捷菜单

显示 主题窗格中使用的快捷键

Alt+向右键
前往以前查看的“帮助”主题
Alt+向左键
返回以前查看的“帮助”主题
Tab
选取下一个隐藏的文本或超链接，或主题顶部的“全部显示”或“全部隐藏”
Shift+Tab
选取以前隐藏的文本或超链接
Enter
执行选定的“全部显示”、“全部隐藏”、隐藏文本或超链接中的操作
向上键或向下键
向“帮助”主题的开始或结束方向滚动
Page Up 或 Page Down
以较大的步长向“帮助”主题的开始或结束方向滚动
Home 或 End
前往“帮助”主题的开始或结束部分
Ctrl+P
打印当前“帮助”主题
Ctrl+A
选定整个“帮助”主题
Ctrl+C
将选定内容复制到剪贴板
Shift+F10
显示快捷菜单


关于工具栏、字段列表和“命令和选项”对话框

显示 数据透视表列表工具栏

数据透视表列表中的工具栏显示在列表的顶部，并且提供一组命令，可用来处理数据透视表列表中的数据。将鼠标指针停留在工具栏的每个按钮上，将显示该命令按钮的名称。

如果看不到工具栏，则可能是已被数据透视表列表的设计者禁用。

显示 数据透视表列表的字段列表

使用字段列表可查看源数据中可用的字段集和字段，并将字段添加到数据透视表列表中的行、列、筛选、数据或明细数据区域中。可以滚动并单击字段集旁的展开指示器（ 加号框 或 减号框 框）来显示或隐藏字段。在字段列表中，没有加粗的字段是可用的，但还未在数据透视表列表中显示。而加粗的字段则已经显示在数据透视表列表中。

如果数据透视表列表的设计者禁用了字段列表，则可能无法显示字段列表。

显示 “命令和选项”对话框

使用此对话框可完成常规任务，例如，筛选数据、设置文本格式以及显示或隐藏元素。“命令和选项”对话框包含一些工具栏或快捷菜单中没有显示的命令。根据选择的数据透视表列表中的各个部分，对话框中显示的选项卡将做相应的更改。如果选择的是网页上的某个控件，而不是数据透视表列表或其他 Microsoft Office Web Component，则对话框将隐藏，并直到再次激活该组件时才会重新显示。

如果数据透视表列表的设计者禁用了“命令和选项”对话框，则可能无法显示该对话框。


显示或隐藏数据透视表列表的工具栏

  1. 右键单击数据透视表列表，再单击“命令和选项”。
  2. 单击“特性”选项卡。
  3. 选中或清除“工具栏”复选框。


显示或隐藏数据透视表列表的标题栏

  1. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“特性”选项卡。
  2. 选中或清除“标题栏”复选框。

注释 若要显示标题栏，必须首先向数据透视表列表中添加数据。


显示或隐藏数据透视表列表的字段列表

  • 如果数据透视表列表工具栏已经显示，请单击工具栏上的“字段列表” 按钮图像 。否则，请右键单击数据透视表列表，再单击快捷菜单上的“字段列表”。


显示或隐藏“命令和选项”对话框

请执行下列操作之一：

  • 如果显示了数据透视表列表工具栏，请单击工具栏上的“命令和选项” 按钮图像 。
  • 如果隐藏了工具栏，请右键单击数据透视表列表，再单击“命令和选项”。

注释 如果在选择数据透视表列表的不同部分或其他 Microsoft Office Web Components 时，使“命令和选项”对话框处于显示状态，则可用的部分及其内容将随当前选定的内容而更改。如果选择了网页的一部分而不是 Office Web 组件，则将隐藏对话框。


显示或隐藏拖放区域

当隐藏了拖放区域且数据透视表列表的行、列、数据或筛选区域没有字段时，就不能将字段拖动到这些区域中。

  1. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“特性”选项卡。

  2. 选中或清除“拖放区域”复选框。

注释 如果数据透视表列表没有绑定到数据源上，则无法看到拖放区域。


关于添加和删除字段

根据数据透视表列表的创建者对数据设置方式的不同，用户可以显示附加数据或删除不需要查看或汇总的数据。

数据透视表列表的创建者将决定提供数据的数据库，并决定该数据库中作为数据透视表列表源数据的可用数据子集。从该源数据中，创建者将选择最初在数据透视表列表中显示的字段，并决定数据的汇总方式。

不能更改可用的源数据，但如果源数据中的可用字段当前并没有显示在数据透视表列表中，则可以添加这些字段来显示附加数据。

例如，如果数据透视表列表将汇总销售收入，而源数据也包括每种产品的销售数量，则可将“销售数量”字段作为数据字段添加，以汇总已销售的产品的收入和数量。如果数据透视表列表根据产品类型和销售人员来汇总产品，并且还可以使用“地区”字段，则可以添加该字段，以便按地区查看销售情况。如果将“地区”字段作为筛选字段添加，则可以筛选整个数据透视表列表，使它仅显示应用于所选地区的数据。

显示 查看数据透视表列表的可用字段

使用字段列表可查看源数据中的可用字段集和字段列表，并将字段添加到数据透视表列表的行、列、筛选、数据或明细数据区域中。在字段列表中，没有加粗的字段是可用的，但还未在数据透视表列表中显示。而加粗的字段则已经显示在数据透视表列表中。可以滚动和单击字段集旁边的展开指示器（ 加号框 或 减号框 框）来显示或隐藏字段列表中的字段。

显示 向明细数据区域添加字段

使用明细数据字段可显示所有可用的明细数据并查看可用于汇总的数据。在向明细数据区域中添加字段时，将显示源数据中该字段的所有明细数据记录。字段名将成为列标志，明细数据记录将显示在列标志下的行中。

标注 1 明细数据字段

标注 2 明细数据

如果数据透视表列表不是基于 OLAP 数据库的源数据，则可添加一个用表达式计算明细数据值的计算明细数据字段。

显示 向行或列区域添加字段

使用行和列字段可汇总并比较数据。这些字段按行列显示了字段中数据的唯一项。每一行和列相交处的单元格对数据项的数据进行了汇总。

标注 1 列字段

标注 2 列字段项

标注 3 行字段

标注 4 行字段项

显示 向数据区域添加字段

数据字段提供在数据透视表列表中要进行汇总的值。在向数据区域中添加字段时，将对行和列字段项汇总字段的值。

标注 1 数据字段

标注 2 汇总数据

显示 向筛选区域添加字段

筛选字段类似于 Microsoft Excel 数据透视表中的页字段。使用筛选字段可使视图仅显示可用数据的特定部分。当选择筛选字段中的某个数据项时，将仅显示和计算该项的数据。例如，如果添加了“地区”筛选字段，则可让数据透视表列表只显示和计算所选地区的数据。

标注 1 筛选字段

标注 2 筛选字段项

标注 3 所选地区汇总

显示 添加汇总字段

通过向数据透视表列表中添加汇总字段，可创建新的数据字段。汇总字段提供了可用作数据字段的汇总数据。例如，如果源数据包括显示每次销售额的“销售额”字段，则可以添加“求和项：销售额”汇总字段来计算全部销售额，或添加“计数项：销售额”汇总字段来计算销售数量。

还可以添加一个用表达式计算汇总值的计算汇总字段。

显示 删除字段

如果要清除不想查看或汇总的数据，则可从数据透视表列表版式中删除字段。删除字段时并不会将其从可用源数据中删除。所删除的字段将不再显示在数据透视表列表中，但仍然可在字段列表中查看。

显示 移动字段

在将字段添加到数据透视表列表中后，可将其移动到其他区域中。在移动字段时，会更改数据透视表列表的版式，并会更改所显示的数据和计算得到的汇总。

显示 添加和删除字段对筛选的影响

当删除字段时，将保留筛选设置。如果删除某字段，稍后又将该字段重新添加到数据透视表列表的版式中，则相同的项将再次隐藏。

显示 查看有关字段的信息

可以在数据透视表列表中查看有关字段的信息，包括有关用于提取数据的源数据库字段的信息和源数据库为字段所提供的数据类型的信息。

显示 对添加和删除字段的限制

如果数据透视表列表设计者设置了在浏览器中添加和删除字段的限制，就不能添加和删除字段。如果数据透视表列表基于的是 OLAP 数据库（例如使用 Microsoft SQL Server OLAP Services 创建的数据库）中的源数据，则会发现不能将字段添加到明细数据区域中。还将发现某些字段只能添加到行、列和筛选区域中。在字段列表的“汇总”下列出的其他字段只可用作数据字段。


添加或删除字段

显示 添加字段

显示 将字段添加到行、列、数据、筛选或明细数据区域中

  1. 在数据透视表列表工具栏上，单击“字段列表” 按钮图像 。

  2. 使用滚动条和展开指示器（ 加号框 和 减号框 框）查找要添加到数据透视表列表中的字段。

  3. 单击字段，并在字段列表的右下角选取要添加该字段的区域。

  4. 单击“添加到”。

注释

  • 如果在选择“行区域”、“列区域”、“数据区域”或“筛选区域”选项时“添加到”不可用，则可能是选取的字段无法用作行、列、数据或筛选字段。如果数据透视表列表基于 OLAP 数据库中的源数据，则只有未列在字段列表中“汇总”之下的字段才能用作行或列字段。

  • 如果选择“明细数据”选项时“添加到”不可用，则可能是由于源数据的明细数据不可用。例如，如果数据透视表列表是基于 OLAP 数据库中的源数据，则一般只能使用汇总数据，而不能使用明细数据。

显示 添加汇总字段

可以将汇总字段添加到数据区域，但是不能添加到行、列、明细数据或筛选区域。

  1. 单击包含要汇总数值的字段。

  2. 在数据透视表列表工具栏上，单击“自动计算” 按钮图像 ，再单击所需的汇总函数。

注释 当不能向数据透视表列表的源数据添加汇总字段时，“自动计算”按钮将不可用。例如，当源数据来自 OLAP 数据库时。

显示 添加计算汇总或明细字段

可将使用表达式的汇总或明细数据字段添加到计算数据中。

  1. 在数据透视表列表工具栏上，单击“计算汇总和字段” 按钮图像 。

  2. 在出现的菜单上，请执行下列操作之一：

    • 若要创建汇总字段，请单击“创建计算汇总”。

    • 若要创建明细数据字段，单击“创建计算明细字段”。

  3. 在“命令和选项”对话框的“计算”选项卡中，为字段指定名称。该名称必须在字段集中是唯一的，并且包含以下字符：字母、数字、空格和圆括号。明细字段的名称不能超过 24 个字符，汇总字段的名称不能超过 50 个字符。

  4. 在“名称”框下面的框中键入表达式，然后单击“更改”。

    显示 提示

    若要添加字段引用，请从“插入引用到”框中选取所需字段，然后单击“插入引用到”按钮。

注释

  • 若要编辑计算字段中正在使用的表达式，请选择该字段，编辑该表达式，再单击“命令和选项”对话框中“计算”选项卡上的“更改”。字段值将使用新的表达式自动重新计算。

  • 默认情况下，汇总数字数据的数据字段使用“求和”汇总函数。汇总其他类型数据的字段使用“计数”汇总函数。

显示 删除字段

将字段从数据透视表列表的版式中删除后，字段的数据将不再显示，但仍可在字段列表中查看该字段。

  1. 单击要从数据透视表列表中删除的字段的字段标志。
  2. 将字段拖到数据透视表列表之外，直至指针变为 红 X 指针 。

注释 通过右键单击字段，再单击快捷菜单上的“删除”，可同时从数据透视表列表和字段列表中删除汇总字段和计算明细数据字段。


关于更改数据透视表列表的版式

可通过更改数据透视表列表的版式来更改数据透视表列表中数据的汇总方式。通过使用不同的版式，可以计算和比较数据中不同元素的汇总值，或显示数据子集的汇总。

显示 使用拖放区域

通过将字段移动到数据透视表列表内的预定义拖放区域中，用户可以更改版式。

标注 1 拖放区域

标注 2 明细数据区域

当您将字段移动到拖放区域中覆盖了拖放区域标题后，还可将其他字段拖动到该区域中。也可使用字段列表中的“添加到”按钮向不同的拖放区域添加字段。

显示 将字段移动到行和列区域中

如果将字段移动到行区域中，则该字段内的唯一数据项将沿数据透视表列表的行显示。如果将字段移动到列区域中，则唯一数据项将跨列显示。

显示 将字段移动到明细数据区域中

若要查看数据透视表列表源数据的所有明细数据记录，可以将字段移动到明细数据区域中。如果不需要重新排列字段或更改汇总数据，则可以在汇总数据旁查看明细数据。

显示 将字段移动到数据区域中

数据字段提供了在数据透视表列表中进行汇总的值。当将一个字段移动到数据区域中时，将对行和列字段项汇总字段的值。

显示 将字段移动到筛选区域中

筛选字段类似于 Microsoft Excel 数据透视表中的页字段。筛选字段可使视图只显示可用数据的特定部分。例如，如果将“产品”字段移到筛选区域，则可以让数据透视表列表每次只显示一种产品的汇总。

显示 将行或列字段移动到较高或较低级别中

如果数据透视表列表中有多个行字段和列字段，则最靠近汇总数据的字段就是内部字段。其他字段为外部字段。

标注 1 外部行字段

标注 2 内部行字段

标注 3 外部字段项

标注 4 内部字段项对外部字段的每一项进行重复。

显示 添加和删除字段

数据透视表列表的版式无须包括源数据中的所有可用字段。如果还有其他可用数据，则可以向数据透视表列表版式中添加字段。例如，如果数据透视表列表汇总了销售收入，并且源数据还包括销售数量，则可以将“销售数量”字段作为数据字段添加到版式中，以便同时汇总所销售产品的数量和收入。还可以删除数据透视表列表版式中不再需要查看的字段。


移动字段或列

  1. 显示数据透视表列表的拖放区域。

    显示 操作方法

    当隐藏了拖放区域且数据透视表列表的行、列、数据或筛选区域没有字段时，就不能将字段拖动到这些区域中。

    1. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“特性”选项卡。

    2. 选中或清除“拖放区域”复选框。

    注释 如果数据透视表列表没有绑定到数据源上，则无法看到拖放区域。

  2. 请执行下列一项或多项操作：

    显示 将字段移至行或列区域

    1. 将鼠标指针指向要移动的字段标志，直到指针变为 十字箭头指针 。
    2. 请执行下列操作之一：

      • 若要使字段成为行字段，请单击并将字段标志拖到数据透视表列表左边的行区域，直至指针变为 突出显示行区域指针 。

      • 若要使字段成为列字段，请单击并将字段标志拖到靠近数据透视表列表顶部的列区域，直至指针变为 突出显示列区域指针 。

    显示 将字段移至明细数据区域

    1. 将鼠标指针指向要移动的字段标志，直至指针变为 十字箭头指针 。

    2. 单击并将字段拖到视图右下角的明细数据区域，直至指针变为 突出显示明细区域指针 。

    显示 将字段移至数据区域

    只有当数据透视表列表是基于非 OLAP 数据库中的源数据时，才可以将字段从行、列和筛选区域移动到数据区域。

    1. 将鼠标指针指向要移动的字段标志，直至指针变为 十字箭头指针 。
    2. 单击并将字段拖到数据透视表列表右下角的数据区域，直至指针变为 求和符号指针 。

    注释 拖至数据区域中的字段的汇总方法取决于字段中的数据类型。包含数字数据的字段将使用 Sum 汇总函数进行汇总，而包含其他类型数据的字段将使用 Count 汇总函数进行汇总。可更改某些字段的汇总函数。

    显示 将字段移至筛选区域

    1. 将鼠标指针指向要移动的字段标志，直至指针变为 十字箭头指针 。
    2. 单击并将字段拖到数据透视表列表顶部的筛选区域，直至指针变为 突出显示筛选区域指针 。

    显示 将行或列字段移至较高或较低级别（更改字段的列次序）

    1. 将鼠标指针指向要移动的字段标志，直至指针变为 十字箭头指针 。
    2. 请执行下列操作之一：

      • 若要将字段移至较高级别，请单击并将字段标志拖到左边，然后放置在所需的位置。

      • 若要将字段移至较低级别，请单击并将字段标志拖到右边，然后放置在所需的位置。


设置数据透视表列表及其元素的大小

显示 自动调整网页上控件的大小以容纳其内容

  1. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“特性”选项卡。
  2. 选中“自动调整控件”复选框。

  3. 为防止数据透视表列表扩展时超过某个指定的大小，则请在“最大高度”框和/或“最大宽度”框中键入所需的值（单位：像素）。

注释 如果可用数据较多而超过可容纳的区域后，在数据透视表列表中将出现滚动条。

显示 更改行、列、明细数据或数据区域的列宽

  1. 将鼠标指针指向字段标志的右边界，直至指针变为 垂直双箭头指针 。
  2. 请执行下列操作之一：

    • 若要增加或减小列宽，请拖动边界直至得到满意的列宽。

    • 若要使列宽能够容纳内容，请双击列边界。

注释 在数据透视表列表中，无法调整行高。


关于在数据透视表列表中显示汇总

数据透视表列表使用两种不同类型的汇总来显示汇总值。第一种类型是汇总字段，它为数据透视表列表提供了汇总值。当数据透视表列表中已包含汇总字段时，还可以显示第二种类型，即行和列字段的分类汇总和总计。

显示 汇总字段

汇总字段是由源数据提供或由用户创建的用于汇总源数据中其他字段的数据字段。例如，如果源数据中含有记录每次销售额数量的“销售额”字段，则可以利用“求和项：销售额”汇总字段在数据透视表列表中对每种分类的销售金额进行求和，或利用“计数项：销售额”汇总字段计算每种分类的销售次数。也可创建使用表达式的汇总字段。

在字段列表中，汇总字段显示在顶部，且位于“汇总”之下。“求和项：销售额”和“计数项：单位数量”字段可在数据透视表列表中用作汇总字段。

显示 添加汇总字段

在某些数据透视表列表中，汇总字段值可能会在提供源数据的数据库服务器上预先计算得到。在这种情况下，则不能新增汇总字段，不能将汇总字段移至明细数据区域，也不能更改汇总字段上用于计算数值的汇总函数。若要了解所查看的数据透视表列表中使用了何种类型的源数据，请咨询数据透视表列表的设计者。

如果字段列表中的汇总字段没有提供所需的汇总，则在源数据允许的情况下，可以向数据透视表列表中新增汇总字段。大多数情况下，可以向数据区域中添加汇总字段。例如，在下面的数据透视表列表中，“求和项：销售额”汇总字段将添加到数据区域中，以便显示每种运动和每个季度的汇总数据。

标注 1 “求和项：销售额”汇总字段

汇总字段可使用汇总函数（例如：“求和”或“计数”）。根据源数据的类型，还可以通过添加多个汇总字段以便对同一字段使用多个汇总函数来汇总其数据（每个汇总字段使用不同的汇总函数）。

还可以添加使用表达式来计算的汇总字段。例如，若要查看年-日期的销售额，可创建使用下面表达式的汇总字段：

Sum (YTD(), [Measures].[Sales])

下面的数据透视表列表显示销售额以及年-日期销售额。

显示 更改汇总字段的方向

在数据透视表列表中，可以更改汇总字段的方向。如果按行方向显示汇总字段，则这些字段会显示在行字段右边的第一列下。如果按列方向显示汇总字段，则这些字段会显示在列字段下的第一行中。

显示 按百分比形式显示汇总值

还可以将汇总值显示为一行、一列或总计的百分比，或显示为行或列坐标轴中数据项的父级数据项的汇总。

标注 1 如果选择以行汇总的百分比形式显示汇总值，将使用这些数值。

标注 2 如果选择以列汇总的百分比形式显示汇总值，将使用这些数值。

标注 3 如果选择以行坐标轴中数据项的父级数据项的汇总值的百分比形式显示汇总值，将使用这些数值。

标注 4 如果选择以总计的百分比来显示汇总值，将会使用这些数值。

显示 分类汇总和总计

如果数据透视表列表中包含至少一个汇总字段和多个行或列字段，则可以在数据透视表列表中显示任意行或列字段的分类汇总。如果选择显示字段的分类汇总，则同时也会显示字段的总计。而且，在数据透视表列表中选定行字段或列字段相交的位置上，将显示每个汇总字段的分类汇总和总计。

在下例中，将利用“求和项：销售额”汇总字段中的值显示上述两个行字段的分类汇总和总计。

标注 1 总计

标注 2 分类汇总

在上面的示例中，如果显示了“运动”和“季度”字段的分类汇总和总计，则数据透视表列表中将包括“季度”字段的分类汇总和“运动”字段的总计。

如果将显示了分类汇总或总计的字段移到行或列区域之外，分类汇总或汇总字段将会隐藏，但该设置将会保留。如果将字段移回到行或列区域中，则会重新显示分类汇总或总计。

如果隐藏字段的分类汇总和总计，那么无论如何移动字段，这些字段都会保持隐藏状态，甚至将字段从数据透视表列表中删除，稍后再重新添加该字段也不能消除其隐藏状态。

根据在数据透视表列表中查看的源数据和数据类型的不同，可能需要让分类汇总和总计包含或省略通过筛选隐藏的数据项的值。可以指定所有分类汇总和总计包含或排除任何隐藏数据。


数据透视表列表中可用的汇总函数

下表列出了“自动计算” 按钮图像 命令提供的汇总函数，该命令可用来创建汇总字段。

函数 | 说明
求和 | 计算数值的和。
计数 | 统计值的个数。空值如空字符串（即不包含字符的字符串）包含在计数中，但 null 值（代表丢失或未知数据的值）不包含在内。
最小值 | 返回进行汇总的字段中的最小值。
最大值 | 返回进行汇总的字段中的最大值。
平均值 | 返回进行汇总的字段中的平均值。
标准偏差 | 返回进行汇总的字段中值的标准偏差，假设值是一个较大总体的某个样本。
总体标准偏差 | 返回进行汇总的字段中值的标准偏差，假设值是整个总体。
方差 | 返回进行汇总的字段中值的方差，假设值是一个较大总体的某个样本。
总体方差 | 返回进行汇总的字段中值的方差，假设值是整个总体。

注释 可用于字段的汇总函数取决于字段中的数据类型。例如，如果字段包含文本，就不能使用“求和”、“最小值”或“最大值”，但可以为该字段使用“计数”。


显示或隐藏字段的汇总

  1. 单击要显示或隐藏分类汇总和总计的行字段或列字段。
  2. 若要显示汇总，请在数据透视表列表工具栏上，单击“分类汇总”按钮 按钮图像 以使其被选中。若要隐藏汇总，请再次单击该按钮。

注释

  • 不会为明细数据区域（显示所有单个记录的区域）中的字段显示分类汇总和总计。
  • 如果选择显示分类汇总和总计，则将在数据透视表列表中的每个汇总字段上显示分类汇总和总计。不能排除个别的汇总字段。
  • 分类汇总和总计的计算中可以包含或排除由筛选所隐藏的数据项。


自定义汇总字段

显示 更改汇总字段的方向

本过程影响数据透视表列表中的汇总字段。但不影响分类汇总或总计。

  1. 单击数据透视表列表的标题栏。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“报表”选项卡。
  3. 在“汇总显示为”之下，选取以下选项之一：
    • 列标题 可将汇总字段显示在列字段下方的第一行上，或者，如果没有列字段，则显示在顶行中。
    • 行标题 可将汇总字段显示在行字段右边的第一列上，或者，如果没有行字段，则显示在最左边的列中。

显示 以百分比形式显示汇总

  • 右键单击其值要以百分比形式显示的汇总字段，接着指向“显示形式”，然后单击以下选项之一：
    • 行汇总的百分比 可将值显示为各行汇总值的百分比。
    • 列汇总的百分比 可将值显示为各列汇总值的百分比。
    • 父行汇总的百分比 可将值显示为行坐标轴上项目的父级项目的汇总值的百分比。
    • 父列汇总的百分比 可将值显示为列坐标轴上项目的父级项目的汇总值的百分比。
    • 全部汇总百分比 可将值显示为数据透视表列表总计值的百分比。


计算汇总时包含或排除隐藏数据

本过程会影响数据透视表列表中的所有分类汇总和总计。

  1. 单击数据透视表列表的标题栏。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“报表”选项卡。
  3. 在“汇总计算基于”下，请执行下列操作之一：
    • 若要包含隐藏数据，请选择“所有项目（包括隐藏项目）”。

    • 若要排除隐藏数据，请选择“仅可见项目”。

注释

  • 该设置将影响通过筛选行和列字段所隐藏的数据；通过使用筛选字段所隐藏的数据将排除在汇总以外。

  • 当您选择包含隐藏数据时，星号 (*) 会显示在分类汇总和总计标题的旁边，以提示您汇总值既包含了显示的项也包含了隐藏的项。


编辑计算字段

  1. 选择要编辑其表达式的计算字段。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“特性”选项卡。
  3. 编辑表达式，再单击“更改”。

    数据的值将用新表达式自动进行重新计算。

显示 提示

若要添加字段引用，从“插入引用到”下拉框中选择要使用的字段，再单击“插入引用到”按钮。


关于超链接

超链接是从一个对象到另一个对象的指针。链接目的地经常是另一个网页，但也可以是一幅图片、一个电子邮件地址、一个文件（例如多媒体文件或 Microsoft Office 文档）或一个程序。超链接本身显示为文本或一幅图片。

可用超链接执行下列操作：

  • 定位到网络、Intranet 或 Internet 上的文件或网页

  • 发送电子邮件

  • 启动文件传输，如下载或执行 FTP 过程

当指向含有超链接的文本或图片时，鼠标的指针将变成一个手的形状 手形指针 ，这表明您可以单击该文本或图片。单击超链接时，链接目标是显示、打开或运行将取决于其自身的类型。例如，一个指向声音文件的超链接将在媒体播放机中打开文件，一个指向网页的超链接将在 Web 浏览器中显示页。

显示 超链接地址的组成部分

一个超链接地址最多具有四个组成部分，它们由数字符号 (#) 分隔：

组成部分 | 说明
显示文本 | 当选择以超链接显示数据时在单元格中看到的文本。例如，可能需要显示万维网站点或由地址和子地址指定的对象的描述性名称。这是一个可选字段。
地址 | 到目标文档的绝对或相对路径。绝对路径是指向文档的完整有效的 URL 或 UNC 路径。 如果未指定地址，则假定显示文本为其地址。
子地址 | 在文件或页面中的位置。例如，可能希望指向目标文档中某一特定段落。
屏幕提示 | 当将指针停留在超链接上时出现的文本。这是一个可选字段。

显示 以超链接显示数据

可通过更改字段的属性设置来选择在行、列或明细数据字段中以超链接显示数据。当以超链接显示数据时，可单击超链接以定位到其他的网页或对象上。

显示 在包含超链接的字段上进行分组

在超链接字段上进行分组的结果取决于相应的源数据字段的定义方式。如果源数据字段是一个“字符式大型对象”(CLOB)，当在超链接上进行分组时将会看到两个组成员：一个针对空白值，一个针对非空白值。如果源数据字段被定义为标量，如变长字符型，则将在单个超链接值上对值进行分组。成员的唯一性是基于超链接的显示文本和地址部分。


将数据显示为超链接

  1. 单击包含超链接的行、列或明细数据字段。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“格式”选项卡。
  3. 选中“显示为超链接”复选框。


显示或隐藏“屏幕提示”

  1. 单击标题栏。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“报表”选项卡。
  3. 选中或清除“屏幕提示”复选框。

注释 如果隐藏了“屏幕提示”，就不能看到设置作为“屏幕提示”显示的项目属性。设置在报表中显示的项目属性将仍旧可见。


关于显示明细数据和项目

数据透视表列表的设计者决定了数据透视表列表最初显示的项目的级别和明细数据的数量。可以更改数据透视表列表以显示源数据中任意数量的可用明细数据。可以显示所有的可用明细数据和项目级别，也可以只显示高级别的汇总或之间任意级别的明细数据，还可以为要强调的数据项显示选定的明细数据。

显示 显示明细数据

最低级别的数据项右边会显示 加号框 和 减号框 。列区域中的最低级别数据项标题下会显示 加号框 和 减号框 。可以通过单击 加号框 或 减号框 来显示或隐藏特定项的明细数据。

只有在源数据中可用的，并且数据透视表列表的设计者没有限制在浏览器中对其进行访问的明细数据才可以显示。例如，OLAP 数据库经常只提供汇总数据，而不提供明细数据。

自动显示或隐藏所有明细数据

默认情况下，在浏览器中最初并不显示明细数据。但如果需要，可更改设置以自动显示所有项目的明细数据。

显示 显示低级别的数据项

当行或列区域有多个字段时，高级别项目的左边将显示展开指示器（ 加号框 和 减号框 框）。单击展开指示器可以在下一个较低级别中显示或隐藏数据项。如果数据透视表列表最里边的字段不是数据项层次中的最低级别，单击最里边字段的展开指示器将自动在数据透视表列表中添加下一个较低级别的项目。

可以显示整个字段较低级别的数据，或者也可以逐项显示数据，这样就仅展开需要查看的项。最低级别的项不显示展开指示器。例如，如果“国家/地区”和“城市”字段在行区域里，“国家/地区”字段的项将显示如下展开指示器：

标注 1 展开指示器

自动显示或隐藏所有项

在加载了数据透视表列表后，可以更改设置，以便在默认情况下可以展开或折叠所有的项。

隐藏展开指示器

在已经展开到所需的级别后，可隐藏数据透视表列表中的所有展开指示器。

显示或隐藏没有数据的项

默认情况下，数据透视表列表不显示在源数据中没有提供值的数据项。例如，如果正显示每个月的销售额，而四月份没有销售额，则“月”字段中将不包含“四月”项。如果要包含全部十二个月份的项，并将没有销售额的月份显示为空白单元格，则可以显示没有数据的项。


显示或隐藏项旁边的展开指示器

  1. 单击数据透视表列表的标题栏。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“特性”选项卡。
  3. 选中或清除“展开指示器”复选框。

注释

  • 该设置不影响显示在最低级别项右边的 加号框 和 减号框 框。
  • 行或列区域中最低级别项的左边没有展开指示器。


显示或隐藏项或字段的明细数据

  1. 请执行下列操作之一：

    • 若要显示或隐藏最低级别单元格或项的明细数据，请选择项或单元格。

    • 若要显示或隐藏行或列字段的明细数据，请选择行或列字段。
  2. 单击数据透视表列表工具栏上的“显示明细数据” 按钮图像 或“隐藏明细数据” 按钮图像 。

注释 若要显示较低级别的项，请选择行字段、列字段或项，再单击工具栏上的“展开” 按钮图像 或“折叠” 按钮图像 。


显示或隐藏项目

  • 若要显示或隐藏行或列坐标轴中特定项目的低级项目，请单击项目旁的展开指示器（ 加号框 或 减号框 框）。
  • 若要显示或隐藏行或列字段中所有项目的低级项目，请单击字段标志，再单击数据透视表列表工具栏上的“展开” 按钮图像 或“折叠” 按钮图像 。

注释

  • 如果在某项目旁看不见 加号框 或 减号框 框，请选中“命令和选项”对话框的“特性”选项卡上的“展开指示器”复选框。如果选中复选框后还看不见项目旁的展开指示器，则该项目可能位于可用于源数据的最低级别上。

  • 若要显示或隐藏明细数据，请选择项目或字段，再单击工具栏上的“显示明细数据” 按钮图像 或 “隐藏明细数据” 按钮图像 。


显示或隐藏没有数据的项

  1. 单击数据透视表列表的标题栏。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“报表”选项卡。
  3. 选中或清除“空行”和“空列”复选框。


自动显示所有明细数据

  1. 单击数据透视表列表的标题栏。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“特性”选项卡。
  3. 将“默认展开明细数据”设置为“始终”。

注释

  • 若要隐藏所有项目的明细数据，请在“默认展开明细数据”列表中选择“从不”。若将“默认展开明细数据”设置为“自动”，则来自表格源的数据将按默认方式展开，但来自 OLAP 数据库的数据将被隐藏。
  • 若要在数据透视表列表中自动显示所有项，在“特性”选项卡上，请将“默认展开项目”设置为“始终”。
  • 如果明细数据不可用，则更改“默认展开明细数据”设置将毫无作用。


自动显示所有项目

  1. 请单击数据透视表列表的标题栏。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“特性”选项卡。
  3. 将“默认展开项目”设置为“始终”。

注释

  • 若要隐藏所有项目，请在“默认展开项目”列表中选择“从不”。如果将“默认展开项目”设置为“自动”，则来自表格源的字段将按默认方式展开，但来自 OLAP 数据库的字段将被隐藏。

  • 若要在数据透视表列表中自动显示所有明细数据，请在“特性”选项卡上，将“默认展开明细数据”设置为“始终”。


添加、编辑或删除数据

如果不能在数据透视表列表中添加、编辑或删除数据，这意味着以下某种情况：

  • 网页的设计者设置了属性以防止添加、编辑或删除数据。
  • 试图进行编辑的字段是一个只读字段，不支持编辑。
  • 基本表没有主键。

显示 添加数据

  1. 在标记有星号 (*) 的空白行中单击某个单元格。
  2. 在第一个字段中键入所需数据，再按 Tab 移到下一个字段。
  3. 请执行下列操作之一：
    • 按 Enter 保存记录并移到下一个记录。
    • 按 Esc 离开记录且不保存该记录。

显示 编辑数据

  1. 单击要编辑的单元格。
  2. 键入新值。
  3. 请执行下列操作之一：
    • 按 Enter 保存记录并移到下一个记录。
    • 按 Esc 离开记录且不保存该记录。

显示 删除数据

  • 请执行下列操作之一：
    • 若要删除一个单元格中的内容，请先单击单元格，再按 Delete。
    • 若要删除一个记录，请先单击该记录最左边的单元格，再按 Delete。
    • 若要删除多个记录，请先单击记录最左边的单元格，并将鼠标指针拖到最后一个记录的最后一个单元格上，再按 Delete。

注释

  • 当向有数字格式的某个字段中输入数据时，不必键入有格式的数据。因为当离开单元格时，格式将自动应用于单元格中的内容。
  • 只有明细数据单元格可直接在数据透视表列表中编辑。若要更改标题，请使用“命令和选项”对话框。


显示或隐藏项目属性

可在报表中显示行和列字段的项目属性或将其作为“屏幕提示”显示。

  1. 单击要显示或隐藏其自定义属性的字段。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“项目属性”选项卡。
  3. 在“项目属性”列表中，选中要更改其设置的属性。
  4. 在“显示于”列表中，选择下列操作之一：
    • 报表 显示项目名称旁的属性标题和值。
    • 屏幕提示 将属性标题和值显示为每个项目的“屏幕提示”部分。
    • 全部显示 既在报表中又在“屏幕提示”中显示属性标题和值。
    • 不显示 隐藏属性标题及其值。
  5. 对选定的字段的每个自定义属性重复步骤 3 和步骤 4。

注释

  • 如果选择将属性作为“屏幕提示”显示，则需保证选中“命令和选项”对话框中的“报表”选项卡上的“屏幕提示”复选框。
  • 可更改自定义属性在报表或“屏幕提示”中的显示次序。
  • 可设置自定义属性的标题和值的格式。所设格式不会影响该属性在“屏幕提示”中的显示。
  • 非 OLAP 数据源不支持自定义属性。


关于项目属性

可通过显示一个行字段或列字段的自定义属性来显示项目的附加信息。例如，如果数据库管理员已经为“商店”字段定义了两个可用的用户属性：“经理”和“电话号码”，则可以选择是在数据透视表列表中还是作为“屏幕提示”来显示“商店”字段中每个项目的属性值。但在浏览器中不能创建自定义属性。

下面的图示显示了“雇员”报表的外观，该报表中显示了自定义属性“教育”和“年收入”。

下面的例子说明在报表中显示的“教育”属性和在“屏幕提示”中显示的“年收入”属性。

用户既可以设置属性的标题和值的格式,也可以指定在报表或“屏幕提示”中属性显示的次序。

非 OLAP 数据源不支持自定义属性。


指定项目属性的显示次序

  1. 单击要对其项目属性排序的字段。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“项目属性”选项卡。

    属性在“项目属性”框中的排列次序就是属性在报表或“屏幕提示”中的显示次序。

  3. 选择要在顶端显示的属性，再单击“向上” 向上箭头 ，直到该属性作为列表第一项出现。
  4. 通过单击“向上” 向上箭头 或“向下” 向下箭头 来给其他属性排序。

注释 在对列表排序后，如果添加了新属性，则新属性将出现在列表的最后，直到用户重新对其进行排序。


关于设置数据透视表列表的格式以改进外观或可读性

显示 设置元素的格式

可按下列方式设置行、列、汇总或明细数据字段的格式，设置标题栏和拖放区域标题的格式，以及设置行或列字段的自定义属性的格式：

  • 设置文本格式 可以设置文本的字体、字体大小和颜色，也可以使字体加粗、加下划线或倾斜。这些设置独立于浏览器中字体和颜色的设置，即浏览器中的设置对数据透视表列表无效。

  • 对齐单元格中的文本 可在单元格中将值显示为左对齐、右对齐或水平居中。但不能更改值的垂直对齐方式。

  • 设置背景色 可更改单元格的背景色。这些设置独立于浏览器中颜色的设置，即浏览器中的设置对数据透视表列表无效。

  • 更改数字格式 可将字段中数字、日期和时间的显示格式更改为任何预定义的数字格式。在 Microsoft Visual Basic 或脚本中，可为数据指定自定义的数字格式。

    例如，可将数字显示为货币或百分比格式，也可按长格式显示日期（包括日和月）或按缩写格式显示日期。对数字格式所做的更改不会改变数值本身，而只会更改数值的显示方式。

应用于某个元素的格式可能会影响其他相似的元素。例如，如果更改某个项目的文本颜色，则同一个字段中的所有其他项目都将使用新的文本颜色。

显示 设置整个数据透视表列表的格式

不能只通过一步操作就设置整个数据透视表列表的格式。必须单独设置数据透视表列表中每一个元素的格式。

若要自定义数据透视表列表中每个元素的外观，则可能需要暂时更改版式，以便设置不希望包含在数据初始显示中的元素的格式。例如，在初始版式并不包含明细数据字段的情况下，如果要为明细数据区域中的字段建立格式，则需要将字段移动到明细数据区域中，并设置其格式，然后将该字段移回原先的区域。如果用户在浏览器中将字段移动到了数据透视表列表的其他区域，则字段及其数据将采用为该区域中的字段和数据所设置的格式。

如果需要更多的格式控制，包括更多的文本对齐选项、自定义数字格式和打印格式选项，请将数据透视表列表导出到 Microsoft Excel 中。在 Excel 中，数据透视表列表将成为数据透视表，用户可以对其设置格式、打印并将其保存在工作簿文件中。有关使用数据透视表的详细信息，请参阅 Excel 的“帮助”。


设置数据透视表列表及其元素的格式

  1. 选择要设置格式的元素。

    显示 操作方法

    显示 选取整个数据透视表列表

    • 如果显示了标题栏，则请单击该标题栏。否则，按 Ctrl+A。

    注释 如果数据透视表列表没有绑定到数据源上，则无法显示标题栏。

    显示 选取一个或多个数据单元格

    • 若要选取单个单元格，请单击该单元格。若要选取一组单元格，请单击并拖动鼠标指针，直至选取了所有要选取的单元格。

    显示 选取行、列或筛选字段

    • 单击字段标志。

    注释 选中行或列字段的同时也将选中该字段中的所有数据项。

    显示 选取明细数据字段

    • 单击字段标志。如果显示了多个项的明细数据，则字段标志将显示多次，单击字段标志的一个实例将选中所有实例。

    显示 选取汇总字段

    • 单击汇总字段的任意字段标志。

    显示 选取一个或多个项

    • 若要选取单个数据项，请单击该数据项的标志。

    • 若要将更多数据项添加到选定区域中，请在单击数据项标志时按住 Ctrl。

    • 若要选取一组连续的数据项，请单击第一个数据项的标志，按住 Shift 并单击最后一个数据项的标志。

    注释 选定某个数据项时也将选定其中的所有数据。

    显示 选取分类汇总或总计

    • 单击分类汇总或总计。

    注释 选定某个分类汇总或总计的同时也将选定分类汇总或总计中的所有数据。

    显示 选取标题栏或拖放区域

    1. 单击标题栏。

    2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“标题”选项卡。

    3. 在“选择标题”列表中，选取所需的项。

    显示 选取行或列字段的自定义属性

    1. 单击行或列字段，或其中一个项目。

    2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“项目属性”选项卡。

    3. 在“项目属性”列表中，选取所需的属性。

      注释 如果选中的字段没有自定义属性，则“项目属性”列表为空。

      可以设置选定属性的标题、数字格式和显示位置。所选格式只影响选定的属性。

    4. 若要设置属性的字体和样式，请选取“格式”列表中的“属性标题”或“属性值”。

    注释 应用于自定义属性的字体和文本样式设置将影响数据透视表列表中的所有自定义属性，但是只有当这些属性显示在报表中时，设置才起作用。当自定义属性显示在屏幕提示中时，该格式将被忽略。

  2. 单击数据透视表列表工具栏上的“命令和选项” 按钮图像 。
  3. 请执行下列操作之一：
    • 若要设置拖放区域的格式，请单击“标题”选项卡。
    • 若要设置行或列字段的项目属性，请单击“项目属性”选项卡。
    • 若要设置数据透视表列表中所有其他元素的格式，请单击“格式”选项卡。
  4. 请执行下列一项或多项操作：

    显示 指定字体和样式设置

    • 若要加粗文本，请单击“加粗” 按钮图像 。

    • 若要使文本显示为斜体，请单击“倾斜” 按钮图像 。

    • 若要给文本加下划线，请单击“下划线” 按钮图像 。

    • 若要更改文本颜色，请单击“字体颜色” 按钮图像 旁的箭头，再单击所需颜色。

    • 若要更改字体，请单击字体列表中的其他字体。

    • 若要更改字体大小，请从字体列表旁的列表中选择字号。

    注释

    • 在列表中可用的字体和字体大小取决于计算机中安装的字体。

    • 不能只通过一步操作设置整个数据透视表列表的字体和文本样式。

    显示 对齐文本

    • 单击所需的对齐方式：“左对齐” 按钮图像 、“居中” 按钮图像 或“右对齐” 按钮图像 。

    注释 不能只通过一步操作来设置整个数据透视表列表的文本对齐方式。不能更改行、列或筛选字段标志的水平对齐方式。

    显示 设置背景色

    • 单击“填充颜色” 按钮图像 旁的箭头，再单击所需的颜色。

    注释 不能只通过一步操作设置整个数据透视表列表的背景色。不能更改拖放区域的背景色。

    显示 更改行或列字段中字段、汇总或项属性的数字格式

    • 在“数字”列表中，单击所需的格式。

    注释 一个字段的数字格式不影响其他行、列、筛选或汇总字段的数字格式。项目属性的数字格式不影响其他项目属性。

注释 不能设置“屏幕提示”的内容格式。因此，应用于项目属性的格式仅应用于当其显示在报表时的属性。


将数据透视表列表中内容的显示格式设置为从右向左或从左向右显示

如果选择了从右到左显示，则数据透视表列表的元素将显示为默认的从左到右显示的镜像图像：拖放区域在数据透视表列表的右上角，行字段位于最右边的列，列字段中的项将从右到左排列。

  1. 单击数据透视表列表的标题栏。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“特性”选项卡。
  3. 选中或清除“从右向左显示”复选框。


数据透视表列表的数字格式

本主题中的部分内容可能不适用于某些语言。

Windows“控制面板”中的区域设置会决定数字、货币、日期和时间格式的显示方式。例如，这些设置将决定年份是按两位数还是四位数显示。请参阅 Windows 的“帮助”以获取有关这些格式的信息。

下表列出了数据透视表列表中支持的数字格式：

格式 | 效果
常规 | 按右对齐方式显示数字，没有千位分隔符，如果为负数，则前面要加负号。 至多显示 11 位数字，如果有小数点，则只显示 10 位数字，并对小数点右边额外的数字进行舍入。如果小数点左边的数字多于 11 位，则使用科学记数法。 按左对齐方式显示文本。
常规日期 | 将数字显示为日期和可选时间。例如，99-8-31 05:54 AM。 数字的小数部分是时间。如果数字没有小数部分，则只显示日期。如果数字只含有小数部分而无整数部分，则只显示时间。
长日期 | 按 Microsoft Windows 区域设置的长日期格式显示日期。例如，星期四 2001 年 1 月 25 日。
中等日期 | 使用缩写月份名称和连字符 (-) 分开显示月、日和年。例如，25-Jan-01。
短日期 | 按 Windows 区域设置的短日期格式显示日期。例如，01-1-25。
长时间 | 按 Windows 区域设置的长时间格式显示时间。例如，8:45:36 PM。
中等时间 | 按 12 小时格式显示时间，使用 AM 或 PM 标志符，但不包含秒。例如，8:45 PM。
短时间 | 按 24 小时格式显示时间，省略秒。例如，20:45。
货币 | 根据 Windows 区域设置的货币显示数字。例如，如果是默认的英语（美国）区域设置，则可能会显示 $2,532.75。
欧洲货币 | 将数字显示为欧洲货币的形式，同时具有千位分隔符和两位小数位。欧元符号和小数位的位置基于 Windows“控制面板”中的货币的区域设置。例如，对于默认的英语（美国）区域设置，显示为 欧元 12.35。
固定 | 显示具有两位小数位的数字。例如，68.30。
标准 | 根据数字在 Windows 区域中的设置来显示数字。例如，以逗号作为千位分隔符，以句号作为小数符号，1,800.00。
百分比 | 显示数字的方法为：数字乘以 100，具有两位小数位和百分比符号。例如，数值 0.8914 将显示为 89.14%。
科学记数 | 按指数方法显示数字。例如，1.25E+10。
是/否 | 如果数字为 0，则显示“No”，其他情况下显示“Yes”。
真/假 | 如果数字为 0，则显示“False”，其他情况下显示“True”。
打开/关闭 | 如果数字为 0，则显示“Off”，其他情况下显示“On”。

注释 在 Microsoft Visual Basic 或脚本中，可以为数据指定自定义数字格式。还可以在“数字”框中键入数据透视表列表对象模式中可用的自定义格式。


关于数据排序

显示 按升序或降序排序

您可按升序排序销售额列，或按降序排序雇员名称列。

还可对数据透视表列表的每列分别进行排序。对列进行排序的顺序决定了数据的组织方法。

在本示例中，清单是按销售人员组织的。首先按“产品”列进行排序，使产品按字母顺序排列；然后对“销售人员”列进行排序。

对多个列进行排序时，首先应确定对列进行排序的顺序，然后向后操作，最后对最外部的列进行排序。例如，如果对两个列进行排序，先确定哪个是外部列，哪个是内部列，然后先对内部列进行排序，再对外部列进行排序。如果要在按字母顺序对每个销售人员排序后再对产品进行排序，则应先对内部的“产品”列进行排序，然后再对外部的“销售人员”列进行排序。

显示 定义自定义排序顺序

当升序或降序排序不符合要求时，您可以定义行或列字段的自定义排序方式。例如，在“头衔”列，您可能想基于头衔资历的顺序显示其值。如果列有三个值：副总统、总经理和经理，则以升序或降序的顺序显示数据将得不到想要的顺序。这种情况下，您可能想明确的定义“头衔”列项的顺序。

如果自定义排序顺序后项添加到了字段中，新的项将会显示在字段的底部，直到您重新对其进行了排列。


对字段中的数据进行排序

显示 按升序或降序排序

您可以将以自然顺序或自定义顺序显示的数据按升序或降序排列。

  1. 请执行下列操作之一：

    • 若要根据项标志对字段中的数据进行排序，请单击包含要排序的数据的字段标志。

    • 若要基于列中的汇总值对字段中的数据进行排序，请单击包含要排序的值的列中的单元格。

    • 若要根据分类汇总或总计值对字段中的数据进行排序，请单击包含要排序的数据的字段中的分类汇总或总计值。

  2. 在数据透视表列表工具栏，请单击“升序” 按钮图像 或“降序” 按钮图像 。

注释 若要对多个字段进行排序，首先对最内部的字段排序并向后操作，最后对最外部的字段排序。

显示 指定自定义排序顺序

  1. 选定要移动的项。
  2. 拖动选定的项并将其放到要放置的项之上。
  3. 重复步骤 1 和步骤 2 直到项按您希望的顺序进行了排列。

注释 如果一个以自定义顺序进行排序的字段有父字段，则每个父字段成员将以自定义顺序显示较低级别的成员。

注释

  • 数字、文本和特殊字符的排序顺序取决于源数据和 Microsoft Windows“控制面板”中的区域设置。
  • 若要从升序或降序排序转换成自定义排序，请单击“升序” 按钮图像 或“降序” 按钮图像 以取消选择该按钮。


删除排序次序

删除升序或降序排序次序后，将按数据的自然次序返回该数据，或者如果指定了一个自定义次序，则按自定义次序返回数据。

  • 单击数据透视表列表工具栏上的“升序”按钮 按钮图像 或“降序”按钮 按钮图像 以取消选择该按钮。


关于项目分组

可用两种方法对行或列字段中的项目进行分组。

显示 按间隔分组

可通过指定间隔的类型和间隔的大小来对项目进行分组。例如，可将具有日期值的字段分组为不同的月份组，指定间隔为 2，可创建出如“一月-二月”和“三月-四月”等分组。

为字段指定的间隔类型取决于字段的数据类型。

  • 数字型字段 可按任意整数（例如，1、2、5 和 100 等等）为间隔进行分组。例如，可将“雇员 ID”字段分组为 1-100 和 101-200 等等。
  • 日期和时间字段 可以日、星期和季度为间隔来进行分组。例如，可将“发货日期”字段中的数据以月为间隔进行分组，以显示一月发货的数据、二月发货的数据等等。
  • 文本字段 可以根据各数据项的前 n 个字符来分组。例如，可以将“姓氏”字段按首字母分组为 A 组和 B 组等等。

可指定分组范围的起始值和结束值。例如，如果在以星期为间隔对“发货日期”字段进行分组时指定起始值为 01-Jul-1999，则将创建以下的分组：

<01-Jul-1999, 01-Jul-1999, 08-Jul-1999, ...

01-Jul-1999 以前的日期则归入标题为“<01-Jul-1999”的单个分组中。

如果还指定 31-Dec-1999 为结束值，则将创建以下的分组：

<01-Jul-1999, 01-Jul-1999, 08-Jul-1999, ... 31-Dec-1999, >31-Dec-1999

31-Dec-1999 以后的日期则归入标题为“>31-Dec-1999”的单个分组中。

显示 自定义分组

可从行或列字段中任意选择项目并将其分组到较高级别的组中。例如，可从“提升”行字段选择在特定时期内所进行的所有的提升并创建一个分组。这会在“提升”行字段上增加一个名为“提升 2”的新行字段，该字段有两个成员：“分组 1”和“其他”。可在“命令和选项”对话框中将“分组 1”的标题更改为“固定”，将“提升 2”的标题更改为“分类”。

“其他”分组包括所有未包含在“固定”自定义分组中的项目。然后可从“其他”分组中选择所有受欢迎的提升来创建一个标题为“受欢迎”的自定义分组。完成以上工作后，“分类”字段将有三个成员：“固定”、“受欢迎”和“其他”。

下面的图示显示了更改自定义字段和分组的标题后数据透视表列表的外观。

标注 1 自定义分组字段。包含作为其项目的自定义分组，并且作为字段（其项目已进行分组）的父级字段出现。

标注 2 自定义分组。作为明确选择用来创建分组的项目的父级项目出现。

标注 3 “其他”分组是没有指定给任何特定的自定义分组项目的父级项目。

显示 创建和删除自定义分组和自定义分组字段

  • 不能将属于不同字段或属于父级项目的项目分组为一个自定义分组。

  • 当为一个字段创建第一个自定义分组时，一个自定义分组字段将自动作为该字段的父级添加。与此类似，删除字段最后一个自定义分组时，将自动删除自定义分组字段。

  • 当删除的字段不是字段中最后一个自定义分组时，所删除的分组成员将自动移到“其他”分组中。

  • 所创建的组将被保留，但只在客户端存在。所以您创建的任何分组都可用于您创建的网页，但却不是源数据的一部分。

显示 将一个自定义分组字段移至明细数据区域

当将一个包含自定义分组字段的字段组移到明细数据区域或筛选区域时，将看不见自定义分组字段。然而，绑定字段将在下拉列表中显示自定义分组层次，所以可通过选择自定义分组或单个值来筛选数据。当将字段集移回行区域或列区域时，在字段组中将显示自定义分组字段。

显示 添加或删除嵌套自定义分组

可选择两个或更多的自定义分组来创建一个较高级别的分组。例如，可将“分类”字段里的成员分成两个组：高优先级提升和低优先级提升。

下面的图示显示了具有嵌套自定义分组的数据列表的外观。

标注 1 作为“分类”自定义分组字段的父级字段出现的自定义分组字段。

也可删除一个较低级别的自定义分组。下面的图示显示了在删除“分类”字段后的数据外观。

注释 如果数据透视表列表设计者不允许在浏览器中进行分组，则不能对项目进行分组。


对项目进行分组或取消分组

显示 按间隔对项目进行分组

  1. 选择要对其项目进行分组的行或列字段。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“筛选和分组”选项卡。
  3. 将“组合项目按”设置为“（没有分组）”之外的一个值。
  4. 将“间隔”设置为所需的值。例如，如果按前缀字符对项目进行分组，则将“间隔”设置为“1”可按 A、B、C 等对项目进行分组。
  5. 若要指定分组的起始值，请选中“起始于”复选框，然后在文本框里输入一个值。
  6. 若要指定分组的结束值，请选中“结束于”复选框，然后在文本框里输入一个值。

    注释 结束值必须大于起始值。

显示 按一定间隔删除分组

  1. 选择要从中删除分组的行或列字段。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“筛选和分组”选项卡。
  3. 将“组合项目按”设置为“（没有分组）”。

显示 创建自定义分组

  1. 单击包含要进行分组的项目的父级字段的标志，再单击数据透视表列表工具栏上的“展开” 按钮图像 。
  2. 单击要包含于分组中的第一个项目。

    若要选择多个项目，请按住 Ctrl 并单击每一项。

  3. 右键单击选定的项目，再单击“组合项目”。
  4. 重复步骤 2 和步骤 3 可创建更多的分组。

注释

  • 当给某个字段添加第一个自定义分组时，自定义分组字段就添加到了字段集中。该自定义分组字段就是对其项目进行了分组的字段的父级字段。
  • 可以在“命令和选项”对话框里更改自定义分组字段和自定义分组的标题。

显示 删除自定义分组

  • 请执行下列操作之一：
    • 若要删除一个自定义分组，请右键单击分组的标题，再单击“取消组合项目”。
    • 若要删除一个自定义分组字段，请右键单击该字段，再单击“删除”。

注释

  • 不能右键单击“其他”项目并不对其进行分组。
  • 如果要删除的分组是字段中的最后一个自定义分组，则自定义分组字段将随同分组一起被删除。如果删除的分组不是该字段中的最后一个自定义分组，被删除的分组的成员将移到“其他”分组中。


关于查找数据

数据透视表列表没有查找或搜索命令。但可以使用筛选功能查找特定数据值或查找符合某个值的所有数据。

显示 筛选技术

筛选字段（自动筛选） 可以对行、列和明细数据区域中的字段进行筛选。筛选字段时，在字段中选择要查看的一个或多个数据项，并隐藏其他项。

标注 1 首先筛选“运动”字段，使得只显示“高尔夫”的销售额。

标注 2 然后，筛选“季度”字段，使得只显示“高尔夫”在“第三季度”的销售额。

标注 3 在筛选字段时，已筛选的字段的下拉箭头 字段箭头 将变为蓝色，而不是黑色，并且将选中数据透视表列表工具栏上的“自动筛选”按钮 按钮图像 。

如果包含大量源数据，但用户只需要关注特定区域的数据，则此时筛选就特别有用。筛选字段时，可以显示单个项的数据，或者也可以选择显示某些项而隐藏其他项。可以一次对多个字段进行筛选以进一步缩小范围。

基于单元格中的数据进行筛选（“按选定筛选”） 可以通过筛选字段仅显示匹配选定单元格中数值的数据。如果要查看包含特定值的所有行，则对于明细数据区域中的字段而言，按选定内容筛选将非常有用。

使用“筛选”轴中的字段 还可通过使用筛选字段来筛选数据。当选择筛选字段中的一项或多项时，整个数据透视表列表中显示和计算的数据都将随之更改以反映这些项的变化。也可添加新的筛选字段或将已有字段移至筛选区域。

标注 1 筛选字段

条件筛选 可基于汇总对行字段或列字段应用筛选，以显示字段中最上面或最下面的 n 个数据项。例如，可以筛选出销售量最大的三个城市，或是赢利最小的五种产品。除了可以进行 n 个数据项的筛选外，还可以选择对数据项的某个百分比进行筛选。例如，基于处理的订单数量可筛选出字段中最上面或最下面 25% 的销售人员。如果有 40 名销售人员，在应用筛选后，将可查看其中 10 人的数据。

显示 组合多个筛选

筛选可以相加。可将所应用的每一个筛选添加到已经起作用的筛选中。但是，如果按选定内容来进行筛选，则在应用这种方式的筛选前，已应用到字段上的条件筛选将被删除。

数据透视表列表中的条件筛选是相互独立的。一个条件筛选的结果并不对其他条件筛选的结果产生影响。

自动筛选总是在按条件筛选前应用，而不管应用它们的顺序如何。例如，如果根据销售量，设置一个条件筛选来显示销售量最大的两个城市，则首先是对“ShippedCity”字段进行自动筛选，使得该字段只包括五个城市，然后再进行条件筛选，使得数据透视表列表显示选定的五个城市中的前两个城市。

显示 删除和重新应用筛选

关闭自动筛选后可显示所有字段的全部数据。但筛选设置仍然保留，这样在重新启动自动筛选时，以前显示或隐藏的数据将再次显示或隐藏。

当您移动字段更改版式时，筛选设置仍然保留。同样，如果删除某字段，稍后又将该字段重新添加到版式中，则相同的数据项将再次隐藏。

如果不需要保留筛选设置，则请确保在开始选择筛选项之前“自动筛选”按钮 按钮图像 未被选中。如果未选中按钮，则选择新的筛选项将自动启动筛选并删除以前的筛选设置。

显示 识别当前正在起作用的筛选

当字段中的项通过自动筛选而隐藏，或是按选定内容进行筛选时，该字段标志中的下拉箭头 字段箭头 为蓝色。单击该蓝色箭头 可查看正在起作用的筛选。

当字段中的数据项通过条件筛选而隐藏时，在下拉箭头 字段箭头 左侧将显示漏斗 图标图像 。可在“命令和选项”对话框中获取有关当前筛选的详细信息。

显示 筛选对计算的影响

汇总只包含显示的数据，或包含可见和隐藏数据。默认情况下，汇总中不包含隐藏数据，但基于 OLAP 数据库中源数据并通过 Microsoft Excel 发布的数据透视表列表除外，其总计中包含隐藏数据。可以更改有效设置以便在汇总中包含或排除隐藏数据。此设置只会影响通过筛选行和列字段而隐藏的数据，通过筛选字段隐藏的数据总是排除在汇总之外。

显示 搜索特定的数据

若要搜索数据而不是使用筛选，或查找与指定模式相匹配的数据，则可以将数据透视表列表导出到 Microsoft Excel 中。有关使用 Excel 中“查找”命令的信息，请参阅 Excel 的“帮助”。


筛选字段以便仅显示所需数据

显示 筛选行、列或明细数据区域的字段（自动筛选）

  1. 单击包含要筛选的数据项字段的箭头 字段箭头 。
  2. 选中与需要显示的数据项对应的复选框，清除与需要隐藏的数据项对应的复选框。

注释

  • 若要显示或隐藏某字段中的全部数据，请选择或清除“（全部）”复选框。灰色复选框说明某些较低级别项处于隐藏状态。若要查看隐藏了哪些较低级别的项，请单击复选框为灰色的数据项旁边的展开指示器 加号框 。
  • 当字段位于行、列或明细数据区域时，字段始终支持多项选择。筛选区域中的字段可支持单项或多项选择。若要从多项选择切换到单项选择，请清除“命令和选项”对话框的“筛选和分组”选项卡上的“在筛选区内允许选择多个项目”复选框。

显示 仅显示与某个单元格相匹配的数据（按选定内容筛选）

  • 右键单击包含要显示其值的单元格，然后单击快捷菜单上的“按选定筛选”。

显示 筛选行或列字段最上面或最下面的 n 项值或按百分比筛选行或列字段（条件筛选）

  1. 选择包含要筛选的值的字段。
  2. 单击数据透视表列表工具栏上的“命令和选项” 按钮图像 ，再单击“筛选和分组”选项卡。
  3. 将“显示”设置为“上”或“下”。
  4. 将“项目”设置为列表中的某个数字，或键入所需值。
  5. 若要显示 n 个数据项，请清除“%”复选框；若要显示总数据项的 n%，请选中“%”复选框。
  6. 将“基于”设置为列表中的一个值。

注释

  • 当字段中的数据项经过自动筛选或按选定内容筛选而隐藏时，字段标志中的箭头 字段箭头 为蓝色。当项经过条件筛选隐藏时，已筛选的字段在箭头的左侧显示为漏斗 图标图像 图像。
  • 应用筛选时，显示的汇总仅基于可见项。可更改设置以包括隐藏数据。


取消筛选以显示数据透视表列表中的所有数据

当字段中的数据项经字段筛选或按筛选内容筛选而隐藏后，字段标志中的箭头 字段箭头 为蓝色。当项目按最上面或最下面的值筛选而隐藏后，筛选字段在箭头的左侧显示为漏斗 图标图像 图像。

  • 请执行下列操作之一：

    显示 取消所有筛选

    • 单击数据透视表列表工具栏上的“自动筛选”按钮 按钮图像 以取消选择该按钮。

    注释 如果再次单击“自动筛选” 按钮图像 重新启动筛选，则将恢复以前设置的筛选。

    显示 取消字段的自动筛选或按选定内容筛选

    1. 单击要取消其筛选的字段的蓝色箭头 蓝色箭头 。
    2. 选中“（全部）”复选框，再单击“确定”。

    显示 取消字段的条件筛选

    1. 选中要从中取消条件筛选的字段。
    2. 单击数据透视表列表工具栏上的“显示最上面/最下面的项目” 按钮图像 ，再单击“全部显示”。

注释 如果不需要保留筛选设置，则请确保在开始选择筛选项之前“自动筛选”按钮 按钮图像 未被选中。如果未选中按钮，则选择新的筛选项将自动启动筛选并删除以前的筛选设置。


在筛选区域中允许选择多个选项

可以指定筛选区域中的字段允许单个选项还是多个选项。在单选项模式下，选中某个项后，该项的前一个项将自动清除被选中状态。在多选项模式下，选中某个项时，以前选中的项将继续保持选中状态。

  1. 在筛选区域中，选取要更改其设置的字段。
  2. 在数据透视表列表工具栏上，单击“命令和选项” 按钮图像 ，再单击“筛选和分组”选项卡。
  3. 选中或清除“在筛选区内允许选择多个项目”复选框。

注释

  • 默认情况下，多项选择将被启用。
  • 此设置仅在字段位于筛选区域时可用。如果将字段移动到行、列或明细数据区域，则字段将总是支持多项选择。


用更新的源数据刷新数据透视表列表

  1. 单击数据透视表列表。
  2. 在数据透视表列表工具栏上，单击“刷新” 图像按钮 。

注释

  • 刷新操作完成后，Office 徽标立方体 Office 徽标立方体 将停止旋转。刷新数据透视表列表时，无法与其进行交互或对其进行更改。

  • 若要取消刷新操作，请按 Esc。只有在数据透视表列表正在计算，而没有检索源数据时，可以取消刷新操作。


将数据透视表列表导出或复制到 Excel 或其他应用程序中

显示 将数据透视表列表导出到 Excel 中

使用本过程可将数据透视表列表作为交互式数据透视表从浏览器导出到 Microsoft Excel 中。在 Excel 数据透视表和原始源数据库之间的链接将保留。

为确保最佳结果，在将数据透视表列表导出到 Excel 之前，请将所有字段移动到明细数据区域以外，或隐藏数据项和单元格的明细数据。

  1. 单击数据透视表列表。
  2. 单击数据透视表列表工具栏上的“导出到 Microsoft Excel” 按钮图像 可运行或切换到 Excel，并显示数据透视表中的数据。

注释 因为 Excel 中的数据透视表无法显示某些数据透视表列表的版式和计算，所以数据透视表的外观可能与浏览器中的数据透视表列表有所不同。有关使用 Excel 数据透视表并向其添加字段的信息，请参阅 Excel 的“帮助”。

显示 将数据透视表列表复制到 Excel 或 Word 中

通过使用本过程，可将数据透视表列表或其某个部分以非交互式且具有格式的表格形式复制到 Excel 或 Word 中。

  1. 请执行下列操作之一：
    • 若要复制整张数据透视表列表，请单击数据透视表列表的标题栏。
    • 若要复制数据透视表列表的一部分，请选择要复制的元素。
  2. 在数据透视表列表工具栏上，单击“复制” 按钮图像 。
  3. 切换到 Excel 或 Word 中，然后在要显示数据透视表列表数据的位置上单击。
  4. 单击“粘贴” 按钮图像 。

注释

  • 在复制数据透视表列表或其一部分时，仅复制了格式和数据值。Excel 或 Word 中的副本与原始源数据库之间不保持链接。

  • 可以将数据透视表列表的一部分作为无格式文本复制到其他程序中，例如复制到 Microsoft Access 中。


数据透视表列表疑难解答

显示 与数据透视表列表进行交互

显示 无法与数据透视表列表进行交互

如果可以查看数据透视表列表但无法与其进行交互，您可能没有安装 Microsoft Office Web Components 或没有适当的 Microsoft Office 2003 许可。请确认组件已安装及具有有效的许可。

显示 无法显示工具栏、标题栏、字段列表、“命令和选项”对话框或快捷菜单

数据透视表列表的设计者限制了对数据透视表列表工具的访问，为的是防止在浏览器中做更改。请与设计者联系获得帮助。

显示 获取帮助

显示 无法获得显示在网页上的某个 Microsoft Office Web Component 的帮助

网页可能是使用旧版本的 Microsoft Office Web Components 设计的。Office 2003 没有安装针对早期版本的“帮助”。可从 Microsoft Office 网站下载早期版本的 Web 组件的“帮助”。

显示 移动字段

显示 不能添加或移动所需字段

字段可能已显示 不能在多个区域中显示相同的字段。

源数据可能限制了使用字段的方式 联机分析处理 (OLAP) 数据库中的源数据为不同级别的明细数据提供了字段集。在字段集内，可以隐藏明细数据的级别，但不能将集合中的字段分别显示在不同区域中。若要查明数据透视表列表的源数据是否来自 OLAP 数据库，请与数据透视表列表的设计者联系。

移动字段可能受到限制 数据透视表列表的创建者可能关闭了移动字段的功能。有关详细信息，请与数据透视表列表的设计者联系。

如果需要移动字段，可以将数据透视表列表的副本导出到 Microsoft Excel 中。在 Excel 数据透视表中，移动字段将不受限制，并且可以在筛选（页）区域和数据区域中同时显示某一字段。但如果使用的是 OLAP 源数据，则数据透视表将具有相同的限制。有关在数据透视表中移动字段以及有关 OLAP 源数据的详细信息，请参阅 Excel 中的“帮助”。

显示 更改布局后数据显示需要较长时间

如果数据透视表列表需要较长时间用于计算，可以一次更改多处布局，并在完成更改后再检索数据。

  1. 当 Office 徽标多维数据集 Office 徽标多维数据集 旋转时，请按 Esc 取消计算。此后数据透视表列表将只显示字段名。
  2. 更改布局，可按需要添加或移动字段。
  3. 若要检索和计算新布局的数据，请单击数据透视表列表工具栏上的“刷新” 按钮图像 。

显示 “命令和选项”对话框或字段列表消失

如果单击了网页上的某个控件（而不是某个 Microsoft Office Web Component），或在最小化后又还原了浏览器窗口，则会隐藏“命令和选项”对话框和字段列表。

若要重新显示对话框或字段列表，请单击数据透视表列表，以便将其重新激活。

显示 刷新数据

显示 数据透视表列表不能刷新来自源数据的数据

不能刷新某些数据透视表列表 不能刷新由 Microsoft Excel 工作表数据、Excel Web 查询和 Excel 文本查询发布的数据透视表列表。在上述情况下，必须刷新原始 Excel 工作簿，并重新发布数据透视表列表。请与数据透视表列表的设计者联系以查明列表所使用的源数据类型，如果源数据属于上述类型之一，请查明数据透视表列表是否可以重新发布以提供更新版本。

源数据库可能不可用 如果数据透视表列表的源数据来自网络中的数据库，则数据库服务器可能不可用，或没有访问该服务器的权限。例如，可能不能连接到网络，或者需要访问权限或密码才能连接数据库。请与数据透视表列表的设计者联系以查明源数据的类型以及数据透视表列表所使用的数据库。如果在连接服务器时遇到问题，请与数据库管理员联系。

Microsoft Office 可能不支持源数据库 如果源数据来自 Microsoft Office 不支持的数据库，则可能需要安装数据库供应商所提供的与 Office 兼容的支持软件。请与数据透视表列表的设计者联系以查明 Office 是否支持源数据库，如果不支持，请查明数据库的设计者在创建数据库时所使用的软件。

源数据库可能已更改 有些情况下，对服务器上数据库组织方式的更改也可能会禁止对数据透视表列表的刷新。例如，如果源数据来自联机分析处理 (OLAP) 数据库，并且用更改了的可用数据重建了该数据库，则可能必须创建新的数据透视表列表。有关详细信息，请与数据透视表列表的设计者联系。

显示 当刷新数据透视表列表时，网页上的其他数据透视表列表也发生了更改

所查看的网页是按如下方式设计的：当刷新某个数据透视表列表时，其他数据透视表列表也将刷新。

有关数据透视表列表链接方式的详细信息，请与数据透视表列表的设计者联系。

显示 数据透视表列表中的查询失败

源数据库可能不可用 如果数据透视表列表的源数据来自网络中的数据库，则可能是由于数据库服务器不可用，也可能是网络或网络连接不可用。请与服务器管理员或网络管理员联系以确定服务器和网络是否可用。

可能不具备所需权限 可能可以连接到数据库中，但却不具备运行数据透视表列表的查询的权限。请与数据库管理员联系以确定权限。

检查数据透视表列表中的筛选 有些情况下，数据透视表列表可能经过筛选后只显示特定项，而对源数据库的更改可能删除了其中的某个项，结果导致查询失败。如果是这个原因，则可以关闭筛选以显示所有项，然后单击数据透视表列表工具栏上的“刷新” 按钮图像 以运行查询。

显示 筛选数据

显示 筛选命令无效

筛选可能受到限制 数据透视表列表的创建者可能关闭了更改字段筛选方式的功能。有关详细信息，请与数据透视表列表的设计者联系。

如果需要筛选数据，可以将数据透视表列表的副本导出到 Microsoft Excel 中。在数据透视表中，筛选字段将不受限制。有关在数据透视表中筛选字段的详细信息，请参阅 Excel 的“帮助”。

显示 不能按所需的方式筛选数据

另外，基于单元格中部分数据进行的筛选（在 Microsoft Access 窗体和数据表中可用的一种功能）对数据透视表将无效。如果需要筛选部分单元格，请与数据透视表列表的创建者联系以查明源数据的来源。可能可以在 Access 窗体或数据表中直接查看该数据，Access 窗体或数据表支持部分单元格筛选。

显示 显示数据

显示 不能显示项或明细数据

展开指示器可能已关闭 如果看不到行或列字段中数据项左边的 加号框 框，请确保展开指示器已打开。

数据项可能不可用 当数据项位于源数据中可用明细数据的最低级别时，该数据项的旁边将没有 加号框 框，即使已打开展开指示器也一样。

源数据可能没有明细数据 某些类型的源数据（如联机分析处理 (OLAP) 数据库中的源数据）没有可显示的明细数据记录。若要查明数据透视表列表的源数据是否来自 OLAP 数据库以及查找可用的明细数据数量，请与数据透视表列表的设计者联系。

显示明细数据可能受到限制 如果打开展开指示器和显示明细数据的命令不可用，可能是由于数据透视表列表的设计者关闭了显示项或明细数据的功能。有关详细信息，请与设计者联系。

如果需要查看明细数据，可以将数据透视表列表的副本导出到 Microsoft Excel 中。在 Excel 数据透视表中，显示明细数据将不受限制。有关在数据透视表中显示明细数据的详细信息，请参阅 Excel 的“帮助”。

显示 数据难以阅读

使用更大的字体 浏览器中字号的设置不会影响数据透视表列表中文本的大小。若要使很难阅读的小字号文本变大，可更改数据透视表列表内的元素的字号。

使用对比明显的颜色 浏览器中的颜色设置不会影响数据透视表列表中的颜色。若要加强文本使其在背景上具有突出效果，可为数据透视表列表中的每个元素设置字体颜色，然后设置对比明显的背景色。

如果将数据透视表列表的副本导出到 Excel 中，可以放大数据。有关使用 Excel 数据透视表的详细信息，请参阅 Excel 的“帮助”。

显示 向下翻页后，看不到选定内容

在浏览器中使用滚动条。数据透视表列表的设计者在设计完列表后，如果更改版式，则列表会根据显示数据所需的空间自动扩展或缩小。如果要查看其他数据，可以使用滚动条在整个网页中滚动。

显示 字段存在，但所有数据却丢失了

您可能取消了数据透视表列表的计算，或是在计算结束前中止了计算。若要显示数据，请单击数据透视表列表工具栏上的“刷新” 按钮图像 。

显示 提示

在刷新数据前，可以更改布局或在字段中筛选数据项。

显示 打印数据透视表列表时数据丢失

确保数据没有隐藏 如果要打印由筛选隐藏了的数据，请在打印前显示数据。若要打印明细数据，请在打印前显示明细数据。

查看数据透视表列表是否显示在固定区域中 数据透视表列表可以根据显示数据所需的空间在网页上自动展开或缩小，或者，也可以显示在固定大小的区域中，这取决于数据透视表列表设计者的设计。如果数据透视表列表显示在固定区域中，则只会打印当前显示的区域。

在整个数据透视表列表中滚动 当打印可根据显示数据需要自动扩展或缩小的数据透视表列表时，只会打印在浏览器会话期间内滚动到的数据。在打印网页前，请使用滚动条从头到尾滚动数据透视表列表。

如果要更灵活地控制数据的打印方式（包括打印较长清单中的内容以及设置自动分页符），则可以将数据透视表列表的副本导出到 Microsoft Excel 中。有关在 Excel 中打印的详细信息，请参阅 Excel 的“帮助”。

显示 将数据透视表列表复制到 Excel 或 Word 中后，数据丢失

如果将数据透视表列表中的数据复制到剪贴板，并粘贴到 Microsoft Excel 或 Microsoft Word 中，则只会复制可见的行和列。任何隐藏或筛选出去的数据将不会复制。

在复制数据之前，请关闭筛选以显示数据透视表列表中的所有数据，然后显示明细数据以便复制。

若要避免在复制前必须显示所有数据，可以导出（而不是复制）数据透视表列表。如果将数据透视表列表的副本导出到 Excel 中，则会自动包含所有数据，并且其中相同的筛选也同样有效。导出后，对源数据中其他字段的访问与在数据透视表列表中相同，并且还可以在 Excel 中更改筛选。然后还可以通过 Excel 将数据复制到 Word 或其他程序中。有关详细信息，请参阅 Excel 的“帮助”。

显示 单元格显示 ##### 而不是所需的数字

如果数字太长以致于单元格容纳不下，则数据透视表列表将显示数字符号而不是数字。可以按下列方法之一处理此情况：

  • 增大列宽，以使其适合整个数字。
  • 如果不想增加列宽，可以缩小字体。
  • 更改数字格式，使用占用较少空间的字体。

显示 基于数据透视表列表的图表为空或没有数据

添加汇总字段 如果图表要反映的是数据透视表列表中的数据，则必须至少为数据透视表列表添加一个汇总字段。

将字段移至行和列区域 数据透视表列表中的行和列字段提供了图表的分类数据和系列数据。例如，如果所有字段都位于数据透视表列表的明细数据区域中，则图表将没有可绘制的分类和系列。应从明细数据区域或字段列表中向行区域或列区域至少移动一个字段。

显示 在 Web 浏览器中单击“编辑”按钮时在不正确的程序打开了网页

Web 浏览器中的“编辑”按钮所调用的程序取决于页面的发布方式。

如果单击 Web 浏览器中的“编辑”按钮时打开了不希望使用的程序，则请退出该程序，并启动要使用的程序，然后在此程序中打开该网页。

显示 数据透视表列表的汇总字段旁显示有星号

在以下情况下，星号 (*) 显示在汇总字段标题的旁边：

  • 如果设置了在汇总中包含所有项，则会在汇总字段的标题旁显示星号以指示汇总中既包含显示的项也包含隐藏的项。
  • 在基于联机分析处理 (OLAP) 数据库中源数据的 Excel 数据透视表中，分类汇总和总计值的计算中总包含字段中所有项的值，不论是显示的还是隐藏的项。Excel 提供关闭显示这些星号的选项。

在数据透视表列表中（无论其是否基于 OLAP 数据库中的源数据），如果要在分类汇总和总计中忽略由筛选隐藏的数据，则可以设置选项以便只包含显示的数据。该选项同样隐藏星号。