关于图表

图表具有较好的视觉效果，可方便用户查看数据的差异、图案和趋势。拥有 Microsoft Office 图表组件，便可与动态图表进行交互，动态图表会及时更新以反映图表所基于的数据的最新变化。

显示 与图表进行交互

如果可以访问图表所基于的数据，则可以对数据进行更改、刷新网页以及查看图表中所反映出来的变化。

根据创建图表的方式不同，可能会使用不同的字段来组织数据。在这些图表类型中，可以重新排列字段以及对数据进行排序和筛选（如果网页设计者提供了这方面的功能）。还可以添加或删除图例、将系列更改为分类等等。

若要交互处理图表，应当安装 Office Web 组件。可以通过安装 Microsoft Office 2003 来安装此组件，或者如果企业拥有 Office 2003 站点许可证，则可以从企业的 Intranet 下载 Office Web 组件。此外，如果不是在 Microsoft Visual Basic for Applications (VBA) 项目内查看图表，则还必须具有 Microsoft Internet Explorer 5.01 SP2 或更高版本，才能交互处理图表。

如果您的系统没有满足上述要求，则只能查看图表，而不能与其进行交互。有关详细信息，请咨询网页或应用程序的设计者，或是咨询系统管理员。


支持图表的浏览器

若要在 Microsoft Internet Explorer 5.01 SP2 和更高版本中处理交互式图表，则必须安装 Microsoft Office Web Components，并拥有适当的 Office 2003 许可。如果没有 Office 2003 许可，也可安装该组件，并可以在网页中对其进行查看，但是不能与其进行交互。

如果安装了 Office Web 组件并且具有 Office 2003 许可，则可支持的浏览器如下：

显示 Microsoft Internet Explorer 5.01 SP2 和更高版本

可以访问在浏览器中可用的所有图表功能。当您离开图表，随后又在同一个浏览器会话中返回到该图表时，您所做的更改（如格式和版式的更改）将保留。

显示 其他浏览器

不能在 Microsoft Internet Explorer 的早期版本及其他浏览器中查看图表。在这些浏览器中，图表在网页上只显示为带外边框的框，或者根本不显示。


关于 Microsoft Office Web Components

Microsoft Office Web Components 是与 Microsoft Office 2003 一起安装的一组 ActiveX 控件。如果在计算机上安装了 Office Web 组件，则可在 Internet Explorer 5.01 SP2 或更高版本中对电子表格、数据透视表列表和图表进行交互访问。如果您要在 Microsoft Access 的数据访问页中使用这些组件，则需要安装 Internet Explorer 5.01 SP2 或更高版本。

如果计算机上未安装 Office Web 组件，但您有允许 Intranet 发布的 Office 2003 站点许可证，则可对组件进行配置，以提示用户从公司的 Intranet 下载 Office Web 组件。这样，您网站上的用户无需在计算机上安装 Office 2003 软件就可使用数据访问页。

有关如何配置 Office Web 组件的信息，请参阅《Microsoft Office 2003 资源工具包》。


关于 Office Web 组件的“仅供查看”模式

如果您的计算机未安装 Microsoft Office 2003 软件许可，或不能通过 Microsoft Office 2003 的应用程序获取该许可，则只能在网页上查看 Microsoft Office Web Component（电子表格组件、图表组件或数据透视表组件），而不能与其进行交互。

若要与正在查看的组件进行交互并使用其完整的功能，则必须安装 Microsoft Office 2003 或获取 Office 2003 许可。如果您是在公司或组织中，请向网络管理员咨询以获取帮助。

在“仅供查看”模式中，可以执行下列操作：

  • 查看数据。
  • 打印。
  • 选择和滚动数据。
  • 使用超链接。
  • 调整组件大小。
  • 在电子表格组件中选取工作表。
  • 展开或折叠数据透视表列表中的成员。
  • 刷新数据透视表列表中的数据。
  • 可使用“关于”、“帮助”和“刷新”命令。但有关交互（例如设置单元格格式、拖动字段、排序、筛选等）的帮助主题不可用。

在“仅供查看”模式中，只可使用“关于”、“帮助”、和“刷新”命令，其他命令都不可用。


关于获取图表的帮助

本主题中的部分内容可能不适用于某些语言。

在 Web 浏览器中查看图表以及与图表进行交互时，实际上是使用由其他程序（称为设计程序）所创建的组件。在设计程序（例如 Microsoft FrontPage 或 Microsoft Access 中的数据访问页）中，您可以指定要进行绘制的数据、设置图表的格式、为图表的显示设置选项以及向 Web 服务器发布网页。在设计程序内可以获取关于设计图表的帮助。

若要了解如何设计图表，请首先选择将要使用的设计程序。可以使用任何支持的设计程序，如果需要其他的设计功能，则可以稍后在其他设计程序中对此图表进行处理。

显示 在设计程序中获取帮助

如果您具有 Microsoft Office 2003 许可，并已安装 Microsoft Office Web Components，则可在几个程序中创建和修改图表。可以在一个程序中创建图表，然后使用另一个程序修改图表或修改该图表所在的网页。

选择使用何种设计程序取决于要在网页上进行设计和管理的工作量、要使用的数据类型和对不同设计程序的熟悉程度等。

Microsoft Excel 如果在工作表中已经有要使用的数据，或者如果有特别适合于工作表的数据，则 Excel 不失为创建图表的最佳设计环境。您只需在 Excel 工作表上排列数据，遵循 Excel“帮助”中的指导来创建图表。然后按照 Excel“帮助”中的指导将图表发布到网页。

如果必要，还可以在其他设计程序（如 Microsoft FrontPage）中对图表做进一步的修改。如果使用 Microsoft Access 数据访问页“设计”视图修改了通过 Excel 发布的网页，则用户在使用该网页之前需要安装 Internet Explorer 5.01 SP2 或更高版本。Excel 可在 Microsoft Office 2003 中获得。

Microsoft FrontPage 如果希望创建网页或修改通过 Excel 发布的图表，则建议使用 FrontPage 这样的设计程序。在 FrontPage 中，除了可以修改用其他程序设计的图表，还可创建网页上的图表。使用 FrontPage 的扩展网页编辑和管理功能向网页中添加控件、图形、主题以及其他内容，然后将页面变成网站的一部分。FrontPage 可在 Microsoft Office 2003 中获得。

Microsoft Access 如果希望创建对数据库中的数据进行操作和显示的网页，并且用户具有 Internet Explorer 5.01 SP2 或更高版本，则请使用 Access 数据访问页设计视图来创建图表。可以使用 Access 建立 Access 数据库与网页之间的连接，然后绘制数据。或者，也可在创建图表时直接连接到数据。Access 在 Microsoft Office 2003 中可获得。

Microsoft Visual Basic 如果需要比 Excel、FrontPage 和 Access 所提供的脚本功能更全面的编程环境，则可以在 Microsoft Visual Basic 中设计图表。如果要在自定义的解决方案中包含图表，则可使用 Visual Basic。用户可以在程序中的 Visual Basic 窗体上查看图表并与其进行交互。此窗体将取代浏览器而成为运行时环境，程序可以使许多图表功能具有自动化效果。

在设计程序中工作时，可按以下方法获取帮助：

  • 设计程序的“帮助” 有关设计程序中可用于处理图表的命令与功能的详细信息，请参阅设计程序的“帮助”。例如，在 Microsoft FrontPage 中，可单击“Office 助手”或单击“Microsoft FrontPage 帮助” 按钮图像 。

    Microsoft Excel 提供了有关保存 Excel 数据以便用于网页的一般性帮助，也提供了有关保存图表以便用于网页的特定信息。若要在 Excel 中访问该“帮助”，请单击“Office 助手”或单击“Microsoft Excel 帮助” 按钮图像 。

  • 图表的设计时“帮助” 如果在其他设计程序中可以访问“命令和选项”对话框，则可以访问设计时的“帮助”主题。在用设计程序创建或激活的图表中，请单击“命令和选项”对话框中的“帮助” 按钮图像 ，或单击图表工具栏上的“帮助” 按钮图像 。

显示 获取有关编写脚本和程序以使用图表的帮助

可以使用脚本和程序使图表具有自动化功能，或者也可以在 Web 浏览器以外的其他运行程序（例如，在 Microsoft Visual Basic 编程环境中开发的程序）中包含图表。

编写脚本 Microsoft Office 程序提供了“Microsoft 脚本编辑器”来帮助编写脚本。例如，可以在 Microsoft Access 数据访问页“设计”视图中使用“脚本编辑器”来自定义图表。有关运行“脚本编辑器”的详细信息，请参阅 Office 设计程序的“帮助”。在“脚本编辑器”中，可以显示有关使用其功能和编写脚本的附加“帮助”。

对象模型“帮助” 如果要获取有关开发程序或脚本来处理图表列表的“帮助”，可显示与图表相关的对象模型、属性和方法的有关信息。每次安装 Microsoft Office Web Components（“图表组件”就是其中之一）时，都会安装对象模型“帮助”。根据所使用的设计程序的不同，用户可以按下列方法访问该“帮助”：

  • Microsoft Visual Basic 中的“帮助” 在 Visual Basic 或 Visual Basic for Applications (VBA) 中，可以创建对 Microsoft Office Web Components 库的引用，然后，就可以通过对象浏览器或通过选择关键字并按 F1 来访问“帮助”。有关创建引用和使用对象模型“帮助”的详细信息，请参阅 VBA 中的“帮助”。
  • 其他环境中的“帮助” 如果使用的是其他开发环境，则请找到并双击“帮助”文件“Owcvba11.chm”。

显示 在浏览器中获取帮助

浏览器中可用的“帮助” 如果有 Microsoft Internet Explorer 5.01 SP2 或更高版本以及 Microsoft Office Web Components，则与图表相关的一般性“帮助”将自动可用。而此运行时“帮助”与浏览器的“帮助”菜单中的“帮助”不同。

图表中可用的“帮助” 运行时图表的“帮助”主题为所有用户提供了有关在浏览器中使用图表的一般信息，例如，如何使用工具栏和快捷菜单，以及当图表是基于数据透视表列表或数据库的表或查询时，如何处理字段列表和各字段。该“帮助”并不包括有关使用“命令和选项”对话框的信息。有关详细信息，请参阅图表的设计时“帮助”，或咨询图表的设计者。


键盘快捷键

本主题中的部分内容可能不适用于某些语言。

显示 用于字段的快捷键

Alt+向下键
打开当前选定的字段的列表
Tab
在字段下拉列表中最近选择的项、“确定”按钮和“取消”按钮之间切换
箭头键
移动到字段下拉列表中的下一项
空格键
选中或清除字段下拉列表中当前项对应的复选框
Enter
关闭字段下拉列表，并应用所做的任何更改
Esc
关闭字段下拉列表，但不应用所做的更改

显示 处理字段列表的快捷键

Ctrl+L
显示字段列表，或者，如果已经显示了字段列表，则激活字段列表
箭头键
移动到字段列表的下一项
Shift+向上键
移动到上一项并将其包括在选定区域中
Shift+向下键
移动到下一项并将其包括在选定区域中
Ctrl+向上键
移动到上一项，但不将其包括在选定区域中
Ctrl+向下键
移动到下一项，但并不将其包括在选定区域中
Ctrl+空格键
如果选定区域中的项有焦点，则将其从选定区域中删除，反之亦然
加号（数字键盘）
展开字段列表中的当前项以显示其内容。或者，展开“汇总”以显示可用的汇总字段。
减号（数字键盘）
折叠字段列表中的当前项以隐藏其内容。或者，折叠“汇总”以隐藏可用的汇总字段。
Tab
在字段列表中最近选定的项、“添加到”按钮及其旁边的列表之间进行切换
Alt+向下键
打开字段列表中“添加到”按钮旁的下拉列表。使用箭头键可移动到列表中的下一项，然后按 Enter 可选定该项。
Enter
将字段列表中突出显示的字段添加到“添加到”列表中显示的数据透视表列表内的区域中
Alt+F4
关闭字段列表

显示 在“帮助”中使用的快捷键

显示 在“帮助”窗口中使用的快捷键

F6
在导航窗格和主题窗格之间进行切换
Alt+O
显示“选项”菜单以访问任何“帮助”工具栏命令
Alt+空格键
显示程序的“控制”菜单
Alt+F4
关闭“帮助”窗口

显示 在导航窗格中使用的快捷键

Ctrl+Tab
切换到另外一个选项卡
Enter
打开或关闭选定的书，或打开选定的“帮助”主题
向下键
选择下一本书或下一个“帮助”主题
向上键
选择上一本书或上一个“帮助”主题
Shift+F10
显示快捷菜单

显示 在主题窗格中使用的快捷键

Alt+向右键
前往以前查看的“帮助”主题
Alt+向左键
返回以前查看的“帮助”主题
Tab
选中下一个隐藏的文本或超链接，或主题顶部的“全部显示”或“全部隐藏”
Shift+Tab
选取以前隐藏的文本或超链接
Enter
执行所选的“全部显示”、“全部隐藏”、隐藏文本或超链接等操作
向上键或向下键
向“帮助”主题的开始或结束方向滚动
Page Up 或 Page Down
以较大的步长向“帮助”主题的开始或结束方向滚动
Home 或 End
前往“帮助”主题的开始或结束部分
Ctrl+P
打印当前“帮助”主题
Ctrl+A
选定整个“帮助”主题
Ctrl+C
将选定内容复制到剪贴板
Shift+F10
显示快捷菜单


打印图表

若要打印一个图表，必须打印整个网页。

  • 在 Microsoft Internet Explorer 的“文件”菜单上，单击“打印”。

注释 如果图表比打印页面宽或长，则将不打印超出页面的部分。


关于图表工具、命令和字段列表

能否访问图表工具栏、字段列表、快捷菜单和“命令和选项”对话框，将取决于您正查看的网页的设计者是否使得这些工具可用。有关详细信息，请咨询图表的设计者或系统管理员。

显示 工具栏

图表顶部的工具栏提供了一套处理图表显示和图表数据的命令。例如，可以用工具栏添加或删除图例，在某些情况下更改系列或分类数据以反映行或列中的数据。如果图表是基于数据透视表列表、数据库表或查询中的数据，并且您希望在图表中对数据进行排序、筛选或更改数据的显示，则该工具栏是非常有用的。

若要查看每个按钮的命令名称，请将鼠标指针停留在该按钮上。

显示 “命令和选项”对话框

默认情况下，“命令和选项”对话框（包括用于处理图表的高级命令）在运行期间不可用。在运行的图表中，有关“命令和选项”对话框的“帮助”也不可用。有关详细信息，请咨询网页的设计者或系统管理员。

显示 字段列表

如果图表基于数据库数据或数据透视表列表，则可从图表工具栏上找到字段列表。使用字段列表可查看源数据提供的字段列表，还可以将字段添加到分类、系列、筛选和图表的数据区域中。在字段列表中，没有加粗的字段是可用的，但还未在图表中显示。加粗的字段是已显示在图表上的字段。可以滚动并单击展开指示器（ 加号框 或 减号框 框）以显示或隐藏其他字段。

显示 快捷菜单

如果右键单击当前的图表，则快捷菜单上将显示一些命令和选项，包括显示或隐藏工具栏的命令、显示或隐藏字段列表和拖放区域的命令以及其他选项。


显示或隐藏图表工具栏

  • 右键单击图表，再单击快捷菜单上的“工具栏”。


显示或隐藏拖放区域

拖放区域被隐藏之后，不能在图表中添加或拖动字段。

  • 右键单击图表，再单击快捷菜单上的“拖放区域”。

注释 如果图表不是基于数据库中的数据或是数据透视表列表中的数据，并且网页设计者将其禁用，则“拖放区域”菜单项不可用。


显示或隐藏图表的图例

  • 在工具栏上，单击“显示/隐藏图例” 按钮图像 。


关于访问不同域中的数据源

“图表”组件试图访问其他域中的数据，但是由于以下原因失败了：

  • 在 Internet Explorer 中的“安全设置”对话框上，在“其他”下面的“通过域访问数据资源”设置被设为“禁用”，或被设为“提示”，而当您被提示时，却单击了“取消”。
  • 控件正在访问的网站不包括在可信网站的列表内。

若要启用跨域访问，请执行下列操作：

显示 启用提示

  1. 在 Internet Explorer 中的 “工具”菜单上，单击“Internet 选项”。在“安全”选项卡上选择相应的 Web 内容区域，然后单击“自定义级别”。在“其他”下面，将“通过域访问数据资源”设置为“提示”。
  2. 当被提示时，如果您信任数据提供商，请单击“确定”以便允许“图表组件”从指定域访问数据。

显示 将网站添加到可信网站列表中

如果正在访问的网站总是可靠的，则可将网站添加到可信网站列表中。

  1. 在 Internet Explorer 中的“工具”菜单上，单击“Internet 选项”。在“安全”选项卡上选择“受信任的站点”作为 Web 内容区域，然后单击“站点”。
  2. 在“可信站点”对话框中，输入网站详细信息，然后单击“确定”。


图表的元素

显示系列、分类和数据的表示方式

代表数据的图表元素示例

标注 1 网格线

标注 2 数据系列

标注 3 数据标志

标注 4 分类

标注 5 绘图区

标注 6 图例项标示

标注 7 系列名称

标注 8 图例

网格线   网格线是可以添加到图表中以使数据易于查看和求值的线条。网格线是坐标轴上刻度线的延伸，并穿过绘图区。

数据系列、系列名称（图例项）   数据系列是绘制在图表中的一组相关数据点。每个数据系列都有唯一的颜色或图案，并且在图例中可由图例项标示和系列名称（图例项）代表。在前面的图表示例中，“计划”和“实际”都是数据系列。在大多数图表中都可以绘制一个或多个数据系列。

数据标志   用于代表数据点，每个数据点都是绘制在图表中的单个值。而相关数据点构成了数据系列。例如，数据标志包括条、点和扇区等。

分类   分类是由图表中每个数据系列的一个数据点构成的一组相关数据点。对于大多数图表，分类是沿分类 (X) 轴绘制的，其方向一般为水平。但是，在某些图表中，分类 (X) 轴却是垂直的，例如条形图中。在前面的图表示例中，“一季度”、“二季度”、“三季度”和“四季度”都是分类，且这四个分类中的每一个都是由“计划”系列的一个数据点和“实际”系列的一个数据点构成的。

绘图区   图表中坐标轴包含的区域，包括所有的数据系列。

图例项标示   图例中的图像，用于显示为图表中数据系列或分类指定的图案和颜色。图例项标示位于图例项的左边。

图例   为图表中数据系列或分类指定的图案或颜色标示。

显示坐标轴

图表中的坐标轴

标注 1 数值 (Y) 轴标题

标注 2 数值 (Y) 轴刻度线标签

标注 3 数值 (Y) 轴

标注 4 网格线

标注 5 次要刻度线

标注 6 分类 (X) 轴标题

标注 7 分类 (X) 轴刻度线标签

标注 8 分类 (X) 轴

数值 (Y) 轴标题   通常用于说明数值轴度量内容的标题。

数值 (Y) 轴刻度线标签   也称为数值轴标签。这些标签对数值轴上的度量值进行了说明。

数值 (Y) 轴   构成绘图区一条边的线，它为在图表中进行度量或比较提供了参照框架。对于大多数图表，数据值是沿数值 (Y) 轴绘制的，而该轴一般是垂直的。但是，在某些图表中数值 (Y) 轴是水平的，例如条形图中。而有些图表的数据值则是绘制在两个坐标轴之上的，例如 XY 散点图中。

网格线   网格线是可以添加到图表中以使数据易于查看和求值的线条。网格线是坐标轴上刻度线的延伸，并穿过绘图区。

主要刻度线和次要刻度线   与坐标轴相交的表示度量单位的细线，类似于标尺上的分隔线。主要刻度线出现在坐标轴刻度的每个主要度量单位上，而次要刻度线出现在每个次要度量单位上。这两种类型可位于坐标轴的内部或外部，或者也可位于横穿坐标轴的位置上。

分类 (X) 轴标题   用于说明分类轴上绘制内容的标题。

分类 (X) 轴刻度线标签   也称为分类标签。这些标签显示了分类轴上分类的名称。

分类 (X) 轴   构成绘图区一条边的线，它为在图表中进行度量或比较提供了参照框架。分类是由图表中每个数据系列的一个数据点构成的数据点组。对于大多数图表，分类是沿分类 (X) 轴绘制的，该轴一般是水平的。但是在某些图表中分类 (X) 轴是垂直的，例如条形图中。还有些图表没有分类 (X) 轴，例如 XY 散点图。

显示标题和标签

图表标题和标签

标注 1 图表工作区标题（用于工作区中所有图表的标题）

标注 2 图表标题（用于单个图表的标题）

标注 3 数值轴标题

标注 4 分类轴标题

标注 5 分类标签

标注 6 数据标签

标注 7 数值轴标签

标注 8 图表工作区图例（用于工作区中所有图表的图例）

标注 9 图表图例（用于单个图表的图例）

图表工作区标题   用于说明所有图表的标题（如果工作区内有多个图表）。本标题可以位于图表工作区的上方、下方、左方或右方。

图表标题   用于说明单个图表的标题。本标题可以位于图表的上方、下方、左方或右方。

数值轴标题   通常用于说明数值轴度量内容的标题。

分类轴标题   通常用于说明分类轴绘制内容的标题。

分类标签   也称为刻度线标签。这些标签显示了分类轴上的分类名称。分类是由图表中每个数据系列的一个数据点构成的一组相关数据点。

数据标签   用于提供有关数据标志（代表单个数据点或值）附加信息的标签。根据不同的图表类型，数据标签可以显示值、数据系列或分类的名称、百分比，或者显示这些项的组合。

数值轴标签   也称为刻度线标签。这些标签对数值轴上的度量值进行了说明。

图表工作区图例   为多图表工作区中所有图表内的数据系列或分类指定的图案或颜色标示。

图表图例   为单个图表中数据系列或分类指定的图案或颜色标示。

显示字段

如果图表是基于数据库或数据透视表列表，则图表像数据透视表列表一样，其中含有可进行移动、筛选和排序的字段。

含有字段的图表

标注 1 筛选字段

标注 2 多图表字段

标注 3 数据字段

标注 4 系列字段

标注 5 分类字段

筛选字段   可以使用该字段根据特定项来筛选数据。在前面的示例中，“年份”筛选字段显示所有具有记录的年份的数据。若要显示单个年份的数据，可单击“年份”旁边的箭头，然后选择年份。

多图表字段   可以使用该字段为字段中的每个项显示不同的图表。在本例中，“销售人员”字段经过筛选后只显示两名销售人员：Dodsworth 和 Suyama。由于该字段在“多图表”区域，因此为这两名销售人员显示了两个不同的图表。

数据字段   来自基本源数据的字段，提供进行比较或计算的数据。在本例中，“销售总金额”就是一个数据字段，它用于汇总每种产品在各个地区的销售情况。在 Dodsworth 图表中第一个分类数据标志 (E) 在数值 (y) 轴上的值略大于 200。该数值是 Dodsworth 在东部地区销售的各产品销售额的总和。根据报表使用的源数据的不同，可将 Sum 汇总函数更改为 Average、Max、Min 或其他计算。

系列字段   分配到图表系列方向上的字段。字段中的项提供单个数据系列。在本例中，“类型”就是一个系列字段。

分类字段   分配到图表分类方向上的源数据中的字段。分类字段为那些用来绘图的数据点提供单一分类。在本例中，“地区”就是一个分类字段。


关于数据系列和分类

数据系列由图例中的名称表示，并且在图表上表现为具有相近颜色的数据标志组。每个数据系列取出一个点便构成了分类。分类是具有相似特征的一组数据点。分类和数据系列中的值可以来自数据源的行或列。

例如，假定图表中的数据来自如下的电子表格：

电子表格中的数据

如果图表按季度分类对欧洲的销售单位进行比较，则数据系列将位于列，而分类将位于行，图表将如下所示：

图表

如果指定数据系列位于行中，则图表应将欧洲作为分类，而每一季度组成一个数据系列，如下所示：

图表


将系列更改为分类或将分类更改为系列

只有在图表是基于数据库或数据透视表列表中的数据绘制时，本选项才可用。

  • 单击工具栏上的“按行/列” 按钮图像 。


关于添加和删除字段

如果图表是基于数据库中的数据或是数据透视表列表中的数据，则可从源数据中选取字段以显示于图表中。

显示 查看图表可用的字段

使用图表的字段列表可查看源数据中可用字段的列表，并将字段添加到图表的分类、系列、筛选和数据区域中。在字段列表中，一个字段集包含一个或多个字段。未使用粗体的字段或字段集可在图表中显示。使用粗体的字段集包含一个或多个已经显示的字段。您可以通过滚动和单击展开指示器（ 加号框 或 减号框 框）来显示或隐藏每个字段集中的其他字段。如果要显示同一字段集中的多个字段，这些字段必须显示在同一个拖放区域中。

如果图表是基于 OLAP 数据库（例如使用 Microsoft SQL Server OLAP Services 创建的数据库）的源数据，您会发现有些字段只能被移动到系列或分类区域。在“汇总”下列出的其他字段则只可以用作数据字段。

显示 向分类或系列区域中添加字段

使用分类和系列字段可汇总并比较数据。这些字段可将某一字段内的唯一数据项显示为系列（相关数据点）或分类（包含每个系列中一个数据点的相关组）。

标注 1 系列字段，显示为图例。图例中的名称为该字段中的数据项。

标注 2 分类字段。沿 X 轴底部显示的名称为分类字段中的数据项。

显示 向数据区域添加字段

数据字段提供了要在图表中进行汇总的值。在向数据区域中添加字段时，该字段的值将显示为分类和系列项的数据标志。

标注 1 数据字段

标注 2 代表数据点的数据标志

显示 向筛选区域添加字段

筛选字段类似于 Microsoft Excel 数据透视表中的页字段。使用筛选字段可使视图仅显示可用数据的特定部分。当选取筛选字段中的某个数据项时，将只显示和计算该项的数据。例如，如果将“年份”添加为一个筛选字段，可以使图表一次显示所有年份的数据或只显示某一年的数据。

标注 1 筛选字段

标注 2 当前显示的筛选字段项

标注 3 选定年份的数据标志

显示 添加汇总字段

通过向图表中添加汇总字段，可以创建新的数据字段。汇总字段提供了可用作数据字段的汇总数据。例如，如果源数据中包括可显示每次销售额的“销售额”字段，则可以添加“销售总额”汇总字段来计算总销售额，或将汇总字段更改为“销售总量”字段来显示销售总数。

显示 删除字段

若要清除您不想继续查看或汇总的数据，可以从图表中删除字段。删除的字段将不再显示在图表中，但仍可在字段列表中查看。

显示 移动字段

在将字段添加到图表中后，可以将其移动到其他区域中。移动字段将会更改图表的布局和数据显示的方式。

显示 添加和删除筛选字段的影响

如果删除某字段，稍后又将其重新添加到图表中，筛选设置将保留。


添加、更改或删除字段

显示 添加字段

  1. 在图表工具栏上，单击“字段列表” 按钮图像 。

  2. 使用滚动条和展开指示器（ 加号框 和 减号框 框）查找要添加到图表中的字段。

  3. 单击该字段并将其拖动到图表上适当的拖放区域中。

    可以向每个位置添加多个字段。

    注释

    • 除拖动字段外，另外一种可选的方法为：在字段列表中，选择将要向其中添加字段的区域（这些区域列在字段列表的底部），再单击“添加到”。如果选择了要放置字段的区域后，“添加到”不可用，则可能是选定的字段不能用作分类字段、系列字段、数据字段或筛选字段。

    • 如果图表是基于 OLAP 数据库中的源数据，则只有未在字段列表中“汇总”之下列出的字段才能用作分类、系列或筛选字段。

    • 您可以向图表中的一个区域中添加多个字段。字段在图表中的位置决定了数据显示的分级顺序。外部字段可以被展开或折叠，以显示内部字段中的更多或更少的信息。

显示 更改数据字段的汇总函数

  1. 单击包含要汇总数值的数据字段。

  2. 在图表工具栏上，单击“自动计算” 按钮图像 ，再单击所需的汇总函数。

注释 当图表的源数据不允许您添加汇总字段时（例如，当源数据是来自 OLAP 数据库时），“自动计算”按钮将不可用。

显示 删除字段

将字段从图表中删除后，该字段的数据将不再显示，但仍可在字段列表中查看该字段。

  1. 单击要从图表中删除的字段的字段标志。

  2. 向图表外部拖动字段，直至指针变为 带红色 X 的指针 。


在图表中移动字段

  1. 如果图表的拖放区域未显示，请右键单击图表，再单击快捷菜单上的“拖放区域”以显示该区域。
  2. 在图表中，单击要移动的字段，然后拖动该字段直到指针更改形状以表示将要放置该字段的区域。
    该指针 | 表示该区域
    系列区域的指针 | 系列区域
    分类区域的指针 | 分类区域
    筛选区域的指针 | 筛选区域
    数据区域的指针 | 数据区域
    多图表区域的指针 | “多图表”区域
  3. 释放鼠标按键。

注释 上述指针只有当在图表内移动字段时有效，而当从字段列表中添加字段时无效。


关于更改图表中字段的布局

如果图表是基于数据库或数据透视表列表中的数据，则可以通过移动字段和自定义布局来控制数据的显示方式（如果网页设计者对此没有限制）。采用不同的布局，您可使用有意义的方式来比较数据中不同元素的值。

显示 使用拖放区域

您可以通过将字段移动到图表工作区内预定义的拖放区域中来更改图表的布局。若要实现上述操作，必须在图表中显示拖放区域。

根据不同的图表类型，拖放区域的显示也不同。例如，对于饼图来说，不会显示系列的拖放区域，因为饼图只包含一个系列。如果绘制多个图表，则可以看到多图表字段的拖放区域，该类型的拖放区域不会为单个图表而显示。

当您将字段移动到拖放区域中覆盖了拖放区域标题后，仍然可以继续向其中拖放其他字段。

显示 将字段移动到分类和系列区域

当将字段移动到系列区域中时，该字段中的唯一数据项将在图表中显示为数据系列。这些数据系列用彩色数据标志表示，其名称显示在图例中。

当将字段移动到分类区域中时，该字段中的唯一数据项将显示为分类或相关的数据组。每个分类由每个数据系列中的一个数据点组成。分类标签通常沿着图表的分类 (X) 轴出现，但因正在使用的图表类型而异。

显示 将字段移动到数据区域中

数据字段提供了要在图表中进行汇总的值。当您将字段移动到数据区域中时，字段的值将被用作在图表中要进行度量的数据。

显示 将字段移动到筛选区域中

筛选字段类似于 Microsoft Excel 数据透视表中的页字段。筛选字段可使视图只显示可用数据中的特定部分。例如，如果将“产品”字段移动到筛选区域，则可以让图表一次只显示某一产品的分类与系列值。

显示 将字段移动到“多图表”区域

如果图表是基于数据透视表列表或是数据库的表或查询中的数据，并且网页设计者已绘制了多个图表，则可以将字段移入和移出“多图表”区域。当将字段移动到“多图表”区域时，该字段中的数据项将成为独立的图表。例如，如果将“销售人员”字段移动到“多图表”区域中，将根据该字段中的数据为每位销售人员创建一个图表。在下面的示例中，“销售人员”字段在“多图表”区域中，但该字段经过了筛选，这样它分别为 Buchanan 和 Davolio 显示独立的图表。

显示 将分类或系列字段移动到内部级或外部级

当图表包含多个系列或分类字段时，最接近数据的字段为内部字段，其他字段为外部字段。在下面的示例中，“年份”为外部字段，而“销售人员”为内部字段。内部字段项显示为销售人员的名称，外部字段项显示为 1997 年和 1998 年。

标注 1 内部字段项

标注 2 外部字段项

您可以展开或折叠多个字段以显示特定字段中的更多或更少信息。例如，在下例中，可以折叠外部字段（年份）使得内部字段项不再显示。

显示 添加和删除字段

图表的布局无需包含源数据中的所有可用字段。如果还有其他可用数据，可以向图表中添加字段。例如，如果图表汇总了销售收入，并且源数据中还包括销售数量，则可以将“销售量”字段作为数据字段添加到图表中，以便同时汇总所销售产品的数量和收入。还可以从图表布局中删除字段，以便不再显示该字段。

显示 对移动和添加字段的限制

如果所用的图表是基于 OLAP 数据库（例如，用 Microsoft SQL Server OLAP Services 创建的数据库）的源数据，您会发现有些字段只能被移动到系列、分类和筛选区域，而且数据区域中的字段不能被移动到其他区域中。

显示 更改筛选布局的影响

移动或删除字段时，筛选设置依旧保留，这意味着当您将系列或分类字段移入或移回筛选区域时，以前隐藏的项将再次隐藏。如果删除某字段，稍后又将该字段重新添加到布局中，则相同的项将再次隐藏。


图表数据字段可用的汇总函数

下表列出了“自动计算”命令 按钮图像 提供的用于汇总数据字段的汇总函数。

函数 | 说明
Sum | 计算数值的和。
Count | 统计值的个数。空值如空字符串（即不包含字符的字符串）包含在计数中，但 null 值（代表丢失或未知数据的值）不包含在内。
Min | 返回进行汇总的字段中的最小值。
Max | 返回进行汇总的字段中的最大值。
Average | 返回进行汇总的字段中的平均值。
标准偏差 | 返回进行汇总的字段中值的标准偏差，假设值是一个较大总体的某个样本。
总体标准偏差 | 返回进行汇总的字段中值的标准偏差，假设值是整个总体。
方差 | 返回进行汇总的字段中值的方差，假设值是一个较大总体的某个样本。
总体方差 | 返回进行汇总的字段中值的方差，假设值是整个总体。

注释 字段可用的汇总函数取决于字段中的数据类型。例如，如果字段包含文本，则该字段只能使用 Count 函数。


关于在图表中筛选数据

如果您正在查看的图表是基于数据库中的数据或是数据透视表列表中的数据，则可以使用筛选功能来查找特定的数据值，或是查找与某个值相匹配的所有数据（如果网页设计者对此没有限制）。

显示 筛选技术

筛选字段（自动筛选） 可以对分类、系列和筛选区域中的字段进行筛选。筛选字段时，在字段中选择要查看的一个或多个数据项，并隐藏其他数据项。

如果您具有大量源数据，但您只关注特定区域的数据，则此时筛选就特别有用。筛选字段时，可以显示单个数据项的数据，或者可以选择显示某些数据项而隐藏其他数据项。可一次对多个字段进行筛选以进一步缩小关注范围。

标注 1 分类字段区域显示所有数据项（未筛选）

标注 2 分类字段区域经过筛选显示“南”和“西”区域中的数据项

条件筛选 可以对系列或数据点应用筛选，以便从总数中选择显示前面或后面的 n 项。例如，可以筛选占有大部分销售额的三个城市或利润最低的五种产品。您也可以按照一定百分比筛选数据项而不是选择 n 项来进行筛选。例如，您可基于已处理订单的数量，筛选出排名前 25% 或后 25% 位的销售人员。如果有 40 位销售人员，经过筛选后就可以看到 10 位销售人员的数据。

显示 组合多个筛选

筛选可以相加。可将所应用的每一个筛选添加到已经起作用的筛选中。

显示 删除和重新应用筛选

关闭自动筛选后可显示所有字段的全部数据。但筛选设置仍然保留，这样在重新启动自动筛选时，以前显示或隐藏的数据将再次显示或隐藏。

当您移动字段更改布局时，筛选设置仍然保留。同样，如果删除某字段，稍后又将该字段重新添加到布局中，则相同的数据项将再次隐藏。

如果不需要保留筛选选项，则请确保在开始选择筛选项之前“自动筛选”按钮 按钮图像 未被选中。如果未选中按钮，则选择新的筛选项将自动启动筛选并删除以前的筛选设置。

显示 识别当前正在起作用的筛选

当字段中的数据项经自动筛选而隐藏时，该字段标签中的下拉箭头 字段箭头 为蓝色。单击该蓝色箭头 蓝色箭头 可查看正在起作用的筛选。


在图表中筛选字段

显示 筛选分类、系列或筛选区域（自动筛选）中的字段

如果筛选区域中没有字段，您可以向其中添加一个新字段，或者从其他区域中移动一个字段到该筛选区域中。
  1. 单击包含要筛选数据项的字段的箭头 字段箭头 。
  2. 选中与需要显示的数据项对应的复选框，清除与需要隐藏的数据项对应的复选框。

注释

  • 若要显示或隐藏某字段中的全部数据，请选中或清除“全部显示”复选框。带阴影的复选框指示隐藏了某些数据项。
  • 当字段位于分类、系列或筛选区域中时，它始终支持多重选定区域。筛选区域中的字段可支持单个选定区域或多重选定区域。

显示 筛选系列或数据点中前面或后面的 n 项值，或按一定的百分比筛选数值（条件筛选）

  1. 选取包含要筛选的数值的系列或数据点。
  2. 在工具栏上，单击“显示最上面/最下面的项目” 按钮图像 。
  3. 指向“仅显示最上面的”或“仅显示最下面的”，再单击所需的数字或百分比。

注释 如果字段中的数据项由自动筛选而隐藏，则字段标签中的箭头 字段箭头 变为蓝色。


取消筛选以显示图表中的所有数据

当字段中的数据项经过筛选而隐藏时，该字段标志中的箭头 字段箭头 为蓝色。

显示 取消所有筛选

  • 单击工具栏上的“自动筛选”按钮 按钮图像 以使其不被选中。

注释 如果再次单击“自动筛选” 按钮图像 以重新启动筛选，则将恢复以前设置的筛选。

显示 取消字段的自动筛选

  1. 单击要取消其筛选的字段的蓝色箭头 蓝色箭头 。
  2. 选中“全部显示”复选框，再单击“确定”。

显示 取消条件筛选

  1. 选取要从中取消条件筛选的系列或数据点。
  2. 单击工具栏上的“显示最上面/最下面的项目” 按钮图像 ，再单击“全部显示”。

注释

  • 如果不需要保留筛选，则请确保在开始选择筛选项之前，“自动筛选”按钮未被选中。如果未选中按钮，则选择新的筛选项将自动启动筛选并删除以前的筛选设置。


展开或折叠字段中的数据项

可以展开或折叠系列字段或分类字段中的数据项，以显示或隐藏某特定数据项的更详细的信息。展开类似于深化，只不过同级的数据项不被隐藏。在本示例中，“西部”被展开以显示有关西部的详细信息，但是仍然显示其他地区的信息，只是没有详细信息。折叠则将删除数据项的详细信息，将图表返回到展开前的状态。

标注 1 显示每一地区销售额的图表

标注 2 “西部”被展开以显示每种产品在“西部”地区的销售额的图表

  1. 单击包含要展开或折叠的数据项的字段。
  2. 在工具栏上，单击“展开” 按钮图像 或“折叠” 按钮图像 。


深化字段中的数据或取消深化

可以深化外部分类字段中的数据项，以集中显示该数据项的详细信息，或者可以取消深化以删除该数据项的详细信息。深化类似于展开，不同之处在于，深化数据项时会隐藏与其平级的其他数据项。

在本示例中，“北部”地区被深化，因而显示了“北部”地区的详细信息，隐藏了其他地区的全部信息。当取消深化某数据项后，该数据项的详细信息会被删除，而与之平级的其他数据项将重新显示。

标注 1 按地区显示产品销售额信息的图表

标注 2 显示被深化的“北部”地区数据项后，图表只显示“北部”地区每种产品的销售额信息。其他地区被隐藏。

  1. 单击要深化或取消深化的分类轴上的数据项。
  2. 在工具栏上，单击“深化数据” 按钮图像 或“取消深化数据” 按钮图像 。


在图表中排序数据

在基于数据透视表列表、数据库的表或查询的图表中，可对其中的分类和系列数据进行排序。

  1. 请执行下列操作之一：
    • 如果要对系列中的数字型数据进行排序，请单击该系列或系列中的某个系列点。
    • 如果要对字段中的数据项按字母顺序进行排序，请单击该分类或系列字段，或者单击分类轴标签或图例项。
  2. 请执行下列操作之一：
    • 单击工具栏上的“升序” 按钮图像 或“降序” 按钮图像 。
    • 对于堆积条形图、堆积面积图或堆积柱形图，如果您要根据整个堆积值的高度而不是单个系列来进行数字排序，请右键单击系列或点，指向“排序”，再单击“按汇总升序排序”或“按汇总降序排序”。


图表疑难解答

显示 图表的左下角出现一个感叹号

被动警告指示图表中包含一个错误。警告显示为图表左下角的感叹号。被动警告出现在错误情况下，例如，无法找到文本文件，或数据库连接失败。单击感叹图标可查看有关错误的更多信息。如果必要，请咨询网页的设计者或系统管理员。

显示 通过 Excel 发布图表后，图表中具有的数据比在 Excel 中时多

在 Microsoft Excel 中，可以指定图表只绘制可见单元格。如果启用此设置，则图表将不会反映创建图表的数据区域中隐藏行或列中的数据。但是发布图表时，所有数据都会反映在图表中。

如果不希望图表反映出隐藏的数据，则应该取消工作表中行或列的隐藏状态，并在发布图表之前将这些数据移动到用于创建图表的数据区域之外。有关在工作表中移动数据的详细信息，请参阅 Excel 的“帮助”。若要在发布后更改图表，则可以取消隐藏并删除行或列（并不希望这些行或列中所包含的数据显示在随图表一起发布的电子表格中）。有关删除行或列的详细信息，请参阅电子表格组件的“帮助”。

显示 通过 Excel 发布图表后，在浏览器中却查看不到数据

若要通过 Microsoft Excel 向 Web 上发布图表，则 XY 散点图必须同时包括 X 值和 Y 值，而气泡图必须同时包括 X 和 Y 值以及气泡的大小值。如果 X 值不在数据选定区域中，则 Excel 会提供默认值。而这些值只会显示在 Excel 的图表中，但在将图表发布到网页上时，这些值不会保留。

如果图表没有包含所有必要的值，那么请在 Excel 中将这些值键入到与图表原始数据相邻的列中，然后重新创建图表，并再次发布该图表。

显示 当我试图显示或刷新 Microsoft Internet Explorer 上的图表，看到提示信息：“该页正在访问其控制范围之外的信息。这有些危险。是否继续?”

您已为网站上的其他域中的图表指定数据源。如果不想被提示，可更改跨域访问数据的方式。有关详细信息，请参阅关于访问不同域中的数据源。

显示 网页上应显示图表的位置却显示为空框

可在 Microsoft Internet Explorer 5.01 SP2 和更高版本中查看 Web 图表并与 Web 图表进行交互。

显示 无法在浏览器中显示图表或与图表进行交互

安装 Microsoft Office Web Components 若要查看和处理 Web 图表，则必须安装 Office Web 组件。可以通过安装 Microsoft Office 2003 来安装该组件；或者，如果用户的公司具有 Microsoft Office 2003 站点许可证，则可通过 Intranet 下载组件。

检查浏览器版本 若要与图表进行交互，还需要具有 Microsoft Internet Explorer 5.01 SP2 或更高版本。建议使用 Internet Explorer 5.01 SP2 或更高版本以充分利用图表的交互式功能及其源数据。

显示 浏览器中的 Web 图表不进行更新

如果通过 Microsoft Excel 发布了图表，则可能是没有选择发布具有交互式功能的图表。如果发布的图表没有交互式功能，则显示在浏览器中的图表将是静态的，并且没有连接到数据上。

若要发布具有交互式功能的图表，请在 Excel 中打开原始工作簿，选择图表，再单击“文件”菜单上的“另存为网页”。在“另存为”对话框中，单击“选择：图表”，并选中“添加交互”复选框。

显示 在 Web 浏览器中单击“编辑”按钮时选择了错误的程序打开网页。

Web 浏览器中的“编辑”按钮所调用的程序取决于页面的发布方式。

如果在 Web 浏览器中单击“编辑”按钮时打开了不希望使用的 Office 程序，那么请关闭此程序，并启动要使用的 Office 程序，然后在此程序中打开网页：

显示 没有针对“命令和选项”对话框的“帮助”

默认情况下，对于运行时模式中的图表（即浏览器中的图表或是显示在自定义应用程序窗体中的图表）不会显示“命令和选项”对话框。因此，涉及“命令和选项”对话框的“帮助”主题将不会包含在运行时“帮助”中。有关使用该对话框的详细信息，请咨询网页的设计者或参阅正在查看的应用程序。

显示 我的三维图表显示为二维图表。

如果正在使用 Microsoft Windows 的版本早于 Windows XP，则可能没有安装 Microsoft DirectX。从 Microsoft.com 下载中心安装 DirectX 便可显示三维图表。