电子表格函数分类

本主题中的部分内容可能不适用于某些语言。

显示 数据库

如果需要对数据清单中的值进行分析以判断其是否满足特定的条件，则可使用数据库电子表格函数。例如，在某个包含销售信息的数据清单中，可以对其中销售量大于 1,000 但小于 2,500 所有行和记录进行计数。

有些数据库和数据清单管理电子表格函数具有以字母 D 开头的函数名。因而，这些函数也称为 D 函数 (Dfunction)，它们都具有三个参数：数据库 (database)、字段 (field) 和条件 (criteria)。

  • 数据库参数表示包含所需数据清单的区域。在该区域中，必须含有包含列标志的行。
  • 参数 field 为需要汇总的列的标志。
  • 条件参数表示包含指定条件的区域。

显示 日期和时间函数

通过日期和时间函数，用户可以在公式中分析和使用日期和时间值。例如，如果需要在公式中使用当前日期，则可使用 TODAY 电子表格函数，此函数将根据计算机的系统时钟返回当前日期。

显示 财务函数

财务函数可执行普通的商务计算，如确定贷款的支付额、投资的未来值或净现值，以及债券或息票的价值。

财务函数的常用参数包括：

  • 未来值 (fv) 在所有付款结束后的投资或贷款的值。
  • 期数 (nper) 投资的付款或周期的总次数。
  • 付款 (pmt) 对于一项投资或贷款的定期支付数额。
  • 现值 (pv) 投资期开始时投资或贷款的值。例如，贷款的现值是借入的本金量。
  • 利率 (rate) 贷款或投资的利率或贴现率。
  • 类型 (type) 付款期内各次付款的间隔，例如，每月的月初或月底。

显示 信息函数

使用信息电子表格函数可确定存储于单元格内的数据的类型。信息函数包括一组称之为 IS 函数的电子表格函数，该类函数在单元格满足条件的情况下返回 TRUE。例如，如果某个单元格中包含数字，则 ISNUMBER 电子表格函数将返回 TRUE。如果需要确定某个单元格区域中是否存在空单元格，则可使用 COUNTBLANK 电子表格函数来计算单元格区域中的空单元格个数，或使用 ISBLANK 电子表格函数以确定区域中是否有某个单元格为空。

显示 逻辑函数

可以使用逻辑函数判断某个条件为真还是为假，或检查多个条件表达式。例如，可以使用 IF 函数判断某个条件表达式为真还是为假：如果条件为真，则返回一个值，如果条件为假，则返回另一个值。

显示 查找函数

如果需要查找数据清单或表中的值，或者如果需要查找单元格的引用，则可以使用查找和引用电子表格函数。例如，如果要通过表格第一列中的值来查找表格中的值，则可使用 VLOOKUP 电子表格函数。如果要确定数据清单中某一值的位置，则可使用 MATCH 电子表格函数。

显示 数学函数

通过数学和三角函数，用户可以执行简单计算（例如，对某一数字进行舍入或计算单元格区域的汇总值）或复杂计算（例如，计算可满足另一单元格区域中条件表达式的某一单元格区域的汇总值）。

显示 统计函数

统计电子表格函数可对数据区域执行统计分析。例如，统计电子表格函数可提供通过一组值绘制的某一直线的统计信息，包括直线的斜率和 Y 轴截距，或有关构成直线的实际点的信息。

显示 文本和数据函数

通过文本函数，用户可以操作公式中的文本串。例如，可以更改大小写或确定文本串的长度。也可以将日期连接或合并到文本串中。下面的公式将使用 TODAY 函数和 TEXT 函数创建一则包含当前日期的消息，同时将日期格式设置为“dd-mmm-yyyy”数字格式。

="Budget report as of "&TEXT(TODAY(),"dd-mmm-yyyy")


在空白电子表格中使用示例

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。


显示或隐藏电子表格工具栏

  1. 在设计窗口中，请确保已激活了电子表格。有关说明，请参阅设计程序的帮助。
  2. 用鼠标右键单击电子表格中的单元格，再在快捷菜单上单击“命令和选项”，然后单击“工作簿”选项卡。
  3. 在“显示/隐藏”下，选中或清除“工具栏”复选框。


DAVERAGE

请参阅

返回清单或数据库中满足指定条件的列中数值的平均值。

语法

DAVERAGE(database,field,criteria)

Database 构成数据清单或数据库的单元格区域。数据库是包含一组相关数据的数据清单，其中包含相关信息的行为记录，而包含数据的列为字段。数据清单的第一行包含着每一列的标志项。

Field 指定函数所使用的数据列。数据清单中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“使用年数”或“产量”；此外，Field 也可以是代表数据清单中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

Criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

显示 示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白工作表
  2. 请在“帮助”主题中选取示例。

    从帮助中选取示例。

  3. 按 Ctrl+C。
  4. 在工作表中，选择单元格 A1，再按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
树种 | 高度 | 使用年数 | 产量 | 利润 | 高度
苹果树 | >10 |  |  |  | <16
梨树 |  |  |  |  |
树种 | 高度 | 使用年数 | 产量 | 利润
苹果树 | 18 | 20 | 14 | 105.00
梨树 | 12 | 12 | 10 | 96.00
樱桃树 | 13 | 14 | 9 | 105.00
苹果树 | 14 | 15 | 10 | 75.00
梨树 | 9 | 8 | 8 | 76.80
苹果树 | 8 | 9 | 6 | 45.00
公式 | 说明（结果）
=DCOUNT(A4:E10,"使用年数",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树的记录，并且计算这些记录中“使用年数”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为 10 到 16 英尺之间的苹果树记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找苹果树和梨树的最大利润。(105)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在 10 英尺以上的苹果树的最小利润。(75)
=DSUM(A4:E10,"利润",A1:A2) | 此函数计算苹果树的总利润。(225)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在 10 到 16 英尺之间的苹果树的总利润。(75)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于 10 英尺的苹果树产量的乘积。(140)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的平均产量。(12)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均使用年数。(13)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，则此值是苹果树和梨树产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，那么此值是苹果树和梨树产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实方差。(7.04)
=DGET(A4:E10,"产量",A1:A3) | 返回错误值 #NUM!，因为有多个记录符合给定的条件。

显示 提示

  • 可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。 例如，如果区域 G1:G2 在 G1 中包含列标志 Income，在 G2 中包含数量 10,000，可将此区域命名为 MatchIncome，那么在数据库函数中就可使用该名称作为参数 criteria。
  • 多数情况下，条件区域不应与数据清单重叠。
  • 若要对数据库的整个列进行操作，请在条件区域的相应列标志下方保留一个空行。

显示 条件示例

显示 单列上具有多个条件

如果对于某一列具有两个或多个筛选条件，那么可直接在各行中从上到下依次键入各个条件。 例如，下面的条件区域显示“销售人员”列中包含“Davolio”、“Buchanan”或“Suyama”的行。

销售人员
Davolio
Buchanan
Suyama

显示 多列上具有单个条件

若要在两列或多列中查找满足单个条件的数据，请在条件区域的同一行中输入所有条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”且“销售额”大于 $1,000 的数据行。

键入 | 销售人员 | 销售
农产品 | Davolio | >1000

显示 某一列或另一列上具有单个条件

若要找到满足一列条件或另一列条件的数据，请在条件区域的不同行中输入条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”或销售额大于 $1,000 的行。

键入 | 销售人员 | 销售
农产品 |  |
 | Davolio |
 |  | >1000

显示 两列上具有两组条件之一

若要找到满足两组条件（每一组条件都包含针对多列的条件）之一的数据行，请在各行中键入条件。例如，下面的条件区域将显示所有在“销售人员”列中包含“Davolio”且销售额大于 $3,000 的行，同时也显示“Buchanan”销售商的销售额大于 $1,500 的行。

销售人员 | 销售
Davolio | >3000
Buchanan | >1500

显示 一列有两组以上条件

若要找到满足两组以上条件的行，请用相同的列标包括多列。例如，下面条件区域显示介于 5,000 和 8,000 之间以及少于 500 的销售额。

销售 | 销售
>5000 | <8000
<500 |

显示 将公式结果用作条件

可以将公式的计算结果作为条件使用。用公式创建条件时，不要将列标志作为条件标记使用，应该将条件标记置空，或者使用清单中非列标志的标记。例如，下面的条件区域显示在列 C 中，其值大于单元格区域 C7:C10 平均值的行。

=C7>AVERAGE($C$7:$C$10)

注释

  • 用作条件的公式必须使用相对引用来引用列标志（例如，“销售”），或者引用第一个记录的对应字段。公式中的所有其他引用都必须是绝对引用，并且公式必须计算出结果 TRUE 或 FALSE。在本公式示例中，C7 引用了数据清单中第一个记录（行 7）的字段（列 C）。

  • 您可以在公式中使用列标志来代替相对的单元格引用或区域名称。当在包含条件的单元格中显示错误值 #NAME? 或 #VALUE! 时，您可以忽略这些错误，因为它们不影响列表的筛选。

  • 评估数据时，与字符的大小写没有区别。


DCOUNT

返回数据库或数据清单的列中满足指定条件并且包含数字的单元格个数。

参数 field 为可选项，如果省略，函数 DCOUNT 返回数据库中满足条件 criteria 的所有记录数。

语法

DCOUNT(database,field,criteria)

Database 构成数据清单或数据库的单元格区域。数据库是包含一组相关数据的数据清单，其中包含相关信息的行为记录，而包含数据的列为字段。数据清单的第一行包含着每一列的标志项。

Field 指定函数所使用的数据列。数据清单中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“使用年数”或“产量”；此外，Field 也可以是代表数据清单中数据列位置的数字：1 表示第一列，2 表示第二列，等等。如果忽略 field，则函数 DCOUNTA 将返回满足条件的所有记录的个数。

Criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

显示 示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白工作表。
  2. 请在“帮助”主题中选取示例。

    从帮助中选取示例。

  3. 按 Ctrl+C。
  4. 在工作表中，选择单元格 A1，再按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
树种 | 高度 | 使用年数 | 产量 | 利润 | 高度
苹果树 | >10 |  |  |  | <16
梨树 |  |  |  |  |
树种 | 高度 | 使用年数 | 产量 | 利润
苹果树 | 18 | 20 | 14 | 105.00
梨树 | 12 | 12 | 10 | 96.00
樱桃树 | 13 | 14 | 9 | 105.00
苹果树 | 14 | 15 | 10 | 75.00
梨树 | 9 | 8 | 8 | 76.80
苹果树 | 8 | 9 | 6 | 45.00
公式 | 说明（结果）
=DCOUNT(A4:E10,"使用年数",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树的记录，并且计算这些记录中“使用年数”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为 10 到 16 英尺之间的苹果树记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找苹果树和梨树的最大利润。(105)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在 10 英尺以上的苹果树的最小利润。(75)
=DSUM(A4:E10,"利润",A1:A2) | 此函数计算苹果树的总利润。(225)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在 10 到 16 英尺之间的苹果树的总利润。(75)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于 10 英尺的苹果树产量的乘积。(140)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的平均产量。(12)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均使用年数。(13)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，则此值是苹果树和梨树产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，那么此值是苹果树和梨树产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实方差。(7.04)
=DGET(A4:E10,"产量",A1:A3) | 返回错误值 #NUM!，因为有多个记录符合给定的条件。

显示 提示

  • 可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。 例如，如果区域 G1:G2 在 G1 中包含列标志 Income，在 G2 中包含数量 10,000，可将此区域命名为 MatchIncome，那么在数据库函数中就可使用该名称作为参数 criteria。
  • 多数情况下，条件区域不应与数据清单重叠。
  • 若要对数据库的整个列进行操作，请在条件区域的相应列标志下方保留一个空行。

显示 条件示例

显示 单列上具有多个条件

如果对于某一列具有两个或多个筛选条件，那么可直接在各行中从上到下依次键入各个条件。 例如，下面的条件区域显示“销售人员”列中包含“Davolio”、“Buchanan”或“Suyama”的行。

销售人员
Davolio
Buchanan
Suyama

显示 多列上具有单个条件

若要在两列或多列中查找满足单个条件的数据，请在条件区域的同一行中输入所有条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”且“销售额”大于 $1,000 的数据行。

键入 | 销售人员 | 销售
农产品 | Davolio | >1000

显示 某一列或另一列上具有单个条件

若要找到满足一列条件或另一列条件的数据，请在条件区域的不同行中输入条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”或销售额大于 $1,000 的行。

键入 | 销售人员 | 销售
农产品 |  |
 | Davolio |
 |  | >1000

显示 两列上具有两组条件之一

若要找到满足两组条件（每一组条件都包含针对多列的条件）之一的数据行，请在各行中键入条件。例如，下面的条件区域将显示所有在“销售人员”列中包含“Davolio”且销售额大于 $3,000 的行，同时也显示“Buchanan”销售商的销售额大于 $1,500 的行。

销售人员 | 销售
Davolio | >3000
Buchanan | >1500

显示 一列有两组以上条件

若要找到满足两组以上条件的行，请用相同的列标包括多列。例如，下面条件区域显示介于 5,000 和 8,000 之间以及少于 500 的销售额。

销售 | 销售
>5000 | <8000
<500 |

显示 将公式结果用作条件

可以将公式的计算结果作为条件使用。用公式创建条件时，不要将列标志作为条件标记使用，应该将条件标记置空，或者使用清单中非列标志的标记。例如，下面的条件区域显示在列 C 中，其值大于单元格区域 C7:C10 平均值的行。

=C7>AVERAGE($C$7:$C$10)

注释

  • 用作条件的公式必须使用相对引用来引用列标志（例如，“销售”），或者引用第一个记录的对应字段。公式中的所有其他引用都必须是绝对引用，并且公式必须计算出结果 TRUE 或 FALSE。在本公式示例中，C7 引用了数据清单中第一个记录（行 7）的字段（列 C）。

  • 您可以在公式中使用列标志来代替相对的单元格引用或区域名称。当在包含条件的单元格中显示错误值 #NAME? 或 #VALUE! 时，您可以忽略这些错误，因为它们不影响列表的筛选。

  • 评估数据时，与字符的大小写没有区别。


DCOUNTA

返回数据库或数据清单的列中满足指定条件的非空单元格个数。

参数 Field 为可选项。如果省略，则函数 DCOUNTA 将返回数据库中满足条件的所有记录数。

语法

DCOUNTA(database,field,criteria)

Database 构成数据清单或数据库的单元格区域。数据库是包含一组相关数据的数据清单，其中包含相关信息的行为记录，而包含数据的列为字段。数据清单的第一行包含着每一列的标志项。

Field 指定函数所使用的数据列。Field 可以是文本，即两端带双引号的列标志，如“使用年数”或“产量”；此外，Field 也可以是代表数据清单中数据列位置的数字：1 表示第一列，2 表示第二列，等等。如果忽略 field，则函数 DCOUNTA 将返回满足条件的所有记录的个数。如果包含 field，则 DCOUNTA 只会返回在 field 中有值且满足条件的记录数。

Criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

显示 示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从帮助中选取示例。

  3. 按 Ctrl+C。
  4. 在工作表中，选择单元格 A1，再按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
树种 | 高度 | 使用年数 | 产量 | 利润 | 高度
苹果树 | >10 |  |  |  | <16
梨树 |  |  |  |  |
树种 | 高度 | 使用年数 | 产量 | 利润
苹果树 | 18 | 20 | 14 | 105.00
梨树 | 12 | 12 | 10 | 96.00
樱桃树 | 13 | 14 | 9 | 105.00
苹果树 | 14 | 15 | 10 | 75.00
梨树 | 9 | 8 | 8 | 76.80
苹果树 | 8 | 9 | 6 | 45.00
公式 | 说明（结果）
=DCOUNT(A4:E10,"使用年数",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树的记录，并且计算这些记录中“使用年数”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为 10 到 16 英尺之间的苹果树记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找苹果树和梨树的最大利润。(105)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在 10 英尺以上的苹果树的最小利润。(75)
=DSUM(A4:E10,"利润",A1:A2) | 此函数计算苹果树的总利润。(225)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在 10 到 16 英尺之间的苹果树的总利润。(75)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于 10 英尺的苹果树产量的乘积。(140)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的平均产量。(12)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均使用年数。(13)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，则此值是苹果树和梨树产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，那么此值是苹果树和梨树产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实方差。(7.04)
=DGET(A4:E10,"产量",A1:A3) | 返回错误值 #NUM!，因为有多个记录符合给定的条件。

显示 提示

  • 可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。 例如，如果区域 G1:G2 在 G1 中包含列标志 Income，在 G2 中包含数量 10,000，可将此区域命名为 MatchIncome，那么在数据库函数中就可使用该名称作为参数 criteria。
  • 多数情况下，条件区域不应与数据清单重叠。
  • 若要对数据库的整个列进行操作，请在条件区域的相应列标志下方保留一个空行。

显示 条件示例

显示 单列上具有多个条件

如果对于某一列具有两个或多个筛选条件，那么可直接在各行中从上到下依次键入各个条件。 例如，下面的条件区域显示“销售人员”列中包含“Davolio”、“Buchanan”或“Suyama”的行。

销售人员
Davolio
Buchanan
Suyama

显示 多列上具有单个条件

若要在两列或多列中查找满足单个条件的数据，请在条件区域的同一行中输入所有条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”且“销售额”大于 $1,000 的数据行。

键入 | 销售人员 | 销售
农产品 | Davolio | >1000

显示 某一列或另一列上具有单个条件

若要找到满足一列条件或另一列条件的数据，请在条件区域的不同行中输入条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”或销售额大于 $1,000 的行。

键入 | 销售人员 | 销售
农产品 |  |
 | Davolio |
 |  | >1000

显示 两列上具有两组条件之一

若要找到满足两组条件（每一组条件都包含针对多列的条件）之一的数据行，请在各行中键入条件。例如，下面的条件区域将显示所有在“销售人员”列中包含“Davolio”且销售额大于 $3,000 的行，同时也显示“Buchanan”销售商的销售额大于 $1,500 的行。

销售人员 | 销售
Davolio | >3000
Buchanan | >1500

显示 一列有两组以上条件

若要找到满足两组以上条件的行，请用相同的列标包括多列。例如，下面条件区域显示介于 5,000 和 8,000 之间以及少于 500 的销售额。

销售 | 销售
>5000 | <8000
<500 |

显示 将公式结果用作条件

可以将公式的计算结果作为条件使用。用公式创建条件时，不要将列标志作为条件标记使用，应该将条件标记置空，或者使用清单中非列标志的标记。例如，下面的条件区域显示在列 C 中，其值大于单元格区域 C7:C10 平均值的行。

=C7>AVERAGE($C$7:$C$10)

注释

  • 用作条件的公式必须使用相对引用来引用列标志（例如，“销售”），或者引用第一个记录的对应字段。公式中的所有其他引用都必须是绝对引用，并且公式必须计算出结果 TRUE 或 FALSE。在本公式示例中，C7 引用了数据清单中第一个记录（行 7）的字段（列 C）。

  • 您可以在公式中使用列标志来代替相对的单元格引用或区域名称。当在包含条件的单元格中显示错误值 #NAME? 或 #VALUE! 时，您可以忽略这些错误，因为它们不影响列表的筛选。

  • 评估数据时，与字符的大小写没有区别。


DGET

从数据清单或数据库的列中提取符合指定条件的单个值。

语法

DGET(database,field,criteria)

Database 构成数据清单或数据库的单元格区域。数据库是包含一组相关数据的数据清单，其中包含相关信息的行为记录，而包含数据的列为字段。数据清单的第一行包含着每一列的标志项。

Field 指定函数所使用的数据列。数据清单中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“使用年数”或“产量”；此外，Field 也可以是代表数据清单中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

Criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

说明

  • 如果没有满足条件的记录，则函数 DGET 将返回错误值 #VALUE!。
  • 如果有多个记录满足条件，则函数 DGET 将返回错误值 #NUM!。

显示 示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从帮助中选取示例。

  3. 按 Ctrl+C。
  4. 在工作表中，选择单元格 A1，再按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
树种 | 高度 | 使用年数 | 产量 | 利润 | 高度
苹果树 | >10 |  |  |  | <16
梨树 |  |  |  |  |
树种 | 高度 | 使用年数 | 产量 | 利润
苹果树 | 18 | 20 | 14 | 105.00
梨树 | 12 | 12 | 10 | 96.00
樱桃树 | 13 | 14 | 9 | 105.00
苹果树 | 14 | 15 | 10 | 75.00
梨树 | 9 | 8 | 8 | 76.80
苹果树 | 8 | 9 | 6 | 45.00
公式 | 说明（结果）
=DCOUNT(A4:E10,"使用年数",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树的记录，并且计算这些记录中“使用年数”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为 10 到 16 英尺之间的苹果树记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找苹果树和梨树的最大利润。(105)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在 10 英尺以上的苹果树的最小利润。(75)
=DSUM(A4:E10,"利润",A1:A2) | 此函数计算苹果树的总利润。(225)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在 10 到 16 英尺之间的苹果树的总利润。(75)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于 10 英尺的苹果树产量的乘积。(140)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的平均产量。(12)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均使用年数。(13)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，则此值是苹果树和梨树产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，那么此值是苹果树和梨树产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实方差。(7.04)
=DGET(A4:E10,"产量",A1:A3) | 返回错误值 #NUM!，因为有多个记录符合给定的条件。

显示 提示

  • 可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。 例如，如果区域 G1:G2 在 G1 中包含列标志 Income，在 G2 中包含数量 10,000，可将此区域命名为 MatchIncome，那么在数据库函数中就可使用该名称作为参数 criteria。
  • 多数情况下，条件区域不应与数据清单重叠。
  • 若要对数据库的整个列进行操作，请在条件区域的相应列标志下方保留一个空行。

显示 条件示例

显示 单列上具有多个条件

如果对于某一列具有两个或多个筛选条件，那么可直接在各行中从上到下依次键入各个条件。 例如，下面的条件区域显示“销售人员”列中包含“Davolio”、“Buchanan”或“Suyama”的行。

销售人员
Davolio
Buchanan
Suyama

显示 多列上具有单个条件

若要在两列或多列中查找满足单个条件的数据，请在条件区域的同一行中输入所有条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”且“销售额”大于 $1,000 的数据行。

键入 | 销售人员 | 销售
农产品 | Davolio | >1000

显示 某一列或另一列上具有单个条件

若要找到满足一列条件或另一列条件的数据，请在条件区域的不同行中输入条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”或销售额大于 $1,000 的行。

键入 | 销售人员 | 销售
农产品 |  |
 | Davolio |
 |  | >1000

显示 两列上具有两组条件之一

若要找到满足两组条件（每一组条件都包含针对多列的条件）之一的数据行，请在各行中键入条件。例如，下面的条件区域将显示所有在“销售人员”列中包含“Davolio”且销售额大于 $3,000 的行，同时也显示“Buchanan”销售商的销售额大于 $1,500 的行。

销售人员 | 销售
Davolio | >3000
Buchanan | >1500

显示 一列有两组以上条件

若要找到满足两组以上条件的行，请用相同的列标包括多列。例如，下面条件区域显示介于 5,000 和 8,000 之间以及少于 500 的销售额。

销售 | 销售
>5000 | <8000
<500 |

显示 将公式结果用作条件

可以将公式的计算结果作为条件使用。用公式创建条件时，不要将列标志作为条件标记使用，应该将条件标记置空，或者使用清单中非列标志的标记。例如，下面的条件区域显示在列 C 中，其值大于单元格区域 C7:C10 平均值的行。

=C7>AVERAGE($C$7:$C$10)

注释

  • 用作条件的公式必须使用相对引用来引用列标志（例如，“销售”），或者引用第一个记录的对应字段。公式中的所有其他引用都必须是绝对引用，并且公式必须计算出结果 TRUE 或 FALSE。在本公式示例中，C7 引用了数据清单中第一个记录（行 7）的字段（列 C）。

  • 您可以在公式中使用列标志来代替相对的单元格引用或区域名称。当在包含条件的单元格中显示错误值 #NAME? 或 #VALUE! 时，您可以忽略这些错误，因为它们不影响列表的筛选。

  • 评估数据时，与字符的大小写没有区别。


DMAX

返回数据清单或数据库的列中满足指定条件的最大数值。

语法

DMAX(database,field,criteria)

Database 构成数据清单或数据库的单元格区域。数据库是包含一组相关数据的数据清单，其中包含相关信息的行为记录，而包含数据的列为字段。数据清单的第一行包含着每一列的标志项。

Field 指定函数所使用的数据列。数据清单中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“使用年数”或“产量”；此外，Field 也可以是代表数据清单中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

Criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

显示 示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从帮助中选取示例。

  3. 按 Ctrl+C。
  4. 在工作表中，选择单元格 A1，再按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
树种 | 高度 | 使用年数 | 产量 | 利润 | 高度
苹果树 | >10 |  |  |  | <16
梨树 |  |  |  |  |
树种 | 高度 | 使用年数 | 产量 | 利润
苹果树 | 18 | 20 | 14 | 105.00
梨树 | 12 | 12 | 10 | 96.00
樱桃树 | 13 | 14 | 9 | 105.00
苹果树 | 14 | 15 | 10 | 75.00
梨树 | 9 | 8 | 8 | 76.80
苹果树 | 8 | 9 | 6 | 45.00
公式 | 说明（结果）
=DCOUNT(A4:E10,"使用年数",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树的记录，并且计算这些记录中“使用年数”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为 10 到 16 英尺之间的苹果树记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找苹果树和梨树的最大利润。(105)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在 10 英尺以上的苹果树的最小利润。(75)
=DSUM(A4:E10,"利润",A1:A2) | 此函数计算苹果树的总利润。(225)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在 10 到 16 英尺之间的苹果树的总利润。(75)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于 10 英尺的苹果树产量的乘积。(140)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的平均产量。(12)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均使用年数。(13)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，则此值是苹果树和梨树产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，那么此值是苹果树和梨树产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实方差。(7.04)
=DGET(A4:E10,"产量",A1:A3) | 返回错误值 #NUM!，因为有多个记录符合给定的条件。

显示 提示

  • 可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。 例如，如果区域 G1:G2 在 G1 中包含列标志 Income，在 G2 中包含数量 10,000，可将此区域命名为 MatchIncome，那么在数据库函数中就可使用该名称作为参数 criteria。
  • 多数情况下，条件区域不应与数据清单重叠。
  • 若要对数据库的整个列进行操作，请在条件区域的相应列标志下方保留一个空行。

显示 条件示例

显示 单列上具有多个条件

如果对于某一列具有两个或多个筛选条件，那么可直接在各行中从上到下依次键入各个条件。 例如，下面的条件区域显示“销售人员”列中包含“Davolio”、“Buchanan”或“Suyama”的行。

销售人员
Davolio
Buchanan
Suyama

显示 多列上具有单个条件

若要在两列或多列中查找满足单个条件的数据，请在条件区域的同一行中输入所有条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”且“销售额”大于 $1,000 的数据行。

键入 | 销售人员 | 销售
农产品 | Davolio | >1000

显示 某一列或另一列上具有单个条件

若要找到满足一列条件或另一列条件的数据，请在条件区域的不同行中输入条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”或销售额大于 $1,000 的行。

键入 | 销售人员 | 销售
农产品 |  |
 | Davolio |
 |  | >1000

显示 两列上具有两组条件之一

若要找到满足两组条件（每一组条件都包含针对多列的条件）之一的数据行，请在各行中键入条件。例如，下面的条件区域将显示所有在“销售人员”列中包含“Davolio”且销售额大于 $3,000 的行，同时也显示“Buchanan”销售商的销售额大于 $1,500 的行。

销售人员 | 销售
Davolio | >3000
Buchanan | >1500

显示 一列有两组以上条件

若要找到满足两组以上条件的行，请用相同的列标包括多列。例如，下面条件区域显示介于 5,000 和 8,000 之间以及少于 500 的销售额。

销售 | 销售
>5000 | <8000
<500 |

显示 将公式结果用作条件

可以将公式的计算结果作为条件使用。用公式创建条件时，不要将列标志作为条件标记使用，应该将条件标记置空，或者使用清单中非列标志的标记。例如，下面的条件区域显示在列 C 中，其值大于单元格区域 C7:C10 平均值的行。

=C7>AVERAGE($C$7:$C$10)

注释

  • 用作条件的公式必须使用相对引用来引用列标志（例如，“销售”），或者引用第一个记录的对应字段。公式中的所有其他引用都必须是绝对引用，并且公式必须计算出结果 TRUE 或 FALSE。在本公式示例中，C7 引用了数据清单中第一个记录（行 7）的字段（列 C）。

  • 您可以在公式中使用列标志来代替相对的单元格引用或区域名称。当在包含条件的单元格中显示错误值 #NAME? 或 #VALUE! 时，您可以忽略这些错误，因为它们不影响列表的筛选。

  • 评估数据时，与字符的大小写没有区别。


DMIN

返回数据清单或数据库的列中满足指定条件的最小数字。

语法

DMIN(database,field,criteria)

Database 构成数据清单或数据库的单元格区域。数据库是包含一组相关数据的数据清单，其中包含相关信息的行为记录，而包含数据的列为字段。数据清单的第一行包含着每一列的标志项。

Field 指定函数所使用的数据列。数据清单中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“使用年数”或“产量”；此外，Field 也可以是代表数据清单中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

Criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

显示 示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从帮助中选取示例。

  3. 按 Ctrl+C。
  4. 在工作表中，选择单元格 A1，再按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
树种 | 高度 | 使用年数 | 产量 | 利润 | 高度
苹果树 | >10 |  |  |  | <16
梨树 |  |  |  |  |
树种 | 高度 | 使用年数 | 产量 | 利润
苹果树 | 18 | 20 | 14 | 105.00
梨树 | 12 | 12 | 10 | 96.00
樱桃树 | 13 | 14 | 9 | 105.00
苹果树 | 14 | 15 | 10 | 75.00
梨树 | 9 | 8 | 8 | 76.80
苹果树 | 8 | 9 | 6 | 45.00
公式 | 说明（结果）
=DCOUNT(A4:E10,"使用年数",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树的记录，并且计算这些记录中“使用年数”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为 10 到 16 英尺之间的苹果树记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找苹果树和梨树的最大利润。(105)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在 10 英尺以上的苹果树的最小利润。(75)
=DSUM(A4:E10,"利润",A1:A2) | 此函数计算苹果树的总利润。(225)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在 10 到 16 英尺之间的苹果树的总利润。(75)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于 10 英尺的苹果树产量的乘积。(140)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的平均产量。(12)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均使用年数。(13)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，则此值是苹果树和梨树产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，那么此值是苹果树和梨树产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实方差。(7.04)
=DGET(A4:E10,"产量",A1:A3) | 返回错误值 #NUM!，因为有多个记录符合给定的条件。

显示 提示

  • 可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。 例如，如果区域 G1:G2 在 G1 中包含列标志 Income，在 G2 中包含数量 10,000，可将此区域命名为 MatchIncome，那么在数据库函数中就可使用该名称作为参数 criteria。
  • 多数情况下，条件区域不应与数据清单重叠。
  • 若要对数据库的整个列进行操作，请在条件区域的相应列标志下方保留一个空行。

显示 条件示例

显示 单列上具有多个条件

如果对于某一列具有两个或多个筛选条件，那么可直接在各行中从上到下依次键入各个条件。 例如，下面的条件区域显示“销售人员”列中包含“Davolio”、“Buchanan”或“Suyama”的行。

销售人员
Davolio
Buchanan
Suyama

显示 多列上具有单个条件

若要在两列或多列中查找满足单个条件的数据，请在条件区域的同一行中输入所有条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”且“销售额”大于 $1,000 的数据行。

键入 | 销售人员 | 销售
农产品 | Davolio | >1000

显示 某一列或另一列上具有单个条件

若要找到满足一列条件或另一列条件的数据，请在条件区域的不同行中输入条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”或销售额大于 $1,000 的行。

键入 | 销售人员 | 销售
农产品 |  |
 | Davolio |
 |  | >1000

显示 两列上具有两组条件之一

若要找到满足两组条件（每一组条件都包含针对多列的条件）之一的数据行，请在各行中键入条件。例如，下面的条件区域将显示所有在“销售人员”列中包含“Davolio”且销售额大于 $3,000 的行，同时也显示“Buchanan”销售商的销售额大于 $1,500 的行。

销售人员 | 销售
Davolio | >3000
Buchanan | >1500

显示 一列有两组以上条件

若要找到满足两组以上条件的行，请用相同的列标包括多列。例如，下面条件区域显示介于 5,000 和 8,000 之间以及少于 500 的销售额。

销售 | 销售
>5000 | <8000
<500 |

显示 将公式结果用作条件

可以将公式的计算结果作为条件使用。用公式创建条件时，不要将列标志作为条件标记使用，应该将条件标记置空，或者使用清单中非列标志的标记。例如，下面的条件区域显示在列 C 中，其值大于单元格区域 C7:C10 平均值的行。

=C7>AVERAGE($C$7:$C$10)

注释

  • 用作条件的公式必须使用相对引用来引用列标志（例如，“销售”），或者引用第一个记录的对应字段。公式中的所有其他引用都必须是绝对引用，并且公式必须计算出结果 TRUE 或 FALSE。在本公式示例中，C7 引用了数据清单中第一个记录（行 7）的字段（列 C）。

  • 您可以在公式中使用列标志来代替相对的单元格引用或区域名称。当在包含条件的单元格中显示错误值 #NAME? 或 #VALUE! 时，您可以忽略这些错误，因为它们不影响列表的筛选。

  • 评估数据时，与字符的大小写没有区别。


DPRODUCT

返回数据清单或数据库的列中满足指定条件的数值的乘积。

语法

DPRODUCT(database,field,criteria)

Database 构成数据清单或数据库的单元格区域。数据库是包含一组相关数据的数据清单，其中包含相关信息的行为记录，而包含数据的列为字段。数据清单的第一行包含着每一列的标志项。

Field 指定函数所使用的数据列。数据清单中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“使用年数”或“产量”；此外，Field 也可以是代表数据清单中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

Criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

显示 示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从帮助中选取示例。

  3. 按 Ctrl+C。
  4. 在工作表中，选择单元格 A1，再按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
树种 | 高度 | 使用年数 | 产量 | 利润 | 高度
苹果树 | >10 |  |  |  | <16
梨树 |  |  |  |  |
树种 | 高度 | 使用年数 | 产量 | 利润
苹果树 | 18 | 20 | 14 | 105.00
梨树 | 12 | 12 | 10 | 96.00
樱桃树 | 13 | 14 | 9 | 105.00
苹果树 | 14 | 15 | 10 | 75.00
梨树 | 9 | 8 | 8 | 76.80
苹果树 | 8 | 9 | 6 | 45.00
公式 | 说明（结果）
=DCOUNT(A4:E10,"使用年数",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树的记录，并且计算这些记录中“使用年数”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为 10 到 16 英尺之间的苹果树记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找苹果树和梨树的最大利润。(105)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在 10 英尺以上的苹果树的最小利润。(75)
=DSUM(A4:E10,"利润",A1:A2) | 此函数计算苹果树的总利润。(225)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在 10 到 16 英尺之间的苹果树的总利润。(75)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于 10 英尺的苹果树产量的乘积。(140)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的平均产量。(12)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均使用年数。(13)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，则此值是苹果树和梨树产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，那么此值是苹果树和梨树产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实方差。(7.04)
=DGET(A4:E10,"产量",A1:A3) | 返回错误值 #NUM!，因为有多个记录符合给定的条件。

显示 提示

  • 可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。 例如，如果区域 G1:G2 在 G1 中包含列标志 Income，在 G2 中包含数量 10,000，可将此区域命名为 MatchIncome，那么在数据库函数中就可使用该名称作为参数 criteria。
  • 多数情况下，条件区域不应与数据清单重叠。
  • 若要对数据库的整个列进行操作，请在条件区域的相应列标志下方保留一个空行。

显示 条件示例

显示 单列上具有多个条件

如果对于某一列具有两个或多个筛选条件，那么可直接在各行中从上到下依次键入各个条件。 例如，下面的条件区域显示“销售人员”列中包含“Davolio”、“Buchanan”或“Suyama”的行。

销售人员
Davolio
Buchanan
Suyama

显示 多列上具有单个条件

若要在两列或多列中查找满足单个条件的数据，请在条件区域的同一行中输入所有条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”且“销售额”大于 $1,000 的数据行。

键入 | 销售人员 | 销售
农产品 | Davolio | >1000

显示 某一列或另一列上具有单个条件

若要找到满足一列条件或另一列条件的数据，请在条件区域的不同行中输入条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”或销售额大于 $1,000 的行。

键入 | 销售人员 | 销售
农产品 |  |
 | Davolio |
 |  | >1000

显示 两列上具有两组条件之一

若要找到满足两组条件（每一组条件都包含针对多列的条件）之一的数据行，请在各行中键入条件。例如，下面的条件区域将显示所有在“销售人员”列中包含“Davolio”且销售额大于 $3,000 的行，同时也显示“Buchanan”销售商的销售额大于 $1,500 的行。

销售人员 | 销售
Davolio | >3000
Buchanan | >1500

显示 一列有两组以上条件

若要找到满足两组以上条件的行，请用相同的列标包括多列。例如，下面条件区域显示介于 5,000 和 8,000 之间以及少于 500 的销售额。

销售 | 销售
>5000 | <8000
<500 |

显示 将公式结果用作条件

可以将公式的计算结果作为条件使用。用公式创建条件时，不要将列标志作为条件标记使用，应该将条件标记置空，或者使用清单中非列标志的标记。例如，下面的条件区域显示在列 C 中，其值大于单元格区域 C7:C10 平均值的行。

=C7>AVERAGE($C$7:$C$10)

注释

  • 用作条件的公式必须使用相对引用来引用列标志（例如，“销售”），或者引用第一个记录的对应字段。公式中的所有其他引用都必须是绝对引用，并且公式必须计算出结果 TRUE 或 FALSE。在本公式示例中，C7 引用了数据清单中第一个记录（行 7）的字段（列 C）。

  • 您可以在公式中使用列标志来代替相对的单元格引用或区域名称。当在包含条件的单元格中显示错误值 #NAME? 或 #VALUE! 时，您可以忽略这些错误，因为它们不影响列表的筛选。

  • 评估数据时，与字符的大小写没有区别。


DSTDEV

将数据清单或数据库的列中满足指定条件的数字作为一个样本，估算样本总体的标准偏差。

语法

DSTDEV(database,field,criteria)

Database 构成数据清单或数据库的单元格区域。数据库是包含一组相关数据的数据清单，其中包含相关信息的行为记录，而包含数据的列为字段。数据清单的第一行包含着每一列的标志项。

Field 指定函数所使用的数据列。数据清单中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“使用年数”或“产量”；此外，Field 也可以是代表数据清单中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

Criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

显示 示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从帮助中选取示例。

  3. 按 Ctrl+C。
  4. 在工作表中，选择单元格 A1，再按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
树种 | 高度 | 使用年数 | 产量 | 利润 | 高度
苹果树 | >10 |  |  |  | <16
梨树 |  |  |  |  |
树种 | 高度 | 使用年数 | 产量 | 利润
苹果树 | 18 | 20 | 14 | 105.00
梨树 | 12 | 12 | 10 | 96.00
樱桃树 | 13 | 14 | 9 | 105.00
苹果树 | 14 | 15 | 10 | 75.00
梨树 | 9 | 8 | 8 | 76.80
苹果树 | 8 | 9 | 6 | 45.00
公式 | 说明（结果）
=DCOUNT(A4:E10,"使用年数",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树的记录，并且计算这些记录中“使用年数”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为 10 到 16 英尺之间的苹果树记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找苹果树和梨树的最大利润。(105)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在 10 英尺以上的苹果树的最小利润。(75)
=DSUM(A4:E10,"利润",A1:A2) | 此函数计算苹果树的总利润。(225)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在 10 到 16 英尺之间的苹果树的总利润。(75)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于 10 英尺的苹果树产量的乘积。(140)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的平均产量。(12)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均使用年数。(13)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，则此值是苹果树和梨树产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，那么此值是苹果树和梨树产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实方差。(7.04)
=DGET(A4:E10,"产量",A1:A3) | 返回错误值 #NUM!，因为有多个记录符合给定的条件。

显示 提示

  • 可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。 例如，如果区域 G1:G2 在 G1 中包含列标志 Income，在 G2 中包含数量 10,000，可将此区域命名为 MatchIncome，那么在数据库函数中就可使用该名称作为参数 criteria。
  • 多数情况下，条件区域不应与数据清单重叠。
  • 若要对数据库的整个列进行操作，请在条件区域的相应列标志下方保留一个空行。

显示 条件示例

显示 单列上具有多个条件

如果对于某一列具有两个或多个筛选条件，那么可直接在各行中从上到下依次键入各个条件。 例如，下面的条件区域显示“销售人员”列中包含“Davolio”、“Buchanan”或“Suyama”的行。

销售人员
Davolio
Buchanan
Suyama

显示 多列上具有单个条件

若要在两列或多列中查找满足单个条件的数据，请在条件区域的同一行中输入所有条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”且“销售额”大于 $1,000 的数据行。

键入 | 销售人员 | 销售
农产品 | Davolio | >1000

显示 某一列或另一列上具有单个条件

若要找到满足一列条件或另一列条件的数据，请在条件区域的不同行中输入条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”或销售额大于 $1,000 的行。

键入 | 销售人员 | 销售
农产品 |  |
 | Davolio |
 |  | >1000

显示 两列上具有两组条件之一

若要找到满足两组条件（每一组条件都包含针对多列的条件）之一的数据行，请在各行中键入条件。例如，下面的条件区域将显示所有在“销售人员”列中包含“Davolio”且销售额大于 $3,000 的行，同时也显示“Buchanan”销售商的销售额大于 $1,500 的行。

销售人员 | 销售
Davolio | >3000
Buchanan | >1500

显示 一列有两组以上条件

若要找到满足两组以上条件的行，请用相同的列标包括多列。例如，下面条件区域显示介于 5,000 和 8,000 之间以及少于 500 的销售额。

销售 | 销售
>5000 | <8000
<500 |

显示 将公式结果用作条件

可以将公式的计算结果作为条件使用。用公式创建条件时，不要将列标志作为条件标记使用，应该将条件标记置空，或者使用清单中非列标志的标记。例如，下面的条件区域显示在列 C 中，其值大于单元格区域 C7:C10 平均值的行。

=C7>AVERAGE($C$7:$C$10)

注释

  • 用作条件的公式必须使用相对引用来引用列标志（例如，“销售”），或者引用第一个记录的对应字段。公式中的所有其他引用都必须是绝对引用，并且公式必须计算出结果 TRUE 或 FALSE。在本公式示例中，C7 引用了数据清单中第一个记录（行 7）的字段（列 C）。

  • 您可以在公式中使用列标志来代替相对的单元格引用或区域名称。当在包含条件的单元格中显示错误值 #NAME? 或 #VALUE! 时，您可以忽略这些错误，因为它们不影响列表的筛选。

  • 评估数据时，与字符的大小写没有区别。


DSTDEVP

将数据清单或数据库的列中满足指定条件的数字作为样本总体，计算总体的标准偏差。

语法

DSTDEVP(database,field,criteria)

Database 构成数据清单或数据库的单元格区域。数据库是包含一组相关数据的数据清单，其中包含相关信息的行为记录，而包含数据的列为字段。数据清单的第一行包含着每一列的标志项。

Field 指定函数所使用的数据列。数据清单中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“使用年数”或“产量”；此外，Field 也可以是代表数据清单中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

Criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

显示 示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从帮助中选取示例。

  3. 按 Ctrl+C。
  4. 在工作表中，选择单元格 A1，再按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
树种 | 高度 | 使用年数 | 产量 | 利润 | 高度
苹果树 | >10 |  |  |  | <16
梨树 |  |  |  |  |
树种 | 高度 | 使用年数 | 产量 | 利润
苹果树 | 18 | 20 | 14 | 105.00
梨树 | 12 | 12 | 10 | 96.00
樱桃树 | 13 | 14 | 9 | 105.00
苹果树 | 14 | 15 | 10 | 75.00
梨树 | 9 | 8 | 8 | 76.80
苹果树 | 8 | 9 | 6 | 45.00
公式 | 说明（结果）
=DCOUNT(A4:E10,"使用年数",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树的记录，并且计算这些记录中“使用年数”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为 10 到 16 英尺之间的苹果树记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找苹果树和梨树的最大利润。(105)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在 10 英尺以上的苹果树的最小利润。(75)
=DSUM(A4:E10,"利润",A1:A2) | 此函数计算苹果树的总利润。(225)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在 10 到 16 英尺之间的苹果树的总利润。(75)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于 10 英尺的苹果树产量的乘积。(140)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的平均产量。(12)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均使用年数。(13)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，则此值是苹果树和梨树产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，那么此值是苹果树和梨树产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实方差。(7.04)
=DGET(A4:E10,"产量",A1:A3) | 返回错误值 #NUM!，因为有多个记录符合给定的条件。

显示 提示

  • 可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。 例如，如果区域 G1:G2 在 G1 中包含列标志 Income，在 G2 中包含数量 10,000，可将此区域命名为 MatchIncome，那么在数据库函数中就可使用该名称作为参数 criteria。
  • 多数情况下，条件区域不应与数据清单重叠。
  • 若要对数据库的整个列进行操作，请在条件区域的相应列标志下方保留一个空行。

显示 条件示例

显示 单列上具有多个条件

如果对于某一列具有两个或多个筛选条件，那么可直接在各行中从上到下依次键入各个条件。 例如，下面的条件区域显示“销售人员”列中包含“Davolio”、“Buchanan”或“Suyama”的行。

销售人员
Davolio
Buchanan
Suyama

显示 多列上具有单个条件

若要在两列或多列中查找满足单个条件的数据，请在条件区域的同一行中输入所有条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”且“销售额”大于 $1,000 的数据行。

键入 | 销售人员 | 销售
农产品 | Davolio | >1000

显示 某一列或另一列上具有单个条件

若要找到满足一列条件或另一列条件的数据，请在条件区域的不同行中输入条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”或销售额大于 $1,000 的行。

键入 | 销售人员 | 销售
农产品 |  |
 | Davolio |
 |  | >1000

显示 两列上具有两组条件之一

若要找到满足两组条件（每一组条件都包含针对多列的条件）之一的数据行，请在各行中键入条件。例如，下面的条件区域将显示所有在“销售人员”列中包含“Davolio”且销售额大于 $3,000 的行，同时也显示“Buchanan”销售商的销售额大于 $1,500 的行。

销售人员 | 销售
Davolio | >3000
Buchanan | >1500

显示 一列有两组以上条件

若要找到满足两组以上条件的行，请用相同的列标包括多列。例如，下面条件区域显示介于 5,000 和 8,000 之间以及少于 500 的销售额。

销售 | 销售
>5000 | <8000
<500 |

显示 将公式结果用作条件

可以将公式的计算结果作为条件使用。用公式创建条件时，不要将列标志作为条件标记使用，应该将条件标记置空，或者使用清单中非列标志的标记。例如，下面的条件区域显示在列 C 中，其值大于单元格区域 C7:C10 平均值的行。

=C7>AVERAGE($C$7:$C$10)

注释

  • 用作条件的公式必须使用相对引用来引用列标志（例如，“销售”），或者引用第一个记录的对应字段。公式中的所有其他引用都必须是绝对引用，并且公式必须计算出结果 TRUE 或 FALSE。在本公式示例中，C7 引用了数据清单中第一个记录（行 7）的字段（列 C）。

  • 您可以在公式中使用列标志来代替相对的单元格引用或区域名称。当在包含条件的单元格中显示错误值 #NAME? 或 #VALUE! 时，您可以忽略这些错误，因为它们不影响列表的筛选。

  • 评估数据时，与字符的大小写没有区别。


DSUM

返回数据清单或数据库的列中满足指定条件的数字之和。

语法

DSUM(database,field,criteria)

Database 构成数据清单或数据库的单元格区域。数据库是包含一组相关数据的数据清单，其中包含相关信息的行为记录，而包含数据的列为字段。数据清单的第一行包含着每一列的标志项。

Field 指定函数所使用的数据列。数据清单中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“使用年数”或“产量”；此外，Field 也可以是代表数据清单中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

Criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

显示 示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从帮助中选取示例。

  3. 按 Ctrl+C。
  4. 在工作表中，选择单元格 A1，再按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
树种 | 高度 | 使用年数 | 产量 | 利润 | 高度
苹果树 | >10 |  |  |  | <16
梨树 |  |  |  |  |
树种 | 高度 | 使用年数 | 产量 | 利润
苹果树 | 18 | 20 | 14 | 105.00
梨树 | 12 | 12 | 10 | 96.00
樱桃树 | 13 | 14 | 9 | 105.00
苹果树 | 14 | 15 | 10 | 75.00
梨树 | 9 | 8 | 8 | 76.80
苹果树 | 8 | 9 | 6 | 45.00
公式 | 说明（结果）
=DCOUNT(A4:E10,"使用年数",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树的记录，并且计算这些记录中“使用年数”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为 10 到 16 英尺之间的苹果树记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找苹果树和梨树的最大利润。(105)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在 10 英尺以上的苹果树的最小利润。(75)
=DSUM(A4:E10,"利润",A1:A2) | 此函数计算苹果树的总利润。(225)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在 10 到 16 英尺之间的苹果树的总利润。(75)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于 10 英尺的苹果树产量的乘积。(140)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的平均产量。(12)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均使用年数。(13)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，则此值是苹果树和梨树产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，那么此值是苹果树和梨树产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实方差。(7.04)
=DGET(A4:E10,"产量",A1:A3) | 返回错误值 #NUM!，因为有多个记录符合给定的条件。

显示 提示

  • 可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。 例如，如果区域 G1:G2 在 G1 中包含列标志 Income，在 G2 中包含数量 10,000，可将此区域命名为 MatchIncome，那么在数据库函数中就可使用该名称作为参数 criteria。
  • 多数情况下，条件区域不应与数据清单重叠。
  • 若要对数据库的整个列进行操作，请在条件区域的相应列标志下方保留一个空行。

显示 条件示例

显示 单列上具有多个条件

如果对于某一列具有两个或多个筛选条件，那么可直接在各行中从上到下依次键入各个条件。 例如，下面的条件区域显示“销售人员”列中包含“Davolio”、“Buchanan”或“Suyama”的行。

销售人员
Davolio
Buchanan
Suyama

显示 多列上具有单个条件

若要在两列或多列中查找满足单个条件的数据，请在条件区域的同一行中输入所有条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”且“销售额”大于 $1,000 的数据行。

键入 | 销售人员 | 销售
农产品 | Davolio | >1000

显示 某一列或另一列上具有单个条件

若要找到满足一列条件或另一列条件的数据，请在条件区域的不同行中输入条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”或销售额大于 $1,000 的行。

键入 | 销售人员 | 销售
农产品 |  |
 | Davolio |
 |  | >1000

显示 两列上具有两组条件之一

若要找到满足两组条件（每一组条件都包含针对多列的条件）之一的数据行，请在各行中键入条件。例如，下面的条件区域将显示所有在“销售人员”列中包含“Davolio”且销售额大于 $3,000 的行，同时也显示“Buchanan”销售商的销售额大于 $1,500 的行。

销售人员 | 销售
Davolio | >3000
Buchanan | >1500

显示 一列有两组以上条件

若要找到满足两组以上条件的行，请用相同的列标包括多列。例如，下面条件区域显示介于 5,000 和 8,000 之间以及少于 500 的销售额。

销售 | 销售
>5000 | <8000
<500 |

显示 将公式结果用作条件

可以将公式的计算结果作为条件使用。用公式创建条件时，不要将列标志作为条件标记使用，应该将条件标记置空，或者使用清单中非列标志的标记。例如，下面的条件区域显示在列 C 中，其值大于单元格区域 C7:C10 平均值的行。

=C7>AVERAGE($C$7:$C$10)

注释

  • 用作条件的公式必须使用相对引用来引用列标志（例如，“销售”），或者引用第一个记录的对应字段。公式中的所有其他引用都必须是绝对引用，并且公式必须计算出结果 TRUE 或 FALSE。在本公式示例中，C7 引用了数据清单中第一个记录（行 7）的字段（列 C）。

  • 您可以在公式中使用列标志来代替相对的单元格引用或区域名称。当在包含条件的单元格中显示错误值 #NAME? 或 #VALUE! 时，您可以忽略这些错误，因为它们不影响列表的筛选。

  • 评估数据时，与字符的大小写没有区别。


DVAR

将数据清单或数据库的列中满足指定条件的数字作为一个样本，估算样本总体的方差。

语法

DVAR(database,field,criteria)

Database 构成数据清单或数据库的单元格区域。数据库是包含一组相关数据的数据清单，其中包含相关信息的行为记录，而包含数据的列为字段。数据清单的第一行包含着每一列的标志项。

Field 指定函数所使用的数据列。数据清单中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“使用年数”或“产量”；此外，Field 也可以是代表数据清单中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

Criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

显示 示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从帮助中选取示例。

  3. 按 Ctrl+C。
  4. 在工作表中，选择单元格 A1，再按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
树种 | 高度 | 使用年数 | 产量 | 利润 | 高度
苹果树 | >10 |  |  |  | <16
梨树 |  |  |  |  |
树种 | 高度 | 使用年数 | 产量 | 利润
苹果树 | 18 | 20 | 14 | 105.00
梨树 | 12 | 12 | 10 | 96.00
樱桃树 | 13 | 14 | 9 | 105.00
苹果树 | 14 | 15 | 10 | 75.00
梨树 | 9 | 8 | 8 | 76.80
苹果树 | 8 | 9 | 6 | 45.00
公式 | 说明（结果）
=DCOUNT(A4:E10,"使用年数",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树的记录，并且计算这些记录中“使用年数”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为 10 到 16 英尺之间的苹果树记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找苹果树和梨树的最大利润。(105)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在 10 英尺以上的苹果树的最小利润。(75)
=DSUM(A4:E10,"利润",A1:A2) | 此函数计算苹果树的总利润。(225)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在 10 到 16 英尺之间的苹果树的总利润。(75)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于 10 英尺的苹果树产量的乘积。(140)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的平均产量。(12)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均使用年数。(13)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，则此值是苹果树和梨树产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，那么此值是苹果树和梨树产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实方差。(7.04)
=DGET(A4:E10,"产量",A1:A3) | 返回错误值 #NUM!，因为有多个记录符合给定的条件。

显示 提示

  • 可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。 例如，如果区域 G1:G2 在 G1 中包含列标志 Income，在 G2 中包含数量 10,000，可将此区域命名为 MatchIncome，那么在数据库函数中就可使用该名称作为参数 criteria。
  • 多数情况下，条件区域不应与数据清单重叠。
  • 若要对数据库的整个列进行操作，请在条件区域的相应列标志下方保留一个空行。

显示 条件示例

显示 单列上具有多个条件

如果对于某一列具有两个或多个筛选条件，那么可直接在各行中从上到下依次键入各个条件。 例如，下面的条件区域显示“销售人员”列中包含“Davolio”、“Buchanan”或“Suyama”的行。

销售人员
Davolio
Buchanan
Suyama

显示 多列上具有单个条件

若要在两列或多列中查找满足单个条件的数据，请在条件区域的同一行中输入所有条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”且“销售额”大于 $1,000 的数据行。

键入 | 销售人员 | 销售
农产品 | Davolio | >1000

显示 某一列或另一列上具有单个条件

若要找到满足一列条件或另一列条件的数据，请在条件区域的不同行中输入条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”或销售额大于 $1,000 的行。

键入 | 销售人员 | 销售
农产品 |  |
 | Davolio |
 |  | >1000

显示 两列上具有两组条件之一

若要找到满足两组条件（每一组条件都包含针对多列的条件）之一的数据行，请在各行中键入条件。例如，下面的条件区域将显示所有在“销售人员”列中包含“Davolio”且销售额大于 $3,000 的行，同时也显示“Buchanan”销售商的销售额大于 $1,500 的行。

销售人员 | 销售
Davolio | >3000
Buchanan | >1500

显示 一列有两组以上条件

若要找到满足两组以上条件的行，请用相同的列标包括多列。例如，下面条件区域显示介于 5,000 和 8,000 之间以及少于 500 的销售额。

销售 | 销售
>5000 | <8000
<500 |

显示 将公式结果用作条件

可以将公式的计算结果作为条件使用。用公式创建条件时，不要将列标志作为条件标记使用，应该将条件标记置空，或者使用清单中非列标志的标记。例如，下面的条件区域显示在列 C 中，其值大于单元格区域 C7:C10 平均值的行。

=C7>AVERAGE($C$7:$C$10)

注释

  • 用作条件的公式必须使用相对引用来引用列标志（例如，“销售”），或者引用第一个记录的对应字段。公式中的所有其他引用都必须是绝对引用，并且公式必须计算出结果 TRUE 或 FALSE。在本公式示例中，C7 引用了数据清单中第一个记录（行 7）的字段（列 C）。

  • 您可以在公式中使用列标志来代替相对的单元格引用或区域名称。当在包含条件的单元格中显示错误值 #NAME? 或 #VALUE! 时，您可以忽略这些错误，因为它们不影响列表的筛选。

  • 评估数据时，与字符的大小写没有区别。


DVARP

将数据清单或数据库的列中满足指定条件的数字作为样本总体，计算总体的方差。

语法

DVARP(database,field,criteria)

Database 构成数据清单或数据库的单元格区域。数据库是包含一组相关数据的数据清单，其中包含相关信息的行为记录，而包含数据的列为字段。数据清单的第一行包含着每一列的标志项。

Field 指定函数所使用的数据列。数据清单中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“使用年数”或“产量”；此外，Field 也可以是代表数据清单中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

Criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

显示 示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从帮助中选取示例。

  3. 按 Ctrl+C。
  4. 在工作表中，选择单元格 A1，再按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
树种 | 高度 | 使用年数 | 产量 | 利润 | 高度
苹果树 | >10 |  |  |  | <16
梨树 |  |  |  |  |
树种 | 高度 | 使用年数 | 产量 | 利润
苹果树 | 18 | 20 | 14 | 105.00
梨树 | 12 | 12 | 10 | 96.00
樱桃树 | 13 | 14 | 9 | 105.00
苹果树 | 14 | 15 | 10 | 75.00
梨树 | 9 | 8 | 8 | 76.80
苹果树 | 8 | 9 | 6 | 45.00
公式 | 说明（结果）
=DCOUNT(A4:E10,"使用年数",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树的记录，并且计算这些记录中“使用年数”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为 10 到 16 英尺之间的苹果树记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找苹果树和梨树的最大利润。(105)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在 10 英尺以上的苹果树的最小利润。(75)
=DSUM(A4:E10,"利润",A1:A2) | 此函数计算苹果树的总利润。(225)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在 10 到 16 英尺之间的苹果树的总利润。(75)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于 10 英尺的苹果树产量的乘积。(140)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的平均产量。(12)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均使用年数。(13)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，则此值是苹果树和梨树产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，那么此值是苹果树和梨树产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实方差。(7.04)
=DGET(A4:E10,"产量",A1:A3) | 返回错误值 #NUM!，因为有多个记录符合给定的条件。

显示 提示

  • 可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。 例如，如果区域 G1:G2 在 G1 中包含列标志 Income，在 G2 中包含数量 10,000，可将此区域命名为 MatchIncome，那么在数据库函数中就可使用该名称作为参数 criteria。
  • 多数情况下，条件区域不应与数据清单重叠。
  • 若要对数据库的整个列进行操作，请在条件区域的相应列标志下方保留一个空行。

显示 条件示例

显示 单列上具有多个条件

如果对于某一列具有两个或多个筛选条件，那么可直接在各行中从上到下依次键入各个条件。 例如，下面的条件区域显示“销售人员”列中包含“Davolio”、“Buchanan”或“Suyama”的行。

销售人员
Davolio
Buchanan
Suyama

显示 多列上具有单个条件

若要在两列或多列中查找满足单个条件的数据，请在条件区域的同一行中输入所有条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”且“销售额”大于 $1,000 的数据行。

键入 | 销售人员 | 销售
农产品 | Davolio | >1000

显示 某一列或另一列上具有单个条件

若要找到满足一列条件或另一列条件的数据，请在条件区域的不同行中输入条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”或销售额大于 $1,000 的行。

键入 | 销售人员 | 销售
农产品 |  |
 | Davolio |
 |  | >1000

显示 两列上具有两组条件之一

若要找到满足两组条件（每一组条件都包含针对多列的条件）之一的数据行，请在各行中键入条件。例如，下面的条件区域将显示所有在“销售人员”列中包含“Davolio”且销售额大于 $3,000 的行，同时也显示“Buchanan”销售商的销售额大于 $1,500 的行。

销售人员 | 销售
Davolio | >3000
Buchanan | >1500

显示 一列有两组以上条件

若要找到满足两组以上条件的行，请用相同的列标包括多列。例如，下面条件区域显示介于 5,000 和 8,000 之间以及少于 500 的销售额。

销售 | 销售
>5000 | <8000
<500 |

显示 将公式结果用作条件

可以将公式的计算结果作为条件使用。用公式创建条件时，不要将列标志作为条件标记使用，应该将条件标记置空，或者使用清单中非列标志的标记。例如，下面的条件区域显示在列 C 中，其值大于单元格区域 C7:C10 平均值的行。

=C7>AVERAGE($C$7:$C$10)

注释

  • 用作条件的公式必须使用相对引用来引用列标志（例如，“销售”），或者引用第一个记录的对应字段。公式中的所有其他引用都必须是绝对引用，并且公式必须计算出结果 TRUE 或 FALSE。在本公式示例中，C7 引用了数据清单中第一个记录（行 7）的字段（列 C）。

  • 您可以在公式中使用列标志来代替相对的单元格引用或区域名称。当在包含条件的单元格中显示错误值 #NAME? 或 #VALUE! 时，您可以忽略这些错误，因为它们不影响列表的筛选。

  • 评估数据时，与字符的大小写没有区别。


数据库函数示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
树种 | 高度 | 使用年数 | 产量 | 利润 | 高度
苹果树 | >10 |  |  |  | <16
梨树 |  |  |  |  |
树种 | 高度 | 使用年数 | 产量 | 利润
苹果树 | 18 | 20 | 14 | 105.00
梨树 | 12 | 12 | 10 | 96.00
樱桃树 | 13 | 14 | 9 | 105.00
苹果树 | 14 | 15 | 10 | 75.00
梨树 | 9 | 8 | 8 | 76.80
苹果树 | 8 | 9 | 6 | 45.00
公式 | 说明（结果）
=DCOUNT(A4:E10,"使用年数",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树的记录，并且计算这些记录中“使用年数”字段包含数字的单元格个数。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度在 10 到 16 英尺之间的苹果树记录，并计算这些记录中“利润”字段为非空的单元格个数。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找苹果树和梨树的最大利润。(105)
=DMIN(A4:E10,"利润",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的最小利润。(75)
=DSUM(A4:E10,"利润",A1:A2) | 此函数计算苹果树的总利润。(225)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在 10 到 16 英尺之间的苹果树的总利润。(75)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于 10 英尺的苹果树产量的乘积。(140)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在 10 英尺以上的苹果树的平均产量。(12)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均使用年数。(13)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，则此值是苹果树和梨树产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个果园的一个样本，那么此值是苹果树和梨树产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个果园的样本总体，则此值是苹果树和梨树产量的真实方差。(7.04)
=DGET(A4:E10,"产量",A1:A3) | 返回错误值 #NUM!，因为有多个记录符合给定的条件。

显示 提示

  • 可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。例如，如果区域 G1:G2 在 G1 中包含列标志 Income，在 G2 中包含数量 10,000，可将此区域命名为 MatchIncome，那么在数据库函数中就可使用该名称作为参数 criteria。
  • 多数情况下，条件区域不应与数据清单重叠。
  • 若要对数据库的整个列进行操作，请在条件区域的相应列标志下方输入一个空行。

显示 条件示例

显示 单列上具有多个条件

如果对于某一列具有两个或多个筛选条件，那么可直接在各行中从上到下依次键入各个条件。例如，下面的条件区域显示“销售人员”列中包含“Davolio”、“Buchanan”或“Suyama”的行。

销售人员
Davolio
Buchanan
Suyama

显示 多列上具有单个条件

若要在两列或多列中查找满足单个条件的数据，请在条件区域的同一行中输入所有条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”且销售额大于 $1,000 的数据行。

类型 | 销售人员 | 销售额
农产品 | Davolio | >1000

显示 某一列或另一列上具有单个条件

若要查找满足某一列上单个条件或另一列上单个条件的数据，请在条件区域的不同行中输入条件。例如，下面的条件区域将显示所有在“类型”列中包含“农产品”、在“销售人员”列中包含“Davolio”或销售额大于 $1,000 的行。

类型 | 销售人员 | 销售额
农产品 |  |
 | Davolio |
 |  | >1000

显示 两列上具有两组条件之一

若要查找满足两组条件（每一组条件都包含针对多列的条件）之一的数据行，请在各行中键入条件。例如，下面的条件区域将显示所有在“销售人员”列中包含“Davolio”且销售额大于 $3,000 的行，同时也显示“Buchanan”销售商的销售额大于 $1,500 的行。

销售人员 | 销售额
Davolio | >3000
Buchanan | >1500

显示 一列有两组以上条件

若要查找满足两组以上条件的行，请包括具有相同列标题的多列。例如，下面的条件区域显示介于 5,000 和 8,000 之间以及少于 500 的销售额。

销售额 | 销售额
>5000 | <8000
<500 |


DATE

返回代表特定日期的序列号。

语法

DATE(year,month,day)

Year 参数 year 可以为一到四位数字。

  • 如果 year 位于 0（零）到 1899（包含）之间，则将该值加上 1900，再计算年份。例如：DATE(108,1,2) 将返回 2008 年 1 月 2 日 (1900+108)。

  • 如果 year 位于 1900 到 9999（包含）之间，则该值将被用作为年份。例如：DATE(2008,1,2) 将返回 2008 年 1 月 2 日。

Month 代表每年中月份的数字。如果所输入的月份大于 12，将从指定年份的一月份开始往上加算。例如：DATE(2008,14,2) 返回代表 2009 年 2 月 2 日的序列号。

Day 代表在该月份中第几天的数字。如果 day 大于指定月份的最大天数，则将从该月份的第一天开始往上累加。例如，DATE(2008,1,35) 返回代表 2008 年 2 月 4 日的序列号。

说明

  • 日期被存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日是序列号 1，2008 年 1 月 1 日是序列号 39,448，这是因为它距 1900 年 1 月 1 日有 39,448 天。
  • 函数 DATE 在年、月、日为变量的公式中非常有用。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
年 | 月 | 日
2008 | 1 | 1
公式 | 说明（结果）
=DATE(A2,B2,C2) | 上述日期的序列号（2008-1-1 或 39448）

注释 如果要将结果的显示从序列号更改为日期格式，或从日期格式更改为序列号，可选中单元格并单击工具栏上的“命令和选项” 按钮图像 。单击“格式”选项卡，然后在“数字格式”框中选择所需的格式。若要以序列号形式显示日期，请应用“常规”数字格式。


DATEVALUE

返回 date_text 所表示的日期的序列号。函数 DATEVALUE 的主要功能是将以文本表示的日期转换成一个序列号。

语法

DATEVALUE(date_text)

Date_text 为表示日期的文本，以日期格式显示。例如，引号内的文本字符串 "2008-1-30" 或 "30-Jan-08" 表示日期。

如果省略 date_text 中的年份部分，则函数 DATEVALUE 使用计算机系统内部时钟的当前年份。date_text 中的时间信息将被忽略。

说明

  • 日期被存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日是序列号 1，2008 年 1 月 1 日是序列号 39,448，这是因为它距 1900 年 1 月 1 日有 39,448 天。
  • 大部分函数都会自动将日期值转换成序列号。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=DATEVALUE("2008-8-22") | 以文本表示的日期的序列号 (39682)
=DATEVALUE("22-AUG-08") | 以文本表示的日期的序列号 (39682)
=DATEVALUE("2008-2-23") | 以文本表示的日期的序列号 (39501)
=DATEVALUE("5-JUL") | 以文本表示的日期的序列号，假设计算机系统内部时钟设置为 2000 (36712)

注释 如果要将结果的显示从序列号更改为日期格式，或从日期格式更改为序列号，可选中单元格并单击工具栏上的“命令和选项” 按钮图像 。单击“格式”选项卡，然后在“数字格式”框中选择所需的格式。若要以序列号形式显示日期，请应用“常规”数字格式。


DAY

返回以序列号表示的某日期的天数，用整数 1 到 31 表示。

语法

DAY(serial_number)

Serial_number 为要查找的那一天的日期。

说明

  • 应使用 DATE 函数来输入日期，或者将日期作为其他公式或函数的结果输入。例如，使用 DATE(2008,5,23) 输入 2008 年 5 月 23 日。如果以文本的形式输入日期，则将返回错误值 #VALUE!。

  • 日期被存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日是序列号 1，2008 年 1 月 1 日是序列号 39,448，这是因为它距 1900 年 1 月 1 日有 39,448 天。
  • 由 YEAR、MONTH 和 DAY 函数返回的值是 Gregorian 值，不管所提供的日期值是怎样的显示格式。例如，如果所提供的日期值显示格式是 Hijri，则 YEAR、MONTH 和 DAY 函数返回的值将是对应 Gregorian 日期的值。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
日期
2008-4-15
公式 | 说明（结果）
=DAY(A2) | 上述日期的天数 (15)


DAYS360

按照一年 360 天的算法（每个月以 30 天计，一年共计 12 个月），返回两日期间相差的天数，这在一些会计计算中将会用到。如果财务系统是基于一年 12 个月，每月 30 天，可用此函数帮助计算支付款项。

语法

DAYS360(start_date,end_date,method)

Start_date 和 end_date 是用于计算期间天数的起止日期。如果 start_date 在 end_date 之后，则 DAYS360 将返回一个负数。应使用 DATE 函数来输入日期，或者将日期作为其他公式或函数的结果输入。例如，使用函数 DATE(2008,5,23) 输入日期 2008 年 5 月 23 日。如果日期以文本的形式输入，则会出现问题。

Method 为一个逻辑值，它指定了在计算中是采用欧洲方法还是美国方法。

Method | 定义
FALSE 或省略 | 美国方法 (NASD)。如果起始日期是一个月的 31 号，则等于同月的 30 号。如果终止日期是一个月的 31 号，并且起始日期早于 30 号，则终止日期等于下一个月的 1 号，否则，终止日期等于本月的 30 号。
TRUE | 欧洲方法。起始日期和终止日期为一个月的 31 号，都将等于本月的 30 号。

说明

日期被存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日是序列号 1，2008 年 1 月 1 日是序列号 39,448，这是因为它距 1900 年 1 月 1 日有 39,448 天。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
日期
2008-1-30
2008-2-1
公式 | 说明（结果）
=DAYS360(A2,A3) | 按照一年 360 天的算法，上述两日期之间的天数 (1)


HOUR

返回时间值的小时数。即一个介于 0 (12:00 A.M.) 到 23 (11:00 P.M.) 之间的整数。

语法

HOUR(serial_number)

Serial_number 表示一个时间值，其中包含要查找的小时。时间有多种输入方式：带引号的文本字符串（例如："6:45 PM"）、十进制数（例如 0.78125 表示 6:45 PM）或其他公式或函数的结果（例如：TIMEVALUE("6:45 PM")）。

说明

时间值为日期值的一部分，并用十进制数来表示（例如 12:00 PM 可表示为 0.5，因为此时是一天的一半）。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
时间
3:30:30 AM
3:30:30 PM
15:30
公式 | 说明（结果）
=HOUR(A2) | 返回第一个时间值的小时数 (3)
=HOUR(A3) | 返回第二个时间值的小时数 (15)
=HOUR(A4) | 返回第三个时间值的小时数 (15)


MINUTE

返回时间值中的分钟，为一个介于 0 到 59 之间的整数。

语法

MINUTE(serial_number)

Serial_number 表示一个时间值，其中包含要查找的分钟。时间有多种输入方式：带引号的文本字符串（例如 "6:45 PM"）、十进制数（例如 0.78125 表示 6:45 PM）或其他公式或函数的结果（例如 TIMEVALUE("6:45 PM")）。

说明

时间值为日期值的一部分，并用十进制数表示（例如 12:00 PM 可表示为 0.5，因为此时是一天的一半）。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
时间
4:48:00 PM
公式 | 说明（结果）
=MINUTE(A2) | 上面时间中的分钟数 (48)


MONTH

返回以序列号表示的日期中的月份。月份是介于 1（一月）到 12（十二月）之间的整数。

语法

MONTH(serial_number)

Serial_number 表示一个日期值，其中包含要查找的月份。应使用 DATE 函数输入日期，或者将日期作为其他公式或函数的结果输入。例如，使用 DATE(2008,5,23) 输入 2008 年 5 月 23 日。如果日期以文本的形式输入，则会出现问题。

说明

日期被存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日是序列号 1，2008 年 1 月 1 日是序列号 39,448，这是因为它距 1900 年 1 月 1 日有 39,448 天。

由 YEAR、MONTH 和 DAY 函数返回的值为公历值，而不用考虑所给日期值的显示格式。例如，如果所给日期值的显示格式为 Hijri，则 YEAR、MONTH 和 DAY 函数的返回值将是与等价的公历日期相关的值。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
日期
2008-4-15
公式 | 说明（结果）
=MONTH(A2) | 上面日期中的月份 (4)


NOW

返回当前日期和时间所对应的序列号。

语法

NOW( )

说明

  • 日期被存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日是序列号 1，2008 年 1 月 1 日是序列号 39,448，这是因为它距 1900 年 1 月 1 日有 39,448 天。
  • 序列号中小数点右边的数字表示时间，左边的数字表示日期。例如，序列号 .5 表示时间为中午 12:00。
  • NOW 函数只在工作表进行计算时进行更改。它并不会随时更新。

注释 如果要将结果的显示从序列号更改为日期格式，或从日期格式更改为序列号，可选中单元格并单击工具栏上的“命令和选项” 按钮图像 。单击“格式”选项卡，然后在“数字格式”框中选择所需的格式。若要以序列号形式显示日期，请应用“常规”数字格式。


SECOND

返回时间值的秒数。返回的秒数为 0 到 59 之间的整数。

语法

SECOND(serial_number)

Serial_number 表示一个时间值，其中包含要查找的秒数。时间有多种输入方式：带引号的文本字符串（例如 "6:45 PM"）、十进制数（例如，0.78125 表示 6:45 PM）或其他公式或函数的结果（例如 TIMEVALUE("6:45 PM")）。

说明

时间值为日期值的一部分，并用十进制数来表示（例如，12:00 PM 可表示为 0.5，因为此时是一天的一半）。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
时间
4:48:18 PM
4:48 PM
公式 | 说明
=SECOND(A2) | 第一个时间的秒数 (18)
=SECOND(A3) | 第二个时间的秒数 (0)


TIME

返回某一特定时间的小数值，函数 TIME 返回的小数值为 0 到 0.99999999 之间的数值，代表从 0:00:00 (12:00:00 AM) 到 23:59:59 (11:59:59 PM) 之间的时间。

语法

TIME(hour,minute,second)

Hour 为 0（零）到 32767 之间的数字，代表小时。任何大于 23 的值将被 24 除，其中余数将作为小时值。例如，TIME(27,0,0) = TIME(3,0,0) = .125 即 3:00 AM。

Minute 为 0（零）到 32767 之间的数字，代表分钟。任何大于 59 的值将转换为小时和分钟。例如，TIME(0,750,0) = TIME(12,30,0) = .520833 即 12:30 PM。

Second 为 0（零）到 32767 之间的数字，代表秒。任何大于 59 的值将转换为小时、分钟和秒。例如，TIME(0,0,2000) = TIME(0,33,22) = .023148 即 12:33:20 AM。

说明

时间值为日期值的一部分，并用十进制数来表示（例如 12:00 PM 可表示为 0.5，因为此时是一天的一半）。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
小时 | 分钟 | 秒
12 | 0 | 0
16 | 48 | 10
公式 | 说明（结果）
=TIME(A2,B2,C2) | 上面第一个时间的小数表示形式 (0.5)
=TIME(A3,B3,C3) | 上面第二个时间的小数表示形式 (0.700115741)

注释 若要以小数的形式显示时间，请选中单元格并单击工具栏上的“命令和选项” 按钮图像 ，再单击“格式”选项卡，然后选中“常规”数字格式。


TIMEVALUE

返回由文本字符串所代表的时间的小数值。该小数值为 0 到 0.999999999 之间的数值，代表从 0:00:00 (12:00:00 AM) 到 23:59:59 (11:59:59 PM) 之间的时间。

语法

TIMEVALUE(time_text)

Time_text 文本字符串，代表以任一电子表格时间格式表示的时间（例如，代表时间的引号内的文本字符串 "6:45 PM" 和 "18:45"）。

说明

  • time_text 中的日期信息将被忽略。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=TIMEVALUE("2:24 AM") | 时间按一天计算的小数表示形式 (0.1)
=TIMEVALUE("22-Aug-2008 6:35 AM") | 时间按一天计算的小数表示形式 (0.274305556)

注释 如果要将结果的显示从序列号更改为时间格式，或从时间格式更改为序列号，可选中单元格并单击工具栏上的“命令和选项” 按钮图像 ，再单击“格式”选项卡，然后在“数字格式”框中选择所需的格式。若要以序列号形式显示日期，请应用“常规”数字格式。


TODAY

返回当前日期的序列号。序列号是电子表格日期和时间计算使用的日期-时间代码。

语法

TODAY( )

说明

日期被存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日是序列号 1，2008 年 1 月 1 日是序列号 39,448，这是因为它距 1900 年 1 月 1 日有 39,448 天。

注释 如果要将结果的显示从序列号更改为日期格式，或从日期格式更改为序列号，可选中单元格并单击工具栏上的“命令和选项” 按钮图像 ，再单击“格式”选项卡，然后在“数字格式”框中选择所需的格式。若要以序列号形式显示日期，请应用“常规”数字格式。


WEEKDAY

返回某日期为星期几。默认情况下，其值为 1（星期天）到 7（星期六）之间的整数。

语法

WEEKDAY(serial_number,return_type)

Serial_number 表示一个顺序的序列号，代表要查找的那一天的日期。应使用 DATE 函数输入日期，或者将函数作为其他公式或函数的结果输入。例如，使用 DATE(2008,5,23) 输入 2008 年 5 月 23 日。如果日期以文本的形式输入，则会出现问题。

Return_type 为确定返回值类型的数字。

Return_type | 返回的数字
1 或省略 | 数字 1（星期日）到数字 7（星期六）。
2 | 数字 1（星期一）到数字 7（星期天）。
3 | 数字 0（星期一）到数字 6（星期天）。

说明

日期被存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日是序列号 1，2008 年 1 月 1 日是序列号 39,448，这是因为它距 1900 年 1 月 1 日有 39,448 天。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
2008-2-14
公式 | 说明（结果）
=WEEKDAY(A2) | 具有数字 1（星期日）到数字 7（星期六）的星期号 (5)
=WEEKDAY(A2,2) | 具有数字 1（星期一）到数字 7（星期日）的星期号 (4)
=WEEKDAY(A2,3) | 具有数字 0（星期一）到数字 6（星期日）的星期号 (3)

注释 2008-2-14 为星期四。


YEAR

返回某日期对应的年份。

语法

YEAR(serial_number)

Serial_number 为一个日期值，其中包含要查找年份的日期。应使用 DATE 函数来输入日期，或者将日期作为其他公式或函数的结果输入。例如，使用 DATE(2008,5,23) 输入 2008 年 5 月 23 日。如果日期以文本的形式输入，则会出现问题。

说明

日期被存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日是序列号 1，2008 年 1 月 1 日是序列号 39,448，这是因为它距 1900 年 1 月 1 日有 39,448 天。

由 YEAR、MONTH 和 DAY 函数返回的值为公历值，而不用考虑所给日期值的显示格式。例如，如果所给日期值的显示格式为 Hijri，则 YEAR、MONTH 和 DAY 函数的返回值将是与等价的公历日期相关的值。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
日期
2008-7-5
10-7-5
公式 | 说明（结果）
=YEAR(A2) | 第一个日期的年份 (2008)
=YEAR(A3) | 第二个日期的年份 (2010)


DB

使用固定余额递减法，计算一笔资产在给定期间内的折旧值。

语法

DB(cost,salvage,life,period,month)

Cost 为资产原值。

Salvage 为资产在折旧期末的价值（也称为资产残值）。

Life 为折旧期限（有时也称作资产的使用寿命）。

Period 为需要计算折旧值的期间。Period 必须使用与 life 相同的单位。

Month 为第一年的月份数，如省略，则假设为 12。

说明

  • 固定余额递减法用于计算固定利率下的资产折旧值，函数 DB 使用下列计算公式来计算一个期间的折旧值：

    (cost - 前期折旧总值 ) * rate

    式中：

    rate = 1 - ((salvage / cost) ^ (1 / life))，保留 3 位小数

  • 第一个周期和最后一个周期的折旧属于特例。对于第一个周期，函数 DB 的计算公式为：

    cost * rate * month / 12

  • 对于最后一个周期，函数 DB 的计算公式为：

    ((cost - 前期折旧总值) * rate * (12 - month)) / 12

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
1,000,000 | 资产原值
100,000 | 资产残值
6 | 使用寿命
公式 | 说明（结果）
=DB(A2,A3,A4,1,7) | 计算第一年 7 个月内的折旧值 (186,083.33)
=DB(A2,A3,A4,2,7) | 计算第二年的折旧值 (259,639.42)
=DB(A2,A3,A4,3,7) | 计算第三年的折旧值 (176,814.44)
=DB(A2,A3,A4,4,7) | 计算第四年的折旧值 (120,410.64)
=DB(A2,A3,A4,5,7) | 计算第五年的折旧值 (81,999.64)
=DB(A2,A3,A4,6,7) | 计算第六年的折旧值 (55,841.76)
=DB(A2,A3,A4,7,7) | 计算第七年 5 个月内的折旧值 (15,845.10)


DDB

使用双倍余额递减法或其他指定方法，计算一笔资产在给定期间内的折旧值。

语法

DDB(cost,salvage,life,period,factor)

Cost 为资产原值。

Salvage 为资产在折旧期末的价值（也称为资产残值）。

Life 为折旧期限（有时也称作资产的使用寿命）。

Period 为需要计算折旧值的期间。Period 必须使用与 life 相同的单位。

Factor 为余额递减速率。如果 factor 被省略，则假设为 2（双倍余额递减法）。

这五个参数都必须为正数。

说明

  • 双倍余额递减法以加速的比率计算折旧。折旧在第一阶段是最高的，在后继阶段中会减少。DDB 使用下面的公式计算一个阶段的折旧值：

    ((资产原值-资产残值) - 前面阶段的折旧总值) * (余额递减速率/生命周期)

  • 如果不想使用双倍余额递减法，更改余额递减速率。
  • 当折旧大于余额递减计算值时，如果希望转换到直线余额递减法，请使用 VDB 函数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
2400 | 资产原值
300 | 资产残值
10 | 使用寿命
公式 | 说明（结果）
=DDB(A2,A3,A4*365,1) | 第一天的折旧值。自动假定余额递减速率为 2。(1.32)
=DDB(A2,A3,A4*12,1,2) | 第一个月的折旧值 (40.00)
=DDB(A2,A3,A4,1,2) | 第一年的折旧值 (480.00)
=DDB(A2,A3,A4,2,1.5) | 计算第二年的折旧值，使用了 1.5 的余额递减速率，而不用双倍余额递减法 (306.00)
=DDB(A2,A3,A4,10) | 计算第十年的折旧值，自动将余额递减速率设置为 2 (22.12)

注释 结果四舍五入到两位小数。


EUROCONVERT

本主题中的部分内容可能不适用于某些语言。

用于将数字转换为欧元形式，将数字由欧元形式转换为欧元成员国货币形式，或利用欧元作为中间货币将数字由某一欧元成员国货币转化为另一欧元成员国货币形式（三角转换关系）。只有采用了欧元的欧盟 (EU) 成员国货币才能进行这些转换。此函数所使用的是由欧盟 (EU) 所建立的固定转换汇率。

语法

EUROCONVERT(number,source,target,full_precision,triangulation_precision)

Number 为要转换的货币值，或对某个包含值的单元格的引用。

Source 是由三个字母组成的字符串，或对包含此类字符串的单元格的引用，而该字符串对应于源货币的国际标准化组织 (ISO) 代码。EUROCONVERT 函数中可以使用下列货币代码：

国家/地区 | 基本货币单位 | ISO 代码
比利时 | 法郎 | BEF
卢森堡 | 法郎 | LUF
德国 | 德国马克 | DEM
西班牙 | 西班牙比塞塔 | ESP
法国 | 法郎 | FRF
爱尔兰 | 爱尔兰磅 | IEP
意大利 | 里拉 | ITL
荷兰 | 荷兰盾 | NLG
奥地利 | 奥地利先令 | ATS
葡萄牙 | 埃斯库多 | PTE
芬兰 | 芬兰马克 | FIM
欧盟成员国 | 欧元 | EUR

Target 是由三个字母组成的字符串，或对包含此类字符串的单元格的引用，而该字符串对应于要将数字转换到的货币所对应的 ISO 代码。有关 ISO 代码的信息，请参见前面列出的有关 Source 的表。

Full_precision 是一个逻辑值（TRUE 或 FALSE），或一个计算结果为 TRUE 或 FALSE 的表达式，它用于指定如何显示结果。

请使用 | 如果需要
FALSE | 使用货币特定的舍入规则来显示结果（请参见下表）。将使用计算精度值来计算结果，同时使用显示精度值来显示结果。如果省略 full_precision 参数，则默认值为 FALSE。
TRUE | 用通过计算得到的所有有效数字来显示结果。

下表显示了货币特定的舍入规则，也就是说，使用多少位小数位数来计算货币的转换结果并显示该转换结果。

ISO 代码 | 计算精度 | 显示精度
BEF | 0 | 0
LUF | 0 | 0
DEM | 2 | 2
ESP | 0 | 0
FRF | 2 | 2
IEP | 2 | 2
ITL | 0 | 0
NLG | 2 | 2
ATS | 2 | 2
PTE | 1 | 2
FIM | 2 | 2
EUR | 2 | 2

Triangulation_precision 是一个等于或大于 3 的整数，它指定了在转换不同欧盟成员国之间货币时所使用的中间结果的欧元值的有效位数。如果省略此参数，则不会对中间结果的欧元值进行取整。如果在将欧盟成员国货币转换为欧元时使用了此参数，则电子表格将会计算中间结果的欧元值，然后再将此中间结果的欧元值转换为某个欧盟成员国货币。

说明

  • 返回值中尾部的零将截尾取整。
  • 如果源 ISO 代码与目标 ISO 代码相同，则会返回该数字的初始值。
  • 对于无效参数，将返回错误值 #VALUE。
  • 此函数并不使用任何数字格式。

示例

这些示例假设转换汇率为 1 欧元 = 6.55957 法国法郎以及 1 欧元 = 1.95583 德国马克。EUROCONVERT 函数使用的是由欧盟所建立的当前汇率。如果汇率发生了变化，Microsoft 也会对此函数进行更新。若要了解有关当前实际转换规则和汇率的完整信息，请参阅欧盟发布的有关欧元的出版物。

这些示例显示了存储在单元格中的结果值，且并未对这些值设置格式。

EUROCONVERT(1.20,"DEM","EUR") 等于 0.61 欧元。因为并未指定 full_precision 和 triangulation_precision，所以结果中将使用欧元的计算精度，它具有两位小数位。

EUROCONVERT(1,"FRF","EUR",TRUE,3) 等于 0.152 欧元。在转换成欧元时，如果 full_precision 为 TRUE，则结果的精度由 triangulation_precision 所指定。

EUROCONVERT(1,"FRF","EUR",FALSE,3) 等于 0.15 欧元。在转换为欧元时，因为 full_precision 为 FALSE，所以结果中将使用欧元的计算精度值，它具有两位小数位。

EUROCONVERT(1,"FRF","DEM",TRUE,3) 等于 0.29728616 DM。因为 triangulation_precision 为 3，所以中间结果的欧元值取整为三位。因为 full_precision 为 TRUE，所以计算结果中的德国马克值保留了所有的有效数字。

EUROCONVERT(1,"FRF","DEM",FALSE,3) 等于 0.30 DM。因为 triangulation_precision 为 3，所以中间结果的欧元值取整为三位。因为 full_precision 为 FALSE，所以计算结果中的德国马克值取整为德国马克的计算精度，它具有两位小数位。


FV

基于固定利率及等额分期付款方式，返回某项投资的未来值。

语法

FV(rate,nper,pmt,pv,type)

有关函数 FV 中各参数以及年金函数的详细信息，请参阅函数 PV。

Rate 为各期利率。

Nper 为总投资期，即该项投资的付款期总数。

Pmt 为各期所应支付的金额，其数值在整个年金期间保持不变。通常 pmt 包括本金和利息，但不包括其他费用及税款。如果忽略 pmt，则必须包括 pv 参数。

Pv 为现值，即从该项投资开始计算时已经入帐的款项，或一系列未来付款的当前值的累积和，也称为本金。如果省略 PV，则假设其值为零，并且必须包括 pmt 参数。

Type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。如果省略 type，则假设其值为零。

Type 值 | 支付时间
0 | 期末
1 | 期初

说明
  • 应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 对于所有的参数，支出的款项，如银行存款，表示为负数；收入的款项，如股息收入，表示为正数。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
6% | 年利率
10 | 付款期总数
-200 | 各期应付金额
-500 | 现值
1 | 各期的支付时间在期初（请参见上面的信息）
公式 | 说明（结果）
=FV(A2/12, A3, A4, A5, A6) | 在上述条件下投资的未来值 (2581.40)

注释 年利率应除以 12，因为它是由按月计复利而得的。

示例 2

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
12% | 年利率
12 | 付款期总数
-1000 | 各期应付金额
公式 | 说明（结果）
=FV(A2/12, A3, A4) | 在上述条件下投资的未来值 (12,682.50)

注释 年利率应除以 12，因为它是由按月计复利而得的。


IPMT

基于固定利率及等额分期付款方式，返回给定期数内对投资的利息偿还额。有关函数 IPMT 的参数和年金函数的详细信息，请参阅函数 PV。

语法

IPMT(rate,per,nper,pv,fv,type)

Rate 为各期利率。

Per 用于计算其利息数额的期数，必须在 1 到 nper 之间。

Nper 为总投资期，即该项投资的付款期总数。

Pv 为现值，即从该项投资开始计算时已经入帐的款项，或一系列未来付款的当前值的累积和，也称为本金。

Fv 为未来值，或在最后一次付款后希望得到的现金余额。如果省略 fv，则假设其值为零（例如，一笔贷款的未来值即为零）。

Type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。如果省略 type，则假设其值为零。

Type 值 | 支付时间
0 | 期末
1 | 期初

说明
  • 应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 对于所有参数，支出的款项，如银行存款，表示为负数；收入的款项，如股息收入，表示为正数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
10% | 年利率
1 | 用于计算其利息数额的期数
3 | 贷款的年限
8000 | 贷款的现值
公式 | 说明（结果）
=IPMT(A2/12, A3*3, A4, A5) | 在上述条件下贷款第一个月的利息 (-22.41)
=IPMT(A2, 3, A4, A5) | 在上述条件下贷款最后一年的利息（按年支付）(-292.45)

注释 利率除以 12 得到月利率。支付的年数乘以 12 得到支付次数。


IRR

返回由数值代表的一组现金流的内部收益率。这些现金流不必为均衡的，但作为年金，它们必须按固定的间隔产生，如按月或按年。内部收益率为投资的回收利率，其中包含定期支付（负值）和定期收入（正值）。

语法

IRR(values,guess)

Values 为数组或单元格的引用，包含用来计算返回的内部收益率的数字。

  • Values 必须包含至少一个正值和一个负值，以计算返回的内部收益率。
  • 函数 IRR 根据数值的顺序来解释现金流的顺序。故应确定按需要的顺序输入了支付和收入的数值。
  • 如果数组或引用包含文本、逻辑值或空白单元格，这些数值将被忽略。

Guess 为对函数 IRR 计算结果的估计值。

  • 迭代法用于计算函数 IRR。从 guess 开始，函数 IRR 进行循环计算，直至结果的精度达到 0.00001%。如果函数 IRR 经过 20 次迭代，仍未找到结果，则返回错误值 #NUM!。
  • 在大多数情况下，并不需要为函数 IRR 的计算提供 guess 值。如果省略 guess，假设它为 0.1 (10%)。
  • 如果函数 IRR 返回错误值 #NUM!，或结果没有靠近期望值，可用另一个 guess 值再试一次。

说明

函数 IRR 与函数 NPV（净现值函数）的关系十分密切。函数 IRR 计算出的收益率即是净现值为 0 时的利率。下面的公式显示了函数 NPV 和函数 IRR 的相互关系：

NPV(IRR(B1:B6),B1:B6) 等于 3.60E-08（在函数 IRR 计算的精度要求之中，数值 3.60E-08 可以当作 0 的有效值）。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
-70,000 | 某项业务的初期成本费用
12,000 | 前五年的净收入
15,000 | 前五年的净收入
18,000 | 前五年的净收入
21,000 | 前五年的净收入
26,000 | 前五年的净收入
公式 | 说明（结果）
=IRR(A2:A6) | 投资四年后的内部收益率 (-2%)
=IRR(A2:A7) | 五年后的内部收益率 (9%)
=IRR(A2:A4,-10%) | 若要计算两年后的内部收益率，需包含一个估计值 (-44%)


ISPMT

计算特定投资期内要支付的利息。提供此函数是为了与 Lotus 1-2-3 兼容。

语法

ISPMT(rate,per,nper,pv)

Rate 为投资的利率。

Per 为要计算利息的期数，此值必须在 1 到 nper 之间。

Nper 为投资的总支付期数。

Pv 为投资的当前值。对于贷款，pv 为贷款数额。

说明

  • 应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 对所有参数，都以负数代表现金支出（如存款或他人取款），以正数代表现金收入（如股息分红或他人存款）。
  • 有关财务函数的其他信息，请参阅 PV 函数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
10% | 年利率
1 | 期数
3 | 投资的年限
8000000 | 贷款额
公式 | 说明（结果）
=ISPMT(A2/12,A3,A4*12,A5) | 在上述条件下对贷款第一个月支付的利息 (-64814.8)
=ISPMT(A2,1,A4,A5) | 在上述条件下对贷款第一年支付的利息 (-533333)

注释 利率除以 12 得到月利率。支付的年数乘以 12 得到支付次数。


MIRR

返回某一连续期间内现金流的修正内部收益率。函数 MIRR 同时考虑了投资的成本和现金再投资的收益率。

语法

MIRR(values,finance_rate,reinvest_rate)

Values 为一个数组或对包含数字的单元格的引用。这些数值代表固定期间的一系列支出（负值）及收入（正值）。

  • 参数 Values 中必须至少包含一个正值和一个负值，才能计算修正后的内部收益率，否则函数 MIRR 会返回错误值 #DIV/0!。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。

Finance_rate 为现金流中使用的资金支付的利率。

Reinvest_rate 为将现金流再投资的收益率。

说明

  • 函数 MIRR 根据输入值的次序来解释现金流的次序。所以，务必按照实际的顺序输入支出和收入数额，并使用正确的正负号（现金流入用正值，现金流出用负值）。
  • 如果现金流的次数为 n，finance_rate 为 frate，而 reinvest_rate 为 rrate，则函数 MIRR 的计算公式为：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
-$120,000 | 资产原值
39,000 | 第一年的收益
30,000 | 第二年的收益
21,000 | 第三年的收益
37,000 | 第四年的收益
46,000 | 第五年的收益
10.00% | 120,000 贷款额的年利率
12.00% | 再投资收益的年利率
公式 | 说明（结果）
=MIRR(A2:A7, A8, A9) | 五年后投资的修正收益率 (13%)
=MIRR(A2:A5, A8, A9) | 三年后的修正收益率 (-5%)
=MIRR(A2:A7, A8, 14%) | 五年的修正收益率（基于 14% 的再投资率）(13%)


NPER

基于固定利率及等额分期付款方式，返回某项投资的总期数。

语法

NPER(rate, pmt, pv, fv, type)

有关函数 NPER 中各参数的详细说明及有关年金函数的详细信息，请参阅函数 PV。

Rate 为各期利率。

Pmt 为各期所应支付的金额，其数值在整个年金期间保持不变。通常，pmt 包括本金和利息，但不包括其他的费用及税款。

Pv 为现值，即从该项投资开始计算时已经入帐的款项，或一系列未来付款的当前值的累积和，也称为本金。

Fv 为未来值，或在最后一次付款后希望得到的现金余额。如果省略 fv，则假设其值为零（例如，一笔贷款的未来值即为零）。

Type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
12% | 年利率
-100 | 各期所付的金额
-1000 | 现值
10000 | 未来值
1 | 各期的支付时间在期初（请参见上面的信息）
公式 | 说明（结果）
=NPER(A2/12, A3, A4, A5, 1) | 在上述条件下投资的总期数 (60)
=NPER(A2/12, A3, A4, A5) | 在上述条件下投资的总期数，不包括在期初的支付 (60)
=NPER(A2/12, A3, A4) | 在上述条件下投资的总期数，不包括未来值 (-9.578)


NPV

通过使用贴现率以及一系列未来支出（负值）和收入（正值），返回一项投资的净现值。

语法

NPV(rate,value1,value2, ...)

Rate 为某一期间的贴现率，是一固定值。

Value1, value2, ... 为 1 到 29 个参数，代表支出及收入。

  • Value1, value2, ...在时间上必须具有相等间隔，并且都发生在期末。
  • NPV 使用 Value1,Value2, … 的顺序来解释现金流的顺序。所以务必保证支出和收入的数额按正确的顺序输入。
  • 如果参数为数值、空白单元格、逻辑值或数字的文本表达式，则都会计算在内；如果参数是错误值或不能转化为数值的文本，则被忽略。
  • 如果参数是一个数组或引用，则只计算其中的数字。数组或引用中的空白单元格、逻辑值、文本及错误值将被忽略。

说明

  • 函数 NPV 假定投资开始于 value1 现金流所在日期的前一期，并结束于最后一笔现金流的当期。函数 NPV 依据未来的现金流来进行计算。如果第一笔现金流发生在第一个期间的期初，则第一笔现金必须添加到函数 NPV 的结果中，而不应包含在 values 参数中。有关详细信息，请参阅下面的示例。
  • 如果 n 是数值参数表中的现金流的次数，则 NPV 的公式如下：

  • 函数 NPV 与函数 PV（现值）相似。PV 与 NPV 之间的主要差别在于：函数 PV 允许现金流在期初或期末开始。与可变的 NPV 的现金流数值不同，PV 的每一笔现金流在整个投资中必须是固定的。有关年金与财务函数的详细信息，请参阅函数 PV。
  • 函数 NPV 与函数 IRR（内部收益率）也有关，函数 IRR 是使 NPV 等于零的比率：NPV(IRR(...), ...) = 0。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
10% | 年贴现率
-10,000 | 一年前的初期投资
3,000 | 第一年的收益
4,200 | 第二年的收益
6,800 | 第三年的收益
公式 | 说明（结果）
=NPV(A2, A3, A4, A5, A6) | 该投资的净现值 (1,188.44)

在上例中，将开始投资的 $10,000 作为数值参数中的一个。这是因为付款发生在第一个期间的期末。

示例 2

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
8% | 年贴现率。可表示整个投资的通货膨胀率或利率。
-40,000 | 初期投资
8,000 | 第一年的收益
9,200 | 第二年的收益
10,000 | 第三年的收益
12,000 | 第四年的收益
14,500 | 第五年的收益
公式 | 说明（结果）
=NPV(A2, A4:A8)+A3 | 该投资的净现值 (1,922.06)
=NPV(A2, A4:A8, -9000)+A3 | 该投资的净现值，包括第六年中 9000 的赔付 (-3,749.47)

在上例中，一开始投资的 $40,000 并不包含在数值参数中，因为此项付款发生在第一个期间的期初。


PMT

基于固定利率及等额分期付款方式，返回贷款的每期付款额。

语法

PMT(rate,nper,pv,fv,type)

有关函数 PMT 中参数的详细说明，请参阅函数 PV。

Rate 贷款利率。

Nper 该项贷款的付款总数。

Pv 现值，或一系列未来付款的当前值的累积和，也称为本金。

Fv 为未来值，或在最后一次付款后希望得到的现金余额。如果省略 fv，则假设其值为零，也就是一笔贷款的未来值为零。

Type 数字 0（零）或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

说明
  • PMT 返回的支付款项包括本金和利息，但不包括税款、储备金支付或某些与贷款有关的费用。
  • 应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。

显示 提示

如果要计算贷款期间的支付总额，请用 PMT 返回值乘以 nper。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
8% | 年利率
10 | 支付的月份数
10000 | 贷款额
公式 | 说明（结果）
=PMT(A2/12, A3, A4) | 在上述条件下贷款的月支付额 (-1,037.03)
=PMT(A2/12, A3, A4, 0, 1) | 在上述条件下贷款的月支付额，不包括支付期限在期初的支付额 (-1,030.16)

示例 2

可以使用 PMT 来计算除贷款之外其他年金的支付额。

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
6% | 年利率
18 | 计划储蓄的年数
50,000 | 18 年内计划储蓄的数额
公式 | 说明（结果）
=PMT(A2/12, A3*12, 0, A4) | 为 18 年后最终得到 50,000，每个月应存的数额 (-129.08)

注释 利率除以 12 得到月利率。支付的年数乘以 12 得到支付次数。


PPMT

基于固定利率及等额分期付款方式，返回投资在某一给定期间内的本金偿还额。

语法

PPMT(rate,per,nper,pv,fv,type)

有关函数 PPMT 中参数的详细信息，请参阅函数 PV。

Rate 为各期利率。

Per 用于计算其本金数额的期数，必须介于 1 到 nper 之间。

Nper 为总投资期，即该项投资的付款期总数。

Pv 为现值，即从该项投资开始计算时已经入帐的款项，或一系列未来付款当前值的累积和，也称为本金。

Fv 为未来值，或在最后一次付款后希望得到的现金余额，如果省略 fv，则假设其值为零，也就是一笔贷款的未来值为零。

Type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

说明

应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明（结果）
10% | 年利率
2 | 贷款期限
2000 | 贷款额
公式 | 说明（结果）
=PPMT(A2/12, 1, A3*12, A4) | 贷款第一个月的本金支付 (-75.62)

注释 利率除以 12 将得到月利率。现金支出的年限乘以 12 将得到应偿还的数额。

示例 2

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明（结果）
8% | 年利率
10 | 贷款期限
200,000 | 贷款额
公式 | 说明（结果）
=PPMT(A2, A3, 10, A4) | 在上述条件下贷款最后一年的本金支付 (-27,598.05)


PV

返回投资的现值。现值为一系列未来付款的当前值的累积和。例如，借入方的借入款即为贷出方贷款的现值。

语法

PV(rate,nper,pmt,fv,type)

Rate 为各期利率。例如，如果按 10% 的年利率借入一笔贷款来购买汽车，并按月偿还贷款，则月利率为 10%/12（即 0.83%）。可以在公式中输入 10%/12、0.83% 或 0.0083 作为 rate 的值。

Nper 为年金中的总付款期数。例如，对于一笔 4 年期按月偿还的汽车贷款，共有 4*12（即 48）个偿款期数。可以在公式中输入 48 作为 nper 的值。

Pmt 为各期所应支付的金额，其数值在整个年金期间保持不变。通常 pmt 包括本金和利息，但不包括其他费用及税款。例如，$10,000 的年利率为 12% 的四年期汽车贷款的月偿还额为 $263.33。可以在公式中输入 -263.33 作为 pmt 的值。如果忽略 pmt，则必须包含 fv 参数。

Fv 为未来值，或在最后一次支付后希望得到的现金余额，如果省略 fv，则假设其值为零（一笔贷款的未来值即为零）。例如，如果需要在 18 年后支付 $50,000，则 $50,000 就是未来值。可以根据保守估计的利率来决定每月的存款额。如果忽略 fv，则必须包含 pmt 参数。

Type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

说明
  • 应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 以下函数应用于年金：
    PPMT
    PV
    FV
    IPMT
    PMT
    RATE

    年金是在一段连续期间内的一系列固定的现金付款。例如汽车贷款或抵押贷款就是年金。有关详细信息，请参阅各年金函数的详细说明。
  • 在年金函数中，支出的款项，如银行存款，表示为负数；收入的款项，如股息收入，表示为正数。例如，对于储户来说，$1000 银行存款可表示为参数 -1,000，而对于银行来说该参数为 1,000。
  • 一个金融参数可根据其他参数求得。如果 rate 不为 0，则：

    如果 rate 为 0，则：

    (pmt * nper) + pv + fv = 0

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
500 | 每月底一项保险年金的支出
8% | 投资收益率
20 | 付款的年限
公式 | 说明（结果）
=PV(A3/12, 12*A4, A2, , 0) | 在上述条件下年金的现值 (-59,777.15)。

结果为负值，因为这是一笔付款，亦即支出现金流。如果年金的购买成本是 (60,000)，则年金的现值 (59,777.15) 小于实际支付值。因此，这不是一项合算的投资。

注释 利率除以 12 得到月利率。支付的年数乘以 12 得到支付次数。


RATE

返回年金的各期利率。函数 RATE 通过迭代法计算得出，并且可能无解或有多个解。如果在进行 20 次迭代计算后，函数 RATE 的相邻两次结果没有收敛于 0.0000001，函数 RATE 将返回错误值 #NUM!。

语法

RATE(nper,pmt,pv,fv,type,guess)

有关参数 nper、pmt、pv、fv 及 type 的详细说明，请参阅函数 PV。

Nper 为总投资期，即该项投资的付款期总数。

Pmt 为各期付款额，其数值在整个投资期内保持不变。通常 pmt 包括本金和利息，但不包括其他费用或税金。如果忽略了 pmt，则必须包含 fv 参数。

Pv 为现值，即从该项投资开始计算时已经入帐的款项，或一系列未来付款当前值的累积和，也称为本金。

Fv 为未来值，或在最后一次付款后希望得到的现金余额。如果省略 fv，则假设其值为零（例如，一笔贷款的未来值即为零）。

Type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

Guess 为预期利率。

  • 如果省略预期利率，则假设该值为 10%。
  • 如果函数 RATE 不收敛，请改变 guess 的值。通常当 guess 位于 0 到 1 之间时，函数 RATE 是收敛的。

说明

应确认所指定的 guess 和 nper 单位的一致性，对于年利率为 12% 的 4 年期贷款，如果按月支付，guess 为 12%/12，nper 为 4*12；如果按年支付，guess 为 12%，nper 为 4。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
4 | 贷款期限
-200 | 每月支付
8000 | 贷款额
公式 | 说明（结果）
=RATE(A2*12, A3, A4) | 在上述条件下贷款的月利率 (1%)
=RATE(A2*12, A3, A4)*12 | 在上述条件下贷款的年利率（0.09241767 或 9.24%）

注释 贷款的年数乘以 12 为月数。


SLN

返回某项资产在一个期间中的线性折旧值。

语法

SLN(cost,salvage,life)

Cost 为资产原值。

Salvage 为资产在折旧期末的价值（也称为资产残值）。

Life 为折旧期限（有时也称作资产的使用寿命）。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
30,000 | 资产原值
7,500 | 资产残值
10 | 使用寿命
公式 | 说明（结果）
=SLN(A2, A3, A4) | 每年的折旧值 (2,250)


SYD

返回某项资产按年限总和折旧法计算的指定期间的折旧值。

语法

SYD(cost,salvage,life,per)

Cost 为资产原值。

Salvage 为资产在折旧期末的价值（也称为资产残值）。

Life 为折旧期限（有时也称作资产的使用寿命）。

Per 为期间，其单位与 life 相同。

说明

  • 函数 SYD 计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
30000 | 资产原值
7500 | 资产残值
10 | 使用寿命
公式 | 说明（结果）
=SYD(A2,A3,A4,1) | 第一年的折旧值 (4,090.91)
=SYD(A2,A3,A4,10) | 第十年的折旧值 (409.09)


VDB

使用双倍余额递减法或其他指定的方法，返回指定的任何期间内（包括部分期间）的资产折旧值。函数 VDB 代表可变余额递减法。

语法

VDB(cost,salvage,life,start_period,end_period,factor,no_switch)

Cost 为资产原值。

Salvage 为资产在折旧期末的价值（也称为资产残值）。

Life 为折旧期限（有时也称作资产的使用寿命）。

Start_period 为进行折旧计算的起始期间，Start_period 必须与 life 的单位相同。

End_period 为进行折旧计算的截止期间，End_period 必须与 life 的单位相同。

Factor 为余额递减速率（折旧因子），如果省略参数 factor，则函数假设 factor 为 2（双倍余额递减法）。如果不想使用双倍余额递减法，可改变参数 factor 的值。有关双倍余额递减法的详细说明，请参阅函数 DDB。

No_switch 为一逻辑值，指定当折旧值大于余额递减计算值时，是否转用直线折旧法。

  • 如果 no_switch 为 TRUE，那么即使折旧值大于余额递减计算值，VDB 也不转用线性折旧法。
  • 如果 no_switch 为 FALSE 或被省略，那么当折旧值大于余额递减计算值时，Excel 将转用线性折旧法。

除 no_switch 外的所有参数必须为正数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
2400 | 资产原值
300 | 资产残值
10 | 使用寿命
公式 | 说明（结果）
=VDB(A2, A3, A4*365, 0, 1) | 第一天的折旧值。 假定折旧因子为 2 (1.32)
=VDB(A2, A3, A4*12, 0, 1) | 第一个月的折旧值 (40.00)
=VDB(A2, A3, A4, 0, 1) | 第一年的折旧值 (480.00)
=VDB(A2, A3, A4*12, 6, 18) | 在第六个月与第十八个月之间的折旧值 (396.31)
=VDB(A2, A3, A4*12, 6, 18, 1.5) | 在第六个月与第十八个月之间的折旧值（用折旧因子 1.5 代替双倍余额法）(311.81)
=VDB(A2, A3, A4, 0, 0.875, 1.5) | 拥有资产的第一个财政年的折旧值（假定税法限制余额递减的折旧为 150%）。资产在财政年的第一个季度中间购买。(315.00)

注释 结果四舍五入到两位小数。


CELL

返回引用左上角单元格的格式、位置或内容信息。

语法

CELL(info_type,reference)

Info_type 为一个文本值，指定所需要的单元格信息的类型。下面列出 info_type 的可能值及相应的结果。

Info_type | 返回
"address" | 引用中第一个单元格的引用，文本类型。
"col" | 引用中单元格的列标。
"contents" | 引用中左上角单元格的值，不是公式。
"row" | 引用中单元格的行号。
"type" | 与单元格中的数据类型相对应的文本值。如果单元格为空，则返回“b”。如果单元格包含文本常量，则返回“l”；如果单元格包含其他内容，则返回“v”。

Reference 表示要获取其有关信息的单元格。如果省略，则在 info_type 中指定的信息将返回给最后更改的单元格。

说明

函数 CELL 用于与其他电子表格程序兼容。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
5-Mar
TOTAL
公式 | 说明（结果）
=CELL("row",A20) | 单元格 A20 的行号 (20)
=CELL("type",A2) | 单元格 A2 中的数据类型 (v)
=CELL("contents",A3) | 单元格 A3 的内容 (TOTAL)


COUNTBLANK

计算指定单元格区域中空白单元格的数目。

语法

COUNTBLANK(range)

Range 为需要计算其中空白单元格数目的区域。

说明

即使单元格中含有返回值为空文本 ("") 的公式，该单元格也会计算在内，但包含零值的单元格不计算在内。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 数据
6 | =IF(B4<30,"",B4)
 | 27
4 | 34
公式 | 说明（结果）
=COUNTBLANK(A2:B5) | 计算上面区域的空白单元格的数目。公式返回空文本单元格的数目。(3)


ERROR.TYPE

返回对应于电子表格中某一错误值的数字，或者，如果没有错误，则返回 #N/A。在函数 IF 中可以使用 ERROR.TYPE 检测错误值，并返回文本字符串（如消息）来取代错误值。

语法

ERROR.TYPE(error_val)

Error_val 为需要得到其标识号的错误值。尽管 error_val 可以为实际的错误值，但它通常为一个单元格引用，而此单元格中包含需要检测的公式。

如果 error_val 为 | 函数 ERROR.TYPE 返回
#NULL! | 1
#DIV/0! | 2
#VALUE! | 3
#REF! | 4
#NAME? | 5
#NUM! | 6
#N/A | 7
#CIRC! | 8
其他值 | #N/A

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
#NULL!
=1/0
公式 | 说明（结果）
=ERROR.TYPE(A2) | 错误值 #NULL! 的标号。(1)
=IF(ERROR.TYPE(A3)<3,CHOOSE(ERROR.TYPE(A3),"区域不相交","除数为零")) | 检测单元格 A3 以查看其是否包含错误值 #NULL! 或错误值 #DIV/0!。如果包含，CHOOSE 工作表函数将根据错误值的标识号来显示两条消息之一。否则，返回错误值 #N/A。（除数为零）


IS 类函数

本部分描述了用来检验数值或引用类型的九个电子表格函数。

这些函数，概括为 IS 类函数，可以检验数值的类型并根据结果返回 TRUE 或 FALSE。例如，如果数值为对空白单元格的引用，函数 ISBLANK 返回逻辑值 TRUE；否则，返回 FALSE。

语法

ISBLANK(value)
ISERR(value)
ISERROR(value)
ISLOGICAL(value)
ISNA(value)
ISNONTEXT(value)
ISNUMBER(value)
ISREF(value)
ISTEXT(value)

Value 为需要进行检验的数值。分别为：空白（空白单元格）、错误值、逻辑值、文本、数字、引用值或对于以上任意参数的名称引用。

函数 | 如果为下面的内容，则返回 TRUE
ISBLANK | 值为空白单元格。
ISERR | 值为任意错误值（除去 #N/A）。
ISERROR | 值为任意错误值（#N/A、#VALUE!、#REF!、#DIV/0!、#NUM!、#NAME? 或 #NULL!）。
ISLOGICAL | 值为逻辑值。
ISNA | 值为错误值 #N/A（值不存在）。
ISNONTEXT | 值为任意不是文本的项（注意此函数在值为空白单元格时返回 TRUE）。
ISNUMBER | 值为数字。
ISREF | 值为引用。
ISTEXT | 值为文本。

说明

  • IS 类函数的参数 value 是不可转换的。例如，在其他大多数需要数字的函数中，文本值“19”会被转换成数字 19。然而，在公式 ISNUMBER("19") 中，“19”并不会由文本值转换成别的类型的值，函数 ISNUMBER 返回 FALSE。
  • IS 类函数在用公式检验计算结果时十分有用。当它与函数 IF 结合在一起使用时，可以提供一种方法用来在公式中查出错误值（请参阅下面的示例）。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ISLOGICAL(TRUE) | 检验 TRUE 是否为逻辑值 (TRUE)
=ISLOGICAL("TRUE") | 检验“TRUE”是否为逻辑值 (FALSE)
=ISNUMBER(4) | 检验 4 是否为数字 (TRUE)

示例 2

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
Gold
Region1
#REF!
330.92
#N/A
公式 | 说明（结果）
=ISBLANK(A2) | 检验单元格 A2 是否为空白单元格 (FALSE)
=ISERROR(A4) | 检验 #REF! 是否为错误值 (TRUE)
=ISNA(A4) | 检验 #REF! 是否为错误值 #N/A (FALSE)
=ISNA(A6) | 检验 #N/A 是否为错误值 #N/A (TRUE)
=ISERR(A6) | 检验 #N/A 是否为错误值 (FALSE)
=ISNUMBER(A5) | 检验 330.92 是否为数字 (TRUE)
=ISTEXT(A3) | 检验 Region1 是否为文本 (TRUE)


N

返回转换为数字后的值。

语法

N(value)

Value 为要转换的值。函数 N 可以转换下表列出的值：

数值或引用 | N 返回值
数字 | 该数字
日期（电子表格的一种内部日期格式） | 该日期的序列号
TRUE | 1
FALSE | 0
错误值，例如 #DIV/0! | 错误值
其他值 | 0

说明
  • 一般情况下不必在公式中使用函数 N，这是因为值会根据需要自动进行转换。此函数用于与其他电子表格程序兼容。
  • 日期被存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日是序列号 1，2008 年 1 月 1 日是序列号 39,448，这是因为它距 1900 年 1 月 1 日有 39,448 天。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
7
Even
TRUE
2008-4-17
公式 | 说明（结果）
=N(A2) | 因为 A2 包含的是数字，所以返回该数字 (7)
=N(A3) | 因为 A3 包含的是文本，所以返回 0（请参见上面的信息）
=N(A4) | 因为 A4 是逻辑值 TRUE，所以返回 1（请参见上面的信息）
=N(A5) | 因为 A5 是日期，所以返回该日期的序列号（根据使用的日期系统会有变化）
=N("7") | 因为“7”是文本，所以返回 0（请参见上面的信息）


NA

返回错误值 #N/A。错误值 #N/A 表示“无法得到有效值”。请使用 NA 标志空白单元格。在没有内容的单元格中输入 #N/A，可以避免不小心将空白单元格计算在内而产生的问题（当公式引用到含有 #N/A 的单元格时，会返回错误值 #N/A）。

语法

NA( )

说明

  • 必须包括带有函数名称的空括号。否则，电子表格不会将其识别为函数。
  • 也可直接在单元格中键入 #N/A。提供 NA 函数是为了与其他电子表格程序兼容。


TYPE

返回值的类型。当某一个函数的计算结果取决于特定单元格中值的类型时，可使用函数 TYPE。

语法

TYPE(value)

Value 可以是任意值，如数字、文本、逻辑值等等。

如果 value 为 | 函数 TYPE 返回
数字 | 1
文本 | 2
逻辑值 | 4
错误值 | 16
数组 | 64

说明
  • 不能使用 TYPE 来确定单元格中是否含有公式。TYPE 只是确定结果、显示或值的类型。如果某个值是一个单元格引用，它所引用的另一个单元格中含有公式，则 TYPE 将返回此公式结果值的类型。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
Smith
公式 | 说明（结果）
=TYPE(A2) | 检验上面数值的类型 (2)
=TYPE("Mr."&A2) | 检验“Mr. Smith”的类型 (2)
=TYPE(2+A2) | 检验公式的类型，并返回错误值 #VALUE! (16)
=TYPE({1,2;3,4}) | 检验数组常量的类型 (64)


AND

所有参数的逻辑值为真时返回 TRUE；只要一个参数的逻辑值为假即返回 FALSE。

语法

AND(logical1,logical2,...)

Logical1, logical2, ... 为待检测的 1 到 30 个条件值，各条件值可为 TRUE，或为 FALSE。

说明

  • 参数必须是逻辑值（TRUE 或 FALSE），或者是包含逻辑值的数组或引用。
  • 如果数组或引用参数中包含文本或空白单元格，则这些值将被忽略。
  • 如果指定的单元格区域内包括非逻辑值，则 AND 将返回错误值 #VALUE!。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=AND(TRUE, TRUE) | 所有参数值为 TRUE (TRUE)
=AND(TRUE, FALSE) | 一个参数值为 FALSE (FALSE)
=AND(2+2=4, 2+3=5) | 所有参数的计算结果为 TRUE (TRUE)

示例 2

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
50
104
公式 | 说明（结果）
=AND(1<A2, A2<100) | 因为 50 在 1 到 100 之间 (TRUE)
=IF(AND(1<A3, A3<100), A3, "The value is out of range.") | 如果上面第二个数在 1 到 100 之间，则显示之。否则，显示一条消息。(The value is out of range.)
=IF(AND(1<A2, A2<100), A2, "The value is out of range.") | 如果上面的第一个数在 1 到 100 之间，则显示之。否则，显示一条消息。(50)


FALSE

返回逻辑值 FALSE。

语法

FALSE( )

说明

也可直接在工作表上或公式中键入单词 FALSE，该词将被解释为逻辑值 FALSE。


IF

执行真假值判断，根据逻辑计算的真假值，返回不同结果。

可以使用函数 IF 对数值和公式进行条件检测。

语法

IF(logical_test,value_if_true,value_if_false)

Logical_test 表示计算结果为 TRUE 或 FALSE 的任意值或表达式。例如，A10=100 就是一个逻辑表达式；如果单元格 A10 中的值等于 100，表达式即为 TRUE；否则为 FALSE。本参数可使用任何比较运算符。

Value_if_true logical_test 为 TRUE 时返回的值。例如，如果本参数为文本字符串“预算内”而且 logical_test 参数值为 TRUE，则 IF 函数将显示文本“预算内”。如果 logical_test 为 TRUE 而 value_if_true 为空，则本参数返回 0（零）。如果要显示 TRUE，则请为本参数使用逻辑值 TRUE。Value_if_true 也可以是其他公式。

Value_if_false logical_test 为 FALSE 时返回的值。例如，如果本参数为文本字符串“超出预算”而且 logical_test 参数值为 FALSE，则 IF 函数将显示文本“超出预算”。如果 logical_test 为 FALSE 且省略了 Value_if_false（即 value_if_true 后没有逗号），则会返回逻辑值 FALSE。如果 logical_test 为 FALSE 且 Value_if_false 为空（即 value_if_true 后有逗号，并紧跟着右括号），则本参数返回 0（零）。Value_if_false 也可以是其他公式。

说明

  • 函数 IF 可以嵌套七层，用 value_if_false 及 value_if_true 参数可以构造复杂的检测条件。请参阅下面最后一个示例。
  • 在计算参数 value_if_true 和 value_if_false 后，函数 IF 返回相应语句执行后的返回值。
  • 如果函数 IF 的参数包含数组，则在执行 IF 语句时，将计算数组中的每一个元素。
  • 其他函数可用于分析基于一定条件的数据。例如，如果要计算单元格区域内某个文本字符串或数字出现的次数，则可使用 COUNTIF 电子表格函数。如果要基于单元格区域中的某一文本字符串或数字求和，则可使用 SUMIF 电子表格函数。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
50
公式 | 说明（结果）
=IF(A2<=100,"预算内","超出预算") | 如果上面的数小于等于 100，则公式显示“预算内”。否则，该函数显示“超出预算”。（预算内）
=IF(A2=100,SUM(B5:B15),"") | 如果上面的数等于 100，则对单元格区域 B5:B15 进行求和计算，否则，返回空文本 ("")。()

示例 2

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
实际费用 | 预期费用
1500 | 900
500 | 900
500 | 925
公式 | 说明（结果）
=IF(A2>B2,"超出预算","预算内") | 检测第一行是否超出预算（超出预算）
=IF(A3>B3,"超出预算","预算内") | 检测第二行是否超出预算（预算内）

示例 3

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
成绩
45
90
78
公式 | 说明（结果）
=IF(A2>89,"A",IF(A2>79,"B", IF(A2>69,"C",IF(A2>59,"D","F")))) | 为第一个成绩指定一个用字母表示的评分等级 (F)
=IF(A3>89,"A",IF(A3>79,"B", IF(A3>69,"C",IF(A3>59,"D","F")))) | 为第二个成绩指定一个用字母表示的评分等级 (A)
=IF(A4>89,"A",IF(A4>79,"B", IF(A4>69,"C",IF(A4>59,"D","F")))) | 为第三个成绩指定一个用字母表示的评分等级 (C)

在上例中，第二个 IF 语句同时也是第一个 IF 语句的参数 value_if_false。同样，第三个 IF 语句是第二个 IF 语句的参数 value_if_false。例如，如果第一个 logical_test (Average > 89) 为 TRUE，则返回“A”；如果第一个 logical_test 为 FALSE，则计算第二个 IF 语句，以此类推。

可使用下列方式指定成绩的用字母表示的评分等级（假设只使用整数）。

如果成绩为 | 则返回
大于 89 | A
80 到 89 | B
70 到 79 | C
60 到 69 | D
小于 60 | F


NOT

对参数值求反。当要确保一个值不等于某一特定值时，可以使用 NOT 函数。

语法

NOT(logical)

Logical 为一个可以计算出 TRUE 或 FALSE 的逻辑值或逻辑表达式。

说明

如果逻辑值为 FALSE，函数 NOT 返回 TRUE；如果逻辑值为 TRUE，函数 NOT 返回 FALSE。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=NOT(FALSE) | 对 FALSE 求反 (TRUE)
=NOT(1+1=2) | 对计算结果为 TRUE 的等式求反 (FALSE)


OR

如果任何一个参数的逻辑值为 TRUE，即返回 TRUE；任何一个参数的逻辑值为 FALSE，即返回 FALSE。

语法

OR(logical1,logical2,...)

Logical1, logical2, ... 表示待检测的 1 到 30 个条件值，各条件值或为 TRUE，或为 FALSE。

说明

  • 参数必须能计算为逻辑值，如 TRUE 或 FALSE，或者为包含逻辑值的数组或引用。
  • 如果数组或引用参数中包含文本或空白单元格，则这些值将被忽略。
  • 如果指定的区域中不包含逻辑值，函数 OR 返回错误值 #VALUE!。
  • 可以使用 OR 数组公式来检验数组中是否包含特定的数值。若要输入数组公式，请按 Ctrl+Shift+Enter。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=OR(TRUE) | 某个参数为 TRUE (TRUE)
=OR(1+1=1,2+2=5) | 所有参数的计算结果均为 FALSE (FALSE)
=OR(TRUE,FALSE,TRUE) | 至少有一个参数为 TRUE (TRUE)


TRUE

返回逻辑值 TRUE。

语法

TRUE( )

说明

可以直接在单元格或公式中输入值 TRUE，而不使用此函数。函数 TRUE 主要用于与其他电子表格程序兼容。


ADDRESS

按照给定的行号和列标，建立文本类型的单元格地址。

语法

ADDRESS(row_num,column_num,abs_num,a1,sheet_text)

Row_num 在单元格引用中使用的行号。

Column_num 在单元格引用中使用的列标。

Abs_num 指定返回的引用类型。

Abs_num | 返回的引用类型
1 或省略 | 绝对引用
2 | 绝对行号，相对列标
3 | 相对行号，绝对列标
4 | 相对引用

A1 用以指定 A1 或 R1C1 引用样式的逻辑值。如果 A1 为 TRUE 或省略，则函数 ADDRESS 返回 A1 样式的引用；如果 A1 为 FALSE，则函数 ADDRESS 返回 R1C1 样式的引用。

Sheet_text 为一文本，指定作为外部引用的工作表的名称。如果省略 sheet_text，则不使用任何工作表名。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ADDRESS(2,3) | 绝对引用 ($C$2)
=ADDRESS(2,3,2) | 绝对行号，相对列标 (C$2)
=ADDRESS(2,3,2,FALSE) | 在 R1C1 引用样式中的绝对行号，相对列标 (R2C[3])
=ADDRESS(2,3,1,FALSE,"Sheet1") | 对另一张工作表的绝对引用 (Sheet1!R2C3)


AREAS

返回引用中包含的区域个数。区域表示连续的单元格范围或单个单元格。

语法

AREAS(reference)

Reference 对某一单元格或单元格区域的引用，也可以引用多个区域。如果需要将几个引用指定为一个参数，则必须用括号括起来，以免将逗号作为参数间的分隔符。请参阅下面的示例。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=AREAS(B2:D4) | 引用中包含的区域数 (1)
=AREAS((B2:D4,E5,F6:I9)) | 引用中包含的区域数 (3)
=AREAS((B2:D4,B2)) | 引用中包含的区域数 (2)


CHOOSE

可以使用 index_num 返回数值参数列表中的数值。使用函数 CHOOSE 可以基于索引号选择多达 29 个数值中的一个数值。例如，如果 value1 到 value7 表示一个星期的 7 天，那么将 1 到 7 之间的数字作为 index_num 时，函数 CHOOSE 返回其中的某一天。

语法

CHOOSE(index_num,value1,value2,...)

Index_num 用以指定所选定的数值参数。Index_num 必须为 1 到 29 之间的数字，或者是包含数字 1 到 29 的公式或单元格引用。

  • 如果 index_num 为 1，函数 CHOOSE 返回 value1；如果为 2，函数 CHOOSE 返回 value2，以此类推。

  • 如果 index_num 小于 1 或大于列表中最后一个值的索引号，函数 CHOOSE 返回错误值 #VALUE!。

  • 如果 index_num 为小数，则在使用前将被截尾取整。

Value1,value2,... 为 1 到 29 个数值参数，函数 CHOOSE 基于 index_num，从中选择一个数值或一项要执行的操作。参数可以为数字、单元格引用、定义名称、公式、函数或文本。

说明

  • 如果 index_num 为一数组，则在函数 CHOOSE 计算时，每一个值都将计算。
  • 函数 CHOOSE 的数值参数不仅可以为单个数值，也可以为区域引用。

    例如，下面的公式：

    SUM(CHOOSE(2,A1:A10,B1:B10,C1:C10))

    相当于：

    SUM(B1:B10)

    该函数基于区域 B1:B10 中的数值返回值。

    函数 CHOOSE 先被计算，返回引用 B1:B10。然后函数 SUM 用 B1:B10 进行求和计算。即函数 CHOOSE 的结果是函数 SUM 的参数。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 数据
1st | Nails
2nd | Screws
3rd | Nuts
完成 | Bolts
公式 | 说明（结果）
=CHOOSE(2,A2,A3,A4,A5) | 第二个参数 A3 的值 (2nd)
=CHOOSE(4,B2,B3,B4,B5) | 第四个参数 B5 的值 (Bolts)

示例 2

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
23
45
12
10
公式 | 说明（结果）
=SUM(A2:CHOOSE(2,A3,A4,A5)) | 单元格区域 A2:A4 中所有数值的和 (80)


COLUMN

返回给定引用的列标。

语法

COLUMN(reference)

Reference 为需要得到其列标的单元格或单元格区域。

说明

  • 如果省略 reference，则假定为是对函数 COLUMN 所在单元格的引用。
  • 如果 reference 为一个单元格区域，并且函数 COLUMN 作为水平数组输入，则函数 COLUMN 将以水平数组的形式返回 reference 中的列标。
  • Reference 不能引用多个区域。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=COLUMN() | 公式所在列的列标 (1)
=COLUMN(B10) | 引用列的列标 (2)


COLUMNS

返回数组或引用的列数。

语法

COLUMNS(array)

Array 为需要得到其列数的数组、数组公式或对单元格区域的引用。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=COLUMNS(C1:E4) | 单元格区域引用的列数 (3)
=COLUMNS({1,2,3;4,5,6}) | 数组常量的列数 (3)


HLOOKUP

在表格或数值数组的首行查找指定的数值，并由此返回表格或数组当前列中指定行处的数值。当比较值位于数据表的首行，并且要查找下面给定行中的数据时，请使用函数 HLOOKUP。当比较值位于要进行数据查找的左边一列时，请使用函数 VLOOKUP。

HLOOKUP 中的 "H" 代表“水平”。

语法

HLOOKUP(lookup_value,table_array,row_index_num,range_lookup)

Lookup_value 为需要在数据表第一行中进行查找的数值。Lookup_value 可以为数值、引用或文本字符串。

Table_array 为需要在其中查找数据的数据表。可以使用对区域或区域名称的引用。

  • Table_array 的第一行的数值可以为文本、数字或逻辑值。

  • 如果 range_lookup 为 TRUE，则 table_array 的第一行的数值必须按升序排列：...-2、-1、0、1、2、…、A-Z、FALSE、TRUE；否则，函数 HLOOKUP 将不能给出正确的数值。如果 range_lookup 为 FALSE，则 table_array 不必进行排序。

  • 文本不区分大小写。

  • 可通过在电子表格工具栏上单击 按钮图像 来对数值进行升序排列。

Row_index_num 为 table_array 中待返回的匹配值的行号。Row_index_num 为 1 时，返回 table_array 第一行的数值，row_index_num 为 2 时，返回 table_array 第二行的数值，以此类推。如果 row_index_num 小于 1，函数 HLOOKUP 返回错误值 #VALUE!；如果 row_index_num 大于 table-array 的行数，则函数 HLOOKUP 返回错误值 #REF!。

Range_lookup 为一逻辑值，指明函数 HLOOKUP 查找时是精确匹配，还是近似匹配。如果为 TRUE 或省略，则返回近似匹配值。也就是说，如果找不到精确匹配值，则返回小于 lookup_value 的最大数值。如果 range_value 为 FALSE，函数 HLOOKUP 将查找精确匹配值，如果找不到，则返回错误值 #N/A!。

说明

  • 如果函数 HLOOKUP 找不到 lookup_value，且 range_lookup 为 TRUE，则使用小于 lookup_value 的最大值。
  • 如果函数 HLOOKUP 小于 table_array 第一行中的最小数值，则函数 HLOOKUP 返回错误值 #N/A!。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
Axles | Bearings | Bolts
4 | 4 | 9
5 | 7 | 10
6 | 8 | 11
公式 | 说明（结果）
=HLOOKUP("Axles",A1:C4,2,TRUE) | 在第 1 行中查找 Axles，并返回同列中第 2 行的值。(4)
=HLOOKUP("Bearings",A1:C4,3,FALSE) | 在第 1 行中查找 Bearings，并返回同列中第 3 行的值。(7)
=HLOOKUP("B",A1:C4,3,TRUE) | 在第 1 行中查找 B，并返回同列中第 3 行的值。因为 B 不是精确匹配，所以将使用小于 B 的最大值 Axles。(5)
=HLOOKUP("Bolts",A1:C4,4) | 在第 1 行中查找 Bolts，并返回同列中第 4 行的值。(11)
=HLOOKUP(3,{1,2,3;"a","b","c";"d","e","f"},2,TRUE) | 在数组常量的第一行中查找 3，并返回同列中第 2 行的值。(c)


HYPERLINK

创建超链接，用以打开存储在网络服务器、Intranet 或 Internet 中的文件。当单击函数 HYPERLINK 所在的单元格时，将打开存储在 link_location 中的文件。

语法

HYPERLINK(link_location, friendly_name)

Link_location 为文档的路径和文件名，此文档可以作为文本打开。路径可以是存储在硬盘驱动器上的文件，或是服务器上的“通用命名规范”(UNC) 路径，或是在 Internet 或 Intranet 上的“统一资源定位符”(URL) 路径。

  • Link_location 可为括在引号中的文本字符串，或是包含文本字符串链接的单元格。

  • 如果在 link_location 中指定的跳转不存在或不能访问，则当单击单元格时将出现错误信息。

Friendly_name 为单元格中显示的跳转文本值或数字值。单元格的内容为蓝色并带有下划线。如果省略 Friendly_name，单元格将 link_location 显示为跳转文本。

  • Friendly_name 可以为数值、文本字符串、名称或包含跳转文本或数值的单元格。

  • 如果 Friendly_name 返回错误值（例如，#VALUE!），则单元格将显示错误值以替代跳转文本。

说明

若要选中一个含有超链接的单元格，而不想跳到超链接的目标地址，请单击与超链接所在单元格相邻的单元格，再使用箭头键来选择。

示例

下例打开一个存储在 Internet 的 example.microsoft.com/report 地址上的名为 Budget Report.xls 的电子表格，并显示文本“Click for report”：

=HYPERLINK("http://example.microsoft.com/report/budget report.xls", "Click for report")


INDEX

返回表或区域中的数值或对数值的引用。函数 INDEX() 有两种形式：数组和引用。数组形式通常返回数值或数值数组；引用形式通常返回引用。

INDEX(array,row_num,column_num) 返回数组中指定单元格的数值或单元格数值数组。

INDEX(reference,row_num,column_num,area_num) 返回引用中指定单元格的引用。

显示 语法 1（数组）

返回表或数组中的元素值，此元素由行号和列标的索引值给定。

INDEX 函数有两种语法形式：数组和引用。数组形式通常返回数值或数值数组；引用形式通常返回引用。当函数 INDEX 的第一个参数为数组常量时，使用数组形式。

语法 1

数组形式

INDEX(array,row_num,column_num)

Array 为单元格区域或数组常量。

  • 如果数组只包含一行或一列，则相对应的参数 row_num 或 column_num 为可选。

  • 如果数组有多行和多列，但只使用 row_num 或 column_num，函数 INDEX 返回数组中的整行或整列，且返回值也为数组。

Row_num 数组中某行的行号，函数从该行返回数值。如果省略 row_num，则必须有 column_num。

Column_num 数组中某列的列标，函数从该列返回数值。如果省略 column_num，则必须有 row_num。

说明

  • 如果同时使用 row_num 和 column_num，函数 INDEX 返回 row_num 和 column_num 交叉处的单元格的数值。
  • 如果将 row_num 或 column_num 设置为 0，函数 INDEX 则分别返回整列或整行的数值数组。若要使用作为数组返回的数值，请在某行的水平单元格区域和某列的垂直单元格区域将 INDEX 函数作为数组公式输入。若要输入数组公式，请按 Ctrl+Shift+Enter。

  • Row_num 和 column_num 必须指向 array 中的某一单元格；否则，函数 INDEX 返回错误值 #REF!。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 数据
苹果 | 柠檬
香蕉 | 梨
公式 | 说明（结果）
=INDEX(A2:B3,2,2) | 位于区域中第二行和第二列交叉处的数值（梨）
=INDEX(A2:B3,2,1) | 位于区域中第二行和第一列交叉处的数值（香蕉）

示例 2

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=INDEX({1,2;3,4},0,2) | 数组常量中第一行，第二列中的数值 (2)
 | 数组常量中第二行，第二列中的数值 (4)

注释 示例中的公式必须以数组公式的形式输入。将示例复制到空白电子表格后，请选中以公式单元格开始的区域 A2:A3。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果为 2。

显示 语法 2（引用）

返回指定的行与列交叉处的单元格引用。如果引用由不连续的选定区域组成，可以选择某一选定区域。

函数 INDEX 有两种语法形式：数组和引用。数组形式通常返回数值或数值数组；引用形式通常返回引用。

语法 2

引用形式

INDEX(reference,row_num,column_num,area_num)

Reference 对一个或多个单元格区域的引用。

  • 如果为引用输入一个不连续的区域，必须将其用括号括起来。

  • 如果引用中的每个区域只包含一行或一列，则相应的参数 row_num 或 column_num 分别为可选项。例如，对于单行的引用，可以使用函数 INDEX(reference,,column_num)。

Row_num 引用中某行的行号，函数从该行返回一个引用。

Column_num 引用中某列的列标，函数从该列返回一个引用。

Area_num 选择引用中的一个区域，并返回该区域中 row_num 和 column_num 的交叉区域。选中或输入的第一个区域序号为 1，第二个为 2，以此类推。如果省略 area_num，函数 INDEX 使用区域 1。

  • 例如，如果引用描述的单元格为 (A1:B4,D1:E4,G1:H4)，则 area_num 1 为区域 A1:B4，area_num 2 为区域 D1:E4，而 area_num 3 为区域 G1:H4。

说明

  • reference 和 area_num 选择了特定的区域后，row_num 和 column_num 将进一步选择特定的单元格：row_num 1 为区域的首行，column_num 1 为首列，以此类推。函数 INDEX 返回的引用即为 row_num 和 column_num 的交叉区域。

  • 如果将 row_num 或 column_num 设置为 0，函数 INDEX 分别返回对整列或整行的引用。

  • Row_num、column_num 和 area_num 必须指向 reference 中的单元格；否则，函数 INDEX 返回错误值 #REF!。如果省略 row_num 和 column_num，函数 INDEX 返回由 area_num 所指定的引用中的区域。
  • 函数 INDEX 的结果为一个引用，且在其他公式中也被解释为引用。根据公式的需要，函数 INDEX 的返回值可以作为引用或是数值。例如，公式 CELL("width",INDEX(A1:B2,1,2)) 等价于公式 CELL("width",B1)。CELL 函数将函数 INDEX 的返回值作为单元格引用。而在另一方面，公式 2*INDEX(A1:B2,1,2) 将函数 INDEX 的返回值解释为 B1 单元格中的数字。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
水果 | 价格 | 数量
苹果 | .69 | 40
香蕉 | .34 | 38
柠檬 | .55 | 15
桔子 | .25 | 25
梨 | .59 | 40
杏 | 2.80 | 10
腰果 | 3.55 | 16
花生 | 1.25 | 20
胡桃 | 1.75 | 12
公式 | 说明（结果）
=INDEX(A2:C6,2,3) | 区域 A2:C6 中第二行和第三列的交叉处，即单元格 C3 的内容。(38)
=INDEX((A1:C6,A8:C11),2,2,2) | 第二个区域 A8:C11 中第二行和第二列的交叉处，即单元格 B9 的内容。(3.55)
=SUM(INDEX(A1:C11,0,3,1)) | 对第一个区域 A1:C11 中的第三列求和，即对 C1:C6 求和。(216)


INDIRECT

返回由文本字符串指定的引用。此函数立即对引用进行计算，并显示其内容。当需要更改公式中单元格的引用，而不更改公式本身时，请使用函数 INDIRECT。

语法

INDIRECT(ref_text,a1)

Ref_text 为对单元格的引用，此单元格可以包含 A1-样式的引用、R1C1-样式的引用、定义为引用的名称或对文本字符串单元格的引用。如果 ref_text 不是合法的单元格的引用，函数 INDIRECT 返回错误值 #REF!。

  • 如果 ref_text 是对另一个工作簿的引用（外部引用），则那个工作簿必须被打开。如果源工作簿没有打开，函数 INDIRECT 返回错误值 #REF!。

A1 为一逻辑值，用于指定包含在单元格 ref_text 中的引用类型。

  • 如果 a1 为 TRUE 或省略，ref_text 被解释为 A1-样式引用。

  • 如果 a1 为 FALSE，ref_text 被解释为 R1C1-样式引用。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 数据
B2 | 1.333
B3 | 45
George | 10
5 | 62
公式 | 说明（结果）
=INDIRECT($A$2) | 单元格 A2 中的引用值 (1.333)
=INDIRECT($A$3) | 单元格 A3 中的引用值 (45)
=INDIRECT($A$4) | 如果单元格 B4 有定义名“George”，则返回定义名的值 (10)
=INDIRECT("B"&$A$5) | 单元格 A5 中的引用值 (62)

当创建引用某个单元格的公式时，如果按“剪切”删除了单元格，或者由于插入或删除了行或列，从而使单元格发生了移动，则单元格引用将被更新。如果需要公式始终引用相同的单元格，而不管单元格上方的行是否被删除或单元格是否移动，则请使用 INDIRECT 工作表函数。例如，如果需要始终对单元格 A10 进行引用，请使用下面的语法：

INDIRECT("A10")


LOOKUP

返回向量（单行区域或单列区域）或数组中的数值。函数 LOOKUP 有两种语法形式：向量和数组。函数 LOOKUP 的向量形式是在单行区域或单列区域（向量）中查找数值，然后返回第二个单行区域或单列区域中相同位置的数值。函数 LOOKUP 的数组形式是在数组的第一行或第一列中查找指定的数值，然后返回数组的最后一行或最后一列中相同位置的数值。

显示 语法 1（向量）

LOOKUP(lookup_value,lookup_vector,result_vector)

Lookup_value 为函数 LOOKUP 在第一个向量中所要查找的数值。Lookup_value 可以为数字、文本、逻辑值或包含数值的名称或引用。

Lookup_vector 为只包含一行或一列的区域。Lookup_vector 的数值可以为文本、数字或逻辑值。

要点 Lookup_vector 的数值必须按升序排序：...、-2、-1、0、1、2、...、A-Z、FALSE、TRUE；否则，函数 LOOKUP 不能返回正确的结果。文本不区分大小写。

Result_vector 只包含一行或一列的区域，其大小必须与 lookup_vector 相同。

说明

  • 如果函数 LOOKUP 找不到 lookup_value，则查找 lookup_vector 中小于或等于 lookup_value 的最大数值。
  • 如果 lookup_value 小于 lookup_vector 中的最小值，则函数 LOOKUP 返回错误值 #N/A。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
频率 | 颜色
4.14 | 红色
4.19 | 橙色
5.17 | 黄色
5.77 | 绿色
6.39 | 蓝色
公式 | 说明（结果）
=LOOKUP(4.91,A2:A6,B2:B6) | 在 A 列中查找 4.19，然后返回同一行 B 列的值（橙色）
=LOOKUP(5.00,A2:A6,B2:B6) | 在 A 列中查找 5.00，然后返回同一行 B 列的值（橙色）
=LOOKUP(7.66,A2:A6,B2:B6) | 在 A 列中查找 7.66，匹配值为相邻的最小值 (6.39)，然后返回与该值处于同一行的 B 列的值（蓝色）
=LOOKUP(0,A2:A6,B2:B6) | 在 A 列中查找 0，因为 0 小于 lookup_vector A2:A7 中的最小值，所以返回错误值 (#N/A)

显示 语法 2（数组）

LOOKUP(lookup_value,array)

Lookup_value 为函数 LOOKUP 在数组中所要查找的数值。Lookup_value 可以为数字、文本、逻辑值或包含数值的名称或引用。

  • 如果函数 LOOKUP 找不到 lookup_value，则使用数组中小于或等于 lookup_value 的最大数值。

  • 如果 lookup_value 小于第一行或第一列（取决于数组的维数）的最小值，则函数 LOOKUP 返回错误值 #N/A。

Array 为包含文本、数字或逻辑值的单元格区域，它的值用于与 lookup_value 进行比较。

函数 LOOKUP 的数组形式与函数 HLOOKUP 和函数 VLOOKUP 非常相似。不同之处在于函数 HLOOKUP 在第一行查找 lookup_value，函数 VLOOKUP 在第一列查找，而函数 LOOKUP 则按照数组的维数查找。

  • 如果数组所包含的区域宽度大，高度小（即列数多于行数），则函数 LOOKUP 在第一行查找 lookup_value。

  • 如果数组为正方形，或者所包含的区域高度大，宽度小（即行数多于列数），则函数 LOOKUP 在第一列查找 lookup_value。

  • 函数 HLOOKUP 和函数 VLOOKUP 允许按行或按列索引，而函数 LOOKUP 总是选择行或列的最后一个数值。

要点 数组的数值必须按升序排序：...、-2、-1、0、1、2、...、A-Z、FALSE、TRUE；否则，函数 LOOKUP 不能返回正确的结果。文本不区分大小写。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=LOOKUP("C",{"a","b","c","d";1,2,3,4}) | 在数组的第一行查找“C”，然后返回同一列最后一行的值 (3)
=LOOKUP("bump",{"a",1;"b",2;"c",3}) | 在数组的第一列查找“bump”，然后返回同一行最后一列的值 (2)


MATCH

返回在指定方式下与指定数值匹配的数组中元素的相应位置。如果需要在区域中找出匹配元素的位置而不是匹配元素本身，则应该使用函数 MATCH 而不是函数 LOOKUP。

语法

MATCH(lookup_value,lookup_array,match_type)

Lookup_value 为需要在数据表中查找的数值。

  • Lookup_value 为需要在 Look_array 中查找的数值。例如，如果要在电话簿中查找某人的电话号码，则应该将姓名作为查找值，但实际上需要的是电话号码。

  • Lookup_value 可以为数值（数字、文本或逻辑值）或对数字、文本或逻辑值的单元格引用。

Lookup_array 可能包含所要查找的数值的连续单元格区域。Lookup_array 必须为数组或数组引用。

Match_type 为数字 -1、0 或 1。Match-type 指明 lookup_value 如何在 lookup_array 中查找数值。

  • 如果 match_type 为 1，函数 MATCH 查找小于或等于 lookup_value 的最大数值。Lookup_array 必须按升序排列：...、-2、-1、0、1、2、...、A-Z、FALSE、TRUE。

  • 如果 match_type 为 0，函数 MATCH 查找等于 lookup_value 的第一个数值。Lookup_array 可以按任何顺序排列。

  • 如果 match_type 为 -1，函数 MATCH 查找大于或等于 lookup_value 的最小数值。Lookup_array 必须按降序排列：TRUE、FALSE、Z-A、 ...2、 1、 0、 -1、 -2、 ...，等等。

  • 如果省略 match_type，则假设为 1。

说明

  • 函数 MATCH 返回 lookup_array 中目标值的位置，而不是数值本身。例如，MATCH("b",{"a","b","c"},0) 返回 2，即“b”在数组 {"a","b","c"} 中的相应位置。
  • 查找文本值时，函数 MATCH 不区分大小写字母。
  • 如果函数 MATCH 查找不成功，则返回错误值 #N/A。
  • 如果 match_type 为 0 且 lookup_value 为文本，lookup_value 可以包含通配符星号 (*) 和问号 (?)。星号可以匹配任何字符序列；问号可以匹配任何单个字符。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
产品 | 数量
香蕉 | 25
桔子 | 38
苹果 | 40
梨 | 41
公式 | 说明（结果）
=MATCH(39,B2:B5,1) | 因为没有精确匹配，所以返回的是区域 B2:B5 中的相邻最小值 (38) 的位置。(2)
=MATCH(41,B2:B5,0) | 区域 B2:B5 中的 41 的位置。(4)
=MATCH(40,B2:B5,-1) | 因为区域 B2:B5 不是按降序排列，所以返回一个错误值。(#N/A)


OFFSET

以指定的引用为参照系，通过给定偏移量返回新的引用。返回的引用可以为一个单元格或单元格区域。并可以指定返回的行数或列数。

语法

OFFSET(reference,rows,cols,height,width)

Reference 作为偏移量参照系的引用区域。Reference 引用的必须是单元格或相连单元格区域；否则，函数 OFFSET 返回错误值 #VALUE!。

Rows 相对于偏移量参照系的左上角单元格，上（下）偏移的行数。如果使用 5 作为参数 Rows，则说明目标引用区域的左上角单元格比 reference 低 5 行。行数可为正数（代表在起始引用的下方）或负数（代表在起始引用的上方）。

Cols 相对于偏移量参照系的左上角单元格，左（右）偏移的列数。如果使用 5 作为参数 Cols，则说明目标引用区域的左上角的单元格比 reference 靠右 5 列。列数可为正数（代表在起始引用的右边）或负数（代表在起始引用的左边）。

Height 高度，即所要返回的引用区域的行数。Height 必须为正数。

Width 宽度，即所要返回的引用区域的列数。Width 必须为正数。

说明

  • 如果行数和列数偏移量超出电子表格的边缘，函数 OFFSET 返回错误值 #REF!。

  • 如果省略 height 或 width，则假设其高度或宽度与 reference 相同。

  • 函数 OFFSET 实际上并不移动任何单元格或更改选定区域，它只是返回一个引用。函数 OFFSET 可用于任何需要将引用作为参数的函数。例如，公式 SUM(OFFSET(C2,1,2,3,1)) 将计算比单元格 C2 靠下 1 行并靠右 2 列的 3 行 1 列的区域的总值。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=OFFSET(C3,2,3,1,1) | 显示单元格 F5 中的数值 (0)
=SUM(OFFSET(C3:E5,-1,0,3,3)) | 对区域 C2:E4 求和 (0)
=OFFSET(C3:E5,0,-3,3,3) | 返回错误值，因为引用不在电子表格上 (#REF!)


ROW

返回引用的行号。

语法

ROW(reference)

Reference 为需要得到其行号的单元格或单元格区域。

  • 如果省略 reference，则假定是对函数 ROW 所在单元格的引用。

  • 如果 reference 为一个单元格区域，并且函数 ROW 作为垂直数组输入，则函数 ROW 将 reference 的行号以垂直数组的形式返回。

  • reference 不能引用多个区域。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ROW() | 公式所在的行 (2)
=ROW(C10) | 引用的行 (10)

示例 2

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ROW(C4:D6) | 引用中的首行 (4)
 | 引用中的第二行 (5)
 | 引用中的第三行 (6)

注释 示例中的公式必须以数组公式的形式输入。将示例复制到空白电子表格中后，请选中以公式单元格开始的区域 A2:A4。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果为 4。


ROWS

返回引用或数组中的行数。

语法

ROWS(array)

Array 为需要得到其行数的数组、数组公式或对单元格区域的引用。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ROWS(C1:E4) | 引用中的行数 (4)
=ROWS({1,2,3;4,5,6}) | 数组常量中的行数 (2)


TRANSPOSE

返回转置单元格区域，即将一行单元格区域转置成一列单元格区域，反之亦然。在行列数分别与数组的行列数相同的区域中，必须将 TRANSPOSE 输入为数组公式。使用 TRANSPOSE 可在电子表格中转置数组的垂直和水平方向。

语法

TRANSPOSE(array)

Array 为需要进行转置的数组或电子表格中的单元格区域。所谓数组的转置就是，将数组的第一行作为新数组的第一列，数组的第二行作为新数组的第二列，以此类推。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 数据 | 数据
1 | 2 | 3
公式 | 说明（结果）
=TRANSPOSE($A$2:$C$2) | 第一列中的值 (1)
 | 第二列中的值 (2)
 | 第三列中的值 (3)

注释 必须将示例中的公式以数组公式的形式输入。将示例复制到空白电子表格后，选中以公式单元格开始的区域 A4:A6。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果值为 1。

示例 2

一些函数（如 LINEST 函数）可返回水平数组。LINEST 返回一条直线的斜率和 Y 截距的水平数组。下面的公式从 LINEST 返回斜率和 Y 截距的垂直数组。

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
已知 y | 已知 x
1 | 0
9 | 4
5 | 2
7 | 3
公式 | 说明（结果）
=TRANSPOSE(LINEST(A2:A5,B2:B5,,FALSE)) | 斜率 (2)
 | Y 轴截距 (1)

注释 示例中的公式必须以数组公式输入。在将示例复制到一张空白电子表格后，选择以公式单元格开始的区域 A7:A8。按 F2，再按 Ctrl+Shift+Enter。如果公式不是以数组公式输入，则单个结果值为 2。


VLOOKUP

在表格的首列查找指定的数值，并由此返回表格当前行中指定列处的数值。当比较值位于数据表首列时，可以使用函数 VLOOKUP 代替函数 HLOOKUP。

函数 VLOOKUP 中的 V 代表 Vertical（垂直）。

语法

VLOOKUP(lookup_value,table_array,col_index_num,range_lookup)

Lookup_value 为需要在数组第一列中查找的数值。Lookup_value 可以为数值、引用或文本字符串。

Table_array 为需要在其中查找数据的数据表。可以使用对区域或区域名称的引用，例如数据库或数据清单。

  • 如果 range_lookup 为 TRUE，则 table_array 的第一列中的数值必须按升序排列：…、-2、-1、0、1、2、…、-Z、FALSE、TRUE；否则，函数 VLOOKUP 不能返回正确的数值。如果 range_lookup 为 FALSE，table_array 不必进行排序。

  • 单击电子表格工具栏上的“升序” 按钮图像 可将数值按升序排序。

  • Table_array 的第一列中的数值可以为文本、数字或逻辑值。

  • 文本不区分大小写。

Col_index_num 为 table_array 中待返回的匹配值的列序号。Col_index_num 为 1 时，返回 table_array 第一列中的数值；col_index_num 为 2，返回 table_array 第二列中的数值，以此类推。如果 col_index_num 小于 1，函数 VLOOKUP 返回错误值 #VALUE!；如果 col_index_num 大于 table_array 的列数，函数 VLOOKUP 返回错误值 #REF!。

Range_lookup 为一逻辑值，指明函数 VLOOKUP 返回值是精确匹配还是近似匹配。如果为 TRUE 或省略，则返回近似匹配值，也就是说，如果找不到精确匹配值，则返回小于 lookup_value 的最大数值；如果 range_value 为 FALSE，函数 VLOOKUP 将返回精确匹配值。如果找不到，则返回错误值 #N/A。

说明

  • 如果函数 VLOOKUP 找不到 lookup_value，且 range_lookup 为 TRUE，则使用小于或等于 lookup_value 的最大值。
  • 如果 lookup_value 小于 table_array 第一列中的最小数值，函数 VLOOKUP 返回错误值 #N/A。
  • 如果函数 VLOOKUP 找不到 lookup_value 且 range_lookup 为 FALSE，函数 VLOOKUP 返回错误值 #N/A。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。

该示例使用的是 1 个标准大气压下的空气参数。

密度 | 粘性 | 温度
.457 | 3.55 | 500
.525 | 3.25 | 400
.616 | 2.93 | 300
.675 | 2.75 | 250
.746 | 2.57 | 200
.835 | 2.38 | 150
.946 | 2.17 | 100
1.09 | 1.95 | 50
1.29 | 1.71 | 0
公式 | 说明（结果）
=VLOOKUP(1,A2:C10,2) | 在 A 列查找 1，并返回同一行 B 列的值。(2.17)
=VLOOKUP(1,A2:C10,3,TRUE) | 在 A 列查找 1，并返回同一行 C 列的值。(100)
=VLOOKUP(.7,A2:C10,3,FALSE) | 在 A 列查找 0.746。因为 A 列没有精确匹配值，所以返回一个错误值。(#N/A)
=VLOOKUP(0.1,A2:C10,2,TRUE) | 在 A 列查找 0.1。因为 0.1 小于 A 列中的最小值，所以返回一个错误值。(#N/A)
=VLOOKUP(2,A2:C10,2,TRUE) | 在 A 列查找 2，并返回同一行 B 列的值。(1.71)


ABS

返回参数的绝对值，参数绝对值是参数去掉正负号后的数值。

语法

ABS(number)

Number 为需要计算其绝对值的实数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
-4
公式 | 说明（结果）
=ABS(2) | 2 的绝对值 (2)
=ABS(-2) | -2 的绝对值 (2)
=ABS(A2) | -4 的绝对值 (4)


ACOS

返回参数的反余弦值。反余弦值为一个角度，而该角度的余弦值即为该函数的参数。返回的角度值以弧度表示，范围是 0 到 pi。

语法

ACOS(number)

Number 为角度的余弦值，必须介于 -1 到 1 之间。

说明

如果要用度表示反余弦值，需将结果再乘以 180/PI() 或使用 DEGREES 函数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ACOS(-0.5) | 用弧度表示的 -0.5 的反余弦值，即 2*pi/3 (2.094395)
=ACOS(-0.5)*180/PI() | 用度表示 -0.5 的反余弦值 (120)
=DEGREES(ACOS(-0.5)) | 用度表示 -0.5 的反余弦值 (120)


ACOSH

返回参数的反双曲余弦值。参数 Number 必须大于或等于 1。反双曲余弦值的双曲余弦即为该函数的参数，因此 ACOSH(COSH(number)) 等于 number。

语法

ACOSH(number)

Number 为大于等于 1 的实数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ACOSH(1) | 1 的反双曲余弦值 (0)
=ACOSH(10) | 10 的反双曲余弦值 (2.993223)


ASIN

返回参数的反正弦值。反正弦值为一个角度，该角度的正弦值即等于此函数的参数。返回的角度值将以弧度表示，范围为 -pi/2 到 pi/2。

语法

ASIN(number)

Number 为角度的正弦值，必须介于 -1 到 1 之间。

说明

若要用度表示反正弦值，需将结果再乘以 180/PI()，或使用 DEGREES 函数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ASIN(-0.5) | 用弧度表示的 -0.5 的反正弦值，即 -pi/6 (-0.5236)
=ASIN(-0.5)*180/PI() | 用度表示的 -0.5 的反正弦值 (-30)
=DEGREES(ASIN(-0.5)) | 用度表示的 -0.5 的反正弦值 (-30)


ASINH

返回参数的反双曲正弦值，反双曲正弦值的双曲正弦即等于此函数的参数值，因此，ASIINH(SLNH(number)) 的值等于 number。

语法

ASINH(number)

Number 为任意实数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ASINH(-2.5) | -2.5 的反双曲正弦值 (-1.64723)
=ASINH(10) | 10 的反双曲正弦值 (2.998223)


ATAN

返回参数的反正切值。反正切值为角度，其正切值即等于参数值。返回的角度值将以弧度表示，范围为 -pi/2 到 pi/2。

语法

ATAN(number)

Number 为角度的正切值。

说明

若要以度表示反正切值，需将结果再乘以 180/PI()，或使用 DEGREES 函数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ATAN(1) | 用弧度表示的 1 的反正切值，即 pi/4 (0.785398)
=ATAN(1)*180/PI() | 用度表示的 1 的反正切值 (45)
=DEGREES(ATAN(1)) | 用度表示的 1 的反正切值 (45)


ATAN2

返回给定的 X 及 Y 坐标值的反正切值。反正切的角度值等于 X 轴与通过原点 (0, 0) 和给定坐标点 (x_num, y_num) 的直线之间的夹角。结果以弧度表示并介于 -pi 到 pi 之间（不包括 -pi）。

语法

ATAN2(x_num,y_num)

X_num 为点的 X 坐标。

Y_num 为点的 Y 坐标。

说明

  • 结果为正，表示从 X 轴逆时针旋转的角度，结果为负，表示从 X 轴顺时针旋转的角度。
  • ATAN2(a, b) 等于 ATAN(b/a)，除非 ATAN2 值为零。
  • 如果 x_num 和 y_num 都为零，ATAN2 返回错误值 #DIV/0!。
  • 若要用度表示反正切值，需将结果再乘以 180/PI()，或使用 DEGREES 函数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ATAN2(1, 1) | 用弧度表示的点 (1,1) 的反正切值，即 pi/4 (0.785398)
=ATAN2(-1, -1) | 用弧度表示的点 (-1,-1) 的反正切值，即 -3*pi/4 的值 (-2.35619)
=ATAN2(-1, -1)*180/PI() | 用度表示的点 (1,1) 的反正切值 (-135)
=DEGREES(ATAN2(-1, -1)) | 用度表示的点 (1,1) 的反正切值 (-135)


ATANH

返回参数的反双曲正切值，参数必须在 -1 到 1 之间（除去 -1 和 1）。反双曲正切值的双曲正切即为该函数的参数值，因此 ATANH(TANH(number)) 等于 number。

语法

ATANH(number)

Number 为 -1 到 1 之间的任意实数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ATANH(0.76159416) | 0.76159416 的反双曲正切值（约等于 1）
=ATANH(-0.1) | -0.1 的反双曲正切值 (-0.10034)


CEILING

将参数 Number 沿绝对值增大的方向向上舍入为最接近的 Significance 的倍数。例如，如果您不愿意使用像“分”这样的零钱，而所要购买的商品价格为 $4.42，可以用公式 =CEILING(4.42,0.1) 将价格向上舍入为以“角”表示。

语法

CEILING(number,significance)

Number 为待舍入的数值。

Significance 基数。

说明

  • 如果参数为非数值型，CEILING 返回错误值 #VALUE!。
  • 无论数字符号如何，都按远离 0 的方向舍入。如果 Number 已经为 Significance 的倍数，则不进行舍入。
  • 如果 Number 和 Significance 符号不同，CEILING 返回错误值 #NUM!。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=CEILING(2.5, 1) | 将 2.5 沿绝对值增大的方向，舍入为最接近的基数 1 的最小倍数 (3)
=CEILING(-2.5, -2) | 将 -2.5 沿绝对值增大的方向，舍入为最接近的基数 -2 的最小倍数 (-4)
=CEILING(-2.5, 2) | 返回错误值，因为 -2.5 和 2 符号不同 (#NUM!)
=CEILING(1.5, 0.1) | 将 1.5 沿绝对值增大的方向，舍入为最接近的基数 0.1 的最小倍数 (1.5)
=CEILING(0.234, 0.01) | 将 0.234 沿绝对值增大的方向，舍入为最接近的基数 0.01 的最小倍数 (0.24)


COMBIN

计算从给定的项目数中提取若干项目的组合数。利用函数 COMBIN 可以确定给定的项目数中所有可能的项目组合数。

语法

COMBIN(number,number_chosen)

Number 为项目的数量。

Number_chosen 为每一组合中项目的数量。

说明

  • 数字参数截尾取整。
  • 如果任一参数为非数字型，则函数 COMBIN 返回错误值 #VALUE!。
  • 如果 number < 0、number_chosen < 0 或 number < number_chosen，则函数 COMBIN 返回错误值 #NUM!。
  • 项目组合为任意项目集或项目子集，而不论其内部顺序。组合与排列不同，排列与项目顺序有关。
  • 组合数计算公式如下，式中 number = n，number_chosen = k：

    式中：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=COMBIN(8,2) | 8 个候选人中可组成的两人组的数量 (28)


COS

返回给定角度的余弦值。

语法

COS(number)

Number 为需要求余弦的角度，以弧度表示。

说明

如果参数的单位是度，则可乘以 PI()/180 或使用函数 RADIANS 将其转换为弧度。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=COS(1.047) | 1.047 弧度的余弦值 (0.500171)
=COS(60*PI()/180) | 60 度的余弦值 (0.5)
=COS(RADIANS(60)) | 60 度的余弦值 (0.5)


COSH

返回参数的双曲余弦值。

语法

COSH(number)

Number 表示要求双曲余弦的任意实数。

说明

双曲余弦的公式为：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=COSH(4) | 4 的双曲余弦值 (27.30823)
=COSH(EXP(1)) | 自然对数底数的双曲余弦值 (7.610125)


COUNTIF

计算区域中满足给定条件的单元格的数目。

语法

COUNTIF(range,criteria)

Range 为需要计算其中满足条件的单元格数目的单元格区域。

Criteria 为定义哪些单元格将被计算在内的条件，其形式可以为数字、表达式或文本。例如，条件可以表示为 32、“32”、“>32”或“apples”。

说明

有一些其他的函数可用于依据条件分析数据。例如，若要计算基于一个文本字符串或某范围内的一个数值的总和，可使用 SUMIF 电子表格函数。若要使公式返回基于条件的两个值之一，例如某指定销售量的销售红利，可使用 IF 电子表格函数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 数据
苹果 | 32
桔子 | 54
桃子 | 75
苹果 | 86
公式 | 说明（结果）
=COUNTIF(A2:A5,"apples") | 在上面第一列中“苹果”所在的单元格数目 (2)
=COUNTIF(B2:B5,">55") | 在上面第二列中值大于 55 的单元格数目 (2)


DEGREES

将弧度转换为度。

语法

DEGREES(angle)

Angle 待转换的角度，以弧度表示。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=DEGREES(PI()) | pi 弧度的度数 (180)


EVEN

返回沿绝对值增大方向舍入取整后最接近的偶数。使用该函数可以处理那些成对出现的项目。例如，一个包装箱一行可以装一宗或两宗货物，只有当这些货物的宗数向上舍入到最近的偶数，与包装箱的容量相匹配时，包装箱才会装满。

语法

EVEN(number)

Number 为将进行舍入取整的数值。

说明

  • 如果 Number 为非数值参数，则 EVEN 返回错误值 #VALUE!。
  • 不论 Number 的正负号如何，函数都向远离零的方向舍入。如果 Number 恰好是偶数，则无需进行任何舍入处理。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=EVEN(1.5) | 将 1.5 沿绝对值增大方向舍入取整到最接近的偶数 (2)
=EVEN(3) | 将 3 沿绝对值增大方向舍入取整到最接近的偶数 (4)
=EVEN(2) | 将 2 沿绝对值增大方向舍入取整到最接近的偶数 (2)
=EVEN(-1) | 将 -1 沿绝对值增大方向舍入取整到最接近的偶数 (-2)


EXP

返回 e 的 n 次幂。常数 e 等于 2.71828182845904，是自然对数的底数。

语法

EXP(number)

Number 为底数 e 的指数。

说明

  • 若要计算以其他常数为底的幂，请使用指数运算符 (^)。
  • EXP 函数是计算自然对数的 LN 函数的反函数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=EXP(1) | e 的近似值 (2.718282)
=EXP(2) | 自然对数的底数 e 的 2 次幂 (7.389056)


FACT

返回数的阶乘，一个数的阶乘等于 1*2*3*...*该数。

语法

FACT(number)

Number 为要计算其阶乘的非负数。如果输入的 Number 不是整数，则截尾取整。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=FACT(5) | 5 的阶乘，即 1*2*3*4*5 (120)
=FACT(1.9) | 1.9 截尾取整后的阶乘 (1)
=FACT(0) | 0 的阶乘 (1)
=FACT(-1) | 负数导致错误值 (#NUM!)
=FACT(1) | 1 的阶乘 (1)


FLOOR

将参数 Number 沿绝对值减小的方向舍入取整，使其等于最接近的 significance 的倍数。

语法

FLOOR(number,significance)

Number 所要舍入取整的数值。

Significance 基数。

说明

  • 如果任一参数为非数值参数，则函数 FLOOR 将返回错误值 #VALUE!。
  • 如果 number 和 significance 符号相反，则函数 FLOOR 将返回错误值 #NUM!。
  • 不论 number 的正负号如何，舍入时参数的绝对值都将减小。如果 number 恰好是 significance 的倍数，则无需进行任何舍入处理。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=FLOOR(2.5, 1) | 将 2.5 沿绝对值减小的方向舍入取整，使其等于最接近的 1 的倍数 (2)
=FLOOR(-2.5, -2) | 将 -2.5 沿绝对值减小方向舍入取整，使其等于最接近的 -2 的倍数 (-2)
=FLOOR(-2.5, 2) | 返回错误值，因为 -2.5 和 2 符号不同 (#NUM!)
=FLOOR(1.5, 0.1) | 将 1.5 沿绝对值减小方向舍入取整，使其等于最接近的 0.1 的倍数 (1.5)
=FLOOR(0.234, 0.01) | 将 0.234 沿绝对值减小方向舍入取整，使其等于最接近的 0.01 的倍数 (0.23)


INT

将数字向下舍入到最接近的整数。

语法

INT(number)

Number 需要进行向下舍入取整的实数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
19.5
公式 | 说明（结果）
=INT(8.9) | 将 8.9 向下舍入到最接近的整数 (8)
=INT(-8.9) | 将 -8.9 向下舍入到最接近的整数 (-9)
=A2-INT(A2) | 返回单元格 A2 中正实数的小数部分 (0.5)


LN

返回一个数的自然对数。自然对数以常量 e(2.71828182845904) 为底。

语法

LN(number)

Number 为用于计算其自然对数的正实数。

说明

LN 函数是 EXP 函数的反函数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=LN(86) | 86 的自然对数 (4.454347)
=LN(2.7182818) | 常量 e 的自然对数 (1)
=LN(EXP(3)) | e 的 3 次幂的自然对数 (3)


LOG

按所指定的底数，返回一个数的对数。

语法

LOG(number,base)

Number 为用于计算对数的正实数。

Base 为对数的底数。如果省略底数，则假定其值为10。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=LOG(10) | 10 的对数 (1)
=LOG(8, 2) | 以 2 为底时，8 的对数 (3)
=LOG(86, 2.7182818) | 以 e 为底时，86 的对数 (4.454347)


LOG10

返回以 10 为底的对数。

语法

LOG10(number)

Number 为用于常用对数计算的正实数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=LOG10(86) | 以 10 为底时，86 的对数 (1.934498451)
=LOG10(10) | 以 10 为底时，10 的对数 (1)
=LOG10(1E5) | 以 10 为底时，1E5 的对数 (5)
=LOG10(10^5) | 以 10 为底时，10^5 的对数 (5)


MDETERM

返回一个数组的矩阵行列式的值。

语法

MDETERM(array)

Array 是具有相等行数和列数的数值数组。

说明

  • Array 可以是单元格区域（例如 A1:C3）；或是一个数组常量，如{1,2,3;4,5,6;7,8,9}；或是单元格区域或数组常量的名称。

  • 如果 Array 中单元格是空白或包含文字，则函数 MDETERM 返回错误值 #VALUE!。

  • 如果 Array 的行数和列数不相等，则函数 MDETERM 也返回错误值 #VALUE!。

  • 矩阵的行列式值是由数组中的各元素计算而来的。对一个三行、三列的数组 A1:C3，其行列式的值定义如下：

    MDETERM(A1:C3) 等于
    A1*(B2*C3-B3*C2)+A2*(B3*C1-B1*C3)+A3*(B1*C2-B2*C1)

  • 矩阵的行列式值常被用来求解多元联立方程。
  • 函数 MDETERM 的精确度可达十六位有效数字，因此运算结果因位数的取舍可能导致某些微小误差。例如，奇异矩阵的行列式值可能与零存在 1E-16 的误差。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 数据 | 数据 | 数据
1 | 3 | 8 | 5
1 | 3 | 6 | 1
1 | 1 | 1 | 0
7 | 3 | 10 | 2
公式 | 说明（结果）
=MDETERM(A2:D5) | 上面矩阵的行列式值 (88)
=MDETERM({3,6,1;1,1,0;3,10,2}) | 作为数组常量的矩阵的行列式值 (1)
=MDETERM({3,6;1,1}) | 数组常量中的矩阵的行列式值 (-3)
=MDETERM({1,3,8,5;1,3,6,1}) | 因为数组中的行数和列数不相等，所以返回一个错误值 (#VALUE!)


MINVERSE

返回数组矩阵的逆距阵。

语法

MINVERSE(array)

Array 是具有相等行数和列数的数值数组。

说明

  • Array 可以是单元格区域，例如 A1:C3；数组常量，例如 {1,2,3;4,5,6;7,8,9}；或单元格区域和数组常量的名称。

  • 如果在 Array 中单元格是空白单元格或包含文字，则函数 MINVERSE 返回错误值 #VALUE!。

  • 如果 Array 的行数和列数不相等，则函数 MINVERSE 也返回错误值 #VALUE!。

  • 对于返回结果为数组的公式，必须以数组公式的形式输入。
  • 与求行列式的值一样，求解矩阵的逆常被用于求解多元联立方程组。矩阵和它的逆矩阵相乘为单位矩阵：对角线的值为 1，其他值为 0。
  • 下面是计算二阶方阵逆的示例。假设 A1:B2 中包含以字母 a、b、c 和 d 表示的四个任意的数，则下表表示矩阵 A1:B2 的逆矩阵：
    第 A 列 | 第 B 列
    第一行 | d/(a*d-b*c) | b/(b*c-a*d)
    第二行 | c/(b*c-a*d) | a/(a*d-b*c)
  • 函数 MINVERSE 的精确度可达十六位有效数字，因此运算结果因位数的取舍可能会导致小的误差。
  • 对于一些不能求逆的矩阵，函数 MINVERSE 将返回错误值 #NUM!。不能求逆的矩阵的行列式值为零。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 数据
4 | -1
2 | 0
公式 | 公式
=MINVERSE(A2:B3) |

注释 必须将示例中的公式以数组公式的形式输入。将示例复制到空白电子表格中后，选中以公式单元格开始的区域 A5:B6。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果为 0。

示例 2

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 数据 | 数据
1 | 2 | 1
3 | 4 | -1
0 | 2 | 0
公式 | 公式 | 公式
=MINVERSE(A2:C4) |  |

注释 必须将示例中的公式以数组公式的形式输入。将示例复制到空白电子表格后，选中以公式单元格开始的区域 A6:C8。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果为 0.25。

显示 提示

使用函数 INDEX 可以访问逆矩阵中的单个元素。


MMULT

返回两数组的矩阵乘积。结果矩阵的行数与 array1 的行数相同，矩阵的列数与 array2 的列数相同。

语法

MMULT(array1,array2)

Array1,array2 是要进行矩阵乘法运算的两个数组。

说明

  • Array1 的列数必须与 array2 的行数相同，而且两个数组中都只能包含数值。

  • Array1 和 array2 可以是单元格区域、数组常量或引用。
  • 如果单元格是空白单元格或含有文本，或是 array1 的行数与 array2 的列数不相等时，则函数 MMULT 返回错误值 #VALUE!。
  • 两个数组 b 和 c 的矩阵乘积 a 为：

    其中 i 为行数，j 为列数。

  • 对于返回结果为数组的公式，必须以数组公式的形式输入。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
Array 1 | Array 1
1 | 3
7 | 2
Array 2 | Array 2
2 | 0
0 | 2
公式 | 公式
=MMULT(A2:B3,A5:B6) |

注释 必须将示例中的公式以数组公式的形式输入。将示例复制到空白电子表格中后，请选中以公式单元格开始的区域 A8:B9。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果为 2。

示例 2

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
Array 1 | Array 1
3 | 0
2 | 0
Array 2 | Array 2
2 | 0
0 | 2
公式 | 公式
=MMULT(A2:B3,A5:B6) |

注释 必须将示例中的公式以数组公式的形式输入。将示例复制到空白电子表格中后，请选中从公式单元格开始的区域 A8:B9。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果为 6。


MOD

返回两数相除的余数。结果的正负号与除数相同。

语法

MOD(number,divisor)

Number 为被除数。

Divisor 为除数。

说明

  • 如果除数为零，函数 MOD 返回错误值 #DIV/0!。

  • 函数 MOD 可以借用函数 INT 来表示:

    MOD(n, d) = n - d*INT(n/d)

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=MOD(3, 2) | 3/2 的余数。(1)
=MOD(-3, 2) | -3/2 的余数。余数的符号与除数相同。(1)
=MOD(3, -2) | 3/-2 的余数。余数的符号与除数相同。(-1)
=MOD(-3, -2) | -3/-2 的余数。余数的符号与除数相同。(-1)


ODD

返回对指定数值舍入到的最临近的奇数。

语法

ODD(number)

Number 为将进行舍入取整的数值。

说明

  • 如果 number 为非数值参数，函数 ODD 将返回错误值 #VALUE!。
  • 不论正负号如何，数值都朝着远离 0 的方向舍入。如果 number 恰好是奇数，则不须进行任何舍入处理。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ODD(1.5) | 将 1.5 舍入为最临近的奇数 (3)
=ODD(3) | 将 3 舍入为最临近的奇数 (3)
=ODD(2) | 将 2 舍入为最临近的奇数 (3)
=ODD(-1) | 将 -1 舍入为最临近的奇数 (-1)
=ODD(-2) | 将 -2 舍入为最临近的奇数 (-3)


PI

返回数字 3.14159265358979，即数学常量 pi，精确到小数点后 15 位。

语法

PI( )

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
半径
3
公式 | 说明（结果）
=PI() | Pi (3.14159265358979)
=PI()/2 | Pi/2 (1.570796327)
=PI()*(A2^2) | 具有上面半径值的圆的面积 (28.27433388)


POWER

返回给定数字的乘幂。

语法

POWER(number,power)

Number 底数，可为任意实数。

Power 指数，number 按该指数次幂乘方。

说明

可以用“^”运算符代替函数 POWER 来表示对底数乘方的幂次，例如 5^2。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=POWER(5,2) | 5 的平方 (25)
=POWER(98.6,3.2) | 98.6 的 3.2 次幂 (2401077)
=POWER(4,5/4) | 4 的 5/4 次幂 (5.656854)


PRODUCT

将所有以参数形式给出的数字相乘，并返回乘积值。

语法

PRODUCT(number1,number2,...)

Number1, number2, ... 为 1 到 30 个需要相乘的数字参数。

说明

  • 当参数为数字、逻辑值或数字型文字表达式时可以被计算；当参数为错误值或是不能转换成数字的文字时，将导致错误。
  • 如果参数为数组或引用，只有其中的数字将被计算。数组或引用中的空白单元格、逻辑值、文本或错误值将被忽略。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
5
15
30
公式 | 说明（结果）
=PRODUCT(A2:A4) | 将上面的数字相乘 (2250)
=PRODUCT(A2:A4,2) | 将上面数字的乘积与 2 相乘 (4500)


RADIANS

将角度转换为弧度。

语法

RADIANS(angle)

Angle 为需要转换成弧度的角度。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=RADIANS(270) | 将 270 度转换为弧度（4.712389 或 3π/2 弧度）


RAND

返回大于等于 0 小于 1 的均匀分布随机数，每次计算电子表格时都将返回一个新的数值。

语法

RAND( )

说明

  • 若要生成 a 和 b 之间的随机实数，请使用：

    RAND()*(b-a)+a

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=RAND() | 0 和 1 之间的一个随机数（可变）
=RAND()*100 | 大于等于 0 但小于 100 的随机数（可变）


ROMAN

将阿拉伯数字转换为文本形式的罗马数字。

语法

ROMAN(number,form)

Number 为需要转换的阿拉伯数字。

Form 为一数字，指定所需的罗马数字类型。罗马数字的样式范围可以从经典到简化，随着 form 值的增加而趋于简单。请参阅下面的示例：ROMAN(499,0)。

Form | 类型
0 或省略 | 经典。
1 | 更简单。请参阅下面示例。
2 | 更简单。请参阅下面示例。
3 | 更简单。请参阅下面示例。
4 | 简化。
TRUE | 经典。
FALSE | 简化。

说明

  • 如果数字为负，则返回错误值 #VALUE!。
  • 如果数字大于 3999，则返回错误值 #VALUE!。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ROMAN(499,0) | 499 的经典罗马数字样式 (CDXCIX)
=ROMAN(499,1) | 499 的更简单的罗马数字样式 (LDVLIV)
=ROMAN(499,2) | 499 的更简单的罗马数字样式 (XDIX)
=ROMAN(499,3) | 499 的更简单的罗马数字样式 (VDIV)
=ROMAN(499,4) | 499 的简化罗马数字样式 (ID)
=ROMAN(2013,0) | 2013 的经典罗马数字样式 (MMXIII)


ROUND

本主题中的部分内容可能不适用于某些语言。

返回某个数字按指定位数舍入后的数字。

语法

ROUND(number,num_digits)

Number 需要进行舍入的数字。

Num_digits 指定的位数，按此位数进行舍入。

说明

  • 如果 num_digits 大于 0，则舍入到指定的小数位。
  • 如果 num_digits 等于 0，则舍入到最接近的整数。
  • 如果 num_digits 小于 0，则在小数点左侧进行舍入。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ROUND(2.15, 1) | 将 2.15 舍入到一个小数位 (2.2)
=ROUND(2.149, 1) | 将 2.149 舍入到一个小数位 (2.1)
=ROUND(-1.475, 2) | 将 -1.475 舍入到两个小数位 (-1.48)
=ROUND(21.5, -1) | 将 21.5 舍入到小数点左侧的一个小数位 (20)


ROUNDDOWN

靠近零值，向下（绝对值减小的方向）舍入数字。

语法

ROUNDDOWN(number,num_digits)

Number 为需要向下舍入的任意实数。

Num_digits 舍入后的数字的位数。

说明

  • 函数 ROUNDDOWN 和函数 ROUND 功能相似，不同之处在于函数 ROUNDDOWN 总是向下舍入数字。
  • 如果 num_digits 大于 0，则向下舍入到指定的小数位。
  • 如果 num_digits 等于 0，则向下舍入到最接近的整数。
  • 如果 num_digits 小于 0，则在小数点左侧向下舍入。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ROUNDDOWN(3.2, 0) | 将 3.2 向下舍入，小数位为 0 (3)
=ROUNDDOWN(76.9,0) | 将 76.9 向下舍入，小数位为 0 (76)
=ROUNDDOWN(3.14159, 3) | 将 3.14159 向下舍入，保留三位小数 (3.141)
=ROUNDDOWN(-3.14159, 1) | 将 -3.14159 向下舍入，保留一位小数 (-3.1)
=ROUNDDOWN(31415.92654, -2) | 将 31415.92654 向下舍入到小数点左侧两位 (31400)


ROUNDUP

远离零值，向上（绝对值增加的方向）舍入数字。

语法

ROUNDUP(number,num_digits)

Number 为需要向上舍入的任意实数。

Num_digits 舍入后的数字的位数。

说明

  • 函数 ROUNDUP 和函数 ROUND 功能相似，不同之处在于函数 ROUNDUP 总是向上舍入数字。

  • 如果 num_digits 大于 0，则向上舍入到指定的小数位。

  • 如果 num_digits 等于 0，则向上舍入到最接近的整数。

  • 如果 num_digits 小于 0，则在小数点左侧向上舍入。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=ROUNDUP(3.2,0) | 将 3.2 向上舍入，小数位为 0 (4)
=ROUNDUP(76.9,0) | 将 76.9 向上舍入，小数位为 0 (77)
=ROUNDUP(3.14159,3) | 将 3.14159 向上舍入，保留三位小数 (3.142)
=ROUNDUP(-3.14159,1) | 将 -3.14159 向上舍入，保留一位小数 (-3.2)
=ROUNDUP(31415.92654,-2) | 将 31415.92654 向上舍入到小数点左侧两位 (31500)


SIGN

返回数字的符号。当数字为正数时返回 1，为零时返回 0，为负数时返回 -1。

语法

SIGN(number)

Number 为任意实数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=SIGN(10) | 正数的符号 (1)
=SIGN(4-4) | 零的符号 (0)
=SIGN(-0.00001) | 负数的符号 (-1)


SIN

返回给定角度的正弦值。

语法

SIN(number)

Number 为需要求正弦的角度，以弧度表示。

说明

如果参数的单位是度，则可乘以 PI()/180 或使用函数 RADIANS 将其转换为弧度。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=SIN(PI()) | pi 弧度的正弦值（近似为 0）
=SIN(PI()/2) | pi/2 弧度的正弦值 (1)
=SIN(30*PI()/180) | 30 度的正弦值 (0.5)
=SIN(RADIANS(30)) | 30 度的正弦值 (0.5)


SINH

返回某一数字的双曲正弦值。

语法

SINH(number)

Number 为任意实数。

说明

双曲正弦的计算公式如下：

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=SINH(1) | 1 的双曲正弦值 (1.175201194)
=SINH(-1) | -1 的双曲正弦值 (-1.175201194)

示例 2

可以使用双曲正弦函数来估计分布的累积概率。假设实验检测值在 0 到 10 秒之间变化。对于实验所搜集的历史数据的经验分析表明：结果 x 小于 t 秒的概率可用下面的等式进行估计：

P(x<t)=2.868*SINH(0.0342*t)，式中 0<t<10

若要计算结果小于 1.03 秒的概率，请用 1.03 代替 t。

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=2.868*SINH(0.0342*1.03) | 结果小于 1.03 秒的概率 (0.101049063)

即每 1000 次实验中，该结果期望发生的次数约为 101 次。


SQRT

返回正平方根。

语法

SQRT(number)

Number 为需要求平方根的数字。

说明

如果参数 number 为负值，则函数 SQRT 返回错误值 #NUM!。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
-16
公式 | 说明（结果）
=SQRT(16) | 16 的平方根 (4)
=SQRT(A2) | 上面数字的平方根。因为数字为负数，所以返回错误值 (#NUM!)
=SQRT(ABS(A2)) | 上面数字的绝对值的平方根 (4)


SUBTOTAL

返回数据清单或数据库中的分类汇总。一旦创建了分类汇总，就可以通过编辑 SUBTOTAL 函数对该数据清单进行修改。

语法

SUBTOTAL(function_num,ref1,ref2,...)

Function_num 为 1 到 11 之间的数字，指定使用何种函数在数据清单中进行分类汇总计算。

Function_Num | 函数
1 | AVERAGE
2 | COUNT
3 | COUNTA
4 | MAX
5 | MIN
6 | PRODUCT
7 | STDEV
8 | STDEVP
9 | SUM
10 | VAR
11 | VARP

Ref1, ref2, ... 为要进行分类汇总计算的 1 到 29 个区域或引用。

说明

  • 如果在 ref1，ref2，… 中有其他的分类汇总（或嵌套分类汇总），将忽略这些嵌套分类汇总，以避免重复计算。
  • 函数 SUBTOTAL 将忽略由数据清单筛选时产生的任何隐藏行。在需要对筛选过的数据清单中的可见数据进行分类汇总时，这一点很重要。
  • 如果所指定的某一引用为三维引用，函数 SUBTOTAL 将返回错误值 #VALUE!。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
120
10
150
23
公式 | 说明（结果）
=SUBTOTAL(9,A2:A5) | 使用 SUM 函数对上面的列所做的分类汇总 (303)
=SUBTOTAL(1,A2:A5) | 使用 AVERAGE 函数对上面的列所做的分类汇总 (75.75)


SUM

返回某一单元格区域中所有数字之和。

语法

SUM(number1,number2,...)

Number1, number2, ... 为 1 到 30 个需要求和的参数。

说明

  • 直接键入到参数表中的数字、逻辑值及数字的文本表达式将被计算，请参阅下面的第一个示例和第二个示例。
  • 如果参数为数组或引用，只有其中的数字将被计算。数组或引用中的空白单元格、逻辑值、文本或错误值将被忽略。请参阅下面的第三个示例。
  • 如果参数为错误值或为不能转换成数字的文本，将会导致错误。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
-5
15
30
'5
TRUE
公式 | 说明（结果）
=SUM(3, 2) | 对 3 和 2 求和 (5)
=SUM("5", 15, TRUE) | 对 5、15 和 1 求和, 因为文本值被转换成数字，而逻辑值 TRUE 被转换成数字 1 (21)
=SUM(A2:A4) | 对上面的列中前三个数字求和 (40)
=SUM(A2:A4, 15) | 对上面的列中的前三个数字和 15 求和 (55)
=SUM(A5,A6, 2) | 对上面最后两行中的值和 2 求和。因为引用中的非数字的值没有被转换为数字，所以上面的列中的这些值被忽略 (2)


SUMIF

根据指定条件对若干单元格求和。

语法

SUMIF(range,criteria,sum_range)

Range 为用于条件判断的单元格区域。

Criteria 为确定哪些单元格将被相加求和的条件，其形式可以为数字、表达式或文本。例如，条件可以表示为 32、“32”、“>32”和“apples”。

Sum_range 为需要求和的实际单元格。

说明

  • 只有当他们在区域中的对应单元格与条件匹配时，才可对 sum_range 中的单元格求和。

  • 如果省略 sum_range，则将对区域中的所有单元格求和。

  • 还可使用其他函数根据条件来分析数据。例如，如果要计算单元格区域内某个文本字符串或数字出现的次数，则可使用 COUNTIF 函数。如果要让公式根据某一条件返回两个数值中的某一值（例如，根据指定销售额返回销售红利），则可使用 IF 函数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
房产价值 | 佣金
100,000 | 7,000
200,000 | 14,000
300,000 | 21,000
400,000 | 28,000
公式 | 说明（结果）
=SUMIF(A2:A5,">160000",B2:B5) | 房产价值高于 160000 的佣金之和 (63,000)


SUMPRODUCT

在给定的几组数组中，将数组间对应的元素相乘，并返回乘积之和。

语法

SUMPRODUCT(array1,array2,array3,...)

Array1, array2, array3, ... 为 2 到 30 个数组，其相应元素需要进行相乘并求和。

说明

  • 数组参数必须具有相同的维数，否则，函数 SUMPRODUCT 将返回错误值 #VALUE!。
  • 函数 SUMPRODUCT 将非数值型的数组元素作为 0 处理。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
Array 1 | Array 1 | Array 2 | Array 2
3 | 4 | 2 | 7
8 | 6 | 6 | 7
1 | 9 | 5 | 3
公式 | 说明（结果）
=SUMPRODUCT(A2:B4, C2:D4) | 将两个数组的所有元素相乘，然后将乘积相加，即 3*2+4*7+8*6+6*7+1*5+9*3。(156)

注释 上例所返回的乘积之和，与以数组形式输入的公式 SUM(A2:B4*C2:D4) 的计算结果相同。使用数组公式可以为类似于 SUMPRODUCT 函数的计算提供更通用的解法。例如，使用公式 =SUM(A2:B4^2) 并按 Ctrl+Shift+Enter，可以计算 A2:B4 中所有元素的平方和。


SUMSQ

返回参数的平方和。

语法

SUMSQ(number1,number2,...)

Number1, number2, ... 为 1 到 30 个需要求平方和的参数，也可以使用数组或对数组的引用来代替以逗号分隔的参数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=SUMSQ(3, 4) | 3 和 4 的平方和 (25)


SUMX2MY2

返回两数组中对应数值的平方差之和。

语法

SUMX2MY2(array_x,array_y)

Array_x 为第一个数组或数值区域。

Array_y 为第二个数组或数值区域。

说明

  • 参数应为数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果 array_x 和 array_y 的元素数目不同，函数 SUMX2MY2 返回错误值 #N/A。
  • 平方差之和的计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
第一个数组 | 第二个数组
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
7 | 4
5 | 4
公式 | 说明（结果）
=SUMX2MY2(A2:A8,B2:B8) | 上面两数组的平方差之和 (-55)
=SUMX2MY2({2, 3, 9, 1, 8, 7, 5},{6, 5, 11, 7, 5, 4, 4}) | 两数组常量的平方差之和 (-55)


SUMX2PY2

返回两数组中对应数值的平方和之和，平方和之和在统计计算中经常使用。

语法

SUMX2PY2(array_x,array_y)

Array_x 为第一个数组或数值区域。

Array_y 为第二个数组或数值区域。

说明

  • 参数应为数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果 array_x 和 array_y 的元素数目不同，函数 SUMX2PY2 返回错误值 #N/A。
  • 平方和之和的计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
第一个数组 | 第二个数组
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
7 | 4
5 | 4
公式 | 说明（结果）
=SUMX2PY2(A2:A8,B2:B8) | 上面两数组的平方和之和 (521)
=SUMX2PY2({2, 3, 9, 1, 8, 7, 5},{6, 5, 11, 7, 5, 4, 4}) | 两数组常量的平方和之和 (521)


SUMXMY2

返回两数组中对应数值之差的平方和。

语法

SUMXMY2(array_x,array_y)

Array_x 为第一个数组或数值区域。

Array_y 为第二个数组或数值区域。

说明

  • 参数应为数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果 array_x 和 array_y 的元素数目不同，函数 SUMXMY2 将返回错误值 #N/A。
  • 差的平方和的计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
第一个数组 | 第二个数组
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
7 | 4
5 | 4
公式 | 说明（结果）
=SUMXMY2(A2:A8,B2:B8) | 上面两数组的差的平方和 (79)
=SUMXMY2({2, 3, 9, 1, 8, 7, 5},{6, 5, 11, 7, 5, 4, 4}) | 两数组常量的差的平方和 (79)


TAN

返回给定角度的正切值。

语法

TAN(number)

Number 为需要求正切的角度，以弧度表示。

说明

如果参数的单位是度，则可乘以 PI()/180 或使用函数 RADIANS 将其转换为弧度。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=TAN(0.785) | 0.785 弧度的正切值 (0.99920)
=TAN(45*PI()/180) | 45 度的正切值 (1)
=TAN(RADIANS(45)) | 45 度的正切值 (1)


TANH

返回某一数字的双曲正切值。

语法

TANH(number)

Number 为任意实数。

说明

双曲正切的计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=TANH(-2) | -2 的双曲正切值 (-0.96403)
=TANH(0) | 0 的双曲正切值 (0)
=TANH(0.5) | 0.5 的双曲正切值 (0.462117)


TRUNC

将数字的小数部分截去，返回整数。

语法

TRUNC(number,num_digits)

Number 为需要截尾取整的数字。

Num_digits 用于指定取整精度的数字。Num_digits 的默认值为 0。

说明

函数 TRUNC 和函数 INT 类似，都能返回整数。函数 TRUNC 直接去除数字的小数部分，而函数 INT 则是基于给定数的小数部分的值，将其向下舍入到最接近的整数。函数 INT 和函数 TRUNC 在处理负数时会有不同：TRUNC(-4.3) 返回 -4，但 INT(-4.3) 返回 -5，因为 -5 是较小的数字。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=TRUNC(8.9) | 8.9 的整数部分 (8)
=TRUNC(-8.9) | -8.9 的整数部分 (-8)
=TRUNC(PI()) | pi 的整数部分 (3)


CREATEOBJECT

不再支持此函数。


HOST

不再支持此函数。


OBJECT

不再支持此函数。


XMLDOM

不再支持此函数。


AVEDEV

返回一组数据与其平均值的绝对偏差的平均值，ADEDEV 用于度量数据集的离散度。

语法

AVEDEV(number1,number2, ...)

Number1, number2, ... 为 1 到 30 个用于计算绝对偏差平均值的参数。也可以不使用这种用逗号分隔参数的形式，而用单个数组或对数组的引用。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 平均偏差的公式为：

输入数据所使用的计量单位将会影响函数 AVEDEV 的计算结果。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
4
5
6
7
5
4
3
公式 | 说明（结果）
=AVEDEV(A2:A8) | 上面一组数据与其平均值的绝对偏差的平均值 (1.020408)


AVERAGE

返回参数的平均值（算术平均值）。

语法

AVERAGE(number1,number2, ...)

Number1, number2, ... 为需要计算平均值的 1 到 30 个参数。

说明

  • 参数必须是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
10
7
9
27
2
公式 | 说明（结果）
=AVERAGE(A2:A6) | 上面数字的平均值 (11)
=AVERAGE(A2:A6, 5) | 上面数字与 5 的平均值 (10)


AVERAGEA

计算参数列表中数值的平均值（算数平均值）。与 AVERAGE 函数不同，在计算中还将包括文本和逻辑值（如 TRUE 和 FALSE）。

语法

AVERAGEA(value1,value2, ...)

Value1, value2,...为需要计算平均值的 1 到 30 个单元格、单元格区域或数值。

说明

  • 参数必须为数字、名称、数组或引用。
  • 包含文本的数组或引用参数将作为 0（零）计算。空文本 ("") 也作为 0（零）计算。如果在平均值的计算中不能包含文本值，请使用函数 AVERAGE。
  • 包含 TRUE 的参数作为 1 计算；包含 FALSE 的参数作为 0（零）计算。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
10
7
9
2
不可用
公式 | 说明（结果）
=AVERAGEA(A2:A6) | 上面的数字与文本“不可用”的平均值。在计算中使用了包含文本“不可用”的单元格 (5.6)
=AVERAGEA(A2:A5,A7) | 上面的数字与空白单元格的平均值 (7)


BETADIST

返回累积 Beta 概率密度函数。累积 Beta 概率密度函数通常用于研究样本中某些事物的百分变化率。例如，人们一天中看电视的时间比率。

语法

BETADIST(x,alpha,beta,A,B)

X 用来进行函数计算的值，居于可选性上下界（A 和 B）之间。

Alpha 分布参数。

Beta 分布参数。

A 数值 x 所属区间的可选下界。

B 数值 x 所属区间的可选上界。

说明

  • 如果任意参数为非数值型，函数 BETADIST 返回错误值 #VALVE!。
  • 如果 alpha ≤ 0 或 beta ≤ 0，函数 BETADIST 返回错误值 #NUM!。
  • 如果 x < A、x > B 或 A = B，函数 BETADIST 返回错误值 #NUM!。
  • 如果省略 A 或 B 值，函数 BETADIST 使用标准的累积 beta 分布，即 A = 0，B = 1。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
2 | 计算函数的数值
8 | 分布参数
10 | 分布参数
1 | 下界
3 | 上界
公式 | 说明（结果）
=BETADIST(A2,A3,A4,A5,A6) | 上述参数的累积 Beta 分布函数值 (0.685470581)


BETAINV

返回累积 Beta 概率密度函数的反函数。即，如果 probability = BETADIST(x,...)，则 BETAINV(probability,...) = x。累积 Beta 概率密度函数可用于项目计划，以模拟期望的完成时间和变化值给定后的可能完成时间。

语法

BETAINV(probability,alpha,beta,A,B)

Probability 与 Beta 分布相关的概率值。

Alpha 分布参数。

Beta 分布参数。

A 数值 x 所属区间的可选下界。

B 数值 x 所属区间的可选上界。

说明

  • 如果任意参数为非数值型，函数 BETAINV 返回错误值 #VALVE!。
  • 如果 alpha ≤ 0 或 beta ≤ 0，函数 BETAINV 返回错误值 #NUM!。
  • 如果 probability ≤ 0 或 probability > 1，函数 BETAINV 返回错误值 #NUM!。
  • 如果省略 A 或 B 值，函数 BETAINV 使用标准的累积 beta 分布，即 A = 0，B = 1。

函数 BETAINV 使用迭代法进行计算。给出一个概率值，函数 BETAINV 开始迭代，直到结果精确到 ±3x10-7。如果经过 100 次迭代后，函数 BETAINV 仍未收敛，则返回错误值 #N/A。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
0.685470581 | 与 beta 分布相关的概率值
8 | 分布参数
10 | 分布参数
1 | 下界
3 | 上界
公式 | 说明（结果）
=BETAINV(A2,A3,A4,A5,A6) | 上述参数的累积 Beta 概率密度函数的反函数值 (2)


BINOMDIST

返回一元二项式分布的概率值。函数 BINOMDIST 适用于固定次数的独立试验，当试验的结果只包含成功或失败二种情况，且当成功的概率在实验期间固定不变。例如，函数 BINOMDIST 可以计算三个即将出生的婴儿中两个是男孩的概率。

语法

BINOMDIST(number_s,trials,probability_s,cumulative)

Number_s 为试验成功的次数。

Trials 为独立试验的次数。

Probability_s 为每次试验中成功的概率。

Cumulative 为一逻辑值，用于确定函数的形式。如果 cumulative 为 TRUE，则函数 BINOMDIST 返回累积分布函数，即至多 number_s 次成功的概率；如果为 FALSE，则返回概率密度函数，即 number_s 次成功的概率。

说明

  • Number_s 和 trials 将被截尾取整。
  • 如果 number_s、trials 或 probability_s 为非数值型，则函数 BINOMDIST 返回错误值 #VALUE!。
  • 如果 number_s < 0 或 number_s > trials，则函数 BINOMDIST 返回错误值 #NUM!。
  • 如果 probability_s < 0 或 probability_s > 1，则函数 BINOMDIST 返回错误值 #NUM!。
  • 一元二项式概率密度函数的计算公式为：

    式中：

    等于 COMBIN(n,x)。

    一元二项式累积分布函数的计算公式为：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
6 | 试验成功次数
10 | 独立试验次数
0.5 | 每次试验中成功的概率
公式 | 说明（结果）
=BINOMDIST(A2,A3,A4,FALSE) | 10 次试验成功 6 次的概率 (0.205078)


CHIDIST

返回 γ2 分布的单尾概率。γ2 分布与 γ2 检验相关。使用 γ2 检验可以比较观察值和期望值。例如，某项遗传学实验假设下一代植物将呈现出某一组颜色。使用此函数比较观测结果和期望值，可以确定初始假设是否有效。

语法

CHIDIST(x,degrees_freedom)

X 为用来计算分布的数值。

Degrees_freedom 自由度。

说明

  • 如果任一参数为非数值型，则函数 CHIDIST 返回错误值 #VALUE!。
  • 如果 x 为负数，则函数 CHIDIST 返回错误值 #NUM!。
  • 如果 degrees_freedom 不是整数，将被截尾取整。
  • 如果 degrees_freedom < 1 或 degrees_freedom ≥ 10^10，则函数 CHIDIST 返回错误值 #NUM!。
  • 函数 CHIDIST 按 CHIDTST=P(X>x) 计算，式中 X 为 γ2 随机变量。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
18.307 | 用来计算分布的数值
10 | 自由度
公式 | 说明（结果）
=CHIDIST(A2,A3) | 满足上述条件的 γ2 分布的单尾概率 (0.050001)


CHIINV

返回 γ2 分布的单尾概率函数的反函数。如果 probability = CHIDIST(x,…)，则 CHIINV(probability,…) = x。使用此函数可比较观测结果和期望值，以确定初始假设是否有效。

语法

CHIINV(probability,degrees_freedom)

Probability 与 γ2 分布相关的概率。

Degrees_freedom 自由度。

说明

  • 如果任一参数为非数字型，则函数 CHIINV 返回错误值 #VALUE!。
  • 如果 probability < 0 或 probability > 1，则函数 CHIINV 返回错误值 #NUM!。
  • 如果 degrees_freedom 不是整数，将被截尾取整。
  • 如果 degrees_freedom < 1 或 degrees_freedom ≥ 10^10，函数 CHIINV 返回错误值 #NUM!。

函数 CHIINV 使用迭代法进行计算。通过给定的 probability 值，函数 CHIINV 开始进行迭代，直到计算结果的精度达到 ±3x10^-7。如果迭代 100 次后，函数 CHIINV 仍不收敛，则返回错误值 #N/A。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
0.05 | 与 γ2 分布相关的概率
10 | 自由度
公式 | 说明（结果）
=CHIINV(A2,A3) | γ2 分布的单尾概率函数的反函数值 (18.30703)


CHITEST

返回独立性检验值。函数 CHITEST 返回 γ2 分布的统计值及相应的自由度。可以使用 γ2 检验确定假设值是否被实验所证实。

语法

CHITEST(actual_range,expected_range)

Actual_range 为包含观察值的数据区域，将和期望值作比较。

Expected_range 为包含行列汇总的乘积与总计值之比率的数据区域。

说明

  • 如果 actual_range 和 expected_range 数据点的个数不同，则函数 CHITEST 返回错误值 #N/A。
  • γ2 检验首先计算 γ2 统计值，然后对实际值与期望值的差值求和。此函数的计算公式为 CHITEST=p(X>γ2)，式中：

    其中：

    Aij = 第 i 行、第 j 列的实际频率

    Eij = 第 i 行、第 j 列的期望频率

    r = 行数

    c = 列数

    函数 CHITEST 返回 γ2 统计的概率和自由度 df，其中 df = (r - 1)(c - 1)。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
男士（实际数） | 女士（实际数） | 说明
58 | 35 | 同意
11 | 25 | 中立
10 | 23 | 不同意
男士（期望数） | 女士（期望数） | 说明
45.35 | 47.65 | 同意
17.56 | 18.44 | 中立
16.09 | 16.91 | 不同意
公式 | 说明（结果）
=CHITEST(A2:B4,A6:B8) | 上述数据的 γ2 统计值为 16.16957，自由度为 2 (0.000308)


CONFIDENCE

返回具有正态分布的总体平均值的置信区间。置信区间是样本平均值任意一侧的区域。例如，如果通过邮购的方式订购产品，依照给定的置信度，可以确定最早及最晚到货的时间。

语法

CONFIDENCE(alpha,standard_dev,size)

Alpha 为用于计算置信度的显著水平参数。置信度等于 100*(1 - alpha)%，即，如果 alpha 为 0.05，则置信度为 95%。

Standard_dev 数据区域的总体标准偏差，假设为已知。

Size 样本容量。

说明

  • 如果任意参数均为非数值型，函数 CONFIDENCE 返回错误值 #VALUE!。
  • 如果 alpha ≤ 0 或 alpha ≥ 1，函数 CONFIDENCE 返回错误值 #NUM!。
  • 如果 standard_dev ≤ 0，函数 CONFIDENCE 返回错误值 #NUM!。
  • 如果 size 不是整数，将被截尾取整。
  • 如果 size < 1，函数 CONFIDENCE 返回错误值 #NUM!。
  • 如果假设 alpha 等于 0.05，则需要计算等于 (1 - alpha) 或 95% 的标准正态分布曲线之下的面积。其面积值为 ±1.96。因此置信区间为：

示例

假设样本取自 50 名乘车上班的旅客，他们花在路上的平均时间为 30 分钟，总体标准偏差为 2.5 分钟。则总体平均值落入下列区域内的置信度为 95%：

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
0.05 | 显著水平参数
2.5 | 总体标准偏差
50 | 样本容量
公式 | 说明（结果）
=CONFIDENCE(A2,A3,A4) | 总体平均值的置信区间。即花在上班路上的平均时间为 30±0.692951 分钟，或 29.3 到 30.7 分钟。(0.692951)


CORREL

返回单元格区域 array1 和 array2 之间的相关系数。使用相关系数可以确定两种属性之间的关系。例如，可以检测某地的平均温度和空调使用情况之间的关系。

语法

CORREL(array1,array2)

Array1 第一组数值单元格区域。

Array2 第二组数值单元格区域。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果 array1 和 array2 的数据点的个数不同，函数 CORREL 返回错误值 #N/A。
  • 如果 array1 或 array2 为空，或者其数值的 s（标准偏差）等于零，则函数 CORREL 返回错误值 #DIV/0!。
  • 相关系数的计算公式为：

    式中：

    且：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 1 | 数据 2
3 | 9
2 | 7
4 | 12
5 | 15
6 | 17
公式 | 说明（结果）
=CORREL(A2:A6,B2:B6) | 上述两个数据集合的相关系数 (0.997054)


COUNT

返回包含数字以及包含参数列表中的数字的单元格的个数。利用函数 COUNT 可以计算单元格区域或数字数组中数字字段的输入项个数。

语法

COUNT(value1,value2, ...)

Value1, value2, ... 为包含或引用各种类型数据的参数（1 到 30 个），但只有数字类型的数据才被计算。

说明

  • 函数 COUNT 在计数时，将把数字、日期、或以文本代表的数字计算在内；但是错误值或其他无法转换成数字的文字将被忽略。
  • 如果参数是一个数组或引用，那么只统计数组或引用中的数字；数组或引用中的空白单元格、逻辑值、文字或错误值都将被忽略。如果要统计逻辑值、文字或错误值，请使用函数 COUNTA。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
销售
2008-12-8
19
22.24
TRUE
#DIV/0!
公式 | 说明（结果）
=COUNT(A2:A8) | 计算上列数据中包含数字的单元格的个数 (3)
=COUNT(A5:A8) | 计算上列数据的最后 4 行中包含数字的单元格的个数 (2)
=COUNT(A2:A8,2) | 计算上列数据中包含数字的单元格以及包含数值 2 的单元格的个数 (4)


COUNTA

返回参数列表中非空值的单元格个数。利用函数 COUNTA 可以计算单元格区域或数组中包含数据的单元格个数。

语法

COUNTA(value1,value2, ...)

Value1, value2, ... 为所要计算的值，参数个数为 1 到 30 个。在这种情况下，参数值可以是任何类型，它们可以包括空字符 ("")，但不包括空白单元格。如果参数是数组或单元格引用，则数组或引用中的空白单元格将被忽略。如果不需要统计逻辑值、文字或错误值，请使用函数 COUNT。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
销售
2008-12-8
19
22.24
TRUE
#DIV/0!
公式 | 说明（结果）
=COUNTA(A2:A8) | 计算上列数据中非空单元格的个数 (6)
=COUNTA(A5:A8) | 计算上列数据的最后四行中非空单元格的个数 (4)
=COUNTA(A1:A7, 2) | 计算上列数据中非空单元格以及包含数值 2 的单元格个数 (7)
=COUNTA(A1:A7, "Two") | 计算上列数据中非空单元格以及值“Two”的个数 (7)


COVAR

返回协方差，即每对数据点的偏差乘积的平均数，利用协方差可以决定两个数据集之间的关系。例如，可利用它来检验收入与教育程度是否成正比。

语法

COVAR(array1,array2)

Array1 第一个所含数据为整数的单元格区域。

Array2 第二个所含数据为整数的单元格区域。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果 array1 和 array2 所含数据点的个数不等，则函数 COVAR 返回错误值 #N/A。
  • 如果 array1 和 array2 当中有一个为空，则函数 COVAR 返回错误值 #DIV/0!。
  • 协方差计算公式为：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 1 | 数据 2
3 | 9
2 | 7
4 | 12
5 | 15
6 | 17
公式 | 说明（结果）
=COVAR(A2:A6, B2:B6) | 协方差，即上述每对数据点的偏差乘积的平均数 (5.2)


CRITBINOM

返回使累积二项式分布大于等于临界值的最小值。此函数可以用于质量检验。例如，使用函数 CRITBINOM 来决定装配线上整批产品达到检验合格所允许的最大残次品个数。

语法

CRITBINOM(trials,probability_s,alpha)

Trials 伯努利试验次数。

Probability_s 每次试验中成功的概率。

Alpha 临界值。

说明

  • 如果任意参数为非数值型，函数 CRITBINOM 返回错误值 #VALUE!。
  • 如果 trials 不是整数，将被截尾取整。
  • 如果 trial < 0，函数 CRITBINOM 返回错误值 #NUM!。
  • 如果 probability_s < 0 或 probability_s > 1，函数 CRITBINOM 返回错误值 #NUM!。
  • 如果 alpha < 0 或 alpha > 1，函数 CRITBINOM 返回错误值 #NUM!。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
6 | 伯努利试验次数
0.5 | 每次试验成功的概率
0.75 | 临界值
公式 | 说明（结果）
=CRITBINOM(A2,A3,A4) | 返回累积二项式分布大于等于临界值的最小值 (4)


DEVSQ

返回数据点与各自样本平均值偏差的平方和。

语法

DEVSQ(number1,number2, ...)

Number1,number2, ... 为 1 到 30 个需要计算偏差平方和的参数，也可以不使用这种用逗号分隔参数的形式，而用单个数组或对数组单元格的引用。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 偏差平方和的计算公式为：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
4
5
8
7
11
4
3
公式 | 说明（结果）
=DEVSQ(A2:A8) | 计算上面数据点与各自样本平均值偏差的平方和 (48)


EXPONDIST

返回指数分布。使用函数 EXPONDIST 可以建立事件之间的时间间隔模型，例如，在计算银行自动提款机支付一次现金所花费的时间时，可通过函数 EXPONDIST 来确定这一过程最长持续一分钟的发生概率。

语法

EXPONDIST(x,lambda,cumulative)

X 函数的数值。

Lambda 参数值。

Cumulative 为一逻辑值，指定指数函数返回的形式。如果 cumulative 为 TRUE，函数 EXPONDIST 返回累积分布函数；如果 cumulative 为 FALSE，返回概率密度函数。

说明

  • 如果 x 或 lambda 为非数值型，函数 EXPONDIST 返回错误值 #VALUE!。
  • 如果 x < 0，函数 EXPONDIST 返回错误值 #NUM!。
  • 如果 labmda ≤ 0，函数 EXPONDIST 返回错误值 #NUM!。
  • 概率密度函数的计算公式为：

  • 累积分布函数的计算公式为：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
0.2 | 函数的数值
10 | 参数值
公式 | 说明（结果）
=EXPONDIST(A2,A3,TRUE) | 累积指数分布的函数值 (0.864665)
=EXPONDIST(0.2,10,FALSE) | 概率密度指数分布的函数值 (1.353353)


FDIST

返回 F 概率分布。使用此函数可以确定两个数据集是否存在变化程度上的不同。例如，可以分析进入中学的男生、女生的考试分数，确定女生分数的变化程度是否与男生不同。

语法

FDIST(x,degrees_freedom1,degrees_freedom2)

X 参数值

Degrees_freedom1 分子自由度。

Degrees_freedom2 分母自由度。

说明

  • 如果任何参数都为非数值型，函数 FDIST 返回错误值 #VALUE!。
  • 如果 x 为负数，函数 FDIST 返回错误值 #NUM!。
  • 如果 degrees_freedom1 或 degrees_freedom2 不是整数，将被截尾取整。
  • 如果 degrees_freedom1 < 1 或 degrees_freedom1 ≥ 10^10，函数 FDIST 返回错误值 #NUM!。
  • 如果 degrees_freedom2 < 1 或 degrees_freedom2 ≥ 10^10，函数 FDIST 返回错误值 #NUM!。
  • 函数 FDIST 的计算公式为 FDIST=P( F < x )，其中 F 为呈 F 分布的随机变量。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
15.20675 | 估算函数的数值
6 | 分子自由度
4 | 分母自由度
公式 | 说明（结果）
=FDIST(A2,A3,A4) | 在上述条件下的 F 概率分布 (0.01)


FINV

返回 F 概率分布的反函数值。如果 p = FDIST(x,…)，则 FINV(p,…) = x。

在 F 检验中，可以使用 F 分布比较两个数据集的变化程度。例如，可以分析美国、加拿大的收入分布，确定两个国家是否有相似的收入变化程度。

语法

FINV(probability,degrees_freedom1,degrees_freedom2)

Probability 与 F 累积分布相关的概率值。

Degrees_freedom1 分子自由度。

Degrees_freedom2 分母自由度。

说明

  • 如果任何参数都为非数值型，则函数 FINV 返回错误值 #VALUE!。
  • 如果 probability < 0 或 probability > 1，则函数 FINV 返回错误值 #NUM!。
  • 如果 degrees_freedom1 或 degrees_freedom2 不是整数，将被截尾取整。
  • 如果 degrees_freedom1 < 1 或 degrees_freedom1 ≥ 10^10，函数 FINV 返回错误值 #NUM!。
  • 如果 degrees_freedom2 < 1 或 degrees_freedom2 ≥ 10^10，函数 FINV 返回错误值 #NUM!。

函数 FINV 可用于返回 F 分布的临界值。例如，ANOVA 计算的结果常常包括 F 统计值、F 概率和显著水平参数为 0.05 的 F 临界值等数据。若要返回 F 的临界值，可用显著水平参数作为函数 FINV 的 probability 参数。

函数 FINV 使用迭代法来计算函数。给定一个概率值，函数 FINV 开始迭代，直到结果精确到 ±3x10^-7。如果经过 100 次迭代后，函数 FINV 仍未收敛，此函数返回错误值 #N/A。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
0.01 | 与 F 累积分布相关的概率值
6 | 分子自由度
4 | 分母自由度
公式 | 说明（结果）
=FINV(A2,A3,A4) | 在上述条件下 F 概率分布的反函数值 (15.20675)


FISHER

返回点 x 的 Fisher 变换。该变换生成一个近似正态分布而非偏斜的函数。使用此函数可以完成相关系数的假设检验。

语法

FISHER(x)

X 为一个数字，在该点进行变换。

说明

  • 如果 x 为非数值型，函数 FISHER 返回错误值 #VALUE!。
  • 如果 x ≤ -1 或 x ≥ 1，函数 FISHER 返回错误值 #NUM!。

  • Fisher 变换的计算公式为：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=FISHER(0.75) | 在点 0.75 进行 Fisher 变换的函数值 (0.972955)


FISHERINV

返回 Fisher 变换的反函数值。使用此变换可以分析数据区域或数组之间的相关性。如果 y = FISHER(x)，则 FISHERINV(y) = x。

语法

FISHERINV(y)

Y 为一个数值，在该点进行反变换。

说明

  • 如果 y 为非数值型，函数 FISHERINV 返回错误值 #VALUE!。

  • Fisher 变换反函数的计算公式为：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=FISHERINV(0.972955) | 在点 0.972955 进行 Fisher 变换的反函数值 (0.75)


FORECAST

根据已有的数值计算或预测未来值。此预测值为基于给定的 x 值推导出的 y 值。已知的数值为已有的 x 值和 y 值，再利用线性回归对新值进行预测。可以使用该函数对未来销售额、库存需求或消费趋势进行预测。

语法

FORECAST(x,known_y's,known_x's)

X 为需要进行预测的数据点。

Known_y's 为因变量数组或数据区域。

Known_x's 为自变量数组或数据区域。

说明

  • 如果 x 为非数值型，函数 FORECAST 返回错误值 #VALUE!。
  • 如果 known_y's 和 known_x's 为空或含有不同个数的数据点，函数 FORECAST 返回错误值 #N/A。
  • 如果 known_x's 的方差为零，函数 FORECAST 返回错误值 #DIV/0!。
  • 函数 FORECAST 的计算公式为 a+bx，式中：

    且：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
已知 Y | 已知 X
6 | 20
7 | 28
9 | 31
15 | 38
21 | 40
公式 | 说明（结果）
=FORECAST(30,A2:A6,B2:B6) | 基于给定的 x 值 30 为 y 预测一个值 (10.60725)


FREQUENCY

以一列垂直数组返回某个区域中数据的频率分布。例如，使用函数 FREQUENCY 可以计算在给定的分数范围内测验分数的个数。由于函数 FREQUENCY 返回一个数组，所以必须以数组公式的形式输入。

语法

FREQUENCY(data_array,bins_array)

Data_array 为一数组或对一组数值的引用，用来计算频率。如果 data_array 中不包含任何数值，函数 FREQUENCY 返回零数组。

Bins_array 为间隔的数组或对间隔的引用，该间隔用于对 data_array 中的数值进行分组。如果 bins_array 中不包含任何数值，函数 FREQUENCY 返回 data_array 中元素的个数。

说明

  • 在选定相邻单元格区域（该区域用于显示返回的分布结果）后，函数 FREQUENCY 应以数组公式的形式输入。
  • 返回的数组中的元素个数比 bins_array（数组）中的元素个数多 1。返回的数组中所多出来的元素表示超出最高间隔的数值个数。例如，如果要计算输入到三个单元格中的三个数值区间（间隔），请一定在四个单元格中输入 FREQUENCY 函数计算的结果。多出来的单元格将返回 data_array 中大于第三个间隔值的数值个数。
  • 函数 FREQUENCY 将忽略空白单元格和文本。
  • 对于返回结果为数组的公式，必须以数组公式的形式输入。

示例

本示例假设所有测验分数都为整数。

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
分数 | 分段点
79 | 70
85 | 79
78 | 89
85 |
50 |
81 |
95 |
88 |
97 |
公式 | 说明（结果）
=FREQUENCY(A2:A10,B2:B5) | 分数小于等于 70 的个数 (1)
 | 分数介于 71 到 79 之间的个数 (2)
 | 分数介于 80 到 89 之间的个数 (4)
 | 分数大于等于 90 的个数 (2)

注释 必须将示例中的公式以数组公式的形式输入。将示例复制到空白电子表格后，请选中以公式单元格开始的区域 A12:A15。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果为 1。


FTEST

返回 F-检验的结果。F-检验返回的是当数组 1 和数组 2 的方差无明显差异时的单尾概率。可以使用此函数来判断两个样本的方差是否不同。例如，给定公立和私立学校的测试成绩，可以检验各学校间的差别程度。

语法

FTEST(array1,array2)

Array1 第一个数组或数据区域。

Array2 第二个数组或数据区域。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果数组 1 或数组 2 中数据点的个数小于 2 个，或者数组 1 或数组 2 的方差为零，函数 FTEST 返回错误值 #DIV/0!。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 1 | 数据 2
6 | 20
7 | 28
9 | 31
15 | 38
21 | 40
公式 | 说明（结果）
=FTEST(A2:A6,B2:B6) | 返回上述数据的 F-检验结果 (0.648318)


GAMMADIST

返回伽玛分布。可以使用此函数来研究具有偏态分布的变量。伽玛分布通常用于排队分析。

语法

GAMMADIST(x,alpha,beta,cumulative)

X 为用来计算伽玛分布的数值。

Alpha 分布参数。

Beta 分布参数。如果 beta = 1，函数 GAMMADIST 返回标准伽玛分布。

Cumulative 为一逻辑值，决定函数的形式。如果 cumulative 为 TRUE，函数 GAMMADIST 返回累积分布函数；如果为 FALSE，则返回概率密度函数。

说明

  • 如果 x、alpha 或 beta 为非数值型，函数 GAMMADIST 返回错误值 #VALUE!。
  • 如果 x < 0，函数 GAMMADIST 返回错误值 #NUM!。
  • 如果 alpha ≤ 0 或 beta ≤ 0，函数 GAMMADIST 返回错误值 #NUM!。
  • 伽玛分布的计算公式如下：

    标准伽玛分布为：

  • 当 alpha = 1 时，函数 GAMMADIST 返回如下的指数分布：

  • 对于正整数 n，当 alpha = n/2，beta = 2 且 cumulative = TRUE 时，函数 GAMMADIST 以自由度 n 返回 (1-CHIDIST(X))。
  • 当 alpha 为正整数时，函数 GAMMADIST 也称为爱尔朗 (Erlang) 分布。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
10 | 用来计算伽玛分布的数值
9 | α 分布参数
2 | β 分布参数
公式 | 说明（结果）
=GAMMADIST(A2,A3,A4,FALSE) | 在上述条件下的概率伽玛分布 (0.032639)
=GAMMADIST(A2,A3,A4,TRUE) | 在上述条件下的累积伽玛分布 (0.068094)


GAMMAINV

返回伽玛累积分布函数的反函数。如果 P = GAMMADIST(x,...)，则 GAMMAINV(p,...) = x。

使用此函数可研究可能出现偏态分布的变量。

语法

GAMMAINV(probability,alpha,beta)

Probability 为伽玛分布的概率值。

Alpha 分布参数。

Beta 分布参数。如果 beta = 1，函数 GAMMAINV 返回标准伽玛分布。

说明

  • 如果任一参数为非数值型，函数 GAMMAINV 返回错误值 #VALUE!。
  • 如果 probability < 0，probability > 1，函数 GAMMAINV 返回错误值 #NUM!。
  • 如果 alpha ≤ 0 或 beta ≤ 0，函数 GAMMAINV 返回错误值 #NUM!。

函数 GAMMAINV 使用迭代法来计算函数。给定一个概率值，函数 GAMMAINV 开始迭代，直到结果精确到 ±3x10^-7。如果经过 100 次迭代后，函数 GAMMAINV 仍未收敛，则返回错误值 #N/A。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
0.068094 | 伽玛分布的概率值
9 | α 分布参数
2 | β 分布参数
公式 | 说明（结果）
=GAMMAINV(A2,A3,A4) | 在上述条件下伽玛累积分布函数的反函数 (10)


GAMMALN

返回伽玛函数的自然对数，Γ(x)。

语法

GAMMALN(x)

X 为需要计算函数 GAMMALN 的数值。

说明

  • 如果 x 为非数值型，函数 GAMMALN 返回错误值 #VALUE!。
  • 如果 x ≤ 0，函数 GAMMAIN 返回错误值 #NUM!。
  • 数字 e 的 GAMMALN(i) 次幂等于 (i-1)!，其中 i 为整数。
  • 函数 GAMMALN 的计算公式如下：

    式中：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=GAMMALN(4) | 4 的伽玛函数的自然对数 (1.791759)


GEOMEAN

返回正数数组或区域的几何平均值。例如，可以使用函数 GEOMEAN 计算可变复利的平均增长率。

语法

GEOMEAN(number1,number2, ...)

Number1,number2, ... 是用于计算平均值的 1 到 30 个参数，也可以不使用这种用逗号分隔参数的形式，而用单个数组或数组引用的形式。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果任何数据点小于 0，函数 GEOMEAN 返回错误值 #NUM!。
  • 几何平均值的计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
4
5
8
7
11
4
3
公式 | 说明（结果）
=GEOMEAN(A2:A8) | 计算上述数据的几何平均值 (5.476987)


GROWTH

根据现有数据计算预测的指数增长值。根据现有的 x 值和 y 值，函数 GROWTH 返回一组新的 x 值对应的 y 值。还可以使用 GROWTH 电子表格函数来拟合满足现有 x 值和 y 值的指数曲线。

语法

GROWTH(known_y's,known_x's,new_x's,const)

Known_y's 满足指数回归拟合曲线 y=b*m^x 的一组已知的 y 值。

  • 如果数组 known_y's 在单独一列中，则 known_x's 的每一列被视为一个独立的变量。

  • 如果数组 known-y's 在单独一行中，则 known-x's 的每一行被视为一个独立的变量。

  • 如果 known_y*s 中的任何数为零或为负数，函数 GROWTH 返回错误值 #NUM!。

Known_x's 满足指数回归拟合曲线 y=b*m^x 的一组已知的 x 值，为可选参数。

  • 数组 known_x's 可以包含一组或多组变量。如是只用到一个变量，只要 known_y's 和 known_x's 维数相同，它们可以是任何形状的区域。如果用到多个变量，known_y's 必须为向量（即必须为一行或一列）。

  • 如果省略 known_x's，则假设该数组为 {1,2,3,...}，其大小与 known_y's 相同。

New_x's 为需要通过函数 GROWTH 返回对应 y 值的一组新 x 值。

  • New_x's 与 known_x's 一样，每个独立变量必须为单独的一列（或一行）。因此，如果 known_y's 是单列的，known_x's 和 new_x's 应该有同样的列数。如果 known_y's 是单行的，known_x's 和 new_x's 应该有同样的行数。

  • 如果省略 new_x's，则假设它和 known_x's 相同。

  • 如果 known_x's 与 new_x's 都被省略，则假设它们为数组 array {1,2,3,...}，其大小与 known_y's 相同。

Const 为一逻辑值，用于指定是否将常数 b 强制设为 1。

  • 如果 const 为 TRUE 或省略，b 将按正常计算。

  • 如果 const 为 FALSE，b 将被设为 1，m 值将被调整以满足 y = m^x。

说明

  • 对于返回结果为数组的公式，在选定正确的单元格个数后，必须以数组公式的形式输入。
  • 当为参数（如 known_x's）输入数组常量时，应当使用逗号分隔同一行中的数据，用分号分隔不同行中的数据。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。

本示例采用与函数 LOGEST 示例中相同的数据。第一个公式显示已知值对应的值。如果指数趋势继续存在，第二个公式则预测下个月的值。

月 | 已知值 | 公式（对应的值）
11 | 33,100 | =GROWTH(B2:B7,A2:A7)
12 | 47,300 |
13 | 69,000 |
14 | 102,000 |
15 | 150,000 |
16 | 220,000 |
月 | 公式（预测的值）
17 | =GROWTH(B2:B7,A2:A7, A9:A10)
18 |

注释 必须将示例中的公式以数组公式的形式输入。将示例复制到空白电子表格后，选中以公式单元格开始的区域 C2:C7 或 B9:B10。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果为 32618.20377 和 320196.7184。


HARMEAN

返回数据集合的调和平均值。调和平均值与倒数的算术平均值互为倒数。

语法

HARMEAN(number1,number2, ...)

Number1,number2, ... 是用于计算平均值的 1 到 30 个参数，也可以不使用这种用逗号分隔参数的形式，而用单个数组或数组引用的形式。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果任何数据点小于等于 0，函数 HARMEAN 返回错误值 #NUM!。
  • 调和平均值总小于几何平均值，而几何平均值总小于算术平均值。
  • 调和平均值的计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
4
5
8
7
11
4
3
公式 | 说明（结果）
=HARMEAN(A2:A8) | 计算上面数据集合的调和平均值 (5.028376)


HYPGEOMDIST

返回超几何分布。给定样本容量、样本总体容量和样本总体中成功的次数，函数 HYPGEOMDIST 返回样本取得给定成功次数的概率。使用函数 HYPGEOMDIST 可以解决有限总体的问题，其中每个观察值或者为成功或者为失败，且给定样本容量的每一个子集有相等的发生概率。

语法

HYPGEOMDIST(sample_s,number_sample,population_s,number_population)

Sample_s 样本中成功的次数。

Number_sample 样本容量。

Population_s 样本总体中成功的次数。

Number_population 样本总体的容量。

说明

  • 所有参数将被截尾取整。
  • 如果任一参数为非数值型，函数 HYPGEOMDIST 返回错误值 #VALUE!。
  • 如果 sample_s < 0 或 sample_s 大于 number_sample 和 population_s 中的较小值，函数 HYPGEOMDIST 返回错误值 #NUM!。
  • 如果 sample_s 小于 0 或 (number_sample - number_population + population_s) 中的较大值，函数 HYPGEOMDIST 返回错误值 #NUM!。
  • 如果 number_sample < 0 或 number_sample > number_population，函数 HYPGEOMDIST 返回错误值 #NUM!。
  • 如果 population_s < 0 或 population_s > number_population，函数 HYPGEOMDIST 返回错误值 #NUM!。
  • 如果 number_population < 0，函数 HYPGEOMDIST 返回错误值 #NUM!。
  • 超几何分布的计算公式如下：

    式中：

    x = sample_s

    n = number_sample

    M = population_s

    N = number_population

    函数 HYPGEOMDIST 用于在有限样本总体中进行不退回抽样的概率计算。

示例

抽样器里有 20 块巧克力。8 块是焦糖的，其余 12 块是果仁的。如果随机选出 4 块，下面函数返回恰好有一块是焦糖的概率。

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
1 | 样本中成功的次数
4 | 样本容量
8 | 样本总体中成功的次数
20 | 样本总体的容量
公式 | 说明（结果）
=HYPGEOMDIST(A2,A3,A4,A5) | 返回上述样本和样本总体的超几何分布 (0.363261)


INTERCEPT

利用现有的 x 值与 y 值计算直线与 y 轴的截距。截距为穿过已知的 known_x's 和 known_y's 数据点的线性回归线与 y 轴的交点。当自变量为 0（零）时，利用截距可以决定因变量的值。例如，当所有的数据点都是在室温或更高的温度下取得的，可以用 INTERCEPT 函数预测在 0°C 时金属的电阻。

语法

INTERCEPT(known_y's,known_x's)

Known_y's 为因变的观察值或数据集合。

Known_x's 为自变的观察值或数据集合。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果 known_y's 和 known_x's 所包含的数据点个数不相等或不包含任何数据点，则函数 INTERCEPT 返回错误值 #N/A。
  • 回归线的截距公式为：

    式中斜率计算如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
已知 y | 已知 x
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
公式 | 说明（结果）
=INTERCEPT(A2:A6, B2:B6) | 利用上面已知的 x 值与 y 值计算直线与 y 轴的截距 (0.0483871)


KURT

返回数据集的峰值。峰值反映与正态分布相比某一分布的尖锐度或平坦度。正峰值表示相对尖锐的分布。负峰值表示相对平坦的分布。

语法

KURT(number1,number2, ...)

Number1,number2, ... 是用于计算峰值的 1 到 30 个参数。也可以不使用这种用逗号分隔参数的形式，而用单个数组或数组引用的形式。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果数据点少于 4 个，或样本标准偏差等于 0，函数 KURT 返回错误值 #DIV/0!。
  • 峰值的计算公式如下：

    式中：

    S 为样本的标准偏差。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
3
4
5
2
3
4
5
6
4
7
公式 | 说明（结果）
=KURT(A2:A11) | 上述数据集的峰值 (-0.1518)


LARGE

返回数据集中第 k 个最大值。使用此函数可以根据相对标准来选择数值。例如，可以使用函数 LARGE 得到第一名、第二名或第三名的得分。

语法

LARGE(array,k)

Array 为需要从中选择第 k 个最大值的数组或数据区域。

K 为返回值在数组或数据单元格区域中的位置（从大到小排）。

说明

  • 如果数组为空，函数 LARGE 返回错误值 #NUM!。
  • 如果 k ≤ 0 或 k 大于数据点的个数，函数 LARGE 返回错误值 #NUM!。

如果区域中数据点的个数为 n，则函数 LARGE(array,1) 返回最大值，函数 LARGE(array,n) 返回最小值。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 数据
3 | 4
5 | 2
3 | 4
5 | 6
4 | 7
公式 | 说明（结果）
=LARGE(A2:B6,3) | 上面数据中第三个最大值 (5)
=LARGE(A2:B6,7) | 上面数据中第七个最大值 (4)


LINEST

使用最小二乘法对已知数据进行最佳直线拟合，并返回描述此直线的数组。因为此函数返回数值数组，所以必须以数组公式的形式输入。

直线的公式为：

y = mx + b

或

y = m1x1 + m2x2 + ... + b（如果有多个区域的 x 值）

式中，因变量 y 是自变量 x 的函数值。M 值是与每个 x 值相对应的系数，b 为常量。注意 y、x 和 m 可以是向量。LINEST 函数返回的数组为 {mn,mn-1,...,m1,b}。LINEST 函数还可返回附加回归统计值。

语法

LINEST(known_y's,known_x's,const,stats)

Known_y's 是关系表达式 y = mx + b 中已知的 y 值集合。

  • 如果数组 known_y's 在单独一列中，则 known_x's 的每一列被视为一个独立的变量。

  • 如果数组 known-y's 在单独一行中，则 known-x's 的每一行被视为一个独立的变量。

Known_x's 是关系表达式 y = mx + b 中已知的可选 x 值集合。

  • 数组 known_x's 可以包含一组或多组变量。如果只用到一个变量，只要 known_y's 和 known_x's 维数相同，它们可以是任何形状的区域。如果用到多个变量，known_y's 必须为向量（即必须为一行或一列）。

  • 如果省略 known_x's，则假设该数组为 {1,2,3,...}，其大小与 known_y's 相同。

Const 为一逻辑值，用于指定是否将常量 b 强制设为 0。

  • 如果 const 为 TRUE 或省略，b 将按正常计算。

  • 如果 const 为 FALSE，b 将被设为 0，并同时调整 m 值使 y = mx。

Stats 为一逻辑值，指定是否返回附加回归统计值。

  • 如果 stats 为 TRUE，则 LINEST 函数返回附加回归统计值，这时返回的数组为 {mn,mn-1,...,m1,b;sen,sen-1,...,se1,seb;r2,sey;F,df;ssreg,ssresid}。

  • 如果 stats 为 FALSE 或省略，LINEST 函数只返回系数 m 和常量 b。

附加回归统计值如下：

统计值 | 说明
se1,se2,...,sen | 系数 m1,m2,...,mn 的标准误差值。
Seb | 常量 b 的标准误差值（当 const 为 FALSE时，seb = #N/A）
r2 | 判定系数。Y 的估计值与实际值之比，范围在 0 到 1 之间。如果为 1，则样本有很好的相关性，Y 的估计值与实际值之间没有差别。如果判定系数为 0，则回归公式不能用来预测 Y 值。有关计算 r2 的方法的详细信息，请参阅本主题后面的“说明”。
sey | Y 估计值的标准误差。
F | F 统计或 F 观察值。使用 F 统计可以判断因变量和自变量之间是否偶尔发生过可观察到的关系。
df | 自由度。用于在统计表上查找 F 临界值。所查得的值和 LINEST 函数返回的 F 统计值的比值可用来判断模型的置信度。
ssreg | 回归平方和。
ssresid | 残差平方和。

下面的图示显示了附加回归统计值返回的顺序。

说明

  • 可以使用斜率和 y 轴截距描述任何直线：

    斜率 (m)：
    通常记为 m，如果需要计算斜率，则选取直线上的两点，(x1,y1) 和 (x2,y2)；斜率等于 (y2 - y1)/(x2 - x1)。

    Y 轴截距 (b)：
    通常记为 b，直线的 y 轴的截距为直线通过 y 轴时与 y 轴交点的数值。

    直线的公式为 y = mx + b。如果知道了 m 和 b 的值，将 y 或 x 的值代入公式就可计算出直线上的任意一点。还可以使用 TREND 函数。

  • 当只有一个自变量 x 时，可直接利用下面公式得到斜率和 y 轴截距值：

    斜率：
    =INDEX(LINEST(known_y's,known_x's),1)

    Y 轴截距：
    =INDEX(LINEST(known_y's,known_x's),2)

  • 数据的离散程度决定了 LINEST 函数计算的精确度。数据越接近线性，LINEST 模型就越精确。LINEST 函数使用最小二乘法来判定最适合数据的模型。当只有一个自变量 x 时，m 和 b 是根据下面的公式计算出的：

  • 直线和曲线函数 LINEST 和 LOGEST 可用来计算与给定数据拟合程度最高的直线或指数曲线。但需要判断两者中哪一个更适合数据。可以用函数 TREND(known_y's,known_x's) 来计算直线，或用函数 GROWTH(known_y's, known_x's) 来计算指数曲线。这些不带参数 new_x's 的函数可在实际数据点上根据直线或曲线来返回 y 的数组值，然后可以将预测值与实际值进行比较。还可以用图表方式来直观地比较二者。
  • 回归分析时，对每一点都计算 y 的估计值和实际值的平方差。这些平方差之和称为残差平方和。然后将计算 y 的实际值和平均值的平方差之和，称为总平方和（回归平方和 + 残差平方和）。残差平方和与总平方和的比值越小，判定系数 r2 的值就越大，r2 是表示回归分析方程的结果反映变量间关系的程度的标志。
  • 对于返回结果为数组的公式，必须以数组公式的形式输入。
  • 当需要输入一个数组常量（如 known_x's）作为参数时，以逗号作为同一行中数据的分隔符，以分号作为不同行数据的分隔符。分隔符将根据“控制面板”中“区域设置”或“区域选项”上的区域设置而有所不同。
  • 注意，如果 y 的回归分析预测值超出了用来计算公式的 y 值的范围，它们可能是无效的。

示例 1 斜率和 Y 轴截距

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
已知 y | 已知 x
1 | 0
9 | 4
5 | 2
7 | 3
公式 | 公式
=LINEST(A2:A5,B2:B5,,FALSE) |

注释 必须将示例中的公式以数组公式的形式输入。将示例复制到空白电子表格中后，请选中从公式单元格开始的区域 A7:B7。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果为 2。

当以数组输入时，将返回斜率 2 和 y 轴截距 1。

示例 2 简单线性回归

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
月 | 销售
1 | 3100
2 | 4500
3 | 4400
4 | 5400
5 | 7500
6 | 8100
公式 | 说明（结果）
=SUM(LINEST(B2:B7, A2:A7)*{9,1}) | 估算第 9 个月的销售值 (11000)

通常，SUM({m,b}*{x,1}) 等于 mx + b，即给定 x 值的 y 的估计值。也可以使用 TREND 函数。

注释 必须将示例中的公式以数组公式的形式输入。在将示例复制到空白电子表格之后，请选择公式单元格 (A9)。按 F2，然后按 Ctrl+Shift+Enter。

示例 3 多重线性回归

假设有开发商正在考虑购买商业区里的一组小型办公楼。

开发商可以根据下列变量，采用多重线性回归的方法来估算给定地区内的办公楼的价值。

变量 | 代表
y | 办公楼的评估值
x1 | 底层面积（平方英尺）
x2 | 办公室的个数
x3 | 入口个数
x4 | 办公楼的使用年数

本示例假设在自变量（x1、x2、x3 和 x4）和因变量 (y) 之间存在线性关系。其中 y 是办公楼的价值。

开发商从 1,500 个可选的办公楼里随机选择了 11 个办公楼作为样本，得到下列数据。 “半个入口”指的是运输专用入口。

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
底层面积 (x1) | 办公室的个数 (x2) | 入口个数 (x3) | 办公楼的使用年数 (x4) | 办公楼的评估值 (y)
2310 | 2 | 2 | 20 | 142,000
2333 | 2 | 2 | 12 | 144,000
2356 | 3 | 1.5 | 33 | 151,000
2379 | 3 | 2 | 43 | 150,000
2402 | 2 | 3 | 53 | 139,000
2425 | 4 | 2 | 23 | 169,000
2448 | 2 | 1.5 | 99 | 126,000
2471 | 2 | 2 | 34 | 142,900
2494 | 3 | 3 | 23 | 163,000
2517 | 4 | 4 | 55 | 169,000
2540 | 2 | 3 | 22 | 149,000
公式
=LINEST(E2:E12,A2:D12,TRUE,TRUE)

注释 必须将示例中的公式以数组公式的形式输入。将示例复制到空白电子表格中后，选中以公式单元格开始的区域 A14:E18。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果为 -234.2371645。

当作为数组输入时，将返回下面的回归统计值，可用该值识别所需的统计值。

多重回归公式，y = m1*x1 + m2*x2 + m3*x3 + m4*x4 + b，可通过第 14 行的值得到：

y = 27.64*x1 + 12,530*x2 + 2,553*x3+ 234.24*x4 + 52,318

现在，开发商用下面公式可得到办公楼的评估价值，其中面积为 2,500 平方英尺、3 个办公室、2 个入口，已使用 25 年：

y = 27.64*2500 + 12530*3 + 2553*2 - 234.24*25 + 52318 = $158,261

或者，可将下表复制到示例工作簿的单元格 A21。

底层面积 (x1) | 办公室的个数 (x2) | 入口个数 (x3) | 办公楼的使用年数 (x4) | 办公楼的评估值 (y)
2500 | 3 | 2 | 25 | =$D$14*$A$22 +$C$14*$B$22 + $B$14*$C$22 +$A$14*$D$22 +$E$14

也可以用 TREND 函数计算此值。

示例 4 使用 F 和 R2 统计

在上例中，判定系数（或 r2）为 0.99675（函数 LINEST 的输出单元格 A17 中的值），表明在自变量与销售价格之间存在很大的相关性。可以通过 F 统计来确定具有如此高的 r2 值的结果偶然发生的可能性。

假设事实上在变量间不存在相关性，但选用 11 个办公楼作为小样本进行统计分析却导致很强的相关性。术语“Alpha”表示得出这样的相关性结论错误的概率。

如果 F 观测统计值大于 F 临界值，表明变量间存在相关性。F 临界值可以从许多的统计类书籍的 F 统计临界值表中查到。如果一项单尾实验的 Alpha 值为 0.05，自由度（在大多数表中缩写成 v1 和 v2）v1 = k = 4，v2 = N - (k + 1) = 11 - (4 + 1) = 6，其中 k 是回归分析中的变量数，n 是数据点的个数。F 临界值为 4.53。

F 观测值为 459.753674（单元格 A18 中），远大于 F 临界值 4.53。因此回归公式可用来对该地区的办公楼进行评估。

示例 5 计算 T 统计

另一个假设检验可以检验示例中的每个斜率系数是否可以用来估算示例 3 中的办公楼的评估价值。例如，如果要检验年数系数的统计显著水平，用 13.268（单元格 A15 里的年数系数的估算标准误差）去除 -234.24（年数斜率系数）。下面是 T 观察值：

t = m4 ÷ se4 = -234.24 ÷ 13.268 = -17.7

如果查阅统计手册里的表格，将会发现：单尾、自由度为 6、Alpha = 0.05 的 t 临界值为 1.94。既然 t 的绝对值为 17.7 大于 1.94，则年数对于估算办公楼的评估价值来说是一个显著变量。用同样方法，可以测试自变量的统计显著水平。下面是每个自变量的 t 观察值。

变量 | t 观察值
底层面积 | 5.1
办公室的个数 | 31.3
入口个数 | 4.8
使用年数 | 17.7

这些值的绝对值都大于 1.94；因此，回归公式的所有变量都可用来估算区域内的办公楼的评估价值。


LOGEST

在回归分析中，计算最符合数据的指数回归拟合曲线，并返回描述该曲线的数值数组。因为此函数返回数值数组，故必须以数组公式的形式输入。

此曲线的方程为：

y = b*m^x 或 y = (b*(m1^x1)*(m2^x2)*_)（如果有多个 x 值）

其中因变量 y 是自变量 x 的函数值。m 值是各指数 x 的底，而 b 值是常量值。注意：公式中的 y、x 和 m 均可以是向量，函数 LOGEST 所返回的数组为 {mn,mn-i,...,m1,b}。

语法

LOGEST(known_y's,known_x's,const,stats)

Known_y's 满足指数回归拟合曲线 y=b*m^x 的一组已知的 y 值。

  • 如果数组 known_y's 在单独一列中，则 known_x's 的每一列被视为一个独立的变量。

  • 如果数组 known-y's 在单独一行中，则 known-x's 的每一行被视为一个独立的变量。

Known_x's 满足指数回归拟合曲线 y=b*m^x 的一组已知的 x 值，为可选参数。

  • known_x's 数组可以包括一组或多组自变量。如果仅使用一个变量，那么只要 known_x's 和 known_y's 具有相同的维数，则它们可以是任何形状的区域。如果使用多个变量，则 known_y's 必须是向量（即具有一列高度或一行宽度的单元格区域）。

  • 如果省略 known_x's，则假设该数组为 {1,2,3,...}，其大小与 known_y's 相同。

Const 为一逻辑值，用于指定是否将常量 b 强制设为 1。

  • 如果 const 为 TRUE 或省略，b 将按正常计算。

  • 如果 const 为 FALSE，则常量 b 将设为 1，而 m 的值满足公式 y=m＾x。

Stats 为一逻辑值，指定是否返回附加回归统计值。

  • 如果 stats 为 TRUE，函数 LOGEST 将返回附加的回归统计值，因此返回的数组为 {mn,mn-1,...,m1,b;sen,sen-1,...,se1,seb;r 2,sey; F,df;ssreg,ssresid}。

  • 如果 stats 为 FALSE 或省略，则函数 LOGSET 只返回系数 m 和常量 b。

有关附加回归统计值的详细信息，请参阅函数 LINEST。

说明

  • 通过数据绘出的图线越近似于指数曲线，则计算出来的曲线就越符合原来给定的数据。正如函数 LINEST 一样，函数 LOGEST 也返回一组描述数值相互关系的数值数组，但函数 LINEST 是用直线来拟合数据的，而函数 LOGEST 则以指数曲线来拟合数据。有关详细信息，请参阅函数 LINEST。
  • 当仅有一个自变量 x 时，可直接用下面的公式计算出斜率 (m) 和 y 轴截距 (b) 的值。

    斜率 (m)：
    INDEX(LOGEST(known_y's,known_x's),1)

    Y 轴截距 (b)：
    INDEX(LOGEST(known_y's,known_x's),2)

    可使用 y = b*m^x 公式来预测 y 的值，但 GROWTH 函数便可做这项工作。有关详细信息，请参阅函数 GROWTH。

  • 对于返回结果为数组的公式，必须以数组公式的形式输入。
  • 当需要输入一个数组常量，比如 known_x's 作为参数时，以逗号作为同一行中数据的分隔符，以分号作为不同行数据的分隔符。分隔符将根据“控制面板”中“区域设置”或“区域选项”上的区域设置而有所不同。
  • 应注意的一点是：如果由回归公式所预测的 y 值超出用来计算回归公式的 y 的取值区间，则该值可能无效。

示例 1：系数 m 和常量 b

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
月 | 值
11 | 33,100
12 | 47,300
13 | 69,000
14 | 102,000
15 | 150,000
16 | 220,000
公式 | 公式
=LOGEST(B2:B7,A2:A7, TRUE, FALSE) |

注释 必须将示例中的公式以数组公式的形式输入。将示例复制到空白电子表格后，选中以公式单元格开始的区域 A9:B10。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果为 1.463275628。

当作为数组输入时，将返回 m 系数和常量 b。

y = b*m1^x1

或使用数组中的值：

y = 495.3 * 1.4633x

可以替换公式中的月份 x 值，估计后几个月的销售情况，或者可使用函数 GROWTH。

示例 2：完全统计

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
月 | 值
11 | 33,100
12 | 47,300
13 | 69,000
14 | 102,000
15 | 150,000
16 | 220,000
公式
=LOGEST(B2:B7,A2:A7, TRUE, TRUE)

注释 必须将示例中的公式以数组公式的形式输入。将示例复制到空白电子表格后，选中以公式单元格开始的区域 A9:B13。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果为 1.463275628。

当作为数组输入时，将返回下面的回归统计值，可用该值识别所需的统计值。

可以利用附加的回归统计值（上述输出数组中的单元格 A10:B13）来确定公式对于未来值预测的有效程度。

要点 使用 LOGEST 对公式进行测试的方法与使用 LINEST 时非常近似。但是，函数 LOGEST 所返回的附加统计值是基于下面的线形模型而计算得出的：

ln y = x1 ln m1 + ... + xn ln mn + ln b

在计算附加的回归统计值，尤其是 sei 和 seb 值时，请牢记这些数值应与 ln mi 和 ln b 比较，而不是与 mi 和 b 比较。有关详细信息，请参阅高级统计手册。


LOGINV

返回 x 的对数累积分布函数的反函数，此处的 ln(x) 是服从 mean 与 standard-dev 参数的正态分布。如果 p = LOGNORMDIST(x,...)，则 LOGINV(p,...) = x。

使用对数分布可分析经过对数变换的数据。

语法

LOGINV(probability,mean,standard_dev)

Probability 是与对数分布相关的概率。

Mean 为 ln(x) 的平均值。

Standard_dev 为 ln(x) 的标准偏差。

说明

  • 如果变量为非数值参数，则函数 LOGINV 返回错误值 #VALUE!。
  • 如果 probability < 0 或 probability > 1，则函数 LOGINV 返回错误值 #NUM!。
  • 如果 standard_dev <= 0，则函数 LOGINV 返回错误值 #NUM!。

  • 对数分布函数的反函数为：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
0.039084 | 与对数分布相关的概率
3.5 | ln(x) 的平均值
1.2 | ln(x) 的标准偏差
公式 | 说明（结果）
=LOGINV(A2, A3, A4) | 在上述条件下对数累积分布函数的反函数值 (4.000014)


LOGNORMDIST

返回 x 的对数累积分布函数，其中 ln(x) 是服从参数 mean 和 standard_dev 的正态分布。使用此函数可以分析经过对数变换的数据。

语法

LOGNORMDIST(x,mean,standard_dev)

X 参数值

Mean 为 ln(x) 的平均值。

Standard_dev 为 ln(x) 的标准偏差。

说明

  • 如果任一参数为非数值型，函数 LOGNORMDIST 返回错误值 #VALUE!。
  • 如果 x ≤ 0 或 standard_dev ≤ 0，函数 LOGNORMDIST 返回错误值 #NUM!。
  • 对数累积分布函数的计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
4 | 参数值 (x)
3.5 | ln(x) 的平均值
1.2 | ln(x) 的标准偏差
公式 | 说明（结果）
=LOGNORMDIST(A2,A3,A4) | 在上述条件下 4 的对数累积分布函数值 (0.039084)


MAX

返回一组值中的最大值。

语法

MAX(number1,number2, ...)

Number1,number2, ... 是要从中找出最大值的 1 到 30 个参数。

说明

  • 可以将参数指定为数字、空白单元格、逻辑值或数字的文本表达式。如果参数为错误值或不能转换成数字的文本，将产生错误。
  • 如果参数为数组或引用，则只有数组或引用中的数字将被计算。数组或引用中的空白单元格、逻辑值或文本将被忽略。如果逻辑值和文本不能忽略，请使用函数 MAXA 来代替。
  • 如果参数不包含数字，函数 MAX 返回 0（零）。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
10
7
9
27
2
公式 | 说明（结果）
=MAX(A2:A6) | 上面一组数字中的最大值 (27)
=MAX(A2:A6, 30) | 上面一组数字和 30 之中的最大值 (30)


MAXA

返回参数清单中的最大值。文本值和逻辑值（如 TRUE 和 FALSE）也作为数字来计算。

函数 MAXA 与函数 MINA 相似。有关详细信息，请参阅函数 MINA 的示例。

语法

MAXA(value1,value2, ...)

Value1, Value2, ... 是要从中找出最大值的 1 到 30 个参数。

说明

  • 参数可以为数字、空白单元格、逻辑值或数字的文本表达式。如果参数为错误值，则会产生错误。如果在计算中不能包含文本或逻辑值，请使用 MAX 函数代替。
  • 如果参数为数组或引用，则只使用数组或引用中的数值。忽略数组或引用中的空白单元格和文本值。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0 计算。
  • 如果参数不包含任何值，函数 MAXA 返回 0。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
0
0.2
0.5
0.4
TRUE
公式 | 说明（结果）
=MAXA(A2:A6) | 上面数据中的最大值。TRUE 值为 1 (1)


MEDIAN

返回给定数值集合的中值。中值是在一组数据中居于中间的数，即在这组数据中，有一半的数据比它大，有一半的数据比它小。

语法

MEDIAN(number1,number2, ...)

Number1, number2, ... 要计算中值的 1 到 30 个数值。

说明

  • 参数应为数字，或者是包含数字的名称、数组或引用。在电子表格中将检查每一数组参数或引用中的所有数字。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。

  • 如果参数集合中包含偶数个数字，函数 MEDIAN 将返回位于中间的两个数的平均值。请参阅下面的第二个公式。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
1
2
3
4
5
6
公式 | 说明（结果）
=MEDIAN(A2:A6) | 上面列表中前五个数的中值 (3)
=MEDIAN(A2:A7) | 上面所有数据的中值，即 3 和 4 的平均值 (3.5)


MIN

返回一组值中的最小值。

语法

MIN(number1,number2, ...)

Number1, number2,... 是要从中找出最小值的 1 到 30 个数字参数。

说明

  • 可以将参数指定为数字、空白单元格、逻辑值或数字的文本表达式。如果参数为错误值或不能转换成数字的文本，将产生错误。
  • 如果参数是数组或引用，则函数 MIN 仅使用其中的数字，空白单元格，逻辑值、文本或错误值将被忽略。如果逻辑值和文本字符串不能忽略，请使用 MINA 函数。
  • 如果参数中不含数字，则函数 MIN 返回 0。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
10
7
9
27
2
公式 | 说明（结果）
=MIN(A2:A6) | 上面数据中的最小值 (2)
=MIN(A2:A6,0) | 上面数据和 0 之中的最小值 (0)


MINA

返回参数列表中的最小值。文本值和逻辑值（如 TRUE 和 FALSE）也作为数字来计算。

语法

MINA(value1,value2,...)

Value1, value2,... 是要从中找出最小值的 1 到 30 个数字参数。

说明

  • 参数可以为数字、空白单元格、逻辑值或数字的文本表达式。如果参数为错误值，则会产生错误。如果在计算中不能包含文本或逻辑值，请使用 MIN 工作表函数来代替。
  • 如果参数为数组或引用，则只使用其中的数值。数组或引用中的空白单元格和文本值将被忽略。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0 计算。
  • 如果参数不包含任何值，函数 MINA 返回 0。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
FALSE
0.2
0.5
0.4
0.8
公式 | 说明（结果）
=MINA(A2:A6) | 上面数据中的最小值。FALSE 的值为 0 (0)


MODE

返回在某一数组或数据区域中出现频率最多的数值。同 MEDIAN 一样，MODE 也是一个位置测量函数。

语法

MODE(number1,number2, ...)

Number1, number2, ... 是用于计算众数的 1 到 30 个参数，也可以不使用这种用逗号分隔参数的形式，而用单个数组或数组引用的形式。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果数据集中不含有重复的数据，则 MODE 数返回错误值 N/A。

在一组数值中，众数是出现频率最高的数值，而中值是位于中间的值，平均值是进行平均后的值，所有这些求中函数都不能单独完整地描绘所有数据。例如，假设数据分布在三个区域中，其中一半集中在一个较小值附近，另外一半集中在两个较大值附近。函数 AVERAGE 和函数 MEDIAN 可能会返回位于相对空的中间的值；而函数 MODE 则可能返回位于数据点密集处的较小值。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
5.6
4
4
3
2
4
公式 | 说明（结果）
=MODE(A2:A7) | 上面数据中的众数，也即出现频率最多的数 (4)


NEGBINOMDIST

返回负二项式分布。当成功概率为常量 probability_s 时，函数 NEGBINOMDIST 返回在到达 number_s 次成功之前，出现 number_f 次失败的概率。此函数与二项式分布相似，只是它的成功次数固定，试验总数为变量。与二项式分布类似的是，试验次数被假设为自变量。

例如，如果要找 10 个反应敏捷的人，且已知具有这种特征的候选人的概率为 0.3。函数 NEGBINOMDIST 将计算出在找到 10 个合格候选人之前，需要对给定数目的不合格候选人进行面视的概率。

语法

NEGBINOMDIST(number_f,number_s,probability_s)

Number_f 失败次数。

Number_s 成功的极限次数。

Probability_s 成功的概率。

说明

  • Number_f 和 number_s 应 >= 0。
  • Number_f 和 number_s 将被截尾取整。
  • 如果任一参数为非数值型，函数 NEGBINOMDIST 返回错误值 #VALUE!。
  • 如果 probability_s < 0 或 probability > 1，函数 NEGBINOMDIST 返回错误值 #NUM!。
  • 负二项式分布的计算公式如下：

    式中：

    x 是 number_f，r 是 number_s，且 p 是 probability_s。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
10 | 失败次数
5 | 成功的极限次数
0.25 | 成功的概率
公式 | 说明（结果）
=NEGBINOMDIST(A2,A3,A4) | 在上述条件下的负二项式分布值 (0.055049)


NORMDIST

返回指定平均值和标准偏差的正态分布函数。此函数在统计方面应用范围广泛（包括假设检验）。

语法

NORMDIST(x,mean,standard_dev,cumulative)

X 为需要计算其分布的数值。

Mean 分布的算术平均值。

Standard_dev 分布的标准偏差。

Cumulative 为一逻辑值，指明函数的形式。如果 cumulative 为 TRUE，函数 NORMDIST 返回累积分布函数；如果为 FALSE，返回概率密度函数。

说明

  • 如果 mean 或 stand_dev 为非数值型，函数 NORMDIST 返回错误值 #VALUE!。
  • 如果 standard_dev ≤ 0，函数 NORMDIST 返回错误值 #NUM!。
  • 如果 mean = 0，standard_dev = 1，且 cumulative = TRUE，则函数 NORMDIST 返回标准正态分布，即函数 NORMSDIST。
  • 正态分布密度函数 (cumulative = FALSE) 的计算公式如下：

  • 如果 cumulative = TRUE，则该公式为从负无穷到给定公式的 x 的积分。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
42 | 需要计算其分布的数值
40 | 该分布的算术平均值
1.5 | 该分布的标准偏差
公式 | 说明（结果）
=NORMDIST(A2,A3,A4,TRUE) | 在上述条件下的累积分布函数值 (0.908789)
=NORMDIST(A2,A3,A4,FALSE) | 在上述条件下的概率密度函数值 (0.10934005)


NORMINV

返回指定平均值和标准偏差的正态累积分布函数的反函数。

语法

NORMINV(probability,mean,standard_dev)

Probability 正态分布的概率值。

Mean 分布的算术平均值。

Standard_dev 分布的标准偏差。

说明

  • 如果任一参数为非数值型，函数 NORMINV 返回错误值 #VALUE!。
  • 如果 probability < 0 或 probability > 1，函数 NORMINV 返回错误值 #NUM!。
  • 如果 standard_dev ≤ 0，函数 NORMINV 返回错误值 #NUM!。

  • 如果 mean = 0 且 standard_dev = 1，函数 NORMINV 使用标准正态分布（请参阅函数 NORMSINV）。

函数 NORMINV 使用迭代法来进行计算。给定一个概率值，函数 NORMINV 开始迭代，直到结果精确到 ±3x10^-7。如果经过 100 次迭代后，函数 NORMINV 仍未收敛，则返回错误值 #N/A。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
0.908789 | 正态分布的概率值
40 | 该分布的算术平均值
1.5 | 该分布的标准偏差
公式 | 说明（结果）
=NORMINV(A2,A3,A4) | 在上述条件下正态分布累积函数的反函数值 (42)


NORMSDIST

返回标准正态累积分布函数，该分布的平均值为 0，标准偏差为 1。可以使用该函数代替标准正态曲线面积表。

语法

NORMSDIST(z)

Z 为需要计算其分布的数值。

说明

  • 如果 z 为非数值型，函数 NORMSDIST 返回错误值 #VALUE!。
  • 标准正态分布密度函数计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=NORMSDIST(1.333333) | 1.333333 的正态累积分布函数值 (0.908789)


NORMSINV

返回标准正态累积分布函数的反函数。该分布的平均值为 0，标准偏差为 1。

语法

NORMSINV(probability)

Probability 正态分布的概率值。

说明

  • 如果 probability 为非数值型，函数 NORMSINV 返回错误值 #VALUE!。
  • 如果 probability < 0 或 probability > 1，函数 NORMINV 返回错误值 #NUM!。

函数 NORMSINV 使用迭代法来进行计算。给定一个概率值，函数 NORMSINV 开始迭代，直到结果精确到 ±3x10^-7。如果经过 100 次迭代后，函数 NORMSINV 仍未收敛，则返回错误值 #N/A。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=NORMSINV(0.908789) | 正态分布概率为 0.908789 时，标准正态累积分布函数的反函数值 (1.3333)


PEARSON

返回 Pearson（皮尔生）乘积矩相关系数 r，这是一个范围在 -1.0 到 1.0 之间（包括 -1.0 和 1.0 在内）的无量纲指数，反映了两个数据集合之间的线性相关程度。

语法

PEARSON(array1,array2)

Array1 为自变量集合。

Array2 为因变量集合。

说明

  • 参数可以是数字，或者是包含数字的名称、数组常量或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果 array1 和 array2 为空或其数据点个数不同，函数 PEARSON 返回错误值 #N/A。
  • 回归线的 r 值为：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
自变量值 | 因变量值
9 | 10
7 | 6
5 | 1
3 | 5
1 | 3
公式 | 说明（结果）
=PEARSON(A2:A6,B2:B6) | 上面数据集合的 Pearson（皮尔生）乘积矩相关系数 (0.699379)


PERCENTILE

返回区域中数值的第 K 个百分点的值。可以使用此函数来建立接受阈值。例如，可以确定得分排名在第 90 个百分点之上的检测侯选人。

语法

PERCENTILE(array,k)

Array 为定义相对位置的数组或数据区域。

K 0 到 1 之间的百分点值，包含 0 和 1。

说明

  • 如果 array 为空或其数据点超过 8,191 个，函数 PERCENTILE 返回错误值 #NUM!。
  • 如果 k 为非数字型，函数 PERCENTILE 返回错误值 #VALUE!。
  • 如果 k < 0 或 k > 1，函数 PERCENTILE 返回错误值 #NUM!。
  • 如果 k 不是 1/(n-1) 的倍数，函数 PERCENTILE 使用插值法来确定第 k 个百分点的值。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
1
3
2
4
公式 | 说明（结果）
=PERCENTILE(A2:A5,0.3) | 上面列表中的数据在第 30 个百分点的值 (1.9)


PERCENTRANK

返回特定数值在一个数据集中的百分比排位。此函数可用于查看特定数据在数据集中所处的位置。例如，可以使用函数 PERCENTRANK 计算某个特定的能力测试得分在所有的能力测试得分中的位置。

语法

PERCENTRANK(array,x,significance)

Array 为定义相对位置的数组或数字区域。

X 为数组中需要得到其排位的值。

Significance 为可选项，表示返回的百分比数值的有效位数。如果省略，函数 PERCENTRANK 保留 3 位小数 (0.xxx)。

说明

  • 如果数组为空，函数 PERCENTRANK 返回错误值 #NUM!。
  • 如果 significane < 1，函数 PERCENTRANK 返回错误值 #NUM!。
  • 如果数组里没有与 x 相匹配的值，函数 PERCENTRANK 将进行插值以返回正确的百分比排位。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
13
12
11
8
4
3
2
1
1
1
公式 | 说明（结果）
=PERCENTRANK(A2:A11,2) | 2 在上面数据列表中的百分比排位 （0.333，这是因为在该组值中有 3 个值小于 2，6 个值大于 2，所以 3/(3+6)=0.333）
=PERCENTRANK(A2:A11,4) | 4 在上面数据列表中的百分比排位 (0.555)
=PERCENTRANK(A2:A11,8) | 8 在上面数据列表中的百分比排位 (0.666)
=PERCENTRANK(A2:A11,5) | 5 在上面数据列表中的百分比排位 （0.583，4 和 8 的 PERCENTRANK 之间的四分之一）

注释 若要以百分比的形式显示数字，请选中单元格并单击工具栏上的“命令和选项” 按钮图像 ，再单击“格式”选项卡，然后在“数字格式”框中选取所需的“百分比”格式。


PERMUT

返回从给定数目的对象集合中选取的若干对象的排列数。排列为有内部顺序的对象或事件的任意集合或子集。排列与组合不同，组合的内部顺序无意义。此函数可用于彩票抽奖的概率计算。

语法

PERMUT(number,number_chosen)

Number 表示对象个数的整数。

Number_chosen 表示每个排列中对象个数的整数。

说明

  • 两个参数将被截尾取整。
  • 如果 number 或 number_chosen 为非数值型，函数 PERMUT 返回错误值 #VALUE!。
  • 如果 number ≤ 0 或 number_chosen < 0，函数 PERMUT 返回错误值 #NUM!。
  • 如果 number < number_chosen，函数 PERMUT 返回错误值 #NUM!。
  • 排列数的计算公式如下:

示例

假设需要计算彩票中奖的可能性，每个彩票号码分别有 3 位数，每个数的范围为 0 到 99之间（包括 0 和 99）。下面函数给出了所有可能的排列的数量：

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
100 | 对象总数
3 | 每个排列中的对象数
公式 | 说明（结果）
=PERMUT(A2,A3) | 在上述条件下所有可能的排列数量 (970200)


POISSON

返回泊松分布。泊松分布通常用于预测一段时间内事件发生的次数，比如一分钟内通过收费站的轿车的数量。

语法

POISSON(x,mean,cumulative)

X 事件数。

Mean 期望值。

Cumulative 为一逻辑值，确定所返回的概率分布形式。如果 cumulative 为 TRUE，函数 POISSON 返回泊松累积分布概率，即，随机事件发生的次数在 0 到 x 之间（包含 0 和 1）；如果为 FALSE，则返回泊松概率密度函数，即，随机事件发生的次数恰好为 x。

说明

  • 如果 x 不为整数，将被截尾取整。
  • 如果 x 或 mean 为非数值型，函数 POISSON 返回错误值 #VALUE!。
  • 如果 x ≤ 0，函数 POISSON 返回错误值 #NUM!。
  • 如果 mean ≤ 0，函数 POISSON 返回错误值 #NUM!。
  • 函数 POISSON 的计算公式如下：

    假设 cumulative = FALSE:

    假设 cumulative = TRUE:

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
2 | 事件数
5 | 期望值
公式 | 说明（结果）
=POISSON(A2,A3,TRUE) | 符合上述条件的泊松累积分布概率 (0.124652)
=POISSON(A2,A3,FALSE) | 符合上述条件的泊松概率密度函数的结果 (0.084224)


PROB

返回区域中的数值落在指定区间内的概率。如果没有给出上限 (upper_limit)，则返回区间 x_range 内的值等于下限 lower_limit 的概率。

语法

PROB(x_range,prob_range,lower_limit,upper_limit)

X_range 具有各自相应概率值的 x 数值区域。

Prob_range 与 x_range 中的值相对应的一组概率值。

Lower_limit 用于计算概率的数值下界。

Upper_limit 用于计算概率的可选数值上界。

说明

  • 如果 prob_range 中的任意值 ≤ 0 或 > 1，函数 PROB 返回错误值 #NUM!。
  • 如果 prob_range 中所有值之和 1 1，函数 PROB 返回错误值 #NUM!。
  • 如果省略 upper_limit，函数 PROB 返回值等于 lower_limit 时的概率。
  • 如果 x_range 和 prob_range 中的数据点个数不同，函数 PROB 返回错误值 #N/A。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
x | 概率
0 | 0.2
1 | 0.3
2 | 0.1
3 | 0.4
公式 | 说明（结果）
=PROB(A2:A5,B2:B5,2) | x 为 2 的概率 (0.1)
=PROB(A2:A5,B2:B5,1,3) | x 在 1 到 3 之间的概率 (0.8)


QUARTILE

返回数据集的四分位数。四分位数通常用于在销售额和测量数据中对总体进行分组。例如，可以使用函数 QUARTILE 求得总体中前 25% 的收入值。

语法

QUARTILE(array,quart)

Array 为需要求得四分位数值的数组或数字型单元格区域。

Quart 决定返回哪一个四分位值。

如果 qurart 等于 | 函数 QUARTILE 返回
0 | 最小值
1 | 第一个四分位数（第 25 个百分点值）
2 | 中分位数（第 50 个百分点值）
3 | 第三个四分位数（第 75 个百分点值）
4 | 最大值

说明
  • 如果数组为空，函数 QUARTILE 返回错误值 #NUM!。
  • 如果 quart 不为整数，将被截尾取整。
  • 如果 quart < 0 或 quart > 4，函数 QUARTILE 返回错误值 #NUM!。
  • 当 quart 分别等于 0、2 和 4 时，函数 MIN、MEDIAN 和 MAX 返回的值与函数 QUARTILE 返回的值相同。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
1
2
4
7
8
9
10
12
公式 | 说明（结果）
=QUARTILE(A2:A9,1) | 上述数据的第一个四分位数（第 25 个百分点值）(3.5)


RANK

返回一个数字在数字列表中的排位。数字的排位是其大小与列表中其他值的比值（如果列表已排过序，则数字的排位就是它当前的位置）。

语法

RANK(number,ref,order)

Number 为需要找到排位的数字。

Ref 为数字列表数组或对数字列表的引用。Ref 中的非数值型参数将被忽略。

Order 为一数字，指明数字排位的方式。

  • 如果 order 为 0（零）或省略，则对数字的排位是基于 ref 为按照降序排列的列表。
  • 如果 order 不为零，则对数字的排位是基于 ref 为按照升序排列的列表。

说明

函数 RANK 对重复数的排位相同。但重复数的存在将影响后续数值的排位。例如，在一列整数里，如果整数 10 出现两次，其排位为 5，则 11 的排位为 7（没有排位为 6 的数值）。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
7
3.5
3.5
1
2
公式 | 说明（结果）
=RANK(A3,A2:A6,1) | 3.5 在上表中的排位 (3)
=RANK(A2,A2:A6,1) | 7 在上表中的排位 (5)


RSQ

返回根据 known_y's 和 known_x's 中数据点计算得出的 Pearson 乘积矩相关系数的平方。有关详细信息，请参阅函数 REARSON。R 平方值可以解释为 y 方差与 x 方差的比例。

语法

RSQ(known_y's,known_x's)

Known_y's 为数组或数据点区域。

Known_x's 为数组或数据点区域。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果 known_y's 和 known_x's 为空或其数据点个数不同，函数 RSQ 返回错误值 #N/A。
  • 回归线 r 值的计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
已知 y | 已知 x
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
7 | 4
5 | 4
公式 | 说明（结果）
=RSQ(A2:A8,B2:B8) | 根据以上数据点计算得出的 Pearson 乘积矩相关系数的平方 (0.05795)


SKEW

返回分布的偏斜度。偏斜度反映以平均值为中心的分布的不对称程度。正偏斜度表示不对称部分的分布更趋向正值。负偏斜度表示不对称部分的分布更趋向负值。

语法

SKEW(number1,number2, ...)

Number1,number2... 为需要计算偏斜度的 1 到 30 个参数。也可以不用这种用逗号分隔参数的形式，而用单个数组或对数组的引用。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果数据点个数少于 3 个，或样本标准偏差为零，函数 SKEW 返回错误值 #DIV/0!。
  • 偏斜度的计算公式定义如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
3
4
5
2
3
4
5
6
4
7
公式 | 说明（结果）
=SKEW(A2:A11) | 上面数据集分布的偏斜度 (0.359543)


SLOPE

返回根据 known_y's 和 known_x's 中的数据点拟合的线性回归直线的斜率。斜率为直线上任意两点的重直距离与水平距离的比值，也就是回归直线的变化率。

语法

SLOPE(known_y's,known_x's)

Known_y's 为数字型因变量数据点数组或单元格区域。

Known_x's 为自变量数据点集合。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果 known_y's 和 known_x's 为空或其数据点个数不同，函数 SLOPE 返回错误值 #N/A。
  • 回归直线的斜率计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
已知 y | 已知 x
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
7 | 4
5 | 4
公式 | 说明（结果）
=SLOPE(A2:A8,B2:B8) | 通过上面数据点的线性回归拟合线的斜率 (0.305556)


SMALL

返回数据集中第 k 个最小值。使用此函数可以返回数据集中特定位置上的数值。

语法

SMALL(array,k)

Array 为需要找到第 k 个最小值的数组或数字型数据区域。

K 为返回的数据在数组或数据区域里的位置（从小到大）。

说明

  • 如果 array 为空，函数 SMALL 返回错误值 #NUM!。
  • 如果 k ≤ 0 或 k 超过了数据点个数，函数 SMALL 返回错误值 #NUM!。
  • 如果 n 为数组中的数据点个数，则 SMALL(array,1) 等于最小值，SMALL(array,n) 等于最大值。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 数据
3 | 1
4 | 4
5 | 8
2 | 3
3 | 7
4 | 12
6 | 54
4 | 8
7 | 23
公式 | 说明（结果）
=SMALL(A2:A10,4) | 第一列中第四个最小值 (4)
=SMALL(B2:B10,2) | 第二列中第二个最小值 (3)


STANDARDIZE

返回以 mean 为平均值，以 standard-dev 为标准偏差的分布的正态化数值。

语法

STANDARDIZE(x,mean,standard_dev)

X 为需要进行正态化的数值。

Mean 分布的算术平均值。

Standard_dev 分布的标准偏差。

说明

  • 如果 standard_dev ≤ 0，函数 STANDARDIZE 返回错误值 #NUM!。
  • 正态化数值的计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
42 | 要正态化的数值
40 | 分布的算术平均值
1.5 | 分布的标准偏差
公式 | 说明（结果）
=STANDARDIZE(A2,A3,A4) | 符合上述条件的 42 的正态化数值 (1.333333)


STDEV

估算样本的标准偏差。标准偏差反映相对于平均值 (mean) 的离散程度。

语法

STDEV(number1,number2,...)

Number1,number2,... 为对应于总体样本的 1 到 30 个参数。也可以不使用这种用逗号分隔参数的形式，而用单个数组或对数组的引用。

说明

  • 逻辑值（TRUE 和 FALSE）和文本将被忽略。如果不能忽略逻辑值和文本，请使用 STDEVA 电子表格函数。
  • 函数 STDEV 假设其参数是总体中的样本。如果数据代表全部样本总体，则应该使用函数 STDEVP 计算标准偏差。
  • 此处标准偏差的计算使用“无偏差”或“n-1”方法。
  • 函数 STDEV 的计算公式如下：

示例

假设有 10 件工具在制造过程中是由同一台机器制造出来的，并取样为随机样本并进行抗断强度检验。

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
强度
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
公式 | 说明（结果）
=STDEV(A2:A11) | 抗断强度的标准偏差 (27.46391572)


STDEVA

估算基于给定样本的标准偏差。标准偏差反映数值相对于平均值 (mean) 的离散程度。文本值和逻辑值（如 TRUE 或 FALSE）也将计算在内。

语法

STDEVA(value1,value2, ...)

Value1,value2, ... 为对应于总体的一个样本的 1 到 30 个参数。也可以不使用这种用逗号分隔参数的形式，而用单个数组或对数组的引用。

说明

  • 函数 STDEVA 假设参数为总体的一个样本。如果数据代表的是样本总体，则必须使用函数 STDEVPA 来计算标准偏差。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0（零）计算。如果在计算中不能包含文本值或逻辑值，请使用 STDEV 电子表格函数来代替。
  • 此处标准偏差的计算使用“无偏差”或“n-1”方法。
  • 函数 STDEVA 的计算公式如下：

示例

假设有 10 件工具在制造过程中是由同一台机器制造出来的，并取样为随机样本进行抗断强度检验。

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
强度
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
公式 | 说明（结果）
=STDEVA(A2:A11) | 全部工具抗断强度的标准偏差 (27.46391572)


STDEVP

返回以参数形式给出的整个样本总体的标准偏差。标准偏差反映相对于平均值 (mean) 的离散程度。

语法

STDEVP(number1,number2, ...)

Number1,number2,... 为对应于样本总体的 1 到 30 个参数。也可以不使用这种用逗号分隔参数的形式，而用单个数组或对数组的引用。

说明

  • 逻辑值（TRUE 和 FALSE）和文本将被忽略。如果不能忽略逻辑值和文本，请使用 STDEVPA 电子表格函数。
  • 函数 STDEVP 假设其参数为整个样本总体。如果数据代表样本总体中的一个样本，则应使用函数 STDEV 来计算标准偏差。
  • 对于大样本容量，函数 STDEV 和 STDEVP 计算结果大致相等。
  • 此处标准偏差的计算使用“有偏差”和“n”方法。
  • 函数 STDEVP 的计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
强度
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
公式 | 说明（结果）
=STDEVP(A2:A11) | 假定仅生产了 10 件工具，其抗断强度的标准偏差 (26.05455814)


STDEVPA

返回以参数形式给出的整个样本总体的标准偏差，包含文本和逻辑值。标准偏差反映数值相对于平均值 (mean) 的离散程度。

语法

STDEVPA(value1,value2, ...)

Value1,value2,... 为样本总体的 1 到 30 个参数。也可以不使用这种用逗号分隔参数的形式，而用单个数组或对数组的引用。

说明

  • 函数 STDEVPA 假设参数即为样本总体。如果数据代表的是总体的一个样本，则必须使用函数 STDEVA 来估算标准偏差。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0 计算。如果在计算中不能包含文本值或逻辑值，请使用 STDEVP 电子表格函数来代替。
  • 对于大样本容量，函数 STDEVA 和函数 STDEVPA 的返回值大致相等。
  • 此处标准偏差的计算使用“有偏差”和“n”方法。
  • 函数 STDEVPA 的计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
强度
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
公式 | 说明（结果）
=STDEVPA(A2:A11) | 假定仅生产了 10 件工具，其抗断强度的标准偏差 (26.05455814)


STEYX

返回通过线性回归法计算每个 x 的 y 预测值时所产生的标准误差。标准误差用来度量根据单个 x 变量计算出的 y 预测值的误差量。

语法

STEYX(known_y's,known_x's)

Known_y's 为因变量数据点数组或区域。

Known_x's 为自变量数据点数组或区域。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果 known_y's 和 known_x's 为空或其数据点个数不同，函数 STEYX 返回错误值 #N//A。
  • 预测值 y 的标准误差计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
已知 y | 已知 x
2 | 6
3 | 5
9 | 11
1 | 7
8 | 5
7 | 4
5 | 4
公式 | 说明（结果）
=STEYX(A2:A8,B2:B8) | 线性回归法计算每个 x 的 y 预测值时所产生的标准误差 (3.305719)


TDIST

返回学生 t 分布的百分点（概率），t 分布中数值 (x) 是 t 的计算值（将计算其百分点）。t 分布用于小样本数据集合的假设检验。使用此函数可以代替 t 分布的临界值表。

语法

TDIST(x,degrees_freedom,tails)

X 为需要计算分布的数字。

Degrees_freedom 为表示自由度的整数。

Tails 指示返回的分布函数是单尾分布还是双尾分布。如果 tails = 1，函数 TDIST 返回单尾分布。如果 tails = 2，函数 TDIST 返回双尾分布。

说明

  • 如果任一参数为非数值型，函数 TDIST 返回错误值 #VALUE!。
  • 如果 degrees_freedom < 1，函数 TDIST 返回错误值 #NUM!。
  • 参数 degrees_freedom 和 tails 将被截尾取整。
  • 如果 tails 不为 1 或 2，函数 TDIST 返回错误值 #NUM!。
  • 函数 TDIST 的计算公式为 TDIST = p( x<abs(X))，其中 X 为服从 t 分布的随机变量。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
1.96 | 为需要计算分布的数值
60 | 自由度
公式 | 说明（结果）
=TDIST(A2,A3,2) | 双尾分布（0.054644927 或 5.46%）
=TDIST(A2,A3,1) | 单尾分布（0.027322463 或 2.73%）

注释 若要以百分比的形式显示数字，请选中单元格并在工具栏上单击“命令和选项” 按钮图像 。再单击“格式”选项卡，然后单击“数字格式”框中的“百分比”。


TINV

返回作为概率和自由度函数的学生 t 分布的 t 值。

语法

TINV(probability,degrees_freedom)

Probability 为对应于双尾学生 t 分布的概率。

Degrees_freedom 为分布的自由度。

说明

  • 如果任一参数为非数值型，函数 TINV 返回错误值 #VALUE!。
  • 如果 probability < 0 或 probability > 1，函数 TINV 返回错误值 #NUM!。
  • 如果 degrees_freedom 不是整数，将被截尾取整。
  • 如果 degrees_freedom < 1，函数 TINV 返回错误值 #NUM!。
  • 函数 TINV 的计算公式为 TINV=P( t<X )，其中 X 为服从 t 分布的随机变量。
  • 单尾 t 值可通过用两倍概率替换概率而求得。如果概率为 0.05 而自由度为 10 ，则双尾值由 TINV(0.05,10) 计算得到，它返回 2.28139。而同样概率和自由度的单尾值可由 TINV(2*0.05,10) 计算得到，它返回 1.812462。

    注释 在某些表中，概率被描述为 (1-p)。

函数 TINV 使用迭代法来进行计算。给定一个概率值，函数 TINV 开始迭代，直到结果精确到 ±3x10^-7。如果经过 100 次迭代后，函数 TINV 仍未收敛，则返回错误值 #N/A。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
0.054645 | 对应于双尾学生 t 分布的概率
60 | 自由度
公式 | 说明（结果）
=TINV(A2,A3) | 在上述条件下学生 t 分布的 t 值 (1.959997462)


TREND

返回一条线性回归拟合线的一组纵坐标值（y 值）。即找到适合给定的数组 known_y's 和 known_x's 的直线（用最小二乘法），并返回指定数组 new_x's 值在直线上对应的 y 值。

语法

TREND(known_y's,known_x's,new_x's,const)

Known_y's 是关系表达式 y = mx + b 中已知的 y 值集合。

  • 如果数组 known_y's 在单独一列中，则 known_x's 的每一列被视为一个独立的变量。

  • 如果数组 known-y's 在单独一行中，则 known-x's 的每一行被视为一个独立的变量。

Known_x's 是关系表达式 y = mx + b 中已知的可选 x 值集合。

  • 数组 known_x's 可以包含一组或多组变量。如果只用到一个变量，只要 known_y's 和 known_x's 维数相同，它们可以是任何形状的区域。如果用到多个变量，known_y's 必须为向量（即必须为一行或一列）。

  • 如果省略 known_x's，则假设该数组为 {1,2,3,...}，其大小与 known_y's 相同。

New_x's 为需要函数 TREND 返回对应 y 值的新 x 值。

  • New_x's 与 known_x's 一样，每个独立变量必须为单独的一行（或一列）。因此，如果 known_y's 是单列的，known_x's 和 new_x's 应该有同样的列数。如果 known_y's 是单行的，known_x's 和 new_x's 应该有同样的行数。

  • 如果省略 new_x's，将假设它和 known_x's 一样。

  • 如果 known_x's 和 new_x's 都省略，将假设它们为数组 {1,2,3,...}，大小与 known_y's 相同。

Const 为一逻辑值，用于指定是否将常数 b 强制设为 0。

  • 如果 const 为 TRUE 或省略，b 将按正常计算。

  • 如果 const 为 FALSE，b 将被设为 0（零），m 将被调整以使 y = mx。

说明

  • 有关直线拟合数据的信息，请参阅 LINEST。
  • 可以使用函数 TREND 计算同一变量的不同乘方的回归值来拟合多项式曲线。例如，假设 A 列包含 y 值，B 列含有 x 值。可以在 C 列中输入 x^2，在 D 列中输入 x^3，等等，然后根据 A 列对 B 列到 D 列进行回归计算。
  • 对于返回结果为数组的公式，必须以数组公式的形式输入。
  • 当为参数（如 known_x's）输入数组常量时，应当使用逗号分隔同一行中的数据，用分号分隔不同行中的数据。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。

第一个公式显示已知值所对应的值。如果线性趋势继续存在，第二个公式预测下个月的值。

月 | 资产原值 | 公式（对应的资产原值）
1 | $133,890 | =TREND(B2:B13, A2:A13)
2 | $135,000 |
3 | $135,790 |
4 | $137,300 |
5 | $138,130 |
6 | $139,100 |
7 | $139,900 |
8 | $141,120 |
9 | $141,890 |
10 | $143,230 |
11 | $144,000 |
12 | $145,290 |
月 | 公式（预测的资产原值）
13 | =TREND(B2:B13, A2:A13,A15:A19)
14 |
15 |
16 |
17 |

注释 必须将示例中的公式以数组公式的形式输入。将示例复制到空白电子表格后，选中以公式单元格开始的区域 C2:C13 或 B15:B19。按 F2，然后按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式输入，则单个结果为 133953.3333 和 146171.5152。


TRIMMEAN

返回数据集的内部平均值。函数 TRIMMEAN 先从数据集的头部和尾部除去一定百分比的数据点，然后再求平均值。当希望在分析中剔除一部分数据的计算时，可以使用此函数。

语法

TRIMMEAN(array,percent)

Array 为需要进行整理并求平均值的数组或数值区域。

Percent 为计算时所要除去的数据点的比例，例如，如果 percent = 0.2，在 20 个数据点的集合中，就要除去 4 个数据点 (20 x 0.2)，头部除去 2 个，尾部除去 2 个。

说明

  • 如果 percent < 0 或 percent > 1，函数 TRIMMEAN 返回错误值 #NUM!。
  • 函数 TRIMMEAN 将除去的数据点数目向下舍入为最接近的 2 的倍数。如果 percent = 0.1，30 个数据点的 10% 等于 3 个数据点。函数 TRIMMEAN 将对称地在数据集的头部和尾部各除去一个数据。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
4
5
6
7
2
3
4
5
1
2
3
公式 | 说明（结果）
=TRIMMEAN(A2:A12,0.2) | 上面数据集的内部平均值（从计算中除去 20%）(3.777778)


TTEST

返回与学生 t 检验相关的概率。可以使用函数 TTEST 判断两个样本是否可能来自两个具有相同平均值的总体。

语法

TTEST(array1,array2,tails,type)

Array1 为第一个数据集。

Array2 为第二个数据集。

Tails 指示分布曲线的尾数。如果 tails = 1，函数 TTEST 使用单尾分布。如果 tails = 2，函数 TTEST 使用双尾分布。

Type 为 t 检验的类型。

如果 type 等于 | 检验方法
1 | 成对
2 | 等方差双样本检验
3 | 异方差双样本检验

说明

  • 如果 array1 和 array2 的数据点个数不同，且 type = 1（成对），函数 TTEST 返回错误值 #N/A。
  • 参数 tails 和 type 将被截尾取整。
  • 如果 tails 或 type 为非数值型，函数 TTEST 返回错误值 #VALUE!。
  • 如果 tails 不为 1 或 2，函数 TTEST 返回错误值 #NUM!。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 1 | 数据 2
3 | 6
4 | 19
5 | 3
8 | 2
9 | 14
1 | 4
2 | 5
4 | 17
5 | 1
公式 | 说明（结果）
=TTEST(A2:A10,B2:B10,2,1) | 对应于学生的成对 t 检验的概率（双尾分布）(0.196016)


VAR

计算基于给定样本的方差。

语法

VAR(number1,number2, ...)

Number1,number2, ... 为对应于总体样本的 1 到 30 个参数。

说明

  • 函数 VAR 假设其参数是样本总体中的一个样本。如果数据为样本总体，则应使用函数 VARP 来计算方差。
  • 逻辑值（TRUE 和 FALSE）和文本将被忽略。如果不能忽略逻辑值和文本，请使用 VARA 电子表格函数。
  • 函数 VAR 的计算公式如下：

示例

假设有 10 件工具在制造过程中是由同一台机器制造出来的，并取样为随机样本进行抗断强度检验。

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
强度
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
公式 | 说明（结果）
=VAR(A2:A11) | 工具抗断强度的方差 (754.2666667)


VARA

计算基于给定样本的方差。不仅数字，文本值和逻辑值（如 TRUE 和 FALSE）也将计算在内。

语法

VARA(value1,value2, ...)

Value1,value2, ... 对应于总体样本的 1 到 30 个参数。

说明

  • 函数 VARA 假设参数为总体的一个样本。如果数据代表的是样本总体，则必须使用函数 VARPA 来计算方差。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0 计算。如果在计算中不能包含文本值或逻辑值，请使用 VAR 电子表格函数来代替。
  • 函数 VARA 的计算公式如下：

示例

假设有 10 件工具在制造过程中是由同一台机器制造出来的，并取样为随机样本进行抗断强度检验。

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
强度
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
公式 | 说明（结果）
=VARA(A2:A11) | 计算抗断强度的方差 (754.2666667)


VARP

计算基于整个样本总体的方差。

语法

VARP(number1,number2, ...)

Number1,number2, ... 为对应于样本总体的 1 到 30 个参数。

  • 逻辑值（TRUE 和 FALSE）和文本将被忽略。如果不能忽略逻辑值和文本，请使用 VARPA 电子表格函数。

说明

  • 函数 VARP 假设其参数为样本总体。如果数据只是代表样本总体中的一个样本，请使用函数 VAR 计算方差。
  • 函数 VARP 的计算公式如下：

示例

假设所有 10 件工具在制造过程中都是由同一台机器制造出来的，并取样进行抗断强度检验。

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
强度
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
公式 | 说明（结果）
=VARP(A2:A11) | 全部工具抗断强度的方差，假定只生产了 10 件工具 (678.84)。


VARPA

计算基于整个样本总体的方差。不仅数字，文本值和逻辑值（如 TRUE 和 FALSE）也将计算在内。

语法

VARPA(value1,value2, ...)

Value1,value2,... 为样本总体的 1 到 30 个参数。

说明

  • 函数 VARPA 假设参数即为样本总体。如果数据代表的是总体的一个样本，则必须使用函数 VARA 来估计方差。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0 计算。如果在计算中不能包含文本值或逻辑值，请使用 VARP 电子表格函数来代替。
  • 函数 VARPA 的计算公式如下：

示例

假设所有 10 件工具在制造过程中都是由同一台机器制造出来的，并取样进行抗断强度检验。

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
强度
1345
1301
1368
1322
1310
1370
1318
1350
1303
1299
公式 | 说明（结果）
=VARPA(A2:A11) | 全部工具抗断强度的方差，假定只生产了 10 件工具 (678.84)


WEIBULL

返回韦伯分布。使用此函数可以进行可靠性分析，比如计算设备的平均故障时间。

语法

WEIBULL(x,alpha,beta,cumulative)

X 参数值。

Alpha 分布参数。

Beta 分布参数。

Cumulative 指明函数的形式。

说明

  • 如果 x、alpha 或 beta 为非数值型，函数 WEIBULL 返回错误值 #VALUE!。
  • 如果 x < 0，函数 WEIBULL 返回错误值 #NUM!。
  • 如果 alpha ≤ 0 或 beta ≤ 0，函数 WEIBULL 返回错误值 #NUM!。
  • 韦伯累积分布函数的计算公式如下：

  • 韦伯概率密度函数的计算公式如下：

  • 当 alpha = 1，函数 WEIBULL 返回指数分布：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据 | 说明
105 | 计算函数的数值
20 | α 分布参数
100 | β 分布参数
公式 | 说明（结果）
=WEIBULL(A2,A3,A4,TRUE) | 在上述条件下使用韦伯累积分布函数的结果 (0.929581)
=WEIBULL(A2,A3,A4,FALSE) | 在上述条件下使用韦伯概率密度函数的结果 (0.035589)


ZTEST

返回 z 检验的双尾 P 值。Z 检验根据数据集或数组生成 x 的标准得分，并返回正态分布的双尾概率。可以使用此函数返回从某总体中抽取特定观测值的似然估计。

语法

ZTEST(array,x,sigma)

Array 为用来检验 x 的数组或数据区域。

X 为要检验的值。

Sigma 为样本总体（已知）的标准偏差，如果省略，则使用样本标准偏差。

说明

  • 如果 array 为空，函数 ZTEST 返回错误值 #N/A。
  • 函数 ZTEST 的计算公式如下：

示例

如果您将示例复制到空白电子表格中，可能会更易于理解示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
3
6
7
8
6
5
4
2
1
9
公式 | 说明（结果）
=ZTEST(A2:A11,4) | 上面数据在数值 4 上的 z 检验双尾 P 值 (0.090574)


ASC

对于双字节字符集 (DBCS) 语言，将全角（双字节）英文字符更改为半角（单字节）字符。

语法

ASC(text)

Text 为文本或对包含要更改文本的单元格的引用。如果文本中不包含任何全角英文字母，则文本不会被更改。

示例

=ASC("ＥＸＣＥＬ") 等于“EXCEL”

=ASC(" Excel Excel Excel Excel ") 等于“ Excel Excel Excel Excel ”


CHAR

返回对应于数字代码的字符，函数 CHAR 可将其他类型计算机文件中的代码转换为字符。

语法

CHAR(number)

Number 为用于转换的字符代码，介于 1 到 255 之间。使用的是当前计算机字符集中的字符。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=CHAR(65) | 显示字符集中代码为 65 的字符 (A)
=CHAR(33) | 显示字符集中代码为 33 的字符 (!)


CLEAN

删除文本中不能打印的字符。对从其他应用程序中输入的字符串使用 CLEAN 函数，将删除其中含有的当前操作系统无法打印的字符。例如，可以删除通常出现在数据文件头部或尾部、无法打印的低级计算机代码。

语法

CLEAN(text)

Text 为要从中删除不能打印字符的任何工作表信息。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
=CHAR(7)&"text"&CHAR(7)
公式 | 说明（结果）
=CLEAN(A2) | 从上面字符串中删除不能打印的字符（即函数 CHAR(7) 返回的字符）。(text)


CODE

返回文本字符串中第一个字符的数字代码。返回的代码对应于计算机当前使用的字符集。

语法

CODE(text)

Text 为要返回其中第一个字符的数字代码的文本。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=CODE("A") | 显示 A 的数字代码 (65)
=CODE("!") | 显示 ! 的数字代码 (33)


CONCATENATE

将几个文本字符串连接为一个文本字符串。

语法

CONCATENATE (text1,text2,...)

Text1, text2, ... 为 1 到 30 个将要连接成单个文本项的文本项。这些文本项可以为文本字符串、数字或对单个单元格的引用。

说明

也可以用“&”运算符代替函数 CONCATENATE 实现文本项的连接。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
brook trout
species
32
公式 | 说明
=CONCATENATE("Stream population for ",A2," ",A3," is ",A4,"/mile") | 将上面数据连接成一个句子 (Stream population for brook trout species is 32/mile)


DOLLAR 或 RMB

使用货币格式将小数四舍五入到指定的位数并转换成文字。使用的格式为 ($#,##0.00_);($#,##0.00)。

语法

DOLLAR(number,decimals)

Number 为数字、包含数字的单元格引用或计算结果为数字的公式。

Decimals 为十进制数的小数位数。如果 Decimals 为负数，则参数 number 从小数点往左按相应位数取整。如果省略 Decimals，则假设其值为 2。

说明

用“货币”格式（在“命令和选项”对话框中的“格式”选项卡上）来设置包含数字的单元格的格式与用 DOLLAR 函数直接设置数字格式之间的主要区别是 DOLLAR 函数将其结果转换为文本。而用“货币”格式设置的数字仍然是数字。在公式中可继续使用用 DOLLARY 函数设置格式的数字，因为作为文本值输入的数字在计算时将被转换为数字。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
1234.567
-1234.567
-.123
99.888
公式 | 说明（结果）
=DOLLAR(A2, 2) | 以货币格式显示第一个数，保留到小数点右边两位 ($1,234.57)
=DOLLAR(A2, -2) | 以货币格式显示第一个数，保留到小数点左边两位 ($1,200)
=DOLLAR(A3, -2) | 以货币格式显示第二个数，保留到小数点左边两位 (($1,200))
=DOLLAR(A4, 4) | 以货币格式显示第三个数，保留到小数点右边四位 (($0.1230))
=DOLLAR(A5) | 以货币格式显示第四个数，保留到小数点右边两位 ($99.89)


EXACT

该函数测试两个文本字符串是否完全相同。如果他们完全相同，则返回 TRUE；否则，返回 FALSE。函数 EXACT 能区分大小写，但忽略格式上的差异。利用函数 EXACT 可以测试输入文档内的文字。

语法

EXACT(text1,text2)

Text1 待比较的第一个文本字符串。

Text2 待比较的第二个文本字符串。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
第一个字符串 | 第二个字符串
word | word
Word | word
w ord | word
公式 | 说明（结果）
=EXACT(A2,B2) | 检验第一行中的字符串是否匹配 (TRUE)
=EXACT(A3,B3) | 检验第二行中的字符串是否匹配 (FALSE)
=EXACT(A4,B4) | 检验第三行中的字符串是否匹配 (FALSE)


FIND

查找其他文本字符串 (within_text) 内的某个文本字符串 (find_text)，并从 within_text 的首字符开始返回 find_text 的起始位置编号。也可使用 SEARCH 查找其他文本字符串中的某个文本字符串，但是，FIND 与 SEARCH 不同，FIND 区分大小写并且不允许使用通配符。

语法

FIND(find_text,within_text,start_num)

Find_text 为要查找的文本。

Within_text 为包含要查找文本的文本。

Start_num 指定从其开始进行查找的字符。within_text 中的首字符是编号为 1 的字符。如果省略 start_num，则假设其为 1。

显示 提示

使用 start_num 可跳过指定数目的字符。例如，假定使用文本字符串“AYF0093.YoungMensApparel”，如果要查找文本字符串中说明部分的第一个“Y”的编号，则可将 start_num 设置为 8，这样就不会查找文本的序列号部分。FIND 将从第 8 个字符开始查找，而在下一个字符处即可找到 find_text，于是返回编号 9。FIND 总是从 within_text 的起始处返回字符编号，即如果 start_num 大于 1，也会对跳过的字符进行计数。

说明

  • 如果 find_text 是空文本 ("")，则 FIND 会匹配搜索字符串中的首字符（即：编号为 start_num 或 1 的字符）。
  • Find_text 中不能包含通配符。
  • 如果 within_text 中没有 find_text，则 FIND 返回错误值 #VALUE!。
  • 如果 start_num 不大于 0，则 FIND 返回错误值 #VALUE!。
  • 如果 start_num 大于 within_text 的长度，则 FIND 返回错误值 #VALUE!。

示例 1

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
Miriam McGovern
公式 | 说明（结果）
=FIND("M",A2) | 上面字符串中第一个“M”的位置 (1)
=FIND("m",A2) | 上面字符串中第一个“m”的位置 (6)
=FIND("M",A2,3) | 在上面字符串中从第三个字符开始查找第一个“M”的位置 (8)

示例 2

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
Ceramic Insulators #124-TD45-87
Copper Coils #12-671-6772
Variable Resistors #116010
公式 | 说明（结果）
=MID(A2,1,FIND(" #",A2,1)-1) | 在上面第一个字符串中提取从位置 1 到位置 # 的文本 (Ceramic Insulators)
=MID(A3,1,FIND(" #",A3,1)-1) | 在上面第二个字符串中提取从位置 1 到位置 # 的文本 (Copper Coils)
=MID(A4,1,FIND(" #",A4,1)-1) | 在上面第三个字符串中提取从位置 1 到位置 # 的文本 (Variable Resistors)


FIXED

将数字按指定的小数位数进行舍入取整，利用句号和逗号，以小数格式对该数进行格式设置，并以文本形式返回结果。

语法

FIXED(number,decimals,no_commas)

Number 为要进行四舍五入并转换成文本的数。

Decimals 为一数值，用以指定小数点右边的小数位数。

No_commas 为一逻辑值。如果为 TRUE，则在函数 FIXED 返回的文本中将不包含逗号。

说明

  • 在电子表格中，Numbers 参数的最大有效位数不能超过 15 位，但 decimals 却可达到 127 位。
  • 如果 Decimals 为负数，则参数 number 舍入到小数点左边。
  • 如果省略小数，则假设其值为 2。
  • 如果 no_commas 为 FALSE 或被省略，则通常返回的文本中包含逗号。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
1234.567
-1234.567
44.332
公式 | 说明（结果）
=FIXED(A2, 1) | 将第一个数四舍五入到小数点右边一位 (1,234.6)
=FIXED(A2, -1) | 将第一个数四舍五入到小数点左边一位 (1,230)
=FIXED(-1234.567, -1, TRUE) | 将第二个数四舍五入到小数点左边一位，不包含逗号 (-1230)
=FIXED(44.332) | 将第三个数四舍五入到小数点右边二位 (44.33)


LEFT

LEFT 基于所指定的字符数返回文本字符串中的第一个或前几个字符。

语法

LEFT(text,num_chars)

Text 为包含要提取字符的文本字符串。

Num_chars 指定要由 LEFT 所提取的字符数。

  • Num_chars 必须大于或等于 0。

  • 如果 num_chars 大于文本长度，则 LEFT 返回所有文本。

  • 如果省略 num_chars，则假定其为 1。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
Sale Price
Sweden
公式 | 说明（结果）
=LEFT(A2,4) | 第一个字符串中的前四个字符 (Sale)
=LEFT(A3) | 第二个字符串中的第一个字符 (S)


LEN

LEN 返回文本字符串中的字符数。

语法

LEN(text)

Text 为要查找其长度的文本。空格将作为字符进行计数。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
Phoenix, AZ
One
公式 | 说明（结果）
=LEN(A2) | 第一个字符串的长度 (11)
=LEN(A3) | 第二个字符串的长度 (0)
=LEN(A4) | 第三个字符串的长度，其中包括 5 个空格 (8)


LOWER

将一个文本字符串中的所有大写字母转换为小写字母。

语法

LOWER(text)

Text 为要转换为小写字母的文本字符串。函数 LOWER 不更改文本字符串中的非字母的字符。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
E. E. Cummings
Apt. 2B
公式 | 说明（结果）
=LOWER(A2) | 第一个字符串的小写字母格式 (e. e. cummings)
=LOWER(A3) | 最后一个字符串的小写字母格式 (apt. 2b)


MID

MID 返回文本字符串中从指定位置开始的特定数目的字符，该数目由用户指定。

语法

MID(text,start_num,num_chars)

Text 是包含要提取字符的文本字符串。

Start_num 是文本中要提取的第一个字符的位置。文本中第一个字符的 start_num 为 1，以此类推。

Num_chars 指定希望 MID 从文本中返回字符的个数。

说明

  • 如果 start_num 大于文本长度，则 MID 返回空文本 ("")。
  • 如果 start_num 小于文本长度，但 start_num 加上 num_chars 超过了文本的长度，则 MID 只返回至多直到文本末尾的字符。
  • 如果 start_num 小于 1，则 MID 返回错误值 #VALUE!。

  • 如果 num_chars 是负数，则 MID 返回错误值 #VALUE!。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
Fluid Flow
公式 | 说明（结果）
=MID(A2,1,5) | 上面字符串中从第一个字符开始的前五个字符 (Fluid)
=MID(A2,7,20) | 上面字符串中从第七个字符开始的后二十个字符 (Flow)
=MID(A2,20,5) | 因为起始位置大于字符串的长度，所以返回空白文本 ()


PROPER

将文本字符串的首字母及任何非字母字符之后的首字母转换成大写。将其余的字母转换成小写。

语法

PROPER(text)

Text 为需要进行转换的字符串数据，包括在一组双引号中的文本、返回文本值的公式或是对包含文本的单元格的引用。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
this is a TITLE
2-cent's worth
76BudGet
公式 | 说明（结果）
=PROPER(A2) | 将第一个字符串中的首字母转换为大写 (This Is A Title)
=PROPER(A3) | 将第二个字符串中的文本字符串中的首字母及任何非字母字符之后的首字母转换为大写 (2-Cent'S Worth)
=PROPER(A4) | 将第三个字符串中的非字母字符之后的首字母转换为大写 (76Budget)


REPLACE

REPLACE 使用其他文本字符串并基于所指定的字符数替换某个文本字符串中的部分文本。

语法

REPLACE(old_text,start_num,num_chars,new_text)

Old_text 为要替换其部分字符的文本。

Start_num 为要用 new_text 替换的 old_text 中字符的位置。

Num_chars 为希望 REPLACE 使用 new_text 替换 old_text 中字符的个数。

New_text 为要用于替换 old_text 中字符的文本。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
abcdefghijk
2009
123456
公式 | 说明（结果）
=REPLACE(A2,6,5,"*") | 用星号替换从第六个字符开始的五个字符 (abcde*k)
=REPLACE(A3,3,2,"10") | 用 10 替换 2009 的后两位数字 (2010)
=REPLACE(A4,1,3,"@") | 用 @ 替换前三个字符 (@456)


REPT

按照给定的次数重复显示文本。可以通过函数 REPT 来不断地重复显示某一文本字符串，对单元格进行填充。

语法

REPT(text,number_times)

Text 需要重复显示的文本。

Number_times 为指定文本重复次数的正数。

说明

  • 如果 number_times 为 0（零），REPT 则返回空文本 ("")。

  • 如果 number_times 不是整数，将被截尾取整。

  • REPT 函数的结果不得多于 32,767 个字符，否则，REPT 将返回 #VALUE!。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=REPT("*-", 3) | 将该字符串显示 3 次 (*-*-*-)
=REPT("-",10) | 将破折号显示 10 次 (----------)


RIGHT

RIGHT 基于所指定的字符数返回文本字符串中最后的字符。

语法

RIGHT(text,num_chars)

Text 是包含要提取字符的文本字符串。

Num_chars 指定希望 RIGHT 提取的字符数。

说明

  • Num_chars 必须大于或等于零。
  • 如果 num_chars 大于文本长度，则 RIGHT 返回所有文本。
  • 如果忽略 num_chars，则假定其为 1。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
Sale Price
Stock Number
公式 | 说明（结果）
=RIGHT(A2,5) | 第一个字符串的最后 5 个字符 (Price)
=RIGHT(A3) | 第二个字符串的最后一个字符 (r)


SEARCH

SEARCH 返回从 start_num 开始首次找到特定字符或文本字符串的位置上特定字符的编号。使用 SEARCH 可确定字符或文本字符串在其他文本字符串中的位置，这样就可使用 MID 或 REPLACE 函数更改文本。

语法

SEARCH(find_text,within_text,start_num)

Find_text 为要查找的文本。可在 find_text 中使用通配符字符，如问号 (?) 和星号 (*)。问号可匹配任意的单个字符，星号可匹配任意一串字符。如果要查找真正的问号或星号，请在该字符前键入波形符 (~)。

Within_text 是要在其中查找 find_text 的文本。

Start_num 是 within_text 中开始查找的字符的编号。

显示 提示

使用 start_num 可跳过指定数目的字符。例如，假定正在使用文本字符串“AYF0093.YoungMensApparel”，若要查找文本字符串中说明部分的第一个“Y”的编号，请将 start_num 设置为 8，这样就不会查找文本的序列号部分。SEARCH 将从第 8 个字符开始查找，而在下一个字符处即可找到 find_text，于是返回编号 9。SEARCH 总是从 within_text 的起始处返回字符编号，如果 start_num 大于 1，也会对跳过的字符进行计数。

说明

  • 查找文本时，函数 SEARCH 不区分大小写字母。
  • SEARCH 函数与 FIND 函数极为相似，只是 FIND 对大小写敏感。
  • 如果没有找到 find_text，则返回错误值 #VALUE!。
  • 如果省略 start_num，则假定其为 1。
  • 如果 start_num 不大于 0（零）或大于 within_text，则返回错误值 #VALUE!。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
Statements
Proft Margin
margin
公式 | 说明（结果）
=SEARCH("e",A2,6) | 上面的第一个字符串中，从第六个位置开始的第一个“e”的位置 (7)
=SEARCH(A4,A3) | “Profit Margin”中“margin”的位置 (8)
=REPLACE(A3,SEARCH(A4,A3),6,"Amount") | 用“Amount”替换“Margin”(Profit Amount)


SUBSTITUTE

在文本字符串中用 new_text 替代 old_text。如果需要在某一文本字符串中替换指定的文本，请使用函数 SUBSTITUTE；如果需要在某一文本字符串中替换指定位置处的任意文本，请使用函数 REPLACE。

语法

SUBSTITUTE(text,old_text,new_text,instance_num)

Text 为需要替换其中字符的文本，或对含有文本的单元格的引用。

Old_text 为需要替换的旧文本。

New_text 用于替换 old_text 的文本。

Instance_num 为一数值，用来指定以 new_text 替换第几次出现的 old_text。如果指定了 instance_num，则只有满足要求的 old_text 被替换；否则将用 new_text 替换 Text 中出现的所有 old_text。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
Sales Data
Quarter 1, 2008
Quarter 1, 2011
公式 | 说明（结果）
=SUBSTITUTE(A2, "Sales", "Cost") | 用 Cost 替换 Sales (Cost Data)
=SUBSTITUTE(A3, "1", "2", 1) | 用 2 替换第一个 1 (Quarter 2, 2008)
=SUBSTITUTE(A4, "1", "2", 3) | 用 2 替换第三个 1 (Quarter 1, 2012)


T

返回值引用的文本。

语法

T(value)

Value 为需要进行检验的值。

说明

  • 如果 value 是文本或引用了文本，则 T 返回 value。如果 value 没有引用文本，则 T 返回空文本 ("")。

  • 通常不需在公式中使用函数 T，因为通常可按需要转换数值的类型。该函数用于与其他电子表格程序兼容。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
Rainfall
19
TRUE
公式 | 说明（结果）
=T(A2) | 因为第一个 value 是一个文本，所以返回该文本 (Rainfall)
=T(A3) | 因为第二个 value 是一个数字，所以返回空文本 ()
=T(A4) | 因为第三个 value 是一个逻辑值，所以返回空文本 ()


TEXT

将数值转换为按指定数字格式表示的文本。

语法

TEXT(value,format_text)

Value 为数值、计算结果为数值的公式或对数值单元格的引用。

Format_text 为一种数字格式，该格式位于“命令和选项”对话框中“格式”选项卡上的“数字格式”框内的文本格式中。

说明

  • 用“命令和选项”对话框中的“格式”选项卡上的选项设置单元格的格式，只会改变单元格的格式而不会影响其中的数值。使用函数 TEXT 可以将数值转换为带格式的文本，而其结果将不再作为数字参与计算。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
销售人员 | 销售
Buchanan | 2800
Dodsworth | .4
公式 | 说明（结果）
=A2&" sold "&TEXT(B2, "Currency")&" worth of units." | 将上面的内容合并到一个短语中 (Buchanan sold $2,800.00 worth of units.)
=A3&" sold "&TEXT(B3,"Percent")&" of the total sales." | 将上面的内容合并到一个短语中 (Dodsworth sold 40.00% of the total sales.)


TRIM

除了单词之间的单个空格外，清除文本中所有的空格。在从其他应用程序中获取带有不规则空格的文本时，可以使用函数 TRIM。

语法

TRIM(text)

Text 为需要清除其中空格的文本。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=TRIM(" First Quarter Earnings ") | 清除公式内的文本中开头和结尾处的空格 (First Quarter Earnings)


UPPER

将文本转换成大写形式。

语法

UPPER(text)

Text 为需要转换成大写形式的文本。Text 可以为引用或文本字符串。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
数据
total
Yield
公式 | 说明（结果）
=UPPER(A2) | 第一个字符串的大写形式 (TOTAL)
=UPPER(A3) | 第二个字符串的大写形式 (YIELD)


VALUE

将代表数字的文本字符串转换成数字。

语法

VALUE(text)

Text 为带引号的文本，或对需要进行文本转换的单元格的引用。

说明

  • Text 可以是电子表格可识别的任意常数、日期或时间格式。如果 Text 不为这些格式，则函数 VALUE 返回错误值 #VALUE!。

  • 因为可在需要时自动将文本转换为数字，所以通常不需要在公式中使用函数 VALUE。该函数用于与其他电子表格程序兼容。

示例

如果您将示例复制到空白电子表格中，可能会更易于理解该示例。

显示 操作方法

  1. 创建空白电子表格。
  2. 请在“帮助”主题中选取示例。

    从“帮助”中选取示例。

  3. 按 Ctrl+C。
  4. 在电子表格中，选中单元格 A1，并按 Ctrl+V。
  5. 若要在查看返回结果的公式和单元格中的结果之间进行切换，请先选中该单元格，再按 F2，然后按 Enter；或者先单击电子表格工具栏上的“命令和选项”，再单击“公式”选项卡，然后搜索“活动单元格中的公式（活动单元格）”框。
公式 | 说明（结果）
=VALUE("$1,000") | 与该字符串相等的数字格式 (1000)
=VALUE("16:48:00")-VALUE("12:00:00") | 与 4 小时 48 分钟相等的序列号，由 16:48:00 减去 12:00:00 得到（0.2 或 4:48）


使用分析工具库函数加载项

电子表格组件还支持另一套能够提供与 Microsoft Excel 中的分析工具库加载项中的函数具有相同功能的函数。若要使用分析工具库函数，必须向包含电子表格组件的网页添加两个标记，才能与分析工具库加载项连接。

  1. 在文本编辑器或网页编辑器中打开包含电子表格组件的网页文件。
  2. 添加如下标记：
    <OBJECT id=atp
   classid="CLSID:3F98D457-551B-48C5-BDE8-7FDECCD5AFA5">
</OBJECT>

<SCRIPT language="VBScript">
   Spreadsheet1.AddIn(atp)
</SCRIPT>
    其中，Spreadsheet1 是网页上的电子表格组件的 OBJECT 标记的 ID 属性值。
  3. 将这些更改保存到网页中。

一旦您做了这些更改，就可以在电子表格组件的公式中使用分析工具库函数。例如，下面的公式使用 ISEVEN 函数检验数值是否为偶数，该公式将返回 FALSE：

=ISEVEN(7)

注释

  • 另外，您也可实例化分析工具库函数加载项，从脚本中添加公式，如下面的示例所示。
       Dim Spreadsheet1
   Dim atp

   ' Instantiate a Spreadsheet component object.
   Set Spreadsheet1 = CreateObject("OWC11.Spreadsheet")

   ' Instantiate the Analysis ToolPak function add-in.
   Set atp = CreateObject("OWCATP.OWCATP")

   ' Call the AddIn method to connect the add-in to the
   ' spreadsheet.
   Spreadsheet1.AddIn(atp)

   ' Add a formula to cell A1.
   Spreadsheet1.Range("A1").Formula = "=ISEVEN(7)"
  • 如果在脚本中使用 XMLData 或 XMLUrl 方法向电子表格中加载新值，将会断开与分析工具库函数加载项的连接。若要解决这个问题，请再次调用 AddIn 方法重新与加载项连接，然后调用 CalculateFull 方法重新计算电子表格中的公式。
       ' Assign new XmlData to the spreadsheet.
   Spreadsheet1.XmlData ="XMLDataString"

   ' Reconnect the function add-in
   Spreadsheet1.AddIn(atp)

   ' Recalculate all formulas in the spreadsheet.
   Spreadsheet1.CalculateFull

    其中，XMLDataString 是 XML 电子表格格式的 XML 数据串，例如，从 Microsoft Office Excel 2003 另存为 XML 电子表格 (.xml) 所产生的输出。


分析工具库函数

电子表格组件支持下表中所列的分析工具库函数。在可以使用这些函数之前，您必须先连接分析工具库函数加载项。有关详细信息，请参阅使用分析工具库函数加载项。有关下面所列函数的语法和使用的信息，请搜索 Microsoft Excel 中的“帮助”或搜索 Microsoft Office Online。

函数 | 说明
ACCRINT | 返回定期支付利息的抵押返回的累计利息。
ACCRINTM | 返回到期一次性付息有价证券的应计利息。
AMORDEGRC | 返回每个结算期间的折旧值。该函数主要为法国会计系统提供。如果某项资产是在该结算期的中期购入的，则按直线折旧法计算。该函数与函数 AMORLINC 相似，不同之处在于该函数中用于计算的折旧系数取决于资产的寿命。
AMORLINC | 返回每个结算期间的折旧值，该函数为法国会计系统提供。如果某项资产是在结算期间的中期购入的，则按线性折旧法计算。
BESSELI | 返回修正 Bessel 函数值，它与用纯虚数参数运算时的 Bessel 函数值相等。
BESSELJ | 返回 Bessel 函数值
BESSELK | 返回修正 Bessel 函数值，它与用纯虚数参数运算时的 Bessel 函数值相等。
BESSELY | 返回 Bessel 函数值，也称为 Weber 函数或 Neumann 函数。
BIN2DEC | 将二进制数转换为十进制数。
BIN2HEX | 将二进制数转换为十六进制数。
BIN2OCT | 将二进制数转换为八进制数。
COMPLEX | 将实系数及虚系数转换为 x+yi 或 x+yj 形式的复数。
CONVERT | 将数字从一个度量系统转换到另一个度量系统中。例如，函数 CONVERT 可以将一个以“英里”为单位的距离表转换成一个以“公里”为单位的距离表。
COUPDAYBS | 返回当前付息期内截止到成交日的天数。
COUPDAYS | 返回成交日所在的付息期的天数。
COUPDAYSNC | 返回从成交日到下一付息日之间的天数。
COUPNCD | 返回一个表示成交日之后的下一个付息日的数字。
COUPNUM | 返回在成交日和到期日之间的付息次数，向上舍入到最近的整数。
COUPPCD | 返回表示成交日之前的付息日的数字。
CUMIPMT | 返回一笔贷款在给定的 start-period 到 end-period 期间累计偿还的利息数额。
CUMPRINC | 返回一笔贷款在给定的 start-period 到 end-period 期间累计偿还的本金数额。
DEC2BIN | 将十进制数转换为二进制数。
DEC2HEX | 将十进制数转换为十六进制数。
DEC2OCT | 将十进制数转换为八进制数。
DELTA | 检验两个值是否相等。
DISC | 返回有价证券的贴现率。
DOLLARDE | 将按分数表示的价格转换为按小数表示的价格，使用函数 DOLLARDE 可以将分数表示的金额数字，如证券价格，转换为小数表示的数字。
DOLLARFR | 将按小数表示的价格转换为按分数表示的价格。使用函数 DOLLARFR 可以将小数表示的金额数字，如证券价格，转换为分数型数字。
DURATION | 返回假设面值 $100 的定期付息有价证券的 Macauley 期限。期限定义为一系列现金流现值的加权平均值，用于计量债券价格对于收益率变化的敏感程度。
EDATE | 返回表示某个数据的序列号，该数据代表指定日期 (start_date) 之前或之后的月份数。使用函数 EDATE 可以计算与发行日处于一月中同一天的到期日的日期。
EFFECT | 利用给定的名义年利率和每年的复利期数，计算有效的年利率。
EOMONTH | 返回 start-date 的指定月数之前或之后的月份的最后一天的序列号。用函数 EOMONTH 可计算正好在特定月份中最后一天内的到期日或发行日。
ERF | 返回误差函数在上下限之间的积分。
ERFC | 返回从 x 到 ∞（无穷）积分的 ERF 函数的余误差函数。
FACTDOUBLE | 返回数字的双倍阶乘。
FVSCHEDULE | 基于一系列复利返回本金的未来值。函数 FVSCHDULE 用于计算某项投资在变动或可调利率下的未来值。
GCD | 返回两个或多个整数的最大公约数，最大公约数是能分别将 Number1 和 Number2 除尽的最大整数。
GESTEP | 如果 Number 大于等于 step，返回 1，否则返回 0。使用该函数可筛选数据。例如，通过计算多个函数 GESTEP 的返回值，可以检测出数据集中超过某个临界值的数据个数。
HEX2BIN | 将十六进制数转换为二进制数。
HEX2DEC | 将十六进制数转换为十进制数。
HEX2OCT | 将十六进制数转换为八进制数。
IMABS | 返回以 x+yi 或 x+yj 文本格式表示的复数的绝对值（模）。
IMAGINARY | 返回以 x+yi 或 x+yj 文本格式表示的复数的虚系数。
IMARGUMENT | 返回参数 (theta)，即以弧度表示的角 Theta 。
IMCONJUGATE | 返回以 x+yi 或 x+yj 文本格式表示的复数的共轭复数。
IMCOS | 返回以 x+yi 或 x+yj 文本格式表示的复数的余弦。
IMDIV | 返回以 x+yi 或 x+yj 文本格式表示的两个复数的商。
IMEXP | 返回以 x+yi 或 x+yj 文本格式表示的复数的指数。
IMLN | 返回以 x+yi 或 x+yj 文本格式表示的复数的自然对数。
IMLOG10 | 返回以 x + yi 或 x + yj 文本格式表示的复数的常用对数（以 10 为底数）。
IMLOG2 | 返回以 x+yi 或 x+yj 文本格式表示的复数的以 2 为底数的对数。
IMPOWER | 返回以 x+yi 或 x+yj 文本格式表示的复数的 n 次幂。
IMPRODUCT | 返回以 x+yi 或 x+yj 文本格式表示的 2 至 29 个复数的乘积。
IMREAL | 返回以 x+yi 或 x+yj 文本格式表示的复数的实系数。
IMSIN | 返回以 x+yi 或 x+yj 文本格式表示的复数的正弦值。
IMSQRT | 返回以 x+yi 或 x+yj 文本格式表示的复数的平方根。
IMSUB | 返回以 x+yi 或 x+yj 文本格式表示的两个复数的差。
IMSUM | 返回以 x+yi 或 x+yj 文本格式表示的两个或多个复数的和。
INTRATE | 返回一次性付息证券的利率。
ISEVEN | 如果数字为偶数则返回 TRUE，如果为奇数则返回 FALSE。
ISODD | 如果数字为奇数则返回 TRUE，如果为偶数则返回 FALSE。
LCM | 返回整数的最小公倍数。最小公倍数是所有整数参数 number1、number2 等等的最小正整数倍数。用函数 LCM 可以将分母不同的分数相加。
MDURATION | 返回假设面值 $100 的有价证券的 Macauley 修正期限。
MROUND | 返回参数按指定基数舍入后的数值。
MULTINOMIAL | 返回参数和的阶乘与各参数阶乘乘积的比值。
NETWORKDAYS | 返回参数 start-data 和 end-data 之间的全部工作日数值。工作日不包括周末和节假日。可以使用函数 NETWORKDAYS，根据某一特定时期内雇员的工作天数，计算其应计的报酬。
NOMINAL | 基于给定的实际利率和年复利期数，返回名义年利率。
OCT2BIN | 将八进制数转换为二进制数。
OCT2DEC | 将八进制数转换为十进制数。
OCT2HEX | 将八进制数转换为十六进制数。
ODDFPRICE | 返回首期付息日不固定（长期或短期）的面值 $100 的有价证券价格。
ODDFYIELD | 返回首期付息日不固定的有价证券（长期或短期）的收益率。
ODDLPRICE | 返回末期付息日不固定的面值 $100 的有价证券（长期或短期）的价格。
ODDLYIELD | 返回末期付息日不固定的有价证券（长期或短期）的收益率。
PRICE | 返回定期付息的面值 $100 的有价证券的价格。
PRICEDISC | 返回折价发行的面值 $100 的有价证券的价格。
PRICEMAT | 返回到期付息的面值 $100 的有价证券的价格。
QUOTIENT | 返回商的整数部分，该函数可用于舍掉商的小数部分。
RANDBETWEEN | 返回位于两个指定数之间的一个随机数。每次计算工作表时都将返回一个新的数值。
RECEIVED | 返回一次性付息的有价证券到期收回的金额。
SERIESSUM | 返回幂级数之和。
SQRTPI | 返回某数与 pi 的乘积的平方根。
TBILLEQ | 返回国库券的等效收益率。
TBILLPRICE | 返回面值 $100 的国库券的价格。
TBILLYIELD | 返回国库券的收益率。
WEEKNUM | 返回一个数字，该数字代表一年中的第几周。
WORKDAY | 返回某日期（起始日期）之前或之后相隔指定工作日的某一日期的日期值。工作日不包括周末和节假日。在计算发票到期日、预期交货时间或工作天数时，可以使用函数 WORKDAY 来扣除周末或节假日。
XIRR | 返回一组现金流的内部收益率，这些现金流不一定定期发生。若要计算一组定期现金流的内部收益率，请使用函数 IRR。
XNPV | 返回一组现金流的净现值，这些现金流不一定定期发生。若要计算一组定期现金流的净现值，请使用函数 NPV。
YEARFRAC | 返回 start_date 和 end_date 之间的天数占全年天数的百分比。使用 YEARFRAC 工作表函数可判别某一特定条件下全年效益或债务的比例。
YIELD | 返回定期付息有价证券的收益率，函数 YIELD 用于计算债券收益率。
YIELDDISC | 返回折价发行的有价证券的年收益率。
YIELDMAT | 返回到期付息的有价证券的年收益率。