关于图表

图表具有较好的视觉效果，可方便用户查看数据的差异、图案和趋势。通过使用 Microsoft Office 图表组件，用户可以创建动态的交互式图表，而这种图表可以用浏览器在网 站上进行查看。如果图表数据发生更改，并且包含图表的网页被刷新，则图表也会自动更新，以反映最新的数据。

图表可以使用输入到数据表中的数据，以及现有的来自数据库表和查询的数据，或是来自使用 Microsoft Office Web Components 创建的电子表格和数据透视表列表。如果数据是基于数据透视表列表或数据库表或查询，则可以添加字段以组织数据，然后重新排列字段，以及对数据进行排序和筛选。

显示 开始之前

确定用户是否可以对图表进行交互处理 在开始设计图表之前，应先对设计程序有所考虑，并且用户是否有所要求的浏览器以及是否可访问 Microsoft Office Web Components 以便对图表进行交互处理。

若要处理图表，用户必须安装 Office Web 组件。可以在安装 Microsoft Office 2003 时安装上述组件，或者如果公司有 Office 2003 站点许可证，则可从企业的 Intranet 中下载 Office Web 组件。用户还必须有 Microsoft Internet Explorer 5.01 SP2 或更高版本才可对图表进行交互处理，除非创建的图表是用于 Visual Basic for Applications (VBA) 项目。

其系统不满足以上要求的用户可以查看图表，但不能交互式地处理图表。

选择设计程序 设计程序是用于创建或修改图表的程序。不同设计程序提供了不同的功能。例如，可以使用 Microsoft Excel 的扩展图表功能来创建图表，并将其保存或发布为静态图表（图片）或交互式图表。可以使用 Microsoft FrontPage 中的工具创建包含图表的动态网页，然后将此网页发布到网站上。也可以使用 Microsoft Access 以利用其自动数据库连接功能。用户可以在 FrontPage 或 Access 中打开包含图表的网页，并对图表进行修改。不能使用 Excel 打开和修改发布到网页上或作为网页发布的图表。

显示 准备需在图表中使用的源数据

可以在图表的数据表中输入图表的数据，也可以使用数据库中的数据、某个 Microsoft Office 电子表格组件的数据、或是某个 Microsoft Office 数据透视表组件的数据。

如果希望通过电子表格或数据透视表列表中的数据绘制图表，则必须首先打开含有这些组件之一的网页，或必须通过要在网页上使用的数据创建一个新的控件。

如果希望通过数据库查询中的数据绘制图表，则应首先创建查询。例如，如果某张表中含有五年内的每年销售数据，而您只需要将其中某一年的销售数据绘制成图表，则可以运行查询以返回所需年份的销售数据，然后将查询结果作为图表的源数据。

显示 可用于创建图表的设计程序

可以用多种程序创建和修改 Web 图表。可以在一个程序中创建图表，然后使用其他程序修改图表或修改该图表所在的网页。至于选择何种设计程序则取决于多方面的因素：设计的工作量、网页上要进行的管理工作量、要使用的源数据类型以及对不同设计程序的熟悉程度等。

显示 Microsoft Excel

如果源数据来自工作表，或者希望尝试使用不同的图表类型，并调整可用于图表的源数据，则 Excel 正是这样一种优秀的设计环境。当通过 Excel 发布图表时，所指定的源数据会自动附加到图表中，并作为交互式电子表格或数据透视表列表发布到相同的页面上。

在通过 Excel 发布图表后，就可以在 Excel 中修改原始图表（如果是保存为 .xls 文件）并重新发布，但并不能在 Excel 中直接修改已发布的图表。但是，可以在 FrontPage 或是在 Microsoft Access 数据访问页“设计”视图中打开含有所发布图表的网页，并修改图表、网页或同时修改网页和图表。

Microsoft Excel 可在 Microsoft Office 2003 中获得。

显示 Microsoft FrontPage

可以在 FrontPage 中创建和修改 Web 图表。还可以使用 FrontPage 的扩展网页编辑和管理功能向网页中添加其他控件、图形、主题以及其他内容，然后将页面变成网站的一部分。

Microsoft FrontPage 可在 Microsoft Office 2003 中获得。

显示 Microsoft Access

在创建网页方面，Access 提供了用于操作并显示数据库中数据的特殊功能。可以使用 Access 建立 Access 数据库与图表所需源数据之间的连接，然后使用数据访问页“设计”视图中的自动功能向图表中附加数据。例如，可以使用字段列表将表放置到网页上，然后在使用了该表中数据的网页上创建图表。还可以在图表与其他在网页上显示和操作数据库中数据的控件之间建立连接。在为使用 Internet Explorer 5.01 SP2 或更高版本的用户创建图表时，可使用 Access 中的数据访问页“设计”视图。

Microsoft Access 可在 Microsoft Office 2003 中获得。

显示 Microsoft Visual Basic

如果您是程序员，并且需要的编程环境比“Microsoft 脚本编辑器”、Excel 或 Access 所能提供的更全面，则可以使用 Visual Basic 编程语言来创建图表。有关 Web 图表编程的详细信息，请参阅关于获取图表的帮助。

显示 创建图表

在准备好要使用的图表数据后，请按设计程序中的指导将图表组件放置到网页上。

当将图表放置到网页上时，将显示图表的“命令和选项”对话框。在此对话框中，可以选择要使用的图表类型和数据，并且根据正使用的数据类型选择数据的显示方式。

显示 自定义图表

在创建图表之后，还可以使用“命令和选项”对话框或图表工具栏来更改图表类型、划分同一个组件空间中多个图表中的数据、更改格式设置选项、添加标签和标题以及更改文字的字体和字形等。

“命令和选项”对话框中包含可以设置图表外观格式的命令按钮和选项。例如，可以更改数据标志的颜色、图例的位置或坐标轴上数值的间距。对话框中的选项分布在各选项卡中。可用的选项卡将根据当前选定的图表内容的变化而变化。例如，如果选择的是图表的图例部分，则只有与图例相关的选项卡才可用，例如，“常规”选项卡、“格式”选项卡和“边框/填充”选项卡。如果选择的是坐标轴，则将显示“线条/标志”选项卡、“轴”选项卡和“刻度”选项卡。

提供自定义说明 如果要添加关于图表的说明文本或其他信息，只需在网页上键入即可。

脚本 可以使用脚本访问和控制图表组件的特性和功能。如果熟悉使用 Visual Basic Scripting Edition (VBScript) 或 JavaScript 语言编写网页脚本，则可以向图表中添加脚本以更改图表的外观，或是向用户提供信息以响应用户在浏览器中输入的内容。

设计程序可能提供了编写脚本的工具。例如，Microsoft Office 程序就提供了“Microsoft 脚本编辑器”。有关编写脚本的信息，请参阅设计程序中的“帮助”。有关通过脚本访问图表特性和功能的详细信息，请参阅图表组件的编程“帮助”。

显示 测试和发布

在浏览器中检查图表 在让用户使用图表前，应该先在浏览器中进行测试。建议使用 Microsoft Internet Explorer 5.01 SP2 或更高版本来处理图表。若要与图表进行交互，用户还应有 Microsoft Office 2003 许可。使用 Internet Explorer 5.01 SP2 或更高版本并有 Office 2003 许可协议的用户也可以查看图表，并与图表进行交互。如果用户使用版本各异的浏览器，则需要在每种版本中对图表进行测试以确保图表能正确显示，并能正确更新信息。

发布网页 如果对结果满意，就可以让用户使用网页了。请参阅设计程序中的“帮助”以了解有关发布网页的信息，也可以向网站管理员或网络管理员咨询。


支持图表的浏览器

若要在 Microsoft Internet Explorer 5.01 SP2 及更高版本中使用交互式图表，用户必须安装 Microsoft Office Web Components，并拥有适当的 Office 2003 许可。没有 Office XP 许可的用户可以安装组件，但不能与之交互。请进一步了解 Office 2003 安装和授权组件。

如果安装了 Office Web 组件并且具有 Office 2003 许可，则可支持的浏览器如下：

显示 Microsoft Internet Explorer 5.01 SP2 和更高版本

用户可以访问在浏览器中可用的所有图表功能。当用户离开图表，随后又在同一个浏览器会话中返回到该图表时，用户所做的更改（如格式和版式更改）将保留。

显示 其他浏览器

用户不能在 Microsoft Internet Explorer 的早期版本及其他浏览器中查看图表。在这些浏览器中，图表在网页上只显示为带外边框的框，或者根本不显示。


关于 Microsoft Office Web Components

Microsoft Office Web Components 是与 Microsoft Office 2003 一起安装的一组 ActiveX 控件。如果在计算机上安装了 Office Web 组件，则可在 Internet Explorer 5.01 SP2 或更高版本中对电子表格、数据透视表列表和图表进行交互访问。如果要在 Microsoft Access 的数据访问页中使用这些组件，则需要安装 Internet Explorer 5.01 SP2 或更高版本。

如果计算机上未安装 Office Web 组件，但您有允许 Intranet 发布的 Office 2003 站点许可证，则可对组件进行配置，以提示用户从公司的 Intranet 下载 Office Web 组件。这样，您网站上的用户无须在计算机上安装 Office 2003 软件就可使用数据访问页。

有关如何配置 Office Web 组件的信息，请参阅《Microsoft Office 2003 资源工具包》。


关于安装、许可和发布 Office Web 组件

如果您设计了一个使用 Microsoft Office Web Components 的网页，则任何具有 Office 2003 许可的用户都可在浏览器中按您所提供的交互性级别与组件进行交互。即，具有适当许可的用户可对电子表格中的数据进行更改，例如，更改格式、拖动图表或数据透视表列表中的字段等等，只要在设计时这些选项不受保护。具有 Office 2003 许可的用户还可在设计环境中创建、设计并修改组件，例如，Microsoft FrontPage 或 Microsoft Access。

没有 Office 2003 许可的用户也可查看组件和其中的数据，还可打印组件的视图，但是不能与组件进行交互，也不能在设计环境下对其进行操作。这意味着如果您发布了一个使用组件的网页，则具有 Office 2003 许可的用户将可访问所提供的所有功能，但是，没有许可的用户则只能查看您所提供的数据和信息。

显示 安装 Office Web 组件

Microsoft Office Web Components 是与 Microsoft Office 2003 和 Microsoft Office 应用程序一同安装的，您也可从网页设计者所提供的安装位置分别进行安装。

如果发布了一个使用组件的网页，则还没有安装组件的用户将被提示安装组件（假定网页设计者配置了组件来进行这样的提示）。网页设计者还必须为组件提供安装路径以及定位于组件安装页上的指针。有关详细信息，请参阅《Microsoft Office 2003 资源工具包》。

在安装了 Office Web 组件后，有 Office 2003 许可的用户就可与组件进行交互并进行所需的更改。而没有许可的用户则只能查看和打印组件及其中的数据，但不能与其进行交互或进行更改。

显示 有关许可和功能的详细信息

在计算机上安装了 Office 2003 这类用户具有组件的全部功能和交互能力，包括运行时和设计时的功能。

在计算机上安装了 Office 2003 的应用程序 这类用户只能在应用程序（而不能在浏览器或其他应用程序中）的设计模式下与组件进行交互。

Office 2003 站点许可证（用户并没有在计算机上安装 Office 2003，但是用户的单位有企业或站点许可证协议） 这类用户具有组件的全部功能和交互性，包括运行时和设计时的功能。但是，网页设计者必须提供可下载组件的地址，并在与一个或多个网页相关的许可包文件 (.lpk) 中引用站点许可证。还可使用“许可包创建工具”来创建用于多个网页的相应许可文件。有关详细信息，请参阅“MSDN Online”。

没有 Office 2003、Office 2003 的应用程序或站点许可证 这类用户可在“只可查看”模式下查看和打印组件，但不能与组件进行交互或使用设计功能。


关于 Office Web 组件的“只可查看”模式

如果您的计算机未安装 Microsoft Office 2003 软件许可，或不能通过 Microsoft Office 2003 的应用程序获取该许可，则只能在网页上查看 Microsoft Office Web Components（电子表格组件、图表组件或数据透视表组件），而不能与其进行交互。

若要与正在查看的组件进行交互并使用其完整的功能，则必须安装 Microsoft Office 2003 或获取 Office 2003 许可。如果您是在公司或组织中，请向网络管理员咨询以获取帮助。

在“只可查看”模式中，可以执行下列操作：

  • 查看数据。
  • 打印。
  • 选取和滚动数据。
  • 使用超链接。
  • 调整组件大小。
  • 在“电子表格组件”中选取工作表。
  • 展开或折叠数据透视表列表中的成员。
  • 刷新数据透视表列表中的数据。
  • 可使用“关于”、“帮助”和“刷新”命令。但有关交互（例如设置单元格格式、拖动字段、排序、筛选等）的帮助主题不可用。

在“只可查看”模式中，只可使用“关于”、“帮助”、和“刷新”命令，其他命令都不可用。


关于获取图表的帮助

本主题中的部分内容可能不适用于某些语言。

显示 在其他设计程序中获取帮助

在设计程序中工作时，可按以下方法获取设计图表的帮助：

  • 设计程序的“帮助” 有关设计程序中可用于处理图表的命令与功能的详细信息，请参阅设计程序的“帮助”。例如，在 Microsoft Access 中，可单击“Office 助手”或单击“Microsoft Office Access 帮助” 按钮图像 。

    Microsoft Excel 提供了有关保存 Excel 数据以便用于网页的一般性帮助，也提供了有关保存图表以便用于网页的特定信息。若要在 Excel 中访问该“帮助”，请单击“Office 助手”或单击“Microsoft Excel 帮助” 按钮图像 。

  • 图表设计时的“帮助” 如果在其他设计程序中可以访问“命令和选项”对话框，则可以访问正在查看的“帮助”主题。在用设计程序创建或激活的图表中，请打开“命令和选项”对话框，单击“常规”选项卡，再单击“帮助” 按钮图像 ，或用鼠标右键单击图表，然后单击快捷菜单上的“帮助”。

显示 获取有关编写脚本和程序来使用 Web 图表的帮助

可以使用脚本和程序使图表具有自动化功能，或者也可以在 Web 浏览器以外的其他运行时程序（例如，在 Microsoft Visual Basic 编程环境中开发的程序）中包含图表。

编写脚本 Microsoft Office 程序提供了“Microsoft 脚本编辑器”来帮助编写脚本。例如，可以在 Microsoft Access 数据访问页“设计”视图中使用“脚本编辑器”来自定义图表。有关运行“脚本编辑器”的详细信息，请参阅 Office 设计程序的“帮助”。在“脚本编辑器”中，可以显示有关使用其功能和编写脚本的附加“帮助”。

对象模型“帮助” 如果要获取有关开发程序或脚本来处理图表列表的“帮助”，可显示与图表相关的对象模型、属性和方法的有关信息。每次安装 Microsoft Office Web Components（“图表组件”就是其中之一）时，都会安装对象模型“帮助”。根据所使用的设计程序的不同，用户可以按下列方法访问该“帮助”：

  • Microsoft Visual Basic 中的“帮助” 在 Visual Basic 或 Visual Basic for Applications (VBA) 中，可以创建对 Microsoft Office Web Components 库的引用，然后，就可以通过对象浏览器或通过选择关键字并按 F1 来访问“帮助”。有关创建引用和使用对象模型“帮助”的详细信息，请参阅 VBA 中的“帮助”。
  • 其他环境中的“帮助” 如果使用的是其他开发环境，则请找到并双击“帮助”文件“Owcvba11.chm”。

显示 在浏览器中获取并提供帮助

浏览器中可用的“帮助” 对于具有 Microsoft Internet Explorer 5.01 SP2 或更高版本以及 Microsoft Office Web Components 的用户，与图表相关的一般性“帮助”将自动可用。而此运行时“帮助”与浏览器“帮助”菜单中的“帮助”不同。

图表中可用的“帮助” 运行时图表的“帮助”主题为所有用户提供了有关在浏览器中使用图表的一般信息。例如，如何使用工具栏和上下文菜单，以及当图表是基于数据透视表列表或数据库的表或查询时，如何处理字段列表和字段。

运行时图表的“帮助”并不包括有关使用“命令和选项”对话框的信息，因此它不同于此处所述的图表设计的“帮助”主题。根据用户的技能和他们要完成的工作类型，您可能需要通过在网页上为图表提供自定义说明，或提供指向其他网页（带有相关说明）的超链接来补充运行时“帮助”。

其他 Office Web 组件，如“数据透视表组件”和“电子表格组件”，可在浏览器中使用其各自的“帮助”。

若要了解浏览器提供了哪些“帮助”，请先在网页上创建图表，并在 Internet Explorer 中打开此网页，用鼠标右键单击图表，再单击快捷菜单上的“帮助” 按钮图像 。在“帮助”窗口中，可查看目录并搜索主题文本。在浏览器中不能使用“Office 助手”回答问题。


键盘快捷键

有关使用键盘激活或停用图表的详细信息，请参阅设计程序的“帮助”。

显示 用于选择图表项的快捷键

向右键
选择图表中的下一项
向左键
选择图表中的上一项
向下键
选择下一个项目组
向上键
选择上一个项目组

显示 用于命令和选项的快捷键

Alt+Enter
显示“命令和选项”对话框
Alt+F4
关闭“命令和选项”对话框
Tab
激活“命令和选项”对话框后，在活动选项卡上选择下一项
向右键
激活“命令和选项”对话框中的选项卡后，选择下一个选项卡
向左键
激活“命令和选项”对话框中的选项卡后，选择上一个选项卡
向下键
选中包含列表或调色板的按钮后，显示列表或调色板
Shift+F10
显示快捷菜单
下划线字母
执行快捷菜单上的命令。
Esc
关闭快捷菜单，不执行任何命令
Ctrl+Z
撤销图表上的一项操作
Delete
删除当前选定的项

显示 在数据表中使用的快捷键

Enter
输入数据，并向下移动一个单元格
Tab
输入数据，并向右移动一个单元格
箭头键
向左、右、上、下移动一个单元格

显示 用于字段的快捷键

Alt+向下键
打开当前选定的字段的列表
Tab
在字段下拉列表中最近选择的项、“确定”按钮和“取消”按钮之间切换
箭头键
移动到字段下拉列表中的下一项
空格键
选中或清除字段下拉列表中当前项对应的复选框
Enter
关闭字段下拉列表，并应用所做的更改
Esc
关闭字段下拉列表，但不应用所做的更改

显示 用于字段列表的快捷键

Ctrl+L
显示字段列表，或者，如果已经显示了字段列表，则激活字段列表
箭头键
移动到字段列表的下一项
Shift+向上键
移动到上一项并将其包括在选定区域中
Shift+向下键
移动到下一项并将其包括在选定区域中
Ctrl+向上键
移动到上一项，但不将其包括在选定区域中
Ctrl+向下键
移动到下一项，但并不将其包括在选定区域中
Ctrl+空格键
如果选定区域中的项有焦点，则将其从选定区域中删除，反之亦然
加号（数字键盘）
展开字段列表中的当前项以显示其内容。或者，展开“汇总”以显示可用的汇总字段。
减号（数字键盘）
折叠字段列表中的当前项以隐藏其内容。或者，折叠“汇总”以隐藏可用的汇总字段。
Tab
在字段列表中最近选定的项、“添加到”按钮及其旁边的列表之间切换
Alt+向下键
打开字段列表中“添加到”按钮旁的下拉列表。使用箭头键可移动到列表中的下一项，然后按 Enter 可选定该项。
Enter
将字段列表中突出显示的字段添加到“添加到”列表中显示的数据透视表列表内的区域中
Alt+F4
关闭字段列表

显示 在“帮助”中使用的快捷键

显示 在“帮助”窗口中使用的快捷键

F6
在导航窗格和主题窗格之间切换
Alt+O
显示“选项”菜单以访问任何“帮助”工具栏命令
Alt+空格键
显示程序的“控制”菜单
Alt+F4
关闭“帮助”窗口

显示 在导航窗格中使用的快捷键

Ctrl+Tab
切换到另外一个选项卡
Enter
打开或关闭选定的书，或打开选定的“帮助”主题
向下键
选择下一本书或下一个“帮助”主题
向上键
选择上一本书或上一个“帮助”主题
Shift+F10
显示快捷菜单

显示 在主题窗格中使用的快捷键

Alt+向右键
前往以前查看的“帮助”主题
Alt+向左键
返回以前查看的“帮助”主题
Tab
选取下一个隐藏的文本或超链接，或主题顶部的“全部显示”或“全部隐藏”
Shift+Tab
选取以前隐藏的文本或超链接
Enter
执行所选的“全部显示”、“全部隐藏”、隐藏文本或超链接等操作
向上键或向下键
向“帮助”主题的开始或结束方向滚动
Page Up 或 Page Down
以较大的步长向“帮助”主题的开始或结束方向滚动
Home 或 End
前往“帮助”主题的开始或结束部分
Ctrl+P
打印当前“帮助”主题
Ctrl+A
选定整个“帮助”主题
Ctrl+C
将选定内容复制到剪贴板
Shift+F10
显示快捷菜单


打印图表

若要打印一个图表，必须打印整个网页。

  • 若要从设计窗口打印图表，请参阅设计程序中有关打印网页的特定指令的“帮助”。

  • 若要从浏览器中打印图表，请单击 Microsoft Internet Explorer 中“文件”菜单上的“打印”。

注释 如果图表比打印页面宽或长，则将不打印超出页面的部分。


关于图表工具、命令和字段列表

显示 工具栏

图表顶部的工具栏提供了一套处理图表显示和图表数据的命令。例如，可以用工具栏更改图表类型、添加或删除图例、更改系列或分类数据以反映行或列中的数据，等等。如果图表基于数据透视表列表、数据库表或查询中的数据，并且您希望在图表中对数据进行排序、筛选或更改数据的显示，则该工具栏是非常有用的。

在设计图表时可使用工具栏，用户也可以用此工具栏处理运行时的图表（例如，图表在浏览器中显示时）。若要查看每个按钮的命令名称，请将鼠标指针停留在该按钮上。

显示 “命令和选项”对话框

命令和选项”对话框包括以下命令：更改格式选项、选择部分图表、对系列进行分组或取消分组（以便组合图表），等等。对话框还包括某些工具栏或快捷菜单上没有的命令。若要显示对话框，请单击工具栏上的“命令和选项” 按钮图像 或用鼠标右键单击图表，然后单击快捷菜单上的“命令和选项”。

“命令和选项”对话框中的命令和属性分布于几个选项卡上，如“常规”选项卡（可在该选项卡上选取图表的各部分、添加或删除图例或图表标题、更改某些图表格式选项）。显示的其他选项卡取决于选择了图表的哪部分。例如，如果选择数据系列，则显示与数据系列相关的选项卡，如“边框/填充”、“类型”和“条件格式”。如果选择坐标轴，则显示“格式”、“线条/标志”、“轴”和“刻度”选项卡。如果无法找到所需的命令，请确保选择了与命令相对应的正确图表项。

显示 字段列表

如果图表基于数据库数据或数据透视表列表，则可从图表工具栏上找到字段列表。使用字段列表可查看源数据提供的字段列表，还可以将字段添加到分类、系列、筛选和图表的数据区域中。在字段列表中，没有加粗的字段是可用的，但还未在图表中显示。加粗的字段是已显示在图表上的字段。可以滚动并单击展开指示器（ 加号框 或 减号框 框）以显示或隐藏其他字段。

显示 快捷菜单

用鼠标右键单击活动图表时，快捷菜单将显示用于显示或隐藏工具栏、“命令和选项”对话框、字段列表和拖放区域（当图表基于数据透视表列表或数据库数据时）的命令。该菜单还包括用于更改图表源数据的“数据”命令。

显示 运行时对工具栏、字段列表、快捷菜单和“命令和选项”对话框的访问。

默认情况下，在运行过程中“命令和选项”对话框不可用，“命令和选项”对话框的“帮助”也不可用。如果要在运行过程中启用“命令和选项”对话框，那么应提供在网页上使用该对话框的指令。

运行过程中工具栏在下列情况下可用：用户特别选择了工具栏，或使工具栏在图表上默认显示。如果图表基于数据库数据或数据透视表列表，并且在“命令和选项”对话框上启用该图表，则字段列表可用。

快捷菜单可用，但是未在运行过程中应用的命令不可用。


显示或隐藏图表工具栏

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 用鼠标右键单击图表，再单击快捷菜单上的“工具栏”。


显示或隐藏“命令和选项”对话框

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 请执行下列操作之一：
    • 若要显示“命令和选项”对话框，请用鼠标右键单击图表，然后单击快捷菜单上的“命令和选项”。
    • 若要隐藏“命令和选项”对话框，请单击该对话框右上角的“关闭” 按钮图像 。


使用“命令和选项”对话框

如果选择图表的其他部分时，“命令和选项”对话框仍然显示，则对话框中可用的选项卡及其内容将随当前选定内容的变化而变化。

  1. 用鼠标右键单击图表，然后单击快捷菜单上的“命令和选项”，将显示“命令和选项”对话框。
  2. 若要选中图表中要修改的部分，请单击一次以选定某个组（例如，数据系列），然后再单击一次以选定该组中的单个项（例如数据系列内的数据标志）。也可以在“选择”列表中选择要修改的部分，该“选择”列表位于“命令和选项”对话框的“常规”选项卡上。
  3. 单击“命令和选项”对话框中包含了要修改的选项的选项卡，然后进行所需的更改。
  4. 如果没有找到含有要修改的选项的选项卡，则可能需要选择图表中的其他项。


显示或隐藏拖放区域

拖放区域被隐藏之后，不能在图表中添加或拖动字段。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 用鼠标右键单击图表，再单击快捷菜单上的“拖放区域”。

注释 如果图表不是基于数据库数据或数据透视表列表，则“拖放区域”菜单项不可用。


关于图表的源数据

在创建 Web 图表时，可以已有的数据或创建时提供的数据为基础。用已有的数据创建 Web 图表时，源数据必须可用，且大多数情况下，源数据所在的网页必须与要放置图表的网页相同。

图表可使用下列源中的数据。

显示 图表数据表

如果要在创建图表时输入数据，请使用图表数据表。数据表由行和列组成，可以在其中进行复制和粘贴。当向数据表输入数据时，图表将自动更新以反映输入的数据。数据表中的每个系列行或列都用不同的颜色突出显示，每种颜色对应于图表中相关数据标志的颜色，这样便于区分不同的系列。

显示 电子表格组件

电子表格组件是可以用来在网页上显示电子表格中计算结果的 Microsoft Office Web Component。用户可以在 Web 浏览器中使用和更改电子表格中的数据。当电子表格中的数据发生更改时，使用此数据的图表就会进行更新。电子表格和图表必须位于相同的网页上。

可以用任何支持 Microsoft Office Web Components 的设计程序来创建电子表格，例如 Microsoft Access 或 Microsoft FrontPage。如果 Microsoft Excel 工作表已包含数据，则可以将数据发布为交互式的电子表格。还可以在 Excel 中创建使用工作表数据的图表，在将此图表发布为交互式图表时，同时也会发布交互式的电子表格。有关发布电子表格控件的详细信息，请参阅设计程序中的“帮助”。

显示 数据透视表组件

“数据透视表组件”是用来表现数据库数据或网页上其他源数据的 Office Web 组件。用户可以在浏览器中与数据透视表列表进行交互。

如果基于数据透视表列表创建图表，则可对该图表进行筛选和排序，还可以按照数据透视表列表中的版式对其进行重新排列。当数据透视表列表中的数据更改时，图表将自动更新。同样，当对基于数据透视表列表的图表中的数据进行操作时，数据透视表列表也将自动更新以与之匹配。例如，如果从图表中删除了某个字段，则数据透视表列表也将删除此字段。数据透视表列表和图表必须位于相同的网页上。

在创建基于数据透视表列表的图表之前，必须创建、设计和访问该列表中的必要数据。可以在支持 Microsoft Office Web Components 的设计程序中创建数据透视表列表，例如，Microsoft Access 数据访问页“设计”视图。或者，还可以通过 Microsoft Excel 发布数据透视表列表。有关创建数据透视表列表的详细信息，请参阅设置程序的“帮助”。

显示 数据库中的表或查询

图表中的数据可以是设计程序所能访问的任何表、查询或视图中的数据。例如，可以使用连接到 Microsoft SQL Server 数据库上的 Access 数据库或 Access 项目中的表或查询中的数据。当数据进行了更新，并且刷新了图表所在的页面时，图表将更新。还可以添加、删除、排序和筛选图表中的字段以便用不同的方式组织数据。

根据要访问的数据库类型和所用的设计程序类型，用户可能需要建立数据源或其他访问方法并设置相应的访问权限才能访问数据。数据源是存储的信息（有时表现为文本文件的形式），其中包含数据库驱动程序的名称和其他用于建立连接和检索数据的相关信息。有关如何访问数据库中数据的详细信息，请参阅设计程序中的“帮助”。

显示 数据源控件

某些程序用数据源控件实现数据连接。例如，如果将数据库窗体放置在 Microsoft Access 数据访问页，则可以用数据源控件将数据库中的数据连接到该网页。如果图表基于这样一个控件，则连接信息已经建立完成。有关创建数据透视表列表的详细信息，请参阅设计程序的“帮助”。


关于访问不同域中的数据源

“图表”组件试图访问其他域中的数据，但是由于以下原因失败了：

  • 在 Internet Explorer 中的“安全设置”对话框上，在“其他”下面的“通过域访问数据资源”设置被设为“禁用”，或被设为“提示”，而当您被提示时，却单击了“取消”。
  • 控件正在访问的网站不包括在可信网站的列表内。

若要启用跨域访问，请执行下列操作：

显示 启用提示

  1. 在 Internet Explorer 中的 “工具”菜单上，单击“Internet 选项”。在“安全”选项卡上选择相应的 Web 内容区域，然后单击“自定义级别”。在“其他”下面，将“通过域访问数据资源”设置为“提示”。
  2. 当被提示时，如果您信任数据提供商，请单击“确定”以便允许“图表组件”从指定域访问数据。

显示 将网站添加到可信网站列表中

如果正在访问的网站总是可靠的，则可将网站添加到可信网站列表中。

  1. 在 Internet Explorer 中的“工具”菜单上，单击“Internet 选项”。在“安全”选项卡上选择“受信任的站点”作为 Web 内容区域，然后单击“站点”。
  2. 在“可信站点”对话框中，输入网站详细信息，然后单击“确定”。


关于使与外部数据源的连接更安全

如果您在网页上为图表组件指定了与外部数据源的连接，则创作环境会将此信息在 HTML 源代码中存储为不加密（纯文本）的连接字符串。于是，在浏览器中打开该网页的用户就可以方便地查看网页的 HTML 源代码，并读取连接字符串，该字符串包含用户名和密码。

若要禁止未经授权的访问用户使用连接字符串信息，如果数据源支持这种模式的验证，请使用 Windows 身份验证(也称为“信任连接”和“集成安全性”)，该验证使用当前用户的 Microsoft Windows 帐户连接到外部数据源。使用 Windows 身份验证连接到外部数据源具有以下优点：

  • 网页设计者不必输入用户名或密码就可与数据源连接，这样信息就不会在页面的 HTML 源代码中公开。
  • 用户在打开网页时不必输入用户名或密码便可与数据源连接，这样信息的安全就不会在被发送到服务器时受到威胁。
  • 只有在安全系统中为数据源配置的 Windows 用户帐户可以与该数据源连接。

例如，若要使用 Windows 身份验证与 Microsoft SQL Server 连接，请在指定连接时使用以下过程。

要点 在可以使用 Windows 身份验证与 Microsoft SQL Server 数据库连接之前，服务器管理员必须将服务器配置为使用该模式的身份验证，并为您的 Windows 用户帐户（或者您的用户帐户所属的组）赋予登录访问权限。此外，服务器管理员也可为您的用户帐户提供访问图表所需的表或存储过程的最低级别的权限。

  1. 在设计窗口中，确保图表处于活动状态。有关指导，请参阅设计程序中的“帮助”。
  2. 右键单击图表，选择“命令和选项”。
  3. 在“命令和选项”对话框中，选中“一个数据库的表或查询”。
  4. 单击“连接”。
  5. 在“数据明细”选项卡上，单击“编辑”。
  6. 在“选择数据源”对话框上，双击“新的 SQL Server 连接.odc”。
  7. 在“数据连接向导”中，在“服务器名称”中指定服务器的名称。
  8. 在“登录凭据”下，单击“使用 Windows 身份验证”。
  9. 单击“下一步”，然后按照“数据连接向导”的其余屏幕中的指导来指定要检索的数据。

注释 支持 Windows 身份验证的其他数据源可能在“数据连接向导”中提供不同的选项。例如，若要使用 Windows 身份验证与 Oracle 数据库连接，必须仅在“用户名”框中输入正斜杠 (/)。有关详细信息，请参阅正在使用的数据源提供程序的文档。

如果 Windows 身份验证不能用于要连接的数据源，就必须输入用户名和密码才能与数据源连接。因为该用户名和密码可能在图表位于网页上时被看到，所以，不要使用这种模式的身份验证从网页上的图表与敏感数据进行连接。即使您不在意未经授权的用户查看您的数据查看您的数据，也应该只使用对数据源具有受限权限的用户帐户进行连接。例如，当使用用户名和密码与 SQL Server 数据库连接时，不要使用已经提高权限的 SA 帐户或任何其他帐户，因为未经授权的用户可能会使用该帐户和密码访问服务器上的其他数据。

注释 如果您使用“Microsoft SQL Server 数据检索服务”（或者使用为使用该数据检索服务而指定的“数据检索服务连接 (.uxdc)”文件）与外部数据源进行连接，且不使用 Windows 身份验证，则用于连接数据源的用户名和密码就不会保存在网页中。当您使用此方法与外部数据源连接时，包含图表的网页的用户将会被提示输入登录信息。


更改图表的源数据

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 用鼠标右键单击图表，再单击快捷菜单上的“数据”。
  3. 在“数据源”选项卡上，选取新的数据源，再设置数据源的选项。

安全说明 某些情况下，用户可能会查看用于连接到外部数据源的信息。这有可能会带来一些风险。有关详细信息，请参阅关于使与外部数据源的连接更安全。


图表的元素

显示系列、分类和数据的表示方式

代表数据的图表元素示例

标注 1 网格线

标注 2 数据系列

标注 3 数据标志

标注 4 分类

标注 5 绘图区

标注 6 图例项标示

标注 7 系列名称

标注 8 图例

网格线   网格线是可以添加到图表中以使数据易于查看和求值的线条。网格线是坐标轴上刻度线的延伸，并穿过绘图区。

数据系列、系列名称（图例项）   数据系列是绘制在图表中的一组相关数据点。每个数据系列都有唯一的颜色或图案，并且在图例中可由图例项标示和系列名称（图例项）代表。在前面的图表示例中，“计划”和“实际”都是数据系列。在大多数图表中都可以绘制一个或多个数据系列。

数据标志   用于代表数据点，每个数据点都是绘制在图表中的单个值。而相关数据点构成了数据系列。例如，数据标志包括条、点和扇区等。

分类   分类是由图表中每个数据系列的一个数据点构成的一组相关数据点。对于大多数图表，分类是沿分类 (X) 轴绘制的，其方向一般为水平。但是，在某些图表中，分类 (X) 轴却是垂直的，例如条形图中。在前面的图表示例中，“一季度”、“二季度”、“三季度”、“四季度”都是分类，且这四个分类中的每一个都是由“计划”系列的一个数据点和“实际”系列的一个数据点构成的。

绘图区   图表中坐标轴包含的区域，包括所有的数据系列。

图例项标示   图例中的图像，用于显示为图表中数据系列或分类指定的图案和颜色。图例项标示位于图例项的左边。

图例   为图表中数据系列或分类指定的图案或颜色标示。

显示坐标轴

图表中的坐标轴

标注 1 数值 (Y) 轴标题

标注 2 数值 (Y) 轴刻度线标签

标注 3 数值 (Y) 轴

标注 4 网格线

标注 5 次要刻度线

标注 6 分类轴标题

标注 7 分类 (X) 轴刻度线标签

标注 8 分类 (X) 轴

数值 (Y) 轴标题   通常用于说明数值轴度量内容的标题。

数值 (Y) 轴刻度线标签   也称为数值轴标签。这些标签对数值轴上的度量值进行了说明。

数值 (Y) 轴   构成绘图区一条边的线，它为在图表中进行度量或比较提供了参照框架。对于大多数图表，数据值是沿数值 (Y) 轴绘制的，而该轴一般是垂直的。但是，在某些图表中数值 (Y) 轴是水平的，例如条形图中。而有些图表的数据值则是绘制在两条坐标轴之上的，例如 XY 散点图中。

网格线   网格线是可以添加到图表中以使数据易于查看和求值的线条。网格线是坐标轴上刻度线的延伸，并穿过绘图区。

主要刻度线和次要刻度线   与坐标轴相交的表示度量单位的细线，类似于标尺上的分隔线。主要刻度线出现在坐标轴刻度的每个主要度量单位上，而次要刻度线出现在每个次要度量单位上。这两种类型可位于坐标轴的内部或外部，或者也可位于横穿坐标轴的位置上。

分类 (X) 轴标题   用于说明分类轴上绘制内容的标题。

分类 (X) 轴刻度线标签   也称为分类标签。这些标签显示了分类轴上分类的名称。

分类 (X) 轴   构成绘图区一条边的线，它为在图表中进行度量或比较提供了参照框架。分类是由图表中每个数据系列的一个数据点构成的数据点组。对于大多数图表，分类是沿分类 (X) 轴绘制的，该轴一般是水平的。但是在某些图表中分类 (X) 轴是垂直的，例如条形图中。还有些图表没有分类轴，例如 XY 散点图。

显示标题和标签

图表标题和标签

标注 1 图表工作区标题（用于工作区中所有图表的标题）

标注 2 图表标题（用于单个图表的标题）

标注 3 数值轴标题

标注 4 分类轴标题

标注 5 分类标签

标注 6 数据标签

标注 7 数值轴标签

标注 8 图表工作区图例（用于工作区中所有图表的图例）

标注 9 图表图例（用于单个图表的图例）

图表工作区标题   用于说明所有图表的标题（如果工作区内有多个图表）。本标题可以位于图表工作区的上方、下方、左方或右方。

图表标题   用于说明单个图表的标题。本标题可以位于图表的上方、下方、左方或右方。

数值轴标题   通常用于说明数值轴度量内容的标题。

分类轴标题   通常用于说明分类轴绘制内容的标题。

分类标签   也称为刻度线标签。这些标签显示了分类轴上的分类名称。分类是由图表中每个数据系列的一个数据点构成的一组相关数据点。

数据标签   用于提供有关数据标志（代表单个数据点或值）附加信息的标志。根据不同的图表类型，数据标签可以显示值、数据系列或分类的名称、百分比，或者显示这些项的组合。

数值轴标签   也称为刻度线标签。这些标签对数值轴上的度量值进行了说明。

图表工作区图例   为多个图表工作区中所有图表内的数据系列或分类指定的图案或颜色标示。

图表图例   为单个图表中数据系列或分类指定的图案或颜色标示。

显示字段

如果基于数据库或数据透视表列表来创建图表，则图表像数据透视表列表一样，其中含有可进行移动、筛选和排序的字段。

含有字段的图表

标注 1 筛选字段

标注 2 多图表字段

标注 3 数据字段

标注 4 系列字段

标注 5 分类字段

筛选字段   可以使用该字段根据特定项来筛选数据。在前面的示例中，“年份”筛选字段显示所有具有记录的年份的数据。若要显示单个年份的数据，可单击“年份”旁边的箭头，然后选择年份。

多图表字段   可以使用该字段为字段中的每个项显示不同的图表。在本例中，“销售人员”字段经过筛选后只显示两名销售人员：Dodsworth 和 Suyama。由于该字段在“多图表”区域，因此为这两名销售人员显示了两个不同的图表。

数据字段   来自基本源数据的字段，提供进行比较或计算的数据。在本例中，“销售总金额”就是一个数据字段，它用于汇总每种产品在各个地区的销售情况。在 Dodsworth 图表中第一个分类数据标志 (E) 在数值 (y) 轴上的值略大于 200。该数值是 Dodsworth 在东部地区销售的各产品销售额的总和。根据报表使用的源数据的不同，可将 Sum 汇总函数更改为 Average、Max、Min 或其他计算。

系列字段   分配到图表系列方向上的字段。字段中的项提供单个数据系列。在本例中，“类型”就是一个系列字段。

分类字段   分配到图表分类方向上的源数据中的字段。分类字段为那些用来绘图的数据点提供单一分类。在本例中，“地区”就是一个分类字段。


图表类型示例

显示 面积图

面积图强调随时间的变化量。通过显示所绘制值的总和，面积图显示了部分与整体的关系。

在本示例中，面积图强调了华盛顿地区销售额的增长并显示了各州对总销售额的贡献。

显示 柱形图

柱形图显示了一段时间内的数据变化情况，或说明了各项之间的比较情况。若要强调随时间的变化情况，可以水平组织分类，垂直组织值。

堆积柱形图显示了单个项目与整体间的关系。

显示 条形图

条形图说明了单个项之间的比较情况。若要集中了解值之间的比较情况，而并不太强调随时间的比较情况，则可以垂直组织分类，水平组织值。

堆积条形图显示了单个项目与整体的关系。

显示 折线图

折线图等间距显示了数据的趋势。

显示 平滑线图

平滑线图等间距显示了数据的趋势，并通过平滑曲线显示了间距之间的估计值。

显示 饼图

饼图显示了组成数据系列的项目相对于项目总数的比例大小。饼图仅显示一个数据系列，当需要强调某个重要元素时它将非常有用。

还可以创建具有多个系列的堆积饼图。

显示 圆环图

像饼图一样，圆环图也显示部分与整体之间的关系，但圆环图由圆环而不是扇区组成，并包含多个数据系列。圆环图的每一个环都代表一个数据系列。

显示 股价图

说明股价的股价图一般有两种：开盘-盘高-盘低-收盘图和盘高-盘低-收盘图。这些图表也可用于科学数据，例如，指示高-低-平均温度。上例中的图表即盘高-盘低-收盘图。

显示 XY 散点图

XY 散点图既可以显示多个数据系列中数值之间的关系，也可以将两组数字绘制成一系列 XY 坐标。该图表显示了不规则的数据间隔（或簇），并常用于科学数据。

如果要将数据排列为 x-y x-y 形式，可将 x 值放置于一行或一列，相应的 y 值放置于相邻的行或列。

显示 气泡图

气泡图是一种 XY 散点图。数据标志的大小反映了第三个变量的大小。

若要排列数据，请将 X 值放置到一行或一列中，然后在相邻的行或列中输入相应的 Y 值和气泡大小。

显示 雷达图

在雷达图中，每个分类都有自己的值坐标轴，此值坐标轴由中心点向外发散。折线连接了相同系列中的所有值。

雷达图可比较多个数据系列的合计值。在该图表中，覆盖了大多数地区的数据系列为“A 牌”，它代表维生素含量最高的品牌。

显示 极坐标图

极坐标图可比较角度和距离之间的关系。本例中的图表显示了雷达天线两个顶点之间的仰角。


创建图表

创建图表的特定步骤取决于用于设计网页的程序。有关详细信息，请参阅该程序的“帮助”。如果设计程序的“帮助”并没有提供创建组件（如图表）的过程，则请按照下列步骤进行操作：

  1. 在设计程序中，打开或创建其中包含图表所需数据的数据库、项目或网页。
  2. 激活要放置图表的页。
  3. 通过使用向网页中添加控件的设计程序过程，可以指定网页上图表组件的位置和初始大小。
  4. 如果没有显示“命令和选项”对话框，请单击图表使其显示。
  5. 通过选择“在一张数据表中输入的数据”、“一个数据库的表或查询”或是“来自以下的网页项目”，在“数据源”选项卡中，指定图表所需的数据。
  6. 如果选择“来自以下的网页项目”，则还必须选择列表中要使用的网页项（例如，电子表格、数据透视表列表或数据源控件）。只有那些正用于创建图表的网页上已有的项才能显示在列表中。
  7. 为下列数据之一指定数据设置：

    显示 在一张数据表中输入的数据

    1. 在“为数据类型设置明细”下，单击“数据表”。
    2. 选择数据表中的某个单元格，然后在每个标有“系列 n”的列下的各单元格中输入每个系列的数据，或者在标有“分类 n”的各行中输入每个分类的数据。
      • 可以在数据表的第一列或第一行中输入分类或系列标签。
      • 输入数据后，按 Enter 可移动到下一列，还可按 Tab 以移过几列。按 Delete 可删除数据。行和列将自动展开或收缩以适应更多或更少的数据。
      • 输入数据后，图表将自动使用默认的列图表类型来表示数据。
      • 如果要更改各行中的系列和各列中的分类，请单击“按行 - 按列” 按钮图像 。

    显示 来自数据库表或查询的数据

    1. 在“为数据类型设置明细”下，单击“连接”。
    2. 在“连接”框中输入连接字符串，或单击“编辑”来进行浏览或输入数据源的信息。
    3. 根据正使用的设计程序，单击“编辑”以显示“选择数据源”对话框，或是“数据链接属性”对话框。

      显示 “选择数据源”对话框

      1. 在“查找范围”框中定位所需的数据源，并在列表中双击该数据源。
      2. 如果所需的数据源不可用，请单击“新建源”，并按“数据连接向导”中的指示为用户的数据创建新的连接文件。

      显示 “数据链接属性”对话框

      • 在“连接”选项卡中，为数据源输入连接信息。有关各选项的帮助，请单击对话框底部的“帮助”。
    4. 选择“数据成员、表、视图，或多维数据集名称”，并从列表中选择数据成员、表、视图或多维数据集名称，或是选择“命令文本或 SQL”，并键入所需的连接字符串。
    5. 在“绘制细节”下，通过单击“按行/列产生数据系列” 按钮图像 来选择系列是在行中还是在列中。
    6. 如果希望直接使用数据中的记录值，例如，如果在服务器上创建了计算汇总的查询，并希望图表使用这些汇总，而不是在客户端计算自己的汇总，请选中“绘制明细记录”复选框。
    7. 将字段列表中的数据添加到图表的拖放区域。

      显示 操作方法

      1. 在图表工具栏上，单击“字段列表” 按钮图像 。
      2. 使用滚动条和展开指示器（ 加号框 和 减号框 框）查找要添加到图表中的字段。
      3. 单击字段，并将其拖动到图表中适当的拖放区域中：“将系列字段拖至此处”区域、“将分类字段拖至此处”区域、“将数据字段拖至此处”区域或是“将筛选字段拖至此处”区域。

        可以向每个位置添加多个字段。

      注释 若要拖动字段，请先选择要添加字段的区域（列在字段列表底部的区域），再单击“添加到”。如果选择了要放置字段的区域后，“添加到”变为不可用，则可能是选择的字段不能用作分类字段、系列字段、数据字段或筛选字段。

    显示 来自网页项（电子表格）的数据

    1. 在“为数据类型设置明细”下，单击“区域”。
    2. 请执行下列操作之一：

      显示 一次指定所有数据

      1. 在“仅用一步设置数据区域”下，输入图表数据区域的引用，在“数据区域”框中用冒号 (:) 分隔。例如，如果要使用电子表格中连续的单元格区域 A1 到 G5 中的数据，请在数据框中键入“A1:G5”。
      2. 单击“系列在”旁边的“行”或“列”以指定系列数据的位置。
      3. 单击“确定”。

      显示 一次指定一个数据系列

      1. 在“系列”下，单击“添加”。
      2. 如果要使系列具有说明性的名称，请在“系列名称”框中用所需的名称来替换默认的名称。
      3. 在“分类标签”框中，键入该系列的分类标签的单元格引用。例如，如果正添加的系列在行区域 A2:G2，而分类标签在单元格区域 A1 到 G1，则请键入“A1:G1”。
      4. 在“数值”框中，键入该系列各值的区域引用。例如，如果系列数据在电子表格上的单元格区域 A2 到 G2，则请键入“A2:G2”。
      5. 对每个要添加的数据系列重复上述操作。

    显示 来自网页项（数据透视表列表）的数据

    1. 在“为数据类型设置明细”下，单击“数据透视细节”。

      由于图表使用连接在数据透视表列表中的数据，因此“连接”选项不可用。

    2. 在“绘制细节”下，通过单击“按行/列产生数据系列” 按钮图像 来选择系列是在行中还是在列中。
    3. 如果希望直接使用数据中的记录值，例如，如果在服务器上创建了计算汇总的查询，并希望图表使用这些汇总，而不是在客户端计算自己的汇总，请选中“绘制明细记录”复选框。
    4. 如果需要，可以在图表中，通过单击图表工具栏上的“字段列表” 按钮图像 来添加、更改或删除字段。

    显示 来自网页项（数据源控件）的数据

    1. 在“为数据类型设置明细”下，单击“数据源细节”。
    2. 在“数据成员、表、视图，或多维数据集名称”列表中，单击包含图表所需数据的项。
    3. 在“绘制细节”下，通过单击“按行/列产生数据系列” 按钮图像 来选择系列是在行中还是在列中。
    4. 如果希望直接使用数据中的记录值，例如，如果在服务器上创建了计算汇总的查询，并希望图表使用这些汇总，而不是在客户端计算自己的汇总，请选中“绘制明细记录”复选框。
    5. 如果需要，可以在图表中，通过单击图表工具栏上的“字段列表” 按钮图像 来添加、更改或删除字段。
  8. 单击“类型”选项卡，单击列表中要使用的图表类型，再单击显示在右端的要使用的图表的子类型。
  9. 单击图表或图表中的项使“命令和选项”对话框中的选项可用。根据在图表中选择的部分不同，对话框中显示的选项也不同。例如，如果选择的是整个图表，则“常规”选项卡可用（可在此添加图例或数据标签，或是根据图表类型进行其他更改）。如果选择的是坐标轴，则将显示“格式”选项卡、“线条/标志”选项卡、“轴”选项卡和“刻度”选项卡。


操作数据表

如果是通过向数据表中键入数据而创建的图表，可使用本过程来操作数据表。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。
  3. 在“常规命令”下，单击“选择”列表中的“图表工作区”。
  4. 单击“数据表”选项卡。
  5. 请执行下列一项或多项操作：

    显示 输入数据

    注释 可在数据表的第一列或第一行中输入分类或系列标签。

    1. 选取数据表中的某个单元格。
    2. 在该单元格中键入所需的数据。
    3. 按 Enter 输入数据并向下选择另一个单元格，或按 Tab 输入数据并向右选择另一个单元格。

    显示 清除数据表

    • 单击“清除数据表” 按钮图像 。
    所有的数据将从数据表及图表中清除。此项操作执行后不能撤销。

    显示 将分类行更改为系列行，或将系列行更改为分类行

    • 单击“按行-按列” 按钮图像 。

    显示 复制和粘贴数据

    1. 在数据表或其他程序中，选取所要复制的数据。
    2. 单击“复制” 按钮图像 。
    3. 单击要向其中粘贴数据的区域左上角的单元格。
    4. 单击“粘贴” 按钮图像 。

    注释 被粘贴的数据将覆盖单元格中已有的内容。


创建组合图

组合图使用两种或两种以上的图表类型，以强调该图表中含有不同类型的信息。下例中的图表将一个数据系列（实际）显示为柱形图，而将另一个数据系列（预计）显示为折线图。

组合图

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。

  2. 确定要设为不同的图表类型的系列。

  3. 请执行下列操作之一：

    显示更改系列的图表类型

    1. 单击要更改其图表类型的系列。

    2. 在工具栏上，单击“图表类型”按钮图像。
    3. 在列表中，单击所需的图表类型，再单击所需的子类型。

    显示更改系列组的图表类型并添加坐标轴

    1. 在图表工具栏上，单击“命令和选项”按钮图像，再单击“常规”选项卡。

    2. 在“常规命令”下，选取“选择”列表中的“图表工作区”。

    3. 单击“系列组”选项卡。

    4. 在“系列组”之下，在“选择一个或多个系列”框中，选取要更改其图表类型的系列。

    5. 在“操作”列表中，单击“新建组”。

    6. 如果您要显示第二个坐标轴，以反映某系列组合的不同刻度，请在“添加坐标轴”下的“组”框中单击该组，再在“坐标轴位置”框中，为第二个坐标轴选择一个位置。例如，如果主坐标轴位于图表的左侧，而要使第二个坐标轴位于图表的右侧，请单击“坐标轴位置”框中的“右”，再单击“添加”。

    7. 在图表中，选取已组合的系列，以便更改其图表类型。

    8. 单击“类型”选项卡。

    9. 在列表中单击所需的图表类型，再单击左侧的框中的子类型。

注释   并非所有的图表类型都可以被组合。例如，不能组合二维和三维图表类型，也不能组合条形图与柱形图，或者柱形图与饼图。


在图表工作区中创建多个图表

当图表是基于来自数据透视表列表或数据库的表或查询的数据时，可在同一个图表工作区中创建多个图表，以便于对数据的各个方面进行比较。下面的示例中显示了多个图表，对每位销售人员使用了单独的图表以比较销售数据。而且，本示例中的图表采用了相同的刻度（可选）。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。
  3. 在“常规命令”下，选取“选择”列表中的“图表工作表”。
  4. 在“添加”下，单击“绘制多个图表” 按钮图像 。
  5. 如果要对所有的图表使用相同的坐标轴刻度，请单击“用相同的刻度绘制多个图表” 按钮图像 。
  6. 单击工具栏上的“字段列表” 按钮图像 ，再使用滚动条及展开指示器（ 加号框 和 减号框 框）来查找您想添加到图表中的字段。
  7. 单击字段并将其拖动到图表中指示为“将多图表字段拖至此处”的拖放区域中。

    您可以向该“多图表”区域中添加多个字段。


更改多图表的显示

当在图表工作区中有多个图表时，可以更改这些图表显示的方向，使其水平或垂直显示，也可更改每行或每列中显示的图表个数。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。
  3. 在“选择”框中，单击“图表工作区”。
  4. 在“图表工作区”之下的“图表布局”列表中，单击“水平”或“垂直”。

    如果选择“自动”，将根据工作区的大小和形状来决定横向或纵向显示图表。

  5. 如果要限制图表工作区中横向或纵向显示的图表个数，请在“每行/列的最大图表数”框中键入所要求的最大图表个数。

    注释 只有当您单击“图表布局”列表中的“水平”或“垂直”时，此选项才可用。


关于在浏览器中使用图表

显示 使用浏览器和使用设计程序之间的比较

Microsoft Office 图表组件使用户可在设计程序中创建图表，以便在 Web 浏览器或其他运行时环境中实现运行时访问。Microsoft Excel、Microsoft FrontPage 和 Microsoft Access 都是可用于创建和修改图表的设计程序。

本主题中讨论的运行时功能适用于安装了 Microsoft Office Web Components 的用户。可以在安装 Microsoft Office 2003 时安装上述组件，或者如果公司有 Office 2003 站点许可证，则可以从企业 Intranet 中下载 Office Web 组件。用户还应有完全支持交互式图表的 Web 浏览器，例如 Internet Explorer 5.01 SP2 或更高版本。如果要创建图表以便在某个非 Web 浏览器的程序（例如：作为自定义解决方案一部分的 Microsoft Visual Basic 窗体）中使用，那么请参阅设计程序的“帮助”以了解用户如何才能访问图表以及如何才能与图表进行交互。

显示 用户可在浏览器中进行的操作

在浏览器中运行时，其系统满足所需要求的用户可以查看已创建的图表。当对数据所做的更改反映到图表中时，这些用户可以看到图表进行了自动更新，并且在允许的级别上可与图表进行交互。例如，如果创建了使用股票价格的图表，并且数据进行了更新以反映最近的价格，则用户将看到图表会进行更改以反映新的价格。如果允许显示图表工具栏，用户还可更改图表的类型、更改某些格式，以及根据数据类型来显示、隐藏或重新排列图表中的数据。

更改图表中所反映的数据 用户可以更改图表中所反映的数据，这取决于源数据的类型和用户所具有的访问权限。例如，可以在网页上提供电子表格和相应的图表，并允许用户更改电子表格中的部分（不能是全部）数据。当用户更改了电子表格中的数据后，图表将会进行更新。或者，如果图表是基于数据透视表列表或数据库的表或查询，并在图表中显示了字段，则用户可以直接在图表中移动、重新排列、筛选和排序字段。

更改图表 可以给用户访问图表工具栏或“命令和选项”对话框的权限，允许用户对图表进行更改，用户可做的更改为您在设计程序中可做的更改中的大部分。例如，用户可以更改图表类型或图表中的任何格式类型。也可以选择禁止使用“命令和选项”对话框或工具栏而进行脚本编写，以便只允许对您选择的部分进行更改。有关脚本的使用和 Web 图表编程的详细信息，请参阅关于获取图表的帮助。

浏览器版本对用户可执行操作的影响 与图表进行交互意味着可以更改图表的源数据以及查看图表的更新。若要与图表进行交互，则用户需要使用 Microsoft Internet Explorer 5.01 SP2 或更高版本。建议用户安装 Internet Explorer 5.01 SP2 或更高版本，以便最大限度地利用图表及其源数据的交互式功能。

为浏览器用户提供的“帮助” 浏览器用户可以访问运行时的图表“帮助”，其中包括关于默认的运行时功能的主题，例如，更改图表类型、隐藏或显示图例，以及排序、筛选和移动字段。运行时的“帮助”不包括有关使用“命令和选项”对话框的信息。如果修改了运行时允许的功能，则应提供有关网页的帮助或指导。

用户还可在浏览器中访问系统的“帮助”主题，以及与图表数据源一起提供的任何“帮助”内容。例如，如果图表使用的是数据透视表列表中的数据，则用户可以查看数据透视表组件的“帮助”，以了解如何在数据透视表列表中更改数据。


关于在浏览器中限制图表的使用

图表的某些功能仅在设计程序中可用。而其他功能在设计图表时和在浏览器中使用图表时都可用。但是，作为设计者，您可通过更改属性设置来限制在浏览器中使用这些功能。

无论您为浏览器用户设置了多少可用的功能，这些用户是否能够利用这些功能取决于他们所使用的浏览器及他们是否获得适当的软件许可。若要充分利用图表的功能，用户需要 Microsoft Internet Explorer 5.01 SP2 或更高版本，或者拥有 Office 2003 许可。

显示 在浏览器中不可用的功能

如果图表是基于数据库或数据透视表列表，那么在浏览器中，用户不能更改有关源数据库、数据库字段及源数据的信息。只有图表的设计者，才可指定所要使用的源数据库以及从数据中选择作为图表源数据的子集。

在浏览器中，用户只能显示已设为可用的数据；如果要求输入访问数据库的密码，用户必须输入密码才能显示这些数据。用户可以在浏览器中刷新图表以反映源数据的任何变化，但是他们不能访问源数据库或更改其中存储的数据。

显示 在浏览器中通常可用的功能

如果所用的浏览器完全支持图表，用户可以在浏览器中对图表执行许多与您在设计程序时可做的相同的更改，前提是他们有相应的权限。例如，您可以设置允许或禁止用户显示图表工具栏或“命令和选项”对话框。

在遵循您设计图表时所设限制的前提下，用户可以向字段列表中添加字段或从中删除字段；可以对基于数据库或数据透视表列表的图表中的数据进行排序、筛选和组合；可以更改基于电子表格或数据表的图表中的数据；可以更改图表格式、图表类型及其他项目。只要您没有限制，在设计程序中可进行的更改，用户都可以进行。

显示 可设置的限制

若要防止用户更改图表或访问您不希望让其使用的部分源数据，则可防止他们使用下列功能：

  • 使用“命令和选项”对话框
  • 对数据项进行分组
  • 筛选数据
  • 使用选中标记
您可以通过编写脚本来进一步设置限制，有关详细信息，请参阅如何获得图表的编程帮助。


限制在浏览器中使用图表

当更改了设置以防止用户在图表中进行某项特定的任务时，您在设计程序中也不能进行该项任务，除非您再次更改设置。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。

  2. 在图表边界内，单击绘图区外的空白区域以选择图表工作区。

  3. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“显示/隐藏”选项卡。

  4. 在“允许用户查看”之下，请执行下列操作之一：

    显示 防止添加、更改或删除筛选

    • 清除“允许透视筛选”复选框。

    显示 防止组合或更改布局

    • 清除“允许透视组合”复选框。

    显示 防止显示选择标志

    • 清除“选择标志”复选框。

    显示 防止使用“命令和选项”对话框

    • 清除“命令和选项对话框”复选框。


显示或隐藏被动警报

被动警报指示图表中包含一个错误。该警报在图表的左下角显示一个感叹号，单击它时将显示有关该警报的信息。被动警报出现在错误情况下，例如，无法找到文本文件，或数据库连接失败。

  1. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。
  2. 在“常规命令”之下，单击“选择”框中的“图表工作区”。
  3. 单击“显示/隐藏”选项卡。
  4. 在“错误”之下，选中或清除“显示被动警报”复选框。


显示或隐藏屏幕提示

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。
  3. 在“常规命令”之下，请单击“选择”框中的“图表工作区”。
  4. 单击“显示/隐藏”选项卡。
  5. 在“默认显示”之下，选中或清除“屏幕提示”复选框。


关于添加和删除字段

当您向基于数据库数据或数据透视表列表的图表中添加数据时，会从源数据中选取字段以显示于图表中。

显示 查看图表可用的字段

使用图表的字段列表可查看源数据中可用字段的列表，并将字段添加到图表的分类、系列、筛选和数据区域中。在字段列表中，一个字段集包含一个或多个字段。未使用粗体的字段或字段集可在图表中显示。使用粗体的字段集包含一个或多个已经显示的字段。您可以通过滚动和单击展开指示器（ 加号框 或 减号框 框）来显示或隐藏每个字段集中的其他字段。如果要显示同一字段集中的多个字段，这些字段必须显示在同一个拖放区域中。

如果图表是基于 OLAP 数据库（例如使用 Microsoft SQL Server OLAP Services 创建的数据库）的源数据，您会发现有些字段只能被移动到系列或分类区域。在“汇总”下列出的其他字段则只可以用作数据字段。

显示 将字段移动到分类或系列区域中

使用分类和系列字段可汇总并比较数据。这些字段可将某一字段内的唯一数据项显示为系列（相关数据点）或分类（包含每个系列中一个数据点的相关组）。

标注 1 系列字段，显示为图例。图例中的名称为该字段中的数据项。

标注 2 分类字段。沿 x 轴底部显示的名称为分类字段中的数据项。

显示 将字段添加到数据区域中

数据字段提供了要在图表中进行汇总的值。在向数据区域中添加字段时，该字段的值将显示为分类和系列项的数据标志。

标注 1 数据字段

标注 2 代表数据点的数据标志

显示 将字段添加到筛选区域

筛选字段类似于 Microsoft Excel 数据透视表中的页字段。使用筛选字段可使视图仅显示可用数据的特定部分。当选取筛选字段中的某个数据项时，将只显示和计算该项的数据。例如，如果将“年份”添加为一个筛选字段，可以使图表一次显示所有年份的数据或只显示某一年的数据。

标注 1 筛选字段

标注 2 当前显示的筛选字段项

标注 3 所选年份的数据标志

显示 添加汇总字段

通过向图表中添加汇总字段，可以创建新的数据字段。汇总字段提供了可用作数据字段的汇总数据。例如，如果源数据中包括可显示每次销售额的“销售额”字段，则可以添加“求和项：销售额”汇总字段来计算总销售额，或将汇总字段更改为“计数项：销售额”字段来显示销售总数。

显示 删除字段

若要清除您不想继续查看或汇总的数据，可以从图表中删除字段。删除的字段将不再显示在图表中，但仍可在字段列表中查看。

显示 移动字段

在将字段添加到图表中后，可以将其移动到其他区域中。移动字段将会更改图表的版式和数据显示的方式。

显示 添加和删除筛选字段的影响

如果删除某字段，稍后又将其重新添加到图表中，筛选设置将保留。


添加、更改或删除字段

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 请执行下列一项或多项操作：

显示 添加字段

  1. 在图表工具栏上，单击“字段列表” 按钮图像 。

  2. 使用滚动条和展开指示器（ 加号框 和 减号框 框）查找要添加到图表中的字段。

  3. 单击该字段并将其拖动到图表上适当的拖放区域中。

    可以向每个位置添加多个字段。

    注释

    • 除拖动字段外，另外一种可选的方法为：在字段列表中选择将要向其中添加字段的区域（这些区域在字段列表的最后面列出），再单击“添加到”。如果在选取了将要向其中添加字段的区域后，“添加到”变得不可用，那么，所选的字段可能不可用作分类、系列、数据或筛选字段。

    • 如果图表是基于 OLAP 数据库中的源数据，则只有未在字段列表中“汇总”之下列出的字段才能用作分类、系列或筛选字段。

    • 您可以向图表中的一个区域中添加多个字段。字段在图表中的位置决定了数据显示的分级顺序。外部字段可以被展开或折叠，以显示内部字段中的更多或更少的信息。

    • 只有当图表是基于数据透视表列表或数据库的表或查询中的数据，并且在“命令和选项”的“常规”选项卡上选中了“绘制多个图表” 按钮图像 时，“多图表区域”才可用。

显示 更改数据字段的汇总函数

  1. 单击包含要汇总数值的数据字段。

  2. 在图表工具栏上，单击“自动计算” 按钮图像 ，再单击所需的汇总函数。

注释 当图表的源数据不允许您添加汇总字段时（例如，当源数据是来自 OLAP 数据库时），“自动计算”按钮将不可用。

显示 删除字段

将字段从图表中删除后，该字段的数据将不再显示，但仍可在字段列表中查看该字段。

  1. 单击要从图表中删除的字段的字段标志。

  2. 向图表外部拖动字段，直至指针变为 带红色 X 的指针 。


在图表中移动字段

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 如果图表的拖放区域未显示，请用鼠标右键单击图表，再单击快捷菜单上的“拖放区域”以显示该区域。
  3. 在图表中，单击要移动的字段，然后拖动该字段直到指针更改形状以表示将要放置该字段的区域。
    该指针 | 表示该区域
    系列区域的指针 | 系列区域
    分类区域的指针 | 分类区域
    筛选区域的指针 | 筛选区域
    数据区域的指针 | 数据区域
    “多图表”区域的指针 | “多图表”区域
  4. 释放鼠标按键。

注释 上述指针只有当在图表内移动字段时有效，而当从字段列表中添加字段时无效。


关于更改图表中字段的布局

当图表是基于数据库或数据透视表列表的数据时，可以通过移动字段或自定义布局来控制数据的显示方式。采用不同的布局，您可使用对用户有意义的方式来比较数据中不同元素的值。当图表可为浏览器用户使用时，这些用户可进一步更改初始布局。

显示 使用拖放区域

您可以通过将字段移动到图表工作区内预定义的拖放区域中来更改图表的布局。若要实现上述操作，必须在图表中显示拖放区域。

根据不同的图表类型，拖放区域的显示也不同。例如，对于饼图来说，不会显示系列的拖放区域，因为饼图只包含一个系列。如果绘制多个图表，则将看到多图表字段的拖放区域，该类型的拖放区域不会为单个图表而显示。

当您将字段移动到拖放区域中覆盖了拖放区域标题后，仍然可以继续向其中拖放其他字段。

显示 将字段移动到分类和系列区域

当将字段移动到系列区域中时，该字段中的唯一数据项将在图表中显示为数据系列。这些数据系列用彩色数据标志表示，其名称显示在图例中。

当将字段移动到分类区域中时，该字段中的唯一数据项将显示为分类或相关的数据组。每个分类由每个数据系列中的一个数据点组成。分类标签通常相对于图表的 x 轴出现，但因正在使用的图表类型而异。

显示 将字段移动到数据区域

数据字段提供了要在图表中进行汇总的值。当您将字段移动到数据区域中时，字段的值将被用作在图表中要进行度量的数据。

显示 将字段移动到筛选区域

筛选字段类似于 Microsoft Excel 数据透视表中的页字段。筛选字段可使视图只显示可用数据中的特定部分。例如，如果将“产品”字段移动到筛选区域，则可以让图表一次只显示某一产品的分类与系列值。

显示 将字段移动到“多图表”区域

如果图表是基于数据透视表列表或数据库的表或查询的数据，则您可以绘制多个图表。当将字段移动到“多图表”区域时，该字段中的数据项成为独立的图表。例如，如果将“销售人员”字段移动到“多图表”区域中，将根据该字段中的数据为每位销售人员创建一个图表。在下面的示例中，“销售人员”字段在“多图表”区域中，但该字段经过了筛选，这样它分别为 Buchanan 和 Davolio 显示独立的图表。

显示 将分类或系列字段移动到内部级或外部级

当图表包含多个系列或分类字段时，最接近数据的字段为内部字段，其他字段为外部字段。在下面的示例中，“年份”为外部字段而“销售人员”为内部字段。内部字段项显示为销售人员的名称，外部字段项显示为 1997 年和 1998 年。

标注 1 内部字段项

标注 2 外部字段项

您可以展开或折叠多个字段以显示特定字段中的更多或更少信息。例如，在下例中，可以折叠外部字段（年份）使得内部字段项不再显示。

显示 添加和删除字段

图表的布局无须包含源数据中的所有可用字段。如果还有其他可用数据，可以向图表中添加字段。例如，如果图表汇总了销售收入，并且源数据中还包括销售数量，则可以将“销售量”字段作为数据字段添加到图表中，以便同时汇总所销售产品的数量和收入。还可以从图表布局中删除字段，以便不再显示该字段。

显示 对移动或添加字段的限制

如果所用的图表是基于 OLAP 数据库（例如，用 Microsoft SQL Server OLAP Services 创建的数据库）的源数据，您会发现有些字段只能被移动到系列、分类和筛选区域，而且数据区域中的字段不能被移动到其他区域中。

显示 更改筛选布局的影响

移动或删除字段时，筛选设置依旧保留，这意味着当您将系列或分类字段移入或移回筛选区域时，以前隐藏的项将再次隐藏。如果删除某字段，稍后又将该字段重新添加到布局中，则相同的项将再次隐藏。

显示 在浏览器中限制使用图表

通过防止用户在运行时添加或移动字段，可限制其更改图表布局的能力。


选取图表项目

  1. 在设计窗口中，请确保图表已激活。请参阅设计程序中的“帮助”，获取有关激活图表的方法的特定信息。

    注释 若要激活图表，必须单击图表一次或两次，具体次数取决于所用的设计程序。例如，在数据访问页中，必须先单击一次选取图表（白色尺寸柄将出现在其边框上），单击第二次激活图表（阴影边框将出现在图表周围）。

  2. 请执行下列操作之一：

    显示 用鼠标选取项目

    • 单击一次可选取一组项目，例如，选取数据系列中的一组数据标志。
    • 如果要选取一组中的单个项目，例如，数据系列中的单个数据标志，请单击一次选中该组，再单击一次选中所需的单个项目。

    显示 用“命令和选项”对话框选取项目

    1. 用鼠标右键单击该图表，再单击“命令和选项”。
    2. 单击“常规”选项卡。
    3. 在“选择”框中，单击所需的图表项目。例如，若要选取图表上的第一个数值坐标轴，请单击列表中的“数值轴 1”。


更改图表类型

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。

  2. 请执行下列操作之一：

    • 若要更改整个图表的图表类型，请选择图表工作区，方法是：单击绘图区域外但在图表边界内的空白区域。

    • 若要更改单个数据系列的图表类型，请选择该数据系列。

      注释 当为单个数据系列更改图表类型时，也同时创建了一个组合图表。并不是所有的图表类型都可组合在一起。例如，不能将二维和三维图表类型进行组合，也不能将条形图和柱形图，或柱形图和饼图进行组合。

  3. 在工具栏上，单击“图表类型” 按钮图像 。
  4. 在列表中，单击所需的图表类型，再单击所需的子类型。


添加、删除或更改坐标轴

  1. 在设计窗口中，请确保图表已激活。有关说明，请参阅设计程序中的“帮助”。
  2. 请执行下列一项或多项操作：

    显示 添加坐标轴

    1. 单击图表工作区（在绘图区和图表边界之间的空白区域）。
    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“系列组合”选项卡。
    3. 在“系列组合”之下的“选择一个或多个系列”框中，选取要向其添加坐标轴的系列组合。
    4. 如果希望坐标轴反映不同的系列，可以将系列与其他组进行组合、取消组合或合并。
    5. 在“添加坐标轴”之下的“组合”框中，选取要向其添加坐标轴的组，然后在“坐标轴位置”框中，选定坐标轴要显示的位置。
    6. 单击“添加”。

    显示 删除坐标轴

    1. 单击要删除的坐标轴。
    2. 按 Delete。

    显示 更改坐标轴的位置

    1. 单击要更改的坐标轴。
    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“格式”选项卡。
    3. 在“位置”之下的“位置”框中，选择所需选项。

    显示 添加、更改或删除坐标轴的标题

    显示 添加标题

    1. 请单击需添加标题的坐标轴。

    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。

    3. 单击“添加标题” 按钮图像 。

    显示 删除标题

    1. 单击要删除的标题。

    2. 按 Delete。

    显示 更改标题

    1. 单击要更改的标题。

    2. 在工具栏上，单击“命令和选项” 按钮图像 。

    3. 请执行下列一项或多项操作：

      显示 更改文本格式

      1. 单击“格式”选项卡。

      2. 在“文本格式”之下，选择所需选项。

      显示 更改标题的内容

      1. 单击“格式”选项卡。

      2. 在“标题”之下的“标题”框中，键入新标题。

      显示 更改边框或填充的颜色

      1. 单击“边框/填充”选项卡。

      2. 在“边框”和“填充”之下，选择所需选项。

    显示 更改坐标轴文本的字体和大小

    1. 单击要更改的坐标轴文本。
    2. 在工具栏上，单击“命令和选项”，再单击“格式”选项卡。
    3. 在“文本格式”下，选择所需选项。

    显示 更改分类轴上刻度线和标志的间距

    分类坐标轴上的分类是由标志来标识的，并根据刻度线与其他分类相区别。 可以更改标志和刻度线各自出现的间隔。

    1. 单击需要更改的分类轴。

    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“刻度”选项卡。

    3. 在“刻度”之下，请执行下列一项或多项操作：
      • 在“标签间距”框中键入数字以指定分类标签出现的频率。例如，键入 1 就是每个分类都添加标签，键入 2 就是每隔一个分类添加一个标签，以此类推。
      • 在“刻度线间距”框中键入数字以指定每对刻度线之间所需的分类个数。例如，键入 1 就是每对刻度线之间有一个分类，键入 2 就是每对刻度线之间有两个分类。

    显示 更改分类 (X) 轴与数值轴的交叉点

    1. 单击需要更改的分类轴。
    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“刻度”选项卡。

    3. 在“交叉轴”之下的“交叉对象”列表中，单击要与分类轴相交的轴。

    4. 如果要指定交叉轴与分类轴相交的位置，请选中“自定义”复选框，然后在该框旁边的框中键入值。

    显示 更改图表的分类轴

    如果分类数据由数字日期组成，则图表将自动使用时间刻度轴。时间刻度分类轴按编年顺序以特定间隔显示日期，即使输入的日期并不是有序的。

    1. 单击需要更改的分类轴。
    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“刻度”选项卡。
    3. 在“时间刻度”之下，单击“时间刻度”框中的选项：

      无 不使用时间刻度轴，而使用分类轴，该轴将日期作为文本标签。

      自动 图表使用时间刻度轴，并决定基于坐标轴刻度的最适当的“组大小”（即，按天、月、季度等组合日期）。

      手动 图表使用时间刻度轴，但需要用户决定基于坐标轴刻度的最适当的“组大小”（即，按天、月、季度等组合日期）。

    4. 如果在上一步中选择了“自动”或“手动”，那么请在“时间刻度”之下的其他选项中，选择所需的日期显示和汇总的方式。

    显示 将坐标轴上值的方向反转

    1. 单击要反转方向的值所在的坐标轴。

    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“刻度”选项卡。

    3. 在“次序”之下，选中“数值次序反转”复选框。

    显示 拆分坐标轴刻度的值

    如果图表中有特别大和特别小的值，则可以拆分数值轴（或时间刻度轴），以便清楚地显示所有值。例如，如果值的范围是 0 到 950 之间，而大量的值都位于 0 到 100 和 750 到 950 之间，则可以拆分坐标轴以使其包含两种刻度：下端刻度取值范围是 0 到 100，上端刻度取值范围是 750 到 950，从而消去了 100 到 750 之间不必要的图表间距。

    Chart with split axis

    1. 单击想要拆分的数值轴。
    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“轴”选项卡。
    3. 选中“拆分坐标轴”复选框，接着在“拆分起点”框（用于标记第一个刻度的末尾值）中键入数值，然后在“拆分终点”框（用于标记第二个刻度的开始值）中键入数值。

    显示 更改坐标轴的线宽或颜色

    1. 单击要更改的线条。
    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“线条/标志”选项卡。
    3. 在“线条”下，选择所需选项。

    显示 更改坐标轴值的数字格式

    1. 选择要更改数字格式的坐标轴值。
    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“格式”选项卡。
    3. 在“文本格式”下的“数字”框中，单击所需的格式。

    显示 更改数值轴的刻度

    刻度指定了坐标轴上数值的范围、坐标轴上数值显示的方式、数值出现的间隔和坐标轴间相互交叉的位置。

    1. 单击想要更改的数值轴。
    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“刻度”选项卡。
    3. 请执行下列一项或多项操作：
      • 在“交叉轴”之下的“交叉对象”框中，选取要与数值轴交叉的轴。如果要指定坐标轴与数值轴相交的位置，请单击“自定义”，然后在“自定义”框中键入数值。
      • 若要指定在坐标轴上是显示最大值还是最小值或同时显示，请选中“自定义最大值”和/或“自定义最小值”复选框，然后在相邻的框中键入适当的值。
      • 如果要指定主要和/或次要刻度与主要和/或次要网格线之间的间隔，请选中“自定义主要刻度单位”和/或“自定义次要刻度单位”复选框，然后在相邻的框中键入适当的值以指定所需间隔。
      • 若要基于 10、2 或 e 的幂计算坐标轴上的值，请选中“对数刻度”复选框，然后在“使用基线”列表中单击要使用的幂。


添加、删除或更改标题

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 请执行下列一项或多项操作：

显示 添加标题

  1. 在图表中，单击要向其添加标题的项：图表工作区或图表坐标轴。

  2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。

  3. 单击“添加标题” 按钮图像 。

显示 删除标题

  1. 单击要删除的标题。

  2. 按 Delete。

显示 更改标题

  1. 单击要更改的标题。

  2. 在工具栏上，单击“命令和选项” 按钮图像 。

  3. 请执行下列一项或多项操作：

    显示 更改文本格式

    1. 单击“格式”选项卡。

    2. 在“文本格式”之下，选择所需选项。

    显示 更改标题的位置

    1. 单击“格式”选项卡。

    2. 在“位置”之下的“位置”框中，单击“上”、“下”、“左”或“右”。

    显示 更改标题的内容

    1. 单击“格式”选项卡。

    2. 在“标题”之下的“标题”框中，键入新标题。

    显示 更改边框或填充的颜色

    1. 单击“边框/填充”选项卡。

    2. 在“边框”和“填充”之下，选择所需选项。


添加、删除或更改图例

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。

  2. 请执行下列操作之一：

    显示 添加或删除图例

    1. 在图表边界内，单击绘图区外的空白区域以选择图表工作区。

    2. 在工具栏上，单击“显示/隐藏图例” 按钮图像 。

    显示 更改图例

    1. 单击要更改的图例。
    2. 在工具栏上，单击“命令和选项” 按钮图像 。
    3. 请执行下列操作之一：

    显示 更改图例的位置

    1. 单击“格式”选项卡。

    2. 在“位置”之下的“位置”框中，单击“上”、“下”、“左”或“右”。

    显示 更改边框宽度或颜色以及背景色

    1. 单击“边框/填充”选项卡。

    2. 在“边框”之下，选择所需的“颜色”、“粗细”或“短划线”选项。

    3. 在“填充”之下，选择所需的“填充类型”和“颜色”。

    显示 更改文本的字体或大小

    1. 单击“格式”选项卡。

    2. 在“文本格式”之下，选取所需选项。


添加、删除或更改数据标签

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 请执行下列一项或多项操作：

    显示 添加数据标签

    与选定数据系列或数据点相关联的图表类型决定了可以添加的数据标签的类型。

    1. 选择要添加数据标签的数据系列。

    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。

    3. 单击“添加数据标签” 按钮图像 。

    注释 无法向单个数据点添加数据标签。但是，向数据系列添加数据标签后，可以选择并删除不希望其显示的个别数据标签。若要选择单个数据标签，请单击任意数据标签以选中系列中的所有数据标签，然后再单击要删除的数据标签。

    显示 删除数据标签

    1. 单击要删除的数据标签集中的数据标签。

    2. 按 Delete。

    显示 更改数据标签

    显示 更改数据标签的内容

    1. 单击要更改的数据标签集中的数据标签。
    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“数据标签”选项卡。
    3. 在“数据标签”之下，从下列选项中选择一个或多个要在数据标签中显示的内容：“类别名称”、“值”、“系列名称”、“气泡尺寸”（只用于气泡图表）或“百分比”。
    4. 如果从以上项目中选择了要在数据标签中显示的多项内容，那么可以用逗号或空格将其隔开，或使其分行显示。若要执行此操作，请单击“分隔符”列表中的所需选项。

    显示 更改数据标签的文本格式

    1. 单击要更改的数据标签集中的数据标签。
    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“格式”选项卡。
    3. 在“文本格式”之下，选取所需选项。

    显示 更改数据标签的位置

    1. 单击要更改的数据标签集中的数据标签。
    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“数据标签”选项卡。
    3. 在“数据标签”之下的“位置”列表中，单击数据标签相对于数据标志出现的位置。例如，单击“轴内侧”可在标准柱形图中的数据标志内侧及底部显示数据标签。

    显示 更改数据标签的边框或填充

    1. 单击要更改的数据标签集中的数据标签。
    2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“边框/填充”选项卡。
    3. 在“边框”和“填充”之下，单击所需选项。


显示、隐藏或更改网格线

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 请执行下列一项或多项操作：

显示 显示或隐藏网格线

  1. 单击要显示或隐藏网格线的坐标轴。

  2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“轴”选项卡。

  3. 在“刻度和网格线”下，选中或清除“主要网格线”复选框或“次要网格线”复选框，或者两者都选中或清除。

显示 更改网格线

  1. 单击要更改的网格线。

  2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“线条/标志”选项卡。

  3. 在“线条”下，选择所需选项。


更改图表项的文本大小和字体

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 单击所需更改的坐标轴标题、数据标签、R 平方值标签和公式标签、图例文本、图表标题或其他图表文本。
  3. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“格式”选项卡。
  4. 在“文本格式”下，选择所需选项。


更改图表项的线条颜色、宽度和样式

可更改图表中的系列线、坐标轴线、网格线、趋势线、误差线和其他类型的线条的宽度和颜色。

  1. 单击要更改的线条。
  2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“线条/标志”选项卡。
  3. 在“线条”之下，选择所需选项。


更改边框、填充和背景色

可更改图表工作区、绘图区、图例、单个数据标志、系列数据标志、标题和其他支持填充区域的图表项的边框宽度和颜色以及背景色。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 选定要更改的图表区或图表项。
  3. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“边框/填充”选项卡。
  4. 请执行下列操作之一：
    • 若要更改边框的颜色、宽度或样式，请在“边框”之下选择取所需选项。
    • 若要更改背景色或填充，请从“填充”之下的“填充类型”列表中选择选项（“纯色”、“图案”、“渐变”或“图片/纹理”），然后根据选中的填充类型选择其他选项。例如，如果选择“渐变”，则可以选择过渡中的颜色数和过渡样式，或选择预设的过渡。


旋转或翻转绘图区

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。

  2. 单击要更改的绘图区。
  3. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。
  4. 请执行下列操作之一：
    • 若要水平或垂直翻转绘图区，请单击“水平翻转” 按钮图像 或“垂直翻转” 按钮图像 。

    • 若要以 90 度的增量顺时针或逆时针旋转绘图区，请单击“顺时针旋转” 按钮图像 或“逆时针旋转” 按钮图像 。


抽出饼图或圆环图中的扇区

在圆环图和堆积饼图中，只能抽出外部环中的扇区。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。

  2. 请执行下列操作之一：

    • 若要抽出所有扇区或圆环，请单击图表工作区（绘图区和图表边界之间的空白区域）。

    • 若要抽出一个扇区或圆环，请单击一次数据扇区或圆环，以选定其所在的数据系列，然后再单击一次以选定要抽出的扇区或圆环。

  3. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。
  4. 在“图表”下的“分离程度”框中，键入某个数字（例如半径的百分比），以表示该扇区上的点或扇区与圆环图或饼图中心之间的距离。


旋转圆环图或饼图中扇区的位置

饼图和圆环图中数据系列的绘制次序是由源数据的次序决定的。使用本过程可以使饼图或圆环图的扇区在 360 度范围内任意旋转。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。

  2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。
  3. 在“选择”列表中，单击“图表工作区”。
  4. 在“图表”下的“第一扇区起始角度”框中，键入 0 到 360 之间的某个数字，以指定第一个扇区出现的角度。


更改条形图和柱形图中数据标志之间的重叠比例或间距

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。

  2. 单击图表工作区（在绘图区和图表边界之间的空白区域）。

  3. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。

  4. 请执行下列操作之一：

    • 若要更改每个分类中数据标志的重叠比例，请在“重叠比例”框中键入从 -100 到 100 之间的某个数字，以表示所需的重叠百分比。例如，如果输入 100，则各条形图或柱形图相互重叠；而如果为 –100，则在条形图或柱形图之间将显示一个条形图或柱形图的间距。如果为 0，则各条形图或柱形图相邻。

    • 若要更改各数据标志分类之间的间距，请在“分类间距”框中键入从 0 到 500 之间的某个数字，以表示所需的分类间距的百分比。例如，如果输入 0，则各数据标志相邻，如果为 100，则数据标志之间将有一个条形图或柱形图的间距。


关于数据系列和分类

数据系列由图例中的名称表示，并且在图表上表现为具有相近颜色的数据标志组。每个数据系列取出一个点便构成了分类。分类是具有相似特征的一组数据点。分类和数据系列中的值可以来自数据的行或列。

例如，假定数据如下所示：

电子表格中的数据

如果要比较按季度分类的在欧洲的单位销量，则数据系列应位于列中，分类应位于行中，该图表如下所示：

图表

如果指定数据系列位于行中，则图表应将欧洲作为分类，而每一季度组成一个数据系列，如下所示：

图表


将系列更改为分类或将分类更改为系列

若要对重点比较哪一方面的数据进行更改，可以对显示为分类的数据和显示为系列的数据进行更改。下面的示例强调对国家/地区（设为分类）的比较。

下面的示例强调对年份（设为分类）的比较。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 请执行下列操作之一：
    • 如果图表是基于数据透视表列表的数据或外部数据，请单击工具栏上的“按行/列” 按钮图像 。
    • 如果图表是基于数据表中的数据，请用鼠标右键单击该图表，再单击快捷菜单上的“数据”，然后单击“数据表”选项卡，再单击“按行-按列” 按钮图像 。


更改分类轴标签的方向和位置

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 单击分类轴的标签。
  3. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“格式”选项卡。
  4. 若要更改轴标签的方向和位置，请分别单击与“方向”或“位置”相邻的下拉列表。
  5. 选择所需的选项。


映射图表颜色以区别不同的数据区域

可设置数据标志的格式，以便用不同的过渡色或单色来代表不同的数据值或数据区域。例如，下面的图表显示来自不同地点的水样及其对应的 pH 测试值，图中用不同深度的过渡色来表示 pH 值的大小，pH 值越高，所对应的颜色越浅。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 单击要设置格式的数据系列。
  3. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“条件格式”选项卡。
  4. 选中“根据条件对数据点染色”复选框。
  5. 在“样式”列表中，单击所需的条件格式样式。
    • 三点渐变 用三种过渡色来在最小值与 0（或指定的数值）以及 0（或指定的数值）与最大值之间进行区分。
    • 两点渐变 用两种过渡色来在最小值与最大值之间进行区分。
    • 两段纯色 用两种纯色来区分小于 0（或指定的数值）和大于 0（或指定的数值）的数值。
    • 最低值 用一种单色来区分某区域中的最小值。
    • 最高值 用一种单色来区分某区域中的最大值。
  6. 在“颜色”旁，选择“开始颜色”、“中间颜色”或“结束颜色”（如果可用）来表示数值区域。
  7. 如果要指定一个数值以根据其设置条件格式，请在“值”框中键入该数值,并在需要时选中“%”复选框。例如，若要设置前 90% 个数值的格式，请在数值框中键入“90”，并选中“%”复选框。
  8. 如果图表基于数据库或数据透视表列表，则可指定另外的数值用于设置条件格式。例如，如果要绘制产品在不同地区的销售额的图表，可根据其他数据集（例如，利润额）来设置数据标志的格式。若要进行此项操作，请清除“条件格式基于数值字段”复选框，再将所需的数据字段添加到图表中的“格式数据”拖放区域中。


向图表中添加图片或纹理填充

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 选择要向其中添加图片的图表区域或项，例如，图表工作区、绘图区或数据标志。
  3. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“边框/填充”选项卡。
  4. 在“填充”下的“填充类型”列表中，单击“图片/纹理”。
  5. 请执行下列操作之一：

    显示 添加自己的图片

    1. 单击“URL”，并键入要使用的图像的地址和名称。

      对于地址，可使用以有效协议开头的 Web 地址，例如：

      http://www.microsoft.com/images/image_name.gif

      或是通用命名规范 (UNC) 的路径，例如：

      \\server\folder\image_name.gif

      或是您的硬盘驱动器上文件的路径，例如：

      C:\image_image.gif

    2. 按 Enter。
    3. 在“格式”旁边，单击某个选项，以设定图片按所需的格式显示在图表中。
      • 平铺 平铺显示图像，使其充满选定的空间。
      • 伸展 伸展图像，使其充满选定的空间。
      • 堆积 堆积图像，使其充满选定的空间。
      • 堆积大小 根据在“单位”框中指定的数值轴单位数来堆积图像。例如，如果柱形图中的数据标志在数值轴上度量为 $6,000 ，并且所指定的单位表示为 $1,000，则在该数据标志中将堆积六个图像。
      • 伸展绘图 沿整个图表伸展图像，但只充满选定的项。
    4. 如果选择“堆积大小”，请在“单位”框中键入希望每个图像填充的单位，然后按 Enter。

    显示 添加内置纹理

    • 单击“预设”，在“预设”列表中单击所需使用的纹理。


更改三维图表视图

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。
  3. 在“常规命令”之下，单击“选择”框中的“图表工作区”。
  4. 单击“三维视图”选项卡。
  5. 单击所需的“投影方式”：

    透视图 按钮图像 图表对象是以如同人视觉所看到的相对距离和位置来表现的。

    正投影图 按钮图像 图表对象看起来像处于同一平面上，此平面与视图和投影线都垂直。

  6. 可通过拖动每一选项的游标来进行所需的更改。例如，若要旋转图表的光源，请拖动“光源”下的旋转游标 按钮图像 。

注释

  • 若要恢复图表的默认视图，请单击“默认视图”旁的“默认” 按钮图像 。
  • 若要使高度比或深度比成比例，请选中“高度比”或“深度比”复选框。


数字格式

本主题中的部分内容可能不适用于某些语言。

“Microsoft Office 图表组件”使用 Microsoft Windows“控制面板”中的区域设置来决定数字、货币、日期和时间格式在图表中的显示方法，该设置对设计程序和运行的浏览器同样有效。例如，这些设置决定了年份是用两位数还是四位数来显示。请参阅 Windows 的“帮助”以获取有关这些格式的信息。

在 Microsoft Visual Basic 或在脚本中，都可以为数据指定自定义的数字格式。有关详细信息，请参阅有关编写脚本和程序来使用 Web 图表的“帮助”。

下面的数字格式在“数字”列表中可用，该“数字”列表位于“命令和选项”对话框的“格式”选项卡中“文本格式”下，当选中图表中的某个项（例如坐标值或数据标签）时，数字格式可用。

格式 | 效果
常规 | 显示没有千位分隔符的数字，负数前面加负号。例如，-36403。 至多显示 11 位数字，如果有小数点，则只显示 10 位数字，并对小数点右边额外的数字进行舍入。如果小数点左边的数字多于 11 位，则使用科学记数法。 数字按右对齐显示，文本按左对齐显示。
常规日期 | 将序列号显示为日期或时间，或者两者均显示。例如，36403.24583 将显示为 99-8-31 05:54 AM。 数字的小数部分为时间。如果数字没有小数部分，则格式将只显示日期。例如，35920 将显示为 98-5-5。如果数字只有小数部分，则格式将只显示时间。例如，.77 就显示为 6:28 PM。
长日期 | 使用 Windows“控制面板”中区域设置的长日期格式显示日期。例如，星期四 2001 年 1 月 25 日。
中等日期 | 根据 Windows“控制面板”中的区域设置显示带月和日分隔符的日期，年份则显示为两位数。例如，25-Jan-01。
短日期 | 使用 Windows“控制面板”中区域设置的短日期格式显示日期。例如，“01-1-25”。
长时间 | 使用 Windows“控制面板”中区域设置的长时间格式显示时间。例如，“8:45:36 PM”。
中等时间 | 按 12 小时格式显示时间，包含 AM 或 PM 标志符，但不包含秒。例如，“8:45 PM”。
短时间 | 按 24 小时格式显示时间，不包含 AM 或 PM 标志符，也不包含秒。例如，“8:45 PM”显示为“20:45”。
货币 | 使用 Windows“控制面板”中区域设置的货币格式设置显示数字，带有货币符号和千位分隔符（如果需要，则会有两位小数位）。例如，“$2,532.75”。
欧洲货币 | 将数字显示为欧洲货币的形式，同时具有千位分隔符和两位小数位。根据 Windows“控制面板”中区域设置的不同，欧洲货币符号可以位于数字之前或之后。例如，对于默认的英语（美国）区域设置，其显示为 欧元 12.35。
固定 | 显示两位小数位的数字。例如，68.3 显示为 68.30。
标准 | 显示两位小数位的数字，使用列表分隔符设置（ Windows“控制面板”区域设置）中指定的千位分隔符。例如，1800 显示为 1,800.00。
百分比 | 显示数字的方法为：将数字乘以 100、保留两位小数位并加上百分号。例如，0.8914 显示为 89.14%。
科学记数 | 按指数方法显示数字。例如，1.25E+10。
是/否 | 如果数字为 0，则显示“No”，其他情况下显示“Yes”。
真/假 | 如果数字为 0，则显示“False”，其他情况下显示“True”。
打开/关闭 | 如果数字为 0，则显示“Off”，其他情况下显示“On”。


更改数字格式

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 选择图表中要更改数字格式的项，例如坐标轴或数据标签。
  3. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“格式”选项卡。
  4. 在“文本格式”下的“数字”框中，单击所需的格式。

注释 不能更改分类轴标志的数字格式。


关于在图表中使用日期

如果根据使用日期的数据来创建图表，并且这些日期组成了图表中的分类 (X) 轴，则可以使用时间刻度的分类轴来表示各日期之间的时段。

日期显示 时间刻度的分类轴按特定间隔的时间先后顺序来显示日期，即使数据中的日期没有按这些时间间隔来排列。

时间刻度组的大小（日、星期、月、季度或年）是由图表根据数据中的日期范围进行初始设置的。例如，如果组的大小初始设置为月，则对于其他透视系数，可以将组的大小更改为季度。在执行该操作时，图表将自动对每个组中的数据点求和，使得将每个组绘制为一个点，如同下面的示例，其中对每个季度的数据点进行求和，而对求和的值进行绘制。还可更改用于创建分组小计的汇总函数。

时间刻度图表和时间 不能根据以小时、分钟或秒为时间间隔的数据创建时间刻度图表。在时间刻度图表中，只有日、星期、月、季度和年可以看作为日期。

可以使用时间刻度轴的图表类型 在股价图以及二维和三维的折线图、柱形图、条形图以及面积图中可以使用时间刻度轴，但此时这些图表中不能含有多级分类标签，或者图表中不能使用字段。

注释 如果图例中也显示有图表中的日期，就不能使用时间刻度轴。您可以更改图表中数据的绘制方法，这样日期就可以出现在分类轴上。


关于趋势线

趋势线用于以图形方式显示数据的趋势以及分析预测问题。这种分析也称为回归分析。例如，下面的图表对四个季度的收入使用了简单线性趋势线，可清楚地显示各季度收入的增长趋势。

支持趋势线的图表类型 可向柱形图、条形图、折线图、XY 散点图、气泡图、面积图、股价图和极坐标图的数据系列中添加趋势线。如果将图表更改为不支持相关趋势线的图表类型，则趋势线会丢失。

显示 使用 R 平方值确定最佳趋势线

当您向图表中添加趋势线时，可从五种不同的趋势/回归类型中任意选择一种。数据的类型决定了应该使用的趋势线的类型。

趋势线的可靠性和 R 平方值 如果趋势线的 R 平方值等于或接近 1，则此时趋势线最可靠。R 平方值也称作确定系数，它是一个取值范围为 0 到 1 的指示器，用以显示趋势线的预测值与实际值的吻合程度。当您用趋势线拟合数据时，其 R 平方值是自动计算的，您可在图表上显示该值。

显示 线性趋势线

线性趋势线是适用于简单线性数据集的最佳拟合直线。如果数据点构成的图案类似于一条直线，则表明数据是线性的。线性趋势线通常表示事物以恒定速率增加或减少。

在下例中，线性趋势线清楚地显示了 13 年间冰箱销售额一直稳步增长。请注意，其 R 平方值为 0.9036，表明该直线与数据拟合得相当好。

显示 对数趋势线

如果数据的增加或减小速度很快，但又迅速趋近于平稳，那么对数趋势线是最佳的拟合曲线。对数趋势线可以使用负值和正值。

下例使用对数趋势线说明固定地域内动物数量增长的预测情况，当动物生活地区相对减少时，动物数量将趋于平稳。注意，此时 R 平方值是 0.9407，表明与数据线拟合得相当好。

显示 多项式趋势线

多项式趋势线是数据波动较大时适用的曲线。例如，它可用于分析一个大数据集的增减问题。多项式的阶数可由数据波动的次数或曲线中拐点（峰和谷）的个数确定。二阶多项式趋势线通常仅有一个峰或谷；三阶多项式趋势线通常有一个或两个峰或谷；四阶多项式则通常多达三个。

下例显示的二阶多项式趋势线（一个波峰）说明了车速和耗油量之间的关系。注意，R 平方值为 0.9474，表明与数据线拟合得相当好。

显示 乘幂趋势线

如果数据集比较的是以特定速率增长的量（例如，赛车一秒内的加速度），那么此时乘幂趋势线是最合适的曲线。只能对值大于 0（零）的数据创建乘幂趋势线。如果使用包含 0 或负值的数据创建乘幂趋势线，则会在该图表的公式标签上显示“趋势线错误”。

在下例中，通过绘制距离（米）/时间（秒）的曲线，在图表中显示加速度的数据。乘幂趋势线清楚地显示了加速度的增长。请注意，其 R 平方值为 0.9923，表明该曲线与数据几乎完全吻合。

显示 指数趋势线

如果数据值增加或减少的速率越来越快，那么指数趋势线是最适用的曲线。只有在数据值大于 0（零）时才能创建指数趋势线。如果使用包含 0 或负值的数据创建指数趋势线，则会在该图表的公式标签上显示“趋势线错误”。

在下例中，指数趋势线用于说明物体中碳 14 含量随时间的衰减情况。注意，此时 R 平方值为 1，表明趋势线与数据拟合得很好。

显示 移动平均

移动平均趋势线对数据中的微小波动进行平滑处理，从而更清晰地显示图案和趋势。移动平均使用特定数目的数据点（由“周期”选项设置），取其平均值，然后将该平均值作为趋势线中的一个点。例如，如果“周期”设置为 2，那么，前两个数据点的平均值就是移动平均趋势线中的第一个点。第二个和第三个数据点的平均值就是趋势线的第二个点，依此类推。

下面的示例中，移动平均趋势线显示了 26 个星期内住房销售量的趋势图案。


计算趋势线的公式

显示 线性

计算由下列公式所代表的直线的最小平方拟合值：

其中，m 代表斜率，b 代表截距。

显示 多项式

使用下列公式计算数据点的最小平方拟合值：

其中，b 和 变量 为常量。

显示 对数

使用下列公式计算数据点的最小平方拟合值：

其中，c 和 b 为常量，函数 ln 为自然对数。

显示 指数

使用下列公式计算数据点的最小平方拟合值：

其中，c 和 b 为常量，e 为自然对数的底数。

显示 乘幂

使用下列公式计算数据点的最小平方拟合值：

其中，c 和 b 为常量。

显示 移动平均

注释 移动平均趋势线中的数据点个数等于数据系列中数据点的总数减去移动平均周期的个数。

显示 R 平方值

R 平方值也称为决定系数，它是取值范围为 0 到 1 的指示器，并显示了趋势线的估计值与实际数据的吻合度。如果趋势线的 R 平方值等于或接近 1，则此时的趋势线最可靠。当使用趋势线拟合数据时，Microsoft Office 图表组件将使用下列公式自动计算趋势线的 R 平方值：

注释 趋势线可以显示的 R 平方值不是已经过调整的 R 平方值。对于对数、乘幂和指数趋势线，“Microsoft Office 图表组件”会使用转换后的回归模型。


将趋势线添加到数据序列中

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 单击要向其添加趋势线的数据系列。
  3. 在图表的工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。
  4. 在“添加”之下，单击“添加趋势线” 按钮图像 。

注释 线性趋势线，即其公式和 R 平方值位于数据系列中。其他趋势线类型包括：对数趋势线、多项式趋势线、乘幂趋势线、指数趋势线和移动平均趋势线。


更改趋势线

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 单击要更改的趋势线。
  3. 在图表工具栏上，单击“命令和选项” 按钮图像 ，再单击“趋势线”选项卡。
  4. 请执行下列一项或多项操作：
    • 若要更改趋势线的类型，请单击“类型”框旁的箭头，然后选择列表中的一个类型。

    • 若要更改多项式趋势线的顺序，请单击“阶数”框旁的箭头，然后从列表中选择要作为自变量最高阶的数字。

    • 若要更改图例中的趋势线名称，请单击“名称”下的“自定义名称”复选框，然后在右边的框中键入新名称。

    • 若要显示或隐藏用于计算趋势线的公式，请选中或清除“显示公式”复选框。

    • 若要显示或隐藏 R 平方值，请选中或清除“显示 R 平方值”复选框。


删除趋势线

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 单击要删除的趋势线。
  3. 按 Delete。


显示或隐藏趋势线公式或 R 平方值

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 单击要显示或隐藏其公式或 R 平方值的趋势线。
  3. 在图表工具栏上，单击“命令和选项” 按钮图像 ，再单击“趋势线”选项卡。
  4. 在“公式”下，选中或清除“显示公式”复选框或“显示 R 平方值”复选框，或者两者都选中或清除。


关于误差线

误差线用图形的方式表示了数据系列中每个数据标签的潜在误差。例如，可以在科学实验结果中显示正负 5% 的潜在误差：

支持误差线的图表 可以向柱形图、条形图、折线图、XY 散点图、气泡图、面积图、雷达图、股价图和极图的数据系列中添加误差线。对于 XY 散点图、极图和气泡图，可以显示 X 值或 Y 值的误差线。如果将图表更改为不支持相关误差线的类型，那么将丢失误差线。


计算误差线中误差量的公式

显示 标准偏差

式中：

s = 系列序号

I = 数据系列 s 中的数据点序号

m = 图表中 Y 点的系列序号

n = 每个数据系列中的数据点个数

变量 = 系列 s 以及第 i 个数据点的数据值

变量 = 所有系列中数据值的总数

M = 算术平均值

显示 标准误差

式中：

s = 系列序号

I = 数据系列 s 中的数据点序号

m = 图表中 Y 点的系列序号

n = 每个数据系列中的数据点个数

yis = 系列 s 以及第 i 个数据点的数据值

ny = 所有系列中数据值的总数


将误差线添加到数据系列中

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 单击要向其添加误差线的数据系列。
  3. 在图表工具栏上，单击“命令和选项” 按钮图像 ，再单击“常规”选项卡。
  4. 在“添加”之下，单击“添加误差线” 按钮图像 。


更改误差线

选择误差线后，用户所做的任意更改都将影响与其相关联的数据系列中的所有误差线。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 单击图表中的任意误差线。
  3. 在图表工具栏上，单击“命令和选项” 按钮图像 ，再单击“误差线”选项卡。
  4. 请执行下列一项或多项操作：
    • 若要显示或隐藏误差线上的末尾字母，请单击“显示” 按钮图像 旁的箭头，再单击所需类型。

    • 若要选择不同类型的误差线（正偏差或负偏差或同时选择两者），请单击“刻度线标志” 按钮图像 旁的箭头，然后单击所需误差线类型。

    • 若要更改用于确定误差量的方法，请在“误差计算”列表中单击所需方法，然后在“误差”框或“百分比”框中键入所需数值。

    • 若要更改误差线的方向，以使它们能根据 XY 散点图、极图和气泡图的 X 值或 Y 值进行计算，请单击“方向”列表中的“X”或“Y”。


删除误差线

不能单独删除单条误差线，只能将整个数据系列的所有误差线同时删除。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 单击要删除误差线的数据系列中的任意一条误差线。
  3. 按 Delete。


关于在图表中筛选数据

使用筛选功能可以查找特定数据值或查找满足特定值的所有数据。您可以在设计图表时进行筛选，用户可在浏览器中查看图表时进行筛选（除非您限制用户在浏览器中使用筛选）。

显示 筛选技术

筛选字段（自动筛选） 可以对分类、系列和筛选区域中的字段进行筛选。筛选字段时，在字段中选择要查看的一个或多个数据项，并隐藏其他数据项。

如果您具有大量源数据，但您只关注特定区域的数据，则此时筛选就特别有用。筛选字段时，可以显示单个数据项的数据，或者可以选择显示某些数据项而隐藏其他数据项。可一次对多个字段进行筛选以进一步缩小关注范围。

标注 1 分类字段区域显示所有数据项（未筛选）

标注 2 分类字段区域经过筛选显示“南部”和“西部”区域中的数据项

条件筛选 可以对系列或数据点应用筛选，以便从总数中选择显示前面或后面的 n 项。例如，可以筛选销售额最高的三个城市或利润最低的五种产品。您也可以按照一定百分比筛选数据项而不是选择 n 项来进行筛选。例如，您可基于已处理订单的数量，筛选出排名前 25% 或后 25% 位的销售人员。如果有 40 位销售人员，经过筛选后就可以看到 10 位销售人员的数据。

显示 组合多个筛选

筛选可以相加。可将所应用的每一个筛选添加到已经起作用的筛选中。

显示 删除和重新应用筛选

关闭自动筛选后可显示所有字段的全部数据。但筛选设置仍然保留，这样在重新启动自动筛选时，以前显示或隐藏的数据将再次显示或隐藏。

当您移动字段更改版式时，筛选设置仍然保留。同样，如果删除某字段，稍后又将该字段重新添加到版式中，则相同的数据项将再次隐藏。

如果不需要保留筛选选项，则请确保在开始选择筛选项之前“自动筛选”按钮 按钮图像 未被选中。如果未选中按钮，则选择新的筛选项将自动启动筛选并删除以前的筛选设置。

显示 识别当前正在起作用的筛选

当字段中的数据项经自动筛选而隐藏时，该字段标志中的下拉箭头 字段箭头 为蓝色。单击该蓝色箭头 蓝色箭头 可查看正在起作用的筛选。

显示 限制在浏览器中进行筛选

如果不希望用户更改筛选数据的方式，可将筛选设为运行时用户不可用。


在图表中筛选字段

显示 筛选分类、系列或筛选区域（自动筛选）中的字段

如果筛选区域中没有字段，您可以向其中添加一个新字段，或者从其他区域中移动一个字段到该区域中。
  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 单击包含要筛选数据项的字段的箭头 字段箭头 。
  3. 选中与需要显示的数据项对应的复选框，清除与需要隐藏的数据项对应的复选框。

注释

  • 若要显示或隐藏某字段中的全部数据，请选中或清除“全部显示”复选框。带阴影的复选框指示隐藏了某些数据项。
  • 当字段位于分类、系列或筛选区域中时，它始终支持多重选定区域。筛选区域中的字段可支持单个选定区域或多重选定区域。

显示 筛选系列或数据点中前面或后面的 n 项值，或按一定的百分比筛选数值（条件筛选）

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 选取包含要筛选的数值的字段、系列或数据点。
  3. 在工具栏上，单击“命令和选项” 字段箭头 ，再单击“筛选和分组”选项卡。
  4. 在“显示”框中，单击“上”或“下”。
  5. 将“项目”设置为列表中的某个数字，或键入所需值。
  6. 若要显示 n 个数据项，请清除“%”复选框；若要显示总数据项的 n%，请选中“%”复选框。
  7. 将“基于”设置为列表中的一个值。


取消筛选以显示图表中的所有数据

当字段中的数据项经过筛选而隐藏时，该字段标志中的箭头 字段箭头 为蓝色。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 请执行下列操作之一：

    显示 取消所有筛选

    • 单击工具栏上的“自动筛选”按钮 按钮图像 以使其不被选中。

    注释 如果再次单击“自动筛选” 按钮图像 以重新启动筛选，则将恢复以前设置的筛选。

    显示 取消字段的自动筛选

    1. 单击要取消其筛选的字段的蓝色箭头 蓝色箭头 。
    2. 选中“（全部）”复选框，再单击“确定”。

    显示 取消条件筛选

    1. 选取要从中取消条件筛选的系列或数据点。
    2. 单击工具栏上的“显示最上面/最下面的项目” 按钮图像 ，再单击“全部显示”。

注释

  • 如果不需要保留筛选，则请确保在开始选择筛选项之前“自动筛选”按钮未被选中。如果未选中按钮，则选择新的筛选项将自动启动筛选并删除以前的筛选设置。
  • 通过清除“命令和选项”对话框的“显示/隐藏”选项卡上的“允许透视筛选”复选框，可以防止用户在浏览器中取消筛选。


对筛选区域中的字段设置多项或单项选择

可以指定筛选区域中的字段允许单项还是多项选择。在单项选择模式下，选中某个项后，该项的前一项将自动清除被选中状态。在多项选择模式下，选中某项时，以前选中的项将继续保持选中状态。

  1. 在设计窗口中，请确保图表被激活。有关指导，请参阅设计程序中的“帮助”。
  2. 选取需要改变其设置的字段。该字段不应在筛选区域中，而应在图表的其他某个区域中，例如系列或分类区域。
  3. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“筛选和分组”选项卡。
  4. 选中或清除“在筛选区内允许选择多个项目”复选框。

    当字段被移动到筛选区域中时，将会反映出这种新设置。

注释

  • 默认情况下，多项选择将被启用。
  • 只有当字段在筛选区域中时，这种设置才有效。如果将字段移动到分类或系列区域，则字段将总是支持多项选择。


展开或折叠字段中的数据项

可展开或折叠系列字段或分类字段中的数据项，以显示或隐藏某特定数据项的更详细的信息。展开类似于深化，只不过同级的数据项不被隐藏。在本示例中，“西部”被展开以显示有关西部的详细信息，但是仍然显示其他地区的信息，只是没有详细信息。折叠则将删除数据项的详细信息，将图表返回到展开前的状态。

标注 1 显示每一地区销售额的图表。

标注 2 “西部”被展开以显示每种产品在西部地区的销售额的图表。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 单击包含要展开或折叠的数据项的字段。
  3. 在工具栏上，单击“展开” 按钮图像 或“折叠” 按钮图像 。


深化字段中的数据或取消深化

可以深化外部分类字段中的数据项，以集中显示该数据项的详细信息，或者可以取消深化以删除该数据项的详细信息。深化类似于展开，不同之处在于，深化数据项时会隐藏与其平级的其他数据项。

在本示例中，“北方”地区被深化，因而显示了“北方”地区的详细信息，隐藏了其他地区的全部信息。当取消深化某数据项后，该数据项的详细信息会被删除，而与之平级的其他数据项将重新显示。

标注 1 按地区显示产品销售额信息的图表

标注 2 显示被深化的“北方”地区数据项的图表。该图表只显示“北方”地区每种产品的销售额信息，但隐藏其他地区的数据项。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 单击要深化或取消深化的分类轴上的数据项。
  3. 在工具栏上，单击“深化数据” 按钮图像 或“取消深化数据” 按钮图像 。


在图表中排序数据

在基于数据透视表列表、数据库的表或查询的图表中，可对其中的分类和系列数据进行排序。

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 请执行下列操作之一：
    • 如果要对系列中的数字型数据排序，请单击该系列或系列中的某个系列点。
    • 如果要对字段中的数据项按字母顺序进行排序，请单击该分类或系列字段，或者单击分类轴标志或图例项。
  3. 请执行下列操作之一：
    • 单击工具栏上的“升序排序” 按钮图像 或“降序排序” 按钮图像 。
    • 对于堆积条形图、堆积面积图或堆积柱形图，如果您要根据整个堆积值的高度而不是单个系列来进行数值排序，请用鼠标右键单击系列或点，指向“排序”，再单击“按汇总升序”或“按汇总降序”。


在图表中对数据进行分组或取消数据分组

  1. 在设计窗口中，请确保图表已激活。有关指导，请参阅设计程序中的“帮助”。
  2. 选取要对其中的数据项进行分组或取消分组的分类或系列字段。
  3. 在工具栏上，单击“命令和选项” 按钮图像 ，再单击“筛选和分组”选项卡。
  4. 请执行下列操作之一：

    显示 对数据进行分组

    1. 在“分组”下，将“项目分组依据”设置为除“（没有分组）”之外的其他值。
    2. 将“间隔”设为所需的值。为字段指定的间隔类型取决于字段的数据类型。
      • 数值字段 可按任意整数（如，1、2、5、100，等等）为间隔进行分组。例如，可将“雇员 ID”字段分组为 1–100、101–200，等等。
      • 日期和时间字段 可以日、星期和季度为间隔来进行分组。例如，可将“发货日期”字段中的数据以月为间隔进行分组，以显示一月发货的数据、二月发货的数据，等等。
      • 文本字段 可以根据各数据项的前 n 个字符来分组。例如，可以将“姓氏”字段按首字母分组为 A 组、B 组，等等。
    3. 若要为数字型间隔指定分组开始或结束时的值，请选中“起始于”或“结束于”这两个复选框之一，或二者都选中，再在相邻的文本框中输入数值。

    显示 取消数据分组

    • 将“项目分组依据”的值设为“（没有分组）”。


图表数据字段可用的汇总函数

下表列出了“自动计算”命令 按钮图像 提供的用于汇总数据字段的汇总函数。

函数 | 说明
求和 | 计算数值的和。
计数 | 统计值的个数。空值如空字符串（即不包含字符的字符串）包含在计数中，但 null 值（代表丢失或未知数据的值）不包含在内。
最小值 | 返回进行汇总的字段中的最小值。
最大值 | 返回进行汇总的字段中的最大值。
平均值 | 返回进行汇总的字段中的平均值。
标准偏差 | 返回进行汇总的字段中值的标准偏差，假设值是一个较大总体的某个样本。
标准偏差总体 | 返回进行汇总的字段中值的标准偏差，假设值是整个总体。
方差 | 返回进行汇总的字段中值的方差，假设值是一个较大总体的某个样本。
方差总体 | 返回进行汇总的字段中值的方差，假设值是整个总体。

注释 字段可用的汇总函数取决于字段中的数据类型。例如，如果字段包含文本，则该字段只能使用 Count 函数。


图表疑难解答

显示 无法找到所需的命令或选项

如果在“命令和选项”对话框中找不到所需的命令或选项，则可能是由于在图表中没有选定必要的项。若要确保选定了正确的项，请单击“命令和选项”对话框中的“常规”选项卡，然后在“选择”框中，单击要处理的图表项。则用于该图表项的选项将出现在“命令和选项”对话框中。

显示 图表的左下角出现一个感叹号

被动警报指示图表中包含一个错误。该警报在图表的左下角显示一个感叹号。被动警报出现在错误情况下，例如，无法找到纹理文件，或数据库连接失败。单击感叹图标可查看有关该错误的详细信息。

显示 无法使用鼠标移动或调整图表项的大小

无法用鼠标移动或调整图表项（例如图例、绘图区、数据标签和标题）的大小。但是，可以使用“命令和选项”对话框中适当的选项卡上的“位置”设置来移动某些图表项，例如图例或某些轴。“命令和选项”对话框中的其他设置还允许对图表绘图区进行旋转或翻转，可以抽出饼图或圆环图中的扇区，调整在标签、标题和图例中使用的字体的大小，以及调整某些图表类型中的数据标志的大小。而其他图表项会在图表大小发生更改时自动进行调整。

显示 无法向图表中添加文本

可以向图表中添加标题，而且可以向图表坐标轴上添加标题。也可以向数据标志中添加数据标签。但不能向图表中添加自由浮动文本。如果必要，可以向包含图表的网页中添加文本。

显示 图表水平 (X) 坐标轴上的文本丢失

可能是图表没有足够空间来显示所有的坐标轴标签。如果某些分类名称在图表的水平坐标轴上不可见，请尝试下列解决方法：

  • 扩大图表。请参阅设计程序中的“帮助”以了解如何选择和调整图表控件的大小。
  • 水平 (X) 轴上的文字使用较小的字号。
  • 缩短源数据中的分类名称。

显示 XY 散点图没有沿水平 (X) 坐标轴使用正确的值

如果分类 (X) 轴显示诸如 1、2、3、4 等数字，而不是所需的值，则可能需要创建折线图，而不是 XY 散点图。如果图表在设计程序中处于激活状态，请单击该图表，再单击工具栏上的“图表类型” 按钮图像 ，然后单击“类型”选项卡上的列表中的“XY 散点图”，再从右边显示的子类型中选择要使用的子类型。如果希望用线条连接各数据标志，请单击有连线的子类型之一。

显示 通过 Excel 发布图表后，图表中具有的数据比在 Excel 中时多

在 Microsoft Excel 中，可以指定图表只绘制可见单元格。如果启用此设置，则图表将不会反映创建图表的数据区域中隐藏行或列中的数据。但是发布图表时，所有数据都会反映在图表中。

如果不希望图表反映出隐藏的数据，则应该取消工作表中行或列的隐藏状态，并在发布图表之前将这些数据移动到用于创建图表的数据区域之外。有关在工作表中移动数据的详细信息，请参阅 Excel 的“帮助”。若要在发布后更改图表，则可以取消隐藏并删除行或列（并不希望这些行或列中所包含的数据显示在随图表一起发布的电子表格中）。有关删除行或列的详细信息，请参阅电子表格组件的“帮助”。

显示 通过 Excel 发布了图表，但在设计程序或浏览器中查看图表时却发现该图表中没有数据

若要通过 Microsoft Excel 向 Web 上发布图表，则 XY 散点图必须同时包括 X 值和 Y 值，而气泡图必须同时包括 X 和 Y 值以及气泡的大小值。如果 X 值不在数据选定区域中，则 Excel 会提供默认值。而这些值只会显示在 Excel 的图表中，但在将图表发布到网页上时，这些值不会保留。

如果图表没有包含所有必需的值，那么请在 Excel 中将这些值键入到与图表原始数据相邻的列中，重新创建图表，然后再发布该图表。

显示 当我试图显示或刷新 Microsoft Internet Explorer 上的图表，看到提示信息：“该页正在访问其控制范围之外的信息。这有些危险。是否继续?”

您已为网站上的其他域中的图表指定数据源。如果不想被提示，可更改跨域访问数据的方式。有关详细信息，请参阅关于访问不同域中的数据源。

显示 网页上应显示图表的位置却显示为空框

在浏览器中 只可在 Microsoft Internet Explorer 5.01 SP2 和更高版本中查看 Web 图表并与 Web 图表进行交互。

在设计程序中 可以在 Microsoft Office FrontPage 2003、Microsoft Office Access 2003 和 Microsoft Visual Basic 中查看和修改已发布的图表。而图表在其他设计程序中则可能显示为空白框。

显示 用户不能在浏览器中显示图表或与图表进行交互

安装 Microsoft Office Web Components 若要查看和处理 Web 图表，则用户必须安装 Office Web 组件。可以通过安装 Microsoft Office 2003 来安装该组件；或者，如果用户的公司具有 Microsoft Office 2003 站点许可证，则可以通过 Intranet 下载组件。

检查浏览器版本 若要与图表进行交互，用户需要使用 Microsoft Internet Explorer 5.01 SP2 或更高版本。建议用户使用 Internet Explorer 5.01 SP2 或更高版本，以便最大限度地利用图表及其源数据的交互式功能。若要了解不同浏览器版本中与图表源数据的交互性级别，请参阅源数据的“帮助”。

显示 Web 图表在浏览器中不进行更新

如果通过 Microsoft Excel 发布了图表，则可能是没有选择发布具有交互式功能的图表。如果发布的图表没有交互式功能，则显示在浏览器中的图表将是静态的，并且没有连接到数据上。

若要发布具有交互式功能的图表，请在 Excel 中打开原始工作簿，选择图表，再单击“文件”菜单上的“另存为网页”。在“另存为”对话框中，单击“选择：图表”，并选中“添加交互”复选框。

显示 在 Web 浏览器中单击“编辑”按钮时选择了错误的程序打开网页。

在单击 Web 浏览器中的“编辑”按钮时可选择的程序取决于网页的发布方式。

如果在 Web 浏览器中单击“编辑”按钮时打开了不希望使用的程序，那么请关闭此程序，并启动要使用的程序，然后在该程序中打开网页。

显示 我的三维图表显示为二维图表。

如果正在使用 Microsoft Windows 的版本早于 Windows XP，则可能没有安装 Microsoft DirectX。从 Microsoft.com 下载中心安装 DirectX 便可显示三维图表。