欢迎使用 SharePoint 产品和技术配置向导的帮助系统

本帮助系统的内容：

  • 欢迎使用 SharePoint 产品和技术配置向导
  • 操作方法：配置代理服务器设置
  • 操作方法：启用 Internet 信息服务
  • 操作方法：修复 SharePoint 产品和技术
  • 操作方法：验证 ASP.NET 版本
  • 操作方法：验证 Windows Workflow Foundation 版本
  • 连接到服务器场
  • 指定配置数据库设置
  • 配置 SharePoint 管理中心 Web 应用程序
  • 确认设置
  • 高级设置
  • 配置 SharePoint 产品和技术
  • 配置完成
  • 删除 SharePoint 管理中心网站
  • 修改服务器场设置
  • 替换默认 SharePoint 网站
  • 删除过程中配置失败
  • SharePoint 产品和技术配置向导的命令行参考


配置 SharePoint 管理中心 Web 应用程序

您可以配置 SharePoint 管理中心 Web 应用程序和安全设置。

端口号

使用 SharePoint 管理中心 Web 应用程序，可以管理 SharePoint 服务器场的配置设置。为服务器场添加的第一台服务器是此网站的宿主。如果需要指定端口号，可使用从 1 到 65535 之间的任何一个数字，不过建议您避免使用常用端口范围中的编号。

端口号分为以下三个范围：

  • 常用端口从 0 到 1023。
  • 注册端口从 1024 到 49151。
  • 动态或专用端口从 49152 到 65535。

如果以后需要更改端口号，则必须再次运行“SharePoint 产品和技术配置向导”。该配置向导将会更新配置数据库中的端口号并创建一个作业，该作业将更新此服务器场的其他服务器上每个 SharePoint 管理中心 Web 应用程序中的端口号。

注释 不支持在 Internet 信息服务 (IIS) 管理器中手动更改 SharePoint 管理中心 Web 应用程序的端口号。您必须再次运行该配置向导。

安全设置

NTLM 和 Kerberos 两种验证协议都受支持。

NTLM

默认设置（NTLM 协议）基于一种“提问 - 答复”机制来进行客户端验证。SharePoint 产品和技术中提供了 NTLM，以便与只能使用 NTLM 验证的系统进行通信。

协商 (Kerberos)

Kerberos 版本 5 协议是用于域内验证的主要安全协议。Kerberos 验证使用一种服务票证系统，该系统验证用户以及网络服务的身份。这样的双重验证被称为相互验证。 该系统会先试图通过 Kerberos 协议协商验证，但如果不成功，则使用 NTLM 协议。

为了启用 Kerberos 验证，您必须执行其他配置。有关详细信息，请参阅 Windows Server 2003 中的 Kerberos 验证。


删除 SharePoint 管理中心网站

使用 SharePoint 管理中心网站，可以在本地或以远程方式执行管理任务。每个服务器场中至少必须有一个 SharePoint 管理中心网站。

可以使用此页上的选项来保留或删除 SharePoint 管理中心网站。


配置完成

当“SharePoint 产品和技术配置向导”完成了所有必需的配置任务后，您就可以使用 SharePoint 3.0 管理中心来配置网站了。

配置成功

当成功完成了必要的配置任务后，如果您执行的是“基本”安装，可单击“完成”，以关闭配置向导。默认网站的主页会打开。

如果您执行的是“高级”安装或升级，您输入的配置设置会显示出来，然后您可以单击“完成”，以关闭配置向导。SharePoint 3.0 管理中心即会打开。

如果您执行的是修复，请单击“关闭”，以退出配置向导。

注释 如果您使用的是 Microsoft Internet Explorer，并且没有修改默认设置，将会启用“扩展的安全性”。当配置向导启动 Internet Explorer 时，会出现一条弹出信息，提示您将该网站添加到受信任网站列表。

配置错误

如果一项或多项配置任务中有错误，事件日志和安装日志中会写入事件。为了让您能够判断问题原因，会显示有关配置向导失败时正在运行的配置任务的详细信息、任何特定的错误信息，以及指向日志的链接。

注释 如果在删除过程中发生错误，您可以在删除过程中的配置错误查找详细信息。


修改服务器场设置

您可以使用此页上的选项来修改服务器场设置。将显示承载配置数据库的服务器的名称以及配置数据库的名称。

如果要断开此计算机与此服务器场的连接，请选择“断开与此服务器场的连接”，然后单击“下一步”。当配置向导完成时，此计算机将不再承载 SharePoint 管理中心网站，并将立即从 SharePoint 服务器场中删除。

可以在以后运行配置向导，将该计算机加入另一服务器场。


配置 SharePoint 产品和技术

“SharePoint 产品和技术配置向导”执行以下配置任务：

  • 配置数据库访问。在“基本”安装中，会安装并配置嵌入式数据库引擎。
  • 安装并配置功能和服务。
  • 配置安全性。
  • 创建示例数据。

注释 对于每项配置任务必须在多长时间内完成，没有时间限制。

如果配置向导在执行某项配置任务时遇到错误，该向导就不会再执行任何其他配置任务。“配置完成”屏幕会出现，并带有配置错误信息和指向日志文件的链接，您可以使用该日志文件来解决导致错误的问题。

如果您取消配置向导，已经完成的配置任务不会回滚；要完成服务器的部署，必须执行其余配置任务。要执行其余配置任务，您必须稍后再次运行配置向导。

运行升级前扫描工具

如果执行升级，首先必须使用升级前扫描工具扫描网站。如果您还未运行此工具，却试图运行“SharePoint 产品和技术配置向导”，则该向导将退出，并提示您运行此工具。

注释 您必须是本地计算机上管理员组的成员，才能运行此工具。

  1. 在命令行中，切换到硬盘上的 c:\program files\common files\microsoft shared\web server extensions\12\bin 文件夹，然后运行以下命令扫描服务器场中的所有服务器：
    prescan.exe /all

    运行此工具可能只需几分钟，也可能需要几小时，具体取决于您环境中内容的多少。

  2. 扫描完成后，会在命令行窗口中显示摘要报告。

升级服务器场

如果要升级服务器场，必须按照以下过程执行操作：

  1. 在场中的第一台前端 Web 服务器上运行安装程序，然后运行“SharePoint 产品和技术配置向导”。
  2. 当看到关于在场中的其他服务器上运行安装程序的消息时，必须在其他服务器上运行安装程序和“SharePoint 产品和技术配置向导”，以保持同步。
  3. 在场中的所有服务器都显示该消息后，返回到第一台 Web 服务器，单击“确定”继续第一台服务器的升级过程。
  4. 在第一台服务器上完成向导后，可以配置其他每一台服务器。

有关升级服务器场的详细信息，请参阅升级和迁移指南。

安全帐户要求

要在服务器场环境中部署 SharePoint 产品和技术，您将需要一个可用来安装该产品或技术以及运行“SharePoint 产品和技术配置向导”的用户帐户。此帐户必须是可以指定为 Windows SharePoint Services 3.0 服务帐户的唯一域用户帐户。此帐户用于访问配置数据库。数据库访问帐户既用于初始数据库配置，也用于此场中服务器与数据库的当前连接。

要点 确保域所包含的组策略不会阻止被选作数据库访问帐户的帐户作为服务来运行。

此帐户还作为 SharePoint 管理中心应用程序池的应用程序池标识，它是 Windows SharePoint Services 定时服务在运行时所使用的帐户。建议您遵循最小权限原则，不要使此用户帐户成为前端服务器或后端服务器上任何特定安全组的成员。


操作方法：修复 SharePoint 产品和技术

此过程用于以“修复”模式启动“SharePoint 产品和技术配置向导”。

  1. 单击“开始”，单击“控制面板”，然后单击“添加或删除程序”。
  2. 选择要修复的“SharePoint 产品和技术”安装，然后单击“更改”。
  3. 在“设置向导”中，选择“修复”，然后单击“继续”。此时会执行二进制文件验证。
  4. 在“设置向导”的最后一屏上，选择“立即运行 SharePoint 产品和技术配置向导”，然后单击“关闭”。
  5. “SharePoint 产品和技术配置向导”会自动以“修复”模式调用，检测丢失的组件，然后确定原来所选择的安装模式。
  6. 如果该安装是多服务器部署，则会提示您提供应用程序池凭据。
  7. 请提供应用程序池的 Run-as 帐户的凭据。
  8. 配置向导会验证前提条件并执行修复配置所需的任务。


删除过程中配置失败

当您从“添加或删除程序”中选择“删除”时，“设置向导”会启动，然后它会以无提示模式调用“SharePoint 产品和技术配置向导”。如果配置向导没有遇到任何错误，则不会显示任何屏幕。如果遇到了错误，会将失败代码返回到“设置向导”，并且配置向导会显示“配置失败”屏幕。

“配置失败”屏幕会提供有关失败的信息以及指向日志文件的链接。要确定失败的原因，您可以检查该日志文件中的错误信息。在了解了发生错误的原因后，您可以解决问题，然后可以选择停止卸载进程并解决问题，然后再次运行“删除”，也可以选择继续进行卸载。

如果在遇到错误时退出设置，二进制文件将不会被删除。不过，已成功完成的任务不会回滚。利用此方法，您可以通过以“修复”模式运行配置向导将服务器恢复到工作状况。

如果您选择继续执行卸载进程，二进制文件将会被删除。计算机的最终状态将取决于配置向导在何时失败。例如，计算机可能仍然会：

  • 加入服务器场。
  • 在配置数据库中注册并且本地计算机上的连接字符串可能存在。
  • 有服务运行。

删除了二进制文件后，您将无法使用配置向导来清除本地计算机上或配置数据库中的配置设置。


欢迎使用“SharePoint 产品和技术配置向导”

“SharePoint 产品和技术配置向导”会执行一些基本任务，这些任务对用户干预需求最少，而且是启动 SharePoint 管理中心所必须执行的，或者是无法在其他地方执行的。

除使用该配置向导来执行初始配置以外，还可以随时使用该配置向导来执行以下操作：

  • 标识缺少的组件。
  • 验证配置。
  • 标识、修复或重置安全性和低级配置设置。

配置向导可能需要启动、停止或重置 SharePoint 管理服务、SharePoint 定时服务、Internet 信息服务 (IIS)，以及来自其他依靠 Windows SharePoint Services 并且已相应注册的应用程序的服务。

如果您不想中断服务器运转，请单击“否”退出配置向导。

注释 您必须先成功完成配置向导，然后才能完成服务器部署并访问 SharePoint 管理中心来配置您的网站。

配置向导完成后，运行管理中心所需的服务将会被启用。然后，您必须使用管理中心来配置您的网站。

操作之前的条件

在安装、配置或操作服务器之前，必须先具备以下条件：

  • 安装了 Windows Server 2003（带 Service Pack 1 或更高版本），而且您必须是 Administrators 组的成员。
  • 启用并配置了 Microsoft Internet 信息服务 (IIS) 6.0。有关详细信息，请参阅操作方法：启用 Internet 信息服务。
  • 安装了 Microsoft .NET Framework 2.0 的正确版本。有关详细信息，请参阅操作方法：验证 ASP.NET 版本。
  • 安装了 Windows Workflow Foundation 的正确版本。有关详细信息，请参阅操作方法：验证 Windows Workflow Foundation 版本。
  • 如果您要在单服务器以外的其他配置中安装 SharePoint 产品和技术，同一台计算机上或服务器场中另外一台计算机上必须有 Microsoft SQL Server 2000 SP3 或更高版本或 SQL Server 2005。
  • 要在服务器场环境中部署 SharePoint 产品和技术，您将需要一个可用来安装该产品或技术以及运行“SharePoint 产品和技术配置向导”的用户帐户。此帐户必须是可以指定为 Windows SharePoint Services 3.0 服务帐户的唯一域用户帐户。此帐户用于访问配置数据库。数据库访问帐户既用于初始数据库配置，也用于此场中服务器与数据库的当前连接。

    要点 确保域所包含的组策略不会阻止被选作数据库访问帐户的帐户作为服务来运行。

    此帐户还作为 SharePoint 管理中心应用程序池的应用程序池标识，它是 Windows SharePoint Services 定时服务在运行时所使用的帐户。建议您遵循最小权限原则，不要使此用户帐户成为前端服务器或后端服务器上任何特定安全组的成员。

基本

在单服务器环境中部署 SharePoint 产品和技术将使用默认设置在一台计算机上安装所有组件和功能。配置向导不会要求您提供任何配置设置或凭据，而是会使用默认值来创建启动管理中心所需的 Web 应用程序、核心服务和标准安全组。

如果您在“设置向导”中选择了以下选项之一，配置向导就会使用默认设置：

  • “基本”
  • “高级”，然后选择“独立”
  • “修复”
  • “升级”

    注释 如果您在“设置向导”中选择了“升级”，则会使用默认设置执行单服务器独立安装。

高级

如果您在“设置向导”中选择“高级”选项，就可以利用配置向导来在服务器场中进行安装、使用现有数据库、部署一个新服务器场或连接到现有服务器场。您可以创建新数据库或使用现有数据库。在服务器场中，一台或多台计算机可以是 Web 服务器，而另一台计算机可以通过 Microsoft SQL Server 提供数据库服务。

配置向导将提示您提供创建核心元素（例如，创建管理中心 Web 应用程序和创建新配置数据库）所需的凭据。

修复

您可以使用“修复”来覆盖已更改或已损坏的文件和注册表设置。

例如，如果您无法在正常工作的场中启动管理中心，就可以使用“修复”。如果无意中删除了 IIS 管理 Web 应用程序，就会出现这种情况。

当您修复安装时，配置向导会对已安装的文件进行验证，检测缺少的组件，然后对配置进行修复。

有关信息，请参阅操作方法：修复 SharePoint 产品和技术。

升级

您可以升级到最新版本的 SharePoint 产品和技术。

运行升级前扫描工具

如果执行升级，首先必须使用升级前扫描工具扫描网站。如果您还未运行此工具，却试图运行“SharePoint 产品和技术配置向导”，则该向导将退出，并提示您运行此工具。

注释 您必须是本地计算机上管理员组的成员，才能运行此工具。

  1. 在命令行中，切换到硬盘上的 c:\program files\common files\microsoft shared\web server extensions\12\bin 文件夹，然后运行以下命令扫描服务器场中的所有服务器：
    prescan.exe /all

    运行此工具可能只需几分钟，也可能需要几小时，具体取决于您环境中内容的多少。

  2. 扫描完成后，会在命令行窗口中显示摘要报告。

升级服务器场

如果要升级服务器场，必须按照以下过程执行操作：

  1. 在场中的第一台前端 Web 服务器上运行安装程序，然后运行“SharePoint 产品和技术配置向导”。
  2. 当看到关于在场中的其他服务器上运行安装程序的消息时，必须在其他服务器上运行安装程序和“SharePoint 产品和技术配置向导”，以保持同步。
  3. 在场中的所有服务器都显示该消息后，返回到第一台 Web 服务器，单击“确定”继续第一台服务器的升级过程。
  4. 在第一台服务器上完成向导后，可以配置其他每一台服务器。

有关升级服务器场的详细信息，请参阅升级和迁移指南。


连接到服务器场

您可以创建新服务器场或管理与现有 SharePoint 服务器场的连接。必须提供数据库服务器名称、数据库名称，以及将用于数据库访问的用户帐户的凭据。

服务器场中的所有服务器都必须使用同一配置数据库。如果该数据库不存在，将会新建一个数据库。如果该数据库的名称与现有数据库相同，则该数据库不得包含任何表、存储过程或其他对象。

请输入 SharePoint 产品和技术将用于数据库连接的用户帐户的凭据。如果配置数据库位于其他计算机上，则该帐户必须是域帐户。

您可以选择下列选项之一：

  • 不修改这些设置
  • 创建新服务器场
  • 连接到现有服务器场
  • 断开与此服务器场的连接

注释 所有这些选项可能都不会出现在您的安装中。显示哪些选项取决于您服务器场的配置和状态。

配置向导会检查是否有到配置数据库的现有连接。如果连接不存在，就会创建一个新服务器场。如果连接存在，则不修改设置。

当管理与现有服务器场的数据库连接时，配置向导会确保服务器场中存在一个或多个 SharePoint 管理中心 Web 应用程序，而且这些程序已在配置数据库中注册。这样设计是为了防止出现服务器场存在但没有安装 SharePoint 管理中心 Web 应用程序来管理安装的情况。

如果选择“断开与此服务器场的连接”，配置向导会从服务器场中删除服务器，然后更新服务器场的 SharePoint 管理中心。

如果断开连接的计算机上有 SharePoint 管理中心 Web 应用程序，该程序将会删除，同时会删除配置数据库中的条目。


如何启用 Internet 信息服务

利用此过程，可以启用和配置 Internet 信息服务 (IIS) 6.0 工作进程分隔模式。该过程适用于 Windows Server 2003。

  1. 单击“开始”，单击“所有程序”，单击“管理工具”，然后单击“管理您的服务器”。
  2. 在“管理您的服务器”页上，单击“添加或删除角色”。
  3. 在“预备步骤”窗格中，单击“下一步”。
  4. 在“服务器角色”窗格中，单击“应用程序服务器(IIS，ASP.NET)”，然后单击“下一步”。
  5. 在“应用程序服务器选项”窗格中，选中“启用 ASP.NET”复选框，然后单击“下一步”。
  6. 在“选择摘要”窗格中，单击“下一步”。

    7. 该向导会安装 IIS。完成此过程可能需要几分钟时间。

  7. 单击“完成”。

您可以通过执行以下操作来验证 IIS 的配置是否正确：

单击“开始”，单击“管理工具”，然后单击“Internet 信息服务(IIS)管理器”。

注释 如果 IIS 的安装正确，Internet 信息服务 (IIS) 管理器窗口将会打开。


如何配置代理服务器设置

此过程用于配置网络代理设置。

  1. 单击“开始”，单击“控制面板”，然后单击“Internet 选项”。
  2. 在“Internet 属性”对话框中，单击“连接”选项卡。
  3. 单击“局域网设置”。
  4. 在“局域网(LAN)设置”对话框中的“自动配置”部分中，确保将两个复选框都清空。
  5. 在“代理服务器”部分中，执行以下操作：
    1. 选中“为 LAN 使用代理服务器”复选框。
    2. 在“地址”框中，键入代理服务器的名称。
    3. 在“端口”框中，键入代理服务器的端口号。
    4. 选中“对于本地地址不使用代理服务器”复选框。
  6. 单击“确定”以关闭“局域网(LAN)设置”对话框。
  7. 单击“确定”以关闭“Internet 选项”对话框。


SharePoint 产品和技术配置向导的命令行参考

在 SharePoint 产品和技术中，您可以将 psconfig.exe 命令行工具用作备用界面，在其中执行若干个控制 SharePoint 产品和技术的配置方式的操作。您必须是本地计算机上 Administrators 组的成员才能执行这些操作。

本文内容
  • 如何使用 psconfig.exe 命令
  • 可用的命令和参数

如何使用 psconfig.exe 命令

从命令行中运行 psconfig.exe 时，可以指定命令以控制该工具如何运行。要从命令行中运行 psconfig.exe，请导航到 %WINDIR%\Program Files\Common Files\Microsoft Shared\web server extensions\12\bin 文件夹，然后使用以下语法键入命令：

psconfig.exe -cmd &amp;lt;command&amp;gt; [optional parameters]

下一节中的参考表包含若干个示例。还可以从命令行界面中使用帮助。要查看帮助，请在命令行中键入以下内容：

psconfig.exe -?

要获取有关特定命令的帮助，请键入以下内容：

psconfig.exe -help &amp;lt;command name&amp;gt;

在 psconfig.exe 中的命令需要按照特定的顺序运行才能运行成功。如果您使用 SharePoint 产品和技术配置向导配置您的安装，则它会为您按照正确的顺序调用命令（也称为配置任务）。然而，如果您使用命令行运行 psconfig.exe，则需要确保按照正确的顺序执行任务。psconfig.exe 命令必须按照以下顺序执行：

  1. configdb
  2. helpcollections
  3. secureresources
  4. services
  5. installfeatures
  6. adminvs
  7. evalprovision（仅用于独立安装）
  8. applicationcontent

要点 如果 psconfig.exe 检测到服务器场需要升级，则它将在运行时自动启动升级（即使没有选择升级命令）。

您可以在一个命令行字符串中指定所有要运行的命令。此时，psconfig.exe 将按照正确的顺序运行所有命令。例如，在命令行中，您可以按如下所示运行一个命令：

psconfig.exe –cmd configdb &amp;lt;parameters&amp;gt;
–cmd helpcollections &amp;lt;parameters&amp;gt;
–cmd secureresources &amp;lt;parameters&amp;gt;
–cmd services &amp;lt;parameters&amp;gt;
–cmd installfeatures &amp;lt;parameters&amp;gt;
–cmd adminvs &amp;lt;parameters&amp;gt;
–cmd evalprovision &amp;lt;parameters&amp;gt;
–cmd applicationcontent &amp;lt;parameters&amp;gt;

有关从命令行中配置服务器或服务器场的详细信息，请参阅 Windows SharePoint Services TechCenter。

返回页首

可用的命令和参数

在 SharePoint 产品和技术配置向导中，可识别下列命令行选项。

命令 说明、参数和示例
? 显示可用于 psconfig.exe 的命令

示例

psconfig.exe -?

help &amp;lt;命令名&amp;gt; 显示可用于 psconfig.exe 的命令。如果指定了命令名，则显示该命令的帮助。

示例

psconfig.exe -help adminvs

adminvs 在本地计算机上管理 SharePoint 管理中心 Web 应用程序。使用下列可选的参数：

[-provision]

在此服务器上设置 SharePoint 管理中心 Web 应用程序。设置过程会创建一个新的 SharePoint 管理中心 Web 应用程序，以及一个在服务器场管理员帐户下运行的应用程序池。

[-unprovision]

在此服务器上取消设置 SharePoint 管理中心 Web 应用程序。取消设置会删除 SharePoint 管理中心 Web 应用程序及其应用程序池。

[-port &amp;lt;端口号&amp;gt;]

此 SharePoint 管理中心 Web 应用程序端口是服务器场的一项全局设置。更改该端口时，将调度 SharePoint 定时服务作业，以同步服务器场中所有 SharePoint 管理中心 Web 应用程序的端口。如果没有指定端口，将使用服务器场中现有 SharePoint 管理中心 Web 应用程序所用的端口。如果尚未在服务器场中设置 SharePoint 管理中心 Web 应用程序，则在没有指定端口时将随机选择默认端口。

[-windowsauthprovider &amp;lt;enablekerberos | onlyusentlm&amp;gt;]

此 SharePoint 管理中心 Web 应用程序验证提供程序是服务器场的一项全局设置。更改该验证提供程序时，将调度 SharePoint 定时服务作业，以同步服务器场中所有 SharePoint 管理中心 Web 应用程序上的提供程序。如果指定 onlyusentlm，NTLM 将成为所有 SharePoint 管理中心 Web 应用程序的独占验证提供程序。其他所有验证提供程序将被禁用，NTLM 将是唯一允许的验证提供程序。如果指定 enablekerberos，将对所有 SharePoint 管理中心 Web 应用程序都启用 Kerberos 验证。如果没有指定验证提供程序，将使用服务器场中现有 SharePoint 管理中心 Web 应用程序所用的提供程序。如果尚未在服务器场中设置 SharePoint 管理中心 Web 应用程序，则在没有指定验证提供程序时将会启用 Kerberos 验证提供程序。

示例

psconfig.exe -cmd adminvs -provision -port 8080 -windowsauthprovider onlyusentlm

psconfig.exe -cmd adminvs -unprovision

applicationcontent 管理共享应用程序内容。使用下列必需的参数：

-install

将共享应用程序数据（例如资源文件、Web 应用程序二进制数据）复制到现有 Web 应用程序虚拟目录中。

示例

psconfig.exe -cmd applicationcontent -install

configdb 创建、连接此服务器或将其与服务器场断开连接。使用下列可选的参数：

[-create]

创建新的配置数据库，从而建立新的服务器场。如果此服务器已连接到某配置数据库，将首先断开该服务器的连接，然后创建新的配置数据库。

[-disconnect]

将此服务器与配置数据库断开连接，从而将此服务器与服务器场断开连接。

[-connect]

连接到现有配置数据库，从而将此服务器连接到现有服务器场。如果此服务器已连接到某配置数据库，将首先断开该服务器的连接，然后连接到现有配置数据库。

[-server &amp;lt;SQL 服务器名称&amp;gt;]

配置数据库所在的运行 SQL Server 的计算机。

[-database &amp;lt;SQL 数据库名称&amp;gt;]

配置数据库名称。

[-dbuser &amp;lt;值&amp;gt;]

用于 SQL 验证的用户名。

[-dbpassword &amp;lt;值&amp;gt;]

用于 SQL 验证的密码。

[-user &amp;lt;域\用户&amp;gt;]

服务器场管理员用户帐户。

[-password &amp;lt;密码&amp;gt;]

服务器场管理员用户帐户密码。

[-addomain &amp;lt;值&amp;gt;]

用于服务器场的 Active Directory 域名。

[-adorgunit &amp;lt;值&amp;gt;]

用于服务器场的 Active Directory 组织单位名称。

[-admincontentdatabase &amp;lt;SQL 管理内容数据库名称&amp;gt;]

管理中心 Web 应用程序内容数据库名称。

示例

psconfig.exe -cmd configdb -create -server 服务器名称 -database 数据库名称 -dbuser 域\用户名 -dbpassword 密码 -user 域\用户名 -password 密码 -addomain 域名 -adorgunit 组织单位 -admincontentdatabase 数据库名称

psconfig.exe -cmd configdb -disconnect

psconfig.exe -cmd configdb -connect -server 服务器名称 -database 数据库名称 -dbuser 域\用户名称 -dbpassword 密码

evalprovision 将此服务器设置为独立（评估模式）服务器。使用下列必需的参数和可选的参数：

-provision

在此服务器上执行独立模式设置。

[-port &amp;lt;端口号&amp;gt;]

分配给默认 SharePoint Web 应用程序的端口号。如果未指定，则使用端口 80。如果已存在使用该端口的 SharePoint Web 应用程序，则将替代现有网站。如果正在使用该端口的现有网站不是 SharePoint Web 应用程序，则将禁用该网站，同时使用该端口新建一个 SharePoint Web 应用程序。

[-overwrite]

指定安装期间是否覆盖任何现有的 Microsoft Windows SharePoint Services 3.0 网站。如果未指定，则不删除该网站。

示例

psconfig.exe -cmd evalprovision -provision -port 1100

helpcollections 管理的帮助集合。使用下列必需的参数：

-installall

安装所有可用的帮助集合。

示例

psconfig.exe -cmd helpcollections -installall

installfeatures 向服务器场注册位于此服务器中的文件系统上所有的 SharePoint 产品和技术功能。

示例

psconfig.exe -cmd installfeatures

quiet 在安静模式下运行 SharePoint 产品和技术配置向导。输出会写入到名为 PSCONFIG.EXE_MM_DD_YY_HH_MM_SS_MS.log 的日志文件中，其中“_MM_DD_YY_HH_MM_SS_MS”是运行实用工具的完整日期和时间。该日志文件存储在 %WINDIR%\Program Files\Common Files\Microsoft Shared\web server extensions\12\LOGS 目录下。

示例

psconfig.exe -cmd quiet

secureresources 在服务器上执行 SharePoint 产品和技术资源安全保护。例如，对文件、文件夹和注册表项执行安全保护。

示例

psconfig.exe -cmd secureresources

services 管理 SharePoint 产品和技术服务。使用下列可选的参数：

[-install]

在服务器场中注册位于此服务器上的服务。

[-provision]

设置位于此服务器上的服务，并在以独立模式安装 SharePoint 产品和技术的情况下将服务设置为联机。设置服务还将确保这些服务已注册。

示例

psconfig.exe -cmd services -install

psconfig.exe -cmd services -provision

setup 根据安装模式执行 SharePoint 产品和技术的配置。还会修复该配置。如果产品或服务是在独立模式下安装的，则将执行独立配置。如果产品或技术不在独立模式下，则必须使用 SharePoint 产品和技术配置向导（而不是 psconfig.exe 命令行实用工具）完成初始配置。要运行该向导，请在“开始”菜单上，依次指向“所有程序”、“管理工具”，然后单击“SharePoint 产品和技术配置向导”。

如果要修复独立安装，请首先运行 setup /repair（有关详细信息，请参阅安装帮助系统），然后运行 psconfig.exe -setup。对于服务器场安装，在运行 setup /repair 后，使用 SharePoint 产品和技术配置向导而不是 psconfig.exe 命令行实用工具。

使用下列可选的参数：

[-lcid &amp;lt;1033&amp;gt;]

指定安装语言的区域设置 ID (LCID)。

示例

psconfig.exe -cmd setup

standaloneconfig 执行 SharePoint 产品和技术的独立配置。使用下列可选的参数：

[-lcid &amp;lt;1033&amp;gt;]

指定安装语言的区域设置 ID (LCID)。

示例

psconfig.exe -cmd standaloneconfig

upgrade 执行 SharePoint 产品和技术的升级。如果产品或技术需要升级，则此命令将在运行 SharePoint 产品和技术配置向导时自动运行。使用下列可选的参数：

[-wait]

如果指定此参数，SharePoint 产品和技术配置向导在升级完成后才会返回。如果不指定，则该向导会在调度 SharePoint 定时服务作业来执行升级之后返回。要查看升级作业状态，您可以使用 Web 浏览器来访问 SharePoint 管理中心 Web 应用程序。

[-force]

如果指定此参数，SharePoint 产品和技术配置向导将停止任何当前运行的升级操作，然后重新启动升级。

[-reghostonupgrade]

如果指定此参数，SharePoint 产品和技术配置向导将在升级过程中将所有内容重置为网站定义版本。

[-finalize]

如果指定此参数，SharePoint 产品和技术配置向导将完成当前升级。仅当您已经成功升级所有网站且不再需要连接到以前的版本时，才执行此操作。您将无法撤消此操作。

[-inplace &amp;lt;v2v|b2b&amp;gt;]

如果指定此参数，SharePoint 产品和技术配置向导将执行就地升级。如果指定 v2v，将执行就地版本升级。如果指定 b2b，将执行就地内部版本升级。

[-sidebyside]

如果指定此参数，SharePoint 产品和技术配置向导将执行逐步升级。

示例

psconfig.exe -cmd upgrade -inplace v2v -wait

psconfig.exe -cmd upgrade -sidebyside -reghostonupgrade

psconfig.exe -cmd upgrade -finalize


指定配置数据库设置

配置数据库用于存储服务器场的配置和网站映射信息。无论服务器场是一台安装了所有必需软件的计算机还是包含若干台计算机，都必须有一个用于服务器场的配置数据库。

数据库设置

您必须提供通过现有用户帐户与现有数据库服务器进行连接所需的设置。

数据库服务器

您必须键入运行 Microsoft SQL Server 2000 SP3 或更高版本或 SQL Server 2005 的计算机的名称。您可以键入将 SQL Server 作为服务器或服务器\实例运行的计算机的名称。

数据库名称

如果您要创建新配置数据库，可以键入要配置向导创建的数据库的名称，也可以键入已经预先建好的数据库的名称。如果使用现有数据库，该数据库不得包含任何表、存储过程或其他对象。

如果您要连接到现有配置数据库，可以单击“检索数据库名称”。这样将会返回运行 SQL Server 的计算机上存在的配置数据库，您可以选择相应的配置数据库。

数据库访问帐户

您必须输入将始终用于连接配置数据库的某个现有用户帐户的凭据。如果配置数据库位于另一台计算机上，您必须提供域帐户的凭据。

虽然在使用 SQL Server 安装程序进行的安装中您可以输入本地帐户或域帐户，但对于单服务器部署，只有本地帐户有效。建议您使用域帐户，从而保留通过向服务器场添加计算机来进行扩充的灵活性。

要在服务器场环境中部署 SharePoint 产品和技术，您将需要一个可指定为 Windows SharePoint Services 3.0 服务帐户的唯一域用户帐户。此帐户用于访问配置数据库。数据库访问帐户既用于初始数据库配置，也用于此场中服务器与数据库的当前连接。

要点 确保域所包含的组策略不会阻止被选作数据库访问帐户的帐户作为服务来运行。

此帐户还作为 SharePoint 管理中心应用程序池的应用程序池标识，它是 Windows SharePoint Services 定时服务在运行时所使用的帐户。“SharePoint 产品和技术配置向导”将此帐户添加到 SQL Server 登录、SQL Server Database Creator 服务器角色和 SQL Server Security Administrators 服务器角色。建议您遵循最小权限原则，不要使此用户帐户成为前端服务器或后端服务器上任何特定安全组的成员。

数据库访问帐户必须有以下权限：所有数据库的安全管理员、数据库创建者和数据库所有者 (DBO)。此帐户的权限必须在 SQL Server 中配置；配置向导不执行此配置。

您为数据库访问指定的帐户至少必须：

  • 能够读写配置数据库。
  • 在 SQL Server 中具有服务器范围的权限（安全管理员）。
  • 在创建和添加架构的过程中，该帐户必须有 DBO 权限。

另外，如果配置向导正在创建新配置数据库，数据库访问帐户必须有以下权限：

  • 创建数据库
  • 创建过程

任务

为创建配置数据库而执行的任务有：

  1. 验证 SQL Server 是否符合最低要求。
  2. 创建新数据库或连接到现有空白数据库。
  3. 向新配置数据库添加数据库架构。
  4. 将当前服务器添加到拓扑。
  5. 向配置数据库添加数据库帐户凭据。
  6. 将数据库连接字符串写入本地计算机上的注册表。

为断开与配置数据库的连接而执行的任务有：

  1. 删除配置数据库连接字符串。
  2. 停止本地计算机上运行的作业/任务计划 NT 服务。
  3. 从旧配置数据库中删除特定于计算机的数据。


高级设置

要通过使用 Active Directory 目录服务自动新建唯一用户帐户，您必须启用 Active Directory 帐户创建模式。

由于每个服务器场至少需要有一个管理中心 Web 应用程序，所以在服务器场中的第一台服务器中，会自动安装管理中心 Web 应用程序，而且，对于 Active Directory 域和 Active Directory 组织单位，只出现一组字段。当您在场中其他服务器上运行配置向导时，您会在此屏幕上看到用来创建管理中心 Web 应用程序的选项。

如果您想为管理中心创建负荷平衡 URL 或提供复制，可以创建多个管理中心网站。不过，这对于大多数安装都是不必要的。

启用 Active Directory 帐户创建模式
  1. 在“高级设置”页上，选择“启用 Active Directory 帐户创建模式”。
  2. 在“Active Directory 域”中，键入您的域名。
  3. 在“Active Directory 组织单位”中，键入您的 SharePoint 组织单位。
  4. 要返回“正在完成 SharePoint 产品和技术配置向导”页，请单击“确定”。

警告 如果您启用此选项，则可能无法从 Windows SharePoint Services 升级到其他基于 SharePoint 产品和技术的产品。如果您在这台计算机上安装基于 SharePoint 产品和技术的产品时遇到问题，请再次运行“SharePoint 产品和技术配置向导”，以清除此选项。


确认设置

使用“正在完成 SharePoint 产品和技术配置向导”页，以确认您输入的数据库和管理中心 Web 应用程序设置。

确认设置正确无误，然后单击“下一步”，以继续操作。

单击“高级设置”，以启用 Active Directory 帐户创建模式。有关详细信息，请参阅高级设置。


替换默认 SharePoint 网站

如果您要执行“基本”安装或“升级”，并且已经安装了现有的 SharePoint 产品或技术，则端口 80 上可能已经存在默认的 SharePoint 网站。

如果您确认不需要现有的默认 SharePoint 网站，则可禁用现有网站并在端口 80 上创建一个新网站，或者可以选择其他端口作为新网站的宿主。


如何验证 ASP.NET 版本

必须安装 ASP.NET 2.0 版。此版本随 Windows Server 2003 R2 及更高版本发布。如果您使用的是早于 R2 的 Windows Server 2003 的某个版本，则可能需要下载 ASP.NET 2.0 版。您可以通过以下方法来确定是否有 ASP.NET 的最新版本：

  1. 单击“开始”，单击“管理工具”，然后单击“Internet 信息服务(IIS)管理器”。
  2. 在“Internet 信息服务(IIS)管理器”窗口中，单击服务器名称旁边的加号 (+)。
  3. 单击“Web 服务扩展”。ASP.NET 2.0 版应该会在“Web 服务扩展”窗格中列出。如果 ASP.NET 2.0 版：
    1. 没有列出，您就必须安装它。
    2. 已经安装，但状态没有设置为“允许”，请将状态设置为“允许”。


如何验证 Windows Workflow Foundation 版本

您的计算机上必须安装 Windows Workflow Foundation 的最新版。如果您已经安装了 Windows Workflow Foundation，可以使用以下方法来验证所安装的版本。

  1. 单击“开始”，单击“控制面板”，然后单击“添加或删除程序”。
  2. 在“添加或删除程序”中，单击“Windows Workflow Foundation”，然后单击“单击此处获得支持信息”。
  3. 在“支持信息”对话框中，验证是否为 3.0.3807.7 版本或更高版本。
  4. 单击“关闭”，然后退出“添加或删除程序”。

如果没有安装 Windows Workflow Foundation，请下载最新版。要了解详细信息，或者，要下载 Windows Workflow Foundation，请转到 Windows Workflow Foundation 网站。